ArtOfTest.Common Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.Common Namespace
Send Feedback
Namespace for the common set of functions and API's that are used by all ArtOfTest products.

Classes

 | Class | Description
Public class | AddProjectReference | Indicates to the designer to add a reference to this assembly when generating a code behind file.
Public class | BaseTreeBuilder<(Of <(<'T>)>)> | This class builds the a strongly-typed markup elements tree.
Public class | CompareUtils | Class to provide the most commonly used comparison types the framework can incorporate into a test.
Public class | DateTimeFormatHelper |
Public class | DispatcherFactory | Provides common dispatchers.
Public class | FindClause | Represents an atomic search expression i.e foo=~bar
Public class | FindExpression<(Of <(<'T>)>)> | Holds the definition of a Find Expression.
Public class | FindSpecialChars | List of special characters that FindExpressions and FindParams recognize.
Public class | GenericEventArgs<(Of <(<'T>)>)> |
Public class | HierarchyConstraint | A Hierarchy constraint can be used to constraint the FindExpression match to a specific hierarchy setup.
Public class | Histogram |
Public class | MUI |
Public class | ParsedElement | Class that represents a markup element that is being parsed. This is the intermediate state between raw text of the mark-up and the fully parsed, strongly typed Element object that represents it
Public class | PixelMap |
Public class | TraceInfo | Tracing helper classed. All calls log directly to the System.Diagnostics.Trace
Public class | TraceInfo..::..TraceCategory | Predefined categories. By finding all references to an instance, you see all the trace sources. Example usage: TraceInfo.Dialogs.WriteLine("blah blah blah");
Public class | TreeCrawler<(Of <(<'T, V, R>)>)> | Crawls an element hierarchy tree.
Public class | Utils | Class to provide simple functions for the rest of the framework.
Public class | WaitAsync | Enables asynchronized waiting on custom conditions
Public class | WaitCompleteEventArgs | Wait complete event args.
Public class | WaitResult | Represents a wait result.
Public class | WaitSync | Waits Synchronously for a condition.

Interfaces

 | Interface | Description
Public interface | IAutomationHost | Implemented by automation hosts that contain ITargetElement.
Public interface | IAutomationHostState |
Public interface | IFindExpression | Interface implemented by all FindExpression.
Public interface | ISupportSearchHost | Implemented by hosts that support search
Public interface | ITargetElement | Represents a target element for a specific technology.
Public interface | ITestRegion | A test region interface definition.

Enumerations

 | Enumeration | Description
Public enumeration | ActionPointUnitType | The action point unit type.
Public enumeration | FindCompareType | The different types of string compares the framework supports.
Public enumeration | FindOperators | List of find operators used in FindExpressions
Public enumeration | NumberCompareType | Numerical compare type (Equals, less than..etc)
Public enumeration | NumberRangeCompareType | Numerical range compare type (InRange, outsiderange)
Public enumeration | OffsetReference | Offset references used to adjust the target point (X,Y) of an action.
Public enumeration | ParsedElementType | The type set by the parser when an element is parsed.
Public enumeration | StringCompareType | String compare type (Contains, exact ...etc.)
Public enumeration | TechnologyType | Technology type supported.
Public enumeration | WaitResultType | The different Wait results possible.
Public enumeration | XamlStringCompareType |

Send comments on this topic to Contact Us

Copyright (c) 2007 - 2012 - Telerik Corp


AddProjectReference Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AddProjectReference Members
AddProjectReference Class Constructors Methods Properties See Also Send Feedback

The AddProjectReference type exposes the following members.

Constructors

 | Name | Description
Public method | AddProjectReference | Initializes a new instance of the AddProjectReference class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

AddProjectReference Class
ArtOfTest.Common Namespace


AddProjectReference Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AddProjectReference Constructor
AddProjectReference Class See Also Send Feedback
Initializes a new instance of the AddProjectReference class

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AddProjectReference()
Visual Basic
Public Sub New
Visual C++
public:
AddProjectReference()

See Also

AddProjectReference Class
ArtOfTest.Common Namespace


AddProjectReference Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AddProjectReference Methods
AddProjectReference Class See Also Send Feedback

The AddProjectReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddProjectReference Class
ArtOfTest.Common Namespace


AddProjectReference Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AddProjectReference Properties
AddProjectReference Class See Also Send Feedback

The AddProjectReference type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

AddProjectReference Class
ArtOfTest.Common Namespace


BaseTreeBuilder(T) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)> Members
BaseTreeBuilder<(Of <(<'T>)>)> Class Methods Properties See Also Send Feedback

The BaseTreeBuilder<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | BuildDomTree | Parse and build the Dom. This method will initialize the Root property with the root element of the Dom.
Protected method | ClearTree |
Public method | CreateNewElement | Called by the builder when a new element of type T needs to be created.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | StartTagCloses | Determines whether to close an open tag with an optional closing tag based on the new tag we're parsing
Public method | TestRegionDetected | Called by the builder when a TestRegion is detected.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackRecursiveContainer |

Properties

 | Name | Description
Public property | DocType | Gets the DOCTYPE element if present in the document. Otherwise null.
Protected property | RecursiveContainerTags | Gets a list of tags for elements that can contain a host of the same type as the host containing the element.
Public property | Root | Gets the root Element node. You can access the tree using this node.

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


BaseTreeBuilder(T) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)> Methods
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseTreeBuilder<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | BuildDomTree | Parse and build the Dom. This method will initialize the Root property with the root element of the Dom.
Protected method | ClearTree |
Public method | CreateNewElement | Called by the builder when a new element of type T needs to be created.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | StartTagCloses | Determines whether to close an open tag with an optional closing tag based on the new tag we're parsing
Public method | TestRegionDetected | Called by the builder when a TestRegion is detected.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackRecursiveContainer |

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


BuildDomTree Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..BuildDomTree Method
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback
Parse and build the Dom. This method will initialize the Root property with the root element of the Dom.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T BuildDomTree(
    string text,
    bool trimWhiteSpace
)
Visual Basic
Public Function BuildDomTree ( _
    text As String, _
    trimWhiteSpace As Boolean _
) As T
Visual C++
public:
T BuildDomTree(
    String^ text,
    bool trimWhiteSpace
)

Parameters

text
Type: System..::..String
The text to build the tree for
trimWhiteSpace
Type: System..::..Boolean
Whether to trim the white spaces or not in the text between tags.

Return Value

The root document element.

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


ClearTree Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..ClearTree Method
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.BaseTreeBuilder`1.ClearTree"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void ClearTree()
Visual Basic
Protected Overridable Sub ClearTree
Visual C++
protected:
virtual void ClearTree()

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


CreateNewElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..CreateNewElement Method
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback
Called by the builder when a new element of type T needs to be created.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract T CreateNewElement(
    ParsedElement parsedElement,
    IAutomationHost host
)
Visual Basic
Public MustOverride Function CreateNewElement ( _
    parsedElement As ParsedElement, _
    host As IAutomationHost _
) As T
Visual C++
public:
virtual T CreateNewElement(
    ParsedElement^ parsedElement,
    IAutomationHost^ host
) abstract

Parameters

parsedElement
Type: ArtOfTest.Common..::..ParsedElement
The parsed element object.
host
Type: ArtOfTest.Common..::..IAutomationHost
The automation host object

Return Value

The elmenet of Type T

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


StartTagCloses Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..StartTagCloses Method
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback
Determines whether to close an open tag with an optional closing tag based on the new tag we're parsing

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual bool StartTagCloses(
    string startTag,
    string stackTag
)
Visual Basic
Protected Overridable Function StartTagCloses ( _
    startTag As String, _
    stackTag As String _
) As Boolean
Visual C++
protected:
virtual bool StartTagCloses(
    String^ startTag,
    String^ stackTag
)

Parameters

startTag
Type: System..::..String
The start tag we've just started parsing
stackTag
Type: System..::..String
The optional-closing tag on top of the stack

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.BaseTreeBuilder`1.StartTagCloses(System.String,System.String)"]

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


TestRegionDetected Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..TestRegionDetected Method
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback
Called by the builder when a TestRegion is detected.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract void TestRegionDetected(
    T regionElement
)
Visual Basic
Public MustOverride Sub TestRegionDetected ( _
    regionElement As T _
)
Visual C++
public:
virtual void TestRegionDetected(
    T regionElement
) abstract

Parameters

regionElement
Type: T
The test region element.

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


TrackRecursiveContainer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..TrackRecursiveContainer Method
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.BaseTreeBuilder`1.TrackRecursiveContainer(`0)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void TrackRecursiveContainer(
    T container
)
Visual Basic
Protected Overridable Sub TrackRecursiveContainer ( _
    container As T _
)
Visual C++
protected:
virtual void TrackRecursiveContainer(
    T container
)

Parameters

container
Type: T

[Missing <param name="container"/> documentation for "M:ArtOfTest.Common.BaseTreeBuilder`1.TrackRecursiveContainer(`0)"]

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


BaseTreeBuilder(T) Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)> Properties
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseTreeBuilder<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | DocType | Gets the DOCTYPE element if present in the document. Otherwise null.
Protected property | RecursiveContainerTags | Gets a list of tags for elements that can contain a host of the same type as the host containing the element.
Public property | Root | Gets the root Element node. You can access the tree using this node.

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


DocType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..DocType Property
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the DOCTYPE element if present in the document. Otherwise null.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T DocType { get; }
Visual Basic
Public ReadOnly Property DocType As T
    Get
Visual C++
public:
property T DocType {
    T get ();
}

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


RecursiveContainerTags Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..RecursiveContainerTags Property
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a list of tags for elements that can contain a host of the same type as the host containing the element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual IEnumerable<string> RecursiveContainerTags { get; }
Visual Basic
Protected Overridable ReadOnly Property RecursiveContainerTags As IEnumerable(Of String)
    Get
Visual C++
protected:
virtual property IEnumerable<String^>^ RecursiveContainerTags {
    IEnumerable<String^>^ get ();
}

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


Root Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTreeBuilder<(Of <(<'T>)>)>..::..Root Property
BaseTreeBuilder<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the root Element node. You can access the tree using this node.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T Root { get; }
Visual Basic
Public ReadOnly Property Root As T
    Get
Visual C++
public:
property T Root {
    T get ();
}

See Also

BaseTreeBuilder<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


CompareUtils Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils Members
CompareUtils Class Methods See Also Send Feedback

The CompareUtils type exposes the following members.

Methods

Name | Description
ImageCompare | Performs a compare of two images and returns whether they are the same within a specific tolerance.
ImageExactCompare | Validate whether two images are exactly the same.
NumberCompare(Double, Double, NumberCompareType) | Do numerical comparison
NumberCompare(Int32, Int32, NumberCompareType) | Do numerical comparison
NumberCompare(Double, Double, NumberCompareType, Double) | Do numerical comparison
NumberCompareRange | Do numerical range comparison.
StringCompare(String, String, FindCompareType) | Perform a string comparison
StringCompare(String, String, StringCompareType) | Perform a string comparison

See Also

CompareUtils Class
ArtOfTest.Common Namespace


CompareUtils Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils Methods
CompareUtils Class See Also Send Feedback

The CompareUtils type exposes the following members.

Methods

Name | Description
ImageCompare | Performs a compare of two images and returns whether they are the same within a specific tolerance.
ImageExactCompare | Validate whether two images are exactly the same.
NumberCompare(Double, Double, NumberCompareType) | Do numerical comparison
NumberCompare(Int32, Int32, NumberCompareType) | Do numerical comparison
NumberCompare(Double, Double, NumberCompareType, Double) | Do numerical comparison
NumberCompareRange | Do numerical range comparison.
StringCompare(String, String, FindCompareType) | Perform a string comparison
StringCompare(String, String, StringCompareType) | Perform a string comparison

See Also

CompareUtils Class
ArtOfTest.Common Namespace


ImageCompare Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..ImageCompare Method
CompareUtils Class See Also Send Feedback
Performs a compare of two images and returns whether they are the same within a specific tolerance.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool ImageCompare(
    Bitmap imageA,
    Bitmap imageB,
    Rectangle selectionArea,
    int tolerance
)
Visual Basic
Public Shared Function ImageCompare ( _
    imageA As Bitmap, _
    imageB As Bitmap, _
    selectionArea As Rectangle, _
    tolerance As Integer _
) As Boolean
Visual C++
public:
static bool ImageCompare(
    Bitmap^ imageA,
    Bitmap^ imageB,
    Rectangle selectionArea,
    int tolerance
)

Parameters

imageA
Type: System.Drawing..::..Bitmap
The first image to compare
imageB
Type: System.Drawing..::..Bitmap
The second image to compare
selectionArea
Type: System.Drawing..::..Rectangle
An area within the image to compare. Pass in Rectangle.Empty if you want to compare the entire image
tolerance
Type: System..::..Int32
The % tolerance of difference between the two images.

Return Value

Returns true/false on whether the images match or not.

See Also

CompareUtils Class
ArtOfTest.Common Namespace


ImageExactCompare Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..ImageExactCompare Method
CompareUtils Class See Also Send Feedback
Validate whether two images are exactly the same.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool ImageExactCompare(
    Bitmap imageA,
    Bitmap imageB
)
Visual Basic
Public Shared Function ImageExactCompare ( _
    imageA As Bitmap, _
    imageB As Bitmap _
) As Boolean
Visual C++
public:
static bool ImageExactCompare(
    Bitmap^ imageA,
    Bitmap^ imageB
)

Parameters

imageA
Type: System.Drawing..::..Bitmap
The first image to compare
imageB
Type: System.Drawing..::..Bitmap
The second image to compare

Return Value

Whether the images match

See Also

CompareUtils Class
ArtOfTest.Common Namespace


NumberCompare Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..NumberCompare Method
CompareUtils Class See Also Send Feedback

Overload List

Name | Description
NumberCompare(Double, Double, NumberCompareType) | Do numerical comparison
NumberCompare(Int32, Int32, NumberCompareType) | Do numerical comparison
NumberCompare(Double, Double, NumberCompareType, Double) | Do numerical comparison

See Also

CompareUtils Class
CompareUtils Members
ArtOfTest.Common Namespace


NumberCompare Method (Double, Double, NumberCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..NumberCompare Method (Double, Double, NumberCompareType)
CompareUtils Class See Also Send Feedback
Do numerical comparison

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool NumberCompare(
    double leftPortion,
    double rightPortion,
    NumberCompareType compareType
)
Visual Basic
Public Shared Function NumberCompare ( _
    leftPortion As Double, _
    rightPortion As Double, _
    compareType As NumberCompareType _
) As Boolean
Visual C++
public:
static bool NumberCompare(
    double leftPortion,
    double rightPortion,
    NumberCompareType compareType
)

Parameters

leftPortion
Type: System..::..Double
Left side
rightPortion
Type: System..::..Double
Right side
compareType
Type: ArtOfTest.Common..::..NumberCompareType
The compare type.

Return Value

True/False whether the compare passed

See Also

CompareUtils Class
NumberCompare Overload
ArtOfTest.Common Namespace


NumberCompare Method (Int32, Int32, NumberCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..NumberCompare Method (Int32, Int32, NumberCompareType)
CompareUtils Class See Also Send Feedback
Do numerical comparison

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool NumberCompare(
    int leftPortion,
    int rightPortion,
    NumberCompareType compareType
)
Visual Basic
Public Shared Function NumberCompare ( _
    leftPortion As Integer, _
    rightPortion As Integer, _
    compareType As NumberCompareType _
) As Boolean
Visual C++
public:
static bool NumberCompare(
    int leftPortion,
    int rightPortion,
    NumberCompareType compareType
)

Parameters

leftPortion
Type: System..::..Int32
Left side
rightPortion
Type: System..::..Int32
Right side
compareType
Type: ArtOfTest.Common..::..NumberCompareType
The compare type.

Return Value

True/False whether the compare passed

See Also

CompareUtils Class
NumberCompare Overload
ArtOfTest.Common Namespace


NumberCompare Method (Double, Double, NumberCompareType, Double)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..NumberCompare Method (Double, Double, NumberCompareType, Double)
CompareUtils Class See Also Send Feedback
Do numerical comparison

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool NumberCompare(
    double leftPortion,
    double rightPortion,
    NumberCompareType compareType,
    double delta
)
Visual Basic
Public Shared Function NumberCompare ( _
    leftPortion As Double, _
    rightPortion As Double, _
    compareType As NumberCompareType, _
    delta As Double _
) As Boolean
Visual C++
public:
static bool NumberCompare(
    double leftPortion,
    double rightPortion,
    NumberCompareType compareType,
    double delta
)

Parameters

leftPortion
Type: System..::..Double
Left side
rightPortion
Type: System..::..Double
Right side
compareType
Type: ArtOfTest.Common..::..NumberCompareType
The compare type.
delta
Type: System..::..Double
How close the value must be to be accepted as a match.

Return Value

True/False whether the compare passed

See Also

CompareUtils Class
NumberCompare Overload
ArtOfTest.Common Namespace


NumberCompareRange Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..NumberCompareRange Method
CompareUtils Class See Also Send Feedback
Do numerical range comparison.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool NumberCompareRange(
    int number,
    int lowerEnd,
    int upperEnd,
    NumberRangeCompareType compareType
)
Visual Basic
Public Shared Function NumberCompareRange ( _
    number As Integer, _
    lowerEnd As Integer, _
    upperEnd As Integer, _
    compareType As NumberRangeCompareType _
) As Boolean
Visual C++
public:
static bool NumberCompareRange(
    int number,
    int lowerEnd,
    int upperEnd,
    NumberRangeCompareType compareType
)

Parameters

number
Type: System..::..Int32
The number to compare.
lowerEnd
Type: System..::..Int32
The lower end of the range.
upperEnd
Type: System..::..Int32
The upper end of the range.
compareType
Type: ArtOfTest.Common..::..NumberRangeCompareType
The compare type.

Return Value

True/False whether the comparison passed.

See Also

CompareUtils Class
ArtOfTest.Common Namespace


StringCompare Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..StringCompare Method
CompareUtils Class See Also Send Feedback

Overload List

Name | Description
StringCompare(String, String, FindCompareType) | Perform a string comparison
StringCompare(String, String, StringCompareType) | Perform a string comparison

See Also

CompareUtils Class
CompareUtils Members
ArtOfTest.Common Namespace


StringCompare Method (String, String, FindCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..StringCompare Method (String, String, FindCompareType)
CompareUtils Class See Also Send Feedback
Perform a string comparison

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool StringCompare(
    string a,
    string b,
    FindCompareType compareType
)
Visual Basic
Public Shared Function StringCompare ( _
    a As String, _
    b As String, _
    compareType As FindCompareType _
) As Boolean
Visual C++
public:
static bool StringCompare(
    String^ a,
    String^ b,
    FindCompareType compareType
)

Parameters

a
Type: System..::..String
The first string.
b
Type: System..::..String
The string to compare to.
compareType
Type: ArtOfTest.Common..::..FindCompareType
The comparison type.

Return Value

True/False whether the comparison passed

See Also

CompareUtils Class
StringCompare Overload
ArtOfTest.Common Namespace


StringCompare Method (String, String, StringCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompareUtils..::..StringCompare Method (String, String, StringCompareType)
CompareUtils Class See Also Send Feedback
Perform a string comparison

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool StringCompare(
    string a,
    string b,
    StringCompareType compareType
)
Visual Basic
Public Shared Function StringCompare ( _
    a As String, _
    b As String, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
static bool StringCompare(
    String^ a,
    String^ b,
    StringCompareType compareType
)

Parameters

a
Type: System..::..String
The first string.
b
Type: System..::..String
The string to compare to.
compareType
Type: ArtOfTest.Common..::..StringCompareType
The comparison type.

Return Value

True/False whether the comparison passed

See Also

CompareUtils Class
StringCompare Overload
ArtOfTest.Common Namespace


DateTimeFormatHelper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DateTimeFormatHelper Members
DateTimeFormatHelper Class Methods See Also Send Feedback

The DateTimeFormatHelper type exposes the following members.

Methods

Name | Description
AbbrMonthToInt |
IntToAbbrMonthName |
IntToMonthName |

See Also

DateTimeFormatHelper Class
ArtOfTest.Common Namespace


DateTimeFormatHelper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DateTimeFormatHelper Methods
DateTimeFormatHelper Class See Also Send Feedback

The DateTimeFormatHelper type exposes the following members.

Methods

Name | Description
AbbrMonthToInt |
IntToAbbrMonthName |
IntToMonthName |

See Also

DateTimeFormatHelper Class
ArtOfTest.Common Namespace


AbbrMonthToInt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DateTimeFormatHelper..::..AbbrMonthToInt Method
DateTimeFormatHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.AbbrMonthToInt(System.String)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int AbbrMonthToInt(
    string month
)
Visual Basic
Public Shared Function AbbrMonthToInt ( _
    month As String _
) As Integer
Visual C++
public:
static int AbbrMonthToInt(
    String^ month
)

Parameters

month
Type: System..::..String

[Missing <param name="month"/> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.AbbrMonthToInt(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.AbbrMonthToInt(System.String)"]

See Also

DateTimeFormatHelper Class
ArtOfTest.Common Namespace


IntToAbbrMonthName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DateTimeFormatHelper..::..IntToAbbrMonthName Method
DateTimeFormatHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.IntToAbbrMonthName(System.Int32)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string IntToAbbrMonthName(
    int month
)
Visual Basic
Public Shared Function IntToAbbrMonthName ( _
    month As Integer _
) As String
Visual C++
public:
static String^ IntToAbbrMonthName(
    int month
)

Parameters

month
Type: System..::..Int32

[Missing <param name="month"/> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.IntToAbbrMonthName(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.IntToAbbrMonthName(System.Int32)"]

See Also

DateTimeFormatHelper Class
ArtOfTest.Common Namespace


IntToMonthName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DateTimeFormatHelper..::..IntToMonthName Method
DateTimeFormatHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.IntToMonthName(System.Int32)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string IntToMonthName(
    int month
)
Visual Basic
Public Shared Function IntToMonthName ( _
    month As Integer _
) As String
Visual C++
public:
static String^ IntToMonthName(
    int month
)

Parameters

month
Type: System..::..Int32

[Missing <param name="month"/> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.IntToMonthName(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.DateTimeFormatHelper.IntToMonthName(System.Int32)"]

See Also

DateTimeFormatHelper Class
ArtOfTest.Common Namespace


DispatcherFactory Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DispatcherFactory Members
DispatcherFactory Class Methods See Also Send Feedback

The DispatcherFactory type exposes the following members.

Methods

Name | Description
CreateDispatcher |

See Also

DispatcherFactory Class
ArtOfTest.Common Namespace


DispatcherFactory Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DispatcherFactory Methods
DispatcherFactory Class See Also Send Feedback

The DispatcherFactory type exposes the following members.

Methods

Name | Description
CreateDispatcher |

See Also

DispatcherFactory Class
ArtOfTest.Common Namespace


CreateDispatcher Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DispatcherFactory..::..CreateDispatcher Method
DispatcherFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.DispatcherFactory.CreateDispatcher"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Dispatcher CreateDispatcher()
Visual Basic
Public Shared Function CreateDispatcher As Dispatcher
Visual C++
public:
static Dispatcher^ CreateDispatcher()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.DispatcherFactory.CreateDispatcher"]

See Also

DispatcherFactory Class
ArtOfTest.Common Namespace


FindClause Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause Members
FindClause Class Constructors Methods Properties See Also Send Feedback

The FindClause type exposes the following members.

Constructors

 | Name | Description
Public method | FindClause()()()() | Create a new Search expression.
Public method | FindClause(String) | Create a new FindClause.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractValue | Given a specific search term, get the actual value from the passed in target element.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSpecialCharForCompareType | Does a reverse look up and returns the special character for a certain compare type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match(ITargetElement) | Match this expression.
Public method | Match(ITargetElement, ITargetElement) | Match this expression starting at a specific element
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnParsed | Called once the expression is parsed. Extenders can override this method to allow for post processing after parsing.
Public method | ToString | Return the string representation of this expression. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Clause | Gets or sets the search expression. On setting the value, the expression will be parsed.
Public property | CompareType | Gets the expression compare type.
Public property | IsHierarchical | Gets whether this search clause is relative to the root of the search.
Public property | Name | Gets the name part of the expression.
Public property | Priority | Gets the search priority of this clause. 0 is the highest. 10 lowest.
Public property | Value | Gets the value part of the expression.

See Also

FindClause Class
ArtOfTest.Common Namespace


FindClause Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause Constructor
FindClause Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindClause()()()() | Create a new Search expression.
Public method | FindClause(String) | Create a new FindClause.

See Also

FindClause Class
FindClause Members
ArtOfTest.Common Namespace


FindClause Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause Constructor
FindClause Class See Also Send Feedback
Create a new Search expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindClause()
Visual Basic
Public Sub New
Visual C++
public:
FindClause()

See Also

FindClause Class
FindClause Overload
ArtOfTest.Common Namespace


FindClause Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause Constructor (String)
FindClause Class See Also Send Feedback
Create a new FindClause.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindClause(
    string clause
)
Visual Basic
Public Sub New ( _
    clause As String _
)
Visual C++
public:
FindClause(
    String^ clause
)

Parameters

clause
Type: System..::..String
A clause expression. (i.e. foo=bar)

See Also

FindClause Class
FindClause Overload
ArtOfTest.Common Namespace


FindClause Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause Methods
FindClause Class See Also Send Feedback

The FindClause type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractValue | Given a specific search term, get the actual value from the passed in target element.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSpecialCharForCompareType | Does a reverse look up and returns the special character for a certain compare type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match(ITargetElement) | Match this expression.
Public method | Match(ITargetElement, ITargetElement) | Match this expression starting at a specific element
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnParsed | Called once the expression is parsed. Extenders can override this method to allow for post processing after parsing.
Public method | ToString | Return the string representation of this expression. (Overrides Object..::..ToString()()()().)

See Also

FindClause Class
ArtOfTest.Common Namespace


ExtractValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..ExtractValue Method
FindClause Class See Also Send Feedback
Given a specific search term, get the actual value from the passed in target element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract string ExtractValue(
    string searchType,
    ITargetElement element
)
Visual Basic
Public MustOverride Function ExtractValue ( _
    searchType As String, _
    element As ITargetElement _
) As String
Visual C++
public:
virtual String^ ExtractValue(
    String^ searchType,
    ITargetElement^ element
) abstract

Parameters

searchType
Type: System..::..String
Search type as a string. (i.e. TagName/TextContent..etc)
element
Type: ArtOfTest.Common..::..ITargetElement
The target element to use.

Return Value

The actual value of that search term.

See Also

FindClause Class
ArtOfTest.Common Namespace


GetSpecialCharForCompareType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..GetSpecialCharForCompareType Method
FindClause Class See Also Send Feedback
Does a reverse look up and returns the special character for a certain compare type.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static char GetSpecialCharForCompareType(
    FindCompareType compareType
)
Visual Basic
Public Shared Function GetSpecialCharForCompareType ( _
    compareType As FindCompareType _
) As Char
Visual C++
public:
static wchar_t GetSpecialCharForCompareType(
    FindCompareType compareType
)

Parameters

compareType
Type: ArtOfTest.Common..::..FindCompareType
The compare type to lookup.

Return Value

The special compare type.

See Also

FindClause Class
ArtOfTest.Common Namespace


Match Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..Match Method
FindClause Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Match(ITargetElement) | Match this expression.
Public method | Match(ITargetElement, ITargetElement) | Match this expression starting at a specific element

See Also

FindClause Class
FindClause Members
ArtOfTest.Common Namespace


Match Method (ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..Match Method (ITargetElement)
FindClause Class See Also Send Feedback
Match this expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract bool Match(
    ITargetElement element
)
Visual Basic
Public MustOverride Function Match ( _
    element As ITargetElement _
) As Boolean
Visual C++
public:
virtual bool Match(
    ITargetElement^ element
) abstract

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement
The element to match

Return Value

True/False whether the clause matches this element.

See Also

FindClause Class
Match Overload
ArtOfTest.Common Namespace


Match Method (ITargetElement, ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..Match Method (ITargetElement, ITargetElement)
FindClause Class See Also Send Feedback
Match this expression starting at a specific element

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract bool Match(
    ITargetElement element,
    ITargetElement startElement
)
Visual Basic
Public MustOverride Function Match ( _
    element As ITargetElement, _
    startElement As ITargetElement _
) As Boolean
Visual C++
public:
virtual bool Match(
    ITargetElement^ element,
    ITargetElement^ startElement
) abstract

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.Common.FindClause.Match(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

startElement
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="startElement"/> documentation for "M:ArtOfTest.Common.FindClause.Match(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.FindClause.Match(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

See Also

FindClause Class
Match Overload
ArtOfTest.Common Namespace


OnParsed Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..OnParsed Method
FindClause Class See Also Send Feedback
Called once the expression is parsed. Extenders can override this method to allow for post processing after parsing.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract void OnParsed()
Visual Basic
Public MustOverride Sub OnParsed
Visual C++
public:
virtual void OnParsed() abstract

See Also

FindClause Class
ArtOfTest.Common Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..ToString Method
FindClause Class See Also Send Feedback
Return the string representation of this expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of this expression.

See Also

FindClause Class
ArtOfTest.Common Namespace


FindClause Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause Properties
FindClause Class See Also Send Feedback

The FindClause type exposes the following members.

Properties

 | Name | Description
Public property | Clause | Gets or sets the search expression. On setting the value, the expression will be parsed.
Public property | CompareType | Gets the expression compare type.
Public property | IsHierarchical | Gets whether this search clause is relative to the root of the search.
Public property | Name | Gets the name part of the expression.
Public property | Priority | Gets the search priority of this clause. 0 is the highest. 10 lowest.
Public property | Value | Gets the value part of the expression.

See Also

FindClause Class
ArtOfTest.Common Namespace


Clause Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..Clause Property
FindClause Class See Also Send Feedback
Gets or sets the search expression. On setting the value, the expression will be parsed.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Clause { get; set; }
Visual Basic
Public Property Clause As String
    Get
    Set
Visual C++
public:
property String^ Clause {
    String^ get ();
    void set (String^ value);
}

See Also

FindClause Class
ArtOfTest.Common Namespace


CompareType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..CompareType Property
FindClause Class See Also Send Feedback
Gets the expression compare type.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindCompareType CompareType { get; }
Visual Basic
Public ReadOnly Property CompareType As FindCompareType
    Get
Visual C++
public:
property FindCompareType CompareType {
    FindCompareType get ();
}

See Also

FindClause Class
ArtOfTest.Common Namespace


IsHierarchical Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..IsHierarchical Property
FindClause Class See Also Send Feedback
Gets whether this search clause is relative to the root of the search.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsHierarchical { get; set; }
Visual Basic
Public Property IsHierarchical As Boolean
    Get
    Set
Visual C++
public:
property bool IsHierarchical {
    bool get ();
    void set (bool value);
}

Remarks

FindExpression implementations set this. Does not need to be serialized.

See Also

FindClause Class
ArtOfTest.Common Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..Name Property
FindClause Class See Also Send Feedback
Gets the name part of the expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FindClause Class
ArtOfTest.Common Namespace


Priority Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..Priority Property
FindClause Class See Also Send Feedback
Gets the search priority of this clause. 0 is the highest. 10 lowest.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Priority { get; set; }
Visual Basic
Public Property Priority As Integer
    Get
    Set
Visual C++
public:
property int Priority {
    int get ();
    void set (int value);
}

Remarks

FindExpression implementations set this. Does not need to be serialized.

See Also

FindClause Class
ArtOfTest.Common Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindClause..::..Value Property
FindClause Class See Also Send Feedback
Gets the value part of the expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

FindClause Class
ArtOfTest.Common Namespace


FindExpression(T) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)> Members
FindExpression<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The FindExpression<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | FindExpression<(Of <(<'T>)>)>()()()() | Create an empty expression.
Public method | FindExpression<(Of <(<'T>)>)>(array<String>[]()[][]) | Create a new FindExpression.

Methods

 | Name | Description
Public method | AddClause | Add the clause to the collection.
Public method | AddHierarchyConstraint | Add a hierarchy constraint.
Public method | AppendChain | Append the passed in expression as a chain to the end of the expression.
Public method | AppendClauses | Append a set of clauses
Public method | CheckConstraints | Check the constraints of this target.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClauses | Get the list of clauses
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize this expression with a set of clauses.
Public method | Match(ITargetElement) | Match this expression against a target.
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of this FindExpression. (Overrides Object..::..ToString()()()().)
Public method | Update | Update this expression with the new expression

Properties

 | Name | Description
Public property | ChainStops | Gets the list of chain locations in the clauses.
Public property | Clauses | Gets the expression clauses
Public property | Constraints | Get any hierarchy constraints.
Public property | FindClauses | Gets or sets the find statement.
Public property | HasConstraints | Gets whether this expression have hierarchy constraints
Public property | HasHierarchicalDependency | Gets whether this expression has any hierarchal dependencies.
Public property | IsChained | Gets whether the search is chained.
Public property | StringRepresentation | Get the string representation of this expression.
Public property | SupportedSearchType | Gets the supported search type as a Type object.

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


FindExpression(T) Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)> Constructor
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindExpression<(Of <(<'T>)>)>()()()() | Create an empty expression.
Public method | FindExpression<(Of <(<'T>)>)>(array<String>[]()[][]) | Create a new FindExpression.

See Also

FindExpression<(Of <(<'T>)>)> Class
FindExpression<(Of <(<'T>)>)> Members
ArtOfTest.Common Namespace


FindExpression(T) Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)> Constructor
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Create an empty expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindExpression()
Visual Basic
Public Sub New
Visual C++
public:
FindExpression()

See Also

FindExpression<(Of <(<'T>)>)> Class
FindExpression<(Of <(<'T>)>)> Overload
ArtOfTest.Common Namespace


FindExpression(T) Constructor (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)> Constructor (array<String>[]()[][])
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new FindExpression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindExpression(
    params string[] findClauses
)
Visual Basic
Public Sub New ( _
    ParamArray findClauses As String() _
)
Visual C++
public:
FindExpression(
    ... array<String^>^ findClauses
)

Parameters

findClauses
Type: array< System..::..String >[]()[][]
A string array of find clauses.

See Also

FindExpression<(Of <(<'T>)>)> Class
FindExpression<(Of <(<'T>)>)> Overload
ArtOfTest.Common Namespace


FindExpression(T) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)> Methods
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback

The FindExpression<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddClause | Add the clause to the collection.
Public method | AddHierarchyConstraint | Add a hierarchy constraint.
Public method | AppendChain | Append the passed in expression as a chain to the end of the expression.
Public method | AppendClauses | Append a set of clauses
Public method | CheckConstraints | Check the constraints of this target.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClauses | Get the list of clauses
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize this expression with a set of clauses.
Public method | Match(ITargetElement) | Match this expression against a target.
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of this FindExpression. (Overrides Object..::..ToString()()()().)
Public method | Update | Update this expression with the new expression

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


AddClause Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..AddClause Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Add the clause to the collection.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract void AddClause(
    string clause
)
Visual Basic
Public MustOverride Sub AddClause ( _
    clause As String _
)
Visual C++
public:
virtual void AddClause(
    String^ clause
) abstract

Parameters

clause
Type: System..::..String
The clause to add.

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


AddHierarchyConstraint Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..AddHierarchyConstraint Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Add a hierarchy constraint.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void AddHierarchyConstraint(
    HierarchyConstraint constraint
)
Visual Basic
Public Overridable Sub AddHierarchyConstraint ( _
    constraint As HierarchyConstraint _
)
Visual C++
public:
virtual void AddHierarchyConstraint(
    HierarchyConstraint^ constraint
)

Parameters

constraint
Type: ArtOfTest.Common..::..HierarchyConstraint
The constraint to add

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


AppendChain Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..AppendChain Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Append the passed in expression as a chain to the end of the expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendChain(
    IFindExpression expression
)
Visual Basic
Public Sub AppendChain ( _
    expression As IFindExpression _
)
Visual C++
public:
virtual void AppendChain(
    IFindExpression^ expression
) sealed

Parameters

expression
Type: ArtOfTest.Common..::..IFindExpression
The expression to append.

Implements

IFindExpression..::..AppendChain(IFindExpression)

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


AppendClauses Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..AppendClauses Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Append a set of clauses

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendClauses(
    bool asChain,
    params string[] clausesToAppend
)
Visual Basic
Public Sub AppendClauses ( _
    asChain As Boolean, _
    ParamArray clausesToAppend As String() _
)
Visual C++
public:
virtual void AppendClauses(
    bool asChain,
    ... array<String^>^ clausesToAppend
) sealed

Parameters

asChain
Type: System..::..Boolean
Whether to append as a chain or simply to the end of the expression
clausesToAppend
Type: array< System..::..String >[]()[][]
The clauses to append.

Implements

IFindExpression..::..AppendClauses(Boolean, array<String>[]()[][])

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


CheckConstraints Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..CheckConstraints Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Check the constraints of this target.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool CheckConstraints(
    ITargetElement target
)
Visual Basic
Public Overridable Function CheckConstraints ( _
    target As ITargetElement _
) As Boolean
Visual C++
public:
virtual bool CheckConstraints(
    ITargetElement^ target
)

Parameters

target
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="target"/> documentation for "M:ArtOfTest.Common.FindExpression`1.CheckConstraints(ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.FindExpression`1.CheckConstraints(ArtOfTest.Common.ITargetElement)"]

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


GetClauses Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..GetClauses Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Get the list of clauses

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FindClause> GetClauses(
    int chainIndex
)
Visual Basic
Public Function GetClauses ( _
    chainIndex As Integer _
) As IList(Of FindClause)
Visual C++
public:
virtual IList<FindClause^>^ GetClauses(
    int chainIndex
) sealed

Parameters

chainIndex
Type: System..::..Int32

[Missing <param name="chainIndex"/> documentation for "M:ArtOfTest.Common.FindExpression`1.GetClauses(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.FindExpression`1.GetClauses(System.Int32)"]

Implements

IFindExpression..::..GetClauses(Int32)

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


Initialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..Initialize Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Initialize this expression with a set of clauses.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Initialize(
    string[] clauses
)
Visual Basic
Public Overridable Sub Initialize ( _
    clauses As String() _
)
Visual C++
public:
virtual void Initialize(
    array<String^>^ clauses
)

Parameters

clauses
Type: array< System..::..String >[]()[][]
The clauses to use.

Implements

IFindExpression..::..Initialize(array<String>[]()[][])

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


Match Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..Match Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Match(ITargetElement) | Match this expression against a target.
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target.

See Also

FindExpression<(Of <(<'T>)>)> Class
FindExpression<(Of <(<'T>)>)> Members
ArtOfTest.Common Namespace


Match Method (ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..Match Method (ITargetElement)
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Match this expression against a target.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool Match(
    ITargetElement target
)
Visual Basic
Public Overridable Function Match ( _
    target As ITargetElement _
) As Boolean
Visual C++
public:
virtual bool Match(
    ITargetElement^ target
)

Parameters

target
Type: ArtOfTest.Common..::..ITargetElement
The target to match

Return Value

True/False is this target matches

Implements

IFindExpression..::..Match(ITargetElement)

Remarks

This call with throw an ArgumentException if the expression has a hierarchical dependency.

See Also

FindExpression<(Of <(<'T>)>)> Class
Match Overload
ArtOfTest.Common Namespace


Match Method (ITargetElement, IList(FindClause), Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..Match Method (ITargetElement, IList<(Of <(<'FindClause>)>)>, Boolean)
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Match a set of clauses against a target.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Match(
    ITargetElement target,
    IList<FindClause> clauses,
    bool ignoreConstraints
)
Visual Basic
Public Function Match ( _
    target As ITargetElement, _
    clauses As IList(Of FindClause), _
    ignoreConstraints As Boolean _
) As Boolean
Visual C++
public:
virtual bool Match(
    ITargetElement^ target,
    IList<FindClause^>^ clauses,
    bool ignoreConstraints
) sealed

Parameters

target
Type: ArtOfTest.Common..::..ITargetElement
The target element to match.
clauses
Type: System.Collections.Generic..::..IList <(Of <(<' FindClause >)>)>
The list of clauses to use during the match test.
ignoreConstraints
Type: System..::..Boolean
Whether or not to ignore any contraints contained in the clauses.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.FindExpression`1.Match(ArtOfTest.Common.ITargetElement,System.Collections.Generic.IList{ArtOfTest.Common.FindClause},System.Boolean)"]

Implements

IFindExpression..::..Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean)

See Also

FindExpression<(Of <(<'T>)>)> Class
Match Overload
ArtOfTest.Common Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..ToString Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Returns the string representation of this FindExpression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string.

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


Update Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..Update Method
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Update this expression with the new expression

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Update(
    string[] expression
)
Visual Basic
Public Sub Update ( _
    expression As String() _
)
Visual C++
public:
virtual void Update(
    array<String^>^ expression
) sealed

Parameters

expression
Type: array< System..::..String >[]()[][]

[Missing <param name="expression"/> documentation for "M:ArtOfTest.Common.FindExpression`1.Update(System.String[])"]

Implements

IFindExpression..::..Update(array<String>[]()[][])

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


FindExpression(T) Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)> Properties
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback

The FindExpression<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | ChainStops | Gets the list of chain locations in the clauses.
Public property | Clauses | Gets the expression clauses
Public property | Constraints | Get any hierarchy constraints.
Public property | FindClauses | Gets or sets the find statement.
Public property | HasConstraints | Gets whether this expression have hierarchy constraints
Public property | HasHierarchicalDependency | Gets whether this expression has any hierarchal dependencies.
Public property | IsChained | Gets whether the search is chained.
Public property | StringRepresentation | Get the string representation of this expression.
Public property | SupportedSearchType | Gets the supported search type as a Type object.

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


ChainStops Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..ChainStops Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the list of chain locations in the clauses.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<int> ChainStops { get; private set; }
Visual Basic
Public Property ChainStops As IList(Of Integer)
    Get
    Private Set
Visual C++
public:
virtual property IList<int>^ ChainStops {
    IList<int>^ get () sealed;
    private: void set (IList<int>^ value) sealed;
}

Implements

IFindExpression..::..ChainStops

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


Clauses Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..Clauses Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the expression clauses

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string[] Clauses { get; }
Visual Basic
Public ReadOnly Property Clauses As String()
    Get
Visual C++
public:
virtual property array<String^>^ Clauses {
    array<String^>^ get () sealed;
}

Implements

IFindExpression..::..Clauses

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


Constraints Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..Constraints Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Get any hierarchy constraints.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HierarchyConstraint> Constraints { get; private set; }
Visual Basic
Public Property Constraints As IList(Of HierarchyConstraint)
    Get
    Private Set
Visual C++
public:
virtual property IList<HierarchyConstraint^>^ Constraints {
    IList<HierarchyConstraint^>^ get () sealed;
    private: void set (IList<HierarchyConstraint^>^ value) sealed;
}

Implements

IFindExpression..::..Constraints

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


FindClauses Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..FindClauses Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the find statement.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<T> FindClauses { get; private set; }
Visual Basic
Public Property FindClauses As IList(Of T)
    Get
    Private Set
Visual C++
public:
property IList<T>^ FindClauses {
    IList<T>^ get ();
    private: void set (IList<T>^ value);
}

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


HasConstraints Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..HasConstraints Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether this expression have hierarchy constraints

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasConstraints { get; }
Visual Basic
Public ReadOnly Property HasConstraints As Boolean
    Get
Visual C++
public:
property bool HasConstraints {
    bool get ();
}

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


HasHierarchicalDependency Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..HasHierarchicalDependency Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether this expression has any hierarchal dependencies.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasHierarchicalDependency { get; }
Visual Basic
Public ReadOnly Property HasHierarchicalDependency As Boolean
    Get
Visual C++
public:
virtual property bool HasHierarchicalDependency {
    bool get () sealed;
}

Implements

IFindExpression..::..HasHierarchicalDependency

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


IsChained Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..IsChained Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Gets whether the search is chained.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsChained { get; }
Visual Basic
Public ReadOnly Property IsChained As Boolean
    Get
Visual C++
public:
virtual property bool IsChained {
    bool get () sealed;
}

Implements

IFindExpression..::..IsChained

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


StringRepresentation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..StringRepresentation Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Get the string representation of this expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string StringRepresentation { get; }
Visual Basic
Public ReadOnly Property StringRepresentation As String
    Get
Visual C++
public:
virtual property String^ StringRepresentation {
    String^ get () sealed;
}

Implements

IFindExpression..::..StringRepresentation

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


SupportedSearchType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpression<(Of <(<'T>)>)>..::..SupportedSearchType Property
FindExpression<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the supported search type as a Type object.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract Type SupportedSearchType { get; }
Visual Basic
Public MustOverride ReadOnly Property SupportedSearchType As Type
    Get
Visual C++
public:
virtual property Type^ SupportedSearchType {
    Type^ get () abstract;
}

Implements

IFindExpression..::..SupportedSearchType

See Also

FindExpression<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


FindSpecialChars Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars Members
FindSpecialChars Class Fields See Also Send Feedback

The FindSpecialChars type exposes the following members.

Fields

Name | Description
Contains | ~ = Contains
EndsWith | ? = Ends with
Equal | = = Equals
Escape | ' = escape the following character and treat it as a regular character
Exists | + = exists
ExpPathSeparator | / = expression path separator
Missing | - = missing
NotContain | ! = NotContains
Pipe | | = chain two expressions together
RegEx | # = this is a regex
StartsWith | ^ = Starts with

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


FindSpecialChars Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars Fields
FindSpecialChars Class See Also Send Feedback

The FindSpecialChars type exposes the following members.

Fields

Name | Description
Contains | ~ = Contains
EndsWith | ? = Ends with
Equal | = = Equals
Escape | ' = escape the following character and treat it as a regular character
Exists | + = exists
ExpPathSeparator | / = expression path separator
Missing | - = missing
NotContain | ! = NotContains
Pipe | | = chain two expressions together
RegEx | # = this is a regex
StartsWith | ^ = Starts with

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


Contains Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..Contains Field
FindSpecialChars Class See Also Send Feedback
~ = Contains

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char Contains
Visual Basic
Public Const Contains As Char
Visual C++
public:
literal wchar_t Contains

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


EndsWith Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..EndsWith Field
FindSpecialChars Class See Also Send Feedback
? = Ends with

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char EndsWith
Visual Basic
Public Const EndsWith As Char
Visual C++
public:
literal wchar_t EndsWith

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


Equal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..Equal Field
FindSpecialChars Class See Also Send Feedback
= = Equals

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char Equal
Visual Basic
Public Const Equal As Char
Visual C++
public:
literal wchar_t Equal

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


Escape Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..Escape Field
FindSpecialChars Class See Also Send Feedback
' = escape the following character and treat it as a regular character

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char Escape
Visual Basic
Public Const Escape As Char
Visual C++
public:
literal wchar_t Escape

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


Exists Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..Exists Field
FindSpecialChars Class See Also Send Feedback
+ = exists

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char Exists
Visual Basic
Public Const Exists As Char
Visual C++
public:
literal wchar_t Exists

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


ExpPathSeparator Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..ExpPathSeparator Field
FindSpecialChars Class See Also Send Feedback
/ = expression path separator

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char ExpPathSeparator
Visual Basic
Public Const ExpPathSeparator As Char
Visual C++
public:
literal wchar_t ExpPathSeparator

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


Missing Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..Missing Field
FindSpecialChars Class See Also Send Feedback
- = missing

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char Missing
Visual Basic
Public Const Missing As Char
Visual C++
public:
literal wchar_t Missing

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


NotContain Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..NotContain Field
FindSpecialChars Class See Also Send Feedback
! = NotContains

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char NotContain
Visual Basic
Public Const NotContain As Char
Visual C++
public:
literal wchar_t NotContain

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


Pipe Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..Pipe Field
FindSpecialChars Class See Also Send Feedback
| = chain two expressions together

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char Pipe
Visual Basic
Public Const Pipe As Char
Visual C++
public:
literal wchar_t Pipe

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


RegEx Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..RegEx Field
FindSpecialChars Class See Also Send Feedback
# = this is a regex

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char RegEx
Visual Basic
Public Const RegEx As Char
Visual C++
public:
literal wchar_t RegEx

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


StartsWith Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindSpecialChars..::..StartsWith Field
FindSpecialChars Class See Also Send Feedback
^ = Starts with

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char StartsWith
Visual Basic
Public Const StartsWith As Char
Visual C++
public:
literal wchar_t StartsWith

See Also

FindSpecialChars Class
ArtOfTest.Common Namespace


GenericEventArgs(T) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericEventArgs<(Of <(<'T>)>)> Members
GenericEventArgs<(Of <(<'T>)>)> Class Constructors Methods Operators Properties See Also Send Feedback

The GenericEventArgs<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | GenericEventArgs<(Of <(<'T>)>)> | Initializes a new instance of the GenericEventArgs<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(T to GenericEventArgs<(Of <<'(T>)>>)) |

Properties

 | Name | Description
Public property | Value |

See Also

GenericEventArgs<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


GenericEventArgs(T) Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericEventArgs<(Of <(<'T>)>)> Constructor
GenericEventArgs<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the GenericEventArgs<(Of <(<'T>)>)> class

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericEventArgs(
    T value
)
Visual Basic
Public Sub New ( _
    value As T _
)
Visual C++
public:
GenericEventArgs(
    T value
)

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:ArtOfTest.Common.GenericEventArgs`1.#ctor(`0)"]

See Also

GenericEventArgs<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


GenericEventArgs(T) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericEventArgs<(Of <(<'T>)>)> Methods
GenericEventArgs<(Of <(<'T>)>)> Class See Also Send Feedback

The GenericEventArgs<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

GenericEventArgs<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericEventArgs<(Of <(<'T>)>)>..::..ToString Method
GenericEventArgs<(Of <(<'T>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.GenericEventArgs`1.ToString"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.GenericEventArgs`1.ToString"]

See Also

GenericEventArgs<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


GenericEventArgs(T) Type Conversions

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericEventArgs<(Of <(<'T>)>)> Type Conversions
GenericEventArgs<(Of <(<'T>)>)> Class See Also Send Feedback

The GenericEventArgs<(Of <(<'T>)>)> type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(T to GenericEventArgs<(Of <<'(T>)>>)) |

See Also

GenericEventArgs<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


Implicit Conversion (T to GenericEventArgs(T))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericEventArgs<(Of <(<'T>)>)> ImplicitWideningImplicitImplicitImplicit Conversion (T to GenericEventArgs<(Of <(<'T>)>)>)
GenericEventArgs<(Of <(<'T>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.GenericEventArgs`1.op_Implicit(`0)~ArtOfTest.Common.GenericEventArgs{`0}"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator GenericEventArgs<T> (
    T value
)
Visual Basic
Public Shared Widening Operator CType ( _
    value As T _
) As GenericEventArgs(Of T)
Visual C++
static implicit operator GenericEventArgs<T>^ (
    T value
)

Parameters

value
Type: T

[Missing <param name="value"/> documentation for "M:ArtOfTest.Common.GenericEventArgs`1.op_Implicit(`0)~ArtOfTest.Common.GenericEventArgs{`0}"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.GenericEventArgs`1.op_Implicit(`0)~ArtOfTest.Common.GenericEventArgs{`0}"]

See Also

GenericEventArgs<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


GenericEventArgs(T) Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericEventArgs<(Of <(<'T>)>)> Properties
GenericEventArgs<(Of <(<'T>)>)> Class See Also Send Feedback

The GenericEventArgs<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Value |

See Also

GenericEventArgs<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericEventArgs<(Of <(<'T>)>)>..::..Value Property
GenericEventArgs<(Of <(<'T>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.GenericEventArgs`1.Value"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T Value { get; set; }
Visual Basic
Public Property Value As T
    Get
    Set
Visual C++
public:
property T Value {
    T get ();
    void set (T value);
}

See Also

GenericEventArgs<(Of <(<'T>)>)> Class
ArtOfTest.Common Namespace


HierarchyConstraint Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint Members
HierarchyConstraint Class Constructors Methods Fields Properties See Also Send Feedback

The HierarchyConstraint type exposes the following members.

Constructors

 | Name | Description
Public method | HierarchyConstraint(IFindExpression, array<Int32>[]()[][]) | Create a new hierarchy constraint.
Public method | HierarchyConstraint(IFindExpression, String) | Create a new hierarchy constraint.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validate this constraint against a target element.

Fields

Name | Description
PathSeparator | Path separator used in the PathReference.

Properties

 | Name | Description
Public property | Expression | Get the Find Expression.
Public property | PathReference | Get the path reference for this constraint.

See Also

HierarchyConstraint Class
ArtOfTest.Common Namespace


HierarchyConstraint Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint Constructor
HierarchyConstraint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HierarchyConstraint(IFindExpression, array<Int32>[]()[][]) | Create a new hierarchy constraint.
Public method | HierarchyConstraint(IFindExpression, String) | Create a new hierarchy constraint.

See Also

HierarchyConstraint Class
HierarchyConstraint Members
ArtOfTest.Common Namespace


HierarchyConstraint Constructor (IFindExpression, Int32[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint Constructor (IFindExpression, array<Int32>[]()[][])
HierarchyConstraint Class See Also Send Feedback
Create a new hierarchy constraint.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HierarchyConstraint(
    IFindExpression expression,
    params int[] pathReference
)
Visual Basic
Public Sub New ( _
    expression As IFindExpression, _
    ParamArray pathReference As Integer() _
)
Visual C++
public:
HierarchyConstraint(
    IFindExpression^ expression,
    ... array<int>^ pathReference
)

Parameters

expression
Type: ArtOfTest.Common..::..IFindExpression
The expression to use.
pathReference
Type: array< System..::..Int32 >[]()[][]
The path reference string example "1,3,2". Negative values refer to parent nodes, positive values refer to child nodes. For example: The first child of a parent can be expressed as "-1,1".

Remarks

Indexes are 1 based given that a zero can't be positive or negative.

See Also

HierarchyConstraint Class
HierarchyConstraint Overload
ArtOfTest.Common Namespace


HierarchyConstraint Constructor (IFindExpression, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint Constructor (IFindExpression, String)
HierarchyConstraint Class See Also Send Feedback
Create a new hierarchy constraint.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HierarchyConstraint(
    IFindExpression expression,
    string pathReference
)
Visual Basic
Public Sub New ( _
    expression As IFindExpression, _
    pathReference As String _
)
Visual C++
public:
HierarchyConstraint(
    IFindExpression^ expression,
    String^ pathReference
)

Parameters

expression
Type: ArtOfTest.Common..::..IFindExpression
The expression to use.
pathReference
Type: System..::..String
The path reference string example "1,3,2". Negative values refer to parent nodes, positive values refer to child nodes. For example: The first child of a parent can be expressed as "-1,1".

Remarks

Indexes are 1 based given that a zero can't be positive or negative.

See Also

HierarchyConstraint Class
HierarchyConstraint Overload
ArtOfTest.Common Namespace


HierarchyConstraint Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint Fields
HierarchyConstraint Class See Also Send Feedback

The HierarchyConstraint type exposes the following members.

Fields

Name | Description
PathSeparator | Path separator used in the PathReference.

See Also

HierarchyConstraint Class
ArtOfTest.Common Namespace


PathSeparator Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint..::..PathSeparator Field
HierarchyConstraint Class See Also Send Feedback
Path separator used in the PathReference.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const char PathSeparator
Visual Basic
Public Const PathSeparator As Char
Visual C++
public:
literal wchar_t PathSeparator

See Also

HierarchyConstraint Class
ArtOfTest.Common Namespace


HierarchyConstraint Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint Methods
HierarchyConstraint Class See Also Send Feedback

The HierarchyConstraint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate | Validate this constraint against a target element.

See Also

HierarchyConstraint Class
ArtOfTest.Common Namespace


Validate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint..::..Validate Method
HierarchyConstraint Class See Also Send Feedback
Validate this constraint against a target element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Validate(
    ITargetElement target
)
Visual Basic
Public Function Validate ( _
    target As ITargetElement _
) As Boolean
Visual C++
public:
bool Validate(
    ITargetElement^ target
)

Parameters

target
Type: ArtOfTest.Common..::..ITargetElement
The target element.

Return Value

True/False whether this constraint validates against this element.

See Also

HierarchyConstraint Class
ArtOfTest.Common Namespace


HierarchyConstraint Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint Properties
HierarchyConstraint Class See Also Send Feedback

The HierarchyConstraint type exposes the following members.

Properties

 | Name | Description
Public property | Expression | Get the Find Expression.
Public property | PathReference | Get the path reference for this constraint.

See Also

HierarchyConstraint Class
ArtOfTest.Common Namespace


Expression Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint..::..Expression Property
HierarchyConstraint Class See Also Send Feedback
Get the Find Expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IFindExpression Expression { get; }
Visual Basic
Public ReadOnly Property Expression As IFindExpression
    Get
Visual C++
public:
property IFindExpression^ Expression {
    IFindExpression^ get ();
}

See Also

HierarchyConstraint Class
ArtOfTest.Common Namespace


PathReference Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HierarchyConstraint..::..PathReference Property
HierarchyConstraint Class See Also Send Feedback
Get the path reference for this constraint.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int[] PathReference { get; }
Visual Basic
Public ReadOnly Property PathReference As Integer()
    Get
Visual C++
public:
property array<int>^ PathReference {
    array<int>^ get ();
}

See Also

HierarchyConstraint Class
ArtOfTest.Common Namespace


Histogram Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram Members
Histogram Class Constructors Methods Properties See Also Send Feedback

The Histogram type exposes the following members.

Constructors

 | Name | Description
Public method | Histogram | Initialize a histogram it an initial value set.

Methods

 | Name | Description
Public method | Compare | Compare two histograms and return the difference. This number represents the percent of pixels that different between the two histograms.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromBitmap | Given a bitmap, returns its histogram.
 | FromPixelMap | Build a histogram from the pixel map.
 | FromXmlFile |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Data | The data for the comparison

See Also

Histogram Class
ArtOfTest.Common Namespace


Histogram Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram Constructor
Histogram Class See Also Send Feedback
Initialize a histogram it an initial value set.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Histogram(
    double[] graph
)
Visual Basic
Public Sub New ( _
    graph As Double() _
)
Visual C++
public:
Histogram(
    array<double>^ graph
)

Parameters

graph
Type: array< System..::..Double >[]()[][]

[Missing <param name="graph"/> documentation for "M:ArtOfTest.Common.Histogram.#ctor(System.Double[])"]

See Also

Histogram Class
ArtOfTest.Common Namespace


Histogram Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram Methods
Histogram Class See Also Send Feedback

The Histogram type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compare two histograms and return the difference. This number represents the percent of pixels that different between the two histograms.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromBitmap | Given a bitmap, returns its histogram.
 | FromPixelMap | Build a histogram from the pixel map.
 | FromXmlFile |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Histogram Class
ArtOfTest.Common Namespace


Compare Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram..::..Compare Method
Histogram Class See Also Send Feedback
Compare two histograms and return the difference. This number represents the percent of pixels that different between the two histograms.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Compare(
    Histogram histogramToCompare
)
Visual Basic
Public Function Compare ( _
    histogramToCompare As Histogram _
) As Double
Visual C++
public:
double Compare(
    Histogram^ histogramToCompare
)

Parameters

histogramToCompare
Type: ArtOfTest.Common..::..Histogram

[Missing <param name="histogramToCompare"/> documentation for "M:ArtOfTest.Common.Histogram.Compare(ArtOfTest.Common.Histogram)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Histogram.Compare(ArtOfTest.Common.Histogram)"]

See Also

Histogram Class
ArtOfTest.Common Namespace


FromBitmap Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram..::..FromBitmap Method
Histogram Class See Also Send Feedback
Given a bitmap, returns its histogram.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Histogram FromBitmap(
    Bitmap bitmap
)
Visual Basic
Public Shared Function FromBitmap ( _
    bitmap As Bitmap _
) As Histogram
Visual C++
public:
static Histogram^ FromBitmap(
    Bitmap^ bitmap
)

Parameters

bitmap
Type: System.Drawing..::..Bitmap
The bitmap to use.

Return Value

The histogram of the bitmap.

See Also

Histogram Class
ArtOfTest.Common Namespace


FromPixelMap Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram..::..FromPixelMap Method
Histogram Class See Also Send Feedback
Build a histogram from the pixel map.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Histogram FromPixelMap(
    PixelMap map
)
Visual Basic
Public Shared Function FromPixelMap ( _
    map As PixelMap _
) As Histogram
Visual C++
public:
static Histogram^ FromPixelMap(
    PixelMap^ map
)

Parameters

map
Type: ArtOfTest.Common..::..PixelMap

[Missing <param name="map"/> documentation for "M:ArtOfTest.Common.Histogram.FromPixelMap(ArtOfTest.Common.PixelMap)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Histogram.FromPixelMap(ArtOfTest.Common.PixelMap)"]

See Also

Histogram Class
ArtOfTest.Common Namespace


FromXmlFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram..::..FromXmlFile Method
Histogram Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Histogram.FromXmlFile(System.String)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Histogram FromXmlFile(
    string filePath
)
Visual Basic
Public Shared Function FromXmlFile ( _
    filePath As String _
) As Histogram
Visual C++
public:
static Histogram^ FromXmlFile(
    String^ filePath
)

Parameters

filePath
Type: System..::..String

[Missing <param name="filePath"/> documentation for "M:ArtOfTest.Common.Histogram.FromXmlFile(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Histogram.FromXmlFile(System.String)"]

See Also

Histogram Class
ArtOfTest.Common Namespace


Histogram Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram Properties
Histogram Class See Also Send Feedback

The Histogram type exposes the following members.

Properties

 | Name | Description
Public property | Data | The data for the comparison

See Also

Histogram Class
ArtOfTest.Common Namespace


Data Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Histogram..::..Data Property
Histogram Class See Also Send Feedback
The data for the comparison

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double[] Data { get; }
Visual Basic
Public ReadOnly Property Data As Double()
    Get
Visual C++
public:
property array<double>^ Data {
    array<double>^ get ();
}

See Also

Histogram Class
ArtOfTest.Common Namespace


IAutomationHost Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost Members
IAutomationHost Interface Methods Properties See Also Send Feedback

The IAutomationHost type exposes the following members.

Methods

 | Name | Description
Public method | Capture | Return a bitmap of the host
Public method | EnsureStateIsCurrent | Force the automation host to be up to date. (i.e. RefreshDomTree in Html)
Public method | GetChildHosts | Return a list of child automation host that this host contains.
Public method | GetHostRoot | Return the root target element of this host.
Public method | LocateAllInHost | Find all target elements from the root of this host. (Inherited from ISupportSearchHost.)
Public method | LocateInHost | Find a target element from the root of this host. (Inherited from ISupportSearchHost.)
Public method | SetWindowFocus | Makes the window containing this host active
Public method | UpdateInterHostLinks | Ensures that any links between hosts are up-to-date (Infrastructure use only)
Public method | ValidateMouseLocation | Validate the location of the mouse.

Properties

 | Name | Description
Public property | FriendlyName | A friendly name that represents this host.
Public property | StateHashCode | Returns a hashcode that uniquely identifies the current content state of this host.
Public property | TechnologyType | Get the technology type of the host
Public property | UniqueId | Returns a unique id that identifies this host

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


IAutomationHost Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost Methods
IAutomationHost Interface See Also Send Feedback

The IAutomationHost type exposes the following members.

Methods

 | Name | Description
Public method | Capture | Return a bitmap of the host
Public method | EnsureStateIsCurrent | Force the automation host to be up to date. (i.e. RefreshDomTree in Html)
Public method | GetChildHosts | Return a list of child automation host that this host contains.
Public method | GetHostRoot | Return the root target element of this host.
Public method | LocateAllInHost | Find all target elements from the root of this host. (Inherited from ISupportSearchHost.)
Public method | LocateInHost | Find a target element from the root of this host. (Inherited from ISupportSearchHost.)
Public method | SetWindowFocus | Makes the window containing this host active
Public method | UpdateInterHostLinks | Ensures that any links between hosts are up-to-date (Infrastructure use only)
Public method | ValidateMouseLocation | Validate the location of the mouse.

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..Capture Method
IAutomationHost Interface See Also Send Feedback
Return a bitmap of the host

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Bitmap Capture()
Visual Basic
Function Capture As Bitmap
Visual C++
Bitmap^ Capture()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.IAutomationHost.Capture"]

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


EnsureStateIsCurrent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..EnsureStateIsCurrent Method
IAutomationHost Interface See Also Send Feedback
Force the automation host to be up to date. (i.e. RefreshDomTree in Html)

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void EnsureStateIsCurrent()
Visual Basic
Sub EnsureStateIsCurrent
Visual C++
void EnsureStateIsCurrent()

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


GetChildHosts Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..GetChildHosts Method
IAutomationHost Interface See Also Send Feedback
Return a list of child automation host that this host contains.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IAutomationHost[] GetChildHosts()
Visual Basic
Function GetChildHosts As IAutomationHost()
Visual C++
array<IAutomationHost^>^ GetChildHosts()

Return Value

An array of child hosts

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


GetHostRoot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..GetHostRoot Method
IAutomationHost Interface See Also Send Feedback
Return the root target element of this host.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
ITargetElement GetHostRoot()
Visual Basic
Function GetHostRoot As ITargetElement
Visual C++
ITargetElement^ GetHostRoot()

Return Value

The root target element

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


SetWindowFocus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..SetWindowFocus Method
IAutomationHost Interface See Also Send Feedback
Makes the window containing this host active

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool SetWindowFocus()
Visual Basic
Function SetWindowFocus As Boolean
Visual C++
bool SetWindowFocus()

Return Value

Whether we successfully set the window to active

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


UpdateInterHostLinks Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..UpdateInterHostLinks Method
IAutomationHost Interface See Also Send Feedback
Ensures that any links between hosts are up-to-date (Infrastructure use only)

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void UpdateInterHostLinks()
Visual Basic
Sub UpdateInterHostLinks
Visual C++
void UpdateInterHostLinks()

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


ValidateMouseLocation Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..ValidateMouseLocation Method
IAutomationHost Interface See Also Send Feedback
Validate the location of the mouse.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void ValidateMouseLocation(
    Point point
)
Visual Basic
Sub ValidateMouseLocation ( _
    point As Point _
)
Visual C++
void ValidateMouseLocation(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point

[Missing <param name="point"/> documentation for "M:ArtOfTest.Common.IAutomationHost.ValidateMouseLocation(System.Drawing.Point)"]

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


IAutomationHost Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost Properties
IAutomationHost Interface See Also Send Feedback

The IAutomationHost type exposes the following members.

Properties

 | Name | Description
Public property | FriendlyName | A friendly name that represents this host.
Public property | StateHashCode | Returns a hashcode that uniquely identifies the current content state of this host.
Public property | TechnologyType | Get the technology type of the host
Public property | UniqueId | Returns a unique id that identifies this host

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


FriendlyName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..FriendlyName Property
IAutomationHost Interface See Also Send Feedback
A friendly name that represents this host.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string FriendlyName { get; }
Visual Basic
ReadOnly Property FriendlyName As String
    Get
Visual C++
property String^ FriendlyName {
    String^ get ();
}

Return Value

A friendly name that represents this host at its current state.

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


StateHashCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..StateHashCode Property
IAutomationHost Interface See Also Send Feedback
Returns a hashcode that uniquely identifies the current content state of this host.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string StateHashCode { get; }
Visual Basic
ReadOnly Property StateHashCode As String
    Get
Visual C++
property String^ StateHashCode {
    String^ get ();
}

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


TechnologyType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..TechnologyType Property
IAutomationHost Interface See Also Send Feedback
Get the technology type of the host

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
TechnologyType TechnologyType { get; }
Visual Basic
ReadOnly Property TechnologyType As TechnologyType
    Get
Visual C++
property TechnologyType TechnologyType {
    TechnologyType get ();
}

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


UniqueId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHost..::..UniqueId Property
IAutomationHost Interface See Also Send Feedback
Returns a unique id that identifies this host

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string UniqueId { get; }
Visual Basic
ReadOnly Property UniqueId As String
    Get
Visual C++
property String^ UniqueId {
    String^ get ();
}

See Also

IAutomationHost Interface
ArtOfTest.Common Namespace


IAutomationHostState Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHostState Members
IAutomationHostState Interface Methods Properties See Also Send Feedback

The IAutomationHostState type exposes the following members.

Methods

 | Name | Description
Public method | Capture | Return a bitmap of the host (Inherited from IAutomationHost.)
Public method | EnsureStateIsCurrent | Force the automation host to be up to date. (i.e. RefreshDomTree in Html) (Inherited from IAutomationHost.)
Public method | GetChildHosts | Return a list of child automation host that this host contains. (Inherited from IAutomationHost.)
Public method | GetHostRoot | Return the root target element of this host. (Inherited from IAutomationHost.)
Public method | GetStateAsImage | Get the automation host state as an image
Public method | GetStateAsString | Get the automation host state as a string.
Public method | LocateAllInHost | Find all target elements from the root of this host. (Inherited from ISupportSearchHost.)
Public method | LocateInHost | Find a target element from the root of this host. (Inherited from ISupportSearchHost.)
Public method | SetWindowFocus | Makes the window containing this host active (Inherited from IAutomationHost.)
Public method | UpdateInterHostLinks | Ensures that any links between hosts are up-to-date (Infrastructure use only) (Inherited from IAutomationHost.)
Public method | ValidateMouseLocation | Validate the location of the mouse. (Inherited from IAutomationHost.)

Properties

 | Name | Description
Public property | FriendlyName | A friendly name that represents this host. (Inherited from IAutomationHost.)
Public property | StateHashCode | Returns a hashcode that uniquely identifies the current content state of this host. (Inherited from IAutomationHost.)
Public property | TechnologyType | Get the technology type of the host (Inherited from IAutomationHost.)
Public property | UniqueId | Returns a unique id that identifies this host (Inherited from IAutomationHost.)

See Also

IAutomationHostState Interface
ArtOfTest.Common Namespace


IAutomationHostState Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHostState Methods
IAutomationHostState Interface See Also Send Feedback

The IAutomationHostState type exposes the following members.

Methods

 | Name | Description
Public method | Capture | Return a bitmap of the host (Inherited from IAutomationHost.)
Public method | EnsureStateIsCurrent | Force the automation host to be up to date. (i.e. RefreshDomTree in Html) (Inherited from IAutomationHost.)
Public method | GetChildHosts | Return a list of child automation host that this host contains. (Inherited from IAutomationHost.)
Public method | GetHostRoot | Return the root target element of this host. (Inherited from IAutomationHost.)
Public method | GetStateAsImage | Get the automation host state as an image
Public method | GetStateAsString | Get the automation host state as a string.
Public method | LocateAllInHost | Find all target elements from the root of this host. (Inherited from ISupportSearchHost.)
Public method | LocateInHost | Find a target element from the root of this host. (Inherited from ISupportSearchHost.)
Public method | SetWindowFocus | Makes the window containing this host active (Inherited from IAutomationHost.)
Public method | UpdateInterHostLinks | Ensures that any links between hosts are up-to-date (Infrastructure use only) (Inherited from IAutomationHost.)
Public method | ValidateMouseLocation | Validate the location of the mouse. (Inherited from IAutomationHost.)

See Also

IAutomationHostState Interface
ArtOfTest.Common Namespace


GetStateAsImage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHostState..::..GetStateAsImage Method
IAutomationHostState Interface See Also Send Feedback
Get the automation host state as an image

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Bitmap GetStateAsImage()
Visual Basic
Function GetStateAsImage As Bitmap
Visual C++
Bitmap^ GetStateAsImage()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.IAutomationHostState.GetStateAsImage"]

See Also

IAutomationHostState Interface
ArtOfTest.Common Namespace


GetStateAsString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHostState..::..GetStateAsString Method
IAutomationHostState Interface See Also Send Feedback
Get the automation host state as a string.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetStateAsString()
Visual Basic
Function GetStateAsString As String
Visual C++
String^ GetStateAsString()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.IAutomationHostState.GetStateAsString"]

See Also

IAutomationHostState Interface
ArtOfTest.Common Namespace


IAutomationHostState Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationHostState Properties
IAutomationHostState Interface See Also Send Feedback

The IAutomationHostState type exposes the following members.

Properties

 | Name | Description
Public property | FriendlyName | A friendly name that represents this host. (Inherited from IAutomationHost.)
Public property | StateHashCode | Returns a hashcode that uniquely identifies the current content state of this host. (Inherited from IAutomationHost.)
Public property | TechnologyType | Get the technology type of the host (Inherited from IAutomationHost.)
Public property | UniqueId | Returns a unique id that identifies this host (Inherited from IAutomationHost.)

See Also

IAutomationHostState Interface
ArtOfTest.Common Namespace


IFindExpression Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression Members
IFindExpression Interface Methods Properties See Also Send Feedback

The IFindExpression type exposes the following members.

Methods

 | Name | Description
Public method | AppendChain | Append an expression as a chain.
Public method | AppendClauses | Append a set of clauses
Public method | GetClauses | Get the list of FindClauses contained in this FindExpression.
Public method | Initialize | Initialize this expression with a set of clauses
Public method | Match(ITargetElement) | Match this expression with a target.
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a specific set of clauses.
Public method | Update | Update the expression with the passed in values.

Properties

 | Name | Description
Public property | ChainStops | Get the list of chain stops.
Public property | Clauses | Gets the list of clauses as a string array
Public property | Constraints | Get the list of hierarchy constraints.
Public property | HasHierarchicalDependency | Gets whether this expression has a hierarchial dependency (i.e. IsChained or has a FindClause that has IsHierarchical set)
Public property | IsChained | Gets whether this expression is a chained search.
Public property | StringRepresentation | Get the string representation of this expression
Public property | SupportedSearchType | Gets the supported search type

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


IFindExpression Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression Methods
IFindExpression Interface See Also Send Feedback

The IFindExpression type exposes the following members.

Methods

 | Name | Description
Public method | AppendChain | Append an expression as a chain.
Public method | AppendClauses | Append a set of clauses
Public method | GetClauses | Get the list of FindClauses contained in this FindExpression.
Public method | Initialize | Initialize this expression with a set of clauses
Public method | Match(ITargetElement) | Match this expression with a target.
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a specific set of clauses.
Public method | Update | Update the expression with the passed in values.

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


AppendChain Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..AppendChain Method
IFindExpression Interface See Also Send Feedback
Append an expression as a chain.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void AppendChain(
    IFindExpression expression
)
Visual Basic
Sub AppendChain ( _
    expression As IFindExpression _
)
Visual C++
void AppendChain(
    IFindExpression^ expression
)

Parameters

expression
Type: ArtOfTest.Common..::..IFindExpression
The expression to append.

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


AppendClauses Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..AppendClauses Method
IFindExpression Interface See Also Send Feedback
Append a set of clauses

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void AppendClauses(
    bool asChain,
    params string[] clausesToAppend
)
Visual Basic
Sub AppendClauses ( _
    asChain As Boolean, _
    ParamArray clausesToAppend As String() _
)
Visual C++
void AppendClauses(
    bool asChain,
    ... array<String^>^ clausesToAppend
)

Parameters

asChain
Type: System..::..Boolean
Whether to append as a chain or simply to the end of the expression
clausesToAppend
Type: array< System..::..String >[]()[][]
The clauses to append.

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


GetClauses Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..GetClauses Method
IFindExpression Interface See Also Send Feedback
Get the list of FindClauses contained in this FindExpression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<FindClause> GetClauses(
    int chainIndex
)
Visual Basic
Function GetClauses ( _
    chainIndex As Integer _
) As IList(Of FindClause)
Visual C++
IList<FindClause^>^ GetClauses(
    int chainIndex
)

Parameters

chainIndex
Type: System..::..Int32
The chain index clauses. -1 to get everything.

Return Value

The list of clauses.

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


Initialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..Initialize Method
IFindExpression Interface See Also Send Feedback
Initialize this expression with a set of clauses

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Initialize(
    string[] clauses
)
Visual Basic
Sub Initialize ( _
    clauses As String() _
)
Visual C++
void Initialize(
    array<String^>^ clauses
)

Parameters

clauses
Type: array< System..::..String >[]()[][]
The set of clauses to use.

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


Match Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..Match Method
IFindExpression Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Match(ITargetElement) | Match this expression with a target.
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a specific set of clauses.

See Also

IFindExpression Interface
IFindExpression Members
ArtOfTest.Common Namespace


Match Method (ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..Match Method (ITargetElement)
IFindExpression Interface See Also Send Feedback
Match this expression with a target.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool Match(
    ITargetElement target
)
Visual Basic
Function Match ( _
    target As ITargetElement _
) As Boolean
Visual C++
bool Match(
    ITargetElement^ target
)

Parameters

target
Type: ArtOfTest.Common..::..ITargetElement
The target.

Return Value

True/False whether the target matches the expression.

See Also

IFindExpression Interface
Match Overload
ArtOfTest.Common Namespace


Match Method (ITargetElement, IList(FindClause), Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..Match Method (ITargetElement, IList<(Of <(<'FindClause>)>)>, Boolean)
IFindExpression Interface See Also Send Feedback
Match a specific set of clauses.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool Match(
    ITargetElement target,
    IList<FindClause> clauses,
    bool ignoreConstraints
)
Visual Basic
Function Match ( _
    target As ITargetElement, _
    clauses As IList(Of FindClause), _
    ignoreConstraints As Boolean _
) As Boolean
Visual C++
bool Match(
    ITargetElement^ target,
    IList<FindClause^>^ clauses,
    bool ignoreConstraints
)

Parameters

target
Type: ArtOfTest.Common..::..ITargetElement
The target element to match.
clauses
Type: System.Collections.Generic..::..IList <(Of <(<' FindClause >)>)>
A list of clauses to test for a match.
ignoreConstraints
Type: System..::..Boolean
Whether or not to ignore any constraints attached to the clauses.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.IFindExpression.Match(ArtOfTest.Common.ITargetElement,System.Collections.Generic.IList{ArtOfTest.Common.FindClause},System.Boolean)"]

See Also

IFindExpression Interface
Match Overload
ArtOfTest.Common Namespace


Update Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..Update Method
IFindExpression Interface See Also Send Feedback
Update the expression with the passed in values.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Update(
    string[] expression
)
Visual Basic
Sub Update ( _
    expression As String() _
)
Visual C++
void Update(
    array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]

[Missing <param name="expression"/> documentation for "M:ArtOfTest.Common.IFindExpression.Update(System.String[])"]

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


IFindExpression Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression Properties
IFindExpression Interface See Also Send Feedback

The IFindExpression type exposes the following members.

Properties

 | Name | Description
Public property | ChainStops | Get the list of chain stops.
Public property | Clauses | Gets the list of clauses as a string array
Public property | Constraints | Get the list of hierarchy constraints.
Public property | HasHierarchicalDependency | Gets whether this expression has a hierarchial dependency (i.e. IsChained or has a FindClause that has IsHierarchical set)
Public property | IsChained | Gets whether this expression is a chained search.
Public property | StringRepresentation | Get the string representation of this expression
Public property | SupportedSearchType | Gets the supported search type

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


ChainStops Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..ChainStops Property
IFindExpression Interface See Also Send Feedback
Get the list of chain stops.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<int> ChainStops { get; }
Visual Basic
ReadOnly Property ChainStops As IList(Of Integer)
    Get
Visual C++
property IList<int>^ ChainStops {
    IList<int>^ get ();
}

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


Clauses Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..Clauses Property
IFindExpression Interface See Also Send Feedback
Gets the list of clauses as a string array

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string[] Clauses { get; }
Visual Basic
ReadOnly Property Clauses As String()
    Get
Visual C++
property array<String^>^ Clauses {
    array<String^>^ get ();
}

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


Constraints Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..Constraints Property
IFindExpression Interface See Also Send Feedback
Get the list of hierarchy constraints.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<HierarchyConstraint> Constraints { get; }
Visual Basic
ReadOnly Property Constraints As IList(Of HierarchyConstraint)
    Get
Visual C++
property IList<HierarchyConstraint^>^ Constraints {
    IList<HierarchyConstraint^>^ get ();
}

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


HasHierarchicalDependency Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..HasHierarchicalDependency Property
IFindExpression Interface See Also Send Feedback
Gets whether this expression has a hierarchial dependency (i.e. IsChained or has a FindClause that has IsHierarchical set)

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool HasHierarchicalDependency { get; }
Visual Basic
ReadOnly Property HasHierarchicalDependency As Boolean
    Get
Visual C++
property bool HasHierarchicalDependency {
    bool get ();
}

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


IsChained Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..IsChained Property
IFindExpression Interface See Also Send Feedback
Gets whether this expression is a chained search.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsChained { get; }
Visual Basic
ReadOnly Property IsChained As Boolean
    Get
Visual C++
property bool IsChained {
    bool get ();
}

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


StringRepresentation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..StringRepresentation Property
IFindExpression Interface See Also Send Feedback
Get the string representation of this expression

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string StringRepresentation { get; }
Visual Basic
ReadOnly Property StringRepresentation As String
    Get
Visual C++
property String^ StringRepresentation {
    String^ get ();
}

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


SupportedSearchType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindExpression..::..SupportedSearchType Property
IFindExpression Interface See Also Send Feedback
Gets the supported search type

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Type SupportedSearchType { get; }
Visual Basic
ReadOnly Property SupportedSearchType As Type
    Get
Visual C++
property Type^ SupportedSearchType {
    Type^ get ();
}

See Also

IFindExpression Interface
ArtOfTest.Common Namespace


ISupportSearchHost Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISupportSearchHost Members
ISupportSearchHost Interface Methods See Also Send Feedback

The ISupportSearchHost type exposes the following members.

Methods

 | Name | Description
Public method | LocateAllInHost | Find all target elements from the root of this host.
Public method | LocateInHost | Find a target element from the root of this host.

See Also

ISupportSearchHost Interface
ArtOfTest.Common Namespace


ISupportSearchHost Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISupportSearchHost Methods
ISupportSearchHost Interface See Also Send Feedback

The ISupportSearchHost type exposes the following members.

Methods

 | Name | Description
Public method | LocateAllInHost | Find all target elements from the root of this host.
Public method | LocateInHost | Find a target element from the root of this host.

See Also

ISupportSearchHost Interface
ArtOfTest.Common Namespace


LocateAllInHost Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISupportSearchHost..::..LocateAllInHost Method
ISupportSearchHost Interface See Also Send Feedback
Find all target elements from the root of this host.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<ITargetElement> LocateAllInHost(
    string[] expression
)
Visual Basic
Function LocateAllInHost ( _
    expression As String() _
) As IList(Of ITargetElement)
Visual C++
IList<ITargetElement^>^ LocateAllInHost(
    array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]
The expression to match

Return Value

The list of matching elements

See Also

ISupportSearchHost Interface
ArtOfTest.Common Namespace


LocateInHost Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISupportSearchHost..::..LocateInHost Method
ISupportSearchHost Interface See Also Send Feedback
Find a target element from the root of this host.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
ITargetElement LocateInHost(
    string[] expression
)
Visual Basic
Function LocateInHost ( _
    expression As String() _
) As ITargetElement
Visual C++
ITargetElement^ LocateInHost(
    array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]
The expression parameters to use.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.ISupportSearchHost.LocateInHost(System.String[])"]

See Also

ISupportSearchHost Interface
ArtOfTest.Common Namespace


ITargetElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement Members
ITargetElement Interface Methods Properties See Also Send Feedback

The ITargetElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element.
Public method | Capture | Return the visual representation of this element
Public method | GetChildren | Get the children of this element.
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page.
Public method | GetParent | Gets the parent of this element.
Public method | GetRectangle | Return the rectangle of this element
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element.
Public method | Match | Match this target element against an expression.
Public method | Refresh | Ensure current state.
Public method | SetClosingTag | Set the closing tag for this element.
Public method | SetDepth | Set the depth of this element.
Public method | SetParent | Set the parent of this node.

Properties

 | Name | Description
Public property | Depth | Get the depth within the tree.
Public property | Host | Get the automation host.
Public property | IsTestRegion | Get whether this element is a test region or not
Public property | ParsedElement | Get the parsed element
Public property | TechnologyType | Get the technology type of this element.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


ITargetElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement Methods
ITargetElement Interface See Also Send Feedback

The ITargetElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element.
Public method | Capture | Return the visual representation of this element
Public method | GetChildren | Get the children of this element.
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page.
Public method | GetParent | Gets the parent of this element.
Public method | GetRectangle | Return the rectangle of this element
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element.
Public method | Match | Match this target element against an expression.
Public method | Refresh | Ensure current state.
Public method | SetClosingTag | Set the closing tag for this element.
Public method | SetDepth | Set the depth of this element.
Public method | SetParent | Set the parent of this node.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


AddChildNode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..AddChildNode Method
ITargetElement Interface See Also Send Feedback
Add a child node to this element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void AddChildNode(
    ITargetElement child
)
Visual Basic
Sub AddChildNode ( _
    child As ITargetElement _
)
Visual C++
void AddChildNode(
    ITargetElement^ child
)

Parameters

child
Type: ArtOfTest.Common..::..ITargetElement
The child node.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..Capture Method
ITargetElement Interface See Also Send Feedback
Return the visual representation of this element

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Bitmap Capture()
Visual Basic
Function Capture As Bitmap
Visual C++
Bitmap^ Capture()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.ITargetElement.Capture"]

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


GetChildren Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..GetChildren Method
ITargetElement Interface See Also Send Feedback
Get the children of this element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
ITargetElement[] GetChildren()
Visual Basic
Function GetChildren As ITargetElement()
Visual C++
array<ITargetElement^>^ GetChildren()

Return Value

An array of the children of this element.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


GetHostParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..GetHostParent Method
ITargetElement Interface See Also Send Feedback
Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
ITargetElement GetHostParent()
Visual Basic
Function GetHostParent As ITargetElement
Visual C++
ITargetElement^ GetHostParent()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.ITargetElement.GetHostParent"]

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


GetParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..GetParent Method
ITargetElement Interface See Also Send Feedback
Gets the parent of this element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
ITargetElement GetParent()
Visual Basic
Function GetParent As ITargetElement
Visual C++
ITargetElement^ GetParent()

Return Value

The parent of this element.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


GetRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..GetRectangle Method
ITargetElement Interface See Also Send Feedback
Return the rectangle of this element

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Rectangle GetRectangle()
Visual Basic
Function GetRectangle As Rectangle
Visual C++
Rectangle GetRectangle()

Return Value

The rectangle of this element

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


GetUniqueHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..GetUniqueHashCode Method
ITargetElement Interface See Also Send Feedback
Returns a unique ID that identifies this target element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int GetUniqueHashCode()
Visual Basic
Function GetUniqueHashCode As Integer
Visual C++
int GetUniqueHashCode()

Return Value

The unique ID

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


Match Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..Match Method
ITargetElement Interface See Also Send Feedback
Match this target element against an expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool Match(
    IFindExpression findExpr
)
Visual Basic
Function Match ( _
    findExpr As IFindExpression _
) As Boolean
Visual C++
bool Match(
    IFindExpression^ findExpr
)

Parameters

findExpr
Type: ArtOfTest.Common..::..IFindExpression
The FindExpression.

Return Value

Returns true/false whether the expression matches.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


Refresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..Refresh Method
ITargetElement Interface See Also Send Feedback
Ensure current state.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Refresh()
Visual Basic
Sub Refresh
Visual C++
void Refresh()

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


SetClosingTag Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..SetClosingTag Method
ITargetElement Interface See Also Send Feedback
Set the closing tag for this element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetClosingTag(
    ITargetElement closingElement
)
Visual Basic
Sub SetClosingTag ( _
    closingElement As ITargetElement _
)
Visual C++
void SetClosingTag(
    ITargetElement^ closingElement
)

Parameters

closingElement
Type: ArtOfTest.Common..::..ITargetElement
The closing element

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


SetDepth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..SetDepth Method
ITargetElement Interface See Also Send Feedback
Set the depth of this element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetDepth(
    int depth
)
Visual Basic
Sub SetDepth ( _
    depth As Integer _
)
Visual C++
void SetDepth(
    int depth
)

Parameters

depth
Type: System..::..Int32
The depth to set it to.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


SetParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..SetParent Method
ITargetElement Interface See Also Send Feedback
Set the parent of this node.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetParent(
    ITargetElement parent
)
Visual Basic
Sub SetParent ( _
    parent As ITargetElement _
)
Visual C++
void SetParent(
    ITargetElement^ parent
)

Parameters

parent
Type: ArtOfTest.Common..::..ITargetElement
The parent node.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


ITargetElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement Properties
ITargetElement Interface See Also Send Feedback

The ITargetElement type exposes the following members.

Properties

 | Name | Description
Public property | Depth | Get the depth within the tree.
Public property | Host | Get the automation host.
Public property | IsTestRegion | Get whether this element is a test region or not
Public property | ParsedElement | Get the parsed element
Public property | TechnologyType | Get the technology type of this element.

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


Depth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..Depth Property
ITargetElement Interface See Also Send Feedback
Get the depth within the tree.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int Depth { get; }
Visual Basic
ReadOnly Property Depth As Integer
    Get
Visual C++
property int Depth {
    int get ();
}

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


Host Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..Host Property
ITargetElement Interface See Also Send Feedback
Get the automation host.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IAutomationHost Host { get; }
Visual Basic
ReadOnly Property Host As IAutomationHost
    Get
Visual C++
property IAutomationHost^ Host {
    IAutomationHost^ get ();
}

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


IsTestRegion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..IsTestRegion Property
ITargetElement Interface See Also Send Feedback
Get whether this element is a test region or not

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsTestRegion { get; }
Visual Basic
ReadOnly Property IsTestRegion As Boolean
    Get
Visual C++
property bool IsTestRegion {
    bool get ();
}

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


ParsedElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..ParsedElement Property
ITargetElement Interface See Also Send Feedback
Get the parsed element

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
ParsedElement ParsedElement { get; }
Visual Basic
ReadOnly Property ParsedElement As ParsedElement
    Get
Visual C++
property ParsedElement^ ParsedElement {
    ParsedElement^ get ();
}

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


TechnologyType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITargetElement..::..TechnologyType Property
ITargetElement Interface See Also Send Feedback
Get the technology type of this element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
TechnologyType TechnologyType { get; }
Visual Basic
ReadOnly Property TechnologyType As TechnologyType
    Get
Visual C++
property TechnologyType TechnologyType {
    TechnologyType get ();
}

See Also

ITargetElement Interface
ArtOfTest.Common Namespace


ITestRegion Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITestRegion Members
ITestRegion Interface Properties See Also Send Feedback

The ITestRegion type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ID of the test region.

See Also

ITestRegion Interface
ArtOfTest.Common Namespace


ITestRegion Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITestRegion Properties
ITestRegion Interface See Also Send Feedback

The ITestRegion type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ID of the test region.

See Also

ITestRegion Interface
ArtOfTest.Common Namespace


Id Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITestRegion..::..Id Property
ITestRegion Interface See Also Send Feedback
The ID of the test region.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Id { get; }
Visual Basic
ReadOnly Property Id As String
    Get
Visual C++
property String^ Id {
    String^ get ();
}

See Also

ITestRegion Interface
ArtOfTest.Common Namespace


MUI Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MUI Members
MUI Class Methods Fields See Also Send Feedback

The MUI type exposes the following members.

Methods

Name | Description
GetString(String, Int32) | Retreive a localized string from a DLL.
GetString(String, Int32, String) | Retreive a localized string from a DLL.
GetString(String, Int32, String, Func<(Of <<'(String, String>)>>)) | Retreive a localized string from a DLL.

Fields

Name | Description
MUIDirectory | The current culture's MUI directory

See Also

MUI Class
ArtOfTest.Common Namespace


MUI Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MUI Fields
MUI Class See Also Send Feedback

The MUI type exposes the following members.

Fields

Name | Description
MUIDirectory | The current culture's MUI directory

See Also

MUI Class
ArtOfTest.Common Namespace


MUIDirectory Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MUI..::..MUIDirectory Field
MUI Class See Also Send Feedback
The current culture's MUI directory

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string MUIDirectory
Visual Basic
Public Shared MUIDirectory As String
Visual C++
public:
static String^ MUIDirectory

See Also

MUI Class
ArtOfTest.Common Namespace


MUI Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MUI Methods
MUI Class See Also Send Feedback

Methods

Name | Description
GetString(String, Int32) | Retreive a localized string from a DLL.
GetString(String, Int32, String) | Retreive a localized string from a DLL.
GetString(String, Int32, String, Func<(Of <<'(String, String>)>>)) | Retreive a localized string from a DLL.

See Also

MUI Class
ArtOfTest.Common Namespace


GetString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MUI..::..GetString Method
MUI Class See Also Send Feedback

Overload List

Name | Description
GetString(String, Int32) | Retreive a localized string from a DLL.
GetString(String, Int32, String) | Retreive a localized string from a DLL.
GetString(String, Int32, String, Func<(Of <<'(String, String>)>>)) | Retreive a localized string from a DLL.

See Also

MUI Class
MUI Members
ArtOfTest.Common Namespace


GetString Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MUI..::..GetString Method (String, Int32)
MUI Class See Also Send Feedback
Retreive a localized string from a DLL.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GetString(
    string module,
    int Id
)
Visual Basic
Public Shared Function GetString ( _
    module As String, _
    Id As Integer _
) As String
Visual C++
public:
static String^ GetString(
    String^ module,
    int Id
)

Parameters

module
Type: System..::..String
The DLL which contains the string
Id
Type: System..::..Int32
The resource Id of the string

Return Value

The localized string loaded from the DLL

See Also

MUI Class
GetString Overload
ArtOfTest.Common Namespace


GetString Method (String, Int32, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MUI..::..GetString Method (String, Int32, String)
MUI Class See Also Send Feedback
Retreive a localized string from a DLL.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GetString(
    string module,
    int Id,
    string defaultValue
)
Visual Basic
Public Shared Function GetString ( _
    module As String, _
    Id As Integer, _
    defaultValue As String _
) As String
Visual C++
public:
static String^ GetString(
    String^ module,
    int Id,
    String^ defaultValue
)

Parameters

module
Type: System..::..String
The DLL which contains the string
Id
Type: System..::..Int32
The resource Id of the string
defaultValue
Type: System..::..String
If for any reason the localized string cannot be loaded, this default value will be used

Return Value

The localized string loaded from the DLL, or defaultValue

See Also

MUI Class
GetString Overload
ArtOfTest.Common Namespace


GetString Method (String, Int32, String, Func(String, String))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MUI..::..GetString Method (String, Int32, String, Func<(Of <(<'String, String>)>)>)
MUI Class See Also Send Feedback
Retreive a localized string from a DLL.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GetString(
    string module,
    int Id,
    string defaultValue,
    Func<string, string> func
)
Visual Basic
Public Shared Function GetString ( _
    module As String, _
    Id As Integer, _
    defaultValue As String, _
    func As Func(Of String, String) _
) As String
Visual C++
public:
static String^ GetString(
    String^ module,
    int Id,
    String^ defaultValue,
    Func<String^, String^>^ func
)

Parameters

module
Type: System..::..String
The DLL which contains the string
Id
Type: System..::..Int32
The resource Id of the string
defaultValue
Type: System..::..String
If for any reason the localized string cannot be loaded, this default value will be used
func
Type: System..::..Func <(Of <(<' String, String >)>)>
An operation to perform on the string before returning it

Return Value

The result of performing func on the localized string loaded from the DLL, or defaultValue

See Also

MUI Class
GetString Overload
ArtOfTest.Common Namespace


ParsedElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement Members
ParsedElement Class Constructors Methods Properties See Also Send Feedback

The ParsedElement type exposes the following members.

Constructors

 | Name | Description
Public method | ParsedElement(ParsedElementType, String, Boolean) | Create a new ParsedElement object.
Public method | ParsedElement(ParsedElementType, String, String, String) | Create a new ParsedElement object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | The string representation of this element. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AbsoluteTagIndex | Gets the absolute tag index on the page. (Only Open/valid tags are counted, no comments)
Public property | Attributes | Gets the parsed attributes of the element.
Public property | IsBeginTag | Gets whether the element is a begin tag or not.
Public property | IsEndTag | Gets whether the element is an end tag or not.
Public property | IsSelfClosing | Gets whether the element is a self closing tag (i.e. <font ... /> )
Public property | ParsingType | Gets the parsed element type.
Public property | Tag | A tag associated with this element
Public property | TagName | Gets the tagName of the element.
Public property | TagNameIndex | Gets the TagName index within the page. (Only valid tags are counted, no comments)

See Also

ParsedElement Class
ArtOfTest.Common Namespace


ParsedElement Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement Constructor
ParsedElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParsedElement(ParsedElementType, String, Boolean) | Create a new ParsedElement object.
Public method | ParsedElement(ParsedElementType, String, String, String) | Create a new ParsedElement object.

See Also

ParsedElement Class
ParsedElement Members
ArtOfTest.Common Namespace


ParsedElement Constructor (ParsedElementType, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement Constructor (ParsedElementType, String, Boolean)
ParsedElement Class See Also Send Feedback
Create a new ParsedElement object.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ParsedElement(
    ParsedElementType elementType,
    string content,
    bool validateIllegal
)
Visual Basic
Public Sub New ( _
    elementType As ParsedElementType, _
    content As String, _
    validateIllegal As Boolean _
)
Visual C++
public:
ParsedElement(
    ParsedElementType elementType,
    String^ content,
    bool validateIllegal
)

Parameters

elementType
Type: ArtOfTest.Common..::..ParsedElementType
The type of element to create.
content
Type: System..::..String
The raw content for the element.
validateIllegal
Type: System..::..Boolean
Whether to validate for illegal formats.

See Also

ParsedElement Class
ParsedElement Overload
ArtOfTest.Common Namespace


ParsedElement Constructor (ParsedElementType, String, String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement Constructor (ParsedElementType, String, String, String)
ParsedElement Class See Also Send Feedback
Create a new ParsedElement object.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ParsedElement(
    ParsedElementType elementType,
    string content,
    string tagName,
    string remainder
)
Visual Basic
Public Sub New ( _
    elementType As ParsedElementType, _
    content As String, _
    tagName As String, _
    remainder As String _
)
Visual C++
public:
ParsedElement(
    ParsedElementType elementType,
    String^ content,
    String^ tagName,
    String^ remainder
)

Parameters

elementType
Type: ArtOfTest.Common..::..ParsedElementType
The type of element to create.
content
Type: System..::..String
The raw content for the element.
tagName
Type: System..::..String
The tag name of the element.
remainder
Type: System..::..String
The rest of the tag text except for the tag name.

See Also

ParsedElement Class
ParsedElement Overload
ArtOfTest.Common Namespace


ParsedElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement Methods
ParsedElement Class See Also Send Feedback

The ParsedElement type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | The string representation of this element. (Overrides Object..::..ToString()()()().)

See Also

ParsedElement Class
ArtOfTest.Common Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..ToString Method
ParsedElement Class See Also Send Feedback
The string representation of this element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation.

See Also

ParsedElement Class
ArtOfTest.Common Namespace


ParsedElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement Properties
ParsedElement Class See Also Send Feedback

The ParsedElement type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteTagIndex | Gets the absolute tag index on the page. (Only Open/valid tags are counted, no comments)
Public property | Attributes | Gets the parsed attributes of the element.
Public property | IsBeginTag | Gets whether the element is a begin tag or not.
Public property | IsEndTag | Gets whether the element is an end tag or not.
Public property | IsSelfClosing | Gets whether the element is a self closing tag (i.e. <font ... /> )
Public property | ParsingType | Gets the parsed element type.
Public property | Tag | A tag associated with this element
Public property | TagName | Gets the tagName of the element.
Public property | TagNameIndex | Gets the TagName index within the page. (Only valid tags are counted, no comments)

See Also

ParsedElement Class
ArtOfTest.Common Namespace


AbsoluteTagIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..AbsoluteTagIndex Property
ParsedElement Class See Also Send Feedback
Gets the absolute tag index on the page. (Only Open/valid tags are counted, no comments)

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AbsoluteTagIndex { get; }
Visual Basic
Public ReadOnly Property AbsoluteTagIndex As Integer
    Get
Visual C++
public:
property int AbsoluteTagIndex {
    int get ();
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


Attributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..Attributes Property
ParsedElement Class See Also Send Feedback
Gets the parsed attributes of the element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NameValueCollection Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As NameValueCollection
    Get
Visual C++
public:
property NameValueCollection^ Attributes {
    NameValueCollection^ get ();
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


IsBeginTag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..IsBeginTag Property
ParsedElement Class See Also Send Feedback
Gets whether the element is a begin tag or not.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsBeginTag { get; }
Visual Basic
Public ReadOnly Property IsBeginTag As Boolean
    Get
Visual C++
public:
property bool IsBeginTag {
    bool get ();
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


IsEndTag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..IsEndTag Property
ParsedElement Class See Also Send Feedback
Gets whether the element is an end tag or not.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEndTag { get; }
Visual Basic
Public ReadOnly Property IsEndTag As Boolean
    Get
Visual C++
public:
property bool IsEndTag {
    bool get ();
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


IsSelfClosing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..IsSelfClosing Property
ParsedElement Class See Also Send Feedback
Gets whether the element is a self closing tag (i.e. <font ... /> )

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelfClosing { get; }
Visual Basic
Public ReadOnly Property IsSelfClosing As Boolean
    Get
Visual C++
public:
property bool IsSelfClosing {
    bool get ();
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


ParsingType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..ParsingType Property
ParsedElement Class See Also Send Feedback
Gets the parsed element type.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ParsedElementType ParsingType { get; }
Visual Basic
Public ReadOnly Property ParsingType As ParsedElementType
    Get
Visual C++
public:
property ParsedElementType ParsingType {
    ParsedElementType get ();
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


Tag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..Tag Property
ParsedElement Class See Also Send Feedback
A tag associated with this element

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object Tag { get; set; }
Visual Basic
Public Property Tag As Object
    Get
    Set
Visual C++
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


TagName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..TagName Property
ParsedElement Class See Also Send Feedback
Gets the tagName of the element.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TagName { get; }
Visual Basic
Public ReadOnly Property TagName As String
    Get
Visual C++
public:
property String^ TagName {
    String^ get ();
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


TagNameIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ParsedElement..::..TagNameIndex Property
ParsedElement Class See Also Send Feedback
Gets the TagName index within the page. (Only valid tags are counted, no comments)

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TagNameIndex { get; }
Visual Basic
Public ReadOnly Property TagNameIndex As Integer
    Get
Visual C++
public:
property int TagNameIndex {
    int get ();
}

See Also

ParsedElement Class
ArtOfTest.Common Namespace


PixelMap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap Members
PixelMap Class Methods Properties See Also Send Feedback

The PixelMap type exposes the following members.

Methods

 | Name | Description
Public method | AreExact | Whether two pixel maps are exactly the same.
Public method | Compare | Compare this map to another map and return whether they match within the tolerance percent 0 tolerance means they both need to be exact matches 1% means we can tolerate 1% of the pixels being difference
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromBitmap | Create a pixel map from a bitmap.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistogram | Return the histogram of this image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Height | The height of the map
Public property | Item | Access the color of a pixel.
Public property | Width | The width of the map

See Also

PixelMap Class
ArtOfTest.Common Namespace


PixelMap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap Methods
PixelMap Class See Also Send Feedback

The PixelMap type exposes the following members.

Methods

 | Name | Description
Public method | AreExact | Whether two pixel maps are exactly the same.
Public method | Compare | Compare this map to another map and return whether they match within the tolerance percent 0 tolerance means they both need to be exact matches 1% means we can tolerate 1% of the pixels being difference
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromBitmap | Create a pixel map from a bitmap.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistogram | Return the histogram of this image.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PixelMap Class
ArtOfTest.Common Namespace


AreExact Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap..::..AreExact Method
PixelMap Class See Also Send Feedback
Whether two pixel maps are exactly the same.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AreExact(
    PixelMap map
)
Visual Basic
Public Function AreExact ( _
    map As PixelMap _
) As Boolean
Visual C++
public:
bool AreExact(
    PixelMap^ map
)

Parameters

map
Type: ArtOfTest.Common..::..PixelMap
The other map.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.PixelMap.AreExact(ArtOfTest.Common.PixelMap)"]

See Also

PixelMap Class
ArtOfTest.Common Namespace


Compare Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap..::..Compare Method
PixelMap Class See Also Send Feedback
Compare this map to another map and return whether they match within the tolerance percent 0 tolerance means they both need to be exact matches 1% means we can tolerate 1% of the pixels being difference

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Compare(
    PixelMap map,
    double tolerancePercent
)
Visual Basic
Public Function Compare ( _
    map As PixelMap, _
    tolerancePercent As Double _
) As Boolean
Visual C++
public:
bool Compare(
    PixelMap^ map,
    double tolerancePercent
)

Parameters

map
Type: ArtOfTest.Common..::..PixelMap

[Missing <param name="map"/> documentation for "M:ArtOfTest.Common.PixelMap.Compare(ArtOfTest.Common.PixelMap,System.Double)"]

tolerancePercent
Type: System..::..Double

[Missing <param name="tolerancePercent"/> documentation for "M:ArtOfTest.Common.PixelMap.Compare(ArtOfTest.Common.PixelMap,System.Double)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.PixelMap.Compare(ArtOfTest.Common.PixelMap,System.Double)"]

See Also

PixelMap Class
ArtOfTest.Common Namespace


FromBitmap Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap..::..FromBitmap Method
PixelMap Class See Also Send Feedback
Create a pixel map from a bitmap.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static PixelMap FromBitmap(
    Bitmap bitmap
)
Visual Basic
Public Shared Function FromBitmap ( _
    bitmap As Bitmap _
) As PixelMap
Visual C++
public:
static PixelMap^ FromBitmap(
    Bitmap^ bitmap
)

Parameters

bitmap
Type: System.Drawing..::..Bitmap

[Missing <param name="bitmap"/> documentation for "M:ArtOfTest.Common.PixelMap.FromBitmap(System.Drawing.Bitmap)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.PixelMap.FromBitmap(System.Drawing.Bitmap)"]

See Also

PixelMap Class
ArtOfTest.Common Namespace


GetHistogram Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap..::..GetHistogram Method
PixelMap Class See Also Send Feedback
Return the histogram of this image.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Histogram GetHistogram()
Visual Basic
Public Function GetHistogram As Histogram
Visual C++
public:
Histogram^ GetHistogram()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.PixelMap.GetHistogram"]

See Also

PixelMap Class
ArtOfTest.Common Namespace


PixelMap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap Properties
PixelMap Class See Also Send Feedback

The PixelMap type exposes the following members.

Properties

 | Name | Description
Public property | Height | The height of the map
Public property | Item | Access the color of a pixel.
Public property | Width | The width of the map

See Also

PixelMap Class
ArtOfTest.Common Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap..::..Height Property
PixelMap Class See Also Send Feedback
The height of the map

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Height { get; }
Visual Basic
Public ReadOnly Property Height As Integer
    Get
Visual C++
public:
property int Height {
    int get ();
}

See Also

PixelMap Class
ArtOfTest.Common Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap..::..Item Property
PixelMap Class See Also Send Feedback
Access the color of a pixel.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Color this[
    int row,
    int column
] { get; set; }
Visual Basic
Public Default Property Item ( _
    row As Integer, _
    column As Integer _
) As Color
    Get
    Set
Visual C++
public:
property Color default[int row, int column] {
    Color get (int row, int column);
    void set (int row, int column, Color value);
}

Parameters

row
Type: System..::..Int32
column
Type: System..::..Int32

Return Value

See Also

PixelMap Class
ArtOfTest.Common Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelMap..::..Width Property
PixelMap Class See Also Send Feedback
The width of the map

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Width { get; }
Visual Basic
Public ReadOnly Property Width As Integer
    Get
Visual C++
public:
property int Width {
    int get ();
}

See Also

PixelMap Class
ArtOfTest.Common Namespace


TraceInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo Members
TraceInfo Class Methods Fields Properties Events See Also Send Feedback

The TraceInfo type exposes the following members.

Methods

Name | Description
DebugBreak | This version of Debugger.Break launches the debugger if not attached, rather than silently failing.
GenerateStackFrameFunctionName |
GetTraceInfoName |
OpenTraceLog | This shell-executes the trace log file. We don't decide what program to run and we really don't want to impose Notepad.
RecordTime |
SetTraceInfoName | In debug builds this uses an internal thread naming system for situations where the thread can't be named or named multiple times. In release builds it simply writes directly to the Thread.Name property.
StartTimer |
TraceNullOrNot |
TraceReturnValue |

Fields

Name | Description
AppDomain | This category is used for anything related to AppDomain handling. Mostly for figuring out what's going on during the AppDomain unload process.
BugTracking | This is a bug tracking category.
DialogPlayback | This category is used for identification and handling of live dialogs encountered during a test run.
DialogRecording | This category is used for identification and handling of live dialogs encountered during a recording session.
Error | This is a category for things that should not happen. Take these more seriously than the other categories.
Execution | This is category is self-explanatory.
FeedbackUI |
Framework | This is a miscellaneous category.
HttpProxy | This category is used for logging from the HTTP proxy
Load | This category is used for the TestStudio Load services and related code.
LoadLicensing | This category is used for the TestStudio Load licensing and related code.
Performance | This category is used for the TestStudio Profiler Service and related code.
ProjectModel | This category is used for code related to our object model and project and test files.
QualityCenterSync |
Recording | This category is self-explanatory.
Serialization | This category is for errors and warnings that occur during object serialization
TeamFoundation | This category is for TFS code
Temporary | This category is used for temporary bug-fixing. It is not intended to remain in final code.
TestStudio | This category is used for the TestStudio UI.
TRACE_LOG_FILE_NAME |
TRACE_LOG_MUTEX_NAME |
UIAutomation | For anything dealing specifically with UI Automation, or System.Windows.Automation in particular.
Uncategorized | For code that still uses old trace statements.
User | For code written by framework users. The other categories are subject to change and should not be used by anyone outside of Telerik.
Warning | This is a category for things that merely ought not to happen in a perfect world. Take these more seriously than the other categories but less seriously than Error.
WebServices | Preliminary new category (not finalized yet).
Window | This category is used for anything relating to native UI controls (ex. HWND) or framework wrappers (Form or Window).
WindowsServices | This category is for any general infrastructure regarding NT services (Load Agent, Profiler, Scheduler, etc).

Properties

Name | Description
TraceLogFileCache |
TraceLogFileCacheLineCount |
TraceLogFileEnabled |
TraceLogFileOmittedCategories |
TraceLogFilePath |

Events

Name | Description
TraceSettingsChanged | Special event. If the provided method belongs to a class that derives from DispatcherObject, the callback is called using Dispatcher.BeginInvoke. If it belongs to a class that derives from System.Windows.Forms.Control, it is called using Control.BeginInvoke. Otherwise it is called from the thread pool.

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceInfo Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo Fields
TraceInfo Class See Also Send Feedback

The TraceInfo type exposes the following members.

Fields

Name | Description
AppDomain | This category is used for anything related to AppDomain handling. Mostly for figuring out what's going on during the AppDomain unload process.
BugTracking | This is a bug tracking category.
DialogPlayback | This category is used for identification and handling of live dialogs encountered during a test run.
DialogRecording | This category is used for identification and handling of live dialogs encountered during a recording session.
Error | This is a category for things that should not happen. Take these more seriously than the other categories.
Execution | This is category is self-explanatory.
FeedbackUI |
Framework | This is a miscellaneous category.
HttpProxy | This category is used for logging from the HTTP proxy
Load | This category is used for the TestStudio Load services and related code.
LoadLicensing | This category is used for the TestStudio Load licensing and related code.
Performance | This category is used for the TestStudio Profiler Service and related code.
ProjectModel | This category is used for code related to our object model and project and test files.
QualityCenterSync |
Recording | This category is self-explanatory.
Serialization | This category is for errors and warnings that occur during object serialization
TeamFoundation | This category is for TFS code
Temporary | This category is used for temporary bug-fixing. It is not intended to remain in final code.
TestStudio | This category is used for the TestStudio UI.
TRACE_LOG_FILE_NAME |
TRACE_LOG_MUTEX_NAME |
UIAutomation | For anything dealing specifically with UI Automation, or System.Windows.Automation in particular.
Uncategorized | For code that still uses old trace statements.
User | For code written by framework users. The other categories are subject to change and should not be used by anyone outside of Telerik.
Warning | This is a category for things that merely ought not to happen in a perfect world. Take these more seriously than the other categories but less seriously than Error.
WebServices | Preliminary new category (not finalized yet).
Window | This category is used for anything relating to native UI controls (ex. HWND) or framework wrappers (Form or Window).
WindowsServices | This category is for any general infrastructure regarding NT services (Load Agent, Profiler, Scheduler, etc).

See Also

TraceInfo Class
ArtOfTest.Common Namespace


AppDomain Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..AppDomain Field
TraceInfo Class See Also Send Feedback
This category is used for anything related to AppDomain handling. Mostly for figuring out what's going on during the AppDomain unload process.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory AppDomain
Visual Basic
Public Shared ReadOnly AppDomain As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ AppDomain

See Also

TraceInfo Class
ArtOfTest.Common Namespace


BugTracking Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..BugTracking Field
TraceInfo Class See Also Send Feedback
This is a bug tracking category.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory BugTracking
Visual Basic
Public Shared ReadOnly BugTracking As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ BugTracking

See Also

TraceInfo Class
ArtOfTest.Common Namespace


DialogPlayback Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..DialogPlayback Field
TraceInfo Class See Also Send Feedback
This category is used for identification and handling of live dialogs encountered during a test run.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory DialogPlayback
Visual Basic
Public Shared ReadOnly DialogPlayback As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ DialogPlayback

See Also

TraceInfo Class
ArtOfTest.Common Namespace


DialogRecording Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..DialogRecording Field
TraceInfo Class See Also Send Feedback
This category is used for identification and handling of live dialogs encountered during a recording session.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory DialogRecording
Visual Basic
Public Shared ReadOnly DialogRecording As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ DialogRecording

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Error Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Error Field
TraceInfo Class See Also Send Feedback
This is a category for things that should not happen. Take these more seriously than the other categories.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Error
Visual Basic
Public Shared ReadOnly Error As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Error

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Execution Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Execution Field
TraceInfo Class See Also Send Feedback
This is category is self-explanatory.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Execution
Visual Basic
Public Shared ReadOnly Execution As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Execution

See Also

TraceInfo Class
ArtOfTest.Common Namespace


FeedbackUI Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..FeedbackUI Field
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.TraceInfo.FeedbackUI"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory FeedbackUI
Visual Basic
Public Shared ReadOnly FeedbackUI As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ FeedbackUI

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Framework Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Framework Field
TraceInfo Class See Also Send Feedback
This is a miscellaneous category.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Framework
Visual Basic
Public Shared ReadOnly Framework As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Framework

See Also

TraceInfo Class
ArtOfTest.Common Namespace


HttpProxy Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..HttpProxy Field
TraceInfo Class See Also Send Feedback
This category is used for logging from the HTTP proxy

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory HttpProxy
Visual Basic
Public Shared ReadOnly HttpProxy As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ HttpProxy

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Load Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Load Field
TraceInfo Class See Also Send Feedback
This category is used for the TestStudio Load services and related code.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Load
Visual Basic
Public Shared ReadOnly Load As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Load

See Also

TraceInfo Class
ArtOfTest.Common Namespace


LoadLicensing Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..LoadLicensing Field
TraceInfo Class See Also Send Feedback
This category is used for the TestStudio Load licensing and related code.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory LoadLicensing
Visual Basic
Public Shared ReadOnly LoadLicensing As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ LoadLicensing

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Performance Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Performance Field
TraceInfo Class See Also Send Feedback
This category is used for the TestStudio Profiler Service and related code.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Performance
Visual Basic
Public Shared ReadOnly Performance As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Performance

See Also

TraceInfo Class
ArtOfTest.Common Namespace


ProjectModel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..ProjectModel Field
TraceInfo Class See Also Send Feedback
This category is used for code related to our object model and project and test files.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory ProjectModel
Visual Basic
Public Shared ReadOnly ProjectModel As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ ProjectModel

See Also

TraceInfo Class
ArtOfTest.Common Namespace


QualityCenterSync Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..QualityCenterSync Field
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.TraceInfo.QualityCenterSync"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory QualityCenterSync
Visual Basic
Public Shared ReadOnly QualityCenterSync As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ QualityCenterSync

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Recording Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Recording Field
TraceInfo Class See Also Send Feedback
This category is self-explanatory.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Recording
Visual Basic
Public Shared ReadOnly Recording As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Recording

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Serialization Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Serialization Field
TraceInfo Class See Also Send Feedback
This category is for errors and warnings that occur during object serialization

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Serialization
Visual Basic
Public Shared ReadOnly Serialization As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Serialization

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TeamFoundation Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TeamFoundation Field
TraceInfo Class See Also Send Feedback
This category is for TFS code

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory TeamFoundation
Visual Basic
Public Shared ReadOnly TeamFoundation As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ TeamFoundation

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Temporary Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Temporary Field
TraceInfo Class See Also Send Feedback
This category is used for temporary bug-fixing. It is not intended to remain in final code.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Temporary
Visual Basic
Public Shared ReadOnly Temporary As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Temporary

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TestStudio Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TestStudio Field
TraceInfo Class See Also Send Feedback
This category is used for the TestStudio UI.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory TestStudio
Visual Basic
Public Shared ReadOnly TestStudio As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ TestStudio

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TRACE_LOG_FILE_NAME Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TRACE_LOG_FILE_NAME Field
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.TraceInfo.TRACE_LOG_FILE_NAME"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TRACE_LOG_FILE_NAME
Visual Basic
Public Const TRACE_LOG_FILE_NAME As String
Visual C++
public:
literal String^ TRACE_LOG_FILE_NAME

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TRACE_LOG_MUTEX_NAME Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TRACE_LOG_MUTEX_NAME Field
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.TraceInfo.TRACE_LOG_MUTEX_NAME"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TRACE_LOG_MUTEX_NAME
Visual Basic
Public Const TRACE_LOG_MUTEX_NAME As String
Visual C++
public:
literal String^ TRACE_LOG_MUTEX_NAME

See Also

TraceInfo Class
ArtOfTest.Common Namespace


UIAutomation Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..UIAutomation Field
TraceInfo Class See Also Send Feedback
For anything dealing specifically with UI Automation, or System.Windows.Automation in particular.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory UIAutomation
Visual Basic
Public Shared ReadOnly UIAutomation As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ UIAutomation

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Uncategorized Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Uncategorized Field
TraceInfo Class See Also Send Feedback
For code that still uses old trace statements.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Uncategorized
Visual Basic
Public Shared ReadOnly Uncategorized As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Uncategorized

See Also

TraceInfo Class
ArtOfTest.Common Namespace


User Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..User Field
TraceInfo Class See Also Send Feedback
For code written by framework users. The other categories are subject to change and should not be used by anyone outside of Telerik.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory User
Visual Basic
Public Shared ReadOnly User As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ User

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Warning Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Warning Field
TraceInfo Class See Also Send Feedback
This is a category for things that merely ought not to happen in a perfect world. Take these more seriously than the other categories but less seriously than Error.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Warning
Visual Basic
Public Shared ReadOnly Warning As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Warning

See Also

TraceInfo Class
ArtOfTest.Common Namespace


WebServices Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..WebServices Field
TraceInfo Class See Also Send Feedback
Preliminary new category (not finalized yet).

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory WebServices
Visual Basic
Public Shared ReadOnly WebServices As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ WebServices

See Also

TraceInfo Class
ArtOfTest.Common Namespace


Window Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..Window Field
TraceInfo Class See Also Send Feedback
This category is used for anything relating to native UI controls (ex. HWND) or framework wrappers (Form or Window).

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory Window
Visual Basic
Public Shared ReadOnly Window As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ Window

See Also

TraceInfo Class
ArtOfTest.Common Namespace


WindowsServices Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..WindowsServices Field
TraceInfo Class See Also Send Feedback
This category is for any general infrastructure regarding NT services (Load Agent, Profiler, Scheduler, etc).

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly TraceInfo..::..TraceCategory WindowsServices
Visual Basic
Public Shared ReadOnly WindowsServices As TraceInfo..::..TraceCategory
Visual C++
public:
static initonly TraceInfo..::..TraceCategory^ WindowsServices

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo Methods
TraceInfo Class See Also Send Feedback

The TraceInfo type exposes the following members.

Methods

Name | Description
DebugBreak | This version of Debugger.Break launches the debugger if not attached, rather than silently failing.
GenerateStackFrameFunctionName |
GetTraceInfoName |
OpenTraceLog | This shell-executes the trace log file. We don't decide what program to run and we really don't want to impose Notepad.
RecordTime |
SetTraceInfoName | In debug builds this uses an internal thread naming system for situations where the thread can't be named or named multiple times. In release builds it simply writes directly to the Thread.Name property.
StartTimer |
TraceNullOrNot |
TraceReturnValue |

See Also

TraceInfo Class
ArtOfTest.Common Namespace


DebugBreak Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..DebugBreak Method
TraceInfo Class See Also Send Feedback
This version of Debugger.Break launches the debugger if not attached, rather than silently failing.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void DebugBreak()
Visual Basic
Public Shared Sub DebugBreak
Visual C++
public:
static void DebugBreak()

See Also

TraceInfo Class
ArtOfTest.Common Namespace


GenerateStackFrameFunctionName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..GenerateStackFrameFunctionName Method
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.GenerateStackFrameFunctionName(System.Diagnostics.StackFrame)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GenerateStackFrameFunctionName(
    StackFrame frame
)
Visual Basic
Public Shared Function GenerateStackFrameFunctionName ( _
    frame As StackFrame _
) As String
Visual C++
public:
static String^ GenerateStackFrameFunctionName(
    StackFrame^ frame
)

Parameters

frame
Type: System.Diagnostics..::..StackFrame

[Missing <param name="frame"/> documentation for "M:ArtOfTest.Common.TraceInfo.GenerateStackFrameFunctionName(System.Diagnostics.StackFrame)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.TraceInfo.GenerateStackFrameFunctionName(System.Diagnostics.StackFrame)"]

See Also

TraceInfo Class
ArtOfTest.Common Namespace


GetTraceInfoName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..GetTraceInfoName Method
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.GetTraceInfoName(System.Threading.Thread)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GetTraceInfoName(
    this Thread thread
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetTraceInfoName ( _
    thread As Thread _
) As String
Visual C++
[ExtensionAttribute]
public:
static String^ GetTraceInfoName(
    Thread^ thread
)

Parameters

thread
Type: System.Threading..::..Thread

[Missing <param name="thread"/> documentation for "M:ArtOfTest.Common.TraceInfo.GetTraceInfoName(System.Threading.Thread)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.TraceInfo.GetTraceInfoName(System.Threading.Thread)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Thread. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

TraceInfo Class
ArtOfTest.Common Namespace


OpenTraceLog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..OpenTraceLog Method
TraceInfo Class See Also Send Feedback
This shell-executes the trace log file. We don't decide what program to run and we really don't want to impose Notepad.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void OpenTraceLog()
Visual Basic
Public Shared Sub OpenTraceLog
Visual C++
public:
static void OpenTraceLog()

See Also

TraceInfo Class
ArtOfTest.Common Namespace


RecordTime Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..RecordTime Method
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.RecordTime(System.String)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void RecordTime(
    string message
)
Visual Basic
Public Shared Sub RecordTime ( _
    message As String _
)
Visual C++
public:
static void RecordTime(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.Common.TraceInfo.RecordTime(System.String)"]

See Also

TraceInfo Class
ArtOfTest.Common Namespace


SetTraceInfoName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..SetTraceInfoName Method
TraceInfo Class See Also Send Feedback
In debug builds this uses an internal thread naming system for situations where the thread can't be named or named multiple times. In release builds it simply writes directly to the Thread.Name property.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SetTraceInfoName(
    this Thread thread,
    string strName
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub SetTraceInfoName ( _
    thread As Thread, _
    strName As String _
)
Visual C++
[ExtensionAttribute]
public:
static void SetTraceInfoName(
    Thread^ thread,
    String^ strName
)

Parameters

thread
Type: System.Threading..::..Thread

[Missing <param name="thread"/> documentation for "M:ArtOfTest.Common.TraceInfo.SetTraceInfoName(System.Threading.Thread,System.String)"]

strName
Type: System..::..String

[Missing <param name="strName"/> documentation for "M:ArtOfTest.Common.TraceInfo.SetTraceInfoName(System.Threading.Thread,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Thread. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

TraceInfo Class
ArtOfTest.Common Namespace


StartTimer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..StartTimer Method
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.StartTimer"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void StartTimer()
Visual Basic
Public Shared Sub StartTimer
Visual C++
public:
static void StartTimer()

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceNullOrNot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceNullOrNot Method
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceNullOrNot(System.Object,System.String)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void TraceNullOrNot(
    Object o,
    string strObjectName
)
Visual Basic
Public Shared Sub TraceNullOrNot ( _
    o As Object, _
    strObjectName As String _
)
Visual C++
public:
static void TraceNullOrNot(
    Object^ o,
    String^ strObjectName
)

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceNullOrNot(System.Object,System.String)"]

strObjectName
Type: System..::..String

[Missing <param name="strObjectName"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceNullOrNot(System.Object,System.String)"]

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceReturnValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceReturnValue Method
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceReturnValue(System.Object,System.String)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void TraceReturnValue(
    Object returnValue,
    string functionName
)
Visual Basic
Public Shared Sub TraceReturnValue ( _
    returnValue As Object, _
    functionName As String _
)
Visual C++
public:
static void TraceReturnValue(
    Object^ returnValue,
    String^ functionName
)

Parameters

returnValue
Type: System..::..Object

[Missing <param name="returnValue"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceReturnValue(System.Object,System.String)"]

functionName
Type: System..::..String

[Missing <param name="functionName"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceReturnValue(System.Object,System.String)"]

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo Properties
TraceInfo Class See Also Send Feedback

The TraceInfo type exposes the following members.

Properties

Name | Description
TraceLogFileCache |
TraceLogFileCacheLineCount |
TraceLogFileEnabled |
TraceLogFileOmittedCategories |
TraceLogFilePath |

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceLogFileCache Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceLogFileCache Property
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.TraceInfo.TraceLogFileCache"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static List<string> TraceLogFileCache { get; }
Visual Basic
Public Shared ReadOnly Property TraceLogFileCache As List(Of String)
    Get
Visual C++
public:
static property List<String^>^ TraceLogFileCache {
    List<String^>^ get ();
}

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceLogFileCacheLineCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceLogFileCacheLineCount Property
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.TraceInfo.TraceLogFileCacheLineCount"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int TraceLogFileCacheLineCount { get; set; }
Visual Basic
Public Shared Property TraceLogFileCacheLineCount As Integer
    Get
    Set
Visual C++
public:
static property int TraceLogFileCacheLineCount {
    int get ();
    void set (int value);
}

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceLogFileEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceLogFileEnabled Property
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.TraceInfo.TraceLogFileEnabled"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool TraceLogFileEnabled { get; set; }
Visual Basic
Public Shared Property TraceLogFileEnabled As Boolean
    Get
    Set
Visual C++
public:
static property bool TraceLogFileEnabled {
    bool get ();
    void set (bool value);
}

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceLogFileOmittedCategories Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceLogFileOmittedCategories Property
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.TraceInfo.TraceLogFileOmittedCategories"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static HashSet<string> TraceLogFileOmittedCategories { get; }
Visual Basic
Public Shared ReadOnly Property TraceLogFileOmittedCategories As HashSet(Of String)
    Get
Visual C++
public:
static property HashSet<String^>^ TraceLogFileOmittedCategories {
    HashSet<String^>^ get ();
}

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceLogFilePath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceLogFilePath Property
TraceInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.TraceInfo.TraceLogFilePath"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string TraceLogFilePath { get; set; }
Visual Basic
Public Shared Property TraceLogFilePath As String
    Get
    Set
Visual C++
public:
static property String^ TraceLogFilePath {
    String^ get ();
    void set (String^ value);
}

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceInfo Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo Events
TraceInfo Class See Also Send Feedback

The TraceInfo type exposes the following members.

Events

Name | Description
TraceSettingsChanged | Special event. If the provided method belongs to a class that derives from DispatcherObject, the callback is called using Dispatcher.BeginInvoke. If it belongs to a class that derives from System.Windows.Forms.Control, it is called using Control.BeginInvoke. Otherwise it is called from the thread pool.

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceSettingsChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceSettingsChanged Event
TraceInfo Class See Also Send Feedback
Special event. If the provided method belongs to a class that derives from DispatcherObject, the callback is called using Dispatcher.BeginInvoke. If it belongs to a class that derives from System.Windows.Forms.Control, it is called using Control.BeginInvoke. Otherwise it is called from the thread pool.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static event Action TraceSettingsChanged
Visual Basic
Public Shared Event TraceSettingsChanged As Action
Visual C++
public:
static  event Action^ TraceSettingsChanged {
    void add (Action^ value);
    void remove (Action^ value);
}

See Also

TraceInfo Class
ArtOfTest.Common Namespace


TraceInfo.TraceCategory Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory Members
TraceInfo..::..TraceCategory Class Methods Fields Properties See Also Send Feedback

Tracing helper classed. All calls log directly to the System.Diagnostics.Trace

The TraceInfo..::..TraceCategory type exposes the following members.

Methods

 | Name | Description
Public method | DebugWriteLine |
Public method | EndFunctionScope |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostedWriteLine |
Public method | ReportCallstack |
Public method | ReportException |
Public method | ReportProcessLaunched |
Public method | ReportProcessTermination |
Public method | ReportSystemVersion |
Public method | StartFunctionScope |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | WriteLine(Int32, String) |
Public method | WriteLine(String, array<Object>[]()[][]) |
Public method | WriteLineIf |

Fields

 | Name | Description
Protected field | _bEnabled |
Protected field | _strCategory |
 | LEFT_NESTING_MARGIN |

Properties

 | Name | Description
Public property | Enabled |
Public property | Permitted |

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


TraceInfo.TraceCategory Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory Fields
TraceInfo..::..TraceCategory Class See Also Send Feedback

The TraceInfo..::..TraceCategory type exposes the following members.

Fields

 | Name | Description
Protected field | _bEnabled |
Protected field | _strCategory |
 | LEFT_NESTING_MARGIN |

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


_bEnabled Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::.._bEnabled Field
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.TraceInfo.TraceCategory._bEnabled"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool _bEnabled
Visual Basic
Protected _bEnabled As Boolean
Visual C++
protected:
bool _bEnabled

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


_strCategory Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::.._strCategory Field
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.TraceInfo.TraceCategory._strCategory"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected string _strCategory
Visual Basic
Protected _strCategory As String
Visual C++
protected:
String^ _strCategory

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


LEFT_NESTING_MARGIN Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..LEFT_NESTING_MARGIN Field
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.TraceInfo.TraceCategory.LEFT_NESTING_MARGIN"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected const string LEFT_NESTING_MARGIN
Visual Basic
Protected Const LEFT_NESTING_MARGIN As String
Visual C++
protected:
literal String^ LEFT_NESTING_MARGIN

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


TraceInfo.TraceCategory Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory Methods
TraceInfo..::..TraceCategory Class See Also Send Feedback

The TraceInfo..::..TraceCategory type exposes the following members.

Methods

 | Name | Description
Public method | DebugWriteLine |
Public method | EndFunctionScope |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PostedWriteLine |
Public method | ReportCallstack |
Public method | ReportException |
Public method | ReportProcessLaunched |
Public method | ReportProcessTermination |
Public method | ReportSystemVersion |
Public method | StartFunctionScope |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | WriteLine(Int32, String) |
Public method | WriteLine(String, array<Object>[]()[][]) |
Public method | WriteLineIf |

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


DebugWriteLine Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..DebugWriteLine Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.DebugWriteLine(System.String,System.Object[])"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DebugWriteLine(
    string strFormat,
    params Object[] args
)
Visual Basic
Public Overridable Sub DebugWriteLine ( _
    strFormat As String, _
    ParamArray args As Object() _
)
Visual C++
public:
virtual void DebugWriteLine(
    String^ strFormat,
    ... array<Object^>^ args
)

Parameters

strFormat
Type: System..::..String

[Missing <param name="strFormat"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.DebugWriteLine(System.String,System.Object[])"]

args
Type: array< System..::..Object >[]()[][]

[Missing <param name="args"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.DebugWriteLine(System.String,System.Object[])"]

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


EndFunctionScope Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..EndFunctionScope Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.EndFunctionScope"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void EndFunctionScope()
Visual Basic
Public Overridable Sub EndFunctionScope
Visual C++
public:
virtual void EndFunctionScope()

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


PostedWriteLine Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..PostedWriteLine Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.PostedWriteLine(System.String,System.Object[])"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void PostedWriteLine(
    string strFormat,
    params Object[] args
)
Visual Basic
Public Overridable Sub PostedWriteLine ( _
    strFormat As String, _
    ParamArray args As Object() _
)
Visual C++
public:
virtual void PostedWriteLine(
    String^ strFormat,
    ... array<Object^>^ args
)

Parameters

strFormat
Type: System..::..String

[Missing <param name="strFormat"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.PostedWriteLine(System.String,System.Object[])"]

args
Type: array< System..::..Object >[]()[][]

[Missing <param name="args"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.PostedWriteLine(System.String,System.Object[])"]

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


ReportCallstack Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..ReportCallstack Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportCallstack"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ReportCallstack()
Visual Basic
Public Overridable Sub ReportCallstack
Visual C++
public:
virtual void ReportCallstack()

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


ReportException Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..ReportException Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportException(System.Exception,System.String,System.Object[])"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ReportException(
    Exception sourceException,
    string strContextMessage,
    params Object[] args
)
Visual Basic
Public Overridable Sub ReportException ( _
    sourceException As Exception, _
    strContextMessage As String, _
    ParamArray args As Object() _
)
Visual C++
public:
virtual void ReportException(
    Exception^ sourceException,
    String^ strContextMessage,
    ... array<Object^>^ args
)

Parameters

sourceException
Type: System..::..Exception

[Missing <param name="sourceException"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportException(System.Exception,System.String,System.Object[])"]

strContextMessage
Type: System..::..String

[Missing <param name="strContextMessage"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportException(System.Exception,System.String,System.Object[])"]

args
Type: array< System..::..Object >[]()[][]

[Missing <param name="args"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportException(System.Exception,System.String,System.Object[])"]

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


ReportProcessLaunched Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..ReportProcessLaunched Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportProcessLaunched(System.Diagnostics.Process,System.Diagnostics.ProcessStartInfo)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ReportProcessLaunched(
    Process process,
    ProcessStartInfo startInfo
)
Visual Basic
Public Overridable Sub ReportProcessLaunched ( _
    process As Process, _
    startInfo As ProcessStartInfo _
)
Visual C++
public:
virtual void ReportProcessLaunched(
    Process^ process,
    ProcessStartInfo^ startInfo
)

Parameters

process
Type: System.Diagnostics..::..Process

[Missing <param name="process"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportProcessLaunched(System.Diagnostics.Process,System.Diagnostics.ProcessStartInfo)"]

startInfo
Type: System.Diagnostics..::..ProcessStartInfo

[Missing <param name="startInfo"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportProcessLaunched(System.Diagnostics.Process,System.Diagnostics.ProcessStartInfo)"]

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


ReportProcessTermination Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..ReportProcessTermination Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportProcessTermination(System.Diagnostics.Process,System.Boolean)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ReportProcessTermination(
    Process process,
    bool bExited
)
Visual Basic
Public Overridable Sub ReportProcessTermination ( _
    process As Process, _
    bExited As Boolean _
)
Visual C++
public:
virtual void ReportProcessTermination(
    Process^ process,
    bool bExited
)

Parameters

process
Type: System.Diagnostics..::..Process

[Missing <param name="process"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportProcessTermination(System.Diagnostics.Process,System.Boolean)"]

bExited
Type: System..::..Boolean

[Missing <param name="bExited"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportProcessTermination(System.Diagnostics.Process,System.Boolean)"]

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


ReportSystemVersion Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..ReportSystemVersion Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.ReportSystemVersion"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ReportSystemVersion()
Visual Basic
Public Overridable Sub ReportSystemVersion
Visual C++
public:
virtual void ReportSystemVersion()

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


StartFunctionScope Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..StartFunctionScope Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.StartFunctionScope"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void StartFunctionScope()
Visual Basic
Public Overridable Sub StartFunctionScope
Visual C++
public:
virtual void StartFunctionScope()

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


WriteLine Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..WriteLine Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | WriteLine(Int32, String) |
Public method | WriteLine(String, array<Object>[]()[][]) |

See Also

TraceInfo..::..TraceCategory Class
TraceInfo..::..TraceCategory Members
ArtOfTest.Common Namespace


WriteLine Method (Int32, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..WriteLine Method (Int32, String)
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLine(System.Int32,System.String)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void WriteLine(
    int iMinimumCallDepthSkip,
    string strLine
)
Visual Basic
Protected Sub WriteLine ( _
    iMinimumCallDepthSkip As Integer, _
    strLine As String _
)
Visual C++
protected:
void WriteLine(
    int iMinimumCallDepthSkip,
    String^ strLine
)

Parameters

iMinimumCallDepthSkip
Type: System..::..Int32
The number of stack frames we are removed from the domain-specific code generating the source trace data.
strLine
Type: System..::..String

[Missing <param name="strLine"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLine(System.Int32,System.String)"]

See Also

TraceInfo..::..TraceCategory Class
WriteLine Overload
ArtOfTest.Common Namespace


WriteLine Method (String, Object[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..WriteLine Method (String, array<Object>[]()[][])
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLine(System.String,System.Object[])"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void WriteLine(
    string strFormat,
    params Object[] args
)
Visual Basic
Public Overridable Sub WriteLine ( _
    strFormat As String, _
    ParamArray args As Object() _
)
Visual C++
public:
virtual void WriteLine(
    String^ strFormat,
    ... array<Object^>^ args
)

Parameters

strFormat
Type: System..::..String

[Missing <param name="strFormat"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLine(System.String,System.Object[])"]

args
Type: array< System..::..Object >[]()[][]

[Missing <param name="args"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLine(System.String,System.Object[])"]

See Also

TraceInfo..::..TraceCategory Class
WriteLine Overload
ArtOfTest.Common Namespace


WriteLineIf Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..WriteLineIf Method
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLineIf(System.Boolean,System.String,System.Object[])"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void WriteLineIf(
    bool bCondition,
    string strFormat,
    params Object[] args
)
Visual Basic
Public Overridable Sub WriteLineIf ( _
    bCondition As Boolean, _
    strFormat As String, _
    ParamArray args As Object() _
)
Visual C++
public:
virtual void WriteLineIf(
    bool bCondition,
    String^ strFormat,
    ... array<Object^>^ args
)

Parameters

bCondition
Type: System..::..Boolean

[Missing <param name="bCondition"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLineIf(System.Boolean,System.String,System.Object[])"]

strFormat
Type: System..::..String

[Missing <param name="strFormat"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLineIf(System.Boolean,System.String,System.Object[])"]

args
Type: array< System..::..Object >[]()[][]

[Missing <param name="args"/> documentation for "M:ArtOfTest.Common.TraceInfo.TraceCategory.WriteLineIf(System.Boolean,System.String,System.Object[])"]

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


TraceInfo.TraceCategory Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory Properties
TraceInfo..::..TraceCategory Class See Also Send Feedback

The TraceInfo..::..TraceCategory type exposes the following members.

Properties

 | Name | Description
Public property | Enabled |
Public property | Permitted |

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


Enabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..Enabled Property
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.TraceInfo.TraceCategory.Enabled"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


Permitted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TraceInfo..::..TraceCategory..::..Permitted Property
TraceInfo..::..TraceCategory Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.TraceInfo.TraceCategory.Permitted"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Permitted { get; }
Visual Basic
Public ReadOnly Property Permitted As Boolean
    Get
Visual C++
public:
property bool Permitted {
    bool get ();
}

See Also

TraceInfo..::..TraceCategory Class
ArtOfTest.Common Namespace


TreeCrawler(T, V, R) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)> Members
TreeCrawler<(Of <(<'T, V, R>)>)> Class Constructors Methods Properties See Also Send Feedback

The TreeCrawler<(Of <(<'T, V, R>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | TreeCrawler<(Of <(<'T, V, R>)>)> | Initializes a new instance of the TreeCrawler<(Of <(<'T, V, R>)>)> class

Methods

 | Name | Description
Public method | AllByCustom | Find all matches that match custom search logic
Public method | AllByExpression(V) | Finds all the elements in the tree that match the find expression.
Public method | AllByExpression(T, V) | Finds all the elements in the tree that match the find expression.
Public method | ByCustom | Find using custom logic.
Public method | ByExpression(V) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(T, V) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(V, Boolean) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(T, V, Boolean) | Finds the first element in the tree that matches the find expression.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindUsingExpressionPath | Find an element using expression paths starting at startNode.
Public method | FindUsingHierarchicalClause | Find a node using a hierarchical clause (XPATH, TagIndex...etc)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LastUsedExpression | The last FindExpression used by this Crawler.
Public property | SearchRoot | Gets the SearchRoot for this crawler.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


TreeCrawler(T, V, R) Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)> Constructor
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Initializes a new instance of the TreeCrawler<(Of <(<'T, V, R>)>)> class

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected TreeCrawler()
Visual Basic
Protected Sub New
Visual C++
protected:
TreeCrawler()

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


TreeCrawler(T, V, R) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)> Methods
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback

The TreeCrawler<(Of <(<'T, V, R>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AllByCustom | Find all matches that match custom search logic
Public method | AllByExpression(V) | Finds all the elements in the tree that match the find expression.
Public method | AllByExpression(T, V) | Finds all the elements in the tree that match the find expression.
Public method | ByCustom | Find using custom logic.
Public method | ByExpression(V) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(T, V) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(V, Boolean) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(T, V, Boolean) | Finds the first element in the tree that matches the find expression.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindUsingExpressionPath | Find an element using expression paths starting at startNode.
Public method | FindUsingHierarchicalClause | Find a node using a hierarchical clause (XPATH, TagIndex...etc)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


AllByCustom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..AllByCustom Method
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Find all matches that match custom search logic

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IList<T> AllByCustom(
    T startNode,
    Predicate<T> customLogic,
    bool includeRoot
)
Visual Basic
Public Overridable Function AllByCustom ( _
    startNode As T, _
    customLogic As Predicate(Of T), _
    includeRoot As Boolean _
) As IList(Of T)
Visual C++
public:
virtual IList<T>^ AllByCustom(
    T startNode,
    Predicate<T>^ customLogic,
    bool includeRoot
)

Parameters

startNode
Type: T
The start node of the search
customLogic
Type: System..::..Predicate <(Of <(<' T >)>)>
The custom logic to use
includeRoot
Type: System..::..Boolean
Whether to include the root or not.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.TreeCrawler`3.AllByCustom(`0,System.Predicate{`0},System.Boolean)"]

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


AllByExpression Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..AllByExpression Method
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByExpression(V) | Finds all the elements in the tree that match the find expression.
Public method | AllByExpression(T, V) | Finds all the elements in the tree that match the find expression.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
TreeCrawler<(Of <(<'T, V, R>)>)> Members
ArtOfTest.Common Namespace


AllByExpression Method (V)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..AllByExpression Method (V)
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Finds all the elements in the tree that match the find expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IList<T> AllByExpression(
    V expression
)
Visual Basic
Public Overridable Function AllByExpression ( _
    expression As V _
) As IList(Of T)
Visual C++
public:
virtual IList<T>^ AllByExpression(
    V expression
)

Parameters

expression
Type: V
The find expression.

Return Value

A list of all elements that match the expression or an empty list if nothing is found.

Remarks

Uses this.SearchRoot as the search root

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
AllByExpression Overload
ArtOfTest.Common Namespace


AllByExpression Method (T, V)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..AllByExpression Method (T, V)
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Finds all the elements in the tree that match the find expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IList<T> AllByExpression(
    T startNode,
    V expression
)
Visual Basic
Public Overridable Function AllByExpression ( _
    startNode As T, _
    expression As V _
) As IList(Of T)
Visual C++
public:
virtual IList<T>^ AllByExpression(
    T startNode,
    V expression
)

Parameters

startNode
Type: T
The root node of the tree to search.
expression
Type: V
The find expression.

Return Value

A list of all elements that match the expression or an empty list if nothing is found.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
AllByExpression Overload
ArtOfTest.Common Namespace


ByCustom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByCustom Method
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Find using custom logic.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T ByCustom(
    T startNode,
    Predicate<T> customLogic,
    bool includeRoot
)
Visual Basic
Public Overridable Function ByCustom ( _
    startNode As T, _
    customLogic As Predicate(Of T), _
    includeRoot As Boolean _
) As T
Visual C++
public:
virtual T ByCustom(
    T startNode,
    Predicate<T>^ customLogic,
    bool includeRoot
)

Parameters

startNode
Type: T
The start node.
customLogic
Type: System..::..Predicate <(Of <(<' T >)>)>
Custom predicate.
includeRoot
Type: System..::..Boolean
True/False whether to search the root node.

Return Value

The found element else null.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


ByExpression Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByExpression Method
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByExpression(V) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(T, V) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(V, Boolean) | Finds the first element in the tree that matches the find expression.
Public method | ByExpression(T, V, Boolean) | Finds the first element in the tree that matches the find expression.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
TreeCrawler<(Of <(<'T, V, R>)>)> Members
ArtOfTest.Common Namespace


ByExpression Method (V)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByExpression Method (V)
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Finds the first element in the tree that matches the find expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T ByExpression(
    V expression
)
Visual Basic
Public Overridable Function ByExpression ( _
    expression As V _
) As T
Visual C++
public:
virtual T ByExpression(
    V expression
)

Parameters

expression
Type: V
The find expression.

Return Value

The first element it finds else null.

Remarks

This overload does not include the root node in the search.

Remarks

Uses this.SearchRoot as the search root

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ByExpression Overload
ArtOfTest.Common Namespace


ByExpression Method (T, V)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByExpression Method (T, V)
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Finds the first element in the tree that matches the find expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T ByExpression(
    T startNode,
    V expression
)
Visual Basic
Public Overridable Function ByExpression ( _
    startNode As T, _
    expression As V _
) As T
Visual C++
public:
virtual T ByExpression(
    T startNode,
    V expression
)

Parameters

startNode
Type: T
The root node of the tree to search.
expression
Type: V
The find expression.

Return Value

The first element it finds else null.

Remarks

This overload does not include the root node in the search.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ByExpression Overload
ArtOfTest.Common Namespace


ByExpression Method (V, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByExpression Method (V, Boolean)
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Finds the first element in the tree that matches the find expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T ByExpression(
    V expression,
    bool includeRoot
)
Visual Basic
Public Overridable Function ByExpression ( _
    expression As V, _
    includeRoot As Boolean _
) As T
Visual C++
public:
virtual T ByExpression(
    V expression,
    bool includeRoot
)

Parameters

expression
Type: V
The find expression.
includeRoot
Type: System..::..Boolean
Whether to include the root node in the search

Return Value

The first element it finds else null.

Remarks

Uses this.SearchRoot as the search root

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ByExpression Overload
ArtOfTest.Common Namespace


ByExpression Method (T, V, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByExpression Method (T, V, Boolean)
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Finds the first element in the tree that matches the find expression.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T ByExpression(
    T startNode,
    V expression,
    bool includeRoot
)
Visual Basic
Public Overridable Function ByExpression ( _
    startNode As T, _
    expression As V, _
    includeRoot As Boolean _
) As T
Visual C++
public:
virtual T ByExpression(
    T startNode,
    V expression,
    bool includeRoot
)

Parameters

startNode
Type: T
The root node of the tree to search.
expression
Type: V
The find expression.
includeRoot
Type: System..::..Boolean
Whether to include the root node in the search.

Return Value

The first element it finds, else null.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ByExpression Overload
ArtOfTest.Common Namespace


FindUsingExpressionPath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..FindUsingExpressionPath Method
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Find an element using expression paths starting at startNode.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T FindUsingExpressionPath(
    T startNode,
    string expPath,
    out T failureLocation
)
Visual Basic
Public Function FindUsingExpressionPath ( _
    startNode As T, _
    expPath As String, _
    <OutAttribute> ByRef failureLocation As T _
) As T
Visual C++
public:
T FindUsingExpressionPath(
    T startNode,
    String^ expPath,
    [OutAttribute] T% failureLocation
)

Parameters

startNode
Type: T
The start node.
expPath
Type: System..::..String
The expression path
failureLocation
Type: T %
In case it didn't find a target, will return the failure location in the tree, where the search stopped

Return Value

The found node, else null.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


FindUsingHierarchicalClause Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..FindUsingHierarchicalClause Method
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Find a node using a hierarchical clause (XPATH, TagIndex...etc)

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract T FindUsingHierarchicalClause(
    T startNode,
    R clause
)
Visual Basic
Public MustOverride Function FindUsingHierarchicalClause ( _
    startNode As T, _
    clause As R _
) As T
Visual C++
public:
virtual T FindUsingHierarchicalClause(
    T startNode,
    R clause
) abstract

Parameters

startNode
Type: T
The node to start with.
clause
Type: R
The clause to use

Return Value

The found element else null;

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


TreeCrawler(T, V, R) Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)> Properties
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback

The TreeCrawler<(Of <(<'T, V, R>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | LastUsedExpression | The last FindExpression used by this Crawler.
Public property | SearchRoot | Gets the SearchRoot for this crawler.

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


LastUsedExpression Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..LastUsedExpression Property
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
The last FindExpression used by this Crawler.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public V LastUsedExpression { get; protected set; }
Visual Basic
Public Property LastUsedExpression As V
    Get
    Protected Set
Visual C++
public:
property V LastUsedExpression {
    V get ();
    protected: void set (V value);
}

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


SearchRoot Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeCrawler<(Of <(<'T, V, R>)>)>..::..SearchRoot Property
TreeCrawler<(Of <(<'T, V, R>)>)> Class See Also Send Feedback
Gets the SearchRoot for this crawler.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T SearchRoot { get; internal set; }
Visual Basic
Public Overridable Property SearchRoot As T
    Get
    Friend Set
Visual C++
public:
virtual property T SearchRoot {
    T get ();
    internal: void set (T value);
}

See Also

TreeCrawler<(Of <(<'T, V, R>)>)> Class
ArtOfTest.Common Namespace


Utils Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils Members
Utils Class Methods Fields Properties See Also Send Feedback

The Utils type exposes the following members.

Methods

Name | Description
Compress | Compresses a file
CropBitmap(Bitmap, Rectangle) | Cuts a bitmap at the specified cut rectangle.
CropBitmap(Bitmap, RectangleF) | Cuts a bitmap at the specified cut rectangle.
Decompress | Decompresses a previously compressed file
EscapeSingleQuotes |
FindFinalizerThread | Creates a dummy object and then forces a full finalization in order to detect the finalizer thread. Useful when seeking to assign a name to the thread.
FullDomainName |
GenerateHash | Computes the hash of the given string. The default is to use the SHA1 algorithm.
GetDateTimeIntersection | Given two sets of DateTimes return the TimeSpan for which they overlap
GetFirstVisibleControl |
GetSubstitutedFrameInfo |
IsVistaOrLater |
IsWin7OrLater |
JSGetContentWindowHeight |
JSGetContentWindowWidth |
QueryAssemblyInfo |
Swap<(Of <<'(T>)>>) |
TryEnterRunOnceNamedLock |

Fields

Name | Description
dpiXFactor |

Properties

Name | Description
ScalingFactorX |
ScalingFactorY |

See Also

Utils Class
ArtOfTest.Common Namespace


Utils Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils Fields
Utils Class See Also Send Feedback

The Utils type exposes the following members.

Fields

Name | Description
dpiXFactor |

See Also

Utils Class
ArtOfTest.Common Namespace


dpiXFactor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..dpiXFactor Field
Utils Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.Utils.dpiXFactor"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static double dpiXFactor
Visual Basic
Public Shared dpiXFactor As Double
Visual C++
public:
static double dpiXFactor

See Also

Utils Class
ArtOfTest.Common Namespace


Utils Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils Methods
Utils Class See Also Send Feedback

The Utils type exposes the following members.

Methods

Name | Description
Compress | Compresses a file
CropBitmap(Bitmap, Rectangle) | Cuts a bitmap at the specified cut rectangle.
CropBitmap(Bitmap, RectangleF) | Cuts a bitmap at the specified cut rectangle.
Decompress | Decompresses a previously compressed file
EscapeSingleQuotes |
FindFinalizerThread | Creates a dummy object and then forces a full finalization in order to detect the finalizer thread. Useful when seeking to assign a name to the thread.
FullDomainName |
GenerateHash | Computes the hash of the given string. The default is to use the SHA1 algorithm.
GetDateTimeIntersection | Given two sets of DateTimes return the TimeSpan for which they overlap
GetFirstVisibleControl |
GetSubstitutedFrameInfo |
IsVistaOrLater |
IsWin7OrLater |
JSGetContentWindowHeight |
JSGetContentWindowWidth |
QueryAssemblyInfo |
Swap<(Of <<'(T>)>>) |
TryEnterRunOnceNamedLock |

See Also

Utils Class
ArtOfTest.Common Namespace


Compress Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..Compress Method
Utils Class See Also Send Feedback
Compresses a file

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FileInfo Compress(
    FileInfo inFileInfo
)
Visual Basic
Public Shared Function Compress ( _
    inFileInfo As FileInfo _
) As FileInfo
Visual C++
public:
static FileInfo^ Compress(
    FileInfo^ inFileInfo
)

Parameters

inFileInfo
Type: System.IO..::..FileInfo
FileInfo about the file to compress

Return Value

FileInfo about the compressed file, or null if InFileInfo is hidden or already compressed

See Also

Utils Class
ArtOfTest.Common Namespace


CropBitmap Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..CropBitmap Method
Utils Class See Also Send Feedback

Overload List

Name | Description
CropBitmap(Bitmap, Rectangle) | Cuts a bitmap at the specified cut rectangle.
CropBitmap(Bitmap, RectangleF) | Cuts a bitmap at the specified cut rectangle.

See Also

Utils Class
Utils Members
ArtOfTest.Common Namespace


CropBitmap Method (Bitmap, Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..CropBitmap Method (Bitmap, Rectangle)
Utils Class See Also Send Feedback
Cuts a bitmap at the specified cut rectangle.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Bitmap CropBitmap(
    Bitmap original,
    Rectangle cutArea
)
Visual Basic
Public Shared Function CropBitmap ( _
    original As Bitmap, _
    cutArea As Rectangle _
) As Bitmap
Visual C++
public:
static Bitmap^ CropBitmap(
    Bitmap^ original,
    Rectangle cutArea
)

Parameters

original
Type: System.Drawing..::..Bitmap
The original bitmap.
cutArea
Type: System.Drawing..::..Rectangle
The desired cut area.

Return Value

The new cut bitmap. If cutArea extends beyond the boundaries of original, the area that does fit within original will be returned.

See Also

Utils Class
CropBitmap Overload
ArtOfTest.Common Namespace


CropBitmap Method (Bitmap, RectangleF)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..CropBitmap Method (Bitmap, RectangleF)
Utils Class See Also Send Feedback
Cuts a bitmap at the specified cut rectangle.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Bitmap CropBitmap(
    Bitmap original,
    RectangleF cutArea
)
Visual Basic
Public Shared Function CropBitmap ( _
    original As Bitmap, _
    cutArea As RectangleF _
) As Bitmap
Visual C++
public:
static Bitmap^ CropBitmap(
    Bitmap^ original,
    RectangleF cutArea
)

Parameters

original
Type: System.Drawing..::..Bitmap
The original bitmap.
cutArea
Type: System.Drawing..::..RectangleF
The desired cut area.

Return Value

The new cut bitmap. If cutArea extends beyond the boundaries of original, the area that does fit within original will be returned.

See Also

Utils Class
CropBitmap Overload
ArtOfTest.Common Namespace


Decompress Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..Decompress Method
Utils Class See Also Send Feedback
Decompresses a previously compressed file

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FileInfo Decompress(
    FileInfo inFileInfo
)
Visual Basic
Public Shared Function Decompress ( _
    inFileInfo As FileInfo _
) As FileInfo
Visual C++
public:
static FileInfo^ Decompress(
    FileInfo^ inFileInfo
)

Parameters

inFileInfo
Type: System.IO..::..FileInfo
The file to decompress

Return Value

The original, decompressed file

See Also

Utils Class
ArtOfTest.Common Namespace


EscapeSingleQuotes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..EscapeSingleQuotes Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.EscapeSingleQuotes(System.String)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string EscapeSingleQuotes(
    string text
)
Visual Basic
Public Shared Function EscapeSingleQuotes ( _
    text As String _
) As String
Visual C++
public:
static String^ EscapeSingleQuotes(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.Common.Utils.EscapeSingleQuotes(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.EscapeSingleQuotes(System.String)"]

See Also

Utils Class
ArtOfTest.Common Namespace


FindFinalizerThread Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..FindFinalizerThread Method
Utils Class See Also Send Feedback
Creates a dummy object and then forces a full finalization in order to detect the finalizer thread. Useful when seeking to assign a name to the thread.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Thread FindFinalizerThread()
Visual Basic
Public Shared Function FindFinalizerThread As Thread
Visual C++
public:
static Thread^ FindFinalizerThread()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.FindFinalizerThread"]

See Also

Utils Class
ArtOfTest.Common Namespace


FullDomainName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..FullDomainName Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.FullDomainName(System.Net.NetworkCredential)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string FullDomainName(
    NetworkCredential credentials
)
Visual Basic
Public Shared Function FullDomainName ( _
    credentials As NetworkCredential _
) As String
Visual C++
public:
static String^ FullDomainName(
    NetworkCredential^ credentials
)

Parameters

credentials
Type: System.Net..::..NetworkCredential

[Missing <param name="credentials"/> documentation for "M:ArtOfTest.Common.Utils.FullDomainName(System.Net.NetworkCredential)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.FullDomainName(System.Net.NetworkCredential)"]

See Also

Utils Class
ArtOfTest.Common Namespace


GenerateHash Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..GenerateHash Method
Utils Class See Also Send Feedback
Computes the hash of the given string. The default is to use the SHA1 algorithm.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GenerateHash(
    string str
)
Visual Basic
Public Shared Function GenerateHash ( _
    str As String _
) As String
Visual C++
public:
static String^ GenerateHash(
    String^ str
)

Parameters

str
Type: System..::..String
The string to compute the hash of.

Return Value

The Bas64 string of the computed hash.

See Also

Utils Class
ArtOfTest.Common Namespace


GetDateTimeIntersection Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..GetDateTimeIntersection Method
Utils Class See Also Send Feedback
Given two sets of DateTimes return the TimeSpan for which they overlap

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static TimeSpan GetDateTimeIntersection(
    DateTime mainStart,
    DateTime mainEnd,
    DateTime intervalStart,
    DateTime intervalEnd,
    bool allowIntervalBeforeMain
)
Visual Basic
Public Shared Function GetDateTimeIntersection ( _
    mainStart As DateTime, _
    mainEnd As DateTime, _
    intervalStart As DateTime, _
    intervalEnd As DateTime, _
    allowIntervalBeforeMain As Boolean _
) As TimeSpan
Visual C++
public:
static TimeSpan GetDateTimeIntersection(
    DateTime mainStart,
    DateTime mainEnd,
    DateTime intervalStart,
    DateTime intervalEnd,
    bool allowIntervalBeforeMain
)

Parameters

mainStart
Type: System..::..DateTime
Beginning of first DateTime pair
mainEnd
Type: System..::..DateTime
End of first DateTime pair
intervalStart
Type: System..::..DateTime
Beginning of second DateTime pair
intervalEnd
Type: System..::..DateTime
End of second DateTime pair
allowIntervalBeforeMain
Type: System..::..Boolean

[Missing <param name="allowIntervalBeforeMain"/> documentation for "M:ArtOfTest.Common.Utils.GetDateTimeIntersection(System.DateTime,System.DateTime,System.DateTime,System.DateTime,System.Boolean)"]

Return Value

The timespan for which the two sets overlap

See Also

Utils Class
ArtOfTest.Common Namespace


GetFirstVisibleControl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..GetFirstVisibleControl Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.GetFirstVisibleControl(System.Windows.Media.Visual)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FrameworkElement GetFirstVisibleControl(
    Visual myVisual
)
Visual Basic
Public Shared Function GetFirstVisibleControl ( _
    myVisual As Visual _
) As FrameworkElement
Visual C++
public:
static FrameworkElement^ GetFirstVisibleControl(
    Visual^ myVisual
)

Parameters

myVisual
Type: System.Windows.Media..::..Visual

[Missing <param name="myVisual"/> documentation for "M:ArtOfTest.Common.Utils.GetFirstVisibleControl(System.Windows.Media.Visual)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.GetFirstVisibleControl(System.Windows.Media.Visual)"]

See Also

Utils Class
ArtOfTest.Common Namespace


GetSubstitutedFrameInfo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..GetSubstitutedFrameInfo Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.GetSubstitutedFrameInfo(System.Uri,ArtOfTest.WebAii.Core.FrameInfo)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FrameInfo GetSubstitutedFrameInfo(
    Uri baseUri,
    FrameInfo frameInfo
)
Visual Basic
Public Shared Function GetSubstitutedFrameInfo ( _
    baseUri As Uri, _
    frameInfo As FrameInfo _
) As FrameInfo
Visual C++
public:
static FrameInfo^ GetSubstitutedFrameInfo(
    Uri^ baseUri,
    FrameInfo^ frameInfo
)

Parameters

baseUri
Type: System..::..Uri

[Missing <param name="baseUri"/> documentation for "M:ArtOfTest.Common.Utils.GetSubstitutedFrameInfo(System.Uri,ArtOfTest.WebAii.Core.FrameInfo)"]

frameInfo
Type: ArtOfTest.WebAii.Core..::..FrameInfo

[Missing <param name="frameInfo"/> documentation for "M:ArtOfTest.Common.Utils.GetSubstitutedFrameInfo(System.Uri,ArtOfTest.WebAii.Core.FrameInfo)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.GetSubstitutedFrameInfo(System.Uri,ArtOfTest.WebAii.Core.FrameInfo)"]

See Also

Utils Class
ArtOfTest.Common Namespace


IsVistaOrLater Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..IsVistaOrLater Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.IsVistaOrLater"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsVistaOrLater()
Visual Basic
Public Shared Function IsVistaOrLater As Boolean
Visual C++
public:
static bool IsVistaOrLater()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.IsVistaOrLater"]

See Also

Utils Class
ArtOfTest.Common Namespace


IsWin7OrLater Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..IsWin7OrLater Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.IsWin7OrLater"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsWin7OrLater()
Visual Basic
Public Shared Function IsWin7OrLater As Boolean
Visual C++
public:
static bool IsWin7OrLater()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.IsWin7OrLater"]

See Also

Utils Class
ArtOfTest.Common Namespace


JSGetContentWindowHeight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..JSGetContentWindowHeight Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.JSGetContentWindowHeight(ArtOfTest.WebAii.Core.Browser)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int JSGetContentWindowHeight(
    Browser brw
)
Visual Basic
Public Shared Function JSGetContentWindowHeight ( _
    brw As Browser _
) As Integer
Visual C++
public:
static int JSGetContentWindowHeight(
    Browser^ brw
)

Parameters

brw
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="brw"/> documentation for "M:ArtOfTest.Common.Utils.JSGetContentWindowHeight(ArtOfTest.WebAii.Core.Browser)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.JSGetContentWindowHeight(ArtOfTest.WebAii.Core.Browser)"]

See Also

Utils Class
ArtOfTest.Common Namespace


JSGetContentWindowWidth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..JSGetContentWindowWidth Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.JSGetContentWindowWidth(ArtOfTest.WebAii.Core.Browser)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int JSGetContentWindowWidth(
    Browser brw
)
Visual Basic
Public Shared Function JSGetContentWindowWidth ( _
    brw As Browser _
) As Integer
Visual C++
public:
static int JSGetContentWindowWidth(
    Browser^ brw
)

Parameters

brw
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="brw"/> documentation for "M:ArtOfTest.Common.Utils.JSGetContentWindowWidth(ArtOfTest.WebAii.Core.Browser)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.JSGetContentWindowWidth(ArtOfTest.WebAii.Core.Browser)"]

See Also

Utils Class
ArtOfTest.Common Namespace


QueryAssemblyInfo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..QueryAssemblyInfo Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.QueryAssemblyInfo(System.String)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string QueryAssemblyInfo(
    string assemblyName
)
Visual Basic
Public Shared Function QueryAssemblyInfo ( _
    assemblyName As String _
) As String
Visual C++
public:
static String^ QueryAssemblyInfo(
    String^ assemblyName
)

Parameters

assemblyName
Type: System..::..String

[Missing <param name="assemblyName"/> documentation for "M:ArtOfTest.Common.Utils.QueryAssemblyInfo(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.QueryAssemblyInfo(System.String)"]

See Also

Utils Class
ArtOfTest.Common Namespace


Swap(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..Swap<(Of <(<'T>)>)> Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.Swap``1(``0@,``0@)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void Swap<T>(
    ref T lhs,
    ref T rhs
)
Visual Basic
Public Shared Sub Swap(Of T) ( _
    ByRef lhs As T, _
    ByRef rhs As T _
)
Visual C++
public:
generic<typename T>
static void Swap(
    T% lhs,
    T% rhs
)

Parameters

lhs
Type: T%

[Missing <param name="lhs"/> documentation for "M:ArtOfTest.Common.Utils.Swap``1(``0@,``0@)"]

rhs
Type: T%

[Missing <param name="rhs"/> documentation for "M:ArtOfTest.Common.Utils.Swap``1(``0@,``0@)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.Utils.Swap``1(``0@,``0@)"]

See Also

Utils Class
ArtOfTest.Common Namespace


TryEnterRunOnceNamedLock Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..TryEnterRunOnceNamedLock Method
Utils Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Utils.TryEnterRunOnceNamedLock(System.Boolean,System.String,System.Object[])"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool TryEnterRunOnceNamedLock(
    bool bGlobal,
    string strNamePrefix,
    params Object[] hashCodeSuffixSources
)
Visual Basic
Public Shared Function TryEnterRunOnceNamedLock ( _
    bGlobal As Boolean, _
    strNamePrefix As String, _
    ParamArray hashCodeSuffixSources As Object() _
) As Boolean
Visual C++
public:
static bool TryEnterRunOnceNamedLock(
    bool bGlobal,
    String^ strNamePrefix,
    ... array<Object^>^ hashCodeSuffixSources
)

Parameters

bGlobal
Type: System..::..Boolean
If true, creates a named mutex. If false, uses the process-local name set.
strNamePrefix
Type: System..::..String

[Missing <param name="strNamePrefix"/> documentation for "M:ArtOfTest.Common.Utils.TryEnterRunOnceNamedLock(System.Boolean,System.String,System.Object[])"]

hashCodeSuffixSources
Type: array< System..::..Object >[]()[][]

[Missing <param name="hashCodeSuffixSources"/> documentation for "M:ArtOfTest.Common.Utils.TryEnterRunOnceNamedLock(System.Boolean,System.String,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Utils.TryEnterRunOnceNamedLock(System.Boolean,System.String,System.Object[])"]

See Also

Utils Class
ArtOfTest.Common Namespace


Utils Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils Properties
Utils Class See Also Send Feedback

The Utils type exposes the following members.

Properties

Name | Description
ScalingFactorX |
ScalingFactorY |

See Also

Utils Class
ArtOfTest.Common Namespace


ScalingFactorX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..ScalingFactorX Property
Utils Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Utils.ScalingFactorX"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static double ScalingFactorX { get; }
Visual Basic
Public Shared ReadOnly Property ScalingFactorX As Double
    Get
Visual C++
public:
static property double ScalingFactorX {
    double get ();
}

See Also

Utils Class
ArtOfTest.Common Namespace


ScalingFactorY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Utils..::..ScalingFactorY Property
Utils Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Utils.ScalingFactorY"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static double ScalingFactorY { get; }
Visual Basic
Public Shared ReadOnly Property ScalingFactorY As Double
    Get
Visual C++
public:
static property double ScalingFactorY {
    double get ();
}

See Also

Utils Class
ArtOfTest.Common Namespace


WaitAsync Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync Members
WaitAsync Class Constructors Methods Properties Events See Also Send Feedback

The WaitAsync type exposes the following members.

Constructors

 | Name | Description
Public method | WaitAsync | Create a new WaitAsync object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) |
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnWaitComplete | Invoke the wait complete event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CheckInterval | Gets or sets the check interval for this wait object.

Events

 | Name | Description
Public event | WaitCompleted | Triggered when the wait operation is completed

See Also

WaitAsync Class
ArtOfTest.Common Namespace


WaitAsync Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync Constructor
WaitAsync Class See Also Send Feedback
Create a new WaitAsync object.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitAsync(
    int timeout,
    int checkInterval
)
Visual Basic
Public Sub New ( _
    timeout As Integer, _
    checkInterval As Integer _
)
Visual C++
public:
WaitAsync(
    int timeout,
    int checkInterval
)

Parameters

timeout
Type: System..::..Int32
The global timeout to use for this wait async object.
checkInterval
Type: System..::..Int32
The check interval to use for condition checking.

See Also

WaitAsync Class
ArtOfTest.Common Namespace


WaitAsync Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync Methods
WaitAsync Class See Also Send Feedback

The WaitAsync type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) |
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnWaitComplete | Invoke the wait complete event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WaitAsync Class
ArtOfTest.Common Namespace


For Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync..::..For Method
WaitAsync Class See Also Send Feedback

Overload List

 | Name | Description
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) |
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) |

See Also

WaitAsync Class
WaitAsync Members
ArtOfTest.Common Namespace


For(T) Method (Predicate(T), T, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync..::..For<(Of <(<'T>)>)> Method (Predicate<(Of <(<'T>)>)>, T, Boolean, Int32)
WaitAsync Class See Also Send Feedback
Wait for an action async. Attach to WaitCompleted to get notification when wait is completed

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void For<T>(
    Predicate<T> predicate,
    T target,
    bool invertCondition,
    int timeout
)
Visual Basic
Public Overridable Sub For(Of T) ( _
    predicate As Predicate(Of T), _
    target As T, _
    invertCondition As Boolean, _
    timeout As Integer _
)
Visual C++
public:
generic<typename T>
virtual void For(
    Predicate<T>^ predicate,
    T target,
    bool invertCondition,
    int timeout
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<'T>)>)>
The function delegate
target
Type: T
The actual target object instance
invertCondition
Type: System..::..Boolean
Whether to invert the condition
timeout
Type: System..::..Int32
The timeout to use.

Type Parameters

T
The object type to pass to predicate

See Also

WaitAsync Class
For Overload
ArtOfTest.Common Namespace


For(T, V) Method (Func(T, V, Boolean), T, V, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync..::..For<(Of <(<'T, V>)>)> Method (Func<(Of <(<'T, V, Boolean>)>)>, T, V, Boolean, Int32)
WaitAsync Class See Also Send Feedback
Wait for an action async. Attach to WaitCompleted to get notification when wait is completed

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void For<T, V>(
    Func<T, V, bool> func,
    T target,
    V custom,
    bool invertCondition,
    int timeout
)
Visual Basic
Public Overridable Sub For(Of T, V) ( _
    func As Func(Of T, V, Boolean), _
    target As T, _
    custom As V, _
    invertCondition As Boolean, _
    timeout As Integer _
)
Visual C++
public:
generic<typename T, typename V>
virtual void For(
    Func<T, V, bool>^ func,
    T target,
    V custom,
    bool invertCondition,
    int timeout
)

Parameters

func
Type: System..::..Func <(Of <(<'T, V, Boolean >)>)>
The wait function delegate
target
Type: T
The target object instance we are waiting on.
custom
Type: V
The custom object instance to pass to the wait function.
invertCondition
Type: System..::..Boolean
True/false whether to invert the condition
timeout
Type: System..::..Int32
The timeout to use.

Type Parameters

T
The object type to pass to wait function.
V
Addition object to pass to wait function.

See Also

WaitAsync Class
For Overload
ArtOfTest.Common Namespace


For(T) Method (Predicate(T), T, Boolean, Int32, WaitResultType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync..::..For<(Of <(<'T>)>)> Method (Predicate<(Of <(<'T>)>)>, T, Boolean, Int32, WaitResultType)
WaitAsync Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.WaitAsync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void For<T>(
    Predicate<T> predicate,
    T target,
    bool invertCondition,
    int timeout,
    WaitResultType errorResultType
)
Visual Basic
Public Overridable Sub For(Of T) ( _
    predicate As Predicate(Of T), _
    target As T, _
    invertCondition As Boolean, _
    timeout As Integer, _
    errorResultType As WaitResultType _
)
Visual C++
public:
generic<typename T>
virtual void For(
    Predicate<T>^ predicate,
    T target,
    bool invertCondition,
    int timeout,
    WaitResultType errorResultType
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<'T>)>)>

[Missing <param name="predicate"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

target
Type: T

[Missing <param name="target"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

invertCondition
Type: System..::..Boolean

[Missing <param name="invertCondition"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

errorResultType
Type: ArtOfTest.Common..::..WaitResultType

[Missing <param name="errorResultType"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

See Also

WaitAsync Class
For Overload
ArtOfTest.Common Namespace


For(T, V) Method (Func(T, V, Boolean), T, V, Boolean, Int32, WaitResultType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync..::..For<(Of <(<'T, V>)>)> Method (Func<(Of <(<'T, V, Boolean>)>)>, T, V, Boolean, Int32, WaitResultType)
WaitAsync Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void For<T, V>(
    Func<T, V, bool> func,
    T target,
    V custom,
    bool invertCondition,
    int timeout,
    WaitResultType errorResultType
)
Visual Basic
Public Overridable Sub For(Of T, V) ( _
    func As Func(Of T, V, Boolean), _
    target As T, _
    custom As V, _
    invertCondition As Boolean, _
    timeout As Integer, _
    errorResultType As WaitResultType _
)
Visual C++
public:
generic<typename T, typename V>
virtual void For(
    Func<T, V, bool>^ func,
    T target,
    V custom,
    bool invertCondition,
    int timeout,
    WaitResultType errorResultType
)

Parameters

func
Type: System..::..Func <(Of <(<'T, V, Boolean >)>)>

[Missing <param name="func"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

target
Type: T

[Missing <param name="target"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

custom
Type: V

[Missing <param name="custom"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

invertCondition
Type: System..::..Boolean

[Missing <param name="invertCondition"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

errorResultType
Type: ArtOfTest.Common..::..WaitResultType

[Missing <param name="errorResultType"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

V

[Missing <typeparam name="V"/> documentation for "M:ArtOfTest.Common.WaitAsync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

See Also

WaitAsync Class
For Overload
ArtOfTest.Common Namespace


OnWaitComplete Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync..::..OnWaitComplete Method
WaitAsync Class See Also Send Feedback
Invoke the wait complete event.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnWaitComplete(
    WaitCompleteEventArgs args
)
Visual Basic
Protected Sub OnWaitComplete ( _
    args As WaitCompleteEventArgs _
)
Visual C++
protected:
void OnWaitComplete(
    WaitCompleteEventArgs^ args
)

Parameters

args
Type: ArtOfTest.Common..::..WaitCompleteEventArgs
WaitCompleteEventArgs

See Also

WaitAsync Class
ArtOfTest.Common Namespace


WaitAsync Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync Properties
WaitAsync Class See Also Send Feedback

The WaitAsync type exposes the following members.

Properties

 | Name | Description
Public property | CheckInterval | Gets or sets the check interval for this wait object.

See Also

WaitAsync Class
ArtOfTest.Common Namespace


CheckInterval Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync..::..CheckInterval Property
WaitAsync Class See Also Send Feedback
Gets or sets the check interval for this wait object.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CheckInterval { get; set; }
Visual Basic
Public Property CheckInterval As Integer
    Get
    Set
Visual C++
public:
property int CheckInterval {
    int get ();
    void set (int value);
}

See Also

WaitAsync Class
ArtOfTest.Common Namespace


WaitAsync Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync Events
WaitAsync Class See Also Send Feedback

The WaitAsync type exposes the following members.

Events

 | Name | Description
Public event | WaitCompleted | Triggered when the wait operation is completed

See Also

WaitAsync Class
ArtOfTest.Common Namespace


WaitCompleted Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitAsync..::..WaitCompleted Event
WaitAsync Class See Also Send Feedback
Triggered when the wait operation is completed

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<WaitCompleteEventArgs> WaitCompleted
Visual Basic
Public Event WaitCompleted As EventHandler(Of WaitCompleteEventArgs)
Visual C++
public:
 event EventHandler<WaitCompleteEventArgs^>^ WaitCompleted {
    void add (EventHandler<WaitCompleteEventArgs^>^ value);
    void remove (EventHandler<WaitCompleteEventArgs^>^ value);
}

See Also

WaitAsync Class
ArtOfTest.Common Namespace


WaitCompleteEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitCompleteEventArgs Members
WaitCompleteEventArgs Class Constructors Methods Properties See Also Send Feedback

The WaitCompleteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | WaitCompleteEventArgs | Create a new WaitCompleteEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | WaitResult | Gets the wait result of this wait operation.

See Also

WaitCompleteEventArgs Class
ArtOfTest.Common Namespace


WaitCompleteEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitCompleteEventArgs Constructor
WaitCompleteEventArgs Class See Also Send Feedback
Create a new WaitCompleteEventArgs.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitCompleteEventArgs(
    WaitResult waitResult
)
Visual Basic
Public Sub New ( _
    waitResult As WaitResult _
)
Visual C++
public:
WaitCompleteEventArgs(
    WaitResult^ waitResult
)

Parameters

waitResult
Type: ArtOfTest.Common..::..WaitResult
The wait result.

See Also

WaitCompleteEventArgs Class
ArtOfTest.Common Namespace


WaitCompleteEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitCompleteEventArgs Methods
WaitCompleteEventArgs Class See Also Send Feedback

The WaitCompleteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WaitCompleteEventArgs Class
ArtOfTest.Common Namespace


WaitCompleteEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitCompleteEventArgs Properties
WaitCompleteEventArgs Class See Also Send Feedback

The WaitCompleteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | WaitResult | Gets the wait result of this wait operation.

See Also

WaitCompleteEventArgs Class
ArtOfTest.Common Namespace


WaitResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitCompleteEventArgs..::..WaitResult Property
WaitCompleteEventArgs Class See Also Send Feedback
Gets the wait result of this wait operation.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitResult WaitResult { get; }
Visual Basic
Public ReadOnly Property WaitResult As WaitResult
    Get
Visual C++
public:
property WaitResult^ WaitResult {
    WaitResult^ get ();
}

See Also

WaitCompleteEventArgs Class
ArtOfTest.Common Namespace


WaitResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult Members
WaitResult Class Constructors Methods Properties See Also Send Feedback

The WaitResult type exposes the following members.

Constructors

 | Name | Description
Public method | WaitResult()()()() | Empty constructor needed for serialization.
Public method | WaitResult(WaitResultType, String) | Create a new WaitConditionResult object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveTo |
Public method | ThrowExceptionIfInError | Throw an exception if the
Public method | ToString | Creates a string that describes this object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | Error | Gets the error if the ResultType = ErrorAbort
Public property | ResultType | Gets the result type of this wait condition.
Public property | RootName |
Public property | XmlBlob |

See Also

WaitResult Class
ArtOfTest.Common Namespace


WaitResult Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult Constructor
WaitResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitResult()()()() | Empty constructor needed for serialization.
Public method | WaitResult(WaitResultType, String) | Create a new WaitConditionResult object.

See Also

WaitResult Class
WaitResult Members
ArtOfTest.Common Namespace


WaitResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult Constructor
WaitResult Class See Also Send Feedback
Empty constructor needed for serialization.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitResult()
Visual Basic
Public Sub New
Visual C++
public:
WaitResult()

See Also

WaitResult Class
WaitResult Overload
ArtOfTest.Common Namespace


WaitResult Constructor (WaitResultType, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult Constructor (WaitResultType, String)
WaitResult Class See Also Send Feedback
Create a new WaitConditionResult object.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitResult(
    WaitResultType resultType,
    string error
)
Visual Basic
Public Sub New ( _
    resultType As WaitResultType, _
    error As String _
)
Visual C++
public:
WaitResult(
    WaitResultType resultType,
    String^ error
)

Parameters

resultType
Type: ArtOfTest.Common..::..WaitResultType
The result type.
error
Type: System..::..String
The error if any.

See Also

WaitResult Class
WaitResult Overload
ArtOfTest.Common Namespace


WaitResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult Methods
WaitResult Class See Also Send Feedback

The WaitResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveTo |
Public method | ThrowExceptionIfInError | Throw an exception if the
Public method | ToString | Creates a string that describes this object. (Overrides Object..::..ToString()()()().)

See Also

WaitResult Class
ArtOfTest.Common Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..LoadFrom Method
WaitResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.WaitResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.Common.WaitResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

WaitResult Class
ArtOfTest.Common Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..SaveTo Method
WaitResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.WaitResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.Common.WaitResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

WaitResult Class
ArtOfTest.Common Namespace


ThrowExceptionIfInError Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..ThrowExceptionIfInError Method
WaitResult Class See Also Send Feedback
Throw an exception if the

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ThrowExceptionIfInError()
Visual Basic
Public Sub ThrowExceptionIfInError
Visual C++
public:
void ThrowExceptionIfInError()

See Also

WaitResult Class
ArtOfTest.Common Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..ToString Method
WaitResult Class See Also Send Feedback
Creates a string that describes this object.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string describing this object.

See Also

WaitResult Class
ArtOfTest.Common Namespace


WaitResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult Properties
WaitResult Class See Also Send Feedback

The WaitResult type exposes the following members.

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | Error | Gets the error if the ResultType = ErrorAbort
Public property | ResultType | Gets the result type of this wait condition.
Public property | RootName |
Public property | XmlBlob |

See Also

WaitResult Class
ArtOfTest.Common Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..CurrentVersion Property
WaitResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.WaitResult.CurrentVersion"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

WaitResult Class
ArtOfTest.Common Namespace


Error Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..Error Property
WaitResult Class See Also Send Feedback
Gets the error if the ResultType = ErrorAbort

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Error { get; }
Visual Basic
Public ReadOnly Property Error As String
    Get
Visual C++
public:
property String^ Error {
    String^ get ();
}

See Also

WaitResult Class
ArtOfTest.Common Namespace


ResultType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..ResultType Property
WaitResult Class See Also Send Feedback
Gets the result type of this wait condition.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitResultType ResultType { get; }
Visual Basic
Public ReadOnly Property ResultType As WaitResultType
    Get
Visual C++
public:
property WaitResultType ResultType {
    WaitResultType get ();
}

See Also

WaitResult Class
ArtOfTest.Common Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..RootName Property
WaitResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.WaitResult.RootName"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

WaitResult Class
ArtOfTest.Common Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitResult..::..XmlBlob Property
WaitResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.WaitResult.XmlBlob"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

WaitResult Class
ArtOfTest.Common Namespace


WaitSync Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync Members
WaitSync Class Constructors Methods Properties Events See Also Send Feedback

The WaitSync type exposes the following members.

Constructors

 | Name | Description
Public method | WaitSync | Create a new synchronous wait object.

Methods

 | Name | Description
 | CheckResult(WaitSync) | Check the result of a WaitSync.
 | CheckResult(WaitSync, String, Object) | Check the sync wait result.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Int32) | Wait for a custom condition defined by predicate on a pooled thread.
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed (Inherited from WaitAsync.)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for a custom condition defined by predicate on a pooled thread. (Overrides WaitAsync..::..For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32).)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) | (Inherited from WaitAsync.)
Public method | For<(Of <<'(T>)>>)(Func<(Of <<'(T, Boolean>)>>), T, Int32, Int32, Object) | Wait for a specific assert.
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) | (Overrides WaitAsync..::..For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType).)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Int32) | Wait for a custom condition defined by func on a pooled thread.
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed (Inherited from WaitAsync.)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for a custom condition defined by func on a pooled thread. (Overrides WaitAsync..::..For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32).)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) | (Inherited from WaitAsync.)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) | (Overrides WaitAsync..::..For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnWaitComplete | Invoke the wait complete event. (Inherited from WaitAsync.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCheckResult | Gets or sets whether to automatically check for timeouts or errors once the wait is done. Default is true.
Public property | CheckInterval | Gets or sets the check interval for this wait object. (Inherited from WaitAsync.)
Public property | SyncWaitResult | Gets the result of the last synchronous wait.

Events

 | Name | Description
Public event | WaitCompleted | Triggered when the wait operation is completed (Inherited from WaitAsync.)

See Also

WaitSync Class
ArtOfTest.Common Namespace


WaitSync Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync Constructor
WaitSync Class See Also Send Feedback
Create a new synchronous wait object.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitSync(
    int timeout,
    int checkInterval
)
Visual Basic
Public Sub New ( _
    timeout As Integer, _
    checkInterval As Integer _
)
Visual C++
public:
WaitSync(
    int timeout,
    int checkInterval
)

Parameters

timeout
Type: System..::..Int32
The global timeout to use for all waits on this method.
checkInterval
Type: System..::..Int32
The condition wait interval to use.

See Also

WaitSync Class
ArtOfTest.Common Namespace


WaitSync Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync Methods
WaitSync Class See Also Send Feedback

The WaitSync type exposes the following members.

Methods

 | Name | Description
 | CheckResult(WaitSync) | Check the result of a WaitSync.
 | CheckResult(WaitSync, String, Object) | Check the sync wait result.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Int32) | Wait for a custom condition defined by predicate on a pooled thread.
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed (Inherited from WaitAsync.)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for a custom condition defined by predicate on a pooled thread. (Overrides WaitAsync..::..For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32).)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) | (Inherited from WaitAsync.)
Public method | For<(Of <<'(T>)>>)(Func<(Of <<'(T, Boolean>)>>), T, Int32, Int32, Object) | Wait for a specific assert.
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) | (Overrides WaitAsync..::..For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType).)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Int32) | Wait for a custom condition defined by func on a pooled thread.
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed (Inherited from WaitAsync.)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for a custom condition defined by func on a pooled thread. (Overrides WaitAsync..::..For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32).)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) | (Inherited from WaitAsync.)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) | (Overrides WaitAsync..::..For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnWaitComplete | Invoke the wait complete event. (Inherited from WaitAsync.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WaitSync Class
ArtOfTest.Common Namespace


CheckResult Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..CheckResult Method
WaitSync Class See Also Send Feedback

Overload List

Name | Description
CheckResult(WaitSync) | Check the result of a WaitSync.
CheckResult(WaitSync, String, Object) | Check the sync wait result.

See Also

WaitSync Class
WaitSync Members
ArtOfTest.Common Namespace


CheckResult Method (WaitSync)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..CheckResult Method (WaitSync)
WaitSync Class See Also Send Feedback
Check the result of a WaitSync.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void CheckResult(
    WaitSync wait
)
Visual Basic
Public Shared Sub CheckResult ( _
    wait As WaitSync _
)
Visual C++
public:
static void CheckResult(
    WaitSync^ wait
)

Parameters

wait
Type: ArtOfTest.Common..::..WaitSync
The wait object.

See Also

WaitSync Class
CheckResult Overload
ArtOfTest.Common Namespace


CheckResult Method (WaitSync, String, Object)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..CheckResult Method (WaitSync, String, Object)
WaitSync Class See Also Send Feedback
Check the sync wait result.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void CheckResult(
    WaitSync wait,
    string extraExceptionInfo,
    Object target
)
Visual Basic
Public Shared Sub CheckResult ( _
    wait As WaitSync, _
    extraExceptionInfo As String, _
    target As Object _
)
Visual C++
public:
static void CheckResult(
    WaitSync^ wait,
    String^ extraExceptionInfo,
    Object^ target
)

Parameters

wait
Type: ArtOfTest.Common..::..WaitSync

[Missing <param name="wait"/> documentation for "M:ArtOfTest.Common.WaitSync.CheckResult(ArtOfTest.Common.WaitSync,System.String,System.Object)"]

extraExceptionInfo
Type: System..::..String

[Missing <param name="extraExceptionInfo"/> documentation for "M:ArtOfTest.Common.WaitSync.CheckResult(ArtOfTest.Common.WaitSync,System.String,System.Object)"]

target
Type: System..::..Object

[Missing <param name="target"/> documentation for "M:ArtOfTest.Common.WaitSync.CheckResult(ArtOfTest.Common.WaitSync,System.String,System.Object)"]

See Also

WaitSync Class
CheckResult Overload
ArtOfTest.Common Namespace


For Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..For Method
WaitSync Class See Also Send Feedback

Overload List

 | Name | Description
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Int32) | Wait for a custom condition defined by predicate on a pooled thread.
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed (Inherited from WaitAsync.)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Int32) | Wait for a custom condition defined by func on a pooled thread.
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32) | Wait for a custom condition defined by predicate on a pooled thread. (Overrides WaitAsync..::..For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32).)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for an action async. Attach to WaitCompleted to get notification when wait is completed (Inherited from WaitAsync.)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) | (Inherited from WaitAsync.)
Public method | For<(Of <<'(T>)>>)(Func<(Of <<'(T, Boolean>)>>), T, Int32, Int32, Object) | Wait for a specific assert.
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32) | Wait for a custom condition defined by func on a pooled thread. (Overrides WaitAsync..::..For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32).)
Public method | For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType) | (Overrides WaitAsync..::..For<(Of <<'(T>)>>)(Predicate<(Of <<'(T>)>>), T, Boolean, Int32, WaitResultType).)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) | (Inherited from WaitAsync.)
Public method | For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType) | (Overrides WaitAsync..::..For<(Of <<'(T, V>)>>)(Func<(Of <<'(T, V, Boolean>)>>), T, V, Boolean, Int32, WaitResultType).)

See Also

WaitSync Class
WaitSync Members
ArtOfTest.Common Namespace


For(T) Method (Predicate(T), T, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..For<(Of <(<'T>)>)> Method (Predicate<(Of <(<'T>)>)>, T, Int32)
WaitSync Class See Also Send Feedback
Wait for a custom condition defined by predicate on a pooled thread.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void For<T>(
    Predicate<T> predicate,
    T target,
    int timeout
)
Visual Basic
Public Sub For(Of T) ( _
    predicate As Predicate(Of T), _
    target As T, _
    timeout As Integer _
)
Visual C++
public:
generic<typename T>
void For(
    Predicate<T>^ predicate,
    T target,
    int timeout
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<'T>)>)>
Predicate function to call.
target
Type: T
The target object instance to pass to predicate.
timeout
Type: System..::..Int32
The time out to use.

Type Parameters

T
target type to pass to function.

Remarks

Function does not throw on timeout. Check the SyncWaitResult to figure out if the call timed-out..etc.

See Also

WaitSync Class
For Overload
ArtOfTest.Common Namespace


For(T, V) Method (Func(T, V, Boolean), T, V, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..For<(Of <(<'T, V>)>)> Method (Func<(Of <(<'T, V, Boolean>)>)>, T, V, Int32)
WaitSync Class See Also Send Feedback
Wait for a custom condition defined by func on a pooled thread.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void For<T, V>(
    Func<T, V, bool> func,
    T target,
    V custom,
    int timeout
)
Visual Basic
Public Sub For(Of T, V) ( _
    func As Func(Of T, V, Boolean), _
    target As T, _
    custom As V, _
    timeout As Integer _
)
Visual C++
public:
generic<typename T, typename V>
void For(
    Func<T, V, bool>^ func,
    T target,
    V custom,
    int timeout
)

Parameters

func
Type: System..::..Func <(Of <(<'T, V, Boolean >)>)>
The function delegate
target
Type: T
The target object instance to pass to function.
custom
Type: V
The custom object instance to pass to function.
timeout
Type: System..::..Int32
The time out to use.

Type Parameters

T
target type to pass to function.
V
custom type to pass to function.

Remarks

Function does not throw on timeout. Check the SyncWaitResult to figure out if the call timed-out..etc.

See Also

WaitSync Class
For Overload
ArtOfTest.Common Namespace


For(T) Method (Predicate(T), T, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..For<(Of <(<'T>)>)> Method (Predicate<(Of <(<'T>)>)>, T, Boolean, Int32)
WaitSync Class See Also Send Feedback
Wait for a custom condition defined by predicate on a pooled thread.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void For<T>(
    Predicate<T> predicate,
    T target,
    bool invertCondition,
    int timeout
)
Visual Basic
Public Overrides Sub For(Of T) ( _
    predicate As Predicate(Of T), _
    target As T, _
    invertCondition As Boolean, _
    timeout As Integer _
)
Visual C++
public:
generic<typename T>
virtual void For(
    Predicate<T>^ predicate,
    T target,
    bool invertCondition,
    int timeout
) override

Parameters

predicate
Type: System..::..Predicate <(Of <(<'T>)>)>
Predicate function to call.
target
Type: T
The target object instance to pass to predicate.
invertCondition
Type: System..::..Boolean
True/false to invert the condition.
timeout
Type: System..::..Int32
The time out to use.

Type Parameters

T
target type to pass to function.

Remarks

Function does not throw on timeout. Check the SyncWaitResult to figure out if the call timed-out..etc.

See Also

WaitSync Class
For Overload
ArtOfTest.Common Namespace


For(T) Method (Func(T, Boolean), T, Int32, Int32, Object)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..For<(Of <(<'T>)>)> Method (Func<(Of <(<'T, Boolean>)>)>, T, Int32, Int32, Object)
WaitSync Class See Also Send Feedback
Wait for a specific assert.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void For<T>(
    Func<T, bool> assert,
    T control,
    int timeout,
    int checkInterval,
    Object target
)
Visual Basic
Public Sub For(Of T) ( _
    assert As Func(Of T, Boolean), _
    control As T, _
    timeout As Integer, _
    checkInterval As Integer, _
    target As Object _
)
Visual C++
public:
generic<typename T>
void For(
    Func<T, bool>^ assert,
    T control,
    int timeout,
    int checkInterval,
    Object^ target
)

Parameters

assert
Type: System..::..Func <(Of <(<'T, Boolean >)>)>
The assert to use. Control.AssertXXXX
control
Type: T
The target control
timeout
Type: System..::..Int32
The timeout to use
checkInterval
Type: System..::..Int32
The check interval to use.
target
Type: System..::..Object
Target object to execute this method against

Type Parameters

T
The type of the control

See Also

WaitSync Class
For Overload
ArtOfTest.Common Namespace


For(T, V) Method (Func(T, V, Boolean), T, V, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..For<(Of <(<'T, V>)>)> Method (Func<(Of <(<'T, V, Boolean>)>)>, T, V, Boolean, Int32)
WaitSync Class See Also Send Feedback
Wait for a custom condition defined by func on a pooled thread.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void For<T, V>(
    Func<T, V, bool> func,
    T target,
    V custom,
    bool invertCondition,
    int timeout
)
Visual Basic
Public Overrides Sub For(Of T, V) ( _
    func As Func(Of T, V, Boolean), _
    target As T, _
    custom As V, _
    invertCondition As Boolean, _
    timeout As Integer _
)
Visual C++
public:
generic<typename T, typename V>
virtual void For(
    Func<T, V, bool>^ func,
    T target,
    V custom,
    bool invertCondition,
    int timeout
) override

Parameters

func
Type: System..::..Func <(Of <(<'T, V, Boolean >)>)>
The function delegate
target
Type: T
The target object instance to pass to function.
custom
Type: V
The custom object instance to pass to function.
invertCondition
Type: System..::..Boolean
True/false to invert the condition.
timeout
Type: System..::..Int32
The time out to use.

Type Parameters

T
target type to pass to function.
V
custom type to pass to function.

Remarks

Function does not throw on timeout. Check the SyncWaitResult to figure out if the call timed-out..etc.

See Also

WaitSync Class
For Overload
ArtOfTest.Common Namespace


For(T) Method (Predicate(T), T, Boolean, Int32, WaitResultType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..For<(Of <(<'T>)>)> Method (Predicate<(Of <(<'T>)>)>, T, Boolean, Int32, WaitResultType)
WaitSync Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.WaitSync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void For<T>(
    Predicate<T> predicate,
    T target,
    bool invertCondition,
    int timeout,
    WaitResultType errorResultType
)
Visual Basic
Public Overrides Sub For(Of T) ( _
    predicate As Predicate(Of T), _
    target As T, _
    invertCondition As Boolean, _
    timeout As Integer, _
    errorResultType As WaitResultType _
)
Visual C++
public:
generic<typename T>
virtual void For(
    Predicate<T>^ predicate,
    T target,
    bool invertCondition,
    int timeout,
    WaitResultType errorResultType
) override

Parameters

predicate
Type: System..::..Predicate <(Of <(<'T>)>)>

[Missing <param name="predicate"/> documentation for "M:ArtOfTest.Common.WaitSync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

target
Type: T

[Missing <param name="target"/> documentation for "M:ArtOfTest.Common.WaitSync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

invertCondition
Type: System..::..Boolean

[Missing <param name="invertCondition"/> documentation for "M:ArtOfTest.Common.WaitSync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.Common.WaitSync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

errorResultType
Type: ArtOfTest.Common..::..WaitResultType

[Missing <param name="errorResultType"/> documentation for "M:ArtOfTest.Common.WaitSync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.WaitSync.For``1(System.Predicate{``0},``0,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

See Also

WaitSync Class
For Overload
ArtOfTest.Common Namespace


For(T, V) Method (Func(T, V, Boolean), T, V, Boolean, Int32, WaitResultType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..For<(Of <(<'T, V>)>)> Method (Func<(Of <(<'T, V, Boolean>)>)>, T, V, Boolean, Int32, WaitResultType)
WaitSync Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void For<T, V>(
    Func<T, V, bool> func,
    T target,
    V custom,
    bool invertCondition,
    int timeout,
    WaitResultType errorResultType
)
Visual Basic
Public Overrides Sub For(Of T, V) ( _
    func As Func(Of T, V, Boolean), _
    target As T, _
    custom As V, _
    invertCondition As Boolean, _
    timeout As Integer, _
    errorResultType As WaitResultType _
)
Visual C++
public:
generic<typename T, typename V>
virtual void For(
    Func<T, V, bool>^ func,
    T target,
    V custom,
    bool invertCondition,
    int timeout,
    WaitResultType errorResultType
) override

Parameters

func
Type: System..::..Func <(Of <(<'T, V, Boolean >)>)>

[Missing <param name="func"/> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

target
Type: T

[Missing <param name="target"/> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

custom
Type: V

[Missing <param name="custom"/> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

invertCondition
Type: System..::..Boolean

[Missing <param name="invertCondition"/> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

errorResultType
Type: ArtOfTest.Common..::..WaitResultType

[Missing <param name="errorResultType"/> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

V

[Missing <typeparam name="V"/> documentation for "M:ArtOfTest.Common.WaitSync.For``2(System.Func{``0,``1,System.Boolean},``0,``1,System.Boolean,System.Int32,ArtOfTest.Common.WaitResultType)"]

See Also

WaitSync Class
For Overload
ArtOfTest.Common Namespace


WaitSync Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync Properties
WaitSync Class See Also Send Feedback

The WaitSync type exposes the following members.

Properties

 | Name | Description
Public property | AutoCheckResult | Gets or sets whether to automatically check for timeouts or errors once the wait is done. Default is true.
Public property | CheckInterval | Gets or sets the check interval for this wait object. (Inherited from WaitAsync.)
Public property | SyncWaitResult | Gets the result of the last synchronous wait.

See Also

WaitSync Class
ArtOfTest.Common Namespace


AutoCheckResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..AutoCheckResult Property
WaitSync Class See Also Send Feedback
Gets or sets whether to automatically check for timeouts or errors once the wait is done. Default is true.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AutoCheckResult { get; set; }
Visual Basic
Public Property AutoCheckResult As Boolean
    Get
    Set
Visual C++
public:
property bool AutoCheckResult {
    bool get ();
    void set (bool value);
}

Remarks

If this value is set to false then the user calling .For will need to manually check the SyncWaitResult when the call comes back.

See Also

WaitSync Class
ArtOfTest.Common Namespace


SyncWaitResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync..::..SyncWaitResult Property
WaitSync Class See Also Send Feedback
Gets the result of the last synchronous wait.

Namespace: ArtOfTest.Common
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitResult SyncWaitResult { get; }
Visual Basic
Public ReadOnly Property SyncWaitResult As WaitResult
    Get
Visual C++
public:
property WaitResult^ SyncWaitResult {
    WaitResult^ get ();
}

See Also

WaitSync Class
ArtOfTest.Common Namespace


WaitSync Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WaitSync Events
WaitSync Class See Also Send Feedback

The WaitSync type exposes the following members.

Events

 | Name | Description
Public event | WaitCompleted | Triggered when the wait operation is completed (Inherited from WaitAsync.)

See Also

WaitSync Class
ArtOfTest.Common Namespace


ArtOfTest.Common.BackCompat Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.Common.BackCompat Namespace
Send Feedback
Namespace for legacy backwards compatibility wrappers and converters.

Interfaces

 | Interface | Description
Public interface | IFindParam |
Public interface | IiAttribute |

Enumerations

 | Enumeration | Description
Public enumeration | BackCompatFindType |


IFindParam Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindParam Members
IFindParam Interface Properties See Also Send Feedback

The IFindParam type exposes the following members.

Properties

 | Name | Description
Public property | Attributes |
Public property | PartialAttributes |
Public property | Type |

See Also

IFindParam Interface
ArtOfTest.Common.BackCompat Namespace


IFindParam Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindParam Properties
IFindParam Interface See Also Send Feedback

The IFindParam type exposes the following members.

Properties

 | Name | Description
Public property | Attributes |
Public property | PartialAttributes |
Public property | Type |

See Also

IFindParam Interface
ArtOfTest.Common.BackCompat Namespace


Attributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindParam..::..Attributes Property
IFindParam Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.BackCompat.IFindParam.Attributes"]

Namespace: ArtOfTest.Common.BackCompat
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<IiAttribute> Attributes { get; }
Visual Basic
ReadOnly Property Attributes As IList(Of IiAttribute)
    Get
Visual C++
property IList<IiAttribute^>^ Attributes {
    IList<IiAttribute^>^ get ();
}

See Also

IFindParam Interface
ArtOfTest.Common.BackCompat Namespace


PartialAttributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindParam..::..PartialAttributes Property
IFindParam Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.BackCompat.IFindParam.PartialAttributes"]

Namespace: ArtOfTest.Common.BackCompat
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<IiAttribute> PartialAttributes { get; }
Visual Basic
ReadOnly Property PartialAttributes As IList(Of IiAttribute)
    Get
Visual C++
property IList<IiAttribute^>^ PartialAttributes {
    IList<IiAttribute^>^ get ();
}

See Also

IFindParam Interface
ArtOfTest.Common.BackCompat Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFindParam..::..Type Property
IFindParam Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.BackCompat.IFindParam.Type"]

Namespace: ArtOfTest.Common.BackCompat
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
BackCompatFindType Type { get; }
Visual Basic
ReadOnly Property Type As BackCompatFindType
    Get
Visual C++
property BackCompatFindType Type {
    BackCompatFindType get ();
}

See Also

IFindParam Interface
ArtOfTest.Common.BackCompat Namespace


IiAttribute Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IiAttribute Members
IiAttribute Interface Properties See Also Send Feedback

The IiAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

IiAttribute Interface
ArtOfTest.Common.BackCompat Namespace


IiAttribute Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IiAttribute Properties
IiAttribute Interface See Also Send Feedback

The IiAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Name |
Public property | Value |

See Also

IiAttribute Interface
ArtOfTest.Common.BackCompat Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IiAttribute..::..Name Property
IiAttribute Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.BackCompat.IiAttribute.Name"]

Namespace: ArtOfTest.Common.BackCompat
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IiAttribute Interface
ArtOfTest.Common.BackCompat Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IiAttribute..::..Value Property
IiAttribute Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.BackCompat.IiAttribute.Value"]

Namespace: ArtOfTest.Common.BackCompat
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Value { get; }
Visual Basic
ReadOnly Property Value As String
    Get
Visual C++
property String^ Value {
    String^ get ();
}

See Also

IiAttribute Interface
ArtOfTest.Common.BackCompat Namespace


ArtOfTest.Common.Exceptions Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.Common.Exceptions Namespace
Send Feedback
Namespace for the Exception classes used throughout the framework.

Classes

 | Class | Description
Public class | AssertException | AssertException thrown when an assert fails.
Public class | FindElementException | FindElementException thrown when an execute command cannot find the element to act on.


AssertException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException Members
AssertException Class Constructors Methods Properties See Also Send Feedback

The AssertException type exposes the following members.

Constructors

 | Name | Description
Public method | AssertException(SerializationInfo, StreamingContext) | Serialization constructor
Public method | AssertException(String, Exception) | Create a new AssertException
Public method | AssertException(String, String, String) | Create a new AssertException
Public method | AssertException(String, String, String, Exception) | Create a new AssertException

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Deserialize this exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | ActualValue | Gets the actual value.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExpectedValue | Gets the expected value.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the assert message (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AssertException Class
ArtOfTest.Common.Exceptions Namespace


AssertException Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException Constructor
AssertException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssertException(SerializationInfo, StreamingContext) | Serialization constructor
Public method | AssertException(String, Exception) | Create a new AssertException
Public method | AssertException(String, String, String) | Create a new AssertException
Public method | AssertException(String, String, String, Exception) | Create a new AssertException

See Also

AssertException Class
AssertException Members
ArtOfTest.Common.Exceptions Namespace


AssertException Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException Constructor (SerializationInfo, StreamingContext)
AssertException Class See Also Send Feedback
Serialization constructor

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
AssertException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
SerializationInfo
context
Type: System.Runtime.Serialization..::..StreamingContext
StreamingContext

See Also

AssertException Class
AssertException Overload
ArtOfTest.Common.Exceptions Namespace


AssertException Constructor (String, Exception)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException Constructor (String, Exception)
AssertException Class See Also Send Feedback
Create a new AssertException

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
AssertException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
Assert message
innerException
Type: System..::..Exception
Any inner exceptions

See Also

AssertException Class
AssertException Overload
ArtOfTest.Common.Exceptions Namespace


AssertException Constructor (String, String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException Constructor (String, String, String)
AssertException Class See Also Send Feedback
Create a new AssertException

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertException(
    string message,
    string expectedValue,
    string actualValue
)
Visual Basic
Public Sub New ( _
    message As String, _
    expectedValue As String, _
    actualValue As String _
)
Visual C++
public:
AssertException(
    String^ message,
    String^ expectedValue,
    String^ actualValue
)

Parameters

message
Type: System..::..String
Assert message
expectedValue
Type: System..::..String
Expected value.
actualValue
Type: System..::..String
Actual value.

See Also

AssertException Class
AssertException Overload
ArtOfTest.Common.Exceptions Namespace


AssertException Constructor (String, String, String, Exception)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException Constructor (String, String, String, Exception)
AssertException Class See Also Send Feedback
Create a new AssertException

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertException(
    string message,
    string expectedValue,
    string actualValue,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    expectedValue As String, _
    actualValue As String, _
    innerException As Exception _
)
Visual C++
public:
AssertException(
    String^ message,
    String^ expectedValue,
    String^ actualValue,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
Assert message
expectedValue
Type: System..::..String
Expected value.
actualValue
Type: System..::..String
Actual value.
innerException
Type: System..::..Exception
Any inner exceptions

See Also

AssertException Class
AssertException Overload
ArtOfTest.Common.Exceptions Namespace


AssertException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException Methods
AssertException Class See Also Send Feedback

The AssertException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Deserialize this exception. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AssertException Class
ArtOfTest.Common.Exceptions Namespace


GetObjectData Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException..::..GetObjectData Method
AssertException Class See Also Send Feedback
Deserialize this exception.

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Serialization info.
context
Type: System.Runtime.Serialization..::..StreamingContext
Context.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

AssertException Class
ArtOfTest.Common.Exceptions Namespace


AssertException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException Properties
AssertException Class See Also Send Feedback

The AssertException type exposes the following members.

Properties

 | Name | Description
Public property | ActualValue | Gets the actual value.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExpectedValue | Gets the expected value.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the assert message (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AssertException Class
ArtOfTest.Common.Exceptions Namespace


ActualValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException..::..ActualValue Property
AssertException Class See Also Send Feedback
Gets the actual value.

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ActualValue { get; }
Visual Basic
Public ReadOnly Property ActualValue As String
    Get
Visual C++
public:
property String^ ActualValue {
    String^ get ();
}

See Also

AssertException Class
ArtOfTest.Common.Exceptions Namespace


ExpectedValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException..::..ExpectedValue Property
AssertException Class See Also Send Feedback
Gets the expected value.

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ExpectedValue { get; }
Visual Basic
Public ReadOnly Property ExpectedValue As String
    Get
Visual C++
public:
property String^ ExpectedValue {
    String^ get ();
}

See Also

AssertException Class
ArtOfTest.Common.Exceptions Namespace


Message Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertException..::..Message Property
AssertException Class See Also Send Feedback
Gets the assert message

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::..Message

See Also

AssertException Class
ArtOfTest.Common.Exceptions Namespace


FindElementException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindElementException Members
FindElementException Class Constructors Methods Properties See Also Send Feedback

The FindElementException type exposes the following members.

Constructors

 | Name | Description
Public method | FindElementException(String) | Creates a new FindElementException object.
Public method | FindElementException(SerializationInfo, StreamingContext) | Creates a new FindElementException object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FindElementException Class
ArtOfTest.Common.Exceptions Namespace


FindElementException Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindElementException Constructor
FindElementException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindElementException(String) | Creates a new FindElementException object.
Public method | FindElementException(SerializationInfo, StreamingContext) | Creates a new FindElementException object.

See Also

FindElementException Class
FindElementException Members
ArtOfTest.Common.Exceptions Namespace


FindElementException Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindElementException Constructor (String)
FindElementException Class See Also Send Feedback
Creates a new FindElementException object.

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindElementException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
FindElementException(
    String^ message
)

Parameters

message
Type: System..::..String
The message for the exception.

See Also

FindElementException Class
FindElementException Overload
ArtOfTest.Common.Exceptions Namespace


FindElementException Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindElementException Constructor (SerializationInfo, StreamingContext)
FindElementException Class See Also Send Feedback
Creates a new FindElementException object.

Namespace: ArtOfTest.Common.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindElementException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
FindElementException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The data needed to serialize or deserialize this object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The source and destination of a given serialized stream, and provides an additional caller-defined context.

See Also

FindElementException Class
FindElementException Overload
ArtOfTest.Common.Exceptions Namespace


FindElementException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindElementException Methods
FindElementException Class See Also Send Feedback

The FindElementException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FindElementException Class
ArtOfTest.Common.Exceptions Namespace


FindElementException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindElementException Properties
FindElementException Class See Also Send Feedback

The FindElementException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FindElementException Class
ArtOfTest.Common.Exceptions Namespace


ArtOfTest.Common.UnitTesting Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.Common.UnitTesting Namespace
Send Feedback
A set of Assert classes for that can be used in verifications.

Classes

 | Class | Description
Public class | Assert |


Assert Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert Members
Assert Class Methods See Also Send Feedback

Methods

Name | Description
AreEqual<(Of <<'(T>)>>)(T, T) |
AreEqual<(Of <<'(T>)>>)(T, T, String) |
AreNotEqual<(Of <<'(T>)>>)(T, T) |
AreNotEqual<(Of <<'(T>)>>)(T, T, String) |
AreSame(Object, Object) |
AreSame(Object, Object, String) |
IsFalse(Boolean) |
IsFalse(Boolean, String) |
IsNotNull(Object) |
IsNotNull(Object, String) |
IsNull(Object) |
IsNull(Object, String) |
IsTrue(Boolean) |
IsTrue(Boolean, String) |

See Also

Assert Class
ArtOfTest.Common.UnitTesting Namespace


Assert Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert Methods
Assert Class See Also Send Feedback

Methods

Name | Description
AreEqual<(Of <<'(T>)>>)(T, T) |
AreEqual<(Of <<'(T>)>>)(T, T, String) |
AreNotEqual<(Of <<'(T>)>>)(T, T) |
AreNotEqual<(Of <<'(T>)>>)(T, T, String) |
AreSame(Object, Object) |
AreSame(Object, Object, String) |
IsFalse(Boolean) |
IsFalse(Boolean, String) |
IsNotNull(Object) |
IsNotNull(Object, String) |
IsNull(Object) |
IsNull(Object, String) |
IsTrue(Boolean) |
IsTrue(Boolean, String) |

See Also

Assert Class
ArtOfTest.Common.UnitTesting Namespace


AreEqual Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreEqual Method
Assert Class See Also Send Feedback

Overload List

Name | Description
AreEqual<(Of <<'(T>)>>)(T, T) |
AreEqual<(Of <<'(T>)>>)(T, T, String) |

See Also

Assert Class
Assert Members
ArtOfTest.Common.UnitTesting Namespace


AreEqual(T) Method (T, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreEqual<(Of <(<'T>)>)> Method (T, T)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void AreEqual<T>(
    T expected,
    T actual
)
Visual Basic
Public Shared Sub AreEqual(Of T) ( _
    expected As T, _
    actual As T _
)
Visual C++
public:
generic<typename T>
static void AreEqual(
    T expected,
    T actual
)

Parameters

expected
Type: T

[Missing <param name="expected"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0)"]

actual
Type: T

[Missing <param name="actual"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0)"]

See Also

Assert Class
AreEqual Overload
ArtOfTest.Common.UnitTesting Namespace


AreEqual(T) Method (T, T, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreEqual<(Of <(<'T>)>)> Method (T, T, String)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0,System.String)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void AreEqual<T>(
    T expected,
    T actual,
    string message
)
Visual Basic
Public Shared Sub AreEqual(Of T) ( _
    expected As T, _
    actual As T, _
    message As String _
)
Visual C++
public:
generic<typename T>
static void AreEqual(
    T expected,
    T actual,
    String^ message
)

Parameters

expected
Type: T

[Missing <param name="expected"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0,System.String)"]

actual
Type: T

[Missing <param name="actual"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreEqual``1(``0,``0,System.String)"]

See Also

Assert Class
AreEqual Overload
ArtOfTest.Common.UnitTesting Namespace


AreNotEqual Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreNotEqual Method
Assert Class See Also Send Feedback

Overload List

Name | Description
AreNotEqual<(Of <<'(T>)>>)(T, T) |
AreNotEqual<(Of <<'(T>)>>)(T, T, String) |

See Also

Assert Class
Assert Members
ArtOfTest.Common.UnitTesting Namespace


AreNotEqual(T) Method (T, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreNotEqual<(Of <(<'T>)>)> Method (T, T)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void AreNotEqual<T>(
    T expected,
    T actual
)
Visual Basic
Public Shared Sub AreNotEqual(Of T) ( _
    expected As T, _
    actual As T _
)
Visual C++
public:
generic<typename T>
static void AreNotEqual(
    T expected,
    T actual
)

Parameters

expected
Type: T

[Missing <param name="expected"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0)"]

actual
Type: T

[Missing <param name="actual"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0)"]

See Also

Assert Class
AreNotEqual Overload
ArtOfTest.Common.UnitTesting Namespace


AreNotEqual(T) Method (T, T, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreNotEqual<(Of <(<'T>)>)> Method (T, T, String)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0,System.String)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void AreNotEqual<T>(
    T expected,
    T actual,
    string message
)
Visual Basic
Public Shared Sub AreNotEqual(Of T) ( _
    expected As T, _
    actual As T, _
    message As String _
)
Visual C++
public:
generic<typename T>
static void AreNotEqual(
    T expected,
    T actual,
    String^ message
)

Parameters

expected
Type: T

[Missing <param name="expected"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0,System.String)"]

actual
Type: T

[Missing <param name="actual"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0,System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreNotEqual``1(``0,``0,System.String)"]

See Also

Assert Class
AreNotEqual Overload
ArtOfTest.Common.UnitTesting Namespace


AreSame Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreSame Method
Assert Class See Also Send Feedback

Overload List

Name | Description
AreSame(Object, Object) |
AreSame(Object, Object, String) |

See Also

Assert Class
Assert Members
ArtOfTest.Common.UnitTesting Namespace


AreSame Method (Object, Object)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreSame Method (Object, Object)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreSame(System.Object,System.Object)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void AreSame(
    Object expected,
    Object actual
)
Visual Basic
Public Shared Sub AreSame ( _
    expected As Object, _
    actual As Object _
)
Visual C++
public:
static void AreSame(
    Object^ expected,
    Object^ actual
)

Parameters

expected
Type: System..::..Object

[Missing <param name="expected"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreSame(System.Object,System.Object)"]

actual
Type: System..::..Object

[Missing <param name="actual"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreSame(System.Object,System.Object)"]

See Also

Assert Class
AreSame Overload
ArtOfTest.Common.UnitTesting Namespace


AreSame Method (Object, Object, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..AreSame Method (Object, Object, String)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreSame(System.Object,System.Object,System.String)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void AreSame(
    Object expected,
    Object actual,
    string message
)
Visual Basic
Public Shared Sub AreSame ( _
    expected As Object, _
    actual As Object, _
    message As String _
)
Visual C++
public:
static void AreSame(
    Object^ expected,
    Object^ actual,
    String^ message
)

Parameters

expected
Type: System..::..Object

[Missing <param name="expected"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreSame(System.Object,System.Object,System.String)"]

actual
Type: System..::..Object

[Missing <param name="actual"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreSame(System.Object,System.Object,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.AreSame(System.Object,System.Object,System.String)"]

See Also

Assert Class
AreSame Overload
ArtOfTest.Common.UnitTesting Namespace


IsFalse Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsFalse Method
Assert Class See Also Send Feedback

Overload List

Name | Description
IsFalse(Boolean) |
IsFalse(Boolean, String) |

See Also

Assert Class
Assert Members
ArtOfTest.Common.UnitTesting Namespace


IsFalse Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsFalse Method (Boolean)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsFalse(System.Boolean)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void IsFalse(
    bool condition
)
Visual Basic
Public Shared Sub IsFalse ( _
    condition As Boolean _
)
Visual C++
public:
static void IsFalse(
    bool condition
)

Parameters

condition
Type: System..::..Boolean

[Missing <param name="condition"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsFalse(System.Boolean)"]

See Also

Assert Class
IsFalse Overload
ArtOfTest.Common.UnitTesting Namespace


IsFalse Method (Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsFalse Method (Boolean, String)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsFalse(System.Boolean,System.String)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void IsFalse(
    bool condition,
    string message
)
Visual Basic
Public Shared Sub IsFalse ( _
    condition As Boolean, _
    message As String _
)
Visual C++
public:
static void IsFalse(
    bool condition,
    String^ message
)

Parameters

condition
Type: System..::..Boolean

[Missing <param name="condition"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsFalse(System.Boolean,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsFalse(System.Boolean,System.String)"]

See Also

Assert Class
IsFalse Overload
ArtOfTest.Common.UnitTesting Namespace


IsNotNull Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsNotNull Method
Assert Class See Also Send Feedback

Overload List

Name | Description
IsNotNull(Object) |
IsNotNull(Object, String) |

See Also

Assert Class
Assert Members
ArtOfTest.Common.UnitTesting Namespace


IsNotNull Method (Object)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsNotNull Method (Object)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNotNull(System.Object)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void IsNotNull(
    Object value
)
Visual Basic
Public Shared Sub IsNotNull ( _
    value As Object _
)
Visual C++
public:
static void IsNotNull(
    Object^ value
)

Parameters

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNotNull(System.Object)"]

See Also

Assert Class
IsNotNull Overload
ArtOfTest.Common.UnitTesting Namespace


IsNotNull Method (Object, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsNotNull Method (Object, String)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNotNull(System.Object,System.String)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void IsNotNull(
    Object value,
    string message
)
Visual Basic
Public Shared Sub IsNotNull ( _
    value As Object, _
    message As String _
)
Visual C++
public:
static void IsNotNull(
    Object^ value,
    String^ message
)

Parameters

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNotNull(System.Object,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNotNull(System.Object,System.String)"]

See Also

Assert Class
IsNotNull Overload
ArtOfTest.Common.UnitTesting Namespace


IsNull Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsNull Method
Assert Class See Also Send Feedback

Overload List

Name | Description
IsNull(Object) |
IsNull(Object, String) |

See Also

Assert Class
Assert Members
ArtOfTest.Common.UnitTesting Namespace


IsNull Method (Object)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsNull Method (Object)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNull(System.Object)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void IsNull(
    Object value
)
Visual Basic
Public Shared Sub IsNull ( _
    value As Object _
)
Visual C++
public:
static void IsNull(
    Object^ value
)

Parameters

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNull(System.Object)"]

See Also

Assert Class
IsNull Overload
ArtOfTest.Common.UnitTesting Namespace


IsNull Method (Object, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsNull Method (Object, String)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNull(System.Object,System.String)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void IsNull(
    Object value,
    string message
)
Visual Basic
Public Shared Sub IsNull ( _
    value As Object, _
    message As String _
)
Visual C++
public:
static void IsNull(
    Object^ value,
    String^ message
)

Parameters

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNull(System.Object,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsNull(System.Object,System.String)"]

See Also

Assert Class
IsNull Overload
ArtOfTest.Common.UnitTesting Namespace


IsTrue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsTrue Method
Assert Class See Also Send Feedback

Overload List

Name | Description
IsTrue(Boolean) |
IsTrue(Boolean, String) |

See Also

Assert Class
Assert Members
ArtOfTest.Common.UnitTesting Namespace


IsTrue Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsTrue Method (Boolean)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsTrue(System.Boolean)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void IsTrue(
    bool condition
)
Visual Basic
Public Shared Sub IsTrue ( _
    condition As Boolean _
)
Visual C++
public:
static void IsTrue(
    bool condition
)

Parameters

condition
Type: System..::..Boolean

[Missing <param name="condition"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsTrue(System.Boolean)"]

See Also

Assert Class
IsTrue Overload
ArtOfTest.Common.UnitTesting Namespace


IsTrue Method (Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Assert..::..IsTrue Method (Boolean, String)
Assert Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsTrue(System.Boolean,System.String)"]

Namespace: ArtOfTest.Common.UnitTesting
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void IsTrue(
    bool condition,
    string message
)
Visual Basic
Public Shared Sub IsTrue ( _
    condition As Boolean, _
    message As String _
)
Visual C++
public:
static void IsTrue(
    bool condition,
    String^ message
)

Parameters

condition
Type: System..::..Boolean

[Missing <param name="condition"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsTrue(System.Boolean,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.Common.UnitTesting.Assert.IsTrue(System.Boolean,System.String)"]

See Also

Assert Class
IsTrue Overload
ArtOfTest.Common.UnitTesting Namespace


ArtOfTest.Common.Win32 Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.Common.Win32 Namespace
Send Feedback
Namespace for the functions that directly access the native Windows Win32 API.

Classes

 | Class | Description
Public class | FlashWindow |
Public class | TunnelingMouseEventArgs | Event arguments for mouse events coming through a wrapped Win32 window.
Public class | Window | For internal use only.
Public class | WindowCollection | A Window object collection.
Public class | WindowEventArgs | windowWatcher events arg
Public class | WindowManager | Provides basic Win32 window management services like searching ...etc.

Structures

 | Structure | Description
Public structure | HWND | Drop-in P/Invoke replacement for IntPtr window handle. Includes implicit typecasts for IntPtr, System.Windows.Window, and System.Windows.Forms.Control. This class performs no caching; all property accesses translate to immediate Win32 function calls, and failed calls will throw exceptions (unlike the P/Invoke entry points themselves).

Interfaces

 | Interface | Description
Public interface | IAdornerWindowContent |

Enumerations

 | Enumeration | Description
Public enumeration | INTERNETFEATURELIST |
Public enumeration | TileWindowsOption |
Public enumeration | WindowPosition |


FlashWindow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow Members
FlashWindow Class Methods Fields See Also Send Feedback

The FlashWindow type exposes the following members.

Methods

Name | Description
Flash(IntPtr) | Flash the specified Window until it recieves focus.
Flash(IntPtr, Int32) | Flash the specified Window for the specified number of times
Start | Start Flashing the specified Window.
Stop | Stop Flashing the specified Window.

Fields

Name | Description
FLASHW_ALL | Flash both the window caption and taskbar button. This is equivalent to setting the FLASHW_CAPTION | FLASHW_TRAY flags.
FLASHW_CAPTION | Flash the window caption.
FLASHW_STOP | Stop flashing. The system restores the window to its original stae.
FLASHW_TIMER | Flash continuously, until the FLASHW_STOP flag is set.
FLASHW_TIMERNOFG | Flash continuously until the window comes to the foreground.
FLASHW_TRAY | Flash the taskbar button.

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


FlashWindow Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow Fields
FlashWindow Class See Also Send Feedback

The FlashWindow type exposes the following members.

Fields

Name | Description
FLASHW_ALL | Flash both the window caption and taskbar button. This is equivalent to setting the FLASHW_CAPTION | FLASHW_TRAY flags.
FLASHW_CAPTION | Flash the window caption.
FLASHW_STOP | Stop flashing. The system restores the window to its original stae.
FLASHW_TIMER | Flash continuously, until the FLASHW_STOP flag is set.
FLASHW_TIMERNOFG | Flash continuously until the window comes to the foreground.
FLASHW_TRAY | Flash the taskbar button.

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


FLASHW_ALL Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..FLASHW_ALL Field
FlashWindow Class See Also Send Feedback
Flash both the window caption and taskbar button. This is equivalent to setting the FLASHW_CAPTION | FLASHW_TRAY flags.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int FLASHW_ALL
Visual Basic
Public Const FLASHW_ALL As Integer
Visual C++
public:
literal int FLASHW_ALL

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


FLASHW_CAPTION Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..FLASHW_CAPTION Field
FlashWindow Class See Also Send Feedback
Flash the window caption.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int FLASHW_CAPTION
Visual Basic
Public Const FLASHW_CAPTION As Integer
Visual C++
public:
literal int FLASHW_CAPTION

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


FLASHW_STOP Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..FLASHW_STOP Field
FlashWindow Class See Also Send Feedback
Stop flashing. The system restores the window to its original stae.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int FLASHW_STOP
Visual Basic
Public Const FLASHW_STOP As Integer
Visual C++
public:
literal int FLASHW_STOP

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


FLASHW_TIMER Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..FLASHW_TIMER Field
FlashWindow Class See Also Send Feedback
Flash continuously, until the FLASHW_STOP flag is set.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int FLASHW_TIMER
Visual Basic
Public Const FLASHW_TIMER As Integer
Visual C++
public:
literal int FLASHW_TIMER

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


FLASHW_TIMERNOFG Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..FLASHW_TIMERNOFG Field
FlashWindow Class See Also Send Feedback
Flash continuously until the window comes to the foreground.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int FLASHW_TIMERNOFG
Visual Basic
Public Const FLASHW_TIMERNOFG As Integer
Visual C++
public:
literal int FLASHW_TIMERNOFG

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


FLASHW_TRAY Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..FLASHW_TRAY Field
FlashWindow Class See Also Send Feedback
Flash the taskbar button.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int FLASHW_TRAY
Visual Basic
Public Const FLASHW_TRAY As Integer
Visual C++
public:
literal int FLASHW_TRAY

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


FlashWindow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow Methods
FlashWindow Class See Also Send Feedback

The FlashWindow type exposes the following members.

Methods

Name | Description
Flash(IntPtr) | Flash the specified Window until it recieves focus.
Flash(IntPtr, Int32) | Flash the specified Window for the specified number of times
Start | Start Flashing the specified Window.
Stop | Stop Flashing the specified Window.

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


Flash Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..Flash Method
FlashWindow Class See Also Send Feedback

Overload List

Name | Description
Flash(IntPtr) | Flash the specified Window until it recieves focus.
Flash(IntPtr, Int32) | Flash the specified Window for the specified number of times

See Also

FlashWindow Class
FlashWindow Members
ArtOfTest.Common.Win32 Namespace


Flash Method (IntPtr)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..Flash Method (IntPtr)
FlashWindow Class See Also Send Feedback
Flash the specified Window until it recieves focus.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool Flash(
    IntPtr handle
)
Visual Basic
Public Shared Function Flash ( _
    handle As IntPtr _
) As Boolean
Visual C++
public:
static bool Flash(
    IntPtr handle
)

Parameters

handle
Type: System..::..IntPtr
The Window to Flash.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.FlashWindow.Flash(System.IntPtr)"]

See Also

FlashWindow Class
Flash Overload
ArtOfTest.Common.Win32 Namespace


Flash Method (IntPtr, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..Flash Method (IntPtr, Int32)
FlashWindow Class See Also Send Feedback
Flash the specified Window for the specified number of times

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool Flash(
    IntPtr handle,
    int count
)
Visual Basic
Public Shared Function Flash ( _
    handle As IntPtr, _
    count As Integer _
) As Boolean
Visual C++
public:
static bool Flash(
    IntPtr handle,
    int count
)

Parameters

handle
Type: System..::..IntPtr
The Window to Flash.
count
Type: System..::..Int32
The number of times to Flash.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.FlashWindow.Flash(System.IntPtr,System.Int32)"]

See Also

FlashWindow Class
Flash Overload
ArtOfTest.Common.Win32 Namespace


Start Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..Start Method
FlashWindow Class See Also Send Feedback
Start Flashing the specified Window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool Start(
    IntPtr handle
)
Visual Basic
Public Shared Function Start ( _
    handle As IntPtr _
) As Boolean
Visual C++
public:
static bool Start(
    IntPtr handle
)

Parameters

handle
Type: System..::..IntPtr
The Window to Flash.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.FlashWindow.Start(System.IntPtr)"]

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


Stop Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlashWindow..::..Stop Method
FlashWindow Class See Also Send Feedback
Stop Flashing the specified Window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool Stop(
    IntPtr handle
)
Visual Basic
Public Shared Function Stop ( _
    handle As IntPtr _
) As Boolean
Visual C++
public:
static bool Stop(
    IntPtr handle
)

Parameters

handle
Type: System..::..IntPtr
The window to stop flashing.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.FlashWindow.Stop(System.IntPtr)"]

See Also

FlashWindow Class
ArtOfTest.Common.Win32 Namespace


HWND Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND Members
HWND Structure Methods Operators Fields Properties See Also Send Feedback

The HWND type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToInt32 |
Public method | ToString()()()() | (Overrides ValueType..::..ToString()()()().)
Public method | ToString(String) |

Operators

Name | Description
Equality(IntPtr, HWND) |
Equality(HWND, HWND) |
Equality(HWND, IntPtr) |
ImplicitWideningImplicitImplicitImplicit(Int32 to HWND) |
ImplicitWideningImplicitImplicitImplicit(IntPtr to HWND) |
ImplicitWideningImplicitImplicitImplicit(AutomationElement to HWND) |
ImplicitWideningImplicitImplicitImplicit(Control to HWND) |
ImplicitWideningImplicitImplicitImplicit(NativeWindow to HWND) |
ImplicitWideningImplicitImplicitImplicit(Window to HWND) |
ImplicitWideningImplicitImplicitImplicit(HWND to IntPtr) |
ImplicitWideningImplicitImplicitImplicit(HWND to Control) |
ImplicitWideningImplicitImplicitImplicit(HWND to AutomationElement) |
ImplicitWideningImplicitImplicitImplicit(HWND to NativeWindow) |
ImplicitWideningImplicitImplicitImplicit(HWND to Int32) |
ImplicitWideningImplicitImplicitImplicit(HWND to Window) |
Inequality(IntPtr, HWND) |
Inequality(HWND, HWND) |
Inequality(HWND, IntPtr) |

Fields

Name | Description
HWND_BOTTOM |
HWND_BROADCAST |
HWND_MESSAGE |
HWND_NOTOPMOST |
HWND_TOP |
HWND_TOPMOST |
NULL |

Properties

 | Name | Description
Public property | Children |
Public property | ClassName |
Public property | Descendants |
Public property | HINSTANCE | This is useful because some frameworks store their DLL instance handle here, allowing you to loosely identify the framework that is managing the window.
Public property | Id |
Public property | IsEnabled |
Public property | IsNull |
Public property | IsWindow |
Public property | Owner |
Public property | Parent |
Public property | ProcessId |
Public property | Root |
Public property | RootOwner |
Public property | Text |
Public property | ThreadId |
Public property | WindowRect | Gets or sets the dimensions of the bounding rectangle of the specified window. The dimensions are given in screen coordinates that are relative to the screen origin.

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HWND Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND Fields
HWND Structure See Also Send Feedback

The HWND type exposes the following members.

Fields

Name | Description
HWND_BOTTOM |
HWND_BROADCAST |
HWND_MESSAGE |
HWND_NOTOPMOST |
HWND_TOP |
HWND_TOPMOST |
NULL |

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HWND_BOTTOM Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..HWND_BOTTOM Field
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.Win32.HWND.HWND_BOTTOM"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly HWND HWND_BOTTOM
Visual Basic
Public Shared ReadOnly HWND_BOTTOM As HWND
Visual C++
public:
static initonly HWND HWND_BOTTOM

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HWND_BROADCAST Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..HWND_BROADCAST Field
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.Win32.HWND.HWND_BROADCAST"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly HWND HWND_BROADCAST
Visual Basic
Public Shared ReadOnly HWND_BROADCAST As HWND
Visual C++
public:
static initonly HWND HWND_BROADCAST

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HWND_MESSAGE Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..HWND_MESSAGE Field
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.Win32.HWND.HWND_MESSAGE"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly HWND HWND_MESSAGE
Visual Basic
Public Shared ReadOnly HWND_MESSAGE As HWND
Visual C++
public:
static initonly HWND HWND_MESSAGE

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HWND_NOTOPMOST Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..HWND_NOTOPMOST Field
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.Win32.HWND.HWND_NOTOPMOST"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly HWND HWND_NOTOPMOST
Visual Basic
Public Shared ReadOnly HWND_NOTOPMOST As HWND
Visual C++
public:
static initonly HWND HWND_NOTOPMOST

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HWND_TOP Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..HWND_TOP Field
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.Win32.HWND.HWND_TOP"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly HWND HWND_TOP
Visual Basic
Public Shared ReadOnly HWND_TOP As HWND
Visual C++
public:
static initonly HWND HWND_TOP

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HWND_TOPMOST Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..HWND_TOPMOST Field
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.Win32.HWND.HWND_TOPMOST"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly HWND HWND_TOPMOST
Visual Basic
Public Shared ReadOnly HWND_TOPMOST As HWND
Visual C++
public:
static initonly HWND HWND_TOPMOST

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


NULL Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..NULL Field
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.Common.Win32.HWND.NULL"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly HWND NULL
Visual Basic
Public Shared ReadOnly NULL As HWND
Visual C++
public:
static initonly HWND NULL

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HWND Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND Methods
HWND Structure See Also Send Feedback

The HWND type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToInt32 |
Public method | ToString()()()() | (Overrides ValueType..::..ToString()()()().)
Public method | ToString(String) |

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Equals Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Equals Method
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.Equals(System.Object)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:ArtOfTest.Common.Win32.HWND.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.Equals(System.Object)"]

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


GetHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..GetHashCode Method
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.GetHashCode"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.GetHashCode"]

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


ToInt32 Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..ToInt32 Method
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.ToInt32"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ToInt32()
Visual Basic
Public Function ToInt32 As Integer
Visual C++
public:
int ToInt32()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.ToInt32"]

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


ToString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..ToString Method
HWND Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | (Overrides ValueType..::..ToString()()()().)
Public method | ToString(String) |

See Also

HWND Structure
HWND Members
ArtOfTest.Common.Win32 Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..ToString Method
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.ToString"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.ToString"]

See Also

HWND Structure
ToString Overload
ArtOfTest.Common.Win32 Namespace


ToString Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..ToString Method (String)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.ToString(System.String)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ToString(
    string strFormat
)
Visual Basic
Public Function ToString ( _
    strFormat As String _
) As String
Visual C++
public:
String^ ToString(
    String^ strFormat
)

Parameters

strFormat
Type: System..::..String

[Missing <param name="strFormat"/> documentation for "M:ArtOfTest.Common.Win32.HWND.ToString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.ToString(System.String)"]

See Also

HWND Structure
ToString Overload
ArtOfTest.Common.Win32 Namespace


HWND Operators and Type Conversions

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND Operators and Type Conversions
HWND Structure See Also Send Feedback

Operators

Name | Description
Equality(IntPtr, HWND) |
Equality(HWND, HWND) |
Equality(HWND, IntPtr) |
ImplicitWideningImplicitImplicitImplicit(Int32 to HWND) |
ImplicitWideningImplicitImplicitImplicit(IntPtr to HWND) |
ImplicitWideningImplicitImplicitImplicit(AutomationElement to HWND) |
ImplicitWideningImplicitImplicitImplicit(Control to HWND) |
ImplicitWideningImplicitImplicitImplicit(NativeWindow to HWND) |
ImplicitWideningImplicitImplicitImplicit(Window to HWND) |
ImplicitWideningImplicitImplicitImplicit(HWND to IntPtr) |
ImplicitWideningImplicitImplicitImplicit(HWND to Control) |
ImplicitWideningImplicitImplicitImplicit(HWND to AutomationElement) |
ImplicitWideningImplicitImplicitImplicit(HWND to NativeWindow) |
ImplicitWideningImplicitImplicitImplicit(HWND to Int32) |
ImplicitWideningImplicitImplicitImplicit(HWND to Window) |
Inequality(IntPtr, HWND) |
Inequality(HWND, HWND) |
Inequality(HWND, IntPtr) |

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Equality Operator

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Equality Operator
HWND Structure See Also Send Feedback

Overload List

Name | Description
Equality(IntPtr, HWND) |
Equality(HWND, HWND) |
Equality(HWND, IntPtr) |

See Also

HWND Structure
HWND Members
ArtOfTest.Common.Win32 Namespace


Equality Operator (IntPtr, HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Equality Operator (IntPtr, HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(System.IntPtr,ArtOfTest.Common.Win32.HWND)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool operator ==(
    IntPtr hwnd1,
    HWND hwnd2
)
Visual Basic
Public Shared Operator = ( _
    hwnd1 As IntPtr, _
    hwnd2 As HWND _
) As Boolean
Visual C++
public:
static bool operator ==(
    IntPtr hwnd1,
    HWND hwnd2
)

Parameters

hwnd1
Type: System..::..IntPtr

[Missing <param name="hwnd1"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(System.IntPtr,ArtOfTest.Common.Win32.HWND)"]

hwnd2
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd2"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(System.IntPtr,ArtOfTest.Common.Win32.HWND)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(System.IntPtr,ArtOfTest.Common.Win32.HWND)"]

See Also

HWND Structure
Equality Overload
ArtOfTest.Common.Win32 Namespace


Equality Operator (HWND, HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Equality Operator (HWND, HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(ArtOfTest.Common.Win32.HWND,ArtOfTest.Common.Win32.HWND)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool operator ==(
    HWND hwnd1,
    HWND hwnd2
)
Visual Basic
Public Shared Operator = ( _
    hwnd1 As HWND, _
    hwnd2 As HWND _
) As Boolean
Visual C++
public:
static bool operator ==(
    HWND hwnd1,
    HWND hwnd2
)

Parameters

hwnd1
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd1"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(ArtOfTest.Common.Win32.HWND,ArtOfTest.Common.Win32.HWND)"]

hwnd2
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd2"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(ArtOfTest.Common.Win32.HWND,ArtOfTest.Common.Win32.HWND)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(ArtOfTest.Common.Win32.HWND,ArtOfTest.Common.Win32.HWND)"]

See Also

HWND Structure
Equality Overload
ArtOfTest.Common.Win32 Namespace


Equality Operator (HWND, IntPtr)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Equality Operator (HWND, IntPtr)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(ArtOfTest.Common.Win32.HWND,System.IntPtr)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool operator ==(
    HWND hwnd1,
    IntPtr hwnd2
)
Visual Basic
Public Shared Operator = ( _
    hwnd1 As HWND, _
    hwnd2 As IntPtr _
) As Boolean
Visual C++
public:
static bool operator ==(
    HWND hwnd1,
    IntPtr hwnd2
)

Parameters

hwnd1
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd1"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(ArtOfTest.Common.Win32.HWND,System.IntPtr)"]

hwnd2
Type: System..::..IntPtr

[Missing <param name="hwnd2"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(ArtOfTest.Common.Win32.HWND,System.IntPtr)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Equality(ArtOfTest.Common.Win32.HWND,System.IntPtr)"]

See Also

HWND Structure
Equality Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion Operators

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion Operators
HWND Structure See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(Int32 to HWND) |
ImplicitWideningImplicitImplicitImplicit(IntPtr to HWND) |
ImplicitWideningImplicitImplicitImplicit(AutomationElement to HWND) |
ImplicitWideningImplicitImplicitImplicit(Control to HWND) |
ImplicitWideningImplicitImplicitImplicit(NativeWindow to HWND) |
ImplicitWideningImplicitImplicitImplicit(Window to HWND) |
ImplicitWideningImplicitImplicitImplicit(HWND to IntPtr) |
ImplicitWideningImplicitImplicitImplicit(HWND to Control) |
ImplicitWideningImplicitImplicitImplicit(HWND to AutomationElement) |
ImplicitWideningImplicitImplicitImplicit(HWND to NativeWindow) |
ImplicitWideningImplicitImplicitImplicit(HWND to Int32) |
ImplicitWideningImplicitImplicitImplicit(HWND to Window) |

See Also

HWND Structure
HWND Members
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (Int32 to HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (Int32 to HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Int32)~ArtOfTest.Common.Win32.HWND"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator HWND (
    int hwnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hwnd As Integer _
) As HWND
Visual C++
static implicit operator HWND (
    int hwnd
)

Parameters

hwnd
Type: System..::..Int32

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Int32)~ArtOfTest.Common.Win32.HWND"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Int32)~ArtOfTest.Common.Win32.HWND"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (IntPtr to HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (IntPtr to HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.IntPtr)~ArtOfTest.Common.Win32.HWND"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator HWND (
    IntPtr hwnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hwnd As IntPtr _
) As HWND
Visual C++
static implicit operator HWND (
    IntPtr hwnd
)

Parameters

hwnd
Type: System..::..IntPtr

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.IntPtr)~ArtOfTest.Common.Win32.HWND"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.IntPtr)~ArtOfTest.Common.Win32.HWND"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (AutomationElement to HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (AutomationElement to HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Automation.AutomationElement)~ArtOfTest.Common.Win32.HWND"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator HWND (
    AutomationElement element
)
Visual Basic
Public Shared Widening Operator CType ( _
    element As AutomationElement _
) As HWND
Visual C++
static implicit operator HWND (
    AutomationElement^ element
)

Parameters

element
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Automation.AutomationElement)~ArtOfTest.Common.Win32.HWND"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Automation.AutomationElement)~ArtOfTest.Common.Win32.HWND"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (Control to HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (Control to HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Forms.Control)~ArtOfTest.Common.Win32.HWND"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator HWND (
    Control control
)
Visual Basic
Public Shared Widening Operator CType ( _
    control As Control _
) As HWND
Visual C++
static implicit operator HWND (
    Control^ control
)

Parameters

control
Type: System.Windows.Forms..::..Control

[Missing <param name="control"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Forms.Control)~ArtOfTest.Common.Win32.HWND"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Forms.Control)~ArtOfTest.Common.Win32.HWND"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (NativeWindow to HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (NativeWindow to HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Forms.NativeWindow)~ArtOfTest.Common.Win32.HWND"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator HWND (
    NativeWindow control
)
Visual Basic
Public Shared Widening Operator CType ( _
    control As NativeWindow _
) As HWND
Visual C++
static implicit operator HWND (
    NativeWindow^ control
)

Parameters

control
Type: System.Windows.Forms..::..NativeWindow

[Missing <param name="control"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Forms.NativeWindow)~ArtOfTest.Common.Win32.HWND"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Forms.NativeWindow)~ArtOfTest.Common.Win32.HWND"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (Window to HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (Window to HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Window)~ArtOfTest.Common.Win32.HWND"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator HWND (
    Window window
)
Visual Basic
Public Shared Widening Operator CType ( _
    window As Window _
) As HWND
Visual C++
static implicit operator HWND (
    Window^ window
)

Parameters

window
Type: System.Windows..::..Window

[Missing <param name="window"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Window)~ArtOfTest.Common.Win32.HWND"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(System.Windows.Window)~ArtOfTest.Common.Win32.HWND"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (HWND to IntPtr)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (HWND to IntPtr)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.IntPtr"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator IntPtr (
    HWND hwnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hwnd As HWND _
) As IntPtr
Visual C++
static implicit operator IntPtr (
    HWND hwnd
)

Parameters

hwnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.IntPtr"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.IntPtr"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (HWND to Control)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (HWND to Control)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Forms.Control"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator Control (
    HWND hwnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hwnd As HWND _
) As Control
Visual C++
static implicit operator Control^ (
    HWND hwnd
)

Parameters

hwnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Forms.Control"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Forms.Control"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (HWND to AutomationElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (HWND to AutomationElement)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Automation.AutomationElement"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator AutomationElement (
    HWND hwnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hwnd As HWND _
) As AutomationElement
Visual C++
static implicit operator AutomationElement^ (
    HWND hwnd
)

Parameters

hwnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Automation.AutomationElement"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Automation.AutomationElement"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (HWND to NativeWindow)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (HWND to NativeWindow)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Forms.NativeWindow"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator NativeWindow (
    HWND hwnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hwnd As HWND _
) As NativeWindow
Visual C++
static implicit operator NativeWindow^ (
    HWND hwnd
)

Parameters

hwnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Forms.NativeWindow"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Forms.NativeWindow"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (HWND to Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (HWND to Int32)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Int32"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator int (
    HWND hwnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hwnd As HWND _
) As Integer
Visual C++
static implicit operator int (
    HWND hwnd
)

Parameters

hwnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Int32"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Int32"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (HWND to Window)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND ImplicitWideningImplicitImplicitImplicit Conversion (HWND to Window)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Window"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator Window (
    HWND hwnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hwnd As HWND _
) As Window
Visual C++
static implicit operator Window^ (
    HWND hwnd
)

Parameters

hwnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Window"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Implicit(ArtOfTest.Common.Win32.HWND)~System.Windows.Window"]

See Also

HWND Structure
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Inequality Operator

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Inequality Operator
HWND Structure See Also Send Feedback

Overload List

Name | Description
Inequality(IntPtr, HWND) |
Inequality(HWND, HWND) |
Inequality(HWND, IntPtr) |

See Also

HWND Structure
HWND Members
ArtOfTest.Common.Win32 Namespace


Inequality Operator (IntPtr, HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Inequality Operator (IntPtr, HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(System.IntPtr,ArtOfTest.Common.Win32.HWND)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool operator !=(
    IntPtr hwnd1,
    HWND hwnd2
)
Visual Basic
Public Shared Operator <> ( _
    hwnd1 As IntPtr, _
    hwnd2 As HWND _
) As Boolean
Visual C++
public:
static bool operator !=(
    IntPtr hwnd1,
    HWND hwnd2
)

Parameters

hwnd1
Type: System..::..IntPtr

[Missing <param name="hwnd1"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(System.IntPtr,ArtOfTest.Common.Win32.HWND)"]

hwnd2
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd2"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(System.IntPtr,ArtOfTest.Common.Win32.HWND)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(System.IntPtr,ArtOfTest.Common.Win32.HWND)"]

See Also

HWND Structure
Inequality Overload
ArtOfTest.Common.Win32 Namespace


Inequality Operator (HWND, HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Inequality Operator (HWND, HWND)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(ArtOfTest.Common.Win32.HWND,ArtOfTest.Common.Win32.HWND)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool operator !=(
    HWND hwnd1,
    HWND hwnd2
)
Visual Basic
Public Shared Operator <> ( _
    hwnd1 As HWND, _
    hwnd2 As HWND _
) As Boolean
Visual C++
public:
static bool operator !=(
    HWND hwnd1,
    HWND hwnd2
)

Parameters

hwnd1
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd1"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(ArtOfTest.Common.Win32.HWND,ArtOfTest.Common.Win32.HWND)"]

hwnd2
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd2"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(ArtOfTest.Common.Win32.HWND,ArtOfTest.Common.Win32.HWND)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(ArtOfTest.Common.Win32.HWND,ArtOfTest.Common.Win32.HWND)"]

See Also

HWND Structure
Inequality Overload
ArtOfTest.Common.Win32 Namespace


Inequality Operator (HWND, IntPtr)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Inequality Operator (HWND, IntPtr)
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(ArtOfTest.Common.Win32.HWND,System.IntPtr)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool operator !=(
    HWND hwnd1,
    IntPtr hwnd2
)
Visual Basic
Public Shared Operator <> ( _
    hwnd1 As HWND, _
    hwnd2 As IntPtr _
) As Boolean
Visual C++
public:
static bool operator !=(
    HWND hwnd1,
    IntPtr hwnd2
)

Parameters

hwnd1
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd1"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(ArtOfTest.Common.Win32.HWND,System.IntPtr)"]

hwnd2
Type: System..::..IntPtr

[Missing <param name="hwnd2"/> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(ArtOfTest.Common.Win32.HWND,System.IntPtr)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.HWND.op_Inequality(ArtOfTest.Common.Win32.HWND,System.IntPtr)"]

See Also

HWND Structure
Inequality Overload
ArtOfTest.Common.Win32 Namespace


HWND Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND Properties
HWND Structure See Also Send Feedback

The HWND type exposes the following members.

Properties

 | Name | Description
Public property | Children |
Public property | ClassName |
Public property | Descendants |
Public property | HINSTANCE | This is useful because some frameworks store their DLL instance handle here, allowing you to loosely identify the framework that is managing the window.
Public property | Id |
Public property | IsEnabled |
Public property | IsNull |
Public property | IsWindow |
Public property | Owner |
Public property | Parent |
Public property | ProcessId |
Public property | Root |
Public property | RootOwner |
Public property | Text |
Public property | ThreadId |
Public property | WindowRect | Gets or sets the dimensions of the bounding rectangle of the specified window. The dimensions are given in screen coordinates that are relative to the screen origin.

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Children Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Children Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.Children"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HWND> Children { get; }
Visual Basic
Public ReadOnly Property Children As IList(Of HWND)
    Get
Visual C++
public:
property IList<HWND>^ Children {
    IList<HWND>^ get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


ClassName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..ClassName Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.ClassName"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ClassName { get; }
Visual Basic
Public ReadOnly Property ClassName As String
    Get
Visual C++
public:
property String^ ClassName {
    String^ get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Descendants Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Descendants Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.Descendants"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HWND> Descendants { get; }
Visual Basic
Public ReadOnly Property Descendants As IList(Of HWND)
    Get
Visual C++
public:
property IList<HWND>^ Descendants {
    IList<HWND>^ get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


HINSTANCE Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..HINSTANCE Property
HWND Structure See Also Send Feedback
This is useful because some frameworks store their DLL instance handle here, allowing you to loosely identify the framework that is managing the window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IntPtr HINSTANCE { get; }
Visual Basic
Public ReadOnly Property HINSTANCE As IntPtr
    Get
Visual C++
public:
property IntPtr HINSTANCE {
    IntPtr get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Id Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Id Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.Id"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
Visual C++
public:
property int Id {
    int get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


IsEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..IsEnabled Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.IsEnabled"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEnabled { get; }
Visual Basic
Public ReadOnly Property IsEnabled As Boolean
    Get
Visual C++
public:
property bool IsEnabled {
    bool get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


IsNull Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..IsNull Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.IsNull"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsNull { get; set; }
Visual Basic
Public Property IsNull As Boolean
    Get
    Set
Visual C++
public:
property bool IsNull {
    bool get ();
    void set (bool value);
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


IsWindow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..IsWindow Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.IsWindow"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsWindow { get; }
Visual Basic
Public ReadOnly Property IsWindow As Boolean
    Get
Visual C++
public:
property bool IsWindow {
    bool get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Owner Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Owner Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.Owner"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HWND Owner { get; }
Visual Basic
Public ReadOnly Property Owner As HWND
    Get
Visual C++
public:
property HWND Owner {
    HWND get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Parent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Parent Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.Parent"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HWND Parent { get; }
Visual Basic
Public ReadOnly Property Parent As HWND
    Get
Visual C++
public:
property HWND Parent {
    HWND get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


ProcessId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..ProcessId Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.ProcessId"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public uint ProcessId { get; }
Visual Basic
Public ReadOnly Property ProcessId As UInteger
    Get
Visual C++
public:
property unsigned int ProcessId {
    unsigned int get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Root Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Root Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.Root"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HWND Root { get; }
Visual Basic
Public ReadOnly Property Root As HWND
    Get
Visual C++
public:
property HWND Root {
    HWND get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


RootOwner Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..RootOwner Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.RootOwner"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HWND RootOwner { get; }
Visual Basic
Public ReadOnly Property RootOwner As HWND
    Get
Visual C++
public:
property HWND RootOwner {
    HWND get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..Text Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.Text"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


ThreadId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..ThreadId Property
HWND Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.HWND.ThreadId"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public uint ThreadId { get; }
Visual Basic
Public ReadOnly Property ThreadId As UInteger
    Get
Visual C++
public:
property unsigned int ThreadId {
    unsigned int get ();
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


WindowRect Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HWND..::..WindowRect Property
HWND Structure See Also Send Feedback
Gets or sets the dimensions of the bounding rectangle of the specified window. The dimensions are given in screen coordinates that are relative to the screen origin.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle WindowRect { get; set; }
Visual Basic
Public Property WindowRect As Rectangle
    Get
    Set
Visual C++
public:
property Rectangle WindowRect {
    Rectangle get ();
    void set (Rectangle value);
}

See Also

HWND Structure
ArtOfTest.Common.Win32 Namespace


IAdornerWindowContent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAdornerWindowContent Members
IAdornerWindowContent Interface Properties See Also Send Feedback

The IAdornerWindowContent type exposes the following members.

Properties

 | Name | Description
Public property | Location |
Public property | Size |
Public property | Thumb |
Public property | Transform |

See Also

IAdornerWindowContent Interface
ArtOfTest.Common.Win32 Namespace


IAdornerWindowContent Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAdornerWindowContent Properties
IAdornerWindowContent Interface See Also Send Feedback

The IAdornerWindowContent type exposes the following members.

Properties

 | Name | Description
Public property | Location |
Public property | Size |
Public property | Thumb |
Public property | Transform |

See Also

IAdornerWindowContent Interface
ArtOfTest.Common.Win32 Namespace


Location Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAdornerWindowContent..::..Location Property
IAdornerWindowContent Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.IAdornerWindowContent.Location"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Point Location { get; }
Visual Basic
ReadOnly Property Location As Point
    Get
Visual C++
property Point Location {
    Point get ();
}

See Also

IAdornerWindowContent Interface
ArtOfTest.Common.Win32 Namespace


Size Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAdornerWindowContent..::..Size Property
IAdornerWindowContent Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.IAdornerWindowContent.Size"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Size Size { get; }
Visual Basic
ReadOnly Property Size As Size
    Get
Visual C++
property Size Size {
    Size get ();
}

See Also

IAdornerWindowContent Interface
ArtOfTest.Common.Win32 Namespace


Thumb Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAdornerWindowContent..::..Thumb Property
IAdornerWindowContent Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.IAdornerWindowContent.Thumb"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Thumb Thumb { get; }
Visual Basic
ReadOnly Property Thumb As Thumb
    Get
Visual C++
property Thumb^ Thumb {
    Thumb^ get ();
}

See Also

IAdornerWindowContent Interface
ArtOfTest.Common.Win32 Namespace


Transform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAdornerWindowContent..::..Transform Property
IAdornerWindowContent Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.IAdornerWindowContent.Transform"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Transform Transform { get; set; }
Visual Basic
Property Transform As Transform
    Get
    Set
Visual C++
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

IAdornerWindowContent Interface
ArtOfTest.Common.Win32 Namespace


TunnelingMouseEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TunnelingMouseEventArgs Members
TunnelingMouseEventArgs Class Constructors Methods Properties See Also Send Feedback

The TunnelingMouseEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TunnelingMouseEventArgs | Constructs a new TunnelingMouseEventArgs object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Button | Gets which mouse button was pressed. (Inherited from MouseEventArgs.)
Public property | Clicks | Gets the number of times the mouse button was pressed and released. (Inherited from MouseEventArgs.)
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel. (Inherited from MouseEventArgs.)
Public property | Location | Gets the location of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | StopTunneling | Controls whether or not to stop processing mouse messages.
Public property | X | Gets the x-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | Y | Gets the y-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)

See Also

TunnelingMouseEventArgs Class
ArtOfTest.Common.Win32 Namespace


TunnelingMouseEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TunnelingMouseEventArgs Constructor
TunnelingMouseEventArgs Class See Also Send Feedback
Constructs a new TunnelingMouseEventArgs object.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TunnelingMouseEventArgs(
    MouseButtons button,
    int clicks,
    int x,
    int y,
    int delta
)
Visual Basic
Public Sub New ( _
    button As MouseButtons, _
    clicks As Integer, _
    x As Integer, _
    y As Integer, _
    delta As Integer _
)
Visual C++
public:
TunnelingMouseEventArgs(
    MouseButtons button,
    int clicks,
    int x,
    int y,
    int delta
)

Parameters

button
Type: System.Windows.Forms..::..MouseButtons
The mouse button.
clicks
Type: System..::..Int32
Number of clicks.
x
Type: System..::..Int32
The mouse x position.
y
Type: System..::..Int32
The mouse y position.
delta
Type: System..::..Int32
A signed count of the number of detents the wheel has rotated.

See Also

TunnelingMouseEventArgs Class
ArtOfTest.Common.Win32 Namespace


TunnelingMouseEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TunnelingMouseEventArgs Methods
TunnelingMouseEventArgs Class See Also Send Feedback

The TunnelingMouseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TunnelingMouseEventArgs Class
ArtOfTest.Common.Win32 Namespace


TunnelingMouseEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TunnelingMouseEventArgs Properties
TunnelingMouseEventArgs Class See Also Send Feedback

The TunnelingMouseEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Button | Gets which mouse button was pressed. (Inherited from MouseEventArgs.)
Public property | Clicks | Gets the number of times the mouse button was pressed and released. (Inherited from MouseEventArgs.)
Public property | Delta | Gets a signed count of the number of detents the mouse wheel has rotated. A detent is one notch of the mouse wheel. (Inherited from MouseEventArgs.)
Public property | Location | Gets the location of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | StopTunneling | Controls whether or not to stop processing mouse messages.
Public property | X | Gets the x-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)
Public property | Y | Gets the y-coordinate of the mouse during the generating mouse event. (Inherited from MouseEventArgs.)

See Also

TunnelingMouseEventArgs Class
ArtOfTest.Common.Win32 Namespace


StopTunneling Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TunnelingMouseEventArgs..::..StopTunneling Property
TunnelingMouseEventArgs Class See Also Send Feedback
Controls whether or not to stop processing mouse messages.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopTunneling { get; set; }
Visual Basic
Public Property StopTunneling As Boolean
    Get
    Set
Visual C++
public:
property bool StopTunneling {
    bool get ();
    void set (bool value);
}

See Also

TunnelingMouseEventArgs Class
ArtOfTest.Common.Win32 Namespace


Window Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Members
Window Class Constructors Methods Operators Properties Events See Also Send Feedback

The Window type exposes the following members.

Constructors

 | Name | Description
Public method | Window | Constructs a new instance of this class for the specified Window Handle.

Methods

 | Name | Description
Public method | AttachWrappedWindow | Attach to the wrapper window handle. This call is needed to allow for events to fire on this window.
Public method | Center | Get the center point of this window
Public method | Close | Close the window.
Public method | ContainsControl | Returns true/false whether the Win32 control id is a child of this window
Public method | ContainsText | Returns true/false whether the text is present within this window.
Public method | DetachWrappedWindow | Detach from the window handle.
 | EnumHwndAncestors |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitmap()()()() |
Public method | GetBitmap(RectangleF) | Returns a bitmap of a specified target area within this window.
Public method | GetBitmap(Size) | Capture the entire window bitmap and returns it.
Public method | GetHashCode | The hash code is the window's hwnd. (Overrides Object..::..GetHashCode()()()().)
Public method | GetText | Get the text contained in this window and all its children windows.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Hide the window.
 | IsHwndDialog | Gets whether the provided window handle represents a dialog
Public method | MakeAbsolute | Return the absolute coordinate of the relative rectangle.
Public method | MakeRelative | Make the absolute rects passed in relative to this window.
Public method | Maximize | Maximize the window
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimize | Minimize the window.
Public method | Move | Move this window to a new location
Protected method | OnClick | For internal use only.
Protected method | OnDoubleClick | For internal use only.
Protected method | OnKeyDown | For internal use only.
Protected method | OnKeyPressed | For internal use only.
Protected method | OnKeyUp | For internal use only.
Protected method | OnMouseClick(MouseEventArgs) | For internal use only.
Protected method | OnMouseClick(MouseButtons, Int32, Int32, Int32) | For internal use only.
Protected method | OnMouseDoubleClick | For internal use only.
Protected method | OnMouseDown(MouseEventArgs) | For internal use only.
Protected method | OnMouseDown(MouseButtons, Int32, Int32) | For internal use only.
Protected method | OnMouseMove | For internal use only.
Protected method | OnMouseUp(MouseEventArgs) | For internal use only.
Protected method | OnMouseUp(MouseButtons, Int32, Int32) | For internal use only.
Protected method | OnPreMouseClick | For internal use only.
Protected method | OnPreMouseDown | For internal use only.
Protected method | OnPreMouseUp | For internal use only.
Protected method | OnWindowMoved | For internal use only.
Public method | RefreshChildren | Refresh the list of child windows (Window.Children) of this window
Public method | Restore | Restore the window to its default size/location
Public method | SetActive | Set this window to active.
Public method | SetFocus | Restores and Brings the window to the front, assuming it is a visible application window.
Public method | SetPosition |
Public method | Show | Show this window and make it visible
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Update the window. Invalidates all areas and forces a redraw.
Public method | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window
Public method | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(HWND to Window) |
ImplicitWideningImplicitImplicitImplicit(Window to HWND) |

Properties

 | Name | Description
Public property | AllChildren | Gets a collection of all child windows (at any level) of this window.
Public property | Caption | Gets the window's caption.
Public property | ClassName | Gets the window's class name.
Public property | Enabled | Gets whether this window is enabled or not.
Public property | Exists | Gets whether the window handle represents a live native window.
Public property | Handle | Gets the handle of the window.
Public property | IsDialog | Gets whether this Window is a dialog
Public property | IsForegroundWindow | Gets whether the window is currently in use by the user.
Public property | IsMaximized | Gets whether the window is maximized.
Public property | IsMinimized | Gets whether the window is minimized.
Public property | IsVisible | Gets whether the window is visible.
Public property | Location | Gets the top left point of the location of the window relative to the screen.
Public property | OwnerProcess | The owner process that created this window.
Public property | ParentWindow | Get parent window of this window. Returns null if there is no parent window.
Public property | Rectangle | Gets the rectangle of the window.
Public property | Size | Gets the size of the window.

Events

 | Name | Description
Public event | Click | For internal use only.
Public event | DoubleClick | For internal use only.
Public event | KeyDown | For internal use only.
Public event | KeyPressed | For internal use only.
Public event | KeyUp | For internal use only.
Public event | MouseClick | For internal use only.
Public event | MouseDoubleClick | For internal use only.
Public event | MouseDown | For internal use only.
Public event | MouseMove | For internal use only.
Public event | MouseUp | For internal use only.
Public event | PreMouseClick | For internal use only.
Public event | PreMouseDown | For internal use only.
Public event | PreMouseUp | For internal use only.
Public event | WindowMoved | For internal use only.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Window Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Constructor
Window Class See Also Send Feedback
Constructs a new instance of this class for the specified Window Handle.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Window(
    IntPtr hWnd
)
Visual Basic
Public Sub New ( _
    hWnd As IntPtr _
)
Visual C++
public:
Window(
    IntPtr hWnd
)

Parameters

hWnd
Type: System..::..IntPtr
The Window Handle

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Window Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Methods
Window Class See Also Send Feedback

The Window type exposes the following members.

Methods

 | Name | Description
Public method | AttachWrappedWindow | Attach to the wrapper window handle. This call is needed to allow for events to fire on this window.
Public method | Center | Get the center point of this window
Public method | Close | Close the window.
Public method | ContainsControl | Returns true/false whether the Win32 control id is a child of this window
Public method | ContainsText | Returns true/false whether the text is present within this window.
Public method | DetachWrappedWindow | Detach from the window handle.
 | EnumHwndAncestors |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitmap()()()() |
Public method | GetBitmap(RectangleF) | Returns a bitmap of a specified target area within this window.
Public method | GetBitmap(Size) | Capture the entire window bitmap and returns it.
Public method | GetHashCode | The hash code is the window's hwnd. (Overrides Object..::..GetHashCode()()()().)
Public method | GetText | Get the text contained in this window and all its children windows.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Hide the window.
 | IsHwndDialog | Gets whether the provided window handle represents a dialog
Public method | MakeAbsolute | Return the absolute coordinate of the relative rectangle.
Public method | MakeRelative | Make the absolute rects passed in relative to this window.
Public method | Maximize | Maximize the window
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimize | Minimize the window.
Public method | Move | Move this window to a new location
Protected method | OnClick | For internal use only.
Protected method | OnDoubleClick | For internal use only.
Protected method | OnKeyDown | For internal use only.
Protected method | OnKeyPressed | For internal use only.
Protected method | OnKeyUp | For internal use only.
Protected method | OnMouseClick(MouseEventArgs) | For internal use only.
Protected method | OnMouseClick(MouseButtons, Int32, Int32, Int32) | For internal use only.
Protected method | OnMouseDoubleClick | For internal use only.
Protected method | OnMouseDown(MouseEventArgs) | For internal use only.
Protected method | OnMouseDown(MouseButtons, Int32, Int32) | For internal use only.
Protected method | OnMouseMove | For internal use only.
Protected method | OnMouseUp(MouseEventArgs) | For internal use only.
Protected method | OnMouseUp(MouseButtons, Int32, Int32) | For internal use only.
Protected method | OnPreMouseClick | For internal use only.
Protected method | OnPreMouseDown | For internal use only.
Protected method | OnPreMouseUp | For internal use only.
Protected method | OnWindowMoved | For internal use only.
Public method | RefreshChildren | Refresh the list of child windows (Window.Children) of this window
Public method | Restore | Restore the window to its default size/location
Public method | SetActive | Set this window to active.
Public method | SetFocus | Restores and Brings the window to the front, assuming it is a visible application window.
Public method | SetPosition |
Public method | Show | Show this window and make it visible
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Update the window. Invalidates all areas and forces a redraw.
Public method | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window
Public method | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


AttachWrappedWindow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..AttachWrappedWindow Method
Window Class See Also Send Feedback
Attach to the wrapper window handle. This call is needed to allow for events to fire on this window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AttachWrappedWindow()
Visual Basic
Public Sub AttachWrappedWindow
Visual C++
public:
void AttachWrappedWindow()

Remarks

The window attached to must be in the same process as this window object for it to intercept its messages and fire its events

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Center Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Center Method
Window Class See Also Send Feedback
Get the center point of this window

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Center()
Visual Basic
Public Function Center As Point
Visual C++
public:
Point Center()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.Window.Center"]

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Close Method
Window Class See Also Send Feedback
Close the window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


ContainsControl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ContainsControl Method
Window Class See Also Send Feedback
Returns true/false whether the Win32 control id is a child of this window

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ContainsControl(
    int controlId
)
Visual Basic
Public Function ContainsControl ( _
    controlId As Integer _
) As Boolean
Visual C++
public:
bool ContainsControl(
    int controlId
)

Parameters

controlId
Type: System..::..Int32
The control id.

Return Value

True/False whether the control exits

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


ContainsText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ContainsText Method
Window Class See Also Send Feedback
Returns true/false whether the text is present within this window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ContainsText(
    string text,
    bool refreshChildren
)
Visual Basic
Public Function ContainsText ( _
    text As String, _
    refreshChildren As Boolean _
) As Boolean
Visual C++
public:
bool ContainsText(
    String^ text,
    bool refreshChildren
)

Parameters

text
Type: System..::..String
The text to check.
refreshChildren
Type: System..::..Boolean
True/False whether to refresh the Children of this window or simply use the cached collection.

Return Value

True/False whether the text exists.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


DetachWrappedWindow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..DetachWrappedWindow Method
Window Class See Also Send Feedback
Detach from the window handle.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DetachWrappedWindow()
Visual Basic
Public Sub DetachWrappedWindow
Visual C++
public:
void DetachWrappedWindow()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


EnumHwndAncestors Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..EnumHwndAncestors Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.Window.EnumHwndAncestors(ArtOfTest.Common.Win32.HWND)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static IEnumerable<HWND> EnumHwndAncestors(
    HWND hwnd
)
Visual Basic
Public Shared Function EnumHwndAncestors ( _
    hwnd As HWND _
) As IEnumerable(Of HWND)
Visual C++
public:
static IEnumerable<HWND>^ EnumHwndAncestors(
    HWND hwnd
)

Parameters

hwnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.Window.EnumHwndAncestors(ArtOfTest.Common.Win32.HWND)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.Window.EnumHwndAncestors(ArtOfTest.Common.Win32.HWND)"]

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


GetBitmap Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetBitmap Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBitmap()()()() |
Public method | GetBitmap(RectangleF) | Returns a bitmap of a specified target area within this window.
Public method | GetBitmap(Size) | Capture the entire window bitmap and returns it.

See Also

Window Class
Window Members
ArtOfTest.Common.Win32 Namespace


GetBitmap Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetBitmap Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.Window.GetBitmap"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap GetBitmap()
Visual Basic
Public Function GetBitmap As Bitmap
Visual C++
public:
Bitmap^ GetBitmap()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.Window.GetBitmap"]

See Also

Window Class
GetBitmap Overload
ArtOfTest.Common.Win32 Namespace


GetBitmap Method (RectangleF)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetBitmap Method (RectangleF)
Window Class See Also Send Feedback
Returns a bitmap of a specified target area within this window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap GetBitmap(
    RectangleF targetArea
)
Visual Basic
Public Function GetBitmap ( _
    targetArea As RectangleF _
) As Bitmap
Visual C++
public:
Bitmap^ GetBitmap(
    RectangleF targetArea
)

Parameters

targetArea
Type: System.Drawing..::..RectangleF
The target area to return the bitmap for.

Return Value

The bitmap of that target area as it appears in the window.

See Also

Window Class
GetBitmap Overload
ArtOfTest.Common.Win32 Namespace


GetBitmap Method (Size)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetBitmap Method (Size)
Window Class See Also Send Feedback
Capture the entire window bitmap and returns it.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap GetBitmap(
    Size windowSize
)
Visual Basic
Public Function GetBitmap ( _
    windowSize As Size _
) As Bitmap
Visual C++
public:
Bitmap^ GetBitmap(
    Size windowSize
)

Parameters

windowSize
Type: System.Drawing..::..Size

[Missing <param name="windowSize"/> documentation for "M:ArtOfTest.Common.Win32.Window.GetBitmap(System.Drawing.Size)"]

Return Value

A bitmap of the window, otherwise will return null

See Also

Window Class
GetBitmap Overload
ArtOfTest.Common.Win32 Namespace


GetHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetHashCode Method
Window Class See Also Send Feedback
The hash code is the window's hwnd.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The Window Handle of this window

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


GetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetText Method
Window Class See Also Send Feedback
Get the text contained in this window and all its children windows.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetText()
Visual Basic
Public Function GetText As String
Visual C++
public:
String^ GetText()

Return Value

Returns a text concatenation of this window and all its children

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Hide Method
Window Class See Also Send Feedback
Hide the window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


IsHwndDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsHwndDialog Method
Window Class See Also Send Feedback
Gets whether the provided window handle represents a dialog

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsHwndDialog(
    HWND hwnd
)
Visual Basic
Public Shared Function IsHwndDialog ( _
    hwnd As HWND _
) As Boolean
Visual C++
public:
static bool IsHwndDialog(
    HWND hwnd
)

Parameters

hwnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.Common.Win32.Window.IsHwndDialog(ArtOfTest.Common.Win32.HWND)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.Window.IsHwndDialog(ArtOfTest.Common.Win32.HWND)"]

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


MakeAbsolute Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..MakeAbsolute Method
Window Class See Also Send Feedback
Return the absolute coordinate of the relative rectangle.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle MakeAbsolute(
    Rectangle windowRelativeRects
)
Visual Basic
Public Function MakeAbsolute ( _
    windowRelativeRects As Rectangle _
) As Rectangle
Visual C++
public:
Rectangle MakeAbsolute(
    Rectangle windowRelativeRects
)

Parameters

windowRelativeRects
Type: System.Drawing..::..Rectangle
The relative rectangle with respect to this window.

Return Value

The absolute

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


MakeRelative Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..MakeRelative Method
Window Class See Also Send Feedback
Make the absolute rects passed in relative to this window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle MakeRelative(
    Rectangle absoluteRects
)
Visual Basic
Public Function MakeRelative ( _
    absoluteRects As Rectangle _
) As Rectangle
Visual C++
public:
Rectangle MakeRelative(
    Rectangle absoluteRects
)

Parameters

absoluteRects
Type: System.Drawing..::..Rectangle
The absolute rects

Return Value

The relative coordinates to this window.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Maximize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Maximize Method
Window Class See Also Send Feedback
Maximize the window

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Maximize()
Visual Basic
Public Sub Maximize
Visual C++
public:
void Maximize()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Minimize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Minimize Method
Window Class See Also Send Feedback
Minimize the window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Minimize()
Visual Basic
Public Sub Minimize
Visual C++
public:
void Minimize()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Move Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Move Method
Window Class See Also Send Feedback
Move this window to a new location

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Rectangle newLocation,
    bool redraw
)
Visual Basic
Public Sub Move ( _
    newLocation As Rectangle, _
    redraw As Boolean _
)
Visual C++
public:
void Move(
    Rectangle newLocation,
    bool redraw
)

Parameters

newLocation
Type: System.Drawing..::..Rectangle
The new location to move the window to.
redraw
Type: System..::..Boolean
True/False whether to redraw the window.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnClick Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnClick()
Visual Basic
Protected Overridable Sub OnClick
Visual C++
protected:
virtual void OnClick()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnDoubleClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnDoubleClick Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnDoubleClick()
Visual Basic
Protected Overridable Sub OnDoubleClick
Visual C++
protected:
virtual void OnDoubleClick()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnKeyDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnKeyDown Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnKeyDown(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub OnKeyDown ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyDown(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs
A KeyEventArgs that contains the event data.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnKeyPressed Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnKeyPressed Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnKeyPressed(
    KeyPressEventArgs e
)
Visual Basic
Protected Overridable Sub OnKeyPressed ( _
    e As KeyPressEventArgs _
)
Visual C++
protected:
virtual void OnKeyPressed(
    KeyPressEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyPressEventArgs
A KeyPressEventArgs that contains the event data.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnKeyUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnKeyUp Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnKeyUp(
    KeyEventArgs e
)
Visual Basic
Protected Overridable Sub OnKeyUp ( _
    e As KeyEventArgs _
)
Visual C++
protected:
virtual void OnKeyUp(
    KeyEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..KeyEventArgs

[Missing <param name="e"/> documentation for "M:ArtOfTest.Common.Win32.Window.OnKeyUp(System.Windows.Forms.KeyEventArgs)"]

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnMouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseClick Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | OnMouseClick(MouseEventArgs) | For internal use only.
Protected method | OnMouseClick(MouseButtons, Int32, Int32, Int32) | For internal use only.

See Also

Window Class
Window Members
ArtOfTest.Common.Win32 Namespace


OnMouseClick Method (MouseEventArgs)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseClick Method (MouseEventArgs)
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnMouseClick(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseClick(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

Window Class
OnMouseClick Overload
ArtOfTest.Common.Win32 Namespace


OnMouseClick Method (MouseButtons, Int32, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseClick Method (MouseButtons, Int32, Int32, Int32)
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnMouseClick(
    MouseButtons button,
    int clicks,
    int x,
    int y
)
Visual Basic
Protected Overridable Sub OnMouseClick ( _
    button As MouseButtons, _
    clicks As Integer, _
    x As Integer, _
    y As Integer _
)
Visual C++
protected:
virtual void OnMouseClick(
    MouseButtons button,
    int clicks,
    int x,
    int y
)

Parameters

button
Type: System.Windows.Forms..::..MouseButtons
A MouseButtons that specifiesd which mouse button is associated with this event.
clicks
Type: System..::..Int32
An int specifying the number of times the mouse button was pressed and released.
x
Type: System..::..Int32
The x-coordinate in pixels of the mouse during the generating mouse event.
y
Type: System..::..Int32
The y-coordinate in pixels of the mouse during the generating mouse event.

See Also

Window Class
OnMouseClick Overload
ArtOfTest.Common.Win32 Namespace


OnMouseDoubleClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseDoubleClick Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnMouseDoubleClick(
    MouseButtons button,
    int clicks,
    int x,
    int y
)
Visual Basic
Protected Overridable Sub OnMouseDoubleClick ( _
    button As MouseButtons, _
    clicks As Integer, _
    x As Integer, _
    y As Integer _
)
Visual C++
protected:
virtual void OnMouseDoubleClick(
    MouseButtons button,
    int clicks,
    int x,
    int y
)

Parameters

button
Type: System.Windows.Forms..::..MouseButtons
A MouseButtons that specifiesd which mouse button is associated with this event.
clicks
Type: System..::..Int32
An int specifying the number of times the mouse button was pressed and released.
x
Type: System..::..Int32
The x-coordinate in pixels of the mouse during the generating mouse event.
y
Type: System..::..Int32
The y-coordinate in pixels of the mouse during the generating mouse event.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnMouseDown Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseDown Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | OnMouseDown(MouseEventArgs) | For internal use only.
Protected method | OnMouseDown(MouseButtons, Int32, Int32) | For internal use only.

See Also

Window Class
Window Members
ArtOfTest.Common.Win32 Namespace


OnMouseDown Method (MouseEventArgs)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseDown Method (MouseEventArgs)
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

Window Class
OnMouseDown Overload
ArtOfTest.Common.Win32 Namespace


OnMouseDown Method (MouseButtons, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseDown Method (MouseButtons, Int32, Int32)
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnMouseDown(
    MouseButtons button,
    int x,
    int y
)
Visual Basic
Protected Overridable Sub OnMouseDown ( _
    button As MouseButtons, _
    x As Integer, _
    y As Integer _
)
Visual C++
protected:
virtual void OnMouseDown(
    MouseButtons button,
    int x,
    int y
)

Parameters

button
Type: System.Windows.Forms..::..MouseButtons
A MouseButtons that specifiesd which mouse button is associated with this event.
x
Type: System..::..Int32
The x-coordinate in pixels of the mouse during the generating mouse event.
y
Type: System..::..Int32
The y-coordinate in pixels of the mouse during the generating mouse event.

See Also

Window Class
OnMouseDown Overload
ArtOfTest.Common.Win32 Namespace


OnMouseMove Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseMove Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnMouseMove(
    int x,
    int y
)
Visual Basic
Protected Overridable Sub OnMouseMove ( _
    x As Integer, _
    y As Integer _
)
Visual C++
protected:
virtual void OnMouseMove(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32
The x-coordinate in pixels of the mouse during the generating mouse event.
y
Type: System..::..Int32
The y-coordinate in pixels of the mouse during the generating mouse event.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnMouseUp Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseUp Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | OnMouseUp(MouseEventArgs) | For internal use only.
Protected method | OnMouseUp(MouseButtons, Int32, Int32) | For internal use only.

See Also

Window Class
Window Members
ArtOfTest.Common.Win32 Namespace


OnMouseUp Method (MouseEventArgs)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseUp Method (MouseEventArgs)
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

Window Class
OnMouseUp Overload
ArtOfTest.Common.Win32 Namespace


OnMouseUp Method (MouseButtons, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnMouseUp Method (MouseButtons, Int32, Int32)
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnMouseUp(
    MouseButtons button,
    int x,
    int y
)
Visual Basic
Protected Overridable Sub OnMouseUp ( _
    button As MouseButtons, _
    x As Integer, _
    y As Integer _
)
Visual C++
protected:
virtual void OnMouseUp(
    MouseButtons button,
    int x,
    int y
)

Parameters

button
Type: System.Windows.Forms..::..MouseButtons
A MouseButtons that specifiesd which mouse button is associated with this event.
x
Type: System..::..Int32
The x-coordinate in pixels of the mouse during the generating mouse event.
y
Type: System..::..Int32
The y-coordinate in pixels of the mouse during the generating mouse event.

See Also

Window Class
OnMouseUp Overload
ArtOfTest.Common.Win32 Namespace


OnPreMouseClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnPreMouseClick Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnPreMouseClick(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnPreMouseClick ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnPreMouseClick(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnPreMouseDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnPreMouseDown Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnPreMouseDown(
    MouseEventArgs e
)
Visual Basic
Protected Overridable Sub OnPreMouseDown ( _
    e As MouseEventArgs _
)
Visual C++
protected:
virtual void OnPreMouseDown(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnPreMouseUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnPreMouseUp Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnPreMouseUp(
    MouseEventArgs e
)
Visual Basic
Protected Sub OnPreMouseUp ( _
    e As MouseEventArgs _
)
Visual C++
protected:
void OnPreMouseUp(
    MouseEventArgs^ e
)

Parameters

e
Type: System.Windows.Forms..::..MouseEventArgs
A MouseEventArgs that contains the event data.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OnWindowMoved Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OnWindowMoved Method
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnWindowMoved()
Visual Basic
Protected Overridable Sub OnWindowMoved
Visual C++
protected:
virtual void OnWindowMoved()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


RefreshChildren Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..RefreshChildren Method
Window Class See Also Send Feedback
Refresh the list of child windows (Window.Children) of this window

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RefreshChildren()
Visual Basic
Public Sub RefreshChildren
Visual C++
public:
void RefreshChildren()

Return Value

The WindowsCollection of children

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Restore Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Restore Method
Window Class See Also Send Feedback
Restore the window to its default size/location

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Restore()
Visual Basic
Public Sub Restore
Visual C++
public:
void Restore()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


SetActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..SetActive Method
Window Class See Also Send Feedback
Set this window to active.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetActive()
Visual Basic
Public Sub SetActive
Visual C++
public:
void SetActive()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


SetFocus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..SetFocus Method
Window Class See Also Send Feedback
Restores and Brings the window to the front, assuming it is a visible application window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetFocus()
Visual Basic
Public Sub SetFocus
Visual C++
public:
void SetFocus()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


SetPosition Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..SetPosition Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.Window.SetPosition(ArtOfTest.Common.Win32.WindowPosition)"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetPosition(
    WindowPosition position
)
Visual Basic
Public Sub SetPosition ( _
    position As WindowPosition _
)
Visual C++
public:
void SetPosition(
    WindowPosition position
)

Parameters

position
Type: ArtOfTest.Common.Win32..::..WindowPosition

[Missing <param name="position"/> documentation for "M:ArtOfTest.Common.Win32.Window.SetPosition(ArtOfTest.Common.Win32.WindowPosition)"]

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Show Method
Window Class See Also Send Feedback
Show this window and make it visible

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Update Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Update Method
Window Class See Also Send Feedback
Update the window. Invalidates all areas and forces a redraw.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
Visual C++
public:
void Update()

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


WaitForVisibility Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..WaitForVisibility Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window
Public method | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window

See Also

Window Class
Window Members
ArtOfTest.Common.Win32 Namespace


WaitForVisibility Method (Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..WaitForVisibility Method (Boolean, Int32)
Window Class See Also Send Feedback
Waits for a certain visibility state for a window

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitForVisibility(
    bool visibilityState,
    int timeout
)
Visual Basic
Public Sub WaitForVisibility ( _
    visibilityState As Boolean, _
    timeout As Integer _
)
Visual C++
public:
void WaitForVisibility(
    bool visibilityState,
    int timeout
)

Parameters

visibilityState
Type: System..::..Boolean
The visibility state of the window to wait for. True: wait until window is visible (The window needs to have its handle created before calling this method), False, wait until window is invisible.
timeout
Type: System..::..Int32
The wait timeout in msecs.

See Also

Window Class
WaitForVisibility Overload
ArtOfTest.Common.Win32 Namespace


WaitForVisibility Method (Boolean, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..WaitForVisibility Method (Boolean, Int32, Boolean)
Window Class See Also Send Feedback
Waits for a certain visibility state for a window

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool WaitForVisibility(
    bool visibilityState,
    int timeout,
    bool suppressException
)
Visual Basic
Public Function WaitForVisibility ( _
    visibilityState As Boolean, _
    timeout As Integer, _
    suppressException As Boolean _
) As Boolean
Visual C++
public:
bool WaitForVisibility(
    bool visibilityState,
    int timeout,
    bool suppressException
)

Parameters

visibilityState
Type: System..::..Boolean
The visibility state of the window to wait for. True: wait until window is visible (The window needs to have its handle created before calling this method), False, wait until window is invisible.
timeout
Type: System..::..Int32
The wait timeout in msecs.
suppressException
Type: System..::..Boolean
Whether to throw or return false if the window does not reach the desired visibility state.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.Window.WaitForVisibility(System.Boolean,System.Int32,System.Boolean)"]

See Also

Window Class
WaitForVisibility Overload
ArtOfTest.Common.Win32 Namespace


Window Type Conversions

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Type Conversions
Window Class See Also Send Feedback

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(HWND to Window) |
ImplicitWideningImplicitImplicitImplicit(Window to HWND) |

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Implicit Conversion Operators

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window ImplicitWideningImplicitImplicitImplicit Conversion Operators
Window Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(HWND to Window) |
ImplicitWideningImplicitImplicitImplicit(Window to HWND) |

See Also

Window Class
Window Members
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (HWND to Window)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window ImplicitWideningImplicitImplicitImplicit Conversion (HWND to Window)
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.Window.op_Implicit(ArtOfTest.Common.Win32.HWND)~ArtOfTest.Common.Win32.Window"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator Window (
    HWND hWnd
)
Visual Basic
Public Shared Widening Operator CType ( _
    hWnd As HWND _
) As Window
Visual C++
static implicit operator Window^ (
    HWND hWnd
)

Parameters

hWnd
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hWnd"/> documentation for "M:ArtOfTest.Common.Win32.Window.op_Implicit(ArtOfTest.Common.Win32.HWND)~ArtOfTest.Common.Win32.Window"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.Window.op_Implicit(ArtOfTest.Common.Win32.HWND)~ArtOfTest.Common.Win32.Window"]

See Also

Window Class
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Implicit Conversion (Window to HWND)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window ImplicitWideningImplicitImplicitImplicit Conversion (Window to HWND)
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.Common.Win32.Window.op_Implicit(ArtOfTest.Common.Win32.Window)~ArtOfTest.Common.Win32.HWND"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator HWND (
    Window window
)
Visual Basic
Public Shared Widening Operator CType ( _
    window As Window _
) As HWND
Visual C++
static implicit operator HWND (
    Window^ window
)

Parameters

window
Type: ArtOfTest.Common.Win32..::..Window

[Missing <param name="window"/> documentation for "M:ArtOfTest.Common.Win32.Window.op_Implicit(ArtOfTest.Common.Win32.Window)~ArtOfTest.Common.Win32.HWND"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.Window.op_Implicit(ArtOfTest.Common.Win32.Window)~ArtOfTest.Common.Win32.HWND"]

See Also

Window Class
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.Common.Win32 Namespace


Window Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Properties
Window Class See Also Send Feedback

The Window type exposes the following members.

Properties

 | Name | Description
Public property | AllChildren | Gets a collection of all child windows (at any level) of this window.
Public property | Caption | Gets the window's caption.
Public property | ClassName | Gets the window's class name.
Public property | Enabled | Gets whether this window is enabled or not.
Public property | Exists | Gets whether the window handle represents a live native window.
Public property | Handle | Gets the handle of the window.
Public property | IsDialog | Gets whether this Window is a dialog
Public property | IsForegroundWindow | Gets whether the window is currently in use by the user.
Public property | IsMaximized | Gets whether the window is maximized.
Public property | IsMinimized | Gets whether the window is minimized.
Public property | IsVisible | Gets whether the window is visible.
Public property | Location | Gets the top left point of the location of the window relative to the screen.
Public property | OwnerProcess | The owner process that created this window.
Public property | ParentWindow | Get parent window of this window. Returns null if there is no parent window.
Public property | Rectangle | Gets the rectangle of the window.
Public property | Size | Gets the size of the window.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


AllChildren Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..AllChildren Property
Window Class See Also Send Feedback
Gets a collection of all child windows (at any level) of this window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WindowCollection AllChildren { get; }
Visual Basic
Public ReadOnly Property AllChildren As WindowCollection
    Get
Visual C++
public:
property WindowCollection^ AllChildren {
    WindowCollection^ get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Caption Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Caption Property
Window Class See Also Send Feedback
Gets the window's caption.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Caption { get; }
Visual Basic
Public ReadOnly Property Caption As String
    Get
Visual C++
public:
property String^ Caption {
    String^ get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


ClassName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ClassName Property
Window Class See Also Send Feedback
Gets the window's class name.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ClassName { get; }
Visual Basic
Public ReadOnly Property ClassName As String
    Get
Visual C++
public:
property String^ ClassName {
    String^ get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Enabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Enabled Property
Window Class See Also Send Feedback
Gets whether this window is enabled or not.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Enabled { get; }
Visual Basic
Public ReadOnly Property Enabled As Boolean
    Get
Visual C++
public:
property bool Enabled {
    bool get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Exists Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Exists Property
Window Class See Also Send Feedback
Gets whether the window handle represents a live native window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Exists { get; }
Visual Basic
Public ReadOnly Property Exists As Boolean
    Get
Visual C++
public:
property bool Exists {
    bool get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Handle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Handle Property
Window Class See Also Send Feedback
Gets the handle of the window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IntPtr Handle { get; }
Visual Basic
Public ReadOnly Property Handle As IntPtr
    Get
Visual C++
public:
property IntPtr Handle {
    IntPtr get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


IsDialog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsDialog Property
Window Class See Also Send Feedback
Gets whether this Window is a dialog

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDialog { get; }
Visual Basic
Public ReadOnly Property IsDialog As Boolean
    Get
Visual C++
public:
property bool IsDialog {
    bool get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


IsForegroundWindow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsForegroundWindow Property
Window Class See Also Send Feedback
Gets whether the window is currently in use by the user.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsForegroundWindow { get; }
Visual Basic
Public ReadOnly Property IsForegroundWindow As Boolean
    Get
Visual C++
public:
property bool IsForegroundWindow {
    bool get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


IsMaximized Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsMaximized Property
Window Class See Also Send Feedback
Gets whether the window is maximized.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMaximized { get; }
Visual Basic
Public ReadOnly Property IsMaximized As Boolean
    Get
Visual C++
public:
property bool IsMaximized {
    bool get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


IsMinimized Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsMinimized Property
Window Class See Also Send Feedback
Gets whether the window is minimized.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMinimized { get; }
Visual Basic
Public ReadOnly Property IsMinimized As Boolean
    Get
Visual C++
public:
property bool IsMinimized {
    bool get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


IsVisible Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsVisible Property
Window Class See Also Send Feedback
Gets whether the window is visible.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsVisible { get; }
Visual Basic
Public ReadOnly Property IsVisible As Boolean
    Get
Visual C++
public:
property bool IsVisible {
    bool get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Location Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Location Property
Window Class See Also Send Feedback
Gets the top left point of the location of the window relative to the screen.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Location { get; }
Visual Basic
Public ReadOnly Property Location As Point
    Get
Visual C++
public:
property Point Location {
    Point get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


OwnerProcess Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..OwnerProcess Property
Window Class See Also Send Feedback
The owner process that created this window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Process OwnerProcess { get; }
Visual Basic
Public ReadOnly Property OwnerProcess As Process
    Get
Visual C++
public:
property Process^ OwnerProcess {
    Process^ get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


ParentWindow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ParentWindow Property
Window Class See Also Send Feedback
Get parent window of this window. Returns null if there is no parent window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Window ParentWindow { get; }
Visual Basic
Public ReadOnly Property ParentWindow As Window
    Get
Visual C++
public:
property Window^ ParentWindow {
    Window^ get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Rectangle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Rectangle Property
Window Class See Also Send Feedback
Gets the rectangle of the window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle Rectangle { get; }
Visual Basic
Public ReadOnly Property Rectangle As Rectangle
    Get
Visual C++
public:
property Rectangle Rectangle {
    Rectangle get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Size Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Size Property
Window Class See Also Send Feedback
Gets the size of the window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Size Size { get; }
Visual Basic
Public ReadOnly Property Size As Size
    Get
Visual C++
public:
property Size Size {
    Size get ();
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Window Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Events
Window Class See Also Send Feedback

The Window type exposes the following members.

Events

 | Name | Description
Public event | Click | For internal use only.
Public event | DoubleClick | For internal use only.
Public event | KeyDown | For internal use only.
Public event | KeyPressed | For internal use only.
Public event | KeyUp | For internal use only.
Public event | MouseClick | For internal use only.
Public event | MouseDoubleClick | For internal use only.
Public event | MouseDown | For internal use only.
Public event | MouseMove | For internal use only.
Public event | MouseUp | For internal use only.
Public event | PreMouseClick | For internal use only.
Public event | PreMouseDown | For internal use only.
Public event | PreMouseUp | For internal use only.
Public event | WindowMoved | For internal use only.

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


Click Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Click Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler Click
Visual Basic
Public Event Click As EventHandler
Visual C++
public:
 event EventHandler^ Click {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


DoubleClick Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..DoubleClick Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler DoubleClick
Visual Basic
Public Event DoubleClick As EventHandler
Visual C++
public:
 event EventHandler^ DoubleClick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


KeyDown Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..KeyDown Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event KeyEventHandler KeyDown
Visual Basic
Public Event KeyDown As KeyEventHandler
Visual C++
public:
 event KeyEventHandler^ KeyDown {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


KeyPressed Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..KeyPressed Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event KeyPressEventHandler KeyPressed
Visual Basic
Public Event KeyPressed As KeyPressEventHandler
Visual C++
public:
 event KeyPressEventHandler^ KeyPressed {
    void add (KeyPressEventHandler^ value);
    void remove (KeyPressEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


KeyUp Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..KeyUp Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event KeyEventHandler KeyUp
Visual Basic
Public Event KeyUp As KeyEventHandler
Visual C++
public:
 event KeyEventHandler^ KeyUp {
    void add (KeyEventHandler^ value);
    void remove (KeyEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


MouseClick Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..MouseClick Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event MouseEventHandler MouseClick
Visual Basic
Public Event MouseClick As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


MouseDoubleClick Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..MouseDoubleClick Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event MouseEventHandler MouseDoubleClick
Visual Basic
Public Event MouseDoubleClick As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseDoubleClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


MouseDown Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..MouseDown Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event MouseEventHandler MouseDown
Visual Basic
Public Event MouseDown As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


MouseMove Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..MouseMove Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event MouseEventHandler MouseMove
Visual Basic
Public Event MouseMove As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseMove {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


MouseUp Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..MouseUp Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event MouseEventHandler MouseUp
Visual Basic
Public Event MouseUp As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


PreMouseClick Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..PreMouseClick Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event MouseEventHandler PreMouseClick
Visual Basic
Public Event PreMouseClick As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ PreMouseClick {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


PreMouseDown Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..PreMouseDown Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event MouseEventHandler PreMouseDown
Visual Basic
Public Event PreMouseDown As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ PreMouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


PreMouseUp Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..PreMouseUp Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event MouseEventHandler PreMouseUp
Visual Basic
Public Event PreMouseUp As MouseEventHandler
Visual C++
public:
 event MouseEventHandler^ PreMouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


WindowMoved Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..WindowMoved Event
Window Class See Also Send Feedback
For internal use only.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler WindowMoved
Visual Basic
Public Event WindowMoved As EventHandler
Visual C++
public:
 event EventHandler^ WindowMoved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Window Class
ArtOfTest.Common.Win32 Namespace


WindowCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowCollection Members
WindowCollection Class Methods Properties See Also Send Feedback

The WindowCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clear the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | Gets the Window at the specified index.

See Also

WindowCollection Class
ArtOfTest.Common.Win32 Namespace


WindowCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowCollection Methods
WindowCollection Class See Also Send Feedback

The WindowCollection type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Clear the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WindowCollection Class
ArtOfTest.Common.Win32 Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowCollection..::..Clear Method
WindowCollection Class See Also Send Feedback
Clear the collection.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

WindowCollection Class
ArtOfTest.Common.Win32 Namespace


WindowCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowCollection Properties
WindowCollection Class See Also Send Feedback

The WindowCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Protected property | InnerList | Gets the list of elements contained in the ReadOnlyCollectionBase instance. (Inherited from ReadOnlyCollectionBase.)
Public property | Item | Gets the Window at the specified index.

See Also

WindowCollection Class
ArtOfTest.Common.Win32 Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowCollection..::..Item Property
WindowCollection Class See Also Send Feedback
Gets the Window at the specified index.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Window this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Window
    Get
Visual C++
public:
property Window^ default[int index] {
    Window^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

WindowCollection Class
ArtOfTest.Common.Win32 Namespace


WindowEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowEventArgs Members
WindowEventArgs Class Constructors Methods Properties See Also Send Feedback

The WindowEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | WindowEventArgs | Constructor

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Tag |
Public property | Window | Get the Window

See Also

WindowEventArgs Class
ArtOfTest.Common.Win32 Namespace


WindowEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowEventArgs Constructor
WindowEventArgs Class See Also Send Feedback
Constructor

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WindowEventArgs(
    Window window,
    string tag
)
Visual Basic
Public Sub New ( _
    window As Window, _
    tag As String _
)
Visual C++
public:
WindowEventArgs(
    Window^ window,
    String^ tag
)

Parameters

window
Type: ArtOfTest.Common.Win32..::..Window
Window
tag
Type: System..::..String

[Missing <param name="tag"/> documentation for "M:ArtOfTest.Common.Win32.WindowEventArgs.#ctor(ArtOfTest.Common.Win32.Window,System.String)"]

See Also

WindowEventArgs Class
ArtOfTest.Common.Win32 Namespace


WindowEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowEventArgs Methods
WindowEventArgs Class See Also Send Feedback

The WindowEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WindowEventArgs Class
ArtOfTest.Common.Win32 Namespace


WindowEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowEventArgs Properties
WindowEventArgs Class See Also Send Feedback

The WindowEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Tag |
Public property | Window | Get the Window

See Also

WindowEventArgs Class
ArtOfTest.Common.Win32 Namespace


Tag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowEventArgs..::..Tag Property
WindowEventArgs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.WindowEventArgs.Tag"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Tag { get; set; }
Visual Basic
Public Property Tag As String
    Get
    Set
Visual C++
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}

See Also

WindowEventArgs Class
ArtOfTest.Common.Win32 Namespace


Window Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowEventArgs..::..Window Property
WindowEventArgs Class See Also Send Feedback
Get the Window

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Window Window { get; set; }
Visual Basic
Public Property Window As Window
    Get
    Set
Visual C++
public:
property Window^ Window {
    Window^ get ();
    void set (Window^ value);
}

See Also

WindowEventArgs Class
ArtOfTest.Common.Win32 Namespace


WindowManager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager Members
WindowManager Class Constructors Methods Properties See Also Send Feedback

The WindowManager type exposes the following members.

Constructors

 | Name | Description
Public method | WindowManager | Create a new window manager

Methods

 | Name | Description
Public method | AppendWindows | Append all child windows of the passed in parentHwnd to the current collection. (Items)
 | CenterSize | Calculate the correct point (x,y) for a specific size to be centered within a specific rectangle.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindWindowRecursively(IntPtr, String, Int32) | Find a window recusively under the parent window. Will return the first window that matches the class name.
 | FindWindowRecursively(IntPtr, String, Boolean, Int32) | Find a window recursively using its caption.
 | FindWindowRecursively(IntPtr, String, Boolean, Int32, Int32) | Find a window recursively using its caption.
 | FindWindowsRecursively | Finds all windows of a given class under the parent window.
 | GetActiveScreen | Returns the active screen the user is using.
Public method | GetAllWindows | Populate the Items collection with all windows associated with this process including child windows of each.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindows()()()() | Populate the Items collection with all top level windows.
Public method | GetWindows(Process) | Populate the Items collection with all non-child windows associated with this process.
Public method | GetWindows(IntPtr) | Populate the Items collection with all child windows of the parent window passed in (Recursive)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RecommendSize | Recommend the actual size of the window to use.
 | TileWindows | Tiles two windows
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
 | IEInstances |
Public property | Items | Returns the collection of windows populated by a call to GetWindows()
Public property | VisibleWindowsOnly | Gets or sets whether to filter window to visible windows only. Default is false.

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


WindowManager Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager Constructor
WindowManager Class See Also Send Feedback
Create a new window manager

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WindowManager()
Visual Basic
Public Sub New
Visual C++
public:
WindowManager()

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


WindowManager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager Methods
WindowManager Class See Also Send Feedback

The WindowManager type exposes the following members.

Methods

 | Name | Description
Public method | AppendWindows | Append all child windows of the passed in parentHwnd to the current collection. (Items)
 | CenterSize | Calculate the correct point (x,y) for a specific size to be centered within a specific rectangle.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindWindowRecursively(IntPtr, String, Int32) | Find a window recusively under the parent window. Will return the first window that matches the class name.
 | FindWindowRecursively(IntPtr, String, Boolean, Int32) | Find a window recursively using its caption.
 | FindWindowRecursively(IntPtr, String, Boolean, Int32, Int32) | Find a window recursively using its caption.
 | FindWindowsRecursively | Finds all windows of a given class under the parent window.
 | GetActiveScreen | Returns the active screen the user is using.
Public method | GetAllWindows | Populate the Items collection with all windows associated with this process including child windows of each.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindows()()()() | Populate the Items collection with all top level windows.
Public method | GetWindows(Process) | Populate the Items collection with all non-child windows associated with this process.
Public method | GetWindows(IntPtr) | Populate the Items collection with all child windows of the parent window passed in (Recursive)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RecommendSize | Recommend the actual size of the window to use.
 | TileWindows | Tiles two windows
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


AppendWindows Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..AppendWindows Method
WindowManager Class See Also Send Feedback
Append all child windows of the passed in parentHwnd to the current collection. (Items)

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendWindows(
    IntPtr parentHwnd
)
Visual Basic
Public Sub AppendWindows ( _
    parentHwnd As IntPtr _
)
Visual C++
public:
void AppendWindows(
    IntPtr parentHwnd
)

Parameters

parentHwnd
Type: System..::..IntPtr
The window to append children of.

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


CenterSize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..CenterSize Method
WindowManager Class See Also Send Feedback
Calculate the correct point (x,y) for a specific size to be centered within a specific rectangle.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Point CenterSize(
    Size sizeToCenter,
    Rectangle areaToCenterIn
)
Visual Basic
Public Shared Function CenterSize ( _
    sizeToCenter As Size, _
    areaToCenterIn As Rectangle _
) As Point
Visual C++
public:
static Point CenterSize(
    Size sizeToCenter,
    Rectangle areaToCenterIn
)

Parameters

sizeToCenter
Type: System.Drawing..::..Size
The size to center
areaToCenterIn
Type: System.Drawing..::..Rectangle
The target location to center

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.WindowManager.CenterSize(System.Drawing.Size,System.Drawing.Rectangle)"]

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


FindWindowRecursively Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..FindWindowRecursively Method
WindowManager Class See Also Send Feedback

Overload List

Name | Description
FindWindowRecursively(IntPtr, String, Int32) | Find a window recusively under the parent window. Will return the first window that matches the class name.
FindWindowRecursively(IntPtr, String, Boolean, Int32) | Find a window recursively using its caption.
FindWindowRecursively(IntPtr, String, Boolean, Int32, Int32) | Find a window recursively using its caption.

See Also

WindowManager Class
WindowManager Members
ArtOfTest.Common.Win32 Namespace


FindWindowRecursively Method (IntPtr, String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..FindWindowRecursively Method (IntPtr, String, Int32)
WindowManager Class See Also Send Feedback
Find a window recusively under the parent window. Will return the first window that matches the class name.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Window FindWindowRecursively(
    IntPtr parentHwnd,
    string className,
    int delaySearchPeriod
)
Visual Basic
Public Shared Function FindWindowRecursively ( _
    parentHwnd As IntPtr, _
    className As String, _
    delaySearchPeriod As Integer _
) As Window
Visual C++
public:
static Window^ FindWindowRecursively(
    IntPtr parentHwnd,
    String^ className,
    int delaySearchPeriod
)

Parameters

parentHwnd
Type: System..::..IntPtr
The parent window to search under. If Zero, will search all desktop windows.
className
Type: System..::..String
The class name to search for. (case-insensitive)
delaySearchPeriod
Type: System..::..Int32
The number of milli-seconds to delay the start of the search to allow the window we are searching for to be constructed. (if 0, no delay will occur)

Return Value

The window that matches, otherwise null.

See Also

WindowManager Class
FindWindowRecursively Overload
ArtOfTest.Common.Win32 Namespace


FindWindowRecursively Method (IntPtr, String, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..FindWindowRecursively Method (IntPtr, String, Boolean, Int32)
WindowManager Class See Also Send Feedback
Find a window recursively using its caption.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Window FindWindowRecursively(
    IntPtr parentHwnd,
    string caption,
    bool partialCaption,
    int delaySearchPeriod
)
Visual Basic
Public Shared Function FindWindowRecursively ( _
    parentHwnd As IntPtr, _
    caption As String, _
    partialCaption As Boolean, _
    delaySearchPeriod As Integer _
) As Window
Visual C++
public:
static Window^ FindWindowRecursively(
    IntPtr parentHwnd,
    String^ caption,
    bool partialCaption,
    int delaySearchPeriod
)

Parameters

parentHwnd
Type: System..::..IntPtr
The parent window to search under. If Zero, will search all deskop windows.
caption
Type: System..::..String
The caption to find.
partialCaption
Type: System..::..Boolean
Use partial caption matching or exact. (In both cases the matching is case-insensitive).
delaySearchPeriod
Type: System..::..Int32
The number of milli-seconds to delay the start of the search to allow the window we are searching for to be constructed. (if 0, no delay will occur)

Return Value

The found window or null;

See Also

WindowManager Class
FindWindowRecursively Overload
ArtOfTest.Common.Win32 Namespace


FindWindowRecursively Method (IntPtr, String, Boolean, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..FindWindowRecursively Method (IntPtr, String, Boolean, Int32, Int32)
WindowManager Class See Also Send Feedback
Find a window recursively using its caption.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Window FindWindowRecursively(
    IntPtr parentHwnd,
    string caption,
    bool partialCaption,
    int delaySearchPeriod,
    int maxDepth
)
Visual Basic
Public Shared Function FindWindowRecursively ( _
    parentHwnd As IntPtr, _
    caption As String, _
    partialCaption As Boolean, _
    delaySearchPeriod As Integer, _
    maxDepth As Integer _
) As Window
Visual C++
public:
static Window^ FindWindowRecursively(
    IntPtr parentHwnd,
    String^ caption,
    bool partialCaption,
    int delaySearchPeriod,
    int maxDepth
)

Parameters

parentHwnd
Type: System..::..IntPtr
The parent window to search under. If Zero, will search all deskop windows.
caption
Type: System..::..String
The caption to find.
partialCaption
Type: System..::..Boolean
Use partial caption matching or exact. (In both cases the matching is case-insensitive).
delaySearchPeriod
Type: System..::..Int32
The number of milli-seconds to delay the start of the search to allow the window we are searching for to be constructed. (if 0, no delay will occur)
maxDepth
Type: System..::..Int32
The maximum depth level at which we will try to get the proper window.

Return Value

The found window or null;

See Also

WindowManager Class
FindWindowRecursively Overload
ArtOfTest.Common.Win32 Namespace


FindWindowsRecursively Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..FindWindowsRecursively Method
WindowManager Class See Also Send Feedback
Finds all windows of a given class under the parent window.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static IList<Window> FindWindowsRecursively(
    IntPtr parentHwnd,
    List<string> classNames,
    int delaySearchPeriod
)
Visual Basic
Public Shared Function FindWindowsRecursively ( _
    parentHwnd As IntPtr, _
    classNames As List(Of String), _
    delaySearchPeriod As Integer _
) As IList(Of Window)
Visual C++
public:
static IList<Window^>^ FindWindowsRecursively(
    IntPtr parentHwnd,
    List<String^>^ classNames,
    int delaySearchPeriod
)

Parameters

parentHwnd
Type: System..::..IntPtr
The parent window to search under. If Zero, will search all desktop windows.
classNames
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>
A list of class names to search for (case-insensitive)
delaySearchPeriod
Type: System..::..Int32
The number of milliseconds to delay the start of the search to allow the window we are searching for to be constructed.

Return Value

A list of all windows of the specified class under the parent window

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


GetActiveScreen Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..GetActiveScreen Method
WindowManager Class See Also Send Feedback
Returns the active screen the user is using.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Screen GetActiveScreen()
Visual Basic
Public Shared Function GetActiveScreen As Screen
Visual C++
public:
static Screen^ GetActiveScreen()

Return Value

The active screen the user is using

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


GetAllWindows Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..GetAllWindows Method
WindowManager Class See Also Send Feedback
Populate the Items collection with all windows associated with this process including child windows of each.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void GetAllWindows(
    Process process
)
Visual Basic
Public Sub GetAllWindows ( _
    process As Process _
)
Visual C++
public:
void GetAllWindows(
    Process^ process
)

Parameters

process
Type: System.Diagnostics..::..Process
The process

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


GetWindows Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..GetWindows Method
WindowManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWindows()()()() | Populate the Items collection with all top level windows.
Public method | GetWindows(Process) | Populate the Items collection with all non-child windows associated with this process.
Public method | GetWindows(IntPtr) | Populate the Items collection with all child windows of the parent window passed in (Recursive)

See Also

WindowManager Class
WindowManager Members
ArtOfTest.Common.Win32 Namespace


GetWindows Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..GetWindows Method
WindowManager Class See Also Send Feedback
Populate the Items collection with all top level windows.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void GetWindows()
Visual Basic
Public Sub GetWindows
Visual C++
public:
void GetWindows()

See Also

WindowManager Class
GetWindows Overload
ArtOfTest.Common.Win32 Namespace


GetWindows Method (Process)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..GetWindows Method (Process)
WindowManager Class See Also Send Feedback
Populate the Items collection with all non-child windows associated with this process.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void GetWindows(
    Process process
)
Visual Basic
Public Sub GetWindows ( _
    process As Process _
)
Visual C++
public:
void GetWindows(
    Process^ process
)

Parameters

process
Type: System.Diagnostics..::..Process
The process

See Also

WindowManager Class
GetWindows Overload
ArtOfTest.Common.Win32 Namespace


GetWindows Method (IntPtr)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..GetWindows Method (IntPtr)
WindowManager Class See Also Send Feedback
Populate the Items collection with all child windows of the parent window passed in (Recursive)

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void GetWindows(
    IntPtr parentHwnd
)
Visual Basic
Public Sub GetWindows ( _
    parentHwnd As IntPtr _
)
Visual C++
public:
void GetWindows(
    IntPtr parentHwnd
)

Parameters

parentHwnd
Type: System..::..IntPtr
The parent window.

See Also

WindowManager Class
GetWindows Overload
ArtOfTest.Common.Win32 Namespace


RecommendSize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..RecommendSize Method
WindowManager Class See Also Send Feedback
Recommend the actual size of the window to use.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Rectangle RecommendSize(
    Rectangle desiredSize,
    Size minSize
)
Visual Basic
Public Shared Function RecommendSize ( _
    desiredSize As Rectangle, _
    minSize As Size _
) As Rectangle
Visual C++
public:
static Rectangle RecommendSize(
    Rectangle desiredSize,
    Size minSize
)

Parameters

desiredSize
Type: System.Drawing..::..Rectangle

[Missing <param name="desiredSize"/> documentation for "M:ArtOfTest.Common.Win32.WindowManager.RecommendSize(System.Drawing.Rectangle,System.Drawing.Size)"]

minSize
Type: System.Drawing..::..Size

[Missing <param name="minSize"/> documentation for "M:ArtOfTest.Common.Win32.WindowManager.RecommendSize(System.Drawing.Rectangle,System.Drawing.Size)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.Common.Win32.WindowManager.RecommendSize(System.Drawing.Rectangle,System.Drawing.Size)"]

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


TileWindows Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..TileWindows Method
WindowManager Class See Also Send Feedback
Tiles two windows

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void TileWindows(
    Window window1,
    Window window2,
    TileWindowsOption option,
    Size window1MinSize
)
Visual Basic
Public Shared Sub TileWindows ( _
    window1 As Window, _
    window2 As Window, _
    option As TileWindowsOption, _
    window1MinSize As Size _
)
Visual C++
public:
static void TileWindows(
    Window^ window1,
    Window^ window2,
    TileWindowsOption option,
    Size window1MinSize
)

Parameters

window1
Type: ArtOfTest.Common.Win32..::..Window
The first window
window2
Type: ArtOfTest.Common.Win32..::..Window
The second window
option
Type: ArtOfTest.Common.Win32..::..TileWindowsOption
Tiling option
window1MinSize
Type: System.Drawing..::..Size

[Missing <param name="window1MinSize"/> documentation for "M:ArtOfTest.Common.Win32.WindowManager.TileWindows(ArtOfTest.Common.Win32.Window,ArtOfTest.Common.Win32.Window,ArtOfTest.Common.Win32.TileWindowsOption,System.Drawing.Size)"]

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


WindowManager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager Properties
WindowManager Class See Also Send Feedback

The WindowManager type exposes the following members.

Properties

 | Name | Description
 | IEInstances |
Public property | Items | Returns the collection of windows populated by a call to GetWindows()
Public property | VisibleWindowsOnly | Gets or sets whether to filter window to visible windows only. Default is false.

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


IEInstances Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..IEInstances Property
WindowManager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.Common.Win32.WindowManager.IEInstances"]

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static List<Window> IEInstances { get; }
Visual Basic
Public Shared ReadOnly Property IEInstances As List(Of Window)
    Get
Visual C++
public:
static property List<Window^>^ IEInstances {
    List<Window^>^ get ();
}

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..Items Property
WindowManager Class See Also Send Feedback
Returns the collection of windows populated by a call to GetWindows()

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WindowCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As WindowCollection
    Get
Visual C++
public:
property WindowCollection^ Items {
    WindowCollection^ get ();
}

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


VisibleWindowsOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowManager..::..VisibleWindowsOnly Property
WindowManager Class See Also Send Feedback
Gets or sets whether to filter window to visible windows only. Default is false.

Namespace: ArtOfTest.Common.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool VisibleWindowsOnly { get; set; }
Visual Basic
Public Property VisibleWindowsOnly As Boolean
    Get
    Set
Visual C++
public:
property bool VisibleWindowsOnly {
    bool get ();
    void set (bool value);
}

See Also

WindowManager Class
ArtOfTest.Common.Win32 Namespace


ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace
Send Feedback
Namespace for IE specific functions.

Classes

 | Class | Description
Public class | InternetExplorerActions | Internet Explorer action support class.
Public class | NativeConsts | WinInet constans.


InternetExplorerActions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions Members
InternetExplorerActions Class Methods Fields Properties See Also Send Feedback

The InternetExplorerActions type exposes the following members.

Methods

 | Name | Description
Public method | AnnotateElement | Visually annotates an element on the browser surface. (Inherited from Actions.)
Public method | AnnotateMessage | Visually annotate a message on the browser surface. (Inherited from Actions.)
Public method | Check | Sets the a checkbox or a radio button to a specific checked state. (Inherited from Actions.)
Public method | Click | Perform a click on the target element. (Inherited from Actions.)
Public method | ConnectIEDialog | Connect an IE modal or modeless dialog to the Manager.
Protected method | DeleteInternetTempFiles | Delete IE's Temp. Internet Files caches http://support.microsoft.com/kb/326201
Protected method | DoSelectDropDown | Performs the select drop down action. (Inherited from Actions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComputedStyle | Get computed style for an element. (Overrides Actions..::..GetComputedStyle(Element, String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIEContentWindowServer | Get IE's content window. (Internet Explorer_Server)
 | GetNativeInstance | Get a reference to the IE IWebBrowser2 object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvokeEvent | Invoke an event on the target element. (Inherited from Actions.)
Public method | InvokeScript(String) | Runs Javascript code in the browser. Internet Explorer requires the string containing the code to run to be escaped, and Firefox requires that the string not be escaped. (Overrides Actions..::..InvokeScript(String).)
Public method | InvokeScript<(Of <<'(T>)>>)(String) | Invoke a JavaScript method in the browser. (Overrides Actions..::..InvokeScript(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop. (Inherited from Actions.)
Public method | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view. (Inherited from Actions.)
Public method | ScrollToVisible(Element, ScrollToVisibleType, Rectangle) | Ensures that a specified portion of an element is visible in the browser. Scrolls the whole element into view if possible, otherwise as much of the specified portion as possible. (Inherited from Actions.)
Public method | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index. (Inherited from Actions.)
Public method | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text. (Inherited from Actions.)
Public method | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true). (Inherited from Actions.)
Public method | SetText(Control, String) | Set the text of an input or content editable control. (Inherited from Actions.)
Public method | SetText(Element, String) | Set the text of a textbox or textarea. (Inherited from Actions.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateTargetElement | Validates the target element. (Inherited from Actions.)
Public method | WaitForElement(FindParam, Int32) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], Int32) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(FindParam, Int32, Boolean) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], Int32, Boolean) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM. (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM. (Inherited from Actions.)
Public method | WaitForElements(Int32, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Public method | WaitForElements(Int32, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Public method | WaitForElements(Int32, TestRegion, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)

Fields

Name | Description
ArtOfTestPlugin |

Properties

 | Name | Description
Protected property | Browser | Gets the Browser object associated with this instance of the actions object. (Inherited from Actions.)
Public property | WaitCheckInterval | The Settings.WaitCheckInterval value. You can get/set it here too. (Inherited from Actions.)

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


InternetExplorerActions Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions Fields
InternetExplorerActions Class See Also Send Feedback

The InternetExplorerActions type exposes the following members.

Fields

Name | Description
ArtOfTestPlugin |

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


ArtOfTestPlugin Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..ArtOfTestPlugin Field
InternetExplorerActions Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer.InternetExplorerActions.ArtOfTestPlugin"]

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string ArtOfTestPlugin
Visual Basic
Public Shared ReadOnly ArtOfTestPlugin As String
Visual C++
public:
static initonly String^ ArtOfTestPlugin

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


InternetExplorerActions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions Methods
InternetExplorerActions Class See Also Send Feedback

The InternetExplorerActions type exposes the following members.

Methods

 | Name | Description
Public method | AnnotateElement | Visually annotates an element on the browser surface. (Inherited from Actions.)
Public method | AnnotateMessage | Visually annotate a message on the browser surface. (Inherited from Actions.)
Public method | Check | Sets the a checkbox or a radio button to a specific checked state. (Inherited from Actions.)
Public method | Click | Perform a click on the target element. (Inherited from Actions.)
Public method | ConnectIEDialog | Connect an IE modal or modeless dialog to the Manager.
Protected method | DeleteInternetTempFiles | Delete IE's Temp. Internet Files caches http://support.microsoft.com/kb/326201
Protected method | DoSelectDropDown | Performs the select drop down action. (Inherited from Actions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComputedStyle | Get computed style for an element. (Overrides Actions..::..GetComputedStyle(Element, String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIEContentWindowServer | Get IE's content window. (Internet Explorer_Server)
 | GetNativeInstance | Get a reference to the IE IWebBrowser2 object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvokeEvent | Invoke an event on the target element. (Inherited from Actions.)
Public method | InvokeScript(String) | Runs Javascript code in the browser. Internet Explorer requires the string containing the code to run to be escaped, and Firefox requires that the string not be escaped. (Overrides Actions..::..InvokeScript(String).)
Public method | InvokeScript<(Of <<'(T>)>>)(String) | Invoke a JavaScript method in the browser. (Overrides Actions..::..InvokeScript(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop. (Inherited from Actions.)
Public method | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view. (Inherited from Actions.)
Public method | ScrollToVisible(Element, ScrollToVisibleType, Rectangle) | Ensures that a specified portion of an element is visible in the browser. Scrolls the whole element into view if possible, otherwise as much of the specified portion as possible. (Inherited from Actions.)
Public method | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index. (Inherited from Actions.)
Public method | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text. (Inherited from Actions.)
Public method | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true). (Inherited from Actions.)
Public method | SetText(Control, String) | Set the text of an input or content editable control. (Inherited from Actions.)
Public method | SetText(Element, String) | Set the text of a textbox or textarea. (Inherited from Actions.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateTargetElement | Validates the target element. (Inherited from Actions.)
Public method | WaitForElement(FindParam, Int32) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], Int32) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(FindParam, Int32, Boolean) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], Int32, Boolean) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM. (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM. (Inherited from Actions.)
Public method | WaitForElements(Int32, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Public method | WaitForElements(Int32, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Public method | WaitForElements(Int32, TestRegion, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


ConnectIEDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..ConnectIEDialog Method
InternetExplorerActions Class See Also Send Feedback
Connect an IE modal or modeless dialog to the Manager.

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ConnectIEDialog(
    string caption,
    int delaySearchPeriod
)
Visual Basic
Public Sub ConnectIEDialog ( _
    caption As String, _
    delaySearchPeriod As Integer _
)
Visual C++
public:
void ConnectIEDialog(
    String^ caption,
    int delaySearchPeriod
)

Parameters

caption
Type: System..::..String
The full or partial caption of the dialog to connect.
delaySearchPeriod
Type: System..::..Int32
Optionally, you can delay the search (in milli-seconds) for the dialog to make sure windows has actually created the window before looking for it. Else 0.

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


DeleteInternetTempFiles Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..DeleteInternetTempFiles Method
InternetExplorerActions Class See Also Send Feedback
Delete IE's Temp. Internet Files caches http://support.microsoft.com/kb/326201

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void DeleteInternetTempFiles(
    bool deleteCookies,
    string givenDomain,
    bool specific
)
Visual Basic
Protected Sub DeleteInternetTempFiles ( _
    deleteCookies As Boolean, _
    givenDomain As String, _
    specific As Boolean _
)
Visual C++
protected:
void DeleteInternetTempFiles(
    bool deleteCookies,
    String^ givenDomain,
    bool specific
)

Parameters

deleteCookies
Type: System..::..Boolean

[Missing <param name="deleteCookies"/> documentation for "M:ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer.InternetExplorerActions.DeleteInternetTempFiles(System.Boolean,System.String,System.Boolean)"]

givenDomain
Type: System..::..String

[Missing <param name="givenDomain"/> documentation for "M:ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer.InternetExplorerActions.DeleteInternetTempFiles(System.Boolean,System.String,System.Boolean)"]

specific
Type: System..::..Boolean

[Missing <param name="specific"/> documentation for "M:ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer.InternetExplorerActions.DeleteInternetTempFiles(System.Boolean,System.String,System.Boolean)"]

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


GetComputedStyle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..GetComputedStyle Method
InternetExplorerActions Class See Also Send Feedback
Get computed style for an element.

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetComputedStyle(
    Element targetElement,
    string style
)
Visual Basic
Public Overrides Function GetComputedStyle ( _
    targetElement As Element, _
    style As String _
) As String
Visual C++
public:
virtual String^ GetComputedStyle(
    Element^ targetElement,
    String^ style
) override

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
style
Type: System..::..String
The style to get.

Return Value

The styles value or string.empty if the style is not present.

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


GetIEContentWindowServer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..GetIEContentWindowServer Method
InternetExplorerActions Class See Also Send Feedback
Get IE's content window. (Internet Explorer_Server)

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Window GetIEContentWindowServer(
    Window parent,
    int initialDelay
)
Visual Basic
Public Shared Function GetIEContentWindowServer ( _
    parent As Window, _
    initialDelay As Integer _
) As Window
Visual C++
public:
static Window^ GetIEContentWindowServer(
    Window^ parent,
    int initialDelay
)

Parameters

parent
Type: ArtOfTest.Common.Win32..::..Window

[Missing <param name="parent"/> documentation for "M:ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer.InternetExplorerActions.GetIEContentWindowServer(ArtOfTest.Common.Win32.Window,System.Int32)"]

initialDelay
Type: System..::..Int32

[Missing <param name="initialDelay"/> documentation for "M:ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer.InternetExplorerActions.GetIEContentWindowServer(ArtOfTest.Common.Win32.Window,System.Int32)"]

Return Value

Window object representing IE's content window. null if not found.

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


GetNativeInstance Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..GetNativeInstance Method
InternetExplorerActions Class See Also Send Feedback
Get a reference to the IE IWebBrowser2 object.

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Object GetNativeInstance(
    IntPtr hwnd
)
Visual Basic
Public Shared Function GetNativeInstance ( _
    hwnd As IntPtr _
) As Object
Visual C++
public:
static Object^ GetNativeInstance(
    IntPtr hwnd
)

Parameters

hwnd
Type: System..::..IntPtr

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer.InternetExplorerActions.GetNativeInstance(System.IntPtr)"]

Return Value

The hwnd handle of the browser to find.

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


InvokeScript Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..InvokeScript Method
InternetExplorerActions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeScript<(Of <<'(T>)>>)(String) | Invoke a JavaScript method in the browser. (Overrides Actions..::..InvokeScript(String).)
Public method | InvokeScript(String) | Runs Javascript code in the browser. Internet Explorer requires the string containing the code to run to be escaped, and Firefox requires that the string not be escaped. (Overrides Actions..::..InvokeScript(String).)

See Also

InternetExplorerActions Class
InternetExplorerActions Members
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


InvokeScript(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..InvokeScript<(Of <(<'T>)>)> Method (String)
InternetExplorerActions Class See Also Send Feedback
Invoke a JavaScript method in the browser.

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override T InvokeScript<T>(
    string script
)
Visual Basic
Public Overrides Function InvokeScript(Of T) ( _
    script As String _
) As T
Visual C++
public:
generic<typename T>
virtual T InvokeScript(
    String^ script
) override

Parameters

script
Type: System..::..String
The name of the method to call.

Type Parameters

T
The type of object to return.

Return Value

The response returned by the JavaScript method.

See Also

InternetExplorerActions Class
InvokeScript Overload
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


InvokeScript Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..InvokeScript Method (String)
InternetExplorerActions Class See Also Send Feedback
Runs Javascript code in the browser. Internet Explorer requires the string containing the code to run to be escaped, and Firefox requires that the string not be escaped.

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string InvokeScript(
    string script
)
Visual Basic
Public Overrides Function InvokeScript ( _
    script As String _
) As String
Visual C++
public:
virtual String^ InvokeScript(
    String^ script
) override

Parameters

script
Type: System..::..String
A string containing the Javascript code to execute

Return Value

A string representation of the value returned by the evaluated Javascript code

See Also

InternetExplorerActions Class
InvokeScript Overload
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..ScrollToVisible Method
InternetExplorerActions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop. (Inherited from Actions.)
Public method | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view. (Inherited from Actions.)
Public method | ScrollToVisible(Element, ScrollToVisibleType, Rectangle) | Ensures that a specified portion of an element is visible in the browser. Scrolls the whole element into view if possible, otherwise as much of the specified portion as possible. (Inherited from Actions.)

See Also

InternetExplorerActions Class
InternetExplorerActions Members
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


SelectDropDown Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..SelectDropDown Method
InternetExplorerActions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index. (Inherited from Actions.)
Public method | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text. (Inherited from Actions.)
Public method | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true). (Inherited from Actions.)

See Also

InternetExplorerActions Class
InternetExplorerActions Members
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


SetText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..SetText Method
InternetExplorerActions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetText(Control, String) | Set the text of an input or content editable control. (Inherited from Actions.)
Public method | SetText(Element, String) | Set the text of a textbox or textarea. (Inherited from Actions.)

See Also

InternetExplorerActions Class
InternetExplorerActions Members
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


WaitForElement Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..WaitForElement Method
InternetExplorerActions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForElement(FindParam, Int32) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], Int32) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(FindParam, Int32, Boolean) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], Int32, Boolean) | Obsolete. Wait until an element is present in the DOM (Inherited from Actions.)
Public method | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM. (Inherited from Actions.)
Public method | WaitForElement(array<FindParam>[]()[][], TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM. (Inherited from Actions.)

See Also

InternetExplorerActions Class
InternetExplorerActions Members
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


WaitForElements Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions..::..WaitForElements Method
InternetExplorerActions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForElements(Int32, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Public method | WaitForElements(Int32, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)
Public method | WaitForElements(Int32, TestRegion, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used. (Inherited from Actions.)

See Also

InternetExplorerActions Class
InternetExplorerActions Members
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


InternetExplorerActions Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InternetExplorerActions Properties
InternetExplorerActions Class See Also Send Feedback

The InternetExplorerActions type exposes the following members.

Properties

 | Name | Description
Protected property | Browser | Gets the Browser object associated with this instance of the actions object. (Inherited from Actions.)
Public property | WaitCheckInterval | The Settings.WaitCheckInterval value. You can get/set it here too. (Inherited from Actions.)

See Also

InternetExplorerActions Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


NativeConsts Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NativeConsts Members
NativeConsts Class Fields See Also Send Feedback

The NativeConsts type exposes the following members.

Fields

Name | Description
INTERNET_COOKIE_HTTPONLY | InternetGetCookieEx method flag.

See Also

NativeConsts Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


NativeConsts Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NativeConsts Fields
NativeConsts Class See Also Send Feedback

The NativeConsts type exposes the following members.

Fields

Name | Description
INTERNET_COOKIE_HTTPONLY | InternetGetCookieEx method flag.

See Also

NativeConsts Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


INTERNET_COOKIE_HTTPONLY Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NativeConsts..::..INTERNET_COOKIE_HTTPONLY Field
NativeConsts Class See Also Send Feedback
InternetGetCookieEx method flag.

Namespace: ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int INTERNET_COOKIE_HTTPONLY
Visual Basic
Public Shared INTERNET_COOKIE_HTTPONLY As Integer
Visual C++
public:
static int INTERNET_COOKIE_HTTPONLY

See Also

NativeConsts Class
ArtOfTest.WebAii.BrowserSpecialized.InternetExplorer Namespace


ArtOfTest.WebAii.Controls Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Controls Namespace
Send Feedback
Namespace for the base class for all the HTML and XAML controls defined throughout the framework.

Classes

 | Class | Description
Public class | BaseControlAssert<(Of <(<'T>)>)> | Represents the base of all control assert objects.
Public class | Control | The base object for all controls.


BaseControlAssert(T) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)> Members
BaseControlAssert<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The BaseControlAssert<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | BaseControlAssert<(Of <(<'T>)>)>()()()() | Create a new base assert.
Public method | BaseControlAssert<(Of <(<'T>)>)>(T) | Create a new base assert and pass it the target control

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false.
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true.
Protected method | AssertNumber | Common assert for a number
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings.
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberCompare | Do numerical comparison
 | NumberCompareRange | Do numberical range comparison.
 | StringCompare | Perform a string comparison
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
NotFound | Not found constant string.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


BaseControlAssert(T) Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)> Constructor
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BaseControlAssert<(Of <(<'T>)>)>()()()() | Create a new base assert.
Public method | BaseControlAssert<(Of <(<'T>)>)>(T) | Create a new base assert and pass it the target control

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
BaseControlAssert<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Controls Namespace


BaseControlAssert(T) Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)> Constructor
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new base assert.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BaseControlAssert()
Visual Basic
Public Sub New
Visual C++
public:
BaseControlAssert()

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
BaseControlAssert<(Of <(<'T>)>)> Overload
ArtOfTest.WebAii.Controls Namespace


BaseControlAssert(T) Constructor (T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)> Constructor (T)
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new base assert and pass it the target control

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BaseControlAssert(
    T control
)
Visual Basic
Public Sub New ( _
    control As T _
)
Visual C++
public:
BaseControlAssert(
    T control
)

Parameters

control
Type: T
The target control

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
BaseControlAssert<(Of <(<'T>)>)> Overload
ArtOfTest.WebAii.Controls Namespace


BaseControlAssert(T) Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)> Fields
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseControlAssert<(Of <(<'T>)>)> type exposes the following members.

Fields

Name | Description
NotFound | Not found constant string.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


NotFound Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..NotFound Field
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Not found constant string.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected static readonly string NotFound
Visual Basic
Protected Shared ReadOnly NotFound As String
Visual C++
protected:
static initonly String^ NotFound

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


BaseControlAssert(T) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)> Methods
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseControlAssert<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false.
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true.
Protected method | AssertNumber | Common assert for a number
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings.
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberCompare | Do numerical comparison
 | NumberCompareRange | Do numberical range comparison.
 | StringCompare | Perform a string comparison
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..Assert Method
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false.
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
BaseControlAssert<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Controls Namespace


Assert Method (Boolean, String, String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..Assert Method (Boolean, String, String, String)
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Throw AssertException if condition is false.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool Assert(
    bool condition,
    string message,
    string expected,
    string actual
)
Visual Basic
Protected Function Assert ( _
    condition As Boolean, _
    message As String, _
    expected As String, _
    actual As String _
) As Boolean
Visual C++
protected:
bool Assert(
    bool condition,
    String^ message,
    String^ expected,
    String^ actual
)

Parameters

condition
Type: System..::..Boolean
The condition result from previous condition test.
message
Type: System..::..String
The message to put in the assert.
expected
Type: System..::..String
The Expected value to display in the assert.
actual
Type: System..::..String
The Actual value to display in the assert.

Return Value

True.

Exceptions

Exception | Condition
ArtOfTest.Common.Exceptions..::..AssertException | Thrown when the comparison fails.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
Assert Overload
ArtOfTest.WebAii.Controls Namespace


Assert Method (Boolean, String, String, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..Assert Method (Boolean, String, String, String, Boolean)
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Throw an AssertException if conditiion is false and throwAssert is true.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool Assert(
    bool condition,
    string message,
    string expected,
    string actual,
    bool throwAssert
)
Visual Basic
Protected Function Assert ( _
    condition As Boolean, _
    message As String, _
    expected As String, _
    actual As String, _
    throwAssert As Boolean _
) As Boolean
Visual C++
protected:
bool Assert(
    bool condition,
    String^ message,
    String^ expected,
    String^ actual,
    bool throwAssert
)

Parameters

condition
Type: System..::..Boolean
The condition result.
message
Type: System..::..String
The message.
expected
Type: System..::..String
Expected value.
actual
Type: System..::..String
Actual value.
throwAssert
Type: System..::..Boolean
Whether or not to throw the assert when condition is false.

Return Value

Returns true/false of the condition result.

Exceptions

Exception | Condition
ArtOfTest.Common.Exceptions..::..AssertException | Thrown when the comparison fails and throwAssert is true.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
Assert Overload
ArtOfTest.WebAii.Controls Namespace


AssertNumber Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..AssertNumber Method
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Common assert for a number

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool AssertNumber(
    int leftPortion,
    int rightPortion,
    NumberCompareType compareType,
    bool throwOnFailure
)
Visual Basic
Protected Function AssertNumber ( _
    leftPortion As Integer, _
    rightPortion As Integer, _
    compareType As NumberCompareType, _
    throwOnFailure As Boolean _
) As Boolean
Visual C++
protected:
bool AssertNumber(
    int leftPortion,
    int rightPortion,
    NumberCompareType compareType,
    bool throwOnFailure
)

Parameters

leftPortion
Type: System..::..Int32
The left side of the comparison.
rightPortion
Type: System..::..Int32
The right side of the comparison.
compareType
Type: ArtOfTest.Common..::..NumberCompareType
The comparison type (Equal, Less Than, etc.).
throwOnFailure
Type: System..::..Boolean

[Missing <param name="throwOnFailure"/> documentation for "M:ArtOfTest.WebAii.Controls.BaseControlAssert`1.AssertNumber(System.Int32,System.Int32,ArtOfTest.Common.NumberCompareType,System.Boolean)"]

Return Value

True.

Exceptions

Exception | Condition
ArtOfTest.Common.Exceptions..::..AssertException | Thrown when the comparison fails.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..AssertString Method
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings.
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
BaseControlAssert<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Controls Namespace


AssertString Method (String, String, StringCompareType, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..AssertString Method (String, String, StringCompareType, Boolean)
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Commnon assert for strings.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool AssertString(
    string expected,
    string actual,
    StringCompareType compareType,
    bool throwOnFailure
)
Visual Basic
Protected Function AssertString ( _
    expected As String, _
    actual As String, _
    compareType As StringCompareType, _
    throwOnFailure As Boolean _
) As Boolean
Visual C++
protected:
bool AssertString(
    String^ expected,
    String^ actual,
    StringCompareType compareType,
    bool throwOnFailure
)

Parameters

expected
Type: System..::..String
The expected value.
actual
Type: System..::..String
The actual value.
compareType
Type: ArtOfTest.Common..::..StringCompareType
The compare type (Contains, Exact, etc.).
throwOnFailure
Type: System..::..Boolean

[Missing <param name="throwOnFailure"/> documentation for "M:ArtOfTest.WebAii.Controls.BaseControlAssert`1.AssertString(System.String,System.String,ArtOfTest.Common.StringCompareType,System.Boolean)"]

Return Value

True.

Exceptions

Exception | Condition
ArtOfTest.Common.Exceptions..::..AssertException | Thrown when the comparison fails.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
AssertString Overload
ArtOfTest.WebAii.Controls Namespace


AssertString Method (String, String, StringCompareType, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..AssertString Method (String, String, StringCompareType, Boolean)
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Commnon assert for strings.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Please use CompareType from ArtOfTest.Common")]
protected bool AssertString(
    string expected,
    string actual,
    StringCompareType compareType,
    bool throwOnFailure
)
Visual Basic
<ObsoleteAttribute("Please use CompareType from ArtOfTest.Common")> _
Protected Function AssertString ( _
    expected As String, _
    actual As String, _
    compareType As StringCompareType, _
    throwOnFailure As Boolean _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Please use CompareType from ArtOfTest.Common")]
protected:
bool AssertString(
    String^ expected,
    String^ actual,
    StringCompareType compareType,
    bool throwOnFailure
)

Parameters

expected
Type: System..::..String
The expected value.
actual
Type: System..::..String
The actual value.
compareType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..StringCompareType
The compare type (Contains, Exact, etc.).
throwOnFailure
Type: System..::..Boolean

[Missing <param name="throwOnFailure"/> documentation for "M:ArtOfTest.WebAii.Controls.BaseControlAssert`1.AssertString(System.String,System.String,ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts.StringCompareType,System.Boolean)"]

Return Value

True.

Exceptions

Exception | Condition
ArtOfTest.Common.Exceptions..::..AssertException | Thrown when the comparison fails.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
AssertString Overload
ArtOfTest.WebAii.Controls Namespace


NumberCompare Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..NumberCompare Method
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Do numerical comparison

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool NumberCompare(
    int leftPortion,
    int rightPortion,
    NumberCompareType compareType
)
Visual Basic
Public Shared Function NumberCompare ( _
    leftPortion As Integer, _
    rightPortion As Integer, _
    compareType As NumberCompareType _
) As Boolean
Visual C++
public:
static bool NumberCompare(
    int leftPortion,
    int rightPortion,
    NumberCompareType compareType
)

Parameters

leftPortion
Type: System..::..Int32
Left side
rightPortion
Type: System..::..Int32
Right side
compareType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..NumberCompareType
The compare type.

Return Value

True/False whether the compare passed

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


NumberCompareRange Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..NumberCompareRange Method
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Do numberical range comparison.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool NumberCompareRange(
    int number,
    int lowerEnd,
    int upperEnd,
    NumberRangeCompareType compareType
)
Visual Basic
Public Shared Function NumberCompareRange ( _
    number As Integer, _
    lowerEnd As Integer, _
    upperEnd As Integer, _
    compareType As NumberRangeCompareType _
) As Boolean
Visual C++
public:
static bool NumberCompareRange(
    int number,
    int lowerEnd,
    int upperEnd,
    NumberRangeCompareType compareType
)

Parameters

number
Type: System..::..Int32
The number to compare.
lowerEnd
Type: System..::..Int32
The lower end of the range.
upperEnd
Type: System..::..Int32
The upper end of the range.
compareType
Type: ArtOfTest.Common..::..NumberRangeCompareType
The compare type.

Return Value

True/False whether the comparison passed.

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


StringCompare Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..StringCompare Method
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Perform a string comparison

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool StringCompare(
    string a,
    string b,
    StringCompareType compareType
)
Visual Basic
Public Shared Function StringCompare ( _
    a As String, _
    b As String, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
static bool StringCompare(
    String^ a,
    String^ b,
    StringCompareType compareType
)

Parameters

a
Type: System..::..String
The first string.
b
Type: System..::..String
The string to compare to.
compareType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..StringCompareType
The comparison type.

Return Value

True/False whether the comparison passed

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


BaseControlAssert(T) Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)> Properties
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback

The BaseControlAssert<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


Target Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseControlAssert<(Of <(<'T>)>)>..::..Target Property
BaseControlAssert<(Of <(<'T>)>)> Class See Also Send Feedback
Gets or sets the assert target

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T Target { get; set; }
Visual Basic
Public Property Target As T
    Get
    Set
Visual C++
public:
property T Target {
    T get ();
    void set (T value);
}

See Also

BaseControlAssert<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Controls Namespace


Control Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Members
Control Class Constructors Methods Properties See Also Send Feedback

The Control type exposes the following members.

Constructors

 | Name | Description
Public method | Control()()()() | Create new control.
Public method | Control(Element) | Create new control and assigns it a base element.

Methods

 | Name | Description
Public method | AssignElement | Assign this control a base element. Performs any initialization for this control.
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFamilyElement | Finds the nth parent/child of the specified element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MatchControl | Given a FindParam this method returns true/false whether this FindParam matches the passed in element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BaseElement | Gets the DOM element representing this test control
Public property | IsRefresh | Gets whether the control is executing a Refresh call.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null.
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null.
Public property | OwnerBrowser | Gets the owner browser that owns this control.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


Control Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Constructor
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Control()()()() | Create new control.
Public method | Control(Element) | Create new control and assigns it a base element.

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls Namespace


Control Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Constructor
Control Class See Also Send Feedback
Create new control.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Control()
Visual Basic
Public Sub New
Visual C++
public:
Control()

See Also

Control Class
Control Overload
ArtOfTest.WebAii.Controls Namespace


Control Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Constructor (Element)
Control Class See Also Send Feedback
Create new control and assigns it a base element.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Control(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
Control(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The DOM element representing this control.

See Also

Control Class
Control Overload
ArtOfTest.WebAii.Controls Namespace


Control Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Methods
Control Class See Also Send Feedback

The Control type exposes the following members.

Methods

 | Name | Description
Public method | AssignElement | Assign this control a base element. Performs any initialization for this control.
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFamilyElement | Finds the nth parent/child of the specified element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MatchControl | Given a FindParam this method returns true/false whether this FindParam matches the passed in element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..AssignElement Method
Control Class See Also Send Feedback
Assign this control a base element. Performs any initialization for this control.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void AssignElement(
    Element e
)
Visual Basic
Public Overridable Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to assign.

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


AssignFailed Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..AssignFailed Method
Control Class See Also Send Feedback
Mark the assignment to failed. Throw if the framework is set for throwing.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void AssignFailed(
    Exception exceptionToThrow
)
Visual Basic
Protected Sub AssignFailed ( _
    exceptionToThrow As Exception _
)
Visual C++
protected:
void AssignFailed(
    Exception^ exceptionToThrow
)

Parameters

exceptionToThrow
Type: System..::..Exception
The exception to throw.

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


GetFamilyElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..GetFamilyElement Method
Control Class See Also Send Feedback
Finds the nth parent/child of the specified element.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Element GetFamilyElement(
    int level,
    Element e
)
Visual Basic
Public Shared Function GetFamilyElement ( _
    level As Integer, _
    e As Element _
) As Element
Visual C++
public:
static Element^ GetFamilyElement(
    int level,
    Element^ e
)

Parameters

level
Type: System..::..Int32
Number of levels to move up/down. Negative values move up. Positive values move down.
e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to start at.

Return Value

A parent/child element or null if an attempt is made to go beyond the ends of the DOM tree.

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


MatchControl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..MatchControl Method
Control Class See Also Send Feedback
Given a FindParam this method returns true/false whether this FindParam matches the passed in element.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool MatchControl(
    Element element,
    FindParam paramToMatch
)
Visual Basic
Public Shared Function MatchControl ( _
    element As Element, _
    paramToMatch As FindParam _
) As Boolean
Visual C++
public:
static bool MatchControl(
    Element^ element,
    FindParam^ paramToMatch
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to match.
paramToMatch
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam.

Return Value

True/False whether the FindParam matches.

Remarks

For a FindParam to match an element, the following condition must be met: 1. The FindParam.TagName is set, needs to match the element's tagName. 2. If FindParam.Type=Content, then the content as described by FindParam needs to match. 3. The FindParam.Attributes and FindParam.PartialAttributes need to match if any are set. 4. If FindParam.Type=TagIndex/XPath or NodeIndexPath will throw an exception since they do not apply in this scenario since they apply only when matching an element within a full DOM hierarchy not an atomic element matching.

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


Refresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Refresh Method
Control Class See Also Send Feedback
Refresh this control within the current DOM and update this control property values.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Refresh()
Visual Basic
Public Overridable Sub Refresh
Visual C++
public:
virtual void Refresh()

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


Control Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Properties
Control Class See Also Send Feedback

The Control type exposes the following members.

Properties

 | Name | Description
Public property | BaseElement | Gets the DOM element representing this test control
Public property | IsRefresh | Gets whether the control is executing a Refresh call.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null.
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null.
Public property | OwnerBrowser | Gets the owner browser that owns this control.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


BaseElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BaseElement Property
Control Class See Also Send Feedback
Gets the DOM element representing this test control

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element BaseElement { get; }
Visual Basic
Public ReadOnly Property BaseElement As Element
    Get
Visual C++
public:
property Element^ BaseElement {
    Element^ get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


IsRefresh Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsRefresh Property
Control Class See Also Send Feedback
Gets whether the control is executing a Refresh call.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsRefresh { get; }
Visual Basic
Public ReadOnly Property IsRefresh As Boolean
    Get
Visual C++
public:
property bool IsRefresh {
    bool get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


Locator Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Locator Property
Control Class See Also Send Feedback
Gets the FindParam that describes this control. The base Control returns null.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FindParam Locator { get; }
Visual Basic
Public Overridable ReadOnly Property Locator As FindParam
    Get
Visual C++
public:
virtual property FindParam^ Locator {
    FindParam^ get ();
}

Remarks

This property is provided for convenience and can be overriden by custom controls as a place to put and store the FindParam that describes them.

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


LocatorExpression Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..LocatorExpression Property
Control Class See Also Send Feedback
Returns the FindExpression for this control. Since this is a abstract base class it always returns null.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IFindExpression LocatorExpression { get; }
Visual Basic
Public Overridable ReadOnly Property LocatorExpression As IFindExpression
    Get
Visual C++
public:
virtual property IFindExpression^ LocatorExpression {
    IFindExpression^ get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


OwnerBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..OwnerBrowser Property
Control Class See Also Send Feedback
Gets the owner browser that owns this control.

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser OwnerBrowser { get; }
Visual Basic
Public ReadOnly Property OwnerBrowser As Browser
    Get
Visual C++
public:
property Browser^ OwnerBrowser {
    Browser^ get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


ThrowOnInvalidAssignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..ThrowOnInvalidAssignment Property
Control Class See Also Send Feedback
Gets whether the control should throw on invalid assignments

Namespace: ArtOfTest.WebAii.Controls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool ThrowOnInvalidAssignment { get; }
Visual Basic
Protected ReadOnly Property ThrowOnInvalidAssignment As Boolean
    Get
Visual C++
protected:
property bool ThrowOnInvalidAssignment {
    bool get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls Namespace


ArtOfTest.WebAii.Controls.HtmlControls Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Controls.HtmlControls Namespace
Send Feedback
Namespace for all the HTML element wrapper controls.

Classes

 | Class | Description
Public class | HtmlAnchor | Test class for an HtmlAnchor element <a href="...">...</a>
Public class | HtmlAudio | Wrapper class for a audio element <audio>...</audio>
Public class | HtmlButton | Test class for an HtmlButton element <button >...</button>
Public class | HtmlCanvas | Test class for an HtmlCanvas element <canvas>...</canvas>
Public class | HtmlContainerControl | Base class for all container controls. Controls that are allowed to contain other Html elements.
Public class | HtmlControl | Base class for all HtmlControl's.
Public class | HtmlControlsAssertExtensions | Assert extensions for the HtmlControl class.
Public class | HtmlDefinitionDescription | Test class for an HtmlDefinitionDescription element <dd /> . This control is used by the HtmlDefinitionList control
Public class | HtmlDefinitionList | Test class for an HtmlDefinitionList element <dl /> .
Public class | HtmlDefinitionTerm | Test class for an HtmlDefinitionTerm element <dt /> . This control is used by the HtmlDefinitionList control
Public class | HtmlDetails | Test class for an HtmlDetails element <details>...</details>
Public class | HtmlDiv | Test class for an HtmlDiv element <div>...</div>
Public class | HtmlFind | Extends the generic Find methods to include HTML specific find objects.
Public class | HtmlForm | Test class for an HtmlForm element <form >...</form>
Public class | HtmlImage | Test class for an HtmlImage element <img src="..." />
Public class | HtmlInputButton | Test class for an HtmlInputButton element <input type="button" />
Public class | HtmlInputCheckBox | Test class for an HtmlInputCheckBox element <input type="checkbox" />
Public class | HtmlInputCheckBoxExtensions | Assert extensions for the HtmlInputCheckBox class.
Public class | HtmlInputControl | Base class for all input controls
Public class | HtmlInputEmail |
Public class | HtmlInputFile | Test class for an HtmlInputFile element <input type="file" />
Public class | HtmlInputHidden | Test class for an HtmlInputHidden element <input type="hidden" />
Public class | HtmlInputImage | Test class for an HtmlInputImage element <input type="image" />
Public class | HtmlInputNumber |
Public class | HtmlInputPassword | Test class for an HtmlInputPassword element <input type="password" />
Public class | HtmlInputRadioButton | Test class for an HtmlInputImage element <input type="radio" />
Public class | HtmlInputRadioButtonExtensions | Assert extensions for the HtmlInputRadioButton class.
Public class | HtmlInputRange |
Public class | HtmlInputReset | Test class for an HtmlInputImage element <input type="reset" />
Public class | HtmlInputSearch |
Public class | HtmlInputSubmit | Test class for an HtmlInputImage element <input type="reset" />
Public class | HtmlInputText | Test class for an HtmlInputImage element <input type="text" />
Public class | HtmlInputUrl |
Public class | HtmlListItem | Test class for an HtmlListItem element <li /> . This control is used by the HtmlOrdererList control and the HtmlUnorderedList controls.
Public class | HtmlMeter | Test class for an HtmlMeter element <meter>...</meter>
Public class | HtmlOption | Test class for an HtmlOption element <option ... />
Public class | HtmlOrderedList | Test class for an HtmlOrderedList element <ol /> .
Public class | HtmlProgress | Test class for an HtmlProgress element <progress>...</progress>
Public class | HtmlSelect | Test class for an HtmlSelect element <select>...</select>
Public class | HtmlSelectAssertExtensions | Assert extensions for the HtmlSelect class.
Public class | HtmlSource | Wrapper class for a source element <source ... />
Public class | HtmlSpan | Test class for an HtmlSpan element <span>...</span>
Public class | HtmlStyle | Represents a single HtmlStyle. This object can be used to help probe and do validation against Html styles. Has functionality to convert unit styles to int values and color styles to System.Drawing.Color.
Public class | HtmlTable | Test class for an HtmlTable element <table>...</table>
Public class | HtmlTableAssertExtensions | Assert extensions for the HtmlTable class.
Public class | HtmlTableCell | Test class for an HtmlTableCell element <td>...</td>
Public class | HtmlTableRow | Test class for an HtmlTableRow element <tr>...</tr>
Public class | HtmlTextArea | Test class for an HtmlAnchor element <textarea>...</textarea>
Public class | HtmlTime | Test class for an HtmlTime element <time>...</time>
Public class | HtmlUnorderedList | Test class for an HtmlOrderedList element <ul /> .
Public class | HtmlVideo | Wrapper class for a video element <video>...</video>
Public class | HtmlWait | Extends the Wait object for specific HtmlWait scenarios.
Public class | HtmlWaitExtensions | Class to extend the legacy HtmlWait. Adds ForSelectedIndex and ForSelectedValue methods.

Enumerations

 | Enumeration | Description
Public enumeration | DownloadOption | Download options for a download from an html page.
Public enumeration | HtmlMediaError |


HtmlAnchor Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor Members
HtmlAnchor Class Constructors Methods Properties See Also Send Feedback

The HtmlAnchor type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlAnchor()()()() | Create a new control.
Public method | HtmlAnchor(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign this control a base element. Performs any initialization for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAnchor Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor Constructor
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlAnchor()()()() | Create a new control.
Public method | HtmlAnchor(Element) | Create a new control.

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAnchor Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor Constructor
HtmlAnchor Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlAnchor()
Visual Basic
Public Sub New
Visual C++
public:
HtmlAnchor()

See Also

HtmlAnchor Class
HtmlAnchor Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAnchor Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor Constructor (Element)
HtmlAnchor Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlAnchor(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlAnchor(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlAnchor Class
HtmlAnchor Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAnchor Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor Methods
HtmlAnchor Class See Also Send Feedback

The HtmlAnchor type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign this control a base element. Performs any initialization for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlAnchor Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..AssignElement Method
HtmlAnchor Class See Also Send Feedback
Assign this control a base element. Performs any initialization for this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to assign.

See Also

HtmlAnchor Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..CallMethod Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..Capture Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..Click Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..DragTo Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..GetValue Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..InvokeEvent Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..MouseClick Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..MouseHover Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..ScrollToVisible Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..SetValue Method
HtmlAnchor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
HtmlAnchor Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAnchor Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor Properties
HtmlAnchor Class See Also Send Feedback

The HtmlAnchor type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlAnchor Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HRef Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..HRef Property
HtmlAnchor Class See Also Send Feedback
Gets the URL of the linked resource.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string HRef { get; }
Visual Basic
Public ReadOnly Property HRef As String
    Get
Visual C++
public:
property String^ HRef {
    String^ get ();
}

See Also

HtmlAnchor Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..Name Property
HtmlAnchor Class See Also Send Feedback
Gets the name of a link.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

HtmlAnchor Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Target Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..Target Property
HtmlAnchor Class See Also Send Feedback
Gets where to open a link.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Target { get; }
Visual Basic
Public ReadOnly Property Target As String
    Get
Visual C++
public:
property String^ Target {
    String^ get ();
}

See Also

HtmlAnchor Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Title Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAnchor..::..Title Property
HtmlAnchor Class See Also Send Feedback
The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

HtmlAnchor Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAudio Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio Members
HtmlAudio Class Constructors Methods Properties See Also Send Feedback

The HtmlAudio type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlAudio()()()() | Create a new control.
Public method | HtmlAudio(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | Load | Cause the audio player to reload its source audio
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Pause |
Public method | Play |
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autoplay | The autoplay attribute determines whether a video begins playing as soon as the page loads
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Controls | The controls attribute determines whether the standard playback controls are shown to the user
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentTime | Gets the current playback time
Public property | Duration | Gets the duration of the audio source, in seconds
Public property | Ended | Gets whether the audio source has played through to its end
Public property | Error |
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InError |
Public property | InitialTime | Gets the initial playback position of the audio player, in seconds
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Loop | Whether the video will start playing from its beginning again once it reaches its end
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Paused |
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Sources |
Public property | Src | URL for the video file to play, if no source elements are specified for the video
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAudio Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio Constructor
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlAudio()()()() | Create a new control.
Public method | HtmlAudio(Element) | Create a new control.

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAudio Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio Constructor
HtmlAudio Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlAudio()
Visual Basic
Public Sub New
Visual C++
public:
HtmlAudio()

See Also

HtmlAudio Class
HtmlAudio Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAudio Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio Constructor (Element)
HtmlAudio Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlAudio(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlAudio(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlAudio Class
HtmlAudio Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAudio Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio Methods
HtmlAudio Class See Also Send Feedback

The HtmlAudio type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | Load | Cause the audio player to reload its source audio
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Pause |
Public method | Play |
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..AssignElement Method
HtmlAudio Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..CallMethod Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Capture Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Click Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..DragTo Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..GetValue Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..InvokeEvent Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Load Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Load Method
HtmlAudio Class See Also Send Feedback
Cause the audio player to reload its source audio

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Load()
Visual Basic
Public Sub Load
Visual C++
public:
void Load()

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..MouseClick Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..MouseHover Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Pause Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Pause Method
HtmlAudio Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAudio.Pause"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Pause()
Visual Basic
Public Sub Pause
Visual C++
public:
void Pause()

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Play Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Play Method
HtmlAudio Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAudio.Play"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Play()
Visual Basic
Public Sub Play
Visual C++
public:
void Play()

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..ScrollToVisible Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..SetValue Method
HtmlAudio Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlAudio Class
HtmlAudio Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlAudio Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio Properties
HtmlAudio Class See Also Send Feedback

The HtmlAudio type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autoplay | The autoplay attribute determines whether a video begins playing as soon as the page loads
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Controls | The controls attribute determines whether the standard playback controls are shown to the user
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentTime | Gets the current playback time
Public property | Duration | Gets the duration of the audio source, in seconds
Public property | Ended | Gets whether the audio source has played through to its end
Public property | Error |
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InError |
Public property | InitialTime | Gets the initial playback position of the audio player, in seconds
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Loop | Whether the video will start playing from its beginning again once it reaches its end
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Paused |
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Sources |
Public property | Src | URL for the video file to play, if no source elements are specified for the video
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Autoplay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Autoplay Property
HtmlAudio Class See Also Send Feedback
The autoplay attribute determines whether a video begins playing as soon as the page loads

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Autoplay { get; set; }
Visual Basic
Public Property Autoplay As Boolean
    Get
    Set
Visual C++
public:
property bool Autoplay {
    bool get ();
    void set (bool value);
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Controls Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Controls Property
HtmlAudio Class See Also Send Feedback
The controls attribute determines whether the standard playback controls are shown to the user

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Controls { get; set; }
Visual Basic
Public Property Controls As Boolean
    Get
    Set
Visual C++
public:
property bool Controls {
    bool get ();
    void set (bool value);
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CurrentTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..CurrentTime Property
HtmlAudio Class See Also Send Feedback
Gets the current playback time

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CurrentTime { get; }
Visual Basic
Public ReadOnly Property CurrentTime As Double
    Get
Visual C++
public:
property double CurrentTime {
    double get ();
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Duration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Duration Property
HtmlAudio Class See Also Send Feedback
Gets the duration of the audio source, in seconds

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Duration { get; }
Visual Basic
Public ReadOnly Property Duration As Double
    Get
Visual C++
public:
property double Duration {
    double get ();
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Ended Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Ended Property
HtmlAudio Class See Also Send Feedback
Gets whether the audio source has played through to its end

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Ended { get; }
Visual Basic
Public ReadOnly Property Ended As Boolean
    Get
Visual C++
public:
property bool Ended {
    bool get ();
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Error Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Error Property
HtmlAudio Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAudio.Error"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlMediaError Error { get; }
Visual Basic
Public ReadOnly Property Error As HtmlMediaError
    Get
Visual C++
public:
property HtmlMediaError Error {
    HtmlMediaError get ();
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InError Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..InError Property
HtmlAudio Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAudio.InError"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool InError { get; }
Visual Basic
Public ReadOnly Property InError As Boolean
    Get
Visual C++
public:
property bool InError {
    bool get ();
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InitialTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..InitialTime Property
HtmlAudio Class See Also Send Feedback
Gets the initial playback position of the audio player, in seconds

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double InitialTime { get; }
Visual Basic
Public ReadOnly Property InitialTime As Double
    Get
Visual C++
public:
property double InitialTime {
    double get ();
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Loop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Loop Property
HtmlAudio Class See Also Send Feedback
Whether the video will start playing from its beginning again once it reaches its end

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Loop { get; set; }
Visual Basic
Public Property Loop As Boolean
    Get
    Set
Visual C++
public:
property bool Loop {
    bool get ();
    void set (bool value);
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Paused Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Paused Property
HtmlAudio Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAudio.Paused"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Paused { get; }
Visual Basic
Public ReadOnly Property Paused As Boolean
    Get
Visual C++
public:
property bool Paused {
    bool get ();
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Sources Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Sources Property
HtmlAudio Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAudio.Sources"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlSource> Sources { get; }
Visual Basic
Public ReadOnly Property Sources As IList(Of HtmlSource)
    Get
Visual C++
public:
property IList<HtmlSource^>^ Sources {
    IList<HtmlSource^>^ get ();
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Src Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlAudio..::..Src Property
HtmlAudio Class See Also Send Feedback
URL for the video file to play, if no source elements are specified for the video

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Src { get; set; }
Visual Basic
Public Property Src As String
    Get
    Set
Visual C++
public:
property String^ Src {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlAudio Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton Members
HtmlButton Class Constructors Methods Properties See Also Send Feedback

The HtmlButton type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlButton()()()() | Create a new control.
Public method | HtmlButton(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether a button is disabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a button.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a button.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Gets the text that is displayed on a button.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton Constructor
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlButton()()()() | Create a new control.
Public method | HtmlButton(Element) | Create a new control.

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton Constructor
HtmlButton Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlButton()
Visual Basic
Public Sub New
Visual C++
public:
HtmlButton()

See Also

HtmlButton Class
HtmlButton Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton Constructor (Element)
HtmlButton Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlButton Class
HtmlButton Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton Methods
HtmlButton Class See Also Send Feedback

The HtmlButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..AssignElement Method
HtmlButton Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..CallMethod Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..Capture Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..Click Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..DragTo Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..GetValue Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..InvokeEvent Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..MouseClick Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..MouseHover Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..ScrollToVisible Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..SetValue Method
HtmlButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlButton Class
HtmlButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton Properties
HtmlButton Class See Also Send Feedback

The HtmlButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether a button is disabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a button.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a button.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Gets the text that is displayed on a button.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Disabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..Disabled Property
HtmlButton Class See Also Send Feedback
Gets whether a button is disabled.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Disabled { get; }
Visual Basic
Public ReadOnly Property Disabled As Boolean
    Get
Visual C++
public:
property bool Disabled {
    bool get ();
}

See Also

HtmlButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..Name Property
HtmlButton Class See Also Send Feedback
Gets the name of a button.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

HtmlButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


TabIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..TabIndex Property
HtmlButton Class See Also Send Feedback
Gets the tab order for a button.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TabIndex { get; }
Visual Basic
Public ReadOnly Property TabIndex As Integer
    Get
Visual C++
public:
property int TabIndex {
    int get ();
}

See Also

HtmlButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlButton..::..Value Property
HtmlButton Class See Also Send Feedback
Gets the text that is displayed on a button.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlCanvas Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas Members
HtmlCanvas Class Constructors Methods Properties See Also Send Feedback

The HtmlCanvas type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlCanvas()()()() | Create a new control.
Public method | HtmlCanvas(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Context2dArc |
Public method | Context2dArcTo |
Public method | Context2dBeginPath |
Public method | Context2dBezierCurveTo |
Public method | Context2dClearRect |
Public method | Context2dClip |
Public method | Context2dClosePath |
Public method | Context2dFill |
Public method | Context2dFillRect |
Public method | Context2dFillText(String, Double, Double) |
Public method | Context2dFillText(String, Double, Double, Double) |
Public method | Context2dIsPointInPath |
Public method | Context2dLineTo |
Public method | Context2dMoveTo |
Public method | Context2dQuadraticCurveTo |
Public method | Context2dRect |
Public method | Context2dRestore |
Public method | Context2dRotate |
Public method | Context2dSave |
Public method | Context2dScale |
Public method | Context2dScrollPathIntoView |
Public method | Context2dSetTransform |
Public method | Context2dStroke |
Public method | Context2dStrokeRect |
Public method | Context2dStrokeText(String, Double, Double) |
Public method | Context2dStrokeText(String, Double, Double, Double) |
Public method | Context2dTransform |
Public method | Context2dTranslate |
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Context2dFillStyle |
Public property | Context2dFont |
Public property | Context2dGlobalAlpha |
Public property | Context2dGlobalCompositOperation |
Public property | Context2dLineCap |
Public property | Context2dLineJoin |
Public property | Context2dLineWidth |
Public property | Context2dMiterLimit |
Public property | Context2dShadowBlur |
Public property | Context2dShadowColor |
Public property | Context2dShadowOffsetX |
Public property | Context2dShadowOffsetY |
Public property | Context2dStrokeStyle |
Public property | Context2dTextAlign |
Public property | Context2dTextBaseline |
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height |
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width |

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlCanvas Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas Constructor
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlCanvas()()()() | Create a new control.
Public method | HtmlCanvas(Element) | Create a new test control

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlCanvas Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas Constructor
HtmlCanvas Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlCanvas()
Visual Basic
Public Sub New
Visual C++
public:
HtmlCanvas()

See Also

HtmlCanvas Class
HtmlCanvas Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlCanvas Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas Constructor (Element)
HtmlCanvas Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlCanvas(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlCanvas(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlCanvas Class
HtmlCanvas Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlCanvas Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas Methods
HtmlCanvas Class See Also Send Feedback

The HtmlCanvas type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Context2dArc |
Public method | Context2dArcTo |
Public method | Context2dBeginPath |
Public method | Context2dBezierCurveTo |
Public method | Context2dClearRect |
Public method | Context2dClip |
Public method | Context2dClosePath |
Public method | Context2dFill |
Public method | Context2dFillRect |
Public method | Context2dFillText(String, Double, Double) |
Public method | Context2dFillText(String, Double, Double, Double) |
Public method | Context2dIsPointInPath |
Public method | Context2dLineTo |
Public method | Context2dMoveTo |
Public method | Context2dQuadraticCurveTo |
Public method | Context2dRect |
Public method | Context2dRestore |
Public method | Context2dRotate |
Public method | Context2dSave |
Public method | Context2dScale |
Public method | Context2dScrollPathIntoView |
Public method | Context2dSetTransform |
Public method | Context2dStroke |
Public method | Context2dStrokeRect |
Public method | Context2dStrokeText(String, Double, Double) |
Public method | Context2dStrokeText(String, Double, Double, Double) |
Public method | Context2dTransform |
Public method | Context2dTranslate |
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..AssignElement Method
HtmlCanvas Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..CallMethod Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Capture Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Click Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dArc Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dArc Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArc(System.Double,System.Double,System.Double,System.Double,System.Double,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dArc(
    double x,
    double y,
    double radius,
    double startAngle,
    double endAngle,
    bool anticlockwise
)
Visual Basic
Public Sub Context2dArc ( _
    x As Double, _
    y As Double, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    anticlockwise As Boolean _
)
Visual C++
public:
void Context2dArc(
    double x,
    double y,
    double radius,
    double startAngle,
    double endAngle,
    bool anticlockwise
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArc(System.Double,System.Double,System.Double,System.Double,System.Double,System.Boolean)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArc(System.Double,System.Double,System.Double,System.Double,System.Double,System.Boolean)"]

radius
Type: System..::..Double

[Missing <param name="radius"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArc(System.Double,System.Double,System.Double,System.Double,System.Double,System.Boolean)"]

startAngle
Type: System..::..Double

[Missing <param name="startAngle"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArc(System.Double,System.Double,System.Double,System.Double,System.Double,System.Boolean)"]

endAngle
Type: System..::..Double

[Missing <param name="endAngle"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArc(System.Double,System.Double,System.Double,System.Double,System.Double,System.Boolean)"]

anticlockwise
Type: System..::..Boolean

[Missing <param name="anticlockwise"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArc(System.Double,System.Double,System.Double,System.Double,System.Double,System.Boolean)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dArcTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dArcTo Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArcTo(System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dArcTo(
    double x1,
    double y1,
    double x2,
    double y2,
    double radius
)
Visual Basic
Public Sub Context2dArcTo ( _
    x1 As Double, _
    y1 As Double, _
    x2 As Double, _
    y2 As Double, _
    radius As Double _
)
Visual C++
public:
void Context2dArcTo(
    double x1,
    double y1,
    double x2,
    double y2,
    double radius
)

Parameters

x1
Type: System..::..Double

[Missing <param name="x1"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArcTo(System.Double,System.Double,System.Double,System.Double,System.Double)"]

y1
Type: System..::..Double

[Missing <param name="y1"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArcTo(System.Double,System.Double,System.Double,System.Double,System.Double)"]

x2
Type: System..::..Double

[Missing <param name="x2"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArcTo(System.Double,System.Double,System.Double,System.Double,System.Double)"]

y2
Type: System..::..Double

[Missing <param name="y2"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArcTo(System.Double,System.Double,System.Double,System.Double,System.Double)"]

radius
Type: System..::..Double

[Missing <param name="radius"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dArcTo(System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dBeginPath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dBeginPath Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dBeginPath"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dBeginPath()
Visual Basic
Public Sub Context2dBeginPath
Visual C++
public:
void Context2dBeginPath()

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dBezierCurveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dBezierCurveTo Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dBezierCurveTo(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dBezierCurveTo(
    double cp1x,
    double cp1y,
    double cp2x,
    double cp2y,
    double x,
    double y
)
Visual Basic
Public Sub Context2dBezierCurveTo ( _
    cp1x As Double, _
    cp1y As Double, _
    cp2x As Double, _
    cp2y As Double, _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Context2dBezierCurveTo(
    double cp1x,
    double cp1y,
    double cp2x,
    double cp2y,
    double x,
    double y
)

Parameters

cp1x
Type: System..::..Double

[Missing <param name="cp1x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dBezierCurveTo(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

cp1y
Type: System..::..Double

[Missing <param name="cp1y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dBezierCurveTo(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

cp2x
Type: System..::..Double

[Missing <param name="cp2x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dBezierCurveTo(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

cp2y
Type: System..::..Double

[Missing <param name="cp2y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dBezierCurveTo(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dBezierCurveTo(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dBezierCurveTo(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dClearRect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dClearRect Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dClearRect(System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dClearRect(
    double x,
    double y,
    double w,
    double h
)
Visual Basic
Public Sub Context2dClearRect ( _
    x As Double, _
    y As Double, _
    w As Double, _
    h As Double _
)
Visual C++
public:
void Context2dClearRect(
    double x,
    double y,
    double w,
    double h
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dClearRect(System.Double,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dClearRect(System.Double,System.Double,System.Double,System.Double)"]

w
Type: System..::..Double

[Missing <param name="w"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dClearRect(System.Double,System.Double,System.Double,System.Double)"]

h
Type: System..::..Double

[Missing <param name="h"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dClearRect(System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dClip Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dClip Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dClip"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dClip()
Visual Basic
Public Sub Context2dClip
Visual C++
public:
void Context2dClip()

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dClosePath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dClosePath Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dClosePath"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dClosePath()
Visual Basic
Public Sub Context2dClosePath
Visual C++
public:
void Context2dClosePath()

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dFill Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dFill Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFill"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dFill()
Visual Basic
Public Sub Context2dFill
Visual C++
public:
void Context2dFill()

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dFillRect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dFillRect Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillRect(System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dFillRect(
    double x,
    double y,
    double w,
    double h
)
Visual Basic
Public Sub Context2dFillRect ( _
    x As Double, _
    y As Double, _
    w As Double, _
    h As Double _
)
Visual C++
public:
void Context2dFillRect(
    double x,
    double y,
    double w,
    double h
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillRect(System.Double,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillRect(System.Double,System.Double,System.Double,System.Double)"]

w
Type: System..::..Double

[Missing <param name="w"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillRect(System.Double,System.Double,System.Double,System.Double)"]

h
Type: System..::..Double

[Missing <param name="h"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillRect(System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dFillText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dFillText Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Context2dFillText(String, Double, Double) |
Public method | Context2dFillText(String, Double, Double, Double) |

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dFillText Method (String, Double, Double)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dFillText Method (String, Double, Double)
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dFillText(
    string text,
    double x,
    double y
)
Visual Basic
Public Sub Context2dFillText ( _
    text As String, _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Context2dFillText(
    String^ text,
    double x,
    double y
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double)"]

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double)"]

See Also

HtmlCanvas Class
Context2dFillText Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dFillText Method (String, Double, Double, Double)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dFillText Method (String, Double, Double, Double)
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dFillText(
    string text,
    double x,
    double y,
    double maxWidth
)
Visual Basic
Public Sub Context2dFillText ( _
    text As String, _
    x As Double, _
    y As Double, _
    maxWidth As Double _
)
Visual C++
public:
void Context2dFillText(
    String^ text,
    double x,
    double y,
    double maxWidth
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double,System.Double)"]

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double,System.Double)"]

maxWidth
Type: System..::..Double

[Missing <param name="maxWidth"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillText(System.String,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
Context2dFillText Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dIsPointInPath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dIsPointInPath Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dIsPointInPath(System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Context2dIsPointInPath(
    double x,
    double y
)
Visual Basic
Public Function Context2dIsPointInPath ( _
    x As Double, _
    y As Double _
) As Boolean
Visual C++
public:
bool Context2dIsPointInPath(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dIsPointInPath(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dIsPointInPath(System.Double,System.Double)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dIsPointInPath(System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dLineTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dLineTo Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dLineTo(System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dLineTo(
    double x,
    double y
)
Visual Basic
Public Sub Context2dLineTo ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Context2dLineTo(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dLineTo(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dLineTo(System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dMoveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dMoveTo Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dMoveTo(System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dMoveTo(
    double x,
    double y
)
Visual Basic
Public Sub Context2dMoveTo ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Context2dMoveTo(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dMoveTo(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dMoveTo(System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dQuadraticCurveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dQuadraticCurveTo Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dQuadraticCurveTo(System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dQuadraticCurveTo(
    double cpx,
    double cpy,
    double x,
    double y
)
Visual Basic
Public Sub Context2dQuadraticCurveTo ( _
    cpx As Double, _
    cpy As Double, _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Context2dQuadraticCurveTo(
    double cpx,
    double cpy,
    double x,
    double y
)

Parameters

cpx
Type: System..::..Double

[Missing <param name="cpx"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dQuadraticCurveTo(System.Double,System.Double,System.Double,System.Double)"]

cpy
Type: System..::..Double

[Missing <param name="cpy"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dQuadraticCurveTo(System.Double,System.Double,System.Double,System.Double)"]

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dQuadraticCurveTo(System.Double,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dQuadraticCurveTo(System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dRect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dRect Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dRect(System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dRect(
    double x,
    double y,
    double w,
    double h
)
Visual Basic
Public Sub Context2dRect ( _
    x As Double, _
    y As Double, _
    w As Double, _
    h As Double _
)
Visual C++
public:
void Context2dRect(
    double x,
    double y,
    double w,
    double h
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dRect(System.Double,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dRect(System.Double,System.Double,System.Double,System.Double)"]

w
Type: System..::..Double

[Missing <param name="w"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dRect(System.Double,System.Double,System.Double,System.Double)"]

h
Type: System..::..Double

[Missing <param name="h"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dRect(System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dRestore Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dRestore Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dRestore"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dRestore()
Visual Basic
Public Sub Context2dRestore
Visual C++
public:
void Context2dRestore()

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dRotate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dRotate Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dRotate(System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dRotate(
    double angle
)
Visual Basic
Public Sub Context2dRotate ( _
    angle As Double _
)
Visual C++
public:
void Context2dRotate(
    double angle
)

Parameters

angle
Type: System..::..Double

[Missing <param name="angle"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dRotate(System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dSave Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dSave Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dSave"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dSave()
Visual Basic
Public Sub Context2dSave
Visual C++
public:
void Context2dSave()

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dScale Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dScale Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dScale(System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dScale(
    double x,
    double y
)
Visual Basic
Public Sub Context2dScale ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Context2dScale(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dScale(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dScale(System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dScrollPathIntoView Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dScrollPathIntoView Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dScrollPathIntoView"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dScrollPathIntoView()
Visual Basic
Public Sub Context2dScrollPathIntoView
Visual C++
public:
void Context2dScrollPathIntoView()

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dSetTransform Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dSetTransform Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dSetTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dSetTransform(
    double a,
    double b,
    double c,
    double d,
    double e,
    double f
)
Visual Basic
Public Sub Context2dSetTransform ( _
    a As Double, _
    b As Double, _
    c As Double, _
    d As Double, _
    e As Double, _
    f As Double _
)
Visual C++
public:
void Context2dSetTransform(
    double a,
    double b,
    double c,
    double d,
    double e,
    double f
)

Parameters

a
Type: System..::..Double

[Missing <param name="a"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dSetTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

b
Type: System..::..Double

[Missing <param name="b"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dSetTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

c
Type: System..::..Double

[Missing <param name="c"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dSetTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dSetTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

e
Type: System..::..Double

[Missing <param name="e"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dSetTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

f
Type: System..::..Double

[Missing <param name="f"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dSetTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dStroke Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dStroke Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStroke"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dStroke()
Visual Basic
Public Sub Context2dStroke
Visual C++
public:
void Context2dStroke()

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dStrokeRect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dStrokeRect Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeRect(System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dStrokeRect(
    double x,
    double y,
    double w,
    double h
)
Visual Basic
Public Sub Context2dStrokeRect ( _
    x As Double, _
    y As Double, _
    w As Double, _
    h As Double _
)
Visual C++
public:
void Context2dStrokeRect(
    double x,
    double y,
    double w,
    double h
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeRect(System.Double,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeRect(System.Double,System.Double,System.Double,System.Double)"]

w
Type: System..::..Double

[Missing <param name="w"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeRect(System.Double,System.Double,System.Double,System.Double)"]

h
Type: System..::..Double

[Missing <param name="h"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeRect(System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dStrokeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dStrokeText Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Context2dStrokeText(String, Double, Double) |
Public method | Context2dStrokeText(String, Double, Double, Double) |

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dStrokeText Method (String, Double, Double)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dStrokeText Method (String, Double, Double)
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dStrokeText(
    string text,
    double x,
    double y
)
Visual Basic
Public Sub Context2dStrokeText ( _
    text As String, _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Context2dStrokeText(
    String^ text,
    double x,
    double y
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double)"]

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double)"]

See Also

HtmlCanvas Class
Context2dStrokeText Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dStrokeText Method (String, Double, Double, Double)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dStrokeText Method (String, Double, Double, Double)
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dStrokeText(
    string text,
    double x,
    double y,
    double maxWidth
)
Visual Basic
Public Sub Context2dStrokeText ( _
    text As String, _
    x As Double, _
    y As Double, _
    maxWidth As Double _
)
Visual C++
public:
void Context2dStrokeText(
    String^ text,
    double x,
    double y,
    double maxWidth
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double,System.Double)"]

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double,System.Double)"]

maxWidth
Type: System..::..Double

[Missing <param name="maxWidth"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeText(System.String,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
Context2dStrokeText Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dTransform Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dTransform Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dTransform(
    double a,
    double b,
    double c,
    double d,
    double e,
    double f
)
Visual Basic
Public Sub Context2dTransform ( _
    a As Double, _
    b As Double, _
    c As Double, _
    d As Double, _
    e As Double, _
    f As Double _
)
Visual C++
public:
void Context2dTransform(
    double a,
    double b,
    double c,
    double d,
    double e,
    double f
)

Parameters

a
Type: System..::..Double

[Missing <param name="a"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

b
Type: System..::..Double

[Missing <param name="b"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

c
Type: System..::..Double

[Missing <param name="c"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

d
Type: System..::..Double

[Missing <param name="d"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

e
Type: System..::..Double

[Missing <param name="e"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

f
Type: System..::..Double

[Missing <param name="f"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTransform(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dTranslate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dTranslate Method
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTranslate(System.Double,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Context2dTranslate(
    double x,
    double y
)
Visual Basic
Public Sub Context2dTranslate ( _
    x As Double, _
    y As Double _
)
Visual C++
public:
void Context2dTranslate(
    double x,
    double y
)

Parameters

x
Type: System..::..Double

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTranslate(System.Double,System.Double)"]

y
Type: System..::..Double

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTranslate(System.Double,System.Double)"]

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..DragTo Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..GetValue Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..InvokeEvent Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..MouseClick Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..MouseHover Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..ScrollToVisible Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..SetValue Method
HtmlCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlCanvas Class
HtmlCanvas Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlCanvas Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas Properties
HtmlCanvas Class See Also Send Feedback

The HtmlCanvas type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Context2dFillStyle |
Public property | Context2dFont |
Public property | Context2dGlobalAlpha |
Public property | Context2dGlobalCompositOperation |
Public property | Context2dLineCap |
Public property | Context2dLineJoin |
Public property | Context2dLineWidth |
Public property | Context2dMiterLimit |
Public property | Context2dShadowBlur |
Public property | Context2dShadowColor |
Public property | Context2dShadowOffsetX |
Public property | Context2dShadowOffsetY |
Public property | Context2dStrokeStyle |
Public property | Context2dTextAlign |
Public property | Context2dTextBaseline |
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height |
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width |

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dFillStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dFillStyle Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFillStyle"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dFillStyle { get; set; }
Visual Basic
Public Property Context2dFillStyle As String
    Get
    Set
Visual C++
public:
property String^ Context2dFillStyle {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dFont Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dFont Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dFont"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dFont { get; set; }
Visual Basic
Public Property Context2dFont As String
    Get
    Set
Visual C++
public:
property String^ Context2dFont {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dGlobalAlpha Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dGlobalAlpha Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dGlobalAlpha"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Context2dGlobalAlpha { get; set; }
Visual Basic
Public Property Context2dGlobalAlpha As Double
    Get
    Set
Visual C++
public:
property double Context2dGlobalAlpha {
    double get ();
    void set (double value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dGlobalCompositOperation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dGlobalCompositOperation Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dGlobalCompositOperation"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dGlobalCompositOperation { get; set; }
Visual Basic
Public Property Context2dGlobalCompositOperation As String
    Get
    Set
Visual C++
public:
property String^ Context2dGlobalCompositOperation {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dLineCap Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dLineCap Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dLineCap"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dLineCap { get; set; }
Visual Basic
Public Property Context2dLineCap As String
    Get
    Set
Visual C++
public:
property String^ Context2dLineCap {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dLineJoin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dLineJoin Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dLineJoin"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dLineJoin { get; set; }
Visual Basic
Public Property Context2dLineJoin As String
    Get
    Set
Visual C++
public:
property String^ Context2dLineJoin {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dLineWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dLineWidth Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dLineWidth"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Context2dLineWidth { get; set; }
Visual Basic
Public Property Context2dLineWidth As Double
    Get
    Set
Visual C++
public:
property double Context2dLineWidth {
    double get ();
    void set (double value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dMiterLimit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dMiterLimit Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dMiterLimit"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Context2dMiterLimit { get; set; }
Visual Basic
Public Property Context2dMiterLimit As Double
    Get
    Set
Visual C++
public:
property double Context2dMiterLimit {
    double get ();
    void set (double value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dShadowBlur Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dShadowBlur Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dShadowBlur"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Context2dShadowBlur { get; set; }
Visual Basic
Public Property Context2dShadowBlur As Double
    Get
    Set
Visual C++
public:
property double Context2dShadowBlur {
    double get ();
    void set (double value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dShadowColor Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dShadowColor Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dShadowColor"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dShadowColor { get; set; }
Visual Basic
Public Property Context2dShadowColor As String
    Get
    Set
Visual C++
public:
property String^ Context2dShadowColor {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dShadowOffsetX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dShadowOffsetX Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dShadowOffsetX"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Context2dShadowOffsetX { get; set; }
Visual Basic
Public Property Context2dShadowOffsetX As Double
    Get
    Set
Visual C++
public:
property double Context2dShadowOffsetX {
    double get ();
    void set (double value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dShadowOffsetY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dShadowOffsetY Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dShadowOffsetY"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Context2dShadowOffsetY { get; set; }
Visual Basic
Public Property Context2dShadowOffsetY As Double
    Get
    Set
Visual C++
public:
property double Context2dShadowOffsetY {
    double get ();
    void set (double value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dStrokeStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dStrokeStyle Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dStrokeStyle"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dStrokeStyle { get; set; }
Visual Basic
Public Property Context2dStrokeStyle As String
    Get
    Set
Visual C++
public:
property String^ Context2dStrokeStyle {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dTextAlign Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dTextAlign Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTextAlign"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dTextAlign { get; set; }
Visual Basic
Public Property Context2dTextAlign As String
    Get
    Set
Visual C++
public:
property String^ Context2dTextAlign {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Context2dTextBaseline Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Context2dTextBaseline Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Context2dTextBaseline"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Context2dTextBaseline { get; set; }
Visual Basic
Public Property Context2dTextBaseline As String
    Get
    Set
Visual C++
public:
property String^ Context2dTextBaseline {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Height Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Height"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCanvas..::..Width Property
HtmlCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlCanvas.Width"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

HtmlCanvas Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlContainerControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl Members
HtmlContainerControl Class Constructors Methods Properties See Also Send Feedback

The HtmlContainerControl type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlContainerControl()()()() | Create a new HtmlContainerControl
Public method | HtmlContainerControl(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlContainerControl Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl Constructor
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlContainerControl()()()() | Create a new HtmlContainerControl
Public method | HtmlContainerControl(Element) | Create a new control.

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlContainerControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl Constructor
HtmlContainerControl Class See Also Send Feedback
Create a new HtmlContainerControl

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlContainerControl()
Visual Basic
Public Sub New
Visual C++
public:
HtmlContainerControl()

See Also

HtmlContainerControl Class
HtmlContainerControl Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlContainerControl Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl Constructor (Element)
HtmlContainerControl Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlContainerControl(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlContainerControl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlContainerControl Class
HtmlContainerControl Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlContainerControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl Methods
HtmlContainerControl Class See Also Send Feedback

The HtmlContainerControl type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlContainerControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..AssignElement Method
HtmlContainerControl Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlContainerControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..CallMethod Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..Capture Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..Click Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..DragTo Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..GetValue Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..InvokeEvent Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..MouseClick Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..MouseHover Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..ScrollToVisible Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..SetValue Method
HtmlContainerControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
HtmlContainerControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlContainerControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl Properties
HtmlContainerControl Class See Also Send Feedback

The HtmlContainerControl type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlContainerControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InnerText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..InnerText Property
HtmlContainerControl Class See Also Send Feedback
Gets the innerText of this container control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string InnerText { get; }
Visual Basic
Public ReadOnly Property InnerText As String
    Get
Visual C++
public:
property String^ InnerText {
    String^ get ();
}

See Also

HtmlContainerControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


TextContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlContainerControl..::..TextContent Property
HtmlContainerControl Class See Also Send Feedback
Gets the TextContent of this container control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TextContent { get; }
Visual Basic
Public ReadOnly Property TextContent As String
    Get
Visual C++
public:
property String^ TextContent {
    String^ get ();
}

See Also

HtmlContainerControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl Members
HtmlControl Class Constructors Methods Properties See Also Send Feedback

The HtmlControl type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlControl()()()() | Create a new emptry HtmlControl.
Public method | HtmlControl(Element) | Wrap the specified Element into a new HtmlControl.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl.
Public method | AssignElement | Attach the specified Element to this HtmlControl and initialize its internal properties. (Overrides Control..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl.
Public method | CallMethod<(Of <<'(T>)>>)(String) | Call a client side Javascript method on this HtmlControl and return type T.
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl.
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file.
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file.
Public method | Click()()()() | Invoke a click on this HtmlControl.
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups).
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced.
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point.
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl.
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset.
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to.
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center.
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source.
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location.
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source.
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location.
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired.
Public method | Focus | Give this Html element focus.
Protected method | GetAttributeAsString | Get an attribute of this element as a string
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl.
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor).
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox.
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEventType, Boolean) |
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden'
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it.
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page.
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red")
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red")
Public method | ToString | Builds and returns a string representation of this element. (Overrides Object..::..ToString()()()().)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression.
Protected method | ValidateTag | Validate a tag name

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl.
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one.
Public property | CssClass | This HtmlControl's CSS class name.
Public property | Events | The list of events defined on this HtmlControl
Public property | Find | Find property
Public property | ID | This HtmlControl's ID.
Public property | IsActiveElement | Gets whether this element has the keyboard focus
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl.
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles.
Public property | TagName | The tag name of this HtmlControl.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlControl Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl Constructor
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlControl()()()() | Create a new emptry HtmlControl.
Public method | HtmlControl(Element) | Wrap the specified Element into a new HtmlControl.

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl Constructor
HtmlControl Class See Also Send Feedback
Create a new emptry HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlControl()
Visual Basic
Public Sub New
Visual C++
public:
HtmlControl()

See Also

HtmlControl Class
HtmlControl Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlControl Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl Constructor (Element)
HtmlControl Class See Also Send Feedback
Wrap the specified Element into a new HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlControl(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlControl(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlControl Class
HtmlControl Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl Methods
HtmlControl Class See Also Send Feedback

The HtmlControl type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl.
Public method | AssignElement | Attach the specified Element to this HtmlControl and initialize its internal properties. (Overrides Control..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl.
Public method | CallMethod<(Of <<'(T>)>>)(String) | Call a client side Javascript method on this HtmlControl and return type T.
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl.
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file.
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file.
Public method | Click()()()() | Invoke a click on this HtmlControl.
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups).
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced.
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point.
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl.
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset.
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to.
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center.
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source.
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location.
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source.
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location.
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired.
Public method | Focus | Give this Html element focus.
Protected method | GetAttributeAsString | Get an attribute of this element as a string
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl.
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor).
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox.
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEventType, Boolean) |
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden'
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it.
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page.
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red")
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red")
Public method | ToString | Builds and returns a string representation of this element. (Overrides Object..::..ToString()()()().)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression.
Protected method | ValidateTag | Validate a tag name

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AddEventListener Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..AddEventListener Method
HtmlControl Class See Also Send Feedback
Add an event handler to a Javascript event handler list on this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool AddEventListener(
    string eventType,
    EventHandler<JavascriptEventArgs> listener
)
Visual Basic
Public Overridable Function AddEventListener ( _
    eventType As String, _
    listener As EventHandler(Of JavascriptEventArgs) _
) As Boolean
Visual C++
public:
virtual bool AddEventListener(
    String^ eventType,
    EventHandler<JavascriptEventArgs^>^ listener
)

Parameters

eventType
Type: System..::..String
The event type to add the handler to.
listener
Type: System..::..EventHandler <(Of <(<' JavascriptEventArgs >)>)>
The event handler to add.

Return Value

True/False indicating whether or not the event handler was successfully added.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..AssignElement Method
HtmlControl Class See Also Send Feedback
Attach the specified Element to this HtmlControl and initialize its internal properties.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base Element to attach to.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..CallMethod Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl.
Public method | CallMethod<(Of <<'(T>)>>)(String) | Call a client side Javascript method on this HtmlControl and return type T.
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value.

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..CallMethod Method (String)
HtmlControl Class See Also Send Feedback
Call a client side Javascript method on this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CallMethod(
    string methodCall
)
Visual Basic
Public Sub CallMethod ( _
    methodCall As String _
)
Visual C++
public:
void CallMethod(
    String^ methodCall
)

Parameters

methodCall
Type: System..::..String
The method call.

See Also

HtmlControl Class
CallMethod Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..CallMethod<(Of <(<'T>)>)> Method (String)
HtmlControl Class See Also Send Feedback
Call a client side Javascript method on this HtmlControl and return type T.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T CallMethod<T>(
    string methodCall
)
Visual Basic
Public Overridable Function CallMethod(Of T) ( _
    methodCall As String _
) As T
Visual C++
public:
generic<typename T>
virtual T CallMethod(
    String^ methodCall
)

Parameters

methodCall
Type: System..::..String
The method call string.

Type Parameters

T
The type to convert the return value of the method call to.

Return Value

The return value from the methoc call, if any

See Also

HtmlControl Class
CallMethod Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod(T) Method (String, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..CallMethod<(Of <(<'T>)>)> Method (String, T)
HtmlControl Class See Also Send Feedback
Call a client side Javascript method on this HtmlControl with return type of T and a default return value.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T CallMethod<T>(
    string methodCall,
    T defaultValue
)
Visual Basic
Public Overridable Function CallMethod(Of T) ( _
    methodCall As String, _
    defaultValue As T _
) As T
Visual C++
public:
generic<typename T>
virtual T CallMethod(
    String^ methodCall,
    T defaultValue
)

Parameters

methodCall
Type: System..::..String
The method call string.
defaultValue
Type: T
A default value to use in case the conversion failed to the specified type and you want to return a custom default value other than default(T).

Type Parameters

T
The type to convert the return value of the method call to.

Return Value

The return value of the call or the default value.

See Also

HtmlControl Class
CallMethod Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Capture Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl.
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file.
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file.

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Capture Method
HtmlControl Class See Also Send Feedback
Captures and returns a bitmap image of this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Bitmap Capture()
Visual Basic
Public Overridable Function Capture As Bitmap
Visual C++
public:
virtual Bitmap^ Capture()

Return Value

Bitmap of this HtmlControl.

See Also

HtmlControl Class
Capture Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Capture Method (String)
HtmlControl Class See Also Send Feedback
Captures and saves this HtmlControl's image to the WebAii log location as a file.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Capture(
    string imageName
)
Visual Basic
Public Overridable Sub Capture ( _
    imageName As String _
)
Visual C++
public:
virtual void Capture(
    String^ imageName
)

Parameters

imageName
Type: System..::..String
The image file name (without extension) to create and write to.

See Also

HtmlControl Class
Capture Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace
BMP


Capture Method (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Capture Method (String, String)
HtmlControl Class See Also Send Feedback
Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Capture(
    string savePath,
    string imageName
)
Visual Basic
Public Overridable Sub Capture ( _
    savePath As String, _
    imageName As String _
)
Visual C++
public:
virtual void Capture(
    String^ savePath,
    String^ imageName
)

Parameters

savePath
Type: System..::..String
Directory path to write the file to.
imageName
Type: System..::..String
The image file name (without extension) to create and write to.

See Also

HtmlControl Class
Capture Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace
System.Drawing..::..Bitmap


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Click Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl.
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups).

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Click Method
HtmlControl Class See Also Send Feedback
Invoke a click on this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Click()
Visual Basic
Public Overridable Sub Click
Visual C++
public:
virtual void Click()

See Also

HtmlControl Class
Click Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Click Method (Boolean)
HtmlControl Class See Also Send Feedback
Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups).

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Click(
    bool isClosing
)
Visual Basic
Public Overridable Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
)

Parameters

isClosing
Type: System..::..Boolean
If set, we won't wait for the browser to be ready. If not set it acts the same as HtmlControl.Click().

See Also

HtmlControl Class
Click Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Download Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Download Method
HtmlControl Class See Also Send Feedback
Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Download(
    bool clickUsingDesktopMouse,
    DownloadOption downloadOption,
    string saveLocation,
    int downloadTimeout
)
Visual Basic
Public Overridable Sub Download ( _
    clickUsingDesktopMouse As Boolean, _
    downloadOption As DownloadOption, _
    saveLocation As String, _
    downloadTimeout As Integer _
)
Visual C++
public:
virtual void Download(
    bool clickUsingDesktopMouse,
    DownloadOption downloadOption,
    String^ saveLocation,
    int downloadTimeout
)

Parameters

clickUsingDesktopMouse
Type: System..::..Boolean
When set to True Desktop Mouse.Click will be used. Make sure the HtmlControl is visible in the browsers window first before using Desktop Mouse.Click. When set to False HtmlControl.Click will be used.
downloadOption
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..DownloadOption
The download option to use (Save or Cancel).
saveLocation
Type: System..::..String
The save location on disk when the download option is set to Save.
downloadTimeout
Type: System..::..Int32
The number of milliseconds to wait until all download dialogs are handled.

Exceptions

Exception | Condition
System..::..TimeoutException | Timed out waiting for the download dialogs to be handled.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point.
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl.
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset.
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to.
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center.
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source.
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location.
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source.
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location.

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (Point)
HtmlControl Class See Also Send Feedback
Drag this HtmlControl to an absolute screen coordinate point.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    Point absolutePoint
)
Visual Basic
Public Overridable Sub DragTo ( _
    absolutePoint As Point _
)
Visual C++
public:
virtual void DragTo(
    Point absolutePoint
)

Parameters

absolutePoint
Type: System.Drawing..::..Point
The absolute screen coordinate point.

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (HtmlControl)
HtmlControl Class See Also Send Feedback
Drag this HtmlControl to the center on the destination HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    HtmlControl control
)
Visual Basic
Public Overridable Sub DragTo ( _
    control As HtmlControl _
)
Visual C++
public:
virtual void DragTo(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The destination HtmlControl

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (Int32, Int32)
HtmlControl Class See Also Send Feedback
Drag this HtmlControl to a relative X/Y offset.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    int offsetX,
    int offsetY
)
Visual Basic
Public Overridable Sub DragTo ( _
    offsetX As Integer, _
    offsetY As Integer _
)
Visual C++
public:
virtual void DragTo(
    int offsetX,
    int offsetY
)

Parameters

offsetX
Type: System..::..Int32
The X offset. May be positive or negative.
offsetY
Type: System..::..Int32
The Y offset. May be positive or negative.

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (HtmlControl, OffsetReference, Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (HtmlControl, OffsetReference, Point)
HtmlControl Class See Also Send Feedback
Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    HtmlControl control,
    OffsetReference destinationOffsetReference,
    Point destinationOffset
)
Visual Basic
Public Overridable Sub DragTo ( _
    control As HtmlControl, _
    destinationOffsetReference As OffsetReference, _
    destinationOffset As Point _
)
Visual C++
public:
virtual void DragTo(
    HtmlControl^ control,
    OffsetReference destinationOffsetReference,
    Point destinationOffset
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The destination HtmlControl.
destinationOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The destination offset reference.
destinationOffset
Type: System.Drawing..::..Point
The offset amount from destination reference. May be positive or negative.

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (OffsetReference, Point, HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (OffsetReference, Point, HtmlControl)
HtmlControl Class See Also Send Feedback
Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    HtmlControl destination
)
Visual Basic
Public Overridable Sub DragTo ( _
    sourceOffsetReference As OffsetReference, _
    sourceOffset As Point, _
    destination As HtmlControl _
)
Visual C++
public:
virtual void DragTo(
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    HtmlControl^ destination
)

Parameters

sourceOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The source offset reference of the drag start.
sourceOffset
Type: System.Drawing..::..Point
The offset from the specified source reference. May be positive or negative.
destination
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The destination HtmlControl.

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (OffsetReference, Point, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (OffsetReference, Point, Int32, Int32)
HtmlControl Class See Also Send Feedback
Drag this HtmlControl from a source offset to an X/Y offset from the source.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    int destinationOffsetX,
    int destinationOffsetY
)
Visual Basic
Public Overridable Sub DragTo ( _
    sourceOffsetReference As OffsetReference, _
    sourceOffset As Point, _
    destinationOffsetX As Integer, _
    destinationOffsetY As Integer _
)
Visual C++
public:
virtual void DragTo(
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    int destinationOffsetX,
    int destinationOffsetY
)

Parameters

sourceOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The source offset reference.
sourceOffset
Type: System.Drawing..::..Point
The source offset.
destinationOffsetX
Type: System..::..Int32
The destination X offset relative to the source.
destinationOffsetY
Type: System..::..Int32
The destination Y offset relative to the source.

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (OffsetReference, Point, HtmlControl, OffsetReference, Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (OffsetReference, Point, HtmlControl, OffsetReference, Point)
HtmlControl Class See Also Send Feedback
Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    HtmlControl destination,
    OffsetReference destinationOffsetReference,
    Point destinationOffset
)
Visual Basic
Public Overridable Sub DragTo ( _
    sourceOffsetReference As OffsetReference, _
    sourceOffset As Point, _
    destination As HtmlControl, _
    destinationOffsetReference As OffsetReference, _
    destinationOffset As Point _
)
Visual C++
public:
virtual void DragTo(
    OffsetReference sourceOffsetReference,
    Point sourceOffset,
    HtmlControl^ destination,
    OffsetReference destinationOffsetReference,
    Point destinationOffset
)

Parameters

sourceOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The source offset reference of the drag start.
sourceOffset
Type: System.Drawing..::..Point
The offset from the specified spirce reference. May be positive or negative.
destination
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The destination HtmlControl.
destinationOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The destination offset reference of the drop.
destinationOffset
Type: System.Drawing..::..Point
The offset from the specified destination reference. May be positive or negative.

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32)
HtmlControl Class See Also Send Feedback
Drag this HtmlControl from a source offset to an X/Y offset from the source.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    Rectangle destinationRectangle,
    OffsetReference destinationOffsetReference,
    int destinationOffsetX,
    int destinationOffsetY
)
Visual Basic
Public Overridable Sub DragTo ( _
    sourceOffsetReference As OffsetReference, _
    sourceOffsetX As Integer, _
    sourceOffsetY As Integer, _
    destinationRectangle As Rectangle, _
    destinationOffsetReference As OffsetReference, _
    destinationOffsetX As Integer, _
    destinationOffsetY As Integer _
)
Visual C++
public:
virtual void DragTo(
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    Rectangle destinationRectangle,
    OffsetReference destinationOffsetReference,
    int destinationOffsetX,
    int destinationOffsetY
)

Parameters

sourceOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The source offset reference.
sourceOffsetX
Type: System..::..Int32
The X offset from the source. May be positive or negative.
sourceOffsetY
Type: System..::..Int32
The Y offset from the source. May be positive or negative.
destinationRectangle
Type: System.Drawing..::..Rectangle

[Missing <param name="destinationRectangle"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.DragTo(ArtOfTest.Common.OffsetReference,System.Int32,System.Int32,System.Drawing.Rectangle,ArtOfTest.Common.OffsetReference,System.Int32,System.Int32)"]

destinationOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The destination rectangle reference.
destinationOffsetX
Type: System..::..Int32
The X offset from the destination.
destinationOffsetY
Type: System..::..Int32
The Y offset from the destination.

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method (OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragTo Method (OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean)
HtmlControl Class See Also Send Feedback
Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragTo(
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    bool sourcePixelDrag,
    HtmlControl destination,
    OffsetReference destinationOffsetReference,
    int destinationOffsetX,
    int destinationOffsetY,
    bool pixelDrop
)
Visual Basic
Public Overridable Sub DragTo ( _
    sourceOffsetReference As OffsetReference, _
    sourceOffsetX As Integer, _
    sourceOffsetY As Integer, _
    sourcePixelDrag As Boolean, _
    destination As HtmlControl, _
    destinationOffsetReference As OffsetReference, _
    destinationOffsetX As Integer, _
    destinationOffsetY As Integer, _
    pixelDrop As Boolean _
)
Visual C++
public:
virtual void DragTo(
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    bool sourcePixelDrag,
    HtmlControl^ destination,
    OffsetReference destinationOffsetReference,
    int destinationOffsetX,
    int destinationOffsetY,
    bool pixelDrop
)

Parameters

sourceOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The source offset reference of the drag start.
sourceOffsetX
Type: System..::..Int32
The offset X from the specified source reference. May be positive or negative.
sourceOffsetY
Type: System..::..Int32
The offset Y from the specified source reference. May be positive or negative.
sourcePixelDrag
Type: System..::..Boolean
If True, will use the sourceOffsetX and sourceOffsetY as the pixel drop point, if false will use sourceOffsetX and sourceOffsetY as a percentage for calculating the drop point.
destination
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The destination HtmlControl.
destinationOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The destination offset reference of the drop.
destinationOffsetX
Type: System..::..Int32
The offset X from the specified destination reference. May be positive or negative.
destinationOffsetY
Type: System..::..Int32
The offset Y from the specified destination reference. May be positive or negative.
pixelDrop
Type: System..::..Boolean
If True, will use the windowOffsetX and windowOffsetY as the pixel drop point, if false will use windowOffsetX and windowOffsetY as a percentage for calculating the drop point.

See Also

HtmlControl Class
DragTo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragToWindowLocation Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..DragToWindowLocation Method
HtmlControl Class See Also Send Feedback
Drag this HtmlControl, using the browser window as the drop target

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void DragToWindowLocation(
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    bool sourcePixelDrag,
    OffsetReference windowOffset,
    int windowOffsetX,
    int windowOffsetY,
    bool pixelDrop
)
Visual Basic
Public Overridable Sub DragToWindowLocation ( _
    sourceOffsetReference As OffsetReference, _
    sourceOffsetX As Integer, _
    sourceOffsetY As Integer, _
    sourcePixelDrag As Boolean, _
    windowOffset As OffsetReference, _
    windowOffsetX As Integer, _
    windowOffsetY As Integer, _
    pixelDrop As Boolean _
)
Visual C++
public:
virtual void DragToWindowLocation(
    OffsetReference sourceOffsetReference,
    int sourceOffsetX,
    int sourceOffsetY,
    bool sourcePixelDrag,
    OffsetReference windowOffset,
    int windowOffsetX,
    int windowOffsetY,
    bool pixelDrop
)

Parameters

sourceOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The source offset reference of the drag start.
sourceOffsetX
Type: System..::..Int32
The offset X from the specified source reference. May be positive or negative.
sourceOffsetY
Type: System..::..Int32
The offset Y from the specified source reference. May be positive or negative.
sourcePixelDrag
Type: System..::..Boolean
If True, will use the sourceOffsetX and sourceOffsetY as the pixel drop point, if false will use sourceOffsetX and sourceOffsetY as a percentage for calculating the drop point.
windowOffset
Type: ArtOfTest.Common..::..OffsetReference
The destination offest reference of the drag destination.
windowOffsetX
Type: System..::..Int32
The offset X from the specified destination reference. May be positive or negative.
windowOffsetY
Type: System..::..Int32
The offset Y from the specified destination reference. May be positive or negative.
pixelDrop
Type: System..::..Boolean
If True, will use the windowOffsetX and windowOffsetY as the pixel drop point, if false will use windowOffsetX and windowOffsetY as a percentage for calculating the drop point.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


FindParentContainer(TContainerControl) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..FindParentContainer<(Of <(<'TContainerControl>)>)> Method
HtmlControl Class See Also Send Feedback
Traverses the DOM tree upwards until it finds the container element desired.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected Element FindParentContainer<TContainerControl>()
where TContainerControl : new(), HtmlContainerControl
Visual Basic
Protected Function FindParentContainer(Of TContainerControl As {New, HtmlContainerControl}) As Element
Visual C++
protected:
generic<typename TContainerControl>
where TContainerControl : gcnew(), HtmlContainerControl
Element^ FindParentContainer()

Type Parameters

TContainerControl

[Missing <typeparam name="TContainerControl"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.FindParentContainer``1"]

Return Value

The container element or element null.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Focus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Focus Method
HtmlControl Class See Also Send Feedback
Give this Html element focus.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Focus()
Visual Basic
Public Overridable Sub Focus
Visual C++
public:
virtual void Focus()

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetAttributeAsString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetAttributeAsString Method
HtmlControl Class See Also Send Feedback
Get an attribute of this element as a string

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected string GetAttributeAsString(
    string attributeName
)
Visual Basic
Protected Function GetAttributeAsString ( _
    attributeName As String _
) As String
Visual C++
protected:
String^ GetAttributeAsString(
    String^ attributeName
)

Parameters

attributeName
Type: System..::..String
The attribute name to get.

Return Value

The value of the attribute or a string.empty if the attribute is not available.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetComputedStyle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetComputedStyle Method
HtmlControl Class See Also Send Feedback
Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual HtmlStyle GetComputedStyle(
    string style
)
Visual Basic
Public Overridable Function GetComputedStyle ( _
    style As String _
) As HtmlStyle
Visual C++
public:
virtual HtmlStyle^ GetComputedStyle(
    String^ style
)

Parameters

style
Type: System..::..String
The style to access. (e.g. backgroundColor, left, border)

Return Value

The HtmlStyle object that defines this style.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetComputedStyleValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetComputedStyleValue Method
HtmlControl Class See Also Send Feedback
Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string GetComputedStyleValue(
    string style
)
Visual Basic
Public Overridable Function GetComputedStyleValue ( _
    style As String _
) As String
Visual C++
public:
virtual String^ GetComputedStyleValue(
    String^ style
)

Parameters

style
Type: System..::..String
The style to access. (e.g. backgroundColor, left, border)

Return Value

The string value of the requested computed style.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetRectangle Method
HtmlControl Class See Also Send Feedback
The absolute screen position and size of this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Rectangle GetRectangle()
Visual Basic
Public Overridable Function GetRectangle As Rectangle
Visual C++
public:
virtual Rectangle GetRectangle()

Return Value

A Rectangle identifying the coordinates of the upper left coner and the width and height of this HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetStyle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetStyle Method
HtmlControl Class See Also Send Feedback
Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual HtmlStyle GetStyle(
    string style
)
Visual Basic
Public Overridable Function GetStyle ( _
    style As String _
) As HtmlStyle
Visual C++
public:
virtual HtmlStyle^ GetStyle(
    String^ style
)

Parameters

style
Type: System..::..String
A string specifying the style to access. (e.g. backgroundColor, border)

Return Value

A HtmlStyle object that defines this style.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetStyleValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetStyleValue Method
HtmlControl Class See Also Send Feedback
Returns any style as if you are accessing the element.style object from JavaScript.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string GetStyleValue(
    string style
)
Visual Basic
Public Overridable Function GetStyleValue ( _
    style As String _
) As String
Visual C++
public:
virtual String^ GetStyleValue(
    String^ style
)

Parameters

style
Type: System..::..String
A string specifying the style to access. (e.g. backgroundColor, border)

Return Value

The string value of the requested style.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetValue Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor).
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox.
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason.

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetValue<(Of <(<'T>)>)> Method (String)
HtmlControl Class Example See Also Send Feedback
Get a property value (e.g. control.border or control.style.backgroundColor).

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T GetValue<T>(
    string propertyName
)
Visual Basic
Public Overridable Function GetValue(Of T) ( _
    propertyName As String _
) As T
Visual C++
public:
generic<typename T>
virtual T GetValue(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
The property name.

Type Parameters

T
The type of the property.

Return Value

The value of the property or default(T) if the value of the property cannot be retrieved or converted to type T.

Remarks

The property is retrieved by executing Javascript on the client side using the specified property name as the Javascript function.

Examples

string s = myControl.GetValue<string>("style.backgroundColor")

See Also

HtmlControl Class
GetValue Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue(T) Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetValue<(Of <(<'T>)>)> Method (String, Boolean)
HtmlControl Class Example See Also Send Feedback
Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T GetValue<T>(
    string propertyName,
    bool isJsWrappedObject
)
Visual Basic
Public Overridable Function GetValue(Of T) ( _
    propertyName As String, _
    isJsWrappedObject As Boolean _
) As T
Visual C++
public:
generic<typename T>
virtual T GetValue(
    String^ propertyName,
    bool isJsWrappedObject
)

Parameters

propertyName
Type: System..::..String
The property name.
isJsWrappedObject
Type: System..::..Boolean
Only applies to Firefox browser. Set to true to indicate this HtmlControl is a wrappedJSObject.

Type Parameters

T
The type of the property.

Return Value

The value of the property.

Remarks

The property is retrieved by executing Javascript on the client side using the specified property name as the Javascript function.

Remarks

See https://developer.mozilla.org/en/wrappedJSObject for more information about wrappedJSObject.

Examples

string s = myControl.GetValue<string>("style.backgroundColor", true)

See Also

HtmlControl Class
GetValue Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue(T) Method (String, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetValue<(Of <(<'T>)>)> Method (String, T)
HtmlControl Class Example See Also Send Feedback
Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T GetValue<T>(
    string propertyName,
    T defaultValue
)
Visual Basic
Public Overridable Function GetValue(Of T) ( _
    propertyName As String, _
    defaultValue As T _
) As T
Visual C++
public:
generic<typename T>
virtual T GetValue(
    String^ propertyName,
    T defaultValue
)

Parameters

propertyName
Type: System..::..String
The property name.
defaultValue
Type: T
A default value to use in case the conversion failed to the specified type and you want to return a custom default value other than default(T).

Type Parameters

T
The type of the property.

Return Value

The value of the property or defaultValue if the property value cannot be retrieved or converted.

Remarks

The property is retrieved by executing Javascript on the client side using the specified property name as the Javascript function.

Examples

string s = myControl.GetValue<string>("style.backgroundColor", "White")

See Also

HtmlControl Class
GetValue Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue(T) Method (String, Boolean, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..GetValue<(Of <(<'T>)>)> Method (String, Boolean, T)
HtmlControl Class Example See Also Send Feedback
Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T GetValue<T>(
    string propertyName,
    bool isJsWrappedObject,
    T defaultValue
)
Visual Basic
Public Overridable Function GetValue(Of T) ( _
    propertyName As String, _
    isJsWrappedObject As Boolean, _
    defaultValue As T _
) As T
Visual C++
public:
generic<typename T>
virtual T GetValue(
    String^ propertyName,
    bool isJsWrappedObject,
    T defaultValue
)

Parameters

propertyName
Type: System..::..String
The property name.
isJsWrappedObject
Type: System..::..Boolean
Only applies to Firefox browser. Set to true to indicate this HtmlControl is a wrappedJSObject.
defaultValue
Type: T
The return value, if the property has no value (is null or the empty string)

Type Parameters

T
The type of the property.

Return Value

The value of the property.

Remarks

The property is retrieved by executing Javascript on the client side using the specified property name as the Javascript function.

Remarks

See https://developer.mozilla.org/en/wrappedJSObject for more information about wrappedJSObject.

Examples

string s = myControl.GetValue<string>("style.backgroundColor", true, "White")

See Also

HtmlControl Class
GetValue Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InitializeMappings Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..InitializeMappings Method
HtmlControl Class See Also Send Feedback
Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic
Public Overridable Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
)

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::..MappingsCollection
The mappings collection to populate

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..InvokeEvent Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl.
Public method | InvokeEvent(ScriptEventType, Boolean) |

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method (ScriptEvent)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..InvokeEvent Method (ScriptEvent)
HtmlControl Class See Also Send Feedback
Invokes an event on this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void InvokeEvent(
    ScriptEvent eventObj
)
Visual Basic
Public Overridable Sub InvokeEvent ( _
    eventObj As ScriptEvent _
)
Visual C++
public:
virtual void InvokeEvent(
    ScriptEvent^ eventObj
)

Parameters

eventObj
Type: ArtOfTest.WebAii.Javascript..::..ScriptEvent
An object representing the event to invoke

See Also

HtmlControl Class
InvokeEvent Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method (ScriptEventType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..InvokeEvent Method (ScriptEventType)
HtmlControl Class See Also Send Feedback
Invokes an event on this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void InvokeEvent(
    ScriptEventType eventType
)
Visual Basic
Public Overridable Sub InvokeEvent ( _
    eventType As ScriptEventType _
)
Visual C++
public:
virtual void InvokeEvent(
    ScriptEventType eventType
)

Parameters

eventType
Type: ArtOfTest.WebAii.Core..::..ScriptEventType
The ScriptEventType to invoke.

See Also

HtmlControl Class
InvokeEvent Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method (ScriptEvent, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..InvokeEvent Method (ScriptEvent, Boolean)
HtmlControl Class See Also Send Feedback
Invokes an event on this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void InvokeEvent(
    ScriptEvent eventObj,
    bool closesBrowser
)
Visual Basic
Public Overridable Sub InvokeEvent ( _
    eventObj As ScriptEvent, _
    closesBrowser As Boolean _
)
Visual C++
public:
virtual void InvokeEvent(
    ScriptEvent^ eventObj,
    bool closesBrowser
)

Parameters

eventObj
Type: ArtOfTest.WebAii.Javascript..::..ScriptEvent
An object representing the event to invoke
closesBrowser
Type: System..::..Boolean
If set, we won't wait for the browser to be ready. If not set it acts the same as HtmlControl.InvokeEvent(eventObj).

See Also

HtmlControl Class
InvokeEvent Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method (ScriptEventType, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..InvokeEvent Method (ScriptEventType, Boolean)
HtmlControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.InvokeEvent(ArtOfTest.WebAii.Core.ScriptEventType,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void InvokeEvent(
    ScriptEventType eventType,
    bool closesBrowser
)
Visual Basic
Public Overridable Sub InvokeEvent ( _
    eventType As ScriptEventType, _
    closesBrowser As Boolean _
)
Visual C++
public:
virtual void InvokeEvent(
    ScriptEventType eventType,
    bool closesBrowser
)

Parameters

eventType
Type: ArtOfTest.WebAii.Core..::..ScriptEventType

[Missing <param name="eventType"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.InvokeEvent(ArtOfTest.WebAii.Core.ScriptEventType,System.Boolean)"]

closesBrowser
Type: System..::..Boolean

[Missing <param name="closesBrowser"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.InvokeEvent(ArtOfTest.WebAii.Core.ScriptEventType,System.Boolean)"]

See Also

HtmlControl Class
InvokeEvent Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


IsVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..IsVisible Method
HtmlControl Class See Also Send Feedback
Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden'

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsVisible()
Visual Basic
Public Overridable Function IsVisible As Boolean
Visual C++
public:
virtual bool IsVisible()

Return Value

True/False indicating whether or not this HtmlControl is currently visible on the page.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseClick Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it.
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseClick Method
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseClick()
Visual Basic
Public Overridable Sub MouseClick
Visual C++
public:
virtual void MouseClick()

See Also

HtmlControl Class
MouseClick Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method (MouseClickType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseClick Method (MouseClickType)
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseClick(
    MouseClickType clicktType
)
Visual Basic
Public Overridable Sub MouseClick ( _
    clicktType As MouseClickType _
)
Visual C++
public:
virtual void MouseClick(
    MouseClickType clicktType
)

Parameters

clicktType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
Mouse Click Type

See Also

HtmlControl Class
MouseClick Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method (MouseClickType, Point, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseClick Method (MouseClickType, Point, OffsetReference)
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseClick(
    MouseClickType clickType,
    Point offset,
    OffsetReference reference
)
Visual Basic
Public Overridable Sub MouseClick ( _
    clickType As MouseClickType, _
    offset As Point, _
    reference As OffsetReference _
)
Visual C++
public:
virtual void MouseClick(
    MouseClickType clickType,
    Point offset,
    OffsetReference reference
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
One of the MouseClickType types.
offset
Type: System.Drawing..::..Point
A point relative to the reference specified to click. The x and/or y values may be negative.
reference
Type: ArtOfTest.Common..::..OffsetReference
Which point on the HtmlControl is used as the reference point.

See Also

HtmlControl Class
MouseClick Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method (MouseClickType, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseClick Method (MouseClickType, Int32, Int32)
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseClick(
    MouseClickType clickType,
    int x,
    int y
)
Visual Basic
Public Overridable Sub MouseClick ( _
    clickType As MouseClickType, _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
virtual void MouseClick(
    MouseClickType clickType,
    int x,
    int y
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
One of the MouseClickType types
x
Type: System..::..Int32
The X offset relative to the left edge of the control to click. May be negative.
y
Type: System..::..Int32
The Y offset relative to the top side of the control to click. May be negative.

See Also

HtmlControl Class
MouseClick Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method (MouseClickType, Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseClick Method (MouseClickType, Int32, Int32, OffsetReference)
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseClick(
    MouseClickType clickType,
    int Xoffset,
    int Yoffset,
    OffsetReference reference
)
Visual Basic
Public Overridable Sub MouseClick ( _
    clickType As MouseClickType, _
    Xoffset As Integer, _
    Yoffset As Integer, _
    reference As OffsetReference _
)
Visual C++
public:
virtual void MouseClick(
    MouseClickType clickType,
    int Xoffset,
    int Yoffset,
    OffsetReference reference
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
One of the MouseClickType types.
Xoffset
Type: System..::..Int32
The X offset relative to the specified reference to click. May be negative.
Yoffset
Type: System..::..Int32
The Y offset relative to the specified reference to click. May be negative.
reference
Type: ArtOfTest.Common..::..OffsetReference
Which point on the HtmlControl is used as the reference point.

See Also

HtmlControl Class
MouseClick Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseHover Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseHover Method
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseHover()
Visual Basic
Public Overridable Sub MouseHover
Visual C++
public:
virtual void MouseHover()

See Also

HtmlControl Class
MouseHover Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method (Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseHover Method (Point)
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseHover(
    Point pointToHoverOver
)
Visual Basic
Public Overridable Sub MouseHover ( _
    pointToHoverOver As Point _
)
Visual C++
public:
virtual void MouseHover(
    Point pointToHoverOver
)

Parameters

pointToHoverOver
Type: System.Drawing..::..Point
Point relative to the upper left corner of this HtmlControl to hover. X and/or Y value may be negative.

See Also

HtmlControl Class
MouseHover Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method (Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseHover Method (Int32, Int32)
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseHover(
    int x,
    int y
)
Visual Basic
Public Overridable Sub MouseHover ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
virtual void MouseHover(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32
The X offset relative to the left edge of the control to hover over. May be negative.
y
Type: System..::..Int32
The Y offset relative to the top edge of the control to hover over. May be negative.

See Also

HtmlControl Class
MouseHover Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method (Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..MouseHover Method (Int32, Int32, OffsetReference)
HtmlControl Class See Also Send Feedback
Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void MouseHover(
    int x,
    int y,
    OffsetReference reference
)
Visual Basic
Public Overridable Sub MouseHover ( _
    x As Integer, _
    y As Integer, _
    reference As OffsetReference _
)
Visual C++
public:
virtual void MouseHover(
    int x,
    int y,
    OffsetReference reference
)

Parameters

x
Type: System..::..Int32
The X offset relative to the specified reference to hover over. May be negative.
y
Type: System..::..Int32
The Y offset relative to the specified reference to hover over. May be negative.
reference
Type: ArtOfTest.Common..::..OffsetReference
Which point on the HtmlControl is used as the reference point.

See Also

HtmlControl Class
MouseHover Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Parent(TContainerControl) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Parent<(Of <(<'TContainerControl>)>)> Method
HtmlControl Class See Also Send Feedback
Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual TContainerControl Parent<TContainerControl>()
where TContainerControl : new(), HtmlContainerControl
Visual Basic
Public Overridable Function Parent(Of TContainerControl As {New, HtmlContainerControl}) As TContainerControl
Visual C++
public:
generic<typename TContainerControl>
where TContainerControl : gcnew(), HtmlContainerControl
virtual TContainerControl Parent()

Type Parameters

TContainerControl
The desired parent container HtmlControl type to find and return.

Return Value

The parent container HtmlControl or null if desired type is not found.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


RemoveEventListener Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..RemoveEventListener Method
HtmlControl Class See Also Send Feedback
Removes an event handler from a Javascript event handler list on this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void RemoveEventListener(
    string eventType,
    EventHandler<JavascriptEventArgs> listener
)
Visual Basic
Public Overridable Sub RemoveEventListener ( _
    eventType As String, _
    listener As EventHandler(Of JavascriptEventArgs) _
)
Visual C++
public:
virtual void RemoveEventListener(
    String^ eventType,
    EventHandler<JavascriptEventArgs^>^ listener
)

Parameters

eventType
Type: System..::..String
The event type to be remove the event handler from.
listener
Type: System..::..EventHandler <(Of <(<' JavascriptEventArgs >)>)>
The event handler to remove.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ScrollToVisible Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page.
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page.

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ScrollToVisible Method
HtmlControl Class See Also Send Feedback
Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ScrollToVisible()
Visual Basic
Public Overridable Sub ScrollToVisible
Visual C++
public:
virtual void ScrollToVisible()

See Also

HtmlControl Class
ScrollToVisible Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method (ScrollToVisibleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ScrollToVisible Method (ScrollToVisibleType)
HtmlControl Class See Also Send Feedback
Scroll the browsers window to make this HtmlControl visible on the page.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ScrollToVisible(
    ScrollToVisibleType scrollToVisibleType
)
Visual Basic
Public Overridable Sub ScrollToVisible ( _
    scrollToVisibleType As ScrollToVisibleType _
)
Visual C++
public:
virtual void ScrollToVisible(
    ScrollToVisibleType scrollToVisibleType
)

Parameters

scrollToVisibleType
Type: ArtOfTest.WebAii.Core..::..ScrollToVisibleType
How the HtmlControl should be aligned on the page

See Also

HtmlControl Class
ScrollToVisible Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method (ScrollToVisibleType, Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ScrollToVisible Method (ScrollToVisibleType, Rectangle)
HtmlControl Class See Also Send Feedback
Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ScrollToVisible(
    ScrollToVisibleType scrollToVisibleType,
    Rectangle rectangle
)
Visual Basic
Public Overridable Sub ScrollToVisible ( _
    scrollToVisibleType As ScrollToVisibleType, _
    rectangle As Rectangle _
)
Visual C++
public:
virtual void ScrollToVisible(
    ScrollToVisibleType scrollToVisibleType,
    Rectangle rectangle
)

Parameters

scrollToVisibleType
Type: ArtOfTest.WebAii.Core..::..ScrollToVisibleType
How the HtmlControl should be aligned on the page.
rectangle
Type: System.Drawing..::..Rectangle
The rectangular portion of the HtmlControl that we want to make sure is visible on the page.

See Also

HtmlControl Class
ScrollToVisible Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..SetValue Method
HtmlControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red")
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red")

See Also

HtmlControl Class
HtmlControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue(T) Method (String, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..SetValue<(Of <(<'T>)>)> Method (String, T)
HtmlControl Class Example See Also Send Feedback
Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red")

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SetValue<T>(
    string propertyName,
    T value
)
Visual Basic
Public Overridable Sub SetValue(Of T) ( _
    propertyName As String, _
    value As T _
)
Visual C++
public:
generic<typename T>
virtual void SetValue(
    String^ propertyName,
    T value
)

Parameters

propertyName
Type: System..::..String
The property name.
value
Type: T
The value to set.

Type Parameters

T
The type of the property.

Examples

myControl.SetValue$lt;string>("style.backgroundColor","red")

See Also

HtmlControl Class
SetValue Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue(T) Method (String, T, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..SetValue<(Of <(<'T>)>)> Method (String, T, Boolean)
HtmlControl Class Example See Also Send Feedback
Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red")

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SetValue<T>(
    string propertyName,
    T value,
    bool isJsWrappedObject
)
Visual Basic
Public Overridable Sub SetValue(Of T) ( _
    propertyName As String, _
    value As T, _
    isJsWrappedObject As Boolean _
)
Visual C++
public:
generic<typename T>
virtual void SetValue(
    String^ propertyName,
    T value,
    bool isJsWrappedObject
)

Parameters

propertyName
Type: System..::..String
The property name.
value
Type: T
The value to set.
isJsWrappedObject
Type: System..::..Boolean
Whether the property is a JsWrappedObject. Specific to Firefox.

Type Parameters

T
The type of the property.

Examples

myControl.SetValue<string>("style.backgroundColor","red")

See Also

HtmlControl Class
SetValue Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ToString Method
HtmlControl Class See Also Send Feedback
Builds and returns a string representation of this element.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of this element.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidateControl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ValidateControl Method
HtmlControl Class See Also Send Feedback
Validate a HtmlControl using its LocatorExpression.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool ValidateControl()
Visual Basic
Protected Function ValidateControl As Boolean
Visual C++
protected:
bool ValidateControl()

Return Value

true of the control validated successfully. Otherwise false.

Remarks

ValidateControl uses LocatorExpression if both LocatorExpression and Locator are defined, and uses Locator only if LocatorExpression is not defined.

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown when the control does not match its FindExpression.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidateTag Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ValidateTag Method
HtmlControl Class See Also Send Feedback
Validate a tag name

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool ValidateTag(
    string tagName
)
Visual Basic
Protected Function ValidateTag ( _
    tagName As String _
) As Boolean
Visual C++
protected:
bool ValidateTag(
    String^ tagName
)

Parameters

tagName
Type: System..::..String
The tagName to verify.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl.ValidateTag(System.String)"]

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl Properties
HtmlControl Class See Also Send Feedback

The HtmlControl type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl.
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one.
Public property | CssClass | This HtmlControl's CSS class name.
Public property | Events | The list of events defined on this HtmlControl
Public property | Find | Find property
Public property | ID | This HtmlControl's ID.
Public property | IsActiveElement | Gets whether this element has the keyboard focus
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl.
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles.
Public property | TagName | The tag name of this HtmlControl.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Attributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Attributes Property
HtmlControl Class See Also Send Feedback
All attributes defined for this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual ReadOnlyCollection<iAttribute> Attributes { get; }
Visual Basic
Public Overridable ReadOnly Property Attributes As ReadOnlyCollection(Of iAttribute)
    Get
Visual C++
public:
virtual property ReadOnlyCollection<iAttribute^>^ Attributes {
    ReadOnlyCollection<iAttribute^>^ get ();
}

Field Value

A ReadOnlyCollection<iAttribute> of the attributes defined for this HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ChildNodes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ChildNodes Property
HtmlControl Class See Also Send Feedback
Get all the child element nodes of this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> ChildNodes { get; }
Visual Basic
Public ReadOnly Property ChildNodes As ReadOnlyCollection(Of Element)
    Get
Visual C++
public:
property ReadOnlyCollection<Element^>^ ChildNodes {
    ReadOnlyCollection<Element^>^ get ();
}

Field Value

A ReadOnlyCollection of the child Element's of this HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ClientSideLocator Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ClientSideLocator Property
HtmlControl Class Example See Also Send Feedback
Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string ClientSideLocator { get; }
Visual Basic
Public Overridable ReadOnly Property ClientSideLocator As String
    Get
Visual C++
public:
virtual property String^ ClientSideLocator {
    String^ get ();
}

Field Value

A string identifying the locator for this HtmlControl.

Examples

(in ASP.NET) $find('myClientObject')

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CssClass Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..CssClass Property
HtmlControl Class See Also Send Feedback
This HtmlControl's CSS class name.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string CssClass { get; }
Visual Basic
Public Overridable ReadOnly Property CssClass As String
    Get
Visual C++
public:
virtual property String^ CssClass {
    String^ get ();
}

Field Value

A string specifying this HtmlControl's CSS class name. An empty string if not present for this HtmlControl

Remarks

See also http://msdn.microsoft.com/en-us/library/ms533560(VS.85).aspx

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Events Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Events Property
HtmlControl Class See Also Send Feedback
The list of events defined on this HtmlControl

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual NameValueCollection Events { get; }
Visual Basic
Public Overridable ReadOnly Property Events As NameValueCollection
    Get
Visual C++
public:
virtual property NameValueCollection^ Events {
    NameValueCollection^ get ();
}

Field Value

A NameValueCollection containing a list of events defined on this HtmlControl. An empty list is returned if there are no styles defined.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Find Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Find Property
HtmlControl Class See Also Send Feedback
Find property

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual HtmlFind Find { get; }
Visual Basic
Public Overridable ReadOnly Property Find As HtmlFind
    Get
Visual C++
public:
virtual property HtmlFind^ Find {
    HtmlFind^ get ();
}

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ID Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ID Property
HtmlControl Class See Also Send Feedback
This HtmlControl's ID.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string ID { get; }
Visual Basic
Public Overridable ReadOnly Property ID As String
    Get
Visual C++
public:
virtual property String^ ID {
    String^ get ();
}

Field Value

A string specifying this HtmlControls ID. An empty string if not present for this HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace
HtmlElement..::..Id


IsActiveElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..IsActiveElement Property
HtmlControl Class See Also Send Feedback
Gets whether this element has the keyboard focus

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsActiveElement { get; }
Visual Basic
Public ReadOnly Property IsActiveElement As Boolean
    Get
Visual C++
public:
property bool IsActiveElement {
    bool get ();
}

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


IsEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..IsEnabled Property
HtmlControl Class See Also Send Feedback
Gets / sets whether this control is enabled (not disabled)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic
Public Property IsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Only applies to input controls

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Mappings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Mappings Property
HtmlControl Class See Also Send Feedback
Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual MappingsCollection Mappings { get; }
Visual Basic
Public Overridable ReadOnly Property Mappings As MappingsCollection
    Get
Visual C++
public:
virtual property MappingsCollection^ Mappings {
    MappingsCollection^ get ();
}

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollLeft Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ScrollLeft Property
HtmlControl Class See Also Send Feedback
Gets / Sets the scrollLeft value of this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int ScrollLeft { get; set; }
Visual Basic
Public Overridable Property ScrollLeft As Integer
    Get
    Set
Visual C++
public:
virtual property int ScrollLeft {
    int get ();
    void set (int value);
}

Field Value

An int specifying the scrollLeft value.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace
HtmlElement..::..ScrollLeft


ScrollTop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..ScrollTop Property
HtmlControl Class See Also Send Feedback
Gets / Sets the scrollTop value of this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int ScrollTop { get; set; }
Visual Basic
Public Overridable Property ScrollTop As Integer
    Get
    Set
Visual C++
public:
virtual property int ScrollTop {
    int get ();
    void set (int value);
}

Field Value

An int specifying the scrollTop value for thos HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace
HtmlElement..::..ScrollTop


Styles Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Styles Property
HtmlControl Class See Also Send Feedback
Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual NameValueCollection Styles { get; }
Visual Basic
Public Overridable ReadOnly Property Styles As NameValueCollection
    Get
Visual C++
public:
virtual property NameValueCollection^ Styles {
    NameValueCollection^ get ();
}

Field Value

A NameValueCollection containing a list of styles defined on this HtmlControl. An empty list is returned if there are no styles defined.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


TagName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..TagName Property
HtmlControl Class See Also Send Feedback
The tag name of this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string TagName { get; }
Visual Basic
Public Overridable ReadOnly Property TagName As String
    Get
Visual C++
public:
virtual property String^ TagName {
    String^ get ();
}

Field Value

A string specifying the tag identification of this HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace
HtmlElement..::..TagName


Wait Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControl..::..Wait Property
HtmlControl Class See Also Send Feedback
Gets the HtmlWait object attached to this HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual HtmlWait Wait { get; }
Visual Basic
Public Overridable ReadOnly Property Wait As HtmlWait
    Get
Visual C++
public:
virtual property HtmlWait^ Wait {
    HtmlWait^ get ();
}

Field Value

An HtmlWait object. null if no HtmlWait object is attached to this HtmlControl.

See Also

HtmlControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlControlsAssertExtensions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions Members
HtmlControlsAssertExtensions Class Methods See Also Send Feedback

The HtmlControlsAssertExtensions type exposes the following members.

Methods

Name | Description
AssertAttribute(HtmlControl) | Assert methods based on the HtmlControl's attributes.
AssertAttribute(HtmlControl, Boolean) | Assert methods based on the HtmlControl's attributes
AssertContent | Assert methods based on the HtmlControl's content.
AssertStyle(HtmlControl) | Assert methods based on the HtmlControl's style.
AssertStyle(HtmlControl, Boolean) | Assert methods based on the HtmlControl's style.

See Also

HtmlControlsAssertExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlControlsAssertExtensions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions Methods
HtmlControlsAssertExtensions Class See Also Send Feedback

The HtmlControlsAssertExtensions type exposes the following members.

Methods

Name | Description
AssertAttribute(HtmlControl) | Assert methods based on the HtmlControl's attributes.
AssertAttribute(HtmlControl, Boolean) | Assert methods based on the HtmlControl's attributes
AssertContent | Assert methods based on the HtmlControl's content.
AssertStyle(HtmlControl) | Assert methods based on the HtmlControl's style.
AssertStyle(HtmlControl, Boolean) | Assert methods based on the HtmlControl's style.

See Also

HtmlControlsAssertExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertAttribute Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions..::..AssertAttribute Method
HtmlControlsAssertExtensions Class See Also Send Feedback

Overload List

Name | Description
AssertAttribute(HtmlControl) | Assert methods based on the HtmlControl's attributes.
AssertAttribute(HtmlControl, Boolean) | Assert methods based on the HtmlControl's attributes

See Also

HtmlControlsAssertExtensions Class
HtmlControlsAssertExtensions Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertAttribute Method (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions..::..AssertAttribute Method (HtmlControl)
HtmlControlsAssertExtensions Class See Also Send Feedback
Assert methods based on the HtmlControl's attributes.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertAttribute AssertAttribute(
    this HtmlControl control
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertAttribute ( _
    control As HtmlControl _
) As AssertAttribute
Visual C++
[ExtensionAttribute]
public:
static AssertAttribute^ AssertAttribute(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The HtmlControl being tested.

Return Value

An AssertAttribute object initializated to this HTML cotnrol.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlControl. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlControlsAssertExtensions Class
AssertAttribute Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertAttribute Method (HtmlControl, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions..::..AssertAttribute Method (HtmlControl, Boolean)
HtmlControlsAssertExtensions Class See Also Send Feedback
Assert methods based on the HtmlControl's attributes

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertAttribute AssertAttribute(
    this HtmlControl control,
    bool throwOnFailure
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertAttribute ( _
    control As HtmlControl, _
    throwOnFailure As Boolean _
) As AssertAttribute
Visual C++
[ExtensionAttribute]
public:
static AssertAttribute^ AssertAttribute(
    HtmlControl^ control,
    bool throwOnFailure
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The HtmlControl being tested
throwOnFailure
Type: System..::..Boolean
Whether to throw an exception if the assertion fails

Return Value

An AssertAttribute object initialized to this HTML control

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlControl. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlControlsAssertExtensions Class
AssertAttribute Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions..::..AssertContent Method
HtmlControlsAssertExtensions Class See Also Send Feedback
Assert methods based on the HtmlControl's content.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertContent AssertContent(
    this HtmlControl control
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertContent ( _
    control As HtmlControl _
) As AssertContent
Visual C++
[ExtensionAttribute]
public:
static AssertContent^ AssertContent(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The HtmlControl being tested.

Return Value

An AssertContent object initializated to this HTML cotnrol.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlControl. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlControlsAssertExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertStyle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions..::..AssertStyle Method
HtmlControlsAssertExtensions Class See Also Send Feedback

Overload List

Name | Description
AssertStyle(HtmlControl) | Assert methods based on the HtmlControl's style.
AssertStyle(HtmlControl, Boolean) | Assert methods based on the HtmlControl's style.

See Also

HtmlControlsAssertExtensions Class
HtmlControlsAssertExtensions Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertStyle Method (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions..::..AssertStyle Method (HtmlControl)
HtmlControlsAssertExtensions Class See Also Send Feedback
Assert methods based on the HtmlControl's style.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertStyle AssertStyle(
    this HtmlControl control
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertStyle ( _
    control As HtmlControl _
) As AssertStyle
Visual C++
[ExtensionAttribute]
public:
static AssertStyle^ AssertStyle(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The HtmlControl being tested.

Return Value

An AssertStyle object initializated to this HTML cotnrol.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlControl. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlControlsAssertExtensions Class
AssertStyle Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertStyle Method (HtmlControl, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlControlsAssertExtensions..::..AssertStyle Method (HtmlControl, Boolean)
HtmlControlsAssertExtensions Class See Also Send Feedback
Assert methods based on the HtmlControl's style.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertStyle AssertStyle(
    this HtmlControl control,
    bool throwOnFailure
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertStyle ( _
    control As HtmlControl, _
    throwOnFailure As Boolean _
) As AssertStyle
Visual C++
[ExtensionAttribute]
public:
static AssertStyle^ AssertStyle(
    HtmlControl^ control,
    bool throwOnFailure
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The HtmlControl being tested.
throwOnFailure
Type: System..::..Boolean
Whether this assert object should throw an exception if the check fails

Return Value

An AssertStyle object initializated to this HTML cotnrol.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlControl. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlControlsAssertExtensions Class
AssertStyle Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionDescription Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription Members
HtmlDefinitionDescription Class Constructors Methods Properties See Also Send Feedback

The HtmlDefinitionDescription type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlDefinitionDescription()()()() | Create a new control.
Public method | HtmlDefinitionDescription(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Description | Gets the definition description.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionDescription Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription Constructor
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlDefinitionDescription()()()() | Create a new control.
Public method | HtmlDefinitionDescription(Element) | Create a new test control

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionDescription Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription Constructor
HtmlDefinitionDescription Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDefinitionDescription()
Visual Basic
Public Sub New
Visual C++
public:
HtmlDefinitionDescription()

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionDescription Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription Constructor (Element)
HtmlDefinitionDescription Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDefinitionDescription(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlDefinitionDescription(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionDescription Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription Methods
HtmlDefinitionDescription Class See Also Send Feedback

The HtmlDefinitionDescription type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlDefinitionDescription Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..AssignElement Method
HtmlDefinitionDescription Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDefinitionDescription Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..CallMethod Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..Capture Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..Click Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..DragTo Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..GetValue Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..InvokeEvent Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..MouseClick Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..MouseHover Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..ScrollToVisible Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..SetValue Method
HtmlDefinitionDescription Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
HtmlDefinitionDescription Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionDescription Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription Properties
HtmlDefinitionDescription Class See Also Send Feedback

The HtmlDefinitionDescription type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Description | Gets the definition description.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDefinitionDescription Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Description Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionDescription..::..Description Property
HtmlDefinitionDescription Class See Also Send Feedback
Gets the definition description.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

HtmlDefinitionDescription Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionList Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList Members
HtmlDefinitionList Class Constructors Methods Properties See Also Send Feedback

The HtmlDefinitionList type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlDefinitionList()()()() | Create a new control.
Public method | HtmlDefinitionList(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Descriptions | Gets an array of descriptions contained in this definition list
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Terms | Gets an array of terms contained in this definition list.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionList Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList Constructor
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlDefinitionList()()()() | Create a new control.
Public method | HtmlDefinitionList(Element) | Create a new test control

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionList Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList Constructor
HtmlDefinitionList Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDefinitionList()
Visual Basic
Public Sub New
Visual C++
public:
HtmlDefinitionList()

See Also

HtmlDefinitionList Class
HtmlDefinitionList Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionList Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList Constructor (Element)
HtmlDefinitionList Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDefinitionList(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlDefinitionList(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDefinitionList Class
HtmlDefinitionList Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionList Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList Methods
HtmlDefinitionList Class See Also Send Feedback

The HtmlDefinitionList type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlDefinitionList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..AssignElement Method
HtmlDefinitionList Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDefinitionList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..CallMethod Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..Capture Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..Click Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..DragTo Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..GetValue Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..InvokeEvent Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..MouseClick Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..MouseHover Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..ScrollToVisible Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..SetValue Method
HtmlDefinitionList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
HtmlDefinitionList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionList Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList Properties
HtmlDefinitionList Class See Also Send Feedback

The HtmlDefinitionList type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Descriptions | Gets an array of descriptions contained in this definition list
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Terms | Gets an array of terms contained in this definition list.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDefinitionList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Descriptions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..Descriptions Property
HtmlDefinitionList Class See Also Send Feedback
Gets an array of descriptions contained in this definition list

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDefinitionDescription[] Descriptions { get; }
Visual Basic
Public ReadOnly Property Descriptions As HtmlDefinitionDescription()
    Get
Visual C++
public:
property array<HtmlDefinitionDescription^>^ Descriptions {
    array<HtmlDefinitionDescription^>^ get ();
}

See Also

HtmlDefinitionList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Terms Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionList..::..Terms Property
HtmlDefinitionList Class See Also Send Feedback
Gets an array of terms contained in this definition list.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDefinitionTerm[] Terms { get; }
Visual Basic
Public ReadOnly Property Terms As HtmlDefinitionTerm()
    Get
Visual C++
public:
property array<HtmlDefinitionTerm^>^ Terms {
    array<HtmlDefinitionTerm^>^ get ();
}

See Also

HtmlDefinitionList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionTerm Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm Members
HtmlDefinitionTerm Class Constructors Methods Properties See Also Send Feedback

The HtmlDefinitionTerm type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlDefinitionTerm()()()() | Create a new control.
Public method | HtmlDefinitionTerm(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Term | Gets the definition term.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionTerm Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm Constructor
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlDefinitionTerm()()()() | Create a new control.
Public method | HtmlDefinitionTerm(Element) | Create a new test control

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionTerm Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm Constructor
HtmlDefinitionTerm Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDefinitionTerm()
Visual Basic
Public Sub New
Visual C++
public:
HtmlDefinitionTerm()

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionTerm Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm Constructor (Element)
HtmlDefinitionTerm Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDefinitionTerm(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlDefinitionTerm(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionTerm Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm Methods
HtmlDefinitionTerm Class See Also Send Feedback

The HtmlDefinitionTerm type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlDefinitionTerm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..AssignElement Method
HtmlDefinitionTerm Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDefinitionTerm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..CallMethod Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..Capture Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..Click Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..DragTo Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..GetValue Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..InvokeEvent Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..MouseClick Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..MouseHover Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..ScrollToVisible Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..SetValue Method
HtmlDefinitionTerm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
HtmlDefinitionTerm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDefinitionTerm Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm Properties
HtmlDefinitionTerm Class See Also Send Feedback

The HtmlDefinitionTerm type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Term | Gets the definition term.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDefinitionTerm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Term Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDefinitionTerm..::..Term Property
HtmlDefinitionTerm Class See Also Send Feedback
Gets the definition term.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Term { get; }
Visual Basic
Public ReadOnly Property Term As String
    Get
Visual C++
public:
property String^ Term {
    String^ get ();
}

See Also

HtmlDefinitionTerm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDetails Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails Members
HtmlDetails Class Constructors Methods Properties See Also Send Feedback

The HtmlDetails type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlDetails()()()() | Create a new control.
Public method | HtmlDetails(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Open |
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDetails Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails Constructor
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlDetails()()()() | Create a new control.
Public method | HtmlDetails(Element) | Create a new test control

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDetails Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails Constructor
HtmlDetails Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDetails()
Visual Basic
Public Sub New
Visual C++
public:
HtmlDetails()

See Also

HtmlDetails Class
HtmlDetails Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDetails Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails Constructor (Element)
HtmlDetails Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDetails(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlDetails(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDetails Class
HtmlDetails Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDetails Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails Methods
HtmlDetails Class See Also Send Feedback

The HtmlDetails type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlDetails Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..AssignElement Method
HtmlDetails Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDetails Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..CallMethod Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..Capture Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..Click Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..DragTo Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..GetValue Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..InvokeEvent Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..MouseClick Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..MouseHover Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..ScrollToVisible Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..SetValue Method
HtmlDetails Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlDetails Class
HtmlDetails Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDetails Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails Properties
HtmlDetails Class See Also Send Feedback

The HtmlDetails type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Open |
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDetails Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Open Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDetails..::..Open Property
HtmlDetails Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlDetails.Open"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Open { get; set; }
Visual Basic
Public Property Open As Boolean
    Get
    Set
Visual C++
public:
property bool Open {
    bool get ();
    void set (bool value);
}

See Also

HtmlDetails Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDiv Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv Members
HtmlDiv Class Constructors Methods Properties See Also Send Feedback

The HtmlDiv type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlDiv()()()() | Create a new control.
Public method | HtmlDiv(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDiv Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv Constructor
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlDiv()()()() | Create a new control.
Public method | HtmlDiv(Element) | Create a new test control

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDiv Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv Constructor
HtmlDiv Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDiv()
Visual Basic
Public Sub New
Visual C++
public:
HtmlDiv()

See Also

HtmlDiv Class
HtmlDiv Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDiv Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv Constructor (Element)
HtmlDiv Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlDiv(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlDiv(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDiv Class
HtmlDiv Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDiv Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv Methods
HtmlDiv Class See Also Send Feedback

The HtmlDiv type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlDiv Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..AssignElement Method
HtmlDiv Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlDiv Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..CallMethod Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..Capture Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..Click Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..DragTo Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..GetValue Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..InvokeEvent Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..MouseClick Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..MouseHover Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..ScrollToVisible Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv..::..SetValue Method
HtmlDiv Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlDiv Class
HtmlDiv Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlDiv Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlDiv Properties
HtmlDiv Class See Also Send Feedback

The HtmlDiv type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlDiv Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlFind Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind Members
HtmlFind Class Constructors Methods Properties Events See Also Send Feedback

The HtmlFind type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlFind | Create a new Find object.

Methods

Name Description
Public method AllByAttributes(array<String>[]()[][])
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
(Inherited from Find.)
Public method AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
The TextContent to match

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method AllByCustom(Predicate<(Of <<'(Element>)>>))
Return all elements that match the predicate
(Inherited from Find.)
Public method AllByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>))
Returns all controls that match the predicate and are convertable to TControl.
(Inherited from Find.)
Public method AllByExpression(array<String>[]()[][])
Find all elements by HTML find expression strings.
(Inherited from Find.)
Public method AllByExpression(HtmlFindExpression)
Find all elements by HtmlFindExpression.
(Inherited from Find.)
Public method AllByParam(FindParam) Obsolete.
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
(Inherited from Find.)
Public method AllByTagName(String)
Returns a list of elements with a specific tag name.
(Inherited from Find.)
Public method AllByXPath(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
(Inherited from Find.)
Public method AllControls<(Of <<'(TControl>)>>)
Gets an IEnmerable for TControl to be used for LINQ queries. This will return only elements that are convertable to TControl
(Inherited from Find.)
Public method AllElements
Gets a IEnumerable for all elements to be used for LINQ queries
(Inherited from Find.)
Public method ByAttributes(array<String>[]()[][])
Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.
(Inherited from Find.)
Public method ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
(Inherited from Find.)
Public method ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method ByContent(String, FindContentType, array<String>[]()[][])
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method ByCustom(Predicate<(Of <<'(Element>)>>))
Return the element that matches the defined predicate.
(Inherited from Find.)
Public method ByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>))
Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.
(Inherited from Find.)
Public method ByExpression(HtmlFindExpression, Boolean)
Find Element by HtmlFindExpression.
(Inherited from Find.)
Public method ByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][])
Find element by HTML find expression strings of type TControl.
(Inherited from Find.)
Public method ByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression)
Find element by HtmlFindExpression of type TControl.
(Inherited from Find.)
Public method ById(String)
Returns an element by looking for its 'id' attribute value.
(Inherited from Find.)
Public method ByName(String)
Returns an element by searching for its 'name' attribute value
(Inherited from Find.)
Public method ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.

Examples

CopyC#
For example:

This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

<referenceElement>
 (0)<foo>
        <bar>
        </bar>
        <car>
        </car>
     (2)<bus>
         (0)<driver>
                <cap>
                </cap>
             (1)<target>
                </target>
            </driver>
        </bus>
    </foo>
</referenceElement>
(Inherited from Find.)
Public method ByParam(FindParam) Obsolete.
Return an element using a FindParam
(Inherited from Find.)
Public method ByParam(array<FindParam>[]()[][]) Obsolete.
Returns an element using a chained identification.
(Inherited from Find.)
Public method ByTagIndex(String, Int32)
Returns an element by its tag name occrrence.
(Inherited from Find.)
Public method ByXPath(String)
Returns an element using an XPath. This function supports the System.Xml XPath syntax.
(Inherited from Find.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FromCollection(FindParamCollection) Obsolete.
Finds all elements with the FindParams in the passed in collection.
(Inherited from Find.)
Public method FromCollection(FindExpressionCollection<(Of <<'(HtmlFindExpression>)>>))
Finds all elements with the HtmlFindExpressions in the collection.
(Inherited from Find.)
Public method FromExpressionsFile
Finds all elements with FindExpressions defined in a file.
(Inherited from Find.)
Public method FromExpressionsXml
Finds all elements with FindExpressions defined in the serialized xml string.
(Inherited from Find.)
Public method FromFile Obsolete.
Finds all elements with FindParams defined in a file.
(Inherited from Find.)
Public method FromXml Obsolete.
Finds all elements with FindParams defined in the serialized xml string. Found elements can be accessed from Find.Elements
(Inherited from Find.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Table
Finds the first table that contains the cell text content specified.
Public method TableCell
Finds the first table cell that contains the text content specified. If the text is contained by a control inside that table cell, this method will not find that cell.
Public method TableRow
Finds the first table row that contains the cell text content specified.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | jQuery | Creates and returns a new jQuery object for the Find object. (Defined by jQueryExtension.)

Properties

 | Name | Description
Public property | AssociatedBrowser | Gets the browser object that is associated with this find object. If this property is null, then the Find object is associated with a search region. (Inherited from Find.)
Public property | FindReferenceType | Gets the reference type that this Find object is using. (i.e. browser root, testregion ... etc) (Inherited from Find.)
Public property | IgnoreFindAllControlMismatch | Gets/Sets whether to ignore Find.Allxx<TControl>(...) elements that don't match the TControl specified. (i.e. the TControl type validation fails for that element). If false, the Find.Allxx method will throw an exception. (Inherited from Find.)
Public property | LastFindParam | Gets the last FindParam used to search. (Inherited from Find.)
Public property | LastSearchLog | Gets the search log for the last find attempt. This log can help diagnose when find fails to locate an element. (Inherited from Find.)
Public property | SearchRegion | Gets the search region for this Find object. When this is set to a specific region, all search is done locale to that region. All indexes are calculated starting at zero from this region's element. If this property is null, then the Find object will perform all searches from the document root element. (Inherited from Find.)
Public property | SearchRootElement | Gets/Sets the root element that all searches will be performed under. This element depended on the reference type. [Browser/TestRegion/Element]. (Inherited from Find.)
Public property | ThrowIfNullOrEmpty | Gets/Sets whether to throw an exception if any of the find methods returns a null element or any of the find all methods return empty list of elements. (Inherited from Find.)

Events

 | Name | Description
Public event | ReturnedNullOrEmpty | Invoked when one of the find methods returns null or an empty list of elements. (Inherited from Find.)

See Also

HtmlFind Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlFind Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind Constructor
HtmlFind Class See Also Send Feedback
Create a new Find object.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlFind(
    Element rootElement
)
Visual Basic
Public Sub New ( _
    rootElement As Element _
)
Visual C++
public:
HtmlFind(
    Element^ rootElement
)

Parameters

rootElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="rootElement"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlFind.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

HtmlFind Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlFind Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind Methods
HtmlFind Class See Also Send Feedback

The HtmlFind type exposes the following members.

Methods

Name Description
Public method AllByAttributes(array<String>[]()[][])
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
(Inherited from Find.)
Public method AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
The TextContent to match

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method AllByCustom(Predicate<(Of <<'(Element>)>>))
Return all elements that match the predicate
(Inherited from Find.)
Public method AllByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>))
Returns all controls that match the predicate and are convertable to TControl.
(Inherited from Find.)
Public method AllByExpression(array<String>[]()[][])
Find all elements by HTML find expression strings.
(Inherited from Find.)
Public method AllByExpression(HtmlFindExpression)
Find all elements by HtmlFindExpression.
(Inherited from Find.)
Public method AllByParam(FindParam) Obsolete.
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
(Inherited from Find.)
Public method AllByTagName(String)
Returns a list of elements with a specific tag name.
(Inherited from Find.)
Public method AllByXPath(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
(Inherited from Find.)
Public method AllControls<(Of <<'(TControl>)>>)
Gets an IEnmerable for TControl to be used for LINQ queries. This will return only elements that are convertable to TControl
(Inherited from Find.)
Public method AllElements
Gets a IEnumerable for all elements to be used for LINQ queries
(Inherited from Find.)
Public method ByAttributes(array<String>[]()[][])
Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.
(Inherited from Find.)
Public method ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
(Inherited from Find.)
Public method ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method ByContent(String, FindContentType, array<String>[]()[][])
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method ByCustom(Predicate<(Of <<'(Element>)>>))
Return the element that matches the defined predicate.
(Inherited from Find.)
Public method ByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>))
Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.
(Inherited from Find.)
Public method ByExpression(HtmlFindExpression, Boolean)
Find Element by HtmlFindExpression.
(Inherited from Find.)
Public method ByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][])
Find element by HTML find expression strings of type TControl.
(Inherited from Find.)
Public method ByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression)
Find element by HtmlFindExpression of type TControl.
(Inherited from Find.)
Public method ById(String)
Returns an element by looking for its 'id' attribute value.
(Inherited from Find.)
Public method ByName(String)
Returns an element by searching for its 'name' attribute value
(Inherited from Find.)
Public method ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.

Examples

CopyC#
For example:

This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

<referenceElement>
 (0)<foo>
        <bar>
        </bar>
        <car>
        </car>
     (2)<bus>
         (0)<driver>
                <cap>
                </cap>
             (1)<target>
                </target>
            </driver>
        </bus>
    </foo>
</referenceElement>
(Inherited from Find.)
Public method ByParam(FindParam) Obsolete.
Return an element using a FindParam
(Inherited from Find.)
Public method ByParam(array<FindParam>[]()[][]) Obsolete.
Returns an element using a chained identification.
(Inherited from Find.)
Public method ByTagIndex(String, Int32)
Returns an element by its tag name occrrence.
(Inherited from Find.)
Public method ByXPath(String)
Returns an element using an XPath. This function supports the System.Xml XPath syntax.
(Inherited from Find.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FromCollection(FindParamCollection) Obsolete.
Finds all elements with the FindParams in the passed in collection.
(Inherited from Find.)
Public method FromCollection(FindExpressionCollection<(Of <<'(HtmlFindExpression>)>>))
Finds all elements with the HtmlFindExpressions in the collection.
(Inherited from Find.)
Public method FromExpressionsFile
Finds all elements with FindExpressions defined in a file.
(Inherited from Find.)
Public method FromExpressionsXml
Finds all elements with FindExpressions defined in the serialized xml string.
(Inherited from Find.)
Public method FromFile Obsolete.
Finds all elements with FindParams defined in a file.
(Inherited from Find.)
Public method FromXml Obsolete.
Finds all elements with FindParams defined in the serialized xml string. Found elements can be accessed from Find.Elements
(Inherited from Find.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method Table
Finds the first table that contains the cell text content specified.
Public method TableCell
Finds the first table cell that contains the text content specified. If the text is contained by a control inside that table cell, this method will not find that cell.
Public method TableRow
Finds the first table row that contains the cell text content specified.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | jQuery | Creates and returns a new jQuery object for the Find object. (Defined by jQueryExtension.)

See Also

HtmlFind Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AllByContent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..AllByContent Method
HtmlFind Class See Also Send Feedback

Overload List

Name Description
Public method AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
The TextContent to match

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)

See Also

HtmlFind Class
HtmlFind Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AllByCustom Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..AllByCustom Method
HtmlFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>)) | Returns all controls that match the predicate and are convertable to TControl. (Inherited from Find.)
Public method | AllByCustom(Predicate<(Of <<'(Element>)>>)) | Return all elements that match the predicate (Inherited from Find.)

See Also

HtmlFind Class
HtmlFind Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AllByExpression Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..AllByExpression Method
HtmlFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByExpression(array<String>[]()[][]) | Find all elements by HTML find expression strings. (Inherited from Find.)
Public method | AllByExpression(HtmlFindExpression) | Find all elements by HtmlFindExpression. (Inherited from Find.)

See Also

HtmlFind Class
HtmlFind Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ByContent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..ByContent Method
HtmlFind Class See Also Send Feedback

Overload List

Name Description
Public method ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
(Inherited from Find.)
Public method ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)
Public method ByContent(String, FindContentType, array<String>[]()[][])
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
(Inherited from Find.)

See Also

HtmlFind Class
HtmlFind Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ByCustom Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..ByCustom Method
HtmlFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>)) | Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type. (Inherited from Find.)
Public method | ByCustom(Predicate<(Of <<'(Element>)>>)) | Return the element that matches the defined predicate. (Inherited from Find.)

See Also

HtmlFind Class
HtmlFind Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ByExpression Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..ByExpression Method
HtmlFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find element by HTML find expression strings of type TControl. (Inherited from Find.)
Public method | ByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression) | Find element by HtmlFindExpression of type TControl. (Inherited from Find.)
Public method | ByExpression(HtmlFindExpression, Boolean) | Find Element by HtmlFindExpression. (Inherited from Find.)

See Also

HtmlFind Class
HtmlFind Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ByParam Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..ByParam Method
HtmlFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByParam(FindParam) | Obsolete. Return an element using a FindParam (Inherited from Find.)
Public method | ByParam(array<FindParam>[]()[][]) | Obsolete. Returns an element using a chained identification. (Inherited from Find.)

See Also

HtmlFind Class
HtmlFind Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


FromCollection Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..FromCollection Method
HtmlFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FromCollection(FindParamCollection) | Obsolete. Finds all elements with the FindParams in the passed in collection. (Inherited from Find.)
Public method | FromCollection(FindExpressionCollection<(Of <<'(HtmlFindExpression>)>>)) | Finds all elements with the HtmlFindExpressions in the collection. (Inherited from Find.)

See Also

HtmlFind Class
HtmlFind Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Table Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..Table Method
HtmlFind Class See Also Send Feedback
Finds the first table that contains the cell text content specified.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTable Table(
    string textContent
)
Visual Basic
Public Function Table ( _
    textContent As String _
) As HtmlTable
Visual C++
public:
HtmlTable^ Table(
    String^ textContent
)

Parameters

textContent
Type: System..::..String
The cell text content to find..

Return Value

The HtmlTable that contains that text, else null

See Also

HtmlFind Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


TableCell Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..TableCell Method
HtmlFind Class See Also Send Feedback
Finds the first table cell that contains the text content specified. If the text is contained by a control inside that table cell, this method will not find that cell.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTableCell TableCell(
    string textContent
)
Visual Basic
Public Function TableCell ( _
    textContent As String _
) As HtmlTableCell
Visual C++
public:
HtmlTableCell^ TableCell(
    String^ textContent
)

Parameters

textContent
Type: System..::..String
The text content.

Return Value

The HtmlTableCell that contains that text, else null.

See Also

HtmlFind Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


TableRow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind..::..TableRow Method
HtmlFind Class See Also Send Feedback
Finds the first table row that contains the cell text content specified.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTableRow TableRow(
    string textContent
)
Visual Basic
Public Function TableRow ( _
    textContent As String _
) As HtmlTableRow
Visual C++
public:
HtmlTableRow^ TableRow(
    String^ textContent
)

Parameters

textContent
Type: System..::..String
The text content.

Return Value

The HtmlTableRow that contains that text, else null

See Also

HtmlFind Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlFind Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind Properties
HtmlFind Class See Also Send Feedback

The HtmlFind type exposes the following members.

Properties

 | Name | Description
Public property | AssociatedBrowser | Gets the browser object that is associated with this find object. If this property is null, then the Find object is associated with a search region. (Inherited from Find.)
Public property | FindReferenceType | Gets the reference type that this Find object is using. (i.e. browser root, testregion ... etc) (Inherited from Find.)
Public property | IgnoreFindAllControlMismatch | Gets/Sets whether to ignore Find.Allxx<TControl>(...) elements that don't match the TControl specified. (i.e. the TControl type validation fails for that element). If false, the Find.Allxx method will throw an exception. (Inherited from Find.)
Public property | LastFindParam | Gets the last FindParam used to search. (Inherited from Find.)
Public property | LastSearchLog | Gets the search log for the last find attempt. This log can help diagnose when find fails to locate an element. (Inherited from Find.)
Public property | SearchRegion | Gets the search region for this Find object. When this is set to a specific region, all search is done locale to that region. All indexes are calculated starting at zero from this region's element. If this property is null, then the Find object will perform all searches from the document root element. (Inherited from Find.)
Public property | SearchRootElement | Gets/Sets the root element that all searches will be performed under. This element depended on the reference type. [Browser/TestRegion/Element]. (Inherited from Find.)
Public property | ThrowIfNullOrEmpty | Gets/Sets whether to throw an exception if any of the find methods returns a null element or any of the find all methods return empty list of elements. (Inherited from Find.)

See Also

HtmlFind Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlFind Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFind Events
HtmlFind Class See Also Send Feedback

The HtmlFind type exposes the following members.

Events

 | Name | Description
Public event | ReturnedNullOrEmpty | Invoked when one of the find methods returns null or an empty list of elements. (Inherited from Find.)

See Also

HtmlFind Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlForm Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm Members
HtmlForm Class Constructors Methods Properties See Also Send Feedback

The HtmlForm type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlForm()()()() | Create a new control.
Public method | HtmlForm(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutofocusInput | Gets the autofocus input control of this form
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EncType | Gets the MIME type used to encode the content of a form.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Length | Gets the number of elements in a form.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a form.
Public property | NoValidate | Gets or sets whether the form uses the browser to validate its inputs
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open the action-URL in a form.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlForm Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm Constructor
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlForm()()()() | Create a new control.
Public method | HtmlForm(Element) | Create a new control.

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlForm Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm Constructor
HtmlForm Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlForm()
Visual Basic
Public Sub New
Visual C++
public:
HtmlForm()

See Also

HtmlForm Class
HtmlForm Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlForm Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm Constructor (Element)
HtmlForm Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlForm(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlForm(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlForm Class
HtmlForm Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlForm Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm Methods
HtmlForm Class See Also Send Feedback

The HtmlForm type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..AssignElement Method
HtmlForm Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..CallMethod Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..Capture Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..Click Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..DragTo Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..GetValue Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..InvokeEvent Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..MouseClick Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..MouseHover Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..ScrollToVisible Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..SetValue Method
HtmlForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlForm Class
HtmlForm Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlForm Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm Properties
HtmlForm Class See Also Send Feedback

The HtmlForm type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutofocusInput | Gets the autofocus input control of this form
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EncType | Gets the MIME type used to encode the content of a form.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Length | Gets the number of elements in a form.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a form.
Public property | NoValidate | Gets or sets whether the form uses the browser to validate its inputs
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open the action-URL in a form.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AutofocusInput Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..AutofocusInput Property
HtmlForm Class See Also Send Feedback
Gets the autofocus input control of this form

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputControl AutofocusInput { get; }
Visual Basic
Public ReadOnly Property AutofocusInput As HtmlInputControl
    Get
Visual C++
public:
property HtmlInputControl^ AutofocusInput {
    HtmlInputControl^ get ();
}

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


EncType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..EncType Property
HtmlForm Class See Also Send Feedback
Gets the MIME type used to encode the content of a form.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string EncType { get; }
Visual Basic
Public ReadOnly Property EncType As String
    Get
Visual C++
public:
property String^ EncType {
    String^ get ();
}

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Length Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..Length Property
HtmlForm Class See Also Send Feedback
Gets the number of elements in a form.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get
Visual C++
public:
property int Length {
    int get ();
}

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..Name Property
HtmlForm Class See Also Send Feedback
Gets the name of a form.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


NoValidate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..NoValidate Property
HtmlForm Class See Also Send Feedback
Gets or sets whether the form uses the browser to validate its inputs

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool NoValidate { get; set; }
Visual Basic
Public Property NoValidate As Boolean
    Get
    Set
Visual C++
public:
property bool NoValidate {
    bool get ();
    void set (bool value);
}

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Target Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlForm..::..Target Property
HtmlForm Class See Also Send Feedback
Gets where to open the action-URL in a form.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Target { get; }
Visual Basic
Public ReadOnly Property Target As String
    Get
Visual C++
public:
property String^ Target {
    String^ get ();
}

See Also

HtmlForm Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlImage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage Members
HtmlImage Class Constructors Methods Properties See Also Send Feedback

The HtmlImage type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlImage()()()() | Create a new control.
Public method | HtmlImage(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsLoaded | Checks to see if the image has finished loading on the page or not.
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | A string that specifies the alignment of the image relative to other Web page elements.
Public property | Alt | A string that contains the alternative caption for the browser to use when the image is unavailable.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Border | Specifies the width of the border around an image.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | The height of the image in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Src | A string that contains the URL to the image to display.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | The width of the image in pixels.

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlImage Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage Constructor
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlImage()()()() | Create a new control.
Public method | HtmlImage(Element) | Create a new control.

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlImage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage Constructor
HtmlImage Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlImage()
Visual Basic
Public Sub New
Visual C++
public:
HtmlImage()

See Also

HtmlImage Class
HtmlImage Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlImage Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage Constructor (Element)
HtmlImage Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlImage(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlImage(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlImage Class
HtmlImage Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlImage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage Methods
HtmlImage Class See Also Send Feedback

The HtmlImage type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsLoaded | Checks to see if the image has finished loading on the page or not.
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..AssignElement Method
HtmlImage Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..CallMethod Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..Capture Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..Click Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..DragTo Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..GetValue Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..InvokeEvent Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


IsLoaded Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..IsLoaded Method
HtmlImage Class See Also Send Feedback
Checks to see if the image has finished loading on the page or not.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsLoaded()
Visual Basic
Public Function IsLoaded As Boolean
Visual C++
public:
bool IsLoaded()

Return Value

Returns true/false indicating if the image successfully loaded or not on the page.

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..MouseClick Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..MouseHover Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..ScrollToVisible Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..SetValue Method
HtmlImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlImage Class
HtmlImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlImage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage Properties
HtmlImage Class See Also Send Feedback

The HtmlImage type exposes the following members.

Properties

 | Name | Description
Public property | Align | A string that specifies the alignment of the image relative to other Web page elements.
Public property | Alt | A string that contains the alternative caption for the browser to use when the image is unavailable.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Border | Specifies the width of the border around an image.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | The height of the image in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Src | A string that contains the URL to the image to display.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | The width of the image in pixels.

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Align Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..Align Property
HtmlImage Class See Also Send Feedback
A string that specifies the alignment of the image relative to other Web page elements.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Align { get; }
Visual Basic
Public ReadOnly Property Align As String
    Get
Visual C++
public:
property String^ Align {
    String^ get ();
}

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Alt Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..Alt Property
HtmlImage Class See Also Send Feedback
A string that contains the alternative caption for the browser to use when the image is unavailable.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Alt { get; }
Visual Basic
Public ReadOnly Property Alt As String
    Get
Visual C++
public:
property String^ Alt {
    String^ get ();
}

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Border Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..Border Property
HtmlImage Class See Also Send Feedback
Specifies the width of the border around an image.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Border { get; }
Visual Basic
Public ReadOnly Property Border As String
    Get
Visual C++
public:
property String^ Border {
    String^ get ();
}

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..Height Property
HtmlImage Class See Also Send Feedback
The height of the image in pixels.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Height { get; }
Visual Basic
Public ReadOnly Property Height As String
    Get
Visual C++
public:
property String^ Height {
    String^ get ();
}

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Src Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..Src Property
HtmlImage Class See Also Send Feedback
A string that contains the URL to the image to display.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Src { get; }
Visual Basic
Public ReadOnly Property Src As String
    Get
Visual C++
public:
property String^ Src {
    String^ get ();
}

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlImage..::..Width Property
HtmlImage Class See Also Send Feedback
The width of the image in pixels.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Width { get; }
Visual Basic
Public ReadOnly Property Width As String
    Get
Visual C++
public:
property String^ Width {
    String^ get ();
}

See Also

HtmlImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton Members
HtmlInputButton Class Constructors Methods Properties See Also Send Feedback

The HtmlInputButton type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputButton()()()() | Create a new control.
Public method | HtmlInputButton(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton Constructor
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputButton()()()() | Create a new control.
Public method | HtmlInputButton(Element) | Create a new control.

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton Constructor
HtmlInputButton Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputButton()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputButton()

See Also

HtmlInputButton Class
HtmlInputButton Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton Constructor (Element)
HtmlInputButton Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputButton Class
HtmlInputButton Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton Methods
HtmlInputButton Class See Also Send Feedback

The HtmlInputButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..AssignElement Method
HtmlInputButton Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..CallMethod Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..Capture Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..Click Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..DragTo Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..GetValue Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..InvokeEvent Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..MouseClick Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..MouseHover Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..ScrollToVisible Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton..::..SetValue Method
HtmlInputButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
HtmlInputButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputButton Properties
HtmlInputButton Class See Also Send Feedback

The HtmlInputButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputCheckBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox Members
HtmlInputCheckBox Class Constructors Methods Properties See Also Send Feedback

The HtmlInputCheckBox type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputCheckBox()()()() | Create a new control.
Public method | HtmlInputCheckBox(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Sets the Checked state to isChecked and optionally invokes the onclick event.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertCheck | Assert methods for the HtmlInputCheckBox control. (Defined by HtmlInputCheckBoxExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Checked | Sets or returns whether or not a checkbox should be checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputCheckBox Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox Constructor
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputCheckBox()()()() | Create a new control.
Public method | HtmlInputCheckBox(Element) | Create a new control.

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputCheckBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox Constructor
HtmlInputCheckBox Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputCheckBox()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputCheckBox()

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputCheckBox Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox Constructor (Element)
HtmlInputCheckBox Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputCheckBox(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputCheckBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputCheckBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox Methods
HtmlInputCheckBox Class See Also Send Feedback

The HtmlInputCheckBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Sets the Checked state to isChecked and optionally invokes the onclick event.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertCheck | Assert methods for the HtmlInputCheckBox control. (Defined by HtmlInputCheckBoxExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputCheckBox Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..AssignElement Method
HtmlInputCheckBox Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputCheckBox Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..CallMethod Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..Capture Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..Check Method
HtmlInputCheckBox Class See Also Send Feedback
Sets the Checked state to isChecked and optionally invokes the onclick event.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Check(
    bool isChecked,
    bool invokeOnClickChanged
)
Visual Basic
Public Sub Check ( _
    isChecked As Boolean, _
    invokeOnClickChanged As Boolean _
)
Visual C++
public:
void Check(
    bool isChecked,
    bool invokeOnClickChanged
)

Parameters

isChecked
Type: System..::..Boolean
The checked state to set.
invokeOnClickChanged
Type: System..::..Boolean
True/False whether to invoke the click event.

See Also

HtmlInputCheckBox Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..Click Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..DragTo Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..GetValue Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..InvokeEvent Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..MouseClick Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..MouseHover Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..ScrollToVisible Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..SetValue Method
HtmlInputCheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
HtmlInputCheckBox Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputCheckBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox Properties
HtmlInputCheckBox Class See Also Send Feedback

The HtmlInputCheckBox type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Checked | Sets or returns whether or not a checkbox should be checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputCheckBox Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Checked Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBox..::..Checked Property
HtmlInputCheckBox Class See Also Send Feedback
Sets or returns whether or not a checkbox should be checked.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Checked { get; set; }
Visual Basic
Public Property Checked As Boolean
    Get
    Set
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

HtmlInputCheckBox Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputCheckBoxExtensions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBoxExtensions Members
HtmlInputCheckBoxExtensions Class Methods See Also Send Feedback

The HtmlInputCheckBoxExtensions type exposes the following members.

Methods

Name | Description
AssertCheck | Assert methods for the HtmlInputCheckBox control.

See Also

HtmlInputCheckBoxExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputCheckBoxExtensions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBoxExtensions Methods
HtmlInputCheckBoxExtensions Class See Also Send Feedback

The HtmlInputCheckBoxExtensions type exposes the following members.

Methods

Name | Description
AssertCheck | Assert methods for the HtmlInputCheckBox control.

See Also

HtmlInputCheckBoxExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertCheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputCheckBoxExtensions..::..AssertCheck Method
HtmlInputCheckBoxExtensions Class See Also Send Feedback
Assert methods for the HtmlInputCheckBox control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertCheck AssertCheck(
    this HtmlInputCheckBox control
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertCheck ( _
    control As HtmlInputCheckBox _
) As AssertCheck
Visual C++
[ExtensionAttribute]
public:
static AssertCheck^ AssertCheck(
    HtmlInputCheckBox^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlInputCheckBox
The HtmlInputCheckBox to wrap.

Return Value

A HtmlInputCheckBox wrapped in a AssertCheck object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlInputCheckBox. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlInputCheckBoxExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl Members
HtmlInputControl Class Constructors Methods Properties See Also Send Feedback

The HtmlInputControl type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputControl()()()() | Create a new test control.
Public method | HtmlInputControl(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
 | GetControlType | Determines the framework control type according to the input element type.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control.

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control
Public property | Required | Gets whether this input must be filled in for the form to validate
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type
Public property | Value | Gets or sets the value attribute for control
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputControl Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl Constructor
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputControl()()()() | Create a new test control.
Public method | HtmlInputControl(Element) | Create a new control.

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl Constructor
HtmlInputControl Class See Also Send Feedback
Create a new test control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputControl()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputControl()

See Also

HtmlInputControl Class
HtmlInputControl Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputControl Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl Constructor (Element)
HtmlInputControl Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputControl(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputControl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputControl Class
HtmlInputControl Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl Methods
HtmlInputControl Class See Also Send Feedback

The HtmlInputControl type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
 | GetControlType | Determines the framework control type according to the input element type.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control.

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..AssignElement Method
HtmlInputControl Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..CallMethod Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..Capture Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..Click Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..DragTo Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetControlType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..GetControlType Method
HtmlInputControl Class See Also Send Feedback
Determines the framework control type according to the input element type.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Type GetControlType(
    InputElementType type
)
Visual Basic
Public Shared Function GetControlType ( _
    type As InputElementType _
) As Type
Visual C++
public:
static Type^ GetControlType(
    InputElementType type
)

Parameters

type
Type: ArtOfTest.WebAii.ObjectModel..::..InputElementType
The input element type to look for.

Return Value

The corresponding framework control type.

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..GetValue Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..InvokeEvent Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..MouseClick Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..MouseHover Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..ScrollToVisible Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..SetValue Method
HtmlInputControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
HtmlInputControl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidateType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..ValidateType Method
HtmlInputControl Class See Also Send Feedback
Validates the type of the input control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void ValidateType(
    InputElementType inputElementType
)
Visual Basic
Protected Sub ValidateType ( _
    inputElementType As InputElementType _
)
Visual C++
protected:
void ValidateType(
    InputElementType inputElementType
)

Parameters

inputElementType
Type: ArtOfTest.WebAii.ObjectModel..::..InputElementType
InputElementType Enum

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl Properties
HtmlInputControl Class See Also Send Feedback

The HtmlInputControl type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control
Public property | Required | Gets whether this input must be filled in for the form to validate
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type
Public property | Value | Gets or sets the value attribute for control
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Autofocus Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..Autofocus Property
HtmlInputControl Class See Also Send Feedback
Gets whether this element is the autofocus input for the form containing it

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Autofocus { get; }
Visual Basic
Public ReadOnly Property Autofocus As Boolean
    Get
Visual C++
public:
property bool Autofocus {
    bool get ();
}

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..Name Property
HtmlInputControl Class See Also Send Feedback
Gets the name attribute for control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Placeholder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..Placeholder Property
HtmlInputControl Class See Also Send Feedback
Gets the placeholder text for the control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Placeholder { get; }
Visual Basic
Public ReadOnly Property Placeholder As String
    Get
Visual C++
public:
property String^ Placeholder {
    String^ get ();
}

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Required Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..Required Property
HtmlInputControl Class See Also Send Feedback
Gets whether this input must be filled in for the form to validate

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Required { get; }
Visual Basic
Public ReadOnly Property Required As Boolean
    Get
Visual C++
public:
property bool Required {
    bool get ();
}

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..Type Property
HtmlInputControl Class See Also Send Feedback
Input control type

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InputElementType Type { get; }
Visual Basic
Public ReadOnly Property Type As InputElementType
    Get
Visual C++
public:
property InputElementType Type {
    InputElementType get ();
}

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputControl..::..Value Property
HtmlInputControl Class See Also Send Feedback
Gets or sets the value attribute for control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlInputControl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputEmail Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail Members
HtmlInputEmail Class Constructors Methods Properties See Also Send Feedback

The HtmlInputEmail type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputEmail()()()() | Create a new control.
Public method | HtmlInputEmail(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputText..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputEmail Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail Constructor
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputEmail()()()() | Create a new control.
Public method | HtmlInputEmail(Element) | Create a new control.

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputEmail Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail Constructor
HtmlInputEmail Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputEmail()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputEmail()

See Also

HtmlInputEmail Class
HtmlInputEmail Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputEmail Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail Constructor (Element)
HtmlInputEmail Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputEmail(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputEmail(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputEmail Class
HtmlInputEmail Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputEmail Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail Methods
HtmlInputEmail Class See Also Send Feedback

The HtmlInputEmail type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputEmail Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..CallMethod Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..Capture Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..Click Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..DragTo Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..GetValue Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..InvokeEvent Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..MouseClick Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..MouseHover Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..ScrollToVisible Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..SetValue Method
HtmlInputEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
HtmlInputEmail Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputEmail Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail Properties
HtmlInputEmail Class See Also Send Feedback

The HtmlInputEmail type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputText..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputEmail Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidationType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputEmail..::..ValidationType Property
HtmlInputEmail Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputEmail.ValidationType"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override InputElementType ValidationType { get; }
Visual Basic
Protected Overrides ReadOnly Property ValidationType As InputElementType
    Get
Visual C++
protected:
virtual property InputElementType ValidationType {
    InputElementType get () override;
}

See Also

HtmlInputEmail Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputFile Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile Members
HtmlInputFile Class Constructors Methods Properties See Also Send Feedback

The HtmlInputFile type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputFile()()()() | Create a new control.
Public method | HtmlInputFile(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Upload | Upload a file.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FilePath | Gets or sets the Path for the control
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputFile Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile Constructor
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputFile()()()() | Create a new control.
Public method | HtmlInputFile(Element) | Create a new control.

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputFile Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile Constructor
HtmlInputFile Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputFile()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputFile()

See Also

HtmlInputFile Class
HtmlInputFile Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputFile Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile Constructor (Element)
HtmlInputFile Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputFile(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputFile(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputFile Class
HtmlInputFile Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputFile Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile Methods
HtmlInputFile Class See Also Send Feedback

The HtmlInputFile type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Upload | Upload a file.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputFile Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..AssignElement Method
HtmlInputFile Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputFile Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..CallMethod Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..Capture Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..Click Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..DragTo Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..GetValue Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..InvokeEvent Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..MouseClick Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..MouseHover Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..ScrollToVisible Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..SetValue Method
HtmlInputFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
HtmlInputFile Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Upload Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..Upload Method
HtmlInputFile Class See Also Send Feedback
Upload a file.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Upload(
    string filePath,
    int uploadTimeout
)
Visual Basic
Public Sub Upload ( _
    filePath As String, _
    uploadTimeout As Integer _
)
Visual C++
public:
void Upload(
    String^ filePath,
    int uploadTimeout
)

Parameters

filePath
Type: System..::..String
The full path to file to upload.
uploadTimeout
Type: System..::..Int32
The timeout to wait until upload is complete.

See Also

HtmlInputFile Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputFile Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile Properties
HtmlInputFile Class See Also Send Feedback

The HtmlInputFile type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FilePath | Gets or sets the Path for the control
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputFile Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


FilePath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputFile..::..FilePath Property
HtmlInputFile Class See Also Send Feedback
Gets or sets the Path for the control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlInputFile Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputHidden Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden Members
HtmlInputHidden Class Constructors Methods Properties See Also Send Feedback

The HtmlInputHidden type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputHidden()()()() | Create a new control.
Public method | HtmlInputHidden(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputHidden Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden Constructor
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputHidden()()()() | Create a new control.
Public method | HtmlInputHidden(Element) | Create a new control.

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputHidden Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden Constructor
HtmlInputHidden Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputHidden()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputHidden()

See Also

HtmlInputHidden Class
HtmlInputHidden Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputHidden Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden Constructor (Element)
HtmlInputHidden Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputHidden(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputHidden(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputHidden Class
HtmlInputHidden Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputHidden Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden Methods
HtmlInputHidden Class See Also Send Feedback

The HtmlInputHidden type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputHidden Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..AssignElement Method
HtmlInputHidden Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputHidden Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..CallMethod Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..Capture Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..Click Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..DragTo Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..GetValue Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..InvokeEvent Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..MouseClick Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..MouseHover Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..ScrollToVisible Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden..::..SetValue Method
HtmlInputHidden Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
HtmlInputHidden Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputHidden Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputHidden Properties
HtmlInputHidden Class See Also Send Feedback

The HtmlInputHidden type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputHidden Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputImage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage Members
HtmlInputImage Class Constructors Methods Properties See Also Send Feedback

The HtmlInputImage type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputImage()()()() | Create a new control.
Public method | HtmlInputImage(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | A string that specifies the alignment of the image relative to other Web page elements.
Public property | Alt | A string that contains the alternative caption for the browser to use when the image is unavailable.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Border | The width (in pixels) of a frame for an image.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | The height of the image.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Src | A string that contains the path to an image file to display.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | The width of the image.

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputImage Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage Constructor
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputImage()()()() | Create a new control.
Public method | HtmlInputImage(Element) | Create a new control.

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputImage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage Constructor
HtmlInputImage Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputImage()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputImage()

See Also

HtmlInputImage Class
HtmlInputImage Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputImage Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage Constructor (Element)
HtmlInputImage Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputImage(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputImage(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputImage Class
HtmlInputImage Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputImage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage Methods
HtmlInputImage Class See Also Send Feedback

The HtmlInputImage type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..AssignElement Method
HtmlInputImage Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..CallMethod Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..Capture Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..Click Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..DragTo Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..GetValue Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..InvokeEvent Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..MouseClick Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..MouseHover Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..ScrollToVisible Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..SetValue Method
HtmlInputImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputImage Class
HtmlInputImage Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputImage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage Properties
HtmlInputImage Class See Also Send Feedback

The HtmlInputImage type exposes the following members.

Properties

 | Name | Description
Public property | Align | A string that specifies the alignment of the image relative to other Web page elements.
Public property | Alt | A string that contains the alternative caption for the browser to use when the image is unavailable.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Border | The width (in pixels) of a frame for an image.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | The height of the image.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Src | A string that contains the path to an image file to display.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | The width of the image.

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Align Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..Align Property
HtmlInputImage Class See Also Send Feedback
A string that specifies the alignment of the image relative to other Web page elements.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Align { get; }
Visual Basic
Public ReadOnly Property Align As String
    Get
Visual C++
public:
property String^ Align {
    String^ get ();
}

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Alt Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..Alt Property
HtmlInputImage Class See Also Send Feedback
A string that contains the alternative caption for the browser to use when the image is unavailable.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Alt { get; }
Visual Basic
Public ReadOnly Property Alt As String
    Get
Visual C++
public:
property String^ Alt {
    String^ get ();
}

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Border Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..Border Property
HtmlInputImage Class See Also Send Feedback
The width (in pixels) of a frame for an image.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Border { get; }
Visual Basic
Public ReadOnly Property Border As String
    Get
Visual C++
public:
property String^ Border {
    String^ get ();
}

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..Height Property
HtmlInputImage Class See Also Send Feedback
The height of the image.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Height { get; }
Visual Basic
Public ReadOnly Property Height As String
    Get
Visual C++
public:
property String^ Height {
    String^ get ();
}

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Src Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..Src Property
HtmlInputImage Class See Also Send Feedback
A string that contains the path to an image file to display.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Src { get; }
Visual Basic
Public ReadOnly Property Src As String
    Get
Visual C++
public:
property String^ Src {
    String^ get ();
}

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputImage..::..Width Property
HtmlInputImage Class See Also Send Feedback
The width of the image.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Width { get; }
Visual Basic
Public ReadOnly Property Width As String
    Get
Visual C++
public:
property String^ Width {
    String^ get ();
}

See Also

HtmlInputImage Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputNumber Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber Members
HtmlInputNumber Class Constructors Methods Properties See Also Send Feedback

The HtmlInputNumber type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputNumber()()()() | Create a new control.
Public method | HtmlInputNumber(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | StepDown |
Public method | StepUp |
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Max |
Public property | Min |
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Step |
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputText..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | ValueAsNumber |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputNumber Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber Constructor
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputNumber()()()() | Create a new control.
Public method | HtmlInputNumber(Element) | Create a new control.

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputNumber Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber Constructor
HtmlInputNumber Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputNumber()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputNumber()

See Also

HtmlInputNumber Class
HtmlInputNumber Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputNumber Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber Constructor (Element)
HtmlInputNumber Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputNumber(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputNumber(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputNumber Class
HtmlInputNumber Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputNumber Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber Methods
HtmlInputNumber Class See Also Send Feedback

The HtmlInputNumber type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | StepDown |
Public method | StepUp |
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..CallMethod Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..Capture Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..Click Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..DragTo Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..GetValue Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..InvokeEvent Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..MouseClick Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..MouseHover Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..ScrollToVisible Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..SetValue Method
HtmlInputNumber Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
HtmlInputNumber Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


StepDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..StepDown Method
HtmlInputNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.StepDown(System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void StepDown(
    int n
)
Visual Basic
Public Sub StepDown ( _
    n As Integer _
)
Visual C++
public:
void StepDown(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.StepDown(System.Int32)"]

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


StepUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..StepUp Method
HtmlInputNumber Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.StepUp(System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void StepUp(
    int n
)
Visual Basic
Public Sub StepUp ( _
    n As Integer _
)
Visual C++
public:
void StepUp(
    int n
)

Parameters

n
Type: System..::..Int32

[Missing <param name="n"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.StepUp(System.Int32)"]

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputNumber Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber Properties
HtmlInputNumber Class See Also Send Feedback

The HtmlInputNumber type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Max |
Public property | Min |
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Step |
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputText..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | ValueAsNumber |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Max Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..Max Property
HtmlInputNumber Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.Max"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Max { get; set; }
Visual Basic
Public Property Max As Double
    Get
    Set
Visual C++
public:
property double Max {
    double get ();
    void set (double value);
}

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Min Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..Min Property
HtmlInputNumber Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.Min"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Min { get; set; }
Visual Basic
Public Property Min As Double
    Get
    Set
Visual C++
public:
property double Min {
    double get ();
    void set (double value);
}

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Step Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..Step Property
HtmlInputNumber Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.Step"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Step { get; set; }
Visual Basic
Public Property Step As Double
    Get
    Set
Visual C++
public:
property double Step {
    double get ();
    void set (double value);
}

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidationType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..ValidationType Property
HtmlInputNumber Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.ValidationType"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override InputElementType ValidationType { get; }
Visual Basic
Protected Overrides ReadOnly Property ValidationType As InputElementType
    Get
Visual C++
protected:
virtual property InputElementType ValidationType {
    InputElementType get () override;
}

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValueAsNumber Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputNumber..::..ValueAsNumber Property
HtmlInputNumber Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputNumber.ValueAsNumber"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ValueAsNumber { get; set; }
Visual Basic
Public Property ValueAsNumber As Double
    Get
    Set
Visual C++
public:
property double ValueAsNumber {
    double get ();
    void set (double value);
}

See Also

HtmlInputNumber Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputPassword Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword Members
HtmlInputPassword Class Constructors Methods Properties See Also Send Feedback

The HtmlInputPassword type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputPassword()()()() | Create a new control.
Public method | HtmlInputPassword(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters).
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputPassword Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword Constructor
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputPassword()()()() | Create a new control.
Public method | HtmlInputPassword(Element) | Create a new control.

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputPassword Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword Constructor
HtmlInputPassword Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputPassword()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputPassword()

See Also

HtmlInputPassword Class
HtmlInputPassword Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputPassword Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword Constructor (Element)
HtmlInputPassword Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputPassword(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputPassword(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputPassword Class
HtmlInputPassword Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputPassword Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword Methods
HtmlInputPassword Class See Also Send Feedback

The HtmlInputPassword type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputPassword Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..AssignElement Method
HtmlInputPassword Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputPassword Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..CallMethod Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..Capture Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..Click Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..DragTo Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..GetValue Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..InvokeEvent Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..MouseClick Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..MouseHover Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..ScrollToVisible Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..SetValue Method
HtmlInputPassword Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
HtmlInputPassword Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputPassword Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword Properties
HtmlInputPassword Class See Also Send Feedback

The HtmlInputPassword type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters).
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputPassword Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Disabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..Disabled Property
HtmlInputPassword Class See Also Send Feedback
Gets whether or not a text field is disabled

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Disabled { get; }
Visual Basic
Public ReadOnly Property Disabled As Boolean
    Get
Visual C++
public:
property bool Disabled {
    bool get ();
}

See Also

HtmlInputPassword Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Size Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..Size Property
HtmlInputPassword Class See Also Send Feedback
Gets the size of a text field (in number of characters).

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get
Visual C++
public:
property int Size {
    int get ();
}

See Also

HtmlInputPassword Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


TabIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..TabIndex Property
HtmlInputPassword Class See Also Send Feedback
Gets the tab order for a text field.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TabIndex { get; }
Visual Basic
Public ReadOnly Property TabIndex As Integer
    Get
Visual C++
public:
property int TabIndex {
    int get ();
}

See Also

HtmlInputPassword Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputPassword..::..Text Property
HtmlInputPassword Class See Also Send Feedback
Gets/Sets the value of the value attribute of a text field

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlInputPassword Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRadioButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton Members
HtmlInputRadioButton Class Constructors Methods Properties See Also Send Feedback

The HtmlInputRadioButton type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputRadioButton()()()() | Create a new control.
Public method | HtmlInputRadioButton(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Sets the Checked state to isChecked and optionally invokes the onclick event.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertCheck | Assert methods for the HtmlInputRadioButton control. (Defined by HtmlInputRadioButtonExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Checked | Gets/Sets whether or not a checkbox should be checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRadioButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton Constructor
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputRadioButton()()()() | Create a new control.
Public method | HtmlInputRadioButton(Element) | Create a new control.

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRadioButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton Constructor
HtmlInputRadioButton Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputRadioButton()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputRadioButton()

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRadioButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton Constructor (Element)
HtmlInputRadioButton Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputRadioButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputRadioButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRadioButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton Methods
HtmlInputRadioButton Class See Also Send Feedback

The HtmlInputRadioButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Sets the Checked state to isChecked and optionally invokes the onclick event.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertCheck | Assert methods for the HtmlInputRadioButton control. (Defined by HtmlInputRadioButtonExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputRadioButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..AssignElement Method
HtmlInputRadioButton Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputRadioButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..CallMethod Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..Capture Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..Check Method
HtmlInputRadioButton Class See Also Send Feedback
Sets the Checked state to isChecked and optionally invokes the onclick event.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Check(
    bool isChecked,
    bool invokeOnClickChanged
)
Visual Basic
Public Sub Check ( _
    isChecked As Boolean, _
    invokeOnClickChanged As Boolean _
)
Visual C++
public:
void Check(
    bool isChecked,
    bool invokeOnClickChanged
)

Parameters

isChecked
Type: System..::..Boolean
The checked state to set.
invokeOnClickChanged
Type: System..::..Boolean
True/False whether to invoke the click event.

See Also

HtmlInputRadioButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..Click Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..DragTo Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..GetValue Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..InvokeEvent Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..MouseClick Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..MouseHover Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..ScrollToVisible Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..SetValue Method
HtmlInputRadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
HtmlInputRadioButton Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRadioButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton Properties
HtmlInputRadioButton Class See Also Send Feedback

The HtmlInputRadioButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Checked | Gets/Sets whether or not a checkbox should be checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputRadioButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Checked Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButton..::..Checked Property
HtmlInputRadioButton Class See Also Send Feedback
Gets/Sets whether or not a checkbox should be checked.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Checked { get; set; }
Visual Basic
Public Property Checked As Boolean
    Get
    Set
Visual C++
public:
property bool Checked {
    bool get ();
    void set (bool value);
}

See Also

HtmlInputRadioButton Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRadioButtonExtensions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButtonExtensions Members
HtmlInputRadioButtonExtensions Class Methods See Also Send Feedback

The HtmlInputRadioButtonExtensions type exposes the following members.

Methods

Name | Description
AssertCheck | Assert methods for the HtmlInputRadioButton control.

See Also

HtmlInputRadioButtonExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRadioButtonExtensions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButtonExtensions Methods
HtmlInputRadioButtonExtensions Class See Also Send Feedback

The HtmlInputRadioButtonExtensions type exposes the following members.

Methods

Name | Description
AssertCheck | Assert methods for the HtmlInputRadioButton control.

See Also

HtmlInputRadioButtonExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertCheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRadioButtonExtensions..::..AssertCheck Method
HtmlInputRadioButtonExtensions Class See Also Send Feedback
Assert methods for the HtmlInputRadioButton control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertCheck AssertCheck(
    this HtmlInputRadioButton control
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertCheck ( _
    control As HtmlInputRadioButton _
) As AssertCheck
Visual C++
[ExtensionAttribute]
public:
static AssertCheck^ AssertCheck(
    HtmlInputRadioButton^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlInputRadioButton
The HtmlInputRadioButton to wrap.

Return Value

A HtmlInputRadioButton wrapped in a AssertCheck object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlInputRadioButton. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlInputRadioButtonExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRange Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange Members
HtmlInputRange Class Constructors Methods Properties See Also Send Feedback

The HtmlInputRange type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputRange()()()() | Create a new control.
Public method | HtmlInputRange(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | StepDown | (Inherited from HtmlInputNumber.)
Public method | StepUp | (Inherited from HtmlInputNumber.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Max | (Inherited from HtmlInputNumber.)
Public property | Min | (Inherited from HtmlInputNumber.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Step | (Inherited from HtmlInputNumber.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputNumber..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | ValueAsNumber | (Inherited from HtmlInputNumber.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRange Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange Constructor
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputRange()()()() | Create a new control.
Public method | HtmlInputRange(Element) | Create a new control.

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRange Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange Constructor
HtmlInputRange Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputRange()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputRange()

See Also

HtmlInputRange Class
HtmlInputRange Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRange Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange Constructor (Element)
HtmlInputRange Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputRange(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputRange(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputRange Class
HtmlInputRange Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRange Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange Methods
HtmlInputRange Class See Also Send Feedback

The HtmlInputRange type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | StepDown | (Inherited from HtmlInputNumber.)
Public method | StepUp | (Inherited from HtmlInputNumber.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputRange Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..CallMethod Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..Capture Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..Click Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..DragTo Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..GetValue Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..InvokeEvent Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..MouseClick Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..MouseHover Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..ScrollToVisible Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..SetValue Method
HtmlInputRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
HtmlInputRange Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputRange Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange Properties
HtmlInputRange Class See Also Send Feedback

The HtmlInputRange type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Max | (Inherited from HtmlInputNumber.)
Public property | Min | (Inherited from HtmlInputNumber.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Step | (Inherited from HtmlInputNumber.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputNumber..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | ValueAsNumber | (Inherited from HtmlInputNumber.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputRange Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidationType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputRange..::..ValidationType Property
HtmlInputRange Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputRange.ValidationType"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override InputElementType ValidationType { get; }
Visual Basic
Protected Overrides ReadOnly Property ValidationType As InputElementType
    Get
Visual C++
protected:
virtual property InputElementType ValidationType {
    InputElementType get () override;
}

See Also

HtmlInputRange Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputReset Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset Members
HtmlInputReset Class Constructors Methods Properties See Also Send Feedback

The HtmlInputReset type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputReset()()()() | Create a new control.
Public method | HtmlInputReset(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputReset Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset Constructor
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputReset()()()() | Create a new control.
Public method | HtmlInputReset(Element) | Create a new control.

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputReset Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset Constructor
HtmlInputReset Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputReset()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputReset()

See Also

HtmlInputReset Class
HtmlInputReset Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputReset Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset Constructor (Element)
HtmlInputReset Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputReset(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputReset(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputReset Class
HtmlInputReset Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputReset Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset Methods
HtmlInputReset Class See Also Send Feedback

The HtmlInputReset type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputReset Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..AssignElement Method
HtmlInputReset Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputReset Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..CallMethod Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..Capture Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..Click Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..DragTo Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..GetValue Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..InvokeEvent Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..MouseClick Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..MouseHover Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..ScrollToVisible Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset..::..SetValue Method
HtmlInputReset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
HtmlInputReset Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputReset Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputReset Properties
HtmlInputReset Class See Also Send Feedback

The HtmlInputReset type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputReset Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSearch Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch Members
HtmlInputSearch Class Constructors Methods Properties See Also Send Feedback

The HtmlInputSearch type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputSearch()()()() | Create a new control.
Public method | HtmlInputSearch(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputText..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSearch Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch Constructor
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputSearch()()()() | Create a new control.
Public method | HtmlInputSearch(Element) | Create a new control.

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSearch Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch Constructor
HtmlInputSearch Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputSearch()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputSearch()

See Also

HtmlInputSearch Class
HtmlInputSearch Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSearch Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch Constructor (Element)
HtmlInputSearch Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputSearch(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputSearch(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputSearch Class
HtmlInputSearch Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSearch Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch Methods
HtmlInputSearch Class See Also Send Feedback

The HtmlInputSearch type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputSearch Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..CallMethod Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..Capture Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..Click Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..DragTo Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..GetValue Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..InvokeEvent Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..MouseClick Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..MouseHover Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..ScrollToVisible Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..SetValue Method
HtmlInputSearch Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
HtmlInputSearch Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSearch Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch Properties
HtmlInputSearch Class See Also Send Feedback

The HtmlInputSearch type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputText..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputSearch Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidationType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSearch..::..ValidationType Property
HtmlInputSearch Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputSearch.ValidationType"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override InputElementType ValidationType { get; }
Visual Basic
Protected Overrides ReadOnly Property ValidationType As InputElementType
    Get
Visual C++
protected:
virtual property InputElementType ValidationType {
    InputElementType get () override;
}

See Also

HtmlInputSearch Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSubmit Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit Members
HtmlInputSubmit Class Constructors Methods Properties See Also Send Feedback

The HtmlInputSubmit type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputSubmit()()()() | Create a new control.
Public method | HtmlInputSubmit(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSubmit Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit Constructor
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputSubmit()()()() | Create a new control.
Public method | HtmlInputSubmit(Element) | Create a new control.

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSubmit Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit Constructor
HtmlInputSubmit Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputSubmit()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputSubmit()

See Also

HtmlInputSubmit Class
HtmlInputSubmit Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSubmit Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit Constructor (Element)
HtmlInputSubmit Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputSubmit(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputSubmit(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputSubmit Class
HtmlInputSubmit Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSubmit Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit Methods
HtmlInputSubmit Class See Also Send Feedback

The HtmlInputSubmit type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputSubmit Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..AssignElement Method
HtmlInputSubmit Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputSubmit Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..CallMethod Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..Capture Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..Click Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..DragTo Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..GetValue Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..InvokeEvent Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..MouseClick Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..MouseHover Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..ScrollToVisible Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit..::..SetValue Method
HtmlInputSubmit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
HtmlInputSubmit Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputSubmit Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputSubmit Properties
HtmlInputSubmit Class See Also Send Feedback

The HtmlInputSubmit type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputSubmit Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputText Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText Members
HtmlInputText Class Constructors Methods Properties See Also Send Feedback

The HtmlInputText type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputText()()()() | Create a new control.
Public method | HtmlInputText(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters).
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType |
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputText Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText Constructor
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputText()()()() | Create a new control.
Public method | HtmlInputText(Element) | Create a new control.

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputText Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText Constructor
HtmlInputText Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputText()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputText()

See Also

HtmlInputText Class
HtmlInputText Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputText Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText Constructor (Element)
HtmlInputText Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputText(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputText(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputText Class
HtmlInputText Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputText Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText Methods
HtmlInputText Class See Also Send Feedback

The HtmlInputText type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlInputControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..AssignElement Method
HtmlInputText Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..CallMethod Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..Capture Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..Click Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..DragTo Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..GetValue Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..InvokeEvent Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..MouseClick Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..MouseHover Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..ScrollToVisible Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..SetValue Method
HtmlInputText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputText Class
HtmlInputText Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputText Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText Properties
HtmlInputText Class See Also Send Feedback

The HtmlInputText type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters).
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType |
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Disabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..Disabled Property
HtmlInputText Class See Also Send Feedback
Gets whether or not a text field is disabled

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Disabled { get; }
Visual Basic
Public ReadOnly Property Disabled As Boolean
    Get
Visual C++
public:
property bool Disabled {
    bool get ();
}

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Size Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..Size Property
HtmlInputText Class See Also Send Feedback
Gets the size of a text field (in number of characters).

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get
Visual C++
public:
property int Size {
    int get ();
}

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


TabIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..TabIndex Property
HtmlInputText Class See Also Send Feedback
Gets the tab order for a text field.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TabIndex { get; }
Visual Basic
Public ReadOnly Property TabIndex As Integer
    Get
Visual C++
public:
property int TabIndex {
    int get ();
}

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..Text Property
HtmlInputText Class See Also Send Feedback
Gets/Sets the value of the value attribute of a text field

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidationType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputText..::..ValidationType Property
HtmlInputText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputText.ValidationType"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual InputElementType ValidationType { get; }
Visual Basic
Protected Overridable ReadOnly Property ValidationType As InputElementType
    Get
Visual C++
protected:
virtual property InputElementType ValidationType {
    InputElementType get ();
}

See Also

HtmlInputText Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputUrl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl Members
HtmlInputUrl Class Constructors Methods Properties See Also Send Feedback

The HtmlInputUrl type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlInputUrl()()()() | Create a new control.
Public method | HtmlInputUrl(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputText..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputUrl Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl Constructor
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlInputUrl()()()() | Create a new control.
Public method | HtmlInputUrl(Element) | Create a new control.

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputUrl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl Constructor
HtmlInputUrl Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputUrl()
Visual Basic
Public Sub New
Visual C++
public:
HtmlInputUrl()

See Also

HtmlInputUrl Class
HtmlInputUrl Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputUrl Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl Constructor (Element)
HtmlInputUrl Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlInputUrl(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlInputUrl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlInputUrl Class
HtmlInputUrl Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputUrl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl Methods
HtmlInputUrl Class See Also Send Feedback

The HtmlInputUrl type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlInputText.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Protected method | ValidateType | Validates the type of the input control. (Inherited from HtmlInputControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlInputUrl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..CallMethod Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..Capture Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..Click Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..DragTo Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..GetValue Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..InvokeEvent Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..MouseClick Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..MouseHover Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..ScrollToVisible Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..SetValue Method
HtmlInputUrl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
HtmlInputUrl Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlInputUrl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl Properties
HtmlInputUrl Class See Also Send Feedback

The HtmlInputUrl type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autofocus | Gets whether this element is the autofocus input for the form containing it (Inherited from HtmlInputControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Gets whether or not a text field is disabled (Inherited from HtmlInputText.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name attribute for control (Inherited from HtmlInputControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Placeholder | Gets the placeholder text for the control (Inherited from HtmlInputControl.)
Public property | Required | Gets whether this input must be filled in for the form to validate (Inherited from HtmlInputControl.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Size | Gets the size of a text field (in number of characters). (Inherited from HtmlInputText.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Gets the tab order for a text field. (Inherited from HtmlInputText.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the value of the value attribute of a text field (Inherited from HtmlInputText.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type | Input control type (Inherited from HtmlInputControl.)
Protected property | ValidationType | (Overrides HtmlInputText..::..ValidationType.)
Public property | Value | Gets or sets the value attribute for control (Inherited from HtmlInputControl.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlInputUrl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ValidationType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlInputUrl..::..ValidationType Property
HtmlInputUrl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlInputUrl.ValidationType"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override InputElementType ValidationType { get; }
Visual Basic
Protected Overrides ReadOnly Property ValidationType As InputElementType
    Get
Visual C++
protected:
virtual property InputElementType ValidationType {
    InputElementType get () override;
}

See Also

HtmlInputUrl Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlListItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem Members
HtmlListItem Class Constructors Methods Properties See Also Send Feedback

The HtmlListItem type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlListItem()()()() | Create a new control.
Public method | HtmlListItem(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlListItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem Constructor
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlListItem()()()() | Create a new control.
Public method | HtmlListItem(Element) | Create a new test control

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlListItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem Constructor
HtmlListItem Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlListItem()
Visual Basic
Public Sub New
Visual C++
public:
HtmlListItem()

See Also

HtmlListItem Class
HtmlListItem Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlListItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem Constructor (Element)
HtmlListItem Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlListItem(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlListItem(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlListItem Class
HtmlListItem Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlListItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem Methods
HtmlListItem Class See Also Send Feedback

The HtmlListItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlListItem Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..AssignElement Method
HtmlListItem Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlListItem Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..CallMethod Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..Capture Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..Click Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..DragTo Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetItemOrder Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..GetItemOrder Method
HtmlListItem Class See Also Send Feedback
Gets this item's order in its parent list. 0 based ordering

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int GetItemOrder()
Visual Basic
Public Function GetItemOrder As Integer
Visual C++
public:
int GetItemOrder()

Return Value

The order of this list item. 0 based

See Also

HtmlListItem Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..GetValue Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..InvokeEvent Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..MouseClick Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..MouseHover Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..ScrollToVisible Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem..::..SetValue Method
HtmlListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlListItem Class
HtmlListItem Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlListItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlListItem Properties
HtmlListItem Class See Also Send Feedback

The HtmlListItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlListItem Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlMeter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter Members
HtmlMeter Class Constructors Methods Properties See Also Send Feedback

The HtmlMeter type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlMeter()()()() | Create a new control.
Public method | HtmlMeter(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | High |
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Low |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Max |
Public property | Min |
Public property | Optimum |
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlMeter Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter Constructor
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlMeter()()()() | Create a new control.
Public method | HtmlMeter(Element) | Create a new test control

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlMeter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter Constructor
HtmlMeter Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlMeter()
Visual Basic
Public Sub New
Visual C++
public:
HtmlMeter()

See Also

HtmlMeter Class
HtmlMeter Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlMeter Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter Constructor (Element)
HtmlMeter Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlMeter(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlMeter(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlMeter Class
HtmlMeter Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlMeter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter Methods
HtmlMeter Class See Also Send Feedback

The HtmlMeter type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..AssignElement Method
HtmlMeter Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..CallMethod Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..Capture Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..Click Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..DragTo Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..GetValue Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..InvokeEvent Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..MouseClick Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..MouseHover Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..ScrollToVisible Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..SetValue Method
HtmlMeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlMeter Class
HtmlMeter Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlMeter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter Properties
HtmlMeter Class See Also Send Feedback

The HtmlMeter type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | High |
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Low |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Max |
Public property | Min |
Public property | Optimum |
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


High Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..High Property
HtmlMeter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlMeter.High"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double High { get; set; }
Visual Basic
Public Property High As Double
    Get
    Set
Visual C++
public:
property double High {
    double get ();
    void set (double value);
}

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Low Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..Low Property
HtmlMeter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlMeter.Low"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Low { get; set; }
Visual Basic
Public Property Low As Double
    Get
    Set
Visual C++
public:
property double Low {
    double get ();
    void set (double value);
}

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Max Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..Max Property
HtmlMeter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlMeter.Max"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Max { get; set; }
Visual Basic
Public Property Max As Double
    Get
    Set
Visual C++
public:
property double Max {
    double get ();
    void set (double value);
}

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Min Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..Min Property
HtmlMeter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlMeter.Min"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Min { get; set; }
Visual Basic
Public Property Min As Double
    Get
    Set
Visual C++
public:
property double Min {
    double get ();
    void set (double value);
}

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Optimum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..Optimum Property
HtmlMeter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlMeter.Optimum"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Optimum { get; set; }
Visual Basic
Public Property Optimum As Double
    Get
    Set
Visual C++
public:
property double Optimum {
    double get ();
    void set (double value);
}

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlMeter..::..Value Property
HtmlMeter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlMeter.Value"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Value { get; set; }
Visual Basic
Public Property Value As Double
    Get
    Set
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

HtmlMeter Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOption Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption Members
HtmlOption Class Constructors Methods Properties See Also Send Feedback

The HtmlOption type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlOption()()()() | Create a new control.
Public method | HtmlOption(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Gets or sets this options selection.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Return the Text that is set for this option.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Gets the value that is set for this option.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlOption Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOption Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption Constructor
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlOption()()()() | Create a new control.
Public method | HtmlOption(Element) | Create a new control.

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOption Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption Constructor
HtmlOption Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlOption()
Visual Basic
Public Sub New
Visual C++
public:
HtmlOption()

See Also

HtmlOption Class
HtmlOption Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOption Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption Constructor (Element)
HtmlOption Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlOption(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlOption(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlOption Class
HtmlOption Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOption Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption Methods
HtmlOption Class See Also Send Feedback

The HtmlOption type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlOption Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..AssignElement Method
HtmlOption Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlOption Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..CallMethod Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..Capture Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..Click Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..DragTo Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..GetValue Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..InvokeEvent Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..MouseClick Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..MouseHover Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..ScrollToVisible Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..SetValue Method
HtmlOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlOption Class
HtmlOption Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOption Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption Properties
HtmlOption Class See Also Send Feedback

The HtmlOption type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Gets or sets this options selection.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Return the Text that is set for this option.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Gets the value that is set for this option.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlOption Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Selected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..Selected Property
HtmlOption Class See Also Send Feedback
Gets or sets this options selection.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Selected { get; set; }
Visual Basic
Public Property Selected As Boolean
    Get
    Set
Visual C++
public:
property bool Selected {
    bool get ();
    void set (bool value);
}

See Also

HtmlOption Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..Text Property
HtmlOption Class See Also Send Feedback
Return the Text that is set for this option.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

HtmlOption Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOption..::..Value Property
HtmlOption Class See Also Send Feedback
Gets the value that is set for this option.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

HtmlOption Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOrderedList Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList Members
HtmlOrderedList Class Constructors Methods Properties See Also Send Feedback

The HtmlOrderedList type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlOrderedList()()()() | Create a new control.
Public method | HtmlOrderedList(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllItems | Gets the all child list items. - Recursive
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Gets the direct child list items. - Not Recursive
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOrderedList Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList Constructor
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlOrderedList()()()() | Create a new control.
Public method | HtmlOrderedList(Element) | Create a new test control

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOrderedList Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList Constructor
HtmlOrderedList Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlOrderedList()
Visual Basic
Public Sub New
Visual C++
public:
HtmlOrderedList()

See Also

HtmlOrderedList Class
HtmlOrderedList Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOrderedList Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList Constructor (Element)
HtmlOrderedList Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlOrderedList(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlOrderedList(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlOrderedList Class
HtmlOrderedList Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOrderedList Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList Methods
HtmlOrderedList Class See Also Send Feedback

The HtmlOrderedList type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlOrderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..AssignElement Method
HtmlOrderedList Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlOrderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..CallMethod Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..Capture Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..Click Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..DragTo Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..GetValue Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..InvokeEvent Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..MouseClick Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..MouseHover Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..ScrollToVisible Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..SetValue Method
HtmlOrderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
HtmlOrderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlOrderedList Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList Properties
HtmlOrderedList Class See Also Send Feedback

The HtmlOrderedList type exposes the following members.

Properties

 | Name | Description
Public property | AllItems | Gets the all child list items. - Recursive
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Gets the direct child list items. - Not Recursive
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlOrderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AllItems Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..AllItems Property
HtmlOrderedList Class See Also Send Feedback
Gets the all child list items. - Recursive

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlListItem[] AllItems { get; }
Visual Basic
Public ReadOnly Property AllItems As HtmlListItem()
    Get
Visual C++
public:
property array<HtmlListItem^>^ AllItems {
    array<HtmlListItem^>^ get ();
}

See Also

HtmlOrderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlOrderedList..::..Items Property
HtmlOrderedList Class See Also Send Feedback
Gets the direct child list items. - Not Recursive

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlListItem[] Items { get; }
Visual Basic
Public ReadOnly Property Items As HtmlListItem()
    Get
Visual C++
public:
property array<HtmlListItem^>^ Items {
    array<HtmlListItem^>^ get ();
}

See Also

HtmlOrderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlProgress Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress Members
HtmlProgress Class Constructors Methods Properties See Also Send Feedback

The HtmlProgress type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlProgress()()()() | Create a new control.
Public method | HtmlProgress(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Max |
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Position |
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlProgress Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress Constructor
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlProgress()()()() | Create a new control.
Public method | HtmlProgress(Element) | Create a new test control

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlProgress Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress Constructor
HtmlProgress Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlProgress()
Visual Basic
Public Sub New
Visual C++
public:
HtmlProgress()

See Also

HtmlProgress Class
HtmlProgress Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlProgress Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress Constructor (Element)
HtmlProgress Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlProgress(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlProgress(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlProgress Class
HtmlProgress Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlProgress Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress Methods
HtmlProgress Class See Also Send Feedback

The HtmlProgress type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlProgress Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..AssignElement Method
HtmlProgress Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlProgress Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..CallMethod Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..Capture Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..Click Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..DragTo Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..GetValue Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..InvokeEvent Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..MouseClick Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..MouseHover Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..ScrollToVisible Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..SetValue Method
HtmlProgress Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlProgress Class
HtmlProgress Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlProgress Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress Properties
HtmlProgress Class See Also Send Feedback

The HtmlProgress type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Max |
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Position |
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlProgress Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Max Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..Max Property
HtmlProgress Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlProgress.Max"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Max { get; set; }
Visual Basic
Public Property Max As Double
    Get
    Set
Visual C++
public:
property double Max {
    double get ();
    void set (double value);
}

See Also

HtmlProgress Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Position Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..Position Property
HtmlProgress Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlProgress.Position"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Position { get; }
Visual Basic
Public ReadOnly Property Position As Double
    Get
Visual C++
public:
property double Position {
    double get ();
}

See Also

HtmlProgress Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlProgress..::..Value Property
HtmlProgress Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlProgress.Value"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Value { get; set; }
Visual Basic
Public Property Value As Double
    Get
    Set
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

HtmlProgress Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSelect Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect Members
HtmlSelect Class Constructors Methods Properties See Also Send Feedback

The HtmlSelect type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlSelect()()()() | Create a new control.
Public method | HtmlSelect(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Protected method | InvokeOnChange |
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MultiSelect | Multi select a set of options on the select drop down. You can also set the .Selected value on any HtmlOption.
Public method | MultiSelectByIndex | Multi select a set of options by passing in the indexes of these options.
Public method | MultiSelectByText | Multi select a set of options by passing in the text of these options.
Public method | MultiSelectByValue | Mutli select a set of options by passing in the values of these options to select.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectByIndex(Int32) | Select a option by index.
Public method | SelectByIndex(Int32, Boolean) | Select ption by Index.
Public method | SelectByPartialText | Select an option by partial text.
Public method | SelectByPartialValue | Select an option by partial value.
Public method | SelectByText(String) | Select a option by text.
Public method | SelectByText(String, Boolean) | Select Option by Text.
Public method | SelectByValue(String) | Select Option by Value.
Public method | SelectByValue(String, Boolean) | Select Option by Value.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertSelect()()()() | Overloaded. Assert methods for the HtmlSelect content. (Defined by HtmlSelectAssertExtensions.)
Public Extension Method | AssertSelect(Boolean) | Overloaded. Assert methods for the HtmlSelect content. (Defined by HtmlSelectAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Gets Html Option by its index.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Options | Gets the List of Options.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets the selected index.
Public property | SelectedOption | Gets the HtmlOption that is currently selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSelect Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect Constructor
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlSelect()()()() | Create a new control.
Public method | HtmlSelect(Element) | Create a new control.

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSelect Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect Constructor
HtmlSelect Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlSelect()
Visual Basic
Public Sub New
Visual C++
public:
HtmlSelect()

See Also

HtmlSelect Class
HtmlSelect Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSelect Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect Constructor (Element)
HtmlSelect Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlSelect(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlSelect(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlSelect Class
HtmlSelect Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSelect Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect Methods
HtmlSelect Class See Also Send Feedback

The HtmlSelect type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Protected method | InvokeOnChange |
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MultiSelect | Multi select a set of options on the select drop down. You can also set the .Selected value on any HtmlOption.
Public method | MultiSelectByIndex | Multi select a set of options by passing in the indexes of these options.
Public method | MultiSelectByText | Multi select a set of options by passing in the text of these options.
Public method | MultiSelectByValue | Mutli select a set of options by passing in the values of these options to select.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectByIndex(Int32) | Select a option by index.
Public method | SelectByIndex(Int32, Boolean) | Select ption by Index.
Public method | SelectByPartialText | Select an option by partial text.
Public method | SelectByPartialValue | Select an option by partial value.
Public method | SelectByText(String) | Select a option by text.
Public method | SelectByText(String, Boolean) | Select Option by Text.
Public method | SelectByValue(String) | Select Option by Value.
Public method | SelectByValue(String, Boolean) | Select Option by Value.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertSelect()()()() | Overloaded. Assert methods for the HtmlSelect content. (Defined by HtmlSelectAssertExtensions.)
Public Extension Method | AssertSelect(Boolean) | Overloaded. Assert methods for the HtmlSelect content. (Defined by HtmlSelectAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..AssignElement Method
HtmlSelect Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..CallMethod Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..Capture Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..Click Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..DragTo Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..GetValue Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..InvokeEvent Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeOnChange Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..InvokeOnChange Method
HtmlSelect Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlSelect.InvokeOnChange"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void InvokeOnChange()
Visual Basic
Protected Overridable Sub InvokeOnChange
Visual C++
protected:
virtual void InvokeOnChange()

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..MouseClick Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..MouseHover Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MultiSelect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..MultiSelect Method
HtmlSelect Class See Also Send Feedback
Multi select a set of options on the select drop down. You can also set the .Selected value on any HtmlOption.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void MultiSelect(
    params HtmlOption[] options
)
Visual Basic
Public Sub MultiSelect ( _
    ParamArray options As HtmlOption() _
)
Visual C++
public:
void MultiSelect(
    ... array<HtmlOption^>^ options
)

Parameters

options
Type: array< ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlOption >[]()[][]
The list of options to select. These can be accessed fro the Options[] collection.

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MultiSelectByIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..MultiSelectByIndex Method
HtmlSelect Class See Also Send Feedback
Multi select a set of options by passing in the indexes of these options.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void MultiSelectByIndex(
    params int[] indexes
)
Visual Basic
Public Sub MultiSelectByIndex ( _
    ParamArray indexes As Integer() _
)
Visual C++
public:
void MultiSelectByIndex(
    ... array<int>^ indexes
)

Parameters

indexes
Type: array< System..::..Int32 >[]()[][]
The indexes to select

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MultiSelectByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..MultiSelectByText Method
HtmlSelect Class See Also Send Feedback
Multi select a set of options by passing in the text of these options.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void MultiSelectByText(
    params string[] textStrings
)
Visual Basic
Public Sub MultiSelectByText ( _
    ParamArray textStrings As String() _
)
Visual C++
public:
void MultiSelectByText(
    ... array<String^>^ textStrings
)

Parameters

textStrings
Type: array< System..::..String >[]()[][]
The array of strings option texts to select.

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MultiSelectByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..MultiSelectByValue Method
HtmlSelect Class See Also Send Feedback
Mutli select a set of options by passing in the values of these options to select.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void MultiSelectByValue(
    params string[] values
)
Visual Basic
Public Sub MultiSelectByValue ( _
    ParamArray values As String() _
)
Visual C++
public:
void MultiSelectByValue(
    ... array<String^>^ values
)

Parameters

values
Type: array< System..::..String >[]()[][]
The arrary of value of options to select.

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..ScrollToVisible Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByIndex Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectByIndex(Int32) | Select a option by index.
Public method | SelectByIndex(Int32, Boolean) | Select ption by Index.

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByIndex Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByIndex Method (Int32)
HtmlSelect Class See Also Send Feedback
Select a option by index.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectByIndex(
    int index
)
Visual Basic
Public Sub SelectByIndex ( _
    index As Integer _
)
Visual C++
public:
void SelectByIndex(
    int index
)

Parameters

index
Type: System..::..Int32
Index to select.

See Also

HtmlSelect Class
SelectByIndex Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByIndex Method (Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByIndex Method (Int32, Boolean)
HtmlSelect Class See Also Send Feedback
Select ption by Index.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectByIndex(
    int index,
    bool invokeOnChangeEvent
)
Visual Basic
Public Sub SelectByIndex ( _
    index As Integer, _
    invokeOnChangeEvent As Boolean _
)
Visual C++
public:
void SelectByIndex(
    int index,
    bool invokeOnChangeEvent
)

Parameters

index
Type: System..::..Int32
Index to select.
invokeOnChangeEvent
Type: System..::..Boolean
Whether to invoke the OnChange event.

See Also

HtmlSelect Class
SelectByIndex Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByPartialText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByPartialText Method
HtmlSelect Class See Also Send Feedback
Select an option by partial text.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectByPartialText(
    string partialText,
    bool invokeOnChangeEvent
)
Visual Basic
Public Sub SelectByPartialText ( _
    partialText As String, _
    invokeOnChangeEvent As Boolean _
)
Visual C++
public:
void SelectByPartialText(
    String^ partialText,
    bool invokeOnChangeEvent
)

Parameters

partialText
Type: System..::..String
The partial text to look for.
invokeOnChangeEvent
Type: System..::..Boolean
Whether to invoke the onchange event.

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown when an option containing the partial text was not found.

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByPartialValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByPartialValue Method
HtmlSelect Class See Also Send Feedback
Select an option by partial value.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectByPartialValue(
    string partialValue,
    bool invokeOnChangeEvent
)
Visual Basic
Public Sub SelectByPartialValue ( _
    partialValue As String, _
    invokeOnChangeEvent As Boolean _
)
Visual C++
public:
void SelectByPartialValue(
    String^ partialValue,
    bool invokeOnChangeEvent
)

Parameters

partialValue
Type: System..::..String
The partial text to look for.
invokeOnChangeEvent
Type: System..::..Boolean
Whether to invoke the onchange event.

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown when an option containing the partial value was not found.

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByText Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectByText(String) | Select a option by text.
Public method | SelectByText(String, Boolean) | Select Option by Text.

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByText Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByText Method (String)
HtmlSelect Class See Also Send Feedback
Select a option by text.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectByText(
    string text
)
Visual Basic
Public Sub SelectByText ( _
    text As String _
)
Visual C++
public:
void SelectByText(
    String^ text
)

Parameters

text
Type: System..::..String
Text of the option to select.

See Also

HtmlSelect Class
SelectByText Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByText Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByText Method (String, Boolean)
HtmlSelect Class See Also Send Feedback
Select Option by Text.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectByText(
    string text,
    bool invokeOnChangeEvent
)
Visual Basic
Public Sub SelectByText ( _
    text As String, _
    invokeOnChangeEvent As Boolean _
)
Visual C++
public:
void SelectByText(
    String^ text,
    bool invokeOnChangeEvent
)

Parameters

text
Type: System..::..String
Text of the option to select.
invokeOnChangeEvent
Type: System..::..Boolean
Whether to invoke the OnChange event.

See Also

HtmlSelect Class
SelectByText Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByValue Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectByValue(String) | Select Option by Value.
Public method | SelectByValue(String, Boolean) | Select Option by Value.

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByValue Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByValue Method (String)
HtmlSelect Class See Also Send Feedback
Select Option by Value.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectByValue(
    string value
)
Visual Basic
Public Sub SelectByValue ( _
    value As String _
)
Visual C++
public:
void SelectByValue(
    String^ value
)

Parameters

value
Type: System..::..String
Value of option to select.

See Also

HtmlSelect Class
SelectByValue Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectByValue Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectByValue Method (String, Boolean)
HtmlSelect Class See Also Send Feedback
Select Option by Value.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectByValue(
    string value,
    bool invokeOnChangeEvent
)
Visual Basic
Public Sub SelectByValue ( _
    value As String, _
    invokeOnChangeEvent As Boolean _
)
Visual C++
public:
void SelectByValue(
    String^ value,
    bool invokeOnChangeEvent
)

Parameters

value
Type: System..::..String
Value of option to select.
invokeOnChangeEvent
Type: System..::..Boolean
Whether to invoke the onchange event.

See Also

HtmlSelect Class
SelectByValue Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SetValue Method
HtmlSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlSelect Class
HtmlSelect Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSelect Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect Properties
HtmlSelect Class See Also Send Feedback

The HtmlSelect type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Gets Html Option by its index.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Options | Gets the List of Options.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets the selected index.
Public property | SelectedOption | Gets the HtmlOption that is currently selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..Item Property
HtmlSelect Class See Also Send Feedback
Gets Html Option by its index.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlOption this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As HtmlOption
    Get
Visual C++
public:
property HtmlOption^ default[int index] {
    HtmlOption^ get (int index);
}

Parameters

index
Type: System..::..Int32
The desired index.

Return Value

The html option.

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Options Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..Options Property
HtmlSelect Class See Also Send Feedback
Gets the List of Options.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<HtmlOption> Options { get; }
Visual Basic
Public ReadOnly Property Options As ReadOnlyCollection(Of HtmlOption)
    Get
Visual C++
public:
property ReadOnlyCollection<HtmlOption^>^ Options {
    ReadOnlyCollection<HtmlOption^>^ get ();
}

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectedIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectedIndex Property
HtmlSelect Class See Also Send Feedback
Gets the selected index.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SelectedIndex { get; }
Visual Basic
Public ReadOnly Property SelectedIndex As Integer
    Get
Visual C++
public:
property int SelectedIndex {
    int get ();
}

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SelectedOption Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelect..::..SelectedOption Property
HtmlSelect Class See Also Send Feedback
Gets the HtmlOption that is currently selected.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlOption SelectedOption { get; }
Visual Basic
Public ReadOnly Property SelectedOption As HtmlOption
    Get
Visual C++
public:
property HtmlOption^ SelectedOption {
    HtmlOption^ get ();
}

See Also

HtmlSelect Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSelectAssertExtensions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelectAssertExtensions Members
HtmlSelectAssertExtensions Class Methods See Also Send Feedback

Methods

Name | Description
AssertSelect(HtmlSelect) | Assert methods for the HtmlSelect content.
AssertSelect(HtmlSelect, Boolean) | Assert methods for the HtmlSelect content.

See Also

HtmlSelectAssertExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSelectAssertExtensions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelectAssertExtensions Methods
HtmlSelectAssertExtensions Class See Also Send Feedback

Methods

Name | Description
AssertSelect(HtmlSelect) | Assert methods for the HtmlSelect content.
AssertSelect(HtmlSelect, Boolean) | Assert methods for the HtmlSelect content.

See Also

HtmlSelectAssertExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertSelect Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelectAssertExtensions..::..AssertSelect Method
HtmlSelectAssertExtensions Class See Also Send Feedback

Overload List

Name | Description
AssertSelect(HtmlSelect) | Assert methods for the HtmlSelect content.
AssertSelect(HtmlSelect, Boolean) | Assert methods for the HtmlSelect content.

See Also

HtmlSelectAssertExtensions Class
HtmlSelectAssertExtensions Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertSelect Method (HtmlSelect)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelectAssertExtensions..::..AssertSelect Method (HtmlSelect)
HtmlSelectAssertExtensions Class See Also Send Feedback
Assert methods for the HtmlSelect content.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertSelect AssertSelect(
    this HtmlSelect control
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertSelect ( _
    control As HtmlSelect _
) As AssertSelect
Visual C++
[ExtensionAttribute]
public:
static AssertSelect^ AssertSelect(
    HtmlSelect^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlSelect
The HtmlSelect to wrap.

Return Value

A HtmlSelect wrapped in a AssertCheck object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlSelect. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlSelectAssertExtensions Class
AssertSelect Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertSelect Method (HtmlSelect, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSelectAssertExtensions..::..AssertSelect Method (HtmlSelect, Boolean)
HtmlSelectAssertExtensions Class See Also Send Feedback
Assert methods for the HtmlSelect content.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertSelect AssertSelect(
    this HtmlSelect control,
    bool throwOnFailure
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertSelect ( _
    control As HtmlSelect, _
    throwOnFailure As Boolean _
) As AssertSelect
Visual C++
[ExtensionAttribute]
public:
static AssertSelect^ AssertSelect(
    HtmlSelect^ control,
    bool throwOnFailure
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlSelect
The HtmlSelect to wrap.
throwOnFailure
Type: System..::..Boolean
Whether this object should throw an exception if checks fail

Return Value

A HtmlSelect wrapped in a AssertCheck object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlSelect. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlSelectAssertExtensions Class
AssertSelect Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSource Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource Members
HtmlSource Class Constructors Methods Properties See Also Send Feedback

The HtmlSource type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlSource()()()() | Initializes a new instance of the HtmlSource class
Public method | HtmlSource(Element) | Initializes a new instance of the HtmlSource class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Src |
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlSource Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSource Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource Constructor
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlSource()()()() | Initializes a new instance of the HtmlSource class
Public method | HtmlSource(Element) | Initializes a new instance of the HtmlSource class

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSource Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource Constructor
HtmlSource Class See Also Send Feedback
Initializes a new instance of the HtmlSource class

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlSource()
Visual Basic
Public Sub New
Visual C++
public:
HtmlSource()

See Also

HtmlSource Class
HtmlSource Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSource Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource Constructor (Element)
HtmlSource Class See Also Send Feedback
Initializes a new instance of the HtmlSource class

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlSource(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlSource(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlSource.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

HtmlSource Class
HtmlSource Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSource Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource Methods
HtmlSource Class See Also Send Feedback

The HtmlSource type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlSource Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..AssignElement Method
HtmlSource Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlSource Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..CallMethod Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..Capture Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..Click Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..DragTo Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..GetValue Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..InvokeEvent Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..MouseClick Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..MouseHover Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..ScrollToVisible Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..SetValue Method
HtmlSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlSource Class
HtmlSource Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSource Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource Properties
HtmlSource Class See Also Send Feedback

The HtmlSource type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Src |
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Type |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlSource Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Src Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..Src Property
HtmlSource Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlSource.Src"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Src { get; set; }
Visual Basic
Public Property Src As String
    Get
    Set
Visual C++
public:
property String^ Src {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlSource Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSource..::..Type Property
HtmlSource Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlSource.Type"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlSource Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSpan Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan Members
HtmlSpan Class Constructors Methods Properties See Also Send Feedback

The HtmlSpan type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlSpan()()()() | Create a new control.
Public method | HtmlSpan(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSpan Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan Constructor
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlSpan()()()() | Create a new control.
Public method | HtmlSpan(Element) | Create a new control.

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSpan Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan Constructor
HtmlSpan Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlSpan()
Visual Basic
Public Sub New
Visual C++
public:
HtmlSpan()

See Also

HtmlSpan Class
HtmlSpan Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSpan Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan Constructor (Element)
HtmlSpan Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlSpan(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlSpan(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlSpan Class
HtmlSpan Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSpan Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan Methods
HtmlSpan Class See Also Send Feedback

The HtmlSpan type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlSpan Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..AssignElement Method
HtmlSpan Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlSpan Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..CallMethod Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..Capture Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..Click Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..DragTo Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..GetValue Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..InvokeEvent Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..MouseClick Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..MouseHover Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..ScrollToVisible Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan..::..SetValue Method
HtmlSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlSpan Class
HtmlSpan Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlSpan Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlSpan Properties
HtmlSpan Class See Also Send Feedback

The HtmlSpan type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlSpan Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlStyle Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle Members
HtmlStyle Class Constructors Methods Properties See Also Send Feedback

The HtmlStyle type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlStyle | Create a new HtmlStyle object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsColor | Whether the value of this style is a color value or not.
Public method | IsInt | Whether the value of this style is an integer value or not.
 | IsSameColor | Performs a simple color compare that only compares red/green/blue colors. Does not compare known color names or alpha blending.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToColor | Attempts to parse the style value as a color and return a System.Drawing.Color object that corresponds to the color style value.
 | ToHtmlColor | Translates a System.Drawing.Color to an Html color string.
Public method | ToInt | Strips any style value from units (i.e. px/pt..etc) and returns the integer value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets the style name.
Public property | Value | Gets the style value.

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlStyle Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle Constructor
HtmlStyle Class See Also Send Feedback
Create a new HtmlStyle object.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlStyle(
    string name,
    string value
)
Visual Basic
Public Sub New ( _
    name As String, _
    value As String _
)
Visual C++
public:
HtmlStyle(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The name of the style.
value
Type: System..::..String
The raw value of this style.

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlStyle Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle Methods
HtmlStyle Class See Also Send Feedback

The HtmlStyle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsColor | Whether the value of this style is a color value or not.
Public method | IsInt | Whether the value of this style is an integer value or not.
 | IsSameColor | Performs a simple color compare that only compares red/green/blue colors. Does not compare known color names or alpha blending.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToColor | Attempts to parse the style value as a color and return a System.Drawing.Color object that corresponds to the color style value.
 | ToHtmlColor | Translates a System.Drawing.Color to an Html color string.
Public method | ToInt | Strips any style value from units (i.e. px/pt..etc) and returns the integer value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


IsColor Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle..::..IsColor Method
HtmlStyle Class See Also Send Feedback
Whether the value of this style is a color value or not.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsColor()
Visual Basic
Public Function IsColor As Boolean
Visual C++
public:
bool IsColor()

Return Value

True if style value is a color

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


IsInt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle..::..IsInt Method
HtmlStyle Class See Also Send Feedback
Whether the value of this style is an integer value or not.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsInt()
Visual Basic
Public Function IsInt As Boolean
Visual C++
public:
bool IsInt()

Return Value

True if a value is an integer value.

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


IsSameColor Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle..::..IsSameColor Method
HtmlStyle Class See Also Send Feedback
Performs a simple color compare that only compares red/green/blue colors. Does not compare known color names or alpha blending.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsSameColor(
    Color colorA,
    Color colorB
)
Visual Basic
Public Shared Function IsSameColor ( _
    colorA As Color, _
    colorB As Color _
) As Boolean
Visual C++
public:
static bool IsSameColor(
    Color colorA,
    Color colorB
)

Parameters

colorA
Type: System.Drawing..::..Color
Color A to compare
colorB
Type: System.Drawing..::..Color
Color B to compare

Return Value

True/False whether the two colors have identical RGB colors.

Remarks

Use this to compare colors instead of System.Color.Equals() to allow your compares to work across browsers. For example, IE returns colors as named colors (yellow, red ..etc) for computed styles where Mozilla always returns (rgb(x,y,z)). Using the HtmlStyle.ToColor and IsSameColor() can help abstract these differences and allow you to perform the compare across browsers.

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ToColor Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle..::..ToColor Method
HtmlStyle Class See Also Send Feedback
Attempts to parse the style value as a color and return a System.Drawing.Color object that corresponds to the color style value.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Color ToColor()
Visual Basic
Public Function ToColor As Color
Visual C++
public:
Color ToColor()

Return Value

The System.Drawing.Color object or Color.Empty if unable to parse the color.

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ToHtmlColor Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle..::..ToHtmlColor Method
HtmlStyle Class See Also Send Feedback
Translates a System.Drawing.Color to an Html color string.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string ToHtmlColor(
    Color color
)
Visual Basic
Public Shared Function ToHtmlColor ( _
    color As Color _
) As String
Visual C++
public:
static String^ ToHtmlColor(
    Color color
)

Parameters

color
Type: System.Drawing..::..Color
The System.Drawing.Color.

Return Value

The html color string.

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ToInt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle..::..ToInt Method
HtmlStyle Class See Also Send Feedback
Strips any style value from units (i.e. px/pt..etc) and returns the integer value.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ToInt()
Visual Basic
Public Function ToInt As Integer
Visual C++
public:
int ToInt()

Return Value

The integer value. If the unit has no integer value or is empty will return -1.

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlStyle Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle Properties
HtmlStyle Class See Also Send Feedback

The HtmlStyle type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets the style name.
Public property | Value | Gets the style value.

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle..::..Name Property
HtmlStyle Class See Also Send Feedback
Gets the style name.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlStyle..::..Value Property
HtmlStyle Class See Also Send Feedback
Gets the style value.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

HtmlStyle Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTable Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable Members
HtmlTable Class Constructors Methods Properties See Also Send Feedback

The HtmlTable type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlTable()()()() | Create a new control.
Public method | HtmlTable(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertTable()()()() | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)
Public Extension Method | AssertTable(Boolean) | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)

Properties

 | Name | Description
Public property | AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag.
Public property | Border | Gets the width of the table border.
Public property | Caption | Gets the caption of a table.
Public property | CellPadding | Gets the amount of space between the cell border and cell content
Public property | CellSpacing | Gets the amount of space between the cells in a table.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColumnCount | Gets the number of columns in this table
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag.
Public property | HeadRows | Gets the rows contained in the table header if the table is using the thead tag.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Gets requested row by index.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Rows | Return List of HtmlTableRows. Only the body rows if TBody is used.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table.

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTable Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable Constructor
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlTable()()()() | Create a new control.
Public method | HtmlTable(Element) | Create a new control.

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTable Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable Constructor
HtmlTable Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTable()
Visual Basic
Public Sub New
Visual C++
public:
HtmlTable()

See Also

HtmlTable Class
HtmlTable Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTable Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable Constructor (Element)
HtmlTable Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTable(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlTable(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTable Class
HtmlTable Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTable Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable Methods
HtmlTable Class See Also Send Feedback

The HtmlTable type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertTable()()()() | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)
Public Extension Method | AssertTable(Boolean) | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..AssignElement Method
HtmlTable Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..CallMethod Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..Capture Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..Click Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..DragTo Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..GetValue Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..InvokeEvent Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..MouseClick Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..MouseHover Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..ScrollToVisible Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..SetValue Method
HtmlTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlTable Class
HtmlTable Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTable Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable Properties
HtmlTable Class See Also Send Feedback

The HtmlTable type exposes the following members.

Properties

 | Name | Description
Public property | AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag.
Public property | Border | Gets the width of the table border.
Public property | Caption | Gets the caption of a table.
Public property | CellPadding | Gets the amount of space between the cell border and cell content
Public property | CellSpacing | Gets the amount of space between the cells in a table.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColumnCount | Gets the number of columns in this table
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag.
Public property | HeadRows | Gets the rows contained in the table header if the table is using the thead tag.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Gets requested row by index.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Rows | Return List of HtmlTableRows. Only the body rows if TBody is used.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table.

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AllRows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..AllRows Property
HtmlTable Class See Also Send Feedback
Gets all rows as one collection. (Head rows, then body rows and then footer rows)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<HtmlTableRow> AllRows { get; }
Visual Basic
Public ReadOnly Property AllRows As ReadOnlyCollection(Of HtmlTableRow)
    Get
Visual C++
public:
property ReadOnlyCollection<HtmlTableRow^>^ AllRows {
    ReadOnlyCollection<HtmlTableRow^>^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


BodyRows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..BodyRows Property
HtmlTable Class See Also Send Feedback
Gets the rows contained in the body of the table if the table is using the tbody tag.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<HtmlTableRow> BodyRows { get; }
Visual Basic
Public ReadOnly Property BodyRows As ReadOnlyCollection(Of HtmlTableRow)
    Get
Visual C++
public:
property ReadOnlyCollection<HtmlTableRow^>^ BodyRows {
    ReadOnlyCollection<HtmlTableRow^>^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Border Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..Border Property
HtmlTable Class See Also Send Feedback
Gets the width of the table border.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Border { get; }
Visual Basic
Public ReadOnly Property Border As String
    Get
Visual C++
public:
property String^ Border {
    String^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Caption Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..Caption Property
HtmlTable Class See Also Send Feedback
Gets the caption of a table.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Caption { get; }
Visual Basic
Public ReadOnly Property Caption As String
    Get
Visual C++
public:
property String^ Caption {
    String^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CellPadding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..CellPadding Property
HtmlTable Class See Also Send Feedback
Gets the amount of space between the cell border and cell content

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string CellPadding { get; }
Visual Basic
Public ReadOnly Property CellPadding As String
    Get
Visual C++
public:
property String^ CellPadding {
    String^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CellSpacing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..CellSpacing Property
HtmlTable Class See Also Send Feedback
Gets the amount of space between the cells in a table.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string CellSpacing { get; }
Visual Basic
Public ReadOnly Property CellSpacing As String
    Get
Visual C++
public:
property String^ CellSpacing {
    String^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ColumnCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..ColumnCount Property
HtmlTable Class See Also Send Feedback
Gets the number of columns in this table

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ColumnCount { get; }
Visual Basic
Public ReadOnly Property ColumnCount As Integer
    Get
Visual C++
public:
property int ColumnCount {
    int get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


FootRows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..FootRows Property
HtmlTable Class See Also Send Feedback
Gets the rows contained in the table footer if the table is using the tfoot tag.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<HtmlTableRow> FootRows { get; }
Visual Basic
Public ReadOnly Property FootRows As ReadOnlyCollection(Of HtmlTableRow)
    Get
Visual C++
public:
property ReadOnlyCollection<HtmlTableRow^>^ FootRows {
    ReadOnlyCollection<HtmlTableRow^>^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HeadRows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..HeadRows Property
HtmlTable Class See Also Send Feedback
Gets the rows contained in the table header if the table is using the thead tag.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<HtmlTableRow> HeadRows { get; }
Visual Basic
Public ReadOnly Property HeadRows As ReadOnlyCollection(Of HtmlTableRow)
    Get
Visual C++
public:
property ReadOnlyCollection<HtmlTableRow^>^ HeadRows {
    ReadOnlyCollection<HtmlTableRow^>^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..Item Property
HtmlTable Class See Also Send Feedback
Gets requested row by index.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTableRow this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As HtmlTableRow
    Get
Visual C++
public:
property HtmlTableRow^ default[int index] {
    HtmlTableRow^ get (int index);
}

Parameters

index
Type: System..::..Int32
row index

Return Value

The requested row.

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Rows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..Rows Property
HtmlTable Class See Also Send Feedback
Return List of HtmlTableRows. Only the body rows if TBody is used.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<HtmlTableRow> Rows { get; }
Visual Basic
Public ReadOnly Property Rows As ReadOnlyCollection(Of HtmlTableRow)
    Get
Visual C++
public:
property ReadOnlyCollection<HtmlTableRow^>^ Rows {
    ReadOnlyCollection<HtmlTableRow^>^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTable..::..Width Property
HtmlTable Class See Also Send Feedback
Gets the width of a table.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Width { get; }
Visual Basic
Public ReadOnly Property Width As String
    Get
Visual C++
public:
property String^ Width {
    String^ get ();
}

See Also

HtmlTable Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableAssertExtensions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableAssertExtensions Members
HtmlTableAssertExtensions Class Methods See Also Send Feedback

Methods

Name | Description
AssertTable(HtmlTable) | Assert methods for the HtmlTable content.
AssertTable(HtmlTable, Boolean) | Assert methods for the HtmlTable content.

See Also

HtmlTableAssertExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableAssertExtensions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableAssertExtensions Methods
HtmlTableAssertExtensions Class See Also Send Feedback

Methods

Name | Description
AssertTable(HtmlTable) | Assert methods for the HtmlTable content.
AssertTable(HtmlTable, Boolean) | Assert methods for the HtmlTable content.

See Also

HtmlTableAssertExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertTable Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableAssertExtensions..::..AssertTable Method
HtmlTableAssertExtensions Class See Also Send Feedback

Overload List

Name | Description
AssertTable(HtmlTable) | Assert methods for the HtmlTable content.
AssertTable(HtmlTable, Boolean) | Assert methods for the HtmlTable content.

See Also

HtmlTableAssertExtensions Class
HtmlTableAssertExtensions Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertTable Method (HtmlTable)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableAssertExtensions..::..AssertTable Method (HtmlTable)
HtmlTableAssertExtensions Class See Also Send Feedback
Assert methods for the HtmlTable content.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertTable AssertTable(
    this HtmlTable control
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertTable ( _
    control As HtmlTable _
) As AssertTable
Visual C++
[ExtensionAttribute]
public:
static AssertTable^ AssertTable(
    HtmlTable^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlTable
The HtmlTable control to wrap.

Return Value

A HtmlTable wrapped in a AssertCheck object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlTable. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlTableAssertExtensions Class
AssertTable Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssertTable Method (HtmlTable, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableAssertExtensions..::..AssertTable Method (HtmlTable, Boolean)
HtmlTableAssertExtensions Class See Also Send Feedback
Assert methods for the HtmlTable content.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AssertTable AssertTable(
    this HtmlTable control,
    bool throwOnFailure
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function AssertTable ( _
    control As HtmlTable, _
    throwOnFailure As Boolean _
) As AssertTable
Visual C++
[ExtensionAttribute]
public:
static AssertTable^ AssertTable(
    HtmlTable^ control,
    bool throwOnFailure
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlTable
The HtmlTable control to wrap.
throwOnFailure
Type: System..::..Boolean
Whether the assert object should throw an exception if checks fail

Return Value

A HtmlTable wrapped in a AssertCheck object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlTable. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlTableAssertExtensions Class
AssertTable Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell Members
HtmlTableCell Class Constructors Methods Properties See Also Send Feedback

The HtmlTableCell type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlTableCell()()()() | Create a new control.
Public method | HtmlTableCell(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell.

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell Constructor
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlTableCell()()()() | Create a new control.
Public method | HtmlTableCell(Element) | Create a new control.

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell Constructor
HtmlTableCell Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTableCell()
Visual Basic
Public Sub New
Visual C++
public:
HtmlTableCell()

See Also

HtmlTableCell Class
HtmlTableCell Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell Constructor (Element)
HtmlTableCell Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTableCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlTableCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTableCell Class
HtmlTableCell Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell Methods
HtmlTableCell Class See Also Send Feedback

The HtmlTableCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..AssignElement Method
HtmlTableCell Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..CallMethod Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..Capture Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..Click Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..DragTo Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..GetValue Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..InvokeEvent Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..MouseClick Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..MouseHover Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..ScrollToVisible Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..SetValue Method
HtmlTableCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlTableCell Class
HtmlTableCell Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell Properties
HtmlTableCell Class See Also Send Feedback

The HtmlTableCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell.

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Align Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..Align Property
HtmlTableCell Class See Also Send Feedback
Gets the horizontal alignment of data within a table cell.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Align { get; }
Visual Basic
Public ReadOnly Property Align As String
    Get
Visual C++
public:
property String^ Align {
    String^ get ();
}

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CellIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..CellIndex Property
HtmlTableCell Class See Also Send Feedback
Gets the position of a cell in the cells collection of a row

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CellIndex { get; }
Visual Basic
Public ReadOnly Property CellIndex As Integer
    Get
Visual C++
public:
property int CellIndex {
    int get ();
}

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ColSpan Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..ColSpan Property
HtmlTableCell Class See Also Send Feedback
Gets the number of columns a table cell should span

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ColSpan { get; }
Visual Basic
Public ReadOnly Property ColSpan As Integer
    Get
Visual C++
public:
property int ColSpan {
    int get ();
}

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..Height Property
HtmlTableCell Class See Also Send Feedback
Gets the height of a table cell.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Height { get; }
Visual Basic
Public ReadOnly Property Height As String
    Get
Visual C++
public:
property String^ Height {
    String^ get ();
}

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


RowSpan Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..RowSpan Property
HtmlTableCell Class See Also Send Feedback
Gets the number of rows a table cell should span.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int RowSpan { get; }
Visual Basic
Public ReadOnly Property RowSpan As Integer
    Get
Visual C++
public:
property int RowSpan {
    int get ();
}

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


VAlign Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..VAlign Property
HtmlTableCell Class See Also Send Feedback
Gets the vertical alignment of data within a table cell.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string VAlign { get; }
Visual Basic
Public ReadOnly Property VAlign As String
    Get
Visual C++
public:
property String^ VAlign {
    String^ get ();
}

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableCell..::..Width Property
HtmlTableCell Class See Also Send Feedback
Gets the width of a table cell.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Width { get; }
Visual Basic
Public ReadOnly Property Width As String
    Get
Visual C++
public:
property String^ Width {
    String^ get ();
}

See Also

HtmlTableCell Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableRow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow Members
HtmlTableRow Class Constructors Methods Properties See Also Send Feedback

The HtmlTableRow type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlTableRow()()()() | Create a new control.
Public method | HtmlTableRow(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableRow Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow Constructor
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlTableRow()()()() | Create a new control.
Public method | HtmlTableRow(Element) | Create a new control.

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableRow Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow Constructor
HtmlTableRow Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTableRow()
Visual Basic
Public Sub New
Visual C++
public:
HtmlTableRow()

See Also

HtmlTableRow Class
HtmlTableRow Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableRow Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow Constructor (Element)
HtmlTableRow Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTableRow(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlTableRow(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTableRow Class
HtmlTableRow Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableRow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow Methods
HtmlTableRow Class See Also Send Feedback

The HtmlTableRow type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlTableRow Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..AssignElement Method
HtmlTableRow Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTableRow Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..CallMethod Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..Capture Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..Click Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..DragTo Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..GetValue Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..InvokeEvent Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..MouseClick Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..MouseHover Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..ScrollToVisible Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..SetValue Method
HtmlTableRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
HtmlTableRow Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTableRow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow Properties
HtmlTableRow Class See Also Send Feedback

The HtmlTableRow type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlTableRow Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Align Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..Align Property
HtmlTableRow Class See Also Send Feedback
Gets the horizontal alignment of data within a table row.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Align { get; }
Visual Basic
Public ReadOnly Property Align As String
    Get
Visual C++
public:
property String^ Align {
    String^ get ();
}

See Also

HtmlTableRow Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Cells Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..Cells Property
HtmlTableRow Class See Also Send Feedback
Return list of HtmlTableCells.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<HtmlTableCell> Cells { get; }
Visual Basic
Public ReadOnly Property Cells As List(Of HtmlTableCell)
    Get
Visual C++
public:
property List<HtmlTableCell^>^ Cells {
    List<HtmlTableCell^>^ get ();
}

See Also

HtmlTableRow Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..Item Property
HtmlTableRow Class See Also Send Feedback
Return cell by its index in this row.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTableCell this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As HtmlTableCell
    Get
Visual C++
public:
property HtmlTableCell^ default[int index] {
    HtmlTableCell^ get (int index);
}

Parameters

index
Type: System..::..Int32
The cell index.

Return Value

The cell at desired index.

See Also

HtmlTableRow Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


RowIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTableRow..::..RowIndex Property
HtmlTableRow Class See Also Send Feedback
Gets the position of a row in the table's rows collection.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int RowIndex { get; }
Visual Basic
Public ReadOnly Property RowIndex As Integer
    Get
Visual C++
public:
property int RowIndex {
    int get ();
}

See Also

HtmlTableRow Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTextArea Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea Members
HtmlTextArea Class Constructors Methods Properties See Also Send Feedback

The HtmlTextArea type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlTextArea()()()() | Create a new control.
Public method | HtmlTextArea(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Cols | Gets the number of columns set. If none, returns -1
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Rows | Gets the number of rows set. If none, returns -1.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets or sets the value of the Text Area
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTextArea Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea Constructor
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlTextArea()()()() | Create a new control.
Public method | HtmlTextArea(Element) | Create a new control.

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTextArea Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea Constructor
HtmlTextArea Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTextArea()
Visual Basic
Public Sub New
Visual C++
public:
HtmlTextArea()

See Also

HtmlTextArea Class
HtmlTextArea Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTextArea Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea Constructor (Element)
HtmlTextArea Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTextArea(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlTextArea(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTextArea Class
HtmlTextArea Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTextArea Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea Methods
HtmlTextArea Class See Also Send Feedback

The HtmlTextArea type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlTextArea Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..AssignElement Method
HtmlTextArea Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTextArea Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..CallMethod Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..Capture Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..Click Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..DragTo Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..GetValue Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..InvokeEvent Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..MouseClick Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..MouseHover Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..ScrollToVisible Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..SetValue Method
HtmlTextArea Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
HtmlTextArea Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTextArea Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea Properties
HtmlTextArea Class See Also Send Feedback

The HtmlTextArea type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Cols | Gets the number of columns set. If none, returns -1
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Rows | Gets the number of rows set. If none, returns -1.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets or sets the value of the Text Area
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlTextArea Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Cols Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..Cols Property
HtmlTextArea Class See Also Send Feedback
Gets the number of columns set. If none, returns -1

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Cols { get; }
Visual Basic
Public ReadOnly Property Cols As Integer
    Get
Visual C++
public:
property int Cols {
    int get ();
}

See Also

HtmlTextArea Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Rows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..Rows Property
HtmlTextArea Class See Also Send Feedback
Gets the number of rows set. If none, returns -1.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Rows { get; }
Visual Basic
Public ReadOnly Property Rows As Integer
    Get
Visual C++
public:
property int Rows {
    int get ();
}

See Also

HtmlTextArea Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTextArea..::..Text Property
HtmlTextArea Class See Also Send Feedback
Gets or sets the value of the Text Area

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlTextArea Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTime Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime Members
HtmlTime Class Constructors Methods Properties See Also Send Feedback

The HtmlTime type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlTime()()()() | Create a new control.
Public method | HtmlTime(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DateTime |
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PubDate |
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlTime Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTime Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime Constructor
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlTime()()()() | Create a new control.
Public method | HtmlTime(Element) | Create a new test control

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTime Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime Constructor
HtmlTime Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTime()
Visual Basic
Public Sub New
Visual C++
public:
HtmlTime()

See Also

HtmlTime Class
HtmlTime Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTime Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime Constructor (Element)
HtmlTime Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTime(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlTime(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTime Class
HtmlTime Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTime Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime Methods
HtmlTime Class See Also Send Feedback

The HtmlTime type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlTime Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..AssignElement Method
HtmlTime Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlTime Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..CallMethod Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..Capture Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..Click Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..DragTo Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..GetValue Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..InvokeEvent Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..MouseClick Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..MouseHover Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..ScrollToVisible Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..SetValue Method
HtmlTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlTime Class
HtmlTime Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlTime Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime Properties
HtmlTime Class See Also Send Feedback

The HtmlTime type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DateTime |
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PubDate |
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlTime Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DateTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..DateTime Property
HtmlTime Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlTime.DateTime"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DateTime { get; set; }
Visual Basic
Public Property DateTime As String
    Get
    Set
Visual C++
public:
property String^ DateTime {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlTime Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


PubDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTime..::..PubDate Property
HtmlTime Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlTime.PubDate"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool PubDate { get; set; }
Visual Basic
Public Property PubDate As Boolean
    Get
    Set
Visual C++
public:
property bool PubDate {
    bool get ();
    void set (bool value);
}

See Also

HtmlTime Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlUnorderedList Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList Members
HtmlUnorderedList Class Constructors Methods Properties See Also Send Feedback

The HtmlUnorderedList type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlUnorderedList()()()() | Create a new control.
Public method | HtmlUnorderedList(Element) | Create a new test control

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllItems | Gets the all child list items. - Recursive
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Gets this ordered list items.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlUnorderedList Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList Constructor
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlUnorderedList()()()() | Create a new control.
Public method | HtmlUnorderedList(Element) | Create a new test control

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlUnorderedList Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList Constructor
HtmlUnorderedList Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlUnorderedList()
Visual Basic
Public Sub New
Visual C++
public:
HtmlUnorderedList()

See Also

HtmlUnorderedList Class
HtmlUnorderedList Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlUnorderedList Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList Constructor (Element)
HtmlUnorderedList Class See Also Send Feedback
Create a new test control

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlUnorderedList(
    Element e
)
Visual Basic
Public Sub New ( _
    e As Element _
)
Visual C++
public:
HtmlUnorderedList(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlUnorderedList Class
HtmlUnorderedList Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlUnorderedList Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList Methods
HtmlUnorderedList Class See Also Send Feedback

The HtmlUnorderedList type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlUnorderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..AssignElement Method
HtmlUnorderedList Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlUnorderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..CallMethod Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..Capture Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..Click Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..DragTo Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..GetValue Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..InvokeEvent Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..MouseClick Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..MouseHover Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..ScrollToVisible Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..SetValue Method
HtmlUnorderedList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
HtmlUnorderedList Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlUnorderedList Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList Properties
HtmlUnorderedList Class See Also Send Feedback

The HtmlUnorderedList type exposes the following members.

Properties

 | Name | Description
Public property | AllItems | Gets the all child list items. - Recursive
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Gets this ordered list items.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlUnorderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AllItems Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..AllItems Property
HtmlUnorderedList Class See Also Send Feedback
Gets the all child list items. - Recursive

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlListItem[] AllItems { get; }
Visual Basic
Public ReadOnly Property AllItems As HtmlListItem()
    Get
Visual C++
public:
property array<HtmlListItem^>^ AllItems {
    array<HtmlListItem^>^ get ();
}

See Also

HtmlUnorderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlUnorderedList..::..Items Property
HtmlUnorderedList Class See Also Send Feedback
Gets this ordered list items.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlListItem[] Items { get; }
Visual Basic
Public ReadOnly Property Items As HtmlListItem()
    Get
Visual C++
public:
property array<HtmlListItem^>^ Items {
    array<HtmlListItem^>^ get ();
}

See Also

HtmlUnorderedList Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlVideo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo Members
HtmlVideo Class Constructors Methods Properties See Also Send Feedback

The HtmlVideo type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlVideo()()()() | Create a new control.
Public method | HtmlVideo(Element) | Create a new control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | Load | Cause the video player to reload its source video
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Pause |
Public method | Play |
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autoplay | The autoplay attribute determines whether a video begins playing as soon as the page loads
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Controls | The controls attribute determines whether the standard playback controls are shown to the user
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentTime | Gets the current playback time
Public property | Duration | Gets the duration of the video, in seconds
Public property | Ended | Gets whether the video has played through to its end
Public property | Error |
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height |
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InError |
Public property | InitialTime | Gets the initial playback position of the video, in seconds
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Loop | Whether the video will start playing from its beginning again once it reaches its end
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Paused |
Public property | Poster | URL for the image that is shown before the video begins playing
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Sources |
Public property | Src | URL for the video file to play, if no source elements are specified for the video
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width |

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlVideo Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo Constructor
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlVideo()()()() | Create a new control.
Public method | HtmlVideo(Element) | Create a new control.

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlVideo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo Constructor
HtmlVideo Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlVideo()
Visual Basic
Public Sub New
Visual C++
public:
HtmlVideo()

See Also

HtmlVideo Class
HtmlVideo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlVideo Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo Constructor (Element)
HtmlVideo Class See Also Send Feedback
Create a new control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlVideo(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlVideo(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlVideo Class
HtmlVideo Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlVideo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo Methods
HtmlVideo Class See Also Send Feedback

The HtmlVideo type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | Load | Cause the video player to reload its source video
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Pause |
Public method | Play |
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..AssignElement Method
HtmlVideo Class See Also Send Feedback
Assign element and initialize this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The base element.

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..CallMethod Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Capture Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Click Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..DragTo Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..GetValue Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..InvokeEvent Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Load Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Load Method
HtmlVideo Class See Also Send Feedback
Cause the video player to reload its source video

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Load()
Visual Basic
Public Sub Load
Visual C++
public:
void Load()

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..MouseClick Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..MouseHover Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Pause Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Pause Method
HtmlVideo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlVideo.Pause"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Pause()
Visual Basic
Public Sub Pause
Visual C++
public:
void Pause()

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Play Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Play Method
HtmlVideo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlVideo.Play"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Play()
Visual Basic
Public Sub Play
Visual C++
public:
void Play()

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..ScrollToVisible Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..SetValue Method
HtmlVideo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlVideo Class
HtmlVideo Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlVideo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo Properties
HtmlVideo Class See Also Send Feedback

The HtmlVideo type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | Autoplay | The autoplay attribute determines whether a video begins playing as soon as the page loads
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Controls | The controls attribute determines whether the standard playback controls are shown to the user
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentTime | Gets the current playback time
Public property | Duration | Gets the duration of the video, in seconds
Public property | Ended | Gets whether the video has played through to its end
Public property | Error |
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height |
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InError |
Public property | InitialTime | Gets the initial playback position of the video, in seconds
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Returns the FindExpression for this control. Since this is a abstract base class it always returns null. (Inherited from Control.)
Public property | Loop | Whether the video will start playing from its beginning again once it reaches its end
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Paused |
Public property | Poster | URL for the image that is shown before the video begins playing
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Sources |
Public property | Src | URL for the video file to play, if no source elements are specified for the video
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width |

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Autoplay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Autoplay Property
HtmlVideo Class See Also Send Feedback
The autoplay attribute determines whether a video begins playing as soon as the page loads

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Autoplay { get; set; }
Visual Basic
Public Property Autoplay As Boolean
    Get
    Set
Visual C++
public:
property bool Autoplay {
    bool get ();
    void set (bool value);
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Controls Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Controls Property
HtmlVideo Class See Also Send Feedback
The controls attribute determines whether the standard playback controls are shown to the user

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Controls { get; set; }
Visual Basic
Public Property Controls As Boolean
    Get
    Set
Visual C++
public:
property bool Controls {
    bool get ();
    void set (bool value);
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


CurrentTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..CurrentTime Property
HtmlVideo Class See Also Send Feedback
Gets the current playback time

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CurrentTime { get; }
Visual Basic
Public ReadOnly Property CurrentTime As Double
    Get
Visual C++
public:
property double CurrentTime {
    double get ();
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Duration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Duration Property
HtmlVideo Class See Also Send Feedback
Gets the duration of the video, in seconds

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Duration { get; }
Visual Basic
Public ReadOnly Property Duration As Double
    Get
Visual C++
public:
property double Duration {
    double get ();
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Ended Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Ended Property
HtmlVideo Class See Also Send Feedback
Gets whether the video has played through to its end

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Ended { get; }
Visual Basic
Public ReadOnly Property Ended As Boolean
    Get
Visual C++
public:
property bool Ended {
    bool get ();
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Error Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Error Property
HtmlVideo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlVideo.Error"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlMediaError Error { get; }
Visual Basic
Public ReadOnly Property Error As HtmlMediaError
    Get
Visual C++
public:
property HtmlMediaError Error {
    HtmlMediaError get ();
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Height Property
HtmlVideo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlVideo.Height"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Height { get; set; }
Visual Basic
Public Property Height As Integer
    Get
    Set
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InError Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..InError Property
HtmlVideo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlVideo.InError"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool InError { get; }
Visual Basic
Public ReadOnly Property InError As Boolean
    Get
Visual C++
public:
property bool InError {
    bool get ();
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


InitialTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..InitialTime Property
HtmlVideo Class See Also Send Feedback
Gets the initial playback position of the video, in seconds

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double InitialTime { get; }
Visual Basic
Public ReadOnly Property InitialTime As Double
    Get
Visual C++
public:
property double InitialTime {
    double get ();
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Loop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Loop Property
HtmlVideo Class See Also Send Feedback
Whether the video will start playing from its beginning again once it reaches its end

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Loop { get; set; }
Visual Basic
Public Property Loop As Boolean
    Get
    Set
Visual C++
public:
property bool Loop {
    bool get ();
    void set (bool value);
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Paused Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Paused Property
HtmlVideo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlVideo.Paused"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Paused { get; }
Visual Basic
Public ReadOnly Property Paused As Boolean
    Get
Visual C++
public:
property bool Paused {
    bool get ();
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Poster Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Poster Property
HtmlVideo Class See Also Send Feedback
URL for the image that is shown before the video begins playing

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Poster { get; set; }
Visual Basic
Public Property Poster As String
    Get
    Set
Visual C++
public:
property String^ Poster {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Sources Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Sources Property
HtmlVideo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlVideo.Sources"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlSource> Sources { get; }
Visual Basic
Public ReadOnly Property Sources As IList(Of HtmlSource)
    Get
Visual C++
public:
property IList<HtmlSource^>^ Sources {
    IList<HtmlSource^>^ get ();
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Src Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Src Property
HtmlVideo Class See Also Send Feedback
URL for the video file to play, if no source elements are specified for the video

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Src { get; set; }
Visual Basic
Public Property Src As String
    Get
    Set
Visual C++
public:
property String^ Src {
    String^ get ();
    void set (String^ value);
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlVideo..::..Width Property
HtmlVideo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.HtmlControls.HtmlVideo.Width"]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Width { get; set; }
Visual Basic
Public Property Width As Integer
    Get
    Set
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

HtmlVideo Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlWait Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait Members
HtmlWait Class Constructors Methods Properties See Also Send Feedback

The HtmlWait type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlWait | Create a new wait class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForAttributes(array<String>[]()[][]) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForAttributes(Int32, array<String>[]()[][]) | Wait for a set of attributes on this element. (Inherited from Wait.)
Public method | ForAttributesNot(array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForAttributesNot(Int32, array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Inherited from Wait.)
Public method | ForCondition(Func<(Of <<'(Control, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this control.
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this element. (Inherited from Wait.)
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32, WaitResultType) | (Inherited from Wait.)
Public method | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true. (Inherited from Wait.)
Public method | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true. (Inherited from Wait.)
Public method | ForExists()()()() | Wait for this element to exist in the DOM. (Inherited from Wait.)
Public method | ForExists(Int32) | Wait for this element to exist in the DOM. (Inherited from Wait.)
Protected method | ForExists(Int32, Boolean) | Protected exists. [Control the control refresh] (Overrides Wait..::..ForExists(Int32, Boolean).)
Public method | ForExistsNot()()()() | Wait for this element not to exist in the DOM (Inherited from Wait.)
Public method | ForExistsNot(Int32) | Wait for this element not to exist in the DOM. (Inherited from Wait.)
Public method | ForStyles(array<String>[]()[][]) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
Public method | ForStyles(Boolean, array<String>[]()[][]) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
Public method | ForStyles(Int32, array<String>[]()[][]) | Wait for a set of styles on this element.
Public method | ForStyles(Int32, Boolean, array<String>[]()[][]) | Wait for a set of styles on this element.
Public method | ForStylesNot(array<String>[]()[][]) | Wait for a set of styles to no longer be true. (Timeout = HtmlWait.Timeout)
Public method | ForStylesNot(Boolean, array<String>[]()[][]) | Wait for a set of styles to no longer be true.
Public method | ForStylesNot(Int32, array<String>[]()[][]) | Wait for a set of styles to no longer be true.
Public method | ForStylesNot(Int32, Boolean, array<String>[]()[][]) | Wait for a set of styles to no longer be true.
Public method | ForVisible()()()() | Wait for an element to be visible. HtmlControl.IsVisible is true. (Timeout = HtmlWait.Timeout)
Public method | ForVisible(Int32) | Wait for an element to be visible. HtmlControl.IsVisible is true.
Public method | ForVisibleNot()()()() | Wait for an element to no longer be visible. HtmlControl.IsVisible is false. (Timeout = HtmlWait.Timeout)
Public method | ForVisibleNot(Int32) | Wait for an element to no longer be visible. HtmlControl.IsVisible is false.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | ForSelectedIndex | Wait for a specific selected index of the drop down. (Defined by HtmlWaitExtensions.)
Public Extension Method | ForSelectedValue | Wait for a specific selected value of the drop down. (Defined by HtmlWaitExtensions.)

Properties

 | Name | Description
Public property | Timeout | Gets/Sets the timeout for all Wait.Forxx methods. Default=Settings.ExecuteCommandTimeout (Inherited from Wait.)

See Also

HtmlWait Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlWait Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait Constructor
HtmlWait Class See Also Send Feedback
Create a new wait class.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlWait(
    HtmlControl htmlControl,
    int checkInterval
)
Visual Basic
Public Sub New ( _
    htmlControl As HtmlControl, _
    checkInterval As Integer _
)
Visual C++
public:
HtmlWait(
    HtmlControl^ htmlControl,
    int checkInterval
)

Parameters

htmlControl
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The html control target
checkInterval
Type: System..::..Int32
Interval to use to check on the wait condition. (msec)

See Also

HtmlWait Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlWait Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait Methods
HtmlWait Class See Also Send Feedback

The HtmlWait type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForAttributes(array<String>[]()[][]) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForAttributes(Int32, array<String>[]()[][]) | Wait for a set of attributes on this element. (Inherited from Wait.)
Public method | ForAttributesNot(array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForAttributesNot(Int32, array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Inherited from Wait.)
Public method | ForCondition(Func<(Of <<'(Control, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this control.
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this element. (Inherited from Wait.)
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32, WaitResultType) | (Inherited from Wait.)
Public method | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true. (Inherited from Wait.)
Public method | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true. (Inherited from Wait.)
Public method | ForExists()()()() | Wait for this element to exist in the DOM. (Inherited from Wait.)
Public method | ForExists(Int32) | Wait for this element to exist in the DOM. (Inherited from Wait.)
Protected method | ForExists(Int32, Boolean) | Protected exists. [Control the control refresh] (Overrides Wait..::..ForExists(Int32, Boolean).)
Public method | ForExistsNot()()()() | Wait for this element not to exist in the DOM (Inherited from Wait.)
Public method | ForExistsNot(Int32) | Wait for this element not to exist in the DOM. (Inherited from Wait.)
Public method | ForStyles(array<String>[]()[][]) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
Public method | ForStyles(Boolean, array<String>[]()[][]) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
Public method | ForStyles(Int32, array<String>[]()[][]) | Wait for a set of styles on this element.
Public method | ForStyles(Int32, Boolean, array<String>[]()[][]) | Wait for a set of styles on this element.
Public method | ForStylesNot(array<String>[]()[][]) | Wait for a set of styles to no longer be true. (Timeout = HtmlWait.Timeout)
Public method | ForStylesNot(Boolean, array<String>[]()[][]) | Wait for a set of styles to no longer be true.
Public method | ForStylesNot(Int32, array<String>[]()[][]) | Wait for a set of styles to no longer be true.
Public method | ForStylesNot(Int32, Boolean, array<String>[]()[][]) | Wait for a set of styles to no longer be true.
Public method | ForVisible()()()() | Wait for an element to be visible. HtmlControl.IsVisible is true. (Timeout = HtmlWait.Timeout)
Public method | ForVisible(Int32) | Wait for an element to be visible. HtmlControl.IsVisible is true.
Public method | ForVisibleNot()()()() | Wait for an element to no longer be visible. HtmlControl.IsVisible is false. (Timeout = HtmlWait.Timeout)
Public method | ForVisibleNot(Int32) | Wait for an element to no longer be visible. HtmlControl.IsVisible is false.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | ForSelectedIndex | Wait for a specific selected index of the drop down. (Defined by HtmlWaitExtensions.)
Public Extension Method | ForSelectedValue | Wait for a specific selected value of the drop down. (Defined by HtmlWaitExtensions.)

See Also

HtmlWait Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForAttributes Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForAttributes Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForAttributes(array<String>[]()[][]) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForAttributes(Int32, array<String>[]()[][]) | Wait for a set of attributes on this element. (Inherited from Wait.)

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForAttributesNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForAttributesNot Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForAttributesNot(array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForAttributesNot(Int32, array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Inherited from Wait.)

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForCondition Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForCondition Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForCondition(Func<(Of <<'(Control, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this control.
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this element. (Inherited from Wait.)
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32, WaitResultType) | (Inherited from Wait.)

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForCondition Method (Func(Control, Object, Boolean), Boolean, Object, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForCondition Method (Func<(Of <(<'Control, Object, Boolean>)>)>, Boolean, Object, Int32)
HtmlWait Class See Also Send Feedback
Wait for a custom condition on this control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForCondition(
    Func<Control, Object, bool> condition,
    bool invertCondition,
    Object custom,
    int timeout
)
Visual Basic
Public Sub ForCondition ( _
    condition As Func(Of Control, Object, Boolean), _
    invertCondition As Boolean, _
    custom As Object, _
    timeout As Integer _
)
Visual C++
public:
void ForCondition(
    Func<Control^, Object^, bool>^ condition,
    bool invertCondition,
    Object^ custom,
    int timeout
)

Parameters

condition
Type: System..::..Func <(Of <(<' Control, Object, Boolean >)>)>
The condition to wait for.
invertCondition
Type: System..::..Boolean
True/False whether to invert the condition or not.
custom
Type: System..::..Object
Any custom data to pass to this condition.
timeout
Type: System..::..Int32
The timeout to use.

See Also

HtmlWait Class
ForCondition Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForContent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForContent Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true. (Inherited from Wait.)

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForContentNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForContentNot Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout) (Inherited from Wait.)
Public method | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true. (Inherited from Wait.)

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForExists Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForExists Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForExists()()()() | Wait for this element to exist in the DOM. (Inherited from Wait.)
Public method | ForExists(Int32) | Wait for this element to exist in the DOM. (Inherited from Wait.)
Protected method | ForExists(Int32, Boolean) | Protected exists. [Control the control refresh] (Overrides Wait..::..ForExists(Int32, Boolean).)

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForExists Method (Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForExists Method (Int32, Boolean)
HtmlWait Class See Also Send Feedback
Protected exists. [Control the control refresh]

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override void ForExists(
    int timeout,
    bool refreshElement
)
Visual Basic
Protected Overrides Sub ForExists ( _
    timeout As Integer, _
    refreshElement As Boolean _
)
Visual C++
protected:
virtual void ForExists(
    int timeout,
    bool refreshElement
) override

Parameters

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlWait.ForExists(System.Int32,System.Boolean)"]

refreshElement
Type: System..::..Boolean

[Missing <param name="refreshElement"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlWait.ForExists(System.Int32,System.Boolean)"]

See Also

HtmlWait Class
ForExists Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForExistsNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForExistsNot Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForExistsNot()()()() | Wait for this element not to exist in the DOM (Inherited from Wait.)
Public method | ForExistsNot(Int32) | Wait for this element not to exist in the DOM. (Inherited from Wait.)

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStyles Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStyles Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForStyles(array<String>[]()[][]) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
Public method | ForStyles(Boolean, array<String>[]()[][]) | Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)
Public method | ForStyles(Int32, array<String>[]()[][]) | Wait for a set of styles on this element.
Public method | ForStyles(Int32, Boolean, array<String>[]()[][]) | Wait for a set of styles on this element.

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStyles Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStyles Method (array<String>[]()[][])
HtmlWait Class Example See Also Send Feedback
Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForStyles(
    params string[] stylesNameValuePairs
)
Visual Basic
Public Sub ForStyles ( _
    ParamArray stylesNameValuePairs As String() _
)
Visual C++
public:
void ForStyles(
    ... array<String^>^ stylesNameValuePairs
)

Parameters

stylesNameValuePairs
Type: array< System..::..String >[]()[][]
The styles name/value pairs

Examples

ForStyles("backgroundColor=red","display=none")

See Also

HtmlWait Class
ForStyles Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStyles Method (Boolean, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStyles Method (Boolean, array<String>[]()[][])
HtmlWait Class Example See Also Send Feedback
Wait for a set of styles on this element. (Timeout = HtmlWait.Timeout)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForStyles(
    bool useComputedStyles,
    params string[] stylesNameValuePairs
)
Visual Basic
Public Sub ForStyles ( _
    useComputedStyles As Boolean, _
    ParamArray stylesNameValuePairs As String() _
)
Visual C++
public:
void ForStyles(
    bool useComputedStyles,
    ... array<String^>^ stylesNameValuePairs
)

Parameters

useComputedStyles
Type: System..::..Boolean
True/False whether to use the computed style for this wait.
stylesNameValuePairs
Type: array< System..::..String >[]()[][]
The styles name/value pairs

Examples

ForStyles("backgroundColor=red","display=none")

See Also

HtmlWait Class
ForStyles Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStyles Method (Int32, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStyles Method (Int32, array<String>[]()[][])
HtmlWait Class Example See Also Send Feedback
Wait for a set of styles on this element.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForStyles(
    int timeout,
    params string[] stylesNameValuePairs
)
Visual Basic
Public Sub ForStyles ( _
    timeout As Integer, _
    ParamArray stylesNameValuePairs As String() _
)
Visual C++
public:
void ForStyles(
    int timeout,
    ... array<String^>^ stylesNameValuePairs
)

Parameters

timeout
Type: System..::..Int32
The timeout to use.
stylesNameValuePairs
Type: array< System..::..String >[]()[][]
The styles name/value pairs

Examples

ForStyles("backgroundColor=red","display=none")

See Also

HtmlWait Class
ForStyles Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStyles Method (Int32, Boolean, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStyles Method (Int32, Boolean, array<String>[]()[][])
HtmlWait Class Example See Also Send Feedback
Wait for a set of styles on this element.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForStyles(
    int timeout,
    bool useComputedStyles,
    params string[] stylesNameValuePairs
)
Visual Basic
Public Sub ForStyles ( _
    timeout As Integer, _
    useComputedStyles As Boolean, _
    ParamArray stylesNameValuePairs As String() _
)
Visual C++
public:
void ForStyles(
    int timeout,
    bool useComputedStyles,
    ... array<String^>^ stylesNameValuePairs
)

Parameters

timeout
Type: System..::..Int32
The timeout to use.
useComputedStyles
Type: System..::..Boolean
True/False whether to use the computed style for this wait.
stylesNameValuePairs
Type: array< System..::..String >[]()[][]
The styles name/value pairs

Examples

ForStyles("backgroundColor=red","display=none")

See Also

HtmlWait Class
ForStyles Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStylesNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStylesNot Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForStylesNot(array<String>[]()[][]) | Wait for a set of styles to no longer be true. (Timeout = HtmlWait.Timeout)
Public method | ForStylesNot(Boolean, array<String>[]()[][]) | Wait for a set of styles to no longer be true.
Public method | ForStylesNot(Int32, array<String>[]()[][]) | Wait for a set of styles to no longer be true.
Public method | ForStylesNot(Int32, Boolean, array<String>[]()[][]) | Wait for a set of styles to no longer be true.

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStylesNot Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStylesNot Method (array<String>[]()[][])
HtmlWait Class Example See Also Send Feedback
Wait for a set of styles to no longer be true. (Timeout = HtmlWait.Timeout)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForStylesNot(
    params string[] stylesNameValuePairs
)
Visual Basic
Public Sub ForStylesNot ( _
    ParamArray stylesNameValuePairs As String() _
)
Visual C++
public:
void ForStylesNot(
    ... array<String^>^ stylesNameValuePairs
)

Parameters

stylesNameValuePairs
Type: array< System..::..String >[]()[][]
The styles name/value pairs

Examples

ForStyles("backgroundColor=red","display=none")

See Also

HtmlWait Class
ForStylesNot Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStylesNot Method (Boolean, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStylesNot Method (Boolean, array<String>[]()[][])
HtmlWait Class Example See Also Send Feedback
Wait for a set of styles to no longer be true.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForStylesNot(
    bool useComputedStyles,
    params string[] stylesNameValuePairs
)
Visual Basic
Public Sub ForStylesNot ( _
    useComputedStyles As Boolean, _
    ParamArray stylesNameValuePairs As String() _
)
Visual C++
public:
void ForStylesNot(
    bool useComputedStyles,
    ... array<String^>^ stylesNameValuePairs
)

Parameters

useComputedStyles
Type: System..::..Boolean
True/False whether to use the computed style for this wait.
stylesNameValuePairs
Type: array< System..::..String >[]()[][]
The styles name/value pairs

Examples

ForStyles("backgroundColor=red","display=none")

See Also

HtmlWait Class
ForStylesNot Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStylesNot Method (Int32, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStylesNot Method (Int32, array<String>[]()[][])
HtmlWait Class Example See Also Send Feedback
Wait for a set of styles to no longer be true.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForStylesNot(
    int timeout,
    params string[] stylesNameValuePairs
)
Visual Basic
Public Sub ForStylesNot ( _
    timeout As Integer, _
    ParamArray stylesNameValuePairs As String() _
)
Visual C++
public:
void ForStylesNot(
    int timeout,
    ... array<String^>^ stylesNameValuePairs
)

Parameters

timeout
Type: System..::..Int32
The timeout to use.
stylesNameValuePairs
Type: array< System..::..String >[]()[][]
The styles name/value pairs

Examples

ForStyles("background-color=red","display=none")

See Also

HtmlWait Class
ForStylesNot Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForStylesNot Method (Int32, Boolean, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForStylesNot Method (Int32, Boolean, array<String>[]()[][])
HtmlWait Class Example See Also Send Feedback
Wait for a set of styles to no longer be true.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForStylesNot(
    int timeout,
    bool useComputedStyles,
    params string[] stylesNameValuePairs
)
Visual Basic
Public Sub ForStylesNot ( _
    timeout As Integer, _
    useComputedStyles As Boolean, _
    ParamArray stylesNameValuePairs As String() _
)
Visual C++
public:
void ForStylesNot(
    int timeout,
    bool useComputedStyles,
    ... array<String^>^ stylesNameValuePairs
)

Parameters

timeout
Type: System..::..Int32
The timeout to use.
useComputedStyles
Type: System..::..Boolean
True/False whether to use the computed style for this wait.
stylesNameValuePairs
Type: array< System..::..String >[]()[][]
The styles name/value pairs

Examples

ForStyles("backgroundColor=red","display=none")

See Also

HtmlWait Class
ForStylesNot Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForVisible Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForVisible()()()() | Wait for an element to be visible. HtmlControl.IsVisible is true. (Timeout = HtmlWait.Timeout)
Public method | ForVisible(Int32) | Wait for an element to be visible. HtmlControl.IsVisible is true.

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForVisible Method
HtmlWait Class See Also Send Feedback
Wait for an element to be visible. HtmlControl.IsVisible is true. (Timeout = HtmlWait.Timeout)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForVisible()
Visual Basic
Public Sub ForVisible
Visual C++
public:
void ForVisible()

See Also

HtmlWait Class
ForVisible Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForVisible Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForVisible Method (Int32)
HtmlWait Class See Also Send Feedback
Wait for an element to be visible. HtmlControl.IsVisible is true.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForVisible(
    int timeout
)
Visual Basic
Public Sub ForVisible ( _
    timeout As Integer _
)
Visual C++
public:
void ForVisible(
    int timeout
)

Parameters

timeout
Type: System..::..Int32
The timeout to use.

See Also

HtmlWait Class
ForVisible Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForVisibleNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForVisibleNot Method
HtmlWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForVisibleNot()()()() | Wait for an element to no longer be visible. HtmlControl.IsVisible is false. (Timeout = HtmlWait.Timeout)
Public method | ForVisibleNot(Int32) | Wait for an element to no longer be visible. HtmlControl.IsVisible is false.

See Also

HtmlWait Class
HtmlWait Members
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForVisibleNot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForVisibleNot Method
HtmlWait Class See Also Send Feedback
Wait for an element to no longer be visible. HtmlControl.IsVisible is false. (Timeout = HtmlWait.Timeout)

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForVisibleNot()
Visual Basic
Public Sub ForVisibleNot
Visual C++
public:
void ForVisibleNot()

See Also

HtmlWait Class
ForVisibleNot Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForVisibleNot Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait..::..ForVisibleNot Method (Int32)
HtmlWait Class See Also Send Feedback
Wait for an element to no longer be visible. HtmlControl.IsVisible is false.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForVisibleNot(
    int timeout
)
Visual Basic
Public Sub ForVisibleNot ( _
    timeout As Integer _
)
Visual C++
public:
void ForVisibleNot(
    int timeout
)

Parameters

timeout
Type: System..::..Int32
The timeout to use

See Also

HtmlWait Class
ForVisibleNot Overload
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlWait Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWait Properties
HtmlWait Class See Also Send Feedback

The HtmlWait type exposes the following members.

Properties

 | Name | Description
Public property | Timeout | Gets/Sets the timeout for all Wait.Forxx methods. Default=Settings.ExecuteCommandTimeout (Inherited from Wait.)

See Also

HtmlWait Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlWaitExtensions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWaitExtensions Members
HtmlWaitExtensions Class Methods See Also Send Feedback

The HtmlWaitExtensions type exposes the following members.

Methods

Name | Description
ForSelectedIndex | Wait for a specific selected index of the drop down.
ForSelectedValue | Wait for a specific selected value of the drop down.

See Also

HtmlWaitExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


HtmlWaitExtensions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWaitExtensions Methods
HtmlWaitExtensions Class See Also Send Feedback

The HtmlWaitExtensions type exposes the following members.

Methods

Name | Description
ForSelectedIndex | Wait for a specific selected index of the drop down.
ForSelectedValue | Wait for a specific selected value of the drop down.

See Also

HtmlWaitExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForSelectedIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWaitExtensions..::..ForSelectedIndex Method
HtmlWaitExtensions Class See Also Send Feedback
Wait for a specific selected index of the drop down.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void ForSelectedIndex(
    this HtmlWait wait,
    int index,
    int timeout
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub ForSelectedIndex ( _
    wait As HtmlWait, _
    index As Integer, _
    timeout As Integer _
)
Visual C++
[ExtensionAttribute]
public:
static void ForSelectedIndex(
    HtmlWait^ wait,
    int index,
    int timeout
)

Parameters

wait
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlWait
The wait object.
index
Type: System..::..Int32
The selection index to wait for.
timeout
Type: System..::..Int32
The timeout to use.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlWait. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlWaitExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ForSelectedValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlWaitExtensions..::..ForSelectedValue Method
HtmlWaitExtensions Class See Also Send Feedback
Wait for a specific selected value of the drop down.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void ForSelectedValue(
    this HtmlWait wait,
    string value,
    int timeout
)
Visual Basic
<ExtensionAttribute> _
Public Shared Sub ForSelectedValue ( _
    wait As HtmlWait, _
    value As String, _
    timeout As Integer _
)
Visual C++
[ExtensionAttribute]
public:
static void ForSelectedValue(
    HtmlWait^ wait,
    String^ value,
    int timeout
)

Parameters

wait
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlWait
The wait object.
value
Type: System..::..String
The selection value to wait for.
timeout
Type: System..::..Int32
The timeout to use.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type HtmlWait. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

HtmlWaitExtensions Class
ArtOfTest.WebAii.Controls.HtmlControls Namespace


ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace
Send Feedback
Namespace for the HTML assert types and classes.

Classes

 | Class | Description
Public class | AssertAttribute | Provides assert service for control attributes.
Public class | AssertCheck | Assert the checked state for a CheckBox or RadioButton input
Public class | AssertContent | Assert the content of an HtmlControl
Public class | AssertSelect | Assert methods for an HtmlSelect control
Public class | AssertStyle | Assert based on common html styles.
Public class | AssertTable | Provide HtmlTable specific asserts

Enumerations

 | Enumeration | Description
Public enumeration | HtmlStyleBox | CSS2 box formatting (Padding, margin..etc)
Public enumeration | HtmlStyleCategory | Style category
Public enumeration | HtmlStyleColorAndBackground | CSS2 common color and background styles. (Color, backgroundColor..etc)
Public enumeration | HtmlStyleDisplay | CSS2 common block formatting (Width, height...etc)
Public enumeration | HtmlStyleFont | CSS2 common font styles. (Family, size..etc)
Public enumeration | HtmlStyleList | CSS2 list styles (ListStyleType ...etc)
Public enumeration | HtmlStyleText | CSS2 common text formatting (Wordspacing, letterspacing ...etc.)
Public enumeration | HtmlStyleType | Style type (Computed vs Inline)
Public enumeration | HtmlVisibility | CSS2 element visibility
Public enumeration | NumberCompareType | Numerical compare type (Equals, less than..etc)
Public enumeration | StringCompareType | String compare type (Contains, exact ...etc.)


AssertAttribute Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute Members
AssertAttribute Class Constructors Methods Properties See Also Send Feedback

The AssertAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AssertAttribute()()()() | Create a new AssertAttribute object.
Public method | AssertAttribute(Boolean) | Initializes a new instance of the AssertAttribute class
Public method | AssertAttribute(HtmlControl) | Create a new AssertAttribute object and assign it to an HtmlControl.
Public method | AssertAttribute(HtmlControl, Boolean) | Initializes a new instance of the AssertAttribute class

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Assert if the specified attribute does not exist.
Public method | ExistsNot | Assert if the specified attribute does exist.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | Assert if the value of the specified attribute does not match.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertAttribute Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertAttribute Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute Constructor
AssertAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssertAttribute()()()() | Create a new AssertAttribute object.
Public method | AssertAttribute(Boolean) | Initializes a new instance of the AssertAttribute class
Public method | AssertAttribute(HtmlControl) | Create a new AssertAttribute object and assign it to an HtmlControl.
Public method | AssertAttribute(HtmlControl, Boolean) | Initializes a new instance of the AssertAttribute class

See Also

AssertAttribute Class
AssertAttribute Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertAttribute Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute Constructor
AssertAttribute Class See Also Send Feedback
Create a new AssertAttribute object.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertAttribute()
Visual Basic
Public Sub New
Visual C++
public:
AssertAttribute()

See Also

AssertAttribute Class
AssertAttribute Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertAttribute Constructor (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute Constructor (Boolean)
AssertAttribute Class See Also Send Feedback
Initializes a new instance of the AssertAttribute class

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertAttribute(
    bool throwOnFailure
)
Visual Basic
Public Sub New ( _
    throwOnFailure As Boolean _
)
Visual C++
public:
AssertAttribute(
    bool throwOnFailure
)

Parameters

throwOnFailure
Type: System..::..Boolean

[Missing <param name="throwOnFailure"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts.AssertAttribute.#ctor(System.Boolean)"]

See Also

AssertAttribute Class
AssertAttribute Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertAttribute Constructor (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute Constructor (HtmlControl)
AssertAttribute Class See Also Send Feedback
Create a new AssertAttribute object and assign it to an HtmlControl.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertAttribute(
    HtmlControl control
)
Visual Basic
Public Sub New ( _
    control As HtmlControl _
)
Visual C++
public:
AssertAttribute(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The target control to assign to this object.

See Also

AssertAttribute Class
AssertAttribute Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertAttribute Constructor (HtmlControl, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute Constructor (HtmlControl, Boolean)
AssertAttribute Class See Also Send Feedback
Initializes a new instance of the AssertAttribute class

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertAttribute(
    HtmlControl control,
    bool throwOnFailure
)
Visual Basic
Public Sub New ( _
    control As HtmlControl, _
    throwOnFailure As Boolean _
)
Visual C++
public:
AssertAttribute(
    HtmlControl^ control,
    bool throwOnFailure
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl

[Missing <param name="control"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts.AssertAttribute.#ctor(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl,System.Boolean)"]

throwOnFailure
Type: System..::..Boolean

[Missing <param name="throwOnFailure"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts.AssertAttribute.#ctor(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl,System.Boolean)"]

See Also

AssertAttribute Class
AssertAttribute Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertAttribute Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute Methods
AssertAttribute Class See Also Send Feedback

The AssertAttribute type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Assert if the specified attribute does not exist.
Public method | ExistsNot | Assert if the specified attribute does exist.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Value | Assert if the value of the specified attribute does not match.

See Also

AssertAttribute Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute..::..Assert Method
AssertAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertAttribute Class
AssertAttribute Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute..::..AssertString Method
AssertAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertAttribute Class
AssertAttribute Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Exists Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute..::..Exists Method
AssertAttribute Class See Also Send Feedback
Assert if the specified attribute does not exist.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Exists(
    string attributeName
)
Visual Basic
Public Function Exists ( _
    attributeName As String _
) As Boolean
Visual C++
public:
bool Exists(
    String^ attributeName
)

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertAttribute Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ExistsNot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute..::..ExistsNot Method
AssertAttribute Class See Also Send Feedback
Assert if the specified attribute does exist.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ExistsNot(
    string attributeName
)
Visual Basic
Public Function ExistsNot ( _
    attributeName As String _
) As Boolean
Visual C++
public:
bool ExistsNot(
    String^ attributeName
)

Parameters

attributeName
Type: System..::..String
The attribute name.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertAttribute Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Value Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute..::..Value Method
AssertAttribute Class See Also Send Feedback
Assert if the value of the specified attribute does not match.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Value(
    string attributeName,
    StringCompareType compare,
    string expectedValue
)
Visual Basic
Public Function Value ( _
    attributeName As String, _
    compare As StringCompareType, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool Value(
    String^ attributeName,
    StringCompareType compare,
    String^ expectedValue
)

Parameters

attributeName
Type: System..::..String
The attribute name to compare the value of.
compare
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertAttribute Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertAttribute Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertAttribute Properties
AssertAttribute Class See Also Send Feedback

The AssertAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertAttribute Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertCheck Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck Members
AssertCheck Class Constructors Methods Properties See Also Send Feedback

The AssertCheck type exposes the following members.

Constructors

 | Name | Description
Public method | AssertCheck()()()() | Create an new AssertCheck.
Public method | AssertCheck(Boolean) | Create a new AssertCheck
Public method | AssertCheck(HtmlInputControl) | Create a new AssertCheck

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFalse | Assert if it is checked.
Public method | IsTrue | Assert if it is not checked
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertCheck Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertCheck Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck Constructor
AssertCheck Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssertCheck()()()() | Create an new AssertCheck.
Public method | AssertCheck(Boolean) | Create a new AssertCheck
Public method | AssertCheck(HtmlInputControl) | Create a new AssertCheck

See Also

AssertCheck Class
AssertCheck Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertCheck Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck Constructor
AssertCheck Class See Also Send Feedback
Create an new AssertCheck.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertCheck()
Visual Basic
Public Sub New
Visual C++
public:
AssertCheck()

See Also

AssertCheck Class
AssertCheck Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertCheck Constructor (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck Constructor (Boolean)
AssertCheck Class See Also Send Feedback
Create a new AssertCheck

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertCheck(
    bool throwOnFailure
)
Visual Basic
Public Sub New ( _
    throwOnFailure As Boolean _
)
Visual C++
public:
AssertCheck(
    bool throwOnFailure
)

Parameters

throwOnFailure
Type: System..::..Boolean
Whether this object throws an exception when a check fails

See Also

AssertCheck Class
AssertCheck Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertCheck Constructor (HtmlInputControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck Constructor (HtmlInputControl)
AssertCheck Class See Also Send Feedback
Create a new AssertCheck

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertCheck(
    HtmlInputControl control
)
Visual Basic
Public Sub New ( _
    control As HtmlInputControl _
)
Visual C++
public:
AssertCheck(
    HtmlInputControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlInputControl
The control to perform assert against.

See Also

AssertCheck Class
AssertCheck Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertCheck Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck Methods
AssertCheck Class See Also Send Feedback

The AssertCheck type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFalse | Assert if it is checked.
Public method | IsTrue | Assert if it is not checked
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssertCheck Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck..::..Assert Method
AssertCheck Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertCheck Class
AssertCheck Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck..::..AssertString Method
AssertCheck Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertCheck Class
AssertCheck Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


IsFalse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck..::..IsFalse Method
AssertCheck Class See Also Send Feedback
Assert if it is checked.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFalse()
Visual Basic
Public Function IsFalse As Boolean
Visual C++
public:
bool IsFalse()

Return Value

True if the values match else will throw an AssertException.

See Also

AssertCheck Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


IsTrue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck..::..IsTrue Method
AssertCheck Class See Also Send Feedback
Assert if it is not checked

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTrue()
Visual Basic
Public Function IsTrue As Boolean
Visual C++
public:
bool IsTrue()

Return Value

True if the values match else will throw an AssertException.

See Also

AssertCheck Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertCheck Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertCheck Properties
AssertCheck Class See Also Send Feedback

The AssertCheck type exposes the following members.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertCheck Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertContent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent Members
AssertContent Class Constructors Methods Properties See Also Send Feedback

The AssertContent type exposes the following members.

Constructors

 | Name | Description
Public method | AssertContent()()()() | Create an new AssertContent.
Public method | AssertContent(HtmlControl) | Create a new AssertContent

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InnerMarkup | Assert the InnerMarkup of the element.
Public method | InnerText | Assert the InnerText of the element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OuterMarkup | Assert the OuterMarkup of the element.
Public method | StartTagContent | Assert the StartTagContent of the element.
Public method | TextContent | Assert the TextContent of the element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertContent Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertContent Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent Constructor
AssertContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssertContent()()()() | Create an new AssertContent.
Public method | AssertContent(HtmlControl) | Create a new AssertContent

See Also

AssertContent Class
AssertContent Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertContent Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent Constructor
AssertContent Class See Also Send Feedback
Create an new AssertContent.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertContent()
Visual Basic
Public Sub New
Visual C++
public:
AssertContent()

See Also

AssertContent Class
AssertContent Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertContent Constructor (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent Constructor (HtmlControl)
AssertContent Class See Also Send Feedback
Create a new AssertContent

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertContent(
    HtmlControl control
)
Visual Basic
Public Sub New ( _
    control As HtmlControl _
)
Visual C++
public:
AssertContent(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The control to perform assert against.

See Also

AssertContent Class
AssertContent Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertContent Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent Methods
AssertContent Class See Also Send Feedback

The AssertContent type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InnerMarkup | Assert the InnerMarkup of the element.
Public method | InnerText | Assert the InnerText of the element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OuterMarkup | Assert the OuterMarkup of the element.
Public method | StartTagContent | Assert the StartTagContent of the element.
Public method | TextContent | Assert the TextContent of the element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssertContent Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent..::..Assert Method
AssertContent Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertContent Class
AssertContent Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent..::..AssertString Method
AssertContent Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertContent Class
AssertContent Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


InnerMarkup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent..::..InnerMarkup Method
AssertContent Class See Also Send Feedback
Assert the InnerMarkup of the element.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool InnerMarkup(
    StringCompareType compareType,
    string expectedValue
)
Visual Basic
Public Function InnerMarkup ( _
    compareType As StringCompareType, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool InnerMarkup(
    StringCompareType compareType,
    String^ expectedValue
)

Parameters

compareType
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertContent Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


InnerText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent..::..InnerText Method
AssertContent Class See Also Send Feedback
Assert the InnerText of the element.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool InnerText(
    StringCompareType compareType,
    string expectedValue
)
Visual Basic
Public Function InnerText ( _
    compareType As StringCompareType, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool InnerText(
    StringCompareType compareType,
    String^ expectedValue
)

Parameters

compareType
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertContent Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


OuterMarkup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent..::..OuterMarkup Method
AssertContent Class See Also Send Feedback
Assert the OuterMarkup of the element.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool OuterMarkup(
    StringCompareType compareType,
    string expectedValue
)
Visual Basic
Public Function OuterMarkup ( _
    compareType As StringCompareType, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool OuterMarkup(
    StringCompareType compareType,
    String^ expectedValue
)

Parameters

compareType
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertContent Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


StartTagContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent..::..StartTagContent Method
AssertContent Class See Also Send Feedback
Assert the StartTagContent of the element.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StartTagContent(
    StringCompareType compareType,
    string expectedValue
)
Visual Basic
Public Function StartTagContent ( _
    compareType As StringCompareType, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool StartTagContent(
    StringCompareType compareType,
    String^ expectedValue
)

Parameters

compareType
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertContent Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


TextContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent..::..TextContent Method
AssertContent Class See Also Send Feedback
Assert the TextContent of the element.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool TextContent(
    StringCompareType compareType,
    string expectedValue
)
Visual Basic
Public Function TextContent ( _
    compareType As StringCompareType, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool TextContent(
    StringCompareType compareType,
    String^ expectedValue
)

Parameters

compareType
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertContent Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertContent Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertContent Properties
AssertContent Class See Also Send Feedback

The AssertContent type exposes the following members.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertContent Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertSelect Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect Members
AssertSelect Class Constructors Methods Properties See Also Send Feedback

The AssertSelect type exposes the following members.

Constructors

 | Name | Description
Public method | AssertSelect()()()() | Create a new AssertSelect object.
Public method | AssertSelect(HtmlSelect) | Create a new AssertSelect object and assign it to an existing control.
Public method | AssertSelect(HtmlSelect, Boolean) | Create a new AssertSelect object and assign it to an existing control.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ItemsCountIs | Assert if the number of options in this HtmlSelect does not match.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectedIndex | Assert if the selected index does not match.
Public method | SelectedText | Assert if the selected text does not match.
Public method | SelectedValue | Assert if the selected value does not match.
Public method | TextExists | Assert if a particular text value does not exist in the HtmlSelect options list.
Public method | TextExistsNot | Assert if a particular text value does exist in the HtmlSelect options list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValueExists | Assert if a particular option value does not exist in the HtmlSelect options list.
Public method | ValueExistsNot | Assert if a particular option value does exist in the HtmlSelect options list.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertSelect Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect Constructor
AssertSelect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssertSelect()()()() | Create a new AssertSelect object.
Public method | AssertSelect(HtmlSelect) | Create a new AssertSelect object and assign it to an existing control.
Public method | AssertSelect(HtmlSelect, Boolean) | Create a new AssertSelect object and assign it to an existing control.

See Also

AssertSelect Class
AssertSelect Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertSelect Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect Constructor
AssertSelect Class See Also Send Feedback
Create a new AssertSelect object.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertSelect()
Visual Basic
Public Sub New
Visual C++
public:
AssertSelect()

See Also

AssertSelect Class
AssertSelect Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertSelect Constructor (HtmlSelect)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect Constructor (HtmlSelect)
AssertSelect Class See Also Send Feedback
Create a new AssertSelect object and assign it to an existing control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertSelect(
    HtmlSelect select
)
Visual Basic
Public Sub New ( _
    select As HtmlSelect _
)
Visual C++
public:
AssertSelect(
    HtmlSelect^ select
)

Parameters

select
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlSelect
The target HtmlSelect to assign to this AssertSelect object.

See Also

AssertSelect Class
AssertSelect Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertSelect Constructor (HtmlSelect, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect Constructor (HtmlSelect, Boolean)
AssertSelect Class See Also Send Feedback
Create a new AssertSelect object and assign it to an existing control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertSelect(
    HtmlSelect select,
    bool throwOnFailure
)
Visual Basic
Public Sub New ( _
    select As HtmlSelect, _
    throwOnFailure As Boolean _
)
Visual C++
public:
AssertSelect(
    HtmlSelect^ select,
    bool throwOnFailure
)

Parameters

select
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlSelect
The target HtmlSelect to assign to this AssertSelect object.
throwOnFailure
Type: System..::..Boolean
Whether this object throws an exception if a check fails

See Also

AssertSelect Class
AssertSelect Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertSelect Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect Methods
AssertSelect Class See Also Send Feedback

The AssertSelect type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ItemsCountIs | Assert if the number of options in this HtmlSelect does not match.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SelectedIndex | Assert if the selected index does not match.
Public method | SelectedText | Assert if the selected text does not match.
Public method | SelectedValue | Assert if the selected value does not match.
Public method | TextExists | Assert if a particular text value does not exist in the HtmlSelect options list.
Public method | TextExistsNot | Assert if a particular text value does exist in the HtmlSelect options list.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValueExists | Assert if a particular option value does not exist in the HtmlSelect options list.
Public method | ValueExistsNot | Assert if a particular option value does exist in the HtmlSelect options list.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..Assert Method
AssertSelect Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertSelect Class
AssertSelect Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..AssertString Method
AssertSelect Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertSelect Class
AssertSelect Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ItemsCountIs Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..ItemsCountIs Method
AssertSelect Class See Also Send Feedback
Assert if the number of options in this HtmlSelect does not match.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ItemsCountIs(
    NumberCompareType compareType,
    int expectedValue
)
Visual Basic
Public Function ItemsCountIs ( _
    compareType As NumberCompareType, _
    expectedValue As Integer _
) As Boolean
Visual C++
public:
bool ItemsCountIs(
    NumberCompareType compareType,
    int expectedValue
)

Parameters

compareType
Type: ArtOfTest.Common..::..NumberCompareType
The integer compare type.
expectedValue
Type: System..::..Int32
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


SelectedIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..SelectedIndex Method
AssertSelect Class See Also Send Feedback
Assert if the selected index does not match.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SelectedIndex(
    NumberCompareType compareType,
    int index
)
Visual Basic
Public Function SelectedIndex ( _
    compareType As NumberCompareType, _
    index As Integer _
) As Boolean
Visual C++
public:
bool SelectedIndex(
    NumberCompareType compareType,
    int index
)

Parameters

compareType
Type: ArtOfTest.Common..::..NumberCompareType
The number compare type.
index
Type: System..::..Int32
The expected index.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


SelectedText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..SelectedText Method
AssertSelect Class See Also Send Feedback
Assert if the selected text does not match.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SelectedText(
    StringCompareType compareType,
    string expectedText
)
Visual Basic
Public Function SelectedText ( _
    compareType As StringCompareType, _
    expectedText As String _
) As Boolean
Visual C++
public:
bool SelectedText(
    StringCompareType compareType,
    String^ expectedText
)

Parameters

compareType
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedText
Type: System..::..String
The expected text.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


SelectedValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..SelectedValue Method
AssertSelect Class See Also Send Feedback
Assert if the selected value does not match.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SelectedValue(
    StringCompareType compareType,
    string expectedValue
)
Visual Basic
Public Function SelectedValue ( _
    compareType As StringCompareType, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool SelectedValue(
    StringCompareType compareType,
    String^ expectedValue
)

Parameters

compareType
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


TextExists Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..TextExists Method
AssertSelect Class See Also Send Feedback
Assert if a particular text value does not exist in the HtmlSelect options list.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool TextExists(
    string expectedText
)
Visual Basic
Public Function TextExists ( _
    expectedText As String _
) As Boolean
Visual C++
public:
bool TextExists(
    String^ expectedText
)

Parameters

expectedText
Type: System..::..String

[Missing <param name="expectedText"/> documentation for "M:ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts.AssertSelect.TextExists(System.String)"]

Return Value

True if the values match else will throw an AssertException.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


TextExistsNot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..TextExistsNot Method
AssertSelect Class See Also Send Feedback
Assert if a particular text value does exist in the HtmlSelect options list.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool TextExistsNot(
    string expectedText
)
Visual Basic
Public Function TextExistsNot ( _
    expectedText As String _
) As Boolean
Visual C++
public:
bool TextExistsNot(
    String^ expectedText
)

Parameters

expectedText
Type: System..::..String
The expected text to verify it does not exist.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ValueExists Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..ValueExists Method
AssertSelect Class See Also Send Feedback
Assert if a particular option value does not exist in the HtmlSelect options list.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ValueExists(
    string expectedValue
)
Visual Basic
Public Function ValueExists ( _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool ValueExists(
    String^ expectedValue
)

Parameters

expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ValueExistsNot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect..::..ValueExistsNot Method
AssertSelect Class See Also Send Feedback
Assert if a particular option value does exist in the HtmlSelect options list.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ValueExistsNot(
    string expectedValue
)
Visual Basic
Public Function ValueExistsNot ( _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool ValueExistsNot(
    String^ expectedValue
)

Parameters

expectedValue
Type: System..::..String
The expected value to verify it does not exist.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertSelect Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertSelect Properties
AssertSelect Class See Also Send Feedback

The AssertSelect type exposes the following members.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertSelect Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertStyle Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle Members
AssertStyle Class Constructors Methods Properties See Also Send Feedback

The AssertStyle type exposes the following members.

Constructors

 | Name | Description
Public method | AssertStyle()()()() | Create a new AssertStyle object.
Public method | AssertStyle(Boolean) | Create a new AssertStyle object.
Public method | AssertStyle(HtmlControl) | Create a new AssertStyle object passing it the target control.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Box(HtmlStyleBox, String) | Assert Box styles.
Public method | Box(HtmlStyleBox, String, HtmlStyleType) | Assert Box styles.
Public method | Box(HtmlStyleBox, String, HtmlStyleType, StringCompareType) | Assert Box styles.
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String) | Assert Color/Background styles.
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType) | Assert Color/Background styles.
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType, StringCompareType) | Assert Color/Background styles.
Public method | Display(HtmlStyleDisplay, String) | Assert Display styles.
Public method | Display(HtmlStyleDisplay, String, HtmlStyleType) | Assert Display styles.
Public method | Display(HtmlStyleDisplay, String, HtmlStyleType, StringCompareType) | Assert Display styles.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Font(HtmlStyleFont, String) | Assert Font styles.
Public method | Font(HtmlStyleFont, String, HtmlStyleType) | Assert Font styles.
Public method | Font(HtmlStyleFont, String, HtmlStyleType, StringCompareType) | Assert Font styles.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List(HtmlStyleList, String) | Assert List styles.
Public method | List(HtmlStyleList, String, HtmlStyleType) | Assert List styles.
Public method | List(HtmlStyleList, String, HtmlStyleType, StringCompareType) | Assert List styles.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Text(HtmlStyleText, String) | Assert Text styles.
Public method | Text(HtmlStyleText, String, HtmlStyleType) | Assert Text styles.
Public method | Text(HtmlStyleText, String, HtmlStyleType, StringCompareType) | Assert Text styles.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultStyleType | Gets or sets the default style type to use (Inline or Computed). Defaults to Computed.
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertStyle Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertStyle Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle Constructor
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssertStyle()()()() | Create a new AssertStyle object.
Public method | AssertStyle(Boolean) | Create a new AssertStyle object.
Public method | AssertStyle(HtmlControl) | Create a new AssertStyle object passing it the target control.

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertStyle Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle Constructor
AssertStyle Class See Also Send Feedback
Create a new AssertStyle object.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertStyle()
Visual Basic
Public Sub New
Visual C++
public:
AssertStyle()

See Also

AssertStyle Class
AssertStyle Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertStyle Constructor (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle Constructor (Boolean)
AssertStyle Class See Also Send Feedback
Create a new AssertStyle object.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertStyle(
    bool throwOnFailure
)
Visual Basic
Public Sub New ( _
    throwOnFailure As Boolean _
)
Visual C++
public:
AssertStyle(
    bool throwOnFailure
)

Parameters

throwOnFailure
Type: System..::..Boolean
Whether this object throws an exception is a check fails

See Also

AssertStyle Class
AssertStyle Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertStyle Constructor (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle Constructor (HtmlControl)
AssertStyle Class See Also Send Feedback
Create a new AssertStyle object passing it the target control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertStyle(
    HtmlControl control
)
Visual Basic
Public Sub New ( _
    control As HtmlControl _
)
Visual C++
public:
AssertStyle(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The target control to assign to this AssertStyle object.

See Also

AssertStyle Class
AssertStyle Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertStyle Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle Methods
AssertStyle Class See Also Send Feedback

The AssertStyle type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | Box(HtmlStyleBox, String) | Assert Box styles.
Public method | Box(HtmlStyleBox, String, HtmlStyleType) | Assert Box styles.
Public method | Box(HtmlStyleBox, String, HtmlStyleType, StringCompareType) | Assert Box styles.
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String) | Assert Color/Background styles.
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType) | Assert Color/Background styles.
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType, StringCompareType) | Assert Color/Background styles.
Public method | Display(HtmlStyleDisplay, String) | Assert Display styles.
Public method | Display(HtmlStyleDisplay, String, HtmlStyleType) | Assert Display styles.
Public method | Display(HtmlStyleDisplay, String, HtmlStyleType, StringCompareType) | Assert Display styles.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Font(HtmlStyleFont, String) | Assert Font styles.
Public method | Font(HtmlStyleFont, String, HtmlStyleType) | Assert Font styles.
Public method | Font(HtmlStyleFont, String, HtmlStyleType, StringCompareType) | Assert Font styles.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | List(HtmlStyleList, String) | Assert List styles.
Public method | List(HtmlStyleList, String, HtmlStyleType) | Assert List styles.
Public method | List(HtmlStyleList, String, HtmlStyleType, StringCompareType) | Assert List styles.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Text(HtmlStyleText, String) | Assert Text styles.
Public method | Text(HtmlStyleText, String, HtmlStyleType) | Assert Text styles.
Public method | Text(HtmlStyleText, String, HtmlStyleType, StringCompareType) | Assert Text styles.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssertStyle Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Assert Method
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..AssertString Method
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Box Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Box Method
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Box(HtmlStyleBox, String) | Assert Box styles.
Public method | Box(HtmlStyleBox, String, HtmlStyleType) | Assert Box styles.
Public method | Box(HtmlStyleBox, String, HtmlStyleType, StringCompareType) | Assert Box styles.

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Box Method (HtmlStyleBox, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Box Method (HtmlStyleBox, String)
AssertStyle Class See Also Send Feedback
Assert Box styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Box(
    HtmlStyleBox styleName,
    string expectedValue
)
Visual Basic
Public Function Box ( _
    styleName As HtmlStyleBox, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool Box(
    HtmlStyleBox styleName,
    String^ expectedValue
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleBox
The style name.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Box Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Box Method (HtmlStyleBox, String, HtmlStyleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Box Method (HtmlStyleBox, String, HtmlStyleType)
AssertStyle Class See Also Send Feedback
Assert Box styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Box(
    HtmlStyleBox styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Visual Basic
Public Function Box ( _
    styleName As HtmlStyleBox, _
    expectedValue As String, _
    styleType As HtmlStyleType _
) As Boolean
Visual C++
public:
bool Box(
    HtmlStyleBox styleName,
    String^ expectedValue,
    HtmlStyleType styleType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleBox
The style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Box Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Box Method (HtmlStyleBox, String, HtmlStyleType, StringCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Box Method (HtmlStyleBox, String, HtmlStyleType, StringCompareType)
AssertStyle Class See Also Send Feedback
Assert Box styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Box(
    HtmlStyleBox styleName,
    string expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)
Visual Basic
Public Function Box ( _
    styleName As HtmlStyleBox, _
    expectedValue As String, _
    styleType As HtmlStyleType, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool Box(
    HtmlStyleBox styleName,
    String^ expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleBox
The style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.
compareType
Type: ArtOfTest.Common..::..StringCompareType
String compare type.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Box Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ColorAndBackground Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..ColorAndBackground Method
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String) | Assert Color/Background styles.
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType) | Assert Color/Background styles.
Public method | ColorAndBackground(HtmlStyleColorAndBackground, String, HtmlStyleType, StringCompareType) | Assert Color/Background styles.

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ColorAndBackground Method (HtmlStyleColorAndBackground, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..ColorAndBackground Method (HtmlStyleColorAndBackground, String)
AssertStyle Class See Also Send Feedback
Assert Color/Background styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ColorAndBackground(
    HtmlStyleColorAndBackground styleName,
    string expectedValue
)
Visual Basic
Public Function ColorAndBackground ( _
    styleName As HtmlStyleColorAndBackground, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool ColorAndBackground(
    HtmlStyleColorAndBackground styleName,
    String^ expectedValue
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleColorAndBackground
The color or background style.
expectedValue
Type: System..::..String
The expected style value.

Return Value

True if the values match else will throw an AssertException.

Remarks

Automatically detects colors and will perform the proper validation regardless of the format of the color encoding attached to the style e.g. "red" will match "#FF0000".

See Also

AssertStyle Class
ColorAndBackground Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ColorAndBackground Method (HtmlStyleColorAndBackground, String, HtmlStyleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..ColorAndBackground Method (HtmlStyleColorAndBackground, String, HtmlStyleType)
AssertStyle Class See Also Send Feedback
Assert Color/Background styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ColorAndBackground(
    HtmlStyleColorAndBackground styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Visual Basic
Public Function ColorAndBackground ( _
    styleName As HtmlStyleColorAndBackground, _
    expectedValue As String, _
    styleType As HtmlStyleType _
) As Boolean
Visual C++
public:
bool ColorAndBackground(
    HtmlStyleColorAndBackground styleName,
    String^ expectedValue,
    HtmlStyleType styleType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleColorAndBackground
The color or background style.
expectedValue
Type: System..::..String
The expected style value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.

Return Value

True if the values match else will throw an AssertException.

Remarks

Automatically detects colors and will perform the proper validation regardless of the format of the color encoding attached to the style e.g. "red" will match "#FF0000".

See Also

AssertStyle Class
ColorAndBackground Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ColorAndBackground Method (HtmlStyleColorAndBackground, String, HtmlStyleType, StringCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..ColorAndBackground Method (HtmlStyleColorAndBackground, String, HtmlStyleType, StringCompareType)
AssertStyle Class See Also Send Feedback
Assert Color/Background styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ColorAndBackground(
    HtmlStyleColorAndBackground styleName,
    string expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)
Visual Basic
Public Function ColorAndBackground ( _
    styleName As HtmlStyleColorAndBackground, _
    expectedValue As String, _
    styleType As HtmlStyleType, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool ColorAndBackground(
    HtmlStyleColorAndBackground styleName,
    String^ expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleColorAndBackground
The color or background style.
expectedValue
Type: System..::..String
The expected style value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.
compareType
Type: ArtOfTest.Common..::..StringCompareType
String Compare Type

Return Value

True if the values match else will throw an AssertException.

Remarks

Automatically detects colors and will perform the proper validation regardless of the format of the color encoding attached to the style e.g. "red" will match "#FF0000".

See Also

AssertStyle Class
ColorAndBackground Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Display Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Display Method
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Display(HtmlStyleDisplay, String) | Assert Display styles.
Public method | Display(HtmlStyleDisplay, String, HtmlStyleType) | Assert Display styles.
Public method | Display(HtmlStyleDisplay, String, HtmlStyleType, StringCompareType) | Assert Display styles.

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Display Method (HtmlStyleDisplay, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Display Method (HtmlStyleDisplay, String)
AssertStyle Class See Also Send Feedback
Assert Display styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Display(
    HtmlStyleDisplay styleName,
    string expectedValue
)
Visual Basic
Public Function Display ( _
    styleName As HtmlStyleDisplay, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool Display(
    HtmlStyleDisplay styleName,
    String^ expectedValue
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleDisplay
The style name.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Display Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Display Method (HtmlStyleDisplay, String, HtmlStyleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Display Method (HtmlStyleDisplay, String, HtmlStyleType)
AssertStyle Class See Also Send Feedback
Assert Display styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Display(
    HtmlStyleDisplay styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Visual Basic
Public Function Display ( _
    styleName As HtmlStyleDisplay, _
    expectedValue As String, _
    styleType As HtmlStyleType _
) As Boolean
Visual C++
public:
bool Display(
    HtmlStyleDisplay styleName,
    String^ expectedValue,
    HtmlStyleType styleType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleDisplay
The font style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Display Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Display Method (HtmlStyleDisplay, String, HtmlStyleType, StringCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Display Method (HtmlStyleDisplay, String, HtmlStyleType, StringCompareType)
AssertStyle Class See Also Send Feedback
Assert Display styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Display(
    HtmlStyleDisplay styleName,
    string expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)
Visual Basic
Public Function Display ( _
    styleName As HtmlStyleDisplay, _
    expectedValue As String, _
    styleType As HtmlStyleType, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool Display(
    HtmlStyleDisplay styleName,
    String^ expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleDisplay
The font style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.
compareType
Type: ArtOfTest.Common..::..StringCompareType
String compare type

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Display Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Font Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Font Method
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Font(HtmlStyleFont, String) | Assert Font styles.
Public method | Font(HtmlStyleFont, String, HtmlStyleType) | Assert Font styles.
Public method | Font(HtmlStyleFont, String, HtmlStyleType, StringCompareType) | Assert Font styles.

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Font Method (HtmlStyleFont, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Font Method (HtmlStyleFont, String)
AssertStyle Class See Also Send Feedback
Assert Font styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Font(
    HtmlStyleFont styleName,
    string expectedValue
)
Visual Basic
Public Function Font ( _
    styleName As HtmlStyleFont, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool Font(
    HtmlStyleFont styleName,
    String^ expectedValue
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleFont
The font style name.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Font Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Font Method (HtmlStyleFont, String, HtmlStyleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Font Method (HtmlStyleFont, String, HtmlStyleType)
AssertStyle Class See Also Send Feedback
Assert Font styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Font(
    HtmlStyleFont styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Visual Basic
Public Function Font ( _
    styleName As HtmlStyleFont, _
    expectedValue As String, _
    styleType As HtmlStyleType _
) As Boolean
Visual C++
public:
bool Font(
    HtmlStyleFont styleName,
    String^ expectedValue,
    HtmlStyleType styleType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleFont
The font style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Font Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Font Method (HtmlStyleFont, String, HtmlStyleType, StringCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Font Method (HtmlStyleFont, String, HtmlStyleType, StringCompareType)
AssertStyle Class See Also Send Feedback
Assert Font styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Font(
    HtmlStyleFont styleName,
    string expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)
Visual Basic
Public Function Font ( _
    styleName As HtmlStyleFont, _
    expectedValue As String, _
    styleType As HtmlStyleType, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool Font(
    HtmlStyleFont styleName,
    String^ expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleFont
The font style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.
compareType
Type: ArtOfTest.Common..::..StringCompareType
String compare type.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Font Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


List Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..List Method
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | List(HtmlStyleList, String) | Assert List styles.
Public method | List(HtmlStyleList, String, HtmlStyleType) | Assert List styles.
Public method | List(HtmlStyleList, String, HtmlStyleType, StringCompareType) | Assert List styles.

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


List Method (HtmlStyleList, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..List Method (HtmlStyleList, String)
AssertStyle Class See Also Send Feedback
Assert List styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool List(
    HtmlStyleList styleName,
    string expectedValue
)
Visual Basic
Public Function List ( _
    styleName As HtmlStyleList, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool List(
    HtmlStyleList styleName,
    String^ expectedValue
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleList
The style name.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
List Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


List Method (HtmlStyleList, String, HtmlStyleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..List Method (HtmlStyleList, String, HtmlStyleType)
AssertStyle Class See Also Send Feedback
Assert List styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool List(
    HtmlStyleList styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Visual Basic
Public Function List ( _
    styleName As HtmlStyleList, _
    expectedValue As String, _
    styleType As HtmlStyleType _
) As Boolean
Visual C++
public:
bool List(
    HtmlStyleList styleName,
    String^ expectedValue,
    HtmlStyleType styleType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleList
The style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
List Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


List Method (HtmlStyleList, String, HtmlStyleType, StringCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..List Method (HtmlStyleList, String, HtmlStyleType, StringCompareType)
AssertStyle Class See Also Send Feedback
Assert List styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool List(
    HtmlStyleList styleName,
    string expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)
Visual Basic
Public Function List ( _
    styleName As HtmlStyleList, _
    expectedValue As String, _
    styleType As HtmlStyleType, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool List(
    HtmlStyleList styleName,
    String^ expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleList
The style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.
compareType
Type: ArtOfTest.Common..::..StringCompareType
String compare type

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
List Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Text Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Text Method
AssertStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Text(HtmlStyleText, String) | Assert Text styles.
Public method | Text(HtmlStyleText, String, HtmlStyleType) | Assert Text styles.
Public method | Text(HtmlStyleText, String, HtmlStyleType, StringCompareType) | Assert Text styles.

See Also

AssertStyle Class
AssertStyle Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Text Method (HtmlStyleText, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Text Method (HtmlStyleText, String)
AssertStyle Class See Also Send Feedback
Assert Text styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Text(
    HtmlStyleText styleName,
    string expectedValue
)
Visual Basic
Public Function Text ( _
    styleName As HtmlStyleText, _
    expectedValue As String _
) As Boolean
Visual C++
public:
bool Text(
    HtmlStyleText styleName,
    String^ expectedValue
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleText
The style name.
expectedValue
Type: System..::..String
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Text Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Text Method (HtmlStyleText, String, HtmlStyleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Text Method (HtmlStyleText, String, HtmlStyleType)
AssertStyle Class See Also Send Feedback
Assert Text styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Text(
    HtmlStyleText styleName,
    string expectedValue,
    HtmlStyleType styleType
)
Visual Basic
Public Function Text ( _
    styleName As HtmlStyleText, _
    expectedValue As String, _
    styleType As HtmlStyleType _
) As Boolean
Visual C++
public:
bool Text(
    HtmlStyleText styleName,
    String^ expectedValue,
    HtmlStyleType styleType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleText
The style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Text Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Text Method (HtmlStyleText, String, HtmlStyleType, StringCompareType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..Text Method (HtmlStyleText, String, HtmlStyleType, StringCompareType)
AssertStyle Class See Also Send Feedback
Assert Text styles.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Text(
    HtmlStyleText styleName,
    string expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)
Visual Basic
Public Function Text ( _
    styleName As HtmlStyleText, _
    expectedValue As String, _
    styleType As HtmlStyleType, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool Text(
    HtmlStyleText styleName,
    String^ expectedValue,
    HtmlStyleType styleType,
    StringCompareType compareType
)

Parameters

styleName
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleText
The style name.
expectedValue
Type: System..::..String
The expected value.
styleType
Type: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts..::..HtmlStyleType
Either computed or inline.
compareType
Type: ArtOfTest.Common..::..StringCompareType
String compare type

Return Value

True if the values match else will throw an AssertException.

See Also

AssertStyle Class
Text Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertStyle Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle Properties
AssertStyle Class See Also Send Feedback

The AssertStyle type exposes the following members.

Properties

 | Name | Description
Public property | DefaultStyleType | Gets or sets the default style type to use (Inline or Computed). Defaults to Computed.
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertStyle Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


DefaultStyleType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertStyle..::..DefaultStyleType Property
AssertStyle Class See Also Send Feedback
Gets or sets the default style type to use (Inline or Computed). Defaults to Computed.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlStyleType DefaultStyleType { get; set; }
Visual Basic
Public Property DefaultStyleType As HtmlStyleType
    Get
    Set
Visual C++
public:
property HtmlStyleType DefaultStyleType {
    HtmlStyleType get ();
    void set (HtmlStyleType value);
}

See Also

AssertStyle Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertTable Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable Members
AssertTable Class Constructors Methods Properties See Also Send Feedback

The AssertTable type exposes the following members.

Constructors

 | Name | Description
Public method | AssertTable()()()() | Create a new table assert object.
Public method | AssertTable(HtmlTable) | Create a new table assert and assigned it to an HtmlTable control.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | ColumnCount | Asserts if the column count does not match.
Public method | ColumnRange | Asserts if the column count is inside/outside the specified range.
Public method | Contains | Asserts that a certain text appears in the table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RowCount | Asserts if the table row count does not match.
Public method | RowRange | Assert if the row count is inside/outside the specified range.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertTable Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertTable Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable Constructor
AssertTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AssertTable()()()() | Create a new table assert object.
Public method | AssertTable(HtmlTable) | Create a new table assert and assigned it to an HtmlTable control.

See Also

AssertTable Class
AssertTable Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertTable Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable Constructor
AssertTable Class See Also Send Feedback
Create a new table assert object.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertTable()
Visual Basic
Public Sub New
Visual C++
public:
AssertTable()

See Also

AssertTable Class
AssertTable Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertTable Constructor (HtmlTable)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable Constructor (HtmlTable)
AssertTable Class See Also Send Feedback
Create a new table assert and assigned it to an HtmlTable control.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AssertTable(
    HtmlTable table
)
Visual Basic
Public Sub New ( _
    table As HtmlTable _
)
Visual C++
public:
AssertTable(
    HtmlTable^ table
)

Parameters

table
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlTable
The HtmlTable to set as the target

See Also

AssertTable Class
AssertTable Overload
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertTable Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable Methods
AssertTable Class See Also Send Feedback

The AssertTable type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | ColumnCount | Asserts if the column count does not match.
Public method | ColumnRange | Asserts if the column count is inside/outside the specified range.
Public method | Contains | Asserts that a certain text appears in the table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RowCount | Asserts if the table row count does not match.
Public method | RowRange | Assert if the row count is inside/outside the specified range.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssertTable Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable..::..Assert Method
AssertTable Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertTable Class
AssertTable Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable..::..AssertString Method
AssertTable Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertTable Class
AssertTable Members
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ColumnCount Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable..::..ColumnCount Method
AssertTable Class See Also Send Feedback
Asserts if the column count does not match.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ColumnCount(
    NumberCompareType compareType,
    int expected
)
Visual Basic
Public Function ColumnCount ( _
    compareType As NumberCompareType, _
    expected As Integer _
) As Boolean
Visual C++
public:
bool ColumnCount(
    NumberCompareType compareType,
    int expected
)

Parameters

compareType
Type: ArtOfTest.Common..::..NumberCompareType
The number compare type.
expected
Type: System..::..Int32
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertTable Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ColumnRange Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable..::..ColumnRange Method
AssertTable Class See Also Send Feedback
Asserts if the column count is inside/outside the specified range.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ColumnRange(
    NumberRangeCompareType compareType,
    int lowerEnd,
    int upperEnd
)
Visual Basic
Public Function ColumnRange ( _
    compareType As NumberRangeCompareType, _
    lowerEnd As Integer, _
    upperEnd As Integer _
) As Boolean
Visual C++
public:
bool ColumnRange(
    NumberRangeCompareType compareType,
    int lowerEnd,
    int upperEnd
)

Parameters

compareType
Type: ArtOfTest.Common..::..NumberRangeCompareType
In/Out of range.
lowerEnd
Type: System..::..Int32
Lower end of the range to compare.
upperEnd
Type: System..::..Int32
Upper end of the range to compare.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertTable Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


Contains Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable..::..Contains Method
AssertTable Class See Also Send Feedback
Asserts that a certain text appears in the table.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Contains(
    StringCompareType compareType,
    string expectedString
)
Visual Basic
Public Function Contains ( _
    compareType As StringCompareType, _
    expectedString As String _
) As Boolean
Visual C++
public:
bool Contains(
    StringCompareType compareType,
    String^ expectedString
)

Parameters

compareType
Type: ArtOfTest.Common..::..StringCompareType
The string compare type.
expectedString
Type: System..::..String
The expected string

Return Value

True if the values match else will throw an AssertException.

See Also

AssertTable Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


RowCount Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable..::..RowCount Method
AssertTable Class See Also Send Feedback
Asserts if the table row count does not match.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RowCount(
    NumberCompareType compareType,
    int expected
)
Visual Basic
Public Function RowCount ( _
    compareType As NumberCompareType, _
    expected As Integer _
) As Boolean
Visual C++
public:
bool RowCount(
    NumberCompareType compareType,
    int expected
)

Parameters

compareType
Type: ArtOfTest.Common..::..NumberCompareType
The number compare type.
expected
Type: System..::..Int32
The expected value.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertTable Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


RowRange Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable..::..RowRange Method
AssertTable Class See Also Send Feedback
Assert if the row count is inside/outside the specified range.

Namespace: ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RowRange(
    NumberRangeCompareType range,
    int lowerEnd,
    int upperEnd
)
Visual Basic
Public Function RowRange ( _
    range As NumberRangeCompareType, _
    lowerEnd As Integer, _
    upperEnd As Integer _
) As Boolean
Visual C++
public:
bool RowRange(
    NumberRangeCompareType range,
    int lowerEnd,
    int upperEnd
)

Parameters

range
Type: ArtOfTest.Common..::..NumberRangeCompareType
In/Out of range.
lowerEnd
Type: System..::..Int32
Lower end of range to compare.
upperEnd
Type: System..::..Int32
Upper end of range to compare.

Return Value

True if the values match else will throw an AssertException.

See Also

AssertTable Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


AssertTable Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AssertTable Properties
AssertTable Class See Also Send Feedback

The AssertTable type exposes the following members.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

AssertTable Class
ArtOfTest.WebAii.Controls.HtmlControls.HtmlAsserts Namespace


ArtOfTest.WebAii.Controls.Xaml Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Controls.Xaml Namespace
Send Feedback
Namespace for all the XAML element wrapper controls.

Classes

 | Class | Description
Public class | XamlControlHelper |

Interfaces

 | Interface | Description
Public interface | IAutoCompleteBox | Represents interface for the Xaml AutoCompleteBox control wrappers.
Public interface | IButton | Represents interface for the Xaml Button control wrappers.
Public interface | IButtonBase | Represents interface for the Xaml ButtonBase control wrappers.
Public interface | ICalendar | Represents interface for the Xaml Calendar control wrappers.
Public interface | ICalendarButton | Represents interface for the Xaml CalendarButton control wrappers.
Public interface | ICalendarDayButton | Represents interface for the Xaml CalendarDayButton control wrappers.
Public interface | ICheckBox | Represents interface for the Xaml CheckBox control wrappers.
Public interface | IComboBox | Represents interface for the Xaml ComboBox control wrappers.
Public interface | IComboBoxItem | Represents interface for the Xaml ComboBoxItem control wrappers.
Public interface | IContentControl | Represents interface for the Xaml ContentControl control wrappers.
Public interface | IControl | Represents the XAML Control interface.
Public interface | IDataGrid | Represents interface for the Xaml DataGrid control wrappers.
Public interface | IDataGridCell | Represents interface for the Xaml DataGridCell control wrappers.
Public interface | IDataGridColumnHeader | Represents interface for the Xaml DataGridColumnHeader control wrappers.
Public interface | IDataGridRow | Represents interface for the Xaml DataGridRow control wrappers.
Public interface | IDatePicker | Represents interface for the Xaml DatePicker control wrappers.
Public interface | IDatePickerTextBox | Represents interface for the Xaml DatePickerTextBox control wrappers.
Public interface | IFrameworkElement |
Public interface | IHyperlinkButton | Represents interface for the Xaml HyperlinkButton control wrappers.
Public interface | IListBox | Represents interface for the Xaml ListBox control wrappers.
Public interface | IListBoxItem | Represents interface for the Xaml ListBoxItem control wrappers.
Public interface | IPasswordBox | Represents interface for the Xaml PasswordBox control wrappers.
Public interface | IPopup | Represents interface for the Xaml Popup control wrappers.
Public interface | IRadioButton | Represents interface for the Xaml RadioButton control wrappers.
Public interface | IRangeBase | Represents the Xaml RangeBase control wrapper interface.
Public interface | IRepeatButton | Represents interface for the Xaml RepeatButton control wrappers.
Public interface | IRichTextBox | Represents interface for the Xaml RichTextBox control wrapper.
Public interface | ISelector | Represents interface for the Xaml Selector control wrappers.
Public interface | ISlider | Represents interface for the Xaml Slider control wrappers.
Public interface | ITabControl | Represents interface for the Xaml TabControl control wrappers.
Public interface | ITabItem | Represents interface for the Xaml TabItem control wrappers.
Public interface | ITextBlock | Represents interface for the Xaml TextBlock control wrappers.
Public interface | ITextBox | Represents interface for the Xaml TextBox control wrappers.
Public interface | IToggleButton | Represents interface for the Xaml ToggleButton control wrappers.
Public interface | ITreeView | Represents interface for the Xaml TreeView control wrappers.
Public interface | ITreeViewItem | Represents the TreeViewItem for SL/Wpf control wrapper interface.
Public interface | IVirtualizingStackPanel | Represents interface for the Xaml VirtualizingStackPanel control wrappers.

Enumerations

 | Enumeration | Description
Public enumeration | CalendarNavigationDirection | Represents navigation direction enumeration.


IAutoCompleteBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutoCompleteBox Members
IAutoCompleteBox Interface Methods Properties See Also Send Feedback

The IAutoCompleteBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetText | Sets or types a new text into the AutoCompleteBox.
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | Selector | Get the drop down list box element holding the items to select.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IAutoCompleteBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IAutoCompleteBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutoCompleteBox Methods
IAutoCompleteBox Interface See Also Send Feedback

The IAutoCompleteBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetText | Sets or types a new text into the AutoCompleteBox.
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IAutoCompleteBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Select Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutoCompleteBox..::..Select Method
IAutoCompleteBox Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.

See Also

IAutoCompleteBox Interface
IAutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml Namespace


Select Method (Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutoCompleteBox..::..Select Method (Boolean, Int32)
IAutoCompleteBox Interface See Also Send Feedback
Selects item in the drop down if open.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Select(
    bool simulateRealUser,
    int itemIndex
)
Visual Basic
Sub Select ( _
    simulateRealUser As Boolean, _
    itemIndex As Integer _
)
Visual C++
void Select(
    bool simulateRealUser,
    int itemIndex
)

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates real click, otherwise changes selection.
itemIndex
Type: System..::..Int32

[Missing <param name="itemIndex"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IAutoCompleteBox.Select(System.Boolean,System.Int32)"]

See Also

IAutoCompleteBox Interface
Select Overload
ArtOfTest.WebAii.Controls.Xaml Namespace


Select Method (Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutoCompleteBox..::..Select Method (Boolean, String)
IAutoCompleteBox Interface See Also Send Feedback
Selects item in the drop down if open.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Select(
    bool simulateRealUser,
    string itemText
)
Visual Basic
Sub Select ( _
    simulateRealUser As Boolean, _
    itemText As String _
)
Visual C++
void Select(
    bool simulateRealUser,
    String^ itemText
)

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates real click, otherwise changes selection.
itemText
Type: System..::..String
The text of the item to select.

See Also

IAutoCompleteBox Interface
Select Overload
ArtOfTest.WebAii.Controls.Xaml Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutoCompleteBox..::..SetText Method
IAutoCompleteBox Interface See Also Send Feedback
Sets or types a new text into the AutoCompleteBox.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
)

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the text.
text
Type: System..::..String
The text to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key

See Also

IAutoCompleteBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IAutoCompleteBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutoCompleteBox Properties
IAutoCompleteBox Interface See Also Send Feedback

The IAutoCompleteBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | Selector | Get the drop down list box element holding the items to select.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IAutoCompleteBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Selector Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutoCompleteBox..::..Selector Property
IAutoCompleteBox Interface See Also Send Feedback
Get the drop down list box element holding the items to select.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IListBox Selector { get; }
Visual Basic
ReadOnly Property Selector As IListBox
    Get
Visual C++
property IListBox^ Selector {
    IListBox^ get ();
}

See Also

IAutoCompleteBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IButton Members
IButton Interface Methods Properties See Also Send Feedback

The IButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsPressed | Get/set whether the button is pressed. (Inherited from IButtonBase.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IButton Methods
IButton Interface See Also Send Feedback

The IButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IButton Properties
IButton Interface See Also Send Feedback

The IButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsPressed | Get/set whether the button is pressed. (Inherited from IButtonBase.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IButtonBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IButtonBase Members
IButtonBase Interface Methods Properties See Also Send Feedback

The IButtonBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsPressed | Get/set whether the button is pressed.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IButtonBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IButtonBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IButtonBase Methods
IButtonBase Interface See Also Send Feedback

The IButtonBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IButtonBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IButtonBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IButtonBase Properties
IButtonBase Interface See Also Send Feedback

The IButtonBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsPressed | Get/set whether the button is pressed.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IButtonBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsPressed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IButtonBase..::..IsPressed Property
IButtonBase Interface See Also Send Feedback
Get/set whether the button is pressed.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsPressed { get; set; }
Visual Basic
Property IsPressed As Boolean
    Get
    Set
Visual C++
property bool IsPressed {
    bool get ();
    void set (bool value);
}

See Also

IButtonBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar Members
ICalendar Interface Methods Properties See Also Send Feedback

The ICalendar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Navigate | Navigate the Calendar depending on the direction.
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SelectDates | Selects dates in the calendar.
Public method | SelectMonth | Simulates user selecting the specified month.
Public method | SelectYear | Simulates user selecting the specified year.
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | ZoomOut | Simulates the user zooming the calendar out via a header button click.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | HeaderButton | Get the Calendar Header navigation button element.
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | MonthViewElement | Get the Calendar MonthView element.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | NextButton | Get the Calendar Next navigation button element.
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | PreviousButton | Get the Calendar Previous navigation button element.
Public property | SelectedDate | Get/set the Calendar SelectedDate.
Public property | SelectedDates | Get the Calendar SelectedDates collection.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)
Public property | YearViewElement | Get the Calendar YearView element.

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar Methods
ICalendar Interface See Also Send Feedback

The ICalendar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Navigate | Navigate the Calendar depending on the direction.
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SelectDates | Selects dates in the calendar.
Public method | SelectMonth | Simulates user selecting the specified month.
Public method | SelectYear | Simulates user selecting the specified year.
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | ZoomOut | Simulates the user zooming the calendar out via a header button click.

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Navigate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..Navigate Method
ICalendar Interface See Also Send Feedback
Navigate the Calendar depending on the direction.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Navigate(
    CalendarNavigationDirection direction
)
Visual Basic
Sub Navigate ( _
    direction As CalendarNavigationDirection _
)
Visual C++
void Navigate(
    CalendarNavigationDirection direction
)

Parameters

direction
Type: ArtOfTest.WebAii.Controls.Xaml..::..CalendarNavigationDirection
The direction to navigate to.

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectDates Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..SelectDates Method
ICalendar Interface See Also Send Feedback
Selects dates in the calendar.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SelectDates(
    bool simulateRealUser,
    List<DateTime> dates,
    bool isInDatePicker
)
Visual Basic
Sub SelectDates ( _
    simulateRealUser As Boolean, _
    dates As List(Of DateTime), _
    isInDatePicker As Boolean _
)
Visual C++
void SelectDates(
    bool simulateRealUser,
    List<DateTime>^ dates,
    bool isInDatePicker
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user clicking on the day elements.
dates
Type: System.Collections.Generic..::..List <(Of <(<' DateTime >)>)>
The calendar dates to select.
isInDatePicker
Type: System..::..Boolean
Whether to update the parent date picker if any too.

Remarks

In simulate real user and date picker mode a single date selection is possible only.

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectMonth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..SelectMonth Method
ICalendar Interface See Also Send Feedback
Simulates user selecting the specified month.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SelectMonth(
    int month
)
Visual Basic
Sub SelectMonth ( _
    month As Integer _
)
Visual C++
void SelectMonth(
    int month
)

Parameters

month
Type: System..::..Int32
The month to select.

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectYear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..SelectYear Method
ICalendar Interface See Also Send Feedback
Simulates user selecting the specified year.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SelectYear(
    int year
)
Visual Basic
Sub SelectYear ( _
    year As Integer _
)
Visual C++
void SelectYear(
    int year
)

Parameters

year
Type: System..::..Int32
The year to select.

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ZoomOut Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..ZoomOut Method
ICalendar Interface See Also Send Feedback
Simulates the user zooming the calendar out via a header button click.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void ZoomOut()
Visual Basic
Sub ZoomOut
Visual C++
void ZoomOut()

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar Properties
ICalendar Interface See Also Send Feedback

The ICalendar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | HeaderButton | Get the Calendar Header navigation button element.
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | MonthViewElement | Get the Calendar MonthView element.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | NextButton | Get the Calendar Next navigation button element.
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | PreviousButton | Get the Calendar Previous navigation button element.
Public property | SelectedDate | Get/set the Calendar SelectedDate.
Public property | SelectedDates | Get the Calendar SelectedDates collection.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)
Public property | YearViewElement | Get the Calendar YearView element.

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


HeaderButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..HeaderButton Property
ICalendar Interface See Also Send Feedback
Get the Calendar Header navigation button element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement HeaderButton { get; }
Visual Basic
ReadOnly Property HeaderButton As FrameworkElement
    Get
Visual C++
property FrameworkElement^ HeaderButton {
    FrameworkElement^ get ();
}

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


MonthViewElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..MonthViewElement Property
ICalendar Interface See Also Send Feedback
Get the Calendar MonthView element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement MonthViewElement { get; }
Visual Basic
ReadOnly Property MonthViewElement As FrameworkElement
    Get
Visual C++
property FrameworkElement^ MonthViewElement {
    FrameworkElement^ get ();
}

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


NextButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..NextButton Property
ICalendar Interface See Also Send Feedback
Get the Calendar Next navigation button element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement NextButton { get; }
Visual Basic
ReadOnly Property NextButton As FrameworkElement
    Get
Visual C++
property FrameworkElement^ NextButton {
    FrameworkElement^ get ();
}

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


PreviousButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..PreviousButton Property
ICalendar Interface See Also Send Feedback
Get the Calendar Previous navigation button element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement PreviousButton { get; }
Visual Basic
ReadOnly Property PreviousButton As FrameworkElement
    Get
Visual C++
property FrameworkElement^ PreviousButton {
    FrameworkElement^ get ();
}

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectedDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..SelectedDate Property
ICalendar Interface See Also Send Feedback
Get/set the Calendar SelectedDate.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Nullable<DateTime> SelectedDate { get; set; }
Visual Basic
Property SelectedDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectedDates Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..SelectedDates Property
ICalendar Interface See Also Send Feedback
Get the Calendar SelectedDates collection.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
SelectedDatesCollection SelectedDates { get; }
Visual Basic
ReadOnly Property SelectedDates As SelectedDatesCollection
    Get
Visual C++
property SelectedDatesCollection^ SelectedDates {
    SelectedDatesCollection^ get ();
}

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


YearViewElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendar..::..YearViewElement Property
ICalendar Interface See Also Send Feedback
Get the Calendar YearView element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement YearViewElement { get; }
Visual Basic
ReadOnly Property YearViewElement As FrameworkElement
    Get
Visual C++
property FrameworkElement^ YearViewElement {
    FrameworkElement^ get ();
}

See Also

ICalendar Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendarButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendarButton Members
ICalendarButton Interface Methods Properties See Also Send Feedback

The ICalendarButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsPressed | Get/set whether the button is pressed. (Inherited from IButtonBase.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ICalendarButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendarButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendarButton Methods
ICalendarButton Interface See Also Send Feedback

The ICalendarButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ICalendarButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendarButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendarButton Properties
ICalendarButton Interface See Also Send Feedback

The ICalendarButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsPressed | Get/set whether the button is pressed. (Inherited from IButtonBase.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ICalendarButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendarDayButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendarDayButton Members
ICalendarDayButton Interface Methods Properties See Also Send Feedback

The ICalendarDayButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsPressed | Get/set whether the button is pressed. (Inherited from IButtonBase.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ICalendarDayButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendarDayButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendarDayButton Methods
ICalendarDayButton Interface See Also Send Feedback

The ICalendarDayButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ICalendarDayButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICalendarDayButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICalendarDayButton Properties
ICalendarDayButton Interface See Also Send Feedback

The ICalendarDayButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsPressed | Get/set whether the button is pressed. (Inherited from IButtonBase.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ICalendarDayButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICheckBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICheckBox Members
ICheckBox Interface Methods Properties See Also Send Feedback

The ICheckBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from IToggleButton.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | Toggle | Toggle the state of the button. (Inherited from IToggleButton.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from IToggleButton.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CheckIcon | Get the check icon element. (Inherited from IToggleButton.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsChecked | Get/set whether the ToggleButton is checked. (Inherited from IToggleButton.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | IsThreeState | Get/set whether the ToggleButton is in three state. (Inherited from IToggleButton.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ICheckBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICheckBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICheckBox Methods
ICheckBox Interface See Also Send Feedback

The ICheckBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from IToggleButton.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | Toggle | Toggle the state of the button. (Inherited from IToggleButton.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from IToggleButton.)

See Also

ICheckBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ICheckBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICheckBox Properties
ICheckBox Interface See Also Send Feedback

The ICheckBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CheckIcon | Get the check icon element. (Inherited from IToggleButton.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsChecked | Get/set whether the ToggleButton is checked. (Inherited from IToggleButton.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | IsThreeState | Get/set whether the ToggleButton is in three state. (Inherited from IToggleButton.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ICheckBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IComboBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox Members
IComboBox Interface Methods Properties See Also Send Feedback

The IComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | OpenDropDown | Open the combobox drop down popup.
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsDropDownOpen | Get/set whether the drop down is open.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | ItemsPopup | Get the popup containing the list with combo box items.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SelectedIndex | Get/set the selected index. (Inherited from ISelector.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IComboBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IComboBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox Methods
IComboBox Interface See Also Send Feedback

The IComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | OpenDropDown | Open the combobox drop down popup.
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IComboBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


OpenDropDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..OpenDropDown Method
IComboBox Interface See Also Send Feedback
Open the combobox drop down popup.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void OpenDropDown(
    bool simulateRealUser
)
Visual Basic
Sub OpenDropDown ( _
    simulateRealUser As Boolean _
)
Visual C++
void OpenDropDown(
    bool simulateRealUser
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user click action or just change the drop down state via automation property.

See Also

IComboBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectItemByIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..SelectItemByIndex Method
IComboBox Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.

See Also

IComboBox Interface
IComboBox Members
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectItemByIndex Method (Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..SelectItemByIndex Method (Boolean, Int32)
IComboBox Interface See Also Send Feedback
Select a combobox item by given index.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SelectItemByIndex(
    bool simulateRealUser,
    int index
)
Visual Basic
Sub SelectItemByIndex ( _
    simulateRealUser As Boolean, _
    index As Integer _
)
Visual C++
void SelectItemByIndex(
    bool simulateRealUser,
    int index
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected index.
index
Type: System..::..Int32
The index of the item to select.

See Also

IComboBox Interface
SelectItemByIndex Overload
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectItemByIndex Method (Boolean, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..SelectItemByIndex Method (Boolean, Int32, Boolean)
IComboBox Interface See Also Send Feedback
Select a combobox item by given index.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SelectItemByIndex(
    bool simulateRealUser,
    int index,
    bool openDropDownBeforeSelection
)
Visual Basic
Sub SelectItemByIndex ( _
    simulateRealUser As Boolean, _
    index As Integer, _
    openDropDownBeforeSelection As Boolean _
)
Visual C++
void SelectItemByIndex(
    bool simulateRealUser,
    int index,
    bool openDropDownBeforeSelection
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected index.
index
Type: System..::..Int32
The index of the item to select.
openDropDownBeforeSelection
Type: System..::..Boolean
Whether to open the dropdown automatically.

See Also

IComboBox Interface
SelectItemByIndex Overload
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectItemByText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..SelectItemByText Method
IComboBox Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.

See Also

IComboBox Interface
IComboBox Members
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectItemByText Method (Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..SelectItemByText Method (Boolean, String)
IComboBox Interface See Also Send Feedback
Select a combo box item by given text.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SelectItemByText(
    bool simulateRealUser,
    string text
)
Visual Basic
Sub SelectItemByText ( _
    simulateRealUser As Boolean, _
    text As String _
)
Visual C++
void SelectItemByText(
    bool simulateRealUser,
    String^ text
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected state of the item.
text
Type: System..::..String
The text of the item to select.

See Also

IComboBox Interface
SelectItemByText Overload
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectItemByText Method (Boolean, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..SelectItemByText Method (Boolean, String, Boolean)
IComboBox Interface See Also Send Feedback
Select a combo box item by given text.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SelectItemByText(
    bool simulateRealUser,
    string text,
    bool openDropDownBeforeSelection
)
Visual Basic
Sub SelectItemByText ( _
    simulateRealUser As Boolean, _
    text As String, _
    openDropDownBeforeSelection As Boolean _
)
Visual C++
void SelectItemByText(
    bool simulateRealUser,
    String^ text,
    bool openDropDownBeforeSelection
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected state of the item.
text
Type: System..::..String
The text of the item to select.
openDropDownBeforeSelection
Type: System..::..Boolean
Whether to open the dropdown automatically.

See Also

IComboBox Interface
SelectItemByText Overload
ArtOfTest.WebAii.Controls.Xaml Namespace


IComboBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox Properties
IComboBox Interface See Also Send Feedback

The IComboBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsDropDownOpen | Get/set whether the drop down is open.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | ItemsPopup | Get the popup containing the list with combo box items.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SelectedIndex | Get/set the selected index. (Inherited from ISelector.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IComboBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsDropDownOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..IsDropDownOpen Property
IComboBox Interface See Also Send Feedback
Get/set whether the drop down is open.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsDropDownOpen { get; set; }
Visual Basic
Property IsDropDownOpen As Boolean
    Get
    Set
Visual C++
property bool IsDropDownOpen {
    bool get ();
    void set (bool value);
}

See Also

IComboBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ItemsPopup Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBox..::..ItemsPopup Property
IComboBox Interface See Also Send Feedback
Get the popup containing the list with combo box items.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement ItemsPopup { get; }
Visual Basic
ReadOnly Property ItemsPopup As FrameworkElement
    Get
Visual C++
property FrameworkElement^ ItemsPopup {
    FrameworkElement^ get ();
}

See Also

IComboBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IComboBoxItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBoxItem Members
IComboBoxItem Interface Methods Properties See Also Send Feedback

The IComboBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsSelected | Get/set whether the item is selected. (Inherited from IListBoxItem.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | ItemText | Get the item text.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParentComboBox | Get the parent ComboBox element.
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IComboBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IComboBoxItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBoxItem Methods
IComboBoxItem Interface See Also Send Feedback

The IComboBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IComboBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IComboBoxItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBoxItem Properties
IComboBoxItem Interface See Also Send Feedback

The IComboBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsSelected | Get/set whether the item is selected. (Inherited from IListBoxItem.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | ItemText | Get the item text.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParentComboBox | Get the parent ComboBox element.
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IComboBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ItemText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBoxItem..::..ItemText Property
IComboBoxItem Interface See Also Send Feedback
Get the item text.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string ItemText { get; }
Visual Basic
ReadOnly Property ItemText As String
    Get
Visual C++
property String^ ItemText {
    String^ get ();
}

See Also

IComboBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ParentComboBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IComboBoxItem..::..ParentComboBox Property
IComboBoxItem Interface See Also Send Feedback
Get the parent ComboBox element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IComboBox ParentComboBox { get; }
Visual Basic
ReadOnly Property ParentComboBox As IComboBox
    Get
Visual C++
property IComboBox^ ParentComboBox {
    IComboBox^ get ();
}

See Also

IComboBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IContentControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IContentControl Members
IContentControl Interface Methods Properties See Also Send Feedback

The IContentControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IContentControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IContentControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IContentControl Methods
IContentControl Interface See Also Send Feedback

The IContentControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IContentControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IContentControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IContentControl Properties
IContentControl Interface See Also Send Feedback

The IContentControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IContentControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IControl Members
IControl Interface Methods Properties See Also Send Feedback

The IControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IControl Methods
IControl Interface See Also Send Feedback

The IControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IControl Properties
IControl Interface See Also Send Feedback

The IControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IControl..::..IsEnabled Property
IControl Interface See Also Send Feedback
Get/set whether the control is enabled.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsEnabled { get; set; }
Visual Basic
Property IsEnabled As Boolean
    Get
    Set
Visual C++
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

See Also

IControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGrid Members
IDataGrid Interface Methods Properties See Also Send Feedback

The IDataGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ColumnHeaderElements | Get the list of DataGrid column header elements.
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | RowElements | Get the list of DataGrid row elements.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDataGrid Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGrid Methods
IDataGrid Interface See Also Send Feedback

The IDataGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IDataGrid Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGrid Properties
IDataGrid Interface See Also Send Feedback

The IDataGrid type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ColumnHeaderElements | Get the list of DataGrid column header elements.
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | RowElements | Get the list of DataGrid row elements.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDataGrid Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ColumnHeaderElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGrid..::..ColumnHeaderElements Property
IDataGrid Interface See Also Send Feedback
Get the list of DataGrid column header elements.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<IDataGridColumnHeader> ColumnHeaderElements { get; }
Visual Basic
ReadOnly Property ColumnHeaderElements As IList(Of IDataGridColumnHeader)
    Get
Visual C++
property IList<IDataGridColumnHeader^>^ ColumnHeaderElements {
    IList<IDataGridColumnHeader^>^ get ();
}

See Also

IDataGrid Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


RowElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGrid..::..RowElements Property
IDataGrid Interface See Also Send Feedback
Get the list of DataGrid row elements.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<IDataGridRow> RowElements { get; }
Visual Basic
ReadOnly Property RowElements As IList(Of IDataGridRow)
    Get
Visual C++
property IList<IDataGridRow^>^ RowElements {
    IList<IDataGridRow^>^ get ();
}

See Also

IDataGrid Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridCell Members
IDataGridCell Interface Methods Properties See Also Send Feedback

The IDataGridCell type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CellText | Get the DataGridCell text.
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDataGridCell Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridCell Methods
IDataGridCell Interface See Also Send Feedback

The IDataGridCell type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IDataGridCell Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridCell Properties
IDataGridCell Interface See Also Send Feedback

The IDataGridCell type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CellText | Get the DataGridCell text.
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDataGridCell Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


CellText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridCell..::..CellText Property
IDataGridCell Interface See Also Send Feedback
Get the DataGridCell text.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string CellText { get; }
Visual Basic
ReadOnly Property CellText As String
    Get
Visual C++
property String^ CellText {
    String^ get ();
}

See Also

IDataGridCell Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridColumnHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridColumnHeader Members
IDataGridColumnHeader Interface Methods Properties See Also Send Feedback

The IDataGridColumnHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDataGridColumnHeader Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridColumnHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridColumnHeader Methods
IDataGridColumnHeader Interface See Also Send Feedback

The IDataGridColumnHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IDataGridColumnHeader Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridColumnHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridColumnHeader Properties
IDataGridColumnHeader Interface See Also Send Feedback

The IDataGridColumnHeader type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDataGridColumnHeader Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridRow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridRow Members
IDataGridRow Interface Methods Properties See Also Send Feedback

The IDataGridRow type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CellElements | Get the list of DataGridCell elements.
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | RowData | Get a summary of the row data content.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDataGridRow Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridRow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridRow Methods
IDataGridRow Interface See Also Send Feedback

The IDataGridRow type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IDataGridRow Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDataGridRow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridRow Properties
IDataGridRow Interface See Also Send Feedback

The IDataGridRow type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CellElements | Get the list of DataGridCell elements.
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | RowData | Get a summary of the row data content.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDataGridRow Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


CellElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridRow..::..CellElements Property
IDataGridRow Interface See Also Send Feedback
Get the list of DataGridCell elements.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<IDataGridCell> CellElements { get; }
Visual Basic
ReadOnly Property CellElements As IList(Of IDataGridCell)
    Get
Visual C++
property IList<IDataGridCell^>^ CellElements {
    IList<IDataGridCell^>^ get ();
}

See Also

IDataGridRow Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


RowData Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDataGridRow..::..RowData Property
IDataGridRow Interface See Also Send Feedback
Get a summary of the row data content.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string[] RowData { get; }
Visual Basic
ReadOnly Property RowData As String()
    Get
Visual C++
property array<String^>^ RowData {
    array<String^>^ get ();
}

See Also

IDataGridRow Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDatePicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker Members
IDatePicker Interface Methods Properties See Also Send Feedback

The IDatePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | OpenCalendarPopup | Open the picker calendar popup.
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetText | Sets new text into the date picker text box.
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsDropDownOpen | Get/set whether the drop down is open.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | PickerTextBox | Get the picker text box element.
Public property | SelectedDate | Get the DatePicker selected date.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | TogglePopupButton | Get the picker toggle popup button element.
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDatePicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker Methods
IDatePicker Interface See Also Send Feedback

The IDatePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | OpenCalendarPopup | Open the picker calendar popup.
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetText | Sets new text into the date picker text box.
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


OpenCalendarPopup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker..::..OpenCalendarPopup Method
IDatePicker Interface See Also Send Feedback
Open the picker calendar popup.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void OpenCalendarPopup(
    bool simulateRealUser
)
Visual Basic
Sub OpenCalendarPopup ( _
    simulateRealUser As Boolean _
)
Visual C++
void OpenCalendarPopup(
    bool simulateRealUser
)

Parameters

simulateRealUser
Type: System..::..Boolean
True to find the button and click on it, false to change the state via automation property.

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker..::..SetText Method
IDatePicker Interface See Also Send Feedback
Sets new text into the date picker text box.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate typing into the text box or just replace its text.
text
Type: System..::..String
The text to type or set.
keyPressTime
Type: System..::..Int32
The delay between each press when typing.
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key when typing.

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDatePicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker Properties
IDatePicker Interface See Also Send Feedback

The IDatePicker type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsDropDownOpen | Get/set whether the drop down is open.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | PickerTextBox | Get the picker text box element.
Public property | SelectedDate | Get the DatePicker selected date.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | TogglePopupButton | Get the picker toggle popup button element.
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsDropDownOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker..::..IsDropDownOpen Property
IDatePicker Interface See Also Send Feedback
Get/set whether the drop down is open.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsDropDownOpen { get; set; }
Visual Basic
Property IsDropDownOpen As Boolean
    Get
    Set
Visual C++
property bool IsDropDownOpen {
    bool get ();
    void set (bool value);
}

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


PickerTextBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker..::..PickerTextBox Property
IDatePicker Interface See Also Send Feedback
Get the picker text box element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IDatePickerTextBox PickerTextBox { get; }
Visual Basic
ReadOnly Property PickerTextBox As IDatePickerTextBox
    Get
Visual C++
property IDatePickerTextBox^ PickerTextBox {
    IDatePickerTextBox^ get ();
}

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectedDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker..::..SelectedDate Property
IDatePicker Interface See Also Send Feedback
Get the DatePicker selected date.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Nullable<DateTime> SelectedDate { get; set; }
Visual Basic
Property SelectedDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


TogglePopupButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePicker..::..TogglePopupButton Property
IDatePicker Interface See Also Send Feedback
Get the picker toggle popup button element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IButton TogglePopupButton { get; }
Visual Basic
ReadOnly Property TogglePopupButton As IButton
    Get
Visual C++
property IButton^ TogglePopupButton {
    IButton^ get ();
}

See Also

IDatePicker Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDatePickerTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePickerTextBox Members
IDatePickerTextBox Interface Methods Properties See Also Send Feedback

The IDatePickerTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox. (Inherited from ITextBox.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBox via automation property. (Inherited from ITextBox.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDatePickerTextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDatePickerTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePickerTextBox Methods
IDatePickerTextBox Interface See Also Send Feedback

The IDatePickerTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox. (Inherited from ITextBox.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IDatePickerTextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IDatePickerTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePickerTextBox Properties
IDatePickerTextBox Interface See Also Send Feedback

The IDatePickerTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBox via automation property. (Inherited from ITextBox.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IDatePickerTextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Text Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDatePickerTextBox..::..Text Property
IDatePickerTextBox Interface See Also Send Feedback

Overload List

 | Name | Description
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBox via automation property. (Inherited from ITextBox.)

See Also

IDatePickerTextBox Interface
IDatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml Namespace


IFrameworkElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement Members
IFrameworkElement Interface Methods Properties See Also Send Feedback

The IFrameworkElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference |
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) |
Public method | GetAutomationProperty |
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) |
Public method | GetPropertyTypeSafe |
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) |
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo |
Public method | SetFocus | Sets keyboard focus to this element
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty |
Public method | SetProxy |
Public method | SetUid |
Public method | SetXamlTag |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex |
Public property | ActualHeight |
Public property | ActualWidth |
Public property | ComputedVisibility |
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find |
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name |
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text.
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements.
Public property | TextLiteralContent | Gets the literal text content of this framework element if any.
Public property | ToolTipText |
Public property | Uid | Unique identifier for this control in its application. For internal use.
Public property | User |
Public property | Wait |

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IFrameworkElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement Methods
IFrameworkElement Interface See Also Send Feedback

The IFrameworkElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference |
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) |
Public method | GetAutomationProperty |
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) |
Public method | GetPropertyTypeSafe |
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) |
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo |
Public method | SetFocus | Sets keyboard focus to this element
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty |
Public method | SetProxy |
Public method | SetUid |
Public method | SetXamlTag |

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..AssignReference Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void AssignReference(
    AutomationReference reference
)
Visual Basic
Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
void AssignReference(
    AutomationReference^ reference
)

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference

[Missing <param name="reference"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


CastAs(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..CastAs<(Of <(<'T>)>)> Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.CastAs``1"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
T CastAs<T>()
where T : IFrameworkElement
Visual Basic
Function CastAs(Of T As IFrameworkElement) As T
Visual C++
generic<typename T>
where T : IFrameworkElement
T CastAs()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.CastAs``1"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.CastAs``1"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


GetAutomationProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..GetAutomationProperty Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetAutomationProperty(System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
AutomationProperty GetAutomationProperty(
    string name
)
Visual Basic
Function GetAutomationProperty ( _
    name As String _
) As AutomationProperty
Visual C++
AutomationProperty^ GetAutomationProperty(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetAutomationProperty(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetAutomationProperty(System.String)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


GetProperty(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..GetProperty<(Of <(<'T>)>)> Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetProperty``1(System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
T GetProperty<T>(
    string name
)
Visual Basic
Function GetProperty(Of T) ( _
    name As String _
) As T
Visual C++
generic<typename T>
T GetProperty(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetProperty``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetProperty``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetProperty``1(System.String)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


GetPropertyTypeSafe Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..GetPropertyTypeSafe Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetPropertyTypeSafe(System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Object GetPropertyTypeSafe(
    string name
)
Visual Basic
Function GetPropertyTypeSafe ( _
    name As String _
) As Object
Visual C++
Object^ GetPropertyTypeSafe(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetPropertyTypeSafe(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.GetPropertyTypeSafe(System.String)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Parent(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..Parent<(Of <(<'T>)>)> Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.Parent``1"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
T Parent<T>()
where T : IFrameworkElement
Visual Basic
Function Parent(Of T As IFrameworkElement) As T
Visual C++
generic<typename T>
where T : IFrameworkElement
T Parent()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.Parent``1"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.Parent``1"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetFindInfo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..SetFindInfo Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetFindInfo(ArtOfTest.WebAii.Silverlight.VisualFindInfo)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetFindInfo(
    VisualFindInfo findInfo
)
Visual Basic
Sub SetFindInfo ( _
    findInfo As VisualFindInfo _
)
Visual C++
void SetFindInfo(
    VisualFindInfo^ findInfo
)

Parameters

findInfo
Type: ArtOfTest.WebAii.Silverlight..::..VisualFindInfo

[Missing <param name="findInfo"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetFindInfo(ArtOfTest.WebAii.Silverlight.VisualFindInfo)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetFocus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..SetFocus Method
IFrameworkElement Interface See Also Send Feedback
Sets keyboard focus to this element

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetFocus()
Visual Basic
Sub SetFocus
Visual C++
void SetFocus()

Return Value

Whether focus was successfully set to this element

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..SetProperty Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetProperty(System.String,System.Object)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetProperty(
    string propertyName,
    Object value
)
Visual Basic
Sub SetProperty ( _
    propertyName As String, _
    value As Object _
)
Visual C++
void SetProperty(
    String^ propertyName,
    Object^ value
)

Parameters

propertyName
Type: System..::..String

[Missing <param name="propertyName"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetProperty(System.String,System.Object)"]

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetProperty(System.String,System.Object)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetProxy Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..SetProxy Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetProxy(System.Boolean)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetProxy(
    bool isProxy
)
Visual Basic
Sub SetProxy ( _
    isProxy As Boolean _
)
Visual C++
void SetProxy(
    bool isProxy
)

Parameters

isProxy
Type: System..::..Boolean

[Missing <param name="isProxy"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetProxy(System.Boolean)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetUid Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..SetUid Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetUid(System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetUid(
    int uid
)
Visual Basic
Sub SetUid ( _
    uid As Integer _
)
Visual C++
void SetUid(
    int uid
)

Parameters

uid
Type: System..::..Int32

[Missing <param name="uid"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetUid(System.Int32)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetXamlTag Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..SetXamlTag Method
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetXamlTag(System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetXamlTag(
    string tag
)
Visual Basic
Sub SetXamlTag ( _
    tag As String _
)
Visual C++
void SetXamlTag(
    String^ tag
)

Parameters

tag
Type: System..::..String

[Missing <param name="tag"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.SetXamlTag(System.String)"]

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IFrameworkElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement Properties
IFrameworkElement Interface See Also Send Feedback

The IFrameworkElement type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex |
Public property | ActualHeight |
Public property | ActualWidth |
Public property | ComputedVisibility |
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find |
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name |
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text.
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements.
Public property | TextLiteralContent | Gets the literal text content of this framework element if any.
Public property | ToolTipText |
Public property | Uid | Unique identifier for this control in its application. For internal use.
Public property | User |
Public property | Wait |

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


AbsoluteSiblingTagIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..AbsoluteSiblingTagIndex Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.AbsoluteSiblingTagIndex"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int AbsoluteSiblingTagIndex { get; }
Visual Basic
ReadOnly Property AbsoluteSiblingTagIndex As Integer
    Get
Visual C++
property int AbsoluteSiblingTagIndex {
    int get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ActualHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..ActualHeight Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.ActualHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double ActualHeight { get; }
Visual Basic
ReadOnly Property ActualHeight As Double
    Get
Visual C++
property double ActualHeight {
    double get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ActualWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..ActualWidth Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.ActualWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double ActualWidth { get; }
Visual Basic
ReadOnly Property ActualWidth As Double
    Get
Visual C++
property double ActualWidth {
    double get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ComputedVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..ComputedVisibility Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.ComputedVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Visibility ComputedVisibility { get; }
Visual Basic
ReadOnly Property ComputedVisibility As Visibility
    Get
Visual C++
property Visibility ComputedVisibility {
    Visibility get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Find Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..Find Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.Find"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
VisualFind Find { get; }
Visual Basic
ReadOnly Property Find As VisualFind
    Get
Visual C++
property VisualFind^ Find {
    VisualFind^ get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..Name Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.Name"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..Text Property
IFrameworkElement Interface See Also Send Feedback
Gets the first text block text.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Text { get; }
Visual Basic
ReadOnly Property Text As String
    Get
Visual C++
property String^ Text {
    String^ get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


TextBlockContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..TextBlockContent Property
IFrameworkElement Interface See Also Send Feedback
Gets the text from all the inner TextBlock elements.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string TextBlockContent { get; }
Visual Basic
ReadOnly Property TextBlockContent As String
    Get
Visual C++
property String^ TextBlockContent {
    String^ get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


TextLiteralContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..TextLiteralContent Property
IFrameworkElement Interface See Also Send Feedback
Gets the literal text content of this framework element if any.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string TextLiteralContent { get; }
Visual Basic
ReadOnly Property TextLiteralContent As String
    Get
Visual C++
property String^ TextLiteralContent {
    String^ get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ToolTipText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..ToolTipText Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.ToolTipText"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string ToolTipText { get; }
Visual Basic
ReadOnly Property ToolTipText As String
    Get
Visual C++
property String^ ToolTipText {
    String^ get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Uid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..Uid Property
IFrameworkElement Interface See Also Send Feedback
Unique identifier for this control in its application. For internal use.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int Uid { get; }
Visual Basic
ReadOnly Property Uid As Integer
    Get
Visual C++
property int Uid {
    int get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


User Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..User Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.User"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
UserInteraction User { get; }
Visual Basic
ReadOnly Property User As UserInteraction
    Get
Visual C++
property UserInteraction^ User {
    UserInteraction^ get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Wait Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IFrameworkElement..::..Wait Property
IFrameworkElement Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.IFrameworkElement.Wait"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
VisualWait Wait { get; }
Visual Basic
ReadOnly Property Wait As VisualWait
    Get
Visual C++
property VisualWait^ Wait {
    VisualWait^ get ();
}

See Also

IFrameworkElement Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IHyperlinkButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IHyperlinkButton Members
IHyperlinkButton Interface Methods Properties See Also Send Feedback

The IHyperlinkButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | NavigateUri | Get the navigate Uri of the hyperlink button.
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IHyperlinkButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IHyperlinkButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IHyperlinkButton Methods
IHyperlinkButton Interface See Also Send Feedback

The IHyperlinkButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IHyperlinkButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IHyperlinkButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IHyperlinkButton Properties
IHyperlinkButton Interface See Also Send Feedback

The IHyperlinkButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | NavigateUri | Get the navigate Uri of the hyperlink button.
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IHyperlinkButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


NavigateUri Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IHyperlinkButton..::..NavigateUri Property
IHyperlinkButton Interface See Also Send Feedback
Get the navigate Uri of the hyperlink button.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string NavigateUri { get; }
Visual Basic
ReadOnly Property NavigateUri As String
    Get
Visual C++
property String^ NavigateUri {
    String^ get ();
}

See Also

IHyperlinkButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IListBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBox Members
IListBox Interface Methods Properties See Also Send Feedback

The IListBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Items | Get the Items collection.
Public property | ListBoxItems | Get the list box items.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SelectedIndex | Get/set the selected index.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IListBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IListBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBox Methods
IListBox Interface See Also Send Feedback

The IListBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IListBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IListBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBox Properties
IListBox Interface See Also Send Feedback

The IListBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Items | Get the Items collection.
Public property | ListBoxItems | Get the list box items.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SelectedIndex | Get/set the selected index.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IListBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBox..::..Items Property
IListBox Interface See Also Send Feedback
Get the Items collection.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
ItemCollection Items { get; }
Visual Basic
ReadOnly Property Items As ItemCollection
    Get
Visual C++
property ItemCollection^ Items {
    ItemCollection^ get ();
}

See Also

IListBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ListBoxItems Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBox..::..ListBoxItems Property
IListBox Interface See Also Send Feedback
Get the list box items.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
List<IListBoxItem> ListBoxItems { get; }
Visual Basic
ReadOnly Property ListBoxItems As List(Of IListBoxItem)
    Get
Visual C++
property List<IListBoxItem^>^ ListBoxItems {
    List<IListBoxItem^>^ get ();
}

See Also

IListBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectedIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBox..::..SelectedIndex Property
IListBox Interface See Also Send Feedback
Get/set the selected index.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int SelectedIndex { get; set; }
Visual Basic
Property SelectedIndex As Integer
    Get
    Set
Visual C++
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

IListBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IListBoxItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBoxItem Members
IListBoxItem Interface Methods Properties See Also Send Feedback

The IListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsSelected | Get/set whether the item is selected.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IListBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IListBoxItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBoxItem Methods
IListBoxItem Interface See Also Send Feedback

The IListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IListBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IListBoxItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBoxItem Properties
IListBoxItem Interface See Also Send Feedback

The IListBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsSelected | Get/set whether the item is selected.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IListBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IListBoxItem..::..IsSelected Property
IListBoxItem Interface See Also Send Feedback
Get/set whether the item is selected.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsSelected { get; set; }
Visual Basic
Property IsSelected As Boolean
    Get
    Set
Visual C++
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

IListBoxItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IPasswordBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPasswordBox Members
IPasswordBox Interface Methods Properties See Also Send Feedback

The IPasswordBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetPassword | Sets or types a new text into the PasswordBox.
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | Password | Get/set the password.
Public property | PasswordChar | Get/set the password char.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IPasswordBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IPasswordBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPasswordBox Methods
IPasswordBox Interface See Also Send Feedback

The IPasswordBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetPassword | Sets or types a new text into the PasswordBox.
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IPasswordBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetPassword Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPasswordBox..::..SetPassword Method
IPasswordBox Interface See Also Send Feedback
Sets or types a new text into the PasswordBox.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetPassword(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Sub SetPassword ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
void SetPassword(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
)

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the text.
text
Type: System..::..String
The text to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press.
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key.

See Also

IPasswordBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IPasswordBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPasswordBox Properties
IPasswordBox Interface See Also Send Feedback

The IPasswordBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | Password | Get/set the password.
Public property | PasswordChar | Get/set the password char.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IPasswordBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Password Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPasswordBox..::..Password Property
IPasswordBox Interface See Also Send Feedback
Get/set the password.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Password { get; set; }
Visual Basic
Property Password As String
    Get
    Set
Visual C++
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

IPasswordBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


PasswordChar Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPasswordBox..::..PasswordChar Property
IPasswordBox Interface See Also Send Feedback
Get/set the password char.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
char PasswordChar { get; set; }
Visual Basic
Property PasswordChar As Char
    Get
    Set
Visual C++
property wchar_t PasswordChar {
    wchar_t get ();
    void set (wchar_t value);
}

See Also

IPasswordBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IPopup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPopup Members
IPopup Interface Methods Properties See Also Send Feedback

The IPopup type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsOpen | Get/set whether the popup is open.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IPopup Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IPopup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPopup Methods
IPopup Interface See Also Send Feedback

The IPopup type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IPopup Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IPopup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPopup Properties
IPopup Interface See Also Send Feedback

The IPopup type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsOpen | Get/set whether the popup is open.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IPopup Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPopup..::..IsOpen Property
IPopup Interface See Also Send Feedback
Get/set whether the popup is open.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsOpen { get; set; }
Visual Basic
Property IsOpen As Boolean
    Get
    Set
Visual C++
property bool IsOpen {
    bool get ();
    void set (bool value);
}

See Also

IPopup Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRadioButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRadioButton Members
IRadioButton Interface Methods Properties See Also Send Feedback

The IRadioButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from IToggleButton.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | Toggle | Toggle the state of the button. (Inherited from IToggleButton.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from IToggleButton.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CheckIcon | Get the check icon element. (Inherited from IToggleButton.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsChecked | Get/set whether the ToggleButton is checked. (Inherited from IToggleButton.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | IsThreeState | Get/set whether the ToggleButton is in three state. (Inherited from IToggleButton.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IRadioButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRadioButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRadioButton Methods
IRadioButton Interface See Also Send Feedback

The IRadioButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from IToggleButton.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | Toggle | Toggle the state of the button. (Inherited from IToggleButton.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from IToggleButton.)

See Also

IRadioButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRadioButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRadioButton Properties
IRadioButton Interface See Also Send Feedback

The IRadioButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CheckIcon | Get the check icon element. (Inherited from IToggleButton.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsChecked | Get/set whether the ToggleButton is checked. (Inherited from IToggleButton.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | IsThreeState | Get/set whether the ToggleButton is in three state. (Inherited from IToggleButton.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IRadioButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRangeBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRangeBase Members
IRangeBase Interface Methods Properties See Also Send Feedback

The IRangeBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | LargeChange | Get/set the large change value.
Public property | Maximum | Get/set the maximum value.
Public property | Minimum | Get/set the minimum value.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SmallChange | Get/set the small change value.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Value | Get/set the control value.
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IRangeBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRangeBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRangeBase Methods
IRangeBase Interface See Also Send Feedback

The IRangeBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IRangeBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRangeBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRangeBase Properties
IRangeBase Interface See Also Send Feedback

The IRangeBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | LargeChange | Get/set the large change value.
Public property | Maximum | Get/set the maximum value.
Public property | Minimum | Get/set the minimum value.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SmallChange | Get/set the small change value.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Value | Get/set the control value.
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IRangeBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


LargeChange Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRangeBase..::..LargeChange Property
IRangeBase Interface See Also Send Feedback
Get/set the large change value.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double LargeChange { get; set; }
Visual Basic
Property LargeChange As Double
    Get
    Set
Visual C++
property double LargeChange {
    double get ();
    void set (double value);
}

See Also

IRangeBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Maximum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRangeBase..::..Maximum Property
IRangeBase Interface See Also Send Feedback
Get/set the maximum value.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double Maximum { get; set; }
Visual Basic
Property Maximum As Double
    Get
    Set
Visual C++
property double Maximum {
    double get ();
    void set (double value);
}

See Also

IRangeBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Minimum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRangeBase..::..Minimum Property
IRangeBase Interface See Also Send Feedback
Get/set the minimum value.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double Minimum { get; set; }
Visual Basic
Property Minimum As Double
    Get
    Set
Visual C++
property double Minimum {
    double get ();
    void set (double value);
}

See Also

IRangeBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SmallChange Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRangeBase..::..SmallChange Property
IRangeBase Interface See Also Send Feedback
Get/set the small change value.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double SmallChange { get; set; }
Visual Basic
Property SmallChange As Double
    Get
    Set
Visual C++
property double SmallChange {
    double get ();
    void set (double value);
}

See Also

IRangeBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRangeBase..::..Value Property
IRangeBase Interface See Also Send Feedback
Get/set the control value.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double Value { get; set; }
Visual Basic
Property Value As Double
    Get
    Set
Visual C++
property double Value {
    double get ();
    void set (double value);
}

See Also

IRangeBase Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRepeatButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRepeatButton Members
IRepeatButton Interface Methods Properties See Also Send Feedback

The IRepeatButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | UserPress | Press and hold the RepeatButton for the specified number of milliseconds

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IRepeatButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRepeatButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRepeatButton Methods
IRepeatButton Interface See Also Send Feedback

The IRepeatButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | UserPress | Press and hold the RepeatButton for the specified number of milliseconds

See Also

IRepeatButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


UserPress Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRepeatButton..::..UserPress Method
IRepeatButton Interface See Also Send Feedback
Press and hold the RepeatButton for the specified number of milliseconds

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void UserPress(
    int holdTime
)
Visual Basic
Sub UserPress ( _
    holdTime As Integer _
)
Visual C++
void UserPress(
    int holdTime
)

Parameters

holdTime
Type: System..::..Int32
The number of milliseconds to hold the button down for.

See Also

IRepeatButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRepeatButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRepeatButton Properties
IRepeatButton Interface See Also Send Feedback

The IRepeatButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IRepeatButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRichTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRichTextBox Members
IRichTextBox Interface Methods Properties See Also Send Feedback

The IRichTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IRichTextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRichTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRichTextBox Methods
IRichTextBox Interface See Also Send Feedback

The IRichTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IRichTextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IRichTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IRichTextBox Properties
IRichTextBox Interface See Also Send Feedback

The IRichTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IRichTextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ISelector Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISelector Members
ISelector Interface Methods Properties See Also Send Feedback

The ISelector type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SelectedIndex | Get/set the selected index.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ISelector Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ISelector Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISelector Methods
ISelector Interface See Also Send Feedback

The ISelector type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ISelector Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ISelector Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISelector Properties
ISelector Interface See Also Send Feedback

The ISelector type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SelectedIndex | Get/set the selected index.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ISelector Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectedIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISelector..::..SelectedIndex Property
ISelector Interface See Also Send Feedback
Get/set the selected index.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int SelectedIndex { get; set; }
Visual Basic
Property SelectedIndex As Integer
    Get
    Set
Visual C++
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

ISelector Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ISlider Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISlider Members
ISlider Interface Methods Properties See Also Send Feedback

The ISlider type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetValue | Sets a new value into Slider.
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Value | Get/set the Slider value.
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ISlider Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ISlider Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISlider Methods
ISlider Interface See Also Send Feedback

The ISlider type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetValue | Sets a new value into Slider.
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ISlider Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISlider..::..SetValue Method
ISlider Interface See Also Send Feedback
Sets a new value into Slider.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetValue(
    double value
)
Visual Basic
Sub SetValue ( _
    value As Double _
)
Visual C++
void SetValue(
    double value
)

Parameters

value
Type: System..::..Double
The new value.

See Also

ISlider Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ISlider Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISlider Properties
ISlider Interface See Also Send Feedback

The ISlider type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Value | Get/set the Slider value.
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ISlider Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ISlider..::..Value Property
ISlider Interface See Also Send Feedback
Get/set the Slider value.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double Value { get; set; }
Visual Basic
Property Value As Double
    Get
    Set
Visual C++
property double Value {
    double get ();
    void set (double value);
}

See Also

ISlider Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITabControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITabControl Members
ITabControl Interface Methods Properties See Also Send Feedback

The ITabControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SelectedIndex | Get/set the TabControl selected index.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITabControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITabControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITabControl Methods
ITabControl Interface See Also Send Feedback

The ITabControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ITabControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITabControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITabControl Properties
ITabControl Interface See Also Send Feedback

The ITabControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | SelectedIndex | Get/set the TabControl selected index.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITabControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectedIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITabControl..::..SelectedIndex Property
ITabControl Interface See Also Send Feedback
Get/set the TabControl selected index.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int SelectedIndex { get; set; }
Visual Basic
Property SelectedIndex As Integer
    Get
    Set
Visual C++
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

ITabControl Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITabItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITabItem Members
ITabItem Interface Methods Properties See Also Send Feedback

The ITabItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITabItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITabItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITabItem Methods
ITabItem Interface See Also Send Feedback

The ITabItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ITabItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITabItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITabItem Properties
ITabItem Interface See Also Send Feedback

The ITabItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITabItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITextBlock Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBlock Members
ITextBlock Interface Methods Properties See Also Send Feedback

The ITextBlock type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBlock.
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITextBlock Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITextBlock Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBlock Methods
ITextBlock Interface See Also Send Feedback

The ITextBlock type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ITextBlock Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITextBlock Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBlock Properties
ITextBlock Interface See Also Send Feedback

The ITextBlock type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBlock.
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITextBlock Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Text Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBlock..::..Text Property
ITextBlock Interface See Also Send Feedback

Overload List

 | Name | Description
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBlock.

See Also

ITextBlock Interface
ITextBlock Members
ArtOfTest.WebAii.Controls.Xaml Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBlock..::..Text Property
ITextBlock Interface See Also Send Feedback
Get/set the text of the TextBlock.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Text { get; set; }
Visual Basic
Property Text As String
    Get
    Set
Visual C++
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Implements

IFrameworkElement..::..Text

See Also

ITextBlock Interface
Text Overload
ArtOfTest.WebAii.Controls.Xaml Namespace


ITextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBox Members
ITextBox Interface Methods Properties See Also Send Feedback

The ITextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBox via automation property.
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBox Methods
ITextBox Interface See Also Send Feedback

The ITextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ITextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBox..::..SetText Method
ITextBox Interface See Also Send Feedback
Sets or types a new text into the TextBox.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime,
    bool fireKeyEvents
)
Visual Basic
Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer, _
    fireKeyEvents As Boolean _
)
Visual C++
void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime,
    bool fireKeyEvents
)

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the text.
text
Type: System..::..String
The text to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key
fireKeyEvents
Type: System..::..Boolean

[Missing <param name="fireKeyEvents"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.ITextBox.SetText(System.Boolean,System.String,System.Int32,System.Int32,System.Boolean)"]

See Also

ITextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBox Properties
ITextBox Interface See Also Send Feedback

The ITextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBox via automation property.
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITextBox Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Text Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBox..::..Text Property
ITextBox Interface See Also Send Feedback

Overload List

 | Name | Description
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | Text | Get/set the text of the TextBox via automation property.

See Also

ITextBox Interface
ITextBox Members
ArtOfTest.WebAii.Controls.Xaml Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITextBox..::..Text Property
ITextBox Interface See Also Send Feedback
Get/set the text of the TextBox via automation property.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Text { get; set; }
Visual Basic
Property Text As String
    Get
    Set
Visual C++
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Implements

IFrameworkElement..::..Text

See Also

ITextBox Interface
Text Overload
ArtOfTest.WebAii.Controls.Xaml Namespace


IToggleButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton Members
IToggleButton Interface Methods Properties See Also Send Feedback

The IToggleButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | Toggle | Toggle the state of the button.
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CheckIcon | Get the check icon element.
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsChecked | Get/set whether the ToggleButton is checked.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | IsThreeState | Get/set whether the ToggleButton is in three state.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IToggleButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton Methods
IToggleButton Interface See Also Send Feedback

The IToggleButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | Toggle | Toggle the state of the button.
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton..::..Check Method
IToggleButton Interface See Also Send Feedback
Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Check(
    bool simulateRealUser
)
Visual Basic
Sub Check ( _
    simulateRealUser As Boolean _
)
Visual C++
void Check(
    bool simulateRealUser
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate a real user click.

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton..::..Toggle Method
IToggleButton Interface See Also Send Feedback
Toggle the state of the button.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Toggle()
Visual Basic
Sub Toggle
Visual C++
void Toggle()

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


UnCheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton..::..UnCheck Method
IToggleButton Interface See Also Send Feedback
Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void UnCheck(
    bool simulateRealUser
)
Visual Basic
Sub UnCheck ( _
    simulateRealUser As Boolean _
)
Visual C++
void UnCheck(
    bool simulateRealUser
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate a real user click.

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IToggleButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton Properties
IToggleButton Interface See Also Send Feedback

The IToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | CheckIcon | Get the check icon element.
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsChecked | Get/set whether the ToggleButton is checked.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | IsThreeState | Get/set whether the ToggleButton is in three state.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


CheckIcon Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton..::..CheckIcon Property
IToggleButton Interface See Also Send Feedback
Get the check icon element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement CheckIcon { get; }
Visual Basic
ReadOnly Property CheckIcon As FrameworkElement
    Get
Visual C++
property FrameworkElement^ CheckIcon {
    FrameworkElement^ get ();
}

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsChecked Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton..::..IsChecked Property
IToggleButton Interface See Also Send Feedback
Get/set whether the ToggleButton is checked.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Nullable<bool> IsChecked { get; set; }
Visual Basic
Property IsChecked As Nullable(Of Boolean)
    Get
    Set
Visual C++
property Nullable<bool> IsChecked {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsThreeState Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IToggleButton..::..IsThreeState Property
IToggleButton Interface See Also Send Feedback
Get/set whether the ToggleButton is in three state.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsThreeState { get; set; }
Visual Basic
Property IsThreeState As Boolean
    Get
    Set
Visual C++
property bool IsThreeState {
    bool get ();
    void set (bool value);
}

See Also

IToggleButton Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITreeView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeView Members
ITreeView Interface Methods Properties See Also Send Feedback

The ITreeView type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | RootItems | Get the TreeView root items.
Public property | SelectedValuePath | Get/set the selected value path.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITreeView Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITreeView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeView Methods
ITreeView Interface See Also Send Feedback

The ITreeView type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

ITreeView Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITreeView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeView Properties
ITreeView Interface See Also Send Feedback

The ITreeView type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | RootItems | Get the TreeView root items.
Public property | SelectedValuePath | Get/set the selected value path.
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITreeView Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


RootItems Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeView..::..RootItems Property
ITreeView Interface See Also Send Feedback
Get the TreeView root items.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<ITreeViewItem> RootItems { get; }
Visual Basic
ReadOnly Property RootItems As IList(Of ITreeViewItem)
    Get
Visual C++
property IList<ITreeViewItem^>^ RootItems {
    IList<ITreeViewItem^>^ get ();
}

See Also

ITreeView Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectedValuePath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeView..::..SelectedValuePath Property
ITreeView Interface See Also Send Feedback
Get/set the selected value path.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string SelectedValuePath { get; set; }
Visual Basic
Property SelectedValuePath As String
    Get
    Set
Visual C++
property String^ SelectedValuePath {
    String^ get ();
    void set (String^ value);
}

See Also

ITreeView Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITreeViewItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem Members
ITreeViewItem Interface Methods Properties See Also Send Feedback

The ITreeViewItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | Select | Selects the item.
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | Toggle | Expands/collapses the item.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Header | Get the header element, useful for selection.
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsExpanded | Get/set whether the item is expanded.
Public property | IsSelected | Get/set whether the item is selected.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Items | Get the TreeView root items.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToggleButton | Get the expand/collapse button element.
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITreeViewItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem Methods
ITreeViewItem Interface See Also Send Feedback

The ITreeViewItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | Select | Selects the item.
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetXamlTag | (Inherited from IFrameworkElement.)
Public method | Toggle | Expands/collapses the item.

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem..::..Select Method
ITreeViewItem Interface See Also Send Feedback
Selects the item.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Select(
    bool simulateRealUser
)
Visual Basic
Sub Select ( _
    simulateRealUser As Boolean _
)
Visual C++
void Select(
    bool simulateRealUser
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user action.

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem..::..Toggle Method
ITreeViewItem Interface See Also Send Feedback
Expands/collapses the item.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Toggle(
    bool simulateRealUser
)
Visual Basic
Sub Toggle ( _
    simulateRealUser As Boolean _
)
Visual C++
void Toggle(
    bool simulateRealUser
)

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user action.

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ITreeViewItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem Properties
ITreeViewItem Interface See Also Send Feedback

The ITreeViewItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Header | Get the header element, useful for selection.
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsEnabled | Get/set whether the control is enabled. (Inherited from IControl.)
Public property | IsExpanded | Get/set whether the item is expanded.
Public property | IsSelected | Get/set whether the item is selected.
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Items | Get the TreeView root items.
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToggleButton | Get the expand/collapse button element.
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Header Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem..::..Header Property
ITreeViewItem Interface See Also Send Feedback
Get the header element, useful for selection.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement Header { get; }
Visual Basic
ReadOnly Property Header As FrameworkElement
    Get
Visual C++
property FrameworkElement^ Header {
    FrameworkElement^ get ();
}

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsExpanded Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem..::..IsExpanded Property
ITreeViewItem Interface See Also Send Feedback
Get/set whether the item is expanded.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsExpanded { get; set; }
Visual Basic
Property IsExpanded As Boolean
    Get
    Set
Visual C++
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem..::..IsSelected Property
ITreeViewItem Interface See Also Send Feedback
Get/set whether the item is selected.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsSelected { get; set; }
Visual Basic
Property IsSelected As Boolean
    Get
    Set
Visual C++
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem..::..Items Property
ITreeViewItem Interface See Also Send Feedback
Get the TreeView root items.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<ITreeViewItem> Items { get; }
Visual Basic
ReadOnly Property Items As IList(Of ITreeViewItem)
    Get
Visual C++
property IList<ITreeViewItem^>^ Items {
    IList<ITreeViewItem^>^ get ();
}

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ToggleButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ITreeViewItem..::..ToggleButton Property
ITreeViewItem Interface See Also Send Feedback
Get the expand/collapse button element.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement ToggleButton { get; }
Visual Basic
ReadOnly Property ToggleButton As FrameworkElement
    Get
Visual C++
property FrameworkElement^ ToggleButton {
    FrameworkElement^ get ();
}

See Also

ITreeViewItem Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IVirtualizingStackPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IVirtualizingStackPanel Members
IVirtualizingStackPanel Interface Methods Properties See Also Send Feedback

The IVirtualizingStackPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetVerticalOffset | Set the vertical offset.
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | VerticalOffset | Get the vertical offset.
Public property | ViewportOffset | Get the viewport offset.
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IVirtualizingStackPanel Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IVirtualizingStackPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IVirtualizingStackPanel Methods
IVirtualizingStackPanel Interface See Also Send Feedback

The IVirtualizingStackPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this element. (Inherited from ITargetElement.)
Public method | AssignReference | (Inherited from IFrameworkElement.)
Public method | Capture | Return the visual representation of this element (Inherited from ITargetElement.)
Public method | CastAs<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetAutomationProperty | (Inherited from IFrameworkElement.)
Public method | GetChildren | Get the children of this element. (Inherited from ITargetElement.)
Public method | GetHostParent | Gets the ITargetElement representing the host of this element in an outer container, if one exists. For example, this will return an IFRAME element for a page contained within an IFRAME on another page. (Inherited from ITargetElement.)
Public method | GetParent | Gets the parent of this element. (Inherited from ITargetElement.)
Public method | GetProperty<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from IFrameworkElement.)
Public method | GetRectangle | Return the rectangle of this element (Inherited from ITargetElement.)
Public method | GetUniqueHashCode | Returns a unique ID that identifies this target element. (Inherited from ITargetElement.)
Public method | Match | Match this target element against an expression. (Inherited from ITargetElement.)
Public method | Parent<(Of <<'(T>)>>) | (Inherited from IFrameworkElement.)
Public method | Refresh | Ensure current state. (Inherited from ITargetElement.)
Public method | SetClosingTag | Set the closing tag for this element. (Inherited from ITargetElement.)
Public method | SetDepth | Set the depth of this element. (Inherited from ITargetElement.)
Public method | SetFindInfo | (Inherited from IFrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from IFrameworkElement.)
Public method | SetParent | Set the parent of this node. (Inherited from ITargetElement.)
Public method | SetProperty | (Inherited from IFrameworkElement.)
Public method | SetProxy | (Inherited from IFrameworkElement.)
Public method | SetUid | (Inherited from IFrameworkElement.)
Public method | SetVerticalOffset | Set the vertical offset.
Public method | SetXamlTag | (Inherited from IFrameworkElement.)

See Also

IVirtualizingStackPanel Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


SetVerticalOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IVirtualizingStackPanel..::..SetVerticalOffset Method
IVirtualizingStackPanel Interface See Also Send Feedback
Set the vertical offset.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetVerticalOffset(
    double offset
)
Visual Basic
Sub SetVerticalOffset ( _
    offset As Double _
)
Visual C++
void SetVerticalOffset(
    double offset
)

Parameters

offset
Type: System..::..Double
The offset to set.

See Also

IVirtualizingStackPanel Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


IVirtualizingStackPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IVirtualizingStackPanel Properties
IVirtualizingStackPanel Interface See Also Send Feedback

The IVirtualizingStackPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | (Inherited from IFrameworkElement.)
Public property | ActualHeight | (Inherited from IFrameworkElement.)
Public property | ActualWidth | (Inherited from IFrameworkElement.)
Public property | ComputedVisibility | (Inherited from IFrameworkElement.)
Public property | Depth | Get the depth within the tree. (Inherited from ITargetElement.)
Public property | Find | (Inherited from IFrameworkElement.)
Public property | Host | Get the automation host. (Inherited from ITargetElement.)
Public property | IsTestRegion | Get whether this element is a test region or not (Inherited from ITargetElement.)
Public property | Name | (Inherited from IFrameworkElement.)
Public property | ParsedElement | Get the parsed element (Inherited from ITargetElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from ITargetElement.)
Public property | Text | Gets the first text block text. (Inherited from IFrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from IFrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from IFrameworkElement.)
Public property | ToolTipText | (Inherited from IFrameworkElement.)
Public property | Uid | Unique identifier for this control in its application. For internal use. (Inherited from IFrameworkElement.)
Public property | User | (Inherited from IFrameworkElement.)
Public property | VerticalOffset | Get the vertical offset.
Public property | ViewportOffset | Get the viewport offset.
Public property | Wait | (Inherited from IFrameworkElement.)

See Also

IVirtualizingStackPanel Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


VerticalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IVirtualizingStackPanel..::..VerticalOffset Property
IVirtualizingStackPanel Interface See Also Send Feedback
Get the vertical offset.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
double VerticalOffset { get; }
Visual Basic
ReadOnly Property VerticalOffset As Double
    Get
Visual C++
property double VerticalOffset {
    double get ();
}

See Also

IVirtualizingStackPanel Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


ViewportOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IVirtualizingStackPanel..::..ViewportOffset Property
IVirtualizingStackPanel Interface See Also Send Feedback
Get the viewport offset.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int ViewportOffset { get; }
Visual Basic
ReadOnly Property ViewportOffset As Integer
    Get
Visual C++
property int ViewportOffset {
    int get ();
}

See Also

IVirtualizingStackPanel Interface
ArtOfTest.WebAii.Controls.Xaml Namespace


XamlControlHelper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper Members
XamlControlHelper Class Methods See Also Send Feedback

The XamlControlHelper type exposes the following members.

Methods

Name | Description
CheckToggleButton |
FindElementByName | Searches from the root for an element with the specified name. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.
FindElementByText | Searches from the root for an element with the specified text. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.
FindElementByType | Searches from the root for an element with the specified type. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.
NavigateCalendar |
OpenComboBoxDropDown |
OpenDatePickerCalendarPopup | Open the picker calendar popup.
PressRepeatButton |
SelectCalendarDates |
SelectCalendarMonth |
SelectCalendarYear |
SetDatePickerText |
SetPassword |
SetSliderValue |
SetText |
ZoomCalendarOut |

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


XamlControlHelper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper Methods
XamlControlHelper Class See Also Send Feedback

The XamlControlHelper type exposes the following members.

Methods

Name | Description
CheckToggleButton |
FindElementByName | Searches from the root for an element with the specified name. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.
FindElementByText | Searches from the root for an element with the specified text. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.
FindElementByType | Searches from the root for an element with the specified type. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.
NavigateCalendar |
OpenComboBoxDropDown |
OpenDatePickerCalendarPopup | Open the picker calendar popup.
PressRepeatButton |
SelectCalendarDates |
SelectCalendarMonth |
SelectCalendarYear |
SetDatePickerText |
SetPassword |
SetSliderValue |
SetText |
ZoomCalendarOut |

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


CheckToggleButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..CheckToggleButton Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.CheckToggleButton(ArtOfTest.WebAii.Controls.Xaml.IToggleButton,System.Boolean,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void CheckToggleButton(
    IToggleButton button,
    bool simulateRealUser,
    bool toCheck
)
Visual Basic
Public Shared Sub CheckToggleButton ( _
    button As IToggleButton, _
    simulateRealUser As Boolean, _
    toCheck As Boolean _
)
Visual C++
public:
static void CheckToggleButton(
    IToggleButton^ button,
    bool simulateRealUser,
    bool toCheck
)

Parameters

button
Type: ArtOfTest.WebAii.Controls.Xaml..::..IToggleButton

[Missing <param name="button"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.CheckToggleButton(ArtOfTest.WebAii.Controls.Xaml.IToggleButton,System.Boolean,System.Boolean)"]

simulateRealUser
Type: System..::..Boolean

[Missing <param name="simulateRealUser"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.CheckToggleButton(ArtOfTest.WebAii.Controls.Xaml.IToggleButton,System.Boolean,System.Boolean)"]

toCheck
Type: System..::..Boolean

[Missing <param name="toCheck"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.CheckToggleButton(ArtOfTest.WebAii.Controls.Xaml.IToggleButton,System.Boolean,System.Boolean)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


FindElementByName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..FindElementByName Method
XamlControlHelper Class See Also Send Feedback
Searches from the root for an element with the specified name. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FrameworkElement FindElementByName(
    FrameworkElement root,
    string name
)
Visual Basic
Public Shared Function FindElementByName ( _
    root As FrameworkElement, _
    name As String _
) As FrameworkElement
Visual C++
public:
static FrameworkElement^ FindElementByName(
    FrameworkElement^ root,
    String^ name
)

Parameters

root
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The root element to start the search from.
name
Type: System..::..String
The name of the element to search.

Return Value

The element or null if not found.

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


FindElementByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..FindElementByText Method
XamlControlHelper Class See Also Send Feedback
Searches from the root for an element with the specified text. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FrameworkElement FindElementByText(
    FrameworkElement root,
    string text
)
Visual Basic
Public Shared Function FindElementByText ( _
    root As FrameworkElement, _
    text As String _
) As FrameworkElement
Visual C++
public:
static FrameworkElement^ FindElementByText(
    FrameworkElement^ root,
    String^ text
)

Parameters

root
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The root element to start the search from.
text
Type: System..::..String
The element text content to search for.

Return Value

The element or null if not found.

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


FindElementByType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..FindElementByType Method
XamlControlHelper Class See Also Send Feedback
Searches from the root for an element with the specified type. This method doesn't timeout searching via FindStrategy.WhenNotVisibleReturnNull.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FrameworkElement FindElementByType(
    FrameworkElement root,
    string type
)
Visual Basic
Public Shared Function FindElementByType ( _
    root As FrameworkElement, _
    type As String _
) As FrameworkElement
Visual C++
public:
static FrameworkElement^ FindElementByType(
    FrameworkElement^ root,
    String^ type
)

Parameters

root
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The root element to start the search from.
type
Type: System..::..String
The type of the element to search.

Return Value

The element or null if not found.

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


NavigateCalendar Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..NavigateCalendar Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.NavigateCalendar(ArtOfTest.WebAii.Controls.Xaml.ICalendar,ArtOfTest.WebAii.Controls.Xaml.CalendarNavigationDirection,System.String,System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void NavigateCalendar(
    ICalendar calendar,
    CalendarNavigationDirection direction,
    string nextButtonName,
    string previousButtonName
)
Visual Basic
Public Shared Sub NavigateCalendar ( _
    calendar As ICalendar, _
    direction As CalendarNavigationDirection, _
    nextButtonName As String, _
    previousButtonName As String _
)
Visual C++
public:
static void NavigateCalendar(
    ICalendar^ calendar,
    CalendarNavigationDirection direction,
    String^ nextButtonName,
    String^ previousButtonName
)

Parameters

calendar
Type: ArtOfTest.WebAii.Controls.Xaml..::..ICalendar

[Missing <param name="calendar"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.NavigateCalendar(ArtOfTest.WebAii.Controls.Xaml.ICalendar,ArtOfTest.WebAii.Controls.Xaml.CalendarNavigationDirection,System.String,System.String)"]

direction
Type: ArtOfTest.WebAii.Controls.Xaml..::..CalendarNavigationDirection

[Missing <param name="direction"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.NavigateCalendar(ArtOfTest.WebAii.Controls.Xaml.ICalendar,ArtOfTest.WebAii.Controls.Xaml.CalendarNavigationDirection,System.String,System.String)"]

nextButtonName
Type: System..::..String

[Missing <param name="nextButtonName"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.NavigateCalendar(ArtOfTest.WebAii.Controls.Xaml.ICalendar,ArtOfTest.WebAii.Controls.Xaml.CalendarNavigationDirection,System.String,System.String)"]

previousButtonName
Type: System..::..String

[Missing <param name="previousButtonName"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.NavigateCalendar(ArtOfTest.WebAii.Controls.Xaml.ICalendar,ArtOfTest.WebAii.Controls.Xaml.CalendarNavigationDirection,System.String,System.String)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


OpenComboBoxDropDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..OpenComboBoxDropDown Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.OpenComboBoxDropDown(ArtOfTest.WebAii.Controls.Xaml.IComboBox,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void OpenComboBoxDropDown(
    IComboBox combo,
    bool simulateRealUser
)
Visual Basic
Public Shared Sub OpenComboBoxDropDown ( _
    combo As IComboBox, _
    simulateRealUser As Boolean _
)
Visual C++
public:
static void OpenComboBoxDropDown(
    IComboBox^ combo,
    bool simulateRealUser
)

Parameters

combo
Type: ArtOfTest.WebAii.Controls.Xaml..::..IComboBox

[Missing <param name="combo"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.OpenComboBoxDropDown(ArtOfTest.WebAii.Controls.Xaml.IComboBox,System.Boolean)"]

simulateRealUser
Type: System..::..Boolean

[Missing <param name="simulateRealUser"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.OpenComboBoxDropDown(ArtOfTest.WebAii.Controls.Xaml.IComboBox,System.Boolean)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


OpenDatePickerCalendarPopup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..OpenDatePickerCalendarPopup Method
XamlControlHelper Class See Also Send Feedback
Open the picker calendar popup.

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void OpenDatePickerCalendarPopup(
    IDatePicker picker,
    bool simulateRealUser
)
Visual Basic
Public Shared Sub OpenDatePickerCalendarPopup ( _
    picker As IDatePicker, _
    simulateRealUser As Boolean _
)
Visual C++
public:
static void OpenDatePickerCalendarPopup(
    IDatePicker^ picker,
    bool simulateRealUser
)

Parameters

picker
Type: ArtOfTest.WebAii.Controls.Xaml..::..IDatePicker

[Missing <param name="picker"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.OpenDatePickerCalendarPopup(ArtOfTest.WebAii.Controls.Xaml.IDatePicker,System.Boolean)"]

simulateRealUser
Type: System..::..Boolean
True to find the button and click on it, false to change the state via automation property.

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


PressRepeatButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..PressRepeatButton Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.PressRepeatButton(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void PressRepeatButton(
    FrameworkElement repeatButton,
    int holdTime
)
Visual Basic
Public Shared Sub PressRepeatButton ( _
    repeatButton As FrameworkElement, _
    holdTime As Integer _
)
Visual C++
public:
static void PressRepeatButton(
    FrameworkElement^ repeatButton,
    int holdTime
)

Parameters

repeatButton
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="repeatButton"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.PressRepeatButton(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Int32)"]

holdTime
Type: System..::..Int32

[Missing <param name="holdTime"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.PressRepeatButton(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Int32)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectCalendarDates Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..SelectCalendarDates Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarDates(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Boolean,System.Collections.Generic.List{System.DateTime},System.Boolean)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SelectCalendarDates(
    ICalendar calendar,
    bool simulateRealUser,
    List<DateTime> dates,
    bool isInDatePicker
)
Visual Basic
Public Shared Sub SelectCalendarDates ( _
    calendar As ICalendar, _
    simulateRealUser As Boolean, _
    dates As List(Of DateTime), _
    isInDatePicker As Boolean _
)
Visual C++
public:
static void SelectCalendarDates(
    ICalendar^ calendar,
    bool simulateRealUser,
    List<DateTime>^ dates,
    bool isInDatePicker
)

Parameters

calendar
Type: ArtOfTest.WebAii.Controls.Xaml..::..ICalendar

[Missing <param name="calendar"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarDates(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Boolean,System.Collections.Generic.List{System.DateTime},System.Boolean)"]

simulateRealUser
Type: System..::..Boolean

[Missing <param name="simulateRealUser"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarDates(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Boolean,System.Collections.Generic.List{System.DateTime},System.Boolean)"]

dates
Type: System.Collections.Generic..::..List <(Of <(<' DateTime >)>)>

[Missing <param name="dates"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarDates(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Boolean,System.Collections.Generic.List{System.DateTime},System.Boolean)"]

isInDatePicker
Type: System..::..Boolean

[Missing <param name="isInDatePicker"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarDates(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Boolean,System.Collections.Generic.List{System.DateTime},System.Boolean)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectCalendarMonth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..SelectCalendarMonth Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarMonth(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SelectCalendarMonth(
    ICalendar calendar,
    int month
)
Visual Basic
Public Shared Sub SelectCalendarMonth ( _
    calendar As ICalendar, _
    month As Integer _
)
Visual C++
public:
static void SelectCalendarMonth(
    ICalendar^ calendar,
    int month
)

Parameters

calendar
Type: ArtOfTest.WebAii.Controls.Xaml..::..ICalendar

[Missing <param name="calendar"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarMonth(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Int32)"]

month
Type: System..::..Int32

[Missing <param name="month"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarMonth(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Int32)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


SelectCalendarYear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..SelectCalendarYear Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarYear(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SelectCalendarYear(
    ICalendar calendar,
    int year
)
Visual Basic
Public Shared Sub SelectCalendarYear ( _
    calendar As ICalendar, _
    year As Integer _
)
Visual C++
public:
static void SelectCalendarYear(
    ICalendar^ calendar,
    int year
)

Parameters

calendar
Type: ArtOfTest.WebAii.Controls.Xaml..::..ICalendar

[Missing <param name="calendar"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarYear(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Int32)"]

year
Type: System..::..Int32

[Missing <param name="year"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SelectCalendarYear(ArtOfTest.WebAii.Controls.Xaml.ICalendar,System.Int32)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


SetDatePickerText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..SetDatePickerText Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetDatePickerText(ArtOfTest.WebAii.Controls.Xaml.IDatePicker,System.Boolean,System.String,System.Int32,System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SetDatePickerText(
    IDatePicker picker,
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Shared Sub SetDatePickerText ( _
    picker As IDatePicker, _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
static void SetDatePickerText(
    IDatePicker^ picker,
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
)

Parameters

picker
Type: ArtOfTest.WebAii.Controls.Xaml..::..IDatePicker

[Missing <param name="picker"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetDatePickerText(ArtOfTest.WebAii.Controls.Xaml.IDatePicker,System.Boolean,System.String,System.Int32,System.Int32)"]

simulateRealUser
Type: System..::..Boolean

[Missing <param name="simulateRealUser"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetDatePickerText(ArtOfTest.WebAii.Controls.Xaml.IDatePicker,System.Boolean,System.String,System.Int32,System.Int32)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetDatePickerText(ArtOfTest.WebAii.Controls.Xaml.IDatePicker,System.Boolean,System.String,System.Int32,System.Int32)"]

keyPressTime
Type: System..::..Int32

[Missing <param name="keyPressTime"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetDatePickerText(ArtOfTest.WebAii.Controls.Xaml.IDatePicker,System.Boolean,System.String,System.Int32,System.Int32)"]

keyHoldTime
Type: System..::..Int32

[Missing <param name="keyHoldTime"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetDatePickerText(ArtOfTest.WebAii.Controls.Xaml.IDatePicker,System.Boolean,System.String,System.Int32,System.Int32)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


SetPassword Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..SetPassword Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetPassword(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SetPassword(
    FrameworkElement xamlControl,
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Shared Sub SetPassword ( _
    xamlControl As FrameworkElement, _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
static void SetPassword(
    FrameworkElement^ xamlControl,
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
)

Parameters

xamlControl
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="xamlControl"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetPassword(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32)"]

simulateRealUser
Type: System..::..Boolean

[Missing <param name="simulateRealUser"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetPassword(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetPassword(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32)"]

keyPressTime
Type: System..::..Int32

[Missing <param name="keyPressTime"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetPassword(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32)"]

keyHoldTime
Type: System..::..Int32

[Missing <param name="keyHoldTime"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetPassword(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


SetSliderValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..SetSliderValue Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetSliderValue(ArtOfTest.WebAii.Controls.Xaml.ISlider,System.Double)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SetSliderValue(
    ISlider slider,
    double value
)
Visual Basic
Public Shared Sub SetSliderValue ( _
    slider As ISlider, _
    value As Double _
)
Visual C++
public:
static void SetSliderValue(
    ISlider^ slider,
    double value
)

Parameters

slider
Type: ArtOfTest.WebAii.Controls.Xaml..::..ISlider

[Missing <param name="slider"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetSliderValue(ArtOfTest.WebAii.Controls.Xaml.ISlider,System.Double)"]

value
Type: System..::..Double

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetSliderValue(ArtOfTest.WebAii.Controls.Xaml.ISlider,System.Double)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..SetText Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetText(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SetText(
    FrameworkElement xamlControl,
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime,
    bool fireKeyEvents,
    bool clearCurrentText
)
Visual Basic
Public Shared Sub SetText ( _
    xamlControl As FrameworkElement, _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer, _
    fireKeyEvents As Boolean, _
    clearCurrentText As Boolean _
)
Visual C++
public:
static void SetText(
    FrameworkElement^ xamlControl,
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime,
    bool fireKeyEvents,
    bool clearCurrentText
)

Parameters

xamlControl
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="xamlControl"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetText(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

simulateRealUser
Type: System..::..Boolean

[Missing <param name="simulateRealUser"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetText(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetText(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

keyPressTime
Type: System..::..Int32

[Missing <param name="keyPressTime"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetText(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

keyHoldTime
Type: System..::..Int32

[Missing <param name="keyHoldTime"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetText(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

fireKeyEvents
Type: System..::..Boolean

[Missing <param name="fireKeyEvents"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetText(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

clearCurrentText
Type: System..::..Boolean

[Missing <param name="clearCurrentText"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.SetText(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean,System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


ZoomCalendarOut Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlControlHelper..::..ZoomCalendarOut Method
XamlControlHelper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.ZoomCalendarOut(ArtOfTest.WebAii.Controls.Xaml.ICalendar)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void ZoomCalendarOut(
    ICalendar calendar
)
Visual Basic
Public Shared Sub ZoomCalendarOut ( _
    calendar As ICalendar _
)
Visual C++
public:
static void ZoomCalendarOut(
    ICalendar^ calendar
)

Parameters

calendar
Type: ArtOfTest.WebAii.Controls.Xaml..::..ICalendar

[Missing <param name="calendar"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.XamlControlHelper.ZoomCalendarOut(ArtOfTest.WebAii.Controls.Xaml.ICalendar)"]

See Also

XamlControlHelper Class
ArtOfTest.WebAii.Controls.Xaml Namespace


ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace
Send Feedback
Namespace for all the Silverlight element wrapper controls.

Classes

 | Class | Description
Public class | FontStretchFactory |
Public class | FontStyleFactory |
Public class | FontWeightFactory |
Public class | Inline |
Public class | InlineCollection |
Public class | Run |
Public class | SilverlightTestElement |


FontStretchFactory Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStretchFactory Members
FontStretchFactory Class Constructors Methods See Also Send Feedback

The FontStretchFactory type exposes the following members.

Constructors

 | Name | Description
Public method | FontStretchFactory | Initializes a new instance of the FontStretchFactory class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontStretchFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontStretchFactory Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStretchFactory Constructor
FontStretchFactory Class See Also Send Feedback
Initializes a new instance of the FontStretchFactory class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretchFactory()
Visual Basic
Public Sub New
Visual C++
public:
FontStretchFactory()

See Also

FontStretchFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontStretchFactory Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStretchFactory Methods
FontStretchFactory Class See Also Send Feedback

The FontStretchFactory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontStretchFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FromString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStretchFactory..::..FromString Method
FontStretchFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontStretchFactory.FromString(System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FontStretch FromString(
    string source
)
Visual Basic
Public Shared Function FromString ( _
    source As String _
) As FontStretch
Visual C++
public:
static FontStretch FromString(
    String^ source
)

Parameters

source
Type: System..::..String

[Missing <param name="source"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontStretchFactory.FromString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontStretchFactory.FromString(System.String)"]

See Also

FontStretchFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontStyleFactory Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStyleFactory Members
FontStyleFactory Class Constructors Methods See Also Send Feedback

The FontStyleFactory type exposes the following members.

Constructors

 | Name | Description
Public method | FontStyleFactory | Initializes a new instance of the FontStyleFactory class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontStyleFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontStyleFactory Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStyleFactory Constructor
FontStyleFactory Class See Also Send Feedback
Initializes a new instance of the FontStyleFactory class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyleFactory()
Visual Basic
Public Sub New
Visual C++
public:
FontStyleFactory()

See Also

FontStyleFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontStyleFactory Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStyleFactory Methods
FontStyleFactory Class See Also Send Feedback

The FontStyleFactory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontStyleFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FromString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStyleFactory..::..FromString Method
FontStyleFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontStyleFactory.FromString(System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FontStyle FromString(
    string source
)
Visual Basic
Public Shared Function FromString ( _
    source As String _
) As FontStyle
Visual C++
public:
static FontStyle FromString(
    String^ source
)

Parameters

source
Type: System..::..String

[Missing <param name="source"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontStyleFactory.FromString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontStyleFactory.FromString(System.String)"]

See Also

FontStyleFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontWeightFactory Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontWeightFactory Members
FontWeightFactory Class Constructors Methods See Also Send Feedback

The FontWeightFactory type exposes the following members.

Constructors

 | Name | Description
Public method | FontWeightFactory | Initializes a new instance of the FontWeightFactory class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontWeightFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontWeightFactory Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontWeightFactory Constructor
FontWeightFactory Class See Also Send Feedback
Initializes a new instance of the FontWeightFactory class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeightFactory()
Visual Basic
Public Sub New
Visual C++
public:
FontWeightFactory()

See Also

FontWeightFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontWeightFactory Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontWeightFactory Methods
FontWeightFactory Class See Also Send Feedback

The FontWeightFactory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontWeightFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FromString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontWeightFactory..::..FromString Method
FontWeightFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontWeightFactory.FromString(System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FontWeight FromString(
    string source
)
Visual Basic
Public Shared Function FromString ( _
    source As String _
) As FontWeight
Visual C++
public:
static FontWeight FromString(
    String^ source
)

Parameters

source
Type: System..::..String

[Missing <param name="source"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontWeightFactory.FromString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.FontWeightFactory.FromString(System.String)"]

See Also

FontWeightFactory Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Inline Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Members
Inline Class Constructors Methods Fields Properties See Also Send Feedback

The Inline type exposes the following members.

Constructors

 | Name | Description
Public method | Inline | Initializes a new instance of the Inline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | _fontFamilySource |
Public field | _fontStretchSource |
Public field | _fontStyleSource |
Public field | _fontWeightSource |
Public field | _foregroundColor |

Properties

 | Name | Description
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Inline Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Constructor
Inline Class See Also Send Feedback
Initializes a new instance of the Inline class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Inline(
    Inline inline
)
Visual Basic
Public Sub New ( _
    inline As Inline _
)
Visual C++
public:
Inline(
    Inline^ inline
)

Parameters

inline
Type: System.Windows.Documents..::..Inline

[Missing <param name="inline"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline.#ctor(System.Windows.Documents.Inline)"]

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Inline Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Fields
Inline Class See Also Send Feedback

The Inline type exposes the following members.

Fields

 | Name | Description
Public field | _fontFamilySource |
Public field | _fontStretchSource |
Public field | _fontStyleSource |
Public field | _fontWeightSource |
Public field | _foregroundColor |

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


_fontFamilySource Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::.._fontFamilySource Field
Inline Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline._fontFamilySource"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _fontFamilySource
Visual Basic
Public _fontFamilySource As String
Visual C++
public:
String^ _fontFamilySource

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


_fontStretchSource Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::.._fontStretchSource Field
Inline Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline._fontStretchSource"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _fontStretchSource
Visual Basic
Public _fontStretchSource As String
Visual C++
public:
String^ _fontStretchSource

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


_fontStyleSource Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::.._fontStyleSource Field
Inline Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline._fontStyleSource"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _fontStyleSource
Visual Basic
Public _fontStyleSource As String
Visual C++
public:
String^ _fontStyleSource

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


_fontWeightSource Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::.._fontWeightSource Field
Inline Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline._fontWeightSource"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _fontWeightSource
Visual Basic
Public _fontWeightSource As String
Visual C++
public:
String^ _fontWeightSource

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


_foregroundColor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::.._foregroundColor Field
Inline Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline._foregroundColor"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<Color> _foregroundColor
Visual Basic
Public _foregroundColor As Nullable(Of Color)
Visual C++
public:
Nullable<Color> _foregroundColor

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Inline Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Methods
Inline Class See Also Send Feedback

The Inline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Inline Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Properties
Inline Class See Also Send Feedback

The Inline type exposes the following members.

Properties

 | Name | Description
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontFamily Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline.FontFamily"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontSize Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline.FontSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; private set; }
Visual Basic
Public Property FontSize As Double
    Get
    Private Set
Visual C++
public:
property double FontSize {
    double get ();
    private: void set (double value);
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontStretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontStretch Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline.FontStretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic
Public ReadOnly Property FontStretch As FontStretch
    Get
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontStyle Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline.FontStyle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyle FontStyle { get; }
Visual Basic
Public ReadOnly Property FontStyle As FontStyle
    Get
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FontWeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontWeight Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline.FontWeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic
Public ReadOnly Property FontWeight As FontWeight
    Get
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..Foreground Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline.Foreground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; }
Visual Basic
Public ReadOnly Property Foreground As Brush
    Get
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


InlineCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Members
InlineCollection Class Constructors Methods Fields Properties See Also Send Feedback

The InlineCollection type exposes the following members.

Constructors

 | Name | Description
Public method | InlineCollection | Initializes a new instance of the InlineCollection class

Methods

 | Name | Description
Public method | Add |
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Store |

Properties

 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


InlineCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Constructor
InlineCollection Class See Also Send Feedback
Initializes a new instance of the InlineCollection class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InlineCollection()
Visual Basic
Public Sub New
Visual C++
public:
InlineCollection()

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


InlineCollection Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Fields
InlineCollection Class See Also Send Feedback

The InlineCollection type exposes the following members.

Fields

 | Name | Description
Public field | Store |

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Store Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Store Field
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Store"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public readonly List<Inline> Store
Visual Basic
Public ReadOnly Store As List(Of Inline)
Visual C++
public:
initonly List<Inline^>^ Store

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


InlineCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Methods
InlineCollection Class See Also Send Feedback

The InlineCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Add Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Add Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Add(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Add(
    Inline item
)
Visual Basic
Public Sub Add ( _
    item As Inline _
)
Visual C++
public:
virtual void Add(
    Inline^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Controls.Xaml.Silverlight..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Add(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Clear Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Clear"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Contains Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Contains Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Contains(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Contains(
    Inline item
)
Visual Basic
Public Function Contains ( _
    item As Inline _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Inline^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Controls.Xaml.Silverlight..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Contains(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Contains(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


CopyTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..CopyTo Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.CopyTo(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline[],System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CopyTo(
    Inline[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo ( _
    array As Inline(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<Inline^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< ArtOfTest.WebAii.Controls.Xaml.Silverlight..::..Inline >[]()[][]

[Missing <param name="array"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.CopyTo(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline[],System.Int32)"]

arrayIndex
Type: System..::..Int32

[Missing <param name="arrayIndex"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.CopyTo(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline[],System.Int32)"]

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FromRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..FromRealObject Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.FromRealObject(System.Object)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void FromRealObject(
    Object obj
)
Visual Basic
Public Overrides Sub FromRealObject ( _
    obj As Object _
)
Visual C++
public:
virtual void FromRealObject(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.FromRealObject(System.Object)"]

Implements

IPeerConverter..::..FromRealObject(Object)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


GetEnumerator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..GetEnumerator Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.GetEnumerator"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.GetEnumerator"]

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..GetProperty Method
InlineCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InlineCollection Class
InlineCollection Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..GetRealType Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


IndexOf Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..IndexOf Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.IndexOf(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int IndexOf(
    Inline item
)
Visual Basic
Public Function IndexOf ( _
    item As Inline _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Inline^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Controls.Xaml.Silverlight..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.IndexOf(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.IndexOf(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Insert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Insert Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Insert(System.Int32,ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Insert(
    int index,
    Inline item
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    item As Inline _
)
Visual C++
public:
virtual void Insert(
    int index,
    Inline^ item
) sealed

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Insert(System.Int32,ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

item
Type: ArtOfTest.WebAii.Controls.Xaml.Silverlight..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Insert(System.Int32,ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..InvokeMethod Method
InlineCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InlineCollection Class
InlineCollection Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Remove Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Remove Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Remove(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Remove(
    Inline item
)
Visual Basic
Public Function Remove ( _
    item As Inline _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Inline^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Controls.Xaml.Silverlight..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Remove(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Remove(ArtOfTest.WebAii.Controls.Xaml.Silverlight.Inline)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


RemoveAt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..RemoveAt Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.RemoveAt(System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.RemoveAt(System.Int32)"]

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


InlineCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Properties
InlineCollection Class See Also Send Feedback

The InlineCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Count Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Count Property
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Count"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..IsReadOnly Property
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Item Property
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.InlineCollection.Item(System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Inline this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As Inline
    Get
    Set
Visual C++
public:
virtual property Inline^ default[int index] {
    Inline^ get (int index) sealed;
    void set (int index, Inline^ value) sealed;
}

Parameters

index
Type: System..::..Int32

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Run Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Members
Run Class Constructors Methods Fields Properties See Also Send Feedback

The Run type exposes the following members.

Constructors

 | Name | Description
Public method | Run | Initializes a new instance of the Run class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | _fontFamilySource | (Inherited from Inline.)
Public field | _fontStretchSource | (Inherited from Inline.)
Public field | _fontStyleSource | (Inherited from Inline.)
Public field | _fontWeightSource | (Inherited from Inline.)
Public field | _foregroundColor | (Inherited from Inline.)

Properties

 | Name | Description
Public property | FlowDirection |
Public property | FontFamily | (Inherited from Inline.)
Public property | FontSize | (Inherited from Inline.)
Public property | FontStretch | (Inherited from Inline.)
Public property | FontStyle | (Inherited from Inline.)
Public property | FontWeight | (Inherited from Inline.)
Public property | Foreground | (Inherited from Inline.)
Public property | Text |

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Run Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Constructor
Run Class See Also Send Feedback
Initializes a new instance of the Run class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Run(
    Run run
)
Visual Basic
Public Sub New ( _
    run As Run _
)
Visual C++
public:
Run(
    Run^ run
)

Parameters

run
Type: System.Windows.Documents..::..Run

[Missing <param name="run"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Run.#ctor(System.Windows.Documents.Run)"]

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Run Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Fields
Run Class See Also Send Feedback

The Run type exposes the following members.

Fields

 | Name | Description
Public field | _fontFamilySource | (Inherited from Inline.)
Public field | _fontStretchSource | (Inherited from Inline.)
Public field | _fontStyleSource | (Inherited from Inline.)
Public field | _fontWeightSource | (Inherited from Inline.)
Public field | _foregroundColor | (Inherited from Inline.)

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Run Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Methods
Run Class See Also Send Feedback

The Run type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Run Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Properties
Run Class See Also Send Feedback

The Run type exposes the following members.

Properties

 | Name | Description
Public property | FlowDirection |
Public property | FontFamily | (Inherited from Inline.)
Public property | FontSize | (Inherited from Inline.)
Public property | FontStretch | (Inherited from Inline.)
Public property | FontStyle | (Inherited from Inline.)
Public property | FontWeight | (Inherited from Inline.)
Public property | Foreground | (Inherited from Inline.)
Public property | Text |

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


FlowDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run..::..FlowDirection Property
Run Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Run.FlowDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDirection FlowDirection { get; private set; }
Visual Basic
Public Property FlowDirection As FlowDirection
    Get
    Private Set
Visual C++
public:
property FlowDirection FlowDirection {
    FlowDirection get ();
    private: void set (FlowDirection value);
}

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run..::..Text Property
Run Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Silverlight.Run.Text"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; private set; }
Visual Basic
Public Property Text As String
    Get
    Private Set
Visual C++
public:
property String^ Text {
    String^ get ();
    private: void set (String^ value);
}

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


SilverlightTestElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement Members
SilverlightTestElement Class Constructors Methods Fields Properties See Also Send Feedback

The SilverlightTestElement type exposes the following members.

Constructors

 | Name | Description
Public method | SilverlightTestElement | Initializes a new instance of the SilverlightTestElement class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
UseLayoutRoundingProperty | Defines how to get the ActualWidth UseLayoutRounding of this element.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element.
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


SilverlightTestElement Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement Constructor
SilverlightTestElement Class See Also Send Feedback
Initializes a new instance of the SilverlightTestElement class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightTestElement()
Visual Basic
Public Sub New
Visual C++
public:
SilverlightTestElement()

See Also

SilverlightTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


SilverlightTestElement Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement Fields
SilverlightTestElement Class See Also Send Feedback

The SilverlightTestElement type exposes the following members.

Fields

Name | Description
UseLayoutRoundingProperty | Defines how to get the ActualWidth UseLayoutRounding of this element.

See Also

SilverlightTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


UseLayoutRoundingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..UseLayoutRoundingProperty Field
SilverlightTestElement Class See Also Send Feedback
Defines how to get the ActualWidth UseLayoutRounding of this element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UseLayoutRoundingProperty
Visual Basic
Public Shared UseLayoutRoundingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UseLayoutRoundingProperty

See Also

SilverlightTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


SilverlightTestElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement Methods
SilverlightTestElement Class See Also Send Feedback

The SilverlightTestElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..AnySibling Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..GetProperty Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..GetRectangle Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..Highlight Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..InvokeMethod Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..IsHitTest Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..NextSibling Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..Parent Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..PreviousSibling Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..ScrollToVisible Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..SetProperty Method
SilverlightTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SilverlightTestElement Class
SilverlightTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


SilverlightTestElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement Properties
SilverlightTestElement Class See Also Send Feedback

The SilverlightTestElement type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element.
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SilverlightTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


UseLayoutRounding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightTestElement..::..UseLayoutRounding Property
SilverlightTestElement Class See Also Send Feedback
Gets / Sets the value of the UseLayoutRounding of this element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool UseLayoutRounding { get; set; }
Visual Basic
Public Property UseLayoutRounding As Boolean
    Get
    Set
Visual C++
public:
property bool UseLayoutRounding {
    bool get ();
    void set (bool value);
}

See Also

SilverlightTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Silverlight Namespace


ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace
Send Feedback
Namespace for all the WPF element wrapper controls.

Classes

 | Class | Description
Public class | AccessText |
Public class | Accordion |
Public class | AccordionButton |
Public class | AccordionItem |
Public class | ActiveXHost |
Public class | AdornedElementPlaceholder |
Public class | Adorner |
Public class | AdornerDecorator |
Public class | AdornerLayer |
Public class | AffineTransform3D |
Public class | AutoCompleteBox |
Public class | AxisAngleRotation3D |
Public class | BindingGroup |
Public class | BitmapFrame |
Public class | BitmapFrameDecode |
Public class | BitmapFrameEncode |
Public class | BitmapImage |
Public class | BitmapPalette |
Public class | BitmapSource |
Public class | Border |
Public class | Brush |
Public class | BulletDecorator |
Public class | Button | Represents the Button for Wpf control wrapper.
Public class | ButtonBase |
Public class | CachedBitmap |
Public class | Calendar |
Public class | CalendarButton |
Public class | CalendarDayButton |
Public class | CalendarItem |
Public class | Camera |
Public class | Canvas |
Public class | CheckBox | Wraps a WPF CheckBox element.
Public class | Clipper |
Public class | Color |
Public class | ColorContext |
Public class | ColorConvertedBitmap |
Public class | CombinedGeometry |
Public class | ComboBox | Represents the Wpf ComboBox control wrapper.
Public class | ComboBoxItem | Represents the Wpf ComboBoxItem for control wrapper.
Public class | ContainerVisual |
Public class | ContentControl |
Public class | ContentPresenter |
Public class | ContextMenu |
Public class | Control |
Public class | CornerRadius |
Public class | CroppedBitmap |
Public class | D3DImage |
Public class | DataGrid | Wraps a Silverlight DataGrid object.
Public class | DataGridCell | Wraps a Silverlight DataGridCell.
Public class | DataGridCellInfo |
Public class | DataGridCellsPanel |
Public class | DataGridCellsPresenter |
Public class | DataGridColumn |
Public class | DataGridColumnHeader |
Public class | DataGridColumnHeadersPresenter |
Public class | DataGridDetailsPresenter |
Public class | DataGridHeaderBorder |
Public class | DataGridLength |
Public class | DataGridRow | Wraps a Silverlight DataGridRow.
Public class | DataGridRowHeader |
Public class | DataGridRowsPresenter |
Public class | DatePicker |
Public class | DatePickerTextBox |
Public class | Decorator |
Public class | DockPanel |
Public class | DocumentPageView |
Public class | DocumentReference |
Public class | DocumentViewer |
Public class | DocumentViewerBase |
Public class | Drawing |
Public class | DrawingBrush |
Public class | DrawingImage |
Public class | Ellipse |
Public class | EllipseGeometry |
Public class | ExpandableContentControl |
Public class | Expander |
Public class | FixedPage |
Public class | FlowDocument |
Public class | FlowDocumentPageViewer |
Public class | FlowDocumentReader |
Public class | FlowDocumentScrollViewer |
Public class | FontStyleFactory |
Public class | FormatConvertedBitmap |
Public class | Frame |
Public class | Geometry |
Public class | GeometryDrawing |
Public class | GlyphRun |
Public class | GlyphRunDrawing |
Public class | Glyphs |
Public class | GradientBrush |
Public class | GradientStop |
Public class | Grid |
Public class | GridSplitter |
Public class | GridViewColumn |
Public class | GridViewColumnHeader |
Public class | GridViewHeaderRowPresenter |
Public class | GridViewRowPresenter |
Public class | GridViewRowPresenterBase |
Public class | GroupBox |
Public class | GroupItem |
Public class | HeaderedContentControl |
Public class | HeaderedItemsControl |
Public class | HwndHost |
Public class | Hyperlink | Wraps a Wpf Hyperlink element.
Public class | Image |
Public class | ImageBrush |
Public class | ImageDrawing |
Public class | ImageSource |
Public class | ImplicitInputBrush |
Public class | InkCanvas |
Public class | InkPresenter |
Public class | Inline |
Public class | InlineCollection |
Public class | Int32Rect |
Public class | InteropBitmap |
Public class | ItemsControl |
Public class | ItemsPresenter |
Public class | Label |
Public class | Line |
Public class | LinearClipper |
Public class | LinearGradientBrush |
Public class | LineGeometry |
Public class | ListBox |
Public class | ListBoxItem | Represents the ListBoxItem for Wpf control wrapper.
Public class | ListView |
Public class | ListViewItem |
Public class | Matrix |
Public class | Matrix3D |
Public class | MatrixCamera |
Public class | MatrixTransform |
Public class | MatrixTransform3D |
Public class | MediaElement |
Public class | MediaPlayer |
Public class | Menu |
Public class | MenuBase |
Public class | MenuItem |
Public class | MultiSelector |
Public class | NavigationWindow |
Public class | OrthographicCamera |
Public class | Page |
Public class | PageContent |
Public class | PageFunctionBase |
Public class | Panel |
Public class | PasswordBox |
Public class | Path |
Public class | PathGeometry |
Public class | Pen |
Public class | PerspectiveCamera |
Public class | PixelFormat |
Public class | Point |
Public class | Point3D |
Public class | Polygon |
Public class | Polyline |
Public class | Popup |
Public class | ProgressBar |
Public class | ProjectionCamera |
Public class | Quaternion |
Public class | QuaternionRotation3D |
Public class | RadialGradientBrush |
Public class | RadioButton | Wraps a WPF RadioButton element.
Public class | RangeBase |
Public class | Rating |
Public class | RatingItem |
Public class | Rect |
Public class | Rectangle |
Public class | RectangleGeometry |
Public class | RenderTargetBitmap |
Public class | RepeatButton | Wraps a Wpf RepeatButton element.
Public class | ResizeGrip |
Public class | RichTextBox |
Public class | RotateTransform |
Public class | RotateTransform3D |
Public class | Rotation3D |
Public class | Run |
Public class | ScaleTransform |
Public class | ScaleTransform3D |
Public class | ScrollBar |
Public class | ScrollContentPresenter |
Public class | ScrollViewer |
Public class | SelectiveScrollingGrid |
Public class | Selector |
Public class | Separator |
Public class | Shape |
Public class | Size |
Public class | SkewTransform |
Public class | Slider |
Public class | SolidColorBrush |
Public class | StackPanel |
Public class | StatusBar |
Public class | StatusBarItem |
Public class | StickyNoteControl |
Public class | StreamGeometry |
Public class | TabControl |
Public class | TabItem |
Public class | TabPanel |
Public class | TextBlock |
Public class | TextBox |
Public class | TextBoxBase |
Public class | Thickness |
Public class | Thumb |
Public class | TickBar |
Public class | TileBrush |
Public class | TimeSpan |
Public class | ToggleButton | Wraps a Silverlight ToggleButton element.
Public class | ToolBar |
Public class | ToolBarOverflowPanel |
Public class | ToolBarPanel |
Public class | ToolBarTray |
Public class | ToolTip |
Public class | Track |
Public class | Transform |
Public class | Transform3D |
Public class | TransformedBitmap |
Public class | TransitioningContentControl |
Public class | TranslateTransform |
Public class | TranslateTransform3D |
Public class | TreeView | Represents the TreeView for Silverlight control wrapper.
Public class | TreeViewItem | Represents the TreeViewItem for Silverlight control wrapper.
Public class | UniformGrid |
Public class | UnmanagedBitmapWrapper |
Public class | UserControl |
Public class | Vector3D |
Public class | VideoDrawing |
Public class | ViewBase |
Public class | Viewbox |
Public class | Viewport3D |
Public class | Viewport3DVisual |
Public class | VirtualizingPanel |
Public class | VirtualizingStackPanel | Wraps the Wpf VirtualizingStackPanel control.
Public class | Visual |
Public class | VisualBrush |
Public class | WebBrowser |
Public class | Window |
Public class | WpfTestElement |
Public class | WrapPanel |
Public class | WriteableBitmap |

Enumerations

 | Enumeration | Description
Public enumeration | AccordionSelectionMode |
Public enumeration | AlignmentX |
Public enumeration | AlignmentY |
Public enumeration | AutoCompleteFilterMode |
Public enumeration | AutoToolTipPlacement |
Public enumeration | BitmapCacheOption |
Public enumeration | BitmapCreateOptions |
Public enumeration | BrushMappingMode |
Public enumeration | CalendarMode |
Public enumeration | CalendarSelectionMode |
Public enumeration | CharacterCasing |
Public enumeration | ClickMode |
Public enumeration | ColorInterpolationMode |
Public enumeration | DataGridClipboardCopyMode |
Public enumeration | DataGridGridLinesVisibility |
Public enumeration | DataGridHeadersVisibility |
Public enumeration | DataGridLengthUnitType |
Public enumeration | DataGridRowDetailsVisibilityMode |
Public enumeration | DataGridSelectionMode |
Public enumeration | DataGridSelectionUnit |
Public enumeration | DatePickerFormat |
Public enumeration | DayOfWeek |
Public enumeration | Dock |
Public enumeration | ExpandDirection |
Public enumeration | FillRule |
Public enumeration | FlowDirection |
Public enumeration | FlowDocumentReaderViewingMode |
Public enumeration | GeometryCombineMode |
Public enumeration | GradientSpreadMethod |
Public enumeration | GridResizeBehavior |
Public enumeration | GridResizeDirection |
Public enumeration | GridViewColumnHeaderRole |
Public enumeration | HorizontalAlignment |
Public enumeration | InkCanvasEditingMode |
Public enumeration | JournalOwnership |
Public enumeration | LineStackingStrategy |
Public enumeration | MediaState |
Public enumeration | MenuItemRole |
Public enumeration | NavigationUIVisibility |
Public enumeration | Orientation |
Public enumeration | PenLineCap |
Public enumeration | PenLineJoin |
Public enumeration | PlacementMode |
Public enumeration | PopupAnimation |
Public enumeration | RatingSelectionMode |
Public enumeration | ResizeMode |
Public enumeration | Rotation |
Public enumeration | ScrollBarVisibility |
Public enumeration | SelectionMode |
Public enumeration | SelectionSequence |
Public enumeration | SizeToContent |
Public enumeration | StickyNoteType |
Public enumeration | Stretch |
Public enumeration | StretchDirection |
Public enumeration | StyleSimulations |
Public enumeration | TextAlignment |
Public enumeration | TextTrimming |
Public enumeration | TextWrapping |
Public enumeration | TickBarPlacement |
Public enumeration | TickPlacement |
Public enumeration | TileMode |
Public enumeration | VerticalAlignment |
Public enumeration | Visibility |
Public enumeration | WindowState |
Public enumeration | WindowStyle |


AccessText Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText Members
AccessText Class Constructors Methods Fields Properties See Also Send Feedback

The AccessText type exposes the following members.

Constructors

 | Name | Description
Public method | AccessText | Initializes a new instance of the AccessText class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BaselineOffsetProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
LineHeightProperty |
LineStackingStrategyProperty |
TextAlignmentProperty |
TextProperty |
TextTrimmingProperty |
TextWrappingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BaselineOffset |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LineHeight |
Public property | LineStackingStrategy |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextTrimming |
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccessText Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText Constructor
AccessText Class See Also Send Feedback
Initializes a new instance of the AccessText class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AccessText()
Visual Basic
Public Sub New
Visual C++
public:
AccessText()

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccessText Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText Fields
AccessText Class See Also Send Feedback

The AccessText type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BaselineOffsetProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
LineHeightProperty |
LineStackingStrategyProperty |
TextAlignmentProperty |
TextProperty |
TextTrimmingProperty |
TextWrappingProperty |

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..BackgroundProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BaselineOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..BaselineOffsetProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.BaselineOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BaselineOffsetProperty
Visual Basic
Public Shared BaselineOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BaselineOffsetProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontFamilyProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontSizeProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontStretchProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontStretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStretchProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontStyleProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontStyleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStyleProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontWeightProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontWeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontWeightProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..ForegroundProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..LineHeightProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.LineHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineHeightProperty
Visual Basic
Public Shared LineHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineHeightProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineStackingStrategyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..LineStackingStrategyProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.LineStackingStrategyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineStackingStrategyProperty
Visual Basic
Public Shared LineStackingStrategyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineStackingStrategyProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..TextAlignmentProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.TextAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextAlignmentProperty
Visual Basic
Public Shared TextAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextAlignmentProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..TextProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.TextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextTrimmingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..TextTrimmingProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.TextTrimmingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextTrimmingProperty
Visual Basic
Public Shared TextTrimmingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextTrimmingProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextWrappingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..TextWrappingProperty Field
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.TextWrappingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextWrappingProperty
Visual Basic
Public Shared TextWrappingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextWrappingProperty

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccessText Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText Methods
AccessText Class See Also Send Feedback

The AccessText type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..AnySibling Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..GetProperty Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..GetRealType Method
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..GetRectangle Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..Highlight Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..InvokeMethod Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..IsHitTest Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..NextSibling Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..Parent Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..PreviousSibling Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..ScrollToVisible Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..SetProperty Method
AccessText Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccessText Class
AccessText Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccessText Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText Properties
AccessText Class See Also Send Feedback

The AccessText type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BaselineOffset |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LineHeight |
Public property | LineStackingStrategy |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextTrimming |
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..Background Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BaselineOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..BaselineOffset Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.BaselineOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double BaselineOffset { get; set; }
Visual Basic
Public Property BaselineOffset As Double
    Get
    Set
Visual C++
public:
property double BaselineOffset {
    double get ();
    void set (double value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontFamily Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontFamily"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontSize Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic
Public Property FontSize As Double
    Get
    Set
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontStretch Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontStretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic
Public ReadOnly Property FontStretch As FontStretch
    Get
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontStyle Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontStyle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyle FontStyle { get; }
Visual Basic
Public ReadOnly Property FontStyle As FontStyle
    Get
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..FontWeight Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.FontWeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic
Public ReadOnly Property FontWeight As FontWeight
    Get
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..Foreground Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.Foreground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic
Public Property Foreground As Brush
    Get
    Set
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..LineHeight Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.LineHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double LineHeight { get; set; }
Visual Basic
Public Property LineHeight As Double
    Get
    Set
Visual C++
public:
property double LineHeight {
    double get ();
    void set (double value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineStackingStrategy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..LineStackingStrategy Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.LineStackingStrategy"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LineStackingStrategy LineStackingStrategy { get; set; }
Visual Basic
Public Property LineStackingStrategy As LineStackingStrategy
    Get
    Set
Visual C++
public:
property LineStackingStrategy LineStackingStrategy {
    LineStackingStrategy get ();
    void set (LineStackingStrategy value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..Text Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.Text"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..TextAlignment Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.TextAlignment"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As TextAlignment
    Get
    Set
Visual C++
public:
property TextAlignment TextAlignment {
    TextAlignment get ();
    void set (TextAlignment value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextTrimming Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..TextTrimming Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.TextTrimming"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextTrimming TextTrimming { get; set; }
Visual Basic
Public Property TextTrimming As TextTrimming
    Get
    Set
Visual C++
public:
property TextTrimming TextTrimming {
    TextTrimming get ();
    void set (TextTrimming value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextWrapping Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccessText..::..TextWrapping Property
AccessText Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccessText.TextWrapping"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextWrapping TextWrapping { get; set; }
Visual Basic
Public Property TextWrapping As TextWrapping
    Get
    Set
Visual C++
public:
property TextWrapping TextWrapping {
    TextWrapping get ();
    void set (TextWrapping value);
}

See Also

AccessText Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Accordion Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion Members
Accordion Class Constructors Methods Fields Properties See Also Send Feedback

The Accordion type exposes the following members.

Constructors

 | Name | Description
Public method | Accordion | Initializes a new instance of the Accordion class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ExpandDirectionProperty |
SelectedIndexProperty |
SelectedIndicesProperty |
SelectionModeProperty |
SelectionSequenceProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExpandDirection |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex |
Public property | SelectedIndices |
Public property | SelectionMode |
Public property | SelectionSequence |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Accordion Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion Constructor
Accordion Class See Also Send Feedback
Initializes a new instance of the Accordion class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Accordion()
Visual Basic
Public Sub New
Visual C++
public:
Accordion()

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Accordion Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion Fields
Accordion Class See Also Send Feedback

The Accordion type exposes the following members.

Fields

Name | Description
ExpandDirectionProperty |
SelectedIndexProperty |
SelectedIndicesProperty |
SelectionModeProperty |
SelectionSequenceProperty |

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..ExpandDirectionProperty Field
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.ExpandDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExpandDirectionProperty
Visual Basic
Public Shared ExpandDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExpandDirectionProperty

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SelectedIndexProperty Field
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.SelectedIndexProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedIndexProperty
Visual Basic
Public Shared SelectedIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedIndexProperty

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedIndicesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SelectedIndicesProperty Field
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.SelectedIndicesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedIndicesProperty
Visual Basic
Public Shared SelectedIndicesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedIndicesProperty

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SelectionModeProperty Field
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.SelectionModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionModeProperty
Visual Basic
Public Shared SelectionModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionModeProperty

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionSequenceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SelectionSequenceProperty Field
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.SelectionSequenceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionSequenceProperty
Visual Basic
Public Shared SelectionSequenceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionSequenceProperty

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Accordion Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion Methods
Accordion Class See Also Send Feedback

The Accordion type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..AnySibling Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..GetProperty Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..GetRealType Method
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..GetRectangle Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..Highlight Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..InvokeMethod Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..IsHitTest Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..NextSibling Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..Parent Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..PreviousSibling Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..ScrollToVisible Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SetProperty Method
Accordion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Accordion Class
Accordion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Accordion Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion Properties
Accordion Class See Also Send Feedback

The Accordion type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExpandDirection |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex |
Public property | SelectedIndices |
Public property | SelectionMode |
Public property | SelectionSequence |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..ExpandDirection Property
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.ExpandDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExpandDirection ExpandDirection { get; set; }
Visual Basic
Public Property ExpandDirection As ExpandDirection
    Get
    Set
Visual C++
public:
property ExpandDirection ExpandDirection {
    ExpandDirection get ();
    void set (ExpandDirection value);
}

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SelectedIndex Property
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.SelectedIndex"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedIndices Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SelectedIndices Property
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.SelectedIndices"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<int> SelectedIndices { get; set; }
Visual Basic
Public Property SelectedIndices As IList(Of Integer)
    Get
    Set
Visual C++
public:
property IList<int>^ SelectedIndices {
    IList<int>^ get ();
    void set (IList<int>^ value);
}

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SelectionMode Property
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.SelectionMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AccordionSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As AccordionSelectionMode
    Get
    Set
Visual C++
public:
property AccordionSelectionMode SelectionMode {
    AccordionSelectionMode get ();
    void set (AccordionSelectionMode value);
}

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionSequence Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Accordion..::..SelectionSequence Property
Accordion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Accordion.SelectionSequence"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SelectionSequence SelectionSequence { get; set; }
Visual Basic
Public Property SelectionSequence As SelectionSequence
    Get
    Set
Visual C++
public:
property SelectionSequence SelectionSequence {
    SelectionSequence get ();
    void set (SelectionSequence value);
}

See Also

Accordion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton Members
AccordionButton Class Constructors Methods Properties See Also Send Feedback

The AccordionButton type exposes the following members.

Constructors

 | Name | Description
Public method | AccordionButton | Initializes a new instance of the AccordionButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AccordionButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton Constructor
AccordionButton Class See Also Send Feedback
Initializes a new instance of the AccordionButton class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AccordionButton()
Visual Basic
Public Sub New
Visual C++
public:
AccordionButton()

See Also

AccordionButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton Methods
AccordionButton Class See Also Send Feedback

The AccordionButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AccordionButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..AnySibling Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..GetProperty Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..GetRealType Method
AccordionButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AccordionButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..GetRectangle Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..Highlight Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..InvokeMethod Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..IsHitTest Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..NextSibling Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..Parent Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..PreviousSibling Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..ScrollToVisible Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton..::..SetProperty Method
AccordionButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccordionButton Class
AccordionButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionButton Properties
AccordionButton Class See Also Send Feedback

The AccordionButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AccordionButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem Members
AccordionItem Class Constructors Methods Fields Properties See Also Send Feedback

The AccordionItem type exposes the following members.

Constructors

 | Name | Description
Public method | AccordionItem | Initializes a new instance of the AccordionItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ContentTargetSizeProperty |
ExpandDirectionProperty |
IsSelectedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTargetSize |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExpandDirection |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader | (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem Constructor
AccordionItem Class See Also Send Feedback
Initializes a new instance of the AccordionItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AccordionItem()
Visual Basic
Public Sub New
Visual C++
public:
AccordionItem()

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem Fields
AccordionItem Class See Also Send Feedback

The AccordionItem type exposes the following members.

Fields

Name | Description
ContentTargetSizeProperty |
ExpandDirectionProperty |
IsSelectedProperty |

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentTargetSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..ContentTargetSizeProperty Field
AccordionItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionItem.ContentTargetSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentTargetSizeProperty
Visual Basic
Public Shared ContentTargetSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentTargetSizeProperty

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..ExpandDirectionProperty Field
AccordionItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionItem.ExpandDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExpandDirectionProperty
Visual Basic
Public Shared ExpandDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExpandDirectionProperty

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..IsSelectedProperty Field
AccordionItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionItem.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem Methods
AccordionItem Class See Also Send Feedback

The AccordionItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..AnySibling Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..GetProperty Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..GetRealType Method
AccordionItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..GetRectangle Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..Highlight Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..InvokeMethod Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..IsHitTest Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..NextSibling Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..Parent Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..PreviousSibling Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..ScrollToVisible Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..SetProperty Method
AccordionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AccordionItem Class
AccordionItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AccordionItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem Properties
AccordionItem Class See Also Send Feedback

The AccordionItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTargetSize |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExpandDirection |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader | (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentTargetSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..ContentTargetSize Property
AccordionItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionItem.ContentTargetSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Size ContentTargetSize { get; set; }
Visual Basic
Public Property ContentTargetSize As Size
    Get
    Set
Visual C++
public:
property Size^ ContentTargetSize {
    Size^ get ();
    void set (Size^ value);
}

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..ExpandDirection Property
AccordionItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionItem.ExpandDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExpandDirection ExpandDirection { get; set; }
Visual Basic
Public Property ExpandDirection As ExpandDirection
    Get
    Set
Visual C++
public:
property ExpandDirection ExpandDirection {
    ExpandDirection get ();
    void set (ExpandDirection value);
}

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AccordionItem..::..IsSelected Property
AccordionItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AccordionItem.IsSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

AccordionItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ActiveXHost Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost Members
ActiveXHost Class Constructors Methods Properties See Also Send Feedback

The ActiveXHost type exposes the following members.

Constructors

 | Name | Description
Public method | ActiveXHost | Initializes a new instance of the ActiveXHost class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HwndHost..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ActiveXHost Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost Constructor
ActiveXHost Class See Also Send Feedback
Initializes a new instance of the ActiveXHost class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ActiveXHost()
Visual Basic
Public Sub New
Visual C++
public:
ActiveXHost()

See Also

ActiveXHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ActiveXHost Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost Methods
ActiveXHost Class See Also Send Feedback

The ActiveXHost type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HwndHost..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..AnySibling Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..GetProperty Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..GetRealType Method
ActiveXHost Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ActiveXHost.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ActiveXHost.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ActiveXHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..GetRectangle Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..Highlight Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..InvokeMethod Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..IsHitTest Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..NextSibling Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..Parent Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..PreviousSibling Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..ScrollToVisible Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost..::..SetProperty Method
ActiveXHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ActiveXHost Class
ActiveXHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ActiveXHost Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ActiveXHost Properties
ActiveXHost Class See Also Send Feedback

The ActiveXHost type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ActiveXHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornedElementPlaceholder Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder Members
AdornedElementPlaceholder Class Constructors Methods Properties See Also Send Feedback

The AdornedElementPlaceholder type exposes the following members.

Constructors

 | Name | Description
Public method | AdornedElementPlaceholder | Initializes a new instance of the AdornedElementPlaceholder class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornedElementPlaceholder Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder Constructor
AdornedElementPlaceholder Class See Also Send Feedback
Initializes a new instance of the AdornedElementPlaceholder class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AdornedElementPlaceholder()
Visual Basic
Public Sub New
Visual C++
public:
AdornedElementPlaceholder()

See Also

AdornedElementPlaceholder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornedElementPlaceholder Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder Methods
AdornedElementPlaceholder Class See Also Send Feedback

The AdornedElementPlaceholder type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..AnySibling Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..GetProperty Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..GetRealType Method
AdornedElementPlaceholder Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AdornedElementPlaceholder.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AdornedElementPlaceholder.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AdornedElementPlaceholder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..GetRectangle Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..Highlight Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..InvokeMethod Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..IsHitTest Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..NextSibling Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..Parent Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..PreviousSibling Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..ScrollToVisible Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder..::..SetProperty Method
AdornedElementPlaceholder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornedElementPlaceholder Class
AdornedElementPlaceholder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornedElementPlaceholder Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornedElementPlaceholder Properties
AdornedElementPlaceholder Class See Also Send Feedback

The AdornedElementPlaceholder type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AdornedElementPlaceholder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Adorner Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner Members
Adorner Class Constructors Methods Properties See Also Send Feedback

The Adorner type exposes the following members.

Constructors

 | Name | Description
Public method | Adorner | Initializes a new instance of the Adorner class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Adorner Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Adorner Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner Constructor
Adorner Class See Also Send Feedback
Initializes a new instance of the Adorner class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Adorner()
Visual Basic
Public Sub New
Visual C++
public:
Adorner()

See Also

Adorner Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Adorner Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner Methods
Adorner Class See Also Send Feedback

The Adorner type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Adorner Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..AnySibling Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..GetProperty Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..GetRealType Method
Adorner Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Adorner.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Adorner.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Adorner Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..GetRectangle Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..Highlight Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..InvokeMethod Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..IsHitTest Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..NextSibling Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..Parent Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..PreviousSibling Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..ScrollToVisible Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner..::..SetProperty Method
Adorner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Adorner Class
Adorner Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Adorner Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Adorner Properties
Adorner Class See Also Send Feedback

The Adorner type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Adorner Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornerDecorator Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator Members
AdornerDecorator Class Constructors Methods Properties See Also Send Feedback

The AdornerDecorator type exposes the following members.

Constructors

 | Name | Description
Public method | AdornerDecorator | Initializes a new instance of the AdornerDecorator class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornerDecorator Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator Constructor
AdornerDecorator Class See Also Send Feedback
Initializes a new instance of the AdornerDecorator class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AdornerDecorator()
Visual Basic
Public Sub New
Visual C++
public:
AdornerDecorator()

See Also

AdornerDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornerDecorator Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator Methods
AdornerDecorator Class See Also Send Feedback

The AdornerDecorator type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..AnySibling Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..GetProperty Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..GetRealType Method
AdornerDecorator Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AdornerDecorator.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AdornerDecorator.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AdornerDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..GetRectangle Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..Highlight Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..InvokeMethod Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..IsHitTest Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..NextSibling Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..Parent Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..PreviousSibling Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..ScrollToVisible Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator..::..SetProperty Method
AdornerDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornerDecorator Class
AdornerDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornerDecorator Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerDecorator Properties
AdornerDecorator Class See Also Send Feedback

The AdornerDecorator type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AdornerDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornerLayer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer Members
AdornerLayer Class Constructors Methods Properties See Also Send Feedback

The AdornerLayer type exposes the following members.

Constructors

 | Name | Description
Public method | AdornerLayer | Initializes a new instance of the AdornerLayer class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornerLayer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer Constructor
AdornerLayer Class See Also Send Feedback
Initializes a new instance of the AdornerLayer class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AdornerLayer()
Visual Basic
Public Sub New
Visual C++
public:
AdornerLayer()

See Also

AdornerLayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornerLayer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer Methods
AdornerLayer Class See Also Send Feedback

The AdornerLayer type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..AnySibling Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..GetProperty Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..GetRealType Method
AdornerLayer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AdornerLayer.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AdornerLayer.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AdornerLayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..GetRectangle Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..Highlight Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..InvokeMethod Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..IsHitTest Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..NextSibling Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..Parent Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..PreviousSibling Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..ScrollToVisible Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer..::..SetProperty Method
AdornerLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdornerLayer Class
AdornerLayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AdornerLayer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdornerLayer Properties
AdornerLayer Class See Also Send Feedback

The AdornerLayer type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AdornerLayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AffineTransform3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AffineTransform3D Members
AffineTransform3D Class Constructors Methods Properties See Also Send Feedback

The AffineTransform3D type exposes the following members.

Constructors

 | Name | Description
Public method | AffineTransform3D | Initializes a new instance of the AffineTransform3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AffineTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AffineTransform3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AffineTransform3D Constructor
AffineTransform3D Class See Also Send Feedback
Initializes a new instance of the AffineTransform3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AffineTransform3D()
Visual Basic
Public Sub New
Visual C++
public:
AffineTransform3D()

See Also

AffineTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AffineTransform3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AffineTransform3D Methods
AffineTransform3D Class See Also Send Feedback

The AffineTransform3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AffineTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AffineTransform3D..::..GetProperty Method
AffineTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AffineTransform3D Class
AffineTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AffineTransform3D..::..GetRealType Method
AffineTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AffineTransform3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AffineTransform3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AffineTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AffineTransform3D..::..InvokeMethod Method
AffineTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AffineTransform3D Class
AffineTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AffineTransform3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AffineTransform3D Properties
AffineTransform3D Class See Also Send Feedback

The AffineTransform3D type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AffineTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoCompleteBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Members
AutoCompleteBox Class Constructors Methods Fields Properties See Also Send Feedback

The AutoCompleteBox type exposes the following members.

Constructors

 | Name | Description
Public method | AutoCompleteBox | Initializes a new instance of the AutoCompleteBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FilterModeProperty |
IsDropDownOpenProperty |
IsTextCompletionEnabledProperty |
MaxDropDownHeightProperty |
MinimumPopulateDelayProperty |
MinimumPrefixLengthProperty |
SearchTextProperty |
TextProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | FilterMode |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextCompletionEnabled |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinimumPopulateDelay |
Public property | MinimumPrefixLength |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SearchText |
Public property | Selector | Get the drop down list box element holding the items to select.
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextBox | Get the actual TextBox element to type text into. Override for custom control template!
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoCompleteBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Constructor
AutoCompleteBox Class See Also Send Feedback
Initializes a new instance of the AutoCompleteBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutoCompleteBox()
Visual Basic
Public Sub New
Visual C++
public:
AutoCompleteBox()

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoCompleteBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Fields
AutoCompleteBox Class See Also Send Feedback

The AutoCompleteBox type exposes the following members.

Fields

Name | Description
FilterModeProperty |
IsDropDownOpenProperty |
IsTextCompletionEnabledProperty |
MaxDropDownHeightProperty |
MinimumPopulateDelayProperty |
MinimumPrefixLengthProperty |
SearchTextProperty |
TextProperty |

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FilterModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..FilterModeProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.FilterModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FilterModeProperty
Visual Basic
Public Shared FilterModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FilterModeProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDropDownOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsDropDownOpenProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.IsDropDownOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDropDownOpenProperty
Visual Basic
Public Shared IsDropDownOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDropDownOpenProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTextCompletionEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsTextCompletionEnabledProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.IsTextCompletionEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTextCompletionEnabledProperty
Visual Basic
Public Shared IsTextCompletionEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTextCompletionEnabledProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxDropDownHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MaxDropDownHeightProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.MaxDropDownHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxDropDownHeightProperty
Visual Basic
Public Shared MaxDropDownHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxDropDownHeightProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinimumPopulateDelayProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MinimumPopulateDelayProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.MinimumPopulateDelayProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinimumPopulateDelayProperty
Visual Basic
Public Shared MinimumPopulateDelayProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinimumPopulateDelayProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinimumPrefixLengthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MinimumPrefixLengthProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.MinimumPrefixLengthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinimumPrefixLengthProperty
Visual Basic
Public Shared MinimumPrefixLengthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinimumPrefixLengthProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SearchTextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..SearchTextProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.SearchTextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SearchTextProperty
Visual Basic
Public Shared SearchTextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SearchTextProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..TextProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.TextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoCompleteBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Methods
AutoCompleteBox Class See Also Send Feedback

The AutoCompleteBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..AnySibling Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..GetProperty Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..GetRealType Method
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..GetRectangle Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Highlight Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..InvokeMethod Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsHitTest Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..NextSibling Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Parent Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..PreviousSibling Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..ScrollToVisible Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Select Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Select Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Select Method (Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Select Method (Boolean, Int32)
AutoCompleteBox Class See Also Send Feedback
Selects item in the drop down if open.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Select(
    bool simulateRealUser,
    int itemIndex
)
Visual Basic
Public Sub Select ( _
    simulateRealUser As Boolean, _
    itemIndex As Integer _
)
Visual C++
public:
virtual void Select(
    bool simulateRealUser,
    int itemIndex
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates real click, otherwise changes selection.
itemIndex
Type: System..::..Int32

[Missing <param name="itemIndex"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.Select(System.Boolean,System.Int32)"]

Implements

IAutoCompleteBox..::..Select(Boolean, Int32)

See Also

AutoCompleteBox Class
Select Overload
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Select Method (Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Select Method (Boolean, String)
AutoCompleteBox Class See Also Send Feedback
Selects item in the drop down if open.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Select(
    bool simulateRealUser,
    string itemText
)
Visual Basic
Public Sub Select ( _
    simulateRealUser As Boolean, _
    itemText As String _
)
Visual C++
public:
virtual void Select(
    bool simulateRealUser,
    String^ itemText
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates real click, otherwise changes selection.
itemText
Type: System..::..String
The text of the item to select.

Implements

IAutoCompleteBox..::..Select(Boolean, String)

See Also

AutoCompleteBox Class
Select Overload
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..SetProperty Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..SetText Method
AutoCompleteBox Class See Also Send Feedback
Sets or types a new text into the TextBox.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
virtual void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the text.
text
Type: System..::..String
The text to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key

Implements

IAutoCompleteBox..::..SetText(Boolean, String, Int32, Int32)

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoCompleteBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Properties
AutoCompleteBox Class See Also Send Feedback

The AutoCompleteBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | FilterMode |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextCompletionEnabled |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinimumPopulateDelay |
Public property | MinimumPrefixLength |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SearchText |
Public property | Selector | Get the drop down list box element holding the items to select.
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextBox | Get the actual TextBox element to type text into. Override for custom control template!
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FilterMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..FilterMode Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.FilterMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutoCompleteFilterMode FilterMode { get; set; }
Visual Basic
Public Property FilterMode As AutoCompleteFilterMode
    Get
    Set
Visual C++
public:
property AutoCompleteFilterMode FilterMode {
    AutoCompleteFilterMode get ();
    void set (AutoCompleteFilterMode value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDropDownOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsDropDownOpen Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.IsDropDownOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic
Public Property IsDropDownOpen As Boolean
    Get
    Set
Visual C++
public:
property bool IsDropDownOpen {
    bool get ();
    void set (bool value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTextCompletionEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsTextCompletionEnabled Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.IsTextCompletionEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTextCompletionEnabled { get; set; }
Visual Basic
Public Property IsTextCompletionEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsTextCompletionEnabled {
    bool get ();
    void set (bool value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxDropDownHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MaxDropDownHeight Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.MaxDropDownHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxDropDownHeight { get; set; }
Visual Basic
Public Property MaxDropDownHeight As Double
    Get
    Set
Visual C++
public:
property double MaxDropDownHeight {
    double get ();
    void set (double value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinimumPopulateDelay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MinimumPopulateDelay Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.MinimumPopulateDelay"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MinimumPopulateDelay { get; set; }
Visual Basic
Public Property MinimumPopulateDelay As Integer
    Get
    Set
Visual C++
public:
property int MinimumPopulateDelay {
    int get ();
    void set (int value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinimumPrefixLength Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MinimumPrefixLength Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.MinimumPrefixLength"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MinimumPrefixLength { get; set; }
Visual Basic
Public Property MinimumPrefixLength As Integer
    Get
    Set
Visual C++
public:
property int MinimumPrefixLength {
    int get ();
    void set (int value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SearchText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..SearchText Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.SearchText"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SearchText { get; set; }
Visual Basic
Public Property SearchText As String
    Get
    Set
Visual C++
public:
property String^ SearchText {
    String^ get ();
    void set (String^ value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Selector Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Selector Property
AutoCompleteBox Class See Also Send Feedback
Get the drop down list box element holding the items to select.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IListBox Selector { get; }
Visual Basic
Public Overridable ReadOnly Property Selector As IListBox
    Get
Visual C++
public:
virtual property IListBox^ Selector {
    IListBox^ get ();
}

Implements

IAutoCompleteBox..::..Selector

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Text Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AutoCompleteBox.Text"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFrameworkElement..::..Text

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..TextBox Property
AutoCompleteBox Class See Also Send Feedback
Get the actual TextBox element to type text into. Override for custom control template!

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual TextBox TextBox { get; }
Visual Basic
Public Overridable ReadOnly Property TextBox As TextBox
    Get
Visual C++
public:
virtual property TextBox^ TextBox {
    TextBox^ get ();
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AxisAngleRotation3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D Members
AxisAngleRotation3D Class Constructors Methods Fields Properties See Also Send Feedback

The AxisAngleRotation3D type exposes the following members.

Constructors

 | Name | Description
Public method | AxisAngleRotation3D | Initializes a new instance of the AxisAngleRotation3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Rotation3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AngleProperty |
AxisProperty |

Properties

 | Name | Description
Public property | Angle |
Public property | Axis |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AxisAngleRotation3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D Constructor
AxisAngleRotation3D Class See Also Send Feedback
Initializes a new instance of the AxisAngleRotation3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AxisAngleRotation3D()
Visual Basic
Public Sub New
Visual C++
public:
AxisAngleRotation3D()

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AxisAngleRotation3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D Fields
AxisAngleRotation3D Class See Also Send Feedback

The AxisAngleRotation3D type exposes the following members.

Fields

Name | Description
AngleProperty |
AxisProperty |

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AngleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D..::..AngleProperty Field
AxisAngleRotation3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AxisAngleRotation3D.AngleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AngleProperty
Visual Basic
Public Shared AngleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AngleProperty

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AxisProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D..::..AxisProperty Field
AxisAngleRotation3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.AxisAngleRotation3D.AxisProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AxisProperty
Visual Basic
Public Shared AxisProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AxisProperty

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AxisAngleRotation3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D Methods
AxisAngleRotation3D Class See Also Send Feedback

The AxisAngleRotation3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Rotation3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D..::..GetProperty Method
AxisAngleRotation3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AxisAngleRotation3D Class
AxisAngleRotation3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D..::..GetRealType Method
AxisAngleRotation3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AxisAngleRotation3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.AxisAngleRotation3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D..::..InvokeMethod Method
AxisAngleRotation3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AxisAngleRotation3D Class
AxisAngleRotation3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AxisAngleRotation3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D Properties
AxisAngleRotation3D Class See Also Send Feedback

The AxisAngleRotation3D type exposes the following members.

Properties

 | Name | Description
Public property | Angle |
Public property | Axis |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Angle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D..::..Angle Property
AxisAngleRotation3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AxisAngleRotation3D.Angle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Axis Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AxisAngleRotation3D..::..Axis Property
AxisAngleRotation3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.AxisAngleRotation3D.Axis"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Vector3D Axis { get; set; }
Visual Basic
Public Property Axis As Vector3D
    Get
    Set
Visual C++
public:
property Vector3D^ Axis {
    Vector3D^ get ();
    void set (Vector3D^ value);
}

See Also

AxisAngleRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BindingGroup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BindingGroup Members
BindingGroup Class Constructors Methods Properties See Also Send Feedback

The BindingGroup type exposes the following members.

Constructors

 | Name | Description
Public method | BindingGroup | Initializes a new instance of the BindingGroup class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BindingGroup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BindingGroup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BindingGroup Constructor
BindingGroup Class See Also Send Feedback
Initializes a new instance of the BindingGroup class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BindingGroup()
Visual Basic
Public Sub New
Visual C++
public:
BindingGroup()

See Also

BindingGroup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BindingGroup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BindingGroup Methods
BindingGroup Class See Also Send Feedback

The BindingGroup type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindingGroup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BindingGroup..::..GetProperty Method
BindingGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BindingGroup Class
BindingGroup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BindingGroup..::..GetRealType Method
BindingGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BindingGroup.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BindingGroup.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BindingGroup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BindingGroup..::..InvokeMethod Method
BindingGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BindingGroup Class
BindingGroup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BindingGroup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BindingGroup Properties
BindingGroup Class See Also Send Feedback

The BindingGroup type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BindingGroup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrame Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrame Members
BitmapFrame Class Constructors Methods Properties See Also Send Feedback

The BitmapFrame type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapFrame | Initializes a new instance of the BitmapFrame class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrame Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrame Constructor
BitmapFrame Class See Also Send Feedback
Initializes a new instance of the BitmapFrame class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapFrame()
Visual Basic
Public Sub New
Visual C++
public:
BitmapFrame()

See Also

BitmapFrame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrame Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrame Methods
BitmapFrame Class See Also Send Feedback

The BitmapFrame type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapFrame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrame..::..GetProperty Method
BitmapFrame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrame Class
BitmapFrame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrame..::..GetRealType Method
BitmapFrame Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapFrame.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapFrame.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BitmapFrame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrame..::..InvokeMethod Method
BitmapFrame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrame Class
BitmapFrame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrame Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrame Properties
BitmapFrame Class See Also Send Feedback

The BitmapFrame type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrameDecode Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameDecode Members
BitmapFrameDecode Class Constructors Methods Properties See Also Send Feedback

The BitmapFrameDecode type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapFrameDecode | Initializes a new instance of the BitmapFrameDecode class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapFrame..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrameDecode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrameDecode Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameDecode Constructor
BitmapFrameDecode Class See Also Send Feedback
Initializes a new instance of the BitmapFrameDecode class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapFrameDecode()
Visual Basic
Public Sub New
Visual C++
public:
BitmapFrameDecode()

See Also

BitmapFrameDecode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrameDecode Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameDecode Methods
BitmapFrameDecode Class See Also Send Feedback

The BitmapFrameDecode type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapFrame..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapFrameDecode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameDecode..::..GetProperty Method
BitmapFrameDecode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrameDecode Class
BitmapFrameDecode Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameDecode..::..GetRealType Method
BitmapFrameDecode Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapFrameDecode.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapFrameDecode.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BitmapFrameDecode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameDecode..::..InvokeMethod Method
BitmapFrameDecode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrameDecode Class
BitmapFrameDecode Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrameDecode Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameDecode Properties
BitmapFrameDecode Class See Also Send Feedback

The BitmapFrameDecode type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrameDecode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrameEncode Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameEncode Members
BitmapFrameEncode Class Constructors Methods Properties See Also Send Feedback

The BitmapFrameEncode type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapFrameEncode | Initializes a new instance of the BitmapFrameEncode class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapFrame..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrameEncode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrameEncode Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameEncode Constructor
BitmapFrameEncode Class See Also Send Feedback
Initializes a new instance of the BitmapFrameEncode class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapFrameEncode()
Visual Basic
Public Sub New
Visual C++
public:
BitmapFrameEncode()

See Also

BitmapFrameEncode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrameEncode Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameEncode Methods
BitmapFrameEncode Class See Also Send Feedback

The BitmapFrameEncode type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapFrame..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapFrameEncode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameEncode..::..GetProperty Method
BitmapFrameEncode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrameEncode Class
BitmapFrameEncode Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameEncode..::..GetRealType Method
BitmapFrameEncode Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapFrameEncode.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapFrameEncode.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BitmapFrameEncode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameEncode..::..InvokeMethod Method
BitmapFrameEncode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrameEncode Class
BitmapFrameEncode Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapFrameEncode Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapFrameEncode Properties
BitmapFrameEncode Class See Also Send Feedback

The BitmapFrameEncode type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapFrameEncode Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapImage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Members
BitmapImage Class Constructors Methods Fields Properties See Also Send Feedback

The BitmapImage type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapImage | Initializes a new instance of the BitmapImage class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CacheOptionProperty |
CreateOptionsProperty |
DecodePixelHeightProperty |
DecodePixelWidthProperty |
RotationProperty |
SourceRectProperty |

Properties

 | Name | Description
Public property | CacheOption |
Public property | CreateOptions |
Public property | DecodePixelHeight |
Public property | DecodePixelWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rotation |
Public property | SourceRect |

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapImage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Constructor
BitmapImage Class See Also Send Feedback
Initializes a new instance of the BitmapImage class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapImage()
Visual Basic
Public Sub New
Visual C++
public:
BitmapImage()

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapImage Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Fields
BitmapImage Class See Also Send Feedback

The BitmapImage type exposes the following members.

Fields

Name | Description
CacheOptionProperty |
CreateOptionsProperty |
DecodePixelHeightProperty |
DecodePixelWidthProperty |
RotationProperty |
SourceRectProperty |

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CacheOptionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..CacheOptionProperty Field
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.CacheOptionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CacheOptionProperty
Visual Basic
Public Shared CacheOptionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CacheOptionProperty

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CreateOptionsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..CreateOptionsProperty Field
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.CreateOptionsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CreateOptionsProperty
Visual Basic
Public Shared CreateOptionsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CreateOptionsProperty

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DecodePixelHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..DecodePixelHeightProperty Field
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.DecodePixelHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DecodePixelHeightProperty
Visual Basic
Public Shared DecodePixelHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DecodePixelHeightProperty

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DecodePixelWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..DecodePixelWidthProperty Field
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.DecodePixelWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DecodePixelWidthProperty
Visual Basic
Public Shared DecodePixelWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DecodePixelWidthProperty

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..RotationProperty Field
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.RotationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RotationProperty
Visual Basic
Public Shared RotationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RotationProperty

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceRectProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..SourceRectProperty Field
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.SourceRectProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceRectProperty
Visual Basic
Public Shared SourceRectProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceRectProperty

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapImage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Methods
BitmapImage Class See Also Send Feedback

The BitmapImage type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..GetProperty Method
BitmapImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapImage Class
BitmapImage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..GetRealType Method
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..InvokeMethod Method
BitmapImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapImage Class
BitmapImage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapImage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Properties
BitmapImage Class See Also Send Feedback

The BitmapImage type exposes the following members.

Properties

 | Name | Description
Public property | CacheOption |
Public property | CreateOptions |
Public property | DecodePixelHeight |
Public property | DecodePixelWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rotation |
Public property | SourceRect |

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CacheOption Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..CacheOption Property
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.CacheOption"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapCacheOption CacheOption { get; set; }
Visual Basic
Public Property CacheOption As BitmapCacheOption
    Get
    Set
Visual C++
public:
property BitmapCacheOption CacheOption {
    BitmapCacheOption get ();
    void set (BitmapCacheOption value);
}

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CreateOptions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..CreateOptions Property
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.CreateOptions"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapCreateOptions CreateOptions { get; set; }
Visual Basic
Public Property CreateOptions As BitmapCreateOptions
    Get
    Set
Visual C++
public:
property BitmapCreateOptions CreateOptions {
    BitmapCreateOptions get ();
    void set (BitmapCreateOptions value);
}

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DecodePixelHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..DecodePixelHeight Property
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.DecodePixelHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int DecodePixelHeight { get; set; }
Visual Basic
Public Property DecodePixelHeight As Integer
    Get
    Set
Visual C++
public:
property int DecodePixelHeight {
    int get ();
    void set (int value);
}

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DecodePixelWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..DecodePixelWidth Property
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.DecodePixelWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int DecodePixelWidth { get; set; }
Visual Basic
Public Property DecodePixelWidth As Integer
    Get
    Set
Visual C++
public:
property int DecodePixelWidth {
    int get ();
    void set (int value);
}

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rotation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..Rotation Property
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.Rotation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rotation Rotation { get; set; }
Visual Basic
Public Property Rotation As Rotation
    Get
    Set
Visual C++
public:
property Rotation Rotation {
    Rotation get ();
    void set (Rotation value);
}

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceRect Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..SourceRect Property
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapImage.SourceRect"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Int32Rect SourceRect { get; set; }
Visual Basic
Public Property SourceRect As Int32Rect
    Get
    Set
Visual C++
public:
property Int32Rect^ SourceRect {
    Int32Rect^ get ();
    void set (Int32Rect^ value);
}

See Also

BitmapImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapPalette Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapPalette Members
BitmapPalette Class Constructors Methods Properties See Also Send Feedback

The BitmapPalette type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapPalette | Initializes a new instance of the BitmapPalette class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapPalette Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapPalette Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapPalette Constructor
BitmapPalette Class See Also Send Feedback
Initializes a new instance of the BitmapPalette class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapPalette()
Visual Basic
Public Sub New
Visual C++
public:
BitmapPalette()

See Also

BitmapPalette Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapPalette Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapPalette Methods
BitmapPalette Class See Also Send Feedback

The BitmapPalette type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapPalette Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapPalette..::..GetProperty Method
BitmapPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapPalette Class
BitmapPalette Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapPalette..::..GetRealType Method
BitmapPalette Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapPalette.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapPalette.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BitmapPalette Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapPalette..::..InvokeMethod Method
BitmapPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapPalette Class
BitmapPalette Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapPalette Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapPalette Properties
BitmapPalette Class See Also Send Feedback

The BitmapPalette type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapPalette Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapSource Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Members
BitmapSource Class Constructors Methods Properties See Also Send Feedback

The BitmapSource type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapSource | Initializes a new instance of the BitmapSource class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapSource Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Constructor
BitmapSource Class See Also Send Feedback
Initializes a new instance of the BitmapSource class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapSource()
Visual Basic
Public Sub New
Visual C++
public:
BitmapSource()

See Also

BitmapSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapSource Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Methods
BitmapSource Class See Also Send Feedback

The BitmapSource type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..GetProperty Method
BitmapSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapSource Class
BitmapSource Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..GetRealType Method
BitmapSource Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapSource.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BitmapSource.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BitmapSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..InvokeMethod Method
BitmapSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapSource Class
BitmapSource Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitmapSource Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Properties
BitmapSource Class See Also Send Feedback

The BitmapSource type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Border Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Members
Border Class Constructors Methods Fields Properties See Also Send Feedback

The Border type exposes the following members.

Constructors

 | Name | Description
Public method | Border | Initializes a new instance of the Border class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
CornerRadiusProperty |
PaddingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | CornerRadius |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Border Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Constructor
Border Class See Also Send Feedback
Initializes a new instance of the Border class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Border()
Visual Basic
Public Sub New
Visual C++
public:
Border()

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Border Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Fields
Border Class See Also Send Feedback

The Border type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
CornerRadiusProperty |
PaddingProperty |

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BackgroundProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BorderBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BorderBrushProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.BorderBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderBrushProperty
Visual Basic
Public Shared BorderBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderBrushProperty

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BorderThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BorderThicknessProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.BorderThicknessProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderThicknessProperty
Visual Basic
Public Shared BorderThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderThicknessProperty

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CornerRadiusProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..CornerRadiusProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.CornerRadiusProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CornerRadiusProperty
Visual Basic
Public Shared CornerRadiusProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CornerRadiusProperty

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..PaddingProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.PaddingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PaddingProperty
Visual Basic
Public Shared PaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PaddingProperty

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Border Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Methods
Border Class See Also Send Feedback

The Border type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..AnySibling Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..GetProperty Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..GetRealType Method
Border Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..GetRectangle Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..Highlight Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..InvokeMethod Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..IsHitTest Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..NextSibling Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..Parent Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..PreviousSibling Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..ScrollToVisible Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..SetProperty Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Border Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Properties
Border Class See Also Send Feedback

The Border type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | CornerRadius |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..Background Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BorderBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BorderBrush Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.BorderBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush BorderBrush { get; set; }
Visual Basic
Public Property BorderBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BorderBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BorderThickness Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BorderThickness Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.BorderThickness"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness BorderThickness { get; set; }
Visual Basic
Public Property BorderThickness As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ BorderThickness {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CornerRadius Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..CornerRadius Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.CornerRadius"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CornerRadius CornerRadius { get; set; }
Visual Basic
Public Property CornerRadius As CornerRadius
    Get
    Set
Visual C++
public:
property CornerRadius^ CornerRadius {
    CornerRadius^ get ();
    void set (CornerRadius^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Padding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..Padding Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Border.Padding"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness Padding { get; set; }
Visual Basic
Public Property Padding As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ Padding {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Brush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Members
Brush Class Constructors Methods Fields Properties See Also Send Feedback

The Brush type exposes the following members.

Constructors

 | Name | Description
Public method | Brush | Initializes a new instance of the Brush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
OpacityProperty |
RelativeTransformProperty |
TransformProperty |

Properties

 | Name | Description
Public property | Opacity |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform |
Public property | Transform |

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Brush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Constructor
Brush Class See Also Send Feedback
Initializes a new instance of the Brush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush()
Visual Basic
Public Sub New
Visual C++
public:
Brush()

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Brush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Fields
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Fields

Name | Description
OpacityProperty |
RelativeTransformProperty |
TransformProperty |

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OpacityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..OpacityProperty Field
Brush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Brush.OpacityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OpacityProperty
Visual Basic
Public Shared OpacityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OpacityProperty

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RelativeTransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..RelativeTransformProperty Field
Brush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Brush.RelativeTransformProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RelativeTransformProperty
Visual Basic
Public Shared RelativeTransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RelativeTransformProperty

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..TransformProperty Field
Brush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Brush.TransformProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TransformProperty
Visual Basic
Public Shared TransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TransformProperty

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Brush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Methods
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..GetProperty Method
Brush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Brush Class
Brush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..GetRealType Method
Brush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Brush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Brush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..InvokeMethod Method
Brush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Brush Class
Brush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Brush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Properties
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Properties

 | Name | Description
Public property | Opacity |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform |
Public property | Transform |

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Opacity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..Opacity Property
Brush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Brush.Opacity"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Opacity { get; set; }
Visual Basic
Public Property Opacity As Double
    Get
    Set
Visual C++
public:
property double Opacity {
    double get ();
    void set (double value);
}

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RelativeTransform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..RelativeTransform Property
Brush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Brush.RelativeTransform"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform RelativeTransform { get; set; }
Visual Basic
Public Property RelativeTransform As Transform
    Get
    Set
Visual C++
public:
property Transform^ RelativeTransform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..Transform Property
Brush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Brush.Transform"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform Transform { get; set; }
Visual Basic
Public Property Transform As Transform
    Get
    Set
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

Brush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BulletDecorator Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator Members
BulletDecorator Class Constructors Methods Fields Properties See Also Send Feedback

The BulletDecorator type exposes the following members.

Constructors

 | Name | Description
Public method | BulletDecorator | Initializes a new instance of the BulletDecorator class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BulletDecorator Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator Constructor
BulletDecorator Class See Also Send Feedback
Initializes a new instance of the BulletDecorator class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BulletDecorator()
Visual Basic
Public Sub New
Visual C++
public:
BulletDecorator()

See Also

BulletDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BulletDecorator Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator Fields
BulletDecorator Class See Also Send Feedback

The BulletDecorator type exposes the following members.

Fields

Name | Description
BackgroundProperty |

See Also

BulletDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..BackgroundProperty Field
BulletDecorator Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.BulletDecorator.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

BulletDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BulletDecorator Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator Methods
BulletDecorator Class See Also Send Feedback

The BulletDecorator type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..AnySibling Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..GetProperty Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..GetRealType Method
BulletDecorator Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BulletDecorator.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.BulletDecorator.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BulletDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..GetRectangle Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..Highlight Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..InvokeMethod Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..IsHitTest Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..NextSibling Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..Parent Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..PreviousSibling Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..ScrollToVisible Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..SetProperty Method
BulletDecorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BulletDecorator Class
BulletDecorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BulletDecorator Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator Properties
BulletDecorator Class See Also Send Feedback

The BulletDecorator type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

BulletDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BulletDecorator..::..Background Property
BulletDecorator Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.BulletDecorator.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

BulletDecorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Button Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Members
Button Class Constructors Methods Fields Properties See Also Send Feedback

The Button type exposes the following members.

Constructors

 | Name | Description
Public method | Button | Initializes a new instance of the Button class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsCancelProperty |
IsDefaultedProperty |
IsDefaultProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsCancel |
Public property | IsDefault |
Public property | IsDefaulted |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Button Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Constructor
Button Class See Also Send Feedback
Initializes a new instance of the Button class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Button()
Visual Basic
Public Sub New
Visual C++
public:
Button()

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Button Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Fields
Button Class See Also Send Feedback

The Button type exposes the following members.

Fields

Name | Description
IsCancelProperty |
IsDefaultedProperty |
IsDefaultProperty |

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsCancelProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..IsCancelProperty Field
Button Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Button.IsCancelProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsCancelProperty
Visual Basic
Public Shared IsCancelProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsCancelProperty

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDefaultedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..IsDefaultedProperty Field
Button Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Button.IsDefaultedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDefaultedProperty
Visual Basic
Public Shared IsDefaultedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDefaultedProperty

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDefaultProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..IsDefaultProperty Field
Button Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Button.IsDefaultProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDefaultProperty
Visual Basic
Public Shared IsDefaultProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDefaultProperty

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Button Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Methods
Button Class See Also Send Feedback

The Button type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..AnySibling Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..GetProperty Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..GetRealType Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Button.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Button.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..GetRectangle Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..Highlight Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..InvokeMethod Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..IsHitTest Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..NextSibling Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..Parent Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..PreviousSibling Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..ScrollToVisible Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..SetProperty Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Button Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Properties
Button Class See Also Send Feedback

The Button type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsCancel |
Public property | IsDefault |
Public property | IsDefaulted |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsCancel Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..IsCancel Property
Button Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Button.IsCancel"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsCancel { get; set; }
Visual Basic
Public Property IsCancel As Boolean
    Get
    Set
Visual C++
public:
property bool IsCancel {
    bool get ();
    void set (bool value);
}

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDefault Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..IsDefault Property
Button Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Button.IsDefault"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDefault { get; set; }
Visual Basic
Public Property IsDefault As Boolean
    Get
    Set
Visual C++
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDefaulted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..IsDefaulted Property
Button Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Button.IsDefaulted"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDefaulted { get; set; }
Visual Basic
Public Property IsDefaulted As Boolean
    Get
    Set
Visual C++
public:
property bool IsDefaulted {
    bool get ();
    void set (bool value);
}

See Also

Button Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ButtonBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Members
ButtonBase Class Constructors Methods Fields Properties See Also Send Feedback

The ButtonBase type exposes the following members.

Constructors

 | Name | Description
Public method | ButtonBase | Initializes a new instance of the ButtonBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ClickModeProperty |
IsPressedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode |
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ButtonBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Constructor
ButtonBase Class See Also Send Feedback
Initializes a new instance of the ButtonBase class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ButtonBase()
Visual Basic
Public Sub New
Visual C++
public:
ButtonBase()

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ButtonBase Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Fields
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Fields

Name | Description
ClickModeProperty |
IsPressedProperty |

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ClickModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..ClickModeProperty Field
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ButtonBase.ClickModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ClickModeProperty
Visual Basic
Public Shared ClickModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ClickModeProperty

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPressedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsPressedProperty Field
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ButtonBase.IsPressedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsPressedProperty
Visual Basic
Public Shared IsPressedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsPressedProperty

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ButtonBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Methods
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..AnySibling Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..GetProperty Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..GetRealType Method
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ButtonBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ButtonBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..GetRectangle Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..Highlight Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..InvokeMethod Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsHitTest Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..NextSibling Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..Parent Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..PreviousSibling Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..ScrollToVisible Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..SetProperty Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ButtonBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Properties
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode |
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ClickMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..ClickMode Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ButtonBase.ClickMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ClickMode ClickMode { get; set; }
Visual Basic
Public Property ClickMode As ClickMode
    Get
    Set
Visual C++
public:
property ClickMode ClickMode {
    ClickMode get ();
    void set (ClickMode value);
}

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPressed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsPressed Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ButtonBase.IsPressed"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsPressed { get; set; }
Visual Basic
Public Property IsPressed As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsPressed {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IButtonBase..::..IsPressed

See Also

ButtonBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CachedBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CachedBitmap Members
CachedBitmap Class Constructors Methods Properties See Also Send Feedback

The CachedBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | CachedBitmap | Initializes a new instance of the CachedBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CachedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CachedBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CachedBitmap Constructor
CachedBitmap Class See Also Send Feedback
Initializes a new instance of the CachedBitmap class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CachedBitmap()
Visual Basic
Public Sub New
Visual C++
public:
CachedBitmap()

See Also

CachedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CachedBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CachedBitmap Methods
CachedBitmap Class See Also Send Feedback

The CachedBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CachedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CachedBitmap..::..GetProperty Method
CachedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CachedBitmap Class
CachedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CachedBitmap..::..GetRealType Method
CachedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CachedBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CachedBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CachedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CachedBitmap..::..InvokeMethod Method
CachedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CachedBitmap Class
CachedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CachedBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CachedBitmap Properties
CachedBitmap Class See Also Send Feedback

The CachedBitmap type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CachedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Calendar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Members
Calendar Class Constructors Methods Fields Properties See Also Send Feedback

The Calendar type exposes the following members.

Constructors

 | Name | Description
Public method | Calendar | Initializes a new instance of the Calendar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Navigate | Simulates calendar navigation.
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectDates | Selects dates in the calendar.
Public method | SelectMonth | Simulates user selecting the specified month.
Public method | SelectYear | Simulates user selecting the specified year.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
Public method | ZoomOut | Simulates the user zooming the calendar out via a header button click.

Fields

Name | Description
DisplayDateEndProperty |
DisplayDateProperty |
DisplayDateStartProperty |
DisplayModeProperty |
FirstDayOfWeekProperty |
IsTodayHighlightedProperty |
SelectedDateProperty |
SelectedDatesProperty |
SelectionModeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayDate |
Public property | DisplayDateEnd |
Public property | DisplayDateStart |
Public property | DisplayMode |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstDayOfWeek |
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HeaderButton | Get the calendar header button to zoom out. Override for custom control template.
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTodayHighlighted |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MonthViewElement | Get the calendar month view element holding the days to select. Override for custom control template.
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NextButton | Get the calendar navigation next button. Override for custom control template.
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PreviousButton | Get the calendar navigation previous button. Override for custom control template.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedDate |
Public property | SelectedDates |
Public property | SelectionMode |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | YearViewElement | Get the calendar year view element holding the months and years to select. Override for custom control template.

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Calendar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Constructor
Calendar Class See Also Send Feedback
Initializes a new instance of the Calendar class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Calendar()
Visual Basic
Public Sub New
Visual C++
public:
Calendar()

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Calendar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Fields
Calendar Class See Also Send Feedback

The Calendar type exposes the following members.

Fields

Name | Description
DisplayDateEndProperty |
DisplayDateProperty |
DisplayDateStartProperty |
DisplayModeProperty |
FirstDayOfWeekProperty |
IsTodayHighlightedProperty |
SelectedDateProperty |
SelectedDatesProperty |
SelectionModeProperty |

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateEndProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateEndProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.DisplayDateEndProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateEndProperty
Visual Basic
Public Shared DisplayDateEndProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateEndProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.DisplayDateProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateProperty
Visual Basic
Public Shared DisplayDateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateStartProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateStartProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.DisplayDateStartProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateStartProperty
Visual Basic
Public Shared DisplayDateStartProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateStartProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayModeProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.DisplayModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayModeProperty
Visual Basic
Public Shared DisplayModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayModeProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FirstDayOfWeekProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..FirstDayOfWeekProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.FirstDayOfWeekProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FirstDayOfWeekProperty
Visual Basic
Public Shared FirstDayOfWeekProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FirstDayOfWeekProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTodayHighlightedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..IsTodayHighlightedProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.IsTodayHighlightedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTodayHighlightedProperty
Visual Basic
Public Shared IsTodayHighlightedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTodayHighlightedProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedDateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectedDateProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.SelectedDateProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedDateProperty
Visual Basic
Public Shared SelectedDateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedDateProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedDatesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectedDatesProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.SelectedDatesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedDatesProperty
Visual Basic
Public Shared SelectedDatesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedDatesProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectionModeProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.SelectionModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionModeProperty
Visual Basic
Public Shared SelectionModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionModeProperty

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Calendar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Methods
Calendar Class See Also Send Feedback

The Calendar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Navigate | Simulates calendar navigation.
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectDates | Selects dates in the calendar.
Public method | SelectMonth | Simulates user selecting the specified month.
Public method | SelectYear | Simulates user selecting the specified year.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
Public method | ZoomOut | Simulates the user zooming the calendar out via a header button click.

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..AnySibling Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..GetProperty Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..GetRealType Method
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..GetRectangle Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..Highlight Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..InvokeMethod Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..IsHitTest Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Navigate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..Navigate Method
Calendar Class See Also Send Feedback
Simulates calendar navigation.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Navigate(
    CalendarNavigationDirection direction
)
Visual Basic
Public Sub Navigate ( _
    direction As CalendarNavigationDirection _
)
Visual C++
public:
virtual void Navigate(
    CalendarNavigationDirection direction
) sealed

Parameters

direction
Type: ArtOfTest.WebAii.Controls.Xaml..::..CalendarNavigationDirection
The calendar navigation direction.

Implements

ICalendar..::..Navigate(CalendarNavigationDirection)

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..NextSibling Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..Parent Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..PreviousSibling Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..ScrollToVisible Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectDates Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectDates Method
Calendar Class See Also Send Feedback
Selects dates in the calendar.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectDates(
    bool simulateRealUser,
    List<DateTime> dates,
    bool isInDatePicker
)
Visual Basic
Public Sub SelectDates ( _
    simulateRealUser As Boolean, _
    dates As List(Of DateTime), _
    isInDatePicker As Boolean _
)
Visual C++
public:
virtual void SelectDates(
    bool simulateRealUser,
    List<DateTime>^ dates,
    bool isInDatePicker
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user clicking on the day elements.
dates
Type: System.Collections.Generic..::..List <(Of <(<' DateTime >)>)>
The calendar dates to select.
isInDatePicker
Type: System..::..Boolean
Whether to update the parent date picker if any too.

Implements

ICalendar..::..SelectDates(Boolean, List<(Of <<'(DateTime>)>>), Boolean)

Remarks

In simulate real user and date picker mode a single date selection is possible only.

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectMonth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectMonth Method
Calendar Class See Also Send Feedback
Simulates user selecting the specified month.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectMonth(
    int month
)
Visual Basic
Public Sub SelectMonth ( _
    month As Integer _
)
Visual C++
public:
virtual void SelectMonth(
    int month
) sealed

Parameters

month
Type: System..::..Int32
The month to select.

Implements

ICalendar..::..SelectMonth(Int32)

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectYear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectYear Method
Calendar Class See Also Send Feedback
Simulates user selecting the specified year.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectYear(
    int year
)
Visual Basic
Public Sub SelectYear ( _
    year As Integer _
)
Visual C++
public:
virtual void SelectYear(
    int year
) sealed

Parameters

year
Type: System..::..Int32
The year to select.

Implements

ICalendar..::..SelectYear(Int32)

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SetProperty Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomOut Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..ZoomOut Method
Calendar Class See Also Send Feedback
Simulates the user zooming the calendar out via a header button click.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ZoomOut()
Visual Basic
Public Sub ZoomOut
Visual C++
public:
virtual void ZoomOut() sealed

Implements

ICalendar..::..ZoomOut()()()()

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Calendar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Properties
Calendar Class See Also Send Feedback

The Calendar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayDate |
Public property | DisplayDateEnd |
Public property | DisplayDateStart |
Public property | DisplayMode |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstDayOfWeek |
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HeaderButton | Get the calendar header button to zoom out. Override for custom control template.
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTodayHighlighted |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MonthViewElement | Get the calendar month view element holding the days to select. Override for custom control template.
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NextButton | Get the calendar navigation next button. Override for custom control template.
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PreviousButton | Get the calendar navigation previous button. Override for custom control template.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedDate |
Public property | SelectedDates |
Public property | SelectionMode |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | YearViewElement | Get the calendar year view element holding the months and years to select. Override for custom control template.

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDate Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.DisplayDate"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime DisplayDate { get; set; }
Visual Basic
Public Property DisplayDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime DisplayDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateEnd Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateEnd Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.DisplayDateEnd"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> DisplayDateEnd { get; set; }
Visual Basic
Public Property DisplayDateEnd As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DisplayDateEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateStart Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateStart Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.DisplayDateStart"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> DisplayDateStart { get; set; }
Visual Basic
Public Property DisplayDateStart As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DisplayDateStart {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayMode Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.DisplayMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarMode DisplayMode { get; set; }
Visual Basic
Public Property DisplayMode As CalendarMode
    Get
    Set
Visual C++
public:
property CalendarMode DisplayMode {
    CalendarMode get ();
    void set (CalendarMode value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FirstDayOfWeek Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..FirstDayOfWeek Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.FirstDayOfWeek"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DayOfWeek FirstDayOfWeek { get; set; }
Visual Basic
Public Property FirstDayOfWeek As DayOfWeek
    Get
    Set
Visual C++
public:
property DayOfWeek FirstDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..HeaderButton Property
Calendar Class See Also Send Feedback
Get the calendar header button to zoom out. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement HeaderButton { get; }
Visual Basic
Public Overridable ReadOnly Property HeaderButton As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ HeaderButton {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..HeaderButton

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTodayHighlighted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..IsTodayHighlighted Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.IsTodayHighlighted"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTodayHighlighted { get; set; }
Visual Basic
Public Property IsTodayHighlighted As Boolean
    Get
    Set
Visual C++
public:
property bool IsTodayHighlighted {
    bool get ();
    void set (bool value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MonthViewElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..MonthViewElement Property
Calendar Class See Also Send Feedback
Get the calendar month view element holding the days to select. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement MonthViewElement { get; }
Visual Basic
Public Overridable ReadOnly Property MonthViewElement As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ MonthViewElement {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..MonthViewElement

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..NextButton Property
Calendar Class See Also Send Feedback
Get the calendar navigation next button. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement NextButton { get; }
Visual Basic
Public Overridable ReadOnly Property NextButton As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ NextButton {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..NextButton

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..PreviousButton Property
Calendar Class See Also Send Feedback
Get the calendar navigation previous button. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement PreviousButton { get; }
Visual Basic
Public Overridable ReadOnly Property PreviousButton As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ PreviousButton {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..PreviousButton

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectedDate Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.SelectedDate"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> SelectedDate { get; set; }
Visual Basic
Public Property SelectedDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Implements

ICalendar..::..SelectedDate

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedDates Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectedDates Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.SelectedDates"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SelectedDatesCollection SelectedDates { get; }
Visual Basic
Public ReadOnly Property SelectedDates As SelectedDatesCollection
    Get
Visual C++
public:
virtual property SelectedDatesCollection^ SelectedDates {
    SelectedDatesCollection^ get () sealed;
}

Implements

ICalendar..::..SelectedDates

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectionMode Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Calendar.SelectionMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As CalendarSelectionMode
    Get
    Set
Visual C++
public:
property CalendarSelectionMode SelectionMode {
    CalendarSelectionMode get ();
    void set (CalendarSelectionMode value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


YearViewElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..YearViewElement Property
Calendar Class See Also Send Feedback
Get the calendar year view element holding the months and years to select. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement YearViewElement { get; }
Visual Basic
Public Overridable ReadOnly Property YearViewElement As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ YearViewElement {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..YearViewElement

See Also

Calendar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Members
CalendarButton Class Constructors Methods Fields Properties See Also Send Feedback

The CalendarButton type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarButton | Initializes a new instance of the CalendarButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Button..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HasSelectedDaysProperty |
IsInactiveProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasSelectedDays |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsCancel | (Inherited from Button.)
Public property | IsDefault | (Inherited from Button.)
Public property | IsDefaulted | (Inherited from Button.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsInactive |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Constructor
CalendarButton Class See Also Send Feedback
Initializes a new instance of the CalendarButton class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarButton()
Visual Basic
Public Sub New
Visual C++
public:
CalendarButton()

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Fields
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Fields

Name | Description
HasSelectedDaysProperty |
IsInactiveProperty |

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasSelectedDaysProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..HasSelectedDaysProperty Field
CalendarButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarButton.HasSelectedDaysProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasSelectedDaysProperty
Visual Basic
Public Shared HasSelectedDaysProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasSelectedDaysProperty

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsInactiveProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..IsInactiveProperty Field
CalendarButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarButton.IsInactiveProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsInactiveProperty
Visual Basic
Public Shared IsInactiveProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsInactiveProperty

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Methods
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Button..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..AnySibling Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..GetProperty Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..GetRealType Method
CalendarButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..GetRectangle Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..Highlight Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..InvokeMethod Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..IsHitTest Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..NextSibling Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..Parent Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..PreviousSibling Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..ScrollToVisible Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..SetProperty Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Properties
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasSelectedDays |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsCancel | (Inherited from Button.)
Public property | IsDefault | (Inherited from Button.)
Public property | IsDefaulted | (Inherited from Button.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsInactive |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasSelectedDays Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..HasSelectedDays Property
CalendarButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarButton.HasSelectedDays"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasSelectedDays { get; set; }
Visual Basic
Public Property HasSelectedDays As Boolean
    Get
    Set
Visual C++
public:
property bool HasSelectedDays {
    bool get ();
    void set (bool value);
}

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsInactive Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..IsInactive Property
CalendarButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarButton.IsInactive"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsInactive { get; set; }
Visual Basic
Public Property IsInactive As Boolean
    Get
    Set
Visual C++
public:
property bool IsInactive {
    bool get ();
    void set (bool value);
}

See Also

CalendarButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarDayButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Members
CalendarDayButton Class Constructors Methods Fields Properties See Also Send Feedback

The CalendarDayButton type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarDayButton | Initializes a new instance of the CalendarDayButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Button..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsBlackedOutProperty |
IsHighlightedProperty |
IsInactiveProperty |
IsSelectedProperty |
IsTodayProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsBlackedOut |
Public property | IsCancel | (Inherited from Button.)
Public property | IsDefault | (Inherited from Button.)
Public property | IsDefaulted | (Inherited from Button.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHighlighted |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsInactive |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsToday |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarDayButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Constructor
CalendarDayButton Class See Also Send Feedback
Initializes a new instance of the CalendarDayButton class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarDayButton()
Visual Basic
Public Sub New
Visual C++
public:
CalendarDayButton()

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarDayButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Fields
CalendarDayButton Class See Also Send Feedback

The CalendarDayButton type exposes the following members.

Fields

Name | Description
IsBlackedOutProperty |
IsHighlightedProperty |
IsInactiveProperty |
IsSelectedProperty |
IsTodayProperty |

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsBlackedOutProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsBlackedOutProperty Field
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsBlackedOutProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsBlackedOutProperty
Visual Basic
Public Shared IsBlackedOutProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsBlackedOutProperty

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHighlightedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsHighlightedProperty Field
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsHighlightedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsHighlightedProperty
Visual Basic
Public Shared IsHighlightedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsHighlightedProperty

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsInactiveProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsInactiveProperty Field
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsInactiveProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsInactiveProperty
Visual Basic
Public Shared IsInactiveProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsInactiveProperty

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsSelectedProperty Field
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTodayProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsTodayProperty Field
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsTodayProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTodayProperty
Visual Basic
Public Shared IsTodayProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTodayProperty

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarDayButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Methods
CalendarDayButton Class See Also Send Feedback

The CalendarDayButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Button..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..AnySibling Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..GetProperty Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..GetRealType Method
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..GetRectangle Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..Highlight Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..InvokeMethod Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsHitTest Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..NextSibling Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..Parent Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..PreviousSibling Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..ScrollToVisible Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..SetProperty Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarDayButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Properties
CalendarDayButton Class See Also Send Feedback

The CalendarDayButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsBlackedOut |
Public property | IsCancel | (Inherited from Button.)
Public property | IsDefault | (Inherited from Button.)
Public property | IsDefaulted | (Inherited from Button.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHighlighted |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsInactive |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsToday |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsBlackedOut Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsBlackedOut Property
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsBlackedOut"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsBlackedOut { get; set; }
Visual Basic
Public Property IsBlackedOut As Boolean
    Get
    Set
Visual C++
public:
property bool IsBlackedOut {
    bool get ();
    void set (bool value);
}

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHighlighted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsHighlighted Property
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsHighlighted"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsHighlighted { get; set; }
Visual Basic
Public Property IsHighlighted As Boolean
    Get
    Set
Visual C++
public:
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsInactive Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsInactive Property
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsInactive"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsInactive { get; set; }
Visual Basic
Public Property IsInactive As Boolean
    Get
    Set
Visual C++
public:
property bool IsInactive {
    bool get ();
    void set (bool value);
}

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsSelected Property
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsToday Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsToday Property
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarDayButton.IsToday"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsToday { get; set; }
Visual Basic
Public Property IsToday As Boolean
    Get
    Set
Visual C++
public:
property bool IsToday {
    bool get ();
    void set (bool value);
}

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem Members
CalendarItem Class Constructors Methods Properties See Also Send Feedback

The CalendarItem type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarItem | Initializes a new instance of the CalendarItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem Constructor
CalendarItem Class See Also Send Feedback
Initializes a new instance of the CalendarItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarItem()
Visual Basic
Public Sub New
Visual C++
public:
CalendarItem()

See Also

CalendarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem Methods
CalendarItem Class See Also Send Feedback

The CalendarItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..AnySibling Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..GetProperty Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..GetRealType Method
CalendarItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CalendarItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CalendarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..GetRectangle Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..Highlight Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..InvokeMethod Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..IsHitTest Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..NextSibling Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..Parent Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..PreviousSibling Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..ScrollToVisible Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..SetProperty Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CalendarItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem Properties
CalendarItem Class See Also Send Feedback

The CalendarItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Camera Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera Members
Camera Class Constructors Methods Fields Properties See Also Send Feedback

The Camera type exposes the following members.

Constructors

 | Name | Description
Public method | Camera | Initializes a new instance of the Camera class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
TransformProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform |

See Also

Camera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Camera Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera Constructor
Camera Class See Also Send Feedback
Initializes a new instance of the Camera class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Camera()
Visual Basic
Public Sub New
Visual C++
public:
Camera()

See Also

Camera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Camera Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera Fields
Camera Class See Also Send Feedback

The Camera type exposes the following members.

Fields

Name | Description
TransformProperty |

See Also

Camera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera..::..TransformProperty Field
Camera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Camera.TransformProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TransformProperty
Visual Basic
Public Shared TransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TransformProperty

See Also

Camera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Camera Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera Methods
Camera Class See Also Send Feedback

The Camera type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Camera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera..::..GetProperty Method
Camera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Camera Class
Camera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera..::..GetRealType Method
Camera Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Camera.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Camera.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Camera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera..::..InvokeMethod Method
Camera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Camera Class
Camera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Camera Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera Properties
Camera Class See Also Send Feedback

The Camera type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform |

See Also

Camera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Camera..::..Transform Property
Camera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Camera.Transform"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform3D Transform { get; set; }
Visual Basic
Public Property Transform As Transform3D
    Get
    Set
Visual C++
public:
property Transform3D^ Transform {
    Transform3D^ get ();
    void set (Transform3D^ value);
}

See Also

Camera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Canvas Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas Members
Canvas Class Constructors Methods Properties See Also Send Feedback

The Canvas type exposes the following members.

Constructors

 | Name | Description
Public method | Canvas | Initializes a new instance of the Canvas class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Canvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Canvas Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas Constructor
Canvas Class See Also Send Feedback
Initializes a new instance of the Canvas class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Canvas()
Visual Basic
Public Sub New
Visual C++
public:
Canvas()

See Also

Canvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Canvas Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas Methods
Canvas Class See Also Send Feedback

The Canvas type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Canvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..AnySibling Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..GetProperty Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..GetRealType Method
Canvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Canvas.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Canvas.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Canvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..GetRectangle Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..Highlight Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..InvokeMethod Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..IsHitTest Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..NextSibling Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..Parent Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..PreviousSibling Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..ScrollToVisible Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..SetProperty Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Canvas Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas Properties
Canvas Class See Also Send Feedback

The Canvas type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Canvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CheckBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox Members
CheckBox Class Constructors Methods Properties See Also Send Feedback

The CheckBox type exposes the following members.

Constructors

 | Name | Description
Public method | CheckBox | Initializes a new instance of the CheckBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CheckBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CheckBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox Constructor
CheckBox Class See Also Send Feedback
Initializes a new instance of the CheckBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CheckBox()
Visual Basic
Public Sub New
Visual C++
public:
CheckBox()

See Also

CheckBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CheckBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox Methods
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CheckBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..AnySibling Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..GetProperty Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..GetRealType Method
CheckBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CheckBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CheckBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CheckBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..GetRectangle Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..Highlight Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..InvokeMethod Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..IsHitTest Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..NextSibling Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..Parent Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..PreviousSibling Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..ScrollToVisible Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..SetProperty Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CheckBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox Properties
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CheckBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Clipper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper Members
Clipper Class Constructors Methods Fields Properties See Also Send Feedback

The Clipper type exposes the following members.

Constructors

 | Name | Description
Public method | Clipper | Initializes a new instance of the Clipper class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
RatioVisibleProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RatioVisible |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Clipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Clipper Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper Constructor
Clipper Class See Also Send Feedback
Initializes a new instance of the Clipper class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Clipper()
Visual Basic
Public Sub New
Visual C++
public:
Clipper()

See Also

Clipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Clipper Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper Fields
Clipper Class See Also Send Feedback

The Clipper type exposes the following members.

Fields

Name | Description
RatioVisibleProperty |

See Also

Clipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RatioVisibleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..RatioVisibleProperty Field
Clipper Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Clipper.RatioVisibleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RatioVisibleProperty
Visual Basic
Public Shared RatioVisibleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RatioVisibleProperty

See Also

Clipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Clipper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper Methods
Clipper Class See Also Send Feedback

The Clipper type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Clipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..AnySibling Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..GetProperty Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..GetRealType Method
Clipper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Clipper.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Clipper.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Clipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..GetRectangle Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..Highlight Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..InvokeMethod Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..IsHitTest Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..NextSibling Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..Parent Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..PreviousSibling Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..ScrollToVisible Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..SetProperty Method
Clipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Clipper Class
Clipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Clipper Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper Properties
Clipper Class See Also Send Feedback

The Clipper type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RatioVisible |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Clipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RatioVisible Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Clipper..::..RatioVisible Property
Clipper Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Clipper.RatioVisible"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RatioVisible { get; set; }
Visual Basic
Public Property RatioVisible As Double
    Get
    Set
Visual C++
public:
property double RatioVisible {
    double get ();
    void set (double value);
}

See Also

Clipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Color Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Members
Color Class Constructors Methods Fields Properties See Also Send Feedback

The Color type exposes the following members.

Constructors

 | Name | Description
Public method | Color | Initializes a new instance of the Color class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AProperty |
BProperty |
ColorContextProperty |
GProperty |
RProperty |
ScAProperty |
ScBProperty |
ScGProperty |
ScRProperty |

Properties

 | Name | Description
Public property | A |
Public property | B |
Public property | ColorContext |
Public property | G |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | R |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ScA |
Public property | ScB |
Public property | ScG |
Public property | ScR |

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Color Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Constructor
Color Class See Also Send Feedback
Initializes a new instance of the Color class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Color()
Visual Basic
Public Sub New
Visual C++
public:
Color()

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Color Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Fields
Color Class See Also Send Feedback

The Color type exposes the following members.

Fields

Name | Description
AProperty |
BProperty |
ColorContextProperty |
GProperty |
RProperty |
ScAProperty |
ScBProperty |
ScGProperty |
ScRProperty |

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..AProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.AProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AProperty
Visual Basic
Public Shared AProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..BProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.BProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BProperty
Visual Basic
Public Shared BProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorContextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ColorContextProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ColorContextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColorContextProperty
Visual Basic
Public Shared ColorContextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColorContextProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..GProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.GProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GProperty
Visual Basic
Public Shared GProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..RProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.RProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RProperty
Visual Basic
Public Shared RProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScAProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ScAProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ScAProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScAProperty
Visual Basic
Public Shared ScAProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScAProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScBProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ScBProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ScBProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScBProperty
Visual Basic
Public Shared ScBProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScBProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScGProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ScGProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ScGProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScGProperty
Visual Basic
Public Shared ScGProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScGProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScRProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ScRProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ScRProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScRProperty
Visual Basic
Public Shared ScRProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScRProperty

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Color Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Methods
Color Class See Also Send Feedback

The Color type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..GetProperty Method
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Color Class
Color Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..GetRealType Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..InvokeMethod Method
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Color Class
Color Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Color Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Properties
Color Class See Also Send Feedback

The Color type exposes the following members.

Properties

 | Name | Description
Public property | A |
Public property | B |
Public property | ColorContext |
Public property | G |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | R |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ScA |
Public property | ScB |
Public property | ScG |
Public property | ScR |

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


A Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..A Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.A"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual byte A { get; set; }
Visual Basic
Public Overridable Property A As Byte
    Get
    Set
Visual C++
public:
virtual property unsigned char A {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


B Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..B Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.B"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual byte B { get; set; }
Visual Basic
Public Overridable Property B As Byte
    Get
    Set
Visual C++
public:
virtual property unsigned char B {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorContext Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ColorContext Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ColorContext"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual ColorContext ColorContext { get; set; }
Visual Basic
Public Overridable Property ColorContext As ColorContext
    Get
    Set
Visual C++
public:
virtual property ColorContext^ ColorContext {
    ColorContext^ get ();
    void set (ColorContext^ value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


G Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..G Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.G"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual byte G { get; set; }
Visual Basic
Public Overridable Property G As Byte
    Get
    Set
Visual C++
public:
virtual property unsigned char G {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


R Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..R Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.R"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual byte R { get; set; }
Visual Basic
Public Overridable Property R As Byte
    Get
    Set
Visual C++
public:
virtual property unsigned char R {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScA Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ScA Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ScA"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual float ScA { get; set; }
Visual Basic
Public Overridable Property ScA As Single
    Get
    Set
Visual C++
public:
virtual property float ScA {
    float get ();
    void set (float value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScB Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ScB Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ScB"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual float ScB { get; set; }
Visual Basic
Public Overridable Property ScB As Single
    Get
    Set
Visual C++
public:
virtual property float ScB {
    float get ();
    void set (float value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScG Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ScG Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ScG"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual float ScG { get; set; }
Visual Basic
Public Overridable Property ScG As Single
    Get
    Set
Visual C++
public:
virtual property float ScG {
    float get ();
    void set (float value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScR Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..ScR Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Color.ScR"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual float ScR { get; set; }
Visual Basic
Public Overridable Property ScR As Single
    Get
    Set
Visual C++
public:
virtual property float ScR {
    float get ();
    void set (float value);
}

See Also

Color Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorContext Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorContext Members
ColorContext Class Constructors Methods Properties See Also Send Feedback

The ColorContext type exposes the following members.

Constructors

 | Name | Description
Public method | ColorContext | Initializes a new instance of the ColorContext class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ColorContext Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorContext Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorContext Constructor
ColorContext Class See Also Send Feedback
Initializes a new instance of the ColorContext class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ColorContext()
Visual Basic
Public Sub New
Visual C++
public:
ColorContext()

See Also

ColorContext Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorContext Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorContext Methods
ColorContext Class See Also Send Feedback

The ColorContext type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorContext Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorContext..::..GetProperty Method
ColorContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ColorContext Class
ColorContext Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorContext..::..GetRealType Method
ColorContext Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorContext.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorContext.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ColorContext Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorContext..::..InvokeMethod Method
ColorContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ColorContext Class
ColorContext Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorContext Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorContext Properties
ColorContext Class See Also Send Feedback

The ColorContext type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ColorContext Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorConvertedBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap Members
ColorConvertedBitmap Class Constructors Methods Fields Properties See Also Send Feedback

The ColorConvertedBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | ColorConvertedBitmap | Initializes a new instance of the ColorConvertedBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DestinationColorContextProperty |
DestinationFormatProperty |
SourceColorContextProperty |
SourceProperty |

Properties

 | Name | Description
Public property | DestinationColorContext |
Public property | DestinationFormat |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Source |
Public property | SourceColorContext |

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorConvertedBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap Constructor
ColorConvertedBitmap Class See Also Send Feedback
Initializes a new instance of the ColorConvertedBitmap class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ColorConvertedBitmap()
Visual Basic
Public Sub New
Visual C++
public:
ColorConvertedBitmap()

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorConvertedBitmap Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap Fields
ColorConvertedBitmap Class See Also Send Feedback

The ColorConvertedBitmap type exposes the following members.

Fields

Name | Description
DestinationColorContextProperty |
DestinationFormatProperty |
SourceColorContextProperty |
SourceProperty |

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DestinationColorContextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..DestinationColorContextProperty Field
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.DestinationColorContextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DestinationColorContextProperty
Visual Basic
Public Shared DestinationColorContextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DestinationColorContextProperty

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DestinationFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..DestinationFormatProperty Field
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.DestinationFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DestinationFormatProperty
Visual Basic
Public Shared DestinationFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DestinationFormatProperty

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceColorContextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..SourceColorContextProperty Field
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.SourceColorContextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceColorContextProperty
Visual Basic
Public Shared SourceColorContextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceColorContextProperty

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..SourceProperty Field
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorConvertedBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap Methods
ColorConvertedBitmap Class See Also Send Feedback

The ColorConvertedBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..GetProperty Method
ColorConvertedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ColorConvertedBitmap Class
ColorConvertedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..GetRealType Method
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..InvokeMethod Method
ColorConvertedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ColorConvertedBitmap Class
ColorConvertedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorConvertedBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap Properties
ColorConvertedBitmap Class See Also Send Feedback

The ColorConvertedBitmap type exposes the following members.

Properties

 | Name | Description
Public property | DestinationColorContext |
Public property | DestinationFormat |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Source |
Public property | SourceColorContext |

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DestinationColorContext Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..DestinationColorContext Property
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.DestinationColorContext"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ColorContext DestinationColorContext { get; set; }
Visual Basic
Public Property DestinationColorContext As ColorContext
    Get
    Set
Visual C++
public:
property ColorContext^ DestinationColorContext {
    ColorContext^ get ();
    void set (ColorContext^ value);
}

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DestinationFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..DestinationFormat Property
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.DestinationFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PixelFormat DestinationFormat { get; set; }
Visual Basic
Public Property DestinationFormat As PixelFormat
    Get
    Set
Visual C++
public:
property PixelFormat^ DestinationFormat {
    PixelFormat^ get ();
    void set (PixelFormat^ value);
}

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..Source Property
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapSource Source { get; set; }
Visual Basic
Public Property Source As BitmapSource
    Get
    Set
Visual C++
public:
property BitmapSource^ Source {
    BitmapSource^ get ();
    void set (BitmapSource^ value);
}

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceColorContext Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorConvertedBitmap..::..SourceColorContext Property
ColorConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ColorConvertedBitmap.SourceColorContext"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ColorContext SourceColorContext { get; set; }
Visual Basic
Public Property SourceColorContext As ColorContext
    Get
    Set
Visual C++
public:
property ColorContext^ SourceColorContext {
    ColorContext^ get ();
    void set (ColorContext^ value);
}

See Also

ColorConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CombinedGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry Members
CombinedGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The CombinedGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | CombinedGeometry | Initializes a new instance of the CombinedGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Geometry1Property |
Geometry2Property |
GeometryCombineModeProperty |

Properties

 | Name | Description
Public property | Geometry1 |
Public property | Geometry2 |
Public property | GeometryCombineMode |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CombinedGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry Constructor
CombinedGeometry Class See Also Send Feedback
Initializes a new instance of the CombinedGeometry class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CombinedGeometry()
Visual Basic
Public Sub New
Visual C++
public:
CombinedGeometry()

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CombinedGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry Fields
CombinedGeometry Class See Also Send Feedback

The CombinedGeometry type exposes the following members.

Fields

Name | Description
Geometry1Property |
Geometry2Property |
GeometryCombineModeProperty |

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry1Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..Geometry1Property Field
CombinedGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CombinedGeometry.Geometry1Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Geometry1Property
Visual Basic
Public Shared Geometry1Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Geometry1Property

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry2Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..Geometry2Property Field
CombinedGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CombinedGeometry.Geometry2Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Geometry2Property
Visual Basic
Public Shared Geometry2Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Geometry2Property

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GeometryCombineModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..GeometryCombineModeProperty Field
CombinedGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CombinedGeometry.GeometryCombineModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GeometryCombineModeProperty
Visual Basic
Public Shared GeometryCombineModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GeometryCombineModeProperty

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CombinedGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry Methods
CombinedGeometry Class See Also Send Feedback

The CombinedGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..GetProperty Method
CombinedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CombinedGeometry Class
CombinedGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..GetRealType Method
CombinedGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CombinedGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CombinedGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..InvokeMethod Method
CombinedGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CombinedGeometry Class
CombinedGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CombinedGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry Properties
CombinedGeometry Class See Also Send Feedback

The CombinedGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Geometry1 |
Public property | Geometry2 |
Public property | GeometryCombineMode |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry1 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..Geometry1 Property
CombinedGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CombinedGeometry.Geometry1"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Geometry Geometry1 { get; set; }
Visual Basic
Public Property Geometry1 As Geometry
    Get
    Set
Visual C++
public:
property Geometry^ Geometry1 {
    Geometry^ get ();
    void set (Geometry^ value);
}

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry2 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..Geometry2 Property
CombinedGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CombinedGeometry.Geometry2"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Geometry Geometry2 { get; set; }
Visual Basic
Public Property Geometry2 As Geometry
    Get
    Set
Visual C++
public:
property Geometry^ Geometry2 {
    Geometry^ get ();
    void set (Geometry^ value);
}

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GeometryCombineMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinedGeometry..::..GeometryCombineMode Property
CombinedGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CombinedGeometry.GeometryCombineMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GeometryCombineMode GeometryCombineMode { get; set; }
Visual Basic
Public Property GeometryCombineMode As GeometryCombineMode
    Get
    Set
Visual C++
public:
property GeometryCombineMode GeometryCombineMode {
    GeometryCombineMode get ();
    void set (GeometryCombineMode value);
}

See Also

CombinedGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Members
ComboBox Class Constructors Methods Fields Properties See Also Send Feedback

The ComboBox type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBox | Initializes a new instance of the ComboBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | OpenDropDown | Open the combobox drop down popup.
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsDropDownOpenProperty |
IsEditableProperty |
IsReadOnlyProperty |
MaxDropDownHeightProperty |
SelectionBoxItemStringFormatProperty |
StaysOpenOnEditProperty |
TextProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDropDownOpen |
Public property | IsEditable |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | Items | Get the list of combobox items.
Public property | ItemsPopup | Get the popup containing the list with combo box items. Override for custom control template.
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionBoxItemStringFormat |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpenOnEdit |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Constructor
ComboBox Class See Also Send Feedback
Initializes a new instance of the ComboBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ComboBox()
Visual Basic
Public Sub New
Visual C++
public:
ComboBox()

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Fields
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Fields

Name | Description
IsDropDownOpenProperty |
IsEditableProperty |
IsReadOnlyProperty |
MaxDropDownHeightProperty |
SelectionBoxItemStringFormatProperty |
StaysOpenOnEditProperty |
TextProperty |

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDropDownOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsDropDownOpenProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.IsDropDownOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDropDownOpenProperty
Visual Basic
Public Shared IsDropDownOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDropDownOpenProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEditableProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsEditableProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.IsEditableProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEditableProperty
Visual Basic
Public Shared IsEditableProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEditableProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsReadOnlyProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxDropDownHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..MaxDropDownHeightProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.MaxDropDownHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxDropDownHeightProperty
Visual Basic
Public Shared MaxDropDownHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxDropDownHeightProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionBoxItemStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectionBoxItemStringFormatProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.SelectionBoxItemStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionBoxItemStringFormatProperty
Visual Basic
Public Shared SelectionBoxItemStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionBoxItemStringFormatProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpenOnEditProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..StaysOpenOnEditProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.StaysOpenOnEditProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StaysOpenOnEditProperty
Visual Basic
Public Shared StaysOpenOnEditProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StaysOpenOnEditProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..TextProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.TextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Methods
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | OpenDropDown | Open the combobox drop down popup.
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..AnySibling Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..AssignReference Method
ComboBox Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..GetProperty Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..GetRealType Method
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..GetRectangle Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..Highlight Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..InvokeMethod Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsHitTest Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..NextSibling Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OpenDropDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..OpenDropDown Method
ComboBox Class See Also Send Feedback
Open the combobox drop down popup.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void OpenDropDown(
    bool simulateRealUser
)
Visual Basic
Public Sub OpenDropDown ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void OpenDropDown(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user click action or just change the drop down state via automation property.

Implements

IComboBox..::..OpenDropDown(Boolean)

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..Parent Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..PreviousSibling Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..ScrollToVisible Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectItemByIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByIndex Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectItemByIndex Method (Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByIndex Method (Boolean, Int32)
ComboBox Class See Also Send Feedback
Select a combobox item by given index.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectItemByIndex(
    bool simulateRealUser,
    int index
)
Visual Basic
Public Sub SelectItemByIndex ( _
    simulateRealUser As Boolean, _
    index As Integer _
)
Visual C++
public:
virtual void SelectItemByIndex(
    bool simulateRealUser,
    int index
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected index.
index
Type: System..::..Int32
The index of the item to select.

Implements

IComboBox..::..SelectItemByIndex(Boolean, Int32)

See Also

ComboBox Class
SelectItemByIndex Overload
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectItemByIndex Method (Boolean, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByIndex Method (Boolean, Int32, Boolean)
ComboBox Class See Also Send Feedback
Select a combobox item by given index.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectItemByIndex(
    bool simulateRealUser,
    int index,
    bool openDropDownBeforeSelection
)
Visual Basic
Public Sub SelectItemByIndex ( _
    simulateRealUser As Boolean, _
    index As Integer, _
    openDropDownBeforeSelection As Boolean _
)
Visual C++
public:
virtual void SelectItemByIndex(
    bool simulateRealUser,
    int index,
    bool openDropDownBeforeSelection
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected index.
index
Type: System..::..Int32
The index of the item to select.
openDropDownBeforeSelection
Type: System..::..Boolean
Whether to automatically open the dropdown.

Implements

IComboBox..::..SelectItemByIndex(Boolean, Int32, Boolean)

See Also

ComboBox Class
SelectItemByIndex Overload
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectItemByText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByText Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectItemByText Method (Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByText Method (Boolean, String)
ComboBox Class See Also Send Feedback
Select a combo box item by given text.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectItemByText(
    bool simulateRealUser,
    string text
)
Visual Basic
Public Sub SelectItemByText ( _
    simulateRealUser As Boolean, _
    text As String _
)
Visual C++
public:
virtual void SelectItemByText(
    bool simulateRealUser,
    String^ text
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected state of the item.
text
Type: System..::..String
The text of the item to select.

Implements

IComboBox..::..SelectItemByText(Boolean, String)

See Also

ComboBox Class
SelectItemByText Overload
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectItemByText Method (Boolean, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByText Method (Boolean, String, Boolean)
ComboBox Class See Also Send Feedback
Select a combo box item by given text.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectItemByText(
    bool simulateRealUser,
    string text,
    bool openDropDownBeforeSelection
)
Visual Basic
Public Sub SelectItemByText ( _
    simulateRealUser As Boolean, _
    text As String, _
    openDropDownBeforeSelection As Boolean _
)
Visual C++
public:
virtual void SelectItemByText(
    bool simulateRealUser,
    String^ text,
    bool openDropDownBeforeSelection
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected state of the item.
text
Type: System..::..String
The text of the item to select.
openDropDownBeforeSelection
Type: System..::..Boolean
Whether to automatically open the dropdown.

Implements

IComboBox..::..SelectItemByText(Boolean, String, Boolean)

See Also

ComboBox Class
SelectItemByText Overload
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SetProperty Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Properties
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDropDownOpen |
Public property | IsEditable |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | Items | Get the list of combobox items.
Public property | ItemsPopup | Get the popup containing the list with combo box items. Override for custom control template.
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionBoxItemStringFormat |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpenOnEdit |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDropDownOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsDropDownOpen Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.IsDropDownOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic
Public Property IsDropDownOpen As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsDropDownOpen {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IComboBox..::..IsDropDownOpen

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEditable Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsEditable Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.IsEditable"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEditable { get; set; }
Visual Basic
Public Property IsEditable As Boolean
    Get
    Set
Visual C++
public:
property bool IsEditable {
    bool get ();
    void set (bool value);
}

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsReadOnly Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..Items Property
ComboBox Class See Also Send Feedback
Get the list of combobox items.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<ComboBoxItem> Items { get; }
Visual Basic
Public ReadOnly Property Items As IList(Of ComboBoxItem)
    Get
Visual C++
public:
property IList<ComboBoxItem^>^ Items {
    IList<ComboBoxItem^>^ get ();
}

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsPopup Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..ItemsPopup Property
ComboBox Class See Also Send Feedback
Get the popup containing the list with combo box items. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ItemsPopup { get; }
Visual Basic
Public Overridable ReadOnly Property ItemsPopup As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ItemsPopup {
    FrameworkElement^ get ();
}

Implements

IComboBox..::..ItemsPopup

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxDropDownHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..MaxDropDownHeight Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.MaxDropDownHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxDropDownHeight { get; set; }
Visual Basic
Public Property MaxDropDownHeight As Double
    Get
    Set
Visual C++
public:
property double MaxDropDownHeight {
    double get ();
    void set (double value);
}

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionBoxItemStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectionBoxItemStringFormat Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.SelectionBoxItemStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SelectionBoxItemStringFormat { get; set; }
Visual Basic
Public Property SelectionBoxItemStringFormat As String
    Get
    Set
Visual C++
public:
property String^ SelectionBoxItemStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpenOnEdit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..StaysOpenOnEdit Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.StaysOpenOnEdit"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StaysOpenOnEdit { get; set; }
Visual Basic
Public Property StaysOpenOnEdit As Boolean
    Get
    Set
Visual C++
public:
property bool StaysOpenOnEdit {
    bool get ();
    void set (bool value);
}

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..Text Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBox.Text"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFrameworkElement..::..Text

See Also

ComboBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBoxItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Members
ComboBoxItem Class Constructors Methods Fields Properties See Also Send Feedback

The ComboBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxItem | Initializes a new instance of the ComboBoxItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ListBoxItem..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsHighlightedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHighlighted |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected | (Inherited from ListBoxItem.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemText | Get the item text.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParentComboBox | Get the parent ComboBox element.
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBoxItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Constructor
ComboBoxItem Class See Also Send Feedback
Initializes a new instance of the ComboBoxItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ComboBoxItem()
Visual Basic
Public Sub New
Visual C++
public:
ComboBoxItem()

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBoxItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Fields
ComboBoxItem Class See Also Send Feedback

The ComboBoxItem type exposes the following members.

Fields

Name | Description
IsHighlightedProperty |

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHighlightedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..IsHighlightedProperty Field
ComboBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBoxItem.IsHighlightedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsHighlightedProperty
Visual Basic
Public Shared IsHighlightedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsHighlightedProperty

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBoxItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Methods
ComboBoxItem Class See Also Send Feedback

The ComboBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ListBoxItem..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..AnySibling Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..GetProperty Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..GetRealType Method
ComboBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBoxItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBoxItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..GetRectangle Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..Highlight Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..InvokeMethod Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..IsHitTest Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..NextSibling Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..Parent Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..PreviousSibling Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..ScrollToVisible Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..SetProperty Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComboBoxItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Properties
ComboBoxItem Class See Also Send Feedback

The ComboBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHighlighted |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected | (Inherited from ListBoxItem.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemText | Get the item text.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParentComboBox | Get the parent ComboBox element.
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHighlighted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..IsHighlighted Property
ComboBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ComboBoxItem.IsHighlighted"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsHighlighted { get; set; }
Visual Basic
Public Property IsHighlighted As Boolean
    Get
    Set
Visual C++
public:
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..ItemText Property
ComboBoxItem Class See Also Send Feedback
Get the item text.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ItemText { get; }
Visual Basic
Public ReadOnly Property ItemText As String
    Get
Visual C++
public:
virtual property String^ ItemText {
    String^ get () sealed;
}

Implements

IComboBoxItem..::..ItemText

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ParentComboBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..ParentComboBox Property
ComboBoxItem Class See Also Send Feedback
Get the parent ComboBox element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IComboBox ParentComboBox { get; }
Visual Basic
Public ReadOnly Property ParentComboBox As IComboBox
    Get
Visual C++
public:
virtual property IComboBox^ ParentComboBox {
    IComboBox^ get () sealed;
}

Implements

IComboBoxItem..::..ParentComboBox

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContainerVisual Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainerVisual Members
ContainerVisual Class Constructors Methods Properties See Also Send Feedback

The ContainerVisual type exposes the following members.

Constructors

 | Name | Description
Public method | ContainerVisual | Initializes a new instance of the ContainerVisual class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Visual..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContainerVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContainerVisual Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainerVisual Constructor
ContainerVisual Class See Also Send Feedback
Initializes a new instance of the ContainerVisual class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContainerVisual()
Visual Basic
Public Sub New
Visual C++
public:
ContainerVisual()

See Also

ContainerVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContainerVisual Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainerVisual Methods
ContainerVisual Class See Also Send Feedback

The ContainerVisual type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Visual..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContainerVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainerVisual..::..GetProperty Method
ContainerVisual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContainerVisual Class
ContainerVisual Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainerVisual..::..GetRealType Method
ContainerVisual Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContainerVisual.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContainerVisual.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ContainerVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainerVisual..::..InvokeMethod Method
ContainerVisual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContainerVisual Class
ContainerVisual Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContainerVisual Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainerVisual Properties
ContainerVisual Class See Also Send Feedback

The ContainerVisual type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContainerVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Members
ContentControl Class Constructors Methods Fields Properties See Also Send Feedback

The ContentControl type exposes the following members.

Constructors

 | Name | Description
Public method | ContentControl | Initializes a new instance of the ContentControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ContentStringFormatProperty |
HasContentProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Constructor
ContentControl Class See Also Send Feedback
Initializes a new instance of the ContentControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContentControl()
Visual Basic
Public Sub New
Visual C++
public:
ContentControl()

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Fields
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Fields

Name | Description
ContentStringFormatProperty |
HasContentProperty |

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..ContentStringFormatProperty Field
ContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentControl.ContentStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentStringFormatProperty
Visual Basic
Public Shared ContentStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentStringFormatProperty

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasContentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..HasContentProperty Field
ContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentControl.HasContentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasContentProperty
Visual Basic
Public Shared HasContentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasContentProperty

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Methods
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..AnySibling Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..GetProperty Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..GetRealType Method
ContentControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..GetRectangle Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..Highlight Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..InvokeMethod Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..IsHitTest Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..NextSibling Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..Parent Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..PreviousSibling Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..ScrollToVisible Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..SetProperty Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Properties
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..ContentStringFormat Property
ContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentControl.ContentStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ContentStringFormat { get; set; }
Visual Basic
Public Property ContentStringFormat As String
    Get
    Set
Visual C++
public:
property String^ ContentStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..HasContent Property
ContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentControl.HasContent"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasContent { get; set; }
Visual Basic
Public Property HasContent As Boolean
    Get
    Set
Visual C++
public:
property bool HasContent {
    bool get ();
    void set (bool value);
}

See Also

ContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Members
ContentPresenter Class Constructors Methods Fields Properties See Also Send Feedback

The ContentPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | ContentPresenter | Initializes a new instance of the ContentPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ContentSourceProperty |
ContentStringFormatProperty |
RecognizesAccessKeyProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentSource |
Public property | ContentStringFormat |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RecognizesAccessKey |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Constructor
ContentPresenter Class See Also Send Feedback
Initializes a new instance of the ContentPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContentPresenter()
Visual Basic
Public Sub New
Visual C++
public:
ContentPresenter()

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentPresenter Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Fields
ContentPresenter Class See Also Send Feedback

The ContentPresenter type exposes the following members.

Fields

Name | Description
ContentSourceProperty |
ContentStringFormatProperty |
RecognizesAccessKeyProperty |

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentSourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..ContentSourceProperty Field
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentPresenter.ContentSourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentSourceProperty
Visual Basic
Public Shared ContentSourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentSourceProperty

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..ContentStringFormatProperty Field
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentPresenter.ContentStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentStringFormatProperty
Visual Basic
Public Shared ContentStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentStringFormatProperty

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RecognizesAccessKeyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..RecognizesAccessKeyProperty Field
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentPresenter.RecognizesAccessKeyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RecognizesAccessKeyProperty
Visual Basic
Public Shared RecognizesAccessKeyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RecognizesAccessKeyProperty

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Methods
ContentPresenter Class See Also Send Feedback

The ContentPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..AnySibling Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..GetProperty Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..GetRealType Method
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..GetRectangle Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..Highlight Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..InvokeMethod Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..IsHitTest Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..NextSibling Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..Parent Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..PreviousSibling Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..ScrollToVisible Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..SetProperty Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Properties
ContentPresenter Class See Also Send Feedback

The ContentPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentSource |
Public property | ContentStringFormat |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RecognizesAccessKey |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentSource Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..ContentSource Property
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentPresenter.ContentSource"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ContentSource { get; set; }
Visual Basic
Public Property ContentSource As String
    Get
    Set
Visual C++
public:
property String^ ContentSource {
    String^ get ();
    void set (String^ value);
}

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..ContentStringFormat Property
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentPresenter.ContentStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ContentStringFormat { get; set; }
Visual Basic
Public Property ContentStringFormat As String
    Get
    Set
Visual C++
public:
property String^ ContentStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RecognizesAccessKey Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..RecognizesAccessKey Property
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContentPresenter.RecognizesAccessKey"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RecognizesAccessKey { get; set; }
Visual Basic
Public Property RecognizesAccessKey As Boolean
    Get
    Set
Visual C++
public:
property bool RecognizesAccessKey {
    bool get ();
    void set (bool value);
}

See Also

ContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContextMenu Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu Members
ContextMenu Class Constructors Methods Fields Properties See Also Send Feedback

The ContextMenu type exposes the following members.

Constructors

 | Name | Description
Public method | ContextMenu | Initializes a new instance of the ContextMenu class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides MenuBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HasDropShadowProperty |
HorizontalOffsetProperty |
IsOpenProperty |
PlacementProperty |
PlacementRectangleProperty |
StaysOpenProperty |
VerticalOffsetProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasDropShadow |
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsOpen |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PlacementRectangle |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpen |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContextMenu Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu Constructor
ContextMenu Class See Also Send Feedback
Initializes a new instance of the ContextMenu class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContextMenu()
Visual Basic
Public Sub New
Visual C++
public:
ContextMenu()

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContextMenu Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu Fields
ContextMenu Class See Also Send Feedback

The ContextMenu type exposes the following members.

Fields

Name | Description
HasDropShadowProperty |
HorizontalOffsetProperty |
IsOpenProperty |
PlacementProperty |
PlacementRectangleProperty |
StaysOpenProperty |
VerticalOffsetProperty |

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasDropShadowProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..HasDropShadowProperty Field
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.HasDropShadowProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasDropShadowProperty
Visual Basic
Public Shared HasDropShadowProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasDropShadowProperty

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..HorizontalOffsetProperty Field
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..IsOpenProperty Field
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.IsOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsOpenProperty
Visual Basic
Public Shared IsOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsOpenProperty

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..PlacementProperty Field
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.PlacementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlacementProperty
Visual Basic
Public Shared PlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlacementProperty

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementRectangleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..PlacementRectangleProperty Field
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.PlacementRectangleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlacementRectangleProperty
Visual Basic
Public Shared PlacementRectangleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlacementRectangleProperty

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..StaysOpenProperty Field
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.StaysOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StaysOpenProperty
Visual Basic
Public Shared StaysOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StaysOpenProperty

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..VerticalOffsetProperty Field
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContextMenu Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu Methods
ContextMenu Class See Also Send Feedback

The ContextMenu type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides MenuBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..AnySibling Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..GetProperty Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..GetRealType Method
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..GetRectangle Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..Highlight Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..InvokeMethod Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..IsHitTest Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..NextSibling Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..Parent Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..PreviousSibling Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..ScrollToVisible Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..SetProperty Method
ContextMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContextMenu Class
ContextMenu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContextMenu Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu Properties
ContextMenu Class See Also Send Feedback

The ContextMenu type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasDropShadow |
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsOpen |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PlacementRectangle |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpen |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasDropShadow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..HasDropShadow Property
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.HasDropShadow"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasDropShadow { get; set; }
Visual Basic
Public Property HasDropShadow As Boolean
    Get
    Set
Visual C++
public:
property bool HasDropShadow {
    bool get ();
    void set (bool value);
}

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..HorizontalOffset Property
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.HorizontalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic
Public Property HorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..IsOpen Property
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.IsOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsOpen { get; set; }
Visual Basic
Public Property IsOpen As Boolean
    Get
    Set
Visual C++
public:
property bool IsOpen {
    bool get ();
    void set (bool value);
}

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Placement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..Placement Property
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.Placement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PlacementMode Placement { get; set; }
Visual Basic
Public Property Placement As PlacementMode
    Get
    Set
Visual C++
public:
property PlacementMode Placement {
    PlacementMode get ();
    void set (PlacementMode value);
}

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementRectangle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..PlacementRectangle Property
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.PlacementRectangle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect PlacementRectangle { get; set; }
Visual Basic
Public Property PlacementRectangle As Rect
    Get
    Set
Visual C++
public:
property Rect^ PlacementRectangle {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..StaysOpen Property
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.StaysOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StaysOpen { get; set; }
Visual Basic
Public Property StaysOpen As Boolean
    Get
    Set
Visual C++
public:
property bool StaysOpen {
    bool get ();
    void set (bool value);
}

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContextMenu..::..VerticalOffset Property
ContextMenu Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ContextMenu.VerticalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic
Public Property VerticalOffset As Double
    Get
    Set
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

ContextMenu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Control Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Members
Control Class Constructors Methods Fields Properties See Also Send Feedback

The Control type exposes the following members.

Constructors

 | Name | Description
Public method | Control | Initializes a new instance of the Control class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
HorizontalContentAlignmentProperty |
IsTabStopProperty |
PaddingProperty |
TabIndexProperty |
VerticalContentAlignmentProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Control Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Constructor
Control Class See Also Send Feedback
Initializes a new instance of the Control class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Control()
Visual Basic
Public Sub New
Visual C++
public:
Control()

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Control Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Fields
Control Class See Also Send Feedback

The Control type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
HorizontalContentAlignmentProperty |
IsTabStopProperty |
PaddingProperty |
TabIndexProperty |
VerticalContentAlignmentProperty |

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BackgroundProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BorderBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BorderBrushProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.BorderBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderBrushProperty
Visual Basic
Public Shared BorderBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderBrushProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BorderThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BorderThicknessProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.BorderThicknessProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderThicknessProperty
Visual Basic
Public Shared BorderThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderThicknessProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontFamilyProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontSizeProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontStretchProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontStretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStretchProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontStyleProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontStyleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStyleProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontWeightProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontWeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontWeightProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..ForegroundProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalContentAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..HorizontalContentAlignmentProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.HorizontalContentAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalContentAlignmentProperty
Visual Basic
Public Shared HorizontalContentAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalContentAlignmentProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTabStopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsTabStopProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.IsTabStopProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTabStopProperty
Visual Basic
Public Shared IsTabStopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTabStopProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..PaddingProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.PaddingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PaddingProperty
Visual Basic
Public Shared PaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PaddingProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..TabIndexProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.TabIndexProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabIndexProperty
Visual Basic
Public Shared TabIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabIndexProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalContentAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..VerticalContentAlignmentProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.VerticalContentAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalContentAlignmentProperty
Visual Basic
Public Shared VerticalContentAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalContentAlignmentProperty

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Control Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Methods
Control Class See Also Send Feedback

The Control type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..AnySibling Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..GetProperty Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..GetRealType Method
Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..GetRectangle Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Highlight Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..InvokeMethod Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsHitTest Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..NextSibling Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Parent Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..PreviousSibling Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..ScrollToVisible Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..SetProperty Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Control Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Properties
Control Class See Also Send Feedback

The Control type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Background Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BorderBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BorderBrush Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.BorderBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush BorderBrush { get; set; }
Visual Basic
Public Property BorderBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BorderBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BorderThickness Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BorderThickness Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.BorderThickness"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness BorderThickness { get; set; }
Visual Basic
Public Property BorderThickness As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ BorderThickness {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontFamily Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontFamily"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontSize Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic
Public Property FontSize As Double
    Get
    Set
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontStretch Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontStretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic
Public ReadOnly Property FontStretch As FontStretch
    Get
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontStyle Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontStyle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyle FontStyle { get; }
Visual Basic
Public ReadOnly Property FontStyle As FontStyle
    Get
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontWeight Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.FontWeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic
Public ReadOnly Property FontWeight As FontWeight
    Get
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Foreground Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.Foreground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic
Public Property Foreground As Brush
    Get
    Set
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalContentAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..HorizontalContentAlignment Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.HorizontalContentAlignment"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HorizontalAlignment HorizontalContentAlignment { get; set; }
Visual Basic
Public Property HorizontalContentAlignment As HorizontalAlignment
    Get
    Set
Visual C++
public:
property HorizontalAlignment HorizontalContentAlignment {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTabStop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsTabStop Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.IsTabStop"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTabStop { get; set; }
Visual Basic
Public Property IsTabStop As Boolean
    Get
    Set
Visual C++
public:
property bool IsTabStop {
    bool get ();
    void set (bool value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Padding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Padding Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.Padding"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness Padding { get; set; }
Visual Basic
Public Property Padding As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ Padding {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..TabIndex Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.TabIndex"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TabIndex { get; set; }
Visual Basic
Public Property TabIndex As Integer
    Get
    Set
Visual C++
public:
property int TabIndex {
    int get ();
    void set (int value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalContentAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..VerticalContentAlignment Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Control.VerticalContentAlignment"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VerticalAlignment VerticalContentAlignment { get; set; }
Visual Basic
Public Property VerticalContentAlignment As VerticalAlignment
    Get
    Set
Visual C++
public:
property VerticalAlignment VerticalContentAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}

See Also

Control Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CornerRadius Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Members
CornerRadius Class Constructors Methods Fields Properties See Also Send Feedback

The CornerRadius type exposes the following members.

Constructors

 | Name | Description
Public method | CornerRadius | Initializes a new instance of the CornerRadius class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BottomLeftProperty |
BottomRightProperty |
TopLeftProperty |
TopRightProperty |

Properties

 | Name | Description
Public property | BottomLeft |
Public property | BottomRight |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | TopLeft |
Public property | TopRight |

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CornerRadius Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Constructor
CornerRadius Class See Also Send Feedback
Initializes a new instance of the CornerRadius class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CornerRadius()
Visual Basic
Public Sub New
Visual C++
public:
CornerRadius()

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CornerRadius Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Fields
CornerRadius Class See Also Send Feedback

The CornerRadius type exposes the following members.

Fields

Name | Description
BottomLeftProperty |
BottomRightProperty |
TopLeftProperty |
TopRightProperty |

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomLeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..BottomLeftProperty Field
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.BottomLeftProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomLeftProperty
Visual Basic
Public Shared BottomLeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomLeftProperty

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomRightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..BottomRightProperty Field
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.BottomRightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomRightProperty
Visual Basic
Public Shared BottomRightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomRightProperty

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopLeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..TopLeftProperty Field
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.TopLeftProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopLeftProperty
Visual Basic
Public Shared TopLeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopLeftProperty

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopRightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..TopRightProperty Field
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.TopRightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopRightProperty
Visual Basic
Public Shared TopRightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopRightProperty

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CornerRadius Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Methods
CornerRadius Class See Also Send Feedback

The CornerRadius type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..GetProperty Method
CornerRadius Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CornerRadius Class
CornerRadius Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..GetRealType Method
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..InvokeMethod Method
CornerRadius Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CornerRadius Class
CornerRadius Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CornerRadius Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Properties
CornerRadius Class See Also Send Feedback

The CornerRadius type exposes the following members.

Properties

 | Name | Description
Public property | BottomLeft |
Public property | BottomRight |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | TopLeft |
Public property | TopRight |

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomLeft Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..BottomLeft Property
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.BottomLeft"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double BottomLeft { get; set; }
Visual Basic
Public Overridable Property BottomLeft As Double
    Get
    Set
Visual C++
public:
virtual property double BottomLeft {
    double get ();
    void set (double value);
}

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomRight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..BottomRight Property
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.BottomRight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double BottomRight { get; set; }
Visual Basic
Public Overridable Property BottomRight As Double
    Get
    Set
Visual C++
public:
virtual property double BottomRight {
    double get ();
    void set (double value);
}

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopLeft Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..TopLeft Property
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.TopLeft"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TopLeft { get; set; }
Visual Basic
Public Overridable Property TopLeft As Double
    Get
    Set
Visual C++
public:
virtual property double TopLeft {
    double get ();
    void set (double value);
}

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopRight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..TopRight Property
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CornerRadius.TopRight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TopRight { get; set; }
Visual Basic
Public Overridable Property TopRight As Double
    Get
    Set
Visual C++
public:
virtual property double TopRight {
    double get ();
    void set (double value);
}

See Also

CornerRadius Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CroppedBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap Members
CroppedBitmap Class Constructors Methods Fields Properties See Also Send Feedback

The CroppedBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | CroppedBitmap | Initializes a new instance of the CroppedBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
SourceProperty |
SourceRectProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Source |
Public property | SourceRect |

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CroppedBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap Constructor
CroppedBitmap Class See Also Send Feedback
Initializes a new instance of the CroppedBitmap class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CroppedBitmap()
Visual Basic
Public Sub New
Visual C++
public:
CroppedBitmap()

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CroppedBitmap Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap Fields
CroppedBitmap Class See Also Send Feedback

The CroppedBitmap type exposes the following members.

Fields

Name | Description
SourceProperty |
SourceRectProperty |

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap..::..SourceProperty Field
CroppedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CroppedBitmap.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceRectProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap..::..SourceRectProperty Field
CroppedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.CroppedBitmap.SourceRectProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceRectProperty
Visual Basic
Public Shared SourceRectProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceRectProperty

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CroppedBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap Methods
CroppedBitmap Class See Also Send Feedback

The CroppedBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap..::..GetProperty Method
CroppedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CroppedBitmap Class
CroppedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap..::..GetRealType Method
CroppedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CroppedBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.CroppedBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap..::..InvokeMethod Method
CroppedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CroppedBitmap Class
CroppedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CroppedBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap Properties
CroppedBitmap Class See Also Send Feedback

The CroppedBitmap type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Source |
Public property | SourceRect |

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap..::..Source Property
CroppedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CroppedBitmap.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapSource Source { get; set; }
Visual Basic
Public Property Source As BitmapSource
    Get
    Set
Visual C++
public:
property BitmapSource^ Source {
    BitmapSource^ get ();
    void set (BitmapSource^ value);
}

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceRect Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CroppedBitmap..::..SourceRect Property
CroppedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.CroppedBitmap.SourceRect"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Int32Rect SourceRect { get; set; }
Visual Basic
Public Property SourceRect As Int32Rect
    Get
    Set
Visual C++
public:
property Int32Rect^ SourceRect {
    Int32Rect^ get ();
    void set (Int32Rect^ value);
}

See Also

CroppedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


D3DImage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage Members
D3DImage Class Constructors Methods Fields Properties See Also Send Feedback

The D3DImage type exposes the following members.

Constructors

 | Name | Description
Public method | D3DImage | Initializes a new instance of the D3DImage class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ImageSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
IsFrontBufferAvailableProperty |

Properties

 | Name | Description
Public property | IsFrontBufferAvailable |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

D3DImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


D3DImage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage Constructor
D3DImage Class See Also Send Feedback
Initializes a new instance of the D3DImage class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public D3DImage()
Visual Basic
Public Sub New
Visual C++
public:
D3DImage()

See Also

D3DImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


D3DImage Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage Fields
D3DImage Class See Also Send Feedback

The D3DImage type exposes the following members.

Fields

Name | Description
IsFrontBufferAvailableProperty |

See Also

D3DImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFrontBufferAvailableProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage..::..IsFrontBufferAvailableProperty Field
D3DImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.D3DImage.IsFrontBufferAvailableProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFrontBufferAvailableProperty
Visual Basic
Public Shared IsFrontBufferAvailableProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFrontBufferAvailableProperty

See Also

D3DImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


D3DImage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage Methods
D3DImage Class See Also Send Feedback

The D3DImage type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ImageSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

D3DImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage..::..GetProperty Method
D3DImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

D3DImage Class
D3DImage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage..::..GetRealType Method
D3DImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.D3DImage.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.D3DImage.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

D3DImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage..::..InvokeMethod Method
D3DImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

D3DImage Class
D3DImage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


D3DImage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage Properties
D3DImage Class See Also Send Feedback

The D3DImage type exposes the following members.

Properties

 | Name | Description
Public property | IsFrontBufferAvailable |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

D3DImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFrontBufferAvailable Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
D3DImage..::..IsFrontBufferAvailable Property
D3DImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.D3DImage.IsFrontBufferAvailable"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFrontBufferAvailable { get; set; }
Visual Basic
Public Property IsFrontBufferAvailable As Boolean
    Get
    Set
Visual C++
public:
property bool IsFrontBufferAvailable {
    bool get ();
    void set (bool value);
}

See Also

D3DImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Members
DataGrid Class Constructors Methods Fields Properties See Also Send Feedback

The DataGrid type exposes the following members.

Constructors

 | Name | Description
Public method | DataGrid | Initializes a new instance of the DataGrid class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides MultiSelector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AlternatingRowBackgroundProperty |
AreRowDetailsFrozenProperty |
AutoGenerateColumnsProperty |
CanUserAddRowsProperty |
CanUserDeleteRowsProperty |
CanUserReorderColumnsProperty |
CanUserResizeColumnsProperty |
CanUserResizeRowsProperty |
CanUserSortColumnsProperty |
CellsPanelHorizontalOffsetProperty |
ClipboardCopyModeProperty |
ColumnHeaderHeightProperty |
ColumnWidthProperty |
CurrentCellProperty |
CurrentColumnProperty |
EnableColumnVirtualizationProperty |
EnableRowVirtualizationProperty |
FrozenColumnCountProperty |
GridLinesVisibilityProperty |
HeadersVisibilityProperty |
HorizontalGridLinesBrushProperty |
HorizontalScrollBarVisibilityProperty |
IsReadOnlyProperty |
MaxColumnWidthProperty |
MinColumnWidthProperty |
MinRowHeightProperty |
NonFrozenColumnsViewportHorizontalOffsetProperty |
RowBackgroundProperty |
RowDetailsVisibilityModeProperty |
RowHeaderActualWidthProperty |
RowHeaderWidthProperty |
RowHeightProperty |
SelectionModeProperty |
SelectionUnitProperty |
VerticalGridLinesBrushProperty |
VerticalScrollBarVisibilityProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternatingRowBackground |
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AreRowDetailsFrozen |
Public property | AutoGenerateColumns |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanUserAddRows |
Public property | CanUserDeleteRows |
Public property | CanUserReorderColumns |
Public property | CanUserResizeColumns |
Public property | CanUserResizeRows |
Public property | CanUserSortColumns |
Public property | CellsPanelHorizontalOffset |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipboardCopyMode |
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ColumnHeaderContainer | Gets the column header container. Please override for custom control template.
Public property | ColumnHeaderElements | Get the list of column headers of this Grid.
Public property | ColumnHeaderHeight |
Public property | ColumnWidth |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | CurrentCell |
Public property | CurrentColumn |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableColumnVirtualization |
Public property | EnableRowVirtualization |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | FrozenColumnCount |
Public property | GridData | Gets the full textual content of a grid. The dictionary key represents the row of the grid.
Public property | GridLinesVisibility |
Public property | HasItems | (Inherited from ItemsControl.)
Public property | HeadersVisibility |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalGridLinesBrush |
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxColumnWidth |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinColumnWidth |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinRowHeight |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NonFrozenColumnsViewportHorizontalOffset |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RowBackground |
Public property | RowContainer | Gets the row container. Please override for custom control template.
Public property | RowDetailsVisibilityMode |
Public property | RowElements | Get the list of rows contained in this Grid.
Public property | RowHeaderActualWidth |
Public property | RowHeaderWidth |
Public property | RowHeight |
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionMode |
Public property | SelectionUnit |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalGridLinesBrush |
Public property | VerticalScrollBarVisibility |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGrid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Constructor
DataGrid Class See Also Send Feedback
Initializes a new instance of the DataGrid class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGrid()
Visual Basic
Public Sub New
Visual C++
public:
DataGrid()

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGrid Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Fields
DataGrid Class See Also Send Feedback

The DataGrid type exposes the following members.

Fields

Name | Description
AlternatingRowBackgroundProperty |
AreRowDetailsFrozenProperty |
AutoGenerateColumnsProperty |
CanUserAddRowsProperty |
CanUserDeleteRowsProperty |
CanUserReorderColumnsProperty |
CanUserResizeColumnsProperty |
CanUserResizeRowsProperty |
CanUserSortColumnsProperty |
CellsPanelHorizontalOffsetProperty |
ClipboardCopyModeProperty |
ColumnHeaderHeightProperty |
ColumnWidthProperty |
CurrentCellProperty |
CurrentColumnProperty |
EnableColumnVirtualizationProperty |
EnableRowVirtualizationProperty |
FrozenColumnCountProperty |
GridLinesVisibilityProperty |
HeadersVisibilityProperty |
HorizontalGridLinesBrushProperty |
HorizontalScrollBarVisibilityProperty |
IsReadOnlyProperty |
MaxColumnWidthProperty |
MinColumnWidthProperty |
MinRowHeightProperty |
NonFrozenColumnsViewportHorizontalOffsetProperty |
RowBackgroundProperty |
RowDetailsVisibilityModeProperty |
RowHeaderActualWidthProperty |
RowHeaderWidthProperty |
RowHeightProperty |
SelectionModeProperty |
SelectionUnitProperty |
VerticalGridLinesBrushProperty |
VerticalScrollBarVisibilityProperty |

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlternatingRowBackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AlternatingRowBackgroundProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.AlternatingRowBackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlternatingRowBackgroundProperty
Visual Basic
Public Shared AlternatingRowBackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlternatingRowBackgroundProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AreRowDetailsFrozenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AreRowDetailsFrozenProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.AreRowDetailsFrozenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AreRowDetailsFrozenProperty
Visual Basic
Public Shared AreRowDetailsFrozenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AreRowDetailsFrozenProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoGenerateColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AutoGenerateColumnsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.AutoGenerateColumnsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoGenerateColumnsProperty
Visual Basic
Public Shared AutoGenerateColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoGenerateColumnsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserAddRowsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserAddRowsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserAddRowsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserAddRowsProperty
Visual Basic
Public Shared CanUserAddRowsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserAddRowsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserDeleteRowsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserDeleteRowsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserDeleteRowsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserDeleteRowsProperty
Visual Basic
Public Shared CanUserDeleteRowsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserDeleteRowsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserReorderColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserReorderColumnsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserReorderColumnsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserReorderColumnsProperty
Visual Basic
Public Shared CanUserReorderColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserReorderColumnsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserResizeColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserResizeColumnsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserResizeColumnsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserResizeColumnsProperty
Visual Basic
Public Shared CanUserResizeColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserResizeColumnsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserResizeRowsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserResizeRowsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserResizeRowsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserResizeRowsProperty
Visual Basic
Public Shared CanUserResizeRowsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserResizeRowsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserSortColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserSortColumnsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserSortColumnsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserSortColumnsProperty
Visual Basic
Public Shared CanUserSortColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserSortColumnsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CellsPanelHorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CellsPanelHorizontalOffsetProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CellsPanelHorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CellsPanelHorizontalOffsetProperty
Visual Basic
Public Shared CellsPanelHorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CellsPanelHorizontalOffsetProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ClipboardCopyModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ClipboardCopyModeProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.ClipboardCopyModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ClipboardCopyModeProperty
Visual Basic
Public Shared ClipboardCopyModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ClipboardCopyModeProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnHeaderHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnHeaderHeightProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.ColumnHeaderHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnHeaderHeightProperty
Visual Basic
Public Shared ColumnHeaderHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnHeaderHeightProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.ColumnWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnWidthProperty
Visual Basic
Public Shared ColumnWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CurrentCellProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CurrentCellProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CurrentCellProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CurrentCellProperty
Visual Basic
Public Shared CurrentCellProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CurrentCellProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CurrentColumnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CurrentColumnProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CurrentColumnProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CurrentColumnProperty
Visual Basic
Public Shared CurrentColumnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CurrentColumnProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EnableColumnVirtualizationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..EnableColumnVirtualizationProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.EnableColumnVirtualizationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EnableColumnVirtualizationProperty
Visual Basic
Public Shared EnableColumnVirtualizationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EnableColumnVirtualizationProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EnableRowVirtualizationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..EnableRowVirtualizationProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.EnableRowVirtualizationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EnableRowVirtualizationProperty
Visual Basic
Public Shared EnableRowVirtualizationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EnableRowVirtualizationProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FrozenColumnCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..FrozenColumnCountProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.FrozenColumnCountProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FrozenColumnCountProperty
Visual Basic
Public Shared FrozenColumnCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FrozenColumnCountProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridLinesVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GridLinesVisibilityProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.GridLinesVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GridLinesVisibilityProperty
Visual Basic
Public Shared GridLinesVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GridLinesVisibilityProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeadersVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HeadersVisibilityProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.HeadersVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeadersVisibilityProperty
Visual Basic
Public Shared HeadersVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeadersVisibilityProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalGridLinesBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HorizontalGridLinesBrushProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.HorizontalGridLinesBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalGridLinesBrushProperty
Visual Basic
Public Shared HorizontalGridLinesBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalGridLinesBrushProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HorizontalScrollBarVisibilityProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.HorizontalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalScrollBarVisibilityProperty
Visual Basic
Public Shared HorizontalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalScrollBarVisibilityProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..IsReadOnlyProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxColumnWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MaxColumnWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.MaxColumnWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxColumnWidthProperty
Visual Basic
Public Shared MaxColumnWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxColumnWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinColumnWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MinColumnWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.MinColumnWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinColumnWidthProperty
Visual Basic
Public Shared MinColumnWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinColumnWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinRowHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MinRowHeightProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.MinRowHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinRowHeightProperty
Visual Basic
Public Shared MinRowHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinRowHeightProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NonFrozenColumnsViewportHorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..NonFrozenColumnsViewportHorizontalOffsetProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.NonFrozenColumnsViewportHorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NonFrozenColumnsViewportHorizontalOffsetProperty
Visual Basic
Public Shared NonFrozenColumnsViewportHorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NonFrozenColumnsViewportHorizontalOffsetProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowBackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowBackgroundProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowBackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowBackgroundProperty
Visual Basic
Public Shared RowBackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowBackgroundProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowDetailsVisibilityModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowDetailsVisibilityModeProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowDetailsVisibilityModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowDetailsVisibilityModeProperty
Visual Basic
Public Shared RowDetailsVisibilityModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowDetailsVisibilityModeProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowHeaderActualWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeaderActualWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowHeaderActualWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowHeaderActualWidthProperty
Visual Basic
Public Shared RowHeaderActualWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowHeaderActualWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowHeaderWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeaderWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowHeaderWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowHeaderWidthProperty
Visual Basic
Public Shared RowHeaderWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowHeaderWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeightProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowHeightProperty
Visual Basic
Public Shared RowHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowHeightProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SelectionModeProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.SelectionModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionModeProperty
Visual Basic
Public Shared SelectionModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionModeProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionUnitProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SelectionUnitProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.SelectionUnitProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionUnitProperty
Visual Basic
Public Shared SelectionUnitProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionUnitProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalGridLinesBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..VerticalGridLinesBrushProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.VerticalGridLinesBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalGridLinesBrushProperty
Visual Basic
Public Shared VerticalGridLinesBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalGridLinesBrushProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..VerticalScrollBarVisibilityProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.VerticalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalScrollBarVisibilityProperty
Visual Basic
Public Shared VerticalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalScrollBarVisibilityProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Methods
DataGrid Class See Also Send Feedback

The DataGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides MultiSelector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AnySibling Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AssignReference Method
DataGrid Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference

[Missing <param name="reference"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GetProperty Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GetRealType Method
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GetRectangle Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..Highlight Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..InvokeMethod Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..IsHitTest Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..NextSibling Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..Parent Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..PreviousSibling Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ScrollToVisible Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SetProperty Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Properties
DataGrid Class See Also Send Feedback

The DataGrid type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternatingRowBackground |
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AreRowDetailsFrozen |
Public property | AutoGenerateColumns |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanUserAddRows |
Public property | CanUserDeleteRows |
Public property | CanUserReorderColumns |
Public property | CanUserResizeColumns |
Public property | CanUserResizeRows |
Public property | CanUserSortColumns |
Public property | CellsPanelHorizontalOffset |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipboardCopyMode |
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ColumnHeaderContainer | Gets the column header container. Please override for custom control template.
Public property | ColumnHeaderElements | Get the list of column headers of this Grid.
Public property | ColumnHeaderHeight |
Public property | ColumnWidth |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | CurrentCell |
Public property | CurrentColumn |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableColumnVirtualization |
Public property | EnableRowVirtualization |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | FrozenColumnCount |
Public property | GridData | Gets the full textual content of a grid. The dictionary key represents the row of the grid.
Public property | GridLinesVisibility |
Public property | HasItems | (Inherited from ItemsControl.)
Public property | HeadersVisibility |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalGridLinesBrush |
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxColumnWidth |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinColumnWidth |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinRowHeight |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NonFrozenColumnsViewportHorizontalOffset |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RowBackground |
Public property | RowContainer | Gets the row container. Please override for custom control template.
Public property | RowDetailsVisibilityMode |
Public property | RowElements | Get the list of rows contained in this Grid.
Public property | RowHeaderActualWidth |
Public property | RowHeaderWidth |
Public property | RowHeight |
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionMode |
Public property | SelectionUnit |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalGridLinesBrush |
Public property | VerticalScrollBarVisibility |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlternatingRowBackground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AlternatingRowBackground Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.AlternatingRowBackground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush AlternatingRowBackground { get; set; }
Visual Basic
Public Property AlternatingRowBackground As Brush
    Get
    Set
Visual C++
public:
property Brush^ AlternatingRowBackground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AreRowDetailsFrozen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AreRowDetailsFrozen Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.AreRowDetailsFrozen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AreRowDetailsFrozen { get; set; }
Visual Basic
Public Property AreRowDetailsFrozen As Boolean
    Get
    Set
Visual C++
public:
property bool AreRowDetailsFrozen {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoGenerateColumns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AutoGenerateColumns Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.AutoGenerateColumns"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AutoGenerateColumns { get; set; }
Visual Basic
Public Property AutoGenerateColumns As Boolean
    Get
    Set
Visual C++
public:
property bool AutoGenerateColumns {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserAddRows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserAddRows Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserAddRows"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserAddRows { get; set; }
Visual Basic
Public Property CanUserAddRows As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserAddRows {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserDeleteRows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserDeleteRows Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserDeleteRows"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserDeleteRows { get; set; }
Visual Basic
Public Property CanUserDeleteRows As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserDeleteRows {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserReorderColumns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserReorderColumns Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserReorderColumns"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserReorderColumns { get; set; }
Visual Basic
Public Property CanUserReorderColumns As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserReorderColumns {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserResizeColumns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserResizeColumns Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserResizeColumns"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserResizeColumns { get; set; }
Visual Basic
Public Property CanUserResizeColumns As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserResizeColumns {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserResizeRows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserResizeRows Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserResizeRows"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserResizeRows { get; set; }
Visual Basic
Public Property CanUserResizeRows As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserResizeRows {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserSortColumns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserSortColumns Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CanUserSortColumns"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserSortColumns { get; set; }
Visual Basic
Public Property CanUserSortColumns As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserSortColumns {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CellsPanelHorizontalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CellsPanelHorizontalOffset Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CellsPanelHorizontalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CellsPanelHorizontalOffset { get; set; }
Visual Basic
Public Property CellsPanelHorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double CellsPanelHorizontalOffset {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ClipboardCopyMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ClipboardCopyMode Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.ClipboardCopyMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridClipboardCopyMode ClipboardCopyMode { get; set; }
Visual Basic
Public Property ClipboardCopyMode As DataGridClipboardCopyMode
    Get
    Set
Visual C++
public:
property DataGridClipboardCopyMode ClipboardCopyMode {
    DataGridClipboardCopyMode get ();
    void set (DataGridClipboardCopyMode value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnHeaderContainer Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnHeaderContainer Property
DataGrid Class See Also Send Feedback
Gets the column header container. Please override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ColumnHeaderContainer { get; }
Visual Basic
Public Overridable ReadOnly Property ColumnHeaderContainer As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ColumnHeaderContainer {
    FrameworkElement^ get ();
}

Field Value

The column header container.

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnHeaderElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnHeaderElements Property
DataGrid Class See Also Send Feedback
Get the list of column headers of this Grid.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<IDataGridColumnHeader> ColumnHeaderElements { get; }
Visual Basic
Public ReadOnly Property ColumnHeaderElements As IList(Of IDataGridColumnHeader)
    Get
Visual C++
public:
virtual property IList<IDataGridColumnHeader^>^ ColumnHeaderElements {
    IList<IDataGridColumnHeader^>^ get () sealed;
}

Implements

IDataGrid..::..ColumnHeaderElements

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnHeaderHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnHeaderHeight Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.ColumnHeaderHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ColumnHeaderHeight { get; set; }
Visual Basic
Public Property ColumnHeaderHeight As Double
    Get
    Set
Visual C++
public:
property double ColumnHeaderHeight {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.ColumnWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridLength ColumnWidth { get; set; }
Visual Basic
Public Property ColumnWidth As DataGridLength
    Get
    Set
Visual C++
public:
property DataGridLength^ ColumnWidth {
    DataGridLength^ get ();
    void set (DataGridLength^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CurrentCell Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CurrentCell Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CurrentCell"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridCellInfo CurrentCell { get; set; }
Visual Basic
Public Property CurrentCell As DataGridCellInfo
    Get
    Set
Visual C++
public:
property DataGridCellInfo^ CurrentCell {
    DataGridCellInfo^ get ();
    void set (DataGridCellInfo^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CurrentColumn Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CurrentColumn Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.CurrentColumn"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumn CurrentColumn { get; set; }
Visual Basic
Public Property CurrentColumn As DataGridColumn
    Get
    Set
Visual C++
public:
property DataGridColumn^ CurrentColumn {
    DataGridColumn^ get ();
    void set (DataGridColumn^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EnableColumnVirtualization Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..EnableColumnVirtualization Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.EnableColumnVirtualization"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableColumnVirtualization { get; set; }
Visual Basic
Public Property EnableColumnVirtualization As Boolean
    Get
    Set
Visual C++
public:
property bool EnableColumnVirtualization {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EnableRowVirtualization Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..EnableRowVirtualization Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.EnableRowVirtualization"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableRowVirtualization { get; set; }
Visual Basic
Public Property EnableRowVirtualization As Boolean
    Get
    Set
Visual C++
public:
property bool EnableRowVirtualization {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FrozenColumnCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..FrozenColumnCount Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.FrozenColumnCount"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int FrozenColumnCount { get; set; }
Visual Basic
Public Property FrozenColumnCount As Integer
    Get
    Set
Visual C++
public:
property int FrozenColumnCount {
    int get ();
    void set (int value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridData Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GridData Property
DataGrid Class See Also Send Feedback
Gets the full textual content of a grid. The dictionary key represents the row of the grid.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<int, string[]> GridData { get; }
Visual Basic
Public ReadOnly Property GridData As Dictionary(Of Integer, String())
    Get
Visual C++
public:
property Dictionary<int, array<String^>^>^ GridData {
    Dictionary<int, array<String^>^>^ get ();
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridLinesVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GridLinesVisibility Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.GridLinesVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridGridLinesVisibility GridLinesVisibility { get; set; }
Visual Basic
Public Property GridLinesVisibility As DataGridGridLinesVisibility
    Get
    Set
Visual C++
public:
property DataGridGridLinesVisibility GridLinesVisibility {
    DataGridGridLinesVisibility get ();
    void set (DataGridGridLinesVisibility value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeadersVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HeadersVisibility Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.HeadersVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridHeadersVisibility HeadersVisibility { get; set; }
Visual Basic
Public Property HeadersVisibility As DataGridHeadersVisibility
    Get
    Set
Visual C++
public:
property DataGridHeadersVisibility HeadersVisibility {
    DataGridHeadersVisibility get ();
    void set (DataGridHeadersVisibility value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalGridLinesBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HorizontalGridLinesBrush Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.HorizontalGridLinesBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush HorizontalGridLinesBrush { get; set; }
Visual Basic
Public Property HorizontalGridLinesBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HorizontalGridLinesBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HorizontalScrollBarVisibility Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.HorizontalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility HorizontalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..IsReadOnly Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxColumnWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MaxColumnWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.MaxColumnWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxColumnWidth { get; set; }
Visual Basic
Public Property MaxColumnWidth As Double
    Get
    Set
Visual C++
public:
property double MaxColumnWidth {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinColumnWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MinColumnWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.MinColumnWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinColumnWidth { get; set; }
Visual Basic
Public Property MinColumnWidth As Double
    Get
    Set
Visual C++
public:
property double MinColumnWidth {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinRowHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MinRowHeight Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.MinRowHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinRowHeight { get; set; }
Visual Basic
Public Property MinRowHeight As Double
    Get
    Set
Visual C++
public:
property double MinRowHeight {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NonFrozenColumnsViewportHorizontalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..NonFrozenColumnsViewportHorizontalOffset Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.NonFrozenColumnsViewportHorizontalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double NonFrozenColumnsViewportHorizontalOffset { get; set; }
Visual Basic
Public Property NonFrozenColumnsViewportHorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double NonFrozenColumnsViewportHorizontalOffset {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowBackground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowBackground Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowBackground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush RowBackground { get; set; }
Visual Basic
Public Property RowBackground As Brush
    Get
    Set
Visual C++
public:
property Brush^ RowBackground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowContainer Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowContainer Property
DataGrid Class See Also Send Feedback
Gets the row container. Please override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement RowContainer { get; }
Visual Basic
Public Overridable ReadOnly Property RowContainer As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ RowContainer {
    FrameworkElement^ get ();
}

Field Value

The row container.

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowDetailsVisibilityMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowDetailsVisibilityMode Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowDetailsVisibilityMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRowDetailsVisibilityMode RowDetailsVisibilityMode { get; set; }
Visual Basic
Public Property RowDetailsVisibilityMode As DataGridRowDetailsVisibilityMode
    Get
    Set
Visual C++
public:
property DataGridRowDetailsVisibilityMode RowDetailsVisibilityMode {
    DataGridRowDetailsVisibilityMode get ();
    void set (DataGridRowDetailsVisibilityMode value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowElements Property
DataGrid Class See Also Send Feedback
Get the list of rows contained in this Grid.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<IDataGridRow> RowElements { get; }
Visual Basic
Public ReadOnly Property RowElements As IList(Of IDataGridRow)
    Get
Visual C++
public:
virtual property IList<IDataGridRow^>^ RowElements {
    IList<IDataGridRow^>^ get () sealed;
}

Implements

IDataGrid..::..RowElements

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowHeaderActualWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeaderActualWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowHeaderActualWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RowHeaderActualWidth { get; set; }
Visual Basic
Public Property RowHeaderActualWidth As Double
    Get
    Set
Visual C++
public:
property double RowHeaderActualWidth {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowHeaderWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeaderWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowHeaderWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RowHeaderWidth { get; set; }
Visual Basic
Public Property RowHeaderWidth As Double
    Get
    Set
Visual C++
public:
property double RowHeaderWidth {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeight Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.RowHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RowHeight { get; set; }
Visual Basic
Public Property RowHeight As Double
    Get
    Set
Visual C++
public:
property double RowHeight {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SelectionMode Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.SelectionMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As DataGridSelectionMode
    Get
    Set
Visual C++
public:
property DataGridSelectionMode SelectionMode {
    DataGridSelectionMode get ();
    void set (DataGridSelectionMode value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionUnit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SelectionUnit Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.SelectionUnit"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridSelectionUnit SelectionUnit { get; set; }
Visual Basic
Public Property SelectionUnit As DataGridSelectionUnit
    Get
    Set
Visual C++
public:
property DataGridSelectionUnit SelectionUnit {
    DataGridSelectionUnit get ();
    void set (DataGridSelectionUnit value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalGridLinesBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..VerticalGridLinesBrush Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.VerticalGridLinesBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush VerticalGridLinesBrush { get; set; }
Visual Basic
Public Property VerticalGridLinesBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ VerticalGridLinesBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..VerticalScrollBarVisibility Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGrid.VerticalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic
Public Property VerticalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility VerticalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Members
DataGridCell Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridCell type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridCell | Initializes a new instance of the DataGridCell class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ColumnProperty |
IsEditingProperty |
IsReadOnlyProperty |
IsSelectedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CellText | Return the cell text if any, else empty string. In case of multiple text blocks concatenates all the text.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Column |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEditing |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Constructor
DataGridCell Class See Also Send Feedback
Initializes a new instance of the DataGridCell class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridCell()
Visual Basic
Public Sub New
Visual C++
public:
DataGridCell()

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCell Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Fields
DataGridCell Class See Also Send Feedback

The DataGridCell type exposes the following members.

Fields

Name | Description
ColumnProperty |
IsEditingProperty |
IsReadOnlyProperty |
IsSelectedProperty |

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..ColumnProperty Field
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.ColumnProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnProperty
Visual Basic
Public Shared ColumnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnProperty

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEditingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsEditingProperty Field
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.IsEditingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEditingProperty
Visual Basic
Public Shared IsEditingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEditingProperty

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsReadOnlyProperty Field
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsSelectedProperty Field
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Methods
DataGridCell Class See Also Send Feedback

The DataGridCell type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..AnySibling Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..GetProperty Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..GetRealType Method
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..GetRectangle Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..Highlight Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..InvokeMethod Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsHitTest Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..NextSibling Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..Parent Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..PreviousSibling Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..ScrollToVisible Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..SetProperty Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Properties
DataGridCell Class See Also Send Feedback

The DataGridCell type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CellText | Return the cell text if any, else empty string. In case of multiple text blocks concatenates all the text.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Column |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEditing |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CellText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..CellText Property
DataGridCell Class See Also Send Feedback
Return the cell text if any, else empty string. In case of multiple text blocks concatenates all the text.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string CellText { get; }
Visual Basic
Public ReadOnly Property CellText As String
    Get
Visual C++
public:
virtual property String^ CellText {
    String^ get () sealed;
}

Implements

IDataGridCell..::..CellText

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Column Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..Column Property
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.Column"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumn Column { get; set; }
Visual Basic
Public Property Column As DataGridColumn
    Get
    Set
Visual C++
public:
property DataGridColumn^ Column {
    DataGridColumn^ get ();
    void set (DataGridColumn^ value);
}

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEditing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsEditing Property
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.IsEditing"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEditing { get; set; }
Visual Basic
Public Property IsEditing As Boolean
    Get
    Set
Visual C++
public:
property bool IsEditing {
    bool get ();
    void set (bool value);
}

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsReadOnly Property
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsSelected Property
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCell.IsSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

DataGridCell Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo Members
DataGridCellInfo Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridCellInfo type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridCellInfo | Initializes a new instance of the DataGridCellInfo class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ColumnProperty |
IsValidProperty |
ItemProperty |

Properties

 | Name | Description
Public property | Column |
Public property | IsValid |
Public property | Item |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo Constructor
DataGridCellInfo Class See Also Send Feedback
Initializes a new instance of the DataGridCellInfo class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridCellInfo()
Visual Basic
Public Sub New
Visual C++
public:
DataGridCellInfo()

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellInfo Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo Fields
DataGridCellInfo Class See Also Send Feedback

The DataGridCellInfo type exposes the following members.

Fields

Name | Description
ColumnProperty |
IsValidProperty |
ItemProperty |

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..ColumnProperty Field
DataGridCellInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellInfo.ColumnProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnProperty
Visual Basic
Public Shared ColumnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnProperty

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsValidProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..IsValidProperty Field
DataGridCellInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellInfo.IsValidProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsValidProperty
Visual Basic
Public Shared IsValidProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsValidProperty

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..ItemProperty Field
DataGridCellInfo Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellInfo.ItemProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemProperty
Visual Basic
Public Shared ItemProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemProperty

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo Methods
DataGridCellInfo Class See Also Send Feedback

The DataGridCellInfo type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..GetProperty Method
DataGridCellInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellInfo Class
DataGridCellInfo Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..GetRealType Method
DataGridCellInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellInfo.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellInfo.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..InvokeMethod Method
DataGridCellInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellInfo Class
DataGridCellInfo Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo Properties
DataGridCellInfo Class See Also Send Feedback

The DataGridCellInfo type exposes the following members.

Properties

 | Name | Description
Public property | Column |
Public property | IsValid |
Public property | Item |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Column Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..Column Property
DataGridCellInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellInfo.Column"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual DataGridColumn Column { get; set; }
Visual Basic
Public Overridable Property Column As DataGridColumn
    Get
    Set
Visual C++
public:
virtual property DataGridColumn^ Column {
    DataGridColumn^ get ();
    void set (DataGridColumn^ value);
}

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsValid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..IsValid Property
DataGridCellInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellInfo.IsValid"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsValid { get; set; }
Visual Basic
Public Overridable Property IsValid As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsValid {
    bool get ();
    void set (bool value);
}

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellInfo..::..Item Property
DataGridCellInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellInfo.Item"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Object Item { get; set; }
Visual Basic
Public Overridable Property Item As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}

See Also

DataGridCellInfo Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel Members
DataGridCellsPanel Class Constructors Methods Properties See Also Send Feedback

The DataGridCellsPanel type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridCellsPanel | Initializes a new instance of the DataGridCellsPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides VirtualizingPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel Constructor
DataGridCellsPanel Class See Also Send Feedback
Initializes a new instance of the DataGridCellsPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridCellsPanel()
Visual Basic
Public Sub New
Visual C++
public:
DataGridCellsPanel()

See Also

DataGridCellsPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel Methods
DataGridCellsPanel Class See Also Send Feedback

The DataGridCellsPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides VirtualizingPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..AnySibling Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..GetProperty Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..GetRealType Method
DataGridCellsPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellsPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellsPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridCellsPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..GetRectangle Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..Highlight Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..InvokeMethod Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..IsHitTest Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..NextSibling Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..Parent Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..PreviousSibling Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..ScrollToVisible Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel..::..SetProperty Method
DataGridCellsPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPanel Properties
DataGridCellsPanel Class See Also Send Feedback

The DataGridCellsPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter Members
DataGridCellsPresenter Class Constructors Methods Properties See Also Send Feedback

The DataGridCellsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridCellsPresenter | Initializes a new instance of the DataGridCellsPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter Constructor
DataGridCellsPresenter Class See Also Send Feedback
Initializes a new instance of the DataGridCellsPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridCellsPresenter()
Visual Basic
Public Sub New
Visual C++
public:
DataGridCellsPresenter()

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter Methods
DataGridCellsPresenter Class See Also Send Feedback

The DataGridCellsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..AnySibling Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..GetProperty Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..GetRealType Method
DataGridCellsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellsPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridCellsPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..GetRectangle Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..Highlight Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..InvokeMethod Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..IsHitTest Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..NextSibling Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..Parent Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..PreviousSibling Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..ScrollToVisible Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..SetProperty Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter Properties
DataGridCellsPresenter Class See Also Send Feedback

The DataGridCellsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumn Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Members
DataGridColumn Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridColumn type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridColumn | Initializes a new instance of the DataGridColumn class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ActualWidthProperty |
CanUserReorderProperty |
CanUserResizeProperty |
CanUserSortProperty |
DisplayIndexProperty |
IsAutoGeneratedProperty |
IsFrozenProperty |
IsReadOnlyProperty |
MaxWidthProperty |
MinWidthProperty |
VisibilityProperty |
WidthProperty |

Properties

 | Name | Description
Public property | ActualWidth |
Public property | CanUserReorder |
Public property | CanUserResize |
Public property | CanUserSort |
Public property | DisplayIndex |
Public property | IsAutoGenerated |
Public property | IsFrozen |
Public property | IsReadOnly |
Public property | MaxWidth |
Public property | MinWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Visibility |
Public property | Width |

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumn Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Constructor
DataGridColumn Class See Also Send Feedback
Initializes a new instance of the DataGridColumn class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumn()
Visual Basic
Public Sub New
Visual C++
public:
DataGridColumn()

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumn Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Fields
DataGridColumn Class See Also Send Feedback

The DataGridColumn type exposes the following members.

Fields

Name | Description
ActualWidthProperty |
CanUserReorderProperty |
CanUserResizeProperty |
CanUserSortProperty |
DisplayIndexProperty |
IsAutoGeneratedProperty |
IsFrozenProperty |
IsReadOnlyProperty |
MaxWidthProperty |
MinWidthProperty |
VisibilityProperty |
WidthProperty |

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ActualWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..ActualWidthProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.ActualWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ActualWidthProperty
Visual Basic
Public Shared ActualWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ActualWidthProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserReorderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..CanUserReorderProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.CanUserReorderProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserReorderProperty
Visual Basic
Public Shared CanUserReorderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserReorderProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserResizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..CanUserResizeProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.CanUserResizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserResizeProperty
Visual Basic
Public Shared CanUserResizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserResizeProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserSortProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..CanUserSortProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.CanUserSortProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserSortProperty
Visual Basic
Public Shared CanUserSortProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserSortProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..DisplayIndexProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.DisplayIndexProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayIndexProperty
Visual Basic
Public Shared DisplayIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayIndexProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsAutoGeneratedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..IsAutoGeneratedProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.IsAutoGeneratedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsAutoGeneratedProperty
Visual Basic
Public Shared IsAutoGeneratedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsAutoGeneratedProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFrozenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..IsFrozenProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.IsFrozenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFrozenProperty
Visual Basic
Public Shared IsFrozenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFrozenProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..IsReadOnlyProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..MaxWidthProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.MaxWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxWidthProperty
Visual Basic
Public Shared MaxWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxWidthProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..MinWidthProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.MinWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinWidthProperty
Visual Basic
Public Shared MinWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinWidthProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..VisibilityProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.VisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VisibilityProperty
Visual Basic
Public Shared VisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VisibilityProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..WidthProperty Field
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.WidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumn Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Methods
DataGridColumn Class See Also Send Feedback

The DataGridColumn type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..GetProperty Method
DataGridColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumn Class
DataGridColumn Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..GetRealType Method
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..InvokeMethod Method
DataGridColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumn Class
DataGridColumn Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumn Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Properties
DataGridColumn Class See Also Send Feedback

The DataGridColumn type exposes the following members.

Properties

 | Name | Description
Public property | ActualWidth |
Public property | CanUserReorder |
Public property | CanUserResize |
Public property | CanUserSort |
Public property | DisplayIndex |
Public property | IsAutoGenerated |
Public property | IsFrozen |
Public property | IsReadOnly |
Public property | MaxWidth |
Public property | MinWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Visibility |
Public property | Width |

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ActualWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..ActualWidth Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.ActualWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ActualWidth { get; set; }
Visual Basic
Public Property ActualWidth As Double
    Get
    Set
Visual C++
public:
property double ActualWidth {
    double get ();
    void set (double value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserReorder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..CanUserReorder Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.CanUserReorder"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserReorder { get; set; }
Visual Basic
Public Property CanUserReorder As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserReorder {
    bool get ();
    void set (bool value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserResize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..CanUserResize Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.CanUserResize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserResize { get; set; }
Visual Basic
Public Property CanUserResize As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserResize {
    bool get ();
    void set (bool value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserSort Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..CanUserSort Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.CanUserSort"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserSort { get; set; }
Visual Basic
Public Property CanUserSort As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserSort {
    bool get ();
    void set (bool value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..DisplayIndex Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.DisplayIndex"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int DisplayIndex { get; set; }
Visual Basic
Public Property DisplayIndex As Integer
    Get
    Set
Visual C++
public:
property int DisplayIndex {
    int get ();
    void set (int value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsAutoGenerated Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..IsAutoGenerated Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.IsAutoGenerated"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsAutoGenerated { get; set; }
Visual Basic
Public Property IsAutoGenerated As Boolean
    Get
    Set
Visual C++
public:
property bool IsAutoGenerated {
    bool get ();
    void set (bool value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFrozen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..IsFrozen Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.IsFrozen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFrozen { get; set; }
Visual Basic
Public Property IsFrozen As Boolean
    Get
    Set
Visual C++
public:
property bool IsFrozen {
    bool get ();
    void set (bool value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..IsReadOnly Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..MaxWidth Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.MaxWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxWidth { get; set; }
Visual Basic
Public Property MaxWidth As Double
    Get
    Set
Visual C++
public:
property double MaxWidth {
    double get ();
    void set (double value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..MinWidth Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.MinWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinWidth { get; set; }
Visual Basic
Public Property MinWidth As Double
    Get
    Set
Visual C++
public:
property double MinWidth {
    double get ();
    void set (double value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Visibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..Visibility Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.Visibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility Visibility { get; set; }
Visual Basic
Public Property Visibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility Visibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..Width Property
DataGridColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumn.Width"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridLength Width { get; set; }
Visual Basic
Public Property Width As DataGridLength
    Get
    Set
Visual C++
public:
property DataGridLength^ Width {
    DataGridLength^ get ();
    void set (DataGridLength^ value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Members
DataGridColumnHeader Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridColumnHeader type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridColumnHeader | Initializes a new instance of the DataGridColumnHeader class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanUserSortProperty |
DisplayIndexProperty |
IsFrozenProperty |
SeparatorBrushProperty |
SeparatorVisibilityProperty |
SortDirectionProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanUserSort |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayIndex |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsFrozen |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | SortDirection |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Constructor
DataGridColumnHeader Class See Also Send Feedback
Initializes a new instance of the DataGridColumnHeader class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumnHeader()
Visual Basic
Public Sub New
Visual C++
public:
DataGridColumnHeader()

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeader Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Fields
DataGridColumnHeader Class See Also Send Feedback

The DataGridColumnHeader type exposes the following members.

Fields

Name | Description
CanUserSortProperty |
DisplayIndexProperty |
IsFrozenProperty |
SeparatorBrushProperty |
SeparatorVisibilityProperty |
SortDirectionProperty |

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserSortProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..CanUserSortProperty Field
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.CanUserSortProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserSortProperty
Visual Basic
Public Shared CanUserSortProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserSortProperty

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..DisplayIndexProperty Field
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.DisplayIndexProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayIndexProperty
Visual Basic
Public Shared DisplayIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayIndexProperty

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFrozenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..IsFrozenProperty Field
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.IsFrozenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFrozenProperty
Visual Basic
Public Shared IsFrozenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFrozenProperty

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SeparatorBrushProperty Field
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.SeparatorBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorBrushProperty
Visual Basic
Public Shared SeparatorBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorBrushProperty

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SeparatorVisibilityProperty Field
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.SeparatorVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorVisibilityProperty
Visual Basic
Public Shared SeparatorVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorVisibilityProperty

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SortDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SortDirectionProperty Field
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.SortDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SortDirectionProperty
Visual Basic
Public Shared SortDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SortDirectionProperty

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Methods
DataGridColumnHeader Class See Also Send Feedback

The DataGridColumnHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..AnySibling Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..GetProperty Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..GetRealType Method
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..GetRectangle Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..Highlight Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..InvokeMethod Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..IsHitTest Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..NextSibling Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..Parent Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..PreviousSibling Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..ScrollToVisible Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SetProperty Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Properties
DataGridColumnHeader Class See Also Send Feedback

The DataGridColumnHeader type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanUserSort |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayIndex |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsFrozen |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | SortDirection |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanUserSort Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..CanUserSort Property
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.CanUserSort"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserSort { get; set; }
Visual Basic
Public Property CanUserSort As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserSort {
    bool get ();
    void set (bool value);
}

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..DisplayIndex Property
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.DisplayIndex"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int DisplayIndex { get; set; }
Visual Basic
Public Property DisplayIndex As Integer
    Get
    Set
Visual C++
public:
property int DisplayIndex {
    int get ();
    void set (int value);
}

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFrozen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..IsFrozen Property
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.IsFrozen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFrozen { get; set; }
Visual Basic
Public Property IsFrozen As Boolean
    Get
    Set
Visual C++
public:
property bool IsFrozen {
    bool get ();
    void set (bool value);
}

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SeparatorBrush Property
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.SeparatorBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush SeparatorBrush { get; set; }
Visual Basic
Public Property SeparatorBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SeparatorBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SeparatorVisibility Property
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.SeparatorVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility SeparatorVisibility { get; set; }
Visual Basic
Public Property SeparatorVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility SeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SortDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SortDirection Property
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeader.SortDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ListSortDescription SortDirection { get; set; }
Visual Basic
Public Property SortDirection As ListSortDescription
    Get
    Set
Visual C++
public:
property ListSortDescription^ SortDirection {
    ListSortDescription^ get ();
    void set (ListSortDescription^ value);
}

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeadersPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter Members
DataGridColumnHeadersPresenter Class Constructors Methods Properties See Also Send Feedback

The DataGridColumnHeadersPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridColumnHeadersPresenter | Initializes a new instance of the DataGridColumnHeadersPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeadersPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter Constructor
DataGridColumnHeadersPresenter Class See Also Send Feedback
Initializes a new instance of the DataGridColumnHeadersPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumnHeadersPresenter()
Visual Basic
Public Sub New
Visual C++
public:
DataGridColumnHeadersPresenter()

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeadersPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter Methods
DataGridColumnHeadersPresenter Class See Also Send Feedback

The DataGridColumnHeadersPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..AnySibling Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..GetProperty Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..GetRealType Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeadersPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridColumnHeadersPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..GetRectangle Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..Highlight Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..InvokeMethod Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..IsHitTest Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..NextSibling Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..Parent Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..PreviousSibling Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..ScrollToVisible Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..SetProperty Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridColumnHeadersPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter Properties
DataGridColumnHeadersPresenter Class See Also Send Feedback

The DataGridColumnHeadersPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridDetailsPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Members
DataGridDetailsPresenter Class Constructors Methods Properties See Also Send Feedback

The DataGridDetailsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridDetailsPresenter | Initializes a new instance of the DataGridDetailsPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentPresenter..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentSource | (Inherited from ContentPresenter.)
Public property | ContentStringFormat | (Inherited from ContentPresenter.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RecognizesAccessKey | (Inherited from ContentPresenter.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridDetailsPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Constructor
DataGridDetailsPresenter Class See Also Send Feedback
Initializes a new instance of the DataGridDetailsPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridDetailsPresenter()
Visual Basic
Public Sub New
Visual C++
public:
DataGridDetailsPresenter()

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridDetailsPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Methods
DataGridDetailsPresenter Class See Also Send Feedback

The DataGridDetailsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentPresenter..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..AnySibling Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..GetProperty Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..GetRealType Method
DataGridDetailsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridDetailsPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridDetailsPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..GetRectangle Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..Highlight Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..InvokeMethod Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..IsHitTest Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..NextSibling Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..Parent Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..PreviousSibling Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..ScrollToVisible Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..SetProperty Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridDetailsPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Properties
DataGridDetailsPresenter Class See Also Send Feedback

The DataGridDetailsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentSource | (Inherited from ContentPresenter.)
Public property | ContentStringFormat | (Inherited from ContentPresenter.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RecognizesAccessKey | (Inherited from ContentPresenter.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridHeaderBorder Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder Members
DataGridHeaderBorder Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridHeaderBorder type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridHeaderBorder | Initializes a new instance of the DataGridHeaderBorder class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Border..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsClickableProperty |
IsHoveredProperty |
IsPressedProperty |
IsSelectedProperty |
OrientationProperty |
SeparatorBrushProperty |
SeparatorVisibilityProperty |
SortDirectionProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Border.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Border.)
Public property | BorderThickness | (Inherited from Border.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | CornerRadius | (Inherited from Border.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsClickable |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsHovered |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed |
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Border.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | SortDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridHeaderBorder Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder Constructor
DataGridHeaderBorder Class See Also Send Feedback
Initializes a new instance of the DataGridHeaderBorder class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridHeaderBorder()
Visual Basic
Public Sub New
Visual C++
public:
DataGridHeaderBorder()

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridHeaderBorder Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder Fields
DataGridHeaderBorder Class See Also Send Feedback

The DataGridHeaderBorder type exposes the following members.

Fields

Name | Description
IsClickableProperty |
IsHoveredProperty |
IsPressedProperty |
IsSelectedProperty |
OrientationProperty |
SeparatorBrushProperty |
SeparatorVisibilityProperty |
SortDirectionProperty |

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsClickableProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsClickableProperty Field
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.IsClickableProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsClickableProperty
Visual Basic
Public Shared IsClickableProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsClickableProperty

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHoveredProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsHoveredProperty Field
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.IsHoveredProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsHoveredProperty
Visual Basic
Public Shared IsHoveredProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsHoveredProperty

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPressedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsPressedProperty Field
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.IsPressedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsPressedProperty
Visual Basic
Public Shared IsPressedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsPressedProperty

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsSelectedProperty Field
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..OrientationProperty Field
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..SeparatorBrushProperty Field
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.SeparatorBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorBrushProperty
Visual Basic
Public Shared SeparatorBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorBrushProperty

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..SeparatorVisibilityProperty Field
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.SeparatorVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorVisibilityProperty
Visual Basic
Public Shared SeparatorVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorVisibilityProperty

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SortDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..SortDirectionProperty Field
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.SortDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SortDirectionProperty
Visual Basic
Public Shared SortDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SortDirectionProperty

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridHeaderBorder Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder Methods
DataGridHeaderBorder Class See Also Send Feedback

The DataGridHeaderBorder type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Border..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..AnySibling Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..GetProperty Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..GetRealType Method
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..GetRectangle Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..Highlight Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..InvokeMethod Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsHitTest Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..NextSibling Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..Parent Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..PreviousSibling Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..ScrollToVisible Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..SetProperty Method
DataGridHeaderBorder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridHeaderBorder Class
DataGridHeaderBorder Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridHeaderBorder Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder Properties
DataGridHeaderBorder Class See Also Send Feedback

The DataGridHeaderBorder type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Border.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Border.)
Public property | BorderThickness | (Inherited from Border.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | CornerRadius | (Inherited from Border.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsClickable |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsHovered |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed |
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Border.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | SortDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsClickable Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsClickable Property
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.IsClickable"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsClickable { get; set; }
Visual Basic
Public Property IsClickable As Boolean
    Get
    Set
Visual C++
public:
property bool IsClickable {
    bool get ();
    void set (bool value);
}

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHovered Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsHovered Property
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.IsHovered"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsHovered { get; set; }
Visual Basic
Public Property IsHovered As Boolean
    Get
    Set
Visual C++
public:
property bool IsHovered {
    bool get ();
    void set (bool value);
}

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPressed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsPressed Property
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.IsPressed"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsPressed { get; set; }
Visual Basic
Public Property IsPressed As Boolean
    Get
    Set
Visual C++
public:
property bool IsPressed {
    bool get ();
    void set (bool value);
}

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..IsSelected Property
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.IsSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..Orientation Property
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..SeparatorBrush Property
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.SeparatorBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush SeparatorBrush { get; set; }
Visual Basic
Public Property SeparatorBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SeparatorBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..SeparatorVisibility Property
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.SeparatorVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility SeparatorVisibility { get; set; }
Visual Basic
Public Property SeparatorVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility SeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SortDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridHeaderBorder..::..SortDirection Property
DataGridHeaderBorder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridHeaderBorder.SortDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ListSortDirection SortDirection { get; set; }
Visual Basic
Public Property SortDirection As ListSortDirection
    Get
    Set
Visual C++
public:
property ListSortDirection SortDirection {
    ListSortDirection get ();
    void set (ListSortDirection value);
}

See Also

DataGridHeaderBorder Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridLength Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Members
DataGridLength Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridLength type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridLength | Initializes a new instance of the DataGridLength class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AutoProperty |
DesiredValueProperty |
DisplayValueProperty |
IsAbsoluteProperty |
IsAutoProperty |
IsSizeToCellsProperty |
IsSizeToHeaderProperty |
IsStarProperty |
SizeToCellsProperty |
SizeToHeaderProperty |
UnitTypeProperty |
ValueProperty |

Properties

 | Name | Description
Public property | Auto |
Public property | DesiredValue |
Public property | DisplayValue |
Public property | IsAbsolute |
Public property | IsAuto |
Public property | IsSizeToCells |
Public property | IsSizeToHeader |
Public property | IsStar |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | SizeToCells |
Public property | SizeToHeader |
Public property | UnitType |
Public property | Value |

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridLength Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Constructor
DataGridLength Class See Also Send Feedback
Initializes a new instance of the DataGridLength class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridLength()
Visual Basic
Public Sub New
Visual C++
public:
DataGridLength()

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridLength Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Fields
DataGridLength Class See Also Send Feedback

The DataGridLength type exposes the following members.

Fields

Name | Description
AutoProperty |
DesiredValueProperty |
DisplayValueProperty |
IsAbsoluteProperty |
IsAutoProperty |
IsSizeToCellsProperty |
IsSizeToHeaderProperty |
IsStarProperty |
SizeToCellsProperty |
SizeToHeaderProperty |
UnitTypeProperty |
ValueProperty |

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..AutoProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.AutoProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoProperty
Visual Basic
Public Shared AutoProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DesiredValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..DesiredValueProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.DesiredValueProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DesiredValueProperty
Visual Basic
Public Shared DesiredValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DesiredValueProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..DisplayValueProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.DisplayValueProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayValueProperty
Visual Basic
Public Shared DisplayValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayValueProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsAbsoluteProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsAbsoluteProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsAbsoluteProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsAbsoluteProperty
Visual Basic
Public Shared IsAbsoluteProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsAbsoluteProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsAutoProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsAutoProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsAutoProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsAutoProperty
Visual Basic
Public Shared IsAutoProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsAutoProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSizeToCellsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsSizeToCellsProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsSizeToCellsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSizeToCellsProperty
Visual Basic
Public Shared IsSizeToCellsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSizeToCellsProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSizeToHeaderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsSizeToHeaderProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsSizeToHeaderProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSizeToHeaderProperty
Visual Basic
Public Shared IsSizeToHeaderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSizeToHeaderProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStarProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsStarProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsStarProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsStarProperty
Visual Basic
Public Shared IsStarProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsStarProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SizeToCellsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..SizeToCellsProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.SizeToCellsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SizeToCellsProperty
Visual Basic
Public Shared SizeToCellsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SizeToCellsProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SizeToHeaderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..SizeToHeaderProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.SizeToHeaderProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SizeToHeaderProperty
Visual Basic
Public Shared SizeToHeaderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SizeToHeaderProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnitTypeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..UnitTypeProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.UnitTypeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UnitTypeProperty
Visual Basic
Public Shared UnitTypeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UnitTypeProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..ValueProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.ValueProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ValueProperty
Visual Basic
Public Shared ValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ValueProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridLength Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Methods
DataGridLength Class See Also Send Feedback

The DataGridLength type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..GetProperty Method
DataGridLength Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridLength Class
DataGridLength Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..GetRealType Method
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..InvokeMethod Method
DataGridLength Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridLength Class
DataGridLength Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridLength Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Properties
DataGridLength Class See Also Send Feedback

The DataGridLength type exposes the following members.

Properties

 | Name | Description
Public property | Auto |
Public property | DesiredValue |
Public property | DisplayValue |
Public property | IsAbsolute |
Public property | IsAuto |
Public property | IsSizeToCells |
Public property | IsSizeToHeader |
Public property | IsStar |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | SizeToCells |
Public property | SizeToHeader |
Public property | UnitType |
Public property | Value |

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Auto Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..Auto Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.Auto"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual DataGridLength Auto { get; set; }
Visual Basic
Public Overridable Property Auto As DataGridLength
    Get
    Set
Visual C++
public:
virtual property DataGridLength^ Auto {
    DataGridLength^ get ();
    void set (DataGridLength^ value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DesiredValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..DesiredValue Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.DesiredValue"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double DesiredValue { get; set; }
Visual Basic
Public Overridable Property DesiredValue As Double
    Get
    Set
Visual C++
public:
virtual property double DesiredValue {
    double get ();
    void set (double value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..DisplayValue Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.DisplayValue"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double DisplayValue { get; set; }
Visual Basic
Public Overridable Property DisplayValue As Double
    Get
    Set
Visual C++
public:
virtual property double DisplayValue {
    double get ();
    void set (double value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsAbsolute Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsAbsolute Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsAbsolute"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsAbsolute { get; set; }
Visual Basic
Public Overridable Property IsAbsolute As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsAbsolute {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsAuto Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsAuto Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsAuto"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsAuto { get; set; }
Visual Basic
Public Overridable Property IsAuto As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsAuto {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSizeToCells Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsSizeToCells Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsSizeToCells"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsSizeToCells { get; set; }
Visual Basic
Public Overridable Property IsSizeToCells As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsSizeToCells {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSizeToHeader Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsSizeToHeader Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsSizeToHeader"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsSizeToHeader { get; set; }
Visual Basic
Public Overridable Property IsSizeToHeader As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsSizeToHeader {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStar Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsStar Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.IsStar"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsStar { get; set; }
Visual Basic
Public Overridable Property IsStar As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsStar {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SizeToCells Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..SizeToCells Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.SizeToCells"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual DataGridLength SizeToCells { get; set; }
Visual Basic
Public Overridable Property SizeToCells As DataGridLength
    Get
    Set
Visual C++
public:
virtual property DataGridLength^ SizeToCells {
    DataGridLength^ get ();
    void set (DataGridLength^ value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SizeToHeader Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..SizeToHeader Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.SizeToHeader"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual DataGridLength SizeToHeader { get; set; }
Visual Basic
Public Overridable Property SizeToHeader As DataGridLength
    Get
    Set
Visual C++
public:
virtual property DataGridLength^ SizeToHeader {
    DataGridLength^ get ();
    void set (DataGridLength^ value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnitType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..UnitType Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.UnitType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual DataGridLengthUnitType UnitType { get; set; }
Visual Basic
Public Overridable Property UnitType As DataGridLengthUnitType
    Get
    Set
Visual C++
public:
virtual property DataGridLengthUnitType UnitType {
    DataGridLengthUnitType get ();
    void set (DataGridLengthUnitType value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..Value Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridLength.Value"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Value { get; set; }
Visual Basic
Public Overridable Property Value As Double
    Get
    Set
Visual C++
public:
virtual property double Value {
    double get ();
    void set (double value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Members
DataGridRow Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridRow type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridRow | Initializes a new instance of the DataGridRow class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AlternationIndexProperty |
DetailsVisibilityProperty |
IsEditingProperty |
IsSelectedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationIndex |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CellElements | Get the cells inside this row.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | DataGridCellsPresenter | Get the DataGridRow cells presenter element. Please override for custom control template.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DetailsVisibility |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEditing |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RowData | Gets all the text contained in the cells as an array of strings for this row.
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRow Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Constructor
DataGridRow Class See Also Send Feedback
Initializes a new instance of the DataGridRow class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRow()
Visual Basic
Public Sub New
Visual C++
public:
DataGridRow()

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRow Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Fields
DataGridRow Class See Also Send Feedback

The DataGridRow type exposes the following members.

Fields

Name | Description
AlternationIndexProperty |
DetailsVisibilityProperty |
IsEditingProperty |
IsSelectedProperty |

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlternationIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..AlternationIndexProperty Field
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.AlternationIndexProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlternationIndexProperty
Visual Basic
Public Shared AlternationIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlternationIndexProperty

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DetailsVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..DetailsVisibilityProperty Field
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.DetailsVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DetailsVisibilityProperty
Visual Basic
Public Shared DetailsVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DetailsVisibilityProperty

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEditingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..IsEditingProperty Field
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.IsEditingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEditingProperty
Visual Basic
Public Shared IsEditingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEditingProperty

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..IsSelectedProperty Field
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Methods
DataGridRow Class See Also Send Feedback

The DataGridRow type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..AnySibling Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..AssignReference Method
DataGridRow Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference

[Missing <param name="reference"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..GetProperty Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..GetRealType Method
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..GetRectangle Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..Highlight Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..InvokeMethod Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..IsHitTest Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..NextSibling Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..Parent Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..PreviousSibling Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..ScrollToVisible Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..SetProperty Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Properties
DataGridRow Class See Also Send Feedback

The DataGridRow type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationIndex |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CellElements | Get the cells inside this row.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | DataGridCellsPresenter | Get the DataGridRow cells presenter element. Please override for custom control template.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DetailsVisibility |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEditing |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RowData | Gets all the text contained in the cells as an array of strings for this row.
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlternationIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..AlternationIndex Property
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.AlternationIndex"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AlternationIndex { get; set; }
Visual Basic
Public Property AlternationIndex As Integer
    Get
    Set
Visual C++
public:
property int AlternationIndex {
    int get ();
    void set (int value);
}

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CellElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..CellElements Property
DataGridRow Class See Also Send Feedback
Get the cells inside this row.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<IDataGridCell> CellElements { get; }
Visual Basic
Public ReadOnly Property CellElements As IList(Of IDataGridCell)
    Get
Visual C++
public:
virtual property IList<IDataGridCell^>^ CellElements {
    IList<IDataGridCell^>^ get () sealed;
}

Implements

IDataGridRow..::..CellElements

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridCellsPresenter Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..DataGridCellsPresenter Property
DataGridRow Class See Also Send Feedback
Get the DataGridRow cells presenter element. Please override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement DataGridCellsPresenter { get; }
Visual Basic
Public Overridable ReadOnly Property DataGridCellsPresenter As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ DataGridCellsPresenter {
    FrameworkElement^ get ();
}

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DetailsVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..DetailsVisibility Property
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.DetailsVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility DetailsVisibility { get; set; }
Visual Basic
Public Property DetailsVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility DetailsVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEditing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..IsEditing Property
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.IsEditing"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEditing { get; set; }
Visual Basic
Public Property IsEditing As Boolean
    Get
    Set
Visual C++
public:
property bool IsEditing {
    bool get ();
    void set (bool value);
}

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..IsSelected Property
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRow.IsSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowData Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..RowData Property
DataGridRow Class See Also Send Feedback
Gets all the text contained in the cells as an array of strings for this row.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string[] RowData { get; }
Visual Basic
Public ReadOnly Property RowData As String()
    Get
Visual C++
public:
virtual property array<String^>^ RowData {
    array<String^>^ get () sealed;
}

Field Value

The row data.

Implements

IDataGridRow..::..RowData

See Also

DataGridRow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Members
DataGridRowHeader Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridRowHeader type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridRowHeader | Initializes a new instance of the DataGridRowHeader class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsRowSelectedProperty |
SeparatorBrushProperty |
SeparatorVisibilityProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsRowSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowHeader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Constructor
DataGridRowHeader Class See Also Send Feedback
Initializes a new instance of the DataGridRowHeader class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRowHeader()
Visual Basic
Public Sub New
Visual C++
public:
DataGridRowHeader()

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowHeader Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Fields
DataGridRowHeader Class See Also Send Feedback

The DataGridRowHeader type exposes the following members.

Fields

Name | Description
IsRowSelectedProperty |
SeparatorBrushProperty |
SeparatorVisibilityProperty |

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsRowSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..IsRowSelectedProperty Field
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowHeader.IsRowSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsRowSelectedProperty
Visual Basic
Public Shared IsRowSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsRowSelectedProperty

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SeparatorBrushProperty Field
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowHeader.SeparatorBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorBrushProperty
Visual Basic
Public Shared SeparatorBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorBrushProperty

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SeparatorVisibilityProperty Field
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowHeader.SeparatorVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorVisibilityProperty
Visual Basic
Public Shared SeparatorVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorVisibilityProperty

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Methods
DataGridRowHeader Class See Also Send Feedback

The DataGridRowHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..AnySibling Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..GetProperty Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..GetRealType Method
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowHeader.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowHeader.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..GetRectangle Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..Highlight Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..InvokeMethod Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..IsHitTest Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..NextSibling Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..Parent Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..PreviousSibling Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..ScrollToVisible Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SetProperty Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Properties
DataGridRowHeader Class See Also Send Feedback

The DataGridRowHeader type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsRowSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsRowSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..IsRowSelected Property
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowHeader.IsRowSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsRowSelected { get; set; }
Visual Basic
Public Property IsRowSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsRowSelected {
    bool get ();
    void set (bool value);
}

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SeparatorBrush Property
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowHeader.SeparatorBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush SeparatorBrush { get; set; }
Visual Basic
Public Property SeparatorBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SeparatorBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SeparatorVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SeparatorVisibility Property
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowHeader.SeparatorVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility SeparatorVisibility { get; set; }
Visual Basic
Public Property SeparatorVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility SeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowsPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter Members
DataGridRowsPresenter Class Constructors Methods Properties See Also Send Feedback

The DataGridRowsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridRowsPresenter | Initializes a new instance of the DataGridRowsPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides VirtualizingStackPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetVerticalOffset | Set the vertical offset. (Inherited from VirtualizingStackPanel.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation | (Inherited from VirtualizingStackPanel.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Get the vertical offset. (Inherited from VirtualizingStackPanel.)
Public property | ViewportOffset | Get the viewport offset. (Inherited from VirtualizingStackPanel.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowsPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter Constructor
DataGridRowsPresenter Class See Also Send Feedback
Initializes a new instance of the DataGridRowsPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRowsPresenter()
Visual Basic
Public Sub New
Visual C++
public:
DataGridRowsPresenter()

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowsPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter Methods
DataGridRowsPresenter Class See Also Send Feedback

The DataGridRowsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides VirtualizingStackPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetVerticalOffset | Set the vertical offset. (Inherited from VirtualizingStackPanel.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..AnySibling Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..GetProperty Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..GetRealType Method
DataGridRowsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowsPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DataGridRowsPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..GetRectangle Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..Highlight Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..InvokeMethod Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..IsHitTest Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..NextSibling Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..Parent Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..PreviousSibling Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..ScrollToVisible Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..SetProperty Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataGridRowsPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter Properties
DataGridRowsPresenter Class See Also Send Feedback

The DataGridRowsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation | (Inherited from VirtualizingStackPanel.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Get the vertical offset. (Inherited from VirtualizingStackPanel.)
Public property | ViewportOffset | Get the viewport offset. (Inherited from VirtualizingStackPanel.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Members
DatePicker Class Constructors Methods Fields Properties See Also Send Feedback

The DatePicker type exposes the following members.

Constructors

 | Name | Description
Public method | DatePicker | Initializes a new instance of the DatePicker class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | OpenCalendarPopup | Open the picker calendar popup.
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets new text into the date picker text box.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DisplayDateEndProperty |
DisplayDateProperty |
DisplayDateStartProperty |
FirstDayOfWeekProperty |
IsDropDownOpenProperty |
IsTodayHighlightedProperty |
SelectedDateFormatProperty |
SelectedDateProperty |
TextProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayDate |
Public property | DisplayDateEnd |
Public property | DisplayDateStart |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstDayOfWeek |
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTodayHighlighted |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PickerTextBox | Get the picker text box element. Override for custom control template.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedDate |
Public property | SelectedDateFormat |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TogglePopupButton | Get the picker toggle popup button element. Override for custom control template.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePicker Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Constructor
DatePicker Class See Also Send Feedback
Initializes a new instance of the DatePicker class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DatePicker()
Visual Basic
Public Sub New
Visual C++
public:
DatePicker()

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePicker Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Fields
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Fields

Name | Description
DisplayDateEndProperty |
DisplayDateProperty |
DisplayDateStartProperty |
FirstDayOfWeekProperty |
IsDropDownOpenProperty |
IsTodayHighlightedProperty |
SelectedDateFormatProperty |
SelectedDateProperty |
TextProperty |

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateEndProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateEndProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.DisplayDateEndProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateEndProperty
Visual Basic
Public Shared DisplayDateEndProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateEndProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.DisplayDateProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateProperty
Visual Basic
Public Shared DisplayDateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateStartProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateStartProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.DisplayDateStartProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateStartProperty
Visual Basic
Public Shared DisplayDateStartProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateStartProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FirstDayOfWeekProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..FirstDayOfWeekProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.FirstDayOfWeekProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FirstDayOfWeekProperty
Visual Basic
Public Shared FirstDayOfWeekProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FirstDayOfWeekProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDropDownOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsDropDownOpenProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.IsDropDownOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDropDownOpenProperty
Visual Basic
Public Shared IsDropDownOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDropDownOpenProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTodayHighlightedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsTodayHighlightedProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.IsTodayHighlightedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTodayHighlightedProperty
Visual Basic
Public Shared IsTodayHighlightedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTodayHighlightedProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedDateFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectedDateFormatProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.SelectedDateFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedDateFormatProperty
Visual Basic
Public Shared SelectedDateFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedDateFormatProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedDateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectedDateProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.SelectedDateProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedDateProperty
Visual Basic
Public Shared SelectedDateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedDateProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..TextProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.TextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Methods
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | OpenCalendarPopup | Open the picker calendar popup.
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets new text into the date picker text box.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..AnySibling Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..GetProperty Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..GetRealType Method
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..GetRectangle Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..Highlight Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..InvokeMethod Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsHitTest Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..NextSibling Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OpenCalendarPopup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..OpenCalendarPopup Method
DatePicker Class See Also Send Feedback
Open the picker calendar popup.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void OpenCalendarPopup(
    bool simulateRealUser
)
Visual Basic
Public Sub OpenCalendarPopup ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void OpenCalendarPopup(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
True to find the button and click on it, false to change the state via automation property.

Implements

IDatePicker..::..OpenCalendarPopup(Boolean)

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..Parent Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..PreviousSibling Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..ScrollToVisible Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SetProperty Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SetText Method
DatePicker Class See Also Send Feedback
Sets new text into the date picker text box.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
virtual void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate typing into the text box or just replace its text.
text
Type: System..::..String
The text to type or set.
keyPressTime
Type: System..::..Int32
The delay between each press when typing.
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key when typing.

Implements

IDatePicker..::..SetText(Boolean, String, Int32, Int32)

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Properties
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayDate |
Public property | DisplayDateEnd |
Public property | DisplayDateStart |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstDayOfWeek |
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTodayHighlighted |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PickerTextBox | Get the picker text box element. Override for custom control template.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedDate |
Public property | SelectedDateFormat |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TogglePopupButton | Get the picker toggle popup button element. Override for custom control template.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDate Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.DisplayDate"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime DisplayDate { get; set; }
Visual Basic
Public Property DisplayDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime DisplayDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateEnd Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateEnd Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.DisplayDateEnd"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> DisplayDateEnd { get; set; }
Visual Basic
Public Property DisplayDateEnd As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DisplayDateEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayDateStart Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateStart Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.DisplayDateStart"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> DisplayDateStart { get; set; }
Visual Basic
Public Property DisplayDateStart As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DisplayDateStart {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FirstDayOfWeek Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..FirstDayOfWeek Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.FirstDayOfWeek"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DayOfWeek FirstDayOfWeek { get; set; }
Visual Basic
Public Property FirstDayOfWeek As DayOfWeek
    Get
    Set
Visual C++
public:
property DayOfWeek FirstDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDropDownOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsDropDownOpen Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.IsDropDownOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic
Public Property IsDropDownOpen As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsDropDownOpen {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IDatePicker..::..IsDropDownOpen

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTodayHighlighted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsTodayHighlighted Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.IsTodayHighlighted"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTodayHighlighted { get; set; }
Visual Basic
Public Property IsTodayHighlighted As Boolean
    Get
    Set
Visual C++
public:
property bool IsTodayHighlighted {
    bool get ();
    void set (bool value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PickerTextBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..PickerTextBox Property
DatePicker Class See Also Send Feedback
Get the picker text box element. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IDatePickerTextBox PickerTextBox { get; }
Visual Basic
Public Overridable ReadOnly Property PickerTextBox As IDatePickerTextBox
    Get
Visual C++
public:
virtual property IDatePickerTextBox^ PickerTextBox {
    IDatePickerTextBox^ get ();
}

Implements

IDatePicker..::..PickerTextBox

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectedDate Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.SelectedDate"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> SelectedDate { get; set; }
Visual Basic
Public Property SelectedDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Implements

IDatePicker..::..SelectedDate

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedDateFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectedDateFormat Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.SelectedDateFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DatePickerFormat SelectedDateFormat { get; set; }
Visual Basic
Public Property SelectedDateFormat As DatePickerFormat
    Get
    Set
Visual C++
public:
property DatePickerFormat SelectedDateFormat {
    DatePickerFormat get ();
    void set (DatePickerFormat value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..Text Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePicker.Text"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFrameworkElement..::..Text

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TogglePopupButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..TogglePopupButton Property
DatePicker Class See Also Send Feedback
Get the picker toggle popup button element. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IButton TogglePopupButton { get; }
Visual Basic
Public Overridable ReadOnly Property TogglePopupButton As IButton
    Get
Visual C++
public:
virtual property IButton^ TogglePopupButton {
    IButton^ get ();
}

Implements

IDatePicker..::..TogglePopupButton

See Also

DatePicker Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePickerTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Members
DatePickerTextBox Class Constructors Methods Properties See Also Send Feedback

The DatePickerTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | DatePickerTextBox | Initializes a new instance of the DatePickerTextBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides TextBox..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox. (Inherited from TextBox.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn | (Inherited from TextBoxBase.)
Public property | AcceptsTab | (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoWordSelection | (Inherited from TextBoxBase.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CharacterCasing | (Inherited from TextBox.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly | (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsUndoEnabled | (Inherited from TextBoxBase.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength | (Inherited from TextBox.)
Public property | MaxLines | (Inherited from TextBox.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinLines | (Inherited from TextBox.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | (Inherited from TextBox.)
Public property | TextAlignment | (Inherited from TextBox.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping | (Inherited from TextBox.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UndoLimit | (Inherited from TextBoxBase.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePickerTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Constructor
DatePickerTextBox Class See Also Send Feedback
Initializes a new instance of the DatePickerTextBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DatePickerTextBox()
Visual Basic
Public Sub New
Visual C++
public:
DatePickerTextBox()

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePickerTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Methods
DatePickerTextBox Class See Also Send Feedback

The DatePickerTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides TextBox..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox. (Inherited from TextBox.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..AnySibling Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..GetProperty Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..GetRealType Method
DatePickerTextBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePickerTextBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DatePickerTextBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..GetRectangle Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..Highlight Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..InvokeMethod Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..IsHitTest Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..NextSibling Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..Parent Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..PreviousSibling Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..ScrollToVisible Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..SetProperty Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DatePickerTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Properties
DatePickerTextBox Class See Also Send Feedback

The DatePickerTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn | (Inherited from TextBoxBase.)
Public property | AcceptsTab | (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoWordSelection | (Inherited from TextBoxBase.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CharacterCasing | (Inherited from TextBox.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly | (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsUndoEnabled | (Inherited from TextBoxBase.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength | (Inherited from TextBox.)
Public property | MaxLines | (Inherited from TextBox.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinLines | (Inherited from TextBox.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | (Inherited from TextBox.)
Public property | TextAlignment | (Inherited from TextBox.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping | (Inherited from TextBox.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UndoLimit | (Inherited from TextBoxBase.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Decorator Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator Members
Decorator Class Constructors Methods Properties See Also Send Feedback

The Decorator type exposes the following members.

Constructors

 | Name | Description
Public method | Decorator | Initializes a new instance of the Decorator class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Decorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Decorator Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator Constructor
Decorator Class See Also Send Feedback
Initializes a new instance of the Decorator class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Decorator()
Visual Basic
Public Sub New
Visual C++
public:
Decorator()

See Also

Decorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Decorator Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator Methods
Decorator Class See Also Send Feedback

The Decorator type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Decorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..AnySibling Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..GetProperty Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..GetRealType Method
Decorator Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Decorator.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Decorator.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Decorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..GetRectangle Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..Highlight Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..InvokeMethod Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..IsHitTest Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..NextSibling Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..Parent Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..PreviousSibling Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..ScrollToVisible Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator..::..SetProperty Method
Decorator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Decorator Class
Decorator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Decorator Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Decorator Properties
Decorator Class See Also Send Feedback

The Decorator type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Decorator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DockPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel Members
DockPanel Class Constructors Methods Fields Properties See Also Send Feedback

The DockPanel type exposes the following members.

Constructors

 | Name | Description
Public method | DockPanel | Initializes a new instance of the DockPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
LastChildFillProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LastChildFill |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DockPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DockPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel Constructor
DockPanel Class See Also Send Feedback
Initializes a new instance of the DockPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DockPanel()
Visual Basic
Public Sub New
Visual C++
public:
DockPanel()

See Also

DockPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DockPanel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel Fields
DockPanel Class See Also Send Feedback

The DockPanel type exposes the following members.

Fields

Name | Description
LastChildFillProperty |

See Also

DockPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LastChildFillProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..LastChildFillProperty Field
DockPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DockPanel.LastChildFillProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LastChildFillProperty
Visual Basic
Public Shared LastChildFillProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LastChildFillProperty

See Also

DockPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DockPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel Methods
DockPanel Class See Also Send Feedback

The DockPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DockPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..AnySibling Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..GetProperty Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..GetRealType Method
DockPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DockPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DockPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DockPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..GetRectangle Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..Highlight Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..InvokeMethod Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..IsHitTest Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..NextSibling Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..Parent Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..PreviousSibling Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..ScrollToVisible Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..SetProperty Method
DockPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DockPanel Class
DockPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DockPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel Properties
DockPanel Class See Also Send Feedback

The DockPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LastChildFill |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DockPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LastChildFill Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockPanel..::..LastChildFill Property
DockPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DockPanel.LastChildFill"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool LastChildFill { get; set; }
Visual Basic
Public Property LastChildFill As Boolean
    Get
    Set
Visual C++
public:
property bool LastChildFill {
    bool get ();
    void set (bool value);
}

See Also

DockPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentPageView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView Members
DocumentPageView Class Constructors Methods Fields Properties See Also Send Feedback

The DocumentPageView type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentPageView | Initializes a new instance of the DocumentPageView class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
PageNumberProperty |
StretchDirectionProperty |
StretchProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | PageNumber |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentPageView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView Constructor
DocumentPageView Class See Also Send Feedback
Initializes a new instance of the DocumentPageView class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DocumentPageView()
Visual Basic
Public Sub New
Visual C++
public:
DocumentPageView()

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentPageView Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView Fields
DocumentPageView Class See Also Send Feedback

The DocumentPageView type exposes the following members.

Fields

Name | Description
PageNumberProperty |
StretchDirectionProperty |
StretchProperty |

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageNumberProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..PageNumberProperty Field
DocumentPageView Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentPageView.PageNumberProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageNumberProperty
Visual Basic
Public Shared PageNumberProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageNumberProperty

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..StretchDirectionProperty Field
DocumentPageView Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentPageView.StretchDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchDirectionProperty
Visual Basic
Public Shared StretchDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchDirectionProperty

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..StretchProperty Field
DocumentPageView Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentPageView.StretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentPageView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView Methods
DocumentPageView Class See Also Send Feedback

The DocumentPageView type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..AnySibling Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..GetProperty Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..GetRealType Method
DocumentPageView Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentPageView.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentPageView.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..GetRectangle Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..Highlight Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..InvokeMethod Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..IsHitTest Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..NextSibling Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..Parent Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..PreviousSibling Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..ScrollToVisible Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..SetProperty Method
DocumentPageView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentPageView Class
DocumentPageView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentPageView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView Properties
DocumentPageView Class See Also Send Feedback

The DocumentPageView type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | PageNumber |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageNumber Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..PageNumber Property
DocumentPageView Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentPageView.PageNumber"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Set
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Stretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..Stretch Property
DocumentPageView Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentPageView.Stretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Stretch Stretch { get; set; }
Visual Basic
Public Property Stretch As Stretch
    Get
    Set
Visual C++
public:
property Stretch Stretch {
    Stretch get ();
    void set (Stretch value);
}

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentPageView..::..StretchDirection Property
DocumentPageView Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentPageView.StretchDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StretchDirection StretchDirection { get; set; }
Visual Basic
Public Property StretchDirection As StretchDirection
    Get
    Set
Visual C++
public:
property StretchDirection StretchDirection {
    StretchDirection get ();
    void set (StretchDirection value);
}

See Also

DocumentPageView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentReference Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference Members
DocumentReference Class Constructors Methods Fields Properties See Also Send Feedback

The DocumentReference type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentReference | Initializes a new instance of the DocumentReference class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SourceProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DocumentReference Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentReference Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference Constructor
DocumentReference Class See Also Send Feedback
Initializes a new instance of the DocumentReference class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DocumentReference()
Visual Basic
Public Sub New
Visual C++
public:
DocumentReference()

See Also

DocumentReference Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentReference Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference Fields
DocumentReference Class See Also Send Feedback

The DocumentReference type exposes the following members.

Fields

Name | Description
SourceProperty |

See Also

DocumentReference Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..SourceProperty Field
DocumentReference Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentReference.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

DocumentReference Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentReference Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference Methods
DocumentReference Class See Also Send Feedback

The DocumentReference type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DocumentReference Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..AnySibling Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..GetProperty Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..GetRealType Method
DocumentReference Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentReference.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentReference.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DocumentReference Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..GetRectangle Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..Highlight Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..InvokeMethod Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..IsHitTest Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..NextSibling Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..Parent Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..PreviousSibling Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..ScrollToVisible Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..SetProperty Method
DocumentReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentReference Class
DocumentReference Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentReference Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference Properties
DocumentReference Class See Also Send Feedback

The DocumentReference type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DocumentReference Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentReference..::..Source Property
DocumentReference Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentReference.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
Visual C++
public:
property String^ Source {
    String^ get ();
}

See Also

DocumentReference Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer Members
DocumentViewer Class Constructors Methods Fields Properties See Also Send Feedback

The DocumentViewer type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentViewer | Initializes a new instance of the DocumentViewer class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides DocumentViewerBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanDecreaseZoomProperty |
CanIncreaseZoomProperty |
CanMoveDownProperty |
CanMoveLeftProperty |
CanMoveRightProperty |
CanMoveUpProperty |
ExtentHeightProperty |
ExtentWidthProperty |
HorizontalOffsetProperty |
HorizontalPageSpacingProperty |
MaxPagesAcrossProperty |
ShowPageBordersProperty |
VerticalOffsetProperty |
VerticalPageSpacingProperty |
ViewportHeightProperty |
ViewportWidthProperty |
ZoomProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanDecreaseZoom |
Public property | CanGoToNextPage | (Inherited from DocumentViewerBase.)
Public property | CanGoToPreviousPage | (Inherited from DocumentViewerBase.)
Public property | CanIncreaseZoom |
Public property | CanMoveDown |
Public property | CanMoveLeft |
Public property | CanMoveRight |
Public property | CanMoveUp |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExtentHeight |
Public property | ExtentWidth |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | HorizontalPageSpacing |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MasterPageNumber | (Inherited from DocumentViewerBase.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxPagesAcross |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount | (Inherited from DocumentViewerBase.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowPageBorders |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | VerticalPageSpacing |
Public property | ViewportHeight |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Zoom |

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer Constructor
DocumentViewer Class See Also Send Feedback
Initializes a new instance of the DocumentViewer class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DocumentViewer()
Visual Basic
Public Sub New
Visual C++
public:
DocumentViewer()

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewer Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer Fields
DocumentViewer Class See Also Send Feedback

The DocumentViewer type exposes the following members.

Fields

Name | Description
CanDecreaseZoomProperty |
CanIncreaseZoomProperty |
CanMoveDownProperty |
CanMoveLeftProperty |
CanMoveRightProperty |
CanMoveUpProperty |
ExtentHeightProperty |
ExtentWidthProperty |
HorizontalOffsetProperty |
HorizontalPageSpacingProperty |
MaxPagesAcrossProperty |
ShowPageBordersProperty |
VerticalOffsetProperty |
VerticalPageSpacingProperty |
ViewportHeightProperty |
ViewportWidthProperty |
ZoomProperty |

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanDecreaseZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanDecreaseZoomProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanDecreaseZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanDecreaseZoomProperty
Visual Basic
Public Shared CanDecreaseZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanDecreaseZoomProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanIncreaseZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanIncreaseZoomProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanIncreaseZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanIncreaseZoomProperty
Visual Basic
Public Shared CanIncreaseZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanIncreaseZoomProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanMoveDownProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanMoveDownProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanMoveDownProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanMoveDownProperty
Visual Basic
Public Shared CanMoveDownProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanMoveDownProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanMoveLeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanMoveLeftProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanMoveLeftProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanMoveLeftProperty
Visual Basic
Public Shared CanMoveLeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanMoveLeftProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanMoveRightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanMoveRightProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanMoveRightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanMoveRightProperty
Visual Basic
Public Shared CanMoveRightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanMoveRightProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanMoveUpProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanMoveUpProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanMoveUpProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanMoveUpProperty
Visual Basic
Public Shared CanMoveUpProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanMoveUpProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExtentHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ExtentHeightProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ExtentHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExtentHeightProperty
Visual Basic
Public Shared ExtentHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExtentHeightProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExtentWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ExtentWidthProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ExtentWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExtentWidthProperty
Visual Basic
Public Shared ExtentWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExtentWidthProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..HorizontalOffsetProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalPageSpacingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..HorizontalPageSpacingProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.HorizontalPageSpacingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalPageSpacingProperty
Visual Basic
Public Shared HorizontalPageSpacingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalPageSpacingProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxPagesAcrossProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..MaxPagesAcrossProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.MaxPagesAcrossProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxPagesAcrossProperty
Visual Basic
Public Shared MaxPagesAcrossProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxPagesAcrossProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowPageBordersProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ShowPageBordersProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ShowPageBordersProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ShowPageBordersProperty
Visual Basic
Public Shared ShowPageBordersProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ShowPageBordersProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..VerticalOffsetProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalPageSpacingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..VerticalPageSpacingProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.VerticalPageSpacingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalPageSpacingProperty
Visual Basic
Public Shared VerticalPageSpacingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalPageSpacingProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ViewportHeightProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ViewportHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportHeightProperty
Visual Basic
Public Shared ViewportHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportHeightProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ViewportWidthProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ViewportWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportWidthProperty
Visual Basic
Public Shared ViewportWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportWidthProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ZoomProperty Field
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZoomProperty
Visual Basic
Public Shared ZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZoomProperty

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer Methods
DocumentViewer Class See Also Send Feedback

The DocumentViewer type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides DocumentViewerBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..AnySibling Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..GetProperty Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..GetRealType Method
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..GetRectangle Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..Highlight Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..InvokeMethod Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..IsHitTest Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..NextSibling Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..Parent Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..PreviousSibling Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ScrollToVisible Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..SetProperty Method
DocumentViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentViewer Class
DocumentViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer Properties
DocumentViewer Class See Also Send Feedback

The DocumentViewer type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanDecreaseZoom |
Public property | CanGoToNextPage | (Inherited from DocumentViewerBase.)
Public property | CanGoToPreviousPage | (Inherited from DocumentViewerBase.)
Public property | CanIncreaseZoom |
Public property | CanMoveDown |
Public property | CanMoveLeft |
Public property | CanMoveRight |
Public property | CanMoveUp |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExtentHeight |
Public property | ExtentWidth |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | HorizontalPageSpacing |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MasterPageNumber | (Inherited from DocumentViewerBase.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxPagesAcross |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount | (Inherited from DocumentViewerBase.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowPageBorders |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | VerticalPageSpacing |
Public property | ViewportHeight |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Zoom |

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanDecreaseZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanDecreaseZoom Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanDecreaseZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanDecreaseZoom { get; set; }
Visual Basic
Public Property CanDecreaseZoom As Boolean
    Get
    Set
Visual C++
public:
property bool CanDecreaseZoom {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanIncreaseZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanIncreaseZoom Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanIncreaseZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanIncreaseZoom { get; set; }
Visual Basic
Public Property CanIncreaseZoom As Boolean
    Get
    Set
Visual C++
public:
property bool CanIncreaseZoom {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanMoveDown Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanMoveDown Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanMoveDown"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanMoveDown { get; set; }
Visual Basic
Public Property CanMoveDown As Boolean
    Get
    Set
Visual C++
public:
property bool CanMoveDown {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanMoveLeft Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanMoveLeft Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanMoveLeft"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanMoveLeft { get; set; }
Visual Basic
Public Property CanMoveLeft As Boolean
    Get
    Set
Visual C++
public:
property bool CanMoveLeft {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanMoveRight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanMoveRight Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanMoveRight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanMoveRight { get; set; }
Visual Basic
Public Property CanMoveRight As Boolean
    Get
    Set
Visual C++
public:
property bool CanMoveRight {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanMoveUp Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..CanMoveUp Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.CanMoveUp"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanMoveUp { get; set; }
Visual Basic
Public Property CanMoveUp As Boolean
    Get
    Set
Visual C++
public:
property bool CanMoveUp {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExtentHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ExtentHeight Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ExtentHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ExtentHeight { get; set; }
Visual Basic
Public Property ExtentHeight As Double
    Get
    Set
Visual C++
public:
property double ExtentHeight {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExtentWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ExtentWidth Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ExtentWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ExtentWidth { get; set; }
Visual Basic
Public Property ExtentWidth As Double
    Get
    Set
Visual C++
public:
property double ExtentWidth {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..HorizontalOffset Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.HorizontalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic
Public Property HorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalPageSpacing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..HorizontalPageSpacing Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.HorizontalPageSpacing"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double HorizontalPageSpacing { get; set; }
Visual Basic
Public Property HorizontalPageSpacing As Double
    Get
    Set
Visual C++
public:
property double HorizontalPageSpacing {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxPagesAcross Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..MaxPagesAcross Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.MaxPagesAcross"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MaxPagesAcross { get; set; }
Visual Basic
Public Property MaxPagesAcross As Integer
    Get
    Set
Visual C++
public:
property int MaxPagesAcross {
    int get ();
    void set (int value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowPageBorders Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ShowPageBorders Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ShowPageBorders"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowPageBorders { get; set; }
Visual Basic
Public Property ShowPageBorders As Boolean
    Get
    Set
Visual C++
public:
property bool ShowPageBorders {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..VerticalOffset Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.VerticalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic
Public Property VerticalOffset As Double
    Get
    Set
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalPageSpacing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..VerticalPageSpacing Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.VerticalPageSpacing"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double VerticalPageSpacing { get; set; }
Visual Basic
Public Property VerticalPageSpacing As Double
    Get
    Set
Visual C++
public:
property double VerticalPageSpacing {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ViewportHeight Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ViewportHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ViewportHeight { get; set; }
Visual Basic
Public Property ViewportHeight As Double
    Get
    Set
Visual C++
public:
property double ViewportHeight {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..ViewportWidth Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.ViewportWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ViewportWidth { get; set; }
Visual Basic
Public Property ViewportWidth As Double
    Get
    Set
Visual C++
public:
property double ViewportWidth {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Zoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewer..::..Zoom Property
DocumentViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewer.Zoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Zoom { get; set; }
Visual Basic
Public Property Zoom As Double
    Get
    Set
Visual C++
public:
property double Zoom {
    double get ();
    void set (double value);
}

See Also

DocumentViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewerBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase Members
DocumentViewerBase Class Constructors Methods Fields Properties See Also Send Feedback

The DocumentViewerBase type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentViewerBase | Initializes a new instance of the DocumentViewerBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanGoToNextPageProperty |
CanGoToPreviousPageProperty |
MasterPageNumberProperty |
PageCountProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanGoToNextPage |
Public property | CanGoToPreviousPage |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MasterPageNumber |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewerBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase Constructor
DocumentViewerBase Class See Also Send Feedback
Initializes a new instance of the DocumentViewerBase class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DocumentViewerBase()
Visual Basic
Public Sub New
Visual C++
public:
DocumentViewerBase()

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewerBase Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase Fields
DocumentViewerBase Class See Also Send Feedback

The DocumentViewerBase type exposes the following members.

Fields

Name | Description
CanGoToNextPageProperty |
CanGoToPreviousPageProperty |
MasterPageNumberProperty |
PageCountProperty |

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoToNextPageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..CanGoToNextPageProperty Field
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.CanGoToNextPageProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoToNextPageProperty
Visual Basic
Public Shared CanGoToNextPageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoToNextPageProperty

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoToPreviousPageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..CanGoToPreviousPageProperty Field
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.CanGoToPreviousPageProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoToPreviousPageProperty
Visual Basic
Public Shared CanGoToPreviousPageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoToPreviousPageProperty

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MasterPageNumberProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..MasterPageNumberProperty Field
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.MasterPageNumberProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MasterPageNumberProperty
Visual Basic
Public Shared MasterPageNumberProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MasterPageNumberProperty

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..PageCountProperty Field
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.PageCountProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageCountProperty
Visual Basic
Public Shared PageCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageCountProperty

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewerBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase Methods
DocumentViewerBase Class See Also Send Feedback

The DocumentViewerBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..AnySibling Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..GetProperty Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..GetRealType Method
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..GetRectangle Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..Highlight Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..InvokeMethod Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..IsHitTest Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..NextSibling Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..Parent Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..PreviousSibling Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..ScrollToVisible Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..SetProperty Method
DocumentViewerBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DocumentViewerBase Class
DocumentViewerBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentViewerBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase Properties
DocumentViewerBase Class See Also Send Feedback

The DocumentViewerBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanGoToNextPage |
Public property | CanGoToPreviousPage |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MasterPageNumber |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoToNextPage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..CanGoToNextPage Property
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.CanGoToNextPage"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoToNextPage { get; set; }
Visual Basic
Public Property CanGoToNextPage As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoToNextPage {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoToPreviousPage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..CanGoToPreviousPage Property
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.CanGoToPreviousPage"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoToPreviousPage { get; set; }
Visual Basic
Public Property CanGoToPreviousPage As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoToPreviousPage {
    bool get ();
    void set (bool value);
}

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MasterPageNumber Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..MasterPageNumber Property
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.MasterPageNumber"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MasterPageNumber { get; set; }
Visual Basic
Public Property MasterPageNumber As Integer
    Get
    Set
Visual C++
public:
property int MasterPageNumber {
    int get ();
    void set (int value);
}

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DocumentViewerBase..::..PageCount Property
DocumentViewerBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DocumentViewerBase.PageCount"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PageCount { get; set; }
Visual Basic
Public Property PageCount As Integer
    Get
    Set
Visual C++
public:
property int PageCount {
    int get ();
    void set (int value);
}

See Also

DocumentViewerBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Drawing Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Drawing Members
Drawing Class Constructors Methods Properties See Also Send Feedback

The Drawing type exposes the following members.

Constructors

 | Name | Description
Public method | Drawing | Initializes a new instance of the Drawing class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Drawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Drawing Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Drawing Constructor
Drawing Class See Also Send Feedback
Initializes a new instance of the Drawing class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Drawing()
Visual Basic
Public Sub New
Visual C++
public:
Drawing()

See Also

Drawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Drawing Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Drawing Methods
Drawing Class See Also Send Feedback

The Drawing type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Drawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Drawing..::..GetProperty Method
Drawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Drawing Class
Drawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Drawing..::..GetRealType Method
Drawing Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Drawing.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Drawing.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Drawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Drawing..::..InvokeMethod Method
Drawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Drawing Class
Drawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Drawing Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Drawing Properties
Drawing Class See Also Send Feedback

The Drawing type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Drawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush Members
DrawingBrush Class Constructors Methods Fields Properties See Also Send Feedback

The DrawingBrush type exposes the following members.

Constructors

 | Name | Description
Public method | DrawingBrush | Initializes a new instance of the DrawingBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DrawingProperty |

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | Drawing |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch | (Inherited from TileBrush.)
Public property | TileMode | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)
Public property | Viewbox | (Inherited from TileBrush.)
Public property | ViewboxUnits | (Inherited from TileBrush.)
Public property | Viewport | (Inherited from TileBrush.)
Public property | ViewportUnits | (Inherited from TileBrush.)

See Also

DrawingBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush Constructor
DrawingBrush Class See Also Send Feedback
Initializes a new instance of the DrawingBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DrawingBrush()
Visual Basic
Public Sub New
Visual C++
public:
DrawingBrush()

See Also

DrawingBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush Fields
DrawingBrush Class See Also Send Feedback

The DrawingBrush type exposes the following members.

Fields

Name | Description
DrawingProperty |

See Also

DrawingBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush..::..DrawingProperty Field
DrawingBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DrawingBrush.DrawingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DrawingProperty
Visual Basic
Public Shared DrawingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DrawingProperty

See Also

DrawingBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush Methods
DrawingBrush Class See Also Send Feedback

The DrawingBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawingBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush..::..GetProperty Method
DrawingBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DrawingBrush Class
DrawingBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush..::..GetRealType Method
DrawingBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DrawingBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DrawingBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DrawingBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush..::..InvokeMethod Method
DrawingBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DrawingBrush Class
DrawingBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush Properties
DrawingBrush Class See Also Send Feedback

The DrawingBrush type exposes the following members.

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | Drawing |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch | (Inherited from TileBrush.)
Public property | TileMode | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)
Public property | Viewbox | (Inherited from TileBrush.)
Public property | ViewboxUnits | (Inherited from TileBrush.)
Public property | Viewport | (Inherited from TileBrush.)
Public property | ViewportUnits | (Inherited from TileBrush.)

See Also

DrawingBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Drawing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingBrush..::..Drawing Property
DrawingBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DrawingBrush.Drawing"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Drawing Drawing { get; set; }
Visual Basic
Public Property Drawing As Drawing
    Get
    Set
Visual C++
public:
property Drawing^ Drawing {
    Drawing^ get ();
    void set (Drawing^ value);
}

See Also

DrawingBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingImage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage Members
DrawingImage Class Constructors Methods Fields Properties See Also Send Feedback

The DrawingImage type exposes the following members.

Constructors

 | Name | Description
Public method | DrawingImage | Initializes a new instance of the DrawingImage class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ImageSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DrawingProperty |

Properties

 | Name | Description
Public property | Drawing |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DrawingImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingImage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage Constructor
DrawingImage Class See Also Send Feedback
Initializes a new instance of the DrawingImage class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DrawingImage()
Visual Basic
Public Sub New
Visual C++
public:
DrawingImage()

See Also

DrawingImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingImage Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage Fields
DrawingImage Class See Also Send Feedback

The DrawingImage type exposes the following members.

Fields

Name | Description
DrawingProperty |

See Also

DrawingImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage..::..DrawingProperty Field
DrawingImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.DrawingImage.DrawingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DrawingProperty
Visual Basic
Public Shared DrawingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DrawingProperty

See Also

DrawingImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingImage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage Methods
DrawingImage Class See Also Send Feedback

The DrawingImage type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ImageSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DrawingImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage..::..GetProperty Method
DrawingImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DrawingImage Class
DrawingImage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage..::..GetRealType Method
DrawingImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DrawingImage.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.DrawingImage.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DrawingImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage..::..InvokeMethod Method
DrawingImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DrawingImage Class
DrawingImage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DrawingImage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage Properties
DrawingImage Class See Also Send Feedback

The DrawingImage type exposes the following members.

Properties

 | Name | Description
Public property | Drawing |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DrawingImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Drawing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DrawingImage..::..Drawing Property
DrawingImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.DrawingImage.Drawing"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Drawing Drawing { get; set; }
Visual Basic
Public Property Drawing As Drawing
    Get
    Set
Visual C++
public:
property Drawing^ Drawing {
    Drawing^ get ();
    void set (Drawing^ value);
}

See Also

DrawingImage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Ellipse Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse Members
Ellipse Class Constructors Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

 | Name | Description
Public method | Ellipse | Initializes a new instance of the Ellipse class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Ellipse Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Ellipse Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse Constructor
Ellipse Class See Also Send Feedback
Initializes a new instance of the Ellipse class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Ellipse()
Visual Basic
Public Sub New
Visual C++
public:
Ellipse()

See Also

Ellipse Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Ellipse Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Ellipse Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..AnySibling Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..GetProperty Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..GetRealType Method
Ellipse Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Ellipse.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Ellipse.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Ellipse Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..GetRectangle Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..Highlight Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..InvokeMethod Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..IsHitTest Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..NextSibling Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..Parent Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..PreviousSibling Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..ScrollToVisible Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..SetProperty Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Ellipse Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Ellipse Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EllipseGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Members
EllipseGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The EllipseGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | EllipseGeometry | Initializes a new instance of the EllipseGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterProperty |
RadiusXProperty |
RadiusYProperty |

Properties

 | Name | Description
Public property | Center |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EllipseGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Constructor
EllipseGeometry Class See Also Send Feedback
Initializes a new instance of the EllipseGeometry class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public EllipseGeometry()
Visual Basic
Public Sub New
Visual C++
public:
EllipseGeometry()

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EllipseGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Fields
EllipseGeometry Class See Also Send Feedback

The EllipseGeometry type exposes the following members.

Fields

Name | Description
CenterProperty |
RadiusXProperty |
RadiusYProperty |

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..CenterProperty Field
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.EllipseGeometry.CenterProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterProperty
Visual Basic
Public Shared CenterProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterProperty

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..RadiusXProperty Field
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.EllipseGeometry.RadiusXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusXProperty
Visual Basic
Public Shared RadiusXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusXProperty

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..RadiusYProperty Field
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.EllipseGeometry.RadiusYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusYProperty
Visual Basic
Public Shared RadiusYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusYProperty

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EllipseGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Methods
EllipseGeometry Class See Also Send Feedback

The EllipseGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..GetProperty Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

EllipseGeometry Class
EllipseGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..GetRealType Method
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.EllipseGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.EllipseGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..InvokeMethod Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

EllipseGeometry Class
EllipseGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EllipseGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Properties
EllipseGeometry Class See Also Send Feedback

The EllipseGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Center |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Center Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..Center Property
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.EllipseGeometry.Center"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Center { get; set; }
Visual Basic
Public Property Center As Point
    Get
    Set
Visual C++
public:
property Point^ Center {
    Point^ get ();
    void set (Point^ value);
}

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..RadiusX Property
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.EllipseGeometry.RadiusX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Double
    Get
    Set
Visual C++
public:
property double RadiusX {
    double get ();
    void set (double value);
}

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..RadiusY Property
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.EllipseGeometry.RadiusY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Double
    Get
    Set
Visual C++
public:
property double RadiusY {
    double get ();
    void set (double value);
}

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandableContentControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl Members
ExpandableContentControl Class Constructors Methods Fields Properties See Also Send Feedback

The ExpandableContentControl type exposes the following members.

Constructors

 | Name | Description
Public method | ExpandableContentControl | Initializes a new instance of the ExpandableContentControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
PercentageProperty |
RevealModeProperty |
TargetSizeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Percentage |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RevealMode |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TargetSize |
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandableContentControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl Constructor
ExpandableContentControl Class See Also Send Feedback
Initializes a new instance of the ExpandableContentControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExpandableContentControl()
Visual Basic
Public Sub New
Visual C++
public:
ExpandableContentControl()

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandableContentControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl Fields
ExpandableContentControl Class See Also Send Feedback

The ExpandableContentControl type exposes the following members.

Fields

Name | Description
PercentageProperty |
RevealModeProperty |
TargetSizeProperty |

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PercentageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..PercentageProperty Field
ExpandableContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ExpandableContentControl.PercentageProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PercentageProperty
Visual Basic
Public Shared PercentageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PercentageProperty

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RevealModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..RevealModeProperty Field
ExpandableContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ExpandableContentControl.RevealModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RevealModeProperty
Visual Basic
Public Shared RevealModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RevealModeProperty

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TargetSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..TargetSizeProperty Field
ExpandableContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ExpandableContentControl.TargetSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TargetSizeProperty
Visual Basic
Public Shared TargetSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TargetSizeProperty

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandableContentControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl Methods
ExpandableContentControl Class See Also Send Feedback

The ExpandableContentControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..AnySibling Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..GetProperty Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..GetRealType Method
ExpandableContentControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ExpandableContentControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ExpandableContentControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..GetRectangle Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..Highlight Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..InvokeMethod Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..IsHitTest Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..NextSibling Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..Parent Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..PreviousSibling Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..ScrollToVisible Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..SetProperty Method
ExpandableContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ExpandableContentControl Class
ExpandableContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandableContentControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl Properties
ExpandableContentControl Class See Also Send Feedback

The ExpandableContentControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Percentage |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RevealMode |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TargetSize |
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Percentage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..Percentage Property
ExpandableContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ExpandableContentControl.Percentage"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Percentage { get; set; }
Visual Basic
Public Property Percentage As Double
    Get
    Set
Visual C++
public:
property double Percentage {
    double get ();
    void set (double value);
}

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RevealMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..RevealMode Property
ExpandableContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ExpandableContentControl.RevealMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExpandDirection RevealMode { get; set; }
Visual Basic
Public Property RevealMode As ExpandDirection
    Get
    Set
Visual C++
public:
property ExpandDirection RevealMode {
    ExpandDirection get ();
    void set (ExpandDirection value);
}

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TargetSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExpandableContentControl..::..TargetSize Property
ExpandableContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ExpandableContentControl.TargetSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Size TargetSize { get; set; }
Visual Basic
Public Property TargetSize As Size
    Get
    Set
Visual C++
public:
property Size^ TargetSize {
    Size^ get ();
    void set (Size^ value);
}

See Also

ExpandableContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Expander Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander Members
Expander Class Constructors Methods Fields Properties See Also Send Feedback

The Expander type exposes the following members.

Constructors

 | Name | Description
Public method | Expander | Initializes a new instance of the Expander class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ExpandDirectionProperty |
IsExpandedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExpandDirection |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader | (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsExpanded |
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Expander Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander Constructor
Expander Class See Also Send Feedback
Initializes a new instance of the Expander class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Expander()
Visual Basic
Public Sub New
Visual C++
public:
Expander()

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Expander Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander Fields
Expander Class See Also Send Feedback

The Expander type exposes the following members.

Fields

Name | Description
ExpandDirectionProperty |
IsExpandedProperty |

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..ExpandDirectionProperty Field
Expander Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Expander.ExpandDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExpandDirectionProperty
Visual Basic
Public Shared ExpandDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExpandDirectionProperty

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsExpandedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..IsExpandedProperty Field
Expander Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Expander.IsExpandedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsExpandedProperty
Visual Basic
Public Shared IsExpandedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsExpandedProperty

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Expander Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander Methods
Expander Class See Also Send Feedback

The Expander type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..AnySibling Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..GetProperty Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..GetRealType Method
Expander Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Expander.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Expander.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..GetRectangle Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..Highlight Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..InvokeMethod Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..IsHitTest Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..NextSibling Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..Parent Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..PreviousSibling Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..ScrollToVisible Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..SetProperty Method
Expander Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Expander Class
Expander Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Expander Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander Properties
Expander Class See Also Send Feedback

The Expander type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExpandDirection |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader | (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsExpanded |
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..ExpandDirection Property
Expander Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Expander.ExpandDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExpandDirection ExpandDirection { get; set; }
Visual Basic
Public Property ExpandDirection As ExpandDirection
    Get
    Set
Visual C++
public:
property ExpandDirection ExpandDirection {
    ExpandDirection get ();
    void set (ExpandDirection value);
}

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsExpanded Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Expander..::..IsExpanded Property
Expander Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Expander.IsExpanded"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic
Public Property IsExpanded As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

Expander Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FixedPage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage Members
FixedPage Class Constructors Methods Fields Properties See Also Send Feedback

The FixedPage type exposes the following members.

Constructors

 | Name | Description
Public method | FixedPage | Initializes a new instance of the FixedPage class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BleedBoxProperty |
ContentBoxProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BleedBox |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentBox |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FixedPage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage Constructor
FixedPage Class See Also Send Feedback
Initializes a new instance of the FixedPage class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FixedPage()
Visual Basic
Public Sub New
Visual C++
public:
FixedPage()

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FixedPage Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage Fields
FixedPage Class See Also Send Feedback

The FixedPage type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BleedBoxProperty |
ContentBoxProperty |

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..BackgroundProperty Field
FixedPage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FixedPage.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BleedBoxProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..BleedBoxProperty Field
FixedPage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FixedPage.BleedBoxProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BleedBoxProperty
Visual Basic
Public Shared BleedBoxProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BleedBoxProperty

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentBoxProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..ContentBoxProperty Field
FixedPage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FixedPage.ContentBoxProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentBoxProperty
Visual Basic
Public Shared ContentBoxProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentBoxProperty

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FixedPage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage Methods
FixedPage Class See Also Send Feedback

The FixedPage type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..AnySibling Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..GetProperty Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..GetRealType Method
FixedPage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FixedPage.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FixedPage.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..GetRectangle Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..Highlight Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..InvokeMethod Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..IsHitTest Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..NextSibling Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..Parent Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..PreviousSibling Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..ScrollToVisible Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..SetProperty Method
FixedPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FixedPage Class
FixedPage Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FixedPage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage Properties
FixedPage Class See Also Send Feedback

The FixedPage type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BleedBox |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentBox |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..Background Property
FixedPage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FixedPage.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BleedBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..BleedBox Property
FixedPage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FixedPage.BleedBox"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect BleedBox { get; set; }
Visual Basic
Public Property BleedBox As Rect
    Get
    Set
Visual C++
public:
property Rect^ BleedBox {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FixedPage..::..ContentBox Property
FixedPage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FixedPage.ContentBox"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect ContentBox { get; set; }
Visual Basic
Public Property ContentBox As Rect
    Get
    Set
Visual C++
public:
property Rect^ ContentBox {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

FixedPage Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocument Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument Members
FlowDocument Class Constructors Methods Fields Properties See Also Send Feedback

The FlowDocument type exposes the following members.

Constructors

 | Name | Description
Public method | FlowDocument | Initializes a new instance of the FlowDocument class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BackgroundProperty |
ColumnGapProperty |
ColumnRuleBrushProperty |
ColumnRuleWidthProperty |
ColumnWidthProperty |
FlowDirectionProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
IsColumnWidthFlexibleProperty |
IsHyphenationEnabledProperty |
IsOptimalParagraphEnabledProperty |
LineHeightProperty |
LineStackingStrategyProperty |
MaxPageHeightProperty |
MaxPageWidthProperty |
MinPageHeightProperty |
MinPageWidthProperty |
PageHeightProperty |
PagePaddingProperty |
PageWidthProperty |
TextAlignmentProperty |

Properties

 | Name | Description
Public property | Background |
Public property | ColumnGap |
Public property | ColumnRuleBrush |
Public property | ColumnRuleWidth |
Public property | ColumnWidth |
Public property | FlowDirection |
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | IsColumnWidthFlexible |
Public property | IsHyphenationEnabled |
Public property | IsOptimalParagraphEnabled |
Public property | LineHeight |
Public property | LineStackingStrategy |
Public property | MaxPageHeight |
Public property | MaxPageWidth |
Public property | MinPageHeight |
Public property | MinPageWidth |
Public property | PageHeight |
Public property | PagePadding |
Public property | PageWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | TextAlignment |

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocument Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument Constructor
FlowDocument Class See Also Send Feedback
Initializes a new instance of the FlowDocument class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDocument()
Visual Basic
Public Sub New
Visual C++
public:
FlowDocument()

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocument Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument Fields
FlowDocument Class See Also Send Feedback

The FlowDocument type exposes the following members.

Fields

Name | Description
BackgroundProperty |
ColumnGapProperty |
ColumnRuleBrushProperty |
ColumnRuleWidthProperty |
ColumnWidthProperty |
FlowDirectionProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
IsColumnWidthFlexibleProperty |
IsHyphenationEnabledProperty |
IsOptimalParagraphEnabledProperty |
LineHeightProperty |
LineStackingStrategyProperty |
MaxPageHeightProperty |
MaxPageWidthProperty |
MinPageHeightProperty |
MinPageWidthProperty |
PageHeightProperty |
PagePaddingProperty |
PageWidthProperty |
TextAlignmentProperty |

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..BackgroundProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnGapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ColumnGapProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ColumnGapProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnGapProperty
Visual Basic
Public Shared ColumnGapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnGapProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnRuleBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ColumnRuleBrushProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ColumnRuleBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnRuleBrushProperty
Visual Basic
Public Shared ColumnRuleBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnRuleBrushProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnRuleWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ColumnRuleWidthProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ColumnRuleWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnRuleWidthProperty
Visual Basic
Public Shared ColumnRuleWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnRuleWidthProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ColumnWidthProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ColumnWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnWidthProperty
Visual Basic
Public Shared ColumnWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnWidthProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FlowDirectionProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FlowDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FlowDirectionProperty
Visual Basic
Public Shared FlowDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FlowDirectionProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontFamilyProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontSizeProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontStretchProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontStretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStretchProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontStyleProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontStyleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStyleProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontWeightProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontWeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontWeightProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ForegroundProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsColumnWidthFlexibleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..IsColumnWidthFlexibleProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.IsColumnWidthFlexibleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsColumnWidthFlexibleProperty
Visual Basic
Public Shared IsColumnWidthFlexibleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsColumnWidthFlexibleProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHyphenationEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..IsHyphenationEnabledProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.IsHyphenationEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsHyphenationEnabledProperty
Visual Basic
Public Shared IsHyphenationEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsHyphenationEnabledProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOptimalParagraphEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..IsOptimalParagraphEnabledProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.IsOptimalParagraphEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsOptimalParagraphEnabledProperty
Visual Basic
Public Shared IsOptimalParagraphEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsOptimalParagraphEnabledProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..LineHeightProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.LineHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineHeightProperty
Visual Basic
Public Shared LineHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineHeightProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineStackingStrategyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..LineStackingStrategyProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.LineStackingStrategyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineStackingStrategyProperty
Visual Basic
Public Shared LineStackingStrategyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineStackingStrategyProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxPageHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..MaxPageHeightProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.MaxPageHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxPageHeightProperty
Visual Basic
Public Shared MaxPageHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxPageHeightProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxPageWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..MaxPageWidthProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.MaxPageWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxPageWidthProperty
Visual Basic
Public Shared MaxPageWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxPageWidthProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinPageHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..MinPageHeightProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.MinPageHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinPageHeightProperty
Visual Basic
Public Shared MinPageHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinPageHeightProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinPageWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..MinPageWidthProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.MinPageWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinPageWidthProperty
Visual Basic
Public Shared MinPageWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinPageWidthProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..PageHeightProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.PageHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageHeightProperty
Visual Basic
Public Shared PageHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageHeightProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PagePaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..PagePaddingProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.PagePaddingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PagePaddingProperty
Visual Basic
Public Shared PagePaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PagePaddingProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..PageWidthProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.PageWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageWidthProperty
Visual Basic
Public Shared PageWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageWidthProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..TextAlignmentProperty Field
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.TextAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextAlignmentProperty
Visual Basic
Public Shared TextAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextAlignmentProperty

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocument Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument Methods
FlowDocument Class See Also Send Feedback

The FlowDocument type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..GetProperty Method
FlowDocument Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocument Class
FlowDocument Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..GetRealType Method
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..InvokeMethod Method
FlowDocument Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocument Class
FlowDocument Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocument Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument Properties
FlowDocument Class See Also Send Feedback

The FlowDocument type exposes the following members.

Properties

 | Name | Description
Public property | Background |
Public property | ColumnGap |
Public property | ColumnRuleBrush |
Public property | ColumnRuleWidth |
Public property | ColumnWidth |
Public property | FlowDirection |
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | IsColumnWidthFlexible |
Public property | IsHyphenationEnabled |
Public property | IsOptimalParagraphEnabled |
Public property | LineHeight |
Public property | LineStackingStrategy |
Public property | MaxPageHeight |
Public property | MaxPageWidth |
Public property | MinPageHeight |
Public property | MinPageWidth |
Public property | PageHeight |
Public property | PagePadding |
Public property | PageWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | TextAlignment |

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..Background Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnGap Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ColumnGap Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ColumnGap"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ColumnGap { get; set; }
Visual Basic
Public Property ColumnGap As Double
    Get
    Set
Visual C++
public:
property double ColumnGap {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnRuleBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ColumnRuleBrush Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ColumnRuleBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush ColumnRuleBrush { get; set; }
Visual Basic
Public Property ColumnRuleBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ ColumnRuleBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnRuleWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ColumnRuleWidth Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ColumnRuleWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ColumnRuleWidth { get; set; }
Visual Basic
Public Property ColumnRuleWidth As Double
    Get
    Set
Visual C++
public:
property double ColumnRuleWidth {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..ColumnWidth Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.ColumnWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ColumnWidth { get; set; }
Visual Basic
Public Property ColumnWidth As Double
    Get
    Set
Visual C++
public:
property double ColumnWidth {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FlowDirection Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FlowDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDirection FlowDirection { get; set; }
Visual Basic
Public Property FlowDirection As FlowDirection
    Get
    Set
Visual C++
public:
property FlowDirection FlowDirection {
    FlowDirection get ();
    void set (FlowDirection value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontFamily Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontFamily"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; set; }
Visual Basic
Public Property FontFamily As FontFamily
    Get
    Set
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontSize Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic
Public Property FontSize As Double
    Get
    Set
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontStretch Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontStretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretch FontStretch { get; set; }
Visual Basic
Public Property FontStretch As FontStretch
    Get
    Set
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
    void set (FontStretch value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontStyle Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontStyle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyle FontStyle { get; set; }
Visual Basic
Public Property FontStyle As FontStyle
    Get
    Set
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..FontWeight Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.FontWeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeight FontWeight { get; set; }
Visual Basic
Public Property FontWeight As FontWeight
    Get
    Set
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
    void set (FontWeight value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..Foreground Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.Foreground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic
Public Property Foreground As Brush
    Get
    Set
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsColumnWidthFlexible Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..IsColumnWidthFlexible Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.IsColumnWidthFlexible"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsColumnWidthFlexible { get; set; }
Visual Basic
Public Property IsColumnWidthFlexible As Boolean
    Get
    Set
Visual C++
public:
property bool IsColumnWidthFlexible {
    bool get ();
    void set (bool value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHyphenationEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..IsHyphenationEnabled Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.IsHyphenationEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsHyphenationEnabled { get; set; }
Visual Basic
Public Property IsHyphenationEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsHyphenationEnabled {
    bool get ();
    void set (bool value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOptimalParagraphEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..IsOptimalParagraphEnabled Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.IsOptimalParagraphEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsOptimalParagraphEnabled { get; set; }
Visual Basic
Public Property IsOptimalParagraphEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsOptimalParagraphEnabled {
    bool get ();
    void set (bool value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..LineHeight Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.LineHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double LineHeight { get; set; }
Visual Basic
Public Property LineHeight As Double
    Get
    Set
Visual C++
public:
property double LineHeight {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineStackingStrategy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..LineStackingStrategy Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.LineStackingStrategy"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LineStackingStrategy LineStackingStrategy { get; set; }
Visual Basic
Public Property LineStackingStrategy As LineStackingStrategy
    Get
    Set
Visual C++
public:
property LineStackingStrategy LineStackingStrategy {
    LineStackingStrategy get ();
    void set (LineStackingStrategy value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxPageHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..MaxPageHeight Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.MaxPageHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxPageHeight { get; set; }
Visual Basic
Public Property MaxPageHeight As Double
    Get
    Set
Visual C++
public:
property double MaxPageHeight {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxPageWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..MaxPageWidth Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.MaxPageWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxPageWidth { get; set; }
Visual Basic
Public Property MaxPageWidth As Double
    Get
    Set
Visual C++
public:
property double MaxPageWidth {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinPageHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..MinPageHeight Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.MinPageHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinPageHeight { get; set; }
Visual Basic
Public Property MinPageHeight As Double
    Get
    Set
Visual C++
public:
property double MinPageHeight {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinPageWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..MinPageWidth Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.MinPageWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinPageWidth { get; set; }
Visual Basic
Public Property MinPageWidth As Double
    Get
    Set
Visual C++
public:
property double MinPageWidth {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..PageHeight Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.PageHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double PageHeight { get; set; }
Visual Basic
Public Property PageHeight As Double
    Get
    Set
Visual C++
public:
property double PageHeight {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PagePadding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..PagePadding Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.PagePadding"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness PagePadding { get; set; }
Visual Basic
Public Property PagePadding As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ PagePadding {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..PageWidth Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.PageWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double PageWidth { get; set; }
Visual Basic
Public Property PageWidth As Double
    Get
    Set
Visual C++
public:
property double PageWidth {
    double get ();
    void set (double value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocument..::..TextAlignment Property
FlowDocument Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocument.TextAlignment"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As TextAlignment
    Get
    Set
Visual C++
public:
property TextAlignment TextAlignment {
    TextAlignment get ();
    void set (TextAlignment value);
}

See Also

FlowDocument Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentPageViewer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer Members
FlowDocumentPageViewer Class Constructors Methods Fields Properties See Also Send Feedback

The FlowDocumentPageViewer type exposes the following members.

Constructors

 | Name | Description
Public method | FlowDocumentPageViewer | Initializes a new instance of the FlowDocumentPageViewer class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides DocumentViewerBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanDecreaseZoomProperty |
CanIncreaseZoomProperty |
MaxZoomProperty |
MinZoomProperty |
ZoomIncrementProperty |
ZoomProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanDecreaseZoom |
Public property | CanGoToNextPage | (Inherited from DocumentViewerBase.)
Public property | CanGoToPreviousPage | (Inherited from DocumentViewerBase.)
Public property | CanIncreaseZoom |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MasterPageNumber | (Inherited from DocumentViewerBase.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MaxZoom |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MinZoom |
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount | (Inherited from DocumentViewerBase.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Zoom |
Public property | ZoomIncrement |

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentPageViewer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer Constructor
FlowDocumentPageViewer Class See Also Send Feedback
Initializes a new instance of the FlowDocumentPageViewer class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDocumentPageViewer()
Visual Basic
Public Sub New
Visual C++
public:
FlowDocumentPageViewer()

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentPageViewer Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer Fields
FlowDocumentPageViewer Class See Also Send Feedback

The FlowDocumentPageViewer type exposes the following members.

Fields

Name | Description
CanDecreaseZoomProperty |
CanIncreaseZoomProperty |
MaxZoomProperty |
MinZoomProperty |
ZoomIncrementProperty |
ZoomProperty |

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanDecreaseZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..CanDecreaseZoomProperty Field
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.CanDecreaseZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanDecreaseZoomProperty
Visual Basic
Public Shared CanDecreaseZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanDecreaseZoomProperty

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanIncreaseZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..CanIncreaseZoomProperty Field
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.CanIncreaseZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanIncreaseZoomProperty
Visual Basic
Public Shared CanIncreaseZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanIncreaseZoomProperty

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..MaxZoomProperty Field
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.MaxZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxZoomProperty
Visual Basic
Public Shared MaxZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxZoomProperty

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..MinZoomProperty Field
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.MinZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinZoomProperty
Visual Basic
Public Shared MinZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinZoomProperty

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomIncrementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..ZoomIncrementProperty Field
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.ZoomIncrementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZoomIncrementProperty
Visual Basic
Public Shared ZoomIncrementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZoomIncrementProperty

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..ZoomProperty Field
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.ZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZoomProperty
Visual Basic
Public Shared ZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZoomProperty

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentPageViewer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer Methods
FlowDocumentPageViewer Class See Also Send Feedback

The FlowDocumentPageViewer type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides DocumentViewerBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..AnySibling Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..GetProperty Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..GetRealType Method
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..GetRectangle Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..Highlight Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..InvokeMethod Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..IsHitTest Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..NextSibling Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..Parent Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..PreviousSibling Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..ScrollToVisible Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..SetProperty Method
FlowDocumentPageViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentPageViewer Class
FlowDocumentPageViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentPageViewer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer Properties
FlowDocumentPageViewer Class See Also Send Feedback

The FlowDocumentPageViewer type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanDecreaseZoom |
Public property | CanGoToNextPage | (Inherited from DocumentViewerBase.)
Public property | CanGoToPreviousPage | (Inherited from DocumentViewerBase.)
Public property | CanIncreaseZoom |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MasterPageNumber | (Inherited from DocumentViewerBase.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MaxZoom |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MinZoom |
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount | (Inherited from DocumentViewerBase.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Zoom |
Public property | ZoomIncrement |

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanDecreaseZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..CanDecreaseZoom Property
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.CanDecreaseZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanDecreaseZoom { get; set; }
Visual Basic
Public Property CanDecreaseZoom As Boolean
    Get
    Set
Visual C++
public:
property bool CanDecreaseZoom {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanIncreaseZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..CanIncreaseZoom Property
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.CanIncreaseZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanIncreaseZoom { get; set; }
Visual Basic
Public Property CanIncreaseZoom As Boolean
    Get
    Set
Visual C++
public:
property bool CanIncreaseZoom {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..MaxZoom Property
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.MaxZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxZoom { get; set; }
Visual Basic
Public Property MaxZoom As Double
    Get
    Set
Visual C++
public:
property double MaxZoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..MinZoom Property
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.MinZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinZoom { get; set; }
Visual Basic
Public Property MinZoom As Double
    Get
    Set
Visual C++
public:
property double MinZoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Zoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..Zoom Property
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.Zoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Zoom { get; set; }
Visual Basic
Public Property Zoom As Double
    Get
    Set
Visual C++
public:
property double Zoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomIncrement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentPageViewer..::..ZoomIncrement Property
FlowDocumentPageViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentPageViewer.ZoomIncrement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ZoomIncrement { get; set; }
Visual Basic
Public Property ZoomIncrement As Double
    Get
    Set
Visual C++
public:
property double ZoomIncrement {
    double get ();
    void set (double value);
}

See Also

FlowDocumentPageViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentReader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader Members
FlowDocumentReader Class Constructors Methods Fields Properties See Also Send Feedback

The FlowDocumentReader type exposes the following members.

Constructors

 | Name | Description
Public method | FlowDocumentReader | Initializes a new instance of the FlowDocumentReader class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanDecreaseZoomProperty |
CanGoToNextPageProperty |
CanGoToPreviousPageProperty |
CanIncreaseZoomProperty |
DocumentProperty |
IsFindEnabledProperty |
IsPageViewEnabledProperty |
IsPrintEnabledProperty |
IsScrollViewEnabledProperty |
IsTwoPageViewEnabledProperty |
MaxZoomProperty |
MinZoomProperty |
PageCountProperty |
PageNumberProperty |
ViewingModeProperty |
ZoomIncrementProperty |
ZoomProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanDecreaseZoom |
Public property | CanGoToNextPage |
Public property | CanGoToPreviousPage |
Public property | CanIncreaseZoom |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | Document |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFindEnabled |
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPageViewEnabled |
Public property | IsPrintEnabled |
Public property | IsScrollViewEnabled |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTwoPageViewEnabled |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MaxZoom |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MinZoom |
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount |
Public property | PageNumber |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | ViewingMode |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Zoom |
Public property | ZoomIncrement |

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentReader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader Constructor
FlowDocumentReader Class See Also Send Feedback
Initializes a new instance of the FlowDocumentReader class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDocumentReader()
Visual Basic
Public Sub New
Visual C++
public:
FlowDocumentReader()

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentReader Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader Fields
FlowDocumentReader Class See Also Send Feedback

The FlowDocumentReader type exposes the following members.

Fields

Name | Description
CanDecreaseZoomProperty |
CanGoToNextPageProperty |
CanGoToPreviousPageProperty |
CanIncreaseZoomProperty |
DocumentProperty |
IsFindEnabledProperty |
IsPageViewEnabledProperty |
IsPrintEnabledProperty |
IsScrollViewEnabledProperty |
IsTwoPageViewEnabledProperty |
MaxZoomProperty |
MinZoomProperty |
PageCountProperty |
PageNumberProperty |
ViewingModeProperty |
ZoomIncrementProperty |
ZoomProperty |

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanDecreaseZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..CanDecreaseZoomProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.CanDecreaseZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanDecreaseZoomProperty
Visual Basic
Public Shared CanDecreaseZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanDecreaseZoomProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoToNextPageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..CanGoToNextPageProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.CanGoToNextPageProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoToNextPageProperty
Visual Basic
Public Shared CanGoToNextPageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoToNextPageProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoToPreviousPageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..CanGoToPreviousPageProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.CanGoToPreviousPageProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoToPreviousPageProperty
Visual Basic
Public Shared CanGoToPreviousPageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoToPreviousPageProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanIncreaseZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..CanIncreaseZoomProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.CanIncreaseZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanIncreaseZoomProperty
Visual Basic
Public Shared CanIncreaseZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanIncreaseZoomProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..DocumentProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.DocumentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DocumentProperty
Visual Basic
Public Shared DocumentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DocumentProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFindEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsFindEnabledProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsFindEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFindEnabledProperty
Visual Basic
Public Shared IsFindEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFindEnabledProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPageViewEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsPageViewEnabledProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsPageViewEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsPageViewEnabledProperty
Visual Basic
Public Shared IsPageViewEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsPageViewEnabledProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPrintEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsPrintEnabledProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsPrintEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsPrintEnabledProperty
Visual Basic
Public Shared IsPrintEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsPrintEnabledProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsScrollViewEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsScrollViewEnabledProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsScrollViewEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsScrollViewEnabledProperty
Visual Basic
Public Shared IsScrollViewEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsScrollViewEnabledProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTwoPageViewEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsTwoPageViewEnabledProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsTwoPageViewEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTwoPageViewEnabledProperty
Visual Basic
Public Shared IsTwoPageViewEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTwoPageViewEnabledProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..MaxZoomProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.MaxZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxZoomProperty
Visual Basic
Public Shared MaxZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxZoomProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..MinZoomProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.MinZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinZoomProperty
Visual Basic
Public Shared MinZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinZoomProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..PageCountProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.PageCountProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageCountProperty
Visual Basic
Public Shared PageCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageCountProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageNumberProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..PageNumberProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.PageNumberProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageNumberProperty
Visual Basic
Public Shared PageNumberProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageNumberProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewingModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..ViewingModeProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.ViewingModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewingModeProperty
Visual Basic
Public Shared ViewingModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewingModeProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomIncrementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..ZoomIncrementProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.ZoomIncrementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZoomIncrementProperty
Visual Basic
Public Shared ZoomIncrementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZoomIncrementProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..ZoomProperty Field
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.ZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZoomProperty
Visual Basic
Public Shared ZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZoomProperty

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentReader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader Methods
FlowDocumentReader Class See Also Send Feedback

The FlowDocumentReader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..AnySibling Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..GetProperty Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..GetRealType Method
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..GetRectangle Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..Highlight Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..InvokeMethod Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsHitTest Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..NextSibling Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..Parent Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..PreviousSibling Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..ScrollToVisible Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..SetProperty Method
FlowDocumentReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentReader Class
FlowDocumentReader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentReader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader Properties
FlowDocumentReader Class See Also Send Feedback

The FlowDocumentReader type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanDecreaseZoom |
Public property | CanGoToNextPage |
Public property | CanGoToPreviousPage |
Public property | CanIncreaseZoom |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | Document |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFindEnabled |
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPageViewEnabled |
Public property | IsPrintEnabled |
Public property | IsScrollViewEnabled |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTwoPageViewEnabled |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MaxZoom |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MinZoom |
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount |
Public property | PageNumber |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | ViewingMode |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Zoom |
Public property | ZoomIncrement |

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanDecreaseZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..CanDecreaseZoom Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.CanDecreaseZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanDecreaseZoom { get; set; }
Visual Basic
Public Property CanDecreaseZoom As Boolean
    Get
    Set
Visual C++
public:
property bool CanDecreaseZoom {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoToNextPage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..CanGoToNextPage Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.CanGoToNextPage"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoToNextPage { get; set; }
Visual Basic
Public Property CanGoToNextPage As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoToNextPage {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoToPreviousPage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..CanGoToPreviousPage Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.CanGoToPreviousPage"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoToPreviousPage { get; set; }
Visual Basic
Public Property CanGoToPreviousPage As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoToPreviousPage {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanIncreaseZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..CanIncreaseZoom Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.CanIncreaseZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanIncreaseZoom { get; set; }
Visual Basic
Public Property CanIncreaseZoom As Boolean
    Get
    Set
Visual C++
public:
property bool CanIncreaseZoom {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Document Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..Document Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.Document"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDocument Document { get; set; }
Visual Basic
Public Property Document As FlowDocument
    Get
    Set
Visual C++
public:
property FlowDocument^ Document {
    FlowDocument^ get ();
    void set (FlowDocument^ value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFindEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsFindEnabled Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsFindEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFindEnabled { get; set; }
Visual Basic
Public Property IsFindEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsFindEnabled {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPageViewEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsPageViewEnabled Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsPageViewEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsPageViewEnabled { get; set; }
Visual Basic
Public Property IsPageViewEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsPageViewEnabled {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPrintEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsPrintEnabled Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsPrintEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsPrintEnabled { get; set; }
Visual Basic
Public Property IsPrintEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsPrintEnabled {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsScrollViewEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsScrollViewEnabled Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsScrollViewEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsScrollViewEnabled { get; set; }
Visual Basic
Public Property IsScrollViewEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsScrollViewEnabled {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTwoPageViewEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..IsTwoPageViewEnabled Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.IsTwoPageViewEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTwoPageViewEnabled { get; set; }
Visual Basic
Public Property IsTwoPageViewEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsTwoPageViewEnabled {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..MaxZoom Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.MaxZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxZoom { get; set; }
Visual Basic
Public Property MaxZoom As Double
    Get
    Set
Visual C++
public:
property double MaxZoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..MinZoom Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.MinZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinZoom { get; set; }
Visual Basic
Public Property MinZoom As Double
    Get
    Set
Visual C++
public:
property double MinZoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..PageCount Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.PageCount"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PageCount { get; set; }
Visual Basic
Public Property PageCount As Integer
    Get
    Set
Visual C++
public:
property int PageCount {
    int get ();
    void set (int value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageNumber Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..PageNumber Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.PageNumber"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic
Public Property PageNumber As Integer
    Get
    Set
Visual C++
public:
property int PageNumber {
    int get ();
    void set (int value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewingMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..ViewingMode Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.ViewingMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDocumentReaderViewingMode ViewingMode { get; set; }
Visual Basic
Public Property ViewingMode As FlowDocumentReaderViewingMode
    Get
    Set
Visual C++
public:
property FlowDocumentReaderViewingMode ViewingMode {
    FlowDocumentReaderViewingMode get ();
    void set (FlowDocumentReaderViewingMode value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Zoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..Zoom Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.Zoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Zoom { get; set; }
Visual Basic
Public Property Zoom As Double
    Get
    Set
Visual C++
public:
property double Zoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomIncrement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentReader..::..ZoomIncrement Property
FlowDocumentReader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentReader.ZoomIncrement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ZoomIncrement { get; set; }
Visual Basic
Public Property ZoomIncrement As Double
    Get
    Set
Visual C++
public:
property double ZoomIncrement {
    double get ();
    void set (double value);
}

See Also

FlowDocumentReader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentScrollViewer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer Members
FlowDocumentScrollViewer Class Constructors Methods Fields Properties See Also Send Feedback

The FlowDocumentScrollViewer type exposes the following members.

Constructors

 | Name | Description
Public method | FlowDocumentScrollViewer | Initializes a new instance of the FlowDocumentScrollViewer class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanDecreaseZoomProperty |
CanIncreaseZoomProperty |
DocumentProperty |
HorizontalScrollBarVisibilityProperty |
IsSelectionEnabledProperty |
IsToolBarVisibleProperty |
MaxZoomProperty |
MinZoomProperty |
VerticalScrollBarVisibilityProperty |
ZoomIncrementProperty |
ZoomProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanDecreaseZoom |
Public property | CanIncreaseZoom |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | Document |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelectionEnabled |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsToolBarVisible |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MaxZoom |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MinZoom |
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Zoom |
Public property | ZoomIncrement |

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentScrollViewer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer Constructor
FlowDocumentScrollViewer Class See Also Send Feedback
Initializes a new instance of the FlowDocumentScrollViewer class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDocumentScrollViewer()
Visual Basic
Public Sub New
Visual C++
public:
FlowDocumentScrollViewer()

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentScrollViewer Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer Fields
FlowDocumentScrollViewer Class See Also Send Feedback

The FlowDocumentScrollViewer type exposes the following members.

Fields

Name | Description
CanDecreaseZoomProperty |
CanIncreaseZoomProperty |
DocumentProperty |
HorizontalScrollBarVisibilityProperty |
IsSelectionEnabledProperty |
IsToolBarVisibleProperty |
MaxZoomProperty |
MinZoomProperty |
VerticalScrollBarVisibilityProperty |
ZoomIncrementProperty |
ZoomProperty |

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanDecreaseZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..CanDecreaseZoomProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.CanDecreaseZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanDecreaseZoomProperty
Visual Basic
Public Shared CanDecreaseZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanDecreaseZoomProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanIncreaseZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..CanIncreaseZoomProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.CanIncreaseZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanIncreaseZoomProperty
Visual Basic
Public Shared CanIncreaseZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanIncreaseZoomProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DocumentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..DocumentProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.DocumentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DocumentProperty
Visual Basic
Public Shared DocumentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DocumentProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..HorizontalScrollBarVisibilityProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.HorizontalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalScrollBarVisibilityProperty
Visual Basic
Public Shared HorizontalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalScrollBarVisibilityProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectionEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..IsSelectionEnabledProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.IsSelectionEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectionEnabledProperty
Visual Basic
Public Shared IsSelectionEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectionEnabledProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsToolBarVisibleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..IsToolBarVisibleProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.IsToolBarVisibleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsToolBarVisibleProperty
Visual Basic
Public Shared IsToolBarVisibleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsToolBarVisibleProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..MaxZoomProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.MaxZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxZoomProperty
Visual Basic
Public Shared MaxZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxZoomProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..MinZoomProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.MinZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinZoomProperty
Visual Basic
Public Shared MinZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinZoomProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..VerticalScrollBarVisibilityProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.VerticalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalScrollBarVisibilityProperty
Visual Basic
Public Shared VerticalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalScrollBarVisibilityProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomIncrementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..ZoomIncrementProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.ZoomIncrementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZoomIncrementProperty
Visual Basic
Public Shared ZoomIncrementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZoomIncrementProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..ZoomProperty Field
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.ZoomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZoomProperty
Visual Basic
Public Shared ZoomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZoomProperty

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentScrollViewer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer Methods
FlowDocumentScrollViewer Class See Also Send Feedback

The FlowDocumentScrollViewer type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..AnySibling Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..GetProperty Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..GetRealType Method
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..GetRectangle Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..Highlight Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..InvokeMethod Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..IsHitTest Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..NextSibling Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..Parent Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..PreviousSibling Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..ScrollToVisible Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..SetProperty Method
FlowDocumentScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FlowDocumentScrollViewer Class
FlowDocumentScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDocumentScrollViewer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer Properties
FlowDocumentScrollViewer Class See Also Send Feedback

The FlowDocumentScrollViewer type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanDecreaseZoom |
Public property | CanIncreaseZoom |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | Document |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelectionEnabled |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsToolBarVisible |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MaxZoom |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MinZoom |
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Zoom |
Public property | ZoomIncrement |

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanDecreaseZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..CanDecreaseZoom Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.CanDecreaseZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanDecreaseZoom { get; set; }
Visual Basic
Public Property CanDecreaseZoom As Boolean
    Get
    Set
Visual C++
public:
property bool CanDecreaseZoom {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanIncreaseZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..CanIncreaseZoom Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.CanIncreaseZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanIncreaseZoom { get; set; }
Visual Basic
Public Property CanIncreaseZoom As Boolean
    Get
    Set
Visual C++
public:
property bool CanIncreaseZoom {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Document Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..Document Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.Document"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDocument Document { get; set; }
Visual Basic
Public Property Document As FlowDocument
    Get
    Set
Visual C++
public:
property FlowDocument^ Document {
    FlowDocument^ get ();
    void set (FlowDocument^ value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..HorizontalScrollBarVisibility Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.HorizontalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility HorizontalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectionEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..IsSelectionEnabled Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.IsSelectionEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelectionEnabled { get; set; }
Visual Basic
Public Property IsSelectionEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelectionEnabled {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsToolBarVisible Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..IsToolBarVisible Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.IsToolBarVisible"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsToolBarVisible { get; set; }
Visual Basic
Public Property IsToolBarVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsToolBarVisible {
    bool get ();
    void set (bool value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..MaxZoom Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.MaxZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxZoom { get; set; }
Visual Basic
Public Property MaxZoom As Double
    Get
    Set
Visual C++
public:
property double MaxZoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinZoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..MinZoom Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.MinZoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinZoom { get; set; }
Visual Basic
Public Property MinZoom As Double
    Get
    Set
Visual C++
public:
property double MinZoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..VerticalScrollBarVisibility Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.VerticalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic
Public Property VerticalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility VerticalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Zoom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..Zoom Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.Zoom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Zoom { get; set; }
Visual Basic
Public Property Zoom As Double
    Get
    Set
Visual C++
public:
property double Zoom {
    double get ();
    void set (double value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZoomIncrement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FlowDocumentScrollViewer..::..ZoomIncrement Property
FlowDocumentScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FlowDocumentScrollViewer.ZoomIncrement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ZoomIncrement { get; set; }
Visual Basic
Public Property ZoomIncrement As Double
    Get
    Set
Visual C++
public:
property double ZoomIncrement {
    double get ();
    void set (double value);
}

See Also

FlowDocumentScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyleFactory Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStyleFactory Members
FontStyleFactory Class Constructors Methods See Also Send Feedback

The FontStyleFactory type exposes the following members.

Constructors

 | Name | Description
Public method | FontStyleFactory | Initializes a new instance of the FontStyleFactory class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontStyleFactory Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyleFactory Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStyleFactory Constructor
FontStyleFactory Class See Also Send Feedback
Initializes a new instance of the FontStyleFactory class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyleFactory()
Visual Basic
Public Sub New
Visual C++
public:
FontStyleFactory()

See Also

FontStyleFactory Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyleFactory Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStyleFactory Methods
FontStyleFactory Class See Also Send Feedback

The FontStyleFactory type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontStyleFactory Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FromString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FontStyleFactory..::..FromString Method
FontStyleFactory Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FontStyleFactory.FromString(System.String)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FontStyle FromString(
    string source
)
Visual Basic
Public Shared Function FromString ( _
    source As String _
) As FontStyle
Visual C++
public:
static FontStyle FromString(
    String^ source
)

Parameters

source
Type: System..::..String

[Missing <param name="source"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FontStyleFactory.FromString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FontStyleFactory.FromString(System.String)"]

See Also

FontStyleFactory Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FormatConvertedBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap Members
FormatConvertedBitmap Class Constructors Methods Fields Properties See Also Send Feedback

The FormatConvertedBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | FormatConvertedBitmap | Initializes a new instance of the FormatConvertedBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AlphaThresholdProperty |
DestinationFormatProperty |
DestinationPaletteProperty |
SourceProperty |

Properties

 | Name | Description
Public property | AlphaThreshold |
Public property | DestinationFormat |
Public property | DestinationPalette |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Source |

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FormatConvertedBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap Constructor
FormatConvertedBitmap Class See Also Send Feedback
Initializes a new instance of the FormatConvertedBitmap class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FormatConvertedBitmap()
Visual Basic
Public Sub New
Visual C++
public:
FormatConvertedBitmap()

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FormatConvertedBitmap Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap Fields
FormatConvertedBitmap Class See Also Send Feedback

The FormatConvertedBitmap type exposes the following members.

Fields

Name | Description
AlphaThresholdProperty |
DestinationFormatProperty |
DestinationPaletteProperty |
SourceProperty |

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlphaThresholdProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..AlphaThresholdProperty Field
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.AlphaThresholdProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlphaThresholdProperty
Visual Basic
Public Shared AlphaThresholdProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlphaThresholdProperty

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DestinationFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..DestinationFormatProperty Field
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.DestinationFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DestinationFormatProperty
Visual Basic
Public Shared DestinationFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DestinationFormatProperty

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DestinationPaletteProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..DestinationPaletteProperty Field
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.DestinationPaletteProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DestinationPaletteProperty
Visual Basic
Public Shared DestinationPaletteProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DestinationPaletteProperty

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..SourceProperty Field
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FormatConvertedBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap Methods
FormatConvertedBitmap Class See Also Send Feedback

The FormatConvertedBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..GetProperty Method
FormatConvertedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FormatConvertedBitmap Class
FormatConvertedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..GetRealType Method
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..InvokeMethod Method
FormatConvertedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FormatConvertedBitmap Class
FormatConvertedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FormatConvertedBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap Properties
FormatConvertedBitmap Class See Also Send Feedback

The FormatConvertedBitmap type exposes the following members.

Properties

 | Name | Description
Public property | AlphaThreshold |
Public property | DestinationFormat |
Public property | DestinationPalette |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Source |

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlphaThreshold Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..AlphaThreshold Property
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.AlphaThreshold"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double AlphaThreshold { get; set; }
Visual Basic
Public Property AlphaThreshold As Double
    Get
    Set
Visual C++
public:
property double AlphaThreshold {
    double get ();
    void set (double value);
}

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DestinationFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..DestinationFormat Property
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.DestinationFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PixelFormat DestinationFormat { get; set; }
Visual Basic
Public Property DestinationFormat As PixelFormat
    Get
    Set
Visual C++
public:
property PixelFormat^ DestinationFormat {
    PixelFormat^ get ();
    void set (PixelFormat^ value);
}

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DestinationPalette Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..DestinationPalette Property
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.DestinationPalette"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapPalette DestinationPalette { get; set; }
Visual Basic
Public Property DestinationPalette As BitmapPalette
    Get
    Set
Visual C++
public:
property BitmapPalette^ DestinationPalette {
    BitmapPalette^ get ();
    void set (BitmapPalette^ value);
}

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FormatConvertedBitmap..::..Source Property
FormatConvertedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.FormatConvertedBitmap.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapSource Source { get; set; }
Visual Basic
Public Property Source As BitmapSource
    Get
    Set
Visual C++
public:
property BitmapSource^ Source {
    BitmapSource^ get ();
    void set (BitmapSource^ value);
}

See Also

FormatConvertedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Frame Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Members
Frame Class Constructors Methods Fields Properties See Also Send Feedback

The Frame type exposes the following members.

Constructors

 | Name | Description
Public method | Frame | Initializes a new instance of the Frame class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanGoBackProperty |
CanGoForwardProperty |
JournalOwnershipProperty |
NavigationUIVisibilityProperty |
SandboxExternalContentProperty |
SourceProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanGoBack |
Public property | CanGoForward |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | JournalOwnership |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NavigationUIVisibility |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SandboxExternalContent |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Frame Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Constructor
Frame Class See Also Send Feedback
Initializes a new instance of the Frame class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Frame()
Visual Basic
Public Sub New
Visual C++
public:
Frame()

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Frame Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Fields
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Fields

Name | Description
CanGoBackProperty |
CanGoForwardProperty |
JournalOwnershipProperty |
NavigationUIVisibilityProperty |
SandboxExternalContentProperty |
SourceProperty |

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoBackProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CanGoBackProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.CanGoBackProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoBackProperty
Visual Basic
Public Shared CanGoBackProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoBackProperty

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoForwardProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CanGoForwardProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.CanGoForwardProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoForwardProperty
Visual Basic
Public Shared CanGoForwardProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoForwardProperty

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


JournalOwnershipProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..JournalOwnershipProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.JournalOwnershipProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty JournalOwnershipProperty
Visual Basic
Public Shared JournalOwnershipProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ JournalOwnershipProperty

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigationUIVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..NavigationUIVisibilityProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.NavigationUIVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NavigationUIVisibilityProperty
Visual Basic
Public Shared NavigationUIVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NavigationUIVisibilityProperty

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SandboxExternalContentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..SandboxExternalContentProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.SandboxExternalContentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SandboxExternalContentProperty
Visual Basic
Public Shared SandboxExternalContentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SandboxExternalContentProperty

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..SourceProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Frame Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Methods
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..AnySibling Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..GetProperty Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..GetRealType Method
Frame Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..GetRectangle Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Highlight Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..InvokeMethod Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..IsHitTest Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..NextSibling Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Parent Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..PreviousSibling Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..ScrollToVisible Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..SetProperty Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Frame Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Properties
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanGoBack |
Public property | CanGoForward |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | JournalOwnership |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NavigationUIVisibility |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SandboxExternalContent |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoBack Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CanGoBack Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.CanGoBack"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoBack { get; set; }
Visual Basic
Public Property CanGoBack As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoBack {
    bool get ();
    void set (bool value);
}

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoForward Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CanGoForward Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.CanGoForward"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoForward { get; set; }
Visual Basic
Public Property CanGoForward As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoForward {
    bool get ();
    void set (bool value);
}

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


JournalOwnership Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..JournalOwnership Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.JournalOwnership"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public JournalOwnership JournalOwnership { get; set; }
Visual Basic
Public Property JournalOwnership As JournalOwnership
    Get
    Set
Visual C++
public:
property JournalOwnership JournalOwnership {
    JournalOwnership get ();
    void set (JournalOwnership value);
}

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigationUIVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..NavigationUIVisibility Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.NavigationUIVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NavigationUIVisibility NavigationUIVisibility { get; set; }
Visual Basic
Public Property NavigationUIVisibility As NavigationUIVisibility
    Get
    Set
Visual C++
public:
property NavigationUIVisibility NavigationUIVisibility {
    NavigationUIVisibility get ();
    void set (NavigationUIVisibility value);
}

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SandboxExternalContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..SandboxExternalContent Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.SandboxExternalContent"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SandboxExternalContent { get; set; }
Visual Basic
Public Property SandboxExternalContent As Boolean
    Get
    Set
Visual C++
public:
property bool SandboxExternalContent {
    bool get ();
    void set (bool value);
}

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Source Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Frame.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
Visual C++
public:
property String^ Source {
    String^ get ();
}

See Also

Frame Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Members
Geometry Class Constructors Methods Fields Properties See Also Send Feedback

The Geometry type exposes the following members.

Constructors

 | Name | Description
Public method | Geometry | Initializes a new instance of the Geometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
TransformProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform |

See Also

Geometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Constructor
Geometry Class See Also Send Feedback
Initializes a new instance of the Geometry class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Geometry()
Visual Basic
Public Sub New
Visual C++
public:
Geometry()

See Also

Geometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Fields
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Fields

Name | Description
TransformProperty |

See Also

Geometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..TransformProperty Field
Geometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Geometry.TransformProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TransformProperty
Visual Basic
Public Shared TransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TransformProperty

See Also

Geometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Methods
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Geometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..GetProperty Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Geometry Class
Geometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..GetRealType Method
Geometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Geometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Geometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Geometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..InvokeMethod Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Geometry Class
Geometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Properties
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform |

See Also

Geometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..Transform Property
Geometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Geometry.Transform"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform Transform { get; set; }
Visual Basic
Public Property Transform As Transform
    Get
    Set
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

Geometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GeometryDrawing Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing Members
GeometryDrawing Class Constructors Methods Fields Properties See Also Send Feedback

The GeometryDrawing type exposes the following members.

Constructors

 | Name | Description
Public method | GeometryDrawing | Initializes a new instance of the GeometryDrawing class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Drawing..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BrushProperty |
GeometryProperty |
PenProperty |

Properties

 | Name | Description
Public property | Brush |
Public property | Geometry |
Public property | Pen |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GeometryDrawing Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing Constructor
GeometryDrawing Class See Also Send Feedback
Initializes a new instance of the GeometryDrawing class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GeometryDrawing()
Visual Basic
Public Sub New
Visual C++
public:
GeometryDrawing()

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GeometryDrawing Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing Fields
GeometryDrawing Class See Also Send Feedback

The GeometryDrawing type exposes the following members.

Fields

Name | Description
BrushProperty |
GeometryProperty |
PenProperty |

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..BrushProperty Field
GeometryDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GeometryDrawing.BrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BrushProperty
Visual Basic
Public Shared BrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BrushProperty

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GeometryProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..GeometryProperty Field
GeometryDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GeometryDrawing.GeometryProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GeometryProperty
Visual Basic
Public Shared GeometryProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GeometryProperty

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..PenProperty Field
GeometryDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GeometryDrawing.PenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PenProperty
Visual Basic
Public Shared PenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PenProperty

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GeometryDrawing Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing Methods
GeometryDrawing Class See Also Send Feedback

The GeometryDrawing type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Drawing..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..GetProperty Method
GeometryDrawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GeometryDrawing Class
GeometryDrawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..GetRealType Method
GeometryDrawing Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GeometryDrawing.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GeometryDrawing.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..InvokeMethod Method
GeometryDrawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GeometryDrawing Class
GeometryDrawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GeometryDrawing Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing Properties
GeometryDrawing Class See Also Send Feedback

The GeometryDrawing type exposes the following members.

Properties

 | Name | Description
Public property | Brush |
Public property | Geometry |
Public property | Pen |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Brush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..Brush Property
GeometryDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GeometryDrawing.Brush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Brush { get; set; }
Visual Basic
Public Property Brush As Brush
    Get
    Set
Visual C++
public:
property Brush^ Brush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Geometry Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..Geometry Property
GeometryDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GeometryDrawing.Geometry"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Geometry Geometry { get; set; }
Visual Basic
Public Property Geometry As Geometry
    Get
    Set
Visual C++
public:
property Geometry^ Geometry {
    Geometry^ get ();
    void set (Geometry^ value);
}

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Pen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryDrawing..::..Pen Property
GeometryDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GeometryDrawing.Pen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Pen Pen { get; set; }
Visual Basic
Public Property Pen As Pen
    Get
    Set
Visual C++
public:
property Pen^ Pen {
    Pen^ get ();
    void set (Pen^ value);
}

See Also

GeometryDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRun Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRun Members
GlyphRun Class Constructors Methods Properties See Also Send Feedback

The GlyphRun type exposes the following members.

Constructors

 | Name | Description
Public method | GlyphRun | Initializes a new instance of the GlyphRun class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GlyphRun Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRun Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRun Constructor
GlyphRun Class See Also Send Feedback
Initializes a new instance of the GlyphRun class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GlyphRun()
Visual Basic
Public Sub New
Visual C++
public:
GlyphRun()

See Also

GlyphRun Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRun Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRun Methods
GlyphRun Class See Also Send Feedback

The GlyphRun type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlyphRun Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRun..::..GetProperty Method
GlyphRun Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GlyphRun Class
GlyphRun Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRun..::..GetRealType Method
GlyphRun Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GlyphRun.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GlyphRun.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GlyphRun Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRun..::..InvokeMethod Method
GlyphRun Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GlyphRun Class
GlyphRun Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRun Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRun Properties
GlyphRun Class See Also Send Feedback

The GlyphRun type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GlyphRun Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRunDrawing Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing Members
GlyphRunDrawing Class Constructors Methods Fields Properties See Also Send Feedback

The GlyphRunDrawing type exposes the following members.

Constructors

 | Name | Description
Public method | GlyphRunDrawing | Initializes a new instance of the GlyphRunDrawing class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Drawing..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ForegroundBrushProperty |
GlyphRunProperty |

Properties

 | Name | Description
Public property | ForegroundBrush |
Public property | GlyphRun |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRunDrawing Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing Constructor
GlyphRunDrawing Class See Also Send Feedback
Initializes a new instance of the GlyphRunDrawing class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GlyphRunDrawing()
Visual Basic
Public Sub New
Visual C++
public:
GlyphRunDrawing()

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRunDrawing Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing Fields
GlyphRunDrawing Class See Also Send Feedback

The GlyphRunDrawing type exposes the following members.

Fields

Name | Description
ForegroundBrushProperty |
GlyphRunProperty |

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForegroundBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing..::..ForegroundBrushProperty Field
GlyphRunDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GlyphRunDrawing.ForegroundBrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundBrushProperty
Visual Basic
Public Shared ForegroundBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundBrushProperty

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRunProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing..::..GlyphRunProperty Field
GlyphRunDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GlyphRunDrawing.GlyphRunProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GlyphRunProperty
Visual Basic
Public Shared GlyphRunProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GlyphRunProperty

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRunDrawing Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing Methods
GlyphRunDrawing Class See Also Send Feedback

The GlyphRunDrawing type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Drawing..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing..::..GetProperty Method
GlyphRunDrawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GlyphRunDrawing Class
GlyphRunDrawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing..::..GetRealType Method
GlyphRunDrawing Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GlyphRunDrawing.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GlyphRunDrawing.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing..::..InvokeMethod Method
GlyphRunDrawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GlyphRunDrawing Class
GlyphRunDrawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRunDrawing Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing Properties
GlyphRunDrawing Class See Also Send Feedback

The GlyphRunDrawing type exposes the following members.

Properties

 | Name | Description
Public property | ForegroundBrush |
Public property | GlyphRun |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForegroundBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing..::..ForegroundBrush Property
GlyphRunDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GlyphRunDrawing.ForegroundBrush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush ForegroundBrush { get; set; }
Visual Basic
Public Property ForegroundBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ ForegroundBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GlyphRun Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlyphRunDrawing..::..GlyphRun Property
GlyphRunDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GlyphRunDrawing.GlyphRun"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GlyphRun GlyphRun { get; set; }
Visual Basic
Public Property GlyphRun As GlyphRun
    Get
    Set
Visual C++
public:
property GlyphRun^ GlyphRun {
    GlyphRun^ get ();
    void set (GlyphRun^ value);
}

See Also

GlyphRunDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Glyphs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Members
Glyphs Class Constructors Methods Fields Properties See Also Send Feedback

The Glyphs type exposes the following members.

Constructors

 | Name | Description
Public method | Glyphs | Initializes a new instance of the Glyphs class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BidiLevelProperty |
CaretStopsProperty |
DeviceFontNameProperty |
FillProperty |
FontRenderingEmSizeProperty |
FontUriProperty |
IndicesProperty |
IsSidewaysProperty |
OriginXProperty |
OriginYProperty |
StyleSimulationsProperty |
UnicodeStringProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BidiLevel |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | CaretStops |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DeviceFontName |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontRenderingEmSize |
Public property | FontUri |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Indices |
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSideways |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OriginX |
Public property | OriginY |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StyleSimulations |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UnicodeString |
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Glyphs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Constructor
Glyphs Class See Also Send Feedback
Initializes a new instance of the Glyphs class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Glyphs()
Visual Basic
Public Sub New
Visual C++
public:
Glyphs()

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Glyphs Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Fields
Glyphs Class See Also Send Feedback

The Glyphs type exposes the following members.

Fields

Name | Description
BidiLevelProperty |
CaretStopsProperty |
DeviceFontNameProperty |
FillProperty |
FontRenderingEmSizeProperty |
FontUriProperty |
IndicesProperty |
IsSidewaysProperty |
OriginXProperty |
OriginYProperty |
StyleSimulationsProperty |
UnicodeStringProperty |

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BidiLevelProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..BidiLevelProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.BidiLevelProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BidiLevelProperty
Visual Basic
Public Shared BidiLevelProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BidiLevelProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CaretStopsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..CaretStopsProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.CaretStopsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CaretStopsProperty
Visual Basic
Public Shared CaretStopsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CaretStopsProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DeviceFontNameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..DeviceFontNameProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.DeviceFontNameProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DeviceFontNameProperty
Visual Basic
Public Shared DeviceFontNameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DeviceFontNameProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FillProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.FillProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillProperty
Visual Basic
Public Shared FillProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontRenderingEmSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FontRenderingEmSizeProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.FontRenderingEmSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontRenderingEmSizeProperty
Visual Basic
Public Shared FontRenderingEmSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontRenderingEmSizeProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontUriProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FontUriProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.FontUriProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontUriProperty
Visual Basic
Public Shared FontUriProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontUriProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IndicesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..IndicesProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.IndicesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IndicesProperty
Visual Basic
Public Shared IndicesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IndicesProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSidewaysProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..IsSidewaysProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.IsSidewaysProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSidewaysProperty
Visual Basic
Public Shared IsSidewaysProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSidewaysProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OriginXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..OriginXProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.OriginXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OriginXProperty
Visual Basic
Public Shared OriginXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OriginXProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OriginYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..OriginYProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.OriginYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OriginYProperty
Visual Basic
Public Shared OriginYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OriginYProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StyleSimulationsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..StyleSimulationsProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.StyleSimulationsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StyleSimulationsProperty
Visual Basic
Public Shared StyleSimulationsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StyleSimulationsProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnicodeStringProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..UnicodeStringProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.UnicodeStringProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UnicodeStringProperty
Visual Basic
Public Shared UnicodeStringProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UnicodeStringProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Glyphs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Methods
Glyphs Class See Also Send Feedback

The Glyphs type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..AnySibling Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..GetProperty Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..GetRealType Method
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..GetRectangle Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..Highlight Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..InvokeMethod Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..IsHitTest Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..NextSibling Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..Parent Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..PreviousSibling Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..ScrollToVisible Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..SetProperty Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Glyphs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Properties
Glyphs Class See Also Send Feedback

The Glyphs type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BidiLevel |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | CaretStops |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DeviceFontName |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontRenderingEmSize |
Public property | FontUri |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Indices |
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSideways |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OriginX |
Public property | OriginY |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StyleSimulations |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UnicodeString |
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BidiLevel Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..BidiLevel Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.BidiLevel"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int BidiLevel { get; set; }
Visual Basic
Public Property BidiLevel As Integer
    Get
    Set
Visual C++
public:
property int BidiLevel {
    int get ();
    void set (int value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CaretStops Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..CaretStops Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.CaretStops"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string CaretStops { get; set; }
Visual Basic
Public Property CaretStops As String
    Get
    Set
Visual C++
public:
property String^ CaretStops {
    String^ get ();
    void set (String^ value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DeviceFontName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..DeviceFontName Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.DeviceFontName"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DeviceFontName { get; set; }
Visual Basic
Public Property DeviceFontName As String
    Get
    Set
Visual C++
public:
property String^ DeviceFontName {
    String^ get ();
    void set (String^ value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Fill Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..Fill Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.Fill"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Fill { get; set; }
Visual Basic
Public Property Fill As Brush
    Get
    Set
Visual C++
public:
property Brush^ Fill {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontRenderingEmSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FontRenderingEmSize Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.FontRenderingEmSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontRenderingEmSize { get; set; }
Visual Basic
Public Property FontRenderingEmSize As Double
    Get
    Set
Visual C++
public:
property double FontRenderingEmSize {
    double get ();
    void set (double value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontUri Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FontUri Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.FontUri"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FontUri { get; }
Visual Basic
Public ReadOnly Property FontUri As String
    Get
Visual C++
public:
property String^ FontUri {
    String^ get ();
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Indices Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..Indices Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.Indices"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Indices { get; set; }
Visual Basic
Public Property Indices As String
    Get
    Set
Visual C++
public:
property String^ Indices {
    String^ get ();
    void set (String^ value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSideways Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..IsSideways Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.IsSideways"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSideways { get; set; }
Visual Basic
Public Property IsSideways As Boolean
    Get
    Set
Visual C++
public:
property bool IsSideways {
    bool get ();
    void set (bool value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OriginX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..OriginX Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.OriginX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double OriginX { get; set; }
Visual Basic
Public Property OriginX As Double
    Get
    Set
Visual C++
public:
property double OriginX {
    double get ();
    void set (double value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OriginY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..OriginY Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.OriginY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double OriginY { get; set; }
Visual Basic
Public Property OriginY As Double
    Get
    Set
Visual C++
public:
property double OriginY {
    double get ();
    void set (double value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StyleSimulations Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..StyleSimulations Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.StyleSimulations"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StyleSimulations StyleSimulations { get; set; }
Visual Basic
Public Property StyleSimulations As StyleSimulations
    Get
    Set
Visual C++
public:
property StyleSimulations StyleSimulations {
    StyleSimulations get ();
    void set (StyleSimulations value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnicodeString Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..UnicodeString Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Glyphs.UnicodeString"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UnicodeString { get; set; }
Visual Basic
Public Property UnicodeString As String
    Get
    Set
Visual C++
public:
property String^ UnicodeString {
    String^ get ();
    void set (String^ value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Members
GradientBrush Class Constructors Methods Fields Properties See Also Send Feedback

The GradientBrush type exposes the following members.

Constructors

 | Name | Description
Public method | GradientBrush | Initializes a new instance of the GradientBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ColorInterpolationModeProperty |
GradientStopsProperty |
MappingModeProperty |
SpreadMethodProperty |

Properties

 | Name | Description
Public property | ColorInterpolationMode |
Public property | GradientStops |
Public property | MappingMode |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod |
Public property | Transform | (Inherited from Brush.)

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Constructor
GradientBrush Class See Also Send Feedback
Initializes a new instance of the GradientBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GradientBrush()
Visual Basic
Public Sub New
Visual C++
public:
GradientBrush()

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Fields
GradientBrush Class See Also Send Feedback

The GradientBrush type exposes the following members.

Fields

Name | Description
ColorInterpolationModeProperty |
GradientStopsProperty |
MappingModeProperty |
SpreadMethodProperty |

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorInterpolationModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..ColorInterpolationModeProperty Field
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.ColorInterpolationModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColorInterpolationModeProperty
Visual Basic
Public Shared ColorInterpolationModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColorInterpolationModeProperty

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientStopsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..GradientStopsProperty Field
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.GradientStopsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GradientStopsProperty
Visual Basic
Public Shared GradientStopsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GradientStopsProperty

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MappingModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..MappingModeProperty Field
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.MappingModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MappingModeProperty
Visual Basic
Public Shared MappingModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MappingModeProperty

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SpreadMethodProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..SpreadMethodProperty Field
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.SpreadMethodProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SpreadMethodProperty
Visual Basic
Public Shared SpreadMethodProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SpreadMethodProperty

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Methods
GradientBrush Class See Also Send Feedback

The GradientBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..GetProperty Method
GradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientBrush Class
GradientBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..GetRealType Method
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..InvokeMethod Method
GradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientBrush Class
GradientBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Properties
GradientBrush Class See Also Send Feedback

The GradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | ColorInterpolationMode |
Public property | GradientStops |
Public property | MappingMode |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod |
Public property | Transform | (Inherited from Brush.)

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorInterpolationMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..ColorInterpolationMode Property
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.ColorInterpolationMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ColorInterpolationMode ColorInterpolationMode { get; set; }
Visual Basic
Public Property ColorInterpolationMode As ColorInterpolationMode
    Get
    Set
Visual C++
public:
property ColorInterpolationMode ColorInterpolationMode {
    ColorInterpolationMode get ();
    void set (ColorInterpolationMode value);
}

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientStops Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..GradientStops Property
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.GradientStops"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<GradientStop> GradientStops { get; set; }
Visual Basic
Public Property GradientStops As List(Of GradientStop)
    Get
    Set
Visual C++
public:
property List<GradientStop^>^ GradientStops {
    List<GradientStop^>^ get ();
    void set (List<GradientStop^>^ value);
}

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MappingMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..MappingMode Property
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.MappingMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrushMappingMode MappingMode { get; set; }
Visual Basic
Public Property MappingMode As BrushMappingMode
    Get
    Set
Visual C++
public:
property BrushMappingMode MappingMode {
    BrushMappingMode get ();
    void set (BrushMappingMode value);
}

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SpreadMethod Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..SpreadMethod Property
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientBrush.SpreadMethod"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GradientSpreadMethod SpreadMethod { get; set; }
Visual Basic
Public Property SpreadMethod As GradientSpreadMethod
    Get
    Set
Visual C++
public:
property GradientSpreadMethod SpreadMethod {
    GradientSpreadMethod get ();
    void set (GradientSpreadMethod value);
}

See Also

GradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientStop Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Members
GradientStop Class Constructors Methods Fields Properties See Also Send Feedback

The GradientStop type exposes the following members.

Constructors

 | Name | Description
Public method | GradientStop | Initializes a new instance of the GradientStop class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ColorProperty |
OffsetProperty |

Properties

 | Name | Description
Public property | Color |
Public property | Offset |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientStop Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Constructor
GradientStop Class See Also Send Feedback
Initializes a new instance of the GradientStop class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GradientStop()
Visual Basic
Public Sub New
Visual C++
public:
GradientStop()

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientStop Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Fields
GradientStop Class See Also Send Feedback

The GradientStop type exposes the following members.

Fields

Name | Description
ColorProperty |
OffsetProperty |

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..ColorProperty Field
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientStop.ColorProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColorProperty
Visual Basic
Public Shared ColorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColorProperty

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..OffsetProperty Field
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientStop.OffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetProperty
Visual Basic
Public Shared OffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetProperty

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientStop Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Methods
GradientStop Class See Also Send Feedback

The GradientStop type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..GetProperty Method
GradientStop Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientStop Class
GradientStop Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..GetRealType Method
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientStop.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientStop.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..InvokeMethod Method
GradientStop Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientStop Class
GradientStop Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientStop Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Properties
GradientStop Class See Also Send Feedback

The GradientStop type exposes the following members.

Properties

 | Name | Description
Public property | Color |
Public property | Offset |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Color Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..Color Property
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientStop.Color"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Offset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..Offset Property
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GradientStop.Offset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Offset { get; set; }
Visual Basic
Public Property Offset As Double
    Get
    Set
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

See Also

GradientStop Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Grid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Members
Grid Class Constructors Methods Fields Properties See Also Send Feedback

The Grid type exposes the following members.

Constructors

 | Name | Description
Public method | Grid | Initializes a new instance of the Grid class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ShowGridLinesProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowGridLines |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Grid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Grid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Constructor
Grid Class See Also Send Feedback
Initializes a new instance of the Grid class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Grid()
Visual Basic
Public Sub New
Visual C++
public:
Grid()

See Also

Grid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Grid Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Fields
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Fields

Name | Description
ShowGridLinesProperty |

See Also

Grid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowGridLinesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..ShowGridLinesProperty Field
Grid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Grid.ShowGridLinesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ShowGridLinesProperty
Visual Basic
Public Shared ShowGridLinesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ShowGridLinesProperty

See Also

Grid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Grid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Methods
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Grid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..AnySibling Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..GetProperty Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..GetRealType Method
Grid Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Grid.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Grid.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Grid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..GetRectangle Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..Highlight Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..InvokeMethod Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..IsHitTest Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..NextSibling Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..Parent Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..PreviousSibling Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..ScrollToVisible Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..SetProperty Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Grid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Properties
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowGridLines |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Grid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowGridLines Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..ShowGridLines Property
Grid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Grid.ShowGridLines"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowGridLines { get; set; }
Visual Basic
Public Property ShowGridLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}

See Also

Grid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridSplitter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Members
GridSplitter Class Constructors Methods Fields Properties See Also Send Feedback

The GridSplitter type exposes the following members.

Constructors

 | Name | Description
Public method | GridSplitter | Initializes a new instance of the GridSplitter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Thumb..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DragIncrementProperty |
KeyboardIncrementProperty |
ResizeBehaviorProperty |
ResizeDirectionProperty |
ShowsPreviewProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DragIncrement |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDragging | (Inherited from Thumb.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | KeyboardIncrement |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ResizeBehavior |
Public property | ResizeDirection |
Public property | ShowsPreview |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridSplitter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Constructor
GridSplitter Class See Also Send Feedback
Initializes a new instance of the GridSplitter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridSplitter()
Visual Basic
Public Sub New
Visual C++
public:
GridSplitter()

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridSplitter Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Fields
GridSplitter Class See Also Send Feedback

The GridSplitter type exposes the following members.

Fields

Name | Description
DragIncrementProperty |
KeyboardIncrementProperty |
ResizeBehaviorProperty |
ResizeDirectionProperty |
ShowsPreviewProperty |

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DragIncrementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..DragIncrementProperty Field
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.DragIncrementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DragIncrementProperty
Visual Basic
Public Shared DragIncrementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DragIncrementProperty

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


KeyboardIncrementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..KeyboardIncrementProperty Field
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.KeyboardIncrementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty KeyboardIncrementProperty
Visual Basic
Public Shared KeyboardIncrementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ KeyboardIncrementProperty

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeBehaviorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ResizeBehaviorProperty Field
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.ResizeBehaviorProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ResizeBehaviorProperty
Visual Basic
Public Shared ResizeBehaviorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ResizeBehaviorProperty

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ResizeDirectionProperty Field
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.ResizeDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ResizeDirectionProperty
Visual Basic
Public Shared ResizeDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ResizeDirectionProperty

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowsPreviewProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ShowsPreviewProperty Field
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.ShowsPreviewProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ShowsPreviewProperty
Visual Basic
Public Shared ShowsPreviewProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ShowsPreviewProperty

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridSplitter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Methods
GridSplitter Class See Also Send Feedback

The GridSplitter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Thumb..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..AnySibling Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..GetProperty Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..GetRealType Method
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..GetRectangle Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..Highlight Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..InvokeMethod Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..IsHitTest Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..NextSibling Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..Parent Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..PreviousSibling Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ScrollToVisible Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..SetProperty Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridSplitter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Properties
GridSplitter Class See Also Send Feedback

The GridSplitter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DragIncrement |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDragging | (Inherited from Thumb.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | KeyboardIncrement |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ResizeBehavior |
Public property | ResizeDirection |
Public property | ShowsPreview |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DragIncrement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..DragIncrement Property
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.DragIncrement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double DragIncrement { get; set; }
Visual Basic
Public Property DragIncrement As Double
    Get
    Set
Visual C++
public:
property double DragIncrement {
    double get ();
    void set (double value);
}

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


KeyboardIncrement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..KeyboardIncrement Property
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.KeyboardIncrement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double KeyboardIncrement { get; set; }
Visual Basic
Public Property KeyboardIncrement As Double
    Get
    Set
Visual C++
public:
property double KeyboardIncrement {
    double get ();
    void set (double value);
}

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeBehavior Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ResizeBehavior Property
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.ResizeBehavior"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridResizeBehavior ResizeBehavior { get; set; }
Visual Basic
Public Property ResizeBehavior As GridResizeBehavior
    Get
    Set
Visual C++
public:
property GridResizeBehavior ResizeBehavior {
    GridResizeBehavior get ();
    void set (GridResizeBehavior value);
}

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ResizeDirection Property
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.ResizeDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridResizeDirection ResizeDirection { get; set; }
Visual Basic
Public Property ResizeDirection As GridResizeDirection
    Get
    Set
Visual C++
public:
property GridResizeDirection ResizeDirection {
    GridResizeDirection get ();
    void set (GridResizeDirection value);
}

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowsPreview Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ShowsPreview Property
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridSplitter.ShowsPreview"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowsPreview { get; set; }
Visual Basic
Public Property ShowsPreview As Boolean
    Get
    Set
Visual C++
public:
property bool ShowsPreview {
    bool get ();
    void set (bool value);
}

See Also

GridSplitter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumn Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn Members
GridViewColumn Class Constructors Methods Fields Properties See Also Send Feedback

The GridViewColumn type exposes the following members.

Constructors

 | Name | Description
Public method | GridViewColumn | Initializes a new instance of the GridViewColumn class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
HeaderStringFormatProperty |
WidthProperty |

Properties

 | Name | Description
Public property | HeaderStringFormat |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Width |

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumn Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn Constructor
GridViewColumn Class See Also Send Feedback
Initializes a new instance of the GridViewColumn class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridViewColumn()
Visual Basic
Public Sub New
Visual C++
public:
GridViewColumn()

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumn Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn Fields
GridViewColumn Class See Also Send Feedback

The GridViewColumn type exposes the following members.

Fields

Name | Description
HeaderStringFormatProperty |
WidthProperty |

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn..::..HeaderStringFormatProperty Field
GridViewColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumn.HeaderStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeaderStringFormatProperty
Visual Basic
Public Shared HeaderStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeaderStringFormatProperty

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn..::..WidthProperty Field
GridViewColumn Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumn.WidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumn Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn Methods
GridViewColumn Class See Also Send Feedback

The GridViewColumn type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn..::..GetProperty Method
GridViewColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewColumn Class
GridViewColumn Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn..::..GetRealType Method
GridViewColumn Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumn.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumn.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn..::..InvokeMethod Method
GridViewColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewColumn Class
GridViewColumn Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumn Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn Properties
GridViewColumn Class See Also Send Feedback

The GridViewColumn type exposes the following members.

Properties

 | Name | Description
Public property | HeaderStringFormat |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Width |

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn..::..HeaderStringFormat Property
GridViewColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumn.HeaderStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string HeaderStringFormat { get; set; }
Visual Basic
Public Property HeaderStringFormat As String
    Get
    Set
Visual C++
public:
property String^ HeaderStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumn..::..Width Property
GridViewColumn Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumn.Width"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

GridViewColumn Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumnHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader Members
GridViewColumnHeader Class Constructors Methods Fields Properties See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Constructors

 | Name | Description
Public method | GridViewColumnHeader | Initializes a new instance of the GridViewColumnHeader class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ColumnProperty |
RoleProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Column |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Role |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumnHeader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader Constructor
GridViewColumnHeader Class See Also Send Feedback
Initializes a new instance of the GridViewColumnHeader class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridViewColumnHeader()
Visual Basic
Public Sub New
Visual C++
public:
GridViewColumnHeader()

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumnHeader Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader Fields
GridViewColumnHeader Class See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Fields

Name | Description
ColumnProperty |
RoleProperty |

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..ColumnProperty Field
GridViewColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumnHeader.ColumnProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnProperty
Visual Basic
Public Shared ColumnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnProperty

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RoleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..RoleProperty Field
GridViewColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumnHeader.RoleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RoleProperty
Visual Basic
Public Shared RoleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RoleProperty

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumnHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader Methods
GridViewColumnHeader Class See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..AnySibling Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..GetProperty Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..GetRealType Method
GridViewColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumnHeader.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumnHeader.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..GetRectangle Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..Highlight Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..InvokeMethod Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..IsHitTest Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..NextSibling Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..Parent Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..PreviousSibling Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..ScrollToVisible Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..SetProperty Method
GridViewColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewColumnHeader Class
GridViewColumnHeader Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewColumnHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader Properties
GridViewColumnHeader Class See Also Send Feedback

The GridViewColumnHeader type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Column |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Role |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Column Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..Column Property
GridViewColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumnHeader.Column"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridViewColumn Column { get; set; }
Visual Basic
Public Property Column As GridViewColumn
    Get
    Set
Visual C++
public:
property GridViewColumn^ Column {
    GridViewColumn^ get ();
    void set (GridViewColumn^ value);
}

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Role Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewColumnHeader..::..Role Property
GridViewColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewColumnHeader.Role"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridViewColumnHeaderRole Role { get; set; }
Visual Basic
Public Property Role As GridViewColumnHeaderRole
    Get
    Set
Visual C++
public:
property GridViewColumnHeaderRole Role {
    GridViewColumnHeaderRole get ();
    void set (GridViewColumnHeaderRole value);
}

See Also

GridViewColumnHeader Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewHeaderRowPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter Members
GridViewHeaderRowPresenter Class Constructors Methods Fields Properties See Also Send Feedback

The GridViewHeaderRowPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | GridViewHeaderRowPresenter | Initializes a new instance of the GridViewHeaderRowPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides GridViewRowPresenterBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AllowsColumnReorderProperty |
ColumnHeaderContextMenuProperty |
ColumnHeaderStringFormatProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AllowsColumnReorder |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ColumnHeaderContextMenu |
Public property | ColumnHeaderStringFormat |
Public property | Columns | (Inherited from GridViewRowPresenterBase.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewHeaderRowPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter Constructor
GridViewHeaderRowPresenter Class See Also Send Feedback
Initializes a new instance of the GridViewHeaderRowPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridViewHeaderRowPresenter()
Visual Basic
Public Sub New
Visual C++
public:
GridViewHeaderRowPresenter()

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewHeaderRowPresenter Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter Fields
GridViewHeaderRowPresenter Class See Also Send Feedback

The GridViewHeaderRowPresenter type exposes the following members.

Fields

Name | Description
AllowsColumnReorderProperty |
ColumnHeaderContextMenuProperty |
ColumnHeaderStringFormatProperty |

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AllowsColumnReorderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..AllowsColumnReorderProperty Field
GridViewHeaderRowPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewHeaderRowPresenter.AllowsColumnReorderProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AllowsColumnReorderProperty
Visual Basic
Public Shared AllowsColumnReorderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AllowsColumnReorderProperty

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnHeaderContextMenuProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..ColumnHeaderContextMenuProperty Field
GridViewHeaderRowPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewHeaderRowPresenter.ColumnHeaderContextMenuProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnHeaderContextMenuProperty
Visual Basic
Public Shared ColumnHeaderContextMenuProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnHeaderContextMenuProperty

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnHeaderStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..ColumnHeaderStringFormatProperty Field
GridViewHeaderRowPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewHeaderRowPresenter.ColumnHeaderStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnHeaderStringFormatProperty
Visual Basic
Public Shared ColumnHeaderStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnHeaderStringFormatProperty

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewHeaderRowPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter Methods
GridViewHeaderRowPresenter Class See Also Send Feedback

The GridViewHeaderRowPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides GridViewRowPresenterBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..AnySibling Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..GetProperty Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..GetRealType Method
GridViewHeaderRowPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewHeaderRowPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewHeaderRowPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..GetRectangle Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..Highlight Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..InvokeMethod Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..IsHitTest Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..NextSibling Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..Parent Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..PreviousSibling Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..ScrollToVisible Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..SetProperty Method
GridViewHeaderRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewHeaderRowPresenter Class
GridViewHeaderRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewHeaderRowPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter Properties
GridViewHeaderRowPresenter Class See Also Send Feedback

The GridViewHeaderRowPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AllowsColumnReorder |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ColumnHeaderContextMenu |
Public property | ColumnHeaderStringFormat |
Public property | Columns | (Inherited from GridViewRowPresenterBase.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AllowsColumnReorder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..AllowsColumnReorder Property
GridViewHeaderRowPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewHeaderRowPresenter.AllowsColumnReorder"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AllowsColumnReorder { get; set; }
Visual Basic
Public Property AllowsColumnReorder As Boolean
    Get
    Set
Visual C++
public:
property bool AllowsColumnReorder {
    bool get ();
    void set (bool value);
}

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnHeaderContextMenu Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..ColumnHeaderContextMenu Property
GridViewHeaderRowPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewHeaderRowPresenter.ColumnHeaderContextMenu"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContextMenu ColumnHeaderContextMenu { get; set; }
Visual Basic
Public Property ColumnHeaderContextMenu As ContextMenu
    Get
    Set
Visual C++
public:
property ContextMenu^ ColumnHeaderContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnHeaderStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewHeaderRowPresenter..::..ColumnHeaderStringFormat Property
GridViewHeaderRowPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewHeaderRowPresenter.ColumnHeaderStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ColumnHeaderStringFormat { get; set; }
Visual Basic
Public Property ColumnHeaderStringFormat As String
    Get
    Set
Visual C++
public:
property String^ ColumnHeaderStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

GridViewHeaderRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter Members
GridViewRowPresenter Class Constructors Methods Properties See Also Send Feedback

The GridViewRowPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | GridViewRowPresenter | Initializes a new instance of the GridViewRowPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides GridViewRowPresenterBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Columns | (Inherited from GridViewRowPresenterBase.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter Constructor
GridViewRowPresenter Class See Also Send Feedback
Initializes a new instance of the GridViewRowPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridViewRowPresenter()
Visual Basic
Public Sub New
Visual C++
public:
GridViewRowPresenter()

See Also

GridViewRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter Methods
GridViewRowPresenter Class See Also Send Feedback

The GridViewRowPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides GridViewRowPresenterBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..AnySibling Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..GetProperty Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..GetRealType Method
GridViewRowPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewRowPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewRowPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GridViewRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..GetRectangle Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..Highlight Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..InvokeMethod Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..IsHitTest Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..NextSibling Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..Parent Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..PreviousSibling Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..ScrollToVisible Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter..::..SetProperty Method
GridViewRowPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewRowPresenter Class
GridViewRowPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenter Properties
GridViewRowPresenter Class See Also Send Feedback

The GridViewRowPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Columns | (Inherited from GridViewRowPresenterBase.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewRowPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenterBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase Members
GridViewRowPresenterBase Class Constructors Methods Fields Properties See Also Send Feedback

The GridViewRowPresenterBase type exposes the following members.

Constructors

 | Name | Description
Public method | GridViewRowPresenterBase | Initializes a new instance of the GridViewRowPresenterBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ColumnsProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Columns |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenterBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase Constructor
GridViewRowPresenterBase Class See Also Send Feedback
Initializes a new instance of the GridViewRowPresenterBase class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridViewRowPresenterBase()
Visual Basic
Public Sub New
Visual C++
public:
GridViewRowPresenterBase()

See Also

GridViewRowPresenterBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenterBase Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase Fields
GridViewRowPresenterBase Class See Also Send Feedback

The GridViewRowPresenterBase type exposes the following members.

Fields

Name | Description
ColumnsProperty |

See Also

GridViewRowPresenterBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..ColumnsProperty Field
GridViewRowPresenterBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewRowPresenterBase.ColumnsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnsProperty
Visual Basic
Public Shared ColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnsProperty

See Also

GridViewRowPresenterBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenterBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase Methods
GridViewRowPresenterBase Class See Also Send Feedback

The GridViewRowPresenterBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..AnySibling Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..GetProperty Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..GetRealType Method
GridViewRowPresenterBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewRowPresenterBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewRowPresenterBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GridViewRowPresenterBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..GetRectangle Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..Highlight Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..InvokeMethod Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..IsHitTest Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..NextSibling Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..Parent Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..PreviousSibling Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..ScrollToVisible Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..SetProperty Method
GridViewRowPresenterBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridViewRowPresenterBase Class
GridViewRowPresenterBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GridViewRowPresenterBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase Properties
GridViewRowPresenterBase Class See Also Send Feedback

The GridViewRowPresenterBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Columns |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridViewRowPresenterBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Columns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridViewRowPresenterBase..::..Columns Property
GridViewRowPresenterBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.GridViewRowPresenterBase.Columns"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ObservableCollection<GridViewColumn> Columns { get; }
Visual Basic
Public ReadOnly Property Columns As ObservableCollection(Of GridViewColumn)
    Get
Visual C++
public:
property ObservableCollection<GridViewColumn^>^ Columns {
    ObservableCollection<GridViewColumn^>^ get ();
}

See Also

GridViewRowPresenterBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox Members
GroupBox Class Constructors Methods Properties See Also Send Feedback

The GroupBox type exposes the following members.

Constructors

 | Name | Description
Public method | GroupBox | Initializes a new instance of the GroupBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader | (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GroupBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox Constructor
GroupBox Class See Also Send Feedback
Initializes a new instance of the GroupBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GroupBox()
Visual Basic
Public Sub New
Visual C++
public:
GroupBox()

See Also

GroupBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox Methods
GroupBox Class See Also Send Feedback

The GroupBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GroupBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..AnySibling Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..GetProperty Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..GetRealType Method
GroupBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GroupBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GroupBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GroupBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..GetRectangle Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..Highlight Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..InvokeMethod Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..IsHitTest Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..NextSibling Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..Parent Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..PreviousSibling Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..ScrollToVisible Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox..::..SetProperty Method
GroupBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GroupBox Class
GroupBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupBox Properties
GroupBox Class See Also Send Feedback

The GroupBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader | (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GroupBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem Members
GroupItem Class Constructors Methods Properties See Also Send Feedback

The GroupItem type exposes the following members.

Constructors

 | Name | Description
Public method | GroupItem | Initializes a new instance of the GroupItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GroupItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem Constructor
GroupItem Class See Also Send Feedback
Initializes a new instance of the GroupItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GroupItem()
Visual Basic
Public Sub New
Visual C++
public:
GroupItem()

See Also

GroupItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem Methods
GroupItem Class See Also Send Feedback

The GroupItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GroupItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..AnySibling Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..GetProperty Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..GetRealType Method
GroupItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GroupItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.GroupItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GroupItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..GetRectangle Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..Highlight Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..InvokeMethod Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..IsHitTest Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..NextSibling Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..Parent Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..PreviousSibling Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..ScrollToVisible Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem..::..SetProperty Method
GroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GroupItem Class
GroupItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GroupItem Properties
GroupItem Class See Also Send Feedback

The GroupItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GroupItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedContentControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl Members
HeaderedContentControl Class Constructors Methods Fields Properties See Also Send Feedback

The HeaderedContentControl type exposes the following members.

Constructors

 | Name | Description
Public method | HeaderedContentControl | Initializes a new instance of the HeaderedContentControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HasHeaderProperty |
HeaderStringFormatProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader |
Public property | HeaderStringFormat |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedContentControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl Constructor
HeaderedContentControl Class See Also Send Feedback
Initializes a new instance of the HeaderedContentControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HeaderedContentControl()
Visual Basic
Public Sub New
Visual C++
public:
HeaderedContentControl()

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedContentControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl Fields
HeaderedContentControl Class See Also Send Feedback

The HeaderedContentControl type exposes the following members.

Fields

Name | Description
HasHeaderProperty |
HeaderStringFormatProperty |

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasHeaderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..HasHeaderProperty Field
HeaderedContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedContentControl.HasHeaderProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasHeaderProperty
Visual Basic
Public Shared HasHeaderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasHeaderProperty

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..HeaderStringFormatProperty Field
HeaderedContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedContentControl.HeaderStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeaderStringFormatProperty
Visual Basic
Public Shared HeaderStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeaderStringFormatProperty

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedContentControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl Methods
HeaderedContentControl Class See Also Send Feedback

The HeaderedContentControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..AnySibling Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..GetProperty Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..GetRealType Method
HeaderedContentControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedContentControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedContentControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..GetRectangle Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..Highlight Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..InvokeMethod Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..IsHitTest Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..NextSibling Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..Parent Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..PreviousSibling Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..ScrollToVisible Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..SetProperty Method
HeaderedContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedContentControl Class
HeaderedContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedContentControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl Properties
HeaderedContentControl Class See Also Send Feedback

The HeaderedContentControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader |
Public property | HeaderStringFormat |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasHeader Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..HasHeader Property
HeaderedContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedContentControl.HasHeader"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasHeader { get; set; }
Visual Basic
Public Property HasHeader As Boolean
    Get
    Set
Visual C++
public:
property bool HasHeader {
    bool get ();
    void set (bool value);
}

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedContentControl..::..HeaderStringFormat Property
HeaderedContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedContentControl.HeaderStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string HeaderStringFormat { get; set; }
Visual Basic
Public Property HeaderStringFormat As String
    Get
    Set
Visual C++
public:
property String^ HeaderStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

HeaderedContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedItemsControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Members
HeaderedItemsControl Class Constructors Methods Fields Properties See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Constructors

 | Name | Description
Public method | HeaderedItemsControl | Initializes a new instance of the HeaderedItemsControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HasHeaderProperty |
HeaderStringFormatProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader |
Public property | HasItems | (Inherited from ItemsControl.)
Public property | HeaderStringFormat |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedItemsControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Constructor
HeaderedItemsControl Class See Also Send Feedback
Initializes a new instance of the HeaderedItemsControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HeaderedItemsControl()
Visual Basic
Public Sub New
Visual C++
public:
HeaderedItemsControl()

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedItemsControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Fields
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Fields

Name | Description
HasHeaderProperty |
HeaderStringFormatProperty |

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasHeaderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..HasHeaderProperty Field
HeaderedItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedItemsControl.HasHeaderProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasHeaderProperty
Visual Basic
Public Shared HasHeaderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasHeaderProperty

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..HeaderStringFormatProperty Field
HeaderedItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedItemsControl.HeaderStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeaderStringFormatProperty
Visual Basic
Public Shared HeaderStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeaderStringFormatProperty

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedItemsControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Methods
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..AnySibling Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..GetProperty Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..GetRealType Method
HeaderedItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedItemsControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedItemsControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..GetRectangle Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..Highlight Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..InvokeMethod Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..IsHitTest Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..NextSibling Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..Parent Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..PreviousSibling Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..ScrollToVisible Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..SetProperty Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderedItemsControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Properties
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader |
Public property | HasItems | (Inherited from ItemsControl.)
Public property | HeaderStringFormat |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasHeader Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..HasHeader Property
HeaderedItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedItemsControl.HasHeader"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasHeader { get; set; }
Visual Basic
Public Property HasHeader As Boolean
    Get
    Set
Visual C++
public:
property bool HasHeader {
    bool get ();
    void set (bool value);
}

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeaderStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..HeaderStringFormat Property
HeaderedItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.HeaderedItemsControl.HeaderStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string HeaderStringFormat { get; set; }
Visual Basic
Public Property HeaderStringFormat As String
    Get
    Set
Visual C++
public:
property String^ HeaderStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HwndHost Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost Members
HwndHost Class Constructors Methods Properties See Also Send Feedback

The HwndHost type exposes the following members.

Constructors

 | Name | Description
Public method | HwndHost | Initializes a new instance of the HwndHost class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HwndHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HwndHost Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost Constructor
HwndHost Class See Also Send Feedback
Initializes a new instance of the HwndHost class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HwndHost()
Visual Basic
Public Sub New
Visual C++
public:
HwndHost()

See Also

HwndHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HwndHost Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost Methods
HwndHost Class See Also Send Feedback

The HwndHost type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

HwndHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..AnySibling Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..GetProperty Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..GetRealType Method
HwndHost Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.HwndHost.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.HwndHost.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

HwndHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..GetRectangle Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..Highlight Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..InvokeMethod Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..IsHitTest Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..NextSibling Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..Parent Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..PreviousSibling Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..ScrollToVisible Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost..::..SetProperty Method
HwndHost Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HwndHost Class
HwndHost Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HwndHost Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HwndHost Properties
HwndHost Class See Also Send Feedback

The HwndHost type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HwndHost Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Hyperlink Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink Members
Hyperlink Class Constructors Methods Fields Properties See Also Send Feedback

The Hyperlink type exposes the following members.

Constructors

 | Name | Description
Public method | Hyperlink | Initializes a new instance of the Hyperlink class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
NavigateUriProperty |
TargetNameProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NavigateUri |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TargetName |
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Hyperlink Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink Constructor
Hyperlink Class See Also Send Feedback
Initializes a new instance of the Hyperlink class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Hyperlink()
Visual Basic
Public Sub New
Visual C++
public:
Hyperlink()

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Hyperlink Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink Fields
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Fields

Name | Description
NavigateUriProperty |
TargetNameProperty |

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigateUriProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..NavigateUriProperty Field
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Hyperlink.NavigateUriProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NavigateUriProperty
Visual Basic
Public Shared NavigateUriProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NavigateUriProperty

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TargetNameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..TargetNameProperty Field
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Hyperlink.TargetNameProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TargetNameProperty
Visual Basic
Public Shared TargetNameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TargetNameProperty

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Hyperlink Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink Methods
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..AnySibling Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..GetProperty Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..GetRealType Method
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Hyperlink.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Hyperlink.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..GetRectangle Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..Highlight Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..InvokeMethod Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..IsHitTest Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..NextSibling Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..Parent Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..PreviousSibling Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..ScrollToVisible Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..SetProperty Method
Hyperlink Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Hyperlink Class
Hyperlink Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Hyperlink Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink Properties
Hyperlink Class See Also Send Feedback

The Hyperlink type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NavigateUri |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TargetName |
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigateUri Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..NavigateUri Property
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Hyperlink.NavigateUri"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string NavigateUri { get; }
Visual Basic
Public ReadOnly Property NavigateUri As String
    Get
Visual C++
public:
virtual property String^ NavigateUri {
    String^ get () sealed;
}

Implements

IHyperlinkButton..::..NavigateUri

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TargetName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Hyperlink..::..TargetName Property
Hyperlink Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Hyperlink.TargetName"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TargetName { get; set; }
Visual Basic
Public Property TargetName As String
    Get
    Set
Visual C++
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}

See Also

Hyperlink Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Image Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Members
Image Class Constructors Methods Fields Properties See Also Send Feedback

The Image type exposes the following members.

Constructors

 | Name | Description
Public method | Image | Initializes a new instance of the Image class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SourceProperty |
StretchDirectionProperty |
StretchProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Image Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Constructor
Image Class See Also Send Feedback
Initializes a new instance of the Image class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Image()
Visual Basic
Public Sub New
Visual C++
public:
Image()

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Image Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Fields
Image Class See Also Send Feedback

The Image type exposes the following members.

Fields

Name | Description
SourceProperty |
StretchDirectionProperty |
StretchProperty |

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..SourceProperty Field
Image Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Image.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..StretchDirectionProperty Field
Image Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Image.StretchDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchDirectionProperty
Visual Basic
Public Shared StretchDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchDirectionProperty

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..StretchProperty Field
Image Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Image.StretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Image Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Methods
Image Class See Also Send Feedback

The Image type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..AnySibling Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..GetProperty Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..GetRealType Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Image.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Image.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..GetRectangle Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..Highlight Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..InvokeMethod Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..IsHitTest Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..NextSibling Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..Parent Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..PreviousSibling Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..ScrollToVisible Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..SetProperty Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Image Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Properties
Image Class See Also Send Feedback

The Image type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..Source Property
Image Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Image.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageSource Source { get; set; }
Visual Basic
Public Property Source As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Source {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Stretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..Stretch Property
Image Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Image.Stretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Stretch Stretch { get; set; }
Visual Basic
Public Property Stretch As Stretch
    Get
    Set
Visual C++
public:
property Stretch Stretch {
    Stretch get ();
    void set (Stretch value);
}

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..StretchDirection Property
Image Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Image.StretchDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StretchDirection StretchDirection { get; set; }
Visual Basic
Public Property StretchDirection As StretchDirection
    Get
    Set
Visual C++
public:
property StretchDirection StretchDirection {
    StretchDirection get ();
    void set (StretchDirection value);
}

See Also

Image Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Members
ImageBrush Class Constructors Methods Fields Properties See Also Send Feedback

The ImageBrush type exposes the following members.

Constructors

 | Name | Description
Public method | ImageBrush | Initializes a new instance of the ImageBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ImageSourceProperty |

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | ImageSource |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch | (Inherited from TileBrush.)
Public property | TileMode | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)
Public property | Viewbox | (Inherited from TileBrush.)
Public property | ViewboxUnits | (Inherited from TileBrush.)
Public property | Viewport | (Inherited from TileBrush.)
Public property | ViewportUnits | (Inherited from TileBrush.)

See Also

ImageBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Constructor
ImageBrush Class See Also Send Feedback
Initializes a new instance of the ImageBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageBrush()
Visual Basic
Public Sub New
Visual C++
public:
ImageBrush()

See Also

ImageBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Fields
ImageBrush Class See Also Send Feedback

The ImageBrush type exposes the following members.

Fields

Name | Description
ImageSourceProperty |

See Also

ImageBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageSourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..ImageSourceProperty Field
ImageBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageBrush.ImageSourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ImageSourceProperty
Visual Basic
Public Shared ImageSourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ImageSourceProperty

See Also

ImageBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Methods
ImageBrush Class See Also Send Feedback

The ImageBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..GetProperty Method
ImageBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageBrush Class
ImageBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..GetRealType Method
ImageBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ImageBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..InvokeMethod Method
ImageBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageBrush Class
ImageBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Properties
ImageBrush Class See Also Send Feedback

The ImageBrush type exposes the following members.

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | ImageSource |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch | (Inherited from TileBrush.)
Public property | TileMode | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)
Public property | Viewbox | (Inherited from TileBrush.)
Public property | ViewboxUnits | (Inherited from TileBrush.)
Public property | Viewport | (Inherited from TileBrush.)
Public property | ViewportUnits | (Inherited from TileBrush.)

See Also

ImageBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageSource Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..ImageSource Property
ImageBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageBrush.ImageSource"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageSource ImageSource { get; set; }
Visual Basic
Public Property ImageSource As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ ImageSource {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

See Also

ImageBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageDrawing Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing Members
ImageDrawing Class Constructors Methods Fields Properties See Also Send Feedback

The ImageDrawing type exposes the following members.

Constructors

 | Name | Description
Public method | ImageDrawing | Initializes a new instance of the ImageDrawing class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Drawing..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ImageSourceProperty |
RectProperty |

Properties

 | Name | Description
Public property | ImageSource |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rect |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageDrawing Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing Constructor
ImageDrawing Class See Also Send Feedback
Initializes a new instance of the ImageDrawing class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageDrawing()
Visual Basic
Public Sub New
Visual C++
public:
ImageDrawing()

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageDrawing Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing Fields
ImageDrawing Class See Also Send Feedback

The ImageDrawing type exposes the following members.

Fields

Name | Description
ImageSourceProperty |
RectProperty |

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageSourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing..::..ImageSourceProperty Field
ImageDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageDrawing.ImageSourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ImageSourceProperty
Visual Basic
Public Shared ImageSourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ImageSourceProperty

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RectProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing..::..RectProperty Field
ImageDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageDrawing.RectProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RectProperty
Visual Basic
Public Shared RectProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RectProperty

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageDrawing Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing Methods
ImageDrawing Class See Also Send Feedback

The ImageDrawing type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Drawing..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing..::..GetProperty Method
ImageDrawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageDrawing Class
ImageDrawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing..::..GetRealType Method
ImageDrawing Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageDrawing.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageDrawing.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing..::..InvokeMethod Method
ImageDrawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageDrawing Class
ImageDrawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageDrawing Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing Properties
ImageDrawing Class See Also Send Feedback

The ImageDrawing type exposes the following members.

Properties

 | Name | Description
Public property | ImageSource |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rect |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageSource Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing..::..ImageSource Property
ImageDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageDrawing.ImageSource"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageSource ImageSource { get; set; }
Visual Basic
Public Property ImageSource As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ ImageSource {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rect Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageDrawing..::..Rect Property
ImageDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageDrawing.Rect"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect Rect { get; set; }
Visual Basic
Public Property Rect As Rect
    Get
    Set
Visual C++
public:
property Rect^ Rect {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

ImageDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageSource Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource Members
ImageSource Class Constructors Methods Properties See Also Send Feedback

The ImageSource type exposes the following members.

Constructors

 | Name | Description
Public method | ImageSource | Initializes a new instance of the ImageSource class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageSource Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource Constructor
ImageSource Class See Also Send Feedback
Initializes a new instance of the ImageSource class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageSource()
Visual Basic
Public Sub New
Visual C++
public:
ImageSource()

See Also

ImageSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageSource Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource Methods
ImageSource Class See Also Send Feedback

The ImageSource type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource..::..GetProperty Method
ImageSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageSource Class
ImageSource Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource..::..GetRealType Method
ImageSource Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageSource.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImageSource.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ImageSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource..::..InvokeMethod Method
ImageSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageSource Class
ImageSource Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImageSource Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource Properties
ImageSource Class See Also Send Feedback

The ImageSource type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageSource Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImplicitInputBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush Members
ImplicitInputBrush Class Constructors Methods Properties See Also Send Feedback

The ImplicitInputBrush type exposes the following members.

Constructors

 | Name | Description
Public method | ImplicitInputBrush | Initializes a new instance of the ImplicitInputBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Transform | (Inherited from Brush.)

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImplicitInputBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush Constructor
ImplicitInputBrush Class See Also Send Feedback
Initializes a new instance of the ImplicitInputBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImplicitInputBrush()
Visual Basic
Public Sub New
Visual C++
public:
ImplicitInputBrush()

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImplicitInputBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush Methods
ImplicitInputBrush Class See Also Send Feedback

The ImplicitInputBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush..::..GetProperty Method
ImplicitInputBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImplicitInputBrush Class
ImplicitInputBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush..::..GetRealType Method
ImplicitInputBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImplicitInputBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ImplicitInputBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush..::..InvokeMethod Method
ImplicitInputBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImplicitInputBrush Class
ImplicitInputBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ImplicitInputBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush Properties
ImplicitInputBrush Class See Also Send Feedback

The ImplicitInputBrush type exposes the following members.

Properties

 | Name | Description
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Transform | (Inherited from Brush.)

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkCanvas Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas Members
InkCanvas Class Constructors Methods Fields Properties See Also Send Feedback

The InkCanvas type exposes the following members.

Constructors

 | Name | Description
Public method | InkCanvas | Initializes a new instance of the InkCanvas class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ActiveEditingModeProperty |
BackgroundProperty |
EditingModeInvertedProperty |
EditingModeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActiveEditingMode |
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EditingMode |
Public property | EditingModeInverted |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkCanvas Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas Constructor
InkCanvas Class See Also Send Feedback
Initializes a new instance of the InkCanvas class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InkCanvas()
Visual Basic
Public Sub New
Visual C++
public:
InkCanvas()

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkCanvas Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas Fields
InkCanvas Class See Also Send Feedback

The InkCanvas type exposes the following members.

Fields

Name | Description
ActiveEditingModeProperty |
BackgroundProperty |
EditingModeInvertedProperty |
EditingModeProperty |

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ActiveEditingModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..ActiveEditingModeProperty Field
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.ActiveEditingModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ActiveEditingModeProperty
Visual Basic
Public Shared ActiveEditingModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ActiveEditingModeProperty

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..BackgroundProperty Field
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EditingModeInvertedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..EditingModeInvertedProperty Field
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.EditingModeInvertedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EditingModeInvertedProperty
Visual Basic
Public Shared EditingModeInvertedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EditingModeInvertedProperty

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EditingModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..EditingModeProperty Field
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.EditingModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EditingModeProperty
Visual Basic
Public Shared EditingModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EditingModeProperty

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkCanvas Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas Methods
InkCanvas Class See Also Send Feedback

The InkCanvas type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..AnySibling Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..GetProperty Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..GetRealType Method
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..GetRectangle Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..Highlight Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..InvokeMethod Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..IsHitTest Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..NextSibling Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..Parent Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..PreviousSibling Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..ScrollToVisible Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..SetProperty Method
InkCanvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkCanvas Class
InkCanvas Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkCanvas Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas Properties
InkCanvas Class See Also Send Feedback

The InkCanvas type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActiveEditingMode |
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EditingMode |
Public property | EditingModeInverted |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ActiveEditingMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..ActiveEditingMode Property
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.ActiveEditingMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InkCanvasEditingMode ActiveEditingMode { get; set; }
Visual Basic
Public Property ActiveEditingMode As InkCanvasEditingMode
    Get
    Set
Visual C++
public:
property InkCanvasEditingMode ActiveEditingMode {
    InkCanvasEditingMode get ();
    void set (InkCanvasEditingMode value);
}

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..Background Property
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EditingMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..EditingMode Property
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.EditingMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InkCanvasEditingMode EditingMode { get; set; }
Visual Basic
Public Property EditingMode As InkCanvasEditingMode
    Get
    Set
Visual C++
public:
property InkCanvasEditingMode EditingMode {
    InkCanvasEditingMode get ();
    void set (InkCanvasEditingMode value);
}

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EditingModeInverted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkCanvas..::..EditingModeInverted Property
InkCanvas Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkCanvas.EditingModeInverted"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InkCanvasEditingMode EditingModeInverted { get; set; }
Visual Basic
Public Property EditingModeInverted As InkCanvasEditingMode
    Get
    Set
Visual C++
public:
property InkCanvasEditingMode EditingModeInverted {
    InkCanvasEditingMode get ();
    void set (InkCanvasEditingMode value);
}

See Also

InkCanvas Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter Members
InkPresenter Class Constructors Methods Properties See Also Send Feedback

The InkPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | InkPresenter | Initializes a new instance of the InkPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

InkPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter Constructor
InkPresenter Class See Also Send Feedback
Initializes a new instance of the InkPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InkPresenter()
Visual Basic
Public Sub New
Visual C++
public:
InkPresenter()

See Also

InkPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter Methods
InkPresenter Class See Also Send Feedback

The InkPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..AnySibling Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..GetProperty Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..GetRealType Method
InkPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InkPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

InkPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..GetRectangle Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..Highlight Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..InvokeMethod Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..IsHitTest Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..NextSibling Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..Parent Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..PreviousSibling Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..ScrollToVisible Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..SetProperty Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InkPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter Properties
InkPresenter Class See Also Send Feedback

The InkPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

InkPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Inline Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Members
Inline Class Constructors Methods Properties See Also Send Feedback

The Inline type exposes the following members.

Constructors

 | Name | Description
Public method | Inline | Initializes a new instance of the Inline class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Background |
Public property | FlowDirection |
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Inline Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Constructor
Inline Class See Also Send Feedback
Initializes a new instance of the Inline class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Inline(
    Inline inline
)
Visual Basic
Public Sub New ( _
    inline As Inline _
)
Visual C++
public:
Inline(
    Inline^ inline
)

Parameters

inline
Type: System.Windows.Documents..::..Inline

[Missing <param name="inline"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.#ctor(System.Windows.Documents.Inline)"]

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Inline Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Methods
Inline Class See Also Send Feedback

The Inline type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Inline Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline Properties
Inline Class See Also Send Feedback

The Inline type exposes the following members.

Properties

 | Name | Description
Public property | Background |
Public property | FlowDirection |
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..Background Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; }
Visual Basic
Public ReadOnly Property Background As Brush
    Get
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FlowDirection Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.FlowDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDirection FlowDirection { get; private set; }
Visual Basic
Public Property FlowDirection As FlowDirection
    Get
    Private Set
Visual C++
public:
property FlowDirection FlowDirection {
    FlowDirection get ();
    private: void set (FlowDirection value);
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontFamily Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.FontFamily"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontSize Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.FontSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; private set; }
Visual Basic
Public Property FontSize As Double
    Get
    Private Set
Visual C++
public:
property double FontSize {
    double get ();
    private: void set (double value);
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontStretch Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.FontStretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic
Public ReadOnly Property FontStretch As FontStretch
    Get
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontStyle Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.FontStyle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyle FontStyle { get; }
Visual Basic
Public ReadOnly Property FontStyle As FontStyle
    Get
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..FontWeight Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.FontWeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic
Public ReadOnly Property FontWeight As FontWeight
    Get
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Inline..::..Foreground Property
Inline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline.Foreground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; }
Visual Basic
Public ReadOnly Property Foreground As Brush
    Get
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
}

See Also

Inline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InlineCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Members
InlineCollection Class Constructors Methods Properties See Also Send Feedback

The InlineCollection type exposes the following members.

Constructors

 | Name | Description
Public method | InlineCollection | Initializes a new instance of the InlineCollection class

Methods

 | Name | Description
Public method | Add |
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InlineCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Constructor
InlineCollection Class See Also Send Feedback
Initializes a new instance of the InlineCollection class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InlineCollection()
Visual Basic
Public Sub New
Visual C++
public:
InlineCollection()

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InlineCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Methods
InlineCollection Class See Also Send Feedback

The InlineCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf |
Public method | Insert |
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | RemoveAt |
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Add Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Add Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Add(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Add(
    Inline item
)
Visual Basic
Public Sub Add ( _
    item As Inline _
)
Visual C++
public:
virtual void Add(
    Inline^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Controls.Xaml.Wpf..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Add(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Clear Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Clear"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Contains Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Contains Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Contains(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Contains(
    Inline item
)
Visual Basic
Public Function Contains ( _
    item As Inline _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Inline^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Controls.Xaml.Wpf..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Contains(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Contains(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CopyTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..CopyTo Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.CopyTo(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline[],System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CopyTo(
    Inline[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo ( _
    array As Inline(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<Inline^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< ArtOfTest.WebAii.Controls.Xaml.Wpf..::..Inline >[]()[][]

[Missing <param name="array"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.CopyTo(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline[],System.Int32)"]

arrayIndex
Type: System..::..Int32

[Missing <param name="arrayIndex"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.CopyTo(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline[],System.Int32)"]

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FromRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..FromRealObject Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.FromRealObject(System.Object)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void FromRealObject(
    Object obj
)
Visual Basic
Public Overrides Sub FromRealObject ( _
    obj As Object _
)
Visual C++
public:
virtual void FromRealObject(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.FromRealObject(System.Object)"]

Implements

IPeerConverter..::..FromRealObject(Object)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetEnumerator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..GetEnumerator Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.GetEnumerator"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.GetEnumerator"]

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..GetProperty Method
InlineCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InlineCollection Class
InlineCollection Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..GetRealType Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IndexOf Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..IndexOf Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.IndexOf(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int IndexOf(
    Inline item
)
Visual Basic
Public Function IndexOf ( _
    item As Inline _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Inline^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Controls.Xaml.Wpf..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.IndexOf(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.IndexOf(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Insert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Insert Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Insert(System.Int32,ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Insert(
    int index,
    Inline item
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    item As Inline _
)
Visual C++
public:
virtual void Insert(
    int index,
    Inline^ item
) sealed

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Insert(System.Int32,ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

item
Type: ArtOfTest.WebAii.Controls.Xaml.Wpf..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Insert(System.Int32,ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..InvokeMethod Method
InlineCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InlineCollection Class
InlineCollection Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Remove Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Remove Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Remove(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Remove(
    Inline item
)
Visual Basic
Public Function Remove ( _
    item As Inline _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Inline^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Controls.Xaml.Wpf..::..Inline

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Remove(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Remove(ArtOfTest.WebAii.Controls.Xaml.Wpf.Inline)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RemoveAt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..RemoveAt Method
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.RemoveAt(System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.RemoveAt(System.Int32)"]

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InlineCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection Properties
InlineCollection Class See Also Send Feedback

The InlineCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Count Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Count Property
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Count"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..IsReadOnly Property
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InlineCollection..::..Item Property
InlineCollection Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.InlineCollection.Item(System.Int32)"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Inline this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As Inline
    Get
    Set
Visual C++
public:
virtual property Inline^ default[int index] {
    Inline^ get (int index) sealed;
    void set (int index, Inline^ value) sealed;
}

Parameters

index
Type: System..::..Int32

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

InlineCollection Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Int32Rect Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect Members
Int32Rect Class Constructors Methods Fields Properties See Also Send Feedback

The Int32Rect type exposes the following members.

Constructors

 | Name | Description
Public method | Int32Rect | Initializes a new instance of the Int32Rect class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
HeightProperty |
IsEmptyProperty |
WidthProperty |
XProperty |
YProperty |

Properties

 | Name | Description
Public property | Height |
Public property | IsEmpty |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Width |
Public property | X |
Public property | Y |

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Int32Rect Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect Constructor
Int32Rect Class See Also Send Feedback
Initializes a new instance of the Int32Rect class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Int32Rect()
Visual Basic
Public Sub New
Visual C++
public:
Int32Rect()

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Int32Rect Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect Fields
Int32Rect Class See Also Send Feedback

The Int32Rect type exposes the following members.

Fields

Name | Description
HeightProperty |
IsEmptyProperty |
WidthProperty |
XProperty |
YProperty |

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..HeightProperty Field
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.HeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeightProperty
Visual Basic
Public Shared HeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeightProperty

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEmptyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..IsEmptyProperty Field
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.IsEmptyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEmptyProperty
Visual Basic
Public Shared IsEmptyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEmptyProperty

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..WidthProperty Field
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.WidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..XProperty Field
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.XProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..YProperty Field
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.YProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Int32Rect Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect Methods
Int32Rect Class See Also Send Feedback

The Int32Rect type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..GetProperty Method
Int32Rect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Int32Rect Class
Int32Rect Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..GetRealType Method
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..InvokeMethod Method
Int32Rect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Int32Rect Class
Int32Rect Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Int32Rect Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect Properties
Int32Rect Class See Also Send Feedback

The Int32Rect type exposes the following members.

Properties

 | Name | Description
Public property | Height |
Public property | IsEmpty |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Width |
Public property | X |
Public property | Y |

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..Height Property
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.Height"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int Height { get; set; }
Visual Basic
Public Overridable Property Height As Integer
    Get
    Set
Visual C++
public:
virtual property int Height {
    int get ();
    void set (int value);
}

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEmpty Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..IsEmpty Property
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.IsEmpty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsEmpty { get; set; }
Visual Basic
Public Overridable Property IsEmpty As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
    void set (bool value);
}

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..Width Property
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.Width"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int Width { get; set; }
Visual Basic
Public Overridable Property Width As Integer
    Get
    Set
Visual C++
public:
virtual property int Width {
    int get ();
    void set (int value);
}

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..X Property
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.X"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int X { get; set; }
Visual Basic
Public Overridable Property X As Integer
    Get
    Set
Visual C++
public:
virtual property int X {
    int get ();
    void set (int value);
}

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Int32Rect..::..Y Property
Int32Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Int32Rect.Y"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int Y { get; set; }
Visual Basic
Public Overridable Property Y As Integer
    Get
    Set
Visual C++
public:
virtual property int Y {
    int get ();
    void set (int value);
}

See Also

Int32Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InteropBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InteropBitmap Members
InteropBitmap Class Constructors Methods Properties See Also Send Feedback

The InteropBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | InteropBitmap | Initializes a new instance of the InteropBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InteropBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InteropBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InteropBitmap Constructor
InteropBitmap Class See Also Send Feedback
Initializes a new instance of the InteropBitmap class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InteropBitmap()
Visual Basic
Public Sub New
Visual C++
public:
InteropBitmap()

See Also

InteropBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InteropBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InteropBitmap Methods
InteropBitmap Class See Also Send Feedback

The InteropBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteropBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InteropBitmap..::..GetProperty Method
InteropBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InteropBitmap Class
InteropBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InteropBitmap..::..GetRealType Method
InteropBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InteropBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.InteropBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

InteropBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InteropBitmap..::..InvokeMethod Method
InteropBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InteropBitmap Class
InteropBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InteropBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InteropBitmap Properties
InteropBitmap Class See Also Send Feedback

The InteropBitmap type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InteropBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Members
ItemsControl Class Constructors Methods Fields Properties See Also Send Feedback

The ItemsControl type exposes the following members.

Constructors

 | Name | Description
Public method | ItemsControl | Initializes a new instance of the ItemsControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AlternationCountProperty |
DisplayMemberPathProperty |
HasItemsProperty |
IsGroupingProperty |
IsTextSearchEnabledProperty |
ItemBindingGroupProperty |
ItemStringFormatProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup |
Public property | ItemStringFormat |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Constructor
ItemsControl Class See Also Send Feedback
Initializes a new instance of the ItemsControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ItemsControl()
Visual Basic
Public Sub New
Visual C++
public:
ItemsControl()

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Fields
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Fields

Name | Description
AlternationCountProperty |
DisplayMemberPathProperty |
HasItemsProperty |
IsGroupingProperty |
IsTextSearchEnabledProperty |
ItemBindingGroupProperty |
ItemStringFormatProperty |

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlternationCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..AlternationCountProperty Field
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.AlternationCountProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlternationCountProperty
Visual Basic
Public Shared AlternationCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlternationCountProperty

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayMemberPathProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..DisplayMemberPathProperty Field
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.DisplayMemberPathProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayMemberPathProperty
Visual Basic
Public Shared DisplayMemberPathProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayMemberPathProperty

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasItemsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..HasItemsProperty Field
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.HasItemsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasItemsProperty
Visual Basic
Public Shared HasItemsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasItemsProperty

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsGroupingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..IsGroupingProperty Field
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.IsGroupingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsGroupingProperty
Visual Basic
Public Shared IsGroupingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsGroupingProperty

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTextSearchEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..IsTextSearchEnabledProperty Field
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.IsTextSearchEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTextSearchEnabledProperty
Visual Basic
Public Shared IsTextSearchEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTextSearchEnabledProperty

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemBindingGroupProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..ItemBindingGroupProperty Field
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.ItemBindingGroupProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemBindingGroupProperty
Visual Basic
Public Shared ItemBindingGroupProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemBindingGroupProperty

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..ItemStringFormatProperty Field
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.ItemStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemStringFormatProperty
Visual Basic
Public Shared ItemStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemStringFormatProperty

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Methods
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..AnySibling Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..GetProperty Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..GetRealType Method
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..GetRectangle Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..Highlight Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..InvokeMethod Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..IsHitTest Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..NextSibling Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..Parent Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..PreviousSibling Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..ScrollToVisible Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..SetProperty Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Properties
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup |
Public property | ItemStringFormat |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlternationCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..AlternationCount Property
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.AlternationCount"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AlternationCount { get; set; }
Visual Basic
Public Property AlternationCount As Integer
    Get
    Set
Visual C++
public:
property int AlternationCount {
    int get ();
    void set (int value);
}

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayMemberPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..DisplayMemberPath Property
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.DisplayMemberPath"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DisplayMemberPath { get; set; }
Visual Basic
Public Property DisplayMemberPath As String
    Get
    Set
Visual C++
public:
property String^ DisplayMemberPath {
    String^ get ();
    void set (String^ value);
}

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasItems Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..HasItems Property
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.HasItems"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasItems { get; set; }
Visual Basic
Public Property HasItems As Boolean
    Get
    Set
Visual C++
public:
property bool HasItems {
    bool get ();
    void set (bool value);
}

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsGrouping Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..IsGrouping Property
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.IsGrouping"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsGrouping { get; set; }
Visual Basic
Public Property IsGrouping As Boolean
    Get
    Set
Visual C++
public:
property bool IsGrouping {
    bool get ();
    void set (bool value);
}

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTextSearchEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..IsTextSearchEnabled Property
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.IsTextSearchEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTextSearchEnabled { get; set; }
Visual Basic
Public Property IsTextSearchEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsTextSearchEnabled {
    bool get ();
    void set (bool value);
}

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemBindingGroup Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..ItemBindingGroup Property
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.ItemBindingGroup"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BindingGroup ItemBindingGroup { get; set; }
Visual Basic
Public Property ItemBindingGroup As BindingGroup
    Get
    Set
Visual C++
public:
property BindingGroup^ ItemBindingGroup {
    BindingGroup^ get ();
    void set (BindingGroup^ value);
}

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..ItemStringFormat Property
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsControl.ItemStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ItemStringFormat { get; set; }
Visual Basic
Public Property ItemStringFormat As String
    Get
    Set
Visual C++
public:
property String^ ItemStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

ItemsControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter Members
ItemsPresenter Class Constructors Methods Properties See Also Send Feedback

The ItemsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemsPresenter | Initializes a new instance of the ItemsPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter Constructor
ItemsPresenter Class See Also Send Feedback
Initializes a new instance of the ItemsPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ItemsPresenter()
Visual Basic
Public Sub New
Visual C++
public:
ItemsPresenter()

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter Methods
ItemsPresenter Class See Also Send Feedback

The ItemsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..AnySibling Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..GetProperty Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..GetRealType Method
ItemsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ItemsPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..GetRectangle Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..Highlight Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..InvokeMethod Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..IsHitTest Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..NextSibling Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..Parent Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..PreviousSibling Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..ScrollToVisible Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..SetProperty Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter Properties
ItemsPresenter Class See Also Send Feedback

The ItemsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Label Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Members
Label Class Constructors Methods Properties See Also Send Feedback

The Label type exposes the following members.

Constructors

 | Name | Description
Public method | Label | Initializes a new instance of the Label class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Label Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Label Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Constructor
Label Class See Also Send Feedback
Initializes a new instance of the Label class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Label()
Visual Basic
Public Sub New
Visual C++
public:
Label()

See Also

Label Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Label Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Methods
Label Class See Also Send Feedback

The Label type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Label Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..AnySibling Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..GetProperty Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..GetRealType Method
Label Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Label.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Label.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Label Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..GetRectangle Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..Highlight Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..InvokeMethod Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..IsHitTest Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..NextSibling Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..Parent Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..PreviousSibling Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..ScrollToVisible Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..SetProperty Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Label Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Properties
Label Class See Also Send Feedback

The Label type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Label Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Line Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Members
Line Class Constructors Methods Fields Properties See Also Send Feedback

The Line type exposes the following members.

Constructors

 | Name | Description
Public method | Line | Initializes a new instance of the Line class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
X1Property |
X2Property |
Y1Property |
Y2Property |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | X1 |
Public property | X2 |
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Y1 |
Public property | Y2 |

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Line Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Constructor
Line Class See Also Send Feedback
Initializes a new instance of the Line class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Line()
Visual Basic
Public Sub New
Visual C++
public:
Line()

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Line Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Fields
Line Class See Also Send Feedback

The Line type exposes the following members.

Fields

Name | Description
X1Property |
X2Property |
Y1Property |
Y2Property |

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X1Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..X1Property Field
Line Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.X1Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty X1Property
Visual Basic
Public Shared X1Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ X1Property

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X2Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..X2Property Field
Line Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.X2Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty X2Property
Visual Basic
Public Shared X2Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ X2Property

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y1Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Y1Property Field
Line Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.Y1Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Y1Property
Visual Basic
Public Shared Y1Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Y1Property

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y2Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Y2Property Field
Line Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.Y2Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Y2Property
Visual Basic
Public Shared Y2Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Y2Property

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Line Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..AnySibling Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..GetProperty Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..GetRealType Method
Line Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..GetRectangle Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Highlight Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..InvokeMethod Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..IsHitTest Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..NextSibling Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Parent Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..PreviousSibling Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..ScrollToVisible Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..SetProperty Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Line Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | X1 |
Public property | X2 |
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Y1 |
Public property | Y2 |

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X1 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..X1 Property
Line Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.X1"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double X1 { get; set; }
Visual Basic
Public Property X1 As Double
    Get
    Set
Visual C++
public:
property double X1 {
    double get ();
    void set (double value);
}

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X2 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..X2 Property
Line Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.X2"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double X2 { get; set; }
Visual Basic
Public Property X2 As Double
    Get
    Set
Visual C++
public:
property double X2 {
    double get ();
    void set (double value);
}

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y1 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Y1 Property
Line Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.Y1"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Y1 { get; set; }
Visual Basic
Public Property Y1 As Double
    Get
    Set
Visual C++
public:
property double Y1 {
    double get ();
    void set (double value);
}

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y2 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Y2 Property
Line Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Line.Y2"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Y2 { get; set; }
Visual Basic
Public Property Y2 As Double
    Get
    Set
Visual C++
public:
property double Y2 {
    double get ();
    void set (double value);
}

See Also

Line Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearClipper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper Members
LinearClipper Class Constructors Methods Fields Properties See Also Send Feedback

The LinearClipper type exposes the following members.

Constructors

 | Name | Description
Public method | LinearClipper | Initializes a new instance of the LinearClipper class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Clipper..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ExpandDirectionProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExpandDirection |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RatioVisible | (Inherited from Clipper.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

LinearClipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearClipper Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper Constructor
LinearClipper Class See Also Send Feedback
Initializes a new instance of the LinearClipper class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LinearClipper()
Visual Basic
Public Sub New
Visual C++
public:
LinearClipper()

See Also

LinearClipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearClipper Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper Fields
LinearClipper Class See Also Send Feedback

The LinearClipper type exposes the following members.

Fields

Name | Description
ExpandDirectionProperty |

See Also

LinearClipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..ExpandDirectionProperty Field
LinearClipper Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearClipper.ExpandDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExpandDirectionProperty
Visual Basic
Public Shared ExpandDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExpandDirectionProperty

See Also

LinearClipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearClipper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper Methods
LinearClipper Class See Also Send Feedback

The LinearClipper type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Clipper..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

LinearClipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..AnySibling Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..GetProperty Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..GetRealType Method
LinearClipper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearClipper.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearClipper.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

LinearClipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..GetRectangle Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..Highlight Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..InvokeMethod Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..IsHitTest Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..NextSibling Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..Parent Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..PreviousSibling Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..ScrollToVisible Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..SetProperty Method
LinearClipper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LinearClipper Class
LinearClipper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearClipper Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper Properties
LinearClipper Class See Also Send Feedback

The LinearClipper type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExpandDirection |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RatioVisible | (Inherited from Clipper.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

LinearClipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExpandDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearClipper..::..ExpandDirection Property
LinearClipper Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearClipper.ExpandDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExpandDirection ExpandDirection { get; set; }
Visual Basic
Public Property ExpandDirection As ExpandDirection
    Get
    Set
Visual C++
public:
property ExpandDirection ExpandDirection {
    ExpandDirection get ();
    void set (ExpandDirection value);
}

See Also

LinearClipper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearGradientBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Members
LinearGradientBrush Class Constructors Methods Fields Properties See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Constructors

 | Name | Description
Public method | LinearGradientBrush | Initializes a new instance of the LinearGradientBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides GradientBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
EndPointProperty |
StartPointProperty |

Properties

 | Name | Description
Public property | ColorInterpolationMode | (Inherited from GradientBrush.)
Public property | EndPoint |
Public property | GradientStops | (Inherited from GradientBrush.)
Public property | MappingMode | (Inherited from GradientBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod | (Inherited from GradientBrush.)
Public property | StartPoint |
Public property | Transform | (Inherited from Brush.)

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearGradientBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Constructor
LinearGradientBrush Class See Also Send Feedback
Initializes a new instance of the LinearGradientBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LinearGradientBrush()
Visual Basic
Public Sub New
Visual C++
public:
LinearGradientBrush()

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearGradientBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Fields
LinearGradientBrush Class See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Fields

Name | Description
EndPointProperty |
StartPointProperty |

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EndPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..EndPointProperty Field
LinearGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearGradientBrush.EndPointProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EndPointProperty
Visual Basic
Public Shared EndPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EndPointProperty

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StartPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..StartPointProperty Field
LinearGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearGradientBrush.StartPointProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StartPointProperty
Visual Basic
Public Shared StartPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StartPointProperty

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearGradientBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Methods
LinearGradientBrush Class See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides GradientBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..GetProperty Method
LinearGradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LinearGradientBrush Class
LinearGradientBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..GetRealType Method
LinearGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearGradientBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearGradientBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..InvokeMethod Method
LinearGradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LinearGradientBrush Class
LinearGradientBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LinearGradientBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Properties
LinearGradientBrush Class See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | ColorInterpolationMode | (Inherited from GradientBrush.)
Public property | EndPoint |
Public property | GradientStops | (Inherited from GradientBrush.)
Public property | MappingMode | (Inherited from GradientBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod | (Inherited from GradientBrush.)
Public property | StartPoint |
Public property | Transform | (Inherited from Brush.)

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EndPoint Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..EndPoint Property
LinearGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearGradientBrush.EndPoint"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic
Public Property EndPoint As Point
    Get
    Set
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StartPoint Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..StartPoint Property
LinearGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.LinearGradientBrush.StartPoint"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic
Public Property StartPoint As Point
    Get
    Set
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Members
LineGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The LineGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | LineGeometry | Initializes a new instance of the LineGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
EndPointProperty |
StartPointProperty |

Properties

 | Name | Description
Public property | EndPoint |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | StartPoint |
Public property | Transform | (Inherited from Geometry.)

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Constructor
LineGeometry Class See Also Send Feedback
Initializes a new instance of the LineGeometry class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LineGeometry()
Visual Basic
Public Sub New
Visual C++
public:
LineGeometry()

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Fields
LineGeometry Class See Also Send Feedback

The LineGeometry type exposes the following members.

Fields

Name | Description
EndPointProperty |
StartPointProperty |

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EndPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..EndPointProperty Field
LineGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.LineGeometry.EndPointProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EndPointProperty
Visual Basic
Public Shared EndPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EndPointProperty

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StartPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..StartPointProperty Field
LineGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.LineGeometry.StartPointProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StartPointProperty
Visual Basic
Public Shared StartPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StartPointProperty

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Methods
LineGeometry Class See Also Send Feedback

The LineGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..GetProperty Method
LineGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LineGeometry Class
LineGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..GetRealType Method
LineGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.LineGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.LineGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..InvokeMethod Method
LineGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LineGeometry Class
LineGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Properties
LineGeometry Class See Also Send Feedback

The LineGeometry type exposes the following members.

Properties

 | Name | Description
Public property | EndPoint |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | StartPoint |
Public property | Transform | (Inherited from Geometry.)

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EndPoint Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..EndPoint Property
LineGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.LineGeometry.EndPoint"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point EndPoint { get; set; }
Visual Basic
Public Property EndPoint As Point
    Get
    Set
Visual C++
public:
property Point^ EndPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StartPoint Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..StartPoint Property
LineGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.LineGeometry.StartPoint"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point StartPoint { get; set; }
Visual Basic
Public Property StartPoint As Point
    Get
    Set
Visual C++
public:
property Point^ StartPoint {
    Point^ get ();
    void set (Point^ value);
}

See Also

LineGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Members
ListBox Class Constructors Methods Fields Properties See Also Send Feedback

The ListBox type exposes the following members.

Constructors

 | Name | Description
Public method | ListBox | Initializes a new instance of the ListBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ItemsProperty |
SelectionModeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | Items |
Public property | ItemsPanel | Get the element holding the list box items.
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | ListBoxItems | Get the list box items.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionMode |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Constructor
ListBox Class See Also Send Feedback
Initializes a new instance of the ListBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ListBox()
Visual Basic
Public Sub New
Visual C++
public:
ListBox()

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Fields
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Fields

Name | Description
ItemsProperty |
SelectionModeProperty |

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..ItemsProperty Field
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBox.ItemsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemsProperty
Visual Basic
Public Shared ItemsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemsProperty

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..SelectionModeProperty Field
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBox.SelectionModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionModeProperty
Visual Basic
Public Shared SelectionModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionModeProperty

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Methods
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..AnySibling Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..AssignReference Method
ListBox Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..GetProperty Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..GetRealType Method
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..GetRectangle Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..Highlight Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..InvokeMethod Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..IsHitTest Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..NextSibling Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..Parent Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..PreviousSibling Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..ScrollToVisible Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..SetProperty Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Properties
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | Items |
Public property | ItemsPanel | Get the element holding the list box items.
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | ListBoxItems | Get the list box items.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionMode |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..Items Property
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBox.Items"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ItemCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As ItemCollection
    Get
Visual C++
public:
virtual property ItemCollection^ Items {
    ItemCollection^ get () sealed;
}

Implements

IListBox..::..Items

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsPanel Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..ItemsPanel Property
ListBox Class See Also Send Feedback
Get the element holding the list box items.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ItemsPanel { get; }
Visual Basic
Public Overridable ReadOnly Property ItemsPanel As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ItemsPanel {
    FrameworkElement^ get ();
}

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBoxItems Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..ListBoxItems Property
ListBox Class See Also Send Feedback
Get the list box items.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<IListBoxItem> ListBoxItems { get; }
Visual Basic
Public ReadOnly Property ListBoxItems As List(Of IListBoxItem)
    Get
Visual C++
public:
virtual property List<IListBoxItem^>^ ListBoxItems {
    List<IListBoxItem^>^ get () sealed;
}

Implements

IListBox..::..ListBoxItems

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..SelectionMode Property
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBox.SelectionMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As SelectionMode
    Get
    Set
Visual C++
public:
property SelectionMode SelectionMode {
    SelectionMode get ();
    void set (SelectionMode value);
}

See Also

ListBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBoxItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Members
ListBoxItem Class Constructors Methods Fields Properties See Also Send Feedback

The ListBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | ListBoxItem | Initializes a new instance of the ListBoxItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsSelectedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBoxItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Constructor
ListBoxItem Class See Also Send Feedback
Initializes a new instance of the ListBoxItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ListBoxItem()
Visual Basic
Public Sub New
Visual C++
public:
ListBoxItem()

See Also

ListBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBoxItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Fields
ListBoxItem Class See Also Send Feedback

The ListBoxItem type exposes the following members.

Fields

Name | Description
IsSelectedProperty |

See Also

ListBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..IsSelectedProperty Field
ListBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBoxItem.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

ListBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBoxItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Methods
ListBoxItem Class See Also Send Feedback

The ListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..AnySibling Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..GetProperty Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..GetRealType Method
ListBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBoxItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBoxItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ListBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..GetRectangle Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..Highlight Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..InvokeMethod Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..IsHitTest Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..NextSibling Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..Parent Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..PreviousSibling Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..ScrollToVisible Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..SetProperty Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListBoxItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Properties
ListBoxItem Class See Also Send Feedback

The ListBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..IsSelected Property
ListBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListBoxItem.IsSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsSelected {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IListBoxItem..::..IsSelected

See Also

ListBoxItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView Members
ListView Class Constructors Methods Fields Properties See Also Send Feedback

The ListView type exposes the following members.

Constructors

 | Name | Description
Public method | ListView | Initializes a new instance of the ListView class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from ListBox.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ListBox..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ViewProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | Items | (Inherited from ListBox.)
Public property | ItemsPanel | Get the element holding the list box items. (Inherited from ListBox.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | ListBoxItems | Get the list box items. (Inherited from ListBox.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionMode | (Inherited from ListBox.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | View |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView Constructor
ListView Class See Also Send Feedback
Initializes a new instance of the ListView class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ListView()
Visual Basic
Public Sub New
Visual C++
public:
ListView()

See Also

ListView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListView Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView Fields
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Fields

Name | Description
ViewProperty |

See Also

ListView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..ViewProperty Field
ListView Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListView.ViewProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewProperty
Visual Basic
Public Shared ViewProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewProperty

See Also

ListView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView Methods
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from ListBox.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ListBox..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ListView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..AnySibling Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..GetProperty Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..GetRealType Method
ListView Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListView.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListView.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ListView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..GetRectangle Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..Highlight Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..InvokeMethod Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..IsHitTest Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..NextSibling Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..Parent Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..PreviousSibling Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..ScrollToVisible Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..SetProperty Method
ListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListView Class
ListView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView Properties
ListView Class See Also Send Feedback

The ListView type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | Items | (Inherited from ListBox.)
Public property | ItemsPanel | Get the element holding the list box items. (Inherited from ListBox.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | ListBoxItems | Get the list box items. (Inherited from ListBox.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionMode | (Inherited from ListBox.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | View |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


View Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListView..::..View Property
ListView Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListView.View"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ViewBase View { get; set; }
Visual Basic
Public Property View As ViewBase
    Get
    Set
Visual C++
public:
property ViewBase^ View {
    ViewBase^ get ();
    void set (ViewBase^ value);
}

See Also

ListView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListViewItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem Members
ListViewItem Class Constructors Methods Properties See Also Send Feedback

The ListViewItem type exposes the following members.

Constructors

 | Name | Description
Public method | ListViewItem | Initializes a new instance of the ListViewItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ListBoxItem..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected | (Inherited from ListBoxItem.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListViewItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem Constructor
ListViewItem Class See Also Send Feedback
Initializes a new instance of the ListViewItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ListViewItem()
Visual Basic
Public Sub New
Visual C++
public:
ListViewItem()

See Also

ListViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListViewItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem Methods
ListViewItem Class See Also Send Feedback

The ListViewItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ListBoxItem..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..AnySibling Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..GetProperty Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..GetRealType Method
ListViewItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListViewItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ListViewItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ListViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..GetRectangle Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..Highlight Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..InvokeMethod Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..IsHitTest Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..NextSibling Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..Parent Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..PreviousSibling Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..ScrollToVisible Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem..::..SetProperty Method
ListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListViewItem Class
ListViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ListViewItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewItem Properties
ListViewItem Class See Also Send Feedback

The ListViewItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected | (Inherited from ListBoxItem.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Members
Matrix Class Constructors Methods Fields Properties See Also Send Feedback

The Matrix type exposes the following members.

Constructors

 | Name | Description
Public method | Matrix | Initializes a new instance of the Matrix class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DeterminantProperty |
HasInverseProperty |
IsIdentityProperty |
M11Property |
M12Property |
M21Property |
M22Property |
OffsetXProperty |
OffsetYProperty |

Properties

 | Name | Description
Public property | Determinant |
Public property | HasInverse |
Public property | IsIdentity |
Public property | M11 |
Public property | M12 |
Public property | M21 |
Public property | M22 |
Public property | OffsetX |
Public property | OffsetY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Constructor
Matrix Class See Also Send Feedback
Initializes a new instance of the Matrix class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Matrix()
Visual Basic
Public Sub New
Visual C++
public:
Matrix()

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Fields
Matrix Class See Also Send Feedback

The Matrix type exposes the following members.

Fields

Name | Description
DeterminantProperty |
HasInverseProperty |
IsIdentityProperty |
M11Property |
M12Property |
M21Property |
M22Property |
OffsetXProperty |
OffsetYProperty |

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DeterminantProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..DeterminantProperty Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.DeterminantProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DeterminantProperty
Visual Basic
Public Shared DeterminantProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DeterminantProperty

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasInverseProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..HasInverseProperty Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.HasInverseProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasInverseProperty
Visual Basic
Public Shared HasInverseProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasInverseProperty

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsIdentityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..IsIdentityProperty Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.IsIdentityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsIdentityProperty
Visual Basic
Public Shared IsIdentityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsIdentityProperty

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M11Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M11Property Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.M11Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M11Property
Visual Basic
Public Shared M11Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M11Property

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M12Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M12Property Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.M12Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M12Property
Visual Basic
Public Shared M12Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M12Property

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M21Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M21Property Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.M21Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M21Property
Visual Basic
Public Shared M21Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M21Property

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M22Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M22Property Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.M22Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M22Property
Visual Basic
Public Shared M22Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M22Property

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..OffsetXProperty Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.OffsetXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetXProperty
Visual Basic
Public Shared OffsetXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetXProperty

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..OffsetYProperty Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.OffsetYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetYProperty
Visual Basic
Public Shared OffsetYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetYProperty

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Methods
Matrix Class See Also Send Feedback

The Matrix type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..GetProperty Method
Matrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix Class
Matrix Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..GetRealType Method
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..InvokeMethod Method
Matrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix Class
Matrix Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Properties
Matrix Class See Also Send Feedback

The Matrix type exposes the following members.

Properties

 | Name | Description
Public property | Determinant |
Public property | HasInverse |
Public property | IsIdentity |
Public property | M11 |
Public property | M12 |
Public property | M21 |
Public property | M22 |
Public property | OffsetX |
Public property | OffsetY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Determinant Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..Determinant Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.Determinant"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Determinant { get; set; }
Visual Basic
Public Overridable Property Determinant As Double
    Get
    Set
Visual C++
public:
virtual property double Determinant {
    double get ();
    void set (double value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasInverse Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..HasInverse Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.HasInverse"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool HasInverse { get; set; }
Visual Basic
Public Overridable Property HasInverse As Boolean
    Get
    Set
Visual C++
public:
virtual property bool HasInverse {
    bool get ();
    void set (bool value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsIdentity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..IsIdentity Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.IsIdentity"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsIdentity { get; set; }
Visual Basic
Public Overridable Property IsIdentity As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsIdentity {
    bool get ();
    void set (bool value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M11 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M11 Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.M11"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M11 { get; set; }
Visual Basic
Public Overridable Property M11 As Double
    Get
    Set
Visual C++
public:
virtual property double M11 {
    double get ();
    void set (double value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M12 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M12 Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.M12"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M12 { get; set; }
Visual Basic
Public Overridable Property M12 As Double
    Get
    Set
Visual C++
public:
virtual property double M12 {
    double get ();
    void set (double value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M21 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M21 Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.M21"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M21 { get; set; }
Visual Basic
Public Overridable Property M21 As Double
    Get
    Set
Visual C++
public:
virtual property double M21 {
    double get ();
    void set (double value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M22 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M22 Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.M22"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M22 { get; set; }
Visual Basic
Public Overridable Property M22 As Double
    Get
    Set
Visual C++
public:
virtual property double M22 {
    double get ();
    void set (double value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..OffsetX Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.OffsetX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double OffsetX { get; set; }
Visual Basic
Public Overridable Property OffsetX As Double
    Get
    Set
Visual C++
public:
virtual property double OffsetX {
    double get ();
    void set (double value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..OffsetY Property
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix.OffsetY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double OffsetY { get; set; }
Visual Basic
Public Overridable Property OffsetY As Double
    Get
    Set
Visual C++
public:
virtual property double OffsetY {
    double get ();
    void set (double value);
}

See Also

Matrix Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D Members
Matrix3D Class Constructors Methods Fields Properties See Also Send Feedback

The Matrix3D type exposes the following members.

Constructors

 | Name | Description
Public method | Matrix3D | Initializes a new instance of the Matrix3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DeterminantProperty |
HasInverseProperty |
IdentityProperty |
IsAffineProperty |
IsIdentityProperty |
M11Property |
M12Property |
M13Property |
M14Property |
M21Property |
M22Property |
M23Property |
M24Property |
M31Property |
M32Property |
M33Property |
M34Property |
M44Property |
OffsetXProperty |
OffsetYProperty |
OffsetZProperty |

Properties

 | Name | Description
Public property | Determinant |
Public property | HasInverse |
Public property | Identity |
Public property | IsAffine |
Public property | IsIdentity |
Public property | M11 |
Public property | M12 |
Public property | M13 |
Public property | M14 |
Public property | M21 |
Public property | M22 |
Public property | M23 |
Public property | M24 |
Public property | M31 |
Public property | M32 |
Public property | M33 |
Public property | M34 |
Public property | M44 |
Public property | OffsetX |
Public property | OffsetY |
Public property | OffsetZ |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D Constructor
Matrix3D Class See Also Send Feedback
Initializes a new instance of the Matrix3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Matrix3D()
Visual Basic
Public Sub New
Visual C++
public:
Matrix3D()

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D Fields
Matrix3D Class See Also Send Feedback

The Matrix3D type exposes the following members.

Fields

Name | Description
DeterminantProperty |
HasInverseProperty |
IdentityProperty |
IsAffineProperty |
IsIdentityProperty |
M11Property |
M12Property |
M13Property |
M14Property |
M21Property |
M22Property |
M23Property |
M24Property |
M31Property |
M32Property |
M33Property |
M34Property |
M44Property |
OffsetXProperty |
OffsetYProperty |
OffsetZProperty |

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DeterminantProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..DeterminantProperty Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.DeterminantProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DeterminantProperty
Visual Basic
Public Shared DeterminantProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DeterminantProperty

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasInverseProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..HasInverseProperty Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.HasInverseProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasInverseProperty
Visual Basic
Public Shared HasInverseProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasInverseProperty

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IdentityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..IdentityProperty Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.IdentityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IdentityProperty
Visual Basic
Public Shared IdentityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IdentityProperty

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsAffineProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..IsAffineProperty Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.IsAffineProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsAffineProperty
Visual Basic
Public Shared IsAffineProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsAffineProperty

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsIdentityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..IsIdentityProperty Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.IsIdentityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsIdentityProperty
Visual Basic
Public Shared IsIdentityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsIdentityProperty

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M11Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M11Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M11Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M11Property
Visual Basic
Public Shared M11Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M11Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M12Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M12Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M12Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M12Property
Visual Basic
Public Shared M12Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M12Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M13Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M13Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M13Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M13Property
Visual Basic
Public Shared M13Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M13Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M14Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M14Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M14Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M14Property
Visual Basic
Public Shared M14Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M14Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M21Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M21Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M21Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M21Property
Visual Basic
Public Shared M21Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M21Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M22Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M22Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M22Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M22Property
Visual Basic
Public Shared M22Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M22Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M23Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M23Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M23Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M23Property
Visual Basic
Public Shared M23Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M23Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M24Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M24Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M24Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M24Property
Visual Basic
Public Shared M24Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M24Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M31Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M31Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M31Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M31Property
Visual Basic
Public Shared M31Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M31Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M32Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M32Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M32Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M32Property
Visual Basic
Public Shared M32Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M32Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M33Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M33Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M33Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M33Property
Visual Basic
Public Shared M33Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M33Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M34Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M34Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M34Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M34Property
Visual Basic
Public Shared M34Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M34Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M44Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M44Property Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M44Property"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M44Property
Visual Basic
Public Shared M44Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M44Property

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..OffsetXProperty Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.OffsetXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetXProperty
Visual Basic
Public Shared OffsetXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetXProperty

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..OffsetYProperty Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.OffsetYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetYProperty
Visual Basic
Public Shared OffsetYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetYProperty

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetZProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..OffsetZProperty Field
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.OffsetZProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetZProperty
Visual Basic
Public Shared OffsetZProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetZProperty

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D Methods
Matrix3D Class See Also Send Feedback

The Matrix3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..GetProperty Method
Matrix3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix3D Class
Matrix3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..GetRealType Method
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..InvokeMethod Method
Matrix3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix3D Class
Matrix3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D Properties
Matrix3D Class See Also Send Feedback

The Matrix3D type exposes the following members.

Properties

 | Name | Description
Public property | Determinant |
Public property | HasInverse |
Public property | Identity |
Public property | IsAffine |
Public property | IsIdentity |
Public property | M11 |
Public property | M12 |
Public property | M13 |
Public property | M14 |
Public property | M21 |
Public property | M22 |
Public property | M23 |
Public property | M24 |
Public property | M31 |
Public property | M32 |
Public property | M33 |
Public property | M34 |
Public property | M44 |
Public property | OffsetX |
Public property | OffsetY |
Public property | OffsetZ |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Determinant Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..Determinant Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.Determinant"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Determinant { get; set; }
Visual Basic
Public Overridable Property Determinant As Double
    Get
    Set
Visual C++
public:
virtual property double Determinant {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasInverse Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..HasInverse Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.HasInverse"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool HasInverse { get; set; }
Visual Basic
Public Overridable Property HasInverse As Boolean
    Get
    Set
Visual C++
public:
virtual property bool HasInverse {
    bool get ();
    void set (bool value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Identity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..Identity Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.Identity"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Matrix3D Identity { get; set; }
Visual Basic
Public Overridable Property Identity As Matrix3D
    Get
    Set
Visual C++
public:
virtual property Matrix3D^ Identity {
    Matrix3D^ get ();
    void set (Matrix3D^ value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsAffine Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..IsAffine Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.IsAffine"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsAffine { get; set; }
Visual Basic
Public Overridable Property IsAffine As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsAffine {
    bool get ();
    void set (bool value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsIdentity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..IsIdentity Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.IsIdentity"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsIdentity { get; set; }
Visual Basic
Public Overridable Property IsIdentity As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsIdentity {
    bool get ();
    void set (bool value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M11 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M11 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M11"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M11 { get; set; }
Visual Basic
Public Overridable Property M11 As Double
    Get
    Set
Visual C++
public:
virtual property double M11 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M12 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M12 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M12"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M12 { get; set; }
Visual Basic
Public Overridable Property M12 As Double
    Get
    Set
Visual C++
public:
virtual property double M12 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M13 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M13 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M13"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M13 { get; set; }
Visual Basic
Public Overridable Property M13 As Double
    Get
    Set
Visual C++
public:
virtual property double M13 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M14 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M14 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M14"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M14 { get; set; }
Visual Basic
Public Overridable Property M14 As Double
    Get
    Set
Visual C++
public:
virtual property double M14 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M21 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M21 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M21"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M21 { get; set; }
Visual Basic
Public Overridable Property M21 As Double
    Get
    Set
Visual C++
public:
virtual property double M21 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M22 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M22 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M22"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M22 { get; set; }
Visual Basic
Public Overridable Property M22 As Double
    Get
    Set
Visual C++
public:
virtual property double M22 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M23 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M23 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M23"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M23 { get; set; }
Visual Basic
Public Overridable Property M23 As Double
    Get
    Set
Visual C++
public:
virtual property double M23 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M24 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M24 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M24"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M24 { get; set; }
Visual Basic
Public Overridable Property M24 As Double
    Get
    Set
Visual C++
public:
virtual property double M24 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M31 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M31 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M31"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M31 { get; set; }
Visual Basic
Public Overridable Property M31 As Double
    Get
    Set
Visual C++
public:
virtual property double M31 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M32 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M32 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M32"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M32 { get; set; }
Visual Basic
Public Overridable Property M32 As Double
    Get
    Set
Visual C++
public:
virtual property double M32 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M33 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M33 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M33"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M33 { get; set; }
Visual Basic
Public Overridable Property M33 As Double
    Get
    Set
Visual C++
public:
virtual property double M33 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M34 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M34 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M34"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M34 { get; set; }
Visual Basic
Public Overridable Property M34 As Double
    Get
    Set
Visual C++
public:
virtual property double M34 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


M44 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..M44 Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.M44"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double M44 { get; set; }
Visual Basic
Public Overridable Property M44 As Double
    Get
    Set
Visual C++
public:
virtual property double M44 {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..OffsetX Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.OffsetX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double OffsetX { get; set; }
Visual Basic
Public Overridable Property OffsetX As Double
    Get
    Set
Visual C++
public:
virtual property double OffsetX {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..OffsetY Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.OffsetY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double OffsetY { get; set; }
Visual Basic
Public Overridable Property OffsetY As Double
    Get
    Set
Visual C++
public:
virtual property double OffsetY {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetZ Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix3D..::..OffsetZ Property
Matrix3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Matrix3D.OffsetZ"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double OffsetZ { get; set; }
Visual Basic
Public Overridable Property OffsetZ As Double
    Get
    Set
Visual C++
public:
virtual property double OffsetZ {
    double get ();
    void set (double value);
}

See Also

Matrix3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixCamera Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera Members
MatrixCamera Class Constructors Methods Fields Properties See Also Send Feedback

The MatrixCamera type exposes the following members.

Constructors

 | Name | Description
Public method | MatrixCamera | Initializes a new instance of the MatrixCamera class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Camera..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ProjectionMatrixProperty |
ViewMatrixProperty |

Properties

 | Name | Description
Public property | ProjectionMatrix |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Camera.)
Public property | ViewMatrix |

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixCamera Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera Constructor
MatrixCamera Class See Also Send Feedback
Initializes a new instance of the MatrixCamera class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MatrixCamera()
Visual Basic
Public Sub New
Visual C++
public:
MatrixCamera()

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixCamera Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera Fields
MatrixCamera Class See Also Send Feedback

The MatrixCamera type exposes the following members.

Fields

Name | Description
ProjectionMatrixProperty |
ViewMatrixProperty |

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProjectionMatrixProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera..::..ProjectionMatrixProperty Field
MatrixCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixCamera.ProjectionMatrixProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ProjectionMatrixProperty
Visual Basic
Public Shared ProjectionMatrixProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ProjectionMatrixProperty

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewMatrixProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera..::..ViewMatrixProperty Field
MatrixCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixCamera.ViewMatrixProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewMatrixProperty
Visual Basic
Public Shared ViewMatrixProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewMatrixProperty

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixCamera Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera Methods
MatrixCamera Class See Also Send Feedback

The MatrixCamera type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Camera..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera..::..GetProperty Method
MatrixCamera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixCamera Class
MatrixCamera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera..::..GetRealType Method
MatrixCamera Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixCamera.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixCamera.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera..::..InvokeMethod Method
MatrixCamera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixCamera Class
MatrixCamera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixCamera Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera Properties
MatrixCamera Class See Also Send Feedback

The MatrixCamera type exposes the following members.

Properties

 | Name | Description
Public property | ProjectionMatrix |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Camera.)
Public property | ViewMatrix |

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProjectionMatrix Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera..::..ProjectionMatrix Property
MatrixCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixCamera.ProjectionMatrix"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Matrix3D ProjectionMatrix { get; set; }
Visual Basic
Public Property ProjectionMatrix As Matrix3D
    Get
    Set
Visual C++
public:
property Matrix3D^ ProjectionMatrix {
    Matrix3D^ get ();
    void set (Matrix3D^ value);
}

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewMatrix Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixCamera..::..ViewMatrix Property
MatrixCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixCamera.ViewMatrix"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Matrix3D ViewMatrix { get; set; }
Visual Basic
Public Property ViewMatrix As Matrix3D
    Get
    Set
Visual C++
public:
property Matrix3D^ ViewMatrix {
    Matrix3D^ get ();
    void set (Matrix3D^ value);
}

See Also

MatrixCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Members
MatrixTransform Class Constructors Methods Fields Properties See Also Send Feedback

The MatrixTransform type exposes the following members.

Constructors

 | Name | Description
Public method | MatrixTransform | Initializes a new instance of the MatrixTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MatrixProperty |

Properties

 | Name | Description
Public property | Matrix |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Constructor
MatrixTransform Class See Also Send Feedback
Initializes a new instance of the MatrixTransform class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MatrixTransform()
Visual Basic
Public Sub New
Visual C++
public:
MatrixTransform()

See Also

MatrixTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Fields
MatrixTransform Class See Also Send Feedback

The MatrixTransform type exposes the following members.

Fields

Name | Description
MatrixProperty |

See Also

MatrixTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..MatrixProperty Field
MatrixTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixTransform.MatrixProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MatrixProperty
Visual Basic
Public Shared MatrixProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MatrixProperty

See Also

MatrixTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Methods
MatrixTransform Class See Also Send Feedback

The MatrixTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..GetProperty Method
MatrixTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform Class
MatrixTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..GetRealType Method
MatrixTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MatrixTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..InvokeMethod Method
MatrixTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform Class
MatrixTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Properties
MatrixTransform Class See Also Send Feedback

The MatrixTransform type exposes the following members.

Properties

 | Name | Description
Public property | Matrix |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..Matrix Property
MatrixTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixTransform.Matrix"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Matrix Matrix { get; set; }
Visual Basic
Public Property Matrix As Matrix
    Get
    Set
Visual C++
public:
property Matrix^ Matrix {
    Matrix^ get ();
    void set (Matrix^ value);
}

See Also

MatrixTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D Members
MatrixTransform3D Class Constructors Methods Fields Properties See Also Send Feedback

The MatrixTransform3D type exposes the following members.

Constructors

 | Name | Description
Public method | MatrixTransform3D | Initializes a new instance of the MatrixTransform3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MatrixProperty |

Properties

 | Name | Description
Public property | Matrix |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D Constructor
MatrixTransform3D Class See Also Send Feedback
Initializes a new instance of the MatrixTransform3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MatrixTransform3D()
Visual Basic
Public Sub New
Visual C++
public:
MatrixTransform3D()

See Also

MatrixTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D Fields
MatrixTransform3D Class See Also Send Feedback

The MatrixTransform3D type exposes the following members.

Fields

Name | Description
MatrixProperty |

See Also

MatrixTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D..::..MatrixProperty Field
MatrixTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixTransform3D.MatrixProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MatrixProperty
Visual Basic
Public Shared MatrixProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MatrixProperty

See Also

MatrixTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D Methods
MatrixTransform3D Class See Also Send Feedback

The MatrixTransform3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D..::..GetProperty Method
MatrixTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform3D Class
MatrixTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D..::..GetRealType Method
MatrixTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixTransform3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixTransform3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MatrixTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D..::..InvokeMethod Method
MatrixTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform3D Class
MatrixTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MatrixTransform3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D Properties
MatrixTransform3D Class See Also Send Feedback

The MatrixTransform3D type exposes the following members.

Properties

 | Name | Description
Public property | Matrix |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Matrix Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform3D..::..Matrix Property
MatrixTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MatrixTransform3D.Matrix"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Matrix3D Matrix { get; set; }
Visual Basic
Public Property Matrix As Matrix3D
    Get
    Set
Visual C++
public:
property Matrix3D^ Matrix {
    Matrix3D^ get ();
    void set (Matrix3D^ value);
}

See Also

MatrixTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Members
MediaElement Class Constructors Methods Fields Properties See Also Send Feedback

The MediaElement type exposes the following members.

Constructors

 | Name | Description
Public method | MediaElement | Initializes a new instance of the MediaElement class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BalanceProperty |
IsMutedProperty |
LoadedBehaviorProperty |
ScrubbingEnabledProperty |
SourceProperty |
StretchDirectionProperty |
StretchProperty |
UnloadedBehaviorProperty |
VolumeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Balance |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsMuted |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LoadedBehavior |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ScrubbingEnabled |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UnloadedBehavior |
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Volume |
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaElement Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Constructor
MediaElement Class See Also Send Feedback
Initializes a new instance of the MediaElement class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MediaElement()
Visual Basic
Public Sub New
Visual C++
public:
MediaElement()

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaElement Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Fields
MediaElement Class See Also Send Feedback

The MediaElement type exposes the following members.

Fields

Name | Description
BalanceProperty |
IsMutedProperty |
LoadedBehaviorProperty |
ScrubbingEnabledProperty |
SourceProperty |
StretchDirectionProperty |
StretchProperty |
UnloadedBehaviorProperty |
VolumeProperty |

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BalanceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..BalanceProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.BalanceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BalanceProperty
Visual Basic
Public Shared BalanceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BalanceProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMutedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..IsMutedProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.IsMutedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMutedProperty
Visual Basic
Public Shared IsMutedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMutedProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LoadedBehaviorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..LoadedBehaviorProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.LoadedBehaviorProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LoadedBehaviorProperty
Visual Basic
Public Shared LoadedBehaviorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LoadedBehaviorProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrubbingEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..ScrubbingEnabledProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.ScrubbingEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScrubbingEnabledProperty
Visual Basic
Public Shared ScrubbingEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScrubbingEnabledProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..SourceProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..StretchDirectionProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.StretchDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchDirectionProperty
Visual Basic
Public Shared StretchDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchDirectionProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..StretchProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.StretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnloadedBehaviorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..UnloadedBehaviorProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.UnloadedBehaviorProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UnloadedBehaviorProperty
Visual Basic
Public Shared UnloadedBehaviorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UnloadedBehaviorProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VolumeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..VolumeProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.VolumeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VolumeProperty
Visual Basic
Public Shared VolumeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VolumeProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Methods
MediaElement Class See Also Send Feedback

The MediaElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..AnySibling Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..GetProperty Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..GetRealType Method
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..GetRectangle Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..Highlight Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..InvokeMethod Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..IsHitTest Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..NextSibling Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..Parent Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..PreviousSibling Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..ScrollToVisible Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..SetProperty Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Properties
MediaElement Class See Also Send Feedback

The MediaElement type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Balance |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsMuted |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LoadedBehavior |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ScrubbingEnabled |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UnloadedBehavior |
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Volume |
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Balance Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..Balance Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.Balance"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Balance { get; set; }
Visual Basic
Public Property Balance As Double
    Get
    Set
Visual C++
public:
property double Balance {
    double get ();
    void set (double value);
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMuted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..IsMuted Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.IsMuted"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMuted { get; set; }
Visual Basic
Public Property IsMuted As Boolean
    Get
    Set
Visual C++
public:
property bool IsMuted {
    bool get ();
    void set (bool value);
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LoadedBehavior Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..LoadedBehavior Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.LoadedBehavior"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MediaState LoadedBehavior { get; set; }
Visual Basic
Public Property LoadedBehavior As MediaState
    Get
    Set
Visual C++
public:
property MediaState LoadedBehavior {
    MediaState get ();
    void set (MediaState value);
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrubbingEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..ScrubbingEnabled Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.ScrubbingEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ScrubbingEnabled { get; set; }
Visual Basic
Public Property ScrubbingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool ScrubbingEnabled {
    bool get ();
    void set (bool value);
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..Source Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
Visual C++
public:
property String^ Source {
    String^ get ();
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Stretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..Stretch Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.Stretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Stretch Stretch { get; set; }
Visual Basic
Public Property Stretch As Stretch
    Get
    Set
Visual C++
public:
property Stretch Stretch {
    Stretch get ();
    void set (Stretch value);
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..StretchDirection Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.StretchDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StretchDirection StretchDirection { get; set; }
Visual Basic
Public Property StretchDirection As StretchDirection
    Get
    Set
Visual C++
public:
property StretchDirection StretchDirection {
    StretchDirection get ();
    void set (StretchDirection value);
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnloadedBehavior Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..UnloadedBehavior Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.UnloadedBehavior"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MediaState UnloadedBehavior { get; set; }
Visual Basic
Public Property UnloadedBehavior As MediaState
    Get
    Set
Visual C++
public:
property MediaState UnloadedBehavior {
    MediaState get ();
    void set (MediaState value);
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Volume Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..Volume Property
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaElement.Volume"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Volume { get; set; }
Visual Basic
Public Property Volume As Double
    Get
    Set
Visual C++
public:
property double Volume {
    double get ();
    void set (double value);
}

See Also

MediaElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaPlayer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaPlayer Members
MediaPlayer Class Constructors Methods Properties See Also Send Feedback

The MediaPlayer type exposes the following members.

Constructors

 | Name | Description
Public method | MediaPlayer | Initializes a new instance of the MediaPlayer class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaPlayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaPlayer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaPlayer Constructor
MediaPlayer Class See Also Send Feedback
Initializes a new instance of the MediaPlayer class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MediaPlayer()
Visual Basic
Public Sub New
Visual C++
public:
MediaPlayer()

See Also

MediaPlayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaPlayer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaPlayer Methods
MediaPlayer Class See Also Send Feedback

The MediaPlayer type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MediaPlayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaPlayer..::..GetProperty Method
MediaPlayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaPlayer Class
MediaPlayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaPlayer..::..GetRealType Method
MediaPlayer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaPlayer.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MediaPlayer.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MediaPlayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaPlayer..::..InvokeMethod Method
MediaPlayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaPlayer Class
MediaPlayer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MediaPlayer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaPlayer Properties
MediaPlayer Class See Also Send Feedback

The MediaPlayer type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaPlayer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Menu Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu Members
Menu Class Constructors Methods Fields Properties See Also Send Feedback

The Menu type exposes the following members.

Constructors

 | Name | Description
Public method | Menu | Initializes a new instance of the Menu class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides MenuBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsMainMenuProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMainMenu |
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Menu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Menu Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu Constructor
Menu Class See Also Send Feedback
Initializes a new instance of the Menu class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Menu()
Visual Basic
Public Sub New
Visual C++
public:
Menu()

See Also

Menu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Menu Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu Fields
Menu Class See Also Send Feedback

The Menu type exposes the following members.

Fields

Name | Description
IsMainMenuProperty |

See Also

Menu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMainMenuProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..IsMainMenuProperty Field
Menu Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Menu.IsMainMenuProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMainMenuProperty
Visual Basic
Public Shared IsMainMenuProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMainMenuProperty

See Also

Menu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Menu Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu Methods
Menu Class See Also Send Feedback

The Menu type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides MenuBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Menu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..AnySibling Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..GetProperty Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..GetRealType Method
Menu Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Menu.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Menu.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Menu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..GetRectangle Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..Highlight Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..InvokeMethod Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..IsHitTest Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..NextSibling Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..Parent Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..PreviousSibling Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..ScrollToVisible Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..SetProperty Method
Menu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Menu Class
Menu Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Menu Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu Properties
Menu Class See Also Send Feedback

The Menu type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMainMenu |
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Menu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMainMenu Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Menu..::..IsMainMenu Property
Menu Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Menu.IsMainMenu"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMainMenu { get; set; }
Visual Basic
Public Property IsMainMenu As Boolean
    Get
    Set
Visual C++
public:
property bool IsMainMenu {
    bool get ();
    void set (bool value);
}

See Also

Menu Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase Members
MenuBase Class Constructors Methods Properties See Also Send Feedback

The MenuBase type exposes the following members.

Constructors

 | Name | Description
Public method | MenuBase | Initializes a new instance of the MenuBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MenuBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase Constructor
MenuBase Class See Also Send Feedback
Initializes a new instance of the MenuBase class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MenuBase()
Visual Basic
Public Sub New
Visual C++
public:
MenuBase()

See Also

MenuBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase Methods
MenuBase Class See Also Send Feedback

The MenuBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

MenuBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..AnySibling Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..GetProperty Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..GetRealType Method
MenuBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MenuBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..GetRectangle Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..Highlight Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..InvokeMethod Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..IsHitTest Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..NextSibling Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..Parent Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..PreviousSibling Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..ScrollToVisible Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase..::..SetProperty Method
MenuBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MenuBase Class
MenuBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuBase Properties
MenuBase Class See Also Send Feedback

The MenuBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MenuBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem Members
MenuItem Class Constructors Methods Fields Properties See Also Send Feedback

The MenuItem type exposes the following members.

Constructors

 | Name | Description
Public method | MenuItem | Initializes a new instance of the MenuItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
InputGestureTextProperty |
IsCheckableProperty |
IsCheckedProperty |
IsHighlightedProperty |
IsPressedProperty |
IsSubmenuOpenProperty |
IsSuspendingPopupAnimationProperty |
RoleProperty |
StaysOpenOnClickProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader | (Inherited from HeaderedItemsControl.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputGestureText |
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsCheckable |
Public property | IsChecked |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHighlighted |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSubmenuOpen |
Public property | IsSuspendingPopupAnimation |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Role |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpenOnClick |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem Constructor
MenuItem Class See Also Send Feedback
Initializes a new instance of the MenuItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MenuItem()
Visual Basic
Public Sub New
Visual C++
public:
MenuItem()

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem Fields
MenuItem Class See Also Send Feedback

The MenuItem type exposes the following members.

Fields

Name | Description
InputGestureTextProperty |
IsCheckableProperty |
IsCheckedProperty |
IsHighlightedProperty |
IsPressedProperty |
IsSubmenuOpenProperty |
IsSuspendingPopupAnimationProperty |
RoleProperty |
StaysOpenOnClickProperty |

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InputGestureTextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..InputGestureTextProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.InputGestureTextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty InputGestureTextProperty
Visual Basic
Public Shared InputGestureTextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ InputGestureTextProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsCheckableProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsCheckableProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsCheckableProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsCheckableProperty
Visual Basic
Public Shared IsCheckableProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsCheckableProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsCheckedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsCheckedProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsCheckedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsCheckedProperty
Visual Basic
Public Shared IsCheckedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsCheckedProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHighlightedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsHighlightedProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsHighlightedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsHighlightedProperty
Visual Basic
Public Shared IsHighlightedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsHighlightedProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPressedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsPressedProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsPressedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsPressedProperty
Visual Basic
Public Shared IsPressedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsPressedProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSubmenuOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsSubmenuOpenProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsSubmenuOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSubmenuOpenProperty
Visual Basic
Public Shared IsSubmenuOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSubmenuOpenProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSuspendingPopupAnimationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsSuspendingPopupAnimationProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsSuspendingPopupAnimationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSuspendingPopupAnimationProperty
Visual Basic
Public Shared IsSuspendingPopupAnimationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSuspendingPopupAnimationProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RoleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..RoleProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.RoleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RoleProperty
Visual Basic
Public Shared RoleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RoleProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpenOnClickProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..StaysOpenOnClickProperty Field
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.StaysOpenOnClickProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StaysOpenOnClickProperty
Visual Basic
Public Shared StaysOpenOnClickProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StaysOpenOnClickProperty

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem Methods
MenuItem Class See Also Send Feedback

The MenuItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..AnySibling Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..GetProperty Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..GetRealType Method
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..GetRectangle Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..Highlight Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..InvokeMethod Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsHitTest Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..NextSibling Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..Parent Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..PreviousSibling Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..ScrollToVisible Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..SetProperty Method
MenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MenuItem Class
MenuItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MenuItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem Properties
MenuItem Class See Also Send Feedback

The MenuItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader | (Inherited from HeaderedItemsControl.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputGestureText |
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsCheckable |
Public property | IsChecked |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHighlighted |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSubmenuOpen |
Public property | IsSuspendingPopupAnimation |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Role |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpenOnClick |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InputGestureText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..InputGestureText Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.InputGestureText"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string InputGestureText { get; set; }
Visual Basic
Public Property InputGestureText As String
    Get
    Set
Visual C++
public:
property String^ InputGestureText {
    String^ get ();
    void set (String^ value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsCheckable Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsCheckable Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsCheckable"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsCheckable { get; set; }
Visual Basic
Public Property IsCheckable As Boolean
    Get
    Set
Visual C++
public:
property bool IsCheckable {
    bool get ();
    void set (bool value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsChecked Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsChecked Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsChecked"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsChecked { get; set; }
Visual Basic
Public Property IsChecked As Boolean
    Get
    Set
Visual C++
public:
property bool IsChecked {
    bool get ();
    void set (bool value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHighlighted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsHighlighted Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsHighlighted"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsHighlighted { get; set; }
Visual Basic
Public Property IsHighlighted As Boolean
    Get
    Set
Visual C++
public:
property bool IsHighlighted {
    bool get ();
    void set (bool value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsPressed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsPressed Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsPressed"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsPressed { get; set; }
Visual Basic
Public Property IsPressed As Boolean
    Get
    Set
Visual C++
public:
property bool IsPressed {
    bool get ();
    void set (bool value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSubmenuOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsSubmenuOpen Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsSubmenuOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSubmenuOpen { get; set; }
Visual Basic
Public Property IsSubmenuOpen As Boolean
    Get
    Set
Visual C++
public:
property bool IsSubmenuOpen {
    bool get ();
    void set (bool value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSuspendingPopupAnimation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..IsSuspendingPopupAnimation Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.IsSuspendingPopupAnimation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSuspendingPopupAnimation { get; set; }
Visual Basic
Public Property IsSuspendingPopupAnimation As Boolean
    Get
    Set
Visual C++
public:
property bool IsSuspendingPopupAnimation {
    bool get ();
    void set (bool value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Role Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..Role Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.Role"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MenuItemRole Role { get; set; }
Visual Basic
Public Property Role As MenuItemRole
    Get
    Set
Visual C++
public:
property MenuItemRole Role {
    MenuItemRole get ();
    void set (MenuItemRole value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpenOnClick Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuItem..::..StaysOpenOnClick Property
MenuItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.MenuItem.StaysOpenOnClick"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StaysOpenOnClick { get; set; }
Visual Basic
Public Property StaysOpenOnClick As Boolean
    Get
    Set
Visual C++
public:
property bool StaysOpenOnClick {
    bool get ();
    void set (bool value);
}

See Also

MenuItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MultiSelector Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector Members
MultiSelector Class Constructors Methods Properties See Also Send Feedback

The MultiSelector type exposes the following members.

Constructors

 | Name | Description
Public method | MultiSelector | Initializes a new instance of the MultiSelector class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MultiSelector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MultiSelector Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector Constructor
MultiSelector Class See Also Send Feedback
Initializes a new instance of the MultiSelector class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MultiSelector()
Visual Basic
Public Sub New
Visual C++
public:
MultiSelector()

See Also

MultiSelector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MultiSelector Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector Methods
MultiSelector Class See Also Send Feedback

The MultiSelector type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

MultiSelector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..AnySibling Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..GetProperty Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..GetRealType Method
MultiSelector Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MultiSelector.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.MultiSelector.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MultiSelector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..GetRectangle Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..Highlight Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..InvokeMethod Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..IsHitTest Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..NextSibling Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..Parent Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..PreviousSibling Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..ScrollToVisible Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector..::..SetProperty Method
MultiSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiSelector Class
MultiSelector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MultiSelector Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiSelector Properties
MultiSelector Class See Also Send Feedback

The MultiSelector type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MultiSelector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigationWindow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow Members
NavigationWindow Class Constructors Methods Fields Properties See Also Send Feedback

The NavigationWindow type exposes the following members.

Constructors

 | Name | Description
Public method | NavigationWindow | Initializes a new instance of the NavigationWindow class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Window..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanGoBackProperty |
CanGoForwardProperty |
SandboxExternalContentProperty |
ShowsNavigationUIProperty |
SourceProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AllowsTransparency | (Inherited from Window.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanGoBack |
Public property | CanGoForward |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Icon | (Inherited from Window.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsActive | (Inherited from Window.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Left | (Inherited from Window.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ResizeMode | (Inherited from Window.)
Public property | SandboxExternalContent |
Public property | ShowActivated | (Inherited from Window.)
Public property | ShowInTaskbar | (Inherited from Window.)
Public property | ShowsNavigationUI |
Public property | SizeToContent | (Inherited from Window.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title | (Inherited from Window.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Top | (Inherited from Window.)
Public property | Topmost | (Inherited from Window.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | WindowState | (Inherited from Window.)
Public property | WindowStyle | (Inherited from Window.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigationWindow Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow Constructor
NavigationWindow Class See Also Send Feedback
Initializes a new instance of the NavigationWindow class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NavigationWindow()
Visual Basic
Public Sub New
Visual C++
public:
NavigationWindow()

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigationWindow Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow Fields
NavigationWindow Class See Also Send Feedback

The NavigationWindow type exposes the following members.

Fields

Name | Description
CanGoBackProperty |
CanGoForwardProperty |
SandboxExternalContentProperty |
ShowsNavigationUIProperty |
SourceProperty |

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoBackProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..CanGoBackProperty Field
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.CanGoBackProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoBackProperty
Visual Basic
Public Shared CanGoBackProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoBackProperty

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoForwardProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..CanGoForwardProperty Field
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.CanGoForwardProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoForwardProperty
Visual Basic
Public Shared CanGoForwardProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoForwardProperty

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SandboxExternalContentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..SandboxExternalContentProperty Field
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.SandboxExternalContentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SandboxExternalContentProperty
Visual Basic
Public Shared SandboxExternalContentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SandboxExternalContentProperty

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowsNavigationUIProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..ShowsNavigationUIProperty Field
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.ShowsNavigationUIProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ShowsNavigationUIProperty
Visual Basic
Public Shared ShowsNavigationUIProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ShowsNavigationUIProperty

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..SourceProperty Field
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigationWindow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow Methods
NavigationWindow Class See Also Send Feedback

The NavigationWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Window..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..AnySibling Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..GetProperty Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..GetRealType Method
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..GetRectangle Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..Highlight Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..InvokeMethod Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..IsHitTest Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..NextSibling Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..Parent Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..PreviousSibling Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..ScrollToVisible Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..SetProperty Method
NavigationWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

NavigationWindow Class
NavigationWindow Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NavigationWindow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow Properties
NavigationWindow Class See Also Send Feedback

The NavigationWindow type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AllowsTransparency | (Inherited from Window.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanGoBack |
Public property | CanGoForward |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Icon | (Inherited from Window.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsActive | (Inherited from Window.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Left | (Inherited from Window.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ResizeMode | (Inherited from Window.)
Public property | SandboxExternalContent |
Public property | ShowActivated | (Inherited from Window.)
Public property | ShowInTaskbar | (Inherited from Window.)
Public property | ShowsNavigationUI |
Public property | SizeToContent | (Inherited from Window.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title | (Inherited from Window.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Top | (Inherited from Window.)
Public property | Topmost | (Inherited from Window.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | WindowState | (Inherited from Window.)
Public property | WindowStyle | (Inherited from Window.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoBack Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..CanGoBack Property
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.CanGoBack"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoBack { get; set; }
Visual Basic
Public Property CanGoBack As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoBack {
    bool get ();
    void set (bool value);
}

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanGoForward Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..CanGoForward Property
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.CanGoForward"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoForward { get; set; }
Visual Basic
Public Property CanGoForward As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoForward {
    bool get ();
    void set (bool value);
}

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SandboxExternalContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..SandboxExternalContent Property
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.SandboxExternalContent"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SandboxExternalContent { get; set; }
Visual Basic
Public Property SandboxExternalContent As Boolean
    Get
    Set
Visual C++
public:
property bool SandboxExternalContent {
    bool get ();
    void set (bool value);
}

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowsNavigationUI Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..ShowsNavigationUI Property
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.ShowsNavigationUI"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowsNavigationUI { get; set; }
Visual Basic
Public Property ShowsNavigationUI As Boolean
    Get
    Set
Visual C++
public:
property bool ShowsNavigationUI {
    bool get ();
    void set (bool value);
}

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NavigationWindow..::..Source Property
NavigationWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.NavigationWindow.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
Visual C++
public:
property String^ Source {
    String^ get ();
}

See Also

NavigationWindow Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrthographicCamera Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera Members
OrthographicCamera Class Constructors Methods Fields Properties See Also Send Feedback

The OrthographicCamera type exposes the following members.

Constructors

 | Name | Description
Public method | OrthographicCamera | Initializes a new instance of the OrthographicCamera class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ProjectionCamera..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
WidthProperty |

Properties

 | Name | Description
Public property | FarPlaneDistance | (Inherited from ProjectionCamera.)
Public property | LookDirection | (Inherited from ProjectionCamera.)
Public property | NearPlaneDistance | (Inherited from ProjectionCamera.)
Public property | Position | (Inherited from ProjectionCamera.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Camera.)
Public property | UpDirection | (Inherited from ProjectionCamera.)
Public property | Width |

See Also

OrthographicCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrthographicCamera Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera Constructor
OrthographicCamera Class See Also Send Feedback
Initializes a new instance of the OrthographicCamera class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public OrthographicCamera()
Visual Basic
Public Sub New
Visual C++
public:
OrthographicCamera()

See Also

OrthographicCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrthographicCamera Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera Fields
OrthographicCamera Class See Also Send Feedback

The OrthographicCamera type exposes the following members.

Fields

Name | Description
WidthProperty |

See Also

OrthographicCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera..::..WidthProperty Field
OrthographicCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.OrthographicCamera.WidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

OrthographicCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrthographicCamera Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera Methods
OrthographicCamera Class See Also Send Feedback

The OrthographicCamera type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ProjectionCamera..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OrthographicCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera..::..GetProperty Method
OrthographicCamera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

OrthographicCamera Class
OrthographicCamera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera..::..GetRealType Method
OrthographicCamera Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.OrthographicCamera.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.OrthographicCamera.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

OrthographicCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera..::..InvokeMethod Method
OrthographicCamera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

OrthographicCamera Class
OrthographicCamera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrthographicCamera Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera Properties
OrthographicCamera Class See Also Send Feedback

The OrthographicCamera type exposes the following members.

Properties

 | Name | Description
Public property | FarPlaneDistance | (Inherited from ProjectionCamera.)
Public property | LookDirection | (Inherited from ProjectionCamera.)
Public property | NearPlaneDistance | (Inherited from ProjectionCamera.)
Public property | Position | (Inherited from ProjectionCamera.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Camera.)
Public property | UpDirection | (Inherited from ProjectionCamera.)
Public property | Width |

See Also

OrthographicCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrthographicCamera..::..Width Property
OrthographicCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.OrthographicCamera.Width"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

OrthographicCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Page Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Members
Page Class Constructors Methods Fields Properties See Also Send Feedback

The Page type exposes the following members.

Constructors

 | Name | Description
Public method | Page | Initializes a new instance of the Page class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
FontFamilyProperty |
FontSizeProperty |
ForegroundProperty |
KeepAliveProperty |
TitleProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | KeepAlive |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Page Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Constructor
Page Class See Also Send Feedback
Initializes a new instance of the Page class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Page()
Visual Basic
Public Sub New
Visual C++
public:
Page()

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Page Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Fields
Page Class See Also Send Feedback

The Page type exposes the following members.

Fields

Name | Description
BackgroundProperty |
FontFamilyProperty |
FontSizeProperty |
ForegroundProperty |
KeepAliveProperty |
TitleProperty |

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..BackgroundProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontFamilyProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontSizeProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..ForegroundProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


KeepAliveProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..KeepAliveProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.KeepAliveProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty KeepAliveProperty
Visual Basic
Public Shared KeepAliveProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ KeepAliveProperty

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TitleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..TitleProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.TitleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TitleProperty
Visual Basic
Public Shared TitleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TitleProperty

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Page Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..AnySibling Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..GetProperty Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..GetRealType Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..GetRectangle Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..Highlight Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..InvokeMethod Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..IsHitTest Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..NextSibling Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..Parent Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..PreviousSibling Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..ScrollToVisible Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..SetProperty Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Page Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Properties
Page Class See Also Send Feedback

The Page type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | KeepAlive |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..Background Property
Page Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontFamily Property
Page Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.FontFamily"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontSize Property
Page Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.FontSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic
Public Property FontSize As Double
    Get
    Set
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..Foreground Property
Page Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.Foreground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic
Public Property Foreground As Brush
    Get
    Set
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


KeepAlive Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..KeepAlive Property
Page Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.KeepAlive"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool KeepAlive { get; set; }
Visual Basic
Public Property KeepAlive As Boolean
    Get
    Set
Visual C++
public:
property bool KeepAlive {
    bool get ();
    void set (bool value);
}

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Title Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..Title Property
Page Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Page.Title"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

Page Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageContent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent Members
PageContent Class Constructors Methods Fields Properties See Also Send Feedback

The PageContent type exposes the following members.

Constructors

 | Name | Description
Public method | PageContent | Initializes a new instance of the PageContent class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SourceProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PageContent Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageContent Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent Constructor
PageContent Class See Also Send Feedback
Initializes a new instance of the PageContent class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PageContent()
Visual Basic
Public Sub New
Visual C++
public:
PageContent()

See Also

PageContent Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageContent Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent Fields
PageContent Class See Also Send Feedback

The PageContent type exposes the following members.

Fields

Name | Description
SourceProperty |

See Also

PageContent Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..SourceProperty Field
PageContent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.PageContent.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

PageContent Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageContent Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent Methods
PageContent Class See Also Send Feedback

The PageContent type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

PageContent Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..AnySibling Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..GetProperty Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..GetRealType Method
PageContent Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PageContent.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PageContent.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PageContent Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..GetRectangle Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..Highlight Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..InvokeMethod Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..IsHitTest Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..NextSibling Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..Parent Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..PreviousSibling Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..ScrollToVisible Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..SetProperty Method
PageContent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PageContent Class
PageContent Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageContent Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent Properties
PageContent Class See Also Send Feedback

The PageContent type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Source |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PageContent Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageContent..::..Source Property
PageContent Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.PageContent.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
Visual C++
public:
property String^ Source {
    String^ get ();
}

See Also

PageContent Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageFunctionBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase Members
PageFunctionBase Class Constructors Methods Properties See Also Send Feedback

The PageFunctionBase type exposes the following members.

Constructors

 | Name | Description
Public method | PageFunctionBase | Initializes a new instance of the PageFunctionBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Page..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Page.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Page.)
Public property | FontSize | (Inherited from Page.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Page.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | KeepAlive | (Inherited from Page.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title | (Inherited from Page.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageFunctionBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase Constructor
PageFunctionBase Class See Also Send Feedback
Initializes a new instance of the PageFunctionBase class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PageFunctionBase()
Visual Basic
Public Sub New
Visual C++
public:
PageFunctionBase()

See Also

PageFunctionBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageFunctionBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase Methods
PageFunctionBase Class See Also Send Feedback

The PageFunctionBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Page..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..AnySibling Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..GetProperty Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..GetRealType Method
PageFunctionBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PageFunctionBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PageFunctionBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PageFunctionBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..GetRectangle Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..Highlight Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..InvokeMethod Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..IsHitTest Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..NextSibling Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..Parent Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..PreviousSibling Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..ScrollToVisible Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase..::..SetProperty Method
PageFunctionBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PageFunctionBase Class
PageFunctionBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PageFunctionBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PageFunctionBase Properties
PageFunctionBase Class See Also Send Feedback

The PageFunctionBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Page.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Page.)
Public property | FontSize | (Inherited from Page.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Page.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | KeepAlive | (Inherited from Page.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title | (Inherited from Page.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PageFunctionBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Panel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Members
Panel Class Constructors Methods Fields Properties See Also Send Feedback

The Panel type exposes the following members.

Constructors

 | Name | Description
Public method | Panel | Initializes a new instance of the Panel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
IsItemsHostProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Panel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Constructor
Panel Class See Also Send Feedback
Initializes a new instance of the Panel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Panel()
Visual Basic
Public Sub New
Visual C++
public:
Panel()

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Panel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Fields
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Fields

Name | Description
BackgroundProperty |
IsItemsHostProperty |

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..BackgroundProperty Field
Panel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Panel.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsItemsHostProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..IsItemsHostProperty Field
Panel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Panel.IsItemsHostProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsItemsHostProperty
Visual Basic
Public Shared IsItemsHostProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsItemsHostProperty

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Panel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Methods
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..AnySibling Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..GetProperty Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..GetRealType Method
Panel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Panel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Panel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..GetRectangle Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..Highlight Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..InvokeMethod Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..IsHitTest Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..NextSibling Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..Parent Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..PreviousSibling Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..ScrollToVisible Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..SetProperty Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Panel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Properties
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..Background Property
Panel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Panel.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsItemsHost Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..IsItemsHost Property
Panel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Panel.IsItemsHost"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsItemsHost { get; set; }
Visual Basic
Public Property IsItemsHost As Boolean
    Get
    Set
Visual C++
public:
property bool IsItemsHost {
    bool get ();
    void set (bool value);
}

See Also

Panel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PasswordBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Members
PasswordBox Class Constructors Methods Fields Properties See Also Send Feedback

The PasswordBox type exposes the following members.

Constructors

 | Name | Description
Public method | PasswordBox | Initializes a new instance of the PasswordBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetPassword | Sets or types a new text into the PasswordBox.
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
MaxLengthProperty |
PasswordCharProperty |
PasswordProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Password | Get/set the password.
Public property | PasswordChar |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PasswordBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Constructor
PasswordBox Class See Also Send Feedback
Initializes a new instance of the PasswordBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PasswordBox()
Visual Basic
Public Sub New
Visual C++
public:
PasswordBox()

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PasswordBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Fields
PasswordBox Class See Also Send Feedback

The PasswordBox type exposes the following members.

Fields

Name | Description
MaxLengthProperty |
PasswordCharProperty |
PasswordProperty |

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxLengthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..MaxLengthProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.PasswordBox.MaxLengthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxLengthProperty
Visual Basic
Public Shared MaxLengthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxLengthProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PasswordCharProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..PasswordCharProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.PasswordBox.PasswordCharProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PasswordCharProperty
Visual Basic
Public Shared PasswordCharProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PasswordCharProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PasswordProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..PasswordProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.PasswordBox.PasswordProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PasswordProperty
Visual Basic
Public Shared PasswordProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PasswordProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PasswordBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Methods
PasswordBox Class See Also Send Feedback

The PasswordBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetPassword | Sets or types a new text into the PasswordBox.
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..AnySibling Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..GetProperty Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..GetRealType Method
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PasswordBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PasswordBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..GetRectangle Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..Highlight Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..InvokeMethod Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..IsHitTest Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..NextSibling Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..Parent Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..PreviousSibling Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..ScrollToVisible Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetPassword Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..SetPassword Method
PasswordBox Class See Also Send Feedback
Sets or types a new text into the PasswordBox.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetPassword(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Sub SetPassword ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
virtual void SetPassword(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the text.
text
Type: System..::..String
The text to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press.
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key.

Implements

IPasswordBox..::..SetPassword(Boolean, String, Int32, Int32)

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..SetProperty Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PasswordBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Properties
PasswordBox Class See Also Send Feedback

The PasswordBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Password | Get/set the password.
Public property | PasswordChar |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxLength Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..MaxLength Property
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.PasswordBox.MaxLength"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Password Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..Password Property
PasswordBox Class See Also Send Feedback
Get/set the password.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
virtual property String^ Password {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IPasswordBox..::..Password

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PasswordChar Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..PasswordChar Property
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.PasswordBox.PasswordChar"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public char PasswordChar { get; set; }
Visual Basic
Public Property PasswordChar As Char
    Get
    Set
Visual C++
public:
virtual property wchar_t PasswordChar {
    wchar_t get () sealed;
    void set (wchar_t value) sealed;
}

Implements

IPasswordBox..::..PasswordChar

See Also

PasswordBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Path Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Members
Path Class Constructors Methods Fields Properties See Also Send Feedback

The Path type exposes the following members.

Constructors

 | Name | Description
Public method | Path | Initializes a new instance of the Path class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DataProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Data |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Path Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Path Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Constructor
Path Class See Also Send Feedback
Initializes a new instance of the Path class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Path()
Visual Basic
Public Sub New
Visual C++
public:
Path()

See Also

Path Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Path Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Fields
Path Class See Also Send Feedback

The Path type exposes the following members.

Fields

Name | Description
DataProperty |

See Also

Path Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DataProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..DataProperty Field
Path Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Path.DataProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DataProperty
Visual Basic
Public Shared DataProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DataProperty

See Also

Path Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Path Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Methods
Path Class See Also Send Feedback

The Path type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Path Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..AnySibling Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..GetProperty Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..GetRealType Method
Path Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Path.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Path.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Path Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..GetRectangle Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..Highlight Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..InvokeMethod Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..IsHitTest Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..NextSibling Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..Parent Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..PreviousSibling Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..ScrollToVisible Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..SetProperty Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Path Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Properties
Path Class See Also Send Feedback

The Path type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Data |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Path Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Data Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..Data Property
Path Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Path.Data"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Geometry Data { get; set; }
Visual Basic
Public Property Data As Geometry
    Get
    Set
Visual C++
public:
property Geometry^ Data {
    Geometry^ get ();
    void set (Geometry^ value);
}

See Also

Path Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PathGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Members
PathGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The PathGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | PathGeometry | Initializes a new instance of the PathGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FillRuleProperty |

Properties

 | Name | Description
Public property | FillRule |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

PathGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PathGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Constructor
PathGeometry Class See Also Send Feedback
Initializes a new instance of the PathGeometry class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PathGeometry()
Visual Basic
Public Sub New
Visual C++
public:
PathGeometry()

See Also

PathGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PathGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Fields
PathGeometry Class See Also Send Feedback

The PathGeometry type exposes the following members.

Fields

Name | Description
FillRuleProperty |

See Also

PathGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillRuleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..FillRuleProperty Field
PathGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.PathGeometry.FillRuleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillRuleProperty
Visual Basic
Public Shared FillRuleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillRuleProperty

See Also

PathGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PathGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Methods
PathGeometry Class See Also Send Feedback

The PathGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..GetProperty Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathGeometry Class
PathGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..GetRealType Method
PathGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PathGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PathGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PathGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..InvokeMethod Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathGeometry Class
PathGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PathGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Properties
PathGeometry Class See Also Send Feedback

The PathGeometry type exposes the following members.

Properties

 | Name | Description
Public property | FillRule |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

PathGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillRule Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..FillRule Property
PathGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.PathGeometry.FillRule"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FillRule FillRule { get; set; }
Visual Basic
Public Property FillRule As FillRule
    Get
    Set
Visual C++
public:
property FillRule FillRule {
    FillRule get ();
    void set (FillRule value);
}

See Also

PathGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Pen Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen Members
Pen Class Constructors Methods Fields Properties See Also Send Feedback

The Pen type exposes the following members.

Constructors

 | Name | Description
Public method | Pen | Initializes a new instance of the Pen class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BrushProperty |
DashCapProperty |
EndLineCapProperty |
LineJoinProperty |
MiterLimitProperty |
StartLineCapProperty |
ThicknessProperty |

Properties

 | Name | Description
Public property | Brush |
Public property | DashCap |
Public property | EndLineCap |
Public property | LineJoin |
Public property | MiterLimit |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | StartLineCap |
Public property | Thickness |

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Pen Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen Constructor
Pen Class See Also Send Feedback
Initializes a new instance of the Pen class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Pen()
Visual Basic
Public Sub New
Visual C++
public:
Pen()

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Pen Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen Fields
Pen Class See Also Send Feedback

The Pen type exposes the following members.

Fields

Name | Description
BrushProperty |
DashCapProperty |
EndLineCapProperty |
LineJoinProperty |
MiterLimitProperty |
StartLineCapProperty |
ThicknessProperty |

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..BrushProperty Field
Pen Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.BrushProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BrushProperty
Visual Basic
Public Shared BrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BrushProperty

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DashCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..DashCapProperty Field
Pen Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.DashCapProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DashCapProperty
Visual Basic
Public Shared DashCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DashCapProperty

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EndLineCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..EndLineCapProperty Field
Pen Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.EndLineCapProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EndLineCapProperty
Visual Basic
Public Shared EndLineCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EndLineCapProperty

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineJoinProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..LineJoinProperty Field
Pen Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.LineJoinProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineJoinProperty
Visual Basic
Public Shared LineJoinProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineJoinProperty

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MiterLimitProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..MiterLimitProperty Field
Pen Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.MiterLimitProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MiterLimitProperty
Visual Basic
Public Shared MiterLimitProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MiterLimitProperty

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StartLineCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..StartLineCapProperty Field
Pen Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.StartLineCapProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StartLineCapProperty
Visual Basic
Public Shared StartLineCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StartLineCapProperty

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..ThicknessProperty Field
Pen Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.ThicknessProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ThicknessProperty
Visual Basic
Public Shared ThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ThicknessProperty

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Pen Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen Methods
Pen Class See Also Send Feedback

The Pen type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..GetProperty Method
Pen Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Pen Class
Pen Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..GetRealType Method
Pen Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..InvokeMethod Method
Pen Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Pen Class
Pen Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Pen Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen Properties
Pen Class See Also Send Feedback

The Pen type exposes the following members.

Properties

 | Name | Description
Public property | Brush |
Public property | DashCap |
Public property | EndLineCap |
Public property | LineJoin |
Public property | MiterLimit |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | StartLineCap |
Public property | Thickness |

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Brush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..Brush Property
Pen Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.Brush"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Brush { get; set; }
Visual Basic
Public Property Brush As Brush
    Get
    Set
Visual C++
public:
property Brush^ Brush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DashCap Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..DashCap Property
Pen Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.DashCap"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PenLineCap DashCap { get; set; }
Visual Basic
Public Property DashCap As PenLineCap
    Get
    Set
Visual C++
public:
property PenLineCap DashCap {
    PenLineCap get ();
    void set (PenLineCap value);
}

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


EndLineCap Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..EndLineCap Property
Pen Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.EndLineCap"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PenLineCap EndLineCap { get; set; }
Visual Basic
Public Property EndLineCap As PenLineCap
    Get
    Set
Visual C++
public:
property PenLineCap EndLineCap {
    PenLineCap get ();
    void set (PenLineCap value);
}

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineJoin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..LineJoin Property
Pen Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.LineJoin"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PenLineJoin LineJoin { get; set; }
Visual Basic
Public Property LineJoin As PenLineJoin
    Get
    Set
Visual C++
public:
property PenLineJoin LineJoin {
    PenLineJoin get ();
    void set (PenLineJoin value);
}

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MiterLimit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..MiterLimit Property
Pen Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.MiterLimit"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MiterLimit { get; set; }
Visual Basic
Public Property MiterLimit As Double
    Get
    Set
Visual C++
public:
property double MiterLimit {
    double get ();
    void set (double value);
}

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StartLineCap Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..StartLineCap Property
Pen Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.StartLineCap"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PenLineCap StartLineCap { get; set; }
Visual Basic
Public Property StartLineCap As PenLineCap
    Get
    Set
Visual C++
public:
property PenLineCap StartLineCap {
    PenLineCap get ();
    void set (PenLineCap value);
}

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thickness Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Pen..::..Thickness Property
Pen Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Pen.Thickness"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Thickness { get; set; }
Visual Basic
Public Property Thickness As Double
    Get
    Set
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

See Also

Pen Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PerspectiveCamera Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera Members
PerspectiveCamera Class Constructors Methods Fields Properties See Also Send Feedback

The PerspectiveCamera type exposes the following members.

Constructors

 | Name | Description
Public method | PerspectiveCamera | Initializes a new instance of the PerspectiveCamera class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ProjectionCamera..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FieldOfViewProperty |

Properties

 | Name | Description
Public property | FarPlaneDistance | (Inherited from ProjectionCamera.)
Public property | FieldOfView |
Public property | LookDirection | (Inherited from ProjectionCamera.)
Public property | NearPlaneDistance | (Inherited from ProjectionCamera.)
Public property | Position | (Inherited from ProjectionCamera.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Camera.)
Public property | UpDirection | (Inherited from ProjectionCamera.)

See Also

PerspectiveCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PerspectiveCamera Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera Constructor
PerspectiveCamera Class See Also Send Feedback
Initializes a new instance of the PerspectiveCamera class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PerspectiveCamera()
Visual Basic
Public Sub New
Visual C++
public:
PerspectiveCamera()

See Also

PerspectiveCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PerspectiveCamera Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera Fields
PerspectiveCamera Class See Also Send Feedback

The PerspectiveCamera type exposes the following members.

Fields

Name | Description
FieldOfViewProperty |

See Also

PerspectiveCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FieldOfViewProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera..::..FieldOfViewProperty Field
PerspectiveCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.PerspectiveCamera.FieldOfViewProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FieldOfViewProperty
Visual Basic
Public Shared FieldOfViewProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FieldOfViewProperty

See Also

PerspectiveCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PerspectiveCamera Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera Methods
PerspectiveCamera Class See Also Send Feedback

The PerspectiveCamera type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ProjectionCamera..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerspectiveCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera..::..GetProperty Method
PerspectiveCamera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PerspectiveCamera Class
PerspectiveCamera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera..::..GetRealType Method
PerspectiveCamera Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PerspectiveCamera.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PerspectiveCamera.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PerspectiveCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera..::..InvokeMethod Method
PerspectiveCamera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PerspectiveCamera Class
PerspectiveCamera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PerspectiveCamera Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera Properties
PerspectiveCamera Class See Also Send Feedback

The PerspectiveCamera type exposes the following members.

Properties

 | Name | Description
Public property | FarPlaneDistance | (Inherited from ProjectionCamera.)
Public property | FieldOfView |
Public property | LookDirection | (Inherited from ProjectionCamera.)
Public property | NearPlaneDistance | (Inherited from ProjectionCamera.)
Public property | Position | (Inherited from ProjectionCamera.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Camera.)
Public property | UpDirection | (Inherited from ProjectionCamera.)

See Also

PerspectiveCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FieldOfView Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerspectiveCamera..::..FieldOfView Property
PerspectiveCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.PerspectiveCamera.FieldOfView"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FieldOfView { get; set; }
Visual Basic
Public Property FieldOfView As Double
    Get
    Set
Visual C++
public:
property double FieldOfView {
    double get ();
    void set (double value);
}

See Also

PerspectiveCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PixelFormat Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat Members
PixelFormat Class Constructors Methods Fields Properties See Also Send Feedback

The PixelFormat type exposes the following members.

Constructors

 | Name | Description
Public method | PixelFormat | Initializes a new instance of the PixelFormat class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BitsPerPixelProperty |

Properties

 | Name | Description
Public property | BitsPerPixel |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PixelFormat Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PixelFormat Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat Constructor
PixelFormat Class See Also Send Feedback
Initializes a new instance of the PixelFormat class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PixelFormat()
Visual Basic
Public Sub New
Visual C++
public:
PixelFormat()

See Also

PixelFormat Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PixelFormat Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat Fields
PixelFormat Class See Also Send Feedback

The PixelFormat type exposes the following members.

Fields

Name | Description
BitsPerPixelProperty |

See Also

PixelFormat Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitsPerPixelProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat..::..BitsPerPixelProperty Field
PixelFormat Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.PixelFormat.BitsPerPixelProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BitsPerPixelProperty
Visual Basic
Public Shared BitsPerPixelProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BitsPerPixelProperty

See Also

PixelFormat Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PixelFormat Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat Methods
PixelFormat Class See Also Send Feedback

The PixelFormat type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PixelFormat Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat..::..GetProperty Method
PixelFormat Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PixelFormat Class
PixelFormat Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat..::..GetRealType Method
PixelFormat Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PixelFormat.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.PixelFormat.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PixelFormat Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat..::..InvokeMethod Method
PixelFormat Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PixelFormat Class
PixelFormat Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PixelFormat Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat Properties
PixelFormat Class See Also Send Feedback

The PixelFormat type exposes the following members.

Properties

 | Name | Description
Public property | BitsPerPixel |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PixelFormat Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BitsPerPixel Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PixelFormat..::..BitsPerPixel Property
PixelFormat Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.PixelFormat.BitsPerPixel"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int BitsPerPixel { get; set; }
Visual Basic
Public Overridable Property BitsPerPixel As Integer
    Get
    Set
Visual C++
public:
virtual property int BitsPerPixel {
    int get ();
    void set (int value);
}

See Also

PixelFormat Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Members
Point Class Constructors Methods Fields Properties See Also Send Feedback

The Point type exposes the following members.

Constructors

 | Name | Description
Public method | Point | Initializes a new instance of the Point class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
XProperty |
YProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Constructor
Point Class See Also Send Feedback
Initializes a new instance of the Point class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point()
Visual Basic
Public Sub New
Visual C++
public:
Point()

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Fields
Point Class See Also Send Feedback

The Point type exposes the following members.

Fields

Name | Description
XProperty |
YProperty |

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..XProperty Field
Point Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point.XProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..YProperty Field
Point Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point.YProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Methods
Point Class See Also Send Feedback

The Point type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..GetProperty Method
Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Point Class
Point Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..GetRealType Method
Point Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..InvokeMethod Method
Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Point Class
Point Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Properties
Point Class See Also Send Feedback

The Point type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..X Property
Point Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point.X"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double X { get; set; }
Visual Basic
Public Overridable Property X As Double
    Get
    Set
Visual C++
public:
virtual property double X {
    double get ();
    void set (double value);
}

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..Y Property
Point Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point.Y"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Y { get; set; }
Visual Basic
Public Overridable Property Y As Double
    Get
    Set
Visual C++
public:
virtual property double Y {
    double get ();
    void set (double value);
}

See Also

Point Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D Members
Point3D Class Constructors Methods Fields Properties See Also Send Feedback

The Point3D type exposes the following members.

Constructors

 | Name | Description
Public method | Point3D | Initializes a new instance of the Point3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
XProperty |
YProperty |
ZProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |
Public property | Z |

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D Constructor
Point3D Class See Also Send Feedback
Initializes a new instance of the Point3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point3D()
Visual Basic
Public Sub New
Visual C++
public:
Point3D()

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D Fields
Point3D Class See Also Send Feedback

The Point3D type exposes the following members.

Fields

Name | Description
XProperty |
YProperty |
ZProperty |

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..XProperty Field
Point3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point3D.XProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..YProperty Field
Point3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point3D.YProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..ZProperty Field
Point3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point3D.ZProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZProperty
Visual Basic
Public Shared ZProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZProperty

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D Methods
Point3D Class See Also Send Feedback

The Point3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..GetProperty Method
Point3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Point3D Class
Point3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..GetRealType Method
Point3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..InvokeMethod Method
Point3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Point3D Class
Point3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Point3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D Properties
Point3D Class See Also Send Feedback

The Point3D type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |
Public property | Z |

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..X Property
Point3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point3D.X"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double X { get; set; }
Visual Basic
Public Overridable Property X As Double
    Get
    Set
Visual C++
public:
virtual property double X {
    double get ();
    void set (double value);
}

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..Y Property
Point3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point3D.Y"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Y { get; set; }
Visual Basic
Public Overridable Property Y As Double
    Get
    Set
Visual C++
public:
virtual property double Y {
    double get ();
    void set (double value);
}

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Z Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point3D..::..Z Property
Point3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Point3D.Z"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Z { get; set; }
Visual Basic
Public Overridable Property Z As Double
    Get
    Set
Visual C++
public:
virtual property double Z {
    double get ();
    void set (double value);
}

See Also

Point3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polygon Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Members
Polygon Class Constructors Methods Fields Properties See Also Send Feedback

The Polygon type exposes the following members.

Constructors

 | Name | Description
Public method | Polygon | Initializes a new instance of the Polygon class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FillRuleProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | FillRule |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Polygon Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polygon Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Constructor
Polygon Class See Also Send Feedback
Initializes a new instance of the Polygon class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Polygon()
Visual Basic
Public Sub New
Visual C++
public:
Polygon()

See Also

Polygon Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polygon Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Fields
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Fields

Name | Description
FillRuleProperty |

See Also

Polygon Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillRuleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..FillRuleProperty Field
Polygon Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Polygon.FillRuleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillRuleProperty
Visual Basic
Public Shared FillRuleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillRuleProperty

See Also

Polygon Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polygon Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Methods
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Polygon Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..AnySibling Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..GetProperty Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..GetRealType Method
Polygon Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Polygon.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Polygon.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Polygon Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..GetRectangle Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..Highlight Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..InvokeMethod Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..IsHitTest Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..NextSibling Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..Parent Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..PreviousSibling Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..ScrollToVisible Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..SetProperty Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polygon Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Properties
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | FillRule |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Polygon Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillRule Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..FillRule Property
Polygon Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Polygon.FillRule"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FillRule FillRule { get; set; }
Visual Basic
Public Property FillRule As FillRule
    Get
    Set
Visual C++
public:
property FillRule FillRule {
    FillRule get ();
    void set (FillRule value);
}

See Also

Polygon Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polyline Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Members
Polyline Class Constructors Methods Fields Properties See Also Send Feedback

The Polyline type exposes the following members.

Constructors

 | Name | Description
Public method | Polyline | Initializes a new instance of the Polyline class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FillRuleProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | FillRule |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Polyline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polyline Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Constructor
Polyline Class See Also Send Feedback
Initializes a new instance of the Polyline class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Polyline()
Visual Basic
Public Sub New
Visual C++
public:
Polyline()

See Also

Polyline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polyline Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Fields
Polyline Class See Also Send Feedback

The Polyline type exposes the following members.

Fields

Name | Description
FillRuleProperty |

See Also

Polyline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillRuleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..FillRuleProperty Field
Polyline Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Polyline.FillRuleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillRuleProperty
Visual Basic
Public Shared FillRuleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillRuleProperty

See Also

Polyline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polyline Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Methods
Polyline Class See Also Send Feedback

The Polyline type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Polyline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..AnySibling Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..GetProperty Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..GetRealType Method
Polyline Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Polyline.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Polyline.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Polyline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..GetRectangle Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..Highlight Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..InvokeMethod Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..IsHitTest Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..NextSibling Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..Parent Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..PreviousSibling Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..ScrollToVisible Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..SetProperty Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Polyline Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Properties
Polyline Class See Also Send Feedback

The Polyline type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | FillRule |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Polyline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillRule Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..FillRule Property
Polyline Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Polyline.FillRule"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FillRule FillRule { get; set; }
Visual Basic
Public Property FillRule As FillRule
    Get
    Set
Visual C++
public:
property FillRule FillRule {
    FillRule get ();
    void set (FillRule value);
}

See Also

Polyline Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Popup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Members
Popup Class Constructors Methods Fields Properties See Also Send Feedback

The Popup type exposes the following members.

Constructors

 | Name | Description
Public method | Popup | Initializes a new instance of the Popup class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AllowsTransparencyProperty |
HasDropShadowProperty |
HorizontalOffsetProperty |
IsOpenProperty |
PlacementProperty |
PlacementRectangleProperty |
PopupAnimationProperty |
StaysOpenProperty |
VerticalOffsetProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AllowsTransparency |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | HasDropShadow |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsOpen |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PlacementRectangle |
Public property | PopupAnimation |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpen |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Popup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Constructor
Popup Class See Also Send Feedback
Initializes a new instance of the Popup class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Popup()
Visual Basic
Public Sub New
Visual C++
public:
Popup()

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Popup Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Fields
Popup Class See Also Send Feedback

The Popup type exposes the following members.

Fields

Name | Description
AllowsTransparencyProperty |
HasDropShadowProperty |
HorizontalOffsetProperty |
IsOpenProperty |
PlacementProperty |
PlacementRectangleProperty |
PopupAnimationProperty |
StaysOpenProperty |
VerticalOffsetProperty |

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AllowsTransparencyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..AllowsTransparencyProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.AllowsTransparencyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AllowsTransparencyProperty
Visual Basic
Public Shared AllowsTransparencyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AllowsTransparencyProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasDropShadowProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..HasDropShadowProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.HasDropShadowProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasDropShadowProperty
Visual Basic
Public Shared HasDropShadowProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasDropShadowProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..HorizontalOffsetProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..IsOpenProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.IsOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsOpenProperty
Visual Basic
Public Shared IsOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsOpenProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..PlacementProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.PlacementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlacementProperty
Visual Basic
Public Shared PlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlacementProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementRectangleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..PlacementRectangleProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.PlacementRectangleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlacementRectangleProperty
Visual Basic
Public Shared PlacementRectangleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlacementRectangleProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PopupAnimationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..PopupAnimationProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.PopupAnimationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PopupAnimationProperty
Visual Basic
Public Shared PopupAnimationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PopupAnimationProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..StaysOpenProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.StaysOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StaysOpenProperty
Visual Basic
Public Shared StaysOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StaysOpenProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..VerticalOffsetProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Popup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Methods
Popup Class See Also Send Feedback

The Popup type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..AnySibling Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..GetProperty Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..GetRealType Method
Popup Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..GetRectangle Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..Highlight Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..InvokeMethod Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..IsHitTest Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..NextSibling Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..Parent Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..PreviousSibling Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..ScrollToVisible Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..SetProperty Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Popup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Properties
Popup Class See Also Send Feedback

The Popup type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AllowsTransparency |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | HasDropShadow |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsOpen |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PlacementRectangle |
Public property | PopupAnimation |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpen |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AllowsTransparency Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..AllowsTransparency Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.AllowsTransparency"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AllowsTransparency { get; set; }
Visual Basic
Public Property AllowsTransparency As Boolean
    Get
    Set
Visual C++
public:
property bool AllowsTransparency {
    bool get ();
    void set (bool value);
}

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasDropShadow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..HasDropShadow Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.HasDropShadow"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasDropShadow { get; set; }
Visual Basic
Public Property HasDropShadow As Boolean
    Get
    Set
Visual C++
public:
property bool HasDropShadow {
    bool get ();
    void set (bool value);
}

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..HorizontalOffset Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.HorizontalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic
Public Property HorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..IsOpen Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.IsOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsOpen { get; set; }
Visual Basic
Public Property IsOpen As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsOpen {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IPopup..::..IsOpen

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Placement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..Placement Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.Placement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PlacementMode Placement { get; set; }
Visual Basic
Public Property Placement As PlacementMode
    Get
    Set
Visual C++
public:
property PlacementMode Placement {
    PlacementMode get ();
    void set (PlacementMode value);
}

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementRectangle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..PlacementRectangle Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.PlacementRectangle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect PlacementRectangle { get; set; }
Visual Basic
Public Property PlacementRectangle As Rect
    Get
    Set
Visual C++
public:
property Rect^ PlacementRectangle {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PopupAnimation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..PopupAnimation Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.PopupAnimation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PopupAnimation PopupAnimation { get; set; }
Visual Basic
Public Property PopupAnimation As PopupAnimation
    Get
    Set
Visual C++
public:
property PopupAnimation PopupAnimation {
    PopupAnimation get ();
    void set (PopupAnimation value);
}

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..StaysOpen Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.StaysOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StaysOpen { get; set; }
Visual Basic
Public Property StaysOpen As Boolean
    Get
    Set
Visual C++
public:
property bool StaysOpen {
    bool get ();
    void set (bool value);
}

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..VerticalOffset Property
Popup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Popup.VerticalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic
Public Property VerticalOffset As Double
    Get
    Set
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

Popup Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProgressBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Members
ProgressBar Class Constructors Methods Fields Properties See Also Send Feedback

The ProgressBar type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressBar | Initializes a new instance of the ProgressBar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsIndeterminateProperty |
OrientationProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsIndeterminate |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProgressBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Constructor
ProgressBar Class See Also Send Feedback
Initializes a new instance of the ProgressBar class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ProgressBar()
Visual Basic
Public Sub New
Visual C++
public:
ProgressBar()

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProgressBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Fields
ProgressBar Class See Also Send Feedback

The ProgressBar type exposes the following members.

Fields

Name | Description
IsIndeterminateProperty |
OrientationProperty |

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsIndeterminateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..IsIndeterminateProperty Field
ProgressBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProgressBar.IsIndeterminateProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsIndeterminateProperty
Visual Basic
Public Shared IsIndeterminateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsIndeterminateProperty

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..OrientationProperty Field
ProgressBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProgressBar.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProgressBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Methods
ProgressBar Class See Also Send Feedback

The ProgressBar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..AnySibling Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..GetProperty Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..GetRealType Method
ProgressBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProgressBar.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProgressBar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..GetRectangle Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..Highlight Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..InvokeMethod Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..IsHitTest Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..NextSibling Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..Parent Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..PreviousSibling Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..ScrollToVisible Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..SetProperty Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProgressBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Properties
ProgressBar Class See Also Send Feedback

The ProgressBar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsIndeterminate |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsIndeterminate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..IsIndeterminate Property
ProgressBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProgressBar.IsIndeterminate"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsIndeterminate { get; set; }
Visual Basic
Public Property IsIndeterminate As Boolean
    Get
    Set
Visual C++
public:
property bool IsIndeterminate {
    bool get ();
    void set (bool value);
}

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..Orientation Property
ProgressBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProgressBar.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

ProgressBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProjectionCamera Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera Members
ProjectionCamera Class Constructors Methods Fields Properties See Also Send Feedback

The ProjectionCamera type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectionCamera | Initializes a new instance of the ProjectionCamera class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Camera..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FarPlaneDistanceProperty |
LookDirectionProperty |
NearPlaneDistanceProperty |
PositionProperty |
UpDirectionProperty |

Properties

 | Name | Description
Public property | FarPlaneDistance |
Public property | LookDirection |
Public property | NearPlaneDistance |
Public property | Position |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Camera.)
Public property | UpDirection |

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProjectionCamera Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera Constructor
ProjectionCamera Class See Also Send Feedback
Initializes a new instance of the ProjectionCamera class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ProjectionCamera()
Visual Basic
Public Sub New
Visual C++
public:
ProjectionCamera()

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProjectionCamera Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera Fields
ProjectionCamera Class See Also Send Feedback

The ProjectionCamera type exposes the following members.

Fields

Name | Description
FarPlaneDistanceProperty |
LookDirectionProperty |
NearPlaneDistanceProperty |
PositionProperty |
UpDirectionProperty |

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FarPlaneDistanceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..FarPlaneDistanceProperty Field
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.FarPlaneDistanceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FarPlaneDistanceProperty
Visual Basic
Public Shared FarPlaneDistanceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FarPlaneDistanceProperty

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LookDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..LookDirectionProperty Field
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.LookDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LookDirectionProperty
Visual Basic
Public Shared LookDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LookDirectionProperty

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NearPlaneDistanceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..NearPlaneDistanceProperty Field
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.NearPlaneDistanceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NearPlaneDistanceProperty
Visual Basic
Public Shared NearPlaneDistanceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NearPlaneDistanceProperty

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PositionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..PositionProperty Field
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.PositionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PositionProperty
Visual Basic
Public Shared PositionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PositionProperty

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UpDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..UpDirectionProperty Field
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.UpDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UpDirectionProperty
Visual Basic
Public Shared UpDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UpDirectionProperty

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProjectionCamera Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera Methods
ProjectionCamera Class See Also Send Feedback

The ProjectionCamera type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Camera..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..GetProperty Method
ProjectionCamera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ProjectionCamera Class
ProjectionCamera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..GetRealType Method
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..InvokeMethod Method
ProjectionCamera Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ProjectionCamera Class
ProjectionCamera Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ProjectionCamera Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera Properties
ProjectionCamera Class See Also Send Feedback

The ProjectionCamera type exposes the following members.

Properties

 | Name | Description
Public property | FarPlaneDistance |
Public property | LookDirection |
Public property | NearPlaneDistance |
Public property | Position |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Camera.)
Public property | UpDirection |

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FarPlaneDistance Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..FarPlaneDistance Property
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.FarPlaneDistance"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FarPlaneDistance { get; set; }
Visual Basic
Public Property FarPlaneDistance As Double
    Get
    Set
Visual C++
public:
property double FarPlaneDistance {
    double get ();
    void set (double value);
}

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LookDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..LookDirection Property
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.LookDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Vector3D LookDirection { get; set; }
Visual Basic
Public Property LookDirection As Vector3D
    Get
    Set
Visual C++
public:
property Vector3D^ LookDirection {
    Vector3D^ get ();
    void set (Vector3D^ value);
}

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NearPlaneDistance Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..NearPlaneDistance Property
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.NearPlaneDistance"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double NearPlaneDistance { get; set; }
Visual Basic
Public Property NearPlaneDistance As Double
    Get
    Set
Visual C++
public:
property double NearPlaneDistance {
    double get ();
    void set (double value);
}

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Position Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..Position Property
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.Position"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point3D Position { get; set; }
Visual Basic
Public Property Position As Point3D
    Get
    Set
Visual C++
public:
property Point3D^ Position {
    Point3D^ get ();
    void set (Point3D^ value);
}

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UpDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProjectionCamera..::..UpDirection Property
ProjectionCamera Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ProjectionCamera.UpDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Vector3D UpDirection { get; set; }
Visual Basic
Public Property UpDirection As Vector3D
    Get
    Set
Visual C++
public:
property Vector3D^ UpDirection {
    Vector3D^ get ();
    void set (Vector3D^ value);
}

See Also

ProjectionCamera Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Quaternion Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion Members
Quaternion Class Constructors Methods Fields Properties See Also Send Feedback

The Quaternion type exposes the following members.

Constructors

 | Name | Description
Public method | Quaternion | Initializes a new instance of the Quaternion class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AngleProperty |
AxisProperty |
IdentityProperty |
IsIdentityProperty |
IsNormalizedProperty |
WProperty |
XProperty |
YProperty |
ZProperty |

Properties

 | Name | Description
Public property | Angle |
Public property | Axis |
Public property | Identity |
Public property | IsIdentity |
Public property | IsNormalized |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | W |
Public property | X |
Public property | Y |
Public property | Z |

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Quaternion Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion Constructor
Quaternion Class See Also Send Feedback
Initializes a new instance of the Quaternion class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Quaternion()
Visual Basic
Public Sub New
Visual C++
public:
Quaternion()

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Quaternion Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion Fields
Quaternion Class See Also Send Feedback

The Quaternion type exposes the following members.

Fields

Name | Description
AngleProperty |
AxisProperty |
IdentityProperty |
IsIdentityProperty |
IsNormalizedProperty |
WProperty |
XProperty |
YProperty |
ZProperty |

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AngleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..AngleProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.AngleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AngleProperty
Visual Basic
Public Shared AngleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AngleProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AxisProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..AxisProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.AxisProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AxisProperty
Visual Basic
Public Shared AxisProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AxisProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IdentityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..IdentityProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.IdentityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IdentityProperty
Visual Basic
Public Shared IdentityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IdentityProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsIdentityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..IsIdentityProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.IsIdentityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsIdentityProperty
Visual Basic
Public Shared IsIdentityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsIdentityProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsNormalizedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..IsNormalizedProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.IsNormalizedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsNormalizedProperty
Visual Basic
Public Shared IsNormalizedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsNormalizedProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..WProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.WProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WProperty
Visual Basic
Public Shared WProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..XProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.XProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..YProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.YProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..ZProperty Field
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.ZProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZProperty
Visual Basic
Public Shared ZProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZProperty

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Quaternion Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion Methods
Quaternion Class See Also Send Feedback

The Quaternion type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..GetProperty Method
Quaternion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Quaternion Class
Quaternion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..GetRealType Method
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..InvokeMethod Method
Quaternion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Quaternion Class
Quaternion Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Quaternion Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion Properties
Quaternion Class See Also Send Feedback

The Quaternion type exposes the following members.

Properties

 | Name | Description
Public property | Angle |
Public property | Axis |
Public property | Identity |
Public property | IsIdentity |
Public property | IsNormalized |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | W |
Public property | X |
Public property | Y |
Public property | Z |

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Angle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..Angle Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.Angle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Angle { get; set; }
Visual Basic
Public Overridable Property Angle As Double
    Get
    Set
Visual C++
public:
virtual property double Angle {
    double get ();
    void set (double value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Axis Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..Axis Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.Axis"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Vector3D Axis { get; set; }
Visual Basic
Public Overridable Property Axis As Vector3D
    Get
    Set
Visual C++
public:
virtual property Vector3D^ Axis {
    Vector3D^ get ();
    void set (Vector3D^ value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Identity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..Identity Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.Identity"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Quaternion Identity { get; set; }
Visual Basic
Public Overridable Property Identity As Quaternion
    Get
    Set
Visual C++
public:
virtual property Quaternion^ Identity {
    Quaternion^ get ();
    void set (Quaternion^ value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsIdentity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..IsIdentity Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.IsIdentity"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsIdentity { get; set; }
Visual Basic
Public Overridable Property IsIdentity As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsIdentity {
    bool get ();
    void set (bool value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsNormalized Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..IsNormalized Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.IsNormalized"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsNormalized { get; set; }
Visual Basic
Public Overridable Property IsNormalized As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsNormalized {
    bool get ();
    void set (bool value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


W Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..W Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.W"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double W { get; set; }
Visual Basic
Public Overridable Property W As Double
    Get
    Set
Visual C++
public:
virtual property double W {
    double get ();
    void set (double value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..X Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.X"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double X { get; set; }
Visual Basic
Public Overridable Property X As Double
    Get
    Set
Visual C++
public:
virtual property double X {
    double get ();
    void set (double value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..Y Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.Y"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Y { get; set; }
Visual Basic
Public Overridable Property Y As Double
    Get
    Set
Visual C++
public:
virtual property double Y {
    double get ();
    void set (double value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Z Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Quaternion..::..Z Property
Quaternion Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Quaternion.Z"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Z { get; set; }
Visual Basic
Public Overridable Property Z As Double
    Get
    Set
Visual C++
public:
virtual property double Z {
    double get ();
    void set (double value);
}

See Also

Quaternion Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


QuaternionRotation3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D Members
QuaternionRotation3D Class Constructors Methods Fields Properties See Also Send Feedback

The QuaternionRotation3D type exposes the following members.

Constructors

 | Name | Description
Public method | QuaternionRotation3D | Initializes a new instance of the QuaternionRotation3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Rotation3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
QuaternionProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Quaternion |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

QuaternionRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


QuaternionRotation3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D Constructor
QuaternionRotation3D Class See Also Send Feedback
Initializes a new instance of the QuaternionRotation3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public QuaternionRotation3D()
Visual Basic
Public Sub New
Visual C++
public:
QuaternionRotation3D()

See Also

QuaternionRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


QuaternionRotation3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D Fields
QuaternionRotation3D Class See Also Send Feedback

The QuaternionRotation3D type exposes the following members.

Fields

Name | Description
QuaternionProperty |

See Also

QuaternionRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


QuaternionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D..::..QuaternionProperty Field
QuaternionRotation3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.QuaternionRotation3D.QuaternionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty QuaternionProperty
Visual Basic
Public Shared QuaternionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ QuaternionProperty

See Also

QuaternionRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


QuaternionRotation3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D Methods
QuaternionRotation3D Class See Also Send Feedback

The QuaternionRotation3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Rotation3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QuaternionRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D..::..GetProperty Method
QuaternionRotation3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

QuaternionRotation3D Class
QuaternionRotation3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D..::..GetRealType Method
QuaternionRotation3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.QuaternionRotation3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.QuaternionRotation3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

QuaternionRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D..::..InvokeMethod Method
QuaternionRotation3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

QuaternionRotation3D Class
QuaternionRotation3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


QuaternionRotation3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D Properties
QuaternionRotation3D Class See Also Send Feedback

The QuaternionRotation3D type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Quaternion |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

QuaternionRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Quaternion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuaternionRotation3D..::..Quaternion Property
QuaternionRotation3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.QuaternionRotation3D.Quaternion"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Quaternion Quaternion { get; set; }
Visual Basic
Public Property Quaternion As Quaternion
    Get
    Set
Visual C++
public:
property Quaternion^ Quaternion {
    Quaternion^ get ();
    void set (Quaternion^ value);
}

See Also

QuaternionRotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadialGradientBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Members
RadialGradientBrush Class Constructors Methods Fields Properties See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Constructors

 | Name | Description
Public method | RadialGradientBrush | Initializes a new instance of the RadialGradientBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides GradientBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterProperty |
GradientOriginProperty |
RadiusXProperty |
RadiusYProperty |

Properties

 | Name | Description
Public property | Center |
Public property | ColorInterpolationMode | (Inherited from GradientBrush.)
Public property | GradientOrigin |
Public property | GradientStops | (Inherited from GradientBrush.)
Public property | MappingMode | (Inherited from GradientBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod | (Inherited from GradientBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadialGradientBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Constructor
RadialGradientBrush Class See Also Send Feedback
Initializes a new instance of the RadialGradientBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RadialGradientBrush()
Visual Basic
Public Sub New
Visual C++
public:
RadialGradientBrush()

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadialGradientBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Fields
RadialGradientBrush Class See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Fields

Name | Description
CenterProperty |
GradientOriginProperty |
RadiusXProperty |
RadiusYProperty |

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..CenterProperty Field
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.CenterProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterProperty
Visual Basic
Public Shared CenterProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterProperty

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientOriginProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..GradientOriginProperty Field
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.GradientOriginProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GradientOriginProperty
Visual Basic
Public Shared GradientOriginProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GradientOriginProperty

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..RadiusXProperty Field
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.RadiusXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusXProperty
Visual Basic
Public Shared RadiusXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusXProperty

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..RadiusYProperty Field
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.RadiusYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusYProperty
Visual Basic
Public Shared RadiusYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusYProperty

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadialGradientBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Methods
RadialGradientBrush Class See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides GradientBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..GetProperty Method
RadialGradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadialGradientBrush Class
RadialGradientBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..GetRealType Method
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..InvokeMethod Method
RadialGradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadialGradientBrush Class
RadialGradientBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadialGradientBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Properties
RadialGradientBrush Class See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | Center |
Public property | ColorInterpolationMode | (Inherited from GradientBrush.)
Public property | GradientOrigin |
Public property | GradientStops | (Inherited from GradientBrush.)
Public property | MappingMode | (Inherited from GradientBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod | (Inherited from GradientBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Center Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..Center Property
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.Center"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Center { get; set; }
Visual Basic
Public Property Center As Point
    Get
    Set
Visual C++
public:
property Point^ Center {
    Point^ get ();
    void set (Point^ value);
}

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GradientOrigin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..GradientOrigin Property
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.GradientOrigin"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point GradientOrigin { get; set; }
Visual Basic
Public Property GradientOrigin As Point
    Get
    Set
Visual C++
public:
property Point^ GradientOrigin {
    Point^ get ();
    void set (Point^ value);
}

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..RadiusX Property
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.RadiusX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Double
    Get
    Set
Visual C++
public:
property double RadiusX {
    double get ();
    void set (double value);
}

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..RadiusY Property
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadialGradientBrush.RadiusY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Double
    Get
    Set
Visual C++
public:
property double RadiusY {
    double get ();
    void set (double value);
}

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadioButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Members
RadioButton Class Constructors Methods Fields Properties See Also Send Feedback

The RadioButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadioButton | Initializes a new instance of the RadioButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
GroupNameProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | GroupName |
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadioButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadioButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Constructor
RadioButton Class See Also Send Feedback
Initializes a new instance of the RadioButton class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RadioButton()
Visual Basic
Public Sub New
Visual C++
public:
RadioButton()

See Also

RadioButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadioButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Fields
RadioButton Class See Also Send Feedback

The RadioButton type exposes the following members.

Fields

Name | Description
GroupNameProperty |

See Also

RadioButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupNameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GroupNameProperty Field
RadioButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadioButton.GroupNameProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GroupNameProperty
Visual Basic
Public Shared GroupNameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GroupNameProperty

See Also

RadioButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadioButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Methods
RadioButton Class See Also Send Feedback

The RadioButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadioButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..AnySibling Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GetProperty Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GetRealType Method
RadioButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadioButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadioButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RadioButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GetRectangle Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..Highlight Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..InvokeMethod Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..IsHitTest Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..NextSibling Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..Parent Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..PreviousSibling Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..ScrollToVisible Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..SetProperty Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadioButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Properties
RadioButton Class See Also Send Feedback

The RadioButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | GroupName |
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadioButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GroupName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GroupName Property
RadioButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RadioButton.GroupName"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GroupName { get; set; }
Visual Basic
Public Property GroupName As String
    Get
    Set
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

See Also

RadioButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RangeBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Members
RangeBase Class Constructors Methods Fields Properties See Also Send Feedback

The RangeBase type exposes the following members.

Constructors

 | Name | Description
Public method | RangeBase | Initializes a new instance of the RangeBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
LargeChangeProperty |
MaximumProperty |
MinimumProperty |
SmallChangeProperty |
ValueProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LargeChange |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RangeBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Constructor
RangeBase Class See Also Send Feedback
Initializes a new instance of the RangeBase class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RangeBase()
Visual Basic
Public Sub New
Visual C++
public:
RangeBase()

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RangeBase Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Fields
RangeBase Class See Also Send Feedback

The RangeBase type exposes the following members.

Fields

Name | Description
LargeChangeProperty |
MaximumProperty |
MinimumProperty |
SmallChangeProperty |
ValueProperty |

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LargeChangeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..LargeChangeProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.LargeChangeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LargeChangeProperty
Visual Basic
Public Shared LargeChangeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LargeChangeProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaximumProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..MaximumProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.MaximumProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaximumProperty
Visual Basic
Public Shared MaximumProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaximumProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinimumProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..MinimumProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.MinimumProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinimumProperty
Visual Basic
Public Shared MinimumProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinimumProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SmallChangeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..SmallChangeProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.SmallChangeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SmallChangeProperty
Visual Basic
Public Shared SmallChangeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SmallChangeProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..ValueProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.ValueProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ValueProperty
Visual Basic
Public Shared ValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ValueProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RangeBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Methods
RangeBase Class See Also Send Feedback

The RangeBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..AnySibling Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..GetProperty Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..GetRealType Method
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..GetRectangle Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..Highlight Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..InvokeMethod Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..IsHitTest Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..NextSibling Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..Parent Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..PreviousSibling Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..ScrollToVisible Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..SetProperty Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RangeBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Properties
RangeBase Class See Also Send Feedback

The RangeBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LargeChange |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LargeChange Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..LargeChange Property
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.LargeChange"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double LargeChange { get; set; }
Visual Basic
Public Property LargeChange As Double
    Get
    Set
Visual C++
public:
virtual property double LargeChange {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IRangeBase..::..LargeChange

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Maximum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..Maximum Property
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.Maximum"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Maximum { get; set; }
Visual Basic
Public Property Maximum As Double
    Get
    Set
Visual C++
public:
virtual property double Maximum {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IRangeBase..::..Maximum

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Minimum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..Minimum Property
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.Minimum"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Minimum { get; set; }
Visual Basic
Public Property Minimum As Double
    Get
    Set
Visual C++
public:
virtual property double Minimum {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IRangeBase..::..Minimum

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SmallChange Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..SmallChange Property
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.SmallChange"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double SmallChange { get; set; }
Visual Basic
Public Property SmallChange As Double
    Get
    Set
Visual C++
public:
virtual property double SmallChange {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IRangeBase..::..SmallChange

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..Value Property
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RangeBase.Value"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Value { get; set; }
Visual Basic
Public Property Value As Double
    Get
    Set
Visual C++
public:
virtual property double Value {
    double get () sealed;
    void set (double value) sealed;
}

Implements

IRangeBase..::..Value

See Also

RangeBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rating Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating Members
Rating Class Constructors Methods Fields Properties See Also Send Feedback

The Rating type exposes the following members.

Constructors

 | Name | Description
Public method | Rating | Initializes a new instance of the Rating class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsReadOnlyProperty |
ItemCountProperty |
SelectionModeProperty |
ValueProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemCount |
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionMode |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rating Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating Constructor
Rating Class See Also Send Feedback
Initializes a new instance of the Rating class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rating()
Visual Basic
Public Sub New
Visual C++
public:
Rating()

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rating Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating Fields
Rating Class See Also Send Feedback

The Rating type exposes the following members.

Fields

Name | Description
IsReadOnlyProperty |
ItemCountProperty |
SelectionModeProperty |
ValueProperty |

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..IsReadOnlyProperty Field
Rating Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..ItemCountProperty Field
Rating Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.ItemCountProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemCountProperty
Visual Basic
Public Shared ItemCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemCountProperty

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..SelectionModeProperty Field
Rating Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.SelectionModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionModeProperty
Visual Basic
Public Shared SelectionModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionModeProperty

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..ValueProperty Field
Rating Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.ValueProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ValueProperty
Visual Basic
Public Shared ValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ValueProperty

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rating Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating Methods
Rating Class See Also Send Feedback

The Rating type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..AnySibling Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..GetProperty Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..GetRealType Method
Rating Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..GetRectangle Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..Highlight Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..InvokeMethod Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..IsHitTest Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..NextSibling Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..Parent Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..PreviousSibling Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..ScrollToVisible Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..SetProperty Method
Rating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rating Class
Rating Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rating Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating Properties
Rating Class See Also Send Feedback

The Rating type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemCount |
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionMode |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..IsReadOnly Property
Rating Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..ItemCount Property
Rating Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.ItemCount"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ItemCount { get; set; }
Visual Basic
Public Property ItemCount As Integer
    Get
    Set
Visual C++
public:
property int ItemCount {
    int get ();
    void set (int value);
}

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..SelectionMode Property
Rating Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.SelectionMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RatingSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As RatingSelectionMode
    Get
    Set
Visual C++
public:
property RatingSelectionMode SelectionMode {
    RatingSelectionMode get ();
    void set (RatingSelectionMode value);
}

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rating..::..Value Property
Rating Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rating.Value"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<double> Value { get; set; }
Visual Basic
Public Property Value As Nullable(Of Double)
    Get
    Set
Visual C++
public:
property Nullable<double> Value {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

See Also

Rating Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RatingItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem Members
RatingItem Class Constructors Methods Fields Properties See Also Send Feedback

The RatingItem type exposes the following members.

Constructors

 | Name | Description
Public method | RatingItem | Initializes a new instance of the RatingItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DisplayValueProperty |
IsReadOnlyProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayValue |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RatingItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem Constructor
RatingItem Class See Also Send Feedback
Initializes a new instance of the RatingItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RatingItem()
Visual Basic
Public Sub New
Visual C++
public:
RatingItem()

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RatingItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem Fields
RatingItem Class See Also Send Feedback

The RatingItem type exposes the following members.

Fields

Name | Description
DisplayValueProperty |
IsReadOnlyProperty |

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..DisplayValueProperty Field
RatingItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RatingItem.DisplayValueProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayValueProperty
Visual Basic
Public Shared DisplayValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayValueProperty

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..IsReadOnlyProperty Field
RatingItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RatingItem.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RatingItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem Methods
RatingItem Class See Also Send Feedback

The RatingItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..AnySibling Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..GetProperty Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..GetRealType Method
RatingItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RatingItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RatingItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..GetRectangle Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..Highlight Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..InvokeMethod Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..IsHitTest Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..NextSibling Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..Parent Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..PreviousSibling Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..ScrollToVisible Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..SetProperty Method
RatingItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RatingItem Class
RatingItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RatingItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem Properties
RatingItem Class See Also Send Feedback

The RatingItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayValue |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DisplayValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..DisplayValue Property
RatingItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RatingItem.DisplayValue"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double DisplayValue { get; set; }
Visual Basic
Public Property DisplayValue As Double
    Get
    Set
Visual C++
public:
property double DisplayValue {
    double get ();
    void set (double value);
}

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingItem..::..IsReadOnly Property
RatingItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RatingItem.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

RatingItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rect Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Members
Rect Class Constructors Methods Fields Properties See Also Send Feedback

The Rect type exposes the following members.

Constructors

 | Name | Description
Public method | Rect | Initializes a new instance of the Rect class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BottomLeftProperty |
BottomProperty |
BottomRightProperty |
HeightProperty |
IsEmptyProperty |
LeftProperty |
LocationProperty |
RightProperty |
SizeProperty |
TopLeftProperty |
TopProperty |
TopRightProperty |
WidthProperty |
XProperty |
YProperty |

Properties

 | Name | Description
Public property | Bottom |
Public property | BottomLeft |
Public property | BottomRight |
Public property | Height |
Public property | IsEmpty |
Public property | Left |
Public property | Location |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Right |
Public property | Size |
Public property | Top |
Public property | TopLeft |
Public property | TopRight |
Public property | Width |
Public property | X |
Public property | Y |

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rect Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Constructor
Rect Class See Also Send Feedback
Initializes a new instance of the Rect class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect()
Visual Basic
Public Sub New
Visual C++
public:
Rect()

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rect Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Fields
Rect Class See Also Send Feedback

The Rect type exposes the following members.

Fields

Name | Description
BottomLeftProperty |
BottomProperty |
BottomRightProperty |
HeightProperty |
IsEmptyProperty |
LeftProperty |
LocationProperty |
RightProperty |
SizeProperty |
TopLeftProperty |
TopProperty |
TopRightProperty |
WidthProperty |
XProperty |
YProperty |

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomLeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..BottomLeftProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.BottomLeftProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomLeftProperty
Visual Basic
Public Shared BottomLeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomLeftProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..BottomProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.BottomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomProperty
Visual Basic
Public Shared BottomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomRightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..BottomRightProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.BottomRightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomRightProperty
Visual Basic
Public Shared BottomRightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomRightProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..HeightProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.HeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeightProperty
Visual Basic
Public Shared HeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeightProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEmptyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..IsEmptyProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.IsEmptyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEmptyProperty
Visual Basic
Public Shared IsEmptyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEmptyProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..LeftProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.LeftProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LeftProperty
Visual Basic
Public Shared LeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LeftProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LocationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..LocationProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.LocationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LocationProperty
Visual Basic
Public Shared LocationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LocationProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..RightProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.RightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RightProperty
Visual Basic
Public Shared RightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RightProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..SizeProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.SizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SizeProperty
Visual Basic
Public Shared SizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SizeProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopLeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..TopLeftProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.TopLeftProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopLeftProperty
Visual Basic
Public Shared TopLeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopLeftProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..TopProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.TopProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopProperty
Visual Basic
Public Shared TopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopRightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..TopRightProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.TopRightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopRightProperty
Visual Basic
Public Shared TopRightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopRightProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..WidthProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.WidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..XProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.XProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..YProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.YProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rect Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Methods
Rect Class See Also Send Feedback

The Rect type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..GetProperty Method
Rect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rect Class
Rect Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..GetRealType Method
Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..InvokeMethod Method
Rect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rect Class
Rect Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rect Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Properties
Rect Class See Also Send Feedback

The Rect type exposes the following members.

Properties

 | Name | Description
Public property | Bottom |
Public property | BottomLeft |
Public property | BottomRight |
Public property | Height |
Public property | IsEmpty |
Public property | Left |
Public property | Location |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Right |
Public property | Size |
Public property | Top |
Public property | TopLeft |
Public property | TopRight |
Public property | Width |
Public property | X |
Public property | Y |

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Bottom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Bottom Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Bottom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Bottom { get; set; }
Visual Basic
Public Overridable Property Bottom As Double
    Get
    Set
Visual C++
public:
virtual property double Bottom {
    double get ();
    void set (double value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomLeft Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..BottomLeft Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.BottomLeft"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Point BottomLeft { get; set; }
Visual Basic
Public Overridable Property BottomLeft As Point
    Get
    Set
Visual C++
public:
virtual property Point^ BottomLeft {
    Point^ get ();
    void set (Point^ value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomRight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..BottomRight Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.BottomRight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Point BottomRight { get; set; }
Visual Basic
Public Overridable Property BottomRight As Point
    Get
    Set
Visual C++
public:
virtual property Point^ BottomRight {
    Point^ get ();
    void set (Point^ value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Height Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Height"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Height { get; set; }
Visual Basic
Public Overridable Property Height As Double
    Get
    Set
Visual C++
public:
virtual property double Height {
    double get ();
    void set (double value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEmpty Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..IsEmpty Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.IsEmpty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsEmpty { get; set; }
Visual Basic
Public Overridable Property IsEmpty As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
    void set (bool value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Left Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Left Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Left"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Left { get; set; }
Visual Basic
Public Overridable Property Left As Double
    Get
    Set
Visual C++
public:
virtual property double Left {
    double get ();
    void set (double value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Location Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Location Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Location"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Point Location { get; set; }
Visual Basic
Public Overridable Property Location As Point
    Get
    Set
Visual C++
public:
virtual property Point^ Location {
    Point^ get ();
    void set (Point^ value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Right Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Right Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Right"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Right { get; set; }
Visual Basic
Public Overridable Property Right As Double
    Get
    Set
Visual C++
public:
virtual property double Right {
    double get ();
    void set (double value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Size Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Size Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Size"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Size Size { get; set; }
Visual Basic
Public Overridable Property Size As Size
    Get
    Set
Visual C++
public:
virtual property Size^ Size {
    Size^ get ();
    void set (Size^ value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Top Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Top Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Top"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Top { get; set; }
Visual Basic
Public Overridable Property Top As Double
    Get
    Set
Visual C++
public:
virtual property double Top {
    double get ();
    void set (double value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopLeft Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..TopLeft Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.TopLeft"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Point TopLeft { get; set; }
Visual Basic
Public Overridable Property TopLeft As Point
    Get
    Set
Visual C++
public:
virtual property Point^ TopLeft {
    Point^ get ();
    void set (Point^ value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopRight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..TopRight Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.TopRight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Point TopRight { get; set; }
Visual Basic
Public Overridable Property TopRight As Point
    Get
    Set
Visual C++
public:
virtual property Point^ TopRight {
    Point^ get ();
    void set (Point^ value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Width Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Width"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Width { get; set; }
Visual Basic
Public Overridable Property Width As Double
    Get
    Set
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..X Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.X"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double X { get; set; }
Visual Basic
Public Overridable Property X As Double
    Get
    Set
Visual C++
public:
virtual property double X {
    double get ();
    void set (double value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..Y Property
Rect Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rect.Y"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Y { get; set; }
Visual Basic
Public Overridable Property Y As Double
    Get
    Set
Visual C++
public:
virtual property double Y {
    double get ();
    void set (double value);
}

See Also

Rect Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rectangle Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Members
Rectangle Class Constructors Methods Fields Properties See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | Rectangle | Initializes a new instance of the Rectangle class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
RadiusXProperty |
RadiusYProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rectangle Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Constructor
Rectangle Class See Also Send Feedback
Initializes a new instance of the Rectangle class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle()
Visual Basic
Public Sub New
Visual C++
public:
Rectangle()

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rectangle Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Fields
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Fields

Name | Description
RadiusXProperty |
RadiusYProperty |

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..RadiusXProperty Field
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rectangle.RadiusXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusXProperty
Visual Basic
Public Shared RadiusXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusXProperty

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..RadiusYProperty Field
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rectangle.RadiusYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusYProperty
Visual Basic
Public Shared RadiusYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusYProperty

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rectangle Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..AnySibling Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..GetProperty Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..GetRealType Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rectangle.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rectangle.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..GetRectangle Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..Highlight Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..InvokeMethod Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..IsHitTest Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..NextSibling Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..Parent Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..PreviousSibling Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..ScrollToVisible Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..SetProperty Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rectangle Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..RadiusX Property
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rectangle.RadiusX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Double
    Get
    Set
Visual C++
public:
property double RadiusX {
    double get ();
    void set (double value);
}

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..RadiusY Property
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rectangle.RadiusY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Double
    Get
    Set
Visual C++
public:
property double RadiusY {
    double get ();
    void set (double value);
}

See Also

Rectangle Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RectangleGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Members
RectangleGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The RectangleGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleGeometry | Initializes a new instance of the RectangleGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
RadiusXProperty |
RadiusYProperty |
RectProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Rect |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RectangleGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Constructor
RectangleGeometry Class See Also Send Feedback
Initializes a new instance of the RectangleGeometry class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RectangleGeometry()
Visual Basic
Public Sub New
Visual C++
public:
RectangleGeometry()

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RectangleGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Fields
RectangleGeometry Class See Also Send Feedback

The RectangleGeometry type exposes the following members.

Fields

Name | Description
RadiusXProperty |
RadiusYProperty |
RectProperty |

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..RadiusXProperty Field
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RectangleGeometry.RadiusXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusXProperty
Visual Basic
Public Shared RadiusXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusXProperty

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..RadiusYProperty Field
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RectangleGeometry.RadiusYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusYProperty
Visual Basic
Public Shared RadiusYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusYProperty

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RectProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..RectProperty Field
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RectangleGeometry.RectProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RectProperty
Visual Basic
Public Shared RectProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RectProperty

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RectangleGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Methods
RectangleGeometry Class See Also Send Feedback

The RectangleGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..GetProperty Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RectangleGeometry Class
RectangleGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..GetRealType Method
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RectangleGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RectangleGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..InvokeMethod Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RectangleGeometry Class
RectangleGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RectangleGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Properties
RectangleGeometry Class See Also Send Feedback

The RectangleGeometry type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Rect |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..RadiusX Property
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RectangleGeometry.RadiusX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Double
    Get
    Set
Visual C++
public:
property double RadiusX {
    double get ();
    void set (double value);
}

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RadiusY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..RadiusY Property
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RectangleGeometry.RadiusY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Double
    Get
    Set
Visual C++
public:
property double RadiusY {
    double get ();
    void set (double value);
}

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rect Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..Rect Property
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RectangleGeometry.Rect"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect Rect { get; set; }
Visual Basic
Public Property Rect As Rect
    Get
    Set
Visual C++
public:
property Rect^ Rect {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RenderTargetBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RenderTargetBitmap Members
RenderTargetBitmap Class Constructors Methods Properties See Also Send Feedback

The RenderTargetBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | RenderTargetBitmap | Initializes a new instance of the RenderTargetBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RenderTargetBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RenderTargetBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RenderTargetBitmap Constructor
RenderTargetBitmap Class See Also Send Feedback
Initializes a new instance of the RenderTargetBitmap class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RenderTargetBitmap()
Visual Basic
Public Sub New
Visual C++
public:
RenderTargetBitmap()

See Also

RenderTargetBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RenderTargetBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RenderTargetBitmap Methods
RenderTargetBitmap Class See Also Send Feedback

The RenderTargetBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderTargetBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RenderTargetBitmap..::..GetProperty Method
RenderTargetBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RenderTargetBitmap Class
RenderTargetBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RenderTargetBitmap..::..GetRealType Method
RenderTargetBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RenderTargetBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RenderTargetBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RenderTargetBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RenderTargetBitmap..::..InvokeMethod Method
RenderTargetBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RenderTargetBitmap Class
RenderTargetBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RenderTargetBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RenderTargetBitmap Properties
RenderTargetBitmap Class See Also Send Feedback

The RenderTargetBitmap type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RenderTargetBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RepeatButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Members
RepeatButton Class Constructors Methods Fields Properties See Also Send Feedback

The RepeatButton type exposes the following members.

Constructors

 | Name | Description
Public method | RepeatButton | Initializes a new instance of the RepeatButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UserPress | Press and hold the RepeatButton for the specified number of milliseconds
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DelayProperty |
IntervalProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Delay |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | Interval |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RepeatButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Constructor
RepeatButton Class See Also Send Feedback
Initializes a new instance of the RepeatButton class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RepeatButton()
Visual Basic
Public Sub New
Visual C++
public:
RepeatButton()

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RepeatButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Fields
RepeatButton Class See Also Send Feedback

The RepeatButton type exposes the following members.

Fields

Name | Description
DelayProperty |
IntervalProperty |

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DelayProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..DelayProperty Field
RepeatButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RepeatButton.DelayProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DelayProperty
Visual Basic
Public Shared DelayProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DelayProperty

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IntervalProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..IntervalProperty Field
RepeatButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RepeatButton.IntervalProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IntervalProperty
Visual Basic
Public Shared IntervalProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IntervalProperty

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RepeatButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Methods
RepeatButton Class See Also Send Feedback

The RepeatButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UserPress | Press and hold the RepeatButton for the specified number of milliseconds
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..AnySibling Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..GetProperty Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..GetRealType Method
RepeatButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RepeatButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RepeatButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..GetRectangle Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..Highlight Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..InvokeMethod Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..IsHitTest Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..NextSibling Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..Parent Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..PreviousSibling Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..ScrollToVisible Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..SetProperty Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UserPress Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..UserPress Method
RepeatButton Class See Also Send Feedback
Press and hold the RepeatButton for the specified number of milliseconds

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void UserPress(
    int holdTime
)
Visual Basic
Public Sub UserPress ( _
    holdTime As Integer _
)
Visual C++
public:
virtual void UserPress(
    int holdTime
) sealed

Parameters

holdTime
Type: System..::..Int32
The number of milliseconds to hold the button down for.

Implements

IRepeatButton..::..UserPress(Int32)

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RepeatButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Properties
RepeatButton Class See Also Send Feedback

The RepeatButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Delay |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | Interval |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Delay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..Delay Property
RepeatButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RepeatButton.Delay"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Delay { get; set; }
Visual Basic
Public Property Delay As Integer
    Get
    Set
Visual C++
public:
property int Delay {
    int get ();
    void set (int value);
}

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Interval Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..Interval Property
RepeatButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RepeatButton.Interval"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Interval { get; set; }
Visual Basic
Public Property Interval As Integer
    Get
    Set
Visual C++
public:
property int Interval {
    int get ();
    void set (int value);
}

See Also

RepeatButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeGrip Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip Members
ResizeGrip Class Constructors Methods Properties See Also Send Feedback

The ResizeGrip type exposes the following members.

Constructors

 | Name | Description
Public method | ResizeGrip | Initializes a new instance of the ResizeGrip class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeGrip Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip Constructor
ResizeGrip Class See Also Send Feedback
Initializes a new instance of the ResizeGrip class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ResizeGrip()
Visual Basic
Public Sub New
Visual C++
public:
ResizeGrip()

See Also

ResizeGrip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeGrip Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip Methods
ResizeGrip Class See Also Send Feedback

The ResizeGrip type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..AnySibling Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..GetProperty Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..GetRealType Method
ResizeGrip Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ResizeGrip.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ResizeGrip.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ResizeGrip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..GetRectangle Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..Highlight Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..InvokeMethod Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..IsHitTest Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..NextSibling Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..Parent Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..PreviousSibling Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..ScrollToVisible Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip..::..SetProperty Method
ResizeGrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ResizeGrip Class
ResizeGrip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeGrip Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResizeGrip Properties
ResizeGrip Class See Also Send Feedback

The ResizeGrip type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ResizeGrip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RichTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Members
RichTextBox Class Constructors Methods Fields Properties See Also Send Feedback

The RichTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | RichTextBox | Initializes a new instance of the RichTextBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides TextBoxBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsDocumentEnabledProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn | (Inherited from TextBoxBase.)
Public property | AcceptsTab | (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoWordSelection | (Inherited from TextBoxBase.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDocumentEnabled |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly | (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsUndoEnabled | (Inherited from TextBoxBase.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UndoLimit | (Inherited from TextBoxBase.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RichTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RichTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Constructor
RichTextBox Class See Also Send Feedback
Initializes a new instance of the RichTextBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RichTextBox()
Visual Basic
Public Sub New
Visual C++
public:
RichTextBox()

See Also

RichTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RichTextBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Fields
RichTextBox Class See Also Send Feedback

The RichTextBox type exposes the following members.

Fields

Name | Description
IsDocumentEnabledProperty |

See Also

RichTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDocumentEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..IsDocumentEnabledProperty Field
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RichTextBox.IsDocumentEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDocumentEnabledProperty
Visual Basic
Public Shared IsDocumentEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDocumentEnabledProperty

See Also

RichTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RichTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Methods
RichTextBox Class See Also Send Feedback

The RichTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides TextBoxBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..AnySibling Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..GetProperty Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..GetRealType Method
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RichTextBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RichTextBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RichTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..GetRectangle Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..Highlight Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..InvokeMethod Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..IsHitTest Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..NextSibling Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..Parent Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..PreviousSibling Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..ScrollToVisible Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..SetProperty Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RichTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Properties
RichTextBox Class See Also Send Feedback

The RichTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn | (Inherited from TextBoxBase.)
Public property | AcceptsTab | (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoWordSelection | (Inherited from TextBoxBase.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDocumentEnabled |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly | (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsUndoEnabled | (Inherited from TextBoxBase.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UndoLimit | (Inherited from TextBoxBase.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RichTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDocumentEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..IsDocumentEnabled Property
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RichTextBox.IsDocumentEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDocumentEnabled { get; set; }
Visual Basic
Public Property IsDocumentEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsDocumentEnabled {
    bool get ();
    void set (bool value);
}

See Also

RichTextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Members
RotateTransform Class Constructors Methods Fields Properties See Also Send Feedback

The RotateTransform type exposes the following members.

Constructors

 | Name | Description
Public method | RotateTransform | Initializes a new instance of the RotateTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AngleProperty |
CenterXProperty |
CenterYProperty |

Properties

 | Name | Description
Public property | Angle |
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Constructor
RotateTransform Class See Also Send Feedback
Initializes a new instance of the RotateTransform class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RotateTransform()
Visual Basic
Public Sub New
Visual C++
public:
RotateTransform()

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Fields
RotateTransform Class See Also Send Feedback

The RotateTransform type exposes the following members.

Fields

Name | Description
AngleProperty |
CenterXProperty |
CenterYProperty |

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AngleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..AngleProperty Field
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform.AngleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AngleProperty
Visual Basic
Public Shared AngleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AngleProperty

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..CenterXProperty Field
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..CenterYProperty Field
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Methods
RotateTransform Class See Also Send Feedback

The RotateTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..GetProperty Method
RotateTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform Class
RotateTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..GetRealType Method
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..InvokeMethod Method
RotateTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform Class
RotateTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Properties
RotateTransform Class See Also Send Feedback

The RotateTransform type exposes the following members.

Properties

 | Name | Description
Public property | Angle |
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Angle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..Angle Property
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform.Angle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..CenterX Property
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform.CenterX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterX { get; set; }
Visual Basic
Public Property CenterX As Double
    Get
    Set
Visual C++
public:
property double CenterX {
    double get ();
    void set (double value);
}

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..CenterY Property
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform.CenterY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterY { get; set; }
Visual Basic
Public Property CenterY As Double
    Get
    Set
Visual C++
public:
property double CenterY {
    double get ();
    void set (double value);
}

See Also

RotateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D Members
RotateTransform3D Class Constructors Methods Fields Properties See Also Send Feedback

The RotateTransform3D type exposes the following members.

Constructors

 | Name | Description
Public method | RotateTransform3D | Initializes a new instance of the RotateTransform3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AffineTransform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterXProperty |
CenterYProperty |
CenterZProperty |
RotationProperty |

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | CenterZ |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rotation |

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D Constructor
RotateTransform3D Class See Also Send Feedback
Initializes a new instance of the RotateTransform3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RotateTransform3D()
Visual Basic
Public Sub New
Visual C++
public:
RotateTransform3D()

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D Fields
RotateTransform3D Class See Also Send Feedback

The RotateTransform3D type exposes the following members.

Fields

Name | Description
CenterXProperty |
CenterYProperty |
CenterZProperty |
RotationProperty |

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..CenterXProperty Field
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..CenterYProperty Field
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterZProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..CenterZProperty Field
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.CenterZProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterZProperty
Visual Basic
Public Shared CenterZProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterZProperty

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..RotationProperty Field
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.RotationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RotationProperty
Visual Basic
Public Shared RotationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RotationProperty

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D Methods
RotateTransform3D Class See Also Send Feedback

The RotateTransform3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AffineTransform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..GetProperty Method
RotateTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform3D Class
RotateTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..GetRealType Method
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..InvokeMethod Method
RotateTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform3D Class
RotateTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RotateTransform3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D Properties
RotateTransform3D Class See Also Send Feedback

The RotateTransform3D type exposes the following members.

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | CenterZ |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rotation |

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..CenterX Property
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.CenterX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterX { get; set; }
Visual Basic
Public Property CenterX As Double
    Get
    Set
Visual C++
public:
property double CenterX {
    double get ();
    void set (double value);
}

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..CenterY Property
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.CenterY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterY { get; set; }
Visual Basic
Public Property CenterY As Double
    Get
    Set
Visual C++
public:
property double CenterY {
    double get ();
    void set (double value);
}

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterZ Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..CenterZ Property
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.CenterZ"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterZ { get; set; }
Visual Basic
Public Property CenterZ As Double
    Get
    Set
Visual C++
public:
property double CenterZ {
    double get ();
    void set (double value);
}

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rotation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform3D..::..Rotation Property
RotateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.RotateTransform3D.Rotation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rotation3D Rotation { get; set; }
Visual Basic
Public Property Rotation As Rotation3D
    Get
    Set
Visual C++
public:
property Rotation3D^ Rotation {
    Rotation3D^ get ();
    void set (Rotation3D^ value);
}

See Also

RotateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rotation3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rotation3D Members
Rotation3D Class Constructors Methods Properties See Also Send Feedback

The Rotation3D type exposes the following members.

Constructors

 | Name | Description
Public method | Rotation3D | Initializes a new instance of the Rotation3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rotation3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rotation3D Constructor
Rotation3D Class See Also Send Feedback
Initializes a new instance of the Rotation3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rotation3D()
Visual Basic
Public Sub New
Visual C++
public:
Rotation3D()

See Also

Rotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rotation3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rotation3D Methods
Rotation3D Class See Also Send Feedback

The Rotation3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rotation3D..::..GetProperty Method
Rotation3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rotation3D Class
Rotation3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rotation3D..::..GetRealType Method
Rotation3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rotation3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Rotation3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Rotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rotation3D..::..InvokeMethod Method
Rotation3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rotation3D Class
Rotation3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rotation3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rotation3D Properties
Rotation3D Class See Also Send Feedback

The Rotation3D type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rotation3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Run Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Members
Run Class Constructors Methods Properties See Also Send Feedback

The Run type exposes the following members.

Constructors

 | Name | Description
Public method | Run | Initializes a new instance of the Run class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Background | (Inherited from Inline.)
Public property | FlowDirection | (Inherited from Inline.)
Public property | FontFamily | (Inherited from Inline.)
Public property | FontSize | (Inherited from Inline.)
Public property | FontStretch | (Inherited from Inline.)
Public property | FontStyle | (Inherited from Inline.)
Public property | FontWeight | (Inherited from Inline.)
Public property | Foreground | (Inherited from Inline.)
Public property | Text |

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Run Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Constructor
Run Class See Also Send Feedback
Initializes a new instance of the Run class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Run(
    Run run
)
Visual Basic
Public Sub New ( _
    run As Run _
)
Visual C++
public:
Run(
    Run^ run
)

Parameters

run
Type: System.Windows.Documents..::..Run

[Missing <param name="run"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Run.#ctor(System.Windows.Documents.Run)"]

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Run Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Methods
Run Class See Also Send Feedback

The Run type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Run Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run Properties
Run Class See Also Send Feedback

The Run type exposes the following members.

Properties

 | Name | Description
Public property | Background | (Inherited from Inline.)
Public property | FlowDirection | (Inherited from Inline.)
Public property | FontFamily | (Inherited from Inline.)
Public property | FontSize | (Inherited from Inline.)
Public property | FontStretch | (Inherited from Inline.)
Public property | FontStyle | (Inherited from Inline.)
Public property | FontWeight | (Inherited from Inline.)
Public property | Foreground | (Inherited from Inline.)
Public property | Text |

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Run..::..Text Property
Run Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Run.Text"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; private set; }
Visual Basic
Public Property Text As String
    Get
    Private Set
Visual C++
public:
property String^ Text {
    String^ get ();
    private: void set (String^ value);
}

See Also

Run Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Members
ScaleTransform Class Constructors Methods Fields Properties See Also Send Feedback

The ScaleTransform type exposes the following members.

Constructors

 | Name | Description
Public method | ScaleTransform | Initializes a new instance of the ScaleTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterXProperty |
CenterYProperty |
ScaleXProperty |
ScaleYProperty |

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ScaleX |
Public property | ScaleY |

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Constructor
ScaleTransform Class See Also Send Feedback
Initializes a new instance of the ScaleTransform class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScaleTransform()
Visual Basic
Public Sub New
Visual C++
public:
ScaleTransform()

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Fields
ScaleTransform Class See Also Send Feedback

The ScaleTransform type exposes the following members.

Fields

Name | Description
CenterXProperty |
CenterYProperty |
ScaleXProperty |
ScaleYProperty |

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..CenterXProperty Field
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..CenterYProperty Field
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..ScaleXProperty Field
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.ScaleXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleXProperty
Visual Basic
Public Shared ScaleXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleXProperty

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..ScaleYProperty Field
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.ScaleYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleYProperty
Visual Basic
Public Shared ScaleYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleYProperty

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Methods
ScaleTransform Class See Also Send Feedback

The ScaleTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..GetProperty Method
ScaleTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScaleTransform Class
ScaleTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..GetRealType Method
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..InvokeMethod Method
ScaleTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScaleTransform Class
ScaleTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Properties
ScaleTransform Class See Also Send Feedback

The ScaleTransform type exposes the following members.

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ScaleX |
Public property | ScaleY |

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..CenterX Property
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.CenterX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterX { get; set; }
Visual Basic
Public Property CenterX As Double
    Get
    Set
Visual C++
public:
property double CenterX {
    double get ();
    void set (double value);
}

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..CenterY Property
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.CenterY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterY { get; set; }
Visual Basic
Public Property CenterY As Double
    Get
    Set
Visual C++
public:
property double CenterY {
    double get ();
    void set (double value);
}

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..ScaleX Property
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.ScaleX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScaleX { get; set; }
Visual Basic
Public Property ScaleX As Double
    Get
    Set
Visual C++
public:
property double ScaleX {
    double get ();
    void set (double value);
}

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..ScaleY Property
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform.ScaleY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScaleY { get; set; }
Visual Basic
Public Property ScaleY As Double
    Get
    Set
Visual C++
public:
property double ScaleY {
    double get ();
    void set (double value);
}

See Also

ScaleTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D Members
ScaleTransform3D Class Constructors Methods Fields Properties See Also Send Feedback

The ScaleTransform3D type exposes the following members.

Constructors

 | Name | Description
Public method | ScaleTransform3D | Initializes a new instance of the ScaleTransform3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AffineTransform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterXProperty |
CenterYProperty |
CenterZProperty |
ScaleXProperty |
ScaleYProperty |
ScaleZProperty |

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | CenterZ |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ScaleX |
Public property | ScaleY |
Public property | ScaleZ |

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D Constructor
ScaleTransform3D Class See Also Send Feedback
Initializes a new instance of the ScaleTransform3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScaleTransform3D()
Visual Basic
Public Sub New
Visual C++
public:
ScaleTransform3D()

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D Fields
ScaleTransform3D Class See Also Send Feedback

The ScaleTransform3D type exposes the following members.

Fields

Name | Description
CenterXProperty |
CenterYProperty |
CenterZProperty |
ScaleXProperty |
ScaleYProperty |
ScaleZProperty |

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..CenterXProperty Field
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..CenterYProperty Field
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterZProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..CenterZProperty Field
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.CenterZProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterZProperty
Visual Basic
Public Shared CenterZProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterZProperty

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..ScaleXProperty Field
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.ScaleXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleXProperty
Visual Basic
Public Shared ScaleXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleXProperty

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..ScaleYProperty Field
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.ScaleYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleYProperty
Visual Basic
Public Shared ScaleYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleYProperty

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleZProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..ScaleZProperty Field
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.ScaleZProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleZProperty
Visual Basic
Public Shared ScaleZProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleZProperty

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D Methods
ScaleTransform3D Class See Also Send Feedback

The ScaleTransform3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AffineTransform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..GetProperty Method
ScaleTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScaleTransform3D Class
ScaleTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..GetRealType Method
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..InvokeMethod Method
ScaleTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScaleTransform3D Class
ScaleTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleTransform3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D Properties
ScaleTransform3D Class See Also Send Feedback

The ScaleTransform3D type exposes the following members.

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | CenterZ |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ScaleX |
Public property | ScaleY |
Public property | ScaleZ |

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..CenterX Property
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.CenterX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterX { get; set; }
Visual Basic
Public Property CenterX As Double
    Get
    Set
Visual C++
public:
property double CenterX {
    double get ();
    void set (double value);
}

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..CenterY Property
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.CenterY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterY { get; set; }
Visual Basic
Public Property CenterY As Double
    Get
    Set
Visual C++
public:
property double CenterY {
    double get ();
    void set (double value);
}

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterZ Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..CenterZ Property
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.CenterZ"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterZ { get; set; }
Visual Basic
Public Property CenterZ As Double
    Get
    Set
Visual C++
public:
property double CenterZ {
    double get ();
    void set (double value);
}

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..ScaleX Property
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.ScaleX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScaleX { get; set; }
Visual Basic
Public Property ScaleX As Double
    Get
    Set
Visual C++
public:
property double ScaleX {
    double get ();
    void set (double value);
}

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..ScaleY Property
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.ScaleY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScaleY { get; set; }
Visual Basic
Public Property ScaleY As Double
    Get
    Set
Visual C++
public:
property double ScaleY {
    double get ();
    void set (double value);
}

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScaleZ Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform3D..::..ScaleZ Property
ScaleTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScaleTransform3D.ScaleZ"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScaleZ { get; set; }
Visual Basic
Public Property ScaleZ As Double
    Get
    Set
Visual C++
public:
property double ScaleZ {
    double get ();
    void set (double value);
}

See Also

ScaleTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Members
ScrollBar Class Constructors Methods Fields Properties See Also Send Feedback

The ScrollBar type exposes the following members.

Constructors

 | Name | Description
Public method | ScrollBar | Initializes a new instance of the ScrollBar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
OrientationProperty |
ViewportSizeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | ViewportSize |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Constructor
ScrollBar Class See Also Send Feedback
Initializes a new instance of the ScrollBar class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBar()
Visual Basic
Public Sub New
Visual C++
public:
ScrollBar()

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Fields
ScrollBar Class See Also Send Feedback

The ScrollBar type exposes the following members.

Fields

Name | Description
OrientationProperty |
ViewportSizeProperty |

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..OrientationProperty Field
ScrollBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollBar.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..ViewportSizeProperty Field
ScrollBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollBar.ViewportSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportSizeProperty
Visual Basic
Public Shared ViewportSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportSizeProperty

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Methods
ScrollBar Class See Also Send Feedback

The ScrollBar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..AnySibling Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..GetProperty Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..GetRealType Method
ScrollBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollBar.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollBar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..GetRectangle Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..Highlight Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..InvokeMethod Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..IsHitTest Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..NextSibling Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..Parent Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..PreviousSibling Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..ScrollToVisible Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..SetProperty Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Properties
ScrollBar Class See Also Send Feedback

The ScrollBar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | ViewportSize |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..Orientation Property
ScrollBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollBar.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..ViewportSize Property
ScrollBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollBar.ViewportSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ViewportSize { get; set; }
Visual Basic
Public Property ViewportSize As Double
    Get
    Set
Visual C++
public:
property double ViewportSize {
    double get ();
    void set (double value);
}

See Also

ScrollBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollContentPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Members
ScrollContentPresenter Class Constructors Methods Fields Properties See Also Send Feedback

The ScrollContentPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | ScrollContentPresenter | Initializes a new instance of the ScrollContentPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentPresenter..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanContentScrollProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | CanContentScroll |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentSource | (Inherited from ContentPresenter.)
Public property | ContentStringFormat | (Inherited from ContentPresenter.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RecognizesAccessKey | (Inherited from ContentPresenter.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollContentPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Constructor
ScrollContentPresenter Class See Also Send Feedback
Initializes a new instance of the ScrollContentPresenter class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollContentPresenter()
Visual Basic
Public Sub New
Visual C++
public:
ScrollContentPresenter()

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollContentPresenter Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Fields
ScrollContentPresenter Class See Also Send Feedback

The ScrollContentPresenter type exposes the following members.

Fields

Name | Description
CanContentScrollProperty |

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanContentScrollProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..CanContentScrollProperty Field
ScrollContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollContentPresenter.CanContentScrollProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanContentScrollProperty
Visual Basic
Public Shared CanContentScrollProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanContentScrollProperty

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollContentPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Methods
ScrollContentPresenter Class See Also Send Feedback

The ScrollContentPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentPresenter..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..AnySibling Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..GetProperty Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..GetRealType Method
ScrollContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollContentPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollContentPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..GetRectangle Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..Highlight Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..InvokeMethod Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..IsHitTest Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..NextSibling Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..Parent Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..PreviousSibling Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..ScrollToVisible Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..SetProperty Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollContentPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Properties
ScrollContentPresenter Class See Also Send Feedback

The ScrollContentPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | CanContentScroll |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentSource | (Inherited from ContentPresenter.)
Public property | ContentStringFormat | (Inherited from ContentPresenter.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RecognizesAccessKey | (Inherited from ContentPresenter.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanContentScroll Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..CanContentScroll Property
ScrollContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollContentPresenter.CanContentScroll"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanContentScroll { get; set; }
Visual Basic
Public Property CanContentScroll As Boolean
    Get
    Set
Visual C++
public:
property bool CanContentScroll {
    bool get ();
    void set (bool value);
}

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollViewer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Members
ScrollViewer Class Constructors Methods Fields Properties See Also Send Feedback

The ScrollViewer type exposes the following members.

Constructors

 | Name | Description
Public method | ScrollViewer | Initializes a new instance of the ScrollViewer class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanContentScrollProperty |
ComputedHorizontalScrollBarVisibilityProperty |
ComputedVerticalScrollBarVisibilityProperty |
ContentHorizontalOffsetProperty |
ContentVerticalOffsetProperty |
ExtentHeightProperty |
ExtentWidthProperty |
HorizontalOffsetProperty |
HorizontalScrollBarVisibilityProperty |
IsDeferredScrollingEnabledProperty |
ScrollableHeightProperty |
ScrollableWidthProperty |
VerticalOffsetProperty |
VerticalScrollBarVisibilityProperty |
ViewportHeightProperty |
ViewportWidthProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanContentScroll |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedHorizontalScrollBarVisibility |
Public property | ComputedVerticalScrollBarVisibility |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentHorizontalOffset |
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentVerticalOffset |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExtentHeight |
Public property | ExtentWidth |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDeferredScrollingEnabled |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ScrollableHeight |
Public property | ScrollableWidth |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | VerticalScrollBarVisibility |
Public property | ViewportHeight |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollViewer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Constructor
ScrollViewer Class See Also Send Feedback
Initializes a new instance of the ScrollViewer class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollViewer()
Visual Basic
Public Sub New
Visual C++
public:
ScrollViewer()

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollViewer Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Fields
ScrollViewer Class See Also Send Feedback

The ScrollViewer type exposes the following members.

Fields

Name | Description
CanContentScrollProperty |
ComputedHorizontalScrollBarVisibilityProperty |
ComputedVerticalScrollBarVisibilityProperty |
ContentHorizontalOffsetProperty |
ContentVerticalOffsetProperty |
ExtentHeightProperty |
ExtentWidthProperty |
HorizontalOffsetProperty |
HorizontalScrollBarVisibilityProperty |
IsDeferredScrollingEnabledProperty |
ScrollableHeightProperty |
ScrollableWidthProperty |
VerticalOffsetProperty |
VerticalScrollBarVisibilityProperty |
ViewportHeightProperty |
ViewportWidthProperty |

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanContentScrollProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..CanContentScrollProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.CanContentScrollProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanContentScrollProperty
Visual Basic
Public Shared CanContentScrollProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanContentScrollProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComputedHorizontalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ComputedHorizontalScrollBarVisibilityProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ComputedHorizontalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ComputedHorizontalScrollBarVisibilityProperty
Visual Basic
Public Shared ComputedHorizontalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ComputedHorizontalScrollBarVisibilityProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComputedVerticalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ComputedVerticalScrollBarVisibilityProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ComputedVerticalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ComputedVerticalScrollBarVisibilityProperty
Visual Basic
Public Shared ComputedVerticalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ComputedVerticalScrollBarVisibilityProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentHorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ContentHorizontalOffsetProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ContentHorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentHorizontalOffsetProperty
Visual Basic
Public Shared ContentHorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentHorizontalOffsetProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentVerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ContentVerticalOffsetProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ContentVerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentVerticalOffsetProperty
Visual Basic
Public Shared ContentVerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentVerticalOffsetProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExtentHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ExtentHeightProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ExtentHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExtentHeightProperty
Visual Basic
Public Shared ExtentHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExtentHeightProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExtentWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ExtentWidthProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ExtentWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExtentWidthProperty
Visual Basic
Public Shared ExtentWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExtentWidthProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..HorizontalOffsetProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..HorizontalScrollBarVisibilityProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.HorizontalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalScrollBarVisibilityProperty
Visual Basic
Public Shared HorizontalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalScrollBarVisibilityProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDeferredScrollingEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..IsDeferredScrollingEnabledProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.IsDeferredScrollingEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDeferredScrollingEnabledProperty
Visual Basic
Public Shared IsDeferredScrollingEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDeferredScrollingEnabledProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollableHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ScrollableHeightProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ScrollableHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScrollableHeightProperty
Visual Basic
Public Shared ScrollableHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScrollableHeightProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollableWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ScrollableWidthProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ScrollableWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScrollableWidthProperty
Visual Basic
Public Shared ScrollableWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScrollableWidthProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..VerticalOffsetProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..VerticalScrollBarVisibilityProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.VerticalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalScrollBarVisibilityProperty
Visual Basic
Public Shared VerticalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalScrollBarVisibilityProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ViewportHeightProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ViewportHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportHeightProperty
Visual Basic
Public Shared ViewportHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportHeightProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ViewportWidthProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ViewportWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportWidthProperty
Visual Basic
Public Shared ViewportWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportWidthProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollViewer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Methods
ScrollViewer Class See Also Send Feedback

The ScrollViewer type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..AnySibling Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..GetProperty Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..GetRealType Method
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..GetRectangle Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..Highlight Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..InvokeMethod Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..IsHitTest Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..NextSibling Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..Parent Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..PreviousSibling Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ScrollToVisible Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..SetProperty Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollViewer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Properties
ScrollViewer Class See Also Send Feedback

The ScrollViewer type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanContentScroll |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedHorizontalScrollBarVisibility |
Public property | ComputedVerticalScrollBarVisibility |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentHorizontalOffset |
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentVerticalOffset |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExtentHeight |
Public property | ExtentWidth |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDeferredScrollingEnabled |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ScrollableHeight |
Public property | ScrollableWidth |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | VerticalScrollBarVisibility |
Public property | ViewportHeight |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CanContentScroll Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..CanContentScroll Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.CanContentScroll"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanContentScroll { get; set; }
Visual Basic
Public Property CanContentScroll As Boolean
    Get
    Set
Visual C++
public:
property bool CanContentScroll {
    bool get ();
    void set (bool value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComputedHorizontalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ComputedHorizontalScrollBarVisibility Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ComputedHorizontalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility ComputedHorizontalScrollBarVisibility { get; set; }
Visual Basic
Public Property ComputedHorizontalScrollBarVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility ComputedHorizontalScrollBarVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComputedVerticalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ComputedVerticalScrollBarVisibility Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ComputedVerticalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility ComputedVerticalScrollBarVisibility { get; set; }
Visual Basic
Public Property ComputedVerticalScrollBarVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility ComputedVerticalScrollBarVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentHorizontalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ContentHorizontalOffset Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ContentHorizontalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ContentHorizontalOffset { get; set; }
Visual Basic
Public Property ContentHorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double ContentHorizontalOffset {
    double get ();
    void set (double value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentVerticalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ContentVerticalOffset Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ContentVerticalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ContentVerticalOffset { get; set; }
Visual Basic
Public Property ContentVerticalOffset As Double
    Get
    Set
Visual C++
public:
property double ContentVerticalOffset {
    double get ();
    void set (double value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExtentHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ExtentHeight Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ExtentHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ExtentHeight { get; set; }
Visual Basic
Public Property ExtentHeight As Double
    Get
    Set
Visual C++
public:
property double ExtentHeight {
    double get ();
    void set (double value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ExtentWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ExtentWidth Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ExtentWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ExtentWidth { get; set; }
Visual Basic
Public Property ExtentWidth As Double
    Get
    Set
Visual C++
public:
property double ExtentWidth {
    double get ();
    void set (double value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..HorizontalOffset Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.HorizontalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double HorizontalOffset { get; }
Visual Basic
Public ReadOnly Property HorizontalOffset As Double
    Get
Visual C++
public:
property double HorizontalOffset {
    double get ();
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..HorizontalScrollBarVisibility Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.HorizontalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility HorizontalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDeferredScrollingEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..IsDeferredScrollingEnabled Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.IsDeferredScrollingEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDeferredScrollingEnabled { get; set; }
Visual Basic
Public Property IsDeferredScrollingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsDeferredScrollingEnabled {
    bool get ();
    void set (bool value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollableHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ScrollableHeight Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ScrollableHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScrollableHeight { get; set; }
Visual Basic
Public Property ScrollableHeight As Double
    Get
    Set
Visual C++
public:
property double ScrollableHeight {
    double get ();
    void set (double value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollableWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ScrollableWidth Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ScrollableWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScrollableWidth { get; set; }
Visual Basic
Public Property ScrollableWidth As Double
    Get
    Set
Visual C++
public:
property double ScrollableWidth {
    double get ();
    void set (double value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..VerticalOffset Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.VerticalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double VerticalOffset { get; }
Visual Basic
Public ReadOnly Property VerticalOffset As Double
    Get
Visual C++
public:
property double VerticalOffset {
    double get ();
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..VerticalScrollBarVisibility Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.VerticalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic
Public Property VerticalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility VerticalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ViewportHeight Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ViewportHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ViewportHeight { get; set; }
Visual Basic
Public Property ViewportHeight As Double
    Get
    Set
Visual C++
public:
property double ViewportHeight {
    double get ();
    void set (double value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ViewportWidth Property
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ScrollViewer.ViewportWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ViewportWidth { get; set; }
Visual Basic
Public Property ViewportWidth As Double
    Get
    Set
Visual C++
public:
property double ViewportWidth {
    double get ();
    void set (double value);
}

See Also

ScrollViewer Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectiveScrollingGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid Members
SelectiveScrollingGrid Class Constructors Methods Properties See Also Send Feedback

The SelectiveScrollingGrid type exposes the following members.

Constructors

 | Name | Description
Public method | SelectiveScrollingGrid | Initializes a new instance of the SelectiveScrollingGrid class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Grid..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowGridLines | (Inherited from Grid.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectiveScrollingGrid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid Constructor
SelectiveScrollingGrid Class See Also Send Feedback
Initializes a new instance of the SelectiveScrollingGrid class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SelectiveScrollingGrid()
Visual Basic
Public Sub New
Visual C++
public:
SelectiveScrollingGrid()

See Also

SelectiveScrollingGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectiveScrollingGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid Methods
SelectiveScrollingGrid Class See Also Send Feedback

The SelectiveScrollingGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Grid..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..AnySibling Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..GetProperty Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..GetRealType Method
SelectiveScrollingGrid Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.SelectiveScrollingGrid.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.SelectiveScrollingGrid.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

SelectiveScrollingGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..GetRectangle Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..Highlight Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..InvokeMethod Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..IsHitTest Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..NextSibling Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..Parent Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..PreviousSibling Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..ScrollToVisible Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid..::..SetProperty Method
SelectiveScrollingGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SelectiveScrollingGrid Class
SelectiveScrollingGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectiveScrollingGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectiveScrollingGrid Properties
SelectiveScrollingGrid Class See Also Send Feedback

The SelectiveScrollingGrid type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowGridLines | (Inherited from Grid.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

SelectiveScrollingGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Selector Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Members
Selector Class Constructors Methods Fields Properties See Also Send Feedback

The Selector type exposes the following members.

Constructors

 | Name | Description
Public method | Selector | Initializes a new instance of the Selector class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsSynchronizedWithCurrentItemProperty |
SelectedIndexProperty |
SelectedValuePathProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex |
Public property | SelectedValuePath |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Selector Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Constructor
Selector Class See Also Send Feedback
Initializes a new instance of the Selector class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Selector()
Visual Basic
Public Sub New
Visual C++
public:
Selector()

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Selector Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Fields
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Fields

Name | Description
IsSynchronizedWithCurrentItemProperty |
SelectedIndexProperty |
SelectedValuePathProperty |

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSynchronizedWithCurrentItemProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..IsSynchronizedWithCurrentItemProperty Field
Selector Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Selector.IsSynchronizedWithCurrentItemProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSynchronizedWithCurrentItemProperty
Visual Basic
Public Shared IsSynchronizedWithCurrentItemProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSynchronizedWithCurrentItemProperty

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..SelectedIndexProperty Field
Selector Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Selector.SelectedIndexProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedIndexProperty
Visual Basic
Public Shared SelectedIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedIndexProperty

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedValuePathProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..SelectedValuePathProperty Field
Selector Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Selector.SelectedValuePathProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedValuePathProperty
Visual Basic
Public Shared SelectedValuePathProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedValuePathProperty

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Selector Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Methods
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..AnySibling Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..GetProperty Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..GetRealType Method
Selector Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Selector.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Selector.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..GetRectangle Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..Highlight Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..InvokeMethod Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..IsHitTest Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..NextSibling Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..Parent Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..PreviousSibling Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..ScrollToVisible Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..SetProperty Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Selector Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Properties
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex |
Public property | SelectedValuePath |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSynchronizedWithCurrentItem Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..IsSynchronizedWithCurrentItem Property
Selector Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Selector.IsSynchronizedWithCurrentItem"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<bool> IsSynchronizedWithCurrentItem { get; set; }
Visual Basic
Public Property IsSynchronizedWithCurrentItem As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
property Nullable<bool> IsSynchronizedWithCurrentItem {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..SelectedIndex Property
Selector Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Selector.SelectedIndex"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set
Visual C++
public:
virtual property int SelectedIndex {
    int get () sealed;
    void set (int value) sealed;
}

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedValuePath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..SelectedValuePath Property
Selector Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Selector.SelectedValuePath"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SelectedValuePath { get; set; }
Visual Basic
Public Property SelectedValuePath As String
    Get
    Set
Visual C++
public:
property String^ SelectedValuePath {
    String^ get ();
    void set (String^ value);
}

See Also

Selector Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Separator Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator Members
Separator Class Constructors Methods Properties See Also Send Feedback

The Separator type exposes the following members.

Constructors

 | Name | Description
Public method | Separator | Initializes a new instance of the Separator class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Separator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Separator Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator Constructor
Separator Class See Also Send Feedback
Initializes a new instance of the Separator class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Separator()
Visual Basic
Public Sub New
Visual C++
public:
Separator()

See Also

Separator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Separator Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator Methods
Separator Class See Also Send Feedback

The Separator type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Separator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..AnySibling Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..GetProperty Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..GetRealType Method
Separator Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Separator.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Separator.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Separator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..GetRectangle Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..Highlight Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..InvokeMethod Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..IsHitTest Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..NextSibling Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..Parent Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..PreviousSibling Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..ScrollToVisible Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator..::..SetProperty Method
Separator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Separator Class
Separator Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Separator Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Separator Properties
Separator Class See Also Send Feedback

The Separator type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Separator Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Shape Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Members
Shape Class Constructors Methods Fields Properties See Also Send Feedback

The Shape type exposes the following members.

Constructors

 | Name | Description
Public method | Shape | Initializes a new instance of the Shape class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FillProperty |
StretchProperty |
StrokeDashCapProperty |
StrokeDashOffsetProperty |
StrokeEndLineCapProperty |
StrokeLineJoinProperty |
StrokeMiterLimitProperty |
StrokeProperty |
StrokeStartLineCapProperty |
StrokeThicknessProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch |
Public property | Stroke |
Public property | StrokeDashCap |
Public property | StrokeDashOffset |
Public property | StrokeEndLineCap |
Public property | StrokeLineJoin |
Public property | StrokeMiterLimit |
Public property | StrokeStartLineCap |
Public property | StrokeThickness |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Shape Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Constructor
Shape Class See Also Send Feedback
Initializes a new instance of the Shape class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Shape()
Visual Basic
Public Sub New
Visual C++
public:
Shape()

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Shape Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Fields
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Fields

Name | Description
FillProperty |
StretchProperty |
StrokeDashCapProperty |
StrokeDashOffsetProperty |
StrokeEndLineCapProperty |
StrokeLineJoinProperty |
StrokeMiterLimitProperty |
StrokeProperty |
StrokeStartLineCapProperty |
StrokeThicknessProperty |

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..FillProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.FillProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillProperty
Visual Basic
Public Shared FillProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StretchProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeDashCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeDashCapProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeDashCapProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeDashCapProperty
Visual Basic
Public Shared StrokeDashCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeDashCapProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeDashOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeDashOffsetProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeDashOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeDashOffsetProperty
Visual Basic
Public Shared StrokeDashOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeDashOffsetProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeEndLineCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeEndLineCapProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeEndLineCapProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeEndLineCapProperty
Visual Basic
Public Shared StrokeEndLineCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeEndLineCapProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeLineJoinProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeLineJoinProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeLineJoinProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeLineJoinProperty
Visual Basic
Public Shared StrokeLineJoinProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeLineJoinProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeMiterLimitProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeMiterLimitProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeMiterLimitProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeMiterLimitProperty
Visual Basic
Public Shared StrokeMiterLimitProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeMiterLimitProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeProperty
Visual Basic
Public Shared StrokeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeStartLineCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeStartLineCapProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeStartLineCapProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeStartLineCapProperty
Visual Basic
Public Shared StrokeStartLineCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeStartLineCapProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeThicknessProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeThicknessProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeThicknessProperty
Visual Basic
Public Shared StrokeThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeThicknessProperty

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Shape Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Methods
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..AnySibling Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..GetProperty Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..GetRealType Method
Shape Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..GetRectangle Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..Highlight Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..InvokeMethod Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..IsHitTest Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..NextSibling Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..Parent Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..PreviousSibling Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..ScrollToVisible Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..SetProperty Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Shape Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Properties
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch |
Public property | Stroke |
Public property | StrokeDashCap |
Public property | StrokeDashOffset |
Public property | StrokeEndLineCap |
Public property | StrokeLineJoin |
Public property | StrokeMiterLimit |
Public property | StrokeStartLineCap |
Public property | StrokeThickness |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Fill Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..Fill Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.Fill"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Fill { get; set; }
Visual Basic
Public Property Fill As Brush
    Get
    Set
Visual C++
public:
property Brush^ Fill {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Stretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..Stretch Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.Stretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Stretch Stretch { get; set; }
Visual Basic
Public Property Stretch As Stretch
    Get
    Set
Visual C++
public:
property Stretch Stretch {
    Stretch get ();
    void set (Stretch value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Stroke Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..Stroke Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.Stroke"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Stroke { get; set; }
Visual Basic
Public Property Stroke As Brush
    Get
    Set
Visual C++
public:
property Brush^ Stroke {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeDashCap Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeDashCap Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeDashCap"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PenLineCap StrokeDashCap { get; set; }
Visual Basic
Public Property StrokeDashCap As PenLineCap
    Get
    Set
Visual C++
public:
property PenLineCap StrokeDashCap {
    PenLineCap get ();
    void set (PenLineCap value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeDashOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeDashOffset Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeDashOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double StrokeDashOffset { get; set; }
Visual Basic
Public Property StrokeDashOffset As Double
    Get
    Set
Visual C++
public:
property double StrokeDashOffset {
    double get ();
    void set (double value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeEndLineCap Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeEndLineCap Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeEndLineCap"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PenLineCap StrokeEndLineCap { get; set; }
Visual Basic
Public Property StrokeEndLineCap As PenLineCap
    Get
    Set
Visual C++
public:
property PenLineCap StrokeEndLineCap {
    PenLineCap get ();
    void set (PenLineCap value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeLineJoin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeLineJoin Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeLineJoin"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PenLineJoin StrokeLineJoin { get; set; }
Visual Basic
Public Property StrokeLineJoin As PenLineJoin
    Get
    Set
Visual C++
public:
property PenLineJoin StrokeLineJoin {
    PenLineJoin get ();
    void set (PenLineJoin value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeMiterLimit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeMiterLimit Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeMiterLimit"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double StrokeMiterLimit { get; set; }
Visual Basic
Public Property StrokeMiterLimit As Double
    Get
    Set
Visual C++
public:
property double StrokeMiterLimit {
    double get ();
    void set (double value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeStartLineCap Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeStartLineCap Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeStartLineCap"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PenLineCap StrokeStartLineCap { get; set; }
Visual Basic
Public Property StrokeStartLineCap As PenLineCap
    Get
    Set
Visual C++
public:
property PenLineCap StrokeStartLineCap {
    PenLineCap get ();
    void set (PenLineCap value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StrokeThickness Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeThickness Property
Shape Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Shape.StrokeThickness"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic
Public Property StrokeThickness As Double
    Get
    Set
Visual C++
public:
property double StrokeThickness {
    double get ();
    void set (double value);
}

See Also

Shape Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Size Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Members
Size Class Constructors Methods Fields Properties See Also Send Feedback

The Size type exposes the following members.

Constructors

 | Name | Description
Public method | Size | Initializes a new instance of the Size class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
HeightProperty |
IsEmptyProperty |
WidthProperty |

Properties

 | Name | Description
Public property | Height |
Public property | IsEmpty |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Width |

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Size Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Constructor
Size Class See Also Send Feedback
Initializes a new instance of the Size class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Size()
Visual Basic
Public Sub New
Visual C++
public:
Size()

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Size Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Fields
Size Class See Also Send Feedback

The Size type exposes the following members.

Fields

Name | Description
HeightProperty |
IsEmptyProperty |
WidthProperty |

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..HeightProperty Field
Size Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Size.HeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeightProperty
Visual Basic
Public Shared HeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeightProperty

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEmptyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..IsEmptyProperty Field
Size Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Size.IsEmptyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEmptyProperty
Visual Basic
Public Shared IsEmptyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEmptyProperty

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..WidthProperty Field
Size Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Size.WidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Size Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Methods
Size Class See Also Send Feedback

The Size type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..GetProperty Method
Size Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Size Class
Size Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..GetRealType Method
Size Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Size.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Size.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..InvokeMethod Method
Size Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Size Class
Size Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Size Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Properties
Size Class See Also Send Feedback

The Size type exposes the following members.

Properties

 | Name | Description
Public property | Height |
Public property | IsEmpty |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Width |

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..Height Property
Size Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Size.Height"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Height { get; set; }
Visual Basic
Public Overridable Property Height As Double
    Get
    Set
Visual C++
public:
virtual property double Height {
    double get ();
    void set (double value);
}

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEmpty Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..IsEmpty Property
Size Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Size.IsEmpty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsEmpty { get; set; }
Visual Basic
Public Overridable Property IsEmpty As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
    void set (bool value);
}

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..Width Property
Size Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Size.Width"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Width { get; set; }
Visual Basic
Public Overridable Property Width As Double
    Get
    Set
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

See Also

Size Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SkewTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Members
SkewTransform Class Constructors Methods Fields Properties See Also Send Feedback

The SkewTransform type exposes the following members.

Constructors

 | Name | Description
Public method | SkewTransform | Initializes a new instance of the SkewTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AngleXProperty |
AngleYProperty |
CenterXProperty |
CenterYProperty |

Properties

 | Name | Description
Public property | AngleX |
Public property | AngleY |
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SkewTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Constructor
SkewTransform Class See Also Send Feedback
Initializes a new instance of the SkewTransform class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SkewTransform()
Visual Basic
Public Sub New
Visual C++
public:
SkewTransform()

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SkewTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Fields
SkewTransform Class See Also Send Feedback

The SkewTransform type exposes the following members.

Fields

Name | Description
AngleXProperty |
AngleYProperty |
CenterXProperty |
CenterYProperty |

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AngleXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..AngleXProperty Field
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.AngleXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AngleXProperty
Visual Basic
Public Shared AngleXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AngleXProperty

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AngleYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..AngleYProperty Field
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.AngleYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AngleYProperty
Visual Basic
Public Shared AngleYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AngleYProperty

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..CenterXProperty Field
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..CenterYProperty Field
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SkewTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Methods
SkewTransform Class See Also Send Feedback

The SkewTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..GetProperty Method
SkewTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SkewTransform Class
SkewTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..GetRealType Method
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..InvokeMethod Method
SkewTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SkewTransform Class
SkewTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SkewTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Properties
SkewTransform Class See Also Send Feedback

The SkewTransform type exposes the following members.

Properties

 | Name | Description
Public property | AngleX |
Public property | AngleY |
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AngleX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..AngleX Property
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.AngleX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double AngleX { get; set; }
Visual Basic
Public Property AngleX As Double
    Get
    Set
Visual C++
public:
property double AngleX {
    double get ();
    void set (double value);
}

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AngleY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..AngleY Property
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.AngleY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double AngleY { get; set; }
Visual Basic
Public Property AngleY As Double
    Get
    Set
Visual C++
public:
property double AngleY {
    double get ();
    void set (double value);
}

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..CenterX Property
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.CenterX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterX { get; set; }
Visual Basic
Public Property CenterX As Double
    Get
    Set
Visual C++
public:
property double CenterX {
    double get ();
    void set (double value);
}

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CenterY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..CenterY Property
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.SkewTransform.CenterY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterY { get; set; }
Visual Basic
Public Property CenterY As Double
    Get
    Set
Visual C++
public:
property double CenterY {
    double get ();
    void set (double value);
}

See Also

SkewTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Slider Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Members
Slider Class Constructors Methods Fields Properties See Also Send Feedback

The Slider type exposes the following members.

Constructors

 | Name | Description
Public method | Slider | Initializes a new instance of the Slider class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetValue | Sets a new value into Slider.
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AutoToolTipPlacementProperty |
AutoToolTipPrecisionProperty |
DelayProperty |
IntervalProperty |
IsDirectionReversedProperty |
IsMoveToPointEnabledProperty |
IsSelectionRangeEnabledProperty |
IsSnapToTickEnabledProperty |
OrientationProperty |
SelectionEndProperty |
SelectionStartProperty |
TickFrequencyProperty |
TickPlacementProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoToolTipPlacement |
Public property | AutoToolTipPrecision |
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Delay |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | Interval |
Public property | IsDirectionReversed |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsMoveToPointEnabled |
Public property | IsSelectionRangeEnabled |
Public property | IsSnapToTickEnabled |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionEnd |
Public property | SelectionStart |
Public property | SmallChange | (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TickFrequency |
Public property | TickPlacement |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Slider Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Constructor
Slider Class See Also Send Feedback
Initializes a new instance of the Slider class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Slider()
Visual Basic
Public Sub New
Visual C++
public:
Slider()

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Slider Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Fields
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Fields

Name | Description
AutoToolTipPlacementProperty |
AutoToolTipPrecisionProperty |
DelayProperty |
IntervalProperty |
IsDirectionReversedProperty |
IsMoveToPointEnabledProperty |
IsSelectionRangeEnabledProperty |
IsSnapToTickEnabledProperty |
OrientationProperty |
SelectionEndProperty |
SelectionStartProperty |
TickFrequencyProperty |
TickPlacementProperty |

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoToolTipPlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..AutoToolTipPlacementProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.AutoToolTipPlacementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoToolTipPlacementProperty
Visual Basic
Public Shared AutoToolTipPlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoToolTipPlacementProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoToolTipPrecisionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..AutoToolTipPrecisionProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.AutoToolTipPrecisionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoToolTipPrecisionProperty
Visual Basic
Public Shared AutoToolTipPrecisionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoToolTipPrecisionProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DelayProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..DelayProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.DelayProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DelayProperty
Visual Basic
Public Shared DelayProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DelayProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IntervalProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IntervalProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IntervalProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IntervalProperty
Visual Basic
Public Shared IntervalProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IntervalProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDirectionReversedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsDirectionReversedProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IsDirectionReversedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDirectionReversedProperty
Visual Basic
Public Shared IsDirectionReversedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDirectionReversedProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMoveToPointEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsMoveToPointEnabledProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IsMoveToPointEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMoveToPointEnabledProperty
Visual Basic
Public Shared IsMoveToPointEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMoveToPointEnabledProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectionRangeEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsSelectionRangeEnabledProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IsSelectionRangeEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectionRangeEnabledProperty
Visual Basic
Public Shared IsSelectionRangeEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectionRangeEnabledProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSnapToTickEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsSnapToTickEnabledProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IsSnapToTickEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSnapToTickEnabledProperty
Visual Basic
Public Shared IsSnapToTickEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSnapToTickEnabledProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..OrientationProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionEndProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..SelectionEndProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.SelectionEndProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionEndProperty
Visual Basic
Public Shared SelectionEndProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionEndProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionStartProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..SelectionStartProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.SelectionStartProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionStartProperty
Visual Basic
Public Shared SelectionStartProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionStartProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickFrequencyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..TickFrequencyProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.TickFrequencyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TickFrequencyProperty
Visual Basic
Public Shared TickFrequencyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TickFrequencyProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickPlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..TickPlacementProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.TickPlacementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TickPlacementProperty
Visual Basic
Public Shared TickPlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TickPlacementProperty

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Slider Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Methods
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetValue | Sets a new value into Slider.
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..AnySibling Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..GetProperty Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..GetRealType Method
Slider Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..GetRectangle Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..Highlight Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..InvokeMethod Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsHitTest Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..NextSibling Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..Parent Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..PreviousSibling Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..ScrollToVisible Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..SetProperty Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..SetValue Method
Slider Class See Also Send Feedback
Sets a new value into Slider.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetValue(
    double value
)
Visual Basic
Public Sub SetValue ( _
    value As Double _
)
Visual C++
public:
virtual void SetValue(
    double value
) sealed

Parameters

value
Type: System..::..Double
The new value.

Implements

ISlider..::..SetValue(Double)

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Slider Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Properties
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoToolTipPlacement |
Public property | AutoToolTipPrecision |
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Delay |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | Interval |
Public property | IsDirectionReversed |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsMoveToPointEnabled |
Public property | IsSelectionRangeEnabled |
Public property | IsSnapToTickEnabled |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionEnd |
Public property | SelectionStart |
Public property | SmallChange | (Inherited from RangeBase.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TickFrequency |
Public property | TickPlacement |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoToolTipPlacement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..AutoToolTipPlacement Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.AutoToolTipPlacement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutoToolTipPlacement AutoToolTipPlacement { get; set; }
Visual Basic
Public Property AutoToolTipPlacement As AutoToolTipPlacement
    Get
    Set
Visual C++
public:
property AutoToolTipPlacement AutoToolTipPlacement {
    AutoToolTipPlacement get ();
    void set (AutoToolTipPlacement value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoToolTipPrecision Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..AutoToolTipPrecision Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.AutoToolTipPrecision"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AutoToolTipPrecision { get; set; }
Visual Basic
Public Property AutoToolTipPrecision As Integer
    Get
    Set
Visual C++
public:
property int AutoToolTipPrecision {
    int get ();
    void set (int value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Delay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..Delay Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.Delay"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Delay { get; set; }
Visual Basic
Public Property Delay As Integer
    Get
    Set
Visual C++
public:
property int Delay {
    int get ();
    void set (int value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Interval Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..Interval Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.Interval"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Interval { get; set; }
Visual Basic
Public Property Interval As Integer
    Get
    Set
Visual C++
public:
property int Interval {
    int get ();
    void set (int value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDirectionReversed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsDirectionReversed Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IsDirectionReversed"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDirectionReversed { get; set; }
Visual Basic
Public Property IsDirectionReversed As Boolean
    Get
    Set
Visual C++
public:
property bool IsDirectionReversed {
    bool get ();
    void set (bool value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMoveToPointEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsMoveToPointEnabled Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IsMoveToPointEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMoveToPointEnabled { get; set; }
Visual Basic
Public Property IsMoveToPointEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsMoveToPointEnabled {
    bool get ();
    void set (bool value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectionRangeEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsSelectionRangeEnabled Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IsSelectionRangeEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelectionRangeEnabled { get; set; }
Visual Basic
Public Property IsSelectionRangeEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelectionRangeEnabled {
    bool get ();
    void set (bool value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSnapToTickEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsSnapToTickEnabled Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.IsSnapToTickEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSnapToTickEnabled { get; set; }
Visual Basic
Public Property IsSnapToTickEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsSnapToTickEnabled {
    bool get ();
    void set (bool value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..Orientation Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionEnd Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..SelectionEnd Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.SelectionEnd"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double SelectionEnd { get; set; }
Visual Basic
Public Property SelectionEnd As Double
    Get
    Set
Visual C++
public:
property double SelectionEnd {
    double get ();
    void set (double value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionStart Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..SelectionStart Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.SelectionStart"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double SelectionStart { get; set; }
Visual Basic
Public Property SelectionStart As Double
    Get
    Set
Visual C++
public:
property double SelectionStart {
    double get ();
    void set (double value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickFrequency Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..TickFrequency Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.TickFrequency"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double TickFrequency { get; set; }
Visual Basic
Public Property TickFrequency As Double
    Get
    Set
Visual C++
public:
property double TickFrequency {
    double get ();
    void set (double value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickPlacement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..TickPlacement Property
Slider Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Slider.TickPlacement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TickPlacement TickPlacement { get; set; }
Visual Basic
Public Property TickPlacement As TickPlacement
    Get
    Set
Visual C++
public:
property TickPlacement TickPlacement {
    TickPlacement get ();
    void set (TickPlacement value);
}

See Also

Slider Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SolidColorBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Members
SolidColorBrush Class Constructors Methods Fields Properties See Also Send Feedback

The SolidColorBrush type exposes the following members.

Constructors

 | Name | Description
Public method | SolidColorBrush | Initializes a new instance of the SolidColorBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ColorProperty |

Properties

 | Name | Description
Public property | Color |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Transform | (Inherited from Brush.)

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SolidColorBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Constructor
SolidColorBrush Class See Also Send Feedback
Initializes a new instance of the SolidColorBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SolidColorBrush()
Visual Basic
Public Sub New
Visual C++
public:
SolidColorBrush()

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SolidColorBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Fields
SolidColorBrush Class See Also Send Feedback

The SolidColorBrush type exposes the following members.

Fields

Name | Description
ColorProperty |

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..ColorProperty Field
SolidColorBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.SolidColorBrush.ColorProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColorProperty
Visual Basic
Public Shared ColorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColorProperty

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SolidColorBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Methods
SolidColorBrush Class See Also Send Feedback

The SolidColorBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..GetProperty Method
SolidColorBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SolidColorBrush Class
SolidColorBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..GetRealType Method
SolidColorBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.SolidColorBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.SolidColorBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..InvokeMethod Method
SolidColorBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SolidColorBrush Class
SolidColorBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SolidColorBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Properties
SolidColorBrush Class See Also Send Feedback

The SolidColorBrush type exposes the following members.

Properties

 | Name | Description
Public property | Color |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Transform | (Inherited from Brush.)

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Color Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..Color Property
SolidColorBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.SolidColorBrush.Color"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StackPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Members
StackPanel Class Constructors Methods Fields Properties See Also Send Feedback

The StackPanel type exposes the following members.

Constructors

 | Name | Description
Public method | StackPanel | Initializes a new instance of the StackPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
OrientationProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StackPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Constructor
StackPanel Class See Also Send Feedback
Initializes a new instance of the StackPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StackPanel()
Visual Basic
Public Sub New
Visual C++
public:
StackPanel()

See Also

StackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StackPanel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Fields
StackPanel Class See Also Send Feedback

The StackPanel type exposes the following members.

Fields

Name | Description
OrientationProperty |

See Also

StackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..OrientationProperty Field
StackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StackPanel.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

StackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StackPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Methods
StackPanel Class See Also Send Feedback

The StackPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..AnySibling Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..GetProperty Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..GetRealType Method
StackPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StackPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StackPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

StackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..GetRectangle Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..Highlight Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..InvokeMethod Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..IsHitTest Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..NextSibling Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..Parent Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..PreviousSibling Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..ScrollToVisible Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..SetProperty Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StackPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Properties
StackPanel Class See Also Send Feedback

The StackPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..Orientation Property
StackPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StackPanel.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

StackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StatusBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar Members
StatusBar Class Constructors Methods Properties See Also Send Feedback

The StatusBar type exposes the following members.

Constructors

 | Name | Description
Public method | StatusBar | Initializes a new instance of the StatusBar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StatusBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StatusBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar Constructor
StatusBar Class See Also Send Feedback
Initializes a new instance of the StatusBar class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StatusBar()
Visual Basic
Public Sub New
Visual C++
public:
StatusBar()

See Also

StatusBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StatusBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar Methods
StatusBar Class See Also Send Feedback

The StatusBar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StatusBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..AnySibling Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..GetProperty Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..GetRealType Method
StatusBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StatusBar.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StatusBar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

StatusBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..GetRectangle Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..Highlight Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..InvokeMethod Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..IsHitTest Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..NextSibling Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..Parent Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..PreviousSibling Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..ScrollToVisible Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar..::..SetProperty Method
StatusBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StatusBar Class
StatusBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StatusBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBar Properties
StatusBar Class See Also Send Feedback

The StatusBar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StatusBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StatusBarItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem Members
StatusBarItem Class Constructors Methods Properties See Also Send Feedback

The StatusBarItem type exposes the following members.

Constructors

 | Name | Description
Public method | StatusBarItem | Initializes a new instance of the StatusBarItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StatusBarItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem Constructor
StatusBarItem Class See Also Send Feedback
Initializes a new instance of the StatusBarItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StatusBarItem()
Visual Basic
Public Sub New
Visual C++
public:
StatusBarItem()

See Also

StatusBarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StatusBarItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem Methods
StatusBarItem Class See Also Send Feedback

The StatusBarItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..AnySibling Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..GetProperty Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..GetRealType Method
StatusBarItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StatusBarItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StatusBarItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

StatusBarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..GetRectangle Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..Highlight Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..InvokeMethod Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..IsHitTest Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..NextSibling Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..Parent Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..PreviousSibling Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..ScrollToVisible Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem..::..SetProperty Method
StatusBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StatusBarItem Class
StatusBarItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StatusBarItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StatusBarItem Properties
StatusBarItem Class See Also Send Feedback

The StatusBarItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StatusBarItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StickyNoteControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl Members
StickyNoteControl Class Constructors Methods Fields Properties See Also Send Feedback

The StickyNoteControl type exposes the following members.

Constructors

 | Name | Description
Public method | StickyNoteControl | Initializes a new instance of the StickyNoteControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AuthorProperty |
CaptionFontSizeProperty |
IsActiveProperty |
IsExpandedProperty |
IsMouseOverAnchorProperty |
PenWidthProperty |
StickyNoteTypeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | Author |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaptionFontSize |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsActive |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsExpanded |
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsMouseOverAnchor |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PenWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StickyNoteType |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StickyNoteControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl Constructor
StickyNoteControl Class See Also Send Feedback
Initializes a new instance of the StickyNoteControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StickyNoteControl()
Visual Basic
Public Sub New
Visual C++
public:
StickyNoteControl()

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StickyNoteControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl Fields
StickyNoteControl Class See Also Send Feedback

The StickyNoteControl type exposes the following members.

Fields

Name | Description
AuthorProperty |
CaptionFontSizeProperty |
IsActiveProperty |
IsExpandedProperty |
IsMouseOverAnchorProperty |
PenWidthProperty |
StickyNoteTypeProperty |

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AuthorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..AuthorProperty Field
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.AuthorProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AuthorProperty
Visual Basic
Public Shared AuthorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AuthorProperty

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CaptionFontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..CaptionFontSizeProperty Field
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.CaptionFontSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CaptionFontSizeProperty
Visual Basic
Public Shared CaptionFontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CaptionFontSizeProperty

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsActiveProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..IsActiveProperty Field
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.IsActiveProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsActiveProperty
Visual Basic
Public Shared IsActiveProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsActiveProperty

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsExpandedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..IsExpandedProperty Field
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.IsExpandedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsExpandedProperty
Visual Basic
Public Shared IsExpandedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsExpandedProperty

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseOverAnchorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..IsMouseOverAnchorProperty Field
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.IsMouseOverAnchorProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMouseOverAnchorProperty
Visual Basic
Public Shared IsMouseOverAnchorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMouseOverAnchorProperty

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PenWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..PenWidthProperty Field
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.PenWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PenWidthProperty
Visual Basic
Public Shared PenWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PenWidthProperty

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StickyNoteTypeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..StickyNoteTypeProperty Field
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.StickyNoteTypeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StickyNoteTypeProperty
Visual Basic
Public Shared StickyNoteTypeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StickyNoteTypeProperty

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StickyNoteControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl Methods
StickyNoteControl Class See Also Send Feedback

The StickyNoteControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..AnySibling Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..GetProperty Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..GetRealType Method
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..GetRectangle Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..Highlight Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..InvokeMethod Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..IsHitTest Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..NextSibling Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..Parent Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..PreviousSibling Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..ScrollToVisible Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..SetProperty Method
StickyNoteControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StickyNoteControl Class
StickyNoteControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StickyNoteControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl Properties
StickyNoteControl Class See Also Send Feedback

The StickyNoteControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | Author |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaptionFontSize |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsActive |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsExpanded |
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsMouseOverAnchor |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PenWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StickyNoteType |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Author Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..Author Property
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.Author"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Author { get; set; }
Visual Basic
Public Property Author As String
    Get
    Set
Visual C++
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CaptionFontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..CaptionFontSize Property
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.CaptionFontSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CaptionFontSize { get; set; }
Visual Basic
Public Property CaptionFontSize As Double
    Get
    Set
Visual C++
public:
property double CaptionFontSize {
    double get ();
    void set (double value);
}

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsActive Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..IsActive Property
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.IsActive"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsActive { get; set; }
Visual Basic
Public Property IsActive As Boolean
    Get
    Set
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsExpanded Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..IsExpanded Property
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.IsExpanded"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic
Public Property IsExpanded As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpanded {
    bool get ();
    void set (bool value);
}

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseOverAnchor Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..IsMouseOverAnchor Property
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.IsMouseOverAnchor"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMouseOverAnchor { get; set; }
Visual Basic
Public Property IsMouseOverAnchor As Boolean
    Get
    Set
Visual C++
public:
property bool IsMouseOverAnchor {
    bool get ();
    void set (bool value);
}

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PenWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..PenWidth Property
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.PenWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double PenWidth { get; set; }
Visual Basic
Public Property PenWidth As Double
    Get
    Set
Visual C++
public:
property double PenWidth {
    double get ();
    void set (double value);
}

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StickyNoteType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StickyNoteControl..::..StickyNoteType Property
StickyNoteControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StickyNoteControl.StickyNoteType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StickyNoteType StickyNoteType { get; set; }
Visual Basic
Public Property StickyNoteType As StickyNoteType
    Get
    Set
Visual C++
public:
property StickyNoteType StickyNoteType {
    StickyNoteType get ();
    void set (StickyNoteType value);
}

See Also

StickyNoteControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StreamGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry Members
StreamGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The StreamGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | StreamGeometry | Initializes a new instance of the StreamGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FillRuleProperty |

Properties

 | Name | Description
Public property | FillRule |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

StreamGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StreamGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry Constructor
StreamGeometry Class See Also Send Feedback
Initializes a new instance of the StreamGeometry class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StreamGeometry()
Visual Basic
Public Sub New
Visual C++
public:
StreamGeometry()

See Also

StreamGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StreamGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry Fields
StreamGeometry Class See Also Send Feedback

The StreamGeometry type exposes the following members.

Fields

Name | Description
FillRuleProperty |

See Also

StreamGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillRuleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry..::..FillRuleProperty Field
StreamGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.StreamGeometry.FillRuleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillRuleProperty
Visual Basic
Public Shared FillRuleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillRuleProperty

See Also

StreamGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StreamGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry Methods
StreamGeometry Class See Also Send Feedback

The StreamGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StreamGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry..::..GetProperty Method
StreamGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StreamGeometry Class
StreamGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry..::..GetRealType Method
StreamGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StreamGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.StreamGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

StreamGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry..::..InvokeMethod Method
StreamGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StreamGeometry Class
StreamGeometry Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StreamGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry Properties
StreamGeometry Class See Also Send Feedback

The StreamGeometry type exposes the following members.

Properties

 | Name | Description
Public property | FillRule |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

StreamGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillRule Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StreamGeometry..::..FillRule Property
StreamGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.StreamGeometry.FillRule"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FillRule FillRule { get; set; }
Visual Basic
Public Property FillRule As FillRule
    Get
    Set
Visual C++
public:
property FillRule FillRule {
    FillRule get ();
    void set (FillRule value);
}

See Also

StreamGeometry Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Members
TabControl Class Constructors Methods Fields Properties See Also Send Feedback

The TabControl type exposes the following members.

Constructors

 | Name | Description
Public method | TabControl | Initializes a new instance of the TabControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ContentStringFormatProperty |
SelectedContentStringFormatProperty |
TabStripPlacementProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedContentStringFormat |
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStripPlacement |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Constructor
TabControl Class See Also Send Feedback
Initializes a new instance of the TabControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TabControl()
Visual Basic
Public Sub New
Visual C++
public:
TabControl()

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Fields
TabControl Class See Also Send Feedback

The TabControl type exposes the following members.

Fields

Name | Description
ContentStringFormatProperty |
SelectedContentStringFormatProperty |
TabStripPlacementProperty |

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..ContentStringFormatProperty Field
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabControl.ContentStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentStringFormatProperty
Visual Basic
Public Shared ContentStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentStringFormatProperty

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedContentStringFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..SelectedContentStringFormatProperty Field
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabControl.SelectedContentStringFormatProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedContentStringFormatProperty
Visual Basic
Public Shared SelectedContentStringFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedContentStringFormatProperty

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabStripPlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..TabStripPlacementProperty Field
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabControl.TabStripPlacementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabStripPlacementProperty
Visual Basic
Public Shared TabStripPlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabStripPlacementProperty

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Methods
TabControl Class See Also Send Feedback

The TabControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..AnySibling Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..GetProperty Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..GetRealType Method
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..GetRectangle Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..Highlight Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..InvokeMethod Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..IsHitTest Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..NextSibling Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..Parent Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..PreviousSibling Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..ScrollToVisible Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..SetProperty Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Properties
TabControl Class See Also Send Feedback

The TabControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat |
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedContentStringFormat |
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStripPlacement |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContentStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..ContentStringFormat Property
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabControl.ContentStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ContentStringFormat { get; set; }
Visual Basic
Public Property ContentStringFormat As String
    Get
    Set
Visual C++
public:
property String^ ContentStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedContentStringFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..SelectedContentStringFormat Property
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabControl.SelectedContentStringFormat"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SelectedContentStringFormat { get; set; }
Visual Basic
Public Property SelectedContentStringFormat As String
    Get
    Set
Visual C++
public:
property String^ SelectedContentStringFormat {
    String^ get ();
    void set (String^ value);
}

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabStripPlacement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..TabStripPlacement Property
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabControl.TabStripPlacement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dock TabStripPlacement { get; set; }
Visual Basic
Public Property TabStripPlacement As Dock
    Get
    Set
Visual C++
public:
property Dock TabStripPlacement {
    Dock get ();
    void set (Dock value);
}

See Also

TabControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Members
TabItem Class Constructors Methods Fields Properties See Also Send Feedback

The TabItem type exposes the following members.

Constructors

 | Name | Description
Public method | TabItem | Initializes a new instance of the TabItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsSelectedProperty |
TabStripPlacementProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader | (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStripPlacement |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Constructor
TabItem Class See Also Send Feedback
Initializes a new instance of the TabItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TabItem()
Visual Basic
Public Sub New
Visual C++
public:
TabItem()

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Fields
TabItem Class See Also Send Feedback

The TabItem type exposes the following members.

Fields

Name | Description
IsSelectedProperty |
TabStripPlacementProperty |

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..IsSelectedProperty Field
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabItem.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabStripPlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..TabStripPlacementProperty Field
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabItem.TabStripPlacementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabStripPlacementProperty
Visual Basic
Public Shared TabStripPlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabStripPlacementProperty

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Methods
TabItem Class See Also Send Feedback

The TabItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..AnySibling Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..GetProperty Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..GetRealType Method
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..GetRectangle Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..Highlight Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..InvokeMethod Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..IsHitTest Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..NextSibling Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..Parent Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..PreviousSibling Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..ScrollToVisible Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..SetProperty Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Properties
TabItem Class See Also Send Feedback

The TabItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasHeader | (Inherited from HeaderedContentControl.)
Public property | HeaderStringFormat | (Inherited from HeaderedContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabStripPlacement |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..IsSelected Property
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabItem.IsSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabStripPlacement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..TabStripPlacement Property
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabItem.TabStripPlacement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dock TabStripPlacement { get; set; }
Visual Basic
Public Property TabStripPlacement As Dock
    Get
    Set
Visual C++
public:
property Dock TabStripPlacement {
    Dock get ();
    void set (Dock value);
}

See Also

TabItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel Members
TabPanel Class Constructors Methods Properties See Also Send Feedback

The TabPanel type exposes the following members.

Constructors

 | Name | Description
Public method | TabPanel | Initializes a new instance of the TabPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel Constructor
TabPanel Class See Also Send Feedback
Initializes a new instance of the TabPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TabPanel()
Visual Basic
Public Sub New
Visual C++
public:
TabPanel()

See Also

TabPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel Methods
TabPanel Class See Also Send Feedback

The TabPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TabPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..AnySibling Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..GetProperty Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..GetRealType Method
TabPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TabPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TabPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..GetRectangle Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..Highlight Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..InvokeMethod Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..IsHitTest Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..NextSibling Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..Parent Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..PreviousSibling Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..ScrollToVisible Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..SetProperty Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TabPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel Properties
TabPanel Class See Also Send Feedback

The TabPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBlock Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Members
TextBlock Class Constructors Methods Fields Properties See Also Send Feedback

The TextBlock type exposes the following members.

Constructors

 | Name | Description
Public method | TextBlock | Initializes a new instance of the TextBlock class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BaselineOffsetProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
InlinesProperty |
IsHyphenationEnabledProperty |
LineHeightProperty |
LineStackingStrategyProperty |
PaddingProperty |
TextAlignmentProperty |
TextProperty |
TextTrimmingProperty |
TextWrappingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BaselineOffset |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Inlines |
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsHyphenationEnabled |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LineHeight |
Public property | LineStackingStrategy |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextTrimming |
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBlock Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Constructor
TextBlock Class See Also Send Feedback
Initializes a new instance of the TextBlock class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextBlock()
Visual Basic
Public Sub New
Visual C++
public:
TextBlock()

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBlock Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Fields
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BaselineOffsetProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
InlinesProperty |
IsHyphenationEnabledProperty |
LineHeightProperty |
LineStackingStrategyProperty |
PaddingProperty |
TextAlignmentProperty |
TextProperty |
TextTrimmingProperty |
TextWrappingProperty |

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..BackgroundProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BaselineOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..BaselineOffsetProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.BaselineOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BaselineOffsetProperty
Visual Basic
Public Shared BaselineOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BaselineOffsetProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontFamilyProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontSizeProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontStretchProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontStretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStretchProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontStyleProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontStyleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStyleProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontWeightProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontWeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontWeightProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..ForegroundProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InlinesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..InlinesProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.InlinesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty InlinesProperty
Visual Basic
Public Shared InlinesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ InlinesProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHyphenationEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..IsHyphenationEnabledProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.IsHyphenationEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsHyphenationEnabledProperty
Visual Basic
Public Shared IsHyphenationEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsHyphenationEnabledProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..LineHeightProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.LineHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineHeightProperty
Visual Basic
Public Shared LineHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineHeightProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineStackingStrategyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..LineStackingStrategyProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.LineStackingStrategyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineStackingStrategyProperty
Visual Basic
Public Shared LineStackingStrategyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineStackingStrategyProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..PaddingProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.PaddingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PaddingProperty
Visual Basic
Public Shared PaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PaddingProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextAlignmentProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.TextAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextAlignmentProperty
Visual Basic
Public Shared TextAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextAlignmentProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.TextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextTrimmingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextTrimmingProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.TextTrimmingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextTrimmingProperty
Visual Basic
Public Shared TextTrimmingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextTrimmingProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextWrappingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextWrappingProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.TextWrappingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextWrappingProperty
Visual Basic
Public Shared TextWrappingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextWrappingProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBlock Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Methods
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..AnySibling Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..GetProperty Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..GetRealType Method
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..GetRectangle Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Highlight Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..InvokeMethod Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..IsHitTest Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..NextSibling Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Parent Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..PreviousSibling Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..ScrollToVisible Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..SetProperty Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBlock Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Properties
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BaselineOffset |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Inlines |
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsHyphenationEnabled |
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | LineHeight |
Public property | LineStackingStrategy |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextTrimming |
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Background Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BaselineOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..BaselineOffset Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.BaselineOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double BaselineOffset { get; set; }
Visual Basic
Public Property BaselineOffset As Double
    Get
    Set
Visual C++
public:
property double BaselineOffset {
    double get ();
    void set (double value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontFamily Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontFamily"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontSize Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic
Public Property FontSize As Double
    Get
    Set
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontStretch Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontStretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic
Public ReadOnly Property FontStretch As FontStretch
    Get
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontStyle Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontStyle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyle FontStyle { get; }
Visual Basic
Public ReadOnly Property FontStyle As FontStyle
    Get
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FontWeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontWeight Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.FontWeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic
Public ReadOnly Property FontWeight As FontWeight
    Get
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Foreground Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.Foreground"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic
Public Property Foreground As Brush
    Get
    Set
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Inlines Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Inlines Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.Inlines"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InlineCollection Inlines { get; }
Visual Basic
Public ReadOnly Property Inlines As InlineCollection
    Get
Visual C++
public:
property InlineCollection^ Inlines {
    InlineCollection^ get ();
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHyphenationEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..IsHyphenationEnabled Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.IsHyphenationEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsHyphenationEnabled { get; set; }
Visual Basic
Public Property IsHyphenationEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsHyphenationEnabled {
    bool get ();
    void set (bool value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..LineHeight Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.LineHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double LineHeight { get; set; }
Visual Basic
Public Property LineHeight As Double
    Get
    Set
Visual C++
public:
property double LineHeight {
    double get ();
    void set (double value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LineStackingStrategy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..LineStackingStrategy Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.LineStackingStrategy"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LineStackingStrategy LineStackingStrategy { get; set; }
Visual Basic
Public Property LineStackingStrategy As LineStackingStrategy
    Get
    Set
Visual C++
public:
property LineStackingStrategy LineStackingStrategy {
    LineStackingStrategy get ();
    void set (LineStackingStrategy value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Padding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Padding Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.Padding"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness Padding { get; set; }
Visual Basic
Public Property Padding As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ Padding {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Text Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.Text"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITextBlock..::..Text
IFrameworkElement..::..Text

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextAlignment Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.TextAlignment"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As TextAlignment
    Get
    Set
Visual C++
public:
property TextAlignment TextAlignment {
    TextAlignment get ();
    void set (TextAlignment value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextTrimming Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextTrimming Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.TextTrimming"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextTrimming TextTrimming { get; set; }
Visual Basic
Public Property TextTrimming As TextTrimming
    Get
    Set
Visual C++
public:
property TextTrimming TextTrimming {
    TextTrimming get ();
    void set (TextTrimming value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextWrapping Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextWrapping Property
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBlock.TextWrapping"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextWrapping TextWrapping { get; set; }
Visual Basic
Public Property TextWrapping As TextWrapping
    Get
    Set
Visual C++
public:
property TextWrapping TextWrapping {
    TextWrapping get ();
    void set (TextWrapping value);
}

See Also

TextBlock Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Members
TextBox Class Constructors Methods Fields Properties See Also Send Feedback

The TextBox type exposes the following members.

Constructors

 | Name | Description
Public method | TextBox | Initializes a new instance of the TextBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides TextBoxBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CharacterCasingProperty |
MaxLengthProperty |
MaxLinesProperty |
MinLinesProperty |
TextAlignmentProperty |
TextProperty |
TextWrappingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn | (Inherited from TextBoxBase.)
Public property | AcceptsTab | (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoWordSelection | (Inherited from TextBoxBase.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CharacterCasing |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly | (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsUndoEnabled | (Inherited from TextBoxBase.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength |
Public property | MaxLines |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinLines |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UndoLimit | (Inherited from TextBoxBase.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Constructor
TextBox Class See Also Send Feedback
Initializes a new instance of the TextBox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextBox()
Visual Basic
Public Sub New
Visual C++
public:
TextBox()

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Fields
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Fields

Name | Description
CharacterCasingProperty |
MaxLengthProperty |
MaxLinesProperty |
MinLinesProperty |
TextAlignmentProperty |
TextProperty |
TextWrappingProperty |

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CharacterCasingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..CharacterCasingProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.CharacterCasingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CharacterCasingProperty
Visual Basic
Public Shared CharacterCasingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CharacterCasingProperty

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxLengthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..MaxLengthProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.MaxLengthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxLengthProperty
Visual Basic
Public Shared MaxLengthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxLengthProperty

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxLinesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..MaxLinesProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.MaxLinesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxLinesProperty
Visual Basic
Public Shared MaxLinesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxLinesProperty

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinLinesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..MinLinesProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.MinLinesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinLinesProperty
Visual Basic
Public Shared MinLinesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinLinesProperty

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..TextAlignmentProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.TextAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextAlignmentProperty
Visual Basic
Public Shared TextAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextAlignmentProperty

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..TextProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.TextProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextWrappingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..TextWrappingProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.TextWrappingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextWrappingProperty
Visual Basic
Public Shared TextWrappingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextWrappingProperty

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Methods
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides TextBoxBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..AnySibling Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..GetProperty Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..GetRealType Method
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..GetRectangle Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..Highlight Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..InvokeMethod Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..IsHitTest Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..NextSibling Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..Parent Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..PreviousSibling Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..ScrollToVisible Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..SetProperty Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..SetText Method
TextBox Class See Also Send Feedback
Sets or types a new text into the TextBox.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime,
    bool fireKeyEvents
)
Visual Basic
Public Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer, _
    fireKeyEvents As Boolean _
)
Visual C++
public:
virtual void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime,
    bool fireKeyEvents
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the text.
text
Type: System..::..String
The text to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key
fireKeyEvents
Type: System..::..Boolean

[Missing <param name="fireKeyEvents"/> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.SetText(System.Boolean,System.String,System.Int32,System.Int32,System.Boolean)"]

Implements

ITextBox..::..SetText(Boolean, String, Int32, Int32, Boolean)

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Properties
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn | (Inherited from TextBoxBase.)
Public property | AcceptsTab | (Inherited from TextBoxBase.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoWordSelection | (Inherited from TextBoxBase.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CharacterCasing |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly | (Inherited from TextBoxBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsUndoEnabled | (Inherited from TextBoxBase.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength |
Public property | MaxLines |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinLines |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UndoLimit | (Inherited from TextBoxBase.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility | (Inherited from TextBoxBase.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CharacterCasing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..CharacterCasing Property
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.CharacterCasing"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CharacterCasing CharacterCasing { get; set; }
Visual Basic
Public Property CharacterCasing As CharacterCasing
    Get
    Set
Visual C++
public:
property CharacterCasing CharacterCasing {
    CharacterCasing get ();
    void set (CharacterCasing value);
}

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxLength Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..MaxLength Property
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.MaxLength"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic
Public Property MaxLength As Integer
    Get
    Set
Visual C++
public:
property int MaxLength {
    int get ();
    void set (int value);
}

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaxLines Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..MaxLines Property
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.MaxLines"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MaxLines { get; set; }
Visual Basic
Public Property MaxLines As Integer
    Get
    Set
Visual C++
public:
property int MaxLines {
    int get ();
    void set (int value);
}

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinLines Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..MinLines Property
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.MinLines"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MinLines { get; set; }
Visual Basic
Public Property MinLines As Integer
    Get
    Set
Visual C++
public:
property int MinLines {
    int get ();
    void set (int value);
}

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..Text Property
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.Text"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITextBox..::..Text
IFrameworkElement..::..Text

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..TextAlignment Property
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.TextAlignment"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As TextAlignment
    Get
    Set
Visual C++
public:
property TextAlignment TextAlignment {
    TextAlignment get ();
    void set (TextAlignment value);
}

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextWrapping Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..TextWrapping Property
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBox.TextWrapping"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextWrapping TextWrapping { get; set; }
Visual Basic
Public Property TextWrapping As TextWrapping
    Get
    Set
Visual C++
public:
property TextWrapping TextWrapping {
    TextWrapping get ();
    void set (TextWrapping value);
}

See Also

TextBox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBoxBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase Members
TextBoxBase Class Constructors Methods Fields Properties See Also Send Feedback

The TextBoxBase type exposes the following members.

Constructors

 | Name | Description
Public method | TextBoxBase | Initializes a new instance of the TextBoxBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AcceptsReturnProperty |
AcceptsTabProperty |
AutoWordSelectionProperty |
HorizontalScrollBarVisibilityProperty |
IsReadOnlyProperty |
IsUndoEnabledProperty |
UndoLimitProperty |
VerticalScrollBarVisibilityProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn |
Public property | AcceptsTab |
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoWordSelection |
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsUndoEnabled |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UndoLimit |
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBoxBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase Constructor
TextBoxBase Class See Also Send Feedback
Initializes a new instance of the TextBoxBase class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextBoxBase()
Visual Basic
Public Sub New
Visual C++
public:
TextBoxBase()

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBoxBase Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase Fields
TextBoxBase Class See Also Send Feedback

The TextBoxBase type exposes the following members.

Fields

Name | Description
AcceptsReturnProperty |
AcceptsTabProperty |
AutoWordSelectionProperty |
HorizontalScrollBarVisibilityProperty |
IsReadOnlyProperty |
IsUndoEnabledProperty |
UndoLimitProperty |
VerticalScrollBarVisibilityProperty |

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AcceptsReturnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..AcceptsReturnProperty Field
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.AcceptsReturnProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AcceptsReturnProperty
Visual Basic
Public Shared AcceptsReturnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AcceptsReturnProperty

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AcceptsTabProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..AcceptsTabProperty Field
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.AcceptsTabProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AcceptsTabProperty
Visual Basic
Public Shared AcceptsTabProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AcceptsTabProperty

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoWordSelectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..AutoWordSelectionProperty Field
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.AutoWordSelectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoWordSelectionProperty
Visual Basic
Public Shared AutoWordSelectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoWordSelectionProperty

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..HorizontalScrollBarVisibilityProperty Field
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.HorizontalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalScrollBarVisibilityProperty
Visual Basic
Public Shared HorizontalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalScrollBarVisibilityProperty

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..IsReadOnlyProperty Field
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsUndoEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..IsUndoEnabledProperty Field
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.IsUndoEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsUndoEnabledProperty
Visual Basic
Public Shared IsUndoEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsUndoEnabledProperty

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UndoLimitProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..UndoLimitProperty Field
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.UndoLimitProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UndoLimitProperty
Visual Basic
Public Shared UndoLimitProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UndoLimitProperty

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..VerticalScrollBarVisibilityProperty Field
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.VerticalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalScrollBarVisibilityProperty
Visual Basic
Public Shared VerticalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalScrollBarVisibilityProperty

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBoxBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase Methods
TextBoxBase Class See Also Send Feedback

The TextBoxBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..AnySibling Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..GetProperty Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..GetRealType Method
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..GetRectangle Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..Highlight Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..InvokeMethod Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..IsHitTest Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..NextSibling Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..Parent Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..PreviousSibling Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..ScrollToVisible Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..SetProperty Method
TextBoxBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBoxBase Class
TextBoxBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TextBoxBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase Properties
TextBoxBase Class See Also Send Feedback

The TextBoxBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn |
Public property | AcceptsTab |
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoWordSelection |
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsReadOnly |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsUndoEnabled |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UndoLimit |
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalScrollBarVisibility |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AcceptsReturn Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..AcceptsReturn Property
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.AcceptsReturn"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AcceptsReturn { get; set; }
Visual Basic
Public Property AcceptsReturn As Boolean
    Get
    Set
Visual C++
public:
property bool AcceptsReturn {
    bool get ();
    void set (bool value);
}

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AcceptsTab Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..AcceptsTab Property
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.AcceptsTab"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AcceptsTab { get; set; }
Visual Basic
Public Property AcceptsTab As Boolean
    Get
    Set
Visual C++
public:
property bool AcceptsTab {
    bool get ();
    void set (bool value);
}

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoWordSelection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..AutoWordSelection Property
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.AutoWordSelection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AutoWordSelection { get; set; }
Visual Basic
Public Property AutoWordSelection As Boolean
    Get
    Set
Visual C++
public:
property bool AutoWordSelection {
    bool get ();
    void set (bool value);
}

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..HorizontalScrollBarVisibility Property
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.HorizontalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility HorizontalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..IsReadOnly Property
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsUndoEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..IsUndoEnabled Property
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.IsUndoEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsUndoEnabled { get; set; }
Visual Basic
Public Property IsUndoEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsUndoEnabled {
    bool get ();
    void set (bool value);
}

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UndoLimit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..UndoLimit Property
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.UndoLimit"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int UndoLimit { get; set; }
Visual Basic
Public Property UndoLimit As Integer
    Get
    Set
Visual C++
public:
property int UndoLimit {
    int get ();
    void set (int value);
}

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBoxBase..::..VerticalScrollBarVisibility Property
TextBoxBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TextBoxBase.VerticalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic
Public Property VerticalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility VerticalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

TextBoxBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thickness Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Members
Thickness Class Constructors Methods Fields Properties See Also Send Feedback

The Thickness type exposes the following members.

Constructors

 | Name | Description
Public method | Thickness | Initializes a new instance of the Thickness class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BottomProperty |
LeftProperty |
RightProperty |
TopProperty |

Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Right |
Public property | Top |

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thickness Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Constructor
Thickness Class See Also Send Feedback
Initializes a new instance of the Thickness class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness()
Visual Basic
Public Sub New
Visual C++
public:
Thickness()

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thickness Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Fields
Thickness Class See Also Send Feedback

The Thickness type exposes the following members.

Fields

Name | Description
BottomProperty |
LeftProperty |
RightProperty |
TopProperty |

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BottomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..BottomProperty Field
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.BottomProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomProperty
Visual Basic
Public Shared BottomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomProperty

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..LeftProperty Field
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.LeftProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LeftProperty
Visual Basic
Public Shared LeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LeftProperty

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..RightProperty Field
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.RightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RightProperty
Visual Basic
Public Shared RightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RightProperty

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..TopProperty Field
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.TopProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopProperty
Visual Basic
Public Shared TopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopProperty

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thickness Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Methods
Thickness Class See Also Send Feedback

The Thickness type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..GetProperty Method
Thickness Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thickness Class
Thickness Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..GetRealType Method
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..InvokeMethod Method
Thickness Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thickness Class
Thickness Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thickness Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Properties
Thickness Class See Also Send Feedback

The Thickness type exposes the following members.

Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Right |
Public property | Top |

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Bottom Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..Bottom Property
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.Bottom"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Bottom { get; set; }
Visual Basic
Public Overridable Property Bottom As Double
    Get
    Set
Visual C++
public:
virtual property double Bottom {
    double get ();
    void set (double value);
}

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Left Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..Left Property
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.Left"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Left { get; set; }
Visual Basic
Public Overridable Property Left As Double
    Get
    Set
Visual C++
public:
virtual property double Left {
    double get ();
    void set (double value);
}

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Right Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..Right Property
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.Right"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Right { get; set; }
Visual Basic
Public Overridable Property Right As Double
    Get
    Set
Visual C++
public:
virtual property double Right {
    double get ();
    void set (double value);
}

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Top Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..Top Property
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thickness.Top"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Top { get; set; }
Visual Basic
Public Overridable Property Top As Double
    Get
    Set
Visual C++
public:
virtual property double Top {
    double get ();
    void set (double value);
}

See Also

Thickness Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thumb Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Members
Thumb Class Constructors Methods Fields Properties See Also Send Feedback

The Thumb type exposes the following members.

Constructors

 | Name | Description
Public method | Thumb | Initializes a new instance of the Thumb class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsDraggingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDragging |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Thumb Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thumb Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Constructor
Thumb Class See Also Send Feedback
Initializes a new instance of the Thumb class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thumb()
Visual Basic
Public Sub New
Visual C++
public:
Thumb()

See Also

Thumb Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thumb Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Fields
Thumb Class See Also Send Feedback

The Thumb type exposes the following members.

Fields

Name | Description
IsDraggingProperty |

See Also

Thumb Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDraggingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..IsDraggingProperty Field
Thumb Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thumb.IsDraggingProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDraggingProperty
Visual Basic
Public Shared IsDraggingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDraggingProperty

See Also

Thumb Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thumb Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Methods
Thumb Class See Also Send Feedback

The Thumb type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Thumb Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..AnySibling Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..GetProperty Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..GetRealType Method
Thumb Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thumb.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thumb.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Thumb Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..GetRectangle Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..Highlight Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..InvokeMethod Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..IsHitTest Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..NextSibling Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..Parent Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..PreviousSibling Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..ScrollToVisible Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..SetProperty Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Thumb Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Properties
Thumb Class See Also Send Feedback

The Thumb type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDragging |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Thumb Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDragging Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..IsDragging Property
Thumb Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Thumb.IsDragging"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDragging { get; set; }
Visual Basic
Public Property IsDragging As Boolean
    Get
    Set
Visual C++
public:
property bool IsDragging {
    bool get ();
    void set (bool value);
}

See Also

Thumb Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar Members
TickBar Class Constructors Methods Fields Properties See Also Send Feedback

The TickBar type exposes the following members.

Constructors

 | Name | Description
Public method | TickBar | Initializes a new instance of the TickBar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FillProperty |
IsDirectionReversedProperty |
IsSelectionRangeEnabledProperty |
MaximumProperty |
MinimumProperty |
PlacementProperty |
ReservedSpaceProperty |
SelectionEndProperty |
SelectionStartProperty |
TickFrequencyProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDirectionReversed |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelectionRangeEnabled |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ReservedSpace |
Public property | SelectionEnd |
Public property | SelectionStart |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TickFrequency |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar Constructor
TickBar Class See Also Send Feedback
Initializes a new instance of the TickBar class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TickBar()
Visual Basic
Public Sub New
Visual C++
public:
TickBar()

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar Fields
TickBar Class See Also Send Feedback

The TickBar type exposes the following members.

Fields

Name | Description
FillProperty |
IsDirectionReversedProperty |
IsSelectionRangeEnabledProperty |
MaximumProperty |
MinimumProperty |
PlacementProperty |
ReservedSpaceProperty |
SelectionEndProperty |
SelectionStartProperty |
TickFrequencyProperty |

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FillProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..FillProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.FillProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillProperty
Visual Basic
Public Shared FillProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDirectionReversedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..IsDirectionReversedProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.IsDirectionReversedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDirectionReversedProperty
Visual Basic
Public Shared IsDirectionReversedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDirectionReversedProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectionRangeEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..IsSelectionRangeEnabledProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.IsSelectionRangeEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectionRangeEnabledProperty
Visual Basic
Public Shared IsSelectionRangeEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectionRangeEnabledProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaximumProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..MaximumProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.MaximumProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaximumProperty
Visual Basic
Public Shared MaximumProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaximumProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinimumProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..MinimumProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.MinimumProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinimumProperty
Visual Basic
Public Shared MinimumProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinimumProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..PlacementProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.PlacementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlacementProperty
Visual Basic
Public Shared PlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlacementProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ReservedSpaceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..ReservedSpaceProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.ReservedSpaceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ReservedSpaceProperty
Visual Basic
Public Shared ReservedSpaceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ReservedSpaceProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionEndProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..SelectionEndProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.SelectionEndProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionEndProperty
Visual Basic
Public Shared SelectionEndProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionEndProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionStartProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..SelectionStartProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.SelectionStartProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionStartProperty
Visual Basic
Public Shared SelectionStartProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionStartProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickFrequencyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..TickFrequencyProperty Field
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.TickFrequencyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TickFrequencyProperty
Visual Basic
Public Shared TickFrequencyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TickFrequencyProperty

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar Methods
TickBar Class See Also Send Feedback

The TickBar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..AnySibling Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..GetProperty Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..GetRealType Method
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..GetRectangle Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..Highlight Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..InvokeMethod Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..IsHitTest Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..NextSibling Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..Parent Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..PreviousSibling Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..ScrollToVisible Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..SetProperty Method
TickBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TickBar Class
TickBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar Properties
TickBar Class See Also Send Feedback

The TickBar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDirectionReversed |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelectionRangeEnabled |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ReservedSpace |
Public property | SelectionEnd |
Public property | SelectionStart |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TickFrequency |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Fill Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..Fill Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.Fill"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Fill { get; set; }
Visual Basic
Public Property Fill As Brush
    Get
    Set
Visual C++
public:
property Brush^ Fill {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDirectionReversed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..IsDirectionReversed Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.IsDirectionReversed"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDirectionReversed { get; set; }
Visual Basic
Public Property IsDirectionReversed As Boolean
    Get
    Set
Visual C++
public:
property bool IsDirectionReversed {
    bool get ();
    void set (bool value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectionRangeEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..IsSelectionRangeEnabled Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.IsSelectionRangeEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelectionRangeEnabled { get; set; }
Visual Basic
Public Property IsSelectionRangeEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelectionRangeEnabled {
    bool get ();
    void set (bool value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Maximum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..Maximum Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.Maximum"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Maximum { get; set; }
Visual Basic
Public Property Maximum As Double
    Get
    Set
Visual C++
public:
property double Maximum {
    double get ();
    void set (double value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Minimum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..Minimum Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.Minimum"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Minimum { get; set; }
Visual Basic
Public Property Minimum As Double
    Get
    Set
Visual C++
public:
property double Minimum {
    double get ();
    void set (double value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Placement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..Placement Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.Placement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TickBarPlacement Placement { get; set; }
Visual Basic
Public Property Placement As TickBarPlacement
    Get
    Set
Visual C++
public:
property TickBarPlacement Placement {
    TickBarPlacement get ();
    void set (TickBarPlacement value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ReservedSpace Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..ReservedSpace Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.ReservedSpace"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ReservedSpace { get; set; }
Visual Basic
Public Property ReservedSpace As Double
    Get
    Set
Visual C++
public:
property double ReservedSpace {
    double get ();
    void set (double value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionEnd Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..SelectionEnd Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.SelectionEnd"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double SelectionEnd { get; set; }
Visual Basic
Public Property SelectionEnd As Double
    Get
    Set
Visual C++
public:
property double SelectionEnd {
    double get ();
    void set (double value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectionStart Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..SelectionStart Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.SelectionStart"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double SelectionStart { get; set; }
Visual Basic
Public Property SelectionStart As Double
    Get
    Set
Visual C++
public:
property double SelectionStart {
    double get ();
    void set (double value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TickFrequency Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TickBar..::..TickFrequency Property
TickBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TickBar.TickFrequency"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double TickFrequency { get; set; }
Visual Basic
Public Property TickFrequency As Double
    Get
    Set
Visual C++
public:
property double TickFrequency {
    double get ();
    void set (double value);
}

See Also

TickBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TileBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Members
TileBrush Class Constructors Methods Fields Properties See Also Send Feedback

The TileBrush type exposes the following members.

Constructors

 | Name | Description
Public method | TileBrush | Initializes a new instance of the TileBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AlignmentXProperty |
AlignmentYProperty |
StretchProperty |
TileModeProperty |
ViewboxProperty |
ViewboxUnitsProperty |
ViewportProperty |
ViewportUnitsProperty |

Properties

 | Name | Description
Public property | AlignmentX |
Public property | AlignmentY |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch |
Public property | TileMode |
Public property | Transform | (Inherited from Brush.)
Public property | Viewbox |
Public property | ViewboxUnits |
Public property | Viewport |
Public property | ViewportUnits |

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TileBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Constructor
TileBrush Class See Also Send Feedback
Initializes a new instance of the TileBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TileBrush()
Visual Basic
Public Sub New
Visual C++
public:
TileBrush()

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TileBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Fields
TileBrush Class See Also Send Feedback

The TileBrush type exposes the following members.

Fields

Name | Description
AlignmentXProperty |
AlignmentYProperty |
StretchProperty |
TileModeProperty |
ViewboxProperty |
ViewboxUnitsProperty |
ViewportProperty |
ViewportUnitsProperty |

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlignmentXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..AlignmentXProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.AlignmentXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlignmentXProperty
Visual Basic
Public Shared AlignmentXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlignmentXProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlignmentYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..AlignmentYProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.AlignmentYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlignmentYProperty
Visual Basic
Public Shared AlignmentYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlignmentYProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..StretchProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.StretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TileModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..TileModeProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.TileModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TileModeProperty
Visual Basic
Public Shared TileModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TileModeProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewboxProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..ViewboxProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.ViewboxProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewboxProperty
Visual Basic
Public Shared ViewboxProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewboxProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewboxUnitsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..ViewboxUnitsProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.ViewboxUnitsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewboxUnitsProperty
Visual Basic
Public Shared ViewboxUnitsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewboxUnitsProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..ViewportProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.ViewportProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportProperty
Visual Basic
Public Shared ViewportProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportUnitsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..ViewportUnitsProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.ViewportUnitsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportUnitsProperty
Visual Basic
Public Shared ViewportUnitsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportUnitsProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TileBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Methods
TileBrush Class See Also Send Feedback

The TileBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..GetProperty Method
TileBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TileBrush Class
TileBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..GetRealType Method
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..InvokeMethod Method
TileBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TileBrush Class
TileBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TileBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Properties
TileBrush Class See Also Send Feedback

The TileBrush type exposes the following members.

Properties

 | Name | Description
Public property | AlignmentX |
Public property | AlignmentY |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch |
Public property | TileMode |
Public property | Transform | (Inherited from Brush.)
Public property | Viewbox |
Public property | ViewboxUnits |
Public property | Viewport |
Public property | ViewportUnits |

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlignmentX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..AlignmentX Property
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.AlignmentX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AlignmentX AlignmentX { get; set; }
Visual Basic
Public Property AlignmentX As AlignmentX
    Get
    Set
Visual C++
public:
property AlignmentX AlignmentX {
    AlignmentX get ();
    void set (AlignmentX value);
}

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AlignmentY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..AlignmentY Property
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.AlignmentY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AlignmentY AlignmentY { get; set; }
Visual Basic
Public Property AlignmentY As AlignmentY
    Get
    Set
Visual C++
public:
property AlignmentY AlignmentY {
    AlignmentY get ();
    void set (AlignmentY value);
}

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Stretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..Stretch Property
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.Stretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Stretch Stretch { get; set; }
Visual Basic
Public Property Stretch As Stretch
    Get
    Set
Visual C++
public:
property Stretch Stretch {
    Stretch get ();
    void set (Stretch value);
}

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TileMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..TileMode Property
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.TileMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TileMode TileMode { get; set; }
Visual Basic
Public Property TileMode As TileMode
    Get
    Set
Visual C++
public:
property TileMode TileMode {
    TileMode get ();
    void set (TileMode value);
}

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewbox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..Viewbox Property
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.Viewbox"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect Viewbox { get; set; }
Visual Basic
Public Property Viewbox As Rect
    Get
    Set
Visual C++
public:
property Rect^ Viewbox {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewboxUnits Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..ViewboxUnits Property
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.ViewboxUnits"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrushMappingMode ViewboxUnits { get; set; }
Visual Basic
Public Property ViewboxUnits As BrushMappingMode
    Get
    Set
Visual C++
public:
property BrushMappingMode ViewboxUnits {
    BrushMappingMode get ();
    void set (BrushMappingMode value);
}

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..Viewport Property
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.Viewport"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect Viewport { get; set; }
Visual Basic
Public Property Viewport As Rect
    Get
    Set
Visual C++
public:
property Rect^ Viewport {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportUnits Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..ViewportUnits Property
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TileBrush.ViewportUnits"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrushMappingMode ViewportUnits { get; set; }
Visual Basic
Public Property ViewportUnits As BrushMappingMode
    Get
    Set
Visual C++
public:
property BrushMappingMode ViewportUnits {
    BrushMappingMode get ();
    void set (BrushMappingMode value);
}

See Also

TileBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TimeSpan Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Members
TimeSpan Class Constructors Methods Fields Properties See Also Send Feedback

The TimeSpan type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSpan | Initializes a new instance of the TimeSpan class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DaysProperty |
HoursProperty |
MillisecondsProperty |
MinutesProperty |
SecondsProperty |
TicksProperty |
TotalDaysProperty |
TotalHoursProperty |
TotalMillisecondsProperty |
TotalMinutesProperty |
TotalSecondsProperty |

Properties

 | Name | Description
Public property | Days |
Public property | Hours |
Public property | Milliseconds |
Public property | Minutes |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Seconds |
Public property | Ticks |
Public property | TotalDays |
Public property | TotalHours |
Public property | TotalMilliseconds |
Public property | TotalMinutes |
Public property | TotalSeconds |

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TimeSpan Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Constructor
TimeSpan Class See Also Send Feedback
Initializes a new instance of the TimeSpan class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TimeSpan()
Visual Basic
Public Sub New
Visual C++
public:
TimeSpan()

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TimeSpan Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Fields
TimeSpan Class See Also Send Feedback

The TimeSpan type exposes the following members.

Fields

Name | Description
DaysProperty |
HoursProperty |
MillisecondsProperty |
MinutesProperty |
SecondsProperty |
TicksProperty |
TotalDaysProperty |
TotalHoursProperty |
TotalMillisecondsProperty |
TotalMinutesProperty |
TotalSecondsProperty |

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


DaysProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..DaysProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.DaysProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DaysProperty
Visual Basic
Public Shared DaysProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DaysProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HoursProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..HoursProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.HoursProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HoursProperty
Visual Basic
Public Shared HoursProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HoursProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MillisecondsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..MillisecondsProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.MillisecondsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MillisecondsProperty
Visual Basic
Public Shared MillisecondsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MillisecondsProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinutesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..MinutesProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.MinutesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinutesProperty
Visual Basic
Public Shared MinutesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinutesProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SecondsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..SecondsProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.SecondsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SecondsProperty
Visual Basic
Public Shared SecondsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SecondsProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TicksProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TicksProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TicksProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TicksProperty
Visual Basic
Public Shared TicksProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TicksProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalDaysProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalDaysProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalDaysProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalDaysProperty
Visual Basic
Public Shared TotalDaysProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalDaysProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalHoursProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalHoursProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalHoursProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalHoursProperty
Visual Basic
Public Shared TotalHoursProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalHoursProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalMillisecondsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalMillisecondsProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalMillisecondsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalMillisecondsProperty
Visual Basic
Public Shared TotalMillisecondsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalMillisecondsProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalMinutesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalMinutesProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalMinutesProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalMinutesProperty
Visual Basic
Public Shared TotalMinutesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalMinutesProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalSecondsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalSecondsProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalSecondsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalSecondsProperty
Visual Basic
Public Shared TotalSecondsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalSecondsProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TimeSpan Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Methods
TimeSpan Class See Also Send Feedback

The TimeSpan type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..GetProperty Method
TimeSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TimeSpan Class
TimeSpan Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..GetRealType Method
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..InvokeMethod Method
TimeSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TimeSpan Class
TimeSpan Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TimeSpan Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Properties
TimeSpan Class See Also Send Feedback

The TimeSpan type exposes the following members.

Properties

 | Name | Description
Public property | Days |
Public property | Hours |
Public property | Milliseconds |
Public property | Minutes |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Seconds |
Public property | Ticks |
Public property | TotalDays |
Public property | TotalHours |
Public property | TotalMilliseconds |
Public property | TotalMinutes |
Public property | TotalSeconds |

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Days Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..Days Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.Days"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int Days { get; set; }
Visual Basic
Public Overridable Property Days As Integer
    Get
    Set
Visual C++
public:
virtual property int Days {
    int get ();
    void set (int value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Hours Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..Hours Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.Hours"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int Hours { get; set; }
Visual Basic
Public Overridable Property Hours As Integer
    Get
    Set
Visual C++
public:
virtual property int Hours {
    int get ();
    void set (int value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Milliseconds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..Milliseconds Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.Milliseconds"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int Milliseconds { get; set; }
Visual Basic
Public Overridable Property Milliseconds As Integer
    Get
    Set
Visual C++
public:
virtual property int Milliseconds {
    int get ();
    void set (int value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Minutes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..Minutes Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.Minutes"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int Minutes { get; set; }
Visual Basic
Public Overridable Property Minutes As Integer
    Get
    Set
Visual C++
public:
virtual property int Minutes {
    int get ();
    void set (int value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Seconds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..Seconds Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.Seconds"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual int Seconds { get; set; }
Visual Basic
Public Overridable Property Seconds As Integer
    Get
    Set
Visual C++
public:
virtual property int Seconds {
    int get ();
    void set (int value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Ticks Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..Ticks Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.Ticks"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual long Ticks { get; set; }
Visual Basic
Public Overridable Property Ticks As Long
    Get
    Set
Visual C++
public:
virtual property long long Ticks {
    long long get ();
    void set (long long value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalDays Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalDays Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalDays"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TotalDays { get; set; }
Visual Basic
Public Overridable Property TotalDays As Double
    Get
    Set
Visual C++
public:
virtual property double TotalDays {
    double get ();
    void set (double value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalHours Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalHours Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalHours"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TotalHours { get; set; }
Visual Basic
Public Overridable Property TotalHours As Double
    Get
    Set
Visual C++
public:
virtual property double TotalHours {
    double get ();
    void set (double value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalMilliseconds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalMilliseconds Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalMilliseconds"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TotalMilliseconds { get; set; }
Visual Basic
Public Overridable Property TotalMilliseconds As Double
    Get
    Set
Visual C++
public:
virtual property double TotalMilliseconds {
    double get ();
    void set (double value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalMinutes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalMinutes Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalMinutes"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TotalMinutes { get; set; }
Visual Basic
Public Overridable Property TotalMinutes As Double
    Get
    Set
Visual C++
public:
virtual property double TotalMinutes {
    double get ();
    void set (double value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TotalSeconds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalSeconds Property
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TimeSpan.TotalSeconds"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TotalSeconds { get; set; }
Visual Basic
Public Overridable Property TotalSeconds As Double
    Get
    Set
Visual C++
public:
virtual property double TotalSeconds {
    double get ();
    void set (double value);
}

See Also

TimeSpan Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToggleButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Members
ToggleButton Class Constructors Methods Fields Properties See Also Send Feedback

The ToggleButton type exposes the following members.

Constructors

 | Name | Description
Public method | ToggleButton | Initializes a new instance of the ToggleButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsCheckedProperty |
IsThreeStateProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check element. Override for custom control template.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsChecked |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToggleButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Constructor
ToggleButton Class See Also Send Feedback
Initializes a new instance of the ToggleButton class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ToggleButton()
Visual Basic
Public Sub New
Visual C++
public:
ToggleButton()

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToggleButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Fields
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Fields

Name | Description
IsCheckedProperty |
IsThreeStateProperty |

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsCheckedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..IsCheckedProperty Field
ToggleButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToggleButton.IsCheckedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsCheckedProperty
Visual Basic
Public Shared IsCheckedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsCheckedProperty

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsThreeStateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..IsThreeStateProperty Field
ToggleButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToggleButton.IsThreeStateProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsThreeStateProperty
Visual Basic
Public Shared IsThreeStateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsThreeStateProperty

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToggleButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Methods
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..AnySibling Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..Check Method
ToggleButton Class See Also Send Feedback
Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Check(
    bool simulateRealUser
)
Visual Basic
Public Sub Check ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void Check(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate a real user click.

Implements

IToggleButton..::..Check(Boolean)

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..GetProperty Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..GetRealType Method
ToggleButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToggleButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToggleButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..GetRectangle Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..Highlight Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..InvokeMethod Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..IsHitTest Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..NextSibling Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..Parent Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..PreviousSibling Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..ScrollToVisible Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..SetProperty Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..Toggle Method
ToggleButton Class See Also Send Feedback
Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Toggle()
Visual Basic
Public Sub Toggle
Visual C++
public:
virtual void Toggle() sealed

Implements

IToggleButton..::..Toggle()()()()

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnCheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..UnCheck Method
ToggleButton Class See Also Send Feedback
Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void UnCheck(
    bool simulateRealUser
)
Visual Basic
Public Sub UnCheck ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void UnCheck(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate a real user click.

Implements

IToggleButton..::..UnCheck(Boolean)

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToggleButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Properties
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check element. Override for custom control template.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsChecked |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CheckIcon Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..CheckIcon Property
ToggleButton Class See Also Send Feedback
Get the ToggleButton check element. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement CheckIcon { get; }
Visual Basic
Public Overridable ReadOnly Property CheckIcon As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ CheckIcon {
    FrameworkElement^ get ();
}

Implements

IToggleButton..::..CheckIcon

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsChecked Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..IsChecked Property
ToggleButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToggleButton.IsChecked"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<bool> IsChecked { get; set; }
Visual Basic
Public Property IsChecked As Nullable(Of Boolean)
    Get
    Set
Visual C++
public:
virtual property Nullable<bool> IsChecked {
    Nullable<bool> get () sealed;
    void set (Nullable<bool> value) sealed;
}

Implements

IToggleButton..::..IsChecked

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsThreeState Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..IsThreeState Property
ToggleButton Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToggleButton.IsThreeState"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsThreeState { get; set; }
Visual Basic
Public Property IsThreeState As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsThreeState {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IToggleButton..::..IsThreeState

See Also

ToggleButton Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar Members
ToolBar Class Constructors Methods Fields Properties See Also Send Feedback

The ToolBar type exposes the following members.

Constructors

 | Name | Description
Public method | ToolBar | Initializes a new instance of the ToolBar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BandIndexProperty |
BandProperty |
HasOverflowItemsProperty |
IsOverflowOpenProperty |
OrientationProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | Band |
Public property | BandIndex |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader | (Inherited from HeaderedItemsControl.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | HasOverflowItems |
Public property | HeaderStringFormat | (Inherited from HeaderedItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsOverflowOpen |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar Constructor
ToolBar Class See Also Send Feedback
Initializes a new instance of the ToolBar class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ToolBar()
Visual Basic
Public Sub New
Visual C++
public:
ToolBar()

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar Fields
ToolBar Class See Also Send Feedback

The ToolBar type exposes the following members.

Fields

Name | Description
BandIndexProperty |
BandProperty |
HasOverflowItemsProperty |
IsOverflowOpenProperty |
OrientationProperty |

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BandIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..BandIndexProperty Field
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.BandIndexProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BandIndexProperty
Visual Basic
Public Shared BandIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BandIndexProperty

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BandProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..BandProperty Field
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.BandProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BandProperty
Visual Basic
Public Shared BandProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BandProperty

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasOverflowItemsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..HasOverflowItemsProperty Field
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.HasOverflowItemsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasOverflowItemsProperty
Visual Basic
Public Shared HasOverflowItemsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasOverflowItemsProperty

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOverflowOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..IsOverflowOpenProperty Field
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.IsOverflowOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsOverflowOpenProperty
Visual Basic
Public Shared IsOverflowOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsOverflowOpenProperty

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..OrientationProperty Field
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar Methods
ToolBar Class See Also Send Feedback

The ToolBar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..AnySibling Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..GetProperty Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..GetRealType Method
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..GetRectangle Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..Highlight Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..InvokeMethod Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..IsHitTest Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..NextSibling Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..Parent Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..PreviousSibling Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..ScrollToVisible Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..SetProperty Method
ToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBar Class
ToolBar Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar Properties
ToolBar Class See Also Send Feedback

The ToolBar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | Band |
Public property | BandIndex |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader | (Inherited from HeaderedItemsControl.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | HasOverflowItems |
Public property | HeaderStringFormat | (Inherited from HeaderedItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsOverflowOpen |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Band Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..Band Property
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.Band"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Band { get; set; }
Visual Basic
Public Property Band As Integer
    Get
    Set
Visual C++
public:
property int Band {
    int get ();
    void set (int value);
}

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BandIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..BandIndex Property
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.BandIndex"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int BandIndex { get; set; }
Visual Basic
Public Property BandIndex As Integer
    Get
    Set
Visual C++
public:
property int BandIndex {
    int get ();
    void set (int value);
}

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasOverflowItems Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..HasOverflowItems Property
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.HasOverflowItems"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasOverflowItems { get; set; }
Visual Basic
Public Property HasOverflowItems As Boolean
    Get
    Set
Visual C++
public:
property bool HasOverflowItems {
    bool get ();
    void set (bool value);
}

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOverflowOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..IsOverflowOpen Property
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.IsOverflowOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsOverflowOpen { get; set; }
Visual Basic
Public Property IsOverflowOpen As Boolean
    Get
    Set
Visual C++
public:
property bool IsOverflowOpen {
    bool get ();
    void set (bool value);
}

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBar..::..Orientation Property
ToolBar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBar.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

ToolBar Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarOverflowPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel Members
ToolBarOverflowPanel Class Constructors Methods Fields Properties See Also Send Feedback

The ToolBarOverflowPanel type exposes the following members.

Constructors

 | Name | Description
Public method | ToolBarOverflowPanel | Initializes a new instance of the ToolBarOverflowPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
WrapWidthProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | WrapWidth |
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarOverflowPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel Constructor
ToolBarOverflowPanel Class See Also Send Feedback
Initializes a new instance of the ToolBarOverflowPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ToolBarOverflowPanel()
Visual Basic
Public Sub New
Visual C++
public:
ToolBarOverflowPanel()

See Also

ToolBarOverflowPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarOverflowPanel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel Fields
ToolBarOverflowPanel Class See Also Send Feedback

The ToolBarOverflowPanel type exposes the following members.

Fields

Name | Description
WrapWidthProperty |

See Also

ToolBarOverflowPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WrapWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..WrapWidthProperty Field
ToolBarOverflowPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarOverflowPanel.WrapWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WrapWidthProperty
Visual Basic
Public Shared WrapWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WrapWidthProperty

See Also

ToolBarOverflowPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarOverflowPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel Methods
ToolBarOverflowPanel Class See Also Send Feedback

The ToolBarOverflowPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..AnySibling Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..GetProperty Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..GetRealType Method
ToolBarOverflowPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarOverflowPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarOverflowPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ToolBarOverflowPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..GetRectangle Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..Highlight Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..InvokeMethod Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..IsHitTest Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..NextSibling Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..Parent Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..PreviousSibling Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..ScrollToVisible Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..SetProperty Method
ToolBarOverflowPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarOverflowPanel Class
ToolBarOverflowPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarOverflowPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel Properties
ToolBarOverflowPanel Class See Also Send Feedback

The ToolBarOverflowPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | WrapWidth |
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolBarOverflowPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WrapWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarOverflowPanel..::..WrapWidth Property
ToolBarOverflowPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarOverflowPanel.WrapWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double WrapWidth { get; set; }
Visual Basic
Public Property WrapWidth As Double
    Get
    Set
Visual C++
public:
property double WrapWidth {
    double get ();
    void set (double value);
}

See Also

ToolBarOverflowPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel Members
ToolBarPanel Class Constructors Methods Properties See Also Send Feedback

The ToolBarPanel type exposes the following members.

Constructors

 | Name | Description
Public method | ToolBarPanel | Initializes a new instance of the ToolBarPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides StackPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation | (Inherited from StackPanel.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel Constructor
ToolBarPanel Class See Also Send Feedback
Initializes a new instance of the ToolBarPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ToolBarPanel()
Visual Basic
Public Sub New
Visual C++
public:
ToolBarPanel()

See Also

ToolBarPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel Methods
ToolBarPanel Class See Also Send Feedback

The ToolBarPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides StackPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..AnySibling Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..GetProperty Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..GetRealType Method
ToolBarPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ToolBarPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..GetRectangle Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..Highlight Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..InvokeMethod Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..IsHitTest Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..NextSibling Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..Parent Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..PreviousSibling Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..ScrollToVisible Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel..::..SetProperty Method
ToolBarPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarPanel Class
ToolBarPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarPanel Properties
ToolBarPanel Class See Also Send Feedback

The ToolBarPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation | (Inherited from StackPanel.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolBarPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarTray Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray Members
ToolBarTray Class Constructors Methods Fields Properties See Also Send Feedback

The ToolBarTray type exposes the following members.

Constructors

 | Name | Description
Public method | ToolBarTray | Initializes a new instance of the ToolBarTray class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
IsLockedProperty |
OrientationProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsLocked |
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarTray Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray Constructor
ToolBarTray Class See Also Send Feedback
Initializes a new instance of the ToolBarTray class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ToolBarTray()
Visual Basic
Public Sub New
Visual C++
public:
ToolBarTray()

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarTray Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray Fields
ToolBarTray Class See Also Send Feedback

The ToolBarTray type exposes the following members.

Fields

Name | Description
BackgroundProperty |
IsLockedProperty |
OrientationProperty |

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..BackgroundProperty Field
ToolBarTray Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarTray.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsLockedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..IsLockedProperty Field
ToolBarTray Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarTray.IsLockedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsLockedProperty
Visual Basic
Public Shared IsLockedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsLockedProperty

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..OrientationProperty Field
ToolBarTray Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarTray.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarTray Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray Methods
ToolBarTray Class See Also Send Feedback

The ToolBarTray type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..AnySibling Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..GetProperty Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..GetRealType Method
ToolBarTray Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarTray.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarTray.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..GetRectangle Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..Highlight Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..InvokeMethod Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..IsHitTest Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..NextSibling Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..Parent Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..PreviousSibling Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..ScrollToVisible Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..SetProperty Method
ToolBarTray Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolBarTray Class
ToolBarTray Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolBarTray Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray Properties
ToolBarTray Class See Also Send Feedback

The ToolBarTray type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsLocked |
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..Background Property
ToolBarTray Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarTray.Background"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsLocked Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..IsLocked Property
ToolBarTray Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarTray.IsLocked"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic
Public Property IsLocked As Boolean
    Get
    Set
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarTray..::..Orientation Property
ToolBarTray Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolBarTray.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

ToolBarTray Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolTip Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Members
ToolTip Class Constructors Methods Fields Properties See Also Send Feedback

The ToolTip type exposes the following members.

Constructors

 | Name | Description
Public method | ToolTip | Initializes a new instance of the ToolTip class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HasDropShadowProperty |
HorizontalOffsetProperty |
IsOpenProperty |
PlacementProperty |
PlacementRectangleProperty |
StaysOpenProperty |
VerticalOffsetProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasDropShadow |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsOpen |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PlacementRectangle |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpen |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolTip Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Constructor
ToolTip Class See Also Send Feedback
Initializes a new instance of the ToolTip class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ToolTip()
Visual Basic
Public Sub New
Visual C++
public:
ToolTip()

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolTip Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Fields
ToolTip Class See Also Send Feedback

The ToolTip type exposes the following members.

Fields

Name | Description
HasDropShadowProperty |
HorizontalOffsetProperty |
IsOpenProperty |
PlacementProperty |
PlacementRectangleProperty |
StaysOpenProperty |
VerticalOffsetProperty |

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasDropShadowProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..HasDropShadowProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.HasDropShadowProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasDropShadowProperty
Visual Basic
Public Shared HasDropShadowProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasDropShadowProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..HorizontalOffsetProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..IsOpenProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.IsOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsOpenProperty
Visual Basic
Public Shared IsOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsOpenProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..PlacementProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.PlacementProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlacementProperty
Visual Basic
Public Shared PlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlacementProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementRectangleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..PlacementRectangleProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.PlacementRectangleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlacementRectangleProperty
Visual Basic
Public Shared PlacementRectangleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlacementRectangleProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..StaysOpenProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.StaysOpenProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StaysOpenProperty
Visual Basic
Public Shared StaysOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StaysOpenProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..VerticalOffsetProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolTip Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Methods
ToolTip Class See Also Send Feedback

The ToolTip type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..AnySibling Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..GetProperty Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..GetRealType Method
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..GetRectangle Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..Highlight Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..InvokeMethod Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..IsHitTest Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..NextSibling Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..Parent Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..PreviousSibling Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..ScrollToVisible Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..SetProperty Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToolTip Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Properties
ToolTip Class See Also Send Feedback

The ToolTip type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | HasDropShadow |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsOpen |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PlacementRectangle |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | StaysOpen |
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HasDropShadow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..HasDropShadow Property
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.HasDropShadow"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasDropShadow { get; set; }
Visual Basic
Public Property HasDropShadow As Boolean
    Get
    Set
Visual C++
public:
property bool HasDropShadow {
    bool get ();
    void set (bool value);
}

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


HorizontalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..HorizontalOffset Property
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.HorizontalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic
Public Property HorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..IsOpen Property
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.IsOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsOpen { get; set; }
Visual Basic
Public Property IsOpen As Boolean
    Get
    Set
Visual C++
public:
property bool IsOpen {
    bool get ();
    void set (bool value);
}

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Placement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..Placement Property
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.Placement"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PlacementMode Placement { get; set; }
Visual Basic
Public Property Placement As PlacementMode
    Get
    Set
Visual C++
public:
property PlacementMode Placement {
    PlacementMode get ();
    void set (PlacementMode value);
}

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlacementRectangle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..PlacementRectangle Property
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.PlacementRectangle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect PlacementRectangle { get; set; }
Visual Basic
Public Property PlacementRectangle As Rect
    Get
    Set
Visual C++
public:
property Rect^ PlacementRectangle {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StaysOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..StaysOpen Property
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.StaysOpen"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StaysOpen { get; set; }
Visual Basic
Public Property StaysOpen As Boolean
    Get
    Set
Visual C++
public:
property bool StaysOpen {
    bool get ();
    void set (bool value);
}

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..VerticalOffset Property
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.ToolTip.VerticalOffset"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic
Public Property VerticalOffset As Double
    Get
    Set
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

ToolTip Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Track Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track Members
Track Class Constructors Methods Fields Properties See Also Send Feedback

The Track type exposes the following members.

Constructors

 | Name | Description
Public method | Track | Initializes a new instance of the Track class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsDirectionReversedProperty |
MaximumProperty |
MinimumProperty |
OrientationProperty |
ValueProperty |
ViewportSizeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDirectionReversed |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | ViewportSize |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Track Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track Constructor
Track Class See Also Send Feedback
Initializes a new instance of the Track class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Track()
Visual Basic
Public Sub New
Visual C++
public:
Track()

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Track Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track Fields
Track Class See Also Send Feedback

The Track type exposes the following members.

Fields

Name | Description
IsDirectionReversedProperty |
MaximumProperty |
MinimumProperty |
OrientationProperty |
ValueProperty |
ViewportSizeProperty |

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDirectionReversedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..IsDirectionReversedProperty Field
Track Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.IsDirectionReversedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDirectionReversedProperty
Visual Basic
Public Shared IsDirectionReversedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDirectionReversedProperty

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MaximumProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..MaximumProperty Field
Track Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.MaximumProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaximumProperty
Visual Basic
Public Shared MaximumProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaximumProperty

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


MinimumProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..MinimumProperty Field
Track Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.MinimumProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinimumProperty
Visual Basic
Public Shared MinimumProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinimumProperty

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..OrientationProperty Field
Track Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..ValueProperty Field
Track Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.ValueProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ValueProperty
Visual Basic
Public Shared ValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ValueProperty

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..ViewportSizeProperty Field
Track Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.ViewportSizeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportSizeProperty
Visual Basic
Public Shared ViewportSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportSizeProperty

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Track Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track Methods
Track Class See Also Send Feedback

The Track type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..AnySibling Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..GetProperty Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..GetRealType Method
Track Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..GetRectangle Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..Highlight Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..InvokeMethod Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..IsHitTest Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..NextSibling Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..Parent Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..PreviousSibling Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..ScrollToVisible Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..SetProperty Method
Track Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Track Class
Track Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Track Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track Properties
Track Class See Also Send Feedback

The Track type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsDirectionReversed |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | ViewportSize |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsDirectionReversed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..IsDirectionReversed Property
Track Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.IsDirectionReversed"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDirectionReversed { get; set; }
Visual Basic
Public Property IsDirectionReversed As Boolean
    Get
    Set
Visual C++
public:
property bool IsDirectionReversed {
    bool get ();
    void set (bool value);
}

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Maximum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..Maximum Property
Track Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.Maximum"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Maximum { get; set; }
Visual Basic
Public Property Maximum As Double
    Get
    Set
Visual C++
public:
property double Maximum {
    double get ();
    void set (double value);
}

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Minimum Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..Minimum Property
Track Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.Minimum"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Minimum { get; set; }
Visual Basic
Public Property Minimum As Double
    Get
    Set
Visual C++
public:
property double Minimum {
    double get ();
    void set (double value);
}

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..Orientation Property
Track Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..Value Property
Track Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.Value"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Value { get; set; }
Visual Basic
Public Property Value As Double
    Get
    Set
Visual C++
public:
property double Value {
    double get ();
    void set (double value);
}

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Track..::..ViewportSize Property
Track Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Track.ViewportSize"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ViewportSize { get; set; }
Visual Basic
Public Property ViewportSize As Double
    Get
    Set
Visual C++
public:
property double ViewportSize {
    double get ();
    void set (double value);
}

See Also

Track Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform Members
Transform Class Constructors Methods Properties See Also Send Feedback

The Transform type exposes the following members.

Constructors

 | Name | Description
Public method | Transform | Initializes a new instance of the Transform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform Constructor
Transform Class See Also Send Feedback
Initializes a new instance of the Transform class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform()
Visual Basic
Public Sub New
Visual C++
public:
Transform()

See Also

Transform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform Methods
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform..::..GetProperty Method
Transform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform Class
Transform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform..::..GetRealType Method
Transform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Transform.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Transform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Transform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform..::..InvokeMethod Method
Transform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform Class
Transform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform Properties
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform3D Members
Transform3D Class Constructors Methods Properties See Also Send Feedback

The Transform3D type exposes the following members.

Constructors

 | Name | Description
Public method | Transform3D | Initializes a new instance of the Transform3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform3D Constructor
Transform3D Class See Also Send Feedback
Initializes a new instance of the Transform3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform3D()
Visual Basic
Public Sub New
Visual C++
public:
Transform3D()

See Also

Transform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform3D Methods
Transform3D Class See Also Send Feedback

The Transform3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform3D..::..GetProperty Method
Transform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform3D Class
Transform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform3D..::..GetRealType Method
Transform3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Transform3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Transform3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Transform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform3D..::..InvokeMethod Method
Transform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform3D Class
Transform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform3D Properties
Transform3D Class See Also Send Feedback

The Transform3D type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformedBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap Members
TransformedBitmap Class Constructors Methods Fields Properties See Also Send Feedback

The TransformedBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | TransformedBitmap | Initializes a new instance of the TransformedBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
SourceProperty |
TransformProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Source |
Public property | Transform |

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformedBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap Constructor
TransformedBitmap Class See Also Send Feedback
Initializes a new instance of the TransformedBitmap class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TransformedBitmap()
Visual Basic
Public Sub New
Visual C++
public:
TransformedBitmap()

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformedBitmap Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap Fields
TransformedBitmap Class See Also Send Feedback

The TransformedBitmap type exposes the following members.

Fields

Name | Description
SourceProperty |
TransformProperty |

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap..::..SourceProperty Field
TransformedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransformedBitmap.SourceProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap..::..TransformProperty Field
TransformedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransformedBitmap.TransformProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TransformProperty
Visual Basic
Public Shared TransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TransformProperty

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformedBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap Methods
TransformedBitmap Class See Also Send Feedback

The TransformedBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap..::..GetProperty Method
TransformedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransformedBitmap Class
TransformedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap..::..GetRealType Method
TransformedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransformedBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransformedBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap..::..InvokeMethod Method
TransformedBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransformedBitmap Class
TransformedBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransformedBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap Properties
TransformedBitmap Class See Also Send Feedback

The TransformedBitmap type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Source |
Public property | Transform |

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap..::..Source Property
TransformedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransformedBitmap.Source"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapSource Source { get; set; }
Visual Basic
Public Property Source As BitmapSource
    Get
    Set
Visual C++
public:
property BitmapSource^ Source {
    BitmapSource^ get ();
    void set (BitmapSource^ value);
}

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformedBitmap..::..Transform Property
TransformedBitmap Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransformedBitmap.Transform"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform Transform { get; set; }
Visual Basic
Public Property Transform As Transform
    Get
    Set
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

TransformedBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransitioningContentControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl Members
TransitioningContentControl Class Constructors Methods Fields Properties See Also Send Feedback

The TransitioningContentControl type exposes the following members.

Constructors

 | Name | Description
Public method | TransitioningContentControl | Initializes a new instance of the TransitioningContentControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsTransitioningProperty |
RestartTransitionOnContentChangeProperty |
TransitionProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTransitioning |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RestartTransitionOnContentChange |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Transition |
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransitioningContentControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl Constructor
TransitioningContentControl Class See Also Send Feedback
Initializes a new instance of the TransitioningContentControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TransitioningContentControl()
Visual Basic
Public Sub New
Visual C++
public:
TransitioningContentControl()

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransitioningContentControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl Fields
TransitioningContentControl Class See Also Send Feedback

The TransitioningContentControl type exposes the following members.

Fields

Name | Description
IsTransitioningProperty |
RestartTransitionOnContentChangeProperty |
TransitionProperty |

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTransitioningProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..IsTransitioningProperty Field
TransitioningContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransitioningContentControl.IsTransitioningProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTransitioningProperty
Visual Basic
Public Shared IsTransitioningProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTransitioningProperty

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RestartTransitionOnContentChangeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..RestartTransitionOnContentChangeProperty Field
TransitioningContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransitioningContentControl.RestartTransitionOnContentChangeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RestartTransitionOnContentChangeProperty
Visual Basic
Public Shared RestartTransitionOnContentChangeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RestartTransitionOnContentChangeProperty

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransitionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..TransitionProperty Field
TransitioningContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransitioningContentControl.TransitionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TransitionProperty
Visual Basic
Public Shared TransitionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TransitionProperty

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransitioningContentControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl Methods
TransitioningContentControl Class See Also Send Feedback

The TransitioningContentControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..AnySibling Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..GetProperty Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..GetRealType Method
TransitioningContentControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransitioningContentControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransitioningContentControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..GetRectangle Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..Highlight Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..InvokeMethod Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..IsHitTest Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..NextSibling Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..Parent Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..PreviousSibling Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..ScrollToVisible Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..SetProperty Method
TransitioningContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransitioningContentControl Class
TransitioningContentControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TransitioningContentControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl Properties
TransitioningContentControl Class See Also Send Feedback

The TransitioningContentControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTransitioning |
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RestartTransitionOnContentChange |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Transition |
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsTransitioning Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..IsTransitioning Property
TransitioningContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransitioningContentControl.IsTransitioning"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTransitioning { get; set; }
Visual Basic
Public Property IsTransitioning As Boolean
    Get
    Set
Visual C++
public:
property bool IsTransitioning {
    bool get ();
    void set (bool value);
}

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RestartTransitionOnContentChange Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..RestartTransitionOnContentChange Property
TransitioningContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransitioningContentControl.RestartTransitionOnContentChange"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RestartTransitionOnContentChange { get; set; }
Visual Basic
Public Property RestartTransitionOnContentChange As Boolean
    Get
    Set
Visual C++
public:
property bool RestartTransitionOnContentChange {
    bool get ();
    void set (bool value);
}

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Transition Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransitioningContentControl..::..Transition Property
TransitioningContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TransitioningContentControl.Transition"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Transition { get; set; }
Visual Basic
Public Property Transition As String
    Get
    Set
Visual C++
public:
property String^ Transition {
    String^ get ();
    void set (String^ value);
}

See Also

TransitioningContentControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Members
TranslateTransform Class Constructors Methods Fields Properties See Also Send Feedback

The TranslateTransform type exposes the following members.

Constructors

 | Name | Description
Public method | TranslateTransform | Initializes a new instance of the TranslateTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
XProperty |
YProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Constructor
TranslateTransform Class See Also Send Feedback
Initializes a new instance of the TranslateTransform class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TranslateTransform()
Visual Basic
Public Sub New
Visual C++
public:
TranslateTransform()

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Fields
TranslateTransform Class See Also Send Feedback

The TranslateTransform type exposes the following members.

Fields

Name | Description
XProperty |
YProperty |

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..XProperty Field
TranslateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform.XProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..YProperty Field
TranslateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform.YProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Methods
TranslateTransform Class See Also Send Feedback

The TranslateTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..GetProperty Method
TranslateTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TranslateTransform Class
TranslateTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..GetRealType Method
TranslateTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..InvokeMethod Method
TranslateTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TranslateTransform Class
TranslateTransform Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Properties
TranslateTransform Class See Also Send Feedback

The TranslateTransform type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..X Property
TranslateTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform.X"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double X { get; set; }
Visual Basic
Public Property X As Double
    Get
    Set
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..Y Property
TranslateTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform.Y"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Y { get; set; }
Visual Basic
Public Property Y As Double
    Get
    Set
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

See Also

TranslateTransform Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D Members
TranslateTransform3D Class Constructors Methods Fields Properties See Also Send Feedback

The TranslateTransform3D type exposes the following members.

Constructors

 | Name | Description
Public method | TranslateTransform3D | Initializes a new instance of the TranslateTransform3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AffineTransform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
OffsetXProperty |
OffsetYProperty |
OffsetZProperty |

Properties

 | Name | Description
Public property | OffsetX |
Public property | OffsetY |
Public property | OffsetZ |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D Constructor
TranslateTransform3D Class See Also Send Feedback
Initializes a new instance of the TranslateTransform3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TranslateTransform3D()
Visual Basic
Public Sub New
Visual C++
public:
TranslateTransform3D()

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D Fields
TranslateTransform3D Class See Also Send Feedback

The TranslateTransform3D type exposes the following members.

Fields

Name | Description
OffsetXProperty |
OffsetYProperty |
OffsetZProperty |

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..OffsetXProperty Field
TranslateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform3D.OffsetXProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetXProperty
Visual Basic
Public Shared OffsetXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetXProperty

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..OffsetYProperty Field
TranslateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform3D.OffsetYProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetYProperty
Visual Basic
Public Shared OffsetYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetYProperty

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetZProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..OffsetZProperty Field
TranslateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform3D.OffsetZProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetZProperty
Visual Basic
Public Shared OffsetZProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetZProperty

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D Methods
TranslateTransform3D Class See Also Send Feedback

The TranslateTransform3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AffineTransform3D..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..GetProperty Method
TranslateTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TranslateTransform3D Class
TranslateTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..GetRealType Method
TranslateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..InvokeMethod Method
TranslateTransform3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TranslateTransform3D Class
TranslateTransform3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TranslateTransform3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D Properties
TranslateTransform3D Class See Also Send Feedback

The TranslateTransform3D type exposes the following members.

Properties

 | Name | Description
Public property | OffsetX |
Public property | OffsetY |
Public property | OffsetZ |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..OffsetX Property
TranslateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform3D.OffsetX"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double OffsetX { get; set; }
Visual Basic
Public Property OffsetX As Double
    Get
    Set
Visual C++
public:
property double OffsetX {
    double get ();
    void set (double value);
}

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..OffsetY Property
TranslateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform3D.OffsetY"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double OffsetY { get; set; }
Visual Basic
Public Property OffsetY As Double
    Get
    Set
Visual C++
public:
property double OffsetY {
    double get ();
    void set (double value);
}

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OffsetZ Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform3D..::..OffsetZ Property
TranslateTransform3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TranslateTransform3D.OffsetZ"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double OffsetZ { get; set; }
Visual Basic
Public Property OffsetZ As Double
    Get
    Set
Visual C++
public:
property double OffsetZ {
    double get ();
    void set (double value);
}

See Also

TranslateTransform3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Members
TreeView Class Constructors Methods Fields Properties See Also Send Feedback

The TreeView type exposes the following members.

Constructors

 | Name | Description
Public method | TreeView | Initializes a new instance of the TreeView class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SelectedValuePathProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemsPanel | Get the element holding the tree view items.
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RootItems | Get the list of tree view items on the root level.
Public property | SelectedValuePath |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Constructor
TreeView Class See Also Send Feedback
Initializes a new instance of the TreeView class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TreeView()
Visual Basic
Public Sub New
Visual C++
public:
TreeView()

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeView Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Fields
TreeView Class See Also Send Feedback

The TreeView type exposes the following members.

Fields

Name | Description
SelectedValuePathProperty |

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedValuePathProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..SelectedValuePathProperty Field
TreeView Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeView.SelectedValuePathProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedValuePathProperty
Visual Basic
Public Shared SelectedValuePathProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedValuePathProperty

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Methods
TreeView Class See Also Send Feedback

The TreeView type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..AnySibling Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..AssignReference Method
TreeView Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..GetProperty Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..GetRealType Method
TreeView Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeView.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeView.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..GetRectangle Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..Highlight Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..InvokeMethod Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..IsHitTest Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..NextSibling Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..Parent Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..PreviousSibling Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..ScrollToVisible Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..SetProperty Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Properties
TreeView Class See Also Send Feedback

The TreeView type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | ItemsPanel | Get the element holding the tree view items.
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RootItems | Get the list of tree view items on the root level.
Public property | SelectedValuePath |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsPanel Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..ItemsPanel Property
TreeView Class See Also Send Feedback
Get the element holding the tree view items.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ItemsPanel { get; }
Visual Basic
Public Overridable ReadOnly Property ItemsPanel As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ItemsPanel {
    FrameworkElement^ get ();
}

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RootItems Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..RootItems Property
TreeView Class See Also Send Feedback
Get the list of tree view items on the root level.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<ITreeViewItem> RootItems { get; }
Visual Basic
Public ReadOnly Property RootItems As IList(Of ITreeViewItem)
    Get
Visual C++
public:
virtual property IList<ITreeViewItem^>^ RootItems {
    IList<ITreeViewItem^>^ get () sealed;
}

Implements

ITreeView..::..RootItems

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SelectedValuePath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..SelectedValuePath Property
TreeView Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeView.SelectedValuePath"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SelectedValuePath { get; set; }
Visual Basic
Public Property SelectedValuePath As String
    Get
    Set
Visual C++
public:
virtual property String^ SelectedValuePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

ITreeView..::..SelectedValuePath

See Also

TreeView Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeViewItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Members
TreeViewItem Class Constructors Methods Fields Properties See Also Send Feedback

The TreeViewItem type exposes the following members.

Constructors

 | Name | Description
Public method | TreeViewItem | Initializes a new instance of the TreeViewItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select | Selects the item.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Expands/collapses the item.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsExpandedProperty |
IsSelectedProperty |
IsSelectionActiveProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader | (Inherited from HeaderedItemsControl.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Header | Get the header responsible for item selection. Override for custom control template.
Public property | HeaderStringFormat | (Inherited from HeaderedItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsExpanded |
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsSelectionActive |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | Items | Get the item children.
Public property | ItemsPanel | Get the element holding the tree view items. Override for custom control template.
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Get the item text. (Overrides FrameworkElement..::..Text.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToggleButton | Get the toggle button responsible for simulating item expand/collapse actions. Override for custom control template.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeViewItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Constructor
TreeViewItem Class See Also Send Feedback
Initializes a new instance of the TreeViewItem class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TreeViewItem()
Visual Basic
Public Sub New
Visual C++
public:
TreeViewItem()

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeViewItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Fields
TreeViewItem Class See Also Send Feedback

The TreeViewItem type exposes the following members.

Fields

Name | Description
IsExpandedProperty |
IsSelectedProperty |
IsSelectionActiveProperty |

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsExpandedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsExpandedProperty Field
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeViewItem.IsExpandedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsExpandedProperty
Visual Basic
Public Shared IsExpandedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsExpandedProperty

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsSelectedProperty Field
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeViewItem.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectionActiveProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsSelectionActiveProperty Field
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeViewItem.IsSelectionActiveProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectionActiveProperty
Visual Basic
Public Shared IsSelectionActiveProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectionActiveProperty

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeViewItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Methods
TreeViewItem Class See Also Send Feedback

The TreeViewItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select | Selects the item.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Expands/collapses the item.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..AnySibling Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..AssignReference Method
TreeViewItem Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..GetProperty Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..GetRealType Method
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeViewItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeViewItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..GetRectangle Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Highlight Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..InvokeMethod Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsHitTest Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..NextSibling Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Parent Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..PreviousSibling Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..ScrollToVisible Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Select Method
TreeViewItem Class See Also Send Feedback
Selects the item.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Select(
    bool simulateRealUser
)
Visual Basic
Public Sub Select ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void Select(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user click to select the item.

Implements

ITreeViewItem..::..Select(Boolean)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..SetProperty Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Toggle Method
TreeViewItem Class See Also Send Feedback
Expands/collapses the item.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Toggle(
    bool simulateRealUser
)
Visual Basic
Public Sub Toggle ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void Toggle(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user click to expand/collapse the item.

Implements

ITreeViewItem..::..Toggle(Boolean)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TreeViewItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Properties
TreeViewItem Class See Also Send Feedback

The TreeViewItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AlternationCount | (Inherited from ItemsControl.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader | (Inherited from HeaderedItemsControl.)
Public property | HasItems | (Inherited from ItemsControl.)
Public property | Header | Get the header responsible for item selection. Override for custom control template.
Public property | HeaderStringFormat | (Inherited from HeaderedItemsControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsExpanded |
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsGrouping | (Inherited from ItemsControl.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsSelected |
Public property | IsSelectionActive |
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextSearchEnabled | (Inherited from ItemsControl.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemBindingGroup | (Inherited from ItemsControl.)
Public property | Items | Get the item children.
Public property | ItemsPanel | Get the element holding the tree view items. Override for custom control template.
Public property | ItemStringFormat | (Inherited from ItemsControl.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Get the item text. (Overrides FrameworkElement..::..Text.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToggleButton | Get the toggle button responsible for simulating item expand/collapse actions. Override for custom control template.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Header Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Header Property
TreeViewItem Class See Also Send Feedback
Get the header responsible for item selection. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement Header { get; }
Visual Basic
Public Overridable ReadOnly Property Header As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ Header {
    FrameworkElement^ get ();
}

Implements

ITreeViewItem..::..Header

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsExpanded Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsExpanded Property
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeViewItem.IsExpanded"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic
Public Property IsExpanded As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsExpanded {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ITreeViewItem..::..IsExpanded

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsSelected Property
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeViewItem.IsSelected"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic
Public Property IsSelected As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsSelected {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ITreeViewItem..::..IsSelected

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsSelectionActive Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsSelectionActive Property
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.TreeViewItem.IsSelectionActive"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelectionActive { get; set; }
Visual Basic
Public Property IsSelectionActive As Boolean
    Get
    Set
Visual C++
public:
property bool IsSelectionActive {
    bool get ();
    void set (bool value);
}

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Items Property
TreeViewItem Class See Also Send Feedback
Get the item children.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<ITreeViewItem> Items { get; }
Visual Basic
Public ReadOnly Property Items As IList(Of ITreeViewItem)
    Get
Visual C++
public:
virtual property IList<ITreeViewItem^>^ Items {
    IList<ITreeViewItem^>^ get () sealed;
}

Implements

ITreeViewItem..::..Items

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemsPanel Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..ItemsPanel Property
TreeViewItem Class See Also Send Feedback
Get the element holding the tree view items. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ItemsPanel { get; }
Visual Basic
Public Overridable ReadOnly Property ItemsPanel As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ItemsPanel {
    FrameworkElement^ get ();
}

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Text Property
TreeViewItem Class See Also Send Feedback
Get the item text.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string Text { get; }
Visual Basic
Public Overrides ReadOnly Property Text As String
    Get
Visual C++
public:
virtual property String^ Text {
    String^ get () override;
}

Implements

IFrameworkElement..::..Text
IFrameworkElement..::..Text

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ToggleButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..ToggleButton Property
TreeViewItem Class See Also Send Feedback
Get the toggle button responsible for simulating item expand/collapse actions. Override for custom control template.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ToggleButton { get; }
Visual Basic
Public Overridable ReadOnly Property ToggleButton As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ToggleButton {
    FrameworkElement^ get ();
}

Implements

ITreeViewItem..::..ToggleButton

See Also

TreeViewItem Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UniformGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid Members
UniformGrid Class Constructors Methods Fields Properties See Also Send Feedback

The UniformGrid type exposes the following members.

Constructors

 | Name | Description
Public method | UniformGrid | Initializes a new instance of the UniformGrid class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ColumnsProperty |
FirstColumnProperty |
RowsProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Columns |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstColumn |
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Rows |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UniformGrid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid Constructor
UniformGrid Class See Also Send Feedback
Initializes a new instance of the UniformGrid class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UniformGrid()
Visual Basic
Public Sub New
Visual C++
public:
UniformGrid()

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UniformGrid Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid Fields
UniformGrid Class See Also Send Feedback

The UniformGrid type exposes the following members.

Fields

Name | Description
ColumnsProperty |
FirstColumnProperty |
RowsProperty |

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..ColumnsProperty Field
UniformGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.UniformGrid.ColumnsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnsProperty
Visual Basic
Public Shared ColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnsProperty

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FirstColumnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..FirstColumnProperty Field
UniformGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.UniformGrid.FirstColumnProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FirstColumnProperty
Visual Basic
Public Shared FirstColumnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FirstColumnProperty

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RowsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..RowsProperty Field
UniformGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.UniformGrid.RowsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowsProperty
Visual Basic
Public Shared RowsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowsProperty

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UniformGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid Methods
UniformGrid Class See Also Send Feedback

The UniformGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..AnySibling Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..GetProperty Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..GetRealType Method
UniformGrid Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.UniformGrid.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.UniformGrid.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..GetRectangle Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..Highlight Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..InvokeMethod Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..IsHitTest Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..NextSibling Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..Parent Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..PreviousSibling Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..ScrollToVisible Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..SetProperty Method
UniformGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UniformGrid Class
UniformGrid Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UniformGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid Properties
UniformGrid Class See Also Send Feedback

The UniformGrid type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | Columns |
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstColumn |
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Rows |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Columns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..Columns Property
UniformGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.UniformGrid.Columns"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Columns { get; set; }
Visual Basic
Public Property Columns As Integer
    Get
    Set
Visual C++
public:
property int Columns {
    int get ();
    void set (int value);
}

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FirstColumn Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..FirstColumn Property
UniformGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.UniformGrid.FirstColumn"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int FirstColumn { get; set; }
Visual Basic
Public Property FirstColumn As Integer
    Get
    Set
Visual C++
public:
property int FirstColumn {
    int get ();
    void set (int value);
}

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UniformGrid..::..Rows Property
UniformGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.UniformGrid.Rows"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Rows { get; set; }
Visual Basic
Public Property Rows As Integer
    Get
    Set
Visual C++
public:
property int Rows {
    int get ();
    void set (int value);
}

See Also

UniformGrid Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnmanagedBitmapWrapper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnmanagedBitmapWrapper Members
UnmanagedBitmapWrapper Class Constructors Methods Properties See Also Send Feedback

The UnmanagedBitmapWrapper type exposes the following members.

Constructors

 | Name | Description
Public method | UnmanagedBitmapWrapper | Initializes a new instance of the UnmanagedBitmapWrapper class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UnmanagedBitmapWrapper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnmanagedBitmapWrapper Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnmanagedBitmapWrapper Constructor
UnmanagedBitmapWrapper Class See Also Send Feedback
Initializes a new instance of the UnmanagedBitmapWrapper class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UnmanagedBitmapWrapper()
Visual Basic
Public Sub New
Visual C++
public:
UnmanagedBitmapWrapper()

See Also

UnmanagedBitmapWrapper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnmanagedBitmapWrapper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnmanagedBitmapWrapper Methods
UnmanagedBitmapWrapper Class See Also Send Feedback

The UnmanagedBitmapWrapper type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UnmanagedBitmapWrapper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnmanagedBitmapWrapper..::..GetProperty Method
UnmanagedBitmapWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UnmanagedBitmapWrapper Class
UnmanagedBitmapWrapper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnmanagedBitmapWrapper..::..GetRealType Method
UnmanagedBitmapWrapper Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.UnmanagedBitmapWrapper.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.UnmanagedBitmapWrapper.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

UnmanagedBitmapWrapper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnmanagedBitmapWrapper..::..InvokeMethod Method
UnmanagedBitmapWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UnmanagedBitmapWrapper Class
UnmanagedBitmapWrapper Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UnmanagedBitmapWrapper Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnmanagedBitmapWrapper Properties
UnmanagedBitmapWrapper Class See Also Send Feedback

The UnmanagedBitmapWrapper type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UnmanagedBitmapWrapper Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UserControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl Members
UserControl Class Constructors Methods Properties See Also Send Feedback

The UserControl type exposes the following members.

Constructors

 | Name | Description
Public method | UserControl | Initializes a new instance of the UserControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

UserControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UserControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl Constructor
UserControl Class See Also Send Feedback
Initializes a new instance of the UserControl class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UserControl()
Visual Basic
Public Sub New
Visual C++
public:
UserControl()

See Also

UserControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UserControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl Methods
UserControl Class See Also Send Feedback

The UserControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

UserControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..AnySibling Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..GetProperty Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..GetRealType Method
UserControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.UserControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.UserControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

UserControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..GetRectangle Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..Highlight Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..InvokeMethod Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..IsHitTest Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..NextSibling Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..Parent Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..PreviousSibling Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..ScrollToVisible Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..SetProperty Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


UserControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl Properties
UserControl Class See Also Send Feedback

The UserControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

UserControl Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Vector3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D Members
Vector3D Class Constructors Methods Fields Properties See Also Send Feedback

The Vector3D type exposes the following members.

Constructors

 | Name | Description
Public method | Vector3D | Initializes a new instance of the Vector3D class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LengthProperty |
LengthSquaredProperty |
XProperty |
YProperty |
ZProperty |

Properties

 | Name | Description
Public property | Length |
Public property | LengthSquared |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |
Public property | Z |

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Vector3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D Constructor
Vector3D Class See Also Send Feedback
Initializes a new instance of the Vector3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Vector3D()
Visual Basic
Public Sub New
Visual C++
public:
Vector3D()

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Vector3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D Fields
Vector3D Class See Also Send Feedback

The Vector3D type exposes the following members.

Fields

Name | Description
LengthProperty |
LengthSquaredProperty |
XProperty |
YProperty |
ZProperty |

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LengthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..LengthProperty Field
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.LengthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LengthProperty
Visual Basic
Public Shared LengthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LengthProperty

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LengthSquaredProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..LengthSquaredProperty Field
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.LengthSquaredProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LengthSquaredProperty
Visual Basic
Public Shared LengthSquaredProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LengthSquaredProperty

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..XProperty Field
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.XProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..YProperty Field
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.YProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ZProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..ZProperty Field
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.ZProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZProperty
Visual Basic
Public Shared ZProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZProperty

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Vector3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D Methods
Vector3D Class See Also Send Feedback

The Vector3D type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..GetProperty Method
Vector3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Vector3D Class
Vector3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..GetRealType Method
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..InvokeMethod Method
Vector3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Vector3D Class
Vector3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Vector3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D Properties
Vector3D Class See Also Send Feedback

The Vector3D type exposes the following members.

Properties

 | Name | Description
Public property | Length |
Public property | LengthSquared |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |
Public property | Z |

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Length Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..Length Property
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.Length"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Length { get; set; }
Visual Basic
Public Overridable Property Length As Double
    Get
    Set
Visual C++
public:
virtual property double Length {
    double get ();
    void set (double value);
}

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LengthSquared Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..LengthSquared Property
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.LengthSquared"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double LengthSquared { get; set; }
Visual Basic
Public Overridable Property LengthSquared As Double
    Get
    Set
Visual C++
public:
virtual property double LengthSquared {
    double get ();
    void set (double value);
}

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


X Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..X Property
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.X"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double X { get; set; }
Visual Basic
Public Overridable Property X As Double
    Get
    Set
Visual C++
public:
virtual property double X {
    double get ();
    void set (double value);
}

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Y Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..Y Property
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.Y"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Y { get; set; }
Visual Basic
Public Overridable Property Y As Double
    Get
    Set
Visual C++
public:
virtual property double Y {
    double get ();
    void set (double value);
}

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Z Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Vector3D..::..Z Property
Vector3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Vector3D.Z"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Z { get; set; }
Visual Basic
Public Overridable Property Z As Double
    Get
    Set
Visual C++
public:
virtual property double Z {
    double get ();
    void set (double value);
}

See Also

Vector3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VideoDrawing Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing Members
VideoDrawing Class Constructors Methods Fields Properties See Also Send Feedback

The VideoDrawing type exposes the following members.

Constructors

 | Name | Description
Public method | VideoDrawing | Initializes a new instance of the VideoDrawing class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Drawing..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PlayerProperty |
RectProperty |

Properties

 | Name | Description
Public property | Player |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rect |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VideoDrawing Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing Constructor
VideoDrawing Class See Also Send Feedback
Initializes a new instance of the VideoDrawing class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VideoDrawing()
Visual Basic
Public Sub New
Visual C++
public:
VideoDrawing()

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VideoDrawing Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing Fields
VideoDrawing Class See Also Send Feedback

The VideoDrawing type exposes the following members.

Fields

Name | Description
PlayerProperty |
RectProperty |

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PlayerProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing..::..PlayerProperty Field
VideoDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.VideoDrawing.PlayerProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlayerProperty
Visual Basic
Public Shared PlayerProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlayerProperty

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


RectProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing..::..RectProperty Field
VideoDrawing Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.VideoDrawing.RectProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RectProperty
Visual Basic
Public Shared RectProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RectProperty

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VideoDrawing Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing Methods
VideoDrawing Class See Also Send Feedback

The VideoDrawing type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Drawing..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing..::..GetProperty Method
VideoDrawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VideoDrawing Class
VideoDrawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing..::..GetRealType Method
VideoDrawing Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.VideoDrawing.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.VideoDrawing.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing..::..InvokeMethod Method
VideoDrawing Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VideoDrawing Class
VideoDrawing Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VideoDrawing Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing Properties
VideoDrawing Class See Also Send Feedback

The VideoDrawing type exposes the following members.

Properties

 | Name | Description
Public property | Player |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rect |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Player Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing..::..Player Property
VideoDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.VideoDrawing.Player"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MediaPlayer Player { get; set; }
Visual Basic
Public Property Player As MediaPlayer
    Get
    Set
Visual C++
public:
property MediaPlayer^ Player {
    MediaPlayer^ get ();
    void set (MediaPlayer^ value);
}

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Rect Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoDrawing..::..Rect Property
VideoDrawing Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.VideoDrawing.Rect"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect Rect { get; set; }
Visual Basic
Public Property Rect As Rect
    Get
    Set
Visual C++
public:
property Rect^ Rect {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

VideoDrawing Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ViewBase Members
ViewBase Class Constructors Methods Properties See Also Send Feedback

The ViewBase type exposes the following members.

Constructors

 | Name | Description
Public method | ViewBase | Initializes a new instance of the ViewBase class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ViewBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ViewBase Constructor
ViewBase Class See Also Send Feedback
Initializes a new instance of the ViewBase class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ViewBase()
Visual Basic
Public Sub New
Visual C++
public:
ViewBase()

See Also

ViewBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ViewBase Methods
ViewBase Class See Also Send Feedback

The ViewBase type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ViewBase..::..GetProperty Method
ViewBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ViewBase Class
ViewBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ViewBase..::..GetRealType Method
ViewBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ViewBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.ViewBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ViewBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ViewBase..::..InvokeMethod Method
ViewBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ViewBase Class
ViewBase Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ViewBase Properties
ViewBase Class See Also Send Feedback

The ViewBase type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ViewBase Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewbox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Members
Viewbox Class Constructors Methods Fields Properties See Also Send Feedback

The Viewbox type exposes the following members.

Constructors

 | Name | Description
Public method | Viewbox | Initializes a new instance of the Viewbox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
StretchDirectionProperty |
StretchProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewbox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Constructor
Viewbox Class See Also Send Feedback
Initializes a new instance of the Viewbox class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Viewbox()
Visual Basic
Public Sub New
Visual C++
public:
Viewbox()

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewbox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Fields
Viewbox Class See Also Send Feedback

The Viewbox type exposes the following members.

Fields

Name | Description
StretchDirectionProperty |
StretchProperty |

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..StretchDirectionProperty Field
Viewbox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewbox.StretchDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchDirectionProperty
Visual Basic
Public Shared StretchDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchDirectionProperty

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..StretchProperty Field
Viewbox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewbox.StretchProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewbox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Methods
Viewbox Class See Also Send Feedback

The Viewbox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Decorator..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..AnySibling Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..GetProperty Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..GetRealType Method
Viewbox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewbox.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewbox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..GetRectangle Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..Highlight Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..InvokeMethod Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..IsHitTest Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..NextSibling Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..Parent Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..PreviousSibling Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..ScrollToVisible Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..SetProperty Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewbox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Properties
Viewbox Class See Also Send Feedback

The Viewbox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Stretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..Stretch Property
Viewbox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewbox.Stretch"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Stretch Stretch { get; set; }
Visual Basic
Public Property Stretch As Stretch
    Get
    Set
Visual C++
public:
property Stretch Stretch {
    Stretch get ();
    void set (Stretch value);
}

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


StretchDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..StretchDirection Property
Viewbox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewbox.StretchDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StretchDirection StretchDirection { get; set; }
Visual Basic
Public Property StretchDirection As StretchDirection
    Get
    Set
Visual C++
public:
property StretchDirection StretchDirection {
    StretchDirection get ();
    void set (StretchDirection value);
}

See Also

Viewbox Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3D Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D Members
Viewport3D Class Constructors Methods Fields Properties See Also Send Feedback

The Viewport3D type exposes the following members.

Constructors

 | Name | Description
Public method | Viewport3D | Initializes a new instance of the Viewport3D class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CameraProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Camera |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Viewport3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3D Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D Constructor
Viewport3D Class See Also Send Feedback
Initializes a new instance of the Viewport3D class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Viewport3D()
Visual Basic
Public Sub New
Visual C++
public:
Viewport3D()

See Also

Viewport3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3D Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D Fields
Viewport3D Class See Also Send Feedback

The Viewport3D type exposes the following members.

Fields

Name | Description
CameraProperty |

See Also

Viewport3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CameraProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..CameraProperty Field
Viewport3D Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3D.CameraProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CameraProperty
Visual Basic
Public Shared CameraProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CameraProperty

See Also

Viewport3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3D Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D Methods
Viewport3D Class See Also Send Feedback

The Viewport3D type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Viewport3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..AnySibling Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..GetProperty Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..GetRealType Method
Viewport3D Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3D.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3D.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Viewport3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..GetRectangle Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..Highlight Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..InvokeMethod Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..IsHitTest Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..NextSibling Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..Parent Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..PreviousSibling Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..ScrollToVisible Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..SetProperty Method
Viewport3D Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewport3D Class
Viewport3D Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3D Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D Properties
Viewport3D Class See Also Send Feedback

The Viewport3D type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Camera |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Viewport3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Camera Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3D..::..Camera Property
Viewport3D Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3D.Camera"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Camera Camera { get; set; }
Visual Basic
Public Property Camera As Camera
    Get
    Set
Visual C++
public:
property Camera^ Camera {
    Camera^ get ();
    void set (Camera^ value);
}

See Also

Viewport3D Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3DVisual Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual Members
Viewport3DVisual Class Constructors Methods Fields Properties See Also Send Feedback

The Viewport3DVisual type exposes the following members.

Constructors

 | Name | Description
Public method | Viewport3DVisual | Initializes a new instance of the Viewport3DVisual class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Visual..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CameraProperty |
ViewportProperty |

Properties

 | Name | Description
Public property | Camera |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Viewport |

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3DVisual Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual Constructor
Viewport3DVisual Class See Also Send Feedback
Initializes a new instance of the Viewport3DVisual class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Viewport3DVisual()
Visual Basic
Public Sub New
Visual C++
public:
Viewport3DVisual()

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3DVisual Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual Fields
Viewport3DVisual Class See Also Send Feedback

The Viewport3DVisual type exposes the following members.

Fields

Name | Description
CameraProperty |
ViewportProperty |

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


CameraProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual..::..CameraProperty Field
Viewport3DVisual Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3DVisual.CameraProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CameraProperty
Visual Basic
Public Shared CameraProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CameraProperty

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual..::..ViewportProperty Field
Viewport3DVisual Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3DVisual.ViewportProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportProperty
Visual Basic
Public Shared ViewportProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportProperty

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3DVisual Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual Methods
Viewport3DVisual Class See Also Send Feedback

The Viewport3DVisual type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Visual..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual..::..GetProperty Method
Viewport3DVisual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewport3DVisual Class
Viewport3DVisual Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual..::..GetRealType Method
Viewport3DVisual Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3DVisual.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3DVisual.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual..::..InvokeMethod Method
Viewport3DVisual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewport3DVisual Class
Viewport3DVisual Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport3DVisual Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual Properties
Viewport3DVisual Class See Also Send Feedback

The Viewport3DVisual type exposes the following members.

Properties

 | Name | Description
Public property | Camera |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Viewport |

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Camera Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual..::..Camera Property
Viewport3DVisual Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3DVisual.Camera"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Camera Camera { get; set; }
Visual Basic
Public Property Camera As Camera
    Get
    Set
Visual C++
public:
property Camera^ Camera {
    Camera^ get ();
    void set (Camera^ value);
}

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Viewport Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewport3DVisual..::..Viewport Property
Viewport3DVisual Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Viewport3DVisual.Viewport"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect Viewport { get; set; }
Visual Basic
Public Property Viewport As Rect
    Get
    Set
Visual C++
public:
property Rect^ Viewport {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

Viewport3DVisual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel Members
VirtualizingPanel Class Constructors Methods Properties See Also Send Feedback

The VirtualizingPanel type exposes the following members.

Constructors

 | Name | Description
Public method | VirtualizingPanel | Initializes a new instance of the VirtualizingPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel Constructor
VirtualizingPanel Class See Also Send Feedback
Initializes a new instance of the VirtualizingPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VirtualizingPanel()
Visual Basic
Public Sub New
Visual C++
public:
VirtualizingPanel()

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel Methods
VirtualizingPanel Class See Also Send Feedback

The VirtualizingPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..AnySibling Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..GetProperty Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..GetRealType Method
VirtualizingPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.VirtualizingPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.VirtualizingPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..GetRectangle Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..Highlight Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..InvokeMethod Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..IsHitTest Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..NextSibling Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..Parent Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..PreviousSibling Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..ScrollToVisible Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..SetProperty Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel Properties
VirtualizingPanel Class See Also Send Feedback

The VirtualizingPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingStackPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Members
VirtualizingStackPanel Class Constructors Methods Fields Properties See Also Send Feedback

The VirtualizingStackPanel type exposes the following members.

Constructors

 | Name | Description
Public method | VirtualizingStackPanel | Initializes a new instance of the VirtualizingStackPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides VirtualizingPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetVerticalOffset | Set the vertical offset.
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
OrientationProperty |
VerticalOffsetProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Get the vertical offset.
Public property | ViewportOffset | Get the viewport offset.
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingStackPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Constructor
VirtualizingStackPanel Class See Also Send Feedback
Initializes a new instance of the VirtualizingStackPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VirtualizingStackPanel()
Visual Basic
Public Sub New
Visual C++
public:
VirtualizingStackPanel()

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingStackPanel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Fields
VirtualizingStackPanel Class See Also Send Feedback

The VirtualizingStackPanel type exposes the following members.

Fields

Name | Description
OrientationProperty |
VerticalOffsetProperty |

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..OrientationProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.VirtualizingStackPanel.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..VerticalOffsetProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.VirtualizingStackPanel.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingStackPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Methods
VirtualizingStackPanel Class See Also Send Feedback

The VirtualizingStackPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides VirtualizingPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetVerticalOffset | Set the vertical offset.
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..AnySibling Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..GetProperty Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..GetRealType Method
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.VirtualizingStackPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.VirtualizingStackPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..GetRectangle Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..Highlight Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..InvokeMethod Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..IsHitTest Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..NextSibling Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..Parent Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..PreviousSibling Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..ScrollToVisible Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..SetProperty Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetVerticalOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..SetVerticalOffset Method
VirtualizingStackPanel Class See Also Send Feedback
Set the vertical offset.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetVerticalOffset(
    double offset
)
Visual Basic
Public Sub SetVerticalOffset ( _
    offset As Double _
)
Visual C++
public:
virtual void SetVerticalOffset(
    double offset
) sealed

Parameters

offset
Type: System..::..Double
The offset to set.

Implements

IVirtualizingStackPanel..::..SetVerticalOffset(Double)

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VirtualizingStackPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Properties
VirtualizingStackPanel Class See Also Send Feedback

The VirtualizingStackPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset | Get the vertical offset.
Public property | ViewportOffset | Get the viewport offset.
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..Orientation Property
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.VirtualizingStackPanel.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VerticalOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..VerticalOffset Property
VirtualizingStackPanel Class See Also Send Feedback
Get the vertical offset.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double VerticalOffset { get; }
Visual Basic
Public ReadOnly Property VerticalOffset As Double
    Get
Visual C++
public:
virtual property double VerticalOffset {
    double get () sealed;
}

Implements

IVirtualizingStackPanel..::..VerticalOffset

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ViewportOffset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..ViewportOffset Property
VirtualizingStackPanel Class See Also Send Feedback
Get the viewport offset.

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ViewportOffset { get; }
Visual Basic
Public ReadOnly Property ViewportOffset As Integer
    Get
Visual C++
public:
virtual property int ViewportOffset {
    int get () sealed;
}

Implements

IVirtualizingStackPanel..::..ViewportOffset

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Visual Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Visual Members
Visual Class Constructors Methods Properties See Also Send Feedback

The Visual type exposes the following members.

Constructors

 | Name | Description
Public method | Visual | Initializes a new instance of the Visual class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Visual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Visual Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Visual Constructor
Visual Class See Also Send Feedback
Initializes a new instance of the Visual class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visual()
Visual Basic
Public Sub New
Visual C++
public:
Visual()

See Also

Visual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Visual Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Visual Methods
Visual Class See Also Send Feedback

The Visual type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Visual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Visual..::..GetProperty Method
Visual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Visual Class
Visual Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Visual..::..GetRealType Method
Visual Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Visual.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Visual.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Visual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Visual..::..InvokeMethod Method
Visual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Visual Class
Visual Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Visual Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Visual Properties
Visual Class See Also Send Feedback

The Visual type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Visual Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VisualBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush Members
VisualBrush Class Constructors Methods Fields Properties See Also Send Feedback

The VisualBrush type exposes the following members.

Constructors

 | Name | Description
Public method | VisualBrush | Initializes a new instance of the VisualBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AutoLayoutContentProperty |
VisualProperty |

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | AutoLayoutContent |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch | (Inherited from TileBrush.)
Public property | TileMode | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)
Public property | Viewbox | (Inherited from TileBrush.)
Public property | ViewboxUnits | (Inherited from TileBrush.)
Public property | Viewport | (Inherited from TileBrush.)
Public property | ViewportUnits | (Inherited from TileBrush.)
Public property | Visual |

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VisualBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush Constructor
VisualBrush Class See Also Send Feedback
Initializes a new instance of the VisualBrush class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualBrush()
Visual Basic
Public Sub New
Visual C++
public:
VisualBrush()

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VisualBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush Fields
VisualBrush Class See Also Send Feedback

The VisualBrush type exposes the following members.

Fields

Name | Description
AutoLayoutContentProperty |
VisualProperty |

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoLayoutContentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush..::..AutoLayoutContentProperty Field
VisualBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.VisualBrush.AutoLayoutContentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoLayoutContentProperty
Visual Basic
Public Shared AutoLayoutContentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoLayoutContentProperty

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VisualProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush..::..VisualProperty Field
VisualBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.VisualBrush.VisualProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VisualProperty
Visual Basic
Public Shared VisualProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VisualProperty

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VisualBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush Methods
VisualBrush Class See Also Send Feedback

The VisualBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush..::..GetProperty Method
VisualBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VisualBrush Class
VisualBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush..::..GetRealType Method
VisualBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.VisualBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.VisualBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush..::..InvokeMethod Method
VisualBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VisualBrush Class
VisualBrush Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


VisualBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush Properties
VisualBrush Class See Also Send Feedback

The VisualBrush type exposes the following members.

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | AutoLayoutContent |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch | (Inherited from TileBrush.)
Public property | TileMode | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)
Public property | Viewbox | (Inherited from TileBrush.)
Public property | ViewboxUnits | (Inherited from TileBrush.)
Public property | Viewport | (Inherited from TileBrush.)
Public property | ViewportUnits | (Inherited from TileBrush.)
Public property | Visual |

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AutoLayoutContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush..::..AutoLayoutContent Property
VisualBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.VisualBrush.AutoLayoutContent"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AutoLayoutContent { get; set; }
Visual Basic
Public Property AutoLayoutContent As Boolean
    Get
    Set
Visual C++
public:
property bool AutoLayoutContent {
    bool get ();
    void set (bool value);
}

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Visual Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualBrush..::..Visual Property
VisualBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.VisualBrush.Visual"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visual Visual { get; set; }
Visual Basic
Public Property Visual As Visual
    Get
    Set
Visual C++
public:
property Visual^ Visual {
    Visual^ get ();
    void set (Visual^ value);
}

See Also

VisualBrush Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WebBrowser Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser Members
WebBrowser Class Constructors Methods Properties See Also Send Feedback

The WebBrowser type exposes the following members.

Constructors

 | Name | Description
Public method | WebBrowser | Initializes a new instance of the WebBrowser class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ActiveXHost..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WebBrowser Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WebBrowser Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser Constructor
WebBrowser Class See Also Send Feedback
Initializes a new instance of the WebBrowser class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebBrowser()
Visual Basic
Public Sub New
Visual C++
public:
WebBrowser()

See Also

WebBrowser Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WebBrowser Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser Methods
WebBrowser Class See Also Send Feedback

The WebBrowser type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ActiveXHost..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..AnySibling Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..GetProperty Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..GetRealType Method
WebBrowser Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.WebBrowser.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.WebBrowser.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

WebBrowser Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..GetRectangle Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..Highlight Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..InvokeMethod Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..IsHitTest Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..NextSibling Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..Parent Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..PreviousSibling Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..ScrollToVisible Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..SetProperty Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WebBrowser Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser Properties
WebBrowser Class See Also Send Feedback

The WebBrowser type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WebBrowser Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Window Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Members
Window Class Constructors Methods Fields Properties See Also Send Feedback

The Window type exposes the following members.

Constructors

 | Name | Description
Public method | Window | Initializes a new instance of the Window class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AllowsTransparencyProperty |
IconProperty |
IsActiveProperty |
LeftProperty |
ResizeModeProperty |
ShowActivatedProperty |
ShowInTaskbarProperty |
SizeToContentProperty |
TitleProperty |
TopmostProperty |
TopProperty |
WindowStateProperty |
WindowStyleProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AllowsTransparency |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Icon |
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsActive |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Left |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ResizeMode |
Public property | ShowActivated |
Public property | ShowInTaskbar |
Public property | SizeToContent |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Top |
Public property | Topmost |
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | WindowState |
Public property | WindowStyle |
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Window Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Constructor
Window Class See Also Send Feedback
Initializes a new instance of the Window class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Window()
Visual Basic
Public Sub New
Visual C++
public:
Window()

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Window Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Fields
Window Class See Also Send Feedback

The Window type exposes the following members.

Fields

Name | Description
AllowsTransparencyProperty |
IconProperty |
IsActiveProperty |
LeftProperty |
ResizeModeProperty |
ShowActivatedProperty |
ShowInTaskbarProperty |
SizeToContentProperty |
TitleProperty |
TopmostProperty |
TopProperty |
WindowStateProperty |
WindowStyleProperty |

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AllowsTransparencyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..AllowsTransparencyProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.AllowsTransparencyProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AllowsTransparencyProperty
Visual Basic
Public Shared AllowsTransparencyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AllowsTransparencyProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IconProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IconProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.IconProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IconProperty
Visual Basic
Public Shared IconProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IconProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsActiveProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsActiveProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.IsActiveProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsActiveProperty
Visual Basic
Public Shared IsActiveProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsActiveProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..LeftProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.LeftProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LeftProperty
Visual Basic
Public Shared LeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LeftProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ResizeModeProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.ResizeModeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ResizeModeProperty
Visual Basic
Public Shared ResizeModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ResizeModeProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowActivatedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ShowActivatedProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.ShowActivatedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ShowActivatedProperty
Visual Basic
Public Shared ShowActivatedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ShowActivatedProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowInTaskbarProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ShowInTaskbarProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.ShowInTaskbarProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ShowInTaskbarProperty
Visual Basic
Public Shared ShowInTaskbarProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ShowInTaskbarProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SizeToContentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..SizeToContentProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.SizeToContentProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SizeToContentProperty
Visual Basic
Public Shared SizeToContentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SizeToContentProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TitleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..TitleProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.TitleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TitleProperty
Visual Basic
Public Shared TitleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TitleProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopmostProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..TopmostProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.TopmostProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopmostProperty
Visual Basic
Public Shared TopmostProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopmostProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


TopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..TopProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.TopProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopProperty
Visual Basic
Public Shared TopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WindowStateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..WindowStateProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.WindowStateProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WindowStateProperty
Visual Basic
Public Shared WindowStateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WindowStateProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WindowStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..WindowStyleProperty Field
Window Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.WindowStyleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WindowStyleProperty
Visual Basic
Public Shared WindowStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WindowStyleProperty

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Window Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Methods
Window Class See Also Send Feedback

The Window type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..AnySibling Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetProperty Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetRealType Method
Window Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..GetRectangle Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Highlight Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..InvokeMethod Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsHitTest Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..NextSibling Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Parent Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..PreviousSibling Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ScrollToVisible Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..SetProperty Method
Window Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Window Class
Window Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Window Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window Properties
Window Class See Also Send Feedback

The Window type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | AllowsTransparency |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Foreground | (Inherited from Control.)
Public property | HasContent | (Inherited from ContentControl.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Icon |
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsActive |
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | Left |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ResizeMode |
Public property | ShowActivated |
Public property | ShowInTaskbar |
Public property | SizeToContent |
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Top |
Public property | Topmost |
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | WindowState |
Public property | WindowStyle |
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AllowsTransparency Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..AllowsTransparency Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.AllowsTransparency"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AllowsTransparency { get; set; }
Visual Basic
Public Property AllowsTransparency As Boolean
    Get
    Set
Visual C++
public:
property bool AllowsTransparency {
    bool get ();
    void set (bool value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Icon Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Icon Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.Icon"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageSource Icon { get; set; }
Visual Basic
Public Property Icon As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Icon {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsActive Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..IsActive Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.IsActive"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsActive { get; set; }
Visual Basic
Public Property IsActive As Boolean
    Get
    Set
Visual C++
public:
property bool IsActive {
    bool get ();
    void set (bool value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Left Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Left Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.Left"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Left { get; set; }
Visual Basic
Public Property Left As Double
    Get
    Set
Visual C++
public:
property double Left {
    double get ();
    void set (double value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ResizeMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ResizeMode Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.ResizeMode"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ResizeMode ResizeMode { get; set; }
Visual Basic
Public Property ResizeMode As ResizeMode
    Get
    Set
Visual C++
public:
property ResizeMode ResizeMode {
    ResizeMode get ();
    void set (ResizeMode value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowActivated Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ShowActivated Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.ShowActivated"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowActivated { get; set; }
Visual Basic
Public Property ShowActivated As Boolean
    Get
    Set
Visual C++
public:
property bool ShowActivated {
    bool get ();
    void set (bool value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ShowInTaskbar Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..ShowInTaskbar Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.ShowInTaskbar"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowInTaskbar { get; set; }
Visual Basic
Public Property ShowInTaskbar As Boolean
    Get
    Set
Visual C++
public:
property bool ShowInTaskbar {
    bool get ();
    void set (bool value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SizeToContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..SizeToContent Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.SizeToContent"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SizeToContent SizeToContent { get; set; }
Visual Basic
Public Property SizeToContent As SizeToContent
    Get
    Set
Visual C++
public:
property SizeToContent SizeToContent {
    SizeToContent get ();
    void set (SizeToContent value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Title Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Title Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.Title"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Top Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Top Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.Top"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Top { get; set; }
Visual Basic
Public Property Top As Double
    Get
    Set
Visual C++
public:
property double Top {
    double get ();
    void set (double value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Topmost Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..Topmost Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.Topmost"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Topmost { get; set; }
Visual Basic
Public Property Topmost As Boolean
    Get
    Set
Visual C++
public:
property bool Topmost {
    bool get ();
    void set (bool value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WindowState Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..WindowState Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.WindowState"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WindowState WindowState { get; set; }
Visual Basic
Public Property WindowState As WindowState
    Get
    Set
Visual C++
public:
property WindowState WindowState {
    WindowState get ();
    void set (WindowState value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WindowStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Window..::..WindowStyle Property
Window Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.Window.WindowStyle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WindowStyle WindowStyle { get; set; }
Visual Basic
Public Property WindowStyle As WindowStyle
    Get
    Set
Visual C++
public:
property WindowStyle WindowStyle {
    WindowStyle get ();
    void set (WindowStyle value);
}

See Also

Window Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WpfTestElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement Members
WpfTestElement Class Constructors Methods Fields Properties See Also Send Feedback

The WpfTestElement type exposes the following members.

Constructors

 | Name | Description
Public method | WpfTestElement | Initializes a new instance of the WpfTestElement class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AllowDropProperty |
BindingGroupProperty |
ClipToBoundsProperty |
ContextMenuProperty |
FlowDirectionProperty |
FocusableProperty |
ForceCursorProperty |
InputScopeProperty |
IsEnabledProperty |
IsFocusedProperty |
IsKeyboardFocusedProperty |
IsKeyboardFocusWithinProperty |
IsMouseCapturedProperty |
IsMouseCaptureWithinProperty |
IsMouseDirectlyOverProperty |
IsMouseOverProperty |
IsStylusCapturedProperty |
IsStylusCaptureWithinProperty |
IsStylusDirectlyOverProperty |
IsStylusOverProperty |
IsVisibleProperty |
LayoutTransformProperty |
OverridesDefaultStyleProperty |
SnapsToDevicePixelsProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds |
Public property | ComputedVisibility | (Overrides FrameworkElement..::..ComputedVisibility.)
Public property | ContextMenu |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection |
Public property | Focusable |
Public property | ForceCursor |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope |
Public property | IsEnabled |
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused |
Public property | IsKeyboardFocusWithin |
Public property | IsMouseCaptured |
Public property | IsMouseCaptureWithin |
Public property | IsMouseDirectlyOver |
Public property | IsMouseOver |
Public property | IsStylusCaptured |
Public property | IsStylusCaptureWithin |
Public property | IsStylusDirectlyOver |
Public property | IsStylusOver |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Overrides FrameworkElement..::..IsVisible.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WpfTestElement Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement Constructor
WpfTestElement Class See Also Send Feedback
Initializes a new instance of the WpfTestElement class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfTestElement()
Visual Basic
Public Sub New
Visual C++
public:
WpfTestElement()

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WpfTestElement Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement Fields
WpfTestElement Class See Also Send Feedback

The WpfTestElement type exposes the following members.

Fields

Name | Description
AllowDropProperty |
BindingGroupProperty |
ClipToBoundsProperty |
ContextMenuProperty |
FlowDirectionProperty |
FocusableProperty |
ForceCursorProperty |
InputScopeProperty |
IsEnabledProperty |
IsFocusedProperty |
IsKeyboardFocusedProperty |
IsKeyboardFocusWithinProperty |
IsMouseCapturedProperty |
IsMouseCaptureWithinProperty |
IsMouseDirectlyOverProperty |
IsMouseOverProperty |
IsStylusCapturedProperty |
IsStylusCaptureWithinProperty |
IsStylusDirectlyOverProperty |
IsStylusOverProperty |
IsVisibleProperty |
LayoutTransformProperty |
OverridesDefaultStyleProperty |
SnapsToDevicePixelsProperty |

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AllowDropProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..AllowDropProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.AllowDropProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AllowDropProperty
Visual Basic
Public Shared AllowDropProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AllowDropProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BindingGroupProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..BindingGroupProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.BindingGroupProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BindingGroupProperty
Visual Basic
Public Shared BindingGroupProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BindingGroupProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ClipToBoundsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..ClipToBoundsProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.ClipToBoundsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ClipToBoundsProperty
Visual Basic
Public Shared ClipToBoundsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ClipToBoundsProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContextMenuProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..ContextMenuProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.ContextMenuProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContextMenuProperty
Visual Basic
Public Shared ContextMenuProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContextMenuProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..FlowDirectionProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.FlowDirectionProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FlowDirectionProperty
Visual Basic
Public Shared FlowDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FlowDirectionProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FocusableProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..FocusableProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.FocusableProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FocusableProperty
Visual Basic
Public Shared FocusableProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FocusableProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForceCursorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..ForceCursorProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.ForceCursorProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForceCursorProperty
Visual Basic
Public Shared ForceCursorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForceCursorProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InputScopeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..InputScopeProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.InputScopeProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty InputScopeProperty
Visual Basic
Public Shared InputScopeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ InputScopeProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsEnabledProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsEnabledProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEnabledProperty
Visual Basic
Public Shared IsEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEnabledProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFocusedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsFocusedProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsFocusedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFocusedProperty
Visual Basic
Public Shared IsFocusedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFocusedProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsKeyboardFocusedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsKeyboardFocusedProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsKeyboardFocusedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsKeyboardFocusedProperty
Visual Basic
Public Shared IsKeyboardFocusedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsKeyboardFocusedProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsKeyboardFocusWithinProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsKeyboardFocusWithinProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsKeyboardFocusWithinProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsKeyboardFocusWithinProperty
Visual Basic
Public Shared IsKeyboardFocusWithinProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsKeyboardFocusWithinProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseCapturedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsMouseCapturedProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsMouseCapturedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMouseCapturedProperty
Visual Basic
Public Shared IsMouseCapturedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMouseCapturedProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseCaptureWithinProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsMouseCaptureWithinProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsMouseCaptureWithinProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMouseCaptureWithinProperty
Visual Basic
Public Shared IsMouseCaptureWithinProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMouseCaptureWithinProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseDirectlyOverProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsMouseDirectlyOverProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsMouseDirectlyOverProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMouseDirectlyOverProperty
Visual Basic
Public Shared IsMouseDirectlyOverProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMouseDirectlyOverProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseOverProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsMouseOverProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsMouseOverProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMouseOverProperty
Visual Basic
Public Shared IsMouseOverProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMouseOverProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStylusCapturedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsStylusCapturedProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsStylusCapturedProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsStylusCapturedProperty
Visual Basic
Public Shared IsStylusCapturedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsStylusCapturedProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStylusCaptureWithinProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsStylusCaptureWithinProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsStylusCaptureWithinProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsStylusCaptureWithinProperty
Visual Basic
Public Shared IsStylusCaptureWithinProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsStylusCaptureWithinProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStylusDirectlyOverProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsStylusDirectlyOverProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsStylusDirectlyOverProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsStylusDirectlyOverProperty
Visual Basic
Public Shared IsStylusDirectlyOverProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsStylusDirectlyOverProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStylusOverProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsStylusOverProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsStylusOverProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsStylusOverProperty
Visual Basic
Public Shared IsStylusOverProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsStylusOverProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsVisibleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsVisibleProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsVisibleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsVisibleProperty
Visual Basic
Public Shared IsVisibleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsVisibleProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


LayoutTransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..LayoutTransformProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.LayoutTransformProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LayoutTransformProperty
Visual Basic
Public Shared LayoutTransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LayoutTransformProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OverridesDefaultStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..OverridesDefaultStyleProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.OverridesDefaultStyleProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OverridesDefaultStyleProperty
Visual Basic
Public Shared OverridesDefaultStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OverridesDefaultStyleProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SnapsToDevicePixelsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..SnapsToDevicePixelsProperty Field
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.SnapsToDevicePixelsProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SnapsToDevicePixelsProperty
Visual Basic
Public Shared SnapsToDevicePixelsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SnapsToDevicePixelsProperty

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WpfTestElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement Methods
WpfTestElement Class See Also Send Feedback

The WpfTestElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Inherited from FrameworkElement.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..AnySibling Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..GetProperty Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..GetRectangle Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..Highlight Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..InvokeMethod Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsHitTest Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..NextSibling Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..Parent Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..PreviousSibling Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..ScrollToVisible Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..SetProperty Method
WpfTestElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WpfTestElement Class
WpfTestElement Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WpfTestElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement Properties
WpfTestElement Class See Also Send Feedback

The WpfTestElement type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BindingGroup |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds |
Public property | ComputedVisibility | (Overrides FrameworkElement..::..ComputedVisibility.)
Public property | ContextMenu |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection |
Public property | Focusable |
Public property | ForceCursor |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope |
Public property | IsEnabled |
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsKeyboardFocused |
Public property | IsKeyboardFocusWithin |
Public property | IsMouseCaptured |
Public property | IsMouseCaptureWithin |
Public property | IsMouseDirectlyOver |
Public property | IsMouseOver |
Public property | IsStylusCaptured |
Public property | IsStylusCaptureWithin |
Public property | IsStylusDirectlyOver |
Public property | IsStylusOver |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Overrides FrameworkElement..::..IsVisible.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverridesDefaultStyle |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AllowDrop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..AllowDrop Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.AllowDrop"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AllowDrop { get; set; }
Visual Basic
Public Property AllowDrop As Boolean
    Get
    Set
Visual C++
public:
property bool AllowDrop {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


BindingGroup Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..BindingGroup Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.BindingGroup"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BindingGroup BindingGroup { get; set; }
Visual Basic
Public Property BindingGroup As BindingGroup
    Get
    Set
Visual C++
public:
property BindingGroup^ BindingGroup {
    BindingGroup^ get ();
    void set (BindingGroup^ value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ClipToBounds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..ClipToBounds Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.ClipToBounds"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ClipToBounds { get; set; }
Visual Basic
Public Property ClipToBounds As Boolean
    Get
    Set
Visual C++
public:
property bool ClipToBounds {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ComputedVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..ComputedVisibility Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.ComputedVisibility"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Visibility ComputedVisibility { get; }
Visual Basic
Public Overrides ReadOnly Property ComputedVisibility As Visibility
    Get
Visual C++
public:
virtual property Visibility ComputedVisibility {
    Visibility get () override;
}

Implements

IFrameworkElement..::..ComputedVisibility

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ContextMenu Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..ContextMenu Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.ContextMenu"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContextMenu ContextMenu { get; set; }
Visual Basic
Public Property ContextMenu As ContextMenu
    Get
    Set
Visual C++
public:
property ContextMenu^ ContextMenu {
    ContextMenu^ get ();
    void set (ContextMenu^ value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


FlowDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..FlowDirection Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.FlowDirection"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FlowDirection FlowDirection { get; set; }
Visual Basic
Public Property FlowDirection As FlowDirection
    Get
    Set
Visual C++
public:
property FlowDirection FlowDirection {
    FlowDirection get ();
    void set (FlowDirection value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Focusable Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..Focusable Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.Focusable"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Focusable { get; set; }
Visual Basic
Public Property Focusable As Boolean
    Get
    Set
Visual C++
public:
property bool Focusable {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ForceCursor Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..ForceCursor Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.ForceCursor"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ForceCursor { get; set; }
Visual Basic
Public Property ForceCursor As Boolean
    Get
    Set
Visual C++
public:
property bool ForceCursor {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InputScope Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..InputScope Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.InputScope"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InputScope InputScope { get; set; }
Visual Basic
Public Property InputScope As InputScope
    Get
    Set
Visual C++
public:
property InputScope^ InputScope {
    InputScope^ get ();
    void set (InputScope^ value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsEnabled Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsEnabled"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic
Public Property IsEnabled As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsFocused Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsFocused Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsFocused"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFocused { get; set; }
Visual Basic
Public Property IsFocused As Boolean
    Get
    Set
Visual C++
public:
property bool IsFocused {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsKeyboardFocused Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsKeyboardFocused Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsKeyboardFocused"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsKeyboardFocused { get; set; }
Visual Basic
Public Property IsKeyboardFocused As Boolean
    Get
    Set
Visual C++
public:
property bool IsKeyboardFocused {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsKeyboardFocusWithin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsKeyboardFocusWithin Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsKeyboardFocusWithin"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsKeyboardFocusWithin { get; set; }
Visual Basic
Public Property IsKeyboardFocusWithin As Boolean
    Get
    Set
Visual C++
public:
property bool IsKeyboardFocusWithin {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseCaptured Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsMouseCaptured Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsMouseCaptured"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMouseCaptured { get; set; }
Visual Basic
Public Property IsMouseCaptured As Boolean
    Get
    Set
Visual C++
public:
property bool IsMouseCaptured {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseCaptureWithin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsMouseCaptureWithin Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsMouseCaptureWithin"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMouseCaptureWithin { get; set; }
Visual Basic
Public Property IsMouseCaptureWithin As Boolean
    Get
    Set
Visual C++
public:
property bool IsMouseCaptureWithin {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseDirectlyOver Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsMouseDirectlyOver Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsMouseDirectlyOver"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMouseDirectlyOver { get; set; }
Visual Basic
Public Property IsMouseDirectlyOver As Boolean
    Get
    Set
Visual C++
public:
property bool IsMouseDirectlyOver {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsMouseOver Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsMouseOver Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsMouseOver"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMouseOver { get; set; }
Visual Basic
Public Property IsMouseOver As Boolean
    Get
    Set
Visual C++
public:
property bool IsMouseOver {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStylusCaptured Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsStylusCaptured Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsStylusCaptured"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsStylusCaptured { get; set; }
Visual Basic
Public Property IsStylusCaptured As Boolean
    Get
    Set
Visual C++
public:
property bool IsStylusCaptured {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStylusCaptureWithin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsStylusCaptureWithin Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsStylusCaptureWithin"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsStylusCaptureWithin { get; set; }
Visual Basic
Public Property IsStylusCaptureWithin As Boolean
    Get
    Set
Visual C++
public:
property bool IsStylusCaptureWithin {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStylusDirectlyOver Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsStylusDirectlyOver Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsStylusDirectlyOver"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsStylusDirectlyOver { get; set; }
Visual Basic
Public Property IsStylusDirectlyOver As Boolean
    Get
    Set
Visual C++
public:
property bool IsStylusDirectlyOver {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsStylusOver Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsStylusOver Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsStylusOver"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsStylusOver { get; set; }
Visual Basic
Public Property IsStylusOver As Boolean
    Get
    Set
Visual C++
public:
property bool IsStylusOver {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsVisible Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..IsVisible Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.IsVisible"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsVisible { get; }
Visual Basic
Public Overrides ReadOnly Property IsVisible As Boolean
    Get
Visual C++
public:
virtual property bool IsVisible {
    bool get () override;
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OverridesDefaultStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..OverridesDefaultStyle Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.OverridesDefaultStyle"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool OverridesDefaultStyle { get; set; }
Visual Basic
Public Property OverridesDefaultStyle As Boolean
    Get
    Set
Visual C++
public:
property bool OverridesDefaultStyle {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SnapsToDevicePixels Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfTestElement..::..SnapsToDevicePixels Property
WpfTestElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WpfTestElement.SnapsToDevicePixels"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SnapsToDevicePixels { get; set; }
Visual Basic
Public Property SnapsToDevicePixels As Boolean
    Get
    Set
Visual C++
public:
property bool SnapsToDevicePixels {
    bool get ();
    void set (bool value);
}

See Also

WpfTestElement Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WrapPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel Members
WrapPanel Class Constructors Methods Fields Properties See Also Send Feedback

The WrapPanel type exposes the following members.

Constructors

 | Name | Description
Public method | WrapPanel | Initializes a new instance of the WrapPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ItemHeightProperty |
ItemWidthProperty |
OrientationProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemHeight |
Public property | ItemWidth |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WrapPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel Constructor
WrapPanel Class See Also Send Feedback
Initializes a new instance of the WrapPanel class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WrapPanel()
Visual Basic
Public Sub New
Visual C++
public:
WrapPanel()

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WrapPanel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel Fields
WrapPanel Class See Also Send Feedback

The WrapPanel type exposes the following members.

Fields

Name | Description
ItemHeightProperty |
ItemWidthProperty |
OrientationProperty |

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..ItemHeightProperty Field
WrapPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WrapPanel.ItemHeightProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemHeightProperty
Visual Basic
Public Shared ItemHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemHeightProperty

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..ItemWidthProperty Field
WrapPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WrapPanel.ItemWidthProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemWidthProperty
Visual Basic
Public Shared ItemWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemWidthProperty

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..OrientationProperty Field
WrapPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Controls.Xaml.Wpf.WrapPanel.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WrapPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel Methods
WrapPanel Class See Also Send Feedback

The WrapPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..AnySibling Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..GetProperty Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..GetRealType Method
WrapPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.WrapPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.WrapPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..GetRectangle Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..Highlight Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..InvokeMethod Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..IsHitTest Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..NextSibling Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..Parent Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..PreviousSibling Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..ScrollToVisible Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..SetProperty Method
WrapPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WrapPanel Class
WrapPanel Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WrapPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel Properties
WrapPanel Class See Also Send Feedback

The WrapPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | (Inherited from WpfTestElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | BindingGroup | (Inherited from WpfTestElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipToBounds | (Inherited from WpfTestElement.)
Public property | ComputedVisibility | (Inherited from WpfTestElement.)
Public property | ContextMenu | (Inherited from WpfTestElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FlowDirection | (Inherited from WpfTestElement.)
Public property | Focusable | (Inherited from WpfTestElement.)
Public property | ForceCursor | (Inherited from WpfTestElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from WpfTestElement.)
Public property | IsEnabled | (Inherited from WpfTestElement.)
Public property | IsFocused | (Inherited from WpfTestElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsKeyboardFocused | (Inherited from WpfTestElement.)
Public property | IsKeyboardFocusWithin | (Inherited from WpfTestElement.)
Public property | IsMouseCaptured | (Inherited from WpfTestElement.)
Public property | IsMouseCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsMouseDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsMouseOver | (Inherited from WpfTestElement.)
Public property | IsStylusCaptured | (Inherited from WpfTestElement.)
Public property | IsStylusCaptureWithin | (Inherited from WpfTestElement.)
Public property | IsStylusDirectlyOver | (Inherited from WpfTestElement.)
Public property | IsStylusOver | (Inherited from WpfTestElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from WpfTestElement.)
Public property | ItemHeight |
Public property | ItemWidth |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | OverridesDefaultStyle | (Inherited from WpfTestElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | (Inherited from WpfTestElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..ItemHeight Property
WrapPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WrapPanel.ItemHeight"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ItemHeight { get; set; }
Visual Basic
Public Property ItemHeight As Double
    Get
    Set
Visual C++
public:
property double ItemHeight {
    double get ();
    void set (double value);
}

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ItemWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..ItemWidth Property
WrapPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WrapPanel.ItemWidth"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ItemWidth { get; set; }
Visual Basic
Public Property ItemWidth As Double
    Get
    Set
Visual C++
public:
property double ItemWidth {
    double get ();
    void set (double value);
}

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


Orientation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WrapPanel..::..Orientation Property
WrapPanel Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Controls.Xaml.Wpf.WrapPanel.Orientation"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic
Public Property Orientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation Orientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

WrapPanel Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WriteableBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap Members
WriteableBitmap Class Constructors Methods Properties See Also Send Feedback

The WriteableBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | WriteableBitmap | Initializes a new instance of the WriteableBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WriteableBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap Constructor
WriteableBitmap Class See Also Send Feedback
Initializes a new instance of the WriteableBitmap class

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WriteableBitmap()
Visual Basic
Public Sub New
Visual C++
public:
WriteableBitmap()

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WriteableBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap Methods
WriteableBitmap Class See Also Send Feedback

The WriteableBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap..::..GetProperty Method
WriteableBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WriteableBitmap Class
WriteableBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap..::..GetRealType Method
WriteableBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.WriteableBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Controls.Xaml.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Controls.Xaml.Wpf.WriteableBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap..::..InvokeMethod Method
WriteableBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WriteableBitmap Class
WriteableBitmap Members
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


WriteableBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap Properties
WriteableBitmap Class See Also Send Feedback

The WriteableBitmap type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Controls.Xaml.Wpf Namespace


ArtOfTest.WebAii.Core Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Core Namespace
Send Feedback
Namespace for the core WebAii framework functionality.

Classes

Class | Description
Public class Actions
Generic action support for all browser types.
Public class Browser
Class represents a browser instance managed by the Manager. This object exposes all the browser specific information and methods to automate the underlying browser that this instance represents.
Public class BrowserConfigurationException
Thrown when invalid configuration operation is performed.
Public class Desktop
Class representing the desktop input devices. Mouse and Keyboard.
Public class ElementFinder
Provides infrastructure for accessing elements defined by FindParamAttribute on test methods and classes. Replaces the Find.Elements dictionary which has been obsoleted.
Public class | EnumExtensions
Public class Find
Class provides quick search routines for finding an element(s) within a document.
Public class FrameInfo
Information regarding a specific frame
Public class FramesCollection
Collection of frames (Browser objects)
Public class HtmlFindClause
An Html specific find clause.
Public class HtmlFindExpression
An Html find expression. This expression replaced FindParams that are being deprecated.
Public class Log
Log support for the framework and test cases.
Public class Manager
This class manages the life spans and instances of all browser objects in the framework. It also manages the communication pipeline between the framework and all browsers.
Public class MappingsCollection
A general purpose collection
Public class Settings
Class representing the settings to be used when initializing the framework.
Public class | Settings..::..WebSettings
Public class | Settings..::..WpfSettings
Public class SettingsConfigSectionHandler
Settings object config section handler. Use this object to read a Settings config section in a .config file.

Examples

CopyC#
You can persist the settings for your application/test cases in a config file.

The following is a sample config file that holds certain settings. Any settings
not specified in this section, their values will be set to the system defaults:

<?xml version="1.0" encoding="utf-8" ?>
   <configuration>
       <configSections>
           <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii"/>
       </configSections>

   <WebAii.Settings
       defaultBrowser="InternetExplorer"
       logLocation="D:\Log\"
       executionTimeout="30000"
       clientReadyTimeout="20000"
       localWebServer="None";
       webAppPhysicalPath="c:\Inetpub\wwwroot\MyApplication"
       enableScriptLogging="false"
       queryEventLogErrorsOnExit="false"
       enableUILessRequestViewing="false"
       baseUrl="http://www.testsite.com/"
       executionDelay="0"
       annotateExecution="false"
       annotationMode="All"
       logAnnotations="false"
       simulatedMouseMoveSpeed="0.3f"
       waitCheckInterval="500"
       aspNetDevServerPort="-1"
       createLogFile="true"
       killBrowserProcessOnClose="false"
       recycleBrowser="false"
       useHttpProxy="false"
       enableSilverlight="false"
       xMultiMgr="false"
       silverlightConnectTimeout="30000"
       elementWaitTimeout="10000"
   />

   </configuration>

In your code, you can get these settings by using the SettingsConfigSectionHandler like this:

SettingsConfigSectionHandler settingsSection =
            (SettingsConfigSectionHandler)ConfigurationManager.GetSection("WebAii.Settings");
Settings mySettings = new Settings(settingsSection);

You can then use mySettings to pass in to the Manager constructor.
Public class TreeBuilder Obsolete.
This class builds the a strongly-typed markup elements tree.
Public class | WebSettingsConfigSectionHandler

Delegates

 | Delegate | Description
Public delegate | Manager..::..ActiveBrowserChangedHandler |

Enumerations

 | Enumeration | Description
Public enumeration | AnnotationMode | The different annotation modes
Public enumeration | BrowserCacheType | The different common categories of browser caching.
Public enumeration | BrowserConfigurationStatus | Show configuration status foa particular browser.
Public enumeration | BrowserExecutionType | The browser execution type. (i.e. firefox, internet explorer ...etc). The real browser type users can choose from.
Public enumeration | BrowserType | The browser type. (i.e. firefox, internet explorer ...etc).
Public enumeration | ElementSyncMethod | The different type of element-dom synchronization supported by the framework and the SyncManager.
Public enumeration | FindReferenceType | Defines which reference type the Find object is using.
Public enumeration | HtmlSearchType | Different types of supported find expressions.
Public enumeration | LocalWebServerType | Type of local web servers available for tests.
Public enumeration | LogType | The types of logging available in WebAii.
Public enumeration | MouseClickType | The different types of mouse events to perform.
Public enumeration | MouseWheelTurnDirection | The mouse wheel turn directions.
Public enumeration | ScriptEventType | Type of script events that can be invoked on an html element.
Public enumeration | ScrollToVisibleType | Used to configure what the default scroll to visible behavior is.
Public enumeration | UnexpectedDialogAction | Specifies the action that the DialogMonitor should take when it encounters unexpected dialogs


Actions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions Members
Actions Class Methods Properties See Also Send Feedback

The Actions type exposes the following members.

Methods

 | Name | Description
Public method | AnnotateElement | Visually annotates an element on the browser surface.
Public method | AnnotateMessage | Visually annotate a message on the browser surface.
Public method | Check | Sets the a checkbox or a radio button to a specific checked state.
Public method | Click | Perform a click on the target element.
Protected method | DoSelectDropDown | Performs the select drop down action.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComputedStyle | Get the computed style for this element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvokeEvent | Invoke an event on the target element.
Public method | InvokeScript(String) | Invokes a javascript function. This function performs a javascript eval() on the callString and returns and values from that call (if any).
Public method | InvokeScript<(Of <<'(T>)>>)(String) | Invokes a javascript function and then uses the System.Web.Extensions.Serialization.JavaScriptSeralizer to deserialize the returned JSON string from the function call to the object type T
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop.
Public method | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view.
Public method | ScrollToVisible(Element, ScrollToVisibleType, Rectangle) | Ensures that a specified portion of an element is visible in the browser. Scrolls the whole element into view if possible, otherwise as much of the specified portion as possible.
Public method | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index.
Public method | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text.
Public method | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true).
Public method | SetText(Control, String) | Set the text of an input or content editable control.
Public method | SetText(Element, String) | Set the text of a textbox or textarea.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateTargetElement | Validates the target element.
Public method | WaitForElement(FindParam, Int32) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(array<FindParam>[]()[][], Int32) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(FindParam, Int32, Boolean) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(array<FindParam>[]()[][], Int32, Boolean) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM.
Public method | WaitForElement(array<FindParam>[]()[][], TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM.
Public method | WaitForElements(Int32, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.
Public method | WaitForElements(Int32, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.
Public method | WaitForElements(Int32, TestRegion, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.

Properties

 | Name | Description
Protected property | Browser | Gets the Browser object associated with this instance of the actions object.
Public property | WaitCheckInterval | The Settings.WaitCheckInterval value. You can get/set it here too.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


Actions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions Methods
Actions Class See Also Send Feedback

The Actions type exposes the following members.

Methods

 | Name | Description
Public method | AnnotateElement | Visually annotates an element on the browser surface.
Public method | AnnotateMessage | Visually annotate a message on the browser surface.
Public method | Check | Sets the a checkbox or a radio button to a specific checked state.
Public method | Click | Perform a click on the target element.
Protected method | DoSelectDropDown | Performs the select drop down action.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetComputedStyle | Get the computed style for this element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InvokeEvent | Invoke an event on the target element.
Public method | InvokeScript(String) | Invokes a javascript function. This function performs a javascript eval() on the callString and returns and values from that call (if any).
Public method | InvokeScript<(Of <<'(T>)>>)(String) | Invokes a javascript function and then uses the System.Web.Extensions.Serialization.JavaScriptSeralizer to deserialize the returned JSON string from the function call to the object type T
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop.
Public method | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view.
Public method | ScrollToVisible(Element, ScrollToVisibleType, Rectangle) | Ensures that a specified portion of an element is visible in the browser. Scrolls the whole element into view if possible, otherwise as much of the specified portion as possible.
Public method | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index.
Public method | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text.
Public method | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true).
Public method | SetText(Control, String) | Set the text of an input or content editable control.
Public method | SetText(Element, String) | Set the text of a textbox or textarea.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | ValidateTargetElement | Validates the target element.
Public method | WaitForElement(FindParam, Int32) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(array<FindParam>[]()[][], Int32) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(FindParam, Int32, Boolean) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(array<FindParam>[]()[][], Int32, Boolean) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM.
Public method | WaitForElement(array<FindParam>[]()[][], TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM.
Public method | WaitForElements(Int32, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.
Public method | WaitForElements(Int32, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.
Public method | WaitForElements(Int32, TestRegion, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


AnnotateElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..AnnotateElement Method
Actions Class See Also Send Feedback
Visually annotates an element on the browser surface.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void AnnotateElement(
    Element targetElement,
    string message
)
Visual Basic
Public Overridable Sub AnnotateElement ( _
    targetElement As Element, _
    message As String _
)
Visual C++
public:
virtual void AnnotateElement(
    Element^ targetElement,
    String^ message
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element to annotate.
message
Type: System..::..String
The message to include.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


AnnotateMessage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..AnnotateMessage Method
Actions Class See Also Send Feedback
Visually annotate a message on the browser surface.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void AnnotateMessage(
    string message
)
Visual Basic
Public Overridable Sub AnnotateMessage ( _
    message As String _
)
Visual C++
public:
virtual void AnnotateMessage(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..Check Method
Actions Class See Also Send Feedback
Sets the a checkbox or a radio button to a specific checked state.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Check(
    Element targetElement,
    bool checkedState
)
Visual Basic
Public Overridable Sub Check ( _
    targetElement As Element, _
    checkedState As Boolean _
)
Visual C++
public:
virtual void Check(
    Element^ targetElement,
    bool checkedState
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
checkedState
Type: System..::..Boolean
True: to set the target to checked, False to set it to unchecked.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..Click Method
Actions Class See Also Send Feedback
Perform a click on the target element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Click(
    Element targetElement
)
Visual Basic
Public Overridable Sub Click ( _
    targetElement As Element _
)
Visual C++
public:
virtual void Click(
    Element^ targetElement
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


DoSelectDropDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..DoSelectDropDown Method
Actions Class See Also Send Feedback
Performs the select drop down action.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void DoSelectDropDown(
    Element targetElement,
    string data
)
Visual Basic
Protected Overridable Sub DoSelectDropDown ( _
    targetElement As Element, _
    data As String _
)
Visual C++
protected:
virtual void DoSelectDropDown(
    Element^ targetElement,
    String^ data
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
data
Type: System..::..String
The data to pass to the browser that provides information on how to do the select.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


GetComputedStyle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..GetComputedStyle Method
Actions Class See Also Send Feedback
Get the computed style for this element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract string GetComputedStyle(
    Element targetElement,
    string style
)
Visual Basic
Public MustOverride Function GetComputedStyle ( _
    targetElement As Element, _
    style As String _
) As String
Visual C++
public:
virtual String^ GetComputedStyle(
    Element^ targetElement,
    String^ style
) abstract

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
style
Type: System..::..String
The style to get.

Return Value

The string value of the style.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


InvokeEvent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..InvokeEvent Method
Actions Class See Also Send Feedback
Invoke an event on the target element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void InvokeEvent(
    Element targetElement,
    ScriptEventType eventType
)
Visual Basic
Public Overridable Sub InvokeEvent ( _
    targetElement As Element, _
    eventType As ScriptEventType _
)
Visual C++
public:
virtual void InvokeEvent(
    Element^ targetElement,
    ScriptEventType eventType
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
eventType
Type: ArtOfTest.WebAii.Core..::..ScriptEventType
Event type.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


InvokeScript Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..InvokeScript Method
Actions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeScript<(Of <<'(T>)>>)(String) | Invokes a javascript function and then uses the System.Web.Extensions.Serialization.JavaScriptSeralizer to deserialize the returned JSON string from the function call to the object type T
Public method | InvokeScript(String) | Invokes a javascript function. This function performs a javascript eval() on the callString and returns and values from that call (if any).

See Also

Actions Class
Actions Members
ArtOfTest.WebAii.Core Namespace


InvokeScript(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..InvokeScript<(Of <(<'T>)>)> Method (String)
Actions Class Example See Also Send Feedback
Invokes a javascript function and then uses the System.Web.Extensions.Serialization.JavaScriptSeralizer to deserialize the returned JSON string from the function call to the object type T

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T InvokeScript<T>(
    string script
)
Visual Basic
Public Overridable Function InvokeScript(Of T) ( _
    script As String _
) As T
Visual C++
public:
generic<typename T>
virtual T InvokeScript(
    String^ script
)

Parameters

script
Type: System..::..String
The call/script to invoke.

Type Parameters

T
The object type to deserialize the JSON string to.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Actions.InvokeScript``1(System.String)"]

Examples

string retValue = InvokeScript("myfunctioncall(""hi"",myvar);");

Exceptions

Exception | Condition
 | InvalidDataContractException: T != JsonObject and T does not have a valid data contract

See Also

Actions Class
InvokeScript Overload
ArtOfTest.WebAii.Core Namespace


InvokeScript Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..InvokeScript Method (String)
Actions Class Example See Also Send Feedback
Invokes a javascript function. This function performs a javascript eval() on the callString and returns and values from that call (if any).

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string InvokeScript(
    string script
)
Visual Basic
Public Overridable Function InvokeScript ( _
    script As String _
) As String
Visual C++
public:
virtual String^ InvokeScript(
    String^ script
)

Parameters

script
Type: System..::..String
The call/script to invoke.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Actions.InvokeScript(System.String)"]

Examples

string retValue = InvokeScript("myfunctioncall('hi', myvar);");

See Also

Actions Class
InvokeScript Overload
ArtOfTest.WebAii.Core Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..ScrollToVisible Method
Actions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible(Element) | Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop.
Public method | ScrollToVisible(Element, ScrollToVisibleType) | Ensures that an item is visible in the browser. Scrolls it into view.
Public method | ScrollToVisible(Element, ScrollToVisibleType, Rectangle) | Ensures that a specified portion of an element is visible in the browser. Scrolls the whole element into view if possible, otherwise as much of the specified portion as possible.

See Also

Actions Class
Actions Members
ArtOfTest.WebAii.Core Namespace


ScrollToVisible Method (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..ScrollToVisible Method (Element)
Actions Class See Also Send Feedback
Ensures that an item is visible in the browser. Scrolls it into view. Uses the ElementTopAtWindowTop.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ScrollToVisible(
    Element targetElement
)
Visual Basic
Public Overridable Sub ScrollToVisible ( _
    targetElement As Element _
)
Visual C++
public:
virtual void ScrollToVisible(
    Element^ targetElement
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.

See Also

Actions Class
ScrollToVisible Overload
ArtOfTest.WebAii.Core Namespace


ScrollToVisible Method (Element, ScrollToVisibleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..ScrollToVisible Method (Element, ScrollToVisibleType)
Actions Class See Also Send Feedback
Ensures that an item is visible in the browser. Scrolls it into view.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ScrollToVisible(
    Element targetElement,
    ScrollToVisibleType scrollType
)
Visual Basic
Public Overridable Sub ScrollToVisible ( _
    targetElement As Element, _
    scrollType As ScrollToVisibleType _
)
Visual C++
public:
virtual void ScrollToVisible(
    Element^ targetElement,
    ScrollToVisibleType scrollType
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
scrollType
Type: ArtOfTest.WebAii.Core..::..ScrollToVisibleType
The scrolling into view type.

See Also

Actions Class
ScrollToVisible Overload
ArtOfTest.WebAii.Core Namespace


ScrollToVisible Method (Element, ScrollToVisibleType, Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..ScrollToVisible Method (Element, ScrollToVisibleType, Rectangle)
Actions Class See Also Send Feedback
Ensures that a specified portion of an element is visible in the browser. Scrolls the whole element into view if possible, otherwise as much of the specified portion as possible.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ScrollToVisible(
    Element element,
    ScrollToVisibleType scrollType,
    Rectangle rectangle
)
Visual Basic
Public Overridable Sub ScrollToVisible ( _
    element As Element, _
    scrollType As ScrollToVisibleType, _
    rectangle As Rectangle _
)
Visual C++
public:
virtual void ScrollToVisible(
    Element^ element,
    ScrollToVisibleType scrollType,
    Rectangle rectangle
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element
scrollType
Type: ArtOfTest.WebAii.Core..::..ScrollToVisibleType
Whether to align the element or portion with the top of the browser window or the bottom.
rectangle
Type: System.Drawing..::..Rectangle
The portion of the element which we are ensuring the visibility of.

See Also

Actions Class
ScrollToVisible Overload
ArtOfTest.WebAii.Core Namespace


SelectDropDown Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..SelectDropDown Method
Actions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectDropDown(Element, Int32) | Selects a drop down item from the drop down list using its index.
Public method | SelectDropDown(Element, String) | Selects a drop down item from the drop down list using the item's text.
Public method | SelectDropDown(Element, String, Boolean) | Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true).

See Also

Actions Class
Actions Members
ArtOfTest.WebAii.Core Namespace


SelectDropDown Method (Element, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..SelectDropDown Method (Element, Int32)
Actions Class See Also Send Feedback
Selects a drop down item from the drop down list using its index.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SelectDropDown(
    Element targetElement,
    int itemIndex
)
Visual Basic
Public Overridable Sub SelectDropDown ( _
    targetElement As Element, _
    itemIndex As Integer _
)
Visual C++
public:
virtual void SelectDropDown(
    Element^ targetElement,
    int itemIndex
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
itemIndex
Type: System..::..Int32
The selected item index.

See Also

Actions Class
SelectDropDown Overload
ArtOfTest.WebAii.Core Namespace


SelectDropDown Method (Element, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..SelectDropDown Method (Element, String)
Actions Class See Also Send Feedback
Selects a drop down item from the drop down list using the item's text.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SelectDropDown(
    Element targetElement,
    string itemText
)
Visual Basic
Public Overridable Sub SelectDropDown ( _
    targetElement As Element, _
    itemText As String _
)
Visual C++
public:
virtual void SelectDropDown(
    Element^ targetElement,
    String^ itemText
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
itemText
Type: System..::..String
The text of the item to select.

Remarks

This function performs a case-insensitive search for the itemText in the list of the drop down items.

See Also

Actions Class
SelectDropDown Overload
ArtOfTest.WebAii.Core Namespace


SelectDropDown Method (Element, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..SelectDropDown Method (Element, String, Boolean)
Actions Class See Also Send Feedback
Selects a drop down item from the drop down list using the item's text or the items option value (if useItemValue = true).

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SelectDropDown(
    Element targetElement,
    string text,
    bool useValue
)
Visual Basic
Public Overridable Sub SelectDropDown ( _
    targetElement As Element, _
    text As String, _
    useValue As Boolean _
)
Visual C++
public:
virtual void SelectDropDown(
    Element^ targetElement,
    String^ text,
    bool useValue
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
text
Type: System..::..String
The text of the item to select.
useValue
Type: System..::..Boolean
If true, the text is the value of the item not it's textual representation.

Remarks

This function performs a case-insensitive search for the itemText in the list of the drop down items.

See Also

Actions Class
SelectDropDown Overload
ArtOfTest.WebAii.Core Namespace


SetText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..SetText Method
Actions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetText(Control, String) | Set the text of an input or content editable control.
Public method | SetText(Element, String) | Set the text of a textbox or textarea.

See Also

Actions Class
Actions Members
ArtOfTest.WebAii.Core Namespace


SetText Method (Control, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..SetText Method (Control, String)
Actions Class See Also Send Feedback
Set the text of an input or content editable control.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SetText(
    Control targetControl,
    string text
)
Visual Basic
Public Overridable Sub SetText ( _
    targetControl As Control, _
    text As String _
)
Visual C++
public:
virtual void SetText(
    Control^ targetControl,
    String^ text
)

Parameters

targetControl
Type: ArtOfTest.WebAii.Controls..::..Control
The target control.
text
Type: System..::..String
The text to set

See Also

Actions Class
SetText Overload
ArtOfTest.WebAii.Core Namespace


SetText Method (Element, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..SetText Method (Element, String)
Actions Class See Also Send Feedback
Set the text of a textbox or textarea.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SetText(
    Element targetElement,
    string text
)
Visual Basic
Public Overridable Sub SetText ( _
    targetElement As Element, _
    text As String _
)
Visual C++
public:
virtual void SetText(
    Element^ targetElement,
    String^ text
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element.
text
Type: System..::..String
The text to set

See Also

Actions Class
SetText Overload
ArtOfTest.WebAii.Core Namespace


ValidateTargetElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..ValidateTargetElement Method
Actions Class See Also Send Feedback
Validates the target element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void ValidateTargetElement(
    Element targetElement
)
Visual Basic
Protected Overridable Sub ValidateTargetElement ( _
    targetElement As Element _
)
Visual C++
protected:
virtual void ValidateTargetElement(
    Element^ targetElement
)

Parameters

targetElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The target element to validate.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


WaitForElement Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElement Method
Actions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForElement(FindParam, Int32) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(array<FindParam>[]()[][], Int32) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(FindParam, Int32, Boolean) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(array<FindParam>[]()[][], Int32, Boolean) | Obsolete. Wait until an element is present in the DOM
Public method | WaitForElement(FindParam, TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM.
Public method | WaitForElement(array<FindParam>[]()[][], TestRegion, Int32, Boolean) | Obsolete. Wait until an element within a region is present in the DOM.

See Also

Actions Class
Actions Members
ArtOfTest.WebAii.Core Namespace


WaitForElement Method (FindParam, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElement Method (FindParam, Int32)
Actions Class See Also Send Feedback
Wait until an element is present in the DOM

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElement(
    FindParam param,
    int waitTimeout
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElement ( _
    param As FindParam, _
    waitTimeout As Integer _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElement(
    FindParam^ param,
    int waitTimeout
)

Parameters

param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam that specifies how to search for the element.
waitTimeout
Type: System..::..Int32
The timeout to wait for the element to be present.

See Also

Actions Class
WaitForElement Overload
ArtOfTest.WebAii.Core Namespace


WaitForElement Method (FindParam[], Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElement Method (array<FindParam>[]()[][], Int32)
Actions Class See Also Send Feedback
Wait until an element is present in the DOM

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElement(
    FindParam[] chainedParams,
    int waitTimeout
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElement ( _
    chainedParams As FindParam(), _
    waitTimeout As Integer _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElement(
    array<FindParam^>^ chainedParams,
    int waitTimeout
)

Parameters

chainedParams
Type: array< ArtOfTest.WebAii.ObjectModel..::..FindParam >[]()[][]
The chained element FindParams.
waitTimeout
Type: System..::..Int32
The timeout to wait for the element to be present.

See Also

Actions Class
WaitForElement Overload
ArtOfTest.WebAii.Core Namespace


WaitForElement Method (FindParam, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElement Method (FindParam, Int32, Boolean)
Actions Class See Also Send Feedback
Wait until an element is present in the DOM

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElement(
    FindParam param,
    int waitTimeout,
    bool invertCondition
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElement ( _
    param As FindParam, _
    waitTimeout As Integer, _
    invertCondition As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElement(
    FindParam^ param,
    int waitTimeout,
    bool invertCondition
)

Parameters

param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam that specifies how to search for the element.
waitTimeout
Type: System..::..Int32
The timeout to wait for the element to be present.
invertCondition
Type: System..::..Boolean
True/False whether to invert the condition defined by the FindParam.

See Also

Actions Class
WaitForElement Overload
ArtOfTest.WebAii.Core Namespace


WaitForElement Method (FindParam[], Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElement Method (array<FindParam>[]()[][], Int32, Boolean)
Actions Class See Also Send Feedback
Wait until an element is present in the DOM

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElement(
    FindParam[] chainedParams,
    int waitTimeout,
    bool invertCondition
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElement ( _
    chainedParams As FindParam(), _
    waitTimeout As Integer, _
    invertCondition As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElement(
    array<FindParam^>^ chainedParams,
    int waitTimeout,
    bool invertCondition
)

Parameters

chainedParams
Type: array< ArtOfTest.WebAii.ObjectModel..::..FindParam >[]()[][]
The chained element FindParams.
waitTimeout
Type: System..::..Int32
The timeout to wait for the element to be present.
invertCondition
Type: System..::..Boolean
True/False whether to invert the condition defined by the FindParam.

See Also

Actions Class
WaitForElement Overload
ArtOfTest.WebAii.Core Namespace


WaitForElement Method (FindParam, TestRegion, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElement Method (FindParam, TestRegion, Int32, Boolean)
Actions Class See Also Send Feedback
Wait until an element within a region is present in the DOM.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElement(
    FindParam param,
    TestRegion region,
    int waitTimeout,
    bool invertCondition
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElement ( _
    param As FindParam, _
    region As TestRegion, _
    waitTimeout As Integer, _
    invertCondition As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElement(
    FindParam^ param,
    TestRegion^ region,
    int waitTimeout,
    bool invertCondition
)

Parameters

param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindPara of the target in reference to the region.
region
Type: ArtOfTest.WebAii.ObjectModel..::..TestRegion
The test region to use to identify the target element.
waitTimeout
Type: System..::..Int32
The timeout to wait for the element to be present.
invertCondition
Type: System..::..Boolean
True/False whether to invert the condition defined by the FindParam.

See Also

Actions Class
WaitForElement Overload
ArtOfTest.WebAii.Core Namespace


WaitForElement Method (FindParam[], TestRegion, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElement Method (array<FindParam>[]()[][], TestRegion, Int32, Boolean)
Actions Class See Also Send Feedback
Wait until an element within a region is present in the DOM.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElement(
    FindParam[] chainedParams,
    TestRegion region,
    int waitTimeout,
    bool invertCondition
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElement ( _
    chainedParams As FindParam(), _
    region As TestRegion, _
    waitTimeout As Integer, _
    invertCondition As Boolean _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElement(
    array<FindParam^>^ chainedParams,
    TestRegion^ region,
    int waitTimeout,
    bool invertCondition
)

Parameters

chainedParams
Type: array< ArtOfTest.WebAii.ObjectModel..::..FindParam >[]()[][]
The chained element FindParams.
region
Type: ArtOfTest.WebAii.ObjectModel..::..TestRegion
The test region to use to identify the target element.
waitTimeout
Type: System..::..Int32
The timeout to wait for the element to be present.
invertCondition
Type: System..::..Boolean
True/False whether to invert the condition defined by the FindParam.

See Also

Actions Class
WaitForElement Overload
ArtOfTest.WebAii.Core Namespace


WaitForElements Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElements Method
Actions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForElements(Int32, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.
Public method | WaitForElements(Int32, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.
Public method | WaitForElements(Int32, TestRegion, Boolean, array<FindParam>[]()[][]) | Obsolete. Wait until all elements have been found. No chaining is used.

See Also

Actions Class
Actions Members
ArtOfTest.WebAii.Core Namespace


WaitForElements Method (Int32, FindParam[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElements Method (Int32, array<FindParam>[]()[][])
Actions Class See Also Send Feedback
Wait until all elements have been found. No chaining is used.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElements(
    int waitTimeout,
    params FindParam[] paramsList
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElements ( _
    waitTimeout As Integer, _
    ParamArray paramsList As FindParam() _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElements(
    int waitTimeout,
    ... array<FindParam^>^ paramsList
)

Parameters

waitTimeout
Type: System..::..Int32
The timeout to wait for all to be found in milli-seconds.
paramsList
Type: array< ArtOfTest.WebAii.ObjectModel..::..FindParam >[]()[][]
The find parameters list of the elements to wait for.

See Also

Actions Class
WaitForElements Overload
ArtOfTest.WebAii.Core Namespace


WaitForElements Method (Int32, Boolean, FindParam[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElements Method (Int32, Boolean, array<FindParam>[]()[][])
Actions Class See Also Send Feedback
Wait until all elements have been found. No chaining is used.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElements(
    int waitTimeout,
    bool invertCondition,
    params FindParam[] paramsList
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElements ( _
    waitTimeout As Integer, _
    invertCondition As Boolean, _
    ParamArray paramsList As FindParam() _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElements(
    int waitTimeout,
    bool invertCondition,
    ... array<FindParam^>^ paramsList
)

Parameters

waitTimeout
Type: System..::..Int32
The timeout to wait for all to be found in milli-seconds.
invertCondition
Type: System..::..Boolean
True/False whether to invert the condition defined by the FindParam.
paramsList
Type: array< ArtOfTest.WebAii.ObjectModel..::..FindParam >[]()[][]
The find parameters list of the elements to wait for.

See Also

Actions Class
WaitForElements Overload
ArtOfTest.WebAii.Core Namespace


WaitForElements Method (Int32, TestRegion, Boolean, FindParam[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitForElements Method (Int32, TestRegion, Boolean, array<FindParam>[]()[][])
Actions Class See Also Send Feedback
Wait until all elements have been found. No chaining is used.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Browser.WaitForElement using a find expression")]
public virtual void WaitForElements(
    int waitTimeout,
    TestRegion region,
    bool invertCondition,
    params FindParam[] paramsList
)
Visual Basic
<ObsoleteAttribute("Use Browser.WaitForElement using a find expression")> _
Public Overridable Sub WaitForElements ( _
    waitTimeout As Integer, _
    region As TestRegion, _
    invertCondition As Boolean, _
    ParamArray paramsList As FindParam() _
)
Visual C++
[ObsoleteAttribute(L"Use Browser.WaitForElement using a find expression")]
public:
virtual void WaitForElements(
    int waitTimeout,
    TestRegion^ region,
    bool invertCondition,
    ... array<FindParam^>^ paramsList
)

Parameters

waitTimeout
Type: System..::..Int32
The timeout to wait for all to be found in milli-seconds.
region
Type: ArtOfTest.WebAii.ObjectModel..::..TestRegion
Test region to use a reference.
invertCondition
Type: System..::..Boolean
True/False whether to invert the condition defined by the FindParam.
paramsList
Type: array< ArtOfTest.WebAii.ObjectModel..::..FindParam >[]()[][]
The find parameters list of the elements to wait for.

See Also

Actions Class
WaitForElements Overload
ArtOfTest.WebAii.Core Namespace


Actions Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions Properties
Actions Class See Also Send Feedback

The Actions type exposes the following members.

Properties

 | Name | Description
Protected property | Browser | Gets the Browser object associated with this instance of the actions object.
Public property | WaitCheckInterval | The Settings.WaitCheckInterval value. You can get/set it here too.

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


Browser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..Browser Property
Actions Class See Also Send Feedback
Gets the Browser object associated with this instance of the actions object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected Browser Browser { get; }
Visual Basic
Protected ReadOnly Property Browser As Browser
    Get
Visual C++
protected:
property Browser^ Browser {
    Browser^ get ();
}

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


WaitCheckInterval Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Actions..::..WaitCheckInterval Property
Actions Class See Also Send Feedback
The Settings.WaitCheckInterval value. You can get/set it here too.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int WaitCheckInterval { get; set; }
Visual Basic
Public Property WaitCheckInterval As Integer
    Get
    Set
Visual C++
public:
property int WaitCheckInterval {
    int get ();
    void set (int value);
}

See Also

Actions Class
ArtOfTest.WebAii.Core Namespace


Browser Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser Members
Browser Class Methods Properties Events See Also Send Feedback

The Browser type exposes the following members.

Methods

 | Name | Description
Public method | Capture | Capture the image of this browser
Public method | ClearCache | Clear the cache of a certain category.
Public method | Close()()()() | Closes a browser window.
Public method | Close(Int32) | Closes a browser window with a custom wait to close timeout.
Public method | ContainsPoint | True/False whether a specific point falls within this browser/frame rendering region
Public method | ContainsRectangle | True/False whether a specific rectangle falls within this browser/frame rendering region
Public method | ContainsText | True/False whether the 'text' is contained within the page currently loaded. Not case sensitive.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteCommand(BrowserCommand) | Executes a command against this browser instance.
Public method | ExecuteCommand(BrowserCommand, Boolean, Boolean) | Executes a command against this browser instance.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildHosts | Get all containing child hosts. For Browser, this will return a list of all Frames (if any) + any SilverlightApp instances
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Get the root element of the DomTree
Public method | GetSelectedText | Gets the text currently selected by the user in the browser window
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GoBack | Simulates a go back browser action.
Public method | GoForward | Simulates a go forward browser action.
Public method | IsReady | Gets whether the browser is ready or not.
Public method | LocateAllInHost | Locates all elements contained in the browser's DOM matching the specified find expression.
Public method | LocateInHost | Locate an element in the host using an expression.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateTo(String) | Navigate the browser to a specific url and then enable the script logging.
Public method | NavigateTo(Uri) | Navigate the browser to a specific url.
Public method | PrepareFrameForClosing | Used to disable the AutoRefreshDom and WaitUntilReady of a frame preparing it to be closed on next action and no longer polled by the framework.
Public method | Refresh | Simulates a browser Refresh.
Public method | RefreshDomTree | Force a referesh of the DOM tree from the current document.
Public method | ResizeContent(Rectangle) | Resize the browser window content to the specified window rectangle. This function will handle the padding between the outer browser window and the content window. If the new rectangle will not fit within the bounds of the screen, this method will try to approximate the requested size within the bounds of the screen.
Public method | ResizeContent(Int32, Int32, Int32, Int32) | Resize the browser window content to the specified window rectangle. This function will handle the padding between the outer browser window and the content window.
Public method | ScrollBy | Scroll this window by offset x horizontally and y vertically.
Public method | Stop | Simulate a stop navigation browser action.
Public method | ToggleFullScreen | Toggle the browser in and out of Full Screen (F11)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateBrowserOffset | Translates an offset from one browser to another. Useful because offset values recorded in Internet Explorer are typically two pixels different from offset values for the same relative point in other browsers.
Protected method | UpdateDomTree | Parse and update the DomTree
Public method | UpdateInterHostLinks |
Public method | WaitForAjax | Wait for any active AJAX requests to complete.
Public method | WaitForElement(Int32, array<String>[]()[][]) | Wait for an element to exist. If it exists, return the Element object, else will throw a Timeout Exception.
Public method | WaitForElement(HtmlFindExpression, Int32, Boolean) | Wait for an element to exist. If it exists, return the Element object, else will throw a Timeout Exception.
Public method | WaitForFrame(FrameInfo) | Wait for a frame to exist. Uses the Settings.ClientReadyTimeout as the timeout
Public method | WaitForFrame(FrameInfo, Int32) | Wait for a frame to exist.
Public method | WaitForUrl | Wait for a specific url to be set. This can be used to wait for browser redirects on certain sites.
Public method | WaitUntilReady | Waits for the browser until its ready

Extension Methods

 | Name | Description
Public Extension Method | GetSilverlightAppIndex | Finds the index into the SilverlightApp array of the specified plugin (Defined by SilverlightAppFinder.)
Public Extension Method | SilverlightApps | Returns an array of all Silverlight Applications on this page. (Defined by SilverlightAppFinder.)

Properties

 | Name | Description
Public property | Actions | Gets the Actions object that can be used to perform different actions against the loaded document in the browser.
Public property | Annotator | Gets the Annotator object associated with this browser.
Public property | AutoDomRefresh | Gets/Sets whether to automatically refresh the DOM tree after each browser command.
Public property | AutoWaitUntilReady | Gets/Sets whether to automatically wait until browser is ready after each browser command.
Public property | BrowserType | Gets the browser type (i.e. IE/FireFox ...etc)
Public property | ClientId | The unique ID for this browser that the manager identifies it with.
Public property | CommandTimeOut | Gets/Sets the max wait time in milliseconds that the browser will wait for a command to process before it times out.
Public property | ContentWindow | Gets the container window of the browser that contains the actual content of the page. (Excludes the browser toolbars, buttons ...etc.)
Public property | Cookies | Gets the cookies manager associated with this browser that allows you to retrieve, delete and add cookies.
Public property | CreationTime | The UTC time this instance was instantiated.
Public property | Desktop | Desktop object that draws its annotations in this browser
Public property | DomTree | Gets the DOM Tree representation of the currently loaded document.
Public property | Find | Gets the Find objects used to provide a rich set of methods to help identify elements in the Dom tree associated with this browser object.
Public property | FrameElement | Gets the Element object for the frame element represented by this Browser object, if this Browser represents a frame. If this Browser does not represent a frame, FrameElement is null.
Public property | FrameInfo | Gets the frame information if IsFrame = true else will return null. FrameInfo contains frame index and frame name.
Public property | Frames | List of child frames contained in this instance
Public property | FriendlyName | Get a friendly name for this browser instance.
Public property | IsConnected | Gets whether the browser is connected to manager of not.
Public property | IsFrame | Gets whether this instance represents a frame or not.
Public property | IsIEDialog | Gets whether this instance is an IE dialog (Modal/Modeless)
Public property | IsUILess | Whether this browser is UI less browser. (i.e. a raw http request/response browser)
Public property | Manager | The manager of this browser object.
Public property | NativeInstance | The native instance of this browser object (if available), otherwise null
Public property | PageTitle | Gets the page title if one exists. (text content of the 'title' tags)
Public property | QueryString | Gets a parsed name/value collection of the query string.
Public property | Regions | Gets a dictionary of all identified test regions in the currently loaded document.
Public property | StateHashCode | Get the state hash code.
Public property | TechnologyType | Get the technology type
Public property | UniqueId | Gets a unique id that identifies this browser instance.
Public property | Url | Gets the current page URL. This property is refreshed when calling RefreshDOMTree().
Public property | Version | The browser version for this browser type.
Public property | ViewSourceString | Gets the source of the page currently loaded in the browser. This is the string that the framework used to build the DOM.
Public property | Window | Gets the Win32 window object representing the actual browser window.

Events

 | Name | Description
Public event | AfterCommandExecuted | Event occurs after the command is executed and the response is available.
Public event | BeforeCommandExecuted | Event occurs before a command is pushed to the browser.
Public event | Closing | Event occurs when the browser is about to close. [Browser.Close()] is called.
Public event | DomRefreshed | Event occurs after the DomTree is rebuilt (either after a command is executed or when RefreshDom is called)

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Browser Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser Methods
Browser Class See Also Send Feedback

The Browser type exposes the following members.

Methods

 | Name | Description
Public method | Capture | Capture the image of this browser
Public method | ClearCache | Clear the cache of a certain category.
Public method | Close()()()() | Closes a browser window.
Public method | Close(Int32) | Closes a browser window with a custom wait to close timeout.
Public method | ContainsPoint | True/False whether a specific point falls within this browser/frame rendering region
Public method | ContainsRectangle | True/False whether a specific rectangle falls within this browser/frame rendering region
Public method | ContainsText | True/False whether the 'text' is contained within the page currently loaded. Not case sensitive.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteCommand(BrowserCommand) | Executes a command against this browser instance.
Public method | ExecuteCommand(BrowserCommand, Boolean, Boolean) | Executes a command against this browser instance.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetChildHosts | Get all containing child hosts. For Browser, this will return a list of all Frames (if any) + any SilverlightApp instances
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Get the root element of the DomTree
Public method | GetSelectedText | Gets the text currently selected by the user in the browser window
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GoBack | Simulates a go back browser action.
Public method | GoForward | Simulates a go forward browser action.
Public method | IsReady | Gets whether the browser is ready or not.
Public method | LocateAllInHost | Locates all elements contained in the browser's DOM matching the specified find expression.
Public method | LocateInHost | Locate an element in the host using an expression.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NavigateTo(String) | Navigate the browser to a specific url and then enable the script logging.
Public method | NavigateTo(Uri) | Navigate the browser to a specific url.
Public method | PrepareFrameForClosing | Used to disable the AutoRefreshDom and WaitUntilReady of a frame preparing it to be closed on next action and no longer polled by the framework.
Public method | Refresh | Simulates a browser Refresh.
Public method | RefreshDomTree | Force a referesh of the DOM tree from the current document.
Public method | ResizeContent(Rectangle) | Resize the browser window content to the specified window rectangle. This function will handle the padding between the outer browser window and the content window. If the new rectangle will not fit within the bounds of the screen, this method will try to approximate the requested size within the bounds of the screen.
Public method | ResizeContent(Int32, Int32, Int32, Int32) | Resize the browser window content to the specified window rectangle. This function will handle the padding between the outer browser window and the content window.
Public method | ScrollBy | Scroll this window by offset x horizontally and y vertically.
Public method | Stop | Simulate a stop navigation browser action.
Public method | ToggleFullScreen | Toggle the browser in and out of Full Screen (F11)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateBrowserOffset | Translates an offset from one browser to another. Useful because offset values recorded in Internet Explorer are typically two pixels different from offset values for the same relative point in other browsers.
Protected method | UpdateDomTree | Parse and update the DomTree
Public method | UpdateInterHostLinks |
Public method | WaitForAjax | Wait for any active AJAX requests to complete.
Public method | WaitForElement(Int32, array<String>[]()[][]) | Wait for an element to exist. If it exists, return the Element object, else will throw a Timeout Exception.
Public method | WaitForElement(HtmlFindExpression, Int32, Boolean) | Wait for an element to exist. If it exists, return the Element object, else will throw a Timeout Exception.
Public method | WaitForFrame(FrameInfo) | Wait for a frame to exist. Uses the Settings.ClientReadyTimeout as the timeout
Public method | WaitForFrame(FrameInfo, Int32) | Wait for a frame to exist.
Public method | WaitForUrl | Wait for a specific url to be set. This can be used to wait for browser redirects on certain sites.
Public method | WaitUntilReady | Waits for the browser until its ready

Extension Methods

 | Name | Description
Public Extension Method | GetSilverlightAppIndex | Finds the index into the SilverlightApp array of the specified plugin (Defined by SilverlightAppFinder.)
Public Extension Method | SilverlightApps | Returns an array of all Silverlight Applications on this page. (Defined by SilverlightAppFinder.)

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Capture Method
Browser Class See Also Send Feedback
Capture the image of this browser

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap Capture()
Visual Basic
Public Function Capture As Bitmap
Visual C++
public:
virtual Bitmap^ Capture() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Browser.Capture"]

Implements

IAutomationHost..::..Capture()()()()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ClearCache Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ClearCache Method
Browser Class See Also Send Feedback
Clear the cache of a certain category.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ClearCache(
    BrowserCacheType cacheType
)
Visual Basic
Public Sub ClearCache ( _
    cacheType As BrowserCacheType _
)
Visual C++
public:
void ClearCache(
    BrowserCacheType cacheType
)

Parameters

cacheType
Type: ArtOfTest.WebAii.Core..::..BrowserCacheType
The cache category

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Close Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Close Method
Browser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Close()()()() | Closes a browser window.
Public method | Close(Int32) | Closes a browser window with a custom wait to close timeout.

See Also

Browser Class
Browser Members
ArtOfTest.WebAii.Core Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Close Method
Browser Class See Also Send Feedback
Closes a browser window.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Close()
Visual Basic
Public Overridable Sub Close
Visual C++
public:
virtual void Close()

Remarks

This function will disconnect the browser from the manager first and then close its window. It will also perform a wait until the browser window is no longer visible. The time out for the wait is the same as the ExecuteCommandTimeout.

See Also

Browser Class
Close Overload
ArtOfTest.WebAii.Core Namespace


Close Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Close Method (Int32)
Browser Class See Also Send Feedback
Closes a browser window with a custom wait to close timeout.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Close(
    int waitToCloseTimeout
)
Visual Basic
Public Overridable Sub Close ( _
    waitToCloseTimeout As Integer _
)
Visual C++
public:
virtual void Close(
    int waitToCloseTimeout
)

Parameters

waitToCloseTimeout
Type: System..::..Int32
The timeout in milliseconds to wait for the browser to close.

Remarks

This function will disconnect the browser from the manager first and then close its window. It will also perform a wait until the browser window is no longer visible. The time out for the wait is the same as the ExecuteCommandTimeout.

See Also

Browser Class
Close Overload
ArtOfTest.WebAii.Core Namespace


ContainsPoint Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ContainsPoint Method
Browser Class See Also Send Feedback
True/False whether a specific point falls within this browser/frame rendering region

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool ContainsPoint(
    Point point
)
Visual Basic
Public Overridable Function ContainsPoint ( _
    point As Point _
) As Boolean
Visual C++
public:
virtual bool ContainsPoint(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point
The point to check.

Return Value

True/False whether the point is within the browser window.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ContainsRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ContainsRectangle Method
Browser Class See Also Send Feedback
True/False whether a specific rectangle falls within this browser/frame rendering region

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool ContainsRectangle(
    Rectangle rectangle
)
Visual Basic
Public Overridable Function ContainsRectangle ( _
    rectangle As Rectangle _
) As Boolean
Visual C++
public:
virtual bool ContainsRectangle(
    Rectangle rectangle
)

Parameters

rectangle
Type: System.Drawing..::..Rectangle
The rectangle to check.

Return Value

True/False whether the rectangle is within the browser window.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ContainsText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ContainsText Method
Browser Class See Also Send Feedback
True/False whether the 'text' is contained within the page currently loaded. Not case sensitive.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool ContainsText(
    string text
)
Visual Basic
Public Overridable Function ContainsText ( _
    text As String _
) As Boolean
Visual C++
public:
virtual bool ContainsText(
    String^ text
)

Parameters

text
Type: System..::..String
The text string.

Return Value

True/False whether the text is contained.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ExecuteCommand Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ExecuteCommand Method
Browser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExecuteCommand(BrowserCommand) | Executes a command against this browser instance.
Public method | ExecuteCommand(BrowserCommand, Boolean, Boolean) | Executes a command against this browser instance.

See Also

Browser Class
Browser Members
ArtOfTest.WebAii.Core Namespace


ExecuteCommand Method ()

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ExecuteCommand Method ()
Browser Class See Also Send Feedback
Executes a command against this browser instance.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual BrowserCommand ExecuteCommand(
    BrowserCommand request
)
Visual Basic
Public Overridable Function ExecuteCommand ( _
    request As BrowserCommand _
) As BrowserCommand
Visual C++
public:
virtual BrowserCommand^ ExecuteCommand(
    BrowserCommand^ request
)

Parameters

request
Type: BrowserCommand

[Missing <param name="request"/> documentation for "M:ArtOfTest.WebAii.Core.Browser.ExecuteCommand(ArtOfTest.WebAii.Messaging.Process.BrowserCommand)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Browser.ExecuteCommand(ArtOfTest.WebAii.Messaging.Process.BrowserCommand)"]

Remarks

If the request requires a specific response data, then the callers of this function should check the BrowserCommand.Response property for any responses from the browser. This method uses the browser's AutoDOMRefresh and AutoWaitUntilReady values to configure whether the browser should refresh the DOM or wait until the browser is ready after the command is executed.

See Also

Browser Class
ExecuteCommand Overload
ArtOfTest.WebAii.Core Namespace


ExecuteCommand Method (, Boolean, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ExecuteCommand Method (, Boolean, Boolean)
Browser Class See Also Send Feedback
Executes a command against this browser instance.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual BrowserCommand ExecuteCommand(
    BrowserCommand request,
    bool performDomRefresh,
    bool waitUntilReady
)
Visual Basic
Public Overridable Function ExecuteCommand ( _
    request As BrowserCommand, _
    performDomRefresh As Boolean, _
    waitUntilReady As Boolean _
) As BrowserCommand
Visual C++
public:
virtual BrowserCommand^ ExecuteCommand(
    BrowserCommand^ request,
    bool performDomRefresh,
    bool waitUntilReady
)

Parameters

request
Type: BrowserCommand
The command request to perform.
performDomRefresh
Type: System..::..Boolean
True/False whether to reference the DOM after the command.
waitUntilReady
Type: System..::..Boolean
True/False whether to wait for the browser to be ready after the command.

Return Value

A response to the request.

Remarks

If the request requires a specific response data, then the callers of this function should check the BrowserCommand.Response property for any responses from the browser.

See Also

Browser Class
ExecuteCommand Overload
ArtOfTest.WebAii.Core Namespace


GetChildHosts Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..GetChildHosts Method
Browser Class See Also Send Feedback
Get all containing child hosts. For Browser, this will return a list of all Frames (if any) + any SilverlightApp instances

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IAutomationHost[] GetChildHosts()
Visual Basic
Public Function GetChildHosts As IAutomationHost()
Visual C++
public:
virtual array<IAutomationHost^>^ GetChildHosts() sealed

Return Value

The list of automation hosts contained in this browser instance

Implements

IAutomationHost..::..GetChildHosts()()()()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


GetHostRoot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..GetHostRoot Method
Browser Class See Also Send Feedback
Get the root element of the DomTree

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement GetHostRoot()
Visual Basic
Public Function GetHostRoot As ITargetElement
Visual C++
public:
virtual ITargetElement^ GetHostRoot() sealed

Return Value

The root element of the DOM tree.

Implements

IAutomationHost..::..GetHostRoot()()()()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


GetSelectedText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..GetSelectedText Method
Browser Class See Also Send Feedback
Gets the text currently selected by the user in the browser window

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string GetSelectedText()
Visual Basic
Public Overridable Function GetSelectedText As String
Visual C++
public:
virtual String^ GetSelectedText()

Return Value

The selected text

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


GoBack Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..GoBack Method
Browser Class See Also Send Feedback
Simulates a go back browser action.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void GoBack()
Visual Basic
Public Overridable Sub GoBack
Visual C++
public:
virtual void GoBack()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


GoForward Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..GoForward Method
Browser Class See Also Send Feedback
Simulates a go forward browser action.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void GoForward()
Visual Basic
Public Overridable Sub GoForward
Visual C++
public:
virtual void GoForward()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


IsReady Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..IsReady Method
Browser Class See Also Send Feedback
Gets whether the browser is ready or not.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsReady()
Visual Basic
Public Overridable Function IsReady As Boolean
Visual C++
public:
virtual bool IsReady()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Browser.IsReady"]

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


LocateAllInHost Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..LocateAllInHost Method
Browser Class See Also Send Feedback
Locates all elements contained in the browser's DOM matching the specified find expression.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<ITargetElement> LocateAllInHost(
    string[] expression
)
Visual Basic
Public Function LocateAllInHost ( _
    expression As String() _
) As IList(Of ITargetElement)
Visual C++
public:
virtual IList<ITargetElement^>^ LocateAllInHost(
    array<String^>^ expression
) sealed

Parameters

expression
Type: array< System..::..String >[]()[][]
Array of find expressions to use to locate the elements.

Return Value

A list of elements matching the find expression.

Implements

ISupportSearchHost..::..LocateAllInHost(array<String>[]()[][])

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


LocateInHost Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..LocateInHost Method
Browser Class See Also Send Feedback
Locate an element in the host using an expression.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement LocateInHost(
    string[] expression
)
Visual Basic
Public Function LocateInHost ( _
    expression As String() _
) As ITargetElement
Visual C++
public:
virtual ITargetElement^ LocateInHost(
    array<String^>^ expression
) sealed

Parameters

expression
Type: array< System..::..String >[]()[][]
Array of find expressions to use to locate the target element.

Return Value

The target element if found. 'null' if not found.

Implements

ISupportSearchHost..::..LocateInHost(array<String>[]()[][])

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


NavigateTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..NavigateTo Method
Browser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NavigateTo(String) | Navigate the browser to a specific url and then enable the script logging.
Public method | NavigateTo(Uri) | Navigate the browser to a specific url.

See Also

Browser Class
Browser Members
ArtOfTest.WebAii.Core Namespace


NavigateTo Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..NavigateTo Method (String)
Browser Class See Also Send Feedback
Navigate the browser to a specific url and then enable the script logging.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void NavigateTo(
    string url
)
Visual Basic
Public Overridable Sub NavigateTo ( _
    url As String _
)
Visual C++
public:
virtual void NavigateTo(
    String^ url
)

Parameters

url
Type: System..::..String
The url to navigate to.

See Also

Browser Class
NavigateTo Overload
ArtOfTest.WebAii.Core Namespace


NavigateTo Method (Uri)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..NavigateTo Method (Uri)
Browser Class See Also Send Feedback
Navigate the browser to a specific url.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void NavigateTo(
    Uri uri
)
Visual Basic
Public Overridable Sub NavigateTo ( _
    uri As Uri _
)
Visual C++
public:
virtual void NavigateTo(
    Uri^ uri
)

Parameters

uri
Type: System..::..Uri
The uri object that describes the Url.

See Also

Browser Class
NavigateTo Overload
ArtOfTest.WebAii.Core Namespace


PrepareFrameForClosing Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..PrepareFrameForClosing Method
Browser Class See Also Send Feedback
Used to disable the AutoRefreshDom and WaitUntilReady of a frame preparing it to be closed on next action and no longer polled by the framework.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void PrepareFrameForClosing()
Visual Basic
Public Overridable Sub PrepareFrameForClosing
Visual C++
public:
virtual void PrepareFrameForClosing()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Refresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Refresh Method
Browser Class See Also Send Feedback
Simulates a browser Refresh.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Refresh()
Visual Basic
Public Overridable Sub Refresh
Visual C++
public:
virtual void Refresh()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


RefreshDomTree Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..RefreshDomTree Method
Browser Class See Also Send Feedback
Force a referesh of the DOM tree from the current document.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool RefreshDomTree()
Visual Basic
Public Overridable Function RefreshDomTree As Boolean
Visual C++
public:
virtual bool RefreshDomTree()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Browser.RefreshDomTree"]

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ResizeContent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ResizeContent Method
Browser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResizeContent(Rectangle) | Resize the browser window content to the specified window rectangle. This function will handle the padding between the outer browser window and the content window. If the new rectangle will not fit within the bounds of the screen, this method will try to approximate the requested size within the bounds of the screen.
Public method | ResizeContent(Int32, Int32, Int32, Int32) | Resize the browser window content to the specified window rectangle. This function will handle the padding between the outer browser window and the content window.

See Also

Browser Class
Browser Members
ArtOfTest.WebAii.Core Namespace


ResizeContent Method (Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ResizeContent Method (Rectangle)
Browser Class See Also Send Feedback
Resize the browser window content to the specified window rectangle. This function will handle the padding between the outer browser window and the content window. If the new rectangle will not fit within the bounds of the screen, this method will try to approximate the requested size within the bounds of the screen.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ResizeContent(
    Rectangle rectangle
)
Visual Basic
Public Overridable Sub ResizeContent ( _
    rectangle As Rectangle _
)
Visual C++
public:
virtual void ResizeContent(
    Rectangle rectangle
)

Parameters

rectangle
Type: System.Drawing..::..Rectangle
The desired rectangle for the content window

See Also

Browser Class
ResizeContent Overload
ArtOfTest.WebAii.Core Namespace


ResizeContent Method (Int32, Int32, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ResizeContent Method (Int32, Int32, Int32, Int32)
Browser Class See Also Send Feedback
Resize the browser window content to the specified window rectangle. This function will handle the padding between the outer browser window and the content window.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ResizeContent(
    int x,
    int y,
    int width,
    int height
)
Visual Basic
Public Overridable Sub ResizeContent ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
virtual void ResizeContent(
    int x,
    int y,
    int width,
    int height
)

Parameters

x
Type: System..::..Int32
Desired x
y
Type: System..::..Int32
Desired y
width
Type: System..::..Int32
Desired width
height
Type: System..::..Int32
Desired height

See Also

Browser Class
ResizeContent Overload
ArtOfTest.WebAii.Core Namespace


ScrollBy Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ScrollBy Method
Browser Class See Also Send Feedback
Scroll this window by offset x horizontally and y vertically.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ScrollBy(
    int x,
    int y
)
Visual Basic
Public Overridable Sub ScrollBy ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
virtual void ScrollBy(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32
The x offset.(negative for scroll left)
y
Type: System..::..Int32
The y offset.(negative for scroll up)

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Stop Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Stop Method
Browser Class See Also Send Feedback
Simulate a stop navigation browser action.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Stop()
Visual Basic
Public Overridable Sub Stop
Visual C++
public:
virtual void Stop()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ToggleFullScreen Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ToggleFullScreen Method
Browser Class See Also Send Feedback
Toggle the browser in and out of Full Screen (F11)

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ToggleFullScreen()
Visual Basic
Public Overridable Sub ToggleFullScreen
Visual C++
public:
virtual void ToggleFullScreen()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


TranslateBrowserOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..TranslateBrowserOffset Method
Browser Class See Also Send Feedback
Translates an offset from one browser to another. Useful because offset values recorded in Internet Explorer are typically two pixels different from offset values for the same relative point in other browsers.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Point TranslateBrowserOffset(
    BrowserType sourceBrowser,
    BrowserType destinationBrowser,
    Point sourceOffset
)
Visual Basic
Public Shared Function TranslateBrowserOffset ( _
    sourceBrowser As BrowserType, _
    destinationBrowser As BrowserType, _
    sourceOffset As Point _
) As Point
Visual C++
public:
static Point TranslateBrowserOffset(
    BrowserType sourceBrowser,
    BrowserType destinationBrowser,
    Point sourceOffset
)

Parameters

sourceBrowser
Type: ArtOfTest.WebAii.Core..::..BrowserType
The BrowserType the offset was originally intended for
destinationBrowser
Type: ArtOfTest.WebAii.Core..::..BrowserType
The BrowserType to translate the offset to
sourceOffset
Type: System.Drawing..::..Point
The original offset value

Return Value

A translated offset value. The offset is translated two pixels left and up when translating from Internet Explorer to any other browser, and translated two pixels down and right when translating from any other browser to Internet Explorer.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


UpdateDomTree Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..UpdateDomTree Method
Browser Class See Also Send Feedback
Parse and update the DomTree

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual bool UpdateDomTree(
    string domString
)
Visual Basic
Protected Overridable Function UpdateDomTree ( _
    domString As String _
) As Boolean
Visual C++
protected:
virtual bool UpdateDomTree(
    String^ domString
)

Parameters

domString
Type: System..::..String

[Missing <param name="domString"/> documentation for "M:ArtOfTest.WebAii.Core.Browser.UpdateDomTree(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Browser.UpdateDomTree(System.String)"]

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


UpdateInterHostLinks Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..UpdateInterHostLinks Method
Browser Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Browser.UpdateInterHostLinks"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void UpdateInterHostLinks()
Visual Basic
Public Sub UpdateInterHostLinks
Visual C++
public:
virtual void UpdateInterHostLinks() sealed

Implements

IAutomationHost..::..UpdateInterHostLinks()()()()

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


WaitForAjax Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitForAjax Method
Browser Class See Also Send Feedback
Wait for any active AJAX requests to complete.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitForAjax(
    int timeout
)
Visual Basic
Public Sub WaitForAjax ( _
    timeout As Integer _
)
Visual C++
public:
void WaitForAjax(
    int timeout
)

Parameters

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Core.Browser.WaitForAjax(System.Int32)"]

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


WaitForElement Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitForElement Method
Browser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForElement(Int32, array<String>[]()[][]) | Wait for an element to exist. If it exists, return the Element object, else will throw a Timeout Exception.
Public method | WaitForElement(HtmlFindExpression, Int32, Boolean) | Wait for an element to exist. If it exists, return the Element object, else will throw a Timeout Exception.

See Also

Browser Class
Browser Members
ArtOfTest.WebAii.Core Namespace


WaitForElement Method (Int32, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitForElement Method (Int32, array<String>[]()[][])
Browser Class See Also Send Feedback
Wait for an element to exist. If it exists, return the Element object, else will throw a Timeout Exception.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element WaitForElement(
    int timeout,
    params string[] findClauses
)
Visual Basic
Public Function WaitForElement ( _
    timeout As Integer, _
    ParamArray findClauses As String() _
) As Element
Visual C++
public:
Element^ WaitForElement(
    int timeout,
    ... array<String^>^ findClauses
)

Parameters

timeout
Type: System..::..Int32
The timeout to use (msec)
findClauses
Type: array< System..::..String >[]()[][]
The Find Expression clauses

Return Value

The fully initialized found Element.

Remarks

This method replaces the Actions.WaitForElement() and supports HtmlFindExpressions

See Also

Browser Class
WaitForElement Overload
ArtOfTest.WebAii.Core Namespace


WaitForElement Method (HtmlFindExpression, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitForElement Method (HtmlFindExpression, Int32, Boolean)
Browser Class See Also Send Feedback
Wait for an element to exist. If it exists, return the Element object, else will throw a Timeout Exception.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element WaitForElement(
    HtmlFindExpression expression,
    int timeout,
    bool invertCondition
)
Visual Basic
Public Function WaitForElement ( _
    expression As HtmlFindExpression, _
    timeout As Integer, _
    invertCondition As Boolean _
) As Element
Visual C++
public:
Element^ WaitForElement(
    HtmlFindExpression^ expression,
    int timeout,
    bool invertCondition
)

Parameters

expression
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression
timeout
Type: System..::..Int32
The timout to use. (msec)
invertCondition
Type: System..::..Boolean

[Missing <param name="invertCondition"/> documentation for "M:ArtOfTest.WebAii.Core.Browser.WaitForElement(ArtOfTest.WebAii.Core.HtmlFindExpression,System.Int32,System.Boolean)"]

Return Value

The fully initialized found Element.

Remarks

This method replaces the Actions.WaitForElement() and supports HtmlFindExpressions

See Also

Browser Class
WaitForElement Overload
ArtOfTest.WebAii.Core Namespace


WaitForFrame Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitForFrame Method
Browser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForFrame(FrameInfo) | Wait for a frame to exist. Uses the Settings.ClientReadyTimeout as the timeout
Public method | WaitForFrame(FrameInfo, Int32) | Wait for a frame to exist.

See Also

Browser Class
Browser Members
ArtOfTest.WebAii.Core Namespace


WaitForFrame Method (FrameInfo)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitForFrame Method (FrameInfo)
Browser Class See Also Send Feedback
Wait for a frame to exist. Uses the Settings.ClientReadyTimeout as the timeout

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser WaitForFrame(
    FrameInfo frameInfo
)
Visual Basic
Public Function WaitForFrame ( _
    frameInfo As FrameInfo _
) As Browser
Visual C++
public:
Browser^ WaitForFrame(
    FrameInfo^ frameInfo
)

Parameters

frameInfo
Type: ArtOfTest.WebAii.Core..::..FrameInfo
The FrameInfo structure containing the frame details (id or name or src). Index is not needed.

Return Value

The Browser object representing the frame, else will throw an exception.

See Also

Browser Class
WaitForFrame Overload
ArtOfTest.WebAii.Core Namespace


WaitForFrame Method (FrameInfo, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitForFrame Method (FrameInfo, Int32)
Browser Class See Also Send Feedback
Wait for a frame to exist.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser WaitForFrame(
    FrameInfo frameInfo,
    int timeout
)
Visual Basic
Public Function WaitForFrame ( _
    frameInfo As FrameInfo, _
    timeout As Integer _
) As Browser
Visual C++
public:
Browser^ WaitForFrame(
    FrameInfo^ frameInfo,
    int timeout
)

Parameters

frameInfo
Type: ArtOfTest.WebAii.Core..::..FrameInfo
The FrameInfo structure containing the frame details (id or name or src). Index is not needed.
timeout
Type: System..::..Int32
The timeout to use for the wait.

Return Value

The Browser object representing the frame, else will throw an exception.

See Also

Browser Class
WaitForFrame Overload
ArtOfTest.WebAii.Core Namespace


WaitForUrl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitForUrl Method
Browser Class See Also Send Feedback
Wait for a specific url to be set. This can be used to wait for browser redirects on certain sites.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void WaitForUrl(
    string url,
    bool isPartial,
    int timeout
)
Visual Basic
Public Overridable Sub WaitForUrl ( _
    url As String, _
    isPartial As Boolean, _
    timeout As Integer _
)
Visual C++
public:
virtual void WaitForUrl(
    String^ url,
    bool isPartial,
    int timeout
)

Parameters

url
Type: System..::..String
The url to wait for.
isPartial
Type: System..::..Boolean
True/False whether to use partial comparison.
timeout
Type: System..::..Int32
The timeout in milli-seconds to use.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


WaitUntilReady Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..WaitUntilReady Method
Browser Class See Also Send Feedback
Waits for the browser until its ready

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void WaitUntilReady()
Visual Basic
Public Overridable Sub WaitUntilReady
Visual C++
public:
virtual void WaitUntilReady()

Remarks

This method uses the Manager.Settings.ClientReadyTimeout as the timeout.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Browser Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser Properties
Browser Class See Also Send Feedback

The Browser type exposes the following members.

Properties

 | Name | Description
Public property | Actions | Gets the Actions object that can be used to perform different actions against the loaded document in the browser.
Public property | Annotator | Gets the Annotator object associated with this browser.
Public property | AutoDomRefresh | Gets/Sets whether to automatically refresh the DOM tree after each browser command.
Public property | AutoWaitUntilReady | Gets/Sets whether to automatically wait until browser is ready after each browser command.
Public property | BrowserType | Gets the browser type (i.e. IE/FireFox ...etc)
Public property | ClientId | The unique ID for this browser that the manager identifies it with.
Public property | CommandTimeOut | Gets/Sets the max wait time in milliseconds that the browser will wait for a command to process before it times out.
Public property | ContentWindow | Gets the container window of the browser that contains the actual content of the page. (Excludes the browser toolbars, buttons ...etc.)
Public property | Cookies | Gets the cookies manager associated with this browser that allows you to retrieve, delete and add cookies.
Public property | CreationTime | The UTC time this instance was instantiated.
Public property | Desktop | Desktop object that draws its annotations in this browser
Public property | DomTree | Gets the DOM Tree representation of the currently loaded document.
Public property | Find | Gets the Find objects used to provide a rich set of methods to help identify elements in the Dom tree associated with this browser object.
Public property | FrameElement | Gets the Element object for the frame element represented by this Browser object, if this Browser represents a frame. If this Browser does not represent a frame, FrameElement is null.
Public property | FrameInfo | Gets the frame information if IsFrame = true else will return null. FrameInfo contains frame index and frame name.
Public property | Frames | List of child frames contained in this instance
Public property | FriendlyName | Get a friendly name for this browser instance.
Public property | IsConnected | Gets whether the browser is connected to manager of not.
Public property | IsFrame | Gets whether this instance represents a frame or not.
Public property | IsIEDialog | Gets whether this instance is an IE dialog (Modal/Modeless)
Public property | IsUILess | Whether this browser is UI less browser. (i.e. a raw http request/response browser)
Public property | Manager | The manager of this browser object.
Public property | NativeInstance | The native instance of this browser object (if available), otherwise null
Public property | PageTitle | Gets the page title if one exists. (text content of the 'title' tags)
Public property | QueryString | Gets a parsed name/value collection of the query string.
Public property | Regions | Gets a dictionary of all identified test regions in the currently loaded document.
Public property | StateHashCode | Get the state hash code.
Public property | TechnologyType | Get the technology type
Public property | UniqueId | Gets a unique id that identifies this browser instance.
Public property | Url | Gets the current page URL. This property is refreshed when calling RefreshDOMTree().
Public property | Version | The browser version for this browser type.
Public property | ViewSourceString | Gets the source of the page currently loaded in the browser. This is the string that the framework used to build the DOM.
Public property | Window | Gets the Win32 window object representing the actual browser window.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Actions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Actions Property
Browser Class See Also Send Feedback
Gets the Actions object that can be used to perform different actions against the loaded document in the browser.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Actions Actions { get; }
Visual Basic
Public ReadOnly Property Actions As Actions
    Get
Visual C++
public:
property Actions^ Actions {
    Actions^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Annotator Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Annotator Property
Browser Class See Also Send Feedback
Gets the Annotator object associated with this browser.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Annotator Annotator { get; }
Visual Basic
Public ReadOnly Property Annotator As Annotator
    Get
Visual C++
public:
virtual property Annotator^ Annotator {
    Annotator^ get () sealed;
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


AutoDomRefresh Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..AutoDomRefresh Property
Browser Class See Also Send Feedback
Gets/Sets whether to automatically refresh the DOM tree after each browser command.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AutoDomRefresh { get; set; }
Visual Basic
Public Property AutoDomRefresh As Boolean
    Get
    Set
Visual C++
public:
property bool AutoDomRefresh {
    bool get ();
    void set (bool value);
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


AutoWaitUntilReady Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..AutoWaitUntilReady Property
Browser Class See Also Send Feedback
Gets/Sets whether to automatically wait until browser is ready after each browser command.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AutoWaitUntilReady { get; set; }
Visual Basic
Public Property AutoWaitUntilReady As Boolean
    Get
    Set
Visual C++
public:
property bool AutoWaitUntilReady {
    bool get ();
    void set (bool value);
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


BrowserType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..BrowserType Property
Browser Class See Also Send Feedback
Gets the browser type (i.e. IE/FireFox ...etc)

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserType BrowserType { get; }
Visual Basic
Public ReadOnly Property BrowserType As BrowserType
    Get
Visual C++
public:
property BrowserType BrowserType {
    BrowserType get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ClientId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ClientId Property
Browser Class See Also Send Feedback
The unique ID for this browser that the manager identifies it with.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ClientId { get; }
Visual Basic
Public ReadOnly Property ClientId As String
    Get
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


CommandTimeOut Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..CommandTimeOut Property
Browser Class See Also Send Feedback
Gets/Sets the max wait time in milliseconds that the browser will wait for a command to process before it times out.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CommandTimeOut { get; set; }
Visual Basic
Public Property CommandTimeOut As Integer
    Get
    Set
Visual C++
public:
property int CommandTimeOut {
    int get ();
    void set (int value);
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ContentWindow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ContentWindow Property
Browser Class See Also Send Feedback
Gets the container window of the browser that contains the actual content of the page. (Excludes the browser toolbars, buttons ...etc.)

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Window ContentWindow { get; }
Visual Basic
Public Overridable ReadOnly Property ContentWindow As Window
    Get
Visual C++
public:
virtual property Window^ ContentWindow {
    Window^ get ();
}

Remarks

For Firefox 4, the ContentWindow returns the same Window as the Window property. Firefox 4 does not have separate Win32 windows for its chrome and its content.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Cookies Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Cookies Property
Browser Class See Also Send Feedback
Gets the cookies manager associated with this browser that allows you to retrieve, delete and add cookies.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CookiesManager Cookies { get; }
Visual Basic
Public ReadOnly Property Cookies As CookiesManager
    Get
Visual C++
public:
property CookiesManager^ Cookies {
    CookiesManager^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


CreationTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..CreationTime Property
Browser Class See Also Send Feedback
The UTC time this instance was instantiated.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime CreationTime { get; }
Visual Basic
Public ReadOnly Property CreationTime As DateTime
    Get
Visual C++
public:
property DateTime CreationTime {
    DateTime get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Desktop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Desktop Property
Browser Class See Also Send Feedback
Desktop object that draws its annotations in this browser

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Desktop Desktop { get; }
Visual Basic
Public ReadOnly Property Desktop As Desktop
    Get
Visual C++
public:
property Desktop^ Desktop {
    Desktop^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


DomTree Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..DomTree Property
Browser Class See Also Send Feedback
Gets the DOM Tree representation of the currently loaded document.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TreeBuilder DomTree { get; }
Visual Basic
Public ReadOnly Property DomTree As TreeBuilder
    Get
Visual C++
public:
property TreeBuilder^ DomTree {
    TreeBuilder^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Find Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Find Property
Browser Class See Also Send Feedback
Gets the Find objects used to provide a rich set of methods to help identify elements in the Dom tree associated with this browser object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Find Find { get; }
Visual Basic
Public ReadOnly Property Find As Find
    Get
Visual C++
public:
property Find^ Find {
    Find^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


FrameElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..FrameElement Property
Browser Class See Also Send Feedback
Gets the Element object for the frame element represented by this Browser object, if this Browser represents a frame. If this Browser does not represent a frame, FrameElement is null.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element FrameElement { get; internal set; }
Visual Basic
Public Property FrameElement As Element
    Get
    Friend Set
Visual C++
public:
property Element^ FrameElement {
    Element^ get ();
    internal: void set (Element^ value);
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


FrameInfo Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..FrameInfo Property
Browser Class See Also Send Feedback
Gets the frame information if IsFrame = true else will return null. FrameInfo contains frame index and frame name.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameInfo FrameInfo { get; }
Visual Basic
Public ReadOnly Property FrameInfo As FrameInfo
    Get
Visual C++
public:
property FrameInfo^ FrameInfo {
    FrameInfo^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Frames Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Frames Property
Browser Class See Also Send Feedback
List of child frames contained in this instance

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FramesCollection Frames { get; }
Visual Basic
Public Overridable ReadOnly Property Frames As FramesCollection
    Get
Visual C++
public:
virtual property FramesCollection^ Frames {
    FramesCollection^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


FriendlyName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..FriendlyName Property
Browser Class See Also Send Feedback
Get a friendly name for this browser instance.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FriendlyName { get; }
Visual Basic
Public ReadOnly Property FriendlyName As String
    Get
Visual C++
public:
virtual property String^ FriendlyName {
    String^ get () sealed;
}

Return Value

A string representing the friendly name for this browser. Used for display in Elements Explorer.

Implements

IAutomationHost..::..FriendlyName

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


IsConnected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..IsConnected Property
Browser Class See Also Send Feedback
Gets whether the browser is connected to manager of not.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsConnected { get; }
Visual Basic
Public Overridable ReadOnly Property IsConnected As Boolean
    Get
Visual C++
public:
virtual property bool IsConnected {
    bool get ();
}

Remarks

This property performs a two way communication check between the manager and the actual browser.

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


IsFrame Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..IsFrame Property
Browser Class See Also Send Feedback
Gets whether this instance represents a frame or not.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFrame { get; }
Visual Basic
Public ReadOnly Property IsFrame As Boolean
    Get
Visual C++
public:
property bool IsFrame {
    bool get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


IsIEDialog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..IsIEDialog Property
Browser Class See Also Send Feedback
Gets whether this instance is an IE dialog (Modal/Modeless)

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsIEDialog { get; }
Visual Basic
Public ReadOnly Property IsIEDialog As Boolean
    Get
Visual C++
public:
property bool IsIEDialog {
    bool get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


IsUILess Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..IsUILess Property
Browser Class See Also Send Feedback
Whether this browser is UI less browser. (i.e. a raw http request/response browser)

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsUILess { get; }
Visual Basic
Public ReadOnly Property IsUILess As Boolean
    Get
Visual C++
public:
property bool IsUILess {
    bool get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Manager Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Manager Property
Browser Class See Also Send Feedback
The manager of this browser object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Manager Manager { get; }
Visual Basic
Public ReadOnly Property Manager As Manager
    Get
Visual C++
public:
virtual property Manager^ Manager {
    Manager^ get () sealed;
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


NativeInstance Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..NativeInstance Property
Browser Class See Also Send Feedback
The native instance of this browser object (if available), otherwise null

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Object NativeInstance { get; }
Visual Basic
Public Overridable ReadOnly Property NativeInstance As Object
    Get
Visual C++
public:
virtual property Object^ NativeInstance {
    Object^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


PageTitle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..PageTitle Property
Browser Class See Also Send Feedback
Gets the page title if one exists. (text content of the 'title' tags)

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string PageTitle { get; }
Visual Basic
Public ReadOnly Property PageTitle As String
    Get
Visual C++
public:
property String^ PageTitle {
    String^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


QueryString Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..QueryString Property
Browser Class See Also Send Feedback
Gets a parsed name/value collection of the query string.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NameValueCollection QueryString { get; }
Visual Basic
Public ReadOnly Property QueryString As NameValueCollection
    Get
Visual C++
public:
property NameValueCollection^ QueryString {
    NameValueCollection^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Regions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Regions Property
Browser Class See Also Send Feedback
Gets a dictionary of all identified test regions in the currently loaded document.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestRegionCollection Regions { get; }
Visual Basic
Public ReadOnly Property Regions As TestRegionCollection
    Get
Visual C++
public:
property TestRegionCollection^ Regions {
    TestRegionCollection^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


StateHashCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..StateHashCode Property
Browser Class See Also Send Feedback
Get the state hash code.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string StateHashCode { get; }
Visual Basic
Public ReadOnly Property StateHashCode As String
    Get
Visual C++
public:
virtual property String^ StateHashCode {
    String^ get () sealed;
}

Implements

IAutomationHost..::..StateHashCode

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


TechnologyType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..TechnologyType Property
Browser Class See Also Send Feedback
Get the technology type

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TechnologyType TechnologyType { get; }
Visual Basic
Public ReadOnly Property TechnologyType As TechnologyType
    Get
Visual C++
public:
virtual property TechnologyType TechnologyType {
    TechnologyType get () sealed;
}

Implements

IAutomationHost..::..TechnologyType

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


UniqueId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..UniqueId Property
Browser Class See Also Send Feedback
Gets a unique id that identifies this browser instance.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UniqueId { get; }
Visual Basic
Public ReadOnly Property UniqueId As String
    Get
Visual C++
public:
virtual property String^ UniqueId {
    String^ get () sealed;
}

Implements

IAutomationHost..::..UniqueId

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Url Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Url Property
Browser Class See Also Send Feedback
Gets the current page URL. This property is refreshed when calling RefreshDOMTree().

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string Url { get; }
Visual Basic
Public Overridable ReadOnly Property Url As String
    Get
Visual C++
public:
virtual property String^ Url {
    String^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Version Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Version Property
Browser Class See Also Send Feedback
The browser version for this browser type.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Version { get; }
Visual Basic
Public ReadOnly Property Version As String
    Get
Visual C++
public:
property String^ Version {
    String^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


ViewSourceString Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..ViewSourceString Property
Browser Class See Also Send Feedback
Gets the source of the page currently loaded in the browser. This is the string that the framework used to build the DOM.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ViewSourceString { get; }
Visual Basic
Public ReadOnly Property ViewSourceString As String
    Get
Visual C++
public:
property String^ ViewSourceString {
    String^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Window Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Window Property
Browser Class See Also Send Feedback
Gets the Win32 window object representing the actual browser window.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Window Window { get; }
Visual Basic
Public Overridable ReadOnly Property Window As Window
    Get
Visual C++
public:
virtual property Window^ Window {
    Window^ get ();
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Browser Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser Events
Browser Class See Also Send Feedback

The Browser type exposes the following members.

Events

 | Name | Description
Public event | AfterCommandExecuted | Event occurs after the command is executed and the response is available.
Public event | BeforeCommandExecuted | Event occurs before a command is pushed to the browser.
Public event | Closing | Event occurs when the browser is about to close. [Browser.Close()] is called.
Public event | DomRefreshed | Event occurs after the DomTree is rebuilt (either after a command is executed or when RefreshDom is called)

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


AfterCommandExecuted Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..AfterCommandExecuted Event
Browser Class See Also Send Feedback
Event occurs after the command is executed and the response is available.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<BrowserCommandEventArgs> AfterCommandExecuted
Visual Basic
Public Event AfterCommandExecuted As EventHandler(Of BrowserCommandEventArgs)
Visual C++
public:
 event EventHandler<BrowserCommandEventArgs^>^ AfterCommandExecuted {
    void add (EventHandler<BrowserCommandEventArgs^>^ value);
    void remove (EventHandler<BrowserCommandEventArgs^>^ value);
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


BeforeCommandExecuted Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..BeforeCommandExecuted Event
Browser Class See Also Send Feedback
Event occurs before a command is pushed to the browser.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<BrowserCommandEventArgs> BeforeCommandExecuted
Visual Basic
Public Event BeforeCommandExecuted As EventHandler(Of BrowserCommandEventArgs)
Visual C++
public:
 event EventHandler<BrowserCommandEventArgs^>^ BeforeCommandExecuted {
    void add (EventHandler<BrowserCommandEventArgs^>^ value);
    void remove (EventHandler<BrowserCommandEventArgs^>^ value);
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


Closing Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..Closing Event
Browser Class See Also Send Feedback
Event occurs when the browser is about to close. [Browser.Close()] is called.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler Closing
Visual Basic
Public Event Closing As EventHandler
Visual C++
public:
 event EventHandler^ Closing {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


DomRefreshed Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Browser..::..DomRefreshed Event
Browser Class See Also Send Feedback
Event occurs after the DomTree is rebuilt (either after a command is executed or when RefreshDom is called)

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler DomRefreshed
Visual Basic
Public Event DomRefreshed As EventHandler
Visual C++
public:
 event EventHandler^ DomRefreshed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

Browser Class
ArtOfTest.WebAii.Core Namespace


BrowserConfigurationException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserConfigurationException Members
BrowserConfigurationException Class Constructors Methods Properties See Also Send Feedback

The BrowserConfigurationException type exposes the following members.

Constructors

 | Name | Description
Public method | BrowserConfigurationException | Initializes a new instance of the BrowserConfigurationException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BrowserConfigurationException Class
ArtOfTest.WebAii.Core Namespace


BrowserConfigurationException Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserConfigurationException Constructor
BrowserConfigurationException Class See Also Send Feedback
Initializes a new instance of the BrowserConfigurationException class

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserConfigurationException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
BrowserConfigurationException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Core.BrowserConfigurationException.#ctor(System.String)"]

See Also

BrowserConfigurationException Class
ArtOfTest.WebAii.Core Namespace


BrowserConfigurationException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserConfigurationException Methods
BrowserConfigurationException Class See Also Send Feedback

The BrowserConfigurationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BrowserConfigurationException Class
ArtOfTest.WebAii.Core Namespace


BrowserConfigurationException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserConfigurationException Properties
BrowserConfigurationException Class See Also Send Feedback

The BrowserConfigurationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BrowserConfigurationException Class
ArtOfTest.WebAii.Core Namespace


Desktop Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop Members
Desktop Class Constructors Methods Properties See Also Send Feedback

The Desktop type exposes the following members.

Constructors

 | Name | Description
Public method | Desktop | Create a new desktop object

Methods

 | Name | Description
Public method | DisableAutoDomRefresh | Disables auto dom refresh for Mouse/Keyboard actions
Public method | Dispose | Releases all resources used by the Desktop
Public method | EnableAutoDomRefresh | Enables the Desktop Mouse/Keyboard objects to perform auto dom refreshes after Click/DragDrop/SendKey actions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Annotator | Annotator that draws on the desktop
Public property | KeyBoard | Gets the keyboard object that enables simulating real keyboard events.
Public property | Mouse | Gets the mouse object that enables simulating real mouse events.
Public property | ValidateMouseActionsWithinBrowserContent | Gets/Sets whether to validate all mouse actions to ensure they are within the browser's content window. If this is set to true, any mouse action outside that region will throw an exception.

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


Desktop Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop Constructor
Desktop Class See Also Send Feedback
Create a new desktop object

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Desktop()
Visual Basic
Public Sub New
Visual C++
public:
Desktop()

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


Desktop Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop Methods
Desktop Class See Also Send Feedback

The Desktop type exposes the following members.

Methods

 | Name | Description
Public method | DisableAutoDomRefresh | Disables auto dom refresh for Mouse/Keyboard actions
Public method | Dispose |
Public method | EnableAutoDomRefresh | Enables the Desktop Mouse/Keyboard objects to perform auto dom refreshes after Click/DragDrop/SendKey actions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


DisableAutoDomRefresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop..::..DisableAutoDomRefresh Method
Desktop Class See Also Send Feedback
Disables auto dom refresh for Mouse/Keyboard actions

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DisableAutoDomRefresh()
Visual Basic
Public Sub DisableAutoDomRefresh
Visual C++
public:
void DisableAutoDomRefresh()

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


Dispose Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop..::..Dispose Method
Desktop Class See Also Send Feedback
Releases all resources used by the Desktop

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


EnableAutoDomRefresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop..::..EnableAutoDomRefresh Method
Desktop Class See Also Send Feedback
Enables the Desktop Mouse/Keyboard objects to perform auto dom refreshes after Click/DragDrop/SendKey actions.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void EnableAutoDomRefresh(
    IAutomationHost targetBrowser
)
Visual Basic
Public Sub EnableAutoDomRefresh ( _
    targetBrowser As IAutomationHost _
)
Visual C++
public:
void EnableAutoDomRefresh(
    IAutomationHost^ targetBrowser
)

Parameters

targetBrowser
Type: ArtOfTest.Common..::..IAutomationHost
The target browser to perform refresh on.

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


Desktop Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop Properties
Desktop Class See Also Send Feedback

The Desktop type exposes the following members.

Properties

 | Name | Description
Public property | Annotator | Annotator that draws on the desktop
Public property | KeyBoard | Gets the keyboard object that enables simulating real keyboard events.
Public property | Mouse | Gets the mouse object that enables simulating real mouse events.
Public property | ValidateMouseActionsWithinBrowserContent | Gets/Sets whether to validate all mouse actions to ensure they are within the browser's content window. If this is set to true, any mouse action outside that region will throw an exception.

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


Annotator Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop..::..Annotator Property
Desktop Class See Also Send Feedback
Annotator that draws on the desktop

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Annotator Annotator { get; }
Visual Basic
Public ReadOnly Property Annotator As Annotator
    Get
Visual C++
public:
property Annotator^ Annotator {
    Annotator^ get ();
}

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


KeyBoard Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop..::..KeyBoard Property
Desktop Class See Also Send Feedback
Gets the keyboard object that enables simulating real keyboard events.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public KeyBoard KeyBoard { get; }
Visual Basic
Public ReadOnly Property KeyBoard As KeyBoard
    Get
Visual C++
public:
property KeyBoard^ KeyBoard {
    KeyBoard^ get ();
}

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


Mouse Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop..::..Mouse Property
Desktop Class See Also Send Feedback
Gets the mouse object that enables simulating real mouse events.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Mouse Mouse { get; }
Visual Basic
Public ReadOnly Property Mouse As Mouse
    Get
Visual C++
public:
property Mouse^ Mouse {
    Mouse^ get ();
}

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


ValidateMouseActionsWithinBrowserContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Desktop..::..ValidateMouseActionsWithinBrowserContent Property
Desktop Class See Also Send Feedback
Gets/Sets whether to validate all mouse actions to ensure they are within the browser's content window. If this is set to true, any mouse action outside that region will throw an exception.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ValidateMouseActionsWithinBrowserContent { get; set; }
Visual Basic
Public Property ValidateMouseActionsWithinBrowserContent As Boolean
    Get
    Set
Visual C++
public:
property bool ValidateMouseActionsWithinBrowserContent {
    bool get ();
    void set (bool value);
}

See Also

Desktop Class
ArtOfTest.WebAii.Core Namespace


ElementFinder Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder Members
ElementFinder Class Constructors Methods Properties See Also Send Feedback

The ElementFinder type exposes the following members.

Constructors

 | Name | Description
Public method | ElementFinder | Create a new ElementFinder against a specific class instance

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Get an element defined by a FindAttribute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHtml(String) | Get an HTML element
Public method | GetHtml<(Of <<'(T>)>>)(String) | Get an HTML element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXaml(String) | Get a Xaml element.
Public method | GetXaml<(Of <<'(T>)>>)(String) | Get a Xaml element
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Merge a set of FindAttribute declarations defined on a type. The parameters will be available using Get, GetHtml or GetXaml
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Obsolete. Get an element object defined by a FindParam attribute on the test method or test class.
Public property | ReturnElementProxyWhenNotFound | Gets or sets a flag that indicates to the ElementFinder to return an ElementProxy object when the element is not found instead of null or an exception. The Element proxy object is an Element object that is only initialized with the FindParam object it needs to use. You can then call Element.Wait.ForExists() on it to wait for it to be found. You can check whether an Element is a proxy element by checking the Element.IsProxy
Public property | WaitOnElements | Gets or sets whether to wait on elements to exist in the DOM tree if they can't be found initially. If set, will use the WaitOnElementsTimeout as the default timeout for the wait. Default is false Note: This property overrides ReturnElementProxyWhenNotFound if set.
Public property | WaitOnElementsTimeout | Gets or sets the timeout to use when waiting on elements. WaitOnElements=true.

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


ElementFinder Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder Constructor
ElementFinder Class See Also Send Feedback
Create a new ElementFinder against a specific class instance

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ElementFinder(
    Manager manager,
    Object classInstance
)
Visual Basic
Public Sub New ( _
    manager As Manager, _
    classInstance As Object _
)
Visual C++
public:
ElementFinder(
    Manager^ manager,
    Object^ classInstance
)

Parameters

manager
Type: ArtOfTest.WebAii.Core..::..Manager
The manager object
classInstance
Type: System..::..Object
The class instance

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


ElementFinder Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder Methods
ElementFinder Class See Also Send Feedback

The ElementFinder type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Get an element defined by a FindAttribute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHtml(String) | Get an HTML element
Public method | GetHtml<(Of <<'(T>)>>)(String) | Get an HTML element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetXaml(String) | Get a Xaml element.
Public method | GetXaml<(Of <<'(T>)>>)(String) | Get a Xaml element
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge | Merge a set of FindAttribute declarations defined on a type. The parameters will be available using Get, GetHtml or GetXaml
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


Get Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..Get Method
ElementFinder Class See Also Send Feedback
Get an element defined by a FindAttribute.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement Get(
    string elementKey
)
Visual Basic
Public Function Get ( _
    elementKey As String _
) As ITargetElement
Visual C++
public:
ITargetElement^ Get(
    String^ elementKey
)

Parameters

elementKey
Type: System..::..String
The FindAttribute to use to locate the element.

Return Value

The element from the DOM or a proxy element that can be used later for another search.

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


GetHtml Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..GetHtml Method
ElementFinder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHtml(String) | Get an HTML element
Public method | GetHtml<(Of <<'(T>)>>)(String) | Get an HTML element.

See Also

ElementFinder Class
ElementFinder Members
ArtOfTest.WebAii.Core Namespace


GetHtml Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..GetHtml Method (String)
ElementFinder Class See Also Send Feedback
Get an HTML element

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element GetHtml(
    string elementKey
)
Visual Basic
Public Function GetHtml ( _
    elementKey As String _
) As Element
Visual C++
public:
Element^ GetHtml(
    String^ elementKey
)

Parameters

elementKey
Type: System..::..String
The key as defined by the Find() attribute.

Return Value

The Element object.

See Also

ElementFinder Class
GetHtml Overload
ArtOfTest.WebAii.Core Namespace


GetHtml(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..GetHtml<(Of <(<'T>)>)> Method (String)
ElementFinder Class See Also Send Feedback
Get an HTML element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T GetHtml<T>(
    string elementKey
)
where T : new(), Control
Visual Basic
Public Function GetHtml(Of T As {New, Control}) ( _
    elementKey As String _
) As T
Visual C++
public:
generic<typename T>
where T : gcnew(), Control
T GetHtml(
    String^ elementKey
)

Parameters

elementKey
Type: System..::..String
The key as defined by the Find() attribute.

Type Parameters

T
The control type.

Return Value

The control.

See Also

ElementFinder Class
GetHtml Overload
ArtOfTest.WebAii.Core Namespace


GetXaml Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..GetXaml Method
ElementFinder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetXaml<(Of <<'(T>)>>)(String) | Get a Xaml element
Public method | GetXaml(String) | Get a Xaml element.

See Also

ElementFinder Class
ElementFinder Members
ArtOfTest.WebAii.Core Namespace


GetXaml(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..GetXaml<(Of <(<'T>)>)> Method (String)
ElementFinder Class See Also Send Feedback
Get a Xaml element

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T GetXaml<T>(
    string elementKey
)
where T : FrameworkElement
Visual Basic
Public Function GetXaml(Of T As FrameworkElement) ( _
    elementKey As String _
) As T
Visual C++
public:
generic<typename T>
where T : FrameworkElement
T GetXaml(
    String^ elementKey
)

Parameters

elementKey
Type: System..::..String
The key as defined by the Find() attribute

Type Parameters

T
The control type.

Return Value

The found element

See Also

ElementFinder Class
GetXaml Overload
ArtOfTest.WebAii.Core Namespace


GetXaml Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..GetXaml Method (String)
ElementFinder Class See Also Send Feedback
Get a Xaml element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement GetXaml(
    string elementKey
)
Visual Basic
Public Function GetXaml ( _
    elementKey As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ GetXaml(
    String^ elementKey
)

Parameters

elementKey
Type: System..::..String
The element key as defined by the Find() attribute

Return Value

The found element

See Also

ElementFinder Class
GetXaml Overload
ArtOfTest.WebAii.Core Namespace


Merge Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..Merge Method
ElementFinder Class See Also Send Feedback
Merge a set of FindAttribute declarations defined on a type. The parameters will be available using Get, GetHtml or GetXaml

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Merge(
    Type typeToMerge
)
Visual Basic
Public Sub Merge ( _
    typeToMerge As Type _
)
Visual C++
public:
void Merge(
    Type^ typeToMerge
)

Parameters

typeToMerge
Type: System..::..Type

[Missing <param name="typeToMerge"/> documentation for "M:ArtOfTest.WebAii.Core.ElementFinder.Merge(System.Type)"]

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


ElementFinder Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder Properties
ElementFinder Class See Also Send Feedback

The ElementFinder type exposes the following members.

Properties

 | Name | Description
Public property | Item | Obsolete. Get an element object defined by a FindParam attribute on the test method or test class.
Public property | ReturnElementProxyWhenNotFound | Gets or sets a flag that indicates to the ElementFinder to return an ElementProxy object when the element is not found instead of null or an exception. The Element proxy object is an Element object that is only initialized with the FindParam object it needs to use. You can then call Element.Wait.ForExists() on it to wait for it to be found. You can check whether an Element is a proxy element by checking the Element.IsProxy
Public property | WaitOnElements | Gets or sets whether to wait on elements to exist in the DOM tree if they can't be found initially. If set, will use the WaitOnElementsTimeout as the default timeout for the wait. Default is false Note: This property overrides ReturnElementProxyWhenNotFound if set.
Public property | WaitOnElementsTimeout | Gets or sets the timeout to use when waiting on elements. WaitOnElements=true.

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..Item Property
ElementFinder Class See Also Send Feedback
Get an element object defined by a FindParam attribute on the test method or test class.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Please use Get, GetHtml or GetXaml instead")]
public Element this[
    string elementKey
] { get; }
Visual Basic
<ObsoleteAttribute("Please use Get, GetHtml or GetXaml instead")> _
Public ReadOnly Default Property Item ( _
    elementKey As String _
) As Element
    Get
Visual C++
[ObsoleteAttribute(L"Please use Get, GetHtml or GetXaml instead")]
public:
property Element^ default[String^ elementKey] {
    Element^ get (String^ elementKey);
}

Parameters

elementKey
Type: System..::..String
The element key as defined by the FindParam attribute.

Return Value

The Element object or null.

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


ReturnElementProxyWhenNotFound Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..ReturnElementProxyWhenNotFound Property
ElementFinder Class See Also Send Feedback
Gets or sets a flag that indicates to the ElementFinder to return an ElementProxy object when the element is not found instead of null or an exception. The Element proxy object is an Element object that is only initialized with the FindParam object it needs to use. You can then call Element.Wait.ForExists() on it to wait for it to be found. You can check whether an Element is a proxy element by checking the Element.IsProxy

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ReturnElementProxyWhenNotFound { get; set; }
Visual Basic
Public Property ReturnElementProxyWhenNotFound As Boolean
    Get
    Set
Visual C++
public:
property bool ReturnElementProxyWhenNotFound {
    bool get ();
    void set (bool value);
}

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


WaitOnElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..WaitOnElements Property
ElementFinder Class See Also Send Feedback
Gets or sets whether to wait on elements to exist in the DOM tree if they can't be found initially. If set, will use the WaitOnElementsTimeout as the default timeout for the wait. Default is false Note: This property overrides ReturnElementProxyWhenNotFound if set.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool WaitOnElements { get; set; }
Visual Basic
Public Property WaitOnElements As Boolean
    Get
    Set
Visual C++
public:
property bool WaitOnElements {
    bool get ();
    void set (bool value);
}

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


WaitOnElementsTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementFinder..::..WaitOnElementsTimeout Property
ElementFinder Class See Also Send Feedback
Gets or sets the timeout to use when waiting on elements. WaitOnElements=true.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int WaitOnElementsTimeout { get; set; }
Visual Basic
Public Property WaitOnElementsTimeout As Integer
    Get
    Set
Visual C++
public:
property int WaitOnElementsTimeout {
    int get ();
    void set (int value);
}

See Also

ElementFinder Class
ArtOfTest.WebAii.Core Namespace


EnumExtensions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EnumExtensions Members
EnumExtensions Class Methods See Also Send Feedback

The EnumExtensions type exposes the following members.

Methods

Name | Description
ToBrowserExecutionType |
ToBrowserType |

See Also

EnumExtensions Class
ArtOfTest.WebAii.Core Namespace


EnumExtensions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EnumExtensions Methods
EnumExtensions Class See Also Send Feedback

The EnumExtensions type exposes the following members.

Methods

Name | Description
ToBrowserExecutionType |
ToBrowserType |

See Also

EnumExtensions Class
ArtOfTest.WebAii.Core Namespace


ToBrowserExecutionType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EnumExtensions..::..ToBrowserExecutionType Method
EnumExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.EnumExtensions.ToBrowserExecutionType(ArtOfTest.WebAii.Core.BrowserType)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static BrowserExecutionType ToBrowserExecutionType(
    this BrowserType browserType
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ToBrowserExecutionType ( _
    browserType As BrowserType _
) As BrowserExecutionType
Visual C++
[ExtensionAttribute]
public:
static BrowserExecutionType ToBrowserExecutionType(
    BrowserType browserType
)

Parameters

browserType
Type: ArtOfTest.WebAii.Core..::..BrowserType

[Missing <param name="browserType"/> documentation for "M:ArtOfTest.WebAii.Core.EnumExtensions.ToBrowserExecutionType(ArtOfTest.WebAii.Core.BrowserType)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.EnumExtensions.ToBrowserExecutionType(ArtOfTest.WebAii.Core.BrowserType)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BrowserType. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

EnumExtensions Class
ArtOfTest.WebAii.Core Namespace


ToBrowserType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EnumExtensions..::..ToBrowserType Method
EnumExtensions Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.EnumExtensions.ToBrowserType(ArtOfTest.WebAii.Core.BrowserExecutionType)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static BrowserType ToBrowserType(
    this BrowserExecutionType browserExecutionType
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ToBrowserType ( _
    browserExecutionType As BrowserExecutionType _
) As BrowserType
Visual C++
[ExtensionAttribute]
public:
static BrowserType ToBrowserType(
    BrowserExecutionType browserExecutionType
)

Parameters

browserExecutionType
Type: ArtOfTest.WebAii.Core..::..BrowserExecutionType

[Missing <param name="browserExecutionType"/> documentation for "M:ArtOfTest.WebAii.Core.EnumExtensions.ToBrowserType(ArtOfTest.WebAii.Core.BrowserExecutionType)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.EnumExtensions.ToBrowserType(ArtOfTest.WebAii.Core.BrowserExecutionType)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BrowserExecutionType. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

EnumExtensions Class
ArtOfTest.WebAii.Core Namespace


Find Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find Members
Find Class Methods Properties Events See Also Send Feedback

The Find type exposes the following members.

Methods

Name Description
Public method AllByAttributes(array<String>[]()[][])
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
Public method AllByAttributes<(Of <<'(TControl>)>>)(array<String>[]()[][])
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
Public method AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
The TextContent to match

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method AllByContent<(Of <<'(TControl>)>>)(String)
AllByContent(String)
Public method AllByContent<(Of <<'(TControl>)>>)(String, FindContentType)
AllByContent(String, FindContentType)
Public method AllByCustom(Predicate<(Of <<'(Element>)>>))
Return all elements that match the predicate
Public method AllByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>))
Returns all controls that match the predicate and are convertable to TControl.
Public method AllByExpression(array<String>[]()[][])
Find all elements by HTML find expression strings.
Public method AllByExpression(HtmlFindExpression)
Find all elements by HtmlFindExpression.
Public method AllByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][])
Find all elements by HTML find expression strings of type TControl.
Public method AllByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression)
Find all elements by HtmlFindExpression of type TControl.
Public method AllByParam(FindParam) Obsolete.
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
Public method AllByParam<(Of <<'(TControl>)>>)(FindParam) Obsolete.
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
Public method AllByTagName(String)
Returns a list of elements with a specific tag name.
Public method AllByTagName<(Of <<'(TControl>)>>)(String)
Returns a list of elements with a specific tag name as a control collection.
Public method AllByXPath(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
Public method AllByXPath<(Of <<'(TControl>)>>)(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
Public method AllControls<(Of <<'(TControl>)>>)
Gets an IEnmerable for TControl to be used for LINQ queries. This will return only elements that are convertable to TControl
Public method AllElements
Gets a IEnumerable for all elements to be used for LINQ queries
BuildBestFitFindExpression
Generates a FindParam[] list to be used to find the specified element. The function uses an algorithm optimized for most reliable search methods and will revert back to using the tagname index as a last resort
BuildBestFitFindParam Obsolete.
Generates a FindParam[] list to be used to find the specified element. The function uses an algorithm optimized for most reliable search methods and will revert back to using the tagname index as a last resort
Public method ByAttributes(array<String>[]()[][])
Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.
Public method ByAttributes<(Of <<'(TControl>)>>)(array<String>[]()[][])
Same as ByAttributes(). Returns a control type instead of element.
Public method ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
Public method ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method ByContent(String, FindContentType, array<String>[]()[][])
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method ByContent<(Of <<'(TControl>)>>)(String)
Same as ByContent(). Returns a control type instead of element.
Public method ByContent<(Of <<'(TControl>)>>)(String, FindContentType)
Same as ByContent(). Returns a control type instead of element.
Public method ByContent<(Of <<'(TControl>)>>)(String, FindContentType, array<String>[]()[][])
Same as ByContent(). Returns a control type instead of element.
Public method ByCustom(Predicate<(Of <<'(Element>)>>))
Return the element that matches the defined predicate.
Public method ByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>))
Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.
Public method ByExpression(array<String>[]()[][])
Find element by HTML find expression strings.
Public method ByExpression(HtmlFindExpression)
Find element by HtmlFindExpression.
Public method ByExpression(HtmlFindExpression, Boolean)
Find Element by HtmlFindExpression.
Public method ByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][])
Find element by HTML find expression strings of type TControl.
Public method ByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression)
Find element by HtmlFindExpression of type TControl.
Public method ById(String)
Returns an element by looking for its 'id' attribute value.
Public method ById<(Of <<'(TControl>)>>)(String)
Same as ById(). Returns a control type instead of element.
Public method ByName(String)
Returns an element by searching for its 'name' attribute value
Public method ByName<(Of <<'(TControl>)>>)(String)
Same as ByName(). Returns a control type instead of element.
Public method ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.

Examples

CopyC#
For example:

This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

<referenceElement>
 (0)<foo>
        <bar>
        </bar>
        <car>
        </car>
     (2)<bus>
         (0)<driver>
                <cap>
                </cap>
             (1)<target>
                </target>
            </driver>
        </bus>
    </foo>
</referenceElement>
Public method ByNodeIndexPath<(Of <<'(TControl>)>>)(String)
Same as ByNodexIndexPath(). Returns a control type instead of element.
Public method ByParam(FindParam) Obsolete.
Return an element using a FindParam
Public method ByParam(array<FindParam>[]()[][]) Obsolete.
Returns an element using a chained identification.
Public method ByParam<(Of <<'(TControl>)>>)(FindParam) Obsolete.
Same as ByParam(). Returns a control type instead of element.
Public method ByParam<(Of <<'(TControl>)>>)(array<FindParam>[]()[][]) Obsolete.
Same as ByParam(). Returns a control type instead of element.
Public method ByTagIndex(String, Int32)
Returns an element by its tag name occrrence.
Public method ByTagIndex<(Of <<'(TControl>)>>)(String, Int32)
Same as ByTagIndex(). Returns a control type instead of element.
Public method ByXPath(String)
Returns an element using an XPath. This function supports the System.Xml XPath syntax.
Public method ByXPath<(Of <<'(TControl>)>>)(String)
Same as ByXPath(). Returns a control type instead of element.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FromCollection(FindParamCollection) Obsolete.
Finds all elements with the FindParams in the passed in collection.
Public method FromCollection(FindExpressionCollection<(Of <<'(HtmlFindExpression>)>>))
Finds all elements with the HtmlFindExpressions in the collection.
Public method FromExpressionsFile
Finds all elements with FindExpressions defined in a file.
Public method FromExpressionsXml
Finds all elements with FindExpressions defined in the serialized xml string.
Public method FromFile Obsolete.
Finds all elements with FindParams defined in a file.
Public method FromXml Obsolete.
Finds all elements with FindParams defined in the serialized xml string. Found elements can be accessed from Find.Elements
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | jQuery | Creates and returns a new jQuery object for the Find object. (Defined by jQueryExtension.)

Properties

 | Name | Description
Public property | AssociatedBrowser | Gets the browser object that is associated with this find object. If this property is null, then the Find object is associated with a search region.
Public property | FindReferenceType | Gets the reference type that this Find object is using. (i.e. browser root, testregion ... etc)
Public property | IgnoreFindAllControlMismatch | Gets/Sets whether to ignore Find.Allxx<TControl>(...) elements that don't match the TControl specified. (i.e. the TControl type validation fails for that element). If false, the Find.Allxx method will throw an exception.
Public property | LastFindParam | Gets the last FindParam used to search.
Public property | LastSearchLog | Gets the search log for the last find attempt. This log can help diagnose when find fails to locate an element.
Public property | SearchRegion | Gets the search region for this Find object. When this is set to a specific region, all search is done locale to that region. All indexes are calculated starting at zero from this region's element. If this property is null, then the Find object will perform all searches from the document root element.
Public property | SearchRootElement | Gets/Sets the root element that all searches will be performed under. This element depended on the reference type. [Browser/TestRegion/Element].
Public property | ThrowIfNullOrEmpty | Gets/Sets whether to throw an exception if any of the find methods returns a null element or any of the find all methods return empty list of elements.

Events

 | Name | Description
Public event | ReturnedNullOrEmpty | Invoked when one of the find methods returns null or an empty list of elements.

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


Find Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find Methods
Find Class See Also Send Feedback

The Find type exposes the following members.

Methods

Name Description
Public method AllByAttributes(array<String>[]()[][])
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
Public method AllByAttributes<(Of <<'(TControl>)>>)(array<String>[]()[][])
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
Public method AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
The TextContent to match

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method AllByContent<(Of <<'(TControl>)>>)(String)
AllByContent(String)
Public method AllByContent<(Of <<'(TControl>)>>)(String, FindContentType)
AllByContent(String, FindContentType)
Public method AllByCustom(Predicate<(Of <<'(Element>)>>))
Return all elements that match the predicate
Public method AllByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>))
Returns all controls that match the predicate and are convertable to TControl.
Public method AllByExpression(array<String>[]()[][])
Find all elements by HTML find expression strings.
Public method AllByExpression(HtmlFindExpression)
Find all elements by HtmlFindExpression.
Public method AllByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][])
Find all elements by HTML find expression strings of type TControl.
Public method AllByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression)
Find all elements by HtmlFindExpression of type TControl.
Public method AllByParam(FindParam) Obsolete.
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
Public method AllByParam<(Of <<'(TControl>)>>)(FindParam) Obsolete.
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
Public method AllByTagName(String)
Returns a list of elements with a specific tag name.
Public method AllByTagName<(Of <<'(TControl>)>>)(String)
Returns a list of elements with a specific tag name as a control collection.
Public method AllByXPath(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
Public method AllByXPath<(Of <<'(TControl>)>>)(String)
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
Public method AllControls<(Of <<'(TControl>)>>)
Gets an IEnmerable for TControl to be used for LINQ queries. This will return only elements that are convertable to TControl
Public method AllElements
Gets a IEnumerable for all elements to be used for LINQ queries
BuildBestFitFindExpression
Generates a FindParam[] list to be used to find the specified element. The function uses an algorithm optimized for most reliable search methods and will revert back to using the tagname index as a last resort
BuildBestFitFindParam Obsolete.
Generates a FindParam[] list to be used to find the specified element. The function uses an algorithm optimized for most reliable search methods and will revert back to using the tagname index as a last resort
Public method ByAttributes(array<String>[]()[][])
Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.
Public method ByAttributes<(Of <<'(TControl>)>>)(array<String>[]()[][])
Same as ByAttributes(). Returns a control type instead of element.
Public method ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
Public method ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method ByContent(String, FindContentType, array<String>[]()[][])
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method ByContent<(Of <<'(TControl>)>>)(String)
Same as ByContent(). Returns a control type instead of element.
Public method ByContent<(Of <<'(TControl>)>>)(String, FindContentType)
Same as ByContent(). Returns a control type instead of element.
Public method ByContent<(Of <<'(TControl>)>>)(String, FindContentType, array<String>[]()[][])
Same as ByContent(). Returns a control type instead of element.
Public method ByCustom(Predicate<(Of <<'(Element>)>>))
Return the element that matches the defined predicate.
Public method ByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>))
Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.
Public method ByExpression(array<String>[]()[][])
Find element by HTML find expression strings.
Public method ByExpression(HtmlFindExpression)
Find element by HtmlFindExpression.
Public method ByExpression(HtmlFindExpression, Boolean)
Find Element by HtmlFindExpression.
Public method ByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][])
Find element by HTML find expression strings of type TControl.
Public method ByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression)
Find element by HtmlFindExpression of type TControl.
Public method ById(String)
Returns an element by looking for its 'id' attribute value.
Public method ById<(Of <<'(TControl>)>>)(String)
Same as ById(). Returns a control type instead of element.
Public method ByName(String)
Returns an element by searching for its 'name' attribute value
Public method ByName<(Of <<'(TControl>)>>)(String)
Same as ByName(). Returns a control type instead of element.
Public method ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.

Examples

CopyC#
For example:

This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

<referenceElement>
 (0)<foo>
        <bar>
        </bar>
        <car>
        </car>
     (2)<bus>
         (0)<driver>
                <cap>
                </cap>
             (1)<target>
                </target>
            </driver>
        </bus>
    </foo>
</referenceElement>
Public method ByNodeIndexPath<(Of <<'(TControl>)>>)(String)
Same as ByNodexIndexPath(). Returns a control type instead of element.
Public method ByParam(FindParam) Obsolete.
Return an element using a FindParam
Public method ByParam(array<FindParam>[]()[][]) Obsolete.
Returns an element using a chained identification.
Public method ByParam<(Of <<'(TControl>)>>)(FindParam) Obsolete.
Same as ByParam(). Returns a control type instead of element.
Public method ByParam<(Of <<'(TControl>)>>)(array<FindParam>[]()[][]) Obsolete.
Same as ByParam(). Returns a control type instead of element.
Public method ByTagIndex(String, Int32)
Returns an element by its tag name occrrence.
Public method ByTagIndex<(Of <<'(TControl>)>>)(String, Int32)
Same as ByTagIndex(). Returns a control type instead of element.
Public method ByXPath(String)
Returns an element using an XPath. This function supports the System.Xml XPath syntax.
Public method ByXPath<(Of <<'(TControl>)>>)(String)
Same as ByXPath(). Returns a control type instead of element.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method FromCollection(FindParamCollection) Obsolete.
Finds all elements with the FindParams in the passed in collection.
Public method FromCollection(FindExpressionCollection<(Of <<'(HtmlFindExpression>)>>))
Finds all elements with the HtmlFindExpressions in the collection.
Public method FromExpressionsFile
Finds all elements with FindExpressions defined in a file.
Public method FromExpressionsXml
Finds all elements with FindExpressions defined in the serialized xml string.
Public method FromFile Obsolete.
Finds all elements with FindParams defined in a file.
Public method FromXml Obsolete.
Finds all elements with FindParams defined in the serialized xml string. Found elements can be accessed from Find.Elements
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | jQuery | Creates and returns a new jQuery object for the Find object. (Defined by jQueryExtension.)

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


AllByAttributes Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByAttributes Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByAttributes(array<String>[]()[][]) | Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.
Public method | AllByAttributes<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


AllByAttributes Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByAttributes Method (array<String>[]()[][])
Find Class See Also Send Feedback
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> AllByAttributes(
    params string[] nameValuePairs
)
Visual Basic
Public Function AllByAttributes ( _
    ParamArray nameValuePairs As String() _
) As ReadOnlyCollection(Of Element)
Visual C++
public:
ReadOnlyCollection<Element^>^ AllByAttributes(
    ... array<String^>^ nameValuePairs
)

Parameters

nameValuePairs
Type: array< System..::..String >[]()[][]
A list of name value pairs to match. For example: "bar=foo","class=myclass","src=~foo.gif","src=!bar". Use =~ for partial values or =! to exclude values.

Return Value

The list of found elements.

See Also

Find Class
AllByAttributes Overload
ArtOfTest.WebAii.Core Namespace


AllByAttributes(TControl) Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByAttributes<(Of <(<'TControl>)>)> Method (array<String>[]()[][])
Find Class See Also Send Feedback
Returns a list of elements that have attributes that match the NameValuePairs passed it fully or partially.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<TControl> AllByAttributes<TControl>(
    params string[] nameValuePairs
)
where TControl : new(), Control
Visual Basic
Public Function AllByAttributes(Of TControl As {New, Control}) ( _
    ParamArray nameValuePairs As String() _
) As ReadOnlyCollection(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByAttributes(
    ... array<String^>^ nameValuePairs
)

Parameters

nameValuePairs
Type: array< System..::..String >[]()[][]
A list of name value pairs to match. For example: AllByAttributes("bar=foo","class=myclass","src=~foo.gif"). Use =~ for partial values.

Type Parameters

TControl
Control type to get.

Return Value

The list of found elements.

Remarks

If

See Also

Find Class
AllByAttributes Overload
ArtOfTest.WebAii.Core Namespace


AllByContent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByContent Method
Find Class See Also Send Feedback

Overload List

Name Description
Public method AllByContent<(Of <<'(TControl>)>>)(String)
AllByContent(String)
Public method AllByContent(String)
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
The TextContent to match

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method AllByContent(String, FindContentType)
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method AllByContent<(Of <<'(TControl>)>>)(String, FindContentType)
AllByContent(String, FindContentType)

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


AllByContent(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByContent<(Of <(<'TControl>)>)> Method (String)
Find Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<TControl> AllByContent<TControl>(
    string textContent
)
where TControl : new(), Control
Visual Basic
Public Function AllByContent(Of TControl As {New, Control}) ( _
    textContent As String _
) As ReadOnlyCollection(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByContent(
    String^ textContent
)

Parameters

textContent
Type: System..::..String

[Missing <param name="textContent"/> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String)"]

Type Parameters

TControl

[Missing <typeparam name="TControl"/> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String)"]

See Also

Find Class
AllByContent Overload
ArtOfTest.WebAii.Core Namespace


AllByContent Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByContent Method (String)
Find Class See Also Send Feedback
Returns a list of elements that have TextContent that match the specified content The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
The TextContent to match

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> AllByContent(
    string textContent
)
Visual Basic
Public Function AllByContent ( _
    textContent As String _
) As ReadOnlyCollection(Of Element)
Visual C++
public:
ReadOnlyCollection<Element^>^ AllByContent(
    String^ textContent
)

Parameters

textContent
Type: System..::..String

[Missing <param name="textContent"/> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent(System.String)"]

Return Value

The list of found elements.

See Also

Find Class
AllByContent Overload
ArtOfTest.WebAii.Core Namespace


AllByContent Method (String, FindContentType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByContent Method (String, FindContentType)
Find Class See Also Send Feedback
Returns a list of elements that match the specified content. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with TextContent of: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> AllByContent(
    string content,
    FindContentType contentType
)
Visual Basic
Public Function AllByContent ( _
    content As String, _
    contentType As FindContentType _
) As ReadOnlyCollection(Of Element)
Visual C++
public:
ReadOnlyCollection<Element^>^ AllByContent(
    String^ content,
    FindContentType contentType
)

Parameters

content
Type: System..::..String
The content to match
contentType
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to match.

Return Value

The list of found elements.

See Also

Find Class
AllByContent Overload
ArtOfTest.WebAii.Core Namespace


AllByContent(TControl) Method (String, FindContentType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByContent<(Of <(<'TControl>)>)> Method (String, FindContentType)
Find Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String,ArtOfTest.WebAii.ObjectModel.FindContentType)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<TControl> AllByContent<TControl>(
    string content,
    FindContentType contentType
)
where TControl : new(), Control
Visual Basic
Public Function AllByContent(Of TControl As {New, Control}) ( _
    content As String, _
    contentType As FindContentType _
) As ReadOnlyCollection(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByContent(
    String^ content,
    FindContentType contentType
)

Parameters

content
Type: System..::..String

[Missing <param name="content"/> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String,ArtOfTest.WebAii.ObjectModel.FindContentType)"]

contentType
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType

[Missing <param name="contentType"/> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String,ArtOfTest.WebAii.ObjectModel.FindContentType)"]

Type Parameters

TControl

[Missing <typeparam name="TControl"/> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String,ArtOfTest.WebAii.ObjectModel.FindContentType)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Find.AllByContent``1(System.String,ArtOfTest.WebAii.ObjectModel.FindContentType)"]

See Also

Find Class
AllByContent Overload
ArtOfTest.WebAii.Core Namespace


AllByCustom Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByCustom Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>)) | Returns all controls that match the predicate and are convertable to TControl.
Public method | AllByCustom(Predicate<(Of <<'(Element>)>>)) | Return all elements that match the predicate

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


AllByCustom(TControl) Method (Predicate(TControl))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByCustom<(Of <(<'TControl>)>)> Method (Predicate<(Of <(<'TControl>)>)>)
Find Class See Also Send Feedback
Returns all controls that match the predicate and are convertable to TControl.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<TControl> AllByCustom<TControl>(
    Predicate<TControl> predicate
)
where TControl : new(), Control
Visual Basic
Public Function AllByCustom(Of TControl As {New, Control}) ( _
    predicate As Predicate(Of TControl) _
) As ReadOnlyCollection(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByCustom(
    Predicate<TControl>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<'TControl>)>)>
The predicate to use during the search.

Type Parameters

TControl
The control type to filter on.

Return Value

A read only collection of elements matching the predicate and control type.

See Also

Find Class
AllByCustom Overload
ArtOfTest.WebAii.Core Namespace


AllByCustom Method (Predicate(Element))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByCustom Method (Predicate<(Of <(<'Element>)>)>)
Find Class See Also Send Feedback
Return all elements that match the predicate

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> AllByCustom(
    Predicate<Element> predicate
)
Visual Basic
Public Function AllByCustom ( _
    predicate As Predicate(Of Element) _
) As ReadOnlyCollection(Of Element)
Visual C++
public:
ReadOnlyCollection<Element^>^ AllByCustom(
    Predicate<Element^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' Element >)>)>
The custom predicate that defines the element search

Return Value

The list of elements that match the predicate, else an empty collection or an exception (depending on ThrowIfNullOrEmpty)

See Also

Find Class
AllByCustom Overload
ArtOfTest.WebAii.Core Namespace


AllByExpression Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByExpression Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find all elements by HTML find expression strings of type TControl.
Public method | AllByExpression(array<String>[]()[][]) | Find all elements by HTML find expression strings.
Public method | AllByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression) | Find all elements by HtmlFindExpression of type TControl.
Public method | AllByExpression(HtmlFindExpression) | Find all elements by HtmlFindExpression.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


AllByExpression(TControl) Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByExpression<(Of <(<'TControl>)>)> Method (array<String>[]()[][])
Find Class See Also Send Feedback
Find all elements by HTML find expression strings of type TControl.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<TControl> AllByExpression<TControl>(
    params string[] expression
)
where TControl : new(), Control
Visual Basic
Public Function AllByExpression(Of TControl As {New, Control}) ( _
    ParamArray expression As String() _
) As ReadOnlyCollection(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByExpression(
    ... array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]
Array of HTML find expression strings.

Type Parameters

TControl
The type of control to search for and return.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of TControl elements.

See Also

Find Class
AllByExpression Overload
ArtOfTest.WebAii.Core Namespace


AllByExpression Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByExpression Method (array<String>[]()[][])
Find Class See Also Send Feedback
Find all elements by HTML find expression strings.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> AllByExpression(
    params string[] expression
)
Visual Basic
Public Function AllByExpression ( _
    ParamArray expression As String() _
) As ReadOnlyCollection(Of Element)
Visual C++
public:
ReadOnlyCollection<Element^>^ AllByExpression(
    ... array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]
Array of HTML find expression strings.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of elements.

See Also

Find Class
AllByExpression Overload
ArtOfTest.WebAii.Core Namespace


AllByExpression(TControl) Method (HtmlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByExpression<(Of <(<'TControl>)>)> Method (HtmlFindExpression)
Find Class See Also Send Feedback
Find all elements by HtmlFindExpression of type TControl.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<TControl> AllByExpression<TControl>(
    HtmlFindExpression expression
)
where TControl : new(), Control
Visual Basic
Public Function AllByExpression(Of TControl As {New, Control}) ( _
    expression As HtmlFindExpression _
) As ReadOnlyCollection(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByExpression(
    HtmlFindExpression^ expression
)

Parameters

expression
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression to use during the find.

Type Parameters

TControl
The type of control to search for and return.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of TControl elements.

See Also

Find Class
AllByExpression Overload
ArtOfTest.WebAii.Core Namespace


AllByExpression Method (HtmlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByExpression Method (HtmlFindExpression)
Find Class See Also Send Feedback
Find all elements by HtmlFindExpression.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> AllByExpression(
    HtmlFindExpression expression
)
Visual Basic
Public Function AllByExpression ( _
    expression As HtmlFindExpression _
) As ReadOnlyCollection(Of Element)
Visual C++
public:
ReadOnlyCollection<Element^>^ AllByExpression(
    HtmlFindExpression^ expression
)

Parameters

expression
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression to use during the find.

Return Value

A ReadOnlyCollection<(Of <(<'T>)>)> of Element's

See Also

Find Class
AllByExpression Overload
ArtOfTest.WebAii.Core Namespace


AllByParam Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByParam Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByParam<(Of <<'(TControl>)>>)(FindParam) | Obsolete. Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.
Public method | AllByParam(FindParam) | Obsolete. Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


AllByParam(TControl) Method (FindParam)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByParam<(Of <(<'TControl>)>)> Method (FindParam)
Find Class See Also Send Feedback
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Find.AllByExpression<TControl>")]
public ReadOnlyCollection<TControl> AllByParam<TControl>(
    FindParam param
)
where TControl : new(), Control
Visual Basic
<ObsoleteAttribute("Use Find.AllByExpression<TControl>")> _
Public Function AllByParam(Of TControl As {New, Control}) ( _
    param As FindParam _
) As ReadOnlyCollection(Of TControl)
Visual C++
[ObsoleteAttribute(L"Use Find.AllByExpression<TControl>")]
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByParam(
    FindParam^ param
)

Parameters

param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam to match.

Type Parameters

TControl
Control type to get.

Return Value

The list of found elements.

See Also

Find Class
AllByParam Overload
ArtOfTest.WebAii.Core Namespace


AllByParam Method (FindParam)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByParam Method (FindParam)
Find Class See Also Send Feedback
Returns a list of elements that match the specified FindParam. Note that this method does not support FindParam.Type=NodePathIndex.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Find.AllByExpression")]
public ReadOnlyCollection<Element> AllByParam(
    FindParam param
)
Visual Basic
<ObsoleteAttribute("Use Find.AllByExpression")> _
Public Function AllByParam ( _
    param As FindParam _
) As ReadOnlyCollection(Of Element)
Visual C++
[ObsoleteAttribute(L"Use Find.AllByExpression")]
public:
ReadOnlyCollection<Element^>^ AllByParam(
    FindParam^ param
)

Parameters

param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam to match.

Return Value

The list of found elements.

See Also

Find Class
AllByParam Overload
ArtOfTest.WebAii.Core Namespace


AllByTagName Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByTagName Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByTagName<(Of <<'(TControl>)>>)(String) | Returns a list of elements with a specific tag name as a control collection.
Public method | AllByTagName(String) | Returns a list of elements with a specific tag name.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


AllByTagName(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByTagName<(Of <(<'TControl>)>)> Method (String)
Find Class See Also Send Feedback
Returns a list of elements with a specific tag name as a control collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<TControl> AllByTagName<TControl>(
    string tagName
)
where TControl : new(), Control
Visual Basic
Public Function AllByTagName(Of TControl As {New, Control}) ( _
    tagName As String _
) As ReadOnlyCollection(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByTagName(
    String^ tagName
)

Parameters

tagName
Type: System..::..String
The tag name.

Type Parameters

TControl
The control type to find.

Return Value

The list of found controls.

See Also

Find Class
AllByTagName Overload
ArtOfTest.WebAii.Core Namespace


AllByTagName Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByTagName Method (String)
Find Class See Also Send Feedback
Returns a list of elements with a specific tag name.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> AllByTagName(
    string tagName
)
Visual Basic
Public Function AllByTagName ( _
    tagName As String _
) As ReadOnlyCollection(Of Element)
Visual C++
public:
ReadOnlyCollection<Element^>^ AllByTagName(
    String^ tagName
)

Parameters

tagName
Type: System..::..String
The tag name to search for.

Return Value

The list of found elements.

See Also

Find Class
AllByTagName Overload
ArtOfTest.WebAii.Core Namespace


AllByXPath Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByXPath Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByXPath(String) | Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.
Public method | AllByXPath<(Of <<'(TControl>)>>)(String) | Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


AllByXPath Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByXPath Method (String)
Find Class See Also Send Feedback
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> AllByXPath(
    string xpath
)
Visual Basic
Public Function AllByXPath ( _
    xpath As String _
) As ReadOnlyCollection(Of Element)
Visual C++
public:
ReadOnlyCollection<Element^>^ AllByXPath(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The XPath string. XPath is case-sensitive.

Return Value

The list of found elements.

See Also

Find Class
AllByXPath Overload
ArtOfTest.WebAii.Core Namespace


AllByXPath(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllByXPath<(Of <(<'TControl>)>)> Method (String)
Find Class See Also Send Feedback
Returns a list of elements that match the specified XPath. This function supports the System.Xml XPath syntax.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<TControl> AllByXPath<TControl>(
    string xpath
)
where TControl : new(), Control
Visual Basic
Public Function AllByXPath(Of TControl As {New, Control}) ( _
    xpath As String _
) As ReadOnlyCollection(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
ReadOnlyCollection<TControl>^ AllByXPath(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The XPath string. XPath is case-sensitive.

Type Parameters

TControl
Control type to get.

Return Value

The list of found elements.

See Also

Find Class
AllByXPath Overload
ArtOfTest.WebAii.Core Namespace


AllControls(TControl) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllControls<(Of <(<'TControl>)>)> Method
Find Class See Also Send Feedback
Gets an IEnmerable for TControl to be used for LINQ queries. This will return only elements that are convertable to TControl

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEnumerable<TControl> AllControls<TControl>()
where TControl : new(), Control
Visual Basic
Public Function AllControls(Of TControl As {New, Control}) As IEnumerable(Of TControl)
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
IEnumerable<TControl>^ AllControls()

Type Parameters

TControl
The control type

Return Value

IEnumberable

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


AllElements Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AllElements Method
Find Class See Also Send Feedback
Gets a IEnumerable for all elements to be used for LINQ queries

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEnumerable<Element> AllElements()
Visual Basic
Public Function AllElements As IEnumerable(Of Element)
Visual C++
public:
IEnumerable<Element^>^ AllElements()

Return Value

IEnumberable

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


BuildBestFitFindExpression Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..BuildBestFitFindExpression Method
Find Class See Also Send Feedback
Generates a FindParam[] list to be used to find the specified element. The function uses an algorithm optimized for most reliable search methods and will revert back to using the tagname index as a last resort

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static HtmlFindExpression BuildBestFitFindExpression(
    Element element
)
Visual Basic
Public Shared Function BuildBestFitFindExpression ( _
    element As Element _
) As HtmlFindExpression
Visual C++
public:
static HtmlFindExpression^ BuildBestFitFindExpression(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to generate the FindParam for.

Return Value

The FindParam scheme to use to find the element. Can contain Chained FindParams

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


BuildBestFitFindParam Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..BuildBestFitFindParam Method
Find Class See Also Send Feedback
Generates a FindParam[] list to be used to find the specified element. The function uses an algorithm optimized for most reliable search methods and will revert back to using the tagname index as a last resort

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Find.BuildBestFitFindExpression instead")]
public static FindParam[] BuildBestFitFindParam(
    Element element
)
Visual Basic
<ObsoleteAttribute("Use Find.BuildBestFitFindExpression instead")> _
Public Shared Function BuildBestFitFindParam ( _
    element As Element _
) As FindParam()
Visual C++
[ObsoleteAttribute(L"Use Find.BuildBestFitFindExpression instead")]
public:
static array<FindParam^>^ BuildBestFitFindParam(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to generate the FindParam for.

Return Value

The FindParam scheme to use to find the element. Can contain Chained FindParams

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


ByAttributes Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByAttributes Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByAttributes<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Same as ByAttributes(). Returns a control type instead of element.
Public method | ByAttributes(array<String>[]()[][]) | Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByAttributes(TControl) Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByAttributes<(Of <(<'TControl>)>)> Method (array<String>[]()[][])
Find Class See Also Send Feedback
Same as ByAttributes(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByAttributes<TControl>(
    params string[] nameValuePairs
)
where TControl : new(), Control
Visual Basic
Public Function ByAttributes(Of TControl As {New, Control}) ( _
    ParamArray nameValuePairs As String() _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByAttributes(
    ... array<String^>^ nameValuePairs
)

Parameters

nameValuePairs
Type: array< System..::..String >[]()[][]
A list of name value pairs to match. For example: "bar=foo","class=myclass","src=~foo.gif","src=!bar". Use =~ for partial values or =! to exclude values.

Type Parameters

TControl
Control type to create.

Return Value

The control object.

See Also

Find Class
ByAttributes Overload
ArtOfTest.WebAii.Core Namespace


ByAttributes Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByAttributes Method (array<String>[]()[][])
Find Class See Also Send Feedback
Returns a an element that has attributes that match the NameValuePairs passed it. All matching is case-insensitive.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByAttributes(
    params string[] nameValuePairs
)
Visual Basic
Public Function ByAttributes ( _
    ParamArray nameValuePairs As String() _
) As Element
Visual C++
public:
Element^ ByAttributes(
    ... array<String^>^ nameValuePairs
)

Parameters

nameValuePairs
Type: array< System..::..String >[]()[][]
A list of name value pairs to match. For example: "bar=foo","class=myclass","src=~foo.gif","src=!bar". Use =~ for partial values or =! to exclude values.

Return Value

The found element. The function returns null if no element is found.

See Also

Find Class
ByAttributes Overload
ArtOfTest.WebAii.Core Namespace


ByContent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByContent Method
Find Class See Also Send Feedback

Overload List

Name Description
Public method ByContent(String)
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");
Public method ByContent<(Of <<'(TControl>)>>)(String)
Same as ByContent(). Returns a control type instead of element.
Public method ByContent(String, FindContentType)
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method ByContent<(Of <<'(TControl>)>>)(String, FindContentType)
Same as ByContent(). Returns a control type instead of element.
Public method ByContent(String, FindContentType, array<String>[]()[][])
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.
Public method ByContent<(Of <<'(TControl>)>>)(String, FindContentType, array<String>[]()[][])
Same as ByContent(). Returns a control type instead of element.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByContent Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByContent Method (String)
Find Class See Also Send Feedback
Returns an element by searching its TextContent. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar'
Example 1: ByContent("l:foo bar");
Example 2: ByContent("p:foo");
Example 3: ByContent("x:[*foo*]");

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByContent(
    string content
)
Visual Basic
Public Function ByContent ( _
    content As String _
) As Element
Visual C++
public:
Element^ ByContent(
    String^ content
)

Parameters

content
Type: System..::..String
The content to match

Return Value

The found element. The function returns null if no element is found

See Also

Find Class
ByContent Overload
ArtOfTest.WebAii.Core Namespace


ByContent(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByContent<(Of <(<'TControl>)>)> Method (String)
Find Class See Also Send Feedback
Same as ByContent(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByContent<TControl>(
    string content
)
where TControl : new(), Control
Visual Basic
Public Function ByContent(Of TControl As {New, Control}) ( _
    content As String _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByContent(
    String^ content
)

Parameters

content
Type: System..::..String
The content to match

Type Parameters

TControl
The control type to create.

Return Value

The control object.

See Also

Find Class
ByContent Overload
ArtOfTest.WebAii.Core Namespace


ByContent Method (String, FindContentType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByContent Method (String, FindContentType)
Find Class See Also Send Feedback
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByContent(
    string content,
    FindContentType contentType
)
Visual Basic
Public Function ByContent ( _
    content As String, _
    contentType As FindContentType _
) As Element
Visual C++
public:
Element^ ByContent(
    String^ content,
    FindContentType contentType
)

Parameters

content
Type: System..::..String
The content to match.
contentType
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to match.

Return Value

The found element. The function returns null if no element is found

See Also

Find Class
ByContent Overload
ArtOfTest.WebAii.Core Namespace


ByContent(TControl) Method (String, FindContentType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByContent<(Of <(<'TControl>)>)> Method (String, FindContentType)
Find Class See Also Send Feedback
Same as ByContent(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByContent<TControl>(
    string content,
    FindContentType contentType
)
where TControl : new(), Control
Visual Basic
Public Function ByContent(Of TControl As {New, Control}) ( _
    content As String, _
    contentType As FindContentType _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByContent(
    String^ content,
    FindContentType contentType
)

Parameters

content
Type: System..::..String
The content to match.
contentType
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to match.

Type Parameters

TControl
The control type to create.

Return Value

The control object.

See Also

Find Class
ByContent Overload
ArtOfTest.WebAii.Core Namespace


ByContent Method (String, FindContentType, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByContent Method (String, FindContentType, array<String>[]()[][])
Find Class See Also Send Feedback
Returns an element by searching its content with the options to pick the content type. (InnerText, InnerMarkup or OuterMarkup) in addition to a list of attributes. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided, the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

Similar to Find.ByContent(string) with the option to specify the content type: Example 1: ByContent("l:foo bar",FindContentType.InnerText); Example 2: ByContent("p:<foo id="f" />",FindContent.OuterMarkup);

Remarks

There is a difference between FindContentType.InnerText and FindContentType.TextContent that is worth noting: Example:
Text1
Text2
InnerText for div1 : Text1Text2 {recursive} TextContent of div1 : Text1 {non-recursive} Default for ByContent is TextContent which is the most common usage.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByContent(
    string content,
    FindContentType contentType,
    params string[] nameValuePairs
)
Visual Basic
Public Function ByContent ( _
    content As String, _
    contentType As FindContentType, _
    ParamArray nameValuePairs As String() _
) As Element
Visual C++
public:
Element^ ByContent(
    String^ content,
    FindContentType contentType,
    ... array<String^>^ nameValuePairs
)

Parameters

content
Type: System..::..String
The content to match.
contentType
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to match.
nameValuePairs
Type: array< System..::..String >[]()[][]
The attribute name/value pairs to apply.

Return Value

The found element. The function returns null if no element is found

See Also

Find Class
ByContent Overload
ArtOfTest.WebAii.Core Namespace


ByContent(TControl) Method (String, FindContentType, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByContent<(Of <(<'TControl>)>)> Method (String, FindContentType, array<String>[]()[][])
Find Class See Also Send Feedback
Same as ByContent(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByContent<TControl>(
    string content,
    FindContentType contentType,
    params string[] nameValuePairs
)
where TControl : new(), Control
Visual Basic
Public Function ByContent(Of TControl As {New, Control}) ( _
    content As String, _
    contentType As FindContentType, _
    ParamArray nameValuePairs As String() _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByContent(
    String^ content,
    FindContentType contentType,
    ... array<String^>^ nameValuePairs
)

Parameters

content
Type: System..::..String
The content to match.
contentType
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to match.
nameValuePairs
Type: array< System..::..String >[]()[][]
The attribute name/value pairs to apply.

Type Parameters

TControl
The control type to create.

Return Value

The control object.

See Also

Find Class
ByContent Overload
ArtOfTest.WebAii.Core Namespace


ByCustom Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByCustom Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByCustom<(Of <<'(TControl>)>>)(Predicate<(Of <<'(TControl>)>>)) | Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.
Public method | ByCustom(Predicate<(Of <<'(Element>)>>)) | Return the element that matches the defined predicate.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByCustom(TControl) Method (Predicate(TControl))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByCustom<(Of <(<'TControl>)>)> Method (Predicate<(Of <(<'TControl>)>)>)
Find Class See Also Send Feedback
Get a control by using custom predicate. This function will try to eliminate any elements that are not convertable to TControl type.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByCustom<TControl>(
    Predicate<TControl> predicate
)
where TControl : new(), Control
Visual Basic
Public Function ByCustom(Of TControl As {New, Control}) ( _
    predicate As Predicate(Of TControl) _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByCustom(
    Predicate<TControl>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<'TControl>)>)>
The predicate.

Type Parameters

TControl
The control type.

Return Value

The first found control.

See Also

Find Class
ByCustom Overload
ArtOfTest.WebAii.Core Namespace


ByCustom Method (Predicate(Element))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByCustom Method (Predicate<(Of <(<'Element>)>)>)
Find Class See Also Send Feedback
Return the element that matches the defined predicate.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByCustom(
    Predicate<Element> predicate
)
Visual Basic
Public Function ByCustom ( _
    predicate As Predicate(Of Element) _
) As Element
Visual C++
public:
Element^ ByCustom(
    Predicate<Element^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' Element >)>)>
The custom predicate that defines the element search.

Return Value

The element, else null.

Exceptions

Exception | Condition
ArtOfTest.WebAii.Exceptions..::..FindException | Thrown if the element was not found and ThrowIfNullOrEmpty is set.

See Also

Find Class
ByCustom Overload
ArtOfTest.WebAii.Core Namespace


ByExpression Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByExpression Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByExpression<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find element by HTML find expression strings of type TControl.
Public method | ByExpression(array<String>[]()[][]) | Find element by HTML find expression strings.
Public method | ByExpression(HtmlFindExpression) | Find element by HtmlFindExpression.
Public method | ByExpression<(Of <<'(TControl>)>>)(HtmlFindExpression) | Find element by HtmlFindExpression of type TControl.
Public method | ByExpression(HtmlFindExpression, Boolean) | Find Element by HtmlFindExpression.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByExpression(TControl) Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByExpression<(Of <(<'TControl>)>)> Method (array<String>[]()[][])
Find Class See Also Send Feedback
Find element by HTML find expression strings of type TControl.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByExpression<TControl>(
    params string[] expression
)
where TControl : new(), Control
Visual Basic
Public Function ByExpression(Of TControl As {New, Control}) ( _
    ParamArray expression As String() _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByExpression(
    ... array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]
Array of HTML find expression strings.

Type Parameters

TControl
The type of control to search for and return.

Return Value

A TControl element if found or null if not found.

See Also

Find Class
ByExpression Overload
ArtOfTest.WebAii.Core Namespace


ByExpression Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByExpression Method (array<String>[]()[][])
Find Class See Also Send Feedback
Find element by HTML find expression strings.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByExpression(
    params string[] expression
)
Visual Basic
Public Function ByExpression ( _
    ParamArray expression As String() _
) As Element
Visual C++
public:
Element^ ByExpression(
    ... array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]
Array of HTML find expression strings.

Return Value

An Element if found or null if not found.

See Also

Find Class
ByExpression Overload
ArtOfTest.WebAii.Core Namespace


ByExpression Method (HtmlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByExpression Method (HtmlFindExpression)
Find Class See Also Send Feedback
Find element by HtmlFindExpression.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByExpression(
    HtmlFindExpression expression
)
Visual Basic
Public Function ByExpression ( _
    expression As HtmlFindExpression _
) As Element
Visual C++
public:
Element^ ByExpression(
    HtmlFindExpression^ expression
)

Parameters

expression
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression to use during the find.

Return Value

An Element if found or null if not found.

See Also

Find Class
ByExpression Overload
ArtOfTest.WebAii.Core Namespace


ByExpression(TControl) Method (HtmlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByExpression<(Of <(<'TControl>)>)> Method (HtmlFindExpression)
Find Class See Also Send Feedback
Find element by HtmlFindExpression of type TControl.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByExpression<TControl>(
    HtmlFindExpression expression
)
where TControl : new(), Control
Visual Basic
Public Function ByExpression(Of TControl As {New, Control}) ( _
    expression As HtmlFindExpression _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByExpression(
    HtmlFindExpression^ expression
)

Parameters

expression
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression to use during the find.

Type Parameters

TControl
The type of control to search for and return.

Return Value

A TControl element if found or null if not found.

See Also

Find Class
ByExpression Overload
ArtOfTest.WebAii.Core Namespace


ByExpression Method (HtmlFindExpression, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByExpression Method (HtmlFindExpression, Boolean)
Find Class See Also Send Feedback
Find Element by HtmlFindExpression.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByExpression(
    HtmlFindExpression expression,
    bool includeRoot
)
Visual Basic
Public Function ByExpression ( _
    expression As HtmlFindExpression, _
    includeRoot As Boolean _
) As Element
Visual C++
public:
Element^ ByExpression(
    HtmlFindExpression^ expression,
    bool includeRoot
)

Parameters

expression
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression to use during the find.
includeRoot
Type: System..::..Boolean
Whether or not to include the root element in the search.

Return Value

An Element if found or null if not found.

See Also

Find Class
ByExpression Overload
ArtOfTest.WebAii.Core Namespace


ById Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ById Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ById(String) | Returns an element by looking for its 'id' attribute value.
Public method | ById<(Of <<'(TControl>)>>)(String) | Same as ById(). Returns a control type instead of element.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ById Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ById Method (String)
Find Class See Also Send Feedback
Returns an element by looking for its 'id' attribute value.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ById(
    string id
)
Visual Basic
Public Function ById ( _
    id As String _
) As Element
Visual C++
public:
Element^ ById(
    String^ id
)

Parameters

id
Type: System..::..String
The id value for the element to find. All searches are case-insensitive. Prefix the id with '~' for partial id searches.

Return Value

The found element. The function returns null if no element is found.

See Also

Find Class
ById Overload
ArtOfTest.WebAii.Core Namespace


ById(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ById<(Of <(<'TControl>)>)> Method (String)
Find Class See Also Send Feedback
Same as ById(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ById<TControl>(
    string id
)
where TControl : new(), Control
Visual Basic
Public Function ById(Of TControl As {New, Control}) ( _
    id As String _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ById(
    String^ id
)

Parameters

id
Type: System..::..String
The id value for the element to find. All searches are case-insensitive

Type Parameters

TControl
The control type to create.

Return Value

The control object.

See Also

Find Class
ById Overload
ArtOfTest.WebAii.Core Namespace


ByName Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByName Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByName(String) | Returns an element by searching for its 'name' attribute value
Public method | ByName<(Of <<'(TControl>)>>)(String) | Same as ByName(). Returns a control type instead of element.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByName Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByName Method (String)
Find Class See Also Send Feedback
Returns an element by searching for its 'name' attribute value

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByName(
    string name
)
Visual Basic
Public Function ByName ( _
    name As String _
) As Element
Visual C++
public:
Element^ ByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name value for the element to find. All searches as case-insensitive

Return Value

The found element. The function returns null if no element is found.

See Also

Find Class
ByName Overload
ArtOfTest.WebAii.Core Namespace


ByName(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByName<(Of <(<'TControl>)>)> Method (String)
Find Class See Also Send Feedback
Same as ByName(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByName<TControl>(
    string name
)
where TControl : new(), Control
Visual Basic
Public Function ByName(Of TControl As {New, Control}) ( _
    name As String _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name value for the element to find. All searches as case-insensitive

Type Parameters

TControl
The control type to create.

Return Value

The control object.

See Also

Find Class
ByName Overload
ArtOfTest.WebAii.Core Namespace


ByNodeIndexPath Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByNodeIndexPath Method
Find Class See Also Send Feedback

Overload List

Name Description
Public method ByNodeIndexPath<(Of <<'(TControl>)>>)(String)
Same as ByNodexIndexPath(). Returns a control type instead of element.
Public method ByNodeIndexPath(String)
Returns an element by searching for it using a node index path.

Examples

CopyC#
For example:

This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

<referenceElement>
 (0)<foo>
        <bar>
        </bar>
        <car>
        </car>
     (2)<bus>
         (0)<driver>
                <cap>
                </cap>
             (1)<target>
                </target>
            </driver>
        </bus>
    </foo>
</referenceElement>

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByNodeIndexPath(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByNodeIndexPath<(Of <(<'TControl>)>)> Method (String)
Find Class See Also Send Feedback
Same as ByNodexIndexPath(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByNodeIndexPath<TControl>(
    string nodeIndexPath
)
where TControl : new(), Control
Visual Basic
Public Function ByNodeIndexPath(Of TControl As {New, Control}) ( _
    nodeIndexPath As String _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByNodeIndexPath(
    String^ nodeIndexPath
)

Parameters

nodeIndexPath
Type: System..::..String
Node index path identifying the target element to wrap.

Type Parameters

TControl
Control type to create.

Return Value

A control of the specified type.

Exceptions

Exception | Condition
System..::..NullReferenceException | Thrown no element at the node index path.

See Also

Find Class
ByNodeIndexPath Overload
ArtOfTest.WebAii.Core Namespace


ByNodeIndexPath Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByNodeIndexPath Method (String)
Find Class See Also Send Feedback
Returns an element by searching for it using a node index path.

Examples

CopyC#
For example:

This call: ByNodeIndexPath("0/2/0/1") describes the <target></target> element in the below hierarchy:

<referenceElement>
 (0)<foo>
        <bar>
        </bar>
        <car>
        </car>
     (2)<bus>
         (0)<driver>
                <cap>
                </cap>
             (1)<target>
                </target>
            </driver>
        </bus>
    </foo>
</referenceElement>

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByNodeIndexPath(
    string nodeIndexPath
)
Visual Basic
Public Function ByNodeIndexPath ( _
    nodeIndexPath As String _
) As Element
Visual C++
public:
Element^ ByNodeIndexPath(
    String^ nodeIndexPath
)

Parameters

nodeIndexPath
Type: System..::..String
The node index path. This is a forward slash delimited list of tree node indexes that describe a specific path to a target element while ignoring the actual element tags and simply describing the hierarchal relationship to that element.

Return Value

The found element. The function returns null if no element is found.

See Also

Find Class
ByNodeIndexPath Overload
ArtOfTest.WebAii.Core Namespace


ByParam Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByParam Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByParam(FindParam) | Obsolete. Return an element using a FindParam
Public method | ByParam<(Of <<'(TControl>)>>)(FindParam) | Obsolete. Same as ByParam(). Returns a control type instead of element.
Public method | ByParam(array<FindParam>[]()[][]) | Obsolete. Returns an element using a chained identification.
Public method | ByParam<(Of <<'(TControl>)>>)(array<FindParam>[]()[][]) | Obsolete. Same as ByParam(). Returns a control type instead of element.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByParam Method (FindParam)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByParam Method (FindParam)
Find Class See Also Send Feedback
Return an element using a FindParam

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Find.ByExpression instead")]
public Element ByParam(
    FindParam param
)
Visual Basic
<ObsoleteAttribute("Use Find.ByExpression instead")> _
Public Function ByParam ( _
    param As FindParam _
) As Element
Visual C++
[ObsoleteAttribute(L"Use Find.ByExpression instead")]
public:
Element^ ByParam(
    FindParam^ param
)

Parameters

param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam that describes how to find the target element.

Return Value

The found element. The function returns null if no element is found.

See Also

Find Class
ByParam Overload
ArtOfTest.WebAii.Core Namespace


ByParam(TControl) Method (FindParam)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByParam<(Of <(<'TControl>)>)> Method (FindParam)
Find Class See Also Send Feedback
Same as ByParam(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use Find.ByExpression<T> instead")]
public TControl ByParam<TControl>(
    FindParam param
)
where TControl : new(), Control
Visual Basic
<ObsoleteAttribute("Use Find.ByExpression<T> instead")> _
Public Function ByParam(Of TControl As {New, Control}) ( _
    param As FindParam _
) As TControl
Visual C++
[ObsoleteAttribute(L"Use Find.ByExpression<T> instead")]
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByParam(
    FindParam^ param
)

Parameters

param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam that describes how to find the target element.

Type Parameters

TControl
Control type to create.

Return Value

The control object.

See Also

Find Class
ByParam Overload
ArtOfTest.WebAii.Core Namespace


ByParam Method (FindParam[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByParam Method (array<FindParam>[]()[][])
Find Class See Also Send Feedback
Returns an element using a chained identification.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Please use the HtmlFindExpressions to perform chained/piped identifications.")]
public Element ByParam(
    FindParam[] chainedParams
)
Visual Basic
<ObsoleteAttribute("Please use the HtmlFindExpressions to perform chained/piped identifications.")> _
Public Function ByParam ( _
    chainedParams As FindParam() _
) As Element
Visual C++
[ObsoleteAttribute(L"Please use the HtmlFindExpressions to perform chained/piped identifications.")]
public:
Element^ ByParam(
    array<FindParam^>^ chainedParams
)

Parameters

chainedParams
Type: array< ArtOfTest.WebAii.ObjectModel..::..FindParam >[]()[][]
An array of FindParams used to identify an element by piping the search result of each FindParam as the reference element for the FindParam that follows.

Return Value

The found element. The function returns null if no element is found.

See Also

Find Class
ByParam Overload
ArtOfTest.WebAii.Core Namespace


ByParam(TControl) Method (FindParam[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByParam<(Of <(<'TControl>)>)> Method (array<FindParam>[]()[][])
Find Class See Also Send Feedback
Same as ByParam(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Please use the HtmlFindExpressions to perform chained/piped identifications")]
public TControl ByParam<TControl>(
    FindParam[] chainedParams
)
where TControl : new(), Control
Visual Basic
<ObsoleteAttribute("Please use the HtmlFindExpressions to perform chained/piped identifications")> _
Public Function ByParam(Of TControl As {New, Control}) ( _
    chainedParams As FindParam() _
) As TControl
Visual C++
[ObsoleteAttribute(L"Please use the HtmlFindExpressions to perform chained/piped identifications")]
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByParam(
    array<FindParam^>^ chainedParams
)

Parameters

chainedParams
Type: array< ArtOfTest.WebAii.ObjectModel..::..FindParam >[]()[][]
An array of FindParams used to identify an element by piping the search result of each FindParam as the reference element for the FindParam that follows.

Type Parameters

TControl
Control type to create.

Return Value

The control object.

See Also

Find Class
ByParam Overload
ArtOfTest.WebAii.Core Namespace


ByTagIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByTagIndex Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByTagIndex(String, Int32) | Returns an element by its tag name occrrence.
Public method | ByTagIndex<(Of <<'(TControl>)>>)(String, Int32) | Same as ByTagIndex(). Returns a control type instead of element.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByTagIndex Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByTagIndex Method (String, Int32)
Find Class See Also Send Feedback
Returns an element by its tag name occrrence.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByTagIndex(
    string tagName,
    int occurrenceIndex
)
Visual Basic
Public Function ByTagIndex ( _
    tagName As String, _
    occurrenceIndex As Integer _
) As Element
Visual C++
public:
Element^ ByTagIndex(
    String^ tagName,
    int occurrenceIndex
)

Parameters

tagName
Type: System..::..String
The tag name to find.
occurrenceIndex
Type: System..::..Int32
The tag name index. This is a zero-base index.

Return Value

The found element. The function returns null if no element is found.

See Also

Find Class
ByTagIndex Overload
ArtOfTest.WebAii.Core Namespace


ByTagIndex(TControl) Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByTagIndex<(Of <(<'TControl>)>)> Method (String, Int32)
Find Class See Also Send Feedback
Same as ByTagIndex(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByTagIndex<TControl>(
    string tagName,
    int occurrenceIndex
)
where TControl : new(), Control
Visual Basic
Public Function ByTagIndex(Of TControl As {New, Control}) ( _
    tagName As String, _
    occurrenceIndex As Integer _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByTagIndex(
    String^ tagName,
    int occurrenceIndex
)

Parameters

tagName
Type: System..::..String
The tag name to find.
occurrenceIndex
Type: System..::..Int32
The tag name index. This is a zero-base index.

Type Parameters

TControl
Control type to create.

Return Value

The control object.

See Also

Find Class
ByTagIndex Overload
ArtOfTest.WebAii.Core Namespace


ByXPath Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByXPath Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByXPath(String) | Returns an element using an XPath. This function supports the System.Xml XPath syntax.
Public method | ByXPath<(Of <<'(TControl>)>>)(String) | Same as ByXPath(). Returns a control type instead of element.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


ByXPath Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByXPath Method (String)
Find Class See Also Send Feedback
Returns an element using an XPath. This function supports the System.Xml XPath syntax.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element ByXPath(
    string xpath
)
Visual Basic
Public Function ByXPath ( _
    xpath As String _
) As Element
Visual C++
public:
Element^ ByXPath(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The XPath string. XPath is case-sensitive.

Return Value

The found element. The function returns null if no element is found.

See Also

Find Class
ByXPath Overload
ArtOfTest.WebAii.Core Namespace


ByXPath(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ByXPath<(Of <(<'TControl>)>)> Method (String)
Find Class See Also Send Feedback
Same as ByXPath(). Returns a control type instead of element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl ByXPath<TControl>(
    string xpath
)
where TControl : new(), Control
Visual Basic
Public Function ByXPath(Of TControl As {New, Control}) ( _
    xpath As String _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl ByXPath(
    String^ xpath
)

Parameters

xpath
Type: System..::..String
The XPath string. XPath is case-sensitive.

Type Parameters

TControl
The control type to create.

Return Value

The control object.

See Also

Find Class
ByXPath Overload
ArtOfTest.WebAii.Core Namespace


FromCollection Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..FromCollection Method
Find Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FromCollection(FindParamCollection) | Obsolete. Finds all elements with the FindParams in the passed in collection.
Public method | FromCollection(FindExpressionCollection<(Of <<'(HtmlFindExpression>)>>)) | Finds all elements with the HtmlFindExpressions in the collection.

See Also

Find Class
Find Members
ArtOfTest.WebAii.Core Namespace


FromCollection Method (FindParamCollection)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..FromCollection Method (FindParamCollection)
Find Class See Also Send Feedback
Finds all elements with the FindParams in the passed in collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Please use the FromCollection(FindExpressionsCollection<>) instead")]
public IDictionary<string, Element> FromCollection(
    FindParamCollection collection
)
Visual Basic
<ObsoleteAttribute("Please use the FromCollection(FindExpressionsCollection<>) instead")> _
Public Function FromCollection ( _
    collection As FindParamCollection _
) As IDictionary(Of String, Element)
Visual C++
[ObsoleteAttribute(L"Please use the FromCollection(FindExpressionsCollection<>) instead")]
public:
IDictionary<String^, Element^>^ FromCollection(
    FindParamCollection^ collection
)

Parameters

collection
Type: ArtOfTest.WebAii.ObjectModel..::..FindParamCollection
The collection of all the FindParams

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Find.FromCollection(ArtOfTest.WebAii.ObjectModel.FindParamCollection)"]

Remarks

If ThrowIfNullOrEmpty is true, this function will throw if an element is not found. If ThrowIfNullOrEmpty is false, this function will not add and element that we not found.

See Also

Find Class
FromCollection Overload
ArtOfTest.WebAii.Core Namespace


FromCollection Method (FindExpressionCollection(HtmlFindExpression))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..FromCollection Method (FindExpressionCollection<(Of <(<'HtmlFindExpression>)>)>)
Find Class See Also Send Feedback
Finds all elements with the HtmlFindExpressions in the collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IDictionary<string, Element> FromCollection(
    FindExpressionCollection<HtmlFindExpression> collection
)
Visual Basic
Public Function FromCollection ( _
    collection As FindExpressionCollection(Of HtmlFindExpression) _
) As IDictionary(Of String, Element)
Visual C++
public:
IDictionary<String^, Element^>^ FromCollection(
    FindExpressionCollection<HtmlFindExpression^>^ collection
)

Parameters

collection
Type: ArtOfTest.WebAii.ObjectModel..::..FindExpressionCollection <(Of <(<' HtmlFindExpression >)>)>
The HtmlFindExpressions

Return Value

The elements found

Remarks

If ThrowIfNullOrEmpty is true, this function will throw if an element is not found. If ThrowIfNullOrEmpty is false, this function will not add and element that we not found.

See Also

Find Class
FromCollection Overload
ArtOfTest.WebAii.Core Namespace


FromExpressionsFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..FromExpressionsFile Method
Find Class See Also Send Feedback
Finds all elements with FindExpressions defined in a file.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IDictionary<string, Element> FromExpressionsFile(
    string fileName
)
Visual Basic
Public Function FromExpressionsFile ( _
    fileName As String _
) As IDictionary(Of String, Element)
Visual C++
public:
IDictionary<String^, Element^>^ FromExpressionsFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The filename where all the FindParams are defined.

Return Value

The collection of found elements in a dictionary with the key being the key defined in the file

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


FromExpressionsXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..FromExpressionsXml Method
Find Class See Also Send Feedback
Finds all elements with FindExpressions defined in the serialized xml string.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IDictionary<string, Element> FromExpressionsXml(
    string xml
)
Visual Basic
Public Function FromExpressionsXml ( _
    xml As String _
) As IDictionary(Of String, Element)
Visual C++
public:
IDictionary<String^, Element^>^ FromExpressionsXml(
    String^ xml
)

Parameters

xml
Type: System..::..String
The xml with the expressions defined.

Return Value

The collection of found elements in a dictionary with the key being the key defined in the xml

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


FromFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..FromFile Method
Find Class See Also Send Feedback
Finds all elements with FindParams defined in a file.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use the FromExpressionsFile instead")]
public IDictionary<string, Element> FromFile(
    string fileName
)
Visual Basic
<ObsoleteAttribute("Use the FromExpressionsFile instead")> _
Public Function FromFile ( _
    fileName As String _
) As IDictionary(Of String, Element)
Visual C++
[ObsoleteAttribute(L"Use the FromExpressionsFile instead")]
public:
IDictionary<String^, Element^>^ FromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The filename where all the FindParams are defined.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Find.FromFile(System.String)"]

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


FromXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..FromXml Method
Find Class See Also Send Feedback
Finds all elements with FindParams defined in the serialized xml string. Found elements can be accessed from Find.Elements

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use the FromExpressionsXml instead")]
public IDictionary<string, Element> FromXml(
    string xml
)
Visual Basic
<ObsoleteAttribute("Use the FromExpressionsXml instead")> _
Public Function FromXml ( _
    xml As String _
) As IDictionary(Of String, Element)
Visual C++
[ObsoleteAttribute(L"Use the FromExpressionsXml instead")]
public:
IDictionary<String^, Element^>^ FromXml(
    String^ xml
)

Parameters

xml
Type: System..::..String
The xml string that describes the FindParams collection.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Find.FromXml(System.String)"]

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


Find Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find Properties
Find Class See Also Send Feedback

The Find type exposes the following members.

Properties

 | Name | Description
Public property | AssociatedBrowser | Gets the browser object that is associated with this find object. If this property is null, then the Find object is associated with a search region.
Public property | FindReferenceType | Gets the reference type that this Find object is using. (i.e. browser root, testregion ... etc)
Public property | IgnoreFindAllControlMismatch | Gets/Sets whether to ignore Find.Allxx<TControl>(...) elements that don't match the TControl specified. (i.e. the TControl type validation fails for that element). If false, the Find.Allxx method will throw an exception.
Public property | LastFindParam | Gets the last FindParam used to search.
Public property | LastSearchLog | Gets the search log for the last find attempt. This log can help diagnose when find fails to locate an element.
Public property | SearchRegion | Gets the search region for this Find object. When this is set to a specific region, all search is done locale to that region. All indexes are calculated starting at zero from this region's element. If this property is null, then the Find object will perform all searches from the document root element.
Public property | SearchRootElement | Gets/Sets the root element that all searches will be performed under. This element depended on the reference type. [Browser/TestRegion/Element].
Public property | ThrowIfNullOrEmpty | Gets/Sets whether to throw an exception if any of the find methods returns a null element or any of the find all methods return empty list of elements.

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


AssociatedBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..AssociatedBrowser Property
Find Class See Also Send Feedback
Gets the browser object that is associated with this find object. If this property is null, then the Find object is associated with a search region.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser AssociatedBrowser { get; }
Visual Basic
Public ReadOnly Property AssociatedBrowser As Browser
    Get
Visual C++
public:
property Browser^ AssociatedBrowser {
    Browser^ get ();
}

Remarks

Either Find.SearchRegion or Find.AssociatedBrowser is null. Both can't be null and both can't be set.

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


FindReferenceType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..FindReferenceType Property
Find Class See Also Send Feedback
Gets the reference type that this Find object is using. (i.e. browser root, testregion ... etc)

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindReferenceType FindReferenceType { get; }
Visual Basic
Public ReadOnly Property FindReferenceType As FindReferenceType
    Get
Visual C++
public:
property FindReferenceType FindReferenceType {
    FindReferenceType get ();
}

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


IgnoreFindAllControlMismatch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..IgnoreFindAllControlMismatch Property
Find Class See Also Send Feedback
Gets/Sets whether to ignore Find.Allxx<TControl>(...) elements that don't match the TControl specified. (i.e. the TControl type validation fails for that element). If false, the Find.Allxx method will throw an exception.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IgnoreFindAllControlMismatch { get; set; }
Visual Basic
Public Property IgnoreFindAllControlMismatch As Boolean
    Get
    Set
Visual C++
public:
property bool IgnoreFindAllControlMismatch {
    bool get ();
    void set (bool value);
}

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


LastFindParam Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..LastFindParam Property
Find Class See Also Send Feedback
Gets the last FindParam used to search.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam LastFindParam { get; }
Visual Basic
Public ReadOnly Property LastFindParam As FindParam
    Get
Visual C++
public:
property FindParam^ LastFindParam {
    FindParam^ get ();
}

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


LastSearchLog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..LastSearchLog Property
Find Class See Also Send Feedback
Gets the search log for the last find attempt. This log can help diagnose when find fails to locate an element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string LastSearchLog { get; }
Visual Basic
Public ReadOnly Property LastSearchLog As String
    Get
Visual C++
public:
property String^ LastSearchLog {
    String^ get ();
}

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


SearchRegion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..SearchRegion Property
Find Class See Also Send Feedback
Gets the search region for this Find object. When this is set to a specific region, all search is done locale to that region. All indexes are calculated starting at zero from this region's element. If this property is null, then the Find object will perform all searches from the document root element.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestRegion SearchRegion { get; }
Visual Basic
Public ReadOnly Property SearchRegion As TestRegion
    Get
Visual C++
public:
property TestRegion^ SearchRegion {
    TestRegion^ get ();
}

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


SearchRootElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..SearchRootElement Property
Find Class See Also Send Feedback
Gets/Sets the root element that all searches will be performed under. This element depended on the reference type. [Browser/TestRegion/Element].

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element SearchRootElement { get; }
Visual Basic
Public ReadOnly Property SearchRootElement As Element
    Get
Visual C++
public:
property Element^ SearchRootElement {
    Element^ get ();
}

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


ThrowIfNullOrEmpty Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ThrowIfNullOrEmpty Property
Find Class See Also Send Feedback
Gets/Sets whether to throw an exception if any of the find methods returns a null element or any of the find all methods return empty list of elements.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ThrowIfNullOrEmpty { get; set; }
Visual Basic
Public Property ThrowIfNullOrEmpty As Boolean
    Get
    Set
Visual C++
public:
property bool ThrowIfNullOrEmpty {
    bool get ();
    void set (bool value);
}

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


Find Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find Events
Find Class See Also Send Feedback

The Find type exposes the following members.

Events

 | Name | Description
Public event | ReturnedNullOrEmpty | Invoked when one of the find methods returns null or an empty list of elements.

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


ReturnedNullOrEmpty Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Find..::..ReturnedNullOrEmpty Event
Find Class See Also Send Feedback
Invoked when one of the find methods returns null or an empty list of elements.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<ReturnedNullOrEmptyEventArgs> ReturnedNullOrEmpty
Visual Basic
Public Event ReturnedNullOrEmpty As EventHandler(Of ReturnedNullOrEmptyEventArgs)
Visual C++
public:
 event EventHandler<ReturnedNullOrEmptyEventArgs^>^ ReturnedNullOrEmpty {
    void add (EventHandler<ReturnedNullOrEmptyEventArgs^>^ value);
    void remove (EventHandler<ReturnedNullOrEmptyEventArgs^>^ value);
}

See Also

Find Class
ArtOfTest.WebAii.Core Namespace


FrameInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Members
FrameInfo Class Constructors Methods Properties Events See Also Send Feedback

The FrameInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FrameInfo()()()() | Create a new FrameInfo object.
Public method | FrameInfo(String, String, String, Int32) | Create a new FrameInfo object.
Public method | FrameInfo(String, String, String, String, Int32, Boolean) | Create a new FrameInfo object.
Public method | FrameInfo(String, String, String, String, Int32, Boolean, Boolean) | Initializes a new instance of the FrameInfo class

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines if two FrameInfo objects are equal. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Get hash code of this FrameInfo object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetIndexer | Get the set indexer on this FrameInfo
Public method | GetRectangle | Returns this Frame's Rectangle in screen coordinates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | String representation of the frame info. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | BaseURL | The frame's src value. Used only if id/name is not set.
Public property | Id | Get frame id.
Public property | Index | Get frame index.
Public property | Name | Get frame name.
Public property | Query | The frame's query part of the src value. Used only if id/name is not set.
Public property | Rectangle | The last rectangle value using GetRectangle();
Public property | Src | The frame's src value. Used only if id/name is not set.
Public property | UniqueId | Gets the unique id of the frame for that session. Note: This property is not garanteed to be the same between requests to the same page so it shouldn't be serialized as part of this frame's information. This is an IE specific property.
Public property | UseQuery | Whether or not to include the query string when comparing the src string.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property on the FrameInfo object changes.

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


FrameInfo Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Constructor
FrameInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FrameInfo()()()() | Create a new FrameInfo object.
Public method | FrameInfo(String, String, String, Int32) | Create a new FrameInfo object.
Public method | FrameInfo(String, String, String, String, Int32, Boolean) | Create a new FrameInfo object.
Public method | FrameInfo(String, String, String, String, Int32, Boolean, Boolean) | Initializes a new instance of the FrameInfo class

See Also

FrameInfo Class
FrameInfo Members
ArtOfTest.WebAii.Core Namespace


FrameInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Constructor
FrameInfo Class See Also Send Feedback
Create a new FrameInfo object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameInfo()
Visual Basic
Public Sub New
Visual C++
public:
FrameInfo()

See Also

FrameInfo Class
FrameInfo Overload
ArtOfTest.WebAii.Core Namespace


FrameInfo Constructor (String, String, String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Constructor (String, String, String, Int32)
FrameInfo Class See Also Send Feedback
Create a new FrameInfo object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameInfo(
    string id,
    string name,
    string src,
    int index
)
Visual Basic
Public Sub New ( _
    id As String, _
    name As String, _
    src As String, _
    index As Integer _
)
Visual C++
public:
FrameInfo(
    String^ id,
    String^ name,
    String^ src,
    int index
)

Parameters

id
Type: System..::..String
The Frame's id.
name
Type: System..::..String
The Frame's name.
src
Type: System..::..String
The Frame's src.
index
Type: System..::..Int32
The Frame's index.

See Also

FrameInfo Class
FrameInfo Overload
ArtOfTest.WebAii.Core Namespace


FrameInfo Constructor (String, String, String, String, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Constructor (String, String, String, String, Int32, Boolean)
FrameInfo Class See Also Send Feedback
Create a new FrameInfo object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameInfo(
    string id,
    string name,
    string baseURL,
    string query,
    int index,
    bool useQuery
)
Visual Basic
Public Sub New ( _
    id As String, _
    name As String, _
    baseURL As String, _
    query As String, _
    index As Integer, _
    useQuery As Boolean _
)
Visual C++
public:
FrameInfo(
    String^ id,
    String^ name,
    String^ baseURL,
    String^ query,
    int index,
    bool useQuery
)

Parameters

id
Type: System..::..String
The Frame's id.
name
Type: System..::..String
The Frame's name.
baseURL
Type: System..::..String
The base URL of the frame's src attribute.
query
Type: System..::..String
The query part of the frame's src attribute.
index
Type: System..::..Int32
The Frame's index.
useQuery
Type: System..::..Boolean
Whether or not to compare the query part when comparing FrameInfo objects.

See Also

FrameInfo Class
FrameInfo Overload
ArtOfTest.WebAii.Core Namespace


FrameInfo Constructor (String, String, String, String, Int32, Boolean, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Constructor (String, String, String, String, Int32, Boolean, Boolean)
FrameInfo Class See Also Send Feedback
Initializes a new instance of the FrameInfo class

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameInfo(
    string id,
    string name,
    string baseURL,
    string query,
    int index,
    bool useQuery,
    bool usesBaseUrlHost
)
Visual Basic
Public Sub New ( _
    id As String, _
    name As String, _
    baseURL As String, _
    query As String, _
    index As Integer, _
    useQuery As Boolean, _
    usesBaseUrlHost As Boolean _
)
Visual C++
public:
FrameInfo(
    String^ id,
    String^ name,
    String^ baseURL,
    String^ query,
    int index,
    bool useQuery,
    bool usesBaseUrlHost
)

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.#ctor(System.String,System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean)"]

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.#ctor(System.String,System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean)"]

baseURL
Type: System..::..String

[Missing <param name="baseURL"/> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.#ctor(System.String,System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean)"]

query
Type: System..::..String

[Missing <param name="query"/> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.#ctor(System.String,System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean)"]

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.#ctor(System.String,System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean)"]

useQuery
Type: System..::..Boolean

[Missing <param name="useQuery"/> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.#ctor(System.String,System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean)"]

usesBaseUrlHost
Type: System..::..Boolean

[Missing <param name="usesBaseUrlHost"/> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.#ctor(System.String,System.String,System.String,System.String,System.Int32,System.Boolean,System.Boolean)"]

See Also

FrameInfo Class
FrameInfo Overload
ArtOfTest.WebAii.Core Namespace


FrameInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Methods
FrameInfo Class See Also Send Feedback

The FrameInfo type exposes the following members.

Methods

 | Name | Description
Public method | Clone |
Public method | Equals | Determines if two FrameInfo objects are equal. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Get hash code of this FrameInfo object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetIndexer | Get the set indexer on this FrameInfo
Public method | GetRectangle | Returns this Frame's Rectangle in screen coordinates.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | String representation of the frame info. (Overrides Object..::..ToString()()()().)

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


Clone Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..Clone Method
FrameInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.Clone"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.FrameInfo.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


Equals Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..Equals Method
FrameInfo Class See Also Send Feedback
Determines if two FrameInfo objects are equal.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to comapre to.

Return Value

True/False whether the two objects are equal.

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


GetHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..GetHashCode Method
FrameInfo Class See Also Send Feedback
Get hash code of this FrameInfo object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The hash code.

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


GetIndexer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..GetIndexer Method
FrameInfo Class See Also Send Feedback
Get the set indexer on this FrameInfo

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object GetIndexer(
    out string frameFindParamParameter
)
Visual Basic
Public Function GetIndexer ( _
    <OutAttribute> ByRef frameFindParamParameter As String _
) As Object
Visual C++
public:
Object^ GetIndexer(
    [OutAttribute] String^% frameFindParamParameter
)

Parameters

frameFindParamParameter
Type: System..::..String %
Returns the index type being used to locate this IFrame.

Return Value

The value of index used to locate this IFrame.

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


GetRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..GetRectangle Method
FrameInfo Class See Also Send Feedback
Returns this Frame's Rectangle in screen coordinates.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle GetRectangle()
Visual Basic
Public Function GetRectangle As Rectangle
Visual C++
public:
Rectangle GetRectangle()

Return Value

The frame's rectangular screen coordinates.

Exceptions

Exception | Condition
System..::..ArithmeticException | Thrown when we can't get the rectangle coordinates of a Frame from the browser.

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..ToString Method
FrameInfo Class See Also Send Feedback
String representation of the frame info.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string.

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


FrameInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Properties
FrameInfo Class See Also Send Feedback

The FrameInfo type exposes the following members.

Properties

 | Name | Description
Public property | BaseURL | The frame's src value. Used only if id/name is not set.
Public property | Id | Get frame id.
Public property | Index | Get frame index.
Public property | Name | Get frame name.
Public property | Query | The frame's query part of the src value. Used only if id/name is not set.
Public property | Rectangle | The last rectangle value using GetRectangle();
Public property | Src | The frame's src value. Used only if id/name is not set.
Public property | UniqueId | Gets the unique id of the frame for that session. Note: This property is not garanteed to be the same between requests to the same page so it shouldn't be serialized as part of this frame's information. This is an IE specific property.
Public property | UseQuery | Whether or not to include the query string when comparing the src string.

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


BaseURL Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..BaseURL Property
FrameInfo Class See Also Send Feedback
The frame's src value. Used only if id/name is not set.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string BaseURL { get; set; }
Visual Basic
Public Property BaseURL As String
    Get
    Set
Visual C++
public:
property String^ BaseURL {
    String^ get ();
    void set (String^ value);
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


Id Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..Id Property
FrameInfo Class See Also Send Feedback
Get frame id.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


Index Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..Index Property
FrameInfo Class See Also Send Feedback
Get frame index.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..Name Property
FrameInfo Class See Also Send Feedback
Get frame name.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


Query Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..Query Property
FrameInfo Class See Also Send Feedback
The frame's query part of the src value. Used only if id/name is not set.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Query { get; set; }
Visual Basic
Public Property Query As String
    Get
    Set
Visual C++
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


Rectangle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..Rectangle Property
FrameInfo Class See Also Send Feedback
The last rectangle value using GetRectangle();

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle Rectangle { get; }
Visual Basic
Public ReadOnly Property Rectangle As Rectangle
    Get
Visual C++
public:
property Rectangle Rectangle {
    Rectangle get ();
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


Src Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..Src Property
FrameInfo Class See Also Send Feedback
The frame's src value. Used only if id/name is not set.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Src { get; set; }
Visual Basic
Public Property Src As String
    Get
    Set
Visual C++
public:
property String^ Src {
    String^ get ();
    void set (String^ value);
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


UniqueId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..UniqueId Property
FrameInfo Class See Also Send Feedback
Gets the unique id of the frame for that session. Note: This property is not garanteed to be the same between requests to the same page so it shouldn't be serialized as part of this frame's information. This is an IE specific property.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UniqueId { get; }
Visual Basic
Public ReadOnly Property UniqueId As String
    Get
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


UseQuery Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..UseQuery Property
FrameInfo Class See Also Send Feedback
Whether or not to include the query string when comparing the src string.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool UseQuery { get; set; }
Visual Basic
Public Property UseQuery As Boolean
    Get
    Set
Visual C++
public:
property bool UseQuery {
    bool get ();
    void set (bool value);
}

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


FrameInfo Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo Events
FrameInfo Class See Also Send Feedback

The FrameInfo type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property on the FrameInfo object changes.

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


PropertyChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameInfo..::..PropertyChanged Event
FrameInfo Class See Also Send Feedback
Occurs when a property on the FrameInfo object changes.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

FrameInfo Class
ArtOfTest.WebAii.Core Namespace


FramesCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection Members
FramesCollection Class Constructors Methods Properties See Also Send Feedback

The FramesCollection type exposes the following members.

Constructors

 | Name | Description
Public method | FramesCollection | Initializes a new instance of the FramesCollection class

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | ById | Gets a frame using its id.
Public method | BySrc | Gets a frame using its src
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get the enumerator.
Public method | GetFramesAsStrings | Get a list of all frames in this collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | RefreshAllDomTrees | Refresh all dom trees in this frames collection.
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | WaitAllUntilReady | Waits until all frames are ready.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public property | Item[([( Int32])]) | Get the frame at a specific index.
Public property | Item[([( String])]) | Get a frame using its name.
Public property | Item[([( FrameInfo])]) | Get the frame based on its FrameInfo.
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


FramesCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection Constructor
FramesCollection Class See Also Send Feedback
Initializes a new instance of the FramesCollection class

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FramesCollection()
Visual Basic
Public Sub New
Visual C++
public:
FramesCollection()

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


FramesCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection Methods
FramesCollection Class See Also Send Feedback

The FramesCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | ById | Gets a frame using its id.
Public method | BySrc | Gets a frame using its src
Public method | Clear | Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | ContainsKey | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | ContainsValue | Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Get the enumerator.
Public method | GetFramesAsStrings | Get a list of all frames in this collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | RefreshAllDomTrees | Refresh all dom trees in this frames collection.
Public method | Remove | Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public method | WaitAllUntilReady | Waits until all frames are ready.

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


ById Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..ById Method
FramesCollection Class See Also Send Feedback
Gets a frame using its id.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser ById(
    string frameid
)
Visual Basic
Public Function ById ( _
    frameid As String _
) As Browser
Visual C++
public:
Browser^ ById(
    String^ frameid
)

Parameters

frameid
Type: System..::..String
The frame id to find. (prefix with '~' to indicate partial string)

Return Value

The frame Browser object or else null.

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


BySrc Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..BySrc Method
FramesCollection Class See Also Send Feedback
Gets a frame using its src

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser BySrc(
    string src
)
Visual Basic
Public Function BySrc ( _
    src As String _
) As Browser
Visual C++
public:
Browser^ BySrc(
    String^ src
)

Parameters

src
Type: System..::..String
The src value to search for. (prefix with '~' to indicate partial string)

Return Value

The frame Browser object or else null.

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


GetEnumerator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..GetEnumerator Method
FramesCollection Class See Also Send Feedback
Get the enumerator.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEnumerator<Browser> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of Browser)
Visual C++
public:
virtual IEnumerator<Browser^>^ GetEnumerator() sealed

Return Value

This collection's enumerator

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


GetFramesAsStrings Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..GetFramesAsStrings Method
FramesCollection Class See Also Send Feedback
Get a list of all frames in this collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetFramesAsStrings()
Visual Basic
Public Function GetFramesAsStrings As String
Visual C++
public:
String^ GetFramesAsStrings()

Return Value

A description of all frames contained in this collection as a string.

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


RefreshAllDomTrees Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..RefreshAllDomTrees Method
FramesCollection Class See Also Send Feedback
Refresh all dom trees in this frames collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RefreshAllDomTrees()
Visual Basic
Public Sub RefreshAllDomTrees
Visual C++
public:
void RefreshAllDomTrees()

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


WaitAllUntilReady Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..WaitAllUntilReady Method
FramesCollection Class See Also Send Feedback
Waits until all frames are ready.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitAllUntilReady()
Visual Basic
Public Sub WaitAllUntilReady
Visual C++
public:
void WaitAllUntilReady()

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


FramesCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection Properties
FramesCollection Class See Also Send Feedback

The FramesCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public property | Item[([( Int32])]) | Get the frame at a specific index.
Public property | Item[([( String])]) | Get a frame using its name.
Public property | Item[([( FrameInfo])]) | Get the frame based on its FrameInfo.
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, Browser >)>)>.)

See Also

FramesCollection Class
ArtOfTest.WebAii.Core Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..Item Property
FramesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Get the frame at a specific index.
Public property | Item[([( String])]) | Get a frame using its name.
Public property | Item[([( FrameInfo])]) | Get the frame based on its FrameInfo.

See Also

FramesCollection Class
FramesCollection Members
ArtOfTest.WebAii.Core Namespace


Item Property (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..Item Property (Int32)
FramesCollection Class See Also Send Feedback
Get the frame at a specific index.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Browser
    Get
Visual C++
public:
property Browser^ default[int index] {
    Browser^ get (int index);
}

Parameters

index
Type: System..::..Int32
The frame index.

Return Value

The frame object.

See Also

FramesCollection Class
Item Overload
ArtOfTest.WebAii.Core Namespace


Item Property (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..Item Property (String)
FramesCollection Class See Also Send Feedback
Get a frame using its name.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As Browser
    Get
Visual C++
public:
property Browser^ default[String^ name] {
    Browser^ get (String^ name);
}

Parameters

name
Type: System..::..String
The frame name. (prefix with '~' to indicate partial string)

Return Value

A frame if matching name found, otherwise 'null'.

See Also

FramesCollection Class
Item Overload
ArtOfTest.WebAii.Core Namespace


Item Property (FrameInfo)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FramesCollection..::..Item Property (FrameInfo)
FramesCollection Class See Also Send Feedback
Get the frame based on its FrameInfo.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser this[
    FrameInfo frameInfo
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    frameInfo As FrameInfo _
) As Browser
    Get
Visual C++
public:
property Browser^ default[FrameInfo^ frameInfo] {
    Browser^ get (FrameInfo^ frameInfo);
}

Parameters

frameInfo
Type: ArtOfTest.WebAii.Core..::..FrameInfo
The frameinfo.

Return Value

The Frame, else null.

Remarks

If more than one frame in the FrameCollection matches the FrameInfo argument, we will return the frame that matches frameInfo.Index.

See Also

FramesCollection Class
Item Overload
ArtOfTest.WebAii.Core Namespace


HtmlFindClause Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause Members
HtmlFindClause Class Constructors Methods Properties See Also Send Feedback

The HtmlFindClause type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlFindClause()()()() | Create a new FindClause.
Public method | HtmlFindClause(String) | Create a new FindClause

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractValue | Extract the actual value for the search type passed in. (Overrides FindClause..::..ExtractValue(String, ITargetElement).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateHtmlPath(ITargetElement) |
 | GenerateHtmlPath(ITargetElement, ITargetElement) |
 | GenerateNodeIndexPath |
 | GenerateXPath(ITargetElement) |
 | GenerateXPath(ITargetElement, ITargetElement) | Generate a backup xpath using an element
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTagIndexFromParent |
 | GetTagIndexInChildren | Get a child index within a parent only.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match(ITargetElement) | (Overrides FindClause..::..Match(ITargetElement).)
Public method | Match(ITargetElement, ITargetElement) | Match an element (Overrides FindClause..::..Match(ITargetElement, ITargetElement).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnParsed | Perform Html specific parameter parsing. (Overrides FindClause..::..OnParsed()()()().)
Public method | ToString | Return the string representation of this expression. (Inherited from FindClause.)

Properties

 | Name | Description
Public property | Clause | Gets or sets the search expression. On setting the value, the expression will be parsed. (Inherited from FindClause.)
Public property | CompareType | Gets the expression compare type. (Inherited from FindClause.)
Public property | IsHierarchical | Gets whether this search clause is relative to the root of the search. (Inherited from FindClause.)
Public property | Name | Gets the name part of the expression. (Inherited from FindClause.)
Public property | Priority | Gets the search priority of this clause. 0 is the highest. 10 lowest. (Inherited from FindClause.)
Public property | SearchType | Get the search type
Public property | TagIndex | Get the tag index
Public property | TagName | Get the tag name.
Public property | Value | Gets the value part of the expression. (Inherited from FindClause.)

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


HtmlFindClause Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause Constructor
HtmlFindClause Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlFindClause()()()() | Create a new FindClause.
Public method | HtmlFindClause(String) | Create a new FindClause

See Also

HtmlFindClause Class
HtmlFindClause Members
ArtOfTest.WebAii.Core Namespace


HtmlFindClause Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause Constructor
HtmlFindClause Class See Also Send Feedback
Create a new FindClause.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlFindClause()
Visual Basic
Public Sub New
Visual C++
public:
HtmlFindClause()

See Also

HtmlFindClause Class
HtmlFindClause Overload
ArtOfTest.WebAii.Core Namespace


HtmlFindClause Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause Constructor (String)
HtmlFindClause Class See Also Send Feedback
Create a new FindClause

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlFindClause(
    string expression
)
Visual Basic
Public Sub New ( _
    expression As String _
)
Visual C++
public:
HtmlFindClause(
    String^ expression
)

Parameters

expression
Type: System..::..String
The find expression to use.

See Also

HtmlFindClause Class
HtmlFindClause Overload
ArtOfTest.WebAii.Core Namespace


HtmlFindClause Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause Methods
HtmlFindClause Class See Also Send Feedback

The HtmlFindClause type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractValue | Extract the actual value for the search type passed in. (Overrides FindClause..::..ExtractValue(String, ITargetElement).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateHtmlPath(ITargetElement) |
 | GenerateHtmlPath(ITargetElement, ITargetElement) |
 | GenerateNodeIndexPath |
 | GenerateXPath(ITargetElement) |
 | GenerateXPath(ITargetElement, ITargetElement) | Generate a backup xpath using an element
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTagIndexFromParent |
 | GetTagIndexInChildren | Get a child index within a parent only.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match(ITargetElement) | (Overrides FindClause..::..Match(ITargetElement).)
Public method | Match(ITargetElement, ITargetElement) | Match an element (Overrides FindClause..::..Match(ITargetElement, ITargetElement).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnParsed | Perform Html specific parameter parsing. (Overrides FindClause..::..OnParsed()()()().)
Public method | ToString | Return the string representation of this expression. (Inherited from FindClause.)

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


ExtractValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..ExtractValue Method
HtmlFindClause Class See Also Send Feedback
Extract the actual value for the search type passed in.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ExtractValue(
    string searchType,
    ITargetElement target
)
Visual Basic
Public Overrides Function ExtractValue ( _
    searchType As String, _
    target As ITargetElement _
) As String
Visual C++
public:
virtual String^ ExtractValue(
    String^ searchType,
    ITargetElement^ target
) override

Parameters

searchType
Type: System..::..String
The search type.
target
Type: ArtOfTest.Common..::..ITargetElement
The target element

Return Value

The actual value

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


GenerateHtmlPath Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GenerateHtmlPath Method
HtmlFindClause Class See Also Send Feedback

Overload List

Name | Description
GenerateHtmlPath(ITargetElement) |
GenerateHtmlPath(ITargetElement, ITargetElement) |

See Also

HtmlFindClause Class
HtmlFindClause Members
ArtOfTest.WebAii.Core Namespace


GenerateHtmlPath Method (ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GenerateHtmlPath Method (ITargetElement)
HtmlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateHtmlPath(ArtOfTest.Common.ITargetElement)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GenerateHtmlPath(
    ITargetElement element
)
Visual Basic
Public Shared Function GenerateHtmlPath ( _
    element As ITargetElement _
) As String
Visual C++
public:
static String^ GenerateHtmlPath(
    ITargetElement^ element
)

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateHtmlPath(ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateHtmlPath(ArtOfTest.Common.ITargetElement)"]

See Also

HtmlFindClause Class
GenerateHtmlPath Overload
ArtOfTest.WebAii.Core Namespace


GenerateHtmlPath Method (ITargetElement, ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GenerateHtmlPath Method (ITargetElement, ITargetElement)
HtmlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateHtmlPath(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GenerateHtmlPath(
    ITargetElement element,
    ITargetElement parent
)
Visual Basic
Public Shared Function GenerateHtmlPath ( _
    element As ITargetElement, _
    parent As ITargetElement _
) As String
Visual C++
public:
static String^ GenerateHtmlPath(
    ITargetElement^ element,
    ITargetElement^ parent
)

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateHtmlPath(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

parent
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="parent"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateHtmlPath(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateHtmlPath(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

See Also

HtmlFindClause Class
GenerateHtmlPath Overload
ArtOfTest.WebAii.Core Namespace


GenerateNodeIndexPath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GenerateNodeIndexPath Method
HtmlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateNodeIndexPath(ArtOfTest.Common.ITargetElement)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GenerateNodeIndexPath(
    ITargetElement element
)
Visual Basic
Public Shared Function GenerateNodeIndexPath ( _
    element As ITargetElement _
) As String
Visual C++
public:
static String^ GenerateNodeIndexPath(
    ITargetElement^ element
)

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateNodeIndexPath(ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateNodeIndexPath(ArtOfTest.Common.ITargetElement)"]

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


GenerateXPath Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GenerateXPath Method
HtmlFindClause Class See Also Send Feedback

Overload List

Name | Description
GenerateXPath(ITargetElement) |
GenerateXPath(ITargetElement, ITargetElement) | Generate a backup xpath using an element

See Also

HtmlFindClause Class
HtmlFindClause Members
ArtOfTest.WebAii.Core Namespace


GenerateXPath Method (ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GenerateXPath Method (ITargetElement)
HtmlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateXPath(ArtOfTest.Common.ITargetElement)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GenerateXPath(
    ITargetElement element
)
Visual Basic
Public Shared Function GenerateXPath ( _
    element As ITargetElement _
) As String
Visual C++
public:
static String^ GenerateXPath(
    ITargetElement^ element
)

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateXPath(ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateXPath(ArtOfTest.Common.ITargetElement)"]

See Also

HtmlFindClause Class
GenerateXPath Overload
ArtOfTest.WebAii.Core Namespace


GenerateXPath Method (ITargetElement, ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GenerateXPath Method (ITargetElement, ITargetElement)
HtmlFindClause Class See Also Send Feedback
Generate a backup xpath using an element

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GenerateXPath(
    ITargetElement element,
    ITargetElement parent
)
Visual Basic
Public Shared Function GenerateXPath ( _
    element As ITargetElement, _
    parent As ITargetElement _
) As String
Visual C++
public:
static String^ GenerateXPath(
    ITargetElement^ element,
    ITargetElement^ parent
)

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateXPath(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

parent
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="parent"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateXPath(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GenerateXPath(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

See Also

HtmlFindClause Class
GenerateXPath Overload
ArtOfTest.WebAii.Core Namespace


GetTagIndexFromParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GetTagIndexFromParent Method
HtmlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GetTagIndexFromParent(ArtOfTest.WebAii.ObjectModel.Element,ArtOfTest.WebAii.ObjectModel.Element)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int GetTagIndexFromParent(
    Element parent,
    Element e
)
Visual Basic
Public Shared Function GetTagIndexFromParent ( _
    parent As Element, _
    e As Element _
) As Integer
Visual C++
public:
static int GetTagIndexFromParent(
    Element^ parent,
    Element^ e
)

Parameters

parent
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="parent"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GetTagIndexFromParent(ArtOfTest.WebAii.ObjectModel.Element,ArtOfTest.WebAii.ObjectModel.Element)"]

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GetTagIndexFromParent(ArtOfTest.WebAii.ObjectModel.Element,ArtOfTest.WebAii.ObjectModel.Element)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GetTagIndexFromParent(ArtOfTest.WebAii.ObjectModel.Element,ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


GetTagIndexInChildren Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..GetTagIndexInChildren Method
HtmlFindClause Class See Also Send Feedback
Get a child index within a parent only.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int GetTagIndexInChildren(
    ITargetElement element
)
Visual Basic
Public Shared Function GetTagIndexInChildren ( _
    element As ITargetElement _
) As Integer
Visual C++
public:
static int GetTagIndexInChildren(
    ITargetElement^ element
)

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GetTagIndexInChildren(ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.GetTagIndexInChildren(ArtOfTest.Common.ITargetElement)"]

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


Match Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..Match Method
HtmlFindClause Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Match(ITargetElement) | (Overrides FindClause..::..Match(ITargetElement).)
Public method | Match(ITargetElement, ITargetElement) | Match an element (Overrides FindClause..::..Match(ITargetElement, ITargetElement).)

See Also

HtmlFindClause Class
HtmlFindClause Members
ArtOfTest.WebAii.Core Namespace


Match Method (ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..Match Method (ITargetElement)
HtmlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.Match(ArtOfTest.Common.ITargetElement)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Match(
    ITargetElement element
)
Visual Basic
Public Overrides Function Match ( _
    element As ITargetElement _
) As Boolean
Visual C++
public:
virtual bool Match(
    ITargetElement^ element
) override

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.Match(ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.Match(ArtOfTest.Common.ITargetElement)"]

See Also

HtmlFindClause Class
Match Overload
ArtOfTest.WebAii.Core Namespace


Match Method (ITargetElement, ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..Match Method (ITargetElement, ITargetElement)
HtmlFindClause Class See Also Send Feedback
Match an element

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Match(
    ITargetElement target,
    ITargetElement startElement
)
Visual Basic
Public Overrides Function Match ( _
    target As ITargetElement, _
    startElement As ITargetElement _
) As Boolean
Visual C++
public:
virtual bool Match(
    ITargetElement^ target,
    ITargetElement^ startElement
) override

Parameters

target
Type: ArtOfTest.Common..::..ITargetElement
The target
startElement
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="startElement"/> documentation for "M:ArtOfTest.WebAii.Core.HtmlFindClause.Match(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

Return Value

True/False whether the element matches or not.

See Also

HtmlFindClause Class
Match Overload
ArtOfTest.WebAii.Core Namespace


OnParsed Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..OnParsed Method
HtmlFindClause Class See Also Send Feedback
Perform Html specific parameter parsing.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void OnParsed()
Visual Basic
Public Overrides Sub OnParsed
Visual C++
public:
virtual void OnParsed() override

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


HtmlFindClause Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause Properties
HtmlFindClause Class See Also Send Feedback

The HtmlFindClause type exposes the following members.

Properties

 | Name | Description
Public property | Clause | Gets or sets the search expression. On setting the value, the expression will be parsed. (Inherited from FindClause.)
Public property | CompareType | Gets the expression compare type. (Inherited from FindClause.)
Public property | IsHierarchical | Gets whether this search clause is relative to the root of the search. (Inherited from FindClause.)
Public property | Name | Gets the name part of the expression. (Inherited from FindClause.)
Public property | Priority | Gets the search priority of this clause. 0 is the highest. 10 lowest. (Inherited from FindClause.)
Public property | SearchType | Get the search type
Public property | TagIndex | Get the tag index
Public property | TagName | Get the tag name.
Public property | Value | Gets the value part of the expression. (Inherited from FindClause.)

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


SearchType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..SearchType Property
HtmlFindClause Class See Also Send Feedback
Get the search type

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlSearchType SearchType { get; }
Visual Basic
Public ReadOnly Property SearchType As HtmlSearchType
    Get
Visual C++
public:
property HtmlSearchType SearchType {
    HtmlSearchType get ();
}

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


TagIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..TagIndex Property
HtmlFindClause Class See Also Send Feedback
Get the tag index

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TagIndex { get; }
Visual Basic
Public ReadOnly Property TagIndex As Integer
    Get
Visual C++
public:
property int TagIndex {
    int get ();
}

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


TagName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindClause..::..TagName Property
HtmlFindClause Class See Also Send Feedback
Get the tag name.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TagName { get; }
Visual Basic
Public ReadOnly Property TagName As String
    Get
Visual C++
public:
property String^ TagName {
    String^ get ();
}

See Also

HtmlFindClause Class
ArtOfTest.WebAii.Core Namespace


HtmlFindExpression Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression Members
HtmlFindExpression Class Constructors Methods Properties See Also Send Feedback

The HtmlFindExpression type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlFindExpression()()()() | Create an empty expression.
Public method | HtmlFindExpression(array<String>[]()[][]) | Create a new FindExpression.

Methods

 | Name | Description
Public method | AddClause | Add the clauses as (Overrides FindExpression<(Of <(<'T>)>)>..::..AddClause(String).)
Public method | AddHierarchyConstraint | Add a hierarchy constraint. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | AppendChain | Append the passed in expression as a chain to the end of the expression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | AppendClauses | Append a set of clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | CheckConstraints | Check the constraints of this target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClauses | Get the list of clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize this expression with a set of clauses. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement) | Match this expression against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of this FindExpression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Update | Update this expression with the new expression (Inherited from FindExpression<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | ChainStops | Gets the list of chain locations in the clauses. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | Clauses | Gets the expression clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | Constraints | Get any hierarchy constraints. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | FindClauses | Gets or sets the find statement. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | HasConstraints | Gets whether this expression have hierarchy constraints (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | HasHierarchicalDependency | Gets whether this expression has any hierarchal dependencies. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | IsChained | Gets whether the search is chained. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | StringRepresentation | Get the string representation of this expression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | SupportedSearchType | Gets the supported search (HtmlSearchType) type as a Type object. (Overrides FindExpression<(Of <(<'T>)>)>..::..SupportedSearchType.)

See Also

HtmlFindExpression Class
ArtOfTest.WebAii.Core Namespace


HtmlFindExpression Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression Constructor
HtmlFindExpression Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlFindExpression()()()() | Create an empty expression.
Public method | HtmlFindExpression(array<String>[]()[][]) | Create a new FindExpression.

See Also

HtmlFindExpression Class
HtmlFindExpression Members
ArtOfTest.WebAii.Core Namespace


HtmlFindExpression Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression Constructor
HtmlFindExpression Class See Also Send Feedback
Create an empty expression.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlFindExpression()
Visual Basic
Public Sub New
Visual C++
public:
HtmlFindExpression()

See Also

HtmlFindExpression Class
HtmlFindExpression Overload
ArtOfTest.WebAii.Core Namespace


HtmlFindExpression Constructor (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression Constructor (array<String>[]()[][])
HtmlFindExpression Class See Also Send Feedback
Create a new FindExpression.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlFindExpression(
    params string[] findClauses
)
Visual Basic
Public Sub New ( _
    ParamArray findClauses As String() _
)
Visual C++
public:
HtmlFindExpression(
    ... array<String^>^ findClauses
)

Parameters

findClauses
Type: array< System..::..String >[]()[][]
The find clauses

See Also

HtmlFindExpression Class
HtmlFindExpression Overload
ArtOfTest.WebAii.Core Namespace


HtmlFindExpression Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression Methods
HtmlFindExpression Class See Also Send Feedback

The HtmlFindExpression type exposes the following members.

Methods

 | Name | Description
Public method | AddClause | Add the clauses as (Overrides FindExpression<(Of <(<'T>)>)>..::..AddClause(String).)
Public method | AddHierarchyConstraint | Add a hierarchy constraint. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | AppendChain | Append the passed in expression as a chain to the end of the expression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | AppendClauses | Append a set of clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | CheckConstraints | Check the constraints of this target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClauses | Get the list of clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize this expression with a set of clauses. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement) | Match this expression against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of this FindExpression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Update | Update this expression with the new expression (Inherited from FindExpression<(Of <(<'T>)>)>.)

See Also

HtmlFindExpression Class
ArtOfTest.WebAii.Core Namespace


AddClause Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression..::..AddClause Method
HtmlFindExpression Class See Also Send Feedback
Add the clauses as

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AddClause(
    string clause
)
Visual Basic
Public Overrides Sub AddClause ( _
    clause As String _
)
Visual C++
public:
virtual void AddClause(
    String^ clause
) override

Parameters

clause
Type: System..::..String
The clause to add

See Also

HtmlFindExpression Class
ArtOfTest.WebAii.Core Namespace


Match Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression..::..Match Method
HtmlFindExpression Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Match(ITargetElement) | Match this expression against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)

See Also

HtmlFindExpression Class
HtmlFindExpression Members
ArtOfTest.WebAii.Core Namespace


HtmlFindExpression Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression Properties
HtmlFindExpression Class See Also Send Feedback

The HtmlFindExpression type exposes the following members.

Properties

 | Name | Description
Public property | ChainStops | Gets the list of chain locations in the clauses. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | Clauses | Gets the expression clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | Constraints | Get any hierarchy constraints. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | FindClauses | Gets or sets the find statement. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | HasConstraints | Gets whether this expression have hierarchy constraints (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | HasHierarchicalDependency | Gets whether this expression has any hierarchal dependencies. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | IsChained | Gets whether the search is chained. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | StringRepresentation | Get the string representation of this expression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | SupportedSearchType | Gets the supported search (HtmlSearchType) type as a Type object. (Overrides FindExpression<(Of <(<'T>)>)>..::..SupportedSearchType.)

See Also

HtmlFindExpression Class
ArtOfTest.WebAii.Core Namespace


SupportedSearchType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlFindExpression..::..SupportedSearchType Property
HtmlFindExpression Class See Also Send Feedback
Gets the supported search (HtmlSearchType) type as a Type object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Type SupportedSearchType { get; }
Visual Basic
Public Overrides ReadOnly Property SupportedSearchType As Type
    Get
Visual C++
public:
virtual property Type^ SupportedSearchType {
    Type^ get () override;
}

Implements

IFindExpression..::..SupportedSearchType

See Also

HtmlFindExpression Class
ArtOfTest.WebAii.Core Namespace


Log Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log Members
Log Class Methods Properties Events See Also Send Feedback

The Log type exposes the following members.

Methods

 | Name | Description
Public method | CaptureBrowser(Browser) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Public method | CaptureBrowser(Browser, String) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Public method | CaptureBrowser(Browser, String, Boolean) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Public method | CaptureDesktop()()()() | Captures the entire desktop to the log location.
Public method | CaptureDesktop(String) | Captures the entire desktop to the log location.
Public method | CaptureDesktop(String, Boolean) | Captures the entire desktop to the log location.
Public method | CaptureWindow(WpfWindow, String) | Captures a visual snap shot of a specific window instance. This function will also add the path to the image to the log file.
Public method | CaptureWindow(WpfWindow, String, Boolean) |
Public method | Dispose | Dispose of this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteLine(String) | Write a line to the log file.
Public method | WriteLine(LogType, String) | Log information to the event log.

Properties

 | Name | Description
Public property | FileName | Full file name where we are doing the logging to.
Public property | LogLocation | The log location on disk where were we are currently creating any logs.
Public property | Text | Current string of the log. This is an snap shot of what is currently in the log.

Events

 | Name | Description
Public event | LogWrite | This event is invoked everytime a WriteLine is invoked. External frameworks can attach to this event to capture logs from this framework to help unify their logging.

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


Log Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log Methods
Log Class See Also Send Feedback

The Log type exposes the following members.

Methods

 | Name | Description
Public method | CaptureBrowser(Browser) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Public method | CaptureBrowser(Browser, String) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Public method | CaptureBrowser(Browser, String, Boolean) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Public method | CaptureDesktop()()()() | Captures the entire desktop to the log location.
Public method | CaptureDesktop(String) | Captures the entire desktop to the log location.
Public method | CaptureDesktop(String, Boolean) | Captures the entire desktop to the log location.
Public method | CaptureWindow(WpfWindow, String) | Captures a visual snap shot of a specific window instance. This function will also add the path to the image to the log file.
Public method | CaptureWindow(WpfWindow, String, Boolean) |
Public method | Dispose | Dispose of this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteLine(String) | Write a line to the log file.
Public method | WriteLine(LogType, String) | Log information to the event log.

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


CaptureBrowser Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureBrowser Method
Log Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CaptureBrowser(Browser) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Public method | CaptureBrowser(Browser, String) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.
Public method | CaptureBrowser(Browser, String, Boolean) | Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.

See Also

Log Class
Log Members
ArtOfTest.WebAii.Core Namespace


CaptureBrowser Method (Browser)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureBrowser Method (Browser)
Log Class See Also Send Feedback
Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureBrowser(
    Browser browserToCapture
)
Visual Basic
Public Sub CaptureBrowser ( _
    browserToCapture As Browser _
)
Visual C++
public:
void CaptureBrowser(
    Browser^ browserToCapture
)

Parameters

browserToCapture
Type: ArtOfTest.WebAii.Core..::..Browser
The browser instance to capture.

See Also

Log Class
CaptureBrowser Overload
ArtOfTest.WebAii.Core Namespace


CaptureBrowser Method (Browser, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureBrowser Method (Browser, String)
Log Class See Also Send Feedback
Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureBrowser(
    Browser browserToCapture,
    string fileNamePrefix
)
Visual Basic
Public Sub CaptureBrowser ( _
    browserToCapture As Browser, _
    fileNamePrefix As String _
)
Visual C++
public:
void CaptureBrowser(
    Browser^ browserToCapture,
    String^ fileNamePrefix
)

Parameters

browserToCapture
Type: ArtOfTest.WebAii.Core..::..Browser
The browser instance to capture.
fileNamePrefix
Type: System..::..String
The file name prefix to use on disk.

See Also

Log Class
CaptureBrowser Overload
ArtOfTest.WebAii.Core Namespace


CaptureBrowser Method (Browser, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureBrowser Method (Browser, String, Boolean)
Log Class See Also Send Feedback
Captures a visual snap shot of a specific browser instance and logs it to the log location. This function will also add the path to the image to the log file.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureBrowser(
    Browser browserToCapture,
    string fileNamePrefix,
    bool overrideFile
)
Visual Basic
Public Sub CaptureBrowser ( _
    browserToCapture As Browser, _
    fileNamePrefix As String, _
    overrideFile As Boolean _
)
Visual C++
public:
void CaptureBrowser(
    Browser^ browserToCapture,
    String^ fileNamePrefix,
    bool overrideFile
)

Parameters

browserToCapture
Type: ArtOfTest.WebAii.Core..::..Browser
The browser to capture.
fileNamePrefix
Type: System..::..String
The file name prefix.
overrideFile
Type: System..::..Boolean
Override the file if exists or not.

See Also

Log Class
CaptureBrowser Overload
ArtOfTest.WebAii.Core Namespace


CaptureDesktop Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureDesktop Method
Log Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CaptureDesktop()()()() | Captures the entire desktop to the log location.
Public method | CaptureDesktop(String) | Captures the entire desktop to the log location.
Public method | CaptureDesktop(String, Boolean) | Captures the entire desktop to the log location.

See Also

Log Class
Log Members
ArtOfTest.WebAii.Core Namespace


CaptureDesktop Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureDesktop Method
Log Class See Also Send Feedback
Captures the entire desktop to the log location.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureDesktop()
Visual Basic
Public Sub CaptureDesktop
Visual C++
public:
void CaptureDesktop()

See Also

Log Class
CaptureDesktop Overload
ArtOfTest.WebAii.Core Namespace


CaptureDesktop Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureDesktop Method (String)
Log Class See Also Send Feedback
Captures the entire desktop to the log location.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureDesktop(
    string fileNamePrefix
)
Visual Basic
Public Sub CaptureDesktop ( _
    fileNamePrefix As String _
)
Visual C++
public:
void CaptureDesktop(
    String^ fileNamePrefix
)

Parameters

fileNamePrefix
Type: System..::..String
File name prefix to use.

See Also

Log Class
CaptureDesktop Overload
ArtOfTest.WebAii.Core Namespace


CaptureDesktop Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureDesktop Method (String, Boolean)
Log Class See Also Send Feedback
Captures the entire desktop to the log location.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureDesktop(
    string fileNamePrefix,
    bool overrideFile
)
Visual Basic
Public Sub CaptureDesktop ( _
    fileNamePrefix As String, _
    overrideFile As Boolean _
)
Visual C++
public:
void CaptureDesktop(
    String^ fileNamePrefix,
    bool overrideFile
)

Parameters

fileNamePrefix
Type: System..::..String
File name prefix to use.
overrideFile
Type: System..::..Boolean

[Missing <param name="overrideFile"/> documentation for "M:ArtOfTest.WebAii.Core.Log.CaptureDesktop(System.String,System.Boolean)"]

See Also

Log Class
CaptureDesktop Overload
ArtOfTest.WebAii.Core Namespace


CaptureWindow Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureWindow Method
Log Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CaptureWindow(WpfWindow, String) | Captures a visual snap shot of a specific window instance. This function will also add the path to the image to the log file.
Public method | CaptureWindow(WpfWindow, String, Boolean) |

See Also

Log Class
Log Members
ArtOfTest.WebAii.Core Namespace


CaptureWindow Method (WpfWindow, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureWindow Method (WpfWindow, String)
Log Class See Also Send Feedback
Captures a visual snap shot of a specific window instance. This function will also add the path to the image to the log file.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureWindow(
    WpfWindow windowToCapture,
    string fileNamePrefix
)
Visual Basic
Public Sub CaptureWindow ( _
    windowToCapture As WpfWindow, _
    fileNamePrefix As String _
)
Visual C++
public:
void CaptureWindow(
    WpfWindow^ windowToCapture,
    String^ fileNamePrefix
)

Parameters

windowToCapture
Type: ArtOfTest.WebAii.Wpf..::..WpfWindow
The window to capture.
fileNamePrefix
Type: System..::..String
The file name prefix.

See Also

Log Class
CaptureWindow Overload
ArtOfTest.WebAii.Core Namespace


CaptureWindow Method (WpfWindow, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..CaptureWindow Method (WpfWindow, String, Boolean)
Log Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Log.CaptureWindow(ArtOfTest.WebAii.Wpf.WpfWindow,System.String,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureWindow(
    WpfWindow windowToCapture,
    string fileNamePrefix,
    bool overrideFile
)
Visual Basic
Public Sub CaptureWindow ( _
    windowToCapture As WpfWindow, _
    fileNamePrefix As String, _
    overrideFile As Boolean _
)
Visual C++
public:
void CaptureWindow(
    WpfWindow^ windowToCapture,
    String^ fileNamePrefix,
    bool overrideFile
)

Parameters

windowToCapture
Type: ArtOfTest.WebAii.Wpf..::..WpfWindow

[Missing <param name="windowToCapture"/> documentation for "M:ArtOfTest.WebAii.Core.Log.CaptureWindow(ArtOfTest.WebAii.Wpf.WpfWindow,System.String,System.Boolean)"]

fileNamePrefix
Type: System..::..String

[Missing <param name="fileNamePrefix"/> documentation for "M:ArtOfTest.WebAii.Core.Log.CaptureWindow(ArtOfTest.WebAii.Wpf.WpfWindow,System.String,System.Boolean)"]

overrideFile
Type: System..::..Boolean

[Missing <param name="overrideFile"/> documentation for "M:ArtOfTest.WebAii.Core.Log.CaptureWindow(ArtOfTest.WebAii.Wpf.WpfWindow,System.String,System.Boolean)"]

See Also

Log Class
CaptureWindow Overload
ArtOfTest.WebAii.Core Namespace


Dispose Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..Dispose Method
Log Class See Also Send Feedback
Dispose of this object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


Finalize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..Finalize Method
Log Class See Also Send Feedback
Destructor

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


WriteLine Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..WriteLine Method
Log Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WriteLine(String) | Write a line to the log file.
Public method | WriteLine(LogType, String) | Log information to the event log.

See Also

Log Class
Log Members
ArtOfTest.WebAii.Core Namespace


WriteLine Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..WriteLine Method (String)
Log Class See Also Send Feedback
Write a line to the log file.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WriteLine(
    string message
)
Visual Basic
Public Sub WriteLine ( _
    message As String _
)
Visual C++
public:
void WriteLine(
    String^ message
)

Parameters

message
Type: System..::..String
The message to write.

See Also

Log Class
WriteLine Overload
ArtOfTest.WebAii.Core Namespace


WriteLine Method (LogType, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..WriteLine Method (LogType, String)
Log Class See Also Send Feedback
Log information to the event log.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WriteLine(
    LogType type,
    string message
)
Visual Basic
Public Sub WriteLine ( _
    type As LogType, _
    message As String _
)
Visual C++
public:
void WriteLine(
    LogType type,
    String^ message
)

Parameters

type
Type: ArtOfTest.WebAii.Core..::..LogType

[Missing <param name="type"/> documentation for "M:ArtOfTest.WebAii.Core.Log.WriteLine(ArtOfTest.WebAii.Core.LogType,System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Core.Log.WriteLine(ArtOfTest.WebAii.Core.LogType,System.String)"]

See Also

Log Class
WriteLine Overload
ArtOfTest.WebAii.Core Namespace


Log Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log Properties
Log Class See Also Send Feedback

The Log type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Full file name where we are doing the logging to.
Public property | LogLocation | The log location on disk where were we are currently creating any logs.
Public property | Text | Current string of the log. This is an snap shot of what is currently in the log.

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


FileName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..FileName Property
Log Class See Also Send Feedback
Full file name where we are doing the logging to.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


LogLocation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..LogLocation Property
Log Class See Also Send Feedback
The log location on disk where were we are currently creating any logs.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string LogLocation { get; }
Visual Basic
Public ReadOnly Property LogLocation As String
    Get
Visual C++
public:
property String^ LogLocation {
    String^ get ();
}

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..Text Property
Log Class See Also Send Feedback
Current string of the log. This is an snap shot of what is currently in the log.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


Log Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log Events
Log Class See Also Send Feedback

The Log type exposes the following members.

Events

 | Name | Description
Public event | LogWrite | This event is invoked everytime a WriteLine is invoked. External frameworks can attach to this event to capture logs from this framework to help unify their logging.

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


LogWrite Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Log..::..LogWrite Event
Log Class See Also Send Feedback
This event is invoked everytime a WriteLine is invoked. External frameworks can attach to this event to capture logs from this framework to help unify their logging.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<LogWriteEventArgs> LogWrite
Visual Basic
Public Event LogWrite As EventHandler(Of LogWriteEventArgs)
Visual C++
public:
 event EventHandler<LogWriteEventArgs^>^ LogWrite {
    void add (EventHandler<LogWriteEventArgs^>^ value);
    void remove (EventHandler<LogWriteEventArgs^>^ value);
}

See Also

Log Class
ArtOfTest.WebAii.Core Namespace


Manager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager Members
Manager Class Constructors Methods Properties Events See Also Send Feedback

The Manager type exposes the following members.

Constructors

 | Name | Description
Public method | Manager(Boolean) | Create a new Manager.
Public method | Manager(Settings) | Create a new Manager.

Methods

 | Name | Description
Public method | AddNewBrowser | Add a new browser to collection.
 | ClearMappingsOverride | Clear the global override mappings for a specific type.
Public method | ConfigureBrowser | Aplly browser settings, requered for automation to work correctly. In order to aplly settings correctly all browseer instances of specified type must be closed.
Public method | ConnectToApplication |
Public method | Dispose | Dispose of resources controlled by this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides Object..::..Finalize()()()().)
Public method | GetBrowserConfigurationStatus | Get browser configureation status.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LaunchNewApplication(ProcessStartInfo) |
Public method | LaunchNewApplication(String, array<String>[]()[][]) | Launch a new WPF Application for automation
Public method | LaunchNewBrowser()()()() | Launch a new browser using default settings. Waits for browser to connect.
Public method | LaunchNewBrowser(ProcessWindowStyle) | Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.
Public method | LaunchNewBrowser(BrowserType) | Launch a new browser of the selected type and wait for it to connect.
Public method | LaunchNewBrowser(ProcessWindowStyle, String) | Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.
Public method | LaunchNewBrowser(BrowserType, Boolean) | Launch a new browser of the specified BrowserType.
Public method | LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle) | Launch a new browser.
Public method | LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle, String) | Launch a new browser.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterMappingsOverride | Register a set of global mappings for a specific type.
Public method | RemoveBrowser | Remove a browser from collection.
Public method | SetNewBrowserTracking | Enable or disable new browser tracking. Use to track pop-up browser windows. When enabled, new pop-up browser windows will be added to the browsers[] collection.
Public method | Start | Initialize the communication pipelines.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForNewBrowserConnect(String, Boolean, Int32) | Wait for a specific browser instance to connect using a timeout.
Public method | WaitForNewBrowserConnect(String, Boolean, String, Int32) | Wait for a specific browser instance to connect using a timeout.

Properties

 | Name | Description
Public property | ActiveApplication |
Public property | ActiveBrowser | Gets the last browser instance launched.
Public property | Applications |
Public property | Browsers | Gets the array of browser instances connected to this instance of the Manager. This should be considered a one-time snapshot and long-term object references to it should be avoided.
 | Current | Gets the current active manager object.
Public property | Desktop | Gets the Desktop object that can be used to invoke desktop input devices like Mouse, Keyboard events.
Public property | DialogMonitor | Gets the DialogMonitor object that handles popup dialogs
Public property | Disposed |
Public property | Elements | Gets the element finder to be used for finding elements defined by the FindParam attributes. This Elements object replaces all the Find.Elements since current FindParamAttributes are not frames and test region aware.
Public property | ErrorStatus | Set when the manager is in an error condition
Public property | Http | Gets the HttpProxy instance if UseHttpProxy is set to true, else will return null.
Public property | Log | Gets the Log object.
Public property | PipeName |
Public property | Settings | Gets the settings object that this Manager instance was initialized with.
Public property | Wait | Gets a wait object that can be used to wait on specific actions on elements/controls or custom predicate actions

Events

 | Name | Description
Public event | ActiveBrowserChanged | Occurs when active browser is changed. After attachment this event will fire, using actual active browser.

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Manager Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager Constructor
Manager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Manager(Boolean) | Create a new Manager.
Public method | Manager(Settings) | Create a new Manager.

See Also

Manager Class
Manager Members
ArtOfTest.WebAii.Core Namespace


Manager Constructor (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager Constructor (Boolean)
Manager Class See Also Send Feedback
Create a new Manager.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Manager(
    bool UseConfig
)
Visual Basic
Public Sub New ( _
    UseConfig As Boolean _
)
Visual C++
public:
Manager(
    bool UseConfig
)

Parameters

UseConfig
Type: System..::..Boolean
If set to true, the manager will load the setting from the config. Else will use the default settings.

See Also

Manager Class
Manager Overload
ArtOfTest.WebAii.Core Namespace


Manager Constructor (Settings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager Constructor (Settings)
Manager Class See Also Send Feedback
Create a new Manager.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Manager(
    Settings settings
)
Visual Basic
Public Sub New ( _
    settings As Settings _
)
Visual C++
public:
Manager(
    Settings^ settings
)

Parameters

settings
Type: ArtOfTest.WebAii.Core..::..Settings
The settings object that specifies the settings to initialize the framework with. These settings are propagated through out the framework objects.

See Also

Manager Class
Manager Overload
ArtOfTest.WebAii.Core Namespace


Manager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager Methods
Manager Class See Also Send Feedback

The Manager type exposes the following members.

Methods

 | Name | Description
Public method | AddNewBrowser | Add a new browser to collection.
 | ClearMappingsOverride | Clear the global override mappings for a specific type.
Public method | ConfigureBrowser | Aplly browser settings, requered for automation to work correctly. In order to aplly settings correctly all browseer instances of specified type must be closed.
Public method | ConnectToApplication |
Public method | Dispose | Dispose of resources controlled by this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Destructor (Overrides Object..::..Finalize()()()().)
Public method | GetBrowserConfigurationStatus | Get browser configureation status.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LaunchNewApplication(ProcessStartInfo) |
Public method | LaunchNewApplication(String, array<String>[]()[][]) | Launch a new WPF Application for automation
Public method | LaunchNewBrowser()()()() | Launch a new browser using default settings. Waits for browser to connect.
Public method | LaunchNewBrowser(ProcessWindowStyle) | Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.
Public method | LaunchNewBrowser(BrowserType) | Launch a new browser of the selected type and wait for it to connect.
Public method | LaunchNewBrowser(ProcessWindowStyle, String) | Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.
Public method | LaunchNewBrowser(BrowserType, Boolean) | Launch a new browser of the specified BrowserType.
Public method | LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle) | Launch a new browser.
Public method | LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle, String) | Launch a new browser.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterMappingsOverride | Register a set of global mappings for a specific type.
Public method | RemoveBrowser | Remove a browser from collection.
Public method | SetNewBrowserTracking | Enable or disable new browser tracking. Use to track pop-up browser windows. When enabled, new pop-up browser windows will be added to the browsers[] collection.
Public method | Start | Initialize the communication pipelines.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForNewBrowserConnect(String, Boolean, Int32) | Wait for a specific browser instance to connect using a timeout.
Public method | WaitForNewBrowserConnect(String, Boolean, String, Int32) | Wait for a specific browser instance to connect using a timeout.

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


AddNewBrowser Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..AddNewBrowser Method
Manager Class See Also Send Feedback
Add a new browser to collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddNewBrowser(
    Browser browser
)
Visual Basic
Public Sub AddNewBrowser ( _
    browser As Browser _
)
Visual C++
public:
void AddNewBrowser(
    Browser^ browser
)

Parameters

browser
Type: ArtOfTest.WebAii.Core..::..Browser
New browser.

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


ClearMappingsOverride Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..ClearMappingsOverride Method
Manager Class See Also Send Feedback
Clear the global override mappings for a specific type.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void ClearMappingsOverride(
    Type controlType
)
Visual Basic
Public Shared Sub ClearMappingsOverride ( _
    controlType As Type _
)
Visual C++
public:
static void ClearMappingsOverride(
    Type^ controlType
)

Parameters

controlType
Type: System..::..Type

[Missing <param name="controlType"/> documentation for "M:ArtOfTest.WebAii.Core.Manager.ClearMappingsOverride(System.Type)"]

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


ConfigureBrowser Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..ConfigureBrowser Method
Manager Class See Also Send Feedback
Aplly browser settings, requered for automation to work correctly. In order to aplly settings correctly all browseer instances of specified type must be closed.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ConfigureBrowser(
    BrowserType browser,
    bool forceShutdown
)
Visual Basic
Public Sub ConfigureBrowser ( _
    browser As BrowserType, _
    forceShutdown As Boolean _
)
Visual C++
public:
void ConfigureBrowser(
    BrowserType browser,
    bool forceShutdown
)

Parameters

browser
Type: ArtOfTest.WebAii.Core..::..BrowserType
The type of browser to configure.
forceShutdown
Type: System..::..Boolean
Whether to shutdown all running instances of specified browser type.

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


ConnectToApplication Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..ConnectToApplication Method
Manager Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Manager.ConnectToApplication(System.Diagnostics.Process,System.String)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfApplication ConnectToApplication(
    Process proc,
    string pid
)
Visual Basic
Public Function ConnectToApplication ( _
    proc As Process, _
    pid As String _
) As WpfApplication
Visual C++
public:
WpfApplication^ ConnectToApplication(
    Process^ proc,
    String^ pid
)

Parameters

proc
Type: System.Diagnostics..::..Process

[Missing <param name="proc"/> documentation for "M:ArtOfTest.WebAii.Core.Manager.ConnectToApplication(System.Diagnostics.Process,System.String)"]

pid
Type: System..::..String

[Missing <param name="pid"/> documentation for "M:ArtOfTest.WebAii.Core.Manager.ConnectToApplication(System.Diagnostics.Process,System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Manager.ConnectToApplication(System.Diagnostics.Process,System.String)"]

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Dispose Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Dispose Method
Manager Class See Also Send Feedback
Dispose of resources controlled by this object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Finalize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Finalize Method
Manager Class See Also Send Feedback
Destructor

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


GetBrowserConfigurationStatus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..GetBrowserConfigurationStatus Method
Manager Class See Also Send Feedback
Get browser configureation status.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserConfigurationStatus GetBrowserConfigurationStatus(
    BrowserType browser
)
Visual Basic
Public Function GetBrowserConfigurationStatus ( _
    browser As BrowserType _
) As BrowserConfigurationStatus
Visual C++
public:
BrowserConfigurationStatus GetBrowserConfigurationStatus(
    BrowserType browser
)

Parameters

browser
Type: ArtOfTest.WebAii.Core..::..BrowserType
Browser type.

Return Value

Browser configuration status.

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


LaunchNewApplication Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewApplication Method
Manager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LaunchNewApplication(ProcessStartInfo) |
Public method | LaunchNewApplication(String, array<String>[]()[][]) | Launch a new WPF Application for automation

See Also

Manager Class
Manager Members
ArtOfTest.WebAii.Core Namespace


LaunchNewApplication Method (ProcessStartInfo)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewApplication Method (ProcessStartInfo)
Manager Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Manager.LaunchNewApplication(System.Diagnostics.ProcessStartInfo)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfApplication LaunchNewApplication(
    ProcessStartInfo pinfo
)
Visual Basic
Public Function LaunchNewApplication ( _
    pinfo As ProcessStartInfo _
) As WpfApplication
Visual C++
public:
WpfApplication^ LaunchNewApplication(
    ProcessStartInfo^ pinfo
)

Parameters

pinfo
Type: System.Diagnostics..::..ProcessStartInfo

[Missing <param name="pinfo"/> documentation for "M:ArtOfTest.WebAii.Core.Manager.LaunchNewApplication(System.Diagnostics.ProcessStartInfo)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.Manager.LaunchNewApplication(System.Diagnostics.ProcessStartInfo)"]

See Also

Manager Class
LaunchNewApplication Overload
ArtOfTest.WebAii.Core Namespace


LaunchNewApplication Method (String, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewApplication Method (String, array<String>[]()[][])
Manager Class See Also Send Feedback
Launch a new WPF Application for automation

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfApplication LaunchNewApplication(
    string path,
    params string[] args
)
Visual Basic
Public Function LaunchNewApplication ( _
    path As String, _
    ParamArray args As String() _
) As WpfApplication
Visual C++
public:
WpfApplication^ LaunchNewApplication(
    String^ path,
    ... array<String^>^ args
)

Parameters

path
Type: System..::..String
The fully qualified path to the WPF Application. This path can include environment varibales
args
Type: array< System..::..String >[]()[][]
Arguments to pass to the WPF Application

Return Value

A WpfApplication for use with automation

See Also

Manager Class
LaunchNewApplication Overload
ArtOfTest.WebAii.Core Namespace


LaunchNewBrowser Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewBrowser Method
Manager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LaunchNewBrowser()()()() | Launch a new browser using default settings. Waits for browser to connect.
Public method | LaunchNewBrowser(ProcessWindowStyle) | Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.
Public method | LaunchNewBrowser(BrowserType) | Launch a new browser of the selected type and wait for it to connect.
Public method | LaunchNewBrowser(ProcessWindowStyle, String) | Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.
Public method | LaunchNewBrowser(BrowserType, Boolean) | Launch a new browser of the specified BrowserType.
Public method | LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle) | Launch a new browser.
Public method | LaunchNewBrowser(BrowserType, Boolean, ProcessWindowStyle, String) | Launch a new browser.

See Also

Manager Class
Manager Members
ArtOfTest.WebAii.Core Namespace


LaunchNewBrowser Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewBrowser Method
Manager Class See Also Send Feedback
Launch a new browser using default settings. Waits for browser to connect.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LaunchNewBrowser()
Visual Basic
Public Sub LaunchNewBrowser
Visual C++
public:
void LaunchNewBrowser()

See Also

Manager Class
LaunchNewBrowser Overload
ArtOfTest.WebAii.Core Namespace


LaunchNewBrowser Method (ProcessWindowStyle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewBrowser Method (ProcessWindowStyle)
Manager Class See Also Send Feedback
Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LaunchNewBrowser(
    ProcessWindowStyle windowStyle
)
Visual Basic
Public Sub LaunchNewBrowser ( _
    windowStyle As ProcessWindowStyle _
)
Visual C++
public:
void LaunchNewBrowser(
    ProcessWindowStyle windowStyle
)

Parameters

windowStyle
Type: System.Diagnostics..::..ProcessWindowStyle
The window style to launch the browser in.

See Also

Manager Class
LaunchNewBrowser Overload
ArtOfTest.WebAii.Core Namespace


LaunchNewBrowser Method (BrowserType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewBrowser Method (BrowserType)
Manager Class See Also Send Feedback
Launch a new browser of the selected type and wait for it to connect.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LaunchNewBrowser(
    BrowserType browserToLaunch
)
Visual Basic
Public Sub LaunchNewBrowser ( _
    browserToLaunch As BrowserType _
)
Visual C++
public:
void LaunchNewBrowser(
    BrowserType browserToLaunch
)

Parameters

browserToLaunch
Type: ArtOfTest.WebAii.Core..::..BrowserType
The browser type to launch.

See Also

Manager Class
LaunchNewBrowser Overload
ArtOfTest.WebAii.Core Namespace


LaunchNewBrowser Method (ProcessWindowStyle, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewBrowser Method (ProcessWindowStyle, String)
Manager Class See Also Send Feedback
Launch a new browser using the default setting and the sets the browser window style. Waits for browser to connect.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LaunchNewBrowser(
    ProcessWindowStyle windowStyle,
    string arguments
)
Visual Basic
Public Sub LaunchNewBrowser ( _
    windowStyle As ProcessWindowStyle, _
    arguments As String _
)
Visual C++
public:
void LaunchNewBrowser(
    ProcessWindowStyle windowStyle,
    String^ arguments
)

Parameters

windowStyle
Type: System.Diagnostics..::..ProcessWindowStyle
The window style to launch the browser in.
arguments
Type: System..::..String
Arguments to pass to the browser. Only SilverlightApplications use this parameter.

See Also

Manager Class
LaunchNewBrowser Overload
ArtOfTest.WebAii.Core Namespace


LaunchNewBrowser Method (BrowserType, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewBrowser Method (BrowserType, Boolean)
Manager Class See Also Send Feedback
Launch a new browser of the specified BrowserType.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LaunchNewBrowser(
    BrowserType browserToLaunch,
    bool waitForBrowserToConnect
)
Visual Basic
Public Sub LaunchNewBrowser ( _
    browserToLaunch As BrowserType, _
    waitForBrowserToConnect As Boolean _
)
Visual C++
public:
void LaunchNewBrowser(
    BrowserType browserToLaunch,
    bool waitForBrowserToConnect
)

Parameters

browserToLaunch
Type: ArtOfTest.WebAii.Core..::..BrowserType
The browser type to launch.
waitForBrowserToConnect
Type: System..::..Boolean
Whether to wait for the browser to connect and be ready.

See Also

Manager Class
LaunchNewBrowser Overload
ArtOfTest.WebAii.Core Namespace


LaunchNewBrowser Method (BrowserType, Boolean, ProcessWindowStyle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewBrowser Method (BrowserType, Boolean, ProcessWindowStyle)
Manager Class See Also Send Feedback
Launch a new browser.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LaunchNewBrowser(
    BrowserType browserToLaunch,
    bool waitForBrowserToConnect,
    ProcessWindowStyle windowStyle
)
Visual Basic
Public Sub LaunchNewBrowser ( _
    browserToLaunch As BrowserType, _
    waitForBrowserToConnect As Boolean, _
    windowStyle As ProcessWindowStyle _
)
Visual C++
public:
void LaunchNewBrowser(
    BrowserType browserToLaunch,
    bool waitForBrowserToConnect,
    ProcessWindowStyle windowStyle
)

Parameters

browserToLaunch
Type: ArtOfTest.WebAii.Core..::..BrowserType
The browser to launch.
waitForBrowserToConnect
Type: System..::..Boolean
True/False to wait for the browser to connect or not.
windowStyle
Type: System.Diagnostics..::..ProcessWindowStyle
The window style to launch the browser in.

See Also

Manager Class
LaunchNewBrowser Overload
ArtOfTest.WebAii.Core Namespace


LaunchNewBrowser Method (BrowserType, Boolean, ProcessWindowStyle, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..LaunchNewBrowser Method (BrowserType, Boolean, ProcessWindowStyle, String)
Manager Class See Also Send Feedback
Launch a new browser.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LaunchNewBrowser(
    BrowserType browserToLaunch,
    bool waitForBrowserToConnect,
    ProcessWindowStyle windowStyle,
    string arguments
)
Visual Basic
Public Sub LaunchNewBrowser ( _
    browserToLaunch As BrowserType, _
    waitForBrowserToConnect As Boolean, _
    windowStyle As ProcessWindowStyle, _
    arguments As String _
)
Visual C++
public:
void LaunchNewBrowser(
    BrowserType browserToLaunch,
    bool waitForBrowserToConnect,
    ProcessWindowStyle windowStyle,
    String^ arguments
)

Parameters

browserToLaunch
Type: ArtOfTest.WebAii.Core..::..BrowserType
The browser to launch.
waitForBrowserToConnect
Type: System..::..Boolean
True/False to wait for the browser to connect or not.
windowStyle
Type: System.Diagnostics..::..ProcessWindowStyle
The window style to launch the browser in.
arguments
Type: System..::..String
Arguments to pass to the browser. Only SilverlightApplications use this parameter.

See Also

Manager Class
LaunchNewBrowser Overload
ArtOfTest.WebAii.Core Namespace


RegisterMappingsOverride Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..RegisterMappingsOverride Method
Manager Class See Also Send Feedback
Register a set of global mappings for a specific type.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void RegisterMappingsOverride(
    MappingsCollection mappinsToOverride,
    Type controlType
)
Visual Basic
Public Shared Sub RegisterMappingsOverride ( _
    mappinsToOverride As MappingsCollection, _
    controlType As Type _
)
Visual C++
public:
static void RegisterMappingsOverride(
    MappingsCollection^ mappinsToOverride,
    Type^ controlType
)

Parameters

mappinsToOverride
Type: ArtOfTest.WebAii.Core..::..MappingsCollection
The list of mappings to override for the control type
controlType
Type: System..::..Type
The type to override the mappings for.

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


RemoveBrowser Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..RemoveBrowser Method
Manager Class See Also Send Feedback
Remove a browser from collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveBrowser(
    string clientId
)
Visual Basic
Public Sub RemoveBrowser ( _
    clientId As String _
)
Visual C++
public:
void RemoveBrowser(
    String^ clientId
)

Parameters

clientId
Type: System..::..String
The browser client ID.

Remarks

Calling Browser.Close eventually calls back into the manager and into this function (be extra careful about deadlocks).

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


SetNewBrowserTracking Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..SetNewBrowserTracking Method
Manager Class See Also Send Feedback
Enable or disable new browser tracking. Use to track pop-up browser windows. When enabled, new pop-up browser windows will be added to the browsers[] collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetNewBrowserTracking(
    bool enable
)
Visual Basic
Public Sub SetNewBrowserTracking ( _
    enable As Boolean _
)
Visual C++
public:
void SetNewBrowserTracking(
    bool enable
)

Parameters

enable
Type: System..::..Boolean
True/false whether to enable/disable new browser tracking.

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Start Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Start Method
Manager Class See Also Send Feedback
Initialize the communication pipelines.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


WaitForNewBrowserConnect Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..WaitForNewBrowserConnect Method
Manager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForNewBrowserConnect(String, Boolean, Int32) | Wait for a specific browser instance to connect using a timeout.
Public method | WaitForNewBrowserConnect(String, Boolean, String, Int32) | Wait for a specific browser instance to connect using a timeout.

See Also

Manager Class
Manager Members
ArtOfTest.WebAii.Core Namespace


WaitForNewBrowserConnect Method (String, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..WaitForNewBrowserConnect Method (String, Boolean, Int32)
Manager Class See Also Send Feedback
Wait for a specific browser instance to connect using a timeout.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitForNewBrowserConnect(
    string url,
    bool isPartial,
    int timeout
)
Visual Basic
Public Sub WaitForNewBrowserConnect ( _
    url As String, _
    isPartial As Boolean, _
    timeout As Integer _
)
Visual C++
public:
void WaitForNewBrowserConnect(
    String^ url,
    bool isPartial,
    int timeout
)

Parameters

url
Type: System..::..String
The url to use to check the browser.
isPartial
Type: System..::..Boolean
Whether to check the url using partial compares.
timeout
Type: System..::..Int32
The timeout for the wait.

See Also

Manager Class
WaitForNewBrowserConnect Overload
ArtOfTest.WebAii.Core Namespace


WaitForNewBrowserConnect Method (String, Boolean, String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..WaitForNewBrowserConnect Method (String, Boolean, String, Int32)
Manager Class See Also Send Feedback
Wait for a specific browser instance to connect using a timeout.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitForNewBrowserConnect(
    string url,
    bool isPartial,
    string partialCaption,
    int timeout
)
Visual Basic
Public Sub WaitForNewBrowserConnect ( _
    url As String, _
    isPartial As Boolean, _
    partialCaption As String, _
    timeout As Integer _
)
Visual C++
public:
void WaitForNewBrowserConnect(
    String^ url,
    bool isPartial,
    String^ partialCaption,
    int timeout
)

Parameters

url
Type: System..::..String
The url to use to check the browser.
isPartial
Type: System..::..Boolean
Whether to check the url using partial compares.
partialCaption
Type: System..::..String
Partial caption of the browser.
timeout
Type: System..::..Int32
The timeout for the wait.

See Also

Manager Class
WaitForNewBrowserConnect Overload
ArtOfTest.WebAii.Core Namespace


Manager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager Properties
Manager Class See Also Send Feedback

The Manager type exposes the following members.

Properties

 | Name | Description
Public property | ActiveApplication |
Public property | ActiveBrowser | Gets the last browser instance launched.
Public property | Applications |
Public property | Browsers | Gets the array of browser instances connected to this instance of the Manager. This should be considered a one-time snapshot and long-term object references to it should be avoided.
 | Current | Gets the current active manager object.
Public property | Desktop | Gets the Desktop object that can be used to invoke desktop input devices like Mouse, Keyboard events.
Public property | DialogMonitor | Gets the DialogMonitor object that handles popup dialogs
Public property | Disposed |
Public property | Elements | Gets the element finder to be used for finding elements defined by the FindParam attributes. This Elements object replaces all the Find.Elements since current FindParamAttributes are not frames and test region aware.
Public property | ErrorStatus | Set when the manager is in an error condition
Public property | Http | Gets the HttpProxy instance if UseHttpProxy is set to true, else will return null.
Public property | Log | Gets the Log object.
Public property | PipeName |
Public property | Settings | Gets the settings object that this Manager instance was initialized with.
Public property | Wait | Gets a wait object that can be used to wait on specific actions on elements/controls or custom predicate actions

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


ActiveApplication Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..ActiveApplication Property
Manager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Manager.ActiveApplication"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfApplication ActiveApplication { get; }
Visual Basic
Public ReadOnly Property ActiveApplication As WpfApplication
    Get
Visual C++
public:
property WpfApplication^ ActiveApplication {
    WpfApplication^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


ActiveBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..ActiveBrowser Property
Manager Class See Also Send Feedback
Gets the last browser instance launched.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser ActiveBrowser { get; }
Visual Basic
Public ReadOnly Property ActiveBrowser As Browser
    Get
Visual C++
public:
property Browser^ ActiveBrowser {
    Browser^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Applications Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Applications Property
Manager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Manager.Applications"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<WpfApplication> Applications { get; }
Visual Basic
Public ReadOnly Property Applications As IList(Of WpfApplication)
    Get
Visual C++
public:
property IList<WpfApplication^>^ Applications {
    IList<WpfApplication^>^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Browsers Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Browsers Property
Manager Class See Also Send Feedback
Gets the array of browser instances connected to this instance of the Manager. This should be considered a one-time snapshot and long-term object references to it should be avoided.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Browser> Browsers { get; }
Visual Basic
Public ReadOnly Property Browsers As ReadOnlyCollection(Of Browser)
    Get
Visual C++
public:
property ReadOnlyCollection<Browser^>^ Browsers {
    ReadOnlyCollection<Browser^>^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Current Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Current Property
Manager Class See Also Send Feedback
Gets the current active manager object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Manager Current { get; }
Visual Basic
Public Shared ReadOnly Property Current As Manager
    Get
Visual C++
public:
static property Manager^ Current {
    Manager^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Desktop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Desktop Property
Manager Class See Also Send Feedback
Gets the Desktop object that can be used to invoke desktop input devices like Mouse, Keyboard events.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Desktop Desktop { get; }
Visual Basic
Public ReadOnly Property Desktop As Desktop
    Get
Visual C++
public:
property Desktop^ Desktop {
    Desktop^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


DialogMonitor Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..DialogMonitor Property
Manager Class See Also Send Feedback
Gets the DialogMonitor object that handles popup dialogs

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogMonitor DialogMonitor { get; }
Visual Basic
Public ReadOnly Property DialogMonitor As DialogMonitor
    Get
Visual C++
public:
property DialogMonitor^ DialogMonitor {
    DialogMonitor^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Disposed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Disposed Property
Manager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Manager.Disposed"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Disposed { get; }
Visual Basic
Public ReadOnly Property Disposed As Boolean
    Get
Visual C++
public:
virtual property bool Disposed {
    bool get () sealed;
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Elements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Elements Property
Manager Class See Also Send Feedback
Gets the element finder to be used for finding elements defined by the FindParam attributes. This Elements object replaces all the Find.Elements since current FindParamAttributes are not frames and test region aware.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ElementFinder Elements { get; }
Visual Basic
Public ReadOnly Property Elements As ElementFinder
    Get
Visual C++
public:
property ElementFinder^ Elements {
    ElementFinder^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


ErrorStatus Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..ErrorStatus Property
Manager Class See Also Send Feedback
Set when the manager is in an error condition

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ErrorStatus { get; set; }
Visual Basic
Public Property ErrorStatus As String
    Get
    Set
Visual C++
public:
property String^ ErrorStatus {
    String^ get ();
    void set (String^ value);
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Http Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Http Property
Manager Class See Also Send Feedback
Gets the HttpProxy instance if UseHttpProxy is set to true, else will return null.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpProxyManager Http { get; }
Visual Basic
Public ReadOnly Property Http As HttpProxyManager
    Get
Visual C++
public:
property HttpProxyManager^ Http {
    HttpProxyManager^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Log Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Log Property
Manager Class See Also Send Feedback
Gets the Log object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Log Log { get; set; }
Visual Basic
Public Property Log As Log
    Get
    Set
Visual C++
public:
property Log^ Log {
    Log^ get ();
    void set (Log^ value);
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


PipeName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..PipeName Property
Manager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Manager.PipeName"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string PipeName { get; }
Visual Basic
Public ReadOnly Property PipeName As String
    Get
Visual C++
public:
property String^ PipeName {
    String^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Settings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Settings Property
Manager Class See Also Send Feedback
Gets the settings object that this Manager instance was initialized with.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings Settings { get; }
Visual Basic
Public ReadOnly Property Settings As Settings
    Get
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Wait Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..Wait Property
Manager Class See Also Send Feedback
Gets a wait object that can be used to wait on specific actions on elements/controls or custom predicate actions

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitSync Wait { get; }
Visual Basic
Public ReadOnly Property Wait As WaitSync
    Get
Visual C++
public:
property WaitSync^ Wait {
    WaitSync^ get ();
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


Manager Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager Events
Manager Class See Also Send Feedback

The Manager type exposes the following members.

Events

 | Name | Description
Public event | ActiveBrowserChanged | Occurs when active browser is changed. After attachment this event will fire, using actual active browser.

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


ActiveBrowserChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Manager..::..ActiveBrowserChanged Event
Manager Class See Also Send Feedback
Occurs when active browser is changed. After attachment this event will fire, using actual active browser.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event Manager..::..ActiveBrowserChangedHandler ActiveBrowserChanged
Visual Basic
Public Event ActiveBrowserChanged As Manager..::..ActiveBrowserChangedHandler
Visual C++
public:
 event Manager..::..ActiveBrowserChangedHandler^ ActiveBrowserChanged {
    void add (Manager..::..ActiveBrowserChangedHandler^ value);
    void remove (Manager..::..ActiveBrowserChangedHandler^ value);
}

See Also

Manager Class
ArtOfTest.WebAii.Core Namespace


MappingsCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection Members
MappingsCollection Class Constructors Methods Properties See Also Send Feedback

The MappingsCollection type exposes the following members.

Constructors

 | Name | Description
Public method | MappingsCollection | Create a new mappings collection.

Methods

 | Name | Description
Public method | Add | Add a new value
Public method | Clear | Clear the collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Get a value
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | Set a value
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllKeys | Gets the keys for the collection.
Public property | Item | Access a value using its name

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


MappingsCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection Constructor
MappingsCollection Class See Also Send Feedback
Create a new mappings collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MappingsCollection()
Visual Basic
Public Sub New
Visual C++
public:
MappingsCollection()

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


MappingsCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection Methods
MappingsCollection Class See Also Send Feedback

The MappingsCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add a new value
Public method | Clear | Clear the collection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Get a value
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | Set a value
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


Add Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection..::..Add Method
MappingsCollection Class See Also Send Feedback
Add a new value

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Add(
    string name,
    string value
)
Visual Basic
Public Sub Add ( _
    name As String, _
    value As String _
)
Visual C++
public:
void Add(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Core.MappingsCollection.Add(System.String,System.String)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Core.MappingsCollection.Add(System.String,System.String)"]

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection..::..Clear Method
MappingsCollection Class See Also Send Feedback
Clear the collection

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


Get Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection..::..Get Method
MappingsCollection Class See Also Send Feedback
Get a value

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Get(
    string name
)
Visual Basic
Public Function Get ( _
    name As String _
) As String
Visual C++
public:
String^ Get(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Core.MappingsCollection.Get(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Core.MappingsCollection.Get(System.String)"]

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


Set Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection..::..Set Method
MappingsCollection Class See Also Send Feedback
Set a value

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Set(
    string name,
    string value
)
Visual Basic
Public Sub Set ( _
    name As String, _
    value As String _
)
Visual C++
public:
void Set(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Core.MappingsCollection.Set(System.String,System.String)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Core.MappingsCollection.Set(System.String,System.String)"]

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


MappingsCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection Properties
MappingsCollection Class See Also Send Feedback

The MappingsCollection type exposes the following members.

Properties

 | Name | Description
Public property | AllKeys | Gets the keys for the collection.
Public property | Item | Access a value using its name

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


AllKeys Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection..::..AllKeys Property
MappingsCollection Class See Also Send Feedback
Gets the keys for the collection.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string[] AllKeys { get; }
Visual Basic
Public ReadOnly Property AllKeys As String()
    Get
Visual C++
public:
property array<String^>^ AllKeys {
    array<String^>^ get ();
}

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MappingsCollection..::..Item Property
MappingsCollection Class See Also Send Feedback
Access a value using its name

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string this[
    string name
] { get; set; }
Visual Basic
Public Default Property Item ( _
    name As String _
) As String
    Get
    Set
Visual C++
public:
property String^ default[String^ name] {
    String^ get (String^ name);
    void set (String^ name, String^ value);
}

Parameters

name
Type: System..::..String

Return Value

See Also

MappingsCollection Class
ArtOfTest.WebAii.Core Namespace


Settings Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Members
Settings Class Constructors Methods Fields Properties See Also Send Feedback

The Settings type exposes the following members.

Constructors

 | Name | Description
Public method | Settings()()()() | Create a new Settings object.
Public method | Settings(Settings) | Create a clone of the passed in settings
Public method | Settings(SettingsConfigSectionHandler) | Create a new Settings object from a config section.
Public method | Settings(Settings..::..WebSettings, Settings..::..WpfSettings) | Initializes a new instance of the Settings class

Methods

Name | Description
Public method Clone
Clone the existing settings
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | LoadFrom
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method PersistToConfigSection
Persist current Settings to a section handler.
Public method Reset
Resets all settings to the default system settings of the infrastructure.

Examples

The following are the system default settings:

DefaultBrowser=InternetExplorer
ClientReadyTimeout=30000
ExecutionCommandTimeout=20000
LogLocation='C:\WebAiiLog\'
WebAppPhysicalPath=""
EnableScriptLogging=false
QueryEventLogErrorsOnExit=false
LocalWebServer=LocalWebServerType.None
EnableUILessRequestViewing=false
BaseUrl=""
ExecutionDelay=0
AnnotateExecution=false
SimulatedMouseMoveSpeed=0.3f
waitCheckInterval=500
aspNetDevServer=-1
annotationMode=All
logAnnotations=false
createLogFile=true
killBrowserProcessOnClose=false
recycleBrowser=false
enableSilverlight=false
useHttpProxy=false
verboseHttpProxy=false
SilverlightConnectTimeout=30000msec
Public method | SaveTo
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method Validate
Validate the settings.

Fields

Name | Description
ObsoleteProperties | XmlSerializer won't deserialize properties marked as Obsolete So we'll keep a list here of all our obsolete properties, for use when encountering an UnknownElement during Deserialization

Properties

 | Name | Description
Public property | AnnotateExecution | Gets/Sets whether to highlight/annotate the target elements that action is being executed against. Default is false.
Public property | AnnotationMode | Gets/Sets the annotation mode when annotation is enabled. Default is All.
Public property | ClientReadyTimeout | Gets/Sets timeout used to wait for a client to be ready after initial launch and after executing a command. (msec.). Default is 20000 msec.
Public property | CreateLogFile | Gets or sets whether or not to create a log file on disk. This value is read once at initialization time. Changing this value during test execution has no effect. Default is true
 | Current | The current settings object.
Public property | CurrentVersion |
Public property | DisableDialogMonitoring |
Public property | ElementWaitTimeout | Gets/Sets the global wait on elements timeout that will be used during execution.
Public property | ExecuteCommandTimeout | Gets/Sets The timeout to wait for a command request to execute. (msec.). Default is 30000 msec.
Public property | ExecutionDelay | Gets/Sets an execution delay in between commands. This can help in observing test execution. Default is zero.
 | Is64BitOS | Whether or not we're a 32-bit app running on a 64 bit OS
Public property | IsUserInteractiveMode | Gets whether the test is running in a user interactive mode or as non-user interactive.
Public property | LogAnnotations | Gets/Sets whether or not to log annotations to the log file. Default is false.
Public property | LogLocation | Gets/Sets the location where to perform all the logging. Default is C:\WebAiiLog\.
Public property | QueryEventLogErrorsOnExit | Gets/Sets whether to query the event log on manager exit for any error logged from automation clients. Any errors will be logged to the test log. Default is false.
Public property | RootName |
Public property | SimulatedMouseMoveSpeed | Gets/Sets the simulated mouse move speed for Desktop.Mouse.Move()/DragDrop() operations in pixels/msec. [Typically between 0.1f - .5f] Default is 0.3f
Public property | UnexpectedDialogAction |
Public property | WaitCheckInterval | Gets/Sets the interval in msec. to use between checks for all the WaitForxx methods. Default is 500 msec.
Public property | Web | Container for all web specific settings
Public property | Wpf | Container for all wpf specific settings
Public property | XmlBlob |
Public property | XMultiMgr | Gets/Sets whether or not to use WebAii 1.1 style connections. Default is false.

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Settings Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Constructor
Settings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Settings()()()() | Create a new Settings object.
Public method | Settings(Settings) | Create a clone of the passed in settings
Public method | Settings(SettingsConfigSectionHandler) | Create a new Settings object from a config section.
Public method | Settings(Settings..::..WebSettings, Settings..::..WpfSettings) | Initializes a new instance of the Settings class

See Also

Settings Class
Settings Members
ArtOfTest.WebAii.Core Namespace


Settings Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Constructor
Settings Class See Also Send Feedback
Create a new Settings object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings()
Visual Basic
Public Sub New
Visual C++
public:
Settings()

See Also

Settings Class
Settings Overload
ArtOfTest.WebAii.Core Namespace


Settings Constructor (Settings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Constructor (Settings)
Settings Class See Also Send Feedback
Create a clone of the passed in settings

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings(
    Settings settingsToClone
)
Visual Basic
Public Sub New ( _
    settingsToClone As Settings _
)
Visual C++
public:
Settings(
    Settings^ settingsToClone
)

Parameters

settingsToClone
Type: ArtOfTest.WebAii.Core..::..Settings

[Missing <param name="settingsToClone"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.#ctor(ArtOfTest.WebAii.Core.Settings)"]

See Also

Settings Class
Settings Overload
ArtOfTest.WebAii.Core Namespace


Settings Constructor (SettingsConfigSectionHandler)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Constructor (SettingsConfigSectionHandler)
Settings Class See Also Send Feedback
Create a new Settings object from a config section.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings(
    SettingsConfigSectionHandler sectionHandler
)
Visual Basic
Public Sub New ( _
    sectionHandler As SettingsConfigSectionHandler _
)
Visual C++
public:
Settings(
    SettingsConfigSectionHandler^ sectionHandler
)

Parameters

sectionHandler
Type: ArtOfTest.WebAii.Core..::..SettingsConfigSectionHandler
The config section handler that contains the settings.

See Also

Settings Class
Settings Overload
ArtOfTest.WebAii.Core Namespace


Settings Constructor (Settings.WebSettings, Settings.WpfSettings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Constructor (Settings..::..WebSettings, Settings..::..WpfSettings)
Settings Class See Also Send Feedback
Initializes a new instance of the Settings class

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings(
    Settings..::..WebSettings webSettings,
    Settings..::..WpfSettings wpfSettings
)
Visual Basic
Public Sub New ( _
    webSettings As Settings..::..WebSettings, _
    wpfSettings As Settings..::..WpfSettings _
)
Visual C++
public:
Settings(
    Settings..::..WebSettings^ webSettings,
    Settings..::..WpfSettings^ wpfSettings
)

Parameters

webSettings
Type: ArtOfTest.WebAii.Core..::..Settings..::..WebSettings

[Missing <param name="webSettings"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.#ctor(ArtOfTest.WebAii.Core.Settings.WebSettings,ArtOfTest.WebAii.Core.Settings.WpfSettings)"]

wpfSettings
Type: ArtOfTest.WebAii.Core..::..Settings..::..WpfSettings

[Missing <param name="wpfSettings"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.#ctor(ArtOfTest.WebAii.Core.Settings.WebSettings,ArtOfTest.WebAii.Core.Settings.WpfSettings)"]

See Also

Settings Class
Settings Overload
ArtOfTest.WebAii.Core Namespace


Settings Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Fields
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Fields

Name | Description
ObsoleteProperties | XmlSerializer won't deserialize properties marked as Obsolete So we'll keep a list here of all our obsolete properties, for use when encountering an UnknownElement during Deserialization

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


ObsoleteProperties Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..ObsoleteProperties Field
Settings Class See Also Send Feedback
XmlSerializer won't deserialize properties marked as Obsolete So we'll keep a list here of all our obsolete properties, for use when encountering an UnknownElement during Deserialization

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly Dictionary<string, Type> ObsoleteProperties
Visual Basic
Public Shared ReadOnly ObsoleteProperties As Dictionary(Of String, Type)
Visual C++
public:
static initonly Dictionary<String^, Type^>^ ObsoleteProperties

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Settings Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

Name | Description
Public method Clone
Clone the existing settings
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method | LoadFrom
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method PersistToConfigSection
Persist current Settings to a section handler.
Public method Reset
Resets all settings to the default system settings of the infrastructure.

Examples

The following are the system default settings:

DefaultBrowser=InternetExplorer
ClientReadyTimeout=30000
ExecutionCommandTimeout=20000
LogLocation='C:\WebAiiLog\'
WebAppPhysicalPath=""
EnableScriptLogging=false
QueryEventLogErrorsOnExit=false
LocalWebServer=LocalWebServerType.None
EnableUILessRequestViewing=false
BaseUrl=""
ExecutionDelay=0
AnnotateExecution=false
SimulatedMouseMoveSpeed=0.3f
waitCheckInterval=500
aspNetDevServer=-1
annotationMode=All
logAnnotations=false
createLogFile=true
killBrowserProcessOnClose=false
recycleBrowser=false
enableSilverlight=false
useHttpProxy=false
verboseHttpProxy=false
SilverlightConnectTimeout=30000msec
Public method | SaveTo
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method Validate
Validate the settings.

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Clone Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..Clone Method
Settings Class See Also Send Feedback
Clone the existing settings

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings Clone()
Visual Basic
Public Function Clone As Settings
Visual C++
public:
Settings^ Clone()

Return Value

The cloned settings

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..LoadFrom Method
Settings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Settings.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


PersistToConfigSection Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..PersistToConfigSection Method
Settings Class See Also Send Feedback
Persist current Settings to a section handler.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void PersistToConfigSection(
    SettingsConfigSectionHandler sectionHandler
)
Visual Basic
Public Sub PersistToConfigSection ( _
    sectionHandler As SettingsConfigSectionHandler _
)
Visual C++
public:
void PersistToConfigSection(
    SettingsConfigSectionHandler^ sectionHandler
)

Parameters

sectionHandler
Type: ArtOfTest.WebAii.Core..::..SettingsConfigSectionHandler

[Missing <param name="sectionHandler"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.PersistToConfigSection(ArtOfTest.WebAii.Core.SettingsConfigSectionHandler)"]

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Reset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..Reset Method
Settings Class See Also Send Feedback
Resets all settings to the default system settings of the infrastructure.

Examples

The following are the system default settings:

DefaultBrowser=InternetExplorer
ClientReadyTimeout=30000
ExecutionCommandTimeout=20000
LogLocation='C:\WebAiiLog\'
WebAppPhysicalPath=""
EnableScriptLogging=false
QueryEventLogErrorsOnExit=false
LocalWebServer=LocalWebServerType.None
EnableUILessRequestViewing=false
BaseUrl=""
ExecutionDelay=0
AnnotateExecution=false
SimulatedMouseMoveSpeed=0.3f
waitCheckInterval=500
aspNetDevServer=-1
annotationMode=All
logAnnotations=false
createLogFile=true
killBrowserProcessOnClose=false
recycleBrowser=false
enableSilverlight=false
useHttpProxy=false
verboseHttpProxy=false
SilverlightConnectTimeout=30000msec

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..SaveTo Method
Settings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Settings.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Validate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..Validate Method
Settings Class See Also Send Feedback
Validate the settings.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Validate()
Visual Basic
Public Sub Validate
Visual C++
public:
void Validate()

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Settings Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings Properties
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Properties

 | Name | Description
Public property | AnnotateExecution | Gets/Sets whether to highlight/annotate the target elements that action is being executed against. Default is false.
Public property | AnnotationMode | Gets/Sets the annotation mode when annotation is enabled. Default is All.
Public property | ClientReadyTimeout | Gets/Sets timeout used to wait for a client to be ready after initial launch and after executing a command. (msec.). Default is 20000 msec.
Public property | CreateLogFile | Gets or sets whether or not to create a log file on disk. This value is read once at initialization time. Changing this value during test execution has no effect. Default is true
 | Current | The current settings object.
Public property | CurrentVersion |
Public property | DisableDialogMonitoring |
Public property | ElementWaitTimeout | Gets/Sets the global wait on elements timeout that will be used during execution.
Public property | ExecuteCommandTimeout | Gets/Sets The timeout to wait for a command request to execute. (msec.). Default is 30000 msec.
Public property | ExecutionDelay | Gets/Sets an execution delay in between commands. This can help in observing test execution. Default is zero.
 | Is64BitOS | Whether or not we're a 32-bit app running on a 64 bit OS
Public property | IsUserInteractiveMode | Gets whether the test is running in a user interactive mode or as non-user interactive.
Public property | LogAnnotations | Gets/Sets whether or not to log annotations to the log file. Default is false.
Public property | LogLocation | Gets/Sets the location where to perform all the logging. Default is C:\WebAiiLog\.
Public property | QueryEventLogErrorsOnExit | Gets/Sets whether to query the event log on manager exit for any error logged from automation clients. Any errors will be logged to the test log. Default is false.
Public property | RootName |
Public property | SimulatedMouseMoveSpeed | Gets/Sets the simulated mouse move speed for Desktop.Mouse.Move()/DragDrop() operations in pixels/msec. [Typically between 0.1f - .5f] Default is 0.3f
Public property | UnexpectedDialogAction |
Public property | WaitCheckInterval | Gets/Sets the interval in msec. to use between checks for all the WaitForxx methods. Default is 500 msec.
Public property | Web | Container for all web specific settings
Public property | Wpf | Container for all wpf specific settings
Public property | XmlBlob |
Public property | XMultiMgr | Gets/Sets whether or not to use WebAii 1.1 style connections. Default is false.

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


AnnotateExecution Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..AnnotateExecution Property
Settings Class See Also Send Feedback
Gets/Sets whether to highlight/annotate the target elements that action is being executed against. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AnnotateExecution { get; set; }
Visual Basic
Public Property AnnotateExecution As Boolean
    Get
    Set
Visual C++
public:
property bool AnnotateExecution {
    bool get ();
    void set (bool value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


AnnotationMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..AnnotationMode Property
Settings Class See Also Send Feedback
Gets/Sets the annotation mode when annotation is enabled. Default is All.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AnnotationMode AnnotationMode { get; set; }
Visual Basic
Public Property AnnotationMode As AnnotationMode
    Get
    Set
Visual C++
public:
property AnnotationMode AnnotationMode {
    AnnotationMode get ();
    void set (AnnotationMode value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


ClientReadyTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..ClientReadyTimeout Property
Settings Class See Also Send Feedback
Gets/Sets timeout used to wait for a client to be ready after initial launch and after executing a command. (msec.). Default is 20000 msec.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ClientReadyTimeout { get; set; }
Visual Basic
Public Property ClientReadyTimeout As Integer
    Get
    Set
Visual C++
public:
property int ClientReadyTimeout {
    int get ();
    void set (int value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


CreateLogFile Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..CreateLogFile Property
Settings Class See Also Send Feedback
Gets or sets whether or not to create a log file on disk. This value is read once at initialization time. Changing this value during test execution has no effect. Default is true

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CreateLogFile { get; set; }
Visual Basic
Public Property CreateLogFile As Boolean
    Get
    Set
Visual C++
public:
property bool CreateLogFile {
    bool get ();
    void set (bool value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Current Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..Current Property
Settings Class See Also Send Feedback
The current settings object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Settings Current { get; }
Visual Basic
Public Shared ReadOnly Property Current As Settings
    Get
Visual C++
public:
static property Settings^ Current {
    Settings^ get ();
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..CurrentVersion Property
Settings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


DisableDialogMonitoring Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..DisableDialogMonitoring Property
Settings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.DisableDialogMonitoring"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool DisableDialogMonitoring { get; set; }
Visual Basic
Public Property DisableDialogMonitoring As Boolean
    Get
    Set
Visual C++
public:
property bool DisableDialogMonitoring {
    bool get ();
    void set (bool value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


ElementWaitTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..ElementWaitTimeout Property
Settings Class See Also Send Feedback
Gets/Sets the global wait on elements timeout that will be used during execution.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ElementWaitTimeout { get; set; }
Visual Basic
Public Property ElementWaitTimeout As Integer
    Get
    Set
Visual C++
public:
property int ElementWaitTimeout {
    int get ();
    void set (int value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


ExecuteCommandTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..ExecuteCommandTimeout Property
Settings Class See Also Send Feedback
Gets/Sets The timeout to wait for a command request to execute. (msec.). Default is 30000 msec.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecuteCommandTimeout { get; set; }
Visual Basic
Public Property ExecuteCommandTimeout As Integer
    Get
    Set
Visual C++
public:
property int ExecuteCommandTimeout {
    int get ();
    void set (int value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


ExecutionDelay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..ExecutionDelay Property
Settings Class See Also Send Feedback
Gets/Sets an execution delay in between commands. This can help in observing test execution. Default is zero.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecutionDelay { get; set; }
Visual Basic
Public Property ExecutionDelay As Integer
    Get
    Set
Visual C++
public:
property int ExecutionDelay {
    int get ();
    void set (int value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Is64BitOS Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..Is64BitOS Property
Settings Class See Also Send Feedback
Whether or not we're a 32-bit app running on a 64 bit OS

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool Is64BitOS { get; }
Visual Basic
Public Shared ReadOnly Property Is64BitOS As Boolean
    Get
Visual C++
public:
static property bool Is64BitOS {
    bool get ();
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


IsUserInteractiveMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..IsUserInteractiveMode Property
Settings Class See Also Send Feedback
Gets whether the test is running in a user interactive mode or as non-user interactive.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsUserInteractiveMode { get; }
Visual Basic
Public ReadOnly Property IsUserInteractiveMode As Boolean
    Get
Visual C++
public:
property bool IsUserInteractiveMode {
    bool get ();
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


LogAnnotations Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..LogAnnotations Property
Settings Class See Also Send Feedback
Gets/Sets whether or not to log annotations to the log file. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool LogAnnotations { get; set; }
Visual Basic
Public Property LogAnnotations As Boolean
    Get
    Set
Visual C++
public:
property bool LogAnnotations {
    bool get ();
    void set (bool value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


LogLocation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..LogLocation Property
Settings Class See Also Send Feedback
Gets/Sets the location where to perform all the logging. Default is C:\WebAiiLog\.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string LogLocation { get; set; }
Visual Basic
Public Property LogLocation As String
    Get
    Set
Visual C++
public:
property String^ LogLocation {
    String^ get ();
    void set (String^ value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


QueryEventLogErrorsOnExit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..QueryEventLogErrorsOnExit Property
Settings Class See Also Send Feedback
Gets/Sets whether to query the event log on manager exit for any error logged from automation clients. Any errors will be logged to the test log. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool QueryEventLogErrorsOnExit { get; set; }
Visual Basic
Public Property QueryEventLogErrorsOnExit As Boolean
    Get
    Set
Visual C++
public:
property bool QueryEventLogErrorsOnExit {
    bool get ();
    void set (bool value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..RootName Property
Settings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.RootName"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


SimulatedMouseMoveSpeed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..SimulatedMouseMoveSpeed Property
Settings Class See Also Send Feedback
Gets/Sets the simulated mouse move speed for Desktop.Mouse.Move()/DragDrop() operations in pixels/msec. [Typically between 0.1f - .5f] Default is 0.3f

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public float SimulatedMouseMoveSpeed { get; set; }
Visual Basic
Public Property SimulatedMouseMoveSpeed As Single
    Get
    Set
Visual C++
public:
property float SimulatedMouseMoveSpeed {
    float get ();
    void set (float value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


UnexpectedDialogAction Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..UnexpectedDialogAction Property
Settings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.UnexpectedDialogAction"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UnexpectedDialogAction UnexpectedDialogAction { get; set; }
Visual Basic
Public Property UnexpectedDialogAction As UnexpectedDialogAction
    Get
    Set
Visual C++
public:
property UnexpectedDialogAction UnexpectedDialogAction {
    UnexpectedDialogAction get ();
    void set (UnexpectedDialogAction value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


WaitCheckInterval Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WaitCheckInterval Property
Settings Class See Also Send Feedback
Gets/Sets the interval in msec. to use between checks for all the WaitForxx methods. Default is 500 msec.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int WaitCheckInterval { get; set; }
Visual Basic
Public Property WaitCheckInterval As Integer
    Get
    Set
Visual C++
public:
property int WaitCheckInterval {
    int get ();
    void set (int value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Web Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..Web Property
Settings Class See Also Send Feedback
Container for all web specific settings

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings..::..WebSettings Web { get; set; }
Visual Basic
Public Property Web As Settings..::..WebSettings
    Get
    Set
Visual C++
public:
property Settings..::..WebSettings^ Web {
    Settings..::..WebSettings^ get ();
    void set (Settings..::..WebSettings^ value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Wpf Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..Wpf Property
Settings Class See Also Send Feedback
Container for all wpf specific settings

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings..::..WpfSettings Wpf { get; set; }
Visual Basic
Public Property Wpf As Settings..::..WpfSettings
    Get
    Set
Visual C++
public:
property Settings..::..WpfSettings^ Wpf {
    Settings..::..WpfSettings^ get ();
    void set (Settings..::..WpfSettings^ value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..XmlBlob Property
Settings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.XmlBlob"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


XMultiMgr Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..XMultiMgr Property
Settings Class See Also Send Feedback
Gets/Sets whether or not to use WebAii 1.1 style connections. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool XMultiMgr { get; set; }
Visual Basic
Public Property XMultiMgr As Boolean
    Get
    Set
Visual C++
public:
property bool XMultiMgr {
    bool get ();
    void set (bool value);
}

See Also

Settings Class
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Members
Settings..::..WebSettings Class Constructors Methods Properties See Also Send Feedback

Class representing the settings to be used when initializing the framework.

The Settings..::..WebSettings type exposes the following members.

Constructors

 | Name | Description
Public method | Settings..::..WebSettings()()()() | Initializes a new instance of the Settings..::..WebSettings class
Public method | Settings..::..WebSettings(String) | Create a new Settings.Web object.
Public method | Settings..::..WebSettings(BrowserType) | Create a new Settings object.
Public method | Settings..::..WebSettings(Settings..::..WebSettings) | Create a clone of the passed in settings
Public method | Settings..::..WebSettings(WebSettingsConfigSectionHandler) | Create a new Settings object from a config section.
Public method | Settings..::..WebSettings(BrowserType, String) | Create a new Settings object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PersistToConfigSection | Persist current Settings to a section handler.
Public method | SaveTo |
Public method | SetWebAppPhysicalBase | Set the WebApp Physical base to be used when using relative WebAppPhysicalBase.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate |

Properties

Name | Description
Public property AspNetDevServerPhysicalPath
Gets the physical path
Public property AspNetDevServerPort
Gets/Sets the AspNetDevServer (if used) port to use. If this is not set (-1) a random port will be generated each time the manager is created.
Public property BaseUrl
Gets/Sets the base url to use for all NavigateTo commands. When set NavigateTo should use a relative url (i.e. "~/default.aspx"). Default is string.empty.
Public property Browser
Serves as a wrapper of the DefaultBrowser property.
Public property | CurrentVersion
Public property DefaultBrowser
Gets/Sets a supported default browser type (IE,FireFox ...etc). Default is InternetExplorer.
Public property EnableScriptLogging
Gets/Sets whether or not to enable script logging. Default is false.
Public property EnableSilverlight
Gets/Sets whether or not to enable Silverlight automation. Default is false.
Public property EnableUILessRequestViewing
Gets/Sets whether or not to allow debugging of UILess page requests using a UI browser like IE. Default is false.
Public property | ExecutingBrowsers
Public property KillBrowserProcessOnClose
Gets or sets whether to make sure the browser process is killed when closing the browser. Note: Firefox is a single process browser. If you are using multiple browser instances and this setting is on, it will kill all open instances of Firefox when you close one of the instances. Default is false.
Public property LocalWebServer
Gets/Sets the local web server to use to serve pages. Default is None.
Public property RecycleBrowser
When set to true, once instance of the browser will be launched and recycled through out the test bed and tests until Manager.Dispose is called.
Public property | RootName
Public property SilverlightApplicationPath
Gets/Sets the path from which to load a silverlight application
Public property SilverlightConnectTimeout
Gets/Sets the Silverlight Application load timeout
Public property UseHttpProxy
Gets/Sets whether or not to use the built-in http proxy during automation. Default is false.
Public property | UseMultiBrowserExecution
Public property VerboseHttpProxy
Gets/Sets whether the HTTP proxy produces lots of tracing output. Default is false.
Public property WebAppPhysicalPath
Gets/Sets the physical path to the application to test when running under the ASP.NET development server. Default is string.empty.

Examples

C:\Inetpub\wwwroot\myApp\
Public property | WebKitExecutionDelay
Public property | XmlBlob

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Constructor
Settings..::..WebSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Settings..::..WebSettings()()()() | Initializes a new instance of the Settings..::..WebSettings class
Public method | Settings..::..WebSettings(String) | Create a new Settings.Web object.
Public method | Settings..::..WebSettings(BrowserType) | Create a new Settings object.
Public method | Settings..::..WebSettings(Settings..::..WebSettings) | Create a clone of the passed in settings
Public method | Settings..::..WebSettings(WebSettingsConfigSectionHandler) | Create a new Settings object from a config section.
Public method | Settings..::..WebSettings(BrowserType, String) | Create a new Settings object.

See Also

Settings..::..WebSettings Class
Settings..::..WebSettings Members
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Constructor
Settings..::..WebSettings Class See Also Send Feedback
Initializes a new instance of the Settings..::..WebSettings class

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebSettings()
Visual Basic
Public Sub New
Visual C++
public:
WebSettings()

See Also

Settings..::..WebSettings Class
Settings..::..WebSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Constructor (String)
Settings..::..WebSettings Class See Also Send Feedback
Create a new Settings.Web object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebSettings(
    string baseUrl
)
Visual Basic
Public Sub New ( _
    baseUrl As String _
)
Visual C++
public:
WebSettings(
    String^ baseUrl
)

Parameters

baseUrl
Type: System..::..String
The baseUrl to use

See Also

Settings..::..WebSettings Class
Settings..::..WebSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Constructor (BrowserType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Constructor (BrowserType)
Settings..::..WebSettings Class See Also Send Feedback
Create a new Settings object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebSettings(
    BrowserType defaultBrowser
)
Visual Basic
Public Sub New ( _
    defaultBrowser As BrowserType _
)
Visual C++
public:
WebSettings(
    BrowserType defaultBrowser
)

Parameters

defaultBrowser
Type: ArtOfTest.WebAii.Core..::..BrowserType
The default browser to use.

See Also

Settings..::..WebSettings Class
Settings..::..WebSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Constructor (Settings.WebSettings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Constructor (Settings..::..WebSettings)
Settings..::..WebSettings Class See Also Send Feedback
Create a clone of the passed in settings

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebSettings(
    Settings..::..WebSettings settingsToClone
)
Visual Basic
Public Sub New ( _
    settingsToClone As Settings..::..WebSettings _
)
Visual C++
public:
WebSettings(
    Settings..::..WebSettings^ settingsToClone
)

Parameters

settingsToClone
Type: ArtOfTest.WebAii.Core..::..Settings..::..WebSettings

[Missing <param name="settingsToClone"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.WebSettings.#ctor(ArtOfTest.WebAii.Core.Settings.WebSettings)"]

See Also

Settings..::..WebSettings Class
Settings..::..WebSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Constructor (WebSettingsConfigSectionHandler)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Constructor (WebSettingsConfigSectionHandler)
Settings..::..WebSettings Class See Also Send Feedback
Create a new Settings object from a config section.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebSettings(
    WebSettingsConfigSectionHandler sectionHandler
)
Visual Basic
Public Sub New ( _
    sectionHandler As WebSettingsConfigSectionHandler _
)
Visual C++
public:
WebSettings(
    WebSettingsConfigSectionHandler^ sectionHandler
)

Parameters

sectionHandler
Type: ArtOfTest.WebAii.Core..::..WebSettingsConfigSectionHandler
The config section handler that contains the settings.

See Also

Settings..::..WebSettings Class
Settings..::..WebSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Constructor (BrowserType, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Constructor (BrowserType, String)
Settings..::..WebSettings Class See Also Send Feedback
Create a new Settings object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebSettings(
    BrowserType defaultBrowser,
    string baseUrl
)
Visual Basic
Public Sub New ( _
    defaultBrowser As BrowserType, _
    baseUrl As String _
)
Visual C++
public:
WebSettings(
    BrowserType defaultBrowser,
    String^ baseUrl
)

Parameters

defaultBrowser
Type: ArtOfTest.WebAii.Core..::..BrowserType
The default browser to use.
baseUrl
Type: System..::..String
The baseUrl to use.

See Also

Settings..::..WebSettings Class
Settings..::..WebSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Methods
Settings..::..WebSettings Class See Also Send Feedback

The Settings..::..WebSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PersistToConfigSection | Persist current Settings to a section handler.
Public method | SaveTo |
Public method | SetWebAppPhysicalBase | Set the WebApp Physical base to be used when using relative WebAppPhysicalBase.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Validate |

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..LoadFrom Method
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Settings.WebSettings.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.WebSettings.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


PersistToConfigSection Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..PersistToConfigSection Method
Settings..::..WebSettings Class See Also Send Feedback
Persist current Settings to a section handler.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void PersistToConfigSection(
    WebSettingsConfigSectionHandler sectionHandler
)
Visual Basic
Public Sub PersistToConfigSection ( _
    sectionHandler As WebSettingsConfigSectionHandler _
)
Visual C++
public:
void PersistToConfigSection(
    WebSettingsConfigSectionHandler^ sectionHandler
)

Parameters

sectionHandler
Type: ArtOfTest.WebAii.Core..::..WebSettingsConfigSectionHandler

[Missing <param name="sectionHandler"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.WebSettings.PersistToConfigSection(ArtOfTest.WebAii.Core.WebSettingsConfigSectionHandler)"]

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..SaveTo Method
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Settings.WebSettings.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.WebSettings.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


SetWebAppPhysicalBase Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..SetWebAppPhysicalBase Method
Settings..::..WebSettings Class See Also Send Feedback
Set the WebApp Physical base to be used when using relative WebAppPhysicalBase.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetWebAppPhysicalBase(
    string physicalBase
)
Visual Basic
Public Sub SetWebAppPhysicalBase ( _
    physicalBase As String _
)
Visual C++
public:
void SetWebAppPhysicalBase(
    String^ physicalBase
)

Parameters

physicalBase
Type: System..::..String
Physical app base

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


Validate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..Validate Method
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Settings.WebSettings.Validate"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Validate()
Visual Basic
Public Sub Validate
Visual C++
public:
void Validate()

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


Settings.WebSettings Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings Properties
Settings..::..WebSettings Class See Also Send Feedback

The Settings..::..WebSettings type exposes the following members.

Properties

Name | Description
Public property AspNetDevServerPhysicalPath
Gets the physical path
Public property AspNetDevServerPort
Gets/Sets the AspNetDevServer (if used) port to use. If this is not set (-1) a random port will be generated each time the manager is created.
Public property BaseUrl
Gets/Sets the base url to use for all NavigateTo commands. When set NavigateTo should use a relative url (i.e. "~/default.aspx"). Default is string.empty.
Public property Browser
Serves as a wrapper of the DefaultBrowser property.
Public property | CurrentVersion
Public property DefaultBrowser
Gets/Sets a supported default browser type (IE,FireFox ...etc). Default is InternetExplorer.
Public property EnableScriptLogging
Gets/Sets whether or not to enable script logging. Default is false.
Public property EnableSilverlight
Gets/Sets whether or not to enable Silverlight automation. Default is false.
Public property EnableUILessRequestViewing
Gets/Sets whether or not to allow debugging of UILess page requests using a UI browser like IE. Default is false.
Public property | ExecutingBrowsers
Public property KillBrowserProcessOnClose
Gets or sets whether to make sure the browser process is killed when closing the browser. Note: Firefox is a single process browser. If you are using multiple browser instances and this setting is on, it will kill all open instances of Firefox when you close one of the instances. Default is false.
Public property LocalWebServer
Gets/Sets the local web server to use to serve pages. Default is None.
Public property RecycleBrowser
When set to true, once instance of the browser will be launched and recycled through out the test bed and tests until Manager.Dispose is called.
Public property | RootName
Public property SilverlightApplicationPath
Gets/Sets the path from which to load a silverlight application
Public property SilverlightConnectTimeout
Gets/Sets the Silverlight Application load timeout
Public property UseHttpProxy
Gets/Sets whether or not to use the built-in http proxy during automation. Default is false.
Public property | UseMultiBrowserExecution
Public property VerboseHttpProxy
Gets/Sets whether the HTTP proxy produces lots of tracing output. Default is false.
Public property WebAppPhysicalPath
Gets/Sets the physical path to the application to test when running under the ASP.NET development server. Default is string.empty.

Examples

C:\Inetpub\wwwroot\myApp\
Public property | WebKitExecutionDelay
Public property | XmlBlob

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


AspNetDevServerPhysicalPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..AspNetDevServerPhysicalPath Property
Settings..::..WebSettings Class See Also Send Feedback
Gets the physical path

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string AspNetDevServerPhysicalPath { get; }
Visual Basic
Public ReadOnly Property AspNetDevServerPhysicalPath As String
    Get
Visual C++
public:
property String^ AspNetDevServerPhysicalPath {
    String^ get ();
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


AspNetDevServerPort Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..AspNetDevServerPort Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets the AspNetDevServer (if used) port to use. If this is not set (-1) a random port will be generated each time the manager is created.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AspNetDevServerPort { get; set; }
Visual Basic
Public Property AspNetDevServerPort As Integer
    Get
    Set
Visual C++
public:
property int AspNetDevServerPort {
    int get ();
    void set (int value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


BaseUrl Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..BaseUrl Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets the base url to use for all NavigateTo commands. When set NavigateTo should use a relative url (i.e. "~/default.aspx"). Default is string.empty.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string BaseUrl { get; set; }
Visual Basic
Public Property BaseUrl As String
    Get
    Set
Visual C++
public:
property String^ BaseUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


Browser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..Browser Property
Settings..::..WebSettings Class See Also Send Feedback
Serves as a wrapper of the DefaultBrowser property.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserExecutionType Browser { get; set; }
Visual Basic
Public Property Browser As BrowserExecutionType
    Get
    Set
Visual C++
public:
property BrowserExecutionType Browser {
    BrowserExecutionType get ();
    void set (BrowserExecutionType value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..CurrentVersion Property
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WebSettings.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


DefaultBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..DefaultBrowser Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets a supported default browser type (IE,FireFox ...etc). Default is InternetExplorer.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserType DefaultBrowser { get; set; }
Visual Basic
Public Property DefaultBrowser As BrowserType
    Get
    Set
Visual C++
public:
property BrowserType DefaultBrowser {
    BrowserType get ();
    void set (BrowserType value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


EnableScriptLogging Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..EnableScriptLogging Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets whether or not to enable script logging. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableScriptLogging { get; set; }
Visual Basic
Public Property EnableScriptLogging As Boolean
    Get
    Set
Visual C++
public:
property bool EnableScriptLogging {
    bool get ();
    void set (bool value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


EnableSilverlight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..EnableSilverlight Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets whether or not to enable Silverlight automation. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableSilverlight { get; set; }
Visual Basic
Public Property EnableSilverlight As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSilverlight {
    bool get ();
    void set (bool value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


EnableUILessRequestViewing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..EnableUILessRequestViewing Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets whether or not to allow debugging of UILess page requests using a UI browser like IE. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableUILessRequestViewing { get; set; }
Visual Basic
Public Property EnableUILessRequestViewing As Boolean
    Get
    Set
Visual C++
public:
property bool EnableUILessRequestViewing {
    bool get ();
    void set (bool value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


ExecutingBrowsers Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..ExecutingBrowsers Property
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WebSettings.ExecutingBrowsers"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<BrowserExecutionType> ExecutingBrowsers { get; set; }
Visual Basic
Public Property ExecutingBrowsers As List(Of BrowserExecutionType)
    Get
    Set
Visual C++
public:
property List<BrowserExecutionType>^ ExecutingBrowsers {
    List<BrowserExecutionType>^ get ();
    void set (List<BrowserExecutionType>^ value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


KillBrowserProcessOnClose Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..KillBrowserProcessOnClose Property
Settings..::..WebSettings Class See Also Send Feedback
Gets or sets whether to make sure the browser process is killed when closing the browser. Note: Firefox is a single process browser. If you are using multiple browser instances and this setting is on, it will kill all open instances of Firefox when you close one of the instances. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool KillBrowserProcessOnClose { get; set; }
Visual Basic
Public Property KillBrowserProcessOnClose As Boolean
    Get
    Set
Visual C++
public:
property bool KillBrowserProcessOnClose {
    bool get ();
    void set (bool value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


LocalWebServer Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..LocalWebServer Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets the local web server to use to serve pages. Default is None.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LocalWebServerType LocalWebServer { get; set; }
Visual Basic
Public Property LocalWebServer As LocalWebServerType
    Get
    Set
Visual C++
public:
property LocalWebServerType LocalWebServer {
    LocalWebServerType get ();
    void set (LocalWebServerType value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


RecycleBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..RecycleBrowser Property
Settings..::..WebSettings Class See Also Send Feedback
When set to true, once instance of the browser will be launched and recycled through out the test bed and tests until Manager.Dispose is called.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RecycleBrowser { get; set; }
Visual Basic
Public Property RecycleBrowser As Boolean
    Get
    Set
Visual C++
public:
property bool RecycleBrowser {
    bool get ();
    void set (bool value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..RootName Property
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WebSettings.RootName"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


SilverlightApplicationPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..SilverlightApplicationPath Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets the path from which to load a silverlight application

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SilverlightApplicationPath { get; set; }
Visual Basic
Public Property SilverlightApplicationPath As String
    Get
    Set
Visual C++
public:
property String^ SilverlightApplicationPath {
    String^ get ();
    void set (String^ value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


SilverlightConnectTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..SilverlightConnectTimeout Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets the Silverlight Application load timeout

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SilverlightConnectTimeout { get; set; }
Visual Basic
Public Property SilverlightConnectTimeout As Integer
    Get
    Set
Visual C++
public:
property int SilverlightConnectTimeout {
    int get ();
    void set (int value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


UseHttpProxy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..UseHttpProxy Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets whether or not to use the built-in http proxy during automation. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool UseHttpProxy { get; set; }
Visual Basic
Public Property UseHttpProxy As Boolean
    Get
    Set
Visual C++
public:
property bool UseHttpProxy {
    bool get ();
    void set (bool value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


UseMultiBrowserExecution Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..UseMultiBrowserExecution Property
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WebSettings.UseMultiBrowserExecution"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool UseMultiBrowserExecution { get; set; }
Visual Basic
Public Property UseMultiBrowserExecution As Boolean
    Get
    Set
Visual C++
public:
property bool UseMultiBrowserExecution {
    bool get ();
    void set (bool value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


VerboseHttpProxy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..VerboseHttpProxy Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets whether the HTTP proxy produces lots of tracing output. Default is false.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool VerboseHttpProxy { get; set; }
Visual Basic
Public Property VerboseHttpProxy As Boolean
    Get
    Set
Visual C++
public:
property bool VerboseHttpProxy {
    bool get ();
    void set (bool value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


WebAppPhysicalPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..WebAppPhysicalPath Property
Settings..::..WebSettings Class See Also Send Feedback
Gets/Sets the physical path to the application to test when running under the ASP.NET development server. Default is string.empty.

Examples

C:\Inetpub\wwwroot\myApp\

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string WebAppPhysicalPath { get; set; }
Visual Basic
Public Property WebAppPhysicalPath As String
    Get
    Set
Visual C++
public:
property String^ WebAppPhysicalPath {
    String^ get ();
    void set (String^ value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


WebKitExecutionDelay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..WebKitExecutionDelay Property
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WebSettings.WebKitExecutionDelay"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int WebKitExecutionDelay { get; set; }
Visual Basic
Public Property WebKitExecutionDelay As Integer
    Get
    Set
Visual C++
public:
property int WebKitExecutionDelay {
    int get ();
    void set (int value);
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WebSettings..::..XmlBlob Property
Settings..::..WebSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WebSettings.XmlBlob"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

Settings..::..WebSettings Class
ArtOfTest.WebAii.Core Namespace


Settings.WpfSettings Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings Members
Settings..::..WpfSettings Class Constructors Methods Properties See Also Send Feedback

Class representing the settings to be used when initializing the framework.

The Settings..::..WpfSettings type exposes the following members.

Constructors

 | Name | Description
Public method | Settings..::..WpfSettings()()()() | Initializes a new instance of the Settings..::..WpfSettings class
Public method | Settings..::..WpfSettings(String) | Create a new Settings.Wpf object.
Public method | Settings..::..WpfSettings(Settings..::..WpfSettings) | Create a clone of the passed in settings

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | DefaultApplicationPath | Gets/Sets the default application path to be used in WPF tests. Represents the default application path for the WPF tests. Once set each test will by default use that path for recording and execution unless one unchecks the "Use default path" option in the WPF test configuration dialog.
Public property | RootName |
Public property | XmlBlob |

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


Settings.WpfSettings Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings Constructor
Settings..::..WpfSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Settings..::..WpfSettings()()()() | Initializes a new instance of the Settings..::..WpfSettings class
Public method | Settings..::..WpfSettings(String) | Create a new Settings.Wpf object.
Public method | Settings..::..WpfSettings(Settings..::..WpfSettings) | Create a clone of the passed in settings

See Also

Settings..::..WpfSettings Class
Settings..::..WpfSettings Members
ArtOfTest.WebAii.Core Namespace


Settings.WpfSettings Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings Constructor
Settings..::..WpfSettings Class See Also Send Feedback
Initializes a new instance of the Settings..::..WpfSettings class

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfSettings()
Visual Basic
Public Sub New
Visual C++
public:
WpfSettings()

See Also

Settings..::..WpfSettings Class
Settings..::..WpfSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WpfSettings Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings Constructor (String)
Settings..::..WpfSettings Class See Also Send Feedback
Create a new Settings.Wpf object.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfSettings(
    string defaultApplicationPath
)
Visual Basic
Public Sub New ( _
    defaultApplicationPath As String _
)
Visual C++
public:
WpfSettings(
    String^ defaultApplicationPath
)

Parameters

defaultApplicationPath
Type: System..::..String

[Missing <param name="defaultApplicationPath"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.WpfSettings.#ctor(System.String)"]

See Also

Settings..::..WpfSettings Class
Settings..::..WpfSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WpfSettings Constructor (Settings.WpfSettings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings Constructor (Settings..::..WpfSettings)
Settings..::..WpfSettings Class See Also Send Feedback
Create a clone of the passed in settings

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfSettings(
    Settings..::..WpfSettings settingsToClone
)
Visual Basic
Public Sub New ( _
    settingsToClone As Settings..::..WpfSettings _
)
Visual C++
public:
WpfSettings(
    Settings..::..WpfSettings^ settingsToClone
)

Parameters

settingsToClone
Type: ArtOfTest.WebAii.Core..::..Settings..::..WpfSettings

[Missing <param name="settingsToClone"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.WpfSettings.#ctor(ArtOfTest.WebAii.Core.Settings.WpfSettings)"]

See Also

Settings..::..WpfSettings Class
Settings..::..WpfSettings Overload
ArtOfTest.WebAii.Core Namespace


Settings.WpfSettings Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings Methods
Settings..::..WpfSettings Class See Also Send Feedback

The Settings..::..WpfSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings..::..LoadFrom Method
Settings..::..WpfSettings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Settings.WpfSettings.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.WpfSettings.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings..::..SaveTo Method
Settings..::..WpfSettings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Core.Settings.WpfSettings.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Core.Settings.WpfSettings.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


Settings.WpfSettings Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings Properties
Settings..::..WpfSettings Class See Also Send Feedback

The Settings..::..WpfSettings type exposes the following members.

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | DefaultApplicationPath | Gets/Sets the default application path to be used in WPF tests. Represents the default application path for the WPF tests. Once set each test will by default use that path for recording and execution unless one unchecks the "Use default path" option in the WPF test configuration dialog.
Public property | RootName |
Public property | XmlBlob |

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings..::..CurrentVersion Property
Settings..::..WpfSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WpfSettings.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


DefaultApplicationPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings..::..DefaultApplicationPath Property
Settings..::..WpfSettings Class See Also Send Feedback
Gets/Sets the default application path to be used in WPF tests. Represents the default application path for the WPF tests. Once set each test will by default use that path for recording and execution unless one unchecks the "Use default path" option in the WPF test configuration dialog.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DefaultApplicationPath { get; set; }
Visual Basic
Public Property DefaultApplicationPath As String
    Get
    Set
Visual C++
public:
property String^ DefaultApplicationPath {
    String^ get ();
    void set (String^ value);
}

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings..::..RootName Property
Settings..::..WpfSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WpfSettings.RootName"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Settings..::..WpfSettings..::..XmlBlob Property
Settings..::..WpfSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Core.Settings.WpfSettings.XmlBlob"]

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

Settings..::..WpfSettings Class
ArtOfTest.WebAii.Core Namespace


SettingsConfigSectionHandler Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler Members
SettingsConfigSectionHandler Class Constructors Methods Properties See Also Send Feedback

The SettingsConfigSectionHandler type exposes the following members.

Constructors

 | Name | Description
Public method | SettingsConfigSectionHandler | Initializes a new instance of the SettingsConfigSectionHandler class

Methods

 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified()()()() method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | AnnotateExecution | Whether to enable execution highlight.
Public property | AnnotationMode | Gets the annotation mode.
Public property | ClientReadyTimeout | Gets the client ready timeout.
Public property | CreateLogFile | Gets whether to create a log file on disk.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | ElementWaitTimeout | The global wait for elements timeout (msec) to be used during execution.
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | ExecutionDelay | The execution delay set.
Public property | ExecutionTimeout | Gets the Execution timeout for commands.
Protected property | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | LogAnnotations | Gets whether to log annotations to log file.
Public property | LogLocation | Gets the log location where all logging by the framework will take place.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | QueryEventLogErrorsOnExit | If true, will query the event log for any un expected client errors.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SimulatedMouseMoveSpeed | The simulated mouse move speed
Public property | UnexpectedDialogAction | Specifies the action to take when an unexpected dialog is encountered
Public property | WaitCheckInterval | The global wait.Forxx interval check.
Public property | XMultiMgr | Enables WebAii 1.1 style connections to the browser. Added for backwards compatibility for VistaPrint doing parallel testing multiple managers.

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


SettingsConfigSectionHandler Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler Constructor
SettingsConfigSectionHandler Class See Also Send Feedback
Initializes a new instance of the SettingsConfigSectionHandler class

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SettingsConfigSectionHandler()
Visual Basic
Public Sub New
Visual C++
public:
SettingsConfigSectionHandler()

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


SettingsConfigSectionHandler Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler Methods
SettingsConfigSectionHandler Class See Also Send Feedback

The SettingsConfigSectionHandler type exposes the following members.

Methods

 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified()()()() method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


SettingsConfigSectionHandler Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler Properties
SettingsConfigSectionHandler Class See Also Send Feedback

The SettingsConfigSectionHandler type exposes the following members.

Properties

 | Name | Description
Public property | AnnotateExecution | Whether to enable execution highlight.
Public property | AnnotationMode | Gets the annotation mode.
Public property | ClientReadyTimeout | Gets the client ready timeout.
Public property | CreateLogFile | Gets whether to create a log file on disk.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | ElementWaitTimeout | The global wait for elements timeout (msec) to be used during execution.
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | ExecutionDelay | The execution delay set.
Public property | ExecutionTimeout | Gets the Execution timeout for commands.
Protected property | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | LogAnnotations | Gets whether to log annotations to log file.
Public property | LogLocation | Gets the log location where all logging by the framework will take place.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | QueryEventLogErrorsOnExit | If true, will query the event log for any un expected client errors.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SimulatedMouseMoveSpeed | The simulated mouse move speed
Public property | UnexpectedDialogAction | Specifies the action to take when an unexpected dialog is encountered
Public property | WaitCheckInterval | The global wait.Forxx interval check.
Public property | XMultiMgr | Enables WebAii 1.1 style connections to the browser. Added for backwards compatibility for VistaPrint doing parallel testing multiple managers.

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


AnnotateExecution Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..AnnotateExecution Property
SettingsConfigSectionHandler Class See Also Send Feedback
Whether to enable execution highlight.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AnnotateExecution { get; set; }
Visual Basic
Public Property AnnotateExecution As Boolean
    Get
    Set
Visual C++
public:
property bool AnnotateExecution {
    bool get ();
    void set (bool value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


AnnotationMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..AnnotationMode Property
SettingsConfigSectionHandler Class See Also Send Feedback
Gets the annotation mode.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AnnotationMode AnnotationMode { get; set; }
Visual Basic
Public Property AnnotationMode As AnnotationMode
    Get
    Set
Visual C++
public:
property AnnotationMode AnnotationMode {
    AnnotationMode get ();
    void set (AnnotationMode value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


ClientReadyTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..ClientReadyTimeout Property
SettingsConfigSectionHandler Class See Also Send Feedback
Gets the client ready timeout.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ClientReadyTimeout { get; set; }
Visual Basic
Public Property ClientReadyTimeout As Integer
    Get
    Set
Visual C++
public:
property int ClientReadyTimeout {
    int get ();
    void set (int value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


CreateLogFile Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..CreateLogFile Property
SettingsConfigSectionHandler Class See Also Send Feedback
Gets whether to create a log file on disk.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CreateLogFile { get; set; }
Visual Basic
Public Property CreateLogFile As Boolean
    Get
    Set
Visual C++
public:
property bool CreateLogFile {
    bool get ();
    void set (bool value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


ElementWaitTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..ElementWaitTimeout Property
SettingsConfigSectionHandler Class See Also Send Feedback
The global wait for elements timeout (msec) to be used during execution.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ElementWaitTimeout { get; set; }
Visual Basic
Public Property ElementWaitTimeout As Integer
    Get
    Set
Visual C++
public:
property int ElementWaitTimeout {
    int get ();
    void set (int value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


ExecutionDelay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..ExecutionDelay Property
SettingsConfigSectionHandler Class See Also Send Feedback
The execution delay set.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecutionDelay { get; set; }
Visual Basic
Public Property ExecutionDelay As Integer
    Get
    Set
Visual C++
public:
property int ExecutionDelay {
    int get ();
    void set (int value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


ExecutionTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..ExecutionTimeout Property
SettingsConfigSectionHandler Class See Also Send Feedback
Gets the Execution timeout for commands.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecutionTimeout { get; set; }
Visual Basic
Public Property ExecutionTimeout As Integer
    Get
    Set
Visual C++
public:
property int ExecutionTimeout {
    int get ();
    void set (int value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..Item Property
SettingsConfigSectionHandler Class See Also Send Feedback

Overload List

 | Name | Description
Protected property | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)

See Also

SettingsConfigSectionHandler Class
SettingsConfigSectionHandler Members
ArtOfTest.WebAii.Core Namespace


LogAnnotations Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..LogAnnotations Property
SettingsConfigSectionHandler Class See Also Send Feedback
Gets whether to log annotations to log file.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool LogAnnotations { get; set; }
Visual Basic
Public Property LogAnnotations As Boolean
    Get
    Set
Visual C++
public:
property bool LogAnnotations {
    bool get ();
    void set (bool value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


LogLocation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..LogLocation Property
SettingsConfigSectionHandler Class See Also Send Feedback
Gets the log location where all logging by the framework will take place.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string LogLocation { get; set; }
Visual Basic
Public Property LogLocation As String
    Get
    Set
Visual C++
public:
property String^ LogLocation {
    String^ get ();
    void set (String^ value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


QueryEventLogErrorsOnExit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..QueryEventLogErrorsOnExit Property
SettingsConfigSectionHandler Class See Also Send Feedback
If true, will query the event log for any un expected client errors.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool QueryEventLogErrorsOnExit { get; set; }
Visual Basic
Public Property QueryEventLogErrorsOnExit As Boolean
    Get
    Set
Visual C++
public:
property bool QueryEventLogErrorsOnExit {
    bool get ();
    void set (bool value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


SimulatedMouseMoveSpeed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..SimulatedMouseMoveSpeed Property
SettingsConfigSectionHandler Class See Also Send Feedback
The simulated mouse move speed

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public float SimulatedMouseMoveSpeed { get; set; }
Visual Basic
Public Property SimulatedMouseMoveSpeed As Single
    Get
    Set
Visual C++
public:
property float SimulatedMouseMoveSpeed {
    float get ();
    void set (float value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


UnexpectedDialogAction Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..UnexpectedDialogAction Property
SettingsConfigSectionHandler Class See Also Send Feedback
Specifies the action to take when an unexpected dialog is encountered

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UnexpectedDialogAction UnexpectedDialogAction { get; set; }
Visual Basic
Public Property UnexpectedDialogAction As UnexpectedDialogAction
    Get
    Set
Visual C++
public:
property UnexpectedDialogAction UnexpectedDialogAction {
    UnexpectedDialogAction get ();
    void set (UnexpectedDialogAction value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


WaitCheckInterval Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..WaitCheckInterval Property
SettingsConfigSectionHandler Class See Also Send Feedback
The global wait.Forxx interval check.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int WaitCheckInterval { get; set; }
Visual Basic
Public Property WaitCheckInterval As Integer
    Get
    Set
Visual C++
public:
property int WaitCheckInterval {
    int get ();
    void set (int value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


XMultiMgr Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SettingsConfigSectionHandler..::..XMultiMgr Property
SettingsConfigSectionHandler Class See Also Send Feedback
Enables WebAii 1.1 style connections to the browser. Added for backwards compatibility for VistaPrint doing parallel testing multiple managers.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool XMultiMgr { get; set; }
Visual Basic
Public Property XMultiMgr As Boolean
    Get
    Set
Visual C++
public:
property bool XMultiMgr {
    bool get ();
    void set (bool value);
}

See Also

SettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


TreeBuilder Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeBuilder Members
TreeBuilder Class Methods Properties See Also Send Feedback

The TreeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDomTree | Parse and build the Dom. This method will initialize the Root property with the root element of the Dom. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Protected method | ClearTree | (Inherited from HtmlTreeBuilder.)
Public method | CreateNewElement | (Inherited from HtmlTreeBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | StartTagCloses | Determines whether to close an open tag with an optional closing tag based on the new tag we're parsing (Inherited from HtmlTreeBuilder.)
Public method | TestRegionDetected | (Inherited from HtmlTreeBuilder.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackRecursiveContainer | (Inherited from HtmlTreeBuilder.)

Properties

 | Name | Description
Public property | DocType | Gets the DOCTYPE element if present in the document. Otherwise null. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Protected property | RecursiveContainerTags | (Inherited from HtmlTreeBuilder.)
Public property | Root | Gets the root Element node. You can access the tree using this node. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Public property | TestRegions | (Inherited from HtmlTreeBuilder.)

See Also

TreeBuilder Class
ArtOfTest.WebAii.Core Namespace


TreeBuilder Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeBuilder Methods
TreeBuilder Class See Also Send Feedback

The TreeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDomTree | Parse and build the Dom. This method will initialize the Root property with the root element of the Dom. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Protected method | ClearTree | (Inherited from HtmlTreeBuilder.)
Public method | CreateNewElement | (Inherited from HtmlTreeBuilder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | StartTagCloses | Determines whether to close an open tag with an optional closing tag based on the new tag we're parsing (Inherited from HtmlTreeBuilder.)
Public method | TestRegionDetected | (Inherited from HtmlTreeBuilder.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackRecursiveContainer | (Inherited from HtmlTreeBuilder.)

See Also

TreeBuilder Class
ArtOfTest.WebAii.Core Namespace


TreeBuilder Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeBuilder Properties
TreeBuilder Class See Also Send Feedback

The TreeBuilder type exposes the following members.

Properties

 | Name | Description
Public property | DocType | Gets the DOCTYPE element if present in the document. Otherwise null. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Protected property | RecursiveContainerTags | (Inherited from HtmlTreeBuilder.)
Public property | Root | Gets the root Element node. You can access the tree using this node. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Public property | TestRegions | (Inherited from HtmlTreeBuilder.)

See Also

TreeBuilder Class
ArtOfTest.WebAii.Core Namespace


WebSettingsConfigSectionHandler Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler Members
WebSettingsConfigSectionHandler Class Constructors Methods Properties See Also Send Feedback

The WebSettingsConfigSectionHandler type exposes the following members.

Constructors

 | Name | Description
Public method | WebSettingsConfigSectionHandler | Initializes a new instance of the WebSettingsConfigSectionHandler class

Methods

 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified()()()() method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)

Properties

 | Name | Description
Public property | AspNetDevServerPort | Gets the AspNetDevServer port if set.
Public property | BaseUrl | The base url to use for all NavigateTo actions in the framework.
Public property | DefaultBrowser | Gets the default browser used by the Manager when none is specified.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EnableScriptLogging | Gets whether to enable script logging or not.
Public property | EnableSilverlight | Enable silverlight automation.
Public property | EnableUILessRequestViewing | Whether to enable debugging of the UILess page requests using a UI browser like IE.
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | KillBrowserProcessOnClose | Gets whether to kill browser processes on exit
Public property | LocalWebServer | Gets which local web server to use to serve test pages.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | RecycleBrowser | Gets whether to recycle the browser instance or not.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SilverlightApplicationPath | Gets the Silverlight Application Path
Public property | SilverlightConnectTimeout | Gets the default Silverlight app connect timeout
Public property | UseHttpProxy | Whether to use the built-in http proxy.
Public property | VerboseHttpProxy | Enable lots of tracing output from the built-in HTTP proxy
Public property | WebAppPhysicalPath | If UseAspNetDevServer is true, then will indicate the physical path to the application we are testing.

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


WebSettingsConfigSectionHandler Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler Constructor
WebSettingsConfigSectionHandler Class See Also Send Feedback
Initializes a new instance of the WebSettingsConfigSectionHandler class

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebSettingsConfigSectionHandler()
Visual Basic
Public Sub New
Visual C++
public:
WebSettingsConfigSectionHandler()

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


WebSettingsConfigSectionHandler Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler Methods
WebSettingsConfigSectionHandler Class See Also Send Feedback

The WebSettingsConfigSectionHandler type exposes the following members.

Methods

 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Inherited from ConfigurationSection.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified()()()() method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly()()()() property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


WebSettingsConfigSectionHandler Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler Properties
WebSettingsConfigSectionHandler Class See Also Send Feedback

The WebSettingsConfigSectionHandler type exposes the following members.

Properties

 | Name | Description
Public property | AspNetDevServerPort | Gets the AspNetDevServer port if set.
Public property | BaseUrl | The base url to use for all NavigateTo actions in the framework.
Public property | DefaultBrowser | Gets the default browser used by the Manager when none is specified.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EnableScriptLogging | Gets whether to enable script logging or not.
Public property | EnableSilverlight | Enable silverlight automation.
Public property | EnableUILessRequestViewing | Whether to enable debugging of the UILess page requests using a UI browser like IE.
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | KillBrowserProcessOnClose | Gets whether to kill browser processes on exit
Public property | LocalWebServer | Gets which local web server to use to serve test pages.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | RecycleBrowser | Gets whether to recycle the browser instance or not.
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Public property | SilverlightApplicationPath | Gets the Silverlight Application Path
Public property | SilverlightConnectTimeout | Gets the default Silverlight app connect timeout
Public property | UseHttpProxy | Whether to use the built-in http proxy.
Public property | VerboseHttpProxy | Enable lots of tracing output from the built-in HTTP proxy
Public property | WebAppPhysicalPath | If UseAspNetDevServer is true, then will indicate the physical path to the application we are testing.

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


AspNetDevServerPort Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..AspNetDevServerPort Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Gets the AspNetDevServer port if set.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AspNetDevServerPort { get; set; }
Visual Basic
Public Property AspNetDevServerPort As Integer
    Get
    Set
Visual C++
public:
property int AspNetDevServerPort {
    int get ();
    void set (int value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


BaseUrl Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..BaseUrl Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
The base url to use for all NavigateTo actions in the framework.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string BaseUrl { get; set; }
Visual Basic
Public Property BaseUrl As String
    Get
    Set
Visual C++
public:
property String^ BaseUrl {
    String^ get ();
    void set (String^ value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


DefaultBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..DefaultBrowser Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Gets the default browser used by the Manager when none is specified.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserType DefaultBrowser { get; set; }
Visual Basic
Public Property DefaultBrowser As BrowserType
    Get
    Set
Visual C++
public:
property BrowserType DefaultBrowser {
    BrowserType get ();
    void set (BrowserType value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


EnableScriptLogging Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..EnableScriptLogging Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Gets whether to enable script logging or not.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableScriptLogging { get; set; }
Visual Basic
Public Property EnableScriptLogging As Boolean
    Get
    Set
Visual C++
public:
property bool EnableScriptLogging {
    bool get ();
    void set (bool value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


EnableSilverlight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..EnableSilverlight Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Enable silverlight automation.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableSilverlight { get; set; }
Visual Basic
Public Property EnableSilverlight As Boolean
    Get
    Set
Visual C++
public:
property bool EnableSilverlight {
    bool get ();
    void set (bool value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


EnableUILessRequestViewing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..EnableUILessRequestViewing Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Whether to enable debugging of the UILess page requests using a UI browser like IE.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableUILessRequestViewing { get; set; }
Visual Basic
Public Property EnableUILessRequestViewing As Boolean
    Get
    Set
Visual C++
public:
property bool EnableUILessRequestViewing {
    bool get ();
    void set (bool value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..Item Property
WebSettingsConfigSectionHandler Class See Also Send Feedback

Overload List

 | Name | Description
Protected property | Item[([( ConfigurationProperty])]) | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | Item[([( String])]) | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)

See Also

WebSettingsConfigSectionHandler Class
WebSettingsConfigSectionHandler Members
ArtOfTest.WebAii.Core Namespace


KillBrowserProcessOnClose Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..KillBrowserProcessOnClose Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Gets whether to kill browser processes on exit

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool KillBrowserProcessOnClose { get; set; }
Visual Basic
Public Property KillBrowserProcessOnClose As Boolean
    Get
    Set
Visual C++
public:
property bool KillBrowserProcessOnClose {
    bool get ();
    void set (bool value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


LocalWebServer Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..LocalWebServer Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Gets which local web server to use to serve test pages.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LocalWebServerType LocalWebServer { get; set; }
Visual Basic
Public Property LocalWebServer As LocalWebServerType
    Get
    Set
Visual C++
public:
property LocalWebServerType LocalWebServer {
    LocalWebServerType get ();
    void set (LocalWebServerType value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


RecycleBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..RecycleBrowser Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Gets whether to recycle the browser instance or not.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RecycleBrowser { get; set; }
Visual Basic
Public Property RecycleBrowser As Boolean
    Get
    Set
Visual C++
public:
property bool RecycleBrowser {
    bool get ();
    void set (bool value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


SilverlightApplicationPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..SilverlightApplicationPath Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Gets the Silverlight Application Path

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SilverlightApplicationPath { get; set; }
Visual Basic
Public Property SilverlightApplicationPath As String
    Get
    Set
Visual C++
public:
property String^ SilverlightApplicationPath {
    String^ get ();
    void set (String^ value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


SilverlightConnectTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..SilverlightConnectTimeout Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Gets the default Silverlight app connect timeout

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SilverlightConnectTimeout { get; set; }
Visual Basic
Public Property SilverlightConnectTimeout As Integer
    Get
    Set
Visual C++
public:
property int SilverlightConnectTimeout {
    int get ();
    void set (int value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


UseHttpProxy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..UseHttpProxy Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Whether to use the built-in http proxy.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool UseHttpProxy { get; set; }
Visual Basic
Public Property UseHttpProxy As Boolean
    Get
    Set
Visual C++
public:
property bool UseHttpProxy {
    bool get ();
    void set (bool value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


VerboseHttpProxy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..VerboseHttpProxy Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
Enable lots of tracing output from the built-in HTTP proxy

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool VerboseHttpProxy { get; set; }
Visual Basic
Public Property VerboseHttpProxy As Boolean
    Get
    Set
Visual C++
public:
property bool VerboseHttpProxy {
    bool get ();
    void set (bool value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


WebAppPhysicalPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebSettingsConfigSectionHandler..::..WebAppPhysicalPath Property
WebSettingsConfigSectionHandler Class See Also Send Feedback
If UseAspNetDevServer is true, then will indicate the physical path to the application we are testing.

Namespace: ArtOfTest.WebAii.Core
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string WebAppPhysicalPath { get; set; }
Visual Basic
Public Property WebAppPhysicalPath As String
    Get
    Set
Visual C++
public:
property String^ WebAppPhysicalPath {
    String^ get ();
    void set (String^ value);
}

See Also

WebSettingsConfigSectionHandler Class
ArtOfTest.WebAii.Core Namespace


ArtOfTest.WebAii.Design Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Design Namespace
Send Feedback
Namespace for the design functionality of the framework

Classes

 | Class | Description
Public class | AutomationStepResult | Represents an automation step results
Public class | BaseWebAiiTest | Base execution class for a WebAii testcase code behind class.
Public class | BaseWebAiiTest..::..TestData |
Public class | DesignTimeExecutionParams | Hold all parameters needed for quick execution.
Public class | ElementsGenerator | Used to generate element descriptors
Public class | HtmlCommandType |
Public class | PerUserSettings |
Public class | TestChangedEventArgs |
Public class | UserSettings | Class containing all the user settings for the current user and any system wide configurable settings

Structures

 | Structure | Description
Public structure | CommandType | Describes the action that took place on the Automation Overlay Surface
Public structure | SelectionValues | The list of values for a select dropdown

Enumerations

 | Enumeration | Description
Public enumeration | BrowserCommandType | Native recordable action from the recorder. (i.e. Click a button, Set text of a textbox)
Public enumeration | BrowserConstraints | The browser constraint
Public enumeration | BrowserStateCaptureMode | The enum to use for capturing browser states
Public enumeration | ComponentType | Different components of the ArtOfTest.WebAii.Design namespace
Public enumeration | DropTarget | The Drop target
Public enumeration | LoadTestResult | Error codes for loading a test from a file
Public enumeration | PageUriCompareMode | Different methods to perform page compares.
Public enumeration | RecordingSurfaceType | Possible recording surfaces
Public enumeration | SelectDropDownType | SelectDropDown type
Public enumeration | TestListType |


AutomationStepResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult Members
AutomationStepResult Class Constructors Methods Properties Events See Also Send Feedback

The AutomationStepResult type exposes the following members.

Constructors

 | Name | Description
Public method | AutomationStepResult | Create an empty result (ResultType=NotRun)

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBrowserState | Load the browser state
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Protected method | OnSerializing |
Public method | PersistStepFailureResourcesOnDisk | Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk.
Public method | SaveTo |
Public method | StoreHostState | Store the browser state as part of this step
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | Exception | Gets or sets the execution exception. If result type is fail, then this will contain the exception information about the failure.
Public property | HasExpectedImage |
Public property | HashCode |
Public property | HasImage |
Public property | IsManual |
Public property | LogMessageOnError |
Public property | Order |
Public property | ParentTestResult |
Public property | ResultType | Gets or sets the result type (Pass/fail/notrun)
Public property | RootName |
Public property | RunTimeStepId |
Public property | StepDescription | Gets or sets the description of this step.
Public property | TestId | Gets or sets the test unique Id this step result belongs to.
Public property | TestName | Gets or sets the test name of this step.
Public property | TestPath | Gets or sets the test path within the project.
Public property | TestStepIndex | Gets or sets the step index
Public property | UserComment |
Public property | WasStepEnabled |
Public property | XmlBlob |

Events

 | Name | Description
Public event | PropertyChanged |

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


AutomationStepResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult Constructor
AutomationStepResult Class See Also Send Feedback
Create an empty result (ResultType=NotRun)

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationStepResult()
Visual Basic
Public Sub New
Visual C++
public:
AutomationStepResult()

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


AutomationStepResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult Methods
AutomationStepResult Class See Also Send Feedback

The AutomationStepResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBrowserState | Load the browser state
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Protected method | OnSerializing |
Public method | PersistStepFailureResourcesOnDisk | Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk.
Public method | SaveTo |
Public method | StoreHostState | Store the browser state as part of this step
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


LoadBrowserState Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..LoadBrowserState Method
AutomationStepResult Class See Also Send Feedback
Load the browser state

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadBrowserState()
Visual Basic
Public Sub LoadBrowserState
Visual C++
public:
void LoadBrowserState()

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..LoadFrom Method
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Overridable Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
)

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


OnPropertyChanged Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..OnPropertyChanged Method
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.OnPropertyChanged(System.String)"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected internal virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Friend Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected public:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String

[Missing <param name="propertyName"/> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.OnPropertyChanged(System.String)"]

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


OnSerializing Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..OnSerializing Method
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.OnSerializing(System.Runtime.Serialization.StreamingContext)"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnSerializing(
    StreamingContext context
)
Visual Basic
Protected Sub OnSerializing ( _
    context As StreamingContext _
)
Visual C++
protected:
void OnSerializing(
    StreamingContext context
)

Parameters

context
Type: System.Runtime.Serialization..::..StreamingContext

[Missing <param name="context"/> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.OnSerializing(System.Runtime.Serialization.StreamingContext)"]

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


PersistStepFailureResourcesOnDisk Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..PersistStepFailureResourcesOnDisk Method
AutomationStepResult Class See Also Send Feedback
Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void PersistStepFailureResourcesOnDisk(
    string projectResultsPath,
    string resourceFolderPath
)
Visual Basic
Public Sub PersistStepFailureResourcesOnDisk ( _
    projectResultsPath As String, _
    resourceFolderPath As String _
)
Visual C++
public:
void PersistStepFailureResourcesOnDisk(
    String^ projectResultsPath,
    String^ resourceFolderPath
)

Parameters

projectResultsPath
Type: System..::..String
The path to the project results.
resourceFolderPath
Type: System..::..String
The folder path to persist the resources in.

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..SaveTo Method
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Overridable Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
)

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


StoreHostState Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..StoreHostState Method
AutomationStepResult Class See Also Send Feedback
Store the browser state as part of this step

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void StoreHostState(
    IAutomationHost host,
    List<ITargetElement> elements,
    string message
)
Visual Basic
Public Sub StoreHostState ( _
    host As IAutomationHost, _
    elements As List(Of ITargetElement), _
    message As String _
)
Visual C++
public:
void StoreHostState(
    IAutomationHost^ host,
    List<ITargetElement^>^ elements,
    String^ message
)

Parameters

host
Type: ArtOfTest.Common..::..IAutomationHost

[Missing <param name="host"/> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.StoreHostState(ArtOfTest.Common.IAutomationHost,System.Collections.Generic.List{ArtOfTest.Common.ITargetElement},System.String)"]

elements
Type: System.Collections.Generic..::..List <(Of <(<' ITargetElement >)>)>

[Missing <param name="elements"/> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.StoreHostState(ArtOfTest.Common.IAutomationHost,System.Collections.Generic.List{ArtOfTest.Common.ITargetElement},System.String)"]

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Design.AutomationStepResult.StoreHostState(ArtOfTest.Common.IAutomationHost,System.Collections.Generic.List{ArtOfTest.Common.ITargetElement},System.String)"]

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


AutomationStepResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult Properties
AutomationStepResult Class See Also Send Feedback

The AutomationStepResult type exposes the following members.

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | Exception | Gets or sets the execution exception. If result type is fail, then this will contain the exception information about the failure.
Public property | HasExpectedImage |
Public property | HashCode |
Public property | HasImage |
Public property | IsManual |
Public property | LogMessageOnError |
Public property | Order |
Public property | ParentTestResult |
Public property | ResultType | Gets or sets the result type (Pass/fail/notrun)
Public property | RootName |
Public property | RunTimeStepId |
Public property | StepDescription | Gets or sets the description of this step.
Public property | TestId | Gets or sets the test unique Id this step result belongs to.
Public property | TestName | Gets or sets the test name of this step.
Public property | TestPath | Gets or sets the test path within the project.
Public property | TestStepIndex | Gets or sets the step index
Public property | UserComment |
Public property | WasStepEnabled |
Public property | XmlBlob |

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..CurrentVersion Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Version CurrentVersion { get; }
Visual Basic
Public Overridable ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get ();
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


Exception Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..Exception Property
AutomationStepResult Class See Also Send Feedback
Gets or sets the execution exception. If result type is fail, then this will contain the exception information about the failure.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual ExecutionException Exception { get; set; }
Visual Basic
Public Overridable Property Exception As ExecutionException
    Get
    Set
Visual C++
public:
virtual property ExecutionException^ Exception {
    ExecutionException^ get ();
    void set (ExecutionException^ value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


HasExpectedImage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..HasExpectedImage Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.HasExpectedImage"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasExpectedImage { get; }
Visual Basic
Public ReadOnly Property HasExpectedImage As Boolean
    Get
Visual C++
public:
property bool HasExpectedImage {
    bool get ();
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


HashCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..HashCode Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.HashCode"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int HashCode { get; set; }
Visual Basic
Public Property HashCode As Integer
    Get
    Set
Visual C++
public:
property int HashCode {
    int get ();
    void set (int value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


HasImage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..HasImage Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.HasImage"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasImage { get; }
Visual Basic
Public ReadOnly Property HasImage As Boolean
    Get
Visual C++
public:
property bool HasImage {
    bool get ();
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


IsManual Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..IsManual Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.IsManual"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsManual { get; set; }
Visual Basic
Public Property IsManual As Boolean
    Get
    Set
Visual C++
public:
property bool IsManual {
    bool get ();
    void set (bool value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


LogMessageOnError Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..LogMessageOnError Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.LogMessageOnError"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string LogMessageOnError { get; set; }
Visual Basic
Public Property LogMessageOnError As String
    Get
    Set
Visual C++
public:
property String^ LogMessageOnError {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


Order Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..Order Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.Order"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Order { get; set; }
Visual Basic
Public Property Order As Integer
    Get
    Set
Visual C++
public:
property int Order {
    int get ();
    void set (int value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


ParentTestResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..ParentTestResult Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.ParentTestResult"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult ParentTestResult { get; set; }
Visual Basic
Public Property ParentTestResult As TestResult
    Get
    Set
Visual C++
public:
property TestResult^ ParentTestResult {
    TestResult^ get ();
    void set (TestResult^ value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


ResultType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..ResultType Property
AutomationStepResult Class See Also Send Feedback
Gets or sets the result type (Pass/fail/notrun)

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual ResultType ResultType { get; set; }
Visual Basic
Public Overridable Property ResultType As ResultType
    Get
    Set
Visual C++
public:
virtual property ResultType ResultType {
    ResultType get ();
    void set (ResultType value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..RootName Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.RootName"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string RootName { get; }
Visual Basic
Public Overridable ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get ();
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


RunTimeStepId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..RunTimeStepId Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.RunTimeStepId"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid RunTimeStepId { get; set; }
Visual Basic
Public Property RunTimeStepId As Guid
    Get
    Set
Visual C++
public:
property Guid RunTimeStepId {
    Guid get ();
    void set (Guid value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


StepDescription Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..StepDescription Property
AutomationStepResult Class See Also Send Feedback
Gets or sets the description of this step.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string StepDescription { get; set; }
Visual Basic
Public Property StepDescription As String
    Get
    Set
Visual C++
public:
property String^ StepDescription {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


TestId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..TestId Property
AutomationStepResult Class See Also Send Feedback
Gets or sets the test unique Id this step result belongs to.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestId { get; set; }
Visual Basic
Public Property TestId As String
    Get
    Set
Visual C++
public:
property String^ TestId {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


TestName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..TestName Property
AutomationStepResult Class See Also Send Feedback
Gets or sets the test name of this step.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestName { get; set; }
Visual Basic
Public Property TestName As String
    Get
    Set
Visual C++
public:
property String^ TestName {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


TestPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..TestPath Property
AutomationStepResult Class See Also Send Feedback
Gets or sets the test path within the project.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestPath { get; set; }
Visual Basic
Public Property TestPath As String
    Get
    Set
Visual C++
public:
property String^ TestPath {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


TestStepIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..TestStepIndex Property
AutomationStepResult Class See Also Send Feedback
Gets or sets the step index

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TestStepIndex { get; set; }
Visual Basic
Public Property TestStepIndex As Integer
    Get
    Set
Visual C++
public:
property int TestStepIndex {
    int get ();
    void set (int value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


UserComment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..UserComment Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.UserComment"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UserComment { get; set; }
Visual Basic
Public Property UserComment As String
    Get
    Set
Visual C++
public:
property String^ UserComment {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


WasStepEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..WasStepEnabled Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.WasStepEnabled"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool WasStepEnabled { get; set; }
Visual Basic
Public Property WasStepEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool WasStepEnabled {
    bool get ();
    void set (bool value);
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..XmlBlob Property
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.AutomationStepResult.XmlBlob"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


AutomationStepResult Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult Events
AutomationStepResult Class See Also Send Feedback

The AutomationStepResult type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged |

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


PropertyChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationStepResult..::..PropertyChanged Event
AutomationStepResult Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.AutomationStepResult.PropertyChanged"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

AutomationStepResult Class
ArtOfTest.WebAii.Design Namespace


BaseWebAiiTest Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest Members
BaseWebAiiTest Class Constructors Methods Properties See Also Send Feedback

The BaseWebAiiTest type exposes the following members.

Constructors

 | Name | Description
Public method | BaseWebAiiTest | Create a new webaii test

Methods

 | Name | Description
Public method | CleanUp | Perform any test clean-up. You can override this method to perform your own clean up.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteStep | Obsolete. Execute a specific step. You need to give the recorded step an Id before you can use this method.
Public method | ExecuteTest | Execute a specific testcase within the current execution context
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExtractedValue | Return the extracted value of a variable. All extract steps persist their values in a local store that is accessible by this method.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAfterTestCompleted | Override this method to get notification right after the test is done execution
Public method | OnBeforeTestStarted | Override this method to get notification right before the test is about to get executed.
Public method | SetExtractedValue | Sets an extracted variable directly with a value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Actions | Gets the Action object of the current test.
Public property | ActiveApplication | Gets the ActiveWpfApplication.
Public property | ActiveBrowser | Gets the ActiveBrowser of current test.
Public property | CodedTestResult |
Public property | Data | Gets the test data this test is executing against.
Public property | ExecutionContext | Gets the execution context of this testcase which contains information about current test being executed, the step and data (if test is data driven).
Public property | Find | Gets the Find object of the current test.
Public property | Log | The current test log.
Public property | Manager | Gets the runtime Manager object.
Public property | Wait | Gets the wait object for sync operations.

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


BaseWebAiiTest Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest Constructor
BaseWebAiiTest Class See Also Send Feedback
Create a new webaii test

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BaseWebAiiTest()
Visual Basic
Public Sub New
Visual C++
public:
BaseWebAiiTest()

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


BaseWebAiiTest Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest Methods
BaseWebAiiTest Class See Also Send Feedback

The BaseWebAiiTest type exposes the following members.

Methods

 | Name | Description
Public method | CleanUp | Perform any test clean-up. You can override this method to perform your own clean up.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteStep | Obsolete. Execute a specific step. You need to give the recorded step an Id before you can use this method.
Public method | ExecuteTest | Execute a specific testcase within the current execution context
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetExtractedValue | Return the extracted value of a variable. All extract steps persist their values in a local store that is accessible by this method.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnAfterTestCompleted | Override this method to get notification right after the test is done execution
Public method | OnBeforeTestStarted | Override this method to get notification right before the test is about to get executed.
Public method | SetExtractedValue | Sets an extracted variable directly with a value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


CleanUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..CleanUp Method
BaseWebAiiTest Class See Also Send Feedback
Perform any test clean-up. You can override this method to perform your own clean up.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void CleanUp()
Visual Basic
Public Overridable Sub CleanUp
Visual C++
public:
virtual void CleanUp()

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


ExecuteStep Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..ExecuteStep Method
BaseWebAiiTest Class See Also Send Feedback
Execute a specific step. You need to give the recorded step an Id before you can use this method.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("This method is obsolete")]
public virtual void ExecuteStep(
    string id
)
Visual Basic
<ObsoleteAttribute("This method is obsolete")> _
Public Overridable Sub ExecuteStep ( _
    id As String _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete")]
public:
virtual void ExecuteStep(
    String^ id
)

Parameters

id
Type: System..::..String
The automation step id

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


ExecuteTest Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..ExecuteTest Method
BaseWebAiiTest Class See Also Send Feedback
Execute a specific testcase within the current execution context

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ExecuteTest(
    string relativeTestPath
)
Visual Basic
Public Sub ExecuteTest ( _
    relativeTestPath As String _
)
Visual C++
public:
void ExecuteTest(
    String^ relativeTestPath
)

Parameters

relativeTestPath
Type: System..::..String
The relative path to the test to execute.

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


GetExtractedValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..GetExtractedValue Method
BaseWebAiiTest Class See Also Send Feedback
Return the extracted value of a variable. All extract steps persist their values in a local store that is accessible by this method.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object GetExtractedValue(
    string dataBindVariableName
)
Visual Basic
Public Function GetExtractedValue ( _
    dataBindVariableName As String _
) As Object
Visual C++
public:
Object^ GetExtractedValue(
    String^ dataBindVariableName
)

Parameters

dataBindVariableName
Type: System..::..String
The DataBindVariableName set by the extract step that you wish to access the value for.

Return Value

The value of the extraction.

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


OnAfterTestCompleted Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..OnAfterTestCompleted Method
BaseWebAiiTest Class See Also Send Feedback
Override this method to get notification right after the test is done execution

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void OnAfterTestCompleted(
    TestResult result
)
Visual Basic
Public Overridable Sub OnAfterTestCompleted ( _
    result As TestResult _
)
Visual C++
public:
virtual void OnAfterTestCompleted(
    TestResult^ result
)

Parameters

result
Type: ArtOfTest.WebAii.Design.Execution..::..TestResult
The result of this test's execution

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


OnBeforeTestStarted Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..OnBeforeTestStarted Method
BaseWebAiiTest Class See Also Send Feedback
Override this method to get notification right before the test is about to get executed.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void OnBeforeTestStarted()
Visual Basic
Public Overridable Sub OnBeforeTestStarted
Visual C++
public:
virtual void OnBeforeTestStarted()

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


SetExtractedValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..SetExtractedValue Method
BaseWebAiiTest Class See Also Send Feedback
Sets an extracted variable directly with a value.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetExtractedValue(
    string dataBindVariableName,
    Object value
)
Visual Basic
Public Sub SetExtractedValue ( _
    dataBindVariableName As String, _
    value As Object _
)
Visual C++
public:
void SetExtractedValue(
    String^ dataBindVariableName,
    Object^ value
)

Parameters

dataBindVariableName
Type: System..::..String
The variable name to set.
value
Type: System..::..Object
The value to set it to.

Remarks

If the variable already exists, it will override its value, else will add the variable and set its value.

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


BaseWebAiiTest Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest Properties
BaseWebAiiTest Class See Also Send Feedback

The BaseWebAiiTest type exposes the following members.

Properties

 | Name | Description
Public property | Actions | Gets the Action object of the current test.
Public property | ActiveApplication | Gets the ActiveWpfApplication.
Public property | ActiveBrowser | Gets the ActiveBrowser of current test.
Public property | CodedTestResult |
Public property | Data | Gets the test data this test is executing against.
Public property | ExecutionContext | Gets the execution context of this testcase which contains information about current test being executed, the step and data (if test is data driven).
Public property | Find | Gets the Find object of the current test.
Public property | Log | The current test log.
Public property | Manager | Gets the runtime Manager object.
Public property | Wait | Gets the wait object for sync operations.

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


Actions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..Actions Property
BaseWebAiiTest Class See Also Send Feedback
Gets the Action object of the current test.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Actions Actions { get; }
Visual Basic
Public ReadOnly Property Actions As Actions
    Get
Visual C++
public:
property Actions^ Actions {
    Actions^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


ActiveApplication Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..ActiveApplication Property
BaseWebAiiTest Class See Also Send Feedback
Gets the ActiveWpfApplication.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfApplication ActiveApplication { get; }
Visual Basic
Public ReadOnly Property ActiveApplication As WpfApplication
    Get
Visual C++
public:
property WpfApplication^ ActiveApplication {
    WpfApplication^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


ActiveBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..ActiveBrowser Property
BaseWebAiiTest Class See Also Send Feedback
Gets the ActiveBrowser of current test.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser ActiveBrowser { get; }
Visual Basic
Public ReadOnly Property ActiveBrowser As Browser
    Get
Visual C++
public:
property Browser^ ActiveBrowser {
    Browser^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


CodedTestResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..CodedTestResult Property
BaseWebAiiTest Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.BaseWebAiiTest.CodedTestResult"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult CodedTestResult { get; }
Visual Basic
Public ReadOnly Property CodedTestResult As TestResult
    Get
Visual C++
public:
property TestResult^ CodedTestResult {
    TestResult^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


Data Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..Data Property
BaseWebAiiTest Class See Also Send Feedback
Gets the test data this test is executing against.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BaseWebAiiTest..::..TestData Data { get; }
Visual Basic
Public ReadOnly Property Data As BaseWebAiiTest..::..TestData
    Get
Visual C++
public:
property BaseWebAiiTest..::..TestData^ Data {
    BaseWebAiiTest..::..TestData^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


ExecutionContext Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..ExecutionContext Property
BaseWebAiiTest Class See Also Send Feedback
Gets the execution context of this testcase which contains information about current test being executed, the step and data (if test is data driven).

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecutionContext ExecutionContext { get; }
Visual Basic
Public ReadOnly Property ExecutionContext As ExecutionContext
    Get
Visual C++
public:
property ExecutionContext^ ExecutionContext {
    ExecutionContext^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


Find Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..Find Property
BaseWebAiiTest Class See Also Send Feedback
Gets the Find object of the current test.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Find Find { get; }
Visual Basic
Public ReadOnly Property Find As Find
    Get
Visual C++
public:
property Find^ Find {
    Find^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


Log Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..Log Property
BaseWebAiiTest Class See Also Send Feedback
The current test log.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Log Log { get; }
Visual Basic
Public ReadOnly Property Log As Log
    Get
Visual C++
public:
property Log^ Log {
    Log^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


Manager Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..Manager Property
BaseWebAiiTest Class See Also Send Feedback
Gets the runtime Manager object.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Manager Manager { get; }
Visual Basic
Public ReadOnly Property Manager As Manager
    Get
Visual C++
public:
property Manager^ Manager {
    Manager^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


Wait Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..Wait Property
BaseWebAiiTest Class See Also Send Feedback
Gets the wait object for sync operations.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WaitSync Wait { get; }
Visual Basic
Public ReadOnly Property Wait As WaitSync
    Get
Visual C++
public:
property WaitSync^ Wait {
    WaitSync^ get ();
}

See Also

BaseWebAiiTest Class
ArtOfTest.WebAii.Design Namespace


BaseWebAiiTest.TestData Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..TestData Members
BaseWebAiiTest..::..TestData Class Methods Properties See Also Send Feedback

Base execution class for a WebAii testcase code behind class.

The BaseWebAiiTest..::..TestData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item[([( Int32])]) | Get the current data value for a data driven test at current iteration for a specific column.
Public property | Item[([( String])]) | Get the current data value for a data driven test at current iteration for a specific column.
Public property | IterationIndex | Get the current iteration index you are in.

See Also

BaseWebAiiTest..::..TestData Class
ArtOfTest.WebAii.Design Namespace


BaseWebAiiTest.TestData Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..TestData Methods
BaseWebAiiTest..::..TestData Class See Also Send Feedback

The BaseWebAiiTest..::..TestData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseWebAiiTest..::..TestData Class
ArtOfTest.WebAii.Design Namespace


BaseWebAiiTest.TestData Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..TestData Properties
BaseWebAiiTest..::..TestData Class See Also Send Feedback

The BaseWebAiiTest..::..TestData type exposes the following members.

Properties

 | Name | Description
Public property | Item[([( Int32])]) | Get the current data value for a data driven test at current iteration for a specific column.
Public property | Item[([( String])]) | Get the current data value for a data driven test at current iteration for a specific column.
Public property | IterationIndex | Get the current iteration index you are in.

See Also

BaseWebAiiTest..::..TestData Class
ArtOfTest.WebAii.Design Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..TestData..::..Item Property
BaseWebAiiTest..::..TestData Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Get the current data value for a data driven test at current iteration for a specific column.
Public property | Item[([( String])]) | Get the current data value for a data driven test at current iteration for a specific column.

See Also

BaseWebAiiTest..::..TestData Class
BaseWebAiiTest..::..TestData Members
ArtOfTest.WebAii.Design Namespace


Item Property (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..TestData..::..Item Property (Int32)
BaseWebAiiTest..::..TestData Class See Also Send Feedback
Get the current data value for a data driven test at current iteration for a specific column.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object this[
    int column
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    column As Integer _
) As Object
    Get
Visual C++
public:
property Object^ default[int column] {
    Object^ get (int column);
}

Parameters

column
Type: System..::..Int32
The column index.

Return Value

The string value.

See Also

BaseWebAiiTest..::..TestData Class
Item Overload
ArtOfTest.WebAii.Design Namespace


Item Property (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..TestData..::..Item Property (String)
BaseWebAiiTest..::..TestData Class See Also Send Feedback
Get the current data value for a data driven test at current iteration for a specific column.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object this[
    string column
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    column As String _
) As Object
    Get
Visual C++
public:
property Object^ default[String^ column] {
    Object^ get (String^ column);
}

Parameters

column
Type: System..::..String
The column name.

Return Value

The string value.

See Also

BaseWebAiiTest..::..TestData Class
Item Overload
ArtOfTest.WebAii.Design Namespace


IterationIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWebAiiTest..::..TestData..::..IterationIndex Property
BaseWebAiiTest..::..TestData Class See Also Send Feedback
Get the current iteration index you are in.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int IterationIndex { get; }
Visual Basic
Public ReadOnly Property IterationIndex As Integer
    Get
Visual C++
public:
property int IterationIndex {
    int get ();
}

See Also

BaseWebAiiTest..::..TestData Class
ArtOfTest.WebAii.Design Namespace


CommandType Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandType Members
CommandType Structure Methods Properties See Also Send Feedback

The CommandType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | BrowserCommandType | Native recordable action from the recorder. (i.e. Click a button, Set text of a textbox)
Public property | CommandCategoryType | The overall category of action or request from the recorder (i.e. Verification, UICue, Browser Command or Desktop Command
Public property | DesktopCommandType | Generally, only actions that can only be invoked from the Automation Overlays Surfaces context menu.

See Also

CommandType Structure
ArtOfTest.WebAii.Design Namespace


CommandType Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandType Methods
CommandType Structure See Also Send Feedback

The CommandType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CommandType Structure
ArtOfTest.WebAii.Design Namespace


CommandType Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandType Properties
CommandType Structure See Also Send Feedback

The CommandType type exposes the following members.

Properties

 | Name | Description
Public property | BrowserCommandType | Native recordable action from the recorder. (i.e. Click a button, Set text of a textbox)
Public property | CommandCategoryType | The overall category of action or request from the recorder (i.e. Verification, UICue, Browser Command or Desktop Command
Public property | DesktopCommandType | Generally, only actions that can only be invoked from the Automation Overlays Surfaces context menu.

See Also

CommandType Structure
ArtOfTest.WebAii.Design Namespace


BrowserCommandType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandType..::..BrowserCommandType Property
CommandType Structure See Also Send Feedback
Native recordable action from the recorder. (i.e. Click a button, Set text of a textbox)

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserCommandType BrowserCommandType { get; set; }
Visual Basic
Public Property BrowserCommandType As BrowserCommandType
    Get
    Set
Visual C++
public:
property BrowserCommandType BrowserCommandType {
    BrowserCommandType get ();
    void set (BrowserCommandType value);
}

See Also

CommandType Structure
ArtOfTest.WebAii.Design Namespace


CommandCategoryType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandType..::..CommandCategoryType Property
CommandType Structure See Also Send Feedback
The overall category of action or request from the recorder (i.e. Verification, UICue, Browser Command or Desktop Command

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CommandCategoryType CommandCategoryType { get; set; }
Visual Basic
Public Property CommandCategoryType As CommandCategoryType
    Get
    Set
Visual C++
public:
property CommandCategoryType CommandCategoryType {
    CommandCategoryType get ();
    void set (CommandCategoryType value);
}

See Also

CommandType Structure
ArtOfTest.WebAii.Design Namespace


DesktopCommandType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandType..::..DesktopCommandType Property
CommandType Structure See Also Send Feedback
Generally, only actions that can only be invoked from the Automation Overlays Surfaces context menu.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DesktopCommandType DesktopCommandType { get; set; }
Visual Basic
Public Property DesktopCommandType As DesktopCommandType
    Get
    Set
Visual C++
public:
property DesktopCommandType DesktopCommandType {
    DesktopCommandType get ();
    void set (DesktopCommandType value);
}

See Also

CommandType Structure
ArtOfTest.WebAii.Design Namespace


DesignTimeExecutionParams Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams Members
DesignTimeExecutionParams Class Constructors Methods Properties See Also Send Feedback

The DesignTimeExecutionParams type exposes the following members.

Constructors

 | Name | Description
Public method | DesignTimeExecutionParams | Initializes a new instance of the DesignTimeExecutionParams class

Methods

 | Name | Description
 | CreateNew | Create new quick execution params for general execution
 | CreateNewRunFromHereParams | Create new quick execution params for a RunFromHere by specifying the step to use and settings, as well as the existing browser window to run in
 | CreateNewRunSelectedParams | Create new quick execution params for a RunSelected by specifying the first and lasts steps to use and settings, as well as the existing browser window to run in
 | CreateNewRunToHereParams(AutomationStepBase) | Create new quick execution params for a RunToHere by specifying the step to use.
 | CreateNewRunToHereParams(AutomationStepBase, Settings) | Create new quick execution params for a RunToHere by specifying the step to use and settings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BinaryFolder |
Public property | BugConfiguration |
Public property | DebuggerOptions |
Public property | DeploymentFolder |
Public property | ExistingBrowserHandle |
Public property | FirstStepGuid |
Public property | LastStepGuid |
Public property | ProfilerConfiguration |
Public property | Settings |
Public property | Test |
Public property | TrafficLogFile |
Public property | Type |

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


DesignTimeExecutionParams Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams Constructor
DesignTimeExecutionParams Class See Also Send Feedback
Initializes a new instance of the DesignTimeExecutionParams class

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DesignTimeExecutionParams()
Visual Basic
Public Sub New
Visual C++
public:
DesignTimeExecutionParams()

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


DesignTimeExecutionParams Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams Methods
DesignTimeExecutionParams Class See Also Send Feedback

The DesignTimeExecutionParams type exposes the following members.

Methods

 | Name | Description
 | CreateNew | Create new quick execution params for general execution
 | CreateNewRunFromHereParams | Create new quick execution params for a RunFromHere by specifying the step to use and settings, as well as the existing browser window to run in
 | CreateNewRunSelectedParams | Create new quick execution params for a RunSelected by specifying the first and lasts steps to use and settings, as well as the existing browser window to run in
 | CreateNewRunToHereParams(AutomationStepBase) | Create new quick execution params for a RunToHere by specifying the step to use.
 | CreateNewRunToHereParams(AutomationStepBase, Settings) | Create new quick execution params for a RunToHere by specifying the step to use and settings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


CreateNew Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..CreateNew Method
DesignTimeExecutionParams Class See Also Send Feedback
Create new quick execution params for general execution

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static DesignTimeExecutionParams CreateNew(
    Test test,
    Settings setting,
    DebuggerOptions debugOptions,
    ExecutionType type
)
Visual Basic
Public Shared Function CreateNew ( _
    test As Test, _
    setting As Settings, _
    debugOptions As DebuggerOptions, _
    type As ExecutionType _
) As DesignTimeExecutionParams
Visual C++
public:
static DesignTimeExecutionParams^ CreateNew(
    Test^ test,
    Settings^ setting,
    DebuggerOptions^ debugOptions,
    ExecutionType type
)

Parameters

test
Type: Test

[Missing <param name="test"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNew(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,ArtOfTest.Common.Design.ExecutionType)"]

setting
Type: ArtOfTest.WebAii.Core..::..Settings

[Missing <param name="setting"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNew(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,ArtOfTest.Common.Design.ExecutionType)"]

debugOptions
Type: ArtOfTest.WebAii.Design.Execution..::..DebuggerOptions

[Missing <param name="debugOptions"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNew(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,ArtOfTest.Common.Design.ExecutionType)"]

type
Type: ExecutionType

[Missing <param name="type"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNew(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,ArtOfTest.Common.Design.ExecutionType)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNew(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,ArtOfTest.Common.Design.ExecutionType)"]

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


CreateNewRunFromHereParams Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..CreateNewRunFromHereParams Method
DesignTimeExecutionParams Class See Also Send Feedback
Create new quick execution params for a RunFromHere by specifying the step to use and settings, as well as the existing browser window to run in

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static DesignTimeExecutionParams CreateNewRunFromHereParams(
    AutomationStepBase step,
    Settings settings,
    IntPtr existingBrowserHandle
)
Visual Basic
Public Shared Function CreateNewRunFromHereParams ( _
    step As AutomationStepBase, _
    settings As Settings, _
    existingBrowserHandle As IntPtr _
) As DesignTimeExecutionParams
Visual C++
public:
static DesignTimeExecutionParams^ CreateNewRunFromHereParams(
    AutomationStepBase^ step,
    Settings^ settings,
    IntPtr existingBrowserHandle
)

Parameters

step
Type: AutomationStepBase

[Missing <param name="step"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunFromHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

settings
Type: ArtOfTest.WebAii.Core..::..Settings

[Missing <param name="settings"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunFromHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

existingBrowserHandle
Type: System..::..IntPtr

[Missing <param name="existingBrowserHandle"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunFromHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunFromHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


CreateNewRunSelectedParams Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..CreateNewRunSelectedParams Method
DesignTimeExecutionParams Class See Also Send Feedback
Create new quick execution params for a RunSelected by specifying the first and lasts steps to use and settings, as well as the existing browser window to run in

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static DesignTimeExecutionParams CreateNewRunSelectedParams(
    AutomationStepBase firstStep,
    AutomationStepBase lastStep,
    Settings settings,
    IntPtr existingBrowserHandle
)
Visual Basic
Public Shared Function CreateNewRunSelectedParams ( _
    firstStep As AutomationStepBase, _
    lastStep As AutomationStepBase, _
    settings As Settings, _
    existingBrowserHandle As IntPtr _
) As DesignTimeExecutionParams
Visual C++
public:
static DesignTimeExecutionParams^ CreateNewRunSelectedParams(
    AutomationStepBase^ firstStep,
    AutomationStepBase^ lastStep,
    Settings^ settings,
    IntPtr existingBrowserHandle
)

Parameters

firstStep
Type: AutomationStepBase

[Missing <param name="firstStep"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunSelectedParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

lastStep
Type: AutomationStepBase

[Missing <param name="lastStep"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunSelectedParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

settings
Type: ArtOfTest.WebAii.Core..::..Settings

[Missing <param name="settings"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunSelectedParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

existingBrowserHandle
Type: System..::..IntPtr

[Missing <param name="existingBrowserHandle"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunSelectedParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunSelectedParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings,System.IntPtr)"]

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


CreateNewRunToHereParams Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..CreateNewRunToHereParams Method
DesignTimeExecutionParams Class See Also Send Feedback

Overload List

Name | Description
CreateNewRunToHereParams(AutomationStepBase) | Create new quick execution params for a RunToHere by specifying the step to use.
CreateNewRunToHereParams(AutomationStepBase, Settings) | Create new quick execution params for a RunToHere by specifying the step to use and settings

See Also

DesignTimeExecutionParams Class
DesignTimeExecutionParams Members
ArtOfTest.WebAii.Design Namespace


CreateNewRunToHereParams Method ()

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..CreateNewRunToHereParams Method ()
DesignTimeExecutionParams Class See Also Send Feedback
Create new quick execution params for a RunToHere by specifying the step to use.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static DesignTimeExecutionParams CreateNewRunToHereParams(
    AutomationStepBase step
)
Visual Basic
Public Shared Function CreateNewRunToHereParams ( _
    step As AutomationStepBase _
) As DesignTimeExecutionParams
Visual C++
public:
static DesignTimeExecutionParams^ CreateNewRunToHereParams(
    AutomationStepBase^ step
)

Parameters

step
Type: AutomationStepBase

[Missing <param name="step"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunToHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunToHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase)"]

See Also

DesignTimeExecutionParams Class
CreateNewRunToHereParams Overload
ArtOfTest.WebAii.Design Namespace


CreateNewRunToHereParams Method (, Settings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..CreateNewRunToHereParams Method (, Settings)
DesignTimeExecutionParams Class See Also Send Feedback
Create new quick execution params for a RunToHere by specifying the step to use and settings

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static DesignTimeExecutionParams CreateNewRunToHereParams(
    AutomationStepBase step,
    Settings settings
)
Visual Basic
Public Shared Function CreateNewRunToHereParams ( _
    step As AutomationStepBase, _
    settings As Settings _
) As DesignTimeExecutionParams
Visual C++
public:
static DesignTimeExecutionParams^ CreateNewRunToHereParams(
    AutomationStepBase^ step,
    Settings^ settings
)

Parameters

step
Type: AutomationStepBase

[Missing <param name="step"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunToHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings)"]

settings
Type: ArtOfTest.WebAii.Core..::..Settings

[Missing <param name="settings"/> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunToHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.CreateNewRunToHereParams(ArtOfTest.Common.Design.ProjectModel.AutomationStepBase,ArtOfTest.WebAii.Core.Settings)"]

See Also

DesignTimeExecutionParams Class
CreateNewRunToHereParams Overload
ArtOfTest.WebAii.Design Namespace


DesignTimeExecutionParams Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams Properties
DesignTimeExecutionParams Class See Also Send Feedback

The DesignTimeExecutionParams type exposes the following members.

Properties

 | Name | Description
Public property | BinaryFolder |
Public property | BugConfiguration |
Public property | DebuggerOptions |
Public property | DeploymentFolder |
Public property | ExistingBrowserHandle |
Public property | FirstStepGuid |
Public property | LastStepGuid |
Public property | ProfilerConfiguration |
Public property | Settings |
Public property | Test |
Public property | TrafficLogFile |
Public property | Type |

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


BinaryFolder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..BinaryFolder Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.BinaryFolder"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string BinaryFolder { get; set; }
Visual Basic
Public Property BinaryFolder As String
    Get
    Set
Visual C++
public:
property String^ BinaryFolder {
    String^ get ();
    void set (String^ value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


BugConfiguration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..BugConfiguration Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.BugConfiguration"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BugConfigurationSet BugConfiguration { get; set; }
Visual Basic
Public Property BugConfiguration As BugConfigurationSet
    Get
    Set
Visual C++
public:
property BugConfigurationSet^ BugConfiguration {
    BugConfigurationSet^ get ();
    void set (BugConfigurationSet^ value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


DebuggerOptions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..DebuggerOptions Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.DebuggerOptions"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DebuggerOptions DebuggerOptions { get; set; }
Visual Basic
Public Property DebuggerOptions As DebuggerOptions
    Get
    Set
Visual C++
public:
property DebuggerOptions^ DebuggerOptions {
    DebuggerOptions^ get ();
    void set (DebuggerOptions^ value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


DeploymentFolder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..DeploymentFolder Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.DeploymentFolder"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DeploymentFolder { get; set; }
Visual Basic
Public Property DeploymentFolder As String
    Get
    Set
Visual C++
public:
property String^ DeploymentFolder {
    String^ get ();
    void set (String^ value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


ExistingBrowserHandle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..ExistingBrowserHandle Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.ExistingBrowserHandle"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IntPtr ExistingBrowserHandle { get; set; }
Visual Basic
Public Property ExistingBrowserHandle As IntPtr
    Get
    Set
Visual C++
public:
property IntPtr ExistingBrowserHandle {
    IntPtr get ();
    void set (IntPtr value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


FirstStepGuid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..FirstStepGuid Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.FirstStepGuid"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid FirstStepGuid { get; set; }
Visual Basic
Public Property FirstStepGuid As Guid
    Get
    Set
Visual C++
public:
property Guid FirstStepGuid {
    Guid get ();
    void set (Guid value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


LastStepGuid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..LastStepGuid Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.LastStepGuid"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid LastStepGuid { get; set; }
Visual Basic
Public Property LastStepGuid As Guid
    Get
    Set
Visual C++
public:
property Guid LastStepGuid {
    Guid get ();
    void set (Guid value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


ProfilerConfiguration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..ProfilerConfiguration Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.ProfilerConfiguration"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ProfilerMetadataConfigurationSet ProfilerConfiguration { get; set; }
Visual Basic
Public Property ProfilerConfiguration As ProfilerMetadataConfigurationSet
    Get
    Set
Visual C++
public:
property ProfilerMetadataConfigurationSet^ ProfilerConfiguration {
    ProfilerMetadataConfigurationSet^ get ();
    void set (ProfilerMetadataConfigurationSet^ value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


Settings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..Settings Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.Settings"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings Settings { get; set; }
Visual Basic
Public Property Settings As Settings
    Get
    Set
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
    void set (Settings^ value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


Test Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..Test Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.Test"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Test Test { get; set; }
Visual Basic
Public Property Test As Test
    Get
    Set
Visual C++
public:
property Test^ Test {
    Test^ get ();
    void set (Test^ value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


TrafficLogFile Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..TrafficLogFile Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.TrafficLogFile"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TrafficLogFile { get; set; }
Visual Basic
Public Property TrafficLogFile As String
    Get
    Set
Visual C++
public:
property String^ TrafficLogFile {
    String^ get ();
    void set (String^ value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DesignTimeExecutionParams..::..Type Property
DesignTimeExecutionParams Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.DesignTimeExecutionParams.Type"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecutionType Type { get; set; }
Visual Basic
Public Property Type As ExecutionType
    Get
    Set
Visual C++
public:
property ExecutionType Type {
    ExecutionType get ();
    void set (ExecutionType value);
}

See Also

DesignTimeExecutionParams Class
ArtOfTest.WebAii.Design Namespace


ElementsGenerator Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator Members
ElementsGenerator Class Methods Fields See Also Send Feedback

The ElementsGenerator type exposes the following members.

Methods

Name | Description
CreateElementDescriptor(String, ITargetElement, INodeData, Type) | Create one single ElementDescriptor for an Element.
CreateElementDescriptor(String, String, ITargetElement, INodeData, Type) | Create one single ElementDescriptor for an Element.
CreateElementsForDescriptor |
FindUsingBackupXPath | FindUsingBackupXPath
GenerateFriendlyName | Generates friendly name for the element.
SetCurrentScheme | Set the scheme to be used for identification.

Fields

Name | Description
INDEPENDENT_KEY | Independent key
s_controlTypeLookup | The controls type lookup dictionary.

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


ElementsGenerator Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator Fields
ElementsGenerator Class See Also Send Feedback

The ElementsGenerator type exposes the following members.

Fields

Name | Description
INDEPENDENT_KEY | Independent key
s_controlTypeLookup | The controls type lookup dictionary.

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


INDEPENDENT_KEY Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..INDEPENDENT_KEY Field
ElementsGenerator Class See Also Send Feedback
Independent key

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string INDEPENDENT_KEY
Visual Basic
Public Const INDEPENDENT_KEY As String
Visual C++
public:
literal String^ INDEPENDENT_KEY

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


s_controlTypeLookup Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..s_controlTypeLookup Field
ElementsGenerator Class See Also Send Feedback
The controls type lookup dictionary.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Dictionary<string, Type> s_controlTypeLookup
Visual Basic
Public Shared s_controlTypeLookup As Dictionary(Of String, Type)
Visual C++
public:
static Dictionary<String^, Type^>^ s_controlTypeLookup

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


ElementsGenerator Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator Methods
ElementsGenerator Class See Also Send Feedback

The ElementsGenerator type exposes the following members.

Methods

Name | Description
CreateElementDescriptor(String, ITargetElement, INodeData, Type) | Create one single ElementDescriptor for an Element.
CreateElementDescriptor(String, String, ITargetElement, INodeData, Type) | Create one single ElementDescriptor for an Element.
CreateElementsForDescriptor |
FindUsingBackupXPath | FindUsingBackupXPath
GenerateFriendlyName | Generates friendly name for the element.
SetCurrentScheme | Set the scheme to be used for identification.

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


CreateElementDescriptor Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..CreateElementDescriptor Method
ElementsGenerator Class See Also Send Feedback

Overload List

Name | Description
CreateElementDescriptor(String, ITargetElement, INodeData, Type) | Create one single ElementDescriptor for an Element.
CreateElementDescriptor(String, String, ITargetElement, INodeData, Type) | Create one single ElementDescriptor for an Element.

See Also

ElementsGenerator Class
ElementsGenerator Members
ArtOfTest.WebAii.Design Namespace


CreateElementDescriptor Method (String, ITargetElement, , Type)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..CreateElementDescriptor Method (String, ITargetElement, , Type)
ElementsGenerator Class See Also Send Feedback
Create one single ElementDescriptor for an Element.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ElementDescriptor CreateElementDescriptor(
    string descriptorName,
    ITargetElement element,
    INodeData page,
    Type customType
)
Visual Basic
Public Shared Function CreateElementDescriptor ( _
    descriptorName As String, _
    element As ITargetElement, _
    page As INodeData, _
    customType As Type _
) As ElementDescriptor
Visual C++
public:
static ElementDescriptor^ CreateElementDescriptor(
    String^ descriptorName,
    ITargetElement^ element,
    INodeData^ page,
    Type^ customType
)

Parameters

descriptorName
Type: System..::..String

[Missing <param name="descriptorName"/> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.CreateElementDescriptor(System.String,ArtOfTest.Common.ITargetElement,ArtOfTest.Common.Design.ProjectModel.INodeData,System.Type)"]

element
Type: ArtOfTest.Common..::..ITargetElement
The actual element
page
Type: INodeData
The pageUri that element should live in.
customType
Type: System..::..Type
Custom control type to use for codegen, else pass in null.

Return Value

The generated ElementDescriptor

See Also

ElementsGenerator Class
CreateElementDescriptor Overload
ArtOfTest.WebAii.Design Namespace


CreateElementDescriptor Method (String, String, ITargetElement, , Type)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..CreateElementDescriptor Method (String, String, ITargetElement, , Type)
ElementsGenerator Class See Also Send Feedback
Create one single ElementDescriptor for an Element.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ElementDescriptor CreateElementDescriptor(
    string descriptorName,
    string elementFriendlyName,
    ITargetElement element,
    INodeData page,
    Type customType
)
Visual Basic
Public Shared Function CreateElementDescriptor ( _
    descriptorName As String, _
    elementFriendlyName As String, _
    element As ITargetElement, _
    page As INodeData, _
    customType As Type _
) As ElementDescriptor
Visual C++
public:
static ElementDescriptor^ CreateElementDescriptor(
    String^ descriptorName,
    String^ elementFriendlyName,
    ITargetElement^ element,
    INodeData^ page,
    Type^ customType
)

Parameters

descriptorName
Type: System..::..String
The descriptor name.
elementFriendlyName
Type: System..::..String
The name to give the element
element
Type: ArtOfTest.Common..::..ITargetElement
The actual element
page
Type: INodeData
The pageUri that element should live in.
customType
Type: System..::..Type
Custom control type to use for codegen, else pass in null.

Return Value

The generated ElementDescriptor

See Also

ElementsGenerator Class
CreateElementDescriptor Overload
ArtOfTest.WebAii.Design Namespace


CreateElementsForDescriptor Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..CreateElementsForDescriptor Method
ElementsGenerator Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.CreateElementsForDescriptor(ArtOfTest.Common.Design.ProjectModel.INodeData,ArtOfTest.Common.Design.Extensibility.Descriptors.AutomationDescriptor,System.Drawing.Rectangle[]@)"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Dictionary<string, ElementDescriptor> CreateElementsForDescriptor(
    INodeData page,
    AutomationDescriptor descriptor,
    out Rectangle[] locations
)
Visual Basic
Public Shared Function CreateElementsForDescriptor ( _
    page As INodeData, _
    descriptor As AutomationDescriptor, _
    <OutAttribute> ByRef locations As Rectangle() _
) As Dictionary(Of String, ElementDescriptor)
Visual C++
public:
static Dictionary<String^, ElementDescriptor^>^ CreateElementsForDescriptor(
    INodeData^ page,
    AutomationDescriptor^ descriptor,
    [OutAttribute] array<Rectangle>^% locations
)

Parameters

page
Type: INodeData

[Missing <param name="page"/> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.CreateElementsForDescriptor(ArtOfTest.Common.Design.ProjectModel.INodeData,ArtOfTest.Common.Design.Extensibility.Descriptors.AutomationDescriptor,System.Drawing.Rectangle[]@)"]

descriptor
Type: AutomationDescriptor

[Missing <param name="descriptor"/> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.CreateElementsForDescriptor(ArtOfTest.Common.Design.ProjectModel.INodeData,ArtOfTest.Common.Design.Extensibility.Descriptors.AutomationDescriptor,System.Drawing.Rectangle[]@)"]

locations
Type: array< System.Drawing..::..Rectangle >[]()[][]%

[Missing <param name="locations"/> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.CreateElementsForDescriptor(ArtOfTest.Common.Design.ProjectModel.INodeData,ArtOfTest.Common.Design.Extensibility.Descriptors.AutomationDescriptor,System.Drawing.Rectangle[]@)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.CreateElementsForDescriptor(ArtOfTest.Common.Design.ProjectModel.INodeData,ArtOfTest.Common.Design.Extensibility.Descriptors.AutomationDescriptor,System.Drawing.Rectangle[]@)"]

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


FindUsingBackupXPath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..FindUsingBackupXPath Method
ElementsGenerator Class See Also Send Feedback
FindUsingBackupXPath

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ITargetElement FindUsingBackupXPath(
    string path,
    ITargetElement root,
    out ITargetElement failureLocation
)
Visual Basic
Public Shared Function FindUsingBackupXPath ( _
    path As String, _
    root As ITargetElement, _
    <OutAttribute> ByRef failureLocation As ITargetElement _
) As ITargetElement
Visual C++
public:
static ITargetElement^ FindUsingBackupXPath(
    String^ path,
    ITargetElement^ root,
    [OutAttribute] ITargetElement^% failureLocation
)

Parameters

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.FindUsingBackupXPath(System.String,ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement@)"]

root
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="root"/> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.FindUsingBackupXPath(System.String,ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement@)"]

failureLocation
Type: ArtOfTest.Common..::..ITargetElement %

[Missing <param name="failureLocation"/> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.FindUsingBackupXPath(System.String,ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement@)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.FindUsingBackupXPath(System.String,ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement@)"]

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


GenerateFriendlyName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..GenerateFriendlyName Method
ElementsGenerator Class See Also Send Feedback
Generates friendly name for the element.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GenerateFriendlyName(
    ITargetElement element
)
Visual Basic
Public Shared Function GenerateFriendlyName ( _
    element As ITargetElement _
) As String
Visual C++
public:
static String^ GenerateFriendlyName(
    ITargetElement^ element
)

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement
The element.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.ElementsGenerator.GenerateFriendlyName(ArtOfTest.Common.ITargetElement)"]

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


SetCurrentScheme Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementsGenerator..::..SetCurrentScheme Method
ElementsGenerator Class See Also Send Feedback
Set the scheme to be used for identification.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SetCurrentScheme(
    IdentificationOptionsScheme scheme
)
Visual Basic
Public Shared Sub SetCurrentScheme ( _
    scheme As IdentificationOptionsScheme _
)
Visual C++
public:
static void SetCurrentScheme(
    IdentificationOptionsScheme^ scheme
)

Parameters

scheme
Type: IdentificationOptionsScheme
Scheme to use.

See Also

ElementsGenerator Class
ArtOfTest.WebAii.Design Namespace


HtmlCommandType Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType Members
HtmlCommandType Class Constructors Methods Properties See Also Send Feedback

The HtmlCommandType type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlCommandType(CommandCategoryType) | Initializes a new instance of the HtmlCommandType class
Public method | HtmlCommandType(DesktopCommandType) | Initializes a new instance of the HtmlCommandType class
Public method | HtmlCommandType(BrowserCommandType) | Initializes a new instance of the HtmlCommandType class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | New |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BrowserCommandType |
Public property | TechnologyType | (Overrides CommandTypeBaseTechnologyType()()()().)

See Also

HtmlCommandType Class
ArtOfTest.WebAii.Design Namespace


HtmlCommandType Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType Constructor
HtmlCommandType Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlCommandType(CommandCategoryType) | Initializes a new instance of the HtmlCommandType class
Public method | HtmlCommandType(DesktopCommandType) | Initializes a new instance of the HtmlCommandType class
Public method | HtmlCommandType(BrowserCommandType) | Initializes a new instance of the HtmlCommandType class

See Also

HtmlCommandType Class
HtmlCommandType Members
ArtOfTest.WebAii.Design Namespace


HtmlCommandType Constructor ()

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType Constructor ()
HtmlCommandType Class See Also Send Feedback
Initializes a new instance of the HtmlCommandType class

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlCommandType(
    CommandCategoryType category
)
Visual Basic
Public Sub New ( _
    category As CommandCategoryType _
)
Visual C++
public:
HtmlCommandType(
    CommandCategoryType category
)

Parameters

category
Type: CommandCategoryType

[Missing <param name="category"/> documentation for "M:ArtOfTest.WebAii.Design.HtmlCommandType.#ctor(ArtOfTest.Common.Design.CommandCategoryType)"]

See Also

HtmlCommandType Class
HtmlCommandType Overload
ArtOfTest.WebAii.Design Namespace


HtmlCommandType Constructor ()

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType Constructor ()
HtmlCommandType Class See Also Send Feedback
Initializes a new instance of the HtmlCommandType class

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlCommandType(
    DesktopCommandType desktopCommandType
)
Visual Basic
Public Sub New ( _
    desktopCommandType As DesktopCommandType _
)
Visual C++
public:
HtmlCommandType(
    DesktopCommandType desktopCommandType
)

Parameters

desktopCommandType
Type: DesktopCommandType

[Missing <param name="desktopCommandType"/> documentation for "M:ArtOfTest.WebAii.Design.HtmlCommandType.#ctor(ArtOfTest.Common.Design.DesktopCommandType)"]

See Also

HtmlCommandType Class
HtmlCommandType Overload
ArtOfTest.WebAii.Design Namespace


HtmlCommandType Constructor (BrowserCommandType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType Constructor (BrowserCommandType)
HtmlCommandType Class See Also Send Feedback
Initializes a new instance of the HtmlCommandType class

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlCommandType(
    BrowserCommandType browserCommandType
)
Visual Basic
Public Sub New ( _
    browserCommandType As BrowserCommandType _
)
Visual C++
public:
HtmlCommandType(
    BrowserCommandType browserCommandType
)

Parameters

browserCommandType
Type: ArtOfTest.WebAii.Design..::..BrowserCommandType

[Missing <param name="browserCommandType"/> documentation for "M:ArtOfTest.WebAii.Design.HtmlCommandType.#ctor(ArtOfTest.WebAii.Design.BrowserCommandType)"]

See Also

HtmlCommandType Class
HtmlCommandType Overload
ArtOfTest.WebAii.Design Namespace


HtmlCommandType Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType Methods
HtmlCommandType Class See Also Send Feedback

The HtmlCommandType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | New |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlCommandType Class
ArtOfTest.WebAii.Design Namespace


New Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType..::..New Method
HtmlCommandType Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.HtmlCommandType.New(ArtOfTest.WebAii.Design.CommandType)"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static HtmlCommandType New(
    CommandType commandType
)
Visual Basic
Public Shared Function New ( _
    commandType As CommandType _
) As HtmlCommandType
Visual C++
public:
static HtmlCommandType^ New(
    CommandType commandType
)

Parameters

commandType
Type: ArtOfTest.WebAii.Design..::..CommandType

[Missing <param name="commandType"/> documentation for "M:ArtOfTest.WebAii.Design.HtmlCommandType.New(ArtOfTest.WebAii.Design.CommandType)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.HtmlCommandType.New(ArtOfTest.WebAii.Design.CommandType)"]

See Also

HtmlCommandType Class
ArtOfTest.WebAii.Design Namespace


HtmlCommandType Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType Properties
HtmlCommandType Class See Also Send Feedback

The HtmlCommandType type exposes the following members.

Properties

 | Name | Description
Public property | BrowserCommandType |
Public property | TechnologyType | (Overrides CommandTypeBaseTechnologyType()()()().)

See Also

HtmlCommandType Class
ArtOfTest.WebAii.Design Namespace


BrowserCommandType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType..::..BrowserCommandType Property
HtmlCommandType Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.HtmlCommandType.BrowserCommandType"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserCommandType BrowserCommandType { get; set; }
Visual Basic
Public Property BrowserCommandType As BrowserCommandType
    Get
    Set
Visual C++
public:
property BrowserCommandType BrowserCommandType {
    BrowserCommandType get ();
    void set (BrowserCommandType value);
}

See Also

HtmlCommandType Class
ArtOfTest.WebAii.Design Namespace


TechnologyType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlCommandType..::..TechnologyType Property
HtmlCommandType Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.HtmlCommandType.TechnologyType"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override TechnologyType TechnologyType { get; }
Visual Basic
Public Overrides ReadOnly Property TechnologyType As TechnologyType
    Get
Visual C++
public:
virtual property TechnologyType TechnologyType {
    TechnologyType get () override;
}

See Also

HtmlCommandType Class
ArtOfTest.WebAii.Design Namespace


PerUserSettings Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings Members
PerUserSettings Class Constructors Methods Properties See Also Send Feedback

The PerUserSettings type exposes the following members.

Constructors

 | Name | Description
Public method | PerUserSettings | Initializes a new instance of the PerUserSettings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DebugMode |
Public property | HideFindExpWelcome |
Public property | HighlightBorderColor |
Public property | HighlightBorderSize |
Public property | MenuHoldTime |
Public property | Password |
Public property | QcPassword |
Public property | QcSkipAuthDialog |
Public property | QcUserName |
Public property | ShouldDeleteElement |
Public property | ShowLoadFeatureTour |
Public property | SilverlightConnectTimeout |
Public property | SkipDeleteElementPrompt |
Public property | SkipFindExpressionSetDataDrivenWarning |
Public property | SkipSavePrompt | Whether to skip the save prompt before running a test
Public property | SkipTPAuthDialog |
Public property | StopShowingHandlerViewTips |
Public property | StopShowingLoadConditionsViewTips |
Public property | StopShowingLoadResultsViewTips |
Public property | StopShowingLoadRunViewTips |
Public property | StopShowingLoadUserGroupsViewTips |
Public property | TfsDomain |
Public property | TfsPassword |
Public property | TfsSkipAuthDialog |
Public property | TfsUserName |
Public property | UrlHistory | Get or set the history of navigated urls
Public property | UserName |
Public property | UseWindowsAuthentication |

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


PerUserSettings Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings Constructor
PerUserSettings Class See Also Send Feedback
Initializes a new instance of the PerUserSettings class

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PerUserSettings()
Visual Basic
Public Sub New
Visual C++
public:
PerUserSettings()

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


PerUserSettings Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings Methods
PerUserSettings Class See Also Send Feedback

The PerUserSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


PerUserSettings Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings Properties
PerUserSettings Class See Also Send Feedback

The PerUserSettings type exposes the following members.

Properties

 | Name | Description
Public property | DebugMode |
Public property | HideFindExpWelcome |
Public property | HighlightBorderColor |
Public property | HighlightBorderSize |
Public property | MenuHoldTime |
Public property | Password |
Public property | QcPassword |
Public property | QcSkipAuthDialog |
Public property | QcUserName |
Public property | ShouldDeleteElement |
Public property | ShowLoadFeatureTour |
Public property | SilverlightConnectTimeout |
Public property | SkipDeleteElementPrompt |
Public property | SkipFindExpressionSetDataDrivenWarning |
Public property | SkipSavePrompt | Whether to skip the save prompt before running a test
Public property | SkipTPAuthDialog |
Public property | StopShowingHandlerViewTips |
Public property | StopShowingLoadConditionsViewTips |
Public property | StopShowingLoadResultsViewTips |
Public property | StopShowingLoadRunViewTips |
Public property | StopShowingLoadUserGroupsViewTips |
Public property | TfsDomain |
Public property | TfsPassword |
Public property | TfsSkipAuthDialog |
Public property | TfsUserName |
Public property | UrlHistory | Get or set the history of navigated urls
Public property | UserName |
Public property | UseWindowsAuthentication |

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


DebugMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..DebugMode Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.DebugMode"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool DebugMode { get; set; }
Visual Basic
Public Property DebugMode As Boolean
    Get
    Set
Visual C++
public:
property bool DebugMode {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


HideFindExpWelcome Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..HideFindExpWelcome Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.HideFindExpWelcome"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HideFindExpWelcome { get; set; }
Visual Basic
Public Property HideFindExpWelcome As Boolean
    Get
    Set
Visual C++
public:
property bool HideFindExpWelcome {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


HighlightBorderColor Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..HighlightBorderColor Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.HighlightBorderColor"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int HighlightBorderColor { get; set; }
Visual Basic
Public Property HighlightBorderColor As Integer
    Get
    Set
Visual C++
public:
property int HighlightBorderColor {
    int get ();
    void set (int value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


HighlightBorderSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..HighlightBorderSize Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.HighlightBorderSize"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int HighlightBorderSize { get; set; }
Visual Basic
Public Property HighlightBorderSize As Integer
    Get
    Set
Visual C++
public:
property int HighlightBorderSize {
    int get ();
    void set (int value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


MenuHoldTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..MenuHoldTime Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.MenuHoldTime"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MenuHoldTime { get; set; }
Visual Basic
Public Property MenuHoldTime As Double
    Get
    Set
Visual C++
public:
property double MenuHoldTime {
    double get ();
    void set (double value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


Password Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..Password Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.Password"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


QcPassword Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..QcPassword Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.QcPassword"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string QcPassword { get; set; }
Visual Basic
Public Property QcPassword As String
    Get
    Set
Visual C++
public:
property String^ QcPassword {
    String^ get ();
    void set (String^ value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


QcSkipAuthDialog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..QcSkipAuthDialog Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.QcSkipAuthDialog"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool QcSkipAuthDialog { get; set; }
Visual Basic
Public Property QcSkipAuthDialog As Boolean
    Get
    Set
Visual C++
public:
property bool QcSkipAuthDialog {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


QcUserName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..QcUserName Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.QcUserName"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string QcUserName { get; set; }
Visual Basic
Public Property QcUserName As String
    Get
    Set
Visual C++
public:
property String^ QcUserName {
    String^ get ();
    void set (String^ value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


ShouldDeleteElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..ShouldDeleteElement Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.ShouldDeleteElement"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShouldDeleteElement { get; set; }
Visual Basic
Public Property ShouldDeleteElement As Boolean
    Get
    Set
Visual C++
public:
property bool ShouldDeleteElement {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


ShowLoadFeatureTour Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..ShowLoadFeatureTour Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.ShowLoadFeatureTour"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowLoadFeatureTour { get; set; }
Visual Basic
Public Property ShowLoadFeatureTour As Boolean
    Get
    Set
Visual C++
public:
property bool ShowLoadFeatureTour {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


SilverlightConnectTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..SilverlightConnectTimeout Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.SilverlightConnectTimeout"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SilverlightConnectTimeout { get; set; }
Visual Basic
Public Property SilverlightConnectTimeout As Integer
    Get
    Set
Visual C++
public:
property int SilverlightConnectTimeout {
    int get ();
    void set (int value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


SkipDeleteElementPrompt Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..SkipDeleteElementPrompt Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.SkipDeleteElementPrompt"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SkipDeleteElementPrompt { get; set; }
Visual Basic
Public Property SkipDeleteElementPrompt As Boolean
    Get
    Set
Visual C++
public:
property bool SkipDeleteElementPrompt {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


SkipFindExpressionSetDataDrivenWarning Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..SkipFindExpressionSetDataDrivenWarning Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.SkipFindExpressionSetDataDrivenWarning"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SkipFindExpressionSetDataDrivenWarning { get; set; }
Visual Basic
Public Property SkipFindExpressionSetDataDrivenWarning As Boolean
    Get
    Set
Visual C++
public:
property bool SkipFindExpressionSetDataDrivenWarning {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


SkipSavePrompt Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..SkipSavePrompt Property
PerUserSettings Class See Also Send Feedback
Whether to skip the save prompt before running a test

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SkipSavePrompt { get; set; }
Visual Basic
Public Property SkipSavePrompt As Boolean
    Get
    Set
Visual C++
public:
property bool SkipSavePrompt {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


SkipTPAuthDialog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..SkipTPAuthDialog Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.SkipTPAuthDialog"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SkipTPAuthDialog { get; set; }
Visual Basic
Public Property SkipTPAuthDialog As Boolean
    Get
    Set
Visual C++
public:
property bool SkipTPAuthDialog {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingHandlerViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..StopShowingHandlerViewTips Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.StopShowingHandlerViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingHandlerViewTips { get; set; }
Visual Basic
Public Property StopShowingHandlerViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingHandlerViewTips {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingLoadConditionsViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..StopShowingLoadConditionsViewTips Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.StopShowingLoadConditionsViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingLoadConditionsViewTips { get; set; }
Visual Basic
Public Property StopShowingLoadConditionsViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingLoadConditionsViewTips {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingLoadResultsViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..StopShowingLoadResultsViewTips Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.StopShowingLoadResultsViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingLoadResultsViewTips { get; set; }
Visual Basic
Public Property StopShowingLoadResultsViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingLoadResultsViewTips {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingLoadRunViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..StopShowingLoadRunViewTips Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.StopShowingLoadRunViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingLoadRunViewTips { get; set; }
Visual Basic
Public Property StopShowingLoadRunViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingLoadRunViewTips {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingLoadUserGroupsViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..StopShowingLoadUserGroupsViewTips Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.StopShowingLoadUserGroupsViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingLoadUserGroupsViewTips { get; set; }
Visual Basic
Public Property StopShowingLoadUserGroupsViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingLoadUserGroupsViewTips {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


TfsDomain Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..TfsDomain Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.TfsDomain"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TfsDomain { get; set; }
Visual Basic
Public Property TfsDomain As String
    Get
    Set
Visual C++
public:
property String^ TfsDomain {
    String^ get ();
    void set (String^ value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


TfsPassword Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..TfsPassword Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.TfsPassword"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TfsPassword { get; set; }
Visual Basic
Public Property TfsPassword As String
    Get
    Set
Visual C++
public:
property String^ TfsPassword {
    String^ get ();
    void set (String^ value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


TfsSkipAuthDialog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..TfsSkipAuthDialog Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.TfsSkipAuthDialog"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool TfsSkipAuthDialog { get; set; }
Visual Basic
Public Property TfsSkipAuthDialog As Boolean
    Get
    Set
Visual C++
public:
property bool TfsSkipAuthDialog {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


TfsUserName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..TfsUserName Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.TfsUserName"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TfsUserName { get; set; }
Visual Basic
Public Property TfsUserName As String
    Get
    Set
Visual C++
public:
property String^ TfsUserName {
    String^ get ();
    void set (String^ value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


UrlHistory Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..UrlHistory Property
PerUserSettings Class See Also Send Feedback
Get or set the history of navigated urls

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<Uri> UrlHistory { get; set; }
Visual Basic
Public Property UrlHistory As List(Of Uri)
    Get
    Set
Visual C++
public:
property List<Uri^>^ UrlHistory {
    List<Uri^>^ get ();
    void set (List<Uri^>^ value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


UserName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..UserName Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.UserName"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UserName { get; set; }
Visual Basic
Public Property UserName As String
    Get
    Set
Visual C++
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


UseWindowsAuthentication Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PerUserSettings..::..UseWindowsAuthentication Property
PerUserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.PerUserSettings.UseWindowsAuthentication"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool UseWindowsAuthentication { get; set; }
Visual Basic
Public Property UseWindowsAuthentication As Boolean
    Get
    Set
Visual C++
public:
property bool UseWindowsAuthentication {
    bool get ();
    void set (bool value);
}

See Also

PerUserSettings Class
ArtOfTest.WebAii.Design Namespace


SelectionValues Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectionValues Members
SelectionValues Structure Constructors Methods Properties See Also Send Feedback

The SelectionValues type exposes the following members.

Constructors

 | Name | Description
Public method | SelectionValues | Initializes a new instance of the SelectionValues class

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | Index |
Public property | Text |
Public property | Value |

See Also

SelectionValues Structure
ArtOfTest.WebAii.Design Namespace


SelectionValues Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectionValues Constructor
SelectionValues Structure See Also Send Feedback
Initializes a new instance of the SelectionValues class

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SelectionValues(
    int index,
    string value,
    string text
)
Visual Basic
Public Sub New ( _
    index As Integer, _
    value As String, _
    text As String _
)
Visual C++
public:
SelectionValues(
    int index,
    String^ value,
    String^ text
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Design.SelectionValues.#ctor(System.Int32,System.String,System.String)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Design.SelectionValues.#ctor(System.Int32,System.String,System.String)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Design.SelectionValues.#ctor(System.Int32,System.String,System.String)"]

See Also

SelectionValues Structure
ArtOfTest.WebAii.Design Namespace


SelectionValues Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectionValues Methods
SelectionValues Structure See Also Send Feedback

The SelectionValues type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SelectionValues Structure
ArtOfTest.WebAii.Design Namespace


SelectionValues Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectionValues Properties
SelectionValues Structure See Also Send Feedback

The SelectionValues type exposes the following members.

Properties

 | Name | Description
Public property | Index |
Public property | Text |
Public property | Value |

See Also

SelectionValues Structure
ArtOfTest.WebAii.Design Namespace


Index Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectionValues..::..Index Property
SelectionValues Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.SelectionValues.Index"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

SelectionValues Structure
ArtOfTest.WebAii.Design Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectionValues..::..Text Property
SelectionValues Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.SelectionValues.Text"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

SelectionValues Structure
ArtOfTest.WebAii.Design Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectionValues..::..Value Property
SelectionValues Structure See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.SelectionValues.Value"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

SelectionValues Structure
ArtOfTest.WebAii.Design Namespace


TestChangedEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestChangedEventArgs Members
TestChangedEventArgs Class Constructors Methods Properties See Also Send Feedback

The TestChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TestChangedEventArgs | Initializes a new instance of the TestChangedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NewTest |
Public property | OldTest |

See Also

TestChangedEventArgs Class
ArtOfTest.WebAii.Design Namespace


TestChangedEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestChangedEventArgs Constructor
TestChangedEventArgs Class See Also Send Feedback
Initializes a new instance of the TestChangedEventArgs class

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestChangedEventArgs(
    TestBase oldTest,
    TestBase newTest
)
Visual Basic
Public Sub New ( _
    oldTest As TestBase, _
    newTest As TestBase _
)
Visual C++
public:
TestChangedEventArgs(
    TestBase^ oldTest,
    TestBase^ newTest
)

Parameters

oldTest
Type: TestBase

[Missing <param name="oldTest"/> documentation for "M:ArtOfTest.WebAii.Design.TestChangedEventArgs.#ctor(ArtOfTest.Common.Design.ProjectModel.TestBase,ArtOfTest.Common.Design.ProjectModel.TestBase)"]

newTest
Type: TestBase

[Missing <param name="newTest"/> documentation for "M:ArtOfTest.WebAii.Design.TestChangedEventArgs.#ctor(ArtOfTest.Common.Design.ProjectModel.TestBase,ArtOfTest.Common.Design.ProjectModel.TestBase)"]

See Also

TestChangedEventArgs Class
ArtOfTest.WebAii.Design Namespace


TestChangedEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestChangedEventArgs Methods
TestChangedEventArgs Class See Also Send Feedback

The TestChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestChangedEventArgs Class
ArtOfTest.WebAii.Design Namespace


TestChangedEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestChangedEventArgs Properties
TestChangedEventArgs Class See Also Send Feedback

The TestChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewTest |
Public property | OldTest |

See Also

TestChangedEventArgs Class
ArtOfTest.WebAii.Design Namespace


NewTest Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestChangedEventArgs..::..NewTest Property
TestChangedEventArgs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.TestChangedEventArgs.NewTest"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestBase NewTest { get; set; }
Visual Basic
Public Property NewTest As TestBase
    Get
    Set
Visual C++
public:
property TestBase^ NewTest {
    TestBase^ get ();
    void set (TestBase^ value);
}

See Also

TestChangedEventArgs Class
ArtOfTest.WebAii.Design Namespace


OldTest Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestChangedEventArgs..::..OldTest Property
TestChangedEventArgs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.TestChangedEventArgs.OldTest"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestBase OldTest { get; set; }
Visual Basic
Public Property OldTest As TestBase
    Get
    Set
Visual C++
public:
property TestBase^ OldTest {
    TestBase^ get ();
    void set (TestBase^ value);
}

See Also

TestChangedEventArgs Class
ArtOfTest.WebAii.Design Namespace


UserSettings Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings Members
UserSettings Class Constructors Methods Fields Properties Events See Also Send Feedback

The UserSettings type exposes the following members.

Constructors

 | Name | Description
Public method | UserSettings | Default Constructor

Methods

 | Name | Description
Public method | Clone | Clone the UserSettings object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeBugTrackersCollections |
Public method | InitNewPropertiesDefaultValuesV2 | Initialize new default values for V2 new properties. These properties will be null when deserializing an old project settings
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ArtOfTestFolderName |
SETTINGS_FILENAME |

Properties

 | Name | Description
Public property | AbsoluteDragDrop |
Public property | AssemblyName | Gets or sets the name of the assembly this project is compiled to (without the extension)
Public property | BaseClassName | Gets the base class name for the code behind.
Public property | BugAddAttachment |
Public property | BugAutoSubmit |
Public property | BugDescriptionMask |
Public property | BugTitleMask |
Public property | DebugMode | Flag to indicate if the application is writing to a debug file.
Public property | DefaultDropDownSelection | Gets or sets the default drop down selection
Public property | DefaultWPFApplication |
Public property | DisableUIAUsage | Gets whether to disable UIA usage when recording.
Public property | ExtensionData |
Public property | GeneratedElementIdentificationType | Sets how to generate the identification in test method
Public property | HideFindExpressionWelcome |
Public property | HighlightBorderColor | Highlighting border color
Public property | HighlightBorderSize | Highlighting border size
Public property | IdentificationOptionSchemes | Dicationary of all Identification Schemes
Public property | ImageScalePercentage | Percentage to scale down captured images
Public property | IsDirty | Flag to indicate when this object has been changed but hasn't been persisted to permanent storage yet.
Public property | IsStoryBoardCapturingEnabled | Whether storyboard capturing is enabled.
Public property | MenuHoldTime | The time (msec) to hold for the menu to show on the surface
Public property | Namespace | Gets or sets the namespace to use when generating code in this project
Public property | OutputFolder | Gets or sets the relative path from the project root to the output folder for code generation
Public property | ProjectGuid |
Public property | ProjectReferences |
Public property | ProjectVersion | Gets or sets the minimum version of Design Canvas required to open this project
Public property | PromptNameOnAddElement |
Public property | QcDomain |
Public property | QcPassword |
Public property | QcProject |
Public property | QcServerUrl |
Public property | QcSkipAuthDialog |
Public property | QcUserName |
Public property | QuickExecutionClientReadyTimeout |
Public property | QuickExecutionElementWaitTimeout |
Public property | RecorderBaseUrl | Recorder base url to use
Public property | RecordWpfWindowStateChanged |
Public property | SelectedIdentificationScheme | Currently Selected Identification Scheme
Public property | ShouldDeleteElement |
Public property | ShowLoadFeatureTour |
Public property | SilverlightConnectTimeout |
Public property | SimulateRealClickByDefault | Gets whether to simulate real click by default
Public property | SimulateRealSilverlightUserByDefault | Gets and sets whether to simulate real clicks and typing for Silverlight actions by default
Public property | SimulateRealTypingByDefault | Gets whether to simulate real typing by default
Public property | SkipDeleteElementPrompt |
Public property | SkipFindExpressionSetDataDrivenWarning |
Public property | StopShowingHandlerViewTips |
Public property | StopShowingLoadConditionsViewTips |
Public property | StopShowingLoadResultsViewTips |
Public property | StopShowingLoadRunViewTips |
Public property | StopShowingLoadUserGroupsViewTips |
Public property | TeamPulseServerUrl |
Public property | TfsDomain |
Public property | TfsPassword |
Public property | TfsSkipAuthDialog |
Public property | TfsUserName |
Public property | TpPassword |
Public property | TpSkipAuthDialog |
Public property | TpUserName |
Public property | TpUseWindowsAuth |
Public property | UnitTestTypeCodeGeneration | Type of unit test to generate for one way code gen
Public property | UrlHistory | History of navigated urls
Public property | UrlRecordMode | The Url record mode
Public property | UseLegacySilverlightFindLogic |

Events

 | Name | Description
Public event | PropertyChanged |
Public event | SettingsChanged |
Public event | TranslatorGroupEnabledChanged |

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UserSettings Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings Constructor
UserSettings Class See Also Send Feedback
Default Constructor

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UserSettings()
Visual Basic
Public Sub New
Visual C++
public:
UserSettings()

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UserSettings Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings Fields
UserSettings Class See Also Send Feedback

The UserSettings type exposes the following members.

Fields

Name | Description
ArtOfTestFolderName |
SETTINGS_FILENAME |

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ArtOfTestFolderName Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..ArtOfTestFolderName Field
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.UserSettings.ArtOfTestFolderName"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string ArtOfTestFolderName
Visual Basic
Public Shared ArtOfTestFolderName As String
Visual C++
public:
static String^ ArtOfTestFolderName

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SETTINGS_FILENAME Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SETTINGS_FILENAME Field
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.UserSettings.SETTINGS_FILENAME"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string SETTINGS_FILENAME
Visual Basic
Public Shared ReadOnly SETTINGS_FILENAME As String
Visual C++
public:
static initonly String^ SETTINGS_FILENAME

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UserSettings Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings Methods
UserSettings Class See Also Send Feedback

The UserSettings type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clone the UserSettings object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeBugTrackersCollections |
Public method | InitNewPropertiesDefaultValuesV2 | Initialize new default values for V2 new properties. These properties will be null when deserializing an old project settings
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


Clone Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..Clone Method
UserSettings Class See Also Send Feedback
Clone the UserSettings object

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.UserSettings.Clone"]

Implements

ICloneable..::..Clone()()()()

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


InitializeBugTrackersCollections Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..InitializeBugTrackersCollections Method
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.UserSettings.InitializeBugTrackersCollections"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void InitializeBugTrackersCollections()
Visual Basic
Public Sub InitializeBugTrackersCollections
Visual C++
public:
void InitializeBugTrackersCollections()

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


InitNewPropertiesDefaultValuesV2 Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..InitNewPropertiesDefaultValuesV2 Method
UserSettings Class See Also Send Feedback
Initialize new default values for V2 new properties. These properties will be null when deserializing an old project settings

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void InitNewPropertiesDefaultValuesV2(
    Version upgradingFrom
)
Visual Basic
Public Sub InitNewPropertiesDefaultValuesV2 ( _
    upgradingFrom As Version _
)
Visual C++
public:
void InitNewPropertiesDefaultValuesV2(
    Version^ upgradingFrom
)

Parameters

upgradingFrom
Type: System..::..Version

[Missing <param name="upgradingFrom"/> documentation for "M:ArtOfTest.WebAii.Design.UserSettings.InitNewPropertiesDefaultValuesV2(System.Version)"]

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


OnPropertyChanged Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..OnPropertyChanged Method
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.UserSettings.OnPropertyChanged(System.String)"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnPropertyChanged(
    string name
)
Visual Basic
Protected Sub OnPropertyChanged ( _
    name As String _
)
Visual C++
protected:
void OnPropertyChanged(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Design.UserSettings.OnPropertyChanged(System.String)"]

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UserSettings Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings Properties
UserSettings Class See Also Send Feedback

The UserSettings type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteDragDrop |
Public property | AssemblyName | Gets or sets the name of the assembly this project is compiled to (without the extension)
Public property | BaseClassName | Gets the base class name for the code behind.
Public property | BugAddAttachment |
Public property | BugAutoSubmit |
Public property | BugDescriptionMask |
Public property | BugTitleMask |
Public property | DebugMode | Flag to indicate if the application is writing to a debug file.
Public property | DefaultDropDownSelection | Gets or sets the default drop down selection
Public property | DefaultWPFApplication |
Public property | DisableUIAUsage | Gets whether to disable UIA usage when recording.
Public property | ExtensionData |
Public property | GeneratedElementIdentificationType | Sets how to generate the identification in test method
Public property | HideFindExpressionWelcome |
Public property | HighlightBorderColor | Highlighting border color
Public property | HighlightBorderSize | Highlighting border size
Public property | IdentificationOptionSchemes | Dicationary of all Identification Schemes
Public property | ImageScalePercentage | Percentage to scale down captured images
Public property | IsDirty | Flag to indicate when this object has been changed but hasn't been persisted to permanent storage yet.
Public property | IsStoryBoardCapturingEnabled | Whether storyboard capturing is enabled.
Public property | MenuHoldTime | The time (msec) to hold for the menu to show on the surface
Public property | Namespace | Gets or sets the namespace to use when generating code in this project
Public property | OutputFolder | Gets or sets the relative path from the project root to the output folder for code generation
Public property | ProjectGuid |
Public property | ProjectReferences |
Public property | ProjectVersion | Gets or sets the minimum version of Design Canvas required to open this project
Public property | PromptNameOnAddElement |
Public property | QcDomain |
Public property | QcPassword |
Public property | QcProject |
Public property | QcServerUrl |
Public property | QcSkipAuthDialog |
Public property | QcUserName |
Public property | QuickExecutionClientReadyTimeout |
Public property | QuickExecutionElementWaitTimeout |
Public property | RecorderBaseUrl | Recorder base url to use
Public property | RecordWpfWindowStateChanged |
Public property | SelectedIdentificationScheme | Currently Selected Identification Scheme
Public property | ShouldDeleteElement |
Public property | ShowLoadFeatureTour |
Public property | SilverlightConnectTimeout |
Public property | SimulateRealClickByDefault | Gets whether to simulate real click by default
Public property | SimulateRealSilverlightUserByDefault | Gets and sets whether to simulate real clicks and typing for Silverlight actions by default
Public property | SimulateRealTypingByDefault | Gets whether to simulate real typing by default
Public property | SkipDeleteElementPrompt |
Public property | SkipFindExpressionSetDataDrivenWarning |
Public property | StopShowingHandlerViewTips |
Public property | StopShowingLoadConditionsViewTips |
Public property | StopShowingLoadResultsViewTips |
Public property | StopShowingLoadRunViewTips |
Public property | StopShowingLoadUserGroupsViewTips |
Public property | TeamPulseServerUrl |
Public property | TfsDomain |
Public property | TfsPassword |
Public property | TfsSkipAuthDialog |
Public property | TfsUserName |
Public property | TpPassword |
Public property | TpSkipAuthDialog |
Public property | TpUserName |
Public property | TpUseWindowsAuth |
Public property | UnitTestTypeCodeGeneration | Type of unit test to generate for one way code gen
Public property | UrlHistory | History of navigated urls
Public property | UrlRecordMode | The Url record mode
Public property | UseLegacySilverlightFindLogic |

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


AbsoluteDragDrop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..AbsoluteDragDrop Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.AbsoluteDragDrop"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AbsoluteDragDrop { get; set; }
Visual Basic
Public Property AbsoluteDragDrop As Boolean
    Get
    Set
Visual C++
public:
property bool AbsoluteDragDrop {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


AssemblyName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..AssemblyName Property
UserSettings Class See Also Send Feedback
Gets or sets the name of the assembly this project is compiled to (without the extension)

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


BaseClassName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..BaseClassName Property
UserSettings Class See Also Send Feedback
Gets the base class name for the code behind.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string BaseClassName { get; set; }
Visual Basic
Public Property BaseClassName As String
    Get
    Set
Visual C++
public:
property String^ BaseClassName {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


BugAddAttachment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..BugAddAttachment Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.BugAddAttachment"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool BugAddAttachment { get; set; }
Visual Basic
Public Property BugAddAttachment As Boolean
    Get
    Set
Visual C++
public:
property bool BugAddAttachment {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


BugAutoSubmit Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..BugAutoSubmit Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.BugAutoSubmit"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool BugAutoSubmit { get; set; }
Visual Basic
Public Property BugAutoSubmit As Boolean
    Get
    Set
Visual C++
public:
property bool BugAutoSubmit {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


BugDescriptionMask Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..BugDescriptionMask Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.BugDescriptionMask"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string BugDescriptionMask { get; set; }
Visual Basic
Public Property BugDescriptionMask As String
    Get
    Set
Visual C++
public:
property String^ BugDescriptionMask {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


BugTitleMask Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..BugTitleMask Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.BugTitleMask"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string BugTitleMask { get; set; }
Visual Basic
Public Property BugTitleMask As String
    Get
    Set
Visual C++
public:
property String^ BugTitleMask {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


DebugMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..DebugMode Property
UserSettings Class See Also Send Feedback
Flag to indicate if the application is writing to a debug file.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool DebugMode { get; set; }
Visual Basic
Public Property DebugMode As Boolean
    Get
    Set
Visual C++
public:
property bool DebugMode {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


DefaultDropDownSelection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..DefaultDropDownSelection Property
UserSettings Class See Also Send Feedback
Gets or sets the default drop down selection

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SelectDropDownType DefaultDropDownSelection { get; set; }
Visual Basic
Public Property DefaultDropDownSelection As SelectDropDownType
    Get
    Set
Visual C++
public:
property SelectDropDownType DefaultDropDownSelection {
    SelectDropDownType get ();
    void set (SelectDropDownType value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


DefaultWPFApplication Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..DefaultWPFApplication Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.DefaultWPFApplication"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DefaultWPFApplication { get; set; }
Visual Basic
Public Property DefaultWPFApplication As String
    Get
    Set
Visual C++
public:
property String^ DefaultWPFApplication {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


DisableUIAUsage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..DisableUIAUsage Property
UserSettings Class See Also Send Feedback
Gets whether to disable UIA usage when recording.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool DisableUIAUsage { get; set; }
Visual Basic
Public Property DisableUIAUsage As Boolean
    Get
    Set
Visual C++
public:
property bool DisableUIAUsage {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ExtensionData Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..ExtensionData Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.ExtensionData"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExtensionDataObject ExtensionData { get; set; }
Visual Basic
Public Property ExtensionData As ExtensionDataObject
    Get
    Set
Visual C++
public:
virtual property ExtensionDataObject^ ExtensionData {
    ExtensionDataObject^ get () sealed;
    void set (ExtensionDataObject^ value) sealed;
}

Implements

IExtensibleDataObject..::..ExtensionData

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


GeneratedElementIdentificationType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..GeneratedElementIdentificationType Property
UserSettings Class See Also Send Feedback
Sets how to generate the identification in test method

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GeneratedElementIdentificationType GeneratedElementIdentificationType { get; set; }
Visual Basic
Public Property GeneratedElementIdentificationType As GeneratedElementIdentificationType
    Get
    Set
Visual C++
public:
property GeneratedElementIdentificationType GeneratedElementIdentificationType {
    GeneratedElementIdentificationType get ();
    void set (GeneratedElementIdentificationType value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


HideFindExpressionWelcome Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..HideFindExpressionWelcome Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.HideFindExpressionWelcome"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HideFindExpressionWelcome { get; set; }
Visual Basic
Public Property HideFindExpressionWelcome As Boolean
    Get
    Set
Visual C++
public:
property bool HideFindExpressionWelcome {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


HighlightBorderColor Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..HighlightBorderColor Property
UserSettings Class See Also Send Feedback
Highlighting border color

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int HighlightBorderColor { get; set; }
Visual Basic
Public Property HighlightBorderColor As Integer
    Get
    Set
Visual C++
public:
property int HighlightBorderColor {
    int get ();
    void set (int value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


HighlightBorderSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..HighlightBorderSize Property
UserSettings Class See Also Send Feedback
Highlighting border size

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int HighlightBorderSize { get; set; }
Visual Basic
Public Property HighlightBorderSize As Integer
    Get
    Set
Visual C++
public:
property int HighlightBorderSize {
    int get ();
    void set (int value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


IdentificationOptionSchemes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..IdentificationOptionSchemes Property
UserSettings Class See Also Send Feedback
Dicationary of all Identification Schemes

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<string, IdentificationOptionsScheme> IdentificationOptionSchemes { get; set; }
Visual Basic
Public Property IdentificationOptionSchemes As Dictionary(Of String, IdentificationOptionsScheme)
    Get
    Set
Visual C++
public:
property Dictionary<String^, IdentificationOptionsScheme^>^ IdentificationOptionSchemes {
    Dictionary<String^, IdentificationOptionsScheme^>^ get ();
    void set (Dictionary<String^, IdentificationOptionsScheme^>^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ImageScalePercentage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..ImageScalePercentage Property
UserSettings Class See Also Send Feedback
Percentage to scale down captured images

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ImageScalePercentage { get; set; }
Visual Basic
Public Property ImageScalePercentage As Integer
    Get
    Set
Visual C++
public:
property int ImageScalePercentage {
    int get ();
    void set (int value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


IsDirty Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..IsDirty Property
UserSettings Class See Also Send Feedback
Flag to indicate when this object has been changed but hasn't been persisted to permanent storage yet.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDirty { get; set; }
Visual Basic
Public Property IsDirty As Boolean
    Get
    Set
Visual C++
public:
property bool IsDirty {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


IsStoryBoardCapturingEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..IsStoryBoardCapturingEnabled Property
UserSettings Class See Also Send Feedback
Whether storyboard capturing is enabled.

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsStoryBoardCapturingEnabled { get; set; }
Visual Basic
Public Property IsStoryBoardCapturingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsStoryBoardCapturingEnabled {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


MenuHoldTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..MenuHoldTime Property
UserSettings Class See Also Send Feedback
The time (msec) to hold for the menu to show on the surface

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MenuHoldTime { get; set; }
Visual Basic
Public Property MenuHoldTime As Double
    Get
    Set
Visual C++
public:
property double MenuHoldTime {
    double get ();
    void set (double value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


Namespace Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..Namespace Property
UserSettings Class See Also Send Feedback
Gets or sets the namespace to use when generating code in this project

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Namespace { get; set; }
Visual Basic
Public Property Namespace As String
    Get
    Set
Visual C++
public:
property String^ Namespace {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


OutputFolder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..OutputFolder Property
UserSettings Class See Also Send Feedback
Gets or sets the relative path from the project root to the output folder for code generation

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string OutputFolder { get; set; }
Visual Basic
Public Property OutputFolder As String
    Get
    Set
Visual C++
public:
property String^ OutputFolder {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ProjectGuid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..ProjectGuid Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.ProjectGuid"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid ProjectGuid { get; internal set; }
Visual Basic
Public Property ProjectGuid As Guid
    Get
    Friend Set
Visual C++
public:
property Guid ProjectGuid {
    Guid get ();
    internal: void set (Guid value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ProjectReferences Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..ProjectReferences Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.ProjectReferences"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<string> ProjectReferences { get; private set; }
Visual Basic
Public Property ProjectReferences As IList(Of String)
    Get
    Private Set
Visual C++
public:
property IList<String^>^ ProjectReferences {
    IList<String^>^ get ();
    private: void set (IList<String^>^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ProjectVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..ProjectVersion Property
UserSettings Class See Also Send Feedback
Gets or sets the minimum version of Design Canvas required to open this project

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ProjectVersion { get; internal set; }
Visual Basic
Public Property ProjectVersion As String
    Get
    Friend Set
Visual C++
public:
property String^ ProjectVersion {
    String^ get ();
    internal: void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


PromptNameOnAddElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..PromptNameOnAddElement Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.PromptNameOnAddElement"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool PromptNameOnAddElement { get; set; }
Visual Basic
Public Property PromptNameOnAddElement As Boolean
    Get
    Set
Visual C++
public:
property bool PromptNameOnAddElement {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


QcDomain Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..QcDomain Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.QcDomain"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string QcDomain { get; set; }
Visual Basic
Public Property QcDomain As String
    Get
    Set
Visual C++
public:
property String^ QcDomain {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


QcPassword Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..QcPassword Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.QcPassword"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string QcPassword { get; set; }
Visual Basic
Public Property QcPassword As String
    Get
    Set
Visual C++
public:
property String^ QcPassword {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


QcProject Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..QcProject Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.QcProject"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string QcProject { get; set; }
Visual Basic
Public Property QcProject As String
    Get
    Set
Visual C++
public:
property String^ QcProject {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


QcServerUrl Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..QcServerUrl Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.QcServerUrl"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string QcServerUrl { get; set; }
Visual Basic
Public Property QcServerUrl As String
    Get
    Set
Visual C++
public:
property String^ QcServerUrl {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


QcSkipAuthDialog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..QcSkipAuthDialog Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.QcSkipAuthDialog"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool QcSkipAuthDialog { get; set; }
Visual Basic
Public Property QcSkipAuthDialog As Boolean
    Get
    Set
Visual C++
public:
property bool QcSkipAuthDialog {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


QcUserName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..QcUserName Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.QcUserName"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string QcUserName { get; set; }
Visual Basic
Public Property QcUserName As String
    Get
    Set
Visual C++
public:
property String^ QcUserName {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


QuickExecutionClientReadyTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..QuickExecutionClientReadyTimeout Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.QuickExecutionClientReadyTimeout"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int QuickExecutionClientReadyTimeout { get; set; }
Visual Basic
Public Property QuickExecutionClientReadyTimeout As Integer
    Get
    Set
Visual C++
public:
property int QuickExecutionClientReadyTimeout {
    int get ();
    void set (int value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


QuickExecutionElementWaitTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..QuickExecutionElementWaitTimeout Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.QuickExecutionElementWaitTimeout"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int QuickExecutionElementWaitTimeout { get; set; }
Visual Basic
Public Property QuickExecutionElementWaitTimeout As Integer
    Get
    Set
Visual C++
public:
property int QuickExecutionElementWaitTimeout {
    int get ();
    void set (int value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


RecorderBaseUrl Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..RecorderBaseUrl Property
UserSettings Class See Also Send Feedback
Recorder base url to use

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RecorderBaseUrl { get; set; }
Visual Basic
Public Property RecorderBaseUrl As String
    Get
    Set
Visual C++
public:
property String^ RecorderBaseUrl {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


RecordWpfWindowStateChanged Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..RecordWpfWindowStateChanged Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.RecordWpfWindowStateChanged"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RecordWpfWindowStateChanged { get; set; }
Visual Basic
Public Property RecordWpfWindowStateChanged As Boolean
    Get
    Set
Visual C++
public:
property bool RecordWpfWindowStateChanged {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SelectedIdentificationScheme Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SelectedIdentificationScheme Property
UserSettings Class See Also Send Feedback
Currently Selected Identification Scheme

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SelectedIdentificationScheme { get; set; }
Visual Basic
Public Property SelectedIdentificationScheme As String
    Get
    Set
Visual C++
public:
property String^ SelectedIdentificationScheme {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ShouldDeleteElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..ShouldDeleteElement Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.ShouldDeleteElement"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShouldDeleteElement { get; set; }
Visual Basic
Public Property ShouldDeleteElement As Boolean
    Get
    Set
Visual C++
public:
property bool ShouldDeleteElement {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ShowLoadFeatureTour Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..ShowLoadFeatureTour Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.ShowLoadFeatureTour"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowLoadFeatureTour { get; set; }
Visual Basic
Public Property ShowLoadFeatureTour As Boolean
    Get
    Set
Visual C++
public:
property bool ShowLoadFeatureTour {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SilverlightConnectTimeout Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SilverlightConnectTimeout Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.SilverlightConnectTimeout"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SilverlightConnectTimeout { get; set; }
Visual Basic
Public Property SilverlightConnectTimeout As Integer
    Get
    Set
Visual C++
public:
property int SilverlightConnectTimeout {
    int get ();
    void set (int value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SimulateRealClickByDefault Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SimulateRealClickByDefault Property
UserSettings Class See Also Send Feedback
Gets whether to simulate real click by default

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SimulateRealClickByDefault { get; set; }
Visual Basic
Public Property SimulateRealClickByDefault As Boolean
    Get
    Set
Visual C++
public:
property bool SimulateRealClickByDefault {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SimulateRealSilverlightUserByDefault Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SimulateRealSilverlightUserByDefault Property
UserSettings Class See Also Send Feedback
Gets and sets whether to simulate real clicks and typing for Silverlight actions by default

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SimulateRealSilverlightUserByDefault { get; set; }
Visual Basic
Public Property SimulateRealSilverlightUserByDefault As Boolean
    Get
    Set
Visual C++
public:
property bool SimulateRealSilverlightUserByDefault {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SimulateRealTypingByDefault Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SimulateRealTypingByDefault Property
UserSettings Class See Also Send Feedback
Gets whether to simulate real typing by default

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SimulateRealTypingByDefault { get; set; }
Visual Basic
Public Property SimulateRealTypingByDefault As Boolean
    Get
    Set
Visual C++
public:
property bool SimulateRealTypingByDefault {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SkipDeleteElementPrompt Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SkipDeleteElementPrompt Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.SkipDeleteElementPrompt"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SkipDeleteElementPrompt { get; set; }
Visual Basic
Public Property SkipDeleteElementPrompt As Boolean
    Get
    Set
Visual C++
public:
property bool SkipDeleteElementPrompt {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SkipFindExpressionSetDataDrivenWarning Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SkipFindExpressionSetDataDrivenWarning Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.SkipFindExpressionSetDataDrivenWarning"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SkipFindExpressionSetDataDrivenWarning { get; set; }
Visual Basic
Public Property SkipFindExpressionSetDataDrivenWarning As Boolean
    Get
    Set
Visual C++
public:
property bool SkipFindExpressionSetDataDrivenWarning {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingHandlerViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..StopShowingHandlerViewTips Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.StopShowingHandlerViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingHandlerViewTips { get; set; }
Visual Basic
Public Property StopShowingHandlerViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingHandlerViewTips {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingLoadConditionsViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..StopShowingLoadConditionsViewTips Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.StopShowingLoadConditionsViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingLoadConditionsViewTips { get; set; }
Visual Basic
Public Property StopShowingLoadConditionsViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingLoadConditionsViewTips {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingLoadResultsViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..StopShowingLoadResultsViewTips Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.StopShowingLoadResultsViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingLoadResultsViewTips { get; set; }
Visual Basic
Public Property StopShowingLoadResultsViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingLoadResultsViewTips {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingLoadRunViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..StopShowingLoadRunViewTips Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.StopShowingLoadRunViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingLoadRunViewTips { get; set; }
Visual Basic
Public Property StopShowingLoadRunViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingLoadRunViewTips {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


StopShowingLoadUserGroupsViewTips Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..StopShowingLoadUserGroupsViewTips Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.StopShowingLoadUserGroupsViewTips"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool StopShowingLoadUserGroupsViewTips { get; set; }
Visual Basic
Public Property StopShowingLoadUserGroupsViewTips As Boolean
    Get
    Set
Visual C++
public:
property bool StopShowingLoadUserGroupsViewTips {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TeamPulseServerUrl Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TeamPulseServerUrl Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TeamPulseServerUrl"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TeamPulseServerUrl { get; set; }
Visual Basic
Public Property TeamPulseServerUrl As String
    Get
    Set
Visual C++
public:
property String^ TeamPulseServerUrl {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TfsDomain Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TfsDomain Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TfsDomain"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TfsDomain { get; set; }
Visual Basic
Public Property TfsDomain As String
    Get
    Set
Visual C++
public:
property String^ TfsDomain {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TfsPassword Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TfsPassword Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TfsPassword"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TfsPassword { get; set; }
Visual Basic
Public Property TfsPassword As String
    Get
    Set
Visual C++
public:
property String^ TfsPassword {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TfsSkipAuthDialog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TfsSkipAuthDialog Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TfsSkipAuthDialog"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool TfsSkipAuthDialog { get; set; }
Visual Basic
Public Property TfsSkipAuthDialog As Boolean
    Get
    Set
Visual C++
public:
property bool TfsSkipAuthDialog {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TfsUserName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TfsUserName Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TfsUserName"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TfsUserName { get; set; }
Visual Basic
Public Property TfsUserName As String
    Get
    Set
Visual C++
public:
property String^ TfsUserName {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TpPassword Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TpPassword Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TpPassword"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TpPassword { get; set; }
Visual Basic
Public Property TpPassword As String
    Get
    Set
Visual C++
public:
property String^ TpPassword {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TpSkipAuthDialog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TpSkipAuthDialog Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TpSkipAuthDialog"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool TpSkipAuthDialog { get; set; }
Visual Basic
Public Property TpSkipAuthDialog As Boolean
    Get
    Set
Visual C++
public:
property bool TpSkipAuthDialog {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TpUserName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TpUserName Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TpUserName"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TpUserName { get; set; }
Visual Basic
Public Property TpUserName As String
    Get
    Set
Visual C++
public:
property String^ TpUserName {
    String^ get ();
    void set (String^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TpUseWindowsAuth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TpUseWindowsAuth Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.TpUseWindowsAuth"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool TpUseWindowsAuth { get; set; }
Visual Basic
Public Property TpUseWindowsAuth As Boolean
    Get
    Set
Visual C++
public:
property bool TpUseWindowsAuth {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UnitTestTypeCodeGeneration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..UnitTestTypeCodeGeneration Property
UserSettings Class See Also Send Feedback
Type of unit test to generate for one way code gen

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UnitTestType UnitTestTypeCodeGeneration { get; set; }
Visual Basic
Public Property UnitTestTypeCodeGeneration As UnitTestType
    Get
    Set
Visual C++
public:
property UnitTestType UnitTestTypeCodeGeneration {
    UnitTestType get ();
    void set (UnitTestType value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UrlHistory Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..UrlHistory Property
UserSettings Class See Also Send Feedback
History of navigated urls

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<Uri> UrlHistory { get; set; }
Visual Basic
Public Property UrlHistory As List(Of Uri)
    Get
    Set
Visual C++
public:
property List<Uri^>^ UrlHistory {
    List<Uri^>^ get ();
    void set (List<Uri^>^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UrlRecordMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..UrlRecordMode Property
UserSettings Class See Also Send Feedback
The Url record mode

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PageUriCompareMode UrlRecordMode { get; set; }
Visual Basic
Public Property UrlRecordMode As PageUriCompareMode
    Get
    Set
Visual C++
public:
property PageUriCompareMode UrlRecordMode {
    PageUriCompareMode get ();
    void set (PageUriCompareMode value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UseLegacySilverlightFindLogic Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..UseLegacySilverlightFindLogic Property
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.UserSettings.UseLegacySilverlightFindLogic"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool UseLegacySilverlightFindLogic { get; set; }
Visual Basic
Public Property UseLegacySilverlightFindLogic As Boolean
    Get
    Set
Visual C++
public:
property bool UseLegacySilverlightFindLogic {
    bool get ();
    void set (bool value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


UserSettings Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings Events
UserSettings Class See Also Send Feedback

The UserSettings type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged |
Public event | SettingsChanged |
Public event | TranslatorGroupEnabledChanged |

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


PropertyChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..PropertyChanged Event
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.UserSettings.PropertyChanged"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


SettingsChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..SettingsChanged Event
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.UserSettings.SettingsChanged"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler SettingsChanged
Visual Basic
Public Event SettingsChanged As EventHandler
Visual C++
public:
 event EventHandler^ SettingsChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


TranslatorGroupEnabledChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserSettings..::..TranslatorGroupEnabledChanged Event
UserSettings Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.UserSettings.TranslatorGroupEnabledChanged"]

Namespace: ArtOfTest.WebAii.Design
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<TranslatorGroupEnabledChangedEventArgs> TranslatorGroupEnabledChanged
Visual Basic
Public Event TranslatorGroupEnabledChanged As EventHandler(Of TranslatorGroupEnabledChangedEventArgs)
Visual C++
public:
 event EventHandler<TranslatorGroupEnabledChangedEventArgs^>^ TranslatorGroupEnabledChanged {
    void add (EventHandler<TranslatorGroupEnabledChangedEventArgs^>^ value);
    void remove (EventHandler<TranslatorGroupEnabledChangedEventArgs^>^ value);
}

See Also

UserSettings Class
ArtOfTest.WebAii.Design Namespace


ArtOfTest.WebAii.Design.Execution Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Design.Execution Namespace
Send Feedback
Class used for programmatically launching test execution.

Classes

 | Class | Description
Public class | CodedStepAttribute | Attribute placed on a coded automation step in the code behind of a test.
Public class | CombinationStepsResult |
Public class | CommandLineRunner | Processes the execution of test (.aii) and test list (.aiilist).
Public class | DataContext | The data context responsible for iteration the test. The ExecutionContext has a collection of DataContext for each test in the row (e.g. test as step, both tests data-bound.
Public class | DataIterationResult | Represents a data iteration result for data driven testing.
Public class | DebuggerOptions | Debugging Options when debugging.
Public class | ExecuteTestCommand | Command to execute a test
Public class | ExecutionContext | Provides the execution context of a specific test. (Test, step, settings, manager, data ..etc) You can use this class to get at information at any point in the execution flow of a testcase.
Public class | ExecutionReturnValues | Contains all values returns from execution
Public class | Filter | Represents the mechanism to filter objects.
Public class | FilteredCollection<(Of <(<'T>)>)> | A filtered collection other objects can implement
Public class | FindExpressionUpdateInfo | All FindExpression updates
Public class | InstalledBrowsers |
Public class | LogicalStepResult |
Public class | MainRunResult |
Public class | RemoteManualRunner |
Public class | RemoteRunner | Manage communication inside the ArtOfTest.Runner.exe with the RunnerController.
Public class | RemoteRunnerCommand | Base for all runner commands
Public class | ResultsReadyCommand | Command to report results
Public class | ResultSummary | Simple summary of an execution of a .aii test.
Public class | RunHelper | Wraps .aii test execution so it can be called from third party apps.
Public class | RunResult | Represents a collection of test results for a specific run.
Public class | RunResultsCollection | Represents the collection of run results exposing filtering methods.
Public class | RunTestArgs |
Public class | TestAsStepResult | Represents the result of a test as step run.
Public class | TestCollection | Represents the collection of actual tests object along with custom logic to retrieve tests (filtering).
Public class | TestInfo |
Public class | TestList |
Public class | TestResult | Class representing a test result.
Protected class | TestResult..::..XmlDataKeys |
Public class | TestUpdatePackage | Class contains all updates that occured to the test during execution.
Public class | UpdateInfo | All update info objects should inherit from this.
Public class | VerificationUpdateInfo | All Verification updates
Public class | VisualDebugger | Visual Debugger that handles UI display during execution and the Stop/Go/Auto-Pause aspect of execution. This object is exposed to users so they can call it from the code behind. Execution engine communicates directly with this object.

Interfaces

 | Interface | Description
Public interface | IExecutionExtension | Implements an extension to the execution engine.

Enumerations

 | Enumeration | Description
Public enumeration | AutoPauseOptions | Possible options to auto pause execution
Public enumeration | DebuggerModes | The different debugger modes
Public enumeration | FilterComparison | Serves as comparison types enum for filtering string type Test properties. Note: Shall we add a new item here a separate case needs to be implemented in the Match method.
Public enumeration | RemoteCommands | Possible commands
Public enumeration | RunExitCode | The command line runner exit code. - '0' for processed run and tests success - '1' for processed run but some failed tests - more than 1 for other errors.


CodedStepAttribute Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CodedStepAttribute Members
CodedStepAttribute Class Constructors Methods Properties See Also Send Feedback

The CodedStepAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | CodedStepAttribute | Create a new coded step attribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectToPopup | Gets / Sets whether this step connects to a popup
Public property | Description | Gets the description of the step.
Public property | RequiresSilverlight | Gets or sets whether this coded step requires Silverlight automation to be enabled.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CodedStepAttribute Class
ArtOfTest.WebAii.Design.Execution Namespace


CodedStepAttribute Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CodedStepAttribute Constructor
CodedStepAttribute Class See Also Send Feedback
Create a new coded step attribute.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CodedStepAttribute(
    string description
)
Visual Basic
Public Sub New ( _
    description As String _
)
Visual C++
public:
CodedStepAttribute(
    String^ description
)

Parameters

description
Type: System..::..String
The description of this step.

See Also

CodedStepAttribute Class
ArtOfTest.WebAii.Design.Execution Namespace


CodedStepAttribute Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CodedStepAttribute Methods
CodedStepAttribute Class See Also Send Feedback

The CodedStepAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CodedStepAttribute Class
ArtOfTest.WebAii.Design.Execution Namespace


CodedStepAttribute Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CodedStepAttribute Properties
CodedStepAttribute Class See Also Send Feedback

The CodedStepAttribute type exposes the following members.

Properties

 | Name | Description
Public property | ConnectToPopup | Gets / Sets whether this step connects to a popup
Public property | Description | Gets the description of the step.
Public property | RequiresSilverlight | Gets or sets whether this coded step requires Silverlight automation to be enabled.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

CodedStepAttribute Class
ArtOfTest.WebAii.Design.Execution Namespace


ConnectToPopup Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CodedStepAttribute..::..ConnectToPopup Property
CodedStepAttribute Class See Also Send Feedback
Gets / Sets whether this step connects to a popup

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ConnectToPopup { get; set; }
Visual Basic
Public Property ConnectToPopup As Boolean
    Get
    Set
Visual C++
public:
property bool ConnectToPopup {
    bool get ();
    void set (bool value);
}

See Also

CodedStepAttribute Class
ArtOfTest.WebAii.Design.Execution Namespace


Description Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CodedStepAttribute..::..Description Property
CodedStepAttribute Class See Also Send Feedback
Gets the description of the step.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

CodedStepAttribute Class
ArtOfTest.WebAii.Design.Execution Namespace


RequiresSilverlight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CodedStepAttribute..::..RequiresSilverlight Property
CodedStepAttribute Class See Also Send Feedback
Gets or sets whether this coded step requires Silverlight automation to be enabled.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RequiresSilverlight { get; set; }
Visual Basic
Public Property RequiresSilverlight As Boolean
    Get
    Set
Visual C++
public:
property bool RequiresSilverlight {
    bool get ();
    void set (bool value);
}

See Also

CodedStepAttribute Class
ArtOfTest.WebAii.Design.Execution Namespace


CombinationStepsResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinationStepsResult Members
CombinationStepsResult Class Constructors Methods Properties Events See Also Send Feedback

The CombinationStepsResult type exposes the following members.

Constructors

 | Name | Description
Public method | CombinationStepsResult | Initializes a new instance of the CombinationStepsResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBrowserState | Load the browser state (Inherited from AutomationStepResult.)
Public method | LoadFrom | (Inherited from AutomationStepResult.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from AutomationStepResult.)
Protected method | OnSerializing | (Inherited from AutomationStepResult.)
Public method | PersistStepFailureResourcesOnDisk | Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk. (Inherited from AutomationStepResult.)
Public method | SaveTo | (Inherited from AutomationStepResult.)
Public method | StoreHostState | Store the browser state as part of this step (Inherited from AutomationStepResult.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentVersion | (Inherited from AutomationStepResult.)
Public property | Exception | Gets or sets the execution exception. If result type is fail, then this will contain the exception information about the failure. (Inherited from AutomationStepResult.)
Public property | HasExpectedImage | (Inherited from AutomationStepResult.)
Public property | HashCode | (Inherited from AutomationStepResult.)
Public property | HasImage | (Inherited from AutomationStepResult.)
Public property | IsManual | (Inherited from AutomationStepResult.)
Public property | LogMessageOnError | (Inherited from AutomationStepResult.)
Public property | Order | (Inherited from AutomationStepResult.)
Public property | ParentTestResult | (Inherited from AutomationStepResult.)
Public property | ResultType | (Overrides AutomationStepResult..::..ResultType.)
Public property | RootName | (Inherited from AutomationStepResult.)
Public property | RunTimeStepId | (Inherited from AutomationStepResult.)
Public property | StepDescription | Gets or sets the description of this step. (Inherited from AutomationStepResult.)
Public property | TestId | Gets or sets the test unique Id this step result belongs to. (Inherited from AutomationStepResult.)
Public property | TestName | Gets or sets the test name of this step. (Inherited from AutomationStepResult.)
Public property | TestPath | Gets or sets the test path within the project. (Inherited from AutomationStepResult.)
Public property | TestResult |
Public property | TestStepIndex | Gets or sets the step index (Inherited from AutomationStepResult.)
Public property | UserComment | (Inherited from AutomationStepResult.)
Public property | WasStepEnabled | (Inherited from AutomationStepResult.)
Public property | XmlBlob | (Inherited from AutomationStepResult.)

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from AutomationStepResult.)

See Also

CombinationStepsResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CombinationStepsResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinationStepsResult Constructor
CombinationStepsResult Class See Also Send Feedback
Initializes a new instance of the CombinationStepsResult class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CombinationStepsResult(
    List<AutomationStepResult> steps
)
Visual Basic
Public Sub New ( _
    steps As List(Of AutomationStepResult) _
)
Visual C++
public:
CombinationStepsResult(
    List<AutomationStepResult^>^ steps
)

Parameters

steps
Type: System.Collections.Generic..::..List <(Of <(<' AutomationStepResult >)>)>

[Missing <param name="steps"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.CombinationStepsResult.#ctor(System.Collections.Generic.List{ArtOfTest.WebAii.Design.AutomationStepResult})"]

See Also

CombinationStepsResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CombinationStepsResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinationStepsResult Methods
CombinationStepsResult Class See Also Send Feedback

The CombinationStepsResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBrowserState | Load the browser state (Inherited from AutomationStepResult.)
Public method | LoadFrom | (Inherited from AutomationStepResult.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from AutomationStepResult.)
Protected method | OnSerializing | (Inherited from AutomationStepResult.)
Public method | PersistStepFailureResourcesOnDisk | Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk. (Inherited from AutomationStepResult.)
Public method | SaveTo | (Inherited from AutomationStepResult.)
Public method | StoreHostState | Store the browser state as part of this step (Inherited from AutomationStepResult.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinationStepsResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CombinationStepsResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinationStepsResult Properties
CombinationStepsResult Class See Also Send Feedback

The CombinationStepsResult type exposes the following members.

Properties

 | Name | Description
Public property | CurrentVersion | (Inherited from AutomationStepResult.)
Public property | Exception | Gets or sets the execution exception. If result type is fail, then this will contain the exception information about the failure. (Inherited from AutomationStepResult.)
Public property | HasExpectedImage | (Inherited from AutomationStepResult.)
Public property | HashCode | (Inherited from AutomationStepResult.)
Public property | HasImage | (Inherited from AutomationStepResult.)
Public property | IsManual | (Inherited from AutomationStepResult.)
Public property | LogMessageOnError | (Inherited from AutomationStepResult.)
Public property | Order | (Inherited from AutomationStepResult.)
Public property | ParentTestResult | (Inherited from AutomationStepResult.)
Public property | ResultType | (Overrides AutomationStepResult..::..ResultType.)
Public property | RootName | (Inherited from AutomationStepResult.)
Public property | RunTimeStepId | (Inherited from AutomationStepResult.)
Public property | StepDescription | Gets or sets the description of this step. (Inherited from AutomationStepResult.)
Public property | TestId | Gets or sets the test unique Id this step result belongs to. (Inherited from AutomationStepResult.)
Public property | TestName | Gets or sets the test name of this step. (Inherited from AutomationStepResult.)
Public property | TestPath | Gets or sets the test path within the project. (Inherited from AutomationStepResult.)
Public property | TestResult |
Public property | TestStepIndex | Gets or sets the step index (Inherited from AutomationStepResult.)
Public property | UserComment | (Inherited from AutomationStepResult.)
Public property | WasStepEnabled | (Inherited from AutomationStepResult.)
Public property | XmlBlob | (Inherited from AutomationStepResult.)

See Also

CombinationStepsResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinationStepsResult..::..ResultType Property
CombinationStepsResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.CombinationStepsResult.ResultType"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override ResultType ResultType { get; set; }
Visual Basic
Public Overrides Property ResultType As ResultType
    Get
    Set
Visual C++
public:
virtual property ResultType ResultType {
    ResultType get () override;
    void set (ResultType value) override;
}

See Also

CombinationStepsResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinationStepsResult..::..TestResult Property
CombinationStepsResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.CombinationStepsResult.TestResult"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult TestResult { get; }
Visual Basic
Public ReadOnly Property TestResult As TestResult
    Get
Visual C++
public:
property TestResult^ TestResult {
    TestResult^ get ();
}

See Also

CombinationStepsResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CombinationStepsResult Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CombinationStepsResult Events
CombinationStepsResult Class See Also Send Feedback

The CombinationStepsResult type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from AutomationStepResult.)

See Also

CombinationStepsResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CommandLineRunner Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner Members
CommandLineRunner Class Constructors Methods See Also Send Feedback

The CommandLineRunner type exposes the following members.

Constructors

 | Name | Description
Public method | CommandLineRunner | Initialize CommandLineRunner object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteTest(String) | Executes a single .aii or .tstest test.
Public method | ExecuteTest(String, Dictionary<(Of <<'(String, String>)>>)) | Executes a single test and publish its results.
Public method | ExecuteTestList(String) | Executes a list of .aii tests (.aiilist). Manages the run result.
Public method | ExecuteTestList(String, Dictionary<(Of <<'(String, String>)>>)) | Executes the test list and calls the publisher.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommandLineRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


CommandLineRunner Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner Constructor
CommandLineRunner Class See Also Send Feedback
Initialize CommandLineRunner object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CommandLineRunner(
    string outFolder,
    string resultName,
    string rootFolder
)
Visual Basic
Public Sub New ( _
    outFolder As String, _
    resultName As String, _
    rootFolder As String _
)
Visual C++
public:
CommandLineRunner(
    String^ outFolder,
    String^ resultName,
    String^ rootFolder
)

Parameters

outFolder
Type: System..::..String
The alternate output folder.
resultName
Type: System..::..String
The result name if user would like to specify.
rootFolder
Type: System..::..String
The project root folder.

See Also

CommandLineRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


CommandLineRunner Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner Methods
CommandLineRunner Class See Also Send Feedback

The CommandLineRunner type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteTest(String) | Executes a single .aii or .tstest test.
Public method | ExecuteTest(String, Dictionary<(Of <<'(String, String>)>>)) | Executes a single test and publish its results.
Public method | ExecuteTestList(String) | Executes a list of .aii tests (.aiilist). Manages the run result.
Public method | ExecuteTestList(String, Dictionary<(Of <<'(String, String>)>>)) | Executes the test list and calls the publisher.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommandLineRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner..::..ExecuteTest Method
CommandLineRunner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExecuteTest(String) | Executes a single .aii or .tstest test.
Public method | ExecuteTest(String, Dictionary<(Of <<'(String, String>)>>)) | Executes a single test and publish its results.

See Also

CommandLineRunner Class
CommandLineRunner Members
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTest Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner..::..ExecuteTest Method (String)
CommandLineRunner Class See Also Send Feedback
Executes a single .aii or .tstest test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecuteTest(
    string testFullPath
)
Visual Basic
Public Function ExecuteTest ( _
    testFullPath As String _
) As Integer
Visual C++
public:
int ExecuteTest(
    String^ testFullPath
)

Parameters

testFullPath
Type: System..::..String
The full path to the test.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.CommandLineRunner.ExecuteTest(System.String)"]

See Also

CommandLineRunner Class
ExecuteTest Overload
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTest Method (String, Dictionary(String, String))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner..::..ExecuteTest Method (String, Dictionary<(Of <(<'String, String>)>)>)
CommandLineRunner Class See Also Send Feedback
Executes a single test and publish its results.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecuteTest(
    string aiiFullPath,
    Dictionary<string, string> publishArgs
)
Visual Basic
Public Function ExecuteTest ( _
    aiiFullPath As String, _
    publishArgs As Dictionary(Of String, String) _
) As Integer
Visual C++
public:
int ExecuteTest(
    String^ aiiFullPath,
    Dictionary<String^, String^>^ publishArgs
)

Parameters

aiiFullPath
Type: System..::..String
The aii full path.
publishArgs
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The publish args.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.CommandLineRunner.ExecuteTest(System.String,System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

CommandLineRunner Class
ExecuteTest Overload
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTestList Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner..::..ExecuteTestList Method
CommandLineRunner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExecuteTestList(String) | Executes a list of .aii tests (.aiilist). Manages the run result.
Public method | ExecuteTestList(String, Dictionary<(Of <<'(String, String>)>>)) | Executes the test list and calls the publisher.

See Also

CommandLineRunner Class
CommandLineRunner Members
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTestList Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner..::..ExecuteTestList Method (String)
CommandLineRunner Class See Also Send Feedback
Executes a list of .aii tests (.aiilist). Manages the run result.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecuteTestList(
    string aiiListPath
)
Visual Basic
Public Function ExecuteTestList ( _
    aiiListPath As String _
) As Integer
Visual C++
public:
int ExecuteTestList(
    String^ aiiListPath
)

Parameters

aiiListPath
Type: System..::..String
The path to the test list.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.CommandLineRunner.ExecuteTestList(System.String)"]

See Also

CommandLineRunner Class
ExecuteTestList Overload
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTestList Method (String, Dictionary(String, String))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommandLineRunner..::..ExecuteTestList Method (String, Dictionary<(Of <(<'String, String>)>)>)
CommandLineRunner Class See Also Send Feedback
Executes the test list and calls the publisher.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecuteTestList(
    string aiiListPath,
    Dictionary<string, string> publishArgs
)
Visual Basic
Public Function ExecuteTestList ( _
    aiiListPath As String, _
    publishArgs As Dictionary(Of String, String) _
) As Integer
Visual C++
public:
int ExecuteTestList(
    String^ aiiListPath,
    Dictionary<String^, String^>^ publishArgs
)

Parameters

aiiListPath
Type: System..::..String
The aii list path.
publishArgs
Type: System.Collections.Generic..::..Dictionary <(Of <(<' String, String >)>)>
The publish args.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.CommandLineRunner.ExecuteTestList(System.String,System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

CommandLineRunner Class
ExecuteTestList Overload
ArtOfTest.WebAii.Design.Execution Namespace


DataContext Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataContext Members
DataContext Class Methods Properties See Also Send Feedback

The DataContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentDataRow | Sets the current data row to execute against.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentDataRow | Gets the current data row of current execution iteration for a data driven test.
Public property | CurrentIterationIndex | Gets the current iteration index
Public property | DataInfo | Gets the data info.
Public property | DataSource | Gets the datatable of a data driven test.

See Also

DataContext Class
ArtOfTest.WebAii.Design.Execution Namespace


DataContext Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataContext Methods
DataContext Class See Also Send Feedback

The DataContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCurrentDataRow | Sets the current data row to execute against.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataContext Class
ArtOfTest.WebAii.Design.Execution Namespace


SetCurrentDataRow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataContext..::..SetCurrentDataRow Method
DataContext Class See Also Send Feedback
Sets the current data row to execute against.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetCurrentDataRow(
    DataRow row
)
Visual Basic
Public Sub SetCurrentDataRow ( _
    row As DataRow _
)
Visual C++
public:
void SetCurrentDataRow(
    DataRow^ row
)

Parameters

row
Type: System.Data..::..DataRow
The data row.

See Also

DataContext Class
ArtOfTest.WebAii.Design.Execution Namespace


DataContext Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataContext Properties
DataContext Class See Also Send Feedback

The DataContext type exposes the following members.

Properties

 | Name | Description
Public property | CurrentDataRow | Gets the current data row of current execution iteration for a data driven test.
Public property | CurrentIterationIndex | Gets the current iteration index
Public property | DataInfo | Gets the data info.
Public property | DataSource | Gets the datatable of a data driven test.

See Also

DataContext Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentDataRow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataContext..::..CurrentDataRow Property
DataContext Class See Also Send Feedback
Gets the current data row of current execution iteration for a data driven test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataRow CurrentDataRow { get; }
Visual Basic
Public ReadOnly Property CurrentDataRow As DataRow
    Get
Visual C++
public:
property DataRow^ CurrentDataRow {
    DataRow^ get ();
}

See Also

DataContext Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentIterationIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataContext..::..CurrentIterationIndex Property
DataContext Class See Also Send Feedback
Gets the current iteration index

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CurrentIterationIndex { get; }
Visual Basic
Public ReadOnly Property CurrentIterationIndex As Integer
    Get
Visual C++
public:
property int CurrentIterationIndex {
    int get ();
}

See Also

DataContext Class
ArtOfTest.WebAii.Design.Execution Namespace


DataInfo Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataContext..::..DataInfo Property
DataContext Class See Also Send Feedback
Gets the data info.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataInfo DataInfo { get; }
Visual Basic
Public ReadOnly Property DataInfo As DataInfo
    Get
Visual C++
public:
property DataInfo^ DataInfo {
    DataInfo^ get ();
}

See Also

DataContext Class
ArtOfTest.WebAii.Design.Execution Namespace


DataSource Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataContext..::..DataSource Property
DataContext Class See Also Send Feedback
Gets the datatable of a data driven test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataTable DataSource { get; }
Visual Basic
Public ReadOnly Property DataSource As DataTable
    Get
Visual C++
public:
property DataTable^ DataSource {
    DataTable^ get ();
}

See Also

DataContext Class
ArtOfTest.WebAii.Design.Execution Namespace


DataIterationResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult Members
DataIterationResult Class Constructors Methods Properties See Also Send Feedback

The DataIterationResult type exposes the following members.

Constructors

 | Name | Description
Public method | DataIterationResult()()()() | Empty constructor needed for serialization.
Public method | DataIterationResult(TestResult, String) | Create an iteration result

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveTo |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | Iteration | Gets the iteration name.
Public property | Result | Gets the test result for this iteration.
Public property | RootName |
Public property | XmlBlob |

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


DataIterationResult Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult Constructor
DataIterationResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DataIterationResult()()()() | Empty constructor needed for serialization.
Public method | DataIterationResult(TestResult, String) | Create an iteration result

See Also

DataIterationResult Class
DataIterationResult Members
ArtOfTest.WebAii.Design.Execution Namespace


DataIterationResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult Constructor
DataIterationResult Class See Also Send Feedback
Empty constructor needed for serialization.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataIterationResult()
Visual Basic
Public Sub New
Visual C++
public:
DataIterationResult()

See Also

DataIterationResult Class
DataIterationResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


DataIterationResult Constructor (TestResult, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult Constructor (TestResult, String)
DataIterationResult Class See Also Send Feedback
Create an iteration result

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataIterationResult(
    TestResult result,
    string iteration
)
Visual Basic
Public Sub New ( _
    result As TestResult, _
    iteration As String _
)
Visual C++
public:
DataIterationResult(
    TestResult^ result,
    String^ iteration
)

Parameters

result
Type: ArtOfTest.WebAii.Design.Execution..::..TestResult

[Missing <param name="result"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.DataIterationResult.#ctor(ArtOfTest.WebAii.Design.Execution.TestResult,System.String)"]

iteration
Type: System..::..String

[Missing <param name="iteration"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.DataIterationResult.#ctor(ArtOfTest.WebAii.Design.Execution.TestResult,System.String)"]

See Also

DataIterationResult Class
DataIterationResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


DataIterationResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult Methods
DataIterationResult Class See Also Send Feedback

The DataIterationResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveTo |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult..::..LoadFrom Method
DataIterationResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.DataIterationResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.DataIterationResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult..::..SaveTo Method
DataIterationResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.DataIterationResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.DataIterationResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult..::..ToString Method
DataIterationResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.DataIterationResult.ToString"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.DataIterationResult.ToString"]

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


DataIterationResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult Properties
DataIterationResult Class See Also Send Feedback

The DataIterationResult type exposes the following members.

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | Iteration | Gets the iteration name.
Public property | Result | Gets the test result for this iteration.
Public property | RootName |
Public property | XmlBlob |

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult..::..CurrentVersion Property
DataIterationResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.DataIterationResult.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Iteration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult..::..Iteration Property
DataIterationResult Class See Also Send Feedback
Gets the iteration name.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Iteration { get; }
Visual Basic
Public ReadOnly Property Iteration As String
    Get
Visual C++
public:
property String^ Iteration {
    String^ get ();
}

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Result Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult..::..Result Property
DataIterationResult Class See Also Send Feedback
Gets the test result for this iteration.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult Result { get; }
Visual Basic
Public ReadOnly Property Result As TestResult
    Get
Visual C++
public:
property TestResult^ Result {
    TestResult^ get ();
}

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult..::..RootName Property
DataIterationResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.DataIterationResult.RootName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataIterationResult..::..XmlBlob Property
DataIterationResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.DataIterationResult.XmlBlob"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

DataIterationResult Class
ArtOfTest.WebAii.Design.Execution Namespace


DebuggerOptions Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions Members
DebuggerOptions Class Constructors Methods Properties See Also Send Feedback

The DebuggerOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DebuggerOptions()()()() | Initializes a new instance of the DebuggerOptions class
Public method | DebuggerOptions(DebuggerModes, AutoPauseOptions, Boolean) | Initializes a new instance of the DebuggerOptions class

Methods

 | Name | Description
Public method | Clone | Clone this object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoPauseOption | The auto-pause option to use.
Public property | IsEnabled | Whether the debugger is enabled or not.
Public property | Mode | The mode to use for the debugger.

See Also

DebuggerOptions Class
ArtOfTest.WebAii.Design.Execution Namespace


DebuggerOptions Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions Constructor
DebuggerOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DebuggerOptions()()()() | Initializes a new instance of the DebuggerOptions class
Public method | DebuggerOptions(DebuggerModes, AutoPauseOptions, Boolean) | Initializes a new instance of the DebuggerOptions class

See Also

DebuggerOptions Class
DebuggerOptions Members
ArtOfTest.WebAii.Design.Execution Namespace


DebuggerOptions Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions Constructor
DebuggerOptions Class See Also Send Feedback
Initializes a new instance of the DebuggerOptions class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DebuggerOptions()
Visual Basic
Public Sub New
Visual C++
public:
DebuggerOptions()

See Also

DebuggerOptions Class
DebuggerOptions Overload
ArtOfTest.WebAii.Design.Execution Namespace


DebuggerOptions Constructor (DebuggerModes, AutoPauseOptions, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions Constructor (DebuggerModes, AutoPauseOptions, Boolean)
DebuggerOptions Class See Also Send Feedback
Initializes a new instance of the DebuggerOptions class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DebuggerOptions(
    DebuggerModes mode,
    AutoPauseOptions autoPauseOption,
    bool isEnabled
)
Visual Basic
Public Sub New ( _
    mode As DebuggerModes, _
    autoPauseOption As AutoPauseOptions, _
    isEnabled As Boolean _
)
Visual C++
public:
DebuggerOptions(
    DebuggerModes mode,
    AutoPauseOptions autoPauseOption,
    bool isEnabled
)

Parameters

mode
Type: ArtOfTest.WebAii.Design.Execution..::..DebuggerModes

[Missing <param name="mode"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.DebuggerOptions.#ctor(ArtOfTest.WebAii.Design.Execution.DebuggerModes,ArtOfTest.WebAii.Design.Execution.AutoPauseOptions,System.Boolean)"]

autoPauseOption
Type: ArtOfTest.WebAii.Design.Execution..::..AutoPauseOptions

[Missing <param name="autoPauseOption"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.DebuggerOptions.#ctor(ArtOfTest.WebAii.Design.Execution.DebuggerModes,ArtOfTest.WebAii.Design.Execution.AutoPauseOptions,System.Boolean)"]

isEnabled
Type: System..::..Boolean

[Missing <param name="isEnabled"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.DebuggerOptions.#ctor(ArtOfTest.WebAii.Design.Execution.DebuggerModes,ArtOfTest.WebAii.Design.Execution.AutoPauseOptions,System.Boolean)"]

See Also

DebuggerOptions Class
DebuggerOptions Overload
ArtOfTest.WebAii.Design.Execution Namespace


DebuggerOptions Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions Methods
DebuggerOptions Class See Also Send Feedback

The DebuggerOptions type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clone this object
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DebuggerOptions Class
ArtOfTest.WebAii.Design.Execution Namespace


Clone Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions..::..Clone Method
DebuggerOptions Class See Also Send Feedback
Clone this object

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DebuggerOptions Clone()
Visual Basic
Public Function Clone As DebuggerOptions
Visual C++
public:
DebuggerOptions^ Clone()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.DebuggerOptions.Clone"]

See Also

DebuggerOptions Class
ArtOfTest.WebAii.Design.Execution Namespace


DebuggerOptions Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions Properties
DebuggerOptions Class See Also Send Feedback

The DebuggerOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoPauseOption | The auto-pause option to use.
Public property | IsEnabled | Whether the debugger is enabled or not.
Public property | Mode | The mode to use for the debugger.

See Also

DebuggerOptions Class
ArtOfTest.WebAii.Design.Execution Namespace


AutoPauseOption Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions..::..AutoPauseOption Property
DebuggerOptions Class See Also Send Feedback
The auto-pause option to use.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutoPauseOptions AutoPauseOption { get; set; }
Visual Basic
Public Property AutoPauseOption As AutoPauseOptions
    Get
    Set
Visual C++
public:
property AutoPauseOptions AutoPauseOption {
    AutoPauseOptions get ();
    void set (AutoPauseOptions value);
}

See Also

DebuggerOptions Class
ArtOfTest.WebAii.Design.Execution Namespace


IsEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions..::..IsEnabled Property
DebuggerOptions Class See Also Send Feedback
Whether the debugger is enabled or not.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic
Public Property IsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

See Also

DebuggerOptions Class
ArtOfTest.WebAii.Design.Execution Namespace


Mode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DebuggerOptions..::..Mode Property
DebuggerOptions Class See Also Send Feedback
The mode to use for the debugger.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DebuggerModes Mode { get; set; }
Visual Basic
Public Property Mode As DebuggerModes
    Get
    Set
Visual C++
public:
property DebuggerModes Mode {
    DebuggerModes get ();
    void set (DebuggerModes value);
}

See Also

DebuggerOptions Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTestCommand Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand Members
ExecuteTestCommand Class Constructors Methods Properties See Also Send Feedback

The ExecuteTestCommand type exposes the following members.

Constructors

 | Name | Description
Public method | ExecuteTestCommand | Initializes a new instance of the ExecuteTestCommand class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BinariesFolder |
Public property | Command | (Inherited from RemoteRunnerCommand.)
Public property | DebuggerOptions |
Public property | DeploymentFolder |
Public property | DesignTimeExecutionParams |
Public property | ExeType |
Public property | ExistingBrowserHandle |
Public property | FirstStepGuid |
Public property | LastStepGuid |
Public property | Settings |
Public property | Test |
Public property | TrafficLogFilename |

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTestCommand Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand Constructor
ExecuteTestCommand Class See Also Send Feedback
Initializes a new instance of the ExecuteTestCommand class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecuteTestCommand(
    Test test,
    Settings settings,
    DesignTimeExecutionParams designTimeExecutionParams,
    string binaryFolder,
    string deploymentFolder,
    ExecutionType type,
    Guid firstStepGuid,
    Guid lastStepGuid,
    IntPtr existingBrowserHandle,
    DebuggerOptions debuggerOptions,
    string trafficLogFilename
)
Visual Basic
Public Sub New ( _
    test As Test, _
    settings As Settings, _
    designTimeExecutionParams As DesignTimeExecutionParams, _
    binaryFolder As String, _
    deploymentFolder As String, _
    type As ExecutionType, _
    firstStepGuid As Guid, _
    lastStepGuid As Guid, _
    existingBrowserHandle As IntPtr, _
    debuggerOptions As DebuggerOptions, _
    trafficLogFilename As String _
)
Visual C++
public:
ExecuteTestCommand(
    Test^ test,
    Settings^ settings,
    DesignTimeExecutionParams^ designTimeExecutionParams,
    String^ binaryFolder,
    String^ deploymentFolder,
    ExecutionType type,
    Guid firstStepGuid,
    Guid lastStepGuid,
    IntPtr existingBrowserHandle,
    DebuggerOptions^ debuggerOptions,
    String^ trafficLogFilename
)

Parameters

test
Type: Test

[Missing <param name="test"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

settings
Type: ArtOfTest.WebAii.Core..::..Settings

[Missing <param name="settings"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

designTimeExecutionParams
Type: ArtOfTest.WebAii.Design..::..DesignTimeExecutionParams

[Missing <param name="designTimeExecutionParams"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

binaryFolder
Type: System..::..String

[Missing <param name="binaryFolder"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

deploymentFolder
Type: System..::..String

[Missing <param name="deploymentFolder"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

type
Type: ExecutionType

[Missing <param name="type"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

firstStepGuid
Type: System..::..Guid

[Missing <param name="firstStepGuid"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

lastStepGuid
Type: System..::..Guid

[Missing <param name="lastStepGuid"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

existingBrowserHandle
Type: System..::..IntPtr

[Missing <param name="existingBrowserHandle"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

debuggerOptions
Type: ArtOfTest.WebAii.Design.Execution..::..DebuggerOptions

[Missing <param name="debuggerOptions"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

trafficLogFilename
Type: System..::..String

[Missing <param name="trafficLogFilename"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.WebAii.Design.DesignTimeExecutionParams,System.String,System.String,ArtOfTest.Common.Design.ExecutionType,System.Guid,System.Guid,System.IntPtr,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,System.String)"]

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTestCommand Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand Methods
ExecuteTestCommand Class See Also Send Feedback

The ExecuteTestCommand type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecuteTestCommand Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand Properties
ExecuteTestCommand Class See Also Send Feedback

The ExecuteTestCommand type exposes the following members.

Properties

 | Name | Description
Public property | BinariesFolder |
Public property | Command | (Inherited from RemoteRunnerCommand.)
Public property | DebuggerOptions |
Public property | DeploymentFolder |
Public property | DesignTimeExecutionParams |
Public property | ExeType |
Public property | ExistingBrowserHandle |
Public property | FirstStepGuid |
Public property | LastStepGuid |
Public property | Settings |
Public property | Test |
Public property | TrafficLogFilename |

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


BinariesFolder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..BinariesFolder Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.BinariesFolder"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string BinariesFolder { get; }
Visual Basic
Public ReadOnly Property BinariesFolder As String
    Get
Visual C++
public:
property String^ BinariesFolder {
    String^ get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


DebuggerOptions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..DebuggerOptions Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.DebuggerOptions"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DebuggerOptions DebuggerOptions { get; }
Visual Basic
Public ReadOnly Property DebuggerOptions As DebuggerOptions
    Get
Visual C++
public:
property DebuggerOptions^ DebuggerOptions {
    DebuggerOptions^ get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


DeploymentFolder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..DeploymentFolder Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.DeploymentFolder"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DeploymentFolder { get; }
Visual Basic
Public ReadOnly Property DeploymentFolder As String
    Get
Visual C++
public:
property String^ DeploymentFolder {
    String^ get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


DesignTimeExecutionParams Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..DesignTimeExecutionParams Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.DesignTimeExecutionParams"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DesignTimeExecutionParams DesignTimeExecutionParams { get; }
Visual Basic
Public ReadOnly Property DesignTimeExecutionParams As DesignTimeExecutionParams
    Get
Visual C++
public:
property DesignTimeExecutionParams^ DesignTimeExecutionParams {
    DesignTimeExecutionParams^ get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ExeType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..ExeType Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.ExeType"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecutionType ExeType { get; }
Visual Basic
Public ReadOnly Property ExeType As ExecutionType
    Get
Visual C++
public:
property ExecutionType ExeType {
    ExecutionType get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ExistingBrowserHandle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..ExistingBrowserHandle Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.ExistingBrowserHandle"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IntPtr ExistingBrowserHandle { get; }
Visual Basic
Public ReadOnly Property ExistingBrowserHandle As IntPtr
    Get
Visual C++
public:
property IntPtr ExistingBrowserHandle {
    IntPtr get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


FirstStepGuid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..FirstStepGuid Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.FirstStepGuid"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid FirstStepGuid { get; }
Visual Basic
Public ReadOnly Property FirstStepGuid As Guid
    Get
Visual C++
public:
property Guid FirstStepGuid {
    Guid get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


LastStepGuid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..LastStepGuid Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.LastStepGuid"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid LastStepGuid { get; }
Visual Basic
Public ReadOnly Property LastStepGuid As Guid
    Get
Visual C++
public:
property Guid LastStepGuid {
    Guid get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


Settings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..Settings Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.Settings"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings Settings { get; }
Visual Basic
Public ReadOnly Property Settings As Settings
    Get
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


Test Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..Test Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.Test"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Test Test { get; }
Visual Basic
Public ReadOnly Property Test As Test
    Get
Visual C++
public:
property Test^ Test {
    Test^ get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


TrafficLogFilename Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteTestCommand..::..TrafficLogFilename Property
ExecuteTestCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecuteTestCommand.TrafficLogFilename"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TrafficLogFilename { get; }
Visual Basic
Public ReadOnly Property TrafficLogFilename As String
    Get
Visual C++
public:
property String^ TrafficLogFilename {
    String^ get ();
}

See Also

ExecuteTestCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionContext Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext Members
ExecutionContext Class Methods Properties See Also Send Feedback

The ExecutionContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetNewBrowserTracking | If popup tracking is on, turn it off.
Public method | SetCurrentDataRow | Sets the current data row to execute against.
Public method | SetCurrentStep | Sets the current step to execute against.
Public method | SetCurrentTestAndData | Sets the current test to execute.
Public method | SetDialogMonitoring()()()() | Setup the dialog monitoring using the execution context test instance.
Public method | SetDialogMonitoring(Test) | Setup dialog monitoring.
Public method | SetDialogMonitoring(AutomationStepList, TestType) | Setup the dialog monitoring using a list of automation steps this is to be used in conjunction with logical descriptors as it will check to see if dialogs have already been added, then reset them if so.
Public method | SetNewBrowserTracking | Setup popup window monitoring
 | TestHasData |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveDataRows | Gets the active data rows.
Public property | BugConfiguration | Gets the settings object.
 | Current | Get the current execution context.
Public property | CurrentDataRow | Gets the current data row of current execution iteration for the current (come on!) data driven test.
Public property | CurrentIterationIndex | Gets the current iteration index
Public property | CurrentStep | Gets the current automation step being executed.
Public property | DataContexts | Gets a dictionary of all data context instances by test. The keys are populated with the Test.UniqueId.
Public property | DataSource | Gets the datatable of the current data driven test.
Public property | DeploymentDirectory | Gets the deployment directory where data files and deployment items are being placed.
Public property | FirstStepGuid | During RunFromHereExecution or RunSelectedExecution, represents the first step to be executed
Public property | HttpRecorder | The HTTP recorder that is recording the test's traffic, or null if we're not recording HTTP traffic
Public property | LastStepGuid | During RunToHereExecution or RunSelectedExecution, represents the last step to be executed
Public property | Manager | Gets the manager object.
Public property | RunFromHereStepExecuted | Flag indicating whether or not the run from here step has already been executed.
Public property | Settings | Gets the settings object.
Public property | ShouldAbort |
Public property | Test | Gets the current test.
Public property | UpdatePackage | Get the update package associated with this execution context.
Public property | VisualDebugger | The Visual UI that allows you to control and display visual annotation in the execution UI.

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionContext Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext Methods
ExecutionContext Class See Also Send Feedback

The ExecutionContext type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ResetNewBrowserTracking | If popup tracking is on, turn it off.
Public method | SetCurrentDataRow | Sets the current data row to execute against.
Public method | SetCurrentStep | Sets the current step to execute against.
Public method | SetCurrentTestAndData | Sets the current test to execute.
Public method | SetDialogMonitoring()()()() | Setup the dialog monitoring using the execution context test instance.
Public method | SetDialogMonitoring(Test) | Setup dialog monitoring.
Public method | SetDialogMonitoring(AutomationStepList, TestType) | Setup the dialog monitoring using a list of automation steps this is to be used in conjunction with logical descriptors as it will check to see if dialogs have already been added, then reset them if so.
Public method | SetNewBrowserTracking | Setup popup window monitoring
 | TestHasData |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


ResetNewBrowserTracking Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..ResetNewBrowserTracking Method
ExecutionContext Class See Also Send Feedback
If popup tracking is on, turn it off.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ResetNewBrowserTracking()
Visual Basic
Public Sub ResetNewBrowserTracking
Visual C++
public:
void ResetNewBrowserTracking()

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


SetCurrentDataRow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..SetCurrentDataRow Method
ExecutionContext Class See Also Send Feedback
Sets the current data row to execute against.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetCurrentDataRow(
    DataRow row,
    int index
)
Visual Basic
Public Sub SetCurrentDataRow ( _
    row As DataRow, _
    index As Integer _
)
Visual C++
public:
void SetCurrentDataRow(
    DataRow^ row,
    int index
)

Parameters

row
Type: System.Data..::..DataRow
The data row.
index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetCurrentDataRow(System.Data.DataRow,System.Int32)"]

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


SetCurrentStep Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..SetCurrentStep Method
ExecutionContext Class See Also Send Feedback
Sets the current step to execute against.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetCurrentStep(
    AutomationStepBase step
)
Visual Basic
Public Sub SetCurrentStep ( _
    step As AutomationStepBase _
)
Visual C++
public:
void SetCurrentStep(
    AutomationStepBase^ step
)

Parameters

step
Type: AutomationStepBase
The step

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


SetCurrentTestAndData Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..SetCurrentTestAndData Method
ExecutionContext Class See Also Send Feedback
Sets the current test to execute.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SetCurrentTestAndData(
    Test test,
    bool canInitializeDataSource
)
Visual Basic
Public Function SetCurrentTestAndData ( _
    test As Test, _
    canInitializeDataSource As Boolean _
) As Boolean
Visual C++
public:
bool SetCurrentTestAndData(
    Test^ test,
    bool canInitializeDataSource
)

Parameters

test
Type: Test
The test to execute.
canInitializeDataSource
Type: System..::..Boolean

[Missing <param name="canInitializeDataSource"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetCurrentTestAndData(ArtOfTest.WebAii.Design.ProjectModel.Test,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetCurrentTestAndData(ArtOfTest.WebAii.Design.ProjectModel.Test,System.Boolean)"]

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


SetDialogMonitoring Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..SetDialogMonitoring Method
ExecutionContext Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetDialogMonitoring()()()() | Setup the dialog monitoring using the execution context test instance.
Public method | SetDialogMonitoring(Test) | Setup dialog monitoring.
Public method | SetDialogMonitoring(AutomationStepList, TestType) | Setup the dialog monitoring using a list of automation steps this is to be used in conjunction with logical descriptors as it will check to see if dialogs have already been added, then reset them if so.

See Also

ExecutionContext Class
ExecutionContext Members
ArtOfTest.WebAii.Design.Execution Namespace


SetDialogMonitoring Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..SetDialogMonitoring Method
ExecutionContext Class See Also Send Feedback
Setup the dialog monitoring using the execution context test instance.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetDialogMonitoring()
Visual Basic
Public Sub SetDialogMonitoring
Visual C++
public:
void SetDialogMonitoring()

See Also

ExecutionContext Class
SetDialogMonitoring Overload
ArtOfTest.WebAii.Design.Execution Namespace


SetDialogMonitoring Method ()

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..SetDialogMonitoring Method ()
ExecutionContext Class See Also Send Feedback
Setup dialog monitoring.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetDialogMonitoring(
    Test test
)
Visual Basic
Public Sub SetDialogMonitoring ( _
    test As Test _
)
Visual C++
public:
void SetDialogMonitoring(
    Test^ test
)

Parameters

test
Type: Test
The test to use

See Also

ExecutionContext Class
SetDialogMonitoring Overload
ArtOfTest.WebAii.Design.Execution Namespace


SetDialogMonitoring Method (, )

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..SetDialogMonitoring Method (, )
ExecutionContext Class See Also Send Feedback
Setup the dialog monitoring using a list of automation steps this is to be used in conjunction with logical descriptors as it will check to see if dialogs have already been added, then reset them if so.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetDialogMonitoring(
    AutomationStepList steps,
    TestType testType
)
Visual Basic
Public Sub SetDialogMonitoring ( _
    steps As AutomationStepList, _
    testType As TestType _
)
Visual C++
public:
void SetDialogMonitoring(
    AutomationStepList^ steps,
    TestType testType
)

Parameters

steps
Type: AutomationStepList

[Missing <param name="steps"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetDialogMonitoring(ArtOfTest.Common.Design.ProjectModel.AutomationStepList,ArtOfTest.Common.Design.Extensibility.TestType)"]

testType
Type: TestType

[Missing <param name="testType"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetDialogMonitoring(ArtOfTest.Common.Design.ProjectModel.AutomationStepList,ArtOfTest.Common.Design.Extensibility.TestType)"]

See Also

ExecutionContext Class
SetDialogMonitoring Overload
ArtOfTest.WebAii.Design.Execution Namespace


SetNewBrowserTracking Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..SetNewBrowserTracking Method
ExecutionContext Class See Also Send Feedback
Setup popup window monitoring

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SetNewBrowserTracking(
    Test test,
    Object codeBehind
)
Visual Basic
Public Function SetNewBrowserTracking ( _
    test As Test, _
    codeBehind As Object _
) As Boolean
Visual C++
public:
bool SetNewBrowserTracking(
    Test^ test,
    Object^ codeBehind
)

Parameters

test
Type: Test
The test to use
codeBehind
Type: System..::..Object

[Missing <param name="codeBehind"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetNewBrowserTracking(ArtOfTest.WebAii.Design.ProjectModel.Test,System.Object)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetNewBrowserTracking(ArtOfTest.WebAii.Design.ProjectModel.Test,System.Object)"]

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


TestHasData Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..TestHasData Method
ExecutionContext Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.TestHasData(ArtOfTest.WebAii.Design.ProjectModel.Test)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool TestHasData(
    Test test
)
Visual Basic
Public Shared Function TestHasData ( _
    test As Test _
) As Boolean
Visual C++
public:
static bool TestHasData(
    Test^ test
)

Parameters

test
Type: Test

[Missing <param name="test"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.TestHasData(ArtOfTest.WebAii.Design.ProjectModel.Test)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionContext.TestHasData(ArtOfTest.WebAii.Design.ProjectModel.Test)"]

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionContext Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext Properties
ExecutionContext Class See Also Send Feedback

The ExecutionContext type exposes the following members.

Properties

 | Name | Description
Public property | ActiveDataRows | Gets the active data rows.
Public property | BugConfiguration | Gets the settings object.
 | Current | Get the current execution context.
Public property | CurrentDataRow | Gets the current data row of current execution iteration for the current (come on!) data driven test.
Public property | CurrentIterationIndex | Gets the current iteration index
Public property | CurrentStep | Gets the current automation step being executed.
Public property | DataContexts | Gets a dictionary of all data context instances by test. The keys are populated with the Test.UniqueId.
Public property | DataSource | Gets the datatable of the current data driven test.
Public property | DeploymentDirectory | Gets the deployment directory where data files and deployment items are being placed.
Public property | FirstStepGuid | During RunFromHereExecution or RunSelectedExecution, represents the first step to be executed
Public property | HttpRecorder | The HTTP recorder that is recording the test's traffic, or null if we're not recording HTTP traffic
Public property | LastStepGuid | During RunToHereExecution or RunSelectedExecution, represents the last step to be executed
Public property | Manager | Gets the manager object.
Public property | RunFromHereStepExecuted | Flag indicating whether or not the run from here step has already been executed.
Public property | Settings | Gets the settings object.
Public property | ShouldAbort |
Public property | Test | Gets the current test.
Public property | UpdatePackage | Get the update package associated with this execution context.
Public property | VisualDebugger | The Visual UI that allows you to control and display visual annotation in the execution UI.

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


ActiveDataRows Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..ActiveDataRows Property
ExecutionContext Class See Also Send Feedback
Gets the active data rows.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataRowCollection ActiveDataRows { get; }
Visual Basic
Public ReadOnly Property ActiveDataRows As DataRowCollection
    Get
Visual C++
public:
property DataRowCollection^ ActiveDataRows {
    DataRowCollection^ get ();
}

Field Value

The active data rows.

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


BugConfiguration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..BugConfiguration Property
ExecutionContext Class See Also Send Feedback
Gets the settings object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BugConfigurationSet BugConfiguration { get; }
Visual Basic
Public ReadOnly Property BugConfiguration As BugConfigurationSet
    Get
Visual C++
public:
property BugConfigurationSet^ BugConfiguration {
    BugConfigurationSet^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


Current Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..Current Property
ExecutionContext Class See Also Send Feedback
Get the current execution context.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ExecutionContext Current { get; internal set; }
Visual Basic
Public Shared Property Current As ExecutionContext
    Get
    Friend Set
Visual C++
public:
static property ExecutionContext^ Current {
    ExecutionContext^ get ();
    internal: void set (ExecutionContext^ value);
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentDataRow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..CurrentDataRow Property
ExecutionContext Class See Also Send Feedback
Gets the current data row of current execution iteration for the current (come on!) data driven test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataRow CurrentDataRow { get; }
Visual Basic
Public ReadOnly Property CurrentDataRow As DataRow
    Get
Visual C++
public:
property DataRow^ CurrentDataRow {
    DataRow^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentIterationIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..CurrentIterationIndex Property
ExecutionContext Class See Also Send Feedback
Gets the current iteration index

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CurrentIterationIndex { get; }
Visual Basic
Public ReadOnly Property CurrentIterationIndex As Integer
    Get
Visual C++
public:
property int CurrentIterationIndex {
    int get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentStep Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..CurrentStep Property
ExecutionContext Class See Also Send Feedback
Gets the current automation step being executed.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationStepBase CurrentStep { get; }
Visual Basic
Public ReadOnly Property CurrentStep As AutomationStepBase
    Get
Visual C++
public:
property AutomationStepBase^ CurrentStep {
    AutomationStepBase^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


DataContexts Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..DataContexts Property
ExecutionContext Class See Also Send Feedback
Gets a dictionary of all data context instances by test. The keys are populated with the Test.UniqueId.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<Guid, DataContext> DataContexts { get; }
Visual Basic
Public ReadOnly Property DataContexts As Dictionary(Of Guid, DataContext)
    Get
Visual C++
public:
property Dictionary<Guid, DataContext^>^ DataContexts {
    Dictionary<Guid, DataContext^>^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


DataSource Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..DataSource Property
ExecutionContext Class See Also Send Feedback
Gets the datatable of the current data driven test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataTable DataSource { get; }
Visual Basic
Public ReadOnly Property DataSource As DataTable
    Get
Visual C++
public:
property DataTable^ DataSource {
    DataTable^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


DeploymentDirectory Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..DeploymentDirectory Property
ExecutionContext Class See Also Send Feedback
Gets the deployment directory where data files and deployment items are being placed.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DeploymentDirectory { get; }
Visual Basic
Public ReadOnly Property DeploymentDirectory As String
    Get
Visual C++
public:
property String^ DeploymentDirectory {
    String^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


FirstStepGuid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..FirstStepGuid Property
ExecutionContext Class See Also Send Feedback
During RunFromHereExecution or RunSelectedExecution, represents the first step to be executed

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid FirstStepGuid { get; internal set; }
Visual Basic
Public Property FirstStepGuid As Guid
    Get
    Friend Set
Visual C++
public:
property Guid FirstStepGuid {
    Guid get ();
    internal: void set (Guid value);
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


HttpRecorder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..HttpRecorder Property
ExecutionContext Class See Also Send Feedback
The HTTP recorder that is recording the test's traffic, or null if we're not recording HTTP traffic

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpTrafficRecorder HttpRecorder { get; internal set; }
Visual Basic
Public Property HttpRecorder As HttpTrafficRecorder
    Get
    Friend Set
Visual C++
public:
property HttpTrafficRecorder^ HttpRecorder {
    HttpTrafficRecorder^ get ();
    internal: void set (HttpTrafficRecorder^ value);
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


LastStepGuid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..LastStepGuid Property
ExecutionContext Class See Also Send Feedback
During RunToHereExecution or RunSelectedExecution, represents the last step to be executed

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid LastStepGuid { get; internal set; }
Visual Basic
Public Property LastStepGuid As Guid
    Get
    Friend Set
Visual C++
public:
property Guid LastStepGuid {
    Guid get ();
    internal: void set (Guid value);
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


Manager Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..Manager Property
ExecutionContext Class See Also Send Feedback
Gets the manager object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Manager Manager { get; }
Visual Basic
Public ReadOnly Property Manager As Manager
    Get
Visual C++
public:
property Manager^ Manager {
    Manager^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


RunFromHereStepExecuted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..RunFromHereStepExecuted Property
ExecutionContext Class See Also Send Feedback
Flag indicating whether or not the run from here step has already been executed.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool RunFromHereStepExecuted { get; set; }
Visual Basic
Public Property RunFromHereStepExecuted As Boolean
    Get
    Set
Visual C++
public:
property bool RunFromHereStepExecuted {
    bool get ();
    void set (bool value);
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


Settings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..Settings Property
ExecutionContext Class See Also Send Feedback
Gets the settings object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings Settings { get; }
Visual Basic
Public ReadOnly Property Settings As Settings
    Get
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


ShouldAbort Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..ShouldAbort Property
ExecutionContext Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecutionContext.ShouldAbort"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShouldAbort { get; set; }
Visual Basic
Public Property ShouldAbort As Boolean
    Get
    Set
Visual C++
public:
property bool ShouldAbort {
    bool get ();
    void set (bool value);
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


Test Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..Test Property
ExecutionContext Class See Also Send Feedback
Gets the current test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Test Test { get; }
Visual Basic
Public ReadOnly Property Test As Test
    Get
Visual C++
public:
property Test^ Test {
    Test^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdatePackage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..UpdatePackage Property
ExecutionContext Class See Also Send Feedback
Get the update package associated with this execution context.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestUpdatePackage UpdatePackage { get; }
Visual Basic
Public ReadOnly Property UpdatePackage As TestUpdatePackage
    Get
Visual C++
public:
property TestUpdatePackage^ UpdatePackage {
    TestUpdatePackage^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


VisualDebugger Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionContext..::..VisualDebugger Property
ExecutionContext Class See Also Send Feedback
The Visual UI that allows you to control and display visual annotation in the execution UI.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualDebugger VisualDebugger { get; }
Visual Basic
Public ReadOnly Property VisualDebugger As VisualDebugger
    Get
Visual C++
public:
property VisualDebugger^ VisualDebugger {
    VisualDebugger^ get ();
}

See Also

ExecutionContext Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionReturnValues Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues Members
ExecutionReturnValues Class Constructors Methods Properties See Also Send Feedback

The ExecutionReturnValues type exposes the following members.

Constructors

 | Name | Description
Public method | ExecutionReturnValues | Initializes a new instance of the ExecutionReturnValues class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Hwnds |
Public property | Pid |
Public property | TestResult |
Public property | TestType |
Public property | UpdatePackage |

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionReturnValues Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues Constructor
ExecutionReturnValues Class See Also Send Feedback
Initializes a new instance of the ExecutionReturnValues class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecutionReturnValues(
    TestResult result,
    TestUpdatePackage updatePackage,
    IntPtr[] hwnds,
    TestType testType
)
Visual Basic
Public Sub New ( _
    result As TestResult, _
    updatePackage As TestUpdatePackage, _
    hwnds As IntPtr(), _
    testType As TestType _
)
Visual C++
public:
ExecutionReturnValues(
    TestResult^ result,
    TestUpdatePackage^ updatePackage,
    array<IntPtr>^ hwnds,
    TestType testType
)

Parameters

result
Type: ArtOfTest.WebAii.Design.Execution..::..TestResult

[Missing <param name="result"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.#ctor(ArtOfTest.WebAii.Design.Execution.TestResult,ArtOfTest.WebAii.Design.Execution.TestUpdatePackage,System.IntPtr[],ArtOfTest.Common.Design.Extensibility.TestType)"]

updatePackage
Type: ArtOfTest.WebAii.Design.Execution..::..TestUpdatePackage

[Missing <param name="updatePackage"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.#ctor(ArtOfTest.WebAii.Design.Execution.TestResult,ArtOfTest.WebAii.Design.Execution.TestUpdatePackage,System.IntPtr[],ArtOfTest.Common.Design.Extensibility.TestType)"]

hwnds
Type: array< System..::..IntPtr >[]()[][]

[Missing <param name="hwnds"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.#ctor(ArtOfTest.WebAii.Design.Execution.TestResult,ArtOfTest.WebAii.Design.Execution.TestUpdatePackage,System.IntPtr[],ArtOfTest.Common.Design.Extensibility.TestType)"]

testType
Type: TestType

[Missing <param name="testType"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.#ctor(ArtOfTest.WebAii.Design.Execution.TestResult,ArtOfTest.WebAii.Design.Execution.TestUpdatePackage,System.IntPtr[],ArtOfTest.Common.Design.Extensibility.TestType)"]

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionReturnValues Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues Methods
ExecutionReturnValues Class See Also Send Feedback

The ExecutionReturnValues type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionReturnValues Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues Properties
ExecutionReturnValues Class See Also Send Feedback

The ExecutionReturnValues type exposes the following members.

Properties

 | Name | Description
Public property | Hwnds |
Public property | Pid |
Public property | TestResult |
Public property | TestType |
Public property | UpdatePackage |

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


Hwnds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues..::..Hwnds Property
ExecutionReturnValues Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.Hwnds"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IntPtr[] Hwnds { get; set; }
Visual Basic
Public Property Hwnds As IntPtr()
    Get
    Set
Visual C++
public:
property array<IntPtr>^ Hwnds {
    array<IntPtr>^ get ();
    void set (array<IntPtr>^ value);
}

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


Pid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues..::..Pid Property
ExecutionReturnValues Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.Pid"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Pid { get; set; }
Visual Basic
Public Property Pid As Integer
    Get
    Set
Visual C++
public:
property int Pid {
    int get ();
    void set (int value);
}

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues..::..TestResult Property
ExecutionReturnValues Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.TestResult"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult TestResult { get; set; }
Visual Basic
Public Property TestResult As TestResult
    Get
    Set
Visual C++
public:
property TestResult^ TestResult {
    TestResult^ get ();
    void set (TestResult^ value);
}

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


TestType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues..::..TestType Property
ExecutionReturnValues Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.TestType"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestType TestType { get; }
Visual Basic
Public ReadOnly Property TestType As TestType
    Get
Visual C++
public:
property TestType TestType {
    TestType get ();
}

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdatePackage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecutionReturnValues..::..UpdatePackage Property
ExecutionReturnValues Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues.UpdatePackage"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestUpdatePackage UpdatePackage { get; set; }
Visual Basic
Public Property UpdatePackage As TestUpdatePackage
    Get
    Set
Visual C++
public:
property TestUpdatePackage^ UpdatePackage {
    TestUpdatePackage^ get ();
    void set (TestUpdatePackage^ value);
}

See Also

ExecutionReturnValues Class
ArtOfTest.WebAii.Design.Execution Namespace


Filter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter Members
Filter Class Constructors Methods Properties See Also Send Feedback

The Filter type exposes the following members.

Constructors

 | Name | Description
Public method | Filter()()()() | Initializes a new instance of the Filter class
Public method | Filter(String, String) | Initializes a new instance of the Filter class
Public method | Filter(String, Object, Int32) | Initializes a new instance of the Filter class
Public method | Filter(String, Object, String) | Initializes a new instance of the Filter class

Methods

 | Name | Description
Public method | AcceptAllTests | Tells the filter to operate over all the tests in the project.
Public method | AddClause(String, Int32) | Adds an equality clause for integer property value.
Public method | AddClause(String, String) | Adds an equality clause.
Public method | AddClause(String, Object, Int32) | Adds a clause to the filtering criteria for an integer property value.
Public method | AddClause(String, Object, String) | Adds a clause to the filtering criteria.
Public method | Clear | Removes all items from the filter.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFilterPropertyNames | Get the list of all target properties we can filter against.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Public method | Match | Gets whether the given test matches the current filtering criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveClauseAt | Removes the filter clause by the specified index.
Public method | SaveTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AcceptAll | Get whether the filter operates over all the tests in the project.
Public property | Comparisons | Gets the list of the filter comparisons.
Public property | CurrentVersion |
Public property | Keys | Gets the list of the filter keys.
Public property | RootName |
Public property | Values | Gets the list of the filter values.
Public property | XmlBlob |

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


Filter Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter Constructor
Filter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Filter()()()() | Initializes a new instance of the Filter class
Public method | Filter(String, String) | Initializes a new instance of the Filter class
Public method | Filter(String, Object, Int32) | Initializes a new instance of the Filter class
Public method | Filter(String, Object, String) | Initializes a new instance of the Filter class

See Also

Filter Class
Filter Members
ArtOfTest.WebAii.Design.Execution Namespace


Filter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter Constructor
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Filter()
Visual Basic
Public Sub New
Visual C++
public:
Filter()

See Also

Filter Class
Filter Overload
ArtOfTest.WebAii.Design.Execution Namespace


Filter Constructor (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter Constructor (String, String)
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Filter(
    string key,
    string value
)
Visual Basic
Public Sub New ( _
    key As String, _
    value As String _
)
Visual C++
public:
Filter(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.#ctor(System.String,System.String)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.#ctor(System.String,System.String)"]

See Also

Filter Class
Filter Overload
ArtOfTest.WebAii.Design.Execution Namespace


Filter Constructor (String, Object, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter Constructor (String, Object, Int32)
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Filter(
    string key,
    Object comparison,
    int value
)
Visual Basic
Public Sub New ( _
    key As String, _
    comparison As Object, _
    value As Integer _
)
Visual C++
public:
Filter(
    String^ key,
    Object^ comparison,
    int value
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.#ctor(System.String,System.Object,System.Int32)"]

comparison
Type: System..::..Object

[Missing <param name="comparison"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.#ctor(System.String,System.Object,System.Int32)"]

value
Type: System..::..Int32

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.#ctor(System.String,System.Object,System.Int32)"]

See Also

Filter Class
Filter Overload
ArtOfTest.WebAii.Design.Execution Namespace


Filter Constructor (String, Object, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter Constructor (String, Object, String)
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Filter(
    string key,
    Object comparison,
    string value
)
Visual Basic
Public Sub New ( _
    key As String, _
    comparison As Object, _
    value As String _
)
Visual C++
public:
Filter(
    String^ key,
    Object^ comparison,
    String^ value
)

Parameters

key
Type: System..::..String

[Missing <param name="key"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.#ctor(System.String,System.Object,System.String)"]

comparison
Type: System..::..Object

[Missing <param name="comparison"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.#ctor(System.String,System.Object,System.String)"]

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.#ctor(System.String,System.Object,System.String)"]

See Also

Filter Class
Filter Overload
ArtOfTest.WebAii.Design.Execution Namespace


Filter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

 | Name | Description
Public method | AcceptAllTests | Tells the filter to operate over all the tests in the project.
Public method | AddClause(String, Int32) | Adds an equality clause for integer property value.
Public method | AddClause(String, String) | Adds an equality clause.
Public method | AddClause(String, Object, Int32) | Adds a clause to the filtering criteria for an integer property value.
Public method | AddClause(String, Object, String) | Adds a clause to the filtering criteria.
Public method | Clear | Removes all items from the filter.
Public method | Clone | Clones this instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetFilterPropertyNames | Get the list of all target properties we can filter against.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Public method | Match | Gets whether the given test matches the current filtering criteria.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveClauseAt | Removes the filter clause by the specified index.
Public method | SaveTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


AcceptAllTests Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..AcceptAllTests Method
Filter Class See Also Send Feedback
Tells the filter to operate over all the tests in the project.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AcceptAllTests()
Visual Basic
Public Sub AcceptAllTests
Visual C++
public:
void AcceptAllTests()

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


AddClause Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..AddClause Method
Filter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddClause(String, Int32) | Adds an equality clause for integer property value.
Public method | AddClause(String, String) | Adds an equality clause.
Public method | AddClause(String, Object, Int32) | Adds a clause to the filtering criteria for an integer property value.
Public method | AddClause(String, Object, String) | Adds a clause to the filtering criteria.

See Also

Filter Class
Filter Members
ArtOfTest.WebAii.Design.Execution Namespace


AddClause Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..AddClause Method (String, Int32)
Filter Class See Also Send Feedback
Adds an equality clause for integer property value.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddClause(
    string key,
    int value
)
Visual Basic
Public Sub AddClause ( _
    key As String, _
    value As Integer _
)
Visual C++
public:
void AddClause(
    String^ key,
    int value
)

Parameters

key
Type: System..::..String
The key to search by.
value
Type: System..::..Int32
The value corresponding to that key.

See Also

Filter Class
AddClause Overload
ArtOfTest.WebAii.Design.Execution Namespace


AddClause Method (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..AddClause Method (String, String)
Filter Class See Also Send Feedback
Adds an equality clause.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddClause(
    string key,
    string value
)
Visual Basic
Public Sub AddClause ( _
    key As String, _
    value As String _
)
Visual C++
public:
void AddClause(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::..String
The key to search by.
value
Type: System..::..String
The value corresponding to that key.

See Also

Filter Class
AddClause Overload
ArtOfTest.WebAii.Design.Execution Namespace


AddClause Method (String, Object, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..AddClause Method (String, Object, Int32)
Filter Class See Also Send Feedback
Adds a clause to the filtering criteria for an integer property value.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddClause(
    string key,
    Object comparison,
    int value
)
Visual Basic
Public Sub AddClause ( _
    key As String, _
    comparison As Object, _
    value As Integer _
)
Visual C++
public:
void AddClause(
    String^ key,
    Object^ comparison,
    int value
)

Parameters

key
Type: System..::..String
The key to search by.
comparison
Type: System..::..Object
The filtering comparison.
value
Type: System..::..Int32
The value corresponding to that key and comparison.

See Also

Filter Class
AddClause Overload
ArtOfTest.WebAii.Design.Execution Namespace


AddClause Method (String, Object, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..AddClause Method (String, Object, String)
Filter Class See Also Send Feedback
Adds a clause to the filtering criteria.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddClause(
    string key,
    Object comparison,
    string value
)
Visual Basic
Public Sub AddClause ( _
    key As String, _
    comparison As Object, _
    value As String _
)
Visual C++
public:
void AddClause(
    String^ key,
    Object^ comparison,
    String^ value
)

Parameters

key
Type: System..::..String
The key to search by.
comparison
Type: System..::..Object
The filtering comparison.
value
Type: System..::..String
The value corresponding to that key and comparison.

See Also

Filter Class
AddClause Overload
ArtOfTest.WebAii.Design.Execution Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..Clear Method
Filter Class See Also Send Feedback
Removes all items from the filter.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


Clone Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..Clone Method
Filter Class See Also Send Feedback
Clones this instance.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Filter Clone()
Visual Basic
Public Function Clone As Filter
Visual C++
public:
Filter^ Clone()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.Clone"]

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


GetFilterPropertyNames Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..GetFilterPropertyNames Method
Filter Class See Also Send Feedback
Get the list of all target properties we can filter against.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static List<string> GetFilterPropertyNames(
    Type targetType
)
Visual Basic
Public Shared Function GetFilterPropertyNames ( _
    targetType As Type _
) As List(Of String)
Visual C++
public:
static List<String^>^ GetFilterPropertyNames(
    Type^ targetType
)

Parameters

targetType
Type: System..::..Type

[Missing <param name="targetType"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.GetFilterPropertyNames(System.Type)"]

Return Value

The list of all target properties we can filter against.

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..LoadFrom Method
Filter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


Match Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..Match Method
Filter Class See Also Send Feedback
Gets whether the given test matches the current filtering criteria.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Match(
    Object target
)
Visual Basic
Public Function Match ( _
    target As Object _
) As Boolean
Visual C++
public:
bool Match(
    Object^ target
)

Parameters

target
Type: System..::..Object

[Missing <param name="target"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.Match(System.Object)"]

Return Value

Whether the given test matches the current filtering criteria.

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoveClauseAt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..RemoveClauseAt Method
Filter Class See Also Send Feedback
Removes the filter clause by the specified index.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveClauseAt(
    int index
)
Visual Basic
Public Sub RemoveClauseAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveClauseAt(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the clause.

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..SaveTo Method
Filter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.Filter.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


Filter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter Properties
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Properties

 | Name | Description
Public property | AcceptAll | Get whether the filter operates over all the tests in the project.
Public property | Comparisons | Gets the list of the filter comparisons.
Public property | CurrentVersion |
Public property | Keys | Gets the list of the filter keys.
Public property | RootName |
Public property | Values | Gets the list of the filter values.
Public property | XmlBlob |

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


AcceptAll Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..AcceptAll Property
Filter Class See Also Send Feedback
Get whether the filter operates over all the tests in the project.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AcceptAll { get; }
Visual Basic
Public ReadOnly Property AcceptAll As Boolean
    Get
Visual C++
public:
property bool AcceptAll {
    bool get ();
}

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


Comparisons Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..Comparisons Property
Filter Class See Also Send Feedback
Gets the list of the filter comparisons.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<Object> Comparisons { get; }
Visual Basic
Public ReadOnly Property Comparisons As List(Of Object)
    Get
Visual C++
public:
property List<Object^>^ Comparisons {
    List<Object^>^ get ();
}

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..CurrentVersion Property
Filter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.Filter.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


Keys Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..Keys Property
Filter Class See Also Send Feedback
Gets the list of the filter keys.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<string> Keys { get; }
Visual Basic
Public ReadOnly Property Keys As List(Of String)
    Get
Visual C++
public:
property List<String^>^ Keys {
    List<String^>^ get ();
}

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..RootName Property
Filter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.Filter.RootName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


Values Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..Values Property
Filter Class See Also Send Feedback
Gets the list of the filter values.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<string> Values { get; }
Visual Basic
Public ReadOnly Property Values As List(Of String)
    Get
Visual C++
public:
property List<String^>^ Values {
    List<String^>^ get ();
}

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Filter..::..XmlBlob Property
Filter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.Filter.XmlBlob"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

Filter Class
ArtOfTest.WebAii.Design.Execution Namespace


FilteredCollection(T) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)> Members
FilteredCollection<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The FilteredCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredCollection<(Of <(<'T>)>)> | Initializes a new instance of the FilteredCollection<(Of <(<'T>)>)> class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' T >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectList |
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' T >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' T >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' T >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' T >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Design.Execution Namespace


FilteredCollection(T) Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)> Constructor
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the FilteredCollection<(Of <(<'T>)>)> class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FilteredCollection(
    IEnumerable<T> list
)
Visual Basic
Public Sub New ( _
    list As IEnumerable(Of T) _
)
Visual C++
public:
FilteredCollection(
    IEnumerable<T>^ list
)

Parameters

list
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' T >)>)>

[Missing <param name="list"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.FilteredCollection`1.#ctor(System.Collections.Generic.IEnumerable{`0})"]

See Also

FilteredCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Design.Execution Namespace


FilteredCollection(T) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)> Methods
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The FilteredCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' T >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectList |
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' T >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' T >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Design.Execution Namespace


BinarySearch Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..BinarySearch Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
FilteredCollection<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Design.Execution Namespace


CopyTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..CopyTo Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' T >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
FilteredCollection<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Design.Execution Namespace


FindIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..FindIndex Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
FilteredCollection<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Design.Execution Namespace


FindLastIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..FindLastIndex Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
FilteredCollection<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Design.Execution Namespace


GetObjectList Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..GetObjectList Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.FilteredCollection`1.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract List<T> GetObjectList(
    Filter filter
)
Visual Basic
Public MustOverride Function GetObjectList ( _
    filter As Filter _
) As List(Of T)
Visual C++
public:
virtual List<T>^ GetObjectList(
    Filter^ filter
) abstract

Parameters

filter
Type: ArtOfTest.WebAii.Design.Execution..::..Filter

[Missing <param name="filter"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.FilteredCollection`1.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.FilteredCollection`1.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

See Also

FilteredCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Design.Execution Namespace


IndexOf Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..IndexOf Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' T >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
FilteredCollection<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Design.Execution Namespace


LastIndexOf Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..LastIndexOf Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' T >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
FilteredCollection<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Design.Execution Namespace


Reverse Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..Reverse Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
FilteredCollection<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Design.Execution Namespace


Sort Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)>..::..Sort Method
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
FilteredCollection<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Design.Execution Namespace


FilteredCollection(T) Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilteredCollection<(Of <(<'T>)>)> Properties
FilteredCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The FilteredCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' T >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' T >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' T >)>)>.)

See Also

FilteredCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Design.Execution Namespace


FindExpressionUpdateInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo Members
FindExpressionUpdateInfo Class Constructors Methods Properties Events See Also Send Feedback

The FindExpressionUpdateInfo type exposes the following members.

Constructors

 | Name | Description
Public method | FindExpressionUpdateInfo | Initializes a new instance of the FindExpressionUpdateInfo class

Methods

 | Name | Description
Public method | ApplyUpdate | (Overrides UpdateInfo..::..ApplyUpdate()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeTestAndStep | Given the actual project object, initialize the target Test/Step (Inherited from UpdateInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnPropertyChanged | (Inherited from UpdateInfo.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplyError | (Inherited from UpdateInfo.)
Public property | Description | (Inherited from UpdateInfo.)
Public property | DoApplyUpdate | (Inherited from UpdateInfo.)
Public property | ElementDescriptorIndex |
Public property | Initialized | (Inherited from UpdateInfo.)
Public property | NewExpression |
Public property | StepOrder | (Inherited from UpdateInfo.)
Public property | TargetStep | (Inherited from UpdateInfo.)
Public property | TargetTest | (Inherited from UpdateInfo.)
Public property | TestId | (Inherited from UpdateInfo.)
Public property | UpdateTypeDescription | (Overrides UpdateInfo..::..UpdateTypeDescription.)

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from UpdateInfo.)

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


FindExpressionUpdateInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo Constructor
FindExpressionUpdateInfo Class See Also Send Feedback
Initializes a new instance of the FindExpressionUpdateInfo class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindExpressionUpdateInfo(
    int elementIndex,
    Guid testId,
    int stepOrder,
    FindExpressionElement newExpression
)
Visual Basic
Public Sub New ( _
    elementIndex As Integer, _
    testId As Guid, _
    stepOrder As Integer, _
    newExpression As FindExpressionElement _
)
Visual C++
public:
FindExpressionUpdateInfo(
    int elementIndex,
    Guid testId,
    int stepOrder,
    FindExpressionElement^ newExpression
)

Parameters

elementIndex
Type: System..::..Int32

[Missing <param name="elementIndex"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.FindExpressionUpdateInfo.#ctor(System.Int32,System.Guid,System.Int32,ArtOfTest.Common.Design.ProjectModel.Elements.FindExpressionElement)"]

testId
Type: System..::..Guid

[Missing <param name="testId"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.FindExpressionUpdateInfo.#ctor(System.Int32,System.Guid,System.Int32,ArtOfTest.Common.Design.ProjectModel.Elements.FindExpressionElement)"]

stepOrder
Type: System..::..Int32

[Missing <param name="stepOrder"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.FindExpressionUpdateInfo.#ctor(System.Int32,System.Guid,System.Int32,ArtOfTest.Common.Design.ProjectModel.Elements.FindExpressionElement)"]

newExpression
Type: FindExpressionElement

[Missing <param name="newExpression"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.FindExpressionUpdateInfo.#ctor(System.Int32,System.Guid,System.Int32,ArtOfTest.Common.Design.ProjectModel.Elements.FindExpressionElement)"]

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


FindExpressionUpdateInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo Methods
FindExpressionUpdateInfo Class See Also Send Feedback

The FindExpressionUpdateInfo type exposes the following members.

Methods

 | Name | Description
Public method | ApplyUpdate | (Overrides UpdateInfo..::..ApplyUpdate()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeTestAndStep | Given the actual project object, initialize the target Test/Step (Inherited from UpdateInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnPropertyChanged | (Inherited from UpdateInfo.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


ApplyUpdate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo..::..ApplyUpdate Method
FindExpressionUpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.FindExpressionUpdateInfo.ApplyUpdate"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void ApplyUpdate()
Visual Basic
Public Overrides Sub ApplyUpdate
Visual C++
public:
virtual void ApplyUpdate() override

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


FindExpressionUpdateInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo Properties
FindExpressionUpdateInfo Class See Also Send Feedback

The FindExpressionUpdateInfo type exposes the following members.

Properties

 | Name | Description
Public property | ApplyError | (Inherited from UpdateInfo.)
Public property | Description | (Inherited from UpdateInfo.)
Public property | DoApplyUpdate | (Inherited from UpdateInfo.)
Public property | ElementDescriptorIndex |
Public property | Initialized | (Inherited from UpdateInfo.)
Public property | NewExpression |
Public property | StepOrder | (Inherited from UpdateInfo.)
Public property | TargetStep | (Inherited from UpdateInfo.)
Public property | TargetTest | (Inherited from UpdateInfo.)
Public property | TestId | (Inherited from UpdateInfo.)
Public property | UpdateTypeDescription | (Overrides UpdateInfo..::..UpdateTypeDescription.)

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


ElementDescriptorIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo..::..ElementDescriptorIndex Property
FindExpressionUpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.FindExpressionUpdateInfo.ElementDescriptorIndex"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ElementDescriptorIndex { get; }
Visual Basic
Public ReadOnly Property ElementDescriptorIndex As Integer
    Get
Visual C++
public:
property int ElementDescriptorIndex {
    int get ();
}

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


NewExpression Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo..::..NewExpression Property
FindExpressionUpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.FindExpressionUpdateInfo.NewExpression"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindExpressionElement NewExpression { get; }
Visual Basic
Public ReadOnly Property NewExpression As FindExpressionElement
    Get
Visual C++
public:
property FindExpressionElement^ NewExpression {
    FindExpressionElement^ get ();
}

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdateTypeDescription Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo..::..UpdateTypeDescription Property
FindExpressionUpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.FindExpressionUpdateInfo.UpdateTypeDescription"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string UpdateTypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property UpdateTypeDescription As String
    Get
Visual C++
public:
virtual property String^ UpdateTypeDescription {
    String^ get () override;
}

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


FindExpressionUpdateInfo Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionUpdateInfo Events
FindExpressionUpdateInfo Class See Also Send Feedback

The FindExpressionUpdateInfo type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from UpdateInfo.)

See Also

FindExpressionUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


IExecutionExtension Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IExecutionExtension Members
IExecutionExtension Interface Methods See Also Send Feedback

The IExecutionExtension type exposes the following members.

Methods

 | Name | Description
Public method | OnAfterTestCompleted | Called right after a test is completed execution.
Public method | OnAfterTestListCompleted | Called right after a test list has been completed
Public method | OnBeforeTestListStarted | Called right before a test list is about to get started.
Public method | OnBeforeTestStarted | Called right before a test is started
Public method | OnInitializeDataSource | Called on the initialization of the data source. This is an opportunity to retrieve a custom data source and return it as a DataTable.
Public method | OnStepFailure | Called when a step fails in a test.

See Also

IExecutionExtension Interface
ArtOfTest.WebAii.Design.Execution Namespace


IExecutionExtension Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IExecutionExtension Methods
IExecutionExtension Interface See Also Send Feedback

The IExecutionExtension type exposes the following members.

Methods

 | Name | Description
Public method | OnAfterTestCompleted | Called right after a test is completed execution.
Public method | OnAfterTestListCompleted | Called right after a test list has been completed
Public method | OnBeforeTestListStarted | Called right before a test list is about to get started.
Public method | OnBeforeTestStarted | Called right before a test is started
Public method | OnInitializeDataSource | Called on the initialization of the data source. This is an opportunity to retrieve a custom data source and return it as a DataTable.
Public method | OnStepFailure | Called when a step fails in a test.

See Also

IExecutionExtension Interface
ArtOfTest.WebAii.Design.Execution Namespace


OnAfterTestCompleted Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IExecutionExtension..::..OnAfterTestCompleted Method
IExecutionExtension Interface See Also Send Feedback
Called right after a test is completed execution.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void OnAfterTestCompleted(
    ExecutionContext executionContext,
    TestResult result
)
Visual Basic
Sub OnAfterTestCompleted ( _
    executionContext As ExecutionContext, _
    result As TestResult _
)
Visual C++
void OnAfterTestCompleted(
    ExecutionContext^ executionContext,
    TestResult^ result
)

Parameters

executionContext
Type: ArtOfTest.WebAii.Design.Execution..::..ExecutionContext
The execution context
result
Type: ArtOfTest.WebAii.Design.Execution..::..TestResult
The test to be executed

See Also

IExecutionExtension Interface
ArtOfTest.WebAii.Design.Execution Namespace


OnAfterTestListCompleted Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IExecutionExtension..::..OnAfterTestListCompleted Method
IExecutionExtension Interface See Also Send Feedback
Called right after a test list has been completed

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void OnAfterTestListCompleted(
    RunResult result
)
Visual Basic
Sub OnAfterTestListCompleted ( _
    result As RunResult _
)
Visual C++
void OnAfterTestListCompleted(
    RunResult^ result
)

Parameters

result
Type: ArtOfTest.WebAii.Design.Execution..::..RunResult
The RunResult of that test list

See Also

IExecutionExtension Interface
ArtOfTest.WebAii.Design.Execution Namespace


OnBeforeTestListStarted Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IExecutionExtension..::..OnBeforeTestListStarted Method
IExecutionExtension Interface See Also Send Feedback
Called right before a test list is about to get started.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void OnBeforeTestListStarted(
    TestList list
)
Visual Basic
Sub OnBeforeTestListStarted ( _
    list As TestList _
)
Visual C++
void OnBeforeTestListStarted(
    TestList^ list
)

Parameters

list
Type: ArtOfTest.WebAii.Design.Execution..::..TestList
The TestList object that will be executed

See Also

IExecutionExtension Interface
ArtOfTest.WebAii.Design.Execution Namespace


OnBeforeTestStarted Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IExecutionExtension..::..OnBeforeTestStarted Method
IExecutionExtension Interface See Also Send Feedback
Called right before a test is started

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void OnBeforeTestStarted(
    ExecutionContext executionContext,
    Test test
)
Visual Basic
Sub OnBeforeTestStarted ( _
    executionContext As ExecutionContext, _
    test As Test _
)
Visual C++
void OnBeforeTestStarted(
    ExecutionContext^ executionContext,
    Test^ test
)

Parameters

executionContext
Type: ArtOfTest.WebAii.Design.Execution..::..ExecutionContext
The execution context
test
Type: Test
The test to be executed

See Also

IExecutionExtension Interface
ArtOfTest.WebAii.Design.Execution Namespace


OnInitializeDataSource Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IExecutionExtension..::..OnInitializeDataSource Method
IExecutionExtension Interface See Also Send Feedback
Called on the initialization of the data source. This is an opportunity to retrieve a custom data source and return it as a DataTable.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
DataTable OnInitializeDataSource(
    ExecutionContext executionContext
)
Visual Basic
Function OnInitializeDataSource ( _
    executionContext As ExecutionContext _
) As DataTable
Visual C++
DataTable^ OnInitializeDataSource(
    ExecutionContext^ executionContext
)

Parameters

executionContext
Type: ArtOfTest.WebAii.Design.Execution..::..ExecutionContext
The execution context.

Return Value

The DataTable to use as a data source else, return null.

Remarks

Regardless if the test is data bound or not, if this method returns a DataTable, the test will be considered data bound.

See Also

IExecutionExtension Interface
ArtOfTest.WebAii.Design.Execution Namespace


OnStepFailure Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IExecutionExtension..::..OnStepFailure Method
IExecutionExtension Interface See Also Send Feedback
Called when a step fails in a test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void OnStepFailure(
    ExecutionContext executionContext,
    AutomationStepResult stepResult
)
Visual Basic
Sub OnStepFailure ( _
    executionContext As ExecutionContext, _
    stepResult As AutomationStepResult _
)
Visual C++
void OnStepFailure(
    ExecutionContext^ executionContext,
    AutomationStepResult^ stepResult
)

Parameters

executionContext
Type: ArtOfTest.WebAii.Design.Execution..::..ExecutionContext
The execution context
stepResult
Type: ArtOfTest.WebAii.Design..::..AutomationStepResult
The result of the step failure

See Also

IExecutionExtension Interface
ArtOfTest.WebAii.Design.Execution Namespace


InstalledBrowsers Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers Members
InstalledBrowsers Class Constructors Methods Properties See Also Send Feedback

The InstalledBrowsers type exposes the following members.

Constructors

 | Name | Description
Public method | InstalledBrowsers | Initializes a new instance of the InstalledBrowsers class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ChromePath |
ChromeVersion |
FireFoxVersion |
IEVersion |
IsChromeInstalled |
IsFireFoxInstalled |
IsIEInstalled |
IsSafariInstalled |
SafariVersion |

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


InstalledBrowsers Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers Constructor
InstalledBrowsers Class See Also Send Feedback
Initializes a new instance of the InstalledBrowsers class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InstalledBrowsers()
Visual Basic
Public Sub New
Visual C++
public:
InstalledBrowsers()

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


InstalledBrowsers Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers Methods
InstalledBrowsers Class See Also Send Feedback

The InstalledBrowsers type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


InstalledBrowsers Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers Properties
InstalledBrowsers Class See Also Send Feedback

The InstalledBrowsers type exposes the following members.

Properties

Name | Description
ChromePath |
ChromeVersion |
FireFoxVersion |
IEVersion |
IsChromeInstalled |
IsFireFoxInstalled |
IsIEInstalled |
IsSafariInstalled |
SafariVersion |

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


ChromePath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..ChromePath Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.ChromePath"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string ChromePath { get; }
Visual Basic
Public Shared ReadOnly Property ChromePath As String
    Get
Visual C++
public:
static property String^ ChromePath {
    String^ get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


ChromeVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..ChromeVersion Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.ChromeVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string ChromeVersion { get; }
Visual Basic
Public Shared ReadOnly Property ChromeVersion As String
    Get
Visual C++
public:
static property String^ ChromeVersion {
    String^ get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


FireFoxVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..FireFoxVersion Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.FireFoxVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string FireFoxVersion { get; }
Visual Basic
Public Shared ReadOnly Property FireFoxVersion As String
    Get
Visual C++
public:
static property String^ FireFoxVersion {
    String^ get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


IEVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..IEVersion Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.IEVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string IEVersion { get; }
Visual Basic
Public Shared ReadOnly Property IEVersion As String
    Get
Visual C++
public:
static property String^ IEVersion {
    String^ get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


IsChromeInstalled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..IsChromeInstalled Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.IsChromeInstalled"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsChromeInstalled { get; }
Visual Basic
Public Shared ReadOnly Property IsChromeInstalled As Boolean
    Get
Visual C++
public:
static property bool IsChromeInstalled {
    bool get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


IsFireFoxInstalled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..IsFireFoxInstalled Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.IsFireFoxInstalled"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsFireFoxInstalled { get; }
Visual Basic
Public Shared ReadOnly Property IsFireFoxInstalled As Boolean
    Get
Visual C++
public:
static property bool IsFireFoxInstalled {
    bool get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


IsIEInstalled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..IsIEInstalled Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.IsIEInstalled"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsIEInstalled { get; }
Visual Basic
Public Shared ReadOnly Property IsIEInstalled As Boolean
    Get
Visual C++
public:
static property bool IsIEInstalled {
    bool get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


IsSafariInstalled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..IsSafariInstalled Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.IsSafariInstalled"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsSafariInstalled { get; }
Visual Basic
Public Shared ReadOnly Property IsSafariInstalled As Boolean
    Get
Visual C++
public:
static property bool IsSafariInstalled {
    bool get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


SafariVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InstalledBrowsers..::..SafariVersion Property
InstalledBrowsers Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.InstalledBrowsers.SafariVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string SafariVersion { get; }
Visual Basic
Public Shared ReadOnly Property SafariVersion As String
    Get
Visual C++
public:
static property String^ SafariVersion {
    String^ get ();
}

See Also

InstalledBrowsers Class
ArtOfTest.WebAii.Design.Execution Namespace


LogicalStepResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult Members
LogicalStepResult Class Constructors Methods Properties Events See Also Send Feedback

The LogicalStepResult type exposes the following members.

Constructors

 | Name | Description
Public method | LogicalStepResult | Initializes a new instance of the LogicalStepResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextSteps |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBrowserState | Load the browser state (Inherited from AutomationStepResult.)
Public method | LoadFrom | (Overrides AutomationStepResult..::..LoadFrom(XmlStoreNode).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from AutomationStepResult.)
Protected method | OnSerializing | (Inherited from AutomationStepResult.)
Public method | PersistStepFailureResourcesOnDisk | Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk. (Inherited from AutomationStepResult.)
Public method | SaveTo | (Overrides AutomationStepResult..::..SaveTo(XmlStoreNode).)
Public method | SetNextSteps |
Public method | StoreHostState | Store the browser state as part of this step (Inherited from AutomationStepResult.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BranchTaken |
Public property | ChildResult |
Public property | CurrentVersion | (Inherited from AutomationStepResult.)
Public property | Exception | Gets or sets the execution exception. If result type is fail, then this will contain the exception information about the failure. (Inherited from AutomationStepResult.)
Public property | HasExpectedImage | (Inherited from AutomationStepResult.)
Public property | HashCode | (Inherited from AutomationStepResult.)
Public property | HasImage | (Inherited from AutomationStepResult.)
Public property | InnerResult |
Public property | IsLoop |
Public property | IsManual | (Inherited from AutomationStepResult.)
Public property | LogicDetails |
Public property | LogMessageOnError | (Inherited from AutomationStepResult.)
Public property | LoopIteration |
Public property | Order | (Inherited from AutomationStepResult.)
Public property | OriginalDescription |
Public property | ParentTestResult | (Inherited from AutomationStepResult.)
Public property | ResultType | Gets or sets the result type (Pass/fail/notrun) (Inherited from AutomationStepResult.)
Public property | RootName | (Overrides AutomationStepResult..::..RootName.)
Public property | RunTimeStepId | (Inherited from AutomationStepResult.)
Public property | StepDescription | Gets or sets the description of this step. (Inherited from AutomationStepResult.)
Public property | TestId | Gets or sets the test unique Id this step result belongs to. (Inherited from AutomationStepResult.)
Public property | TestName | Gets or sets the test name of this step. (Inherited from AutomationStepResult.)
Public property | TestPath | Gets or sets the test path within the project. (Inherited from AutomationStepResult.)
Public property | TestStepIndex | Gets or sets the step index (Inherited from AutomationStepResult.)
Public property | UserComment | (Inherited from AutomationStepResult.)
Public property | WasStepEnabled | (Inherited from AutomationStepResult.)
Public property | XmlBlob | (Inherited from AutomationStepResult.)

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from AutomationStepResult.)

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LogicalStepResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult Constructor
LogicalStepResult Class See Also Send Feedback
Initializes a new instance of the LogicalStepResult class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LogicalStepResult()
Visual Basic
Public Sub New
Visual C++
public:
LogicalStepResult()

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LogicalStepResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult Methods
LogicalStepResult Class See Also Send Feedback

The LogicalStepResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextSteps |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBrowserState | Load the browser state (Inherited from AutomationStepResult.)
Public method | LoadFrom | (Overrides AutomationStepResult..::..LoadFrom(XmlStoreNode).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from AutomationStepResult.)
Protected method | OnSerializing | (Inherited from AutomationStepResult.)
Public method | PersistStepFailureResourcesOnDisk | Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk. (Inherited from AutomationStepResult.)
Public method | SaveTo | (Overrides AutomationStepResult..::..SaveTo(XmlStoreNode).)
Public method | SetNextSteps |
Public method | StoreHostState | Store the browser state as part of this step (Inherited from AutomationStepResult.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


GetNextSteps Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..GetNextSteps Method
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.GetNextSteps"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationStepList GetNextSteps()
Visual Basic
Public Function GetNextSteps As AutomationStepList
Visual C++
public:
AutomationStepList^ GetNextSteps()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.GetNextSteps"]

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..LoadFrom Method
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Overrides Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) override

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..SaveTo Method
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Overrides Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) override

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SetNextSteps Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..SetNextSteps Method
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.SetNextSteps(ArtOfTest.Common.Design.ProjectModel.AutomationStepList,System.Int32)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetNextSteps(
    AutomationStepList stepList,
    int branchTaken
)
Visual Basic
Public Sub SetNextSteps ( _
    stepList As AutomationStepList, _
    branchTaken As Integer _
)
Visual C++
public:
void SetNextSteps(
    AutomationStepList^ stepList,
    int branchTaken
)

Parameters

stepList
Type: AutomationStepList

[Missing <param name="stepList"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.SetNextSteps(ArtOfTest.Common.Design.ProjectModel.AutomationStepList,System.Int32)"]

branchTaken
Type: System..::..Int32

[Missing <param name="branchTaken"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.SetNextSteps(ArtOfTest.Common.Design.ProjectModel.AutomationStepList,System.Int32)"]

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LogicalStepResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult Properties
LogicalStepResult Class See Also Send Feedback

The LogicalStepResult type exposes the following members.

Properties

 | Name | Description
Public property | BranchTaken |
Public property | ChildResult |
Public property | CurrentVersion | (Inherited from AutomationStepResult.)
Public property | Exception | Gets or sets the execution exception. If result type is fail, then this will contain the exception information about the failure. (Inherited from AutomationStepResult.)
Public property | HasExpectedImage | (Inherited from AutomationStepResult.)
Public property | HashCode | (Inherited from AutomationStepResult.)
Public property | HasImage | (Inherited from AutomationStepResult.)
Public property | InnerResult |
Public property | IsLoop |
Public property | IsManual | (Inherited from AutomationStepResult.)
Public property | LogicDetails |
Public property | LogMessageOnError | (Inherited from AutomationStepResult.)
Public property | LoopIteration |
Public property | Order | (Inherited from AutomationStepResult.)
Public property | OriginalDescription |
Public property | ParentTestResult | (Inherited from AutomationStepResult.)
Public property | ResultType | Gets or sets the result type (Pass/fail/notrun) (Inherited from AutomationStepResult.)
Public property | RootName | (Overrides AutomationStepResult..::..RootName.)
Public property | RunTimeStepId | (Inherited from AutomationStepResult.)
Public property | StepDescription | Gets or sets the description of this step. (Inherited from AutomationStepResult.)
Public property | TestId | Gets or sets the test unique Id this step result belongs to. (Inherited from AutomationStepResult.)
Public property | TestName | Gets or sets the test name of this step. (Inherited from AutomationStepResult.)
Public property | TestPath | Gets or sets the test path within the project. (Inherited from AutomationStepResult.)
Public property | TestStepIndex | Gets or sets the step index (Inherited from AutomationStepResult.)
Public property | UserComment | (Inherited from AutomationStepResult.)
Public property | WasStepEnabled | (Inherited from AutomationStepResult.)
Public property | XmlBlob | (Inherited from AutomationStepResult.)

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


BranchTaken Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..BranchTaken Property
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.BranchTaken"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int BranchTaken { get; internal set; }
Visual Basic
Public Property BranchTaken As Integer
    Get
    Friend Set
Visual C++
public:
property int BranchTaken {
    int get ();
    internal: void set (int value);
}

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ChildResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..ChildResult Property
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.ChildResult"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult ChildResult { get; set; }
Visual Basic
Public Property ChildResult As TestResult
    Get
    Set
Visual C++
public:
property TestResult^ ChildResult {
    TestResult^ get ();
    void set (TestResult^ value);
}

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


InnerResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..InnerResult Property
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.InnerResult"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult InnerResult { get; set; }
Visual Basic
Public Property InnerResult As TestResult
    Get
    Set
Visual C++
public:
property TestResult^ InnerResult {
    TestResult^ get ();
    void set (TestResult^ value);
}

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


IsLoop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..IsLoop Property
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.IsLoop"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsLoop { get; set; }
Visual Basic
Public Property IsLoop As Boolean
    Get
    Set
Visual C++
public:
property bool IsLoop {
    bool get ();
    void set (bool value);
}

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LogicDetails Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..LogicDetails Property
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.LogicDetails"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string LogicDetails { get; set; }
Visual Basic
Public Property LogicDetails As String
    Get
    Set
Visual C++
public:
property String^ LogicDetails {
    String^ get ();
    void set (String^ value);
}

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LoopIteration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..LoopIteration Property
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.LoopIteration"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int LoopIteration { get; set; }
Visual Basic
Public Property LoopIteration As Integer
    Get
    Set
Visual C++
public:
property int LoopIteration {
    int get ();
    void set (int value);
}

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


OriginalDescription Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..OriginalDescription Property
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.OriginalDescription"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string OriginalDescription { get; set; }
Visual Basic
Public Property OriginalDescription As String
    Get
    Set
Visual C++
public:
property String^ OriginalDescription {
    String^ get ();
    void set (String^ value);
}

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult..::..RootName Property
LogicalStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.LogicalStepResult.RootName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string RootName { get; }
Visual Basic
Public Overrides ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () override;
}

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LogicalStepResult Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogicalStepResult Events
LogicalStepResult Class See Also Send Feedback

The LogicalStepResult type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from AutomationStepResult.)

See Also

LogicalStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


MainRunResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult Members
MainRunResult Class Constructors Methods Properties See Also Send Feedback

The MainRunResult type exposes the following members.

Constructors

 | Name | Description
Public method | MainRunResult | Initializes a new instance of the MainRunResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndDate |
Public property | Results |
Public property | StartDate |
Public property | TestListName |
Public property | TestLists |

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


MainRunResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult Constructor
MainRunResult Class See Also Send Feedback
Initializes a new instance of the MainRunResult class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MainRunResult()
Visual Basic
Public Sub New
Visual C++
public:
MainRunResult()

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


MainRunResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult Methods
MainRunResult Class See Also Send Feedback

The MainRunResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


MainRunResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult Properties
MainRunResult Class See Also Send Feedback

The MainRunResult type exposes the following members.

Properties

 | Name | Description
Public property | EndDate |
Public property | Results |
Public property | StartDate |
Public property | TestListName |
Public property | TestLists |

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


EndDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult..::..EndDate Property
MainRunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.MainRunResult.EndDate"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic
Public Property EndDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Results Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult..::..Results Property
MainRunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.MainRunResult.Results"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<RunResult> Results { get; set; }
Visual Basic
Public Property Results As List(Of RunResult)
    Get
    Set
Visual C++
public:
property List<RunResult^>^ Results {
    List<RunResult^>^ get ();
    void set (List<RunResult^>^ value);
}

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


StartDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult..::..StartDate Property
MainRunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.MainRunResult.StartDate"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestListName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult..::..TestListName Property
MainRunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.MainRunResult.TestListName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestListName { get; set; }
Visual Basic
Public Property TestListName As String
    Get
    Set
Visual C++
public:
property String^ TestListName {
    String^ get ();
    void set (String^ value);
}

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestLists Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MainRunResult..::..TestLists Property
MainRunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.MainRunResult.TestLists"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<string> TestLists { get; set; }
Visual Basic
Public Property TestLists As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ TestLists {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

MainRunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteManualRunner Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner Members
RemoteManualRunner Class Constructors Methods Fields Properties Events See Also Send Feedback

The RemoteManualRunner type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteManualRunner | Initializes a new instance of the RemoteManualRunner class

Methods

 | Name | Description
Public method | Connect()()()() | (Inherited from RemoteRunner.)
Public method | Connect(Int32) | Connect to the controller (Inherited from RemoteRunner.)
Public method | Disconnect | Disconnect from controller (Inherited from RemoteRunner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeTestRunStarts | (Inherited from RemoteRunner.)
Protected method | OnCommand |
Protected method | OnRunCompleted | (Inherited from RemoteRunner.)
Protected method | OnTestComplete | Called when the test is complete (Inherited from RemoteRunner.)
Protected method | ProcessCommand | (Overrides RemoteRunner..::..ProcessCommand(RemoteRunnerCommand).)
Public method | SendResultsBack |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
REMOTE_MANUALRUNNER_PIPEPREFIX |

Properties

 | Name | Description
Public property | IsListnerAlive | Gets whether the listener thread is alive. (Inherited from RemoteRunner.)

Events

 | Name | Description
Public event | CommandReceived |

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteManualRunner Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner Constructor
RemoteManualRunner Class See Also Send Feedback
Initializes a new instance of the RemoteManualRunner class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RemoteManualRunner()
Visual Basic
Public Sub New
Visual C++
public:
RemoteManualRunner()

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteManualRunner Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner Fields
RemoteManualRunner Class See Also Send Feedback

The RemoteManualRunner type exposes the following members.

Fields

Name | Description
REMOTE_MANUALRUNNER_PIPEPREFIX |

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


REMOTE_MANUALRUNNER_PIPEPREFIX Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner..::..REMOTE_MANUALRUNNER_PIPEPREFIX Field
RemoteManualRunner Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.REMOTE_MANUALRUNNER_PIPEPREFIX"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string REMOTE_MANUALRUNNER_PIPEPREFIX
Visual Basic
Public Const REMOTE_MANUALRUNNER_PIPEPREFIX As String
Visual C++
public:
literal String^ REMOTE_MANUALRUNNER_PIPEPREFIX

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteManualRunner Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner Methods
RemoteManualRunner Class See Also Send Feedback

The RemoteManualRunner type exposes the following members.

Methods

 | Name | Description
Public method | Connect()()()() | (Inherited from RemoteRunner.)
Public method | Connect(Int32) | Connect to the controller (Inherited from RemoteRunner.)
Public method | Disconnect | Disconnect from controller (Inherited from RemoteRunner.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeTestRunStarts | (Inherited from RemoteRunner.)
Protected method | OnCommand |
Protected method | OnRunCompleted | (Inherited from RemoteRunner.)
Protected method | OnTestComplete | Called when the test is complete (Inherited from RemoteRunner.)
Protected method | ProcessCommand | (Overrides RemoteRunner..::..ProcessCommand(RemoteRunnerCommand).)
Public method | SendResultsBack |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


Connect Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner..::..Connect Method
RemoteManualRunner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect()()()() | (Inherited from RemoteRunner.)
Public method | Connect(Int32) | Connect to the controller (Inherited from RemoteRunner.)

See Also

RemoteManualRunner Class
RemoteManualRunner Members
ArtOfTest.WebAii.Design.Execution Namespace


OnCommand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner..::..OnCommand Method
RemoteManualRunner Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.OnCommand(ArtOfTest.WebAii.Design.Execution.RemoteRunnerCommand)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnCommand(
    RemoteRunnerCommand cmd
)
Visual Basic
Protected Sub OnCommand ( _
    cmd As RemoteRunnerCommand _
)
Visual C++
protected:
void OnCommand(
    RemoteRunnerCommand^ cmd
)

Parameters

cmd
Type: ArtOfTest.WebAii.Design.Execution..::..RemoteRunnerCommand

[Missing <param name="cmd"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.OnCommand(ArtOfTest.WebAii.Design.Execution.RemoteRunnerCommand)"]

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


ProcessCommand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner..::..ProcessCommand Method
RemoteManualRunner Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.ProcessCommand(ArtOfTest.WebAii.Design.Execution.RemoteRunnerCommand)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override void ProcessCommand(
    RemoteRunnerCommand cmd
)
Visual Basic
Protected Overrides Sub ProcessCommand ( _
    cmd As RemoteRunnerCommand _
)
Visual C++
protected:
virtual void ProcessCommand(
    RemoteRunnerCommand^ cmd
) override

Parameters

cmd
Type: ArtOfTest.WebAii.Design.Execution..::..RemoteRunnerCommand

[Missing <param name="cmd"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.ProcessCommand(ArtOfTest.WebAii.Design.Execution.RemoteRunnerCommand)"]

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


SendResultsBack Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner..::..SendResultsBack Method
RemoteManualRunner Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.SendResultsBack(ArtOfTest.WebAii.Design.Execution.TestResult,ArtOfTest.Common.Design.Extensibility.TestType)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SendResultsBack(
    TestResult result,
    TestType type
)
Visual Basic
Public Sub SendResultsBack ( _
    result As TestResult, _
    type As TestType _
)
Visual C++
public:
void SendResultsBack(
    TestResult^ result,
    TestType type
)

Parameters

result
Type: ArtOfTest.WebAii.Design.Execution..::..TestResult

[Missing <param name="result"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.SendResultsBack(ArtOfTest.WebAii.Design.Execution.TestResult,ArtOfTest.Common.Design.Extensibility.TestType)"]

type
Type: TestType

[Missing <param name="type"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.SendResultsBack(ArtOfTest.WebAii.Design.Execution.TestResult,ArtOfTest.Common.Design.Extensibility.TestType)"]

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteManualRunner Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner Properties
RemoteManualRunner Class See Also Send Feedback

The RemoteManualRunner type exposes the following members.

Properties

 | Name | Description
Public property | IsListnerAlive | Gets whether the listener thread is alive. (Inherited from RemoteRunner.)

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteManualRunner Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner Events
RemoteManualRunner Class See Also Send Feedback

The RemoteManualRunner type exposes the following members.

Events

 | Name | Description
Public event | CommandReceived |

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


CommandReceived Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteManualRunner..::..CommandReceived Event
RemoteManualRunner Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.Execution.RemoteManualRunner.CommandReceived"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<GenericEventArgs<RemoteRunnerCommand>> CommandReceived
Visual Basic
Public Event CommandReceived As EventHandler(Of GenericEventArgs(Of RemoteRunnerCommand))
Visual C++
public:
 event EventHandler<GenericEventArgs<RemoteRunnerCommand^>^>^ CommandReceived {
    void add (EventHandler<GenericEventArgs<RemoteRunnerCommand^>^>^ value);
    void remove (EventHandler<GenericEventArgs<RemoteRunnerCommand^>^>^ value);
}

See Also

RemoteManualRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunner Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner Members
RemoteRunner Class Constructors Methods Fields Properties See Also Send Feedback

The RemoteRunner type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteRunner()()()() | Create the
Public method | RemoteRunner(String, Boolean) | Initializes a new instance of the RemoteRunner class

Methods

 | Name | Description
Public method | Connect()()()() |
Public method | Connect(Int32) | Connect to the controller
Public method | Disconnect | Disconnect from controller
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeTestRunStarts |
Protected method | OnRunCompleted |
Protected method | OnTestComplete | Called when the test is complete
Protected method | ProcessCommand | Process a command
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CALLBACK_SUFFIX |
REMOTERUNNER_PIPEPREFIX | The remote runner pipe prefix name
REMOTERUNNER_START_TIMEOUT |

Properties

 | Name | Description
Public property | IsListnerAlive | Gets whether the listener thread is alive.

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunner Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner Constructor
RemoteRunner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoteRunner()()()() | Create the
Public method | RemoteRunner(String, Boolean) | Initializes a new instance of the RemoteRunner class

See Also

RemoteRunner Class
RemoteRunner Members
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunner Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner Constructor
RemoteRunner Class See Also Send Feedback
Create the

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RemoteRunner()
Visual Basic
Public Sub New
Visual C++
public:
RemoteRunner()

See Also

RemoteRunner Class
RemoteRunner Overload
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunner Constructor (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner Constructor (String, Boolean)
RemoteRunner Class See Also Send Feedback
Initializes a new instance of the RemoteRunner class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RemoteRunner(
    string pipePrefix,
    bool isConsoleApp
)
Visual Basic
Public Sub New ( _
    pipePrefix As String, _
    isConsoleApp As Boolean _
)
Visual C++
public:
RemoteRunner(
    String^ pipePrefix,
    bool isConsoleApp
)

Parameters

pipePrefix
Type: System..::..String

[Missing <param name="pipePrefix"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.#ctor(System.String,System.Boolean)"]

isConsoleApp
Type: System..::..Boolean

[Missing <param name="isConsoleApp"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.#ctor(System.String,System.Boolean)"]

See Also

RemoteRunner Class
RemoteRunner Overload
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunner Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner Fields
RemoteRunner Class See Also Send Feedback

The RemoteRunner type exposes the following members.

Fields

Name | Description
CALLBACK_SUFFIX |
REMOTERUNNER_PIPEPREFIX | The remote runner pipe prefix name
REMOTERUNNER_START_TIMEOUT |

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


CALLBACK_SUFFIX Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..CALLBACK_SUFFIX Field
RemoteRunner Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.RemoteRunner.CALLBACK_SUFFIX"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string CALLBACK_SUFFIX
Visual Basic
Public Const CALLBACK_SUFFIX As String
Visual C++
public:
literal String^ CALLBACK_SUFFIX

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


REMOTERUNNER_PIPEPREFIX Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..REMOTERUNNER_PIPEPREFIX Field
RemoteRunner Class See Also Send Feedback
The remote runner pipe prefix name

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string REMOTERUNNER_PIPEPREFIX
Visual Basic
Public Const REMOTERUNNER_PIPEPREFIX As String
Visual C++
public:
literal String^ REMOTERUNNER_PIPEPREFIX

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


REMOTERUNNER_START_TIMEOUT Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..REMOTERUNNER_START_TIMEOUT Field
RemoteRunner Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.RemoteRunner.REMOTERUNNER_START_TIMEOUT"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int REMOTERUNNER_START_TIMEOUT
Visual Basic
Public Const REMOTERUNNER_START_TIMEOUT As Integer
Visual C++
public:
literal int REMOTERUNNER_START_TIMEOUT

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunner Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner Methods
RemoteRunner Class See Also Send Feedback

The RemoteRunner type exposes the following members.

Methods

 | Name | Description
Public method | Connect()()()() |
Public method | Connect(Int32) | Connect to the controller
Public method | Disconnect | Disconnect from controller
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeTestRunStarts |
Protected method | OnRunCompleted |
Protected method | OnTestComplete | Called when the test is complete
Protected method | ProcessCommand | Process a command
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


Connect Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..Connect Method
RemoteRunner Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect()()()() |
Public method | Connect(Int32) | Connect to the controller

See Also

RemoteRunner Class
RemoteRunner Members
ArtOfTest.WebAii.Design.Execution Namespace


Connect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..Connect Method
RemoteRunner Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.Connect"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Connect()
Visual Basic
Public Sub Connect
Visual C++
public:
void Connect()

See Also

RemoteRunner Class
Connect Overload
ArtOfTest.WebAii.Design.Execution Namespace


Connect Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..Connect Method (Int32)
RemoteRunner Class See Also Send Feedback
Connect to the controller

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Connect(
    int timeout
)
Visual Basic
Public Sub Connect ( _
    timeout As Integer _
)
Visual C++
public:
void Connect(
    int timeout
)

Parameters

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.Connect(System.Int32)"]

See Also

RemoteRunner Class
Connect Overload
ArtOfTest.WebAii.Design.Execution Namespace


Disconnect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..Disconnect Method
RemoteRunner Class See Also Send Feedback
Disconnect from controller

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Disconnect()
Visual Basic
Public Sub Disconnect
Visual C++
public:
void Disconnect()

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


OnBeforeTestRunStarts Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..OnBeforeTestRunStarts Method
RemoteRunner Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.OnBeforeTestRunStarts(ArtOfTest.WebAii.Design.Execution.RunTestArgs)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnBeforeTestRunStarts(
    RunTestArgs args
)
Visual Basic
Protected Sub OnBeforeTestRunStarts ( _
    args As RunTestArgs _
)
Visual C++
protected:
void OnBeforeTestRunStarts(
    RunTestArgs^ args
)

Parameters

args
Type: ArtOfTest.WebAii.Design.Execution..::..RunTestArgs

[Missing <param name="args"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.OnBeforeTestRunStarts(ArtOfTest.WebAii.Design.Execution.RunTestArgs)"]

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


OnRunCompleted Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..OnRunCompleted Method
RemoteRunner Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.OnRunCompleted(System.EventArgs)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnRunCompleted(
    EventArgs args
)
Visual Basic
Protected Sub OnRunCompleted ( _
    args As EventArgs _
)
Visual C++
protected:
void OnRunCompleted(
    EventArgs^ args
)

Parameters

args
Type: System..::..EventArgs

[Missing <param name="args"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.OnRunCompleted(System.EventArgs)"]

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


OnTestComplete Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..OnTestComplete Method
RemoteRunner Class See Also Send Feedback
Called when the test is complete

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnTestComplete(
    ExecutionReturnValues retValues,
    bool displayResults
)
Visual Basic
Protected Sub OnTestComplete ( _
    retValues As ExecutionReturnValues, _
    displayResults As Boolean _
)
Visual C++
protected:
void OnTestComplete(
    ExecutionReturnValues^ retValues,
    bool displayResults
)

Parameters

retValues
Type: ArtOfTest.WebAii.Design.Execution..::..ExecutionReturnValues

[Missing <param name="retValues"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.OnTestComplete(ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues,System.Boolean)"]

displayResults
Type: System..::..Boolean

[Missing <param name="displayResults"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.OnTestComplete(ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues,System.Boolean)"]

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


ProcessCommand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..ProcessCommand Method
RemoteRunner Class See Also Send Feedback
Process a command

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void ProcessCommand(
    RemoteRunnerCommand cmd
)
Visual Basic
Protected Overridable Sub ProcessCommand ( _
    cmd As RemoteRunnerCommand _
)
Visual C++
protected:
virtual void ProcessCommand(
    RemoteRunnerCommand^ cmd
)

Parameters

cmd
Type: ArtOfTest.WebAii.Design.Execution..::..RemoteRunnerCommand

[Missing <param name="cmd"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunner.ProcessCommand(ArtOfTest.WebAii.Design.Execution.RemoteRunnerCommand)"]

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunner Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner Properties
RemoteRunner Class See Also Send Feedback

The RemoteRunner type exposes the following members.

Properties

 | Name | Description
Public property | IsListnerAlive | Gets whether the listener thread is alive.

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


IsListnerAlive Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunner..::..IsListnerAlive Property
RemoteRunner Class See Also Send Feedback
Gets whether the listener thread is alive.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsListnerAlive { get; }
Visual Basic
Public ReadOnly Property IsListnerAlive As Boolean
    Get
Visual C++
public:
property bool IsListnerAlive {
    bool get ();
}

See Also

RemoteRunner Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunnerCommand Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunnerCommand Members
RemoteRunnerCommand Class Constructors Methods Properties See Also Send Feedback

The RemoteRunnerCommand type exposes the following members.

Constructors

 | Name | Description
Public method | RemoteRunnerCommand | Initializes a new instance of the RemoteRunnerCommand class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Command |

See Also

RemoteRunnerCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunnerCommand Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunnerCommand Constructor
RemoteRunnerCommand Class See Also Send Feedback
Initializes a new instance of the RemoteRunnerCommand class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RemoteRunnerCommand(
    RemoteCommands command
)
Visual Basic
Public Sub New ( _
    command As RemoteCommands _
)
Visual C++
public:
RemoteRunnerCommand(
    RemoteCommands command
)

Parameters

command
Type: ArtOfTest.WebAii.Design.Execution..::..RemoteCommands

[Missing <param name="command"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RemoteRunnerCommand.#ctor(ArtOfTest.WebAii.Design.Execution.RemoteCommands)"]

See Also

RemoteRunnerCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunnerCommand Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunnerCommand Methods
RemoteRunnerCommand Class See Also Send Feedback

The RemoteRunnerCommand type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoteRunnerCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoteRunnerCommand Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunnerCommand Properties
RemoteRunnerCommand Class See Also Send Feedback

The RemoteRunnerCommand type exposes the following members.

Properties

 | Name | Description
Public property | Command |

See Also

RemoteRunnerCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


Command Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RemoteRunnerCommand..::..Command Property
RemoteRunnerCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RemoteRunnerCommand.Command"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RemoteCommands Command { get; }
Visual Basic
Public ReadOnly Property Command As RemoteCommands
    Get
Visual C++
public:
property RemoteCommands Command {
    RemoteCommands get ();
}

See Also

RemoteRunnerCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultsReadyCommand Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultsReadyCommand Members
ResultsReadyCommand Class Constructors Methods Properties See Also Send Feedback

The ResultsReadyCommand type exposes the following members.

Constructors

 | Name | Description
Public method | ResultsReadyCommand | Initializes a new instance of the ResultsReadyCommand class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Command | (Inherited from RemoteRunnerCommand.)
Public property | Result |

See Also

ResultsReadyCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultsReadyCommand Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultsReadyCommand Constructor
ResultsReadyCommand Class See Also Send Feedback
Initializes a new instance of the ResultsReadyCommand class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ResultsReadyCommand(
    ExecutionReturnValues result
)
Visual Basic
Public Sub New ( _
    result As ExecutionReturnValues _
)
Visual C++
public:
ResultsReadyCommand(
    ExecutionReturnValues^ result
)

Parameters

result
Type: ArtOfTest.WebAii.Design.Execution..::..ExecutionReturnValues

[Missing <param name="result"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ResultsReadyCommand.#ctor(ArtOfTest.WebAii.Design.Execution.ExecutionReturnValues)"]

See Also

ResultsReadyCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultsReadyCommand Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultsReadyCommand Methods
ResultsReadyCommand Class See Also Send Feedback

The ResultsReadyCommand type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResultsReadyCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultsReadyCommand Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultsReadyCommand Properties
ResultsReadyCommand Class See Also Send Feedback

The ResultsReadyCommand type exposes the following members.

Properties

 | Name | Description
Public property | Command | (Inherited from RemoteRunnerCommand.)
Public property | Result |

See Also

ResultsReadyCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


Result Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultsReadyCommand..::..Result Property
ResultsReadyCommand Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.ResultsReadyCommand.Result"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecutionReturnValues Result { get; }
Visual Basic
Public ReadOnly Property Result As ExecutionReturnValues
    Get
Visual C++
public:
property ExecutionReturnValues^ Result {
    ExecutionReturnValues^ get ();
}

See Also

ResultsReadyCommand Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultSummary Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary Members
ResultSummary Class Constructors Methods Fields See Also Send Feedback

The ResultSummary type exposes the following members.

Constructors

 | Name | Description
Public method | ResultSummary(String) | Initializes a new instance of the ResultSummary class
Public method | ResultSummary(XmlDocument, String) | Initializes a new instance of the ResultSummary class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | InError | Whether there was an expected error during execution.
Public field | Passed | Whether the test Passed or not.
Public field | RawOutput | Raw output of the execution
Public field | Result | The full detailed results for each test executed. This results will not be set if test was run using Run.TestUsingMsTest().
Public field | VSResult | The Visual Studio result file. (.trx file). This is what Visual Studio generates. This will be set only if test was run using Run.TestUsingMsTest()

See Also

ResultSummary Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultSummary Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary Constructor
ResultSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResultSummary(String) | Initializes a new instance of the ResultSummary class
Public method | ResultSummary(XmlDocument, String) | Initializes a new instance of the ResultSummary class

See Also

ResultSummary Class
ResultSummary Members
ArtOfTest.WebAii.Design.Execution Namespace


ResultSummary Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary Constructor (String)
ResultSummary Class See Also Send Feedback
Initializes a new instance of the ResultSummary class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ResultSummary(
    string error
)
Visual Basic
Public Sub New ( _
    error As String _
)
Visual C++
public:
ResultSummary(
    String^ error
)

Parameters

error
Type: System..::..String

[Missing <param name="error"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ResultSummary.#ctor(System.String)"]

See Also

ResultSummary Class
ResultSummary Overload
ArtOfTest.WebAii.Design.Execution Namespace


ResultSummary Constructor (XmlDocument, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary Constructor (XmlDocument, String)
ResultSummary Class See Also Send Feedback
Initializes a new instance of the ResultSummary class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ResultSummary(
    XmlDocument vsResult,
    string rawOutput
)
Visual Basic
Public Sub New ( _
    vsResult As XmlDocument, _
    rawOutput As String _
)
Visual C++
public:
ResultSummary(
    XmlDocument^ vsResult,
    String^ rawOutput
)

Parameters

vsResult
Type: System.Xml..::..XmlDocument

[Missing <param name="vsResult"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ResultSummary.#ctor(System.Xml.XmlDocument,System.String)"]

rawOutput
Type: System..::..String

[Missing <param name="rawOutput"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.ResultSummary.#ctor(System.Xml.XmlDocument,System.String)"]

See Also

ResultSummary Class
ResultSummary Overload
ArtOfTest.WebAii.Design.Execution Namespace


ResultSummary Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary Fields
ResultSummary Class See Also Send Feedback

The ResultSummary type exposes the following members.

Fields

 | Name | Description
Public field | InError | Whether there was an expected error during execution.
Public field | Passed | Whether the test Passed or not.
Public field | RawOutput | Raw output of the execution
Public field | Result | The full detailed results for each test executed. This results will not be set if test was run using Run.TestUsingMsTest().
Public field | VSResult | The Visual Studio result file. (.trx file). This is what Visual Studio generates. This will be set only if test was run using Run.TestUsingMsTest()

See Also

ResultSummary Class
ArtOfTest.WebAii.Design.Execution Namespace


InError Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary..::..InError Field
ResultSummary Class See Also Send Feedback
Whether there was an expected error during execution.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool InError
Visual Basic
Public InError As Boolean
Visual C++
public:
bool InError

See Also

ResultSummary Class
ArtOfTest.WebAii.Design.Execution Namespace


Passed Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary..::..Passed Field
ResultSummary Class See Also Send Feedback
Whether the test Passed or not.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Passed
Visual Basic
Public Passed As Boolean
Visual C++
public:
bool Passed

See Also

ResultSummary Class
ArtOfTest.WebAii.Design.Execution Namespace


RawOutput Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary..::..RawOutput Field
ResultSummary Class See Also Send Feedback
Raw output of the execution

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RawOutput
Visual Basic
Public RawOutput As String
Visual C++
public:
String^ RawOutput

See Also

ResultSummary Class
ArtOfTest.WebAii.Design.Execution Namespace


Result Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary..::..Result Field
ResultSummary Class See Also Send Feedback
The full detailed results for each test executed. This results will not be set if test was run using Run.TestUsingMsTest().

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult Result
Visual Basic
Public Result As TestResult
Visual C++
public:
TestResult^ Result

See Also

ResultSummary Class
ArtOfTest.WebAii.Design.Execution Namespace


VSResult Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary..::..VSResult Field
ResultSummary Class See Also Send Feedback
The Visual Studio result file. (.trx file). This is what Visual Studio generates. This will be set only if test was run using Run.TestUsingMsTest()

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlDocument VSResult
Visual Basic
Public VSResult As XmlDocument
Visual C++
public:
XmlDocument^ VSResult

See Also

ResultSummary Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultSummary Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResultSummary Methods
ResultSummary Class See Also Send Feedback

The ResultSummary type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResultSummary Class
ArtOfTest.WebAii.Design.Execution Namespace


RunHelper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunHelper Members
RunHelper Class Methods See Also Send Feedback

The RunHelper type exposes the following members.

Methods

Name | Description
Test(String, String) | Execute a .aii test file
Test(String, Settings, String) | Execute a .aii test file
TestUsingMsTest | Execute a specific .aii test.

See Also

RunHelper Class
ArtOfTest.WebAii.Design.Execution Namespace


RunHelper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunHelper Methods
RunHelper Class See Also Send Feedback

The RunHelper type exposes the following members.

Methods

Name | Description
Test(String, String) | Execute a .aii test file
Test(String, Settings, String) | Execute a .aii test file
TestUsingMsTest | Execute a specific .aii test.

See Also

RunHelper Class
ArtOfTest.WebAii.Design.Execution Namespace


Test Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunHelper..::..Test Method
RunHelper Class See Also Send Feedback

Overload List

Name | Description
Test(String, String) | Execute a .aii test file
Test(String, Settings, String) | Execute a .aii test file

See Also

RunHelper Class
RunHelper Members
ArtOfTest.WebAii.Design.Execution Namespace


Test Method (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunHelper..::..Test Method (String, String)
RunHelper Class See Also Send Feedback
Execute a .aii test file

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ResultSummary Test(
    string fullTestPath,
    string fullPathToBinary
)
Visual Basic
Public Shared Function Test ( _
    fullTestPath As String, _
    fullPathToBinary As String _
) As ResultSummary
Visual C++
public:
static ResultSummary^ Test(
    String^ fullTestPath,
    String^ fullPathToBinary
)

Parameters

fullTestPath
Type: System..::..String
The full path to the .aii file
fullPathToBinary
Type: System..::..String
The full path to the test binaries that contain the code behind for the test.

Return Value

The results of execution

See Also

RunHelper Class
Test Overload
ArtOfTest.WebAii.Design.Execution Namespace


Test Method (String, Settings, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunHelper..::..Test Method (String, Settings, String)
RunHelper Class See Also Send Feedback
Execute a .aii test file

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ResultSummary Test(
    string fullTestPath,
    Settings settingsToUse,
    string fullPathToBinary
)
Visual Basic
Public Shared Function Test ( _
    fullTestPath As String, _
    settingsToUse As Settings, _
    fullPathToBinary As String _
) As ResultSummary
Visual C++
public:
static ResultSummary^ Test(
    String^ fullTestPath,
    Settings^ settingsToUse,
    String^ fullPathToBinary
)

Parameters

fullTestPath
Type: System..::..String
The full path to the .aii file
settingsToUse
Type: ArtOfTest.WebAii.Core..::..Settings
The settings to use for this test.
fullPathToBinary
Type: System..::..String
The full path to the test binaries that contain the code behind for the test.

Return Value

The results of execution

See Also

RunHelper Class
Test Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestUsingMsTest Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunHelper..::..TestUsingMsTest Method
RunHelper Class See Also Send Feedback
Execute a specific .aii test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ResultSummary TestUsingMsTest(
    string fullTestPath
)
Visual Basic
Public Shared Function TestUsingMsTest ( _
    fullTestPath As String _
) As ResultSummary
Visual C++
public:
static ResultSummary^ TestUsingMsTest(
    String^ fullTestPath
)

Parameters

fullTestPath
Type: System..::..String
The full path to the .aii test file. (i.e. c:\myprojects\testing\projec1\webaiitest1.aii)

Return Value

A ResultSummary object that contains the execution result of this test. If ResultSummary.InError is true, the there was an unexpected failure during execution. RawOutput should contain failure information.

See Also

RunHelper Class
ArtOfTest.WebAii.Design.Execution Namespace


RunResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult Members
RunResult Class Constructors Methods Fields Properties See Also Send Feedback

The RunResult type exposes the following members.

Constructors

 | Name | Description
Public method | RunResult()()()() | Empty constructor for serialization.
Public method | RunResult(String) | Initializes a new instance of the RunResult object passing the name of the test list.

Methods

 | Name | Description
 | DeleteResources | Delete run result resources from disk if present.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResultSummary | Call when the RunResult object is completed (e.g. all test results are added).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
 | LoadFromFile | Loads the RunResult object from the file with given path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserialized |
Protected method | OnSerializing |
Public method | SaveTo |
Public method | SaveToResultFile(String) | Create the result file from the current run result object.
Public method | SaveToResultFile(String, Boolean) |
Public method | SaveToResultFile(String, Boolean, Boolean) |
Public method | SaveToResultFile(String, Boolean, Boolean, Boolean) | Create the result file from the current run result object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
RESULT_FILE_EXTENSION |
RESULTS_FOLDER_NAME |

Properties

 | Name | Description
Public property | AllCount |
Public property | Comment |
Public property | CurrentVersion |
Public property | DataCollectors | Gets the data collectors info associated with the run result.
Public property | EndDate | Obsolete. Gets and sets the run end date.
Public property | EndTime | Gets and sets the run end time.
Public property | FailedCount |
Public property | FailedPercent |
Public property | FileName | Gets or sets the friendly name of the result. The default value is generated by the id and the start date.
Public property | Id | Gets or sets the data base id. used by the WCF service to match the RunResult with its DB counterpart
Public property | IsManual |
Public property | Machine |
Public property | Name | Gets or sets the name of the run result. The setter generates the name of the XML file to persist the data into.
Public property | NotRunCount |
Public property | PassedCount | The count of the passed test results.
Public property | PassedPercent |
Public property | PassedResult | Gets whether all test results passed.
Public property | ReportingProivderKey |
Public property | RootName |
Public property | RunId | Gets or sets the data base id. used by the WCF service to match the RunResult with its DB counterpart
Protected property | SerializedString | Gets or sets the serialized string used in WCF services.
Public property | StartTime | Gets the run start time.
Public property | Summary | Gets a brief summary of the run result.
Public property | TestListId |
Public property | TestResults | Gets the list of test results associated with the run result.
Public property | XmlBlob |

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RunResult Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult Constructor
RunResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RunResult()()()() | Empty constructor for serialization.
Public method | RunResult(String) | Initializes a new instance of the RunResult object passing the name of the test list.

See Also

RunResult Class
RunResult Members
ArtOfTest.WebAii.Design.Execution Namespace


RunResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult Constructor
RunResult Class See Also Send Feedback
Empty constructor for serialization.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RunResult()
Visual Basic
Public Sub New
Visual C++
public:
RunResult()

See Also

RunResult Class
RunResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


RunResult Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult Constructor (String)
RunResult Class See Also Send Feedback
Initializes a new instance of the RunResult object passing the name of the test list.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RunResult(
    string listName
)
Visual Basic
Public Sub New ( _
    listName As String _
)
Visual C++
public:
RunResult(
    String^ listName
)

Parameters

listName
Type: System..::..String
The name of the test list generated this result.

See Also

RunResult Class
RunResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


RunResult Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult Fields
RunResult Class See Also Send Feedback

The RunResult type exposes the following members.

Fields

Name | Description
RESULT_FILE_EXTENSION |
RESULTS_FOLDER_NAME |

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RESULT_FILE_EXTENSION Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..RESULT_FILE_EXTENSION Field
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.RunResult.RESULT_FILE_EXTENSION"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string RESULT_FILE_EXTENSION
Visual Basic
Public Const RESULT_FILE_EXTENSION As String
Visual C++
public:
literal String^ RESULT_FILE_EXTENSION

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RESULTS_FOLDER_NAME Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..RESULTS_FOLDER_NAME Field
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.RunResult.RESULTS_FOLDER_NAME"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string RESULTS_FOLDER_NAME
Visual Basic
Public Const RESULTS_FOLDER_NAME As String
Visual C++
public:
literal String^ RESULTS_FOLDER_NAME

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RunResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult Methods
RunResult Class See Also Send Feedback

The RunResult type exposes the following members.

Methods

 | Name | Description
 | DeleteResources | Delete run result resources from disk if present.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateResultSummary | Call when the RunResult object is completed (e.g. all test results are added).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
 | LoadFromFile | Loads the RunResult object from the file with given path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserialized |
Protected method | OnSerializing |
Public method | SaveTo |
Public method | SaveToResultFile(String) | Create the result file from the current run result object.
Public method | SaveToResultFile(String, Boolean) |
Public method | SaveToResultFile(String, Boolean, Boolean) |
Public method | SaveToResultFile(String, Boolean, Boolean, Boolean) | Create the result file from the current run result object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


DeleteResources Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..DeleteResources Method
RunResult Class See Also Send Feedback
Delete run result resources from disk if present.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool DeleteResources(
    string resultFilePath,
    out string error
)
Visual Basic
Public Shared Function DeleteResources ( _
    resultFilePath As String, _
    <OutAttribute> ByRef error As String _
) As Boolean
Visual C++
public:
static bool DeleteResources(
    String^ resultFilePath,
    [OutAttribute] String^% error
)

Parameters

resultFilePath
Type: System..::..String
The run result file path.
error
Type: System..::..String %

[Missing <param name="error"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.DeleteResources(System.String,System.String@)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.DeleteResources(System.String,System.String@)"]

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


GenerateResultSummary Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..GenerateResultSummary Method
RunResult Class See Also Send Feedback
Call when the RunResult object is completed (e.g. all test results are added).

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GenerateResultSummary()
Visual Basic
Public Function GenerateResultSummary As String
Visual C++
public:
String^ GenerateResultSummary()

Return Value

The summary of the run result.

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..LoadFrom Method
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFromFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..LoadFromFile Method
RunResult Class See Also Send Feedback
Loads the RunResult object from the file with given path.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static RunResult LoadFromFile(
    string aiiResultFilePath
)
Visual Basic
Public Shared Function LoadFromFile ( _
    aiiResultFilePath As String _
) As RunResult
Visual C++
public:
static RunResult^ LoadFromFile(
    String^ aiiResultFilePath
)

Parameters

aiiResultFilePath
Type: System..::..String
The full path to the file.

Return Value

The run result saved in that file.

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


OnDeserialized Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..OnDeserialized Method
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.OnDeserialized(System.Runtime.Serialization.StreamingContext)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnDeserialized(
    StreamingContext context
)
Visual Basic
Protected Sub OnDeserialized ( _
    context As StreamingContext _
)
Visual C++
protected:
void OnDeserialized(
    StreamingContext context
)

Parameters

context
Type: System.Runtime.Serialization..::..StreamingContext

[Missing <param name="context"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.OnDeserialized(System.Runtime.Serialization.StreamingContext)"]

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


OnSerializing Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..OnSerializing Method
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.OnSerializing(System.Runtime.Serialization.StreamingContext)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void OnSerializing(
    StreamingContext context
)
Visual Basic
Protected Sub OnSerializing ( _
    context As StreamingContext _
)
Visual C++
protected:
void OnSerializing(
    StreamingContext context
)

Parameters

context
Type: System.Runtime.Serialization..::..StreamingContext

[Missing <param name="context"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.OnSerializing(System.Runtime.Serialization.StreamingContext)"]

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..SaveTo Method
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveToResultFile Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..SaveToResultFile Method
RunResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveToResultFile(String) | Create the result file from the current run result object.
Public method | SaveToResultFile(String, Boolean) |
Public method | SaveToResultFile(String, Boolean, Boolean) |
Public method | SaveToResultFile(String, Boolean, Boolean, Boolean) | Create the result file from the current run result object.

See Also

RunResult Class
RunResult Members
ArtOfTest.WebAii.Design.Execution Namespace


SaveToResultFile Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..SaveToResultFile Method (String)
RunResult Class See Also Send Feedback
Create the result file from the current run result object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SaveToResultFile(
    string outputPath
)
Visual Basic
Public Function SaveToResultFile ( _
    outputPath As String _
) As String
Visual C++
public:
String^ SaveToResultFile(
    String^ outputPath
)

Parameters

outputPath
Type: System..::..String
The output path.

Return Value

The full path of the result file.

See Also

RunResult Class
SaveToResultFile Overload
ArtOfTest.WebAii.Design.Execution Namespace


SaveToResultFile Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..SaveToResultFile Method (String, Boolean)
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SaveToResultFile(
    string outputPath,
    bool skipResultsFolder
)
Visual Basic
Public Function SaveToResultFile ( _
    outputPath As String, _
    skipResultsFolder As Boolean _
) As String
Visual C++
public:
String^ SaveToResultFile(
    String^ outputPath,
    bool skipResultsFolder
)

Parameters

outputPath
Type: System..::..String

[Missing <param name="outputPath"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean)"]

skipResultsFolder
Type: System..::..Boolean

[Missing <param name="skipResultsFolder"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean)"]

See Also

RunResult Class
SaveToResultFile Overload
ArtOfTest.WebAii.Design.Execution Namespace


SaveToResultFile Method (String, Boolean, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..SaveToResultFile Method (String, Boolean, Boolean)
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SaveToResultFile(
    string outputPath,
    bool skipResultsFolder,
    bool persistFailureResources
)
Visual Basic
Public Function SaveToResultFile ( _
    outputPath As String, _
    skipResultsFolder As Boolean, _
    persistFailureResources As Boolean _
) As String
Visual C++
public:
String^ SaveToResultFile(
    String^ outputPath,
    bool skipResultsFolder,
    bool persistFailureResources
)

Parameters

outputPath
Type: System..::..String

[Missing <param name="outputPath"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean,System.Boolean)"]

skipResultsFolder
Type: System..::..Boolean

[Missing <param name="skipResultsFolder"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean,System.Boolean)"]

persistFailureResources
Type: System..::..Boolean

[Missing <param name="persistFailureResources"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean,System.Boolean)"]

See Also

RunResult Class
SaveToResultFile Overload
ArtOfTest.WebAii.Design.Execution Namespace


SaveToResultFile Method (String, Boolean, Boolean, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..SaveToResultFile Method (String, Boolean, Boolean, Boolean)
RunResult Class See Also Send Feedback
Create the result file from the current run result object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SaveToResultFile(
    string outputPath,
    bool skipResultsFolder,
    bool persistFailureResources,
    bool overrideFile
)
Visual Basic
Public Function SaveToResultFile ( _
    outputPath As String, _
    skipResultsFolder As Boolean, _
    persistFailureResources As Boolean, _
    overrideFile As Boolean _
) As String
Visual C++
public:
String^ SaveToResultFile(
    String^ outputPath,
    bool skipResultsFolder,
    bool persistFailureResources,
    bool overrideFile
)

Parameters

outputPath
Type: System..::..String
The output path.
skipResultsFolder
Type: System..::..Boolean
Whether to skip appending the results folder to the given output path.
persistFailureResources
Type: System..::..Boolean

[Missing <param name="persistFailureResources"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean,System.Boolean,System.Boolean)"]

overrideFile
Type: System..::..Boolean

[Missing <param name="overrideFile"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResult.SaveToResultFile(System.String,System.Boolean,System.Boolean,System.Boolean)"]

Return Value

The full path of the result file.

See Also

RunResult Class
SaveToResultFile Overload
ArtOfTest.WebAii.Design.Execution Namespace


RunResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult Properties
RunResult Class See Also Send Feedback

The RunResult type exposes the following members.

Properties

 | Name | Description
Public property | AllCount |
Public property | Comment |
Public property | CurrentVersion |
Public property | DataCollectors | Gets the data collectors info associated with the run result.
Public property | EndDate | Obsolete. Gets and sets the run end date.
Public property | EndTime | Gets and sets the run end time.
Public property | FailedCount |
Public property | FailedPercent |
Public property | FileName | Gets or sets the friendly name of the result. The default value is generated by the id and the start date.
Public property | Id | Gets or sets the data base id. used by the WCF service to match the RunResult with its DB counterpart
Public property | IsManual |
Public property | Machine |
Public property | Name | Gets or sets the name of the run result. The setter generates the name of the XML file to persist the data into.
Public property | NotRunCount |
Public property | PassedCount | The count of the passed test results.
Public property | PassedPercent |
Public property | PassedResult | Gets whether all test results passed.
Public property | ReportingProivderKey |
Public property | RootName |
Public property | RunId | Gets or sets the data base id. used by the WCF service to match the RunResult with its DB counterpart
Protected property | SerializedString | Gets or sets the serialized string used in WCF services.
Public property | StartTime | Gets the run start time.
Public property | Summary | Gets a brief summary of the run result.
Public property | TestListId |
Public property | TestResults | Gets the list of test results associated with the run result.
Public property | XmlBlob |

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


AllCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..AllCount Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.AllCount"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AllCount { get; }
Visual Basic
Public ReadOnly Property AllCount As Integer
    Get
Visual C++
public:
property int AllCount {
    int get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Comment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..Comment Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.Comment"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Comment { get; set; }
Visual Basic
Public Property Comment As String
    Get
    Set
Visual C++
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..CurrentVersion Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


DataCollectors Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..DataCollectors Property
RunResult Class See Also Send Feedback
Gets the data collectors info associated with the run result.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<string, string> DataCollectors { get; }
Visual Basic
Public ReadOnly Property DataCollectors As Dictionary(Of String, String)
    Get
Visual C++
public:
property Dictionary<String^, String^>^ DataCollectors {
    Dictionary<String^, String^>^ get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


EndDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..EndDate Property
RunResult Class See Also Send Feedback
Gets and sets the run end date.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Please use EndTime instead.")]
public DateTime EndDate { get; }
Visual Basic
<ObsoleteAttribute("Please use EndTime instead.")> _
Public ReadOnly Property EndDate As DateTime
    Get
Visual C++
[ObsoleteAttribute(L"Please use EndTime instead.")]
public:
property DateTime EndDate {
    DateTime get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


EndTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..EndTime Property
RunResult Class See Also Send Feedback
Gets and sets the run end time.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime EndTime { get; internal set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Friend Set
Visual C++
public:
property DateTime EndTime {
    DateTime get ();
    internal: void set (DateTime value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


FailedCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..FailedCount Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.FailedCount"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int FailedCount { get; }
Visual Basic
Public ReadOnly Property FailedCount As Integer
    Get
Visual C++
public:
property int FailedCount {
    int get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


FailedPercent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..FailedPercent Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.FailedPercent"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int FailedPercent { get; }
Visual Basic
Public ReadOnly Property FailedPercent As Integer
    Get
Visual C++
public:
property int FailedPercent {
    int get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


FileName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..FileName Property
RunResult Class See Also Send Feedback
Gets or sets the friendly name of the result. The default value is generated by the id and the start date.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Id Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..Id Property
RunResult Class See Also Send Feedback
Gets or sets the data base id. used by the WCF service to match the RunResult with its DB counterpart

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid Id { get; set; }
Visual Basic
Public Property Id As Guid
    Get
    Set
Visual C++
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}

Field Value

The id.

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


IsManual Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..IsManual Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.IsManual"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsManual { get; set; }
Visual Basic
Public Property IsManual As Boolean
    Get
    Set
Visual C++
public:
property bool IsManual {
    bool get ();
    void set (bool value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Machine Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..Machine Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.Machine"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Machine Machine { get; set; }
Visual Basic
Public Property Machine As Machine
    Get
    Set
Visual C++
public:
property Machine^ Machine {
    Machine^ get ();
    void set (Machine^ value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..Name Property
RunResult Class See Also Send Feedback
Gets or sets the name of the run result. The setter generates the name of the XML file to persist the data into.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; internal set; }
Visual Basic
Public Property Name As String
    Get
    Friend Set
Visual C++
public:
property String^ Name {
    String^ get ();
    internal: void set (String^ value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


NotRunCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..NotRunCount Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.NotRunCount"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int NotRunCount { get; }
Visual Basic
Public ReadOnly Property NotRunCount As Integer
    Get
Visual C++
public:
property int NotRunCount {
    int get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


PassedCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..PassedCount Property
RunResult Class See Also Send Feedback
The count of the passed test results.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PassedCount { get; }
Visual Basic
Public ReadOnly Property PassedCount As Integer
    Get
Visual C++
public:
property int PassedCount {
    int get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


PassedPercent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..PassedPercent Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.PassedPercent"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double PassedPercent { get; }
Visual Basic
Public ReadOnly Property PassedPercent As Double
    Get
Visual C++
public:
property double PassedPercent {
    double get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


PassedResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..PassedResult Property
RunResult Class See Also Send Feedback
Gets whether all test results passed.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool PassedResult { get; }
Visual Basic
Public ReadOnly Property PassedResult As Boolean
    Get
Visual C++
public:
property bool PassedResult {
    bool get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ReportingProivderKey Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..ReportingProivderKey Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.ReportingProivderKey"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ReportingProivderKey { get; set; }
Visual Basic
Public Property ReportingProivderKey As String
    Get
    Set
Visual C++
public:
property String^ ReportingProivderKey {
    String^ get ();
    void set (String^ value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..RootName Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.RootName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RunId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..RunId Property
RunResult Class See Also Send Feedback
Gets or sets the data base id. used by the WCF service to match the RunResult with its DB counterpart

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid RunId { get; set; }
Visual Basic
Public Property RunId As Guid
    Get
    Set
Visual C++
public:
property Guid RunId {
    Guid get ();
    void set (Guid value);
}

Field Value

The RunId.

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SerializedString Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..SerializedString Property
RunResult Class See Also Send Feedback
Gets or sets the serialized string used in WCF services.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected string SerializedString { get; private set; }
Visual Basic
Protected Property SerializedString As String
    Get
    Private Set
Visual C++
protected:
property String^ SerializedString {
    String^ get ();
    private: void set (String^ value);
}

Field Value

The serialized string.

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


StartTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..StartTime Property
RunResult Class See Also Send Feedback
Gets the run start time.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime StartTime { get; internal set; }
Visual Basic
Public Property StartTime As DateTime
    Get
    Friend Set
Visual C++
public:
property DateTime StartTime {
    DateTime get ();
    internal: void set (DateTime value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Summary Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..Summary Property
RunResult Class See Also Send Feedback
Gets a brief summary of the run result.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Summary { get; }
Visual Basic
Public ReadOnly Property Summary As String
    Get
Visual C++
public:
property String^ Summary {
    String^ get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestListId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..TestListId Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.TestListId"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid TestListId { get; set; }
Visual Basic
Public Property TestListId As Guid
    Get
    Set
Visual C++
public:
property Guid TestListId {
    Guid get ();
    void set (Guid value);
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResults Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..TestResults Property
RunResult Class See Also Send Feedback
Gets the list of test results associated with the run result.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<TestResult> TestResults { get; }
Visual Basic
Public ReadOnly Property TestResults As List(Of TestResult)
    Get
Visual C++
public:
property List<TestResult^>^ TestResults {
    List<TestResult^>^ get ();
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResult..::..XmlBlob Property
RunResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunResult.XmlBlob"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

RunResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RunResultsCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection Members
RunResultsCollection Class Constructors Methods Properties See Also Send Feedback

The RunResultsCollection type exposes the following members.

Constructors

 | Name | Description
Public method | RunResultsCollection | Initializes the run results collection with a list of run results.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' RunResult >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectList | (Overrides FilteredCollection<(Of <(<'T>)>)>..::..GetObjectList(Filter).)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | GetRunResultsBetween | Retrieves the list of run results started and completed between the start and end time arguments.
Public method | GetRunResultsStartedBetween | Retrieves the list of run results started between the start and end time arguments.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' RunResult >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


RunResultsCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection Constructor
RunResultsCollection Class See Also Send Feedback
Initializes the run results collection with a list of run results.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RunResultsCollection(
    List<RunResult> results
)
Visual Basic
Public Sub New ( _
    results As List(Of RunResult) _
)
Visual C++
public:
RunResultsCollection(
    List<RunResult^>^ results
)

Parameters

results
Type: System.Collections.Generic..::..List <(Of <(<' RunResult >)>)>
The run result list to initialize the collection with.

See Also

RunResultsCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


RunResultsCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection Methods
RunResultsCollection Class See Also Send Feedback

The RunResultsCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' RunResult >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectList | (Overrides FilteredCollection<(Of <(<'T>)>)>..::..GetObjectList(Filter).)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | GetRunResultsBetween | Retrieves the list of run results started and completed between the start and end time arguments.
Public method | GetRunResultsStartedBetween | Retrieves the list of run results started between the start and end time arguments.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


BinarySearch Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..BinarySearch Method
RunResultsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
RunResultsCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


CopyTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..CopyTo Method
RunResultsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
RunResultsCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


FindIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..FindIndex Method
RunResultsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
RunResultsCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


FindLastIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..FindLastIndex Method
RunResultsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
RunResultsCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


GetObjectList Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..GetObjectList Method
RunResultsCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResultsCollection.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override List<RunResult> GetObjectList(
    Filter filter
)
Visual Basic
Public Overrides Function GetObjectList ( _
    filter As Filter _
) As List(Of RunResult)
Visual C++
public:
virtual List<RunResult^>^ GetObjectList(
    Filter^ filter
) override

Parameters

filter
Type: ArtOfTest.WebAii.Design.Execution..::..Filter

[Missing <param name="filter"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResultsCollection.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunResultsCollection.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

See Also

RunResultsCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


GetRunResultsBetween Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..GetRunResultsBetween Method
RunResultsCollection Class See Also Send Feedback
Retrieves the list of run results started and completed between the start and end time arguments.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<RunResult> GetRunResultsBetween(
    DateTime start,
    DateTime end
)
Visual Basic
Public Function GetRunResultsBetween ( _
    start As DateTime, _
    end As DateTime _
) As List(Of RunResult)
Visual C++
public:
List<RunResult^>^ GetRunResultsBetween(
    DateTime start,
    DateTime end
)

Parameters

start
Type: System..::..DateTime
The start time argument, result start time instance should be later.
end
Type: System..::..DateTime
The end time argument, result end time instance should be earlier.

Return Value

The list of run results started and completed between the start and end time arguments.

See Also

RunResultsCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


GetRunResultsStartedBetween Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..GetRunResultsStartedBetween Method
RunResultsCollection Class See Also Send Feedback
Retrieves the list of run results started between the start and end time arguments.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<RunResult> GetRunResultsStartedBetween(
    DateTime start,
    DateTime end
)
Visual Basic
Public Function GetRunResultsStartedBetween ( _
    start As DateTime, _
    end As DateTime _
) As List(Of RunResult)
Visual C++
public:
List<RunResult^>^ GetRunResultsStartedBetween(
    DateTime start,
    DateTime end
)

Parameters

start
Type: System..::..DateTime
The start time argument, result instance should be started later.
end
Type: System..::..DateTime
The end time argument, result instance should be started earlier.

Return Value

The list of run results started between the start and end time arguments.

See Also

RunResultsCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


IndexOf Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..IndexOf Method
RunResultsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
RunResultsCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


LastIndexOf Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..LastIndexOf Method
RunResultsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
RunResultsCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


Reverse Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..Reverse Method
RunResultsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
RunResultsCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


Sort Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection..::..Sort Method
RunResultsCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
RunResultsCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


RunResultsCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunResultsCollection Properties
RunResultsCollection Class See Also Send Feedback

The RunResultsCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<' RunResult >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<' RunResult >)>)>.)

See Also

RunResultsCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


RunTestArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunTestArgs Members
RunTestArgs Class Constructors Methods Properties See Also Send Feedback

The RunTestArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RunTestArgs | Initializes a new instance of the RunTestArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExecutionType |
Public property | Settings |
Public property | Test |

See Also

RunTestArgs Class
ArtOfTest.WebAii.Design.Execution Namespace


RunTestArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunTestArgs Constructor
RunTestArgs Class See Also Send Feedback
Initializes a new instance of the RunTestArgs class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RunTestArgs(
    Test test,
    Settings settings,
    ExecutionType et
)
Visual Basic
Public Sub New ( _
    test As Test, _
    settings As Settings, _
    et As ExecutionType _
)
Visual C++
public:
RunTestArgs(
    Test^ test,
    Settings^ settings,
    ExecutionType et
)

Parameters

test
Type: Test

[Missing <param name="test"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunTestArgs.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.Common.Design.ExecutionType)"]

settings
Type: ArtOfTest.WebAii.Core..::..Settings

[Missing <param name="settings"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunTestArgs.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.Common.Design.ExecutionType)"]

et
Type: ExecutionType

[Missing <param name="et"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.RunTestArgs.#ctor(ArtOfTest.WebAii.Design.ProjectModel.Test,ArtOfTest.WebAii.Core.Settings,ArtOfTest.Common.Design.ExecutionType)"]

See Also

RunTestArgs Class
ArtOfTest.WebAii.Design.Execution Namespace


RunTestArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunTestArgs Methods
RunTestArgs Class See Also Send Feedback

The RunTestArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RunTestArgs Class
ArtOfTest.WebAii.Design.Execution Namespace


RunTestArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunTestArgs Properties
RunTestArgs Class See Also Send Feedback

The RunTestArgs type exposes the following members.

Properties

 | Name | Description
Public property | ExecutionType |
Public property | Settings |
Public property | Test |

See Also

RunTestArgs Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunTestArgs..::..ExecutionType Property
RunTestArgs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunTestArgs.ExecutionType"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecutionType ExecutionType { get; private set; }
Visual Basic
Public Property ExecutionType As ExecutionType
    Get
    Private Set
Visual C++
public:
property ExecutionType ExecutionType {
    ExecutionType get ();
    private: void set (ExecutionType value);
}

See Also

RunTestArgs Class
ArtOfTest.WebAii.Design.Execution Namespace


Settings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunTestArgs..::..Settings Property
RunTestArgs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunTestArgs.Settings"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings Settings { get; private set; }
Visual Basic
Public Property Settings As Settings
    Get
    Private Set
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
    private: void set (Settings^ value);
}

See Also

RunTestArgs Class
ArtOfTest.WebAii.Design.Execution Namespace


Test Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RunTestArgs..::..Test Property
RunTestArgs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.RunTestArgs.Test"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Test Test { get; private set; }
Visual Basic
Public Property Test As Test
    Get
    Private Set
Visual C++
public:
property Test^ Test {
    Test^ get ();
    private: void set (Test^ value);
}

See Also

RunTestArgs Class
ArtOfTest.WebAii.Design.Execution Namespace


TestAsStepResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult Members
TestAsStepResult Class Constructors Methods Properties Events See Also Send Feedback

The TestAsStepResult type exposes the following members.

Constructors

 | Name | Description
Public method | TestAsStepResult()()()() | Initializes a new instance of the TestAsStepResult class
Public method | TestAsStepResult(TestResult) | Initializes a new instance of the TestAsStepResult class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBrowserState | Load the browser state (Inherited from AutomationStepResult.)
Public method | LoadFrom | (Overrides AutomationStepResult..::..LoadFrom(XmlStoreNode).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from AutomationStepResult.)
Protected method | OnSerializing | (Inherited from AutomationStepResult.)
Public method | PersistStepFailureResourcesOnDisk | Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk. (Inherited from AutomationStepResult.)
Public method | SaveTo | (Overrides AutomationStepResult..::..SaveTo(XmlStoreNode).)
Public method | SetFailedStepLog | Persists the failed step log during execution.
Public method | StoreHostState | Store the browser state as part of this step (Inherited from AutomationStepResult.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentVersion | (Inherited from AutomationStepResult.)
Public property | Exception | Gets/sets the exception related to the test failure. (Overrides AutomationStepResult..::..Exception.)
Public property | FailedStepLog | Gets or sets the failed step log.
Public property | HasExpectedImage | (Inherited from AutomationStepResult.)
Public property | HashCode | (Inherited from AutomationStepResult.)
Public property | HasImage | (Inherited from AutomationStepResult.)
Public property | IsManual | (Inherited from AutomationStepResult.)
Public property | LogMessageOnError | (Inherited from AutomationStepResult.)
Public property | Order | (Inherited from AutomationStepResult.)
Public property | ParentTestResult | (Inherited from AutomationStepResult.)
Public property | ResultType | Gets or sets the result type (Pass/fail/notrun). (Overrides AutomationStepResult..::..ResultType.)
Public property | RootName | (Overrides AutomationStepResult..::..RootName.)
Public property | RunTimeStepId | (Inherited from AutomationStepResult.)
Public property | StepDescription | Gets or sets the description of this step. (Inherited from AutomationStepResult.)
Public property | TestId | Gets or sets the test unique Id this step result belongs to. (Inherited from AutomationStepResult.)
Public property | TestName | Gets or sets the test name of this step. (Inherited from AutomationStepResult.)
Public property | TestPath | Gets or sets the test path within the project. (Inherited from AutomationStepResult.)
Public property | TestResult | Gets the test result of our step.
Public property | TestStepIndex | Gets or sets the step index (Inherited from AutomationStepResult.)
Public property | UserComment | (Inherited from AutomationStepResult.)
Public property | WasStepEnabled | (Inherited from AutomationStepResult.)
Public property | XmlBlob | (Inherited from AutomationStepResult.)

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from AutomationStepResult.)

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestAsStepResult Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult Constructor
TestAsStepResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TestAsStepResult()()()() | Initializes a new instance of the TestAsStepResult class
Public method | TestAsStepResult(TestResult) | Initializes a new instance of the TestAsStepResult class

See Also

TestAsStepResult Class
TestAsStepResult Members
ArtOfTest.WebAii.Design.Execution Namespace


TestAsStepResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult Constructor
TestAsStepResult Class See Also Send Feedback
Initializes a new instance of the TestAsStepResult class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestAsStepResult()
Visual Basic
Public Sub New
Visual C++
public:
TestAsStepResult()

See Also

TestAsStepResult Class
TestAsStepResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestAsStepResult Constructor (TestResult)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult Constructor (TestResult)
TestAsStepResult Class See Also Send Feedback
Initializes a new instance of the TestAsStepResult class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestAsStepResult(
    TestResult result
)
Visual Basic
Public Sub New ( _
    result As TestResult _
)
Visual C++
public:
TestAsStepResult(
    TestResult^ result
)

Parameters

result
Type: ArtOfTest.WebAii.Design.Execution..::..TestResult

[Missing <param name="result"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestAsStepResult.#ctor(ArtOfTest.WebAii.Design.Execution.TestResult)"]

See Also

TestAsStepResult Class
TestAsStepResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestAsStepResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult Methods
TestAsStepResult Class See Also Send Feedback

The TestAsStepResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadBrowserState | Load the browser state (Inherited from AutomationStepResult.)
Public method | LoadFrom | (Overrides AutomationStepResult..::..LoadFrom(XmlStoreNode).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged | (Inherited from AutomationStepResult.)
Protected method | OnSerializing | (Inherited from AutomationStepResult.)
Public method | PersistStepFailureResourcesOnDisk | Persists the step failure BrowserState (DOM, ImageBytes) resourses on the disk. (Inherited from AutomationStepResult.)
Public method | SaveTo | (Overrides AutomationStepResult..::..SaveTo(XmlStoreNode).)
Public method | SetFailedStepLog | Persists the failed step log during execution.
Public method | StoreHostState | Store the browser state as part of this step (Inherited from AutomationStepResult.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult..::..LoadFrom Method
TestAsStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestAsStepResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Overrides Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) override

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestAsStepResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult..::..SaveTo Method
TestAsStepResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestAsStepResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Overrides Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) override

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestAsStepResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SetFailedStepLog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult..::..SetFailedStepLog Method
TestAsStepResult Class See Also Send Feedback
Persists the failed step log during execution.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetFailedStepLog(
    int stepIndex,
    string stepDescription
)
Visual Basic
Public Sub SetFailedStepLog ( _
    stepIndex As Integer, _
    stepDescription As String _
)
Visual C++
public:
void SetFailedStepLog(
    int stepIndex,
    String^ stepDescription
)

Parameters

stepIndex
Type: System..::..Int32
Index of the step.
stepDescription
Type: System..::..String
The step description.

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestAsStepResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult Properties
TestAsStepResult Class See Also Send Feedback

The TestAsStepResult type exposes the following members.

Properties

 | Name | Description
Public property | CurrentVersion | (Inherited from AutomationStepResult.)
Public property | Exception | Gets/sets the exception related to the test failure. (Overrides AutomationStepResult..::..Exception.)
Public property | FailedStepLog | Gets or sets the failed step log.
Public property | HasExpectedImage | (Inherited from AutomationStepResult.)
Public property | HashCode | (Inherited from AutomationStepResult.)
Public property | HasImage | (Inherited from AutomationStepResult.)
Public property | IsManual | (Inherited from AutomationStepResult.)
Public property | LogMessageOnError | (Inherited from AutomationStepResult.)
Public property | Order | (Inherited from AutomationStepResult.)
Public property | ParentTestResult | (Inherited from AutomationStepResult.)
Public property | ResultType | Gets or sets the result type (Pass/fail/notrun). (Overrides AutomationStepResult..::..ResultType.)
Public property | RootName | (Overrides AutomationStepResult..::..RootName.)
Public property | RunTimeStepId | (Inherited from AutomationStepResult.)
Public property | StepDescription | Gets or sets the description of this step. (Inherited from AutomationStepResult.)
Public property | TestId | Gets or sets the test unique Id this step result belongs to. (Inherited from AutomationStepResult.)
Public property | TestName | Gets or sets the test name of this step. (Inherited from AutomationStepResult.)
Public property | TestPath | Gets or sets the test path within the project. (Inherited from AutomationStepResult.)
Public property | TestResult | Gets the test result of our step.
Public property | TestStepIndex | Gets or sets the step index (Inherited from AutomationStepResult.)
Public property | UserComment | (Inherited from AutomationStepResult.)
Public property | WasStepEnabled | (Inherited from AutomationStepResult.)
Public property | XmlBlob | (Inherited from AutomationStepResult.)

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Exception Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult..::..Exception Property
TestAsStepResult Class See Also Send Feedback
Gets/sets the exception related to the test failure.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override ExecutionException Exception { get; set; }
Visual Basic
Public Overrides Property Exception As ExecutionException
    Get
    Set
Visual C++
public:
virtual property ExecutionException^ Exception {
    ExecutionException^ get () override;
    void set (ExecutionException^ value) override;
}

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


FailedStepLog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult..::..FailedStepLog Property
TestAsStepResult Class See Also Send Feedback
Gets or sets the failed step log.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FailedStepLog { get; }
Visual Basic
Public ReadOnly Property FailedStepLog As String
    Get
Visual C++
public:
property String^ FailedStepLog {
    String^ get ();
}

Field Value

The failed step log.

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult..::..ResultType Property
TestAsStepResult Class See Also Send Feedback
Gets or sets the result type (Pass/fail/notrun).

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override ResultType ResultType { get; set; }
Visual Basic
Public Overrides Property ResultType As ResultType
    Get
    Set
Visual C++
public:
virtual property ResultType ResultType {
    ResultType get () override;
    void set (ResultType value) override;
}

Field Value

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult..::..RootName Property
TestAsStepResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestAsStepResult.RootName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string RootName { get; }
Visual Basic
Public Overrides ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () override;
}

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult..::..TestResult Property
TestAsStepResult Class See Also Send Feedback
Gets the test result of our step.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult TestResult { get; set; }
Visual Basic
Public Property TestResult As TestResult
    Get
    Set
Visual C++
public:
property TestResult^ TestResult {
    TestResult^ get ();
    void set (TestResult^ value);
}

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestAsStepResult Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestAsStepResult Events
TestAsStepResult Class See Also Send Feedback

The TestAsStepResult type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from AutomationStepResult.)

See Also

TestAsStepResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection Members
TestCollection Class Constructors Methods Properties See Also Send Feedback

The TestCollection type exposes the following members.

Constructors

 | Name | Description
Public method | TestCollection | Initializes the test collection with a list of tests.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<'TestBase>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectList | (Overrides FilteredCollection<(Of <(<'T>)>)>..::..GetObjectList(Filter).)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<'TestBase>)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


TestCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection Constructor
TestCollection Class See Also Send Feedback
Initializes the test collection with a list of tests.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestCollection(
    List<TestBase> tests
)
Visual Basic
Public Sub New ( _
    tests As List(Of TestBase) _
)
Visual C++
public:
TestCollection(
    List<TestBase^>^ tests
)

Parameters

tests
Type: System.Collections.Generic..::..List <(Of <(<'TestBase>)>)>

[Missing <param name="tests"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestCollection.#ctor(System.Collections.Generic.List{ArtOfTest.Common.Design.ProjectModel.TestBase})"]

See Also

TestCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


TestCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection Methods
TestCollection Class See Also Send Feedback

The TestCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<'TestBase>)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectList | (Overrides FilteredCollection<(Of <(<'T>)>)>..::..GetObjectList(Filter).)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


BinarySearch Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..BinarySearch Method
TestCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
TestCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


CopyTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..CopyTo Method
TestCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
TestCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


FindIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..FindIndex Method
TestCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
TestCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


FindLastIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..FindLastIndex Method
TestCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
TestCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


GetObjectList Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..GetObjectList Method
TestCollection Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestCollection.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override List<TestBase> GetObjectList(
    Filter filter
)
Visual Basic
Public Overrides Function GetObjectList ( _
    filter As Filter _
) As List(Of TestBase)
Visual C++
public:
virtual List<TestBase^>^ GetObjectList(
    Filter^ filter
) override

Parameters

filter
Type: ArtOfTest.WebAii.Design.Execution..::..Filter

[Missing <param name="filter"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestCollection.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestCollection.GetObjectList(ArtOfTest.WebAii.Design.Execution.Filter)"]

See Also

TestCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


IndexOf Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..IndexOf Method
TestCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
TestCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


LastIndexOf Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..LastIndexOf Method
TestCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
TestCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


Reverse Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..Reverse Method
TestCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
TestCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


Sort Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection..::..Sort Method
TestCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
TestCollection Members
ArtOfTest.WebAii.Design.Execution Namespace


TestCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestCollection Properties
TestCollection Class See Also Send Feedback

The TestCollection type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List <(Of <(<'TestBase>)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List <(Of <(<'TestBase>)>)>.)

See Also

TestCollection Class
ArtOfTest.WebAii.Design.Execution Namespace


TestInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo Members
TestInfo Class Constructors Methods Properties See Also Send Feedback

The TestInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TestInfo()()()() | Initializes a new instance of the TestInfo class
Public method | TestInfo(String, String) | Initializes a new instance of the TestInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | Id | The test unique Id.
Public property | Path | The test relative path to the project.
Public property | RootName |
Public property | Test | Cached test object
Public property | XmlBlob |

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


TestInfo Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo Constructor
TestInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TestInfo()()()() | Initializes a new instance of the TestInfo class
Public method | TestInfo(String, String) | Initializes a new instance of the TestInfo class

See Also

TestInfo Class
TestInfo Members
ArtOfTest.WebAii.Design.Execution Namespace


TestInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo Constructor
TestInfo Class See Also Send Feedback
Initializes a new instance of the TestInfo class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestInfo()
Visual Basic
Public Sub New
Visual C++
public:
TestInfo()

See Also

TestInfo Class
TestInfo Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestInfo Constructor (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo Constructor (String, String)
TestInfo Class See Also Send Feedback
Initializes a new instance of the TestInfo class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestInfo(
    string id,
    string path
)
Visual Basic
Public Sub New ( _
    id As String, _
    path As String _
)
Visual C++
public:
TestInfo(
    String^ id,
    String^ path
)

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestInfo.#ctor(System.String,System.String)"]

path
Type: System..::..String

[Missing <param name="path"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestInfo.#ctor(System.String,System.String)"]

See Also

TestInfo Class
TestInfo Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo Methods
TestInfo Class See Also Send Feedback

The TestInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveTo |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo..::..LoadFrom Method
TestInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestInfo.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestInfo.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo..::..SaveTo Method
TestInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestInfo.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestInfo.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


TestInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo Properties
TestInfo Class See Also Send Feedback

The TestInfo type exposes the following members.

Properties

 | Name | Description
Public property | CurrentVersion |
Public property | Id | The test unique Id.
Public property | Path | The test relative path to the project.
Public property | RootName |
Public property | Test | Cached test object
Public property | XmlBlob |

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo..::..CurrentVersion Property
TestInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestInfo.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


Id Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo..::..Id Property
TestInfo Class See Also Send Feedback
The test unique Id.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


Path Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo..::..Path Property
TestInfo Class See Also Send Feedback
The test relative path to the project.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo..::..RootName Property
TestInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestInfo.RootName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


Test Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo..::..Test Property
TestInfo Class See Also Send Feedback
Cached test object

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Test Test { get; set; }
Visual Basic
Public Property Test As Test
    Get
    Set
Visual C++
public:
property Test^ Test {
    Test^ get ();
    void set (Test^ value);
}

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestInfo..::..XmlBlob Property
TestInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestInfo.XmlBlob"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

TestInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


TestList Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Members
TestList Class Constructors Methods Fields Properties Events See Also Send Feedback

The TestList type exposes the following members.

Constructors

 | Name | Description
Public method | TestList()()()() | An empty constuctor for serialization.
Public method | TestList(String, String, Filter) | The TestList object constructor initializing the tests by the list of filters. Adds an automated test list for backwards compatibility.
Public method | TestList(String, String, TestListType) | Create a TestList without tests.
Public method | TestList(String, String, List<(Of <<'(TestInfo>)>>)) | The TestList object constructor initializing the flat list of test paths. Adds an automated test list for backwards compatibility.
Public method | TestList(String, String, Filter, TestListType) | The TestList object constructor initializing the tests by the list of filters.
Public method | TestList(String, String, List<(Of <<'(TestInfo>)>>), TestListType) | The TestList object constructor initializing the flat list of test paths.

Methods

 | Name | Description
Public method | Clone | Clones the TestList instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProjectRootPath | Get the project root path from the given list full path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
 | LoadFromFile | Loads the TestList object from the file with given path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnTestListChanged |
Public method | SaveTo |
Public method | SaveToListFile | Create the list file from the current test list object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
LIST_FILE_EXTENSION |
LISTS_FOLDER_NAME |

Properties

 | Name | Description
Public property | CreationDate | Gets the date of creation of the run object.
Public property | CurrentVersion |
Public property | Filter | Gets the test filter to retrieve the tests by.
Public property | Id |
Public property | IsDynamic | Get whether a filter stands behind the test list and is applied to all the tests in the project.
Public property | IsProfilingExecution | This property is exposed for databinding because Settings and .WebSettings don't implement INotifyPropertyChanged.
Public property | ListType |
Public property | OwnerName | Gets the owner name of the Run object.
Public property | RootName |
Public property | Settings | Gets or sets the settings associated with the TestList object.
Public property | TestListId | Gets the unique Id of the TestList object.
Public property | TestListName | Gets the friendly name of the TestList object.
Public property | Tests | Gets the list of test paths the TestList object operates with. The path is relative to the project, corresponding to the Test.Path value.
Public property | XmlBlob |

Events

 | Name | Description
Public event | PropertyChanged |
Public event | TestListChanged |

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


TestList Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Constructor
TestList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TestList()()()() | An empty constuctor for serialization.
Public method | TestList(String, String, Filter) | The TestList object constructor initializing the tests by the list of filters. Adds an automated test list for backwards compatibility.
Public method | TestList(String, String, TestListType) | Create a TestList without tests.
Public method | TestList(String, String, List<(Of <<'(TestInfo>)>>)) | The TestList object constructor initializing the flat list of test paths. Adds an automated test list for backwards compatibility.
Public method | TestList(String, String, Filter, TestListType) | The TestList object constructor initializing the tests by the list of filters.
Public method | TestList(String, String, List<(Of <<'(TestInfo>)>>), TestListType) | The TestList object constructor initializing the flat list of test paths.

See Also

TestList Class
TestList Members
ArtOfTest.WebAii.Design.Execution Namespace


TestList Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Constructor
TestList Class See Also Send Feedback
An empty constuctor for serialization.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestList()
Visual Basic
Public Sub New
Visual C++
public:
TestList()

See Also

TestList Class
TestList Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestList Constructor (String, String, Filter)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Constructor (String, String, Filter)
TestList Class See Also Send Feedback
The TestList object constructor initializing the tests by the list of filters. Adds an automated test list for backwards compatibility.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestList(
    string name,
    string ownerName,
    Filter filter
)
Visual Basic
Public Sub New ( _
    name As String, _
    ownerName As String, _
    filter As Filter _
)
Visual C++
public:
TestList(
    String^ name,
    String^ ownerName,
    Filter^ filter
)

Parameters

name
Type: System..::..String
The friendly name of the test list instance.
ownerName
Type: System..::..String
The owner name of the test list instance.
filter
Type: ArtOfTest.WebAii.Design.Execution..::..Filter
The test filter to be applied on retrieving the tests.

See Also

TestList Class
TestList Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestList Constructor (String, String, TestListType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Constructor (String, String, TestListType)
TestList Class See Also Send Feedback
Create a TestList without tests.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestList(
    string name,
    string owner,
    TestListType type
)
Visual Basic
Public Sub New ( _
    name As String, _
    owner As String, _
    type As TestListType _
)
Visual C++
public:
TestList(
    String^ name,
    String^ owner,
    TestListType type
)

Parameters

name
Type: System..::..String
The test list name.
owner
Type: System..::..String
The owner.
type
Type: ArtOfTest.WebAii.Design..::..TestListType
The test list type.

See Also

TestList Class
TestList Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestList Constructor (String, String, List(TestInfo))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Constructor (String, String, List<(Of <(<'TestInfo>)>)>)
TestList Class See Also Send Feedback
The TestList object constructor initializing the flat list of test paths. Adds an automated test list for backwards compatibility.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestList(
    string name,
    string ownerName,
    List<TestInfo> tests
)
Visual Basic
Public Sub New ( _
    name As String, _
    ownerName As String, _
    tests As List(Of TestInfo) _
)
Visual C++
public:
TestList(
    String^ name,
    String^ ownerName,
    List<TestInfo^>^ tests
)

Parameters

name
Type: System..::..String
The friendly name of the test list instance.
ownerName
Type: System..::..String
The owner name of the test list instance.
tests
Type: System.Collections.Generic..::..List <(Of <(<' TestInfo >)>)>
The list of tests represented by their test path.

See Also

TestList Class
TestList Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestList Constructor (String, String, Filter, TestListType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Constructor (String, String, Filter, TestListType)
TestList Class See Also Send Feedback
The TestList object constructor initializing the tests by the list of filters.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestList(
    string name,
    string ownerName,
    Filter filter,
    TestListType type
)
Visual Basic
Public Sub New ( _
    name As String, _
    ownerName As String, _
    filter As Filter, _
    type As TestListType _
)
Visual C++
public:
TestList(
    String^ name,
    String^ ownerName,
    Filter^ filter,
    TestListType type
)

Parameters

name
Type: System..::..String
The friendly name of the test list instance.
ownerName
Type: System..::..String
The owner name of the test list instance.
filter
Type: ArtOfTest.WebAii.Design.Execution..::..Filter
The test filter to be applied on retrieving the tests.
type
Type: ArtOfTest.WebAii.Design..::..TestListType
The test list type.

See Also

TestList Class
TestList Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestList Constructor (String, String, List(TestInfo), TestListType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Constructor (String, String, List<(Of <(<'TestInfo>)>)>, TestListType)
TestList Class See Also Send Feedback
The TestList object constructor initializing the flat list of test paths.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestList(
    string name,
    string ownerName,
    List<TestInfo> tests,
    TestListType type
)
Visual Basic
Public Sub New ( _
    name As String, _
    ownerName As String, _
    tests As List(Of TestInfo), _
    type As TestListType _
)
Visual C++
public:
TestList(
    String^ name,
    String^ ownerName,
    List<TestInfo^>^ tests,
    TestListType type
)

Parameters

name
Type: System..::..String
The friendly name of the test list instance.
ownerName
Type: System..::..String
The owner name of the test list instance.
tests
Type: System.Collections.Generic..::..List <(Of <(<' TestInfo >)>)>
The list of tests represented by their test path.
type
Type: ArtOfTest.WebAii.Design..::..TestListType
The test list type.

See Also

TestList Class
TestList Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestList Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Fields
TestList Class See Also Send Feedback

The TestList type exposes the following members.

Fields

Name | Description
LIST_FILE_EXTENSION |
LISTS_FOLDER_NAME |

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


LIST_FILE_EXTENSION Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..LIST_FILE_EXTENSION Field
TestList Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestList.LIST_FILE_EXTENSION"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string LIST_FILE_EXTENSION
Visual Basic
Public Const LIST_FILE_EXTENSION As String
Visual C++
public:
literal String^ LIST_FILE_EXTENSION

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


LISTS_FOLDER_NAME Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..LISTS_FOLDER_NAME Field
TestList Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestList.LISTS_FOLDER_NAME"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string LISTS_FOLDER_NAME
Visual Basic
Public Const LISTS_FOLDER_NAME As String
Visual C++
public:
literal String^ LISTS_FOLDER_NAME

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


TestList Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Methods
TestList Class See Also Send Feedback

The TestList type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Clones the TestList instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProjectRootPath | Get the project root path from the given list full path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
 | LoadFromFile | Loads the TestList object from the file with given path.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnTestListChanged |
Public method | SaveTo |
Public method | SaveToListFile | Create the list file from the current test list object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


Clone Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..Clone Method
TestList Class See Also Send Feedback
Clones the TestList instance.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestList Clone(
    string newName
)
Visual Basic
Public Function Clone ( _
    newName As String _
) As TestList
Visual C++
public:
TestList^ Clone(
    String^ newName
)

Parameters

newName
Type: System..::..String
The cloned test list name.

Return Value

Cloned the TestList instance.

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


GetProjectRootPath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..GetProjectRootPath Method
TestList Class See Also Send Feedback
Get the project root path from the given list full path.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GetProjectRootPath(
    string aiiListFullPath
)
Visual Basic
Public Shared Function GetProjectRootPath ( _
    aiiListFullPath As String _
) As String
Visual C++
public:
static String^ GetProjectRootPath(
    String^ aiiListFullPath
)

Parameters

aiiListFullPath
Type: System..::..String
The path to the .aiilist file.

Return Value

The project root path from the given list full path.

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..LoadFrom Method
TestList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestList.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestList.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFromFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..LoadFromFile Method
TestList Class See Also Send Feedback
Loads the TestList object from the file with given path.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static TestList LoadFromFile(
    string aiiListFilePath
)
Visual Basic
Public Shared Function LoadFromFile ( _
    aiiListFilePath As String _
) As TestList
Visual C++
public:
static TestList^ LoadFromFile(
    String^ aiiListFilePath
)

Parameters

aiiListFilePath
Type: System..::..String
The full path to the file.

Return Value

The test list saved in that file.

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


OnTestListChanged Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..OnTestListChanged Method
TestList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestList.OnTestListChanged"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void OnTestListChanged()
Visual Basic
Public Sub OnTestListChanged
Visual C++
public:
void OnTestListChanged()

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..SaveTo Method
TestList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestList.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestList.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveToListFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..SaveToListFile Method
TestList Class See Also Send Feedback
Create the list file from the current test list object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SaveToListFile(
    string projectRootPath
)
Visual Basic
Public Function SaveToListFile ( _
    projectRootPath As String _
) As String
Visual C++
public:
String^ SaveToListFile(
    String^ projectRootPath
)

Parameters

projectRootPath
Type: System..::..String
The root path of the project.

Return Value

The path of the list file.

Remarks

Replaces the old list file if any.

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


TestList Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Properties
TestList Class See Also Send Feedback

The TestList type exposes the following members.

Properties

 | Name | Description
Public property | CreationDate | Gets the date of creation of the run object.
Public property | CurrentVersion |
Public property | Filter | Gets the test filter to retrieve the tests by.
Public property | Id |
Public property | IsDynamic | Get whether a filter stands behind the test list and is applied to all the tests in the project.
Public property | IsProfilingExecution | This property is exposed for databinding because Settings and .WebSettings don't implement INotifyPropertyChanged.
Public property | ListType |
Public property | OwnerName | Gets the owner name of the Run object.
Public property | RootName |
Public property | Settings | Gets or sets the settings associated with the TestList object.
Public property | TestListId | Gets the unique Id of the TestList object.
Public property | TestListName | Gets the friendly name of the TestList object.
Public property | Tests | Gets the list of test paths the TestList object operates with. The path is relative to the project, corresponding to the Test.Path value.
Public property | XmlBlob |

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


CreationDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..CreationDate Property
TestList Class See Also Send Feedback
Gets the date of creation of the run object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime CreationDate { get; }
Visual Basic
Public ReadOnly Property CreationDate As DateTime
    Get
Visual C++
public:
property DateTime CreationDate {
    DateTime get ();
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..CurrentVersion Property
TestList Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestList.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


Filter Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..Filter Property
TestList Class See Also Send Feedback
Gets the test filter to retrieve the tests by.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Filter Filter { get; set; }
Visual Basic
Public Property Filter As Filter
    Get
    Set
Visual C++
public:
property Filter^ Filter {
    Filter^ get ();
    void set (Filter^ value);
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


Id Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..Id Property
TestList Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestList.Id"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid Id { get; }
Visual Basic
Public ReadOnly Property Id As Guid
    Get
Visual C++
public:
property Guid Id {
    Guid get ();
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


IsDynamic Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..IsDynamic Property
TestList Class See Also Send Feedback
Get whether a filter stands behind the test list and is applied to all the tests in the project.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDynamic { get; }
Visual Basic
Public ReadOnly Property IsDynamic As Boolean
    Get
Visual C++
public:
property bool IsDynamic {
    bool get ();
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


IsProfilingExecution Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..IsProfilingExecution Property
TestList Class See Also Send Feedback
This property is exposed for databinding because Settings and .WebSettings don't implement INotifyPropertyChanged.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsProfilingExecution { get; set; }
Visual Basic
Public Property IsProfilingExecution As Boolean
    Get
    Set
Visual C++
public:
property bool IsProfilingExecution {
    bool get ();
    void set (bool value);
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


ListType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..ListType Property
TestList Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestList.ListType"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestListType ListType { get; set; }
Visual Basic
Public Property ListType As TestListType
    Get
    Set
Visual C++
public:
property TestListType ListType {
    TestListType get ();
    void set (TestListType value);
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


OwnerName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..OwnerName Property
TestList Class See Also Send Feedback
Gets the owner name of the Run object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string OwnerName { get; set; }
Visual Basic
Public Property OwnerName As String
    Get
    Set
Visual C++
public:
property String^ OwnerName {
    String^ get ();
    void set (String^ value);
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..RootName Property
TestList Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestList.RootName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


Settings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..Settings Property
TestList Class See Also Send Feedback
Gets or sets the settings associated with the TestList object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Settings Settings { get; set; }
Visual Basic
Public Property Settings As Settings
    Get
    Set
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
    void set (Settings^ value);
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


TestListId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..TestListId Property
TestList Class See Also Send Feedback
Gets the unique Id of the TestList object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestListId { get; }
Visual Basic
Public ReadOnly Property TestListId As String
    Get
Visual C++
public:
property String^ TestListId {
    String^ get ();
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


TestListName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..TestListName Property
TestList Class See Also Send Feedback
Gets the friendly name of the TestList object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestListName { get; internal set; }
Visual Basic
Public Property TestListName As String
    Get
    Friend Set
Visual C++
public:
property String^ TestListName {
    String^ get ();
    internal: void set (String^ value);
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


Tests Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..Tests Property
TestList Class See Also Send Feedback
Gets the list of test paths the TestList object operates with. The path is relative to the project, corresponding to the Test.Path value.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<TestInfo> Tests { get; }
Visual Basic
Public ReadOnly Property Tests As List(Of TestInfo)
    Get
Visual C++
public:
property List<TestInfo^>^ Tests {
    List<TestInfo^>^ get ();
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..XmlBlob Property
TestList Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestList.XmlBlob"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


TestList Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList Events
TestList Class See Also Send Feedback

The TestList type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged |
Public event | TestListChanged |

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


PropertyChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..PropertyChanged Event
TestList Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.Execution.TestList.PropertyChanged"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


TestListChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestList..::..TestListChanged Event
TestList Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.Execution.TestList.TestListChanged"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler TestListChanged
Visual Basic
Public Event TestListChanged As EventHandler
Visual C++
public:
 event EventHandler^ TestListChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

TestList Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult Members
TestResult Class Constructors Methods Properties Events See Also Send Feedback

The TestResult type exposes the following members.

Constructors

 | Name | Description
Public method | TestResult()()()() | Empty constructor needed for serialization.
Public method | TestResult(Test) | Initializes a new TestResult instance based on the given Test object.

Methods

 | Name | Description
Public method | AddDataIterationResult | Adds a data iteration result
Public method | AddStepResult(AutomationStepResult) |
Public method | AddStepResult(AutomationStepResult, Boolean) | Add an automation step result to this test.
Public method | AppendMessage | Appends a messsage to the result.
Public method | AppendOverallResult | Append the overall result of this test execution.
Public method | AppendSeparatorLine()()()() | Append a default separator line.
Public method | AppendSeparatorLine(Char, Int32) | Append a separator to the result
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportToResultFile | Exports the test result into a Test Studio run result file.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | PersistTestFailureResourcesOnDisk | Save results resources to disk.
Public method | PrependMessage | Prepend a specific message to the log.
Public method | RecalculateStepResults |
Public method | RemoveLastStepResult |
Public method | SaveTo |
Public method | SetStartTime | Sets the start time of the execution of this test // TODO: add to persistence
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllTestStepCount | Calculate all test step count.
Public property | CommitedBy |
Public property | CurrentVersion |
Public property | DataIterationResults | Gets the data iteration results when IsDataDrivenResult is set to true
Public property | Duration | Gets the duration of test execution.
Public property | EndTime | Gets the time when the test ended execution.
Public property | ExecutingTestStepCount |
Public property | ExeType |
Public property | FailureException | Gets the execution exception causing the test failure.
Public property | FirstFailedStepComment |
Public property | IsDataDrivenResult | Gets whether the result contains data driven results
Public property | IsManualResult |
Public property | Message | Gets/Sets the message of this result.
Public property | NotRunStepDescriptions | Gets the descriptions of the not executed steps so that we don't have to get the test behind this result in order to show all descriptions.
Public property | Parent |
Public property | PercentComplete |
Public property | ProfilerResultsId | The permanent ID of the profiler results file, for verification and in case the path changes.
Public property | ProfilerResultsPath | The location on disk of the Profiler database associated with this test run. This is not the final path etched in stone, rather it is used more like a cached value to prevent a long enumeration. If the path is invalid, the enumeration will have to take place regardless.
Public property | ProjectPath | Gets the project path that contains this test.
Public property | Result | Gets/Sets the result type of this result object.
Public property | RootName |
Public property | SeparatorLineCharCount |
Public property | StartTime | Gets the time when the test started execution
Public property | StepResults | Gets the AutomationStep results
Public property | TestDescription | The test description to help users in case of failure.
Public property | TestId | Gets or sets the test unique Id behind this result.
Public property | TestName | Gets the test name within the project.
Public property | TestOwner | The test owner to present in case of failure.
Public property | TestPath | Gets the test path within the project.
Public property | TotalNumberOfNotRunSteps | Gets the total number of not run automation steps.
Public property | TotalPassedSteps | Gets the total number of passed automation steps.
Public property | VersionGroupKey |
Public property | XmlBlob |

Events

 | Name | Description
Public event | PropertyChanged |

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult Constructor
TestResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TestResult()()()() | Empty constructor needed for serialization.
Public method | TestResult(Test) | Initializes a new TestResult instance based on the given Test object.

See Also

TestResult Class
TestResult Members
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult Constructor
TestResult Class See Also Send Feedback
Empty constructor needed for serialization.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult()
Visual Basic
Public Sub New
Visual C++
public:
TestResult()

See Also

TestResult Class
TestResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Constructor ()

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult Constructor ()
TestResult Class See Also Send Feedback
Initializes a new TestResult instance based on the given Test object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestResult(
    Test test
)
Visual Basic
Public Sub New ( _
    test As Test _
)
Visual C++
public:
TestResult(
    Test^ test
)

Parameters

test
Type: Test
The test object.

See Also

TestResult Class
TestResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult Methods
TestResult Class See Also Send Feedback

The TestResult type exposes the following members.

Methods

 | Name | Description
Public method | AddDataIterationResult | Adds a data iteration result
Public method | AddStepResult(AutomationStepResult) |
Public method | AddStepResult(AutomationStepResult, Boolean) | Add an automation step result to this test.
Public method | AppendMessage | Appends a messsage to the result.
Public method | AppendOverallResult | Append the overall result of this test execution.
Public method | AppendSeparatorLine()()()() | Append a default separator line.
Public method | AppendSeparatorLine(Char, Int32) | Append a separator to the result
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportToResultFile | Exports the test result into a Test Studio run result file.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadFrom |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnPropertyChanged |
Public method | PersistTestFailureResourcesOnDisk | Save results resources to disk.
Public method | PrependMessage | Prepend a specific message to the log.
Public method | RecalculateStepResults |
Public method | RemoveLastStepResult |
Public method | SaveTo |
Public method | SetStartTime | Sets the start time of the execution of this test // TODO: add to persistence
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


AddDataIterationResult Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AddDataIterationResult Method
TestResult Class See Also Send Feedback
Adds a data iteration result

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddDataIterationResult(
    DataIterationResult result
)
Visual Basic
Public Sub AddDataIterationResult ( _
    result As DataIterationResult _
)
Visual C++
public:
void AddDataIterationResult(
    DataIterationResult^ result
)

Parameters

result
Type: ArtOfTest.WebAii.Design.Execution..::..DataIterationResult
The result to add

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


AddStepResult Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AddStepResult Method
TestResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddStepResult(AutomationStepResult) |
Public method | AddStepResult(AutomationStepResult, Boolean) | Add an automation step result to this test.

See Also

TestResult Class
TestResult Members
ArtOfTest.WebAii.Design.Execution Namespace


AddStepResult Method (AutomationStepResult)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AddStepResult Method (AutomationStepResult)
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.AddStepResult(ArtOfTest.WebAii.Design.AutomationStepResult)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddStepResult(
    AutomationStepResult stepResult
)
Visual Basic
Public Sub AddStepResult ( _
    stepResult As AutomationStepResult _
)
Visual C++
public:
void AddStepResult(
    AutomationStepResult^ stepResult
)

Parameters

stepResult
Type: ArtOfTest.WebAii.Design..::..AutomationStepResult

[Missing <param name="stepResult"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.AddStepResult(ArtOfTest.WebAii.Design.AutomationStepResult)"]

See Also

TestResult Class
AddStepResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


AddStepResult Method (AutomationStepResult, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AddStepResult Method (AutomationStepResult, Boolean)
TestResult Class See Also Send Feedback
Add an automation step result to this test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddStepResult(
    AutomationStepResult stepResult,
    bool appendMessage
)
Visual Basic
Public Sub AddStepResult ( _
    stepResult As AutomationStepResult, _
    appendMessage As Boolean _
)
Visual C++
public:
void AddStepResult(
    AutomationStepResult^ stepResult,
    bool appendMessage
)

Parameters

stepResult
Type: ArtOfTest.WebAii.Design..::..AutomationStepResult
The result to add.
appendMessage
Type: System..::..Boolean

[Missing <param name="appendMessage"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.AddStepResult(ArtOfTest.WebAii.Design.AutomationStepResult,System.Boolean)"]

See Also

TestResult Class
AddStepResult Overload
ArtOfTest.WebAii.Design.Execution Namespace


AppendMessage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AppendMessage Method
TestResult Class See Also Send Feedback
Appends a messsage to the result.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendMessage(
    string message
)
Visual Basic
Public Sub AppendMessage ( _
    message As String _
)
Visual C++
public:
void AppendMessage(
    String^ message
)

Parameters

message
Type: System..::..String
The message to append.

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


AppendOverallResult Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AppendOverallResult Method
TestResult Class See Also Send Feedback
Append the overall result of this test execution.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendOverallResult()
Visual Basic
Public Sub AppendOverallResult
Visual C++
public:
void AppendOverallResult()

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


AppendSeparatorLine Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AppendSeparatorLine Method
TestResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AppendSeparatorLine()()()() | Append a default separator line.
Public method | AppendSeparatorLine(Char, Int32) | Append a separator to the result

See Also

TestResult Class
TestResult Members
ArtOfTest.WebAii.Design.Execution Namespace


AppendSeparatorLine Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AppendSeparatorLine Method
TestResult Class See Also Send Feedback
Append a default separator line.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendSeparatorLine()
Visual Basic
Public Sub AppendSeparatorLine
Visual C++
public:
void AppendSeparatorLine()

See Also

TestResult Class
AppendSeparatorLine Overload
ArtOfTest.WebAii.Design.Execution Namespace


AppendSeparatorLine Method (Char, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AppendSeparatorLine Method (Char, Int32)
TestResult Class See Also Send Feedback
Append a separator to the result

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendSeparatorLine(
    char repeatChar,
    int count
)
Visual Basic
Public Sub AppendSeparatorLine ( _
    repeatChar As Char, _
    count As Integer _
)
Visual C++
public:
void AppendSeparatorLine(
    wchar_t repeatChar,
    int count
)

Parameters

repeatChar
Type: System..::..Char
The repeat char to use for the separator line.
count
Type: System..::..Int32
Number of characters to join

See Also

TestResult Class
AppendSeparatorLine Overload
ArtOfTest.WebAii.Design.Execution Namespace


ExportToResultFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..ExportToResultFile Method
TestResult Class See Also Send Feedback
Exports the test result into a Test Studio run result file.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ExportToResultFile(
    string path,
    string name
)
Visual Basic
Public Function ExportToResultFile ( _
    path As String, _
    name As String _
) As Boolean
Visual C++
public:
bool ExportToResultFile(
    String^ path,
    String^ name
)

Parameters

path
Type: System..::..String
The path to the result file.
name
Type: System..::..String
The name of the result file.

Return Value

True for success, false otherwise.

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


LoadFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..LoadFrom Method
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void LoadFrom(
    XmlStoreNode store
)
Visual Basic
Public Overridable Sub LoadFrom ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void LoadFrom(
    XmlStoreNode^ store
)

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.LoadFrom(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


OnPropertyChanged Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..OnPropertyChanged Method
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.OnPropertyChanged(System.String)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected internal virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic
Protected Friend Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)
Visual C++
protected public:
virtual void OnPropertyChanged(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String

[Missing <param name="propertyName"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.OnPropertyChanged(System.String)"]

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


PersistTestFailureResourcesOnDisk Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..PersistTestFailureResourcesOnDisk Method
TestResult Class See Also Send Feedback
Save results resources to disk.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void PersistTestFailureResourcesOnDisk(
    string projectResultsPath,
    string resourceFolder
)
Visual Basic
Public Sub PersistTestFailureResourcesOnDisk ( _
    projectResultsPath As String, _
    resourceFolder As String _
)
Visual C++
public:
void PersistTestFailureResourcesOnDisk(
    String^ projectResultsPath,
    String^ resourceFolder
)

Parameters

projectResultsPath
Type: System..::..String

[Missing <param name="projectResultsPath"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.PersistTestFailureResourcesOnDisk(System.String,System.String)"]

resourceFolder
Type: System..::..String

[Missing <param name="resourceFolder"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.PersistTestFailureResourcesOnDisk(System.String,System.String)"]

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


PrependMessage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..PrependMessage Method
TestResult Class See Also Send Feedback
Prepend a specific message to the log.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void PrependMessage(
    string message
)
Visual Basic
Public Sub PrependMessage ( _
    message As String _
)
Visual C++
public:
void PrependMessage(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.PrependMessage(System.String)"]

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RecalculateStepResults Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..RecalculateStepResults Method
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.RecalculateStepResults"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RecalculateStepResults()
Visual Basic
Public Sub RecalculateStepResults
Visual C++
public:
void RecalculateStepResults()

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RemoveLastStepResult Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..RemoveLastStepResult Method
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.RemoveLastStepResult"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveLastStepResult()
Visual Basic
Public Sub RemoveLastStepResult
Visual C++
public:
void RemoveLastStepResult()

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SaveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..SaveTo Method
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SaveTo(
    XmlStoreNode store
)
Visual Basic
Public Sub SaveTo ( _
    store As XmlStoreNode _
)
Visual C++
public:
virtual void SaveTo(
    XmlStoreNode^ store
) sealed

Parameters

store
Type: XmlStoreNode

[Missing <param name="store"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestResult.SaveTo(ArtOfTest.Common.Serialization.XmlStoreNode)"]

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SetStartTime Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..SetStartTime Method
TestResult Class See Also Send Feedback
Sets the start time of the execution of this test // TODO: add to persistence

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetStartTime()
Visual Basic
Public Sub SetStartTime
Visual C++
public:
void SetStartTime()

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult Properties
TestResult Class See Also Send Feedback

The TestResult type exposes the following members.

Properties

 | Name | Description
Public property | AllTestStepCount | Calculate all test step count.
Public property | CommitedBy |
Public property | CurrentVersion |
Public property | DataIterationResults | Gets the data iteration results when IsDataDrivenResult is set to true
Public property | Duration | Gets the duration of test execution.
Public property | EndTime | Gets the time when the test ended execution.
Public property | ExecutingTestStepCount |
Public property | ExeType |
Public property | FailureException | Gets the execution exception causing the test failure.
Public property | FirstFailedStepComment |
Public property | IsDataDrivenResult | Gets whether the result contains data driven results
Public property | IsManualResult |
Public property | Message | Gets/Sets the message of this result.
Public property | NotRunStepDescriptions | Gets the descriptions of the not executed steps so that we don't have to get the test behind this result in order to show all descriptions.
Public property | Parent |
Public property | PercentComplete |
Public property | ProfilerResultsId | The permanent ID of the profiler results file, for verification and in case the path changes.
Public property | ProfilerResultsPath | The location on disk of the Profiler database associated with this test run. This is not the final path etched in stone, rather it is used more like a cached value to prevent a long enumeration. If the path is invalid, the enumeration will have to take place regardless.
Public property | ProjectPath | Gets the project path that contains this test.
Public property | Result | Gets/Sets the result type of this result object.
Public property | RootName |
Public property | SeparatorLineCharCount |
Public property | StartTime | Gets the time when the test started execution
Public property | StepResults | Gets the AutomationStep results
Public property | TestDescription | The test description to help users in case of failure.
Public property | TestId | Gets or sets the test unique Id behind this result.
Public property | TestName | Gets the test name within the project.
Public property | TestOwner | The test owner to present in case of failure.
Public property | TestPath | Gets the test path within the project.
Public property | TotalNumberOfNotRunSteps | Gets the total number of not run automation steps.
Public property | TotalPassedSteps | Gets the total number of passed automation steps.
Public property | VersionGroupKey |
Public property | XmlBlob |

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


AllTestStepCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..AllTestStepCount Property
TestResult Class See Also Send Feedback
Calculate all test step count.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AllTestStepCount { get; }
Visual Basic
Public ReadOnly Property AllTestStepCount As Integer
    Get
Visual C++
public:
property int AllTestStepCount {
    int get ();
}

Field Value

All test step count.

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CommitedBy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..CommitedBy Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.CommitedBy"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string CommitedBy { get; set; }
Visual Basic
Public Property CommitedBy As String
    Get
    Set
Visual C++
public:
property String^ CommitedBy {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


CurrentVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..CurrentVersion Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.CurrentVersion"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Version CurrentVersion { get; }
Visual Basic
Public ReadOnly Property CurrentVersion As Version
    Get
Visual C++
public:
virtual property Version^ CurrentVersion {
    Version^ get () sealed;
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


DataIterationResults Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..DataIterationResults Property
TestResult Class See Also Send Feedback
Gets the data iteration results when IsDataDrivenResult is set to true

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<DataIterationResult> DataIterationResults { get; }
Visual Basic
Public ReadOnly Property DataIterationResults As IList(Of DataIterationResult)
    Get
Visual C++
public:
property IList<DataIterationResult^>^ DataIterationResults {
    IList<DataIterationResult^>^ get ();
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Duration Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..Duration Property
TestResult Class See Also Send Feedback
Gets the duration of test execution.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TimeSpan Duration { get; }
Visual Basic
Public ReadOnly Property Duration As TimeSpan
    Get
Visual C++
public:
property TimeSpan Duration {
    TimeSpan get ();
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


EndTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..EndTime Property
TestResult Class See Also Send Feedback
Gets the time when the test ended execution.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime EndTime { get; internal set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Friend Set
Visual C++
public:
property DateTime EndTime {
    DateTime get ();
    internal: void set (DateTime value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutingTestStepCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..ExecutingTestStepCount Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.ExecutingTestStepCount"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ExecutingTestStepCount { get; internal set; }
Visual Basic
Public Property ExecutingTestStepCount As Integer
    Get
    Friend Set
Visual C++
public:
property int ExecutingTestStepCount {
    int get ();
    internal: void set (int value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ExeType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..ExeType Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.ExeType"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecutionType ExeType { get; set; }
Visual Basic
Public Property ExeType As ExecutionType
    Get
    Set
Visual C++
public:
property ExecutionType ExeType {
    ExecutionType get ();
    void set (ExecutionType value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


FailureException Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..FailureException Property
TestResult Class See Also Send Feedback
Gets the execution exception causing the test failure.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecutionException FailureException { get; internal set; }
Visual Basic
Public Property FailureException As ExecutionException
    Get
    Friend Set
Visual C++
public:
property ExecutionException^ FailureException {
    ExecutionException^ get ();
    internal: void set (ExecutionException^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


FirstFailedStepComment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..FirstFailedStepComment Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.FirstFailedStepComment"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FirstFailedStepComment { get; }
Visual Basic
Public ReadOnly Property FirstFailedStepComment As String
    Get
Visual C++
public:
property String^ FirstFailedStepComment {
    String^ get ();
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


IsDataDrivenResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..IsDataDrivenResult Property
TestResult Class See Also Send Feedback
Gets whether the result contains data driven results

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDataDrivenResult { get; internal set; }
Visual Basic
Public Property IsDataDrivenResult As Boolean
    Get
    Friend Set
Visual C++
public:
property bool IsDataDrivenResult {
    bool get ();
    internal: void set (bool value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


IsManualResult Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..IsManualResult Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.IsManualResult"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsManualResult { get; set; }
Visual Basic
Public Property IsManualResult As Boolean
    Get
    Set
Visual C++
public:
property bool IsManualResult {
    bool get ();
    void set (bool value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Message Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..Message Property
TestResult Class See Also Send Feedback
Gets/Sets the message of this result.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set
Visual C++
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


NotRunStepDescriptions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..NotRunStepDescriptions Property
TestResult Class See Also Send Feedback
Gets the descriptions of the not executed steps so that we don't have to get the test behind this result in order to show all descriptions.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<string> NotRunStepDescriptions { get; }
Visual Basic
Public ReadOnly Property NotRunStepDescriptions As IList(Of String)
    Get
Visual C++
public:
property IList<String^>^ NotRunStepDescriptions {
    IList<String^>^ get ();
}

Field Value

The not run step descriptions.

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Parent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..Parent Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.Parent"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RunResult Parent { get; set; }
Visual Basic
Public Property Parent As RunResult
    Get
    Set
Visual C++
public:
property RunResult^ Parent {
    RunResult^ get ();
    void set (RunResult^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


PercentComplete Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..PercentComplete Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.PercentComplete"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public float PercentComplete { get; }
Visual Basic
Public ReadOnly Property PercentComplete As Single
    Get
Visual C++
public:
property float PercentComplete {
    float get ();
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ProfilerResultsId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..ProfilerResultsId Property
TestResult Class See Also Send Feedback
The permanent ID of the profiler results file, for verification and in case the path changes.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid ProfilerResultsId { get; set; }
Visual Basic
Public Property ProfilerResultsId As Guid
    Get
    Set
Visual C++
public:
property Guid ProfilerResultsId {
    Guid get ();
    void set (Guid value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ProfilerResultsPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..ProfilerResultsPath Property
TestResult Class See Also Send Feedback
The location on disk of the Profiler database associated with this test run. This is not the final path etched in stone, rather it is used more like a cached value to prevent a long enumeration. If the path is invalid, the enumeration will have to take place regardless.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ProfilerResultsPath { get; set; }
Visual Basic
Public Property ProfilerResultsPath As String
    Get
    Set
Visual C++
public:
property String^ ProfilerResultsPath {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


ProjectPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..ProjectPath Property
TestResult Class See Also Send Feedback
Gets the project path that contains this test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ProjectPath { get; set; }
Visual Basic
Public Property ProjectPath As String
    Get
    Set
Visual C++
public:
property String^ ProjectPath {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


Result Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..Result Property
TestResult Class See Also Send Feedback
Gets/Sets the result type of this result object.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ResultType Result { get; set; }
Visual Basic
Public Property Result As ResultType
    Get
    Set
Visual C++
public:
property ResultType Result {
    ResultType get ();
    void set (ResultType value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


RootName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..RootName Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.RootName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RootName { get; }
Visual Basic
Public ReadOnly Property RootName As String
    Get
Visual C++
public:
virtual property String^ RootName {
    String^ get () sealed;
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


SeparatorLineCharCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..SeparatorLineCharCount Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.SeparatorLineCharCount"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SeparatorLineCharCount { get; set; }
Visual Basic
Public Property SeparatorLineCharCount As Integer
    Get
    Set
Visual C++
public:
property int SeparatorLineCharCount {
    int get ();
    void set (int value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


StartTime Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..StartTime Property
TestResult Class See Also Send Feedback
Gets the time when the test started execution

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime StartTime { get; internal set; }
Visual Basic
Public Property StartTime As DateTime
    Get
    Friend Set
Visual C++
public:
property DateTime StartTime {
    DateTime get ();
    internal: void set (DateTime value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


StepResults Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..StepResults Property
TestResult Class See Also Send Feedback
Gets the AutomationStep results

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<AutomationStepResult> StepResults { get; }
Visual Basic
Public ReadOnly Property StepResults As IList(Of AutomationStepResult)
    Get
Visual C++
public:
property IList<AutomationStepResult^>^ StepResults {
    IList<AutomationStepResult^>^ get ();
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestDescription Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..TestDescription Property
TestResult Class See Also Send Feedback
The test description to help users in case of failure.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestDescription { get; set; }
Visual Basic
Public Property TestDescription As String
    Get
    Set
Visual C++
public:
property String^ TestDescription {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..TestId Property
TestResult Class See Also Send Feedback
Gets or sets the test unique Id behind this result.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestId { get; set; }
Visual Basic
Public Property TestId As String
    Get
    Set
Visual C++
public:
property String^ TestId {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..TestName Property
TestResult Class See Also Send Feedback
Gets the test name within the project.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestName { get; set; }
Visual Basic
Public Property TestName As String
    Get
    Set
Visual C++
public:
property String^ TestName {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestOwner Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..TestOwner Property
TestResult Class See Also Send Feedback
The test owner to present in case of failure.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestOwner { get; set; }
Visual Basic
Public Property TestOwner As String
    Get
    Set
Visual C++
public:
property String^ TestOwner {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..TestPath Property
TestResult Class See Also Send Feedback
Gets the test path within the project.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TestPath { get; set; }
Visual Basic
Public Property TestPath As String
    Get
    Set
Visual C++
public:
property String^ TestPath {
    String^ get ();
    void set (String^ value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TotalNumberOfNotRunSteps Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..TotalNumberOfNotRunSteps Property
TestResult Class See Also Send Feedback
Gets the total number of not run automation steps.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TotalNumberOfNotRunSteps { get; internal set; }
Visual Basic
Public Property TotalNumberOfNotRunSteps As Integer
    Get
    Friend Set
Visual C++
public:
property int TotalNumberOfNotRunSteps {
    int get ();
    internal: void set (int value);
}

Field Value

The total number of not run steps.

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TotalPassedSteps Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..TotalPassedSteps Property
TestResult Class See Also Send Feedback
Gets the total number of passed automation steps.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TotalPassedSteps { get; internal set; }
Visual Basic
Public Property TotalPassedSteps As Integer
    Get
    Friend Set
Visual C++
public:
property int TotalPassedSteps {
    int get ();
    internal: void set (int value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


VersionGroupKey Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..VersionGroupKey Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.VersionGroupKey"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid VersionGroupKey { get; set; }
Visual Basic
Public Property VersionGroupKey As Guid
    Get
    Set
Visual C++
public:
property Guid VersionGroupKey {
    Guid get ();
    void set (Guid value);
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


XmlBlob Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlBlob Property
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestResult.XmlBlob"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlBlob XmlBlob { get; set; }
Visual Basic
Public Property XmlBlob As XmlBlob
    Get
    Set
Visual C++
public:
virtual property XmlBlob^ XmlBlob {
    XmlBlob^ get () sealed;
    void set (XmlBlob^ value) sealed;
}

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult Events
TestResult Class See Also Send Feedback

The TestResult type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged |

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


PropertyChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..PropertyChanged Event
TestResult Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.Execution.TestResult.PropertyChanged"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

TestResult Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult.XmlDataKeys Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys Members
TestResult..::..XmlDataKeys Class Constructors Methods Fields See Also Send Feedback

Class representing a test result.

The TestResult..::..XmlDataKeys type exposes the following members.

Constructors

 | Name | Description
Public method | TestResult..::..XmlDataKeys | Initializes a new instance of the TestResult..::..XmlDataKeys class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AutomationStepResults |
CommitedBy |
DataIterationResults |
EndTime |
ExecutingTestStepCount |
ExecutionType |
FailureException |
IsDataDrivenResult |
NotRunStepDescriptions |
PerStepMessages |
ProfilerResultsPath |
ProjectPath |
ResultType |
SeparatorLineCharCount |
StartTime |
TestDescription |
TestId |
TestName |
TestOwner |
TestPath |
TotalNumberOfNotRunSteps |
TotalNumberOfPassedSteps |
VersionGroupKey |

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult.XmlDataKeys Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys Constructor
TestResult..::..XmlDataKeys Class See Also Send Feedback
Initializes a new instance of the TestResult..::..XmlDataKeys class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlDataKeys()
Visual Basic
Public Sub New
Visual C++
public:
XmlDataKeys()

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult.XmlDataKeys Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys Fields
TestResult..::..XmlDataKeys Class See Also Send Feedback

The TestResult..::..XmlDataKeys type exposes the following members.

Fields

Name | Description
AutomationStepResults |
CommitedBy |
DataIterationResults |
EndTime |
ExecutingTestStepCount |
ExecutionType |
FailureException |
IsDataDrivenResult |
NotRunStepDescriptions |
PerStepMessages |
ProfilerResultsPath |
ProjectPath |
ResultType |
SeparatorLineCharCount |
StartTime |
TestDescription |
TestId |
TestName |
TestOwner |
TestPath |
TotalNumberOfNotRunSteps |
TotalNumberOfPassedSteps |
VersionGroupKey |

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


AutomationStepResults Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..AutomationStepResults Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.AutomationStepResults"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string AutomationStepResults
Visual Basic
Public Const AutomationStepResults As String
Visual C++
public:
literal String^ AutomationStepResults

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


CommitedBy Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..CommitedBy Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.CommitedBy"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string CommitedBy
Visual Basic
Public Const CommitedBy As String
Visual C++
public:
literal String^ CommitedBy

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


DataIterationResults Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..DataIterationResults Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.DataIterationResults"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string DataIterationResults
Visual Basic
Public Const DataIterationResults As String
Visual C++
public:
literal String^ DataIterationResults

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


EndTime Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..EndTime Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.EndTime"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string EndTime
Visual Basic
Public Const EndTime As String
Visual C++
public:
literal String^ EndTime

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutingTestStepCount Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..ExecutingTestStepCount Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.ExecutingTestStepCount"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string ExecutingTestStepCount
Visual Basic
Public Const ExecutingTestStepCount As String
Visual C++
public:
literal String^ ExecutingTestStepCount

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


ExecutionType Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..ExecutionType Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.ExecutionType"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string ExecutionType
Visual Basic
Public Const ExecutionType As String
Visual C++
public:
literal String^ ExecutionType

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


FailureException Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..FailureException Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.FailureException"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string FailureException
Visual Basic
Public Const FailureException As String
Visual C++
public:
literal String^ FailureException

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


IsDataDrivenResult Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..IsDataDrivenResult Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.IsDataDrivenResult"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string IsDataDrivenResult
Visual Basic
Public Const IsDataDrivenResult As String
Visual C++
public:
literal String^ IsDataDrivenResult

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


NotRunStepDescriptions Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..NotRunStepDescriptions Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.NotRunStepDescriptions"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string NotRunStepDescriptions
Visual Basic
Public Const NotRunStepDescriptions As String
Visual C++
public:
literal String^ NotRunStepDescriptions

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


PerStepMessages Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..PerStepMessages Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.PerStepMessages"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string PerStepMessages
Visual Basic
Public Const PerStepMessages As String
Visual C++
public:
literal String^ PerStepMessages

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


ProfilerResultsPath Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..ProfilerResultsPath Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.ProfilerResultsPath"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string ProfilerResultsPath
Visual Basic
Public Const ProfilerResultsPath As String
Visual C++
public:
literal String^ ProfilerResultsPath

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


ProjectPath Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..ProjectPath Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.ProjectPath"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string ProjectPath
Visual Basic
Public Const ProjectPath As String
Visual C++
public:
literal String^ ProjectPath

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


ResultType Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..ResultType Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.ResultType"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string ResultType
Visual Basic
Public Const ResultType As String
Visual C++
public:
literal String^ ResultType

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


SeparatorLineCharCount Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..SeparatorLineCharCount Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.SeparatorLineCharCount"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string SeparatorLineCharCount
Visual Basic
Public Const SeparatorLineCharCount As String
Visual C++
public:
literal String^ SeparatorLineCharCount

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


StartTime Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..StartTime Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.StartTime"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string StartTime
Visual Basic
Public Const StartTime As String
Visual C++
public:
literal String^ StartTime

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestDescription Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..TestDescription Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.TestDescription"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TestDescription
Visual Basic
Public Const TestDescription As String
Visual C++
public:
literal String^ TestDescription

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..TestId Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.TestId"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TestId
Visual Basic
Public Const TestId As String
Visual C++
public:
literal String^ TestId

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestName Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..TestName Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.TestName"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TestName
Visual Basic
Public Const TestName As String
Visual C++
public:
literal String^ TestName

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestOwner Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..TestOwner Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.TestOwner"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TestOwner
Visual Basic
Public Const TestOwner As String
Visual C++
public:
literal String^ TestOwner

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestPath Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..TestPath Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.TestPath"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TestPath
Visual Basic
Public Const TestPath As String
Visual C++
public:
literal String^ TestPath

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TotalNumberOfNotRunSteps Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..TotalNumberOfNotRunSteps Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.TotalNumberOfNotRunSteps"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TotalNumberOfNotRunSteps
Visual Basic
Public Const TotalNumberOfNotRunSteps As String
Visual C++
public:
literal String^ TotalNumberOfNotRunSteps

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TotalNumberOfPassedSteps Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..TotalNumberOfPassedSteps Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.TotalNumberOfPassedSteps"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string TotalNumberOfPassedSteps
Visual Basic
Public Const TotalNumberOfPassedSteps As String
Visual C++
public:
literal String^ TotalNumberOfPassedSteps

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


VersionGroupKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys..::..VersionGroupKey Field
TestResult..::..XmlDataKeys Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Design.Execution.TestResult.XmlDataKeys.VersionGroupKey"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const string VersionGroupKey
Visual Basic
Public Const VersionGroupKey As String
Visual C++
public:
literal String^ VersionGroupKey

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestResult.XmlDataKeys Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestResult..::..XmlDataKeys Methods
TestResult..::..XmlDataKeys Class See Also Send Feedback

The TestResult..::..XmlDataKeys type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestResult..::..XmlDataKeys Class
ArtOfTest.WebAii.Design.Execution Namespace


TestUpdatePackage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestUpdatePackage Members
TestUpdatePackage Class Constructors Methods Properties See Also Send Feedback

The TestUpdatePackage type exposes the following members.

Constructors

 | Name | Description
Public method | TestUpdatePackage | Initializes a new instance of the TestUpdatePackage class

Methods

 | Name | Description
Public method | AddUpdate |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize each update info with its corresponding test.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Updates |

See Also

TestUpdatePackage Class
ArtOfTest.WebAii.Design.Execution Namespace


TestUpdatePackage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestUpdatePackage Constructor
TestUpdatePackage Class See Also Send Feedback
Initializes a new instance of the TestUpdatePackage class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestUpdatePackage()
Visual Basic
Public Sub New
Visual C++
public:
TestUpdatePackage()

See Also

TestUpdatePackage Class
ArtOfTest.WebAii.Design.Execution Namespace


TestUpdatePackage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestUpdatePackage Methods
TestUpdatePackage Class See Also Send Feedback

The TestUpdatePackage type exposes the following members.

Methods

 | Name | Description
Public method | AddUpdate |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize each update info with its corresponding test.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestUpdatePackage Class
ArtOfTest.WebAii.Design.Execution Namespace


AddUpdate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestUpdatePackage..::..AddUpdate Method
TestUpdatePackage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestUpdatePackage.AddUpdate(ArtOfTest.WebAii.Design.Execution.UpdateInfo)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddUpdate(
    UpdateInfo findUpdate
)
Visual Basic
Public Sub AddUpdate ( _
    findUpdate As UpdateInfo _
)
Visual C++
public:
void AddUpdate(
    UpdateInfo^ findUpdate
)

Parameters

findUpdate
Type: ArtOfTest.WebAii.Design.Execution..::..UpdateInfo

[Missing <param name="findUpdate"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestUpdatePackage.AddUpdate(ArtOfTest.WebAii.Design.Execution.UpdateInfo)"]

See Also

TestUpdatePackage Class
ArtOfTest.WebAii.Design.Execution Namespace


Initialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestUpdatePackage..::..Initialize Method
TestUpdatePackage Class See Also Send Feedback
Initialize each update info with its corresponding test.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    Project project
)
Visual Basic
Public Sub Initialize ( _
    project As Project _
)
Visual C++
public:
void Initialize(
    Project^ project
)

Parameters

project
Type: Project

[Missing <param name="project"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.TestUpdatePackage.Initialize(ArtOfTest.WebAii.Design.ProjectModel.Project)"]

See Also

TestUpdatePackage Class
ArtOfTest.WebAii.Design.Execution Namespace


TestUpdatePackage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestUpdatePackage Properties
TestUpdatePackage Class See Also Send Feedback

The TestUpdatePackage type exposes the following members.

Properties

 | Name | Description
Public property | Updates |

See Also

TestUpdatePackage Class
ArtOfTest.WebAii.Design.Execution Namespace


Updates Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestUpdatePackage..::..Updates Property
TestUpdatePackage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.TestUpdatePackage.Updates"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<UpdateInfo> Updates { get; }
Visual Basic
Public ReadOnly Property Updates As IList(Of UpdateInfo)
    Get
Visual C++
public:
property IList<UpdateInfo^>^ Updates {
    IList<UpdateInfo^>^ get ();
}

See Also

TestUpdatePackage Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdateInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo Members
UpdateInfo Class Constructors Methods Properties Events See Also Send Feedback

The UpdateInfo type exposes the following members.

Constructors

 | Name | Description
Public method | UpdateInfo | Initializes a new instance of the UpdateInfo class

Methods

 | Name | Description
Public method | ApplyUpdate |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeTestAndStep | Given the actual project object, initialize the target Test/Step
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnPropertyChanged |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplyError |
Public property | Description |
Public property | DoApplyUpdate |
Public property | Initialized |
Public property | StepOrder |
Public property | TargetStep |
Public property | TargetTest |
Public property | TestId |
Public property | UpdateTypeDescription |

Events

 | Name | Description
Public event | PropertyChanged |

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdateInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo Constructor
UpdateInfo Class See Also Send Feedback
Initializes a new instance of the UpdateInfo class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UpdateInfo(
    Guid testId,
    int stepOrder
)
Visual Basic
Public Sub New ( _
    testId As Guid, _
    stepOrder As Integer _
)
Visual C++
public:
UpdateInfo(
    Guid testId,
    int stepOrder
)

Parameters

testId
Type: System..::..Guid

[Missing <param name="testId"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.UpdateInfo.#ctor(System.Guid,System.Int32)"]

stepOrder
Type: System..::..Int32

[Missing <param name="stepOrder"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.UpdateInfo.#ctor(System.Guid,System.Int32)"]

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdateInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo Methods
UpdateInfo Class See Also Send Feedback

The UpdateInfo type exposes the following members.

Methods

 | Name | Description
Public method | ApplyUpdate |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeTestAndStep | Given the actual project object, initialize the target Test/Step
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnPropertyChanged |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


ApplyUpdate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..ApplyUpdate Method
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.UpdateInfo.ApplyUpdate"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract void ApplyUpdate()
Visual Basic
Public MustOverride Sub ApplyUpdate
Visual C++
public:
virtual void ApplyUpdate() abstract

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


InitializeTestAndStep Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..InitializeTestAndStep Method
UpdateInfo Class See Also Send Feedback
Given the actual project object, initialize the target Test/Step

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void InitializeTestAndStep(
    Project project
)
Visual Basic
Public Sub InitializeTestAndStep ( _
    project As Project _
)
Visual C++
public:
void InitializeTestAndStep(
    Project^ project
)

Parameters

project
Type: Project

[Missing <param name="project"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.UpdateInfo.InitializeTestAndStep(ArtOfTest.WebAii.Design.ProjectModel.Project)"]

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


OnPropertyChanged Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..OnPropertyChanged Method
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.UpdateInfo.OnPropertyChanged(System.String)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void OnPropertyChanged(
    string PropertyName
)
Visual Basic
Public Sub OnPropertyChanged ( _
    PropertyName As String _
)
Visual C++
public:
void OnPropertyChanged(
    String^ PropertyName
)

Parameters

PropertyName
Type: System..::..String

[Missing <param name="PropertyName"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.UpdateInfo.OnPropertyChanged(System.String)"]

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdateInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo Properties
UpdateInfo Class See Also Send Feedback

The UpdateInfo type exposes the following members.

Properties

 | Name | Description
Public property | ApplyError |
Public property | Description |
Public property | DoApplyUpdate |
Public property | Initialized |
Public property | StepOrder |
Public property | TargetStep |
Public property | TargetTest |
Public property | TestId |
Public property | UpdateTypeDescription |

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


ApplyError Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..ApplyError Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.ApplyError"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ApplyError { get; set; }
Visual Basic
Public Property ApplyError As String
    Get
    Set
Visual C++
public:
property String^ ApplyError {
    String^ get ();
    void set (String^ value);
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


Description Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..Description Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.Description"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


DoApplyUpdate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..DoApplyUpdate Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.DoApplyUpdate"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool DoApplyUpdate { get; set; }
Visual Basic
Public Property DoApplyUpdate As Boolean
    Get
    Set
Visual C++
public:
property bool DoApplyUpdate {
    bool get ();
    void set (bool value);
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


Initialized Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..Initialized Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.Initialized"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Initialized { get; }
Visual Basic
Public ReadOnly Property Initialized As Boolean
    Get
Visual C++
public:
property bool Initialized {
    bool get ();
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


StepOrder Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..StepOrder Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.StepOrder"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int StepOrder { get; set; }
Visual Basic
Public Property StepOrder As Integer
    Get
    Set
Visual C++
public:
property int StepOrder {
    int get ();
    void set (int value);
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


TargetStep Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..TargetStep Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.TargetStep"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationStep TargetStep { get; }
Visual Basic
Public ReadOnly Property TargetStep As AutomationStep
    Get
Visual C++
public:
property AutomationStep^ TargetStep {
    AutomationStep^ get ();
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


TargetTest Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..TargetTest Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.TargetTest"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Test TargetTest { get; }
Visual Basic
Public ReadOnly Property TargetTest As Test
    Get
Visual C++
public:
property Test^ TargetTest {
    Test^ get ();
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


TestId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..TestId Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.TestId"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid TestId { get; set; }
Visual Basic
Public Property TestId As Guid
    Get
    Set
Visual C++
public:
property Guid TestId {
    Guid get ();
    void set (Guid value);
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdateTypeDescription Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..UpdateTypeDescription Property
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.UpdateInfo.UpdateTypeDescription"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract string UpdateTypeDescription { get; }
Visual Basic
Public MustOverride ReadOnly Property UpdateTypeDescription As String
    Get
Visual C++
public:
virtual property String^ UpdateTypeDescription {
    String^ get () abstract;
}

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdateInfo Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo Events
UpdateInfo Class See Also Send Feedback

The UpdateInfo type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged |

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


PropertyChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UpdateInfo..::..PropertyChanged Event
UpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Design.Execution.UpdateInfo.PropertyChanged"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

UpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


VerificationUpdateInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VerificationUpdateInfo Members
VerificationUpdateInfo Class Constructors Methods Properties Events See Also Send Feedback

The VerificationUpdateInfo type exposes the following members.

Constructors

 | Name | Description
Public method | VerificationUpdateInfo | Initializes a new instance of the VerificationUpdateInfo class

Methods

 | Name | Description
Public method | ApplyUpdate | (Overrides UpdateInfo..::..ApplyUpdate()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeTestAndStep | Given the actual project object, initialize the target Test/Step (Inherited from UpdateInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnPropertyChanged | (Inherited from UpdateInfo.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApplyError | (Inherited from UpdateInfo.)
Public property | Description | (Inherited from UpdateInfo.)
Public property | DoApplyUpdate | (Inherited from UpdateInfo.)
Public property | Initialized | (Inherited from UpdateInfo.)
Public property | NewDescriptor |
Public property | StepOrder | (Inherited from UpdateInfo.)
Public property | TargetStep | (Inherited from UpdateInfo.)
Public property | TargetTest | (Inherited from UpdateInfo.)
Public property | TestId | (Inherited from UpdateInfo.)
Public property | UpdateTypeDescription | (Overrides UpdateInfo..::..UpdateTypeDescription.)

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from UpdateInfo.)

See Also

VerificationUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


VerificationUpdateInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VerificationUpdateInfo Constructor
VerificationUpdateInfo Class See Also Send Feedback
Initializes a new instance of the VerificationUpdateInfo class

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VerificationUpdateInfo(
    Guid testId,
    int stepOrder,
    VerificationDescriptor descriptor
)
Visual Basic
Public Sub New ( _
    testId As Guid, _
    stepOrder As Integer, _
    descriptor As VerificationDescriptor _
)
Visual C++
public:
VerificationUpdateInfo(
    Guid testId,
    int stepOrder,
    VerificationDescriptor^ descriptor
)

Parameters

testId
Type: System..::..Guid

[Missing <param name="testId"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VerificationUpdateInfo.#ctor(System.Guid,System.Int32,ArtOfTest.Common.Design.Extensibility.Descriptors.VerificationDescriptor)"]

stepOrder
Type: System..::..Int32

[Missing <param name="stepOrder"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VerificationUpdateInfo.#ctor(System.Guid,System.Int32,ArtOfTest.Common.Design.Extensibility.Descriptors.VerificationDescriptor)"]

descriptor
Type: VerificationDescriptor

[Missing <param name="descriptor"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VerificationUpdateInfo.#ctor(System.Guid,System.Int32,ArtOfTest.Common.Design.Extensibility.Descriptors.VerificationDescriptor)"]

See Also

VerificationUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


VerificationUpdateInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VerificationUpdateInfo Methods
VerificationUpdateInfo Class See Also Send Feedback

The VerificationUpdateInfo type exposes the following members.

Methods

 | Name | Description
Public method | ApplyUpdate | (Overrides UpdateInfo..::..ApplyUpdate()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeTestAndStep | Given the actual project object, initialize the target Test/Step (Inherited from UpdateInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnPropertyChanged | (Inherited from UpdateInfo.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VerificationUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


ApplyUpdate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VerificationUpdateInfo..::..ApplyUpdate Method
VerificationUpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VerificationUpdateInfo.ApplyUpdate"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void ApplyUpdate()
Visual Basic
Public Overrides Sub ApplyUpdate
Visual C++
public:
virtual void ApplyUpdate() override

See Also

VerificationUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


VerificationUpdateInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VerificationUpdateInfo Properties
VerificationUpdateInfo Class See Also Send Feedback

The VerificationUpdateInfo type exposes the following members.

Properties

 | Name | Description
Public property | ApplyError | (Inherited from UpdateInfo.)
Public property | Description | (Inherited from UpdateInfo.)
Public property | DoApplyUpdate | (Inherited from UpdateInfo.)
Public property | Initialized | (Inherited from UpdateInfo.)
Public property | NewDescriptor |
Public property | StepOrder | (Inherited from UpdateInfo.)
Public property | TargetStep | (Inherited from UpdateInfo.)
Public property | TargetTest | (Inherited from UpdateInfo.)
Public property | TestId | (Inherited from UpdateInfo.)
Public property | UpdateTypeDescription | (Overrides UpdateInfo..::..UpdateTypeDescription.)

See Also

VerificationUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


NewDescriptor Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VerificationUpdateInfo..::..NewDescriptor Property
VerificationUpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VerificationUpdateInfo.NewDescriptor"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VerificationDescriptor NewDescriptor { get; }
Visual Basic
Public ReadOnly Property NewDescriptor As VerificationDescriptor
    Get
Visual C++
public:
property VerificationDescriptor^ NewDescriptor {
    VerificationDescriptor^ get ();
}

See Also

VerificationUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


UpdateTypeDescription Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VerificationUpdateInfo..::..UpdateTypeDescription Property
VerificationUpdateInfo Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VerificationUpdateInfo.UpdateTypeDescription"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string UpdateTypeDescription { get; }
Visual Basic
Public Overrides ReadOnly Property UpdateTypeDescription As String
    Get
Visual C++
public:
virtual property String^ UpdateTypeDescription {
    String^ get () override;
}

See Also

VerificationUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


VerificationUpdateInfo Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VerificationUpdateInfo Events
VerificationUpdateInfo Class See Also Send Feedback

The VerificationUpdateInfo type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | (Inherited from UpdateInfo.)

See Also

VerificationUpdateInfo Class
ArtOfTest.WebAii.Design.Execution Namespace


VisualDebugger Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger Members
VisualDebugger Class Constructors Methods Properties See Also Send Feedback

The VisualDebugger type exposes the following members.

Constructors

 | Name | Description
Public method | VisualDebugger | Create the visual debugger

Methods

 | Name | Description
Public method | CaptureState |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RequestResume |
Public method | RequestStop()()()() |
Public method | RequestStop(String) |
Public method | ReRun |
Public method | SetDetail |
Public method | SetFocus |
Public method | SetMessage |
Public method | SetProgress |
Public method | ShowDiagnosticsUI | Show the disgnose UI for a failure.
Public method | ShowDomExplorer | Show the DOM Explorer
Public method | ShowTestLog | Show the test log
Public method | Step |
Public method | SubmitBug |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InBreakpoint |
Public property | IsDebugging | Whether the Debugger is enabled or not.
Public property | IsProfilingExecution |
Public property | IsReRunRequested |
Public property | IsResumeRequested |
Public property | IsStepMode |
Public property | IsStopRequested |
Public property | ResetSignal |

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


VisualDebugger Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger Constructor
VisualDebugger Class See Also Send Feedback
Create the visual debugger

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualDebugger(
    ExecutionContext context,
    DebuggerOptions options,
    TestType testType
)
Visual Basic
Public Sub New ( _
    context As ExecutionContext, _
    options As DebuggerOptions, _
    testType As TestType _
)
Visual C++
public:
VisualDebugger(
    ExecutionContext^ context,
    DebuggerOptions^ options,
    TestType testType
)

Parameters

context
Type: ArtOfTest.WebAii.Design.Execution..::..ExecutionContext

[Missing <param name="context"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.#ctor(ArtOfTest.WebAii.Design.Execution.ExecutionContext,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,ArtOfTest.Common.Design.Extensibility.TestType)"]

options
Type: ArtOfTest.WebAii.Design.Execution..::..DebuggerOptions

[Missing <param name="options"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.#ctor(ArtOfTest.WebAii.Design.Execution.ExecutionContext,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,ArtOfTest.Common.Design.Extensibility.TestType)"]

testType
Type: TestType

[Missing <param name="testType"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.#ctor(ArtOfTest.WebAii.Design.Execution.ExecutionContext,ArtOfTest.WebAii.Design.Execution.DebuggerOptions,ArtOfTest.Common.Design.Extensibility.TestType)"]

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


VisualDebugger Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger Methods
VisualDebugger Class See Also Send Feedback

The VisualDebugger type exposes the following members.

Methods

 | Name | Description
Public method | CaptureState |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RequestResume |
Public method | RequestStop()()()() |
Public method | RequestStop(String) |
Public method | ReRun |
Public method | SetDetail |
Public method | SetFocus |
Public method | SetMessage |
Public method | SetProgress |
Public method | ShowDiagnosticsUI | Show the disgnose UI for a failure.
Public method | ShowDomExplorer | Show the DOM Explorer
Public method | ShowTestLog | Show the test log
Public method | Step |
Public method | SubmitBug |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


CaptureState Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..CaptureState Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.CaptureState"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CaptureState()
Visual Basic
Public Sub CaptureState
Visual C++
public:
void CaptureState()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


RequestResume Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..RequestResume Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.RequestResume"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RequestResume()
Visual Basic
Public Sub RequestResume
Visual C++
public:
void RequestResume()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


RequestStop Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..RequestStop Method
VisualDebugger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RequestStop()()()() |
Public method | RequestStop(String) |

See Also

VisualDebugger Class
VisualDebugger Members
ArtOfTest.WebAii.Design.Execution Namespace


RequestStop Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..RequestStop Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.RequestStop"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RequestStop()
Visual Basic
Public Sub RequestStop
Visual C++
public:
void RequestStop()

See Also

VisualDebugger Class
RequestStop Overload
ArtOfTest.WebAii.Design.Execution Namespace


RequestStop Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..RequestStop Method (String)
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.RequestStop(System.String)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RequestStop(
    string pauseMessage
)
Visual Basic
Public Sub RequestStop ( _
    pauseMessage As String _
)
Visual C++
public:
void RequestStop(
    String^ pauseMessage
)

Parameters

pauseMessage
Type: System..::..String

[Missing <param name="pauseMessage"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.RequestStop(System.String)"]

See Also

VisualDebugger Class
RequestStop Overload
ArtOfTest.WebAii.Design.Execution Namespace


ReRun Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..ReRun Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.ReRun"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ReRun()
Visual Basic
Public Sub ReRun
Visual C++
public:
void ReRun()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


SetDetail Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..SetDetail Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SetDetail(System.String)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetDetail(
    string detail
)
Visual Basic
Public Sub SetDetail ( _
    detail As String _
)
Visual C++
public:
void SetDetail(
    String^ detail
)

Parameters

detail
Type: System..::..String

[Missing <param name="detail"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SetDetail(System.String)"]

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


SetFocus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..SetFocus Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SetFocus"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetFocus()
Visual Basic
Public Sub SetFocus
Visual C++
public:
void SetFocus()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


SetMessage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..SetMessage Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SetMessage(System.String)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetMessage(
    string message
)
Visual Basic
Public Sub SetMessage ( _
    message As String _
)
Visual C++
public:
void SetMessage(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SetMessage(System.String)"]

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


SetProgress Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..SetProgress Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SetProgress(System.Int32,System.Int32)"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetProgress(
    int current,
    int max
)
Visual Basic
Public Sub SetProgress ( _
    current As Integer, _
    max As Integer _
)
Visual C++
public:
void SetProgress(
    int current,
    int max
)

Parameters

current
Type: System..::..Int32

[Missing <param name="current"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SetProgress(System.Int32,System.Int32)"]

max
Type: System..::..Int32

[Missing <param name="max"/> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SetProgress(System.Int32,System.Int32)"]

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


ShowDiagnosticsUI Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..ShowDiagnosticsUI Method
VisualDebugger Class See Also Send Feedback
Show the disgnose UI for a failure.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ShowDiagnosticsUI()
Visual Basic
Public Sub ShowDiagnosticsUI
Visual C++
public:
void ShowDiagnosticsUI()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


ShowDomExplorer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..ShowDomExplorer Method
VisualDebugger Class See Also Send Feedback
Show the DOM Explorer

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ShowDomExplorer()
Visual Basic
Public Sub ShowDomExplorer
Visual C++
public:
void ShowDomExplorer()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


ShowTestLog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..ShowTestLog Method
VisualDebugger Class See Also Send Feedback
Show the test log

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ShowTestLog()
Visual Basic
Public Sub ShowTestLog
Visual C++
public:
void ShowTestLog()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


Step Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..Step Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.Step"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Step()
Visual Basic
Public Sub Step
Visual C++
public:
void Step()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


SubmitBug Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..SubmitBug Method
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Design.Execution.VisualDebugger.SubmitBug"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SubmitBug()
Visual Basic
Public Sub SubmitBug
Visual C++
public:
void SubmitBug()

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


VisualDebugger Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger Properties
VisualDebugger Class See Also Send Feedback

The VisualDebugger type exposes the following members.

Properties

 | Name | Description
Public property | InBreakpoint |
Public property | IsDebugging | Whether the Debugger is enabled or not.
Public property | IsProfilingExecution |
Public property | IsReRunRequested |
Public property | IsResumeRequested |
Public property | IsStepMode |
Public property | IsStopRequested |
Public property | ResetSignal |

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


InBreakpoint Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..InBreakpoint Property
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VisualDebugger.InBreakpoint"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool InBreakpoint { get; }
Visual Basic
Public ReadOnly Property InBreakpoint As Boolean
    Get
Visual C++
public:
property bool InBreakpoint {
    bool get ();
}

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


IsDebugging Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..IsDebugging Property
VisualDebugger Class See Also Send Feedback
Whether the Debugger is enabled or not.

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDebugging { get; }
Visual Basic
Public ReadOnly Property IsDebugging As Boolean
    Get
Visual C++
public:
property bool IsDebugging {
    bool get ();
}

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


IsProfilingExecution Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..IsProfilingExecution Property
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VisualDebugger.IsProfilingExecution"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsProfilingExecution { get; }
Visual Basic
Public ReadOnly Property IsProfilingExecution As Boolean
    Get
Visual C++
public:
property bool IsProfilingExecution {
    bool get ();
}

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


IsReRunRequested Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..IsReRunRequested Property
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VisualDebugger.IsReRunRequested"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReRunRequested { get; }
Visual Basic
Public ReadOnly Property IsReRunRequested As Boolean
    Get
Visual C++
public:
property bool IsReRunRequested {
    bool get ();
}

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


IsResumeRequested Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..IsResumeRequested Property
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VisualDebugger.IsResumeRequested"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsResumeRequested { get; }
Visual Basic
Public ReadOnly Property IsResumeRequested As Boolean
    Get
Visual C++
public:
property bool IsResumeRequested {
    bool get ();
}

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


IsStepMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..IsStepMode Property
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VisualDebugger.IsStepMode"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsStepMode { get; set; }
Visual Basic
Public Property IsStepMode As Boolean
    Get
    Set
Visual C++
public:
property bool IsStepMode {
    bool get ();
    void set (bool value);
}

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


IsStopRequested Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..IsStopRequested Property
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VisualDebugger.IsStopRequested"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsStopRequested { get; }
Visual Basic
Public ReadOnly Property IsStopRequested As Boolean
    Get
Visual C++
public:
property bool IsStopRequested {
    bool get ();
}

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


ResetSignal Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualDebugger..::..ResetSignal Property
VisualDebugger Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Design.Execution.VisualDebugger.ResetSignal"]

Namespace: ArtOfTest.WebAii.Design.Execution
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutoResetEvent ResetSignal { get; set; }
Visual Basic
Public Property ResetSignal As AutoResetEvent
    Get
    Set
Visual C++
public:
property AutoResetEvent^ ResetSignal {
    AutoResetEvent^ get ();
    void set (AutoResetEvent^ value);
}

See Also

VisualDebugger Class
ArtOfTest.WebAii.Design.Execution Namespace


ArtOfTest.WebAii.EventsArgs Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.EventsArgs Namespace
Send Feedback
Namespace for the various EventArgs classes uses throughout the framework.

Classes

 | Class | Description
Public class | BrowserCommandEventArgs | BrowserCommandEventArgs.
Public class | ClientDisconnectedEventArgs | ClientDisconnectedEventArgs
Public class | ClientLogMessageEventArgs | ClientLogMessageEventArgs
Public class | FindParamCollectionItemAddedEventArgs | FindParamCollection items added event args
Public class | LogWriteEventArgs | LogWrite event argument.
Public class | ReturnedNullOrEmptyEventArgs | ReturnedNullOrEmpty event argument.


BrowserCommandEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserCommandEventArgs Members
BrowserCommandEventArgs Class Constructors Methods Properties See Also Send Feedback

The BrowserCommandEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BrowserCommandEventArgs | Create a new BrowserRequestEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Command | Gets the request.
Public property | Id | Gets the unique id of this command.

See Also

BrowserCommandEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


BrowserCommandEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserCommandEventArgs Constructor
BrowserCommandEventArgs Class See Also Send Feedback
Create a new BrowserRequestEventArgs.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserCommandEventArgs(
    BrowserCommand command,
    string requestId
)
Visual Basic
Public Sub New ( _
    command As BrowserCommand, _
    requestId As String _
)
Visual C++
public:
BrowserCommandEventArgs(
    BrowserCommand^ command,
    String^ requestId
)

Parameters

command
Type: BrowserCommand
The request.
requestId
Type: System..::..String
The unique request id.

See Also

BrowserCommandEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


BrowserCommandEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserCommandEventArgs Methods
BrowserCommandEventArgs Class See Also Send Feedback

The BrowserCommandEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BrowserCommandEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


BrowserCommandEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserCommandEventArgs Properties
BrowserCommandEventArgs Class See Also Send Feedback

The BrowserCommandEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the request.
Public property | Id | Gets the unique id of this command.

See Also

BrowserCommandEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


Command Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserCommandEventArgs..::..Command Property
BrowserCommandEventArgs Class See Also Send Feedback
Gets the request.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserCommand Command { get; set; }
Visual Basic
Public Property Command As BrowserCommand
    Get
    Set
Visual C++
public:
property BrowserCommand^ Command {
    BrowserCommand^ get ();
    void set (BrowserCommand^ value);
}

See Also

BrowserCommandEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


Id Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BrowserCommandEventArgs..::..Id Property
BrowserCommandEventArgs Class See Also Send Feedback
Gets the unique id of this command.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

BrowserCommandEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ClientDisconnectedEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientDisconnectedEventArgs Members
ClientDisconnectedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ClientDisconnectedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ClientDisconnectedEventArgs | Create a new ClientDisconnectedEventArgs.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ClientId | Gets the client unique id that disconnected.

See Also

ClientDisconnectedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ClientDisconnectedEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientDisconnectedEventArgs Constructor
ClientDisconnectedEventArgs Class See Also Send Feedback
Create a new ClientDisconnectedEventArgs.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ClientDisconnectedEventArgs(
    string clientId
)
Visual Basic
Public Sub New ( _
    clientId As String _
)
Visual C++
public:
ClientDisconnectedEventArgs(
    String^ clientId
)

Parameters

clientId
Type: System..::..String
The client unique id that disconnected.

See Also

ClientDisconnectedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ClientDisconnectedEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientDisconnectedEventArgs Methods
ClientDisconnectedEventArgs Class See Also Send Feedback

The ClientDisconnectedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientDisconnectedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ClientDisconnectedEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientDisconnectedEventArgs Properties
ClientDisconnectedEventArgs Class See Also Send Feedback

The ClientDisconnectedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ClientId | Gets the client unique id that disconnected.

See Also

ClientDisconnectedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ClientId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientDisconnectedEventArgs..::..ClientId Property
ClientDisconnectedEventArgs Class See Also Send Feedback
Gets the client unique id that disconnected.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ClientId { get; }
Visual Basic
Public ReadOnly Property ClientId As String
    Get
Visual C++
public:
property String^ ClientId {
    String^ get ();
}

See Also

ClientDisconnectedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ClientLogMessageEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientLogMessageEventArgs Members
ClientLogMessageEventArgs Class Constructors Methods Properties See Also Send Feedback

The ClientLogMessageEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ClientLogMessageEventArgs(String) | Create a new ClientLogMessageEventArgs.
Public method | ClientLogMessageEventArgs(LogType, String) | Create a new ClientLogMessageEventArgs

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LogType | Gets the log type to use.
Public property | Message | Gets message to log.

See Also

ClientLogMessageEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ClientLogMessageEventArgs Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientLogMessageEventArgs Constructor
ClientLogMessageEventArgs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClientLogMessageEventArgs(String) | Create a new ClientLogMessageEventArgs.
Public method | ClientLogMessageEventArgs(LogType, String) | Create a new ClientLogMessageEventArgs

See Also

ClientLogMessageEventArgs Class
ClientLogMessageEventArgs Members
ArtOfTest.WebAii.EventsArgs Namespace


ClientLogMessageEventArgs Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientLogMessageEventArgs Constructor (String)
ClientLogMessageEventArgs Class See Also Send Feedback
Create a new ClientLogMessageEventArgs.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ClientLogMessageEventArgs(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ClientLogMessageEventArgs(
    String^ message
)

Parameters

message
Type: System..::..String
Message to log.

See Also

ClientLogMessageEventArgs Class
ClientLogMessageEventArgs Overload
ArtOfTest.WebAii.EventsArgs Namespace


ClientLogMessageEventArgs Constructor (LogType, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientLogMessageEventArgs Constructor (LogType, String)
ClientLogMessageEventArgs Class See Also Send Feedback
Create a new ClientLogMessageEventArgs

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ClientLogMessageEventArgs(
    LogType type,
    string message
)
Visual Basic
Public Sub New ( _
    type As LogType, _
    message As String _
)
Visual C++
public:
ClientLogMessageEventArgs(
    LogType type,
    String^ message
)

Parameters

type
Type: ArtOfTest.WebAii.Core..::..LogType
The type of the log to execute.
message
Type: System..::..String
The message to log.

See Also

ClientLogMessageEventArgs Class
ClientLogMessageEventArgs Overload
ArtOfTest.WebAii.EventsArgs Namespace


ClientLogMessageEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientLogMessageEventArgs Methods
ClientLogMessageEventArgs Class See Also Send Feedback

The ClientLogMessageEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ClientLogMessageEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ClientLogMessageEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientLogMessageEventArgs Properties
ClientLogMessageEventArgs Class See Also Send Feedback

The ClientLogMessageEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | LogType | Gets the log type to use.
Public property | Message | Gets message to log.

See Also

ClientLogMessageEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


LogType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientLogMessageEventArgs..::..LogType Property
ClientLogMessageEventArgs Class See Also Send Feedback
Gets the log type to use.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LogType LogType { get; }
Visual Basic
Public ReadOnly Property LogType As LogType
    Get
Visual C++
public:
property LogType LogType {
    LogType get ();
}

See Also

ClientLogMessageEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


Message Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ClientLogMessageEventArgs..::..Message Property
ClientLogMessageEventArgs Class See Also Send Feedback
Gets message to log.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

ClientLogMessageEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


FindParamCollectionItemAddedEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollectionItemAddedEventArgs Members
FindParamCollectionItemAddedEventArgs Class Constructors Methods Properties See Also Send Feedback

The FindParamCollectionItemAddedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | FindParamCollectionItemAddedEventArgs | Create a new event args.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FindParam | Gets the FindParam object added.
Public property | Key | Gets the FindParam key.

See Also

FindParamCollectionItemAddedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


FindParamCollectionItemAddedEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollectionItemAddedEventArgs Constructor
FindParamCollectionItemAddedEventArgs Class See Also Send Feedback
Create a new event args.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParamCollectionItemAddedEventArgs(
    string key,
    FindParam param
)
Visual Basic
Public Sub New ( _
    key As String, _
    param As FindParam _
)
Visual C++
public:
FindParamCollectionItemAddedEventArgs(
    String^ key,
    FindParam^ param
)

Parameters

key
Type: System..::..String
The key of the FindParam
param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam object.

See Also

FindParamCollectionItemAddedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


FindParamCollectionItemAddedEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollectionItemAddedEventArgs Methods
FindParamCollectionItemAddedEventArgs Class See Also Send Feedback

The FindParamCollectionItemAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindParamCollectionItemAddedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


FindParamCollectionItemAddedEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollectionItemAddedEventArgs Properties
FindParamCollectionItemAddedEventArgs Class See Also Send Feedback

The FindParamCollectionItemAddedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | FindParam | Gets the FindParam object added.
Public property | Key | Gets the FindParam key.

See Also

FindParamCollectionItemAddedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


FindParam Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollectionItemAddedEventArgs..::..FindParam Property
FindParamCollectionItemAddedEventArgs Class See Also Send Feedback
Gets the FindParam object added.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam FindParam { get; }
Visual Basic
Public ReadOnly Property FindParam As FindParam
    Get
Visual C++
public:
property FindParam^ FindParam {
    FindParam^ get ();
}

See Also

FindParamCollectionItemAddedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


Key Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollectionItemAddedEventArgs..::..Key Property
FindParamCollectionItemAddedEventArgs Class See Also Send Feedback
Gets the FindParam key.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Key { get; }
Visual Basic
Public ReadOnly Property Key As String
    Get
Visual C++
public:
property String^ Key {
    String^ get ();
}

See Also

FindParamCollectionItemAddedEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


LogWriteEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogWriteEventArgs Members
LogWriteEventArgs Class Constructors Methods Properties See Also Send Feedback

The LogWriteEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LogWriteEventArgs | Create a new LogWriteEventArgs object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | Gets the message being logged.
Public property | MessageWithoutTimeStamp | Gets the message without the time stampe.

See Also

LogWriteEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


LogWriteEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogWriteEventArgs Constructor
LogWriteEventArgs Class See Also Send Feedback
Create a new LogWriteEventArgs object.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LogWriteEventArgs(
    string message,
    string messageNoTime
)
Visual Basic
Public Sub New ( _
    message As String, _
    messageNoTime As String _
)
Visual C++
public:
LogWriteEventArgs(
    String^ message,
    String^ messageNoTime
)

Parameters

message
Type: System..::..String
The message to log.
messageNoTime
Type: System..::..String
The message to log minus the time stamp.

See Also

LogWriteEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


LogWriteEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogWriteEventArgs Methods
LogWriteEventArgs Class See Also Send Feedback

The LogWriteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogWriteEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


LogWriteEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogWriteEventArgs Properties
LogWriteEventArgs Class See Also Send Feedback

The LogWriteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Message | Gets the message being logged.
Public property | MessageWithoutTimeStamp | Gets the message without the time stampe.

See Also

LogWriteEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


Message Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogWriteEventArgs..::..Message Property
LogWriteEventArgs Class See Also Send Feedback
Gets the message being logged.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

LogWriteEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


MessageWithoutTimeStamp Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogWriteEventArgs..::..MessageWithoutTimeStamp Property
LogWriteEventArgs Class See Also Send Feedback
Gets the message without the time stampe.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string MessageWithoutTimeStamp { get; }
Visual Basic
Public ReadOnly Property MessageWithoutTimeStamp As String
    Get
Visual C++
public:
property String^ MessageWithoutTimeStamp {
    String^ get ();
}

See Also

LogWriteEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ReturnedNullOrEmptyEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ReturnedNullOrEmptyEventArgs Members
ReturnedNullOrEmptyEventArgs Class Constructors Methods Properties See Also Send Feedback

The ReturnedNullOrEmptyEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ReturnedNullOrEmptyEventArgs | Create new ReturnedNullOrEmptyEventArgs

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FindErrorData | Gets the FindErrorData object that contains information regarding the identification that caused this event.

See Also

ReturnedNullOrEmptyEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ReturnedNullOrEmptyEventArgs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ReturnedNullOrEmptyEventArgs Constructor
ReturnedNullOrEmptyEventArgs Class See Also Send Feedback
Create new ReturnedNullOrEmptyEventArgs

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReturnedNullOrEmptyEventArgs(
    FindError findErrorData
)
Visual Basic
Public Sub New ( _
    findErrorData As FindError _
)
Visual C++
public:
ReturnedNullOrEmptyEventArgs(
    FindError^ findErrorData
)

Parameters

findErrorData
Type: ArtOfTest.WebAii.Exceptions.ErrorData..::..FindError
The find error data object that contains information on the find error that results in a null or an empty list of elements to be returned.

See Also

ReturnedNullOrEmptyEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ReturnedNullOrEmptyEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ReturnedNullOrEmptyEventArgs Methods
ReturnedNullOrEmptyEventArgs Class See Also Send Feedback

The ReturnedNullOrEmptyEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReturnedNullOrEmptyEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ReturnedNullOrEmptyEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ReturnedNullOrEmptyEventArgs Properties
ReturnedNullOrEmptyEventArgs Class See Also Send Feedback

The ReturnedNullOrEmptyEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | FindErrorData | Gets the FindErrorData object that contains information regarding the identification that caused this event.

See Also

ReturnedNullOrEmptyEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


FindErrorData Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ReturnedNullOrEmptyEventArgs..::..FindErrorData Property
ReturnedNullOrEmptyEventArgs Class See Also Send Feedback
Gets the FindErrorData object that contains information regarding the identification that caused this event.

Namespace: ArtOfTest.WebAii.EventsArgs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindError FindErrorData { get; }
Visual Basic
Public ReadOnly Property FindErrorData As FindError
    Get
Visual C++
public:
property FindError^ FindErrorData {
    FindError^ get ();
}

See Also

ReturnedNullOrEmptyEventArgs Class
ArtOfTest.WebAii.EventsArgs Namespace


ArtOfTest.WebAii.Exceptions Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Exceptions Namespace
Send Feedback
Namespace for the various exceptions that may be thrown throughout the framework.

Classes

 | Class | Description
Public class | ExecuteCommandException | Execute command exception. Occurs when a command fails to execute.
Public class | FindException | Find exception. Thrown when Find returns null or an empty list
Public class | LogErrorException | This exception indicates that a log error call has been made to hault the execution of the tests by throwing a LogErrorException.
Public class | UnsupportedBrowserOperationException | Exception for operations that are not supported by a certain type of browser.
Public class | UnsupportedNonInteractiveOperationException | This exception is thrown when an automation test tries to perform a operation that is deemed invalid in non-interactive mode like trying to use the keyboard or click the mouse.


ExecuteCommandException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException Members
ExecuteCommandException Class Constructors Methods Properties See Also Send Feedback

The ExecuteCommandException type exposes the following members.

Constructors

 | Name | Description
Public method | ExecuteCommandException(BrowserCommand, Exception) | Create a new ExecuteCommandException.
Public method | ExecuteCommandException(SerializationInfo, StreamingContext) | Initializes a new ExecuteCommandException object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Deserializes a ExecuteCommandException object; (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Command | Gets the command that caused the exception.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the ExecuteCommandException message. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExecuteCommandException Class
ArtOfTest.WebAii.Exceptions Namespace


ExecuteCommandException Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException Constructor
ExecuteCommandException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExecuteCommandException(BrowserCommand, Exception) | Create a new ExecuteCommandException.
Public method | ExecuteCommandException(SerializationInfo, StreamingContext) | Initializes a new ExecuteCommandException object.

See Also

ExecuteCommandException Class
ExecuteCommandException Members
ArtOfTest.WebAii.Exceptions Namespace


ExecuteCommandException Constructor (, Exception)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException Constructor (, Exception)
ExecuteCommandException Class See Also Send Feedback
Create a new ExecuteCommandException.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecuteCommandException(
    BrowserCommand command,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    command As BrowserCommand, _
    innerException As Exception _
)
Visual C++
public:
ExecuteCommandException(
    BrowserCommand^ command,
    Exception^ innerException
)

Parameters

command
Type: BrowserCommand
The command that caused the exception.
innerException
Type: System..::..Exception
The inner exception (if any).

See Also

ExecuteCommandException Class
ExecuteCommandException Overload
ArtOfTest.WebAii.Exceptions Namespace


ExecuteCommandException Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException Constructor (SerializationInfo, StreamingContext)
ExecuteCommandException Class See Also Send Feedback
Initializes a new ExecuteCommandException object.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecuteCommandException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExecuteCommandException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The data needed to serialize or deserialize an object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The source and destination of a given serialized stream, and provides an additional caller-defined context.

See Also

ExecuteCommandException Class
ExecuteCommandException Overload
ArtOfTest.WebAii.Exceptions Namespace


ExecuteCommandException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException Methods
ExecuteCommandException Class See Also Send Feedback

The ExecuteCommandException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Deserializes a ExecuteCommandException object; (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ExecuteCommandException Class
ArtOfTest.WebAii.Exceptions Namespace


GetObjectData Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException..::..GetObjectData Method
ExecuteCommandException Class See Also Send Feedback
Deserializes a ExecuteCommandException object;

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The data needed to serialize or deserialize an object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The source and destination of a given serialized stream, and provides an additional caller-defined context.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ExecuteCommandException Class
ArtOfTest.WebAii.Exceptions Namespace


ExecuteCommandException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException Properties
ExecuteCommandException Class See Also Send Feedback

The ExecuteCommandException type exposes the following members.

Properties

 | Name | Description
Public property | Command | Gets the command that caused the exception.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the ExecuteCommandException message. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExecuteCommandException Class
ArtOfTest.WebAii.Exceptions Namespace


Command Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException..::..Command Property
ExecuteCommandException Class See Also Send Feedback
Gets the command that caused the exception.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrowserCommand Command { get; }
Visual Basic
Public ReadOnly Property Command As BrowserCommand
    Get
Visual C++
public:
property BrowserCommand^ Command {
    BrowserCommand^ get ();
}

See Also

ExecuteCommandException Class
ArtOfTest.WebAii.Exceptions Namespace


Message Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteCommandException..::..Message Property
ExecuteCommandException Class See Also Send Feedback
Gets the ExecuteCommandException message.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::..Message

See Also

ExecuteCommandException Class
ArtOfTest.WebAii.Exceptions Namespace


FindException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException Members
FindException Class Constructors Methods Properties See Also Send Feedback

The FindException type exposes the following members.

Constructors

 | Name | Description
Public method | FindException(String) | Create a new generic FindException.
Public method | FindException(SerializationInfo, StreamingContext) | Create a new generic FindException.
Public method | FindException(String, Exception) | Create a new generic FindException.
Public method | FindException(FindError, Exception) | Create a new FindException.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FindErrorData | Extended information on the Find error that occurred.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | The FindException message. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FindException Class
ArtOfTest.WebAii.Exceptions Namespace


FindException Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException Constructor
FindException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindException(String) | Create a new generic FindException.
Public method | FindException(SerializationInfo, StreamingContext) | Create a new generic FindException.
Public method | FindException(String, Exception) | Create a new generic FindException.
Public method | FindException(FindError, Exception) | Create a new FindException.

See Also

FindException Class
FindException Members
ArtOfTest.WebAii.Exceptions Namespace


FindException Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException Constructor (String)
FindException Class See Also Send Feedback
Create a new generic FindException.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
FindException(
    String^ message
)

Parameters

message
Type: System..::..String
The exception message.

See Also

FindException Class
FindException Overload
ArtOfTest.WebAii.Exceptions Namespace


FindException Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException Constructor (SerializationInfo, StreamingContext)
FindException Class See Also Send Feedback
Create a new generic FindException.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
FindException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Serialization info
context
Type: System.Runtime.Serialization..::..StreamingContext
Streaming context

See Also

FindException Class
FindException Overload
ArtOfTest.WebAii.Exceptions Namespace


FindException Constructor (String, Exception)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException Constructor (String, Exception)
FindException Class See Also Send Feedback
Create a new generic FindException.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
FindException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The exception message.
innerException
Type: System..::..Exception
Any inner exceptions.

See Also

FindException Class
FindException Overload
ArtOfTest.WebAii.Exceptions Namespace


FindException Constructor (FindError, Exception)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException Constructor (FindError, Exception)
FindException Class See Also Send Feedback
Create a new FindException.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindException(
    FindError findErrorData,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    findErrorData As FindError, _
    innerException As Exception _
)
Visual C++
public:
FindException(
    FindError^ findErrorData,
    Exception^ innerException
)

Parameters

findErrorData
Type: ArtOfTest.WebAii.Exceptions.ErrorData..::..FindError
Extended information on the find exception.
innerException
Type: System..::..Exception
The innerException (if any).

See Also

FindException Class
FindException Overload
ArtOfTest.WebAii.Exceptions Namespace


FindException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException Methods
FindException Class See Also Send Feedback

The FindException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FindException Class
ArtOfTest.WebAii.Exceptions Namespace


FindException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException Properties
FindException Class See Also Send Feedback

The FindException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FindErrorData | Extended information on the Find error that occurred.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | The FindException message. (Overrides Exception..::..Message.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FindException Class
ArtOfTest.WebAii.Exceptions Namespace


FindErrorData Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException..::..FindErrorData Property
FindException Class See Also Send Feedback
Extended information on the Find error that occurred.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindError FindErrorData { get; }
Visual Basic
Public ReadOnly Property FindErrorData As FindError
    Get
Visual C++
public:
property FindError^ FindErrorData {
    FindError^ get ();
}

See Also

FindException Class
ArtOfTest.WebAii.Exceptions Namespace


Message Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindException..::..Message Property
FindException Class See Also Send Feedback
The FindException message.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::..Message

See Also

FindException Class
ArtOfTest.WebAii.Exceptions Namespace


LogErrorException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogErrorException Members
LogErrorException Class Constructors Methods Properties See Also Send Feedback

The LogErrorException type exposes the following members.

Constructors

 | Name | Description
Public method | LogErrorException(String) | Create this exception
Public method | LogErrorException(SerializationInfo, StreamingContext) | Serialization Contructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | GetObjectData - Serialization (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LogErrorException Class
ArtOfTest.WebAii.Exceptions Namespace


LogErrorException Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogErrorException Constructor
LogErrorException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogErrorException(String) | Create this exception
Public method | LogErrorException(SerializationInfo, StreamingContext) | Serialization Contructor.

See Also

LogErrorException Class
LogErrorException Members
ArtOfTest.WebAii.Exceptions Namespace


LogErrorException Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogErrorException Constructor (String)
LogErrorException Class See Also Send Feedback
Create this exception

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LogErrorException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
LogErrorException(
    String^ message
)

Parameters

message
Type: System..::..String
Exception message.

See Also

LogErrorException Class
LogErrorException Overload
ArtOfTest.WebAii.Exceptions Namespace


LogErrorException Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogErrorException Constructor (SerializationInfo, StreamingContext)
LogErrorException Class See Also Send Feedback
Serialization Contructor.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LogErrorException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
LogErrorException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Serialization Info.
context
Type: System.Runtime.Serialization..::..StreamingContext
Context Info.

See Also

LogErrorException Class
LogErrorException Overload
ArtOfTest.WebAii.Exceptions Namespace


LogErrorException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogErrorException Methods
LogErrorException Class See Also Send Feedback

The LogErrorException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | GetObjectData - Serialization (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LogErrorException Class
ArtOfTest.WebAii.Exceptions Namespace


GetObjectData Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogErrorException..::..GetObjectData Method
LogErrorException Class See Also Send Feedback
GetObjectData - Serialization

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Serialization Info.
context
Type: System.Runtime.Serialization..::..StreamingContext
Context Info.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

LogErrorException Class
ArtOfTest.WebAii.Exceptions Namespace


LogErrorException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogErrorException Properties
LogErrorException Class See Also Send Feedback

The LogErrorException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LogErrorException Class
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedBrowserOperationException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedBrowserOperationException Members
UnsupportedBrowserOperationException Class Constructors Methods Properties See Also Send Feedback

The UnsupportedBrowserOperationException type exposes the following members.

Constructors

 | Name | Description
Public method | UnsupportedBrowserOperationException | Create this exception

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedBrowserOperationException Class
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedBrowserOperationException Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedBrowserOperationException Constructor
UnsupportedBrowserOperationException Class See Also Send Feedback
Create this exception

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UnsupportedBrowserOperationException(
    BrowserType browserType,
    string operationName
)
Visual Basic
Public Sub New ( _
    browserType As BrowserType, _
    operationName As String _
)
Visual C++
public:
UnsupportedBrowserOperationException(
    BrowserType browserType,
    String^ operationName
)

Parameters

browserType
Type: ArtOfTest.WebAii.Core..::..BrowserType
The browser type.
operationName
Type: System..::..String
The unsupported operation.

See Also

UnsupportedBrowserOperationException Class
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedBrowserOperationException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedBrowserOperationException Methods
UnsupportedBrowserOperationException Class See Also Send Feedback

The UnsupportedBrowserOperationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UnsupportedBrowserOperationException Class
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedBrowserOperationException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedBrowserOperationException Properties
UnsupportedBrowserOperationException Class See Also Send Feedback

The UnsupportedBrowserOperationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedBrowserOperationException Class
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedNonInteractiveOperationException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedNonInteractiveOperationException Members
UnsupportedNonInteractiveOperationException Class Constructors Methods Properties See Also Send Feedback

The UnsupportedNonInteractiveOperationException type exposes the following members.

Constructors

 | Name | Description
Public method | UnsupportedNonInteractiveOperationException(String) | Create this exception.
Public method | UnsupportedNonInteractiveOperationException(String, Exception) | Create this exception.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedNonInteractiveOperationException Class
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedNonInteractiveOperationException Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedNonInteractiveOperationException Constructor
UnsupportedNonInteractiveOperationException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UnsupportedNonInteractiveOperationException(String) | Create this exception.
Public method | UnsupportedNonInteractiveOperationException(String, Exception) | Create this exception.

See Also

UnsupportedNonInteractiveOperationException Class
UnsupportedNonInteractiveOperationException Members
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedNonInteractiveOperationException Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedNonInteractiveOperationException Constructor (String)
UnsupportedNonInteractiveOperationException Class See Also Send Feedback
Create this exception.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UnsupportedNonInteractiveOperationException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
UnsupportedNonInteractiveOperationException(
    String^ message
)

Parameters

message
Type: System..::..String
The exception message.

See Also

UnsupportedNonInteractiveOperationException Class
UnsupportedNonInteractiveOperationException Overload
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedNonInteractiveOperationException Constructor (String, Exception)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedNonInteractiveOperationException Constructor (String, Exception)
UnsupportedNonInteractiveOperationException Class See Also Send Feedback
Create this exception.

Namespace: ArtOfTest.WebAii.Exceptions
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UnsupportedNonInteractiveOperationException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
UnsupportedNonInteractiveOperationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String
The exception message.
innerException
Type: System..::..Exception
InnerException.

See Also

UnsupportedNonInteractiveOperationException Class
UnsupportedNonInteractiveOperationException Overload
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedNonInteractiveOperationException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedNonInteractiveOperationException Methods
UnsupportedNonInteractiveOperationException Class See Also Send Feedback

The UnsupportedNonInteractiveOperationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

UnsupportedNonInteractiveOperationException Class
ArtOfTest.WebAii.Exceptions Namespace


UnsupportedNonInteractiveOperationException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UnsupportedNonInteractiveOperationException Properties
UnsupportedNonInteractiveOperationException Class See Also Send Feedback

The UnsupportedNonInteractiveOperationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

UnsupportedNonInteractiveOperationException Class
ArtOfTest.WebAii.Exceptions Namespace


ArtOfTest.WebAii.Exceptions.ErrorData Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Exceptions.ErrorData Namespace
Send Feedback
Namespace for the FindError class, which holds detailed error information when a find element fails.

Classes

 | Class | Description
Public class | FindError | Class represents a Find error information. This class encapsulates all the information regarding a Find object call that caused one of the Find methods to return null or an empty list.


FindError Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError Members
FindError Class Methods Properties See Also Send Feedback

The FindError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | String representation of a FindError object (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | ChainedParametersUsed | Obsolete. Gets the chained parameters used for the search. If isChained == null, then this will return null.
Public property | ExpressionUsed | Gets the FindExpression used for the search
Public property | IsChained | Gets whether this is a chained parameter error or not.
Public property | ParameterUsed | Gets the FindParam used for the search. If IsChained != null, then this will return null.
Public property | Reference | Gets the reference element used for the search.
Public property | SearchLog | Gets the search log returned by the identification routines.

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


FindError Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError Methods
FindError Class See Also Send Feedback

The FindError type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | String representation of a FindError object (Overrides Object..::..ToString()()()().)

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError..::..ToString Method
FindError Class See Also Send Feedback
String representation of a FindError object

Namespace: ArtOfTest.WebAii.Exceptions.ErrorData
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation.

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


FindError Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError Properties
FindError Class See Also Send Feedback

The FindError type exposes the following members.

Properties

 | Name | Description
Public property | ChainedParametersUsed | Obsolete. Gets the chained parameters used for the search. If isChained == null, then this will return null.
Public property | ExpressionUsed | Gets the FindExpression used for the search
Public property | IsChained | Gets whether this is a chained parameter error or not.
Public property | ParameterUsed | Gets the FindParam used for the search. If IsChained != null, then this will return null.
Public property | Reference | Gets the reference element used for the search.
Public property | SearchLog | Gets the search log returned by the identification routines.

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


ChainedParametersUsed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError..::..ChainedParametersUsed Property
FindError Class See Also Send Feedback
Gets the chained parameters used for the search. If isChained == null, then this will return null.

Namespace: ArtOfTest.WebAii.Exceptions.ErrorData
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("FindParams are deprecated in favor of FindExpressions")]
public FindParam[] ChainedParametersUsed { get; }
Visual Basic
<ObsoleteAttribute("FindParams are deprecated in favor of FindExpressions")> _
Public ReadOnly Property ChainedParametersUsed As FindParam()
    Get
Visual C++
[ObsoleteAttribute(L"FindParams are deprecated in favor of FindExpressions")]
public:
property array<FindParam^>^ ChainedParametersUsed {
    array<FindParam^>^ get ();
}

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


ExpressionUsed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError..::..ExpressionUsed Property
FindError Class See Also Send Feedback
Gets the FindExpression used for the search

Namespace: ArtOfTest.WebAii.Exceptions.ErrorData
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IFindExpression ExpressionUsed { get; }
Visual Basic
Public ReadOnly Property ExpressionUsed As IFindExpression
    Get
Visual C++
public:
property IFindExpression^ ExpressionUsed {
    IFindExpression^ get ();
}

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


IsChained Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError..::..IsChained Property
FindError Class See Also Send Feedback
Gets whether this is a chained parameter error or not.

Namespace: ArtOfTest.WebAii.Exceptions.ErrorData
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsChained { get; }
Visual Basic
Public ReadOnly Property IsChained As Boolean
    Get
Visual C++
public:
property bool IsChained {
    bool get ();
}

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


ParameterUsed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError..::..ParameterUsed Property
FindError Class See Also Send Feedback
Gets the FindParam used for the search. If IsChained != null, then this will return null.

Namespace: ArtOfTest.WebAii.Exceptions.ErrorData
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam ParameterUsed { get; }
Visual Basic
Public ReadOnly Property ParameterUsed As FindParam
    Get
Visual C++
public:
property FindParam^ ParameterUsed {
    FindParam^ get ();
}

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


Reference Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError..::..Reference Property
FindError Class See Also Send Feedback
Gets the reference element used for the search.

Namespace: ArtOfTest.WebAii.Exceptions.ErrorData
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Element
    Get
Visual C++
public:
property Element^ Reference {
    Element^ get ();
}

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


SearchLog Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindError..::..SearchLog Property
FindError Class See Also Send Feedback
Gets the search log returned by the identification routines.

Namespace: ArtOfTest.WebAii.Exceptions.ErrorData
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SearchLog { get; }
Visual Basic
Public ReadOnly Property SearchLog As String
    Get
Visual C++
public:
property String^ SearchLog {
    String^ get ();
}

See Also

FindError Class
ArtOfTest.WebAii.Exceptions.ErrorData Namespace


ArtOfTest.WebAii.Javascript Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Javascript Namespace
Send Feedback
Namespace for all the JavaScript functionality of the framework.

Classes

 | Class | Description
Public class | CustomScriptEventBase | Base class for our clients to create custom Javascript events from. Subclasses should implement their properties or whatever to set key-value pairs in the internal dictionary, the contents of which will be used to create the Javascript object passed to the event handler in the browser. TODO We probably want to change the dictionary to hold javascript objects instead of strings
Public class | JavascriptEventArgs | Provides data to the Javascript event handler
Public class | JavascriptEventMessage | Contains the data associated with a Javascript event
Public class | JsonArray | An array of JSON objects, which can be of many types.
Public class | JsonBaseType | Boxes a single JSON value which could be an array, a string, an int, a double, or a bool.
Public class | JsonCollection | A collection of JSON objects.
Public class | JsonObject | A dictionary containing JavaScript Object Notation (JSON) objects used in the Actions.InvokeScript function.
Public class | KeyEvent | Class representing a scriptable key event that can be sent to a browser window.
Public class | MouseEvent | Class representing a scriptable mouse event that can be sent to a browser window.
Public class | ScriptEvent | The WebAii representation of a Javascript event object
Public class | ScriptUIEvent | Class representing a scriptable UI event. Used as the base class for MouseEvent and KeyEvent.
Public class | Utils | All utility methods used by Javascript classes.

Enumerations

 | Enumeration | Description
Public enumeration | ModifierKeys | Specifies the set of modifier keys. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.
Public enumeration | MouseButton | Mouse buttons used by Javascript mouse events. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.


CustomScriptEventBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CustomScriptEventBase Members
CustomScriptEventBase Class Constructors Methods Properties See Also Send Feedback

The CustomScriptEventBase type exposes the following members.

Constructors

 | Name | Description
Protected method | CustomScriptEventBase | Initializes a new instance of the CustomScriptEventBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CanBubble | Gets / Sets whether this event can bubble (Inherited from ScriptEvent.)
Public property | Internal | Gets / Sets the list of custom fields.
Public property | IsCancelable | Gets / Sets whether this event can be cancelled (Inherited from ScriptEvent.)
Public property | Item | Gets / Sets the value at the specified key.
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types (Inherited from ScriptEvent.)

See Also

CustomScriptEventBase Class
ArtOfTest.WebAii.Javascript Namespace


CustomScriptEventBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CustomScriptEventBase Constructor
CustomScriptEventBase Class See Also Send Feedback
Initializes a new instance of the CustomScriptEventBase class

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected CustomScriptEventBase()
Visual Basic
Protected Sub New
Visual C++
protected:
CustomScriptEventBase()

See Also

CustomScriptEventBase Class
ArtOfTest.WebAii.Javascript Namespace


CustomScriptEventBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CustomScriptEventBase Methods
CustomScriptEventBase Class See Also Send Feedback

The CustomScriptEventBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomScriptEventBase Class
ArtOfTest.WebAii.Javascript Namespace


CustomScriptEventBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CustomScriptEventBase Properties
CustomScriptEventBase Class See Also Send Feedback

The CustomScriptEventBase type exposes the following members.

Properties

 | Name | Description
Public property | CanBubble | Gets / Sets whether this event can bubble (Inherited from ScriptEvent.)
Public property | Internal | Gets / Sets the list of custom fields.
Public property | IsCancelable | Gets / Sets whether this event can be cancelled (Inherited from ScriptEvent.)
Public property | Item | Gets / Sets the value at the specified key.
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types (Inherited from ScriptEvent.)

See Also

CustomScriptEventBase Class
ArtOfTest.WebAii.Javascript Namespace


Internal Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CustomScriptEventBase..::..Internal Property
CustomScriptEventBase Class See Also Send Feedback
Gets / Sets the list of custom fields.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<string, string> Internal { get; set; }
Visual Basic
Public Property Internal As Dictionary(Of String, String)
    Get
    Set
Visual C++
public:
property Dictionary<String^, String^>^ Internal {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

See Also

CustomScriptEventBase Class
ArtOfTest.WebAii.Javascript Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CustomScriptEventBase..::..Item Property
CustomScriptEventBase Class See Also Send Feedback
Gets / Sets the value at the specified key.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string this[
    string key
] { get; set; }
Visual Basic
Public Default Property Item ( _
    key As String _
) As String
    Get
    Set
Visual C++
public:
property String^ default[String^ key] {
    String^ get (String^ key);
    void set (String^ key, String^ value);
}

Parameters

key
Type: System..::..String
The key to get the value of.

Return Value

A value.

See Also

CustomScriptEventBase Class
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs Members
JavascriptEventArgs Class Methods Properties See Also Send Feedback

The JavascriptEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CharCode | Gets the Unicode value of a printable character that was entered
Public property | ClientX | Gets the horizontal cursor position in browser-relative coordinates
Public property | ClientY | Gets the vertical cursor position in browser-relative coordinates
Public property | KeyCode | Gets the Unicode (or something) value of the key that was pressed
Public property | ModifierKeys | Gets the modifier keys that were active during the event
Public property | ScreenX | Gets the horizontal cursor position in screen coordinates
Public property | ScreenY | Gets the vertical cursor position in screen coordinates
Public property | Type | Gets the type of the event

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs Methods
JavascriptEventArgs Class See Also Send Feedback

The JavascriptEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs Properties
JavascriptEventArgs Class See Also Send Feedback

The JavascriptEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CharCode | Gets the Unicode value of a printable character that was entered
Public property | ClientX | Gets the horizontal cursor position in browser-relative coordinates
Public property | ClientY | Gets the vertical cursor position in browser-relative coordinates
Public property | KeyCode | Gets the Unicode (or something) value of the key that was pressed
Public property | ModifierKeys | Gets the modifier keys that were active during the event
Public property | ScreenX | Gets the horizontal cursor position in screen coordinates
Public property | ScreenY | Gets the vertical cursor position in screen coordinates
Public property | Type | Gets the type of the event

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


CharCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs..::..CharCode Property
JavascriptEventArgs Class See Also Send Feedback
Gets the Unicode value of a printable character that was entered

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CharCode { get; }
Visual Basic
Public ReadOnly Property CharCode As Integer
    Get
Visual C++
public:
property int CharCode {
    int get ();
}

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


ClientX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs..::..ClientX Property
JavascriptEventArgs Class See Also Send Feedback
Gets the horizontal cursor position in browser-relative coordinates

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ClientX { get; }
Visual Basic
Public ReadOnly Property ClientX As Integer
    Get
Visual C++
public:
property int ClientX {
    int get ();
}

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


ClientY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs..::..ClientY Property
JavascriptEventArgs Class See Also Send Feedback
Gets the vertical cursor position in browser-relative coordinates

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ClientY { get; }
Visual Basic
Public ReadOnly Property ClientY As Integer
    Get
Visual C++
public:
property int ClientY {
    int get ();
}

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


KeyCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs..::..KeyCode Property
JavascriptEventArgs Class See Also Send Feedback
Gets the Unicode (or something) value of the key that was pressed

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int KeyCode { get; }
Visual Basic
Public ReadOnly Property KeyCode As Integer
    Get
Visual C++
public:
property int KeyCode {
    int get ();
}

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


ModifierKeys Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs..::..ModifierKeys Property
JavascriptEventArgs Class See Also Send Feedback
Gets the modifier keys that were active during the event

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ModifierKeys ModifierKeys { get; }
Visual Basic
Public ReadOnly Property ModifierKeys As ModifierKeys
    Get
Visual C++
public:
property ModifierKeys ModifierKeys {
    ModifierKeys get ();
}

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


ScreenX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs..::..ScreenX Property
JavascriptEventArgs Class See Also Send Feedback
Gets the horizontal cursor position in screen coordinates

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ScreenX { get; }
Visual Basic
Public ReadOnly Property ScreenX As Integer
    Get
Visual C++
public:
property int ScreenX {
    int get ();
}

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


ScreenY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs..::..ScreenY Property
JavascriptEventArgs Class See Also Send Feedback
Gets the vertical cursor position in screen coordinates

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ScreenY { get; }
Visual Basic
Public ReadOnly Property ScreenY As Integer
    Get
Visual C++
public:
property int ScreenY {
    int get ();
}

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventArgs..::..Type Property
JavascriptEventArgs Class See Also Send Feedback
Gets the type of the event

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Type { get; }
Visual Basic
Public ReadOnly Property Type As String
    Get
Visual C++
public:
property String^ Type {
    String^ get ();
}

See Also

JavascriptEventArgs Class
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventMessage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage Members
JavascriptEventMessage Class Constructors Methods Properties See Also Send Feedback

The JavascriptEventMessage type exposes the following members.

Constructors

 | Name | Description
Public method | JavascriptEventMessage()()()() | Default constructor; required for DataContract
Public method | JavascriptEventMessage(String, String) | Creates a new JavascriptEventMessage for an event of the specified type

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CharCode | Gets / Sets the Unicode value of a printable character that was entered
Public property | ClientX | Gets / Sets the horizontal cursor position in browser-relative coordinates
Public property | ClientY | Gets / Sets the vertical cursor position in browser-relative coordinates
Public property | Guid | Gets the Guid identifying the handler for this event
Public property | GuidString | Gets / Sets the string representation of the Guid identifying the handler for this event
Public property | KeyCode | Gets / Sets the Unicode (or something) value of the key that was pressed
Public property | ModifierKeys | Gets / Sets the modifier keys that were active during the event
Public property | ScreenX | Gets / Sets the horizontal cursor position in screen coordinates
Public property | ScreenY | Gets / Sets the vertical cursor position in screen coordinates
Public property | Type | Gets / Sets the type of the event

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventMessage Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage Constructor
JavascriptEventMessage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | JavascriptEventMessage()()()() | Default constructor; required for DataContract
Public method | JavascriptEventMessage(String, String) | Creates a new JavascriptEventMessage for an event of the specified type

See Also

JavascriptEventMessage Class
JavascriptEventMessage Members
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventMessage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage Constructor
JavascriptEventMessage Class See Also Send Feedback
Default constructor; required for DataContract

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public JavascriptEventMessage()
Visual Basic
Public Sub New
Visual C++
public:
JavascriptEventMessage()

See Also

JavascriptEventMessage Class
JavascriptEventMessage Overload
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventMessage Constructor (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage Constructor (String, String)
JavascriptEventMessage Class See Also Send Feedback
Creates a new JavascriptEventMessage for an event of the specified type

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public JavascriptEventMessage(
    string guid,
    string type
)
Visual Basic
Public Sub New ( _
    guid As String, _
    type As String _
)
Visual C++
public:
JavascriptEventMessage(
    String^ guid,
    String^ type
)

Parameters

guid
Type: System..::..String
A Guid identifying the event handler for this event
type
Type: System..::..String
The event's type

See Also

JavascriptEventMessage Class
JavascriptEventMessage Overload
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventMessage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage Methods
JavascriptEventMessage Class See Also Send Feedback

The JavascriptEventMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


JavascriptEventMessage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage Properties
JavascriptEventMessage Class See Also Send Feedback

The JavascriptEventMessage type exposes the following members.

Properties

 | Name | Description
Public property | CharCode | Gets / Sets the Unicode value of a printable character that was entered
Public property | ClientX | Gets / Sets the horizontal cursor position in browser-relative coordinates
Public property | ClientY | Gets / Sets the vertical cursor position in browser-relative coordinates
Public property | Guid | Gets the Guid identifying the handler for this event
Public property | GuidString | Gets / Sets the string representation of the Guid identifying the handler for this event
Public property | KeyCode | Gets / Sets the Unicode (or something) value of the key that was pressed
Public property | ModifierKeys | Gets / Sets the modifier keys that were active during the event
Public property | ScreenX | Gets / Sets the horizontal cursor position in screen coordinates
Public property | ScreenY | Gets / Sets the vertical cursor position in screen coordinates
Public property | Type | Gets / Sets the type of the event

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


CharCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..CharCode Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the Unicode value of a printable character that was entered

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CharCode { get; set; }
Visual Basic
Public Property CharCode As Integer
    Get
    Set
Visual C++
public:
property int CharCode {
    int get ();
    void set (int value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


ClientX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..ClientX Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the horizontal cursor position in browser-relative coordinates

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ClientX { get; set; }
Visual Basic
Public Property ClientX As Integer
    Get
    Set
Visual C++
public:
property int ClientX {
    int get ();
    void set (int value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


ClientY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..ClientY Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the vertical cursor position in browser-relative coordinates

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ClientY { get; set; }
Visual Basic
Public Property ClientY As Integer
    Get
    Set
Visual C++
public:
property int ClientY {
    int get ();
    void set (int value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


Guid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..Guid Property
JavascriptEventMessage Class See Also Send Feedback
Gets the Guid identifying the handler for this event

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid Guid { get; }
Visual Basic
Public ReadOnly Property Guid As Guid
    Get
Visual C++
public:
property Guid Guid {
    Guid get ();
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


GuidString Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..GuidString Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the string representation of the Guid identifying the handler for this event

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GuidString { get; set; }
Visual Basic
Public Property GuidString As String
    Get
    Set
Visual C++
public:
property String^ GuidString {
    String^ get ();
    void set (String^ value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


KeyCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..KeyCode Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the Unicode (or something) value of the key that was pressed

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int KeyCode { get; set; }
Visual Basic
Public Property KeyCode As Integer
    Get
    Set
Visual C++
public:
property int KeyCode {
    int get ();
    void set (int value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


ModifierKeys Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..ModifierKeys Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the modifier keys that were active during the event

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ModifierKeys ModifierKeys { get; set; }
Visual Basic
Public Property ModifierKeys As ModifierKeys
    Get
    Set
Visual C++
public:
property ModifierKeys ModifierKeys {
    ModifierKeys get ();
    void set (ModifierKeys value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


ScreenX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..ScreenX Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the horizontal cursor position in screen coordinates

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ScreenX { get; set; }
Visual Basic
Public Property ScreenX As Integer
    Get
    Set
Visual C++
public:
property int ScreenX {
    int get ();
    void set (int value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


ScreenY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..ScreenY Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the vertical cursor position in screen coordinates

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ScreenY { get; set; }
Visual Basic
Public Property ScreenY As Integer
    Get
    Set
Visual C++
public:
property int ScreenY {
    int get ();
    void set (int value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JavascriptEventMessage..::..Type Property
JavascriptEventMessage Class See Also Send Feedback
Gets / Sets the type of the event

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

JavascriptEventMessage Class
ArtOfTest.WebAii.Javascript Namespace


JsonArray Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonArray Members
JsonArray Class Methods Properties See Also Send Feedback

The JsonArray type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | InternalValue | Gets / sets the value of this JSON object. (Inherited from JsonBaseType.)
Public property | Item[([( Int32])]) | Gets / sets the JSON element at the specified index. (Overrides JsonBaseType..::..Item[([( Int32])]) .)
Public property | Item[([( String])]) | Not supported. (Inherited from JsonBaseType.)

See Also

JsonArray Class
ArtOfTest.WebAii.Javascript Namespace


JsonArray Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonArray Methods
JsonArray Class See Also Send Feedback

The JsonArray type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JsonArray Class
ArtOfTest.WebAii.Javascript Namespace


JsonArray Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonArray Properties
JsonArray Class See Also Send Feedback

The JsonArray type exposes the following members.

Properties

 | Name | Description
Protected property | InternalValue | Gets / sets the value of this JSON object. (Inherited from JsonBaseType.)
Public property | Item[([( Int32])]) | Gets / sets the JSON element at the specified index. (Overrides JsonBaseType..::..Item[([( Int32])]) .)
Public property | Item[([( String])]) | Not supported. (Inherited from JsonBaseType.)

See Also

JsonArray Class
ArtOfTest.WebAii.Javascript Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonArray..::..Item Property
JsonArray Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets / sets the JSON element at the specified index. (Overrides JsonBaseType..::..Item[([( Int32])]) .)
Public property | Item[([( String])]) | Not supported. (Inherited from JsonBaseType.)

See Also

JsonArray Class
JsonArray Members
ArtOfTest.WebAii.Javascript Namespace


Item Property (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonArray..::..Item Property (Int32)
JsonArray Class See Also Send Feedback
Gets / sets the JSON element at the specified index.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override JsonBaseType this[
    int index
] { get; set; }
Visual Basic
Public Overrides Default Property Item ( _
    index As Integer _
) As JsonBaseType
    Get
    Set
Visual C++
public:
virtual property JsonBaseType^ default[int index] {
    JsonBaseType^ get (int index) override;
    void set (int index, JsonBaseType^ value) override;
}

Parameters

index
Type: System..::..Int32
The zero-based index of the element to get or set.

Field Value

The JsonBaseType at the specified index.

See Also

JsonArray Class
Item Overload
ArtOfTest.WebAii.Javascript Namespace


JsonBaseType Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType Members
JsonBaseType Class Methods Operators Properties See Also Send Feedback

The JsonBaseType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to String) | Implicitly converts this JSON object to a string.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Boolean) | Implicitly converts this JSON object to a bool.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Int32) | Implicitly converts this JSON object to an int.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Double) | Implicitly converts this JSON object to a double.

Properties

 | Name | Description
Protected property | InternalValue | Gets / sets the value of this JSON object.
Public property | Item[([( Int32])]) | Not supported.
Public property | Item[([( String])]) | Not supported.

See Also

JsonBaseType Class
ArtOfTest.WebAii.Javascript Namespace


JsonBaseType Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType Methods
JsonBaseType Class See Also Send Feedback

The JsonBaseType type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JsonBaseType Class
ArtOfTest.WebAii.Javascript Namespace


JsonBaseType Type Conversions

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType Type Conversions
JsonBaseType Class See Also Send Feedback

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to String) | Implicitly converts this JSON object to a string.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Boolean) | Implicitly converts this JSON object to a bool.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Int32) | Implicitly converts this JSON object to an int.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Double) | Implicitly converts this JSON object to a double.

See Also

JsonBaseType Class
ArtOfTest.WebAii.Javascript Namespace


Implicit Conversion Operators

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType ImplicitWideningImplicitImplicitImplicit Conversion Operators
JsonBaseType Class See Also Send Feedback

Overload List

Name | Description
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to String) | Implicitly converts this JSON object to a string.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Boolean) | Implicitly converts this JSON object to a bool.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Int32) | Implicitly converts this JSON object to an int.
ImplicitWideningImplicitImplicitImplicit(JsonBaseType to Double) | Implicitly converts this JSON object to a double.

See Also

JsonBaseType Class
JsonBaseType Members
ArtOfTest.WebAii.Javascript Namespace


Implicit Conversion (JsonBaseType to String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType ImplicitWideningImplicitImplicitImplicit Conversion (JsonBaseType to String)
JsonBaseType Class See Also Send Feedback
Implicitly converts this JSON object to a string.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator string (
    JsonBaseType type
)
Visual Basic
Public Shared Widening Operator CType ( _
    type As JsonBaseType _
) As String
Visual C++
static implicit operator String^ (
    JsonBaseType^ type
)

Parameters

type
Type: ArtOfTest.WebAii.Javascript..::..JsonBaseType
The JSON object to convert.

Return Value

The string value contained in the JSON object.

Exceptions

Exception | Condition
System..::..InvalidCastException | Thrown when the JSON object does not contain a string.

See Also

JsonBaseType Class
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.WebAii.Javascript Namespace


Implicit Conversion (JsonBaseType to Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType ImplicitWideningImplicitImplicitImplicit Conversion (JsonBaseType to Boolean)
JsonBaseType Class See Also Send Feedback
Implicitly converts this JSON object to a bool.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator bool (
    JsonBaseType type
)
Visual Basic
Public Shared Widening Operator CType ( _
    type As JsonBaseType _
) As Boolean
Visual C++
static implicit operator bool (
    JsonBaseType^ type
)

Parameters

type
Type: ArtOfTest.WebAii.Javascript..::..JsonBaseType
The JSON object to convert.

Return Value

The bool value contained in the JSON object.

Exceptions

Exception | Condition
System..::..InvalidCastException | Thrown when the JSON object does not contain a bool.

See Also

JsonBaseType Class
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.WebAii.Javascript Namespace


Implicit Conversion (JsonBaseType to Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType ImplicitWideningImplicitImplicitImplicit Conversion (JsonBaseType to Int32)
JsonBaseType Class See Also Send Feedback
Implicitly converts this JSON object to an int.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator int (
    JsonBaseType type
)
Visual Basic
Public Shared Widening Operator CType ( _
    type As JsonBaseType _
) As Integer
Visual C++
static implicit operator int (
    JsonBaseType^ type
)

Parameters

type
Type: ArtOfTest.WebAii.Javascript..::..JsonBaseType
The JSON object to convert.

Return Value

The int value contained in the JSON object.

Exceptions

Exception | Condition
System..::..InvalidCastException | Thrown when the JSON object does not contain an int.

See Also

JsonBaseType Class
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.WebAii.Javascript Namespace


Implicit Conversion (JsonBaseType to Double)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType ImplicitWideningImplicitImplicitImplicit Conversion (JsonBaseType to Double)
JsonBaseType Class See Also Send Feedback
Implicitly converts this JSON object to a double.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static implicit operator double (
    JsonBaseType type
)
Visual Basic
Public Shared Widening Operator CType ( _
    type As JsonBaseType _
) As Double
Visual C++
static implicit operator double (
    JsonBaseType^ type
)

Parameters

type
Type: ArtOfTest.WebAii.Javascript..::..JsonBaseType
The JSON object to convert.

Return Value

The double value contained in the JSON object.

Exceptions

Exception | Condition
System..::..InvalidCastException | Thrown when the JSON object does not contain a double.

See Also

JsonBaseType Class
ImplicitWideningImplicitImplicitImplicit Overload
ArtOfTest.WebAii.Javascript Namespace


JsonBaseType Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType Properties
JsonBaseType Class See Also Send Feedback

The JsonBaseType type exposes the following members.

Properties

 | Name | Description
Protected property | InternalValue | Gets / sets the value of this JSON object.
Public property | Item[([( Int32])]) | Not supported.
Public property | Item[([( String])]) | Not supported.

See Also

JsonBaseType Class
ArtOfTest.WebAii.Javascript Namespace


InternalValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType..::..InternalValue Property
JsonBaseType Class See Also Send Feedback
Gets / sets the value of this JSON object.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected Object InternalValue { get; set; }
Visual Basic
Protected Property InternalValue As Object
    Get
    Set
Visual C++
protected:
property Object^ InternalValue {
    Object^ get ();
    void set (Object^ value);
}

Field Value

A generic Object

See Also

JsonBaseType Class
ArtOfTest.WebAii.Javascript Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType..::..Item Property
JsonBaseType Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Not supported.
Public property | Item[([( String])]) | Not supported.

See Also

JsonBaseType Class
JsonBaseType Members
ArtOfTest.WebAii.Javascript Namespace


Item Property (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType..::..Item Property (Int32)
JsonBaseType Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual JsonBaseType this[
    int index
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    index As Integer _
) As JsonBaseType
    Get
    Set
Visual C++
public:
virtual property JsonBaseType^ default[int index] {
    JsonBaseType^ get (int index);
    void set (int index, JsonBaseType^ value);
}

Parameters

index
Type: System..::..Int32
Not supported.

Return Value

Not supported.

See Also

JsonBaseType Class
Item Overload
ArtOfTest.WebAii.Javascript Namespace


Item Property (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonBaseType..::..Item Property (String)
JsonBaseType Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual JsonBaseType this[
    string key
] { get; set; }
Visual Basic
Public Overridable Default Property Item ( _
    key As String _
) As JsonBaseType
    Get
    Set
Visual C++
public:
virtual property JsonBaseType^ default[String^ key] {
    JsonBaseType^ get (String^ key);
    void set (String^ key, JsonBaseType^ value);
}

Parameters

key
Type: System..::..String
Not supported.

Return Value

Not supported.

See Also

JsonBaseType Class
Item Overload
ArtOfTest.WebAii.Javascript Namespace


JsonCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonCollection Members
JsonCollection Class Methods Properties See Also Send Feedback

The JsonCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | InternalValue | Gets / sets the value of this JSON object. (Inherited from JsonBaseType.)
Public property | Item[([( Int32])]) | Not supported. (Inherited from JsonBaseType.)
Public property | Item[([( String])]) | Not supported. (Inherited from JsonBaseType.)

See Also

JsonCollection Class
ArtOfTest.WebAii.Javascript Namespace


JsonCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonCollection Methods
JsonCollection Class See Also Send Feedback

The JsonCollection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JsonCollection Class
ArtOfTest.WebAii.Javascript Namespace


JsonCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonCollection Properties
JsonCollection Class See Also Send Feedback

The JsonCollection type exposes the following members.

Properties

 | Name | Description
Protected property | InternalValue | Gets / sets the value of this JSON object. (Inherited from JsonBaseType.)
Public property | Item[([( Int32])]) | Not supported. (Inherited from JsonBaseType.)
Public property | Item[([( String])]) | Not supported. (Inherited from JsonBaseType.)

See Also

JsonCollection Class
ArtOfTest.WebAii.Javascript Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonCollection..::..Item Property
JsonCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Not supported. (Inherited from JsonBaseType.)
Public property | Item[([( String])]) | Not supported. (Inherited from JsonBaseType.)

See Also

JsonCollection Class
JsonCollection Members
ArtOfTest.WebAii.Javascript Namespace


JsonObject Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonObject Members
JsonObject Class Constructors Methods Properties See Also Send Feedback

The JsonObject type exposes the following members.

Constructors

 | Name | Description
Public method | JsonObject | Constructor that accepts an Xmlreader which contains the information needed to construct this JSON object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Protected property | InternalValue | Gets / sets the value of this JSON object. (Inherited from JsonBaseType.)
Public property | Item[([( Int32])]) | Not supported. (Inherited from JsonBaseType.)
Public property | Item[([( String])]) | Gets / sets the JSON value associated with the specified key. (Overrides JsonBaseType..::..Item[([( String])]) .)

See Also

JsonObject Class
ArtOfTest.WebAii.Javascript Namespace


JsonObject Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonObject Constructor
JsonObject Class See Also Send Feedback
Constructor that accepts an Xmlreader which contains the information needed to construct this JSON object.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public JsonObject(
    XmlReader reader
)
Visual Basic
Public Sub New ( _
    reader As XmlReader _
)
Visual C++
public:
JsonObject(
    XmlReader^ reader
)

Parameters

reader
Type: System.Xml..::..XmlReader
The XmlReader to read during construction.

See Also

JsonObject Class
ArtOfTest.WebAii.Javascript Namespace


JsonObject Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonObject Methods
JsonObject Class See Also Send Feedback

The JsonObject type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JsonObject Class
ArtOfTest.WebAii.Javascript Namespace


JsonObject Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonObject Properties
JsonObject Class See Also Send Feedback

The JsonObject type exposes the following members.

Properties

 | Name | Description
Protected property | InternalValue | Gets / sets the value of this JSON object. (Inherited from JsonBaseType.)
Public property | Item[([( Int32])]) | Not supported. (Inherited from JsonBaseType.)
Public property | Item[([( String])]) | Gets / sets the JSON value associated with the specified key. (Overrides JsonBaseType..::..Item[([( String])]) .)

See Also

JsonObject Class
ArtOfTest.WebAii.Javascript Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonObject..::..Item Property
JsonObject Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Not supported. (Inherited from JsonBaseType.)
Public property | Item[([( String])]) | Gets / sets the JSON value associated with the specified key. (Overrides JsonBaseType..::..Item[([( String])]) .)

See Also

JsonObject Class
JsonObject Members
ArtOfTest.WebAii.Javascript Namespace


Item Property (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
JsonObject..::..Item Property (String)
JsonObject Class See Also Send Feedback
Gets / sets the JSON value associated with the specified key.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override JsonBaseType this[
    string key
] { get; set; }
Visual Basic
Public Overrides Default Property Item ( _
    key As String _
) As JsonBaseType
    Get
    Set
Visual C++
public:
virtual property JsonBaseType^ default[String^ key] {
    JsonBaseType^ get (String^ key) override;
    void set (String^ key, JsonBaseType^ value) override;
}

Parameters

key
Type: System..::..String
The key of the value to get / set

Field Value

A JsonBaseType at the specified index

See Also

JsonObject Class
Item Overload
ArtOfTest.WebAii.Javascript Namespace


KeyEvent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyEvent Members
KeyEvent Class Constructors Methods Properties See Also Send Feedback

The KeyEvent type exposes the following members.

Constructors

 | Name | Description
Public method | KeyEvent()()()() | Initializes a new KeyEvent object.
Public method | KeyEvent(String) | Initializes a new KeyEvent object.
Public method | KeyEvent(String, Char) | Initializes a new KeyEvent object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CanBubble | Gets / Sets whether this event can bubble (Inherited from ScriptEvent.)
Public property | IsCancelable | Gets / Sets whether this event can be cancelled (Inherited from ScriptEvent.)
Public property | KeyCode | Gets / Sets the character code for this event
Public property | ModifierKeys | Gets / Sets the modifier keys bitmask (Inherited from ScriptUIEvent.)
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types (Inherited from ScriptEvent.)

See Also

KeyEvent Class
ArtOfTest.WebAii.Javascript Namespace


KeyEvent Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyEvent Constructor
KeyEvent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KeyEvent()()()() | Initializes a new KeyEvent object.
Public method | KeyEvent(String) | Initializes a new KeyEvent object.
Public method | KeyEvent(String, Char) | Initializes a new KeyEvent object.

See Also

KeyEvent Class
KeyEvent Members
ArtOfTest.WebAii.Javascript Namespace


KeyEvent Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyEvent Constructor
KeyEvent Class See Also Send Feedback
Initializes a new KeyEvent object.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public KeyEvent()
Visual Basic
Public Sub New
Visual C++
public:
KeyEvent()

See Also

KeyEvent Class
KeyEvent Overload
ArtOfTest.WebAii.Javascript Namespace


KeyEvent Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyEvent Constructor (String)
KeyEvent Class See Also Send Feedback
Initializes a new KeyEvent object.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public KeyEvent(
    string type
)
Visual Basic
Public Sub New ( _
    type As String _
)
Visual C++
public:
KeyEvent(
    String^ type
)

Parameters

type
Type: System..::..String
The type of key event.

See Also

KeyEvent Class
KeyEvent Overload
ArtOfTest.WebAii.Javascript Namespace


KeyEvent Constructor (String, Char)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyEvent Constructor (String, Char)
KeyEvent Class See Also Send Feedback
Initializes a new KeyEvent object.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public KeyEvent(
    string type,
    char key
)
Visual Basic
Public Sub New ( _
    type As String, _
    key As Char _
)
Visual C++
public:
KeyEvent(
    String^ type,
    wchar_t key
)

Parameters

type
Type: System..::..String
The type of key event.
key
Type: System..::..Char
The keycode for the key event.

See Also

KeyEvent Class
KeyEvent Overload
ArtOfTest.WebAii.Javascript Namespace


KeyEvent Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyEvent Methods
KeyEvent Class See Also Send Feedback

The KeyEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeyEvent Class
ArtOfTest.WebAii.Javascript Namespace


KeyEvent Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyEvent Properties
KeyEvent Class See Also Send Feedback

The KeyEvent type exposes the following members.

Properties

 | Name | Description
Public property | CanBubble | Gets / Sets whether this event can bubble (Inherited from ScriptEvent.)
Public property | IsCancelable | Gets / Sets whether this event can be cancelled (Inherited from ScriptEvent.)
Public property | KeyCode | Gets / Sets the character code for this event
Public property | ModifierKeys | Gets / Sets the modifier keys bitmask (Inherited from ScriptUIEvent.)
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types (Inherited from ScriptEvent.)

See Also

KeyEvent Class
ArtOfTest.WebAii.Javascript Namespace


KeyCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyEvent..::..KeyCode Property
KeyEvent Class See Also Send Feedback
Gets / Sets the character code for this event

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int KeyCode { get; set; }
Visual Basic
Public Property KeyCode As Integer
    Get
    Set
Visual C++
public:
property int KeyCode {
    int get ();
    void set (int value);
}

See Also

KeyEvent Class
ArtOfTest.WebAii.Javascript Namespace


MouseEvent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent Members
MouseEvent Class Constructors Methods Properties See Also Send Feedback

The MouseEvent type exposes the following members.

Constructors

 | Name | Description
Public method | MouseEvent()()()() | Initializes a new MouseEvent object.
Public method | MouseEvent(String) | Creates a mouse event of the given type, with other parameters set to default values

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetRelatedTarget(String) | Set the related target for this event to an HtmlControl, using the control's ClientSideLocator.
Public method | SetRelatedTarget(Element) | Set the related target for this event to an element, with a locator based on the tag name / tag index
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Button | Gets / Sets the mouse button of this event.
Public property | CanBubble | Gets / Sets whether this event can bubble (Inherited from ScriptEvent.)
Public property | IsCancelable | Gets / Sets whether this event can be cancelled (Inherited from ScriptEvent.)
Public property | ModifierKeys | Gets / Sets the modifier keys bitmask (Inherited from ScriptUIEvent.)
Public property | RelatedTargetLocator | Gets / Sets the related target control
Public property | ScreenX | Gets / Sets the horizontal position of the cursor for mouse events
Public property | ScreenY | Gets / Sets the vertical position of the cursor for mouse events
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types (Inherited from ScriptEvent.)

See Also

MouseEvent Class
ArtOfTest.WebAii.Javascript Namespace


MouseEvent Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent Constructor
MouseEvent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseEvent()()()() | Initializes a new MouseEvent object.
Public method | MouseEvent(String) | Creates a mouse event of the given type, with other parameters set to default values

See Also

MouseEvent Class
MouseEvent Members
ArtOfTest.WebAii.Javascript Namespace


MouseEvent Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent Constructor
MouseEvent Class See Also Send Feedback
Initializes a new MouseEvent object.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MouseEvent()
Visual Basic
Public Sub New
Visual C++
public:
MouseEvent()

See Also

MouseEvent Class
MouseEvent Overload
ArtOfTest.WebAii.Javascript Namespace


MouseEvent Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent Constructor (String)
MouseEvent Class See Also Send Feedback
Creates a mouse event of the given type, with other parameters set to default values

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MouseEvent(
    string type
)
Visual Basic
Public Sub New ( _
    type As String _
)
Visual C++
public:
MouseEvent(
    String^ type
)

Parameters

type
Type: System..::..String
The type of the event

See Also

MouseEvent Class
MouseEvent Overload
ArtOfTest.WebAii.Javascript Namespace


MouseEvent Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent Methods
MouseEvent Class See Also Send Feedback

The MouseEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetRelatedTarget(String) | Set the related target for this event to an HtmlControl, using the control's ClientSideLocator.
Public method | SetRelatedTarget(Element) | Set the related target for this event to an element, with a locator based on the tag name / tag index
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseEvent Class
ArtOfTest.WebAii.Javascript Namespace


SetRelatedTarget Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent..::..SetRelatedTarget Method
MouseEvent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetRelatedTarget(String) | Set the related target for this event to an HtmlControl, using the control's ClientSideLocator.
Public method | SetRelatedTarget(Element) | Set the related target for this event to an element, with a locator based on the tag name / tag index

See Also

MouseEvent Class
MouseEvent Members
ArtOfTest.WebAii.Javascript Namespace


SetRelatedTarget Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent..::..SetRelatedTarget Method (String)
MouseEvent Class See Also Send Feedback
Set the related target for this event to an HtmlControl, using the control's ClientSideLocator.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetRelatedTarget(
    string locator
)
Visual Basic
Public Sub SetRelatedTarget ( _
    locator As String _
)
Visual C++
public:
void SetRelatedTarget(
    String^ locator
)

Parameters

locator
Type: System..::..String
The related target control.

See Also

MouseEvent Class
SetRelatedTarget Overload
ArtOfTest.WebAii.Javascript Namespace


SetRelatedTarget Method (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent..::..SetRelatedTarget Method (Element)
MouseEvent Class See Also Send Feedback
Set the related target for this event to an element, with a locator based on the tag name / tag index

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetRelatedTarget(
    Element e
)
Visual Basic
Public Sub SetRelatedTarget ( _
    e As Element _
)
Visual C++
public:
void SetRelatedTarget(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The related target element

See Also

MouseEvent Class
SetRelatedTarget Overload
ArtOfTest.WebAii.Javascript Namespace


MouseEvent Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent Properties
MouseEvent Class See Also Send Feedback

The MouseEvent type exposes the following members.

Properties

 | Name | Description
Public property | Button | Gets / Sets the mouse button of this event.
Public property | CanBubble | Gets / Sets whether this event can bubble (Inherited from ScriptEvent.)
Public property | IsCancelable | Gets / Sets whether this event can be cancelled (Inherited from ScriptEvent.)
Public property | ModifierKeys | Gets / Sets the modifier keys bitmask (Inherited from ScriptUIEvent.)
Public property | RelatedTargetLocator | Gets / Sets the related target control
Public property | ScreenX | Gets / Sets the horizontal position of the cursor for mouse events
Public property | ScreenY | Gets / Sets the vertical position of the cursor for mouse events
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types (Inherited from ScriptEvent.)

See Also

MouseEvent Class
ArtOfTest.WebAii.Javascript Namespace


Button Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent..::..Button Property
MouseEvent Class See Also Send Feedback
Gets / Sets the mouse button of this event.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MouseButton Button { get; set; }
Visual Basic
Public Property Button As MouseButton
    Get
    Set
Visual C++
public:
property MouseButton Button {
    MouseButton get ();
    void set (MouseButton value);
}

See Also

MouseEvent Class
ArtOfTest.WebAii.Javascript Namespace


RelatedTargetLocator Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent..::..RelatedTargetLocator Property
MouseEvent Class See Also Send Feedback
Gets / Sets the related target control

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RelatedTargetLocator { get; set; }
Visual Basic
Public Property RelatedTargetLocator As String
    Get
    Set
Visual C++
public:
property String^ RelatedTargetLocator {
    String^ get ();
    void set (String^ value);
}

See Also

MouseEvent Class
ArtOfTest.WebAii.Javascript Namespace


ScreenX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent..::..ScreenX Property
MouseEvent Class See Also Send Feedback
Gets / Sets the horizontal position of the cursor for mouse events

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ScreenX { get; set; }
Visual Basic
Public Property ScreenX As Integer
    Get
    Set
Visual C++
public:
property int ScreenX {
    int get ();
    void set (int value);
}

See Also

MouseEvent Class
ArtOfTest.WebAii.Javascript Namespace


ScreenY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MouseEvent..::..ScreenY Property
MouseEvent Class See Also Send Feedback
Gets / Sets the vertical position of the cursor for mouse events

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ScreenY { get; set; }
Visual Basic
Public Property ScreenY As Integer
    Get
    Set
Visual C++
public:
property int ScreenY {
    int get ();
    void set (int value);
}

See Also

MouseEvent Class
ArtOfTest.WebAii.Javascript Namespace


ScriptEvent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent Members
ScriptEvent Class Constructors Methods Properties See Also Send Feedback

The ScriptEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ScriptEvent()()()() | Initializes a new ScriptEvent object.
Public method | ScriptEvent(String) | Creates a ScriptEvent with the given type and other properties set to default values

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CanBubble | Gets / Sets whether this event can bubble
Public property | IsCancelable | Gets / Sets whether this event can be cancelled
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types

See Also

ScriptEvent Class
ArtOfTest.WebAii.Javascript Namespace


ScriptEvent Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent Constructor
ScriptEvent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScriptEvent()()()() | Initializes a new ScriptEvent object.
Public method | ScriptEvent(String) | Creates a ScriptEvent with the given type and other properties set to default values

See Also

ScriptEvent Class
ScriptEvent Members
ArtOfTest.WebAii.Javascript Namespace


ScriptEvent Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent Constructor
ScriptEvent Class See Also Send Feedback
Initializes a new ScriptEvent object.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScriptEvent()
Visual Basic
Public Sub New
Visual C++
public:
ScriptEvent()

See Also

ScriptEvent Class
ScriptEvent Overload
ArtOfTest.WebAii.Javascript Namespace


ScriptEvent Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent Constructor (String)
ScriptEvent Class See Also Send Feedback
Creates a ScriptEvent with the given type and other properties set to default values

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScriptEvent(
    string type
)
Visual Basic
Public Sub New ( _
    type As String _
)
Visual C++
public:
ScriptEvent(
    String^ type
)

Parameters

type
Type: System..::..String
The type of the event

See Also

ScriptEvent Class
ScriptEvent Overload
ArtOfTest.WebAii.Javascript Namespace


ScriptEvent Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent Methods
ScriptEvent Class See Also Send Feedback

The ScriptEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptEvent Class
ArtOfTest.WebAii.Javascript Namespace


ScriptEvent Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent Properties
ScriptEvent Class See Also Send Feedback

The ScriptEvent type exposes the following members.

Properties

 | Name | Description
Public property | CanBubble | Gets / Sets whether this event can bubble
Public property | IsCancelable | Gets / Sets whether this event can be cancelled
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types

See Also

ScriptEvent Class
ArtOfTest.WebAii.Javascript Namespace


CanBubble Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent..::..CanBubble Property
ScriptEvent Class See Also Send Feedback
Gets / Sets whether this event can bubble

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanBubble { get; set; }
Visual Basic
Public Property CanBubble As Boolean
    Get
    Set
Visual C++
public:
property bool CanBubble {
    bool get ();
    void set (bool value);
}

See Also

ScriptEvent Class
ArtOfTest.WebAii.Javascript Namespace


IsCancelable Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent..::..IsCancelable Property
ScriptEvent Class See Also Send Feedback
Gets / Sets whether this event can be cancelled

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsCancelable { get; set; }
Visual Basic
Public Property IsCancelable As Boolean
    Get
    Set
Visual C++
public:
property bool IsCancelable {
    bool get ();
    void set (bool value);
}

See Also

ScriptEvent Class
ArtOfTest.WebAii.Javascript Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptEvent..::..Type Property
ScriptEvent Class See Also Send Feedback
The type of this event, for standard event types. TODO Make it so we can define custom event types

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Type { get; set; }
Visual Basic
Public Property Type As String
    Get
    Set
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

ScriptEvent Class
ArtOfTest.WebAii.Javascript Namespace


ScriptUIEvent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptUIEvent Members
ScriptUIEvent Class Constructors Methods Properties See Also Send Feedback

The ScriptUIEvent type exposes the following members.

Constructors

 | Name | Description
Public method | ScriptUIEvent()()()() | Initializes a new ScriptUIEvent object.
Public method | ScriptUIEvent(String) | Creates a UI event of the given type, with other parameters set to default values

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CanBubble | Gets / Sets whether this event can bubble (Inherited from ScriptEvent.)
Public property | IsCancelable | Gets / Sets whether this event can be cancelled (Inherited from ScriptEvent.)
Public property | ModifierKeys | Gets / Sets the modifier keys bitmask
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types (Inherited from ScriptEvent.)

See Also

ScriptUIEvent Class
ArtOfTest.WebAii.Javascript Namespace


ScriptUIEvent Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptUIEvent Constructor
ScriptUIEvent Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScriptUIEvent()()()() | Initializes a new ScriptUIEvent object.
Public method | ScriptUIEvent(String) | Creates a UI event of the given type, with other parameters set to default values

See Also

ScriptUIEvent Class
ScriptUIEvent Members
ArtOfTest.WebAii.Javascript Namespace


ScriptUIEvent Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptUIEvent Constructor
ScriptUIEvent Class See Also Send Feedback
Initializes a new ScriptUIEvent object.

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScriptUIEvent()
Visual Basic
Public Sub New
Visual C++
public:
ScriptUIEvent()

See Also

ScriptUIEvent Class
ScriptUIEvent Overload
ArtOfTest.WebAii.Javascript Namespace


ScriptUIEvent Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptUIEvent Constructor (String)
ScriptUIEvent Class See Also Send Feedback
Creates a UI event of the given type, with other parameters set to default values

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScriptUIEvent(
    string type
)
Visual Basic
Public Sub New ( _
    type As String _
)
Visual C++
public:
ScriptUIEvent(
    String^ type
)

Parameters

type
Type: System..::..String
The type of the event

See Also

ScriptUIEvent Class
ScriptUIEvent Overload
ArtOfTest.WebAii.Javascript Namespace


ScriptUIEvent Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptUIEvent Methods
ScriptUIEvent Class See Also Send Feedback

The ScriptUIEvent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScriptUIEvent Class
ArtOfTest.WebAii.Javascript Namespace


ScriptUIEvent Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptUIEvent Properties
ScriptUIEvent Class See Also Send Feedback

The ScriptUIEvent type exposes the following members.

Properties

 | Name | Description
Public property | CanBubble | Gets / Sets whether this event can bubble (Inherited from ScriptEvent.)
Public property | IsCancelable | Gets / Sets whether this event can be cancelled (Inherited from ScriptEvent.)
Public property | ModifierKeys | Gets / Sets the modifier keys bitmask
Public property | Type | The type of this event, for standard event types. TODO Make it so we can define custom event types (Inherited from ScriptEvent.)

See Also

ScriptUIEvent Class
ArtOfTest.WebAii.Javascript Namespace


ModifierKeys Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScriptUIEvent..::..ModifierKeys Property
ScriptUIEvent Class See Also Send Feedback
Gets / Sets the modifier keys bitmask

Namespace: ArtOfTest.WebAii.Javascript
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ModifierKeys ModifierKeys { get; set; }
Visual Basic
Public Property ModifierKeys As ModifierKeys
    Get
    Set
Visual C++
public:
property ModifierKeys ModifierKeys {
    ModifierKeys get ();
    void set (ModifierKeys value);
}

See Also

ScriptUIEvent Class
ArtOfTest.WebAii.Javascript Namespace


ArtOfTest.WebAii.jQuery Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.jQuery Namespace
Send Feedback
Namespace for working with jQuery on your webpages. See http://jquery.com/.

Classes

 | Class | Description
Public class | jQuery | Provide jQuery selector syntax support. Version 1.3 - http://docs.jquery.com/Selectors
Public class | jQueryExtension | This class extends the legacy Find class and BaseText clss and adds jQuery capability.


jQuery Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery Members
jQuery Class Methods See Also Send Feedback

The jQuery type exposes the following members.

Methods

 | Name | Description
Public method | all()()()() | Matches all elements.
Public method | all<(Of <<'(T>)>>)()()()() | Matches all elements as a strongly typed control.
Public method | attributes | Filter based on the attributes.
Public method | button | Filter on all input type=button
Public method | checkbox | Filter on all input type=checkbox
Public method | child | Matches all child elements only. 'parent > child', http://docs.jquery.com/Selectors/child#parentchild
Public method | classes | Matches all elements with the given class or classes.
Public method | contains | Matches all elements that contain specific text. It's case sensitive.
Public method | descendant | Matches all descendant elements.
Public method | empty | Matches all elements that have no children (including text nodes).
Public method | eq | Matches a specific index
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | even | Matches even elements, zero-indexed.
Public method | file | Filter on all input type=file.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | first()()()() | Matches the first selected element.
Public method | first<(Of <<'(TControl>)>>)()()()() | Matches the first selected element.
Public method | firstChild | Matches all elements that are the first child of their parent.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | gt | Matches index greated than
Public method | header | Matches all header elements.
Public method | id(String) | Matches a single element with the given id attribute.
Public method | id<(Of <<'(TControl>)>>)(String) | Matches a single element with the given id attribute.
Public method | image | Filter on all input type=image
Public method | input | Filter on all 'input' elements.
Public method | last()()()() | Matches the last selected element.
Public method | last<(Of <<'(TControl>)>>)()()()() | Matches the last selected element.
Public method | lastChild | Matches all elements that are the last child of their parent.
Public method | lt | Matches index less than.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | next | Matches all next elements. 'prev + next', The immediate next sibling. http://docs.jquery.com/Selectors/next#prevnext
Public method | odd | Matches odd elements, zero-indexed.
Public method | onlyChild | Matches all elements that are the only child of their parent.
Public method | parent | Matches all elements that are parents - they have child elements, including text.
Public method | password | Filter on all input type=password
Public method | radio | Filter on all input type=radio
Public method | reset | Filter on all input type=reset
Public method | siblings | Matches all sibling elements. 'prev ~ siblings', All next sibling elements. http://docs.jquery.com/Selectors/siblings#prevsiblings
Public method | submit | Filter on all input type=submit
Public method | tag | Matches all elements with the given tag name.
Public method | text | Filter on all input type=text.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


jQuery Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery Methods
jQuery Class See Also Send Feedback

The jQuery type exposes the following members.

Methods

 | Name | Description
Public method | all()()()() | Matches all elements.
Public method | all<(Of <<'(T>)>>)()()()() | Matches all elements as a strongly typed control.
Public method | attributes | Filter based on the attributes.
Public method | button | Filter on all input type=button
Public method | checkbox | Filter on all input type=checkbox
Public method | child | Matches all child elements only. 'parent > child', http://docs.jquery.com/Selectors/child#parentchild
Public method | classes | Matches all elements with the given class or classes.
Public method | contains | Matches all elements that contain specific text. It's case sensitive.
Public method | descendant | Matches all descendant elements.
Public method | empty | Matches all elements that have no children (including text nodes).
Public method | eq | Matches a specific index
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | even | Matches even elements, zero-indexed.
Public method | file | Filter on all input type=file.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | first()()()() | Matches the first selected element.
Public method | first<(Of <<'(TControl>)>>)()()()() | Matches the first selected element.
Public method | firstChild | Matches all elements that are the first child of their parent.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | gt | Matches index greated than
Public method | header | Matches all header elements.
Public method | id(String) | Matches a single element with the given id attribute.
Public method | id<(Of <<'(TControl>)>>)(String) | Matches a single element with the given id attribute.
Public method | image | Filter on all input type=image
Public method | input | Filter on all 'input' elements.
Public method | last()()()() | Matches the last selected element.
Public method | last<(Of <<'(TControl>)>>)()()()() | Matches the last selected element.
Public method | lastChild | Matches all elements that are the last child of their parent.
Public method | lt | Matches index less than.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | next | Matches all next elements. 'prev + next', The immediate next sibling. http://docs.jquery.com/Selectors/next#prevnext
Public method | odd | Matches odd elements, zero-indexed.
Public method | onlyChild | Matches all elements that are the only child of their parent.
Public method | parent | Matches all elements that are parents - they have child elements, including text.
Public method | password | Filter on all input type=password
Public method | radio | Filter on all input type=radio
Public method | reset | Filter on all input type=reset
Public method | siblings | Matches all sibling elements. 'prev ~ siblings', All next sibling elements. http://docs.jquery.com/Selectors/siblings#prevsiblings
Public method | submit | Filter on all input type=submit
Public method | tag | Matches all elements with the given tag name.
Public method | text | Filter on all input type=text.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


all Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..all Method
jQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | all<(Of <<'(T>)>>)()()()() | Matches all elements as a strongly typed control.
Public method | all()()()() | Matches all elements.

See Also

jQuery Class
jQuery Members
ArtOfTest.WebAii.jQuery Namespace


all(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..all<(Of <(<'T>)>)> Method
jQuery Class See Also Send Feedback
Matches all elements as a strongly typed control.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<T> all<T>()
where T : new(), HtmlControl
Visual Basic
Public Function all(Of T As {New, HtmlControl}) As IList(Of T)
Visual C++
public:
generic<typename T>
where T : gcnew(), HtmlControl
IList<T>^ all()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.all``1"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.all``1"]

See Also

jQuery Class
all Overload
ArtOfTest.WebAii.jQuery Namespace


all Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..all Method
jQuery Class See Also Send Feedback
Matches all elements.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<Element> all()
Visual Basic
Public Function all As IList(Of Element)
Visual C++
public:
IList<Element^>^ all()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.all"]

See Also

jQuery Class
all Overload
ArtOfTest.WebAii.jQuery Namespace


attributes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..attributes Method
jQuery Class See Also Send Feedback
Filter based on the attributes.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery attributes(
    params string[] attributeFilters
)
Visual Basic
Public Function attributes ( _
    ParamArray attributeFilters As String() _
) As jQuery
Visual C++
public:
jQuery^ attributes(
    ... array<String^>^ attributeFilters
)

Parameters

attributeFilters
Type: array< System..::..String >[]()[][]

[Missing <param name="attributeFilters"/> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.attributes(System.String[])"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.attributes(System.String[])"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


button Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..button Method
jQuery Class See Also Send Feedback
Filter on all input type=button

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputButton> button()
Visual Basic
Public Function button As IList(Of HtmlInputButton)
Visual C++
public:
IList<HtmlInputButton^>^ button()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.button"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


checkbox Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..checkbox Method
jQuery Class See Also Send Feedback
Filter on all input type=checkbox

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputCheckBox> checkbox()
Visual Basic
Public Function checkbox As IList(Of HtmlInputCheckBox)
Visual C++
public:
IList<HtmlInputCheckBox^>^ checkbox()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.checkbox"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


child Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..child Method
jQuery Class See Also Send Feedback
Matches all child elements only. 'parent > child', http://docs.jquery.com/Selectors/child#parentchild

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery child()
Visual Basic
Public Function child As jQuery
Visual C++
public:
jQuery^ child()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.child"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


classes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..classes Method
jQuery Class See Also Send Feedback
Matches all elements with the given class or classes.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery classes(
    params string[] classes
)
Visual Basic
Public Function classes ( _
    ParamArray classes As String() _
) As jQuery
Visual C++
public:
jQuery^ classes(
    ... array<String^>^ classes
)

Parameters

classes
Type: array< System..::..String >[]()[][]
1 to n classes to match on the query

Return Value

The query match

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


contains Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..contains Method
jQuery Class See Also Send Feedback
Matches all elements that contain specific text. It's case sensitive.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery contains(
    string text
)
Visual Basic
Public Function contains ( _
    text As String _
) As jQuery
Visual C++
public:
jQuery^ contains(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.contains(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.contains(System.String)"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


descendant Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..descendant Method
jQuery Class See Also Send Feedback
Matches all descendant elements.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery descendant()
Visual Basic
Public Function descendant As jQuery
Visual C++
public:
jQuery^ descendant()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.descendant"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


empty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..empty Method
jQuery Class See Also Send Feedback
Matches all elements that have no children (including text nodes).

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery empty()
Visual Basic
Public Function empty As jQuery
Visual C++
public:
jQuery^ empty()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.empty"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


eq Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..eq Method
jQuery Class See Also Send Feedback
Matches a specific index

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element eq(
    int index
)
Visual Basic
Public Function eq ( _
    index As Integer _
) As Element
Visual C++
public:
Element^ eq(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.eq(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.eq(System.Int32)"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


even Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..even Method
jQuery Class See Also Send Feedback
Matches even elements, zero-indexed.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery even()
Visual Basic
Public Function even As jQuery
Visual C++
public:
jQuery^ even()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.even"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


file Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..file Method
jQuery Class See Also Send Feedback
Filter on all input type=file.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputFile> file()
Visual Basic
Public Function file As IList(Of HtmlInputFile)
Visual C++
public:
IList<HtmlInputFile^>^ file()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.file"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


first Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..first Method
jQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | first()()()() | Matches the first selected element.
Public method | first<(Of <<'(TControl>)>>)()()()() | Matches the first selected element.

See Also

jQuery Class
jQuery Members
ArtOfTest.WebAii.jQuery Namespace


first Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..first Method
jQuery Class See Also Send Feedback
Matches the first selected element.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element first()
Visual Basic
Public Function first As Element
Visual C++
public:
Element^ first()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.first"]

See Also

jQuery Class
first Overload
ArtOfTest.WebAii.jQuery Namespace


first(TControl) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..first<(Of <(<'TControl>)>)> Method
jQuery Class See Also Send Feedback
Matches the first selected element.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl first<TControl>()
where TControl : new(), HtmlControl
Visual Basic
Public Function first(Of TControl As {New, HtmlControl}) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), HtmlControl
TControl first()

Type Parameters

TControl

[Missing <typeparam name="TControl"/> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.first``1"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.first``1"]

See Also

jQuery Class
first Overload
ArtOfTest.WebAii.jQuery Namespace


firstChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..firstChild Method
jQuery Class See Also Send Feedback
Matches all elements that are the first child of their parent.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery firstChild()
Visual Basic
Public Function firstChild As jQuery
Visual C++
public:
jQuery^ firstChild()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.firstChild"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


gt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..gt Method
jQuery Class See Also Send Feedback
Matches index greated than

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery gt(
    int index
)
Visual Basic
Public Function gt ( _
    index As Integer _
) As jQuery
Visual C++
public:
jQuery^ gt(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.gt(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.gt(System.Int32)"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


header Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..header Method
jQuery Class See Also Send Feedback
Matches all header elements.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery header()
Visual Basic
Public Function header As jQuery
Visual C++
public:
jQuery^ header()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.header"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


id Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..id Method
jQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | id(String) | Matches a single element with the given id attribute.
Public method | id<(Of <<'(TControl>)>>)(String) | Matches a single element with the given id attribute.

See Also

jQuery Class
jQuery Members
ArtOfTest.WebAii.jQuery Namespace


id Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..id Method (String)
jQuery Class See Also Send Feedback
Matches a single element with the given id attribute.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element id(
    string id
)
Visual Basic
Public Function id ( _
    id As String _
) As Element
Visual C++
public:
Element^ id(
    String^ id
)

Parameters

id
Type: System..::..String
An ID to search for, specified via the id attribute of an element

Return Value

The first matched element else null.

See Also

jQuery Class
id Overload
ArtOfTest.WebAii.jQuery Namespace


id(TControl) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..id<(Of <(<'TControl>)>)> Method (String)
jQuery Class See Also Send Feedback
Matches a single element with the given id attribute.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl id<TControl>(
    string id
)
where TControl : new(), HtmlControl
Visual Basic
Public Function id(Of TControl As {New, HtmlControl}) ( _
    id As String _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), HtmlControl
TControl id(
    String^ id
)

Parameters

id
Type: System..::..String
The control id

Type Parameters

TControl
The control type

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.id``1(System.String)"]

See Also

jQuery Class
id Overload
ArtOfTest.WebAii.jQuery Namespace


image Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..image Method
jQuery Class See Also Send Feedback
Filter on all input type=image

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputImage> image()
Visual Basic
Public Function image As IList(Of HtmlInputImage)
Visual C++
public:
IList<HtmlInputImage^>^ image()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.image"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


input Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..input Method
jQuery Class See Also Send Feedback
Filter on all 'input' elements.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputControl> input()
Visual Basic
Public Function input As IList(Of HtmlInputControl)
Visual C++
public:
IList<HtmlInputControl^>^ input()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.input"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


last Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..last Method
jQuery Class See Also Send Feedback

Overload List

 | Name | Description
Public method | last<(Of <<'(TControl>)>>)()()()() | Matches the last selected element.
Public method | last()()()() | Matches the last selected element.

See Also

jQuery Class
jQuery Members
ArtOfTest.WebAii.jQuery Namespace


last(TControl) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..last<(Of <(<'TControl>)>)> Method
jQuery Class See Also Send Feedback
Matches the last selected element.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl last<TControl>()
where TControl : new(), HtmlControl
Visual Basic
Public Function last(Of TControl As {New, HtmlControl}) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), HtmlControl
TControl last()

Type Parameters

TControl

[Missing <typeparam name="TControl"/> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.last``1"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.last``1"]

See Also

jQuery Class
last Overload
ArtOfTest.WebAii.jQuery Namespace


last Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..last Method
jQuery Class See Also Send Feedback
Matches the last selected element.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element last()
Visual Basic
Public Function last As Element
Visual C++
public:
Element^ last()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.last"]

See Also

jQuery Class
last Overload
ArtOfTest.WebAii.jQuery Namespace


lastChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..lastChild Method
jQuery Class See Also Send Feedback
Matches all elements that are the last child of their parent.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery lastChild()
Visual Basic
Public Function lastChild As jQuery
Visual C++
public:
jQuery^ lastChild()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.lastChild"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


lt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..lt Method
jQuery Class See Also Send Feedback
Matches index less than.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery lt(
    int index
)
Visual Basic
Public Function lt ( _
    index As Integer _
) As jQuery
Visual C++
public:
jQuery^ lt(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.lt(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.lt(System.Int32)"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


next Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..next Method
jQuery Class See Also Send Feedback
Matches all next elements. 'prev + next', The immediate next sibling. http://docs.jquery.com/Selectors/next#prevnext

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery next()
Visual Basic
Public Function next As jQuery
Visual C++
public:
jQuery^ next()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.next"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


odd Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..odd Method
jQuery Class See Also Send Feedback
Matches odd elements, zero-indexed.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery odd()
Visual Basic
Public Function odd As jQuery
Visual C++
public:
jQuery^ odd()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.odd"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


onlyChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..onlyChild Method
jQuery Class See Also Send Feedback
Matches all elements that are the only child of their parent.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery onlyChild()
Visual Basic
Public Function onlyChild As jQuery
Visual C++
public:
jQuery^ onlyChild()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.onlyChild"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


parent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..parent Method
jQuery Class See Also Send Feedback
Matches all elements that are parents - they have child elements, including text.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery parent()
Visual Basic
Public Function parent As jQuery
Visual C++
public:
jQuery^ parent()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.parent"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


password Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..password Method
jQuery Class See Also Send Feedback
Filter on all input type=password

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputPassword> password()
Visual Basic
Public Function password As IList(Of HtmlInputPassword)
Visual C++
public:
IList<HtmlInputPassword^>^ password()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.password"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


radio Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..radio Method
jQuery Class See Also Send Feedback
Filter on all input type=radio

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputRadioButton> radio()
Visual Basic
Public Function radio As IList(Of HtmlInputRadioButton)
Visual C++
public:
IList<HtmlInputRadioButton^>^ radio()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.radio"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


reset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..reset Method
jQuery Class See Also Send Feedback
Filter on all input type=reset

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputReset> reset()
Visual Basic
Public Function reset As IList(Of HtmlInputReset)
Visual C++
public:
IList<HtmlInputReset^>^ reset()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.reset"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


siblings Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..siblings Method
jQuery Class See Also Send Feedback
Matches all sibling elements. 'prev ~ siblings', All next sibling elements. http://docs.jquery.com/Selectors/siblings#prevsiblings

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery siblings()
Visual Basic
Public Function siblings As jQuery
Visual C++
public:
jQuery^ siblings()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.siblings"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


submit Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..submit Method
jQuery Class See Also Send Feedback
Filter on all input type=submit

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputSubmit> submit()
Visual Basic
Public Function submit As IList(Of HtmlInputSubmit)
Visual C++
public:
IList<HtmlInputSubmit^>^ submit()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.submit"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


tag Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..tag Method
jQuery Class See Also Send Feedback
Matches all elements with the given tag name.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public jQuery tag(
    string element
)
Visual Basic
Public Function tag ( _
    element As String _
) As jQuery
Visual C++
public:
jQuery^ tag(
    String^ element
)

Parameters

element
Type: System..::..String
The tag name to match

Return Value

The query match.

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


text Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQuery..::..text Method
jQuery Class See Also Send Feedback
Filter on all input type=text.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<HtmlInputText> text()
Visual Basic
Public Function text As IList(Of HtmlInputText)
Visual C++
public:
IList<HtmlInputText^>^ text()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQuery.text"]

See Also

jQuery Class
ArtOfTest.WebAii.jQuery Namespace


jQueryExtension Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQueryExtension Members
jQueryExtension Class Methods See Also Send Feedback

The jQueryExtension type exposes the following members.

Methods

Name | Description
jQuery(BaseTest) | Returns the jQuery object associated with the BaseTest object.
jQuery(Find) | Creates and returns a new jQuery object for the Find object.
TojQuery | Start a jQuery expression from this element.

See Also

jQueryExtension Class
ArtOfTest.WebAii.jQuery Namespace


jQueryExtension Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQueryExtension Methods
jQueryExtension Class See Also Send Feedback

The jQueryExtension type exposes the following members.

Methods

Name | Description
jQuery(BaseTest) | Returns the jQuery object associated with the BaseTest object.
jQuery(Find) | Creates and returns a new jQuery object for the Find object.
TojQuery | Start a jQuery expression from this element.

See Also

jQueryExtension Class
ArtOfTest.WebAii.jQuery Namespace


jQuery Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQueryExtension..::..jQuery Method
jQueryExtension Class See Also Send Feedback

Overload List

Name | Description
jQuery(BaseTest) | Returns the jQuery object associated with the BaseTest object.
jQuery(Find) | Creates and returns a new jQuery object for the Find object.

See Also

jQueryExtension Class
jQueryExtension Members
ArtOfTest.WebAii.jQuery Namespace


jQuery Method (BaseTest)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQueryExtension..::..jQuery Method (BaseTest)
jQueryExtension Class See Also Send Feedback
Returns the jQuery object associated with the BaseTest object.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static jQuery jQuery(
    this BaseTest baseTest
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function jQuery ( _
    baseTest As BaseTest _
) As jQuery
Visual C++
[ExtensionAttribute]
public:
static jQuery^ jQuery(
    BaseTest^ baseTest
)

Parameters

baseTest
Type: ArtOfTest.WebAii.TestTemplates..::..BaseTest
The BaseTest object to get the jQuery object from.

Return Value

A jQuery object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BaseTest. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

jQueryExtension Class
jQuery Overload
ArtOfTest.WebAii.jQuery Namespace


jQuery Method (Find)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQueryExtension..::..jQuery Method (Find)
jQueryExtension Class See Also Send Feedback
Creates and returns a new jQuery object for the Find object.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static jQuery jQuery(
    this Find find
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function jQuery ( _
    find As Find _
) As jQuery
Visual C++
[ExtensionAttribute]
public:
static jQuery^ jQuery(
    Find^ find
)

Parameters

find
Type: ArtOfTest.WebAii.Core..::..Find
The Find object to create the jQuery for.

Return Value

A jQuery object initialized for the Find object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Find. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

jQueryExtension Class
jQuery Overload
ArtOfTest.WebAii.jQuery Namespace


TojQuery Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
jQueryExtension..::..TojQuery Method
jQueryExtension Class See Also Send Feedback
Start a jQuery expression from this element.

Namespace: ArtOfTest.WebAii.jQuery
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static jQuery TojQuery(
    this Element e
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function TojQuery ( _
    e As Element _
) As jQuery
Visual C++
[ExtensionAttribute]
public:
static jQuery^ TojQuery(
    Element^ e
)

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.jQuery.jQueryExtension.TojQuery(ArtOfTest.WebAii.ObjectModel.Element)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Element. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

jQueryExtension Class
ArtOfTest.WebAii.jQuery Namespace


ArtOfTest.WebAii.Messaging.Http Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Messaging.Http Namespace
Send Feedback
Namespace for the HTTP proxy functionality contained in the framework.

Classes

 | Class | Description
Public class | HttpProxyConstants |
Public class | HttpProxyManager | Class used to manage the HTTP proxy agent.
Public class | HttpRequest | Used to create and manipulate an HTTP request.
Public class | HttpRequestEventArgs | EventArgs subclass that wraps an HTTP request, and possibly the related response
Public class | HttpRequestResponsePair |
Public class | HttpResponse | Class wrapper of an HTTP response.
Public class | HttpResponseEventArgs | EventArgs subclass that wraps an HTTP response and the related request
Public class | HttpTrafficEvent |
Public class | ListenerInfo | Base class used by RequestListenerInfo and ResponseListenerInfo
Public class | RequestListenerInfo | Wraps a listener for BeforeRequest events from the proxy
Public class | ResponseListenerInfo | Wraps a listener for BeforeResponse events from the proxy

Delegates

 | Delegate | Description
Public delegate | HttpRequestHandler | Event handler delegate for the HTTP proxy's BeforeRequest events
Public delegate | HttpResponseHandler | Event handler delegate for the HTTP proxy's BeforeResponse events


HttpProxyConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyConstants Members
HttpProxyConstants Class Methods Properties See Also Send Feedback

The HttpProxyConstants type exposes the following members.

Methods

Name | Description
ExecutablePath |

Properties

Name | Description
InstallCertificateArg |

See Also

HttpProxyConstants Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpProxyConstants Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyConstants Methods
HttpProxyConstants Class See Also Send Feedback

The HttpProxyConstants type exposes the following members.

Methods

Name | Description
ExecutablePath |

See Also

HttpProxyConstants Class
ArtOfTest.WebAii.Messaging.Http Namespace


ExecutablePath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyConstants..::..ExecutablePath Method
HttpProxyConstants Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpProxyConstants.ExecutablePath"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string ExecutablePath()
Visual Basic
Public Shared Function ExecutablePath As String
Visual C++
public:
static String^ ExecutablePath()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpProxyConstants.ExecutablePath"]

See Also

HttpProxyConstants Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpProxyConstants Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyConstants Properties
HttpProxyConstants Class See Also Send Feedback

The HttpProxyConstants type exposes the following members.

Properties

Name | Description
InstallCertificateArg |

See Also

HttpProxyConstants Class
ArtOfTest.WebAii.Messaging.Http Namespace


InstallCertificateArg Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyConstants..::..InstallCertificateArg Property
HttpProxyConstants Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Messaging.Http.HttpProxyConstants.InstallCertificateArg"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string InstallCertificateArg { get; }
Visual Basic
Public Shared ReadOnly Property InstallCertificateArg As String
    Get
Visual C++
public:
static property String^ InstallCertificateArg {
    String^ get ();
}

See Also

HttpProxyConstants Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpProxyManager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyManager Members
HttpProxyManager Class Methods Properties See Also Send Feedback

The HttpProxyManager type exposes the following members.

Methods

 | Name | Description
Public method | AddBeforeRequestListener | Adds an event handler to the proxy's BeforeRequest event. The handler will be called when an HTTP request has been received from the web browser, but before it has been sent to the downstream server.
Public method | AddBeforeResponseListener | Subscribes an event handler to the proxy's BeforeResponse event. The handler will be called when an HTTP response has been received from a server, but before it has been sent to the web browser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveBeforeRequestListener | Removes an event handler from the collection of handlers subscribed to the proxy's BeforeRequest event
Public method | RemoveBeforeResponseListener | Unsubscribes an event handler from the proxy's BeforeResponse event
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsRunning | Gets whether or not the proxy is running.

See Also

HttpProxyManager Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpProxyManager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyManager Methods
HttpProxyManager Class See Also Send Feedback

The HttpProxyManager type exposes the following members.

Methods

 | Name | Description
Public method | AddBeforeRequestListener | Adds an event handler to the proxy's BeforeRequest event. The handler will be called when an HTTP request has been received from the web browser, but before it has been sent to the downstream server.
Public method | AddBeforeResponseListener | Subscribes an event handler to the proxy's BeforeResponse event. The handler will be called when an HTTP response has been received from a server, but before it has been sent to the web browser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveBeforeRequestListener | Removes an event handler from the collection of handlers subscribed to the proxy's BeforeRequest event
Public method | RemoveBeforeResponseListener | Unsubscribes an event handler from the proxy's BeforeResponse event
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpProxyManager Class
ArtOfTest.WebAii.Messaging.Http Namespace


AddBeforeRequestListener Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyManager..::..AddBeforeRequestListener Method
HttpProxyManager Class See Also Send Feedback
Adds an event handler to the proxy's BeforeRequest event. The handler will be called when an HTTP request has been received from the web browser, but before it has been sent to the downstream server.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddBeforeRequestListener(
    RequestListenerInfo info
)
Visual Basic
Public Sub AddBeforeRequestListener ( _
    info As RequestListenerInfo _
)
Visual C++
public:
void AddBeforeRequestListener(
    RequestListenerInfo^ info
)

Parameters

info
Type: ArtOfTest.WebAii.Messaging.Http..::..RequestListenerInfo
ListenerInfo object describing the subscription

See Also

HttpProxyManager Class
ArtOfTest.WebAii.Messaging.Http Namespace


AddBeforeResponseListener Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyManager..::..AddBeforeResponseListener Method
HttpProxyManager Class See Also Send Feedback
Subscribes an event handler to the proxy's BeforeResponse event. The handler will be called when an HTTP response has been received from a server, but before it has been sent to the web browser.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddBeforeResponseListener(
    ResponseListenerInfo info
)
Visual Basic
Public Sub AddBeforeResponseListener ( _
    info As ResponseListenerInfo _
)
Visual C++
public:
void AddBeforeResponseListener(
    ResponseListenerInfo^ info
)

Parameters

info
Type: ArtOfTest.WebAii.Messaging.Http..::..ResponseListenerInfo
ListenerInfo object describing the subscription

See Also

HttpProxyManager Class
ArtOfTest.WebAii.Messaging.Http Namespace


RemoveBeforeRequestListener Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyManager..::..RemoveBeforeRequestListener Method
HttpProxyManager Class See Also Send Feedback
Removes an event handler from the collection of handlers subscribed to the proxy's BeforeRequest event

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveBeforeRequestListener(
    RequestListenerInfo info
)
Visual Basic
Public Sub RemoveBeforeRequestListener ( _
    info As RequestListenerInfo _
)
Visual C++
public:
void RemoveBeforeRequestListener(
    RequestListenerInfo^ info
)

Parameters

info
Type: ArtOfTest.WebAii.Messaging.Http..::..RequestListenerInfo
ListenerInfo object describing the event handler. Use the same ListenerInfo object that was used to subscribe to the event.

See Also

HttpProxyManager Class
ArtOfTest.WebAii.Messaging.Http Namespace


RemoveBeforeResponseListener Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyManager..::..RemoveBeforeResponseListener Method
HttpProxyManager Class See Also Send Feedback
Unsubscribes an event handler from the proxy's BeforeResponse event

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveBeforeResponseListener(
    ResponseListenerInfo info
)
Visual Basic
Public Sub RemoveBeforeResponseListener ( _
    info As ResponseListenerInfo _
)
Visual C++
public:
void RemoveBeforeResponseListener(
    ResponseListenerInfo^ info
)

Parameters

info
Type: ArtOfTest.WebAii.Messaging.Http..::..ResponseListenerInfo
A ListenerInfo object describing the event handler. Use the same ListenerInfo object that was used to subscribe to the event.

See Also

HttpProxyManager Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpProxyManager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyManager Properties
HttpProxyManager Class See Also Send Feedback

The HttpProxyManager type exposes the following members.

Properties

 | Name | Description
Public property | IsRunning | Gets whether or not the proxy is running.

See Also

HttpProxyManager Class
ArtOfTest.WebAii.Messaging.Http Namespace


IsRunning Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpProxyManager..::..IsRunning Property
HttpProxyManager Class See Also Send Feedback
Gets whether or not the proxy is running.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsRunning { get; }
Visual Basic
Public ReadOnly Property IsRunning As Boolean
    Get
Visual C++
public:
property bool IsRunning {
    bool get ();
}

See Also

HttpProxyManager Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequest Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest Members
HttpRequest Class Constructors Methods Properties See Also Send Feedback

The HttpRequest type exposes the following members.

Constructors

 | Name | Description
Public method | HttpRequest()()()() | Creates an empty HttpRequest object
Public method | HttpRequest(array<Byte>[]()[][]) | Create a new HttpRequest object from the given network data

Methods

 | Name | Description
Public method | CleanUpConnectionOptions | Strips out any headers matching the tokens listed in the Connection header, and removes all tokens from the Connection header except for 'close'.
Public method | DecodeContent |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPostFormContent |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnchunkedContent |
Public method | InitializeHttpWebRequest | NOTE: The caller will still have to write the content, because it is highly dependent on threading model.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByteArray | Rebuilds the HTTP query
Public method | ToString()()()() | Converts this HTTP request object to a string representation. HTTP request header information will not be included. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts this HTTP request object to a string representation.

Properties

 | Name | Description
Public property | Content | Gets / Sets the content of this request
Public property | Guid | Gets the unique identifier of this request
Public property | HasCloseConnectionOption | Gets whether this request specifies that the connection be closed after a response to it is received
Public property | Headers | Gets / Sets the headers for this request
Public property | HttpMethod | Gets / Sets the HTTP method of this request
Public property | HttpVersion | Gets / Sets the HTTP version string of this request
Public property | ID | Gets the ID number of this request
Public property | RequestUri | Gets / Sets the URI of this request.
Public property | Response | Gets / Sets the response to this request. If a response is set, the request will not be sent to the server.
Public property | Timestamp | The time at which this request was sent to the server

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequest Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest Constructor
HttpRequest Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HttpRequest()()()() | Creates an empty HttpRequest object
Public method | HttpRequest(array<Byte>[]()[][]) | Create a new HttpRequest object from the given network data

See Also

HttpRequest Class
HttpRequest Members
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequest Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest Constructor
HttpRequest Class See Also Send Feedback
Creates an empty HttpRequest object

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpRequest()
Visual Basic
Public Sub New
Visual C++
public:
HttpRequest()

See Also

HttpRequest Class
HttpRequest Overload
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequest Constructor (Byte[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest Constructor (array<Byte>[]()[][])
HttpRequest Class See Also Send Feedback
Create a new HttpRequest object from the given network data

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpRequest(
    byte[] buffer
)
Visual Basic
Public Sub New ( _
    buffer As Byte() _
)
Visual C++
public:
HttpRequest(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: array< System..::..Byte >[]()[][]
A buffer containing the network data that will be parsed to generate an HttpRequest object

See Also

HttpRequest Class
HttpRequest Overload
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequest Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest Methods
HttpRequest Class See Also Send Feedback

The HttpRequest type exposes the following members.

Methods

 | Name | Description
Public method | CleanUpConnectionOptions | Strips out any headers matching the tokens listed in the Connection header, and removes all tokens from the Connection header except for 'close'.
Public method | DecodeContent |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPostFormContent |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnchunkedContent |
Public method | InitializeHttpWebRequest | NOTE: The caller will still have to write the content, because it is highly dependent on threading model.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByteArray | Rebuilds the HTTP query
Public method | ToString()()()() | Converts this HTTP request object to a string representation. HTTP request header information will not be included. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts this HTTP request object to a string representation.

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


CleanUpConnectionOptions Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..CleanUpConnectionOptions Method
HttpRequest Class See Also Send Feedback
Strips out any headers matching the tokens listed in the Connection header, and removes all tokens from the Connection header except for 'close'.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CleanUpConnectionOptions()
Visual Basic
Public Sub CleanUpConnectionOptions
Visual C++
public:
void CleanUpConnectionOptions()

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


DecodeContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..DecodeContent Method
HttpRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequest.DecodeContent"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DecodeContent()
Visual Basic
Public Function DecodeContent As String
Visual C++
public:
String^ DecodeContent()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequest.DecodeContent"]

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


GetPostFormContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..GetPostFormContent Method
HttpRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequest.GetPostFormContent"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NameValueCollection GetPostFormContent()
Visual Basic
Public Function GetPostFormContent As NameValueCollection
Visual C++
public:
NameValueCollection^ GetPostFormContent()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequest.GetPostFormContent"]

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


GetUnchunkedContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..GetUnchunkedContent Method
HttpRequest Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequest.GetUnchunkedContent"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public byte[] GetUnchunkedContent()
Visual Basic
Public Function GetUnchunkedContent As Byte()
Visual C++
public:
array<unsigned char>^ GetUnchunkedContent()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequest.GetUnchunkedContent"]

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


InitializeHttpWebRequest Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..InitializeHttpWebRequest Method
HttpRequest Class See Also Send Feedback
NOTE: The caller will still have to write the content, because it is highly dependent on threading model.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpWebRequest InitializeHttpWebRequest()
Visual Basic
Public Function InitializeHttpWebRequest As HttpWebRequest
Visual C++
public:
HttpWebRequest^ InitializeHttpWebRequest()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequest.InitializeHttpWebRequest"]

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


ToByteArray Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..ToByteArray Method
HttpRequest Class See Also Send Feedback
Rebuilds the HTTP query

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public byte[] ToByteArray()
Visual Basic
Public Function ToByteArray As Byte()
Visual C++
public:
array<unsigned char>^ ToByteArray()

Return Value

A byte array representing the rebuilt HTTP query string.

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


ToString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..ToString Method
HttpRequest Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Converts this HTTP request object to a string representation. HTTP request header information will not be included. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts this HTTP request object to a string representation.

See Also

HttpRequest Class
HttpRequest Members
ArtOfTest.WebAii.Messaging.Http Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..ToString Method
HttpRequest Class See Also Send Feedback
Converts this HTTP request object to a string representation. HTTP request header information will not be included.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of this header request.

See Also

HttpRequest Class
ToString Overload
ArtOfTest.WebAii.Messaging.Http Namespace


ToString Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..ToString Method (Boolean)
HttpRequest Class See Also Send Feedback
Converts this HTTP request object to a string representation.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ToString(
    bool PrintHeaders
)
Visual Basic
Public Function ToString ( _
    PrintHeaders As Boolean _
) As String
Visual C++
public:
String^ ToString(
    bool PrintHeaders
)

Parameters

PrintHeaders
Type: System..::..Boolean
Set to true to have the HTTP request header information to be included.

Return Value

A string representation of this header request.

See Also

HttpRequest Class
ToString Overload
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequest Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest Properties
HttpRequest Class See Also Send Feedback

The HttpRequest type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets / Sets the content of this request
Public property | Guid | Gets the unique identifier of this request
Public property | HasCloseConnectionOption | Gets whether this request specifies that the connection be closed after a response to it is received
Public property | Headers | Gets / Sets the headers for this request
Public property | HttpMethod | Gets / Sets the HTTP method of this request
Public property | HttpVersion | Gets / Sets the HTTP version string of this request
Public property | ID | Gets the ID number of this request
Public property | RequestUri | Gets / Sets the URI of this request.
Public property | Response | Gets / Sets the response to this request. If a response is set, the request will not be sent to the server.
Public property | Timestamp | The time at which this request was sent to the server

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


Content Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..Content Property
HttpRequest Class See Also Send Feedback
Gets / Sets the content of this request

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public byte[] Content { get; set; }
Visual Basic
Public Property Content As Byte()
    Get
    Set
Visual C++
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


Guid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..Guid Property
HttpRequest Class See Also Send Feedback
Gets the unique identifier of this request

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid Guid { get; }
Visual Basic
Public ReadOnly Property Guid As Guid
    Get
Visual C++
public:
property Guid Guid {
    Guid get ();
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


HasCloseConnectionOption Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..HasCloseConnectionOption Property
HttpRequest Class See Also Send Feedback
Gets whether this request specifies that the connection be closed after a response to it is received

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasCloseConnectionOption { get; }
Visual Basic
Public ReadOnly Property HasCloseConnectionOption As Boolean
    Get
Visual C++
public:
property bool HasCloseConnectionOption {
    bool get ();
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


Headers Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..Headers Property
HttpRequest Class See Also Send Feedback
Gets / Sets the headers for this request

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NameValueCollection Headers { get; set; }
Visual Basic
Public Property Headers As NameValueCollection
    Get
    Set
Visual C++
public:
property NameValueCollection^ Headers {
    NameValueCollection^ get ();
    void set (NameValueCollection^ value);
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpMethod Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..HttpMethod Property
HttpRequest Class See Also Send Feedback
Gets / Sets the HTTP method of this request

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string HttpMethod { get; set; }
Visual Basic
Public Property HttpMethod As String
    Get
    Set
Visual C++
public:
property String^ HttpMethod {
    String^ get ();
    void set (String^ value);
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..HttpVersion Property
HttpRequest Class See Also Send Feedback
Gets / Sets the HTTP version string of this request

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string HttpVersion { get; set; }
Visual Basic
Public Property HttpVersion As String
    Get
    Set
Visual C++
public:
property String^ HttpVersion {
    String^ get ();
    void set (String^ value);
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


ID Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..ID Property
HttpRequest Class See Also Send Feedback
Gets the ID number of this request

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ID { get; }
Visual Basic
Public ReadOnly Property ID As Integer
    Get
Visual C++
public:
property int ID {
    int get ();
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


RequestUri Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..RequestUri Property
HttpRequest Class See Also Send Feedback
Gets / Sets the URI of this request.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RequestUri { get; set; }
Visual Basic
Public Property RequestUri As String
    Get
    Set
Visual C++
public:
property String^ RequestUri {
    String^ get ();
    void set (String^ value);
}

Remarks

The URI should not contain the server to which the request is directed. It should only contain the path on the server of the requested resource. The server's IP address or DNS name should be stored in the 'Host' header. For example, to request the page 'http://www.example.com/directory/file.html', the URI string should be "/directory/file.html" and the Host header should be "www.example.com".

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


Response Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..Response Property
HttpRequest Class See Also Send Feedback
Gets / Sets the response to this request. If a response is set, the request will not be sent to the server.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpResponse Response { get; set; }
Visual Basic
Public Property Response As HttpResponse
    Get
    Set
Visual C++
public:
property HttpResponse^ Response {
    HttpResponse^ get ();
    void set (HttpResponse^ value);
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


Timestamp Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequest..::..Timestamp Property
HttpRequest Class See Also Send Feedback
The time at which this request was sent to the server

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime Timestamp { get; set; }
Visual Basic
Public Property Timestamp As DateTime
    Get
    Set
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

HttpRequest Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequestEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestEventArgs Members
HttpRequestEventArgs Class Methods Properties See Also Send Feedback

The HttpRequestEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Request | Gets the HttpRequest object that caused the event to fire

See Also

HttpRequestEventArgs Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequestEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestEventArgs Methods
HttpRequestEventArgs Class See Also Send Feedback

The HttpRequestEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpRequestEventArgs Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequestEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestEventArgs Properties
HttpRequestEventArgs Class See Also Send Feedback

The HttpRequestEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Request | Gets the HttpRequest object that caused the event to fire

See Also

HttpRequestEventArgs Class
ArtOfTest.WebAii.Messaging.Http Namespace


Request Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestEventArgs..::..Request Property
HttpRequestEventArgs Class See Also Send Feedback
Gets the HttpRequest object that caused the event to fire

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpRequest Request { get; }
Visual Basic
Public ReadOnly Property Request As HttpRequest
    Get
Visual C++
public:
property HttpRequest^ Request {
    HttpRequest^ get ();
}

See Also

HttpRequestEventArgs Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequestResponsePair Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestResponsePair Members
HttpRequestResponsePair Class Constructors Methods Properties See Also Send Feedback

The HttpRequestResponsePair type exposes the following members.

Constructors

 | Name | Description
Public method | HttpRequestResponsePair | Initializes a new instance of the HttpRequestResponsePair class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImportFiddlerLog |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HttpRequest |
Public property | HttpResponse |

See Also

HttpRequestResponsePair Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequestResponsePair Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestResponsePair Constructor
HttpRequestResponsePair Class See Also Send Feedback
Initializes a new instance of the HttpRequestResponsePair class

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpRequestResponsePair(
    HttpRequest httpRequest,
    HttpResponse httpResponse
)
Visual Basic
Public Sub New ( _
    httpRequest As HttpRequest, _
    httpResponse As HttpResponse _
)
Visual C++
public:
HttpRequestResponsePair(
    HttpRequest^ httpRequest,
    HttpResponse^ httpResponse
)

Parameters

httpRequest
Type: ArtOfTest.WebAii.Messaging.Http..::..HttpRequest

[Missing <param name="httpRequest"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequestResponsePair.#ctor(ArtOfTest.WebAii.Messaging.Http.HttpRequest,ArtOfTest.WebAii.Messaging.Http.HttpResponse)"]

httpResponse
Type: ArtOfTest.WebAii.Messaging.Http..::..HttpResponse

[Missing <param name="httpResponse"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequestResponsePair.#ctor(ArtOfTest.WebAii.Messaging.Http.HttpRequest,ArtOfTest.WebAii.Messaging.Http.HttpResponse)"]

See Also

HttpRequestResponsePair Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequestResponsePair Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestResponsePair Methods
HttpRequestResponsePair Class See Also Send Feedback

The HttpRequestResponsePair type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ImportFiddlerLog |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpRequestResponsePair Class
ArtOfTest.WebAii.Messaging.Http Namespace


ImportFiddlerLog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestResponsePair..::..ImportFiddlerLog Method
HttpRequestResponsePair Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequestResponsePair.ImportFiddlerLog(System.String)"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static IEnumerable<HttpRequestResponsePair> ImportFiddlerLog(
    string strLogPath
)
Visual Basic
Public Shared Function ImportFiddlerLog ( _
    strLogPath As String _
) As IEnumerable(Of HttpRequestResponsePair)
Visual C++
public:
static IEnumerable<HttpRequestResponsePair^>^ ImportFiddlerLog(
    String^ strLogPath
)

Parameters

strLogPath
Type: System..::..String

[Missing <param name="strLogPath"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequestResponsePair.ImportFiddlerLog(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpRequestResponsePair.ImportFiddlerLog(System.String)"]

See Also

HttpRequestResponsePair Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequestResponsePair Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestResponsePair Properties
HttpRequestResponsePair Class See Also Send Feedback

The HttpRequestResponsePair type exposes the following members.

Properties

 | Name | Description
Public property | HttpRequest |
Public property | HttpResponse |

See Also

HttpRequestResponsePair Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpRequest Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestResponsePair..::..HttpRequest Property
HttpRequestResponsePair Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Messaging.Http.HttpRequestResponsePair.HttpRequest"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpRequest HttpRequest { get; }
Visual Basic
Public ReadOnly Property HttpRequest As HttpRequest
    Get
Visual C++
public:
property HttpRequest^ HttpRequest {
    HttpRequest^ get ();
}

See Also

HttpRequestResponsePair Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponse Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpRequestResponsePair..::..HttpResponse Property
HttpRequestResponsePair Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Messaging.Http.HttpRequestResponsePair.HttpResponse"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpResponse HttpResponse { get; }
Visual Basic
Public ReadOnly Property HttpResponse As HttpResponse
    Get
Visual C++
public:
property HttpResponse^ HttpResponse {
    HttpResponse^ get ();
}

See Also

HttpRequestResponsePair Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponse Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse Members
HttpResponse Class Constructors Methods Properties See Also Send Feedback

The HttpResponse type exposes the following members.

Constructors

 | Name | Description
Public method | HttpResponse()()()() | Internal use only. Required for serialization.
Public method | HttpResponse(HttpResponse) | Copy constructor
Public method | HttpResponse(Int32, HttpRequest) | Create a response object containing an error message

Methods

 | Name | Description
Public method | AddHeader | Adds a new header to this response's headers. If there is already a header by the same name, the value specified in thie call is added to the list of values for the header.
Public method | AppendHeader | Adds a new header to this response's headers. If there is already a header by the same name, the value specified in thie call is added to the list of values for the header.
Public method | CleanUpConnectionOptions | Strips out any headers matching the tokens listed in the Connection header, and removes all tokens from the Connection header.
Public method | Clear | Clears all headers and content output from the current response
Public method | ClearContent | Clears the content buffer for the current response
Public method | ClearHeaders | Clears all headers from the current response
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnchunkedContent |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Gets the string representation of this object. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts this HttpResponse to a string representation.

Properties

 | Name | Description
Public property | Content | Gets or sets the message body. To remove the body from a message, set Content to null.
Public property | Guid | Gets the unique identifier for this request object
Public property | Headers | Gets / Sets the response headers
Public property | HttpVersion | Gets the HTTP version string the server used for this response
Public property | IsImage | Gets whether this response contains an image (according to its content-type header)
Public property | IsXml | Gets whether this response contains an XML document (according to its content-type header)
Public property | MimeType | Gets an array containing all the values specified as MIME types for the content of this response
Public property | Request | Gets the request object that caused this response
Public property | StatusCode | Gets / Sets the HTTP status code for this response
Public property | StatusDescription | Gets / Sets the status description string for this response
Public property | Timestamp | The time at which this response was received from the server

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponse Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse Constructor
HttpResponse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HttpResponse()()()() | Internal use only. Required for serialization.
Public method | HttpResponse(HttpResponse) | Copy constructor
Public method | HttpResponse(Int32, HttpRequest) | Create a response object containing an error message

See Also

HttpResponse Class
HttpResponse Members
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponse Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse Constructor
HttpResponse Class See Also Send Feedback
Internal use only. Required for serialization.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpResponse()
Visual Basic
Public Sub New
Visual C++
public:
HttpResponse()

See Also

HttpResponse Class
HttpResponse Overload
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponse Constructor (HttpResponse)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse Constructor (HttpResponse)
HttpResponse Class See Also Send Feedback
Copy constructor

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpResponse(
    HttpResponse toCopy
)
Visual Basic
Public Sub New ( _
    toCopy As HttpResponse _
)
Visual C++
public:
HttpResponse(
    HttpResponse^ toCopy
)

Parameters

toCopy
Type: ArtOfTest.WebAii.Messaging.Http..::..HttpResponse
The HttpResponse object to create a new copy of

See Also

HttpResponse Class
HttpResponse Overload
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponse Constructor (Int32, HttpRequest)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse Constructor (Int32, HttpRequest)
HttpResponse Class See Also Send Feedback
Create a response object containing an error message

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpResponse(
    int errorCode,
    HttpRequest request
)
Visual Basic
Public Sub New ( _
    errorCode As Integer, _
    request As HttpRequest _
)
Visual C++
public:
HttpResponse(
    int errorCode,
    HttpRequest^ request
)

Parameters

errorCode
Type: System..::..Int32
The HTTP status code of the error
request
Type: ArtOfTest.WebAii.Messaging.Http..::..HttpRequest
The request that caused the error

See Also

HttpResponse Class
HttpResponse Overload
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponse Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse Methods
HttpResponse Class See Also Send Feedback

The HttpResponse type exposes the following members.

Methods

 | Name | Description
Public method | AddHeader | Adds a new header to this response's headers. If there is already a header by the same name, the value specified in thie call is added to the list of values for the header.
Public method | AppendHeader | Adds a new header to this response's headers. If there is already a header by the same name, the value specified in thie call is added to the list of values for the header.
Public method | CleanUpConnectionOptions | Strips out any headers matching the tokens listed in the Connection header, and removes all tokens from the Connection header.
Public method | Clear | Clears all headers and content output from the current response
Public method | ClearContent | Clears the content buffer for the current response
Public method | ClearHeaders | Clears all headers from the current response
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnchunkedContent |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Gets the string representation of this object. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts this HttpResponse to a string representation.

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


AddHeader Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..AddHeader Method
HttpResponse Class See Also Send Feedback
Adds a new header to this response's headers. If there is already a header by the same name, the value specified in thie call is added to the list of values for the header.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddHeader(
    string name,
    string value
)
Visual Basic
Public Sub AddHeader ( _
    name As String, _
    value As String _
)
Visual C++
public:
void AddHeader(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The header's name
value
Type: System..::..String
The value for the header

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


AppendHeader Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..AppendHeader Method
HttpResponse Class See Also Send Feedback
Adds a new header to this response's headers. If there is already a header by the same name, the value specified in thie call is added to the list of values for the header.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendHeader(
    string name,
    string value
)
Visual Basic
Public Sub AppendHeader ( _
    name As String, _
    value As String _
)
Visual C++
public:
void AppendHeader(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The header's name
value
Type: System..::..String
The value for the header

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


CleanUpConnectionOptions Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..CleanUpConnectionOptions Method
HttpResponse Class See Also Send Feedback
Strips out any headers matching the tokens listed in the Connection header, and removes all tokens from the Connection header.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CleanUpConnectionOptions()
Visual Basic
Public Sub CleanUpConnectionOptions
Visual C++
public:
void CleanUpConnectionOptions()

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..Clear Method
HttpResponse Class See Also Send Feedback
Clears all headers and content output from the current response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


ClearContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..ClearContent Method
HttpResponse Class See Also Send Feedback
Clears the content buffer for the current response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ClearContent()
Visual Basic
Public Sub ClearContent
Visual C++
public:
void ClearContent()

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


ClearHeaders Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..ClearHeaders Method
HttpResponse Class See Also Send Feedback
Clears all headers from the current response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ClearHeaders()
Visual Basic
Public Sub ClearHeaders
Visual C++
public:
void ClearHeaders()

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


GetUnchunkedContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..GetUnchunkedContent Method
HttpResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpResponse.GetUnchunkedContent"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public byte[] GetUnchunkedContent()
Visual Basic
Public Function GetUnchunkedContent As Byte()
Visual C++
public:
array<unsigned char>^ GetUnchunkedContent()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpResponse.GetUnchunkedContent"]

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


ToString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..ToString Method
HttpResponse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Gets the string representation of this object. (Overrides Object..::..ToString()()()().)
Public method | ToString(Boolean) | Converts this HttpResponse to a string representation.

See Also

HttpResponse Class
HttpResponse Members
ArtOfTest.WebAii.Messaging.Http Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..ToString Method
HttpResponse Class See Also Send Feedback
Gets the string representation of this object.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

String representation of this object.

See Also

HttpResponse Class
ToString Overload
ArtOfTest.WebAii.Messaging.Http Namespace


ToString Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..ToString Method (Boolean)
HttpResponse Class See Also Send Feedback
Converts this HttpResponse to a string representation.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ToString(
    bool printHeaders
)
Visual Basic
Public Function ToString ( _
    printHeaders As Boolean _
) As String
Visual C++
public:
String^ ToString(
    bool printHeaders
)

Parameters

printHeaders
Type: System..::..Boolean
Whether or not to include the HTTP headers in the converted string.

Return Value

A string representation of this object.

See Also

HttpResponse Class
ToString Overload
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponse Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse Properties
HttpResponse Class See Also Send Feedback

The HttpResponse type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets or sets the message body. To remove the body from a message, set Content to null.
Public property | Guid | Gets the unique identifier for this request object
Public property | Headers | Gets / Sets the response headers
Public property | HttpVersion | Gets the HTTP version string the server used for this response
Public property | IsImage | Gets whether this response contains an image (according to its content-type header)
Public property | IsXml | Gets whether this response contains an XML document (according to its content-type header)
Public property | MimeType | Gets an array containing all the values specified as MIME types for the content of this response
Public property | Request | Gets the request object that caused this response
Public property | StatusCode | Gets / Sets the HTTP status code for this response
Public property | StatusDescription | Gets / Sets the status description string for this response
Public property | Timestamp | The time at which this response was received from the server

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


Content Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..Content Property
HttpResponse Class See Also Send Feedback
Gets or sets the message body. To remove the body from a message, set Content to null.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public byte[] Content { get; set; }
Visual Basic
Public Property Content As Byte()
    Get
    Set
Visual C++
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Remarks

Sets the Content-Length header field to the length of the new message body.

Removes any existing Transfer-Encoding header. If you want to add a message body that is transfer-encoded, you must set the transfer coding for the body after assigning to the message's Content property.

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


Guid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..Guid Property
HttpResponse Class See Also Send Feedback
Gets the unique identifier for this request object

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid Guid { get; }
Visual Basic
Public ReadOnly Property Guid As Guid
    Get
Visual C++
public:
property Guid Guid {
    Guid get ();
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


Headers Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..Headers Property
HttpResponse Class See Also Send Feedback
Gets / Sets the response headers

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NameValueCollection Headers { get; set; }
Visual Basic
Public Property Headers As NameValueCollection
    Get
    Set
Visual C++
public:
property NameValueCollection^ Headers {
    NameValueCollection^ get ();
    void set (NameValueCollection^ value);
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpVersion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..HttpVersion Property
HttpResponse Class See Also Send Feedback
Gets the HTTP version string the server used for this response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string HttpVersion { get; set; }
Visual Basic
Public Property HttpVersion As String
    Get
    Set
Visual C++
public:
property String^ HttpVersion {
    String^ get ();
    void set (String^ value);
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


IsImage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..IsImage Property
HttpResponse Class See Also Send Feedback
Gets whether this response contains an image (according to its content-type header)

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsImage { get; }
Visual Basic
Public ReadOnly Property IsImage As Boolean
    Get
Visual C++
public:
property bool IsImage {
    bool get ();
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


IsXml Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..IsXml Property
HttpResponse Class See Also Send Feedback
Gets whether this response contains an XML document (according to its content-type header)

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsXml { get; }
Visual Basic
Public ReadOnly Property IsXml As Boolean
    Get
Visual C++
public:
property bool IsXml {
    bool get ();
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


MimeType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..MimeType Property
HttpResponse Class See Also Send Feedback
Gets an array containing all the values specified as MIME types for the content of this response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string[] MimeType { get; }
Visual Basic
Public ReadOnly Property MimeType As String()
    Get
Visual C++
public:
property array<String^>^ MimeType {
    array<String^>^ get ();
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


Request Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..Request Property
HttpResponse Class See Also Send Feedback
Gets the request object that caused this response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpRequest Request { get; internal set; }
Visual Basic
Public Property Request As HttpRequest
    Get
    Friend Set
Visual C++
public:
property HttpRequest^ Request {
    HttpRequest^ get ();
    internal: void set (HttpRequest^ value);
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


StatusCode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..StatusCode Property
HttpResponse Class See Also Send Feedback
Gets / Sets the HTTP status code for this response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int StatusCode { get; set; }
Visual Basic
Public Property StatusCode As Integer
    Get
    Set
Visual C++
public:
property int StatusCode {
    int get ();
    void set (int value);
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


StatusDescription Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..StatusDescription Property
HttpResponse Class See Also Send Feedback
Gets / Sets the status description string for this response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string StatusDescription { get; set; }
Visual Basic
Public Property StatusDescription As String
    Get
    Set
Visual C++
public:
property String^ StatusDescription {
    String^ get ();
    void set (String^ value);
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


Timestamp Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponse..::..Timestamp Property
HttpResponse Class See Also Send Feedback
The time at which this response was received from the server

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime Timestamp { get; internal set; }
Visual Basic
Public Property Timestamp As DateTime
    Get
    Friend Set
Visual C++
public:
property DateTime Timestamp {
    DateTime get ();
    internal: void set (DateTime value);
}

See Also

HttpResponse Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponseEventArgs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponseEventArgs Members
HttpResponseEventArgs Class Methods Properties See Also Send Feedback

The HttpResponseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Response | Gets the HttpResponse object that caused the event to fire

See Also

HttpResponseEventArgs Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponseEventArgs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponseEventArgs Methods
HttpResponseEventArgs Class See Also Send Feedback

The HttpResponseEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpResponseEventArgs Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpResponseEventArgs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponseEventArgs Properties
HttpResponseEventArgs Class See Also Send Feedback

The HttpResponseEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Response | Gets the HttpResponse object that caused the event to fire

See Also

HttpResponseEventArgs Class
ArtOfTest.WebAii.Messaging.Http Namespace


Response Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpResponseEventArgs..::..Response Property
HttpResponseEventArgs Class See Also Send Feedback
Gets the HttpResponse object that caused the event to fire

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpResponse Response { get; }
Visual Basic
Public ReadOnly Property Response As HttpResponse
    Get
Visual C++
public:
property HttpResponse^ Response {
    HttpResponse^ get ();
}

See Also

HttpResponseEventArgs Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpTrafficEvent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent Members
HttpTrafficEvent Class Constructors Methods Fields See Also Send Feedback

The HttpTrafficEvent type exposes the following members.

Constructors

 | Name | Description
Public method | HttpTrafficEvent | Initializes a new instance of the HttpTrafficEvent class

Methods

 | Name | Description
 | CalculateErrorCount |
 | CalculateTotalHttpTime | For a given step, calculate the amount of time where a webserver was actively working on a response
 | CalculateTotalReceivedDataSize |
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | _bytesReceivedBody |
Public field | _bytesReceivedHeader |
Public field | _bytesSentBody |
Public field | _bytesSentHeader |
Public field | _clientBeginRequest |
Public field | _clientBeginResponse |
Public field | _clientConnected |
Public field | _clientDoneRequest |
Public field | _clientDoneResponse |
Public field | _connectingTime |
Public field | _dnsTime |
Public field | _lHttpResponseCode |
Public field | _serverBeginResponse |
Public field | _serverConnected |
Public field | _serverDoneResponse |
Public field | _serverGotRequest |
Public field | _strHttpResponseCodeString |
Public field | _strMethod |
Public field | _strRequest |
Public field | _strResponseContentType |
Public field | _strSuggestedFileName |

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpTrafficEvent Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent Constructor
HttpTrafficEvent Class See Also Send Feedback
Initializes a new instance of the HttpTrafficEvent class

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpTrafficEvent()
Visual Basic
Public Sub New
Visual C++
public:
HttpTrafficEvent()

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpTrafficEvent Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent Fields
HttpTrafficEvent Class See Also Send Feedback

The HttpTrafficEvent type exposes the following members.

Fields

 | Name | Description
Public field | _bytesReceivedBody |
Public field | _bytesReceivedHeader |
Public field | _bytesSentBody |
Public field | _bytesSentHeader |
Public field | _clientBeginRequest |
Public field | _clientBeginResponse |
Public field | _clientConnected |
Public field | _clientDoneRequest |
Public field | _clientDoneResponse |
Public field | _connectingTime |
Public field | _dnsTime |
Public field | _lHttpResponseCode |
Public field | _serverBeginResponse |
Public field | _serverConnected |
Public field | _serverDoneResponse |
Public field | _serverGotRequest |
Public field | _strHttpResponseCodeString |
Public field | _strMethod |
Public field | _strRequest |
Public field | _strResponseContentType |
Public field | _strSuggestedFileName |

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_bytesReceivedBody Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._bytesReceivedBody Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._bytesReceivedBody"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public long _bytesReceivedBody
Visual Basic
Public _bytesReceivedBody As Long
Visual C++
public:
long long _bytesReceivedBody

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_bytesReceivedHeader Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._bytesReceivedHeader Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._bytesReceivedHeader"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public long _bytesReceivedHeader
Visual Basic
Public _bytesReceivedHeader As Long
Visual C++
public:
long long _bytesReceivedHeader

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_bytesSentBody Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._bytesSentBody Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._bytesSentBody"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public long _bytesSentBody
Visual Basic
Public _bytesSentBody As Long
Visual C++
public:
long long _bytesSentBody

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_bytesSentHeader Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._bytesSentHeader Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._bytesSentHeader"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public long _bytesSentHeader
Visual Basic
Public _bytesSentHeader As Long
Visual C++
public:
long long _bytesSentHeader

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_clientBeginRequest Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._clientBeginRequest Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._clientBeginRequest"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _clientBeginRequest
Visual Basic
Public _clientBeginRequest As DateTime
Visual C++
public:
DateTime _clientBeginRequest

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_clientBeginResponse Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._clientBeginResponse Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._clientBeginResponse"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _clientBeginResponse
Visual Basic
Public _clientBeginResponse As DateTime
Visual C++
public:
DateTime _clientBeginResponse

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_clientConnected Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._clientConnected Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._clientConnected"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _clientConnected
Visual Basic
Public _clientConnected As DateTime
Visual C++
public:
DateTime _clientConnected

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_clientDoneRequest Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._clientDoneRequest Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._clientDoneRequest"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _clientDoneRequest
Visual Basic
Public _clientDoneRequest As DateTime
Visual C++
public:
DateTime _clientDoneRequest

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_clientDoneResponse Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._clientDoneResponse Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._clientDoneResponse"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _clientDoneResponse
Visual Basic
Public _clientDoneResponse As DateTime
Visual C++
public:
DateTime _clientDoneResponse

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_connectingTime Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._connectingTime Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._connectingTime"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TimeSpan _connectingTime
Visual Basic
Public _connectingTime As TimeSpan
Visual C++
public:
TimeSpan _connectingTime

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_dnsTime Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._dnsTime Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._dnsTime"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TimeSpan _dnsTime
Visual Basic
Public _dnsTime As TimeSpan
Visual C++
public:
TimeSpan _dnsTime

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_lHttpResponseCode Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._lHttpResponseCode Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._lHttpResponseCode"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public long _lHttpResponseCode
Visual Basic
Public _lHttpResponseCode As Long
Visual C++
public:
long long _lHttpResponseCode

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_serverBeginResponse Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._serverBeginResponse Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._serverBeginResponse"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _serverBeginResponse
Visual Basic
Public _serverBeginResponse As DateTime
Visual C++
public:
DateTime _serverBeginResponse

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_serverConnected Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._serverConnected Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._serverConnected"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _serverConnected
Visual Basic
Public _serverConnected As DateTime
Visual C++
public:
DateTime _serverConnected

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_serverDoneResponse Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._serverDoneResponse Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._serverDoneResponse"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _serverDoneResponse
Visual Basic
Public _serverDoneResponse As DateTime
Visual C++
public:
DateTime _serverDoneResponse

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_serverGotRequest Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._serverGotRequest Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._serverGotRequest"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime _serverGotRequest
Visual Basic
Public _serverGotRequest As DateTime
Visual C++
public:
DateTime _serverGotRequest

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_strHttpResponseCodeString Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._strHttpResponseCodeString Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._strHttpResponseCodeString"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _strHttpResponseCodeString
Visual Basic
Public _strHttpResponseCodeString As String
Visual C++
public:
String^ _strHttpResponseCodeString

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_strMethod Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._strMethod Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._strMethod"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _strMethod
Visual Basic
Public _strMethod As String
Visual C++
public:
String^ _strMethod

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_strRequest Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._strRequest Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._strRequest"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _strRequest
Visual Basic
Public _strRequest As String
Visual C++
public:
String^ _strRequest

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_strResponseContentType Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._strResponseContentType Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._strResponseContentType"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _strResponseContentType
Visual Basic
Public _strResponseContentType As String
Visual C++
public:
String^ _strResponseContentType

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


_strSuggestedFileName Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::.._strSuggestedFileName Field
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent._strSuggestedFileName"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string _strSuggestedFileName
Visual Basic
Public _strSuggestedFileName As String
Visual C++
public:
String^ _strSuggestedFileName

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


HttpTrafficEvent Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent Methods
HttpTrafficEvent Class See Also Send Feedback

The HttpTrafficEvent type exposes the following members.

Methods

 | Name | Description
 | CalculateErrorCount |
 | CalculateTotalHttpTime | For a given step, calculate the amount of time where a webserver was actively working on a response
 | CalculateTotalReceivedDataSize |
Public method | CompareTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


CalculateErrorCount Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::..CalculateErrorCount Method
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateErrorCount(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int CalculateErrorCount(
    IEnumerable<HttpTrafficEvent> trafficData,
    DateTime stepStart,
    DateTime stepEnd
)
Visual Basic
Public Shared Function CalculateErrorCount ( _
    trafficData As IEnumerable(Of HttpTrafficEvent), _
    stepStart As DateTime, _
    stepEnd As DateTime _
) As Integer
Visual C++
public:
static int CalculateErrorCount(
    IEnumerable<HttpTrafficEvent^>^ trafficData,
    DateTime stepStart,
    DateTime stepEnd
)

Parameters

trafficData
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' HttpTrafficEvent >)>)>

[Missing <param name="trafficData"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateErrorCount(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

stepStart
Type: System..::..DateTime

[Missing <param name="stepStart"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateErrorCount(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

stepEnd
Type: System..::..DateTime

[Missing <param name="stepEnd"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateErrorCount(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateErrorCount(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


CalculateTotalHttpTime Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::..CalculateTotalHttpTime Method
HttpTrafficEvent Class See Also Send Feedback
For a given step, calculate the amount of time where a webserver was actively working on a response

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static TimeSpan CalculateTotalHttpTime(
    IEnumerable<HttpTrafficEvent> trafficData,
    DateTime stepStart,
    DateTime stepEnd
)
Visual Basic
Public Shared Function CalculateTotalHttpTime ( _
    trafficData As IEnumerable(Of HttpTrafficEvent), _
    stepStart As DateTime, _
    stepEnd As DateTime _
) As TimeSpan
Visual C++
public:
static TimeSpan CalculateTotalHttpTime(
    IEnumerable<HttpTrafficEvent^>^ trafficData,
    DateTime stepStart,
    DateTime stepEnd
)

Parameters

trafficData
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' HttpTrafficEvent >)>)>

[Missing <param name="trafficData"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalHttpTime(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

stepStart
Type: System..::..DateTime

[Missing <param name="stepStart"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalHttpTime(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

stepEnd
Type: System..::..DateTime

[Missing <param name="stepEnd"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalHttpTime(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalHttpTime(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


CalculateTotalReceivedDataSize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::..CalculateTotalReceivedDataSize Method
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalReceivedDataSize(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ulong CalculateTotalReceivedDataSize(
    IEnumerable<HttpTrafficEvent> trafficData,
    DateTime stepStart,
    DateTime stepEnd
)
Visual Basic
Public Shared Function CalculateTotalReceivedDataSize ( _
    trafficData As IEnumerable(Of HttpTrafficEvent), _
    stepStart As DateTime, _
    stepEnd As DateTime _
) As ULong
Visual C++
public:
static unsigned long long CalculateTotalReceivedDataSize(
    IEnumerable<HttpTrafficEvent^>^ trafficData,
    DateTime stepStart,
    DateTime stepEnd
)

Parameters

trafficData
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' HttpTrafficEvent >)>)>

[Missing <param name="trafficData"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalReceivedDataSize(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

stepStart
Type: System..::..DateTime

[Missing <param name="stepStart"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalReceivedDataSize(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

stepEnd
Type: System..::..DateTime

[Missing <param name="stepEnd"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalReceivedDataSize(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CalculateTotalReceivedDataSize(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent},System.DateTime,System.DateTime)"]

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


CompareTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HttpTrafficEvent..::..CompareTo Method
HttpTrafficEvent Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CompareTo(System.Object)"]

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object

[Missing <param name="obj"/> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CompareTo(System.Object)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Messaging.Http.HttpTrafficEvent.CompareTo(System.Object)"]

Implements

IComparable..::..CompareTo(Object)

See Also

HttpTrafficEvent Class
ArtOfTest.WebAii.Messaging.Http Namespace


ListenerInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListenerInfo Members
ListenerInfo Class Methods Properties See Also Send Feedback

The ListenerInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether this ListenerInfo object describes the same event handler delegate as another (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Calculates and returns the hashcode for this object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MatchesUri | Determines whether this listener's filter matches a given URI
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Guid | Gets the guid of the event handler wrapped by this ListenerInfo object
Public property | UriFilter | Gets / Sets the wildcard string used to filter request URIs before firing this listener's handler delegate

See Also

ListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


ListenerInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListenerInfo Methods
ListenerInfo Class See Also Send Feedback

The ListenerInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether this ListenerInfo object describes the same event handler delegate as another (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Calculates and returns the hashcode for this object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MatchesUri | Determines whether this listener's filter matches a given URI
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


Equals Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListenerInfo..::..Equals Method
ListenerInfo Class See Also Send Feedback
Determines whether this ListenerInfo object describes the same event handler delegate as another

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare this one to

Return Value

True if the objects are equivalent enough for our purposes (tracking them in the lists of listeners subscribed to proxy events)

Remarks

Two listeners are considered equivalent if they have the same guid for their event handler, are listening to the same type of event, and have the same wildcard filter for request URIs.

See Also

ListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


GetHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListenerInfo..::..GetHashCode Method
ListenerInfo Class See Also Send Feedback
Calculates and returns the hashcode for this object.

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The calculated hashcode.

See Also

ListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


MatchesUri Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListenerInfo..::..MatchesUri Method
ListenerInfo Class See Also Send Feedback
Determines whether this listener's filter matches a given URI

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool MatchesUri(
    string uri
)
Visual Basic
Public Function MatchesUri ( _
    uri As String _
) As Boolean
Visual C++
public:
bool MatchesUri(
    String^ uri
)

Parameters

uri
Type: System..::..String
The URI to check this listener's filter against

Return Value

True if the filter matches, false if it doesn't

See Also

ListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


ListenerInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListenerInfo Properties
ListenerInfo Class See Also Send Feedback

The ListenerInfo type exposes the following members.

Properties

 | Name | Description
Public property | Guid | Gets the guid of the event handler wrapped by this ListenerInfo object
Public property | UriFilter | Gets / Sets the wildcard string used to filter request URIs before firing this listener's handler delegate

See Also

ListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


Guid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListenerInfo..::..Guid Property
ListenerInfo Class See Also Send Feedback
Gets the guid of the event handler wrapped by this ListenerInfo object

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Guid Guid { get; protected set; }
Visual Basic
Public Property Guid As Guid
    Get
    Protected Set
Visual C++
public:
property Guid Guid {
    Guid get ();
    protected: void set (Guid value);
}

See Also

ListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


UriFilter Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListenerInfo..::..UriFilter Property
ListenerInfo Class See Also Send Feedback
Gets / Sets the wildcard string used to filter request URIs before firing this listener's handler delegate

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UriFilter { get; set; }
Visual Basic
Public Property UriFilter As String
    Get
    Set
Visual C++
public:
property String^ UriFilter {
    String^ get ();
    void set (String^ value);
}

See Also

ListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


RequestListenerInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RequestListenerInfo Members
RequestListenerInfo Class Constructors Methods Properties See Also Send Feedback

The RequestListenerInfo type exposes the following members.

Constructors

 | Name | Description
Public method | RequestListenerInfo | Creates a new listener info object wrapping the given event handler delegate

Methods

 | Name | Description
Public method | Equals | Determines whether this ListenerInfo object describes the same event handler delegate as another (Inherited from ListenerInfo.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Calculates and returns the hashcode for this object. (Inherited from ListenerInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MatchesUri | Determines whether this listener's filter matches a given URI (Inherited from ListenerInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Guid | Gets the guid of the event handler wrapped by this ListenerInfo object (Inherited from ListenerInfo.)
Public property | Handler | Gets the event handler delegate wrapped by this listener object
Public property | UriFilter | Gets / Sets the wildcard string used to filter request URIs before firing this listener's handler delegate (Inherited from ListenerInfo.)

See Also

RequestListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


RequestListenerInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RequestListenerInfo Constructor
RequestListenerInfo Class See Also Send Feedback
Creates a new listener info object wrapping the given event handler delegate

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RequestListenerInfo(
    HttpRequestHandler handler
)
Visual Basic
Public Sub New ( _
    handler As HttpRequestHandler _
)
Visual C++
public:
RequestListenerInfo(
    HttpRequestHandler^ handler
)

Parameters

handler
Type: ArtOfTest.WebAii.Messaging.Http..::..HttpRequestHandler
The event handler delegate

See Also

RequestListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


RequestListenerInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RequestListenerInfo Methods
RequestListenerInfo Class See Also Send Feedback

The RequestListenerInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether this ListenerInfo object describes the same event handler delegate as another (Inherited from ListenerInfo.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Calculates and returns the hashcode for this object. (Inherited from ListenerInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MatchesUri | Determines whether this listener's filter matches a given URI (Inherited from ListenerInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


RequestListenerInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RequestListenerInfo Properties
RequestListenerInfo Class See Also Send Feedback

The RequestListenerInfo type exposes the following members.

Properties

 | Name | Description
Public property | Guid | Gets the guid of the event handler wrapped by this ListenerInfo object (Inherited from ListenerInfo.)
Public property | Handler | Gets the event handler delegate wrapped by this listener object
Public property | UriFilter | Gets / Sets the wildcard string used to filter request URIs before firing this listener's handler delegate (Inherited from ListenerInfo.)

See Also

RequestListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


Handler Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RequestListenerInfo..::..Handler Property
RequestListenerInfo Class See Also Send Feedback
Gets the event handler delegate wrapped by this listener object

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpRequestHandler Handler { get; }
Visual Basic
Public ReadOnly Property Handler As HttpRequestHandler
    Get
Visual C++
public:
property HttpRequestHandler^ Handler {
    HttpRequestHandler^ get ();
}

See Also

RequestListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


ResponseListenerInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResponseListenerInfo Members
ResponseListenerInfo Class Constructors Methods Properties See Also Send Feedback

The ResponseListenerInfo type exposes the following members.

Constructors

 | Name | Description
Public method | ResponseListenerInfo | Creates a new listener info object wrapping the given event handler delegate

Methods

 | Name | Description
Public method | Equals | Determines whether this ListenerInfo object describes the same event handler delegate as another (Inherited from ListenerInfo.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Calculates and returns the hashcode for this object. (Inherited from ListenerInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MatchesUri | Determines whether this listener's filter matches a given URI (Inherited from ListenerInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Guid | Gets the guid of the event handler wrapped by this ListenerInfo object (Inherited from ListenerInfo.)
Public property | Handler | Gets the event handler delegate wrapped by this listener info object
Public property | UriFilter | Gets / Sets the wildcard string used to filter request URIs before firing this listener's handler delegate (Inherited from ListenerInfo.)

See Also

ResponseListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


ResponseListenerInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResponseListenerInfo Constructor
ResponseListenerInfo Class See Also Send Feedback
Creates a new listener info object wrapping the given event handler delegate

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ResponseListenerInfo(
    HttpResponseHandler handler
)
Visual Basic
Public Sub New ( _
    handler As HttpResponseHandler _
)
Visual C++
public:
ResponseListenerInfo(
    HttpResponseHandler^ handler
)

Parameters

handler
Type: ArtOfTest.WebAii.Messaging.Http..::..HttpResponseHandler
The event handler delegate

See Also

ResponseListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


ResponseListenerInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResponseListenerInfo Methods
ResponseListenerInfo Class See Also Send Feedback

The ResponseListenerInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether this ListenerInfo object describes the same event handler delegate as another (Inherited from ListenerInfo.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Calculates and returns the hashcode for this object. (Inherited from ListenerInfo.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MatchesUri | Determines whether this listener's filter matches a given URI (Inherited from ListenerInfo.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ResponseListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


ResponseListenerInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResponseListenerInfo Properties
ResponseListenerInfo Class See Also Send Feedback

The ResponseListenerInfo type exposes the following members.

Properties

 | Name | Description
Public property | Guid | Gets the guid of the event handler wrapped by this ListenerInfo object (Inherited from ListenerInfo.)
Public property | Handler | Gets the event handler delegate wrapped by this listener info object
Public property | UriFilter | Gets / Sets the wildcard string used to filter request URIs before firing this listener's handler delegate (Inherited from ListenerInfo.)

See Also

ResponseListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


Handler Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ResponseListenerInfo..::..Handler Property
ResponseListenerInfo Class See Also Send Feedback
Gets the event handler delegate wrapped by this listener info object

Namespace: ArtOfTest.WebAii.Messaging.Http
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HttpResponseHandler Handler { get; }
Visual Basic
Public ReadOnly Property Handler As HttpResponseHandler
    Get
Visual C++
public:
property HttpResponseHandler^ Handler {
    HttpResponseHandler^ get ();
}

See Also

ResponseListenerInfo Class
ArtOfTest.WebAii.Messaging.Http Namespace


ArtOfTest.WebAii.Network Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Network Namespace
Send Feedback

[Missing <summary> documentation for "N:ArtOfTest.WebAii.Network"]

Classes

Class Description
Public class NetworkBrowser
Provides a mechanism for supplying a list of all PC names in the local network. This collection of PC names is used in the form
This class makes use of a DllImport instruction. The purpose of which is as follows: When a DllImport declaration is made in managed code (C#) it is a call to a legacy unmanaged code module, normally a C++ Dynamic Link Library. These C++ Dll's are usually part of the operating system API, or some other vendors API, and must be used to carry out operations that are not native within the managed code C# framework. This is fairly normal within the windows world. The only thing that needs careful consideration is the construction of the correct type of STRUCTS, object pointers, and attribute markers, which all contribute to making the link between managed (C#) and unmanaged code (C++) more seamless
This class makes use of the following Dll calls
  • Netapi32.dll : NetServerEnum, The NetServerEnum function lists all servers of the specified type that are visible in a domain. For example, an application can call NetServerEnum to list all domain controllers only or all SQL servers only. You can combine bit masks to list several types. For example, a value of 0x00000003 combines the bit masks for SV_TYPE_WORKSTATION (0x00000001) and SV_TYPE_SERVER (0x00000002).
  • Netapi32.dll : NetApiBufferFree, The NetApiBufferFree function frees the memory that the NetApiBufferAllocate function allocates. Call NetApiBufferFree to free the memory that other network management functions return.

Structures

 | Structure | Description
Public structure | NetworkBrowser..::.._SERVER_INFO_100 |


NetworkBrowser Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NetworkBrowser Members
NetworkBrowser Class Constructors Methods See Also Send Feedback

The NetworkBrowser type exposes the following members.

Constructors

 | Name | Description
Public method | NetworkBrowser | Constructor, simply creates a new NetworkBrowser object

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNetworkComputers | Uses the DllImport : NetServerEnum with all its required parameters (see http://msdn.microsoft.com/library/default.asp?url=/library/en-us/netmgmt/netmgmt/netserverenum.asp for full details or method signature) to retrieve a list of domain SV_TYPE_WORKSTATION and SV_TYPE_SERVER PC's
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetApiBufferFree |
 | NetServerEnum |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetworkBrowser Class
ArtOfTest.WebAii.Network Namespace


NetworkBrowser Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NetworkBrowser Constructor
NetworkBrowser Class See Also Send Feedback
Constructor, simply creates a new NetworkBrowser object

Namespace: ArtOfTest.WebAii.Network
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NetworkBrowser()
Visual Basic
Public Sub New
Visual C++
public:
NetworkBrowser()

See Also

NetworkBrowser Class
ArtOfTest.WebAii.Network Namespace


NetworkBrowser Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NetworkBrowser Methods
NetworkBrowser Class See Also Send Feedback

The NetworkBrowser type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getNetworkComputers | Uses the DllImport : NetServerEnum with all its required parameters (see http://msdn.microsoft.com/library/default.asp?url=/library/en-us/netmgmt/netmgmt/netserverenum.asp for full details or method signature) to retrieve a list of domain SV_TYPE_WORKSTATION and SV_TYPE_SERVER PC's
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetApiBufferFree |
 | NetServerEnum |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NetworkBrowser Class
ArtOfTest.WebAii.Network Namespace


getNetworkComputers Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NetworkBrowser..::..getNetworkComputers Method
NetworkBrowser Class See Also Send Feedback
Uses the DllImport : NetServerEnum with all its required parameters (see http://msdn.microsoft.com/library/default.asp?url=/library/en-us/netmgmt/netmgmt/netserverenum.asp for full details or method signature) to retrieve a list of domain SV_TYPE_WORKSTATION and SV_TYPE_SERVER PC's

Namespace: ArtOfTest.WebAii.Network
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ObservableCollection<string> getNetworkComputers()
Visual Basic
Public Function getNetworkComputers As ObservableCollection(Of String)
Visual C++
public:
ObservableCollection<String^>^ getNetworkComputers()

Return Value

Arraylist that represents all the SV_TYPE_WORKSTATION and SV_TYPE_SERVER PC's in the Domain

See Also

NetworkBrowser Class
ArtOfTest.WebAii.Network Namespace


NetApiBufferFree Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NetworkBrowser..::..NetApiBufferFree Method
NetworkBrowser Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetApiBufferFree(System.IntPtr)"]

Namespace: ArtOfTest.WebAii.Network
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int NetApiBufferFree(
    IntPtr pBuf
)
Visual Basic
Public Shared Function NetApiBufferFree ( _
    pBuf As IntPtr _
) As Integer
Visual C++
public:
static int NetApiBufferFree(
    IntPtr pBuf
)

Parameters

pBuf
Type: System..::..IntPtr

[Missing <param name="pBuf"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetApiBufferFree(System.IntPtr)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetApiBufferFree(System.IntPtr)"]

See Also

NetworkBrowser Class
ArtOfTest.WebAii.Network Namespace


NetServerEnum Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NetworkBrowser..::..NetServerEnum Method
NetworkBrowser Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

Namespace: ArtOfTest.WebAii.Network
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int NetServerEnum(
    string ServerNane,
    int dwLevel,
    ref IntPtr pBuf,
    int dwPrefMaxLen,
    out int dwEntriesRead,
    out int dwTotalEntries,
    int dwServerType,
    string domain,
    out int dwResumeHandle
)
Visual Basic
Public Shared Function NetServerEnum ( _
    ServerNane As String, _
    dwLevel As Integer, _
    ByRef pBuf As IntPtr, _
    dwPrefMaxLen As Integer, _
    <OutAttribute> ByRef dwEntriesRead As Integer, _
    <OutAttribute> ByRef dwTotalEntries As Integer, _
    dwServerType As Integer, _
    domain As String, _
    <OutAttribute> ByRef dwResumeHandle As Integer _
) As Integer
Visual C++
public:
static int NetServerEnum(
    String^ ServerNane,
    int dwLevel,
    IntPtr% pBuf,
    int dwPrefMaxLen,
    [OutAttribute] int% dwEntriesRead,
    [OutAttribute] int% dwTotalEntries,
    int dwServerType,
    String^ domain,
    [OutAttribute] int% dwResumeHandle
)

Parameters

ServerNane
Type: System..::..String

[Missing <param name="ServerNane"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

dwLevel
Type: System..::..Int32

[Missing <param name="dwLevel"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

pBuf
Type: System..::..IntPtr %

[Missing <param name="pBuf"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

dwPrefMaxLen
Type: System..::..Int32

[Missing <param name="dwPrefMaxLen"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

dwEntriesRead
Type: System..::..Int32 %

[Missing <param name="dwEntriesRead"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

dwTotalEntries
Type: System..::..Int32 %

[Missing <param name="dwTotalEntries"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

dwServerType
Type: System..::..Int32

[Missing <param name="dwServerType"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

domain
Type: System..::..String

[Missing <param name="domain"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

dwResumeHandle
Type: System..::..Int32 %

[Missing <param name="dwResumeHandle"/> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Network.NetworkBrowser.NetServerEnum(System.String,System.Int32,System.IntPtr@,System.Int32,System.Int32@,System.Int32@,System.Int32,System.String,System.Int32@)"]

See Also

NetworkBrowser Class
ArtOfTest.WebAii.Network Namespace


NetworkBrowser._SERVER_INFO_100 Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NetworkBrowser..::.._SERVER_INFO_100 Members
NetworkBrowser..::.._SERVER_INFO_100 Structure Methods See Also Send Feedback

Provides a mechanism for supplying a list of all PC names in the local network. This collection of PC names is used in the form
This class makes use of a DllImport instruction. The purpose of which is as follows: When a DllImport declaration is made in managed code (C#) it is a call to a legacy unmanaged code module, normally a C++ Dynamic Link Library. These C++ Dll's are usually part of the operating system API, or some other vendors API, and must be used to carry out operations that are not native within the managed code C# framework. This is fairly normal within the windows world. The only thing that needs careful consideration is the construction of the correct type of STRUCTS, object pointers, and attribute markers, which all contribute to making the link between managed (C#) and unmanaged code (C++) more seamless
This class makes use of the following Dll calls
  • Netapi32.dll : NetServerEnum, The NetServerEnum function lists all servers of the specified type that are visible in a domain. For example, an application can call NetServerEnum to list all domain controllers only or all SQL servers only. You can combine bit masks to list several types. For example, a value of 0x00000003 combines the bit masks for SV_TYPE_WORKSTATION (0x00000001) and SV_TYPE_SERVER (0x00000002).
  • Netapi32.dll : NetApiBufferFree, The NetApiBufferFree function frees the memory that the NetApiBufferAllocate function allocates. Call NetApiBufferFree to free the memory that other network management functions return.

The NetworkBrowser..::.._SERVER_INFO_100 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NetworkBrowser..::.._SERVER_INFO_100 Structure
ArtOfTest.WebAii.Network Namespace


NetworkBrowser._SERVER_INFO_100 Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NetworkBrowser..::.._SERVER_INFO_100 Methods
NetworkBrowser..::.._SERVER_INFO_100 Structure See Also Send Feedback

The NetworkBrowser..::.._SERVER_INFO_100 type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

NetworkBrowser..::.._SERVER_INFO_100 Structure
ArtOfTest.WebAii.Network Namespace


ArtOfTest.WebAii.ObjectModel Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.ObjectModel Namespace
Send Feedback
Namespace for the object model of the framwork.

Classes

 | Class | Description
Public class | CookiesManager | Class representing all cookie operations on the current browser machine.
Public class | Element | Represents an element in the Document Object Model (DOM) tree.
Public class | FindExpressionCollection<(Of <(<'T>)>)> | Class to manage a collection of FindParam objects.
Public class | FindParam | Obsolete. A class that defines how a search for an element should be conducted within a document.
Public class | FindParamCollection | Obsolete. Class to manage a collection of FindParam objects.
Public class | FindParamConstraint | Obsolete. Offers addition contraints for a FindParam to allow for a more flexible use in HtmlControls
Public class | FindParamExtension | Class to extend the legacy FindParam class. Adds the ability to convert any legacy FindParam into a HtmlFindExpression.
Public class | HtmlTreeBuilder |
Public class | iAttribute | This class represents a markup attribute (foo="bar"). The iAttribute object contains a starting 'i' to distinguish it from System.Attribute.
Public class | TestRegion | Class representing a TestRegion Object defined in the document as: <testregion id="foo"> ... </testregion> or <!--testregion id="foo"--> ... <!--/testregion>
Public class | TestRegionCollection | A keyed TestRegion collection.

Enumerations

 | Enumeration | Description
Public enumeration | AttributeType | Type of attributes parsed.
Public enumeration | ElementState | Possible element states
Public enumeration | ElementType | The element type of an element within the Dom.
Public enumeration | FindContentType | Types of identification of type=Content
Public enumeration | FindType | Types of identification supported by the framework.
Public enumeration | InputElementType | The types of input for an ElementType=Input.
Public enumeration | Quote | Types of quotes parsed.


CookiesManager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager Members
CookiesManager Class Methods See Also Send Feedback

The CookiesManager type exposes the following members.

Methods

 | Name | Description
Public method | DeleteCookie(Cookie) | Delete a cookie from the machine.
Public method | DeleteCookie(String) | DeleteCookie using the domain name
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCookies(String) | Gets all cookies for a specific url
Public method | GetCookies(Uri) | Gets all cookies for a specific uri
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCookie | Set a new cookie or modify an existing one. This methods will only consider the following cookie properties (Name, Value, Domain, Path and Expires)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CookiesManager Class
ArtOfTest.WebAii.ObjectModel Namespace


CookiesManager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager Methods
CookiesManager Class See Also Send Feedback

The CookiesManager type exposes the following members.

Methods

 | Name | Description
Public method | DeleteCookie(Cookie) | Delete a cookie from the machine.
Public method | DeleteCookie(String) | DeleteCookie using the domain name
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCookies(String) | Gets all cookies for a specific url
Public method | GetCookies(Uri) | Gets all cookies for a specific uri
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCookie | Set a new cookie or modify an existing one. This methods will only consider the following cookie properties (Name, Value, Domain, Path and Expires)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CookiesManager Class
ArtOfTest.WebAii.ObjectModel Namespace


DeleteCookie Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager..::..DeleteCookie Method
CookiesManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DeleteCookie(Cookie) | Delete a cookie from the machine.
Public method | DeleteCookie(String) | DeleteCookie using the domain name

See Also

CookiesManager Class
CookiesManager Members
ArtOfTest.WebAii.ObjectModel Namespace


DeleteCookie Method (Cookie)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager..::..DeleteCookie Method (Cookie)
CookiesManager Class See Also Send Feedback
Delete a cookie from the machine.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool DeleteCookie(
    Cookie cookie
)
Visual Basic
Public Function DeleteCookie ( _
    cookie As Cookie _
) As Boolean
Visual C++
public:
bool DeleteCookie(
    Cookie^ cookie
)

Parameters

cookie
Type: System.Net..::..Cookie
The cookie to delete. The cookie must have a name and domain

Return Value

True/False whether the cookie deletion passed or failed.

See Also

CookiesManager Class
DeleteCookie Overload
ArtOfTest.WebAii.ObjectModel Namespace


DeleteCookie Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager..::..DeleteCookie Method (String)
CookiesManager Class Example See Also Send Feedback
DeleteCookie using the domain name

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DeleteCookie(
    string domain
)
Visual Basic
Public Sub DeleteCookie ( _
    domain As String _
)
Visual C++
public:
void DeleteCookie(
    String^ domain
)

Parameters

domain
Type: System..::..String
The url or domain associate with the cookie to delete. If using urls, make sure the url does not start with http:// or https://

Return Value

True/False whether the cookie got deleted.

Examples

DeleteCookie("mail.google.com") or DeleteCookie("facebook.com")

See Also

CookiesManager Class
DeleteCookie Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetCookies Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager..::..GetCookies Method
CookiesManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCookies(String) | Gets all cookies for a specific url
Public method | GetCookies(Uri) | Gets all cookies for a specific uri

See Also

CookiesManager Class
CookiesManager Members
ArtOfTest.WebAii.ObjectModel Namespace


GetCookies Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager..::..GetCookies Method (String)
CookiesManager Class See Also Send Feedback
Gets all cookies for a specific url

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CookieCollection GetCookies(
    string url
)
Visual Basic
Public Function GetCookies ( _
    url As String _
) As CookieCollection
Visual C++
public:
CookieCollection^ GetCookies(
    String^ url
)

Parameters

url
Type: System..::..String
The url to get the cookies for (i.e. http://www.google.com)

Return Value

The collection of cookies stored on this machine for the associated browser.

See Also

CookiesManager Class
GetCookies Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetCookies Method (Uri)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager..::..GetCookies Method (Uri)
CookiesManager Class See Also Send Feedback
Gets all cookies for a specific uri

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CookieCollection GetCookies(
    Uri uri
)
Visual Basic
Public Function GetCookies ( _
    uri As Uri _
) As CookieCollection
Visual C++
public:
CookieCollection^ GetCookies(
    Uri^ uri
)

Parameters

uri
Type: System..::..Uri
The url to get the cookies for (i.e. http://www.google.com)

Return Value

The collection of cookies stored on this machine for the associated browser.

See Also

CookiesManager Class
GetCookies Overload
ArtOfTest.WebAii.ObjectModel Namespace


SetCookie Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CookiesManager..::..SetCookie Method
CookiesManager Class See Also Send Feedback
Set a new cookie or modify an existing one. This methods will only consider the following cookie properties (Name, Value, Domain, Path and Expires)

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool SetCookie(
    Cookie cookie
)
Visual Basic
Public Function SetCookie ( _
    cookie As Cookie _
) As Boolean
Visual C++
public:
bool SetCookie(
    Cookie^ cookie
)

Parameters

cookie
Type: System.Net..::..Cookie
The cookie to set on the machine for current browser.

Return Value

True/False whether the setting passed or failed.

See Also

CookiesManager Class
ArtOfTest.WebAii.ObjectModel Namespace


Element Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element Members
Element Class Constructors Methods Properties See Also Send Feedback

The Element type exposes the following members.

Constructors

 | Name | Description
Public method | Element(FindParam, Browser) | Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
Public method | Element(FindParam, Find, Browser) | Obsolete. Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
Public method | Element(HtmlFindExpression, Find, Browser) | Initialize an element proxy. The onlyl property off this element that you can use is Wait.Exist() or Wait.ExistsNot()

Methods

 | Name | Description
Public method | AddChild | Add a child element to this element.
Public method | AddChildNode | Add this node as a child node.
Public method | As<(Of <<'(TControl>)>>) | Returns this elements as a strongly-typed control of type TControl.
Public method | Capture |
Public method | ContainsAttribute(String) | True/False whether this element contains a specific attribute name.
Public method | ContainsAttribute(iAttribute, Boolean, StringComparison, Boolean) | Whether a certain attribute is contained in this element
 | CreateLight | Create an Element object with a specific tagname and index.
Public method | Equals | Defines how two Elements should be compared. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Focus | Give this element keyboard focus
Public method | FriendlyName | Constructs a friendly name that represents this element.
Public method | GetAttribute(String) | Find a specific attribute by name and returns it. (case-insensitive)
Public method | GetAttribute(String, Boolean) | Finds a specific attribute name in the Element list of attributes and returns its object
Public method | GetAttributeValueOrEmpty | Gets the value of the attribute or a String.Empty if attribute does not exist.
Public method | GetChildren | Get the children of this node.
Public method | GetHashCode | Get the hash code for this Element. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHostParent | Returns the FRAME or IFRAME element containing this element's document, if one exists.
Public method | GetNextSibling | Get the next sibling of this node. If this node is the last sibling, will return null.
Public method | GetParent | Get the parent of this node.
Public method | GetPreservedInnerText | Same as InnerText but will respect any whitespaces between the tags.
Public method | GetPreviousSibling | Get the previous sibiling of this node. If this node is the first sibling, will return null.
Public method | GetRectangle | Gets the element rectangle. (X,Y) and width, height as it appears on browser and screen. Takes into account any scrolling.
Public method | GetTextContentRecursive | Gets the text content of this element, recursing only into the listed tags
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates the hash code for this element.
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value on this element.
Public method | IsFrame()()()() | Gets whether this element represents an iframe or frame
Public method | IsFrame(Boolean, Boolean) | Gets whether this element represents an iframe or frame
Public method | Match | Match this expression against element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh()()()() | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
Public method | Refresh(Boolean) | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
Public method | SetClosingTag | Set the matching closing tag.
Public method | SetDepth | Sets the hierarchical depth of this element.
Public method | SetParent | Sets the parent of this Element.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property to a value on this element.
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property to a value on this element.
Public method | ToString | String representation of an Element. (Overrides Object..::..ToString()()()().)

Extension Methods

 | Name | Description
Public Extension Method | IsSilverlightPlugin | Detects whether the element is an object tag hosting a Silverlight plugin (Defined by SilverlightAppFinder.)
Public Extension Method | TojQuery | Start a jQuery expression from this element. (Defined by jQueryExtension.)

Properties

Name Description
Public property AbsoluteSiblingTagIndex
Gets the absolute sibling tag index of this element within the parent node. Basically the order of this node among its siblings. Zero-based.
Public property AbsoluteTagIndex
Gets the absolute that index of this element. This index is unique within a document.
Public property Attributes
Gets the list of attributes defined for this element.
Public property ChildNodes
Gets the list of all parsed element of this tag including text literals, comments, malformed tags...etc.
Public property Children
Gets the list of child elements that are well formed markup non-text elements.
Public property Content
Gets the raw content of the tag that represents this element.

Examples

The following tag <foo id="bar" height="px">some text</foo> , has a Content property that is: '<foo id="bar" height="px">' Note: this does not include the innerText or the closing tag.
Public property CssClassAttributeValue
Gets the value of the attribute ('class') if present on this tag.
Public property Data
Gets/Sets any custom data associated with this element.
Public property Depth
The hierarchical depth of this element
Public property ElementType
Gets the element type (div, table ..etc).
Public property FindExpressionUsed
Gets the FindExpression used to find this element when using the Find object. This property is not set when calling the Find.Allxxx methods.
Public property FindObjectUsed
Gets a reference to the Find object used to find this element
Public property FindParamsUsed Obsolete.
Gets the FindParams used to find this element when using the Find object. If chained identification is used this array will contain the list of params, otherwise will contain a single FindParam object. This property is not set when calling the Find.Allxxx methods.
Public property FrameElement
Gets / Sets the root frame element that this element is contained in.
Public property HasIdOrName
Gets whether this element has an id or a name set on it.
Public property Host
Get the IAutomationHost associated with this element.
Public property IdAttributeValue
Gets the value of the attribute ('id') if present on this tag.
Public property InnerMarkup
Gets the InnerMarkup of this element.

Examples

Example: <foo id="1">hello<bar></bar></foo> If foo is this element then InnerMarkup=<bar></bar>
Public property InnerText
Gets this element's inner text content including all of its nested children.

Examples

Example: <foo id="1">one<bar>two</bar></foo> If foo is this element then InnerText=onetwo
Public property InputElementType
Gets the Input type (i.e. checkbox, radio...etc) if the ElementType=Input. Otherwise, will return NotSet.
Public property IsBeginTag
Gets whether it is a begin tag <foo bar='me'> .
Public property IsEndTag
Gets whether this element is an end tag </foo>.
Public property IsProxy
Gets whether this element is a proxy element or a fully initialized element.
Public property IsSelfClosing
Gets whether the element is self-closing (<foo />).
Public property IsTestRegion
Gets whether the element is a test region or not. This function has been added for performance reasons. We don't want to call the ElementType property since it will trigger the full initialization of types.
Public property MatchingClosingTag
Gets the element's closing tag if it is a begin tag and not self-closing.
Public property NameAttributeValue
Gets the value of the attribute ('name') if present on this tag
Public property OuterMarkup
Gets the OuterMarkup of this element.

Examples

Example: <foo id="1"><bar></bar></foo> If foo is this element then outerMarkup=<foo id="1"><bar></bar></foo>
Public property OwnerBrowser
Returns the owner browser of this element.
Public property Parent
Gets the Parent element.
Public property ParsedElement
Returns the raw parsed element.
Public property ParsingType
Gets the parsing type set by the parser. (Markup, LiteralText, Comment..etc)
Public property TagName
Gets the tagName of the the element
Public property TagNameIndex
Gets the tagName occurrence of this element.

Examples

If this element is TagName='foo', then TagNameIndex= 3 indicates that this element represents the third occurence of tagName 'foo' within this document.
Public property TechnologyType
Get the technology type.
Public property TextContent
Gets this element's inner text content without recursing through all its nested children for text.
Public property Wait
Gets the wait object to wait for certain conditions of this element.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Element Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element Constructor
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Element(FindParam, Browser) | Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
Public method | Element(FindParam, Find, Browser) | Obsolete. Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()
Public method | Element(HtmlFindExpression, Find, Browser) | Initialize an element proxy. The onlyl property off this element that you can use is Wait.Exist() or Wait.ExistsNot()

See Also

Element Class
Element Members
ArtOfTest.WebAii.ObjectModel Namespace


Element Constructor (FindParam, Browser)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element Constructor (FindParam, Browser)
Element Class See Also Send Feedback
Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element(
    FindParam findParam,
    Browser ownerBrowser
)
Visual Basic
Public Sub New ( _
    findParam As FindParam, _
    ownerBrowser As Browser _
)
Visual C++
public:
Element(
    FindParam^ findParam,
    Browser^ ownerBrowser
)

Parameters

findParam
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam array
ownerBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
Owner browser

See Also

Element Class
Element Overload
ArtOfTest.WebAii.ObjectModel Namespace


Element Constructor (FindParam, Find, Browser)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element Constructor (FindParam, Find, Browser)
Element Class See Also Send Feedback
Initialize an element proxy. The only property off this element that you can use is Wait.Exist() or Wait.ExistsNot()

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Use the Element(HtmlFindExpression,Find,Browser) constructor instead")]
public Element(
    FindParam findParam,
    Find findObj,
    Browser ownerBrowser
)
Visual Basic
<ObsoleteAttribute("Use the Element(HtmlFindExpression,Find,Browser) constructor instead")> _
Public Sub New ( _
    findParam As FindParam, _
    findObj As Find, _
    ownerBrowser As Browser _
)
Visual C++
[ObsoleteAttribute(L"Use the Element(HtmlFindExpression,Find,Browser) constructor instead")]
public:
Element(
    FindParam^ findParam,
    Find^ findObj,
    Browser^ ownerBrowser
)

Parameters

findParam
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam array
findObj
Type: ArtOfTest.WebAii.Core..::..Find
The Find object to use
ownerBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
Owner browser

See Also

Element Class
Element Overload
ArtOfTest.WebAii.ObjectModel Namespace


Element Constructor (HtmlFindExpression, Find, Browser)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element Constructor (HtmlFindExpression, Find, Browser)
Element Class See Also Send Feedback
Initialize an element proxy. The onlyl property off this element that you can use is Wait.Exist() or Wait.ExistsNot()

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element(
    HtmlFindExpression findExpr,
    Find findObj,
    Browser ownerBrowser
)
Visual Basic
Public Sub New ( _
    findExpr As HtmlFindExpression, _
    findObj As Find, _
    ownerBrowser As Browser _
)
Visual C++
public:
Element(
    HtmlFindExpression^ findExpr,
    Find^ findObj,
    Browser^ ownerBrowser
)

Parameters

findExpr
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
A FindExpression identifying this element
findObj
Type: ArtOfTest.WebAii.Core..::..Find
The Find object to use
ownerBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
Owner browser

See Also

Element Class
Element Overload
ArtOfTest.WebAii.ObjectModel Namespace


Element Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

 | Name | Description
Public method | AddChild | Add a child element to this element.
Public method | AddChildNode | Add this node as a child node.
Public method | As<(Of <<'(TControl>)>>) | Returns this elements as a strongly-typed control of type TControl.
Public method | Capture |
Public method | ContainsAttribute(String) | True/False whether this element contains a specific attribute name.
Public method | ContainsAttribute(iAttribute, Boolean, StringComparison, Boolean) | Whether a certain attribute is contained in this element
 | CreateLight | Create an Element object with a specific tagname and index.
Public method | Equals | Defines how two Elements should be compared. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Focus | Give this element keyboard focus
Public method | FriendlyName | Constructs a friendly name that represents this element.
Public method | GetAttribute(String) | Find a specific attribute by name and returns it. (case-insensitive)
Public method | GetAttribute(String, Boolean) | Finds a specific attribute name in the Element list of attributes and returns its object
Public method | GetAttributeValueOrEmpty | Gets the value of the attribute or a String.Empty if attribute does not exist.
Public method | GetChildren | Get the children of this node.
Public method | GetHashCode | Get the hash code for this Element. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHostParent | Returns the FRAME or IFRAME element containing this element's document, if one exists.
Public method | GetNextSibling | Get the next sibling of this node. If this node is the last sibling, will return null.
Public method | GetParent | Get the parent of this node.
Public method | GetPreservedInnerText | Same as InnerText but will respect any whitespaces between the tags.
Public method | GetPreviousSibling | Get the previous sibiling of this node. If this node is the first sibling, will return null.
Public method | GetRectangle | Gets the element rectangle. (X,Y) and width, height as it appears on browser and screen. Takes into account any scrolling.
Public method | GetTextContentRecursive | Gets the text content of this element, recursing only into the listed tags
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates the hash code for this element.
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value on this element.
Public method | IsFrame()()()() | Gets whether this element represents an iframe or frame
Public method | IsFrame(Boolean, Boolean) | Gets whether this element represents an iframe or frame
Public method | Match | Match this expression against element.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh()()()() | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
Public method | Refresh(Boolean) | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
Public method | SetClosingTag | Set the matching closing tag.
Public method | SetDepth | Sets the hierarchical depth of this element.
Public method | SetParent | Sets the parent of this Element.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property to a value on this element.
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property to a value on this element.
Public method | ToString | String representation of an Element. (Overrides Object..::..ToString()()()().)

Extension Methods

 | Name | Description
Public Extension Method | IsSilverlightPlugin | Detects whether the element is an object tag hosting a Silverlight plugin (Defined by SilverlightAppFinder.)
Public Extension Method | TojQuery | Start a jQuery expression from this element. (Defined by jQueryExtension.)

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


AddChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..AddChild Method
Element Class See Also Send Feedback
Add a child element to this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void AddChild(
    Element child
)
Visual Basic
Public Overridable Sub AddChild ( _
    child As Element _
)
Visual C++
public:
virtual void AddChild(
    Element^ child
)

Parameters

child
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The child to add.

Remarks

This method will only add elements of ParsingType=Markup to the Children collection. ChildNodes collection will contain a complete list of elements of all types. (i.e. Comment,TextLiteral ...etc).

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


AddChildNode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..AddChildNode Method
Element Class See Also Send Feedback
Add this node as a child node.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddChildNode(
    ITargetElement element
)
Visual Basic
Public Sub AddChildNode ( _
    element As ITargetElement _
)
Visual C++
public:
virtual void AddChildNode(
    ITargetElement^ element
) sealed

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.ObjectModel.Element.AddChildNode(ArtOfTest.Common.ITargetElement)"]

Implements

ITargetElement..::..AddChildNode(ITargetElement)

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


As(TControl) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..As<(Of <(<'TControl>)>)> Method
Element Class See Also Send Feedback
Returns this elements as a strongly-typed control of type TControl.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl As<TControl>()
where TControl : new(), Control
Visual Basic
Public Function As(Of TControl As {New, Control}) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl As()

Type Parameters

TControl
The control type.

Return Value

The control object.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Capture Method
Element Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.ObjectModel.Element.Capture"]

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap Capture()
Visual Basic
Public Function Capture As Bitmap
Visual C++
public:
virtual Bitmap^ Capture() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.ObjectModel.Element.Capture"]

Implements

ITargetElement..::..Capture()()()()

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


ContainsAttribute Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..ContainsAttribute Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ContainsAttribute(String) | True/False whether this element contains a specific attribute name.
Public method | ContainsAttribute(iAttribute, Boolean, StringComparison, Boolean) | Whether a certain attribute is contained in this element

See Also

Element Class
Element Members
ArtOfTest.WebAii.ObjectModel Namespace


ContainsAttribute Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..ContainsAttribute Method (String)
Element Class See Also Send Feedback
True/False whether this element contains a specific attribute name.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ContainsAttribute(
    string attributeName
)
Visual Basic
Public Function ContainsAttribute ( _
    attributeName As String _
) As Boolean
Visual C++
public:
bool ContainsAttribute(
    String^ attributeName
)

Parameters

attributeName
Type: System..::..String
The attribute name to check for.

Return Value

True/False on the attribute existence.

See Also

Element Class
ContainsAttribute Overload
ArtOfTest.WebAii.ObjectModel Namespace


ContainsAttribute Method (iAttribute, Boolean, StringComparison, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..ContainsAttribute Method (iAttribute, Boolean, StringComparison, Boolean)
Element Class See Also Send Feedback
Whether a certain attribute is contained in this element

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ContainsAttribute(
    iAttribute attribute,
    bool usePartialAttributeValue,
    StringComparison comparison,
    bool matchQuotes
)
Visual Basic
Public Function ContainsAttribute ( _
    attribute As iAttribute, _
    usePartialAttributeValue As Boolean, _
    comparison As StringComparison, _
    matchQuotes As Boolean _
) As Boolean
Visual C++
public:
bool ContainsAttribute(
    iAttribute^ attribute,
    bool usePartialAttributeValue,
    StringComparison comparison,
    bool matchQuotes
)

Parameters

attribute
Type: ArtOfTest.WebAii.ObjectModel..::..iAttribute
The attribute to compare.
usePartialAttributeValue
Type: System..::..Boolean
Whether to use partinal values of the attribute values.
comparison
Type: System..::..StringComparison
Comparison type.
matchQuotes
Type: System..::..Boolean
Whether to match the quotes or not. This only applied when UsePartialAttributeValue is false.

Return Value

True/False Whether the attribute is contained or not.

See Also

Element Class
ContainsAttribute Overload
ArtOfTest.WebAii.ObjectModel Namespace


CreateLight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..CreateLight Method
Element Class See Also Send Feedback
Create an Element object with a specific tagname and index.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Element CreateLight(
    string tagName,
    int tagIndex
)
Visual Basic
Public Shared Function CreateLight ( _
    tagName As String, _
    tagIndex As Integer _
) As Element
Visual C++
public:
static Element^ CreateLight(
    String^ tagName,
    int tagIndex
)

Parameters

tagName
Type: System..::..String
The tagName
tagIndex
Type: System..::..Int32
The tagIndex

Return Value

A lightweight element of the specified tag name and index.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Equals Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Equals Method
Element Class See Also Send Feedback
Defines how two Elements should be compared.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare.

Return Value

True/False whether the two objects are equal.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Focus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Focus Method
Element Class See Also Send Feedback
Give this element keyboard focus

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Focus()
Visual Basic
Public Sub Focus
Visual C++
public:
void Focus()

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


FriendlyName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..FriendlyName Method
Element Class See Also Send Feedback
Constructs a friendly name that represents this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FriendlyName()
Visual Basic
Public Function FriendlyName As String
Visual C++
public:
String^ FriendlyName()

Return Value

The string representation of this element.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetAttribute Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetAttribute Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAttribute(String) | Find a specific attribute by name and returns it. (case-insensitive)
Public method | GetAttribute(String, Boolean) | Finds a specific attribute name in the Element list of attributes and returns its object

See Also

Element Class
Element Members
ArtOfTest.WebAii.ObjectModel Namespace


GetAttribute Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetAttribute Method (String)
Element Class See Also Send Feedback
Find a specific attribute by name and returns it. (case-insensitive)

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public iAttribute GetAttribute(
    string name
)
Visual Basic
Public Function GetAttribute ( _
    name As String _
) As iAttribute
Visual C++
public:
iAttribute^ GetAttribute(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the attribute to get.

Return Value

The attribute or null if the attribute was not found.

See Also

Element Class
GetAttribute Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetAttribute Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetAttribute Method (String, Boolean)
Element Class See Also Send Feedback
Finds a specific attribute name in the Element list of attributes and returns its object

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public iAttribute GetAttribute(
    string name,
    bool ignoreCase
)
Visual Basic
Public Function GetAttribute ( _
    name As String, _
    ignoreCase As Boolean _
) As iAttribute
Visual C++
public:
iAttribute^ GetAttribute(
    String^ name,
    bool ignoreCase
)

Parameters

name
Type: System..::..String
The name of the attribute to find.
ignoreCase
Type: System..::..Boolean
Ignore case when searching.

Return Value

The attribute object or null if the attribute is not found.

See Also

Element Class
GetAttribute Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetAttributeValueOrEmpty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetAttributeValueOrEmpty Method
Element Class See Also Send Feedback
Gets the value of the attribute or a String.Empty if attribute does not exist.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetAttributeValueOrEmpty(
    string attrName
)
Visual Basic
Public Function GetAttributeValueOrEmpty ( _
    attrName As String _
) As String
Visual C++
public:
String^ GetAttributeValueOrEmpty(
    String^ attrName
)

Parameters

attrName
Type: System..::..String
The attribute to get.

Return Value

String.Empty if not found, else the attribute name.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetChildren Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetChildren Method
Element Class See Also Send Feedback
Get the children of this node.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement[] GetChildren()
Visual Basic
Public Function GetChildren As ITargetElement()
Visual C++
public:
virtual array<ITargetElement^>^ GetChildren() sealed

Return Value

The list of children as an array.

Implements

ITargetElement..::..GetChildren()()()()

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetHashCode Method
Element Class See Also Send Feedback
Get the hash code for this Element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The hash code.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetHostParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetHostParent Method
Element Class See Also Send Feedback
Returns the FRAME or IFRAME element containing this element's document, if one exists.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement GetHostParent()
Visual Basic
Public Function GetHostParent As ITargetElement
Visual C++
public:
virtual ITargetElement^ GetHostParent() sealed

Return Value

The parent IFrame element this element is hosted in.

Implements

ITargetElement..::..GetHostParent()()()()

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetNextSibling Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetNextSibling Method
Element Class See Also Send Feedback
Get the next sibling of this node. If this node is the last sibling, will return null.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element GetNextSibling()
Visual Basic
Public Function GetNextSibling As Element
Visual C++
public:
Element^ GetNextSibling()

Return Value

The next sibiling.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetParent Method
Element Class See Also Send Feedback
Get the parent of this node.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement GetParent()
Visual Basic
Public Function GetParent As ITargetElement
Visual C++
public:
virtual ITargetElement^ GetParent() sealed

Return Value

The parent node.

Implements

ITargetElement..::..GetParent()()()()

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetPreservedInnerText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetPreservedInnerText Method
Element Class See Also Send Feedback
Same as InnerText but will respect any whitespaces between the tags.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetPreservedInnerText(
    bool trimStartEnd
)
Visual Basic
Public Function GetPreservedInnerText ( _
    trimStartEnd As Boolean _
) As String
Visual C++
public:
String^ GetPreservedInnerText(
    bool trimStartEnd
)

Parameters

trimStartEnd
Type: System..::..Boolean
True/False whether to trim the whitespace from the start/end of the string.

Return Value

The preserved innertext.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetPreviousSibling Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetPreviousSibling Method
Element Class See Also Send Feedback
Get the previous sibiling of this node. If this node is the first sibling, will return null.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element GetPreviousSibling()
Visual Basic
Public Function GetPreviousSibling As Element
Visual C++
public:
Element^ GetPreviousSibling()

Return Value

The previous sibling

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetRectangle Method
Element Class See Also Send Feedback
Gets the element rectangle. (X,Y) and width, height as it appears on browser and screen. Takes into account any scrolling.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Rectangle GetRectangle()
Visual Basic
Public Overridable Function GetRectangle As Rectangle
Visual C++
public:
virtual Rectangle GetRectangle()

Return Value

The rectangle object of this element.

Implements

ITargetElement..::..GetRectangle()()()()

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetTextContentRecursive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetTextContentRecursive Method
Element Class See Also Send Feedback
Gets the text content of this element, recursing only into the listed tags

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetTextContentRecursive(
    params string[] tags
)
Visual Basic
Public Function GetTextContentRecursive ( _
    ParamArray tags As String() _
) As String
Visual C++
public:
String^ GetTextContentRecursive(
    ... array<String^>^ tags
)

Parameters

tags
Type: array< System..::..String >[]()[][]
The tags to recurse into

Return Value

The combined test content of the specified tags.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetUniqueHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetUniqueHashCode Method
Element Class See Also Send Feedback
Calculates the hash code for this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int GetUniqueHashCode()
Visual Basic
Public Function GetUniqueHashCode As Integer
Visual C++
public:
virtual int GetUniqueHashCode() sealed

Return Value

The hash code.

Implements

ITargetElement..::..GetUniqueHashCode()()()()

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetValue Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value on this element.
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value on this element.

See Also

Element Class
Element Members
ArtOfTest.WebAii.ObjectModel Namespace


GetValue(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetValue<(Of <(<'T>)>)> Method (String)
Element Class See Also Send Feedback
Get a property value on this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T GetValue<T>(
    string propertyName
)
Visual Basic
Public Overridable Function GetValue(Of T) ( _
    propertyName As String _
) As T
Visual C++
public:
generic<typename T>
virtual T GetValue(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String
The property name.

Type Parameters

T
The type of the property to return.

Return Value

The property value returned as type T.

See Also

Element Class
GetValue Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetValue(T) Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetValue<(Of <(<'T>)>)> Method (String, Boolean)
Element Class See Also Send Feedback
Get a property value on this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T GetValue<T>(
    string propertyName,
    bool isJsWrappedObject
)
Visual Basic
Public Overridable Function GetValue(Of T) ( _
    propertyName As String, _
    isJsWrappedObject As Boolean _
) As T
Visual C++
public:
generic<typename T>
virtual T GetValue(
    String^ propertyName,
    bool isJsWrappedObject
)

Parameters

propertyName
Type: System..::..String
The property name.
isJsWrappedObject
Type: System..::..Boolean
True/False whether you are accessing an extended wrapperd JS object. [Needed for Firefox only]

Type Parameters

T
The type of the property to return

Return Value

The property value returned as type T.

See Also

Element Class
GetValue Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetValue(T) Method (String, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetValue<(Of <(<'T>)>)> Method (String, T)
Element Class See Also Send Feedback
Get a property value on this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T GetValue<T>(
    string propertyName,
    T defaultValue
)
Visual Basic
Public Overridable Function GetValue(Of T) ( _
    propertyName As String, _
    defaultValue As T _
) As T
Visual C++
public:
generic<typename T>
virtual T GetValue(
    String^ propertyName,
    T defaultValue
)

Parameters

propertyName
Type: System..::..String
The property name.
defaultValue
Type: T
The return value, if the property has no value (is null or the empty string)

Type Parameters

T
The type of the property to return.

Return Value

The property value returned as type T.

See Also

Element Class
GetValue Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetValue(T) Method (String, Boolean, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..GetValue<(Of <(<'T>)>)> Method (String, Boolean, T)
Element Class See Also Send Feedback
Get a property value on this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual T GetValue<T>(
    string propertyName,
    bool isJsWrappedObject,
    T defaultValue
)
Visual Basic
Public Overridable Function GetValue(Of T) ( _
    propertyName As String, _
    isJsWrappedObject As Boolean, _
    defaultValue As T _
) As T
Visual C++
public:
generic<typename T>
virtual T GetValue(
    String^ propertyName,
    bool isJsWrappedObject,
    T defaultValue
)

Parameters

propertyName
Type: System..::..String
The property name.
isJsWrappedObject
Type: System..::..Boolean
True/False whether you are accessing an extended wrapped JS object. [Needed for Firefox only]
defaultValue
Type: T
The return value, if the property has no value (is null or the empty string)

Type Parameters

T
The type of the property to return

Return Value

The property value returned as type T.

See Also

Element Class
GetValue Overload
ArtOfTest.WebAii.ObjectModel Namespace


IsFrame Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IsFrame Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsFrame()()()() | Gets whether this element represents an iframe or frame
Public method | IsFrame(Boolean, Boolean) | Gets whether this element represents an iframe or frame

See Also

Element Class
Element Members
ArtOfTest.WebAii.ObjectModel Namespace


IsFrame Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IsFrame Method
Element Class See Also Send Feedback
Gets whether this element represents an iframe or frame

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameInfo IsFrame()
Visual Basic
Public Function IsFrame As FrameInfo
Visual C++
public:
FrameInfo^ IsFrame()

Return Value

Return the FrameInfo of the frame if is a frame, else will return null

See Also

Element Class
IsFrame Overload
ArtOfTest.WebAii.ObjectModel Namespace


IsFrame Method (Boolean, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IsFrame Method (Boolean, Boolean)
Element Class See Also Send Feedback
Gets whether this element represents an iframe or frame

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameInfo IsFrame(
    bool makeAbsolute,
    bool stripFinalBrowserSegment
)
Visual Basic
Public Function IsFrame ( _
    makeAbsolute As Boolean, _
    stripFinalBrowserSegment As Boolean _
) As FrameInfo
Visual C++
public:
FrameInfo^ IsFrame(
    bool makeAbsolute,
    bool stripFinalBrowserSegment
)

Parameters

makeAbsolute
Type: System..::..Boolean
Whether to force the FrameInfo's Src to be an absolute URI
stripFinalBrowserSegment
Type: System..::..Boolean
When used in conjunction with makeAbsolute, this will strip the final path segment from the owning browser's URL before concatenating the frame's src.

Return Value

Return the FrameInfo of the frame if is a frame, else will return null

See Also

Element Class
IsFrame Overload
ArtOfTest.WebAii.ObjectModel Namespace


Match Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Match Method
Element Class See Also Send Feedback
Match this expression against element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Match(
    IFindExpression findExpr
)
Visual Basic
Public Function Match ( _
    findExpr As IFindExpression _
) As Boolean
Visual C++
public:
virtual bool Match(
    IFindExpression^ findExpr
) sealed

Parameters

findExpr
Type: ArtOfTest.Common..::..IFindExpression
The expression to use.

Return Value

Returns true/false

Implements

ITargetElement..::..Match(IFindExpression)

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Refresh Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Refresh Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Refresh()()()() | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.
Public method | Refresh(Boolean) | Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.

See Also

Element Class
Element Members
ArtOfTest.WebAii.ObjectModel Namespace


Refresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Refresh Method
Element Class See Also Send Feedback
Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Refresh()
Visual Basic
Public Overridable Sub Refresh
Visual C++
public:
virtual void Refresh()

Implements

ITargetElement..::..Refresh()()()()

See Also

Element Class
Refresh Overload
ArtOfTest.WebAii.ObjectModel Namespace


Refresh Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Refresh Method (Boolean)
Element Class See Also Send Feedback
Using the FindParamsUsed and the TestRegionIdUsed to find this element last, this methods will attempt to re-find this element in the new DOM tree.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Refresh(
    bool forceDomTreeRefresh
)
Visual Basic
Public Overridable Sub Refresh ( _
    forceDomTreeRefresh As Boolean _
)
Visual C++
public:
virtual void Refresh(
    bool forceDomTreeRefresh
)

Parameters

forceDomTreeRefresh
Type: System..::..Boolean
Force a Browser/Plugin refresh before attempting to refine this element.

See Also

Element Class
Refresh Overload
ArtOfTest.WebAii.ObjectModel Namespace


SetClosingTag Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..SetClosingTag Method
Element Class See Also Send Feedback
Set the matching closing tag.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetClosingTag(
    ITargetElement closingElement
)
Visual Basic
Public Sub SetClosingTag ( _
    closingElement As ITargetElement _
)
Visual C++
public:
virtual void SetClosingTag(
    ITargetElement^ closingElement
) sealed

Parameters

closingElement
Type: ArtOfTest.Common..::..ITargetElement
The closing tag

Implements

ITargetElement..::..SetClosingTag(ITargetElement)

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


SetDepth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..SetDepth Method
Element Class See Also Send Feedback
Sets the hierarchical depth of this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetDepth(
    int depth
)
Visual Basic
Public Sub SetDepth ( _
    depth As Integer _
)
Visual C++
public:
virtual void SetDepth(
    int depth
) sealed

Parameters

depth
Type: System..::..Int32

[Missing <param name="depth"/> documentation for "M:ArtOfTest.WebAii.ObjectModel.Element.SetDepth(System.Int32)"]

Implements

ITargetElement..::..SetDepth(Int32)

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


SetParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..SetParent Method
Element Class See Also Send Feedback
Sets the parent of this Element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetParent(
    ITargetElement parent
)
Visual Basic
Public Sub SetParent ( _
    parent As ITargetElement _
)
Visual C++
public:
virtual void SetParent(
    ITargetElement^ parent
) sealed

Parameters

parent
Type: ArtOfTest.Common..::..ITargetElement
The parent element.

Implements

ITargetElement..::..SetParent(ITargetElement)

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..SetValue Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property to a value on this element.
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property to a value on this element.

See Also

Element Class
Element Members
ArtOfTest.WebAii.ObjectModel Namespace


SetValue(T) Method (String, T)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..SetValue<(Of <(<'T>)>)> Method (String, T)
Element Class See Also Send Feedback
Set a property to a value on this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SetValue<T>(
    string propertyName,
    T value
)
Visual Basic
Public Overridable Sub SetValue(Of T) ( _
    propertyName As String, _
    value As T _
)
Visual C++
public:
generic<typename T>
virtual void SetValue(
    String^ propertyName,
    T value
)

Parameters

propertyName
Type: System..::..String
The property name.
value
Type: T
The value.

Type Parameters

T
The type of the value.

See Also

Element Class
SetValue Overload
ArtOfTest.WebAii.ObjectModel Namespace


SetValue(T) Method (String, T, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..SetValue<(Of <(<'T>)>)> Method (String, T, Boolean)
Element Class See Also Send Feedback
Set a property to a value on this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SetValue<T>(
    string propertyName,
    T value,
    bool isJsWrappedObject
)
Visual Basic
Public Overridable Sub SetValue(Of T) ( _
    propertyName As String, _
    value As T, _
    isJsWrappedObject As Boolean _
)
Visual C++
public:
generic<typename T>
virtual void SetValue(
    String^ propertyName,
    T value,
    bool isJsWrappedObject
)

Parameters

propertyName
Type: System..::..String
The property name.
value
Type: T
The value.
isJsWrappedObject
Type: System..::..Boolean
True/False whether you are accessing an extended wrapperd JS object. [Needed for Firefox only]

Type Parameters

T
The type of the value.

See Also

Element Class
SetValue Overload
ArtOfTest.WebAii.ObjectModel Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..ToString Method
Element Class See Also Send Feedback
String representation of an Element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Element Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

Name Description
Public property AbsoluteSiblingTagIndex
Gets the absolute sibling tag index of this element within the parent node. Basically the order of this node among its siblings. Zero-based.
Public property AbsoluteTagIndex
Gets the absolute that index of this element. This index is unique within a document.
Public property Attributes
Gets the list of attributes defined for this element.
Public property ChildNodes
Gets the list of all parsed element of this tag including text literals, comments, malformed tags...etc.
Public property Children
Gets the list of child elements that are well formed markup non-text elements.
Public property Content
Gets the raw content of the tag that represents this element.

Examples

The following tag <foo id="bar" height="px">some text</foo> , has a Content property that is: '<foo id="bar" height="px">' Note: this does not include the innerText or the closing tag.
Public property CssClassAttributeValue
Gets the value of the attribute ('class') if present on this tag.
Public property Data
Gets/Sets any custom data associated with this element.
Public property Depth
The hierarchical depth of this element
Public property ElementType
Gets the element type (div, table ..etc).
Public property FindExpressionUsed
Gets the FindExpression used to find this element when using the Find object. This property is not set when calling the Find.Allxxx methods.
Public property FindObjectUsed
Gets a reference to the Find object used to find this element
Public property FindParamsUsed Obsolete.
Gets the FindParams used to find this element when using the Find object. If chained identification is used this array will contain the list of params, otherwise will contain a single FindParam object. This property is not set when calling the Find.Allxxx methods.
Public property FrameElement
Gets / Sets the root frame element that this element is contained in.
Public property HasIdOrName
Gets whether this element has an id or a name set on it.
Public property Host
Get the IAutomationHost associated with this element.
Public property IdAttributeValue
Gets the value of the attribute ('id') if present on this tag.
Public property InnerMarkup
Gets the InnerMarkup of this element.

Examples

Example: <foo id="1">hello<bar></bar></foo> If foo is this element then InnerMarkup=<bar></bar>
Public property InnerText
Gets this element's inner text content including all of its nested children.

Examples

Example: <foo id="1">one<bar>two</bar></foo> If foo is this element then InnerText=onetwo
Public property InputElementType
Gets the Input type (i.e. checkbox, radio...etc) if the ElementType=Input. Otherwise, will return NotSet.
Public property IsBeginTag
Gets whether it is a begin tag <foo bar='me'> .
Public property IsEndTag
Gets whether this element is an end tag </foo>.
Public property IsProxy
Gets whether this element is a proxy element or a fully initialized element.
Public property IsSelfClosing
Gets whether the element is self-closing (<foo />).
Public property IsTestRegion
Gets whether the element is a test region or not. This function has been added for performance reasons. We don't want to call the ElementType property since it will trigger the full initialization of types.
Public property MatchingClosingTag
Gets the element's closing tag if it is a begin tag and not self-closing.
Public property NameAttributeValue
Gets the value of the attribute ('name') if present on this tag
Public property OuterMarkup
Gets the OuterMarkup of this element.

Examples

Example: <foo id="1"><bar></bar></foo> If foo is this element then outerMarkup=<foo id="1"><bar></bar></foo>
Public property OwnerBrowser
Returns the owner browser of this element.
Public property Parent
Gets the Parent element.
Public property ParsedElement
Returns the raw parsed element.
Public property ParsingType
Gets the parsing type set by the parser. (Markup, LiteralText, Comment..etc)
Public property TagName
Gets the tagName of the the element
Public property TagNameIndex
Gets the tagName occurrence of this element.

Examples

If this element is TagName='foo', then TagNameIndex= 3 indicates that this element represents the third occurence of tagName 'foo' within this document.
Public property TechnologyType
Get the technology type.
Public property TextContent
Gets this element's inner text content without recursing through all its nested children for text.
Public property Wait
Gets the wait object to wait for certain conditions of this element.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


AbsoluteSiblingTagIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..AbsoluteSiblingTagIndex Property
Element Class See Also Send Feedback
Gets the absolute sibling tag index of this element within the parent node. Basically the order of this node among its siblings. Zero-based.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AbsoluteSiblingTagIndex { get; set; }
Visual Basic
Public Property AbsoluteSiblingTagIndex As Integer
    Get
    Set
Visual C++
public:
property int AbsoluteSiblingTagIndex {
    int get ();
    void set (int value);
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


AbsoluteTagIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..AbsoluteTagIndex Property
Element Class See Also Send Feedback
Gets the absolute that index of this element. This index is unique within a document.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AbsoluteTagIndex { get; }
Visual Basic
Public ReadOnly Property AbsoluteTagIndex As Integer
    Get
Visual C++
public:
property int AbsoluteTagIndex {
    int get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Attributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Attributes Property
Element Class See Also Send Feedback
Gets the list of attributes defined for this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<iAttribute> Attributes { get; }
Visual Basic
Public ReadOnly Property Attributes As ReadOnlyCollection(Of iAttribute)
    Get
Visual C++
public:
property ReadOnlyCollection<iAttribute^>^ Attributes {
    ReadOnlyCollection<iAttribute^>^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


ChildNodes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..ChildNodes Property
Element Class See Also Send Feedback
Gets the list of all parsed element of this tag including text literals, comments, malformed tags...etc.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> ChildNodes { get; }
Visual Basic
Public ReadOnly Property ChildNodes As ReadOnlyCollection(Of Element)
    Get
Visual C++
public:
property ReadOnlyCollection<Element^>^ ChildNodes {
    ReadOnlyCollection<Element^>^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Children Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Children Property
Element Class See Also Send Feedback
Gets the list of child elements that are well formed markup non-text elements.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ReadOnlyCollection<Element> Children { get; }
Visual Basic
Public ReadOnly Property Children As ReadOnlyCollection(Of Element)
    Get
Visual C++
public:
property ReadOnlyCollection<Element^>^ Children {
    ReadOnlyCollection<Element^>^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Content Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Content Property
Element Class See Also Send Feedback
Gets the raw content of the tag that represents this element.

Examples

The following tag <foo id="bar" height="px">some text</foo> , has a Content property that is: '<foo id="bar" height="px">' Note: this does not include the innerText or the closing tag.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Content { get; }
Visual Basic
Public ReadOnly Property Content As String
    Get
Visual C++
public:
property String^ Content {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


CssClassAttributeValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..CssClassAttributeValue Property
Element Class See Also Send Feedback
Gets the value of the attribute ('class') if present on this tag.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string CssClassAttributeValue { get; }
Visual Basic
Public ReadOnly Property CssClassAttributeValue As String
    Get
Visual C++
public:
property String^ CssClassAttributeValue {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Data Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Data Property
Element Class See Also Send Feedback
Gets/Sets any custom data associated with this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object Data { get; set; }
Visual Basic
Public Property Data As Object
    Get
    Set
Visual C++
public:
property Object^ Data {
    Object^ get ();
    void set (Object^ value);
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Depth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Depth Property
Element Class See Also Send Feedback
The hierarchical depth of this element

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Depth { get; }
Visual Basic
Public ReadOnly Property Depth As Integer
    Get
Visual C++
public:
virtual property int Depth {
    int get () sealed;
}

Implements

ITargetElement..::..Depth

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


ElementType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..ElementType Property
Element Class See Also Send Feedback
Gets the element type (div, table ..etc).

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ElementType ElementType { get; }
Visual Basic
Public ReadOnly Property ElementType As ElementType
    Get
Visual C++
public:
property ElementType ElementType {
    ElementType get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


FindExpressionUsed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..FindExpressionUsed Property
Element Class See Also Send Feedback
Gets the FindExpression used to find this element when using the Find object. This property is not set when calling the Find.Allxxx methods.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlFindExpression FindExpressionUsed { get; }
Visual Basic
Public ReadOnly Property FindExpressionUsed As HtmlFindExpression
    Get
Visual C++
public:
property HtmlFindExpression^ FindExpressionUsed {
    HtmlFindExpression^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


FindObjectUsed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..FindObjectUsed Property
Element Class See Also Send Feedback
Gets a reference to the Find object used to find this element

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Find FindObjectUsed { get; }
Visual Basic
Public ReadOnly Property FindObjectUsed As Find
    Get
Visual C++
public:
property Find^ FindObjectUsed {
    Find^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamsUsed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..FindParamsUsed Property
Element Class See Also Send Feedback
Gets the FindParams used to find this element when using the Find object. If chained identification is used this array will contain the list of params, otherwise will contain a single FindParam object. This property is not set when calling the Find.Allxxx methods.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("FindParams are deprecated in favor of FindExpressions.")]
public FindParam[] FindParamsUsed { get; }
Visual Basic
<ObsoleteAttribute("FindParams are deprecated in favor of FindExpressions.")> _
Public ReadOnly Property FindParamsUsed As FindParam()
    Get
Visual C++
[ObsoleteAttribute(L"FindParams are deprecated in favor of FindExpressions.")]
public:
property array<FindParam^>^ FindParamsUsed {
    array<FindParam^>^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


FrameElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..FrameElement Property
Element Class See Also Send Feedback
Gets / Sets the root frame element that this element is contained in.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element FrameElement { get; set; }
Visual Basic
Public Property FrameElement As Element
    Get
    Set
Visual C++
public:
property Element^ FrameElement {
    Element^ get ();
    void set (Element^ value);
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


HasIdOrName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..HasIdOrName Property
Element Class See Also Send Feedback
Gets whether this element has an id or a name set on it.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasIdOrName { get; }
Visual Basic
Public ReadOnly Property HasIdOrName As Boolean
    Get
Visual C++
public:
property bool HasIdOrName {
    bool get ();
}

Return Value

True/False whether or not this element has an ID or a Name attribute applied to it.

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Host Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Host Property
Element Class See Also Send Feedback
Get the IAutomationHost associated with this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IAutomationHost Host { get; }
Visual Basic
Public ReadOnly Property Host As IAutomationHost
    Get
Visual C++
public:
virtual property IAutomationHost^ Host {
    IAutomationHost^ get () sealed;
}

Implements

ITargetElement..::..Host

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


IdAttributeValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IdAttributeValue Property
Element Class See Also Send Feedback
Gets the value of the attribute ('id') if present on this tag.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string IdAttributeValue { get; }
Visual Basic
Public ReadOnly Property IdAttributeValue As String
    Get
Visual C++
public:
property String^ IdAttributeValue {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


InnerMarkup Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..InnerMarkup Property
Element Class See Also Send Feedback
Gets the InnerMarkup of this element.

Examples

Example: <foo id="1">hello<bar></bar></foo> If foo is this element then InnerMarkup=<bar></bar>

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string InnerMarkup { get; }
Visual Basic
Public ReadOnly Property InnerMarkup As String
    Get
Visual C++
public:
property String^ InnerMarkup {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


InnerText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..InnerText Property
Element Class See Also Send Feedback
Gets this element's inner text content including all of its nested children.

Examples

Example: <foo id="1">one<bar>two</bar></foo> If foo is this element then InnerText=onetwo

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string InnerText { get; }
Visual Basic
Public ReadOnly Property InnerText As String
    Get
Visual C++
public:
property String^ InnerText {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


InputElementType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..InputElementType Property
Element Class See Also Send Feedback
Gets the Input type (i.e. checkbox, radio...etc) if the ElementType=Input. Otherwise, will return NotSet.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InputElementType InputElementType { get; }
Visual Basic
Public ReadOnly Property InputElementType As InputElementType
    Get
Visual C++
public:
property InputElementType InputElementType {
    InputElementType get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


IsBeginTag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IsBeginTag Property
Element Class See Also Send Feedback
Gets whether it is a begin tag <foo bar='me'> .

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsBeginTag { get; }
Visual Basic
Public ReadOnly Property IsBeginTag As Boolean
    Get
Visual C++
public:
property bool IsBeginTag {
    bool get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


IsEndTag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IsEndTag Property
Element Class See Also Send Feedback
Gets whether this element is an end tag </foo>.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEndTag { get; }
Visual Basic
Public ReadOnly Property IsEndTag As Boolean
    Get
Visual C++
public:
property bool IsEndTag {
    bool get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


IsProxy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IsProxy Property
Element Class See Also Send Feedback
Gets whether this element is a proxy element or a fully initialized element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsProxy { get; }
Visual Basic
Public ReadOnly Property IsProxy As Boolean
    Get
Visual C++
public:
property bool IsProxy {
    bool get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


IsSelfClosing Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IsSelfClosing Property
Element Class See Also Send Feedback
Gets whether the element is self-closing (<foo />).

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSelfClosing { get; }
Visual Basic
Public ReadOnly Property IsSelfClosing As Boolean
    Get
Visual C++
public:
property bool IsSelfClosing {
    bool get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


IsTestRegion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..IsTestRegion Property
Element Class See Also Send Feedback
Gets whether the element is a test region or not. This function has been added for performance reasons. We don't want to call the ElementType property since it will trigger the full initialization of types.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTestRegion { get; }
Visual Basic
Public ReadOnly Property IsTestRegion As Boolean
    Get
Visual C++
public:
virtual property bool IsTestRegion {
    bool get () sealed;
}

Implements

ITargetElement..::..IsTestRegion

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


MatchingClosingTag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..MatchingClosingTag Property
Element Class See Also Send Feedback
Gets the element's closing tag if it is a begin tag and not self-closing.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element MatchingClosingTag { get; set; }
Visual Basic
Public Property MatchingClosingTag As Element
    Get
    Set
Visual C++
public:
property Element^ MatchingClosingTag {
    Element^ get ();
    void set (Element^ value);
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


NameAttributeValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..NameAttributeValue Property
Element Class See Also Send Feedback
Gets the value of the attribute ('name') if present on this tag

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string NameAttributeValue { get; }
Visual Basic
Public ReadOnly Property NameAttributeValue As String
    Get
Visual C++
public:
property String^ NameAttributeValue {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


OuterMarkup Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..OuterMarkup Property
Element Class See Also Send Feedback
Gets the OuterMarkup of this element.

Examples

Example: <foo id="1"><bar></bar></foo> If foo is this element then outerMarkup=<foo id="1"><bar></bar></foo>

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string OuterMarkup { get; }
Visual Basic
Public ReadOnly Property OuterMarkup As String
    Get
Visual C++
public:
property String^ OuterMarkup {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


OwnerBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..OwnerBrowser Property
Element Class See Also Send Feedback
Returns the owner browser of this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser OwnerBrowser { get; }
Visual Basic
Public ReadOnly Property OwnerBrowser As Browser
    Get
Visual C++
public:
property Browser^ OwnerBrowser {
    Browser^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Parent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Parent Property
Element Class See Also Send Feedback
Gets the Parent element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element Parent { get; }
Visual Basic
Public ReadOnly Property Parent As Element
    Get
Visual C++
public:
property Element^ Parent {
    Element^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


ParsedElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..ParsedElement Property
Element Class See Also Send Feedback
Returns the raw parsed element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ParsedElement ParsedElement { get; }
Visual Basic
Public ReadOnly Property ParsedElement As ParsedElement
    Get
Visual C++
public:
virtual property ParsedElement^ ParsedElement {
    ParsedElement^ get () sealed;
}

Return Value

The raw parsed element

Implements

ITargetElement..::..ParsedElement

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


ParsingType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..ParsingType Property
Element Class See Also Send Feedback
Gets the parsing type set by the parser. (Markup, LiteralText, Comment..etc)

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ParsedElementType ParsingType { get; }
Visual Basic
Public ReadOnly Property ParsingType As ParsedElementType
    Get
Visual C++
public:
property ParsedElementType ParsingType {
    ParsedElementType get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


TagName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..TagName Property
Element Class See Also Send Feedback
Gets the tagName of the the element

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TagName { get; }
Visual Basic
Public ReadOnly Property TagName As String
    Get
Visual C++
public:
property String^ TagName {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


TagNameIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..TagNameIndex Property
Element Class See Also Send Feedback
Gets the tagName occurrence of this element.

Examples

If this element is TagName='foo', then TagNameIndex= 3 indicates that this element represents the third occurence of tagName 'foo' within this document.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TagNameIndex { get; }
Visual Basic
Public ReadOnly Property TagNameIndex As Integer
    Get
Visual C++
public:
property int TagNameIndex {
    int get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


TechnologyType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..TechnologyType Property
Element Class See Also Send Feedback
Get the technology type.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TechnologyType TechnologyType { get; }
Visual Basic
Public ReadOnly Property TechnologyType As TechnologyType
    Get
Visual C++
public:
virtual property TechnologyType TechnologyType {
    TechnologyType get () sealed;
}

Implements

ITargetElement..::..TechnologyType

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


TextContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..TextContent Property
Element Class See Also Send Feedback
Gets this element's inner text content without recursing through all its nested children for text.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TextContent { get; }
Visual Basic
Public ReadOnly Property TextContent As String
    Get
Visual C++
public:
property String^ TextContent {
    String^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


Wait Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Element..::..Wait Property
Element Class See Also Send Feedback
Gets the wait object to wait for certain conditions of this element.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Wait Wait { get; }
Visual Basic
Public ReadOnly Property Wait As Wait
    Get
Visual C++
public:
property Wait^ Wait {
    Wait^ get ();
}

See Also

Element Class
ArtOfTest.WebAii.ObjectModel Namespace


FindExpressionCollection(T) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)> Members
FindExpressionCollection<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The FindExpressionCollection<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | FindExpressionCollection<(Of <(<'T>)>)> | Create a new FindExpressionCollection that also be serialized.

Methods

Name Description
Public method Add
Add a new FindExpression item.
Public method Clear
Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method ContainsKey
Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method ContainsValue
Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetObjectData
Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method GetSchema
Return the schema used for serialization.

Remarks

Currently we are returning null
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
LoadFromFile
Load a FindParamCollection from a file.
LoadFromXml
Load a FindParamCollection from an xml persisted string.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method OnDeserialization
Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method ReadXml
Deserialized from the xmlReader and initialize the object
Public method Remove
Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method Save
Serialized and saves the current collection to a file. You can later load that file using FindParamCollection.Load().
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method ToXml
Serialize and return the current FindParamCollection as a string. You can later use that string to create a FindParamCollection using the .Load().
Public method TryGetValue
Gets the value associated with the specified key.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method WriteXml
Serialize this object to the XmlWriter

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public property | Item | Access a FindExpression using its key.
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public property | ReturnNullIfNotFound | Gets/Sets whether to throw or return null if a FindExpressions is not found.
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, T >)>)>.)

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


FindExpressionCollection(T) Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)> Constructor
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new FindExpressionCollection that also be serialized.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindExpressionCollection()
Visual Basic
Public Sub New
Visual C++
public:
FindExpressionCollection()

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


FindExpressionCollection(T) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)> Methods
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The FindExpressionCollection<(Of <(<'T>)>)> type exposes the following members.

Methods

Name Description
Public method Add
Add a new FindExpression item.
Public method Clear
Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method ContainsKey
Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method ContainsValue
Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetObjectData
Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method GetSchema
Return the schema used for serialization.

Remarks

Currently we are returning null
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
LoadFromFile
Load a FindParamCollection from a file.
LoadFromXml
Load a FindParamCollection from an xml persisted string.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method OnDeserialization
Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method ReadXml
Deserialized from the xmlReader and initialize the object
Public method Remove
Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method Save
Serialized and saves the current collection to a file. You can later load that file using FindParamCollection.Load().
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method ToXml
Serialize and return the current FindParamCollection as a string. You can later use that string to create a FindParamCollection using the .Load().
Public method TryGetValue
Gets the value associated with the specified key.
(Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public method WriteXml
Serialize this object to the XmlWriter

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


Add Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..Add Method
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Add a new FindExpression item.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Add(
    string key,
    T param
)
Visual Basic
Public Sub Add ( _
    key As String, _
    param As T _
)
Visual C++
public:
void Add(
    String^ key,
    T param
)

Parameters

key
Type: System..::..String
The key.
param
Type: T
The FindExpression object.

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


GetSchema Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..GetSchema Method
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Return the schema used for serialization.

Remarks

Currently we are returning null

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema
Visual C++
public:
virtual XmlSchema^ GetSchema() sealed

Return Value

The schema

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


LoadFromFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..LoadFromFile Method
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Load a FindParamCollection from a file.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FindExpressionCollection<T> LoadFromFile(
    string fileName
)
Visual Basic
Public Shared Function LoadFromFile ( _
    fileName As String _
) As FindExpressionCollection(Of T)
Visual C++
public:
static FindExpressionCollection<T>^ LoadFromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name to load the xml from.

Return Value

The FindParamCollection object.

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


LoadFromXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..LoadFromXml Method
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Load a FindParamCollection from an xml persisted string.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FindExpressionCollection<T> LoadFromXml(
    string xml
)
Visual Basic
Public Shared Function LoadFromXml ( _
    xml As String _
) As FindExpressionCollection(Of T)
Visual C++
public:
static FindExpressionCollection<T>^ LoadFromXml(
    String^ xml
)

Parameters

xml
Type: System..::..String
The string string.

Return Value

The FindParamCollection object.

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


ReadXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..ReadXml Method
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Deserialized from the xmlReader and initialize the object

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml ( _
    reader As XmlReader _
)
Visual C++
public:
virtual void ReadXml(
    XmlReader^ reader
) sealed

Parameters

reader
Type: System.Xml..::..XmlReader
The reader.

Implements

IXmlSerializable..::..ReadXml(XmlReader)

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


Save Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..Save Method
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Serialized and saves the current collection to a file. You can later load that file using FindParamCollection.Load().

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Save(
    string fileName
)
Visual Basic
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name to save to.

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


ToXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..ToXml Method
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Serialize and return the current FindParamCollection as a string. You can later use that string to create a FindParamCollection using the .Load().

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ToXml()
Visual Basic
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

The serialized Xml that represents this object.

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


WriteXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..WriteXml Method
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Serialize this object to the XmlWriter

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml ( _
    writer As XmlWriter _
)
Visual C++
public:
virtual void WriteXml(
    XmlWriter^ writer
) sealed

Parameters

writer
Type: System.Xml..::..XmlWriter
The writer.

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


FindExpressionCollection(T) Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)> Properties
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback

The FindExpressionCollection<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public property | Item | Access a FindExpression using its key.
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, T >)>)>.)
Public property | ReturnNullIfNotFound | Gets/Sets whether to throw or return null if a FindExpressions is not found.
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, T >)>)>.)

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..Item Property
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Access a FindExpression using its key.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T this[
    string key
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    key As String _
) As T
    Get
Visual C++
public:
property T default[String^ key] {
    T get (String^ key);
}

Parameters

key
Type: System..::..String
The key.

Return Value

The FindExpression object.

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


ReturnNullIfNotFound Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindExpressionCollection<(Of <(<'T>)>)>..::..ReturnNullIfNotFound Property
FindExpressionCollection<(Of <(<'T>)>)> Class See Also Send Feedback
Gets/Sets whether to throw or return null if a FindExpressions is not found.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ReturnNullIfNotFound { get; set; }
Visual Basic
Public Property ReturnNullIfNotFound As Boolean
    Get
    Set
Visual C++
public:
property bool ReturnNullIfNotFound {
    bool get ();
    void set (bool value);
}

See Also

FindExpressionCollection<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Members
FindParam Class Constructors Methods Properties Events See Also Send Feedback

The FindParam type exposes the following members.

Constructors

 | Name | Description
Public method | FindParam()()()() | Create a new FindParam
Public method | FindParam(array<Int32>[]()[][]) | Create a new find parameter of Type=NodeIndexPath
Public method | FindParam(array<String>[]()[][]) | Create a new find parameter using name-value pairs of attributes.
Public method | FindParam(HtmlFindExpression) | Create a new find param of type.
Public method | FindParam(String, Int32) | Create a new find parameter of Type=TagIndex
Public method | FindParam(String, Int32, array<String>[]()[][]) | Create a new find parameter of Type=TagIndex with additional attributes to use to find the element or verify it.
Public method | FindParam(FindType, String, array<String>[]()[][]) | Create a new FindParam by explicitly specifying the FindType.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadFromFile | Load a FindParam from a file.
 | LoadFromXml | Load a FindParam from an xml persisted string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewExpr | Create a FindParam object from an expression.
Public method | Save | Serialized and saves the current FindParam to a file. You can later load that file using FindParam.Load().
Public method | SetAttributes | Used to initialize a list of parameter value pairs on a FindParam.
Public method | SetContent | Sets the content type and returns the updated FindParam.
Public method | SetTagName | Sets the tag name and returns the updated FindParam.
Public method | ToString | String representation of the FindParam. (Overrides Object..::..ToString()()()().)
Public method | ToXml | Serialize and return the current FindParam as a string. You can later use that string to create a FindParam using the .Load().

Extension Methods

 | Name | Description
Public Extension Method | ToExpression | Convert a FindParam legacy object to a HtmlFindExpression (Defined by FindParamExtension.)

Properties

Name Description
Public property Attributes
Gets/Sets the list of Attributes to use for identification.
Public property Constraints
Gets or sets a constraint for this FindParam
Public property ContentType
Gets/Sets the content type when the identification type is Content. (Default:TextContent)
Public property ContentValue
Gets/Sets the content value to find when type is Content. This can be a string to validate against or a regular expression. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar' Example 1: 'l:foo bar' Example 2: 'p:foo' Example 3: 'x:foo\s*bar'
Public property ExcludedAttributes
Gets/Sets the list of attribute to exclude for identification.
Public property Expression
The HtmlFindExpression used if Type=Expression.
Public property NodeIndexPath
Gets/Sets Hierarchal path from the reference element when Type=NodeIndexPath.
Public property PartialAttributes
Gets/Sets the partial attribute values to use for identification.
Public property SearchAttributes
List of (partial & exact) attributes to use for identification.
Public property TagIndex
Gets/Sets tagName occurrence index when Type=TagIndex
Public property TagName
Gets/Sets the tagName of the element this parameter identifies.
Public property Type
Gets/Sets the identification type to use to identify this element. (Default:TagIndex)
Public property XPath
Gets/Sets the XPath to use when Type=XPath.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes on this FindParam object.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Constructor
FindParam Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindParam()()()() | Create a new FindParam
Public method | FindParam(array<Int32>[]()[][]) | Create a new find parameter of Type=NodeIndexPath
Public method | FindParam(array<String>[]()[][]) | Create a new find parameter using name-value pairs of attributes.
Public method | FindParam(HtmlFindExpression) | Create a new find param of type.
Public method | FindParam(String, Int32) | Create a new find parameter of Type=TagIndex
Public method | FindParam(String, Int32, array<String>[]()[][]) | Create a new find parameter of Type=TagIndex with additional attributes to use to find the element or verify it.
Public method | FindParam(FindType, String, array<String>[]()[][]) | Create a new FindParam by explicitly specifying the FindType.

See Also

FindParam Class
FindParam Members
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Constructor
FindParam Class See Also Send Feedback
Create a new FindParam

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam()
Visual Basic
Public Sub New
Visual C++
public:
FindParam()

See Also

FindParam Class
FindParam Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Constructor (Int32[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Constructor (array<Int32>[]()[][])
FindParam Class See Also Send Feedback
Create a new find parameter of Type=NodeIndexPath

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam(
    params int[] nodesIndexPath
)
Visual Basic
Public Sub New ( _
    ParamArray nodesIndexPath As Integer() _
)
Visual C++
public:
FindParam(
    ... array<int>^ nodesIndexPath
)

Parameters

nodesIndexPath
Type: array< System..::..Int32 >[]()[][]
The index path of the desired node

See Also

FindParam Class
FindParam Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Constructor (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Constructor (array<String>[]()[][])
FindParam Class See Also Send Feedback
Create a new find parameter using name-value pairs of attributes.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam(
    params string[] attributesNameValuePairs
)
Visual Basic
Public Sub New ( _
    ParamArray attributesNameValuePairs As String() _
)
Visual C++
public:
FindParam(
    ... array<String^>^ attributesNameValuePairs
)

Parameters

attributesNameValuePairs
Type: array< System..::..String >[]()[][]
The name value pairs. Example ("id=foo","style=~color:red"). Use '=~' to indicate partial values.

See Also

FindParam Class
FindParam Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Constructor (HtmlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Constructor (HtmlFindExpression)
FindParam Class See Also Send Feedback
Create a new find param of type.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam(
    HtmlFindExpression expression
)
Visual Basic
Public Sub New ( _
    expression As HtmlFindExpression _
)
Visual C++
public:
FindParam(
    HtmlFindExpression^ expression
)

Parameters

expression
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression

[Missing <param name="expression"/> documentation for "M:ArtOfTest.WebAii.ObjectModel.FindParam.#ctor(ArtOfTest.WebAii.Core.HtmlFindExpression)"]

See Also

FindParam Class
FindParam Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Constructor (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Constructor (String, Int32)
FindParam Class See Also Send Feedback
Create a new find parameter of Type=TagIndex

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam(
    string tagName,
    int occurrenceIndex
)
Visual Basic
Public Sub New ( _
    tagName As String, _
    occurrenceIndex As Integer _
)
Visual C++
public:
FindParam(
    String^ tagName,
    int occurrenceIndex
)

Parameters

tagName
Type: System..::..String
The TagName to search for
occurrenceIndex
Type: System..::..Int32
The occurrence index of the target tag (zero-based).

See Also

FindParam Class
FindParam Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Constructor (String, Int32, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Constructor (String, Int32, array<String>[]()[][])
FindParam Class See Also Send Feedback
Create a new find parameter of Type=TagIndex with additional attributes to use to find the element or verify it.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam(
    string tagName,
    int occurrenceIndex,
    params string[] attributesNameValuePairs
)
Visual Basic
Public Sub New ( _
    tagName As String, _
    occurrenceIndex As Integer, _
    ParamArray attributesNameValuePairs As String() _
)
Visual C++
public:
FindParam(
    String^ tagName,
    int occurrenceIndex,
    ... array<String^>^ attributesNameValuePairs
)

Parameters

tagName
Type: System..::..String
The TagName to search for.
occurrenceIndex
Type: System..::..Int32
The occurrence index of the tag (Zero-Based).
attributesNameValuePairs
Type: array< System..::..String >[]()[][]
Any additional attributes to check for; both exact or partial

See Also

FindParam Class
FindParam Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Constructor (FindType, String, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Constructor (FindType, String, array<String>[]()[][])
FindParam Class See Also Send Feedback
Create a new FindParam by explicitly specifying the FindType.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam(
    FindType type,
    string value,
    params string[] attributesNameValuePairs
)
Visual Basic
Public Sub New ( _
    type As FindType, _
    value As String, _
    ParamArray attributesNameValuePairs As String() _
)
Visual C++
public:
FindParam(
    FindType type,
    String^ value,
    ... array<String^>^ attributesNameValuePairs
)

Parameters

type
Type: ArtOfTest.WebAii.ObjectModel..::..FindType
The find type.
value
Type: System..::..String
The value signifies the following depending on the type: Type=AttributesOnly:Value=(string.empty|tagName [When tagName is set, will match tagName in addition to attributes]),Type=NodeIndexPath:Value=(index path [i.e. "0/3/2/0"]), Type=XPath:Value=(xpath to use),Type=Content:Value=(content to use [i.e. "p:string"]) - default is FindContentType.TextContent, Type=TagIndex:Value(tagName:tagIndex [i.e. "input:3"])
attributesNameValuePairs
Type: array< System..::..String >[]()[][]
The attributes list, if any, else string.Empty.

See Also

FindParam Class
FindParam Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Methods
FindParam Class See Also Send Feedback

The FindParam type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadFromFile | Load a FindParam from a file.
 | LoadFromXml | Load a FindParam from an xml persisted string.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewExpr | Create a FindParam object from an expression.
Public method | Save | Serialized and saves the current FindParam to a file. You can later load that file using FindParam.Load().
Public method | SetAttributes | Used to initialize a list of parameter value pairs on a FindParam.
Public method | SetContent | Sets the content type and returns the updated FindParam.
Public method | SetTagName | Sets the tag name and returns the updated FindParam.
Public method | ToString | String representation of the FindParam. (Overrides Object..::..ToString()()()().)
Public method | ToXml | Serialize and return the current FindParam as a string. You can later use that string to create a FindParam using the .Load().

Extension Methods

 | Name | Description
Public Extension Method | ToExpression | Convert a FindParam legacy object to a HtmlFindExpression (Defined by FindParamExtension.)

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


LoadFromFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..LoadFromFile Method
FindParam Class See Also Send Feedback
Load a FindParam from a file.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FindParam LoadFromFile(
    string fileName
)
Visual Basic
Public Shared Function LoadFromFile ( _
    fileName As String _
) As FindParam
Visual C++
public:
static FindParam^ LoadFromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name to load the xml from.

Return Value

The FindParam object.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


LoadFromXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..LoadFromXml Method
FindParam Class See Also Send Feedback
Load a FindParam from an xml persisted string.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FindParam LoadFromXml(
    string findParamXml
)
Visual Basic
Public Shared Function LoadFromXml ( _
    findParamXml As String _
) As FindParam
Visual C++
public:
static FindParam^ LoadFromXml(
    String^ findParamXml
)

Parameters

findParamXml
Type: System..::..String
The string.

Return Value

The FindParam object.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


NewExpr Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..NewExpr Method
FindParam Class See Also Send Feedback
Create a FindParam object from an expression.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FindParam NewExpr(
    params string[] expression
)
Visual Basic
Public Shared Function NewExpr ( _
    ParamArray expression As String() _
) As FindParam
Visual C++
public:
static FindParam^ NewExpr(
    ... array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]
The expression to use.

Return Value

The FindParam as an expression.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


Save Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..Save Method
FindParam Class See Also Send Feedback
Serialized and saves the current FindParam to a file. You can later load that file using FindParam.Load().

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Save(
    string fileName
)
Visual Basic
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name to save to.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


SetAttributes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..SetAttributes Method
FindParam Class See Also Send Feedback
Used to initialize a list of parameter value pairs on a FindParam.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam SetAttributes(
    params string[] nameValuePairs
)
Visual Basic
Public Function SetAttributes ( _
    ParamArray nameValuePairs As String() _
) As FindParam
Visual C++
public:
FindParam^ SetAttributes(
    ... array<String^>^ nameValuePairs
)

Parameters

nameValuePairs
Type: array< System..::..String >[]()[][]
The name value pairs.

Return Value

The modified FindParam

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


SetContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..SetContent Method
FindParam Class See Also Send Feedback
Sets the content type and returns the updated FindParam.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam SetContent(
    FindContentType contentType,
    string contentValue
)
Visual Basic
Public Function SetContent ( _
    contentType As FindContentType, _
    contentValue As String _
) As FindParam
Visual C++
public:
FindParam^ SetContent(
    FindContentType contentType,
    String^ contentValue
)

Parameters

contentType
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type.
contentValue
Type: System..::..String
The content.

Return Value

The modified FindParam

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


SetTagName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..SetTagName Method
FindParam Class See Also Send Feedback
Sets the tag name and returns the updated FindParam.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam SetTagName(
    string tagName
)
Visual Basic
Public Function SetTagName ( _
    tagName As String _
) As FindParam
Visual C++
public:
FindParam^ SetTagName(
    String^ tagName
)

Parameters

tagName
Type: System..::..String
The set tagName

Return Value

The modified FindParam

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..ToString Method
FindParam Class See Also Send Feedback
String representation of the FindParam.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


ToXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..ToXml Method
FindParam Class See Also Send Feedback
Serialize and return the current FindParam as a string. You can later use that string to create a FindParam using the .Load().

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ToXml()
Visual Basic
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

The serialized Xml that represents this object.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Properties
FindParam Class See Also Send Feedback

The FindParam type exposes the following members.

Properties

Name Description
Public property Attributes
Gets/Sets the list of Attributes to use for identification.
Public property Constraints
Gets or sets a constraint for this FindParam
Public property ContentType
Gets/Sets the content type when the identification type is Content. (Default:TextContent)
Public property ContentValue
Gets/Sets the content value to find when type is Content. This can be a string to validate against or a regular expression. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar' Example 1: 'l:foo bar' Example 2: 'p:foo' Example 3: 'x:foo\s*bar'
Public property ExcludedAttributes
Gets/Sets the list of attribute to exclude for identification.
Public property Expression
The HtmlFindExpression used if Type=Expression.
Public property NodeIndexPath
Gets/Sets Hierarchal path from the reference element when Type=NodeIndexPath.
Public property PartialAttributes
Gets/Sets the partial attribute values to use for identification.
Public property SearchAttributes
List of (partial & exact) attributes to use for identification.
Public property TagIndex
Gets/Sets tagName occurrence index when Type=TagIndex
Public property TagName
Gets/Sets the tagName of the element this parameter identifies.
Public property Type
Gets/Sets the identification type to use to identify this element. (Default:TagIndex)
Public property XPath
Gets/Sets the XPath to use when Type=XPath.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


Attributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..Attributes Property
FindParam Class See Also Send Feedback
Gets/Sets the list of Attributes to use for identification.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Collection<iAttribute> Attributes { get; set; }
Visual Basic
Public Property Attributes As Collection(Of iAttribute)
    Get
    Set
Visual C++
public:
property Collection<iAttribute^>^ Attributes {
    Collection<iAttribute^>^ get ();
    void set (Collection<iAttribute^>^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


Constraints Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..Constraints Property
FindParam Class See Also Send Feedback
Gets or sets a constraint for this FindParam

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParamConstraint[] Constraints { get; set; }
Visual Basic
Public Property Constraints As FindParamConstraint()
    Get
    Set
Visual C++
public:
property array<FindParamConstraint^>^ Constraints {
    array<FindParamConstraint^>^ get ();
    void set (array<FindParamConstraint^>^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


ContentType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..ContentType Property
FindParam Class See Also Send Feedback
Gets/Sets the content type when the identification type is Content. (Default:TextContent)

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindContentType ContentType { get; set; }
Visual Basic
Public Property ContentType As FindContentType
    Get
    Set
Visual C++
public:
property FindContentType ContentType {
    FindContentType get ();
    void set (FindContentType value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


ContentValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..ContentValue Property
FindParam Class See Also Send Feedback
Gets/Sets the content value to find when type is Content. This can be a string to validate against or a regular expression. The content must start with: 'l:' for exact match strings, 'p:' for partial strings or 'x:' for regular expression matches. If none are provided the string will be matched using an exact match 'l:'. All searches are case-insensitive.

Examples

To find tags with innerText content is: 'foo bar' Example 1: 'l:foo bar' Example 2: 'p:foo' Example 3: 'x:foo\s*bar'

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ContentValue { get; set; }
Visual Basic
Public Property ContentValue As String
    Get
    Set
Visual C++
public:
property String^ ContentValue {
    String^ get ();
    void set (String^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


ExcludedAttributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..ExcludedAttributes Property
FindParam Class See Also Send Feedback
Gets/Sets the list of attribute to exclude for identification.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Collection<iAttribute> ExcludedAttributes { get; set; }
Visual Basic
Public Property ExcludedAttributes As Collection(Of iAttribute)
    Get
    Set
Visual C++
public:
property Collection<iAttribute^>^ ExcludedAttributes {
    Collection<iAttribute^>^ get ();
    void set (Collection<iAttribute^>^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


Expression Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..Expression Property
FindParam Class See Also Send Feedback
The HtmlFindExpression used if Type=Expression.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlFindExpression Expression { get; set; }
Visual Basic
Public Property Expression As HtmlFindExpression
    Get
    Set
Visual C++
public:
property HtmlFindExpression^ Expression {
    HtmlFindExpression^ get ();
    void set (HtmlFindExpression^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


NodeIndexPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..NodeIndexPath Property
FindParam Class See Also Send Feedback
Gets/Sets Hierarchal path from the reference element when Type=NodeIndexPath.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string NodeIndexPath { get; set; }
Visual Basic
Public Property NodeIndexPath As String
    Get
    Set
Visual C++
public:
property String^ NodeIndexPath {
    String^ get ();
    void set (String^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


PartialAttributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..PartialAttributes Property
FindParam Class See Also Send Feedback
Gets/Sets the partial attribute values to use for identification.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Collection<iAttribute> PartialAttributes { get; set; }
Visual Basic
Public Property PartialAttributes As Collection(Of iAttribute)
    Get
    Set
Visual C++
public:
property Collection<iAttribute^>^ PartialAttributes {
    Collection<iAttribute^>^ get ();
    void set (Collection<iAttribute^>^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


SearchAttributes Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..SearchAttributes Property
FindParam Class See Also Send Feedback
List of (partial & exact) attributes to use for identification.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SearchAttributes { get; }
Visual Basic
Public ReadOnly Property SearchAttributes As String
    Get
Visual C++
public:
property String^ SearchAttributes {
    String^ get ();
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


TagIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..TagIndex Property
FindParam Class See Also Send Feedback
Gets/Sets tagName occurrence index when Type=TagIndex

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TagIndex { get; set; }
Visual Basic
Public Property TagIndex As Integer
    Get
    Set
Visual C++
public:
property int TagIndex {
    int get ();
    void set (int value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


TagName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..TagName Property
FindParam Class See Also Send Feedback
Gets/Sets the tagName of the element this parameter identifies.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TagName { get; set; }
Visual Basic
Public Property TagName As String
    Get
    Set
Visual C++
public:
property String^ TagName {
    String^ get ();
    void set (String^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..Type Property
FindParam Class See Also Send Feedback
Gets/Sets the identification type to use to identify this element. (Default:TagIndex)

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindType Type { get; set; }
Visual Basic
Public Property Type As FindType
    Get
    Set
Visual C++
public:
property FindType Type {
    FindType get ();
    void set (FindType value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


XPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..XPath Property
FindParam Class See Also Send Feedback
Gets/Sets the XPath to use when Type=XPath.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string XPath { get; set; }
Visual Basic
Public Property XPath As String
    Get
    Set
Visual C++
public:
property String^ XPath {
    String^ get ();
    void set (String^ value);
}

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParam Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam Events
FindParam Class See Also Send Feedback

The FindParam type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes on this FindParam object.

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


PropertyChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParam..::..PropertyChanged Event
FindParam Class See Also Send Feedback
Occurs when a property changes on this FindParam object.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

FindParam Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection Members
FindParamCollection Class Constructors Methods Properties Events See Also Send Feedback

The FindParamCollection type exposes the following members.

Constructors

 | Name | Description
Public method | FindParamCollection()()()() | Create a new FindParam collection that also be serialized.
Public method | FindParamCollection(SerializationInfo, StreamingContext) | Create new FindParamCollection. Serialization Constructor

Methods

Name Description
Public method Add
Add a new FindParam item.
Public method Clear
Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method ContainsKey
Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method ContainsValue
Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetObjectData
Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method GetSchema
Return the schema used for serialization.

Remarks

Currently we are returning null
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
LoadFromFile
Load a FindParamCollection from a file.
LoadFromXml
Load a FindParamCollection from an xml persisted string.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method OnDeserialization
Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method OnItemAdded
Trigger the ItemAdded event.
Public method ReadXml
Deserialized from the xmlReader and initialize the object
Public method Remove
Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method Save
Serialized and saves the current collection to a file. You can later load that file using FindParamCollection.Load().
Public method ToArray
Get an array of FindParam objects contained in this collection.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method ToXml
Serialize and return the current FindParamCollection as a string. You can later use that string to create a FindParamCollection using the .Load().
Public method TryGetValue
Gets the value associated with the specified key.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method WriteXml
Serialize this object to the XmlWriter

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public property | Item | Access a FindParam using its key.
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public property | ReturnNullIfNotFound | Gets/Sets whether to throw or return null if a FindParam is not found.
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)

Events

 | Name | Description
Public event | ItemAdded | Occurs when a new items is added to this collection.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamCollection Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection Constructor
FindParamCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindParamCollection()()()() | Create a new FindParam collection that also be serialized.
Public method | FindParamCollection(SerializationInfo, StreamingContext) | Create new FindParamCollection. Serialization Constructor

See Also

FindParamCollection Class
FindParamCollection Members
ArtOfTest.WebAii.ObjectModel Namespace


FindParamCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection Constructor
FindParamCollection Class See Also Send Feedback
Create a new FindParam collection that also be serialized.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParamCollection()
Visual Basic
Public Sub New
Visual C++
public:
FindParamCollection()

See Also

FindParamCollection Class
FindParamCollection Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParamCollection Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection Constructor (SerializationInfo, StreamingContext)
FindParamCollection Class See Also Send Feedback
Create new FindParamCollection. Serialization Constructor

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParamCollection(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
FindParamCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Serialization info
context
Type: System.Runtime.Serialization..::..StreamingContext
Serialization context

See Also

FindParamCollection Class
FindParamCollection Overload
ArtOfTest.WebAii.ObjectModel Namespace


FindParamCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection Methods
FindParamCollection Class See Also Send Feedback

The FindParamCollection type exposes the following members.

Methods

Name Description
Public method Add
Add a new FindParam item.
Public method Clear
Removes all keys and values from the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method ContainsKey
Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains the specified key.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method ContainsValue
Determines whether the Dictionary<(Of <(<'TKey, TValue>)>)> contains a specific value.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetEnumerator
Returns an enumerator that iterates through the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetObjectData
Implements the ISerializable interface and returns the data needed to serialize the Dictionary<(Of <(<'TKey, TValue>)>)> instance.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method GetSchema
Return the schema used for serialization.

Remarks

Currently we are returning null
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
LoadFromFile
Load a FindParamCollection from a file.
LoadFromXml
Load a FindParamCollection from an xml persisted string.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method OnDeserialization
Implements the ISerializable interface and raises the deserialization event when the deserialization is complete.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method OnItemAdded
Trigger the ItemAdded event.
Public method ReadXml
Deserialized from the xmlReader and initialize the object
Public method Remove
Removes the value with the specified key from the Dictionary<(Of <(<'TKey, TValue>)>)>.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method Save
Serialized and saves the current collection to a file. You can later load that file using FindParamCollection.Load().
Public method ToArray
Get an array of FindParam objects contained in this collection.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)
Public method ToXml
Serialize and return the current FindParamCollection as a string. You can later use that string to create a FindParamCollection using the .Load().
Public method TryGetValue
Gets the value associated with the specified key.
(Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public method WriteXml
Serialize this object to the XmlWriter

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


Add Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..Add Method
FindParamCollection Class See Also Send Feedback
Add a new FindParam item.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Add(
    string key,
    FindParam param
)
Visual Basic
Public Sub Add ( _
    key As String, _
    param As FindParam _
)
Visual C++
public:
void Add(
    String^ key,
    FindParam^ param
)

Parameters

key
Type: System..::..String
The key.
param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam object.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


GetSchema Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..GetSchema Method
FindParamCollection Class See Also Send Feedback
Return the schema used for serialization.

Remarks

Currently we are returning null

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XmlSchema GetSchema()
Visual Basic
Public Function GetSchema As XmlSchema
Visual C++
public:
virtual XmlSchema^ GetSchema() sealed

Return Value

The schema

Implements

IXmlSerializable..::..GetSchema()()()()

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


LoadFromFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..LoadFromFile Method
FindParamCollection Class See Also Send Feedback
Load a FindParamCollection from a file.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FindParamCollection LoadFromFile(
    string fileName
)
Visual Basic
Public Shared Function LoadFromFile ( _
    fileName As String _
) As FindParamCollection
Visual C++
public:
static FindParamCollection^ LoadFromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name to load the xml from.

Return Value

The FindParamCollection object.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


LoadFromXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..LoadFromXml Method
FindParamCollection Class See Also Send Feedback
Load a FindParamCollection from an xml persisted string.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static FindParamCollection LoadFromXml(
    string xml
)
Visual Basic
Public Shared Function LoadFromXml ( _
    xml As String _
) As FindParamCollection
Visual C++
public:
static FindParamCollection^ LoadFromXml(
    String^ xml
)

Parameters

xml
Type: System..::..String
The string string.

Return Value

The FindParamCollection object.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


OnItemAdded Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..OnItemAdded Method
FindParamCollection Class See Also Send Feedback
Trigger the ItemAdded event.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void OnItemAdded(
    FindParamCollectionItemAddedEventArgs item
)
Visual Basic
Public Sub OnItemAdded ( _
    item As FindParamCollectionItemAddedEventArgs _
)
Visual C++
public:
void OnItemAdded(
    FindParamCollectionItemAddedEventArgs^ item
)

Parameters

item
Type: ArtOfTest.WebAii.EventsArgs..::..FindParamCollectionItemAddedEventArgs
The event argument.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


ReadXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..ReadXml Method
FindParamCollection Class See Also Send Feedback
Deserialized from the xmlReader and initialize the object

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ReadXml(
    XmlReader reader
)
Visual Basic
Public Sub ReadXml ( _
    reader As XmlReader _
)
Visual C++
public:
virtual void ReadXml(
    XmlReader^ reader
) sealed

Parameters

reader
Type: System.Xml..::..XmlReader
The reader.

Implements

IXmlSerializable..::..ReadXml(XmlReader)

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


Save Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..Save Method
FindParamCollection Class See Also Send Feedback
Serialized and saves the current collection to a file. You can later load that file using FindParamCollection.Load().

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Save(
    string fileName
)
Visual Basic
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name to save to.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


ToArray Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..ToArray Method
FindParamCollection Class See Also Send Feedback
Get an array of FindParam objects contained in this collection.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam[] ToArray()
Visual Basic
Public Function ToArray As FindParam()
Visual C++
public:
array<FindParam^>^ ToArray()

Return Value

The array.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


ToXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..ToXml Method
FindParamCollection Class See Also Send Feedback
Serialize and return the current FindParamCollection as a string. You can later use that string to create a FindParamCollection using the .Load().

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ToXml()
Visual Basic
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

The serialized Xml that represents this object.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


WriteXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..WriteXml Method
FindParamCollection Class See Also Send Feedback
Serialize this object to the XmlWriter

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WriteXml(
    XmlWriter writer
)
Visual Basic
Public Sub WriteXml ( _
    writer As XmlWriter _
)
Visual C++
public:
virtual void WriteXml(
    XmlWriter^ writer
) sealed

Parameters

writer
Type: System.Xml..::..XmlWriter
The writer.

Implements

IXmlSerializable..::..WriteXml(XmlWriter)

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection Properties
FindParamCollection Class See Also Send Feedback

The FindParamCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the IEqualityComparer<(Of <(<'T>)>)> that is used to determine equality of keys for the dictionary. (Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public property | Count | Gets the number of key/value pairs contained in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public property | Item | Access a FindParam using its key.
Public property | Keys | Gets a collection containing the keys in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)
Public property | ReturnNullIfNotFound | Gets/Sets whether to throw or return null if a FindParam is not found.
Public property | Values | Gets a collection containing the values in the Dictionary<(Of <(<'TKey, TValue>)>)>. (Inherited from Dictionary <(Of <(<' String, FindParam >)>)>.)

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..Item Property
FindParamCollection Class See Also Send Feedback
Access a FindParam using its key.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam this[
    string key
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    key As String _
) As FindParam
    Get
Visual C++
public:
property FindParam^ default[String^ key] {
    FindParam^ get (String^ key);
}

Parameters

key
Type: System..::..String
The key.

Return Value

The FindParam object.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


ReturnNullIfNotFound Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..ReturnNullIfNotFound Property
FindParamCollection Class See Also Send Feedback
Gets/Sets whether to throw or return null if a FindParam is not found.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ReturnNullIfNotFound { get; set; }
Visual Basic
Public Property ReturnNullIfNotFound As Boolean
    Get
    Set
Visual C++
public:
property bool ReturnNullIfNotFound {
    bool get ();
    void set (bool value);
}

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamCollection Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection Events
FindParamCollection Class See Also Send Feedback

The FindParamCollection type exposes the following members.

Events

 | Name | Description
Public event | ItemAdded | Occurs when a new items is added to this collection.

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


ItemAdded Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamCollection..::..ItemAdded Event
FindParamCollection Class See Also Send Feedback
Occurs when a new items is added to this collection.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<FindParamCollectionItemAddedEventArgs> ItemAdded
Visual Basic
Public Event ItemAdded As EventHandler(Of FindParamCollectionItemAddedEventArgs)
Visual C++
public:
 event EventHandler<FindParamCollectionItemAddedEventArgs^>^ ItemAdded {
    void add (EventHandler<FindParamCollectionItemAddedEventArgs^>^ value);
    void remove (EventHandler<FindParamCollectionItemAddedEventArgs^>^ value);
}

See Also

FindParamCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamConstraint Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamConstraint Members
FindParamConstraint Class Constructors Methods Properties See Also Send Feedback

The FindParamConstraint type exposes the following members.

Constructors

 | Name | Description
Public method | FindParamConstraint | Create a FindParam contraint

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Gets the contraint definition
Public property | Level | Gets the level constraint. Negative level indicates parent hierarchy. (i.e. -1 first parent). Positive level indicates child hierarchy. (i.e. 1 first child).

See Also

FindParamConstraint Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamConstraint Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamConstraint Constructor
FindParamConstraint Class See Also Send Feedback
Create a FindParam contraint

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParamConstraint(
    int level,
    FindParam constraint
)
Visual Basic
Public Sub New ( _
    level As Integer, _
    constraint As FindParam _
)
Visual C++
public:
FindParamConstraint(
    int level,
    FindParam^ constraint
)

Parameters

level
Type: System..::..Int32
The level of the contraint (negative:parent,positive:children)
constraint
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The constraint definition

See Also

FindParamConstraint Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamConstraint Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamConstraint Methods
FindParamConstraint Class See Also Send Feedback

The FindParamConstraint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindParamConstraint Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamConstraint Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamConstraint Properties
FindParamConstraint Class See Also Send Feedback

The FindParamConstraint type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Gets the contraint definition
Public property | Level | Gets the level constraint. Negative level indicates parent hierarchy. (i.e. -1 first parent). Positive level indicates child hierarchy. (i.e. 1 first child).

See Also

FindParamConstraint Class
ArtOfTest.WebAii.ObjectModel Namespace


Definition Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamConstraint..::..Definition Property
FindParamConstraint Class See Also Send Feedback
Gets the contraint definition

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParam Definition { get; }
Visual Basic
Public ReadOnly Property Definition As FindParam
    Get
Visual C++
public:
property FindParam^ Definition {
    FindParam^ get ();
}

See Also

FindParamConstraint Class
ArtOfTest.WebAii.ObjectModel Namespace


Level Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamConstraint..::..Level Property
FindParamConstraint Class See Also Send Feedback
Gets the level constraint. Negative level indicates parent hierarchy. (i.e. -1 first parent). Positive level indicates child hierarchy. (i.e. 1 first child).

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Level { get; }
Visual Basic
Public ReadOnly Property Level As Integer
    Get
Visual C++
public:
property int Level {
    int get ();
}

See Also

FindParamConstraint Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamExtension Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamExtension Members
FindParamExtension Class Methods See Also Send Feedback

The FindParamExtension type exposes the following members.

Methods

Name | Description
ToExpression | Convert a FindParam legacy object to a HtmlFindExpression

See Also

FindParamExtension Class
ArtOfTest.WebAii.ObjectModel Namespace


FindParamExtension Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamExtension Methods
FindParamExtension Class See Also Send Feedback

The FindParamExtension type exposes the following members.

Methods

Name | Description
ToExpression | Convert a FindParam legacy object to a HtmlFindExpression

See Also

FindParamExtension Class
ArtOfTest.WebAii.ObjectModel Namespace


ToExpression Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamExtension..::..ToExpression Method
FindParamExtension Class See Also Send Feedback
Convert a FindParam legacy object to a HtmlFindExpression

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static HtmlFindExpression ToExpression(
    this FindParam param
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function ToExpression ( _
    param As FindParam _
) As HtmlFindExpression
Visual C++
[ExtensionAttribute]
public:
static HtmlFindExpression^ ToExpression(
    FindParam^ param
)

Parameters

param
Type: ArtOfTest.WebAii.ObjectModel..::..FindParam
The FindParam to convert.

Return Value

The converted HtmlFindExpression.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type FindParam. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

FindParamExtension Class
ArtOfTest.WebAii.ObjectModel Namespace


HtmlTreeBuilder Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder Members
HtmlTreeBuilder Class Constructors Methods Properties See Also Send Feedback

The HtmlTreeBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlTreeBuilder()()()() | Initializes a new instance of the HtmlTreeBuilder class
Public method | HtmlTreeBuilder(IAutomationHost) | Initializes a new instance of the HtmlTreeBuilder class

Methods

 | Name | Description
Public method | BuildDomTree | Parse and build the Dom. This method will initialize the Root property with the root element of the Dom. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Protected method | ClearTree | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..ClearTree()()()().)
Public method | CreateNewElement | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..CreateNewElement(ParsedElement, IAutomationHost).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | StartTagCloses | Determines whether to close an open tag with an optional closing tag based on the new tag we're parsing (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..StartTagCloses(String, String).)
Public method | TestRegionDetected | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..TestRegionDetected(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackRecursiveContainer | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..TrackRecursiveContainer(T).)

Properties

 | Name | Description
Public property | DocType | Gets the DOCTYPE element if present in the document. Otherwise null. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Protected property | RecursiveContainerTags | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..RecursiveContainerTags.)
Public property | Root | Gets the root Element node. You can access the tree using this node. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Public property | TestRegions |

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


HtmlTreeBuilder Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder Constructor
HtmlTreeBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlTreeBuilder()()()() | Initializes a new instance of the HtmlTreeBuilder class
Public method | HtmlTreeBuilder(IAutomationHost) | Initializes a new instance of the HtmlTreeBuilder class

See Also

HtmlTreeBuilder Class
HtmlTreeBuilder Members
ArtOfTest.WebAii.ObjectModel Namespace


HtmlTreeBuilder Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder Constructor
HtmlTreeBuilder Class See Also Send Feedback
Initializes a new instance of the HtmlTreeBuilder class

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTreeBuilder()
Visual Basic
Public Sub New
Visual C++
public:
HtmlTreeBuilder()

See Also

HtmlTreeBuilder Class
HtmlTreeBuilder Overload
ArtOfTest.WebAii.ObjectModel Namespace


HtmlTreeBuilder Constructor (IAutomationHost)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder Constructor (IAutomationHost)
HtmlTreeBuilder Class See Also Send Feedback
Initializes a new instance of the HtmlTreeBuilder class

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlTreeBuilder(
    IAutomationHost browser
)
Visual Basic
Public Sub New ( _
    browser As IAutomationHost _
)
Visual C++
public:
HtmlTreeBuilder(
    IAutomationHost^ browser
)

Parameters

browser
Type: ArtOfTest.Common..::..IAutomationHost

[Missing <param name="browser"/> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.#ctor(ArtOfTest.Common.IAutomationHost)"]

See Also

HtmlTreeBuilder Class
HtmlTreeBuilder Overload
ArtOfTest.WebAii.ObjectModel Namespace


HtmlTreeBuilder Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder Methods
HtmlTreeBuilder Class See Also Send Feedback

The HtmlTreeBuilder type exposes the following members.

Methods

 | Name | Description
Public method | BuildDomTree | Parse and build the Dom. This method will initialize the Root property with the root element of the Dom. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Protected method | ClearTree | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..ClearTree()()()().)
Public method | CreateNewElement | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..CreateNewElement(ParsedElement, IAutomationHost).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | StartTagCloses | Determines whether to close an open tag with an optional closing tag based on the new tag we're parsing (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..StartTagCloses(String, String).)
Public method | TestRegionDetected | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..TestRegionDetected(T).)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Protected method | TrackRecursiveContainer | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..TrackRecursiveContainer(T).)

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


ClearTree Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder..::..ClearTree Method
HtmlTreeBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.ClearTree"]

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override void ClearTree()
Visual Basic
Protected Overrides Sub ClearTree
Visual C++
protected:
virtual void ClearTree() override

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


CreateNewElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder..::..CreateNewElement Method
HtmlTreeBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.CreateNewElement(ArtOfTest.Common.ParsedElement,ArtOfTest.Common.IAutomationHost)"]

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Element CreateNewElement(
    ParsedElement parsedElement,
    IAutomationHost host
)
Visual Basic
Public Overrides Function CreateNewElement ( _
    parsedElement As ParsedElement, _
    host As IAutomationHost _
) As Element
Visual C++
public:
virtual Element^ CreateNewElement(
    ParsedElement^ parsedElement,
    IAutomationHost^ host
) override

Parameters

parsedElement
Type: ArtOfTest.Common..::..ParsedElement

[Missing <param name="parsedElement"/> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.CreateNewElement(ArtOfTest.Common.ParsedElement,ArtOfTest.Common.IAutomationHost)"]

host
Type: ArtOfTest.Common..::..IAutomationHost

[Missing <param name="host"/> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.CreateNewElement(ArtOfTest.Common.ParsedElement,ArtOfTest.Common.IAutomationHost)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.CreateNewElement(ArtOfTest.Common.ParsedElement,ArtOfTest.Common.IAutomationHost)"]

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


StartTagCloses Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder..::..StartTagCloses Method
HtmlTreeBuilder Class See Also Send Feedback
Determines whether to close an open tag with an optional closing tag based on the new tag we're parsing

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override bool StartTagCloses(
    string startTag,
    string stackTag
)
Visual Basic
Protected Overrides Function StartTagCloses ( _
    startTag As String, _
    stackTag As String _
) As Boolean
Visual C++
protected:
virtual bool StartTagCloses(
    String^ startTag,
    String^ stackTag
) override

Parameters

startTag
Type: System..::..String
The start tag we've just started parsing
stackTag
Type: System..::..String
The optional-closing tag on top of the stack

Return Value

True/False whether or not this startTag automatically closes the the currently open tag.

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


TestRegionDetected Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder..::..TestRegionDetected Method
HtmlTreeBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.TestRegionDetected(ArtOfTest.WebAii.ObjectModel.Element)"]

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void TestRegionDetected(
    Element regionElement
)
Visual Basic
Public Overrides Sub TestRegionDetected ( _
    regionElement As Element _
)
Visual C++
public:
virtual void TestRegionDetected(
    Element^ regionElement
) override

Parameters

regionElement
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="regionElement"/> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.TestRegionDetected(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


TrackRecursiveContainer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder..::..TrackRecursiveContainer Method
HtmlTreeBuilder Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.TrackRecursiveContainer(ArtOfTest.WebAii.ObjectModel.Element)"]

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override void TrackRecursiveContainer(
    Element element
)
Visual Basic
Protected Overrides Sub TrackRecursiveContainer ( _
    element As Element _
)
Visual C++
protected:
virtual void TrackRecursiveContainer(
    Element^ element
) override

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.TrackRecursiveContainer(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


HtmlTreeBuilder Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder Properties
HtmlTreeBuilder Class See Also Send Feedback

The HtmlTreeBuilder type exposes the following members.

Properties

 | Name | Description
Public property | DocType | Gets the DOCTYPE element if present in the document. Otherwise null. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Protected property | RecursiveContainerTags | (Overrides BaseTreeBuilder<(Of <(<'T>)>)>..::..RecursiveContainerTags.)
Public property | Root | Gets the root Element node. You can access the tree using this node. (Inherited from BaseTreeBuilder<(Of <(<'T>)>)>.)
Public property | TestRegions |

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


RecursiveContainerTags Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder..::..RecursiveContainerTags Property
HtmlTreeBuilder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.RecursiveContainerTags"]

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override IEnumerable<string> RecursiveContainerTags { get; }
Visual Basic
Protected Overrides ReadOnly Property RecursiveContainerTags As IEnumerable(Of String)
    Get
Visual C++
protected:
virtual property IEnumerable<String^>^ RecursiveContainerTags {
    IEnumerable<String^>^ get () override;
}

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


TestRegions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlTreeBuilder..::..TestRegions Property
HtmlTreeBuilder Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.ObjectModel.HtmlTreeBuilder.TestRegions"]

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestRegionCollection TestRegions { get; }
Visual Basic
Public ReadOnly Property TestRegions As TestRegionCollection
    Get
Visual C++
public:
property TestRegionCollection^ TestRegions {
    TestRegionCollection^ get ();
}

See Also

HtmlTreeBuilder Class
ArtOfTest.WebAii.ObjectModel Namespace


iAttribute Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute Members
iAttribute Class Constructors Methods Properties Events See Also Send Feedback

The iAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | iAttribute()()()() | Create a new attribute.
Public method | iAttribute(String, String) | Create a new attribute.

Methods

Name Description
Public method ContainsPartialAttributeValue
Determines whether a partial attribute value is contained in this attribute value Also makes sure the attribute name is correct.
Public method Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Equals(iAttribute, StringComparison, Boolean)
Determines equality between two attributes
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetAttributeList
Quick shortcut to get a list of attributes. Pass in the name/value pairs as a semi-colon delimited list.

Examples

For example: GetAttributeList("id=foo","checked=true") Note: Any string that don't contain a pair will be ignored. Don't include an type of quotes.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
A string representation of the attribute.
(Overrides Object..::..ToString()()()().)

Properties

Name Description
Public property AttributeType
Gets the attribute type (i.e. Style/Event/Other).
Public property BeginQuote
Gets/Sets the begin quote type of the attribute.
Public property DecodedValue
The value of the attribute after converting any HTML entities to normal characters e.g. &amp; -> &
Public property EndQuote
Gets/Sets the end quote type of the attribute
Public property IsSingular
Gets/Sets whether the attribute is singluar.

Examples

CopyC#
The nowrap attribute is a singluar attribute in  <foo id="myfoo" nowrap /> .
Public property Name
Gets/Sets the name of this attribute.
Public property RawValue
The raw value of the attribute including any quotes.
Public property Styles
The Styles collection if AttributeType = Style.

Examples

The following element <foo style="height:1px;width:2px;" /> , will contain a NameValueCollection that consists of two items: The first : name=height,value=1px The second : name=width,value=2px
Public property Value
Gets/Sets the value of this attribute.

Remarks

The value will be trimmed from any beginning or ending quotes. If you need the raw value use the RawValue property.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes on this iAttribute object.

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


iAttribute Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute Constructor
iAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | iAttribute()()()() | Create a new attribute.
Public method | iAttribute(String, String) | Create a new attribute.

See Also

iAttribute Class
iAttribute Members
ArtOfTest.WebAii.ObjectModel Namespace


iAttribute Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute Constructor
iAttribute Class See Also Send Feedback
Create a new attribute.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public iAttribute()
Visual Basic
Public Sub New
Visual C++
public:
iAttribute()

See Also

iAttribute Class
iAttribute Overload
ArtOfTest.WebAii.ObjectModel Namespace


iAttribute Constructor (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute Constructor (String, String)
iAttribute Class See Also Send Feedback
Create a new attribute.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public iAttribute(
    string name,
    string value
)
Visual Basic
Public Sub New ( _
    name As String, _
    value As String _
)
Visual C++
public:
iAttribute(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
Name of the attribute.
value
Type: System..::..String
Value of the attribute.

See Also

iAttribute Class
iAttribute Overload
ArtOfTest.WebAii.ObjectModel Namespace


iAttribute Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute Methods
iAttribute Class See Also Send Feedback

The iAttribute type exposes the following members.

Methods

Name Description
Public method ContainsPartialAttributeValue
Determines whether a partial attribute value is contained in this attribute value Also makes sure the attribute name is correct.
Public method Equals(Object)
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public method Equals(iAttribute, StringComparison, Boolean)
Determines equality between two attributes
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetAttributeList
Quick shortcut to get a list of attributes. Pass in the name/value pairs as a semi-colon delimited list.

Examples

For example: GetAttributeList("id=foo","checked=true") Note: Any string that don't contain a pair will be ignored. Don't include an type of quotes.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method ToString
A string representation of the attribute.
(Overrides Object..::..ToString()()()().)

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


ContainsPartialAttributeValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..ContainsPartialAttributeValue Method
iAttribute Class See Also Send Feedback
Determines whether a partial attribute value is contained in this attribute value Also makes sure the attribute name is correct.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ContainsPartialAttributeValue(
    iAttribute partialAttributeToCompare,
    StringComparison comparison
)
Visual Basic
Public Function ContainsPartialAttributeValue ( _
    partialAttributeToCompare As iAttribute, _
    comparison As StringComparison _
) As Boolean
Visual C++
public:
bool ContainsPartialAttributeValue(
    iAttribute^ partialAttributeToCompare,
    StringComparison comparison
)

Parameters

partialAttributeToCompare
Type: ArtOfTest.WebAii.ObjectModel..::..iAttribute
The partial attribute to compare.
comparison
Type: System..::..StringComparison
Type of comparison to perform.

Return Value

True/False whether this attribute contains the parital attribute value passed in.

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


Equals Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..Equals Method
iAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(iAttribute, StringComparison, Boolean) | Determines equality between two attributes

See Also

iAttribute Class
iAttribute Members
ArtOfTest.WebAii.ObjectModel Namespace


Equals Method (iAttribute, StringComparison, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..Equals Method (iAttribute, StringComparison, Boolean)
iAttribute Class See Also Send Feedback
Determines equality between two attributes

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Equals(
    iAttribute obj,
    StringComparison comparison,
    bool matchQuotes
)
Visual Basic
Public Function Equals ( _
    obj As iAttribute, _
    comparison As StringComparison, _
    matchQuotes As Boolean _
) As Boolean
Visual C++
public:
bool Equals(
    iAttribute^ obj,
    StringComparison comparison,
    bool matchQuotes
)

Parameters

obj
Type: ArtOfTest.WebAii.ObjectModel..::..iAttribute
The object to compare.
comparison
Type: System..::..StringComparison
The type of comparsion to perform.
matchQuotes
Type: System..::..Boolean
Whether to match the begin/end quotes or just the value.

Return Value

True/False whether they are the same.

See Also

iAttribute Class
Equals Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetAttributeList Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..GetAttributeList Method
iAttribute Class See Also Send Feedback
Quick shortcut to get a list of attributes. Pass in the name/value pairs as a semi-colon delimited list.

Examples

For example: GetAttributeList("id=foo","checked=true") Note: Any string that don't contain a pair will be ignored. Don't include an type of quotes.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Collection<iAttribute> GetAttributeList(
    params string[] nameValuePairs
)
Visual Basic
Public Shared Function GetAttributeList ( _
    ParamArray nameValuePairs As String() _
) As Collection(Of iAttribute)
Visual C++
public:
static Collection<iAttribute^>^ GetAttributeList(
    ... array<String^>^ nameValuePairs
)

Parameters

nameValuePairs
Type: array< System..::..String >[]()[][]
The name value pairs.

Return Value

The list of attributes.

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..ToString Method
iAttribute Class See Also Send Feedback
A string representation of the attribute.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation.

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


iAttribute Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute Properties
iAttribute Class See Also Send Feedback

The iAttribute type exposes the following members.

Properties

Name Description
Public property AttributeType
Gets the attribute type (i.e. Style/Event/Other).
Public property BeginQuote
Gets/Sets the begin quote type of the attribute.
Public property DecodedValue
The value of the attribute after converting any HTML entities to normal characters e.g. &amp; -> &
Public property EndQuote
Gets/Sets the end quote type of the attribute
Public property IsSingular
Gets/Sets whether the attribute is singluar.

Examples

CopyC#
The nowrap attribute is a singluar attribute in  <foo id="myfoo" nowrap /> .
Public property Name
Gets/Sets the name of this attribute.
Public property RawValue
The raw value of the attribute including any quotes.
Public property Styles
The Styles collection if AttributeType = Style.

Examples

The following element <foo style="height:1px;width:2px;" /> , will contain a NameValueCollection that consists of two items: The first : name=height,value=1px The second : name=width,value=2px
Public property Value
Gets/Sets the value of this attribute.

Remarks

The value will be trimmed from any beginning or ending quotes. If you need the raw value use the RawValue property.

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


AttributeType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..AttributeType Property
iAttribute Class See Also Send Feedback
Gets the attribute type (i.e. Style/Event/Other).

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AttributeType AttributeType { get; }
Visual Basic
Public ReadOnly Property AttributeType As AttributeType
    Get
Visual C++
public:
property AttributeType AttributeType {
    AttributeType get ();
}

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


BeginQuote Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..BeginQuote Property
iAttribute Class See Also Send Feedback
Gets/Sets the begin quote type of the attribute.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Quote BeginQuote { get; set; }
Visual Basic
Public Property BeginQuote As Quote
    Get
    Set
Visual C++
public:
property Quote BeginQuote {
    Quote get ();
    void set (Quote value);
}

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


DecodedValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..DecodedValue Property
iAttribute Class See Also Send Feedback
The value of the attribute after converting any HTML entities to normal characters e.g. &amp; -> &

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string DecodedValue { get; }
Visual Basic
Public ReadOnly Property DecodedValue As String
    Get
Visual C++
public:
property String^ DecodedValue {
    String^ get ();
}

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


EndQuote Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..EndQuote Property
iAttribute Class See Also Send Feedback
Gets/Sets the end quote type of the attribute

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Quote EndQuote { get; set; }
Visual Basic
Public Property EndQuote As Quote
    Get
    Set
Visual C++
public:
property Quote EndQuote {
    Quote get ();
    void set (Quote value);
}

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


IsSingular Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..IsSingular Property
iAttribute Class See Also Send Feedback
Gets/Sets whether the attribute is singluar.

Examples

CopyC#
The nowrap attribute is a singluar attribute in  <foo id="myfoo" nowrap /> .

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSingular { get; set; }
Visual Basic
Public Property IsSingular As Boolean
    Get
    Set
Visual C++
public:
property bool IsSingular {
    bool get ();
    void set (bool value);
}

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..Name Property
iAttribute Class See Also Send Feedback
Gets/Sets the name of this attribute.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IiAttribute..::..Name

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


RawValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..RawValue Property
iAttribute Class See Also Send Feedback
The raw value of the attribute including any quotes.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string RawValue { get; }
Visual Basic
Public ReadOnly Property RawValue As String
    Get
Visual C++
public:
property String^ RawValue {
    String^ get ();
}

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


Styles Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..Styles Property
iAttribute Class See Also Send Feedback
The Styles collection if AttributeType = Style.

Examples

The following element <foo style="height:1px;width:2px;" /> , will contain a NameValueCollection that consists of two items: The first : name=height,value=1px The second : name=width,value=2px

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NameValueCollection Styles { get; }
Visual Basic
Public ReadOnly Property Styles As NameValueCollection
    Get
Visual C++
public:
property NameValueCollection^ Styles {
    NameValueCollection^ get ();
}

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..Value Property
iAttribute Class See Also Send Feedback
Gets/Sets the value of this attribute.

Remarks

The value will be trimmed from any beginning or ending quotes. If you need the raw value use the RawValue property.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IiAttribute..::..Value

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


iAttribute Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute Events
iAttribute Class See Also Send Feedback

The iAttribute type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property changes on this iAttribute object.

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


PropertyChanged Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
iAttribute..::..PropertyChanged Event
iAttribute Class See Also Send Feedback
Occurs when a property changes on this iAttribute object.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

iAttribute Class
ArtOfTest.WebAii.ObjectModel Namespace


TestRegion Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion Members
TestRegion Class Methods Properties See Also Send Feedback

The TestRegion type exposes the following members.

Methods

 | Name | Description
Public method | ContainsElement | Checks if a certain element is contained in this region or not.
Public method | Equals | Defined how two TestRegions should be compared. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetContainerRegion | This static methods can test whether an element falls within a Test Region. If it does, it will return the region that contains it. If the Element passed in is a test region then the function will return that element's test region. Otherwise will return null.
Public method | GetHashCode | Get the hash code for this testregion. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh()()()() | Refresh this test region.
Public method | Refresh(Boolean) | Refresh the test region.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllChildRegions | Gets a list of all sub regions contained in this region regardless of their depth relative to this region.
Public property | ChildRegions | Gets a list of all direct sub regions of this region.
Public property | Element | Gets the element object that represents this region in the Dom tree.
Public property | Find | Gets the Find object associated with this test region. All searchs from this object will be scoped to this region.
Public property | Id | Gets the region id.
Public property | Parent | Gets the parent Region that this region is within. Else will return null.

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


TestRegion Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion Methods
TestRegion Class See Also Send Feedback

The TestRegion type exposes the following members.

Methods

 | Name | Description
Public method | ContainsElement | Checks if a certain element is contained in this region or not.
Public method | Equals | Defined how two TestRegions should be compared. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetContainerRegion | This static methods can test whether an element falls within a Test Region. If it does, it will return the region that contains it. If the Element passed in is a test region then the function will return that element's test region. Otherwise will return null.
Public method | GetHashCode | Get the hash code for this testregion. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh()()()() | Refresh this test region.
Public method | Refresh(Boolean) | Refresh the test region.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


ContainsElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..ContainsElement Method
TestRegion Class See Also Send Feedback
Checks if a certain element is contained in this region or not.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ContainsElement(
    Element element,
    bool verifyDirectChildrenOnly
)
Visual Basic
Public Function ContainsElement ( _
    element As Element, _
    verifyDirectChildrenOnly As Boolean _
) As Boolean
Visual C++
public:
bool ContainsElement(
    Element^ element,
    bool verifyDirectChildrenOnly
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to check.
verifyDirectChildrenOnly
Type: System..::..Boolean
Check only the direct children of this region. If false, this method will check all sub regions too.

Return Value

True/False whether the element is contained or not.

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


Equals Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..Equals Method
TestRegion Class See Also Send Feedback
Defined how two TestRegions should be compared.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare.

Return Value

True/False whether the two objects are equal.

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


GetContainerRegion Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..GetContainerRegion Method
TestRegion Class See Also Send Feedback
This static methods can test whether an element falls within a Test Region. If it does, it will return the region that contains it. If the Element passed in is a test region then the function will return that element's test region. Otherwise will return null.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static TestRegion GetContainerRegion(
    Element element
)
Visual Basic
Public Shared Function GetContainerRegion ( _
    element As Element _
) As TestRegion
Visual C++
public:
static TestRegion^ GetContainerRegion(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to find its container test region.

Return Value

The testregion found or null.

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


GetHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..GetHashCode Method
TestRegion Class See Also Send Feedback
Get the hash code for this testregion.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The hash code.

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


Refresh Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..Refresh Method
TestRegion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Refresh()()()() | Refresh this test region.
Public method | Refresh(Boolean) | Refresh the test region.

See Also

TestRegion Class
TestRegion Members
ArtOfTest.WebAii.ObjectModel Namespace


Refresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..Refresh Method
TestRegion Class See Also Send Feedback
Refresh this test region.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Refresh()
Visual Basic
Public Sub Refresh
Visual C++
public:
void Refresh()

See Also

TestRegion Class
Refresh Overload
ArtOfTest.WebAii.ObjectModel Namespace


Refresh Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..Refresh Method (Boolean)
TestRegion Class See Also Send Feedback
Refresh the test region.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Refresh(
    bool forceDomTreeRefresh
)
Visual Basic
Public Sub Refresh ( _
    forceDomTreeRefresh As Boolean _
)
Visual C++
public:
void Refresh(
    bool forceDomTreeRefresh
)

Parameters

forceDomTreeRefresh
Type: System..::..Boolean
Whether to update the complete DOM before trying to refresh the region element.

See Also

TestRegion Class
Refresh Overload
ArtOfTest.WebAii.ObjectModel Namespace


TestRegion Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion Properties
TestRegion Class See Also Send Feedback

The TestRegion type exposes the following members.

Properties

 | Name | Description
Public property | AllChildRegions | Gets a list of all sub regions contained in this region regardless of their depth relative to this region.
Public property | ChildRegions | Gets a list of all direct sub regions of this region.
Public property | Element | Gets the element object that represents this region in the Dom tree.
Public property | Find | Gets the Find object associated with this test region. All searchs from this object will be scoped to this region.
Public property | Id | Gets the region id.
Public property | Parent | Gets the parent Region that this region is within. Else will return null.

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


AllChildRegions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..AllChildRegions Property
TestRegion Class See Also Send Feedback
Gets a list of all sub regions contained in this region regardless of their depth relative to this region.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestRegionCollection AllChildRegions { get; }
Visual Basic
Public ReadOnly Property AllChildRegions As TestRegionCollection
    Get
Visual C++
public:
property TestRegionCollection^ AllChildRegions {
    TestRegionCollection^ get ();
}

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


ChildRegions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..ChildRegions Property
TestRegion Class See Also Send Feedback
Gets a list of all direct sub regions of this region.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestRegionCollection ChildRegions { get; }
Visual Basic
Public ReadOnly Property ChildRegions As TestRegionCollection
    Get
Visual C++
public:
property TestRegionCollection^ ChildRegions {
    TestRegionCollection^ get ();
}

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


Element Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..Element Property
TestRegion Class See Also Send Feedback
Gets the element object that represents this region in the Dom tree.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Element Element { get; }
Visual Basic
Public ReadOnly Property Element As Element
    Get
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


Find Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..Find Property
TestRegion Class See Also Send Feedback
Gets the Find object associated with this test region. All searchs from this object will be scoped to this region.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Find Find { get; }
Visual Basic
Public ReadOnly Property Find As Find
    Get
Visual C++
public:
property Find^ Find {
    Find^ get ();
}

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


Id Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..Id Property
TestRegion Class See Also Send Feedback
Gets the region id.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


Parent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegion..::..Parent Property
TestRegion Class See Also Send Feedback
Gets the parent Region that this region is within. Else will return null.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestRegion Parent { get; }
Visual Basic
Public ReadOnly Property Parent As TestRegion
    Get
Visual C++
public:
property TestRegion^ Parent {
    TestRegion^ get ();
}

See Also

TestRegion Class
ArtOfTest.WebAii.ObjectModel Namespace


TestRegionCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection Members
TestRegionCollection Class Methods Properties See Also Send Feedback

The TestRegionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public method | Contains(String) | Check if a TestRegion is in this collection.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Get the key for an item. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected method | InsertItem | Inserts an element into the KeyedCollection<(Of <(<'TKey, TItem>)>)> at the specified index. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Remove an item from the collection.
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public property | Item[([( String])]) | Get a testregion by id. Case-insensitive.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public property | ReturnNullIfNotFound | Gets/Sets whether to throw or return null if a region is not found.

See Also

TestRegionCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


TestRegionCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection Methods
TestRegionCollection Class See Also Send Feedback

The TestRegionCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected method | ClearItems | Removes all elements from the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public method | Contains(String) | Check if a TestRegion is in this collection.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Get the key for an item. (Overrides KeyedCollection<(Of <(<'TKey, TItem>)>)>..::..GetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected method | InsertItem | Inserts an element into the KeyedCollection<(Of <(<'TKey, TItem>)>)> at the specified index. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(String) | Remove an item from the collection.
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TestRegionCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


Contains Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection..::..Contains Method
TestRegionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Contains(String) | Check if a TestRegion is in this collection.
Public method | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)

See Also

TestRegionCollection Class
TestRegionCollection Members
ArtOfTest.WebAii.ObjectModel Namespace


Contains Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection..::..Contains Method (String)
TestRegionCollection Class See Also Send Feedback
Check if a TestRegion is in this collection.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Contains(
    string key
)
Visual Basic
Public Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
bool Contains(
    String^ key
)

Parameters

key
Type: System..::..String
The key to check

Return Value

True/False whether the items is in the collection.

See Also

TestRegionCollection Class
Contains Overload
ArtOfTest.WebAii.ObjectModel Namespace


GetKeyForItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection..::..GetKeyForItem Method
TestRegionCollection Class See Also Send Feedback
Get the key for an item.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override string GetKeyForItem(
    TestRegion item
)
Visual Basic
Protected Overrides Function GetKeyForItem ( _
    item As TestRegion _
) As String
Visual C++
protected:
virtual String^ GetKeyForItem(
    TestRegion^ item
) override

Parameters

item
Type: ArtOfTest.WebAii.ObjectModel..::..TestRegion
The item to get the key for.

Return Value

The key.

See Also

TestRegionCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


Remove Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection..::..Remove Method
TestRegionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(String) | Remove an item from the collection.
Public method | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)

See Also

TestRegionCollection Class
TestRegionCollection Members
ArtOfTest.WebAii.ObjectModel Namespace


Remove Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection..::..Remove Method (String)
TestRegionCollection Class See Also Send Feedback
Remove an item from the collection.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Remove(
    string key
)
Visual Basic
Public Sub Remove ( _
    key As String _
)
Visual C++
public:
void Remove(
    String^ key
)

Parameters

key
Type: System..::..String
The key of the TestRegion to remove.

See Also

TestRegionCollection Class
Remove Overload
ArtOfTest.WebAii.ObjectModel Namespace


TestRegionCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection Properties
TestRegionCollection Class See Also Send Feedback

The TestRegionCollection type exposes the following members.

Properties

 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollection<(Of <(<'TKey, TItem>)>)>. (Inherited from KeyedCollection <(Of <(<' String, TestRegion >)>)>.)
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public property | Item[([( String])]) | Get a testregion by id. Case-insensitive.
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public property | ReturnNullIfNotFound | Gets/Sets whether to throw or return null if a region is not found.

See Also

TestRegionCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection..::..Item Property
TestRegionCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' TestRegion >)>)>.)
Public property | Item[([( String])]) | Get a testregion by id. Case-insensitive.

See Also

TestRegionCollection Class
TestRegionCollection Members
ArtOfTest.WebAii.ObjectModel Namespace


Item Property (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection..::..Item Property (String)
TestRegionCollection Class See Also Send Feedback
Get a testregion by id. Case-insensitive.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TestRegion this[
    string id
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    id As String _
) As TestRegion
    Get
Visual C++
public:
property TestRegion^ default[String^ id] {
    TestRegion^ get (String^ id);
}

Parameters

id
Type: System..::..String
The testregion id.

Return Value

The testregion.

See Also

TestRegionCollection Class
Item Overload
ArtOfTest.WebAii.ObjectModel Namespace


ReturnNullIfNotFound Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TestRegionCollection..::..ReturnNullIfNotFound Property
TestRegionCollection Class See Also Send Feedback
Gets/Sets whether to throw or return null if a region is not found.

Namespace: ArtOfTest.WebAii.ObjectModel
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ReturnNullIfNotFound { get; set; }
Visual Basic
Public Property ReturnNullIfNotFound As Boolean
    Get
    Set
Visual C++
public:
property bool ReturnNullIfNotFound {
    bool get ();
    void set (bool value);
}

Remarks

Default value is false

See Also

TestRegionCollection Class
ArtOfTest.WebAii.ObjectModel Namespace


ArtOfTest.WebAii.Silverlight Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Silverlight Namespace
Send Feedback
Namespace for the core Silverlight features and functionality of the framework.

Classes

 | Class | Description
Public class | ApplicationNotReadyException | This exception is used to signal that an operation was attempted against a Silverlight app that is not yet or no longer accessible through the DOM.
Public class | AutomationMethod | Represents a method on an AutomationObject
Public class | AutomationObject<(Of <(<'T>)>)> | Represents an object that can be automated inside a Silverlight/WPF App.
Public class | AutomationProperty | Represents a property on an AutomationObject.
Public class | AutomationReference | Represents an automation object reference that can point to a UIElement, a property or a method.
Public class | ExecuteSilverlightCommandException | Holds information about a SilverlightCommandException
Public class | FrameworkElement | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | GlobalInfo | Global constants used throughout Silverlight.
Public class | ItemCollection | This class wraps the collection of items contained in a listbox.
Public class | NoSuchPropertyException | The exception that is thrown when the specified property does not exist on a Silverlight element.
Public class | ObjectSerializer | Static class used to serialize/deserialize JSON objects to .NET objects.
Public class | SelectedDatesCollection | Holds a colleciton of selected dates for a Silverlight Calendar control.
Public class | SilverlightApp | Class that represents a Silverlight Application hosted in a browser.
Public class | SilverlightAppContent | Represents the access point to the content of the Silverlight App as described here: http://msdn2.microsoft.com/en-us/library/bb412394.aspx Note: Currently all properties are Read-Only.
Public class | SilverlightAppFinder | A static class used to obtain a list of all Silverlight Applications on a specific page
Public class | SilverlightAppSettings | Represents a settings object as described here: http://msdn2.microsoft.com/en-us/library/bb412394.aspx Note: Currently all properties are Read-Only.
Public class | SilverlightAppsList | A collection of silverlight applications.
Public class | SilverlightCommand | For internal use only. Holds a command to be processed by the Silverlight client.
Public class | SilverlightProxy | For internal use only.
Public class | SilverlightResponse | For internal use only. Holds the response returned by the client processor after processing a Silverlight command.
Public class | UserInteraction |
Public class | UserInteractionHelper | Collection of methods to assist the UserInteraction class.
Public class | VisualFind | VisualFind is used to search the Visual Tree of the Silverlight Application. It provides a rich set of API to do rich search.
Public class | VisualFindInfo | Class used to encapsulate information on how a visual element should be found in the VisualTree
Public class | VisualTree | The VisualTree for this Silverlight application
Public class | VisualTreeHost | Obsolete.
Public class | VisualTreeUnavailableException | The VisualTreeUnavailableException is thrown when a system error occurs trying to connect to the Silverlight application.
Public class | VisualWait | Provide wait functionality for Silverlight elements.
Public class | XamlFindClause | Holds a single clause as part of a Silverlight element FindExpression.
Public class | XamlFindExpression | Holds a Silverlight element FindExpression.

Interfaces

 | Interface | Description
Public interface | IApplication | Use the IApplication interface to manage a wrapped Silverlight application.
Public interface | IAutomationPeer | Implemented by automation objects that have a Silverlight/WPF object peer.
Public interface | IClientProcessor | This process is implemented by the Silverlight client
Public interface | ICommunicationProxy | Interface for communication across application boundaries.
Public interface | IPeerConverter | Interface to help manage converting to/from real object.

Enumerations

 | Enumeration | Description
Public enumeration | AutomationHostType | The type of host application being automated.
Public enumeration | FindStrategy | The FindStrategy to use when finding or waiting on elements in the VisualTree.
Public enumeration | ResponseStatus | Silverlight response status's.
Public enumeration | SilverlightCommandType | Sliverlight command types.
Public enumeration | XamlSearchType | Different types of supported find expressions.


ApplicationNotReadyException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ApplicationNotReadyException Members
ApplicationNotReadyException Class Constructors Methods Properties See Also Send Feedback

The ApplicationNotReadyException type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationNotReadyException()()()() | Initializes a new instance of the ApplicationNotReadyException class
Public method | ApplicationNotReadyException(String) | Initializes a new instance of the ApplicationNotReadyException class
Public method | ApplicationNotReadyException(SerializationInfo, StreamingContext) | Initializes a new instance of the ApplicationNotReadyException class
Public method | ApplicationNotReadyException(String, Exception) | Initializes a new instance of the ApplicationNotReadyException class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ApplicationNotReadyException Class
ArtOfTest.WebAii.Silverlight Namespace


ApplicationNotReadyException Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ApplicationNotReadyException Constructor
ApplicationNotReadyException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplicationNotReadyException()()()() | Initializes a new instance of the ApplicationNotReadyException class
Public method | ApplicationNotReadyException(String) | Initializes a new instance of the ApplicationNotReadyException class
Public method | ApplicationNotReadyException(SerializationInfo, StreamingContext) | Initializes a new instance of the ApplicationNotReadyException class
Public method | ApplicationNotReadyException(String, Exception) | Initializes a new instance of the ApplicationNotReadyException class

See Also

ApplicationNotReadyException Class
ApplicationNotReadyException Members
ArtOfTest.WebAii.Silverlight Namespace


ApplicationNotReadyException Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ApplicationNotReadyException Constructor
ApplicationNotReadyException Class See Also Send Feedback
Initializes a new instance of the ApplicationNotReadyException class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ApplicationNotReadyException()
Visual Basic
Public Sub New
Visual C++
public:
ApplicationNotReadyException()

See Also

ApplicationNotReadyException Class
ApplicationNotReadyException Overload
ArtOfTest.WebAii.Silverlight Namespace


ApplicationNotReadyException Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ApplicationNotReadyException Constructor (String)
ApplicationNotReadyException Class See Also Send Feedback
Initializes a new instance of the ApplicationNotReadyException class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ApplicationNotReadyException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ApplicationNotReadyException(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ApplicationNotReadyException.#ctor(System.String)"]

See Also

ApplicationNotReadyException Class
ApplicationNotReadyException Overload
ArtOfTest.WebAii.Silverlight Namespace


ApplicationNotReadyException Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ApplicationNotReadyException Constructor (SerializationInfo, StreamingContext)
ApplicationNotReadyException Class See Also Send Feedback
Initializes a new instance of the ApplicationNotReadyException class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ApplicationNotReadyException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ApplicationNotReadyException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo

[Missing <param name="info"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ApplicationNotReadyException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context
Type: System.Runtime.Serialization..::..StreamingContext

[Missing <param name="context"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ApplicationNotReadyException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

See Also

ApplicationNotReadyException Class
ApplicationNotReadyException Overload
ArtOfTest.WebAii.Silverlight Namespace


ApplicationNotReadyException Constructor (String, Exception)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ApplicationNotReadyException Constructor (String, Exception)
ApplicationNotReadyException Class See Also Send Feedback
Initializes a new instance of the ApplicationNotReadyException class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ApplicationNotReadyException(
    string message,
    Exception innerException
)
Visual Basic
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
Visual C++
public:
ApplicationNotReadyException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ApplicationNotReadyException.#ctor(System.String,System.Exception)"]

innerException
Type: System..::..Exception

[Missing <param name="innerException"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ApplicationNotReadyException.#ctor(System.String,System.Exception)"]

See Also

ApplicationNotReadyException Class
ApplicationNotReadyException Overload
ArtOfTest.WebAii.Silverlight Namespace


ApplicationNotReadyException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ApplicationNotReadyException Methods
ApplicationNotReadyException Class See Also Send Feedback

The ApplicationNotReadyException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ApplicationNotReadyException Class
ArtOfTest.WebAii.Silverlight Namespace


ApplicationNotReadyException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ApplicationNotReadyException Properties
ApplicationNotReadyException Class See Also Send Feedback

The ApplicationNotReadyException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ApplicationNotReadyException Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationMethod Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod Members
AutomationMethod Class Constructors Methods Properties See Also Send Feedback

The AutomationMethod type exposes the following members.

Constructors

 | Name | Description
Public method | AutomationMethod | Creates a new AutomationMethod

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReturnsAutomationPeer | Whether this object is an AutomationObject or not.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Gets / Sets the name of the method this object represents
Public property | Parameters | Gets / Sets the parameters for the method call
Public property | ReturnType | Gets / Sets the return type of the method this object represents
Public property | ReturnTypeName | Gets / Sets the return type name of the method this object represents

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationMethod Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod Constructor
AutomationMethod Class See Also Send Feedback
Creates a new AutomationMethod

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationMethod(
    string name,
    Type returnType
)
Visual Basic
Public Sub New ( _
    name As String, _
    returnType As Type _
)
Visual C++
public:
AutomationMethod(
    String^ name,
    Type^ returnType
)

Parameters

name
Type: System..::..String
The name of the method to call on the AutomationObject
returnType
Type: System..::..Type
The return type of the method

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationMethod Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod Methods
AutomationMethod Class See Also Send Feedback

The AutomationMethod type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReturnsAutomationPeer | Whether this object is an AutomationObject or not.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


ReturnsAutomationPeer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod..::..ReturnsAutomationPeer Method
AutomationMethod Class See Also Send Feedback
Whether this object is an AutomationObject or not.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ReturnsAutomationPeer()
Visual Basic
Public Function ReturnsAutomationPeer As Boolean
Visual C++
public:
bool ReturnsAutomationPeer()

Return Value

True/False whether or not this object is an AutomationObject.

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationMethod Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod Properties
AutomationMethod Class See Also Send Feedback

The AutomationMethod type exposes the following members.

Properties

 | Name | Description
Public property | Name | Gets / Sets the name of the method this object represents
Public property | Parameters | Gets / Sets the parameters for the method call
Public property | ReturnType | Gets / Sets the return type of the method this object represents
Public property | ReturnTypeName | Gets / Sets the return type name of the method this object represents

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod..::..Name Property
AutomationMethod Class See Also Send Feedback
Gets / Sets the name of the method this object represents

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


Parameters Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod..::..Parameters Property
AutomationMethod Class See Also Send Feedback
Gets / Sets the parameters for the method call

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object[] Parameters { get; set; }
Visual Basic
Public Property Parameters As Object()
    Get
    Set
Visual C++
public:
property array<Object^>^ Parameters {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


ReturnType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod..::..ReturnType Property
AutomationMethod Class See Also Send Feedback
Gets / Sets the return type of the method this object represents

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Type ReturnType { get; set; }
Visual Basic
Public Property ReturnType As Type
    Get
    Set
Visual C++
public:
property Type^ ReturnType {
    Type^ get ();
    void set (Type^ value);
}

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


ReturnTypeName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationMethod..::..ReturnTypeName Property
AutomationMethod Class See Also Send Feedback
Gets / Sets the return type name of the method this object represents

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ReturnTypeName { get; set; }
Visual Basic
Public Property ReturnTypeName As String
    Get
    Set
Visual C++
public:
property String^ ReturnTypeName {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationMethod Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationObject(T) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)> Members
AutomationObject<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The AutomationObject<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | AutomationObject<(Of <(<'T>)>)>()()()() | Initializes a new instance of the AutomationObject<(Of <(<'T>)>)> class.
Public method | AutomationObject<(Of <(<'T>)>)>(AutomationReference) | Create a new AutomationObject.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method?
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object.
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved
Public method | GetRealType | Gets the real peer type
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String
Public method | SetProperty | Set a property on this automation object.
Public method | ToRealObject | Converts an automation object to the real object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag.
Public property | Reference | Get or set the object reference.

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationObject(T) Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)> Constructor
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AutomationObject<(Of <(<'T>)>)>()()()() | Initializes a new instance of the AutomationObject<(Of <(<'T>)>)> class.
Public method | AutomationObject<(Of <(<'T>)>)>(AutomationReference) | Create a new AutomationObject.

See Also

AutomationObject<(Of <(<'T>)>)> Class
AutomationObject<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Silverlight Namespace


AutomationObject(T) Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)> Constructor
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Initializes a new instance of the AutomationObject<(Of <(<'T>)>)> class.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationObject()
Visual Basic
Public Sub New
Visual C++
public:
AutomationObject()

See Also

AutomationObject<(Of <(<'T>)>)> Class
AutomationObject<(Of <(<'T>)>)> Overload
ArtOfTest.WebAii.Silverlight Namespace


AutomationObject(T) Constructor (AutomationReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)> Constructor (AutomationReference)
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Create a new AutomationObject.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationObject(
    AutomationReference reference
)
Visual Basic
Public Sub New ( _
    reference As AutomationReference _
)
Visual C++
public:
AutomationObject(
    AutomationReference^ reference
)

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The object reference.

See Also

AutomationObject<(Of <(<'T>)>)> Class
AutomationObject<(Of <(<'T>)>)> Overload
ArtOfTest.WebAii.Silverlight Namespace


AutomationObject(T) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)> Methods
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback

The AutomationObject<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method?
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object.
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved
Public method | GetRealType | Gets the real peer type
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String
Public method | SetProperty | Set a property on this automation object.
Public method | ToRealObject | Converts an automation object to the real object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..AssignReference Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Assign a reference to this AutomationObject.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overridable Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
)

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference.

Return Value

True/False whether the assignment passed/failed.

Implements

IAutomationPeer..::..AssignReference(AutomationReference)

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


Deserialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..Deserialize Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Deserialize this AutomationObject to a jsonString TODO: Should this be a static method?

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Object Deserialize(
    string jsonString
)
Visual Basic
Public Overridable Function Deserialize ( _
    jsonString As String _
) As Object
Visual C++
public:
virtual Object^ Deserialize(
    String^ jsonString
)

Parameters

jsonString
Type: System..::..String
The Json string to deserialize

Return Value

The deserialize object

Implements

IAutomationPeer..::..Deserialize(String)

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


FromRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..FromRealObject Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Converts a Silverlight object to an AutomationObject

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void FromRealObject(
    Object o
)
Visual Basic
Public Overridable Sub FromRealObject ( _
    o As Object _
)
Visual C++
public:
virtual void FromRealObject(
    Object^ o
)

Parameters

o
Type: System..::..Object
The Silverlight object to convert.

Implements

IPeerConverter..::..FromRealObject(Object)

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..GetProperty Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object.
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved

See Also

AutomationObject<(Of <(<'T>)>)> Class
AutomationObject<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Silverlight Namespace


GetProperty Method (AutomationProperty)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..GetProperty Method (AutomationProperty)
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Get a property on this automation object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Object GetProperty(
    AutomationProperty property
)
Visual Basic
Public Overridable Function GetProperty ( _
    property As AutomationProperty _
) As Object
Visual C++
public:
virtual Object^ GetProperty(
    AutomationProperty^ property
)

Parameters

property
Type: ArtOfTest.WebAii.Silverlight..::..AutomationProperty
The name of the property to retrieve

Return Value

The value of the property

See Also

AutomationObject<(Of <(<'T>)>)> Class
GetProperty Overload
ArtOfTest.WebAii.Silverlight Namespace


GetProperty Method (AutomationProperty, Object)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..GetProperty Method (AutomationProperty, Object)
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Gets a property on this automation object, or returns a default value if the property cannot be retrieved

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Object GetProperty(
    AutomationProperty property,
    Object defaultValue
)
Visual Basic
Public Overridable Function GetProperty ( _
    property As AutomationProperty, _
    defaultValue As Object _
) As Object
Visual C++
public:
virtual Object^ GetProperty(
    AutomationProperty^ property,
    Object^ defaultValue
)

Parameters

property
Type: ArtOfTest.WebAii.Silverlight..::..AutomationProperty
The name of the property to retrieve
defaultValue
Type: System..::..Object
The value to be returned if the property cannot be retrieved

Return Value

The value of the property, or defaultValue if an error occurs while retrieving the property

See Also

AutomationObject<(Of <(<'T>)>)> Class
GetProperty Overload
ArtOfTest.WebAii.Silverlight Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..GetRealType Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Gets the real peer type

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract string GetRealType()
Visual Basic
Public MustOverride Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() abstract

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationObject`1.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


Invoke Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..Invoke Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Invokes a method on the AutomationObject's client-side peer

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("Please use InvokeMethod instead")]
public virtual Object Invoke(
    AutomationMethod method,
    params Object[] parameters
)
Visual Basic
<ObsoleteAttribute("Please use InvokeMethod instead")> _
Public Overridable Function Invoke ( _
    method As AutomationMethod, _
    ParamArray parameters As Object() _
) As Object
Visual C++
[ObsoleteAttribute(L"Please use InvokeMethod instead")]
public:
virtual Object^ Invoke(
    AutomationMethod^ method,
    ... array<Object^>^ parameters
)

Parameters

method
Type: ArtOfTest.WebAii.Silverlight..::..AutomationMethod
An AutomationMethod specifying the method to invoke on the peer
parameters
Type: array< System..::..Object >[]()[][]
The parameters for the method call

Return Value

null

Remarks

This method is deprecated. Please use InvokeMethod with the same signature instead.

Only simple parameters (numbers, booleans, and strings) are supported, and return values are not yet passed back from the automation peer.

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..InvokeMethod Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer

See Also

AutomationObject<(Of <(<'T>)>)> Class
AutomationObject<(Of <(<'T>)>)> Members
ArtOfTest.WebAii.Silverlight Namespace


InvokeMethod Method (String, Object[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..InvokeMethod Method (String, array<Object>[]()[][])
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Invokes a method on the AutomationObject's client-side peer

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Object InvokeMethod(
    string methodName,
    params Object[] parameters
)
Visual Basic
Public Overridable Function InvokeMethod ( _
    methodName As String, _
    ParamArray parameters As Object() _
) As Object
Visual C++
public:
virtual Object^ InvokeMethod(
    String^ methodName,
    ... array<Object^>^ parameters
)

Parameters

methodName
Type: System..::..String
The name of the method to invoke
parameters
Type: array< System..::..Object >[]()[][]
The parameters for the method call

Return Value

null

Remarks

Only simple parameters (numbers, booleans, and string) are supported, and return values are not yet passed back from the automation peer

See Also

AutomationObject<(Of <(<'T>)>)> Class
InvokeMethod Overload
ArtOfTest.WebAii.Silverlight Namespace


InvokeMethod Method (AutomationMethod, Object[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..InvokeMethod Method (AutomationMethod, array<Object>[]()[][])
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Invokes a method on the AutomationObject's client-side peer

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Object InvokeMethod(
    AutomationMethod method,
    params Object[] parameters
)
Visual Basic
Public Overridable Function InvokeMethod ( _
    method As AutomationMethod, _
    ParamArray parameters As Object() _
) As Object
Visual C++
public:
virtual Object^ InvokeMethod(
    AutomationMethod^ method,
    ... array<Object^>^ parameters
)

Parameters

method
Type: ArtOfTest.WebAii.Silverlight..::..AutomationMethod
An AutomationMethod specifying the method to invoke on the peer
parameters
Type: array< System..::..Object >[]()[][]
The parameters for the method call

Return Value

null

Remarks

Only simple parameters (numbers, booleans, and strings) are supported, and return values are not yet passed back from the automation peer

See Also

AutomationObject<(Of <(<'T>)>)> Class
InvokeMethod Overload
ArtOfTest.WebAii.Silverlight Namespace


Serialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..Serialize Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Serialize this automation object to a Json String

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string Serialize()
Visual Basic
Public Overridable Function Serialize As String
Visual C++
public:
virtual String^ Serialize()

Return Value

The Json string representation of this object.

Implements

IAutomationPeer..::..Serialize()()()()

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


SetProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..SetProperty Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Set a property on this automation object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void SetProperty(
    AutomationProperty property,
    Object value
)
Visual Basic
Public Overridable Sub SetProperty ( _
    property As AutomationProperty, _
    value As Object _
)
Visual C++
public:
virtual void SetProperty(
    AutomationProperty^ property,
    Object^ value
)

Parameters

property
Type: ArtOfTest.WebAii.Silverlight..::..AutomationProperty
The property.
value
Type: System..::..Object
The value.

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


ToRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..ToRealObject Method
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Converts an automation object to the real object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Object ToRealObject()
Visual Basic
Public Overridable Function ToRealObject As Object
Visual C++
public:
virtual Object^ ToRealObject()

Return Value

The Silverlight object.

Implements

IPeerConverter..::..ToRealObject()()()()

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationObject(T) Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)> Properties
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback

The AutomationObject<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag.
Public property | Reference | Get or set the object reference.

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


PropertyBag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..PropertyBag Property
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
The automation object property bag.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<string, Object> PropertyBag { get; set; }
Visual Basic
Public Property PropertyBag As Dictionary(Of String, Object)
    Get
    Set
Visual C++
public:
virtual property Dictionary<String^, Object^>^ PropertyBag {
    Dictionary<String^, Object^>^ get () sealed;
    void set (Dictionary<String^, Object^>^ value) sealed;
}

Field Value

The entire property bag.

Implements

IAutomationPeer..::..PropertyBag

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


Reference Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationObject<(Of <(<'T>)>)>..::..Reference Property
AutomationObject<(Of <(<'T>)>)> Class See Also Send Feedback
Get or set the object reference.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationReference Reference { get; set; }
Visual Basic
Public Property Reference As AutomationReference
    Get
    Set
Visual C++
public:
virtual property AutomationReference^ Reference {
    AutomationReference^ get () sealed;
    void set (AutomationReference^ value) sealed;
}

Implements

IAutomationPeer..::..Reference

See Also

AutomationObject<(Of <(<'T>)>)> Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationProperty Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty Members
AutomationProperty Class Constructors Methods Properties See Also Send Feedback

The AutomationProperty type exposes the following members.

Constructors

 | Name | Description
Public method | AutomationProperty | Create a new AutomationProperty

Methods

 | Name | Description
Public method | Clone | Returns a clone of this AutomationProperty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAutomationPeer | Whether this object is an AutomationObject or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | Gets or sets the property type.
Public property | Name | Gets or sets the property name.
Public property | Type | Gets or sets the property type.
Public property | TypeName | The name of the type this AutomationObject represents.

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationProperty Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty Constructor
AutomationProperty Class See Also Send Feedback
Create a new AutomationProperty

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationProperty(
    string propertyName,
    Type propertyType
)
Visual Basic
Public Sub New ( _
    propertyName As String, _
    propertyType As Type _
)
Visual C++
public:
AutomationProperty(
    String^ propertyName,
    Type^ propertyType
)

Parameters

propertyName
Type: System..::..String
The property name.
propertyType
Type: System..::..Type
The property type.

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationProperty Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty Methods
AutomationProperty Class See Also Send Feedback

The AutomationProperty type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a clone of this AutomationProperty.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAutomationPeer | Whether this object is an AutomationObject or not.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


Clone Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty..::..Clone Method
AutomationProperty Class See Also Send Feedback
Returns a clone of this AutomationProperty.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationProperty Clone()
Visual Basic
Public Function Clone As AutomationProperty
Visual C++
public:
AutomationProperty^ Clone()

Return Value

The cloned AutomationProperty

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


IsAutomationPeer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty..::..IsAutomationPeer Method
AutomationProperty Class See Also Send Feedback
Whether this object is an AutomationObject or not.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsAutomationPeer()
Visual Basic
Public Function IsAutomationPeer As Boolean
Visual C++
public:
bool IsAutomationPeer()

Return Value

True/False whether or not this object is an AutomationObject

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationProperty Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty Properties
AutomationProperty Class See Also Send Feedback

The AutomationProperty type exposes the following members.

Properties

 | Name | Description
Public property | Index | Gets or sets the property type.
Public property | Name | Gets or sets the property name.
Public property | Type | Gets or sets the property type.
Public property | TypeName | The name of the type this AutomationObject represents.

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


Index Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty..::..Index Property
AutomationProperty Class See Also Send Feedback
Gets or sets the property type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<int> Index { get; set; }
Visual Basic
Public Property Index As Nullable(Of Integer)
    Get
    Set
Visual C++
public:
property Nullable<int> Index {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty..::..Name Property
AutomationProperty Class See Also Send Feedback
Gets or sets the property name.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty..::..Type Property
AutomationProperty Class See Also Send Feedback
Gets or sets the property type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Type Type { get; set; }
Visual Basic
Public Property Type As Type
    Get
    Set
Visual C++
public:
property Type^ Type {
    Type^ get ();
    void set (Type^ value);
}

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


TypeName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationProperty..::..TypeName Property
AutomationProperty Class See Also Send Feedback
The name of the type this AutomationObject represents.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TypeName { get; set; }
Visual Basic
Public Property TypeName As String
    Get
    Set
Visual C++
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationProperty Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationReference Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference Members
AutomationReference Class Constructors Methods Properties See Also Send Feedback

The AutomationReference type exposes the following members.

Constructors

 | Name | Description
Public method | AutomationReference(FrameworkElement) | Create an AutomationReference that is a FrameworkElement.
Public method | AutomationReference(ICommunicationProxy) | Create a new AutomationReference passing it the communication proxy.
Public method | AutomationReference(ICommunicationProxy, String) | Create a new AutomationReference passing it the communication proxy & object name
Public method | AutomationReference(ICommunicationProxy, String, String) | Create a new AutomationRefernece passing it the communication proxy, object name and reference path.

Methods

 | Name | Description
Public method | AppendProperty | Appends an AutomationProperty to this reference.
Public method | Clone | Clone this AutomationReference.
Public method | EnsureReferencePath | Ensure the reference path is built for the FrameworkElement
Public method | Equals | Determines if this object is equal to another. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode for this AutomationReference object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ObjectName | Gets the object name of the reference
Public property | Path | Gets the reference path
Public property | Properties | Gets or sets the list of AutomationProperties that is reference represents

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationReference Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference Constructor
AutomationReference Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AutomationReference(FrameworkElement) | Create an AutomationReference that is a FrameworkElement.
Public method | AutomationReference(ICommunicationProxy) | Create a new AutomationReference passing it the communication proxy.
Public method | AutomationReference(ICommunicationProxy, String) | Create a new AutomationReference passing it the communication proxy & object name
Public method | AutomationReference(ICommunicationProxy, String, String) | Create a new AutomationRefernece passing it the communication proxy, object name and reference path.

See Also

AutomationReference Class
AutomationReference Members
ArtOfTest.WebAii.Silverlight Namespace


AutomationReference Constructor (FrameworkElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference Constructor (FrameworkElement)
AutomationReference Class See Also Send Feedback
Create an AutomationReference that is a FrameworkElement.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationReference(
    FrameworkElement fx
)
Visual Basic
Public Sub New ( _
    fx As FrameworkElement _
)
Visual C++
public:
AutomationReference(
    FrameworkElement^ fx
)

Parameters

fx
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="fx"/> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationReference.#ctor(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

AutomationReference Class
AutomationReference Overload
ArtOfTest.WebAii.Silverlight Namespace


AutomationReference Constructor (ICommunicationProxy)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference Constructor (ICommunicationProxy)
AutomationReference Class See Also Send Feedback
Create a new AutomationReference passing it the communication proxy.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationReference(
    ICommunicationProxy proxy
)
Visual Basic
Public Sub New ( _
    proxy As ICommunicationProxy _
)
Visual C++
public:
AutomationReference(
    ICommunicationProxy^ proxy
)

Parameters

proxy
Type: ArtOfTest.WebAii.Silverlight..::..ICommunicationProxy

[Missing <param name="proxy"/> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationReference.#ctor(ArtOfTest.WebAii.Silverlight.ICommunicationProxy)"]

See Also

AutomationReference Class
AutomationReference Overload
ArtOfTest.WebAii.Silverlight Namespace


AutomationReference Constructor (ICommunicationProxy, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference Constructor (ICommunicationProxy, String)
AutomationReference Class See Also Send Feedback
Create a new AutomationReference passing it the communication proxy & object name

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationReference(
    ICommunicationProxy proxy,
    string objectName
)
Visual Basic
Public Sub New ( _
    proxy As ICommunicationProxy, _
    objectName As String _
)
Visual C++
public:
AutomationReference(
    ICommunicationProxy^ proxy,
    String^ objectName
)

Parameters

proxy
Type: ArtOfTest.WebAii.Silverlight..::..ICommunicationProxy

[Missing <param name="proxy"/> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationReference.#ctor(ArtOfTest.WebAii.Silverlight.ICommunicationProxy,System.String)"]

objectName
Type: System..::..String

[Missing <param name="objectName"/> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationReference.#ctor(ArtOfTest.WebAii.Silverlight.ICommunicationProxy,System.String)"]

See Also

AutomationReference Class
AutomationReference Overload
ArtOfTest.WebAii.Silverlight Namespace


AutomationReference Constructor (ICommunicationProxy, String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference Constructor (ICommunicationProxy, String, String)
AutomationReference Class See Also Send Feedback
Create a new AutomationRefernece passing it the communication proxy, object name and reference path.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationReference(
    ICommunicationProxy proxy,
    string objectName,
    string refPath
)
Visual Basic
Public Sub New ( _
    proxy As ICommunicationProxy, _
    objectName As String, _
    refPath As String _
)
Visual C++
public:
AutomationReference(
    ICommunicationProxy^ proxy,
    String^ objectName,
    String^ refPath
)

Parameters

proxy
Type: ArtOfTest.WebAii.Silverlight..::..ICommunicationProxy

[Missing <param name="proxy"/> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationReference.#ctor(ArtOfTest.WebAii.Silverlight.ICommunicationProxy,System.String,System.String)"]

objectName
Type: System..::..String

[Missing <param name="objectName"/> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationReference.#ctor(ArtOfTest.WebAii.Silverlight.ICommunicationProxy,System.String,System.String)"]

refPath
Type: System..::..String

[Missing <param name="refPath"/> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationReference.#ctor(ArtOfTest.WebAii.Silverlight.ICommunicationProxy,System.String,System.String)"]

See Also

AutomationReference Class
AutomationReference Overload
ArtOfTest.WebAii.Silverlight Namespace


AutomationReference Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference Methods
AutomationReference Class See Also Send Feedback

The AutomationReference type exposes the following members.

Methods

 | Name | Description
Public method | AppendProperty | Appends an AutomationProperty to this reference.
Public method | Clone | Clone this AutomationReference.
Public method | EnsureReferencePath | Ensure the reference path is built for the FrameworkElement
Public method | Equals | Determines if this object is equal to another. (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets the hashcode for this AutomationReference object. (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


AppendProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference..::..AppendProperty Method
AutomationReference Class See Also Send Feedback
Appends an AutomationProperty to this reference.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AppendProperty(
    AutomationProperty prop
)
Visual Basic
Public Sub AppendProperty ( _
    prop As AutomationProperty _
)
Visual C++
public:
void AppendProperty(
    AutomationProperty^ prop
)

Parameters

prop
Type: ArtOfTest.WebAii.Silverlight..::..AutomationProperty

[Missing <param name="prop"/> documentation for "M:ArtOfTest.WebAii.Silverlight.AutomationReference.AppendProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty)"]

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


Clone Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference..::..Clone Method
AutomationReference Class See Also Send Feedback
Clone this AutomationReference.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationReference Clone()
Visual Basic
Public Function Clone As AutomationReference
Visual C++
public:
AutomationReference^ Clone()

Return Value

Cloned reference.

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


EnsureReferencePath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference..::..EnsureReferencePath Method
AutomationReference Class See Also Send Feedback
Ensure the reference path is built for the FrameworkElement

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void EnsureReferencePath()
Visual Basic
Public Sub EnsureReferencePath
Visual C++
public:
void EnsureReferencePath()

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


Equals Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference..::..Equals Method
AutomationReference Class See Also Send Feedback
Determines if this object is equal to another.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare to this one

Return Value

True if both objects are AutomationReferences, and both have ObjectName and Path properties defined, and both objects have the same values for those properties.

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


GetHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference..::..GetHashCode Method
AutomationReference Class See Also Send Feedback
Gets the hashcode for this AutomationReference object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

A hashcode.

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationReference Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference Properties
AutomationReference Class See Also Send Feedback

The AutomationReference type exposes the following members.

Properties

 | Name | Description
Public property | ObjectName | Gets the object name of the reference
Public property | Path | Gets the reference path
Public property | Properties | Gets or sets the list of AutomationProperties that is reference represents

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


ObjectName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference..::..ObjectName Property
AutomationReference Class See Also Send Feedback
Gets the object name of the reference

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ObjectName { get; set; }
Visual Basic
Public Property ObjectName As String
    Get
    Set
Visual C++
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


Path Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference..::..Path Property
AutomationReference Class See Also Send Feedback
Gets the reference path

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Path { get; set; }
Visual Basic
Public Property Path As String
    Get
    Set
Visual C++
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


Properties Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutomationReference..::..Properties Property
AutomationReference Class See Also Send Feedback
Gets or sets the list of AutomationProperties that is reference represents

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationProperty[] Properties { get; set; }
Visual Basic
Public Property Properties As AutomationProperty()
    Get
    Set
Visual C++
public:
property array<AutomationProperty^>^ Properties {
    array<AutomationProperty^>^ get ();
    void set (array<AutomationProperty^>^ value);
}

See Also

AutomationReference Class
ArtOfTest.WebAii.Silverlight Namespace


ExecuteSilverlightCommandException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteSilverlightCommandException Members
ExecuteSilverlightCommandException Class Constructors Methods Properties See Also Send Feedback

The ExecuteSilverlightCommandException type exposes the following members.

Constructors

 | Name | Description
Public method | ExecuteSilverlightCommandException(String) | Initializes a new ExecuteSilverlightCommandException
Public method | ExecuteSilverlightCommandException(SerializationInfo, StreamingContext) | Initializes a new ExecuteSilverlightCommandException

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExecuteSilverlightCommandException Class
ArtOfTest.WebAii.Silverlight Namespace


ExecuteSilverlightCommandException Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteSilverlightCommandException Constructor
ExecuteSilverlightCommandException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExecuteSilverlightCommandException(String) | Initializes a new ExecuteSilverlightCommandException
Public method | ExecuteSilverlightCommandException(SerializationInfo, StreamingContext) | Initializes a new ExecuteSilverlightCommandException

See Also

ExecuteSilverlightCommandException Class
ExecuteSilverlightCommandException Members
ArtOfTest.WebAii.Silverlight Namespace


ExecuteSilverlightCommandException Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteSilverlightCommandException Constructor (String)
ExecuteSilverlightCommandException Class See Also Send Feedback
Initializes a new ExecuteSilverlightCommandException

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecuteSilverlightCommandException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
ExecuteSilverlightCommandException(
    String^ message
)

Parameters

message
Type: System..::..String
The exception message.

See Also

ExecuteSilverlightCommandException Class
ExecuteSilverlightCommandException Overload
ArtOfTest.WebAii.Silverlight Namespace


ExecuteSilverlightCommandException Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteSilverlightCommandException Constructor (SerializationInfo, StreamingContext)
ExecuteSilverlightCommandException Class See Also Send Feedback
Initializes a new ExecuteSilverlightCommandException

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ExecuteSilverlightCommandException(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
ExecuteSilverlightCommandException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
The information needed to serialize/deserialize this object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The source and destination of a given serialized stream, and provides an additional caller-defined context.

See Also

ExecuteSilverlightCommandException Class
ExecuteSilverlightCommandException Overload
ArtOfTest.WebAii.Silverlight Namespace


ExecuteSilverlightCommandException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteSilverlightCommandException Methods
ExecuteSilverlightCommandException Class See Also Send Feedback

The ExecuteSilverlightCommandException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ExecuteSilverlightCommandException Class
ArtOfTest.WebAii.Silverlight Namespace


ExecuteSilverlightCommandException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ExecuteSilverlightCommandException Properties
ExecuteSilverlightCommandException Class See Also Send Feedback

The ExecuteSilverlightCommandException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExecuteSilverlightCommandException Class
ArtOfTest.WebAii.Silverlight Namespace


FrameworkElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement Members
FrameworkElement Class Constructors Methods Fields Properties See Also Send Feedback

The FrameworkElement type exposes the following members.

Constructors

 | Name | Description
Public method | FrameworkElement | Create a new FrameworkElement.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element.
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings.
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type.
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control.
Public method | AssignReference | Assign the automation reference to this element. (Overrides AutomationObject<(Of <(<'T>)>)>..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element.
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions.
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property.
Public method | GetAutomationProperty |
Public method | GetChildren | Get the children of this framework element.
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted.
 | GetControlTypeFromInterface | Get the loaded Xaml control type by given interface control type. Useful for sharing common Xaml (SL/Wpf) controls.
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null.
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first.
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates
 | GetKnownControlTypes | Return all the known control types.
Public method | GetNextSibling | Get the next sibling of this FrameworkElement.
Public method | GetParent | Get the Parent of this element.
Public method | GetPrevSibling | Get the previous sibling.
Public method | GetProperties | Reads and returns the specified property from this element.
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf).
Public method | GetPropertyTypeSafe |
Public method | GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App.
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element.
Public method | Highlight()()()() | Highlight this element.
Public method | Highlight(Boolean) | Highlight this element
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached
 | InitKnownSilverlightControlTypes |
 | InitKnownWpfControlTypes |
 | InitKnownXamlControlTypes | Initialize all the known types
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element.
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy].
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent].
Public method | KeyPress | Simulate user key press specific to this element.
Public method | Match | Match this FrameworkElement against a specific find expression.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type.
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type.
Public method | Parent()()()() | Get the parent framework element
Public method | Parent(String) | Get the parent control that matched the control type.
Public method | Parent(String, Boolean) | Get the parent control that matched the control type.
Public method | Parent<(Of <<'(T>)>>)()()()() | Get the parent control of this control that is of type T.
Public method | PreviousSibling(String) | The previous sibling control of desired type.
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type.
Public method | Refresh | Refresh this FrameworkElement within the VisualTree.
 | RegisterElement | Associate a control type with a Xaml tag.
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property.
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality.
Public method | SetDepth | Set the depth of this framework element.
Public method | SetFindInfo |
Public method | SetFocus | Sets keyboard focus to this element
Public method | SetParent | Set the parent object of this framework element.
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf).
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy |
Public method | SetUid |
Public method | SetXamlTag | Set the Xaml tag name.
Public method | ToRealObject | Used internally to translate object across application boundaries (Overrides AutomationObject<(Of <(<'T>)>)>..::..ToRealObject()()()().)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Overrides Object..::..ToString()()()().)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree.
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window.
Protected method | ValidateType | Validate a control type with the control tag name.

Fields

Name | Description
ActualHeightProperty | Defines how to get the ActualHeight property of this element.
ActualWidthProperty | Defines how to get the ActualWidth property of this element.
ClipProperty | Defines how to get the Clip property of this element.
DataContextProperty | Defines how to get the DataContext property of this element.
DesiredSizeProperty | Defines how to get the DesiredSize property of this element.
HeightProperty | Defines how to get the Height property of this element.
HorizontalAlignmentProperty | Defines how to get the HorizontalAlignment property of this element.
IsHitTestVisibleProperty | Defines how to get the IsHitTestVisible property of this element.
MarginProperty | Defines how to get the Margin property of this element.
MaxHeightProperty | Defines how to get the MaxHeight property of this element.
MaxWidthProperty | Defines how to get the MaxWidth property of this element.
MinHeightProperty | Defines how to get the MinHeight property of this element.
MinWidthProperty | Defines how to get the MinWidth property of this element.
NameProperty | Defines how to get the Name property of this element.
OpacityMaskProperty | Defines how to get the OpacityMask property of this element.
OpacityProperty | Defines how to get the Opacity property of this element.
RenderSizeProperty | Defines how to get the RenderSize property of this element.
RenderTransformOriginProperty | Defines how to get the RenderTransformOrigin property of this element.
RenderTransformProperty | Defines how to get the RenderTransform property of this element.
TagProperty | Defines how to get the Tag property of this element.
VerticalAlignmentProperty | Defines how to get the VerticalAlignment property of this element.
VisibilityProperty | Defines how to get the Visibility property of this element.
WidthProperty | Defines how to get the Width property of this element.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement.
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree.
Public property | ActualHeight | Gets the value of the ActualHeight of this element.
Public property | ActualWidth | Gets the value of the ActualWidth of this element.
Public property | Application | Get the Application object that owns this element.
Public property | AutomationId | Gets the AutomationId set on this element if any.
Public property | Children | Gets the visual children of this element.
Public property | Clip | Gets / Sets the value of the Clip of this element.
Public property | ComputedVisibility |
Public property | Depth | Get the depth of this element in the Visual Tree.
Public property | DesiredSize | Gets the value of the DesiredSize of this element.
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions
Public property | Find | Get the Find object used to search the visual children of this element.
Public property | Height | Gets / Sets the value of the Height of this element.
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element.
Public property | Host | Returns the AutomationHost for this object.
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element.
Public property | IsTestRegion | Gets whether or not this element is contained in a test region.
Public property | IsVisible |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized.
Public property | Margin | Gets / Sets the value of the Margin of this element.
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element.
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element.
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element.
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element.
Public property | Name | Gets the value of the Name of this element.
Public property | Opacity | Gets / Sets the value of the Opacity of this element.
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element.
Public property | ParsedElement | Get the parsed element under this object.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element.
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element.
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element.
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree.
Public property | TechnologyType | Get the technology type of this element.
Public property | Text | Gets the element text, the first text block text by default.
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements.
Public property | TextLiteralContent | Gets the literal text content of this framework element if any.
Public property | ToolTipText | The text of the tooltip specified for this element
Public property | Uid |
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element.
Public property | Visibility | Gets / Sets the value of the Visibility of this element.
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree.
Public property | Width | Gets / Sets the value of the Width of this element.
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal.
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


FrameworkElement Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement Constructor
FrameworkElement Class See Also Send Feedback
Create a new FrameworkElement.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement()
Visual Basic
Public Sub New
Visual C++
public:
FrameworkElement()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


FrameworkElement Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement Fields
FrameworkElement Class See Also Send Feedback

The FrameworkElement type exposes the following members.

Fields

Name | Description
ActualHeightProperty | Defines how to get the ActualHeight property of this element.
ActualWidthProperty | Defines how to get the ActualWidth property of this element.
ClipProperty | Defines how to get the Clip property of this element.
DataContextProperty | Defines how to get the DataContext property of this element.
DesiredSizeProperty | Defines how to get the DesiredSize property of this element.
HeightProperty | Defines how to get the Height property of this element.
HorizontalAlignmentProperty | Defines how to get the HorizontalAlignment property of this element.
IsHitTestVisibleProperty | Defines how to get the IsHitTestVisible property of this element.
MarginProperty | Defines how to get the Margin property of this element.
MaxHeightProperty | Defines how to get the MaxHeight property of this element.
MaxWidthProperty | Defines how to get the MaxWidth property of this element.
MinHeightProperty | Defines how to get the MinHeight property of this element.
MinWidthProperty | Defines how to get the MinWidth property of this element.
NameProperty | Defines how to get the Name property of this element.
OpacityMaskProperty | Defines how to get the OpacityMask property of this element.
OpacityProperty | Defines how to get the Opacity property of this element.
RenderSizeProperty | Defines how to get the RenderSize property of this element.
RenderTransformOriginProperty | Defines how to get the RenderTransformOrigin property of this element.
RenderTransformProperty | Defines how to get the RenderTransform property of this element.
TagProperty | Defines how to get the Tag property of this element.
VerticalAlignmentProperty | Defines how to get the VerticalAlignment property of this element.
VisibilityProperty | Defines how to get the Visibility property of this element.
WidthProperty | Defines how to get the Width property of this element.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ActualHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ActualHeightProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the ActualHeight property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ActualHeightProperty
Visual Basic
Public Shared ActualHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ActualHeightProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ActualWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ActualWidthProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the ActualWidth property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ActualWidthProperty
Visual Basic
Public Shared ActualWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ActualWidthProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ClipProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ClipProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the Clip property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ClipProperty
Visual Basic
Public Shared ClipProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ClipProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


DataContextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..DataContextProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the DataContext property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DataContextProperty
Visual Basic
Public Shared DataContextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DataContextProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


DesiredSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..DesiredSizeProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the DesiredSize property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DesiredSizeProperty
Visual Basic
Public Shared DesiredSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DesiredSizeProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


HeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..HeightProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the Height property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeightProperty
Visual Basic
Public Shared HeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeightProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


HorizontalAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..HorizontalAlignmentProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the HorizontalAlignment property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalAlignmentProperty
Visual Basic
Public Shared HorizontalAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalAlignmentProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


IsHitTestVisibleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsHitTestVisibleProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the IsHitTestVisible property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsHitTestVisibleProperty
Visual Basic
Public Shared IsHitTestVisibleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsHitTestVisibleProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MarginProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MarginProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the Margin property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MarginProperty
Visual Basic
Public Shared MarginProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MarginProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MaxHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MaxHeightProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the MaxHeight property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxHeightProperty
Visual Basic
Public Shared MaxHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxHeightProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MaxWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MaxWidthProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the MaxWidth property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxWidthProperty
Visual Basic
Public Shared MaxWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxWidthProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MinHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MinHeightProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the MinHeight property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinHeightProperty
Visual Basic
Public Shared MinHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinHeightProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MinWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MinWidthProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the MinWidth property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinWidthProperty
Visual Basic
Public Shared MinWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinWidthProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


NameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..NameProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the Name property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NameProperty
Visual Basic
Public Shared NameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NameProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


OpacityMaskProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..OpacityMaskProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the OpacityMask property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OpacityMaskProperty
Visual Basic
Public Shared OpacityMaskProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OpacityMaskProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


OpacityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..OpacityProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the Opacity property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OpacityProperty
Visual Basic
Public Shared OpacityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OpacityProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


RenderSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..RenderSizeProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the RenderSize property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RenderSizeProperty
Visual Basic
Public Shared RenderSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RenderSizeProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


RenderTransformOriginProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..RenderTransformOriginProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the RenderTransformOrigin property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RenderTransformOriginProperty
Visual Basic
Public Shared RenderTransformOriginProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RenderTransformOriginProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


RenderTransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..RenderTransformProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the RenderTransform property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RenderTransformProperty
Visual Basic
Public Shared RenderTransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RenderTransformProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


TagProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..TagProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the Tag property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TagProperty
Visual Basic
Public Shared TagProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TagProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


VerticalAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..VerticalAlignmentProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the VerticalAlignment property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalAlignmentProperty
Visual Basic
Public Shared VerticalAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalAlignmentProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


VisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..VisibilityProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the Visibility property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VisibilityProperty
Visual Basic
Public Shared VisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VisibilityProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..WidthProperty Field
FrameworkElement Class See Also Send Feedback
Defines how to get the Width property of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


FrameworkElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement Methods
FrameworkElement Class See Also Send Feedback

The FrameworkElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element.
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings.
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type.
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control.
Public method | AssignReference | Assign the automation reference to this element. (Overrides AutomationObject<(Of <(<'T>)>)>..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element.
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions.
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property.
Public method | GetAutomationProperty |
Public method | GetChildren | Get the children of this framework element.
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted.
 | GetControlTypeFromInterface | Get the loaded Xaml control type by given interface control type. Useful for sharing common Xaml (SL/Wpf) controls.
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Overrides Object..::..GetHashCode()()()().)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null.
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first.
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates
 | GetKnownControlTypes | Return all the known control types.
Public method | GetNextSibling | Get the next sibling of this FrameworkElement.
Public method | GetParent | Get the Parent of this element.
Public method | GetPrevSibling | Get the previous sibling.
Public method | GetProperties | Reads and returns the specified property from this element.
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf).
Public method | GetPropertyTypeSafe |
Public method | GetRealType | Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App.
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element.
Public method | Highlight()()()() | Highlight this element.
Public method | Highlight(Boolean) | Highlight this element
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached
 | InitKnownSilverlightControlTypes |
 | InitKnownWpfControlTypes |
 | InitKnownXamlControlTypes | Initialize all the known types
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element.
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy].
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent].
Public method | KeyPress | Simulate user key press specific to this element.
Public method | Match | Match this FrameworkElement against a specific find expression.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type.
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type.
Public method | Parent()()()() | Get the parent framework element
Public method | Parent(String) | Get the parent control that matched the control type.
Public method | Parent(String, Boolean) | Get the parent control that matched the control type.
Public method | Parent<(Of <<'(T>)>>)()()()() | Get the parent control of this control that is of type T.
Public method | PreviousSibling(String) | The previous sibling control of desired type.
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type.
Public method | Refresh | Refresh this FrameworkElement within the VisualTree.
 | RegisterElement | Associate a control type with a Xaml tag.
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property.
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality.
Public method | SetDepth | Set the depth of this framework element.
Public method | SetFindInfo |
Public method | SetFocus | Sets keyboard focus to this element
Public method | SetParent | Set the parent object of this framework element.
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf).
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy |
Public method | SetUid |
Public method | SetXamlTag | Set the Xaml tag name.
Public method | ToRealObject | Used internally to translate object across application boundaries (Overrides AutomationObject<(Of <(<'T>)>)>..::..ToRealObject()()()().)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Overrides Object..::..ToString()()()().)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree.
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window.
Protected method | ValidateType | Validate a control type with the control tag name.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


AddChildNode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..AddChildNode Method
FrameworkElement Class See Also Send Feedback
Add a child node to this framework element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddChildNode(
    ITargetElement child
)
Visual Basic
Public Sub AddChildNode ( _
    child As ITargetElement _
)
Visual C++
public:
virtual void AddChildNode(
    ITargetElement^ child
) sealed

Parameters

child
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="child"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.AddChildNode(ArtOfTest.Common.ITargetElement)"]

Implements

ITargetElement..::..AddChildNode(ITargetElement)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..AnySibling Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type.
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings.

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


AnySibling(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..AnySibling<(Of <(<'T>)>)> Method
FrameworkElement Class See Also Send Feedback
Return any sibling of this control of the specified type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T AnySibling<T>()
where T : FrameworkElement
Visual Basic
Public Function AnySibling(Of T As FrameworkElement) As T
Visual C++
public:
generic<typename T>
where T : FrameworkElement
T AnySibling()

Type Parameters

T
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.AnySibling``1"]

See Also

FrameworkElement Class
AnySibling Overload
ArtOfTest.WebAii.Silverlight Namespace


AnySibling Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..AnySibling Method (String)
FrameworkElement Class See Also Send Feedback
Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement AnySibling(
    string controlType
)
Visual Basic
Public Function AnySibling ( _
    controlType As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ AnySibling(
    String^ controlType
)

Parameters

controlType
Type: System..::..String
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)

Return Value

The matching sibling else null.

See Also

FrameworkElement Class
AnySibling Overload
ArtOfTest.WebAii.Silverlight Namespace


As(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..As<(Of <(<'T>)>)> Method
FrameworkElement Class See Also Send Feedback
Return this framework element as a strongly-typed control.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T As<T>()
where T : FrameworkElement
Visual Basic
Public Function As(Of T As FrameworkElement) As T
Visual C++
public:
generic<typename T>
where T : FrameworkElement
T As()

Type Parameters

T
The type of desired control.

Return Value

The desired control instance.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..AssignReference Method
FrameworkElement Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Capture Method
FrameworkElement Class See Also Send Feedback
Capture the image of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap Capture()
Visual Basic
Public Function Capture As Bitmap
Visual C++
public:
virtual Bitmap^ Capture() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.Capture"]

Implements

ITargetElement..::..Capture()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


CastAs(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..CastAs<(Of <(<'T>)>)> Method
FrameworkElement Class See Also Send Feedback
Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T CastAs<T>()
where T : IFrameworkElement
Visual Basic
Public Function CastAs(Of T As IFrameworkElement) As T
Visual C++
public:
generic<typename T>
where T : IFrameworkElement
virtual T CastAs() sealed

Type Parameters

T
The type to cast against.

Return Value

The control type

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


EnsureClickable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..EnsureClickable Method
FrameworkElement Class See Also Send Feedback
Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void EnsureClickable()
Visual Basic
Public Sub EnsureClickable
Visual C++
public:
void EnsureClickable()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Equals Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Equals Method
FrameworkElement Class See Also Send Feedback
Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The object to compare this FrameworkElement to

Return Value

True if obj is a FrameworkElement and its AutomationReference refers to the same element as this one's

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


FromRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..FromRealObject Method
FrameworkElement Class See Also Send Feedback
Used internally to translate object across application boundaries

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void FromRealObject(
    Object o
)
Visual Basic
Public Overrides Sub FromRealObject ( _
    o As Object _
)
Visual C++
public:
virtual void FromRealObject(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.FromRealObject(System.Object)"]

Implements

IPeerConverter..::..FromRealObject(Object)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetAttachedProperty(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetAttachedProperty<(Of <(<'T>)>)> Method
FrameworkElement Class See Also Send Feedback
Get value of attached property.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T GetAttachedProperty<T>(
    string propertyOwner,
    string propertyName
)
Visual Basic
Public Function GetAttachedProperty(Of T) ( _
    propertyOwner As String, _
    propertyName As String _
) As T
Visual C++
public:
generic<typename T>
T GetAttachedProperty(
    String^ propertyOwner,
    String^ propertyName
)

Parameters

propertyOwner
Type: System..::..String
The type name of attached property owner.
propertyName
Type: System..::..String
The name of the property.

Type Parameters

T
The property value type.

Return Value

The value of attached property.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetAutomationProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetAutomationProperty Method
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetAutomationProperty(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationProperty GetAutomationProperty(
    string name
)
Visual Basic
Public Function GetAutomationProperty ( _
    name As String _
) As AutomationProperty
Visual C++
public:
virtual AutomationProperty^ GetAutomationProperty(
    String^ name
) sealed

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetAutomationProperty(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetAutomationProperty(System.String)"]

Implements

IFrameworkElement..::..GetAutomationProperty(String)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetChildren Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetChildren Method
FrameworkElement Class See Also Send Feedback
Get the children of this framework element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement[] GetChildren()
Visual Basic
Public Function GetChildren As ITargetElement()
Visual C++
public:
virtual array<ITargetElement^>^ GetChildren() sealed

Return Value

The list of children

Implements

ITargetElement..::..GetChildren()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetChildTagIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetChildTagIndex Method
FrameworkElement Class See Also Send Feedback
Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int GetChildTagIndex(
    FrameworkElement child
)
Visual Basic
Public Function GetChildTagIndex ( _
    child As FrameworkElement _
) As Integer
Visual C++
public:
int GetChildTagIndex(
    FrameworkElement^ child
)

Parameters

child
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The child to find the index of.

Return Value

The child tag index else -1

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetControlTypeFromInterface Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetControlTypeFromInterface Method
FrameworkElement Class See Also Send Feedback
Get the loaded Xaml control type by given interface control type. Useful for sharing common Xaml (SL/Wpf) controls.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Type GetControlTypeFromInterface(
    Type interfaceType
)
Visual Basic
Public Shared Function GetControlTypeFromInterface ( _
    interfaceType As Type _
) As Type
Visual C++
public:
static Type^ GetControlTypeFromInterface(
    Type^ interfaceType
)

Parameters

interfaceType
Type: System..::..Type
The interface to look for.

Return Value

The loaded Xaml control type, or 'null' if nothing is found.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetHashCode Method
FrameworkElement Class See Also Send Feedback
Calculates and returns the hashcode for this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

The hashcode.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetHostParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetHostParent Method
FrameworkElement Class See Also Send Feedback
Not implemented for Silverlight elements. Returns null.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement GetHostParent()
Visual Basic
Public Function GetHostParent As ITargetElement
Visual C++
public:
virtual ITargetElement^ GetHostParent() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetHostParent"]

Implements

ITargetElement..::..GetHostParent()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetIdentifier Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetIdentifier Method
FrameworkElement Class See Also Send Feedback
Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool GetIdentifier(
    out string name,
    out string value
)
Visual Basic
Public Function GetIdentifier ( _
    <OutAttribute> ByRef name As String, _
    <OutAttribute> ByRef value As String _
) As Boolean
Visual C++
public:
bool GetIdentifier(
    [OutAttribute] String^% name,
    [OutAttribute] String^% value
)

Parameters

name
Type: System..::..String %

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetIdentifier(System.String@,System.String@)"]

value
Type: System..::..String %

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetIdentifier(System.String@,System.String@)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetIdentifier(System.String@,System.String@)"]

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetIntRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetIntRectangle Method
FrameworkElement Class See Also Send Feedback
Gets the bounding rectangle of this element within the Silverlight app with integral coordinates

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle GetIntRectangle()
Visual Basic
Public Function GetIntRectangle As Rectangle
Visual C++
public:
Rectangle GetIntRectangle()

Return Value

The rectangle of this element

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetKnownControlTypes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetKnownControlTypes Method
FrameworkElement Class See Also Send Feedback
Return all the known control types.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static List<string> GetKnownControlTypes(
    TechnologyType techType
)
Visual Basic
Public Shared Function GetKnownControlTypes ( _
    techType As TechnologyType _
) As List(Of String)
Visual C++
public:
static List<String^>^ GetKnownControlTypes(
    TechnologyType techType
)

Parameters

techType
Type: ArtOfTest.Common..::..TechnologyType

[Missing <param name="techType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetKnownControlTypes(ArtOfTest.Common.TechnologyType)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetKnownControlTypes(ArtOfTest.Common.TechnologyType)"]

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetNextSibling Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetNextSibling Method
FrameworkElement Class See Also Send Feedback
Get the next sibling of this FrameworkElement.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement GetNextSibling()
Visual Basic
Public Function GetNextSibling As FrameworkElement
Visual C++
public:
FrameworkElement^ GetNextSibling()

Return Value

The next sibling else null.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetParent Method
FrameworkElement Class See Also Send Feedback
Get the Parent of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ITargetElement GetParent()
Visual Basic
Public Function GetParent As ITargetElement
Visual C++
public:
virtual ITargetElement^ GetParent() sealed

Return Value

Return the parent object.

Implements

ITargetElement..::..GetParent()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetPrevSibling Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetPrevSibling Method
FrameworkElement Class See Also Send Feedback
Get the previous sibling.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement GetPrevSibling()
Visual Basic
Public Function GetPrevSibling As FrameworkElement
Visual C++
public:
FrameworkElement^ GetPrevSibling()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetPrevSibling"]

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetProperties Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetProperties Method
FrameworkElement Class See Also Send Feedback
Reads and returns the specified property from this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<string, string> GetProperties()
Visual Basic
Public Function GetProperties As Dictionary(Of String, String)
Visual C++
public:
Dictionary<String^, String^>^ GetProperties()

Return Value

The value of the specified property as a string.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetProperty Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf).
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


GetProperty(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetProperty<(Of <(<'T>)>)> Method (String)
FrameworkElement Class See Also Send Feedback
Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf).

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T GetProperty<T>(
    string name
)
Visual Basic
Public Function GetProperty(Of T) ( _
    name As String _
) As T
Visual C++
public:
generic<typename T>
virtual T GetProperty(
    String^ name
) sealed

Parameters

name
Type: System..::..String
The property name.

Type Parameters

T
The type to pass and return.

Return Value

The propterty return type.

See Also

FrameworkElement Class
GetProperty Overload
ArtOfTest.WebAii.Silverlight Namespace


GetPropertyTypeSafe Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetPropertyTypeSafe Method
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetPropertyTypeSafe(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object GetPropertyTypeSafe(
    string name
)
Visual Basic
Public Function GetPropertyTypeSafe ( _
    name As String _
) As Object
Visual C++
public:
virtual Object^ GetPropertyTypeSafe(
    String^ name
) sealed

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetPropertyTypeSafe(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetPropertyTypeSafe(System.String)"]

Implements

IFrameworkElement..::..GetPropertyTypeSafe(String)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetRealType Method
FrameworkElement Class See Also Send Feedback
Gets the real object type. This property returns string.empty on FrameworkElement and all subclasses that inherit from it.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetRectangle Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App.
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetRectangle Method
FrameworkElement Class See Also Send Feedback
Get the bounding rectangle of this element within this Silverlight App.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RectangleF GetRectangle()
Visual Basic
Public Function GetRectangle As RectangleF
Visual C++
public:
RectangleF GetRectangle()

Return Value

The rectangle of this element

See Also

FrameworkElement Class
GetRectangle Overload
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method (FrameworkElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetRectangle Method (FrameworkElement)
FrameworkElement Class See Also Send Feedback
Get the bounding rectangle of this element relative to another element

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RectangleF GetRectangle(
    FrameworkElement relativeTo
)
Visual Basic
Public Function GetRectangle ( _
    relativeTo As FrameworkElement _
) As RectangleF
Visual C++
public:
RectangleF GetRectangle(
    FrameworkElement^ relativeTo
)

Parameters

relativeTo
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="relativeTo"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.GetRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

FrameworkElement Class
GetRectangle Overload
ArtOfTest.WebAii.Silverlight Namespace


GetScreenRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetScreenRectangle Method
FrameworkElement Class See Also Send Feedback
Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle GetScreenRectangle()
Visual Basic
Public Function GetScreenRectangle As Rectangle
Visual C++
public:
Rectangle GetScreenRectangle()

Return Value

Screen coordinates of this element

Remarks

This will take into consideration any Transforms done on the element.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GetUniqueHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..GetUniqueHashCode Method
FrameworkElement Class See Also Send Feedback
Calculates and returns the hash code for this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int GetUniqueHashCode()
Visual Basic
Public Function GetUniqueHashCode As Integer
Visual C++
public:
virtual int GetUniqueHashCode() sealed

Return Value

The hash code.

Implements

ITargetElement..::..GetUniqueHashCode()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Highlight Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element.
Public method | Highlight(Boolean) | Highlight this element

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


Highlight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Highlight Method
FrameworkElement Class See Also Send Feedback
Highlight this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Highlight()
Visual Basic
Public Sub Highlight
Visual C++
public:
void Highlight()

See Also

FrameworkElement Class
Highlight Overload
ArtOfTest.WebAii.Silverlight Namespace


Highlight Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Highlight Method (Boolean)
FrameworkElement Class See Also Send Feedback
Highlight this element

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Highlight(
    bool clear
)
Visual Basic
Public Sub Highlight ( _
    clear As Boolean _
)
Visual C++
public:
void Highlight(
    bool clear
)

Parameters

clear
Type: System..::..Boolean
True to clear the highlight on the element.

See Also

FrameworkElement Class
Highlight Overload
ArtOfTest.WebAii.Silverlight Namespace


InitializeMappings Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..InitializeMappings Method
FrameworkElement Class See Also Send Feedback
Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void InitializeMappings(
    MappingsCollection mappings
)
Visual Basic
Public Overridable Sub InitializeMappings ( _
    mappings As MappingsCollection _
)
Visual C++
public:
virtual void InitializeMappings(
    MappingsCollection^ mappings
)

Parameters

mappings
Type: ArtOfTest.WebAii.Core..::..MappingsCollection
The mappings collection to populate

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


InitKnownSilverlightControlTypes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..InitKnownSilverlightControlTypes Method
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.InitKnownSilverlightControlTypes"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void InitKnownSilverlightControlTypes()
Visual Basic
Public Shared Sub InitKnownSilverlightControlTypes
Visual C++
public:
static void InitKnownSilverlightControlTypes()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


InitKnownWpfControlTypes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..InitKnownWpfControlTypes Method
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.InitKnownWpfControlTypes"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void InitKnownWpfControlTypes()
Visual Basic
Public Shared Sub InitKnownWpfControlTypes
Visual C++
public:
static void InitKnownWpfControlTypes()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


InitKnownXamlControlTypes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..InitKnownXamlControlTypes Method
FrameworkElement Class See Also Send Feedback
Initialize all the known types

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void InitKnownXamlControlTypes(
    Type baseType
)
Visual Basic
Public Shared Sub InitKnownXamlControlTypes ( _
    baseType As Type _
)
Visual C++
public:
static void InitKnownXamlControlTypes(
    Type^ baseType
)

Parameters

baseType
Type: System..::..Type

[Missing <param name="baseType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.InitKnownXamlControlTypes(System.Type)"]

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..InvokeMethod Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


IsChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsChild Method
FrameworkElement Class See Also Send Feedback
Checks if element passed in is a child of this framework element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsChild(
    FrameworkElement element
)
Visual Basic
Public Function IsChild ( _
    element As FrameworkElement _
) As Boolean
Visual C++
public:
bool IsChild(
    FrameworkElement^ element
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The child to check.

Return Value

True/False whether the element is a child.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsHitTest Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy].
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent].

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


IsHitTest Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsHitTest Method
FrameworkElement Class See Also Send Feedback
Determines whether the element can be clicked/selected

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsHitTest()
Visual Basic
Public Overridable Function IsHitTest As Boolean
Visual C++
public:
virtual bool IsHitTest()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.IsHitTest"]

See Also

FrameworkElement Class
IsHitTest Overload
ArtOfTest.WebAii.Silverlight Namespace


IsHitTest Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsHitTest Method (Boolean)
FrameworkElement Class See Also Send Feedback
Determines whether [is hit test] [the specified allow partial visibiltiy].

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsHitTest(
    bool allowPartialVisibiltiy
)
Visual Basic
Public Overridable Function IsHitTest ( _
    allowPartialVisibiltiy As Boolean _
) As Boolean
Visual C++
public:
virtual bool IsHitTest(
    bool allowPartialVisibiltiy
)

Parameters

allowPartialVisibiltiy
Type: System..::..Boolean
The allow partial visibiltiy.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.IsHitTest(System.Boolean)"]

See Also

FrameworkElement Class
IsHitTest Overload
ArtOfTest.WebAii.Silverlight Namespace


IsHitTest Method (FrameworkElement, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsHitTest Method (FrameworkElement, Boolean)
FrameworkElement Class See Also Send Feedback
Determines whether [is hit test] [the specified relative parent].

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsHitTest(
    FrameworkElement relativeParent,
    bool allowPartialVisibiltiy
)
Visual Basic
Public Overridable Function IsHitTest ( _
    relativeParent As FrameworkElement, _
    allowPartialVisibiltiy As Boolean _
) As Boolean
Visual C++
public:
virtual bool IsHitTest(
    FrameworkElement^ relativeParent,
    bool allowPartialVisibiltiy
)

Parameters

relativeParent
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The relative parent.
allowPartialVisibiltiy
Type: System..::..Boolean
The allow partial visibiltiy.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.IsHitTest(ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Boolean)"]

See Also

FrameworkElement Class
IsHitTest Overload
ArtOfTest.WebAii.Silverlight Namespace


KeyPress Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..KeyPress Method
FrameworkElement Class See Also Send Feedback
Simulate user key press specific to this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyPress(
    Keys key,
    int holdFor,
    int delayBetweenRepetitions,
    int repeatCount
)
Visual Basic
Public Sub KeyPress ( _
    key As Keys, _
    holdFor As Integer, _
    delayBetweenRepetitions As Integer, _
    repeatCount As Integer _
)
Visual C++
public:
void KeyPress(
    Keys key,
    int holdFor,
    int delayBetweenRepetitions,
    int repeatCount
)

Parameters

key
Type: System.Windows.Forms..::..Keys
The key code for the key to press.
holdFor
Type: System..::..Int32
How long to hold the key down, in milliseconds.
delayBetweenRepetitions
Type: System..::..Int32
The time in milliseconds to wait between key presses.
repeatCount
Type: System..::..Int32
The count of actions to repeat.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Match Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Match Method
FrameworkElement Class See Also Send Feedback
Match this FrameworkElement against a specific find expression.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Match(
    IFindExpression findExpr
)
Visual Basic
Public Function Match ( _
    findExpr As IFindExpression _
) As Boolean
Visual C++
public:
virtual bool Match(
    IFindExpression^ findExpr
) sealed

Parameters

findExpr
Type: ArtOfTest.Common..::..IFindExpression
The find expression to match.

Return Value

Return true/false whether the expression matches.

Implements

ITargetElement..::..Match(IFindExpression)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..NextSibling Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type.
Public method | NextSibling(String) | Return the next sibling of this control of type.

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


NextSibling(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..NextSibling<(Of <(<'T>)>)> Method
FrameworkElement Class See Also Send Feedback
The next sibling control of desired type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T NextSibling<T>()
where T : FrameworkElement
Visual Basic
Public Function NextSibling(Of T As FrameworkElement) As T
Visual C++
public:
generic<typename T>
where T : FrameworkElement
T NextSibling()

Type Parameters

T
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)

Return Value

The next sibling.

See Also

FrameworkElement Class
NextSibling Overload
ArtOfTest.WebAii.Silverlight Namespace


NextSibling Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..NextSibling Method (String)
FrameworkElement Class See Also Send Feedback
Return the next sibling of this control of type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement NextSibling(
    string controlType
)
Visual Basic
Public Function NextSibling ( _
    controlType As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ NextSibling(
    String^ controlType
)

Parameters

controlType
Type: System..::..String
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)

Return Value

The next sibling, else null if this control is the last sibiling.

See Also

FrameworkElement Class
NextSibling Overload
ArtOfTest.WebAii.Silverlight Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Parent Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent<(Of <<'(T>)>>)()()()() | Get the parent control of this control that is of type T.
Public method | Parent()()()() | Get the parent framework element
Public method | Parent(String) | Get the parent control that matched the control type.
Public method | Parent(String, Boolean) | Get the parent control that matched the control type.

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


Parent(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Parent<(Of <(<'T>)>)> Method
FrameworkElement Class See Also Send Feedback
Get the parent control of this control that is of type T.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T Parent<T>()
where T : IFrameworkElement
Visual Basic
Public Function Parent(Of T As IFrameworkElement) As T
Visual C++
public:
generic<typename T>
where T : IFrameworkElement
virtual T Parent() sealed

Type Parameters

T
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)

Return Value

The parent control of specified type.

Remarks

This function will traverse up the VisualTree until it finds the desired type. This function will also match custom control type that inherit from type T. For explicit matchings use Parent(string)

See Also

FrameworkElement Class
Parent Overload
ArtOfTest.WebAii.Silverlight Namespace


Parent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Parent Method
FrameworkElement Class See Also Send Feedback
Get the parent framework element

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement Parent()
Visual Basic
Public Function Parent As FrameworkElement
Visual C++
public:
FrameworkElement^ Parent()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.Parent"]

See Also

FrameworkElement Class
Parent Overload
ArtOfTest.WebAii.Silverlight Namespace


Parent Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Parent Method (String)
FrameworkElement Class See Also Send Feedback
Get the parent control that matched the control type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement Parent(
    string controlType
)
Visual Basic
Public Function Parent ( _
    controlType As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ Parent(
    String^ controlType
)

Parameters

controlType
Type: System..::..String
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)

Return Value

The parent object of specified type.

See Also

FrameworkElement Class
Parent Overload
ArtOfTest.WebAii.Silverlight Namespace


Parent Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Parent Method (String, Boolean)
FrameworkElement Class See Also Send Feedback
Get the parent control that matched the control type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement Parent(
    string controlType,
    bool matchBaseType
)
Visual Basic
Public Function Parent ( _
    controlType As String, _
    matchBaseType As Boolean _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ Parent(
    String^ controlType,
    bool matchBaseType
)

Parameters

controlType
Type: System..::..String
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)
matchBaseType
Type: System..::..Boolean
If set to true, will match a parent control that inherits from 'controlType'

Return Value

The parent object of specified type.

See Also

FrameworkElement Class
Parent Overload
ArtOfTest.WebAii.Silverlight Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..PreviousSibling Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type.
Public method | PreviousSibling(String) | The previous sibling control of desired type.

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


PreviousSibling(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..PreviousSibling<(Of <(<'T>)>)> Method
FrameworkElement Class See Also Send Feedback
The previous sibling control of specified type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T PreviousSibling<T>()
where T : FrameworkElement
Visual Basic
Public Function PreviousSibling(Of T As FrameworkElement) As T
Visual C++
public:
generic<typename T>
where T : FrameworkElement
T PreviousSibling()

Type Parameters

T
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.PreviousSibling``1"]

See Also

FrameworkElement Class
PreviousSibling Overload
ArtOfTest.WebAii.Silverlight Namespace


PreviousSibling Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..PreviousSibling Method (String)
FrameworkElement Class See Also Send Feedback
The previous sibling control of desired type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement PreviousSibling(
    string controlType
)
Visual Basic
Public Function PreviousSibling ( _
    controlType As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ PreviousSibling(
    String^ controlType
)

Parameters

controlType
Type: System..::..String
The desired control type to match (i.e. 'Button', 'Calendar' ...etc)

Return Value

The previous sibling.

See Also

FrameworkElement Class
PreviousSibling Overload
ArtOfTest.WebAii.Silverlight Namespace


Refresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Refresh Method
FrameworkElement Class See Also Send Feedback
Refresh this FrameworkElement within the VisualTree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Refresh()
Visual Basic
Public Sub Refresh
Visual C++
public:
virtual void Refresh() sealed

Implements

ITargetElement..::..Refresh()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


RegisterElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..RegisterElement Method
FrameworkElement Class See Also Send Feedback
Associate a control type with a Xaml tag.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void RegisterElement(
    Type controlType,
    string xamlTagName
)
Visual Basic
Public Shared Sub RegisterElement ( _
    controlType As Type, _
    xamlTagName As String _
)
Visual C++
public:
static void RegisterElement(
    Type^ controlType,
    String^ xamlTagName
)

Parameters

controlType
Type: System..::..Type
The control type.
xamlTagName
Type: System..::..String
The xaml tag name.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ScrollToVisible Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


ScrollToVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ScrollToVisible Method
FrameworkElement Class See Also Send Feedback
Scrolls the web page so that this element is visible in the browser window

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ScrollToVisible()
Visual Basic
Public Sub ScrollToVisible
Visual C++
public:
void ScrollToVisible()

See Also

FrameworkElement Class
ScrollToVisible Overload
ArtOfTest.WebAii.Silverlight Namespace


ScrollToVisible Method (ScrollToVisibleType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ScrollToVisible Method (ScrollToVisibleType)
FrameworkElement Class See Also Send Feedback
Scrolls the web page so that this element is visible in the browser window

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ScrollToVisible(
    ScrollToVisibleType scrollType
)
Visual Basic
Public Sub ScrollToVisible ( _
    scrollType As ScrollToVisibleType _
)
Visual C++
public:
void ScrollToVisible(
    ScrollToVisibleType scrollType
)

Parameters

scrollType
Type: ArtOfTest.WebAii.Core..::..ScrollToVisibleType
Where in the window the the element should be after scrolling

See Also

FrameworkElement Class
ScrollToVisible Overload
ArtOfTest.WebAii.Silverlight Namespace


SetAttachedProperty(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetAttachedProperty<(Of <(<'T>)>)> Method
FrameworkElement Class See Also Send Feedback
Set value of attached property.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetAttachedProperty<T>(
    string propertyOwner,
    string propertyName,
    T value
)
Visual Basic
Public Sub SetAttachedProperty(Of T) ( _
    propertyOwner As String, _
    propertyName As String, _
    value As T _
)
Visual C++
public:
generic<typename T>
void SetAttachedProperty(
    String^ propertyOwner,
    String^ propertyName,
    T value
)

Parameters

propertyOwner
Type: System..::..String
The type name of attached property owner.
propertyName
Type: System..::..String
The name of the property.
value
Type: T
The value to be set.

Type Parameters

T
The property value type.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


SetClosingTag Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetClosingTag Method
FrameworkElement Class See Also Send Feedback
Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetClosingTag(
    ITargetElement closingElement
)
Visual Basic
Public Sub SetClosingTag ( _
    closingElement As ITargetElement _
)
Visual C++
public:
virtual void SetClosingTag(
    ITargetElement^ closingElement
) sealed

Parameters

closingElement
Type: ArtOfTest.Common..::..ITargetElement
Whether or not to mark this element as a closing type of element.

Implements

ITargetElement..::..SetClosingTag(ITargetElement)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


SetDepth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetDepth Method
FrameworkElement Class See Also Send Feedback
Set the depth of this framework element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetDepth(
    int depth
)
Visual Basic
Public Sub SetDepth ( _
    depth As Integer _
)
Visual C++
public:
virtual void SetDepth(
    int depth
) sealed

Parameters

depth
Type: System..::..Int32
The depth to set it to.

Implements

ITargetElement..::..SetDepth(Int32)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


SetFindInfo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetFindInfo Method
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.SetFindInfo(ArtOfTest.WebAii.Silverlight.VisualFindInfo)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetFindInfo(
    VisualFindInfo findInfo
)
Visual Basic
Public Sub SetFindInfo ( _
    findInfo As VisualFindInfo _
)
Visual C++
public:
virtual void SetFindInfo(
    VisualFindInfo^ findInfo
) sealed

Parameters

findInfo
Type: ArtOfTest.WebAii.Silverlight..::..VisualFindInfo

[Missing <param name="findInfo"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.SetFindInfo(ArtOfTest.WebAii.Silverlight.VisualFindInfo)"]

Implements

IFrameworkElement..::..SetFindInfo(VisualFindInfo)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


SetFocus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetFocus Method
FrameworkElement Class See Also Send Feedback
Sets keyboard focus to this element

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetFocus()
Visual Basic
Public Sub SetFocus
Visual C++
public:
virtual void SetFocus() sealed

Return Value

Whether focus was successfully set to this element

Implements

IFrameworkElement..::..SetFocus()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


SetParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetParent Method
FrameworkElement Class See Also Send Feedback
Set the parent object of this framework element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetParent(
    ITargetElement parent
)
Visual Basic
Public Sub SetParent ( _
    parent As ITargetElement _
)
Visual C++
public:
virtual void SetParent(
    ITargetElement^ parent
) sealed

Parameters

parent
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="parent"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.SetParent(ArtOfTest.Common.ITargetElement)"]

Implements

ITargetElement..::..SetParent(ITargetElement)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetProperty Method
FrameworkElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf).
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

FrameworkElement Class
FrameworkElement Members
ArtOfTest.WebAii.Silverlight Namespace


SetProperty Method (String, Object)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetProperty Method (String, Object)
FrameworkElement Class See Also Send Feedback
Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf).

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetProperty(
    string name,
    Object value
)
Visual Basic
Public Sub SetProperty ( _
    name As String, _
    value As Object _
)
Visual C++
public:
virtual void SetProperty(
    String^ name,
    Object^ value
) sealed

Parameters

name
Type: System..::..String
The property name.
value
Type: System..::..Object
The new property name.

Implements

IFrameworkElement..::..SetProperty(String, Object)

See Also

FrameworkElement Class
SetProperty Overload
ArtOfTest.WebAii.Silverlight Namespace


SetProxy Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetProxy Method
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.SetProxy(System.Boolean)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetProxy(
    bool isProxy
)
Visual Basic
Public Sub SetProxy ( _
    isProxy As Boolean _
)
Visual C++
public:
virtual void SetProxy(
    bool isProxy
) sealed

Parameters

isProxy
Type: System..::..Boolean

[Missing <param name="isProxy"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.SetProxy(System.Boolean)"]

Implements

IFrameworkElement..::..SetProxy(Boolean)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


SetUid Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetUid Method
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.SetUid(System.Int32)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetUid(
    int uid
)
Visual Basic
Public Sub SetUid ( _
    uid As Integer _
)
Visual C++
public:
virtual void SetUid(
    int uid
) sealed

Parameters

uid
Type: System..::..Int32

[Missing <param name="uid"/> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.SetUid(System.Int32)"]

Implements

IFrameworkElement..::..SetUid(Int32)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


SetXamlTag Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..SetXamlTag Method
FrameworkElement Class See Also Send Feedback
Set the Xaml tag name.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetXamlTag(
    string tag
)
Visual Basic
Public Sub SetXamlTag ( _
    tag As String _
)
Visual C++
public:
virtual void SetXamlTag(
    String^ tag
) sealed

Parameters

tag
Type: System..::..String
The tag name.

Implements

IFrameworkElement..::..SetXamlTag(String)

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ToRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ToRealObject Method
FrameworkElement Class See Also Send Feedback
Used internally to translate object across application boundaries

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Object ToRealObject()
Visual Basic
Public Overrides Function ToRealObject As Object
Visual C++
public:
virtual Object^ ToRealObject() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.ToRealObject"]

Implements

IPeerConverter..::..ToRealObject()()()()

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ToString Method
FrameworkElement Class See Also Send Feedback
Gets the string representation of this FrameworkElement object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.FrameworkElement.ToString"]

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ToXml Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ToXml Method
FrameworkElement Class See Also Send Feedback
Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ToXml()
Visual Basic
Public Function ToXml As String
Visual C++
public:
String^ ToXml()

Return Value

The Xml string.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ValidateMouseLocationIfNeeded Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ValidateMouseLocationIfNeeded Method
FrameworkElement Class See Also Send Feedback
Validate that the current location of the mouse is inside the browser window.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ValidateMouseLocationIfNeeded(
    Point point
)
Visual Basic
Public Sub ValidateMouseLocationIfNeeded ( _
    point As Point _
)
Visual C++
public:
void ValidateMouseLocationIfNeeded(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point
The coordinates of the mouse.

Exceptions

Exception | Condition
System..::..InvalidOperationException | Thrown when the mouse is outside of the browser window.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ValidateType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ValidateType Method
FrameworkElement Class See Also Send Feedback
Validate a control type with the control tag name.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool ValidateType(
    Type type,
    string tagName
)
Visual Basic
Protected Function ValidateType ( _
    type As Type, _
    tagName As String _
) As Boolean
Visual C++
protected:
bool ValidateType(
    Type^ type,
    String^ tagName
)

Parameters

type
Type: System..::..Type
The control type.
tagName
Type: System..::..String
The tag name to check

Return Value

True/False whether the tag name matches the type.

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


FrameworkElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement Properties
FrameworkElement Class See Also Send Feedback

The FrameworkElement type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement.
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree.
Public property | ActualHeight | Gets the value of the ActualHeight of this element.
Public property | ActualWidth | Gets the value of the ActualWidth of this element.
Public property | Application | Get the Application object that owns this element.
Public property | AutomationId | Gets the AutomationId set on this element if any.
Public property | Children | Gets the visual children of this element.
Public property | Clip | Gets / Sets the value of the Clip of this element.
Public property | ComputedVisibility |
Public property | Depth | Get the depth of this element in the Visual Tree.
Public property | DesiredSize | Gets the value of the DesiredSize of this element.
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions
Public property | Find | Get the Find object used to search the visual children of this element.
Public property | Height | Gets / Sets the value of the Height of this element.
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element.
Public property | Host | Returns the AutomationHost for this object.
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element.
Public property | IsTestRegion | Gets whether or not this element is contained in a test region.
Public property | IsVisible |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized.
Public property | Margin | Gets / Sets the value of the Margin of this element.
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element.
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element.
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element.
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element.
Public property | Name | Gets the value of the Name of this element.
Public property | Opacity | Gets / Sets the value of the Opacity of this element.
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element.
Public property | ParsedElement | Get the parsed element under this object.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element.
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element.
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element.
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree.
Public property | TechnologyType | Get the technology type of this element.
Public property | Text | Gets the element text, the first text block text by default.
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements.
Public property | TextLiteralContent | Gets the literal text content of this framework element if any.
Public property | ToolTipText | The text of the tooltip specified for this element
Public property | Uid |
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element.
Public property | Visibility | Gets / Sets the value of the Visibility of this element.
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree.
Public property | Width | Gets / Sets the value of the Width of this element.
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal.
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


AbsoluteSiblingTagIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..AbsoluteSiblingTagIndex Property
FrameworkElement Class See Also Send Feedback
Get the sibling tag index of this FrameworkElement.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AbsoluteSiblingTagIndex { get; }
Visual Basic
Public ReadOnly Property AbsoluteSiblingTagIndex As Integer
    Get
Visual C++
public:
virtual property int AbsoluteSiblingTagIndex {
    int get () sealed;
}

Implements

IFrameworkElement..::..AbsoluteSiblingTagIndex

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


AbsoluteTagIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..AbsoluteTagIndex Property
FrameworkElement Class See Also Send Feedback
Get the absolute index of this Xaml tag in the Visual Tree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int AbsoluteTagIndex { get; }
Visual Basic
Public ReadOnly Property AbsoluteTagIndex As Integer
    Get
Visual C++
public:
property int AbsoluteTagIndex {
    int get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ActualHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ActualHeight Property
FrameworkElement Class See Also Send Feedback
Gets the value of the ActualHeight of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ActualHeight { get; }
Visual Basic
Public ReadOnly Property ActualHeight As Double
    Get
Visual C++
public:
virtual property double ActualHeight {
    double get () sealed;
}

Implements

IFrameworkElement..::..ActualHeight

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ActualWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ActualWidth Property
FrameworkElement Class See Also Send Feedback
Gets the value of the ActualWidth of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ActualWidth { get; }
Visual Basic
Public ReadOnly Property ActualWidth As Double
    Get
Visual C++
public:
virtual property double ActualWidth {
    double get () sealed;
}

Implements

IFrameworkElement..::..ActualWidth

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Application Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Application Property
FrameworkElement Class See Also Send Feedback
Get the Application object that owns this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IApplication Application { get; }
Visual Basic
Public ReadOnly Property Application As IApplication
    Get
Visual C++
public:
property IApplication^ Application {
    IApplication^ get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


AutomationId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..AutomationId Property
FrameworkElement Class See Also Send Feedback
Gets the AutomationId set on this element if any.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string AutomationId { get; }
Visual Basic
Public ReadOnly Property AutomationId As String
    Get
Visual C++
public:
property String^ AutomationId {
    String^ get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Children Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Children Property
FrameworkElement Class See Also Send Feedback
Gets the visual children of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> Children { get; }
Visual Basic
Public ReadOnly Property Children As IList(Of FrameworkElement)
    Get
Visual C++
public:
property IList<FrameworkElement^>^ Children {
    IList<FrameworkElement^>^ get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Clip Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Clip Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the Clip of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Geometry Clip { get; set; }
Visual Basic
Public Property Clip As Geometry
    Get
    Set
Visual C++
public:
property Geometry^ Clip {
    Geometry^ get ();
    void set (Geometry^ value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ComputedVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ComputedVisibility Property
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.FrameworkElement.ComputedVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Visibility ComputedVisibility { get; }
Visual Basic
Public Overridable ReadOnly Property ComputedVisibility As Visibility
    Get
Visual C++
public:
virtual property Visibility ComputedVisibility {
    Visibility get ();
}

Implements

IFrameworkElement..::..ComputedVisibility

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Depth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Depth Property
FrameworkElement Class See Also Send Feedback
Get the depth of this element in the Visual Tree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Depth { get; }
Visual Basic
Public ReadOnly Property Depth As Integer
    Get
Visual C++
public:
virtual property int Depth {
    int get () sealed;
}

Implements

ITargetElement..::..Depth

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


DesiredSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..DesiredSize Property
FrameworkElement Class See Also Send Feedback
Gets the value of the DesiredSize of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Size DesiredSize { get; }
Visual Basic
Public ReadOnly Property DesiredSize As Size
    Get
Visual C++
public:
property Size^ DesiredSize {
    Size^ get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


EnableValidateMouseLocation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..EnableValidateMouseLocation Property
FrameworkElement Class See Also Send Feedback
Enables or disables the validation of mouse click locations before performing mouse actions

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableValidateMouseLocation { get; set; }
Visual Basic
Public Property EnableValidateMouseLocation As Boolean
    Get
    Set
Visual C++
public:
property bool EnableValidateMouseLocation {
    bool get ();
    void set (bool value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Find Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Find Property
FrameworkElement Class See Also Send Feedback
Get the Find object used to search the visual children of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualFind Find { get; }
Visual Basic
Public ReadOnly Property Find As VisualFind
    Get
Visual C++
public:
virtual property VisualFind^ Find {
    VisualFind^ get () sealed;
}

Implements

IFrameworkElement..::..Find

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Height Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Height Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the Height of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


HorizontalAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..HorizontalAlignment Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the HorizontalAlignment of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HorizontalAlignment HorizontalAlignment { get; set; }
Visual Basic
Public Property HorizontalAlignment As HorizontalAlignment
    Get
    Set
Visual C++
public:
property HorizontalAlignment HorizontalAlignment {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Host Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Host Property
FrameworkElement Class See Also Send Feedback
Returns the AutomationHost for this object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IAutomationHost Host { get; }
Visual Basic
Public ReadOnly Property Host As IAutomationHost
    Get
Visual C++
public:
virtual property IAutomationHost^ Host {
    IAutomationHost^ get () sealed;
}

Implements

ITargetElement..::..Host

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


IsHitTestVisible Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsHitTestVisible Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the IsHitTestVisible of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsHitTestVisible { get; set; }
Visual Basic
Public Property IsHitTestVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsHitTestVisible {
    bool get ();
    void set (bool value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


IsTestRegion Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsTestRegion Property
FrameworkElement Class See Also Send Feedback
Gets whether or not this element is contained in a test region.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTestRegion { get; }
Visual Basic
Public ReadOnly Property IsTestRegion As Boolean
    Get
Visual C++
public:
virtual property bool IsTestRegion {
    bool get () sealed;
}

Implements

ITargetElement..::..IsTestRegion

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


IsVisible Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..IsVisible Property
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.FrameworkElement.IsVisible"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsVisible { get; }
Visual Basic
Public Overridable ReadOnly Property IsVisible As Boolean
    Get
Visual C++
public:
virtual property bool IsVisible {
    bool get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Mappings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Mappings Property
FrameworkElement Class See Also Send Feedback
Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual MappingsCollection Mappings { get; }
Visual Basic
Public Overridable ReadOnly Property Mappings As MappingsCollection
    Get
Visual C++
public:
virtual property MappingsCollection^ Mappings {
    MappingsCollection^ get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Margin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Margin Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the Margin of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness Margin { get; set; }
Visual Basic
Public Property Margin As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ Margin {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MaxHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MaxHeight Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the MaxHeight of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxHeight { get; set; }
Visual Basic
Public Property MaxHeight As Double
    Get
    Set
Visual C++
public:
property double MaxHeight {
    double get ();
    void set (double value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MaxWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MaxWidth Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the MaxWidth of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxWidth { get; set; }
Visual Basic
Public Property MaxWidth As Double
    Get
    Set
Visual C++
public:
property double MaxWidth {
    double get ();
    void set (double value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MinHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MinHeight Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the MinHeight of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinHeight { get; set; }
Visual Basic
Public Property MinHeight As Double
    Get
    Set
Visual C++
public:
property double MinHeight {
    double get ();
    void set (double value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


MinWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..MinWidth Property
FrameworkElement Class See Also Send Feedback
Gets /Sets the value of the MinWidth of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinWidth { get; set; }
Visual Basic
Public Property MinWidth As Double
    Get
    Set
Visual C++
public:
property double MinWidth {
    double get ();
    void set (double value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Name Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Name Property
FrameworkElement Class See Also Send Feedback
Gets the value of the Name of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

IFrameworkElement..::..Name

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Opacity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Opacity Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the Opacity of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Opacity { get; set; }
Visual Basic
Public Property Opacity As Double
    Get
    Set
Visual C++
public:
property double Opacity {
    double get ();
    void set (double value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


OpacityMask Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..OpacityMask Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the OpacityMask of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush OpacityMask { get; set; }
Visual Basic
Public Property OpacityMask As Brush
    Get
    Set
Visual C++
public:
property Brush^ OpacityMask {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ParsedElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ParsedElement Property
FrameworkElement Class See Also Send Feedback
Get the parsed element under this object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ParsedElement ParsedElement { get; }
Visual Basic
Public ReadOnly Property ParsedElement As ParsedElement
    Get
Visual C++
public:
virtual property ParsedElement^ ParsedElement {
    ParsedElement^ get () sealed;
}

Implements

ITargetElement..::..ParsedElement

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


RenderSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..RenderSize Property
FrameworkElement Class See Also Send Feedback
Gets the value of the RenderSize of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Size RenderSize { get; }
Visual Basic
Public ReadOnly Property RenderSize As Size
    Get
Visual C++
public:
property Size^ RenderSize {
    Size^ get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


RenderTransform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..RenderTransform Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the RenderTransform of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform RenderTransform { get; set; }
Visual Basic
Public Property RenderTransform As Transform
    Get
    Set
Visual C++
public:
property Transform^ RenderTransform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


RenderTransformOrigin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..RenderTransformOrigin Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the RenderTransformOrigin of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point RenderTransformOrigin { get; set; }
Visual Basic
Public Property RenderTransformOrigin As Point
    Get
    Set
Visual C++
public:
property Point^ RenderTransformOrigin {
    Point^ get ();
    void set (Point^ value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


TagNameIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..TagNameIndex Property
FrameworkElement Class See Also Send Feedback
Gets the tag name index of the xaml tag name in the visual tree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TagNameIndex { get; }
Visual Basic
Public ReadOnly Property TagNameIndex As Integer
    Get
Visual C++
public:
property int TagNameIndex {
    int get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


TechnologyType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..TechnologyType Property
FrameworkElement Class See Also Send Feedback
Get the technology type of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual TechnologyType TechnologyType { get; }
Visual Basic
Public Overridable ReadOnly Property TechnologyType As TechnologyType
    Get
Visual C++
public:
virtual property TechnologyType TechnologyType {
    TechnologyType get ();
}

Implements

ITargetElement..::..TechnologyType

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Text Property
FrameworkElement Class See Also Send Feedback
Gets the element text, the first text block text by default.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string Text { get; }
Visual Basic
Public Overridable ReadOnly Property Text As String
    Get
Visual C++
public:
virtual property String^ Text {
    String^ get ();
}

Implements

IFrameworkElement..::..Text

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


TextBlockContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..TextBlockContent Property
FrameworkElement Class See Also Send Feedback
Gets the text from all the inner TextBlock elements.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TextBlockContent { get; }
Visual Basic
Public ReadOnly Property TextBlockContent As String
    Get
Visual C++
public:
virtual property String^ TextBlockContent {
    String^ get () sealed;
}

Implements

IFrameworkElement..::..TextBlockContent

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


TextLiteralContent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..TextLiteralContent Property
FrameworkElement Class See Also Send Feedback
Gets the literal text content of this framework element if any.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string TextLiteralContent { get; }
Visual Basic
Public ReadOnly Property TextLiteralContent As String
    Get
Visual C++
public:
virtual property String^ TextLiteralContent {
    String^ get () sealed;
}

Implements

IFrameworkElement..::..TextLiteralContent

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


ToolTipText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..ToolTipText Property
FrameworkElement Class See Also Send Feedback
The text of the tooltip specified for this element

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string ToolTipText { get; }
Visual Basic
Public Overridable ReadOnly Property ToolTipText As String
    Get
Visual C++
public:
virtual property String^ ToolTipText {
    String^ get ();
}

Implements

IFrameworkElement..::..ToolTipText

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Uid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Uid Property
FrameworkElement Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.FrameworkElement.Uid"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Uid { get; }
Visual Basic
Public ReadOnly Property Uid As Integer
    Get
Visual C++
public:
virtual property int Uid {
    int get () sealed;
}

Implements

IFrameworkElement..::..Uid

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


User Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..User Property
FrameworkElement Class See Also Send Feedback
Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual UserInteraction User { get; }
Visual Basic
Public Overridable ReadOnly Property User As UserInteraction
    Get
Visual C++
public:
virtual property UserInteraction^ User {
    UserInteraction^ get ();
}

Implements

IFrameworkElement..::..User

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


VerticalAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..VerticalAlignment Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the VerticalAlignment of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VerticalAlignment VerticalAlignment { get; set; }
Visual Basic
Public Property VerticalAlignment As VerticalAlignment
    Get
    Set
Visual C++
public:
property VerticalAlignment VerticalAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Visibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Visibility Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the Visibility of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility Visibility { get; set; }
Visual Basic
Public Property Visibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility Visibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Wait Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Wait Property
FrameworkElement Class See Also Send Feedback
Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualWait Wait { get; }
Visual Basic
Public ReadOnly Property Wait As VisualWait
    Get
Visual C++
public:
virtual property VisualWait^ Wait {
    VisualWait^ get () sealed;
}

Implements

IFrameworkElement..::..Wait

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


Width Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..Width Property
FrameworkElement Class See Also Send Feedback
Gets / Sets the value of the Width of this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


XamlTag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..XamlTag Property
FrameworkElement Class See Also Send Feedback
Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string XamlTag { get; }
Visual Basic
Public Overridable ReadOnly Property XamlTag As String
    Get
Visual C++
public:
virtual property String^ XamlTag {
    String^ get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


XamlTagBase Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FrameworkElement..::..XamlTagBase Property
FrameworkElement Class See Also Send Feedback
Gets the lowest control type that the framework recognizes

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string XamlTagBase { get; }
Visual Basic
Public ReadOnly Property XamlTagBase As String
    Get
Visual C++
public:
property String^ XamlTagBase {
    String^ get ();
}

See Also

FrameworkElement Class
ArtOfTest.WebAii.Silverlight Namespace


GlobalInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlobalInfo Members
GlobalInfo Class Fields See Also Send Feedback

The GlobalInfo type exposes the following members.

Fields

Name | Description
APP_UNIQUE_ID_ATTRIBUTE | The unique id attribute
IS_AUTOMATIONREADY_ATTRIBUTE | Whether the silverlight application is automation ready
VISUAL_TREE_ROOT | WebAii visual tree root string.
WEBAII_CLIENT_CONNECTED | WebAii client connected string.
WEBAII_CLIENT_ID | WebAii client ID string.
WEBAII_CLIENT_TESTMETHOD | WebAii client test method string.

See Also

GlobalInfo Class
ArtOfTest.WebAii.Silverlight Namespace


GlobalInfo Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlobalInfo Fields
GlobalInfo Class See Also Send Feedback

The GlobalInfo type exposes the following members.

Fields

Name | Description
APP_UNIQUE_ID_ATTRIBUTE | The unique id attribute
IS_AUTOMATIONREADY_ATTRIBUTE | Whether the silverlight application is automation ready
VISUAL_TREE_ROOT | WebAii visual tree root string.
WEBAII_CLIENT_CONNECTED | WebAii client connected string.
WEBAII_CLIENT_ID | WebAii client ID string.
WEBAII_CLIENT_TESTMETHOD | WebAii client test method string.

See Also

GlobalInfo Class
ArtOfTest.WebAii.Silverlight Namespace


APP_UNIQUE_ID_ATTRIBUTE Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlobalInfo..::..APP_UNIQUE_ID_ATTRIBUTE Field
GlobalInfo Class See Also Send Feedback
The unique id attribute

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string APP_UNIQUE_ID_ATTRIBUTE
Visual Basic
Public Shared ReadOnly APP_UNIQUE_ID_ATTRIBUTE As String
Visual C++
public:
static initonly String^ APP_UNIQUE_ID_ATTRIBUTE

See Also

GlobalInfo Class
ArtOfTest.WebAii.Silverlight Namespace


IS_AUTOMATIONREADY_ATTRIBUTE Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlobalInfo..::..IS_AUTOMATIONREADY_ATTRIBUTE Field
GlobalInfo Class See Also Send Feedback
Whether the silverlight application is automation ready

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string IS_AUTOMATIONREADY_ATTRIBUTE
Visual Basic
Public Shared ReadOnly IS_AUTOMATIONREADY_ATTRIBUTE As String
Visual C++
public:
static initonly String^ IS_AUTOMATIONREADY_ATTRIBUTE

See Also

GlobalInfo Class
ArtOfTest.WebAii.Silverlight Namespace


VISUAL_TREE_ROOT Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlobalInfo..::..VISUAL_TREE_ROOT Field
GlobalInfo Class See Also Send Feedback
WebAii visual tree root string.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string VISUAL_TREE_ROOT
Visual Basic
Public Shared ReadOnly VISUAL_TREE_ROOT As String
Visual C++
public:
static initonly String^ VISUAL_TREE_ROOT

See Also

GlobalInfo Class
ArtOfTest.WebAii.Silverlight Namespace


WEBAII_CLIENT_CONNECTED Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlobalInfo..::..WEBAII_CLIENT_CONNECTED Field
GlobalInfo Class See Also Send Feedback
WebAii client connected string.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string WEBAII_CLIENT_CONNECTED
Visual Basic
Public Shared ReadOnly WEBAII_CLIENT_CONNECTED As String
Visual C++
public:
static initonly String^ WEBAII_CLIENT_CONNECTED

See Also

GlobalInfo Class
ArtOfTest.WebAii.Silverlight Namespace


WEBAII_CLIENT_ID Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlobalInfo..::..WEBAII_CLIENT_ID Field
GlobalInfo Class See Also Send Feedback
WebAii client ID string.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string WEBAII_CLIENT_ID
Visual Basic
Public Shared ReadOnly WEBAII_CLIENT_ID As String
Visual C++
public:
static initonly String^ WEBAII_CLIENT_ID

See Also

GlobalInfo Class
ArtOfTest.WebAii.Silverlight Namespace


WEBAII_CLIENT_TESTMETHOD Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GlobalInfo..::..WEBAII_CLIENT_TESTMETHOD Field
GlobalInfo Class See Also Send Feedback
WebAii client test method string.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string WEBAII_CLIENT_TESTMETHOD
Visual Basic
Public Shared ReadOnly WEBAII_CLIENT_TESTMETHOD As String
Visual C++
public:
static initonly String^ WEBAII_CLIENT_TESTMETHOD

See Also

GlobalInfo Class
ArtOfTest.WebAii.Silverlight Namespace


IApplication Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication Members
IApplication Interface Methods Properties See Also Send Feedback

The IApplication type exposes the following members.

Methods

 | Name | Description
Public method | Capture()()()() | Return a bitmap of the host (Inherited from IAutomationHost.)
Public method | Capture(FrameworkElement) | Captures the image of an element
Public method | ElementFromPoint |
Public method | EnsureElementClickable |
Public method | EnsureStateIsCurrent | Force the automation host to be up to date. (i.e. RefreshDomTree in Html) (Inherited from IAutomationHost.)
Public method | GetChildHosts | Return a list of child automation host that this host contains. (Inherited from IAutomationHost.)
Public method | GetHostRoot | Return the root target element of this host. (Inherited from IAutomationHost.)
Public method | GetScreenRectangle | Gets the rectangle of the element in screen coordinates
Public method | GetSubtreeFriendlyName | Gets a friendly name for the specified sub-tree of this IApplication
Public method | GetToolTipText | Gets the text of a tooltip on the element
Public method | LocateAllInHost | Find all target elements from the root of this host. (Inherited from ISupportSearchHost.)
Public method | LocateInHost | Find a target element from the root of this host. (Inherited from ISupportSearchHost.)
Public method | PopulateVisualTree | Ensures that the IApplication's visual tree is in a valid state
Public method | RefreshVisualTrees |
Public method | ResizeContainer | Resizes the browser or application window so its content rectangle is (x, y, width, height) if possible. If that rectangle doesn't fit on the screen, then try it at the upper left corner of the screen and as close to that size as possible.
Public method | ScrollElementVisible | Scrolls a control into view
Public method | SetWindowFocus | Makes the window containing this host active (Inherited from IAutomationHost.)
Public method | UpdateInterHostLinks | Ensures that any links between hosts are up-to-date (Infrastructure use only) (Inherited from IAutomationHost.)
Public method | ValidateMouseLocation | Validate the location of the mouse. (Inherited from IAutomationHost.)

Properties

 | Name | Description
Public property | Bounds | Gets the rectangular bounds of this app.
Public property | Desktop | Gets the Desktop object for this app.
Public property | EnableValidateMouseLocation | Whether to validate that the mouse will be within the application's bounds before performing a mouse action
Public property | Find |
Public property | FriendlyName | A friendly name that represents this host. (Inherited from IAutomationHost.)
Public property | IsConnected | Checks if we're connected to the automation client
Public property | IsRecordingHost |
Public property | ManagedProxy | Gets the ManagedProxy for this app.
Public property | Popups |
Public property | StateHashCode | Returns a hashcode that uniquely identifies the current content state of this host. (Inherited from IAutomationHost.)
Public property | TechnologyType | Get the technology type of the host (Inherited from IAutomationHost.)
Public property | UniqueId | Returns a unique id that identifies this host (Inherited from IAutomationHost.)
Public property | VisualTree | Gets the VisualTree of this app.

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


IApplication Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication Methods
IApplication Interface See Also Send Feedback

The IApplication type exposes the following members.

Methods

 | Name | Description
Public method | Capture()()()() | Return a bitmap of the host (Inherited from IAutomationHost.)
Public method | Capture(FrameworkElement) | Captures the image of an element
Public method | ElementFromPoint |
Public method | EnsureElementClickable |
Public method | EnsureStateIsCurrent | Force the automation host to be up to date. (i.e. RefreshDomTree in Html) (Inherited from IAutomationHost.)
Public method | GetChildHosts | Return a list of child automation host that this host contains. (Inherited from IAutomationHost.)
Public method | GetHostRoot | Return the root target element of this host. (Inherited from IAutomationHost.)
Public method | GetScreenRectangle | Gets the rectangle of the element in screen coordinates
Public method | GetSubtreeFriendlyName | Gets a friendly name for the specified sub-tree of this IApplication
Public method | GetToolTipText | Gets the text of a tooltip on the element
Public method | LocateAllInHost | Find all target elements from the root of this host. (Inherited from ISupportSearchHost.)
Public method | LocateInHost | Find a target element from the root of this host. (Inherited from ISupportSearchHost.)
Public method | PopulateVisualTree | Ensures that the IApplication's visual tree is in a valid state
Public method | RefreshVisualTrees |
Public method | ResizeContainer | Resizes the browser or application window so its content rectangle is (x, y, width, height) if possible. If that rectangle doesn't fit on the screen, then try it at the upper left corner of the screen and as close to that size as possible.
Public method | ScrollElementVisible | Scrolls a control into view
Public method | SetWindowFocus | Makes the window containing this host active (Inherited from IAutomationHost.)
Public method | UpdateInterHostLinks | Ensures that any links between hosts are up-to-date (Infrastructure use only) (Inherited from IAutomationHost.)
Public method | ValidateMouseLocation | Validate the location of the mouse. (Inherited from IAutomationHost.)

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..Capture Method
IApplication Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Return a bitmap of the host (Inherited from IAutomationHost.)
Public method | Capture(FrameworkElement) | Captures the image of an element

See Also

IApplication Interface
IApplication Members
ArtOfTest.WebAii.Silverlight Namespace


Capture Method (FrameworkElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..Capture Method (FrameworkElement)
IApplication Interface See Also Send Feedback
Captures the image of an element

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Bitmap Capture(
    FrameworkElement element
)
Visual Basic
Function Capture ( _
    element As FrameworkElement _
) As Bitmap
Visual C++
Bitmap^ Capture(
    FrameworkElement^ element
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The element to capture an image of

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.Capture(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

IApplication Interface
Capture Overload
ArtOfTest.WebAii.Silverlight Namespace


ElementFromPoint Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..ElementFromPoint Method
IApplication Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ElementFromPoint(System.Int32,System.Int32)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
FrameworkElement ElementFromPoint(
    int x,
    int y
)
Visual Basic
Function ElementFromPoint ( _
    x As Integer, _
    y As Integer _
) As FrameworkElement
Visual C++
FrameworkElement^ ElementFromPoint(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ElementFromPoint(System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ElementFromPoint(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ElementFromPoint(System.Int32,System.Int32)"]

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


EnsureElementClickable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..EnsureElementClickable Method
IApplication Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.EnsureElementClickable(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void EnsureElementClickable(
    FrameworkElement element
)
Visual Basic
Sub EnsureElementClickable ( _
    element As FrameworkElement _
)
Visual C++
void EnsureElementClickable(
    FrameworkElement^ element
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.EnsureElementClickable(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


GetScreenRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..GetScreenRectangle Method
IApplication Interface See Also Send Feedback
Gets the rectangle of the element in screen coordinates

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Rectangle GetScreenRectangle(
    FrameworkElement element
)
Visual Basic
Function GetScreenRectangle ( _
    element As FrameworkElement _
) As Rectangle
Visual C++
Rectangle GetScreenRectangle(
    FrameworkElement^ element
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.GetScreenRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.GetScreenRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


GetSubtreeFriendlyName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..GetSubtreeFriendlyName Method
IApplication Interface See Also Send Feedback
Gets a friendly name for the specified sub-tree of this IApplication

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetSubtreeFriendlyName(
    VisualTree subtree
)
Visual Basic
Function GetSubtreeFriendlyName ( _
    subtree As VisualTree _
) As String
Visual C++
String^ GetSubtreeFriendlyName(
    VisualTree^ subtree
)

Parameters

subtree
Type: ArtOfTest.WebAii.Silverlight..::..VisualTree
The sub-tree we want the friendly name of

Return Value

The sub-tree's friendly name

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


GetToolTipText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..GetToolTipText Method
IApplication Interface See Also Send Feedback
Gets the text of a tooltip on the element

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetToolTipText(
    FrameworkElement element
)
Visual Basic
Function GetToolTipText ( _
    element As FrameworkElement _
) As String
Visual C++
String^ GetToolTipText(
    FrameworkElement^ element
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.GetToolTipText(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

Any text contained by the element's tooltip, or null if the element has no toolip

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


PopulateVisualTree Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..PopulateVisualTree Method
IApplication Interface See Also Send Feedback
Ensures that the IApplication's visual tree is in a valid state

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
VisualTree PopulateVisualTree()
Visual Basic
Function PopulateVisualTree As VisualTree
Visual C++
VisualTree^ PopulateVisualTree()

Return Value

A valid VisualTree

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


RefreshVisualTrees Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..RefreshVisualTrees Method
IApplication Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.RefreshVisualTrees"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void RefreshVisualTrees()
Visual Basic
Sub RefreshVisualTrees
Visual C++
void RefreshVisualTrees()

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


ResizeContainer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..ResizeContainer Method
IApplication Interface See Also Send Feedback
Resizes the browser or application window so its content rectangle is (x, y, width, height) if possible. If that rectangle doesn't fit on the screen, then try it at the upper left corner of the screen and as close to that size as possible.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void ResizeContainer(
    int x,
    int y,
    int width,
    int height
)
Visual Basic
Sub ResizeContainer ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
Visual C++
void ResizeContainer(
    int x,
    int y,
    int width,
    int height
)

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


ScrollElementVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..ScrollElementVisible Method
IApplication Interface See Also Send Feedback
Scrolls a control into view

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void ScrollElementVisible(
    FrameworkElement element,
    ScrollToVisibleType scrollType
)
Visual Basic
Sub ScrollElementVisible ( _
    element As FrameworkElement, _
    scrollType As ScrollToVisibleType _
)
Visual C++
void ScrollElementVisible(
    FrameworkElement^ element,
    ScrollToVisibleType scrollType
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ScrollElementVisible(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Core.ScrollToVisibleType)"]

scrollType
Type: ArtOfTest.WebAii.Core..::..ScrollToVisibleType

[Missing <param name="scrollType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.IApplication.ScrollElementVisible(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Core.ScrollToVisibleType)"]

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


IApplication Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication Properties
IApplication Interface See Also Send Feedback

The IApplication type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Gets the rectangular bounds of this app.
Public property | Desktop | Gets the Desktop object for this app.
Public property | EnableValidateMouseLocation | Whether to validate that the mouse will be within the application's bounds before performing a mouse action
Public property | Find |
Public property | FriendlyName | A friendly name that represents this host. (Inherited from IAutomationHost.)
Public property | IsConnected | Checks if we're connected to the automation client
Public property | IsRecordingHost |
Public property | ManagedProxy | Gets the ManagedProxy for this app.
Public property | Popups |
Public property | StateHashCode | Returns a hashcode that uniquely identifies the current content state of this host. (Inherited from IAutomationHost.)
Public property | TechnologyType | Get the technology type of the host (Inherited from IAutomationHost.)
Public property | UniqueId | Returns a unique id that identifies this host (Inherited from IAutomationHost.)
Public property | VisualTree | Gets the VisualTree of this app.

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


Bounds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..Bounds Property
IApplication Interface See Also Send Feedback
Gets the rectangular bounds of this app.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Rectangle Bounds { get; }
Visual Basic
ReadOnly Property Bounds As Rectangle
    Get
Visual C++
property Rectangle Bounds {
    Rectangle get ();
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


Desktop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..Desktop Property
IApplication Interface See Also Send Feedback
Gets the Desktop object for this app.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Desktop Desktop { get; }
Visual Basic
ReadOnly Property Desktop As Desktop
    Get
Visual C++
property Desktop^ Desktop {
    Desktop^ get ();
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


EnableValidateMouseLocation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..EnableValidateMouseLocation Property
IApplication Interface See Also Send Feedback
Whether to validate that the mouse will be within the application's bounds before performing a mouse action

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool EnableValidateMouseLocation { get; set; }
Visual Basic
Property EnableValidateMouseLocation As Boolean
    Get
    Set
Visual C++
property bool EnableValidateMouseLocation {
    bool get ();
    void set (bool value);
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


Find Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..Find Property
IApplication Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.IApplication.Find"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
VisualFind Find { get; }
Visual Basic
ReadOnly Property Find As VisualFind
    Get
Visual C++
property VisualFind^ Find {
    VisualFind^ get ();
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


IsConnected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..IsConnected Property
IApplication Interface See Also Send Feedback
Checks if we're connected to the automation client

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsConnected { get; }
Visual Basic
ReadOnly Property IsConnected As Boolean
    Get
Visual C++
property bool IsConnected {
    bool get ();
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


IsRecordingHost Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..IsRecordingHost Property
IApplication Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.IApplication.IsRecordingHost"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsRecordingHost { get; }
Visual Basic
ReadOnly Property IsRecordingHost As Boolean
    Get
Visual C++
property bool IsRecordingHost {
    bool get ();
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


ManagedProxy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..ManagedProxy Property
IApplication Interface See Also Send Feedback
Gets the ManagedProxy for this app.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
ICommunicationProxy ManagedProxy { get; }
Visual Basic
ReadOnly Property ManagedProxy As ICommunicationProxy
    Get
Visual C++
property ICommunicationProxy^ ManagedProxy {
    ICommunicationProxy^ get ();
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


Popups Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..Popups Property
IApplication Interface See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.IApplication.Popups"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IList<VisualTreeHost> Popups { get; }
Visual Basic
ReadOnly Property Popups As IList(Of VisualTreeHost)
    Get
Visual C++
property IList<VisualTreeHost^>^ Popups {
    IList<VisualTreeHost^>^ get ();
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


VisualTree Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IApplication..::..VisualTree Property
IApplication Interface See Also Send Feedback
Gets the VisualTree of this app.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
VisualTree VisualTree { get; }
Visual Basic
ReadOnly Property VisualTree As VisualTree
    Get
Visual C++
property VisualTree^ VisualTree {
    VisualTree^ get ();
}

See Also

IApplication Interface
ArtOfTest.WebAii.Silverlight Namespace


IAutomationPeer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer Members
IAutomationPeer Interface Methods Properties See Also Send Feedback

The IAutomationPeer type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign the reference of this peer.
Public method | Deserialize | Deserialize this object from a string.
Public method | FromRealObject | Converts a real object to this object. (Inherited from IPeerConverter.)
Public method | GetRealType | Gets the real object type that this peer represents.
Public method | Serialize | Serialize this automation peer to a string.
Public method | ToRealObject | Convert this object to a real object. (Inherited from IPeerConverter.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag
Public property | Reference | Gets or sets the automation reference of this peer.

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


IAutomationPeer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer Methods
IAutomationPeer Interface See Also Send Feedback

The IAutomationPeer type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign the reference of this peer.
Public method | Deserialize | Deserialize this object from a string.
Public method | FromRealObject | Converts a real object to this object. (Inherited from IPeerConverter.)
Public method | GetRealType | Gets the real object type that this peer represents.
Public method | Serialize | Serialize this automation peer to a string.
Public method | ToRealObject | Convert this object to a real object. (Inherited from IPeerConverter.)

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer..::..AssignReference Method
IAutomationPeer Interface See Also Send Feedback
Assign the reference of this peer.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void AssignReference(
    AutomationReference reference
)
Visual Basic
Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
void AssignReference(
    AutomationReference^ reference
)

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The AutomationReference that corresponds to this peer

Return Value

True/False whether the assignment succeeded.

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


Deserialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer..::..Deserialize Method
IAutomationPeer Interface See Also Send Feedback
Deserialize this object from a string.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Object Deserialize(
    string objectString
)
Visual Basic
Function Deserialize ( _
    objectString As String _
) As Object
Visual C++
Object^ Deserialize(
    String^ objectString
)

Parameters

objectString
Type: System..::..String
The string representation of this object.

Return Value

The deserialized object.

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer..::..GetRealType Method
IAutomationPeer Interface See Also Send Feedback
Gets the real object type that this peer represents.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetRealType()
Visual Basic
Function GetRealType As String
Visual C++
String^ GetRealType()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.IAutomationPeer.GetRealType"]

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


Serialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer..::..Serialize Method
IAutomationPeer Interface See Also Send Feedback
Serialize this automation peer to a string.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string Serialize()
Visual Basic
Function Serialize As String
Visual C++
String^ Serialize()

Return Value

The string representation of this object.

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


IAutomationPeer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer Properties
IAutomationPeer Interface See Also Send Feedback

The IAutomationPeer type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag
Public property | Reference | Gets or sets the automation reference of this peer.

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


PropertyBag Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer..::..PropertyBag Property
IAutomationPeer Interface See Also Send Feedback
The automation object property bag

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Dictionary<string, Object> PropertyBag { get; }
Visual Basic
ReadOnly Property PropertyBag As Dictionary(Of String, Object)
    Get
Visual C++
property Dictionary<String^, Object^>^ PropertyBag {
    Dictionary<String^, Object^>^ get ();
}

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


Reference Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IAutomationPeer..::..Reference Property
IAutomationPeer Interface See Also Send Feedback
Gets or sets the automation reference of this peer.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
AutomationReference Reference { get; set; }
Visual Basic
Property Reference As AutomationReference
    Get
    Set
Visual C++
property AutomationReference^ Reference {
    AutomationReference^ get ();
    void set (AutomationReference^ value);
}

See Also

IAutomationPeer Interface
ArtOfTest.WebAii.Silverlight Namespace


IClientProcessor Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IClientProcessor Members
IClientProcessor Interface Methods Properties See Also Send Feedback

The IClientProcessor type exposes the following members.

Methods

 | Name | Description
Public method | ProcessCommand | Process a request from the framework.

Properties

 | Name | Description
Public property | TestConnection | Test the connection to the Silverlight application.

See Also

IClientProcessor Interface
ArtOfTest.WebAii.Silverlight Namespace


IClientProcessor Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IClientProcessor Methods
IClientProcessor Interface See Also Send Feedback

The IClientProcessor type exposes the following members.

Methods

 | Name | Description
Public method | ProcessCommand | Process a request from the framework.

See Also

IClientProcessor Interface
ArtOfTest.WebAii.Silverlight Namespace


ProcessCommand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IClientProcessor..::..ProcessCommand Method
IClientProcessor Interface See Also Send Feedback
Process a request from the framework.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string ProcessCommand(
    string command
)
Visual Basic
Function ProcessCommand ( _
    command As String _
) As String
Visual C++
String^ ProcessCommand(
    String^ command
)

Parameters

command
Type: System..::..String
The command to process.

Return Value

The response after processing the command.

See Also

IClientProcessor Interface
ArtOfTest.WebAii.Silverlight Namespace


IClientProcessor Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IClientProcessor Properties
IClientProcessor Interface See Also Send Feedback

The IClientProcessor type exposes the following members.

Properties

 | Name | Description
Public property | TestConnection | Test the connection to the Silverlight application.

See Also

IClientProcessor Interface
ArtOfTest.WebAii.Silverlight Namespace


TestConnection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IClientProcessor..::..TestConnection Property
IClientProcessor Interface See Also Send Feedback
Test the connection to the Silverlight application.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string TestConnection { get; }
Visual Basic
ReadOnly Property TestConnection As String
    Get
Visual C++
property String^ TestConnection {
    String^ get ();
}

See Also

IClientProcessor Interface
ArtOfTest.WebAii.Silverlight Namespace


ICommunicationProxy Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy Members
ICommunicationProxy Interface Methods Properties See Also Send Feedback

The ICommunicationProxy type exposes the following members.

Methods

 | Name | Description
Public method | GetAllVisualTrees | Gets all visual trees of the application
Public method | GetPeerHashCode | Gets the hash code of the peer.
Public method | GetProperties | Gets a collection of the properties of an element whose values we are able to transfer from the application back to the testing framework.
Public method | GetProperty | Get a property for an automation peer
Public method | GetRectangle(IAutomationPeer) | Get the bounding rectangle for an automation peer
Public method | GetRectangle(IAutomationPeer, IAutomationPeer) | Get the bounding rectangle for one automation peer relative to another automation peer
Public method | GetTextRecursive | Gets the text content of an element or property. Recursively descends into children of an element and collects the text of all TextBlocks contained in it. Or if the reference is string-valued, simply returns that string
Public method | GetVirtualizedViewportOffset |
Public method | GetVisibility | Get the Visibility property value of an element, where the element inherits the Collapsed value if any of its visual tree ancestors have Visibility == Collapsed
Public method | GetVisualTree(String) | Get the full visual tree of the application
Public method | GetVisualTree(IAutomationPeer) |
Public method | GetVisualTree(String, String) | Get the full visual tree of the application, but only if it's different from the one we already have
Public method | GetVisualTree(IAutomationPeer, String) |
Public method | Highlight | Highlight an element on the surface
Public method | InvokeMethod | Invokes a method on an automation peer
Public method | PublishKnownControlTypes | Publish the known control types to the Silverlight application.
Public method | ScrollToVisible | Scroll the controls containing an element so that the element comes into view
Public method | SetProperty | Set a property for an automation peer

Properties

 | Name | Description
Public property | Application | Get the parent application object.

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


ICommunicationProxy Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy Methods
ICommunicationProxy Interface See Also Send Feedback

The ICommunicationProxy type exposes the following members.

Methods

 | Name | Description
Public method | GetAllVisualTrees | Gets all visual trees of the application
Public method | GetPeerHashCode | Gets the hash code of the peer.
Public method | GetProperties | Gets a collection of the properties of an element whose values we are able to transfer from the application back to the testing framework.
Public method | GetProperty | Get a property for an automation peer
Public method | GetRectangle(IAutomationPeer) | Get the bounding rectangle for an automation peer
Public method | GetRectangle(IAutomationPeer, IAutomationPeer) | Get the bounding rectangle for one automation peer relative to another automation peer
Public method | GetTextRecursive | Gets the text content of an element or property. Recursively descends into children of an element and collects the text of all TextBlocks contained in it. Or if the reference is string-valued, simply returns that string
Public method | GetVirtualizedViewportOffset |
Public method | GetVisibility | Get the Visibility property value of an element, where the element inherits the Collapsed value if any of its visual tree ancestors have Visibility == Collapsed
Public method | GetVisualTree(String) | Get the full visual tree of the application
Public method | GetVisualTree(IAutomationPeer) |
Public method | GetVisualTree(String, String) | Get the full visual tree of the application, but only if it's different from the one we already have
Public method | GetVisualTree(IAutomationPeer, String) |
Public method | Highlight | Highlight an element on the surface
Public method | InvokeMethod | Invokes a method on an automation peer
Public method | PublishKnownControlTypes | Publish the known control types to the Silverlight application.
Public method | ScrollToVisible | Scroll the controls containing an element so that the element comes into view
Public method | SetProperty | Set a property for an automation peer

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


GetAllVisualTrees Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetAllVisualTrees Method
ICommunicationProxy Interface See Also Send Feedback
Gets all visual trees of the application

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetAllVisualTrees()
Visual Basic
Function GetAllVisualTrees As String
Visual C++
String^ GetAllVisualTrees()

Return Value

An encoded string containing all the visual trees of the application in the format (@@[length]@@[tree])+.

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


GetPeerHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetPeerHashCode Method
ICommunicationProxy Interface See Also Send Feedback
Gets the hash code of the peer.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int GetPeerHashCode(
    IAutomationPeer peer
)
Visual Basic
Function GetPeerHashCode ( _
    peer As IAutomationPeer _
) As Integer
Visual C++
int GetPeerHashCode(
    IAutomationPeer^ peer
)

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer
The peer to get the hash code from.

Return Value

The hash code.

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


GetProperties Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetProperties Method
ICommunicationProxy Interface See Also Send Feedback
Gets a collection of the properties of an element whose values we are able to transfer from the application back to the testing framework.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Dictionary<string, string> GetProperties(
    IAutomationPeer peer
)
Visual Basic
Function GetProperties ( _
    peer As IAutomationPeer _
) As Dictionary(Of String, String)
Visual C++
Dictionary<String^, String^>^ GetProperties(
    IAutomationPeer^ peer
)

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetProperties(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetProperties(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


GetProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetProperty Method
ICommunicationProxy Interface See Also Send Feedback
Get a property for an automation peer

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Object GetProperty(
    AutomationProperty property,
    IAutomationPeer peer
)
Visual Basic
Function GetProperty ( _
    property As AutomationProperty, _
    peer As IAutomationPeer _
) As Object
Visual C++
Object^ GetProperty(
    AutomationProperty^ property,
    IAutomationPeer^ peer
)

Parameters

property
Type: ArtOfTest.WebAii.Silverlight..::..AutomationProperty

[Missing <param name="property"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetRectangle Method
ICommunicationProxy Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle(IAutomationPeer) | Get the bounding rectangle for an automation peer
Public method | GetRectangle(IAutomationPeer, IAutomationPeer) | Get the bounding rectangle for one automation peer relative to another automation peer

See Also

ICommunicationProxy Interface
ICommunicationProxy Members
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method (IAutomationPeer)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetRectangle Method (IAutomationPeer)
ICommunicationProxy Interface See Also Send Feedback
Get the bounding rectangle for an automation peer

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Object GetRectangle(
    IAutomationPeer peer
)
Visual Basic
Function GetRectangle ( _
    peer As IAutomationPeer _
) As Object
Visual C++
Object^ GetRectangle(
    IAutomationPeer^ peer
)

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetRectangle(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetRectangle(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

See Also

ICommunicationProxy Interface
GetRectangle Overload
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method (IAutomationPeer, IAutomationPeer)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetRectangle Method (IAutomationPeer, IAutomationPeer)
ICommunicationProxy Interface See Also Send Feedback
Get the bounding rectangle for one automation peer relative to another automation peer

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Object GetRectangle(
    IAutomationPeer peer,
    IAutomationPeer relativeTo
)
Visual Basic
Function GetRectangle ( _
    peer As IAutomationPeer, _
    relativeTo As IAutomationPeer _
) As Object
Visual C++
Object^ GetRectangle(
    IAutomationPeer^ peer,
    IAutomationPeer^ relativeTo
)

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer
The peer whose rectangle to get
relativeTo
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer
The reference point peer

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetRectangle(ArtOfTest.WebAii.Silverlight.IAutomationPeer,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

See Also

ICommunicationProxy Interface
GetRectangle Overload
ArtOfTest.WebAii.Silverlight Namespace


GetTextRecursive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetTextRecursive Method
ICommunicationProxy Interface See Also Send Feedback
Gets the text content of an element or property. Recursively descends into children of an element and collects the text of all TextBlocks contained in it. Or if the reference is string-valued, simply returns that string

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetTextRecursive(
    AutomationReference reference
)
Visual Basic
Function GetTextRecursive ( _
    reference As AutomationReference _
) As String
Visual C++
String^ GetTextRecursive(
    AutomationReference^ reference
)

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The target reference (element or property of an element)

Return Value

The text content, as described above

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


GetVirtualizedViewportOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetVirtualizedViewportOffset Method
ICommunicationProxy Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVirtualizedViewportOffset(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
int GetVirtualizedViewportOffset(
    IAutomationPeer peer
)
Visual Basic
Function GetVirtualizedViewportOffset ( _
    peer As IAutomationPeer _
) As Integer
Visual C++
int GetVirtualizedViewportOffset(
    IAutomationPeer^ peer
)

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVirtualizedViewportOffset(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVirtualizedViewportOffset(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


GetVisibility Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetVisibility Method
ICommunicationProxy Interface See Also Send Feedback
Get the Visibility property value of an element, where the element inherits the Collapsed value if any of its visual tree ancestors have Visibility == Collapsed

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Visibility GetVisibility(
    IAutomationPeer peer
)
Visual Basic
Function GetVisibility ( _
    peer As IAutomationPeer _
) As Visibility
Visual C++
Visibility GetVisibility(
    IAutomationPeer^ peer
)

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer
The element whose Visibility value we're retrieving

Return Value

Collapsed if the element or any of its visual tree ancestors have Visibility == Collapsed. Otherwise, Visible.

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetVisualTree Method
ICommunicationProxy Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVisualTree(String) | Get the full visual tree of the application
Public method | GetVisualTree(IAutomationPeer) |
Public method | GetVisualTree(String, String) | Get the full visual tree of the application, but only if it's different from the one we already have
Public method | GetVisualTree(IAutomationPeer, String) |

See Also

ICommunicationProxy Interface
ICommunicationProxy Members
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetVisualTree Method (String)
ICommunicationProxy Interface See Also Send Feedback
Get the full visual tree of the application

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetVisualTree(
    string startAt
)
Visual Basic
Function GetVisualTree ( _
    startAt As String _
) As String
Visual C++
String^ GetVisualTree(
    String^ startAt
)

Parameters

startAt
Type: System..::..String

[Missing <param name="startAt"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(System.String)"]

See Also

ICommunicationProxy Interface
GetVisualTree Overload
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method (IAutomationPeer)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetVisualTree Method (IAutomationPeer)
ICommunicationProxy Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetVisualTree(
    IAutomationPeer root
)
Visual Basic
Function GetVisualTree ( _
    root As IAutomationPeer _
) As String
Visual C++
String^ GetVisualTree(
    IAutomationPeer^ root
)

Parameters

root
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="root"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

See Also

ICommunicationProxy Interface
GetVisualTree Overload
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetVisualTree Method (String, String)
ICommunicationProxy Interface See Also Send Feedback
Get the full visual tree of the application, but only if it's different from the one we already have

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetVisualTree(
    string startAt,
    string hash
)
Visual Basic
Function GetVisualTree ( _
    startAt As String, _
    hash As String _
) As String
Visual C++
String^ GetVisualTree(
    String^ startAt,
    String^ hash
)

Parameters

startAt
Type: System..::..String

[Missing <param name="startAt"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(System.String,System.String)"]

hash
Type: System..::..String
The hash of the visual tree we already have

Return Value

A string representation of the visual tree, or null if the tree has not changed

See Also

ICommunicationProxy Interface
GetVisualTree Overload
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method (IAutomationPeer, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..GetVisualTree Method (IAutomationPeer, String)
ICommunicationProxy Interface See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
string GetVisualTree(
    IAutomationPeer root,
    string hash
)
Visual Basic
Function GetVisualTree ( _
    root As IAutomationPeer, _
    hash As String _
) As String
Visual C++
String^ GetVisualTree(
    IAutomationPeer^ root,
    String^ hash
)

Parameters

root
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="root"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.String)"]

hash
Type: System..::..String

[Missing <param name="hash"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.String)"]

See Also

ICommunicationProxy Interface
GetVisualTree Overload
ArtOfTest.WebAii.Silverlight Namespace


Highlight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..Highlight Method
ICommunicationProxy Interface See Also Send Feedback
Highlight an element on the surface

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Highlight(
    IAutomationPeer peer,
    bool clear
)
Visual Basic
Sub Highlight ( _
    peer As IAutomationPeer, _
    clear As Boolean _
)
Visual C++
void Highlight(
    IAutomationPeer^ peer,
    bool clear
)

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer
The element to highlight
clear
Type: System..::..Boolean
True/False whether to clear it.

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


InvokeMethod Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..InvokeMethod Method
ICommunicationProxy Interface See Also Send Feedback
Invokes a method on an automation peer

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Object InvokeMethod(
    AutomationMethod method,
    IAutomationPeer peer
)
Visual Basic
Function InvokeMethod ( _
    method As AutomationMethod, _
    peer As IAutomationPeer _
) As Object
Visual C++
Object^ InvokeMethod(
    AutomationMethod^ method,
    IAutomationPeer^ peer
)

Parameters

method
Type: ArtOfTest.WebAii.Silverlight..::..AutomationMethod

[Missing <param name="method"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.InvokeMethod(ArtOfTest.WebAii.Silverlight.AutomationMethod,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.InvokeMethod(ArtOfTest.WebAii.Silverlight.AutomationMethod,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.InvokeMethod(ArtOfTest.WebAii.Silverlight.AutomationMethod,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


PublishKnownControlTypes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..PublishKnownControlTypes Method
ICommunicationProxy Interface See Also Send Feedback
Publish the known control types to the Silverlight application.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void PublishKnownControlTypes(
    List<string> knownTypes
)
Visual Basic
Sub PublishKnownControlTypes ( _
    knownTypes As List(Of String) _
)
Visual C++
void PublishKnownControlTypes(
    List<String^>^ knownTypes
)

Parameters

knownTypes
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>

[Missing <param name="knownTypes"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.PublishKnownControlTypes(System.Collections.Generic.List{System.String})"]

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


ScrollToVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..ScrollToVisible Method
ICommunicationProxy Interface See Also Send Feedback
Scroll the controls containing an element so that the element comes into view

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void ScrollToVisible(
    IAutomationPeer peer
)
Visual Basic
Sub ScrollToVisible ( _
    peer As IAutomationPeer _
)
Visual C++
void ScrollToVisible(
    IAutomationPeer^ peer
)

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer
The element to bring into view

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


SetProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..SetProperty Method
ICommunicationProxy Interface See Also Send Feedback
Set a property for an automation peer

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void SetProperty(
    AutomationProperty property,
    IAutomationPeer peer,
    Object value
)
Visual Basic
Sub SetProperty ( _
    property As AutomationProperty, _
    peer As IAutomationPeer, _
    value As Object _
)
Visual C++
void SetProperty(
    AutomationProperty^ property,
    IAutomationPeer^ peer,
    Object^ value
)

Parameters

property
Type: ArtOfTest.WebAii.Silverlight..::..AutomationProperty

[Missing <param name="property"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.SetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Object)"]

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.SetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Object)"]

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ICommunicationProxy.SetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Object)"]

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


ICommunicationProxy Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy Properties
ICommunicationProxy Interface See Also Send Feedback

The ICommunicationProxy type exposes the following members.

Properties

 | Name | Description
Public property | Application | Get the parent application object.

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


Application Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ICommunicationProxy..::..Application Property
ICommunicationProxy Interface See Also Send Feedback
Get the parent application object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
IApplication Application { get; }
Visual Basic
ReadOnly Property Application As IApplication
    Get
Visual C++
property IApplication^ Application {
    IApplication^ get ();
}

See Also

ICommunicationProxy Interface
ArtOfTest.WebAii.Silverlight Namespace


IPeerConverter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPeerConverter Members
IPeerConverter Interface Methods See Also Send Feedback

The IPeerConverter type exposes the following members.

Methods

 | Name | Description
Public method | FromRealObject | Converts a real object to this object.
Public method | ToRealObject | Convert this object to a real object.

See Also

IPeerConverter Interface
ArtOfTest.WebAii.Silverlight Namespace


IPeerConverter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPeerConverter Methods
IPeerConverter Interface See Also Send Feedback

The IPeerConverter type exposes the following members.

Methods

 | Name | Description
Public method | FromRealObject | Converts a real object to this object.
Public method | ToRealObject | Convert this object to a real object.

See Also

IPeerConverter Interface
ArtOfTest.WebAii.Silverlight Namespace


FromRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPeerConverter..::..FromRealObject Method
IPeerConverter Interface See Also Send Feedback
Converts a real object to this object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void FromRealObject(
    Object o
)
Visual Basic
Sub FromRealObject ( _
    o As Object _
)
Visual C++
void FromRealObject(
    Object^ o
)

Parameters

o
Type: System..::..Object
The real object to convert from.

See Also

IPeerConverter Interface
ArtOfTest.WebAii.Silverlight Namespace


ToRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IPeerConverter..::..ToRealObject Method
IPeerConverter Interface See Also Send Feedback
Convert this object to a real object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
Object ToRealObject()
Visual Basic
Function ToRealObject As Object
Visual C++
Object^ ToRealObject()

Return Value

A real object.

See Also

IPeerConverter Interface
ArtOfTest.WebAii.Silverlight Namespace


ItemCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection Members
ItemCollection Class Constructors Methods Properties See Also Send Feedback

The ItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ItemCollection | Creates a new empty ItemCollection object.

Methods

 | Name | Description
Public method | Add | Not supported.
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Clear | Not supported.
Public method | Contains | Checks whether or not the specified item is contained in the collection.
Public method | CopyTo | Not supported.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Wraps the items contained in a real item collection and stores them in this object. (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | Gets the type of the real object that this class wraps. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index number for the indicated item.
Public method | Insert | Not supported.
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Not supported.
Public method | RemoveAt | Not supported.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Not supported (Overrides AutomationObject<(Of <(<'T>)>)>..::..ToRealObject()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Collection | Infrastructure use
Public property | Count | Gets the number of items in the collection.
Public property | IsFixedSize | Not supported.
Public property | IsReadOnly | This class is always read only once created. It always returns true.
Public property | IsSynchronized | Not supported.
Public property | Item | Gets the item at the specified index. Setting is not supported.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | SyncRoot | Not supported.

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


ItemCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection Constructor
ItemCollection Class See Also Send Feedback
Creates a new empty ItemCollection object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ItemCollection()
Visual Basic
Public Sub New
Visual C++
public:
ItemCollection()

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


ItemCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection Methods
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Not supported.
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Clear | Not supported.
Public method | Contains | Checks whether or not the specified item is contained in the collection.
Public method | CopyTo | Not supported.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Wraps the items contained in a real item collection and stores them in this object. (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | Gets the type of the real object that this class wraps. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index number for the indicated item.
Public method | Insert | Not supported.
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Not supported.
Public method | RemoveAt | Not supported.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Not supported (Overrides AutomationObject<(Of <(<'T>)>)>..::..ToRealObject()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Add Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..Add Method
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Add(
    string value
)
Visual Basic
Public Sub Add ( _
    value As String _
)
Visual C++
public:
virtual void Add(
    String^ value
) sealed

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ItemCollection.Add(System.String)"]

Return Value

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..Clear Method
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Contains Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..Contains Method
ItemCollection Class See Also Send Feedback
Checks whether or not the specified item is contained in the collection.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Contains(
    string value
)
Visual Basic
Public Function Contains ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ value
) sealed

Parameters

value
Type: System..::..String
The item to check on.

Return Value

True/false whether or not the item is contained in this collection.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


CopyTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..CopyTo Method
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CopyTo(
    string[] array,
    int index
)
Visual Basic
Public Sub CopyTo ( _
    array As String(), _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<String^>^ array,
    int index
) sealed

Parameters

array
Type: array< System..::..String >[]()[][]

[Missing <param name="array"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ItemCollection.CopyTo(System.String[],System.Int32)"]

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ItemCollection.CopyTo(System.String[],System.Int32)"]

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


FromRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..FromRealObject Method
ItemCollection Class See Also Send Feedback
Wraps the items contained in a real item collection and stores them in this object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void FromRealObject(
    Object o
)
Visual Basic
Public Overrides Sub FromRealObject ( _
    o As Object _
)
Visual C++
public:
virtual void FromRealObject(
    Object^ o
) override

Parameters

o
Type: System..::..Object

[Missing <param name="o"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ItemCollection.FromRealObject(System.Object)"]

Implements

IPeerConverter..::..FromRealObject(Object)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..GetProperty Method
ItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemCollection Class
ItemCollection Members
ArtOfTest.WebAii.Silverlight Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..GetRealType Method
ItemCollection Class See Also Send Feedback
Gets the type of the real object that this class wraps.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

A string represtation for this real type.

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


IndexOf Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..IndexOf Method
ItemCollection Class See Also Send Feedback
Gets the index number for the indicated item.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int IndexOf(
    string value
)
Visual Basic
Public Function IndexOf ( _
    value As String _
) As Integer
Visual C++
public:
virtual int IndexOf(
    String^ value
) sealed

Parameters

value
Type: System..::..String
The item to get the index of.

Return Value

An index value.

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Insert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..Insert Method
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Insert(
    int index,
    string value
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    value As String _
)
Visual C++
public:
virtual void Insert(
    int index,
    String^ value
) sealed

Parameters

index
Type: System..::..Int32
Not supported.
value
Type: System..::..String
Not supported.

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..InvokeMethod Method
ItemCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemCollection Class
ItemCollection Members
ArtOfTest.WebAii.Silverlight Namespace


Remove Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..Remove Method
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Remove(
    string value
)
Visual Basic
Public Function Remove ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool Remove(
    String^ value
) sealed

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ItemCollection.Remove(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ItemCollection.Remove(System.String)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


RemoveAt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..RemoveAt Method
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:ArtOfTest.WebAii.Silverlight.ItemCollection.RemoveAt(System.Int32)"]

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


ToRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..ToRealObject Method
ItemCollection Class See Also Send Feedback
Not supported

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Object ToRealObject()
Visual Basic
Public Overrides Function ToRealObject As Object
Visual C++
public:
virtual Object^ ToRealObject() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.ItemCollection.ToRealObject"]

Implements

IPeerConverter..::..ToRealObject()()()()

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


ItemCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection Properties
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Properties

 | Name | Description
Public property | Collection | Infrastructure use
Public property | Count | Gets the number of items in the collection.
Public property | IsFixedSize | Not supported.
Public property | IsReadOnly | This class is always read only once created. It always returns true.
Public property | IsSynchronized | Not supported.
Public property | Item | Gets the item at the specified index. Setting is not supported.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | SyncRoot | Not supported.

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Collection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..Collection Property
ItemCollection Class See Also Send Feedback
Infrastructure use

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<string> Collection { get; set; }
Visual Basic
Public Property Collection As List(Of String)
    Get
    Set
Visual C++
public:
property List<String^>^ Collection {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Count Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..Count Property
ItemCollection Class See Also Send Feedback
Gets the number of items in the collection.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


IsFixedSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..IsFixedSize Property
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFixedSize { get; }
Visual Basic
Public ReadOnly Property IsFixedSize As Boolean
    Get
Visual C++
public:
property bool IsFixedSize {
    bool get ();
}

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..IsReadOnly Property
ItemCollection Class See Also Send Feedback
This class is always read only once created. It always returns true.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


IsSynchronized Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..IsSynchronized Property
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic
Public ReadOnly Property IsSynchronized As Boolean
    Get
Visual C++
public:
property bool IsSynchronized {
    bool get ();
}

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..Item Property
ItemCollection Class See Also Send Feedback
Gets the item at the specified index. Setting is not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As String
    Get
    Set
Visual C++
public:
virtual property String^ default[int index] {
    String^ get (int index) sealed;
    void set (int index, String^ value) sealed;
}

Parameters

index
Type: System..::..Int32
The 0 based index of the item to get.

Return Value

The itme at the index.

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


SyncRoot Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemCollection..::..SyncRoot Property
ItemCollection Class See Also Send Feedback
Not supported.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic
Public ReadOnly Property SyncRoot As Object
    Get
Visual C++
public:
property Object^ SyncRoot {
    Object^ get ();
}

See Also

ItemCollection Class
ArtOfTest.WebAii.Silverlight Namespace


NoSuchPropertyException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NoSuchPropertyException Members
NoSuchPropertyException Class Constructors Methods Properties See Also Send Feedback

The NoSuchPropertyException type exposes the following members.

Constructors

 | Name | Description
Public method | NoSuchPropertyException | Constructs a new NoSuchPropertyException object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NoSuchPropertyException Class
ArtOfTest.WebAii.Silverlight Namespace


NoSuchPropertyException Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NoSuchPropertyException Constructor
NoSuchPropertyException Class See Also Send Feedback
Constructs a new NoSuchPropertyException object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public NoSuchPropertyException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
NoSuchPropertyException(
    String^ message
)

Parameters

message
Type: System..::..String
The message to relating to the exception.

See Also

NoSuchPropertyException Class
ArtOfTest.WebAii.Silverlight Namespace


NoSuchPropertyException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NoSuchPropertyException Methods
NoSuchPropertyException Class See Also Send Feedback

The NoSuchPropertyException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NoSuchPropertyException Class
ArtOfTest.WebAii.Silverlight Namespace


NoSuchPropertyException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NoSuchPropertyException Properties
NoSuchPropertyException Class See Also Send Feedback

The NoSuchPropertyException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NoSuchPropertyException Class
ArtOfTest.WebAii.Silverlight Namespace


ObjectSerializer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ObjectSerializer Members
ObjectSerializer Class Methods See Also Send Feedback

The ObjectSerializer type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes the JSON string into a .NET object.
Serialize | Serializes a .NET object into a JSON.

See Also

ObjectSerializer Class
ArtOfTest.WebAii.Silverlight Namespace


ObjectSerializer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ObjectSerializer Methods
ObjectSerializer Class See Also Send Feedback

The ObjectSerializer type exposes the following members.

Methods

Name | Description
Deserialize | Deserializes the JSON string into a .NET object.
Serialize | Serializes a .NET object into a JSON.

See Also

ObjectSerializer Class
ArtOfTest.WebAii.Silverlight Namespace


Deserialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ObjectSerializer..::..Deserialize Method
ObjectSerializer Class See Also Send Feedback
Deserializes the JSON string into a .NET object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Object Deserialize(
    Type t,
    string jsonString
)
Visual Basic
Public Shared Function Deserialize ( _
    t As Type, _
    jsonString As String _
) As Object
Visual C++
public:
static Object^ Deserialize(
    Type^ t,
    String^ jsonString
)

Parameters

t
Type: System..::..Type
The type to deserialize the string into.
jsonString
Type: System..::..String
The input JSON.

Return Value

A deserialized .NET object of type t.

See Also

ObjectSerializer Class
ArtOfTest.WebAii.Silverlight Namespace


Serialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ObjectSerializer..::..Serialize Method
ObjectSerializer Class See Also Send Feedback
Serializes a .NET object into a JSON.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string Serialize(
    Type t,
    Object o
)
Visual Basic
Public Shared Function Serialize ( _
    t As Type, _
    o As Object _
) As String
Visual C++
public:
static String^ Serialize(
    Type^ t,
    Object^ o
)

Parameters

t
Type: System..::..Type
The objects type to serialize.
o
Type: System..::..Object
the object to serialize into a JSON.

Return Value

The serialized JSON.

See Also

ObjectSerializer Class
ArtOfTest.WebAii.Silverlight Namespace


SelectedDatesCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection Members
SelectedDatesCollection Class Constructors Methods Properties See Also Send Feedback

The SelectedDatesCollection type exposes the following members.

Constructors

 | Name | Description
Public method | SelectedDatesCollection | Constructs a new SelectedDatesCollection object.

Methods

 | Name | Description
Public method | Add | Adds a DateTime to this collection.
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Clear | Clears this collection.
Public method | Contains | Returns true if this collection contains the specified DateTime.
Public method | CopyTo | Copies this collection to the specified array.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a real Silverlight object into this wrapped object. (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetEnumerator | Returns an IEnumerator<(Of <(<'T>)>)> that supports a simple iteration over a collection of DateTime objects.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | Gets a string representing the Silverlight type this class wraps. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index of the specified DateTime.
Public method | Insert | Inserts the specified DateTime into the collection at the specified index. Existing DateTime values are moved down one index.
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified DateTime from the collection.
Public method | RemoveAt | Removes the DateTime at the specified index from this collection.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Throws the NotSupportedException because this object cannot be converted into a real Silverlight object. (Overrides AutomationObject<(Of <(<'T>)>)>..::..ToRealObject()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Collection | Gets / Sets the collection of DateTime objects this class contains.
Public property | Count | Returns the number of items contained in this collection.
Public property | IsReadOnly | Always returns True.
Public property | Item | Gets / Sets the DateTime at the specified index.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


SelectedDatesCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection Constructor
SelectedDatesCollection Class See Also Send Feedback
Constructs a new SelectedDatesCollection object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SelectedDatesCollection()
Visual Basic
Public Sub New
Visual C++
public:
SelectedDatesCollection()

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


SelectedDatesCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection Methods
SelectedDatesCollection Class See Also Send Feedback

The SelectedDatesCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a DateTime to this collection.
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Clear | Clears this collection.
Public method | Contains | Returns true if this collection contains the specified DateTime.
Public method | CopyTo | Copies this collection to the specified array.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a real Silverlight object into this wrapped object. (Overrides AutomationObject<(Of <(<'T>)>)>..::..FromRealObject(Object).)
Public method | GetEnumerator | Returns an IEnumerator<(Of <(<'T>)>)> that supports a simple iteration over a collection of DateTime objects.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | Gets a string representing the Silverlight type this class wraps. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index of the specified DateTime.
Public method | Insert | Inserts the specified DateTime into the collection at the specified index. Existing DateTime values are moved down one index.
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the specified DateTime from the collection.
Public method | RemoveAt | Removes the DateTime at the specified index from this collection.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Throws the NotSupportedException because this object cannot be converted into a real Silverlight object. (Overrides AutomationObject<(Of <(<'T>)>)>..::..ToRealObject()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Add Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..Add Method
SelectedDatesCollection Class See Also Send Feedback
Adds a DateTime to this collection.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Add(
    DateTime item
)
Visual Basic
Public Sub Add ( _
    item As DateTime _
)
Visual C++
public:
virtual void Add(
    DateTime item
) sealed

Parameters

item
Type: System..::..DateTime
The DateTime to add.

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..Clear Method
SelectedDatesCollection Class See Also Send Feedback
Clears this collection.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Contains Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..Contains Method
SelectedDatesCollection Class See Also Send Feedback
Returns true if this collection contains the specified DateTime.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Contains(
    DateTime item
)
Visual Basic
Public Function Contains ( _
    item As DateTime _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DateTime item
) sealed

Parameters

item
Type: System..::..DateTime
The DateTime to look for.

Return Value

true if the specified DateTime is found. Else returns false.

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


CopyTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..CopyTo Method
SelectedDatesCollection Class See Also Send Feedback
Copies this collection to the specified array.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CopyTo(
    DateTime[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo ( _
    array As DateTime(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<DateTime>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< System..::..DateTime >[]()[][]
The DateTime array to copy this collection to.
arrayIndex
Type: System..::..Int32
The starting index in the array to copy to. This index is 0 based.

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


FromRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..FromRealObject Method
SelectedDatesCollection Class See Also Send Feedback
Converts a real Silverlight object into this wrapped object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void FromRealObject(
    Object obj
)
Visual Basic
Public Overrides Sub FromRealObject ( _
    obj As Object _
)
Visual C++
public:
virtual void FromRealObject(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The real Silverlight object to convert.

Implements

IPeerConverter..::..FromRealObject(Object)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


GetEnumerator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..GetEnumerator Method
SelectedDatesCollection Class See Also Send Feedback
Returns an IEnumerator<(Of <(<'T>)>)> that supports a simple iteration over a collection of DateTime objects.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEnumerator<DateTime> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of DateTime)
Visual C++
public:
virtual IEnumerator<DateTime>^ GetEnumerator() sealed

Return Value

An IEnumerator<DateTime>

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..GetProperty Method
SelectedDatesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SelectedDatesCollection Class
SelectedDatesCollection Members
ArtOfTest.WebAii.Silverlight Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..GetRealType Method
SelectedDatesCollection Class See Also Send Feedback
Gets a string representing the Silverlight type this class wraps.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SelectedDatesCollection.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


IndexOf Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..IndexOf Method
SelectedDatesCollection Class See Also Send Feedback
Gets the index of the specified DateTime.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int IndexOf(
    DateTime item
)
Visual Basic
Public Function IndexOf ( _
    item As DateTime _
) As Integer
Visual C++
public:
virtual int IndexOf(
    DateTime item
) sealed

Parameters

item
Type: System..::..DateTime
The DateTime to get the index of.

Return Value

The index of the DateTime if found in the collection. Returns -1 if not found. The index is 0 based.

Implements

IList<(Of <(<'T>)>)>..::..IndexOf(T)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Insert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..Insert Method
SelectedDatesCollection Class See Also Send Feedback
Inserts the specified DateTime into the collection at the specified index. Existing DateTime values are moved down one index.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Insert(
    int index,
    DateTime item
)
Visual Basic
Public Sub Insert ( _
    index As Integer, _
    item As DateTime _
)
Visual C++
public:
virtual void Insert(
    int index,
    DateTime item
) sealed

Parameters

index
Type: System..::..Int32
The index to insert into.
item
Type: System..::..DateTime
The DateTime to insert.

Implements

IList<(Of <(<'T>)>)>..::..Insert(Int32, T)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..InvokeMethod Method
SelectedDatesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SelectedDatesCollection Class
SelectedDatesCollection Members
ArtOfTest.WebAii.Silverlight Namespace


Remove Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..Remove Method
SelectedDatesCollection Class See Also Send Feedback
Removes the specified DateTime from the collection.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Remove(
    DateTime item
)
Visual Basic
Public Function Remove ( _
    item As DateTime _
) As Boolean
Visual C++
public:
virtual bool Remove(
    DateTime item
) sealed

Parameters

item
Type: System..::..DateTime
The DateTime to remove.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SelectedDatesCollection.Remove(System.DateTime)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


RemoveAt Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..RemoveAt Method
SelectedDatesCollection Class See Also Send Feedback
Removes the DateTime at the specified index from this collection.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: System..::..Int32
The index of the DateTime to remove. The index is 0 based.

Implements

IList<(Of <(<'T>)>)>..::..RemoveAt(Int32)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


ToRealObject Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..ToRealObject Method
SelectedDatesCollection Class See Also Send Feedback
Throws the NotSupportedException because this object cannot be converted into a real Silverlight object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Object ToRealObject()
Visual Basic
Public Overrides Function ToRealObject As Object
Visual C++
public:
virtual Object^ ToRealObject() override

Return Value

Does not return.

Implements

IPeerConverter..::..ToRealObject()()()()

Exceptions

Exception | Condition
System..::..NotSupportedException | Always thrown.

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


SelectedDatesCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection Properties
SelectedDatesCollection Class See Also Send Feedback

The SelectedDatesCollection type exposes the following members.

Properties

 | Name | Description
Public property | Collection | Gets / Sets the collection of DateTime objects this class contains.
Public property | Count | Returns the number of items contained in this collection.
Public property | IsReadOnly | Always returns True.
Public property | Item | Gets / Sets the DateTime at the specified index.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Collection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..Collection Property
SelectedDatesCollection Class See Also Send Feedback
Gets / Sets the collection of DateTime objects this class contains.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<DateTime> Collection { get; set; }
Visual Basic
Public Property Collection As List(Of DateTime)
    Get
    Set
Visual C++
public:
property List<DateTime>^ Collection {
    List<DateTime>^ get ();
    void set (List<DateTime>^ value);
}

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Count Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..Count Property
SelectedDatesCollection Class See Also Send Feedback
Returns the number of items contained in this collection.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..IsReadOnly Property
SelectedDatesCollection Class See Also Send Feedback
Always returns True.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


Item Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDatesCollection..::..Item Property
SelectedDatesCollection Class See Also Send Feedback
Gets / Sets the DateTime at the specified index.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime this[
    int index
] { get; set; }
Visual Basic
Public Default Property Item ( _
    index As Integer _
) As DateTime
    Get
    Set
Visual C++
public:
virtual property DateTime default[int index] {
    DateTime get (int index) sealed;
    void set (int index, DateTime value) sealed;
}

Parameters

index
Type: System..::..Int32
The index to get/set the DateTime at. The index is 0 based.

Return Value

The DateTime object at the specified index.

Implements

IList<(Of <(<'T>)>)>..::..Item[([( Int32])])

See Also

SelectedDatesCollection Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightApp Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp Members
SilverlightApp Class Constructors Methods Properties See Also Send Feedback

The SilverlightApp type exposes the following members.

Constructors

 | Name | Description
Public method | SilverlightApp | Initializes a new instance of the SilverlightApp class

Methods

 | Name | Description
 | AddCustomAssembly | Add a custom assembly to the list of types that will be available for automation in addition to what ArtOfTest.WebAii.Silverlight.UI contains.
Public method | Capture()()()() |
Public method | Capture(FrameworkElement) |
 | ClearAppCache | Clear the application's cache.
Public method | ClearHighlight | Clear any highlighting on the Silverlight surface.
Public method | Connect()()()() | Connect to the Silverlight app
Public method | Connect(Int32) | Connect the silverlight application to the automation host.
Public method | ElementFromPoint | Returns a proxy for the element at the specified application coordinates
Public method | ElementsFromPoint | Gets a list of FrameworkElements under the specified point in the application
Public method | EnsureElementClickable |
Public method | EnsureStateIsCurrent | Will force all visual trees in the application to refresh. (Overrides VisualTreeHost..::..EnsureStateIsCurrent()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName(String) | Finds an element with a specific name in the Silverlight Application. If the name is not found using the Root.FindName, it will use the VisualTree to traverse the tree and find the first name occurrence.
Public method | FindName<(Of <<'(T>)>>)(String) | Finds an element with a specific name in the Silverlight Application. If the name is not found using the Root.FindName(), it will use the VisualTree to traverse the tree and find the first name occurrence.
Public method | FixAnnotationArea | (Inherited from VisualTreeHost.)
 | GetApp(HtmlControl) |
 | GetApp(HtmlControl, Int32, Boolean) | Gets the Silverlight application for the specified HtmlControl host.
Public method | GetChildHosts | Get all contained hosts. This will always return an empty array for SilverlightApp hosts. (Overrides VisualTreeHost..::..GetChildHosts()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Returns the root target element of this host. VisualTree.Root (Inherited from VisualTreeHost.)
Public method | GetScreenRectangle |
Public method | GetToolTipText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeCustomTypes()()()() | Searches the AppDomain for assemblies that provide custom Silverlight types and adds the assemblies containing those types to the custom assembly list
 | InitializeCustomTypes(IList<(Of <<'(ICustomSilverlightTypesProvider>)>>)) | Initializes the list of custom type providers that can provide automation in addition to what ArtOfTest.WebAii.Silverlight.UI contains
Public method | LocateAllInHost | (Overrides VisualTreeHost..::..LocateAllInHost(array<String>[]()[][]).)
Public method | LocateInHost | Locate an element from the root of this host using an expression. (Inherited from VisualTreeHost.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshVisualTrees | Refreshes the main visual tree for the application as well as any open Popup visual trees.
Public method | ResizeContainer |
Public method | ScrollElementVisible |
Public method | SetWindowFocus | (Overrides VisualTreeHost..::..SetWindowFocus()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateInterHostLinks | Silverlight hosts have no inter-host links to update (Inherited from VisualTreeHost.)
Public method | ValidateMouseLocation | (Overrides VisualTreeHost..::..ValidateMouseLocation(Point).)

Properties

 | Name | Description
Public property | Annotator | (Overrides VisualTreeHost..::..Annotator.)
Public property | Bounds | Get the Rectangle bounds of this application relative to the entire screen.
Public property | Content | Gets the 'content' object of this plugin: plugin.content.xxx
Public property | ContentWindow | (Overrides VisualTreeHost..::..ContentWindow.)
 | CustomAssemblies | Gets the list of custom assemblies included
Public property | Desktop | Get the Desktop object used for real Keyboard/Mouse automation.
Public property | EnableValidateMouseLocation | Gets / Sets whether to validate mouse click locations before allowing user interaction automation
Public property | Find | Gets the XamlFind object used to search the silverlight plugin VisualTree.
Public property | FriendlyName | Returns a friendly name for this host (Overrides VisualTreeHost..::..FriendlyName.)
Public property | Host | Gets the Html tag hosting this Silverlight App as an HtmlControl object. (The parent Html tag of the object/embed tag)
Public property | IsConnected | Gets whether the SilverlightApp is connected to the automation host
Public property | IsLoaded | Gets whether this plugin is loaded or not.
Public property | IsRecordingHost |
Public property | ManagedProxy | The proxy that allows this app to communicate with the managed world inside a silverlight application
Public property | Manager | (Overrides VisualTreeHost..::..Manager.)
Public property | OwnerApp | The SilverlightApp containing this visual tree (Inherited from VisualTreeHost.)
Public property | OwnerBrowser | Gets the owner browser object instance of this silverlight application.
Public property | Plugin | Gets the actual plugin element (object or embed) as an HtmlControl
Public property | Popups |
Public property | Settings | Gets the 'settings' object of this plugin: plugin.settings.xxx
Public property | ShouldDisplayAnnotation | (Inherited from VisualTreeHost.)
Public property | StateHashCode | Gets a unique identifier that identifies the state of this host (Inherited from VisualTreeHost.)
Public property | TechnologyType | (Overrides VisualTreeHost..::..TechnologyType.)
Public property | UniqueId | A unique identifier that identifies this plugin instance. This id is updated only when the plug-in is reloaded on a postback or a browser refresh. (Overrides VisualTreeHost..::..UniqueId.)
Public property | VisualTree | The visual tree wrapped by this host object (Inherited from VisualTreeHost.)
Public property | Window | (Overrides VisualTreeHost..::..Window.)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightApp Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp Constructor
SilverlightApp Class See Also Send Feedback
Initializes a new instance of the SilverlightApp class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightApp(
    HtmlControl plugin
)
Visual Basic
Public Sub New ( _
    plugin As HtmlControl _
)
Visual C++
public:
SilverlightApp(
    HtmlControl^ plugin
)

Parameters

plugin
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl

[Missing <param name="plugin"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.#ctor(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl)"]

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightApp Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp Methods
SilverlightApp Class See Also Send Feedback

The SilverlightApp type exposes the following members.

Methods

 | Name | Description
 | AddCustomAssembly | Add a custom assembly to the list of types that will be available for automation in addition to what ArtOfTest.WebAii.Silverlight.UI contains.
Public method | Capture()()()() |
Public method | Capture(FrameworkElement) |
 | ClearAppCache | Clear the application's cache.
Public method | ClearHighlight | Clear any highlighting on the Silverlight surface.
Public method | Connect()()()() | Connect to the Silverlight app
Public method | Connect(Int32) | Connect the silverlight application to the automation host.
Public method | ElementFromPoint | Returns a proxy for the element at the specified application coordinates
Public method | ElementsFromPoint | Gets a list of FrameworkElements under the specified point in the application
Public method | EnsureElementClickable |
Public method | EnsureStateIsCurrent | Will force all visual trees in the application to refresh. (Overrides VisualTreeHost..::..EnsureStateIsCurrent()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindName(String) | Finds an element with a specific name in the Silverlight Application. If the name is not found using the Root.FindName, it will use the VisualTree to traverse the tree and find the first name occurrence.
Public method | FindName<(Of <<'(T>)>>)(String) | Finds an element with a specific name in the Silverlight Application. If the name is not found using the Root.FindName(), it will use the VisualTree to traverse the tree and find the first name occurrence.
Public method | FixAnnotationArea | (Inherited from VisualTreeHost.)
 | GetApp(HtmlControl) |
 | GetApp(HtmlControl, Int32, Boolean) | Gets the Silverlight application for the specified HtmlControl host.
Public method | GetChildHosts | Get all contained hosts. This will always return an empty array for SilverlightApp hosts. (Overrides VisualTreeHost..::..GetChildHosts()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Returns the root target element of this host. VisualTree.Root (Inherited from VisualTreeHost.)
Public method | GetScreenRectangle |
Public method | GetToolTipText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeCustomTypes()()()() | Searches the AppDomain for assemblies that provide custom Silverlight types and adds the assemblies containing those types to the custom assembly list
 | InitializeCustomTypes(IList<(Of <<'(ICustomSilverlightTypesProvider>)>>)) | Initializes the list of custom type providers that can provide automation in addition to what ArtOfTest.WebAii.Silverlight.UI contains
Public method | LocateAllInHost | (Overrides VisualTreeHost..::..LocateAllInHost(array<String>[]()[][]).)
Public method | LocateInHost | Locate an element from the root of this host using an expression. (Inherited from VisualTreeHost.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshVisualTrees | Refreshes the main visual tree for the application as well as any open Popup visual trees.
Public method | ResizeContainer |
Public method | ScrollElementVisible |
Public method | SetWindowFocus | (Overrides VisualTreeHost..::..SetWindowFocus()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateInterHostLinks | Silverlight hosts have no inter-host links to update (Inherited from VisualTreeHost.)
Public method | ValidateMouseLocation | (Overrides VisualTreeHost..::..ValidateMouseLocation(Point).)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


AddCustomAssembly Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..AddCustomAssembly Method
SilverlightApp Class See Also Send Feedback
Add a custom assembly to the list of types that will be available for automation in addition to what ArtOfTest.WebAii.Silverlight.UI contains.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void AddCustomAssembly(
    string assemblyName,
    MemoryStream assembly
)
Visual Basic
Public Shared Sub AddCustomAssembly ( _
    assemblyName As String, _
    assembly As MemoryStream _
)
Visual C++
public:
static void AddCustomAssembly(
    String^ assemblyName,
    MemoryStream^ assembly
)

Parameters

assemblyName
Type: System..::..String
The name of the assembly to add.
assembly
Type: System.IO..::..MemoryStream
The assembly to include as a MemoryStream. This must be a Silverlight compiled assembly.

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Capture Method
SilverlightApp Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() |
Public method | Capture(FrameworkElement) |

See Also

SilverlightApp Class
SilverlightApp Members
ArtOfTest.WebAii.Silverlight Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Capture Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.Capture"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap Capture()
Visual Basic
Public Function Capture As Bitmap
Visual C++
public:
virtual Bitmap^ Capture() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.Capture"]

Implements

IAutomationHost..::..Capture()()()()

See Also

SilverlightApp Class
Capture Overload
ArtOfTest.WebAii.Silverlight Namespace


Capture Method (FrameworkElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Capture Method (FrameworkElement)
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.Capture(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap Capture(
    FrameworkElement element
)
Visual Basic
Public Function Capture ( _
    element As FrameworkElement _
) As Bitmap
Visual C++
public:
virtual Bitmap^ Capture(
    FrameworkElement^ element
) sealed

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.Capture(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.Capture(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Implements

IApplication..::..Capture(FrameworkElement)

See Also

SilverlightApp Class
Capture Overload
ArtOfTest.WebAii.Silverlight Namespace


ClearAppCache Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ClearAppCache Method
SilverlightApp Class See Also Send Feedback
Clear the application's cache.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void ClearAppCache()
Visual Basic
Public Shared Sub ClearAppCache
Visual C++
public:
static void ClearAppCache()

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


ClearHighlight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ClearHighlight Method
SilverlightApp Class See Also Send Feedback
Clear any highlighting on the Silverlight surface.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ClearHighlight()
Visual Basic
Public Sub ClearHighlight
Visual C++
public:
void ClearHighlight()

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Connect Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Connect Method
SilverlightApp Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Connect()()()() | Connect to the Silverlight app
Public method | Connect(Int32) | Connect the silverlight application to the automation host.

See Also

SilverlightApp Class
SilverlightApp Members
ArtOfTest.WebAii.Silverlight Namespace


Connect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Connect Method
SilverlightApp Class See Also Send Feedback
Connect to the Silverlight app

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Connect()
Visual Basic
Public Sub Connect
Visual C++
public:
void Connect()

See Also

SilverlightApp Class
Connect Overload
ArtOfTest.WebAii.Silverlight Namespace


Connect Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Connect Method (Int32)
SilverlightApp Class See Also Send Feedback
Connect the silverlight application to the automation host.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Connect(
    int timeout
)
Visual Basic
Public Sub Connect ( _
    timeout As Integer _
)
Visual C++
public:
void Connect(
    int timeout
)

Parameters

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.Connect(System.Int32)"]

See Also

SilverlightApp Class
Connect Overload
ArtOfTest.WebAii.Silverlight Namespace


ElementFromPoint Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ElementFromPoint Method
SilverlightApp Class See Also Send Feedback
Returns a proxy for the element at the specified application coordinates

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ElementFromPoint(
    int x,
    int y
)
Visual Basic
Public Function ElementFromPoint ( _
    x As Integer, _
    y As Integer _
) As FrameworkElement
Visual C++
public:
virtual FrameworkElement^ ElementFromPoint(
    int x,
    int y
) sealed

Parameters

x
Type: System..::..Int32
The x-coordinate of the element
y
Type: System..::..Int32
The y-coordinate of the element

Return Value

A proxy for the element at those coordinates, or null if no element corresponds to the specified coordinates

Implements

IApplication..::..ElementFromPoint(Int32, Int32)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


ElementsFromPoint Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ElementsFromPoint Method
SilverlightApp Class See Also Send Feedback
Gets a list of FrameworkElements under the specified point in the application

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> ElementsFromPoint(
    Point p
)
Visual Basic
Public Function ElementsFromPoint ( _
    p As Point _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ ElementsFromPoint(
    Point p
)

Parameters

p
Type: System.Drawing..::..Point
The point to hit-test, in application-relative coordinates

Return Value

A list of FrameworkElements under the point, starting with the topmost FrameworkElement

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


EnsureElementClickable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..EnsureElementClickable Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.EnsureElementClickable(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void EnsureElementClickable(
    FrameworkElement element
)
Visual Basic
Public Sub EnsureElementClickable ( _
    element As FrameworkElement _
)
Visual C++
public:
virtual void EnsureElementClickable(
    FrameworkElement^ element
) sealed

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.EnsureElementClickable(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Implements

IApplication..::..EnsureElementClickable(FrameworkElement)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


EnsureStateIsCurrent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..EnsureStateIsCurrent Method
SilverlightApp Class See Also Send Feedback
Will force all visual trees in the application to refresh.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void EnsureStateIsCurrent()
Visual Basic
Public Overrides Sub EnsureStateIsCurrent
Visual C++
public:
virtual void EnsureStateIsCurrent() override

Implements

IAutomationHost..::..EnsureStateIsCurrent()()()()
IAutomationHost..::..EnsureStateIsCurrent()()()()

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


FindName Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..FindName Method
SilverlightApp Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindName(String) | Finds an element with a specific name in the Silverlight Application. If the name is not found using the Root.FindName, it will use the VisualTree to traverse the tree and find the first name occurrence.
Public method | FindName<(Of <<'(T>)>>)(String) | Finds an element with a specific name in the Silverlight Application. If the name is not found using the Root.FindName(), it will use the VisualTree to traverse the tree and find the first name occurrence.

See Also

SilverlightApp Class
SilverlightApp Members
ArtOfTest.WebAii.Silverlight Namespace


FindName Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..FindName Method (String)
SilverlightApp Class See Also Send Feedback
Finds an element with a specific name in the Silverlight Application. If the name is not found using the Root.FindName, it will use the VisualTree to traverse the tree and find the first name occurrence.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement FindName(
    string name
)
Visual Basic
Public Function FindName ( _
    name As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ FindName(
    String^ name
)

Parameters

name
Type: System..::..String
The name to find.

Return Value

The found FrameworkElement, else returns null.

Remarks

This method is a short-cut for Find.ByName()

See Also

SilverlightApp Class
FindName Overload
ArtOfTest.WebAii.Silverlight Namespace


FindName(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..FindName<(Of <(<'T>)>)> Method (String)
SilverlightApp Class See Also Send Feedback
Finds an element with a specific name in the Silverlight Application. If the name is not found using the Root.FindName(), it will use the VisualTree to traverse the tree and find the first name occurrence.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T FindName<T>(
    string name
)
where T : FrameworkElement
Visual Basic
Public Function FindName(Of T As FrameworkElement) ( _
    name As String _
) As T
Visual C++
public:
generic<typename T>
where T : FrameworkElement
T FindName(
    String^ name
)

Parameters

name
Type: System..::..String
The name to find.

Type Parameters

T
The type to cast this FrameworkElement to.

Return Value

The found FrameworkElement, else returns null.

Remarks

This method is a short-cut for Find.ByName()

See Also

SilverlightApp Class
FindName Overload
ArtOfTest.WebAii.Silverlight Namespace


GetApp Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..GetApp Method
SilverlightApp Class See Also Send Feedback

Overload List

Name | Description
GetApp(HtmlControl) |
GetApp(HtmlControl, Int32, Boolean) | Gets the Silverlight application for the specified HtmlControl host.

See Also

SilverlightApp Class
SilverlightApp Members
ArtOfTest.WebAii.Silverlight Namespace


GetApp Method (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..GetApp Method (HtmlControl)
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetApp(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static SilverlightApp GetApp(
    HtmlControl host
)
Visual Basic
Public Shared Function GetApp ( _
    host As HtmlControl _
) As SilverlightApp
Visual C++
public:
static SilverlightApp^ GetApp(
    HtmlControl^ host
)

Parameters

host
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl

[Missing <param name="host"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetApp(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetApp(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl)"]

See Also

SilverlightApp Class
GetApp Overload
ArtOfTest.WebAii.Silverlight Namespace


GetApp Method (HtmlControl, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..GetApp Method (HtmlControl, Int32, Boolean)
SilverlightApp Class See Also Send Feedback
Gets the Silverlight application for the specified HtmlControl host.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static SilverlightApp GetApp(
    HtmlControl host,
    int timeout,
    bool catchedOnly
)
Visual Basic
Public Shared Function GetApp ( _
    host As HtmlControl, _
    timeout As Integer, _
    catchedOnly As Boolean _
) As SilverlightApp
Visual C++
public:
static SilverlightApp^ GetApp(
    HtmlControl^ host,
    int timeout,
    bool catchedOnly
)

Parameters

host
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl

[Missing <param name="host"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetApp(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl,System.Int32,System.Boolean)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetApp(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl,System.Int32,System.Boolean)"]

catchedOnly
Type: System..::..Boolean

[Missing <param name="catchedOnly"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetApp(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl,System.Int32,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetApp(ArtOfTest.WebAii.Controls.HtmlControls.HtmlControl,System.Int32,System.Boolean)"]

See Also

SilverlightApp Class
GetApp Overload
ArtOfTest.WebAii.Silverlight Namespace


GetChildHosts Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..GetChildHosts Method
SilverlightApp Class See Also Send Feedback
Get all contained hosts. This will always return an empty array for SilverlightApp hosts.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override IAutomationHost[] GetChildHosts()
Visual Basic
Public Overrides Function GetChildHosts As IAutomationHost()
Visual C++
public:
virtual array<IAutomationHost^>^ GetChildHosts() override

Return Value

Contained Hosts

Implements

IAutomationHost..::..GetChildHosts()()()()
IAutomationHost..::..GetChildHosts()()()()

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


GetScreenRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..GetScreenRectangle Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetScreenRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle GetScreenRectangle(
    FrameworkElement element
)
Visual Basic
Public Function GetScreenRectangle ( _
    element As FrameworkElement _
) As Rectangle
Visual C++
public:
virtual Rectangle GetScreenRectangle(
    FrameworkElement^ element
) sealed

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetScreenRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetScreenRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Implements

IApplication..::..GetScreenRectangle(FrameworkElement)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


GetToolTipText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..GetToolTipText Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetToolTipText(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetToolTipText(
    FrameworkElement element
)
Visual Basic
Public Function GetToolTipText ( _
    element As FrameworkElement _
) As String
Visual C++
public:
virtual String^ GetToolTipText(
    FrameworkElement^ element
) sealed

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetToolTipText(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.GetToolTipText(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Implements

IApplication..::..GetToolTipText(FrameworkElement)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


InitializeCustomTypes Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..InitializeCustomTypes Method
SilverlightApp Class See Also Send Feedback

Overload List

Name | Description
InitializeCustomTypes()()()() | Searches the AppDomain for assemblies that provide custom Silverlight types and adds the assemblies containing those types to the custom assembly list
InitializeCustomTypes(IList<(Of <<'(ICustomSilverlightTypesProvider>)>>)) | Initializes the list of custom type providers that can provide automation in addition to what ArtOfTest.WebAii.Silverlight.UI contains

See Also

SilverlightApp Class
SilverlightApp Members
ArtOfTest.WebAii.Silverlight Namespace


InitializeCustomTypes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..InitializeCustomTypes Method
SilverlightApp Class See Also Send Feedback
Searches the AppDomain for assemblies that provide custom Silverlight types and adds the assemblies containing those types to the custom assembly list

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void InitializeCustomTypes()
Visual Basic
Public Shared Sub InitializeCustomTypes
Visual C++
public:
static void InitializeCustomTypes()

See Also

SilverlightApp Class
InitializeCustomTypes Overload
ArtOfTest.WebAii.Silverlight Namespace


InitializeCustomTypes Method (IList())

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..InitializeCustomTypes Method (IList<(Of <(<'>)>)>)
SilverlightApp Class See Also Send Feedback
Initializes the list of custom type providers that can provide automation in addition to what ArtOfTest.WebAii.Silverlight.UI contains

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void InitializeCustomTypes(
    IList<ICustomSilverlightTypesProvider> providers
)
Visual Basic
Public Shared Sub InitializeCustomTypes ( _
    providers As IList(Of ICustomSilverlightTypesProvider) _
)
Visual C++
public:
static void InitializeCustomTypes(
    IList<ICustomSilverlightTypesProvider^>^ providers
)

Parameters

providers
Type: System.Collections.Generic..::..IList <(Of <(<'ICustomSilverlightTypesProvider>)>)>
The list of providers to initialize.

See Also

SilverlightApp Class
InitializeCustomTypes Overload
ArtOfTest.WebAii.Silverlight Namespace


LocateAllInHost Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..LocateAllInHost Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.LocateAllInHost(System.String[])"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override IList<ITargetElement> LocateAllInHost(
    string[] expression
)
Visual Basic
Public Overrides Function LocateAllInHost ( _
    expression As String() _
) As IList(Of ITargetElement)
Visual C++
public:
virtual IList<ITargetElement^>^ LocateAllInHost(
    array<String^>^ expression
) override

Parameters

expression
Type: array< System..::..String >[]()[][]

[Missing <param name="expression"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.LocateAllInHost(System.String[])"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.LocateAllInHost(System.String[])"]

Implements

ISupportSearchHost..::..LocateAllInHost(array<String>[]()[][])
ISupportSearchHost..::..LocateAllInHost(array<String>[]()[][])

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


RefreshVisualTrees Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..RefreshVisualTrees Method
SilverlightApp Class See Also Send Feedback
Refreshes the main visual tree for the application as well as any open Popup visual trees.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RefreshVisualTrees()
Visual Basic
Public Sub RefreshVisualTrees
Visual C++
public:
virtual void RefreshVisualTrees() sealed

Implements

IApplication..::..RefreshVisualTrees()()()()

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


ResizeContainer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ResizeContainer Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ResizeContainer(
    int x,
    int y,
    int width,
    int height
)
Visual Basic
Public Sub ResizeContainer ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
virtual void ResizeContainer(
    int x,
    int y,
    int width,
    int height
) sealed

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

Implements

IApplication..::..ResizeContainer(Int32, Int32, Int32, Int32)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


ScrollElementVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ScrollElementVisible Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ScrollElementVisible(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Core.ScrollToVisibleType)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ScrollElementVisible(
    FrameworkElement element,
    ScrollToVisibleType scrollType
)
Visual Basic
Public Sub ScrollElementVisible ( _
    element As FrameworkElement, _
    scrollType As ScrollToVisibleType _
)
Visual C++
public:
virtual void ScrollElementVisible(
    FrameworkElement^ element,
    ScrollToVisibleType scrollType
) sealed

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ScrollElementVisible(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Core.ScrollToVisibleType)"]

scrollType
Type: ArtOfTest.WebAii.Core..::..ScrollToVisibleType

[Missing <param name="scrollType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ScrollElementVisible(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Core.ScrollToVisibleType)"]

Implements

IApplication..::..ScrollElementVisible(FrameworkElement, ScrollToVisibleType)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


SetWindowFocus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..SetWindowFocus Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.SetWindowFocus"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool SetWindowFocus()
Visual Basic
Public Overrides Function SetWindowFocus As Boolean
Visual C++
public:
virtual bool SetWindowFocus() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.SetWindowFocus"]

Implements

IAutomationHost..::..SetWindowFocus()()()()
IAutomationHost..::..SetWindowFocus()()()()

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


ValidateMouseLocation Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ValidateMouseLocation Method
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ValidateMouseLocation(System.Drawing.Point)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void ValidateMouseLocation(
    Point point
)
Visual Basic
Public Overrides Sub ValidateMouseLocation ( _
    point As Point _
)
Visual C++
public:
virtual void ValidateMouseLocation(
    Point point
) override

Parameters

point
Type: System.Drawing..::..Point

[Missing <param name="point"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightApp.ValidateMouseLocation(System.Drawing.Point)"]

Implements

IAutomationHost..::..ValidateMouseLocation(Point)
IAutomationHost..::..ValidateMouseLocation(Point)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightApp Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp Properties
SilverlightApp Class See Also Send Feedback

The SilverlightApp type exposes the following members.

Properties

 | Name | Description
Public property | Annotator | (Overrides VisualTreeHost..::..Annotator.)
Public property | Bounds | Get the Rectangle bounds of this application relative to the entire screen.
Public property | Content | Gets the 'content' object of this plugin: plugin.content.xxx
Public property | ContentWindow | (Overrides VisualTreeHost..::..ContentWindow.)
 | CustomAssemblies | Gets the list of custom assemblies included
Public property | Desktop | Get the Desktop object used for real Keyboard/Mouse automation.
Public property | EnableValidateMouseLocation | Gets / Sets whether to validate mouse click locations before allowing user interaction automation
Public property | Find | Gets the XamlFind object used to search the silverlight plugin VisualTree.
Public property | FriendlyName | Returns a friendly name for this host (Overrides VisualTreeHost..::..FriendlyName.)
Public property | Host | Gets the Html tag hosting this Silverlight App as an HtmlControl object. (The parent Html tag of the object/embed tag)
Public property | IsConnected | Gets whether the SilverlightApp is connected to the automation host
Public property | IsLoaded | Gets whether this plugin is loaded or not.
Public property | IsRecordingHost |
Public property | ManagedProxy | The proxy that allows this app to communicate with the managed world inside a silverlight application
Public property | Manager | (Overrides VisualTreeHost..::..Manager.)
Public property | OwnerApp | The SilverlightApp containing this visual tree (Inherited from VisualTreeHost.)
Public property | OwnerBrowser | Gets the owner browser object instance of this silverlight application.
Public property | Plugin | Gets the actual plugin element (object or embed) as an HtmlControl
Public property | Popups |
Public property | Settings | Gets the 'settings' object of this plugin: plugin.settings.xxx
Public property | ShouldDisplayAnnotation | (Inherited from VisualTreeHost.)
Public property | StateHashCode | Gets a unique identifier that identifies the state of this host (Inherited from VisualTreeHost.)
Public property | TechnologyType | (Overrides VisualTreeHost..::..TechnologyType.)
Public property | UniqueId | A unique identifier that identifies this plugin instance. This id is updated only when the plug-in is reloaded on a postback or a browser refresh. (Overrides VisualTreeHost..::..UniqueId.)
Public property | VisualTree | The visual tree wrapped by this host object (Inherited from VisualTreeHost.)
Public property | Window | (Overrides VisualTreeHost..::..Window.)

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Annotator Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Annotator Property
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightApp.Annotator"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Annotator Annotator { get; }
Visual Basic
Public Overrides ReadOnly Property Annotator As Annotator
    Get
Visual C++
public:
virtual property Annotator^ Annotator {
    Annotator^ get () override;
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Bounds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Bounds Property
SilverlightApp Class See Also Send Feedback
Get the Rectangle bounds of this application relative to the entire screen.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle Bounds { get; }
Visual Basic
Public ReadOnly Property Bounds As Rectangle
    Get
Visual C++
public:
virtual property Rectangle Bounds {
    Rectangle get () sealed;
}

Implements

IApplication..::..Bounds

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Content Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Content Property
SilverlightApp Class See Also Send Feedback
Gets the 'content' object of this plugin: plugin.content.xxx

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightAppContent Content { get; }
Visual Basic
Public ReadOnly Property Content As SilverlightAppContent
    Get
Visual C++
public:
property SilverlightAppContent^ Content {
    SilverlightAppContent^ get ();
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


ContentWindow Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ContentWindow Property
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightApp.ContentWindow"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Window ContentWindow { get; }
Visual Basic
Public Overrides ReadOnly Property ContentWindow As Window
    Get
Visual C++
public:
virtual property Window^ ContentWindow {
    Window^ get () override;
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


CustomAssemblies Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..CustomAssemblies Property
SilverlightApp Class See Also Send Feedback
Gets the list of custom assemblies included

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string[] CustomAssemblies { get; }
Visual Basic
Public Shared ReadOnly Property CustomAssemblies As String()
    Get
Visual C++
public:
static property array<String^>^ CustomAssemblies {
    array<String^>^ get ();
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Desktop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Desktop Property
SilverlightApp Class See Also Send Feedback
Get the Desktop object used for real Keyboard/Mouse automation.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Desktop Desktop { get; }
Visual Basic
Public ReadOnly Property Desktop As Desktop
    Get
Visual C++
public:
virtual property Desktop^ Desktop {
    Desktop^ get () sealed;
}

Implements

IApplication..::..Desktop

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


EnableValidateMouseLocation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..EnableValidateMouseLocation Property
SilverlightApp Class See Also Send Feedback
Gets / Sets whether to validate mouse click locations before allowing user interaction automation

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableValidateMouseLocation { get; set; }
Visual Basic
Public Property EnableValidateMouseLocation As Boolean
    Get
    Set
Visual C++
public:
virtual property bool EnableValidateMouseLocation {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IApplication..::..EnableValidateMouseLocation

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Find Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Find Property
SilverlightApp Class See Also Send Feedback
Gets the XamlFind object used to search the silverlight plugin VisualTree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualFind Find { get; }
Visual Basic
Public ReadOnly Property Find As VisualFind
    Get
Visual C++
public:
virtual property VisualFind^ Find {
    VisualFind^ get () sealed;
}

Implements

IApplication..::..Find

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


FriendlyName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..FriendlyName Property
SilverlightApp Class See Also Send Feedback
Returns a friendly name for this host

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string FriendlyName { get; }
Visual Basic
Public Overrides ReadOnly Property FriendlyName As String
    Get
Visual C++
public:
virtual property String^ FriendlyName {
    String^ get () override;
}

Return Value

Implements

IAutomationHost..::..FriendlyName
IAutomationHost..::..FriendlyName

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Host Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Host Property
SilverlightApp Class See Also Send Feedback
Gets the Html tag hosting this Silverlight App as an HtmlControl object. (The parent Html tag of the object/embed tag)

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlControl Host { get; }
Visual Basic
Public ReadOnly Property Host As HtmlControl
    Get
Visual C++
public:
property HtmlControl^ Host {
    HtmlControl^ get ();
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


IsConnected Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..IsConnected Property
SilverlightApp Class See Also Send Feedback
Gets whether the SilverlightApp is connected to the automation host

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsConnected { get; }
Visual Basic
Public ReadOnly Property IsConnected As Boolean
    Get
Visual C++
public:
property bool IsConnected {
    bool get ();
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


IsLoaded Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..IsLoaded Property
SilverlightApp Class See Also Send Feedback
Gets whether this plugin is loaded or not.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsLoaded { get; }
Visual Basic
Public ReadOnly Property IsLoaded As Boolean
    Get
Visual C++
public:
property bool IsLoaded {
    bool get ();
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


IsRecordingHost Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..IsRecordingHost Property
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightApp.IsRecordingHost"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsRecordingHost { get; }
Visual Basic
Public ReadOnly Property IsRecordingHost As Boolean
    Get
Visual C++
public:
virtual property bool IsRecordingHost {
    bool get () sealed;
}

Implements

IApplication..::..IsRecordingHost

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


ManagedProxy Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..ManagedProxy Property
SilverlightApp Class See Also Send Feedback
The proxy that allows this app to communicate with the managed world inside a silverlight application

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ICommunicationProxy ManagedProxy { get; }
Visual Basic
Public ReadOnly Property ManagedProxy As ICommunicationProxy
    Get
Visual C++
public:
virtual property ICommunicationProxy^ ManagedProxy {
    ICommunicationProxy^ get () sealed;
}

Implements

IApplication..::..ManagedProxy

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Manager Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Manager Property
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightApp.Manager"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Manager Manager { get; }
Visual Basic
Public Overrides ReadOnly Property Manager As Manager
    Get
Visual C++
public:
virtual property Manager^ Manager {
    Manager^ get () override;
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


OwnerBrowser Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..OwnerBrowser Property
SilverlightApp Class See Also Send Feedback
Gets the owner browser object instance of this silverlight application.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Browser OwnerBrowser { get; }
Visual Basic
Public ReadOnly Property OwnerBrowser As Browser
    Get
Visual C++
public:
property Browser^ OwnerBrowser {
    Browser^ get ();
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Plugin Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Plugin Property
SilverlightApp Class See Also Send Feedback
Gets the actual plugin element (object or embed) as an HtmlControl

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlControl Plugin { get; }
Visual Basic
Public ReadOnly Property Plugin As HtmlControl
    Get
Visual C++
public:
property HtmlControl^ Plugin {
    HtmlControl^ get ();
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Popups Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Popups Property
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightApp.Popups"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<VisualTreeHost> Popups { get; }
Visual Basic
Public ReadOnly Property Popups As IList(Of VisualTreeHost)
    Get
Visual C++
public:
virtual property IList<VisualTreeHost^>^ Popups {
    IList<VisualTreeHost^>^ get () sealed;
}

Implements

IApplication..::..Popups

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Settings Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Settings Property
SilverlightApp Class See Also Send Feedback
Gets the 'settings' object of this plugin: plugin.settings.xxx

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightAppSettings Settings { get; }
Visual Basic
Public ReadOnly Property Settings As SilverlightAppSettings
    Get
Visual C++
public:
property SilverlightAppSettings^ Settings {
    SilverlightAppSettings^ get ();
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


TechnologyType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..TechnologyType Property
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightApp.TechnologyType"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override TechnologyType TechnologyType { get; }
Visual Basic
Public Overrides ReadOnly Property TechnologyType As TechnologyType
    Get
Visual C++
public:
virtual property TechnologyType TechnologyType {
    TechnologyType get () override;
}

Implements

IAutomationHost..::..TechnologyType
IAutomationHost..::..TechnologyType

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


UniqueId Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..UniqueId Property
SilverlightApp Class See Also Send Feedback
A unique identifier that identifies this plugin instance. This id is updated only when the plug-in is reloaded on a postback or a browser refresh.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string UniqueId { get; }
Visual Basic
Public Overrides ReadOnly Property UniqueId As String
    Get
Visual C++
public:
virtual property String^ UniqueId {
    String^ get () override;
}

Implements

IAutomationHost..::..UniqueId
IAutomationHost..::..UniqueId

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


Window Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightApp..::..Window Property
SilverlightApp Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightApp.Window"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Window Window { get; }
Visual Basic
Public Overrides ReadOnly Property Window As Window
    Get
Visual C++
public:
virtual property Window^ Window {
    Window^ get () override;
}

See Also

SilverlightApp Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppContent Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppContent Members
SilverlightAppContent Class Methods Properties See Also Send Feedback

The SilverlightAppContent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualHeight |
Public property | ActualWidth |
Public property | FullScreen |

See Also

SilverlightAppContent Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppContent Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppContent Methods
SilverlightAppContent Class See Also Send Feedback

The SilverlightAppContent type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>) |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SilverlightAppContent Class
ArtOfTest.WebAii.Silverlight Namespace


GetValue(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppContent..::..GetValue<(Of <(<'T>)>)> Method
SilverlightAppContent Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppContent.GetValue``1(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T GetValue<T>(
    string propertyName
)
Visual Basic
Public Function GetValue(Of T) ( _
    propertyName As String _
) As T
Visual C++
public:
generic<typename T>
T GetValue(
    String^ propertyName
)

Parameters

propertyName
Type: System..::..String

[Missing <param name="propertyName"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppContent.GetValue``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppContent.GetValue``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppContent.GetValue``1(System.String)"]

See Also

SilverlightAppContent Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppContent Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppContent Properties
SilverlightAppContent Class See Also Send Feedback

The SilverlightAppContent type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight |
Public property | ActualWidth |
Public property | FullScreen |

See Also

SilverlightAppContent Class
ArtOfTest.WebAii.Silverlight Namespace


ActualHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppContent..::..ActualHeight Property
SilverlightAppContent Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightAppContent.ActualHeight"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ActualHeight { get; }
Visual Basic
Public ReadOnly Property ActualHeight As Integer
    Get
Visual C++
public:
property int ActualHeight {
    int get ();
}

See Also

SilverlightAppContent Class
ArtOfTest.WebAii.Silverlight Namespace


ActualWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppContent..::..ActualWidth Property
SilverlightAppContent Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightAppContent.ActualWidth"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ActualWidth { get; }
Visual Basic
Public ReadOnly Property ActualWidth As Integer
    Get
Visual C++
public:
property int ActualWidth {
    int get ();
}

See Also

SilverlightAppContent Class
ArtOfTest.WebAii.Silverlight Namespace


FullScreen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppContent..::..FullScreen Property
SilverlightAppContent Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightAppContent.FullScreen"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool FullScreen { get; }
Visual Basic
Public ReadOnly Property FullScreen As Boolean
    Get
Visual C++
public:
property bool FullScreen {
    bool get ();
}

See Also

SilverlightAppContent Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppFinder Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppFinder Members
SilverlightAppFinder Class Methods See Also Send Feedback

The SilverlightAppFinder type exposes the following members.

Methods

Name | Description
GetSilverlightAppIndex | Finds the index into the SilverlightApp array of the specified plugin
IsSilverlightPlugin | Detects whether the element is an object tag hosting a Silverlight plugin
SilverlightApps | Returns an array of all Silverlight Applications on this page.

See Also

SilverlightAppFinder Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppFinder Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppFinder Methods
SilverlightAppFinder Class See Also Send Feedback

The SilverlightAppFinder type exposes the following members.

Methods

Name | Description
GetSilverlightAppIndex | Finds the index into the SilverlightApp array of the specified plugin
IsSilverlightPlugin | Detects whether the element is an object tag hosting a Silverlight plugin
SilverlightApps | Returns an array of all Silverlight Applications on this page.

See Also

SilverlightAppFinder Class
ArtOfTest.WebAii.Silverlight Namespace


GetSilverlightAppIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppFinder..::..GetSilverlightAppIndex Method
SilverlightAppFinder Class See Also Send Feedback
Finds the index into the SilverlightApp array of the specified plugin

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int GetSilverlightAppIndex(
    this Browser browser,
    HtmlControl plugin
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetSilverlightAppIndex ( _
    browser As Browser, _
    plugin As HtmlControl _
) As Integer
Visual C++
[ExtensionAttribute]
public:
static int GetSilverlightAppIndex(
    Browser^ browser,
    HtmlControl^ plugin
)

Parameters

browser
Type: ArtOfTest.WebAii.Core..::..Browser
The containing Browser
plugin
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The Silverlight plugin object of which we're looking up the index

Return Value

The index of the specified plugin in the browser's SilverlightApps list, or -1 if not found

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Browser. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

SilverlightAppFinder Class
ArtOfTest.WebAii.Silverlight Namespace


IsSilverlightPlugin Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppFinder..::..IsSilverlightPlugin Method
SilverlightAppFinder Class See Also Send Feedback
Detects whether the element is an object tag hosting a Silverlight plugin

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsSilverlightPlugin(
    this Element element
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsSilverlightPlugin ( _
    element As Element _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool IsSilverlightPlugin(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to inspect

Return Value

Returns true/false whether the element is a Silverlight plugin

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Element. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

SilverlightAppFinder Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightApps Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppFinder..::..SilverlightApps Method
SilverlightAppFinder Class See Also Send Feedback
Returns an array of all Silverlight Applications on this page.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static SilverlightAppsList SilverlightApps(
    this Browser browser
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SilverlightApps ( _
    browser As Browser _
) As SilverlightAppsList
Visual C++
[ExtensionAttribute]
public:
static SilverlightAppsList^ SilverlightApps(
    Browser^ browser
)

Parameters

browser
Type: ArtOfTest.WebAii.Core..::..Browser
The browser instance.

Return Value

An array of Silverlight Application.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Browser. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

SilverlightAppFinder Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppSettings Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings Members
SilverlightAppSettings Class Methods Properties See Also Send Feedback

The SilverlightAppSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Background | Gets the background color of the rectangular region that display XAML content.
Public property | EnableFramerateCounter | Gets a value that determines whether to display the current framerate in the hosting browser's status bar.
Public property | EnableHtmlAccess | Determines whether the hosted content in the Silverlight control has access to the browser Document Object Model (DOM). // BUG: Silverlight returns true but html access is disabled
Public property | EnableRedrawRegions | Gets the areas of the control that are being redrawn each frame.
Public property | MaxFrameRate | Gets the maximum number of frames to render per second.
Public property | Windowless | Gets whether the Silverlight control displays as a window-less control.

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppSettings Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings Methods
SilverlightAppSettings Class See Also Send Feedback

The SilverlightAppSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppSettings Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings Properties
SilverlightAppSettings Class See Also Send Feedback

The SilverlightAppSettings type exposes the following members.

Properties

 | Name | Description
Public property | Background | Gets the background color of the rectangular region that display XAML content.
Public property | EnableFramerateCounter | Gets a value that determines whether to display the current framerate in the hosting browser's status bar.
Public property | EnableHtmlAccess | Determines whether the hosted content in the Silverlight control has access to the browser Document Object Model (DOM). // BUG: Silverlight returns true but html access is disabled
Public property | EnableRedrawRegions | Gets the areas of the control that are being redrawn each frame.
Public property | MaxFrameRate | Gets the maximum number of frames to render per second.
Public property | Windowless | Gets whether the Silverlight control displays as a window-less control.

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings..::..Background Property
SilverlightAppSettings Class See Also Send Feedback
Gets the background color of the rectangular region that display XAML content.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Color Background { get; }
Visual Basic
Public ReadOnly Property Background As Color
    Get
Visual C++
public:
property Color Background {
    Color get ();
}

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


EnableFramerateCounter Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings..::..EnableFramerateCounter Property
SilverlightAppSettings Class See Also Send Feedback
Gets a value that determines whether to display the current framerate in the hosting browser's status bar.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableFramerateCounter { get; }
Visual Basic
Public ReadOnly Property EnableFramerateCounter As Boolean
    Get
Visual C++
public:
property bool EnableFramerateCounter {
    bool get ();
}

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


EnableHtmlAccess Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings..::..EnableHtmlAccess Property
SilverlightAppSettings Class See Also Send Feedback
Determines whether the hosted content in the Silverlight control has access to the browser Document Object Model (DOM). // BUG: Silverlight returns true but html access is disabled

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableHtmlAccess { get; }
Visual Basic
Public ReadOnly Property EnableHtmlAccess As Boolean
    Get
Visual C++
public:
property bool EnableHtmlAccess {
    bool get ();
}

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


EnableRedrawRegions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings..::..EnableRedrawRegions Property
SilverlightAppSettings Class See Also Send Feedback
Gets the areas of the control that are being redrawn each frame.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool EnableRedrawRegions { get; }
Visual Basic
Public ReadOnly Property EnableRedrawRegions As Boolean
    Get
Visual C++
public:
property bool EnableRedrawRegions {
    bool get ();
}

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


MaxFrameRate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings..::..MaxFrameRate Property
SilverlightAppSettings Class See Also Send Feedback
Gets the maximum number of frames to render per second.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MaxFrameRate { get; }
Visual Basic
Public ReadOnly Property MaxFrameRate As Integer
    Get
Visual C++
public:
property int MaxFrameRate {
    int get ();
}

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


Windowless Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppSettings..::..Windowless Property
SilverlightAppSettings Class See Also Send Feedback
Gets whether the Silverlight control displays as a window-less control.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Windowless { get; }
Visual Basic
Public ReadOnly Property Windowless As Boolean
    Get
Visual C++
public:
property bool Windowless {
    bool get ();
}

See Also

SilverlightAppSettings Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppsList Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList Members
SilverlightAppsList Class Constructors Methods Properties See Also Send Feedback

The SilverlightAppsList type exposes the following members.

Constructors

 | Name | Description
Public method | SilverlightAppsList | Constructs a new SilverlightAppsList object.

Methods

 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetApp | Returns the SilverlightApplication without calling Connect on it. You can use this method to call the Connect(loadTimeout) with a custom timeout for your application
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item[([( Int32])]) | Get a Silverlight Application using its index.
Public property | Item[([( String])]) | Get a Silverlight Application using its html host id (i.e the owner div id)

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppsList Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList Constructor
SilverlightAppsList Class See Also Send Feedback
Constructs a new SilverlightAppsList object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightAppsList()
Visual Basic
Public Sub New
Visual C++
public:
SilverlightAppsList()

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppsList Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList Methods
SilverlightAppsList Class See Also Send Feedback

The SilverlightAppsList type exposes the following members.

Methods

 | Name | Description
Public method | Add |
Public method | Clear |
Public method | Contains |
Public method | CopyTo |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetApp | Returns the SilverlightApplication without calling Connect on it. You can use this method to call the Connect(loadTimeout) with a custom timeout for your application
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


Add Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..Add Method
SilverlightAppsList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Add(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Add(
    SilverlightApp item
)
Visual Basic
Public Sub Add ( _
    item As SilverlightApp _
)
Visual C++
public:
virtual void Add(
    SilverlightApp^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Silverlight..::..SilverlightApp

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Add(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Add(T)

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..Clear Method
SilverlightAppsList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Clear"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ICollection<(Of <(<'T>)>)>..::..Clear()()()()

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


Contains Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..Contains Method
SilverlightAppsList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Contains(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Contains(
    SilverlightApp item
)
Visual Basic
Public Function Contains ( _
    item As SilverlightApp _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SilverlightApp^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Silverlight..::..SilverlightApp

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Contains(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Contains(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Contains(T)

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


CopyTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..CopyTo Method
SilverlightAppsList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.CopyTo(ArtOfTest.WebAii.Silverlight.SilverlightApp[],System.Int32)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CopyTo(
    SilverlightApp[] array,
    int arrayIndex
)
Visual Basic
Public Sub CopyTo ( _
    array As SilverlightApp(), _
    arrayIndex As Integer _
)
Visual C++
public:
virtual void CopyTo(
    array<SilverlightApp^>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: array< ArtOfTest.WebAii.Silverlight..::..SilverlightApp >[]()[][]

[Missing <param name="array"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.CopyTo(ArtOfTest.WebAii.Silverlight.SilverlightApp[],System.Int32)"]

arrayIndex
Type: System..::..Int32

[Missing <param name="arrayIndex"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.CopyTo(ArtOfTest.WebAii.Silverlight.SilverlightApp[],System.Int32)"]

Implements

ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


GetApp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..GetApp Method
SilverlightAppsList Class See Also Send Feedback
Returns the SilverlightApplication without calling Connect on it. You can use this method to call the Connect(loadTimeout) with a custom timeout for your application

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightApp GetApp(
    int index
)
Visual Basic
Public Function GetApp ( _
    index As Integer _
) As SilverlightApp
Visual C++
public:
SilverlightApp^ GetApp(
    int index
)

Parameters

index
Type: System..::..Int32
The application index

Return Value

The Silverlight Application

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


GetEnumerator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..GetEnumerator Method
SilverlightAppsList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.GetEnumerator"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEnumerator<SilverlightApp> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of SilverlightApp)
Visual C++
public:
virtual IEnumerator<SilverlightApp^>^ GetEnumerator() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.GetEnumerator"]

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


Remove Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..Remove Method
SilverlightAppsList Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Remove(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Remove(
    SilverlightApp item
)
Visual Basic
Public Function Remove ( _
    item As SilverlightApp _
) As Boolean
Visual C++
public:
virtual bool Remove(
    SilverlightApp^ item
) sealed

Parameters

item
Type: ArtOfTest.WebAii.Silverlight..::..SilverlightApp

[Missing <param name="item"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Remove(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Remove(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

Implements

ICollection<(Of <(<'T>)>)>..::..Remove(T)

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightAppsList Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList Properties
SilverlightAppsList Class See Also Send Feedback

The SilverlightAppsList type exposes the following members.

Properties

 | Name | Description
Public property | Count |
Public property | IsReadOnly |
Public property | Item[([( Int32])]) | Get a Silverlight Application using its index.
Public property | Item[([( String])]) | Get a Silverlight Application using its html host id (i.e the owner div id)

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


Count Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..Count Property
SilverlightAppsList Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.Count"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..Count

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..IsReadOnly Property
SilverlightAppsList Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightAppsList.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Implements

ICollection<(Of <(<'T>)>)>..::..IsReadOnly

See Also

SilverlightAppsList Class
ArtOfTest.WebAii.Silverlight Namespace


Item Property

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..Item Property
SilverlightAppsList Class See Also Send Feedback

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | Get a Silverlight Application using its index.
Public property | Item[([( String])]) | Get a Silverlight Application using its html host id (i.e the owner div id)

See Also

SilverlightAppsList Class
SilverlightAppsList Members
ArtOfTest.WebAii.Silverlight Namespace


Item Property (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..Item Property (Int32)
SilverlightAppsList Class See Also Send Feedback
Get a Silverlight Application using its index.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightApp this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As SilverlightApp
    Get
Visual C++
public:
property SilverlightApp^ default[int index] {
    SilverlightApp^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index

Return Value

The Silverlight App.

See Also

SilverlightAppsList Class
Item Overload
ArtOfTest.WebAii.Silverlight Namespace


Item Property (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightAppsList..::..Item Property (String)
SilverlightAppsList Class See Also Send Feedback
Get a Silverlight Application using its html host id (i.e the owner div id)

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightApp this[
    string hostId
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    hostId As String _
) As SilverlightApp
    Get
Visual C++
public:
property SilverlightApp^ default[String^ hostId] {
    SilverlightApp^ get (String^ hostId);
}

Parameters

hostId
Type: System..::..String
The host id

Return Value

The Silverlight App

See Also

SilverlightAppsList Class
Item Overload
ArtOfTest.WebAii.Silverlight Namespace


SilverlightCommand Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand Members
SilverlightCommand Class Constructors Methods Properties See Also Send Feedback

The SilverlightCommand type exposes the following members.

Constructors

 | Name | Description
Public method | SilverlightCommand | Initializes a new instance of the SilverlightCommand class

Methods

 | Name | Description
Public method | AsString | Return this command as a string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Method | Gets / Sets the method to invoke
Public property | Property | The property to use
Public property | Reference | Get or set the reference
Public property | Reference2 | Get / Set secondary reference
Public property | Type | Get or set the command type
Public property | Value | Additional info for this command

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightCommand Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand Constructor
SilverlightCommand Class See Also Send Feedback
Initializes a new instance of the SilverlightCommand class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightCommand(
    SilverlightCommandType type,
    IAutomationPeer peer
)
Visual Basic
Public Sub New ( _
    type As SilverlightCommandType, _
    peer As IAutomationPeer _
)
Visual C++
public:
SilverlightCommand(
    SilverlightCommandType type,
    IAutomationPeer^ peer
)

Parameters

type
Type: ArtOfTest.WebAii.Silverlight..::..SilverlightCommandType

[Missing <param name="type"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightCommand.#ctor(ArtOfTest.WebAii.Silverlight.SilverlightCommandType,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightCommand.#ctor(ArtOfTest.WebAii.Silverlight.SilverlightCommandType,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightCommand Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand Methods
SilverlightCommand Class See Also Send Feedback

The SilverlightCommand type exposes the following members.

Methods

 | Name | Description
Public method | AsString | Return this command as a string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


AsString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand..::..AsString Method
SilverlightCommand Class See Also Send Feedback
Return this command as a string.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string AsString()
Visual Basic
Public Function AsString As String
Visual C++
public:
String^ AsString()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightCommand.AsString"]

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


FromString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand..::..FromString Method
SilverlightCommand Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightCommand.FromString(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static SilverlightCommand FromString(
    string s
)
Visual Basic
Public Shared Function FromString ( _
    s As String _
) As SilverlightCommand
Visual C++
public:
static SilverlightCommand^ FromString(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightCommand.FromString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightCommand.FromString(System.String)"]

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightCommand Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand Properties
SilverlightCommand Class See Also Send Feedback

The SilverlightCommand type exposes the following members.

Properties

 | Name | Description
Public property | Method | Gets / Sets the method to invoke
Public property | Property | The property to use
Public property | Reference | Get or set the reference
Public property | Reference2 | Get / Set secondary reference
Public property | Type | Get or set the command type
Public property | Value | Additional info for this command

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


Method Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand..::..Method Property
SilverlightCommand Class See Also Send Feedback
Gets / Sets the method to invoke

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationMethod Method { get; set; }
Visual Basic
Public Property Method As AutomationMethod
    Get
    Set
Visual C++
public:
property AutomationMethod^ Method {
    AutomationMethod^ get ();
    void set (AutomationMethod^ value);
}

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


Property Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand..::..Property Property
SilverlightCommand Class See Also Send Feedback
The property to use

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationProperty Property { get; set; }
Visual Basic
Public Property Property As AutomationProperty
    Get
    Set
Visual C++
public:
property AutomationProperty^ Property {
    AutomationProperty^ get ();
    void set (AutomationProperty^ value);
}

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


Reference Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand..::..Reference Property
SilverlightCommand Class See Also Send Feedback
Get or set the reference

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationReference Reference { get; set; }
Visual Basic
Public Property Reference As AutomationReference
    Get
    Set
Visual C++
public:
property AutomationReference^ Reference {
    AutomationReference^ get ();
    void set (AutomationReference^ value);
}

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


Reference2 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand..::..Reference2 Property
SilverlightCommand Class See Also Send Feedback
Get / Set secondary reference

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutomationReference Reference2 { get; set; }
Visual Basic
Public Property Reference2 As AutomationReference
    Get
    Set
Visual C++
public:
property AutomationReference^ Reference2 {
    AutomationReference^ get ();
    void set (AutomationReference^ value);
}

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


Type Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand..::..Type Property
SilverlightCommand Class See Also Send Feedback
Get or set the command type

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightCommandType Type { get; set; }
Visual Basic
Public Property Type As SilverlightCommandType
    Get
    Set
Visual C++
public:
property SilverlightCommandType Type {
    SilverlightCommandType get ();
    void set (SilverlightCommandType value);
}

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightCommand..::..Value Property
SilverlightCommand Class See Also Send Feedback
Additional info for this command

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set
Visual C++
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

SilverlightCommand Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightProxy Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy Members
SilverlightProxy Class Constructors Methods Properties See Also Send Feedback

The SilverlightProxy type exposes the following members.

Constructors

 | Name | Description
Public method | SilverlightProxy | Initializes a new instance of the SilverlightProxy class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllVisualTrees |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPeerHashCode |
Public method | GetProperties |
Public method | GetProperty |
Public method | GetRectangle(IAutomationPeer) | Get the real rectangle of an elements
Public method | GetRectangle(IAutomationPeer, IAutomationPeer) | Get the rectangle of one element relative to another
Public method | GetTextRecursive |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualizedViewportOffset |
Public method | GetVisibility |
Public method | GetVisualTree(String) |
Public method | GetVisualTree(IAutomationPeer) |
Public method | GetVisualTree(String, String) |
Public method | GetVisualTree(IAutomationPeer, String) |
Public method | Highlight |
Public method | HitTest | Gets a list of all FrameworkElements under the specified point
Public method | InvokeMethod | Invokes method on automation peer's client side.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PublishKnownControlTypes | Publish Known Control types
Public method | ScrollToVisible |
Public method | SetProperty |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Application |

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightProxy Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy Constructor
SilverlightProxy Class See Also Send Feedback
Initializes a new instance of the SilverlightProxy class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightProxy(
    SilverlightApp hostApp
)
Visual Basic
Public Sub New ( _
    hostApp As SilverlightApp _
)
Visual C++
public:
SilverlightProxy(
    SilverlightApp^ hostApp
)

Parameters

hostApp
Type: ArtOfTest.WebAii.Silverlight..::..SilverlightApp

[Missing <param name="hostApp"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.#ctor(ArtOfTest.WebAii.Silverlight.SilverlightApp)"]

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightProxy Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy Methods
SilverlightProxy Class See Also Send Feedback

The SilverlightProxy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAllVisualTrees |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPeerHashCode |
Public method | GetProperties |
Public method | GetProperty |
Public method | GetRectangle(IAutomationPeer) | Get the real rectangle of an elements
Public method | GetRectangle(IAutomationPeer, IAutomationPeer) | Get the rectangle of one element relative to another
Public method | GetTextRecursive |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVirtualizedViewportOffset |
Public method | GetVisibility |
Public method | GetVisualTree(String) |
Public method | GetVisualTree(IAutomationPeer) |
Public method | GetVisualTree(String, String) |
Public method | GetVisualTree(IAutomationPeer, String) |
Public method | Highlight |
Public method | HitTest | Gets a list of all FrameworkElements under the specified point
Public method | InvokeMethod | Invokes method on automation peer's client side.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PublishKnownControlTypes | Publish Known Control types
Public method | ScrollToVisible |
Public method | SetProperty |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


GetAllVisualTrees Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetAllVisualTrees Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetAllVisualTrees"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetAllVisualTrees()
Visual Basic
Public Function GetAllVisualTrees As String
Visual C++
public:
virtual String^ GetAllVisualTrees() sealed

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetAllVisualTrees"]

Implements

ICommunicationProxy..::..GetAllVisualTrees()()()()

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


GetPeerHashCode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetPeerHashCode Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetPeerHashCode(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int GetPeerHashCode(
    IAutomationPeer peer
)
Visual Basic
Public Function GetPeerHashCode ( _
    peer As IAutomationPeer _
) As Integer
Visual C++
public:
virtual int GetPeerHashCode(
    IAutomationPeer^ peer
) sealed

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetPeerHashCode(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetPeerHashCode(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..GetPeerHashCode(IAutomationPeer)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


GetProperties Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetProperties Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetProperties(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<string, string> GetProperties(
    IAutomationPeer peer
)
Visual Basic
Public Function GetProperties ( _
    peer As IAutomationPeer _
) As Dictionary(Of String, String)
Visual C++
public:
virtual Dictionary<String^, String^>^ GetProperties(
    IAutomationPeer^ peer
) sealed

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetProperties(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetProperties(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..GetProperties(IAutomationPeer)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


GetProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetProperty Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object GetProperty(
    AutomationProperty property,
    IAutomationPeer peer
)
Visual Basic
Public Function GetProperty ( _
    property As AutomationProperty, _
    peer As IAutomationPeer _
) As Object
Visual C++
public:
virtual Object^ GetProperty(
    AutomationProperty^ property,
    IAutomationPeer^ peer
) sealed

Parameters

property
Type: ArtOfTest.WebAii.Silverlight..::..AutomationProperty

[Missing <param name="property"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..GetProperty(AutomationProperty, IAutomationPeer)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetRectangle Method
SilverlightProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle(IAutomationPeer) | Get the real rectangle of an elements
Public method | GetRectangle(IAutomationPeer, IAutomationPeer) | Get the rectangle of one element relative to another

See Also

SilverlightProxy Class
SilverlightProxy Members
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method (IAutomationPeer)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetRectangle Method (IAutomationPeer)
SilverlightProxy Class See Also Send Feedback
Get the real rectangle of an elements

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object GetRectangle(
    IAutomationPeer peer
)
Visual Basic
Public Function GetRectangle ( _
    peer As IAutomationPeer _
) As Object
Visual C++
public:
virtual Object^ GetRectangle(
    IAutomationPeer^ peer
) sealed

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetRectangle(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetRectangle(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..GetRectangle(IAutomationPeer)

See Also

SilverlightProxy Class
GetRectangle Overload
ArtOfTest.WebAii.Silverlight Namespace


GetRectangle Method (IAutomationPeer, IAutomationPeer)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetRectangle Method (IAutomationPeer, IAutomationPeer)
SilverlightProxy Class See Also Send Feedback
Get the rectangle of one element relative to another

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object GetRectangle(
    IAutomationPeer peer,
    IAutomationPeer relativeTo
)
Visual Basic
Public Function GetRectangle ( _
    peer As IAutomationPeer, _
    relativeTo As IAutomationPeer _
) As Object
Visual C++
public:
virtual Object^ GetRectangle(
    IAutomationPeer^ peer,
    IAutomationPeer^ relativeTo
) sealed

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetRectangle(ArtOfTest.WebAii.Silverlight.IAutomationPeer,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

relativeTo
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="relativeTo"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetRectangle(ArtOfTest.WebAii.Silverlight.IAutomationPeer,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetRectangle(ArtOfTest.WebAii.Silverlight.IAutomationPeer,ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..GetRectangle(IAutomationPeer, IAutomationPeer)

See Also

SilverlightProxy Class
GetRectangle Overload
ArtOfTest.WebAii.Silverlight Namespace


GetTextRecursive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetTextRecursive Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetTextRecursive(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetTextRecursive(
    AutomationReference targetRef
)
Visual Basic
Public Function GetTextRecursive ( _
    targetRef As AutomationReference _
) As String
Visual C++
public:
virtual String^ GetTextRecursive(
    AutomationReference^ targetRef
) sealed

Parameters

targetRef
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference

[Missing <param name="targetRef"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetTextRecursive(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetTextRecursive(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

ICommunicationProxy..::..GetTextRecursive(AutomationReference)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


GetVirtualizedViewportOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetVirtualizedViewportOffset Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVirtualizedViewportOffset(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int GetVirtualizedViewportOffset(
    IAutomationPeer virtualizingPanel
)
Visual Basic
Public Function GetVirtualizedViewportOffset ( _
    virtualizingPanel As IAutomationPeer _
) As Integer
Visual C++
public:
virtual int GetVirtualizedViewportOffset(
    IAutomationPeer^ virtualizingPanel
) sealed

Parameters

virtualizingPanel
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="virtualizingPanel"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVirtualizedViewportOffset(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVirtualizedViewportOffset(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..GetVirtualizedViewportOffset(IAutomationPeer)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


GetVisibility Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetVisibility Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisibility(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility GetVisibility(
    IAutomationPeer peer
)
Visual Basic
Public Function GetVisibility ( _
    peer As IAutomationPeer _
) As Visibility
Visual C++
public:
virtual Visibility GetVisibility(
    IAutomationPeer^ peer
) sealed

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisibility(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisibility(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..GetVisibility(IAutomationPeer)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetVisualTree Method
SilverlightProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetVisualTree(String) |
Public method | GetVisualTree(IAutomationPeer) |
Public method | GetVisualTree(String, String) |
Public method | GetVisualTree(IAutomationPeer, String) |

See Also

SilverlightProxy Class
SilverlightProxy Members
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetVisualTree Method (String)
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetVisualTree(
    string startAt
)
Visual Basic
Public Function GetVisualTree ( _
    startAt As String _
) As String
Visual C++
public:
virtual String^ GetVisualTree(
    String^ startAt
) sealed

Parameters

startAt
Type: System..::..String

[Missing <param name="startAt"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(System.String)"]

Implements

ICommunicationProxy..::..GetVisualTree(String)

See Also

SilverlightProxy Class
GetVisualTree Overload
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method (IAutomationPeer)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetVisualTree Method (IAutomationPeer)
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetVisualTree(
    IAutomationPeer root
)
Visual Basic
Public Function GetVisualTree ( _
    root As IAutomationPeer _
) As String
Visual C++
public:
virtual String^ GetVisualTree(
    IAutomationPeer^ root
) sealed

Parameters

root
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="root"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..GetVisualTree(IAutomationPeer)

See Also

SilverlightProxy Class
GetVisualTree Overload
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetVisualTree Method (String, String)
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(System.String,System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetVisualTree(
    string startAt,
    string hash
)
Visual Basic
Public Function GetVisualTree ( _
    startAt As String, _
    hash As String _
) As String
Visual C++
public:
virtual String^ GetVisualTree(
    String^ startAt,
    String^ hash
) sealed

Parameters

startAt
Type: System..::..String

[Missing <param name="startAt"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(System.String,System.String)"]

hash
Type: System..::..String

[Missing <param name="hash"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(System.String,System.String)"]

Implements

ICommunicationProxy..::..GetVisualTree(String, String)

See Also

SilverlightProxy Class
GetVisualTree Overload
ArtOfTest.WebAii.Silverlight Namespace


GetVisualTree Method (IAutomationPeer, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..GetVisualTree Method (IAutomationPeer, String)
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GetVisualTree(
    IAutomationPeer root,
    string hash
)
Visual Basic
Public Function GetVisualTree ( _
    root As IAutomationPeer, _
    hash As String _
) As String
Visual C++
public:
virtual String^ GetVisualTree(
    IAutomationPeer^ root,
    String^ hash
) sealed

Parameters

root
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="root"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.String)"]

hash
Type: System..::..String

[Missing <param name="hash"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.GetVisualTree(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.String)"]

Implements

ICommunicationProxy..::..GetVisualTree(IAutomationPeer, String)

See Also

SilverlightProxy Class
GetVisualTree Overload
ArtOfTest.WebAii.Silverlight Namespace


Highlight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..Highlight Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.Highlight(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Highlight(
    IAutomationPeer peer,
    bool clear
)
Visual Basic
Public Sub Highlight ( _
    peer As IAutomationPeer, _
    clear As Boolean _
)
Visual C++
public:
virtual void Highlight(
    IAutomationPeer^ peer,
    bool clear
) sealed

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.Highlight(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Boolean)"]

clear
Type: System..::..Boolean

[Missing <param name="clear"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.Highlight(ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Boolean)"]

Implements

ICommunicationProxy..::..Highlight(IAutomationPeer, Boolean)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


HitTest Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..HitTest Method
SilverlightProxy Class See Also Send Feedback
Gets a list of all FrameworkElements under the specified point

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> HitTest(
    Point p
)
Visual Basic
Public Function HitTest ( _
    p As Point _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ HitTest(
    Point p
)

Parameters

p
Type: System.Drawing..::..Point
The point to hit test

Return Value

List of all elements under the point

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


InvokeMethod Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..InvokeMethod Method
SilverlightProxy Class See Also Send Feedback
Invokes method on automation peer's client side.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object InvokeMethod(
    AutomationMethod method,
    IAutomationPeer peer
)
Visual Basic
Public Function InvokeMethod ( _
    method As AutomationMethod, _
    peer As IAutomationPeer _
) As Object
Visual C++
public:
virtual Object^ InvokeMethod(
    AutomationMethod^ method,
    IAutomationPeer^ peer
) sealed

Parameters

method
Type: ArtOfTest.WebAii.Silverlight..::..AutomationMethod
Method to be invoked.
peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer
Automation peer, containing the method.

Return Value

The object client side method returned.

Implements

ICommunicationProxy..::..InvokeMethod(AutomationMethod, IAutomationPeer)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


PublishKnownControlTypes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..PublishKnownControlTypes Method
SilverlightProxy Class See Also Send Feedback
Publish Known Control types

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void PublishKnownControlTypes(
    List<string> knownTypes
)
Visual Basic
Public Sub PublishKnownControlTypes ( _
    knownTypes As List(Of String) _
)
Visual C++
public:
virtual void PublishKnownControlTypes(
    List<String^>^ knownTypes
) sealed

Parameters

knownTypes
Type: System.Collections.Generic..::..List <(Of <(<' String >)>)>

[Missing <param name="knownTypes"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.PublishKnownControlTypes(System.Collections.Generic.List{System.String})"]

Implements

ICommunicationProxy..::..PublishKnownControlTypes(List<(Of <<'(String>)>>))

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


ScrollToVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..ScrollToVisible Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.ScrollToVisible(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ScrollToVisible(
    IAutomationPeer peer
)
Visual Basic
Public Sub ScrollToVisible ( _
    peer As IAutomationPeer _
)
Visual C++
public:
virtual void ScrollToVisible(
    IAutomationPeer^ peer
) sealed

Parameters

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.ScrollToVisible(ArtOfTest.WebAii.Silverlight.IAutomationPeer)"]

Implements

ICommunicationProxy..::..ScrollToVisible(IAutomationPeer)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


SetProperty Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..SetProperty Method
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.SetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Object)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetProperty(
    AutomationProperty property,
    IAutomationPeer peer,
    Object value
)
Visual Basic
Public Sub SetProperty ( _
    property As AutomationProperty, _
    peer As IAutomationPeer, _
    value As Object _
)
Visual C++
public:
virtual void SetProperty(
    AutomationProperty^ property,
    IAutomationPeer^ peer,
    Object^ value
) sealed

Parameters

property
Type: ArtOfTest.WebAii.Silverlight..::..AutomationProperty

[Missing <param name="property"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.SetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Object)"]

peer
Type: ArtOfTest.WebAii.Silverlight..::..IAutomationPeer

[Missing <param name="peer"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.SetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Object)"]

value
Type: System..::..Object

[Missing <param name="value"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightProxy.SetProperty(ArtOfTest.WebAii.Silverlight.AutomationProperty,ArtOfTest.WebAii.Silverlight.IAutomationPeer,System.Object)"]

Implements

ICommunicationProxy..::..SetProperty(AutomationProperty, IAutomationPeer, Object)

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightProxy Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy Properties
SilverlightProxy Class See Also Send Feedback

The SilverlightProxy type exposes the following members.

Properties

 | Name | Description
Public property | Application |

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


Application Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightProxy..::..Application Property
SilverlightProxy Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.SilverlightProxy.Application"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IApplication Application { get; }
Visual Basic
Public ReadOnly Property Application As IApplication
    Get
Visual C++
public:
virtual property IApplication^ Application {
    IApplication^ get () sealed;
}

Implements

ICommunicationProxy..::..Application

See Also

SilverlightProxy Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightResponse Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse Members
SilverlightResponse Class Constructors Methods Fields See Also Send Feedback

The SilverlightResponse type exposes the following members.

Constructors

 | Name | Description
Public method | SilverlightResponse | Initializes a new instance of the SilverlightResponse class

Methods

 | Name | Description
Public method | AsString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Error |
Public field | Out |
Public field | Status | The returned status from the Silverlignt client after processing a Silverlight command. Either OK, ERROR or ELEMENT_NOT_FOUND.
Public field | TreeChanged |

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightResponse Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse Constructor
SilverlightResponse Class See Also Send Feedback
Initializes a new instance of the SilverlightResponse class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SilverlightResponse()
Visual Basic
Public Sub New
Visual C++
public:
SilverlightResponse()

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightResponse Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse Fields
SilverlightResponse Class See Also Send Feedback

The SilverlightResponse type exposes the following members.

Fields

 | Name | Description
Public field | Error |
Public field | Out |
Public field | Status | The returned status from the Silverlignt client after processing a Silverlight command. Either OK, ERROR or ELEMENT_NOT_FOUND.
Public field | TreeChanged |

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


Error Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse..::..Error Field
SilverlightResponse Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.SilverlightResponse.Error"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Error
Visual Basic
Public Error As String
Visual C++
public:
String^ Error

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


Out Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse..::..Out Field
SilverlightResponse Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.SilverlightResponse.Out"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Out
Visual Basic
Public Out As String
Visual C++
public:
String^ Out

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


Status Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse..::..Status Field
SilverlightResponse Class See Also Send Feedback
The returned status from the Silverlignt client after processing a Silverlight command. Either OK, ERROR or ELEMENT_NOT_FOUND.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ResponseStatus Status
Visual Basic
Public Status As ResponseStatus
Visual C++
public:
ResponseStatus Status

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


TreeChanged Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse..::..TreeChanged Field
SilverlightResponse Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.SilverlightResponse.TreeChanged"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool TreeChanged
Visual Basic
Public TreeChanged As Boolean
Visual C++
public:
bool TreeChanged

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


SilverlightResponse Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse Methods
SilverlightResponse Class See Also Send Feedback

The SilverlightResponse type exposes the following members.

Methods

 | Name | Description
Public method | AsString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromString |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


AsString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse..::..AsString Method
SilverlightResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightResponse.AsString"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string AsString()
Visual Basic
Public Function AsString As String
Visual C++
public:
String^ AsString()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightResponse.AsString"]

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


FromString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SilverlightResponse..::..FromString Method
SilverlightResponse Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightResponse.FromString(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static SilverlightResponse FromString(
    string s
)
Visual Basic
Public Shared Function FromString ( _
    s As String _
) As SilverlightResponse
Visual C++
public:
static SilverlightResponse^ FromString(
    String^ s
)

Parameters

s
Type: System..::..String

[Missing <param name="s"/> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightResponse.FromString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.SilverlightResponse.FromString(System.String)"]

See Also

SilverlightResponse Class
ArtOfTest.WebAii.Silverlight Namespace


UserInteraction Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction Members
UserInteraction Class Methods See Also Send Feedback

The UserInteraction type exposes the following members.

Methods

 | Name | Description
Public method | Click()()()() | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Point) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Point, OffsetReference) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Int32, Int32, OffsetReference) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType) |
Public method | Click(MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType, Keys) | Click this control by moving the mouse to it and click it.
Public method | ClickPoint(Point) | Click an absolute point on the screen.
Public method | ClickPoint(MouseClickType, Point) | Click an absolute point on the screen.
Public method | DetectHotSpot(Int32) | Get the hot spot within this element that causes the mouse to change shape.
Public method | DetectHotSpot(Int32, Cursor) | Get the hot spot within this element that causes the mouse to change to the specified cursor
Public method | DragTo(FrameworkElement) | Drag this element from its center to the center of the dropTarget
Public method | DragTo(Int32, Int32) | Drag this element from its center to the x,y offset.
Public method | DragTo(Int32, Int32, Boolean) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Boolean, Cursor, Int32) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Int32, Int32, OffsetReference) | Drag this element from a specified offset
Public method | DragTo(Int32, Int32, Boolean, Cursor, Int32, Boolean) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Int32, Int32, OffsetReference, Boolean) | Drag this element from a specified offset
Public method | DragTo(Int32, Int32, OffsetReference, FrameworkElement, Int32, Int32, OffsetReference) | Drag this element to the dropTarget
Public method | DragTo(Int32, Int32, OffsetReference, ActionPointUnitType, FrameworkElement, Int32, Int32, OffsetReference, ActionPointUnitType, Boolean) | Drag this element to the dropTarget
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HoverOver()()()() | Hover over this element.
Public method | HoverOver(Point) | Hover over a specific point relative to the element.
Public method | HoverOver(Int32, Int32, OffsetReference) | Hover over a specific point in this element.
Public method | HoverOver(Int32, Int32, OffsetReference, ActionPointUnitType) | Hover over a specific point in this element.
Public method | KeyDown | Press key down.
Public method | KeyPress | Press a key and hold it down for a specific period of time.
Public method | KeyUp | Press key up.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseEnter | Enter this element from a certain direction.
Public method | MouseLeave | Leave this element from a certain direction.
Public method | MouseMove | Move the mouse along the defined path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TurnMouseWheel | Turn the mouse wheel over over this element.
Public method | TypeText(String, Int32) | Type text as a real user. By default click the element to place the cursor in it.
Public method | TypeText(String, Int32, Boolean) | Type text as a real user.
Public method | TypeText(String, Int32, Int32, Boolean, Boolean) | Type text as a real user.

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


UserInteraction Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction Methods
UserInteraction Class See Also Send Feedback

The UserInteraction type exposes the following members.

Methods

 | Name | Description
Public method | Click()()()() | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Point) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Point, OffsetReference) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Int32, Int32, OffsetReference) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType) |
Public method | Click(MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType, Keys) | Click this control by moving the mouse to it and click it.
Public method | ClickPoint(Point) | Click an absolute point on the screen.
Public method | ClickPoint(MouseClickType, Point) | Click an absolute point on the screen.
Public method | DetectHotSpot(Int32) | Get the hot spot within this element that causes the mouse to change shape.
Public method | DetectHotSpot(Int32, Cursor) | Get the hot spot within this element that causes the mouse to change to the specified cursor
Public method | DragTo(FrameworkElement) | Drag this element from its center to the center of the dropTarget
Public method | DragTo(Int32, Int32) | Drag this element from its center to the x,y offset.
Public method | DragTo(Int32, Int32, Boolean) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Boolean, Cursor, Int32) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Int32, Int32, OffsetReference) | Drag this element from a specified offset
Public method | DragTo(Int32, Int32, Boolean, Cursor, Int32, Boolean) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Int32, Int32, OffsetReference, Boolean) | Drag this element from a specified offset
Public method | DragTo(Int32, Int32, OffsetReference, FrameworkElement, Int32, Int32, OffsetReference) | Drag this element to the dropTarget
Public method | DragTo(Int32, Int32, OffsetReference, ActionPointUnitType, FrameworkElement, Int32, Int32, OffsetReference, ActionPointUnitType, Boolean) | Drag this element to the dropTarget
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HoverOver()()()() | Hover over this element.
Public method | HoverOver(Point) | Hover over a specific point relative to the element.
Public method | HoverOver(Int32, Int32, OffsetReference) | Hover over a specific point in this element.
Public method | HoverOver(Int32, Int32, OffsetReference, ActionPointUnitType) | Hover over a specific point in this element.
Public method | KeyDown | Press key down.
Public method | KeyPress | Press a key and hold it down for a specific period of time.
Public method | KeyUp | Press key up.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseEnter | Enter this element from a certain direction.
Public method | MouseLeave | Leave this element from a certain direction.
Public method | MouseMove | Move the mouse along the defined path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TurnMouseWheel | Turn the mouse wheel over over this element.
Public method | TypeText(String, Int32) | Type text as a real user. By default click the element to place the cursor in it.
Public method | TypeText(String, Int32, Boolean) | Type text as a real user.
Public method | TypeText(String, Int32, Int32, Boolean, Boolean) | Type text as a real user.

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..Click Method
UserInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Point) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Point, OffsetReference) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Int32, Int32, OffsetReference) | Click this control by moving the mouse to it and click it.
Public method | Click(MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType) |
Public method | Click(MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType, Keys) | Click this control by moving the mouse to it and click it.

See Also

UserInteraction Class
UserInteraction Members
ArtOfTest.WebAii.Silverlight Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..Click Method
UserInteraction Class See Also Send Feedback
Click this control by moving the mouse to it and click it.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click()
Visual Basic
Public Sub Click
Visual C++
public:
void Click()

See Also

UserInteraction Class
Click Overload
ArtOfTest.WebAii.Silverlight Namespace


Click Method (MouseClickType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..Click Method (MouseClickType)
UserInteraction Class See Also Send Feedback
Click this control by moving the mouse to it and click it.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType _
)
Visual C++
public:
void Click(
    MouseClickType clickType
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The mouse click type to use.

See Also

UserInteraction Class
Click Overload
ArtOfTest.WebAii.Silverlight Namespace


Click Method (MouseClickType, Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..Click Method (MouseClickType, Point)
UserInteraction Class See Also Send Feedback
Click this control by moving the mouse to it and click it.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    Point offsetPoint
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    offsetPoint As Point _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    Point offsetPoint
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The mouse click type to use.
offsetPoint
Type: System.Drawing..::..Point
The offset point to use from the TopLeft corner of the control

See Also

UserInteraction Class
Click Overload
ArtOfTest.WebAii.Silverlight Namespace


Click Method (MouseClickType, Point, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..Click Method (MouseClickType, Point, OffsetReference)
UserInteraction Class See Also Send Feedback
Click this control by moving the mouse to it and click it.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    Point offsetPoint,
    OffsetReference reference
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    offsetPoint As Point, _
    reference As OffsetReference _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    Point offsetPoint,
    OffsetReference reference
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The mouse click type to use.
offsetPoint
Type: System.Drawing..::..Point
The offset point to use from the reference specified of the control
reference
Type: ArtOfTest.Common..::..OffsetReference
The desired reference point to use to calculate the offset

See Also

UserInteraction Class
Click Overload
ArtOfTest.WebAii.Silverlight Namespace


Click Method (MouseClickType, Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..Click Method (MouseClickType, Int32, Int32, OffsetReference)
UserInteraction Class See Also Send Feedback
Click this control by moving the mouse to it and click it.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    int x,
    int y,
    OffsetReference reference
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    x As Integer, _
    y As Integer, _
    reference As OffsetReference _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    int x,
    int y,
    OffsetReference reference
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The mouse click type to use.
x
Type: System..::..Int32
The X-coordinate of the offset point to use
y
Type: System..::..Int32
The Y-coordinate of the offset point to use
reference
Type: ArtOfTest.Common..::..OffsetReference
The desired reference point to use to calculate the offset

See Also

UserInteraction Class
Click Overload
ArtOfTest.WebAii.Silverlight Namespace


Click Method (MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..Click Method (MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType)
UserInteraction Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.Click(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    int x,
    int y,
    OffsetReference reference,
    ActionPointUnitType unitType
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    x As Integer, _
    y As Integer, _
    reference As OffsetReference, _
    unitType As ActionPointUnitType _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    int x,
    int y,
    OffsetReference reference,
    ActionPointUnitType unitType
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType

[Missing <param name="clickType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.Click(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType)"]

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.Click(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.Click(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType)"]

reference
Type: ArtOfTest.Common..::..OffsetReference

[Missing <param name="reference"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.Click(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType)"]

unitType
Type: ArtOfTest.Common..::..ActionPointUnitType

[Missing <param name="unitType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.Click(ArtOfTest.WebAii.Core.MouseClickType,System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType)"]

See Also

UserInteraction Class
Click Overload
ArtOfTest.WebAii.Silverlight Namespace


Click Method (MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType, Keys)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..Click Method (MouseClickType, Int32, Int32, OffsetReference, ActionPointUnitType, Keys)
UserInteraction Class See Also Send Feedback
Click this control by moving the mouse to it and click it.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    int x,
    int y,
    OffsetReference reference,
    ActionPointUnitType unitType,
    Keys modifierKeys
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    x As Integer, _
    y As Integer, _
    reference As OffsetReference, _
    unitType As ActionPointUnitType, _
    modifierKeys As Keys _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    int x,
    int y,
    OffsetReference reference,
    ActionPointUnitType unitType,
    Keys modifierKeys
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The mouse click type to use.
x
Type: System..::..Int32
The X-coordinate of the offset point to use
y
Type: System..::..Int32
The Y-coordinate of the offset point to use
reference
Type: ArtOfTest.Common..::..OffsetReference
The desired reference point to use to calculate the offset
unitType
Type: ArtOfTest.Common..::..ActionPointUnitType
The units in which the X and Y coordinates are specified
modifierKeys
Type: System.Windows.Forms..::..Keys
Combination of modifier keys to hold while clicking

See Also

UserInteraction Class
Click Overload
ArtOfTest.WebAii.Silverlight Namespace


ClickPoint Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..ClickPoint Method
UserInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClickPoint(Point) | Click an absolute point on the screen.
Public method | ClickPoint(MouseClickType, Point) | Click an absolute point on the screen.

See Also

UserInteraction Class
UserInteraction Members
ArtOfTest.WebAii.Silverlight Namespace


ClickPoint Method (Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..ClickPoint Method (Point)
UserInteraction Class See Also Send Feedback
Click an absolute point on the screen.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ClickPoint(
    Point absolutePoint
)
Visual Basic
Public Sub ClickPoint ( _
    absolutePoint As Point _
)
Visual C++
public:
void ClickPoint(
    Point absolutePoint
)

Parameters

absolutePoint
Type: System.Drawing..::..Point
The point to click.

See Also

UserInteraction Class
ClickPoint Overload
ArtOfTest.WebAii.Silverlight Namespace


ClickPoint Method (MouseClickType, Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..ClickPoint Method (MouseClickType, Point)
UserInteraction Class See Also Send Feedback
Click an absolute point on the screen.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ClickPoint(
    MouseClickType clickType,
    Point absolutePoint
)
Visual Basic
Public Sub ClickPoint ( _
    clickType As MouseClickType, _
    absolutePoint As Point _
)
Visual C++
public:
void ClickPoint(
    MouseClickType clickType,
    Point absolutePoint
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The mouse click type to use.
absolutePoint
Type: System.Drawing..::..Point
The absolute point to click

See Also

UserInteraction Class
ClickPoint Overload
ArtOfTest.WebAii.Silverlight Namespace


DetectHotSpot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DetectHotSpot Method
UserInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DetectHotSpot(Int32) | Get the hot spot within this element that causes the mouse to change shape.
Public method | DetectHotSpot(Int32, Cursor) | Get the hot spot within this element that causes the mouse to change to the specified cursor

See Also

UserInteraction Class
UserInteraction Members
ArtOfTest.WebAii.Silverlight Namespace


DetectHotSpot Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DetectHotSpot Method (Int32)
UserInteraction Class See Also Send Feedback
Get the hot spot within this element that causes the mouse to change shape.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point DetectHotSpot(
    int searchRadius
)
Visual Basic
Public Function DetectHotSpot ( _
    searchRadius As Integer _
) As Point
Visual C++
public:
Point DetectHotSpot(
    int searchRadius
)

Parameters

searchRadius
Type: System..::..Int32
The search radius from the center point of this element.

Return Value

The target point.

See Also

UserInteraction Class
DetectHotSpot Overload
ArtOfTest.WebAii.Silverlight Namespace


DetectHotSpot Method (Int32, Cursor)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DetectHotSpot Method (Int32, Cursor)
UserInteraction Class See Also Send Feedback
Get the hot spot within this element that causes the mouse to change to the specified cursor

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point DetectHotSpot(
    int searchRadius,
    Cursor cursor
)
Visual Basic
Public Function DetectHotSpot ( _
    searchRadius As Integer, _
    cursor As Cursor _
) As Point
Visual C++
public:
Point DetectHotSpot(
    int searchRadius,
    Cursor^ cursor
)

Parameters

searchRadius
Type: System..::..Int32
The search radius from the center point of this element.
cursor
Type: System.Windows.Forms..::..Cursor
The cursor to check.

Return Value

The target point.

See Also

UserInteraction Class
DetectHotSpot Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method
UserInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(FrameworkElement) | Drag this element from its center to the center of the dropTarget
Public method | DragTo(Int32, Int32) | Drag this element from its center to the x,y offset.
Public method | DragTo(Int32, Int32, Boolean) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Boolean, Cursor, Int32) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Int32, Int32, OffsetReference) | Drag this element from a specified offset
Public method | DragTo(Int32, Int32, Boolean, Cursor, Int32, Boolean) | Perform a drag to with an auto detection option of the hot spot.
Public method | DragTo(Int32, Int32, Int32, Int32, OffsetReference, Boolean) | Drag this element from a specified offset
Public method | DragTo(Int32, Int32, OffsetReference, FrameworkElement, Int32, Int32, OffsetReference) | Drag this element to the dropTarget
Public method | DragTo(Int32, Int32, OffsetReference, ActionPointUnitType, FrameworkElement, Int32, Int32, OffsetReference, ActionPointUnitType, Boolean) | Drag this element to the dropTarget

See Also

UserInteraction Class
UserInteraction Members
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (FrameworkElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (FrameworkElement)
UserInteraction Class See Also Send Feedback
Drag this element from its center to the center of the dropTarget

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    FrameworkElement dropTarget
)
Visual Basic
Public Sub DragTo ( _
    dropTarget As FrameworkElement _
)
Visual C++
public:
void DragTo(
    FrameworkElement^ dropTarget
)

Parameters

dropTarget
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The drop target element

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (Int32, Int32)
UserInteraction Class See Also Send Feedback
Drag this element from its center to the x,y offset.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    int x,
    int y
)
Visual Basic
Public Sub DragTo ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
void DragTo(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32
The x offset from the center.
y
Type: System..::..Int32
The y offset from the center.

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (Int32, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (Int32, Int32, Boolean)
UserInteraction Class See Also Send Feedback
Perform a drag to with an auto detection option of the hot spot.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    int x,
    int y,
    bool autoDetectStartHotSpot
)
Visual Basic
Public Sub DragTo ( _
    x As Integer, _
    y As Integer, _
    autoDetectStartHotSpot As Boolean _
)
Visual C++
public:
void DragTo(
    int x,
    int y,
    bool autoDetectStartHotSpot
)

Parameters

x
Type: System..::..Int32
The x offset from the center.
y
Type: System..::..Int32
The y offset from the center.
autoDetectStartHotSpot
Type: System..::..Boolean
Whether to auto-detect the hot spot at the start of the drag or no.

Remarks

The function uses mouse cursor change (from default cursor) to detect the hot spot. If the hot spot does not change the mouse when over it, this function will not be able to detect the spot. This function uses a 10 pixel range to scan for hotspots from the center point of this element.

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (Int32, Int32, Boolean, Cursor, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (Int32, Int32, Boolean, Cursor, Int32)
UserInteraction Class See Also Send Feedback
Perform a drag to with an auto detection option of the hot spot.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    int x,
    int y,
    bool autoDetectStartHotSpot,
    Cursor hotSpotCursor,
    int radius
)
Visual Basic
Public Sub DragTo ( _
    x As Integer, _
    y As Integer, _
    autoDetectStartHotSpot As Boolean, _
    hotSpotCursor As Cursor, _
    radius As Integer _
)
Visual C++
public:
void DragTo(
    int x,
    int y,
    bool autoDetectStartHotSpot,
    Cursor^ hotSpotCursor,
    int radius
)

Parameters

x
Type: System..::..Int32
The x offset from the center.
y
Type: System..::..Int32
The y offset from the center.
autoDetectStartHotSpot
Type: System..::..Boolean
Whether to auto-detect the hot spot at the start of the drag or no.
hotSpotCursor
Type: System.Windows.Forms..::..Cursor
A specific cursor to check for as the hot spot indicator
radius
Type: System..::..Int32
The search radios from the center point of the source element.

Remarks

The function uses mouse cursor change to detect the hot spot. If the hot spot does not change the mouse, this function will not be able to detect the spot

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (Int32, Int32, Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (Int32, Int32, Int32, Int32, OffsetReference)
UserInteraction Class See Also Send Feedback
Drag this element from a specified offset

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    int x,
    int y,
    int xOffset,
    int yOffset,
    OffsetReference offsetRef
)
Visual Basic
Public Sub DragTo ( _
    x As Integer, _
    y As Integer, _
    xOffset As Integer, _
    yOffset As Integer, _
    offsetRef As OffsetReference _
)
Visual C++
public:
void DragTo(
    int x,
    int y,
    int xOffset,
    int yOffset,
    OffsetReference offsetRef
)

Parameters

x
Type: System..::..Int32
The number of pixels to drag the element horizontally
y
Type: System..::..Int32
The number of pixels to drag the element vertically
xOffset
Type: System..::..Int32
The horizontal offset within the element's rectangle from which to begin the drag
yOffset
Type: System..::..Int32
The vertical offset within the element's rectangle from which to begin the drag
offsetRef
Type: ArtOfTest.Common..::..OffsetReference
The reference used to calculate the offsets within the element

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (Int32, Int32, Boolean, Cursor, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (Int32, Int32, Boolean, Cursor, Int32, Boolean)
UserInteraction Class See Also Send Feedback
Perform a drag to with an auto detection option of the hot spot.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    int x,
    int y,
    bool autoDetectStartHotSpot,
    Cursor hotSpotCursor,
    int radius,
    bool skipValidateDropLocation
)
Visual Basic
Public Sub DragTo ( _
    x As Integer, _
    y As Integer, _
    autoDetectStartHotSpot As Boolean, _
    hotSpotCursor As Cursor, _
    radius As Integer, _
    skipValidateDropLocation As Boolean _
)
Visual C++
public:
void DragTo(
    int x,
    int y,
    bool autoDetectStartHotSpot,
    Cursor^ hotSpotCursor,
    int radius,
    bool skipValidateDropLocation
)

Parameters

x
Type: System..::..Int32
The x offset from the center.
y
Type: System..::..Int32
The y offset from the center.
autoDetectStartHotSpot
Type: System..::..Boolean
Whether to auto-detect the hot spot at the start of the drag or no.
hotSpotCursor
Type: System.Windows.Forms..::..Cursor
A specific cursor to check for as the hot spot indicator
radius
Type: System..::..Int32
The search radios from the center point of the source element.
skipValidateDropLocation
Type: System..::..Boolean
Whether to skip validation of the drop location

Remarks

The function uses mouse cursor change to detect the hot spot. If the hot spot does not change the mouse, this function will not be able to detect the spot

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (Int32, Int32, Int32, Int32, OffsetReference, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (Int32, Int32, Int32, Int32, OffsetReference, Boolean)
UserInteraction Class See Also Send Feedback
Drag this element from a specified offset

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    int x,
    int y,
    int xOffset,
    int yOffset,
    OffsetReference offsetRef,
    bool skipValidateDropLocation
)
Visual Basic
Public Sub DragTo ( _
    x As Integer, _
    y As Integer, _
    xOffset As Integer, _
    yOffset As Integer, _
    offsetRef As OffsetReference, _
    skipValidateDropLocation As Boolean _
)
Visual C++
public:
void DragTo(
    int x,
    int y,
    int xOffset,
    int yOffset,
    OffsetReference offsetRef,
    bool skipValidateDropLocation
)

Parameters

x
Type: System..::..Int32
The number of pixels to drag the element horizontally
y
Type: System..::..Int32
The number of pixels to drag the element vertically
xOffset
Type: System..::..Int32
The horizontal offset within the element's rectangle from which to begin the drag
yOffset
Type: System..::..Int32
The vertical offset within the element's rectangle from which to begin the drag
offsetRef
Type: ArtOfTest.Common..::..OffsetReference
The reference used to calculate the offsets within the element
skipValidateDropLocation
Type: System..::..Boolean
Whether to skip validation of the drop location

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (Int32, Int32, OffsetReference, FrameworkElement, Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (Int32, Int32, OffsetReference, FrameworkElement, Int32, Int32, OffsetReference)
UserInteraction Class See Also Send Feedback
Drag this element to the dropTarget

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    int startOffsetX,
    int startOffsetY,
    OffsetReference startOffsetReference,
    FrameworkElement dropTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endOffsetReference
)
Visual Basic
Public Sub DragTo ( _
    startOffsetX As Integer, _
    startOffsetY As Integer, _
    startOffsetReference As OffsetReference, _
    dropTarget As FrameworkElement, _
    endOffsetX As Integer, _
    endOffsetY As Integer, _
    endOffsetReference As OffsetReference _
)
Visual C++
public:
void DragTo(
    int startOffsetX,
    int startOffsetY,
    OffsetReference startOffsetReference,
    FrameworkElement^ dropTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endOffsetReference
)

Parameters

startOffsetX
Type: System..::..Int32
The horizontal offset within this element from which to begin the drag
startOffsetY
Type: System..::..Int32
The vertical offset within this element from which to begin the drag
startOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The reference used to calculate the offsets within this element
dropTarget
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The drop target element
endOffsetX
Type: System..::..Int32
The horizontal offset within the drop target at which to end the drag
endOffsetY
Type: System..::..Int32
The vertical offset within the drop target at which to end the drag
endOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The reference used to calculate the offsets within the drop target element

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


DragTo Method (Int32, Int32, OffsetReference, ActionPointUnitType, FrameworkElement, Int32, Int32, OffsetReference, ActionPointUnitType, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..DragTo Method (Int32, Int32, OffsetReference, ActionPointUnitType, FrameworkElement, Int32, Int32, OffsetReference, ActionPointUnitType, Boolean)
UserInteraction Class See Also Send Feedback
Drag this element to the dropTarget

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragTo(
    int startOffsetX,
    int startOffsetY,
    OffsetReference startOffsetReference,
    ActionPointUnitType startUnitType,
    FrameworkElement dropTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endOffsetReference,
    ActionPointUnitType endUnitType,
    bool skipValidateDropLocation
)
Visual Basic
Public Sub DragTo ( _
    startOffsetX As Integer, _
    startOffsetY As Integer, _
    startOffsetReference As OffsetReference, _
    startUnitType As ActionPointUnitType, _
    dropTarget As FrameworkElement, _
    endOffsetX As Integer, _
    endOffsetY As Integer, _
    endOffsetReference As OffsetReference, _
    endUnitType As ActionPointUnitType, _
    skipValidateDropLocation As Boolean _
)
Visual C++
public:
void DragTo(
    int startOffsetX,
    int startOffsetY,
    OffsetReference startOffsetReference,
    ActionPointUnitType startUnitType,
    FrameworkElement^ dropTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endOffsetReference,
    ActionPointUnitType endUnitType,
    bool skipValidateDropLocation
)

Parameters

startOffsetX
Type: System..::..Int32
The horizontal offset within this element from which to begin the drag
startOffsetY
Type: System..::..Int32
The vertical offset within this element from which to begin the drag
startOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The reference used to calculate the offsets within this element
startUnitType
Type: ArtOfTest.Common..::..ActionPointUnitType

[Missing <param name="startUnitType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.DragTo(System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType,ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType,System.Boolean)"]

dropTarget
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement
The drop target element
endOffsetX
Type: System..::..Int32
The horizontal offset within the drop target at which to end the drag
endOffsetY
Type: System..::..Int32
The vertical offset within the drop target at which to end the drag
endOffsetReference
Type: ArtOfTest.Common..::..OffsetReference
The reference used to calculate the offsets within the drop target element
endUnitType
Type: ArtOfTest.Common..::..ActionPointUnitType

[Missing <param name="endUnitType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.DragTo(System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType,ArtOfTest.WebAii.Silverlight.FrameworkElement,System.Int32,System.Int32,ArtOfTest.Common.OffsetReference,ArtOfTest.Common.ActionPointUnitType,System.Boolean)"]

skipValidateDropLocation
Type: System..::..Boolean
Whether to skip validation of the drop location

See Also

UserInteraction Class
DragTo Overload
ArtOfTest.WebAii.Silverlight Namespace


HoverOver Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..HoverOver Method
UserInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HoverOver()()()() | Hover over this element.
Public method | HoverOver(Point) | Hover over a specific point relative to the element.
Public method | HoverOver(Int32, Int32, OffsetReference) | Hover over a specific point in this element.
Public method | HoverOver(Int32, Int32, OffsetReference, ActionPointUnitType) | Hover over a specific point in this element.

See Also

UserInteraction Class
UserInteraction Members
ArtOfTest.WebAii.Silverlight Namespace


HoverOver Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..HoverOver Method
UserInteraction Class See Also Send Feedback
Hover over this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void HoverOver()
Visual Basic
Public Sub HoverOver
Visual C++
public:
void HoverOver()

See Also

UserInteraction Class
HoverOver Overload
ArtOfTest.WebAii.Silverlight Namespace


HoverOver Method (Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..HoverOver Method (Point)
UserInteraction Class See Also Send Feedback
Hover over a specific point relative to the element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void HoverOver(
    Point p
)
Visual Basic
Public Sub HoverOver ( _
    p As Point _
)
Visual C++
public:
void HoverOver(
    Point p
)

Parameters

p
Type: System.Drawing..::..Point
The point to hover over relative to the top left corner of this element. .

See Also

UserInteraction Class
HoverOver Overload
ArtOfTest.WebAii.Silverlight Namespace


HoverOver Method (Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..HoverOver Method (Int32, Int32, OffsetReference)
UserInteraction Class See Also Send Feedback
Hover over a specific point in this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void HoverOver(
    int x,
    int y,
    OffsetReference reference
)
Visual Basic
Public Sub HoverOver ( _
    x As Integer, _
    y As Integer, _
    reference As OffsetReference _
)
Visual C++
public:
void HoverOver(
    int x,
    int y,
    OffsetReference reference
)

Parameters

x
Type: System..::..Int32
The x-coordinate of the offset
y
Type: System..::..Int32
The y-coordinate of the offset
reference
Type: ArtOfTest.Common..::..OffsetReference
The reference point for the offset

See Also

UserInteraction Class
HoverOver Overload
ArtOfTest.WebAii.Silverlight Namespace


HoverOver Method (Int32, Int32, OffsetReference, ActionPointUnitType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..HoverOver Method (Int32, Int32, OffsetReference, ActionPointUnitType)
UserInteraction Class See Also Send Feedback
Hover over a specific point in this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void HoverOver(
    int x,
    int y,
    OffsetReference reference,
    ActionPointUnitType unitType
)
Visual Basic
Public Sub HoverOver ( _
    x As Integer, _
    y As Integer, _
    reference As OffsetReference, _
    unitType As ActionPointUnitType _
)
Visual C++
public:
void HoverOver(
    int x,
    int y,
    OffsetReference reference,
    ActionPointUnitType unitType
)

Parameters

x
Type: System..::..Int32
The x-coordinate of the offset
y
Type: System..::..Int32
The y-coordinate of the offset
reference
Type: ArtOfTest.Common..::..OffsetReference
The reference point for the offset
unitType
Type: ArtOfTest.Common..::..ActionPointUnitType
The unit type for the x and y coordinates

See Also

UserInteraction Class
HoverOver Overload
ArtOfTest.WebAii.Silverlight Namespace


KeyDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..KeyDown Method
UserInteraction Class See Also Send Feedback
Press key down.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyDown(
    Keys key
)
Visual Basic
Public Sub KeyDown ( _
    key As Keys _
)
Visual C++
public:
void KeyDown(
    Keys key
)

Parameters

key
Type: System.Windows.Forms..::..Keys

[Missing <param name="key"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.KeyDown(System.Windows.Forms.Keys)"]

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


KeyPress Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..KeyPress Method
UserInteraction Class See Also Send Feedback
Press a key and hold it down for a specific period of time.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyPress(
    Keys key,
    int holdFor
)
Visual Basic
Public Sub KeyPress ( _
    key As Keys, _
    holdFor As Integer _
)
Visual C++
public:
void KeyPress(
    Keys key,
    int holdFor
)

Parameters

key
Type: System.Windows.Forms..::..Keys
The key code for the key to press.
holdFor
Type: System..::..Int32
How long to hold the key down, in milliseconds.

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


KeyUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..KeyUp Method
UserInteraction Class See Also Send Feedback
Press key up.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyUp(
    Keys key
)
Visual Basic
Public Sub KeyUp ( _
    key As Keys _
)
Visual C++
public:
void KeyUp(
    Keys key
)

Parameters

key
Type: System.Windows.Forms..::..Keys

[Missing <param name="key"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.KeyUp(System.Windows.Forms.Keys)"]

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


MouseEnter Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..MouseEnter Method
UserInteraction Class See Also Send Feedback
Enter this element from a certain direction.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void MouseEnter(
    OffsetReference enterSide
)
Visual Basic
Public Sub MouseEnter ( _
    enterSide As OffsetReference _
)
Visual C++
public:
void MouseEnter(
    OffsetReference enterSide
)

Parameters

enterSide
Type: ArtOfTest.Common..::..OffsetReference
The side to enter from

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


MouseLeave Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..MouseLeave Method
UserInteraction Class See Also Send Feedback
Leave this element from a certain direction.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void MouseLeave(
    OffsetReference leaveSide
)
Visual Basic
Public Sub MouseLeave ( _
    leaveSide As OffsetReference _
)
Visual C++
public:
void MouseLeave(
    OffsetReference leaveSide
)

Parameters

leaveSide
Type: ArtOfTest.Common..::..OffsetReference
The direction to leave from

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


MouseMove Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..MouseMove Method
UserInteraction Class See Also Send Feedback
Move the mouse along the defined path.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void MouseMove(
    List<Point> path,
    int delayBetweenPathPoints,
    bool firstPointIsElementCenter
)
Visual Basic
Public Sub MouseMove ( _
    path As List(Of Point), _
    delayBetweenPathPoints As Integer, _
    firstPointIsElementCenter As Boolean _
)
Visual C++
public:
void MouseMove(
    List<Point>^ path,
    int delayBetweenPathPoints,
    bool firstPointIsElementCenter
)

Parameters

path
Type: System.Collections.Generic..::..List <(Of <(<' Point >)>)>
The path as a series of points.
delayBetweenPathPoints
Type: System..::..Int32
Delay between mouse moves within the path points in msec.
firstPointIsElementCenter
Type: System..::..Boolean
If set to true, will assume that the first point of the path is this element's center point. Else will simply use the passed in path.

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


TurnMouseWheel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..TurnMouseWheel Method
UserInteraction Class See Also Send Feedback
Turn the mouse wheel over over this element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void TurnMouseWheel(
    int delta,
    MouseWheelTurnDirection direction,
    bool clickFirst
)
Visual Basic
Public Sub TurnMouseWheel ( _
    delta As Integer, _
    direction As MouseWheelTurnDirection, _
    clickFirst As Boolean _
)
Visual C++
public:
void TurnMouseWheel(
    int delta,
    MouseWheelTurnDirection direction,
    bool clickFirst
)

Parameters

delta
Type: System..::..Int32
The delta to turn the wheel.
direction
Type: ArtOfTest.WebAii.Core..::..MouseWheelTurnDirection
The turn direction.
clickFirst
Type: System..::..Boolean
Whether you want the element clicked first.

See Also

UserInteraction Class
ArtOfTest.WebAii.Silverlight Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..TypeText Method
UserInteraction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String, Int32) | Type text as a real user. By default click the element to place the cursor in it.
Public method | TypeText(String, Int32, Boolean) | Type text as a real user.
Public method | TypeText(String, Int32, Int32, Boolean, Boolean) | Type text as a real user.

See Also

UserInteraction Class
UserInteraction Members
ArtOfTest.WebAii.Silverlight Namespace


TypeText Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..TypeText Method (String, Int32)
UserInteraction Class See Also Send Feedback
Type text as a real user. By default click the element to place the cursor in it.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void TypeText(
    string text,
    int keyPressTime
)
Visual Basic
Public Sub TypeText ( _
    text As String, _
    keyPressTime As Integer _
)
Visual C++
public:
void TypeText(
    String^ text,
    int keyPressTime
)

Parameters

text
Type: System..::..String
The text to type.
keyPressTime
Type: System..::..Int32
The delay between each press

See Also

UserInteraction Class
TypeText Overload
ArtOfTest.WebAii.Silverlight Namespace


TypeText Method (String, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..TypeText Method (String, Int32, Boolean)
UserInteraction Class See Also Send Feedback
Type text as a real user.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void TypeText(
    string text,
    int keyPressTime,
    bool clickFirst
)
Visual Basic
Public Sub TypeText ( _
    text As String, _
    keyPressTime As Integer, _
    clickFirst As Boolean _
)
Visual C++
public:
void TypeText(
    String^ text,
    int keyPressTime,
    bool clickFirst
)

Parameters

text
Type: System..::..String
The text to type.
keyPressTime
Type: System..::..Int32
The delay between each press
clickFirst
Type: System..::..Boolean
Whether to click the element first before typing. Used to place cursor in TextBoxes for example.

See Also

UserInteraction Class
TypeText Overload
ArtOfTest.WebAii.Silverlight Namespace


TypeText Method (String, Int32, Int32, Boolean, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteraction..::..TypeText Method (String, Int32, Int32, Boolean, Boolean)
UserInteraction Class See Also Send Feedback
Type text as a real user.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void TypeText(
    string text,
    int keyPressTime,
    int holdTime,
    bool clickFirst,
    bool supportUnicode
)
Visual Basic
Public Sub TypeText ( _
    text As String, _
    keyPressTime As Integer, _
    holdTime As Integer, _
    clickFirst As Boolean, _
    supportUnicode As Boolean _
)
Visual C++
public:
void TypeText(
    String^ text,
    int keyPressTime,
    int holdTime,
    bool clickFirst,
    bool supportUnicode
)

Parameters

text
Type: System..::..String
The text to type.
keyPressTime
Type: System..::..Int32
The delay between each press
holdTime
Type: System..::..Int32
The delay between pressing and releasing each key
clickFirst
Type: System..::..Boolean
Whether to click the element first before typing. Used to place cursor in TextBoxes for example.
supportUnicode
Type: System..::..Boolean

[Missing <param name="supportUnicode"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UserInteraction.TypeText(System.String,System.Int32,System.Int32,System.Boolean,System.Boolean)"]

See Also

UserInteraction Class
TypeText Overload
ArtOfTest.WebAii.Silverlight Namespace


UserInteractionHelper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteractionHelper Members
UserInteractionHelper Class Methods See Also Send Feedback

The UserInteractionHelper type exposes the following members.

Methods

Name | Description
GetCenterPoint | Return the center point of this rectangle.

See Also

UserInteractionHelper Class
ArtOfTest.WebAii.Silverlight Namespace


UserInteractionHelper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteractionHelper Methods
UserInteractionHelper Class See Also Send Feedback

The UserInteractionHelper type exposes the following members.

Methods

Name | Description
GetCenterPoint | Return the center point of this rectangle.

See Also

UserInteractionHelper Class
ArtOfTest.WebAii.Silverlight Namespace


GetCenterPoint Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserInteractionHelper..::..GetCenterPoint Method
UserInteractionHelper Class See Also Send Feedback
Return the center point of this rectangle.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Point GetCenterPoint(
    this Rectangle rectangle
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GetCenterPoint ( _
    rectangle As Rectangle _
) As Point
Visual C++
[ExtensionAttribute]
public:
static Point GetCenterPoint(
    Rectangle rectangle
)

Parameters

rectangle
Type: System.Drawing..::..Rectangle
The rectangle to calculate center off.

Return Value

The center point.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rectangle. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

UserInteractionHelper Class
ArtOfTest.WebAii.Silverlight Namespace


VisualFind Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind Members
VisualFind Class Methods Properties See Also Send Feedback

The VisualFind type exposes the following members.

Methods

 | Name | Description
Public method | AllByAutomationId(String) | Finds all controls with a given automation id
Public method | AllByAutomationId(String, String) |
Public method | AllByAutomationId<(Of <<'(T>)>>)(String) |
Public method | AllByCustom(Predicate<(Of <<'(FrameworkElement>)>>)) |
Public method | AllByCustom(T, Predicate<(Of <<'(T>)>>), Boolean) | Find all matches that match custom search logic (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | AllByExpression(XamlFindExpression) | Finds all the elements in the tree that match the find expression. (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..AllByExpression(V).)
Public method | AllByExpression(T, V) | Finds all the elements in the tree that match the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | AllByName(String) |
Public method | AllByName(String, String) |
Public method | AllByName<(Of <<'(T>)>>)(String) |
Public method | AllByTextContent |
Public method | AllByType(String) |
Public method | AllByType<(Of <<'(T>)>>)()()()() |
Public method | ByAutomationId(String) | Search the Visual Tree for an element with a certain automation ID
Public method | ByAutomationId(String, Boolean) |
Public method | ByAutomationId<(Of <<'(T>)>>)(String) | Search the Visual Tree for an element with a certain automation ID and return it as a strongly-typed control
Public method | ByCustom(Predicate<(Of <<'(FrameworkElement>)>>)) | Find using custom logic.
Public method | ByCustom(T, Predicate<(Of <<'(T>)>>), Boolean) | Find using custom logic. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpression(V) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpression(T, V) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpression(XamlFindExpression, Boolean) | Finds the first element in the tree that matches the find expression. It doesn't wait an element to be populated, returns immediately. (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByExpression(T, V).)
Public method | ByExpression(T, V, Boolean) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpressionReturnOrThrow(XamlFindExpression) | Finds the first element in the tree that matches the find expression. It respects the find strategy so can wait an element to be populated according to the timeout.
Public method | ByExpressionReturnOrThrow(XamlFindExpression, Boolean) | Finds the first element in the tree that matches the find expression. It respects the find strategy so can wait an element to be populated according to the timeout.
Public method | ByName(String) | Search the Visual Tree with an element with a certain name.
Public method | ByName<(Of <<'(T>)>>)(String) | Return the element with specified name as the desired type.
Public method | ByTextContent | Return the element that contain the specified text.
Public method | ByType(String) | Find the first control of type defined
Public method | ByType<(Of <<'(T>)>>)()()()() | Find the first control of certain type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindUsingExpressionPath | Find an element using expression paths starting at startNode. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | FindUsingHierarchicalClause | (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..FindUsingHierarchicalClause(T, R).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshRoot | Refresh the visual tree this VisualFind object searches
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LastUsedExpression | The last FindExpression used by this Crawler. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public property | OwnerApp | Gets the owner app of this Find object.
Public property | SearchRoot | Gets the Search Root for this FrameworkElement (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..SearchRoot.)
Public property | Strategy | Gets or sets the find strategy to use when searching for elements in the VisualTree
Public property | WaitOnElementsTimeout | Gets or sets the time out to use when Strategy=AlwaysWaitForElementsVisible

See Also

VisualFind Class
ArtOfTest.WebAii.Silverlight Namespace


VisualFind Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind Methods
VisualFind Class See Also Send Feedback

The VisualFind type exposes the following members.

Methods

 | Name | Description
Public method | AllByAutomationId(String) | Finds all controls with a given automation id
Public method | AllByAutomationId(String, String) |
Public method | AllByAutomationId<(Of <<'(T>)>>)(String) |
Public method | AllByCustom(Predicate<(Of <<'(FrameworkElement>)>>)) |
Public method | AllByCustom(T, Predicate<(Of <<'(T>)>>), Boolean) | Find all matches that match custom search logic (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | AllByExpression(XamlFindExpression) | Finds all the elements in the tree that match the find expression. (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..AllByExpression(V).)
Public method | AllByExpression(T, V) | Finds all the elements in the tree that match the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | AllByName(String) |
Public method | AllByName(String, String) |
Public method | AllByName<(Of <<'(T>)>>)(String) |
Public method | AllByTextContent |
Public method | AllByType(String) |
Public method | AllByType<(Of <<'(T>)>>)()()()() |
Public method | ByAutomationId(String) | Search the Visual Tree for an element with a certain automation ID
Public method | ByAutomationId(String, Boolean) |
Public method | ByAutomationId<(Of <<'(T>)>>)(String) | Search the Visual Tree for an element with a certain automation ID and return it as a strongly-typed control
Public method | ByCustom(Predicate<(Of <<'(FrameworkElement>)>>)) | Find using custom logic.
Public method | ByCustom(T, Predicate<(Of <<'(T>)>>), Boolean) | Find using custom logic. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpression(V) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpression(T, V) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpression(XamlFindExpression, Boolean) | Finds the first element in the tree that matches the find expression. It doesn't wait an element to be populated, returns immediately. (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByExpression(T, V).)
Public method | ByExpression(T, V, Boolean) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpressionReturnOrThrow(XamlFindExpression) | Finds the first element in the tree that matches the find expression. It respects the find strategy so can wait an element to be populated according to the timeout.
Public method | ByExpressionReturnOrThrow(XamlFindExpression, Boolean) | Finds the first element in the tree that matches the find expression. It respects the find strategy so can wait an element to be populated according to the timeout.
Public method | ByName(String) | Search the Visual Tree with an element with a certain name.
Public method | ByName<(Of <<'(T>)>>)(String) | Return the element with specified name as the desired type.
Public method | ByTextContent | Return the element that contain the specified text.
Public method | ByType(String) | Find the first control of type defined
Public method | ByType<(Of <<'(T>)>>)()()()() | Find the first control of certain type.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindUsingExpressionPath | Find an element using expression paths starting at startNode. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | FindUsingHierarchicalClause | (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..FindUsingHierarchicalClause(T, R).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshRoot | Refresh the visual tree this VisualFind object searches
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualFind Class
ArtOfTest.WebAii.Silverlight Namespace


AllByAutomationId Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByAutomationId Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByAutomationId<(Of <<'(T>)>>)(String) |
Public method | AllByAutomationId(String) | Finds all controls with a given automation id
Public method | AllByAutomationId(String, String) |

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


AllByAutomationId(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByAutomationId<(Of <(<'T>)>)> Method (String)
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByAutomationId``1(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<T> AllByAutomationId<T>(
    string id
)
where T : IFrameworkElement
Visual Basic
Public Function AllByAutomationId(Of T As IFrameworkElement) ( _
    id As String _
) As IList(Of T)
Visual C++
public:
generic<typename T>
where T : IFrameworkElement
IList<T>^ AllByAutomationId(
    String^ id
)

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByAutomationId``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByAutomationId``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByAutomationId``1(System.String)"]

See Also

VisualFind Class
AllByAutomationId Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByAutomationId Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByAutomationId Method (String)
VisualFind Class See Also Send Feedback
Finds all controls with a given automation id

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> AllByAutomationId(
    string id
)
Visual Basic
Public Function AllByAutomationId ( _
    id As String _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ AllByAutomationId(
    String^ id
)

Parameters

id
Type: System..::..String
The id to search for

Return Value

A list of all controls with the given id

See Also

VisualFind Class
AllByAutomationId Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByAutomationId Method (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByAutomationId Method (String, String)
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByAutomationId(System.String,System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> AllByAutomationId(
    string id,
    string controlType
)
Visual Basic
Public Function AllByAutomationId ( _
    id As String, _
    controlType As String _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ AllByAutomationId(
    String^ id,
    String^ controlType
)

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByAutomationId(System.String,System.String)"]

controlType
Type: System..::..String

[Missing <param name="controlType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByAutomationId(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByAutomationId(System.String,System.String)"]

See Also

VisualFind Class
AllByAutomationId Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByCustom Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByCustom Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByCustom(Predicate<(Of <<'(FrameworkElement>)>>)) |
Public method | AllByCustom(T, Predicate<(Of <<'(T>)>>), Boolean) | Find all matches that match custom search logic (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


AllByCustom Method (Predicate(FrameworkElement))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByCustom Method (Predicate<(Of <(<'FrameworkElement>)>)>)
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByCustom(System.Predicate{ArtOfTest.WebAii.Silverlight.FrameworkElement})"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> AllByCustom(
    Predicate<FrameworkElement> customLogic
)
Visual Basic
Public Function AllByCustom ( _
    customLogic As Predicate(Of FrameworkElement) _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ AllByCustom(
    Predicate<FrameworkElement^>^ customLogic
)

Parameters

customLogic
Type: System..::..Predicate <(Of <(<' FrameworkElement >)>)>

[Missing <param name="customLogic"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByCustom(System.Predicate{ArtOfTest.WebAii.Silverlight.FrameworkElement})"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByCustom(System.Predicate{ArtOfTest.WebAii.Silverlight.FrameworkElement})"]

See Also

VisualFind Class
AllByCustom Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByExpression Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByExpression Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByExpression(XamlFindExpression) | Finds all the elements in the tree that match the find expression. (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..AllByExpression(V).)
Public method | AllByExpression(T, V) | Finds all the elements in the tree that match the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


AllByExpression Method (XamlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByExpression Method (XamlFindExpression)
VisualFind Class See Also Send Feedback
Finds all the elements in the tree that match the find expression.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override IList<FrameworkElement> AllByExpression(
    XamlFindExpression expression
)
Visual Basic
Public Overrides Function AllByExpression ( _
    expression As XamlFindExpression _
) As IList(Of FrameworkElement)
Visual C++
public:
virtual IList<FrameworkElement^>^ AllByExpression(
    XamlFindExpression^ expression
) override

Parameters

expression
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression
The find expression.

Return Value

A list of all elements that match the expression or an empty list if nothing is found.

Remarks

Uses this.SearchRoot as the search root

See Also

VisualFind Class
AllByExpression Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByName Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByName Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByName<(Of <<'(T>)>>)(String) |
Public method | AllByName(String) |
Public method | AllByName(String, String) |

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


AllByName(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByName<(Of <(<'T>)>)> Method (String)
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName``1(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<T> AllByName<T>(
    string name
)
where T : IFrameworkElement
Visual Basic
Public Function AllByName(Of T As IFrameworkElement) ( _
    name As String _
) As IList(Of T)
Visual C++
public:
generic<typename T>
where T : IFrameworkElement
IList<T>^ AllByName(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName``1(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName``1(System.String)"]

See Also

VisualFind Class
AllByName Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByName Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByName Method (String)
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> AllByName(
    string name
)
Visual Basic
Public Function AllByName ( _
    name As String _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ AllByName(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName(System.String)"]

See Also

VisualFind Class
AllByName Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByName Method (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByName Method (String, String)
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName(System.String,System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> AllByName(
    string name,
    string controlType
)
Visual Basic
Public Function AllByName ( _
    name As String, _
    controlType As String _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ AllByName(
    String^ name,
    String^ controlType
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName(System.String,System.String)"]

controlType
Type: System..::..String

[Missing <param name="controlType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName(System.String,System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByName(System.String,System.String)"]

See Also

VisualFind Class
AllByName Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByTextContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByTextContent Method
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByTextContent(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> AllByTextContent(
    string textContent
)
Visual Basic
Public Function AllByTextContent ( _
    textContent As String _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ AllByTextContent(
    String^ textContent
)

Parameters

textContent
Type: System..::..String

[Missing <param name="textContent"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByTextContent(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByTextContent(System.String)"]

See Also

VisualFind Class
ArtOfTest.WebAii.Silverlight Namespace


AllByType Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByType Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllByType<(Of <<'(T>)>>)()()()() |
Public method | AllByType(String) |

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


AllByType(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByType<(Of <(<'T>)>)> Method
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByType``1"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<T> AllByType<T>()
where T : IFrameworkElement
Visual Basic
Public Function AllByType(Of T As IFrameworkElement) As IList(Of T)
Visual C++
public:
generic<typename T>
where T : IFrameworkElement
IList<T>^ AllByType()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByType``1"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByType``1"]

See Also

VisualFind Class
AllByType Overload
ArtOfTest.WebAii.Silverlight Namespace


AllByType Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..AllByType Method (String)
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByType(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<FrameworkElement> AllByType(
    string controlType
)
Visual Basic
Public Function AllByType ( _
    controlType As String _
) As IList(Of FrameworkElement)
Visual C++
public:
IList<FrameworkElement^>^ AllByType(
    String^ controlType
)

Parameters

controlType
Type: System..::..String

[Missing <param name="controlType"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByType(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.AllByType(System.String)"]

See Also

VisualFind Class
AllByType Overload
ArtOfTest.WebAii.Silverlight Namespace


ByAutomationId Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByAutomationId Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByAutomationId<(Of <<'(T>)>>)(String) | Search the Visual Tree for an element with a certain automation ID and return it as a strongly-typed control
Public method | ByAutomationId(String) | Search the Visual Tree for an element with a certain automation ID
Public method | ByAutomationId(String, Boolean) |

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


ByAutomationId(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByAutomationId<(Of <(<'T>)>)> Method (String)
VisualFind Class See Also Send Feedback
Search the Visual Tree for an element with a certain automation ID and return it as a strongly-typed control

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T ByAutomationId<T>(
    string id
)
where T : IFrameworkElement
Visual Basic
Public Function ByAutomationId(Of T As IFrameworkElement) ( _
    id As String _
) As T
Visual C++
public:
generic<typename T>
where T : IFrameworkElement
T ByAutomationId(
    String^ id
)

Parameters

id
Type: System..::..String
The automation ID to search for

Type Parameters

T
The desired control type

Return Value

The first visual element with the specified automation ID, cast to the specified type

Remarks

This method does not limit the scope of its search only to controls whose types match T. It searches all controls, and attempts to cast the first match to type T.

See Also

VisualFind Class
ByAutomationId Overload
ArtOfTest.WebAii.Silverlight Namespace


ByAutomationId Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByAutomationId Method (String)
VisualFind Class See Also Send Feedback
Search the Visual Tree for an element with a certain automation ID

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ByAutomationId(
    string id
)
Visual Basic
Public Function ByAutomationId ( _
    id As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ ByAutomationId(
    String^ id
)

Parameters

id
Type: System..::..String
The automation ID to search for

Return Value

The first visual element with the specified automation ID

See Also

VisualFind Class
ByAutomationId Overload
ArtOfTest.WebAii.Silverlight Namespace


ByAutomationId Method (String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByAutomationId Method (String, Boolean)
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.ByAutomationId(System.String,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ByAutomationId(
    string id,
    bool includeRoot
)
Visual Basic
Public Function ByAutomationId ( _
    id As String, _
    includeRoot As Boolean _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ ByAutomationId(
    String^ id,
    bool includeRoot
)

Parameters

id
Type: System..::..String

[Missing <param name="id"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.ByAutomationId(System.String,System.Boolean)"]

includeRoot
Type: System..::..Boolean

[Missing <param name="includeRoot"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.ByAutomationId(System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.ByAutomationId(System.String,System.Boolean)"]

See Also

VisualFind Class
ByAutomationId Overload
ArtOfTest.WebAii.Silverlight Namespace


ByCustom Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByCustom Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByCustom(Predicate<(Of <<'(FrameworkElement>)>>)) | Find using custom logic.
Public method | ByCustom(T, Predicate<(Of <<'(T>)>>), Boolean) | Find using custom logic. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


ByCustom Method (Predicate(FrameworkElement))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByCustom Method (Predicate<(Of <(<'FrameworkElement>)>)>)
VisualFind Class See Also Send Feedback
Find using custom logic.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ByCustom(
    Predicate<FrameworkElement> customLogic
)
Visual Basic
Public Function ByCustom ( _
    customLogic As Predicate(Of FrameworkElement) _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ ByCustom(
    Predicate<FrameworkElement^>^ customLogic
)

Parameters

customLogic
Type: System..::..Predicate <(Of <(<' FrameworkElement >)>)>
Custom logic predicate

Return Value

The found element else null.

See Also

VisualFind Class
ByCustom Overload
ArtOfTest.WebAii.Silverlight Namespace


ByExpression Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByExpression Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByExpression(V) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpression(T, V) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public method | ByExpression(XamlFindExpression, Boolean) | Finds the first element in the tree that matches the find expression. It doesn't wait an element to be populated, returns immediately. (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..ByExpression(T, V).)
Public method | ByExpression(T, V, Boolean) | Finds the first element in the tree that matches the find expression. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


ByExpression Method (XamlFindExpression, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByExpression Method (XamlFindExpression, Boolean)
VisualFind Class See Also Send Feedback
Finds the first element in the tree that matches the find expression. It doesn't wait an element to be populated, returns immediately.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override FrameworkElement ByExpression(
    XamlFindExpression expression,
    bool includeRoot
)
Visual Basic
Public Overrides Function ByExpression ( _
    expression As XamlFindExpression, _
    includeRoot As Boolean _
) As FrameworkElement
Visual C++
public:
virtual FrameworkElement^ ByExpression(
    XamlFindExpression^ expression,
    bool includeRoot
) override

Parameters

expression
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression
The find expression.
includeRoot
Type: System..::..Boolean
Whether to include the root node in the search

Return Value

The first element it finds else null.

See Also

VisualFind Class
ByExpression Overload
ArtOfTest.WebAii.Silverlight Namespace


ByExpressionReturnOrThrow Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByExpressionReturnOrThrow Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByExpressionReturnOrThrow(XamlFindExpression) | Finds the first element in the tree that matches the find expression. It respects the find strategy so can wait an element to be populated according to the timeout.
Public method | ByExpressionReturnOrThrow(XamlFindExpression, Boolean) | Finds the first element in the tree that matches the find expression. It respects the find strategy so can wait an element to be populated according to the timeout.

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


ByExpressionReturnOrThrow Method (XamlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByExpressionReturnOrThrow Method (XamlFindExpression)
VisualFind Class See Also Send Feedback
Finds the first element in the tree that matches the find expression. It respects the find strategy so can wait an element to be populated according to the timeout.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ByExpressionReturnOrThrow(
    XamlFindExpression expression
)
Visual Basic
Public Function ByExpressionReturnOrThrow ( _
    expression As XamlFindExpression _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ ByExpressionReturnOrThrow(
    XamlFindExpression^ expression
)

Parameters

expression
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression
The find expression.

Return Value

The first element it finds.

See Also

VisualFind Class
ByExpressionReturnOrThrow Overload
ArtOfTest.WebAii.Silverlight Namespace


ByExpressionReturnOrThrow Method (XamlFindExpression, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByExpressionReturnOrThrow Method (XamlFindExpression, Boolean)
VisualFind Class See Also Send Feedback
Finds the first element in the tree that matches the find expression. It respects the find strategy so can wait an element to be populated according to the timeout.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ByExpressionReturnOrThrow(
    XamlFindExpression expression,
    bool includeRoot
)
Visual Basic
Public Function ByExpressionReturnOrThrow ( _
    expression As XamlFindExpression, _
    includeRoot As Boolean _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ ByExpressionReturnOrThrow(
    XamlFindExpression^ expression,
    bool includeRoot
)

Parameters

expression
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression
The find expression.
includeRoot
Type: System..::..Boolean
Whether to include the root node in the search

Return Value

The first element it finds.

See Also

VisualFind Class
ByExpressionReturnOrThrow Overload
ArtOfTest.WebAii.Silverlight Namespace


ByName Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByName Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByName<(Of <<'(T>)>>)(String) | Return the element with specified name as the desired type.
Public method | ByName(String) | Search the Visual Tree with an element with a certain name.

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


ByName(T) Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByName<(Of <(<'T>)>)> Method (String)
VisualFind Class See Also Send Feedback
Return the element with specified name as the desired type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T ByName<T>(
    string name
)
where T : IFrameworkElement
Visual Basic
Public Function ByName(Of T As IFrameworkElement) ( _
    name As String _
) As T
Visual C++
public:
generic<typename T>
where T : IFrameworkElement
T ByName(
    String^ name
)

Parameters

name
Type: System..::..String
The element's name.

Type Parameters

T
The desired type of element to return.

Return Value

The object if found.

See Also

VisualFind Class
ByName Overload
ArtOfTest.WebAii.Silverlight Namespace


ByName Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByName Method (String)
VisualFind Class See Also Send Feedback
Search the Visual Tree with an element with a certain name.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ByName(
    string name
)
Visual Basic
Public Function ByName ( _
    name As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ ByName(
    String^ name
)

Parameters

name
Type: System..::..String
The name to find.

Return Value

The first visual element with the specified name

See Also

VisualFind Class
ByName Overload
ArtOfTest.WebAii.Silverlight Namespace


ByTextContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByTextContent Method
VisualFind Class See Also Send Feedback
Return the element that contain the specified text.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ByTextContent(
    string textContent
)
Visual Basic
Public Function ByTextContent ( _
    textContent As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ ByTextContent(
    String^ textContent
)

Parameters

textContent
Type: System..::..String
The text to look for. By default, we will use exact text, if you wish to use partial text then prefix the text with a '~' example: ByText("~partialText")

Return Value

The found element.

See Also

VisualFind Class
ArtOfTest.WebAii.Silverlight Namespace


ByType Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByType Method
VisualFind Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ByType<(Of <<'(T>)>>)()()()() | Find the first control of certain type.
Public method | ByType(String) | Find the first control of type defined

See Also

VisualFind Class
VisualFind Members
ArtOfTest.WebAii.Silverlight Namespace


ByType(T) Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByType<(Of <(<'T>)>)> Method
VisualFind Class See Also Send Feedback
Find the first control of certain type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public T ByType<T>()
where T : IFrameworkElement
Visual Basic
Public Function ByType(Of T As IFrameworkElement) As T
Visual C++
public:
generic<typename T>
where T : IFrameworkElement
T ByType()

Type Parameters

T
The type of the control

Return Value

The control or null if not found.

See Also

VisualFind Class
ByType Overload
ArtOfTest.WebAii.Silverlight Namespace


ByType Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..ByType Method (String)
VisualFind Class See Also Send Feedback
Find the first control of type defined

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FrameworkElement ByType(
    string controlType
)
Visual Basic
Public Function ByType ( _
    controlType As String _
) As FrameworkElement
Visual C++
public:
FrameworkElement^ ByType(
    String^ controlType
)

Parameters

controlType
Type: System..::..String
The control type defined

Return Value

The found control or null if not found

See Also

VisualFind Class
ByType Overload
ArtOfTest.WebAii.Silverlight Namespace


FindUsingHierarchicalClause Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..FindUsingHierarchicalClause Method
VisualFind Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.FindUsingHierarchicalClause(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.XamlFindClause)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override FrameworkElement FindUsingHierarchicalClause(
    FrameworkElement startNode,
    XamlFindClause clause
)
Visual Basic
Public Overrides Function FindUsingHierarchicalClause ( _
    startNode As FrameworkElement, _
    clause As XamlFindClause _
) As FrameworkElement
Visual C++
public:
virtual FrameworkElement^ FindUsingHierarchicalClause(
    FrameworkElement^ startNode,
    XamlFindClause^ clause
) override

Parameters

startNode
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="startNode"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.FindUsingHierarchicalClause(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.XamlFindClause)"]

clause
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindClause

[Missing <param name="clause"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.FindUsingHierarchicalClause(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.XamlFindClause)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFind.FindUsingHierarchicalClause(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.XamlFindClause)"]

See Also

VisualFind Class
ArtOfTest.WebAii.Silverlight Namespace


RefreshRoot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind..::..RefreshRoot Method
VisualFind Class See Also Send Feedback
Refresh the visual tree this VisualFind object searches

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RefreshRoot()
Visual Basic
Public Sub RefreshRoot
Visual C++
public:
void RefreshRoot()

See Also

VisualFind Class
ArtOfTest.WebAii.Silverlight Namespace


VisualFind Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFind Properties
VisualFind Class See Also Send Feedback

The VisualFind type exposes the following members.

Properties

 | Name | Description
Public property | LastUsedExpression | The last FindExpression used by this Crawler. (Inherited from TreeCrawler<(Of <(<'T, V, R>)>)>.)
Public property | OwnerApp | Gets the owner app of this Find object.
Public property | SearchRoot | Gets the Search Root for this FrameworkElement (Overrides TreeCrawler<(Of <(<'T, V, R>)>)>..::..SearchRoot.)
Public property | Strategy | Gets or sets the find strategy to use when searching for elements in the VisualTree
Public property | WaitOnElementsTimeout | Gets or sets the time out to use when Strategy=AlwaysWaitForElementsVisible

See Also

VisualFind Class
ArtOfTest.WebAii.Silverlight Namespace


VisualFindInfo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFindInfo Members
VisualFindInfo Class Constructors Methods Properties See Also Send Feedback

The VisualFindInfo type exposes the following members.

Constructors

 | Name | Description
Public method | VisualFindInfo | Initializes a new instance of the VisualFindInfo class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Expression |
Public property | Find |

See Also

VisualFindInfo Class
ArtOfTest.WebAii.Silverlight Namespace


VisualFindInfo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFindInfo Constructor
VisualFindInfo Class See Also Send Feedback
Initializes a new instance of the VisualFindInfo class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualFindInfo(
    XamlFindExpression expression,
    VisualFind vf
)
Visual Basic
Public Sub New ( _
    expression As XamlFindExpression, _
    vf As VisualFind _
)
Visual C++
public:
VisualFindInfo(
    XamlFindExpression^ expression,
    VisualFind^ vf
)

Parameters

expression
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression

[Missing <param name="expression"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFindInfo.#ctor(ArtOfTest.WebAii.Silverlight.XamlFindExpression,ArtOfTest.WebAii.Silverlight.VisualFind)"]

vf
Type: ArtOfTest.WebAii.Silverlight..::..VisualFind

[Missing <param name="vf"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualFindInfo.#ctor(ArtOfTest.WebAii.Silverlight.XamlFindExpression,ArtOfTest.WebAii.Silverlight.VisualFind)"]

See Also

VisualFindInfo Class
ArtOfTest.WebAii.Silverlight Namespace


VisualFindInfo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFindInfo Methods
VisualFindInfo Class See Also Send Feedback

The VisualFindInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualFindInfo Class
ArtOfTest.WebAii.Silverlight Namespace


VisualFindInfo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualFindInfo Properties
VisualFindInfo Class See Also Send Feedback

The VisualFindInfo type exposes the following members.

Properties

 | Name | Description
Public property | Expression |
Public property | Find |

See Also

VisualFindInfo Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTree Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTree Members
VisualTree Class Methods Properties See Also Send Feedback

The VisualTree type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Refresh the visual tree and tell us if a refresh was needed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Find | Get the Find object for this visual tree
Public property | Root | Get the root of the VisualTree

See Also

VisualTree Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTree Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTree Methods
VisualTree Class See Also Send Feedback

The VisualTree type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Refresh | Refresh the visual tree and tell us if a refresh was needed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualTree Class
ArtOfTest.WebAii.Silverlight Namespace


Refresh Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTree..::..Refresh Method
VisualTree Class See Also Send Feedback
Refresh the visual tree and tell us if a refresh was needed.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool Refresh()
Visual Basic
Public Function Refresh As Boolean
Visual C++
public:
bool Refresh()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualTree.Refresh"]

See Also

VisualTree Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTree Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTree Properties
VisualTree Class See Also Send Feedback

The VisualTree type exposes the following members.

Properties

 | Name | Description
Public property | Find | Get the Find object for this visual tree
Public property | Root | Get the root of the VisualTree

See Also

VisualTree Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTreeHost Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost Members
VisualTreeHost Class Methods Properties See Also Send Feedback

The VisualTreeHost type exposes the following members.

Methods

 | Name | Description
Public method | Capture | (Inherited from VisualTreeHost.)
Public method | EnsureStateIsCurrent | Will force the VisualTree to Refresh. Identical to VisualTree.Refresh(). (Inherited from VisualTreeHost.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixAnnotationArea | (Inherited from VisualTreeHost.)
Public method | GetChildHosts | Get all contained hosts. (Inherited from VisualTreeHost.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Returns the root target element of this host. VisualTree.Root (Inherited from VisualTreeHost.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateAllInHost | Locate all in host. (Inherited from VisualTreeHost.)
Public method | LocateInHost | Locate an element from the root of this host using an expression. (Inherited from VisualTreeHost.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetWindowFocus | (Inherited from VisualTreeHost.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateInterHostLinks | Silverlight hosts have no inter-host links to update (Inherited from VisualTreeHost.)
Public method | ValidateMouseLocation | (Inherited from VisualTreeHost.)

Properties

 | Name | Description
Public property | Annotator | (Inherited from VisualTreeHost.)
Public property | ContentWindow | (Inherited from VisualTreeHost.)
Public property | FriendlyName | Returns a friendly name for this host (Inherited from VisualTreeHost.)
Public property | Manager | (Inherited from VisualTreeHost.)
Public property | OwnerApp | The SilverlightApp containing this visual tree (Inherited from VisualTreeHost.)
Public property | ShouldDisplayAnnotation | (Inherited from VisualTreeHost.)
Public property | StateHashCode | Gets a unique identifier that identifies the state of this host (Inherited from VisualTreeHost.)
Public property | TechnologyType | VisualTreeHosts are only used for Silverlight (Inherited from VisualTreeHost.)
Public property | UniqueId | A unique identifier that identifies this plugin instance. This id is updated only when the plug-in is reloaded on a postback or a browser refresh. (Inherited from VisualTreeHost.)
Public property | VisualTree | The visual tree wrapped by this host object (Inherited from VisualTreeHost.)
Public property | Window | (Inherited from VisualTreeHost.)

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTreeHost Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost Methods
VisualTreeHost Class See Also Send Feedback

The VisualTreeHost type exposes the following members.

Methods

 | Name | Description
Public method | Capture | (Inherited from VisualTreeHost.)
Public method | EnsureStateIsCurrent | Will force the VisualTree to Refresh. Identical to VisualTree.Refresh(). (Inherited from VisualTreeHost.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixAnnotationArea | (Inherited from VisualTreeHost.)
Public method | GetChildHosts | Get all contained hosts. (Inherited from VisualTreeHost.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Returns the root target element of this host. VisualTree.Root (Inherited from VisualTreeHost.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateAllInHost | Locate all in host. (Inherited from VisualTreeHost.)
Public method | LocateInHost | Locate an element from the root of this host using an expression. (Inherited from VisualTreeHost.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetWindowFocus | (Inherited from VisualTreeHost.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateInterHostLinks | Silverlight hosts have no inter-host links to update (Inherited from VisualTreeHost.)
Public method | ValidateMouseLocation | (Inherited from VisualTreeHost.)

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTreeHost Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost Properties
VisualTreeHost Class See Also Send Feedback

The VisualTreeHost type exposes the following members.

Properties

 | Name | Description
Public property | Annotator | (Inherited from VisualTreeHost.)
Public property | ContentWindow | (Inherited from VisualTreeHost.)
Public property | FriendlyName | Returns a friendly name for this host (Inherited from VisualTreeHost.)
Public property | Manager | (Inherited from VisualTreeHost.)
Public property | OwnerApp | The SilverlightApp containing this visual tree (Inherited from VisualTreeHost.)
Public property | ShouldDisplayAnnotation | (Inherited from VisualTreeHost.)
Public property | StateHashCode | Gets a unique identifier that identifies the state of this host (Inherited from VisualTreeHost.)
Public property | TechnologyType | VisualTreeHosts are only used for Silverlight (Inherited from VisualTreeHost.)
Public property | UniqueId | A unique identifier that identifies this plugin instance. This id is updated only when the plug-in is reloaded on a postback or a browser refresh. (Inherited from VisualTreeHost.)
Public property | VisualTree | The visual tree wrapped by this host object (Inherited from VisualTreeHost.)
Public property | Window | (Inherited from VisualTreeHost.)

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTreeUnavailableException Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeUnavailableException Members
VisualTreeUnavailableException Class Constructors Methods Properties See Also Send Feedback

The VisualTreeUnavailableException type exposes the following members.

Constructors

 | Name | Description
Public method | VisualTreeUnavailableException | Constructs a new VisualTreeUnavailableException object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VisualTreeUnavailableException Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTreeUnavailableException Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeUnavailableException Constructor
VisualTreeUnavailableException Class See Also Send Feedback
Constructs a new VisualTreeUnavailableException object.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualTreeUnavailableException(
    string message,
    Exception inner
)
Visual Basic
Public Sub New ( _
    message As String, _
    inner As Exception _
)
Visual C++
public:
VisualTreeUnavailableException(
    String^ message,
    Exception^ inner
)

Parameters

message
Type: System..::..String
The message for the exception.
inner
Type: System..::..Exception
Any inner exception being wrapped by this exception.

See Also

VisualTreeUnavailableException Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTreeUnavailableException Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeUnavailableException Methods
VisualTreeUnavailableException Class See Also Send Feedback

The VisualTreeUnavailableException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

VisualTreeUnavailableException Class
ArtOfTest.WebAii.Silverlight Namespace


VisualTreeUnavailableException Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeUnavailableException Properties
VisualTreeUnavailableException Class See Also Send Feedback

The VisualTreeUnavailableException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VisualTreeUnavailableException Class
ArtOfTest.WebAii.Silverlight Namespace


VisualWait Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait Members
VisualWait Class Methods Properties See Also Send Feedback

The VisualWait type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>)) | Wait for a custom defined predicate on this framework element.
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>), String) | Wait for a custom defined predicate on this framework element.
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>), Int32, String) | Wait for a custom defined predicate on this framework element.
Public method | ForExists()()()() |
Public method | ForExists(Int32) |
Public method | ForExistsNot()()()() |
Public method | ForExistsNot(Int32) |
Public method | ForNoMotion(Int32) | Waits for this element to stop moving.
Public method | ForNoMotion(Int32, Int32) | Waits for this element to stop moving.
Public method | ForNoMotion(Int32, Int32, Int32) | Waits for this element to stop moving.
Public method | ForVisible()()()() | Wait for this element to be visible in the VisualTree.
Public method | ForVisible(Int32) | Wait for this element to be visible in the VisualTree.
Public method | ForVisibleNot()()()() | Wait for this element to no longer be visible i the VisualTree
Public method | ForVisibleNot(Int32) | Wait for this element to no longer be visible i the VisualTree
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Timeout | Gets or sets the default timeout for all wait operations

See Also

VisualWait Class
ArtOfTest.WebAii.Silverlight Namespace


VisualWait Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait Methods
VisualWait Class See Also Send Feedback

The VisualWait type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>)) | Wait for a custom defined predicate on this framework element.
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>), String) | Wait for a custom defined predicate on this framework element.
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>), Int32, String) | Wait for a custom defined predicate on this framework element.
Public method | ForExists()()()() |
Public method | ForExists(Int32) |
Public method | ForExistsNot()()()() |
Public method | ForExistsNot(Int32) |
Public method | ForNoMotion(Int32) | Waits for this element to stop moving.
Public method | ForNoMotion(Int32, Int32) | Waits for this element to stop moving.
Public method | ForNoMotion(Int32, Int32, Int32) | Waits for this element to stop moving.
Public method | ForVisible()()()() | Wait for this element to be visible in the VisualTree.
Public method | ForVisible(Int32) | Wait for this element to be visible in the VisualTree.
Public method | ForVisibleNot()()()() | Wait for this element to no longer be visible i the VisualTree
Public method | ForVisibleNot(Int32) | Wait for this element to no longer be visible i the VisualTree
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualWait Class
ArtOfTest.WebAii.Silverlight Namespace


For Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..For Method
VisualWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>)) | Wait for a custom defined predicate on this framework element.
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>), String) | Wait for a custom defined predicate on this framework element.
Public method | For(Predicate<(Of <<'(FrameworkElement>)>>), Int32, String) | Wait for a custom defined predicate on this framework element.

See Also

VisualWait Class
VisualWait Members
ArtOfTest.WebAii.Silverlight Namespace


For Method (Predicate(FrameworkElement))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..For Method (Predicate<(Of <(<'FrameworkElement>)>)>)
VisualWait Class See Also Send Feedback
Wait for a custom defined predicate on this framework element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void For(
    Predicate<FrameworkElement> predicate
)
Visual Basic
Public Sub For ( _
    predicate As Predicate(Of FrameworkElement) _
)
Visual C++
public:
void For(
    Predicate<FrameworkElement^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' FrameworkElement >)>)>
The custom predicate

See Also

VisualWait Class
For Overload
ArtOfTest.WebAii.Silverlight Namespace


For Method (Predicate(FrameworkElement), String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..For Method (Predicate<(Of <(<'FrameworkElement>)>)>, String)
VisualWait Class See Also Send Feedback
Wait for a custom defined predicate on this framework element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void For(
    Predicate<FrameworkElement> predicate,
    string onErrorMessage
)
Visual Basic
Public Sub For ( _
    predicate As Predicate(Of FrameworkElement), _
    onErrorMessage As String _
)
Visual C++
public:
void For(
    Predicate<FrameworkElement^>^ predicate,
    String^ onErrorMessage
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' FrameworkElement >)>)>
The custom predicate
onErrorMessage
Type: System..::..String
Message to show in case of an error/timeout

See Also

VisualWait Class
For Overload
ArtOfTest.WebAii.Silverlight Namespace


For Method (Predicate(FrameworkElement), Int32, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..For Method (Predicate<(Of <(<'FrameworkElement>)>)>, Int32, String)
VisualWait Class See Also Send Feedback
Wait for a custom defined predicate on this framework element.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void For(
    Predicate<FrameworkElement> predicate,
    int timeout,
    string onErrorMessage
)
Visual Basic
Public Sub For ( _
    predicate As Predicate(Of FrameworkElement), _
    timeout As Integer, _
    onErrorMessage As String _
)
Visual C++
public:
void For(
    Predicate<FrameworkElement^>^ predicate,
    int timeout,
    String^ onErrorMessage
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' FrameworkElement >)>)>
The custom predicate
timeout
Type: System..::..Int32
The timeout to use
onErrorMessage
Type: System..::..String
Message to show in case of an error/timeout

See Also

VisualWait Class
For Overload
ArtOfTest.WebAii.Silverlight Namespace


ForExists Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForExists Method
VisualWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForExists()()()() |
Public method | ForExists(Int32) |

See Also

VisualWait Class
VisualWait Members
ArtOfTest.WebAii.Silverlight Namespace


ForExists Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForExists Method
VisualWait Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualWait.ForExists"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForExists()
Visual Basic
Public Sub ForExists
Visual C++
public:
void ForExists()

See Also

VisualWait Class
ForExists Overload
ArtOfTest.WebAii.Silverlight Namespace


ForExists Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForExists Method (Int32)
VisualWait Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualWait.ForExists(System.Int32)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForExists(
    int timeout
)
Visual Basic
Public Sub ForExists ( _
    timeout As Integer _
)
Visual C++
public:
void ForExists(
    int timeout
)

Parameters

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualWait.ForExists(System.Int32)"]

See Also

VisualWait Class
ForExists Overload
ArtOfTest.WebAii.Silverlight Namespace


ForExistsNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForExistsNot Method
VisualWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForExistsNot()()()() |
Public method | ForExistsNot(Int32) |

See Also

VisualWait Class
VisualWait Members
ArtOfTest.WebAii.Silverlight Namespace


ForExistsNot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForExistsNot Method
VisualWait Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualWait.ForExistsNot"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForExistsNot()
Visual Basic
Public Sub ForExistsNot
Visual C++
public:
void ForExistsNot()

See Also

VisualWait Class
ForExistsNot Overload
ArtOfTest.WebAii.Silverlight Namespace


ForExistsNot Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForExistsNot Method (Int32)
VisualWait Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualWait.ForExistsNot(System.Int32)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForExistsNot(
    int timeout
)
Visual Basic
Public Sub ForExistsNot ( _
    timeout As Integer _
)
Visual C++
public:
void ForExistsNot(
    int timeout
)

Parameters

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Silverlight.VisualWait.ForExistsNot(System.Int32)"]

See Also

VisualWait Class
ForExistsNot Overload
ArtOfTest.WebAii.Silverlight Namespace


ForNoMotion Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForNoMotion Method
VisualWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForNoMotion(Int32) | Waits for this element to stop moving.
Public method | ForNoMotion(Int32, Int32) | Waits for this element to stop moving.
Public method | ForNoMotion(Int32, Int32, Int32) | Waits for this element to stop moving.

See Also

VisualWait Class
VisualWait Members
ArtOfTest.WebAii.Silverlight Namespace


ForNoMotion Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForNoMotion Method (Int32)
VisualWait Class See Also Send Feedback
Waits for this element to stop moving.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForNoMotion(
    int motionCheckInterval
)
Visual Basic
Public Sub ForNoMotion ( _
    motionCheckInterval As Integer _
)
Visual C++
public:
void ForNoMotion(
    int motionCheckInterval
)

Parameters

motionCheckInterval
Type: System..::..Int32
The period of time in msec that constitutes no motion. For example if you pass in 500msec then if the object does not move for a period of 500msec, this function will return else will continue polling.

See Also

VisualWait Class
ForNoMotion Overload
ArtOfTest.WebAii.Silverlight Namespace


ForNoMotion Method (Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForNoMotion Method (Int32, Int32)
VisualWait Class See Also Send Feedback
Waits for this element to stop moving.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForNoMotion(
    int motionCheckInterval,
    int timeout
)
Visual Basic
Public Sub ForNoMotion ( _
    motionCheckInterval As Integer, _
    timeout As Integer _
)
Visual C++
public:
void ForNoMotion(
    int motionCheckInterval,
    int timeout
)

Parameters

motionCheckInterval
Type: System..::..Int32
The period of time in msec that constitutes no motion. For example if you pass in 500msec then if the object does not move for a period of 500msec, this function will return else will continue polling.
timeout
Type: System..::..Int32
The timeout to use.

See Also

VisualWait Class
ForNoMotion Overload
ArtOfTest.WebAii.Silverlight Namespace


ForNoMotion Method (Int32, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForNoMotion Method (Int32, Int32, Int32)
VisualWait Class See Also Send Feedback
Waits for this element to stop moving.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForNoMotion(
    int initialWait,
    int motionCheckInterval,
    int timeout
)
Visual Basic
Public Sub ForNoMotion ( _
    initialWait As Integer, _
    motionCheckInterval As Integer, _
    timeout As Integer _
)
Visual C++
public:
void ForNoMotion(
    int initialWait,
    int motionCheckInterval,
    int timeout
)

Parameters

initialWait
Type: System..::..Int32
The number of milliseconds to wait before starting to check whether the element has stopped moving
motionCheckInterval
Type: System..::..Int32
The period of time in msec that constitutes no motion. For example if you pass in 500msec then if the object does not move for a period of 500msec, this function will return else will continue polling.
timeout
Type: System..::..Int32
The timeout to use.

See Also

VisualWait Class
ForNoMotion Overload
ArtOfTest.WebAii.Silverlight Namespace


ForVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForVisible Method
VisualWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForVisible()()()() | Wait for this element to be visible in the VisualTree.
Public method | ForVisible(Int32) | Wait for this element to be visible in the VisualTree.

See Also

VisualWait Class
VisualWait Members
ArtOfTest.WebAii.Silverlight Namespace


ForVisible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForVisible Method
VisualWait Class See Also Send Feedback
Wait for this element to be visible in the VisualTree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForVisible()
Visual Basic
Public Sub ForVisible
Visual C++
public:
void ForVisible()

See Also

VisualWait Class
ForVisible Overload
ArtOfTest.WebAii.Silverlight Namespace


ForVisible Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForVisible Method (Int32)
VisualWait Class See Also Send Feedback
Wait for this element to be visible in the VisualTree.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForVisible(
    int timeout
)
Visual Basic
Public Sub ForVisible ( _
    timeout As Integer _
)
Visual C++
public:
void ForVisible(
    int timeout
)

Parameters

timeout
Type: System..::..Int32
The timeout to use.

See Also

VisualWait Class
ForVisible Overload
ArtOfTest.WebAii.Silverlight Namespace


ForVisibleNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForVisibleNot Method
VisualWait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForVisibleNot()()()() | Wait for this element to no longer be visible i the VisualTree
Public method | ForVisibleNot(Int32) | Wait for this element to no longer be visible i the VisualTree

See Also

VisualWait Class
VisualWait Members
ArtOfTest.WebAii.Silverlight Namespace


ForVisibleNot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForVisibleNot Method
VisualWait Class See Also Send Feedback
Wait for this element to no longer be visible i the VisualTree

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForVisibleNot()
Visual Basic
Public Sub ForVisibleNot
Visual C++
public:
void ForVisibleNot()

See Also

VisualWait Class
ForVisibleNot Overload
ArtOfTest.WebAii.Silverlight Namespace


ForVisibleNot Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait..::..ForVisibleNot Method (Int32)
VisualWait Class See Also Send Feedback
Wait for this element to no longer be visible i the VisualTree

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForVisibleNot(
    int timeout
)
Visual Basic
Public Sub ForVisibleNot ( _
    timeout As Integer _
)
Visual C++
public:
void ForVisibleNot(
    int timeout
)

Parameters

timeout
Type: System..::..Int32
The timeout to use.

See Also

VisualWait Class
ForVisibleNot Overload
ArtOfTest.WebAii.Silverlight Namespace


VisualWait Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualWait Properties
VisualWait Class See Also Send Feedback

The VisualWait type exposes the following members.

Properties

 | Name | Description
Public property | Timeout | Gets or sets the default timeout for all wait operations

See Also

VisualWait Class
ArtOfTest.WebAii.Silverlight Namespace


XamlFindClause Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause Members
XamlFindClause Class Constructors Methods Properties See Also Send Feedback

The XamlFindClause type exposes the following members.

Constructors

 | Name | Description
Public method | XamlFindClause()()()() | Initializes a new instance of the XamlFindClause class
Public method | XamlFindClause(String) | Initializes a new instance of the XamlFindClause class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractValue | Extract the actual value for the search type passed in. (Overrides FindClause..::..ExtractValue(String, ITargetElement).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateXamlPath(FrameworkElement) |
Public method | GenerateXamlPath(FrameworkElement, FrameworkElement) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTagIndexFromParent | Given a parent and a child element, return the child index within that parent
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match(ITargetElement) | (Overrides FindClause..::..Match(ITargetElement).)
Public method | Match(ITargetElement, ITargetElement) | Match the target with this clause. (Overrides FindClause..::..Match(ITargetElement, ITargetElement).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnParsed | Occurs when an clause is parsed into name value pairs including compare type. (Overrides FindClause..::..OnParsed()()()().)
Public method | ToString | Return the string representation of this expression. (Inherited from FindClause.)

Properties

 | Name | Description
Public property | Clause | Gets or sets the search expression. On setting the value, the expression will be parsed. (Inherited from FindClause.)
Public property | CompareType | Gets the expression compare type. (Inherited from FindClause.)
Public property | IsHierarchical | Gets whether this search clause is relative to the root of the search. (Inherited from FindClause.)
Public property | Name | Gets the name part of the expression. (Inherited from FindClause.)
Public property | Priority | Gets the search priority of this clause. 0 is the highest. 10 lowest. (Inherited from FindClause.)
Public property | SearchType |
Public property | TagIndex |
Public property | Value | Gets the value part of the expression. (Inherited from FindClause.)
Public property | XamlTagName |

See Also

XamlFindClause Class
ArtOfTest.WebAii.Silverlight Namespace


XamlFindClause Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause Constructor
XamlFindClause Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XamlFindClause()()()() | Initializes a new instance of the XamlFindClause class
Public method | XamlFindClause(String) | Initializes a new instance of the XamlFindClause class

See Also

XamlFindClause Class
XamlFindClause Members
ArtOfTest.WebAii.Silverlight Namespace


XamlFindClause Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause Constructor
XamlFindClause Class See Also Send Feedback
Initializes a new instance of the XamlFindClause class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XamlFindClause()
Visual Basic
Public Sub New
Visual C++
public:
XamlFindClause()

See Also

XamlFindClause Class
XamlFindClause Overload
ArtOfTest.WebAii.Silverlight Namespace


XamlFindClause Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause Constructor (String)
XamlFindClause Class See Also Send Feedback
Initializes a new instance of the XamlFindClause class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XamlFindClause(
    string clause
)
Visual Basic
Public Sub New ( _
    clause As String _
)
Visual C++
public:
XamlFindClause(
    String^ clause
)

Parameters

clause
Type: System..::..String

[Missing <param name="clause"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.#ctor(System.String)"]

See Also

XamlFindClause Class
XamlFindClause Overload
ArtOfTest.WebAii.Silverlight Namespace


XamlFindClause Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause Methods
XamlFindClause Class See Also Send Feedback

The XamlFindClause type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractValue | Extract the actual value for the search type passed in. (Overrides FindClause..::..ExtractValue(String, ITargetElement).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateXamlPath(FrameworkElement) |
Public method | GenerateXamlPath(FrameworkElement, FrameworkElement) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTagIndexFromParent | Given a parent and a child element, return the child index within that parent
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Match(ITargetElement) | (Overrides FindClause..::..Match(ITargetElement).)
Public method | Match(ITargetElement, ITargetElement) | Match the target with this clause. (Overrides FindClause..::..Match(ITargetElement, ITargetElement).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnParsed | Occurs when an clause is parsed into name value pairs including compare type. (Overrides FindClause..::..OnParsed()()()().)
Public method | ToString | Return the string representation of this expression. (Inherited from FindClause.)

See Also

XamlFindClause Class
ArtOfTest.WebAii.Silverlight Namespace


ExtractValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..ExtractValue Method
XamlFindClause Class See Also Send Feedback
Extract the actual value for the search type passed in.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ExtractValue(
    string searchType,
    ITargetElement element
)
Visual Basic
Public Overrides Function ExtractValue ( _
    searchType As String, _
    element As ITargetElement _
) As String
Visual C++
public:
virtual String^ ExtractValue(
    String^ searchType,
    ITargetElement^ element
) override

Parameters

searchType
Type: System..::..String
The search type.
element
Type: ArtOfTest.Common..::..ITargetElement
The target element

Return Value

The actual value

See Also

XamlFindClause Class
ArtOfTest.WebAii.Silverlight Namespace


GenerateXamlPath Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..GenerateXamlPath Method
XamlFindClause Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GenerateXamlPath(FrameworkElement) |
Public method | GenerateXamlPath(FrameworkElement, FrameworkElement) |

See Also

XamlFindClause Class
XamlFindClause Members
ArtOfTest.WebAii.Silverlight Namespace


GenerateXamlPath Method (FrameworkElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..GenerateXamlPath Method (FrameworkElement)
XamlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GenerateXamlPath(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GenerateXamlPath(
    FrameworkElement fx
)
Visual Basic
Public Function GenerateXamlPath ( _
    fx As FrameworkElement _
) As String
Visual C++
public:
String^ GenerateXamlPath(
    FrameworkElement^ fx
)

Parameters

fx
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="fx"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GenerateXamlPath(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GenerateXamlPath(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

XamlFindClause Class
GenerateXamlPath Overload
ArtOfTest.WebAii.Silverlight Namespace


GenerateXamlPath Method (FrameworkElement, FrameworkElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..GenerateXamlPath Method (FrameworkElement, FrameworkElement)
XamlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GenerateXamlPath(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string GenerateXamlPath(
    FrameworkElement fx,
    FrameworkElement parent
)
Visual Basic
Public Function GenerateXamlPath ( _
    fx As FrameworkElement, _
    parent As FrameworkElement _
) As String
Visual C++
public:
String^ GenerateXamlPath(
    FrameworkElement^ fx,
    FrameworkElement^ parent
)

Parameters

fx
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="fx"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GenerateXamlPath(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

parent
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="parent"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GenerateXamlPath(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GenerateXamlPath(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

XamlFindClause Class
GenerateXamlPath Overload
ArtOfTest.WebAii.Silverlight Namespace


GetTagIndexFromParent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..GetTagIndexFromParent Method
XamlFindClause Class See Also Send Feedback
Given a parent and a child element, return the child index within that parent

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static int GetTagIndexFromParent(
    FrameworkElement parent,
    FrameworkElement e
)
Visual Basic
Public Shared Function GetTagIndexFromParent ( _
    parent As FrameworkElement, _
    e As FrameworkElement _
) As Integer
Visual C++
public:
static int GetTagIndexFromParent(
    FrameworkElement^ parent,
    FrameworkElement^ e
)

Parameters

parent
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="parent"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GetTagIndexFromParent(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

e
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="e"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GetTagIndexFromParent(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.GetTagIndexFromParent(ArtOfTest.WebAii.Silverlight.FrameworkElement,ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

See Also

XamlFindClause Class
ArtOfTest.WebAii.Silverlight Namespace


Match Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..Match Method
XamlFindClause Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Match(ITargetElement) | (Overrides FindClause..::..Match(ITargetElement).)
Public method | Match(ITargetElement, ITargetElement) | Match the target with this clause. (Overrides FindClause..::..Match(ITargetElement, ITargetElement).)

See Also

XamlFindClause Class
XamlFindClause Members
ArtOfTest.WebAii.Silverlight Namespace


Match Method (ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..Match Method (ITargetElement)
XamlFindClause Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.Match(ArtOfTest.Common.ITargetElement)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Match(
    ITargetElement element
)
Visual Basic
Public Overrides Function Match ( _
    element As ITargetElement _
) As Boolean
Visual C++
public:
virtual bool Match(
    ITargetElement^ element
) override

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.Match(ArtOfTest.Common.ITargetElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.Match(ArtOfTest.Common.ITargetElement)"]

See Also

XamlFindClause Class
Match Overload
ArtOfTest.WebAii.Silverlight Namespace


Match Method (ITargetElement, ITargetElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..Match Method (ITargetElement, ITargetElement)
XamlFindClause Class See Also Send Feedback
Match the target with this clause.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool Match(
    ITargetElement element,
    ITargetElement startElement
)
Visual Basic
Public Overrides Function Match ( _
    element As ITargetElement, _
    startElement As ITargetElement _
) As Boolean
Visual C++
public:
virtual bool Match(
    ITargetElement^ element,
    ITargetElement^ startElement
) override

Parameters

element
Type: ArtOfTest.Common..::..ITargetElement
The element to match.
startElement
Type: ArtOfTest.Common..::..ITargetElement
Element to start search at. Required for hierarchal searches

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindClause.Match(ArtOfTest.Common.ITargetElement,ArtOfTest.Common.ITargetElement)"]

See Also

XamlFindClause Class
Match Overload
ArtOfTest.WebAii.Silverlight Namespace


OnParsed Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause..::..OnParsed Method
XamlFindClause Class See Also Send Feedback
Occurs when an clause is parsed into name value pairs including compare type.

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void OnParsed()
Visual Basic
Public Overrides Sub OnParsed
Visual C++
public:
virtual void OnParsed() override

See Also

XamlFindClause Class
ArtOfTest.WebAii.Silverlight Namespace


XamlFindClause Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindClause Properties
XamlFindClause Class See Also Send Feedback

The XamlFindClause type exposes the following members.

Properties

 | Name | Description
Public property | Clause | Gets or sets the search expression. On setting the value, the expression will be parsed. (Inherited from FindClause.)
Public property | CompareType | Gets the expression compare type. (Inherited from FindClause.)
Public property | IsHierarchical | Gets whether this search clause is relative to the root of the search. (Inherited from FindClause.)
Public property | Name | Gets the name part of the expression. (Inherited from FindClause.)
Public property | Priority | Gets the search priority of this clause. 0 is the highest. 10 lowest. (Inherited from FindClause.)
Public property | SearchType |
Public property | TagIndex |
Public property | Value | Gets the value part of the expression. (Inherited from FindClause.)
Public property | XamlTagName |

See Also

XamlFindClause Class
ArtOfTest.WebAii.Silverlight Namespace


XamlFindExpression Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindExpression Members
XamlFindExpression Class Constructors Methods Properties See Also Send Feedback

The XamlFindExpression type exposes the following members.

Constructors

 | Name | Description
Public method | XamlFindExpression()()()() | Initializes a new instance of the XamlFindExpression class
Public method | XamlFindExpression(array<String>[]()[][]) | Initializes a new instance of the XamlFindExpression class

Methods

 | Name | Description
Public method | AddClause | (Overrides FindExpression<(Of <(<'T>)>)>..::..AddClause(String).)
Public method | AddHierarchyConstraint | Add a hierarchy constraint. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | AppendChain | Append the passed in expression as a chain to the end of the expression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | AppendClauses | Append a set of clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | CheckConstraints | Check the constraints of this target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClauses | Get the list of clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize this expression with a set of clauses. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement) | Match this expression against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of this FindExpression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Update | Update this expression with the new expression (Inherited from FindExpression<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | ChainStops | Gets the list of chain locations in the clauses. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | Clauses | Gets the expression clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | Constraints | Get any hierarchy constraints. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | FindClauses | Gets or sets the find statement. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | HasConstraints | Gets whether this expression have hierarchy constraints (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | HasHierarchicalDependency | Gets whether this expression has any hierarchal dependencies. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | IsChained | Gets whether the search is chained. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | StringRepresentation | Get the string representation of this expression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | SupportedSearchType | Gets the XamlSearchType as a Type object. (Overrides FindExpression<(Of <(<'T>)>)>..::..SupportedSearchType.)

See Also

XamlFindExpression Class
ArtOfTest.WebAii.Silverlight Namespace


XamlFindExpression Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindExpression Constructor
XamlFindExpression Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XamlFindExpression()()()() | Initializes a new instance of the XamlFindExpression class
Public method | XamlFindExpression(array<String>[]()[][]) | Initializes a new instance of the XamlFindExpression class

See Also

XamlFindExpression Class
XamlFindExpression Members
ArtOfTest.WebAii.Silverlight Namespace


XamlFindExpression Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindExpression Constructor
XamlFindExpression Class See Also Send Feedback
Initializes a new instance of the XamlFindExpression class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XamlFindExpression()
Visual Basic
Public Sub New
Visual C++
public:
XamlFindExpression()

See Also

XamlFindExpression Class
XamlFindExpression Overload
ArtOfTest.WebAii.Silverlight Namespace


XamlFindExpression Constructor (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindExpression Constructor (array<String>[]()[][])
XamlFindExpression Class See Also Send Feedback
Initializes a new instance of the XamlFindExpression class

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XamlFindExpression(
    params string[] findClauses
)
Visual Basic
Public Sub New ( _
    ParamArray findClauses As String() _
)
Visual C++
public:
XamlFindExpression(
    ... array<String^>^ findClauses
)

Parameters

findClauses
Type: array< System..::..String >[]()[][]

[Missing <param name="findClauses"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindExpression.#ctor(System.String[])"]

See Also

XamlFindExpression Class
XamlFindExpression Overload
ArtOfTest.WebAii.Silverlight Namespace


XamlFindExpression Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindExpression Methods
XamlFindExpression Class See Also Send Feedback

The XamlFindExpression type exposes the following members.

Methods

 | Name | Description
Public method | AddClause | (Overrides FindExpression<(Of <(<'T>)>)>..::..AddClause(String).)
Public method | AddHierarchyConstraint | Add a hierarchy constraint. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | AppendChain | Append the passed in expression as a chain to the end of the expression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | AppendClauses | Append a set of clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | CheckConstraints | Check the constraints of this target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetClauses | Get the list of clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize this expression with a set of clauses. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement) | Match this expression against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the string representation of this FindExpression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Update | Update this expression with the new expression (Inherited from FindExpression<(Of <(<'T>)>)>.)

See Also

XamlFindExpression Class
ArtOfTest.WebAii.Silverlight Namespace


AddClause Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindExpression..::..AddClause Method
XamlFindExpression Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindExpression.AddClause(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AddClause(
    string clause
)
Visual Basic
Public Overrides Sub AddClause ( _
    clause As String _
)
Visual C++
public:
virtual void AddClause(
    String^ clause
) override

Parameters

clause
Type: System..::..String

[Missing <param name="clause"/> documentation for "M:ArtOfTest.WebAii.Silverlight.XamlFindExpression.AddClause(System.String)"]

See Also

XamlFindExpression Class
ArtOfTest.WebAii.Silverlight Namespace


Match Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindExpression..::..Match Method
XamlFindExpression Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Match(ITargetElement) | Match this expression against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public method | Match(ITargetElement, IList<(Of <<'(FindClause>)>>), Boolean) | Match a set of clauses against a target. (Inherited from FindExpression<(Of <(<'T>)>)>.)

See Also

XamlFindExpression Class
XamlFindExpression Members
ArtOfTest.WebAii.Silverlight Namespace


XamlFindExpression Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlFindExpression Properties
XamlFindExpression Class See Also Send Feedback

The XamlFindExpression type exposes the following members.

Properties

 | Name | Description
Public property | ChainStops | Gets the list of chain locations in the clauses. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | Clauses | Gets the expression clauses (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | Constraints | Get any hierarchy constraints. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | FindClauses | Gets or sets the find statement. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | HasConstraints | Gets whether this expression have hierarchy constraints (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | HasHierarchicalDependency | Gets whether this expression has any hierarchal dependencies. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | IsChained | Gets whether the search is chained. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | StringRepresentation | Get the string representation of this expression. (Inherited from FindExpression<(Of <(<'T>)>)>.)
Public property | SupportedSearchType | Gets the XamlSearchType as a Type object. (Overrides FindExpression<(Of <(<'T>)>)>..::..SupportedSearchType.)

See Also

XamlFindExpression Class
ArtOfTest.WebAii.Silverlight Namespace


ArtOfTest.WebAii.Silverlight.Attributes Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Silverlight.Attributes Namespace
Send Feedback
Wrappers for the various common attributes of Silverlight elements.

Classes

 | Class | Description
Public class | ContainsSilverlightTypesAttribute | Use this attribute to decorate assemblies that contain classes that are used to transfer information between WebAii tests and Silverlight applications.


ContainsSilverlightTypesAttribute Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainsSilverlightTypesAttribute Members
ContainsSilverlightTypesAttribute Class Constructors Methods Properties See Also Send Feedback

The ContainsSilverlightTypesAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | ContainsSilverlightTypesAttribute | Initializes a new instance of the ContainsSilverlightTypesAttribute class

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ContainsSilverlightTypesAttribute Class
ArtOfTest.WebAii.Silverlight.Attributes Namespace


ContainsSilverlightTypesAttribute Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainsSilverlightTypesAttribute Constructor
ContainsSilverlightTypesAttribute Class See Also Send Feedback
Initializes a new instance of the ContainsSilverlightTypesAttribute class

Namespace: ArtOfTest.WebAii.Silverlight.Attributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContainsSilverlightTypesAttribute()
Visual Basic
Public Sub New
Visual C++
public:
ContainsSilverlightTypesAttribute()

See Also

ContainsSilverlightTypesAttribute Class
ArtOfTest.WebAii.Silverlight.Attributes Namespace


ContainsSilverlightTypesAttribute Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainsSilverlightTypesAttribute Methods
ContainsSilverlightTypesAttribute Class See Also Send Feedback

The ContainsSilverlightTypesAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContainsSilverlightTypesAttribute Class
ArtOfTest.WebAii.Silverlight.Attributes Namespace


ContainsSilverlightTypesAttribute Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContainsSilverlightTypesAttribute Properties
ContainsSilverlightTypesAttribute Class See Also Send Feedback

The ContainsSilverlightTypesAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ContainsSilverlightTypesAttribute Class
ArtOfTest.WebAii.Silverlight.Attributes Namespace


ArtOfTest.WebAii.Silverlight.UI Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Silverlight.UI Namespace
Send Feedback
Namespace for all the XAML element wrapper classes.

Classes

 | Class | Description
Public class | ArcSegment |
Public class | AutoCompleteBox |
Public class | BezierSegment |
Public class | BitmapImage | Wraps a Silverlight BitmapImage element.
Public class | BitmapSource |
Public class | Border |
Public class | Brush |
Public class | Button |
Public class | ButtonBase |
Public class | Calendar | Wraps a Silverlight Calendar element.
Public class | CalendarButton |
Public class | CalendarDayButton |
Public class | CalendarItem |
Public class | Canvas |
Public class | CheckBox |
Public class | ChildWindow |
Public class | Color |
Public class | ComboBox |
Public class | ComboBoxItem | Represents the Silverlight ComboBoxItem for control wrapper.
Public class | CompositeTransform |
Public class | ContentControl |
Public class | ContentPresenter |
Public class | Control |
Public class | CornerRadius |
Public class | DataGrid | Wraps a Silverlight DataGrid object.
Public class | DataGridCell | Wraps a Silverlight DataGridCell.
Public class | DataGridCellsPresenter |
Public class | DataGridColumn |
Public class | DataGridColumnHeader |
Public class | DataGridColumnHeadersPresenter |
Public class | DataGridDetailsPresenter |
Public class | DataGridFrozenGrid |
Public class | DataGridLength |
Public class | DataGridRow | Wraps a Silverlight DataGridRow.
Public class | DataGridRowGroupHeader |
Public class | DataGridRowHeader |
Public class | DataGridRowsPresenter |
Public class | DataPager |
Public class | DatePicker |
Public class | DatePickerTextBox |
Public class | DeepZoomImageTileSource | Wraps a Silverlight DeepZoomImageTileSource element.
Public class | DescriptionViewer |
Public class | Duration |
Public class | Ellipse |
Public class | EllipseGeometry |
Public class | Frame |
Public class | Geometry |
Public class | GeometryGroup |
Public class | Glyphs |
Public class | GradientBrush |
Public class | GradientStop |
Public class | Grid |
Public class | GridSplitter |
Public class | HeaderedItemsControl |
Public class | HyperlinkButton | Wraps a Silverlight HyperlinkButton element.
Public class | Image |
Public class | ImageBrush |
Public class | ImageSource |
Public class | ImplicitInputBrush |
Public class | InkPresenter |
Public class | InputScope |
Public class | ItemsControl |
Public class | ItemsPresenter |
Public class | Label |
Public class | Line |
Public class | LinearGradientBrush |
Public class | LineGeometry |
Public class | LineSegment |
Public class | ListBox |
Public class | ListBoxItem | Represents the ListBoxItem for Silverlight control wrapper.
Public class | Matrix |
Public class | MatrixTransform |
Public class | MediaElement |
Public class | MultiScaleImage |
Public class | MultiScaleSubImage | Class that wraps a MultiScaleSubImage oject.
Public class | MultiScaleTileSource |
Public class | Page |
Public class | Panel |
Public class | PasswordBox |
Public class | Path |
Public class | PathFigure |
Public class | PathGeometry |
Public class | PathSegment |
Public class | Point |
Public class | PolyBezierSegment |
Public class | Polygon |
Public class | Polyline |
Public class | PolyLineSegment |
Public class | PolyQuadraticBezierSegment |
Public class | Popup |
Public class | ProgressBar |
Public class | QuadraticBezierSegment |
Public class | RadialGradientBrush |
Public class | RadioButton |
Public class | RangeBase |
Public class | Rect |
Public class | Rectangle |
Public class | RectangleGeometry |
Public class | RepeatButton | Wraps a Silverlight RepeatButton element.
Public class | RichTextBox |
Public class | RotateTransform |
Public class | ScaleTransform |
Public class | ScrollBar |
Public class | ScrollContentPresenter |
Public class | ScrollViewer |
Public class | Selector |
Public class | Shape |
Public class | Size |
Public class | SkewTransform |
Public class | Slider |
Public class | SolidColorBrush |
Public class | StackPanel |
Public class | TabControl |
Public class | TabItem |
Public class | TabPanel |
Public class | TextBlock |
Public class | TextBox |
Public class | Thickness |
Public class | Thumb |
Public class | TileBrush |
Public class | TimeSpan |
Public class | ToggleButton | Wraps a Silverlight ToggleButton element.
Public class | ToolTip |
Public class | Transform |
Public class | TransformGroup |
Public class | TranslateTransform |
Public class | TreeView | Represents the TreeView for Silverlight control wrapper.
Public class | TreeViewItem | Represents the TreeViewItem for Silverlight control wrapper.
Public class | UserControl |
Public class | ValidationSummary |
Public class | VideoBrush |
Public class | Viewbox |
Public class | VirtualizingPanel |
Public class | VirtualizingStackPanel |
Public class | WebBrowser |
Public class | WebBrowserBrush |
Public class | WriteableBitmap |

Structures

 | Structure | Description
Public structure | StructSize |
Public structure | StructThickness |

Enumerations

 | Enumeration | Description
Public enumeration | AlignmentX |
Public enumeration | AlignmentY |
Public enumeration | AutoCompleteFilterMode |
Public enumeration | BitmapCreateOptions |
Public enumeration | BrushMappingMode |
Public enumeration | CalendarMode |
Public enumeration | CalendarSelectionMode |
Public enumeration | ClickMode |
Public enumeration | ColorInterpolationMode |
Public enumeration | DataGridClipboardCopyMode |
Public enumeration | DataGridGridLinesVisibility |
Public enumeration | DataGridHeadersVisibility |
Public enumeration | DataGridLengthUnitType |
Public enumeration | DataGridRowDetailsVisibilityMode |
Public enumeration | DataGridSelectionMode |
Public enumeration | DatePickerFormat |
Public enumeration | DayOfWeek |
Public enumeration | Dock |
Public enumeration | FillRule |
Public enumeration | GradientSpreadMethod |
Public enumeration | HorizontalAlignment |
Public enumeration | JournalOwnership |
Public enumeration | KeyboardNavigationMode |
Public enumeration | LineStackingStrategy |
Public enumeration | MediaElementState |
Public enumeration | Orientation |
Public enumeration | PagerDisplayMode |
Public enumeration | PenLineCap |
Public enumeration | PenLineJoin |
Public enumeration | PlacementMode |
Public enumeration | ScrollBarVisibility |
Public enumeration | SelectionMode |
Public enumeration | Stretch |
Public enumeration | StretchDirection |
Public enumeration | StyleSimulations |
Public enumeration | SweepDirection |
Public enumeration | TextAlignment |
Public enumeration | TextTrimming |
Public enumeration | TextWrapping |
Public enumeration | ValidationSummaryFilters |
Public enumeration | VerticalAlignment |
Public enumeration | Visibility |


ArcSegment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment Members
ArcSegment Class Constructors Methods Fields Properties See Also Send Feedback

The ArcSegment type exposes the following members.

Constructors

 | Name | Description
Public method | ArcSegment | Initializes a new instance of the ArcSegment class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
IsLargeArcProperty |
PointProperty |
RotationAngleProperty |
SizeProperty |
SweepDirectionProperty |

Properties

 | Name | Description
Public property | IsLargeArc |
Public property | Point |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RotationAngle |
Public property | Size |
Public property | SweepDirection |

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ArcSegment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment Constructor
ArcSegment Class See Also Send Feedback
Initializes a new instance of the ArcSegment class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ArcSegment()
Visual Basic
Public Sub New
Visual C++
public:
ArcSegment()

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ArcSegment Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment Fields
ArcSegment Class See Also Send Feedback

The ArcSegment type exposes the following members.

Fields

Name | Description
IsLargeArcProperty |
PointProperty |
RotationAngleProperty |
SizeProperty |
SweepDirectionProperty |

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsLargeArcProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..IsLargeArcProperty Field
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.IsLargeArcProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsLargeArcProperty
Visual Basic
Public Shared IsLargeArcProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsLargeArcProperty

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..PointProperty Field
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.PointProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PointProperty
Visual Basic
Public Shared PointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PointProperty

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RotationAngleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..RotationAngleProperty Field
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.RotationAngleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RotationAngleProperty
Visual Basic
Public Shared RotationAngleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RotationAngleProperty

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..SizeProperty Field
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.SizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SizeProperty
Visual Basic
Public Shared SizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SizeProperty

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SweepDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..SweepDirectionProperty Field
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.SweepDirectionProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SweepDirectionProperty
Visual Basic
Public Shared SweepDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SweepDirectionProperty

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ArcSegment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment Methods
ArcSegment Class See Also Send Feedback

The ArcSegment type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..GetProperty Method
ArcSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ArcSegment Class
ArcSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..GetRealType Method
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..InvokeMethod Method
ArcSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ArcSegment Class
ArcSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ArcSegment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment Properties
ArcSegment Class See Also Send Feedback

The ArcSegment type exposes the following members.

Properties

 | Name | Description
Public property | IsLargeArc |
Public property | Point |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RotationAngle |
Public property | Size |
Public property | SweepDirection |

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsLargeArc Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..IsLargeArc Property
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.IsLargeArc"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsLargeArc { get; set; }
Visual Basic
Public Property IsLargeArc As Boolean
    Get
    Set
Visual C++
public:
property bool IsLargeArc {
    bool get ();
    void set (bool value);
}

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..Point Property
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.Point"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Point { get; set; }
Visual Basic
Public Property Point As Point
    Get
    Set
Visual C++
public:
property Point^ Point {
    Point^ get ();
    void set (Point^ value);
}

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RotationAngle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..RotationAngle Property
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.RotationAngle"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Double
    Get
    Set
Visual C++
public:
property double RotationAngle {
    double get ();
    void set (double value);
}

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Size Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..Size Property
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.Size"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Size Size { get; set; }
Visual Basic
Public Property Size As Size
    Get
    Set
Visual C++
public:
property Size^ Size {
    Size^ get ();
    void set (Size^ value);
}

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SweepDirection Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArcSegment..::..SweepDirection Property
ArcSegment Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ArcSegment.SweepDirection"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SweepDirection SweepDirection { get; set; }
Visual Basic
Public Property SweepDirection As SweepDirection
    Get
    Set
Visual C++
public:
property SweepDirection SweepDirection {
    SweepDirection get ();
    void set (SweepDirection value);
}

See Also

ArcSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoCompleteBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Members
AutoCompleteBox Class Constructors Methods Fields Properties See Also Send Feedback

The AutoCompleteBox type exposes the following members.

Constructors

 | Name | Description
Public method | AutoCompleteBox | Initializes a new instance of the AutoCompleteBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FilterModeProperty |
IsDropDownOpenProperty |
IsTextCompletionEnabledProperty |
MaxDropDownHeightProperty |
MinimumPopulateDelayProperty |
MinimumPrefixLengthProperty |
SearchTextProperty |
TextProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | FilterMode |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextCompletionEnabled |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinimumPopulateDelay |
Public property | MinimumPrefixLength |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SearchText |
Public property | Selector | Get the drop down list box element holding the items to select.
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextBox | Get the actual TextBox element to type text into. Override for custom control template!
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoCompleteBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Constructor
AutoCompleteBox Class See Also Send Feedback
Initializes a new instance of the AutoCompleteBox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutoCompleteBox()
Visual Basic
Public Sub New
Visual C++
public:
AutoCompleteBox()

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoCompleteBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Fields
AutoCompleteBox Class See Also Send Feedback

The AutoCompleteBox type exposes the following members.

Fields

Name | Description
FilterModeProperty |
IsDropDownOpenProperty |
IsTextCompletionEnabledProperty |
MaxDropDownHeightProperty |
MinimumPopulateDelayProperty |
MinimumPrefixLengthProperty |
SearchTextProperty |
TextProperty |

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FilterModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..FilterModeProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.FilterModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FilterModeProperty
Visual Basic
Public Shared FilterModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FilterModeProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDropDownOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsDropDownOpenProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.IsDropDownOpenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDropDownOpenProperty
Visual Basic
Public Shared IsDropDownOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDropDownOpenProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTextCompletionEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsTextCompletionEnabledProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.IsTextCompletionEnabledProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTextCompletionEnabledProperty
Visual Basic
Public Shared IsTextCompletionEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTextCompletionEnabledProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaxDropDownHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MaxDropDownHeightProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.MaxDropDownHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxDropDownHeightProperty
Visual Basic
Public Shared MaxDropDownHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxDropDownHeightProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MinimumPopulateDelayProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MinimumPopulateDelayProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.MinimumPopulateDelayProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinimumPopulateDelayProperty
Visual Basic
Public Shared MinimumPopulateDelayProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinimumPopulateDelayProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MinimumPrefixLengthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MinimumPrefixLengthProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.MinimumPrefixLengthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinimumPrefixLengthProperty
Visual Basic
Public Shared MinimumPrefixLengthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinimumPrefixLengthProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SearchTextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..SearchTextProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.SearchTextProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SearchTextProperty
Visual Basic
Public Shared SearchTextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SearchTextProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..TextProperty Field
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.TextProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoCompleteBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Methods
AutoCompleteBox Class See Also Send Feedback

The AutoCompleteBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..AnySibling Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..GetProperty Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..GetRealType Method
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..GetRectangle Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Highlight Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..InvokeMethod Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsHitTest Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..NextSibling Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Parent Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..PreviousSibling Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..ScrollToVisible Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Select Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Select Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select(Boolean, Int32) | Selects item in the drop down if open.
Public method | Select(Boolean, String) | Selects item in the drop down if open.

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Select Method (Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Select Method (Boolean, Int32)
AutoCompleteBox Class See Also Send Feedback
Selects item in the drop down if open.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Select(
    bool simulateRealUser,
    int itemIndex
)
Visual Basic
Public Sub Select ( _
    simulateRealUser As Boolean, _
    itemIndex As Integer _
)
Visual C++
public:
virtual void Select(
    bool simulateRealUser,
    int itemIndex
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates real click, otherwise changes selection.
itemIndex
Type: System..::..Int32

[Missing <param name="itemIndex"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.Select(System.Boolean,System.Int32)"]

Implements

IAutoCompleteBox..::..Select(Boolean, Int32)

See Also

AutoCompleteBox Class
Select Overload
ArtOfTest.WebAii.Silverlight.UI Namespace


Select Method (Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Select Method (Boolean, String)
AutoCompleteBox Class See Also Send Feedback
Selects item in the drop down if open.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Select(
    bool simulateRealUser,
    string itemText
)
Visual Basic
Public Sub Select ( _
    simulateRealUser As Boolean, _
    itemText As String _
)
Visual C++
public:
virtual void Select(
    bool simulateRealUser,
    String^ itemText
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates real click, otherwise changes selection.
itemText
Type: System..::..String
The text of the item to select.

Implements

IAutoCompleteBox..::..Select(Boolean, String)

See Also

AutoCompleteBox Class
Select Overload
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..SetProperty Method
AutoCompleteBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AutoCompleteBox Class
AutoCompleteBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..SetText Method
AutoCompleteBox Class See Also Send Feedback
Sets or types a new text into the TextBox.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
virtual void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the text.
text
Type: System..::..String
The text to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key

Implements

IAutoCompleteBox..::..SetText(Boolean, String, Int32, Int32)

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoCompleteBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox Properties
AutoCompleteBox Class See Also Send Feedback

The AutoCompleteBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | FilterMode |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTextCompletionEnabled |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinimumPopulateDelay |
Public property | MinimumPrefixLength |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SearchText |
Public property | Selector | Get the drop down list box element holding the items to select.
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextBox | Get the actual TextBox element to type text into. Override for custom control template!
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FilterMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..FilterMode Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.FilterMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AutoCompleteFilterMode FilterMode { get; set; }
Visual Basic
Public Property FilterMode As AutoCompleteFilterMode
    Get
    Set
Visual C++
public:
property AutoCompleteFilterMode FilterMode {
    AutoCompleteFilterMode get ();
    void set (AutoCompleteFilterMode value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDropDownOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsDropDownOpen Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.IsDropDownOpen"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic
Public Property IsDropDownOpen As Boolean
    Get
    Set
Visual C++
public:
property bool IsDropDownOpen {
    bool get ();
    void set (bool value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTextCompletionEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..IsTextCompletionEnabled Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.IsTextCompletionEnabled"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTextCompletionEnabled { get; set; }
Visual Basic
Public Property IsTextCompletionEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsTextCompletionEnabled {
    bool get ();
    void set (bool value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaxDropDownHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MaxDropDownHeight Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.MaxDropDownHeight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxDropDownHeight { get; set; }
Visual Basic
Public Property MaxDropDownHeight As Double
    Get
    Set
Visual C++
public:
property double MaxDropDownHeight {
    double get ();
    void set (double value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MinimumPopulateDelay Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MinimumPopulateDelay Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.MinimumPopulateDelay"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MinimumPopulateDelay { get; set; }
Visual Basic
Public Property MinimumPopulateDelay As Integer
    Get
    Set
Visual C++
public:
property int MinimumPopulateDelay {
    int get ();
    void set (int value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MinimumPrefixLength Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..MinimumPrefixLength Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.MinimumPrefixLength"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int MinimumPrefixLength { get; set; }
Visual Basic
Public Property MinimumPrefixLength As Integer
    Get
    Set
Visual C++
public:
property int MinimumPrefixLength {
    int get ();
    void set (int value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SearchText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..SearchText Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.SearchText"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string SearchText { get; set; }
Visual Basic
Public Property SearchText As String
    Get
    Set
Visual C++
public:
property String^ SearchText {
    String^ get ();
    void set (String^ value);
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Selector Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Selector Property
AutoCompleteBox Class See Also Send Feedback
Get the drop down list box element holding the items to select.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IListBox Selector { get; }
Visual Basic
Public Overridable ReadOnly Property Selector As IListBox
    Get
Visual C++
public:
virtual property IListBox^ Selector {
    IListBox^ get ();
}

Implements

IAutoCompleteBox..::..Selector

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..Text Property
AutoCompleteBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.AutoCompleteBox.Text"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFrameworkElement..::..Text

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AutoCompleteBox..::..TextBox Property
AutoCompleteBox Class See Also Send Feedback
Get the actual TextBox element to type text into. Override for custom control template!

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual TextBox TextBox { get; }
Visual Basic
Public Overridable ReadOnly Property TextBox As TextBox
    Get
Visual C++
public:
virtual property TextBox^ TextBox {
    TextBox^ get ();
}

See Also

AutoCompleteBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BezierSegment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment Members
BezierSegment Class Constructors Methods Fields Properties See Also Send Feedback

The BezierSegment type exposes the following members.

Constructors

 | Name | Description
Public method | BezierSegment | Initializes a new instance of the BezierSegment class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Point1Property |
Point2Property |
Point3Property |

Properties

 | Name | Description
Public property | Point1 |
Public property | Point2 |
Public property | Point3 |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BezierSegment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment Constructor
BezierSegment Class See Also Send Feedback
Initializes a new instance of the BezierSegment class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BezierSegment()
Visual Basic
Public Sub New
Visual C++
public:
BezierSegment()

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BezierSegment Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment Fields
BezierSegment Class See Also Send Feedback

The BezierSegment type exposes the following members.

Fields

Name | Description
Point1Property |
Point2Property |
Point3Property |

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point1Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..Point1Property Field
BezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.BezierSegment.Point1Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Point1Property
Visual Basic
Public Shared Point1Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Point1Property

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point2Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..Point2Property Field
BezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.BezierSegment.Point2Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Point2Property
Visual Basic
Public Shared Point2Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Point2Property

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point3Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..Point3Property Field
BezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.BezierSegment.Point3Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Point3Property
Visual Basic
Public Shared Point3Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Point3Property

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BezierSegment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment Methods
BezierSegment Class See Also Send Feedback

The BezierSegment type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..GetProperty Method
BezierSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BezierSegment Class
BezierSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..GetRealType Method
BezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.BezierSegment.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.BezierSegment.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..InvokeMethod Method
BezierSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BezierSegment Class
BezierSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


BezierSegment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment Properties
BezierSegment Class See Also Send Feedback

The BezierSegment type exposes the following members.

Properties

 | Name | Description
Public property | Point1 |
Public property | Point2 |
Public property | Point3 |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point1 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..Point1 Property
BezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.BezierSegment.Point1"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Point1 { get; set; }
Visual Basic
Public Property Point1 As Point
    Get
    Set
Visual C++
public:
property Point^ Point1 {
    Point^ get ();
    void set (Point^ value);
}

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point2 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..Point2 Property
BezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.BezierSegment.Point2"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Point2 { get; set; }
Visual Basic
Public Property Point2 As Point
    Get
    Set
Visual C++
public:
property Point^ Point2 {
    Point^ get ();
    void set (Point^ value);
}

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point3 Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BezierSegment..::..Point3 Property
BezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.BezierSegment.Point3"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Point3 { get; set; }
Visual Basic
Public Property Point3 As Point
    Get
    Set
Visual C++
public:
property Point^ Point3 {
    Point^ get ();
    void set (Point^ value);
}

See Also

BezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapImage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Members
BitmapImage Class Constructors Methods Fields Properties See Also Send Feedback

The BitmapImage type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapImage | Initializes a new instance of the BitmapImage class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CreateOptionsProperty |
UriSourceProperty |

Properties

 | Name | Description
Public property | CreateOptions |
Public property | PixelHeight | (Inherited from BitmapSource.)
Public property | PixelWidth | (Inherited from BitmapSource.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | UriSource |

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapImage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Constructor
BitmapImage Class See Also Send Feedback
Initializes a new instance of the BitmapImage class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapImage()
Visual Basic
Public Sub New
Visual C++
public:
BitmapImage()

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapImage Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Fields
BitmapImage Class See Also Send Feedback

The BitmapImage type exposes the following members.

Fields

Name | Description
CreateOptionsProperty |
UriSourceProperty |

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CreateOptionsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..CreateOptionsProperty Field
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.BitmapImage.CreateOptionsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CreateOptionsProperty
Visual Basic
Public Shared CreateOptionsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CreateOptionsProperty

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UriSourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..UriSourceProperty Field
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.BitmapImage.UriSourceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UriSourceProperty
Visual Basic
Public Shared UriSourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UriSourceProperty

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapImage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Methods
BitmapImage Class See Also Send Feedback

The BitmapImage type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..GetProperty Method
BitmapImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapImage Class
BitmapImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..GetRealType Method
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.BitmapImage.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.BitmapImage.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..InvokeMethod Method
BitmapImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapImage Class
BitmapImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapImage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage Properties
BitmapImage Class See Also Send Feedback

The BitmapImage type exposes the following members.

Properties

 | Name | Description
Public property | CreateOptions |
Public property | PixelHeight | (Inherited from BitmapSource.)
Public property | PixelWidth | (Inherited from BitmapSource.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | UriSource |

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CreateOptions Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..CreateOptions Property
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.BitmapImage.CreateOptions"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapCreateOptions CreateOptions { get; set; }
Visual Basic
Public Property CreateOptions As BitmapCreateOptions
    Get
    Set
Visual C++
public:
property BitmapCreateOptions CreateOptions {
    BitmapCreateOptions get ();
    void set (BitmapCreateOptions value);
}

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UriSource Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapImage..::..UriSource Property
BitmapImage Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.BitmapImage.UriSource"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UriSource { get; set; }
Visual Basic
Public Property UriSource As String
    Get
    Set
Visual C++
public:
property String^ UriSource {
    String^ get ();
    void set (String^ value);
}

See Also

BitmapImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapSource Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Members
BitmapSource Class Constructors Methods Fields Properties See Also Send Feedback

The BitmapSource type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapSource | Initializes a new instance of the BitmapSource class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ImageSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PixelHeightProperty |
PixelWidthProperty |

Properties

 | Name | Description
Public property | PixelHeight |
Public property | PixelWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapSource Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Constructor
BitmapSource Class See Also Send Feedback
Initializes a new instance of the BitmapSource class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BitmapSource()
Visual Basic
Public Sub New
Visual C++
public:
BitmapSource()

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapSource Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Fields
BitmapSource Class See Also Send Feedback

The BitmapSource type exposes the following members.

Fields

Name | Description
PixelHeightProperty |
PixelWidthProperty |

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PixelHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..PixelHeightProperty Field
BitmapSource Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.BitmapSource.PixelHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PixelHeightProperty
Visual Basic
Public Shared PixelHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PixelHeightProperty

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PixelWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..PixelWidthProperty Field
BitmapSource Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.BitmapSource.PixelWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PixelWidthProperty
Visual Basic
Public Shared PixelWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PixelWidthProperty

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapSource Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Methods
BitmapSource Class See Also Send Feedback

The BitmapSource type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides ImageSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..GetProperty Method
BitmapSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapSource Class
BitmapSource Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..GetRealType Method
BitmapSource Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.BitmapSource.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.BitmapSource.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..InvokeMethod Method
BitmapSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapSource Class
BitmapSource Members
ArtOfTest.WebAii.Silverlight.UI Namespace


BitmapSource Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource Properties
BitmapSource Class See Also Send Feedback

The BitmapSource type exposes the following members.

Properties

 | Name | Description
Public property | PixelHeight |
Public property | PixelWidth |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PixelHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..PixelHeight Property
BitmapSource Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.BitmapSource.PixelHeight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PixelHeight { get; set; }
Visual Basic
Public Property PixelHeight As Integer
    Get
    Set
Visual C++
public:
property int PixelHeight {
    int get ();
    void set (int value);
}

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PixelWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BitmapSource..::..PixelWidth Property
BitmapSource Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.BitmapSource.PixelWidth"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PixelWidth { get; set; }
Visual Basic
Public Property PixelWidth As Integer
    Get
    Set
Visual C++
public:
property int PixelWidth {
    int get ();
    void set (int value);
}

See Also

BitmapSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Border Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Members
Border Class Constructors Methods Fields Properties See Also Send Feedback

The Border type exposes the following members.

Constructors

 | Name | Description
Public method | Border | Initializes a new instance of the Border class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
CornerRadiusProperty |
PaddingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | CornerRadius |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Border Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Constructor
Border Class See Also Send Feedback
Initializes a new instance of the Border class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Border()
Visual Basic
Public Sub New
Visual C++
public:
Border()

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Border Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Fields
Border Class See Also Send Feedback

The Border type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
CornerRadiusProperty |
PaddingProperty |

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BackgroundProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Border.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BorderBrushProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Border.BorderBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderBrushProperty
Visual Basic
Public Shared BorderBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderBrushProperty

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BorderThicknessProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Border.BorderThicknessProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderThicknessProperty
Visual Basic
Public Shared BorderThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderThicknessProperty

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CornerRadiusProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..CornerRadiusProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Border.CornerRadiusProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CornerRadiusProperty
Visual Basic
Public Shared CornerRadiusProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CornerRadiusProperty

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..PaddingProperty Field
Border Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Border.PaddingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PaddingProperty
Visual Basic
Public Shared PaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PaddingProperty

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Border Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Methods
Border Class See Also Send Feedback

The Border type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..AnySibling Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..GetProperty Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..GetRealType Method
Border Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Border.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Border.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..GetRectangle Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..Highlight Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..InvokeMethod Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..IsHitTest Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..NextSibling Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..Parent Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..PreviousSibling Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..ScrollToVisible Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..SetProperty Method
Border Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Border Class
Border Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Border Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border Properties
Border Class See Also Send Feedback

The Border type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | CornerRadius |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..Background Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Border.Background"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BorderBrush Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Border.BorderBrush"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush BorderBrush { get; set; }
Visual Basic
Public Property BorderBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BorderBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderThickness Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..BorderThickness Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Border.BorderThickness"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness BorderThickness { get; set; }
Visual Basic
Public Property BorderThickness As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ BorderThickness {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CornerRadius Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..CornerRadius Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Border.CornerRadius"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CornerRadius CornerRadius { get; set; }
Visual Basic
Public Property CornerRadius As CornerRadius
    Get
    Set
Visual C++
public:
property CornerRadius^ CornerRadius {
    CornerRadius^ get ();
    void set (CornerRadius^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Padding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Border..::..Padding Property
Border Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Border.Padding"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness Padding { get; set; }
Visual Basic
Public Property Padding As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ Padding {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Border Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Brush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Members
Brush Class Constructors Methods Fields Properties See Also Send Feedback

The Brush type exposes the following members.

Constructors

 | Name | Description
Public method | Brush | Initializes a new instance of the Brush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
OpacityProperty |
RelativeTransformProperty |
TransformProperty |

Properties

 | Name | Description
Public property | Opacity |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform |
Public property | Transform |

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Brush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Constructor
Brush Class See Also Send Feedback
Initializes a new instance of the Brush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush()
Visual Basic
Public Sub New
Visual C++
public:
Brush()

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Brush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Fields
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Fields

Name | Description
OpacityProperty |
RelativeTransformProperty |
TransformProperty |

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OpacityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..OpacityProperty Field
Brush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Brush.OpacityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OpacityProperty
Visual Basic
Public Shared OpacityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OpacityProperty

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RelativeTransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..RelativeTransformProperty Field
Brush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Brush.RelativeTransformProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RelativeTransformProperty
Visual Basic
Public Shared RelativeTransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RelativeTransformProperty

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..TransformProperty Field
Brush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Brush.TransformProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TransformProperty
Visual Basic
Public Shared TransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TransformProperty

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Brush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Methods
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..GetProperty Method
Brush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Brush Class
Brush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..GetRealType Method
Brush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Brush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Brush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..InvokeMethod Method
Brush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Brush Class
Brush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Brush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush Properties
Brush Class See Also Send Feedback

The Brush type exposes the following members.

Properties

 | Name | Description
Public property | Opacity |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform |
Public property | Transform |

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Opacity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..Opacity Property
Brush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Brush.Opacity"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Opacity { get; set; }
Visual Basic
Public Property Opacity As Double
    Get
    Set
Visual C++
public:
property double Opacity {
    double get ();
    void set (double value);
}

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RelativeTransform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..RelativeTransform Property
Brush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Brush.RelativeTransform"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform RelativeTransform { get; set; }
Visual Basic
Public Property RelativeTransform As Transform
    Get
    Set
Visual C++
public:
property Transform^ RelativeTransform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Transform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Brush..::..Transform Property
Brush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Brush.Transform"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform Transform { get; set; }
Visual Basic
Public Property Transform As Transform
    Get
    Set
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

Brush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Button Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Members
Button Class Constructors Methods Properties See Also Send Feedback

The Button type exposes the following members.

Constructors

 | Name | Description
Public method | Button | Initializes a new instance of the Button class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Button Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Button Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Constructor
Button Class See Also Send Feedback
Initializes a new instance of the Button class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Button()
Visual Basic
Public Sub New
Visual C++
public:
Button()

See Also

Button Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Button Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Methods
Button Class See Also Send Feedback

The Button type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Button Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..AnySibling Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..GetProperty Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..GetRealType Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Button.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Button.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Button Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..GetRectangle Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..Highlight Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..InvokeMethod Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..IsHitTest Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..NextSibling Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..Parent Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..PreviousSibling Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..ScrollToVisible Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..SetProperty Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Button Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Properties
Button Class See Also Send Feedback

The Button type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Button Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ButtonBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Members
ButtonBase Class Constructors Methods Fields Properties See Also Send Feedback

The ButtonBase type exposes the following members.

Constructors

 | Name | Description
Public method | ButtonBase | Initializes a new instance of the ButtonBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ClickModeProperty |
IsFocusedProperty |
IsMouseOverProperty |
IsPressedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode |
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver |
Public property | IsPressed |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ButtonBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Constructor
ButtonBase Class See Also Send Feedback
Initializes a new instance of the ButtonBase class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ButtonBase()
Visual Basic
Public Sub New
Visual C++
public:
ButtonBase()

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ButtonBase Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Fields
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Fields

Name | Description
ClickModeProperty |
IsFocusedProperty |
IsMouseOverProperty |
IsPressedProperty |

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ClickModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..ClickModeProperty Field
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.ClickModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ClickModeProperty
Visual Basic
Public Shared ClickModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ClickModeProperty

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsFocusedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsFocusedProperty Field
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.IsFocusedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFocusedProperty
Visual Basic
Public Shared IsFocusedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFocusedProperty

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsMouseOverProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsMouseOverProperty Field
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.IsMouseOverProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMouseOverProperty
Visual Basic
Public Shared IsMouseOverProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMouseOverProperty

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsPressedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsPressedProperty Field
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.IsPressedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsPressedProperty
Visual Basic
Public Shared IsPressedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsPressedProperty

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ButtonBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Methods
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..AnySibling Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..GetProperty Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..GetRealType Method
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..GetRectangle Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..Highlight Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..InvokeMethod Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsHitTest Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..NextSibling Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..Parent Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..PreviousSibling Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..ScrollToVisible Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..SetProperty Method
ButtonBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ButtonBase Class
ButtonBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ButtonBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase Properties
ButtonBase Class See Also Send Feedback

The ButtonBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode |
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver |
Public property | IsPressed |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ClickMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..ClickMode Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.ClickMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ClickMode ClickMode { get; set; }
Visual Basic
Public Property ClickMode As ClickMode
    Get
    Set
Visual C++
public:
property ClickMode ClickMode {
    ClickMode get ();
    void set (ClickMode value);
}

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsFocused Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsFocused Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.IsFocused"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsFocused { get; set; }
Visual Basic
Public Property IsFocused As Boolean
    Get
    Set
Visual C++
public:
property bool IsFocused {
    bool get ();
    void set (bool value);
}

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsMouseOver Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsMouseOver Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.IsMouseOver"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsMouseOver { get; set; }
Visual Basic
Public Property IsMouseOver As Boolean
    Get
    Set
Visual C++
public:
property bool IsMouseOver {
    bool get ();
    void set (bool value);
}

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsPressed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonBase..::..IsPressed Property
ButtonBase Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ButtonBase.IsPressed"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsPressed { get; set; }
Visual Basic
Public Property IsPressed As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsPressed {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IButtonBase..::..IsPressed

See Also

ButtonBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Calendar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Members
Calendar Class Constructors Methods Fields Properties See Also Send Feedback

The Calendar type exposes the following members.

Constructors

 | Name | Description
Public method | Calendar | Initializes a new instance of the Calendar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Navigate | Simulates calendar navigation.
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectDates | Selects dates in the calendar.
Public method | SelectMonth | Simulates user selecting the specified month.
Public method | SelectYear | Simulates user selecting the specified year.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
Public method | ZoomOut | Simulates the user zooming the calendar out via a header button click.

Fields

Name | Description
DisplayDateEndProperty |
DisplayDateProperty |
DisplayDateStartProperty |
DisplayModeProperty |
FirstDayOfWeekProperty |
IsTodayHighlightedProperty |
SelectedDateProperty |
SelectedDatesProperty |
SelectionModeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayDate |
Public property | DisplayDateEnd |
Public property | DisplayDateStart |
Public property | DisplayMode |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstDayOfWeek |
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HeaderButton | Get the calendar header button to zoom out. Override for custom control template.
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTodayHighlighted |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MonthViewElement | Get the calendar month view element holding the days to select. Override for custom control template.
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NextButton | Get the calendar navigation next button. Override for custom control template.
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PreviousButton | Get the calendar navigation previous button. Override for custom control template.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedDate |
Public property | SelectedDates |
Public property | SelectionMode |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | YearViewElement | Get the calendar year view element holding the months and years to select. Override for custom control template.

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Calendar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Constructor
Calendar Class See Also Send Feedback
Initializes a new instance of the Calendar class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Calendar()
Visual Basic
Public Sub New
Visual C++
public:
Calendar()

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Calendar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Fields
Calendar Class See Also Send Feedback

The Calendar type exposes the following members.

Fields

Name | Description
DisplayDateEndProperty |
DisplayDateProperty |
DisplayDateStartProperty |
DisplayModeProperty |
FirstDayOfWeekProperty |
IsTodayHighlightedProperty |
SelectedDateProperty |
SelectedDatesProperty |
SelectionModeProperty |

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateEndProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateEndProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.DisplayDateEndProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateEndProperty
Visual Basic
Public Shared DisplayDateEndProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateEndProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.DisplayDateProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateProperty
Visual Basic
Public Shared DisplayDateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateStartProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateStartProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.DisplayDateStartProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateStartProperty
Visual Basic
Public Shared DisplayDateStartProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateStartProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayModeProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.DisplayModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayModeProperty
Visual Basic
Public Shared DisplayModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayModeProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FirstDayOfWeekProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..FirstDayOfWeekProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.FirstDayOfWeekProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FirstDayOfWeekProperty
Visual Basic
Public Shared FirstDayOfWeekProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FirstDayOfWeekProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTodayHighlightedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..IsTodayHighlightedProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.IsTodayHighlightedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTodayHighlightedProperty
Visual Basic
Public Shared IsTodayHighlightedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTodayHighlightedProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedDateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectedDateProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.SelectedDateProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedDateProperty
Visual Basic
Public Shared SelectedDateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedDateProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedDatesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectedDatesProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.SelectedDatesProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedDatesProperty
Visual Basic
Public Shared SelectedDatesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedDatesProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectionModeProperty Field
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Calendar.SelectionModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionModeProperty
Visual Basic
Public Shared SelectionModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionModeProperty

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Calendar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Methods
Calendar Class See Also Send Feedback

The Calendar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Navigate | Simulates calendar navigation.
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectDates | Selects dates in the calendar.
Public method | SelectMonth | Simulates user selecting the specified month.
Public method | SelectYear | Simulates user selecting the specified year.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)
Public method | ZoomOut | Simulates the user zooming the calendar out via a header button click.

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..AnySibling Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..GetProperty Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..GetRealType Method
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Calendar.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Calendar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..GetRectangle Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..Highlight Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..InvokeMethod Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..IsHitTest Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Navigate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..Navigate Method
Calendar Class See Also Send Feedback
Simulates calendar navigation.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Navigate(
    CalendarNavigationDirection direction
)
Visual Basic
Public Sub Navigate ( _
    direction As CalendarNavigationDirection _
)
Visual C++
public:
virtual void Navigate(
    CalendarNavigationDirection direction
) sealed

Parameters

direction
Type: ArtOfTest.WebAii.Controls.Xaml..::..CalendarNavigationDirection
The calendar navigation direction.

Implements

ICalendar..::..Navigate(CalendarNavigationDirection)

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..NextSibling Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..Parent Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..PreviousSibling Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..ScrollToVisible Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectDates Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectDates Method
Calendar Class See Also Send Feedback
Selects dates in the calendar.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectDates(
    bool simulateRealUser,
    List<DateTime> dates,
    bool isInDatePicker
)
Visual Basic
Public Sub SelectDates ( _
    simulateRealUser As Boolean, _
    dates As List(Of DateTime), _
    isInDatePicker As Boolean _
)
Visual C++
public:
virtual void SelectDates(
    bool simulateRealUser,
    List<DateTime>^ dates,
    bool isInDatePicker
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user clicking on the day elements.
dates
Type: System.Collections.Generic..::..List <(Of <(<' DateTime >)>)>
The calendar dates to select.
isInDatePicker
Type: System..::..Boolean
Whether to update the parent date picker if any too.

Implements

ICalendar..::..SelectDates(Boolean, List<(Of <<'(DateTime>)>>), Boolean)

Remarks

In simulate real user and date picker mode a single date selection is possible only.

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectMonth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectMonth Method
Calendar Class See Also Send Feedback
Simulates user selecting the specified month.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectMonth(
    int month
)
Visual Basic
Public Sub SelectMonth ( _
    month As Integer _
)
Visual C++
public:
virtual void SelectMonth(
    int month
) sealed

Parameters

month
Type: System..::..Int32
The month to select.

Implements

ICalendar..::..SelectMonth(Int32)

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectYear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectYear Method
Calendar Class See Also Send Feedback
Simulates user selecting the specified year.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectYear(
    int year
)
Visual Basic
Public Sub SelectYear ( _
    year As Integer _
)
Visual C++
public:
virtual void SelectYear(
    int year
) sealed

Parameters

year
Type: System..::..Int32
The year to select.

Implements

ICalendar..::..SelectYear(Int32)

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SetProperty Method
Calendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Calendar Class
Calendar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ZoomOut Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..ZoomOut Method
Calendar Class See Also Send Feedback
Simulates the user zooming the calendar out via a header button click.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ZoomOut()
Visual Basic
Public Sub ZoomOut
Visual C++
public:
virtual void ZoomOut() sealed

Implements

ICalendar..::..ZoomOut()()()()

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Calendar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar Properties
Calendar Class See Also Send Feedback

The Calendar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayDate |
Public property | DisplayDateEnd |
Public property | DisplayDateStart |
Public property | DisplayMode |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstDayOfWeek |
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HeaderButton | Get the calendar header button to zoom out. Override for custom control template.
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTodayHighlighted |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | MonthViewElement | Get the calendar month view element holding the days to select. Override for custom control template.
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NextButton | Get the calendar navigation next button. Override for custom control template.
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PreviousButton | Get the calendar navigation previous button. Override for custom control template.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedDate |
Public property | SelectedDates |
Public property | SelectionMode |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | YearViewElement | Get the calendar year view element holding the months and years to select. Override for custom control template.

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDate Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.DisplayDate"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime DisplayDate { get; set; }
Visual Basic
Public Property DisplayDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime DisplayDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateEnd Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateEnd Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.DisplayDateEnd"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> DisplayDateEnd { get; set; }
Visual Basic
Public Property DisplayDateEnd As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DisplayDateEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateStart Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayDateStart Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.DisplayDateStart"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> DisplayDateStart { get; set; }
Visual Basic
Public Property DisplayDateStart As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DisplayDateStart {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..DisplayMode Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.DisplayMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarMode DisplayMode { get; set; }
Visual Basic
Public Property DisplayMode As CalendarMode
    Get
    Set
Visual C++
public:
property CalendarMode DisplayMode {
    CalendarMode get ();
    void set (CalendarMode value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FirstDayOfWeek Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..FirstDayOfWeek Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.FirstDayOfWeek"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DayOfWeek FirstDayOfWeek { get; set; }
Visual Basic
Public Property FirstDayOfWeek As DayOfWeek
    Get
    Set
Visual C++
public:
property DayOfWeek FirstDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeaderButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..HeaderButton Property
Calendar Class See Also Send Feedback
Get the calendar header button to zoom out. Override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement HeaderButton { get; }
Visual Basic
Public Overridable ReadOnly Property HeaderButton As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ HeaderButton {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..HeaderButton

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTodayHighlighted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..IsTodayHighlighted Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.IsTodayHighlighted"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTodayHighlighted { get; set; }
Visual Basic
Public Property IsTodayHighlighted As Boolean
    Get
    Set
Visual C++
public:
property bool IsTodayHighlighted {
    bool get ();
    void set (bool value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MonthViewElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..MonthViewElement Property
Calendar Class See Also Send Feedback
Get the calendar month view element holding the days to select. Override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement MonthViewElement { get; }
Visual Basic
Public Overridable ReadOnly Property MonthViewElement As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ MonthViewElement {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..MonthViewElement

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


NextButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..NextButton Property
Calendar Class See Also Send Feedback
Get the calendar navigation next button. Override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement NextButton { get; }
Visual Basic
Public Overridable ReadOnly Property NextButton As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ NextButton {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..NextButton

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..PreviousButton Property
Calendar Class See Also Send Feedback
Get the calendar navigation previous button. Override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement PreviousButton { get; }
Visual Basic
Public Overridable ReadOnly Property PreviousButton As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ PreviousButton {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..PreviousButton

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectedDate Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.SelectedDate"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> SelectedDate { get; set; }
Visual Basic
Public Property SelectedDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Implements

ICalendar..::..SelectedDate

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedDates Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectedDates Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.SelectedDates"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SelectedDatesCollection SelectedDates { get; }
Visual Basic
Public ReadOnly Property SelectedDates As SelectedDatesCollection
    Get
Visual C++
public:
virtual property SelectedDatesCollection^ SelectedDates {
    SelectedDatesCollection^ get () sealed;
}

Implements

ICalendar..::..SelectedDates

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..SelectionMode Property
Calendar Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Calendar.SelectionMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As CalendarSelectionMode
    Get
    Set
Visual C++
public:
property CalendarSelectionMode SelectionMode {
    CalendarSelectionMode get ();
    void set (CalendarSelectionMode value);
}

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


YearViewElement Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Calendar..::..YearViewElement Property
Calendar Class See Also Send Feedback
Get the calendar year view element holding the months and years to select. Override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement YearViewElement { get; }
Visual Basic
Public Overridable ReadOnly Property YearViewElement As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ YearViewElement {
    FrameworkElement^ get ();
}

Implements

ICalendar..::..YearViewElement

See Also

Calendar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Members
CalendarButton Class Constructors Methods Properties See Also Send Feedback

The CalendarButton type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarButton | Initializes a new instance of the CalendarButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Button..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Constructor
CalendarButton Class See Also Send Feedback
Initializes a new instance of the CalendarButton class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarButton()
Visual Basic
Public Sub New
Visual C++
public:
CalendarButton()

See Also

CalendarButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Methods
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Button..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..AnySibling Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..GetProperty Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..GetRealType Method
CalendarButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CalendarButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CalendarButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CalendarButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..GetRectangle Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..Highlight Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..InvokeMethod Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..IsHitTest Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..NextSibling Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..Parent Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..PreviousSibling Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..ScrollToVisible Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton..::..SetProperty Method
CalendarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarButton Class
CalendarButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarButton Properties
CalendarButton Class See Also Send Feedback

The CalendarButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarDayButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Members
CalendarDayButton Class Constructors Methods Properties See Also Send Feedback

The CalendarDayButton type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarDayButton | Initializes a new instance of the CalendarDayButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Button..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarDayButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Constructor
CalendarDayButton Class See Also Send Feedback
Initializes a new instance of the CalendarDayButton class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarDayButton()
Visual Basic
Public Sub New
Visual C++
public:
CalendarDayButton()

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarDayButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Methods
CalendarDayButton Class See Also Send Feedback

The CalendarDayButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Button..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..AnySibling Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..GetProperty Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..GetRealType Method
CalendarDayButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CalendarDayButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CalendarDayButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..GetRectangle Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..Highlight Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..InvokeMethod Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..IsHitTest Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..NextSibling Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..Parent Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..PreviousSibling Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..ScrollToVisible Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton..::..SetProperty Method
CalendarDayButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarDayButton Class
CalendarDayButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarDayButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarDayButton Properties
CalendarDayButton Class See Also Send Feedback

The CalendarDayButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarDayButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem Members
CalendarItem Class Constructors Methods Properties See Also Send Feedback

The CalendarItem type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarItem | Initializes a new instance of the CalendarItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem Constructor
CalendarItem Class See Also Send Feedback
Initializes a new instance of the CalendarItem class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CalendarItem()
Visual Basic
Public Sub New
Visual C++
public:
CalendarItem()

See Also

CalendarItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem Methods
CalendarItem Class See Also Send Feedback

The CalendarItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..AnySibling Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..GetProperty Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..GetRealType Method
CalendarItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CalendarItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CalendarItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CalendarItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..GetRectangle Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..Highlight Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..InvokeMethod Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..IsHitTest Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..NextSibling Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..Parent Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..PreviousSibling Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..ScrollToVisible Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem..::..SetProperty Method
CalendarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CalendarItem Class
CalendarItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


CalendarItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarItem Properties
CalendarItem Class See Also Send Feedback

The CalendarItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CalendarItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Canvas Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas Members
Canvas Class Constructors Methods Properties See Also Send Feedback

The Canvas type exposes the following members.

Constructors

 | Name | Description
Public method | Canvas | Initializes a new instance of the Canvas class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Canvas Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Canvas Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas Constructor
Canvas Class See Also Send Feedback
Initializes a new instance of the Canvas class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Canvas()
Visual Basic
Public Sub New
Visual C++
public:
Canvas()

See Also

Canvas Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Canvas Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas Methods
Canvas Class See Also Send Feedback

The Canvas type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Canvas Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..AnySibling Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..GetProperty Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..GetRealType Method
Canvas Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Canvas.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Canvas.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Canvas Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..GetRectangle Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..Highlight Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..InvokeMethod Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..IsHitTest Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..NextSibling Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..Parent Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..PreviousSibling Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..ScrollToVisible Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas..::..SetProperty Method
Canvas Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Canvas Class
Canvas Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Canvas Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Canvas Properties
Canvas Class See Also Send Feedback

The Canvas type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Canvas Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CheckBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox Members
CheckBox Class Constructors Methods Properties See Also Send Feedback

The CheckBox type exposes the following members.

Constructors

 | Name | Description
Public method | CheckBox | Initializes a new instance of the CheckBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check icon element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CheckBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CheckBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox Constructor
CheckBox Class See Also Send Feedback
Initializes a new instance of the CheckBox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CheckBox()
Visual Basic
Public Sub New
Visual C++
public:
CheckBox()

See Also

CheckBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CheckBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox Methods
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

CheckBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..AnySibling Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..GetProperty Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..GetRealType Method
CheckBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CheckBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CheckBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CheckBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..GetRectangle Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..Highlight Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..InvokeMethod Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..IsHitTest Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..NextSibling Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..Parent Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..PreviousSibling Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..ScrollToVisible Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox..::..SetProperty Method
CheckBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CheckBox Class
CheckBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


CheckBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CheckBox Properties
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check icon element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

CheckBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ChildWindow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow Members
ChildWindow Class Constructors Methods Fields Properties See Also Send Feedback

The ChildWindow type exposes the following members.

Constructors

 | Name | Description
Public method | ChildWindow | Initializes a new instance of the ChildWindow class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HasCloseButtonProperty |
OverlayBrushProperty |
OverlayOpacityProperty |
TitleProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HasCloseButton |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverlayBrush |
Public property | OverlayOpacity |
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ChildWindow Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow Constructor
ChildWindow Class See Also Send Feedback
Initializes a new instance of the ChildWindow class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ChildWindow()
Visual Basic
Public Sub New
Visual C++
public:
ChildWindow()

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ChildWindow Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow Fields
ChildWindow Class See Also Send Feedback

The ChildWindow type exposes the following members.

Fields

Name | Description
HasCloseButtonProperty |
OverlayBrushProperty |
OverlayOpacityProperty |
TitleProperty |

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HasCloseButtonProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..HasCloseButtonProperty Field
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.HasCloseButtonProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasCloseButtonProperty
Visual Basic
Public Shared HasCloseButtonProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasCloseButtonProperty

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OverlayBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..OverlayBrushProperty Field
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.OverlayBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OverlayBrushProperty
Visual Basic
Public Shared OverlayBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OverlayBrushProperty

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OverlayOpacityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..OverlayOpacityProperty Field
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.OverlayOpacityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OverlayOpacityProperty
Visual Basic
Public Shared OverlayOpacityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OverlayOpacityProperty

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TitleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..TitleProperty Field
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.TitleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TitleProperty
Visual Basic
Public Shared TitleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TitleProperty

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ChildWindow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow Methods
ChildWindow Class See Also Send Feedback

The ChildWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..AnySibling Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..GetProperty Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..GetRealType Method
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..GetRectangle Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..Highlight Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..InvokeMethod Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..IsHitTest Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..NextSibling Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..Parent Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..PreviousSibling Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..ScrollToVisible Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..SetProperty Method
ChildWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ChildWindow Class
ChildWindow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ChildWindow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow Properties
ChildWindow Class See Also Send Feedback

The ChildWindow type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HasCloseButton |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OverlayBrush |
Public property | OverlayOpacity |
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | Title |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HasCloseButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..HasCloseButton Property
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.HasCloseButton"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool HasCloseButton { get; set; }
Visual Basic
Public Property HasCloseButton As Boolean
    Get
    Set
Visual C++
public:
property bool HasCloseButton {
    bool get ();
    void set (bool value);
}

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OverlayBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..OverlayBrush Property
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.OverlayBrush"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush OverlayBrush { get; set; }
Visual Basic
Public Property OverlayBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ OverlayBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OverlayOpacity Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..OverlayOpacity Property
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.OverlayOpacity"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double OverlayOpacity { get; set; }
Visual Basic
Public Property OverlayOpacity As Double
    Get
    Set
Visual C++
public:
property double OverlayOpacity {
    double get ();
    void set (double value);
}

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Title Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChildWindow..::..Title Property
ChildWindow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ChildWindow.Title"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

See Also

ChildWindow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Color Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Members
Color Class Constructors Methods Fields Properties See Also Send Feedback

The Color type exposes the following members.

Constructors

 | Name | Description
Public method | Color | Initializes a new instance of the Color class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AProperty |
BProperty |
GProperty |
RProperty |

Properties

 | Name | Description
Public property | A |
Public property | B |
Public property | G |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | R |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Color Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Constructor
Color Class See Also Send Feedback
Initializes a new instance of the Color class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Color()
Visual Basic
Public Sub New
Visual C++
public:
Color()

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Color Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Fields
Color Class See Also Send Feedback

The Color type exposes the following members.

Fields

Name | Description
AProperty |
BProperty |
GProperty |
RProperty |

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..AProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Color.AProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AProperty
Visual Basic
Public Shared AProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AProperty

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..BProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Color.BProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BProperty
Visual Basic
Public Shared BProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BProperty

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..GProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Color.GProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GProperty
Visual Basic
Public Shared GProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GProperty

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..RProperty Field
Color Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Color.RProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RProperty
Visual Basic
Public Shared RProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RProperty

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Color Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Methods
Color Class See Also Send Feedback

The Color type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..GetProperty Method
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Color Class
Color Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..GetRealType Method
Color Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Color.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Color.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..InvokeMethod Method
Color Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Color Class
Color Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Color Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color Properties
Color Class See Also Send Feedback

The Color type exposes the following members.

Properties

 | Name | Description
Public property | A |
Public property | B |
Public property | G |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | R |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


A Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..A Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Color.A"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual byte A { get; set; }
Visual Basic
Public Overridable Property A As Byte
    Get
    Set
Visual C++
public:
virtual property unsigned char A {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


B Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..B Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Color.B"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual byte B { get; set; }
Visual Basic
Public Overridable Property B As Byte
    Get
    Set
Visual C++
public:
virtual property unsigned char B {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


G Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..G Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Color.G"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual byte G { get; set; }
Visual Basic
Public Overridable Property G As Byte
    Get
    Set
Visual C++
public:
virtual property unsigned char G {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


R Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Color..::..R Property
Color Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Color.R"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual byte R { get; set; }
Visual Basic
Public Overridable Property R As Byte
    Get
    Set
Visual C++
public:
virtual property unsigned char R {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

Color Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Members
ComboBox Class Constructors Methods Fields Properties See Also Send Feedback

The ComboBox type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBox | Initializes a new instance of the ComboBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | OpenDropDown | Open the combobox drop down popup.
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsDropDownOpenProperty |
MaxDropDownHeightProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Items | Retrieves the list of items for this ComboBoxItem's for this ComboBox.
Public property | ItemsPopup | Get the popup containing the list with combo box items. Override for custom control template.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Constructor
ComboBox Class See Also Send Feedback
Initializes a new instance of the ComboBox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ComboBox()
Visual Basic
Public Sub New
Visual C++
public:
ComboBox()

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Fields
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Fields

Name | Description
IsDropDownOpenProperty |
MaxDropDownHeightProperty |

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDropDownOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsDropDownOpenProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ComboBox.IsDropDownOpenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDropDownOpenProperty
Visual Basic
Public Shared IsDropDownOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDropDownOpenProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaxDropDownHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..MaxDropDownHeightProperty Field
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ComboBox.MaxDropDownHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxDropDownHeightProperty
Visual Basic
Public Shared MaxDropDownHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxDropDownHeightProperty

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Methods
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | OpenDropDown | Open the combobox drop down popup.
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..AnySibling Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..AssignReference Method
ComboBox Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..GetProperty Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..GetRealType Method
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ComboBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ComboBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..GetRectangle Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..Highlight Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..InvokeMethod Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsHitTest Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..NextSibling Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


OpenDropDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..OpenDropDown Method
ComboBox Class See Also Send Feedback
Open the combobox drop down popup.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void OpenDropDown(
    bool simulateRealUser
)
Visual Basic
Public Sub OpenDropDown ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void OpenDropDown(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user click action or just change the drop down state via automation property.

Implements

IComboBox..::..OpenDropDown(Boolean)

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..Parent Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..PreviousSibling Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..ScrollToVisible Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectItemByIndex Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByIndex Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectItemByIndex(Boolean, Int32) | Select a combobox item by given index.
Public method | SelectItemByIndex(Boolean, Int32, Boolean) | Select a combobox item by given index.

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectItemByIndex Method (Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByIndex Method (Boolean, Int32)
ComboBox Class See Also Send Feedback
Select a combobox item by given index.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectItemByIndex(
    bool simulateRealUser,
    int index
)
Visual Basic
Public Sub SelectItemByIndex ( _
    simulateRealUser As Boolean, _
    index As Integer _
)
Visual C++
public:
virtual void SelectItemByIndex(
    bool simulateRealUser,
    int index
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected index.
index
Type: System..::..Int32
The index of the item to select.

Implements

IComboBox..::..SelectItemByIndex(Boolean, Int32)

See Also

ComboBox Class
SelectItemByIndex Overload
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectItemByIndex Method (Boolean, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByIndex Method (Boolean, Int32, Boolean)
ComboBox Class See Also Send Feedback
Select a combobox item by given index.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectItemByIndex(
    bool simulateRealUser,
    int index,
    bool openDropDownBeforeSelection
)
Visual Basic
Public Sub SelectItemByIndex ( _
    simulateRealUser As Boolean, _
    index As Integer, _
    openDropDownBeforeSelection As Boolean _
)
Visual C++
public:
virtual void SelectItemByIndex(
    bool simulateRealUser,
    int index,
    bool openDropDownBeforeSelection
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected index.
index
Type: System..::..Int32
The index of the item to select.
openDropDownBeforeSelection
Type: System..::..Boolean
Whether to automatically open the dropdown.

Implements

IComboBox..::..SelectItemByIndex(Boolean, Int32, Boolean)

See Also

ComboBox Class
SelectItemByIndex Overload
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectItemByText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByText Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectItemByText(Boolean, String) | Select a combo box item by given text.
Public method | SelectItemByText(Boolean, String, Boolean) | Select a combo box item by given text.

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectItemByText Method (Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByText Method (Boolean, String)
ComboBox Class See Also Send Feedback
Select a combo box item by given text.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectItemByText(
    bool simulateRealUser,
    string text
)
Visual Basic
Public Sub SelectItemByText ( _
    simulateRealUser As Boolean, _
    text As String _
)
Visual C++
public:
virtual void SelectItemByText(
    bool simulateRealUser,
    String^ text
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected state of the item.
text
Type: System..::..String
The text of the item to select.

Implements

IComboBox..::..SelectItemByText(Boolean, String)

See Also

ComboBox Class
SelectItemByText Overload
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectItemByText Method (Boolean, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SelectItemByText Method (Boolean, String, Boolean)
ComboBox Class See Also Send Feedback
Select a combo box item by given text.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectItemByText(
    bool simulateRealUser,
    string text,
    bool openDropDownBeforeSelection
)
Visual Basic
Public Sub SelectItemByText ( _
    simulateRealUser As Boolean, _
    text As String, _
    openDropDownBeforeSelection As Boolean _
)
Visual C++
public:
virtual void SelectItemByText(
    bool simulateRealUser,
    String^ text,
    bool openDropDownBeforeSelection
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate selection by real user click or just change the selected state of the item.
text
Type: System..::..String
The text of the item to select.
openDropDownBeforeSelection
Type: System..::..Boolean
Whether to automatically open the dropdown.

Implements

IComboBox..::..SelectItemByText(Boolean, String, Boolean)

See Also

ComboBox Class
SelectItemByText Overload
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..SetProperty Method
ComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBox Class
ComboBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox Properties
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Items | Retrieves the list of items for this ComboBoxItem's for this ComboBox.
Public property | ItemsPopup | Get the popup containing the list with combo box items. Override for custom control template.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxDropDownHeight |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDropDownOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..IsDropDownOpen Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ComboBox.IsDropDownOpen"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic
Public Property IsDropDownOpen As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsDropDownOpen {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IComboBox..::..IsDropDownOpen

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Items Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..Items Property
ComboBox Class See Also Send Feedback
Retrieves the list of items for this ComboBoxItem's for this ComboBox.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<ComboBoxItem> Items { get; }
Visual Basic
Public ReadOnly Property Items As IList(Of ComboBoxItem)
    Get
Visual C++
public:
property IList<ComboBoxItem^>^ Items {
    IList<ComboBoxItem^>^ get ();
}

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsPopup Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..ItemsPopup Property
ComboBox Class See Also Send Feedback
Get the popup containing the list with combo box items. Override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ItemsPopup { get; }
Visual Basic
Public Overridable ReadOnly Property ItemsPopup As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ItemsPopup {
    FrameworkElement^ get ();
}

Implements

IComboBox..::..ItemsPopup

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaxDropDownHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBox..::..MaxDropDownHeight Property
ComboBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ComboBox.MaxDropDownHeight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxDropDownHeight { get; set; }
Visual Basic
Public Property MaxDropDownHeight As Double
    Get
    Set
Visual C++
public:
property double MaxDropDownHeight {
    double get ();
    void set (double value);
}

See Also

ComboBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBoxItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Members
ComboBoxItem Class Constructors Methods Properties See Also Send Feedback

The ComboBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxItem | Initializes a new instance of the ComboBoxItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ListBoxItem..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected | (Inherited from ListBoxItem.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | ItemText | Get the item text.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParentComboBox | Get the parent ComboBox element.
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBoxItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Constructor
ComboBoxItem Class See Also Send Feedback
Initializes a new instance of the ComboBoxItem class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ComboBoxItem()
Visual Basic
Public Sub New
Visual C++
public:
ComboBoxItem()

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBoxItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Methods
ComboBoxItem Class See Also Send Feedback

The ComboBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ListBoxItem..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..AnySibling Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..GetProperty Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..GetRealType Method
ComboBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ComboBoxItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ComboBoxItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..GetRectangle Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..Highlight Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..InvokeMethod Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..IsHitTest Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..NextSibling Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..Parent Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..PreviousSibling Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..ScrollToVisible Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..SetProperty Method
ComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ComboBoxItem Class
ComboBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ComboBoxItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem Properties
ComboBoxItem Class See Also Send Feedback

The ComboBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected | (Inherited from ListBoxItem.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | ItemText | Get the item text.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParentComboBox | Get the parent ComboBox element.
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..ItemText Property
ComboBoxItem Class See Also Send Feedback
Get the item text.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string ItemText { get; }
Visual Basic
Public ReadOnly Property ItemText As String
    Get
Visual C++
public:
virtual property String^ ItemText {
    String^ get () sealed;
}

Implements

IComboBoxItem..::..ItemText

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ParentComboBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxItem..::..ParentComboBox Property
ComboBoxItem Class See Also Send Feedback
Get the parent ComboBox element.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IComboBox ParentComboBox { get; }
Visual Basic
Public ReadOnly Property ParentComboBox As IComboBox
    Get
Visual C++
public:
virtual property IComboBox^ ParentComboBox {
    IComboBox^ get () sealed;
}

Implements

IComboBoxItem..::..ParentComboBox

See Also

ComboBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CompositeTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform Members
CompositeTransform Class Constructors Methods Fields Properties See Also Send Feedback

The CompositeTransform type exposes the following members.

Constructors

 | Name | Description
Public method | CompositeTransform | Initializes a new instance of the CompositeTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterXProperty |
CenterYProperty |
RotationProperty |
ScaleXProperty |
ScaleYProperty |
SkewXProperty |
SkewYProperty |
TranslateXProperty |
TranslateYProperty |

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rotation |
Public property | ScaleX |
Public property | ScaleY |
Public property | SkewX |
Public property | SkewY |
Public property | TranslateX |
Public property | TranslateY |

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CompositeTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform Constructor
CompositeTransform Class See Also Send Feedback
Initializes a new instance of the CompositeTransform class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CompositeTransform()
Visual Basic
Public Sub New
Visual C++
public:
CompositeTransform()

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CompositeTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform Fields
CompositeTransform Class See Also Send Feedback

The CompositeTransform type exposes the following members.

Fields

Name | Description
CenterXProperty |
CenterYProperty |
RotationProperty |
ScaleXProperty |
ScaleYProperty |
SkewXProperty |
SkewYProperty |
TranslateXProperty |
TranslateYProperty |

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..CenterXProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..CenterYProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RotationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..RotationProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.RotationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RotationProperty
Visual Basic
Public Shared RotationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RotationProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..ScaleXProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.ScaleXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleXProperty
Visual Basic
Public Shared ScaleXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleXProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..ScaleYProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.ScaleYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleYProperty
Visual Basic
Public Shared ScaleYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleYProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..SkewXProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.SkewXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SkewXProperty
Visual Basic
Public Shared SkewXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SkewXProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..SkewYProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.SkewYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SkewYProperty
Visual Basic
Public Shared SkewYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SkewYProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..TranslateXProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.TranslateXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TranslateXProperty
Visual Basic
Public Shared TranslateXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TranslateXProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..TranslateYProperty Field
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.TranslateYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TranslateYProperty
Visual Basic
Public Shared TranslateYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TranslateYProperty

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CompositeTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform Methods
CompositeTransform Class See Also Send Feedback

The CompositeTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..GetProperty Method
CompositeTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CompositeTransform Class
CompositeTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..GetRealType Method
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..InvokeMethod Method
CompositeTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CompositeTransform Class
CompositeTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


CompositeTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform Properties
CompositeTransform Class See Also Send Feedback

The CompositeTransform type exposes the following members.

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Rotation |
Public property | ScaleX |
Public property | ScaleY |
Public property | SkewX |
Public property | SkewY |
Public property | TranslateX |
Public property | TranslateY |

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..CenterX Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.CenterX"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterX { get; set; }
Visual Basic
Public Property CenterX As Double
    Get
    Set
Visual C++
public:
property double CenterX {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..CenterY Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.CenterY"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double CenterY { get; set; }
Visual Basic
Public Property CenterY As Double
    Get
    Set
Visual C++
public:
property double CenterY {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rotation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..Rotation Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.Rotation"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Rotation { get; set; }
Visual Basic
Public Property Rotation As Double
    Get
    Set
Visual C++
public:
property double Rotation {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..ScaleX Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.ScaleX"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScaleX { get; set; }
Visual Basic
Public Property ScaleX As Double
    Get
    Set
Visual C++
public:
property double ScaleX {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..ScaleY Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.ScaleY"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ScaleY { get; set; }
Visual Basic
Public Property ScaleY As Double
    Get
    Set
Visual C++
public:
property double ScaleY {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..SkewX Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.SkewX"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double SkewX { get; set; }
Visual Basic
Public Property SkewX As Double
    Get
    Set
Visual C++
public:
property double SkewX {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..SkewY Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.SkewY"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double SkewY { get; set; }
Visual Basic
Public Property SkewY As Double
    Get
    Set
Visual C++
public:
property double SkewY {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..TranslateX Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.TranslateX"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double TranslateX { get; set; }
Visual Basic
Public Property TranslateX As Double
    Get
    Set
Visual C++
public:
property double TranslateX {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CompositeTransform..::..TranslateY Property
CompositeTransform Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CompositeTransform.TranslateY"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double TranslateY { get; set; }
Visual Basic
Public Property TranslateY As Double
    Get
    Set
Visual C++
public:
property double TranslateY {
    double get ();
    void set (double value);
}

See Also

CompositeTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Members
ContentControl Class Constructors Methods Fields Properties See Also Send Feedback

The ContentControl type exposes the following members.

Constructors

 | Name | Description
Public method | ContentControl | Initializes a new instance of the ContentControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ContentProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContentControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Constructor
ContentControl Class See Also Send Feedback
Initializes a new instance of the ContentControl class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContentControl()
Visual Basic
Public Sub New
Visual C++
public:
ContentControl()

See Also

ContentControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Fields
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Fields

Name | Description
ContentProperty |

See Also

ContentControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..ContentProperty Field
ContentControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ContentControl.ContentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentProperty
Visual Basic
Public Shared ContentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentProperty

See Also

ContentControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Methods
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..AnySibling Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..GetProperty Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..GetRealType Method
ContentControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ContentControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ContentControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ContentControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..GetRectangle Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..Highlight Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..InvokeMethod Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..IsHitTest Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..NextSibling Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..Parent Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..PreviousSibling Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..ScrollToVisible Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..SetProperty Method
ContentControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentControl Class
ContentControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl Properties
ContentControl Class See Also Send Feedback

The ContentControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContentControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Content Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentControl..::..Content Property
ContentControl Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ContentControl.Content"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object Content { get; set; }
Visual Basic
Public Property Content As Object
    Get
    Set
Visual C++
public:
property Object^ Content {
    Object^ get ();
    void set (Object^ value);
}

See Also

ContentControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Members
ContentPresenter Class Constructors Methods Fields Properties See Also Send Feedback

The ContentPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | ContentPresenter | Initializes a new instance of the ContentPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ContentProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Constructor
ContentPresenter Class See Also Send Feedback
Initializes a new instance of the ContentPresenter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ContentPresenter()
Visual Basic
Public Sub New
Visual C++
public:
ContentPresenter()

See Also

ContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentPresenter Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Fields
ContentPresenter Class See Also Send Feedback

The ContentPresenter type exposes the following members.

Fields

Name | Description
ContentProperty |

See Also

ContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..ContentProperty Field
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ContentPresenter.ContentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentProperty
Visual Basic
Public Shared ContentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentProperty

See Also

ContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Methods
ContentPresenter Class See Also Send Feedback

The ContentPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..AnySibling Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..GetProperty Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..GetRealType Method
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ContentPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ContentPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..GetRectangle Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..Highlight Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..InvokeMethod Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..IsHitTest Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..NextSibling Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..Parent Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..PreviousSibling Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..ScrollToVisible Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..SetProperty Method
ContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ContentPresenter Class
ContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter Properties
ContentPresenter Class See Also Send Feedback

The ContentPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Content Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ContentPresenter..::..Content Property
ContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.ContentPresenter.Content"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object Content { get; set; }
Visual Basic
Public Property Content As Object
    Get
    Set
Visual C++
public:
property Object^ Content {
    Object^ get ();
    void set (Object^ value);
}

See Also

ContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Control Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Members
Control Class Constructors Methods Fields Properties See Also Send Feedback

The Control type exposes the following members.

Constructors

 | Name | Description
Public method | Control | Initializes a new instance of the Control class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
HorizontalContentAlignmentProperty |
IsEnabledProperty |
IsTabStopProperty |
PaddingProperty |
TabIndexProperty |
TabNavigationProperty |
VerticalContentAlignmentProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex |
Public property | TabNavigation |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Control Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Constructor
Control Class See Also Send Feedback
Initializes a new instance of the Control class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Control()
Visual Basic
Public Sub New
Visual C++
public:
Control()

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Control Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Fields
Control Class See Also Send Feedback

The Control type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
HorizontalContentAlignmentProperty |
IsEnabledProperty |
IsTabStopProperty |
PaddingProperty |
TabIndexProperty |
TabNavigationProperty |
VerticalContentAlignmentProperty |

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BackgroundProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BorderBrushProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.BorderBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderBrushProperty
Visual Basic
Public Shared BorderBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderBrushProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BorderThicknessProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.BorderThicknessProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderThicknessProperty
Visual Basic
Public Shared BorderThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderThicknessProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontFamilyProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontSizeProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontStretchProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.FontStretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStretchProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontStyleProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.FontStyleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStyleProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontWeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontWeightProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.FontWeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontWeightProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..ForegroundProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalContentAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..HorizontalContentAlignmentProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.HorizontalContentAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalContentAlignmentProperty
Visual Basic
Public Shared HorizontalContentAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalContentAlignmentProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsEnabledProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.IsEnabledProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEnabledProperty
Visual Basic
Public Shared IsEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEnabledProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTabStopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsTabStopProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.IsTabStopProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTabStopProperty
Visual Basic
Public Shared IsTabStopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTabStopProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..PaddingProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.PaddingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PaddingProperty
Visual Basic
Public Shared PaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PaddingProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..TabIndexProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.TabIndexProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabIndexProperty
Visual Basic
Public Shared TabIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabIndexProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabNavigationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..TabNavigationProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.TabNavigationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabNavigationProperty
Visual Basic
Public Shared TabNavigationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabNavigationProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalContentAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..VerticalContentAlignmentProperty Field
Control Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Control.VerticalContentAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalContentAlignmentProperty
Visual Basic
Public Shared VerticalContentAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalContentAlignmentProperty

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Control Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Methods
Control Class See Also Send Feedback

The Control type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..AnySibling Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..GetProperty Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..GetRealType Method
Control Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Control.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Control.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..GetRectangle Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Highlight Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..InvokeMethod Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsHitTest Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..NextSibling Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Parent Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..PreviousSibling Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..ScrollToVisible Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..SetProperty Method
Control Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Control Class
Control Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Control Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control Properties
Control Class See Also Send Feedback

The Control type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex |
Public property | TabNavigation |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Background Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.Background"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BorderBrush Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.BorderBrush"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush BorderBrush { get; set; }
Visual Basic
Public Property BorderBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BorderBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderThickness Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..BorderThickness Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.BorderThickness"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness BorderThickness { get; set; }
Visual Basic
Public Property BorderThickness As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ BorderThickness {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontFamily Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.FontFamily"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontSize Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.FontSize"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic
Public Property FontSize As Double
    Get
    Set
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontStretch Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.FontStretch"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic
Public ReadOnly Property FontStretch As FontStretch
    Get
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontStyle Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.FontStyle"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyle FontStyle { get; }
Visual Basic
Public ReadOnly Property FontStyle As FontStyle
    Get
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontWeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..FontWeight Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.FontWeight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic
Public ReadOnly Property FontWeight As FontWeight
    Get
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Foreground Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.Foreground"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic
Public Property Foreground As Brush
    Get
    Set
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalContentAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..HorizontalContentAlignment Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.HorizontalContentAlignment"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HorizontalAlignment HorizontalContentAlignment { get; set; }
Visual Basic
Public Property HorizontalContentAlignment As HorizontalAlignment
    Get
    Set
Visual C++
public:
property HorizontalAlignment HorizontalContentAlignment {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsEnabled Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.IsEnabled"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic
Public Property IsEnabled As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsEnabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IControl..::..IsEnabled

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTabStop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..IsTabStop Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.IsTabStop"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTabStop { get; set; }
Visual Basic
Public Property IsTabStop As Boolean
    Get
    Set
Visual C++
public:
property bool IsTabStop {
    bool get ();
    void set (bool value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Padding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..Padding Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.Padding"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness Padding { get; set; }
Visual Basic
Public Property Padding As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ Padding {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..TabIndex Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.TabIndex"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TabIndex { get; set; }
Visual Basic
Public Property TabIndex As Integer
    Get
    Set
Visual C++
public:
property int TabIndex {
    int get ();
    void set (int value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabNavigation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..TabNavigation Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.TabNavigation"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public KeyboardNavigationMode TabNavigation { get; set; }
Visual Basic
Public Property TabNavigation As KeyboardNavigationMode
    Get
    Set
Visual C++
public:
property KeyboardNavigationMode TabNavigation {
    KeyboardNavigationMode get ();
    void set (KeyboardNavigationMode value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalContentAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Control..::..VerticalContentAlignment Property
Control Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Control.VerticalContentAlignment"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VerticalAlignment VerticalContentAlignment { get; set; }
Visual Basic
Public Property VerticalContentAlignment As VerticalAlignment
    Get
    Set
Visual C++
public:
property VerticalAlignment VerticalContentAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}

See Also

Control Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CornerRadius Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Members
CornerRadius Class Constructors Methods Fields Properties See Also Send Feedback

The CornerRadius type exposes the following members.

Constructors

 | Name | Description
Public method | CornerRadius | Initializes a new instance of the CornerRadius class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BottomLeftProperty |
BottomRightProperty |
TopLeftProperty |
TopRightProperty |

Properties

 | Name | Description
Public property | BottomLeft |
Public property | BottomRight |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | TopLeft |
Public property | TopRight |

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CornerRadius Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Constructor
CornerRadius Class See Also Send Feedback
Initializes a new instance of the CornerRadius class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public CornerRadius()
Visual Basic
Public Sub New
Visual C++
public:
CornerRadius()

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CornerRadius Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Fields
CornerRadius Class See Also Send Feedback

The CornerRadius type exposes the following members.

Fields

Name | Description
BottomLeftProperty |
BottomRightProperty |
TopLeftProperty |
TopRightProperty |

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BottomLeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..BottomLeftProperty Field
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.BottomLeftProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomLeftProperty
Visual Basic
Public Shared BottomLeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomLeftProperty

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BottomRightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..BottomRightProperty Field
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.BottomRightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomRightProperty
Visual Basic
Public Shared BottomRightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomRightProperty

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TopLeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..TopLeftProperty Field
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.TopLeftProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopLeftProperty
Visual Basic
Public Shared TopLeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopLeftProperty

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TopRightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..TopRightProperty Field
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.TopRightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopRightProperty
Visual Basic
Public Shared TopRightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopRightProperty

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CornerRadius Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Methods
CornerRadius Class See Also Send Feedback

The CornerRadius type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..GetProperty Method
CornerRadius Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CornerRadius Class
CornerRadius Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..GetRealType Method
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..InvokeMethod Method
CornerRadius Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

CornerRadius Class
CornerRadius Members
ArtOfTest.WebAii.Silverlight.UI Namespace


CornerRadius Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius Properties
CornerRadius Class See Also Send Feedback

The CornerRadius type exposes the following members.

Properties

 | Name | Description
Public property | BottomLeft |
Public property | BottomRight |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | TopLeft |
Public property | TopRight |

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BottomLeft Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..BottomLeft Property
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.BottomLeft"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double BottomLeft { get; set; }
Visual Basic
Public Overridable Property BottomLeft As Double
    Get
    Set
Visual C++
public:
virtual property double BottomLeft {
    double get ();
    void set (double value);
}

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BottomRight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..BottomRight Property
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.BottomRight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double BottomRight { get; set; }
Visual Basic
Public Overridable Property BottomRight As Double
    Get
    Set
Visual C++
public:
virtual property double BottomRight {
    double get ();
    void set (double value);
}

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TopLeft Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..TopLeft Property
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.TopLeft"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TopLeft { get; set; }
Visual Basic
Public Overridable Property TopLeft As Double
    Get
    Set
Visual C++
public:
virtual property double TopLeft {
    double get ();
    void set (double value);
}

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TopRight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CornerRadius..::..TopRight Property
CornerRadius Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.CornerRadius.TopRight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double TopRight { get; set; }
Visual Basic
Public Overridable Property TopRight As Double
    Get
    Set
Visual C++
public:
virtual property double TopRight {
    double get ();
    void set (double value);
}

See Also

CornerRadius Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Members
DataGrid Class Constructors Methods Fields Properties See Also Send Feedback

The DataGrid type exposes the following members.

Constructors

 | Name | Description
Public method | DataGrid | Initializes a new instance of the DataGrid class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AlternatingRowBackgroundProperty |
AreRowDetailsFrozenProperty |
AreRowGroupHeadersFrozenProperty |
AutoGenerateColumnsProperty |
CanUserReorderColumnsProperty |
CanUserResizeColumnsProperty |
CanUserSortColumnsProperty |
ClipboardCopyModeProperty |
ColumnHeaderHeightProperty |
ColumnWidthProperty |
CurrentColumnProperty | Defines how to get the value of the CurrentColumn property.
FrozenColumnCountProperty |
GridLinesVisibilityProperty |
HeadersVisibilityProperty |
HorizontalGridLinesBrushProperty |
HorizontalScrollBarVisibilityProperty |
IsReadOnlyProperty |
IsValidProperty |
MaxColumnWidthProperty |
MinColumnWidthProperty |
RowBackgroundProperty |
RowDetailsVisibilityModeProperty |
RowHeaderWidthProperty |
RowHeightProperty |
SelectedIndexProperty |
SelectionModeProperty |
VerticalGridLinesBrushProperty |
VerticalScrollBarVisibilityProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AlternatingRowBackground |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AreRowDetailsFrozen |
Public property | AreRowGroupHeadersFrozen |
Public property | AutoGenerateColumns |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanUserReorderColumns |
Public property | CanUserResizeColumns |
Public property | CanUserSortColumns |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipboardCopyMode |
Public property | ColumnHeaderContainer | Gets the column header container. Please override for custom control template.
Public property | ColumnHeaderElements | Get the list of column headers of this Grid.
Public property | ColumnHeaderHeight |
Public property | ColumnWidth |
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | CurrentColumn | Gets / Sets the CurrentColumn for this Silverlight DataGrid.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | FrozenColumnCount |
Public property | GridData | Gets the full textual content of a grid. The dictionary key represents the row of the grid.
Public property | GridLinesVisibility |
Public property | HeadersVisibility |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalGridLinesBrush |
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsReadOnly |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxColumnWidth |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinColumnWidth |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RowBackground |
Public property | RowContainer | Gets the row container. Please override for custom control template.
Public property | RowDetailsVisibilityMode |
Public property | RowElements | Get the list of rows contained in this Grid.
Public property | RowHeaderWidth |
Public property | RowHeight |
Public property | SelectedIndex |
Public property | SelectionMode |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalGridLinesBrush |
Public property | VerticalScrollBarVisibility |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGrid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Constructor
DataGrid Class See Also Send Feedback
Initializes a new instance of the DataGrid class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGrid()
Visual Basic
Public Sub New
Visual C++
public:
DataGrid()

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGrid Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Fields
DataGrid Class See Also Send Feedback

The DataGrid type exposes the following members.

Fields

Name | Description
AlternatingRowBackgroundProperty |
AreRowDetailsFrozenProperty |
AreRowGroupHeadersFrozenProperty |
AutoGenerateColumnsProperty |
CanUserReorderColumnsProperty |
CanUserResizeColumnsProperty |
CanUserSortColumnsProperty |
ClipboardCopyModeProperty |
ColumnHeaderHeightProperty |
ColumnWidthProperty |
CurrentColumnProperty | Defines how to get the value of the CurrentColumn property.
FrozenColumnCountProperty |
GridLinesVisibilityProperty |
HeadersVisibilityProperty |
HorizontalGridLinesBrushProperty |
HorizontalScrollBarVisibilityProperty |
IsReadOnlyProperty |
IsValidProperty |
MaxColumnWidthProperty |
MinColumnWidthProperty |
RowBackgroundProperty |
RowDetailsVisibilityModeProperty |
RowHeaderWidthProperty |
RowHeightProperty |
SelectedIndexProperty |
SelectionModeProperty |
VerticalGridLinesBrushProperty |
VerticalScrollBarVisibilityProperty |

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AlternatingRowBackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AlternatingRowBackgroundProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AlternatingRowBackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlternatingRowBackgroundProperty
Visual Basic
Public Shared AlternatingRowBackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlternatingRowBackgroundProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AreRowDetailsFrozenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AreRowDetailsFrozenProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AreRowDetailsFrozenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AreRowDetailsFrozenProperty
Visual Basic
Public Shared AreRowDetailsFrozenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AreRowDetailsFrozenProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AreRowGroupHeadersFrozenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AreRowGroupHeadersFrozenProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AreRowGroupHeadersFrozenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AreRowGroupHeadersFrozenProperty
Visual Basic
Public Shared AreRowGroupHeadersFrozenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AreRowGroupHeadersFrozenProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoGenerateColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AutoGenerateColumnsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AutoGenerateColumnsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoGenerateColumnsProperty
Visual Basic
Public Shared AutoGenerateColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoGenerateColumnsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanUserReorderColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserReorderColumnsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.CanUserReorderColumnsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserReorderColumnsProperty
Visual Basic
Public Shared CanUserReorderColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserReorderColumnsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanUserResizeColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserResizeColumnsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.CanUserResizeColumnsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserResizeColumnsProperty
Visual Basic
Public Shared CanUserResizeColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserResizeColumnsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanUserSortColumnsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserSortColumnsProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.CanUserSortColumnsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanUserSortColumnsProperty
Visual Basic
Public Shared CanUserSortColumnsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanUserSortColumnsProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ClipboardCopyModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ClipboardCopyModeProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.ClipboardCopyModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ClipboardCopyModeProperty
Visual Basic
Public Shared ClipboardCopyModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ClipboardCopyModeProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColumnHeaderHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnHeaderHeightProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.ColumnHeaderHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnHeaderHeightProperty
Visual Basic
Public Shared ColumnHeaderHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnHeaderHeightProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColumnWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.ColumnWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColumnWidthProperty
Visual Basic
Public Shared ColumnWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColumnWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CurrentColumnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CurrentColumnProperty Field
DataGrid Class See Also Send Feedback
Defines how to get the value of the CurrentColumn property.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CurrentColumnProperty
Visual Basic
Public Shared CurrentColumnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CurrentColumnProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FrozenColumnCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..FrozenColumnCountProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.FrozenColumnCountProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FrozenColumnCountProperty
Visual Basic
Public Shared FrozenColumnCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FrozenColumnCountProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GridLinesVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GridLinesVisibilityProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.GridLinesVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GridLinesVisibilityProperty
Visual Basic
Public Shared GridLinesVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GridLinesVisibilityProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeadersVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HeadersVisibilityProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.HeadersVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeadersVisibilityProperty
Visual Basic
Public Shared HeadersVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeadersVisibilityProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalGridLinesBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HorizontalGridLinesBrushProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.HorizontalGridLinesBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalGridLinesBrushProperty
Visual Basic
Public Shared HorizontalGridLinesBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalGridLinesBrushProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HorizontalScrollBarVisibilityProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.HorizontalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalScrollBarVisibilityProperty
Visual Basic
Public Shared HorizontalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalScrollBarVisibilityProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..IsReadOnlyProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValidProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..IsValidProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.IsValidProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsValidProperty
Visual Basic
Public Shared IsValidProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsValidProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaxColumnWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MaxColumnWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.MaxColumnWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxColumnWidthProperty
Visual Basic
Public Shared MaxColumnWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxColumnWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MinColumnWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MinColumnWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.MinColumnWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinColumnWidthProperty
Visual Basic
Public Shared MinColumnWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinColumnWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowBackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowBackgroundProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.RowBackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowBackgroundProperty
Visual Basic
Public Shared RowBackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowBackgroundProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowDetailsVisibilityModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowDetailsVisibilityModeProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.RowDetailsVisibilityModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowDetailsVisibilityModeProperty
Visual Basic
Public Shared RowDetailsVisibilityModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowDetailsVisibilityModeProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowHeaderWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeaderWidthProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.RowHeaderWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowHeaderWidthProperty
Visual Basic
Public Shared RowHeaderWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowHeaderWidthProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeightProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.RowHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RowHeightProperty
Visual Basic
Public Shared RowHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RowHeightProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SelectedIndexProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.SelectedIndexProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedIndexProperty
Visual Basic
Public Shared SelectedIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedIndexProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SelectionModeProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.SelectionModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionModeProperty
Visual Basic
Public Shared SelectionModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionModeProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalGridLinesBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..VerticalGridLinesBrushProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.VerticalGridLinesBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalGridLinesBrushProperty
Visual Basic
Public Shared VerticalGridLinesBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalGridLinesBrushProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..VerticalScrollBarVisibilityProperty Field
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGrid.VerticalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalScrollBarVisibilityProperty
Visual Basic
Public Shared VerticalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalScrollBarVisibilityProperty

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Methods
DataGrid Class See Also Send Feedback

The DataGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AnySibling Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AssignReference Method
DataGrid Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference

[Missing <param name="reference"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GetProperty Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GetRealType Method
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGrid.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGrid.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GetRectangle Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..Highlight Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..InvokeMethod Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..IsHitTest Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..NextSibling Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..Parent Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..PreviousSibling Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ScrollToVisible Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SetProperty Method
DataGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGrid Class
DataGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid Properties
DataGrid Class See Also Send Feedback

The DataGrid type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AlternatingRowBackground |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AreRowDetailsFrozen |
Public property | AreRowGroupHeadersFrozen |
Public property | AutoGenerateColumns |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanUserReorderColumns |
Public property | CanUserResizeColumns |
Public property | CanUserSortColumns |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ClipboardCopyMode |
Public property | ColumnHeaderContainer | Gets the column header container. Please override for custom control template.
Public property | ColumnHeaderElements | Get the list of column headers of this Grid.
Public property | ColumnHeaderHeight |
Public property | ColumnWidth |
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | CurrentColumn | Gets / Sets the CurrentColumn for this Silverlight DataGrid.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | FrozenColumnCount |
Public property | GridData | Gets the full textual content of a grid. The dictionary key represents the row of the grid.
Public property | GridLinesVisibility |
Public property | HeadersVisibility |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalGridLinesBrush |
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsReadOnly |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxColumnWidth |
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinColumnWidth |
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RowBackground |
Public property | RowContainer | Gets the row container. Please override for custom control template.
Public property | RowDetailsVisibilityMode |
Public property | RowElements | Get the list of rows contained in this Grid.
Public property | RowHeaderWidth |
Public property | RowHeight |
Public property | SelectedIndex |
Public property | SelectionMode |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalGridLinesBrush |
Public property | VerticalScrollBarVisibility |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AlternatingRowBackground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AlternatingRowBackground Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AlternatingRowBackground"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush AlternatingRowBackground { get; set; }
Visual Basic
Public Property AlternatingRowBackground As Brush
    Get
    Set
Visual C++
public:
property Brush^ AlternatingRowBackground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AreRowDetailsFrozen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AreRowDetailsFrozen Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AreRowDetailsFrozen"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AreRowDetailsFrozen { get; set; }
Visual Basic
Public Property AreRowDetailsFrozen As Boolean
    Get
    Set
Visual C++
public:
property bool AreRowDetailsFrozen {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AreRowGroupHeadersFrozen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AreRowGroupHeadersFrozen Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AreRowGroupHeadersFrozen"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AreRowGroupHeadersFrozen { get; set; }
Visual Basic
Public Property AreRowGroupHeadersFrozen As Boolean
    Get
    Set
Visual C++
public:
property bool AreRowGroupHeadersFrozen {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoGenerateColumns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..AutoGenerateColumns Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.AutoGenerateColumns"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AutoGenerateColumns { get; set; }
Visual Basic
Public Property AutoGenerateColumns As Boolean
    Get
    Set
Visual C++
public:
property bool AutoGenerateColumns {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanUserReorderColumns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserReorderColumns Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.CanUserReorderColumns"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserReorderColumns { get; set; }
Visual Basic
Public Property CanUserReorderColumns As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserReorderColumns {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanUserResizeColumns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserResizeColumns Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.CanUserResizeColumns"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserResizeColumns { get; set; }
Visual Basic
Public Property CanUserResizeColumns As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserResizeColumns {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanUserSortColumns Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CanUserSortColumns Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.CanUserSortColumns"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanUserSortColumns { get; set; }
Visual Basic
Public Property CanUserSortColumns As Boolean
    Get
    Set
Visual C++
public:
property bool CanUserSortColumns {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ClipboardCopyMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ClipboardCopyMode Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.ClipboardCopyMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridClipboardCopyMode ClipboardCopyMode { get; set; }
Visual Basic
Public Property ClipboardCopyMode As DataGridClipboardCopyMode
    Get
    Set
Visual C++
public:
property DataGridClipboardCopyMode ClipboardCopyMode {
    DataGridClipboardCopyMode get ();
    void set (DataGridClipboardCopyMode value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColumnHeaderContainer Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnHeaderContainer Property
DataGrid Class See Also Send Feedback
Gets the column header container. Please override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ColumnHeaderContainer { get; }
Visual Basic
Public Overridable ReadOnly Property ColumnHeaderContainer As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ ColumnHeaderContainer {
    FrameworkElement^ get ();
}

Field Value

The column header container.

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColumnHeaderElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnHeaderElements Property
DataGrid Class See Also Send Feedback
Get the list of column headers of this Grid.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<IDataGridColumnHeader> ColumnHeaderElements { get; }
Visual Basic
Public ReadOnly Property ColumnHeaderElements As IList(Of IDataGridColumnHeader)
    Get
Visual C++
public:
virtual property IList<IDataGridColumnHeader^>^ ColumnHeaderElements {
    IList<IDataGridColumnHeader^>^ get () sealed;
}

Implements

IDataGrid..::..ColumnHeaderElements

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColumnHeaderHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnHeaderHeight Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.ColumnHeaderHeight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ColumnHeaderHeight { get; set; }
Visual Basic
Public Property ColumnHeaderHeight As Double
    Get
    Set
Visual C++
public:
property double ColumnHeaderHeight {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColumnWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..ColumnWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.ColumnWidth"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridLength ColumnWidth { get; set; }
Visual Basic
Public Property ColumnWidth As DataGridLength
    Get
    Set
Visual C++
public:
property DataGridLength^ ColumnWidth {
    DataGridLength^ get ();
    void set (DataGridLength^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CurrentColumn Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..CurrentColumn Property
DataGrid Class See Also Send Feedback
Gets / Sets the CurrentColumn for this Silverlight DataGrid.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumn CurrentColumn { get; set; }
Visual Basic
Public Property CurrentColumn As DataGridColumn
    Get
    Set
Visual C++
public:
property DataGridColumn^ CurrentColumn {
    DataGridColumn^ get ();
    void set (DataGridColumn^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FrozenColumnCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..FrozenColumnCount Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.FrozenColumnCount"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int FrozenColumnCount { get; set; }
Visual Basic
Public Property FrozenColumnCount As Integer
    Get
    Set
Visual C++
public:
property int FrozenColumnCount {
    int get ();
    void set (int value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GridData Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GridData Property
DataGrid Class See Also Send Feedback
Gets the full textual content of a grid. The dictionary key represents the row of the grid.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Dictionary<int, string[]> GridData { get; }
Visual Basic
Public ReadOnly Property GridData As Dictionary(Of Integer, String())
    Get
Visual C++
public:
property Dictionary<int, array<String^>^>^ GridData {
    Dictionary<int, array<String^>^>^ get ();
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GridLinesVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..GridLinesVisibility Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.GridLinesVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridGridLinesVisibility GridLinesVisibility { get; set; }
Visual Basic
Public Property GridLinesVisibility As DataGridGridLinesVisibility
    Get
    Set
Visual C++
public:
property DataGridGridLinesVisibility GridLinesVisibility {
    DataGridGridLinesVisibility get ();
    void set (DataGridGridLinesVisibility value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeadersVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HeadersVisibility Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.HeadersVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridHeadersVisibility HeadersVisibility { get; set; }
Visual Basic
Public Property HeadersVisibility As DataGridHeadersVisibility
    Get
    Set
Visual C++
public:
property DataGridHeadersVisibility HeadersVisibility {
    DataGridHeadersVisibility get ();
    void set (DataGridHeadersVisibility value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalGridLinesBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HorizontalGridLinesBrush Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.HorizontalGridLinesBrush"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush HorizontalGridLinesBrush { get; set; }
Visual Basic
Public Property HorizontalGridLinesBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ HorizontalGridLinesBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..HorizontalScrollBarVisibility Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.HorizontalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility HorizontalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsReadOnly Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..IsReadOnly Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.IsReadOnly"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..IsValid Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.IsValid"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsValid { get; set; }
Visual Basic
Public Property IsValid As Boolean
    Get
    Set
Visual C++
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaxColumnWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MaxColumnWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.MaxColumnWidth"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MaxColumnWidth { get; set; }
Visual Basic
Public Property MaxColumnWidth As Double
    Get
    Set
Visual C++
public:
property double MaxColumnWidth {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MinColumnWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..MinColumnWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.MinColumnWidth"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double MinColumnWidth { get; set; }
Visual Basic
Public Property MinColumnWidth As Double
    Get
    Set
Visual C++
public:
property double MinColumnWidth {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowBackground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowBackground Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.RowBackground"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush RowBackground { get; set; }
Visual Basic
Public Property RowBackground As Brush
    Get
    Set
Visual C++
public:
property Brush^ RowBackground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowContainer Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowContainer Property
DataGrid Class See Also Send Feedback
Gets the row container. Please override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement RowContainer { get; }
Visual Basic
Public Overridable ReadOnly Property RowContainer As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ RowContainer {
    FrameworkElement^ get ();
}

Field Value

The row container.

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowDetailsVisibilityMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowDetailsVisibilityMode Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.RowDetailsVisibilityMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRowDetailsVisibilityMode RowDetailsVisibilityMode { get; set; }
Visual Basic
Public Property RowDetailsVisibilityMode As DataGridRowDetailsVisibilityMode
    Get
    Set
Visual C++
public:
property DataGridRowDetailsVisibilityMode RowDetailsVisibilityMode {
    DataGridRowDetailsVisibilityMode get ();
    void set (DataGridRowDetailsVisibilityMode value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowElements Property
DataGrid Class See Also Send Feedback
Get the list of rows contained in this Grid.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<IDataGridRow> RowElements { get; }
Visual Basic
Public ReadOnly Property RowElements As IList(Of IDataGridRow)
    Get
Visual C++
public:
virtual property IList<IDataGridRow^>^ RowElements {
    IList<IDataGridRow^>^ get () sealed;
}

Implements

IDataGrid..::..RowElements

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowHeaderWidth Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeaderWidth Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.RowHeaderWidth"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RowHeaderWidth { get; set; }
Visual Basic
Public Property RowHeaderWidth As Double
    Get
    Set
Visual C++
public:
property double RowHeaderWidth {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..RowHeight Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.RowHeight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RowHeight { get; set; }
Visual Basic
Public Property RowHeight As Double
    Get
    Set
Visual C++
public:
property double RowHeight {
    double get ();
    void set (double value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SelectedIndex Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.SelectedIndex"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic
Public Property SelectedIndex As Integer
    Get
    Set
Visual C++
public:
property int SelectedIndex {
    int get ();
    void set (int value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..SelectionMode Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.SelectionMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridSelectionMode SelectionMode { get; set; }
Visual Basic
Public Property SelectionMode As DataGridSelectionMode
    Get
    Set
Visual C++
public:
property DataGridSelectionMode SelectionMode {
    DataGridSelectionMode get ();
    void set (DataGridSelectionMode value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalGridLinesBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..VerticalGridLinesBrush Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.VerticalGridLinesBrush"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush VerticalGridLinesBrush { get; set; }
Visual Basic
Public Property VerticalGridLinesBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ VerticalGridLinesBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalScrollBarVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGrid..::..VerticalScrollBarVisibility Property
DataGrid Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGrid.VerticalScrollBarVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic
Public Property VerticalScrollBarVisibility As ScrollBarVisibility
    Get
    Set
Visual C++
public:
property ScrollBarVisibility VerticalScrollBarVisibility {
    ScrollBarVisibility get ();
    void set (ScrollBarVisibility value);
}

See Also

DataGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Members
DataGridCell Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridCell type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridCell | Initializes a new instance of the DataGridCell class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsValidProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CellText | Return the cell text if any, else empty string. In case of multiple text blocks concatenates all the text.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Constructor
DataGridCell Class See Also Send Feedback
Initializes a new instance of the DataGridCell class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridCell()
Visual Basic
Public Sub New
Visual C++
public:
DataGridCell()

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCell Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Fields
DataGridCell Class See Also Send Feedback

The DataGridCell type exposes the following members.

Fields

Name | Description
IsValidProperty |

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValidProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsValidProperty Field
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridCell.IsValidProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsValidProperty
Visual Basic
Public Shared IsValidProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsValidProperty

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Methods
DataGridCell Class See Also Send Feedback

The DataGridCell type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..AnySibling Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..GetProperty Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..GetRealType Method
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridCell.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridCell.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..GetRectangle Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..Highlight Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..InvokeMethod Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsHitTest Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..NextSibling Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..Parent Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..PreviousSibling Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..ScrollToVisible Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..SetProperty Method
DataGridCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCell Class
DataGridCell Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell Properties
DataGridCell Class See Also Send Feedback

The DataGridCell type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CellText | Return the cell text if any, else empty string. In case of multiple text blocks concatenates all the text.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CellText Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..CellText Property
DataGridCell Class See Also Send Feedback
Return the cell text if any, else empty string. In case of multiple text blocks concatenates all the text.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string CellText { get; }
Visual Basic
Public ReadOnly Property CellText As String
    Get
Visual C++
public:
virtual property String^ CellText {
    String^ get () sealed;
}

Implements

IDataGridCell..::..CellText

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCell..::..IsValid Property
DataGridCell Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridCell.IsValid"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsValid { get; set; }
Visual Basic
Public Property IsValid As Boolean
    Get
    Set
Visual C++
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}

See Also

DataGridCell Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCellsPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter Members
DataGridCellsPresenter Class Constructors Methods Properties See Also Send Feedback

The DataGridCellsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridCellsPresenter | Initializes a new instance of the DataGridCellsPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCellsPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter Constructor
DataGridCellsPresenter Class See Also Send Feedback
Initializes a new instance of the DataGridCellsPresenter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridCellsPresenter()
Visual Basic
Public Sub New
Visual C++
public:
DataGridCellsPresenter()

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCellsPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter Methods
DataGridCellsPresenter Class See Also Send Feedback

The DataGridCellsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..AnySibling Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..GetProperty Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..GetRealType Method
DataGridCellsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridCellsPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridCellsPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..GetRectangle Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..Highlight Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..InvokeMethod Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..IsHitTest Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..NextSibling Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..Parent Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..PreviousSibling Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..ScrollToVisible Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter..::..SetProperty Method
DataGridCellsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridCellsPresenter Class
DataGridCellsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCellsPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridCellsPresenter Properties
DataGridCellsPresenter Class See Also Send Feedback

The DataGridCellsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridCellsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumn Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Members
DataGridColumn Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridColumn type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridColumn | Initializes a new instance of the DataGridColumn class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | Gets the full type name of the DataGridColumn this class wraps. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DisplayIndexProperty | Defines how to get/set the DisplayIndex property from the real Silverlight object.

Properties

 | Name | Description
Public property | DisplayIndex | Gets / Sets the value of the DisplayIndex.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumn Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumn Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Constructor
DataGridColumn Class See Also Send Feedback
Initializes a new instance of the DataGridColumn class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumn()
Visual Basic
Public Sub New
Visual C++
public:
DataGridColumn()

See Also

DataGridColumn Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumn Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Fields
DataGridColumn Class See Also Send Feedback

The DataGridColumn type exposes the following members.

Fields

Name | Description
DisplayIndexProperty | Defines how to get/set the DisplayIndex property from the real Silverlight object.

See Also

DataGridColumn Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..DisplayIndexProperty Field
DataGridColumn Class See Also Send Feedback
Defines how to get/set the DisplayIndex property from the real Silverlight object.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayIndexProperty
Visual Basic
Public Shared DisplayIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayIndexProperty

See Also

DataGridColumn Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumn Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Methods
DataGridColumn Class See Also Send Feedback

The DataGridColumn type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | Gets the full type name of the DataGridColumn this class wraps. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridColumn Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..GetProperty Method
DataGridColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumn Class
DataGridColumn Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..GetRealType Method
DataGridColumn Class See Also Send Feedback
Gets the full type name of the DataGridColumn this class wraps.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridColumn.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridColumn Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..InvokeMethod Method
DataGridColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumn Class
DataGridColumn Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumn Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn Properties
DataGridColumn Class See Also Send Feedback

The DataGridColumn type exposes the following members.

Properties

 | Name | Description
Public property | DisplayIndex | Gets / Sets the value of the DisplayIndex.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumn Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumn..::..DisplayIndex Property
DataGridColumn Class See Also Send Feedback
Gets / Sets the value of the DisplayIndex.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int DisplayIndex { get; set; }
Visual Basic
Public Property DisplayIndex As Integer
    Get
    Set
Visual C++
public:
property int DisplayIndex {
    int get ();
    void set (int value);
}

See Also

DataGridColumn Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Members
DataGridColumnHeader Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridColumnHeader type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridColumnHeader | Initializes a new instance of the DataGridColumnHeader class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SeparatorBrushProperty |
SeparatorVisibilityProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Constructor
DataGridColumnHeader Class See Also Send Feedback
Initializes a new instance of the DataGridColumnHeader class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumnHeader()
Visual Basic
Public Sub New
Visual C++
public:
DataGridColumnHeader()

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeader Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Fields
DataGridColumnHeader Class See Also Send Feedback

The DataGridColumnHeader type exposes the following members.

Fields

Name | Description
SeparatorBrushProperty |
SeparatorVisibilityProperty |

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SeparatorBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SeparatorBrushProperty Field
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridColumnHeader.SeparatorBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorBrushProperty
Visual Basic
Public Shared SeparatorBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorBrushProperty

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SeparatorVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SeparatorVisibilityProperty Field
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridColumnHeader.SeparatorVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorVisibilityProperty
Visual Basic
Public Shared SeparatorVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorVisibilityProperty

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Methods
DataGridColumnHeader Class See Also Send Feedback

The DataGridColumnHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..AnySibling Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..GetProperty Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..GetRealType Method
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridColumnHeader.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridColumnHeader.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..GetRectangle Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..Highlight Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..InvokeMethod Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..IsHitTest Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..NextSibling Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..Parent Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..PreviousSibling Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..ScrollToVisible Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SetProperty Method
DataGridColumnHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader Properties
DataGridColumnHeader Class See Also Send Feedback

The DataGridColumnHeader type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SeparatorBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SeparatorBrush Property
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridColumnHeader.SeparatorBrush"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush SeparatorBrush { get; set; }
Visual Basic
Public Property SeparatorBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SeparatorBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SeparatorVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeader..::..SeparatorVisibility Property
DataGridColumnHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridColumnHeader.SeparatorVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility SeparatorVisibility { get; set; }
Visual Basic
Public Property SeparatorVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility SeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridColumnHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeadersPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter Members
DataGridColumnHeadersPresenter Class Constructors Methods Properties See Also Send Feedback

The DataGridColumnHeadersPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridColumnHeadersPresenter | Initializes a new instance of the DataGridColumnHeadersPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeadersPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter Constructor
DataGridColumnHeadersPresenter Class See Also Send Feedback
Initializes a new instance of the DataGridColumnHeadersPresenter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridColumnHeadersPresenter()
Visual Basic
Public Sub New
Visual C++
public:
DataGridColumnHeadersPresenter()

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeadersPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter Methods
DataGridColumnHeadersPresenter Class See Also Send Feedback

The DataGridColumnHeadersPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..AnySibling Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..GetProperty Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..GetRealType Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridColumnHeadersPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridColumnHeadersPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..GetRectangle Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..Highlight Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..InvokeMethod Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..IsHitTest Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..NextSibling Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..Parent Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..PreviousSibling Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..ScrollToVisible Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter..::..SetProperty Method
DataGridColumnHeadersPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridColumnHeadersPresenter Class
DataGridColumnHeadersPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridColumnHeadersPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridColumnHeadersPresenter Properties
DataGridColumnHeadersPresenter Class See Also Send Feedback

The DataGridColumnHeadersPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridColumnHeadersPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridDetailsPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Members
DataGridDetailsPresenter Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridDetailsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridDetailsPresenter | Initializes a new instance of the DataGridDetailsPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ContentHeightProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | ContentHeight |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridDetailsPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Constructor
DataGridDetailsPresenter Class See Also Send Feedback
Initializes a new instance of the DataGridDetailsPresenter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridDetailsPresenter()
Visual Basic
Public Sub New
Visual C++
public:
DataGridDetailsPresenter()

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridDetailsPresenter Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Fields
DataGridDetailsPresenter Class See Also Send Feedback

The DataGridDetailsPresenter type exposes the following members.

Fields

Name | Description
ContentHeightProperty |

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..ContentHeightProperty Field
DataGridDetailsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridDetailsPresenter.ContentHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ContentHeightProperty
Visual Basic
Public Shared ContentHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ContentHeightProperty

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridDetailsPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Methods
DataGridDetailsPresenter Class See Also Send Feedback

The DataGridDetailsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..AnySibling Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..GetProperty Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..GetRealType Method
DataGridDetailsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridDetailsPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridDetailsPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..GetRectangle Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..Highlight Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..InvokeMethod Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..IsHitTest Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..NextSibling Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..Parent Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..PreviousSibling Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..ScrollToVisible Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..SetProperty Method
DataGridDetailsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridDetailsPresenter Class
DataGridDetailsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridDetailsPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter Properties
DataGridDetailsPresenter Class See Also Send Feedback

The DataGridDetailsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | ContentHeight |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ContentHeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridDetailsPresenter..::..ContentHeight Property
DataGridDetailsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridDetailsPresenter.ContentHeight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double ContentHeight { get; set; }
Visual Basic
Public Property ContentHeight As Double
    Get
    Set
Visual C++
public:
property double ContentHeight {
    double get ();
    void set (double value);
}

See Also

DataGridDetailsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridFrozenGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid Members
DataGridFrozenGrid Class Constructors Methods Properties See Also Send Feedback

The DataGridFrozenGrid type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridFrozenGrid | Initializes a new instance of the DataGridFrozenGrid class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Grid..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowGridLines | (Inherited from Grid.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridFrozenGrid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid Constructor
DataGridFrozenGrid Class See Also Send Feedback
Initializes a new instance of the DataGridFrozenGrid class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridFrozenGrid()
Visual Basic
Public Sub New
Visual C++
public:
DataGridFrozenGrid()

See Also

DataGridFrozenGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridFrozenGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid Methods
DataGridFrozenGrid Class See Also Send Feedback

The DataGridFrozenGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Grid..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..AnySibling Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..GetProperty Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..GetRealType Method
DataGridFrozenGrid Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridFrozenGrid.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridFrozenGrid.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridFrozenGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..GetRectangle Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..Highlight Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..InvokeMethod Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..IsHitTest Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..NextSibling Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..Parent Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..PreviousSibling Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..ScrollToVisible Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid..::..SetProperty Method
DataGridFrozenGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridFrozenGrid Class
DataGridFrozenGrid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridFrozenGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridFrozenGrid Properties
DataGridFrozenGrid Class See Also Send Feedback

The DataGridFrozenGrid type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowGridLines | (Inherited from Grid.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridFrozenGrid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridLength Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Members
DataGridLength Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridLength type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridLength | Initializes a new instance of the DataGridLength class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DesiredValueProperty |
DisplayValueProperty |
IsAbsoluteProperty |
IsAutoProperty |
IsSizeToCellsProperty |
IsSizeToHeaderProperty |
IsStarProperty |
UnitTypeProperty |
ValueProperty |

Properties

 | Name | Description
Public property | DesiredValue |
Public property | DisplayValue |
Public property | IsAbsolute |
Public property | IsAuto |
Public property | IsSizeToCells |
Public property | IsSizeToHeader |
Public property | IsStar |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | UnitType |
Public property | Value |

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridLength Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Constructor
DataGridLength Class See Also Send Feedback
Initializes a new instance of the DataGridLength class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridLength()
Visual Basic
Public Sub New
Visual C++
public:
DataGridLength()

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridLength Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Fields
DataGridLength Class See Also Send Feedback

The DataGridLength type exposes the following members.

Fields

Name | Description
DesiredValueProperty |
DisplayValueProperty |
IsAbsoluteProperty |
IsAutoProperty |
IsSizeToCellsProperty |
IsSizeToHeaderProperty |
IsStarProperty |
UnitTypeProperty |
ValueProperty |

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DesiredValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..DesiredValueProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.DesiredValueProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DesiredValueProperty
Visual Basic
Public Shared DesiredValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DesiredValueProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..DisplayValueProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.DisplayValueProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayValueProperty
Visual Basic
Public Shared DisplayValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayValueProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsAbsoluteProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsAbsoluteProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsAbsoluteProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsAbsoluteProperty
Visual Basic
Public Shared IsAbsoluteProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsAbsoluteProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsAutoProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsAutoProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsAutoProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsAutoProperty
Visual Basic
Public Shared IsAutoProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsAutoProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSizeToCellsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsSizeToCellsProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsSizeToCellsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSizeToCellsProperty
Visual Basic
Public Shared IsSizeToCellsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSizeToCellsProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSizeToHeaderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsSizeToHeaderProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsSizeToHeaderProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSizeToHeaderProperty
Visual Basic
Public Shared IsSizeToHeaderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSizeToHeaderProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsStarProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsStarProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsStarProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsStarProperty
Visual Basic
Public Shared IsStarProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsStarProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UnitTypeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..UnitTypeProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.UnitTypeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UnitTypeProperty
Visual Basic
Public Shared UnitTypeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UnitTypeProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..ValueProperty Field
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.ValueProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ValueProperty
Visual Basic
Public Shared ValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ValueProperty

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridLength Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Methods
DataGridLength Class See Also Send Feedback

The DataGridLength type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..GetProperty Method
DataGridLength Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridLength Class
DataGridLength Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..GetRealType Method
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..InvokeMethod Method
DataGridLength Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridLength Class
DataGridLength Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridLength Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength Properties
DataGridLength Class See Also Send Feedback

The DataGridLength type exposes the following members.

Properties

 | Name | Description
Public property | DesiredValue |
Public property | DisplayValue |
Public property | IsAbsolute |
Public property | IsAuto |
Public property | IsSizeToCells |
Public property | IsSizeToHeader |
Public property | IsStar |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | UnitType |
Public property | Value |

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DesiredValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..DesiredValue Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.DesiredValue"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double DesiredValue { get; set; }
Visual Basic
Public Overridable Property DesiredValue As Double
    Get
    Set
Visual C++
public:
virtual property double DesiredValue {
    double get ();
    void set (double value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayValue Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..DisplayValue Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.DisplayValue"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double DisplayValue { get; set; }
Visual Basic
Public Overridable Property DisplayValue As Double
    Get
    Set
Visual C++
public:
virtual property double DisplayValue {
    double get ();
    void set (double value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsAbsolute Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsAbsolute Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsAbsolute"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsAbsolute { get; set; }
Visual Basic
Public Overridable Property IsAbsolute As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsAbsolute {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsAuto Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsAuto Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsAuto"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsAuto { get; set; }
Visual Basic
Public Overridable Property IsAuto As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsAuto {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSizeToCells Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsSizeToCells Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsSizeToCells"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsSizeToCells { get; set; }
Visual Basic
Public Overridable Property IsSizeToCells As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsSizeToCells {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSizeToHeader Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsSizeToHeader Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsSizeToHeader"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsSizeToHeader { get; set; }
Visual Basic
Public Overridable Property IsSizeToHeader As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsSizeToHeader {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsStar Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..IsStar Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.IsStar"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool IsStar { get; set; }
Visual Basic
Public Overridable Property IsStar As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsStar {
    bool get ();
    void set (bool value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UnitType Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..UnitType Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.UnitType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual DataGridLengthUnitType UnitType { get; set; }
Visual Basic
Public Overridable Property UnitType As DataGridLengthUnitType
    Get
    Set
Visual C++
public:
virtual property DataGridLengthUnitType UnitType {
    DataGridLengthUnitType get ();
    void set (DataGridLengthUnitType value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Value Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridLength..::..Value Property
DataGridLength Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridLength.Value"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual double Value { get; set; }
Visual Basic
Public Overridable Property Value As Double
    Get
    Set
Visual C++
public:
virtual property double Value {
    double get ();
    void set (double value);
}

See Also

DataGridLength Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Members
DataGridRow Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridRow type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridRow | Initializes a new instance of the DataGridRow class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DetailsVisibilityProperty |
IsValidProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CellElements | Get the cells inside this row.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | DataGridCellsPresenter | Get the DataGridRow cells presenter element. Please override for custom control template.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DetailsVisibility |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RowData | Gets all the text contained in the cells as an array of strings for this row.
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRow Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Constructor
DataGridRow Class See Also Send Feedback
Initializes a new instance of the DataGridRow class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRow()
Visual Basic
Public Sub New
Visual C++
public:
DataGridRow()

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRow Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Fields
DataGridRow Class See Also Send Feedback

The DataGridRow type exposes the following members.

Fields

Name | Description
DetailsVisibilityProperty |
IsValidProperty |

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DetailsVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..DetailsVisibilityProperty Field
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridRow.DetailsVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DetailsVisibilityProperty
Visual Basic
Public Shared DetailsVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DetailsVisibilityProperty

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValidProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..IsValidProperty Field
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridRow.IsValidProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsValidProperty
Visual Basic
Public Shared IsValidProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsValidProperty

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Methods
DataGridRow Class See Also Send Feedback

The DataGridRow type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..AnySibling Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..AssignReference Method
DataGridRow Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference

[Missing <param name="reference"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRow.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..GetProperty Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..GetRealType Method
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRow.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRow.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..GetRectangle Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..Highlight Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..InvokeMethod Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..IsHitTest Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..NextSibling Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..Parent Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..PreviousSibling Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..ScrollToVisible Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..SetProperty Method
DataGridRow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRow Class
DataGridRow Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow Properties
DataGridRow Class See Also Send Feedback

The DataGridRow type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CellElements | Get the cells inside this row.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | DataGridCellsPresenter | Get the DataGridRow cells presenter element. Please override for custom control template.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DetailsVisibility |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RowData | Gets all the text contained in the cells as an array of strings for this row.
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CellElements Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..CellElements Property
DataGridRow Class See Also Send Feedback
Get the cells inside this row.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IList<IDataGridCell> CellElements { get; }
Visual Basic
Public ReadOnly Property CellElements As IList(Of IDataGridCell)
    Get
Visual C++
public:
virtual property IList<IDataGridCell^>^ CellElements {
    IList<IDataGridCell^>^ get () sealed;
}

Implements

IDataGridRow..::..CellElements

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridCellsPresenter Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..DataGridCellsPresenter Property
DataGridRow Class See Also Send Feedback
Get the DataGridRow cells presenter element. Please override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement DataGridCellsPresenter { get; }
Visual Basic
Public Overridable ReadOnly Property DataGridCellsPresenter As FrameworkElement
    Get
Visual C++
public:
virtual property FrameworkElement^ DataGridCellsPresenter {
    FrameworkElement^ get ();
}

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DetailsVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..DetailsVisibility Property
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridRow.DetailsVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility DetailsVisibility { get; set; }
Visual Basic
Public Property DetailsVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility DetailsVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..IsValid Property
DataGridRow Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridRow.IsValid"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsValid { get; set; }
Visual Basic
Public Property IsValid As Boolean
    Get
    Set
Visual C++
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RowData Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRow..::..RowData Property
DataGridRow Class See Also Send Feedback
Gets all the text contained in the cells as an array of strings for this row.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string[] RowData { get; }
Visual Basic
Public ReadOnly Property RowData As String()
    Get
Visual C++
public:
virtual property array<String^>^ RowData {
    array<String^>^ get () sealed;
}

Field Value

The row data.

Implements

IDataGridRow..::..RowData

See Also

DataGridRow Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowGroupHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader Members
DataGridRowGroupHeader Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridRowGroupHeader type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridRowGroupHeader | Initializes a new instance of the DataGridRowGroupHeader class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ItemCountVisibilityProperty |
PropertyNameProperty |
PropertyNameVisibilityProperty |
SublevelIndentProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | ItemCountVisibility |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | PropertyName |
Public property | PropertyNameVisibility |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SublevelIndent |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowGroupHeader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader Constructor
DataGridRowGroupHeader Class See Also Send Feedback
Initializes a new instance of the DataGridRowGroupHeader class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRowGroupHeader()
Visual Basic
Public Sub New
Visual C++
public:
DataGridRowGroupHeader()

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowGroupHeader Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader Fields
DataGridRowGroupHeader Class See Also Send Feedback

The DataGridRowGroupHeader type exposes the following members.

Fields

Name | Description
ItemCountVisibilityProperty |
PropertyNameProperty |
PropertyNameVisibilityProperty |
SublevelIndentProperty |

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemCountVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..ItemCountVisibilityProperty Field
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.ItemCountVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemCountVisibilityProperty
Visual Basic
Public Shared ItemCountVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemCountVisibilityProperty

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PropertyNameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..PropertyNameProperty Field
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.PropertyNameProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PropertyNameProperty
Visual Basic
Public Shared PropertyNameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PropertyNameProperty

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PropertyNameVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..PropertyNameVisibilityProperty Field
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.PropertyNameVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PropertyNameVisibilityProperty
Visual Basic
Public Shared PropertyNameVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PropertyNameVisibilityProperty

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SublevelIndentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..SublevelIndentProperty Field
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.SublevelIndentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SublevelIndentProperty
Visual Basic
Public Shared SublevelIndentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SublevelIndentProperty

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowGroupHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader Methods
DataGridRowGroupHeader Class See Also Send Feedback

The DataGridRowGroupHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..AnySibling Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..GetProperty Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..GetRealType Method
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..GetRectangle Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..Highlight Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..InvokeMethod Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..IsHitTest Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..NextSibling Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..Parent Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..PreviousSibling Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..ScrollToVisible Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..SetProperty Method
DataGridRowGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowGroupHeader Class
DataGridRowGroupHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowGroupHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader Properties
DataGridRowGroupHeader Class See Also Send Feedback

The DataGridRowGroupHeader type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | ItemCountVisibility |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | PropertyName |
Public property | PropertyNameVisibility |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SublevelIndent |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemCountVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..ItemCountVisibility Property
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.ItemCountVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility ItemCountVisibility { get; set; }
Visual Basic
Public Property ItemCountVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility ItemCountVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PropertyName Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..PropertyName Property
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.PropertyName"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic
Public Property PropertyName As String
    Get
    Set
Visual C++
public:
property String^ PropertyName {
    String^ get ();
    void set (String^ value);
}

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PropertyNameVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..PropertyNameVisibility Property
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.PropertyNameVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility PropertyNameVisibility { get; set; }
Visual Basic
Public Property PropertyNameVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility PropertyNameVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SublevelIndent Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowGroupHeader..::..SublevelIndent Property
DataGridRowGroupHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridRowGroupHeader.SublevelIndent"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double SublevelIndent { get; set; }
Visual Basic
Public Property SublevelIndent As Double
    Get
    Set
Visual C++
public:
property double SublevelIndent {
    double get ();
    void set (double value);
}

See Also

DataGridRowGroupHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Members
DataGridRowHeader Class Constructors Methods Fields Properties See Also Send Feedback

The DataGridRowHeader type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridRowHeader | Initializes a new instance of the DataGridRowHeader class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SeparatorBrushProperty |
SeparatorVisibilityProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowHeader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Constructor
DataGridRowHeader Class See Also Send Feedback
Initializes a new instance of the DataGridRowHeader class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRowHeader()
Visual Basic
Public Sub New
Visual C++
public:
DataGridRowHeader()

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowHeader Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Fields
DataGridRowHeader Class See Also Send Feedback

The DataGridRowHeader type exposes the following members.

Fields

Name | Description
SeparatorBrushProperty |
SeparatorVisibilityProperty |

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SeparatorBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SeparatorBrushProperty Field
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridRowHeader.SeparatorBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorBrushProperty
Visual Basic
Public Shared SeparatorBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorBrushProperty

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SeparatorVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SeparatorVisibilityProperty Field
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataGridRowHeader.SeparatorVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SeparatorVisibilityProperty
Visual Basic
Public Shared SeparatorVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SeparatorVisibilityProperty

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Methods
DataGridRowHeader Class See Also Send Feedback

The DataGridRowHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..AnySibling Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..GetProperty Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..GetRealType Method
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRowHeader.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRowHeader.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..GetRectangle Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..Highlight Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..InvokeMethod Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..IsHitTest Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..NextSibling Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..Parent Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..PreviousSibling Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..ScrollToVisible Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SetProperty Method
DataGridRowHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader Properties
DataGridRowHeader Class See Also Send Feedback

The DataGridRowHeader type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SeparatorBrush |
Public property | SeparatorVisibility |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SeparatorBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SeparatorBrush Property
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridRowHeader.SeparatorBrush"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush SeparatorBrush { get; set; }
Visual Basic
Public Property SeparatorBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ SeparatorBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SeparatorVisibility Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowHeader..::..SeparatorVisibility Property
DataGridRowHeader Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataGridRowHeader.SeparatorVisibility"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Visibility SeparatorVisibility { get; set; }
Visual Basic
Public Property SeparatorVisibility As Visibility
    Get
    Set
Visual C++
public:
property Visibility SeparatorVisibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

DataGridRowHeader Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowsPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter Members
DataGridRowsPresenter Class Constructors Methods Properties See Also Send Feedback

The DataGridRowsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | DataGridRowsPresenter | Initializes a new instance of the DataGridRowsPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowsPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter Constructor
DataGridRowsPresenter Class See Also Send Feedback
Initializes a new instance of the DataGridRowsPresenter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataGridRowsPresenter()
Visual Basic
Public Sub New
Visual C++
public:
DataGridRowsPresenter()

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowsPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter Methods
DataGridRowsPresenter Class See Also Send Feedback

The DataGridRowsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..AnySibling Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..GetProperty Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..GetRealType Method
DataGridRowsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRowsPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataGridRowsPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..GetRectangle Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..Highlight Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..InvokeMethod Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..IsHitTest Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..NextSibling Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..Parent Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..PreviousSibling Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..ScrollToVisible Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter..::..SetProperty Method
DataGridRowsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataGridRowsPresenter Class
DataGridRowsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataGridRowsPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataGridRowsPresenter Properties
DataGridRowsPresenter Class See Also Send Feedback

The DataGridRowsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataGridRowsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataPager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager Members
DataPager Class Constructors Methods Fields Properties See Also Send Feedback

The DataPager type exposes the following members.

Constructors

 | Name | Description
Public method | DataPager | Initializes a new instance of the DataPager class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AutoEllipsisProperty |
CanChangePageProperty |
CanMoveToFirstPageProperty |
CanMoveToLastPageProperty |
CanMoveToNextPageProperty |
CanMoveToPreviousPageProperty |
DisplayModeProperty |
IsTotalItemCountFixedProperty |
ItemCountProperty |
NumericButtonCountProperty |
PageCountProperty |
PageIndexProperty |
PageSizeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutoEllipsis |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanChangePage |
Public property | CanMoveToFirstPage |
Public property | CanMoveToLastPage |
Public property | CanMoveToNextPage |
Public property | CanMoveToPreviousPage |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMode |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTotalItemCountFixed |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | ItemCount |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NumericButtonCount |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount |
Public property | PageIndex |
Public property | PageSize |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataPager Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager Constructor
DataPager Class See Also Send Feedback
Initializes a new instance of the DataPager class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DataPager()
Visual Basic
Public Sub New
Visual C++
public:
DataPager()

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataPager Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager Fields
DataPager Class See Also Send Feedback

The DataPager type exposes the following members.

Fields

Name | Description
AutoEllipsisProperty |
CanChangePageProperty |
CanMoveToFirstPageProperty |
CanMoveToLastPageProperty |
CanMoveToNextPageProperty |
CanMoveToPreviousPageProperty |
DisplayModeProperty |
IsTotalItemCountFixedProperty |
ItemCountProperty |
NumericButtonCountProperty |
PageCountProperty |
PageIndexProperty |
PageSizeProperty |

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoEllipsisProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..AutoEllipsisProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.AutoEllipsisProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoEllipsisProperty
Visual Basic
Public Shared AutoEllipsisProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoEllipsisProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanChangePageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanChangePageProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanChangePageProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanChangePageProperty
Visual Basic
Public Shared CanChangePageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanChangePageProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanMoveToFirstPageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanMoveToFirstPageProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanMoveToFirstPageProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanMoveToFirstPageProperty
Visual Basic
Public Shared CanMoveToFirstPageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanMoveToFirstPageProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanMoveToLastPageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanMoveToLastPageProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanMoveToLastPageProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanMoveToLastPageProperty
Visual Basic
Public Shared CanMoveToLastPageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanMoveToLastPageProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanMoveToNextPageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanMoveToNextPageProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanMoveToNextPageProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanMoveToNextPageProperty
Visual Basic
Public Shared CanMoveToNextPageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanMoveToNextPageProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanMoveToPreviousPageProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanMoveToPreviousPageProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanMoveToPreviousPageProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanMoveToPreviousPageProperty
Visual Basic
Public Shared CanMoveToPreviousPageProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanMoveToPreviousPageProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..DisplayModeProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.DisplayModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayModeProperty
Visual Basic
Public Shared DisplayModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayModeProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTotalItemCountFixedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..IsTotalItemCountFixedProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.IsTotalItemCountFixedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTotalItemCountFixedProperty
Visual Basic
Public Shared IsTotalItemCountFixedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTotalItemCountFixedProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..ItemCountProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.ItemCountProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemCountProperty
Visual Basic
Public Shared ItemCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemCountProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


NumericButtonCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..NumericButtonCountProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.NumericButtonCountProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NumericButtonCountProperty
Visual Basic
Public Shared NumericButtonCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NumericButtonCountProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PageCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..PageCountProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.PageCountProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageCountProperty
Visual Basic
Public Shared PageCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageCountProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PageIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..PageIndexProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.PageIndexProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageIndexProperty
Visual Basic
Public Shared PageIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageIndexProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PageSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..PageSizeProperty Field
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DataPager.PageSizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PageSizeProperty
Visual Basic
Public Shared PageSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PageSizeProperty

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataPager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager Methods
DataPager Class See Also Send Feedback

The DataPager type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..AnySibling Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..GetProperty Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..GetRealType Method
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataPager.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DataPager.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..GetRectangle Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..Highlight Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..InvokeMethod Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..IsHitTest Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..NextSibling Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..Parent Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..PreviousSibling Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..ScrollToVisible Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..SetProperty Method
DataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DataPager Class
DataPager Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DataPager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager Properties
DataPager Class See Also Send Feedback

The DataPager type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutoEllipsis |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CanChangePage |
Public property | CanMoveToFirstPage |
Public property | CanMoveToLastPage |
Public property | CanMoveToNextPage |
Public property | CanMoveToPreviousPage |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMode |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTotalItemCountFixed |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | ItemCount |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NumericButtonCount |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | PageCount |
Public property | PageIndex |
Public property | PageSize |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoEllipsis Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..AutoEllipsis Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.AutoEllipsis"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool AutoEllipsis { get; set; }
Visual Basic
Public Property AutoEllipsis As Boolean
    Get
    Set
Visual C++
public:
property bool AutoEllipsis {
    bool get ();
    void set (bool value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanChangePage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanChangePage Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanChangePage"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanChangePage { get; set; }
Visual Basic
Public Property CanChangePage As Boolean
    Get
    Set
Visual C++
public:
property bool CanChangePage {
    bool get ();
    void set (bool value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanMoveToFirstPage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanMoveToFirstPage Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanMoveToFirstPage"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanMoveToFirstPage { get; set; }
Visual Basic
Public Property CanMoveToFirstPage As Boolean
    Get
    Set
Visual C++
public:
property bool CanMoveToFirstPage {
    bool get ();
    void set (bool value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanMoveToLastPage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanMoveToLastPage Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanMoveToLastPage"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanMoveToLastPage { get; set; }
Visual Basic
Public Property CanMoveToLastPage As Boolean
    Get
    Set
Visual C++
public:
property bool CanMoveToLastPage {
    bool get ();
    void set (bool value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanMoveToNextPage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanMoveToNextPage Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanMoveToNextPage"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanMoveToNextPage { get; set; }
Visual Basic
Public Property CanMoveToNextPage As Boolean
    Get
    Set
Visual C++
public:
property bool CanMoveToNextPage {
    bool get ();
    void set (bool value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanMoveToPreviousPage Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..CanMoveToPreviousPage Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.CanMoveToPreviousPage"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanMoveToPreviousPage { get; set; }
Visual Basic
Public Property CanMoveToPreviousPage As Boolean
    Get
    Set
Visual C++
public:
property bool CanMoveToPreviousPage {
    bool get ();
    void set (bool value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..DisplayMode Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.DisplayMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PagerDisplayMode DisplayMode { get; set; }
Visual Basic
Public Property DisplayMode As PagerDisplayMode
    Get
    Set
Visual C++
public:
property PagerDisplayMode DisplayMode {
    PagerDisplayMode get ();
    void set (PagerDisplayMode value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTotalItemCountFixed Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..IsTotalItemCountFixed Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.IsTotalItemCountFixed"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTotalItemCountFixed { get; set; }
Visual Basic
Public Property IsTotalItemCountFixed As Boolean
    Get
    Set
Visual C++
public:
property bool IsTotalItemCountFixed {
    bool get ();
    void set (bool value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..ItemCount Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.ItemCount"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int ItemCount { get; set; }
Visual Basic
Public Property ItemCount As Integer
    Get
    Set
Visual C++
public:
property int ItemCount {
    int get ();
    void set (int value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


NumericButtonCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..NumericButtonCount Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.NumericButtonCount"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int NumericButtonCount { get; set; }
Visual Basic
Public Property NumericButtonCount As Integer
    Get
    Set
Visual C++
public:
property int NumericButtonCount {
    int get ();
    void set (int value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PageCount Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..PageCount Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.PageCount"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PageCount { get; set; }
Visual Basic
Public Property PageCount As Integer
    Get
    Set
Visual C++
public:
property int PageCount {
    int get ();
    void set (int value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PageIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..PageIndex Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.PageIndex"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PageIndex { get; set; }
Visual Basic
Public Property PageIndex As Integer
    Get
    Set
Visual C++
public:
property int PageIndex {
    int get ();
    void set (int value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PageSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPager..::..PageSize Property
DataPager Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DataPager.PageSize"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int PageSize { get; set; }
Visual Basic
Public Property PageSize As Integer
    Get
    Set
Visual C++
public:
property int PageSize {
    int get ();
    void set (int value);
}

See Also

DataPager Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Members
DatePicker Class Constructors Methods Fields Properties See Also Send Feedback

The DatePicker type exposes the following members.

Constructors

 | Name | Description
Public method | DatePicker | Initializes a new instance of the DatePicker class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | OpenCalendarPopup | Open the picker calendar popup.
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets new text into the date picker text box.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DisplayDateEndProperty |
DisplayDateProperty |
DisplayDateStartProperty |
FirstDayOfWeekProperty |
IsDropDownOpenProperty |
IsTodayHighlightedProperty |
SelectedDateFormatProperty |
SelectedDateProperty |
SelectionBackgroundProperty |
TextProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayDate |
Public property | DisplayDateEnd |
Public property | DisplayDateStart |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstDayOfWeek |
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTodayHighlighted |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PickerTextBox | Get the picker text box element. Override for custom control template.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedDate |
Public property | SelectedDateFormat |
Public property | SelectionBackground |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TogglePopupButton | Get the picker toggle popup button element. Override for custom control template.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePicker Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Constructor
DatePicker Class See Also Send Feedback
Initializes a new instance of the DatePicker class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DatePicker()
Visual Basic
Public Sub New
Visual C++
public:
DatePicker()

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePicker Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Fields
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Fields

Name | Description
DisplayDateEndProperty |
DisplayDateProperty |
DisplayDateStartProperty |
FirstDayOfWeekProperty |
IsDropDownOpenProperty |
IsTodayHighlightedProperty |
SelectedDateFormatProperty |
SelectedDateProperty |
SelectionBackgroundProperty |
TextProperty |

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateEndProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateEndProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.DisplayDateEndProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateEndProperty
Visual Basic
Public Shared DisplayDateEndProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateEndProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.DisplayDateProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateProperty
Visual Basic
Public Shared DisplayDateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateStartProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateStartProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.DisplayDateStartProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayDateStartProperty
Visual Basic
Public Shared DisplayDateStartProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayDateStartProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FirstDayOfWeekProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..FirstDayOfWeekProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.FirstDayOfWeekProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FirstDayOfWeekProperty
Visual Basic
Public Shared FirstDayOfWeekProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FirstDayOfWeekProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDropDownOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsDropDownOpenProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.IsDropDownOpenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDropDownOpenProperty
Visual Basic
Public Shared IsDropDownOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDropDownOpenProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTodayHighlightedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsTodayHighlightedProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.IsTodayHighlightedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTodayHighlightedProperty
Visual Basic
Public Shared IsTodayHighlightedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTodayHighlightedProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedDateFormatProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectedDateFormatProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.SelectedDateFormatProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedDateFormatProperty
Visual Basic
Public Shared SelectedDateFormatProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedDateFormatProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedDateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectedDateProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.SelectedDateProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedDateProperty
Visual Basic
Public Shared SelectedDateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedDateProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionBackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectionBackgroundProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.SelectionBackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionBackgroundProperty
Visual Basic
Public Shared SelectionBackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionBackgroundProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..TextProperty Field
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePicker.TextProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Methods
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | OpenCalendarPopup | Open the picker calendar popup.
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets new text into the date picker text box.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..AnySibling Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..GetProperty Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..GetRealType Method
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DatePicker.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DatePicker.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..GetRectangle Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..Highlight Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..InvokeMethod Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsHitTest Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..NextSibling Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


OpenCalendarPopup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..OpenCalendarPopup Method
DatePicker Class See Also Send Feedback
Open the picker calendar popup.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void OpenCalendarPopup(
    bool simulateRealUser
)
Visual Basic
Public Sub OpenCalendarPopup ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void OpenCalendarPopup(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
True to find the button and click on it, false to change the state via automation property.

Implements

IDatePicker..::..OpenCalendarPopup(Boolean)

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..Parent Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..PreviousSibling Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..ScrollToVisible Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SetProperty Method
DatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePicker Class
DatePicker Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SetText Method
DatePicker Class See Also Send Feedback
Sets new text into the date picker text box.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
virtual void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate typing into the text box or just replace its text.
text
Type: System..::..String
The text to type or set.
keyPressTime
Type: System..::..Int32
The delay between each press when typing.
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key when typing.

Implements

IDatePicker..::..SetText(Boolean, String, Int32, Int32)

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker Properties
DatePicker Class See Also Send Feedback

The DatePicker type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayDate |
Public property | DisplayDateEnd |
Public property | DisplayDateStart |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FirstDayOfWeek |
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDropDownOpen |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsTodayHighlighted |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PickerTextBox | Get the picker text box element. Override for custom control template.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedDate |
Public property | SelectedDateFormat |
Public property | SelectionBackground |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TogglePopupButton | Get the picker toggle popup button element. Override for custom control template.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDate Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.DisplayDate"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DateTime DisplayDate { get; set; }
Visual Basic
Public Property DisplayDate As DateTime
    Get
    Set
Visual C++
public:
property DateTime DisplayDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateEnd Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateEnd Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.DisplayDateEnd"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> DisplayDateEnd { get; set; }
Visual Basic
Public Property DisplayDateEnd As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DisplayDateEnd {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayDateStart Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..DisplayDateStart Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.DisplayDateStart"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> DisplayDateStart { get; set; }
Visual Basic
Public Property DisplayDateStart As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
property Nullable<DateTime> DisplayDateStart {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FirstDayOfWeek Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..FirstDayOfWeek Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.FirstDayOfWeek"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DayOfWeek FirstDayOfWeek { get; set; }
Visual Basic
Public Property FirstDayOfWeek As DayOfWeek
    Get
    Set
Visual C++
public:
property DayOfWeek FirstDayOfWeek {
    DayOfWeek get ();
    void set (DayOfWeek value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDropDownOpen Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsDropDownOpen Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.IsDropDownOpen"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic
Public Property IsDropDownOpen As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsDropDownOpen {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

IDatePicker..::..IsDropDownOpen

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTodayHighlighted Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..IsTodayHighlighted Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.IsTodayHighlighted"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTodayHighlighted { get; set; }
Visual Basic
Public Property IsTodayHighlighted As Boolean
    Get
    Set
Visual C++
public:
property bool IsTodayHighlighted {
    bool get ();
    void set (bool value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PickerTextBox Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..PickerTextBox Property
DatePicker Class See Also Send Feedback
Get the picker text box element. Override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IDatePickerTextBox PickerTextBox { get; }
Visual Basic
Public Overridable ReadOnly Property PickerTextBox As IDatePickerTextBox
    Get
Visual C++
public:
virtual property IDatePickerTextBox^ PickerTextBox {
    IDatePickerTextBox^ get ();
}

Implements

IDatePicker..::..PickerTextBox

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedDate Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectedDate Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.SelectedDate"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Nullable<DateTime> SelectedDate { get; set; }
Visual Basic
Public Property SelectedDate As Nullable(Of DateTime)
    Get
    Set
Visual C++
public:
virtual property Nullable<DateTime> SelectedDate {
    Nullable<DateTime> get () sealed;
    void set (Nullable<DateTime> value) sealed;
}

Implements

IDatePicker..::..SelectedDate

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedDateFormat Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectedDateFormat Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.SelectedDateFormat"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DatePickerFormat SelectedDateFormat { get; set; }
Visual Basic
Public Property SelectedDateFormat As DatePickerFormat
    Get
    Set
Visual C++
public:
property DatePickerFormat SelectedDateFormat {
    DatePickerFormat get ();
    void set (DatePickerFormat value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionBackground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..SelectionBackground Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.SelectionBackground"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush SelectionBackground { get; set; }
Visual Basic
Public Property SelectionBackground As Brush
    Get
    Set
Visual C++
public:
property Brush^ SelectionBackground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Text Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..Text Property
DatePicker Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePicker.Text"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
virtual property String^ Text {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Implements

IFrameworkElement..::..Text

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TogglePopupButton Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePicker..::..TogglePopupButton Property
DatePicker Class See Also Send Feedback
Get the picker toggle popup button element. Override for custom control template.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IButton TogglePopupButton { get; }
Visual Basic
Public Overridable ReadOnly Property TogglePopupButton As IButton
    Get
Visual C++
public:
virtual property IButton^ TogglePopupButton {
    IButton^ get ();
}

Implements

IDatePicker..::..TogglePopupButton

See Also

DatePicker Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePickerTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Members
DatePickerTextBox Class Constructors Methods Fields Properties See Also Send Feedback

The DatePickerTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | DatePickerTextBox | Initializes a new instance of the DatePickerTextBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides TextBox..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox. (Inherited from TextBox.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
WatermarkProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn | (Inherited from TextBox.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaretBrush | (Inherited from TextBox.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from TextBox.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsReadOnly | (Inherited from TextBox.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength | (Inherited from TextBox.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionBackground | (Inherited from TextBox.)
Public property | SelectionForeground | (Inherited from TextBox.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | (Inherited from TextBox.)
Public property | TextAlignment | (Inherited from TextBox.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping | (Inherited from TextBox.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Watermark |
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePickerTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Constructor
DatePickerTextBox Class See Also Send Feedback
Initializes a new instance of the DatePickerTextBox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DatePickerTextBox()
Visual Basic
Public Sub New
Visual C++
public:
DatePickerTextBox()

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePickerTextBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Fields
DatePickerTextBox Class See Also Send Feedback

The DatePickerTextBox type exposes the following members.

Fields

Name | Description
WatermarkProperty |

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WatermarkProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..WatermarkProperty Field
DatePickerTextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DatePickerTextBox.WatermarkProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WatermarkProperty
Visual Basic
Public Shared WatermarkProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WatermarkProperty

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePickerTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Methods
DatePickerTextBox Class See Also Send Feedback

The DatePickerTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides TextBox..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox. (Inherited from TextBox.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..AnySibling Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..GetProperty Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..GetRealType Method
DatePickerTextBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DatePickerTextBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DatePickerTextBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..GetRectangle Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..Highlight Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..InvokeMethod Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..IsHitTest Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..NextSibling Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..Parent Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..PreviousSibling Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..ScrollToVisible Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..SetProperty Method
DatePickerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DatePickerTextBox Class
DatePickerTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DatePickerTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox Properties
DatePickerTextBox Class See Also Send Feedback

The DatePickerTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn | (Inherited from TextBox.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaretBrush | (Inherited from TextBox.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope | (Inherited from TextBox.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsReadOnly | (Inherited from TextBox.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength | (Inherited from TextBox.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionBackground | (Inherited from TextBox.)
Public property | SelectionForeground | (Inherited from TextBox.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | (Inherited from TextBox.)
Public property | TextAlignment | (Inherited from TextBox.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping | (Inherited from TextBox.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Watermark |
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Watermark Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DatePickerTextBox..::..Watermark Property
DatePickerTextBox Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DatePickerTextBox.Watermark"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Object Watermark { get; set; }
Visual Basic
Public Property Watermark As Object
    Get
    Set
Visual C++
public:
property Object^ Watermark {
    Object^ get ();
    void set (Object^ value);
}

See Also

DatePickerTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DeepZoomImageTileSource Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource Members
DeepZoomImageTileSource Class Constructors Methods Fields Properties See Also Send Feedback

The DeepZoomImageTileSource type exposes the following members.

Constructors

 | Name | Description
Public method | DeepZoomImageTileSource | Initializes a new instance of the DeepZoomImageTileSource class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides MultiScaleTileSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
UriSourceProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | UriSource |

See Also

DeepZoomImageTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DeepZoomImageTileSource Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource Constructor
DeepZoomImageTileSource Class See Also Send Feedback
Initializes a new instance of the DeepZoomImageTileSource class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DeepZoomImageTileSource()
Visual Basic
Public Sub New
Visual C++
public:
DeepZoomImageTileSource()

See Also

DeepZoomImageTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DeepZoomImageTileSource Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource Fields
DeepZoomImageTileSource Class See Also Send Feedback

The DeepZoomImageTileSource type exposes the following members.

Fields

Name | Description
UriSourceProperty |

See Also

DeepZoomImageTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UriSourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource..::..UriSourceProperty Field
DeepZoomImageTileSource Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DeepZoomImageTileSource.UriSourceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UriSourceProperty
Visual Basic
Public Shared UriSourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UriSourceProperty

See Also

DeepZoomImageTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DeepZoomImageTileSource Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource Methods
DeepZoomImageTileSource Class See Also Send Feedback

The DeepZoomImageTileSource type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides MultiScaleTileSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeepZoomImageTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource..::..GetProperty Method
DeepZoomImageTileSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DeepZoomImageTileSource Class
DeepZoomImageTileSource Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource..::..GetRealType Method
DeepZoomImageTileSource Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DeepZoomImageTileSource.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DeepZoomImageTileSource.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DeepZoomImageTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource..::..InvokeMethod Method
DeepZoomImageTileSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DeepZoomImageTileSource Class
DeepZoomImageTileSource Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DeepZoomImageTileSource Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource Properties
DeepZoomImageTileSource Class See Also Send Feedback

The DeepZoomImageTileSource type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | UriSource |

See Also

DeepZoomImageTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UriSource Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DeepZoomImageTileSource..::..UriSource Property
DeepZoomImageTileSource Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DeepZoomImageTileSource.UriSource"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UriSource { get; set; }
Visual Basic
Public Property UriSource As String
    Get
    Set
Visual C++
public:
property String^ UriSource {
    String^ get ();
    void set (String^ value);
}

See Also

DeepZoomImageTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DescriptionViewer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer Members
DescriptionViewer Class Constructors Methods Fields Properties See Also Send Feedback

The DescriptionViewer type exposes the following members.

Constructors

 | Name | Description
Public method | DescriptionViewer | Initializes a new instance of the DescriptionViewer class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DescriptionProperty |
IsValidProperty |
PropertyPathProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | Description |
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | PropertyPath |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DescriptionViewer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer Constructor
DescriptionViewer Class See Also Send Feedback
Initializes a new instance of the DescriptionViewer class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DescriptionViewer()
Visual Basic
Public Sub New
Visual C++
public:
DescriptionViewer()

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DescriptionViewer Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer Fields
DescriptionViewer Class See Also Send Feedback

The DescriptionViewer type exposes the following members.

Fields

Name | Description
DescriptionProperty |
IsValidProperty |
PropertyPathProperty |

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DescriptionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..DescriptionProperty Field
DescriptionViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DescriptionViewer.DescriptionProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DescriptionProperty
Visual Basic
Public Shared DescriptionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DescriptionProperty

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValidProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..IsValidProperty Field
DescriptionViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DescriptionViewer.IsValidProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsValidProperty
Visual Basic
Public Shared IsValidProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsValidProperty

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PropertyPathProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..PropertyPathProperty Field
DescriptionViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.DescriptionViewer.PropertyPathProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PropertyPathProperty
Visual Basic
Public Shared PropertyPathProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PropertyPathProperty

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DescriptionViewer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer Methods
DescriptionViewer Class See Also Send Feedback

The DescriptionViewer type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..AnySibling Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..GetProperty Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..GetRealType Method
DescriptionViewer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DescriptionViewer.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.DescriptionViewer.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..GetRectangle Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..Highlight Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..InvokeMethod Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..IsHitTest Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..NextSibling Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..Parent Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..PreviousSibling Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..ScrollToVisible Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..SetProperty Method
DescriptionViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

DescriptionViewer Class
DescriptionViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


DescriptionViewer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer Properties
DescriptionViewer Class See Also Send Feedback

The DescriptionViewer type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | Description |
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | PropertyPath |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Description Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..Description Property
DescriptionViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DescriptionViewer.Description"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValid Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..IsValid Property
DescriptionViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DescriptionViewer.IsValid"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsValid { get; set; }
Visual Basic
Public Property IsValid As Boolean
    Get
    Set
Visual C++
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PropertyPath Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DescriptionViewer..::..PropertyPath Property
DescriptionViewer Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.DescriptionViewer.PropertyPath"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string PropertyPath { get; set; }
Visual Basic
Public Property PropertyPath As String
    Get
    Set
Visual C++
public:
property String^ PropertyPath {
    String^ get ();
    void set (String^ value);
}

See Also

DescriptionViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Duration Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration Members
Duration Class Constructors Methods Fields Properties See Also Send Feedback

The Duration type exposes the following members.

Constructors

 | Name | Description
Public method | Duration | Initializes a new instance of the Duration class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
HasTimeSpanProperty |
TimeSpanProperty |

Properties

 | Name | Description
Public property | HasTimeSpan |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | TimeSpan |

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Duration Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration Constructor
Duration Class See Also Send Feedback
Initializes a new instance of the Duration class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Duration()
Visual Basic
Public Sub New
Visual C++
public:
Duration()

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Duration Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration Fields
Duration Class See Also Send Feedback

The Duration type exposes the following members.

Fields

Name | Description
HasTimeSpanProperty |
TimeSpanProperty |

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HasTimeSpanProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration..::..HasTimeSpanProperty Field
Duration Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Duration.HasTimeSpanProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasTimeSpanProperty
Visual Basic
Public Shared HasTimeSpanProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasTimeSpanProperty

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TimeSpanProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration..::..TimeSpanProperty Field
Duration Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Duration.TimeSpanProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TimeSpanProperty
Visual Basic
Public Shared TimeSpanProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TimeSpanProperty

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Duration Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration Methods
Duration Class See Also Send Feedback

The Duration type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration..::..GetProperty Method
Duration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Duration Class
Duration Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration..::..GetRealType Method
Duration Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Duration.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Duration.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration..::..InvokeMethod Method
Duration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Duration Class
Duration Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Duration Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration Properties
Duration Class See Also Send Feedback

The Duration type exposes the following members.

Properties

 | Name | Description
Public property | HasTimeSpan |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | TimeSpan |

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HasTimeSpan Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration..::..HasTimeSpan Property
Duration Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Duration.HasTimeSpan"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool HasTimeSpan { get; set; }
Visual Basic
Public Overridable Property HasTimeSpan As Boolean
    Get
    Set
Visual C++
public:
virtual property bool HasTimeSpan {
    bool get ();
    void set (bool value);
}

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TimeSpan Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Duration..::..TimeSpan Property
Duration Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Duration.TimeSpan"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual TimeSpan TimeSpan { get; set; }
Visual Basic
Public Overridable Property TimeSpan As TimeSpan
    Get
    Set
Visual C++
public:
virtual property TimeSpan^ TimeSpan {
    TimeSpan^ get ();
    void set (TimeSpan^ value);
}

See Also

Duration Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Ellipse Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse Members
Ellipse Class Constructors Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

 | Name | Description
Public method | Ellipse | Initializes a new instance of the Ellipse class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Ellipse Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Ellipse Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse Constructor
Ellipse Class See Also Send Feedback
Initializes a new instance of the Ellipse class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Ellipse()
Visual Basic
Public Sub New
Visual C++
public:
Ellipse()

See Also

Ellipse Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Ellipse Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Ellipse Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..AnySibling Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..GetProperty Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..GetRealType Method
Ellipse Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Ellipse.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Ellipse.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Ellipse Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..GetRectangle Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..Highlight Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..InvokeMethod Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..IsHitTest Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..NextSibling Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..Parent Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..PreviousSibling Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..ScrollToVisible Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse..::..SetProperty Method
Ellipse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Ellipse Class
Ellipse Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Ellipse Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Ellipse Class
ArtOfTest.WebAii.Silverlight.UI Namespace


EllipseGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Members
EllipseGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The EllipseGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | EllipseGeometry | Initializes a new instance of the EllipseGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterProperty |
RadiusXProperty |
RadiusYProperty |

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | Center |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


EllipseGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Constructor
EllipseGeometry Class See Also Send Feedback
Initializes a new instance of the EllipseGeometry class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public EllipseGeometry()
Visual Basic
Public Sub New
Visual C++
public:
EllipseGeometry()

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


EllipseGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Fields
EllipseGeometry Class See Also Send Feedback

The EllipseGeometry type exposes the following members.

Fields

Name | Description
CenterProperty |
RadiusXProperty |
RadiusYProperty |

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..CenterProperty Field
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.EllipseGeometry.CenterProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterProperty
Visual Basic
Public Shared CenterProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterProperty

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..RadiusXProperty Field
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.EllipseGeometry.RadiusXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusXProperty
Visual Basic
Public Shared RadiusXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusXProperty

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..RadiusYProperty Field
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.EllipseGeometry.RadiusYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusYProperty
Visual Basic
Public Shared RadiusYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusYProperty

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


EllipseGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Methods
EllipseGeometry Class See Also Send Feedback

The EllipseGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..GetProperty Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

EllipseGeometry Class
EllipseGeometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..GetRealType Method
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.EllipseGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.EllipseGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..InvokeMethod Method
EllipseGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

EllipseGeometry Class
EllipseGeometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


EllipseGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry Properties
EllipseGeometry Class See Also Send Feedback

The EllipseGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | Center |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Center Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..Center Property
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.EllipseGeometry.Center"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point Center { get; set; }
Visual Basic
Public Property Center As Point
    Get
    Set
Visual C++
public:
property Point^ Center {
    Point^ get ();
    void set (Point^ value);
}

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..RadiusX Property
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.EllipseGeometry.RadiusX"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusX { get; set; }
Visual Basic
Public Property RadiusX As Double
    Get
    Set
Visual C++
public:
property double RadiusX {
    double get ();
    void set (double value);
}

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EllipseGeometry..::..RadiusY Property
EllipseGeometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.EllipseGeometry.RadiusY"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double RadiusY { get; set; }
Visual Basic
Public Property RadiusY As Double
    Get
    Set
Visual C++
public:
property double RadiusY {
    double get ();
    void set (double value);
}

See Also

EllipseGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Frame Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Members
Frame Class Constructors Methods Fields Properties See Also Send Feedback

The Frame type exposes the following members.

Constructors

 | Name | Description
Public method | Frame | Initializes a new instance of the Frame class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
CacheSizeProperty |
CanGoBackProperty |
CanGoForwardProperty |
CurrentSourceProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
HorizontalContentAlignmentProperty |
IsEnabledProperty |
IsTabStopProperty |
JournalOwnershipProperty |
PaddingProperty |
SourceProperty |
TabIndexProperty |
TabNavigationProperty |
VerticalContentAlignmentProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BorderBrush |
Public property | BorderThickness |
Public property | CacheSize |
Public property | CanGoBack |
Public property | CanGoForward |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | CurrentSource |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | JournalOwnership |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Source |
Public property | TabIndex |
Public property | TabNavigation |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Frame Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Constructor
Frame Class See Also Send Feedback
Initializes a new instance of the Frame class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Frame()
Visual Basic
Public Sub New
Visual C++
public:
Frame()

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Frame Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Fields
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
CacheSizeProperty |
CanGoBackProperty |
CanGoForwardProperty |
CurrentSourceProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
HorizontalContentAlignmentProperty |
IsEnabledProperty |
IsTabStopProperty |
JournalOwnershipProperty |
PaddingProperty |
SourceProperty |
TabIndexProperty |
TabNavigationProperty |
VerticalContentAlignmentProperty |

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..BackgroundProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..BorderBrushProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.BorderBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderBrushProperty
Visual Basic
Public Shared BorderBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderBrushProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..BorderThicknessProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.BorderThicknessProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderThicknessProperty
Visual Basic
Public Shared BorderThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderThicknessProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CacheSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CacheSizeProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.CacheSizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CacheSizeProperty
Visual Basic
Public Shared CacheSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CacheSizeProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanGoBackProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CanGoBackProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.CanGoBackProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoBackProperty
Visual Basic
Public Shared CanGoBackProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoBackProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanGoForwardProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CanGoForwardProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.CanGoForwardProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanGoForwardProperty
Visual Basic
Public Shared CanGoForwardProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanGoForwardProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CurrentSourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CurrentSourceProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.CurrentSourceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CurrentSourceProperty
Visual Basic
Public Shared CurrentSourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CurrentSourceProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontFamilyProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontSizeProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontStretchProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.FontStretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStretchProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontStyleProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.FontStyleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStyleProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontWeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontWeightProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.FontWeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontWeightProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..ForegroundProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalContentAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..HorizontalContentAlignmentProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.HorizontalContentAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalContentAlignmentProperty
Visual Basic
Public Shared HorizontalContentAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalContentAlignmentProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..IsEnabledProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.IsEnabledProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEnabledProperty
Visual Basic
Public Shared IsEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEnabledProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTabStopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..IsTabStopProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.IsTabStopProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTabStopProperty
Visual Basic
Public Shared IsTabStopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTabStopProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


JournalOwnershipProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..JournalOwnershipProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.JournalOwnershipProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty JournalOwnershipProperty
Visual Basic
Public Shared JournalOwnershipProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ JournalOwnershipProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..PaddingProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.PaddingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PaddingProperty
Visual Basic
Public Shared PaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PaddingProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..SourceProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.SourceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..TabIndexProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.TabIndexProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabIndexProperty
Visual Basic
Public Shared TabIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabIndexProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabNavigationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..TabNavigationProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.TabNavigationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabNavigationProperty
Visual Basic
Public Shared TabNavigationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabNavigationProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalContentAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..VerticalContentAlignmentProperty Field
Frame Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Frame.VerticalContentAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalContentAlignmentProperty
Visual Basic
Public Shared VerticalContentAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalContentAlignmentProperty

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Frame Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Methods
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..AnySibling Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..GetProperty Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..GetRealType Method
Frame Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Frame.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Frame.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..GetRectangle Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Highlight Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..InvokeMethod Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..IsHitTest Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..NextSibling Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Parent Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..PreviousSibling Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..ScrollToVisible Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..SetProperty Method
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Frame Class
Frame Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Frame Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame Properties
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BorderBrush |
Public property | BorderThickness |
Public property | CacheSize |
Public property | CanGoBack |
Public property | CanGoForward |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | CurrentSource |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | JournalOwnership |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Source |
Public property | TabIndex |
Public property | TabNavigation |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Background Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Background Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.Background"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Background { get; set; }
Visual Basic
Public Property Background As Brush
    Get
    Set
Visual C++
public:
property Brush^ Background {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderBrush Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..BorderBrush Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.BorderBrush"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush BorderBrush { get; set; }
Visual Basic
Public Property BorderBrush As Brush
    Get
    Set
Visual C++
public:
property Brush^ BorderBrush {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderThickness Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..BorderThickness Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.BorderThickness"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness BorderThickness { get; set; }
Visual Basic
Public Property BorderThickness As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ BorderThickness {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CacheSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CacheSize Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.CacheSize"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int CacheSize { get; set; }
Visual Basic
Public Property CacheSize As Integer
    Get
    Set
Visual C++
public:
property int CacheSize {
    int get ();
    void set (int value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanGoBack Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CanGoBack Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.CanGoBack"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoBack { get; set; }
Visual Basic
Public Property CanGoBack As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoBack {
    bool get ();
    void set (bool value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanGoForward Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CanGoForward Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.CanGoForward"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool CanGoForward { get; set; }
Visual Basic
Public Property CanGoForward As Boolean
    Get
    Set
Visual C++
public:
property bool CanGoForward {
    bool get ();
    void set (bool value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CurrentSource Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..CurrentSource Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.CurrentSource"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string CurrentSource { get; }
Visual Basic
Public ReadOnly Property CurrentSource As String
    Get
Visual C++
public:
property String^ CurrentSource {
    String^ get ();
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontFamily Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontFamily Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.FontFamily"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic
Public ReadOnly Property FontFamily As FontFamily
    Get
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontSize Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.FontSize"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic
Public Property FontSize As Double
    Get
    Set
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStretch Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontStretch Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.FontStretch"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic
Public ReadOnly Property FontStretch As FontStretch
    Get
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStyle Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontStyle Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.FontStyle"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontStyle FontStyle { get; }
Visual Basic
Public ReadOnly Property FontStyle As FontStyle
    Get
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontWeight Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..FontWeight Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.FontWeight"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic
Public ReadOnly Property FontWeight As FontWeight
    Get
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Foreground Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Foreground Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.Foreground"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic
Public Property Foreground As Brush
    Get
    Set
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalContentAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..HorizontalContentAlignment Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.HorizontalContentAlignment"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HorizontalAlignment HorizontalContentAlignment { get; set; }
Visual Basic
Public Property HorizontalContentAlignment As HorizontalAlignment
    Get
    Set
Visual C++
public:
property HorizontalAlignment HorizontalContentAlignment {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsEnabled Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..IsEnabled Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.IsEnabled"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic
Public Property IsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTabStop Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..IsTabStop Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.IsTabStop"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool IsTabStop { get; set; }
Visual Basic
Public Property IsTabStop As Boolean
    Get
    Set
Visual C++
public:
property bool IsTabStop {
    bool get ();
    void set (bool value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


JournalOwnership Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..JournalOwnership Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.JournalOwnership"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public JournalOwnership JournalOwnership { get; set; }
Visual Basic
Public Property JournalOwnership As JournalOwnership
    Get
    Set
Visual C++
public:
property JournalOwnership JournalOwnership {
    JournalOwnership get ();
    void set (JournalOwnership value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Padding Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Padding Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.Padding"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness Padding { get; set; }
Visual Basic
Public Property Padding As Thickness
    Get
    Set
Visual C++
public:
property Thickness^ Padding {
    Thickness^ get ();
    void set (Thickness^ value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Source Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..Source Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.Source"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Source { get; }
Visual Basic
Public ReadOnly Property Source As String
    Get
Visual C++
public:
property String^ Source {
    String^ get ();
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabIndex Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..TabIndex Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.TabIndex"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public int TabIndex { get; set; }
Visual Basic
Public Property TabIndex As Integer
    Get
    Set
Visual C++
public:
property int TabIndex {
    int get ();
    void set (int value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabNavigation Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..TabNavigation Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.TabNavigation"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public KeyboardNavigationMode TabNavigation { get; set; }
Visual Basic
Public Property TabNavigation As KeyboardNavigationMode
    Get
    Set
Visual C++
public:
property KeyboardNavigationMode TabNavigation {
    KeyboardNavigationMode get ();
    void set (KeyboardNavigationMode value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalContentAlignment Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Frame..::..VerticalContentAlignment Property
Frame Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Frame.VerticalContentAlignment"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VerticalAlignment VerticalContentAlignment { get; set; }
Visual Basic
Public Property VerticalContentAlignment As VerticalAlignment
    Get
    Set
Visual C++
public:
property VerticalAlignment VerticalContentAlignment {
    VerticalAlignment get ();
    void set (VerticalAlignment value);
}

See Also

Frame Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Geometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Members
Geometry Class Constructors Methods Fields Properties See Also Send Feedback

The Geometry type exposes the following members.

Constructors

 | Name | Description
Public method | Geometry | Initializes a new instance of the Geometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BoundsProperty |
TransformProperty |

Properties

 | Name | Description
Public property | Bounds |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform |

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Geometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Constructor
Geometry Class See Also Send Feedback
Initializes a new instance of the Geometry class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Geometry()
Visual Basic
Public Sub New
Visual C++
public:
Geometry()

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Geometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Fields
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Fields

Name | Description
BoundsProperty |
TransformProperty |

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BoundsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..BoundsProperty Field
Geometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Geometry.BoundsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BoundsProperty
Visual Basic
Public Shared BoundsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BoundsProperty

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TransformProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..TransformProperty Field
Geometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Geometry.TransformProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TransformProperty
Visual Basic
Public Shared TransformProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TransformProperty

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Geometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Methods
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..GetProperty Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Geometry Class
Geometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..GetRealType Method
Geometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Geometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Geometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..InvokeMethod Method
Geometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Geometry Class
Geometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Geometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry Properties
Geometry Class See Also Send Feedback

The Geometry type exposes the following members.

Properties

 | Name | Description
Public property | Bounds |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform |

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Bounds Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..Bounds Property
Geometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Geometry.Bounds"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect Bounds { get; set; }
Visual Basic
Public Property Bounds As Rect
    Get
    Set
Visual C++
public:
property Rect^ Bounds {
    Rect^ get ();
    void set (Rect^ value);
}

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Transform Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Geometry..::..Transform Property
Geometry Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Geometry.Transform"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform Transform { get; set; }
Visual Basic
Public Property Transform As Transform
    Get
    Set
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

See Also

Geometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GeometryGroup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup Members
GeometryGroup Class Constructors Methods Fields Properties See Also Send Feedback

The GeometryGroup type exposes the following members.

Constructors

 | Name | Description
Public method | GeometryGroup | Initializes a new instance of the GeometryGroup class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ChildrenProperty |
FillRuleProperty |

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | Children |
Public property | FillRule |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GeometryGroup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup Constructor
GeometryGroup Class See Also Send Feedback
Initializes a new instance of the GeometryGroup class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GeometryGroup()
Visual Basic
Public Sub New
Visual C++
public:
GeometryGroup()

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GeometryGroup Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup Fields
GeometryGroup Class See Also Send Feedback

The GeometryGroup type exposes the following members.

Fields

Name | Description
ChildrenProperty |
FillRuleProperty |

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ChildrenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup..::..ChildrenProperty Field
GeometryGroup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GeometryGroup.ChildrenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ChildrenProperty
Visual Basic
Public Shared ChildrenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ChildrenProperty

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FillRuleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup..::..FillRuleProperty Field
GeometryGroup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GeometryGroup.FillRuleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillRuleProperty
Visual Basic
Public Shared FillRuleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillRuleProperty

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GeometryGroup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup Methods
GeometryGroup Class See Also Send Feedback

The GeometryGroup type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup..::..GetProperty Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GeometryGroup Class
GeometryGroup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup..::..GetRealType Method
GeometryGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.GeometryGroup.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.GeometryGroup.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup..::..InvokeMethod Method
GeometryGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GeometryGroup Class
GeometryGroup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GeometryGroup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup Properties
GeometryGroup Class See Also Send Feedback

The GeometryGroup type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | Children |
Public property | FillRule |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Children Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup..::..Children Property
GeometryGroup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GeometryGroup.Children"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<Geometry> Children { get; set; }
Visual Basic
Public Property Children As List(Of Geometry)
    Get
    Set
Visual C++
public:
property List<Geometry^>^ Children {
    List<Geometry^>^ get ();
    void set (List<Geometry^>^ value);
}

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FillRule Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GeometryGroup..::..FillRule Property
GeometryGroup Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GeometryGroup.FillRule"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FillRule FillRule { get; set; }
Visual Basic
Public Property FillRule As FillRule
    Get
    Set
Visual C++
public:
property FillRule FillRule {
    FillRule get ();
    void set (FillRule value);
}

See Also

GeometryGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Glyphs Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Members
Glyphs Class Constructors Methods Fields Properties See Also Send Feedback

The Glyphs type exposes the following members.

Constructors

 | Name | Description
Public method | Glyphs | Initializes a new instance of the Glyphs class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FillProperty |
FontRenderingEmSizeProperty |
FontUriProperty |
IndicesProperty |
OriginXProperty |
OriginYProperty |
StyleSimulationsProperty |
UnicodeStringProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontRenderingEmSize |
Public property | FontUri |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Indices |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OriginX |
Public property | OriginY |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | StyleSimulations |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UnicodeString |
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Glyphs Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Constructor
Glyphs Class See Also Send Feedback
Initializes a new instance of the Glyphs class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Glyphs()
Visual Basic
Public Sub New
Visual C++
public:
Glyphs()

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Glyphs Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Fields
Glyphs Class See Also Send Feedback

The Glyphs type exposes the following members.

Fields

Name | Description
FillProperty |
FontRenderingEmSizeProperty |
FontUriProperty |
IndicesProperty |
OriginXProperty |
OriginYProperty |
StyleSimulationsProperty |
UnicodeStringProperty |

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FillProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FillProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Glyphs.FillProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillProperty
Visual Basic
Public Shared FillProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontRenderingEmSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FontRenderingEmSizeProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Glyphs.FontRenderingEmSizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontRenderingEmSizeProperty
Visual Basic
Public Shared FontRenderingEmSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontRenderingEmSizeProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontUriProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FontUriProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Glyphs.FontUriProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontUriProperty
Visual Basic
Public Shared FontUriProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontUriProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IndicesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..IndicesProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Glyphs.IndicesProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IndicesProperty
Visual Basic
Public Shared IndicesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IndicesProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OriginXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..OriginXProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Glyphs.OriginXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OriginXProperty
Visual Basic
Public Shared OriginXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OriginXProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OriginYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..OriginYProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Glyphs.OriginYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OriginYProperty
Visual Basic
Public Shared OriginYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OriginYProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StyleSimulationsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..StyleSimulationsProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Glyphs.StyleSimulationsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StyleSimulationsProperty
Visual Basic
Public Shared StyleSimulationsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StyleSimulationsProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UnicodeStringProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..UnicodeStringProperty Field
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Glyphs.UnicodeStringProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UnicodeStringProperty
Visual Basic
Public Shared UnicodeStringProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UnicodeStringProperty

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Glyphs Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Methods
Glyphs Class See Also Send Feedback

The Glyphs type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..AnySibling Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..GetProperty Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..GetRealType Method
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Glyphs.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Glyphs.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..GetRectangle Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..Highlight Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..InvokeMethod Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..IsHitTest Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..NextSibling Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..Parent Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..PreviousSibling Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..ScrollToVisible Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..SetProperty Method
Glyphs Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Glyphs Class
Glyphs Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Glyphs Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs Properties
Glyphs Class See Also Send Feedback

The Glyphs type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontRenderingEmSize |
Public property | FontUri |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Indices |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | OriginX |
Public property | OriginY |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | StyleSimulations |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UnicodeString |
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Fill Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..Fill Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Glyphs.Fill"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Brush Fill { get; set; }
Visual Basic
Public Property Fill As Brush
    Get
    Set
Visual C++
public:
property Brush^ Fill {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontRenderingEmSize Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FontRenderingEmSize Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Glyphs.FontRenderingEmSize"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double FontRenderingEmSize { get; set; }
Visual Basic
Public Property FontRenderingEmSize As Double
    Get
    Set
Visual C++
public:
property double FontRenderingEmSize {
    double get ();
    void set (double value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontUri Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..FontUri Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Glyphs.FontUri"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string FontUri { get; }
Visual Basic
Public ReadOnly Property FontUri As String
    Get
Visual C++
public:
property String^ FontUri {
    String^ get ();
}

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Indices Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..Indices Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Glyphs.Indices"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string Indices { get; set; }
Visual Basic
Public Property Indices As String
    Get
    Set
Visual C++
public:
property String^ Indices {
    String^ get ();
    void set (String^ value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OriginX Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..OriginX Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Glyphs.OriginX"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double OriginX { get; set; }
Visual Basic
Public Property OriginX As Double
    Get
    Set
Visual C++
public:
property double OriginX {
    double get ();
    void set (double value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OriginY Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..OriginY Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Glyphs.OriginY"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double OriginY { get; set; }
Visual Basic
Public Property OriginY As Double
    Get
    Set
Visual C++
public:
property double OriginY {
    double get ();
    void set (double value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StyleSimulations Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..StyleSimulations Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Glyphs.StyleSimulations"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StyleSimulations StyleSimulations { get; set; }
Visual Basic
Public Property StyleSimulations As StyleSimulations
    Get
    Set
Visual C++
public:
property StyleSimulations StyleSimulations {
    StyleSimulations get ();
    void set (StyleSimulations value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UnicodeString Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Glyphs..::..UnicodeString Property
Glyphs Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.Glyphs.UnicodeString"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public string UnicodeString { get; set; }
Visual Basic
Public Property UnicodeString As String
    Get
    Set
Visual C++
public:
property String^ UnicodeString {
    String^ get ();
    void set (String^ value);
}

See Also

Glyphs Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Members
GradientBrush Class Constructors Methods Fields Properties See Also Send Feedback

The GradientBrush type exposes the following members.

Constructors

 | Name | Description
Public method | GradientBrush | Initializes a new instance of the GradientBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ColorInterpolationModeProperty |
GradientStopsProperty |
MappingModeProperty |
SpreadMethodProperty |

Properties

 | Name | Description
Public property | ColorInterpolationMode |
Public property | GradientStops |
Public property | MappingMode |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod |
Public property | Transform | (Inherited from Brush.)

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Constructor
GradientBrush Class See Also Send Feedback
Initializes a new instance of the GradientBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GradientBrush()
Visual Basic
Public Sub New
Visual C++
public:
GradientBrush()

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Fields
GradientBrush Class See Also Send Feedback

The GradientBrush type exposes the following members.

Fields

Name | Description
ColorInterpolationModeProperty |
GradientStopsProperty |
MappingModeProperty |
SpreadMethodProperty |

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColorInterpolationModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..ColorInterpolationModeProperty Field
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.ColorInterpolationModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColorInterpolationModeProperty
Visual Basic
Public Shared ColorInterpolationModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColorInterpolationModeProperty

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientStopsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..GradientStopsProperty Field
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.GradientStopsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GradientStopsProperty
Visual Basic
Public Shared GradientStopsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GradientStopsProperty

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MappingModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..MappingModeProperty Field
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.MappingModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MappingModeProperty
Visual Basic
Public Shared MappingModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MappingModeProperty

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SpreadMethodProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..SpreadMethodProperty Field
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.SpreadMethodProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SpreadMethodProperty
Visual Basic
Public Shared SpreadMethodProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SpreadMethodProperty

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Methods
GradientBrush Class See Also Send Feedback

The GradientBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..GetProperty Method
GradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientBrush Class
GradientBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..GetRealType Method
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..InvokeMethod Method
GradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientBrush Class
GradientBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush Properties
GradientBrush Class See Also Send Feedback

The GradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | ColorInterpolationMode |
Public property | GradientStops |
Public property | MappingMode |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod |
Public property | Transform | (Inherited from Brush.)

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColorInterpolationMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..ColorInterpolationMode Property
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.ColorInterpolationMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ColorInterpolationMode ColorInterpolationMode { get; set; }
Visual Basic
Public Property ColorInterpolationMode As ColorInterpolationMode
    Get
    Set
Visual C++
public:
property ColorInterpolationMode ColorInterpolationMode {
    ColorInterpolationMode get ();
    void set (ColorInterpolationMode value);
}

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientStops Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..GradientStops Property
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.GradientStops"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public List<GradientStop> GradientStops { get; set; }
Visual Basic
Public Property GradientStops As List(Of GradientStop)
    Get
    Set
Visual C++
public:
property List<GradientStop^>^ GradientStops {
    List<GradientStop^>^ get ();
    void set (List<GradientStop^>^ value);
}

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MappingMode Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..MappingMode Property
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.MappingMode"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BrushMappingMode MappingMode { get; set; }
Visual Basic
Public Property MappingMode As BrushMappingMode
    Get
    Set
Visual C++
public:
property BrushMappingMode MappingMode {
    BrushMappingMode get ();
    void set (BrushMappingMode value);
}

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SpreadMethod Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientBrush..::..SpreadMethod Property
GradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GradientBrush.SpreadMethod"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GradientSpreadMethod SpreadMethod { get; set; }
Visual Basic
Public Property SpreadMethod As GradientSpreadMethod
    Get
    Set
Visual C++
public:
property GradientSpreadMethod SpreadMethod {
    GradientSpreadMethod get ();
    void set (GradientSpreadMethod value);
}

See Also

GradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientStop Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Members
GradientStop Class Constructors Methods Fields Properties See Also Send Feedback

The GradientStop type exposes the following members.

Constructors

 | Name | Description
Public method | GradientStop | Initializes a new instance of the GradientStop class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ColorProperty |
OffsetProperty |

Properties

 | Name | Description
Public property | Color |
Public property | Offset |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientStop Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Constructor
GradientStop Class See Also Send Feedback
Initializes a new instance of the GradientStop class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GradientStop()
Visual Basic
Public Sub New
Visual C++
public:
GradientStop()

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientStop Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Fields
GradientStop Class See Also Send Feedback

The GradientStop type exposes the following members.

Fields

Name | Description
ColorProperty |
OffsetProperty |

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..ColorProperty Field
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GradientStop.ColorProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColorProperty
Visual Basic
Public Shared ColorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColorProperty

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..OffsetProperty Field
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GradientStop.OffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetProperty
Visual Basic
Public Shared OffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetProperty

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientStop Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Methods
GradientStop Class See Also Send Feedback

The GradientStop type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..GetProperty Method
GradientStop Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientStop Class
GradientStop Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..GetRealType Method
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.GradientStop.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.GradientStop.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..InvokeMethod Method
GradientStop Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientStop Class
GradientStop Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientStop Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop Properties
GradientStop Class See Also Send Feedback

The GradientStop type exposes the following members.

Properties

 | Name | Description
Public property | Color |
Public property | Offset |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Color Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..Color Property
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GradientStop.Color"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Offset Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GradientStop..::..Offset Property
GradientStop Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GradientStop.Offset"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public double Offset { get; set; }
Visual Basic
Public Property Offset As Double
    Get
    Set
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

See Also

GradientStop Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Grid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Members
Grid Class Constructors Methods Fields Properties See Also Send Feedback

The Grid type exposes the following members.

Constructors

 | Name | Description
Public method | Grid | Initializes a new instance of the Grid class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ShowGridLinesProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowGridLines |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Grid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Grid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Constructor
Grid Class See Also Send Feedback
Initializes a new instance of the Grid class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Grid()
Visual Basic
Public Sub New
Visual C++
public:
Grid()

See Also

Grid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Grid Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Fields
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Fields

Name | Description
ShowGridLinesProperty |

See Also

Grid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ShowGridLinesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..ShowGridLinesProperty Field
Grid Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Grid.ShowGridLinesProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ShowGridLinesProperty
Visual Basic
Public Shared ShowGridLinesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ShowGridLinesProperty

See Also

Grid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Grid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Methods
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Grid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..AnySibling Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..GetProperty Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..GetRealType Method
Grid Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Grid.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Grid.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Grid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..GetRectangle Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..Highlight Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..InvokeMethod Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..IsHitTest Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..NextSibling Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..Parent Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..PreviousSibling Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..ScrollToVisible Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid..::..SetProperty Method
Grid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Grid Class
Grid Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Grid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Grid Properties
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowGridLines |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Grid Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GridSplitter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Members
GridSplitter Class Constructors Methods Fields Properties See Also Send Feedback

The GridSplitter type exposes the following members.

Constructors

 | Name | Description
Public method | GridSplitter | Initializes a new instance of the GridSplitter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ShowsPreviewProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowsPreview |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridSplitter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GridSplitter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Constructor
GridSplitter Class See Also Send Feedback
Initializes a new instance of the GridSplitter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GridSplitter()
Visual Basic
Public Sub New
Visual C++
public:
GridSplitter()

See Also

GridSplitter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GridSplitter Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Fields
GridSplitter Class See Also Send Feedback

The GridSplitter type exposes the following members.

Fields

Name | Description
ShowsPreviewProperty |

See Also

GridSplitter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ShowsPreviewProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ShowsPreviewProperty Field
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.GridSplitter.ShowsPreviewProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ShowsPreviewProperty
Visual Basic
Public Shared ShowsPreviewProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ShowsPreviewProperty

See Also

GridSplitter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GridSplitter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Methods
GridSplitter Class See Also Send Feedback

The GridSplitter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..AnySibling Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..GetProperty Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..GetRealType Method
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.GridSplitter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.GridSplitter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

GridSplitter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..GetRectangle Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..Highlight Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..InvokeMethod Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..IsHitTest Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..NextSibling Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..Parent Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..PreviousSibling Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ScrollToVisible Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..SetProperty Method
GridSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

GridSplitter Class
GridSplitter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GridSplitter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter Properties
GridSplitter Class See Also Send Feedback

The GridSplitter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ShowsPreview |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

GridSplitter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ShowsPreview Property

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridSplitter..::..ShowsPreview Property
GridSplitter Class See Also Send Feedback

[Missing <summary> documentation for "P:ArtOfTest.WebAii.Silverlight.UI.GridSplitter.ShowsPreview"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool ShowsPreview { get; set; }
Visual Basic
Public Property ShowsPreview As Boolean
    Get
    Set
Visual C++
public:
property bool ShowsPreview {
    bool get ();
    void set (bool value);
}

See Also

GridSplitter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeaderedItemsControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Members
HeaderedItemsControl Class Constructors Methods Properties See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Constructors

 | Name | Description
Public method | HeaderedItemsControl | Initializes a new instance of the HeaderedItemsControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeaderedItemsControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Constructor
HeaderedItemsControl Class See Also Send Feedback
Initializes a new instance of the HeaderedItemsControl class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HeaderedItemsControl()
Visual Basic
Public Sub New
Visual C++
public:
HeaderedItemsControl()

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeaderedItemsControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Methods
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..AnySibling Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..GetProperty Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..GetRealType Method
HeaderedItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.HeaderedItemsControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.HeaderedItemsControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..GetRectangle Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..Highlight Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..InvokeMethod Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..IsHitTest Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..NextSibling Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..Parent Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..PreviousSibling Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..ScrollToVisible Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl..::..SetProperty Method
HeaderedItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HeaderedItemsControl Class
HeaderedItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


HeaderedItemsControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HeaderedItemsControl Properties
HeaderedItemsControl Class See Also Send Feedback

The HeaderedItemsControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HeaderedItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HyperlinkButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton Members
HyperlinkButton Class Constructors Methods Fields Properties See Also Send Feedback

The HyperlinkButton type exposes the following members.

Constructors

 | Name | Description
Public method | HyperlinkButton | Initializes a new instance of the HyperlinkButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
NavigateUriProperty |
TargetNameProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NavigateUri |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TargetName |
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HyperlinkButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton Constructor
HyperlinkButton Class See Also Send Feedback
Initializes a new instance of the HyperlinkButton class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HyperlinkButton()
Visual Basic
Public Sub New
Visual C++
public:
HyperlinkButton()

See Also

HyperlinkButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HyperlinkButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton Fields
HyperlinkButton Class See Also Send Feedback

The HyperlinkButton type exposes the following members.

Fields

Name | Description
NavigateUriProperty |
TargetNameProperty |

See Also

HyperlinkButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


NavigateUriProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..NavigateUriProperty Field
HyperlinkButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.HyperlinkButton.NavigateUriProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NavigateUriProperty
Visual Basic
Public Shared NavigateUriProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NavigateUriProperty

See Also

HyperlinkButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TargetNameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..TargetNameProperty Field
HyperlinkButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.HyperlinkButton.TargetNameProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TargetNameProperty
Visual Basic
Public Shared TargetNameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TargetNameProperty

See Also

HyperlinkButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HyperlinkButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton Methods
HyperlinkButton Class See Also Send Feedback

The HyperlinkButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..AnySibling Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..GetProperty Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..GetRealType Method
HyperlinkButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.HyperlinkButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.HyperlinkButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

HyperlinkButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..GetRectangle Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..Highlight Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..InvokeMethod Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..IsHitTest Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..NextSibling Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..Parent Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..PreviousSibling Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..ScrollToVisible Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton..::..SetProperty Method
HyperlinkButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

HyperlinkButton Class
HyperlinkButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


HyperlinkButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HyperlinkButton Properties
HyperlinkButton Class See Also Send Feedback

The HyperlinkButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NavigateUri |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TargetName |
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

HyperlinkButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Image Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Members
Image Class Constructors Methods Fields Properties See Also Send Feedback

The Image type exposes the following members.

Constructors

 | Name | Description
Public method | Image | Initializes a new instance of the Image class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SourceProperty |
StretchProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Source |
Public property | Stretch |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Image Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Image Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Constructor
Image Class See Also Send Feedback
Initializes a new instance of the Image class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Image()
Visual Basic
Public Sub New
Visual C++
public:
Image()

See Also

Image Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Image Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Fields
Image Class See Also Send Feedback

The Image type exposes the following members.

Fields

Name | Description
SourceProperty |
StretchProperty |

See Also

Image Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..SourceProperty Field
Image Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Image.SourceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

Image Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..StretchProperty Field
Image Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Image.StretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

Image Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Image Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Methods
Image Class See Also Send Feedback

The Image type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Image Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..AnySibling Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..GetProperty Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..GetRealType Method
Image Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Image.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Image.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Image Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..GetRectangle Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..Highlight Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..InvokeMethod Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..IsHitTest Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..NextSibling Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..Parent Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..PreviousSibling Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..ScrollToVisible Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image..::..SetProperty Method
Image Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Image Class
Image Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Image Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Image Properties
Image Class See Also Send Feedback

The Image type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Source |
Public property | Stretch |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Image Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Members
ImageBrush Class Constructors Methods Fields Properties See Also Send Feedback

The ImageBrush type exposes the following members.

Constructors

 | Name | Description
Public method | ImageBrush | Initializes a new instance of the ImageBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ImageSourceProperty |

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | ImageSource |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

ImageBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Constructor
ImageBrush Class See Also Send Feedback
Initializes a new instance of the ImageBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageBrush()
Visual Basic
Public Sub New
Visual C++
public:
ImageBrush()

See Also

ImageBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Fields
ImageBrush Class See Also Send Feedback

The ImageBrush type exposes the following members.

Fields

Name | Description
ImageSourceProperty |

See Also

ImageBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageSourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..ImageSourceProperty Field
ImageBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ImageBrush.ImageSourceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ImageSourceProperty
Visual Basic
Public Shared ImageSourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ImageSourceProperty

See Also

ImageBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Methods
ImageBrush Class See Also Send Feedback

The ImageBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..GetProperty Method
ImageBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageBrush Class
ImageBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..GetRealType Method
ImageBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ImageBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ImageBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ImageBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush..::..InvokeMethod Method
ImageBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageBrush Class
ImageBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageBrush Properties
ImageBrush Class See Also Send Feedback

The ImageBrush type exposes the following members.

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | ImageSource |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

ImageBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageSource Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource Members
ImageSource Class Constructors Methods Properties See Also Send Feedback

The ImageSource type exposes the following members.

Constructors

 | Name | Description
Public method | ImageSource | Initializes a new instance of the ImageSource class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageSource Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource Constructor
ImageSource Class See Also Send Feedback
Initializes a new instance of the ImageSource class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImageSource()
Visual Basic
Public Sub New
Visual C++
public:
ImageSource()

See Also

ImageSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageSource Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource Methods
ImageSource Class See Also Send Feedback

The ImageSource type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource..::..GetProperty Method
ImageSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageSource Class
ImageSource Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource..::..GetRealType Method
ImageSource Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ImageSource.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ImageSource.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ImageSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource..::..InvokeMethod Method
ImageSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageSource Class
ImageSource Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ImageSource Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageSource Properties
ImageSource Class See Also Send Feedback

The ImageSource type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImageSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImplicitInputBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush Members
ImplicitInputBrush Class Constructors Methods Properties See Also Send Feedback

The ImplicitInputBrush type exposes the following members.

Constructors

 | Name | Description
Public method | ImplicitInputBrush | Initializes a new instance of the ImplicitInputBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Transform | (Inherited from Brush.)

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImplicitInputBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush Constructor
ImplicitInputBrush Class See Also Send Feedback
Initializes a new instance of the ImplicitInputBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ImplicitInputBrush()
Visual Basic
Public Sub New
Visual C++
public:
ImplicitInputBrush()

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ImplicitInputBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush Methods
ImplicitInputBrush Class See Also Send Feedback

The ImplicitInputBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush..::..GetProperty Method
ImplicitInputBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImplicitInputBrush Class
ImplicitInputBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush..::..GetRealType Method
ImplicitInputBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ImplicitInputBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ImplicitInputBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush..::..InvokeMethod Method
ImplicitInputBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ImplicitInputBrush Class
ImplicitInputBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ImplicitInputBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImplicitInputBrush Properties
ImplicitInputBrush Class See Also Send Feedback

The ImplicitInputBrush type exposes the following members.

Properties

 | Name | Description
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Transform | (Inherited from Brush.)

See Also

ImplicitInputBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InkPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter Members
InkPresenter Class Constructors Methods Properties See Also Send Feedback

The InkPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | InkPresenter | Initializes a new instance of the InkPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Canvas..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

InkPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InkPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter Constructor
InkPresenter Class See Also Send Feedback
Initializes a new instance of the InkPresenter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InkPresenter()
Visual Basic
Public Sub New
Visual C++
public:
InkPresenter()

See Also

InkPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InkPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter Methods
InkPresenter Class See Also Send Feedback

The InkPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Canvas..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..AnySibling Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..GetProperty Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..GetRealType Method
InkPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.InkPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.InkPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

InkPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..GetRectangle Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..Highlight Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..InvokeMethod Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..IsHitTest Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..NextSibling Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..Parent Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..PreviousSibling Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..ScrollToVisible Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter..::..SetProperty Method
InkPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InkPresenter Class
InkPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InkPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InkPresenter Properties
InkPresenter Class See Also Send Feedback

The InkPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

InkPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InputScope Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputScope Members
InputScope Class Constructors Methods Properties See Also Send Feedback

The InputScope type exposes the following members.

Constructors

 | Name | Description
Public method | InputScope | Initializes a new instance of the InputScope class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InputScope Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InputScope Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputScope Constructor
InputScope Class See Also Send Feedback
Initializes a new instance of the InputScope class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public InputScope()
Visual Basic
Public Sub New
Visual C++
public:
InputScope()

See Also

InputScope Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InputScope Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputScope Methods
InputScope Class See Also Send Feedback

The InputScope type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InputScope Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputScope..::..GetProperty Method
InputScope Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InputScope Class
InputScope Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputScope..::..GetRealType Method
InputScope Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.InputScope.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.InputScope.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

InputScope Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputScope..::..InvokeMethod Method
InputScope Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InputScope Class
InputScope Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InputScope Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputScope Properties
InputScope Class See Also Send Feedback

The InputScope type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

InputScope Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Members
ItemsControl Class Constructors Methods Fields Properties See Also Send Feedback

The ItemsControl type exposes the following members.

Constructors

 | Name | Description
Public method | ItemsControl | Initializes a new instance of the ItemsControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DisplayMemberPathProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Constructor
ItemsControl Class See Also Send Feedback
Initializes a new instance of the ItemsControl class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ItemsControl()
Visual Basic
Public Sub New
Visual C++
public:
ItemsControl()

See Also

ItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Fields
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Fields

Name | Description
DisplayMemberPathProperty |

See Also

ItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DisplayMemberPathProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..DisplayMemberPathProperty Field
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ItemsControl.DisplayMemberPathProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DisplayMemberPathProperty
Visual Basic
Public Shared DisplayMemberPathProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DisplayMemberPathProperty

See Also

ItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Methods
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..AnySibling Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..GetProperty Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..GetRealType Method
ItemsControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ItemsControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ItemsControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..GetRectangle Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..Highlight Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..InvokeMethod Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..IsHitTest Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..NextSibling Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..Parent Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..PreviousSibling Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..ScrollToVisible Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl..::..SetProperty Method
ItemsControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsControl Class
ItemsControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsControl Properties
ItemsControl Class See Also Send Feedback

The ItemsControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ItemsControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter Members
ItemsPresenter Class Constructors Methods Properties See Also Send Feedback

The ItemsPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | ItemsPresenter | Initializes a new instance of the ItemsPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter Constructor
ItemsPresenter Class See Also Send Feedback
Initializes a new instance of the ItemsPresenter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ItemsPresenter()
Visual Basic
Public Sub New
Visual C++
public:
ItemsPresenter()

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter Methods
ItemsPresenter Class See Also Send Feedback

The ItemsPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..AnySibling Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..GetProperty Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..GetRealType Method
ItemsPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ItemsPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ItemsPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..GetRectangle Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..Highlight Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..InvokeMethod Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..IsHitTest Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..NextSibling Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..Parent Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..PreviousSibling Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..ScrollToVisible Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter..::..SetProperty Method
ItemsPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ItemsPresenter Class
ItemsPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ItemsPresenter Properties
ItemsPresenter Class See Also Send Feedback

The ItemsPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ItemsPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Label Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Members
Label Class Constructors Methods Fields Properties See Also Send Feedback

The Label type exposes the following members.

Constructors

 | Name | Description
Public method | Label | Initializes a new instance of the Label class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsRequiredProperty |
IsValidProperty |
PropertyPathProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsRequired |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | PropertyPath |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Label Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Constructor
Label Class See Also Send Feedback
Initializes a new instance of the Label class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Label()
Visual Basic
Public Sub New
Visual C++
public:
Label()

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Label Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Fields
Label Class See Also Send Feedback

The Label type exposes the following members.

Fields

Name | Description
IsRequiredProperty |
IsValidProperty |
PropertyPathProperty |

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsRequiredProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..IsRequiredProperty Field
Label Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Label.IsRequiredProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsRequiredProperty
Visual Basic
Public Shared IsRequiredProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsRequiredProperty

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsValidProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..IsValidProperty Field
Label Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Label.IsValidProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsValidProperty
Visual Basic
Public Shared IsValidProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsValidProperty

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PropertyPathProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..PropertyPathProperty Field
Label Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Label.PropertyPathProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PropertyPathProperty
Visual Basic
Public Shared PropertyPathProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PropertyPathProperty

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Label Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Methods
Label Class See Also Send Feedback

The Label type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..AnySibling Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..GetProperty Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..GetRealType Method
Label Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Label.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Label.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..GetRectangle Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..Highlight Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..InvokeMethod Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..IsHitTest Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..NextSibling Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..Parent Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..PreviousSibling Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..ScrollToVisible Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label..::..SetProperty Method
Label Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Label Class
Label Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Label Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Label Properties
Label Class See Also Send Feedback

The Label type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsRequired |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsValid |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | PropertyPath |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Label Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Line Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Members
Line Class Constructors Methods Fields Properties See Also Send Feedback

The Line type exposes the following members.

Constructors

 | Name | Description
Public method | Line | Initializes a new instance of the Line class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
X1Property |
X2Property |
Y1Property |
Y2Property |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | X1 |
Public property | X2 |
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Y1 |
Public property | Y2 |

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Line Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Constructor
Line Class See Also Send Feedback
Initializes a new instance of the Line class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Line()
Visual Basic
Public Sub New
Visual C++
public:
Line()

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Line Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Fields
Line Class See Also Send Feedback

The Line type exposes the following members.

Fields

Name | Description
X1Property |
X2Property |
Y1Property |
Y2Property |

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


X1Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..X1Property Field
Line Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Line.X1Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty X1Property
Visual Basic
Public Shared X1Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ X1Property

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


X2Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..X2Property Field
Line Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Line.X2Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty X2Property
Visual Basic
Public Shared X2Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ X2Property

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Y1Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Y1Property Field
Line Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Line.Y1Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Y1Property
Visual Basic
Public Shared Y1Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Y1Property

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Y2Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Y2Property Field
Line Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Line.Y2Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Y2Property
Visual Basic
Public Shared Y2Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Y2Property

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Line Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..AnySibling Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..GetProperty Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..GetRealType Method
Line Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Line.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Line.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..GetRectangle Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Highlight Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..InvokeMethod Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..IsHitTest Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..NextSibling Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..Parent Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..PreviousSibling Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..ScrollToVisible Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line..::..SetProperty Method
Line Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Line Class
Line Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Line Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | X1 |
Public property | X2 |
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)
Public property | Y1 |
Public property | Y2 |

See Also

Line Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LinearGradientBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Members
LinearGradientBrush Class Constructors Methods Fields Properties See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Constructors

 | Name | Description
Public method | LinearGradientBrush | Initializes a new instance of the LinearGradientBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides GradientBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
EndPointProperty |
StartPointProperty |

Properties

 | Name | Description
Public property | ColorInterpolationMode | (Inherited from GradientBrush.)
Public property | EndPoint |
Public property | GradientStops | (Inherited from GradientBrush.)
Public property | MappingMode | (Inherited from GradientBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod | (Inherited from GradientBrush.)
Public property | StartPoint |
Public property | Transform | (Inherited from Brush.)

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LinearGradientBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Constructor
LinearGradientBrush Class See Also Send Feedback
Initializes a new instance of the LinearGradientBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LinearGradientBrush()
Visual Basic
Public Sub New
Visual C++
public:
LinearGradientBrush()

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LinearGradientBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Fields
LinearGradientBrush Class See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Fields

Name | Description
EndPointProperty |
StartPointProperty |

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


EndPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..EndPointProperty Field
LinearGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.LinearGradientBrush.EndPointProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EndPointProperty
Visual Basic
Public Shared EndPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EndPointProperty

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StartPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..StartPointProperty Field
LinearGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.LinearGradientBrush.StartPointProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StartPointProperty
Visual Basic
Public Shared StartPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StartPointProperty

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LinearGradientBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Methods
LinearGradientBrush Class See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides GradientBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..GetProperty Method
LinearGradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LinearGradientBrush Class
LinearGradientBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..GetRealType Method
LinearGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.LinearGradientBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.LinearGradientBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush..::..InvokeMethod Method
LinearGradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LinearGradientBrush Class
LinearGradientBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


LinearGradientBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LinearGradientBrush Properties
LinearGradientBrush Class See Also Send Feedback

The LinearGradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | ColorInterpolationMode | (Inherited from GradientBrush.)
Public property | EndPoint |
Public property | GradientStops | (Inherited from GradientBrush.)
Public property | MappingMode | (Inherited from GradientBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod | (Inherited from GradientBrush.)
Public property | StartPoint |
Public property | Transform | (Inherited from Brush.)

See Also

LinearGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Members
LineGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The LineGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | LineGeometry | Initializes a new instance of the LineGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
EndPointProperty |
StartPointProperty |

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | EndPoint |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | StartPoint |
Public property | Transform | (Inherited from Geometry.)

See Also

LineGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Constructor
LineGeometry Class See Also Send Feedback
Initializes a new instance of the LineGeometry class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LineGeometry()
Visual Basic
Public Sub New
Visual C++
public:
LineGeometry()

See Also

LineGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Fields
LineGeometry Class See Also Send Feedback

The LineGeometry type exposes the following members.

Fields

Name | Description
EndPointProperty |
StartPointProperty |

See Also

LineGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


EndPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..EndPointProperty Field
LineGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.LineGeometry.EndPointProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty EndPointProperty
Visual Basic
Public Shared EndPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ EndPointProperty

See Also

LineGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StartPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..StartPointProperty Field
LineGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.LineGeometry.StartPointProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StartPointProperty
Visual Basic
Public Shared StartPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StartPointProperty

See Also

LineGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Methods
LineGeometry Class See Also Send Feedback

The LineGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..GetProperty Method
LineGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LineGeometry Class
LineGeometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..GetRealType Method
LineGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.LineGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.LineGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

LineGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry..::..InvokeMethod Method
LineGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LineGeometry Class
LineGeometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


LineGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineGeometry Properties
LineGeometry Class See Also Send Feedback

The LineGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | EndPoint |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | StartPoint |
Public property | Transform | (Inherited from Geometry.)

See Also

LineGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineSegment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment Members
LineSegment Class Constructors Methods Fields Properties See Also Send Feedback

The LineSegment type exposes the following members.

Constructors

 | Name | Description
Public method | LineSegment | Initializes a new instance of the LineSegment class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PointProperty |

Properties

 | Name | Description
Public property | Point |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineSegment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment Constructor
LineSegment Class See Also Send Feedback
Initializes a new instance of the LineSegment class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public LineSegment()
Visual Basic
Public Sub New
Visual C++
public:
LineSegment()

See Also

LineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineSegment Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment Fields
LineSegment Class See Also Send Feedback

The LineSegment type exposes the following members.

Fields

Name | Description
PointProperty |

See Also

LineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment..::..PointProperty Field
LineSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.LineSegment.PointProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PointProperty
Visual Basic
Public Shared PointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PointProperty

See Also

LineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineSegment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment Methods
LineSegment Class See Also Send Feedback

The LineSegment type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment..::..GetProperty Method
LineSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LineSegment Class
LineSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment..::..GetRealType Method
LineSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.LineSegment.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.LineSegment.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

LineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment..::..InvokeMethod Method
LineSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LineSegment Class
LineSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


LineSegment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LineSegment Properties
LineSegment Class See Also Send Feedback

The LineSegment type exposes the following members.

Properties

 | Name | Description
Public property | Point |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

LineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Members
ListBox Class Constructors Methods Fields Properties See Also Send Feedback

The ListBox type exposes the following members.

Constructors

 | Name | Description
Public method | ListBox | Initializes a new instance of the ListBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ItemsProperty |
SelectionModeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Items |
Public property | ItemsPanel | Get the element holding the list box items.
Public property | ListBoxItems | Get the list box items.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionMode |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Constructor
ListBox Class See Also Send Feedback
Initializes a new instance of the ListBox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ListBox()
Visual Basic
Public Sub New
Visual C++
public:
ListBox()

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Fields
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Fields

Name | Description
ItemsProperty |
SelectionModeProperty |

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ItemsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..ItemsProperty Field
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ListBox.ItemsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ItemsProperty
Visual Basic
Public Shared ItemsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ItemsProperty

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionModeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..SelectionModeProperty Field
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ListBox.SelectionModeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionModeProperty
Visual Basic
Public Shared SelectionModeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionModeProperty

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Methods
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Selector..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..AnySibling Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..AssignReference Method
ListBox Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..GetProperty Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..GetRealType Method
ListBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ListBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ListBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..GetRectangle Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..Highlight Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..InvokeMethod Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..IsHitTest Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..NextSibling Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..Parent Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..PreviousSibling Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..ScrollToVisible Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox..::..SetProperty Method
ListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBox Class
ListBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBox Properties
ListBox Class See Also Send Feedback

The ListBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSynchronizedWithCurrentItem | (Inherited from Selector.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Items |
Public property | ItemsPanel | Get the element holding the list box items.
Public property | ListBoxItems | Get the list box items.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex | (Inherited from Selector.)
Public property | SelectedValuePath | (Inherited from Selector.)
Public property | SelectionMode |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBoxItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Members
ListBoxItem Class Constructors Methods Fields Properties See Also Send Feedback

The ListBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | ListBoxItem | Initializes a new instance of the ListBoxItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsSelectedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBoxItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Constructor
ListBoxItem Class See Also Send Feedback
Initializes a new instance of the ListBoxItem class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ListBoxItem()
Visual Basic
Public Sub New
Visual C++
public:
ListBoxItem()

See Also

ListBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBoxItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Fields
ListBoxItem Class See Also Send Feedback

The ListBoxItem type exposes the following members.

Fields

Name | Description
IsSelectedProperty |

See Also

ListBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..IsSelectedProperty Field
ListBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ListBoxItem.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

ListBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBoxItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Methods
ListBoxItem Class See Also Send Feedback

The ListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..AnySibling Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..GetProperty Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..GetRealType Method
ListBoxItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ListBoxItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ListBoxItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ListBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..GetRectangle Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..Highlight Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..InvokeMethod Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..IsHitTest Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..NextSibling Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..Parent Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..PreviousSibling Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..ScrollToVisible Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem..::..SetProperty Method
ListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ListBoxItem Class
ListBoxItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ListBoxItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxItem Properties
ListBoxItem Class See Also Send Feedback

The ListBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ListBoxItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Matrix Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Members
Matrix Class Constructors Methods Fields Properties See Also Send Feedback

The Matrix type exposes the following members.

Constructors

 | Name | Description
Public method | Matrix | Initializes a new instance of the Matrix class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
IsIdentityProperty |
M11Property |
M12Property |
M21Property |
M22Property |
OffsetXProperty |
OffsetYProperty |

Properties

 | Name | Description
Public property | IsIdentity |
Public property | M11 |
Public property | M12 |
Public property | M21 |
Public property | M22 |
Public property | OffsetX |
Public property | OffsetY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Matrix Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Constructor
Matrix Class See Also Send Feedback
Initializes a new instance of the Matrix class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Matrix()
Visual Basic
Public Sub New
Visual C++
public:
Matrix()

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Matrix Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Fields
Matrix Class See Also Send Feedback

The Matrix type exposes the following members.

Fields

Name | Description
IsIdentityProperty |
M11Property |
M12Property |
M21Property |
M22Property |
OffsetXProperty |
OffsetYProperty |

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsIdentityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..IsIdentityProperty Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Matrix.IsIdentityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsIdentityProperty
Visual Basic
Public Shared IsIdentityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsIdentityProperty

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


M11Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M11Property Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Matrix.M11Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M11Property
Visual Basic
Public Shared M11Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M11Property

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


M12Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M12Property Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Matrix.M12Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M12Property
Visual Basic
Public Shared M12Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M12Property

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


M21Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M21Property Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Matrix.M21Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M21Property
Visual Basic
Public Shared M21Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M21Property

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


M22Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..M22Property Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Matrix.M22Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty M22Property
Visual Basic
Public Shared M22Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ M22Property

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OffsetXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..OffsetXProperty Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Matrix.OffsetXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetXProperty
Visual Basic
Public Shared OffsetXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetXProperty

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OffsetYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..OffsetYProperty Field
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Matrix.OffsetYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OffsetYProperty
Visual Basic
Public Shared OffsetYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OffsetYProperty

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Matrix Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Methods
Matrix Class See Also Send Feedback

The Matrix type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..GetProperty Method
Matrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix Class
Matrix Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..GetRealType Method
Matrix Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Matrix.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Matrix.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix..::..InvokeMethod Method
Matrix Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix Class
Matrix Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Matrix Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Matrix Properties
Matrix Class See Also Send Feedback

The Matrix type exposes the following members.

Properties

 | Name | Description
Public property | IsIdentity |
Public property | M11 |
Public property | M12 |
Public property | M21 |
Public property | M22 |
Public property | OffsetX |
Public property | OffsetY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Matrix Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MatrixTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Members
MatrixTransform Class Constructors Methods Fields Properties See Also Send Feedback

The MatrixTransform type exposes the following members.

Constructors

 | Name | Description
Public method | MatrixTransform | Initializes a new instance of the MatrixTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MatrixProperty |

Properties

 | Name | Description
Public property | Matrix |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MatrixTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Constructor
MatrixTransform Class See Also Send Feedback
Initializes a new instance of the MatrixTransform class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MatrixTransform()
Visual Basic
Public Sub New
Visual C++
public:
MatrixTransform()

See Also

MatrixTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MatrixTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Fields
MatrixTransform Class See Also Send Feedback

The MatrixTransform type exposes the following members.

Fields

Name | Description
MatrixProperty |

See Also

MatrixTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MatrixProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..MatrixProperty Field
MatrixTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MatrixTransform.MatrixProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MatrixProperty
Visual Basic
Public Shared MatrixProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MatrixProperty

See Also

MatrixTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MatrixTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Methods
MatrixTransform Class See Also Send Feedback

The MatrixTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..GetProperty Method
MatrixTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform Class
MatrixTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..GetRealType Method
MatrixTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.MatrixTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.MatrixTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MatrixTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform..::..InvokeMethod Method
MatrixTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform Class
MatrixTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


MatrixTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MatrixTransform Properties
MatrixTransform Class See Also Send Feedback

The MatrixTransform type exposes the following members.

Properties

 | Name | Description
Public property | Matrix |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MatrixTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MediaElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Members
MediaElement Class Constructors Methods Fields Properties See Also Send Feedback

The MediaElement type exposes the following members.

Constructors

 | Name | Description
Public method | MediaElement | Initializes a new instance of the MediaElement class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AttributesProperty |
AudioStreamCountProperty |
AudioStreamIndexProperty |
AutoPlayProperty |
BalanceProperty |
BufferingProgressProperty |
BufferingTimeProperty |
CanPauseProperty |
CanSeekProperty |
CurrentStateProperty |
DownloadProgressOffsetProperty |
DownloadProgressProperty |
DroppedFramesPerSecondProperty |
IsMutedProperty |
NaturalDurationProperty |
NaturalVideoHeightProperty |
NaturalVideoWidthProperty |
PositionProperty |
RenderedFramesPerSecondProperty |
SourceProperty |
StretchProperty |
VolumeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | Attributes |
Public property | AudioStreamCount |
Public property | AudioStreamIndex |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoPlay |
Public property | Balance |
Public property | BufferingProgress |
Public property | BufferingTime |
Public property | CanPause |
Public property | CanSeek |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | CurrentState |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DownloadProgress |
Public property | DownloadProgressOffset |
Public property | DroppedFramesPerSecond |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMuted |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NaturalDuration |
Public property | NaturalVideoHeight |
Public property | NaturalVideoWidth |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Position |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderedFramesPerSecond |
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Source |
Public property | Stretch |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Volume |
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MediaElement Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Constructor
MediaElement Class See Also Send Feedback
Initializes a new instance of the MediaElement class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MediaElement()
Visual Basic
Public Sub New
Visual C++
public:
MediaElement()

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MediaElement Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Fields
MediaElement Class See Also Send Feedback

The MediaElement type exposes the following members.

Fields

Name | Description
AttributesProperty |
AudioStreamCountProperty |
AudioStreamIndexProperty |
AutoPlayProperty |
BalanceProperty |
BufferingProgressProperty |
BufferingTimeProperty |
CanPauseProperty |
CanSeekProperty |
CurrentStateProperty |
DownloadProgressOffsetProperty |
DownloadProgressProperty |
DroppedFramesPerSecondProperty |
IsMutedProperty |
NaturalDurationProperty |
NaturalVideoHeightProperty |
NaturalVideoWidthProperty |
PositionProperty |
RenderedFramesPerSecondProperty |
SourceProperty |
StretchProperty |
VolumeProperty |

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AttributesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..AttributesProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.AttributesProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AttributesProperty
Visual Basic
Public Shared AttributesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AttributesProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AudioStreamCountProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..AudioStreamCountProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.AudioStreamCountProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AudioStreamCountProperty
Visual Basic
Public Shared AudioStreamCountProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AudioStreamCountProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AudioStreamIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..AudioStreamIndexProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.AudioStreamIndexProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AudioStreamIndexProperty
Visual Basic
Public Shared AudioStreamIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AudioStreamIndexProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AutoPlayProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..AutoPlayProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.AutoPlayProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AutoPlayProperty
Visual Basic
Public Shared AutoPlayProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AutoPlayProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BalanceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..BalanceProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.BalanceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BalanceProperty
Visual Basic
Public Shared BalanceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BalanceProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BufferingProgressProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..BufferingProgressProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.BufferingProgressProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BufferingProgressProperty
Visual Basic
Public Shared BufferingProgressProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BufferingProgressProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BufferingTimeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..BufferingTimeProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.BufferingTimeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BufferingTimeProperty
Visual Basic
Public Shared BufferingTimeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BufferingTimeProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanPauseProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..CanPauseProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.CanPauseProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanPauseProperty
Visual Basic
Public Shared CanPauseProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanPauseProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanSeekProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..CanSeekProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.CanSeekProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanSeekProperty
Visual Basic
Public Shared CanSeekProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanSeekProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CurrentStateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..CurrentStateProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.CurrentStateProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CurrentStateProperty
Visual Basic
Public Shared CurrentStateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CurrentStateProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DownloadProgressOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..DownloadProgressOffsetProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.DownloadProgressOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DownloadProgressOffsetProperty
Visual Basic
Public Shared DownloadProgressOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DownloadProgressOffsetProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DownloadProgressProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..DownloadProgressProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.DownloadProgressProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DownloadProgressProperty
Visual Basic
Public Shared DownloadProgressProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DownloadProgressProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DroppedFramesPerSecondProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..DroppedFramesPerSecondProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.DroppedFramesPerSecondProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DroppedFramesPerSecondProperty
Visual Basic
Public Shared DroppedFramesPerSecondProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DroppedFramesPerSecondProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsMutedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..IsMutedProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.IsMutedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsMutedProperty
Visual Basic
Public Shared IsMutedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsMutedProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


NaturalDurationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..NaturalDurationProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.NaturalDurationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NaturalDurationProperty
Visual Basic
Public Shared NaturalDurationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NaturalDurationProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


NaturalVideoHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..NaturalVideoHeightProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.NaturalVideoHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NaturalVideoHeightProperty
Visual Basic
Public Shared NaturalVideoHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NaturalVideoHeightProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


NaturalVideoWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..NaturalVideoWidthProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.NaturalVideoWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty NaturalVideoWidthProperty
Visual Basic
Public Shared NaturalVideoWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ NaturalVideoWidthProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PositionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..PositionProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.PositionProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PositionProperty
Visual Basic
Public Shared PositionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PositionProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RenderedFramesPerSecondProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..RenderedFramesPerSecondProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.RenderedFramesPerSecondProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RenderedFramesPerSecondProperty
Visual Basic
Public Shared RenderedFramesPerSecondProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RenderedFramesPerSecondProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..SourceProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.SourceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..StretchProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.StretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VolumeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..VolumeProperty Field
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MediaElement.VolumeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VolumeProperty
Visual Basic
Public Shared VolumeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VolumeProperty

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MediaElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Methods
MediaElement Class See Also Send Feedback

The MediaElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..AnySibling Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..GetProperty Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..GetRealType Method
MediaElement Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.MediaElement.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.MediaElement.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..GetRectangle Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..Highlight Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..InvokeMethod Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..IsHitTest Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..NextSibling Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..Parent Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..PreviousSibling Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..ScrollToVisible Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement..::..SetProperty Method
MediaElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MediaElement Class
MediaElement Members
ArtOfTest.WebAii.Silverlight.UI Namespace


MediaElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MediaElement Properties
MediaElement Class See Also Send Feedback

The MediaElement type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | Attributes |
Public property | AudioStreamCount |
Public property | AudioStreamIndex |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | AutoPlay |
Public property | Balance |
Public property | BufferingProgress |
Public property | BufferingTime |
Public property | CanPause |
Public property | CanSeek |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | CurrentState |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DownloadProgress |
Public property | DownloadProgressOffset |
Public property | DroppedFramesPerSecond |
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMuted |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | NaturalDuration |
Public property | NaturalVideoHeight |
Public property | NaturalVideoWidth |
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Position |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderedFramesPerSecond |
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Source |
Public property | Stretch |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Volume |
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MediaElement Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleImage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage Members
MultiScaleImage Class Constructors Methods Fields Properties See Also Send Feedback

The MultiScaleImage type exposes the following members.

Constructors

 | Name | Description
Public method | MultiScaleImage | Initializes a new instance of the MultiScaleImage class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AllowDownloadingProperty |
AspectRatioProperty |
BlurFactorProperty |
IsDownloadingProperty |
IsIdleProperty |
SkipLevelsProperty |
SourceProperty |
SubImagesProperty |
UseSpringsProperty |
ViewportOriginProperty |
ViewportWidthProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDownloading |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AspectRatio |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BlurFactor |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDownloading |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsIdle |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SkipLevels |
Public property | Source |
Public property | SubImages |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | UseSprings |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | ViewportOrigin |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleImage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage Constructor
MultiScaleImage Class See Also Send Feedback
Initializes a new instance of the MultiScaleImage class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MultiScaleImage()
Visual Basic
Public Sub New
Visual C++
public:
MultiScaleImage()

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleImage Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage Fields
MultiScaleImage Class See Also Send Feedback

The MultiScaleImage type exposes the following members.

Fields

Name | Description
AllowDownloadingProperty |
AspectRatioProperty |
BlurFactorProperty |
IsDownloadingProperty |
IsIdleProperty |
SkipLevelsProperty |
SourceProperty |
SubImagesProperty |
UseSpringsProperty |
ViewportOriginProperty |
ViewportWidthProperty |

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AllowDownloadingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..AllowDownloadingProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.AllowDownloadingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AllowDownloadingProperty
Visual Basic
Public Shared AllowDownloadingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AllowDownloadingProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AspectRatioProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..AspectRatioProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.AspectRatioProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AspectRatioProperty
Visual Basic
Public Shared AspectRatioProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AspectRatioProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BlurFactorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..BlurFactorProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.BlurFactorProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BlurFactorProperty
Visual Basic
Public Shared BlurFactorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BlurFactorProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDownloadingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..IsDownloadingProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.IsDownloadingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDownloadingProperty
Visual Basic
Public Shared IsDownloadingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDownloadingProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsIdleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..IsIdleProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.IsIdleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsIdleProperty
Visual Basic
Public Shared IsIdleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsIdleProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkipLevelsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..SkipLevelsProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.SkipLevelsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SkipLevelsProperty
Visual Basic
Public Shared SkipLevelsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SkipLevelsProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SourceProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..SourceProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.SourceProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceProperty
Visual Basic
Public Shared SourceProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SubImagesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..SubImagesProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.SubImagesProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SubImagesProperty
Visual Basic
Public Shared SubImagesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SubImagesProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UseSpringsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..UseSpringsProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.UseSpringsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty UseSpringsProperty
Visual Basic
Public Shared UseSpringsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ UseSpringsProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportOriginProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..ViewportOriginProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.ViewportOriginProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportOriginProperty
Visual Basic
Public Shared ViewportOriginProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportOriginProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..ViewportWidthProperty Field
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.ViewportWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportWidthProperty
Visual Basic
Public Shared ViewportWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportWidthProperty

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleImage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage Methods
MultiScaleImage Class See Also Send Feedback

The MultiScaleImage type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..AnySibling Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..GetProperty Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..GetRealType Method
MultiScaleImage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.MultiScaleImage.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..GetRectangle Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..Highlight Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..InvokeMethod Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..IsHitTest Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..NextSibling Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..Parent Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..PreviousSibling Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..ScrollToVisible Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage..::..SetProperty Method
MultiScaleImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleImage Class
MultiScaleImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleImage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleImage Properties
MultiScaleImage Class See Also Send Feedback

The MultiScaleImage type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AllowDownloading |
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AspectRatio |
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | BlurFactor |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDownloading |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsIdle |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SkipLevels |
Public property | Source |
Public property | SubImages |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | UseSprings |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | ViewportOrigin |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

MultiScaleImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleSubImage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage Members
MultiScaleSubImage Class Constructors Methods Fields Properties See Also Send Feedback

The MultiScaleSubImage type exposes the following members.

Constructors

 | Name | Description
Public method | MultiScaleSubImage | Creates a new MultiScaleSubImage wrapper.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | Gets the string representation of the real type this class wraps. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AspectRatioProperty | Defines how to get the AspectRatio property.
OpacityProperty | Defines how to get the Opacity property.
ViewportOriginProperty | Defines how to get the ViewportOrigin property.
ViewportWidthProperty | Defines how to get the ViewportWidth property.
ZIndexProperty | Definds how to get the ZIndex property.

Properties

 | Name | Description
Public property | AspectRatio | Gets the AspectRatio value.
Public property | Opacity | Gets / Sets the Opacity value.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ViewportOrigin | Gets / Sets the ViewportOrigin value.
Public property | ViewportWidth | Gets / Sets the ViewportWidth value.
Public property | ZIndex | Gets / Sets the zIndex value.

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleSubImage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage Constructor
MultiScaleSubImage Class See Also Send Feedback
Creates a new MultiScaleSubImage wrapper.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MultiScaleSubImage()
Visual Basic
Public Sub New
Visual C++
public:
MultiScaleSubImage()

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleSubImage Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage Fields
MultiScaleSubImage Class See Also Send Feedback

The MultiScaleSubImage type exposes the following members.

Fields

Name | Description
AspectRatioProperty | Defines how to get the AspectRatio property.
OpacityProperty | Defines how to get the Opacity property.
ViewportOriginProperty | Defines how to get the ViewportOrigin property.
ViewportWidthProperty | Defines how to get the ViewportWidth property.
ZIndexProperty | Definds how to get the ZIndex property.

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AspectRatioProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage..::..AspectRatioProperty Field
MultiScaleSubImage Class See Also Send Feedback
Defines how to get the AspectRatio property.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AspectRatioProperty
Visual Basic
Public Shared AspectRatioProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AspectRatioProperty

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OpacityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage..::..OpacityProperty Field
MultiScaleSubImage Class See Also Send Feedback
Defines how to get the Opacity property.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OpacityProperty
Visual Basic
Public Shared OpacityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OpacityProperty

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportOriginProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage..::..ViewportOriginProperty Field
MultiScaleSubImage Class See Also Send Feedback
Defines how to get the ViewportOrigin property.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportOriginProperty
Visual Basic
Public Shared ViewportOriginProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportOriginProperty

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage..::..ViewportWidthProperty Field
MultiScaleSubImage Class See Also Send Feedback
Defines how to get the ViewportWidth property.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportWidthProperty
Visual Basic
Public Shared ViewportWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportWidthProperty

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ZIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage..::..ZIndexProperty Field
MultiScaleSubImage Class See Also Send Feedback
Definds how to get the ZIndex property.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ZIndexProperty
Visual Basic
Public Shared ZIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ZIndexProperty

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleSubImage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage Methods
MultiScaleSubImage Class See Also Send Feedback

The MultiScaleSubImage type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | Gets the string representation of the real type this class wraps. (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage..::..GetProperty Method
MultiScaleSubImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleSubImage Class
MultiScaleSubImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage..::..GetRealType Method
MultiScaleSubImage Class See Also Send Feedback
Gets the string representation of the real type this class wraps.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

The string representation of the real type.

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage..::..InvokeMethod Method
MultiScaleSubImage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleSubImage Class
MultiScaleSubImage Members
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleSubImage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleSubImage Properties
MultiScaleSubImage Class See Also Send Feedback

The MultiScaleSubImage type exposes the following members.

Properties

 | Name | Description
Public property | AspectRatio | Gets the AspectRatio value.
Public property | Opacity | Gets / Sets the Opacity value.
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ViewportOrigin | Gets / Sets the ViewportOrigin value.
Public property | ViewportWidth | Gets / Sets the ViewportWidth value.
Public property | ZIndex | Gets / Sets the zIndex value.

See Also

MultiScaleSubImage Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleTileSource Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleTileSource Members
MultiScaleTileSource Class Constructors Methods Properties See Also Send Feedback

The MultiScaleTileSource type exposes the following members.

Constructors

 | Name | Description
Public method | MultiScaleTileSource | Initializes a new instance of the MultiScaleTileSource class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleTileSource Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleTileSource Constructor
MultiScaleTileSource Class See Also Send Feedback
Initializes a new instance of the MultiScaleTileSource class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public MultiScaleTileSource()
Visual Basic
Public Sub New
Visual C++
public:
MultiScaleTileSource()

See Also

MultiScaleTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleTileSource Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleTileSource Methods
MultiScaleTileSource Class See Also Send Feedback

The MultiScaleTileSource type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiScaleTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleTileSource..::..GetProperty Method
MultiScaleTileSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleTileSource Class
MultiScaleTileSource Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleTileSource..::..GetRealType Method
MultiScaleTileSource Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.MultiScaleTileSource.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.MultiScaleTileSource.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

MultiScaleTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleTileSource..::..InvokeMethod Method
MultiScaleTileSource Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleTileSource Class
MultiScaleTileSource Members
ArtOfTest.WebAii.Silverlight.UI Namespace


MultiScaleTileSource Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MultiScaleTileSource Properties
MultiScaleTileSource Class See Also Send Feedback

The MultiScaleTileSource type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

MultiScaleTileSource Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Page Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Members
Page Class Constructors Methods Fields Properties See Also Send Feedback

The Page type exposes the following members.

Constructors

 | Name | Description
Public method | Page | Initializes a new instance of the Page class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
HorizontalContentAlignmentProperty |
IsEnabledProperty |
IsTabStopProperty |
PaddingProperty |
TabIndexProperty |
TabNavigationProperty |
VerticalContentAlignmentProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex |
Public property | TabNavigation |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Page Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Constructor
Page Class See Also Send Feedback
Initializes a new instance of the Page class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Page()
Visual Basic
Public Sub New
Visual C++
public:
Page()

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Page Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Fields
Page Class See Also Send Feedback

The Page type exposes the following members.

Fields

Name | Description
BackgroundProperty |
BorderBrushProperty |
BorderThicknessProperty |
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
HorizontalContentAlignmentProperty |
IsEnabledProperty |
IsTabStopProperty |
PaddingProperty |
TabIndexProperty |
TabNavigationProperty |
VerticalContentAlignmentProperty |

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..BackgroundProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..BorderBrushProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.BorderBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderBrushProperty
Visual Basic
Public Shared BorderBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderBrushProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BorderThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..BorderThicknessProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.BorderThicknessProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BorderThicknessProperty
Visual Basic
Public Shared BorderThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BorderThicknessProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontFamilyProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontSizeProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontStretchProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.FontStretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStretchProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontStyleProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.FontStyleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStyleProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontWeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..FontWeightProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.FontWeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontWeightProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..ForegroundProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalContentAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..HorizontalContentAlignmentProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.HorizontalContentAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalContentAlignmentProperty
Visual Basic
Public Shared HorizontalContentAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalContentAlignmentProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsEnabledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..IsEnabledProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.IsEnabledProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEnabledProperty
Visual Basic
Public Shared IsEnabledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEnabledProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsTabStopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..IsTabStopProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.IsTabStopProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsTabStopProperty
Visual Basic
Public Shared IsTabStopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsTabStopProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..PaddingProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.PaddingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PaddingProperty
Visual Basic
Public Shared PaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PaddingProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..TabIndexProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.TabIndexProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabIndexProperty
Visual Basic
Public Shared TabIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabIndexProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabNavigationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..TabNavigationProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.TabNavigationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabNavigationProperty
Visual Basic
Public Shared TabNavigationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabNavigationProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalContentAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..VerticalContentAlignmentProperty Field
Page Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Page.VerticalContentAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalContentAlignmentProperty
Visual Basic
Public Shared VerticalContentAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalContentAlignmentProperty

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Page Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Methods
Page Class See Also Send Feedback

The Page type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..AnySibling Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..GetProperty Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..GetRealType Method
Page Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Page.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Page.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..GetRectangle Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..Highlight Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..InvokeMethod Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..IsHitTest Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..NextSibling Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..Parent Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..PreviousSibling Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..ScrollToVisible Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page..::..SetProperty Method
Page Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Page Class
Page Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Page Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Page Properties
Page Class See Also Send Feedback

The Page type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | BorderBrush |
Public property | BorderThickness |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex |
Public property | TabNavigation |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Page Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Panel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Members
Panel Class Constructors Methods Fields Properties See Also Send Feedback

The Panel type exposes the following members.

Constructors

 | Name | Description
Public method | Panel | Initializes a new instance of the Panel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
BackgroundProperty |
IsItemsHostProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Panel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Panel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Constructor
Panel Class See Also Send Feedback
Initializes a new instance of the Panel class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Panel()
Visual Basic
Public Sub New
Visual C++
public:
Panel()

See Also

Panel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Panel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Fields
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Fields

Name | Description
BackgroundProperty |
IsItemsHostProperty |

See Also

Panel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..BackgroundProperty Field
Panel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Panel.BackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BackgroundProperty
Visual Basic
Public Shared BackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BackgroundProperty

See Also

Panel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsItemsHostProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..IsItemsHostProperty Field
Panel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Panel.IsItemsHostProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsItemsHostProperty
Visual Basic
Public Shared IsItemsHostProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsItemsHostProperty

See Also

Panel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Panel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Methods
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Panel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..AnySibling Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..GetProperty Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..GetRealType Method
Panel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Panel.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Panel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Panel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..GetRectangle Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..Highlight Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..InvokeMethod Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..IsHitTest Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..NextSibling Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..Parent Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..PreviousSibling Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..ScrollToVisible Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel..::..SetProperty Method
Panel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Panel Class
Panel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Panel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Panel Properties
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Panel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PasswordBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Members
PasswordBox Class Constructors Methods Fields Properties See Also Send Feedback

The PasswordBox type exposes the following members.

Constructors

 | Name | Description
Public method | PasswordBox | Initializes a new instance of the PasswordBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetPassword | Sets or types a new text into the PasswordBox.
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CaretBrushProperty |
MaxLengthProperty |
PasswordCharProperty |
PasswordProperty |
SelectionBackgroundProperty |
SelectionForegroundProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaretBrush |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Password |
Public property | PasswordChar |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionBackground |
Public property | SelectionForeground |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PasswordBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Constructor
PasswordBox Class See Also Send Feedback
Initializes a new instance of the PasswordBox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PasswordBox()
Visual Basic
Public Sub New
Visual C++
public:
PasswordBox()

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PasswordBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Fields
PasswordBox Class See Also Send Feedback

The PasswordBox type exposes the following members.

Fields

Name | Description
CaretBrushProperty |
MaxLengthProperty |
PasswordCharProperty |
PasswordProperty |
SelectionBackgroundProperty |
SelectionForegroundProperty |

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CaretBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..CaretBrushProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PasswordBox.CaretBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CaretBrushProperty
Visual Basic
Public Shared CaretBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CaretBrushProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaxLengthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..MaxLengthProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PasswordBox.MaxLengthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxLengthProperty
Visual Basic
Public Shared MaxLengthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxLengthProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PasswordCharProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..PasswordCharProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PasswordBox.PasswordCharProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PasswordCharProperty
Visual Basic
Public Shared PasswordCharProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PasswordCharProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PasswordProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..PasswordProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PasswordBox.PasswordProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PasswordProperty
Visual Basic
Public Shared PasswordProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PasswordProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionBackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..SelectionBackgroundProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PasswordBox.SelectionBackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionBackgroundProperty
Visual Basic
Public Shared SelectionBackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionBackgroundProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..SelectionForegroundProperty Field
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PasswordBox.SelectionForegroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionForegroundProperty
Visual Basic
Public Shared SelectionForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionForegroundProperty

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PasswordBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Methods
PasswordBox Class See Also Send Feedback

The PasswordBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetPassword | Sets or types a new text into the PasswordBox.
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..AnySibling Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..GetProperty Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..GetRealType Method
PasswordBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PasswordBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PasswordBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..GetRectangle Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..Highlight Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..InvokeMethod Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..IsHitTest Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..NextSibling Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..Parent Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..PreviousSibling Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..ScrollToVisible Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetPassword Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..SetPassword Method
PasswordBox Class See Also Send Feedback
Sets or types a new text into the PasswordBox.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetPassword(
    bool simulateRealUser,
    string password,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Sub SetPassword ( _
    simulateRealUser As Boolean, _
    password As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
virtual void SetPassword(
    bool simulateRealUser,
    String^ password,
    int keyPressTime,
    int keyHoldTime
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the password.
password
Type: System..::..String
The password to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press.
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key.

Implements

IPasswordBox..::..SetPassword(Boolean, String, Int32, Int32)

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox..::..SetProperty Method
PasswordBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PasswordBox Class
PasswordBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PasswordBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PasswordBox Properties
PasswordBox Class See Also Send Feedback

The PasswordBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaretBrush |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Password |
Public property | PasswordChar |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionBackground |
Public property | SelectionForeground |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

PasswordBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Path Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Members
Path Class Constructors Methods Fields Properties See Also Send Feedback

The Path type exposes the following members.

Constructors

 | Name | Description
Public method | Path | Initializes a new instance of the Path class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DataProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Data |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Path Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Path Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Constructor
Path Class See Also Send Feedback
Initializes a new instance of the Path class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Path()
Visual Basic
Public Sub New
Visual C++
public:
Path()

See Also

Path Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Path Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Fields
Path Class See Also Send Feedback

The Path type exposes the following members.

Fields

Name | Description
DataProperty |

See Also

Path Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DataProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..DataProperty Field
Path Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Path.DataProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DataProperty
Visual Basic
Public Shared DataProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DataProperty

See Also

Path Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Path Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Methods
Path Class See Also Send Feedback

The Path type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Path Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..AnySibling Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..GetProperty Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..GetRealType Method
Path Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Path.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Path.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Path Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..GetRectangle Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..Highlight Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..InvokeMethod Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..IsHitTest Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..NextSibling Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..Parent Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..PreviousSibling Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..ScrollToVisible Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path..::..SetProperty Method
Path Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Path Class
Path Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Path Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Path Properties
Path Class See Also Send Feedback

The Path type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Data |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Path Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathFigure Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure Members
PathFigure Class Constructors Methods Fields Properties See Also Send Feedback

The PathFigure type exposes the following members.

Constructors

 | Name | Description
Public method | PathFigure | Initializes a new instance of the PathFigure class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
IsClosedProperty |
IsFilledProperty |
SegmentsProperty |
StartPointProperty |

Properties

 | Name | Description
Public property | IsClosed |
Public property | IsFilled |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Segments |
Public property | StartPoint |

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathFigure Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure Constructor
PathFigure Class See Also Send Feedback
Initializes a new instance of the PathFigure class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PathFigure()
Visual Basic
Public Sub New
Visual C++
public:
PathFigure()

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathFigure Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure Fields
PathFigure Class See Also Send Feedback

The PathFigure type exposes the following members.

Fields

Name | Description
IsClosedProperty |
IsFilledProperty |
SegmentsProperty |
StartPointProperty |

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsClosedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure..::..IsClosedProperty Field
PathFigure Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PathFigure.IsClosedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsClosedProperty
Visual Basic
Public Shared IsClosedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsClosedProperty

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsFilledProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure..::..IsFilledProperty Field
PathFigure Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PathFigure.IsFilledProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFilledProperty
Visual Basic
Public Shared IsFilledProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFilledProperty

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SegmentsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure..::..SegmentsProperty Field
PathFigure Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PathFigure.SegmentsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SegmentsProperty
Visual Basic
Public Shared SegmentsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SegmentsProperty

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StartPointProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure..::..StartPointProperty Field
PathFigure Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PathFigure.StartPointProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StartPointProperty
Visual Basic
Public Shared StartPointProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StartPointProperty

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathFigure Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure Methods
PathFigure Class See Also Send Feedback

The PathFigure type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure..::..GetProperty Method
PathFigure Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathFigure Class
PathFigure Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure..::..GetRealType Method
PathFigure Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PathFigure.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PathFigure.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure..::..InvokeMethod Method
PathFigure Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathFigure Class
PathFigure Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PathFigure Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathFigure Properties
PathFigure Class See Also Send Feedback

The PathFigure type exposes the following members.

Properties

 | Name | Description
Public property | IsClosed |
Public property | IsFilled |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Segments |
Public property | StartPoint |

See Also

PathFigure Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Members
PathGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The PathGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | PathGeometry | Initializes a new instance of the PathGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
FiguresProperty |
FillRuleProperty |

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | Figures |
Public property | FillRule |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

PathGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Constructor
PathGeometry Class See Also Send Feedback
Initializes a new instance of the PathGeometry class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PathGeometry()
Visual Basic
Public Sub New
Visual C++
public:
PathGeometry()

See Also

PathGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Fields
PathGeometry Class See Also Send Feedback

The PathGeometry type exposes the following members.

Fields

Name | Description
FiguresProperty |
FillRuleProperty |

See Also

PathGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FiguresProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..FiguresProperty Field
PathGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PathGeometry.FiguresProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FiguresProperty
Visual Basic
Public Shared FiguresProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FiguresProperty

See Also

PathGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FillRuleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..FillRuleProperty Field
PathGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PathGeometry.FillRuleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillRuleProperty
Visual Basic
Public Shared FillRuleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillRuleProperty

See Also

PathGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Methods
PathGeometry Class See Also Send Feedback

The PathGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..GetProperty Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathGeometry Class
PathGeometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..GetRealType Method
PathGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PathGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PathGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PathGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry..::..InvokeMethod Method
PathGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathGeometry Class
PathGeometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PathGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathGeometry Properties
PathGeometry Class See Also Send Feedback

The PathGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | Figures |
Public property | FillRule |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

PathGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathSegment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathSegment Members
PathSegment Class Constructors Methods Properties See Also Send Feedback

The PathSegment type exposes the following members.

Constructors

 | Name | Description
Public method | PathSegment | Initializes a new instance of the PathSegment class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathSegment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathSegment Constructor
PathSegment Class See Also Send Feedback
Initializes a new instance of the PathSegment class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PathSegment()
Visual Basic
Public Sub New
Visual C++
public:
PathSegment()

See Also

PathSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PathSegment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathSegment Methods
PathSegment Class See Also Send Feedback

The PathSegment type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathSegment..::..GetProperty Method
PathSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathSegment Class
PathSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathSegment..::..GetRealType Method
PathSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PathSegment.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PathSegment.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PathSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathSegment..::..InvokeMethod Method
PathSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathSegment Class
PathSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PathSegment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PathSegment Properties
PathSegment Class See Also Send Feedback

The PathSegment type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PathSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Members
Point Class Constructors Methods Fields Properties See Also Send Feedback

The Point type exposes the following members.

Constructors

 | Name | Description
Public method | Point | Initializes a new instance of the Point class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
XProperty |
YProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |

See Also

Point Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Constructor
Point Class See Also Send Feedback
Initializes a new instance of the Point class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point()
Visual Basic
Public Sub New
Visual C++
public:
Point()

See Also

Point Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Fields
Point Class See Also Send Feedback

The Point type exposes the following members.

Fields

Name | Description
XProperty |
YProperty |

See Also

Point Class
ArtOfTest.WebAii.Silverlight.UI Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..XProperty Field
Point Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Point.XProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

Point Class
ArtOfTest.WebAii.Silverlight.UI Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..YProperty Field
Point Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Point.YProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

Point Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Methods
Point Class See Also Send Feedback

The Point type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Point Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..GetProperty Method
Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Point Class
Point Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..GetRealType Method
Point Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Point.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Point.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Point Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point..::..InvokeMethod Method
Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Point Class
Point Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Point Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Point Properties
Point Class See Also Send Feedback

The Point type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |

See Also

Point Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyBezierSegment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment Members
PolyBezierSegment Class Constructors Methods Fields Properties See Also Send Feedback

The PolyBezierSegment type exposes the following members.

Constructors

 | Name | Description
Public method | PolyBezierSegment | Initializes a new instance of the PolyBezierSegment class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PointsProperty |

Properties

 | Name | Description
Public property | Points |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyBezierSegment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment Constructor
PolyBezierSegment Class See Also Send Feedback
Initializes a new instance of the PolyBezierSegment class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PolyBezierSegment()
Visual Basic
Public Sub New
Visual C++
public:
PolyBezierSegment()

See Also

PolyBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyBezierSegment Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment Fields
PolyBezierSegment Class See Also Send Feedback

The PolyBezierSegment type exposes the following members.

Fields

Name | Description
PointsProperty |

See Also

PolyBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PointsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment..::..PointsProperty Field
PolyBezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PolyBezierSegment.PointsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PointsProperty
Visual Basic
Public Shared PointsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PointsProperty

See Also

PolyBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyBezierSegment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment Methods
PolyBezierSegment Class See Also Send Feedback

The PolyBezierSegment type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolyBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment..::..GetProperty Method
PolyBezierSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyBezierSegment Class
PolyBezierSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment..::..GetRealType Method
PolyBezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PolyBezierSegment.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PolyBezierSegment.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PolyBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment..::..InvokeMethod Method
PolyBezierSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyBezierSegment Class
PolyBezierSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyBezierSegment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyBezierSegment Properties
PolyBezierSegment Class See Also Send Feedback

The PolyBezierSegment type exposes the following members.

Properties

 | Name | Description
Public property | Points |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Polygon Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Members
Polygon Class Constructors Methods Fields Properties See Also Send Feedback

The Polygon type exposes the following members.

Constructors

 | Name | Description
Public method | Polygon | Initializes a new instance of the Polygon class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FillRuleProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | FillRule |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Polygon Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Polygon Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Constructor
Polygon Class See Also Send Feedback
Initializes a new instance of the Polygon class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Polygon()
Visual Basic
Public Sub New
Visual C++
public:
Polygon()

See Also

Polygon Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Polygon Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Fields
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Fields

Name | Description
FillRuleProperty |

See Also

Polygon Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FillRuleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..FillRuleProperty Field
Polygon Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Polygon.FillRuleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillRuleProperty
Visual Basic
Public Shared FillRuleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillRuleProperty

See Also

Polygon Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Polygon Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Methods
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Polygon Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..AnySibling Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..GetProperty Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..GetRealType Method
Polygon Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Polygon.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Polygon.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Polygon Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..GetRectangle Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..Highlight Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..InvokeMethod Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..IsHitTest Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..NextSibling Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..Parent Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..PreviousSibling Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..ScrollToVisible Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon..::..SetProperty Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polygon Class
Polygon Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Polygon Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polygon Properties
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | FillRule |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Polygon Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Polyline Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Members
Polyline Class Constructors Methods Fields Properties See Also Send Feedback

The Polyline type exposes the following members.

Constructors

 | Name | Description
Public method | Polyline | Initializes a new instance of the Polyline class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FillRuleProperty |
PointsProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | FillRule |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Points |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Polyline Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Polyline Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Constructor
Polyline Class See Also Send Feedback
Initializes a new instance of the Polyline class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Polyline()
Visual Basic
Public Sub New
Visual C++
public:
Polyline()

See Also

Polyline Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Polyline Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Fields
Polyline Class See Also Send Feedback

The Polyline type exposes the following members.

Fields

Name | Description
FillRuleProperty |
PointsProperty |

See Also

Polyline Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FillRuleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..FillRuleProperty Field
Polyline Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Polyline.FillRuleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillRuleProperty
Visual Basic
Public Shared FillRuleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillRuleProperty

See Also

Polyline Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PointsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..PointsProperty Field
Polyline Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Polyline.PointsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PointsProperty
Visual Basic
Public Shared PointsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PointsProperty

See Also

Polyline Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Polyline Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Methods
Polyline Class See Also Send Feedback

The Polyline type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Polyline Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..AnySibling Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..GetProperty Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..GetRealType Method
Polyline Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Polyline.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Polyline.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Polyline Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..GetRectangle Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..Highlight Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..InvokeMethod Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..IsHitTest Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..NextSibling Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..Parent Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..PreviousSibling Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..ScrollToVisible Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline..::..SetProperty Method
Polyline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Polyline Class
Polyline Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Polyline Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Polyline Properties
Polyline Class See Also Send Feedback

The Polyline type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | FillRule |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Points |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Polyline Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyLineSegment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment Members
PolyLineSegment Class Constructors Methods Fields Properties See Also Send Feedback

The PolyLineSegment type exposes the following members.

Constructors

 | Name | Description
Public method | PolyLineSegment | Initializes a new instance of the PolyLineSegment class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PointsProperty |

Properties

 | Name | Description
Public property | Points |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyLineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyLineSegment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment Constructor
PolyLineSegment Class See Also Send Feedback
Initializes a new instance of the PolyLineSegment class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PolyLineSegment()
Visual Basic
Public Sub New
Visual C++
public:
PolyLineSegment()

See Also

PolyLineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyLineSegment Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment Fields
PolyLineSegment Class See Also Send Feedback

The PolyLineSegment type exposes the following members.

Fields

Name | Description
PointsProperty |

See Also

PolyLineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PointsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment..::..PointsProperty Field
PolyLineSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PolyLineSegment.PointsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PointsProperty
Visual Basic
Public Shared PointsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PointsProperty

See Also

PolyLineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyLineSegment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment Methods
PolyLineSegment Class See Also Send Feedback

The PolyLineSegment type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolyLineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment..::..GetProperty Method
PolyLineSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyLineSegment Class
PolyLineSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment..::..GetRealType Method
PolyLineSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PolyLineSegment.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PolyLineSegment.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PolyLineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment..::..InvokeMethod Method
PolyLineSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyLineSegment Class
PolyLineSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyLineSegment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyLineSegment Properties
PolyLineSegment Class See Also Send Feedback

The PolyLineSegment type exposes the following members.

Properties

 | Name | Description
Public property | Points |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyLineSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyQuadraticBezierSegment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment Members
PolyQuadraticBezierSegment Class Constructors Methods Fields Properties See Also Send Feedback

The PolyQuadraticBezierSegment type exposes the following members.

Constructors

 | Name | Description
Public method | PolyQuadraticBezierSegment | Initializes a new instance of the PolyQuadraticBezierSegment class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PointsProperty |

Properties

 | Name | Description
Public property | Points |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyQuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyQuadraticBezierSegment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment Constructor
PolyQuadraticBezierSegment Class See Also Send Feedback
Initializes a new instance of the PolyQuadraticBezierSegment class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public PolyQuadraticBezierSegment()
Visual Basic
Public Sub New
Visual C++
public:
PolyQuadraticBezierSegment()

See Also

PolyQuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyQuadraticBezierSegment Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment Fields
PolyQuadraticBezierSegment Class See Also Send Feedback

The PolyQuadraticBezierSegment type exposes the following members.

Fields

Name | Description
PointsProperty |

See Also

PolyQuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PointsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment..::..PointsProperty Field
PolyQuadraticBezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.PolyQuadraticBezierSegment.PointsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PointsProperty
Visual Basic
Public Shared PointsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PointsProperty

See Also

PolyQuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyQuadraticBezierSegment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment Methods
PolyQuadraticBezierSegment Class See Also Send Feedback

The PolyQuadraticBezierSegment type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolyQuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment..::..GetProperty Method
PolyQuadraticBezierSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyQuadraticBezierSegment Class
PolyQuadraticBezierSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment..::..GetRealType Method
PolyQuadraticBezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PolyQuadraticBezierSegment.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.PolyQuadraticBezierSegment.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

PolyQuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment..::..InvokeMethod Method
PolyQuadraticBezierSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyQuadraticBezierSegment Class
PolyQuadraticBezierSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PolyQuadraticBezierSegment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PolyQuadraticBezierSegment Properties
PolyQuadraticBezierSegment Class See Also Send Feedback

The PolyQuadraticBezierSegment type exposes the following members.

Properties

 | Name | Description
Public property | Points |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

PolyQuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Popup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Members
Popup Class Constructors Methods Fields Properties See Also Send Feedback

The Popup type exposes the following members.

Constructors

 | Name | Description
Public method | Popup | Initializes a new instance of the Popup class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HorizontalOffsetProperty |
IsOpenProperty |
VerticalOffsetProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsOpen |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Popup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Constructor
Popup Class See Also Send Feedback
Initializes a new instance of the Popup class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Popup()
Visual Basic
Public Sub New
Visual C++
public:
Popup()

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Popup Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Fields
Popup Class See Also Send Feedback

The Popup type exposes the following members.

Fields

Name | Description
HorizontalOffsetProperty |
IsOpenProperty |
VerticalOffsetProperty |

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..HorizontalOffsetProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Popup.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..IsOpenProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Popup.IsOpenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsOpenProperty
Visual Basic
Public Shared IsOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsOpenProperty

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..VerticalOffsetProperty Field
Popup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Popup.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Popup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Methods
Popup Class See Also Send Feedback

The Popup type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..AnySibling Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..GetProperty Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..GetRealType Method
Popup Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Popup.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Popup.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..GetRectangle Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..Highlight Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..InvokeMethod Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..IsHitTest Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..NextSibling Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..Parent Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..PreviousSibling Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..ScrollToVisible Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup..::..SetProperty Method
Popup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Popup Class
Popup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Popup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Popup Properties
Popup Class See Also Send Feedback

The Popup type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsOpen |
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Popup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ProgressBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Members
ProgressBar Class Constructors Methods Fields Properties See Also Send Feedback

The ProgressBar type exposes the following members.

Constructors

 | Name | Description
Public method | ProgressBar | Initializes a new instance of the ProgressBar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsIndeterminateProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsIndeterminate |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ProgressBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Constructor
ProgressBar Class See Also Send Feedback
Initializes a new instance of the ProgressBar class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ProgressBar()
Visual Basic
Public Sub New
Visual C++
public:
ProgressBar()

See Also

ProgressBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ProgressBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Fields
ProgressBar Class See Also Send Feedback

The ProgressBar type exposes the following members.

Fields

Name | Description
IsIndeterminateProperty |

See Also

ProgressBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsIndeterminateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..IsIndeterminateProperty Field
ProgressBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ProgressBar.IsIndeterminateProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsIndeterminateProperty
Visual Basic
Public Shared IsIndeterminateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsIndeterminateProperty

See Also

ProgressBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ProgressBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Methods
ProgressBar Class See Also Send Feedback

The ProgressBar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..AnySibling Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..GetProperty Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..GetRealType Method
ProgressBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ProgressBar.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ProgressBar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ProgressBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..GetRectangle Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..Highlight Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..InvokeMethod Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..IsHitTest Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..NextSibling Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..Parent Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..PreviousSibling Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..ScrollToVisible Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar..::..SetProperty Method
ProgressBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ProgressBar Class
ProgressBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ProgressBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ProgressBar Properties
ProgressBar Class See Also Send Feedback

The ProgressBar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsIndeterminate |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ProgressBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


QuadraticBezierSegment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment Members
QuadraticBezierSegment Class Constructors Methods Fields Properties See Also Send Feedback

The QuadraticBezierSegment type exposes the following members.

Constructors

 | Name | Description
Public method | QuadraticBezierSegment | Initializes a new instance of the QuadraticBezierSegment class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Point1Property |
Point2Property |

Properties

 | Name | Description
Public property | Point1 |
Public property | Point2 |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

QuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


QuadraticBezierSegment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment Constructor
QuadraticBezierSegment Class See Also Send Feedback
Initializes a new instance of the QuadraticBezierSegment class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public QuadraticBezierSegment()
Visual Basic
Public Sub New
Visual C++
public:
QuadraticBezierSegment()

See Also

QuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


QuadraticBezierSegment Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment Fields
QuadraticBezierSegment Class See Also Send Feedback

The QuadraticBezierSegment type exposes the following members.

Fields

Name | Description
Point1Property |
Point2Property |

See Also

QuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point1Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment..::..Point1Property Field
QuadraticBezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.QuadraticBezierSegment.Point1Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Point1Property
Visual Basic
Public Shared Point1Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Point1Property

See Also

QuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Point2Property Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment..::..Point2Property Field
QuadraticBezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.QuadraticBezierSegment.Point2Property"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty Point2Property
Visual Basic
Public Shared Point2Property As AutomationProperty
Visual C++
public:
static AutomationProperty^ Point2Property

See Also

QuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


QuadraticBezierSegment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment Methods
QuadraticBezierSegment Class See Also Send Feedback

The QuadraticBezierSegment type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides PathSegment..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment..::..GetProperty Method
QuadraticBezierSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

QuadraticBezierSegment Class
QuadraticBezierSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment..::..GetRealType Method
QuadraticBezierSegment Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.QuadraticBezierSegment.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.QuadraticBezierSegment.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

QuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment..::..InvokeMethod Method
QuadraticBezierSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

QuadraticBezierSegment Class
QuadraticBezierSegment Members
ArtOfTest.WebAii.Silverlight.UI Namespace


QuadraticBezierSegment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
QuadraticBezierSegment Properties
QuadraticBezierSegment Class See Also Send Feedback

The QuadraticBezierSegment type exposes the following members.

Properties

 | Name | Description
Public property | Point1 |
Public property | Point2 |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

QuadraticBezierSegment Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadialGradientBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Members
RadialGradientBrush Class Constructors Methods Fields Properties See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Constructors

 | Name | Description
Public method | RadialGradientBrush | Initializes a new instance of the RadialGradientBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides GradientBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterProperty |
GradientOriginProperty |
RadiusXProperty |
RadiusYProperty |

Properties

 | Name | Description
Public property | Center |
Public property | ColorInterpolationMode | (Inherited from GradientBrush.)
Public property | GradientOrigin |
Public property | GradientStops | (Inherited from GradientBrush.)
Public property | MappingMode | (Inherited from GradientBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod | (Inherited from GradientBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadialGradientBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Constructor
RadialGradientBrush Class See Also Send Feedback
Initializes a new instance of the RadialGradientBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RadialGradientBrush()
Visual Basic
Public Sub New
Visual C++
public:
RadialGradientBrush()

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadialGradientBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Fields
RadialGradientBrush Class See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Fields

Name | Description
CenterProperty |
GradientOriginProperty |
RadiusXProperty |
RadiusYProperty |

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..CenterProperty Field
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RadialGradientBrush.CenterProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterProperty
Visual Basic
Public Shared CenterProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterProperty

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GradientOriginProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..GradientOriginProperty Field
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RadialGradientBrush.GradientOriginProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GradientOriginProperty
Visual Basic
Public Shared GradientOriginProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GradientOriginProperty

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..RadiusXProperty Field
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RadialGradientBrush.RadiusXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusXProperty
Visual Basic
Public Shared RadiusXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusXProperty

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..RadiusYProperty Field
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RadialGradientBrush.RadiusYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusYProperty
Visual Basic
Public Shared RadiusYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusYProperty

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadialGradientBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Methods
RadialGradientBrush Class See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides GradientBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..GetProperty Method
RadialGradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadialGradientBrush Class
RadialGradientBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..GetRealType Method
RadialGradientBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RadialGradientBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RadialGradientBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush..::..InvokeMethod Method
RadialGradientBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadialGradientBrush Class
RadialGradientBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


RadialGradientBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadialGradientBrush Properties
RadialGradientBrush Class See Also Send Feedback

The RadialGradientBrush type exposes the following members.

Properties

 | Name | Description
Public property | Center |
Public property | ColorInterpolationMode | (Inherited from GradientBrush.)
Public property | GradientOrigin |
Public property | GradientStops | (Inherited from GradientBrush.)
Public property | MappingMode | (Inherited from GradientBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SpreadMethod | (Inherited from GradientBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

RadialGradientBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadioButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Members
RadioButton Class Constructors Methods Fields Properties See Also Send Feedback

The RadioButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadioButton | Initializes a new instance of the RadioButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
GroupNameProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check icon element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | GroupName |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadioButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadioButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Constructor
RadioButton Class See Also Send Feedback
Initializes a new instance of the RadioButton class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RadioButton()
Visual Basic
Public Sub New
Visual C++
public:
RadioButton()

See Also

RadioButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadioButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Fields
RadioButton Class See Also Send Feedback

The RadioButton type exposes the following members.

Fields

Name | Description
GroupNameProperty |

See Also

RadioButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GroupNameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GroupNameProperty Field
RadioButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RadioButton.GroupNameProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty GroupNameProperty
Visual Basic
Public Shared GroupNameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ GroupNameProperty

See Also

RadioButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadioButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Methods
RadioButton Class See Also Send Feedback

The RadioButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ToggleButton..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. (Inherited from ToggleButton.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property. (Inherited from ToggleButton.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RadioButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..AnySibling Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GetProperty Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GetRealType Method
RadioButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RadioButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RadioButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RadioButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..GetRectangle Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..Highlight Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..InvokeMethod Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..IsHitTest Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..NextSibling Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..Parent Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..PreviousSibling Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..ScrollToVisible Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton..::..SetProperty Method
RadioButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RadioButton Class
RadioButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


RadioButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadioButton Properties
RadioButton Class See Also Send Feedback

The RadioButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check icon element. Override for custom control template. (Inherited from ToggleButton.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | GroupName |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsChecked | (Inherited from ToggleButton.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState | (Inherited from ToggleButton.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RadioButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RangeBase Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Members
RangeBase Class Constructors Methods Fields Properties See Also Send Feedback

The RangeBase type exposes the following members.

Constructors

 | Name | Description
Public method | RangeBase | Initializes a new instance of the RangeBase class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
LargeChangeProperty |
MaximumProperty |
MinimumProperty |
SmallChangeProperty |
ValueProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LargeChange |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RangeBase Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Constructor
RangeBase Class See Also Send Feedback
Initializes a new instance of the RangeBase class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RangeBase()
Visual Basic
Public Sub New
Visual C++
public:
RangeBase()

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RangeBase Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Fields
RangeBase Class See Also Send Feedback

The RangeBase type exposes the following members.

Fields

Name | Description
LargeChangeProperty |
MaximumProperty |
MinimumProperty |
SmallChangeProperty |
ValueProperty |

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LargeChangeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..LargeChangeProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RangeBase.LargeChangeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LargeChangeProperty
Visual Basic
Public Shared LargeChangeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LargeChangeProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaximumProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..MaximumProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RangeBase.MaximumProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaximumProperty
Visual Basic
Public Shared MaximumProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaximumProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MinimumProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..MinimumProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RangeBase.MinimumProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinimumProperty
Visual Basic
Public Shared MinimumProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinimumProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SmallChangeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..SmallChangeProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RangeBase.SmallChangeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SmallChangeProperty
Visual Basic
Public Shared SmallChangeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SmallChangeProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ValueProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..ValueProperty Field
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RangeBase.ValueProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ValueProperty
Visual Basic
Public Shared ValueProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ValueProperty

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RangeBase Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Methods
RangeBase Class See Also Send Feedback

The RangeBase type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..AnySibling Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..GetProperty Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..GetRealType Method
RangeBase Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RangeBase.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RangeBase.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..GetRectangle Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..Highlight Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..InvokeMethod Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..IsHitTest Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..NextSibling Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..Parent Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..PreviousSibling Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..ScrollToVisible Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase..::..SetProperty Method
RangeBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RangeBase Class
RangeBase Members
ArtOfTest.WebAii.Silverlight.UI Namespace


RangeBase Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RangeBase Properties
RangeBase Class See Also Send Feedback

The RangeBase type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LargeChange |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum |
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value |
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RangeBase Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rect Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Members
Rect Class Constructors Methods Fields Properties See Also Send Feedback

The Rect type exposes the following members.

Constructors

 | Name | Description
Public method | Rect | Initializes a new instance of the Rect class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BottomProperty |
HeightProperty |
IsEmptyProperty |
LeftProperty |
RightProperty |
TopProperty |
WidthProperty |
XProperty |
YProperty |

Properties

 | Name | Description
Public property | Bottom |
Public property | Height |
Public property | IsEmpty |
Public property | Left |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Right |
Public property | Top |
Public property | Width |
Public property | X |
Public property | Y |

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rect Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Constructor
Rect Class See Also Send Feedback
Initializes a new instance of the Rect class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rect()
Visual Basic
Public Sub New
Visual C++
public:
Rect()

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rect Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Fields
Rect Class See Also Send Feedback

The Rect type exposes the following members.

Fields

Name | Description
BottomProperty |
HeightProperty |
IsEmptyProperty |
LeftProperty |
RightProperty |
TopProperty |
WidthProperty |
XProperty |
YProperty |

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BottomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..BottomProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.BottomProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomProperty
Visual Basic
Public Shared BottomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..HeightProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.HeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeightProperty
Visual Basic
Public Shared HeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeightProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsEmptyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..IsEmptyProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.IsEmptyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEmptyProperty
Visual Basic
Public Shared IsEmptyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEmptyProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..LeftProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.LeftProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LeftProperty
Visual Basic
Public Shared LeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LeftProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..RightProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.RightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RightProperty
Visual Basic
Public Shared RightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RightProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..TopProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.TopProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopProperty
Visual Basic
Public Shared TopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..WidthProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.WidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..XProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.XProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..YProperty Field
Rect Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rect.YProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rect Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Methods
Rect Class See Also Send Feedback

The Rect type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..GetProperty Method
Rect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rect Class
Rect Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..GetRealType Method
Rect Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Rect.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Rect.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect..::..InvokeMethod Method
Rect Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rect Class
Rect Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Rect Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rect Properties
Rect Class See Also Send Feedback

The Rect type exposes the following members.

Properties

 | Name | Description
Public property | Bottom |
Public property | Height |
Public property | IsEmpty |
Public property | Left |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Right |
Public property | Top |
Public property | Width |
Public property | X |
Public property | Y |

See Also

Rect Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rectangle Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Members
Rectangle Class Constructors Methods Fields Properties See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | Rectangle | Initializes a new instance of the Rectangle class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
RadiusXProperty |
RadiusYProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Rectangle Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rectangle Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Constructor
Rectangle Class See Also Send Feedback
Initializes a new instance of the Rectangle class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Rectangle()
Visual Basic
Public Sub New
Visual C++
public:
Rectangle()

See Also

Rectangle Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rectangle Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Fields
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Fields

Name | Description
RadiusXProperty |
RadiusYProperty |

See Also

Rectangle Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..RadiusXProperty Field
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rectangle.RadiusXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusXProperty
Visual Basic
Public Shared RadiusXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusXProperty

See Also

Rectangle Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..RadiusYProperty Field
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Rectangle.RadiusYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusYProperty
Visual Basic
Public Shared RadiusYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusYProperty

See Also

Rectangle Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Rectangle Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Shape..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Rectangle Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..AnySibling Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..GetProperty Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..GetRealType Method
Rectangle Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Rectangle.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Rectangle.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Rectangle Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..GetRectangle Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..Highlight Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..InvokeMethod Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..IsHitTest Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..NextSibling Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..Parent Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..PreviousSibling Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..ScrollToVisible Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle..::..SetProperty Method
Rectangle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Rectangle Class
Rectangle Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Rectangle Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill | (Inherited from Shape.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch | (Inherited from Shape.)
Public property | Stroke | (Inherited from Shape.)
Public property | StrokeDashCap | (Inherited from Shape.)
Public property | StrokeDashOffset | (Inherited from Shape.)
Public property | StrokeEndLineCap | (Inherited from Shape.)
Public property | StrokeLineJoin | (Inherited from Shape.)
Public property | StrokeMiterLimit | (Inherited from Shape.)
Public property | StrokeStartLineCap | (Inherited from Shape.)
Public property | StrokeThickness | (Inherited from Shape.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Rectangle Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RectangleGeometry Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Members
RectangleGeometry Class Constructors Methods Fields Properties See Also Send Feedback

The RectangleGeometry type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleGeometry | Initializes a new instance of the RectangleGeometry class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
RadiusXProperty |
RadiusYProperty |
RectProperty |

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Rect |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RectangleGeometry Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Constructor
RectangleGeometry Class See Also Send Feedback
Initializes a new instance of the RectangleGeometry class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RectangleGeometry()
Visual Basic
Public Sub New
Visual C++
public:
RectangleGeometry()

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RectangleGeometry Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Fields
RectangleGeometry Class See Also Send Feedback

The RectangleGeometry type exposes the following members.

Fields

Name | Description
RadiusXProperty |
RadiusYProperty |
RectProperty |

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..RadiusXProperty Field
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RectangleGeometry.RadiusXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusXProperty
Visual Basic
Public Shared RadiusXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusXProperty

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RadiusYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..RadiusYProperty Field
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RectangleGeometry.RadiusYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RadiusYProperty
Visual Basic
Public Shared RadiusYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RadiusYProperty

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RectProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..RectProperty Field
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RectangleGeometry.RectProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RectProperty
Visual Basic
Public Shared RectProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RectProperty

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RectangleGeometry Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Methods
RectangleGeometry Class See Also Send Feedback

The RectangleGeometry type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Geometry..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..GetProperty Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RectangleGeometry Class
RectangleGeometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..GetRealType Method
RectangleGeometry Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RectangleGeometry.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RectangleGeometry.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry..::..InvokeMethod Method
RectangleGeometry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RectangleGeometry Class
RectangleGeometry Members
ArtOfTest.WebAii.Silverlight.UI Namespace


RectangleGeometry Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RectangleGeometry Properties
RectangleGeometry Class See Also Send Feedback

The RectangleGeometry type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | (Inherited from Geometry.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RadiusX |
Public property | RadiusY |
Public property | Rect |
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Transform | (Inherited from Geometry.)

See Also

RectangleGeometry Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RepeatButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Members
RepeatButton Class Constructors Methods Fields Properties See Also Send Feedback

The RepeatButton type exposes the following members.

Constructors

 | Name | Description
Public method | RepeatButton | Initializes a new instance of the RepeatButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UserPress | Press and hold the RepeatButton for the specified number of milliseconds
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
DelayProperty |
IntervalProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Delay |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Interval |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RepeatButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Constructor
RepeatButton Class See Also Send Feedback
Initializes a new instance of the RepeatButton class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RepeatButton()
Visual Basic
Public Sub New
Visual C++
public:
RepeatButton()

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RepeatButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Fields
RepeatButton Class See Also Send Feedback

The RepeatButton type exposes the following members.

Fields

Name | Description
DelayProperty |
IntervalProperty |

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DelayProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..DelayProperty Field
RepeatButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RepeatButton.DelayProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DelayProperty
Visual Basic
Public Shared DelayProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DelayProperty

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IntervalProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..IntervalProperty Field
RepeatButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RepeatButton.IntervalProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IntervalProperty
Visual Basic
Public Shared IntervalProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IntervalProperty

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RepeatButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Methods
RepeatButton Class See Also Send Feedback

The RepeatButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UserPress | Press and hold the RepeatButton for the specified number of milliseconds
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..AnySibling Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..GetProperty Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..GetRealType Method
RepeatButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RepeatButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RepeatButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..GetRectangle Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..Highlight Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..InvokeMethod Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..IsHitTest Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..NextSibling Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..Parent Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..PreviousSibling Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..ScrollToVisible Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..SetProperty Method
RepeatButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RepeatButton Class
RepeatButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


UserPress Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton..::..UserPress Method
RepeatButton Class See Also Send Feedback
Press and hold the RepeatButton for the specified number of milliseconds

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void UserPress(
    int holdTime
)
Visual Basic
Public Sub UserPress ( _
    holdTime As Integer _
)
Visual C++
public:
virtual void UserPress(
    int holdTime
) sealed

Parameters

holdTime
Type: System..::..Int32
The number of milliseconds to hold the button down for

Implements

IRepeatButton..::..UserPress(Int32)

Remarks

Due to inaccuracies in automation and Silverlight timing, the hold time is approximate.

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RepeatButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RepeatButton Properties
RepeatButton Class See Also Send Feedback

The RepeatButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Delay |
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Interval |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RepeatButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RichTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Members
RichTextBox Class Constructors Methods Fields Properties See Also Send Feedback

The RichTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | RichTextBox | Initializes a new instance of the RichTextBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AcceptsReturnProperty |
CaretBrushProperty |
IsReadOnlyProperty |
TextAlignmentProperty |
TextWrappingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn |
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaretBrush |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsReadOnly |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RichTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Constructor
RichTextBox Class See Also Send Feedback
Initializes a new instance of the RichTextBox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RichTextBox()
Visual Basic
Public Sub New
Visual C++
public:
RichTextBox()

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RichTextBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Fields
RichTextBox Class See Also Send Feedback

The RichTextBox type exposes the following members.

Fields

Name | Description
AcceptsReturnProperty |
CaretBrushProperty |
IsReadOnlyProperty |
TextAlignmentProperty |
TextWrappingProperty |

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AcceptsReturnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..AcceptsReturnProperty Field
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RichTextBox.AcceptsReturnProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AcceptsReturnProperty
Visual Basic
Public Shared AcceptsReturnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AcceptsReturnProperty

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CaretBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..CaretBrushProperty Field
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RichTextBox.CaretBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CaretBrushProperty
Visual Basic
Public Shared CaretBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CaretBrushProperty

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..IsReadOnlyProperty Field
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RichTextBox.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..TextAlignmentProperty Field
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RichTextBox.TextAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextAlignmentProperty
Visual Basic
Public Shared TextAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextAlignmentProperty

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextWrappingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..TextWrappingProperty Field
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RichTextBox.TextWrappingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextWrappingProperty
Visual Basic
Public Shared TextWrappingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextWrappingProperty

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RichTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Methods
RichTextBox Class See Also Send Feedback

The RichTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..AnySibling Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..GetProperty Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..GetRealType Method
RichTextBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RichTextBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RichTextBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..GetRectangle Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..Highlight Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..InvokeMethod Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..IsHitTest Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..NextSibling Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..Parent Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..PreviousSibling Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..ScrollToVisible Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox..::..SetProperty Method
RichTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RichTextBox Class
RichTextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


RichTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RichTextBox Properties
RichTextBox Class See Also Send Feedback

The RichTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn |
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaretBrush |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsReadOnly |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

RichTextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RotateTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Members
RotateTransform Class Constructors Methods Fields Properties See Also Send Feedback

The RotateTransform type exposes the following members.

Constructors

 | Name | Description
Public method | RotateTransform | Initializes a new instance of the RotateTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AngleProperty |
CenterXProperty |
CenterYProperty |

Properties

 | Name | Description
Public property | Angle |
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RotateTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Constructor
RotateTransform Class See Also Send Feedback
Initializes a new instance of the RotateTransform class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public RotateTransform()
Visual Basic
Public Sub New
Visual C++
public:
RotateTransform()

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RotateTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Fields
RotateTransform Class See Also Send Feedback

The RotateTransform type exposes the following members.

Fields

Name | Description
AngleProperty |
CenterXProperty |
CenterYProperty |

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AngleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..AngleProperty Field
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RotateTransform.AngleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AngleProperty
Visual Basic
Public Shared AngleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AngleProperty

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..CenterXProperty Field
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RotateTransform.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..CenterYProperty Field
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.RotateTransform.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RotateTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Methods
RotateTransform Class See Also Send Feedback

The RotateTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..GetProperty Method
RotateTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform Class
RotateTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..GetRealType Method
RotateTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RotateTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.RotateTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform..::..InvokeMethod Method
RotateTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform Class
RotateTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


RotateTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotateTransform Properties
RotateTransform Class See Also Send Feedback

The RotateTransform type exposes the following members.

Properties

 | Name | Description
Public property | Angle |
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

RotateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Members
ScaleTransform Class Constructors Methods Fields Properties See Also Send Feedback

The ScaleTransform type exposes the following members.

Constructors

 | Name | Description
Public method | ScaleTransform | Initializes a new instance of the ScaleTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CenterXProperty |
CenterYProperty |
ScaleXProperty |
ScaleYProperty |

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ScaleX |
Public property | ScaleY |

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Constructor
ScaleTransform Class See Also Send Feedback
Initializes a new instance of the ScaleTransform class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScaleTransform()
Visual Basic
Public Sub New
Visual C++
public:
ScaleTransform()

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Fields
ScaleTransform Class See Also Send Feedback

The ScaleTransform type exposes the following members.

Fields

Name | Description
CenterXProperty |
CenterYProperty |
ScaleXProperty |
ScaleYProperty |

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..CenterXProperty Field
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScaleTransform.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..CenterYProperty Field
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScaleTransform.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..ScaleXProperty Field
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScaleTransform.ScaleXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleXProperty
Visual Basic
Public Shared ScaleXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleXProperty

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..ScaleYProperty Field
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScaleTransform.ScaleYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScaleYProperty
Visual Basic
Public Shared ScaleYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScaleYProperty

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Methods
ScaleTransform Class See Also Send Feedback

The ScaleTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..GetProperty Method
ScaleTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScaleTransform Class
ScaleTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..GetRealType Method
ScaleTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ScaleTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ScaleTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform..::..InvokeMethod Method
ScaleTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScaleTransform Class
ScaleTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScaleTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScaleTransform Properties
ScaleTransform Class See Also Send Feedback

The ScaleTransform type exposes the following members.

Properties

 | Name | Description
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | ScaleX |
Public property | ScaleY |

See Also

ScaleTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Members
ScrollBar Class Constructors Methods Fields Properties See Also Send Feedback

The ScrollBar type exposes the following members.

Constructors

 | Name | Description
Public method | ScrollBar | Initializes a new instance of the ScrollBar class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
OrientationProperty |
ViewportSizeProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | ViewportSize |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Constructor
ScrollBar Class See Also Send Feedback
Initializes a new instance of the ScrollBar class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollBar()
Visual Basic
Public Sub New
Visual C++
public:
ScrollBar()

See Also

ScrollBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Fields
ScrollBar Class See Also Send Feedback

The ScrollBar type exposes the following members.

Fields

Name | Description
OrientationProperty |
ViewportSizeProperty |

See Also

ScrollBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..OrientationProperty Field
ScrollBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollBar.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

ScrollBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..ViewportSizeProperty Field
ScrollBar Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollBar.ViewportSizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportSizeProperty
Visual Basic
Public Shared ViewportSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportSizeProperty

See Also

ScrollBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Methods
ScrollBar Class See Also Send Feedback

The ScrollBar type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..AnySibling Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..GetProperty Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..GetRealType Method
ScrollBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ScrollBar.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ScrollBar.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScrollBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..GetRectangle Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..Highlight Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..InvokeMethod Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..IsHitTest Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..NextSibling Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..Parent Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..PreviousSibling Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..ScrollToVisible Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar..::..SetProperty Method
ScrollBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollBar Class
ScrollBar Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollBar Properties
ScrollBar Class See Also Send Feedback

The ScrollBar type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | ViewportSize |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollBar Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollContentPresenter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Members
ScrollContentPresenter Class Constructors Methods Properties See Also Send Feedback

The ScrollContentPresenter type exposes the following members.

Constructors

 | Name | Description
Public method | ScrollContentPresenter | Initializes a new instance of the ScrollContentPresenter class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentPresenter..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentPresenter.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollContentPresenter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Constructor
ScrollContentPresenter Class See Also Send Feedback
Initializes a new instance of the ScrollContentPresenter class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollContentPresenter()
Visual Basic
Public Sub New
Visual C++
public:
ScrollContentPresenter()

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollContentPresenter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Methods
ScrollContentPresenter Class See Also Send Feedback

The ScrollContentPresenter type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentPresenter..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..AnySibling Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..GetProperty Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..GetRealType Method
ScrollContentPresenter Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ScrollContentPresenter.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ScrollContentPresenter.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..GetRectangle Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..Highlight Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..InvokeMethod Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..IsHitTest Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..NextSibling Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..Parent Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..PreviousSibling Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..ScrollToVisible Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter..::..SetProperty Method
ScrollContentPresenter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollContentPresenter Class
ScrollContentPresenter Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollContentPresenter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollContentPresenter Properties
ScrollContentPresenter Class See Also Send Feedback

The ScrollContentPresenter type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentPresenter.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollContentPresenter Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollViewer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Members
ScrollViewer Class Constructors Methods Fields Properties See Also Send Feedback

The ScrollViewer type exposes the following members.

Constructors

 | Name | Description
Public method | ScrollViewer | Initializes a new instance of the ScrollViewer class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
ComputedHorizontalScrollBarVisibilityProperty |
ComputedVerticalScrollBarVisibilityProperty |
ExtentHeightProperty |
ExtentWidthProperty |
HorizontalOffsetProperty |
HorizontalScrollBarVisibilityProperty |
ScrollableHeightProperty |
ScrollableWidthProperty |
VerticalOffsetProperty |
VerticalScrollBarVisibilityProperty |
ViewportHeightProperty |
ViewportWidthProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedHorizontalScrollBarVisibility |
Public property | ComputedVerticalScrollBarVisibility |
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExtentHeight |
Public property | ExtentWidth |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ScrollableHeight |
Public property | ScrollableWidth |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | VerticalScrollBarVisibility |
Public property | ViewportHeight |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollViewer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Constructor
ScrollViewer Class See Also Send Feedback
Initializes a new instance of the ScrollViewer class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ScrollViewer()
Visual Basic
Public Sub New
Visual C++
public:
ScrollViewer()

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollViewer Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Fields
ScrollViewer Class See Also Send Feedback

The ScrollViewer type exposes the following members.

Fields

Name | Description
ComputedHorizontalScrollBarVisibilityProperty |
ComputedVerticalScrollBarVisibilityProperty |
ExtentHeightProperty |
ExtentWidthProperty |
HorizontalOffsetProperty |
HorizontalScrollBarVisibilityProperty |
ScrollableHeightProperty |
ScrollableWidthProperty |
VerticalOffsetProperty |
VerticalScrollBarVisibilityProperty |
ViewportHeightProperty |
ViewportWidthProperty |

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComputedHorizontalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ComputedHorizontalScrollBarVisibilityProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.ComputedHorizontalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ComputedHorizontalScrollBarVisibilityProperty
Visual Basic
Public Shared ComputedHorizontalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ComputedHorizontalScrollBarVisibilityProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ComputedVerticalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ComputedVerticalScrollBarVisibilityProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.ComputedVerticalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ComputedVerticalScrollBarVisibilityProperty
Visual Basic
Public Shared ComputedVerticalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ComputedVerticalScrollBarVisibilityProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ExtentHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ExtentHeightProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.ExtentHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExtentHeightProperty
Visual Basic
Public Shared ExtentHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExtentHeightProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ExtentWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ExtentWidthProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.ExtentWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExtentWidthProperty
Visual Basic
Public Shared ExtentWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExtentWidthProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..HorizontalOffsetProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..HorizontalScrollBarVisibilityProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.HorizontalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalScrollBarVisibilityProperty
Visual Basic
Public Shared HorizontalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalScrollBarVisibilityProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollableHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ScrollableHeightProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.ScrollableHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScrollableHeightProperty
Visual Basic
Public Shared ScrollableHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScrollableHeightProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollableWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ScrollableWidthProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.ScrollableWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ScrollableWidthProperty
Visual Basic
Public Shared ScrollableWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ScrollableWidthProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..VerticalOffsetProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalScrollBarVisibilityProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..VerticalScrollBarVisibilityProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.VerticalScrollBarVisibilityProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalScrollBarVisibilityProperty
Visual Basic
Public Shared VerticalScrollBarVisibilityProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalScrollBarVisibilityProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ViewportHeightProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.ViewportHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportHeightProperty
Visual Basic
Public Shared ViewportHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportHeightProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ViewportWidthProperty Field
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.ViewportWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportWidthProperty
Visual Basic
Public Shared ViewportWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportWidthProperty

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollViewer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Methods
ScrollViewer Class See Also Send Feedback

The ScrollViewer type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..AnySibling Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..GetProperty Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..GetRealType Method
ScrollViewer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ScrollViewer.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..GetRectangle Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..Highlight Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..InvokeMethod Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..IsHitTest Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..NextSibling Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..Parent Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..PreviousSibling Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..ScrollToVisible Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer..::..SetProperty Method
ScrollViewer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ScrollViewer Class
ScrollViewer Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollViewer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ScrollViewer Properties
ScrollViewer Class See Also Send Feedback

The ScrollViewer type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedHorizontalScrollBarVisibility |
Public property | ComputedVerticalScrollBarVisibility |
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExtentHeight |
Public property | ExtentWidth |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | HorizontalScrollBarVisibility |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | ScrollableHeight |
Public property | ScrollableWidth |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | VerticalScrollBarVisibility |
Public property | ViewportHeight |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ScrollViewer Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Selector Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Members
Selector Class Constructors Methods Fields Properties See Also Send Feedback

The Selector type exposes the following members.

Constructors

 | Name | Description
Public method | Selector | Initializes a new instance of the Selector class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsSynchronizedWithCurrentItemProperty |
SelectedIndexProperty |
SelectedValuePathProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSynchronizedWithCurrentItem |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex |
Public property | SelectedValuePath |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Selector Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Constructor
Selector Class See Also Send Feedback
Initializes a new instance of the Selector class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Selector()
Visual Basic
Public Sub New
Visual C++
public:
Selector()

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Selector Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Fields
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Fields

Name | Description
IsSynchronizedWithCurrentItemProperty |
SelectedIndexProperty |
SelectedValuePathProperty |

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSynchronizedWithCurrentItemProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..IsSynchronizedWithCurrentItemProperty Field
Selector Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Selector.IsSynchronizedWithCurrentItemProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSynchronizedWithCurrentItemProperty
Visual Basic
Public Shared IsSynchronizedWithCurrentItemProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSynchronizedWithCurrentItemProperty

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..SelectedIndexProperty Field
Selector Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Selector.SelectedIndexProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedIndexProperty
Visual Basic
Public Shared SelectedIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedIndexProperty

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedValuePathProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..SelectedValuePathProperty Field
Selector Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Selector.SelectedValuePathProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedValuePathProperty
Visual Basic
Public Shared SelectedValuePathProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedValuePathProperty

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Selector Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Methods
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..AnySibling Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..GetProperty Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..GetRealType Method
Selector Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Selector.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Selector.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..GetRectangle Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..Highlight Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..InvokeMethod Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..IsHitTest Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..NextSibling Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..Parent Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..PreviousSibling Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..ScrollToVisible Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector..::..SetProperty Method
Selector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Selector Class
Selector Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Selector Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Selector Properties
Selector Class See Also Send Feedback

The Selector type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSynchronizedWithCurrentItem |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex |
Public property | SelectedValuePath |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Selector Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Shape Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Members
Shape Class Constructors Methods Fields Properties See Also Send Feedback

The Shape type exposes the following members.

Constructors

 | Name | Description
Public method | Shape | Initializes a new instance of the Shape class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FillProperty |
StretchProperty |
StrokeDashCapProperty |
StrokeDashOffsetProperty |
StrokeEndLineCapProperty |
StrokeLineJoinProperty |
StrokeMiterLimitProperty |
StrokeProperty |
StrokeStartLineCapProperty |
StrokeThicknessProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch |
Public property | Stroke |
Public property | StrokeDashCap |
Public property | StrokeDashOffset |
Public property | StrokeEndLineCap |
Public property | StrokeLineJoin |
Public property | StrokeMiterLimit |
Public property | StrokeStartLineCap |
Public property | StrokeThickness |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Shape Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Constructor
Shape Class See Also Send Feedback
Initializes a new instance of the Shape class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Shape()
Visual Basic
Public Sub New
Visual C++
public:
Shape()

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Shape Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Fields
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Fields

Name | Description
FillProperty |
StretchProperty |
StrokeDashCapProperty |
StrokeDashOffsetProperty |
StrokeEndLineCapProperty |
StrokeLineJoinProperty |
StrokeMiterLimitProperty |
StrokeProperty |
StrokeStartLineCapProperty |
StrokeThicknessProperty |

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FillProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..FillProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.FillProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FillProperty
Visual Basic
Public Shared FillProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FillProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StretchProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StrokeDashCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeDashCapProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StrokeDashCapProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeDashCapProperty
Visual Basic
Public Shared StrokeDashCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeDashCapProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StrokeDashOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeDashOffsetProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StrokeDashOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeDashOffsetProperty
Visual Basic
Public Shared StrokeDashOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeDashOffsetProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StrokeEndLineCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeEndLineCapProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StrokeEndLineCapProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeEndLineCapProperty
Visual Basic
Public Shared StrokeEndLineCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeEndLineCapProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StrokeLineJoinProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeLineJoinProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StrokeLineJoinProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeLineJoinProperty
Visual Basic
Public Shared StrokeLineJoinProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeLineJoinProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StrokeMiterLimitProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeMiterLimitProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StrokeMiterLimitProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeMiterLimitProperty
Visual Basic
Public Shared StrokeMiterLimitProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeMiterLimitProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StrokeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StrokeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeProperty
Visual Basic
Public Shared StrokeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StrokeStartLineCapProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeStartLineCapProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StrokeStartLineCapProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeStartLineCapProperty
Visual Basic
Public Shared StrokeStartLineCapProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeStartLineCapProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StrokeThicknessProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..StrokeThicknessProperty Field
Shape Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Shape.StrokeThicknessProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StrokeThicknessProperty
Visual Basic
Public Shared StrokeThicknessProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StrokeThicknessProperty

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Shape Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Methods
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..AnySibling Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..GetProperty Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..GetRealType Method
Shape Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Shape.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Shape.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..GetRectangle Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..Highlight Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..InvokeMethod Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..IsHitTest Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..NextSibling Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..Parent Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..PreviousSibling Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..ScrollToVisible Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape..::..SetProperty Method
Shape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Shape Class
Shape Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Shape Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Shape Properties
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Fill |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch |
Public property | Stroke |
Public property | StrokeDashCap |
Public property | StrokeDashOffset |
Public property | StrokeEndLineCap |
Public property | StrokeLineJoin |
Public property | StrokeMiterLimit |
Public property | StrokeStartLineCap |
Public property | StrokeThickness |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Shape Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Size Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Members
Size Class Constructors Methods Fields Properties See Also Send Feedback

The Size type exposes the following members.

Constructors

 | Name | Description
Public method | Size | Initializes a new instance of the Size class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
HeightProperty |
IsEmptyProperty |
WidthProperty |

Properties

 | Name | Description
Public property | Height |
Public property | IsEmpty |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Width |

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Size Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Constructor
Size Class See Also Send Feedback
Initializes a new instance of the Size class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Size()
Visual Basic
Public Sub New
Visual C++
public:
Size()

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Size Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Fields
Size Class See Also Send Feedback

The Size type exposes the following members.

Fields

Name | Description
HeightProperty |
IsEmptyProperty |
WidthProperty |

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..HeightProperty Field
Size Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Size.HeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeightProperty
Visual Basic
Public Shared HeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeightProperty

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsEmptyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..IsEmptyProperty Field
Size Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Size.IsEmptyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsEmptyProperty
Visual Basic
Public Shared IsEmptyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsEmptyProperty

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..WidthProperty Field
Size Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Size.WidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty WidthProperty
Visual Basic
Public Shared WidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ WidthProperty

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Size Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Methods
Size Class See Also Send Feedback

The Size type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..GetProperty Method
Size Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Size Class
Size Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..GetRealType Method
Size Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Size.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Size.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size..::..InvokeMethod Method
Size Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Size Class
Size Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Size Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Size Properties
Size Class See Also Send Feedback

The Size type exposes the following members.

Properties

 | Name | Description
Public property | Height |
Public property | IsEmpty |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Width |

See Also

Size Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Members
SkewTransform Class Constructors Methods Fields Properties See Also Send Feedback

The SkewTransform type exposes the following members.

Constructors

 | Name | Description
Public method | SkewTransform | Initializes a new instance of the SkewTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AngleXProperty |
AngleYProperty |
CenterXProperty |
CenterYProperty |

Properties

 | Name | Description
Public property | AngleX |
Public property | AngleY |
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Constructor
SkewTransform Class See Also Send Feedback
Initializes a new instance of the SkewTransform class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SkewTransform()
Visual Basic
Public Sub New
Visual C++
public:
SkewTransform()

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Fields
SkewTransform Class See Also Send Feedback

The SkewTransform type exposes the following members.

Fields

Name | Description
AngleXProperty |
AngleYProperty |
CenterXProperty |
CenterYProperty |

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AngleXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..AngleXProperty Field
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.SkewTransform.AngleXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AngleXProperty
Visual Basic
Public Shared AngleXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AngleXProperty

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AngleYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..AngleYProperty Field
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.SkewTransform.AngleYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AngleYProperty
Visual Basic
Public Shared AngleYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AngleYProperty

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..CenterXProperty Field
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.SkewTransform.CenterXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterXProperty
Visual Basic
Public Shared CenterXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterXProperty

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CenterYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..CenterYProperty Field
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.SkewTransform.CenterYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CenterYProperty
Visual Basic
Public Shared CenterYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CenterYProperty

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Methods
SkewTransform Class See Also Send Feedback

The SkewTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..GetProperty Method
SkewTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SkewTransform Class
SkewTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..GetRealType Method
SkewTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.SkewTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.SkewTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform..::..InvokeMethod Method
SkewTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SkewTransform Class
SkewTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SkewTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SkewTransform Properties
SkewTransform Class See Also Send Feedback

The SkewTransform type exposes the following members.

Properties

 | Name | Description
Public property | AngleX |
Public property | AngleY |
Public property | CenterX |
Public property | CenterY |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SkewTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Slider Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Members
Slider Class Constructors Methods Fields Properties See Also Send Feedback

The Slider type exposes the following members.

Constructors

 | Name | Description
Public method | Slider | Initializes a new instance of the Slider class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetValue | Sets a new value into Slider.
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsDirectionReversedProperty |
IsFocusedProperty |
OrientationProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDirectionReversed |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Slider Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Constructor
Slider Class See Also Send Feedback
Initializes a new instance of the Slider class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Slider()
Visual Basic
Public Sub New
Visual C++
public:
Slider()

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Slider Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Fields
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Fields

Name | Description
IsDirectionReversedProperty |
IsFocusedProperty |
OrientationProperty |

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDirectionReversedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsDirectionReversedProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Slider.IsDirectionReversedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDirectionReversedProperty
Visual Basic
Public Shared IsDirectionReversedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDirectionReversedProperty

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsFocusedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsFocusedProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Slider.IsFocusedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFocusedProperty
Visual Basic
Public Shared IsFocusedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFocusedProperty

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..OrientationProperty Field
Slider Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Slider.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Slider Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Methods
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides RangeBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetValue | Sets a new value into Slider.
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..AnySibling Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..GetProperty Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..GetRealType Method
Slider Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Slider.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Slider.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..GetRectangle Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..Highlight Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..InvokeMethod Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..IsHitTest Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..NextSibling Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..Parent Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..PreviousSibling Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..ScrollToVisible Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..SetProperty Method
Slider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Slider Class
Slider Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider..::..SetValue Method
Slider Class See Also Send Feedback
Sets a new value into Slider.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetValue(
    double value
)
Visual Basic
Public Sub SetValue ( _
    value As Double _
)
Visual C++
public:
virtual void SetValue(
    double value
) sealed

Parameters

value
Type: System..::..Double
The new value.

Implements

ISlider..::..SetValue(Double)

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Slider Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Slider Properties
Slider Class See Also Send Feedback

The Slider type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDirectionReversed |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LargeChange | (Inherited from RangeBase.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | Maximum | (Inherited from RangeBase.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | Minimum | (Inherited from RangeBase.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SmallChange | (Inherited from RangeBase.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | Value | (Inherited from RangeBase.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Slider Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SolidColorBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Members
SolidColorBrush Class Constructors Methods Fields Properties See Also Send Feedback

The SolidColorBrush type exposes the following members.

Constructors

 | Name | Description
Public method | SolidColorBrush | Initializes a new instance of the SolidColorBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ColorProperty |

Properties

 | Name | Description
Public property | Color |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Transform | (Inherited from Brush.)

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SolidColorBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Constructor
SolidColorBrush Class See Also Send Feedback
Initializes a new instance of the SolidColorBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SolidColorBrush()
Visual Basic
Public Sub New
Visual C++
public:
SolidColorBrush()

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SolidColorBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Fields
SolidColorBrush Class See Also Send Feedback

The SolidColorBrush type exposes the following members.

Fields

Name | Description
ColorProperty |

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ColorProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..ColorProperty Field
SolidColorBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.SolidColorBrush.ColorProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ColorProperty
Visual Basic
Public Shared ColorProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ColorProperty

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SolidColorBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Methods
SolidColorBrush Class See Also Send Feedback

The SolidColorBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..GetProperty Method
SolidColorBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SolidColorBrush Class
SolidColorBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..GetRealType Method
SolidColorBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.SolidColorBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.SolidColorBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush..::..InvokeMethod Method
SolidColorBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

SolidColorBrush Class
SolidColorBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SolidColorBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SolidColorBrush Properties
SolidColorBrush Class See Also Send Feedback

The SolidColorBrush type exposes the following members.

Properties

 | Name | Description
Public property | Color |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Transform | (Inherited from Brush.)

See Also

SolidColorBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StackPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Members
StackPanel Class Constructors Methods Fields Properties See Also Send Feedback

The StackPanel type exposes the following members.

Constructors

 | Name | Description
Public method | StackPanel | Initializes a new instance of the StackPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
OrientationProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StackPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Constructor
StackPanel Class See Also Send Feedback
Initializes a new instance of the StackPanel class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StackPanel()
Visual Basic
Public Sub New
Visual C++
public:
StackPanel()

See Also

StackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StackPanel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Fields
StackPanel Class See Also Send Feedback

The StackPanel type exposes the following members.

Fields

Name | Description
OrientationProperty |

See Also

StackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..OrientationProperty Field
StackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.StackPanel.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

StackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StackPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Methods
StackPanel Class See Also Send Feedback

The StackPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

StackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..AnySibling Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..GetProperty Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..GetRealType Method
StackPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StackPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StackPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

StackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..GetRectangle Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..Highlight Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..InvokeMethod Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..IsHitTest Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..NextSibling Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..Parent Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..PreviousSibling Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..ScrollToVisible Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel..::..SetProperty Method
StackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

StackPanel Class
StackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


StackPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StackPanel Properties
StackPanel Class See Also Send Feedback

The StackPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

StackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StructSize Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructSize Members
StructSize Structure Constructors Methods Properties See Also Send Feedback

The StructSize type exposes the following members.

Constructors

 | Name | Description
Public method | StructSize | Initializes a new instance of the StructSize class

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | Height |
Public property | IsEmpty |
Public property | Width |

See Also

StructSize Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


StructSize Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructSize Constructor
StructSize Structure See Also Send Feedback
Initializes a new instance of the StructSize class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StructSize(
    Size live
)
Visual Basic
Public Sub New ( _
    live As Size _
)
Visual C++
public:
StructSize(
    Size^ live
)

Parameters

live
Type: ArtOfTest.WebAii.Silverlight.UI..::..Size

[Missing <param name="live"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructSize.#ctor(ArtOfTest.WebAii.Silverlight.UI.Size)"]

See Also

StructSize Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


StructSize Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructSize Methods
StructSize Structure See Also Send Feedback

The StructSize type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

See Also

StructSize Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


Parse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructSize..::..Parse Method
StructSize Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructSize.Parse(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static StructSize Parse(
    string toParse
)
Visual Basic
Public Shared Function Parse ( _
    toParse As String _
) As StructSize
Visual C++
public:
static StructSize Parse(
    String^ toParse
)

Parameters

toParse
Type: System..::..String

[Missing <param name="toParse"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructSize.Parse(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructSize.Parse(System.String)"]

See Also

StructSize Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructSize..::..ToString Method
StructSize Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructSize.ToString"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructSize.ToString"]

See Also

StructSize Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


StructSize Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructSize Properties
StructSize Structure See Also Send Feedback

The StructSize type exposes the following members.

Properties

 | Name | Description
Public property | Height |
Public property | IsEmpty |
Public property | Width |

See Also

StructSize Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


StructThickness Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructThickness Members
StructThickness Structure Constructors Methods Properties See Also Send Feedback

The StructThickness type exposes the following members.

Constructors

 | Name | Description
Public method | StructThickness | Initializes a new instance of the StructThickness class

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | Right |
Public property | Top |

See Also

StructThickness Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


StructThickness Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructThickness Constructor
StructThickness Structure See Also Send Feedback
Initializes a new instance of the StructThickness class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public StructThickness(
    Thickness live
)
Visual Basic
Public Sub New ( _
    live As Thickness _
)
Visual C++
public:
StructThickness(
    Thickness^ live
)

Parameters

live
Type: ArtOfTest.WebAii.Silverlight.UI..::..Thickness

[Missing <param name="live"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructThickness.#ctor(ArtOfTest.WebAii.Silverlight.UI.Thickness)"]

See Also

StructThickness Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


StructThickness Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructThickness Methods
StructThickness Structure See Also Send Feedback

The StructThickness type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | ToString | (Overrides ValueType..::..ToString()()()().)

See Also

StructThickness Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


Parse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructThickness..::..Parse Method
StructThickness Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructThickness.Parse(System.String)"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static StructThickness Parse(
    string toParse
)
Visual Basic
Public Shared Function Parse ( _
    toParse As String _
) As StructThickness
Visual C++
public:
static StructThickness Parse(
    String^ toParse
)

Parameters

toParse
Type: System..::..String

[Missing <param name="toParse"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructThickness.Parse(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructThickness.Parse(System.String)"]

See Also

StructThickness Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructThickness..::..ToString Method
StructThickness Structure See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructThickness.ToString"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.StructThickness.ToString"]

See Also

StructThickness Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


StructThickness Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
StructThickness Properties
StructThickness Structure See Also Send Feedback

The StructThickness type exposes the following members.

Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | Right |
Public property | Top |

See Also

StructThickness Structure
ArtOfTest.WebAii.Silverlight.UI Namespace


TabControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Members
TabControl Class Constructors Methods Fields Properties See Also Send Feedback

The TabControl type exposes the following members.

Constructors

 | Name | Description
Public method | TabControl | Initializes a new instance of the TabControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectTab | Selects the tab by its header text.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SelectedIndexProperty |
TabStripPlacementProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex |
Public property | TabIndex | (Inherited from Control.)
Public property | TabItemContainer | Gets the tab item container.
Public property | TabItems | Gets the tab items.
Public property | TabNavigation | (Inherited from Control.)
Public property | TabStripPlacement |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Constructor
TabControl Class See Also Send Feedback
Initializes a new instance of the TabControl class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TabControl()
Visual Basic
Public Sub New
Visual C++
public:
TabControl()

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabControl Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Fields
TabControl Class See Also Send Feedback

The TabControl type exposes the following members.

Fields

Name | Description
SelectedIndexProperty |
TabStripPlacementProperty |

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedIndexProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..SelectedIndexProperty Field
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TabControl.SelectedIndexProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedIndexProperty
Visual Basic
Public Shared SelectedIndexProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedIndexProperty

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabStripPlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..TabStripPlacementProperty Field
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TabControl.TabStripPlacementProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TabStripPlacementProperty
Visual Basic
Public Shared TabStripPlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TabStripPlacementProperty

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Methods
TabControl Class See Also Send Feedback

The TabControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | SelectTab | Selects the tab by its header text.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..AnySibling Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..AssignReference Method
TabControl Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference

[Missing <param name="reference"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TabControl.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..GetProperty Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..GetRealType Method
TabControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TabControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TabControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..GetRectangle Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..Highlight Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..InvokeMethod Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..IsHitTest Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..NextSibling Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..Parent Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..PreviousSibling Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..ScrollToVisible Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectTab Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..SelectTab Method
TabControl Class See Also Send Feedback
Selects the tab by its header text.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SelectTab(
    string headerText
)
Visual Basic
Public Sub SelectTab ( _
    headerText As String _
)
Visual C++
public:
void SelectTab(
    String^ headerText
)

Parameters

headerText
Type: System..::..String
The tab text in the header.

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl..::..SetProperty Method
TabControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabControl Class
TabControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TabControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabControl Properties
TabControl Class See Also Send Feedback

The TabControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectedIndex |
Public property | TabIndex | (Inherited from Control.)
Public property | TabItemContainer | Gets the tab item container.
Public property | TabItems | Gets the tab items.
Public property | TabNavigation | (Inherited from Control.)
Public property | TabStripPlacement |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Members
TabItem Class Constructors Methods Fields Properties See Also Send Feedback

The TabItem type exposes the following members.

Constructors

 | Name | Description
Public method | TabItem | Initializes a new instance of the TabItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HasHeaderProperty |
HeaderProperty |
IsFocusedProperty |
IsSelectedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader |
Public property | Header |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Constructor
TabItem Class See Also Send Feedback
Initializes a new instance of the TabItem class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TabItem()
Visual Basic
Public Sub New
Visual C++
public:
TabItem()

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Fields
TabItem Class See Also Send Feedback

The TabItem type exposes the following members.

Fields

Name | Description
HasHeaderProperty |
HeaderProperty |
IsFocusedProperty |
IsSelectedProperty |

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HasHeaderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..HasHeaderProperty Field
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TabItem.HasHeaderProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasHeaderProperty
Visual Basic
Public Shared HasHeaderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasHeaderProperty

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HeaderProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..HeaderProperty Field
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TabItem.HeaderProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HeaderProperty
Visual Basic
Public Shared HeaderProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HeaderProperty

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsFocusedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..IsFocusedProperty Field
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TabItem.IsFocusedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFocusedProperty
Visual Basic
Public Shared IsFocusedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFocusedProperty

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..IsSelectedProperty Field
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TabItem.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Methods
TabItem Class See Also Send Feedback

The TabItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..AnySibling Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..GetProperty Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..GetRealType Method
TabItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TabItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TabItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..GetRectangle Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..Highlight Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..InvokeMethod Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..IsHitTest Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..NextSibling Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..Parent Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..PreviousSibling Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..ScrollToVisible Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem..::..SetProperty Method
TabItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabItem Class
TabItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TabItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabItem Properties
TabItem Class See Also Send Feedback

The TabItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HasHeader |
Public property | Header |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel Members
TabPanel Class Constructors Methods Properties See Also Send Feedback

The TabPanel type exposes the following members.

Constructors

 | Name | Description
Public method | TabPanel | Initializes a new instance of the TabPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel Constructor
TabPanel Class See Also Send Feedback
Initializes a new instance of the TabPanel class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TabPanel()
Visual Basic
Public Sub New
Visual C++
public:
TabPanel()

See Also

TabPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TabPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel Methods
TabPanel Class See Also Send Feedback

The TabPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TabPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..AnySibling Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..GetProperty Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..GetRealType Method
TabPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TabPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TabPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TabPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..GetRectangle Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..Highlight Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..InvokeMethod Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..IsHitTest Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..NextSibling Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..Parent Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..PreviousSibling Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..ScrollToVisible Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel..::..SetProperty Method
TabPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TabPanel Class
TabPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TabPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabPanel Properties
TabPanel Class See Also Send Feedback

The TabPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TabPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBlock Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Members
TextBlock Class Constructors Methods Fields Properties See Also Send Feedback

The TextBlock type exposes the following members.

Constructors

 | Name | Description
Public method | TextBlock | Initializes a new instance of the TextBlock class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
InlinesProperty |
LineHeightProperty |
LineStackingStrategyProperty |
PaddingProperty |
TextAlignmentProperty |
TextProperty |
TextTrimmingProperty |
TextWrappingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Inlines |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LineHeight |
Public property | LineStackingStrategy |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextTrimming |
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBlock Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Constructor
TextBlock Class See Also Send Feedback
Initializes a new instance of the TextBlock class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextBlock()
Visual Basic
Public Sub New
Visual C++
public:
TextBlock()

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBlock Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Fields
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Fields

Name | Description
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontWeightProperty |
ForegroundProperty |
InlinesProperty |
LineHeightProperty |
LineStackingStrategyProperty |
PaddingProperty |
TextAlignmentProperty |
TextProperty |
TextTrimmingProperty |
TextWrappingProperty |

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontFamilyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontFamilyProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.FontFamilyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontFamilyProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontSizeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontSizeProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.FontSizeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontSizeProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontStretchProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.FontStretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStretchProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontStyleProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontStyleProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.FontStyleProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontStyleProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FontWeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..FontWeightProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.FontWeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FontWeightProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..ForegroundProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.ForegroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ForegroundProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InlinesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..InlinesProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.InlinesProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty InlinesProperty
Visual Basic
Public Shared InlinesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ InlinesProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..LineHeightProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.LineHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineHeightProperty
Visual Basic
Public Shared LineHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineHeightProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LineStackingStrategyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..LineStackingStrategyProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.LineStackingStrategyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LineStackingStrategyProperty
Visual Basic
Public Shared LineStackingStrategyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LineStackingStrategyProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PaddingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..PaddingProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.PaddingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PaddingProperty
Visual Basic
Public Shared PaddingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PaddingProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextAlignmentProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.TextAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextAlignmentProperty
Visual Basic
Public Shared TextAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextAlignmentProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.TextProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextTrimmingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextTrimmingProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.TextTrimmingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextTrimmingProperty
Visual Basic
Public Shared TextTrimmingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextTrimmingProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextWrappingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..TextWrappingProperty Field
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBlock.TextWrappingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextWrappingProperty
Visual Basic
Public Shared TextWrappingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextWrappingProperty

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBlock Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Methods
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..AnySibling Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..GetProperty Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..GetRealType Method
TextBlock Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TextBlock.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TextBlock.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..GetRectangle Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Highlight Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..InvokeMethod Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..IsHitTest Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..NextSibling Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..Parent Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..PreviousSibling Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..ScrollToVisible Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock..::..SetProperty Method
TextBlock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBlock Class
TextBlock Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBlock Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBlock Properties
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily |
Public property | FontSize |
Public property | FontStretch |
Public property | FontStyle |
Public property | FontWeight |
Public property | Foreground |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | Inlines |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | LineHeight |
Public property | LineStackingStrategy |
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextTrimming |
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBlock Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Members
TextBox Class Constructors Methods Fields Properties See Also Send Feedback

The TextBox type exposes the following members.

Constructors

 | Name | Description
Public method | TextBox | Initializes a new instance of the TextBox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
AcceptsReturnProperty |
CaretBrushProperty |
InputScopeProperty |
IsReadOnlyProperty |
MaxLengthProperty |
SelectionBackgroundProperty |
SelectionForegroundProperty |
TextAlignmentProperty |
TextProperty |
TextWrappingProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn |
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaretBrush |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsReadOnly |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionBackground |
Public property | SelectionForeground |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Constructor
TextBox Class See Also Send Feedback
Initializes a new instance of the TextBox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TextBox()
Visual Basic
Public Sub New
Visual C++
public:
TextBox()

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Fields
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Fields

Name | Description
AcceptsReturnProperty |
CaretBrushProperty |
InputScopeProperty |
IsReadOnlyProperty |
MaxLengthProperty |
SelectionBackgroundProperty |
SelectionForegroundProperty |
TextAlignmentProperty |
TextProperty |
TextWrappingProperty |

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AcceptsReturnProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..AcceptsReturnProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.AcceptsReturnProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AcceptsReturnProperty
Visual Basic
Public Shared AcceptsReturnProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AcceptsReturnProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CaretBrushProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..CaretBrushProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.CaretBrushProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CaretBrushProperty
Visual Basic
Public Shared CaretBrushProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CaretBrushProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InputScopeProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..InputScopeProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.InputScopeProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty InputScopeProperty
Visual Basic
Public Shared InputScopeProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ InputScopeProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsReadOnlyProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..IsReadOnlyProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.IsReadOnlyProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsReadOnlyProperty
Visual Basic
Public Shared IsReadOnlyProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsReadOnlyProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MaxLengthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..MaxLengthProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.MaxLengthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MaxLengthProperty
Visual Basic
Public Shared MaxLengthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MaxLengthProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionBackgroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..SelectionBackgroundProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.SelectionBackgroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionBackgroundProperty
Visual Basic
Public Shared SelectionBackgroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionBackgroundProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectionForegroundProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..SelectionForegroundProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.SelectionForegroundProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectionForegroundProperty
Visual Basic
Public Shared SelectionForegroundProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectionForegroundProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextAlignmentProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..TextAlignmentProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.TextAlignmentProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextAlignmentProperty
Visual Basic
Public Shared TextAlignmentProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextAlignmentProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..TextProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.TextProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextProperty
Visual Basic
Public Shared TextProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextWrappingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..TextWrappingProperty Field
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TextBox.TextWrappingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TextWrappingProperty
Visual Basic
Public Shared TextWrappingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TextWrappingProperty

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Methods
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetText | Sets or types a new text into the TextBox.
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..AnySibling Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..GetProperty Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..GetRealType Method
TextBox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TextBox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TextBox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..GetRectangle Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..Highlight Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..InvokeMethod Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..IsHitTest Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..NextSibling Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..Parent Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..PreviousSibling Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..ScrollToVisible Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..SetProperty Method
TextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TextBox Class
TextBox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox..::..SetText Method
TextBox Class See Also Send Feedback
Sets or types a new text into the TextBox.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetText(
    bool simulateRealUser,
    string text,
    int keyPressTime,
    int keyHoldTime,
    bool fireKeyEvents
)
Visual Basic
Public Sub SetText ( _
    simulateRealUser As Boolean, _
    text As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer, _
    fireKeyEvents As Boolean _
)
Visual C++
public:
virtual void SetText(
    bool simulateRealUser,
    String^ text,
    int keyPressTime,
    int keyHoldTime,
    bool fireKeyEvents
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
If true, simulates typing, otherwise simply replaces the text.
text
Type: System..::..String
The text to set/type.
keyPressTime
Type: System..::..Int32
The delay between each press
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing each key
fireKeyEvents
Type: System..::..Boolean

[Missing <param name="fireKeyEvents"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TextBox.SetText(System.Boolean,System.String,System.Int32,System.Int32,System.Boolean)"]

Implements

ITextBox..::..SetText(Boolean, String, Int32, Int32, Boolean)

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TextBox Properties
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | AcceptsReturn |
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CaretBrush |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | InputScope |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsReadOnly |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxLength |
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SelectionBackground |
Public property | SelectionForeground |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text |
Public property | TextAlignment |
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TextWrapping |
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TextBox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Thickness Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Members
Thickness Class Constructors Methods Fields Properties See Also Send Feedback

The Thickness type exposes the following members.

Constructors

 | Name | Description
Public method | Thickness | Initializes a new instance of the Thickness class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
BottomProperty |
LeftProperty |
RightProperty |
TopProperty |

Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Right |
Public property | Top |

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Thickness Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Constructor
Thickness Class See Also Send Feedback
Initializes a new instance of the Thickness class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thickness()
Visual Basic
Public Sub New
Visual C++
public:
Thickness()

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Thickness Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Fields
Thickness Class See Also Send Feedback

The Thickness type exposes the following members.

Fields

Name | Description
BottomProperty |
LeftProperty |
RightProperty |
TopProperty |

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


BottomProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..BottomProperty Field
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Thickness.BottomProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty BottomProperty
Visual Basic
Public Shared BottomProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ BottomProperty

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


LeftProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..LeftProperty Field
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Thickness.LeftProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty LeftProperty
Visual Basic
Public Shared LeftProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ LeftProperty

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


RightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..RightProperty Field
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Thickness.RightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty RightProperty
Visual Basic
Public Shared RightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ RightProperty

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TopProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..TopProperty Field
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Thickness.TopProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TopProperty
Visual Basic
Public Shared TopProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TopProperty

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Thickness Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Methods
Thickness Class See Also Send Feedback

The Thickness type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..GetProperty Method
Thickness Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thickness Class
Thickness Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..GetRealType Method
Thickness Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Thickness.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Thickness.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness..::..InvokeMethod Method
Thickness Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thickness Class
Thickness Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Thickness Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thickness Properties
Thickness Class See Also Send Feedback

The Thickness type exposes the following members.

Properties

 | Name | Description
Public property | Bottom |
Public property | Left |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Right |
Public property | Top |

See Also

Thickness Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Thumb Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Members
Thumb Class Constructors Methods Fields Properties See Also Send Feedback

The Thumb type exposes the following members.

Constructors

 | Name | Description
Public method | Thumb | Initializes a new instance of the Thumb class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsDraggingProperty |
IsFocusedProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDragging |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Thumb Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Thumb Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Constructor
Thumb Class See Also Send Feedback
Initializes a new instance of the Thumb class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Thumb()
Visual Basic
Public Sub New
Visual C++
public:
Thumb()

See Also

Thumb Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Thumb Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Fields
Thumb Class See Also Send Feedback

The Thumb type exposes the following members.

Fields

Name | Description
IsDraggingProperty |
IsFocusedProperty |

See Also

Thumb Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsDraggingProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..IsDraggingProperty Field
Thumb Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Thumb.IsDraggingProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsDraggingProperty
Visual Basic
Public Shared IsDraggingProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsDraggingProperty

See Also

Thumb Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsFocusedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..IsFocusedProperty Field
Thumb Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Thumb.IsFocusedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsFocusedProperty
Visual Basic
Public Shared IsFocusedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsFocusedProperty

See Also

Thumb Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Thumb Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Methods
Thumb Class See Also Send Feedback

The Thumb type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Thumb Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..AnySibling Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..GetProperty Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..GetRealType Method
Thumb Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Thumb.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Thumb.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Thumb Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..GetRectangle Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..Highlight Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..InvokeMethod Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..IsHitTest Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..NextSibling Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..Parent Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..PreviousSibling Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..ScrollToVisible Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb..::..SetProperty Method
Thumb Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Thumb Class
Thumb Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Thumb Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Thumb Properties
Thumb Class See Also Send Feedback

The Thumb type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsDragging |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Thumb Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TileBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Members
TileBrush Class Constructors Methods Fields Properties See Also Send Feedback

The TileBrush type exposes the following members.

Constructors

 | Name | Description
Public method | TileBrush | Initializes a new instance of the TileBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
AlignmentXProperty |
AlignmentYProperty |
StretchProperty |

Properties

 | Name | Description
Public property | AlignmentX |
Public property | AlignmentY |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch |
Public property | Transform | (Inherited from Brush.)

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TileBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Constructor
TileBrush Class See Also Send Feedback
Initializes a new instance of the TileBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TileBrush()
Visual Basic
Public Sub New
Visual C++
public:
TileBrush()

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TileBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Fields
TileBrush Class See Also Send Feedback

The TileBrush type exposes the following members.

Fields

Name | Description
AlignmentXProperty |
AlignmentYProperty |
StretchProperty |

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AlignmentXProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..AlignmentXProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TileBrush.AlignmentXProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlignmentXProperty
Visual Basic
Public Shared AlignmentXProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlignmentXProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AlignmentYProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..AlignmentYProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TileBrush.AlignmentYProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty AlignmentYProperty
Visual Basic
Public Shared AlignmentYProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ AlignmentYProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..StretchProperty Field
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TileBrush.StretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TileBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Methods
TileBrush Class See Also Send Feedback

The TileBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Brush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..GetProperty Method
TileBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TileBrush Class
TileBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..GetRealType Method
TileBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TileBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TileBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush..::..InvokeMethod Method
TileBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TileBrush Class
TileBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TileBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TileBrush Properties
TileBrush Class See Also Send Feedback

The TileBrush type exposes the following members.

Properties

 | Name | Description
Public property | AlignmentX |
Public property | AlignmentY |
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | Stretch |
Public property | Transform | (Inherited from Brush.)

See Also

TileBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TimeSpan Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Members
TimeSpan Class Constructors Methods Fields Properties See Also Send Feedback

The TimeSpan type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSpan | Initializes a new instance of the TimeSpan class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
DaysProperty |
HoursProperty |
MillisecondsProperty |
MinutesProperty |
SecondsProperty |
TicksProperty |
TotalDaysProperty |
TotalHoursProperty |
TotalMillisecondsProperty |
TotalMinutesProperty |
TotalSecondsProperty |

Properties

 | Name | Description
Public property | Days |
Public property | Hours |
Public property | Milliseconds |
Public property | Minutes |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Seconds |
Public property | Ticks |
Public property | TotalDays |
Public property | TotalHours |
Public property | TotalMilliseconds |
Public property | TotalMinutes |
Public property | TotalSeconds |

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TimeSpan Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Constructor
TimeSpan Class See Also Send Feedback
Initializes a new instance of the TimeSpan class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TimeSpan()
Visual Basic
Public Sub New
Visual C++
public:
TimeSpan()

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TimeSpan Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Fields
TimeSpan Class See Also Send Feedback

The TimeSpan type exposes the following members.

Fields

Name | Description
DaysProperty |
HoursProperty |
MillisecondsProperty |
MinutesProperty |
SecondsProperty |
TicksProperty |
TotalDaysProperty |
TotalHoursProperty |
TotalMillisecondsProperty |
TotalMinutesProperty |
TotalSecondsProperty |

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


DaysProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..DaysProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.DaysProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty DaysProperty
Visual Basic
Public Shared DaysProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ DaysProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HoursProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..HoursProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.HoursProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HoursProperty
Visual Basic
Public Shared HoursProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HoursProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MillisecondsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..MillisecondsProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.MillisecondsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MillisecondsProperty
Visual Basic
Public Shared MillisecondsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MillisecondsProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


MinutesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..MinutesProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.MinutesProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty MinutesProperty
Visual Basic
Public Shared MinutesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ MinutesProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SecondsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..SecondsProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.SecondsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SecondsProperty
Visual Basic
Public Shared SecondsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SecondsProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TicksProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TicksProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.TicksProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TicksProperty
Visual Basic
Public Shared TicksProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TicksProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TotalDaysProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalDaysProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.TotalDaysProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalDaysProperty
Visual Basic
Public Shared TotalDaysProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalDaysProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TotalHoursProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalHoursProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.TotalHoursProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalHoursProperty
Visual Basic
Public Shared TotalHoursProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalHoursProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TotalMillisecondsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalMillisecondsProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.TotalMillisecondsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalMillisecondsProperty
Visual Basic
Public Shared TotalMillisecondsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalMillisecondsProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TotalMinutesProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalMinutesProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.TotalMinutesProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalMinutesProperty
Visual Basic
Public Shared TotalMinutesProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalMinutesProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TotalSecondsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..TotalSecondsProperty Field
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.TotalSecondsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty TotalSecondsProperty
Visual Basic
Public Shared TotalSecondsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ TotalSecondsProperty

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TimeSpan Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Methods
TimeSpan Class See Also Send Feedback

The TimeSpan type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..GetProperty Method
TimeSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TimeSpan Class
TimeSpan Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..GetRealType Method
TimeSpan Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TimeSpan.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan..::..InvokeMethod Method
TimeSpan Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TimeSpan Class
TimeSpan Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TimeSpan Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TimeSpan Properties
TimeSpan Class See Also Send Feedback

The TimeSpan type exposes the following members.

Properties

 | Name | Description
Public property | Days |
Public property | Hours |
Public property | Milliseconds |
Public property | Minutes |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Seconds |
Public property | Ticks |
Public property | TotalDays |
Public property | TotalHours |
Public property | TotalMilliseconds |
Public property | TotalMinutes |
Public property | TotalSeconds |

See Also

TimeSpan Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToggleButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Members
ToggleButton Class Constructors Methods Fields Properties See Also Send Feedback

The ToggleButton type exposes the following members.

Constructors

 | Name | Description
Public method | ToggleButton | Initializes a new instance of the ToggleButton class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
IsCheckedProperty |
IsThreeStateProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check icon element. Override for custom control template.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsChecked |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToggleButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Constructor
ToggleButton Class See Also Send Feedback
Initializes a new instance of the ToggleButton class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ToggleButton()
Visual Basic
Public Sub New
Visual C++
public:
ToggleButton()

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToggleButton Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Fields
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Fields

Name | Description
IsCheckedProperty |
IsThreeStateProperty |

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsCheckedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..IsCheckedProperty Field
ToggleButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ToggleButton.IsCheckedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsCheckedProperty
Visual Basic
Public Shared IsCheckedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsCheckedProperty

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsThreeStateProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..IsThreeStateProperty Field
ToggleButton Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ToggleButton.IsThreeStateProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsThreeStateProperty
Visual Basic
Public Shared IsThreeStateProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsThreeStateProperty

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToggleButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Methods
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Check | Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ButtonBase..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | UnCheck | Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..AnySibling Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..Check Method
ToggleButton Class See Also Send Feedback
Checks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Check(
    bool simulateRealUser
)
Visual Basic
Public Sub Check ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void Check(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate a real user click.

Implements

IToggleButton..::..Check(Boolean)

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..GetProperty Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..GetRealType Method
ToggleButton Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ToggleButton.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ToggleButton.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..GetRectangle Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..Highlight Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..InvokeMethod Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..IsHitTest Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..NextSibling Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..Parent Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..PreviousSibling Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..ScrollToVisible Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..SetProperty Method
ToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToggleButton Class
ToggleButton Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..Toggle Method
ToggleButton Class See Also Send Feedback
Changes the state of the toggle button. Clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Toggle()
Visual Basic
Public Sub Toggle
Visual C++
public:
virtual void Toggle() sealed

Implements

IToggleButton..::..Toggle()()()()

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UnCheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton..::..UnCheck Method
ToggleButton Class See Also Send Feedback
Unchecks the toggle button. If simulate real user clicks on the toggle box portion if it exists, otherwise clicks on the center of the button rectangle. If doesn't, simulate real user updates the checked state via an automation property.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void UnCheck(
    bool simulateRealUser
)
Visual Basic
Public Sub UnCheck ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void UnCheck(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate a real user click.

Implements

IToggleButton..::..UnCheck(Boolean)

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToggleButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToggleButton Properties
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | CheckIcon | Get the ToggleButton check icon element. Override for custom control template.
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | ClickMode | (Inherited from ButtonBase.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsChecked |
Public property | IsEnabled | (Inherited from Control.)
Public property | IsFocused | (Inherited from ButtonBase.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsMouseOver | (Inherited from ButtonBase.)
Public property | IsPressed | (Inherited from ButtonBase.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsThreeState |
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToggleButton Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToolTip Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Members
ToolTip Class Constructors Methods Fields Properties See Also Send Feedback

The ToolTip type exposes the following members.

Constructors

 | Name | Description
Public method | ToolTip | Initializes a new instance of the ToolTip class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HorizontalOffsetProperty |
IsOpenProperty |
PlacementProperty |
VerticalOffsetProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsOpen |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToolTip Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Constructor
ToolTip Class See Also Send Feedback
Initializes a new instance of the ToolTip class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ToolTip()
Visual Basic
Public Sub New
Visual C++
public:
ToolTip()

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToolTip Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Fields
ToolTip Class See Also Send Feedback

The ToolTip type exposes the following members.

Fields

Name | Description
HorizontalOffsetProperty |
IsOpenProperty |
PlacementProperty |
VerticalOffsetProperty |

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..HorizontalOffsetProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ToolTip.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsOpenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..IsOpenProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ToolTip.IsOpenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsOpenProperty
Visual Basic
Public Shared IsOpenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsOpenProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


PlacementProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..PlacementProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ToolTip.PlacementProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty PlacementProperty
Visual Basic
Public Shared PlacementProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ PlacementProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..VerticalOffsetProperty Field
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ToolTip.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ToolTip Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Methods
ToolTip Class See Also Send Feedback

The ToolTip type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ContentControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..AnySibling Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..GetProperty Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..GetRealType Method
ToolTip Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ToolTip.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ToolTip.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..GetRectangle Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..Highlight Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..InvokeMethod Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..IsHitTest Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..NextSibling Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..Parent Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..PreviousSibling Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..ScrollToVisible Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip..::..SetProperty Method
ToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ToolTip Class
ToolTip Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ToolTip Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTip Properties
ToolTip Class See Also Send Feedback

The ToolTip type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsOpen |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Placement |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | VerticalOffset |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ToolTip Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Transform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform Members
Transform Class Constructors Methods Properties See Also Send Feedback

The Transform type exposes the following members.

Constructors

 | Name | Description
Public method | Transform | Initializes a new instance of the Transform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Transform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform Constructor
Transform Class See Also Send Feedback
Initializes a new instance of the Transform class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Transform()
Visual Basic
Public Sub New
Visual C++
public:
Transform()

See Also

Transform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Transform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform Methods
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides AutomationObject<(Of <(<'T>)>)>..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform..::..GetProperty Method
Transform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform Class
Transform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform..::..GetRealType Method
Transform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Transform.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Transform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Transform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform..::..InvokeMethod Method
Transform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform Class
Transform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Transform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Transform Properties
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Transform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TransformGroup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup Members
TransformGroup Class Constructors Methods Fields Properties See Also Send Feedback

The TransformGroup type exposes the following members.

Constructors

 | Name | Description
Public method | TransformGroup | Initializes a new instance of the TransformGroup class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ChildrenProperty |

Properties

 | Name | Description
Public property | Children |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransformGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TransformGroup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup Constructor
TransformGroup Class See Also Send Feedback
Initializes a new instance of the TransformGroup class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TransformGroup()
Visual Basic
Public Sub New
Visual C++
public:
TransformGroup()

See Also

TransformGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TransformGroup Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup Fields
TransformGroup Class See Also Send Feedback

The TransformGroup type exposes the following members.

Fields

Name | Description
ChildrenProperty |

See Also

TransformGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ChildrenProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup..::..ChildrenProperty Field
TransformGroup Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TransformGroup.ChildrenProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ChildrenProperty
Visual Basic
Public Shared ChildrenProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ChildrenProperty

See Also

TransformGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TransformGroup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup Methods
TransformGroup Class See Also Send Feedback

The TransformGroup type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransformGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup..::..GetProperty Method
TransformGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransformGroup Class
TransformGroup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup..::..GetRealType Method
TransformGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TransformGroup.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TransformGroup.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TransformGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup..::..InvokeMethod Method
TransformGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransformGroup Class
TransformGroup Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TransformGroup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TransformGroup Properties
TransformGroup Class See Also Send Feedback

The TransformGroup type exposes the following members.

Properties

 | Name | Description
Public property | Children |
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TransformGroup Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateTransform Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Members
TranslateTransform Class Constructors Methods Fields Properties See Also Send Feedback

The TranslateTransform type exposes the following members.

Constructors

 | Name | Description
Public method | TranslateTransform | Initializes a new instance of the TranslateTransform class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
XProperty |
YProperty |

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |

See Also

TranslateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateTransform Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Constructor
TranslateTransform Class See Also Send Feedback
Initializes a new instance of the TranslateTransform class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TranslateTransform()
Visual Basic
Public Sub New
Visual C++
public:
TranslateTransform()

See Also

TranslateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateTransform Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Fields
TranslateTransform Class See Also Send Feedback

The TranslateTransform type exposes the following members.

Fields

Name | Description
XProperty |
YProperty |

See Also

TranslateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


XProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..XProperty Field
TranslateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TranslateTransform.XProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty XProperty
Visual Basic
Public Shared XProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ XProperty

See Also

TranslateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


YProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..YProperty Field
TranslateTransform Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TranslateTransform.YProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty YProperty
Visual Basic
Public Shared YProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ YProperty

See Also

TranslateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateTransform Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Methods
TranslateTransform Class See Also Send Feedback

The TranslateTransform type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides Transform..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TranslateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..GetProperty Method
TranslateTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TranslateTransform Class
TranslateTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..GetRealType Method
TranslateTransform Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TranslateTransform.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TranslateTransform.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TranslateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform..::..InvokeMethod Method
TranslateTransform Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TranslateTransform Class
TranslateTransform Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TranslateTransform Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TranslateTransform Properties
TranslateTransform Class See Also Send Feedback

The TranslateTransform type exposes the following members.

Properties

 | Name | Description
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | X |
Public property | Y |

See Also

TranslateTransform Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Members
TreeView Class Constructors Methods Fields Properties See Also Send Feedback

The TreeView type exposes the following members.

Constructors

 | Name | Description
Public method | TreeView | Initializes a new instance of the TreeView class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
SelectedValuePathProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | ItemsPanel | Get the element holding the tree view items.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RootItems | Get the list of tree view items on the root level.
Public property | SelectedValuePath |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TreeView Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Constructor
TreeView Class See Also Send Feedback
Initializes a new instance of the TreeView class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TreeView()
Visual Basic
Public Sub New
Visual C++
public:
TreeView()

See Also

TreeView Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeView Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Fields
TreeView Class See Also Send Feedback

The TreeView type exposes the following members.

Fields

Name | Description
SelectedValuePathProperty |

See Also

TreeView Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SelectedValuePathProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..SelectedValuePathProperty Field
TreeView Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TreeView.SelectedValuePathProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SelectedValuePathProperty
Visual Basic
Public Shared SelectedValuePathProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SelectedValuePathProperty

See Also

TreeView Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Methods
TreeView Class See Also Send Feedback

The TreeView type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides ItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TreeView Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..AnySibling Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..AssignReference Method
TreeView Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

TreeView Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..GetProperty Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..GetRealType Method
TreeView Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TreeView.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TreeView.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TreeView Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..GetRectangle Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..Highlight Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..InvokeMethod Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..IsHitTest Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..NextSibling Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..Parent Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..PreviousSibling Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..ScrollToVisible Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView..::..SetProperty Method
TreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeView Class
TreeView Members
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeView Properties
TreeView Class See Also Send Feedback

The TreeView type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | ItemsPanel | Get the element holding the tree view items.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | RootItems | Get the list of tree view items on the root level.
Public property | SelectedValuePath |
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TreeView Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeViewItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Members
TreeViewItem Class Constructors Methods Fields Properties See Also Send Feedback

The TreeViewItem type exposes the following members.

Constructors

 | Name | Description
Public method | TreeViewItem | Initializes a new instance of the TreeViewItem class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select | Selects the item.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Expands/collapses the item.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
HasItemsProperty |
IsExpandedProperty |
IsSelectedProperty |
IsSelectionActiveProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems |
Public property | Header | Get the header responsible for item selection. Override for custom control template.
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsExpanded |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected |
Public property | IsSelectionActive |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Items | Get the item children.
Public property | ItemsPanel | Get the element holding the tree view items. Override for custom control template.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Get the item text. (Overrides FrameworkElement..::..Text.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToggleButton | Get the toggle button responsible for simulating item expand/collapse actions. Override for custom control template.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeViewItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Constructor
TreeViewItem Class See Also Send Feedback
Initializes a new instance of the TreeViewItem class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TreeViewItem()
Visual Basic
Public Sub New
Visual C++
public:
TreeViewItem()

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeViewItem Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Fields
TreeViewItem Class See Also Send Feedback

The TreeViewItem type exposes the following members.

Fields

Name | Description
HasItemsProperty |
IsExpandedProperty |
IsSelectedProperty |
IsSelectionActiveProperty |

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HasItemsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..HasItemsProperty Field
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TreeViewItem.HasItemsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasItemsProperty
Visual Basic
Public Shared HasItemsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasItemsProperty

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsExpandedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsExpandedProperty Field
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TreeViewItem.IsExpandedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsExpandedProperty
Visual Basic
Public Shared IsExpandedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsExpandedProperty

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSelectedProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsSelectedProperty Field
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TreeViewItem.IsSelectedProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectedProperty
Visual Basic
Public Shared IsSelectedProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectedProperty

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


IsSelectionActiveProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsSelectionActiveProperty Field
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.TreeViewItem.IsSelectionActiveProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty IsSelectionActiveProperty
Visual Basic
Public Shared IsSelectionActiveProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ IsSelectionActiveProperty

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeViewItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Methods
TreeViewItem Class See Also Send Feedback

The TreeViewItem type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides HeaderedItemsControl..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select | Selects the item.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | Toggle | Expands/collapses the item.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..AnySibling Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..AssignReference Method
TreeViewItem Class See Also Send Feedback
Assign the automation reference to this element.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference
The automation reference to assign.

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..GetProperty Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..GetRealType Method
TreeViewItem Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TreeViewItem.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.TreeViewItem.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..GetRectangle Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Highlight Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..InvokeMethod Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..IsHitTest Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..NextSibling Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Parent Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..PreviousSibling Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..ScrollToVisible Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Select Method
TreeViewItem Class See Also Send Feedback
Selects the item.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Select(
    bool simulateRealUser
)
Visual Basic
Public Sub Select ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void Select(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user click to select the item.

Implements

ITreeViewItem..::..Select(Boolean)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..SetProperty Method
TreeViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

TreeViewItem Class
TreeViewItem Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem..::..Toggle Method
TreeViewItem Class See Also Send Feedback
Expands/collapses the item.

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Toggle(
    bool simulateRealUser
)
Visual Basic
Public Sub Toggle ( _
    simulateRealUser As Boolean _
)
Visual C++
public:
virtual void Toggle(
    bool simulateRealUser
) sealed

Parameters

simulateRealUser
Type: System..::..Boolean
Whether to simulate real user click to expand/collapse the item.

Implements

ITreeViewItem..::..Toggle(Boolean)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


TreeViewItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewItem Properties
TreeViewItem Class See Also Send Feedback

The TreeViewItem type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HasItems |
Public property | Header | Get the header responsible for item selection. Override for custom control template.
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsExpanded |
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected |
Public property | IsSelectionActive |
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Items | Get the item children.
Public property | ItemsPanel | Get the element holding the tree view items. Override for custom control template.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Get the item text. (Overrides FrameworkElement..::..Text.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToggleButton | Get the toggle button responsible for simulating item expand/collapse actions. Override for custom control template.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

TreeViewItem Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UserControl Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl Members
UserControl Class Constructors Methods Properties See Also Send Feedback

The UserControl type exposes the following members.

Constructors

 | Name | Description
Public method | UserControl | Initializes a new instance of the UserControl class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

UserControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UserControl Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl Constructor
UserControl Class See Also Send Feedback
Initializes a new instance of the UserControl class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public UserControl()
Visual Basic
Public Sub New
Visual C++
public:
UserControl()

See Also

UserControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


UserControl Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl Methods
UserControl Class See Also Send Feedback

The UserControl type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

UserControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..AnySibling Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..GetProperty Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..GetRealType Method
UserControl Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.UserControl.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.UserControl.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

UserControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..GetRectangle Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..Highlight Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..InvokeMethod Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..IsHitTest Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..NextSibling Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..Parent Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..PreviousSibling Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..ScrollToVisible Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl..::..SetProperty Method
UserControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

UserControl Class
UserControl Members
ArtOfTest.WebAii.Silverlight.UI Namespace


UserControl Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UserControl Properties
UserControl Class See Also Send Feedback

The UserControl type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

UserControl Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ValidationSummary Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary Members
ValidationSummary Class Constructors Methods Fields Properties See Also Send Feedback

The ValidationSummary type exposes the following members.

Constructors

 | Name | Description
Public method | ValidationSummary | Initializes a new instance of the ValidationSummary class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
FilterProperty |
FocusControlsOnClickProperty |
HasDisplayedErrorsProperty |
HasErrorsProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Filter |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FocusControlsOnClick |
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HasDisplayedErrors |
Public property | HasErrors |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ValidationSummary Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary Constructor
ValidationSummary Class See Also Send Feedback
Initializes a new instance of the ValidationSummary class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ValidationSummary()
Visual Basic
Public Sub New
Visual C++
public:
ValidationSummary()

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ValidationSummary Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary Fields
ValidationSummary Class See Also Send Feedback

The ValidationSummary type exposes the following members.

Fields

Name | Description
FilterProperty |
FocusControlsOnClickProperty |
HasDisplayedErrorsProperty |
HasErrorsProperty |

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FilterProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..FilterProperty Field
ValidationSummary Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ValidationSummary.FilterProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FilterProperty
Visual Basic
Public Shared FilterProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FilterProperty

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


FocusControlsOnClickProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..FocusControlsOnClickProperty Field
ValidationSummary Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ValidationSummary.FocusControlsOnClickProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty FocusControlsOnClickProperty
Visual Basic
Public Shared FocusControlsOnClickProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ FocusControlsOnClickProperty

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HasDisplayedErrorsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..HasDisplayedErrorsProperty Field
ValidationSummary Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ValidationSummary.HasDisplayedErrorsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasDisplayedErrorsProperty
Visual Basic
Public Shared HasDisplayedErrorsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasDisplayedErrorsProperty

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HasErrorsProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..HasErrorsProperty Field
ValidationSummary Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.ValidationSummary.HasErrorsProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HasErrorsProperty
Visual Basic
Public Shared HasErrorsProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HasErrorsProperty

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ValidationSummary Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary Methods
ValidationSummary Class See Also Send Feedback

The ValidationSummary type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Control..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..AnySibling Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..GetProperty Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..GetRealType Method
ValidationSummary Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ValidationSummary.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.ValidationSummary.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..GetRectangle Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..Highlight Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..InvokeMethod Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..IsHitTest Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..NextSibling Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..Parent Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..PreviousSibling Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..ScrollToVisible Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary..::..SetProperty Method
ValidationSummary Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

ValidationSummary Class
ValidationSummary Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ValidationSummary Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ValidationSummary Properties
ValidationSummary Class See Also Send Feedback

The ValidationSummary type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Filter |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FocusControlsOnClick |
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | HasDisplayedErrors |
Public property | HasErrors |
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

ValidationSummary Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VideoBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush Members
VideoBrush Class Constructors Methods Fields Properties See Also Send Feedback

The VideoBrush type exposes the following members.

Constructors

 | Name | Description
Public method | VideoBrush | Initializes a new instance of the VideoBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
SourceNameProperty |

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SourceName |
Public property | Stretch | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

VideoBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VideoBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush Constructor
VideoBrush Class See Also Send Feedback
Initializes a new instance of the VideoBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VideoBrush()
Visual Basic
Public Sub New
Visual C++
public:
VideoBrush()

See Also

VideoBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VideoBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush Fields
VideoBrush Class See Also Send Feedback

The VideoBrush type exposes the following members.

Fields

Name | Description
SourceNameProperty |

See Also

VideoBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SourceNameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush..::..SourceNameProperty Field
VideoBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VideoBrush.SourceNameProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceNameProperty
Visual Basic
Public Shared SourceNameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceNameProperty

See Also

VideoBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VideoBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush Methods
VideoBrush Class See Also Send Feedback

The VideoBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VideoBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush..::..GetProperty Method
VideoBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VideoBrush Class
VideoBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush..::..GetRealType Method
VideoBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.VideoBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.VideoBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

VideoBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush..::..InvokeMethod Method
VideoBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VideoBrush Class
VideoBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


VideoBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VideoBrush Properties
VideoBrush Class See Also Send Feedback

The VideoBrush type exposes the following members.

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SourceName |
Public property | Stretch | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

VideoBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Viewbox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Members
Viewbox Class Constructors Methods Fields Properties See Also Send Feedback

The Viewbox type exposes the following members.

Constructors

 | Name | Description
Public method | Viewbox | Initializes a new instance of the Viewbox class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
StretchDirectionProperty |
StretchProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Viewbox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Viewbox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Constructor
Viewbox Class See Also Send Feedback
Initializes a new instance of the Viewbox class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Viewbox()
Visual Basic
Public Sub New
Visual C++
public:
Viewbox()

See Also

Viewbox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Viewbox Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Fields
Viewbox Class See Also Send Feedback

The Viewbox type exposes the following members.

Fields

Name | Description
StretchDirectionProperty |
StretchProperty |

See Also

Viewbox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StretchDirectionProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..StretchDirectionProperty Field
Viewbox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Viewbox.StretchDirectionProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchDirectionProperty
Visual Basic
Public Shared StretchDirectionProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchDirectionProperty

See Also

Viewbox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


StretchProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..StretchProperty Field
Viewbox Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.Viewbox.StretchProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty StretchProperty
Visual Basic
Public Shared StretchProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ StretchProperty

See Also

Viewbox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


Viewbox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Methods
Viewbox Class See Also Send Feedback

The Viewbox type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

Viewbox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..AnySibling Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..GetProperty Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..GetRealType Method
Viewbox Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Viewbox.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.Viewbox.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

Viewbox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..GetRectangle Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..Highlight Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..InvokeMethod Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..IsHitTest Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..NextSibling Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..Parent Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..PreviousSibling Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..ScrollToVisible Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox..::..SetProperty Method
Viewbox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

Viewbox Class
Viewbox Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Viewbox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Viewbox Properties
Viewbox Class See Also Send Feedback

The Viewbox type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | Stretch |
Public property | StretchDirection |
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

Viewbox Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel Members
VirtualizingPanel Class Constructors Methods Properties See Also Send Feedback

The VirtualizingPanel type exposes the following members.

Constructors

 | Name | Description
Public method | VirtualizingPanel | Initializes a new instance of the VirtualizingPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel Constructor
VirtualizingPanel Class See Also Send Feedback
Initializes a new instance of the VirtualizingPanel class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VirtualizingPanel()
Visual Basic
Public Sub New
Visual C++
public:
VirtualizingPanel()

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel Methods
VirtualizingPanel Class See Also Send Feedback

The VirtualizingPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides Panel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..AnySibling Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..GetProperty Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..GetRealType Method
VirtualizingPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.VirtualizingPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.VirtualizingPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..GetRectangle Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..Highlight Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..InvokeMethod Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..IsHitTest Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..NextSibling Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..Parent Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..PreviousSibling Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..ScrollToVisible Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel..::..SetProperty Method
VirtualizingPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingPanel Class
VirtualizingPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingPanel Properties
VirtualizingPanel Class See Also Send Feedback

The VirtualizingPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

VirtualizingPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingStackPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Members
VirtualizingStackPanel Class Constructors Methods Fields Properties See Also Send Feedback

The VirtualizingStackPanel type exposes the following members.

Constructors

 | Name | Description
Public method | VirtualizingStackPanel | Initializes a new instance of the VirtualizingStackPanel class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides VirtualizingPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetVerticalOffset |
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Fields

Name | Description
CanHorzontallyScrollProperty |
CanVerticallyScrollProperty |
ExtentHeightProperty |
ExtentWidthProperty |
HorizontalOffsetProperty |
OrientationProperty |
VerticalOffsetProperty |
ViewportHeightProperty |
ViewportWidthProperty |

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | CanHorizontallyScroll |
Public property | CanVerticallyScroll |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExtentHeight |
Public property | ExtentWidth |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset |
Public property | ViewportHeight |
Public property | ViewportOffset |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingStackPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Constructor
VirtualizingStackPanel Class See Also Send Feedback
Initializes a new instance of the VirtualizingStackPanel class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VirtualizingStackPanel()
Visual Basic
Public Sub New
Visual C++
public:
VirtualizingStackPanel()

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingStackPanel Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Fields
VirtualizingStackPanel Class See Also Send Feedback

The VirtualizingStackPanel type exposes the following members.

Fields

Name | Description
CanHorzontallyScrollProperty |
CanVerticallyScrollProperty |
ExtentHeightProperty |
ExtentWidthProperty |
HorizontalOffsetProperty |
OrientationProperty |
VerticalOffsetProperty |
ViewportHeightProperty |
ViewportWidthProperty |

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanHorzontallyScrollProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..CanHorzontallyScrollProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.CanHorzontallyScrollProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanHorzontallyScrollProperty
Visual Basic
Public Shared CanHorzontallyScrollProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanHorzontallyScrollProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


CanVerticallyScrollProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..CanVerticallyScrollProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.CanVerticallyScrollProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty CanVerticallyScrollProperty
Visual Basic
Public Shared CanVerticallyScrollProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ CanVerticallyScrollProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ExtentHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..ExtentHeightProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.ExtentHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExtentHeightProperty
Visual Basic
Public Shared ExtentHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExtentHeightProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ExtentWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..ExtentWidthProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.ExtentWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ExtentWidthProperty
Visual Basic
Public Shared ExtentWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ExtentWidthProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


HorizontalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..HorizontalOffsetProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.HorizontalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty HorizontalOffsetProperty
Visual Basic
Public Shared HorizontalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ HorizontalOffsetProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


OrientationProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..OrientationProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.OrientationProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty OrientationProperty
Visual Basic
Public Shared OrientationProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ OrientationProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VerticalOffsetProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..VerticalOffsetProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.VerticalOffsetProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty VerticalOffsetProperty
Visual Basic
Public Shared VerticalOffsetProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ VerticalOffsetProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportHeightProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..ViewportHeightProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.ViewportHeightProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportHeightProperty
Visual Basic
Public Shared ViewportHeightProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportHeightProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ViewportWidthProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..ViewportWidthProperty Field
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.ViewportWidthProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty ViewportWidthProperty
Visual Basic
Public Shared ViewportWidthProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ ViewportWidthProperty

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingStackPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Methods
VirtualizingStackPanel Class See Also Send Feedback

The VirtualizingStackPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides VirtualizingPanel..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetVerticalOffset |
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..AnySibling Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..GetProperty Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..GetRealType Method
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..GetRectangle Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..Highlight Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..InvokeMethod Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..IsHitTest Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..NextSibling Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..Parent Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..PreviousSibling Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..ScrollToVisible Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..SetProperty Method
VirtualizingStackPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

VirtualizingStackPanel Class
VirtualizingStackPanel Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetVerticalOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel..::..SetVerticalOffset Method
VirtualizingStackPanel Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.SetVerticalOffset(System.Double)"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetVerticalOffset(
    double offset
)
Visual Basic
Public Sub SetVerticalOffset ( _
    offset As Double _
)
Visual C++
public:
virtual void SetVerticalOffset(
    double offset
) sealed

Parameters

offset
Type: System..::..Double

[Missing <param name="offset"/> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.VirtualizingStackPanel.SetVerticalOffset(System.Double)"]

Implements

IVirtualizingStackPanel..::..SetVerticalOffset(Double)

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


VirtualizingStackPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VirtualizingStackPanel Properties
VirtualizingStackPanel Class See Also Send Feedback

The VirtualizingStackPanel type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Panel.)
Public property | CanHorizontallyScroll |
Public property | CanVerticallyScroll |
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | ExtentHeight |
Public property | ExtentWidth |
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalOffset |
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Orientation |
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalOffset |
Public property | ViewportHeight |
Public property | ViewportOffset |
Public property | ViewportWidth |
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

VirtualizingStackPanel Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowser Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser Members
WebBrowser Class Constructors Methods Properties See Also Send Feedback

The WebBrowser type exposes the following members.

Constructors

 | Name | Description
Public method | WebBrowser | Initializes a new instance of the WebBrowser class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WebBrowser Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowser Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser Constructor
WebBrowser Class See Also Send Feedback
Initializes a new instance of the WebBrowser class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebBrowser()
Visual Basic
Public Sub New
Visual C++
public:
WebBrowser()

See Also

WebBrowser Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowser Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser Methods
WebBrowser Class See Also Send Feedback

The WebBrowser type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Overrides FrameworkElement..::..GetRealType()()()().)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
ArtOfTest.WebAii.Silverlight.UI Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..AnySibling Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..GetProperty Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..GetRealType Method
WebBrowser Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.WebBrowser.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.WebBrowser.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

WebBrowser Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..GetRectangle Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..Highlight Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..InvokeMethod Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..IsHitTest Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..NextSibling Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..Parent Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..PreviousSibling Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..ScrollToVisible Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser..::..SetProperty Method
WebBrowser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WebBrowser Class
WebBrowser Members
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowser Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowser Properties
WebBrowser Class See Also Send Feedback

The WebBrowser type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

WebBrowser Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowserBrush Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush Members
WebBrowserBrush Class Constructors Methods Fields Properties See Also Send Feedback

The WebBrowserBrush type exposes the following members.

Constructors

 | Name | Description
Public method | WebBrowserBrush | Initializes a new instance of the WebBrowserBrush class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
SourceNameProperty |

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SourceName |
Public property | Stretch | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

WebBrowserBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowserBrush Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush Constructor
WebBrowserBrush Class See Also Send Feedback
Initializes a new instance of the WebBrowserBrush class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WebBrowserBrush()
Visual Basic
Public Sub New
Visual C++
public:
WebBrowserBrush()

See Also

WebBrowserBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowserBrush Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush Fields
WebBrowserBrush Class See Also Send Feedback

The WebBrowserBrush type exposes the following members.

Fields

Name | Description
SourceNameProperty |

See Also

WebBrowserBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


SourceNameProperty Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush..::..SourceNameProperty Field
WebBrowserBrush Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Silverlight.UI.WebBrowserBrush.SourceNameProperty"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationProperty SourceNameProperty
Visual Basic
Public Shared SourceNameProperty As AutomationProperty
Visual C++
public:
static AutomationProperty^ SourceNameProperty

See Also

WebBrowserBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowserBrush Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush Methods
WebBrowserBrush Class See Also Send Feedback

The WebBrowserBrush type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides TileBrush..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WebBrowserBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush..::..GetProperty Method
WebBrowserBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WebBrowserBrush Class
WebBrowserBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush..::..GetRealType Method
WebBrowserBrush Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.WebBrowserBrush.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.WebBrowserBrush.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

WebBrowserBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush..::..InvokeMethod Method
WebBrowserBrush Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WebBrowserBrush Class
WebBrowserBrush Members
ArtOfTest.WebAii.Silverlight.UI Namespace


WebBrowserBrush Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WebBrowserBrush Properties
WebBrowserBrush Class See Also Send Feedback

The WebBrowserBrush type exposes the following members.

Properties

 | Name | Description
Public property | AlignmentX | (Inherited from TileBrush.)
Public property | AlignmentY | (Inherited from TileBrush.)
Public property | Opacity | (Inherited from Brush.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RelativeTransform | (Inherited from Brush.)
Public property | SourceName |
Public property | Stretch | (Inherited from TileBrush.)
Public property | Transform | (Inherited from Brush.)

See Also

WebBrowserBrush Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WriteableBitmap Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap Members
WriteableBitmap Class Constructors Methods Properties See Also Send Feedback

The WriteableBitmap type exposes the following members.

Constructors

 | Name | Description
Public method | WriteableBitmap | Initializes a new instance of the WriteableBitmap class

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PixelHeight | (Inherited from BitmapSource.)
Public property | PixelWidth | (Inherited from BitmapSource.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WriteableBitmap Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap Constructor
WriteableBitmap Class See Also Send Feedback
Initializes a new instance of the WriteableBitmap class

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WriteableBitmap()
Visual Basic
Public Sub New
Visual C++
public:
WriteableBitmap()

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Silverlight.UI Namespace


WriteableBitmap Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap Methods
WriteableBitmap Class See Also Send Feedback

The WriteableBitmap type exposes the following members.

Methods

 | Name | Description
Public method | AssignReference | Assign a reference to this AutomationObject. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Converts a Silverlight object to an AutomationObject (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetRealType | (Overrides BitmapSource..::..GetRealType()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProperty | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToRealObject | Converts an automation object to the real object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Silverlight.UI Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap..::..GetProperty Method
WriteableBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WriteableBitmap Class
WriteableBitmap Members
ArtOfTest.WebAii.Silverlight.UI Namespace


GetRealType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap..::..GetRealType Method
WriteableBitmap Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.WriteableBitmap.GetRealType"]

Namespace: ArtOfTest.WebAii.Silverlight.UI
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string GetRealType()
Visual Basic
Public Overrides Function GetRealType As String
Visual C++
public:
virtual String^ GetRealType() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Silverlight.UI.WriteableBitmap.GetRealType"]

Implements

IAutomationPeer..::..GetRealType()()()()

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Silverlight.UI Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap..::..InvokeMethod Method
WriteableBitmap Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WriteableBitmap Class
WriteableBitmap Members
ArtOfTest.WebAii.Silverlight.UI Namespace


WriteableBitmap Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WriteableBitmap Properties
WriteableBitmap Class See Also Send Feedback

The WriteableBitmap type exposes the following members.

Properties

 | Name | Description
Public property | PixelHeight | (Inherited from BitmapSource.)
Public property | PixelWidth | (Inherited from BitmapSource.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

WriteableBitmap Class
ArtOfTest.WebAii.Silverlight.UI Namespace


ArtOfTest.WebAii.Synchronization Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Synchronization Namespace
Send Feedback
Namespace for the framework synchronization classes (e.g. the Wait class).

Classes

 | Class | Description
Public class | Wait | Provide wait functionality for an Element object.


Wait Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait Members
Wait Class Methods Properties See Also Send Feedback

The Wait type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForAttributes(array<String>[]()[][]) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout)
Public method | ForAttributes(Int32, array<String>[]()[][]) | Wait for a set of attributes on this element.
Public method | ForAttributesNot(array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout)
Public method | ForAttributesNot(Int32, array<String>[]()[][]) | Wait for a set of attributes to no longer be true.
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this element.
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32, WaitResultType) |
Public method | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout)
Public method | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true.
Public method | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout)
Public method | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true.
Public method | ForExists()()()() | Wait for this element to exist in the DOM.
Public method | ForExists(Int32) | Wait for this element to exist in the DOM.
Protected method | ForExists(Int32, Boolean) | Wait for an element and decide on whether to refresh the element.
Public method | ForExistsNot()()()() | Wait for this element not to exist in the DOM
Public method | ForExistsNot(Int32) | Wait for this element not to exist in the DOM.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Timeout | Gets/Sets the timeout for all Wait.Forxx methods. Default=Settings.ExecuteCommandTimeout

See Also

Wait Class
ArtOfTest.WebAii.Synchronization Namespace


Wait Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait Methods
Wait Class See Also Send Feedback

The Wait type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | ForAttributes(array<String>[]()[][]) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout)
Public method | ForAttributes(Int32, array<String>[]()[][]) | Wait for a set of attributes on this element.
Public method | ForAttributesNot(array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout)
Public method | ForAttributesNot(Int32, array<String>[]()[][]) | Wait for a set of attributes to no longer be true.
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this element.
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32, WaitResultType) |
Public method | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout)
Public method | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true.
Public method | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout)
Public method | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true.
Public method | ForExists()()()() | Wait for this element to exist in the DOM.
Public method | ForExists(Int32) | Wait for this element to exist in the DOM.
Protected method | ForExists(Int32, Boolean) | Wait for an element and decide on whether to refresh the element.
Public method | ForExistsNot()()()() | Wait for this element not to exist in the DOM
Public method | ForExistsNot(Int32) | Wait for this element not to exist in the DOM.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Wait Class
ArtOfTest.WebAii.Synchronization Namespace


ForAttributes Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForAttributes Method
Wait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForAttributes(array<String>[]()[][]) | Wait for a set of attributes on this element. (Timeout = Wait.Timeout)
Public method | ForAttributes(Int32, array<String>[]()[][]) | Wait for a set of attributes on this element.

See Also

Wait Class
Wait Members
ArtOfTest.WebAii.Synchronization Namespace


ForAttributes Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForAttributes Method (array<String>[]()[][])
Wait Class Example See Also Send Feedback
Wait for a set of attributes on this element. (Timeout = Wait.Timeout)

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForAttributes(
    params string[] attributesNameValuePairs
)
Visual Basic
Public Sub ForAttributes ( _
    ParamArray attributesNameValuePairs As String() _
)
Visual C++
public:
void ForAttributes(
    ... array<String^>^ attributesNameValuePairs
)

Parameters

attributesNameValuePairs
Type: array< System..::..String >[]()[][]
The attributes name/value pairs

Examples

Wait.ForAttribute("src=~foo.png","foo=bar")

See Also

Wait Class
ForAttributes Overload
ArtOfTest.WebAii.Synchronization Namespace


ForAttributes Method (Int32, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForAttributes Method (Int32, array<String>[]()[][])
Wait Class Example See Also Send Feedback
Wait for a set of attributes on this element.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForAttributes(
    int timeout,
    params string[] attributesNameValuePairs
)
Visual Basic
Public Sub ForAttributes ( _
    timeout As Integer, _
    ParamArray attributesNameValuePairs As String() _
)
Visual C++
public:
void ForAttributes(
    int timeout,
    ... array<String^>^ attributesNameValuePairs
)

Parameters

timeout
Type: System..::..Int32
Wait timeout in milliseconds.
attributesNameValuePairs
Type: array< System..::..String >[]()[][]
The attribute name/value pairs

Examples

Wait.ForAttribute("src=~foo.png","foo=bar")

See Also

Wait Class
ForAttributes Overload
ArtOfTest.WebAii.Synchronization Namespace


ForAttributesNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForAttributesNot Method
Wait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForAttributesNot(array<String>[]()[][]) | Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout)
Public method | ForAttributesNot(Int32, array<String>[]()[][]) | Wait for a set of attributes to no longer be true.

See Also

Wait Class
Wait Members
ArtOfTest.WebAii.Synchronization Namespace


ForAttributesNot Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForAttributesNot Method (array<String>[]()[][])
Wait Class See Also Send Feedback
Wait for a set of attributes to no longer be true. (Timeout = Wait.Timeout)

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForAttributesNot(
    params string[] attributeNameValuePairs
)
Visual Basic
Public Sub ForAttributesNot ( _
    ParamArray attributeNameValuePairs As String() _
)
Visual C++
public:
void ForAttributesNot(
    ... array<String^>^ attributeNameValuePairs
)

Parameters

attributeNameValuePairs
Type: array< System..::..String >[]()[][]
The attributes name/value pairs

See Also

Wait Class
ForAttributesNot Overload
ArtOfTest.WebAii.Synchronization Namespace


ForAttributesNot Method (Int32, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForAttributesNot Method (Int32, array<String>[]()[][])
Wait Class See Also Send Feedback
Wait for a set of attributes to no longer be true.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForAttributesNot(
    int timeout,
    params string[] attributeNameValuePairs
)
Visual Basic
Public Sub ForAttributesNot ( _
    timeout As Integer, _
    ParamArray attributeNameValuePairs As String() _
)
Visual C++
public:
void ForAttributesNot(
    int timeout,
    ... array<String^>^ attributeNameValuePairs
)

Parameters

timeout
Type: System..::..Int32
Wait timeout in milliseconds.
attributeNameValuePairs
Type: array< System..::..String >[]()[][]
The attributes name/value pairs

See Also

Wait Class
ForAttributesNot Overload
ArtOfTest.WebAii.Synchronization Namespace


ForCondition Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForCondition Method
Wait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32) | Wait for a custom condition on this element.
Public method | ForCondition(Func<(Of <<'(Element, Object, Boolean>)>>), Boolean, Object, Int32, WaitResultType) |

See Also

Wait Class
Wait Members
ArtOfTest.WebAii.Synchronization Namespace


ForCondition Method (Func(Element, Object, Boolean), Boolean, Object, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForCondition Method (Func<(Of <(<'Element, Object, Boolean>)>)>, Boolean, Object, Int32)
Wait Class See Also Send Feedback
Wait for a custom condition on this element.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForCondition(
    Func<Element, Object, bool> condition,
    bool invertCondition,
    Object custom,
    int timeout
)
Visual Basic
Public Sub ForCondition ( _
    condition As Func(Of Element, Object, Boolean), _
    invertCondition As Boolean, _
    custom As Object, _
    timeout As Integer _
)
Visual C++
public:
void ForCondition(
    Func<Element^, Object^, bool>^ condition,
    bool invertCondition,
    Object^ custom,
    int timeout
)

Parameters

condition
Type: System..::..Func <(Of <(<' Element, Object, Boolean >)>)>
The condition to wait for.
invertCondition
Type: System..::..Boolean
True/False whether to invert the condition or not.
custom
Type: System..::..Object
Any custom data to pass to this condition.
timeout
Type: System..::..Int32
The timeout to use.

See Also

Wait Class
ForCondition Overload
ArtOfTest.WebAii.Synchronization Namespace


ForCondition Method (Func(Element, Object, Boolean), Boolean, Object, Int32, WaitResultType)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForCondition Method (Func<(Of <(<'Element, Object, Boolean>)>)>, Boolean, Object, Int32, WaitResultType)
Wait Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Synchronization.Wait.ForCondition(System.Func{ArtOfTest.WebAii.ObjectModel.Element,System.Object,System.Boolean},System.Boolean,System.Object,System.Int32,ArtOfTest.Common.WaitResultType)"]

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForCondition(
    Func<Element, Object, bool> condition,
    bool invertCondition,
    Object custom,
    int timeout,
    WaitResultType errorResultType
)
Visual Basic
Public Sub ForCondition ( _
    condition As Func(Of Element, Object, Boolean), _
    invertCondition As Boolean, _
    custom As Object, _
    timeout As Integer, _
    errorResultType As WaitResultType _
)
Visual C++
public:
void ForCondition(
    Func<Element^, Object^, bool>^ condition,
    bool invertCondition,
    Object^ custom,
    int timeout,
    WaitResultType errorResultType
)

Parameters

condition
Type: System..::..Func <(Of <(<' Element, Object, Boolean >)>)>

[Missing <param name="condition"/> documentation for "M:ArtOfTest.WebAii.Synchronization.Wait.ForCondition(System.Func{ArtOfTest.WebAii.ObjectModel.Element,System.Object,System.Boolean},System.Boolean,System.Object,System.Int32,ArtOfTest.Common.WaitResultType)"]

invertCondition
Type: System..::..Boolean

[Missing <param name="invertCondition"/> documentation for "M:ArtOfTest.WebAii.Synchronization.Wait.ForCondition(System.Func{ArtOfTest.WebAii.ObjectModel.Element,System.Object,System.Boolean},System.Boolean,System.Object,System.Int32,ArtOfTest.Common.WaitResultType)"]

custom
Type: System..::..Object

[Missing <param name="custom"/> documentation for "M:ArtOfTest.WebAii.Synchronization.Wait.ForCondition(System.Func{ArtOfTest.WebAii.ObjectModel.Element,System.Object,System.Boolean},System.Boolean,System.Object,System.Int32,ArtOfTest.Common.WaitResultType)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Synchronization.Wait.ForCondition(System.Func{ArtOfTest.WebAii.ObjectModel.Element,System.Object,System.Boolean},System.Boolean,System.Object,System.Int32,ArtOfTest.Common.WaitResultType)"]

errorResultType
Type: ArtOfTest.Common..::..WaitResultType

[Missing <param name="errorResultType"/> documentation for "M:ArtOfTest.WebAii.Synchronization.Wait.ForCondition(System.Func{ArtOfTest.WebAii.ObjectModel.Element,System.Object,System.Boolean},System.Boolean,System.Object,System.Int32,ArtOfTest.Common.WaitResultType)"]

See Also

Wait Class
ForCondition Overload
ArtOfTest.WebAii.Synchronization Namespace


ForContent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForContent Method
Wait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForContent(FindContentType, String) | Wait for certain content of this element to be true. (Timeout = Wait.Timeout)
Public method | ForContent(FindContentType, String, Int32) | Wait for certain content of this element to be true.

See Also

Wait Class
Wait Members
ArtOfTest.WebAii.Synchronization Namespace


ForContent Method (FindContentType, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForContent Method (FindContentType, String)
Wait Class See Also Send Feedback
Wait for certain content of this element to be true. (Timeout = Wait.Timeout)

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForContent(
    FindContentType type,
    string value
)
Visual Basic
Public Sub ForContent ( _
    type As FindContentType, _
    value As String _
)
Visual C++
public:
void ForContent(
    FindContentType type,
    String^ value
)

Parameters

type
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to wait for.
value
Type: System..::..String
The content values to wait for. Value can be (p:partialvalue,l:liternal,x:regex)

See Also

Wait Class
ForContent Overload
ArtOfTest.WebAii.Synchronization Namespace


ForContent Method (FindContentType, String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForContent Method (FindContentType, String, Int32)
Wait Class See Also Send Feedback
Wait for certain content of this element to be true.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForContent(
    FindContentType type,
    string value,
    int timeout
)
Visual Basic
Public Sub ForContent ( _
    type As FindContentType, _
    value As String, _
    timeout As Integer _
)
Visual C++
public:
void ForContent(
    FindContentType type,
    String^ value,
    int timeout
)

Parameters

type
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to wait for.
value
Type: System..::..String
The content values to wait for. Value can be (p:partialvalue,l:liternal,x:regex)
timeout
Type: System..::..Int32
The time out to wait for.

See Also

Wait Class
ForContent Overload
ArtOfTest.WebAii.Synchronization Namespace


ForContentNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForContentNot Method
Wait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForContentNot(FindContentType, String) | Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout)
Public method | ForContentNot(FindContentType, String, Int32) | Wait for certain content of this element to no longer be true.

See Also

Wait Class
Wait Members
ArtOfTest.WebAii.Synchronization Namespace


ForContentNot Method (FindContentType, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForContentNot Method (FindContentType, String)
Wait Class See Also Send Feedback
Wait for certain content of this element to no longer be true. (Timeout = Wait.Timeout)

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForContentNot(
    FindContentType type,
    string value
)
Visual Basic
Public Sub ForContentNot ( _
    type As FindContentType, _
    value As String _
)
Visual C++
public:
void ForContentNot(
    FindContentType type,
    String^ value
)

Parameters

type
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to wait for.
value
Type: System..::..String
The content values to wait for. Value can be (p:partialvalue,l:liternal,x:regex)

See Also

Wait Class
ForContentNot Overload
ArtOfTest.WebAii.Synchronization Namespace


ForContentNot Method (FindContentType, String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForContentNot Method (FindContentType, String, Int32)
Wait Class See Also Send Feedback
Wait for certain content of this element to no longer be true.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForContentNot(
    FindContentType type,
    string value,
    int timeout
)
Visual Basic
Public Sub ForContentNot ( _
    type As FindContentType, _
    value As String, _
    timeout As Integer _
)
Visual C++
public:
void ForContentNot(
    FindContentType type,
    String^ value,
    int timeout
)

Parameters

type
Type: ArtOfTest.WebAii.ObjectModel..::..FindContentType
The content type to wait for.
value
Type: System..::..String
The content values to wait for. Value can be (p:partialvalue,l:liternal,x:regex)
timeout
Type: System..::..Int32
The time out to wait for.

See Also

Wait Class
ForContentNot Overload
ArtOfTest.WebAii.Synchronization Namespace


ForExists Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForExists Method
Wait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForExists()()()() | Wait for this element to exist in the DOM.
Public method | ForExists(Int32) | Wait for this element to exist in the DOM.
Protected method | ForExists(Int32, Boolean) | Wait for an element and decide on whether to refresh the element.

See Also

Wait Class
Wait Members
ArtOfTest.WebAii.Synchronization Namespace


ForExists Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForExists Method
Wait Class See Also Send Feedback
Wait for this element to exist in the DOM.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForExists()
Visual Basic
Public Sub ForExists
Visual C++
public:
void ForExists()

See Also

Wait Class
ForExists Overload
ArtOfTest.WebAii.Synchronization Namespace


ForExists Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForExists Method (Int32)
Wait Class See Also Send Feedback
Wait for this element to exist in the DOM.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForExists(
    int timeout
)
Visual Basic
Public Sub ForExists ( _
    timeout As Integer _
)
Visual C++
public:
void ForExists(
    int timeout
)

Parameters

timeout
Type: System..::..Int32
Wait timeout.

See Also

Wait Class
ForExists Overload
ArtOfTest.WebAii.Synchronization Namespace


ForExists Method (Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForExists Method (Int32, Boolean)
Wait Class See Also Send Feedback
Wait for an element and decide on whether to refresh the element.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void ForExists(
    int timeout,
    bool refreshElement
)
Visual Basic
Protected Overridable Sub ForExists ( _
    timeout As Integer, _
    refreshElement As Boolean _
)
Visual C++
protected:
virtual void ForExists(
    int timeout,
    bool refreshElement
)

Parameters

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Synchronization.Wait.ForExists(System.Int32,System.Boolean)"]

refreshElement
Type: System..::..Boolean

[Missing <param name="refreshElement"/> documentation for "M:ArtOfTest.WebAii.Synchronization.Wait.ForExists(System.Int32,System.Boolean)"]

See Also

Wait Class
ForExists Overload
ArtOfTest.WebAii.Synchronization Namespace


ForExistsNot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForExistsNot Method
Wait Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ForExistsNot()()()() | Wait for this element not to exist in the DOM
Public method | ForExistsNot(Int32) | Wait for this element not to exist in the DOM.

See Also

Wait Class
Wait Members
ArtOfTest.WebAii.Synchronization Namespace


ForExistsNot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForExistsNot Method
Wait Class See Also Send Feedback
Wait for this element not to exist in the DOM

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForExistsNot()
Visual Basic
Public Sub ForExistsNot
Visual C++
public:
void ForExistsNot()

See Also

Wait Class
ForExistsNot Overload
ArtOfTest.WebAii.Synchronization Namespace


ForExistsNot Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait..::..ForExistsNot Method (Int32)
Wait Class See Also Send Feedback
Wait for this element not to exist in the DOM.

Namespace: ArtOfTest.WebAii.Synchronization
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ForExistsNot(
    int timeout
)
Visual Basic
Public Sub ForExistsNot ( _
    timeout As Integer _
)
Visual C++
public:
void ForExistsNot(
    int timeout
)

Parameters

timeout
Type: System..::..Int32
Wait timeout

See Also

Wait Class
ForExistsNot Overload
ArtOfTest.WebAii.Synchronization Namespace


Wait Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Wait Properties
Wait Class See Also Send Feedback

The Wait type exposes the following members.

Properties

 | Name | Description
Public property | Timeout | Gets/Sets the timeout for all Wait.Forxx methods. Default=Settings.ExecuteCommandTimeout

See Also

Wait Class
ArtOfTest.WebAii.Synchronization Namespace


ArtOfTest.WebAii.TestAttributes Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.TestAttributes Namespace
Send Feedback
Namespace for the custom WebAii method decorators (e.g. DialogAttribute and FindParamAttribute).

Classes

 | Class | Description
Public class | DialogAttribute | A dialog attribute that can be set on a test method of a test class.
Public class | FindAttribute | The Find attribute may be set on classes or test methods to define a find expression that may be used later in your code to find that element.
Public class | FindParamAttribute | FindParam attribute used to be set on a test method or test class.


DialogAttribute Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogAttribute Members
DialogAttribute Class Constructors Methods Properties See Also Send Feedback

The DialogAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | DialogAttribute(DialogButton) | Create an AlertDialog.
Public method | DialogAttribute(IDialog) | Create a custom dialog.
Public method | DialogAttribute(String, DialogButton) | Create a FileUploadDialog
Public method | DialogAttribute(String, String, DialogButton) | Create a LogonDialog.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DialogAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


DialogAttribute Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogAttribute Constructor
DialogAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DialogAttribute(DialogButton) | Create an AlertDialog.
Public method | DialogAttribute(IDialog) | Create a custom dialog.
Public method | DialogAttribute(String, DialogButton) | Create a FileUploadDialog
Public method | DialogAttribute(String, String, DialogButton) | Create a LogonDialog.

See Also

DialogAttribute Class
DialogAttribute Members
ArtOfTest.WebAii.TestAttributes Namespace


DialogAttribute Constructor (DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogAttribute Constructor (DialogButton)
DialogAttribute Class See Also Send Feedback
Create an AlertDialog.

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogAttribute(
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    dismissButton As DialogButton _
)
Visual C++
public:
DialogAttribute(
    DialogButton dismissButton
)

Parameters

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The dismiss button to click.

See Also

DialogAttribute Class
DialogAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


DialogAttribute Constructor (IDialog)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogAttribute Constructor (IDialog)
DialogAttribute Class See Also Send Feedback
Create a custom dialog.

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogAttribute(
    IDialog customDialog
)
Visual Basic
Public Sub New ( _
    customDialog As IDialog _
)
Visual C++
public:
DialogAttribute(
    IDialog^ customDialog
)

Parameters

customDialog
Type: ArtOfTest.WebAii.Win32.Dialogs..::..IDialog
The custom dialog

See Also

DialogAttribute Class
DialogAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


DialogAttribute Constructor (String, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogAttribute Constructor (String, DialogButton)
DialogAttribute Class See Also Send Feedback
Create a FileUploadDialog

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogAttribute(
    string filePath,
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    filePath As String, _
    dismissButton As DialogButton _
)
Visual C++
public:
DialogAttribute(
    String^ filePath,
    DialogButton dismissButton
)

Parameters

filePath
Type: System..::..String
The filepath to use.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The dismiss button to click.

See Also

DialogAttribute Class
DialogAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


DialogAttribute Constructor (String, String, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogAttribute Constructor (String, String, DialogButton)
DialogAttribute Class See Also Send Feedback
Create a LogonDialog.

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogAttribute(
    string userName,
    string password,
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    userName As String, _
    password As String, _
    dismissButton As DialogButton _
)
Visual C++
public:
DialogAttribute(
    String^ userName,
    String^ password,
    DialogButton dismissButton
)

Parameters

userName
Type: System..::..String
The username to use.
password
Type: System..::..String
The password to use.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The dismiss button to click.

See Also

DialogAttribute Class
DialogAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


DialogAttribute Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogAttribute Methods
DialogAttribute Class See Also Send Feedback

The DialogAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


DialogAttribute Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogAttribute Properties
DialogAttribute Class See Also Send Feedback

The DialogAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

DialogAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


FindAttribute Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindAttribute Members
FindAttribute Class Constructors Methods Properties See Also Send Feedback

The FindAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | FindAttribute()()()() | Create a new FindExpression attribute
Public method | FindAttribute(String, array<String>[]()[][]) | Create a new FindParamAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefinesFrame | Gets whether the FindParam defines a Frame.
Public property | DefinesTestRegion | Gets whether the FindParam defines a TestRegion
Public property | FindClauses | The actualy FindParam object corresponding to this attribute.
Public property | FrameId | Gets or sets the frame id for this findparam.
Public property | FrameIndex | Gets or sets the frame index
Public property | FrameName | Gets or sets the frame name for this findparam.
Public property | FrameSrc | Gets or sets the frame src value
Public property | Key | The friendly name to identify this FindParam and the element it will identify when using Find.All().
Public property | ParentAppKey | Gets or sets the parent application key that defines the find expression for the Silverlight application that owns this element.
Public property | TargetType | Gets or sets the technology type of the target element of this expression
Public property | TestRegionId | Gets or sets the TestRegion Id this FindParam belongs to.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FindAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


FindAttribute Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindAttribute Constructor
FindAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindAttribute()()()() | Create a new FindExpression attribute
Public method | FindAttribute(String, array<String>[]()[][]) | Create a new FindParamAttribute.

See Also

FindAttribute Class
FindAttribute Members
ArtOfTest.WebAii.TestAttributes Namespace


FindAttribute Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindAttribute Constructor
FindAttribute Class See Also Send Feedback
Create a new FindExpression attribute

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindAttribute()
Visual Basic
Public Sub New
Visual C++
public:
FindAttribute()

See Also

FindAttribute Class
FindAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


FindAttribute Constructor (String, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindAttribute Constructor (String, array<String>[]()[][])
FindAttribute Class See Also Send Feedback
Create a new FindParamAttribute.

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindAttribute(
    string key,
    params string[] findClauses
)
Visual Basic
Public Sub New ( _
    key As String, _
    ParamArray findClauses As String() _
)
Visual C++
public:
FindAttribute(
    String^ key,
    ... array<String^>^ findClauses
)

Parameters

key
Type: System..::..String
The friendly name of this element. You will use that name as the key in the dictionary of found elements using Find.Elements[] collection
findClauses
Type: array< System..::..String >[]()[][]
The find expression clauses

See Also

FindAttribute Class
FindAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


FindAttribute Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindAttribute Methods
FindAttribute Class See Also Send Feedback

The FindAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


FindAttribute Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindAttribute Properties
FindAttribute Class See Also Send Feedback

The FindAttribute type exposes the following members.

Properties

 | Name | Description
Public property | DefinesFrame | Gets whether the FindParam defines a Frame.
Public property | DefinesTestRegion | Gets whether the FindParam defines a TestRegion
Public property | FindClauses | The actualy FindParam object corresponding to this attribute.
Public property | FrameId | Gets or sets the frame id for this findparam.
Public property | FrameIndex | Gets or sets the frame index
Public property | FrameName | Gets or sets the frame name for this findparam.
Public property | FrameSrc | Gets or sets the frame src value
Public property | Key | The friendly name to identify this FindParam and the element it will identify when using Find.All().
Public property | ParentAppKey | Gets or sets the parent application key that defines the find expression for the Silverlight application that owns this element.
Public property | TargetType | Gets or sets the technology type of the target element of this expression
Public property | TestRegionId | Gets or sets the TestRegion Id this FindParam belongs to.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FindAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


FindParamAttribute Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamAttribute Members
FindParamAttribute Class Constructors Methods Properties See Also Send Feedback

The FindParamAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | FindParamAttribute(String) | Obsolete. Create a new FindParamAttribute.
Public method | FindParamAttribute(String, FindType, String) | Create a new FindParamAttribute.
Public method | FindParamAttribute(String, FindType, String, array<String>[]()[][]) | Create a new FindParamAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefinesFrame | Gets whether the FindParam defines a Frame.
Public property | DefinesTestRegion | Gets whether the FindParam defines a TestRegion
Public property | FileName | Obsolete. The file name that contains the collection of FindParams.
Public property | FindParam | The actualy FindParam object corresponding to this attribute.
Public property | FrameId | Gets or sets the frame id for this findparam.
Public property | FrameIndex | Gets or sets the frame index
Public property | FrameName | Gets or sets the frame name for this findparam.
Public property | FrameSrc | Gets or sets the frame src value
Public property | Key | The friendly name to identify this FindParam and the element it will identify when using Find.All().
Public property | TestRegionId | Gets or sets the TestRegion Id this FindParam belongs to.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FindParamAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


FindParamAttribute Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamAttribute Constructor
FindParamAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FindParamAttribute(String) | Obsolete. Create a new FindParamAttribute.
Public method | FindParamAttribute(String, FindType, String) | Create a new FindParamAttribute.
Public method | FindParamAttribute(String, FindType, String, array<String>[]()[][]) | Create a new FindParamAttribute.

See Also

FindParamAttribute Class
FindParamAttribute Members
ArtOfTest.WebAii.TestAttributes Namespace


FindParamAttribute Constructor (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamAttribute Constructor (String)
FindParamAttribute Class See Also Send Feedback
Create a new FindParamAttribute.

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("No longer supported. Use the FindParamCollection.LoadFromFile()")]
public FindParamAttribute(
    string fileName
)
Visual Basic
<ObsoleteAttribute("No longer supported. Use the FindParamCollection.LoadFromFile()")> _
Public Sub New ( _
    fileName As String _
)
Visual C++
[ObsoleteAttribute(L"No longer supported. Use the FindParamCollection.LoadFromFile()")]
public:
FindParamAttribute(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file name that contains the collection of FindParams.

See Also

FindParamAttribute Class
FindParamAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


FindParamAttribute Constructor (String, FindType, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamAttribute Constructor (String, FindType, String)
FindParamAttribute Class See Also Send Feedback
Create a new FindParamAttribute.

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParamAttribute(
    string key,
    FindType type,
    string value
)
Visual Basic
Public Sub New ( _
    key As String, _
    type As FindType, _
    value As String _
)
Visual C++
public:
FindParamAttribute(
    String^ key,
    FindType type,
    String^ value
)

Parameters

key
Type: System..::..String
The friendly name of this FindParam. You will use that name as the key in the dictionary of found elements using Find.Elements[] collection
type
Type: ArtOfTest.WebAii.ObjectModel..::..FindType
The type of the FindParam.
value
Type: System..::..String
The value of the FindParam./>

See Also

FindParamAttribute Class
FindParamAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


FindParamAttribute Constructor (String, FindType, String, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamAttribute Constructor (String, FindType, String, array<String>[]()[][])
FindParamAttribute Class See Also Send Feedback
Create a new FindParamAttribute.

Namespace: ArtOfTest.WebAii.TestAttributes
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FindParamAttribute(
    string key,
    FindType type,
    string value,
    params string[] attributes
)
Visual Basic
Public Sub New ( _
    key As String, _
    type As FindType, _
    value As String, _
    ParamArray attributes As String() _
)
Visual C++
public:
FindParamAttribute(
    String^ key,
    FindType type,
    String^ value,
    ... array<String^>^ attributes
)

Parameters

key
Type: System..::..String
The friendly name of this FindParam. You will use that name as the key in the dictionary of found elements using Find.Elements[] collection
type
Type: ArtOfTest.WebAii.ObjectModel..::..FindType
The type of the FindParam.
value
Type: System..::..String
The value of the FindParam./>
attributes
Type: array< System..::..String >[]()[][]
The list of attributes to match.

Remarks

value can be set as (string.empty for FindType.AttributesOnly, "tagName:tagIndex" for FindType.TagIndex, "p/l/x:text or expression" for FindType.Content, "xpath" for FindType.XPath, "nodeindexpath" for FindType.NodeIndexPath

See Also

FindParamAttribute Class
FindParamAttribute Overload
ArtOfTest.WebAii.TestAttributes Namespace


FindParamAttribute Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamAttribute Methods
FindParamAttribute Class See Also Send Feedback

The FindParamAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FindParamAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


FindParamAttribute Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FindParamAttribute Properties
FindParamAttribute Class See Also Send Feedback

The FindParamAttribute type exposes the following members.

Properties

 | Name | Description
Public property | DefinesFrame | Gets whether the FindParam defines a Frame.
Public property | DefinesTestRegion | Gets whether the FindParam defines a TestRegion
Public property | FileName | Obsolete. The file name that contains the collection of FindParams.
Public property | FindParam | The actualy FindParam object corresponding to this attribute.
Public property | FrameId | Gets or sets the frame id for this findparam.
Public property | FrameIndex | Gets or sets the frame index
Public property | FrameName | Gets or sets the frame name for this findparam.
Public property | FrameSrc | Gets or sets the frame src value
Public property | Key | The friendly name to identify this FindParam and the element it will identify when using Find.All().
Public property | TestRegionId | Gets or sets the TestRegion Id this FindParam belongs to.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FindParamAttribute Class
ArtOfTest.WebAii.TestAttributes Namespace


ArtOfTest.WebAii.TestTemplates Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.TestTemplates Namespace
Send Feedback
Namespace for the BaseTest testing template.

Classes

 | Class | Description
Public class | BaseTest | Base test class for all WebAii unit/coded tests.
Public class | BaseWpfTest | Base test class for all WebAii unit/coded tests.
Public class | ElementContainer<(Of <(<'TElement, TFindExpression>)>)> | Base class for element containers (Page, Region, SilverlightApp, etc.) in Project.cs file
Public class | HtmlElementContainer | Base class for containers of HTML elements in the Project.cs file
Public class | HtmlPage | Represents an Html Page objects.
Public class | XamlApplication |
Public class | XamlElementContainer | Base class for containers of Silverlight elements in the Project.cs file

Delegates

 | Delegate | Description
Public delegate | TestContextWriteLine | Delegate used when you wish to perform your own logging into a custom logging system.


BaseTest Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest Members
BaseTest Class Constructors Methods Properties See Also Send Feedback

The BaseTest type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseTest | Initializes a new instance of the BaseTest class

Methods

Name Description
Public method CleanUp
Shut down and clean-up.
Public method Dispose
Dispose of this test and all of its resources. This method simply calls the CleanUp() method.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetSettings
This method reads the settings object from the App.Config file and returns a Settings object.

Examples

The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii, Version=x.x.xxx.x, Culture=neutral, PublicKeyToken=4FD5F65BE123776C"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Initialize()()()()
Initialize this test case object.
Public method Initialize(Boolean)
Initialize this test case object.
Public method Initialize(String)
Initialize this test case object.
Public method Initialize(Settings)
Initialize this test case object.
Public method Initialize(TestContextWriteLine)
Initialize this test case object.
Public method Initialize(Boolean, TestContextWriteLine)
Initialize this test case object.
Public method Initialize(String, TestContextWriteLine)
Initialize this test case object.
Public method Initialize(Settings, TestContextWriteLine)
Initialize this test case object.
Public method Initialize(Boolean, String, TestContextWriteLine)
Initialize this test case object.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetTestMethod
Set the TestMethod executing so that WebAii can extract its attributes.
ShutDown
Shut down all instances if recycle brower is set.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | jQuery | Returns the jQuery object associated with the BaseTest object. (Defined by jQueryExtension.)

Properties

 | Name | Description
Public property | Actions | Gets the actions object associated with the ActiveBrowser.
Public property | ActiveBrowser | Gets the ActiveBrowser object. (The last browser launched).
Public property | Desktop | Gets the Desktop object from the Manager.
Public property | Elements | Gets the Elements finder to be used to access elements defined by FindAttribute on the test method or class.
Public property | Find | Gets the Find object associated with the ActiveBrowser.
Public property | Log | Gets the Log object associated with the Manager.
Public property | Manager | Gets the Manager object.
Public property | Wait | Gets a wait object that can be used to wait on specific actions or opertions.

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


BaseTest Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest Constructor
BaseTest Class See Also Send Feedback
Initializes a new instance of the BaseTest class

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected BaseTest()
Visual Basic
Protected Sub New
Visual C++
protected:
BaseTest()

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


BaseTest Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest Methods
BaseTest Class See Also Send Feedback

The BaseTest type exposes the following members.

Methods

Name Description
Public method CleanUp
Shut down and clean-up.
Public method Dispose
Dispose of this test and all of its resources. This method simply calls the CleanUp() method.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetSettings
This method reads the settings object from the App.Config file and returns a Settings object.

Examples

The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii, Version=x.x.xxx.x, Culture=neutral, PublicKeyToken=4FD5F65BE123776C"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Initialize()()()()
Initialize this test case object.
Public method Initialize(Boolean)
Initialize this test case object.
Public method Initialize(String)
Initialize this test case object.
Public method Initialize(Settings)
Initialize this test case object.
Public method Initialize(TestContextWriteLine)
Initialize this test case object.
Public method Initialize(Boolean, TestContextWriteLine)
Initialize this test case object.
Public method Initialize(String, TestContextWriteLine)
Initialize this test case object.
Public method Initialize(Settings, TestContextWriteLine)
Initialize this test case object.
Public method Initialize(Boolean, String, TestContextWriteLine)
Initialize this test case object.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetTestMethod
Set the TestMethod executing so that WebAii can extract its attributes.
ShutDown
Shut down all instances if recycle brower is set.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Extension Methods

 | Name | Description
Public Extension Method | jQuery | Returns the jQuery object associated with the BaseTest object. (Defined by jQueryExtension.)

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


CleanUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..CleanUp Method
BaseTest Class See Also Send Feedback
Shut down and clean-up.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CleanUp()
Visual Basic
Public Sub CleanUp
Visual C++
public:
void CleanUp()

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


Dispose Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Dispose Method
BaseTest Class See Also Send Feedback
Dispose of this test and all of its resources. This method simply calls the CleanUp() method.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose
Visual C++
public:
virtual void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


GetSettings Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..GetSettings Method
BaseTest Class See Also Send Feedback
This method reads the settings object from the App.Config file and returns a Settings object.

Examples

The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii, Version=x.x.xxx.x, Culture=neutral, PublicKeyToken=4FD5F65BE123776C"/> </configSections> <WebAii.Settings defaultBrowser="InternetExplorer" logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Settings GetSettings()
Visual Basic
Public Shared Function GetSettings As Settings
Visual C++
public:
static Settings^ GetSettings()

Return Value

The settings object read from App.Config.

Remarks

If you call this method and there are not settings present in the App.Config, then the method will create an empty Setting object and reset it to the system default settings. Also note that all Initialize() methods will call this method to attempt to load the settings.

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method
BaseTest Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Initialize()()()() | Initialize this test case object.
Public method | Initialize(Boolean) | Initialize this test case object.
Public method | Initialize(String) | Initialize this test case object.
Public method | Initialize(Settings) | Initialize this test case object.
Public method | Initialize(TestContextWriteLine) | Initialize this test case object.
Public method | Initialize(Boolean, TestContextWriteLine) | Initialize this test case object.
Public method | Initialize(String, TestContextWriteLine) | Initialize this test case object.
Public method | Initialize(Settings, TestContextWriteLine) | Initialize this test case object.
Public method | Initialize(Boolean, String, TestContextWriteLine) | Initialize this test case object.

See Also

BaseTest Class
BaseTest Members
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize()
Visual Basic
Public Sub Initialize
Visual C++
public:
void Initialize()

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method (Boolean)
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    bool recycleBrowser
)
Visual Basic
Public Sub Initialize ( _
    recycleBrowser As Boolean _
)
Visual C++
public:
void Initialize(
    bool recycleBrowser
)

Parameters

recycleBrowser
Type: System..::..Boolean
True to run all tests in the same browser instance. Make sure that the test fixture tear-down calls the static ShutDown method of this class when using this setting.

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method (String)
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    string logLocation
)
Visual Basic
Public Sub Initialize ( _
    logLocation As String _
)
Visual C++
public:
void Initialize(
    String^ logLocation
)

Parameters

logLocation
Type: System..::..String
The log location where to do the logging.

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (Settings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method (Settings)
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    Settings settings
)
Visual Basic
Public Sub Initialize ( _
    settings As Settings _
)
Visual C++
public:
void Initialize(
    Settings^ settings
)

Parameters

settings
Type: ArtOfTest.WebAii.Core..::..Settings
The settings to use for initialization.

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (TestContextWriteLine)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method (TestContextWriteLine)
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    TestContextWriteLine vsWriteLineDelegate
)
Visual Basic
Public Sub Initialize ( _
    vsWriteLineDelegate As TestContextWriteLine _
)
Visual C++
public:
void Initialize(
    TestContextWriteLine^ vsWriteLineDelegate
)

Parameters

vsWriteLineDelegate
Type: ArtOfTest.WebAii.TestTemplates..::..TestContextWriteLine
A write line delegate to call when logging from Log.WriteLine.

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (Boolean, TestContextWriteLine)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method (Boolean, TestContextWriteLine)
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    bool recycleBrowser,
    TestContextWriteLine vsWriteLineDelegate
)
Visual Basic
Public Sub Initialize ( _
    recycleBrowser As Boolean, _
    vsWriteLineDelegate As TestContextWriteLine _
)
Visual C++
public:
void Initialize(
    bool recycleBrowser,
    TestContextWriteLine^ vsWriteLineDelegate
)

Parameters

recycleBrowser
Type: System..::..Boolean
True to run all tests in the same browser instance. Make sure that the test fixture tear-down calls the static ShutDown method of this class when using this setting.
vsWriteLineDelegate
Type: ArtOfTest.WebAii.TestTemplates..::..TestContextWriteLine
A write line delegate to call when logging from Log.WriteLine.

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (String, TestContextWriteLine)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method (String, TestContextWriteLine)
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    string logLocation,
    TestContextWriteLine vsWriteLineDelegate
)
Visual Basic
Public Sub Initialize ( _
    logLocation As String, _
    vsWriteLineDelegate As TestContextWriteLine _
)
Visual C++
public:
void Initialize(
    String^ logLocation,
    TestContextWriteLine^ vsWriteLineDelegate
)

Parameters

logLocation
Type: System..::..String
The log location where to do the logging.
vsWriteLineDelegate
Type: ArtOfTest.WebAii.TestTemplates..::..TestContextWriteLine
A write line delegate to call when logging from Log.WriteLine.

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (Settings, TestContextWriteLine)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method (Settings, TestContextWriteLine)
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    Settings settings,
    TestContextWriteLine vsWriteLineDelegate
)
Visual Basic
Public Sub Initialize ( _
    settings As Settings, _
    vsWriteLineDelegate As TestContextWriteLine _
)
Visual C++
public:
void Initialize(
    Settings^ settings,
    TestContextWriteLine^ vsWriteLineDelegate
)

Parameters

settings
Type: ArtOfTest.WebAii.Core..::..Settings
The settings to use for initialization.
vsWriteLineDelegate
Type: ArtOfTest.WebAii.TestTemplates..::..TestContextWriteLine
A write line delegate to call when logging from Log.WriteLine.

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (Boolean, String, TestContextWriteLine)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..Initialize Method (Boolean, String, TestContextWriteLine)
BaseTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    bool recycleBrowser,
    string logLocation,
    TestContextWriteLine vsWriteLineDelegate
)
Visual Basic
Public Sub Initialize ( _
    recycleBrowser As Boolean, _
    logLocation As String, _
    vsWriteLineDelegate As TestContextWriteLine _
)
Visual C++
public:
void Initialize(
    bool recycleBrowser,
    String^ logLocation,
    TestContextWriteLine^ vsWriteLineDelegate
)

Parameters

recycleBrowser
Type: System..::..Boolean
True to run all tests in the same browser instance. Make sure that the test fixture tear-down calls the static ShutDown method of this class when using this setting.
logLocation
Type: System..::..String
The log location where to do the logging.
vsWriteLineDelegate
Type: ArtOfTest.WebAii.TestTemplates..::..TestContextWriteLine
A write line delegate to call when logging from Log.WriteLine.

See Also

BaseTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


SetTestMethod Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..SetTestMethod Method
BaseTest Class See Also Send Feedback
Set the TestMethod executing so that WebAii can extract its attributes.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetTestMethod(
    Object testObject,
    string testMethodName
)
Visual Basic
Public Sub SetTestMethod ( _
    testObject As Object, _
    testMethodName As String _
)
Visual C++
public:
void SetTestMethod(
    Object^ testObject,
    String^ testMethodName
)

Parameters

testObject
Type: System..::..Object
The test object.
testMethodName
Type: System..::..String
The test Method name executing.

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


ShutDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest..::..ShutDown Method
BaseTest Class See Also Send Feedback
Shut down all instances if recycle brower is set.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void ShutDown()
Visual Basic
Public Shared Sub ShutDown
Visual C++
public:
static void ShutDown()

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


BaseTest Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseTest Properties
BaseTest Class See Also Send Feedback

The BaseTest type exposes the following members.

Properties

 | Name | Description
Public property | Actions | Gets the actions object associated with the ActiveBrowser.
Public property | ActiveBrowser | Gets the ActiveBrowser object. (The last browser launched).
Public property | Desktop | Gets the Desktop object from the Manager.
Public property | Elements | Gets the Elements finder to be used to access elements defined by FindAttribute on the test method or class.
Public property | Find | Gets the Find object associated with the ActiveBrowser.
Public property | Log | Gets the Log object associated with the Manager.
Public property | Manager | Gets the Manager object.
Public property | Wait | Gets a wait object that can be used to wait on specific actions or opertions.

See Also

BaseTest Class
ArtOfTest.WebAii.TestTemplates Namespace


BaseWpfTest Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest Members
BaseWpfTest Class Constructors Methods Properties See Also Send Feedback

The BaseWpfTest type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseWpfTest | Initializes a new instance of the BaseWpfTest class

Methods

Name Description
Public method CleanUp
Shut down and clean-up.
Public method Dispose
Dispose of this test and all of its resources. This method simply calls the CleanUp() method.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetSettings
This method reads the settings object from the App.Config file and returns a Settings object.

Examples

The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii, Version=x.x.xxx.x, Culture=neutral, PublicKeyToken=4FD5F65BE123776C"/> </configSections> <WebAii.Settings /// logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Initialize()()()()
Initialize this test case object.
Public method Initialize(String)
Initialize this test case object.
Public method Initialize(Settings)
Initialize this test case object.
Public method Initialize(TestContextWriteLine)
Initialize this test case object.
Public method Initialize(String, TestContextWriteLine)
Initialize this test case object.
Public method Initialize(Settings, TestContextWriteLine)
Initialize this test case object.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetTestMethod
Set the TestMethod executing so that WebAii can extract its attributes.
ShutDown
Shut down all instances if recycle brower is set.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveApplication | Gets the ActiveBrowser object. (The last browser launched).
Public property | Desktop | Gets the Desktop object from the Manager.
Public property | Elements | Gets the Elements finder to be used to access elements defined by FindAttribute on the test method or class.
Public property | Log | Gets the Log object associated with the Manager.
Public property | Manager | Gets the Manager object.
Public property | Wait | Gets a wait object that can be used to wait on specific actions or opertions.

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


BaseWpfTest Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest Constructor
BaseWpfTest Class See Also Send Feedback
Initializes a new instance of the BaseWpfTest class

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected BaseWpfTest()
Visual Basic
Protected Sub New
Visual C++
protected:
BaseWpfTest()

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


BaseWpfTest Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest Methods
BaseWpfTest Class See Also Send Feedback

The BaseWpfTest type exposes the following members.

Methods

Name Description
Public method CleanUp
Shut down and clean-up.
Public method Dispose
Dispose of this test and all of its resources. This method simply calls the CleanUp() method.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Protected method Finalize
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetSettings
This method reads the settings object from the App.Config file and returns a Settings object.

Examples

The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii, Version=x.x.xxx.x, Culture=neutral, PublicKeyToken=4FD5F65BE123776C"/> </configSections> <WebAii.Settings /// logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method Initialize()()()()
Initialize this test case object.
Public method Initialize(String)
Initialize this test case object.
Public method Initialize(Settings)
Initialize this test case object.
Public method Initialize(TestContextWriteLine)
Initialize this test case object.
Public method Initialize(String, TestContextWriteLine)
Initialize this test case object.
Public method Initialize(Settings, TestContextWriteLine)
Initialize this test case object.
Protected method MemberwiseClone
Creates a shallow copy of the current Object.
(Inherited from Object.)
Public method SetTestMethod
Set the TestMethod executing so that WebAii can extract its attributes.
ShutDown
Shut down all instances if recycle brower is set.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


CleanUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..CleanUp Method
BaseWpfTest Class See Also Send Feedback
Shut down and clean-up.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void CleanUp()
Visual Basic
Public Sub CleanUp
Visual C++
public:
void CleanUp()

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


Dispose Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..Dispose Method
BaseWpfTest Class See Also Send Feedback
Dispose of this test and all of its resources. This method simply calls the CleanUp() method.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void Dispose()
Visual Basic
Public Overridable Sub Dispose
Visual C++
public:
virtual void Dispose()

Implements

IDisposable..::..Dispose()()()()

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


GetSettings Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..GetSettings Method
BaseWpfTest Class See Also Send Feedback
This method reads the settings object from the App.Config file and returns a Settings object.

Examples

The following is a sample config file that holds certain settings. Any settings not specified in this section, their values will be set to the system defaults: <?xml version="1.0" encoding="utf-8" ?> <configuration> <configSections> <section name="WebAii.Settings" type="ArtOfTest.WebAii.Core.SettingsConfigSectionHandler,ArtOfTest.WebAii, Version=x.x.xxx.x, Culture=neutral, PublicKeyToken=4FD5F65BE123776C"/> </configSections> <WebAii.Settings /// logLocation="D:\Log\" executionTimeout="60000" clientReadyTimeout="50000" /> </configuration>

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Settings GetSettings()
Visual Basic
Public Shared Function GetSettings As Settings
Visual C++
public:
static Settings^ GetSettings()

Return Value

The settings object read from App.Config.

Remarks

If you call this method and there are not settings present in the App.Config, then the method will create an empty Setting object and reset it to the system default settings. Also note that all Initialize() methods will call this method to attempt to load the settings.

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..Initialize Method
BaseWpfTest Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Initialize()()()() | Initialize this test case object.
Public method | Initialize(String) | Initialize this test case object.
Public method | Initialize(Settings) | Initialize this test case object.
Public method | Initialize(TestContextWriteLine) | Initialize this test case object.
Public method | Initialize(String, TestContextWriteLine) | Initialize this test case object.
Public method | Initialize(Settings, TestContextWriteLine) | Initialize this test case object.

See Also

BaseWpfTest Class
BaseWpfTest Members
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..Initialize Method
BaseWpfTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize()
Visual Basic
Public Sub Initialize
Visual C++
public:
void Initialize()

See Also

BaseWpfTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..Initialize Method (String)
BaseWpfTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    string logLocation
)
Visual Basic
Public Sub Initialize ( _
    logLocation As String _
)
Visual C++
public:
void Initialize(
    String^ logLocation
)

Parameters

logLocation
Type: System..::..String
The log location where to do the logging.

See Also

BaseWpfTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (Settings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..Initialize Method (Settings)
BaseWpfTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    Settings settings
)
Visual Basic
Public Sub Initialize ( _
    settings As Settings _
)
Visual C++
public:
void Initialize(
    Settings^ settings
)

Parameters

settings
Type: ArtOfTest.WebAii.Core..::..Settings
The settings to use for initialization.

See Also

BaseWpfTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (TestContextWriteLine)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..Initialize Method (TestContextWriteLine)
BaseWpfTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    TestContextWriteLine vsWriteLineDelegate
)
Visual Basic
Public Sub Initialize ( _
    vsWriteLineDelegate As TestContextWriteLine _
)
Visual C++
public:
void Initialize(
    TestContextWriteLine^ vsWriteLineDelegate
)

Parameters

vsWriteLineDelegate
Type: ArtOfTest.WebAii.TestTemplates..::..TestContextWriteLine
A write line delegate to call when logging from Log.WriteLine.

See Also

BaseWpfTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (String, TestContextWriteLine)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..Initialize Method (String, TestContextWriteLine)
BaseWpfTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    string logLocation,
    TestContextWriteLine vsWriteLineDelegate
)
Visual Basic
Public Sub Initialize ( _
    logLocation As String, _
    vsWriteLineDelegate As TestContextWriteLine _
)
Visual C++
public:
void Initialize(
    String^ logLocation,
    TestContextWriteLine^ vsWriteLineDelegate
)

Parameters

logLocation
Type: System..::..String
The log location where to do the logging.
vsWriteLineDelegate
Type: ArtOfTest.WebAii.TestTemplates..::..TestContextWriteLine
A write line delegate to call when logging from Log.WriteLine.

See Also

BaseWpfTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


Initialize Method (Settings, TestContextWriteLine)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..Initialize Method (Settings, TestContextWriteLine)
BaseWpfTest Class See Also Send Feedback
Initialize this test case object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Initialize(
    Settings settings,
    TestContextWriteLine vsWriteLineDelegate
)
Visual Basic
Public Sub Initialize ( _
    settings As Settings, _
    vsWriteLineDelegate As TestContextWriteLine _
)
Visual C++
public:
void Initialize(
    Settings^ settings,
    TestContextWriteLine^ vsWriteLineDelegate
)

Parameters

settings
Type: ArtOfTest.WebAii.Core..::..Settings
The settings to use for initialization.
vsWriteLineDelegate
Type: ArtOfTest.WebAii.TestTemplates..::..TestContextWriteLine
A write line delegate to call when logging from Log.WriteLine.

See Also

BaseWpfTest Class
Initialize Overload
ArtOfTest.WebAii.TestTemplates Namespace


SetTestMethod Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..SetTestMethod Method
BaseWpfTest Class See Also Send Feedback
Set the TestMethod executing so that WebAii can extract its attributes.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetTestMethod(
    Object testObject,
    string testMethodName
)
Visual Basic
Public Sub SetTestMethod ( _
    testObject As Object, _
    testMethodName As String _
)
Visual C++
public:
void SetTestMethod(
    Object^ testObject,
    String^ testMethodName
)

Parameters

testObject
Type: System..::..Object
The test object.
testMethodName
Type: System..::..String
The test Method name executing.

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


ShutDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest..::..ShutDown Method
BaseWpfTest Class See Also Send Feedback
Shut down all instances if recycle brower is set.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void ShutDown()
Visual Basic
Public Shared Sub ShutDown
Visual C++
public:
static void ShutDown()

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


BaseWpfTest Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseWpfTest Properties
BaseWpfTest Class See Also Send Feedback

The BaseWpfTest type exposes the following members.

Properties

 | Name | Description
Public property | ActiveApplication | Gets the ActiveBrowser object. (The last browser launched).
Public property | Desktop | Gets the Desktop object from the Manager.
Public property | Elements | Gets the Elements finder to be used to access elements defined by FindAttribute on the test method or class.
Public property | Log | Gets the Log object associated with the Manager.
Public property | Manager | Gets the Manager object.
Public property | Wait | Gets a wait object that can be used to wait on specific actions or opertions.

See Also

BaseWpfTest Class
ArtOfTest.WebAii.TestTemplates Namespace


ElementContainer(TElement, TFindExpression) Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Members
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class Constructors Methods See Also Send Feedback

The ElementContainer<(Of <(<'TElement, TFindExpression>)>)> type exposes the following members.

Constructors

 | Name | Description
Protected method | ElementContainer<(Of <(<'TElement, TFindExpression>)>)> | Initializes a new instance of the ElementContainer<(Of <(<'TElement, TFindExpression>)>)> class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(array<String>[]()[][]) | Finds an element using a FindExpression.
Public method | Get(TFindExpression) | Finds an element using a FindExpression.
Public method | Get(TFindExpression, Boolean, Int32) | Finds an element using a FindExpression.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class
ArtOfTest.WebAii.TestTemplates Namespace


ElementContainer(TElement, TFindExpression) Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Constructor
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class See Also Send Feedback
Initializes a new instance of the ElementContainer<(Of <(<'TElement, TFindExpression>)>)> class

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected ElementContainer()
Visual Basic
Protected Sub New
Visual C++
protected:
ElementContainer()

See Also

ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class
ArtOfTest.WebAii.TestTemplates Namespace


ElementContainer(TElement, TFindExpression) Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Methods
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class See Also Send Feedback

The ElementContainer<(Of <(<'TElement, TFindExpression>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(array<String>[]()[][]) | Finds an element using a FindExpression.
Public method | Get(TFindExpression) | Finds an element using a FindExpression.
Public method | Get(TFindExpression, Boolean, Int32) | Finds an element using a FindExpression.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class
ArtOfTest.WebAii.TestTemplates Namespace


Get Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get Method
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get(array<String>[]()[][]) | Finds an element using a FindExpression.
Public method | Get(TFindExpression) | Finds an element using a FindExpression.
Public method | Get(TFindExpression, Boolean, Int32) | Finds an element using a FindExpression.

See Also

ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Members
ArtOfTest.WebAii.TestTemplates Namespace


Get Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get Method (array<String>[]()[][])
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class See Also Send Feedback
Finds an element using a FindExpression.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TElement Get(
    params string[] clauses
)
Visual Basic
Public Function Get ( _
    ParamArray clauses As String() _
) As TElement
Visual C++
public:
TElement Get(
    ... array<String^>^ clauses
)

Parameters

clauses
Type: array< System..::..String >[]()[][]
A list of clauses to use to find the element.

Return Value

The element or null if no matching element found.

See Also

ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get Method (TFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get Method (TFindExpression)
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class See Also Send Feedback
Finds an element using a FindExpression.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract TElement Get(
    TFindExpression expr
)
Visual Basic
Public MustOverride Function Get ( _
    expr As TFindExpression _
) As TElement
Visual C++
public:
virtual TElement Get(
    TFindExpression expr
) abstract

Parameters

expr
Type: TFindExpression
The FindExpression<(Of <(<'T>)>)> to use to locate the element.

Return Value

The element or null if no matching element found.

See Also

ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get Method (TFindExpression, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get Method (TFindExpression, Boolean, Int32)
ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class See Also Send Feedback
Finds an element using a FindExpression.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract TElement Get(
    TFindExpression expr,
    bool waitOnElement,
    int timeout
)
Visual Basic
Public MustOverride Function Get ( _
    expr As TFindExpression, _
    waitOnElement As Boolean, _
    timeout As Integer _
) As TElement
Visual C++
public:
virtual TElement Get(
    TFindExpression expr,
    bool waitOnElement,
    int timeout
) abstract

Parameters

expr
Type: TFindExpression
The FindExpression<(Of <(<'T>)>)> to use to locate the element.
waitOnElement
Type: System..::..Boolean
Whether or not to wait for the element to exist.
timeout
Type: System..::..Int32
The amount of time to wait for the element to exist. If waitOnElement is false, this parameter is not used.

Return Value

The element or null if no matching element found within the timeout period.

See Also

ElementContainer<(Of <(<'TElement, TFindExpression>)>)> Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


HtmlElementContainer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer Members
HtmlElementContainer Class Constructors Methods Properties See Also Send Feedback

The HtmlElementContainer type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlElementContainer | Initializes a new HtmlElementContainer object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression).)
Public method | Get(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree. (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression, Boolean, Int32).)
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.
Public method | Get<(Of <<'(TControl>)>>)(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.
Public method | Get<(Of <<'(TControl>)>>)(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Find | Gets the Find object scoped to this container.
Public property | OwnerBrowser | The owner browser of this container.

See Also

HtmlElementContainer Class
ArtOfTest.WebAii.TestTemplates Namespace


HtmlElementContainer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer Constructor
HtmlElementContainer Class See Also Send Feedback
Initializes a new HtmlElementContainer object.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlElementContainer(
    Find find
)
Visual Basic
Public Sub New ( _
    find As Find _
)
Visual C++
public:
HtmlElementContainer(
    Find^ find
)

Parameters

find
Type: ArtOfTest.WebAii.Core..::..Find
The Find object use when searching for this element in the DOM tree.

See Also

HtmlElementContainer Class
ArtOfTest.WebAii.TestTemplates Namespace


HtmlElementContainer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer Methods
HtmlElementContainer Class See Also Send Feedback

The HtmlElementContainer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression).)
Public method | Get(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree. (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression, Boolean, Int32).)
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.
Public method | Get<(Of <<'(TControl>)>>)(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.
Public method | Get<(Of <<'(TControl>)>>)(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlElementContainer Class
ArtOfTest.WebAii.TestTemplates Namespace


Get Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer..::..Get Method
HtmlElementContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.
Public method | Get(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression).)
Public method | Get<(Of <<'(TControl>)>>)(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.
Public method | Get(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree. (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression, Boolean, Int32).)
Public method | Get<(Of <<'(TControl>)>>)(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree.

See Also

HtmlElementContainer Class
HtmlElementContainer Members
ArtOfTest.WebAii.TestTemplates Namespace


Get(TControl) Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer..::..Get<(Of <(<'TControl>)>)> Method (array<String>[]()[][])
HtmlElementContainer Class See Also Send Feedback
Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl Get<TControl>(
    params string[] clauses
)
where TControl : new(), Control
Visual Basic
Public Function Get(Of TControl As {New, Control}) ( _
    ParamArray clauses As String() _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl Get(
    ... array<String^>^ clauses
)

Parameters

clauses
Type: array< System..::..String >[]()[][]
An array of HtmlFindExpression strings to use to find a matching element in the DOM tree.

Type Parameters

TControl
The type of element to search for.

Return Value

An element of type TControl or null if no matching element found.

See Also

HtmlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get Method (HtmlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer..::..Get Method (HtmlFindExpression)
HtmlElementContainer Class See Also Send Feedback
Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Element Get(
    HtmlFindExpression expr
)
Visual Basic
Public Overrides Function Get ( _
    expr As HtmlFindExpression _
) As Element
Visual C++
public:
virtual Element^ Get(
    HtmlFindExpression^ expr
) override

Parameters

expr
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression that defines how to find the right element.

Return Value

An Element or null if no matching element found.

See Also

HtmlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get(TControl) Method (HtmlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer..::..Get<(Of <(<'TControl>)>)> Method (HtmlFindExpression)
HtmlElementContainer Class See Also Send Feedback
Find a matching element in the DOM tree. Waits the default amount of time for the element to exist.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl Get<TControl>(
    HtmlFindExpression expr
)
where TControl : new(), Control
Visual Basic
Public Function Get(Of TControl As {New, Control}) ( _
    expr As HtmlFindExpression _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl Get(
    HtmlFindExpression^ expr
)

Parameters

expr
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression that defines how to find the right element.

Type Parameters

TControl
The type of element to search for.

Return Value

An element of type TControl or null if no matching element found.

See Also

HtmlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get Method (HtmlFindExpression, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer..::..Get Method (HtmlFindExpression, Boolean, Int32)
HtmlElementContainer Class See Also Send Feedback
Find a matching element in the DOM tree.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Element Get(
    HtmlFindExpression expr,
    bool waitOnElement,
    int timeout
)
Visual Basic
Public Overrides Function Get ( _
    expr As HtmlFindExpression, _
    waitOnElement As Boolean, _
    timeout As Integer _
) As Element
Visual C++
public:
virtual Element^ Get(
    HtmlFindExpression^ expr,
    bool waitOnElement,
    int timeout
) override

Parameters

expr
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression that defines how to find the right element.
waitOnElement
Type: System..::..Boolean
Whether or not to wait for the element to exist.
timeout
Type: System..::..Int32
The amount of time to wait for the element to exist.

Return Value

An Element or null if no matching element found.

See Also

HtmlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get(TControl) Method (HtmlFindExpression, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer..::..Get<(Of <(<'TControl>)>)> Method (HtmlFindExpression, Boolean, Int32)
HtmlElementContainer Class See Also Send Feedback
Find a matching element in the DOM tree.

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl Get<TControl>(
    HtmlFindExpression expr,
    bool waitOnElement,
    int timeout
)
where TControl : new(), Control
Visual Basic
Public Function Get(Of TControl As {New, Control}) ( _
    expr As HtmlFindExpression, _
    waitOnElement As Boolean, _
    timeout As Integer _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : gcnew(), Control
TControl Get(
    HtmlFindExpression^ expr,
    bool waitOnElement,
    int timeout
)

Parameters

expr
Type: ArtOfTest.WebAii.Core..::..HtmlFindExpression
The HtmlFindExpression that defines how to find the right element.
waitOnElement
Type: System..::..Boolean
Whether or not to wait for the element to exist.
timeout
Type: System..::..Int32
The amount of time to wait for the element to exist.

Type Parameters

TControl
The type of element to search for.

Return Value

An element of type TControl or null if no matching element found.

See Also

HtmlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


HtmlElementContainer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlElementContainer Properties
HtmlElementContainer Class See Also Send Feedback

The HtmlElementContainer type exposes the following members.

Properties

 | Name | Description
Public property | Find | Gets the Find object scoped to this container.
Public property | OwnerBrowser | The owner browser of this container.

See Also

HtmlElementContainer Class
ArtOfTest.WebAii.TestTemplates Namespace


HtmlPage Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlPage Members
HtmlPage Class Constructors Methods Properties See Also Send Feedback

The HtmlPage type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlPage | Initializes a new instance of the HtmlPage class

Methods

 | Name | Description
Public method | Close |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Inherited from HtmlElementContainer.)
Public method | Get(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree. (Inherited from HtmlElementContainer.)
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Inherited from HtmlElementContainer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Navigate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForRedirect |

Properties

 | Name | Description
Public property | Find | Gets the Find object scoped to this container. (Inherited from HtmlElementContainer.)
Public property | OwnerBrowser | The owner browser of this container. (Inherited from HtmlElementContainer.)
Public property | Url |

See Also

HtmlPage Class
ArtOfTest.WebAii.TestTemplates Namespace


HtmlPage Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlPage Constructor
HtmlPage Class See Also Send Feedback
Initializes a new instance of the HtmlPage class

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public HtmlPage(
    string url,
    Find find
)
Visual Basic
Public Sub New ( _
    url As String, _
    find As Find _
)
Visual C++
public:
HtmlPage(
    String^ url,
    Find^ find
)

Parameters

url
Type: System..::..String

[Missing <param name="url"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.HtmlPage.#ctor(System.String,ArtOfTest.WebAii.Core.Find)"]

find
Type: ArtOfTest.WebAii.Core..::..Find

[Missing <param name="find"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.HtmlPage.#ctor(System.String,ArtOfTest.WebAii.Core.Find)"]

See Also

HtmlPage Class
ArtOfTest.WebAii.TestTemplates Namespace


HtmlPage Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlPage Methods
HtmlPage Class See Also Send Feedback

The HtmlPage type exposes the following members.

Methods

 | Name | Description
Public method | Close |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Inherited from HtmlElementContainer.)
Public method | Get(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree. (Inherited from HtmlElementContainer.)
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Inherited from HtmlElementContainer.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Navigate |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForRedirect |

See Also

HtmlPage Class
ArtOfTest.WebAii.TestTemplates Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlPage..::..Close Method
HtmlPage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.TestTemplates.HtmlPage.Close"]

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

HtmlPage Class
ArtOfTest.WebAii.TestTemplates Namespace


Get Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlPage..::..Get Method
HtmlPage Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Inherited from HtmlElementContainer.)
Public method | Get(HtmlFindExpression) | Find a matching element in the DOM tree. Waits the default amount of time for the element to exist. (Inherited from HtmlElementContainer.)
Public method | Get(HtmlFindExpression, Boolean, Int32) | Find a matching element in the DOM tree. (Inherited from HtmlElementContainer.)

See Also

HtmlPage Class
HtmlPage Members
ArtOfTest.WebAii.TestTemplates Namespace


Navigate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlPage..::..Navigate Method
HtmlPage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.TestTemplates.HtmlPage.Navigate"]

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Navigate()
Visual Basic
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

HtmlPage Class
ArtOfTest.WebAii.TestTemplates Namespace


WaitForRedirect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlPage..::..WaitForRedirect Method
HtmlPage Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.TestTemplates.HtmlPage.WaitForRedirect(ArtOfTest.WebAii.TestTemplates.HtmlPage,System.Int32)"]

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitForRedirect(
    HtmlPage page,
    int timeout
)
Visual Basic
Public Sub WaitForRedirect ( _
    page As HtmlPage, _
    timeout As Integer _
)
Visual C++
public:
void WaitForRedirect(
    HtmlPage^ page,
    int timeout
)

Parameters

page
Type: ArtOfTest.WebAii.TestTemplates..::..HtmlPage

[Missing <param name="page"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.HtmlPage.WaitForRedirect(ArtOfTest.WebAii.TestTemplates.HtmlPage,System.Int32)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.HtmlPage.WaitForRedirect(ArtOfTest.WebAii.TestTemplates.HtmlPage,System.Int32)"]

See Also

HtmlPage Class
ArtOfTest.WebAii.TestTemplates Namespace


HtmlPage Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlPage Properties
HtmlPage Class See Also Send Feedback

The HtmlPage type exposes the following members.

Properties

 | Name | Description
Public property | Find | Gets the Find object scoped to this container. (Inherited from HtmlElementContainer.)
Public property | OwnerBrowser | The owner browser of this container. (Inherited from HtmlElementContainer.)
Public property | Url |

See Also

HtmlPage Class
ArtOfTest.WebAii.TestTemplates Namespace


XamlApplication Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlApplication Members
XamlApplication Class Constructors Methods Properties See Also Send Feedback

The XamlApplication type exposes the following members.

Constructors

 | Name | Description
Public method | XamlApplication | Initializes a new instance of the XamlApplication class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OwnerApplication |

See Also

XamlApplication Class
ArtOfTest.WebAii.TestTemplates Namespace


XamlApplication Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlApplication Constructor
XamlApplication Class See Also Send Feedback
Initializes a new instance of the XamlApplication class

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XamlApplication(
    WpfApplication ownerApplication
)
Visual Basic
Public Sub New ( _
    ownerApplication As WpfApplication _
)
Visual C++
public:
XamlApplication(
    WpfApplication^ ownerApplication
)

Parameters

ownerApplication
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="ownerApplication"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlApplication.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication)"]

See Also

XamlApplication Class
ArtOfTest.WebAii.TestTemplates Namespace


XamlApplication Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlApplication Methods
XamlApplication Class See Also Send Feedback

The XamlApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XamlApplication Class
ArtOfTest.WebAii.TestTemplates Namespace


XamlApplication Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlApplication Properties
XamlApplication Class See Also Send Feedback

The XamlApplication type exposes the following members.

Properties

 | Name | Description
Public property | OwnerApplication |

See Also

XamlApplication Class
ArtOfTest.WebAii.TestTemplates Namespace


XamlElementContainer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer Members
XamlElementContainer Class Constructors Methods Properties See Also Send Feedback

The XamlElementContainer type exposes the following members.

Constructors

 | Name | Description
Public method | XamlElementContainer | Initializes a new instance of the XamlElementContainer class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(XamlFindExpression) | (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression).)
Public method | Get(XamlFindExpression, Boolean, Int32) | (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression, Boolean, Int32).)
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) |
Public method | Get<(Of <<'(TControl>)>>)(XamlFindExpression) |
Public method | Get<(Of <<'(TControl>)>>)(XamlFindExpression, Boolean, Int32) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EnsureClickable | Gets and sets whether to ensure elements are in a clickable region of the browser
Public property | Find | Gets the Find object scoped to this container.
Public property | OwnerApp | Gets a reference of the application that owner this element.

See Also

XamlElementContainer Class
ArtOfTest.WebAii.TestTemplates Namespace


XamlElementContainer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer Constructor
XamlElementContainer Class See Also Send Feedback
Initializes a new instance of the XamlElementContainer class

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public XamlElementContainer(
    VisualFind find
)
Visual Basic
Public Sub New ( _
    find As VisualFind _
)
Visual C++
public:
XamlElementContainer(
    VisualFind^ find
)

Parameters

find
Type: ArtOfTest.WebAii.Silverlight..::..VisualFind

[Missing <param name="find"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.#ctor(ArtOfTest.WebAii.Silverlight.VisualFind)"]

See Also

XamlElementContainer Class
ArtOfTest.WebAii.TestTemplates Namespace


XamlElementContainer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer Methods
XamlElementContainer Class See Also Send Feedback

The XamlElementContainer type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get(XamlFindExpression) | (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression).)
Public method | Get(XamlFindExpression, Boolean, Int32) | (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression, Boolean, Int32).)
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) |
Public method | Get<(Of <<'(TControl>)>>)(XamlFindExpression) |
Public method | Get<(Of <<'(TControl>)>>)(XamlFindExpression, Boolean, Int32) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

XamlElementContainer Class
ArtOfTest.WebAii.TestTemplates Namespace


Get Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer..::..Get Method
XamlElementContainer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get<(Of <<'(TControl>)>>)(array<String>[]()[][]) |
Public method | Get(XamlFindExpression) | (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression).)
Public method | Get<(Of <<'(TControl>)>>)(XamlFindExpression) |
Public method | Get<(Of <<'(TControl>)>>)(XamlFindExpression, Boolean, Int32) |
Public method | Get(XamlFindExpression, Boolean, Int32) | (Overrides ElementContainer<(Of <(<'TElement, TFindExpression>)>)>..::..Get(TFindExpression, Boolean, Int32).)

See Also

XamlElementContainer Class
XamlElementContainer Members
ArtOfTest.WebAii.TestTemplates Namespace


Get(TControl) Method (String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer..::..Get<(Of <(<'TControl>)>)> Method (array<String>[]()[][])
XamlElementContainer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(System.String[])"]

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl Get<TControl>(
    params string[] clauses
)
where TControl : IFrameworkElement
Visual Basic
Public Function Get(Of TControl As IFrameworkElement) ( _
    ParamArray clauses As String() _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : IFrameworkElement
TControl Get(
    ... array<String^>^ clauses
)

Parameters

clauses
Type: array< System..::..String >[]()[][]

[Missing <param name="clauses"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(System.String[])"]

Type Parameters

TControl

[Missing <typeparam name="TControl"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(System.String[])"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(System.String[])"]

See Also

XamlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get Method (XamlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer..::..Get Method (XamlFindExpression)
XamlElementContainer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get(ArtOfTest.WebAii.Silverlight.XamlFindExpression)"]

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override FrameworkElement Get(
    XamlFindExpression expr
)
Visual Basic
Public Overrides Function Get ( _
    expr As XamlFindExpression _
) As FrameworkElement
Visual C++
public:
virtual FrameworkElement^ Get(
    XamlFindExpression^ expr
) override

Parameters

expr
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression

[Missing <param name="expr"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get(ArtOfTest.WebAii.Silverlight.XamlFindExpression)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get(ArtOfTest.WebAii.Silverlight.XamlFindExpression)"]

See Also

XamlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get(TControl) Method (XamlFindExpression)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer..::..Get<(Of <(<'TControl>)>)> Method (XamlFindExpression)
XamlElementContainer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression)"]

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl Get<TControl>(
    XamlFindExpression expr
)
where TControl : IFrameworkElement
Visual Basic
Public Function Get(Of TControl As IFrameworkElement) ( _
    expr As XamlFindExpression _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : IFrameworkElement
TControl Get(
    XamlFindExpression^ expr
)

Parameters

expr
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression

[Missing <param name="expr"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression)"]

Type Parameters

TControl

[Missing <typeparam name="TControl"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression)"]

See Also

XamlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get(TControl) Method (XamlFindExpression, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer..::..Get<(Of <(<'TControl>)>)> Method (XamlFindExpression, Boolean, Int32)
XamlElementContainer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public TControl Get<TControl>(
    XamlFindExpression expr,
    bool waitOnElement,
    int timeout
)
where TControl : IFrameworkElement
Visual Basic
Public Function Get(Of TControl As IFrameworkElement) ( _
    expr As XamlFindExpression, _
    waitOnElement As Boolean, _
    timeout As Integer _
) As TControl
Visual C++
public:
generic<typename TControl>
where TControl : IFrameworkElement
TControl Get(
    XamlFindExpression^ expr,
    bool waitOnElement,
    int timeout
)

Parameters

expr
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression

[Missing <param name="expr"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

waitOnElement
Type: System..::..Boolean

[Missing <param name="waitOnElement"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

Type Parameters

TControl

[Missing <typeparam name="TControl"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get``1(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

See Also

XamlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


Get Method (XamlFindExpression, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer..::..Get Method (XamlFindExpression, Boolean, Int32)
XamlElementContainer Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

Namespace: ArtOfTest.WebAii.TestTemplates
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override FrameworkElement Get(
    XamlFindExpression expr,
    bool waitOnElement,
    int timeout
)
Visual Basic
Public Overrides Function Get ( _
    expr As XamlFindExpression, _
    waitOnElement As Boolean, _
    timeout As Integer _
) As FrameworkElement
Visual C++
public:
virtual FrameworkElement^ Get(
    XamlFindExpression^ expr,
    bool waitOnElement,
    int timeout
) override

Parameters

expr
Type: ArtOfTest.WebAii.Silverlight..::..XamlFindExpression

[Missing <param name="expr"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

waitOnElement
Type: System..::..Boolean

[Missing <param name="waitOnElement"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.TestTemplates.XamlElementContainer.Get(ArtOfTest.WebAii.Silverlight.XamlFindExpression,System.Boolean,System.Int32)"]

See Also

XamlElementContainer Class
Get Overload
ArtOfTest.WebAii.TestTemplates Namespace


XamlElementContainer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XamlElementContainer Properties
XamlElementContainer Class See Also Send Feedback

The XamlElementContainer type exposes the following members.

Properties

 | Name | Description
Public property | EnsureClickable | Gets and sets whether to ensure elements are in a clickable region of the browser
Public property | Find | Gets the Find object scoped to this container.
Public property | OwnerApp | Gets a reference of the application that owner this element.

See Also

XamlElementContainer Class
ArtOfTest.WebAii.TestTemplates Namespace


ArtOfTest.WebAii.Win32 Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Win32 Namespace
Send Feedback
Namespace for the WebAii functions that directly access the native Windows Win32 API.

Classes

 | Class | Description
Public class | Annotator | Provides annotation support for a browser.
Public class | AnnotatorSettings | Class representing all the annotator settings.
Public class | AnnotatorUI | Interaction logic for AnnotatorUI.xaml
Public class | Button | Represents a Win32 button on a window or a dialog.
Public class | KeyBoard | Keyboard events class.
Public class | Mouse | Mouse events class.
Public class | OSInformation | Provides detailed information about the host operating system.
Public class | VisualMouseProxy |
Public class | Win32Error | Static class used to retrieve last error strings from Win32 calls.


Annotator Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator Members
Annotator Class Constructors Methods Properties See Also Send Feedback

The Annotator type exposes the following members.

Constructors

 | Name | Description
Public method | Annotator(IAnnotationHost) | Create a new annotator with default settings.
Public method | Annotator(Desktop) | Initializes a new instance of the Annotator class
Public method | Annotator(IAnnotationHost, AnnotatorSettings) | Create a new annotator object.

Methods

 | Name | Description
Public method | Annotate(String) | Annotate a message to the browser. Will use the AnnotateSettings.InfoMessageLocation to place this message on the browser surface.
Public method | Annotate(Point, String) | Annotate a single point.
Public method | Annotate(Rectangle, String) | Annotate and highlight a specific target rectangle on the browser surface with a message to display underneath.
Public method | Annotate(String, Int32, OffsetReference) | Annotate a message to the browser
Public method | Clear | Clear all annotations
Public method | Close | Close the annotator.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Settings | Gets/Sets the annotation settings to use. You can use these settings at any point in execution to change how annotation is done.

See Also

Annotator Class
ArtOfTest.WebAii.Win32 Namespace


Annotator Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator Constructor
Annotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Annotator(IAnnotationHost) | Create a new annotator with default settings.
Public method | Annotator(Desktop) | Initializes a new instance of the Annotator class
Public method | Annotator(IAnnotationHost, AnnotatorSettings) | Create a new annotator object.

See Also

Annotator Class
Annotator Members
ArtOfTest.WebAii.Win32 Namespace


Annotator Constructor ()

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator Constructor ()
Annotator Class See Also Send Feedback
Create a new annotator with default settings.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Annotator(
    IAnnotationHost host
)
Visual Basic
Public Sub New ( _
    host As IAnnotationHost _
)
Visual C++
public:
Annotator(
    IAnnotationHost^ host
)

Parameters

host
Type: IAnnotationHost

[Missing <param name="host"/> documentation for "M:ArtOfTest.WebAii.Win32.Annotator.#ctor(ArtOfTest.WebAii.IAnnotationHost)"]

See Also

Annotator Class
Annotator Overload
ArtOfTest.WebAii.Win32 Namespace


Annotator Constructor (Desktop)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator Constructor (Desktop)
Annotator Class See Also Send Feedback
Initializes a new instance of the Annotator class

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Annotator(
    Desktop desktop
)
Visual Basic
Public Sub New ( _
    desktop As Desktop _
)
Visual C++
public:
Annotator(
    Desktop^ desktop
)

Parameters

desktop
Type: ArtOfTest.WebAii.Core..::..Desktop

[Missing <param name="desktop"/> documentation for "M:ArtOfTest.WebAii.Win32.Annotator.#ctor(ArtOfTest.WebAii.Core.Desktop)"]

See Also

Annotator Class
Annotator Overload
ArtOfTest.WebAii.Win32 Namespace


Annotator Constructor (, AnnotatorSettings)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator Constructor (, AnnotatorSettings)
Annotator Class See Also Send Feedback
Create a new annotator object.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Annotator(
    IAnnotationHost host,
    AnnotatorSettings annotationSettings
)
Visual Basic
Public Sub New ( _
    host As IAnnotationHost, _
    annotationSettings As AnnotatorSettings _
)
Visual C++
public:
Annotator(
    IAnnotationHost^ host,
    AnnotatorSettings^ annotationSettings
)

Parameters

host
Type: IAnnotationHost

[Missing <param name="host"/> documentation for "M:ArtOfTest.WebAii.Win32.Annotator.#ctor(ArtOfTest.WebAii.IAnnotationHost,ArtOfTest.WebAii.Win32.AnnotatorSettings)"]

annotationSettings
Type: ArtOfTest.WebAii.Win32..::..AnnotatorSettings
The annotation settings.

See Also

Annotator Class
Annotator Overload
ArtOfTest.WebAii.Win32 Namespace


Annotator Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator Methods
Annotator Class See Also Send Feedback

The Annotator type exposes the following members.

Methods

 | Name | Description
Public method | Annotate(String) | Annotate a message to the browser. Will use the AnnotateSettings.InfoMessageLocation to place this message on the browser surface.
Public method | Annotate(Point, String) | Annotate a single point.
Public method | Annotate(Rectangle, String) | Annotate and highlight a specific target rectangle on the browser surface with a message to display underneath.
Public method | Annotate(String, Int32, OffsetReference) | Annotate a message to the browser
Public method | Clear | Clear all annotations
Public method | Close | Close the annotator.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Annotator Class
ArtOfTest.WebAii.Win32 Namespace


Annotate Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator..::..Annotate Method
Annotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Annotate(String) | Annotate a message to the browser. Will use the AnnotateSettings.InfoMessageLocation to place this message on the browser surface.
Public method | Annotate(Point, String) | Annotate a single point.
Public method | Annotate(Rectangle, String) | Annotate and highlight a specific target rectangle on the browser surface with a message to display underneath.
Public method | Annotate(String, Int32, OffsetReference) | Annotate a message to the browser

See Also

Annotator Class
Annotator Members
ArtOfTest.WebAii.Win32 Namespace


Annotate Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator..::..Annotate Method (String)
Annotator Class See Also Send Feedback
Annotate a message to the browser. Will use the AnnotateSettings.InfoMessageLocation to place this message on the browser surface.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Annotate(
    string message
)
Visual Basic
Public Sub Annotate ( _
    message As String _
)
Visual C++
public:
void Annotate(
    String^ message
)

Parameters

message
Type: System..::..String
The message.

See Also

Annotator Class
Annotate Overload
ArtOfTest.WebAii.Win32 Namespace


Annotate Method (Point, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator..::..Annotate Method (Point, String)
Annotator Class See Also Send Feedback
Annotate a single point.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Annotate(
    Point point,
    string message
)
Visual Basic
Public Sub Annotate ( _
    point As Point, _
    message As String _
)
Visual C++
public:
void Annotate(
    Point point,
    String^ message
)

Parameters

point
Type: System.Drawing..::..Point
The point.
message
Type: System..::..String
The message

See Also

Annotator Class
Annotate Overload
ArtOfTest.WebAii.Win32 Namespace


Annotate Method (Rectangle, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator..::..Annotate Method (Rectangle, String)
Annotator Class See Also Send Feedback
Annotate and highlight a specific target rectangle on the browser surface with a message to display underneath.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Annotate(
    Rectangle targetArea,
    string message
)
Visual Basic
Public Sub Annotate ( _
    targetArea As Rectangle, _
    message As String _
)
Visual C++
public:
void Annotate(
    Rectangle targetArea,
    String^ message
)

Parameters

targetArea
Type: System.Drawing..::..Rectangle
The target area to highlight.
message
Type: System..::..String
The message.

See Also

Annotator Class
Annotate Overload
ArtOfTest.WebAii.Win32 Namespace


Annotate Method (String, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator..::..Annotate Method (String, Int32, OffsetReference)
Annotator Class See Also Send Feedback
Annotate a message to the browser

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Annotate(
    string message,
    int displayTime,
    OffsetReference location
)
Visual Basic
Public Sub Annotate ( _
    message As String, _
    displayTime As Integer, _
    location As OffsetReference _
)
Visual C++
public:
void Annotate(
    String^ message,
    int displayTime,
    OffsetReference location
)

Parameters

message
Type: System..::..String
The message.
displayTime
Type: System..::..Int32
The display time (msec).
location
Type: ArtOfTest.Common..::..OffsetReference
The display location

See Also

Annotator Class
Annotate Overload
ArtOfTest.WebAii.Win32 Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator..::..Clear Method
Annotator Class See Also Send Feedback
Clear all annotations

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

Annotator Class
ArtOfTest.WebAii.Win32 Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator..::..Close Method
Annotator Class See Also Send Feedback
Close the annotator.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

Annotator Class
ArtOfTest.WebAii.Win32 Namespace


Annotator Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Annotator Properties
Annotator Class See Also Send Feedback

The Annotator type exposes the following members.

Properties

 | Name | Description
Public property | Settings | Gets/Sets the annotation settings to use. You can use these settings at any point in execution to change how annotation is done.

See Also

Annotator Class
ArtOfTest.WebAii.Win32 Namespace


AnnotatorSettings Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorSettings Members
AnnotatorSettings Class Constructors Methods Properties See Also Send Feedback

The AnnotatorSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotatorSettings()()()() | Create a new Annotator settings object. Use default settings.
Public method | AnnotatorSettings(Color, Single) | Create a new Annotator settings object.
Public method | AnnotatorSettings(Color, Single, String, Single, FontStyle, Boolean, Color, Int32, Int32, OffsetReference) | Create a new Annotator settings object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackColor | Gets/Sets the background color for message annotations. Default Yellow.
Public property | BackColorAlpha | Gets/Sets the background color alpha blending. Default 240.
Public property | BorderPadding | Gets/Sets the border padding between the border and highlighted element. Default 4.
Public property | BorderWidth | Gets/Sets the border width that highlights the element. Default 2.
Public property | Color | Gets/Sets the color to use to draw the annotations. Default Red.
Public property | CustomDisplayTime | Gets or sets the hang time for custom annotations.
Public property | FontemSize | Gets/Sets the font size to use to draw the messages. Default 10.
Public property | FontFamilyName | The font family name to use to draw the annotation messages. Default Tahoma.
Public property | FontStyle | Gets/Sets the font style to use to draw the messages. Default Bold.
Public property | InfoMessageLocation | Gets/Sets the info message location in reference to the window. Default TopCenter.
Public property | ShowAnnotationMessage | Gets/Sets whether to show message annotation in addition to highlighting the target elements.

See Also

AnnotatorSettings Class
ArtOfTest.WebAii.Win32 Namespace


AnnotatorSettings Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorSettings Constructor
AnnotatorSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnnotatorSettings()()()() | Create a new Annotator settings object. Use default settings.
Public method | AnnotatorSettings(Color, Single) | Create a new Annotator settings object.
Public method | AnnotatorSettings(Color, Single, String, Single, FontStyle, Boolean, Color, Int32, Int32, OffsetReference) | Create a new Annotator settings object.

See Also

AnnotatorSettings Class
AnnotatorSettings Members
ArtOfTest.WebAii.Win32 Namespace


AnnotatorSettings Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorSettings Constructor
AnnotatorSettings Class See Also Send Feedback
Create a new Annotator settings object. Use default settings.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AnnotatorSettings()
Visual Basic
Public Sub New
Visual C++
public:
AnnotatorSettings()

See Also

AnnotatorSettings Class
AnnotatorSettings Overload
ArtOfTest.WebAii.Win32 Namespace


AnnotatorSettings Constructor (Color, Single)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorSettings Constructor (Color, Single)
AnnotatorSettings Class See Also Send Feedback
Create a new Annotator settings object.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AnnotatorSettings(
    Color color,
    float borderWidth
)
Visual Basic
Public Sub New ( _
    color As Color, _
    borderWidth As Single _
)
Visual C++
public:
AnnotatorSettings(
    Color color,
    float borderWidth
)

Parameters

color
Type: System.Drawing..::..Color
The color to use.
borderWidth
Type: System..::..Single
The border width to use.

See Also

AnnotatorSettings Class
AnnotatorSettings Overload
ArtOfTest.WebAii.Win32 Namespace


AnnotatorSettings Constructor (Color, Single, String, Single, FontStyle, Boolean, Color, Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorSettings Constructor (Color, Single, String, Single, FontStyle, Boolean, Color, Int32, Int32, OffsetReference)
AnnotatorSettings Class See Also Send Feedback
Create a new Annotator settings object.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AnnotatorSettings(
    Color color,
    float borderWidth,
    string fontFamilyName,
    float fontemSize,
    FontStyle fontStyle,
    bool ShowAnnotationMessage,
    Color backgroundColor,
    int backgroundAlpha,
    int borderPadding,
    OffsetReference infoLocation
)
Visual Basic
Public Sub New ( _
    color As Color, _
    borderWidth As Single, _
    fontFamilyName As String, _
    fontemSize As Single, _
    fontStyle As FontStyle, _
    ShowAnnotationMessage As Boolean, _
    backgroundColor As Color, _
    backgroundAlpha As Integer, _
    borderPadding As Integer, _
    infoLocation As OffsetReference _
)
Visual C++
public:
AnnotatorSettings(
    Color color,
    float borderWidth,
    String^ fontFamilyName,
    float fontemSize,
    FontStyle fontStyle,
    bool ShowAnnotationMessage,
    Color backgroundColor,
    int backgroundAlpha,
    int borderPadding,
    OffsetReference infoLocation
)

Parameters

color
Type: System.Drawing..::..Color
The color to use.
borderWidth
Type: System..::..Single
The border width to use.
fontFamilyName
Type: System..::..String
The font to use to draw messages.
fontemSize
Type: System..::..Single
The font size to use.
fontStyle
Type: System.Drawing..::..FontStyle
The font style to use.
ShowAnnotationMessage
Type: System..::..Boolean
Whether to show annotation messages or not.
backgroundColor
Type: System.Drawing..::..Color
The background color of text annotations.
backgroundAlpha
Type: System..::..Int32
The background alpha blending 0-255.
borderPadding
Type: System..::..Int32
The padding between the highlight border and the element.
infoLocation
Type: ArtOfTest.Common..::..OffsetReference
The location where to place text annotations.

See Also

AnnotatorSettings Class
AnnotatorSettings Overload
ArtOfTest.WebAii.Win32 Namespace


AnnotatorSettings Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorSettings Methods
AnnotatorSettings Class See Also Send Feedback

The AnnotatorSettings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotatorSettings Class
ArtOfTest.WebAii.Win32 Namespace


AnnotatorSettings Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorSettings Properties
AnnotatorSettings Class See Also Send Feedback

The AnnotatorSettings type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Gets/Sets the background color for message annotations. Default Yellow.
Public property | BackColorAlpha | Gets/Sets the background color alpha blending. Default 240.
Public property | BorderPadding | Gets/Sets the border padding between the border and highlighted element. Default 4.
Public property | BorderWidth | Gets/Sets the border width that highlights the element. Default 2.
Public property | Color | Gets/Sets the color to use to draw the annotations. Default Red.
Public property | CustomDisplayTime | Gets or sets the hang time for custom annotations.
Public property | FontemSize | Gets/Sets the font size to use to draw the messages. Default 10.
Public property | FontFamilyName | The font family name to use to draw the annotation messages. Default Tahoma.
Public property | FontStyle | Gets/Sets the font style to use to draw the messages. Default Bold.
Public property | InfoMessageLocation | Gets/Sets the info message location in reference to the window. Default TopCenter.
Public property | ShowAnnotationMessage | Gets/Sets whether to show message annotation in addition to highlighting the target elements.

See Also

AnnotatorSettings Class
ArtOfTest.WebAii.Win32 Namespace


AnnotatorUI Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI Members
AnnotatorUI Class Constructors Methods Properties Events See Also Send Feedback

The AnnotatorUI type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotatorUI | Initializes a new instance of the AnnotatorUI class

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplySettings |
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clear any annotation
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MeasureString | Measure a string using the provided settings. This method should be called after ApplySettings() is called.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetRectPosition |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ShowMessage |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. This is a dependency property. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. This is a dependency property. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. This is a dependency property. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that declares whether this instance is currently read-only. (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Location |
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Size |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Thumb |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). This is a dependency property. (Inherited from FrameworkElement.)
Public property | Transform |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


AnnotatorUI Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI Constructor
AnnotatorUI Class See Also Send Feedback
Initializes a new instance of the AnnotatorUI class

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public AnnotatorUI()
Visual Basic
Public Sub New
Visual C++
public:
AnnotatorUI()

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


AnnotatorUI Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI Methods
AnnotatorUI Class See Also Send Feedback

The AnnotatorUI type exposes the following members.

Methods

 | Name | Description
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplySettings |
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Called to arrange and size the content of a Control object. (Inherited from Control.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | Clear | Clear any annotation
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Do not use. Use FindName(String, FrameworkElement) instead. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Called to remeasure a control. (Inherited from Control.)
Public method | MeasureString | Measure a string using the provided settings. This method should be called after ApplySettings() is called.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from ContentControl.)
Protected method | OnContentStringFormatChanged | (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns an AutomationPeer for this UserControl. (Inherited from UserControl.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Invoked when the parent of this element in the visual tree is changed. Overrides OnVisualParentChanged(DependencyObject). (Inherited from FrameworkElement.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetRectPosition |
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ShowMessage |
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


AddHandler Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..AddHandler Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


ApplyAnimationClock Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..ApplyAnimationClock Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


ApplySettings Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..ApplySettings Method
AnnotatorUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.ApplySettings(ArtOfTest.WebAii.Win32.AnnotatorSettings)"]

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ApplySettings(
    AnnotatorSettings settings
)
Visual Basic
Public Sub ApplySettings ( _
    settings As AnnotatorSettings _
)
Visual C++
public:
void ApplySettings(
    AnnotatorSettings^ settings
)

Parameters

settings
Type: ArtOfTest.WebAii.Win32..::..AnnotatorSettings

[Missing <param name="settings"/> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.ApplySettings(ArtOfTest.WebAii.Win32.AnnotatorSettings)"]

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


BeginAnimation Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..BeginAnimation Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


BeginStoryboard Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..BeginStoryboard Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


BringIntoView Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..BringIntoView Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..Clear Method
AnnotatorUI Class See Also Send Feedback
Clear any annotation

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


ClearValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..ClearValue Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


HitTestCore Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..HitTestCore Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


InitializeComponent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..InitializeComponent Method
AnnotatorUI Class See Also Send Feedback
InitializeComponent

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnector..::..InitializeComponent()()()()

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


MeasureString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..MeasureString Method
AnnotatorUI Class See Also Send Feedback
Measure a string using the provided settings. This method should be called after ApplySettings() is called.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SizeF MeasureString(
    string message
)
Visual Basic
Public Function MeasureString ( _
    message As String _
) As SizeF
Visual C++
public:
SizeF MeasureString(
    String^ message
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.MeasureString(System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.MeasureString(System.String)"]

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


SetBinding Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..SetBinding Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


SetRectPosition Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..SetRectPosition Method
AnnotatorUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.SetRectPosition(System.Drawing.Rectangle)"]

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void SetRectPosition(
    Rectangle pos
)
Visual Basic
Public Sub SetRectPosition ( _
    pos As Rectangle _
)
Visual C++
public:
void SetRectPosition(
    Rectangle pos
)

Parameters

pos
Type: System.Drawing..::..Rectangle

[Missing <param name="pos"/> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.SetRectPosition(System.Drawing.Rectangle)"]

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..SetValue Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


ShowMessage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..ShowMessage Method
AnnotatorUI Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.ShowMessage(System.String,System.Windows.Point)"]

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ShowMessage(
    string message,
    Point location
)
Visual Basic
Public Sub ShowMessage ( _
    message As String, _
    location As Point _
)
Visual C++
public:
void ShowMessage(
    String^ message,
    Point location
)

Parameters

message
Type: System..::..String

[Missing <param name="message"/> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.ShowMessage(System.String,System.Windows.Point)"]

location
Type: System.Windows..::..Point

[Missing <param name="location"/> documentation for "M:ArtOfTest.WebAii.Win32.AnnotatorUI.ShowMessage(System.String,System.Windows.Point)"]

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


TransformToAncestor Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI..::..TransformToAncestor Method
AnnotatorUI Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

AnnotatorUI Class
AnnotatorUI Members
ArtOfTest.WebAii.Win32 Namespace


AnnotatorUI Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI Properties
AnnotatorUI Class See Also Send Feedback

The AnnotatorUI type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. This is a dependency property. (Inherited from Control.)
Public property | BindingGroup | (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. This is a dependency property. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. This is a dependency property. (Inherited from Control.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentStringFormat | (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. This is a dependency property. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. This is a dependency property. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. This is a dependency property. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. This is a dependency property. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. This is a dependency property. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. This is a dependency property. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. This is a dependency property. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. This is a dependency property. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. This is a dependency property. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. This is a dependency property. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. This is a dependency property. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. This is a dependency property. (Inherited from Control.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance and resource key lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. This is a dependency property. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that declares whether this instance is currently read-only. (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. This is a dependency property. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Location |
Protected property | LogicalChildren | Gets an enumerator to the content control's logical child elements. (Inherited from ContentControl.)
Public property | Margin | Gets or sets the outer margin of an element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. This is a dependency property. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | Size |
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. This is a dependency property. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. This is a dependency property. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. This is a dependency property. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. This is a dependency property. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Thumb |
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). This is a dependency property. (Inherited from FrameworkElement.)
Public property | Transform |
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from UIElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. This is a dependency property. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. This is a dependency property. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. This is a dependency property. (Inherited from FrameworkElement.)

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


AnnotatorUI Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AnnotatorUI Events
AnnotatorUI Class See Also Send Feedback

The AnnotatorUI type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

AnnotatorUI Class
ArtOfTest.WebAii.Win32 Namespace


Button Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Members
Button Class Constructors Methods Properties Events See Also Send Feedback

The Button type exposes the following members.

Constructors

 | Name | Description
Public method | Button(HWND, Int32) | Create a new button using its parent and its button id.
Public method | Button(Window, Int32) | Create a new button using the button id
Public method | Button(HWND, String, Boolean) | Create a new button using a parent window and the button caption. Can use partial caption.
Public method | Button(Window, String, Boolean) | Create a new button using a button text and parent window.

Methods

 | Name | Description
Public method | AttachWrappedWindow | Attach to the wrapper window handle. This call is needed to allow for events to fire on this window. (Inherited from Window.)
Public method | Center | Get the center point of this window (Inherited from Window.)
Public method | Click | Click this button
Public method | Close | Close the window. (Inherited from Window.)
Public method | ContainsControl | Returns true/false whether the Win32 control id is a child of this window (Inherited from Window.)
Public method | ContainsText | Returns true/false whether the text is present within this window. (Inherited from Window.)
Public method | DetachWrappedWindow | Detach from the window handle. (Inherited from Window.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitmap()()()() | (Inherited from Window.)
Public method | GetBitmap(RectangleF) | Returns a bitmap of a specified target area within this window. (Inherited from Window.)
Public method | GetBitmap(Size) | Capture the entire window bitmap and returns it. (Inherited from Window.)
Public method | GetHashCode | The hash code is the window's hwnd. (Inherited from Window.)
Public method | GetText | Get the text contained in this window and all its children windows. (Inherited from Window.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Hide the window. (Inherited from Window.)
Public method | MakeAbsolute | Return the absolute coordinate of the relative rectangle. (Inherited from Window.)
Public method | MakeRelative | Make the absolute rects passed in relative to this window. (Inherited from Window.)
Public method | Maximize | Maximize the window (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimize | Minimize the window. (Inherited from Window.)
Public method | Move | Move this window to a new location (Inherited from Window.)
Protected method | OnClick | For internal use only. (Inherited from Window.)
Protected method | OnDoubleClick | For internal use only. (Inherited from Window.)
Protected method | OnKeyDown | For internal use only. (Inherited from Window.)
Protected method | OnKeyPressed | For internal use only. (Inherited from Window.)
Protected method | OnKeyUp | For internal use only. (Inherited from Window.)
Protected method | OnMouseClick(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseClick(MouseButtons, Int32, Int32, Int32) | For internal use only. (Inherited from Window.)
Protected method | OnMouseDoubleClick | For internal use only. (Inherited from Window.)
Protected method | OnMouseDown(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseDown(MouseButtons, Int32, Int32) | For internal use only. (Inherited from Window.)
Protected method | OnMouseMove | For internal use only. (Inherited from Window.)
Protected method | OnMouseUp(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseUp(MouseButtons, Int32, Int32) | For internal use only. (Inherited from Window.)
Protected method | OnPreMouseClick | For internal use only. (Inherited from Window.)
Protected method | OnPreMouseDown | For internal use only. (Inherited from Window.)
Protected method | OnPreMouseUp | For internal use only. (Inherited from Window.)
Protected method | OnWindowMoved | For internal use only. (Inherited from Window.)
 | PostClickMessage |
Public method | RefreshChildren | Refresh the list of child windows (Window.Children) of this window (Inherited from Window.)
Public method | Restore | Restore the window to its default size/location (Inherited from Window.)
Public method | SetActive | Set this window to active. (Inherited from Window.)
Public method | SetFocus | Restores and Brings the window to the front, assuming it is a visible application window. (Inherited from Window.)
Public method | SetPosition | (Inherited from Window.)
Public method | Show | Show this window and make it visible (Inherited from Window.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Update the window. Invalidates all areas and forces a redraw. (Inherited from Window.)
Public method | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window (Inherited from Window.)
Public method | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window (Inherited from Window.)

Properties

 | Name | Description
Public property | AllChildren | Gets a collection of all child windows (at any level) of this window. (Inherited from Window.)
Public property | Caption | Gets the window's caption. (Inherited from Window.)
Public property | ClassName | Gets the window's class name. (Inherited from Window.)
Public property | Enabled | Gets whether this window is enabled or not. (Inherited from Window.)
Public property | Exists | Gets whether the window handle represents a live native window. (Inherited from Window.)
Public property | Handle | Gets the handle of the window. (Inherited from Window.)
Public property | IsDialog | Gets whether this Window is a dialog (Inherited from Window.)
Public property | IsForegroundWindow | Gets whether the window is currently in use by the user. (Inherited from Window.)
Public property | IsMaximized | Gets whether the window is maximized. (Inherited from Window.)
Public property | IsMinimized | Gets whether the window is minimized. (Inherited from Window.)
Public property | IsVisible | Gets whether the window is visible. (Inherited from Window.)
Public property | Location | Gets the top left point of the location of the window relative to the screen. (Inherited from Window.)
Public property | OwnerProcess | The owner process that created this window. (Inherited from Window.)
Public property | ParentWindow | Get parent window of this window. Returns null if there is no parent window. (Inherited from Window.)
Public property | Rectangle | Gets the rectangle of the window. (Inherited from Window.)
Public property | Size | Gets the size of the window. (Inherited from Window.)

Events

 | Name | Description
Public event | Click | For internal use only. (Inherited from Window.)
Public event | DoubleClick | For internal use only. (Inherited from Window.)
Public event | KeyDown | For internal use only. (Inherited from Window.)
Public event | KeyPressed | For internal use only. (Inherited from Window.)
Public event | KeyUp | For internal use only. (Inherited from Window.)
Public event | MouseClick | For internal use only. (Inherited from Window.)
Public event | MouseDoubleClick | For internal use only. (Inherited from Window.)
Public event | MouseDown | For internal use only. (Inherited from Window.)
Public event | MouseMove | For internal use only. (Inherited from Window.)
Public event | MouseUp | For internal use only. (Inherited from Window.)
Public event | PreMouseClick | For internal use only. (Inherited from Window.)
Public event | PreMouseDown | For internal use only. (Inherited from Window.)
Public event | PreMouseUp | For internal use only. (Inherited from Window.)
Public event | WindowMoved | For internal use only. (Inherited from Window.)

See Also

Button Class
ArtOfTest.WebAii.Win32 Namespace


Button Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Constructor
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Button(HWND, Int32) | Create a new button using its parent and its button id.
Public method | Button(Window, Int32) | Create a new button using the button id
Public method | Button(HWND, String, Boolean) | Create a new button using a parent window and the button caption. Can use partial caption.
Public method | Button(Window, String, Boolean) | Create a new button using a button text and parent window.

See Also

Button Class
Button Members
ArtOfTest.WebAii.Win32 Namespace


Button Constructor (HWND, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Constructor (HWND, Int32)
Button Class See Also Send Feedback
Create a new button using its parent and its button id.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Button(
    HWND parentWindow,
    int buttonId
)
Visual Basic
Public Sub New ( _
    parentWindow As HWND, _
    buttonId As Integer _
)
Visual C++
public:
Button(
    HWND parentWindow,
    int buttonId
)

Parameters

parentWindow
Type: ArtOfTest.Common.Win32..::..HWND
The parent window.
buttonId
Type: System..::..Int32
The button id.

See Also

Button Class
Button Overload
ArtOfTest.WebAii.Win32 Namespace


Button Constructor (Window, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Constructor (Window, Int32)
Button Class See Also Send Feedback
Create a new button using the button id

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Button(
    Window parentWindow,
    int buttonId
)
Visual Basic
Public Sub New ( _
    parentWindow As Window, _
    buttonId As Integer _
)
Visual C++
public:
Button(
    Window^ parentWindow,
    int buttonId
)

Parameters

parentWindow
Type: ArtOfTest.Common.Win32..::..Window
The parent window object.
buttonId
Type: System..::..Int32
The button id.

See Also

Button Class
Button Overload
ArtOfTest.WebAii.Win32 Namespace


Button Constructor (HWND, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Constructor (HWND, String, Boolean)
Button Class See Also Send Feedback
Create a new button using a parent window and the button caption. Can use partial caption.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Button(
    HWND parentWindow,
    string buttonCaption,
    bool isPartial
)
Visual Basic
Public Sub New ( _
    parentWindow As HWND, _
    buttonCaption As String, _
    isPartial As Boolean _
)
Visual C++
public:
Button(
    HWND parentWindow,
    String^ buttonCaption,
    bool isPartial
)

Parameters

parentWindow
Type: ArtOfTest.Common.Win32..::..HWND
The parent window that contains the button.
buttonCaption
Type: System..::..String
The button caption.
isPartial
Type: System..::..Boolean
True/False whether the caption is partial.

See Also

Button Class
Button Overload
ArtOfTest.WebAii.Win32 Namespace


Button Constructor (Window, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Constructor (Window, String, Boolean)
Button Class See Also Send Feedback
Create a new button using a button text and parent window.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Button(
    Window parentWindow,
    string buttonCaption,
    bool isPartial
)
Visual Basic
Public Sub New ( _
    parentWindow As Window, _
    buttonCaption As String, _
    isPartial As Boolean _
)
Visual C++
public:
Button(
    Window^ parentWindow,
    String^ buttonCaption,
    bool isPartial
)

Parameters

parentWindow
Type: ArtOfTest.Common.Win32..::..Window
The parent window object.
buttonCaption
Type: System..::..String
The button caption.
isPartial
Type: System..::..Boolean
True/False whether using a partial caption.

See Also

Button Class
Button Overload
ArtOfTest.WebAii.Win32 Namespace


Button Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Methods
Button Class See Also Send Feedback

The Button type exposes the following members.

Methods

 | Name | Description
Public method | AttachWrappedWindow | Attach to the wrapper window handle. This call is needed to allow for events to fire on this window. (Inherited from Window.)
Public method | Center | Get the center point of this window (Inherited from Window.)
Public method | Click | Click this button
Public method | Close | Close the window. (Inherited from Window.)
Public method | ContainsControl | Returns true/false whether the Win32 control id is a child of this window (Inherited from Window.)
Public method | ContainsText | Returns true/false whether the text is present within this window. (Inherited from Window.)
Public method | DetachWrappedWindow | Detach from the window handle. (Inherited from Window.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBitmap()()()() | (Inherited from Window.)
Public method | GetBitmap(RectangleF) | Returns a bitmap of a specified target area within this window. (Inherited from Window.)
Public method | GetBitmap(Size) | Capture the entire window bitmap and returns it. (Inherited from Window.)
Public method | GetHashCode | The hash code is the window's hwnd. (Inherited from Window.)
Public method | GetText | Get the text contained in this window and all its children windows. (Inherited from Window.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Hide the window. (Inherited from Window.)
Public method | MakeAbsolute | Return the absolute coordinate of the relative rectangle. (Inherited from Window.)
Public method | MakeRelative | Make the absolute rects passed in relative to this window. (Inherited from Window.)
Public method | Maximize | Maximize the window (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimize | Minimize the window. (Inherited from Window.)
Public method | Move | Move this window to a new location (Inherited from Window.)
Protected method | OnClick | For internal use only. (Inherited from Window.)
Protected method | OnDoubleClick | For internal use only. (Inherited from Window.)
Protected method | OnKeyDown | For internal use only. (Inherited from Window.)
Protected method | OnKeyPressed | For internal use only. (Inherited from Window.)
Protected method | OnKeyUp | For internal use only. (Inherited from Window.)
Protected method | OnMouseClick(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseClick(MouseButtons, Int32, Int32, Int32) | For internal use only. (Inherited from Window.)
Protected method | OnMouseDoubleClick | For internal use only. (Inherited from Window.)
Protected method | OnMouseDown(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseDown(MouseButtons, Int32, Int32) | For internal use only. (Inherited from Window.)
Protected method | OnMouseMove | For internal use only. (Inherited from Window.)
Protected method | OnMouseUp(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseUp(MouseButtons, Int32, Int32) | For internal use only. (Inherited from Window.)
Protected method | OnPreMouseClick | For internal use only. (Inherited from Window.)
Protected method | OnPreMouseDown | For internal use only. (Inherited from Window.)
Protected method | OnPreMouseUp | For internal use only. (Inherited from Window.)
Protected method | OnWindowMoved | For internal use only. (Inherited from Window.)
 | PostClickMessage |
Public method | RefreshChildren | Refresh the list of child windows (Window.Children) of this window (Inherited from Window.)
Public method | Restore | Restore the window to its default size/location (Inherited from Window.)
Public method | SetActive | Set this window to active. (Inherited from Window.)
Public method | SetFocus | Restores and Brings the window to the front, assuming it is a visible application window. (Inherited from Window.)
Public method | SetPosition | (Inherited from Window.)
Public method | Show | Show this window and make it visible (Inherited from Window.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Update | Update the window. Invalidates all areas and forces a redraw. (Inherited from Window.)
Public method | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window (Inherited from Window.)
Public method | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window (Inherited from Window.)

See Also

Button Class
ArtOfTest.WebAii.Win32 Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..Click Method
Button Class See Also Send Feedback
Click this button

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click()
Visual Basic
Public Sub Click
Visual C++
public:
void Click()

See Also

Button Class
ArtOfTest.WebAii.Win32 Namespace


GetBitmap Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..GetBitmap Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetBitmap()()()() | (Inherited from Window.)
Public method | GetBitmap(RectangleF) | Returns a bitmap of a specified target area within this window. (Inherited from Window.)
Public method | GetBitmap(Size) | Capture the entire window bitmap and returns it. (Inherited from Window.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Win32 Namespace


OnMouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..OnMouseClick Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | OnMouseClick(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseClick(MouseButtons, Int32, Int32, Int32) | For internal use only. (Inherited from Window.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Win32 Namespace


OnMouseDown Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..OnMouseDown Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | OnMouseDown(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseDown(MouseButtons, Int32, Int32) | For internal use only. (Inherited from Window.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Win32 Namespace


OnMouseUp Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..OnMouseUp Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | OnMouseUp(MouseEventArgs) | For internal use only. (Inherited from Window.)
Protected method | OnMouseUp(MouseButtons, Int32, Int32) | For internal use only. (Inherited from Window.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Win32 Namespace


PostClickMessage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..PostClickMessage Method
Button Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Button.PostClickMessage(ArtOfTest.Common.Win32.HWND)"]

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool PostClickMessage(
    HWND hButton
)
Visual Basic
Public Shared Function PostClickMessage ( _
    hButton As HWND _
) As Boolean
Visual C++
public:
static bool PostClickMessage(
    HWND hButton
)

Parameters

hButton
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Button.PostClickMessage(ArtOfTest.Common.Win32.HWND)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Button.PostClickMessage(ArtOfTest.Common.Win32.HWND)"]

See Also

Button Class
ArtOfTest.WebAii.Win32 Namespace


WaitForVisibility Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button..::..WaitForVisibility Method
Button Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForVisibility(Boolean, Int32) | Waits for a certain visibility state for a window (Inherited from Window.)
Public method | WaitForVisibility(Boolean, Int32, Boolean) | Waits for a certain visibility state for a window (Inherited from Window.)

See Also

Button Class
Button Members
ArtOfTest.WebAii.Win32 Namespace


Button Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Properties
Button Class See Also Send Feedback

The Button type exposes the following members.

Properties

 | Name | Description
Public property | AllChildren | Gets a collection of all child windows (at any level) of this window. (Inherited from Window.)
Public property | Caption | Gets the window's caption. (Inherited from Window.)
Public property | ClassName | Gets the window's class name. (Inherited from Window.)
Public property | Enabled | Gets whether this window is enabled or not. (Inherited from Window.)
Public property | Exists | Gets whether the window handle represents a live native window. (Inherited from Window.)
Public property | Handle | Gets the handle of the window. (Inherited from Window.)
Public property | IsDialog | Gets whether this Window is a dialog (Inherited from Window.)
Public property | IsForegroundWindow | Gets whether the window is currently in use by the user. (Inherited from Window.)
Public property | IsMaximized | Gets whether the window is maximized. (Inherited from Window.)
Public property | IsMinimized | Gets whether the window is minimized. (Inherited from Window.)
Public property | IsVisible | Gets whether the window is visible. (Inherited from Window.)
Public property | Location | Gets the top left point of the location of the window relative to the screen. (Inherited from Window.)
Public property | OwnerProcess | The owner process that created this window. (Inherited from Window.)
Public property | ParentWindow | Get parent window of this window. Returns null if there is no parent window. (Inherited from Window.)
Public property | Rectangle | Gets the rectangle of the window. (Inherited from Window.)
Public property | Size | Gets the size of the window. (Inherited from Window.)

See Also

Button Class
ArtOfTest.WebAii.Win32 Namespace


Button Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Button Events
Button Class See Also Send Feedback

The Button type exposes the following members.

Events

 | Name | Description
Public event | Click | For internal use only. (Inherited from Window.)
Public event | DoubleClick | For internal use only. (Inherited from Window.)
Public event | KeyDown | For internal use only. (Inherited from Window.)
Public event | KeyPressed | For internal use only. (Inherited from Window.)
Public event | KeyUp | For internal use only. (Inherited from Window.)
Public event | MouseClick | For internal use only. (Inherited from Window.)
Public event | MouseDoubleClick | For internal use only. (Inherited from Window.)
Public event | MouseDown | For internal use only. (Inherited from Window.)
Public event | MouseMove | For internal use only. (Inherited from Window.)
Public event | MouseUp | For internal use only. (Inherited from Window.)
Public event | PreMouseClick | For internal use only. (Inherited from Window.)
Public event | PreMouseDown | For internal use only. (Inherited from Window.)
Public event | PreMouseUp | For internal use only. (Inherited from Window.)
Public event | WindowMoved | For internal use only. (Inherited from Window.)

See Also

Button Class
ArtOfTest.WebAii.Win32 Namespace


KeyBoard Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard Members
KeyBoard Class Constructors Methods Properties See Also Send Feedback

The KeyBoard type exposes the following members.

Constructors

 | Name | Description
Public method | KeyBoard | Create a new keyboard object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeyDown | Simulates a key down. (Press-Hold)
Public method | KeyPress(Keys) | Simulates a keyboard key press (down/up).
Public method | KeyPress(Keys, Int32) | Simulates a keyboard key press with a hold delay
Public method | KeyPress(Keys, Int32, Int32) | Repeat a set of key presses x number of times
 | KeysFromString | Converts a key combination i.e CTRL+R or SHIFT+CTRL+R to a System.Windows.Keys value
Public method | KeyUp | Simulates a key up. (Key-Release)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendString | Obsolete. Sends an unmodified string to the active application using SendKeys
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TypeText(String, Int32) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.
Public method | TypeText(String, Int32, Int32) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.
Public method | TypeText(String, Int32, Int32, Boolean) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.

Properties

Name | Description
KeyDownDelay | The amount of time a key is held down for during simulated typing

See Also

KeyBoard Class
ArtOfTest.WebAii.Win32 Namespace


KeyBoard Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard Constructor
KeyBoard Class See Also Send Feedback
Create a new keyboard object.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public KeyBoard(
    Desktop desktop
)
Visual Basic
Public Sub New ( _
    desktop As Desktop _
)
Visual C++
public:
KeyBoard(
    Desktop^ desktop
)

Parameters

desktop
Type: ArtOfTest.WebAii.Core..::..Desktop

[Missing <param name="desktop"/> documentation for "M:ArtOfTest.WebAii.Win32.KeyBoard.#ctor(ArtOfTest.WebAii.Core.Desktop)"]

See Also

KeyBoard Class
ArtOfTest.WebAii.Win32 Namespace


KeyBoard Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard Methods
KeyBoard Class See Also Send Feedback

The KeyBoard type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | KeyDown | Simulates a key down. (Press-Hold)
Public method | KeyPress(Keys) | Simulates a keyboard key press (down/up).
Public method | KeyPress(Keys, Int32) | Simulates a keyboard key press with a hold delay
Public method | KeyPress(Keys, Int32, Int32) | Repeat a set of key presses x number of times
 | KeysFromString | Converts a key combination i.e CTRL+R or SHIFT+CTRL+R to a System.Windows.Keys value
Public method | KeyUp | Simulates a key up. (Key-Release)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SendString | Obsolete. Sends an unmodified string to the active application using SendKeys
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TypeText(String, Int32) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.
Public method | TypeText(String, Int32, Int32) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.
Public method | TypeText(String, Int32, Int32, Boolean) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.

See Also

KeyBoard Class
ArtOfTest.WebAii.Win32 Namespace


KeyDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..KeyDown Method
KeyBoard Class See Also Send Feedback
Simulates a key down. (Press-Hold)

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyDown(
    Keys key
)
Visual Basic
Public Sub KeyDown ( _
    key As Keys _
)
Visual C++
public:
void KeyDown(
    Keys key
)

Parameters

key
Type: System.Windows.Forms..::..Keys
The key code

See Also

KeyBoard Class
ArtOfTest.WebAii.Win32 Namespace


KeyPress Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..KeyPress Method
KeyBoard Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KeyPress(Keys) | Simulates a keyboard key press (down/up).
Public method | KeyPress(Keys, Int32) | Simulates a keyboard key press with a hold delay
Public method | KeyPress(Keys, Int32, Int32) | Repeat a set of key presses x number of times

See Also

KeyBoard Class
KeyBoard Members
ArtOfTest.WebAii.Win32 Namespace


KeyPress Method (Keys)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..KeyPress Method (Keys)
KeyBoard Class See Also Send Feedback
Simulates a keyboard key press (down/up).

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyPress(
    Keys code
)
Visual Basic
Public Sub KeyPress ( _
    code As Keys _
)
Visual C++
public:
void KeyPress(
    Keys code
)

Parameters

code
Type: System.Windows.Forms..::..Keys
The key code

See Also

KeyBoard Class
KeyPress Overload
ArtOfTest.WebAii.Win32 Namespace


KeyPress Method (Keys, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..KeyPress Method (Keys, Int32)
KeyBoard Class See Also Send Feedback
Simulates a keyboard key press with a hold delay

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyPress(
    Keys code,
    int holdFor
)
Visual Basic
Public Sub KeyPress ( _
    code As Keys, _
    holdFor As Integer _
)
Visual C++
public:
void KeyPress(
    Keys code,
    int holdFor
)

Parameters

code
Type: System.Windows.Forms..::..Keys
The key code for the key to press.
holdFor
Type: System..::..Int32
How long to hold the key down, in milliseconds.

See Also

KeyBoard Class
KeyPress Overload
ArtOfTest.WebAii.Win32 Namespace


KeyPress Method (Keys, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..KeyPress Method (Keys, Int32, Int32)
KeyBoard Class See Also Send Feedback
Repeat a set of key presses x number of times

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyPress(
    Keys code,
    int holdFor,
    int repeatCount
)
Visual Basic
Public Sub KeyPress ( _
    code As Keys, _
    holdFor As Integer, _
    repeatCount As Integer _
)
Visual C++
public:
void KeyPress(
    Keys code,
    int holdFor,
    int repeatCount
)

Parameters

code
Type: System.Windows.Forms..::..Keys
The key code
holdFor
Type: System..::..Int32
Hold it for (msec)
repeatCount
Type: System..::..Int32
The number of time to repeat it

See Also

KeyBoard Class
KeyPress Overload
ArtOfTest.WebAii.Win32 Namespace


KeysFromString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..KeysFromString Method
KeyBoard Class See Also Send Feedback
Converts a key combination i.e CTRL+R or SHIFT+CTRL+R to a System.Windows.Keys value

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Keys KeysFromString(
    string keyCombination
)
Visual Basic
Public Shared Function KeysFromString ( _
    keyCombination As String _
) As Keys
Visual C++
public:
static Keys KeysFromString(
    String^ keyCombination
)

Parameters

keyCombination
Type: System..::..String
The key combination to translate

Return Value

The Keys value or Keys.None if it can't convert it

See Also

KeyBoard Class
ArtOfTest.WebAii.Win32 Namespace


KeyUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..KeyUp Method
KeyBoard Class See Also Send Feedback
Simulates a key up. (Key-Release)

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void KeyUp(
    Keys key
)
Visual Basic
Public Sub KeyUp ( _
    key As Keys _
)
Visual C++
public:
void KeyUp(
    Keys key
)

Parameters

key
Type: System.Windows.Forms..::..Keys
The key code.

See Also

KeyBoard Class
ArtOfTest.WebAii.Win32 Namespace


SendString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..SendString Method
KeyBoard Class See Also Send Feedback
Sends an unmodified string to the active application using SendKeys

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("SendString has reliability issues. Please use TypeText instead, or KeyPress for special keys.")]
public void SendString(
    string strText
)
Visual Basic
<ObsoleteAttribute("SendString has reliability issues. Please use TypeText instead, or KeyPress for special keys.")> _
Public Sub SendString ( _
    strText As String _
)
Visual C++
[ObsoleteAttribute(L"SendString has reliability issues. Please use TypeText instead, or KeyPress for special keys.")]
public:
void SendString(
    String^ strText
)

Parameters

strText
Type: System..::..String

[Missing <param name="strText"/> documentation for "M:ArtOfTest.WebAii.Win32.KeyBoard.SendString(System.String)"]

Remarks

This method uses the System.Windows.Forms.SendKeys.SendWait() method which is not reliable in some cases. You can use the TypeText and KeyPress for a more reliable key typing simulation

See Also

KeyBoard Class
ArtOfTest.WebAii.Win32 Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..TypeText Method
KeyBoard Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String, Int32) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.
Public method | TypeText(String, Int32, Int32) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.
Public method | TypeText(String, Int32, Int32, Boolean) | Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.

See Also

KeyBoard Class
KeyBoard Members
ArtOfTest.WebAii.Win32 Namespace


TypeText Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..TypeText Method (String, Int32)
KeyBoard Class See Also Send Feedback
Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void TypeText(
    string text,
    int delayBetweenKeypresses
)
Visual Basic
Public Sub TypeText ( _
    text As String, _
    delayBetweenKeypresses As Integer _
)
Visual C++
public:
void TypeText(
    String^ text,
    int delayBetweenKeypresses
)

Parameters

text
Type: System..::..String
The text to type
delayBetweenKeypresses
Type: System..::..Int32

[Missing <param name="delayBetweenKeypresses"/> documentation for "M:ArtOfTest.WebAii.Win32.KeyBoard.TypeText(System.String,System.Int32)"]

See Also

KeyBoard Class
TypeText Overload
ArtOfTest.WebAii.Win32 Namespace


TypeText Method (String, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..TypeText Method (String, Int32, Int32)
KeyBoard Class See Also Send Feedback
Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void TypeText(
    string text,
    int delayBetweenKeypresses,
    int keyHoldTime
)
Visual Basic
Public Sub TypeText ( _
    text As String, _
    delayBetweenKeypresses As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
void TypeText(
    String^ text,
    int delayBetweenKeypresses,
    int keyHoldTime
)

Parameters

text
Type: System..::..String
The text to type
delayBetweenKeypresses
Type: System..::..Int32
The delay time between key presses.
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing a key

See Also

KeyBoard Class
TypeText Overload
ArtOfTest.WebAii.Win32 Namespace


TypeText Method (String, Int32, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard..::..TypeText Method (String, Int32, Int32, Boolean)
KeyBoard Class See Also Send Feedback
Types text one character at a time with a specific type speed. This function does not support special keywords (i.e {TAB}, {SPACE}) or special characters like ^,+..etc. to simulate special keys use KeyPress if you want to send special characters like Ctrl/Shift..etc.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void TypeText(
    string text,
    int delayBetweenKeypresses,
    int keyHoldTime,
    bool supportUnicode
)
Visual Basic
Public Sub TypeText ( _
    text As String, _
    delayBetweenKeypresses As Integer, _
    keyHoldTime As Integer, _
    supportUnicode As Boolean _
)
Visual C++
public:
void TypeText(
    String^ text,
    int delayBetweenKeypresses,
    int keyHoldTime,
    bool supportUnicode
)

Parameters

text
Type: System..::..String
The text to type
delayBetweenKeypresses
Type: System..::..Int32
The delay time between key presses.
keyHoldTime
Type: System..::..Int32
The delay between pressing and releasing a key
supportUnicode
Type: System..::..Boolean
Whether to support Unicode input in this call. By default, supportUnicode is true. See remarks regarding keyboard events and Unicode input.

Remarks

When Unicode support is enabled, KeyDown and KeyUp events are not fired by target controls. If KeyDown and KeyUp events are required, you must call TypeText with supportUnicode = false.

See Also

KeyBoard Class
TypeText Overload
ArtOfTest.WebAii.Win32 Namespace


KeyBoard Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KeyBoard Properties
KeyBoard Class See Also Send Feedback

The KeyBoard type exposes the following members.

Properties

Name | Description
KeyDownDelay | The amount of time a key is held down for during simulated typing

See Also

KeyBoard Class
ArtOfTest.WebAii.Win32 Namespace


Mouse Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse Members
Mouse Class Methods Properties See Also Send Feedback

The Mouse type exposes the following members.

Methods

 | Name | Description
 | CalculateOffset | Calculates the offset from the rectangles given a reference.
Public method | Click(MouseClickType, Point) | Simulate a mouse event (Target as a point object)
Public method | Click(MouseClickType, Rectangle) | Simulate a mouse event (Target a rectangle). Will click absolute center of target rectangle.
Public method | Click(MouseClickType, Int32, Int32) | Simulate a mouse event.
Public method | Click(MouseClickType, Rectangle, Point, OffsetReference) | Simulate a mouse event (Target as a rectangle with offset)
Public method | DetectHotSpot | Given a rectangle and optionally a cursor, this function will detect the cursor change
Public method | DragDrop(Point, Point) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Rectangle) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
Public method | DragDrop(Point, Point, Int32, Int32) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Rectangle, Int32, Int32) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
Public method | DragDrop(Int32, Int32, Int32, Int32) | Simulates a mouse drag and drop.
Public method | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Simulate a mouse drag and drop.
Public method | DragDrop(Int32, Int32, Int32, Int32, Int32, Int32) | Simulates a mouse drag and drop.
Public method | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCursorHandle | Get the current cursor handle
Protected method | GetDistance | Gets the number of mouse move intervals depending on the current set speed and interval time. Any negative coordinates will be reset to zero automatically.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRelativeNumOfMouseMoveIntervals(Int32) | Gets the number of mouse move intervals depending on the current set speed and interval time. DistanceInPixels(pixels) = NumOfIntervals(const) * IntervalTime(msec) * Speed(pixels/msec)
Protected method | GetRelativeNumOfMouseMoveIntervals(Point, Point) | Gets the number of mouse move intervals depending on the current set speed and interval time.
Protected method | GetRelativeNumOfMouseMoveIntervals(Rectangle, Rectangle) | Gets the number of mouse move intervals depending on the current set speed and interval time. Uses the absolute centers of passed in rectangles.
Protected method | GetRelativeNumOfMouseMoveIntervals(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Returns the relative number of mouse move intervals given a start/end locations.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HoverOver(Point) | HoverOver (Target a point).
Public method | HoverOver(Rectangle) | Hover over (Target the center of the target rectangle).
Public method | HoverOver(Int32, Int32) | Simulates a mouse hover over. Simply moves the mouse pointer over the X,Y passed in. Can also be used to move the mouse to a certain location.
Public method | HoverOver(Rectangle, Point, OffsetReference) | Hover over (Target is a rectangle with an offset).
Public method | MatchCursor | Tests whether or not the current mouse handle matches a specified handle. Can be used to check if the current mouse cursor is a particular value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move(Point, Point) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Rectangle) | Move the mouse from the start to the end location
Public method | Move(Point, Point, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Rectangle, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Move the mouse from the start to the end location
Public method | Move(Int32, Int32, Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TurnWheel | Move the mouse wheel by a certain delta
 | ValidateNonNegativePoint | Validate that the specified point coordinates is non-negative. If it is negative, it will be reset to zero.

Properties

 | Name | Description
Public property | MouseMoveIntervalTime | Gets/Sets the mouse interval time between mouse move intervals. The default is set at 15msec. Typically you don't need to change this. If you want to configure the speed of the mouse move, use the Settings.SimulatedMouseMoveSpeed.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


Mouse Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse Methods
Mouse Class See Also Send Feedback

The Mouse type exposes the following members.

Methods

 | Name | Description
 | CalculateOffset | Calculates the offset from the rectangles given a reference.
Public method | Click(MouseClickType, Point) | Simulate a mouse event (Target as a point object)
Public method | Click(MouseClickType, Rectangle) | Simulate a mouse event (Target a rectangle). Will click absolute center of target rectangle.
Public method | Click(MouseClickType, Int32, Int32) | Simulate a mouse event.
Public method | Click(MouseClickType, Rectangle, Point, OffsetReference) | Simulate a mouse event (Target as a rectangle with offset)
Public method | DetectHotSpot | Given a rectangle and optionally a cursor, this function will detect the cursor change
Public method | DragDrop(Point, Point) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Rectangle) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
Public method | DragDrop(Point, Point, Int32, Int32) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Rectangle, Int32, Int32) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
Public method | DragDrop(Int32, Int32, Int32, Int32) | Simulates a mouse drag and drop.
Public method | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Simulate a mouse drag and drop.
Public method | DragDrop(Int32, Int32, Int32, Int32, Int32, Int32) | Simulates a mouse drag and drop.
Public method | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCursorHandle | Get the current cursor handle
Protected method | GetDistance | Gets the number of mouse move intervals depending on the current set speed and interval time. Any negative coordinates will be reset to zero automatically.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRelativeNumOfMouseMoveIntervals(Int32) | Gets the number of mouse move intervals depending on the current set speed and interval time. DistanceInPixels(pixels) = NumOfIntervals(const) * IntervalTime(msec) * Speed(pixels/msec)
Protected method | GetRelativeNumOfMouseMoveIntervals(Point, Point) | Gets the number of mouse move intervals depending on the current set speed and interval time.
Protected method | GetRelativeNumOfMouseMoveIntervals(Rectangle, Rectangle) | Gets the number of mouse move intervals depending on the current set speed and interval time. Uses the absolute centers of passed in rectangles.
Protected method | GetRelativeNumOfMouseMoveIntervals(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Returns the relative number of mouse move intervals given a start/end locations.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HoverOver(Point) | HoverOver (Target a point).
Public method | HoverOver(Rectangle) | Hover over (Target the center of the target rectangle).
Public method | HoverOver(Int32, Int32) | Simulates a mouse hover over. Simply moves the mouse pointer over the X,Y passed in. Can also be used to move the mouse to a certain location.
Public method | HoverOver(Rectangle, Point, OffsetReference) | Hover over (Target is a rectangle with an offset).
Public method | MatchCursor | Tests whether or not the current mouse handle matches a specified handle. Can be used to check if the current mouse cursor is a particular value.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move(Point, Point) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Rectangle) | Move the mouse from the start to the end location
Public method | Move(Point, Point, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Rectangle, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Move the mouse from the start to the end location
Public method | Move(Int32, Int32, Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TurnWheel | Move the mouse wheel by a certain delta
 | ValidateNonNegativePoint | Validate that the specified point coordinates is non-negative. If it is negative, it will be reset to zero.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


CalculateOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..CalculateOffset Method
Mouse Class See Also Send Feedback
Calculates the offset from the rectangles given a reference.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static Point CalculateOffset(
    Rectangle rectangle,
    Point offset,
    OffsetReference reference
)
Visual Basic
Public Shared Function CalculateOffset ( _
    rectangle As Rectangle, _
    offset As Point, _
    reference As OffsetReference _
) As Point
Visual C++
public:
static Point CalculateOffset(
    Rectangle rectangle,
    Point offset,
    OffsetReference reference
)

Parameters

rectangle
Type: System.Drawing..::..Rectangle
The rectangle.
offset
Type: System.Drawing..::..Point
The offset.
reference
Type: ArtOfTest.Common..::..OffsetReference
The offset reference type.

Return Value

The adjusted point.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Click Method
Mouse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click(MouseClickType, Point) | Simulate a mouse event (Target as a point object)
Public method | Click(MouseClickType, Rectangle) | Simulate a mouse event (Target a rectangle). Will click absolute center of target rectangle.
Public method | Click(MouseClickType, Int32, Int32) | Simulate a mouse event.
Public method | Click(MouseClickType, Rectangle, Point, OffsetReference) | Simulate a mouse event (Target as a rectangle with offset)

See Also

Mouse Class
Mouse Members
ArtOfTest.WebAii.Win32 Namespace


Click Method (MouseClickType, Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Click Method (MouseClickType, Point)
Mouse Class See Also Send Feedback
Simulate a mouse event (Target as a point object)

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    Point pointToClick
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    pointToClick As Point _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    Point pointToClick
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The type of the click mouse to simulate.
pointToClick
Type: System.Drawing..::..Point
The point to click.

See Also

Mouse Class
Click Overload
ArtOfTest.WebAii.Win32 Namespace


Click Method (MouseClickType, Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Click Method (MouseClickType, Rectangle)
Mouse Class See Also Send Feedback
Simulate a mouse event (Target a rectangle). Will click absolute center of target rectangle.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    Rectangle target
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    target As Rectangle _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    Rectangle target
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The type of the click mouse to simulate.
target
Type: System.Drawing..::..Rectangle
The target rectangle to click the center for.

See Also

Mouse Class
Click Overload
ArtOfTest.WebAii.Win32 Namespace


Click Method (MouseClickType, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Click Method (MouseClickType, Int32, Int32)
Mouse Class See Also Send Feedback
Simulate a mouse event.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    int x,
    int y
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    int x,
    int y
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The type of the click mouse to simulate.
x
Type: System..::..Int32
Absolute X coordinate to click on.
y
Type: System..::..Int32
Absolute Y coordinate to click on.

See Also

Mouse Class
Click Overload
ArtOfTest.WebAii.Win32 Namespace


Click Method (MouseClickType, Rectangle, Point, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Click Method (MouseClickType, Rectangle, Point, OffsetReference)
Mouse Class See Also Send Feedback
Simulate a mouse event (Target as a rectangle with offset)

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Click(
    MouseClickType clickType,
    Rectangle target,
    Point offset,
    OffsetReference reference
)
Visual Basic
Public Sub Click ( _
    clickType As MouseClickType, _
    target As Rectangle, _
    offset As Point, _
    reference As OffsetReference _
)
Visual C++
public:
void Click(
    MouseClickType clickType,
    Rectangle target,
    Point offset,
    OffsetReference reference
)

Parameters

clickType
Type: ArtOfTest.WebAii.Core..::..MouseClickType
The type of the click mouse to simulate.
target
Type: System.Drawing..::..Rectangle
The target rectangle.
offset
Type: System.Drawing..::..Point
The offset in X/Y (negatives represents opposite direction).

Remarks

For offset: Positive X : Represents the right direction. Negative X : Represents the left direction. Positive Y : Represents the down direction. Negative Y : Represents the up direction. Keep these in mind when calculating the offset from a reference point.
reference
Type: ArtOfTest.Common..::..OffsetReference
The reference point to offset within the rectangle.

See Also

Mouse Class
Click Overload
ArtOfTest.WebAii.Win32 Namespace


DetectHotSpot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DetectHotSpot Method
Mouse Class See Also Send Feedback
Given a rectangle and optionally a cursor, this function will detect the cursor change

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Point DetectHotSpot(
    Rectangle rectangle,
    Cursor hotSpotCursor,
    int radius
)
Visual Basic
Public Function DetectHotSpot ( _
    rectangle As Rectangle, _
    hotSpotCursor As Cursor, _
    radius As Integer _
) As Point
Visual C++
public:
Point DetectHotSpot(
    Rectangle rectangle,
    Cursor^ hotSpotCursor,
    int radius
)

Parameters

rectangle
Type: System.Drawing..::..Rectangle
The rectangle to you to detect the host spot within.
hotSpotCursor
Type: System.Windows.Forms..::..Cursor
The cursor that the hot spot will be. If null, the function will assume a hot spot if the cursor simple changes.
radius
Type: System..::..Int32
The number of pixels from the center point to scan.

Return Value

The actual point the ended up activating the cursor change.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method
Mouse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragDrop(Point, Point) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Rectangle) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
Public method | DragDrop(Point, Point, Int32, Int32) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Rectangle, Int32, Int32) | Simulate a mouse drag and drop. (Uses center point of each rectangle)
Public method | DragDrop(Int32, Int32, Int32, Int32) | Simulates a mouse drag and drop.
Public method | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Simulate a mouse drag and drop.
Public method | DragDrop(Int32, Int32, Int32, Int32, Int32, Int32) | Simulates a mouse drag and drop.
Public method | DragDrop(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Simulate a mouse drag and drop.
Public method | DragDrop(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Simulate a mouse drag and drop.

See Also

Mouse Class
Mouse Members
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Point, Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Point, Point)
Mouse Class See Also Send Feedback
Simulate a mouse drag and drop.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    Point start,
    Point end
)
Visual Basic
Public Sub DragDrop ( _
    start As Point, _
    end As Point _
)
Visual C++
public:
void DragDrop(
    Point start,
    Point end
)

Parameters

start
Type: System.Drawing..::..Point
The start drag point.
end
Type: System.Drawing..::..Point
The end drop point.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Rectangle, Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Rectangle, Rectangle)
Mouse Class See Also Send Feedback
Simulate a mouse drag and drop. (Uses center point of each rectangle)

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    Rectangle start,
    Rectangle end
)
Visual Basic
Public Sub DragDrop ( _
    start As Rectangle, _
    end As Rectangle _
)
Visual C++
public:
void DragDrop(
    Rectangle start,
    Rectangle end
)

Parameters

start
Type: System.Drawing..::..Rectangle
Start target.
end
Type: System.Drawing..::..Rectangle
End target.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Point, Point, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Point, Point, Int32, Int32)
Mouse Class See Also Send Feedback
Simulate a mouse drag and drop.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    Point start,
    Point end,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub DragDrop ( _
    start As Point, _
    end As Point, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void DragDrop(
    Point start,
    Point end,
    int intervals,
    int intervalDelay
)

Parameters

start
Type: System.Drawing..::..Point
The start drag point.
end
Type: System.Drawing..::..Point
The end drop point.
intervals
Type: System..::..Int32
Number of intervals for this dragdrop operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Rectangle, Rectangle, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Rectangle, Rectangle, Int32, Int32)
Mouse Class See Also Send Feedback
Simulate a mouse drag and drop. (Uses center point of each rectangle)

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    Rectangle startTarget,
    Rectangle endTarget,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub DragDrop ( _
    startTarget As Rectangle, _
    endTarget As Rectangle, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void DragDrop(
    Rectangle startTarget,
    Rectangle endTarget,
    int intervals,
    int intervalDelay
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
Start target.
endTarget
Type: System.Drawing..::..Rectangle
End target.
intervals
Type: System..::..Int32
Number of intervals for this dragdrop operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Int32, Int32, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Int32, Int32, Int32, Int32)
Mouse Class See Also Send Feedback
Simulates a mouse drag and drop.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    int startX,
    int startY,
    int endX,
    int endY
)
Visual Basic
Public Sub DragDrop ( _
    startX As Integer, _
    startY As Integer, _
    endX As Integer, _
    endY As Integer _
)
Visual C++
public:
void DragDrop(
    int startX,
    int startY,
    int endX,
    int endY
)

Parameters

startX
Type: System..::..Int32
Absolute X coordinate to start the drag.
startY
Type: System..::..Int32
Absolute Y coordinate to start the drag.
endX
Type: System..::..Int32
Absolute X coordinate to do the drop.
endY
Type: System..::..Int32
Absolute Y coordinate to do the drop.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)
Mouse Class See Also Send Feedback
Simulate a mouse drag and drop.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)
Visual Basic
Public Sub DragDrop ( _
    startTarget As Rectangle, _
    startOffset As Point, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffset As Point, _
    endReference As OffsetReference _
)
Visual C++
public:
void DragDrop(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
The start rectangle.
startOffset
Type: System.Drawing..::..Point
The start offset.
startReference
Type: ArtOfTest.Common..::..OffsetReference
The start offset reference.
endTarget
Type: System.Drawing..::..Rectangle
The end rectangle.
endOffset
Type: System.Drawing..::..Point
The end offset.
endReference
Type: ArtOfTest.Common..::..OffsetReference
The end offset reference.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Int32, Int32, Int32, Int32, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Int32, Int32, Int32, Int32, Int32, Int32)
Mouse Class See Also Send Feedback
Simulates a mouse drag and drop.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    int startX,
    int startY,
    int endX,
    int endY,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub DragDrop ( _
    startX As Integer, _
    startY As Integer, _
    endX As Integer, _
    endY As Integer, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void DragDrop(
    int startX,
    int startY,
    int endX,
    int endY,
    int intervals,
    int intervalDelay
)

Parameters

startX
Type: System..::..Int32
Absolute X coordinate to start the drag.
startY
Type: System..::..Int32
Absolute Y coordinate to start the drag.
endX
Type: System..::..Int32
Absolute X coordinate to do the drop.
endY
Type: System..::..Int32
Absolute Y coordinate to do the drop.
intervals
Type: System..::..Int32
Number of intervals for this DragDrop operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32)
Mouse Class See Also Send Feedback
Simulate a mouse drag and drop.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub DragDrop ( _
    startTarget As Rectangle, _
    startOffset As Point, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffset As Point, _
    endReference As OffsetReference, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void DragDrop(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
The start rectangle.
startOffset
Type: System.Drawing..::..Point
The start offset.
startReference
Type: ArtOfTest.Common..::..OffsetReference
The start offset reference.
endTarget
Type: System.Drawing..::..Rectangle
The end rectangle.
endOffset
Type: System.Drawing..::..Point
The end offset.
endReference
Type: ArtOfTest.Common..::..OffsetReference
The end offset reference.
intervals
Type: System..::..Int32
Number of intervals for this dragdrop operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference)
Mouse Class See Also Send Feedback
Simulate a mouse drag and drop.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference
)
Visual Basic
Public Sub DragDrop ( _
    startTarget As Rectangle, _
    startOffsetX As Integer, _
    startOffsetY As Integer, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffsetX As Integer, _
    endOffsetY As Integer, _
    endReference As OffsetReference _
)
Visual C++
public:
void DragDrop(
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
The start rectangle.
startOffsetX
Type: System..::..Int32
The x start offset.
startOffsetY
Type: System..::..Int32
The y start offset.
startReference
Type: ArtOfTest.Common..::..OffsetReference
The start offset reference.
endTarget
Type: System.Drawing..::..Rectangle
The end rectangle.
endOffsetX
Type: System..::..Int32
The x end offset.
endOffsetY
Type: System..::..Int32
The y end offset.
endReference
Type: ArtOfTest.Common..::..OffsetReference
The end offset reference.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


DragDrop Method (Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..DragDrop Method (Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32)
Mouse Class See Also Send Feedback
Simulate a mouse drag and drop.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void DragDrop(
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub DragDrop ( _
    startTarget As Rectangle, _
    startOffsetX As Integer, _
    startOffsetY As Integer, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffsetX As Integer, _
    endOffsetY As Integer, _
    endReference As OffsetReference, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void DragDrop(
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
The start rectangle.
startOffsetX
Type: System..::..Int32
The x start offset.
startOffsetY
Type: System..::..Int32
The y start offset.
startReference
Type: ArtOfTest.Common..::..OffsetReference
The start offset reference.
endTarget
Type: System.Drawing..::..Rectangle
The end rectangle.
endOffsetX
Type: System..::..Int32
The x end offset.
endOffsetY
Type: System..::..Int32
The y end offset.
endReference
Type: ArtOfTest.Common..::..OffsetReference
The end offset reference.
intervals
Type: System..::..Int32
Number of intervals for this dragdrop operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
DragDrop Overload
ArtOfTest.WebAii.Win32 Namespace


GetCursorHandle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..GetCursorHandle Method
Mouse Class See Also Send Feedback
Get the current cursor handle

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IntPtr GetCursorHandle()
Visual Basic
Public Function GetCursorHandle As IntPtr
Visual C++
public:
IntPtr GetCursorHandle()

Return Value

The cursor handle.

Remarks

System.Windows.Forms.Cursor.Handle does not work. Seems like it is always cached.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


GetDistance Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..GetDistance Method
Mouse Class See Also Send Feedback
Gets the number of mouse move intervals depending on the current set speed and interval time. Any negative coordinates will be reset to zero automatically.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected float GetDistance(
    Point start,
    Point end
)
Visual Basic
Protected Function GetDistance ( _
    start As Point, _
    end As Point _
) As Single
Visual C++
protected:
float GetDistance(
    Point start,
    Point end
)

Parameters

start
Type: System.Drawing..::..Point
The start point.
end
Type: System.Drawing..::..Point
The end point.

Return Value

The distance.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


GetRelativeNumOfMouseMoveIntervals Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..GetRelativeNumOfMouseMoveIntervals Method
Mouse Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | GetRelativeNumOfMouseMoveIntervals(Int32) | Gets the number of mouse move intervals depending on the current set speed and interval time. DistanceInPixels(pixels) = NumOfIntervals(const) * IntervalTime(msec) * Speed(pixels/msec)
Protected method | GetRelativeNumOfMouseMoveIntervals(Point, Point) | Gets the number of mouse move intervals depending on the current set speed and interval time.
Protected method | GetRelativeNumOfMouseMoveIntervals(Rectangle, Rectangle) | Gets the number of mouse move intervals depending on the current set speed and interval time. Uses the absolute centers of passed in rectangles.
Protected method | GetRelativeNumOfMouseMoveIntervals(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Returns the relative number of mouse move intervals given a start/end locations.

See Also

Mouse Class
Mouse Members
ArtOfTest.WebAii.Win32 Namespace


GetRelativeNumOfMouseMoveIntervals Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..GetRelativeNumOfMouseMoveIntervals Method (Int32)
Mouse Class See Also Send Feedback
Gets the number of mouse move intervals depending on the current set speed and interval time. DistanceInPixels(pixels) = NumOfIntervals(const) * IntervalTime(msec) * Speed(pixels/msec)

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected int GetRelativeNumOfMouseMoveIntervals(
    int distanceInPixels
)
Visual Basic
Protected Function GetRelativeNumOfMouseMoveIntervals ( _
    distanceInPixels As Integer _
) As Integer
Visual C++
protected:
int GetRelativeNumOfMouseMoveIntervals(
    int distanceInPixels
)

Parameters

distanceInPixels
Type: System..::..Int32
The distance in pixels.

Return Value

The number of intervals.

See Also

Mouse Class
GetRelativeNumOfMouseMoveIntervals Overload
ArtOfTest.WebAii.Win32 Namespace


GetRelativeNumOfMouseMoveIntervals Method (Point, Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..GetRelativeNumOfMouseMoveIntervals Method (Point, Point)
Mouse Class See Also Send Feedback
Gets the number of mouse move intervals depending on the current set speed and interval time.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected int GetRelativeNumOfMouseMoveIntervals(
    Point start,
    Point end
)
Visual Basic
Protected Function GetRelativeNumOfMouseMoveIntervals ( _
    start As Point, _
    end As Point _
) As Integer
Visual C++
protected:
int GetRelativeNumOfMouseMoveIntervals(
    Point start,
    Point end
)

Parameters

start
Type: System.Drawing..::..Point
The start point.
end
Type: System.Drawing..::..Point
The end point.

Return Value

return the number of intervals

See Also

Mouse Class
GetRelativeNumOfMouseMoveIntervals Overload
ArtOfTest.WebAii.Win32 Namespace


GetRelativeNumOfMouseMoveIntervals Method (Rectangle, Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..GetRelativeNumOfMouseMoveIntervals Method (Rectangle, Rectangle)
Mouse Class See Also Send Feedback
Gets the number of mouse move intervals depending on the current set speed and interval time. Uses the absolute centers of passed in rectangles.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected int GetRelativeNumOfMouseMoveIntervals(
    Rectangle start,
    Rectangle end
)
Visual Basic
Protected Function GetRelativeNumOfMouseMoveIntervals ( _
    start As Rectangle, _
    end As Rectangle _
) As Integer
Visual C++
protected:
int GetRelativeNumOfMouseMoveIntervals(
    Rectangle start,
    Rectangle end
)

Parameters

start
Type: System.Drawing..::..Rectangle
The start location.
end
Type: System.Drawing..::..Rectangle
The end location.

Return Value

The number of intervals

See Also

Mouse Class
GetRelativeNumOfMouseMoveIntervals Overload
ArtOfTest.WebAii.Win32 Namespace


GetRelativeNumOfMouseMoveIntervals Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..GetRelativeNumOfMouseMoveIntervals Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)
Mouse Class See Also Send Feedback
Returns the relative number of mouse move intervals given a start/end locations.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected int GetRelativeNumOfMouseMoveIntervals(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)
Visual Basic
Protected Function GetRelativeNumOfMouseMoveIntervals ( _
    startTarget As Rectangle, _
    startOffset As Point, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffset As Point, _
    endReference As OffsetReference _
) As Integer
Visual C++
protected:
int GetRelativeNumOfMouseMoveIntervals(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
Start rectangle.
startOffset
Type: System.Drawing..::..Point
Start offset.
startReference
Type: ArtOfTest.Common..::..OffsetReference
Start offset reference.
endTarget
Type: System.Drawing..::..Rectangle
End rectangle.
endOffset
Type: System.Drawing..::..Point
End offset.
endReference
Type: ArtOfTest.Common..::..OffsetReference
End offset reference.

Return Value

The number of intervals

See Also

Mouse Class
GetRelativeNumOfMouseMoveIntervals Overload
ArtOfTest.WebAii.Win32 Namespace


HoverOver Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..HoverOver Method
Mouse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HoverOver(Point) | HoverOver (Target a point).
Public method | HoverOver(Rectangle) | Hover over (Target the center of the target rectangle).
Public method | HoverOver(Int32, Int32) | Simulates a mouse hover over. Simply moves the mouse pointer over the X,Y passed in. Can also be used to move the mouse to a certain location.
Public method | HoverOver(Rectangle, Point, OffsetReference) | Hover over (Target is a rectangle with an offset).

See Also

Mouse Class
Mouse Members
ArtOfTest.WebAii.Win32 Namespace


HoverOver Method (Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..HoverOver Method (Point)
Mouse Class See Also Send Feedback
HoverOver (Target a point).

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void HoverOver(
    Point pointToHoverOver
)
Visual Basic
Public Sub HoverOver ( _
    pointToHoverOver As Point _
)
Visual C++
public:
void HoverOver(
    Point pointToHoverOver
)

Parameters

pointToHoverOver
Type: System.Drawing..::..Point
Point to hover over.

See Also

Mouse Class
HoverOver Overload
ArtOfTest.WebAii.Win32 Namespace


HoverOver Method (Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..HoverOver Method (Rectangle)
Mouse Class See Also Send Feedback
Hover over (Target the center of the target rectangle).

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void HoverOver(
    Rectangle target
)
Visual Basic
Public Sub HoverOver ( _
    target As Rectangle _
)
Visual C++
public:
void HoverOver(
    Rectangle target
)

Parameters

target
Type: System.Drawing..::..Rectangle
The target rectangle.

See Also

Mouse Class
HoverOver Overload
ArtOfTest.WebAii.Win32 Namespace


HoverOver Method (Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..HoverOver Method (Int32, Int32)
Mouse Class See Also Send Feedback
Simulates a mouse hover over. Simply moves the mouse pointer over the X,Y passed in. Can also be used to move the mouse to a certain location.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void HoverOver(
    int x,
    int y
)
Visual Basic
Public Sub HoverOver ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
void HoverOver(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32
Absolute X coordinate to click.
y
Type: System..::..Int32
Absolute Y coordinate to click.

See Also

Mouse Class
HoverOver Overload
ArtOfTest.WebAii.Win32 Namespace


HoverOver Method (Rectangle, Point, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..HoverOver Method (Rectangle, Point, OffsetReference)
Mouse Class See Also Send Feedback
Hover over (Target is a rectangle with an offset).

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void HoverOver(
    Rectangle target,
    Point offset,
    OffsetReference reference
)
Visual Basic
Public Sub HoverOver ( _
    target As Rectangle, _
    offset As Point, _
    reference As OffsetReference _
)
Visual C++
public:
void HoverOver(
    Rectangle target,
    Point offset,
    OffsetReference reference
)

Parameters

target
Type: System.Drawing..::..Rectangle
The target rectangle.
offset
Type: System.Drawing..::..Point
The offset in X/Y (negatives represents opposite direction).
reference
Type: ArtOfTest.Common..::..OffsetReference
The reference point to offset within the rectangle.

See Also

Mouse Class
HoverOver Overload
ArtOfTest.WebAii.Win32 Namespace


MatchCursor Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..MatchCursor Method
Mouse Class See Also Send Feedback
Tests whether or not the current mouse handle matches a specified handle. Can be used to check if the current mouse cursor is a particular value.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool MatchCursor(
    IntPtr handle
)
Visual Basic
Public Function MatchCursor ( _
    handle As IntPtr _
) As Boolean
Visual C++
public:
bool MatchCursor(
    IntPtr handle
)

Parameters

handle
Type: System..::..IntPtr
The mouse handle to compare.

Return Value

True/False indicating whether or not the current mouse cursor handle matches.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


Move Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method
Mouse Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Move(Point, Point) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Rectangle) | Move the mouse from the start to the end location
Public method | Move(Point, Point, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Rectangle, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference) | Move the mouse from the start to the end location
Public method | Move(Int32, Int32, Int32, Int32, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference) | Move the mouse from the start to the end location
Public method | Move(Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32) | Move the mouse from the start to the end location

See Also

Mouse Class
Mouse Members
ArtOfTest.WebAii.Win32 Namespace


Move Method (Point, Point)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Point, Point)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Point start,
    Point end
)
Visual Basic
Public Sub Move ( _
    start As Point, _
    end As Point _
)
Visual C++
public:
void Move(
    Point start,
    Point end
)

Parameters

start
Type: System.Drawing..::..Point
start point of the move.
end
Type: System.Drawing..::..Point
end point of the move

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Rectangle, Rectangle)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Rectangle, Rectangle)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Rectangle start,
    Rectangle end
)
Visual Basic
Public Sub Move ( _
    start As Rectangle, _
    end As Rectangle _
)
Visual C++
public:
void Move(
    Rectangle start,
    Rectangle end
)

Parameters

start
Type: System.Drawing..::..Rectangle
Move start point.
end
Type: System.Drawing..::..Rectangle
Move end point.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Point, Point, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Point, Point, Int32, Int32)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Point start,
    Point end,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub Move ( _
    start As Point, _
    end As Point, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void Move(
    Point start,
    Point end,
    int intervals,
    int intervalDelay
)

Parameters

start
Type: System.Drawing..::..Point
start point of the move.
end
Type: System.Drawing..::..Point
end point of the move
intervals
Type: System..::..Int32
Number of intervals for this Move operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Rectangle, Rectangle, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Rectangle, Rectangle, Int32, Int32)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Rectangle start,
    Rectangle end,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub Move ( _
    start As Rectangle, _
    end As Rectangle, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void Move(
    Rectangle start,
    Rectangle end,
    int intervals,
    int intervalDelay
)

Parameters

start
Type: System.Drawing..::..Rectangle
Move start point.
end
Type: System.Drawing..::..Rectangle
Move end point.
intervals
Type: System..::..Int32
Number of intervals for this Move operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Int32, Int32, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Int32, Int32, Int32, Int32)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    int startX,
    int startY,
    int endX,
    int endY
)
Visual Basic
Public Sub Move ( _
    startX As Integer, _
    startY As Integer, _
    endX As Integer, _
    endY As Integer _
)
Visual C++
public:
void Move(
    int startX,
    int startY,
    int endX,
    int endY
)

Parameters

startX
Type: System..::..Int32
Move start X position.
startY
Type: System..::..Int32
Move start Y position.
endX
Type: System..::..Int32
Move end X position.
endY
Type: System..::..Int32
Move end Y position.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)
Visual Basic
Public Sub Move ( _
    startTarget As Rectangle, _
    startOffset As Point, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffset As Point, _
    endReference As OffsetReference _
)
Visual C++
public:
void Move(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
Move start rectangle.
startOffset
Type: System.Drawing..::..Point
Move start offset.
startReference
Type: ArtOfTest.Common..::..OffsetReference
Move start offsetReference
endTarget
Type: System.Drawing..::..Rectangle
Move end rectangle.
endOffset
Type: System.Drawing..::..Point
Move end offset.
endReference
Type: ArtOfTest.Common..::..OffsetReference
Move end offsetReference.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Int32, Int32, Int32, Int32, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Int32, Int32, Int32, Int32, Int32, Int32)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    int startX,
    int startY,
    int endX,
    int endY,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub Move ( _
    startX As Integer, _
    startY As Integer, _
    endX As Integer, _
    endY As Integer, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void Move(
    int startX,
    int startY,
    int endX,
    int endY,
    int intervals,
    int intervalDelay
)

Parameters

startX
Type: System..::..Int32
Move start X position.
startY
Type: System..::..Int32
Move start Y position.
endX
Type: System..::..Int32
Move end X position.
endY
Type: System..::..Int32
Move end Y position.
intervals
Type: System..::..Int32
Number of intervals for this Move operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Rectangle, Point, OffsetReference, Rectangle, Point, OffsetReference, Int32, Int32)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub Move ( _
    startTarget As Rectangle, _
    startOffset As Point, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffset As Point, _
    endReference As OffsetReference, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void Move(
    Rectangle startTarget,
    Point startOffset,
    OffsetReference startReference,
    Rectangle endTarget,
    Point endOffset,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
Move start rectangle.
startOffset
Type: System.Drawing..::..Point
Move start offset.
startReference
Type: ArtOfTest.Common..::..OffsetReference
Move start offsetReference
endTarget
Type: System.Drawing..::..Rectangle
Move end rectangle.
endOffset
Type: System.Drawing..::..Point
Move end offset.
endReference
Type: ArtOfTest.Common..::..OffsetReference
Move end offsetReference.
intervals
Type: System..::..Int32
Number of intervals for this Move operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference
)
Visual Basic
Public Sub Move ( _
    startTarget As Rectangle, _
    startOffsetX As Integer, _
    startOffsetY As Integer, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffsetX As Integer, _
    endOffsetY As Integer, _
    endReference As OffsetReference _
)
Visual C++
public:
void Move(
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
Move start rectangle.
startOffsetX
Type: System..::..Int32
Move start offset x.
startOffsetY
Type: System..::..Int32
Move start offset y.
startReference
Type: ArtOfTest.Common..::..OffsetReference
Move start offsetReference
endTarget
Type: System.Drawing..::..Rectangle
Move end rectangle.
endOffsetX
Type: System..::..Int32
Move end offset x.
endOffsetY
Type: System..::..Int32
Move end offset y.
endReference
Type: ArtOfTest.Common..::..OffsetReference
Move end offsetReference.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


Move Method (Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..Move Method (Rectangle, Int32, Int32, OffsetReference, Rectangle, Int32, Int32, OffsetReference, Int32, Int32)
Mouse Class See Also Send Feedback
Move the mouse from the start to the end location

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Move(
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)
Visual Basic
Public Sub Move ( _
    startTarget As Rectangle, _
    startOffsetX As Integer, _
    startOffsetY As Integer, _
    startReference As OffsetReference, _
    endTarget As Rectangle, _
    endOffsetX As Integer, _
    endOffsetY As Integer, _
    endReference As OffsetReference, _
    intervals As Integer, _
    intervalDelay As Integer _
)
Visual C++
public:
void Move(
    Rectangle startTarget,
    int startOffsetX,
    int startOffsetY,
    OffsetReference startReference,
    Rectangle endTarget,
    int endOffsetX,
    int endOffsetY,
    OffsetReference endReference,
    int intervals,
    int intervalDelay
)

Parameters

startTarget
Type: System.Drawing..::..Rectangle
Move start rectangle.
startOffsetX
Type: System..::..Int32
Move start offset x.
startOffsetY
Type: System..::..Int32
Move start offset y.
startReference
Type: ArtOfTest.Common..::..OffsetReference
Move start offsetReference
endTarget
Type: System.Drawing..::..Rectangle
Move end rectangle.
endOffsetX
Type: System..::..Int32
Move end offset x.
endOffsetY
Type: System..::..Int32
Move end offset y.
endReference
Type: ArtOfTest.Common..::..OffsetReference
Move end offsetReference.
intervals
Type: System..::..Int32
Number of intervals for this Move operation.
intervalDelay
Type: System..::..Int32
The delay in msec. between each interval.

See Also

Mouse Class
Move Overload
ArtOfTest.WebAii.Win32 Namespace


TurnWheel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..TurnWheel Method
Mouse Class See Also Send Feedback
Move the mouse wheel by a certain delta

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void TurnWheel(
    int delta,
    MouseWheelTurnDirection direction
)
Visual Basic
Public Sub TurnWheel ( _
    delta As Integer, _
    direction As MouseWheelTurnDirection _
)
Visual C++
public:
void TurnWheel(
    int delta,
    MouseWheelTurnDirection direction
)

Parameters

delta
Type: System..::..Int32
The delta to use.
direction
Type: ArtOfTest.WebAii.Core..::..MouseWheelTurnDirection
The direction to turn the mouse wheel in.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


ValidateNonNegativePoint Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse..::..ValidateNonNegativePoint Method
Mouse Class See Also Send Feedback
Validate that the specified point coordinates is non-negative. If it is negative, it will be reset to zero.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void ValidateNonNegativePoint(
    ref Point point
)
Visual Basic
Public Shared Sub ValidateNonNegativePoint ( _
    ByRef point As Point _
)
Visual C++
public:
static void ValidateNonNegativePoint(
    Point% point
)

Parameters

point
Type: System.Drawing..::..Point %
The point to validate.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


Mouse Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Mouse Properties
Mouse Class See Also Send Feedback

The Mouse type exposes the following members.

Properties

 | Name | Description
Public property | MouseMoveIntervalTime | Gets/Sets the mouse interval time between mouse move intervals. The default is set at 15msec. Typically you don't need to change this. If you want to configure the speed of the mouse move, use the Settings.SimulatedMouseMoveSpeed.

See Also

Mouse Class
ArtOfTest.WebAii.Win32 Namespace


OSInformation Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OSInformation Members
OSInformation Class Properties See Also Send Feedback

The OSInformation type exposes the following members.

Properties

Name | Description
Bits | Determines if the current application is 32 or 64-bit.
BuildVersion | Gets the build version number of the operating system running on this computer.
Edition | Gets the edition of the operating system running on this computer.
MajorVersion | Gets the major version number of the operating system running on this computer.
MinorVersion | Gets the minor version number of the operating system running on this computer.
Name | Gets the name of the operating system running on this computer.
RevisionVersion | Gets the revision version number of the operating system running on this computer.
ServicePack | Gets the service pack information of the operating system running on this computer.
Version | Gets the full version of the operating system running on this computer.
VersionString | Gets the full version string of the operating system running on this computer.

See Also

OSInformation Class
ArtOfTest.WebAii.Win32 Namespace


OSInformation Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OSInformation Properties
OSInformation Class See Also Send Feedback

The OSInformation type exposes the following members.

Properties

Name | Description
Bits | Determines if the current application is 32 or 64-bit.
BuildVersion | Gets the build version number of the operating system running on this computer.
Edition | Gets the edition of the operating system running on this computer.
MajorVersion | Gets the major version number of the operating system running on this computer.
MinorVersion | Gets the minor version number of the operating system running on this computer.
Name | Gets the name of the operating system running on this computer.
RevisionVersion | Gets the revision version number of the operating system running on this computer.
ServicePack | Gets the service pack information of the operating system running on this computer.
Version | Gets the full version of the operating system running on this computer.
VersionString | Gets the full version string of the operating system running on this computer.

See Also

OSInformation Class
ArtOfTest.WebAii.Win32 Namespace


VisualMouseProxy Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy Members
VisualMouseProxy Class Constructors Methods Properties Events See Also Send Feedback

The VisualMouseProxy type exposes the following members.

Constructors

 | Name | Description
Public method | VisualMouseProxy | Initializes a new instance of the VisualMouseProxy class

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() |
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | FreezeModeHostX |
Public property | FreezeModeHostY |
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

VisualMouseProxy Class
ArtOfTest.WebAii.Win32 Namespace


VisualMouseProxy Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy Constructor
VisualMouseProxy Class See Also Send Feedback
Initializes a new instance of the VisualMouseProxy class

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public VisualMouseProxy()
Visual Basic
Public Sub New
Visual C++
public:
VisualMouseProxy()

See Also

VisualMouseProxy Class
ArtOfTest.WebAii.Win32 Namespace


VisualMouseProxy Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy Methods
VisualMouseProxy Class See Also Send Feedback

The VisualMouseProxy type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide |
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() |
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

See Also

VisualMouseProxy Class
ArtOfTest.WebAii.Win32 Namespace


AccessibilityNotifyClients Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..AccessibilityNotifyClients Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


BeginInvoke Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..BeginInvoke Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Dispose Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Dispose Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::..Dispose(Boolean).)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Dispose Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Dispose Method (Boolean)
VisualMouseProxy Class See Also Send Feedback
Clean up any resources being used.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
true if managed resources should be disposed; otherwise, false.

See Also

VisualMouseProxy Class
Dispose Overload
ArtOfTest.WebAii.Win32 Namespace


GetChildAtPoint Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..GetChildAtPoint Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Hide Method
VisualMouseProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.VisualMouseProxy.Hide"]

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

VisualMouseProxy Class
ArtOfTest.WebAii.Win32 Namespace


Invalidate Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Invalidate Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Invoke Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Invoke Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


MemberwiseClone Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..MemberwiseClone Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


PerformLayout Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..PerformLayout Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


ResumeLayout Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..ResumeLayout Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


RtlTranslateAlignment Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..RtlTranslateAlignment Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Scale Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Scale Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Select Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Select Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Select()()()() | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


SetBounds Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..SetBounds Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Show Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Show Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Show()()()() |
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Show Method
VisualMouseProxy Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.VisualMouseProxy.Show"]

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

VisualMouseProxy Class
Show Overload
ArtOfTest.WebAii.Win32 Namespace


ShowDialog Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..ShowDialog Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowDialog()()()() | Shows the form as a modal dialog box with the currently active window set as its owner. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


UpdateBounds Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..UpdateBounds Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


Validate Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..Validate Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


ValidateChildren Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy..::..ValidateChildren Method
VisualMouseProxy Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

VisualMouseProxy Class
VisualMouseProxy Members
ArtOfTest.WebAii.Win32 Namespace


VisualMouseProxy Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy Properties
VisualMouseProxy Class See Also Send Feedback

The VisualMouseProxy type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | FreezeModeHostX |
Public property | FreezeModeHostY |
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its parent controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets the form's window state. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)

See Also

VisualMouseProxy Class
ArtOfTest.WebAii.Win32 Namespace


VisualMouseProxy Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualMouseProxy Events
VisualMouseProxy Class See Also Send Feedback

The VisualMouseProxy type exposes the following members.

Events

 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses or gains mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)

See Also

VisualMouseProxy Class
ArtOfTest.WebAii.Win32 Namespace


Win32Error Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Win32Error Members
Win32Error Class Methods Properties See Also Send Feedback

The Win32Error type exposes the following members.

Methods

Name | Description
SetLastWin32Error | Set the formatted Win32Error string.

Properties

Name | Description
LastErrorString | Gets/Sets last error string

See Also

Win32Error Class
ArtOfTest.WebAii.Win32 Namespace


Win32Error Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Win32Error Methods
Win32Error Class See Also Send Feedback

The Win32Error type exposes the following members.

Methods

Name | Description
SetLastWin32Error | Set the formatted Win32Error string.

See Also

Win32Error Class
ArtOfTest.WebAii.Win32 Namespace


SetLastWin32Error Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Win32Error..::..SetLastWin32Error Method
Win32Error Class See Also Send Feedback
Set the formatted Win32Error string.

Namespace: ArtOfTest.WebAii.Win32
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void SetLastWin32Error()
Visual Basic
Public Shared Sub SetLastWin32Error
Visual C++
public:
static void SetLastWin32Error()

See Also

Win32Error Class
ArtOfTest.WebAii.Win32 Namespace


Win32Error Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Win32Error Properties
Win32Error Class See Also Send Feedback

The Win32Error type exposes the following members.

Properties

Name | Description
LastErrorString | Gets/Sets last error string

See Also

Win32Error Class
ArtOfTest.WebAii.Win32 Namespace


ArtOfTest.WebAii.Win32.Dialogs Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Win32.Dialogs Namespace
Send Feedback
Namespace for all of the WebAii native Win32 dialog handlers.

Classes

 | Class | Description
Public class | AlertDialog | Class to handle javascript alert dialogs.
Public class | BaseDialog | A base implementation for a dialog.
Public class | ChromePromptDialog |
Public class | ConfirmDialog | Class to handle javascript confirm dialogs.
Public class | DialogBatch | A group of dialogs to be monitored together.
Public class | DialogMonitor | Class implementation for a dialog monitor to handle dialogs during execution.
Public class | DownloadDialogsHandler | The download dialogs handler. Wraps all the download dialog sequences for IE/Firefox into a simple API call.
Public class | FFOpenDownloadDialog | Firefox OpenDialog.
Public class | FileUploadDialog | Class to handle the FileUpload dialog.
Public class | FireFoxPromptDialog |
Public class | GenericDialog | A generic dialog handler that can be used for quick and easy way to write a dialog handler for a simply dialog.
Public class | IE9DownloadCompleteNotificationBar |
Public class | IE9DownloadNotificationBar |
Public class | IE9NotificationBar |
Public class | IEDownloadCompleteDialog | The IE download complete dialog.
Public class | IEDownloadDialog | IE's initial download dialog.
Public class | IEPromptDialog |
Public class | IEStrings |
Public class | LogonDialog | Class to handle the logon dialog (username/password)
Public class | OnBeforeUnloadDialog | Class to handle javascript onbeforeunload Confirm Navigation dialogs.
Public class | OpenFileDialog |
Public class | PrompDialogFactory | Prompt dialog factory.
Public class | SafariDownloadDialog | Handles all the unique file download dialogs that appear under the Safari browser.
Public class | SafariPromptDialog |
Public class | SaveAsDialog | SaveAs Dialog handler.

Interfaces

 | Interface | Description
Public interface | IDialog | Interface to implement for dialogs to be monitored and handled by the DialogMonitor object.

Delegates

 | Delegate | Description
Public delegate | DialogHandlerDelegate | A dialog handler that allows for users to do their own handling of a dialog instead of calling Handle().

Enumerations

 | Enumeration | Description
Public enumeration | DialogButton | Possible buttons for to click for a dialog
Public enumeration | DialogCurrentState | Different states the dialog can be set to.


AlertDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog Members
AlertDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The AlertDialog type exposes the following members.

Constructors

 | Name | Description
Public method | AlertDialog(Browser, DialogButton) | Obsolete. Create a new AlertDialog object to handle the dialog.
Protected method | AlertDialog(Browser, DialogButton, Boolean) | Create a new AlertDialog object to handle the dialog.

Methods

 | Name | Description
 | CreateAlertDialog |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether the dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

AlertDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


AlertDialog Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog Constructor
AlertDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AlertDialog(Browser, DialogButton) | Obsolete. Create a new AlertDialog object to handle the dialog.
Protected method | AlertDialog(Browser, DialogButton, Boolean) | Create a new AlertDialog object to handle the dialog.

See Also

AlertDialog Class
AlertDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


AlertDialog Constructor (Browser, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog Constructor (Browser, DialogButton)
AlertDialog Class See Also Send Feedback
Create a new AlertDialog object to handle the dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("AlertDialog constructor is deprecated.  Use AlertDialog.CreateAlertDialog method instead.")]
public AlertDialog(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
<ObsoleteAttribute("AlertDialog constructor is deprecated.  Use AlertDialog.CreateAlertDialog method instead.")> _
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
)
Visual C++
[ObsoleteAttribute(L"AlertDialog constructor is deprecated.  Use AlertDialog.CreateAlertDialog method instead.")]
public:
AlertDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The dismiss button to use.

See Also

AlertDialog Class
AlertDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


AlertDialog Constructor (Browser, DialogButton, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog Constructor (Browser, DialogButton, Boolean)
AlertDialog Class See Also Send Feedback
Create a new AlertDialog object to handle the dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected AlertDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    bool skipObsoleteMessage
)
Visual Basic
Protected Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    skipObsoleteMessage As Boolean _
)
Visual C++
protected:
AlertDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    bool skipObsoleteMessage
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
This dismiss button to use.
skipObsoleteMessage
Type: System..::..Boolean
Not used, but keeps this internal constructor from producing "obsolete" compile warnings

See Also

AlertDialog Class
AlertDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


AlertDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog Fields
AlertDialog Class See Also Send Feedback

The AlertDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

AlertDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


AlertDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog Methods
AlertDialog Class See Also Send Feedback

The AlertDialog type exposes the following members.

Methods

 | Name | Description
 | CreateAlertDialog |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether the dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

AlertDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateAlertDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog..::..CreateAlertDialog Method
AlertDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.AlertDialog.CreateAlertDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AlertDialog CreateAlertDialog(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
Public Shared Function CreateAlertDialog ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
) As AlertDialog
Visual C++
public:
static AlertDialog^ CreateAlertDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.AlertDialog.CreateAlertDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.AlertDialog.CreateAlertDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.AlertDialog.CreateAlertDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

See Also

AlertDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog..::..Handle Method
AlertDialog Class See Also Send Feedback
Handle this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Return Value

True/False whether this dialog was handled.

Implements

IDialog..::..Handle()()()()

See Also

AlertDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog..::..IsDialogActive Method
AlertDialog Class See Also Send Feedback
Whether the dialog is active or not.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs on the desktop.

Return Value

True/False whether the dialog is active or not.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

AlertDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog..::..IsDialogActiveByTitle Method
AlertDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

AlertDialog Class
AlertDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog..::..WaitUntilHandled Method
AlertDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

AlertDialog Class
AlertDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


AlertDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog Properties
AlertDialog Class See Also Send Feedback

The AlertDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

AlertDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


AlertDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AlertDialog Events
AlertDialog Class See Also Send Feedback

The AlertDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

AlertDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


BaseDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog Members
BaseDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The BaseDialog type exposes the following members.

Constructors

 | Name | Description
Public method | BaseDialog(Browser, DialogButton) | Create a new dialog.
Public method | BaseDialog(WpfApplication, DialogButton) | Initializes a new instance of the BaseDialog class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle the dialog. If HandlerDelegate is set, use the delegate
Public method | IsDialogActive | Detect whether this dialog is active or not. Mostly used for HWND-based controls, such as top-level windows.
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title.
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title.
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog
 | IsMatchingWindowsVistaTaskDialog | Gets whether the provided window is a dialog created by TaskDialog() or TaskDialogIndirect(), according to the given criteria.
 | IsRejectedViaRegexOrExactMatch |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle |
Public method | ResetHandleCount | Resets the handle count back to zero.
Protected method | SetDialogWindow | Set the dialog window.
Public method | ToString | (Overrides Object..::..ToString()()()().)
 | WaitUntilAnyHandled |
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout.
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait.
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor.
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog.
Public property | ErrorText |
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled.
Public property | HandlerDelegate | Gets/Sets the dialog custom handler
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts.
Protected property | ParentBrowser | The parent browser object of this dialog
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle.
Public property | Tags | Custom tags for miscellaneous use.
Public property | Window | The dialog Window object.

Events

 | Name | Description
Public event | BeforeHandle |

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


BaseDialog Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog Constructor
BaseDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BaseDialog(Browser, DialogButton) | Create a new dialog.
Public method | BaseDialog(WpfApplication, DialogButton) | Initializes a new instance of the BaseDialog class

See Also

BaseDialog Class
BaseDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


BaseDialog Constructor (Browser, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog Constructor (Browser, DialogButton)
BaseDialog Class See Also Send Feedback
Create a new dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BaseDialog(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
)
Visual C++
public:
BaseDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser. Expect null for non-web dialogs.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss the dialog.

See Also

BaseDialog Class
BaseDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


BaseDialog Constructor (WpfApplication, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog Constructor (WpfApplication, DialogButton)
BaseDialog Class See Also Send Feedback
Initializes a new instance of the BaseDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public BaseDialog(
    WpfApplication application,
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    application As WpfApplication, _
    dismissButton As DialogButton _
)
Visual C++
public:
BaseDialog(
    WpfApplication^ application,
    DialogButton dismissButton
)

Parameters

application
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="application"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

See Also

BaseDialog Class
BaseDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


BaseDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog Fields
BaseDialog Class See Also Send Feedback

The BaseDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


m_browserVersionMajor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..m_browserVersionMajor Field
BaseDialog Class See Also Send Feedback
The major version of the browser

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected int m_browserVersionMajor
Visual Basic
Protected m_browserVersionMajor As Integer
Visual C++
protected:
int m_browserVersionMajor

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


BaseDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog Methods
BaseDialog Class See Also Send Feedback

The BaseDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle the dialog. If HandlerDelegate is set, use the delegate
Public method | IsDialogActive | Detect whether this dialog is active or not. Mostly used for HWND-based controls, such as top-level windows.
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title.
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title.
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog
 | IsMatchingWindowsVistaTaskDialog | Gets whether the provided window is a dialog created by TaskDialog() or TaskDialogIndirect(), according to the given criteria.
 | IsRejectedViaRegexOrExactMatch |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle |
Public method | ResetHandleCount | Resets the handle count back to zero.
Protected method | SetDialogWindow | Set the dialog window.
Public method | ToString | (Overrides Object..::..ToString()()()().)
 | WaitUntilAnyHandled |
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout.
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait.
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting.

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..Handle Method
BaseDialog Class See Also Send Feedback
Handle the dialog. If HandlerDelegate is set, use the delegate

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract void Handle()
Visual Basic
Public MustOverride Sub Handle
Visual C++
public:
virtual void Handle() abstract

Implements

IDialog..::..Handle()()()()

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..IsDialogActive Method
BaseDialog Class See Also Send Feedback
Detect whether this dialog is active or not. Mostly used for HWND-based controls, such as top-level windows.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public abstract bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public MustOverride Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) abstract

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of all dialogs.

Return Value

True/False whether this dialog is active or not.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..IsDialogActiveByTitle Method
BaseDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title.
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title.

See Also

BaseDialog Class
BaseDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method (WindowCollection, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..IsDialogActiveByTitle Method (WindowCollection, String)
BaseDialog Class See Also Send Feedback
Get whether the dialog is active based on its title.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool IsDialogActiveByTitle(
    WindowCollection dialogs,
    string title
)
Visual Basic
Protected Function IsDialogActiveByTitle ( _
    dialogs As WindowCollection, _
    title As String _
) As Boolean
Visual C++
protected:
bool IsDialogActiveByTitle(
    WindowCollection^ dialogs,
    String^ title
)

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs to check.
title
Type: System..::..String
The title to check for.

Return Value

True/False whether the dialog is active or not.

See Also

BaseDialog Class
IsDialogActiveByTitle Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method (WindowCollection, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..IsDialogActiveByTitle Method (WindowCollection, String, Boolean)
BaseDialog Class See Also Send Feedback
Get whether the dialog is active base on its title.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool IsDialogActiveByTitle(
    WindowCollection dialogs,
    string title,
    bool partialTitle
)
Visual Basic
Protected Function IsDialogActiveByTitle ( _
    dialogs As WindowCollection, _
    title As String, _
    partialTitle As Boolean _
) As Boolean
Visual C++
protected:
bool IsDialogActiveByTitle(
    WindowCollection^ dialogs,
    String^ title,
    bool partialTitle
)

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs to check.
title
Type: System..::..String
The title to check for.
partialTitle
Type: System..::..Boolean
True/False whether to do partial match or not.

Return Value

True/False whether the dialog is active or not.

See Also

BaseDialog Class
IsDialogActiveByTitle Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitleAndTextContent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..IsDialogActiveByTitleAndTextContent Method
BaseDialog Class See Also Send Feedback
Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected bool IsDialogActiveByTitleAndTextContent(
    WindowCollection dialogs,
    string title,
    bool partialTitle,
    string childWindowTextContent
)
Visual Basic
Protected Function IsDialogActiveByTitleAndTextContent ( _
    dialogs As WindowCollection, _
    title As String, _
    partialTitle As Boolean, _
    childWindowTextContent As String _
) As Boolean
Visual C++
protected:
bool IsDialogActiveByTitleAndTextContent(
    WindowCollection^ dialogs,
    String^ title,
    bool partialTitle,
    String^ childWindowTextContent
)

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs to check.
title
Type: System..::..String
The title to check for.
partialTitle
Type: System..::..Boolean
True/False whether to do partial match or not.
childWindowTextContent
Type: System..::..String
The partial content of a child window

Return Value

True/False whether the dialog is active or not.

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsMatchingWindowsVistaTaskDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..IsMatchingWindowsVistaTaskDialog Method
BaseDialog Class See Also Send Feedback
Gets whether the provided window is a dialog created by TaskDialog() or TaskDialogIndirect(), according to the given criteria.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected static bool IsMatchingWindowsVistaTaskDialog(
    HWND hDialog,
    Object titleRegexOrString,
    Object mainInstructionRegexOrString,
    Object contentTextRegexOrString,
    params Object[] expectedButtonTextRegexesOrStrings
)
Visual Basic
Protected Shared Function IsMatchingWindowsVistaTaskDialog ( _
    hDialog As HWND, _
    titleRegexOrString As Object, _
    mainInstructionRegexOrString As Object, _
    contentTextRegexOrString As Object, _
    ParamArray expectedButtonTextRegexesOrStrings As Object() _
) As Boolean
Visual C++
protected:
static bool IsMatchingWindowsVistaTaskDialog(
    HWND hDialog,
    Object^ titleRegexOrString,
    Object^ mainInstructionRegexOrString,
    Object^ contentTextRegexOrString,
    ... array<Object^>^ expectedButtonTextRegexesOrStrings
)

Parameters

hDialog
Type: ArtOfTest.Common.Win32..::..HWND

[Missing <param name="hDialog"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.IsMatchingWindowsVistaTaskDialog(ArtOfTest.Common.Win32.HWND,System.Object,System.Object,System.Object,System.Object[])"]

titleRegexOrString
Type: System..::..Object
A Regex or String describing the main window title.
mainInstructionRegexOrString
Type: System..::..Object
A Regex or String describing the "MainInstruction" automation element name.
contentTextRegexOrString
Type: System..::..Object
A Regex or String describing the "ContentText" automation element name.
expectedButtonTextRegexesOrStrings
Type: array< System..::..Object >[]()[][]
A Regex or String describing each expected Win32 button caption.

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.IsMatchingWindowsVistaTaskDialog(ArtOfTest.Common.Win32.HWND,System.Object,System.Object,System.Object,System.Object[])"]

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsRejectedViaRegexOrExactMatch Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..IsRejectedViaRegexOrExactMatch Method
BaseDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.IsRejectedViaRegexOrExactMatch(System.String,System.Object)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static bool IsRejectedViaRegexOrExactMatch(
    string strActualValue,
    Object regexOrString
)
Visual Basic
Public Shared Function IsRejectedViaRegexOrExactMatch ( _
    strActualValue As String, _
    regexOrString As Object _
) As Boolean
Visual C++
public:
static bool IsRejectedViaRegexOrExactMatch(
    String^ strActualValue,
    Object^ regexOrString
)

Parameters

strActualValue
Type: System..::..String

[Missing <param name="strActualValue"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.IsRejectedViaRegexOrExactMatch(System.String,System.Object)"]

regexOrString
Type: System..::..Object

[Missing <param name="regexOrString"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.IsRejectedViaRegexOrExactMatch(System.String,System.Object)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.IsRejectedViaRegexOrExactMatch(System.String,System.Object)"]

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OnBeforeHandle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..OnBeforeHandle Method
BaseDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.OnBeforeHandle(System.EventArgs)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnBeforeHandle(
    EventArgs args
)
Visual Basic
Protected Overridable Sub OnBeforeHandle ( _
    args As EventArgs _
)
Visual C++
protected:
virtual void OnBeforeHandle(
    EventArgs^ args
)

Parameters

args
Type: System..::..EventArgs

[Missing <param name="args"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.OnBeforeHandle(System.EventArgs)"]

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ResetHandleCount Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..ResetHandleCount Method
BaseDialog Class See Also Send Feedback
Resets the handle count back to zero.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ResetHandleCount()
Visual Basic
Public Sub ResetHandleCount
Visual C++
public:
void ResetHandleCount()

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SetDialogWindow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..SetDialogWindow Method
BaseDialog Class See Also Send Feedback
Set the dialog window.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected internal void SetDialogWindow(
    Window dialogWindow
)
Visual Basic
Protected Friend Sub SetDialogWindow ( _
    dialogWindow As Window _
)
Visual C++
protected public:
void SetDialogWindow(
    Window^ dialogWindow
)

Parameters

dialogWindow
Type: ArtOfTest.Common.Win32..::..Window
The dialog window object.

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..ToString Method
BaseDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.ToString"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.ToString"]

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilAnyHandled Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..WaitUntilAnyHandled Method
BaseDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilAnyHandled(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Win32.Dialogs.BaseDialog},System.Int32,System.Int64,System.Boolean)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void WaitUntilAnyHandled(
    IEnumerable<BaseDialog> dialogs,
    int handleCount,
    long timeoutMilliseconds,
    bool resetHandleCount
)
Visual Basic
Public Shared Sub WaitUntilAnyHandled ( _
    dialogs As IEnumerable(Of BaseDialog), _
    handleCount As Integer, _
    timeoutMilliseconds As Long, _
    resetHandleCount As Boolean _
)
Visual C++
public:
static void WaitUntilAnyHandled(
    IEnumerable<BaseDialog^>^ dialogs,
    int handleCount,
    long long timeoutMilliseconds,
    bool resetHandleCount
)

Parameters

dialogs
Type: System.Collections.Generic..::..IEnumerable <(Of <(<' BaseDialog >)>)>

[Missing <param name="dialogs"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilAnyHandled(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Win32.Dialogs.BaseDialog},System.Int32,System.Int64,System.Boolean)"]

handleCount
Type: System..::..Int32

[Missing <param name="handleCount"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilAnyHandled(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Win32.Dialogs.BaseDialog},System.Int32,System.Int64,System.Boolean)"]

timeoutMilliseconds
Type: System..::..Int64

[Missing <param name="timeoutMilliseconds"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilAnyHandled(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Win32.Dialogs.BaseDialog},System.Int32,System.Int64,System.Boolean)"]

resetHandleCount
Type: System..::..Boolean

[Missing <param name="resetHandleCount"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.WaitUntilAnyHandled(System.Collections.Generic.IEnumerable{ArtOfTest.WebAii.Win32.Dialogs.BaseDialog},System.Int32,System.Int64,System.Boolean)"]

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..WaitUntilHandled Method
BaseDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout.
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait.
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting.

See Also

BaseDialog Class
BaseDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..WaitUntilHandled Method
BaseDialog Class See Also Send Feedback
Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitUntilHandled()
Visual Basic
Public Sub WaitUntilHandled
Visual C++
public:
void WaitUntilHandled()

See Also

BaseDialog Class
WaitUntilHandled Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..WaitUntilHandled Method (Int32)
BaseDialog Class See Also Send Feedback
Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitUntilHandled(
    int timeout
)
Visual Basic
Public Sub WaitUntilHandled ( _
    timeout As Integer _
)
Visual C++
public:
void WaitUntilHandled(
    int timeout
)

Parameters

timeout
Type: System..::..Int32
The timeout to use. (msec.)

See Also

BaseDialog Class
WaitUntilHandled Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method (Int32, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..WaitUntilHandled Method (Int32, Int32, Boolean)
BaseDialog Class See Also Send Feedback
Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitUntilHandled(
    int handleCount,
    int timeout,
    bool resetHandleCount
)
Visual Basic
Public Sub WaitUntilHandled ( _
    handleCount As Integer, _
    timeout As Integer, _
    resetHandleCount As Boolean _
)
Visual C++
public:
void WaitUntilHandled(
    int handleCount,
    int timeout,
    bool resetHandleCount
)

Parameters

handleCount
Type: System..::..Int32
The handle count to wait for.
timeout
Type: System..::..Int32
The time out in milli-seconds to wait for count.
resetHandleCount
Type: System..::..Boolean
True/False whether to reset the handle count before starting.

See Also

BaseDialog Class
WaitUntilHandled Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


BaseDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog Properties
BaseDialog Class See Also Send Feedback

The BaseDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor.
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog.
Public property | ErrorText |
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled.
Public property | HandlerDelegate | Gets/Sets the dialog custom handler
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts.
Protected property | ParentBrowser | The parent browser object of this dialog
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle.
Public property | Tags | Custom tags for miscellaneous use.
Public property | Window | The dialog Window object.

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


BaseDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog Events
BaseDialog Class See Also Send Feedback

The BaseDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle |

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


BeforeHandle Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
BaseDialog..::..BeforeHandle Event
BaseDialog Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Win32.Dialogs.BaseDialog.BeforeHandle"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler BeforeHandle
Visual Basic
Public Event BeforeHandle As EventHandler
Visual C++
public:
 event EventHandler^ BeforeHandle {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

BaseDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ChromePromptDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog Members
ChromePromptDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The ChromePromptDialog type exposes the following members.

Constructors

 | Name | Description
Public method | ChromePromptDialog | Initializes a new instance of the ChromePromptDialog class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

ChromePromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ChromePromptDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog Constructor
ChromePromptDialog Class See Also Send Feedback
Initializes a new instance of the ChromePromptDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public ChromePromptDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    string text
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    text As String _
)
Visual C++
public:
ChromePromptDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    String^ text
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ChromePromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ChromePromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ChromePromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

See Also

ChromePromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ChromePromptDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog Fields
ChromePromptDialog Class See Also Send Feedback

The ChromePromptDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

ChromePromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ChromePromptDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog Methods
ChromePromptDialog Class See Also Send Feedback

The ChromePromptDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

ChromePromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog..::..Handle Method
ChromePromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ChromePromptDialog.Handle"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

ChromePromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog..::..IsDialogActive Method
ChromePromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ChromePromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection

[Missing <param name="dialogs"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ChromePromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ChromePromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

ChromePromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog..::..IsDialogActiveByTitle Method
ChromePromptDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

ChromePromptDialog Class
ChromePromptDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog..::..WaitUntilHandled Method
ChromePromptDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

ChromePromptDialog Class
ChromePromptDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


ChromePromptDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog Properties
ChromePromptDialog Class See Also Send Feedback

The ChromePromptDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

ChromePromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ChromePromptDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ChromePromptDialog Events
ChromePromptDialog Class See Also Send Feedback

The ChromePromptDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

ChromePromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ConfirmDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog Members
ConfirmDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The ConfirmDialog type exposes the following members.

Constructors

 | Name | Description
Public method | ConfirmDialog(Browser, DialogButton) | Obsolete. Create a new AlertDialog object to handle the dialog.
Protected method | ConfirmDialog(Browser, DialogButton, Boolean) | Initializes a new instance of the ConfirmDialog class

Methods

 | Name | Description
 | CreateConfirmDialog |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether the dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

ConfirmDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ConfirmDialog Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog Constructor
ConfirmDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConfirmDialog(Browser, DialogButton) | Obsolete. Create a new AlertDialog object to handle the dialog.
Protected method | ConfirmDialog(Browser, DialogButton, Boolean) | Initializes a new instance of the ConfirmDialog class

See Also

ConfirmDialog Class
ConfirmDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


ConfirmDialog Constructor (Browser, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog Constructor (Browser, DialogButton)
ConfirmDialog Class See Also Send Feedback
Create a new AlertDialog object to handle the dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("ConfirmDialog constructor is deprecated. Use ConfirmDialog.CreateConfirmDialog method instead.")]
public ConfirmDialog(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
<ObsoleteAttribute("ConfirmDialog constructor is deprecated. Use ConfirmDialog.CreateConfirmDialog method instead.")> _
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
)
Visual C++
[ObsoleteAttribute(L"ConfirmDialog constructor is deprecated. Use ConfirmDialog.CreateConfirmDialog method instead.")]
public:
ConfirmDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The dismiss button to use.

See Also

ConfirmDialog Class
ConfirmDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


ConfirmDialog Constructor (Browser, DialogButton, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog Constructor (Browser, DialogButton, Boolean)
ConfirmDialog Class See Also Send Feedback
Initializes a new instance of the ConfirmDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected ConfirmDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    bool skipObsoleteMessage
)
Visual Basic
Protected Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    skipObsoleteMessage As Boolean _
)
Visual C++
protected:
ConfirmDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    bool skipObsoleteMessage
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ConfirmDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.Boolean)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ConfirmDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.Boolean)"]

skipObsoleteMessage
Type: System..::..Boolean

[Missing <param name="skipObsoleteMessage"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ConfirmDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.Boolean)"]

See Also

ConfirmDialog Class
ConfirmDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


ConfirmDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog Fields
ConfirmDialog Class See Also Send Feedback

The ConfirmDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

ConfirmDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ConfirmDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog Methods
ConfirmDialog Class See Also Send Feedback

The ConfirmDialog type exposes the following members.

Methods

 | Name | Description
 | CreateConfirmDialog |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether the dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

ConfirmDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateConfirmDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog..::..CreateConfirmDialog Method
ConfirmDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ConfirmDialog.CreateConfirmDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static ConfirmDialog CreateConfirmDialog(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
Public Shared Function CreateConfirmDialog ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
) As ConfirmDialog
Visual C++
public:
static ConfirmDialog^ CreateConfirmDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ConfirmDialog.CreateConfirmDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ConfirmDialog.CreateConfirmDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.ConfirmDialog.CreateConfirmDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

See Also

ConfirmDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog..::..Handle Method
ConfirmDialog Class See Also Send Feedback
Handle this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Return Value

True/False whether this dialog was handled.

Implements

IDialog..::..Handle()()()()

See Also

ConfirmDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog..::..IsDialogActive Method
ConfirmDialog Class See Also Send Feedback
Whether the dialog is active or not.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs on the desktop.

Return Value

True/False whether the dialog is active or not.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

ConfirmDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog..::..IsDialogActiveByTitle Method
ConfirmDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

ConfirmDialog Class
ConfirmDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog..::..WaitUntilHandled Method
ConfirmDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

ConfirmDialog Class
ConfirmDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


ConfirmDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog Properties
ConfirmDialog Class See Also Send Feedback

The ConfirmDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

ConfirmDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ConfirmDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ConfirmDialog Events
ConfirmDialog Class See Also Send Feedback

The ConfirmDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

ConfirmDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogBatch Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogBatch Members
DialogBatch Class Constructors Methods Properties See Also Send Feedback

The DialogBatch type exposes the following members.

Constructors

 | Name | Description
Public method | DialogBatch | Initializes a new instance of the DialogBatch class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoRemove | Indicates whether batch will be auto removed from dialog monitoring when all its dialogs are handled.
Public property | Dialogs | Dialogs to be monitored.

See Also

DialogBatch Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogBatch Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogBatch Constructor
DialogBatch Class See Also Send Feedback
Initializes a new instance of the DialogBatch class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogBatch()
Visual Basic
Public Sub New
Visual C++
public:
DialogBatch()

See Also

DialogBatch Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogBatch Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogBatch Methods
DialogBatch Class See Also Send Feedback

The DialogBatch type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogBatch Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogBatch Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogBatch Properties
DialogBatch Class See Also Send Feedback

The DialogBatch type exposes the following members.

Properties

 | Name | Description
Public property | AutoRemove | Indicates whether batch will be auto removed from dialog monitoring when all its dialogs are handled.
Public property | Dialogs | Dialogs to be monitored.

See Also

DialogBatch Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogMonitor Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor Members
DialogMonitor Class Constructors Methods Properties Events See Also Send Feedback

The DialogMonitor type exposes the following members.

Constructors

 | Name | Description
Public method | DialogMonitor()()()() | Create a new DialogMonitor object and start the monitoring.
Public method | DialogMonitor(Boolean) | Create a new DialogMonitor object, associated with the current Manager
Public method | DialogMonitor(Boolean, Manager) | Create a new DialogMonitor object, associated with a specific Manager

Methods

 | Name | Description
Public method | AddDialog | Add a dialog to be monitored.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllDialogs | Returns a collection of all top level dialogs of the current desktop.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveDialog | Remove a single dialog from the list of dialogs to monitor.
Public method | RemoveDialogs | Remove any number of dialogs from the list of dialogs to monitor.
Public method | Start | Start dialog monitoring.
Public method | Stop | Stop dialog monitoring.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Dialogs | Gets the collection of dialogs the monitor is monitoring.
Public property | IsMonitoring | Gets whether the DialogMonitor object is currently monitoring dialogs or not.

Events

 | Name | Description
Public event | UnexpectedDialogEvent |

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogMonitor Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor Constructor
DialogMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DialogMonitor()()()() | Create a new DialogMonitor object and start the monitoring.
Public method | DialogMonitor(Boolean) | Create a new DialogMonitor object, associated with the current Manager
Public method | DialogMonitor(Boolean, Manager) | Create a new DialogMonitor object, associated with a specific Manager

See Also

DialogMonitor Class
DialogMonitor Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogMonitor Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor Constructor
DialogMonitor Class See Also Send Feedback
Create a new DialogMonitor object and start the monitoring.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogMonitor()
Visual Basic
Public Sub New
Visual C++
public:
DialogMonitor()

See Also

DialogMonitor Class
DialogMonitor Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogMonitor Constructor (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor Constructor (Boolean)
DialogMonitor Class See Also Send Feedback
Create a new DialogMonitor object, associated with the current Manager

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogMonitor(
    bool startMonitoring
)
Visual Basic
Public Sub New ( _
    startMonitoring As Boolean _
)
Visual C++
public:
DialogMonitor(
    bool startMonitoring
)

Parameters

startMonitoring
Type: System..::..Boolean
Whether to start monitoring the dialogs. If false, monitoring can start by calling Start().

See Also

DialogMonitor Class
DialogMonitor Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogMonitor Constructor (Boolean, Manager)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor Constructor (Boolean, Manager)
DialogMonitor Class See Also Send Feedback
Create a new DialogMonitor object, associated with a specific Manager

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DialogMonitor(
    bool startMonitoring,
    Manager manager
)
Visual Basic
Public Sub New ( _
    startMonitoring As Boolean, _
    manager As Manager _
)
Visual C++
public:
DialogMonitor(
    bool startMonitoring,
    Manager^ manager
)

Parameters

startMonitoring
Type: System..::..Boolean
Whether to start monitoring the dialogs. If false, monitoring can start by calling Start().
manager
Type: ArtOfTest.WebAii.Core..::..Manager
The manager to associate with the dialog monitor

See Also

DialogMonitor Class
DialogMonitor Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogMonitor Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor Methods
DialogMonitor Class See Also Send Feedback

The DialogMonitor type exposes the following members.

Methods

 | Name | Description
Public method | AddDialog | Add a dialog to be monitored.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllDialogs | Returns a collection of all top level dialogs of the current desktop.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveDialog | Remove a single dialog from the list of dialogs to monitor.
Public method | RemoveDialogs | Remove any number of dialogs from the list of dialogs to monitor.
Public method | Start | Start dialog monitoring.
Public method | Stop | Stop dialog monitoring.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


AddDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor..::..AddDialog Method
DialogMonitor Class See Also Send Feedback
Add a dialog to be monitored.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void AddDialog(
    IDialog dialog
)
Visual Basic
Public Sub AddDialog ( _
    dialog As IDialog _
)
Visual C++
public:
void AddDialog(
    IDialog^ dialog
)

Parameters

dialog
Type: ArtOfTest.WebAii.Win32.Dialogs..::..IDialog
The dialog to add.

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetAllDialogs Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor..::..GetAllDialogs Method
DialogMonitor Class See Also Send Feedback
Returns a collection of all top level dialogs of the current desktop.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static WindowCollection GetAllDialogs()
Visual Basic
Public Shared Function GetAllDialogs As WindowCollection
Visual C++
public:
static WindowCollection^ GetAllDialogs()

Return Value

The collectin of dialogs.

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


RemoveDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor..::..RemoveDialog Method
DialogMonitor Class See Also Send Feedback
Remove a single dialog from the list of dialogs to monitor.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveDialog(
    IDialog dialog
)
Visual Basic
Public Sub RemoveDialog ( _
    dialog As IDialog _
)
Visual C++
public:
void RemoveDialog(
    IDialog^ dialog
)

Parameters

dialog
Type: ArtOfTest.WebAii.Win32.Dialogs..::..IDialog

[Missing <param name="dialog"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.DialogMonitor.RemoveDialog(ArtOfTest.WebAii.Win32.Dialogs.IDialog)"]

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


RemoveDialogs Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor..::..RemoveDialogs Method
DialogMonitor Class See Also Send Feedback
Remove any number of dialogs from the list of dialogs to monitor.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RemoveDialogs(
    params IDialog[] specifiedDialogsToRemove
)
Visual Basic
Public Sub RemoveDialogs ( _
    ParamArray specifiedDialogsToRemove As IDialog() _
)
Visual C++
public:
void RemoveDialogs(
    ... array<IDialog^>^ specifiedDialogsToRemove
)

Parameters

specifiedDialogsToRemove
Type: array< ArtOfTest.WebAii.Win32.Dialogs..::..IDialog >[]()[][]
The dialogs to remove. If empty, it will remove all of them.

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Start Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor..::..Start Method
DialogMonitor Class See Also Send Feedback
Start dialog monitoring.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Stop Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor..::..Stop Method
DialogMonitor Class See Also Send Feedback
Stop dialog monitoring.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
void Stop()

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogMonitor Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor Properties
DialogMonitor Class See Also Send Feedback

The DialogMonitor type exposes the following members.

Properties

 | Name | Description
Public property | Dialogs | Gets the collection of dialogs the monitor is monitoring.
Public property | IsMonitoring | Gets whether the DialogMonitor object is currently monitoring dialogs or not.

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DialogMonitor Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor Events
DialogMonitor Class See Also Send Feedback

The DialogMonitor type exposes the following members.

Events

 | Name | Description
Public event | UnexpectedDialogEvent |

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


UnexpectedDialogEvent Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DialogMonitor..::..UnexpectedDialogEvent Event
DialogMonitor Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Win32.Dialogs.DialogMonitor.UnexpectedDialogEvent"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<WindowEventArgs> UnexpectedDialogEvent
Visual Basic
Public Event UnexpectedDialogEvent As EventHandler(Of WindowEventArgs)
Visual C++
public:
 event EventHandler<WindowEventArgs^>^ UnexpectedDialogEvent {
    void add (EventHandler<WindowEventArgs^>^ value);
    void remove (EventHandler<WindowEventArgs^>^ value);
}

See Also

DialogMonitor Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DownloadDialogsHandler Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DownloadDialogsHandler Members
DownloadDialogsHandler Class Constructors Methods Properties See Also Send Feedback

The DownloadDialogsHandler type exposes the following members.

Constructors

 | Name | Description
Public method | DownloadDialogsHandler | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitUntilHandled()()()() | Wait until all dialogs handled. Uses the Settings.ClientReadyTimeout as the timeout.
Public method | WaitUntilHandled(Int32) | Wait until all dialogs are handled using the timeout passed in. SetupMonitoring() must be called before every use.

Properties

 | Name | Description
Public property | SaveLocation | Gets/Sets the save location when doing a SAVE.

See Also

DownloadDialogsHandler Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DownloadDialogsHandler Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DownloadDialogsHandler Constructor
DownloadDialogsHandler Class See Also Send Feedback
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public DownloadDialogsHandler(
    Browser parentBrowser,
    DialogButton dismissButton,
    string saveLocation,
    Desktop desktopObject
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    saveLocation As String, _
    desktopObject As Desktop _
)
Visual C++
public:
DownloadDialogsHandler(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    String^ saveLocation,
    Desktop^ desktopObject
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss the dialog. Accepts: SAVE or CANCEL.
saveLocation
Type: System..::..String
The location to save the file if dismiss button is SAVE, else is ignored.
desktopObject
Type: ArtOfTest.WebAii.Core..::..Desktop
The desktop object.

See Also

DownloadDialogsHandler Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DownloadDialogsHandler Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DownloadDialogsHandler Methods
DownloadDialogsHandler Class See Also Send Feedback

The DownloadDialogsHandler type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitUntilHandled()()()() | Wait until all dialogs handled. Uses the Settings.ClientReadyTimeout as the timeout.
Public method | WaitUntilHandled(Int32) | Wait until all dialogs are handled using the timeout passed in. SetupMonitoring() must be called before every use.

See Also

DownloadDialogsHandler Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DownloadDialogsHandler..::..WaitUntilHandled Method
DownloadDialogsHandler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Wait until all dialogs handled. Uses the Settings.ClientReadyTimeout as the timeout.
Public method | WaitUntilHandled(Int32) | Wait until all dialogs are handled using the timeout passed in. SetupMonitoring() must be called before every use.

See Also

DownloadDialogsHandler Class
DownloadDialogsHandler Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DownloadDialogsHandler..::..WaitUntilHandled Method
DownloadDialogsHandler Class See Also Send Feedback
Wait until all dialogs handled. Uses the Settings.ClientReadyTimeout as the timeout.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitUntilHandled()
Visual Basic
Public Sub WaitUntilHandled
Visual C++
public:
void WaitUntilHandled()

See Also

DownloadDialogsHandler Class
WaitUntilHandled Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DownloadDialogsHandler..::..WaitUntilHandled Method (Int32)
DownloadDialogsHandler Class See Also Send Feedback
Wait until all dialogs are handled using the timeout passed in. SetupMonitoring() must be called before every use.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void WaitUntilHandled(
    int timeout
)
Visual Basic
Public Sub WaitUntilHandled ( _
    timeout As Integer _
)
Visual C++
public:
void WaitUntilHandled(
    int timeout
)

Parameters

timeout
Type: System..::..Int32

[Missing <param name="timeout"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.DownloadDialogsHandler.WaitUntilHandled(System.Int32)"]

See Also

DownloadDialogsHandler Class
WaitUntilHandled Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


DownloadDialogsHandler Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DownloadDialogsHandler Properties
DownloadDialogsHandler Class See Also Send Feedback

The DownloadDialogsHandler type exposes the following members.

Properties

 | Name | Description
Public property | SaveLocation | Gets/Sets the save location when doing a SAVE.

See Also

DownloadDialogsHandler Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FFOpenDownloadDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog Members
FFOpenDownloadDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The FFOpenDownloadDialog type exposes the following members.

Constructors

 | Name | Description
Public method | FFOpenDownloadDialog | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether the dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

FFOpenDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FFOpenDownloadDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog Constructor
FFOpenDownloadDialog Class See Also Send Feedback
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FFOpenDownloadDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    Desktop desktopObject
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    desktopObject As Desktop _
)
Visual C++
public:
FFOpenDownloadDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    Desktop^ desktopObject
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss the dialog. Accepts: SAVE, OPEN or CANCEL.
desktopObject
Type: ArtOfTest.WebAii.Core..::..Desktop
The desktop object to use for mouse events if needed.

See Also

FFOpenDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FFOpenDownloadDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog Fields
FFOpenDownloadDialog Class See Also Send Feedback

The FFOpenDownloadDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

FFOpenDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FFOpenDownloadDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog Methods
FFOpenDownloadDialog Class See Also Send Feedback

The FFOpenDownloadDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether the dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

FFOpenDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog..::..Handle Method
FFOpenDownloadDialog Class See Also Send Feedback
Handle this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

FFOpenDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog..::..IsDialogActive Method
FFOpenDownloadDialog Class See Also Send Feedback
Whether the dialog is active or not.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs to check.

Return Value

True/False whether the dialog is active.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

FFOpenDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog..::..IsDialogActiveByTitle Method
FFOpenDownloadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

FFOpenDownloadDialog Class
FFOpenDownloadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog..::..WaitUntilHandled Method
FFOpenDownloadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

FFOpenDownloadDialog Class
FFOpenDownloadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


FFOpenDownloadDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog Properties
FFOpenDownloadDialog Class See Also Send Feedback

The FFOpenDownloadDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

FFOpenDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FFOpenDownloadDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FFOpenDownloadDialog Events
FFOpenDownloadDialog Class See Also Send Feedback

The FFOpenDownloadDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

FFOpenDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Members
FileUploadDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The FileUploadDialog type exposes the following members.

Constructors

 | Name | Description
Public method | FileUploadDialog(Browser, String, DialogButton) | Create a new FileUploadDialog.
Public method | FileUploadDialog(Browser, String, DialogButton, String) | Create a new FileUploadDialog with a nonstandard title to search for
Public method | FileUploadDialog(Browser, String, DialogButton, array<String>[]()[][]) | Create a new FileUploadDialog with a list of fallback titles to search for

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle the dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Is dialog active. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | FilePath | Gets/Sets the file path to set for this dialog.
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

FileUploadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Constructor
FileUploadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FileUploadDialog(Browser, String, DialogButton) | Create a new FileUploadDialog.
Public method | FileUploadDialog(Browser, String, DialogButton, String) | Create a new FileUploadDialog with a nonstandard title to search for
Public method | FileUploadDialog(Browser, String, DialogButton, array<String>[]()[][]) | Create a new FileUploadDialog with a list of fallback titles to search for

See Also

FileUploadDialog Class
FileUploadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Constructor (Browser, String, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Constructor (Browser, String, DialogButton)
FileUploadDialog Class See Also Send Feedback
Create a new FileUploadDialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FileUploadDialog(
    Browser parentBrowser,
    string filePath,
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    filePath As String, _
    dismissButton As DialogButton _
)
Visual C++
public:
FileUploadDialog(
    Browser^ parentBrowser,
    String^ filePath,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
filePath
Type: System..::..String
The file path of the file to upload.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The dismiss button to use to close the dialog.

See Also

FileUploadDialog Class
FileUploadDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Constructor (Browser, String, DialogButton, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Constructor (Browser, String, DialogButton, String)
FileUploadDialog Class See Also Send Feedback
Create a new FileUploadDialog with a nonstandard title to search for

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FileUploadDialog(
    Browser parentBrowser,
    string filePath,
    DialogButton dismissButton,
    string title
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    filePath As String, _
    dismissButton As DialogButton, _
    title As String _
)
Visual C++
public:
FileUploadDialog(
    Browser^ parentBrowser,
    String^ filePath,
    DialogButton dismissButton,
    String^ title
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FileUploadDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

filePath
Type: System..::..String

[Missing <param name="filePath"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FileUploadDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FileUploadDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

title
Type: System..::..String
The expected title of the dialog window

See Also

FileUploadDialog Class
FileUploadDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Constructor (Browser, String, DialogButton, String[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Constructor (Browser, String, DialogButton, array<String>[]()[][])
FileUploadDialog Class See Also Send Feedback
Create a new FileUploadDialog with a list of fallback titles to search for

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FileUploadDialog(
    Browser parentBrowser,
    string filePath,
    DialogButton dismissButton,
    string[] alternateTitles
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    filePath As String, _
    dismissButton As DialogButton, _
    alternateTitles As String() _
)
Visual C++
public:
FileUploadDialog(
    Browser^ parentBrowser,
    String^ filePath,
    DialogButton dismissButton,
    array<String^>^ alternateTitles
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FileUploadDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String[])"]

filePath
Type: System..::..String

[Missing <param name="filePath"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FileUploadDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String[])"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FileUploadDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String[])"]

alternateTitles
Type: array< System..::..String >[]()[][]
Nonstandard titles to check for if the browser's standard file upload dialog title is not found

See Also

FileUploadDialog Class
FileUploadDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Fields
FileUploadDialog Class See Also Send Feedback

The FileUploadDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

FileUploadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Methods
FileUploadDialog Class See Also Send Feedback

The FileUploadDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle the dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Is dialog active. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

FileUploadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog..::..Handle Method
FileUploadDialog Class See Also Send Feedback
Handle the dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

FileUploadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog..::..IsDialogActive Method
FileUploadDialog Class See Also Send Feedback
Is dialog active.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs

Return Value

True/False whether the dialog is active or not.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

FileUploadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog..::..IsDialogActiveByTitle Method
FileUploadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

FileUploadDialog Class
FileUploadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog..::..WaitUntilHandled Method
FileUploadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

FileUploadDialog Class
FileUploadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Properties
FileUploadDialog Class See Also Send Feedback

The FileUploadDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | FilePath | Gets/Sets the file path to set for this dialog.
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

FileUploadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FileUploadDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileUploadDialog Events
FileUploadDialog Class See Also Send Feedback

The FileUploadDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

FileUploadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FireFoxPromptDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog Members
FireFoxPromptDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The FireFoxPromptDialog type exposes the following members.

Constructors

 | Name | Description
Public method | FireFoxPromptDialog | Initializes a new instance of the FireFoxPromptDialog class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Public method | MatchesUIAutomationElement |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | _dialogElement |
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FireFoxPromptDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog Constructor
FireFoxPromptDialog Class See Also Send Feedback
Initializes a new instance of the FireFoxPromptDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public FireFoxPromptDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    string text
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    text As String _
)
Visual C++
public:
FireFoxPromptDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    String^ text
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FireFoxPromptDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog Fields
FireFoxPromptDialog Class See Also Send Feedback

The FireFoxPromptDialog type exposes the following members.

Fields

 | Name | Description
Protected field | _dialogElement |
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


_dialogElement Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog..::.._dialogElement Field
FireFoxPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog._dialogElement"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected AutomationElement _dialogElement
Visual Basic
Protected _dialogElement As AutomationElement
Visual C++
protected:
AutomationElement^ _dialogElement

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FireFoxPromptDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog Methods
FireFoxPromptDialog Class See Also Send Feedback

The FireFoxPromptDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Public method | MatchesUIAutomationElement |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog..::..Handle Method
FireFoxPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.Handle"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()
IDialog..::..Handle()()()()

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog..::..IsDialogActive Method
FireFoxPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection

[Missing <param name="dialogs"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Implements

IDialog..::..IsDialogActive(WindowCollection)
IDialog..::..IsDialogActive(WindowCollection)

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog..::..IsDialogActiveByTitle Method
FireFoxPromptDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

FireFoxPromptDialog Class
FireFoxPromptDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


MatchesUIAutomationElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog..::..MatchesUIAutomationElement Method
FireFoxPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public bool MatchesUIAutomationElement(
    AutomationElement element
)
Visual Basic
Public Function MatchesUIAutomationElement ( _
    element As AutomationElement _
) As Boolean
Visual C++
public:
virtual bool MatchesUIAutomationElement(
    AutomationElement^ element
) sealed

Parameters

element
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.FireFoxPromptDialog.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog..::..WaitUntilHandled Method
FireFoxPromptDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

FireFoxPromptDialog Class
FireFoxPromptDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


FireFoxPromptDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog Properties
FireFoxPromptDialog Class See Also Send Feedback

The FireFoxPromptDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


FireFoxPromptDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FireFoxPromptDialog Events
FireFoxPromptDialog Class See Also Send Feedback

The FireFoxPromptDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

FireFoxPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Members
GenericDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The GenericDialog type exposes the following members.

Constructors

 | Name | Description
Public method | GenericDialog(Browser, String, Boolean) | Create a new generic dialog.
Public method | GenericDialog(WpfApplication, String, Boolean) | Create a new generic dialog.
Public method | GenericDialog(Browser, String, Boolean, Int32) | Create a new generic dialog
Public method | GenericDialog(Browser, String, Boolean, String) | Create a new generic dialog.
Public method | GenericDialog(Browser, String, String, Boolean) | Create a new generic dialog.
Public method | GenericDialog(WpfApplication, String, Boolean, Int32) | Create a new generic dialog
Public method | GenericDialog(WpfApplication, String, Boolean, String) | Create a new generic dialog.
Public method | GenericDialog(WpfApplication, String, String, Boolean) | Create a new generic dialog.
Public method | GenericDialog(Browser, String, Boolean, Int32, String) | Create a new generic dialog
Public method | GenericDialog(Browser, String, Boolean, String, String) | Create a new generic dialog.
Public method | GenericDialog(WpfApplication, String, Boolean, Int32, String) | Create a new generic dialog
Public method | GenericDialog(WpfApplication, String, Boolean, String, String) | Create a new generic dialog.
Public method | GenericDialog(Browser, String, Boolean, String, Int32, String) | All-encompassing base constructor.
Public method | GenericDialog(WpfApplication, String, Boolean, String, Int32, String) | All-encompassing base constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this generic dialog (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | If dialog is active. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | ButtonId | Gets/Sets the button id to click.
Public property | ButtonText | Gets/Sets the button text to click.
Public property | ChildTextContext | Gets/Sets the child text of a child window of this dialog.
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | PartialTitle | Gets/Sets whether the title is partial title.
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Title | Gets/Sets the title of this dialog.
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

GenericDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor
GenericDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GenericDialog(Browser, String, Boolean) | Create a new generic dialog.
Public method | GenericDialog(WpfApplication, String, Boolean) | Create a new generic dialog.
Public method | GenericDialog(Browser, String, Boolean, Int32) | Create a new generic dialog
Public method | GenericDialog(Browser, String, Boolean, String) | Create a new generic dialog.
Public method | GenericDialog(Browser, String, String, Boolean) | Create a new generic dialog.
Public method | GenericDialog(WpfApplication, String, Boolean, Int32) | Create a new generic dialog
Public method | GenericDialog(WpfApplication, String, Boolean, String) | Create a new generic dialog.
Public method | GenericDialog(WpfApplication, String, String, Boolean) | Create a new generic dialog.
Public method | GenericDialog(Browser, String, Boolean, Int32, String) | Create a new generic dialog
Public method | GenericDialog(Browser, String, Boolean, String, String) | Create a new generic dialog.
Public method | GenericDialog(WpfApplication, String, Boolean, Int32, String) | Create a new generic dialog
Public method | GenericDialog(WpfApplication, String, Boolean, String, String) | Create a new generic dialog.
Public method | GenericDialog(Browser, String, Boolean, String, Int32, String) | All-encompassing base constructor.
Public method | GenericDialog(WpfApplication, String, Boolean, String, Int32, String) | All-encompassing base constructor.

See Also

GenericDialog Class
GenericDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (Browser, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (Browser, String, Boolean)
GenericDialog Class See Also Send Feedback
Create a new generic dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    Browser parentBrowser,
    string title,
    bool partialTitle
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    title As String, _
    partialTitle As Boolean _
)
Visual C++
public:
GenericDialog(
    Browser^ parentBrowser,
    String^ title,
    bool partialTitle
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
title
Type: System..::..String
The title of the dialog to handle.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.

Remarks

Will simply close this dialog.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (WpfApplication, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (WpfApplication, String, Boolean)
GenericDialog Class See Also Send Feedback
Create a new generic dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    WpfApplication parentApp,
    string title,
    bool partialTitle
)
Visual Basic
Public Sub New ( _
    parentApp As WpfApplication, _
    title As String, _
    partialTitle As Boolean _
)
Visual C++
public:
GenericDialog(
    WpfApplication^ parentApp,
    String^ title,
    bool partialTitle
)

Parameters

parentApp
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="parentApp"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean)"]

title
Type: System..::..String
The title of the dialog to handle.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.

Remarks

Will simply close this dialog.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (Browser, String, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (Browser, String, Boolean, Int32)
GenericDialog Class See Also Send Feedback
Create a new generic dialog

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    Browser parentBrowser,
    string title,
    bool partialTitle,
    int buttonId
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    title As String, _
    partialTitle As Boolean, _
    buttonId As Integer _
)
Visual C++
public:
GenericDialog(
    Browser^ parentBrowser,
    String^ title,
    bool partialTitle,
    int buttonId
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
title
Type: System..::..String
The title of the dialog.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.
buttonId
Type: System..::..Int32
The button id to click on the dialog.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (Browser, String, Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (Browser, String, Boolean, String)
GenericDialog Class See Also Send Feedback
Create a new generic dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    Browser parentBrowser,
    string title,
    bool partialTitle,
    string childTextContent
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    title As String, _
    partialTitle As Boolean, _
    childTextContent As String _
)
Visual C++
public:
GenericDialog(
    Browser^ parentBrowser,
    String^ title,
    bool partialTitle,
    String^ childTextContent
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
title
Type: System..::..String
The title of the dialog to handle.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.
childTextContent
Type: System..::..String
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (Browser, String, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (Browser, String, String, Boolean)
GenericDialog Class See Also Send Feedback
Create a new generic dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    Browser parentBrowser,
    string title,
    string buttonText,
    bool partialTitle
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    title As String, _
    buttonText As String, _
    partialTitle As Boolean _
)
Visual C++
public:
GenericDialog(
    Browser^ parentBrowser,
    String^ title,
    String^ buttonText,
    bool partialTitle
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
title
Type: System..::..String
The title of the dialog.
buttonText
Type: System..::..String
The button caption to click.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (WpfApplication, String, Boolean, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (WpfApplication, String, Boolean, Int32)
GenericDialog Class See Also Send Feedback
Create a new generic dialog

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    WpfApplication parentApp,
    string title,
    bool partialTitle,
    int buttonId
)
Visual Basic
Public Sub New ( _
    parentApp As WpfApplication, _
    title As String, _
    partialTitle As Boolean, _
    buttonId As Integer _
)
Visual C++
public:
GenericDialog(
    WpfApplication^ parentApp,
    String^ title,
    bool partialTitle,
    int buttonId
)

Parameters

parentApp
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="parentApp"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.Int32)"]

title
Type: System..::..String
The title of the dialog.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.
buttonId
Type: System..::..Int32
The button id to click on the dialog.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (WpfApplication, String, Boolean, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (WpfApplication, String, Boolean, String)
GenericDialog Class See Also Send Feedback
Create a new generic dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    WpfApplication parentApp,
    string title,
    bool partialTitle,
    string childTextContent
)
Visual Basic
Public Sub New ( _
    parentApp As WpfApplication, _
    title As String, _
    partialTitle As Boolean, _
    childTextContent As String _
)
Visual C++
public:
GenericDialog(
    WpfApplication^ parentApp,
    String^ title,
    bool partialTitle,
    String^ childTextContent
)

Parameters

parentApp
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="parentApp"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.String)"]

title
Type: System..::..String
The title of the dialog to handle.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.
childTextContent
Type: System..::..String
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (WpfApplication, String, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (WpfApplication, String, String, Boolean)
GenericDialog Class See Also Send Feedback
Create a new generic dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    WpfApplication parentApp,
    string title,
    string buttonText,
    bool partialTitle
)
Visual Basic
Public Sub New ( _
    parentApp As WpfApplication, _
    title As String, _
    buttonText As String, _
    partialTitle As Boolean _
)
Visual C++
public:
GenericDialog(
    WpfApplication^ parentApp,
    String^ title,
    String^ buttonText,
    bool partialTitle
)

Parameters

parentApp
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="parentApp"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.String,System.Boolean)"]

title
Type: System..::..String
The title of the dialog.
buttonText
Type: System..::..String
The button caption to click.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (Browser, String, Boolean, Int32, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (Browser, String, Boolean, Int32, String)
GenericDialog Class See Also Send Feedback
Create a new generic dialog

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    Browser parentBrowser,
    string title,
    bool partialTitle,
    int buttonId,
    string childTextContent
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    title As String, _
    partialTitle As Boolean, _
    buttonId As Integer, _
    childTextContent As String _
)
Visual C++
public:
GenericDialog(
    Browser^ parentBrowser,
    String^ title,
    bool partialTitle,
    int buttonId,
    String^ childTextContent
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
title
Type: System..::..String
The title of the dialog.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.
buttonId
Type: System..::..Int32
The button id to click on the dialog.
childTextContent
Type: System..::..String
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (Browser, String, Boolean, String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (Browser, String, Boolean, String, String)
GenericDialog Class See Also Send Feedback
Create a new generic dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    Browser parentBrowser,
    string title,
    bool partialTitle,
    string buttonText,
    string childTextContent
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    title As String, _
    partialTitle As Boolean, _
    buttonText As String, _
    childTextContent As String _
)
Visual C++
public:
GenericDialog(
    Browser^ parentBrowser,
    String^ title,
    bool partialTitle,
    String^ buttonText,
    String^ childTextContent
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
title
Type: System..::..String
The title of the dialog.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.
buttonText
Type: System..::..String
The button caption to click.
childTextContent
Type: System..::..String
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (WpfApplication, String, Boolean, Int32, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (WpfApplication, String, Boolean, Int32, String)
GenericDialog Class See Also Send Feedback
Create a new generic dialog

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    WpfApplication parentApp,
    string title,
    bool partialTitle,
    int buttonId,
    string childTextContent
)
Visual Basic
Public Sub New ( _
    parentApp As WpfApplication, _
    title As String, _
    partialTitle As Boolean, _
    buttonId As Integer, _
    childTextContent As String _
)
Visual C++
public:
GenericDialog(
    WpfApplication^ parentApp,
    String^ title,
    bool partialTitle,
    int buttonId,
    String^ childTextContent
)

Parameters

parentApp
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="parentApp"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.Int32,System.String)"]

title
Type: System..::..String
The title of the dialog.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.
buttonId
Type: System..::..Int32
The button id to click on the dialog.
childTextContent
Type: System..::..String
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (WpfApplication, String, Boolean, String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (WpfApplication, String, Boolean, String, String)
GenericDialog Class See Also Send Feedback
Create a new generic dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    WpfApplication parentApp,
    string title,
    bool partialTitle,
    string buttonText,
    string childTextContent
)
Visual Basic
Public Sub New ( _
    parentApp As WpfApplication, _
    title As String, _
    partialTitle As Boolean, _
    buttonText As String, _
    childTextContent As String _
)
Visual C++
public:
GenericDialog(
    WpfApplication^ parentApp,
    String^ title,
    bool partialTitle,
    String^ buttonText,
    String^ childTextContent
)

Parameters

parentApp
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="parentApp"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.String,System.String)"]

title
Type: System..::..String
The title of the dialog.
partialTitle
Type: System..::..Boolean
Whether the title provided is partial or complete.
buttonText
Type: System..::..String
The button caption to click.
childTextContent
Type: System..::..String
A partial text that might be found on that dialog. This can help isolate this dialog from other dialogs that might have similar titles.

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (Browser, String, Boolean, String, Int32, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (Browser, String, Boolean, String, Int32, String)
GenericDialog Class See Also Send Feedback
All-encompassing base constructor.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    Browser parentBrowser,
    string title,
    bool partialTitle,
    string childTextContent,
    int buttonId,
    string buttonText
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    title As String, _
    partialTitle As Boolean, _
    childTextContent As String, _
    buttonId As Integer, _
    buttonText As String _
)
Visual C++
public:
GenericDialog(
    Browser^ parentBrowser,
    String^ title,
    bool partialTitle,
    String^ childTextContent,
    int buttonId,
    String^ buttonText
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,System.Boolean,System.String,System.Int32,System.String)"]

title
Type: System..::..String

[Missing <param name="title"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,System.Boolean,System.String,System.Int32,System.String)"]

partialTitle
Type: System..::..Boolean

[Missing <param name="partialTitle"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,System.Boolean,System.String,System.Int32,System.String)"]

childTextContent
Type: System..::..String

[Missing <param name="childTextContent"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,System.Boolean,System.String,System.Int32,System.String)"]

buttonId
Type: System..::..Int32

[Missing <param name="buttonId"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,System.Boolean,System.String,System.Int32,System.String)"]

buttonText
Type: System..::..String

[Missing <param name="buttonText"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Core.Browser,System.String,System.Boolean,System.String,System.Int32,System.String)"]

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Constructor (WpfApplication, String, Boolean, String, Int32, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Constructor (WpfApplication, String, Boolean, String, Int32, String)
GenericDialog Class See Also Send Feedback
All-encompassing base constructor.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public GenericDialog(
    WpfApplication parentApp,
    string title,
    bool partialTitle,
    string childTextContent,
    int buttonId,
    string buttonText
)
Visual Basic
Public Sub New ( _
    parentApp As WpfApplication, _
    title As String, _
    partialTitle As Boolean, _
    childTextContent As String, _
    buttonId As Integer, _
    buttonText As String _
)
Visual C++
public:
GenericDialog(
    WpfApplication^ parentApp,
    String^ title,
    bool partialTitle,
    String^ childTextContent,
    int buttonId,
    String^ buttonText
)

Parameters

parentApp
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="parentApp"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.String,System.Int32,System.String)"]

title
Type: System..::..String

[Missing <param name="title"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.String,System.Int32,System.String)"]

partialTitle
Type: System..::..Boolean

[Missing <param name="partialTitle"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.String,System.Int32,System.String)"]

childTextContent
Type: System..::..String

[Missing <param name="childTextContent"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.String,System.Int32,System.String)"]

buttonId
Type: System..::..Int32

[Missing <param name="buttonId"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.String,System.Int32,System.String)"]

buttonText
Type: System..::..String

[Missing <param name="buttonText"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.GenericDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,System.String,System.Boolean,System.String,System.Int32,System.String)"]

See Also

GenericDialog Class
GenericDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Fields
GenericDialog Class See Also Send Feedback

The GenericDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

GenericDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Methods
GenericDialog Class See Also Send Feedback

The GenericDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this generic dialog (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | If dialog is active. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

GenericDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog..::..Handle Method
GenericDialog Class See Also Send Feedback
Handle this generic dialog

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Return Value

Implements

IDialog..::..Handle()()()()

See Also

GenericDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog..::..IsDialogActive Method
GenericDialog Class See Also Send Feedback
If dialog is active.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of all dialogs

Return Value

True/False if the dialog is active.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

GenericDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog..::..IsDialogActiveByTitle Method
GenericDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

GenericDialog Class
GenericDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog..::..WaitUntilHandled Method
GenericDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

GenericDialog Class
GenericDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Properties
GenericDialog Class See Also Send Feedback

The GenericDialog type exposes the following members.

Properties

 | Name | Description
Public property | ButtonId | Gets/Sets the button id to click.
Public property | ButtonText | Gets/Sets the button text to click.
Public property | ChildTextContext | Gets/Sets the child text of a child window of this dialog.
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | PartialTitle | Gets/Sets whether the title is partial title.
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Title | Gets/Sets the title of this dialog.
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

GenericDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GenericDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GenericDialog Events
GenericDialog Class See Also Send Feedback

The GenericDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

GenericDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDialog Members
IDialog Interface Methods Properties See Also Send Feedback

The IDialog type exposes the following members.

Methods

 | Name | Description
Public method | Handle | If a HandlerDelegate is set, this function should call the delegate, otherwise handle the dialog itself.
Public method | IsDialogActive | Whether the dialog is active or not.

Properties

 | Name | Description
Public property | CurrentState | The dialogs current state. This property is Managed by the dialog monitor. Implementors should simply provide a private field to store this value for get/set operations.
Public property | ErrorText | When a dialog encounters an error and needs to abort, this property is set
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled.
Public property | HandlerDelegate | Gets/Sets a dialog handler delegate that will be used instead of the Handle() function.
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts.
Public property | Window | The Window object that represents this dialog. IsDialogActive() should set this property if it is returning true.

See Also

IDialog Interface
ArtOfTest.WebAii.Win32.Dialogs Namespace


IDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDialog Methods
IDialog Interface See Also Send Feedback

The IDialog type exposes the following members.

Methods

 | Name | Description
Public method | Handle | If a HandlerDelegate is set, this function should call the delegate, otherwise handle the dialog itself.
Public method | IsDialogActive | Whether the dialog is active or not.

See Also

IDialog Interface
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDialog..::..Handle Method
IDialog Interface See Also Send Feedback
If a HandlerDelegate is set, this function should call the delegate, otherwise handle the dialog itself.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
void Handle()
Visual Basic
Sub Handle
Visual C++
void Handle()

See Also

IDialog Interface
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDialog..::..IsDialogActive Method
IDialog Interface See Also Send Feedback
Whether the dialog is active or not.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
bool IsDialogActive(
    WindowCollection^ dialogs
)

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs present on the desktop.

Return Value

True/False whether the dialog is active/present.

See Also

IDialog Interface
ArtOfTest.WebAii.Win32.Dialogs Namespace


IDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IDialog Properties
IDialog Interface See Also Send Feedback

The IDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | The dialogs current state. This property is Managed by the dialog monitor. Implementors should simply provide a private field to store this value for get/set operations.
Public property | ErrorText | When a dialog encounters an error and needs to abort, this property is set
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled.
Public property | HandlerDelegate | Gets/Sets a dialog handler delegate that will be used instead of the Handle() function.
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts.
Public property | Window | The Window object that represents this dialog. IsDialogActive() should set this property if it is returning true.

See Also

IDialog Interface
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadCompleteNotificationBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar Members
IE9DownloadCompleteNotificationBar Class Constructors Methods Fields Properties Events See Also Send Feedback

The IE9DownloadCompleteNotificationBar type exposes the following members.

Constructors

 | Name | Description
Public method | IE9DownloadCompleteNotificationBar | Initializes a new instance of the IE9DownloadCompleteNotificationBar class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Inherited from IE9NotificationBar.)
Public method | IsDialogActive | (Inherited from IE9NotificationBar.)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Public method | MatchesUIAutomationElement | (Overrides IE9NotificationBar..::..MatchesUIAutomationElement(AutomationElement).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)
Protected field | NotificationBar | Reference to notification bar element. If this field is null Handle method will fail. (Inherited from IE9NotificationBar.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IE9DownloadCompleteNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadCompleteNotificationBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar Constructor
IE9DownloadCompleteNotificationBar Class See Also Send Feedback
Initializes a new instance of the IE9DownloadCompleteNotificationBar class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IE9DownloadCompleteNotificationBar(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
)
Visual C++
public:
IE9DownloadCompleteNotificationBar(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadCompleteNotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadCompleteNotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

See Also

IE9DownloadCompleteNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadCompleteNotificationBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar Fields
IE9DownloadCompleteNotificationBar Class See Also Send Feedback

The IE9DownloadCompleteNotificationBar type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)
Protected field | NotificationBar | Reference to notification bar element. If this field is null Handle method will fail. (Inherited from IE9NotificationBar.)

See Also

IE9DownloadCompleteNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadCompleteNotificationBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar Methods
IE9DownloadCompleteNotificationBar Class See Also Send Feedback

The IE9DownloadCompleteNotificationBar type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Inherited from IE9NotificationBar.)
Public method | IsDialogActive | (Inherited from IE9NotificationBar.)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Public method | MatchesUIAutomationElement | (Overrides IE9NotificationBar..::..MatchesUIAutomationElement(AutomationElement).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IE9DownloadCompleteNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar..::..IsDialogActiveByTitle Method
IE9DownloadCompleteNotificationBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

IE9DownloadCompleteNotificationBar Class
IE9DownloadCompleteNotificationBar Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


MatchesUIAutomationElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar..::..MatchesUIAutomationElement Method
IE9DownloadCompleteNotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadCompleteNotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool MatchesUIAutomationElement(
    AutomationElement element
)
Visual Basic
Public Overrides Function MatchesUIAutomationElement ( _
    element As AutomationElement _
) As Boolean
Visual C++
public:
virtual bool MatchesUIAutomationElement(
    AutomationElement^ element
) override

Parameters

element
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadCompleteNotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadCompleteNotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

See Also

IE9DownloadCompleteNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar..::..WaitUntilHandled Method
IE9DownloadCompleteNotificationBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IE9DownloadCompleteNotificationBar Class
IE9DownloadCompleteNotificationBar Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadCompleteNotificationBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar Properties
IE9DownloadCompleteNotificationBar Class See Also Send Feedback

The IE9DownloadCompleteNotificationBar type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

IE9DownloadCompleteNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadCompleteNotificationBar Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadCompleteNotificationBar Events
IE9DownloadCompleteNotificationBar Class See Also Send Feedback

The IE9DownloadCompleteNotificationBar type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IE9DownloadCompleteNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadNotificationBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar Members
IE9DownloadNotificationBar Class Constructors Methods Fields Properties Events See Also Send Feedback

The IE9DownloadNotificationBar type exposes the following members.

Constructors

 | Name | Description
Public method | IE9DownloadNotificationBar(Browser, DialogButton) | Initializes a new instance of the IE9DownloadNotificationBar class
Public method | IE9DownloadNotificationBar(Browser, DialogButton, Desktop) | Initializes a new instance of the IE9DownloadNotificationBar class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides IE9NotificationBar..::..Handle()()()().)
Public method | IsDialogActive | (Inherited from IE9NotificationBar.)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Public method | MatchesUIAutomationElement | (Overrides IE9NotificationBar..::..MatchesUIAutomationElement(AutomationElement).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)
Protected field | NotificationBar | Reference to notification bar element. If this field is null Handle method will fail. (Inherited from IE9NotificationBar.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IE9DownloadNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadNotificationBar Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar Constructor
IE9DownloadNotificationBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IE9DownloadNotificationBar(Browser, DialogButton) | Initializes a new instance of the IE9DownloadNotificationBar class
Public method | IE9DownloadNotificationBar(Browser, DialogButton, Desktop) | Initializes a new instance of the IE9DownloadNotificationBar class

See Also

IE9DownloadNotificationBar Class
IE9DownloadNotificationBar Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadNotificationBar Constructor (Browser, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar Constructor (Browser, DialogButton)
IE9DownloadNotificationBar Class See Also Send Feedback
Initializes a new instance of the IE9DownloadNotificationBar class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IE9DownloadNotificationBar(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
)
Visual C++
public:
IE9DownloadNotificationBar(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

See Also

IE9DownloadNotificationBar Class
IE9DownloadNotificationBar Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadNotificationBar Constructor (Browser, DialogButton, Desktop)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar Constructor (Browser, DialogButton, Desktop)
IE9DownloadNotificationBar Class See Also Send Feedback
Initializes a new instance of the IE9DownloadNotificationBar class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IE9DownloadNotificationBar(
    Browser parentBrowser,
    DialogButton dismissButton,
    Desktop desktopObject
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    desktopObject As Desktop _
)
Visual C++
public:
IE9DownloadNotificationBar(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    Desktop^ desktopObject
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,ArtOfTest.WebAii.Core.Desktop)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,ArtOfTest.WebAii.Core.Desktop)"]

desktopObject
Type: ArtOfTest.WebAii.Core..::..Desktop

[Missing <param name="desktopObject"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,ArtOfTest.WebAii.Core.Desktop)"]

See Also

IE9DownloadNotificationBar Class
IE9DownloadNotificationBar Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadNotificationBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar Fields
IE9DownloadNotificationBar Class See Also Send Feedback

The IE9DownloadNotificationBar type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)
Protected field | NotificationBar | Reference to notification bar element. If this field is null Handle method will fail. (Inherited from IE9NotificationBar.)

See Also

IE9DownloadNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadNotificationBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar Methods
IE9DownloadNotificationBar Class See Also Send Feedback

The IE9DownloadNotificationBar type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides IE9NotificationBar..::..Handle()()()().)
Public method | IsDialogActive | (Inherited from IE9NotificationBar.)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Public method | MatchesUIAutomationElement | (Overrides IE9NotificationBar..::..MatchesUIAutomationElement(AutomationElement).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IE9DownloadNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar..::..Handle Method
IE9DownloadNotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.Handle"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()
IDialog..::..Handle()()()()

See Also

IE9DownloadNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar..::..IsDialogActiveByTitle Method
IE9DownloadNotificationBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

IE9DownloadNotificationBar Class
IE9DownloadNotificationBar Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


MatchesUIAutomationElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar..::..MatchesUIAutomationElement Method
IE9DownloadNotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool MatchesUIAutomationElement(
    AutomationElement element
)
Visual Basic
Public Overrides Function MatchesUIAutomationElement ( _
    element As AutomationElement _
) As Boolean
Visual C++
public:
virtual bool MatchesUIAutomationElement(
    AutomationElement^ element
) override

Parameters

element
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9DownloadNotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

See Also

IE9DownloadNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar..::..WaitUntilHandled Method
IE9DownloadNotificationBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IE9DownloadNotificationBar Class
IE9DownloadNotificationBar Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadNotificationBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar Properties
IE9DownloadNotificationBar Class See Also Send Feedback

The IE9DownloadNotificationBar type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

IE9DownloadNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9DownloadNotificationBar Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9DownloadNotificationBar Events
IE9DownloadNotificationBar Class See Also Send Feedback

The IE9DownloadNotificationBar type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IE9DownloadNotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9NotificationBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar Members
IE9NotificationBar Class Constructors Methods Fields Properties Events See Also Send Feedback

The IE9NotificationBar type exposes the following members.

Constructors

 | Name | Description
Public method | IE9NotificationBar | Initializes a new instance of the IE9NotificationBar class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCancelButton |
 | GetCloseButton |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNotificationBar |
 | GetNotificationBarText |
 | GetOpenButton |
 | GetRunButton |
 | GetSaveButton |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Public method | MatchesUIAutomationElement |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)
Protected field | NotificationBar | Reference to notification bar element. If this field is null Handle method will fail.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9NotificationBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar Constructor
IE9NotificationBar Class See Also Send Feedback
Initializes a new instance of the IE9NotificationBar class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IE9NotificationBar(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
)
Visual C++
public:
IE9NotificationBar(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9NotificationBar Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar Fields
IE9NotificationBar Class See Also Send Feedback

The IE9NotificationBar type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)
Protected field | NotificationBar | Reference to notification bar element. If this field is null Handle method will fail.

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


NotificationBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..NotificationBar Field
IE9NotificationBar Class See Also Send Feedback
Reference to notification bar element. If this field is null Handle method will fail.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected AutomationElement NotificationBar
Visual Basic
Protected NotificationBar As AutomationElement
Visual C++
protected:
AutomationElement^ NotificationBar

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9NotificationBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar Methods
IE9NotificationBar Class See Also Send Feedback

The IE9NotificationBar type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCancelButton |
 | GetCloseButton |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNotificationBar |
 | GetNotificationBarText |
 | GetOpenButton |
 | GetRunButton |
 | GetSaveButton |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Public method | MatchesUIAutomationElement |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetCancelButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..GetCancelButton Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetCancelButton(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationElement GetCancelButton(
    AutomationElement anyParentElement
)
Visual Basic
Public Shared Function GetCancelButton ( _
    anyParentElement As AutomationElement _
) As AutomationElement
Visual C++
public:
static AutomationElement^ GetCancelButton(
    AutomationElement^ anyParentElement
)

Parameters

anyParentElement
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="anyParentElement"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetCancelButton(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetCancelButton(System.Windows.Automation.AutomationElement)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetCloseButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..GetCloseButton Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetCloseButton(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationElement GetCloseButton(
    AutomationElement anyParentElement
)
Visual Basic
Public Shared Function GetCloseButton ( _
    anyParentElement As AutomationElement _
) As AutomationElement
Visual C++
public:
static AutomationElement^ GetCloseButton(
    AutomationElement^ anyParentElement
)

Parameters

anyParentElement
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="anyParentElement"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetCloseButton(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetCloseButton(System.Windows.Automation.AutomationElement)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetNotificationBar Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..GetNotificationBar Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetNotificationBar(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationElement GetNotificationBar(
    AutomationElement anySubTreeElement
)
Visual Basic
Public Shared Function GetNotificationBar ( _
    anySubTreeElement As AutomationElement _
) As AutomationElement
Visual C++
public:
static AutomationElement^ GetNotificationBar(
    AutomationElement^ anySubTreeElement
)

Parameters

anySubTreeElement
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="anySubTreeElement"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetNotificationBar(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetNotificationBar(System.Windows.Automation.AutomationElement)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetNotificationBarText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..GetNotificationBarText Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetNotificationBarText(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationElement GetNotificationBarText(
    AutomationElement anyParentElement
)
Visual Basic
Public Shared Function GetNotificationBarText ( _
    anyParentElement As AutomationElement _
) As AutomationElement
Visual C++
public:
static AutomationElement^ GetNotificationBarText(
    AutomationElement^ anyParentElement
)

Parameters

anyParentElement
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="anyParentElement"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetNotificationBarText(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetNotificationBarText(System.Windows.Automation.AutomationElement)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetOpenButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..GetOpenButton Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetOpenButton(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationElement GetOpenButton(
    AutomationElement anyParentElement
)
Visual Basic
Public Shared Function GetOpenButton ( _
    anyParentElement As AutomationElement _
) As AutomationElement
Visual C++
public:
static AutomationElement^ GetOpenButton(
    AutomationElement^ anyParentElement
)

Parameters

anyParentElement
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="anyParentElement"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetOpenButton(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetOpenButton(System.Windows.Automation.AutomationElement)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetRunButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..GetRunButton Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetRunButton(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationElement GetRunButton(
    AutomationElement anyParentElement
)
Visual Basic
Public Shared Function GetRunButton ( _
    anyParentElement As AutomationElement _
) As AutomationElement
Visual C++
public:
static AutomationElement^ GetRunButton(
    AutomationElement^ anyParentElement
)

Parameters

anyParentElement
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="anyParentElement"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetRunButton(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetRunButton(System.Windows.Automation.AutomationElement)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetSaveButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..GetSaveButton Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetSaveButton(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static AutomationElement GetSaveButton(
    AutomationElement anyParentElement
)
Visual Basic
Public Shared Function GetSaveButton ( _
    anyParentElement As AutomationElement _
) As AutomationElement
Visual C++
public:
static AutomationElement^ GetSaveButton(
    AutomationElement^ anyParentElement
)

Parameters

anyParentElement
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="anyParentElement"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetSaveButton(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.GetSaveButton(System.Windows.Automation.AutomationElement)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..Handle Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.Handle"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()
IDialog..::..Handle()()()()

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..IsDialogActive Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection

[Missing <param name="dialogs"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Implements

IDialog..::..IsDialogActive(WindowCollection)
IDialog..::..IsDialogActive(WindowCollection)

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..IsDialogActiveByTitle Method
IE9NotificationBar Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

IE9NotificationBar Class
IE9NotificationBar Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


MatchesUIAutomationElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..MatchesUIAutomationElement Method
IE9NotificationBar Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool MatchesUIAutomationElement(
    AutomationElement element
)
Visual Basic
Public Overridable Function MatchesUIAutomationElement ( _
    element As AutomationElement _
) As Boolean
Visual C++
public:
virtual bool MatchesUIAutomationElement(
    AutomationElement^ element
)

Parameters

element
Type: System.Windows.Automation..::..AutomationElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IE9NotificationBar.MatchesUIAutomationElement(System.Windows.Automation.AutomationElement)"]

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar..::..WaitUntilHandled Method
IE9NotificationBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IE9NotificationBar Class
IE9NotificationBar Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9NotificationBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar Properties
IE9NotificationBar Class See Also Send Feedback

The IE9NotificationBar type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IE9NotificationBar Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IE9NotificationBar Events
IE9NotificationBar Class See Also Send Feedback

The IE9NotificationBar type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IE9NotificationBar Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadCompleteDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog Members
IEDownloadCompleteDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The IEDownloadCompleteDialog type exposes the following members.

Constructors

 | Name | Description
Public method | IEDownloadCompleteDialog | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IEDownloadCompleteDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadCompleteDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog Constructor
IEDownloadCompleteDialog Class See Also Send Feedback
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEDownloadCompleteDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    Desktop desktopObject
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    desktopObject As Desktop _
)
Visual C++
public:
IEDownloadCompleteDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    Desktop^ desktopObject
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss the dialog. Accepts: RUN, OPEN or CLOSE.
desktopObject
Type: ArtOfTest.WebAii.Core..::..Desktop
The desktop object to use to invoke mouse/keyboard events.

See Also

IEDownloadCompleteDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadCompleteDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog Fields
IEDownloadCompleteDialog Class See Also Send Feedback

The IEDownloadCompleteDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

IEDownloadCompleteDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadCompleteDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog Methods
IEDownloadCompleteDialog Class See Also Send Feedback

The IEDownloadCompleteDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IEDownloadCompleteDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog..::..Handle Method
IEDownloadCompleteDialog Class See Also Send Feedback
This is called by the DialogMonitor whenever IsDialogActive returns true.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

IEDownloadCompleteDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog..::..IsDialogActive Method
IEDownloadCompleteDialog Class See Also Send Feedback
Check whether the dialog is present or not. This function is called by the dialogmonitor object

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
This is a list of dialog passes in the by the DialogMonitor object.

Return Value

True/False whether this dialog is present.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

IEDownloadCompleteDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog..::..IsDialogActiveByTitle Method
IEDownloadCompleteDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

IEDownloadCompleteDialog Class
IEDownloadCompleteDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog..::..WaitUntilHandled Method
IEDownloadCompleteDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IEDownloadCompleteDialog Class
IEDownloadCompleteDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadCompleteDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog Properties
IEDownloadCompleteDialog Class See Also Send Feedback

The IEDownloadCompleteDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

IEDownloadCompleteDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadCompleteDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadCompleteDialog Events
IEDownloadCompleteDialog Class See Also Send Feedback

The IEDownloadCompleteDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IEDownloadCompleteDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog Members
IEDownloadDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The IEDownloadDialog type exposes the following members.

Constructors

 | Name | Description
Public method | IEDownloadDialog | Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IEDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog Constructor
IEDownloadDialog Class See Also Send Feedback
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEDownloadDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    Desktop desktop
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    desktop As Desktop _
)
Visual C++
public:
IEDownloadDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    Desktop^ desktop
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss the dialog. Accepts: RUN, CANCEL, SAVE or OPEN.
desktop
Type: ArtOfTest.WebAii.Core..::..Desktop
The desktop object.

See Also

IEDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog Fields
IEDownloadDialog Class See Also Send Feedback

The IEDownloadDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

IEDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog Methods
IEDownloadDialog Class See Also Send Feedback

The IEDownloadDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IEDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog..::..Handle Method
IEDownloadDialog Class See Also Send Feedback
This is called by the DialogMonitor whenever IsDialogActive returns true.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

IEDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog..::..IsDialogActive Method
IEDownloadDialog Class See Also Send Feedback
Check whether the dialog is present or not. This function is called by the dialogmonitor object

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
This is a list of dialog passes in the by the DialogMonitor object.

Return Value

True/False whether this dialog is present.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

IEDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog..::..IsDialogActiveByTitle Method
IEDownloadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

IEDownloadDialog Class
IEDownloadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog..::..WaitUntilHandled Method
IEDownloadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IEDownloadDialog Class
IEDownloadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog Properties
IEDownloadDialog Class See Also Send Feedback

The IEDownloadDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

IEDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEDownloadDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEDownloadDialog Events
IEDownloadDialog Class See Also Send Feedback

The IEDownloadDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IEDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEPromptDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog Members
IEPromptDialog Class Methods Fields Properties Events See Also Send Feedback

The IEPromptDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
 | CANCEL_BUTTON_ID |
 | EDIT_ID |
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)
 | OK_BUTTON_ID |
 | TITLE_REGEX |
 | USUAL_TITLE |

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEPromptDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog Fields
IEPromptDialog Class See Also Send Feedback

The IEPromptDialog type exposes the following members.

Fields

 | Name | Description
 | CANCEL_BUTTON_ID |
 | EDIT_ID |
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)
 | OK_BUTTON_ID |
 | TITLE_REGEX |
 | USUAL_TITLE |

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


CANCEL_BUTTON_ID Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..CANCEL_BUTTON_ID Field
IEPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.CANCEL_BUTTON_ID"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int CANCEL_BUTTON_ID
Visual Basic
Public Const CANCEL_BUTTON_ID As Integer
Visual C++
public:
literal int CANCEL_BUTTON_ID

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


EDIT_ID Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..EDIT_ID Field
IEPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.EDIT_ID"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int EDIT_ID
Visual Basic
Public Const EDIT_ID As Integer
Visual C++
public:
literal int EDIT_ID

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OK_BUTTON_ID Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..OK_BUTTON_ID Field
IEPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.OK_BUTTON_ID"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public const int OK_BUTTON_ID
Visual Basic
Public Const OK_BUTTON_ID As Integer
Visual C++
public:
literal int OK_BUTTON_ID

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


TITLE_REGEX Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..TITLE_REGEX Field
IEPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.TITLE_REGEX"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly Regex TITLE_REGEX
Visual Basic
Public Shared ReadOnly TITLE_REGEX As Regex
Visual C++
public:
static initonly Regex^ TITLE_REGEX

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


USUAL_TITLE Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..USUAL_TITLE Field
IEPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.USUAL_TITLE"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string USUAL_TITLE
Visual Basic
Public Shared ReadOnly USUAL_TITLE As String
Visual C++
public:
static initonly String^ USUAL_TITLE

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEPromptDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog Methods
IEPromptDialog Class See Also Send Feedback

The IEPromptDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..Handle Method
IEPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.Handle"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..IsDialogActive Method
IEPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection

[Missing <param name="dialogs"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IEPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..IsDialogActiveByTitle Method
IEPromptDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

IEPromptDialog Class
IEPromptDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog..::..WaitUntilHandled Method
IEPromptDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

IEPromptDialog Class
IEPromptDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEPromptDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog Properties
IEPromptDialog Class See Also Send Feedback

The IEPromptDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEPromptDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEPromptDialog Events
IEPromptDialog Class See Also Send Feedback

The IEPromptDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

IEPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEStrings Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings Members
IEStrings Class Constructors Methods Fields See Also Send Feedback

The IEStrings type exposes the following members.

Constructors

 | Name | Description
Public method | IEStrings | Initializes a new instance of the IEStrings class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultDownloadPath |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Cancel |
Close |
DownloadHasCompleted |
DownloadHasCompletedPattern |
DownloadingFromSiteStripped |
Open |
PercentDownloadedPattern |
ResourceModulePath |
RunningSecurityScan |
RunNoAmps |
Save |
SaveAsNoAmps |
WindowsInternetExplorer |

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEStrings Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings Constructor
IEStrings Class See Also Send Feedback
Initializes a new instance of the IEStrings class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public IEStrings()
Visual Basic
Public Sub New
Visual C++
public:
IEStrings()

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEStrings Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings Fields
IEStrings Class See Also Send Feedback

The IEStrings type exposes the following members.

Fields

Name | Description
Cancel |
Close |
DownloadHasCompleted |
DownloadHasCompletedPattern |
DownloadingFromSiteStripped |
Open |
PercentDownloadedPattern |
ResourceModulePath |
RunningSecurityScan |
RunNoAmps |
Save |
SaveAsNoAmps |
WindowsInternetExplorer |

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Cancel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..Cancel Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.Cancel"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string Cancel
Visual Basic
Public Shared ReadOnly Cancel As String
Visual C++
public:
static initonly String^ Cancel

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Close Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..Close Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.Close"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string Close
Visual Basic
Public Shared ReadOnly Close As String
Visual C++
public:
static initonly String^ Close

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DownloadHasCompleted Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..DownloadHasCompleted Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.DownloadHasCompleted"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string DownloadHasCompleted
Visual Basic
Public Shared ReadOnly DownloadHasCompleted As String
Visual C++
public:
static initonly String^ DownloadHasCompleted

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DownloadHasCompletedPattern Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..DownloadHasCompletedPattern Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.DownloadHasCompletedPattern"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string DownloadHasCompletedPattern
Visual Basic
Public Shared ReadOnly DownloadHasCompletedPattern As String
Visual C++
public:
static initonly String^ DownloadHasCompletedPattern

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


DownloadingFromSiteStripped Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..DownloadingFromSiteStripped Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.DownloadingFromSiteStripped"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string DownloadingFromSiteStripped
Visual Basic
Public Shared ReadOnly DownloadingFromSiteStripped As String
Visual C++
public:
static initonly String^ DownloadingFromSiteStripped

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Open Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..Open Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.Open"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string Open
Visual Basic
Public Shared ReadOnly Open As String
Visual C++
public:
static initonly String^ Open

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


PercentDownloadedPattern Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..PercentDownloadedPattern Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.PercentDownloadedPattern"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string PercentDownloadedPattern
Visual Basic
Public Shared ReadOnly PercentDownloadedPattern As String
Visual C++
public:
static initonly String^ PercentDownloadedPattern

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ResourceModulePath Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..ResourceModulePath Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.ResourceModulePath"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string ResourceModulePath
Visual Basic
Public Shared ReadOnly ResourceModulePath As String
Visual C++
public:
static initonly String^ ResourceModulePath

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


RunningSecurityScan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..RunningSecurityScan Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.RunningSecurityScan"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string RunningSecurityScan
Visual Basic
Public Shared ReadOnly RunningSecurityScan As String
Visual C++
public:
static initonly String^ RunningSecurityScan

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


RunNoAmps Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..RunNoAmps Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.RunNoAmps"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string RunNoAmps
Visual Basic
Public Shared ReadOnly RunNoAmps As String
Visual C++
public:
static initonly String^ RunNoAmps

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Save Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..Save Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.Save"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string Save
Visual Basic
Public Shared ReadOnly Save As String
Visual C++
public:
static initonly String^ Save

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsNoAmps Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..SaveAsNoAmps Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.SaveAsNoAmps"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string SaveAsNoAmps
Visual Basic
Public Shared ReadOnly SaveAsNoAmps As String
Visual C++
public:
static initonly String^ SaveAsNoAmps

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WindowsInternetExplorer Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..WindowsInternetExplorer Field
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "F:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.WindowsInternetExplorer"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static readonly string WindowsInternetExplorer
Visual Basic
Public Shared ReadOnly WindowsInternetExplorer As String
Visual C++
public:
static initonly String^ WindowsInternetExplorer

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IEStrings Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings Methods
IEStrings Class See Also Send Feedback

The IEStrings type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefaultDownloadPath |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


GetDefaultDownloadPath Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IEStrings..::..GetDefaultDownloadPath Method
IEStrings Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.GetDefaultDownloadPath"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii.Design (in ArtOfTest.WebAii.Design.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static string GetDefaultDownloadPath()
Visual Basic
Public Shared Function GetDefaultDownloadPath As String
Visual C++
public:
static String^ GetDefaultDownloadPath()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.IEStrings.GetDefaultDownloadPath"]

See Also

IEStrings Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


LogonDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog Members
LogonDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The LogonDialog type exposes the following members.

Constructors

 | Name | Description
Public method | LogonDialog(Browser, String, String, DialogButton) | Obsolete. Create a new LogonDialog handler.
Protected method | LogonDialog(Browser, String, String, DialogButton, Boolean) | Create a new LogonDialog handler.

Methods

 | Name | Description
 | CreateLogonDialog | Create a new LogonDialog handler.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether this dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Overrides BaseDialog..::..ToString()()()().)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Password | Gets/Sets Password
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | UserName | Gets/Sets UserName
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


LogonDialog Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog Constructor
LogonDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogonDialog(Browser, String, String, DialogButton) | Obsolete. Create a new LogonDialog handler.
Protected method | LogonDialog(Browser, String, String, DialogButton, Boolean) | Create a new LogonDialog handler.

See Also

LogonDialog Class
LogonDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


LogonDialog Constructor (Browser, String, String, DialogButton)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog Constructor (Browser, String, String, DialogButton)
LogonDialog Class See Also Send Feedback
Create a new LogonDialog handler.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("LogonDialog constructor is deprecated.  Use LogonDialog.CreateLogonDialog method instead.")]
public LogonDialog(
    Browser parentBrowser,
    string userName,
    string password,
    DialogButton dismissButton
)
Visual Basic
<ObsoleteAttribute("LogonDialog constructor is deprecated.  Use LogonDialog.CreateLogonDialog method instead.")> _
Public Sub New ( _
    parentBrowser As Browser, _
    userName As String, _
    password As String, _
    dismissButton As DialogButton _
)
Visual C++
[ObsoleteAttribute(L"LogonDialog constructor is deprecated.  Use LogonDialog.CreateLogonDialog method instead.")]
public:
LogonDialog(
    Browser^ parentBrowser,
    String^ userName,
    String^ password,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
userName
Type: System..::..String
The username to set.
password
Type: System..::..String
The password to set.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss this dialog.

See Also

LogonDialog Class
LogonDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


LogonDialog Constructor (Browser, String, String, DialogButton, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog Constructor (Browser, String, String, DialogButton, Boolean)
LogonDialog Class See Also Send Feedback
Create a new LogonDialog handler.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected LogonDialog(
    Browser parentBrowser,
    string userName,
    string password,
    DialogButton dismissButton,
    bool skipObsoleteMessage
)
Visual Basic
Protected Sub New ( _
    parentBrowser As Browser, _
    userName As String, _
    password As String, _
    dismissButton As DialogButton, _
    skipObsoleteMessage As Boolean _
)
Visual C++
protected:
LogonDialog(
    Browser^ parentBrowser,
    String^ userName,
    String^ password,
    DialogButton dismissButton,
    bool skipObsoleteMessage
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
userName
Type: System..::..String
The username to set.
password
Type: System..::..String
The password to set.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss this dialog.
skipObsoleteMessage
Type: System..::..Boolean
Not used, but keeps this internal constructor from producing "obsolete" compile warnings

See Also

LogonDialog Class
LogonDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


LogonDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog Fields
LogonDialog Class See Also Send Feedback

The LogonDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


LogonDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog Methods
LogonDialog Class See Also Send Feedback

The LogonDialog type exposes the following members.

Methods

 | Name | Description
 | CreateLogonDialog | Create a new LogonDialog handler.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether this dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Overrides BaseDialog..::..ToString()()()().)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateLogonDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog..::..CreateLogonDialog Method
LogonDialog Class See Also Send Feedback
Create a new LogonDialog handler.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static LogonDialog CreateLogonDialog(
    Browser parentBrowser,
    string userName,
    string password,
    DialogButton dismissButton
)
Visual Basic
Public Shared Function CreateLogonDialog ( _
    parentBrowser As Browser, _
    userName As String, _
    password As String, _
    dismissButton As DialogButton _
) As LogonDialog
Visual C++
public:
static LogonDialog^ CreateLogonDialog(
    Browser^ parentBrowser,
    String^ userName,
    String^ password,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
userName
Type: System..::..String
The username to set.
password
Type: System..::..String
The password to set.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss this dialog.

Return Value

A new LogonDialog handler

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog..::..Handle Method
LogonDialog Class See Also Send Feedback
Handle this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog..::..IsDialogActive Method
LogonDialog Class See Also Send Feedback
Whether this dialog is active or not.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs to check.

Return Value

True/False whether this dialog is active or not.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog..::..IsDialogActiveByTitle Method
LogonDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

LogonDialog Class
LogonDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


ToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog..::..ToString Method
LogonDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.LogonDialog.ToString"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.LogonDialog.ToString"]

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog..::..WaitUntilHandled Method
LogonDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

LogonDialog Class
LogonDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


LogonDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog Properties
LogonDialog Class See Also Send Feedback

The LogonDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Password | Gets/Sets Password
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | UserName | Gets/Sets UserName
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


LogonDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
LogonDialog Events
LogonDialog Class See Also Send Feedback

The LogonDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

LogonDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OnBeforeUnloadDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog Members
OnBeforeUnloadDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The OnBeforeUnloadDialog type exposes the following members.

Constructors

 | Name | Description
Protected method | OnBeforeUnloadDialog | Initializes a new instance of the OnBeforeUnloadDialog class

Methods

 | Name | Description
 | CreateOnBeforeUnloadDialog | Creates a OnBeforeUnloadDialog object to handle the dialog.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether the dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OnBeforeUnloadDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog Constructor
OnBeforeUnloadDialog Class See Also Send Feedback
Initializes a new instance of the OnBeforeUnloadDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected OnBeforeUnloadDialog(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
Protected Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
)
Visual C++
protected:
OnBeforeUnloadDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.OnBeforeUnloadDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.OnBeforeUnloadDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton)"]

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OnBeforeUnloadDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog Fields
OnBeforeUnloadDialog Class See Also Send Feedback

The OnBeforeUnloadDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OnBeforeUnloadDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog Methods
OnBeforeUnloadDialog Class See Also Send Feedback

The OnBeforeUnloadDialog type exposes the following members.

Methods

 | Name | Description
 | CreateOnBeforeUnloadDialog | Creates a OnBeforeUnloadDialog object to handle the dialog.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle this dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Whether the dialog is active or not. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateOnBeforeUnloadDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog..::..CreateOnBeforeUnloadDialog Method
OnBeforeUnloadDialog Class See Also Send Feedback
Creates a OnBeforeUnloadDialog object to handle the dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static OnBeforeUnloadDialog CreateOnBeforeUnloadDialog(
    Browser parentBrowser,
    DialogButton dismissButton
)
Visual Basic
Public Shared Function CreateOnBeforeUnloadDialog ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton _
) As OnBeforeUnloadDialog
Visual C++
public:
static OnBeforeUnloadDialog^ CreateOnBeforeUnloadDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The dismiss button to use.

Return Value

A new OnBeforeUnloadDialog object.

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog..::..Handle Method
OnBeforeUnloadDialog Class See Also Send Feedback
Handle this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Return Value

True/False whether this dialog was handled.

Implements

IDialog..::..Handle()()()()

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog..::..IsDialogActive Method
OnBeforeUnloadDialog Class See Also Send Feedback
Whether the dialog is active or not.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs on the desktop.

Return Value

True/False whether the dialog is active or not.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog..::..IsDialogActiveByTitle Method
OnBeforeUnloadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

OnBeforeUnloadDialog Class
OnBeforeUnloadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog..::..WaitUntilHandled Method
OnBeforeUnloadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

OnBeforeUnloadDialog Class
OnBeforeUnloadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


OnBeforeUnloadDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog Properties
OnBeforeUnloadDialog Class See Also Send Feedback

The OnBeforeUnloadDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OnBeforeUnloadDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OnBeforeUnloadDialog Events
OnBeforeUnloadDialog Class See Also Send Feedback

The OnBeforeUnloadDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

OnBeforeUnloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OpenFileDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog Members
OpenFileDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The OpenFileDialog type exposes the following members.

Constructors

 | Name | Description
Protected method | OpenFileDialog | Initializes a new instance of the OpenFileDialog class

Methods

 | Name | Description
 | CreateOpenFileDialog | Returns an Open File Dialog for use with WPF applications.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle the dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Is dialog active. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | _filePathToSet | the path of the file to open
Protected field | _titleToCheckFor | The title of the dialog to check.
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | FilePath | Gets/Sets the file path.
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OpenFileDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog Constructor
OpenFileDialog Class See Also Send Feedback
Initializes a new instance of the OpenFileDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected OpenFileDialog(
    WpfApplication application,
    DialogButton dismissButton,
    string filePath
)
Visual Basic
Protected Sub New ( _
    application As WpfApplication, _
    dismissButton As DialogButton, _
    filePath As String _
)
Visual C++
protected:
OpenFileDialog(
    WpfApplication^ application,
    DialogButton dismissButton,
    String^ filePath
)

Parameters

application
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="application"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.OpenFileDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.OpenFileDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

filePath
Type: System..::..String

[Missing <param name="filePath"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.OpenFileDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OpenFileDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog Fields
OpenFileDialog Class See Also Send Feedback

The OpenFileDialog type exposes the following members.

Fields

 | Name | Description
Protected field | _filePathToSet | the path of the file to open
Protected field | _titleToCheckFor | The title of the dialog to check.
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


_filePathToSet Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog..::.._filePathToSet Field
OpenFileDialog Class See Also Send Feedback
the path of the file to open

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected string _filePathToSet
Visual Basic
Protected _filePathToSet As String
Visual C++
protected:
String^ _filePathToSet

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


_titleToCheckFor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog..::.._titleToCheckFor Field
OpenFileDialog Class See Also Send Feedback
The title of the dialog to check.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected string _titleToCheckFor
Visual Basic
Protected _titleToCheckFor As String
Visual C++
protected:
String^ _titleToCheckFor

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OpenFileDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog Methods
OpenFileDialog Class See Also Send Feedback

The OpenFileDialog type exposes the following members.

Methods

 | Name | Description
 | CreateOpenFileDialog | Returns an Open File Dialog for use with WPF applications.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handle the dialog. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Is dialog active. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateOpenFileDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog..::..CreateOpenFileDialog Method
OpenFileDialog Class See Also Send Feedback
Returns an Open File Dialog for use with WPF applications.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static OpenFileDialog CreateOpenFileDialog(
    WpfApplication application,
    DialogButton dismissButton,
    string filePath
)
Visual Basic
Public Shared Function CreateOpenFileDialog ( _
    application As WpfApplication, _
    dismissButton As DialogButton, _
    filePath As String _
) As OpenFileDialog
Visual C++
public:
static OpenFileDialog^ CreateOpenFileDialog(
    WpfApplication^ application,
    DialogButton dismissButton,
    String^ filePath
)

Parameters

application
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="application"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.OpenFileDialog.CreateOpenFileDialog(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The dismiss button to use. Accepts OPEN or CANCEL.
filePath
Type: System..::..String
The location of the file to open.

Return Value

A new OpenFileDialog.

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog..::..Handle Method
OpenFileDialog Class See Also Send Feedback
Handle the dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog..::..IsDialogActive Method
OpenFileDialog Class See Also Send Feedback
Is dialog active.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The list of dialogs

Return Value

True/False whether the dialog is active or not.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog..::..IsDialogActiveByTitle Method
OpenFileDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

OpenFileDialog Class
OpenFileDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog..::..WaitUntilHandled Method
OpenFileDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

OpenFileDialog Class
OpenFileDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


OpenFileDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog Properties
OpenFileDialog Class See Also Send Feedback

The OpenFileDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | FilePath | Gets/Sets the file path.
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


OpenFileDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OpenFileDialog Events
OpenFileDialog Class See Also Send Feedback

The OpenFileDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

OpenFileDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


PrompDialogFactory Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PrompDialogFactory Members
PrompDialogFactory Class Methods See Also Send Feedback

The PrompDialogFactory type exposes the following members.

Methods

Name | Description
CreateDialog | Creates a prompt dialog.

See Also

PrompDialogFactory Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


PrompDialogFactory Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PrompDialogFactory Methods
PrompDialogFactory Class See Also Send Feedback

The PrompDialogFactory type exposes the following members.

Methods

Name | Description
CreateDialog | Creates a prompt dialog.

See Also

PrompDialogFactory Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PrompDialogFactory..::..CreateDialog Method
PrompDialogFactory Class See Also Send Feedback
Creates a prompt dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static BaseDialog CreateDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    string text
)
Visual Basic
Public Shared Function CreateDialog ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    text As String _
) As BaseDialog
Visual C++
public:
static BaseDialog^ CreateDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    String^ text
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The current browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
Dismiss button.
text
Type: System..::..String
Text of the propmpt.

Return Value

Prompt dialog for a specific browser.

See Also

PrompDialogFactory Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariDownloadDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog Members
SafariDownloadDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The SafariDownloadDialog type exposes the following members.

Constructors

 | Name | Description
Public method | SafariDownloadDialog | Constructs a new SafariDownloadDialog object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handles an open download dialog window according to the properties set on this object. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Determines whether or not one of the download dialog windows is currently open. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

SafariDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariDownloadDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog Constructor
SafariDownloadDialog Class See Also Send Feedback
Constructs a new SafariDownloadDialog object.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SafariDownloadDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    Desktop desktop
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    desktop As Desktop _
)
Visual C++
public:
SafariDownloadDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    Desktop^ desktop
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The browser object initiating the download.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
Which button of the download dialog to click to dismiss the dialog.
desktop
Type: ArtOfTest.WebAii.Core..::..Desktop
The desktop object used to search for Win32 windows.

See Also

SafariDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariDownloadDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog Fields
SafariDownloadDialog Class See Also Send Feedback

The SafariDownloadDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

SafariDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariDownloadDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog Methods
SafariDownloadDialog Class See Also Send Feedback

The SafariDownloadDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | Handles an open download dialog window according to the properties set on this object. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Determines whether or not one of the download dialog windows is currently open. (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

SafariDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog..::..Handle Method
SafariDownloadDialog Class See Also Send Feedback
Handles an open download dialog window according to the properties set on this object.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

SafariDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog..::..IsDialogActive Method
SafariDownloadDialog Class See Also Send Feedback
Determines whether or not one of the download dialog windows is currently open.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
The collection of Win32 windows to search for.

Return Value

True if one of the specified windows was found on the desktop and is attached to this browser.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

SafariDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog..::..IsDialogActiveByTitle Method
SafariDownloadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

SafariDownloadDialog Class
SafariDownloadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog..::..WaitUntilHandled Method
SafariDownloadDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

SafariDownloadDialog Class
SafariDownloadDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariDownloadDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog Properties
SafariDownloadDialog Class See Also Send Feedback

The SafariDownloadDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

SafariDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariDownloadDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariDownloadDialog Events
SafariDownloadDialog Class See Also Send Feedback

The SafariDownloadDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

SafariDownloadDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariPromptDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog Members
SafariPromptDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The SafariPromptDialog type exposes the following members.

Constructors

 | Name | Description
Public method | SafariPromptDialog | Initializes a new instance of the SafariPromptDialog class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

SafariPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariPromptDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog Constructor
SafariPromptDialog Class See Also Send Feedback
Initializes a new instance of the SafariPromptDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public SafariPromptDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    string text
)
Visual Basic
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    text As String _
)
Visual C++
public:
SafariPromptDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    String^ text
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SafariPromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SafariPromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SafariPromptDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

See Also

SafariPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariPromptDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog Fields
SafariPromptDialog Class See Also Send Feedback

The SafariPromptDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

SafariPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariPromptDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog Methods
SafariPromptDialog Class See Also Send Feedback

The SafariPromptDialog type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

SafariPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog..::..Handle Method
SafariPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SafariPromptDialog.Handle"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

SafariPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog..::..IsDialogActive Method
SafariPromptDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SafariPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection

[Missing <param name="dialogs"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SafariPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SafariPromptDialog.IsDialogActive(ArtOfTest.Common.Win32.WindowCollection)"]

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

SafariPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog..::..IsDialogActiveByTitle Method
SafariPromptDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

SafariPromptDialog Class
SafariPromptDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog..::..WaitUntilHandled Method
SafariPromptDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

SafariPromptDialog Class
SafariPromptDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariPromptDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog Properties
SafariPromptDialog Class See Also Send Feedback

The SafariPromptDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

SafariPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SafariPromptDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SafariPromptDialog Events
SafariPromptDialog Class See Also Send Feedback

The SafariPromptDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

SafariPromptDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Members
SaveAsDialog Class Constructors Methods Fields Properties Events See Also Send Feedback

The SaveAsDialog type exposes the following members.

Constructors

 | Name | Description
Public method | SaveAsDialog(Browser, DialogButton, String, Desktop) | Obsolete. Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
Protected method | SaveAsDialog(WpfApplication, DialogButton, String, Desktop) | Initializes a new instance of the SaveAsDialog class
Protected method | SaveAsDialog(Browser, DialogButton, String, Desktop, Boolean) | Initializes a new instance of the SaveAsDialog class

Methods

 | Name | Description
 | CreateSaveAsDialog(WpfApplication, DialogButton, String) |
 | CreateSaveAsDialog(Browser, DialogButton, String, Desktop) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | SaveFileName | Gets/Sets the save file name/path to use if you are saving the file. Else set to string.empty.
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

SaveAsDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Constructor
SaveAsDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveAsDialog(Browser, DialogButton, String, Desktop) | Obsolete. Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.
Protected method | SaveAsDialog(WpfApplication, DialogButton, String, Desktop) | Initializes a new instance of the SaveAsDialog class
Protected method | SaveAsDialog(Browser, DialogButton, String, Desktop, Boolean) | Initializes a new instance of the SaveAsDialog class

See Also

SaveAsDialog Class
SaveAsDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Constructor (Browser, DialogButton, String, Desktop)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Constructor (Browser, DialogButton, String, Desktop)
SaveAsDialog Class See Also Send Feedback
Create the dialog passing it the parent browser and the button to use to dismiss the instance of this dialog.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
[ObsoleteAttribute("SaveAsDialog constructor is deprecated. Use SaveAsDialog.CreateSaveAsDialog method instead.")]
public SaveAsDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    string fileName,
    Desktop desktopObject
)
Visual Basic
<ObsoleteAttribute("SaveAsDialog constructor is deprecated. Use SaveAsDialog.CreateSaveAsDialog method instead.")> _
Public Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    fileName As String, _
    desktopObject As Desktop _
)
Visual C++
[ObsoleteAttribute(L"SaveAsDialog constructor is deprecated. Use SaveAsDialog.CreateSaveAsDialog method instead.")]
public:
SaveAsDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    String^ fileName,
    Desktop^ desktopObject
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser
The parent browser.
dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton
The button to use to dismiss the dialog. Accepts SAVE or CANCEL.
fileName
Type: System..::..String
The full file path to the save location.
desktopObject
Type: ArtOfTest.WebAii.Core..::..Desktop
The desktop object.

See Also

SaveAsDialog Class
SaveAsDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Constructor (WpfApplication, DialogButton, String, Desktop)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Constructor (WpfApplication, DialogButton, String, Desktop)
SaveAsDialog Class See Also Send Feedback
Initializes a new instance of the SaveAsDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected SaveAsDialog(
    WpfApplication application,
    DialogButton dismissButton,
    string filename,
    Desktop desktopObject
)
Visual Basic
Protected Sub New ( _
    application As WpfApplication, _
    dismissButton As DialogButton, _
    filename As String, _
    desktopObject As Desktop _
)
Visual C++
protected:
SaveAsDialog(
    WpfApplication^ application,
    DialogButton dismissButton,
    String^ filename,
    Desktop^ desktopObject
)

Parameters

application
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="application"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

filename
Type: System..::..String

[Missing <param name="filename"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

desktopObject
Type: ArtOfTest.WebAii.Core..::..Desktop

[Missing <param name="desktopObject"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

See Also

SaveAsDialog Class
SaveAsDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Constructor (Browser, DialogButton, String, Desktop, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Constructor (Browser, DialogButton, String, Desktop, Boolean)
SaveAsDialog Class See Also Send Feedback
Initializes a new instance of the SaveAsDialog class

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected SaveAsDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    string fileName,
    Desktop desktopObject,
    bool skipObsoleteMessage
)
Visual Basic
Protected Sub New ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    fileName As String, _
    desktopObject As Desktop, _
    skipObsoleteMessage As Boolean _
)
Visual C++
protected:
SaveAsDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    String^ fileName,
    Desktop^ desktopObject,
    bool skipObsoleteMessage
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop,System.Boolean)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop,System.Boolean)"]

fileName
Type: System..::..String

[Missing <param name="fileName"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop,System.Boolean)"]

desktopObject
Type: ArtOfTest.WebAii.Core..::..Desktop

[Missing <param name="desktopObject"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop,System.Boolean)"]

skipObsoleteMessage
Type: System..::..Boolean

[Missing <param name="skipObsoleteMessage"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.#ctor(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop,System.Boolean)"]

See Also

SaveAsDialog Class
SaveAsDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Fields
SaveAsDialog Class See Also Send Feedback

The SaveAsDialog type exposes the following members.

Fields

 | Name | Description
Protected field | m_browserVersionMajor | The major version of the browser (Inherited from BaseDialog.)

See Also

SaveAsDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Methods
SaveAsDialog Class See Also Send Feedback

The SaveAsDialog type exposes the following members.

Methods

 | Name | Description
 | CreateSaveAsDialog(WpfApplication, DialogButton, String) |
 | CreateSaveAsDialog(Browser, DialogButton, String, Desktop) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Handle | This is called by the DialogMonitor whenever IsDialogActive returns true. (Overrides BaseDialog..::..Handle()()()().)
Public method | IsDialogActive | Check whether the dialog is present or not. This function is called by the dialogmonitor object (Overrides BaseDialog..::..IsDialogActive(WindowCollection).)
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitleAndTextContent | Gets whether a dialog is active or not using the title and caption of an inner window contained in the dialog (Inherited from BaseDialog.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnBeforeHandle | (Inherited from BaseDialog.)
Public method | ResetHandleCount | Resets the handle count back to zero. (Inherited from BaseDialog.)
Protected method | SetDialogWindow | Set the dialog window. (Inherited from BaseDialog.)
Public method | ToString | (Inherited from BaseDialog.)
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

SaveAsDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateSaveAsDialog Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog..::..CreateSaveAsDialog Method
SaveAsDialog Class See Also Send Feedback

Overload List

Name | Description
CreateSaveAsDialog(WpfApplication, DialogButton, String) |
CreateSaveAsDialog(Browser, DialogButton, String, Desktop) |

See Also

SaveAsDialog Class
SaveAsDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateSaveAsDialog Method (WpfApplication, DialogButton, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog..::..CreateSaveAsDialog Method (WpfApplication, DialogButton, String)
SaveAsDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static SaveAsDialog CreateSaveAsDialog(
    WpfApplication application,
    DialogButton dismissButton,
    string fileName
)
Visual Basic
Public Shared Function CreateSaveAsDialog ( _
    application As WpfApplication, _
    dismissButton As DialogButton, _
    fileName As String _
) As SaveAsDialog
Visual C++
public:
static SaveAsDialog^ CreateSaveAsDialog(
    WpfApplication^ application,
    DialogButton dismissButton,
    String^ fileName
)

Parameters

application
Type: ArtOfTest.WebAii.Wpf..::..WpfApplication

[Missing <param name="application"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

fileName
Type: System..::..String

[Missing <param name="fileName"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Wpf.WpfApplication,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String)"]

See Also

SaveAsDialog Class
CreateSaveAsDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


CreateSaveAsDialog Method (Browser, DialogButton, String, Desktop)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog..::..CreateSaveAsDialog Method (Browser, DialogButton, String, Desktop)
SaveAsDialog Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static SaveAsDialog CreateSaveAsDialog(
    Browser parentBrowser,
    DialogButton dismissButton,
    string fileName,
    Desktop desktopObject
)
Visual Basic
Public Shared Function CreateSaveAsDialog ( _
    parentBrowser As Browser, _
    dismissButton As DialogButton, _
    fileName As String, _
    desktopObject As Desktop _
) As SaveAsDialog
Visual C++
public:
static SaveAsDialog^ CreateSaveAsDialog(
    Browser^ parentBrowser,
    DialogButton dismissButton,
    String^ fileName,
    Desktop^ desktopObject
)

Parameters

parentBrowser
Type: ArtOfTest.WebAii.Core..::..Browser

[Missing <param name="parentBrowser"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

dismissButton
Type: ArtOfTest.WebAii.Win32.Dialogs..::..DialogButton

[Missing <param name="dismissButton"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

fileName
Type: System..::..String

[Missing <param name="fileName"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

desktopObject
Type: ArtOfTest.WebAii.Core..::..Desktop

[Missing <param name="desktopObject"/> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Win32.Dialogs.SaveAsDialog.CreateSaveAsDialog(ArtOfTest.WebAii.Core.Browser,ArtOfTest.WebAii.Win32.Dialogs.DialogButton,System.String,ArtOfTest.WebAii.Core.Desktop)"]

See Also

SaveAsDialog Class
CreateSaveAsDialog Overload
ArtOfTest.WebAii.Win32.Dialogs Namespace


Handle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog..::..Handle Method
SaveAsDialog Class See Also Send Feedback
This is called by the DialogMonitor whenever IsDialogActive returns true.

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void Handle()
Visual Basic
Public Overrides Sub Handle
Visual C++
public:
virtual void Handle() override

Implements

IDialog..::..Handle()()()()

See Also

SaveAsDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActive Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog..::..IsDialogActive Method
SaveAsDialog Class See Also Send Feedback
Check whether the dialog is present or not. This function is called by the dialogmonitor object

Namespace: ArtOfTest.WebAii.Win32.Dialogs
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool IsDialogActive(
    WindowCollection dialogs
)
Visual Basic
Public Overrides Function IsDialogActive ( _
    dialogs As WindowCollection _
) As Boolean
Visual C++
public:
virtual bool IsDialogActive(
    WindowCollection^ dialogs
) override

Parameters

dialogs
Type: ArtOfTest.Common.Win32..::..WindowCollection
This is a list of dialog passes in the by the DialogMonitor object.

Return Value

True/False whether this dialog is present.

Implements

IDialog..::..IsDialogActive(WindowCollection)

See Also

SaveAsDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


IsDialogActiveByTitle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog..::..IsDialogActiveByTitle Method
SaveAsDialog Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | IsDialogActiveByTitle(WindowCollection, String) | Get whether the dialog is active based on its title. (Inherited from BaseDialog.)
Protected method | IsDialogActiveByTitle(WindowCollection, String, Boolean) | Get whether the dialog is active base on its title. (Inherited from BaseDialog.)

See Also

SaveAsDialog Class
SaveAsDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


WaitUntilHandled Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog..::..WaitUntilHandled Method
SaveAsDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitUntilHandled()()()() | Waits for the dialog to be handled atleast once. Always performs a reset at the beginning of the wait. Will use the Settings.ClientReadyTimeout. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32) | Waits for the dialog to be handled atleast once. Always performs a reset at the being of the wait. (Inherited from BaseDialog.)
Public method | WaitUntilHandled(Int32, Int32, Boolean) | Waits for the dialog to be handled handleCount. You can optionally reset the handle count before waiting. (Inherited from BaseDialog.)

See Also

SaveAsDialog Class
SaveAsDialog Members
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Properties
SaveAsDialog Class See Also Send Feedback

The SaveAsDialog type exposes the following members.

Properties

 | Name | Description
Public property | CurrentState | Gets/Sets the dialog current state. State is handled my DialogMonitor. (Inherited from BaseDialog.)
Public property | DismissButton | Gets/Sets the dismiss button to use to knock down this dialog. (Inherited from BaseDialog.)
Public property | ErrorText | (Inherited from BaseDialog.)
Public property | HandleCount | Gets/Sets the number of times this dialog has been handled. (Inherited from BaseDialog.)
Public property | HandlerDelegate | Gets/Sets the dialog custom handler (Inherited from BaseDialog.)
Public property | InitializationTime | Gets/Sets the time to before handling of the dialog starts. (Inherited from BaseDialog.)
Protected property | ParentBrowser | The parent browser object of this dialog (Inherited from BaseDialog.)
Protected property | ParentProcessId | Parent process id of the browser and all the dialogs that this object should handle. (Inherited from BaseDialog.)
Public property | SaveFileName | Gets/Sets the save file name/path to use if you are saving the file. Else set to string.empty.
Public property | Tags | Custom tags for miscellaneous use. (Inherited from BaseDialog.)
Public property | Window | The dialog Window object. (Inherited from BaseDialog.)

See Also

SaveAsDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


SaveAsDialog Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SaveAsDialog Events
SaveAsDialog Class See Also Send Feedback

The SaveAsDialog type exposes the following members.

Events

 | Name | Description
Public event | BeforeHandle | (Inherited from BaseDialog.)

See Also

SaveAsDialog Class
ArtOfTest.WebAii.Win32.Dialogs Namespace


ArtOfTest.WebAii.Wpf Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Wpf Namespace
Send Feedback
Namespace for the core WPF features and functionality of the framework.

Classes

 | Class | Description
Public class | WpfApplication |
Public class | WpfWindow |


WpfApplication Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication Members
WpfApplication Class Methods Properties Events See Also Send Feedback

The WpfApplication type exposes the following members.

Methods

 | Name | Description
Public method | Detach()()()() |
Public method | Detach(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindow | Given a window caption get the corresponding window object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Quit |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForWindow(String) | Wait for a window to show up and be ready for automation. Uses the Settings.ClientReadyTimeout
Public method | WaitForWindow(String, Int32) | Wait for a window to show up and be ready for automation

Properties

 | Name | Description
Public property | AppFileName | Gets the application file name
Public property | DebugMode | Whether to open a trace listener output window.
Public property | HasExited |
Public property | MainWindow |
Public property | Manager | The Manager object that owns this application
Public property | Pid | The application's process id
Public property | Process |
Public property | QuitOnDetach | Whether to close all of this application's windows when the testing framework detaches from the application.
Public property | Windows | The application's collection of windows

Events

 | Name | Description
Public event | NewWindow |

See Also

WpfApplication Class
ArtOfTest.WebAii.Wpf Namespace


WpfApplication Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication Methods
WpfApplication Class See Also Send Feedback

The WpfApplication type exposes the following members.

Methods

 | Name | Description
Public method | Detach()()()() |
Public method | Detach(Boolean) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindow | Given a window caption get the corresponding window object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Quit |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WaitForWindow(String) | Wait for a window to show up and be ready for automation. Uses the Settings.ClientReadyTimeout
Public method | WaitForWindow(String, Int32) | Wait for a window to show up and be ready for automation

See Also

WpfApplication Class
ArtOfTest.WebAii.Wpf Namespace


Detach Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..Detach Method
WpfApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Detach()()()() |
Public method | Detach(Boolean) |

See Also

WpfApplication Class
WpfApplication Members
ArtOfTest.WebAii.Wpf Namespace


Detach Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..Detach Method
WpfApplication Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfApplication.Detach"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Detach()
Visual Basic
Public Sub Detach
Visual C++
public:
void Detach()

See Also

WpfApplication Class
Detach Overload
ArtOfTest.WebAii.Wpf Namespace


Detach Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..Detach Method (Boolean)
WpfApplication Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfApplication.Detach(System.Boolean)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Detach(
    bool quitOnDetach
)
Visual Basic
Public Sub Detach ( _
    quitOnDetach As Boolean _
)
Visual C++
public:
void Detach(
    bool quitOnDetach
)

Parameters

quitOnDetach
Type: System..::..Boolean

[Missing <param name="quitOnDetach"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfApplication.Detach(System.Boolean)"]

See Also

WpfApplication Class
Detach Overload
ArtOfTest.WebAii.Wpf Namespace


GetWindow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..GetWindow Method
WpfApplication Class See Also Send Feedback
Given a window caption get the corresponding window object.

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfWindow GetWindow(
    string caption
)
Visual Basic
Public Function GetWindow ( _
    caption As String _
) As WpfWindow
Visual C++
public:
WpfWindow^ GetWindow(
    String^ caption
)

Parameters

caption
Type: System..::..String
The full caption or partial caption of the window. (case-insensitive)

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfApplication.GetWindow(System.String)"]

See Also

WpfApplication Class
ArtOfTest.WebAii.Wpf Namespace


Quit Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..Quit Method
WpfApplication Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfApplication.Quit"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void Quit()
Visual Basic
Public Sub Quit
Visual C++
public:
void Quit()

See Also

WpfApplication Class
ArtOfTest.WebAii.Wpf Namespace


WaitForWindow Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..WaitForWindow Method
WpfApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WaitForWindow(String) | Wait for a window to show up and be ready for automation. Uses the Settings.ClientReadyTimeout
Public method | WaitForWindow(String, Int32) | Wait for a window to show up and be ready for automation

See Also

WpfApplication Class
WpfApplication Members
ArtOfTest.WebAii.Wpf Namespace


WaitForWindow Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..WaitForWindow Method (String)
WpfApplication Class See Also Send Feedback
Wait for a window to show up and be ready for automation. Uses the Settings.ClientReadyTimeout

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfWindow WaitForWindow(
    string caption
)
Visual Basic
Public Function WaitForWindow ( _
    caption As String _
) As WpfWindow
Visual C++
public:
WpfWindow^ WaitForWindow(
    String^ caption
)

Parameters

caption
Type: System..::..String
The caption of the window

Return Value

The window if found.

See Also

WpfApplication Class
WaitForWindow Overload
ArtOfTest.WebAii.Wpf Namespace


WaitForWindow Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..WaitForWindow Method (String, Int32)
WpfApplication Class See Also Send Feedback
Wait for a window to show up and be ready for automation

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public WpfWindow WaitForWindow(
    string caption,
    int timeout
)
Visual Basic
Public Function WaitForWindow ( _
    caption As String, _
    timeout As Integer _
) As WpfWindow
Visual C++
public:
WpfWindow^ WaitForWindow(
    String^ caption,
    int timeout
)

Parameters

caption
Type: System..::..String
The caption of the window
timeout
Type: System..::..Int32
The timeout to wait in msec.

Return Value

The window if found.

See Also

WpfApplication Class
WaitForWindow Overload
ArtOfTest.WebAii.Wpf Namespace


WpfApplication Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication Properties
WpfApplication Class See Also Send Feedback

The WpfApplication type exposes the following members.

Properties

 | Name | Description
Public property | AppFileName | Gets the application file name
Public property | DebugMode | Whether to open a trace listener output window.
Public property | HasExited |
Public property | MainWindow |
Public property | Manager | The Manager object that owns this application
Public property | Pid | The application's process id
Public property | Process |
Public property | QuitOnDetach | Whether to close all of this application's windows when the testing framework detaches from the application.
Public property | Windows | The application's collection of windows

See Also

WpfApplication Class
ArtOfTest.WebAii.Wpf Namespace


WpfApplication Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication Events
WpfApplication Class See Also Send Feedback

The WpfApplication type exposes the following members.

Events

 | Name | Description
Public event | NewWindow |

See Also

WpfApplication Class
ArtOfTest.WebAii.Wpf Namespace


NewWindow Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfApplication..::..NewWindow Event
WpfApplication Class See Also Send Feedback

[Missing <summary> documentation for "E:ArtOfTest.WebAii.Wpf.WpfApplication.NewWindow"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler<GenericEventArgs<WpfWindow>> NewWindow
Visual Basic
Public Event NewWindow As EventHandler(Of GenericEventArgs(Of WpfWindow))
Visual C++
public:
 event EventHandler<GenericEventArgs<WpfWindow^>^>^ NewWindow {
    void add (EventHandler<GenericEventArgs<WpfWindow^>^>^ value);
    void remove (EventHandler<GenericEventArgs<WpfWindow^>^>^ value);
}

See Also

WpfApplication Class
ArtOfTest.WebAii.Wpf Namespace


WpfWindow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow Members
WpfWindow Class Constructors Methods Properties Events See Also Send Feedback

The WpfWindow type exposes the following members.

Constructors

 | Name | Description
Protected method | WpfWindow | Initializes a new instance of the WpfWindow class

Methods

 | Name | Description
 | AddCustomAssembly |
Public method | Capture()()()() | (Overrides VisualTreeHost..::..Capture()()()().)
Public method | Capture(FrameworkElement) |
Protected method | DetachFromWindowEvents |
Public method | ElementFromPoint |
Public method | EnsureElementClickable |
Public method | EnsureStateIsCurrent | (Overrides VisualTreeHost..::..EnsureStateIsCurrent()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixAnnotationArea | (Inherited from VisualTreeHost.)
Public method | GetChildHosts | (Overrides VisualTreeHost..::..GetChildHosts()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Returns the root target element of this host. VisualTree.Root (Inherited from VisualTreeHost.)
Public method | GetScreenRectangle |
Public method | GetToolTipText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeCustomWpfTypes |
Protected method | IsActiveWindow |
Public method | LocateAllInHost | Locate all in host. (Inherited from VisualTreeHost.)
Public method | LocateInHost | Locate an element in this host or any of the children of this host using an expression. (Overrides VisualTreeHost..::..LocateInHost(array<String>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnWindowClosed |
Public method | PopulateVisualTree |
Public method | RefreshVisualTrees | Refreshes the main visual tree for the application as well as any open Popup visual trees.
Public method | ResizeContainer |
Public method | SetWindowFocus | (Overrides VisualTreeHost..::..SetWindowFocus()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateInterHostLinks | Silverlight hosts have no inter-host links to update (Inherited from VisualTreeHost.)
Public method | ValidateMouseLocation | (Overrides VisualTreeHost..::..ValidateMouseLocation(Point).)

Properties

 | Name | Description
Public property | Annotator | (Overrides VisualTreeHost..::..Annotator.)
Public property | Application |
Public property | Bounds |
Public property | ContentWindow | (Overrides VisualTreeHost..::..ContentWindow.)
Public property | Desktop |
Public property | EnableValidateMouseLocation |
Public property | Find |
Public property | FriendlyName | (Overrides VisualTreeHost..::..FriendlyName.)
Public property | IsConnected |
Public property | IsRecordingHost |
Public property | ManagedProxy |
Public property | Manager | (Overrides VisualTreeHost..::..Manager.)
Public property | OwnerApp | The SilverlightApp containing this visual tree (Inherited from VisualTreeHost.)
Protected property | Popups |
Public property | ShouldDisplayAnnotation | (Inherited from VisualTreeHost.)
Public property | StateHashCode | Gets a unique identifier that identifies the state of this host (Inherited from VisualTreeHost.)
Public property | TechnologyType | (Overrides VisualTreeHost..::..TechnologyType.)
Public property | UniqueId | (Overrides VisualTreeHost..::..UniqueId.)
Public property | VisualTree | The visual tree wrapped by this host object (Inherited from VisualTreeHost.)
Public property | Window | (Overrides VisualTreeHost..::..Window.)

Events

 | Name | Description
Public event | WindowClosed | This event is triggered when the wrapped window closes

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


WpfWindow Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow Constructor
WpfWindow Class See Also Send Feedback
Initializes a new instance of the WpfWindow class

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected WpfWindow(
    IntPtr hwnd
)
Visual Basic
Protected Sub New ( _
    hwnd As IntPtr _
)
Visual C++
protected:
WpfWindow(
    IntPtr hwnd
)

Parameters

hwnd
Type: System..::..IntPtr

[Missing <param name="hwnd"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.#ctor(System.IntPtr)"]

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


WpfWindow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow Methods
WpfWindow Class See Also Send Feedback

The WpfWindow type exposes the following members.

Methods

 | Name | Description
 | AddCustomAssembly |
Public method | Capture()()()() | (Overrides VisualTreeHost..::..Capture()()()().)
Public method | Capture(FrameworkElement) |
Protected method | DetachFromWindowEvents |
Public method | ElementFromPoint |
Public method | EnsureElementClickable |
Public method | EnsureStateIsCurrent | (Overrides VisualTreeHost..::..EnsureStateIsCurrent()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixAnnotationArea | (Inherited from VisualTreeHost.)
Public method | GetChildHosts | (Overrides VisualTreeHost..::..GetChildHosts()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Returns the root target element of this host. VisualTree.Root (Inherited from VisualTreeHost.)
Public method | GetScreenRectangle |
Public method | GetToolTipText |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeCustomWpfTypes |
Protected method | IsActiveWindow |
Public method | LocateAllInHost | Locate all in host. (Inherited from VisualTreeHost.)
Public method | LocateInHost | Locate an element in this host or any of the children of this host using an expression. (Overrides VisualTreeHost..::..LocateInHost(array<String>[]()[][]).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnWindowClosed |
Public method | PopulateVisualTree |
Public method | RefreshVisualTrees | Refreshes the main visual tree for the application as well as any open Popup visual trees.
Public method | ResizeContainer |
Public method | SetWindowFocus | (Overrides VisualTreeHost..::..SetWindowFocus()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateInterHostLinks | Silverlight hosts have no inter-host links to update (Inherited from VisualTreeHost.)
Public method | ValidateMouseLocation | (Overrides VisualTreeHost..::..ValidateMouseLocation(Point).)

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


AddCustomAssembly Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..AddCustomAssembly Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.AddCustomAssembly(System.String,System.String)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public static void AddCustomAssembly(
    string assemblyName,
    string assemblyPath
)
Visual Basic
Public Shared Sub AddCustomAssembly ( _
    assemblyName As String, _
    assemblyPath As String _
)
Visual C++
public:
static void AddCustomAssembly(
    String^ assemblyName,
    String^ assemblyPath
)

Parameters

assemblyName
Type: System..::..String

[Missing <param name="assemblyName"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.AddCustomAssembly(System.String,System.String)"]

assemblyPath
Type: System..::..String

[Missing <param name="assemblyPath"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.AddCustomAssembly(System.String,System.String)"]

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..Capture Method
WpfWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | (Overrides VisualTreeHost..::..Capture()()()().)
Public method | Capture(FrameworkElement) |

See Also

WpfWindow Class
WpfWindow Members
ArtOfTest.WebAii.Wpf Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..Capture Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.Capture"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override Bitmap Capture()
Visual Basic
Public Overrides Function Capture As Bitmap
Visual C++
public:
virtual Bitmap^ Capture() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.Capture"]

Implements

IAutomationHost..::..Capture()()()()
IAutomationHost..::..Capture()()()()

See Also

WpfWindow Class
Capture Overload
ArtOfTest.WebAii.Wpf Namespace


Capture Method (FrameworkElement)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..Capture Method (FrameworkElement)
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.Capture(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public Bitmap Capture(
    FrameworkElement element
)
Visual Basic
Public Function Capture ( _
    element As FrameworkElement _
) As Bitmap
Visual C++
public:
virtual Bitmap^ Capture(
    FrameworkElement^ element
) sealed

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.Capture(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.Capture(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Implements

IApplication..::..Capture(FrameworkElement)

See Also

WpfWindow Class
Capture Overload
ArtOfTest.WebAii.Wpf Namespace


DetachFromWindowEvents Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..DetachFromWindowEvents Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.DetachFromWindowEvents"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected void DetachFromWindowEvents()
Visual Basic
Protected Sub DetachFromWindowEvents
Visual C++
protected:
void DetachFromWindowEvents()

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


ElementFromPoint Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..ElementFromPoint Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ElementFromPoint(System.Int32,System.Int32)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual FrameworkElement ElementFromPoint(
    int x,
    int y
)
Visual Basic
Public Overridable Function ElementFromPoint ( _
    x As Integer, _
    y As Integer _
) As FrameworkElement
Visual C++
public:
virtual FrameworkElement^ ElementFromPoint(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ElementFromPoint(System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ElementFromPoint(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ElementFromPoint(System.Int32,System.Int32)"]

Implements

IApplication..::..ElementFromPoint(Int32, Int32)

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


EnsureElementClickable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..EnsureElementClickable Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.EnsureElementClickable(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void EnsureElementClickable(
    FrameworkElement element
)
Visual Basic
Public Sub EnsureElementClickable ( _
    element As FrameworkElement _
)
Visual C++
public:
virtual void EnsureElementClickable(
    FrameworkElement^ element
) sealed

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.EnsureElementClickable(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Implements

IApplication..::..EnsureElementClickable(FrameworkElement)

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


EnsureStateIsCurrent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..EnsureStateIsCurrent Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.EnsureStateIsCurrent"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void EnsureStateIsCurrent()
Visual Basic
Public Overrides Sub EnsureStateIsCurrent
Visual C++
public:
virtual void EnsureStateIsCurrent() override

Implements

IAutomationHost..::..EnsureStateIsCurrent()()()()
IAutomationHost..::..EnsureStateIsCurrent()()()()

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


GetChildHosts Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..GetChildHosts Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.GetChildHosts"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override IAutomationHost[] GetChildHosts()
Visual Basic
Public Overrides Function GetChildHosts As IAutomationHost()
Visual C++
public:
virtual array<IAutomationHost^>^ GetChildHosts() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.GetChildHosts"]

Implements

IAutomationHost..::..GetChildHosts()()()()
IAutomationHost..::..GetChildHosts()()()()

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


GetScreenRectangle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..GetScreenRectangle Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.GetScreenRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Rectangle GetScreenRectangle(
    FrameworkElement element
)
Visual Basic
Public Overridable Function GetScreenRectangle ( _
    element As FrameworkElement _
) As Rectangle
Visual C++
public:
virtual Rectangle GetScreenRectangle(
    FrameworkElement^ element
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.GetScreenRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.GetScreenRectangle(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Implements

IApplication..::..GetScreenRectangle(FrameworkElement)

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


GetToolTipText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..GetToolTipText Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.GetToolTipText(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual string GetToolTipText(
    FrameworkElement element
)
Visual Basic
Public Overridable Function GetToolTipText ( _
    element As FrameworkElement _
) As String
Visual C++
public:
virtual String^ GetToolTipText(
    FrameworkElement^ element
)

Parameters

element
Type: ArtOfTest.WebAii.Silverlight..::..FrameworkElement

[Missing <param name="element"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.GetToolTipText(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.GetToolTipText(ArtOfTest.WebAii.Silverlight.FrameworkElement)"]

Implements

IApplication..::..GetToolTipText(FrameworkElement)

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


InitializeCustomWpfTypes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..InitializeCustomWpfTypes Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.InitializeCustomWpfTypes"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void InitializeCustomWpfTypes()
Visual Basic
Public Sub InitializeCustomWpfTypes
Visual C++
public:
void InitializeCustomWpfTypes()

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


IsActiveWindow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..IsActiveWindow Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.IsActiveWindow"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual bool IsActiveWindow()
Visual Basic
Protected Overridable Function IsActiveWindow As Boolean
Visual C++
protected:
virtual bool IsActiveWindow()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.IsActiveWindow"]

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


LocateInHost Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..LocateInHost Method
WpfWindow Class See Also Send Feedback
Locate an element in this host or any of the children of this host using an expression.

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override ITargetElement LocateInHost(
    string[] expression
)
Visual Basic
Public Overrides Function LocateInHost ( _
    expression As String() _
) As ITargetElement
Visual C++
public:
virtual ITargetElement^ LocateInHost(
    array<String^>^ expression
) override

Parameters

expression
Type: array< System..::..String >[]()[][]

[Missing <param name="expression"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.LocateInHost(System.String[])"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.LocateInHost(System.String[])"]

Implements

ISupportSearchHost..::..LocateInHost(array<String>[]()[][])
ISupportSearchHost..::..LocateInHost(array<String>[]()[][])

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


OnWindowClosed Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..OnWindowClosed Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.OnWindowClosed"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
protected virtual void OnWindowClosed()
Visual Basic
Protected Overridable Sub OnWindowClosed
Visual C++
protected:
virtual void OnWindowClosed()

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


PopulateVisualTree Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..PopulateVisualTree Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.PopulateVisualTree"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual VisualTree PopulateVisualTree()
Visual Basic
Public Overridable Function PopulateVisualTree As VisualTree
Visual C++
public:
virtual VisualTree^ PopulateVisualTree()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.PopulateVisualTree"]

Implements

IApplication..::..PopulateVisualTree()()()()

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


RefreshVisualTrees Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..RefreshVisualTrees Method
WpfWindow Class See Also Send Feedback
Refreshes the main visual tree for the application as well as any open Popup visual trees.

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void RefreshVisualTrees()
Visual Basic
Public Sub RefreshVisualTrees
Visual C++
public:
virtual void RefreshVisualTrees() sealed

Implements

IApplication..::..RefreshVisualTrees()()()()

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


ResizeContainer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..ResizeContainer Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void ResizeContainer(
    int x,
    int y,
    int width,
    int height
)
Visual Basic
Public Sub ResizeContainer ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
virtual void ResizeContainer(
    int x,
    int y,
    int width,
    int height
) sealed

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ResizeContainer(System.Int32,System.Int32,System.Int32,System.Int32)"]

Implements

IApplication..::..ResizeContainer(Int32, Int32, Int32, Int32)

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


SetWindowFocus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..SetWindowFocus Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.SetWindowFocus"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override bool SetWindowFocus()
Visual Basic
Public Overrides Function SetWindowFocus As Boolean
Visual C++
public:
virtual bool SetWindowFocus() override

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.SetWindowFocus"]

Implements

IAutomationHost..::..SetWindowFocus()()()()
IAutomationHost..::..SetWindowFocus()()()()

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


ValidateMouseLocation Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..ValidateMouseLocation Method
WpfWindow Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ValidateMouseLocation(System.Drawing.Point)"]

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public override void ValidateMouseLocation(
    Point point
)
Visual Basic
Public Overrides Sub ValidateMouseLocation ( _
    point As Point _
)
Visual C++
public:
virtual void ValidateMouseLocation(
    Point point
) override

Parameters

point
Type: System.Drawing..::..Point

[Missing <param name="point"/> documentation for "M:ArtOfTest.WebAii.Wpf.WpfWindow.ValidateMouseLocation(System.Drawing.Point)"]

Implements

IAutomationHost..::..ValidateMouseLocation(Point)
IAutomationHost..::..ValidateMouseLocation(Point)

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


WpfWindow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow Properties
WpfWindow Class See Also Send Feedback

The WpfWindow type exposes the following members.

Properties

 | Name | Description
Public property | Annotator | (Overrides VisualTreeHost..::..Annotator.)
Public property | Application |
Public property | Bounds |
Public property | ContentWindow | (Overrides VisualTreeHost..::..ContentWindow.)
Public property | Desktop |
Public property | EnableValidateMouseLocation |
Public property | Find |
Public property | FriendlyName | (Overrides VisualTreeHost..::..FriendlyName.)
Public property | IsConnected |
Public property | IsRecordingHost |
Public property | ManagedProxy |
Public property | Manager | (Overrides VisualTreeHost..::..Manager.)
Public property | OwnerApp | The SilverlightApp containing this visual tree (Inherited from VisualTreeHost.)
Protected property | Popups |
Public property | ShouldDisplayAnnotation | (Inherited from VisualTreeHost.)
Public property | StateHashCode | Gets a unique identifier that identifies the state of this host (Inherited from VisualTreeHost.)
Public property | TechnologyType | (Overrides VisualTreeHost..::..TechnologyType.)
Public property | UniqueId | (Overrides VisualTreeHost..::..UniqueId.)
Public property | VisualTree | The visual tree wrapped by this host object (Inherited from VisualTreeHost.)
Public property | Window | (Overrides VisualTreeHost..::..Window.)

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


WpfWindow Events

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow Events
WpfWindow Class See Also Send Feedback

The WpfWindow type exposes the following members.

Events

 | Name | Description
Public event | WindowClosed | This event is triggered when the wrapped window closes

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


WindowClosed Event

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WpfWindow..::..WindowClosed Event
WpfWindow Class See Also Send Feedback
This event is triggered when the wrapped window closes

Namespace: ArtOfTest.WebAii.Wpf
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public event EventHandler WindowClosed
Visual Basic
Public Event WindowClosed As EventHandler
Visual C++
public:
 event EventHandler^ WindowClosed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

WpfWindow Class
ArtOfTest.WebAii.Wpf Namespace


ArtOfTest.WebAii.Xaml Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ArtOfTest.WebAii.Xaml Namespace
Send Feedback
Namespace for the core XAML features and functionality of the framework.

Classes

 | Class | Description
Public class | VisualTreeHost | Abstraction for something that contains a visual tree root. Silverlight applications and Popups.


VisualTreeHost Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost Members
VisualTreeHost Class Methods Properties See Also Send Feedback

The VisualTreeHost type exposes the following members.

Methods

 | Name | Description
Public method | Capture |
Public method | EnsureStateIsCurrent | Will force the VisualTree to Refresh. Identical to VisualTree.Refresh().
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixAnnotationArea |
Public method | GetChildHosts | Get all contained hosts.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Returns the root target element of this host. VisualTree.Root
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateAllInHost | Locate all in host.
Public method | LocateInHost | Locate an element from the root of this host using an expression.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetWindowFocus |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateInterHostLinks | Silverlight hosts have no inter-host links to update
Public method | ValidateMouseLocation |

Properties

 | Name | Description
Public property | Annotator |
Public property | ContentWindow |
Public property | FriendlyName | Returns a friendly name for this host
Public property | Manager |
Public property | OwnerApp | The SilverlightApp containing this visual tree
Public property | ShouldDisplayAnnotation |
Public property | StateHashCode | Gets a unique identifier that identifies the state of this host
Public property | TechnologyType | VisualTreeHosts are only used for Silverlight
Public property | UniqueId | A unique identifier that identifies this plugin instance. This id is updated only when the plug-in is reloaded on a postback or a browser refresh.
Public property | VisualTree | The visual tree wrapped by this host object
Public property | Window |

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


VisualTreeHost Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost Methods
VisualTreeHost Class See Also Send Feedback

The VisualTreeHost type exposes the following members.

Methods

 | Name | Description
Public method | Capture |
Public method | EnsureStateIsCurrent | Will force the VisualTree to Refresh. Identical to VisualTree.Refresh().
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FixAnnotationArea |
Public method | GetChildHosts | Get all contained hosts.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostRoot | Returns the root target element of this host. VisualTree.Root
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LocateAllInHost | Locate all in host.
Public method | LocateInHost | Locate an element from the root of this host using an expression.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetWindowFocus |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateInterHostLinks | Silverlight hosts have no inter-host links to update
Public method | ValidateMouseLocation |

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


Capture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..Capture Method
VisualTreeHost Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.Capture"]

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Bitmap Capture()
Visual Basic
Public Overridable Function Capture As Bitmap
Visual C++
public:
virtual Bitmap^ Capture()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.Capture"]

Implements

IAutomationHost..::..Capture()()()()

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


EnsureStateIsCurrent Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..EnsureStateIsCurrent Method
VisualTreeHost Class See Also Send Feedback
Will force the VisualTree to Refresh. Identical to VisualTree.Refresh().

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void EnsureStateIsCurrent()
Visual Basic
Public Overridable Sub EnsureStateIsCurrent
Visual C++
public:
virtual void EnsureStateIsCurrent()

Implements

IAutomationHost..::..EnsureStateIsCurrent()()()()

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


FixAnnotationArea Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..FixAnnotationArea Method
VisualTreeHost Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.FixAnnotationArea(System.Drawing.Rectangle)"]

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual Rectangle FixAnnotationArea(
    Rectangle area
)
Visual Basic
Public Overridable Function FixAnnotationArea ( _
    area As Rectangle _
) As Rectangle
Visual C++
public:
virtual Rectangle FixAnnotationArea(
    Rectangle area
)

Parameters

area
Type: System.Drawing..::..Rectangle

[Missing <param name="area"/> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.FixAnnotationArea(System.Drawing.Rectangle)"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.FixAnnotationArea(System.Drawing.Rectangle)"]

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


GetChildHosts Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..GetChildHosts Method
VisualTreeHost Class See Also Send Feedback
Get all contained hosts.

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IAutomationHost[] GetChildHosts()
Visual Basic
Public Overridable Function GetChildHosts As IAutomationHost()
Visual C++
public:
virtual array<IAutomationHost^>^ GetChildHosts()

Return Value

Contained Hosts

Implements

IAutomationHost..::..GetChildHosts()()()()

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


GetHostRoot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..GetHostRoot Method
VisualTreeHost Class See Also Send Feedback
Returns the root target element of this host. VisualTree.Root

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual ITargetElement GetHostRoot()
Visual Basic
Public Overridable Function GetHostRoot As ITargetElement
Visual C++
public:
virtual ITargetElement^ GetHostRoot()

Return Value

The VisualTree.Root element

Implements

IAutomationHost..::..GetHostRoot()()()()

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


LocateAllInHost Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..LocateAllInHost Method
VisualTreeHost Class See Also Send Feedback
Locate all in host.

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual IList<ITargetElement> LocateAllInHost(
    string[] expression
)
Visual Basic
Public Overridable Function LocateAllInHost ( _
    expression As String() _
) As IList(Of ITargetElement)
Visual C++
public:
virtual IList<ITargetElement^>^ LocateAllInHost(
    array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]
The expression to use.

Return Value

The list of target elements

Implements

ISupportSearchHost..::..LocateAllInHost(array<String>[]()[][])

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


LocateInHost Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..LocateInHost Method
VisualTreeHost Class See Also Send Feedback
Locate an element from the root of this host using an expression.

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual ITargetElement LocateInHost(
    string[] expression
)
Visual Basic
Public Overridable Function LocateInHost ( _
    expression As String() _
) As ITargetElement
Visual C++
public:
virtual ITargetElement^ LocateInHost(
    array<String^>^ expression
)

Parameters

expression
Type: array< System..::..String >[]()[][]

[Missing <param name="expression"/> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.LocateInHost(System.String[])"]

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.LocateInHost(System.String[])"]

Implements

ISupportSearchHost..::..LocateInHost(array<String>[]()[][])

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


SetWindowFocus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..SetWindowFocus Method
VisualTreeHost Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.SetWindowFocus"]

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual bool SetWindowFocus()
Visual Basic
Public Overridable Function SetWindowFocus As Boolean
Visual C++
public:
virtual bool SetWindowFocus()

Return Value

[Missing <returns> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.SetWindowFocus"]

Implements

IAutomationHost..::..SetWindowFocus()()()()

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


UpdateInterHostLinks Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..UpdateInterHostLinks Method
VisualTreeHost Class See Also Send Feedback
Silverlight hosts have no inter-host links to update

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public void UpdateInterHostLinks()
Visual Basic
Public Sub UpdateInterHostLinks
Visual C++
public:
virtual void UpdateInterHostLinks() sealed

Implements

IAutomationHost..::..UpdateInterHostLinks()()()()

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


ValidateMouseLocation Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost..::..ValidateMouseLocation Method
VisualTreeHost Class See Also Send Feedback

[Missing <summary> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.ValidateMouseLocation(System.Drawing.Point)"]

Namespace: ArtOfTest.WebAii.Xaml
Assembly: ArtOfTest.WebAii (in ArtOfTest.WebAii.dll) Version: 2012.2.904.0 (2012.2.904.0)

Syntax

C#
public virtual void ValidateMouseLocation(
    Point point
)
Visual Basic
Public Overridable Sub ValidateMouseLocation ( _
    point As Point _
)
Visual C++
public:
virtual void ValidateMouseLocation(
    Point point
)

Parameters

point
Type: System.Drawing..::..Point

[Missing <param name="point"/> documentation for "M:ArtOfTest.WebAii.Xaml.VisualTreeHost.ValidateMouseLocation(System.Drawing.Point)"]

Implements

IAutomationHost..::..ValidateMouseLocation(Point)

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


VisualTreeHost Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
VisualTreeHost Properties
VisualTreeHost Class See Also Send Feedback

The VisualTreeHost type exposes the following members.

Properties

 | Name | Description
Public property | Annotator |
Public property | ContentWindow |
Public property | FriendlyName | Returns a friendly name for this host
Public property | Manager |
Public property | OwnerApp | The SilverlightApp containing this visual tree
Public property | ShouldDisplayAnnotation |
Public property | StateHashCode | Gets a unique identifier that identifies the state of this host
Public property | TechnologyType | VisualTreeHosts are only used for Silverlight
Public property | UniqueId | A unique identifier that identifies this plugin instance. This id is updated only when the plug-in is reloaded on a postback or a browser refresh.
Public property | VisualTree | The visual tree wrapped by this host object
Public property | Window |

See Also

VisualTreeHost Class
ArtOfTest.WebAii.Xaml Namespace


Telerik.TestingFramework.Controls.KendoUI Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Telerik.TestingFramework.Controls.KendoUI Namespace
Send Feedback
Namespace for all the Kendo UI control wrapper classes.

Classes

 | Class | Description
Public class | CommonHelper | Represents a common helper class.
Public class | IndexesCollection | Represents a custom collection of integer values, serving as a return type for RadGrid wrapper properties.
Public class | KendoCalendar | KendoCalendarr control.
Public class | KendoCalendarConstants | String constatns of the Calendar(Css classes, Id prefix, etc).
Public class | KendoControlAssert | Represents the base class for assertion of RadControls wrappers.
Public class | KendoExtendedInput |
Public class | KendoGrid |
Public class | KendoGridConstants |
Public class | KendoGridDataCell |
Public class | KendoGridDataItem |
Public class | KendoGridGroup |
Public class | KendoInput |
Public class | KendoInputConstants |
Public class | KendoListView | KendoListView control.
Public class | KendoListViewConstants | String constatns of the TabStrip(Css classes, Id prefix, etc).
Public class | KendoListViewItem | KendoListViewItem control.
Public class | KendoMenu | KendoMenu control.
Public class | KendoMenuConstants | String constatns of the Menu(Css classes, Id prefix, etc).
Public class | KendoMenuItem |
Public class | KendoMenuOption |
Public class | KendoPager | KendoPager control.
Public class | KendoPagerConstants | String constatns of the PanelBar(Css classes, Id prefix, etc).
Public class | KendoPanel |
Public class | KendoPanelBar | KendoPanelBar control.
Public class | KendoPanelBarConstants | String constatns of the PanelBar(Css classes, Id prefix, etc).
Public class | KendoTab | KendoTab control.
Public class | KendoTabStrip | KendoTabStrip control.
Public class | KendoTabStripConstants | String constatns of the TabStrip(Css classes, Id prefix, etc).
Public class | KendoTreeNode |
Public class | KendoTreeView | KendoTreeview control.
Public class | KendoTreeViewConstants | String constatns of the Menu(Css classes, Id prefix, etc).
Public class | KendoWindow | KendoWindow control.
Public class | KendoWindowConstants | String constatns of the window(Css classes, Id prefix, etc).

Enumerations

 | Enumeration | Description
Public enumeration | KendoInputControlType | Control type of the Input.
Public enumeration | MenuOrientationType | Type of menu orientation type.


CommonHelper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper Members
CommonHelper Class Methods See Also Send Feedback

The CommonHelper type exposes the following members.

Methods

Name | Description
GenArray | A helper method to generate an array of integers with given count.
GetControl | Get the HtmlControl type of the given element.
GetControlType | Get the control type of the given element.
GetInputControl | Get the HtmlInputControl type of the given element.
GetInputControlType | Get the input control type of the given element.
RemoveWhiteSpaces | A helper method for removing whitespaces from strings.

See Also

CommonHelper Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CommonHelper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper Methods
CommonHelper Class See Also Send Feedback

The CommonHelper type exposes the following members.

Methods

Name | Description
GenArray | A helper method to generate an array of integers with given count.
GetControl | Get the HtmlControl type of the given element.
GetControlType | Get the control type of the given element.
GetInputControl | Get the HtmlInputControl type of the given element.
GetInputControlType | Get the input control type of the given element.
RemoveWhiteSpaces | A helper method for removing whitespaces from strings.

See Also

CommonHelper Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GenArray Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GenArray Method
CommonHelper Class See Also Send Feedback
A helper method to generate an array of integers with given count.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public static int[] GenArray(
    int count
)
Visual Basic
Public Shared Function GenArray ( _
    count As Integer _
) As Integer()
Visual C++
public:
static array<int>^ GenArray(
    int count
)

Parameters

count
Type: System..::..Int32
The count of the array elements.

Return Value

An array of integers with given count.

See Also

CommonHelper Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetControl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GetControl Method
CommonHelper Class See Also Send Feedback
Get the HtmlControl type of the given element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public static HtmlControl GetControl(
    Element element
)
Visual Basic
Public Shared Function GetControl ( _
    element As Element _
) As HtmlControl
Visual C++
public:
static HtmlControl^ GetControl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to get the control type of.

Return Value

The HtmlControl type of the given element.

See Also

CommonHelper Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetControlType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GetControlType Method
CommonHelper Class See Also Send Feedback
Get the control type of the given element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public static Type GetControlType(
    Element element
)
Visual Basic
Public Shared Function GetControlType ( _
    element As Element _
) As Type
Visual C++
public:
static Type^ GetControlType(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to get the control type of.

Return Value

The control type of the given element.

See Also

CommonHelper Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetInputControl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GetInputControl Method
CommonHelper Class See Also Send Feedback
Get the HtmlInputControl type of the given element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public static HtmlInputControl GetInputControl(
    Element element
)
Visual Basic
Public Shared Function GetInputControl ( _
    element As Element _
) As HtmlInputControl
Visual C++
public:
static HtmlInputControl^ GetInputControl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to get the control type of.

Return Value

The HtmlInputControl type of the given element.

See Also

CommonHelper Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetInputControlType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GetInputControlType Method
CommonHelper Class See Also Send Feedback
Get the input control type of the given element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public static Type GetInputControlType(
    Element element
)
Visual Basic
Public Shared Function GetInputControlType ( _
    element As Element _
) As Type
Visual C++
public:
static Type^ GetInputControlType(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to get the input control type of.

Return Value

The input control type of the given element.

See Also

CommonHelper Class
Telerik.TestingFramework.Controls.KendoUI Namespace


RemoveWhiteSpaces Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..RemoveWhiteSpaces Method
CommonHelper Class See Also Send Feedback
A helper method for removing whitespaces from strings.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public static string RemoveWhiteSpaces(
    string stringToModify
)
Visual Basic
Public Shared Function RemoveWhiteSpaces ( _
    stringToModify As String _
) As String
Visual C++
public:
static String^ RemoveWhiteSpaces(
    String^ stringToModify
)

Parameters

stringToModify
Type: System..::..String
The string to modify.

Return Value

The string without whitespaces.

See Also

CommonHelper Class
Telerik.TestingFramework.Controls.KendoUI Namespace


IndexesCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Members
IndexesCollection Class Constructors Methods Properties See Also Send Feedback

The IndexesCollection type exposes the following members.

Constructors

 | Name | Description
Public method | IndexesCollection()()()() | Initializes a new instance of the IndexesCollection class.
Public method | IndexesCollection(IList<(Of <<'(Int32>)>>)) | Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified list.
Public method | IndexesCollection(array<Int32>[]()[][]) | Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified int array.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | ConvertToString | Converts the collection to comma separated string.
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | InitializeCodeExpression | Generates initialization code for the indexes collection.
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Matches | Compares the items of the current collection with the passed one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)

See Also

IndexesCollection Class
Telerik.TestingFramework.Controls.KendoUI Namespace


IndexesCollection Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Constructor
IndexesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexesCollection()()()() | Initializes a new instance of the IndexesCollection class.
Public method | IndexesCollection(IList<(Of <<'(Int32>)>>)) | Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified list.
Public method | IndexesCollection(array<Int32>[]()[][]) | Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified int array.

See Also

IndexesCollection Class
IndexesCollection Members
Telerik.TestingFramework.Controls.KendoUI Namespace


IndexesCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Constructor
IndexesCollection Class See Also Send Feedback
Initializes a new instance of the IndexesCollection class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public IndexesCollection()
Visual Basic
Public Sub New
Visual C++
public:
IndexesCollection()

See Also

IndexesCollection Class
IndexesCollection Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


IndexesCollection Constructor (IList(Int32))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Constructor (IList<(Of <(<'Int32>)>)>)
IndexesCollection Class See Also Send Feedback
Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified list.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public IndexesCollection(
    IList<int> list
)
Visual Basic
Public Sub New ( _
    list As IList(Of Integer) _
)
Visual C++
public:
IndexesCollection(
    IList<int>^ list
)

Parameters

list
Type: System.Collections.Generic..::..IList <(Of <(<' Int32 >)>)>

[Missing <param name="list"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.IndexesCollection.#ctor(System.Collections.Generic.IList{System.Int32})"]

See Also

IndexesCollection Class
IndexesCollection Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


IndexesCollection Constructor (Int32[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Constructor (array<Int32>[]()[][])
IndexesCollection Class See Also Send Feedback
Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified int array.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public IndexesCollection(
    int[] intArray
)
Visual Basic
Public Sub New ( _
    intArray As Integer() _
)
Visual C++
public:
IndexesCollection(
    array<int>^ intArray
)

Parameters

intArray
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="intArray"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.IndexesCollection.#ctor(System.Int32[])"]

See Also

IndexesCollection Class
IndexesCollection Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


IndexesCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Methods
IndexesCollection Class See Also Send Feedback

The IndexesCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | ConvertToString | Converts the collection to comma separated string.
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | InitializeCodeExpression | Generates initialization code for the indexes collection.
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Matches | Compares the items of the current collection with the passed one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexesCollection Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ConvertToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection..::..ConvertToString Method
IndexesCollection Class See Also Send Feedback
Converts the collection to comma separated string.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public string ConvertToString()
Visual Basic
Public Function ConvertToString As String
Visual C++
public:
String^ ConvertToString()

Return Value

[Missing <returns> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.IndexesCollection.ConvertToString"]

See Also

IndexesCollection Class
Telerik.TestingFramework.Controls.KendoUI Namespace


InitializeCodeExpression Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection..::..InitializeCodeExpression Method
IndexesCollection Class See Also Send Feedback
Generates initialization code for the indexes collection.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public string InitializeCodeExpression()
Visual Basic
Public Function InitializeCodeExpression As String
Visual C++
public:
String^ InitializeCodeExpression()

Return Value

The initialization code for the indexes collection.

See Also

IndexesCollection Class
Telerik.TestingFramework.Controls.KendoUI Namespace


Matches Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection..::..Matches Method
IndexesCollection Class See Also Send Feedback
Compares the items of the current collection with the passed one.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public bool Matches(
    IndexesCollection indexesCollection
)
Visual Basic
Public Function Matches ( _
    indexesCollection As IndexesCollection _
) As Boolean
Visual C++
public:
bool Matches(
    IndexesCollection^ indexesCollection
)

Parameters

indexesCollection
Type: Telerik.TestingFramework.Controls.KendoUI..::..IndexesCollection
The collection to compare.

Return Value

Whether the current colleciton items match those from the given collection.

See Also

IndexesCollection Class
Telerik.TestingFramework.Controls.KendoUI Namespace


IndexesCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Properties
IndexesCollection Class See Also Send Feedback

The IndexesCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)

See Also

IndexesCollection Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoCalendar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar Members
KendoCalendar Class Constructors Methods Properties See Also Send Feedback

The KendoCalendar type exposes the following members.

Constructors

 | Name | Description
Public method | KendoCalendar()()()() | Initializes a new instance of the KendoCalendarBar class.
Public method | KendoCalendar(Element) | Initializes a new instance of the KendoCalendar class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NavigateDown | Navigates to lower calendar view - decades, years, months
Public method | NavigateToFuture | Navigates to next month
Public method | NavigateToPast | Navigates previous month
Public method | NavigateUp | Navigates to upper calendar view - months, years, decades
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | selectDay | Obsolete. Selects a day in the Calendar.
Public method | SelectDay | Selects a day in the Calendar.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CalendarFullDateValue | The value of the of the Calendar.
Public property | CalendarValue | The selected element of the of the Calendar (InnerText).
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoCalendar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DateValue | The date-value attribute of the of the Calendar.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FooterPresent | Shows whether calendar footer is present
Public property | FooterText | The footer text of the Calendar.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoCalendar. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Returns the Calendar's selected date.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoCalendar Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar Constructor
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoCalendar()()()() | Initializes a new instance of the KendoCalendarBar class.
Public method | KendoCalendar(Element) | Initializes a new instance of the KendoCalendar class.

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoCalendar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar Constructor
KendoCalendar Class See Also Send Feedback
Initializes a new instance of the KendoCalendarBar class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoCalendar()
Visual Basic
Public Sub New
Visual C++
public:
KendoCalendar()

See Also

KendoCalendar Class
KendoCalendar Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoCalendar Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar Constructor (Element)
KendoCalendar Class See Also Send Feedback
Initializes a new instance of the KendoCalendar class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoCalendar(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoCalendar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoCalendar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoCalendar Class
KendoCalendar Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoCalendar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar Methods
KendoCalendar Class See Also Send Feedback

The KendoCalendar type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NavigateDown | Navigates to lower calendar view - decades, years, months
Public method | NavigateToFuture | Navigates to next month
Public method | NavigateToPast | Navigates previous month
Public method | NavigateUp | Navigates to upper calendar view - months, years, decades
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | selectDay | Obsolete. Selects a day in the Calendar.
Public method | SelectDay | Selects a day in the Calendar.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..AssignElement Method
KendoCalendar Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoCalendar.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoCalendar.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..CallMethod Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..Capture Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..Click Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..ControlAssert Method
KendoCalendar Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..DragTo Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..GetValue Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..InvokeEvent Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..MouseClick Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..MouseHover Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


NavigateDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..NavigateDown Method
KendoCalendar Class See Also Send Feedback
Navigates to lower calendar view - decades, years, months

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void NavigateDown(
    string downTo
)
Visual Basic
Public Sub NavigateDown ( _
    downTo As String _
)
Visual C++
public:
void NavigateDown(
    String^ downTo
)

Parameters

downTo
Type: System..::..String

[Missing <param name="downTo"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoCalendar.NavigateDown(System.String)"]

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


NavigateToFuture Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..NavigateToFuture Method
KendoCalendar Class See Also Send Feedback
Navigates to next month

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void NavigateToFuture()
Visual Basic
Public Sub NavigateToFuture
Visual C++
public:
void NavigateToFuture()

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


NavigateToPast Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..NavigateToPast Method
KendoCalendar Class See Also Send Feedback
Navigates previous month

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void NavigateToPast()
Visual Basic
Public Sub NavigateToPast
Visual C++
public:
void NavigateToPast()

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


NavigateUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..NavigateUp Method
KendoCalendar Class See Also Send Feedback
Navigates to upper calendar view - months, years, decades

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void NavigateUp()
Visual Basic
Public Sub NavigateUp
Visual C++
public:
void NavigateUp()

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..ScrollToVisible Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SelectDay Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..SelectDay Method
KendoCalendar Class See Also Send Feedback
Selects a day in the Calendar.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void SelectDay(
    string day
)
Visual Basic
Public Sub SelectDay ( _
    day As String _
)
Visual C++
public:
void SelectDay(
    String^ day
)

Parameters

day
Type: System..::..String
Date in format "yyyy, mm, dd".

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar..::..SetValue Method
KendoCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoCalendar Class
KendoCalendar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoCalendar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendar Properties
KendoCalendar Class See Also Send Feedback

The KendoCalendar type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CalendarFullDateValue | The value of the of the Calendar.
Public property | CalendarValue | The selected element of the of the Calendar (InnerText).
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoCalendar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DateValue | The date-value attribute of the of the Calendar.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FooterPresent | Shows whether calendar footer is present
Public property | FooterText | The footer text of the Calendar.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoCalendar. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Returns the Calendar's selected date.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoCalendar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoCalendarConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants Members
KendoCalendarConstants Class Fields See Also Send Feedback

The KendoCalendarConstants type exposes the following members.

Fields

Name | Description
CalendarKey | The name identifying the Calendar control.
CssBackArrow | The CSS class for navigate to past arrow
CssBackArrowOld |
CssCalendar | The CSS class identifying the control.
CssFooter | The CSS of the footer div
CssFwArrow | The CSS class for navigate to past arrow
CssFwArrowOld |
CssMonthView | The CSS class for coelndar in month view (day figures available)
CssNavigateDown | The CSS class for navigate to lower view
CssUpperView | The CSS class for navigate to upper view

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoCalendarConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants Fields
KendoCalendarConstants Class See Also Send Feedback

The KendoCalendarConstants type exposes the following members.

Fields

Name | Description
CalendarKey | The name identifying the Calendar control.
CssBackArrow | The CSS class for navigate to past arrow
CssBackArrowOld |
CssCalendar | The CSS class identifying the control.
CssFooter | The CSS of the footer div
CssFwArrow | The CSS class for navigate to past arrow
CssFwArrowOld |
CssMonthView | The CSS class for coelndar in month view (day figures available)
CssNavigateDown | The CSS class for navigate to lower view
CssUpperView | The CSS class for navigate to upper view

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CalendarKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CalendarKey Field
KendoCalendarConstants Class See Also Send Feedback
The name identifying the Calendar control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CalendarKey
Visual Basic
Public Const CalendarKey As String
Visual C++
public:
literal String^ CalendarKey

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssBackArrow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssBackArrow Field
KendoCalendarConstants Class See Also Send Feedback
The CSS class for navigate to past arrow

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssBackArrow
Visual Basic
Public Const CssBackArrow As String
Visual C++
public:
literal String^ CssBackArrow

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssBackArrowOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssBackArrowOld Field
KendoCalendarConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoCalendarConstants.CssBackArrowOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssBackArrowOld
Visual Basic
Public Const CssBackArrowOld As String
Visual C++
public:
literal String^ CssBackArrowOld

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssCalendar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssCalendar Field
KendoCalendarConstants Class See Also Send Feedback
The CSS class identifying the control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssCalendar
Visual Basic
Public Const CssCalendar As String
Visual C++
public:
literal String^ CssCalendar

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssFooter Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssFooter Field
KendoCalendarConstants Class See Also Send Feedback
The CSS of the footer div

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssFooter
Visual Basic
Public Const CssFooter As String
Visual C++
public:
literal String^ CssFooter

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssFwArrow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssFwArrow Field
KendoCalendarConstants Class See Also Send Feedback
The CSS class for navigate to past arrow

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssFwArrow
Visual Basic
Public Const CssFwArrow As String
Visual C++
public:
literal String^ CssFwArrow

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssFwArrowOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssFwArrowOld Field
KendoCalendarConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoCalendarConstants.CssFwArrowOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssFwArrowOld
Visual Basic
Public Const CssFwArrowOld As String
Visual C++
public:
literal String^ CssFwArrowOld

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssMonthView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssMonthView Field
KendoCalendarConstants Class See Also Send Feedback
The CSS class for coelndar in month view (day figures available)

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssMonthView
Visual Basic
Public Const CssMonthView As String
Visual C++
public:
literal String^ CssMonthView

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssNavigateDown Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssNavigateDown Field
KendoCalendarConstants Class See Also Send Feedback
The CSS class for navigate to lower view

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssNavigateDown
Visual Basic
Public Const CssNavigateDown As String
Visual C++
public:
literal String^ CssNavigateDown

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssUpperView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoCalendarConstants..::..CssUpperView Field
KendoCalendarConstants Class See Also Send Feedback
The CSS class for navigate to upper view

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssUpperView
Visual Basic
Public Const CssUpperView As String
Visual C++
public:
literal String^ CssUpperView

See Also

KendoCalendarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoControlAssert Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert Members
KendoControlAssert Class Constructors Methods Properties See Also Send Feedback

The KendoControlAssert type exposes the following members.

Constructors

 | Name | Description
Public method | KendoControlAssert()()()() | Initializes a new instance of the RadControlAssert class.
Public method | KendoControlAssert(HtmlControl) | Initializes a new instance of the RadControlAssert class.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | DecimalValue | Assert a decimal.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberValue | Assert a number.
Public method | StringValue | Assert a string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

KendoControlAssert Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoControlAssert Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert Constructor
KendoControlAssert Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoControlAssert()()()() | Initializes a new instance of the RadControlAssert class.
Public method | KendoControlAssert(HtmlControl) | Initializes a new instance of the RadControlAssert class.

See Also

KendoControlAssert Class
KendoControlAssert Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoControlAssert Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert Constructor
KendoControlAssert Class See Also Send Feedback
Initializes a new instance of the RadControlAssert class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert()
Visual Basic
Public Sub New
Visual C++
public:
KendoControlAssert()

See Also

KendoControlAssert Class
KendoControlAssert Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoControlAssert Constructor (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert Constructor (HtmlControl)
KendoControlAssert Class See Also Send Feedback
Initializes a new instance of the RadControlAssert class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert(
    HtmlControl control
)
Visual Basic
Public Sub New ( _
    control As HtmlControl _
)
Visual C++
public:
KendoControlAssert(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The target control to assert against.

See Also

KendoControlAssert Class
KendoControlAssert Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoControlAssert Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert Methods
KendoControlAssert Class See Also Send Feedback

The KendoControlAssert type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | DecimalValue | Assert a decimal.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberValue | Assert a number.
Public method | StringValue | Assert a string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KendoControlAssert Class
Telerik.TestingFramework.Controls.KendoUI Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert..::..Assert Method
KendoControlAssert Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

KendoControlAssert Class
KendoControlAssert Members
Telerik.TestingFramework.Controls.KendoUI Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert..::..AssertString Method
KendoControlAssert Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

KendoControlAssert Class
KendoControlAssert Members
Telerik.TestingFramework.Controls.KendoUI Namespace


DecimalValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert..::..DecimalValue Method
KendoControlAssert Class See Also Send Feedback
Assert a decimal.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public bool DecimalValue(
    string controlPropertyName,
    decimal expected,
    NumberCompareType compareType
)
Visual Basic
Public Function DecimalValue ( _
    controlPropertyName As String, _
    expected As Decimal, _
    compareType As NumberCompareType _
) As Boolean
Visual C++
public:
bool DecimalValue(
    String^ controlPropertyName,
    Decimal expected,
    NumberCompareType compareType
)

Parameters

controlPropertyName
Type: System..::..String
The property name to get value of.
expected
Type: System..::..Decimal
The expected string.
compareType
Type: ArtOfTest.Common..::..NumberCompareType
The compare type.

Return Value

True/false whether the comparison works. Returns false if the property value is not of integer type.

See Also

KendoControlAssert Class
Telerik.TestingFramework.Controls.KendoUI Namespace


NumberValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert..::..NumberValue Method
KendoControlAssert Class See Also Send Feedback
Assert a number.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public bool NumberValue(
    string controlPropertyName,
    int expected,
    NumberCompareType compareType
)
Visual Basic
Public Function NumberValue ( _
    controlPropertyName As String, _
    expected As Integer, _
    compareType As NumberCompareType _
) As Boolean
Visual C++
public:
bool NumberValue(
    String^ controlPropertyName,
    int expected,
    NumberCompareType compareType
)

Parameters

controlPropertyName
Type: System..::..String
The property name to get value of.
expected
Type: System..::..Int32
The expected string.
compareType
Type: ArtOfTest.Common..::..NumberCompareType
The compare type.

Return Value

True/false whether the comparison works. Returns false if the property value is not of integer type.

See Also

KendoControlAssert Class
Telerik.TestingFramework.Controls.KendoUI Namespace


StringValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert..::..StringValue Method
KendoControlAssert Class See Also Send Feedback
Assert a string.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public bool StringValue(
    string controlPropertyName,
    string expected,
    StringCompareType compareType
)
Visual Basic
Public Function StringValue ( _
    controlPropertyName As String, _
    expected As String, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool StringValue(
    String^ controlPropertyName,
    String^ expected,
    StringCompareType compareType
)

Parameters

controlPropertyName
Type: System..::..String
The property name to get value of.
expected
Type: System..::..String
The expected string.
compareType
Type: ArtOfTest.Common..::..StringCompareType
The compare type.

Return Value

True/false whether the comparison works.

See Also

KendoControlAssert Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoControlAssert Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoControlAssert Properties
KendoControlAssert Class See Also Send Feedback

The KendoControlAssert type exposes the following members.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

KendoControlAssert Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoExtendedInput Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput Members
KendoExtendedInput Class Constructors Methods Properties See Also Send Feedback

The KendoExtendedInput type exposes the following members.

Constructors

 | Name | Description
Public method | KendoExtendedInput | Initializes a new instance of the KendoExtendedInput class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides KendoInput..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Clear the textbox. (Inherited from KendoInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns KendoControlAssert instance initialized for this control. (Inherited from KendoInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | SpinDownClick | NumericTextBox spin down button click.
Public method | SpinUpClick | NumericTextBox spin up button click.
Public method | ToggleCalendar | Opens/closes the calendar (DatePicker, DateTimePicker) (Inherited from KendoInput.)
Public method | ToggleCombo | Opens/closes the calendar (DatePicker, DateTimePicker) (Inherited from KendoInput.)
Public method | ToggleComboArrow | ComboBox and DropDown button click.
Public method | ToggleTimePicker | Opens/closes the TimePicker of an input (DateTimePicker) (Inherited from KendoInput.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from KendoInput.)
Public method | TypeText(String, Int32) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from KendoInput.)
Public method | TypeText(String, Int32, Int32) | Types text into the input. (Inherited from KendoInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CalendarOpened | (Inherited from KendoInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. Applies for combobox, dropdownlist, numerictextbox (Inherited from KendoInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from KendoInput.)
Public property | ComboOpened | (Inherited from KendoInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputText | Get or set the client-side input text. (Inherited from KendoInput.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from KendoInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from KendoInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from KendoInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePickerOpened | (Inherited from KendoInput.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoExtendedInput Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput Constructor
KendoExtendedInput Class See Also Send Feedback
Initializes a new instance of the KendoExtendedInput class

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoExtendedInput()
Visual Basic
Public Sub New
Visual C++
public:
KendoExtendedInput()

See Also

KendoExtendedInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoExtendedInput Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput Methods
KendoExtendedInput Class See Also Send Feedback

The KendoExtendedInput type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides KendoInput..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Clear the textbox. (Inherited from KendoInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns KendoControlAssert instance initialized for this control. (Inherited from KendoInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | SpinDownClick | NumericTextBox spin down button click.
Public method | SpinUpClick | NumericTextBox spin up button click.
Public method | ToggleCalendar | Opens/closes the calendar (DatePicker, DateTimePicker) (Inherited from KendoInput.)
Public method | ToggleCombo | Opens/closes the calendar (DatePicker, DateTimePicker) (Inherited from KendoInput.)
Public method | ToggleComboArrow | ComboBox and DropDown button click.
Public method | ToggleTimePicker | Opens/closes the TimePicker of an input (DateTimePicker) (Inherited from KendoInput.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from KendoInput.)
Public method | TypeText(String, Int32) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from KendoInput.)
Public method | TypeText(String, Int32, Int32) | Types text into the input. (Inherited from KendoInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoExtendedInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..AssignElement Method
KendoExtendedInput Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoExtendedInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..CallMethod Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..Capture Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..Click Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..DragTo Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..GetValue Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..InvokeEvent Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..MouseClick Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..MouseHover Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..ScrollToVisible Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..SetValue Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SpinDownClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..SpinDownClick Method
KendoExtendedInput Class See Also Send Feedback
NumericTextBox spin down button click.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void SpinDownClick()
Visual Basic
Public Sub SpinDownClick
Visual C++
public:
void SpinDownClick()

See Also

KendoExtendedInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SpinUpClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..SpinUpClick Method
KendoExtendedInput Class See Also Send Feedback
NumericTextBox spin up button click.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void SpinUpClick()
Visual Basic
Public Sub SpinUpClick
Visual C++
public:
void SpinUpClick()

See Also

KendoExtendedInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ToggleComboArrow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..ToggleComboArrow Method
KendoExtendedInput Class See Also Send Feedback
ComboBox and DropDown button click.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void ToggleComboArrow()
Visual Basic
Public Sub ToggleComboArrow
Visual C++
public:
void ToggleComboArrow()

See Also

KendoExtendedInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput..::..TypeText Method
KendoExtendedInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String) | Types text into the input. (Inherited from KendoInput.)
Public method | TypeText(String, Int32) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from KendoInput.)
Public method | TypeText(String, Int32, Int32) | Types text into the input. (Inherited from KendoInput.)

See Also

KendoExtendedInput Class
KendoExtendedInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoExtendedInput Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoExtendedInput Properties
KendoExtendedInput Class See Also Send Feedback

The KendoExtendedInput type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CalendarOpened | (Inherited from KendoInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. Applies for combobox, dropdownlist, numerictextbox (Inherited from KendoInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from KendoInput.)
Public property | ComboOpened | (Inherited from KendoInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputText | Get or set the client-side input text. (Inherited from KendoInput.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from KendoInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from KendoInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from KendoInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePickerOpened | (Inherited from KendoInput.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoExtendedInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid Members
KendoGrid Class Constructors Methods Properties See Also Send Feedback

The KendoGrid type exposes the following members.

Constructors

 | Name | Description
Public method | KendoGrid()()()() | Initializes a new instance of the KendoGrid class.
Public method | KendoGrid(Element) | Initializes a new instance of the KendoGrid class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ClearSelection | Clears all selected items in the Grid.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Get the list of the data items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectItembyIndex | Selects Grid item by index.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the KendoGrid control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DataItems | Get the list of the children data items of this table.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Groupable | shows whether the grid is groupable
Public property | Groups | shows the groups by which the grid is grouped
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selectable | shows whether the grid is multi-select, multi-cell-select or selection is not active
Public property | SelectedIndexes | Collection containting the indexes of the expanded items for the current Grid.
Public property | SelectedItems | Get the list of selected items.
Public property | Sortable | shows whether the grid is sortable
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoGrid Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGrid Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid Constructor
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoGrid()()()() | Initializes a new instance of the KendoGrid class.
Public method | KendoGrid(Element) | Initializes a new instance of the KendoGrid class.

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGrid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid Constructor
KendoGrid Class See Also Send Feedback
Initializes a new instance of the KendoGrid class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGrid()
Visual Basic
Public Sub New
Visual C++
public:
KendoGrid()

See Also

KendoGrid Class
KendoGrid Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGrid Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid Constructor (Element)
KendoGrid Class See Also Send Feedback
Initializes a new instance of the KendoGrid class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGrid(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoGrid(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGrid.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoGrid Class
KendoGrid Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid Methods
KendoGrid Class See Also Send Feedback

The KendoGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ClearSelection | Clears all selected items in the Grid.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Get the list of the data items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectItembyIndex | Selects Grid item by index.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoGrid Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..AssignElement Method
KendoGrid Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGrid.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGrid.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoGrid Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..CallMethod Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..Capture Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ClearSelection Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..ClearSelection Method
KendoGrid Class See Also Send Feedback
Clears all selected items in the Grid.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void ClearSelection()
Visual Basic
Public Sub ClearSelection
Visual C++
public:
void ClearSelection()

See Also

KendoGrid Class
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..Click Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..ControlAssert Method
KendoGrid Class See Also Send Feedback
Returns KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoGrid Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..DragTo Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..FindItems Method
KendoGrid Class See Also Send Feedback
Get the list of the data items matching the given predicate.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public IList<KendoGridDataItem> FindItems(
    Predicate<KendoGridDataItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of KendoGridDataItem) _
) As IList(Of KendoGridDataItem)
Visual C++
public:
IList<KendoGridDataItem^>^ FindItems(
    Predicate<KendoGridDataItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' KendoGridDataItem >)>)>
The predicate to search for.

Return Value

The list of the data items matching the given predicate.

See Also

KendoGrid Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..GetValue Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..InvokeEvent Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..MouseClick Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..MouseHover Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..ScrollToVisible Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SelectItembyIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..SelectItembyIndex Method
KendoGrid Class See Also Send Feedback
Selects Grid item by index.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void SelectItembyIndex(
    int index
)
Visual Basic
Public Sub SelectItembyIndex ( _
    index As Integer _
)
Visual C++
public:
void SelectItembyIndex(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the item to be selected.

See Also

KendoGrid Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid..::..SetValue Method
KendoGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoGrid Class
KendoGrid Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGrid Properties
KendoGrid Class See Also Send Feedback

The KendoGrid type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the KendoGrid control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DataItems | Get the list of the children data items of this table.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Groupable | shows whether the grid is groupable
Public property | Groups | shows the groups by which the grid is grouped
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selectable | shows whether the grid is multi-select, multi-cell-select or selection is not active
Public property | SelectedIndexes | Collection containting the indexes of the expanded items for the current Grid.
Public property | SelectedItems | Get the list of selected items.
Public property | Sortable | shows whether the grid is sortable
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoGrid Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants Members
KendoGridConstants Class Constructors Methods Fields See Also Send Feedback

The KendoGridConstants type exposes the following members.

Constructors

 | Name | Description
Public method | KendoGridConstants | Initializes a new instance of the KendoGridConstants class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
CssCollapsedGroup | The CSS class of the collapsed group
CssContentDiv | The CSS class of the div containing the Grid table.
CssExpandedGroup | The CSS class of the expanded group
CssGrid | The CSS class of the Grid widget wrapper div.
CssSelectedItem | The CSS class of the selected item.
GridCellKey | The Call key used accross the verifications and action messages.
GridGroupKey | The Group key used accross the verifications and action messages.
GridKey | The Grid key used accross the verifications and action messages.
GridRowKey | The Row key used accross the verifications and action messages.

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridConstants Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants Constructor
KendoGridConstants Class See Also Send Feedback
Initializes a new instance of the KendoGridConstants class

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGridConstants()
Visual Basic
Public Sub New
Visual C++
public:
KendoGridConstants()

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants Fields
KendoGridConstants Class See Also Send Feedback

The KendoGridConstants type exposes the following members.

Fields

Name | Description
CssCollapsedGroup | The CSS class of the collapsed group
CssContentDiv | The CSS class of the div containing the Grid table.
CssExpandedGroup | The CSS class of the expanded group
CssGrid | The CSS class of the Grid widget wrapper div.
CssSelectedItem | The CSS class of the selected item.
GridCellKey | The Call key used accross the verifications and action messages.
GridGroupKey | The Group key used accross the verifications and action messages.
GridKey | The Grid key used accross the verifications and action messages.
GridRowKey | The Row key used accross the verifications and action messages.

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssCollapsedGroup Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..CssCollapsedGroup Field
KendoGridConstants Class See Also Send Feedback
The CSS class of the collapsed group

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssCollapsedGroup
Visual Basic
Public Const CssCollapsedGroup As String
Visual C++
public:
literal String^ CssCollapsedGroup

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssContentDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..CssContentDiv Field
KendoGridConstants Class See Also Send Feedback
The CSS class of the div containing the Grid table.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssContentDiv
Visual Basic
Public Const CssContentDiv As String
Visual C++
public:
literal String^ CssContentDiv

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssExpandedGroup Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..CssExpandedGroup Field
KendoGridConstants Class See Also Send Feedback
The CSS class of the expanded group

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssExpandedGroup
Visual Basic
Public Const CssExpandedGroup As String
Visual C++
public:
literal String^ CssExpandedGroup

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssGrid Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..CssGrid Field
KendoGridConstants Class See Also Send Feedback
The CSS class of the Grid widget wrapper div.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssGrid
Visual Basic
Public Const CssGrid As String
Visual C++
public:
literal String^ CssGrid

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssSelectedItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..CssSelectedItem Field
KendoGridConstants Class See Also Send Feedback
The CSS class of the selected item.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssSelectedItem
Visual Basic
Public Const CssSelectedItem As String
Visual C++
public:
literal String^ CssSelectedItem

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GridCellKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..GridCellKey Field
KendoGridConstants Class See Also Send Feedback
The Call key used accross the verifications and action messages.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string GridCellKey
Visual Basic
Public Const GridCellKey As String
Visual C++
public:
literal String^ GridCellKey

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GridGroupKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..GridGroupKey Field
KendoGridConstants Class See Also Send Feedback
The Group key used accross the verifications and action messages.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string GridGroupKey
Visual Basic
Public Const GridGroupKey As String
Visual C++
public:
literal String^ GridGroupKey

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GridKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..GridKey Field
KendoGridConstants Class See Also Send Feedback
The Grid key used accross the verifications and action messages.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string GridKey
Visual Basic
Public Const GridKey As String
Visual C++
public:
literal String^ GridKey

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GridRowKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants..::..GridRowKey Field
KendoGridConstants Class See Also Send Feedback
The Row key used accross the verifications and action messages.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string GridRowKey
Visual Basic
Public Const GridRowKey As String
Visual C++
public:
literal String^ GridRowKey

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridConstants Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridConstants Methods
KendoGridConstants Class See Also Send Feedback

The KendoGridConstants type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KendoGridConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell Members
KendoGridDataCell Class Constructors Methods Properties See Also Send Feedback

The KendoGridDataCell type exposes the following members.

Constructors

 | Name | Description
Public method | KendoGridDataCell()()()() | Initializes a new instance of the GridDataCell class.
Public method | KendoGridDataCell(Element) | Initializes a new instance of the KendoTreeView class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickItem |
Public method | ControlAssert | Get KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Groupable | checks whether the grid is selected
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | Gets current cell text
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | HIndex | horizontal index of the cell
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentGridDataItem | The parent Griditem of the item.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | shows whether the cell is selected
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | VIndex | vertical index of the cell
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

KendoGridDataCell Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell Constructor
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoGridDataCell()()()() | Initializes a new instance of the GridDataCell class.
Public method | KendoGridDataCell(Element) | Initializes a new instance of the KendoTreeView class.

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell Constructor
KendoGridDataCell Class See Also Send Feedback
Initializes a new instance of the GridDataCell class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGridDataCell()
Visual Basic
Public Sub New
Visual C++
public:
KendoGridDataCell()

See Also

KendoGridDataCell Class
KendoGridDataCell Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell Constructor (Element)
KendoGridDataCell Class See Also Send Feedback
Initializes a new instance of the KendoTreeView class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGridDataCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoGridDataCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridDataCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoGridDataCell Class
KendoGridDataCell Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell Methods
KendoGridDataCell Class See Also Send Feedback

The KendoGridDataCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickItem |
Public method | ControlAssert | Get KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Groupable | checks whether the grid is selected
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoGridDataCell Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..AssignElement Method
KendoGridDataCell Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridDataCell.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridDataCell.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoGridDataCell Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..CallMethod Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..Capture Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..Click Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ClickItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..ClickItem Method
KendoGridDataCell Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridDataCell.ClickItem"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void ClickItem()
Visual Basic
Public Sub ClickItem
Visual C++
public:
void ClickItem()

See Also

KendoGridDataCell Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..ControlAssert Method
KendoGridDataCell Class See Also Send Feedback
Get KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoGridDataCell Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..DragTo Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..GetValue Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Groupable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..Groupable Method
KendoGridDataCell Class See Also Send Feedback
checks whether the grid is selected

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Groupable()
Visual Basic
Public Sub Groupable
Visual C++
public:
void Groupable()

See Also

KendoGridDataCell Class
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..InvokeEvent Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..MouseClick Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..MouseHover Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..ScrollToVisible Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell..::..SetValue Method
KendoGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoGridDataCell Class
KendoGridDataCell Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataCell Properties
KendoGridDataCell Class See Also Send Feedback

The KendoGridDataCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | Gets current cell text
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | HIndex | horizontal index of the cell
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentGridDataItem | The parent Griditem of the item.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | shows whether the cell is selected
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | VIndex | vertical index of the cell
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

KendoGridDataCell Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem Members
KendoGridDataItem Class Constructors Methods Properties See Also Send Feedback

The KendoGridDataItem type exposes the following members.

Constructors

 | Name | Description
Public method | KendoGridDataItem()()()() | Initializes a new instance of the GridDataItem class.
Public method | KendoGridDataItem(Element) | Initializes a new instance of the GridDataItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | ItemIndex | The data item index.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentGrid | The parent Grid of the item.
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem Constructor
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoGridDataItem()()()() | Initializes a new instance of the GridDataItem class.
Public method | KendoGridDataItem(Element) | Initializes a new instance of the GridDataItem class.

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem Constructor
KendoGridDataItem Class See Also Send Feedback
Initializes a new instance of the GridDataItem class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGridDataItem()
Visual Basic
Public Sub New
Visual C++
public:
KendoGridDataItem()

See Also

KendoGridDataItem Class
KendoGridDataItem Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem Constructor (Element)
KendoGridDataItem Class See Also Send Feedback
Initializes a new instance of the GridDataItem class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGridDataItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoGridDataItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridDataItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoGridDataItem Class
KendoGridDataItem Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem Methods
KendoGridDataItem Class See Also Send Feedback

The KendoGridDataItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoGridDataItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..AssignElement Method
KendoGridDataItem Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridDataItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridDataItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoGridDataItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..CallMethod Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..Capture Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..Click Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..DragTo Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..GetValue Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..InvokeEvent Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..MouseClick Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..MouseHover Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..ScrollToVisible Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem..::..SetValue Method
KendoGridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
KendoGridDataItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridDataItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridDataItem Properties
KendoGridDataItem Class See Also Send Feedback

The KendoGridDataItem type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | ItemIndex | The data item index.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentGrid | The parent Grid of the item.
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoGridDataItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridGroup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup Members
KendoGridGroup Class Constructors Methods Properties See Also Send Feedback

The KendoGridGroup type exposes the following members.

Constructors

 | Name | Description
Public method | KendoGridGroup()()()() | Initializes a new instance of the GridGroup class.
Public method | KendoGridGroup(Element) | Initializes a new instance of the KendoGridGroup class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupIndex | The data item index.
Public property | GroupText | Gets current group text
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentGrid |
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridGroup Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup Constructor
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoGridGroup()()()() | Initializes a new instance of the GridGroup class.
Public method | KendoGridGroup(Element) | Initializes a new instance of the KendoGridGroup class.

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridGroup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup Constructor
KendoGridGroup Class See Also Send Feedback
Initializes a new instance of the GridGroup class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGridGroup()
Visual Basic
Public Sub New
Visual C++
public:
KendoGridGroup()

See Also

KendoGridGroup Class
KendoGridGroup Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridGroup Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup Constructor (Element)
KendoGridGroup Class See Also Send Feedback
Initializes a new instance of the KendoGridGroup class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoGridGroup(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoGridGroup(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridGroup.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoGridGroup Class
KendoGridGroup Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridGroup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup Methods
KendoGridGroup Class See Also Send Feedback

The KendoGridGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoGridGroup Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..AssignElement Method
KendoGridGroup Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridGroup.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoGridGroup.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoGridGroup Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..CallMethod Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..Capture Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..Click Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..ControlAssert Method
KendoGridGroup Class See Also Send Feedback
Get KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoGridGroup Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..DragTo Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..GetValue Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..InvokeEvent Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..MouseClick Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..MouseHover Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..ScrollToVisible Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup..::..SetValue Method
KendoGridGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
KendoGridGroup Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoGridGroup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoGridGroup Properties
KendoGridGroup Class See Also Send Feedback

The KendoGridGroup type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupIndex | The data item index.
Public property | GroupText | Gets current group text
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentGrid |
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoGridGroup Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoInput Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput Members
KendoInput Class Constructors Methods Properties See Also Send Feedback

The KendoInput type exposes the following members.

Constructors

 | Name | Description
Public method | KendoInput()()()() | Initializes a new instance of the KendoInput class.
Public method | KendoInput(Element) | Initializes a new instance of the KendoInput class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Clear the textbox.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToggleCalendar | Opens/closes the calendar (DatePicker, DateTimePicker)
Public method | ToggleCombo | Opens/closes the calendar (DatePicker, DateTimePicker)
Public method | ToggleTimePicker | Opens/closes the TimePicker of an input (DateTimePicker)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input.
Public method | TypeText(String, Int32) | Types text into the input. KeyHoldTime internally set to 50.
Public method | TypeText(String, Int32, Int32) | Types text into the input.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CalendarOpened |
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. Applies for combobox, dropdownlist, numerictextbox
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ComboOpened |
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputText | Get or set the client-side input text.
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox.
Public property | InputValue | Get or set the client-side input value.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePickerOpened |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoInput Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput Constructor
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoInput()()()() | Initializes a new instance of the KendoInput class.
Public method | KendoInput(Element) | Initializes a new instance of the KendoInput class.

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoInput Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput Constructor
KendoInput Class See Also Send Feedback
Initializes a new instance of the KendoInput class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoInput()
Visual Basic
Public Sub New
Visual C++
public:
KendoInput()

See Also

KendoInput Class
KendoInput Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoInput Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput Constructor (Element)
KendoInput Class See Also Send Feedback
Initializes a new instance of the KendoInput class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoInput(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoInput(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoInput.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoInput Class
KendoInput Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoInput Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput Methods
KendoInput Class See Also Send Feedback

The KendoInput type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Clear the textbox.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToggleCalendar | Opens/closes the calendar (DatePicker, DateTimePicker)
Public method | ToggleCombo | Opens/closes the calendar (DatePicker, DateTimePicker)
Public method | ToggleTimePicker | Opens/closes the TimePicker of an input (DateTimePicker)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input.
Public method | TypeText(String, Int32) | Types text into the input. KeyHoldTime internally set to 50.
Public method | TypeText(String, Int32, Int32) | Types text into the input.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..AssignElement Method
KendoInput Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..CallMethod Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..Capture Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..Clear Method
KendoInput Class See Also Send Feedback
Clear the textbox.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..Click Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..ControlAssert Method
KendoInput Class See Also Send Feedback
Returns KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..DragTo Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..GetValue Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..InvokeEvent Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..MouseClick Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..MouseHover Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..ScrollToVisible Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..SetValue Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ToggleCalendar Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..ToggleCalendar Method
KendoInput Class See Also Send Feedback
Opens/closes the calendar (DatePicker, DateTimePicker)

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void ToggleCalendar()
Visual Basic
Public Sub ToggleCalendar
Visual C++
public:
void ToggleCalendar()

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ToggleCombo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..ToggleCombo Method
KendoInput Class See Also Send Feedback
Opens/closes the calendar (DatePicker, DateTimePicker)

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void ToggleCombo()
Visual Basic
Public Sub ToggleCombo
Visual C++
public:
void ToggleCombo()

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ToggleTimePicker Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..ToggleTimePicker Method
KendoInput Class See Also Send Feedback
Opens/closes the TimePicker of an input (DateTimePicker)

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void ToggleTimePicker()
Visual Basic
Public Sub ToggleTimePicker
Visual C++
public:
void ToggleTimePicker()

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..TypeText Method
KendoInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String) | Types text into the input.
Public method | TypeText(String, Int32) | Types text into the input. KeyHoldTime internally set to 50.
Public method | TypeText(String, Int32, Int32) | Types text into the input.

See Also

KendoInput Class
KendoInput Members
Telerik.TestingFramework.Controls.KendoUI Namespace


TypeText Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..TypeText Method (String)
KendoInput Class See Also Send Feedback
Types text into the input.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void TypeText(
    string valueTyped
)
Visual Basic
Public Sub TypeText ( _
    valueTyped As String _
)
Visual C++
public:
void TypeText(
    String^ valueTyped
)

Parameters

valueTyped
Type: System..::..String
The text to be typed.

See Also

KendoInput Class
TypeText Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


TypeText Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..TypeText Method (String, Int32)
KendoInput Class See Also Send Feedback
Types text into the input. KeyHoldTime internally set to 50.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void TypeText(
    string valueTyped,
    int keyPressTime
)
Visual Basic
Public Sub TypeText ( _
    valueTyped As String, _
    keyPressTime As Integer _
)
Visual C++
public:
void TypeText(
    String^ valueTyped,
    int keyPressTime
)

Parameters

valueTyped
Type: System..::..String
The text to be typed.
keyPressTime
Type: System..::..Int32
The time for each keypress.

See Also

KendoInput Class
TypeText Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


TypeText Method (String, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput..::..TypeText Method (String, Int32, Int32)
KendoInput Class See Also Send Feedback
Types text into the input.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void TypeText(
    string valueTyped,
    int keyPressTime,
    int keyHoldTime
)
Visual Basic
Public Sub TypeText ( _
    valueTyped As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer _
)
Visual C++
public:
void TypeText(
    String^ valueTyped,
    int keyPressTime,
    int keyHoldTime
)

Parameters

valueTyped
Type: System..::..String
The text to be typed.
keyPressTime
Type: System..::..Int32
The time for each keypress.
keyHoldTime
Type: System..::..Int32
The time to hold the key pressed.

See Also

KendoInput Class
TypeText Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoInput Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInput Properties
KendoInput Class See Also Send Feedback

The KendoInput type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CalendarOpened |
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. Applies for combobox, dropdownlist, numerictextbox
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ComboOpened |
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputText | Get or set the client-side input text.
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox.
Public property | InputValue | Get or set the client-side input value.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePickerOpened |
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoInput Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoInputConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants Members
KendoInputConstants Class Fields See Also Send Feedback

The KendoInputConstants type exposes the following members.

Fields

Name | Description
CssAutoComplete | The CSS class of the AutoComplete span.
CssCalendarIcon | The CSS class of the calendar.
CssCalendarIconOld |
CssClockIcon | The CSS class of the calendar.
CssClockIconOld |
CssComboBox | The CSS class of the ComboBox wrapper span.
CssDatePicker | The CSS class of the DatePicker span.
CssDateTimePicker | The CSS class of the DatetimePicker span.
CssDropDownListTextBox | The CSS class of the DropDownList wrapper span.
CssInputClientObject | The CSS class of the input holding the client-side object.
CssKendoInputWrapperSpan | The base CSS class of the KendoInput wrapper span element.
CssNumericTextBox | The CSS class of the NumericTextBox wrapper span.
CssSpinButton | The common part of the spin button CSS class.
CssSpinButtonOld |
CssSpinDown | The CSS class of the spin down span.
CssSpinDownOld |
CssSpinUp | The CSS class of the spin up span.
CssSpinUpOld |
CssTimePicker | The CSS class of the TimePicker span.
DatePickerKey | The KendoDataPicker key used across the source classes.
DecreaseValueTitle | The title of the increase span
IncreaseValueTitle | The title of the increase span
InputKey | The 'KendoInput' key used across the source classes.
NumericTextBoxKey | The KendoNumericTextBox key used across the source classes.

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoInputConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants Fields
KendoInputConstants Class See Also Send Feedback

The KendoInputConstants type exposes the following members.

Fields

Name | Description
CssAutoComplete | The CSS class of the AutoComplete span.
CssCalendarIcon | The CSS class of the calendar.
CssCalendarIconOld |
CssClockIcon | The CSS class of the calendar.
CssClockIconOld |
CssComboBox | The CSS class of the ComboBox wrapper span.
CssDatePicker | The CSS class of the DatePicker span.
CssDateTimePicker | The CSS class of the DatetimePicker span.
CssDropDownListTextBox | The CSS class of the DropDownList wrapper span.
CssInputClientObject | The CSS class of the input holding the client-side object.
CssKendoInputWrapperSpan | The base CSS class of the KendoInput wrapper span element.
CssNumericTextBox | The CSS class of the NumericTextBox wrapper span.
CssSpinButton | The common part of the spin button CSS class.
CssSpinButtonOld |
CssSpinDown | The CSS class of the spin down span.
CssSpinDownOld |
CssSpinUp | The CSS class of the spin up span.
CssSpinUpOld |
CssTimePicker | The CSS class of the TimePicker span.
DatePickerKey | The KendoDataPicker key used across the source classes.
DecreaseValueTitle | The title of the increase span
IncreaseValueTitle | The title of the increase span
InputKey | The 'KendoInput' key used across the source classes.
NumericTextBoxKey | The KendoNumericTextBox key used across the source classes.

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssAutoComplete Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssAutoComplete Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the AutoComplete span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssAutoComplete
Visual Basic
Public Const CssAutoComplete As String
Visual C++
public:
literal String^ CssAutoComplete

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssCalendarIcon Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssCalendarIcon Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the calendar.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssCalendarIcon
Visual Basic
Public Const CssCalendarIcon As String
Visual C++
public:
literal String^ CssCalendarIcon

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssCalendarIconOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssCalendarIconOld Field
KendoInputConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoInputConstants.CssCalendarIconOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssCalendarIconOld
Visual Basic
Public Const CssCalendarIconOld As String
Visual C++
public:
literal String^ CssCalendarIconOld

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssClockIcon Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssClockIcon Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the calendar.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssClockIcon
Visual Basic
Public Const CssClockIcon As String
Visual C++
public:
literal String^ CssClockIcon

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssClockIconOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssClockIconOld Field
KendoInputConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoInputConstants.CssClockIconOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssClockIconOld
Visual Basic
Public Const CssClockIconOld As String
Visual C++
public:
literal String^ CssClockIconOld

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssComboBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssComboBox Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the ComboBox wrapper span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssComboBox
Visual Basic
Public Const CssComboBox As String
Visual C++
public:
literal String^ CssComboBox

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssDatePicker Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssDatePicker Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the DatePicker span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssDatePicker
Visual Basic
Public Const CssDatePicker As String
Visual C++
public:
literal String^ CssDatePicker

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssDateTimePicker Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssDateTimePicker Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the DatetimePicker span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssDateTimePicker
Visual Basic
Public Const CssDateTimePicker As String
Visual C++
public:
literal String^ CssDateTimePicker

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssDropDownListTextBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssDropDownListTextBox Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the DropDownList wrapper span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssDropDownListTextBox
Visual Basic
Public Const CssDropDownListTextBox As String
Visual C++
public:
literal String^ CssDropDownListTextBox

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssInputClientObject Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssInputClientObject Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the input holding the client-side object.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssInputClientObject
Visual Basic
Public Const CssInputClientObject As String
Visual C++
public:
literal String^ CssInputClientObject

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssKendoInputWrapperSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssKendoInputWrapperSpan Field
KendoInputConstants Class See Also Send Feedback
The base CSS class of the KendoInput wrapper span element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssKendoInputWrapperSpan
Visual Basic
Public Const CssKendoInputWrapperSpan As String
Visual C++
public:
literal String^ CssKendoInputWrapperSpan

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssNumericTextBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssNumericTextBox Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the NumericTextBox wrapper span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssNumericTextBox
Visual Basic
Public Const CssNumericTextBox As String
Visual C++
public:
literal String^ CssNumericTextBox

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssSpinButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssSpinButton Field
KendoInputConstants Class See Also Send Feedback
The common part of the spin button CSS class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssSpinButton
Visual Basic
Public Const CssSpinButton As String
Visual C++
public:
literal String^ CssSpinButton

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssSpinButtonOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssSpinButtonOld Field
KendoInputConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoInputConstants.CssSpinButtonOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssSpinButtonOld
Visual Basic
Public Const CssSpinButtonOld As String
Visual C++
public:
literal String^ CssSpinButtonOld

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssSpinDown Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssSpinDown Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the spin down span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssSpinDown
Visual Basic
Public Const CssSpinDown As String
Visual C++
public:
literal String^ CssSpinDown

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssSpinDownOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssSpinDownOld Field
KendoInputConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoInputConstants.CssSpinDownOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssSpinDownOld
Visual Basic
Public Const CssSpinDownOld As String
Visual C++
public:
literal String^ CssSpinDownOld

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssSpinUp Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssSpinUp Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the spin up span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssSpinUp
Visual Basic
Public Const CssSpinUp As String
Visual C++
public:
literal String^ CssSpinUp

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssSpinUpOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssSpinUpOld Field
KendoInputConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoInputConstants.CssSpinUpOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssSpinUpOld
Visual Basic
Public Const CssSpinUpOld As String
Visual C++
public:
literal String^ CssSpinUpOld

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssTimePicker Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..CssTimePicker Field
KendoInputConstants Class See Also Send Feedback
The CSS class of the TimePicker span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssTimePicker
Visual Basic
Public Const CssTimePicker As String
Visual C++
public:
literal String^ CssTimePicker

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DatePickerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..DatePickerKey Field
KendoInputConstants Class See Also Send Feedback
The KendoDataPicker key used across the source classes.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string DatePickerKey
Visual Basic
Public Const DatePickerKey As String
Visual C++
public:
literal String^ DatePickerKey

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DecreaseValueTitle Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..DecreaseValueTitle Field
KendoInputConstants Class See Also Send Feedback
The title of the increase span

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string DecreaseValueTitle
Visual Basic
Public Const DecreaseValueTitle As String
Visual C++
public:
literal String^ DecreaseValueTitle

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


IncreaseValueTitle Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..IncreaseValueTitle Field
KendoInputConstants Class See Also Send Feedback
The title of the increase span

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string IncreaseValueTitle
Visual Basic
Public Const IncreaseValueTitle As String
Visual C++
public:
literal String^ IncreaseValueTitle

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


InputKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..InputKey Field
KendoInputConstants Class See Also Send Feedback
The 'KendoInput' key used across the source classes.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string InputKey
Visual Basic
Public Const InputKey As String
Visual C++
public:
literal String^ InputKey

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


NumericTextBoxKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoInputConstants..::..NumericTextBoxKey Field
KendoInputConstants Class See Also Send Feedback
The KendoNumericTextBox key used across the source classes.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string NumericTextBoxKey
Visual Basic
Public Const NumericTextBoxKey As String
Visual C++
public:
literal String^ NumericTextBoxKey

See Also

KendoInputConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView Members
KendoListView Class Constructors Methods Properties See Also Send Feedback

The KendoListView type exposes the following members.

Constructors

 | Name | Description
Public method | KendoListView()()()() | Initializes a new instance of the KendoListView class.
Public method | KendoListView(Element) | Initializes a new instance of the KendoListView class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Get the list of the data items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoListView. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemsCount | count of ListViewItems on the current page
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoListView. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selectable | shows whether the list is multi-select, single-select or selection is not active
Public property | SelectedItemsCount | Get the count of selected items.
Public property | SelectedItemsList | Get the list of selected items.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoListView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListView Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView Constructor
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoListView()()()() | Initializes a new instance of the KendoListView class.
Public method | KendoListView(Element) | Initializes a new instance of the KendoListView class.

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView Constructor
KendoListView Class See Also Send Feedback
Initializes a new instance of the KendoListView class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoListView()
Visual Basic
Public Sub New
Visual C++
public:
KendoListView()

See Also

KendoListView Class
KendoListView Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListView Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView Constructor (Element)
KendoListView Class See Also Send Feedback
Initializes a new instance of the KendoListView class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoListView(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoListView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoListView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoListView Class
KendoListView Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView Methods
KendoListView Class See Also Send Feedback

The KendoListView type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Get the list of the data items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoListView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..AssignElement Method
KendoListView Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoListView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..CallMethod Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..Capture Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..Click Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..ControlAssert Method
KendoListView Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoListView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..DragTo Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..FindItems Method
KendoListView Class See Also Send Feedback
Get the list of the data items matching the given predicate.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public IList<KendoListViewItem> FindItems(
    Predicate<KendoListViewItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of KendoListViewItem) _
) As IList(Of KendoListViewItem)
Visual C++
public:
IList<KendoListViewItem^>^ FindItems(
    Predicate<KendoListViewItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' KendoListViewItem >)>)>
The predicate to search for.

Return Value

The list of the data items matching the given predicate.

See Also

KendoListView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..GetValue Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..InvokeEvent Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..MouseClick Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..MouseHover Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..ScrollToVisible Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView..::..SetValue Method
KendoListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoListView Class
KendoListView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListView Properties
KendoListView Class See Also Send Feedback

The KendoListView type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoListView. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemsCount | count of ListViewItems on the current page
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoListView. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selectable | shows whether the list is multi-select, single-select or selection is not active
Public property | SelectedItemsCount | Get the count of selected items.
Public property | SelectedItemsList | Get the list of selected items.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoListView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListViewConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewConstants Members
KendoListViewConstants Class Fields See Also Send Feedback

The KendoListViewConstants type exposes the following members.

Fields

Name | Description
KeyListView | The name identifying the KeyListView control.
KeyListViewItem | The name identifying the KeyListViewItem control.
ListViewItemSelected | The class of selected ListViewitem

See Also

KendoListViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListViewConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewConstants Fields
KendoListViewConstants Class See Also Send Feedback

The KendoListViewConstants type exposes the following members.

Fields

Name | Description
KeyListView | The name identifying the KeyListView control.
KeyListViewItem | The name identifying the KeyListViewItem control.
ListViewItemSelected | The class of selected ListViewitem

See Also

KendoListViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KeyListView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewConstants..::..KeyListView Field
KendoListViewConstants Class See Also Send Feedback
The name identifying the KeyListView control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string KeyListView
Visual Basic
Public Const KeyListView As String
Visual C++
public:
literal String^ KeyListView

See Also

KendoListViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KeyListViewItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewConstants..::..KeyListViewItem Field
KendoListViewConstants Class See Also Send Feedback
The name identifying the KeyListViewItem control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string KeyListViewItem
Visual Basic
Public Const KeyListViewItem As String
Visual C++
public:
literal String^ KeyListViewItem

See Also

KendoListViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ListViewItemSelected Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewConstants..::..ListViewItemSelected Field
KendoListViewConstants Class See Also Send Feedback
The class of selected ListViewitem

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string ListViewItemSelected
Visual Basic
Public Const ListViewItemSelected As String
Visual C++
public:
literal String^ ListViewItemSelected

See Also

KendoListViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListViewItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem Members
KendoListViewItem Class Constructors Methods Properties See Also Send Feedback

The KendoListViewItem type exposes the following members.

Constructors

 | Name | Description
Public method | KendoListViewItem()()()() | Initializes a new instance of the KendoListViewItem class.
Public method | KendoListViewItem(Element) | Initializes a new instance of the KendoListViewItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickItem |
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ListviewItemIndex | Returns the index of the current ListviewItem
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTab. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Returns 'true' if the ListViewitem is selected. Otherwise 'false'.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListViewItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem Constructor
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoListViewItem()()()() | Initializes a new instance of the KendoListViewItem class.
Public method | KendoListViewItem(Element) | Initializes a new instance of the KendoListViewItem class.

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListViewItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem Constructor
KendoListViewItem Class See Also Send Feedback
Initializes a new instance of the KendoListViewItem class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoListViewItem()
Visual Basic
Public Sub New
Visual C++
public:
KendoListViewItem()

See Also

KendoListViewItem Class
KendoListViewItem Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListViewItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem Constructor (Element)
KendoListViewItem Class See Also Send Feedback
Initializes a new instance of the KendoListViewItem class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoListViewItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoListViewItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoListViewItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoListViewItem Class
KendoListViewItem Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListViewItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem Methods
KendoListViewItem Class See Also Send Feedback

The KendoListViewItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickItem |
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoListViewItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..AssignElement Method
KendoListViewItem Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoListViewItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..CallMethod Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..Capture Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..Click Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ClickItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..ClickItem Method
KendoListViewItem Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoListViewItem.ClickItem"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void ClickItem()
Visual Basic
Public Sub ClickItem
Visual C++
public:
void ClickItem()

See Also

KendoListViewItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..ControlAssert Method
KendoListViewItem Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoPanelAssert instance initialized for this control.

See Also

KendoListViewItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..DragTo Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..GetValue Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..InvokeEvent Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..MouseClick Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..MouseHover Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..ScrollToVisible Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem..::..SetValue Method
KendoListViewItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
KendoListViewItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoListViewItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoListViewItem Properties
KendoListViewItem Class See Also Send Feedback

The KendoListViewItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ListviewItemIndex | Returns the index of the current ListviewItem
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTab. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Returns 'true' if the ListViewitem is selected. Otherwise 'false'.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoListViewItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenu Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu Members
KendoMenu Class Constructors Methods Properties See Also Send Feedback

The KendoMenu type exposes the following members.

Constructors

 | Name | Description
Public method | KendoMenu()()()() | Initializes a new instance of the KendoMenu class.
Public method | KendoMenu(Element) | Initializes a new instance of the KendoMenu class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Find menu by given predicate.
Public method | FindMenu |
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllMenus | Collection containing the sub Menu items of the Menu.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoMenu. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | closeOnClick | Whether the menu closes on option seselected
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoMenu. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MenuId | The Menu id.
Public property | openOnClick | Whether the opens and closes on root item click
Public property | OrientationType | Menu orientation.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoMenu Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenu Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu Constructor
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoMenu()()()() | Initializes a new instance of the KendoMenu class.
Public method | KendoMenu(Element) | Initializes a new instance of the KendoMenu class.

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenu Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu Constructor
KendoMenu Class See Also Send Feedback
Initializes a new instance of the KendoMenu class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoMenu()
Visual Basic
Public Sub New
Visual C++
public:
KendoMenu()

See Also

KendoMenu Class
KendoMenu Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenu Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu Constructor (Element)
KendoMenu Class See Also Send Feedback
Initializes a new instance of the KendoMenu class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoMenu(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoMenu(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenu.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoMenu Class
KendoMenu Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenu Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu Methods
KendoMenu Class See Also Send Feedback

The KendoMenu type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Find menu by given predicate.
Public method | FindMenu |
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoMenu Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..AssignElement Method
KendoMenu Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoMenu Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..CallMethod Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..Capture Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..Click Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..ControlAssert Method
KendoMenu Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoMenu Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..DragTo Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..FindItems Method
KendoMenu Class See Also Send Feedback
Find menu by given predicate.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public IList<KendoMenu> FindItems(
    Predicate<KendoMenu> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of KendoMenu) _
) As IList(Of KendoMenu)
Visual C++
public:
IList<KendoMenu^>^ FindItems(
    Predicate<KendoMenu^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' KendoMenu >)>)>
The predicate used as a search criteria.

Return Value

The menu found or 'null' if no menu matches the given search criteria.

See Also

KendoMenu Class
Telerik.TestingFramework.Controls.KendoUI Namespace


FindMenu Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..FindMenu Method
KendoMenu Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenu.FindMenu(System.Predicate{Telerik.TestingFramework.Controls.KendoUI.KendoMenu})"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoMenu FindMenu(
    Predicate<KendoMenu> predicate
)
Visual Basic
Public Function FindMenu ( _
    predicate As Predicate(Of KendoMenu) _
) As KendoMenu
Visual C++
public:
KendoMenu^ FindMenu(
    Predicate<KendoMenu^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' KendoMenu >)>)>

[Missing <param name="predicate"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenu.FindMenu(System.Predicate{Telerik.TestingFramework.Controls.KendoUI.KendoMenu})"]

Return Value

[Missing <returns> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenu.FindMenu(System.Predicate{Telerik.TestingFramework.Controls.KendoUI.KendoMenu})"]

See Also

KendoMenu Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..GetValue Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..InvokeEvent Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..MouseClick Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..MouseHover Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..ScrollToVisible Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu..::..SetValue Method
KendoMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoMenu Class
KendoMenu Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenu Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenu Properties
KendoMenu Class See Also Send Feedback

The KendoMenu type exposes the following members.

Properties

 | Name | Description
Public property | AllMenus | Collection containing the sub Menu items of the Menu.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoMenu. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | closeOnClick | Whether the menu closes on option seselected
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoMenu. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MenuId | The Menu id.
Public property | openOnClick | Whether the opens and closes on root item click
Public property | OrientationType | Menu orientation.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoMenu Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants Members
KendoMenuConstants Class Fields See Also Send Feedback

The KendoMenuConstants type exposes the following members.

Fields

Name | Description
CssArrowSpan | The CSS calss of the arrow span.
CssArrowSpanOld |
CssDisabledItem | The class of disabled menu item
CssMenu | The class of the kendo Menu
CssMenuItem | The CSS class identifying menu item
CssMenuItemLinkSpan | The CSS class identifying menu link (contained span).
CssOpenedItem | The class of opened menu item
MenuKey | The name identifying the menu control.

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants Fields
KendoMenuConstants Class See Also Send Feedback

The KendoMenuConstants type exposes the following members.

Fields

Name | Description
CssArrowSpan | The CSS calss of the arrow span.
CssArrowSpanOld |
CssDisabledItem | The class of disabled menu item
CssMenu | The class of the kendo Menu
CssMenuItem | The CSS class identifying menu item
CssMenuItemLinkSpan | The CSS class identifying menu link (contained span).
CssOpenedItem | The class of opened menu item
MenuKey | The name identifying the menu control.

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssArrowSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants..::..CssArrowSpan Field
KendoMenuConstants Class See Also Send Feedback
The CSS calss of the arrow span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssArrowSpan
Visual Basic
Public Const CssArrowSpan As String
Visual C++
public:
literal String^ CssArrowSpan

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssArrowSpanOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants..::..CssArrowSpanOld Field
KendoMenuConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoMenuConstants.CssArrowSpanOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssArrowSpanOld
Visual Basic
Public Const CssArrowSpanOld As String
Visual C++
public:
literal String^ CssArrowSpanOld

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssDisabledItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants..::..CssDisabledItem Field
KendoMenuConstants Class See Also Send Feedback
The class of disabled menu item

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssDisabledItem
Visual Basic
Public Const CssDisabledItem As String
Visual C++
public:
literal String^ CssDisabledItem

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssMenu Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants..::..CssMenu Field
KendoMenuConstants Class See Also Send Feedback
The class of the kendo Menu

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssMenu
Visual Basic
Public Const CssMenu As String
Visual C++
public:
literal String^ CssMenu

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssMenuItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants..::..CssMenuItem Field
KendoMenuConstants Class See Also Send Feedback
The CSS class identifying menu item

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssMenuItem
Visual Basic
Public Const CssMenuItem As String
Visual C++
public:
literal String^ CssMenuItem

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssMenuItemLinkSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants..::..CssMenuItemLinkSpan Field
KendoMenuConstants Class See Also Send Feedback
The CSS class identifying menu link (contained span).

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssMenuItemLinkSpan
Visual Basic
Public Const CssMenuItemLinkSpan As String
Visual C++
public:
literal String^ CssMenuItemLinkSpan

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssOpenedItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants..::..CssOpenedItem Field
KendoMenuConstants Class See Also Send Feedback
The class of opened menu item

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssOpenedItem
Visual Basic
Public Const CssOpenedItem As String
Visual C++
public:
literal String^ CssOpenedItem

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


MenuKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuConstants..::..MenuKey Field
KendoMenuConstants Class See Also Send Feedback
The name identifying the menu control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string MenuKey
Visual Basic
Public Const MenuKey As String
Visual C++
public:
literal String^ MenuKey

See Also

KendoMenuConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem Members
KendoMenuItem Class Constructors Methods Properties See Also Send Feedback

The KendoMenuItem type exposes the following members.

Constructors

 | Name | Description
Public method | KendoMenuItem()()()() | Initializes a new instance of the KendoMenuItem class.
Public method | KendoMenuItem(Element) | Initializes a new instance of the KendoMenuItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlListItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Closes the MenuItem.
Public method | ControlAssert |
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | opens the menuitem
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllOptions | Collection containing the options of the menu
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Returns 'true' if the Menu is disabled. Otherwise 'false'.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoMenuItem. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Menu | Returns the parent Menu of the .
Public property | MenuItemIndex | Returns the index of the current menu.
Public property | MenuItemTitle | Gets current MenuItem title.
Public property | Opened | Returns 'true' if the Menu item is opened. Otherwise 'false'.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem Constructor
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoMenuItem()()()() | Initializes a new instance of the KendoMenuItem class.
Public method | KendoMenuItem(Element) | Initializes a new instance of the KendoMenuItem class.

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem Constructor
KendoMenuItem Class See Also Send Feedback
Initializes a new instance of the KendoMenuItem class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoMenuItem()
Visual Basic
Public Sub New
Visual C++
public:
KendoMenuItem()

See Also

KendoMenuItem Class
KendoMenuItem Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem Constructor (Element)
KendoMenuItem Class See Also Send Feedback
Initializes a new instance of the KendoMenuItem class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoMenuItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoMenuItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenuItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoMenuItem Class
KendoMenuItem Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem Methods
KendoMenuItem Class See Also Send Feedback

The KendoMenuItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlListItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Closes the MenuItem.
Public method | ControlAssert |
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | opens the menuitem
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoMenuItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..AssignElement Method
KendoMenuItem Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoMenuItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..CallMethod Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..Capture Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..Click Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..Close Method
KendoMenuItem Class See Also Send Feedback
Closes the MenuItem.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

KendoMenuItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..ControlAssert Method
KendoMenuItem Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenuItem.ControlAssert"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenuItem.ControlAssert"]

See Also

KendoMenuItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..DragTo Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..GetValue Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..InvokeEvent Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..MouseClick Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..MouseHover Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Open Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..Open Method
KendoMenuItem Class See Also Send Feedback
opens the menuitem

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Open()
Visual Basic
Public Sub Open
Visual C++
public:
void Open()

See Also

KendoMenuItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..ScrollToVisible Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..Select Method
KendoMenuItem Class See Also Send Feedback
Selects

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

KendoMenuItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem..::..SetValue Method
KendoMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
KendoMenuItem Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuItem Properties
KendoMenuItem Class See Also Send Feedback

The KendoMenuItem type exposes the following members.

Properties

 | Name | Description
Public property | AllOptions | Collection containing the options of the menu
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Returns 'true' if the Menu is disabled. Otherwise 'false'.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoMenuItem. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Menu | Returns the parent Menu of the .
Public property | MenuItemIndex | Returns the index of the current menu.
Public property | MenuItemTitle | Gets current MenuItem title.
Public property | Opened | Returns 'true' if the Menu item is opened. Otherwise 'false'.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoMenuItem Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuOption Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption Members
KendoMenuOption Class Constructors Methods Properties See Also Send Feedback

The KendoMenuOption type exposes the following members.

Constructors

 | Name | Description
Public method | KendoMenuOption()()()() | Initializes a new instance of the Option class.
Public method | KendoMenuOption(Element) | Initializes a new instance of the Option class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlListItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert |
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Clicks the first child span of the option
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Returns 'true' if the Menu is disabled. Otherwise 'false'.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoMenuItem. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MenuItem | Returns the parent MenuItem of the .
Public property | MenuOptionIndex | Returns the index of the current menuOption.
Public property | MenuOptionTitle | Gets current MenuItem title.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuOption Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption Constructor
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoMenuOption()()()() | Initializes a new instance of the Option class.
Public method | KendoMenuOption(Element) | Initializes a new instance of the Option class.

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuOption Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption Constructor
KendoMenuOption Class See Also Send Feedback
Initializes a new instance of the Option class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoMenuOption()
Visual Basic
Public Sub New
Visual C++
public:
KendoMenuOption()

See Also

KendoMenuOption Class
KendoMenuOption Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuOption Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption Constructor (Element)
KendoMenuOption Class See Also Send Feedback
Initializes a new instance of the Option class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoMenuOption(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoMenuOption(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenuOption.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoMenuOption Class
KendoMenuOption Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuOption Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption Methods
KendoMenuOption Class See Also Send Feedback

The KendoMenuOption type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlListItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert |
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Clicks the first child span of the option
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoMenuOption Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..AssignElement Method
KendoMenuOption Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoMenuOption Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..CallMethod Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..Capture Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..Click Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..ControlAssert Method
KendoMenuOption Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenuOption.ControlAssert"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoMenuOption.ControlAssert"]

See Also

KendoMenuOption Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..DragTo Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..GetValue Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..InvokeEvent Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..MouseClick Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..MouseHover Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..ScrollToVisible Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..Select Method
KendoMenuOption Class See Also Send Feedback
Clicks the first child span of the option

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

KendoMenuOption Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption..::..SetValue Method
KendoMenuOption Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
KendoMenuOption Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoMenuOption Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoMenuOption Properties
KendoMenuOption Class See Also Send Feedback

The KendoMenuOption type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Returns 'true' if the Menu is disabled. Otherwise 'false'.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoMenuItem. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MenuItem | Returns the parent MenuItem of the .
Public property | MenuOptionIndex | Returns the index of the current menuOption.
Public property | MenuOptionTitle | Gets current MenuItem title.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoMenuOption Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager Members
KendoPager Class Constructors Methods Properties See Also Send Feedback

The KendoPager type exposes the following members.

Constructors

 | Name | Description
Public method | KendoPager()()()() | Initializes a new instance of the KendoPager class.
Public method | KendoPager(Element) | Initializes a new instance of the KendoPager class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectPage |
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoPager (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoPager. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pages | Collection containing pages of the pager
Public property | PagesCount | the number of teh pages shown in the pager
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedPage | string representing the selected page. string is selected (not int) to be compatible with future enhancements
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoPager Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPager Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager Constructor
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoPager()()()() | Initializes a new instance of the KendoPager class.
Public method | KendoPager(Element) | Initializes a new instance of the KendoPager class.

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPager Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager Constructor
KendoPager Class See Also Send Feedback
Initializes a new instance of the KendoPager class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoPager()
Visual Basic
Public Sub New
Visual C++
public:
KendoPager()

See Also

KendoPager Class
KendoPager Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPager Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager Constructor (Element)
KendoPager Class See Also Send Feedback
Initializes a new instance of the KendoPager class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoPager(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoPager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoPager Class
KendoPager Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager Methods
KendoPager Class See Also Send Feedback

The KendoPager type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectPage |
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoPager Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..AssignElement Method
KendoPager Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoPager Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..CallMethod Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..Capture Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..Click Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..ControlAssert Method
KendoPager Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoPager Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..DragTo Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..GetValue Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..InvokeEvent Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..MouseClick Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..MouseHover Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..ScrollToVisible Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SelectPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..SelectPage Method
KendoPager Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPager.SelectPage(System.String)"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void SelectPage(
    string pageTitle
)
Visual Basic
Public Sub SelectPage ( _
    pageTitle As String _
)
Visual C++
public:
void SelectPage(
    String^ pageTitle
)

Parameters

pageTitle
Type: System..::..String

[Missing <param name="pageTitle"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPager.SelectPage(System.String)"]

See Also

KendoPager Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager..::..SetValue Method
KendoPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoPager Class
KendoPager Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPager Properties
KendoPager Class See Also Send Feedback

The KendoPager type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoPager (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoPager. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pages | Collection containing pages of the pager
Public property | PagesCount | the number of teh pages shown in the pager
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedPage | string representing the selected page. string is selected (not int) to be compatible with future enhancements
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoPager Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPagerConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPagerConstants Members
KendoPagerConstants Class Fields See Also Send Feedback

The KendoPagerConstants type exposes the following members.

Fields

Name | Description
CssPageLink | The CSS class identifying page link (contained anchor).
CssPager | The CSS class identifying the control.
PagerKey | The name identifying the PanelBar control.

See Also

KendoPagerConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPagerConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPagerConstants Fields
KendoPagerConstants Class See Also Send Feedback

The KendoPagerConstants type exposes the following members.

Fields

Name | Description
CssPageLink | The CSS class identifying page link (contained anchor).
CssPager | The CSS class identifying the control.
PagerKey | The name identifying the PanelBar control.

See Also

KendoPagerConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssPageLink Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPagerConstants..::..CssPageLink Field
KendoPagerConstants Class See Also Send Feedback
The CSS class identifying page link (contained anchor).

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssPageLink
Visual Basic
Public Const CssPageLink As String
Visual C++
public:
literal String^ CssPageLink

See Also

KendoPagerConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssPager Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPagerConstants..::..CssPager Field
KendoPagerConstants Class See Also Send Feedback
The CSS class identifying the control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssPager
Visual Basic
Public Const CssPager As String
Visual C++
public:
literal String^ CssPager

See Also

KendoPagerConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


PagerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPagerConstants..::..PagerKey Field
KendoPagerConstants Class See Also Send Feedback
The name identifying the PanelBar control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string PagerKey
Visual Basic
Public Const PagerKey As String
Visual C++
public:
literal String^ PagerKey

See Also

KendoPagerConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel Members
KendoPanel Class Constructors Methods Properties See Also Send Feedback

The KendoPanel type exposes the following members.

Constructors

 | Name | Description
Public method | KendoPanel()()()() | Initializes a new instance of the KendoPanel class.
Public method | KendoPanel(Element) | Initializes a new instance of the KendoPanel class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapses the panel.
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the panel.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects the Panel.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Toggle | Toggles the state of the panel.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Returns 'true' if the Panel is disabled. Otherwise 'false'.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Returns 'true' if the Panel is expanded. Otherwise 'false'.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoPanel. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PanelBar | Returns the parent PanelBar of the Panel.
Public property | PanelIndex | Returns the index of the current panel.
Public property | PanelTitle | Gets current KendoPanel title.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Returns 'true' if the Panel is selected. Otherwise 'false'.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanel Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel Constructor
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoPanel()()()() | Initializes a new instance of the KendoPanel class.
Public method | KendoPanel(Element) | Initializes a new instance of the KendoPanel class.

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel Constructor
KendoPanel Class See Also Send Feedback
Initializes a new instance of the KendoPanel class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoPanel()
Visual Basic
Public Sub New
Visual C++
public:
KendoPanel()

See Also

KendoPanel Class
KendoPanel Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanel Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel Constructor (Element)
KendoPanel Class See Also Send Feedback
Initializes a new instance of the KendoPanel class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoPanel(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoPanel(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPanel.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoPanel Class
KendoPanel Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel Methods
KendoPanel Class See Also Send Feedback

The KendoPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapses the panel.
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the panel.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects the Panel.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Toggle | Toggles the state of the panel.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..AssignElement Method
KendoPanel Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..CallMethod Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..Capture Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..Click Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..Collapse Method
KendoPanel Class See Also Send Feedback
Collapses the panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..ControlAssert Method
KendoPanel Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoPanelAssert instance initialized for this control.

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..DragTo Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..Expand Method
KendoPanel Class See Also Send Feedback
Expands the panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..GetValue Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..InvokeEvent Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..MouseClick Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..MouseHover Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..ScrollToVisible Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..Select Method
KendoPanel Class See Also Send Feedback
Selects the Panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..SetValue Method
KendoPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoPanel Class
KendoPanel Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel..::..Toggle Method
KendoPanel Class See Also Send Feedback
Toggles the state of the panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Toggle()
Visual Basic
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanel Properties
KendoPanel Class See Also Send Feedback

The KendoPanel type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Returns 'true' if the Panel is disabled. Otherwise 'false'.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Returns 'true' if the Panel is expanded. Otherwise 'false'.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoPanel. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PanelBar | Returns the parent PanelBar of the Panel.
Public property | PanelIndex | Returns the index of the current panel.
Public property | PanelTitle | Gets current KendoPanel title.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Returns 'true' if the Panel is selected. Otherwise 'false'.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoPanel Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanelBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar Members
KendoPanelBar Class Constructors Methods Properties See Also Send Feedback

The KendoPanelBar type exposes the following members.

Constructors

 | Name | Description
Public method | KendoPanelBar()()()() | Initializes a new instance of the KendoPanelBar class.
Public method | KendoPanelBar(Element) | Initializes a new instance of the KendoPanelBar class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CollapsePanelByIndex | Collapses the panel.
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandPanelByIndex | Expands the panel.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Find tab by given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindTab |
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectByIndex | Selects Tab by index, zero based.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllPanels | Collection containing the sub tab items of the PanelBar.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoPanelBar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | ExpandMode | Gets the expand mode of the PanelBar.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoPanelBar. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PanelBarId | The PanelBar's id.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanelBar Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar Constructor
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoPanelBar()()()() | Initializes a new instance of the KendoPanelBar class.
Public method | KendoPanelBar(Element) | Initializes a new instance of the KendoPanelBar class.

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanelBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar Constructor
KendoPanelBar Class See Also Send Feedback
Initializes a new instance of the KendoPanelBar class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoPanelBar()
Visual Basic
Public Sub New
Visual C++
public:
KendoPanelBar()

See Also

KendoPanelBar Class
KendoPanelBar Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanelBar Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar Constructor (Element)
KendoPanelBar Class See Also Send Feedback
Initializes a new instance of the KendoPanelBar class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoPanelBar(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoPanelBar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPanelBar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoPanelBar Class
KendoPanelBar Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanelBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar Methods
KendoPanelBar Class See Also Send Feedback

The KendoPanelBar type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CollapsePanelByIndex | Collapses the panel.
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandPanelByIndex | Expands the panel.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Find tab by given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindTab |
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectByIndex | Selects Tab by index, zero based.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..AssignElement Method
KendoPanelBar Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..CallMethod Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..Capture Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..Click Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


CollapsePanelByIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..CollapsePanelByIndex Method
KendoPanelBar Class See Also Send Feedback
Collapses the panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void CollapsePanelByIndex(
    int index
)
Visual Basic
Public Sub CollapsePanelByIndex ( _
    index As Integer _
)
Visual C++
public:
void CollapsePanelByIndex(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPanelBar.CollapsePanelByIndex(System.Int32)"]

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..ControlAssert Method
KendoPanelBar Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..DragTo Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ExpandPanelByIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..ExpandPanelByIndex Method
KendoPanelBar Class See Also Send Feedback
Expands the panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void ExpandPanelByIndex(
    int index
)
Visual Basic
Public Sub ExpandPanelByIndex ( _
    index As Integer _
)
Visual C++
public:
void ExpandPanelByIndex(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPanelBar.ExpandPanelByIndex(System.Int32)"]

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..FindItems Method
KendoPanelBar Class See Also Send Feedback
Find tab by given predicate.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public IList<KendoPanel> FindItems(
    Predicate<KendoPanel> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of KendoPanel) _
) As IList(Of KendoPanel)
Visual C++
public:
IList<KendoPanel^>^ FindItems(
    Predicate<KendoPanel^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' KendoPanel >)>)>
The predicate used as a search criteria.

Return Value

The tab found or 'null' if no tab matches the given search criteria.

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


FindTab Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..FindTab Method
KendoPanelBar Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPanelBar.FindTab(System.Predicate{Telerik.TestingFramework.Controls.KendoUI.KendoPanel})"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoPanel FindTab(
    Predicate<KendoPanel> predicate
)
Visual Basic
Public Function FindTab ( _
    predicate As Predicate(Of KendoPanel) _
) As KendoPanel
Visual C++
public:
KendoPanel^ FindTab(
    Predicate<KendoPanel^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' KendoPanel >)>)>

[Missing <param name="predicate"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPanelBar.FindTab(System.Predicate{Telerik.TestingFramework.Controls.KendoUI.KendoPanel})"]

Return Value

[Missing <returns> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPanelBar.FindTab(System.Predicate{Telerik.TestingFramework.Controls.KendoUI.KendoPanel})"]

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..GetValue Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..InvokeEvent Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..MouseClick Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..MouseHover Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..ScrollToVisible Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SelectByIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..SelectByIndex Method
KendoPanelBar Class See Also Send Feedback
Selects Tab by index, zero based.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void SelectByIndex(
    int index
)
Visual Basic
Public Sub SelectByIndex ( _
    index As Integer _
)
Visual C++
public:
void SelectByIndex(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoPanelBar.SelectByIndex(System.Int32)"]

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar..::..SetValue Method
KendoPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
KendoPanelBar Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanelBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBar Properties
KendoPanelBar Class See Also Send Feedback

The KendoPanelBar type exposes the following members.

Properties

 | Name | Description
Public property | AllPanels | Collection containing the sub tab items of the PanelBar.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoPanelBar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | ExpandMode | Gets the expand mode of the PanelBar.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoPanelBar. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PanelBarId | The PanelBar's id.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoPanelBar Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanelBarConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants Members
KendoPanelBarConstants Class Fields See Also Send Feedback

The KendoPanelBarConstants type exposes the following members.

Fields

Name | Description
CssActivePanel | The CSS class identifying selected panel.
CssArrowSpan | The CSS calss of the arrow span.
CssArrowSpanOld |
CssDefaultPanel | The CSS class identifying default panel.
CssDisabledPanel | The CSS class identifying disabled panel.
CssExpandedPanel | The CSS class identifying disabled panel.
CssPanelBar | The CSS class identifying the control.
CssPanelItem | The CSS class identifying panel.
CssPanelLinkSpan | The CSS class identifying panel link (contained span).
PanelBarKey | The name identifying the PanelBar control.
PanelKey | The name identifying the Panel control.

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoPanelBarConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants Fields
KendoPanelBarConstants Class See Also Send Feedback

The KendoPanelBarConstants type exposes the following members.

Fields

Name | Description
CssActivePanel | The CSS class identifying selected panel.
CssArrowSpan | The CSS calss of the arrow span.
CssArrowSpanOld |
CssDefaultPanel | The CSS class identifying default panel.
CssDisabledPanel | The CSS class identifying disabled panel.
CssExpandedPanel | The CSS class identifying disabled panel.
CssPanelBar | The CSS class identifying the control.
CssPanelItem | The CSS class identifying panel.
CssPanelLinkSpan | The CSS class identifying panel link (contained span).
PanelBarKey | The name identifying the PanelBar control.
PanelKey | The name identifying the Panel control.

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssActivePanel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssActivePanel Field
KendoPanelBarConstants Class See Also Send Feedback
The CSS class identifying selected panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssActivePanel
Visual Basic
Public Const CssActivePanel As String
Visual C++
public:
literal String^ CssActivePanel

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssArrowSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssArrowSpan Field
KendoPanelBarConstants Class See Also Send Feedback
The CSS calss of the arrow span.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssArrowSpan
Visual Basic
Public Const CssArrowSpan As String
Visual C++
public:
literal String^ CssArrowSpan

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssArrowSpanOld Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssArrowSpanOld Field
KendoPanelBarConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoPanelBarConstants.CssArrowSpanOld"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssArrowSpanOld
Visual Basic
Public Const CssArrowSpanOld As String
Visual C++
public:
literal String^ CssArrowSpanOld

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssDefaultPanel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssDefaultPanel Field
KendoPanelBarConstants Class See Also Send Feedback
The CSS class identifying default panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssDefaultPanel
Visual Basic
Public Const CssDefaultPanel As String
Visual C++
public:
literal String^ CssDefaultPanel

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssDisabledPanel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssDisabledPanel Field
KendoPanelBarConstants Class See Also Send Feedback
The CSS class identifying disabled panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssDisabledPanel
Visual Basic
Public Const CssDisabledPanel As String
Visual C++
public:
literal String^ CssDisabledPanel

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssExpandedPanel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssExpandedPanel Field
KendoPanelBarConstants Class See Also Send Feedback
The CSS class identifying disabled panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssExpandedPanel
Visual Basic
Public Const CssExpandedPanel As String
Visual C++
public:
literal String^ CssExpandedPanel

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssPanelBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssPanelBar Field
KendoPanelBarConstants Class See Also Send Feedback
The CSS class identifying the control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssPanelBar
Visual Basic
Public Const CssPanelBar As String
Visual C++
public:
literal String^ CssPanelBar

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssPanelItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssPanelItem Field
KendoPanelBarConstants Class See Also Send Feedback
The CSS class identifying panel.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssPanelItem
Visual Basic
Public Const CssPanelItem As String
Visual C++
public:
literal String^ CssPanelItem

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssPanelLinkSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..CssPanelLinkSpan Field
KendoPanelBarConstants Class See Also Send Feedback
The CSS class identifying panel link (contained span).

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssPanelLinkSpan
Visual Basic
Public Const CssPanelLinkSpan As String
Visual C++
public:
literal String^ CssPanelLinkSpan

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


PanelBarKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..PanelBarKey Field
KendoPanelBarConstants Class See Also Send Feedback
The name identifying the PanelBar control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string PanelBarKey
Visual Basic
Public Const PanelBarKey As String
Visual C++
public:
literal String^ PanelBarKey

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


PanelKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoPanelBarConstants..::..PanelKey Field
KendoPanelBarConstants Class See Also Send Feedback
The name identifying the Panel control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string PanelKey
Visual Basic
Public Const PanelKey As String
Visual C++
public:
literal String^ PanelKey

See Also

KendoPanelBarConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTab Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab Members
KendoTab Class Constructors Methods Properties See Also Send Feedback

The KendoTab type exposes the following members.

Constructors

 | Name | Description
Public method | KendoTab()()()() | Initializes a new instance of the KendoTab class.
Public method | KendoTab(Element) | Initializes a new instance of the KendoTab class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Disabled | Returns 'true' if the Tab is disabled. Otherwise 'false'.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects Tab
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTab. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Returns 'true' if the Tab is selected. Otherwise 'false'.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Returns the index of the current tab.
Public property | TabTitle | Gets current KendoTab title.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoTab Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTab Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab Constructor
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoTab()()()() | Initializes a new instance of the KendoTab class.
Public method | KendoTab(Element) | Initializes a new instance of the KendoTab class.

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTab Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab Constructor
KendoTab Class See Also Send Feedback
Initializes a new instance of the KendoTab class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTab()
Visual Basic
Public Sub New
Visual C++
public:
KendoTab()

See Also

KendoTab Class
KendoTab Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTab Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab Constructor (Element)
KendoTab Class See Also Send Feedback
Initializes a new instance of the KendoTab class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTab(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoTab(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoTab.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoTab Class
KendoTab Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTab Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab Methods
KendoTab Class See Also Send Feedback

The KendoTab type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Disabled | Returns 'true' if the Tab is disabled. Otherwise 'false'.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects Tab
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoTab Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..AssignElement Method
KendoTab Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoTab Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..CallMethod Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..Capture Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..Click Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..ControlAssert Method
KendoTab Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoTab Class
Telerik.TestingFramework.Controls.KendoUI Namespace


Disabled Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..Disabled Method
KendoTab Class See Also Send Feedback
Returns 'true' if the Tab is disabled. Otherwise 'false'.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public bool Disabled()
Visual Basic
Public Function Disabled As Boolean
Visual C++
public:
bool Disabled()

Return Value

Whether the Tab is disabled

See Also

KendoTab Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..DragTo Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..GetValue Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..InvokeEvent Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..MouseClick Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..MouseHover Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..ScrollToVisible Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..Select Method
KendoTab Class See Also Send Feedback
Selects Tab

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

KendoTab Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab..::..SetValue Method
KendoTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoTab Class
KendoTab Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTab Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTab Properties
KendoTab Class See Also Send Feedback

The KendoTab type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTab. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Returns 'true' if the Tab is selected. Otherwise 'false'.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Returns the index of the current tab.
Public property | TabTitle | Gets current KendoTab title.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoTab Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTabStrip Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip Members
KendoTabStrip Class Constructors Methods Properties See Also Send Feedback

The KendoTabStrip type exposes the following members.

Constructors

 | Name | Description
Public method | KendoTabStrip()()()() | Initializes a new instance of the KendoTabStrip class.
Public method | KendoTabStrip(Element) | Initializes a new instance of the KendoTabStrip class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Get the list of the sub tabs matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindTab | Find tab by given predicate.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectByIndex | Selects Tab by index, zero based.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllTabs | Collection containing the sub tab items of the TabStrip.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoTabStrip. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTabStrip. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTabStrip Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip Constructor
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoTabStrip()()()() | Initializes a new instance of the KendoTabStrip class.
Public method | KendoTabStrip(Element) | Initializes a new instance of the KendoTabStrip class.

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTabStrip Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip Constructor
KendoTabStrip Class See Also Send Feedback
Initializes a new instance of the KendoTabStrip class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTabStrip()
Visual Basic
Public Sub New
Visual C++
public:
KendoTabStrip()

See Also

KendoTabStrip Class
KendoTabStrip Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTabStrip Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip Constructor (Element)
KendoTabStrip Class See Also Send Feedback
Initializes a new instance of the KendoTabStrip class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTabStrip(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoTabStrip(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoTabStrip.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoTabStrip Class
KendoTabStrip Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTabStrip Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip Methods
KendoTabStrip Class See Also Send Feedback

The KendoTabStrip type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Get the list of the sub tabs matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindTab | Find tab by given predicate.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectByIndex | Selects Tab by index, zero based.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoTabStrip Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..AssignElement Method
KendoTabStrip Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoTabStrip Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..CallMethod Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..Capture Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..Click Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..ControlAssert Method
KendoTabStrip Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoTabStrip Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..DragTo Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..FindItems Method
KendoTabStrip Class See Also Send Feedback
Get the list of the sub tabs matching the given predicate.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public IList<KendoTab> FindItems(
    Predicate<KendoTab> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of KendoTab) _
) As IList(Of KendoTab)
Visual C++
public:
IList<KendoTab^>^ FindItems(
    Predicate<KendoTab^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' KendoTab >)>)>
The predicate to search for.

Return Value

The list of the data items matching the given predicate.

See Also

KendoTabStrip Class
Telerik.TestingFramework.Controls.KendoUI Namespace


FindTab Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..FindTab Method
KendoTabStrip Class See Also Send Feedback
Find tab by given predicate.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTab FindTab(
    Predicate<KendoTab> predicate
)
Visual Basic
Public Function FindTab ( _
    predicate As Predicate(Of KendoTab) _
) As KendoTab
Visual C++
public:
KendoTab^ FindTab(
    Predicate<KendoTab^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' KendoTab >)>)>
The predicate used as a search criteria.

Return Value

The tab found or 'null' if no tab matches the given search criteria.

See Also

KendoTabStrip Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..GetValue Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..InvokeEvent Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..MouseClick Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..MouseHover Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..ScrollToVisible Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SelectByIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..SelectByIndex Method
KendoTabStrip Class See Also Send Feedback
Selects Tab by index, zero based.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void SelectByIndex(
    int index
)
Visual Basic
Public Sub SelectByIndex ( _
    index As Integer _
)
Visual C++
public:
void SelectByIndex(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoTabStrip.SelectByIndex(System.Int32)"]

See Also

KendoTabStrip Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip..::..SetValue Method
KendoTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
KendoTabStrip Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTabStrip Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStrip Properties
KendoTabStrip Class See Also Send Feedback

The KendoTabStrip type exposes the following members.

Properties

 | Name | Description
Public property | AllTabs | Collection containing the sub tab items of the TabStrip.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoTabStrip. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTabStrip. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoTabStrip Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTabStripConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants Members
KendoTabStripConstants Class Fields See Also Send Feedback

The KendoTabStripConstants type exposes the following members.

Fields

Name | Description
CssActiveTab | The CSS class identifying selected Tab.
CssDisabledTab | The CSS class identifying disabled Tab.
CssTabItem | The CSS Class of the Tab item.
CssTabLink | The CSS class identifying Tab name.
CssTabStrip | The CSS class identifying the control.
KeyTab | The name identifying the Tab control.
KeyTabStrip | The name identifying the TabStrip control.

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTabStripConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants Fields
KendoTabStripConstants Class See Also Send Feedback

The KendoTabStripConstants type exposes the following members.

Fields

Name | Description
CssActiveTab | The CSS class identifying selected Tab.
CssDisabledTab | The CSS class identifying disabled Tab.
CssTabItem | The CSS Class of the Tab item.
CssTabLink | The CSS class identifying Tab name.
CssTabStrip | The CSS class identifying the control.
KeyTab | The name identifying the Tab control.
KeyTabStrip | The name identifying the TabStrip control.

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssActiveTab Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants..::..CssActiveTab Field
KendoTabStripConstants Class See Also Send Feedback
The CSS class identifying selected Tab.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssActiveTab
Visual Basic
Public Const CssActiveTab As String
Visual C++
public:
literal String^ CssActiveTab

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssDisabledTab Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants..::..CssDisabledTab Field
KendoTabStripConstants Class See Also Send Feedback
The CSS class identifying disabled Tab.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssDisabledTab
Visual Basic
Public Const CssDisabledTab As String
Visual C++
public:
literal String^ CssDisabledTab

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssTabItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants..::..CssTabItem Field
KendoTabStripConstants Class See Also Send Feedback
The CSS Class of the Tab item.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssTabItem
Visual Basic
Public Const CssTabItem As String
Visual C++
public:
literal String^ CssTabItem

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssTabLink Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants..::..CssTabLink Field
KendoTabStripConstants Class See Also Send Feedback
The CSS class identifying Tab name.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssTabLink
Visual Basic
Public Const CssTabLink As String
Visual C++
public:
literal String^ CssTabLink

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssTabStrip Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants..::..CssTabStrip Field
KendoTabStripConstants Class See Also Send Feedback
The CSS class identifying the control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssTabStrip
Visual Basic
Public Const CssTabStrip As String
Visual C++
public:
literal String^ CssTabStrip

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KeyTab Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants..::..KeyTab Field
KendoTabStripConstants Class See Also Send Feedback
The name identifying the Tab control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string KeyTab
Visual Basic
Public Const KeyTab As String
Visual C++
public:
literal String^ KeyTab

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KeyTabStrip Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTabStripConstants..::..KeyTabStrip Field
KendoTabStripConstants Class See Also Send Feedback
The name identifying the TabStrip control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string KeyTabStrip
Visual Basic
Public Const KeyTabStrip As String
Visual C++
public:
literal String^ KeyTabStrip

See Also

KendoTabStripConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeNode Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode Members
KendoTreeNode Class Constructors Methods Properties See Also Send Feedback

The KendoTreeNode type exposes the following members.

Constructors

 | Name | Description
Public method | KendoTreeNode()()()() | Initializes a new instance of the KendoMenuItem class.
Public method | KendoTreeNode(Element) | Initializes a new instance of the KendoTreeView class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapse node
Public method | ControlAssert |
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expand node
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Collapse node
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ChildNodesCount |
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Returns 'true' if the Node is disabled. Otherwise 'false'.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Returns 'true' if the Node is expanded. Otherwise 'false'.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsRoot | Returns 'true' if the Node expandable. Otherwise 'false'.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTreeNode (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NodeIndex | Returns the index of the current node.
Public property | NodeName |
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentTree | Returns the parent TreeView
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Returns 'true' if the Node is selected. Otherwise 'false'.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeNode Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode Constructor
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoTreeNode()()()() | Initializes a new instance of the KendoMenuItem class.
Public method | KendoTreeNode(Element) | Initializes a new instance of the KendoTreeView class.

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeNode Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode Constructor
KendoTreeNode Class See Also Send Feedback
Initializes a new instance of the KendoMenuItem class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTreeNode()
Visual Basic
Public Sub New
Visual C++
public:
KendoTreeNode()

See Also

KendoTreeNode Class
KendoTreeNode Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeNode Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode Constructor (Element)
KendoTreeNode Class See Also Send Feedback
Initializes a new instance of the KendoTreeView class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTreeNode(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoTreeNode(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoTreeNode.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoTreeNode Class
KendoTreeNode Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeNode Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode Methods
KendoTreeNode Class See Also Send Feedback

The KendoTreeNode type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapse node
Public method | ControlAssert |
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expand node
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Collapse node
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoTreeNode Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..AssignElement Method
KendoTreeNode Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoTreeNode Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..CallMethod Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..Capture Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..Click Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..Collapse Method
KendoTreeNode Class See Also Send Feedback
Collapse node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

KendoTreeNode Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..ControlAssert Method
KendoTreeNode Class See Also Send Feedback

[Missing <summary> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoTreeNode.ControlAssert"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoTreeNode.ControlAssert"]

See Also

KendoTreeNode Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..DragTo Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..Expand Method
KendoTreeNode Class See Also Send Feedback
Expand node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

KendoTreeNode Class
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..GetValue Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..InvokeEvent Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..MouseClick Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..MouseHover Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..ScrollToVisible Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..Select Method
KendoTreeNode Class See Also Send Feedback
Collapse node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

KendoTreeNode Class
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode..::..SetValue Method
KendoTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
KendoTreeNode Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeNode Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeNode Properties
KendoTreeNode Class See Also Send Feedback

The KendoTreeNode type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ChildNodesCount |
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Disabled | Returns 'true' if the Node is disabled. Otherwise 'false'.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Returns 'true' if the Node is expanded. Otherwise 'false'.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsRoot | Returns 'true' if the Node expandable. Otherwise 'false'.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTreeNode (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NodeIndex | Returns the index of the current node.
Public property | NodeName |
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentTree | Returns the parent TreeView
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Returns 'true' if the Node is selected. Otherwise 'false'.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoTreeNode Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView Members
KendoTreeView Class Constructors Methods Properties See Also Send Feedback

The KendoTreeView type exposes the following members.

Constructors

 | Name | Description
Public method | KendoTreeView()()()() | Initializes a new instance of the KendoTReeView class.
Public method | KendoTreeView(Element) | Initializes a new instance of the KendoTreeView class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllNodes | Collection containing the sub Menu items of the Menu.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoTreeView. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTreeView (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootNodes | Gets the RootNodes of thet treeview
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeView Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView Constructor
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoTreeView()()()() | Initializes a new instance of the KendoTReeView class.
Public method | KendoTreeView(Element) | Initializes a new instance of the KendoTreeView class.

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView Constructor
KendoTreeView Class See Also Send Feedback
Initializes a new instance of the KendoTReeView class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTreeView()
Visual Basic
Public Sub New
Visual C++
public:
KendoTreeView()

See Also

KendoTreeView Class
KendoTreeView Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeView Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView Constructor (Element)
KendoTreeView Class See Also Send Feedback
Initializes a new instance of the KendoTreeView class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoTreeView(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoTreeView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoTreeView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoTreeView Class
KendoTreeView Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView Methods
KendoTreeView Class See Also Send Feedback

The KendoTreeView type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoTreeView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..AssignElement Method
KendoTreeView Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoTreeView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..CallMethod Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..Capture Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..Click Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..ControlAssert Method
KendoTreeView Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoTreeView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..DragTo Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..GetValue Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..InvokeEvent Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..MouseClick Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..MouseHover Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..ScrollToVisible Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView..::..SetValue Method
KendoTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoTreeView Class
KendoTreeView Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeView Properties
KendoTreeView Class See Also Send Feedback

The KendoTreeView type exposes the following members.

Properties

 | Name | Description
Public property | AllNodes | Collection containing the sub Menu items of the Menu.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoTreeView. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoTreeView (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootNodes | Gets the RootNodes of thet treeview
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

KendoTreeView Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeViewConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants Members
KendoTreeViewConstants Class Fields See Also Send Feedback

The KendoTreeViewConstants type exposes the following members.

Fields

Name | Description
CssArrowSpan | The class arrow for expanding a node
CssCollapsedNode | The CSS calss of the collapsed node
CssDisabledNode | The class of disabled node
CssExpandedNode | The CSS calss of the expanded node
CssNode | The CSS class identifying node item
CssNodeSpan | The CSS class identifying the span contained in teh node
CssSelectedNode | The class of selected node
CssTreeView | The class of the kendo TreeView
TreeNodeKey | The name identifying the TreeNode control.
TreeViewKey | The name identifying the TreeView control.

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoTreeViewConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants Fields
KendoTreeViewConstants Class See Also Send Feedback

The KendoTreeViewConstants type exposes the following members.

Fields

Name | Description
CssArrowSpan | The class arrow for expanding a node
CssCollapsedNode | The CSS calss of the collapsed node
CssDisabledNode | The class of disabled node
CssExpandedNode | The CSS calss of the expanded node
CssNode | The CSS class identifying node item
CssNodeSpan | The CSS class identifying the span contained in teh node
CssSelectedNode | The class of selected node
CssTreeView | The class of the kendo TreeView
TreeNodeKey | The name identifying the TreeNode control.
TreeViewKey | The name identifying the TreeView control.

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssArrowSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..CssArrowSpan Field
KendoTreeViewConstants Class See Also Send Feedback
The class arrow for expanding a node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssArrowSpan
Visual Basic
Public Const CssArrowSpan As String
Visual C++
public:
literal String^ CssArrowSpan

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssCollapsedNode Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..CssCollapsedNode Field
KendoTreeViewConstants Class See Also Send Feedback
The CSS calss of the collapsed node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssCollapsedNode
Visual Basic
Public Const CssCollapsedNode As String
Visual C++
public:
literal String^ CssCollapsedNode

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssDisabledNode Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..CssDisabledNode Field
KendoTreeViewConstants Class See Also Send Feedback
The class of disabled node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssDisabledNode
Visual Basic
Public Const CssDisabledNode As String
Visual C++
public:
literal String^ CssDisabledNode

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssExpandedNode Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..CssExpandedNode Field
KendoTreeViewConstants Class See Also Send Feedback
The CSS calss of the expanded node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssExpandedNode
Visual Basic
Public Const CssExpandedNode As String
Visual C++
public:
literal String^ CssExpandedNode

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssNode Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..CssNode Field
KendoTreeViewConstants Class See Also Send Feedback
The CSS class identifying node item

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssNode
Visual Basic
Public Const CssNode As String
Visual C++
public:
literal String^ CssNode

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssNodeSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..CssNodeSpan Field
KendoTreeViewConstants Class See Also Send Feedback
The CSS class identifying the span contained in teh node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssNodeSpan
Visual Basic
Public Const CssNodeSpan As String
Visual C++
public:
literal String^ CssNodeSpan

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssSelectedNode Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..CssSelectedNode Field
KendoTreeViewConstants Class See Also Send Feedback
The class of selected node

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssSelectedNode
Visual Basic
Public Const CssSelectedNode As String
Visual C++
public:
literal String^ CssSelectedNode

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssTreeView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..CssTreeView Field
KendoTreeViewConstants Class See Also Send Feedback
The class of the kendo TreeView

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssTreeView
Visual Basic
Public Const CssTreeView As String
Visual C++
public:
literal String^ CssTreeView

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


TreeNodeKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..TreeNodeKey Field
KendoTreeViewConstants Class See Also Send Feedback
The name identifying the TreeNode control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string TreeNodeKey
Visual Basic
Public Const TreeNodeKey As String
Visual C++
public:
literal String^ TreeNodeKey

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


TreeViewKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoTreeViewConstants..::..TreeViewKey Field
KendoTreeViewConstants Class See Also Send Feedback
The name identifying the TreeView control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string TreeViewKey
Visual Basic
Public Const TreeViewKey As String
Visual C++
public:
literal String^ TreeViewKey

See Also

KendoTreeViewConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoWindow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow Members
KendoWindow Class Constructors Methods Properties See Also Send Feedback

The KendoWindow type exposes the following members.

Constructors

 | Name | Description
Public method | KendoWindow()()()() | Initializes a new instance of the KendoWindow class.
Public method | KendoWindow(Element) | Initializes a new instance of the KendoWindow class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Closes KendoWindow.
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | IsWindowModal | Returns 'true' if the Window is modal. Otherwise 'false'.
Public method | Maximize | Maximizes KendoWindow.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimize | minimizes KendoWindow.
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Restore | Restores KendoWindow.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoWindow. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsWindowMaximized | Returns 'true' if the Window is maximized. Otherwise 'false'.
Public property | IsWindowMinimized | Returns 'true' if the Window is minimized. Otherwise 'false'.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoWindow. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets current KendoWindow title.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | WindowId | The Window's id.

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoWindow Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow Constructor
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | KendoWindow()()()() | Initializes a new instance of the KendoWindow class.
Public method | KendoWindow(Element) | Initializes a new instance of the KendoWindow class.

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoWindow Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow Constructor
KendoWindow Class See Also Send Feedback
Initializes a new instance of the KendoWindow class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoWindow()
Visual Basic
Public Sub New
Visual C++
public:
KendoWindow()

See Also

KendoWindow Class
KendoWindow Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoWindow Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow Constructor (Element)
KendoWindow Class See Also Send Feedback
Initializes a new instance of the KendoWindow class.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoWindow(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
KendoWindow(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.TestingFramework.Controls.KendoUI.KendoWindow.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

KendoWindow Class
KendoWindow Overload
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoWindow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow Methods
KendoWindow Class See Also Send Feedback

The KendoWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Closes KendoWindow.
Public method | ControlAssert | Gets KendoControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | IsWindowModal | Returns 'true' if the Window is modal. Otherwise 'false'.
Public method | Maximize | Maximizes KendoWindow.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimize | minimizes KendoWindow.
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Restore | Restores KendoWindow.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..AssignElement Method
KendoWindow Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..CallMethod Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..Capture Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..Click Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..Close Method
KendoWindow Class See Also Send Feedback
Closes KendoWindow.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..ControlAssert Method
KendoWindow Class See Also Send Feedback
Gets KendoControlAssert instance initialized for this control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public KendoControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As KendoControlAssert
Visual C++
public:
KendoControlAssert^ ControlAssert()

Return Value

KendoControlAssert instance initialized for this control.

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..DragTo Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..GetValue Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..InvokeEvent Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


IsWindowModal Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..IsWindowModal Method
KendoWindow Class See Also Send Feedback
Returns 'true' if the Window is modal. Otherwise 'false'.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public bool IsWindowModal()
Visual Basic
Public Function IsWindowModal As Boolean
Visual C++
public:
bool IsWindowModal()

Return Value

Whether the Window is modal.

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


Maximize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..Maximize Method
KendoWindow Class See Also Send Feedback
Maximizes KendoWindow.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Maximize()
Visual Basic
Public Sub Maximize
Visual C++
public:
void Maximize()

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


Minimize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..Minimize Method
KendoWindow Class See Also Send Feedback
minimizes KendoWindow.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Minimize()
Visual Basic
Public Sub Minimize
Visual C++
public:
void Minimize()

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..MouseClick Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..MouseHover Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


Restore Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..Restore Method
KendoWindow Class See Also Send Feedback
Restores KendoWindow.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public void Restore()
Visual Basic
Public Sub Restore
Visual C++
public:
void Restore()

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..ScrollToVisible Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow..::..SetValue Method
KendoWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

KendoWindow Class
KendoWindow Members
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoWindow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindow Properties
KendoWindow Class See Also Send Feedback

The KendoWindow type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the KendoWindow. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsWindowMaximized | Returns 'true' if the Window is maximized. Otherwise 'false'.
Public property | IsWindowMinimized | Returns 'true' if the Window is minimized. Otherwise 'false'.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a KendoWindow. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets current KendoWindow title.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | WindowId | The Window's id.

See Also

KendoWindow Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoWindowConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants Members
KendoWindowConstants Class Fields See Also Send Feedback

The KendoWindowConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the Window's close button element.
CssContentWindow |
CssKendoWindowMinimizeButton | The CSS class of the span element representing the minimize button.
CssKendoWindowModalDiv | The CSS class of the div element representing the modal button.
CssKendoWindowStateSpan | The CSS class of the span element representing the restore/maximize button.
CssKendoWindowWrapperDiv | The base CSS class of the KendoWindow wrapper div element.
CssMaximizeButton | The CSS class identifying the Window's maximize button element.
CssMinimizeButton | The CSS class of the span element representing the minimize button.
CssOverlayDiv | The CSS class of the overlay div rendered before the modal window.
CssReloadButton | The CSS class identifying the Window's reload button element.
CssResizeBorder1 | The CSS class identifying the Window's div element, which handles top resize.
CssResizeBorder2 | The CSS class identifying the Window's table cell element, which handles bottom resize.
CssResizeBorder3 | The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.
CssRestoreButton | The CSS class identifying the Window's restore button element.
CssWindow | The CSS class identifying the Window control.
KeyWindow | The name identifying the Window control.

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KendoWindowConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants Fields
KendoWindowConstants Class See Also Send Feedback

The KendoWindowConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the Window's close button element.
CssContentWindow |
CssKendoWindowMinimizeButton | The CSS class of the span element representing the minimize button.
CssKendoWindowModalDiv | The CSS class of the div element representing the modal button.
CssKendoWindowStateSpan | The CSS class of the span element representing the restore/maximize button.
CssKendoWindowWrapperDiv | The base CSS class of the KendoWindow wrapper div element.
CssMaximizeButton | The CSS class identifying the Window's maximize button element.
CssMinimizeButton | The CSS class of the span element representing the minimize button.
CssOverlayDiv | The CSS class of the overlay div rendered before the modal window.
CssReloadButton | The CSS class identifying the Window's reload button element.
CssResizeBorder1 | The CSS class identifying the Window's div element, which handles top resize.
CssResizeBorder2 | The CSS class identifying the Window's table cell element, which handles bottom resize.
CssResizeBorder3 | The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.
CssRestoreButton | The CSS class identifying the Window's restore button element.
CssWindow | The CSS class identifying the Window control.
KeyWindow | The name identifying the Window control.

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssCloseButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssCloseButton Field
KendoWindowConstants Class See Also Send Feedback
The CSS class identifying the Window's close button element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssCloseButton
Visual Basic
Public Const CssCloseButton As String
Visual C++
public:
literal String^ CssCloseButton

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssContentWindow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssContentWindow Field
KendoWindowConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.TestingFramework.Controls.KendoUI.KendoWindowConstants.CssContentWindow"]

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssContentWindow
Visual Basic
Public Const CssContentWindow As String
Visual C++
public:
literal String^ CssContentWindow

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssKendoWindowMinimizeButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssKendoWindowMinimizeButton Field
KendoWindowConstants Class See Also Send Feedback
The CSS class of the span element representing the minimize button.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssKendoWindowMinimizeButton
Visual Basic
Public Const CssKendoWindowMinimizeButton As String
Visual C++
public:
literal String^ CssKendoWindowMinimizeButton

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssKendoWindowModalDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssKendoWindowModalDiv Field
KendoWindowConstants Class See Also Send Feedback
The CSS class of the div element representing the modal button.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssKendoWindowModalDiv
Visual Basic
Public Const CssKendoWindowModalDiv As String
Visual C++
public:
literal String^ CssKendoWindowModalDiv

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssKendoWindowStateSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssKendoWindowStateSpan Field
KendoWindowConstants Class See Also Send Feedback
The CSS class of the span element representing the restore/maximize button.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssKendoWindowStateSpan
Visual Basic
Public Const CssKendoWindowStateSpan As String
Visual C++
public:
literal String^ CssKendoWindowStateSpan

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssKendoWindowWrapperDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssKendoWindowWrapperDiv Field
KendoWindowConstants Class See Also Send Feedback
The base CSS class of the KendoWindow wrapper div element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssKendoWindowWrapperDiv
Visual Basic
Public Const CssKendoWindowWrapperDiv As String
Visual C++
public:
literal String^ CssKendoWindowWrapperDiv

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssMaximizeButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssMaximizeButton Field
KendoWindowConstants Class See Also Send Feedback
The CSS class identifying the Window's maximize button element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssMaximizeButton
Visual Basic
Public Const CssMaximizeButton As String
Visual C++
public:
literal String^ CssMaximizeButton

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssMinimizeButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssMinimizeButton Field
KendoWindowConstants Class See Also Send Feedback
The CSS class of the span element representing the minimize button.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssMinimizeButton
Visual Basic
Public Const CssMinimizeButton As String
Visual C++
public:
literal String^ CssMinimizeButton

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssOverlayDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssOverlayDiv Field
KendoWindowConstants Class See Also Send Feedback
The CSS class of the overlay div rendered before the modal window.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssOverlayDiv
Visual Basic
Public Const CssOverlayDiv As String
Visual C++
public:
literal String^ CssOverlayDiv

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssReloadButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssReloadButton Field
KendoWindowConstants Class See Also Send Feedback
The CSS class identifying the Window's reload button element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssReloadButton
Visual Basic
Public Const CssReloadButton As String
Visual C++
public:
literal String^ CssReloadButton

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssResizeBorder1 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssResizeBorder1 Field
KendoWindowConstants Class See Also Send Feedback
The CSS class identifying the Window's div element, which handles top resize.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssResizeBorder1
Visual Basic
Public Const CssResizeBorder1 As String
Visual C++
public:
literal String^ CssResizeBorder1

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssResizeBorder2 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssResizeBorder2 Field
KendoWindowConstants Class See Also Send Feedback
The CSS class identifying the Window's table cell element, which handles bottom resize.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssResizeBorder2
Visual Basic
Public Const CssResizeBorder2 As String
Visual C++
public:
literal String^ CssResizeBorder2

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssResizeBorder3 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssResizeBorder3 Field
KendoWindowConstants Class See Also Send Feedback
The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssResizeBorder3
Visual Basic
Public Const CssResizeBorder3 As String
Visual C++
public:
literal String^ CssResizeBorder3

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssRestoreButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssRestoreButton Field
KendoWindowConstants Class See Also Send Feedback
The CSS class identifying the Window's restore button element.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssRestoreButton
Visual Basic
Public Const CssRestoreButton As String
Visual C++
public:
literal String^ CssRestoreButton

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


CssWindow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..CssWindow Field
KendoWindowConstants Class See Also Send Feedback
The CSS class identifying the Window control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string CssWindow
Visual Basic
Public Const CssWindow As String
Visual C++
public:
literal String^ CssWindow

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


KeyWindow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
KendoWindowConstants..::..KeyWindow Field
KendoWindowConstants Class See Also Send Feedback
The name identifying the Window control.

Namespace: Telerik.TestingFramework.Controls.KendoUI
Assembly: Telerik.TestingFramework.Controls.KendoUI (in Telerik.TestingFramework.Controls.KendoUI.dll) Version: 2012.1.322.0 (2012.1.322.0)

Syntax

C#
public const string KeyWindow
Visual Basic
Public Const KeyWindow As String
Visual C++
public:
literal String^ KeyWindow

See Also

KendoWindowConstants Class
Telerik.TestingFramework.Controls.KendoUI Namespace


Telerik.WebAii.Controls.Html Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Telerik.WebAii.Controls.Html Namespace
Send Feedback
Namespace for all the HTML control wrapper classes.

Classes

 | Class | Description
Public class | AsyncUploadConstants | Represents the upload constants class.
Public class | ButtonConstants | The RadButtobn constants used across the source classes.
Public class | CalendarConstants | The calendar string constants.
Public class | CalendarFastNavigationPopup | Represents the RadCalendar for ASP.NET AJAX fast navigation popup control wrapper.
Public class | CaptchaConstants | The RadCaptcha constants used across the source classes.
Public class | ColorPickerConstants | String constatns of the colorpicker(Css classes, Id prefix, etc).
Public class | ColorPickerIcon | The icon of the RadColorpicker.
Public class | ColorPickerPalette | The palette of the RadColorPicker.
Public class | ComboBoxConstants | Represents the RadComboBox constants class.
Public class | CommonHelper | Represents a common helper class.
Public class | DataPagerConstants | The ListView string constants.
Public class | DockConstants | String constatns of the dock(Css classes, Id prefix, etc).
Public class | EditorCommand | RadEditor for the ASP.NET AJAX: EditorCommand wrapper.
Public class | EditorConstants | String constatns of the editor(Css classes, Id prefix, etc).
Public class | EditorDropDown | RadEditor for the ASP.NET AJAX: EditorDropDown wrapper.
Public class | EditorDropDownBody | RadEditor for the ASP.NET AJAX: EditorDropDownBody wrapper.
Public class | EditorModeCommand | RadEditor for the ASP.NET AJAX: EditorModeCommand wrapper.
Public class | EditorSpinBox | RadEditor for the ASP.NET AJAX: EditorSpinBox wrapper.
Public class | EditorSplitButton | RadEditor for the ASP.NET AJAX: EditorSplitButton wrapper.
Public class | FileExplorerConstants | The RadFileExplorer constants used across the source classes.
Public class | FilterConstants | The Filter constants used in the verifications and action messages.
Public class | GridConstants | The Grid constants used in the verifications and action messages.
Public class | GridDataCell | Represents the RadGrid for ASP.NET AJAX data cell control wrapper.
Public class | GridDataItem | Represents the RadGrid for ASP.NET AJAX data item control wrapper.
Public class | GridEditForm | Represents the RadGrid for ASP.NET AJAX edit form control wrapper.
Public class | GridFilterItem | Represents the RadGrid for ASP.NET AJAX filter item control wrapper.
Public class | GridFooterCell | Represents the RadGrid for ASP.NET AJAX footer cell control wrapper.
Public class | GridGroupHeader | Represents the RadGrid for ASP.NET AJAX group header control wrapper.
Public class | GridGroupPanel | Represents the RadGrid for ASP.NET AJAX group panel control wrapper.
Public class | GridGroupPanelItem | Represents the RadGrid for ASP.NET AJAX group panel item control wrapper.
Public class | GridHelper | A helper class for the RadGrid wrapper.
Public class | GridPager | Represents the RadGrid for ASP.NET AJAX pager control wrapper.
Public class | GridTableHeader | Represents the RadGrid for ASP.NET AJAX table header control wrapper.
Public class | GridTableView | Represents the RadGrid for ASP.NET AJAX TableView control wrapper.
Public class | HtmlChartConstants | The RadHtmlChart constants used across the source classes.
Public class | HtmlChartTooltip | The Tooltip button of the RadHtmlChart.
Public class | ImageEditorConstants | The RadImageEditor constants used across the source classes.
Public class | IndexesCollection | Represents a custom collection of integer values, serving as a return type for RadGrid wrapper properties.
Public class | InputConstants | The RadInput constants used across the source classes.
Public class | ListBoxConstants | Represents the ListBoxConstants class.
Public class | ListViewConstants | The ListView string constants.
Public class | MenuConstants | Represents the menu constants class.
Public class | NotificationConstants | The RadNotification constants used across the source classes.
Public class | OrgChartConstants | Represents the OrgChartConstants class.
Public class | PanelBarConstants | Represents the PanelBar constants class.
Public class | PivotGridAggregatesZone | Represents the aggregates zone in the PivotGrid.
Public class | PivotGridColumnHeaderCell | Represents the PivotGrid for ASP.NET AJAX row header cell control wrapper.
Public class | PivotGridColumnsZone | Represents the columns zone in the PivotGrid.
Public class | PivotGridConstants | The PivotGrid constants used in the verifications and action messages.
Public class | PivotGridDataCell | Represents the PivotGrid for ASP.NET AJAX data cell control wrapper.
Public class | PivotGridField | Represents the PivotGrid for ASP.NET AJAX field control wrapper.
Public class | PivotGridPager | Represents the PivotGrid for ASP.NET AJAX pager control wrapper.
Public class | PivotGridRowHeaderCell | Represents the PivotGrid for ASP.NET AJAX row header cell control wrapper.
Public class | PivotGridRowsZone | Represents the rows zone in the PivotGrid.
Public class | PivotGridZone | Represents a zone in the PivotGrid.
Public class | RadAsyncUpload | Represents the RadAsyncUpload class.
Public class | RadButton | Represents the RadButton for ASP.NET AJAX control wrapper.
Public class | RadCalendar | Represents the RadCalendar for ASP.NET AJAX control wrapper.
Public class | RadCaptcha | Represents the RadCaptcha for ASP.NET AJAX control wrapper.
Public class | RadColorPicker | RadColorPicker control.
Public class | RadComboBox | Represents the RadComboBox class.
Public class | RadComboBoxItem | Represents the RadComboBoxItem class.
Public class | RadControlAssert | Represents the base class for assertion of RadControls wrappers.
Public class | RadDataPager | Represents RadDataPager for Asp.Net Ajax control wrapper.
Public class | RadDateInput | Represents the RadDateInput for ASP.NET AJAX control wrapper.
Public class | RadDatePicker | Represents the RadDatePicker for ASP.NET AJAX control wrapper.
Public class | RadDateTimePicker | Represents the RadDateTimePicker for ASP.NET AJAX control wrapper.
Public class | RadDock | A simple control wrapper for the RadDock for the ASP.NET AJAX.
Public class | RadDockCommand | A simple control wrapper for the RadDockCommand for the ASP.NET AJAX.
Public class | RadDockZone | A simple control wrapper for the RadEditor for the ASP.NET AJAX.
Public class | RadEditor | A simple control wrapper for the RadEditor for the ASP.NET AJAX.
Public class | RadEditorComment | The RadEditor RadEditorComment name.
Public class | RadEditorCommentsBox | The RadEditor RadEditorCommentsBox name.
Public class | RadEditorCommentsTextBox | The RadEditor RadEditorCommentsTextBox name.
Public class | RadFileExplorer | Represents the RadFileExplorer for ASP.NET AJAX control wrapper.
Public class | RadFileExplorerListItem | The FileExplorer ListView item name.
Public class | RadFilter | Represents RadFilter for Asp.Net Ajax control wrapper.
Public class | RadFilterExpressionItem | Represents the filter Expression Item.
Public class | RadFilterGroupItem | Represents the filter Group Item.
Public class | RadFilterItem | Represents the RadFilterItem.
Public class | RadGrid | Represents the RadGrid for ASP.NET AJAX control wrapper.
Public class | RadHtmlChart | Represents the RadHtmlChart for ASP.NET AJAX control wrapper.
Public class | RadImageEditor | Represents the RadImageEditor for ASP.NET AJAX control wrapper.
Public class | RadInput | Represents the RadInput for ASP.NET AJAX control wrapper.
Public class | RadInputManager | Represents the RadInputManager for ASP.NET AJAX control wrapper.
Public class | RadInputManagerTextBox | Represents the TextBox extended with RadInputManager for ASP.NET AJAX control wrapper.
Public class | RadListBox | Represents the RadListBox class.
Public class | RadListBoxItem | Represents the RadListBoxItem class.
Public class | RadListView | Represents RadListView for Asp.Net Ajax control wrapper.
Public class | RadMaskedTextBox | Represents the RadMaskedTextBox for ASP.NET AJAX control wrapper.
Public class | RadMenu | Represents the RadMenu class.
Public class | RadMenuItem | Represents the RadMenuItem class.
Public class | RadMonthYearPicker | Represents the RadMonthYearPicker for ASP.NET AJAX control wrapper.
Public class | RadNotification | Represents the RadNotification for ASP.NET AJAX control wrapper.
Public class | RadNumericTextBox | Represents the RadNumericTextBox for ASP.NET AJAX control wrapper.
Public class | RadOrgChart | Represents the RadOrgChart class.
Public class | RadOrgChartItem | Represents the RadOrgChartItem class.
Public class | RadPane | The RadPane of the RadSplitter.
Public class | RadPanelBar | Represents the RadPanelBar class.
Public class | RadPanelBarItem | Represents the RadPanelBarItem class.
Public class | RadPicker | Represents the RadDate/DateTime/TimePicker for ASP.NET AJAX control wrapper.
Public class | RadPivotGrid | Represents the RadPivotGrid for ASP.NET AJAX control wrapper.
Public class | RadRating | A simple control wrapper for the RadRating for the ASP.NET AJAX.
Public class | RadRibbonBar | Represents the RadRibbonBar class.
Public class | RadRibbonBarApplicationTab | Represents the RadRibbonBarApplicationTab class.
Public class | RadRibbonBarButton | Represents the RadRibbonBarButton class.
Public class | RadRibbonBarContextualTabGroup | Represents the RadRibbonBarContextualTab class.
Public class | RadRibbonBarGroup | Represents the RadRibbonBarGroup class.
Public class | RadRibbonBarItem | Represents the RadRibbonBarItem class.
Public class | RadRibbonBarMenu | Represents the RadRibbonBarMenu class.
Public class | RadRibbonBarQATMenuItem | Represents the RadRibbonBarQATMenuItem class.
Public class | RadRibbonBarSplitButton | Represents the RadRibbonBarSplitButton class.
Public class | RadRibbonBarTab | Represents the RadRibbonBarTab class.
Public class | RadRibbonBarToggleButton | Represents the RadRibbonBarToggleButton class.
Public class | RadRotator | RadRotator control.
Public class | RadScheduler | A simple control wrapper for the scheduler Control.
Public class | RadSlider | RadSlider control.
Public class | RadSlidingPane | The sliding pane of Radsplitter.
Public class | RadSlidingZone | RadSlidingZone of the RadSplitter.
Public class | RadSocialShare | Represents the RadSocialShare for ASP.NET AJAX control wrapper.
Public class | RadSpellDialog | The content of Radspell dialog window.
Public class | RadSplitBar | The splitbar of the RadSplitter.
Public class | RadSplitter | RadSplitter control.
Public class | RadTab | Represents the RadTab class.
Public class | RadTabStrip | Represents the RadTabStrip class.
Public class | RadTagCloud | Represents the RadTagCloud for ASP.NET AJAX control wrapper.
Public class | RadTextBox | The HtmlControl wrapper for RadTextBox.
Public class | RadTimePicker | Represents the RadTimePicker for ASP.NET AJAX control wrapper.
Public class | RadTimeView | Represents the RadDateTimePicker/RadTimePicker for ASP.NET AJAX TimeView control wrapper.
Public class | RadToolBar | Represents the RadToolBar class.
Public class | RadToolBarButton | Represents the RadToolBarButton class.
Public class | RadToolBarDropDownButton | Represents the RadToolBarDropDownButton class.
Public class | RadToolBarItem | Represents the RadToolBarItem class.
Public class | RadToolBarSplitButton | Represents the RadToolBar SplitButton control wrapper.
Public class | RadToolTip | RadToolTip control.
Public class | RadTreeList | Represents the RadTreeList for ASP.NET AJAX control wrapper.
Public class | RadTreeNode | Represents the RadTreeNode class.
Public class | RadTreeView | Represents the RadTreeView class.
Public class | RadUpload | Represents the RadUpload class.
Public class | RadWindow | RadWindow control.
Public class | RadXmlHttpPanel | Represents the RadXmlHttpPanel for ASP.NET AJAX control wrapper.
Public class | RatingConstants | String constatns of the dock(Css classes, Id prefix, etc).
Public class | RibbonBarConstants | Represents the RibbonBar constants class.
Public class | RotatorConstants | String constatns of the rotator(Css classes, Id prefix, etc).
Public class | SchedulerAppointment | Class that represents the scheduler appointment object.
Public class | SchedulerConstants | Represents the scheduler constants class.
Public class | SchedulerTimeSlot | Represents the SchedulerTimeSlot class.
Public class | SelectedDateCollection | Represents a custom collection of DateTime objects, serving as return type of RadCalendar wrapper properties and methods.
Public class | SliderConstants | String constatns of the slider(Css classes, Id prefix, etc).
Public class | SocialShareBlogger | The Blogger button of the RadSocialShare.
Public class | SocialShareCompactButton | The CompactButton button of the RadSocialShare.
Public class | SocialShareConstants | The RadSocialShare constants used across the source classes.
Public class | SocialShareDelicious | The Delicious button of the RadSocialShare.
Public class | SocialShareDigg | The Digg button of the RadSocialShare.
Public class | SocialShareFacebook | The FaceBook button of the RadSocialShare.
Public class | SocialShareGoogleBookmarks | The GoogleBookmarks button of the RadSocialShare.
Public class | SocialShareLinkedIn | The LinkedIn button of the RadSocialShare.
Public class | SocialShareMailTo | The MailTo button of the RadSocialShare.
Public class | SocialShareMySpace | The MySpace button of the RadSocialShare.
Public class | SocialShareReddit | The Reddit button of the RadSocialShare.
Public class | SocialShareSendEmail | The SendEmail button of the RadSocialShare.
Public class | SocialShareStumbleUpon | The StumbleUpon button of the RadSocialShare.
Public class | SocialShareTumblr | The Tumblr button of the RadSocialShare.
Public class | SocialShareTweeter | The Tweeter button of the RadSocialShare.
Public class | SpellConstants | String constatns of the radspell(Css classes, Id prefix, etc).
Public class | SplitterConstants | String constatns of the splitter(Css classes, Id prefix, etc).
Public class | TabStripConstants | The TabStrip constants class.
Public class | TagCloudConstants | The RadTagCloud constants used across the source classes.
Public class | ToolBarConstants | Class that represents toolbar constants.
Public class | ToolTipConstants | String constatns of the tooltip(Css classes, Id prefix, etc).
Public class | TreeListConstants | The TreeList constants used across the wrappers and translators.
Public class | TreeListDataCell | Represents the RadTreeList for ASP.NET AJAX data cell control wrapper.
Public class | TreeListDataItem | RadTreeList for ASP.NET AJAX Data Item wrapper.
Public class | TreeListEditForm | Represents the RadTreeList for ASP.NET AJAX edit form control wrapper.
Public class | TreeListFooterCell | Represents the RadTreeList for ASP.NET AJAX footer cell control wrapper.
Public class | TreeListHeaderCell | Represents the TreeList for ASP.NET AJAX header cell control wrapper.
Public class | TreeListPager | Represents the RedTreeList for ASP.NET AJAX pager control wrapper.
Public class | TreeViewConstants | Represents the treeview constants class.
Public class | UploadConstants | Represents the upload constants class.
Public class | WindowConstants | String constatns of the window(Css classes, Id prefix, etc).
Public class | XmlHttpPanelConstants | The RadXmlHttpPanel constants used across the source classes.

Enumerations

 | Enumeration | Description
Public enumeration | AsyncUploadModuleType | Type of async upload current module.
Public enumeration | CalendarPresentationType | Enumerates the PresentationType settings of the calendar.
Public enumeration | ComboBoxSelectionType | Type of combobox selection.
Public enumeration | DockingMode | Editor action type enumeration.
Public enumeration | EditorActionType | Editor action type enumeration.
Public enumeration | EditorMode | Editor mode enumeration.
Public enumeration | EditorSpinBoxActionType | Action type enumeration of the editor spinbox.
Public enumeration | EditorSplitButtonActionType | Action types enumeration of the editor splitbutton.
Public enumeration | EditorToolBarMode | Editor toolbar mode enumeration.
Public enumeration | FastNavigationOwnerType | Enumerates the FastNavigationOwnerType settings of the navigation popup.
Public enumeration | FileExplorerExplorerMode | Enumerates the FileExplorer explorer mode.
Public enumeration | FilterItemType | Enumerates the type of the filter items.
Public enumeration | GridAdvancedPagerActionType | Enumerates the Grid advanced pager action type.
Public enumeration | GridColumnSortOrderType | Enumerates the Grid column sort order type.
Public enumeration | GridCommandItemLocation | Enumerates the Grid command item lcation -- either 'top' or 'bottom' command item.
Public enumeration | GridCommandItemType | Enumerates the Grid command item type. The standard 'AddNew' and 'Refresh' are supported.
Public enumeration | GridEditFormActionType | Enumerates the Grid edit form action type.
Public enumeration | GridEditModeType | Enumerates the Grid edit mode type.
Public enumeration | GridGroupExpandCollapseActionType | Enumerates the Grid group expand/collapse action type.
Public enumeration | HtmlChartType | Enumerates the HtmlChart types.
Public enumeration | ImageEditorFlip | Enumerates the ImageEditor flip mode.
Public enumeration | ImageEditorRotation | Enumerates the ImageEditor rotation.
Public enumeration | ImageEditorTool | Enumerates the ImageEditor tools dialogs.
Public enumeration | ListBoxButtonPosition | Type of listbox button position.
Public enumeration | MenuOrientationType | Type of menu orientation type.
Public enumeration | NotificationAnimation | Enumerates the Notification animation.
Public enumeration | NotificationLoadType | Enumerates the Notification load types.
Public enumeration | NotificationPosition | Enumerates the Notification position.
Public enumeration | NotificationScrolling | Enumerates the Notification scrolling.
Public enumeration | PagerMode | Enumerates the TreeList pager modes.
Public enumeration | PivotGridAdvancedPagerActionType | Enumerates the PivotGrid advanced pager action type.
Public enumeration | PivotGridDataCellType | Enumerates the PivotGrid DataCell type.
Public enumeration | PivotGridFieldSortOrderType | Enumerates the Grid column sort order type.
Public enumeration | PivotGridFieldZoneType | PivotGrid field type enumeration
Public enumeration | PivotGridHeaderCellType | Enumerates the PivotGrid HeaderCell type.
Public enumeration | PivotGridHeaderExpandStateType | Enumerates the Grid column sort order type.
Public enumeration | PivotGridPagerItemLocation | Enumerates the PivotGrid pager item lcation -- either 'top' or 'bottom' pager item.
Public enumeration | PivotGridPagingActionType | PivotGrid PagingAction type enumeration.
Public enumeration | PopupDirection | Enumerates the popup opening directions.
Public enumeration | PredefinedLayoutType | Enumerates the predefined layouts of the ListView.
Public enumeration | RadButtonControlToggleType | Control Toggle type of the Button.
Public enumeration | RadButtonControlType | Control type of the Button.
Public enumeration | RadInputControlType | Control type of the Input.
Public enumeration | RadPickerControlType | Enumerates the different picker types.
Public enumeration | RadRibbonBarItemType | Type of the RibbonBar item.
Public enumeration | RadTagCloudSorting | Sorting of the TagCloud.
Public enumeration | RangeSelectionModes |
Public enumeration | RatingPrecision | Specifies the possible values for the Precision property of the RadRating control.
Public enumeration | RatingSelectionMode | Specifies the possible values for the SelectionMode property of the RadRating control.
Public enumeration | ResizeModes | Represents the RadTreeList resize mode.
Public enumeration | RotatorScrollDirection | Rotator scroll direction enumeration.
Public enumeration | RotatorScrollType | Rotator scroll type enumeration.
Public enumeration | RotatorType | The type of approach, that changes the icons of rotaror.
Public enumeration | SchedulerViewNavigationType | Type of scheduler view navigarion.
Public enumeration | SliderDirection | Slider direction.
Public enumeration | SliderOrientation | Slider orientation enumeration.
Public enumeration | SlidingPaneActionType | Action type enumeration of the splitter sliding pane.
Public enumeration | SocialShareButton | Enumerates the SocialShare load types.
Public enumeration | SplitBarActionType | Action type enumeration of the splitbar.
Public enumeration | SplitBarCollapseDirection | The direction of the splitbar collapsing.
Public enumeration | SplitterOrientation | Splitter orientation enumeration.
Public enumeration | SplitterPaneType | Splitter pane type: Previous(Left or Upper) or Next(Right or Down).
Public enumeration | SplitterSlideDirection | Splitter slide direction enumeration.
Public enumeration | TabStripOrientationType | Type of scheduler view navigarion.
Public enumeration | ToolBarButtonType | The ToolBar button type.
Public enumeration | ToolBarOrientationType | ToolBar orientation.
Public enumeration | ToolTipHideMode | Tooltip hide mode enumeration.
Public enumeration | ToolTipRelativeToMode | Tooltip RelativeTo mode enumeration.
Public enumeration | ToolTipShowMode | Tooltip show mode enumeration.
Public enumeration | TreeListAdvancedPagerActionType | Enumerates the TreeList advanced pager action types.
Public enumeration | TreeListColumnSortOrderType | Enumerates the TreeList column sort order type.
Public enumeration | TreeListEditFormActionType | Enumerates Edit form action types.
Public enumeration | TreeListEditFormType | Enumerates the TreeList edit form types.


AsyncUploadConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants Members
AsyncUploadConstants Class Fields See Also Send Feedback

The AsyncUploadConstants type exposes the following members.

Fields

Name | Description
CssClearButton | CSS class of the 'Clear' button.
CssFileInput | CSS class of the file input.
CssFileProgress | CSS class of the async upload progress span.
CssFileProgressWrap | CSS class of the async upload progress wrap.
CssFileWrap | CSS class of the container span.
CssListContainer | CSS class of the async upload list container.
CssProgress | CSS class of the async upload progress area.
CssProgressComplete | CSS class of the async upload progress span success.
CssProgressHidden | CSS class of the async upload progress area when it is hidden.
CssProgressStarted | CSS class of the async upload progress span start.
CssRadAsyncUpload | CSS class of the async upload main div element.
CssRemoveButton | CSS class of the 'Remove' button.
CssSelectButton | CSS class of the 'Select' button.
CssSilverlightObject | CSS class of the async upload silverlight object.
CssUploadProgress | CSS class of the async upload progress span.
CssUploadSuccess | CSS class of the async upload progress span success.
KeyAsyncUpload | The key identifying the AsyncUpload control.

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


AsyncUploadConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants Fields
AsyncUploadConstants Class See Also Send Feedback

The AsyncUploadConstants type exposes the following members.

Fields

Name | Description
CssClearButton | CSS class of the 'Clear' button.
CssFileInput | CSS class of the file input.
CssFileProgress | CSS class of the async upload progress span.
CssFileProgressWrap | CSS class of the async upload progress wrap.
CssFileWrap | CSS class of the container span.
CssListContainer | CSS class of the async upload list container.
CssProgress | CSS class of the async upload progress area.
CssProgressComplete | CSS class of the async upload progress span success.
CssProgressHidden | CSS class of the async upload progress area when it is hidden.
CssProgressStarted | CSS class of the async upload progress span start.
CssRadAsyncUpload | CSS class of the async upload main div element.
CssRemoveButton | CSS class of the 'Remove' button.
CssSelectButton | CSS class of the 'Select' button.
CssSilverlightObject | CSS class of the async upload silverlight object.
CssUploadProgress | CSS class of the async upload progress span.
CssUploadSuccess | CSS class of the async upload progress span success.
KeyAsyncUpload | The key identifying the AsyncUpload control.

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssClearButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssClearButton Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the 'Clear' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssClearButton
Visual Basic
Public Const CssClearButton As String
Visual C++
public:
literal String^ CssClearButton

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFileInput Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssFileInput Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the file input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFileInput
Visual Basic
Public Const CssFileInput As String
Visual C++
public:
literal String^ CssFileInput

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFileProgress Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssFileProgress Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload progress span.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFileProgress
Visual Basic
Public Const CssFileProgress As String
Visual C++
public:
literal String^ CssFileProgress

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFileProgressWrap Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssFileProgressWrap Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload progress wrap.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFileProgressWrap
Visual Basic
Public Const CssFileProgressWrap As String
Visual C++
public:
literal String^ CssFileProgressWrap

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFileWrap Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssFileWrap Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the container span.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFileWrap
Visual Basic
Public Const CssFileWrap As String
Visual C++
public:
literal String^ CssFileWrap

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListContainer Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssListContainer Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload list container.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListContainer
Visual Basic
Public Const CssListContainer As String
Visual C++
public:
literal String^ CssListContainer

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssProgress Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssProgress Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload progress area.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssProgress
Visual Basic
Public Const CssProgress As String
Visual C++
public:
literal String^ CssProgress

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssProgressComplete Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssProgressComplete Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload progress span success.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssProgressComplete
Visual Basic
Public Const CssProgressComplete As String
Visual C++
public:
literal String^ CssProgressComplete

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssProgressHidden Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssProgressHidden Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload progress area when it is hidden.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssProgressHidden
Visual Basic
Public Const CssProgressHidden As String
Visual C++
public:
literal String^ CssProgressHidden

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssProgressStarted Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssProgressStarted Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload progress span start.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssProgressStarted
Visual Basic
Public Const CssProgressStarted As String
Visual C++
public:
literal String^ CssProgressStarted

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadAsyncUpload Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssRadAsyncUpload Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload main div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadAsyncUpload
Visual Basic
Public Const CssRadAsyncUpload As String
Visual C++
public:
literal String^ CssRadAsyncUpload

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRemoveButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssRemoveButton Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the 'Remove' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRemoveButton
Visual Basic
Public Const CssRemoveButton As String
Visual C++
public:
literal String^ CssRemoveButton

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSelectButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssSelectButton Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the 'Select' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSelectButton
Visual Basic
Public Const CssSelectButton As String
Visual C++
public:
literal String^ CssSelectButton

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSilverlightObject Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssSilverlightObject Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload silverlight object.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSilverlightObject
Visual Basic
Public Const CssSilverlightObject As String
Visual C++
public:
literal String^ CssSilverlightObject

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssUploadProgress Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssUploadProgress Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload progress span.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssUploadProgress
Visual Basic
Public Const CssUploadProgress As String
Visual C++
public:
literal String^ CssUploadProgress

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssUploadSuccess Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..CssUploadSuccess Field
AsyncUploadConstants Class See Also Send Feedback
CSS class of the async upload progress span success.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssUploadSuccess
Visual Basic
Public Const CssUploadSuccess As String
Visual C++
public:
literal String^ CssUploadSuccess

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyAsyncUpload Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AsyncUploadConstants..::..KeyAsyncUpload Field
AsyncUploadConstants Class See Also Send Feedback
The key identifying the AsyncUpload control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyAsyncUpload
Visual Basic
Public Const KeyAsyncUpload As String
Visual C++
public:
literal String^ KeyAsyncUpload

See Also

AsyncUploadConstants Class
Telerik.WebAii.Controls.Html Namespace


ButtonConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonConstants Members
ButtonConstants Class Fields See Also Send Feedback

The ButtonConstants type exposes the following members.

Fields

Name | Description
ButtonKey | The 'RadButton' key used across the source classes.
CssPrimaryIcon | The base CSS class of the RadButton primary icon element.
CssRadButton | The base CSS class of the RadButton wrapper element.
CssSecondaryIcon | The base CSS class of the RadButton secondary icon element.
CssText | The base CSS class of the RadButton text element.

See Also

ButtonConstants Class
Telerik.WebAii.Controls.Html Namespace


ButtonConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonConstants Fields
ButtonConstants Class See Also Send Feedback

The ButtonConstants type exposes the following members.

Fields

Name | Description
ButtonKey | The 'RadButton' key used across the source classes.
CssPrimaryIcon | The base CSS class of the RadButton primary icon element.
CssRadButton | The base CSS class of the RadButton wrapper element.
CssSecondaryIcon | The base CSS class of the RadButton secondary icon element.
CssText | The base CSS class of the RadButton text element.

See Also

ButtonConstants Class
Telerik.WebAii.Controls.Html Namespace


ButtonKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonConstants..::..ButtonKey Field
ButtonConstants Class See Also Send Feedback
The 'RadButton' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ButtonKey
Visual Basic
Public Const ButtonKey As String
Visual C++
public:
literal String^ ButtonKey

See Also

ButtonConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPrimaryIcon Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonConstants..::..CssPrimaryIcon Field
ButtonConstants Class See Also Send Feedback
The base CSS class of the RadButton primary icon element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPrimaryIcon
Visual Basic
Public Const CssPrimaryIcon As String
Visual C++
public:
literal String^ CssPrimaryIcon

See Also

ButtonConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonConstants..::..CssRadButton Field
ButtonConstants Class See Also Send Feedback
The base CSS class of the RadButton wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadButton
Visual Basic
Public Const CssRadButton As String
Visual C++
public:
literal String^ CssRadButton

See Also

ButtonConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSecondaryIcon Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonConstants..::..CssSecondaryIcon Field
ButtonConstants Class See Also Send Feedback
The base CSS class of the RadButton secondary icon element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSecondaryIcon
Visual Basic
Public Const CssSecondaryIcon As String
Visual C++
public:
literal String^ CssSecondaryIcon

See Also

ButtonConstants Class
Telerik.WebAii.Controls.Html Namespace


CssText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ButtonConstants..::..CssText Field
ButtonConstants Class See Also Send Feedback
The base CSS class of the RadButton text element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssText
Visual Basic
Public Const CssText As String
Visual C++
public:
literal String^ CssText

See Also

ButtonConstants Class
Telerik.WebAii.Controls.Html Namespace


CalendarConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants Members
CalendarConstants Class Fields See Also Send Feedback

The CalendarConstants type exposes the following members.

Fields

Name | Description
CalendarKey | The Calendar key.
ColumnHeaderCellId | The ID of the ColumnHeader cell.
CssDatePopupButton | The CSS class of the calendar popup button.
CssDisabled | The disabled CSS class.
CssFastNavigationPopup | The CSS class of the fast navigation popup div element.
CssFastNextButton | The CSS class of the fast next button.
CssFastPreviousButton | The CSS class of the fast previous button.
CssNavigationTable | The CSS class of the navigation table;
CssNextButton | The CSS class of the next button.
CssOutOfRange | The out of range CSS class.
CssPreviousButton | The CSS class of the previous button.
CssRadCalendar | The CSS class of the RadCalendar table.
CssTimePopupButton | The CSS class of the TimeView popup button.
CssTitleBar | The CSS class of the title bar.
CssTitleCell | The CSS class of the title cell.
CssViewSelector | The CSS class of the calendar's ViewSelector.
DatePickerKey | The RadDatePicker key.
DateTimePickerKey | The RadDateTimePicker key.
FastNavigationCancelButtonId | The Id of the fast navigation 'Cancel' button.
FastNavigationKey | The Fast Navigation key.
FastNavigationNextButtonId | The Id of the fast navigation 'Next' button.
FastNavigationOkButtonId | The Id of the fast navigation 'Ok' button.
FastNavigationPreviousButtonId | The Id of the fast navigation 'Previous' button.
FastNavigationTodayButtonId | The Id of the fast navigation 'Today' button.
FastNextButtonId | The ID of the fast next button.
FastPreviousButtonId | The ID of the fast previous button.
MonthYearPickerKey | The RadMonthYearPicker key.
NextButtonId | The ID of the next button.
PickerKey | The Picker key.
PreviousButtonId | The ID of the previous button.
RowHeaderCellId | The ID of the RowHeader cell.
TimePickerKey | The RadTimePicker key.
TimeViewKey | The TimeView key.

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CalendarConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants Fields
CalendarConstants Class See Also Send Feedback

The CalendarConstants type exposes the following members.

Fields

Name | Description
CalendarKey | The Calendar key.
ColumnHeaderCellId | The ID of the ColumnHeader cell.
CssDatePopupButton | The CSS class of the calendar popup button.
CssDisabled | The disabled CSS class.
CssFastNavigationPopup | The CSS class of the fast navigation popup div element.
CssFastNextButton | The CSS class of the fast next button.
CssFastPreviousButton | The CSS class of the fast previous button.
CssNavigationTable | The CSS class of the navigation table;
CssNextButton | The CSS class of the next button.
CssOutOfRange | The out of range CSS class.
CssPreviousButton | The CSS class of the previous button.
CssRadCalendar | The CSS class of the RadCalendar table.
CssTimePopupButton | The CSS class of the TimeView popup button.
CssTitleBar | The CSS class of the title bar.
CssTitleCell | The CSS class of the title cell.
CssViewSelector | The CSS class of the calendar's ViewSelector.
DatePickerKey | The RadDatePicker key.
DateTimePickerKey | The RadDateTimePicker key.
FastNavigationCancelButtonId | The Id of the fast navigation 'Cancel' button.
FastNavigationKey | The Fast Navigation key.
FastNavigationNextButtonId | The Id of the fast navigation 'Next' button.
FastNavigationOkButtonId | The Id of the fast navigation 'Ok' button.
FastNavigationPreviousButtonId | The Id of the fast navigation 'Previous' button.
FastNavigationTodayButtonId | The Id of the fast navigation 'Today' button.
FastNextButtonId | The ID of the fast next button.
FastPreviousButtonId | The ID of the fast previous button.
MonthYearPickerKey | The RadMonthYearPicker key.
NextButtonId | The ID of the next button.
PickerKey | The Picker key.
PreviousButtonId | The ID of the previous button.
RowHeaderCellId | The ID of the RowHeader cell.
TimePickerKey | The RadTimePicker key.
TimeViewKey | The TimeView key.

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CalendarKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CalendarKey Field
CalendarConstants Class See Also Send Feedback
The Calendar key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CalendarKey
Visual Basic
Public Const CalendarKey As String
Visual C++
public:
literal String^ CalendarKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnHeaderCellId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..ColumnHeaderCellId Field
CalendarConstants Class See Also Send Feedback
The ID of the ColumnHeader cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ColumnHeaderCellId
Visual Basic
Public Const ColumnHeaderCellId As String
Visual C++
public:
literal String^ ColumnHeaderCellId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDatePopupButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssDatePopupButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the calendar popup button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDatePopupButton
Visual Basic
Public Const CssDatePopupButton As String
Visual C++
public:
literal String^ CssDatePopupButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDisabled Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssDisabled Field
CalendarConstants Class See Also Send Feedback
The disabled CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDisabled
Visual Basic
Public Const CssDisabled As String
Visual C++
public:
literal String^ CssDisabled

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFastNavigationPopup Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssFastNavigationPopup Field
CalendarConstants Class See Also Send Feedback
The CSS class of the fast navigation popup div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFastNavigationPopup
Visual Basic
Public Const CssFastNavigationPopup As String
Visual C++
public:
literal String^ CssFastNavigationPopup

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFastNextButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssFastNextButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the fast next button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFastNextButton
Visual Basic
Public Const CssFastNextButton As String
Visual C++
public:
literal String^ CssFastNextButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFastPreviousButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssFastPreviousButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the fast previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFastPreviousButton
Visual Basic
Public Const CssFastPreviousButton As String
Visual C++
public:
literal String^ CssFastPreviousButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNavigationTable Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssNavigationTable Field
CalendarConstants Class See Also Send Feedback
The CSS class of the navigation table;

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNavigationTable
Visual Basic
Public Const CssNavigationTable As String
Visual C++
public:
literal String^ CssNavigationTable

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNextButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssNextButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the next button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNextButton
Visual Basic
Public Const CssNextButton As String
Visual C++
public:
literal String^ CssNextButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssOutOfRange Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssOutOfRange Field
CalendarConstants Class See Also Send Feedback
The out of range CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssOutOfRange
Visual Basic
Public Const CssOutOfRange As String
Visual C++
public:
literal String^ CssOutOfRange

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPreviousButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssPreviousButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPreviousButton
Visual Basic
Public Const CssPreviousButton As String
Visual C++
public:
literal String^ CssPreviousButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadCalendar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssRadCalendar Field
CalendarConstants Class See Also Send Feedback
The CSS class of the RadCalendar table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadCalendar
Visual Basic
Public Const CssRadCalendar As String
Visual C++
public:
literal String^ CssRadCalendar

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTimePopupButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssTimePopupButton Field
CalendarConstants Class See Also Send Feedback
The CSS class of the TimeView popup button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTimePopupButton
Visual Basic
Public Const CssTimePopupButton As String
Visual C++
public:
literal String^ CssTimePopupButton

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTitleBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssTitleBar Field
CalendarConstants Class See Also Send Feedback
The CSS class of the title bar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTitleBar
Visual Basic
Public Const CssTitleBar As String
Visual C++
public:
literal String^ CssTitleBar

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTitleCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssTitleCell Field
CalendarConstants Class See Also Send Feedback
The CSS class of the title cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTitleCell
Visual Basic
Public Const CssTitleCell As String
Visual C++
public:
literal String^ CssTitleCell

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssViewSelector Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..CssViewSelector Field
CalendarConstants Class See Also Send Feedback
The CSS class of the calendar's ViewSelector.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssViewSelector
Visual Basic
Public Const CssViewSelector As String
Visual C++
public:
literal String^ CssViewSelector

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


DatePickerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..DatePickerKey Field
CalendarConstants Class See Also Send Feedback
The RadDatePicker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DatePickerKey
Visual Basic
Public Const DatePickerKey As String
Visual C++
public:
literal String^ DatePickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


DateTimePickerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..DateTimePickerKey Field
CalendarConstants Class See Also Send Feedback
The RadDateTimePicker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DateTimePickerKey
Visual Basic
Public Const DateTimePickerKey As String
Visual C++
public:
literal String^ DateTimePickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationCancelButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..FastNavigationCancelButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Cancel' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FastNavigationCancelButtonId
Visual Basic
Public Const FastNavigationCancelButtonId As String
Visual C++
public:
literal String^ FastNavigationCancelButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..FastNavigationKey Field
CalendarConstants Class See Also Send Feedback
The Fast Navigation key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FastNavigationKey
Visual Basic
Public Const FastNavigationKey As String
Visual C++
public:
literal String^ FastNavigationKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationNextButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..FastNavigationNextButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Next' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FastNavigationNextButtonId
Visual Basic
Public Const FastNavigationNextButtonId As String
Visual C++
public:
literal String^ FastNavigationNextButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationOkButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..FastNavigationOkButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Ok' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FastNavigationOkButtonId
Visual Basic
Public Const FastNavigationOkButtonId As String
Visual C++
public:
literal String^ FastNavigationOkButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationPreviousButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..FastNavigationPreviousButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Previous' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FastNavigationPreviousButtonId
Visual Basic
Public Const FastNavigationPreviousButtonId As String
Visual C++
public:
literal String^ FastNavigationPreviousButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNavigationTodayButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..FastNavigationTodayButtonId Field
CalendarConstants Class See Also Send Feedback
The Id of the fast navigation 'Today' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FastNavigationTodayButtonId
Visual Basic
Public Const FastNavigationTodayButtonId As String
Visual C++
public:
literal String^ FastNavigationTodayButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastNextButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..FastNextButtonId Field
CalendarConstants Class See Also Send Feedback
The ID of the fast next button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FastNextButtonId
Visual Basic
Public Const FastNextButtonId As String
Visual C++
public:
literal String^ FastNextButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


FastPreviousButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..FastPreviousButtonId Field
CalendarConstants Class See Also Send Feedback
The ID of the fast previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FastPreviousButtonId
Visual Basic
Public Const FastPreviousButtonId As String
Visual C++
public:
literal String^ FastPreviousButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


MonthYearPickerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..MonthYearPickerKey Field
CalendarConstants Class See Also Send Feedback
The RadMonthYearPicker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string MonthYearPickerKey
Visual Basic
Public Const MonthYearPickerKey As String
Visual C++
public:
literal String^ MonthYearPickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


NextButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..NextButtonId Field
CalendarConstants Class See Also Send Feedback
The ID of the next button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string NextButtonId
Visual Basic
Public Const NextButtonId As String
Visual C++
public:
literal String^ NextButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


PickerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..PickerKey Field
CalendarConstants Class See Also Send Feedback
The Picker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PickerKey
Visual Basic
Public Const PickerKey As String
Visual C++
public:
literal String^ PickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


PreviousButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..PreviousButtonId Field
CalendarConstants Class See Also Send Feedback
The ID of the previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PreviousButtonId
Visual Basic
Public Const PreviousButtonId As String
Visual C++
public:
literal String^ PreviousButtonId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


RowHeaderCellId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..RowHeaderCellId Field
CalendarConstants Class See Also Send Feedback
The ID of the RowHeader cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RowHeaderCellId
Visual Basic
Public Const RowHeaderCellId As String
Visual C++
public:
literal String^ RowHeaderCellId

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


TimePickerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..TimePickerKey Field
CalendarConstants Class See Also Send Feedback
The RadTimePicker key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TimePickerKey
Visual Basic
Public Const TimePickerKey As String
Visual C++
public:
literal String^ TimePickerKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


TimeViewKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarConstants..::..TimeViewKey Field
CalendarConstants Class See Also Send Feedback
The TimeView key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TimeViewKey
Visual Basic
Public Const TimeViewKey As String
Visual C++
public:
literal String^ TimeViewKey

See Also

CalendarConstants Class
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup Members
CalendarFastNavigationPopup Class Constructors Methods Properties See Also Send Feedback

The CalendarFastNavigationPopup type exposes the following members.

Constructors

 | Name | Description
Public method | CalendarFastNavigationPopup()()()() | Initializes a new instance of the CalendarFastNavigationPopup class.
Public method | CalendarFastNavigationPopup(Element) | Initializes a new instance of the CalendarFastNavigationPopup class. Create the control.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickCancel | Clicks on the Cancel button.
Public method | ClickOk | Clicks on the Ok button.
Public method | ClickToday | Clicks on the Today button.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NextYears | Navigates to next years.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | PreviousYears | Navigates to previous years.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectMonth | Selects a month.
Public method | SelectYear | Selects an year.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the navigation popup. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FirstYear | Gets the firt year which the popup is displaying.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFastNavigationOpen | Gets the visibility of the popup.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | LastYear | Gets the last year which the popup is displaying.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedMonth | Gets the selected month string of the popup.
Public property | SelectedYear | Gets the selected year of the popup.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup Constructor
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CalendarFastNavigationPopup()()()() | Initializes a new instance of the CalendarFastNavigationPopup class.
Public method | CalendarFastNavigationPopup(Element) | Initializes a new instance of the CalendarFastNavigationPopup class. Create the control.

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup Constructor
CalendarFastNavigationPopup Class See Also Send Feedback
Initializes a new instance of the CalendarFastNavigationPopup class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public CalendarFastNavigationPopup()
Visual Basic
Public Sub New
Visual C++
public:
CalendarFastNavigationPopup()

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Overload
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup Constructor (Element)
CalendarFastNavigationPopup Class See Also Send Feedback
Initializes a new instance of the CalendarFastNavigationPopup class. Create the control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public CalendarFastNavigationPopup(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
CalendarFastNavigationPopup(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.CalendarFastNavigationPopup.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Overload
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup Methods
CalendarFastNavigationPopup Class See Also Send Feedback

The CalendarFastNavigationPopup type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickCancel | Clicks on the Cancel button.
Public method | ClickOk | Clicks on the Ok button.
Public method | ClickToday | Clicks on the Today button.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NextYears | Navigates to next years.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | PreviousYears | Navigates to previous years.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectMonth | Selects a month.
Public method | SelectYear | Selects an year.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..AssignElement Method
CalendarFastNavigationPopup Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..CallMethod Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..Capture Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..Click Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


ClickCancel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..ClickCancel Method
CalendarFastNavigationPopup Class See Also Send Feedback
Clicks on the Cancel button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClickCancel()
Visual Basic
Public Sub ClickCancel
Visual C++
public:
void ClickCancel()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


ClickOk Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..ClickOk Method
CalendarFastNavigationPopup Class See Also Send Feedback
Clicks on the Ok button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClickOk()
Visual Basic
Public Sub ClickOk
Visual C++
public:
void ClickOk()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


ClickToday Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..ClickToday Method
CalendarFastNavigationPopup Class See Also Send Feedback
Clicks on the Today button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClickToday()
Visual Basic
Public Sub ClickToday
Visual C++
public:
void ClickToday()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..DragTo Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..GetValue Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..InvokeEvent Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..MouseClick Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..MouseHover Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


NextYears Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..NextYears Method
CalendarFastNavigationPopup Class See Also Send Feedback
Navigates to next years.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NextYears()
Visual Basic
Public Sub NextYears
Visual C++
public:
void NextYears()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


PreviousYears Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..PreviousYears Method
CalendarFastNavigationPopup Class See Also Send Feedback
Navigates to previous years.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void PreviousYears()
Visual Basic
Public Sub PreviousYears
Visual C++
public:
void PreviousYears()

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..ScrollToVisible Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


SelectMonth Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..SelectMonth Method
CalendarFastNavigationPopup Class See Also Send Feedback
Selects a month.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectMonth(
    string month
)
Visual Basic
Public Sub SelectMonth ( _
    month As String _
)
Visual C++
public:
void SelectMonth(
    String^ month
)

Parameters

month
Type: System..::..String
The month string.

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


SelectYear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..SelectYear Method
CalendarFastNavigationPopup Class See Also Send Feedback
Selects an year.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectYear(
    string year
)
Visual Basic
Public Sub SelectYear ( _
    year As String _
)
Visual C++
public:
void SelectYear(
    String^ year
)

Parameters

year
Type: System..::..String
The year string.

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup..::..SetValue Method
CalendarFastNavigationPopup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
CalendarFastNavigationPopup Members
Telerik.WebAii.Controls.Html Namespace


CalendarFastNavigationPopup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CalendarFastNavigationPopup Properties
CalendarFastNavigationPopup Class See Also Send Feedback

The CalendarFastNavigationPopup type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the navigation popup. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FirstYear | Gets the firt year which the popup is displaying.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFastNavigationOpen | Gets the visibility of the popup.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | LastYear | Gets the last year which the popup is displaying.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedMonth | Gets the selected month string of the popup.
Public property | SelectedYear | Gets the selected year of the popup.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

CalendarFastNavigationPopup Class
Telerik.WebAii.Controls.Html Namespace


CaptchaConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CaptchaConstants Members
CaptchaConstants Class Fields See Also Send Feedback

The CaptchaConstants type exposes the following members.

Fields

Name | Description
CaptchaKey | The 'Captcha' key used across the source classes.
CssRadCaptcha | The base CSS class of the RadCaptcha wrapper element.

See Also

CaptchaConstants Class
Telerik.WebAii.Controls.Html Namespace


CaptchaConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CaptchaConstants Fields
CaptchaConstants Class See Also Send Feedback

The CaptchaConstants type exposes the following members.

Fields

Name | Description
CaptchaKey | The 'Captcha' key used across the source classes.
CssRadCaptcha | The base CSS class of the RadCaptcha wrapper element.

See Also

CaptchaConstants Class
Telerik.WebAii.Controls.Html Namespace


CaptchaKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CaptchaConstants..::..CaptchaKey Field
CaptchaConstants Class See Also Send Feedback
The 'Captcha' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CaptchaKey
Visual Basic
Public Const CaptchaKey As String
Visual C++
public:
literal String^ CaptchaKey

See Also

CaptchaConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadCaptcha Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CaptchaConstants..::..CssRadCaptcha Field
CaptchaConstants Class See Also Send Feedback
The base CSS class of the RadCaptcha wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadCaptcha
Visual Basic
Public Const CssRadCaptcha As String
Visual C++
public:
literal String^ CssRadCaptcha

See Also

CaptchaConstants Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants Members
ColorPickerConstants Class Fields See Also Send Feedback

The ColorPickerConstants type exposes the following members.

Fields

Name | Description
CssColorBox | The CSS class identifying the ColorPicker's colorbox element.
CssColorPicker | The CSS class identifying the ColorPicker control.
CssColorPickerIcon | The CSS class identifying the ColorPickerIcon control.
CssColorPickerPalette | The CSS class identifying the ColorPickerPalette control.
CssEmptyColor | The CSS class identifying the ColorPicker's "No color" element.
CssSelectedColor | The CSS class identifying the ColorPicker's selected color element.
IconKey | The key identifying the ColorPicker Icon.
PaletteKey | The key identifying the ColorPicker Palette.

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants Fields
ColorPickerConstants Class See Also Send Feedback

The ColorPickerConstants type exposes the following members.

Fields

Name | Description
CssColorBox | The CSS class identifying the ColorPicker's colorbox element.
CssColorPicker | The CSS class identifying the ColorPicker control.
CssColorPickerIcon | The CSS class identifying the ColorPickerIcon control.
CssColorPickerPalette | The CSS class identifying the ColorPickerPalette control.
CssEmptyColor | The CSS class identifying the ColorPicker's "No color" element.
CssSelectedColor | The CSS class identifying the ColorPicker's selected color element.
IconKey | The key identifying the ColorPicker Icon.
PaletteKey | The key identifying the ColorPicker Palette.

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColorBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants..::..CssColorBox Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPicker's colorbox element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColorBox
Visual Basic
Public Const CssColorBox As String
Visual C++
public:
literal String^ CssColorBox

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColorPicker Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants..::..CssColorPicker Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPicker control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColorPicker
Visual Basic
Public Const CssColorPicker As String
Visual C++
public:
literal String^ CssColorPicker

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColorPickerIcon Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants..::..CssColorPickerIcon Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPickerIcon control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColorPickerIcon
Visual Basic
Public Const CssColorPickerIcon As String
Visual C++
public:
literal String^ CssColorPickerIcon

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColorPickerPalette Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants..::..CssColorPickerPalette Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPickerPalette control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColorPickerPalette
Visual Basic
Public Const CssColorPickerPalette As String
Visual C++
public:
literal String^ CssColorPickerPalette

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEmptyColor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants..::..CssEmptyColor Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPicker's "No color" element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEmptyColor
Visual Basic
Public Const CssEmptyColor As String
Visual C++
public:
literal String^ CssEmptyColor

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSelectedColor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants..::..CssSelectedColor Field
ColorPickerConstants Class See Also Send Feedback
The CSS class identifying the ColorPicker's selected color element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSelectedColor
Visual Basic
Public Const CssSelectedColor As String
Visual C++
public:
literal String^ CssSelectedColor

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


IconKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants..::..IconKey Field
ColorPickerConstants Class See Also Send Feedback
The key identifying the ColorPicker Icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IconKey
Visual Basic
Public Const IconKey As String
Visual C++
public:
literal String^ IconKey

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


PaletteKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerConstants..::..PaletteKey Field
ColorPickerConstants Class See Also Send Feedback
The key identifying the ColorPicker Palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PaletteKey
Visual Basic
Public Const PaletteKey As String
Visual C++
public:
literal String^ PaletteKey

See Also

ColorPickerConstants Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon Members
ColorPickerIcon Class Constructors Methods Properties See Also Send Feedback

The ColorPickerIcon type exposes the following members.

Constructors

 | Name | Description
Public method | ColorPickerIcon()()()() | Initializes a new instance of the ColorPickerIcon class.
Public method | ColorPickerIcon(Element) | Initializes a new instance of the ColorPickerIcon class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HidePalette | Hides the ColorPicker palette.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowPalette | Shows the ColorPicker palette.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PaletteDisplayed | Determines whether the palette is displayed.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon Constructor
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorPickerIcon()()()() | Initializes a new instance of the ColorPickerIcon class.
Public method | ColorPickerIcon(Element) | Initializes a new instance of the ColorPickerIcon class.

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon Constructor
ColorPickerIcon Class See Also Send Feedback
Initializes a new instance of the ColorPickerIcon class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public ColorPickerIcon()
Visual Basic
Public Sub New
Visual C++
public:
ColorPickerIcon()

See Also

ColorPickerIcon Class
ColorPickerIcon Overload
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon Constructor (Element)
ColorPickerIcon Class See Also Send Feedback
Initializes a new instance of the ColorPickerIcon class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public ColorPickerIcon(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
ColorPickerIcon(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
RadColorPicker icon element.

See Also

ColorPickerIcon Class
ColorPickerIcon Overload
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon Methods
ColorPickerIcon Class See Also Send Feedback

The ColorPickerIcon type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HidePalette | Hides the ColorPicker palette.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowPalette | Shows the ColorPicker palette.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..AssignElement Method
ColorPickerIcon Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..CallMethod Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..Capture Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..Click Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..DragTo Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..GetValue Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


HidePalette Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..HidePalette Method
ColorPickerIcon Class See Also Send Feedback
Hides the ColorPicker palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void HidePalette()
Visual Basic
Public Sub HidePalette
Visual C++
public:
void HidePalette()

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..InvokeEvent Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..MouseClick Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..MouseHover Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..ScrollToVisible Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..SetValue Method
ColorPickerIcon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
ColorPickerIcon Members
Telerik.WebAii.Controls.Html Namespace


ShowPalette Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon..::..ShowPalette Method
ColorPickerIcon Class See Also Send Feedback
Shows the ColorPicker palette.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowPalette()
Visual Basic
Public Sub ShowPalette
Visual C++
public:
void ShowPalette()

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerIcon Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerIcon Properties
ColorPickerIcon Class See Also Send Feedback

The ColorPickerIcon type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PaletteDisplayed | Determines whether the palette is displayed.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerIcon Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette Members
ColorPickerPalette Class Constructors Methods Properties See Also Send Feedback

The ColorPickerPalette type exposes the following members.

Constructors

 | Name | Description
Public method | ColorPickerPalette()()()() | Initializes a new instance of the ColorPickerPalette class.
Public method | ColorPickerPalette(Element) | Initializes a new instance of the ColorPickerPalette class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPicker palette. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedColor | Gets/Sets the selected color of the RadColorPicker palette.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette Constructor
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ColorPickerPalette()()()() | Initializes a new instance of the ColorPickerPalette class.
Public method | ColorPickerPalette(Element) | Initializes a new instance of the ColorPickerPalette class.

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette Constructor
ColorPickerPalette Class See Also Send Feedback
Initializes a new instance of the ColorPickerPalette class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public ColorPickerPalette()
Visual Basic
Public Sub New
Visual C++
public:
ColorPickerPalette()

See Also

ColorPickerPalette Class
ColorPickerPalette Overload
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette Constructor (Element)
ColorPickerPalette Class See Also Send Feedback
Initializes a new instance of the ColorPickerPalette class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public ColorPickerPalette(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
ColorPickerPalette(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.ColorPickerPalette.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

ColorPickerPalette Class
ColorPickerPalette Overload
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette Methods
ColorPickerPalette Class See Also Send Feedback

The ColorPickerPalette type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..AssignElement Method
ColorPickerPalette Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..CallMethod Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..Capture Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..Click Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..DragTo Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..GetValue Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..InvokeEvent Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..MouseClick Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..MouseHover Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..ScrollToVisible Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette..::..SetValue Method
ColorPickerPalette Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
ColorPickerPalette Members
Telerik.WebAii.Controls.Html Namespace


ColorPickerPalette Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ColorPickerPalette Properties
ColorPickerPalette Class See Also Send Feedback

The ColorPickerPalette type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPicker palette. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedColor | Gets/Sets the selected color of the RadColorPicker palette.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

ColorPickerPalette Class
Telerik.WebAii.Controls.Html Namespace


ComboBoxConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants Members
ComboBoxConstants Class Fields See Also Send Feedback

The ComboBoxConstants type exposes the following members.

Fields

Name | Description
ComboBox | The ComboBox key used across the source classes.
ComboBoxItemKey | The ComboBoxItem key used across the source classes.
CssComboBox | The CSS class identifying the ComboBox control.
CssComboBoxItem | The CSS class identifying the ComboBox item.
CssComboBoxItemCheckBox | The CSS class identifying the ComboBox item checkbox.
IdComboArrow | The ID part identifying the drop down arrow of the ComboBox control.
IdComboDropDown | The ID part identifying the drop down element of the ComboBox control.
IdComboInput | The ID part identifying the input element of the ComboBox control.

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ComboBoxConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants Fields
ComboBoxConstants Class See Also Send Feedback

The ComboBoxConstants type exposes the following members.

Fields

Name | Description
ComboBox | The ComboBox key used across the source classes.
ComboBoxItemKey | The ComboBoxItem key used across the source classes.
CssComboBox | The CSS class identifying the ComboBox control.
CssComboBoxItem | The CSS class identifying the ComboBox item.
CssComboBoxItemCheckBox | The CSS class identifying the ComboBox item checkbox.
IdComboArrow | The ID part identifying the drop down arrow of the ComboBox control.
IdComboDropDown | The ID part identifying the drop down element of the ComboBox control.
IdComboInput | The ID part identifying the input element of the ComboBox control.

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ComboBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants..::..ComboBox Field
ComboBoxConstants Class See Also Send Feedback
The ComboBox key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ComboBox
Visual Basic
Public Const ComboBox As String
Visual C++
public:
literal String^ ComboBox

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ComboBoxItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants..::..ComboBoxItemKey Field
ComboBoxConstants Class See Also Send Feedback
The ComboBoxItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ComboBoxItemKey
Visual Basic
Public Const ComboBoxItemKey As String
Visual C++
public:
literal String^ ComboBoxItemKey

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssComboBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants..::..CssComboBox Field
ComboBoxConstants Class See Also Send Feedback
The CSS class identifying the ComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssComboBox
Visual Basic
Public Const CssComboBox As String
Visual C++
public:
literal String^ CssComboBox

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssComboBoxItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants..::..CssComboBoxItem Field
ComboBoxConstants Class See Also Send Feedback
The CSS class identifying the ComboBox item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssComboBoxItem
Visual Basic
Public Const CssComboBoxItem As String
Visual C++
public:
literal String^ CssComboBoxItem

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssComboBoxItemCheckBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants..::..CssComboBoxItemCheckBox Field
ComboBoxConstants Class See Also Send Feedback
The CSS class identifying the ComboBox item checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssComboBoxItemCheckBox
Visual Basic
Public Const CssComboBoxItemCheckBox As String
Visual C++
public:
literal String^ CssComboBoxItemCheckBox

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


IdComboArrow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants..::..IdComboArrow Field
ComboBoxConstants Class See Also Send Feedback
The ID part identifying the drop down arrow of the ComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdComboArrow
Visual Basic
Public Const IdComboArrow As String
Visual C++
public:
literal String^ IdComboArrow

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


IdComboDropDown Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants..::..IdComboDropDown Field
ComboBoxConstants Class See Also Send Feedback
The ID part identifying the drop down element of the ComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdComboDropDown
Visual Basic
Public Const IdComboDropDown As String
Visual C++
public:
literal String^ IdComboDropDown

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


IdComboInput Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ComboBoxConstants..::..IdComboInput Field
ComboBoxConstants Class See Also Send Feedback
The ID part identifying the input element of the ComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdComboInput
Visual Basic
Public Const IdComboInput As String
Visual C++
public:
literal String^ IdComboInput

See Also

ComboBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CommonHelper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper Members
CommonHelper Class Methods See Also Send Feedback

The CommonHelper type exposes the following members.

Methods

Name | Description
GenArray | A helper method to generate an array of integers with given count.
GetControl | Get the HtmlControl type of the given element.
GetControlType | Get the control type of the given element.
GetInputControl | Get the HtmlInputControl type of the given element.
GetInputControlType | Get the input control type of the given element.
RemoveWhiteSpaces | A helper method for removing whitespaces from strings.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


CommonHelper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper Methods
CommonHelper Class See Also Send Feedback

The CommonHelper type exposes the following members.

Methods

Name | Description
GenArray | A helper method to generate an array of integers with given count.
GetControl | Get the HtmlControl type of the given element.
GetControlType | Get the control type of the given element.
GetInputControl | Get the HtmlInputControl type of the given element.
GetInputControlType | Get the input control type of the given element.
RemoveWhiteSpaces | A helper method for removing whitespaces from strings.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GenArray Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GenArray Method
CommonHelper Class See Also Send Feedback
A helper method to generate an array of integers with given count.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static int[] GenArray(
    int count
)
Visual Basic
Public Shared Function GenArray ( _
    count As Integer _
) As Integer()
Visual C++
public:
static array<int>^ GenArray(
    int count
)

Parameters

count
Type: System..::..Int32
The count of the array elements.

Return Value

An array of integers with given count.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GetControl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GetControl Method
CommonHelper Class See Also Send Feedback
Get the HtmlControl type of the given element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static HtmlControl GetControl(
    Element element
)
Visual Basic
Public Shared Function GetControl ( _
    element As Element _
) As HtmlControl
Visual C++
public:
static HtmlControl^ GetControl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to get the control type of.

Return Value

The HtmlControl type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GetControlType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GetControlType Method
CommonHelper Class See Also Send Feedback
Get the control type of the given element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static Type GetControlType(
    Element element
)
Visual Basic
Public Shared Function GetControlType ( _
    element As Element _
) As Type
Visual C++
public:
static Type^ GetControlType(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to get the control type of.

Return Value

The control type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GetInputControl Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GetInputControl Method
CommonHelper Class See Also Send Feedback
Get the HtmlInputControl type of the given element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static HtmlInputControl GetInputControl(
    Element element
)
Visual Basic
Public Shared Function GetInputControl ( _
    element As Element _
) As HtmlInputControl
Visual C++
public:
static HtmlInputControl^ GetInputControl(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to get the control type of.

Return Value

The HtmlInputControl type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


GetInputControlType Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..GetInputControlType Method
CommonHelper Class See Also Send Feedback
Get the input control type of the given element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static Type GetInputControlType(
    Element element
)
Visual Basic
Public Shared Function GetInputControlType ( _
    element As Element _
) As Type
Visual C++
public:
static Type^ GetInputControlType(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element to get the input control type of.

Return Value

The input control type of the given element.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


RemoveWhiteSpaces Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
CommonHelper..::..RemoveWhiteSpaces Method
CommonHelper Class See Also Send Feedback
A helper method for removing whitespaces from strings.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static string RemoveWhiteSpaces(
    string stringToModify
)
Visual Basic
Public Shared Function RemoveWhiteSpaces ( _
    stringToModify As String _
) As String
Visual C++
public:
static String^ RemoveWhiteSpaces(
    String^ stringToModify
)

Parameters

stringToModify
Type: System..::..String
The string to modify.

Return Value

The string without whitespaces.

See Also

CommonHelper Class
Telerik.WebAii.Controls.Html Namespace


DataPagerConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants Members
DataPagerConstants Class Fields See Also Send Feedback

The DataPagerConstants type exposes the following members.

Fields

Name | Description
CssCurrentPage | The CSS class of the DataPager's currently selected page.
CssFirstButton | The CSS class of the DataPager's 'first page' button.
CssLastButton | The CSS class of the DataPager's 'last page' button.
CssNextButton | The CSS class of the DataPager's next page button.
CssNumberPartDiv | The CSS class of the div wrapping the numbers in the pager.
CssPageButton | The CSS class of the DataPager's 'Go' button.
CssPreviousButton | The CSS class of the DataPager's previous button.
CssRadDataPager | The CSS class of the DataPager div wrapper.
DataPagerKey | The DataPager key.
PagerTextBoxId | The ID of the numeric textbox in the pager.
PageSizeComboBoxId | The ID of the page size combo box.

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


DataPagerConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants Fields
DataPagerConstants Class See Also Send Feedback

The DataPagerConstants type exposes the following members.

Fields

Name | Description
CssCurrentPage | The CSS class of the DataPager's currently selected page.
CssFirstButton | The CSS class of the DataPager's 'first page' button.
CssLastButton | The CSS class of the DataPager's 'last page' button.
CssNextButton | The CSS class of the DataPager's next page button.
CssNumberPartDiv | The CSS class of the div wrapping the numbers in the pager.
CssPageButton | The CSS class of the DataPager's 'Go' button.
CssPreviousButton | The CSS class of the DataPager's previous button.
CssRadDataPager | The CSS class of the DataPager div wrapper.
DataPagerKey | The DataPager key.
PagerTextBoxId | The ID of the numeric textbox in the pager.
PageSizeComboBoxId | The ID of the page size combo box.

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCurrentPage Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..CssCurrentPage Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's currently selected page.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCurrentPage
Visual Basic
Public Const CssCurrentPage As String
Visual C++
public:
literal String^ CssCurrentPage

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFirstButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..CssFirstButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's 'first page' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFirstButton
Visual Basic
Public Const CssFirstButton As String
Visual C++
public:
literal String^ CssFirstButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssLastButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..CssLastButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's 'last page' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssLastButton
Visual Basic
Public Const CssLastButton As String
Visual C++
public:
literal String^ CssLastButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNextButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..CssNextButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's next page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNextButton
Visual Basic
Public Const CssNextButton As String
Visual C++
public:
literal String^ CssNextButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNumberPartDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..CssNumberPartDiv Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the div wrapping the numbers in the pager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNumberPartDiv
Visual Basic
Public Const CssNumberPartDiv As String
Visual C++
public:
literal String^ CssNumberPartDiv

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..CssPageButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's 'Go' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageButton
Visual Basic
Public Const CssPageButton As String
Visual C++
public:
literal String^ CssPageButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPreviousButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..CssPreviousButton Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager's previous button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPreviousButton
Visual Basic
Public Const CssPreviousButton As String
Visual C++
public:
literal String^ CssPreviousButton

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadDataPager Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..CssRadDataPager Field
DataPagerConstants Class See Also Send Feedback
The CSS class of the DataPager div wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadDataPager
Visual Basic
Public Const CssRadDataPager As String
Visual C++
public:
literal String^ CssRadDataPager

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


DataPagerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..DataPagerKey Field
DataPagerConstants Class See Also Send Feedback
The DataPager key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DataPagerKey
Visual Basic
Public Const DataPagerKey As String
Visual C++
public:
literal String^ DataPagerKey

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


PagerTextBoxId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..PagerTextBoxId Field
DataPagerConstants Class See Also Send Feedback
The ID of the numeric textbox in the pager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PagerTextBoxId
Visual Basic
Public Const PagerTextBoxId As String
Visual C++
public:
literal String^ PagerTextBoxId

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


PageSizeComboBoxId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DataPagerConstants..::..PageSizeComboBoxId Field
DataPagerConstants Class See Also Send Feedback
The ID of the page size combo box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PageSizeComboBoxId
Visual Basic
Public Const PageSizeComboBoxId As String
Visual C++
public:
literal String^ PageSizeComboBoxId

See Also

DataPagerConstants Class
Telerik.WebAii.Controls.Html Namespace


DockConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants Members
DockConstants Class Fields See Also Send Feedback

The DockConstants type exposes the following members.

Fields

Name | Description
CssDock | The CSS class identifying the RadDock control.
CssDockCommandsContainer | The CSS class identifying the RadDockCommnads container.
CssDockPlaceHolder | The CSS class identifying the RadDock's placeholder..
CssDockZone | The CSS class identifying the RadDockZone control.
KeyDock | The Dock key used accross the verifications and action messages.
KeyDockCommand | The DockCommand key used accross the verifications and action messages.
KeyDockZone | The DockZone key used accross the verifications and action messages.

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


DockConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants Fields
DockConstants Class See Also Send Feedback

The DockConstants type exposes the following members.

Fields

Name | Description
CssDock | The CSS class identifying the RadDock control.
CssDockCommandsContainer | The CSS class identifying the RadDockCommnads container.
CssDockPlaceHolder | The CSS class identifying the RadDock's placeholder..
CssDockZone | The CSS class identifying the RadDockZone control.
KeyDock | The Dock key used accross the verifications and action messages.
KeyDockCommand | The DockCommand key used accross the verifications and action messages.
KeyDockZone | The DockZone key used accross the verifications and action messages.

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDock Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants..::..CssDock Field
DockConstants Class See Also Send Feedback
The CSS class identifying the RadDock control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDock
Visual Basic
Public Const CssDock As String
Visual C++
public:
literal String^ CssDock

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDockCommandsContainer Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants..::..CssDockCommandsContainer Field
DockConstants Class See Also Send Feedback
The CSS class identifying the RadDockCommnads container.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDockCommandsContainer
Visual Basic
Public Const CssDockCommandsContainer As String
Visual C++
public:
literal String^ CssDockCommandsContainer

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDockPlaceHolder Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants..::..CssDockPlaceHolder Field
DockConstants Class See Also Send Feedback
The CSS class identifying the RadDock's placeholder..

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDockPlaceHolder
Visual Basic
Public Const CssDockPlaceHolder As String
Visual C++
public:
literal String^ CssDockPlaceHolder

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDockZone Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants..::..CssDockZone Field
DockConstants Class See Also Send Feedback
The CSS class identifying the RadDockZone control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDockZone
Visual Basic
Public Const CssDockZone As String
Visual C++
public:
literal String^ CssDockZone

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyDock Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants..::..KeyDock Field
DockConstants Class See Also Send Feedback
The Dock key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyDock
Visual Basic
Public Const KeyDock As String
Visual C++
public:
literal String^ KeyDock

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyDockCommand Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants..::..KeyDockCommand Field
DockConstants Class See Also Send Feedback
The DockCommand key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyDockCommand
Visual Basic
Public Const KeyDockCommand As String
Visual C++
public:
literal String^ KeyDockCommand

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyDockZone Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
DockConstants..::..KeyDockZone Field
DockConstants Class See Also Send Feedback
The DockZone key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyDockZone
Visual Basic
Public Const KeyDockZone As String
Visual C++
public:
literal String^ KeyDockZone

See Also

DockConstants Class
Telerik.WebAii.Controls.Html Namespace


EditorCommand Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand Members
EditorCommand Class Constructors Methods Properties See Also Send Feedback

The EditorCommand type exposes the following members.

Constructors

 | Name | Description
Public method | EditorCommand()()()() | Initializes a new instance of the EditorCommand class.
Public method | EditorCommand(Element) | Initializes a new instance of the EditorCommand class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlAnchor..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadEditor command. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CommandName | The Command name.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EditorId | Gets ID of the parent editor.
Public property | Enabled | Determines whether RadEditorCommand is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsNonDefaultToolBarMode | Determines whether the editor is in default toolbar mode or not.
Public property | IsOn | Determines whether RadEditorCommand is on.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorCommand. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link. (Inherited from HtmlAnchor.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Public property | Text | Gets RadEditorCommand text(tooltip).
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorCommand Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand Constructor
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditorCommand()()()() | Initializes a new instance of the EditorCommand class.
Public method | EditorCommand(Element) | Initializes a new instance of the EditorCommand class.

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorCommand Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand Constructor
EditorCommand Class See Also Send Feedback
Initializes a new instance of the EditorCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorCommand()
Visual Basic
Public Sub New
Visual C++
public:
EditorCommand()

See Also

EditorCommand Class
EditorCommand Overload
Telerik.WebAii.Controls.Html Namespace


EditorCommand Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand Constructor (Element)
EditorCommand Class See Also Send Feedback
Initializes a new instance of the EditorCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorCommand(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorCommand(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorCommand.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorCommand Class
EditorCommand Overload
Telerik.WebAii.Controls.Html Namespace


EditorCommand Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand Methods
EditorCommand Class See Also Send Feedback

The EditorCommand type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlAnchor..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..AssignElement Method
EditorCommand Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..CallMethod Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..Capture Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..Click Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..DragTo Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..GetValue Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..InvokeEvent Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..MouseClick Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..MouseHover Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..ScrollToVisible Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand..::..SetValue Method
EditorCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorCommand Class
EditorCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorCommand Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorCommand Properties
EditorCommand Class See Also Send Feedback

The EditorCommand type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadEditor command. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CommandName | The Command name.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EditorId | Gets ID of the parent editor.
Public property | Enabled | Determines whether RadEditorCommand is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsNonDefaultToolBarMode | Determines whether the editor is in default toolbar mode or not.
Public property | IsOn | Determines whether RadEditorCommand is on.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorCommand. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link. (Inherited from HtmlAnchor.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Public property | Text | Gets RadEditorCommand text(tooltip).
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants Members
EditorConstants Class Fields See Also Send Feedback

The EditorConstants type exposes the following members.

Fields

Name | Description
CssEditor | The CSS class identifying the RadEditor control.
CssEditorCommandExclude | The CSS class, excluding splitbuttons, identifying the RadEditorCommand control.
CssEditorCommandInclude | The CSS class identifying the RadEditorCommand control.
CssEditorComment | The CSS class identifying the RadEditor comment.
CssEditorCommentsBox | The CSS class identifying the RadEditor Comments box.
CssEditorCommentTextBox | The CSS class identifying the RadEditor comment textbox.
CssEditorDropDown | The CSS class identifying the RadEditorDropDown control.
CssEditorDropDownBody | The CSS class identifying the DropDownBody control.
CssEditorModeCommand | The CSS class identifying the RadEditorModeCommand control.
CssEditorSpinBox | The CSS class identifying the RadEditorSpinBox control.
CssEditorSpinBoxDecrease | The CSS class identifying decreasing handler of the RadEditorSpinBox.
CssEditorSpinBoxIncrease | The CSS class identifying increasing handler of the RadEditorSpinBox.
CssEditorSpinBoxTextBox | The CSS class identifying the textbox of the RadEditorSpinBox.
CssModeCommandSelected | The CSS class, that will be added, when the RadEditorModeCommand is selected.
CssSplitButton | The CSS class identifying the RadEditorSplitButton control.
CssSplitButtonHandler | The CSS class identifying showing handler of RadEditorCommand control.
CssTableHelperCell | The CSS class identifying the table cell of the Table helper.
CssToolDisabled | The CSS class, that will be added, when the tool is disabled.
CssToolSelected | The CSS class, that will be added, when the tool is selected.
EditorCommandsUsingSelectedText | The string, identify a group of editor commands, that uses selected text.
KeyEditor | The Editor key used accross the verifications and action messages.
KeyEditorCommand | The Editor Command key used accross the verifications and action messages.
KeyEditorComment | The Editor Comment key used accross the verifications and action messages.
KeyEditorCommentTextBox | The Editor Comment text box key used accross the verifications and action messages.
KeyEditorDropDown | The Editor DropDown key used accross the verifications and action messages.
KeyEditorDropDownBody | The Editor DropDownBody key used accross the verifications and action messages.
KeyEditorModeCommand | The Editor Mode key used accross the verifications and action messages.
KeyEditorSpinBox | The Editor SpinBox key used accross the verifications and action messages.
KeyEditorSplitButton | The Editor Split Button key used accross the verifications and action messages.
ToolBarIdPostfix | The string postfix of the toolbar ID, when toolbar mode of editor is not default.
ToolBarIdPrefix | The string prefix of the toolbar ID, when toolbar mode of editor is not default.

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


EditorConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants Fields
EditorConstants Class See Also Send Feedback

The EditorConstants type exposes the following members.

Fields

Name | Description
CssEditor | The CSS class identifying the RadEditor control.
CssEditorCommandExclude | The CSS class, excluding splitbuttons, identifying the RadEditorCommand control.
CssEditorCommandInclude | The CSS class identifying the RadEditorCommand control.
CssEditorComment | The CSS class identifying the RadEditor comment.
CssEditorCommentsBox | The CSS class identifying the RadEditor Comments box.
CssEditorCommentTextBox | The CSS class identifying the RadEditor comment textbox.
CssEditorDropDown | The CSS class identifying the RadEditorDropDown control.
CssEditorDropDownBody | The CSS class identifying the DropDownBody control.
CssEditorModeCommand | The CSS class identifying the RadEditorModeCommand control.
CssEditorSpinBox | The CSS class identifying the RadEditorSpinBox control.
CssEditorSpinBoxDecrease | The CSS class identifying decreasing handler of the RadEditorSpinBox.
CssEditorSpinBoxIncrease | The CSS class identifying increasing handler of the RadEditorSpinBox.
CssEditorSpinBoxTextBox | The CSS class identifying the textbox of the RadEditorSpinBox.
CssModeCommandSelected | The CSS class, that will be added, when the RadEditorModeCommand is selected.
CssSplitButton | The CSS class identifying the RadEditorSplitButton control.
CssSplitButtonHandler | The CSS class identifying showing handler of RadEditorCommand control.
CssTableHelperCell | The CSS class identifying the table cell of the Table helper.
CssToolDisabled | The CSS class, that will be added, when the tool is disabled.
CssToolSelected | The CSS class, that will be added, when the tool is selected.
EditorCommandsUsingSelectedText | The string, identify a group of editor commands, that uses selected text.
KeyEditor | The Editor key used accross the verifications and action messages.
KeyEditorCommand | The Editor Command key used accross the verifications and action messages.
KeyEditorComment | The Editor Comment key used accross the verifications and action messages.
KeyEditorCommentTextBox | The Editor Comment text box key used accross the verifications and action messages.
KeyEditorDropDown | The Editor DropDown key used accross the verifications and action messages.
KeyEditorDropDownBody | The Editor DropDownBody key used accross the verifications and action messages.
KeyEditorModeCommand | The Editor Mode key used accross the verifications and action messages.
KeyEditorSpinBox | The Editor SpinBox key used accross the verifications and action messages.
KeyEditorSplitButton | The Editor Split Button key used accross the verifications and action messages.
ToolBarIdPostfix | The string postfix of the toolbar ID, when toolbar mode of editor is not default.
ToolBarIdPrefix | The string prefix of the toolbar ID, when toolbar mode of editor is not default.

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditor Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditor control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditor
Visual Basic
Public Const CssEditor As String
Visual C++
public:
literal String^ CssEditor

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorCommandExclude Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorCommandExclude Field
EditorConstants Class See Also Send Feedback
The CSS class, excluding splitbuttons, identifying the RadEditorCommand control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorCommandExclude
Visual Basic
Public Const CssEditorCommandExclude As String
Visual C++
public:
literal String^ CssEditorCommandExclude

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorCommandInclude Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorCommandInclude Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorCommand control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorCommandInclude
Visual Basic
Public Const CssEditorCommandInclude As String
Visual C++
public:
literal String^ CssEditorCommandInclude

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorComment Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorComment Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditor comment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorComment
Visual Basic
Public Const CssEditorComment As String
Visual C++
public:
literal String^ CssEditorComment

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorCommentsBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorCommentsBox Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditor Comments box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorCommentsBox
Visual Basic
Public Const CssEditorCommentsBox As String
Visual C++
public:
literal String^ CssEditorCommentsBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorCommentTextBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorCommentTextBox Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditor comment textbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorCommentTextBox
Visual Basic
Public Const CssEditorCommentTextBox As String
Visual C++
public:
literal String^ CssEditorCommentTextBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorDropDown Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorDropDown Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorDropDown control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorDropDown
Visual Basic
Public Const CssEditorDropDown As String
Visual C++
public:
literal String^ CssEditorDropDown

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorDropDownBody Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorDropDownBody Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the DropDownBody control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorDropDownBody
Visual Basic
Public Const CssEditorDropDownBody As String
Visual C++
public:
literal String^ CssEditorDropDownBody

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorModeCommand Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorModeCommand Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorModeCommand control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorModeCommand
Visual Basic
Public Const CssEditorModeCommand As String
Visual C++
public:
literal String^ CssEditorModeCommand

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorSpinBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorSpinBox Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorSpinBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorSpinBox
Visual Basic
Public Const CssEditorSpinBox As String
Visual C++
public:
literal String^ CssEditorSpinBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorSpinBoxDecrease Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorSpinBoxDecrease Field
EditorConstants Class See Also Send Feedback
The CSS class identifying decreasing handler of the RadEditorSpinBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorSpinBoxDecrease
Visual Basic
Public Const CssEditorSpinBoxDecrease As String
Visual C++
public:
literal String^ CssEditorSpinBoxDecrease

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorSpinBoxIncrease Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorSpinBoxIncrease Field
EditorConstants Class See Also Send Feedback
The CSS class identifying increasing handler of the RadEditorSpinBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorSpinBoxIncrease
Visual Basic
Public Const CssEditorSpinBoxIncrease As String
Visual C++
public:
literal String^ CssEditorSpinBoxIncrease

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditorSpinBoxTextBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssEditorSpinBoxTextBox Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the textbox of the RadEditorSpinBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditorSpinBoxTextBox
Visual Basic
Public Const CssEditorSpinBoxTextBox As String
Visual C++
public:
literal String^ CssEditorSpinBoxTextBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssModeCommandSelected Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssModeCommandSelected Field
EditorConstants Class See Also Send Feedback
The CSS class, that will be added, when the RadEditorModeCommand is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssModeCommandSelected
Visual Basic
Public Const CssModeCommandSelected As String
Visual C++
public:
literal String^ CssModeCommandSelected

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSplitButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssSplitButton Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the RadEditorSplitButton control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSplitButton
Visual Basic
Public Const CssSplitButton As String
Visual C++
public:
literal String^ CssSplitButton

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSplitButtonHandler Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssSplitButtonHandler Field
EditorConstants Class See Also Send Feedback
The CSS class identifying showing handler of RadEditorCommand control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSplitButtonHandler
Visual Basic
Public Const CssSplitButtonHandler As String
Visual C++
public:
literal String^ CssSplitButtonHandler

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTableHelperCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssTableHelperCell Field
EditorConstants Class See Also Send Feedback
The CSS class identifying the table cell of the Table helper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTableHelperCell
Visual Basic
Public Const CssTableHelperCell As String
Visual C++
public:
literal String^ CssTableHelperCell

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolDisabled Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssToolDisabled Field
EditorConstants Class See Also Send Feedback
The CSS class, that will be added, when the tool is disabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolDisabled
Visual Basic
Public Const CssToolDisabled As String
Visual C++
public:
literal String^ CssToolDisabled

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolSelected Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..CssToolSelected Field
EditorConstants Class See Also Send Feedback
The CSS class, that will be added, when the tool is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolSelected
Visual Basic
Public Const CssToolSelected As String
Visual C++
public:
literal String^ CssToolSelected

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


EditorCommandsUsingSelectedText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..EditorCommandsUsingSelectedText Field
EditorConstants Class See Also Send Feedback
The string, identify a group of editor commands, that uses selected text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string EditorCommandsUsingSelectedText
Visual Basic
Public Const EditorCommandsUsingSelectedText As String
Visual C++
public:
literal String^ EditorCommandsUsingSelectedText

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditor Field
EditorConstants Class See Also Send Feedback
The Editor key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditor
Visual Basic
Public Const KeyEditor As String
Visual C++
public:
literal String^ KeyEditor

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorCommand Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditorCommand Field
EditorConstants Class See Also Send Feedback
The Editor Command key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditorCommand
Visual Basic
Public Const KeyEditorCommand As String
Visual C++
public:
literal String^ KeyEditorCommand

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorComment Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditorComment Field
EditorConstants Class See Also Send Feedback
The Editor Comment key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditorComment
Visual Basic
Public Const KeyEditorComment As String
Visual C++
public:
literal String^ KeyEditorComment

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorCommentTextBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditorCommentTextBox Field
EditorConstants Class See Also Send Feedback
The Editor Comment text box key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditorCommentTextBox
Visual Basic
Public Const KeyEditorCommentTextBox As String
Visual C++
public:
literal String^ KeyEditorCommentTextBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorDropDown Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditorDropDown Field
EditorConstants Class See Also Send Feedback
The Editor DropDown key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditorDropDown
Visual Basic
Public Const KeyEditorDropDown As String
Visual C++
public:
literal String^ KeyEditorDropDown

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorDropDownBody Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditorDropDownBody Field
EditorConstants Class See Also Send Feedback
The Editor DropDownBody key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditorDropDownBody
Visual Basic
Public Const KeyEditorDropDownBody As String
Visual C++
public:
literal String^ KeyEditorDropDownBody

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorModeCommand Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditorModeCommand Field
EditorConstants Class See Also Send Feedback
The Editor Mode key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditorModeCommand
Visual Basic
Public Const KeyEditorModeCommand As String
Visual C++
public:
literal String^ KeyEditorModeCommand

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorSpinBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditorSpinBox Field
EditorConstants Class See Also Send Feedback
The Editor SpinBox key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditorSpinBox
Visual Basic
Public Const KeyEditorSpinBox As String
Visual C++
public:
literal String^ KeyEditorSpinBox

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyEditorSplitButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..KeyEditorSplitButton Field
EditorConstants Class See Also Send Feedback
The Editor Split Button key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyEditorSplitButton
Visual Basic
Public Const KeyEditorSplitButton As String
Visual C++
public:
literal String^ KeyEditorSplitButton

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarIdPostfix Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..ToolBarIdPostfix Field
EditorConstants Class See Also Send Feedback
The string postfix of the toolbar ID, when toolbar mode of editor is not default.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ToolBarIdPostfix
Visual Basic
Public Const ToolBarIdPostfix As String
Visual C++
public:
literal String^ ToolBarIdPostfix

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarIdPrefix Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorConstants..::..ToolBarIdPrefix Field
EditorConstants Class See Also Send Feedback
The string prefix of the toolbar ID, when toolbar mode of editor is not default.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ToolBarIdPrefix
Visual Basic
Public Const ToolBarIdPrefix As String
Visual C++
public:
literal String^ ToolBarIdPrefix

See Also

EditorConstants Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown Members
EditorDropDown Class Constructors Methods Properties See Also Send Feedback

The EditorDropDown type exposes the following members.

Constructors

 | Name | Description
Public method | EditorDropDown()()()() | Initializes a new instance of the EditorDropDown class.
Public method | EditorDropDown(Element) | Initializes a new instance of the EditorDropDown class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlAnchor..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides the drop down.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectItem | Selects Item.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows the drop down.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadEditor dropdown. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CommandName | The Command name.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DropDownValue | Gets/Sets the value of the drop down.
Public property | EditorId | Gets the parent Editor Id.
Public property | Enabled | Determines or set whether RadEditorDropDown is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsExpanded | Determines whether RadEditorDropDown is expanded.
Public property | IsOn | Determines whether RadEditorDropDown is on.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Gets the item count of the drop down.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorDropDown. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link. (Inherited from HtmlAnchor.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets/Sets selected index of drop down.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown Constructor
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditorDropDown()()()() | Initializes a new instance of the EditorDropDown class.
Public method | EditorDropDown(Element) | Initializes a new instance of the EditorDropDown class.

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown Constructor
EditorDropDown Class See Also Send Feedback
Initializes a new instance of the EditorDropDown class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorDropDown()
Visual Basic
Public Sub New
Visual C++
public:
EditorDropDown()

See Also

EditorDropDown Class
EditorDropDown Overload
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown Constructor (Element)
EditorDropDown Class See Also Send Feedback
Initializes a new instance of the EditorDropDown class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorDropDown(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorDropDown(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorDropDown.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorDropDown Class
EditorDropDown Overload
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown Methods
EditorDropDown Class See Also Send Feedback

The EditorDropDown type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlAnchor..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides the drop down.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectItem | Selects Item.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows the drop down.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..AssignElement Method
EditorDropDown Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..CallMethod Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..Capture Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..Click Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..ControlAssert Method
EditorDropDown Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..DragTo Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..GetValue Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..Hide Method
EditorDropDown Class See Also Send Feedback
Hides the drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..InvokeEvent Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..MouseClick Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..MouseHover Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..ScrollToVisible Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


SelectItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..SelectItem Method
EditorDropDown Class See Also Send Feedback
Selects Item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectItem(
    int index
)
Visual Basic
Public Sub SelectItem ( _
    index As Integer _
)
Visual C++
public:
void SelectItem(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorDropDown.SelectItem(System.Int32)"]

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..SetValue Method
EditorDropDown Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorDropDown Class
EditorDropDown Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown..::..Show Method
EditorDropDown Class See Also Send Feedback
Shows the drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDown Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDown Properties
EditorDropDown Class See Also Send Feedback

The EditorDropDown type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadEditor dropdown. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CommandName | The Command name.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DropDownValue | Gets/Sets the value of the drop down.
Public property | EditorId | Gets the parent Editor Id.
Public property | Enabled | Determines or set whether RadEditorDropDown is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsExpanded | Determines whether RadEditorDropDown is expanded.
Public property | IsOn | Determines whether RadEditorDropDown is on.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Gets the item count of the drop down.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorDropDown. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link. (Inherited from HtmlAnchor.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets/Sets selected index of drop down.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDown Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody Members
EditorDropDownBody Class Constructors Methods Properties See Also Send Feedback

The EditorDropDownBody type exposes the following members.

Constructors

 | Name | Description
Public method | EditorDropDownBody()()()() | Initializes a new instance of the EditorDropDownBody class.
Public method | EditorDropDownBody(Element) | Initializes a new instance of the EditorDropDownBody class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the HtmlFindExpression that defines the pattern for a EditorDropDownBody. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody Constructor
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditorDropDownBody()()()() | Initializes a new instance of the EditorDropDownBody class.
Public method | EditorDropDownBody(Element) | Initializes a new instance of the EditorDropDownBody class.

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody Constructor
EditorDropDownBody Class See Also Send Feedback
Initializes a new instance of the EditorDropDownBody class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorDropDownBody()
Visual Basic
Public Sub New
Visual C++
public:
EditorDropDownBody()

See Also

EditorDropDownBody Class
EditorDropDownBody Overload
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody Constructor (Element)
EditorDropDownBody Class See Also Send Feedback
Initializes a new instance of the EditorDropDownBody class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorDropDownBody(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorDropDownBody(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorDropDownBody.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorDropDownBody Class
EditorDropDownBody Overload
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody Methods
EditorDropDownBody Class See Also Send Feedback

The EditorDropDownBody type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..AssignElement Method
EditorDropDownBody Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..CallMethod Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..Capture Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..Click Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..ControlAssert Method
EditorDropDownBody Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..DragTo Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..GetValue Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..InvokeEvent Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..MouseClick Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..MouseHover Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..ScrollToVisible Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody..::..SetValue Method
EditorDropDownBody Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
EditorDropDownBody Members
Telerik.WebAii.Controls.Html Namespace


EditorDropDownBody Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorDropDownBody Properties
EditorDropDownBody Class See Also Send Feedback

The EditorDropDownBody type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the HtmlFindExpression that defines the pattern for a EditorDropDownBody. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorDropDownBody Class
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand Members
EditorModeCommand Class Constructors Methods Properties See Also Send Feedback

The EditorModeCommand type exposes the following members.

Constructors

 | Name | Description
Public method | EditorModeCommand()()()() | Initializes a new instance of the EditorModeCommand class.
Public method | EditorModeCommand(Element) | Initializes a new instance of the EditorModeCommand class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CommandName | The Command name.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorModeCommand. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Determines whether this command is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand Constructor
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditorModeCommand()()()() | Initializes a new instance of the EditorModeCommand class.
Public method | EditorModeCommand(Element) | Initializes a new instance of the EditorModeCommand class.

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand Constructor
EditorModeCommand Class See Also Send Feedback
Initializes a new instance of the EditorModeCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorModeCommand()
Visual Basic
Public Sub New
Visual C++
public:
EditorModeCommand()

See Also

EditorModeCommand Class
EditorModeCommand Overload
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand Constructor (Element)
EditorModeCommand Class See Also Send Feedback
Initializes a new instance of the EditorModeCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorModeCommand(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorModeCommand(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorModeCommand.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorModeCommand Class
EditorModeCommand Overload
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand Methods
EditorModeCommand Class See Also Send Feedback

The EditorModeCommand type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..AssignElement Method
EditorModeCommand Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..CallMethod Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..Capture Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..Click Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..DragTo Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..GetValue Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..InvokeEvent Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..MouseClick Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..MouseHover Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..ScrollToVisible Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand..::..SetValue Method
EditorModeCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
EditorModeCommand Members
Telerik.WebAii.Controls.Html Namespace


EditorModeCommand Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorModeCommand Properties
EditorModeCommand Class See Also Send Feedback

The EditorModeCommand type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CommandName | The Command name.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorModeCommand. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Determines whether this command is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorModeCommand Class
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox Members
EditorSpinBox Class Constructors Methods Properties See Also Send Feedback

The EditorSpinBox type exposes the following members.

Constructors

 | Name | Description
Public method | EditorSpinBox()()()() | Initializes a new instance of the EditorSpinBox class.
Public method | EditorSpinBox(Element) | Initializes a new instance of the EditorSpinBox class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorSpinBox. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SpinBoxValue | Gets/Sets SpinBox value.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox Constructor
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditorSpinBox()()()() | Initializes a new instance of the EditorSpinBox class.
Public method | EditorSpinBox(Element) | Initializes a new instance of the EditorSpinBox class.

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox Constructor
EditorSpinBox Class See Also Send Feedback
Initializes a new instance of the EditorSpinBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorSpinBox()
Visual Basic
Public Sub New
Visual C++
public:
EditorSpinBox()

See Also

EditorSpinBox Class
EditorSpinBox Overload
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox Constructor (Element)
EditorSpinBox Class See Also Send Feedback
Initializes a new instance of the EditorSpinBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorSpinBox(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorSpinBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorSpinBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorSpinBox Class
EditorSpinBox Overload
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox Methods
EditorSpinBox Class See Also Send Feedback

The EditorSpinBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..AssignElement Method
EditorSpinBox Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..CallMethod Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..Capture Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..Click Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..DragTo Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..GetValue Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..InvokeEvent Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..MouseClick Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..MouseHover Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..ScrollToVisible Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox..::..SetValue Method
EditorSpinBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
EditorSpinBox Members
Telerik.WebAii.Controls.Html Namespace


EditorSpinBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSpinBox Properties
EditorSpinBox Class See Also Send Feedback

The EditorSpinBox type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorSpinBox. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SpinBoxValue | Gets/Sets SpinBox value.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSpinBox Class
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton Members
EditorSplitButton Class Constructors Methods Properties See Also Send Feedback

The EditorSplitButton type exposes the following members.

Constructors

 | Name | Description
Public method | EditorSplitButton()()()() | Initializes a new instance of the EditorSplitButton class.
Public method | EditorSplitButton(Element) | Initializes a new instance of the EditorSplitButton class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlAnchor..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the split button.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectItem | Selects item.
Public method | SelectItemOfTableHelper | Selects item of table helper.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the split button.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadEditor splitbutton. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Color | Gets/Sets the color of the tool(if it has).
Public property | CommandName | The Command name.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EditorId | Gets the parent Editor ID.
Public property | Enabled | Determines or set whether RadEditorSplitButton is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsExpanded | Determines whether RadEditorSplitButton is expanded.
Public property | IsOn | Determines whether RadEditorSplitButton is on.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Gets the number of items.
Public property | ItemsPerRow | Gets the number of items per row.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorSplitButton. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link. (Inherited from HtmlAnchor.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets/Sets selected index of slit button.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TableHelperClicked | Determines whether the table helper is clicked.
Public property | TableHelperSelectedIndex | Gets/Sets the table helper active index.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton Constructor
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EditorSplitButton()()()() | Initializes a new instance of the EditorSplitButton class.
Public method | EditorSplitButton(Element) | Initializes a new instance of the EditorSplitButton class.

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton Constructor
EditorSplitButton Class See Also Send Feedback
Initializes a new instance of the EditorSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorSplitButton()
Visual Basic
Public Sub New
Visual C++
public:
EditorSplitButton()

See Also

EditorSplitButton Class
EditorSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton Constructor (Element)
EditorSplitButton Class See Also Send Feedback
Initializes a new instance of the EditorSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorSplitButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
EditorSplitButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.EditorSplitButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

EditorSplitButton Class
EditorSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton Methods
EditorSplitButton Class See Also Send Feedback

The EditorSplitButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlAnchor..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the split button.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectItem | Selects item.
Public method | SelectItemOfTableHelper | Selects item of table helper.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the split button.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..AssignElement Method
EditorSplitButton Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..CallMethod Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..Capture Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..Click Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..ControlAssert Method
EditorSplitButton Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..DragTo Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..GetValue Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..Hide Method
EditorSplitButton Class See Also Send Feedback
Hide the split button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..InvokeEvent Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..MouseClick Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..MouseHover Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..ScrollToVisible Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


SelectItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..SelectItem Method
EditorSplitButton Class See Also Send Feedback
Selects item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectItem(
    int index
)
Visual Basic
Public Sub SelectItem ( _
    index As Integer _
)
Visual C++
public:
void SelectItem(
    int index
)

Parameters

index
Type: System..::..Int32
The index of item.

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


SelectItemOfTableHelper Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..SelectItemOfTableHelper Method
EditorSplitButton Class See Also Send Feedback
Selects item of table helper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectItemOfTableHelper(
    int index
)
Visual Basic
Public Sub SelectItemOfTableHelper ( _
    index As Integer _
)
Visual C++
public:
void SelectItemOfTableHelper(
    int index
)

Parameters

index
Type: System..::..Int32
The index of item.

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..SetValue Method
EditorSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
EditorSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton..::..Show Method
EditorSplitButton Class See Also Send Feedback
Show the split button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


EditorSplitButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
EditorSplitButton Properties
EditorSplitButton Class See Also Send Feedback

The EditorSplitButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadEditor splitbutton. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Color | Gets/Sets the color of the tool(if it has).
Public property | CommandName | The Command name.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EditorId | Gets the parent Editor ID.
Public property | Enabled | Determines or set whether RadEditorSplitButton is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsExpanded | Determines whether RadEditorSplitButton is expanded.
Public property | IsOn | Determines whether RadEditorSplitButton is on.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Gets the number of items.
Public property | ItemsPerRow | Gets the number of items per row.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a EditorSplitButton. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link. (Inherited from HtmlAnchor.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets/Sets selected index of slit button.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TableHelperClicked | Determines whether the table helper is clicked.
Public property | TableHelperSelectedIndex | Gets/Sets the table helper active index.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

EditorSplitButton Class
Telerik.WebAii.Controls.Html Namespace


FileExplorerConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileExplorerConstants Members
FileExplorerConstants Class Fields See Also Send Feedback

The FileExplorerConstants type exposes the following members.

Fields

Name | Description
CssRadFileExplorer | The base CSS class of the RadFileExplorer wrapper element.
CssRadFileExplorerListViewItem | The base CSS class of the RadFileExplorer ListView wrapper element.
FileExplorerKey | The 'FileExplorer' key used across the source classes.

See Also

FileExplorerConstants Class
Telerik.WebAii.Controls.Html Namespace


FileExplorerConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileExplorerConstants Fields
FileExplorerConstants Class See Also Send Feedback

The FileExplorerConstants type exposes the following members.

Fields

Name | Description
CssRadFileExplorer | The base CSS class of the RadFileExplorer wrapper element.
CssRadFileExplorerListViewItem | The base CSS class of the RadFileExplorer ListView wrapper element.
FileExplorerKey | The 'FileExplorer' key used across the source classes.

See Also

FileExplorerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadFileExplorer Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileExplorerConstants..::..CssRadFileExplorer Field
FileExplorerConstants Class See Also Send Feedback
The base CSS class of the RadFileExplorer wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadFileExplorer
Visual Basic
Public Const CssRadFileExplorer As String
Visual C++
public:
literal String^ CssRadFileExplorer

See Also

FileExplorerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadFileExplorerListViewItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileExplorerConstants..::..CssRadFileExplorerListViewItem Field
FileExplorerConstants Class See Also Send Feedback
The base CSS class of the RadFileExplorer ListView wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadFileExplorerListViewItem
Visual Basic
Public Const CssRadFileExplorerListViewItem As String
Visual C++
public:
literal String^ CssRadFileExplorerListViewItem

See Also

FileExplorerConstants Class
Telerik.WebAii.Controls.Html Namespace


FileExplorerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FileExplorerConstants..::..FileExplorerKey Field
FileExplorerConstants Class See Also Send Feedback
The 'FileExplorer' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FileExplorerKey
Visual Basic
Public Const FileExplorerKey As String
Visual C++
public:
literal String^ FileExplorerKey

See Also

FileExplorerConstants Class
Telerik.WebAii.Controls.Html Namespace


FilterConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants Members
FilterConstants Class Fields See Also Send Feedback

The FilterConstants type exposes the following members.

Fields

Name | Description
CssAddExpressionAnchor | The CSS class of the 'add expression' anchor.
CssAddGroupAnchor | The CSS class of the 'add group' anchor.
CssDeleteAnchor | The CSS class of the 'delete' anchor.
CssDeleteButtonDiv | The CSS class of the div containing the delete button.
CssExpressionAnchor | The CSS class of the anchor that contains the expression value.
CssFieldAnchor | The CSS class of the anchor that contains the field value.
CssFilterButton | The CSS class of the filter button.
CssFilterButtonDiv | The CSS class of the div containing the filter button.
CssFilterItemDivContainer | The CSS class of the div container of the filter item.
CssFilterItemLeftDiv | The CSS class of the first div in the filter item.
CssOperatorAnchor | The CSS class of the 'operator' anchor.
CssRadFilter | The CSS class of the Filter div wrapper.
CssTextBox | The CSS class of the asp TextBox controls generated for string fields.
FilterItemKey | The FilterItemKey key.
FilterKey | The RadFilter key.

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


FilterConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants Fields
FilterConstants Class See Also Send Feedback

The FilterConstants type exposes the following members.

Fields

Name | Description
CssAddExpressionAnchor | The CSS class of the 'add expression' anchor.
CssAddGroupAnchor | The CSS class of the 'add group' anchor.
CssDeleteAnchor | The CSS class of the 'delete' anchor.
CssDeleteButtonDiv | The CSS class of the div containing the delete button.
CssExpressionAnchor | The CSS class of the anchor that contains the expression value.
CssFieldAnchor | The CSS class of the anchor that contains the field value.
CssFilterButton | The CSS class of the filter button.
CssFilterButtonDiv | The CSS class of the div containing the filter button.
CssFilterItemDivContainer | The CSS class of the div container of the filter item.
CssFilterItemLeftDiv | The CSS class of the first div in the filter item.
CssOperatorAnchor | The CSS class of the 'operator' anchor.
CssRadFilter | The CSS class of the Filter div wrapper.
CssTextBox | The CSS class of the asp TextBox controls generated for string fields.
FilterItemKey | The FilterItemKey key.
FilterKey | The RadFilter key.

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAddExpressionAnchor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssAddExpressionAnchor Field
FilterConstants Class See Also Send Feedback
The CSS class of the 'add expression' anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAddExpressionAnchor
Visual Basic
Public Const CssAddExpressionAnchor As String
Visual C++
public:
literal String^ CssAddExpressionAnchor

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAddGroupAnchor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssAddGroupAnchor Field
FilterConstants Class See Also Send Feedback
The CSS class of the 'add group' anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAddGroupAnchor
Visual Basic
Public Const CssAddGroupAnchor As String
Visual C++
public:
literal String^ CssAddGroupAnchor

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDeleteAnchor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssDeleteAnchor Field
FilterConstants Class See Also Send Feedback
The CSS class of the 'delete' anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDeleteAnchor
Visual Basic
Public Const CssDeleteAnchor As String
Visual C++
public:
literal String^ CssDeleteAnchor

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDeleteButtonDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssDeleteButtonDiv Field
FilterConstants Class See Also Send Feedback
The CSS class of the div containing the delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDeleteButtonDiv
Visual Basic
Public Const CssDeleteButtonDiv As String
Visual C++
public:
literal String^ CssDeleteButtonDiv

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpressionAnchor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssExpressionAnchor Field
FilterConstants Class See Also Send Feedback
The CSS class of the anchor that contains the expression value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExpressionAnchor
Visual Basic
Public Const CssExpressionAnchor As String
Visual C++
public:
literal String^ CssExpressionAnchor

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFieldAnchor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssFieldAnchor Field
FilterConstants Class See Also Send Feedback
The CSS class of the anchor that contains the field value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFieldAnchor
Visual Basic
Public Const CssFieldAnchor As String
Visual C++
public:
literal String^ CssFieldAnchor

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFilterButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssFilterButton Field
FilterConstants Class See Also Send Feedback
The CSS class of the filter button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFilterButton
Visual Basic
Public Const CssFilterButton As String
Visual C++
public:
literal String^ CssFilterButton

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFilterButtonDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssFilterButtonDiv Field
FilterConstants Class See Also Send Feedback
The CSS class of the div containing the filter button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFilterButtonDiv
Visual Basic
Public Const CssFilterButtonDiv As String
Visual C++
public:
literal String^ CssFilterButtonDiv

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFilterItemDivContainer Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssFilterItemDivContainer Field
FilterConstants Class See Also Send Feedback
The CSS class of the div container of the filter item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFilterItemDivContainer
Visual Basic
Public Const CssFilterItemDivContainer As String
Visual C++
public:
literal String^ CssFilterItemDivContainer

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFilterItemLeftDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssFilterItemLeftDiv Field
FilterConstants Class See Also Send Feedback
The CSS class of the first div in the filter item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFilterItemLeftDiv
Visual Basic
Public Const CssFilterItemLeftDiv As String
Visual C++
public:
literal String^ CssFilterItemLeftDiv

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssOperatorAnchor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssOperatorAnchor Field
FilterConstants Class See Also Send Feedback
The CSS class of the 'operator' anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssOperatorAnchor
Visual Basic
Public Const CssOperatorAnchor As String
Visual C++
public:
literal String^ CssOperatorAnchor

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadFilter Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssRadFilter Field
FilterConstants Class See Also Send Feedback
The CSS class of the Filter div wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadFilter
Visual Basic
Public Const CssRadFilter As String
Visual C++
public:
literal String^ CssRadFilter

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTextBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..CssTextBox Field
FilterConstants Class See Also Send Feedback
The CSS class of the asp TextBox controls generated for string fields.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTextBox
Visual Basic
Public Const CssTextBox As String
Visual C++
public:
literal String^ CssTextBox

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


FilterItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..FilterItemKey Field
FilterConstants Class See Also Send Feedback
The FilterItemKey key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FilterItemKey
Visual Basic
Public Const FilterItemKey As String
Visual C++
public:
literal String^ FilterItemKey

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


FilterKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
FilterConstants..::..FilterKey Field
FilterConstants Class See Also Send Feedback
The RadFilter key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FilterKey
Visual Basic
Public Const FilterKey As String
Visual C++
public:
literal String^ FilterKey

See Also

FilterConstants Class
Telerik.WebAii.Controls.Html Namespace


GridConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants Members
GridConstants Class Fields See Also Send Feedback

The GridConstants type exposes the following members.

Fields

Name | Description
ColumnKey | The Grid table column key used accross the verifications and action messages.
CssAdvancedPart | CSS class of the Grid pager navigation buttons part div.
CssArrayPart | CSS class of the Grid pager navigation buttons part div.
CssCollapse | CSS class of the Grid "collapse" input button.
CssCommandAdd | CSS class of the Grid Command item 'add new' button.
CssCommandRefresh | CSS class of the Grid Command item 'refresh' button.
CssCommandTable | The CSS class of the autogenerated command item table.
CssDetailTable | The unique CSS class of the detail table.
CssExpand | CSS class of the Grid "expand" input button.
CssExpandCol | CSS class of the Grid hierarchy expand/collapse column.
CssExportButton | The CSS class of the export buttons in the Command item.
CssExportCsv | The CSS class of the export to Csv button.
CssExportExcel | The CSS class of the export to Excel button.
CssExportPdf | The CSS class of the export to PDF button.
CssExportWord | The CSS class of the export to Word button.
CssFilter | CSS class of the Grid filtering input button.
CssGrid | The unique CSS class of the Grid div element.
CssGridAltRow | CSS class of the Grid alternating row item.
CssGridCommandRow | CSS class of the Grid Command item.
CssGridEditForm | CSS class of the Grid edit form item.
CssGridEditRow | CSS class of the Grid edited row item.
CssGridFilterRow | CSS class of the Grid filter item.
CssGridFooter | CSS class of the Grid footer item.
CssGridHeader | CSS class of the Grid header item.
CssGridPager | CSS class of the Grid pager item.
CssGridRow | CSS class of the Grid row item.
CssGroupCol | CSS class of the Grid group separator column.
CssGroupHeader | CSS class of the Grid group header item.
CssGroupPanelItem | CSS class of the Grid grouping panel item.
CssInfoPart | CSS class of the Grid pager info part div.
CssMasterTable | The unique CSS class of the master table.
CssMultiColumnheaders | The CSS class of the header row when multi column headers are enabled.
CssNumberPart | CSS class of the Grid pager number part div.
CssPageFirst | CSS class of the Grid pager "first page" button.
CssPageLast | CSS class of the Grid pager "last page" button.
CssPageNext | CSS class of the Grid pager "next page" button.
CssPagePrevious | CSS class of the Grid pager "previous page" button.
CssPagerCell | CSS class of the Grid pager cell.
CssResizeCol | CSS class of built-in resize column.
CssScrollingDiv | The CSS class of the div containert when the control has scrolling enabled.
CssSelectedCell | CSS class of a selected cell
CssSelectedItem | CSS class of a selected item
CssSort | CSS class of the Grid sorting input button.
CssSortAscending | CSS class of the Grid sorting input button - 'Asc' order.
CssSortDescending | CSS class of the Grid sorting input button - 'Desc' order.
CssStaticHeaderDiv | The CSS class of the header div when static headers are enabled.
CssUngroupButton | Css class of the Ungroup button.
CssWrap | CSS class of the Grid pager wrap div.
DataCellKey | The Grid data cell key used accross the verifications and action messages.
DataItemKey | The Grid Data Item key used accross the verifications and action messages.
FilterContextMenuButtonId | The unique part of the Grid context menu's filter button ID.
FilterContextMenuClearButtonId | The unique part of the Grid context menu's clear button ID.
FilterKey | The Grid filter item key used accross the verifications and action messages.
FooterKey | The Grid Footer key used accross the verifications and action messages.
GridKey | The Grid key used accross the verifications and action messages.
GroupItemKey | The Grid group item key used accross the verifications and action messages.
GroupKey | The Grid group item key used accross the verifications and action messages.
GroupPanelKey | The Grid group panel key used accross the verifications and action messages.
HeaderKey | The Grid Data header key used accross the verifications and action messages.
IdCancelButton | Id of the auto generated edit form "Cancel" button.
IdChangePageSize | Id of the "change page size" Advanced Pager button.
IdCommandItemAddNew | Id of the CommandItem "Insert" button.
IdCommandItemCsv | The ID of the export to csv button.
IdCommandItemExcel | The ID of the export to Wxcel button.
IdCommandItemPdf | The ID of the export to PDF button.
IdCommandItemRefresh | Id of the CommandItem "Rebind" button.
IdCommandItemWord | The ID of the export to Word button.
IdDeleteButton | Id of the auto generated "Delete" button.
IdDeleteColumn | The GridButtonColumn with Command "Delete" image button ID ending part.
IdEditButton | Id of the auto generated "Edit" button.
IdFilteringContextMenu | The unique part of the Grid context menu control Id.
IdGoToPage | Id of the "go to page" Advanced Pager button.
IdGridData | Id of the Grid Data div in scrolling mode.
IdGroupPanel | Id of the Grid group panel.
IdHierarchyButton | The ID of the hierarchy image button.
IdInsertButton | Id of the auto generated insert form "Insert" button.
IdMasterTable | The Id ending part of the Grid master table.
IdSelectCheckBox | Id of the ClientSelectCheckBox column check boxes.
IdUpdateButton | Id of the auto generated edit form "Update" button.
PagerKey | The Grid Pager key used accross the verifications and action messages.
TableKey | The Grid table key used accross the verifications and action messages.

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GridConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants Fields
GridConstants Class See Also Send Feedback

The GridConstants type exposes the following members.

Fields

Name | Description
ColumnKey | The Grid table column key used accross the verifications and action messages.
CssAdvancedPart | CSS class of the Grid pager navigation buttons part div.
CssArrayPart | CSS class of the Grid pager navigation buttons part div.
CssCollapse | CSS class of the Grid "collapse" input button.
CssCommandAdd | CSS class of the Grid Command item 'add new' button.
CssCommandRefresh | CSS class of the Grid Command item 'refresh' button.
CssCommandTable | The CSS class of the autogenerated command item table.
CssDetailTable | The unique CSS class of the detail table.
CssExpand | CSS class of the Grid "expand" input button.
CssExpandCol | CSS class of the Grid hierarchy expand/collapse column.
CssExportButton | The CSS class of the export buttons in the Command item.
CssExportCsv | The CSS class of the export to Csv button.
CssExportExcel | The CSS class of the export to Excel button.
CssExportPdf | The CSS class of the export to PDF button.
CssExportWord | The CSS class of the export to Word button.
CssFilter | CSS class of the Grid filtering input button.
CssGrid | The unique CSS class of the Grid div element.
CssGridAltRow | CSS class of the Grid alternating row item.
CssGridCommandRow | CSS class of the Grid Command item.
CssGridEditForm | CSS class of the Grid edit form item.
CssGridEditRow | CSS class of the Grid edited row item.
CssGridFilterRow | CSS class of the Grid filter item.
CssGridFooter | CSS class of the Grid footer item.
CssGridHeader | CSS class of the Grid header item.
CssGridPager | CSS class of the Grid pager item.
CssGridRow | CSS class of the Grid row item.
CssGroupCol | CSS class of the Grid group separator column.
CssGroupHeader | CSS class of the Grid group header item.
CssGroupPanelItem | CSS class of the Grid grouping panel item.
CssInfoPart | CSS class of the Grid pager info part div.
CssMasterTable | The unique CSS class of the master table.
CssMultiColumnheaders | The CSS class of the header row when multi column headers are enabled.
CssNumberPart | CSS class of the Grid pager number part div.
CssPageFirst | CSS class of the Grid pager "first page" button.
CssPageLast | CSS class of the Grid pager "last page" button.
CssPageNext | CSS class of the Grid pager "next page" button.
CssPagePrevious | CSS class of the Grid pager "previous page" button.
CssPagerCell | CSS class of the Grid pager cell.
CssResizeCol | CSS class of built-in resize column.
CssScrollingDiv | The CSS class of the div containert when the control has scrolling enabled.
CssSelectedCell | CSS class of a selected cell
CssSelectedItem | CSS class of a selected item
CssSort | CSS class of the Grid sorting input button.
CssSortAscending | CSS class of the Grid sorting input button - 'Asc' order.
CssSortDescending | CSS class of the Grid sorting input button - 'Desc' order.
CssStaticHeaderDiv | The CSS class of the header div when static headers are enabled.
CssUngroupButton | Css class of the Ungroup button.
CssWrap | CSS class of the Grid pager wrap div.
DataCellKey | The Grid data cell key used accross the verifications and action messages.
DataItemKey | The Grid Data Item key used accross the verifications and action messages.
FilterContextMenuButtonId | The unique part of the Grid context menu's filter button ID.
FilterContextMenuClearButtonId | The unique part of the Grid context menu's clear button ID.
FilterKey | The Grid filter item key used accross the verifications and action messages.
FooterKey | The Grid Footer key used accross the verifications and action messages.
GridKey | The Grid key used accross the verifications and action messages.
GroupItemKey | The Grid group item key used accross the verifications and action messages.
GroupKey | The Grid group item key used accross the verifications and action messages.
GroupPanelKey | The Grid group panel key used accross the verifications and action messages.
HeaderKey | The Grid Data header key used accross the verifications and action messages.
IdCancelButton | Id of the auto generated edit form "Cancel" button.
IdChangePageSize | Id of the "change page size" Advanced Pager button.
IdCommandItemAddNew | Id of the CommandItem "Insert" button.
IdCommandItemCsv | The ID of the export to csv button.
IdCommandItemExcel | The ID of the export to Wxcel button.
IdCommandItemPdf | The ID of the export to PDF button.
IdCommandItemRefresh | Id of the CommandItem "Rebind" button.
IdCommandItemWord | The ID of the export to Word button.
IdDeleteButton | Id of the auto generated "Delete" button.
IdDeleteColumn | The GridButtonColumn with Command "Delete" image button ID ending part.
IdEditButton | Id of the auto generated "Edit" button.
IdFilteringContextMenu | The unique part of the Grid context menu control Id.
IdGoToPage | Id of the "go to page" Advanced Pager button.
IdGridData | Id of the Grid Data div in scrolling mode.
IdGroupPanel | Id of the Grid group panel.
IdHierarchyButton | The ID of the hierarchy image button.
IdInsertButton | Id of the auto generated insert form "Insert" button.
IdMasterTable | The Id ending part of the Grid master table.
IdSelectCheckBox | Id of the ClientSelectCheckBox column check boxes.
IdUpdateButton | Id of the auto generated edit form "Update" button.
PagerKey | The Grid Pager key used accross the verifications and action messages.
TableKey | The Grid table key used accross the verifications and action messages.

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..ColumnKey Field
GridConstants Class See Also Send Feedback
The Grid table column key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ColumnKey
Visual Basic
Public Const ColumnKey As String
Visual C++
public:
literal String^ ColumnKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAdvancedPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssAdvancedPart Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager navigation buttons part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAdvancedPart
Visual Basic
Public Const CssAdvancedPart As String
Visual C++
public:
literal String^ CssAdvancedPart

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssArrayPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssArrayPart Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager navigation buttons part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssArrayPart
Visual Basic
Public Const CssArrayPart As String
Visual C++
public:
literal String^ CssArrayPart

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCollapse Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssCollapse Field
GridConstants Class See Also Send Feedback
CSS class of the Grid "collapse" input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCollapse
Visual Basic
Public Const CssCollapse As String
Visual C++
public:
literal String^ CssCollapse

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCommandAdd Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssCommandAdd Field
GridConstants Class See Also Send Feedback
CSS class of the Grid Command item 'add new' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCommandAdd
Visual Basic
Public Const CssCommandAdd As String
Visual C++
public:
literal String^ CssCommandAdd

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCommandRefresh Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssCommandRefresh Field
GridConstants Class See Also Send Feedback
CSS class of the Grid Command item 'refresh' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCommandRefresh
Visual Basic
Public Const CssCommandRefresh As String
Visual C++
public:
literal String^ CssCommandRefresh

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCommandTable Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssCommandTable Field
GridConstants Class See Also Send Feedback
The CSS class of the autogenerated command item table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCommandTable
Visual Basic
Public Const CssCommandTable As String
Visual C++
public:
literal String^ CssCommandTable

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDetailTable Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssDetailTable Field
GridConstants Class See Also Send Feedback
The unique CSS class of the detail table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDetailTable
Visual Basic
Public Const CssDetailTable As String
Visual C++
public:
literal String^ CssDetailTable

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpand Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssExpand Field
GridConstants Class See Also Send Feedback
CSS class of the Grid "expand" input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExpand
Visual Basic
Public Const CssExpand As String
Visual C++
public:
literal String^ CssExpand

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpandCol Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssExpandCol Field
GridConstants Class See Also Send Feedback
CSS class of the Grid hierarchy expand/collapse column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExpandCol
Visual Basic
Public Const CssExpandCol As String
Visual C++
public:
literal String^ CssExpandCol

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExportButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssExportButton Field
GridConstants Class See Also Send Feedback
The CSS class of the export buttons in the Command item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExportButton
Visual Basic
Public Const CssExportButton As String
Visual C++
public:
literal String^ CssExportButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExportCsv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssExportCsv Field
GridConstants Class See Also Send Feedback
The CSS class of the export to Csv button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExportCsv
Visual Basic
Public Const CssExportCsv As String
Visual C++
public:
literal String^ CssExportCsv

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExportExcel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssExportExcel Field
GridConstants Class See Also Send Feedback
The CSS class of the export to Excel button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExportExcel
Visual Basic
Public Const CssExportExcel As String
Visual C++
public:
literal String^ CssExportExcel

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExportPdf Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssExportPdf Field
GridConstants Class See Also Send Feedback
The CSS class of the export to PDF button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExportPdf
Visual Basic
Public Const CssExportPdf As String
Visual C++
public:
literal String^ CssExportPdf

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExportWord Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssExportWord Field
GridConstants Class See Also Send Feedback
The CSS class of the export to Word button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExportWord
Visual Basic
Public Const CssExportWord As String
Visual C++
public:
literal String^ CssExportWord

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFilter Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssFilter Field
GridConstants Class See Also Send Feedback
CSS class of the Grid filtering input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFilter
Visual Basic
Public Const CssFilter As String
Visual C++
public:
literal String^ CssFilter

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGrid Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGrid Field
GridConstants Class See Also Send Feedback
The unique CSS class of the Grid div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGrid
Visual Basic
Public Const CssGrid As String
Visual C++
public:
literal String^ CssGrid

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridAltRow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridAltRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid alternating row item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridAltRow
Visual Basic
Public Const CssGridAltRow As String
Visual C++
public:
literal String^ CssGridAltRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridCommandRow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridCommandRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid Command item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridCommandRow
Visual Basic
Public Const CssGridCommandRow As String
Visual C++
public:
literal String^ CssGridCommandRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridEditForm Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridEditForm Field
GridConstants Class See Also Send Feedback
CSS class of the Grid edit form item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridEditForm
Visual Basic
Public Const CssGridEditForm As String
Visual C++
public:
literal String^ CssGridEditForm

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridEditRow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridEditRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid edited row item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridEditRow
Visual Basic
Public Const CssGridEditRow As String
Visual C++
public:
literal String^ CssGridEditRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridFilterRow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridFilterRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid filter item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridFilterRow
Visual Basic
Public Const CssGridFilterRow As String
Visual C++
public:
literal String^ CssGridFilterRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridFooter Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridFooter Field
GridConstants Class See Also Send Feedback
CSS class of the Grid footer item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridFooter
Visual Basic
Public Const CssGridFooter As String
Visual C++
public:
literal String^ CssGridFooter

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridHeader Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridHeader Field
GridConstants Class See Also Send Feedback
CSS class of the Grid header item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridHeader
Visual Basic
Public Const CssGridHeader As String
Visual C++
public:
literal String^ CssGridHeader

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridPager Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridPager Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridPager
Visual Basic
Public Const CssGridPager As String
Visual C++
public:
literal String^ CssGridPager

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGridRow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGridRow Field
GridConstants Class See Also Send Feedback
CSS class of the Grid row item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGridRow
Visual Basic
Public Const CssGridRow As String
Visual C++
public:
literal String^ CssGridRow

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGroupCol Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGroupCol Field
GridConstants Class See Also Send Feedback
CSS class of the Grid group separator column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGroupCol
Visual Basic
Public Const CssGroupCol As String
Visual C++
public:
literal String^ CssGroupCol

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGroupHeader Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGroupHeader Field
GridConstants Class See Also Send Feedback
CSS class of the Grid group header item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGroupHeader
Visual Basic
Public Const CssGroupHeader As String
Visual C++
public:
literal String^ CssGroupHeader

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssGroupPanelItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssGroupPanelItem Field
GridConstants Class See Also Send Feedback
CSS class of the Grid grouping panel item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssGroupPanelItem
Visual Basic
Public Const CssGroupPanelItem As String
Visual C++
public:
literal String^ CssGroupPanelItem

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInfoPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssInfoPart Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager info part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssInfoPart
Visual Basic
Public Const CssInfoPart As String
Visual C++
public:
literal String^ CssInfoPart

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMasterTable Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssMasterTable Field
GridConstants Class See Also Send Feedback
The unique CSS class of the master table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMasterTable
Visual Basic
Public Const CssMasterTable As String
Visual C++
public:
literal String^ CssMasterTable

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMultiColumnheaders Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssMultiColumnheaders Field
GridConstants Class See Also Send Feedback
The CSS class of the header row when multi column headers are enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMultiColumnheaders
Visual Basic
Public Const CssMultiColumnheaders As String
Visual C++
public:
literal String^ CssMultiColumnheaders

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNumberPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssNumberPart Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager number part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNumberPart
Visual Basic
Public Const CssNumberPart As String
Visual C++
public:
literal String^ CssNumberPart

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageFirst Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssPageFirst Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager "first page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageFirst
Visual Basic
Public Const CssPageFirst As String
Visual C++
public:
literal String^ CssPageFirst

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageLast Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssPageLast Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager "last page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageLast
Visual Basic
Public Const CssPageLast As String
Visual C++
public:
literal String^ CssPageLast

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageNext Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssPageNext Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager "next page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageNext
Visual Basic
Public Const CssPageNext As String
Visual C++
public:
literal String^ CssPageNext

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPagePrevious Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssPagePrevious Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager "previous page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPagePrevious
Visual Basic
Public Const CssPagePrevious As String
Visual C++
public:
literal String^ CssPagePrevious

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPagerCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssPagerCell Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPagerCell
Visual Basic
Public Const CssPagerCell As String
Visual C++
public:
literal String^ CssPagerCell

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssResizeCol Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssResizeCol Field
GridConstants Class See Also Send Feedback
CSS class of built-in resize column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssResizeCol
Visual Basic
Public Const CssResizeCol As String
Visual C++
public:
literal String^ CssResizeCol

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssScrollingDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssScrollingDiv Field
GridConstants Class See Also Send Feedback
The CSS class of the div containert when the control has scrolling enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssScrollingDiv
Visual Basic
Public Const CssScrollingDiv As String
Visual C++
public:
literal String^ CssScrollingDiv

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSelectedCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssSelectedCell Field
GridConstants Class See Also Send Feedback
CSS class of a selected cell

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSelectedCell
Visual Basic
Public Const CssSelectedCell As String
Visual C++
public:
literal String^ CssSelectedCell

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSelectedItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssSelectedItem Field
GridConstants Class See Also Send Feedback
CSS class of a selected item

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSelectedItem
Visual Basic
Public Const CssSelectedItem As String
Visual C++
public:
literal String^ CssSelectedItem

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSort Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssSort Field
GridConstants Class See Also Send Feedback
CSS class of the Grid sorting input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSort
Visual Basic
Public Const CssSort As String
Visual C++
public:
literal String^ CssSort

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSortAscending Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssSortAscending Field
GridConstants Class See Also Send Feedback
CSS class of the Grid sorting input button - 'Asc' order.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSortAscending
Visual Basic
Public Const CssSortAscending As String
Visual C++
public:
literal String^ CssSortAscending

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSortDescending Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssSortDescending Field
GridConstants Class See Also Send Feedback
CSS class of the Grid sorting input button - 'Desc' order.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSortDescending
Visual Basic
Public Const CssSortDescending As String
Visual C++
public:
literal String^ CssSortDescending

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssStaticHeaderDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssStaticHeaderDiv Field
GridConstants Class See Also Send Feedback
The CSS class of the header div when static headers are enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssStaticHeaderDiv
Visual Basic
Public Const CssStaticHeaderDiv As String
Visual C++
public:
literal String^ CssStaticHeaderDiv

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssUngroupButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssUngroupButton Field
GridConstants Class See Also Send Feedback
Css class of the Ungroup button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssUngroupButton
Visual Basic
Public Const CssUngroupButton As String
Visual C++
public:
literal String^ CssUngroupButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssWrap Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..CssWrap Field
GridConstants Class See Also Send Feedback
CSS class of the Grid pager wrap div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssWrap
Visual Basic
Public Const CssWrap As String
Visual C++
public:
literal String^ CssWrap

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


DataCellKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..DataCellKey Field
GridConstants Class See Also Send Feedback
The Grid data cell key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DataCellKey
Visual Basic
Public Const DataCellKey As String
Visual C++
public:
literal String^ DataCellKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


DataItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..DataItemKey Field
GridConstants Class See Also Send Feedback
The Grid Data Item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DataItemKey
Visual Basic
Public Const DataItemKey As String
Visual C++
public:
literal String^ DataItemKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


FilterContextMenuButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..FilterContextMenuButtonId Field
GridConstants Class See Also Send Feedback
The unique part of the Grid context menu's filter button ID.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FilterContextMenuButtonId
Visual Basic
Public Const FilterContextMenuButtonId As String
Visual C++
public:
literal String^ FilterContextMenuButtonId

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


FilterContextMenuClearButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..FilterContextMenuClearButtonId Field
GridConstants Class See Also Send Feedback
The unique part of the Grid context menu's clear button ID.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FilterContextMenuClearButtonId
Visual Basic
Public Const FilterContextMenuClearButtonId As String
Visual C++
public:
literal String^ FilterContextMenuClearButtonId

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


FilterKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..FilterKey Field
GridConstants Class See Also Send Feedback
The Grid filter item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FilterKey
Visual Basic
Public Const FilterKey As String
Visual C++
public:
literal String^ FilterKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


FooterKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..FooterKey Field
GridConstants Class See Also Send Feedback
The Grid Footer key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FooterKey
Visual Basic
Public Const FooterKey As String
Visual C++
public:
literal String^ FooterKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GridKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..GridKey Field
GridConstants Class See Also Send Feedback
The Grid key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string GridKey
Visual Basic
Public Const GridKey As String
Visual C++
public:
literal String^ GridKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GroupItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..GroupItemKey Field
GridConstants Class See Also Send Feedback
The Grid group item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string GroupItemKey
Visual Basic
Public Const GroupItemKey As String
Visual C++
public:
literal String^ GroupItemKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GroupKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..GroupKey Field
GridConstants Class See Also Send Feedback
The Grid group item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string GroupKey
Visual Basic
Public Const GroupKey As String
Visual C++
public:
literal String^ GroupKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GroupPanelKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..GroupPanelKey Field
GridConstants Class See Also Send Feedback
The Grid group panel key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string GroupPanelKey
Visual Basic
Public Const GroupPanelKey As String
Visual C++
public:
literal String^ GroupPanelKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


HeaderKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..HeaderKey Field
GridConstants Class See Also Send Feedback
The Grid Data header key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string HeaderKey
Visual Basic
Public Const HeaderKey As String
Visual C++
public:
literal String^ HeaderKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCancelButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdCancelButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated edit form "Cancel" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdCancelButton
Visual Basic
Public Const IdCancelButton As String
Visual C++
public:
literal String^ IdCancelButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdChangePageSize Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdChangePageSize Field
GridConstants Class See Also Send Feedback
Id of the "change page size" Advanced Pager button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdChangePageSize
Visual Basic
Public Const IdChangePageSize As String
Visual C++
public:
literal String^ IdChangePageSize

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCommandItemAddNew Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdCommandItemAddNew Field
GridConstants Class See Also Send Feedback
Id of the CommandItem "Insert" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdCommandItemAddNew
Visual Basic
Public Const IdCommandItemAddNew As String
Visual C++
public:
literal String^ IdCommandItemAddNew

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCommandItemCsv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdCommandItemCsv Field
GridConstants Class See Also Send Feedback
The ID of the export to csv button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdCommandItemCsv
Visual Basic
Public Const IdCommandItemCsv As String
Visual C++
public:
literal String^ IdCommandItemCsv

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCommandItemExcel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdCommandItemExcel Field
GridConstants Class See Also Send Feedback
The ID of the export to Wxcel button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdCommandItemExcel
Visual Basic
Public Const IdCommandItemExcel As String
Visual C++
public:
literal String^ IdCommandItemExcel

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCommandItemPdf Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdCommandItemPdf Field
GridConstants Class See Also Send Feedback
The ID of the export to PDF button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdCommandItemPdf
Visual Basic
Public Const IdCommandItemPdf As String
Visual C++
public:
literal String^ IdCommandItemPdf

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCommandItemRefresh Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdCommandItemRefresh Field
GridConstants Class See Also Send Feedback
Id of the CommandItem "Rebind" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdCommandItemRefresh
Visual Basic
Public Const IdCommandItemRefresh As String
Visual C++
public:
literal String^ IdCommandItemRefresh

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCommandItemWord Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdCommandItemWord Field
GridConstants Class See Also Send Feedback
The ID of the export to Word button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdCommandItemWord
Visual Basic
Public Const IdCommandItemWord As String
Visual C++
public:
literal String^ IdCommandItemWord

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdDeleteButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdDeleteButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated "Delete" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdDeleteButton
Visual Basic
Public Const IdDeleteButton As String
Visual C++
public:
literal String^ IdDeleteButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdDeleteColumn Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdDeleteColumn Field
GridConstants Class See Also Send Feedback
The GridButtonColumn with Command "Delete" image button ID ending part.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdDeleteColumn
Visual Basic
Public Const IdDeleteColumn As String
Visual C++
public:
literal String^ IdDeleteColumn

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdEditButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdEditButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated "Edit" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdEditButton
Visual Basic
Public Const IdEditButton As String
Visual C++
public:
literal String^ IdEditButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdFilteringContextMenu Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdFilteringContextMenu Field
GridConstants Class See Also Send Feedback
The unique part of the Grid context menu control Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdFilteringContextMenu
Visual Basic
Public Const IdFilteringContextMenu As String
Visual C++
public:
literal String^ IdFilteringContextMenu

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdGoToPage Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdGoToPage Field
GridConstants Class See Also Send Feedback
Id of the "go to page" Advanced Pager button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdGoToPage
Visual Basic
Public Const IdGoToPage As String
Visual C++
public:
literal String^ IdGoToPage

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdGridData Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdGridData Field
GridConstants Class See Also Send Feedback
Id of the Grid Data div in scrolling mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdGridData
Visual Basic
Public Const IdGridData As String
Visual C++
public:
literal String^ IdGridData

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdGroupPanel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdGroupPanel Field
GridConstants Class See Also Send Feedback
Id of the Grid group panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdGroupPanel
Visual Basic
Public Const IdGroupPanel As String
Visual C++
public:
literal String^ IdGroupPanel

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdHierarchyButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdHierarchyButton Field
GridConstants Class See Also Send Feedback
The ID of the hierarchy image button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdHierarchyButton
Visual Basic
Public Const IdHierarchyButton As String
Visual C++
public:
literal String^ IdHierarchyButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdInsertButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdInsertButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated insert form "Insert" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdInsertButton
Visual Basic
Public Const IdInsertButton As String
Visual C++
public:
literal String^ IdInsertButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdMasterTable Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdMasterTable Field
GridConstants Class See Also Send Feedback
The Id ending part of the Grid master table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdMasterTable
Visual Basic
Public Const IdMasterTable As String
Visual C++
public:
literal String^ IdMasterTable

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSelectCheckBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdSelectCheckBox Field
GridConstants Class See Also Send Feedback
Id of the ClientSelectCheckBox column check boxes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSelectCheckBox
Visual Basic
Public Const IdSelectCheckBox As String
Visual C++
public:
literal String^ IdSelectCheckBox

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdUpdateButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..IdUpdateButton Field
GridConstants Class See Also Send Feedback
Id of the auto generated edit form "Update" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdUpdateButton
Visual Basic
Public Const IdUpdateButton As String
Visual C++
public:
literal String^ IdUpdateButton

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


PagerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..PagerKey Field
GridConstants Class See Also Send Feedback
The Grid Pager key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PagerKey
Visual Basic
Public Const PagerKey As String
Visual C++
public:
literal String^ PagerKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


TableKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridConstants..::..TableKey Field
GridConstants Class See Also Send Feedback
The Grid table key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TableKey
Visual Basic
Public Const TableKey As String
Visual C++
public:
literal String^ TableKey

See Also

GridConstants Class
Telerik.WebAii.Controls.Html Namespace


GridDataCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell Members
GridDataCell Class Constructors Methods Properties See Also Send Feedback

The GridDataCell type exposes the following members.

Constructors

 | Name | Description
Public method | GridDataCell()()()() | Initializes a new instance of the GridDataCell class.
Public method | GridDataCell(Element) | Initializes a new instance of the GridDataCell class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Cancel | Performs 'cancel editing' action when in edit mode.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClientSelectCheckBoxClick | Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | DeleteButtonClick | Built-in 'Delete' button click to delete the item. Throws InvalidOperationException if the delete button cannot be located.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditButtonClick | Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandCollapseButtonClick | Expand/collapse button click to expand/collapse the item in Grid hierarchy mode. Throws InvalidOperationException in case of a plain Grid.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Update | Performs 'update item' action when in edit mode.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanDeleteItem | Get whether a built-in 'delete' item button is available in this cell so the parent item can be deleted.
Public property | CanEditItem | Get whether a built-in 'edit' item button is available in this cell so the parent item can be edited.
Public property | CanExpandCollapseItem | Get whether a built-in 'expand/collapse' item button is available in this cell so the parent item can be expanded/colapsed.
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this Grid data cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent data item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the cell is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


GridDataCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell Constructor
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridDataCell()()()() | Initializes a new instance of the GridDataCell class.
Public method | GridDataCell(Element) | Initializes a new instance of the GridDataCell class.

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


GridDataCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell Constructor
GridDataCell Class See Also Send Feedback
Initializes a new instance of the GridDataCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridDataCell()
Visual Basic
Public Sub New
Visual C++
public:
GridDataCell()

See Also

GridDataCell Class
GridDataCell Overload
Telerik.WebAii.Controls.Html Namespace


GridDataCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell Constructor (Element)
GridDataCell Class See Also Send Feedback
Initializes a new instance of the GridDataCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridDataCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridDataCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridDataCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridDataCell Class
GridDataCell Overload
Telerik.WebAii.Controls.Html Namespace


GridDataCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell Methods
GridDataCell Class See Also Send Feedback

The GridDataCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Cancel | Performs 'cancel editing' action when in edit mode.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClientSelectCheckBoxClick | Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | DeleteButtonClick | Built-in 'Delete' button click to delete the item. Throws InvalidOperationException if the delete button cannot be located.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditButtonClick | Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandCollapseButtonClick | Expand/collapse button click to expand/collapse the item in Grid hierarchy mode. Throws InvalidOperationException in case of a plain Grid.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Update | Performs 'update item' action when in edit mode.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..AssignElement Method
GridDataCell Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..CallMethod Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


Cancel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..Cancel Method
GridDataCell Class See Also Send Feedback
Performs 'cancel editing' action when in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..Capture Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..Click Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


ClientSelectCheckBoxClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..ClientSelectCheckBoxClick Method
GridDataCell Class See Also Send Feedback
Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClientSelectCheckBoxClick()
Visual Basic
Public Sub ClientSelectCheckBoxClick
Visual C++
public:
void ClientSelectCheckBoxClick()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..ControlAssert Method
GridDataCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


DeleteButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..DeleteButtonClick Method
GridDataCell Class See Also Send Feedback
Built-in 'Delete' button click to delete the item. Throws InvalidOperationException if the delete button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DeleteButtonClick()
Visual Basic
Public Sub DeleteButtonClick
Visual C++
public:
void DeleteButtonClick()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..DragTo Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


EditButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..EditButtonClick Method
GridDataCell Class See Also Send Feedback
Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void EditButtonClick()
Visual Basic
Public Sub EditButtonClick
Visual C++
public:
void EditButtonClick()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


ExpandCollapseButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..ExpandCollapseButtonClick Method
GridDataCell Class See Also Send Feedback
Expand/collapse button click to expand/collapse the item in Grid hierarchy mode. Throws InvalidOperationException in case of a plain Grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ExpandCollapseButtonClick()
Visual Basic
Public Sub ExpandCollapseButtonClick
Visual C++
public:
void ExpandCollapseButtonClick()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..GetValue Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..InvokeEvent Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..MouseClick Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..MouseHover Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..ScrollToVisible Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..SetValue Method
GridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridDataCell Class
GridDataCell Members
Telerik.WebAii.Controls.Html Namespace


Update Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell..::..Update Method
GridDataCell Class See Also Send Feedback
Performs 'update item' action when in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
Visual C++
public:
void Update()

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


GridDataCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataCell Properties
GridDataCell Class See Also Send Feedback

The GridDataCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanDeleteItem | Get whether a built-in 'delete' item button is available in this cell so the parent item can be deleted.
Public property | CanEditItem | Get whether a built-in 'edit' item button is available in this cell so the parent item can be edited.
Public property | CanExpandCollapseItem | Get whether a built-in 'expand/collapse' item button is available in this cell so the parent item can be expanded/colapsed.
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this Grid data cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent data item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the cell is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridDataCell Class
Telerik.WebAii.Controls.Html Namespace


GridDataItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem Members
GridDataItem Class Constructors Methods Properties See Also Send Feedback

The GridDataItem type exposes the following members.

Constructors

 | Name | Description
Public method | GridDataItem()()()() | Initializes a new instance of the GridDataItem class.
Public method | GridDataItem(Element) | Initializes a new instance of the GridDataItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapses the current item in case of hierarchy and the item is expanded. Throws InvalidOperationException otherwise.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the current item in case of hierarchy and the item is collapsed. Throws InvalidOperationException otherwise.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
 | GetRowIndex | Gets the row index of a row.
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanDelete | Get whether the item can be deleted, e.g. whether the Grid parent table contains built-in delete column.
Public property | CanEdit | Get whether the item can be edited, e.g. whether the Grid parent table contains built-in edit column.
Public property | CanExpand | Get whether the item can be expanded, e.g. whether the Grid is in hierarchy mode.
Public property | CanSelect | Get whether the item can be selected, e.g. whether the Grid has ClientSettings.Selecting.AllowRowSelect set to 'true'.
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the control client-side locator, determining which base script initializes the data item object on the client. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DataCells | Get the list of item's data cells direct children (note the RadGrid hierarchy mode).
Public property | Edited | Get whether this item has edit form opened.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Get whether the data item is expanded so that a detail table is displayed. Use this property when 'CanExpand' returns 'true'.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsInEditMode | Get whether the item is in edit mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | ItemId | The data item Id client-side value.
Public property | ItemIndex | The data item index.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the data item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


GridDataItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem Constructor
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridDataItem()()()() | Initializes a new instance of the GridDataItem class.
Public method | GridDataItem(Element) | Initializes a new instance of the GridDataItem class.

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


GridDataItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem Constructor
GridDataItem Class See Also Send Feedback
Initializes a new instance of the GridDataItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridDataItem()
Visual Basic
Public Sub New
Visual C++
public:
GridDataItem()

See Also

GridDataItem Class
GridDataItem Overload
Telerik.WebAii.Controls.Html Namespace


GridDataItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem Constructor (Element)
GridDataItem Class See Also Send Feedback
Initializes a new instance of the GridDataItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridDataItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridDataItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridDataItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridDataItem Class
GridDataItem Overload
Telerik.WebAii.Controls.Html Namespace


GridDataItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem Methods
GridDataItem Class See Also Send Feedback

The GridDataItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapses the current item in case of hierarchy and the item is expanded. Throws InvalidOperationException otherwise.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the current item in case of hierarchy and the item is collapsed. Throws InvalidOperationException otherwise.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
 | GetRowIndex | Gets the row index of a row.
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..AssignElement Method
GridDataItem Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..CallMethod Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..Capture Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..Click Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..Collapse Method
GridDataItem Class See Also Send Feedback
Collapses the current item in case of hierarchy and the item is expanded. Throws InvalidOperationException otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..ControlAssert Method
GridDataItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..DragTo Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..Expand Method
GridDataItem Class See Also Send Feedback
Expands the current item in case of hierarchy and the item is collapsed. Throws InvalidOperationException otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


GetRowIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..GetRowIndex Method
GridDataItem Class See Also Send Feedback
Gets the row index of a row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static int GetRowIndex(
    string id
)
Visual Basic
Public Shared Function GetRowIndex ( _
    id As String _
) As Integer
Visual C++
public:
static int GetRowIndex(
    String^ id
)

Parameters

id
Type: System..::..String
The Id of the row.

Return Value

The index of the row.

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..GetValue Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..InvokeEvent Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..MouseClick Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..MouseHover Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..ScrollToVisible Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem..::..SetValue Method
GridDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridDataItem Class
GridDataItem Members
Telerik.WebAii.Controls.Html Namespace


GridDataItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridDataItem Properties
GridDataItem Class See Also Send Feedback

The GridDataItem type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanDelete | Get whether the item can be deleted, e.g. whether the Grid parent table contains built-in delete column.
Public property | CanEdit | Get whether the item can be edited, e.g. whether the Grid parent table contains built-in edit column.
Public property | CanExpand | Get whether the item can be expanded, e.g. whether the Grid is in hierarchy mode.
Public property | CanSelect | Get whether the item can be selected, e.g. whether the Grid has ClientSettings.Selecting.AllowRowSelect set to 'true'.
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the control client-side locator, determining which base script initializes the data item object on the client. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DataCells | Get the list of item's data cells direct children (note the RadGrid hierarchy mode).
Public property | Edited | Get whether this item has edit form opened.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Get whether the data item is expanded so that a detail table is displayed. Use this property when 'CanExpand' returns 'true'.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsInEditMode | Get whether the item is in edit mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | ItemId | The data item Id client-side value.
Public property | ItemIndex | The data item index.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the data item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridDataItem Class
Telerik.WebAii.Controls.Html Namespace


GridEditForm Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm Members
GridEditForm Class Constructors Methods Properties See Also Send Feedback

The GridEditForm type exposes the following members.

Constructors

 | Name | Description
Public method | GridEditForm()()()() | Initializes a new instance of the GridEditForm class.
Public method | GridEditForm(Element) | Initializes a new instance of the GridEditForm class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Cancel | Performs 'cancel editing/inserting' action for the edit form.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | Insert | Performs 'insert item' action for the edit form.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Update | Performs 'update item' action for the edit form.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


GridEditForm Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm Constructor
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridEditForm()()()() | Initializes a new instance of the GridEditForm class.
Public method | GridEditForm(Element) | Initializes a new instance of the GridEditForm class.

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


GridEditForm Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm Constructor
GridEditForm Class See Also Send Feedback
Initializes a new instance of the GridEditForm class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridEditForm()
Visual Basic
Public Sub New
Visual C++
public:
GridEditForm()

See Also

GridEditForm Class
GridEditForm Overload
Telerik.WebAii.Controls.Html Namespace


GridEditForm Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm Constructor (Element)
GridEditForm Class See Also Send Feedback
Initializes a new instance of the GridEditForm class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridEditForm(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridEditForm(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridEditForm.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridEditForm Class
GridEditForm Overload
Telerik.WebAii.Controls.Html Namespace


GridEditForm Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm Methods
GridEditForm Class See Also Send Feedback

The GridEditForm type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Cancel | Performs 'cancel editing/inserting' action for the edit form.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | Insert | Performs 'insert item' action for the edit form.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Update | Performs 'update item' action for the edit form.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..AssignElement Method
GridEditForm Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..CallMethod Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


Cancel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..Cancel Method
GridEditForm Class See Also Send Feedback
Performs 'cancel editing/inserting' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..Capture Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..Click Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..DragTo Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..GetValue Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


Insert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..Insert Method
GridEditForm Class See Also Send Feedback
Performs 'insert item' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Insert()
Visual Basic
Public Sub Insert
Visual C++
public:
void Insert()

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..InvokeEvent Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..MouseClick Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..MouseHover Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..ScrollToVisible Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..SetValue Method
GridEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridEditForm Class
GridEditForm Members
Telerik.WebAii.Controls.Html Namespace


Update Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm..::..Update Method
GridEditForm Class See Also Send Feedback
Performs 'update item' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
Visual C++
public:
void Update()

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


GridEditForm Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridEditForm Properties
GridEditForm Class See Also Send Feedback

The GridEditForm type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridEditForm Class
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem Members
GridFilterItem Class Constructors Methods Properties See Also Send Feedback

The GridFilterItem type exposes the following members.

Constructors

 | Name | Description
Public method | GridFilterItem()()()() | Initializes a new instance of the GridFilterItem class.
Public method | GridFilterItem(Element) | Initializes a new instance of the GridFilterItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FilterMenuPopup | Click to popup the column filter menu.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem Constructor
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridFilterItem()()()() | Initializes a new instance of the GridFilterItem class.
Public method | GridFilterItem(Element) | Initializes a new instance of the GridFilterItem class.

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem Constructor
GridFilterItem Class See Also Send Feedback
Initializes a new instance of the GridFilterItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridFilterItem()
Visual Basic
Public Sub New
Visual C++
public:
GridFilterItem()

See Also

GridFilterItem Class
GridFilterItem Overload
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem Constructor (Element)
GridFilterItem Class See Also Send Feedback
Initializes a new instance of the GridFilterItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridFilterItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridFilterItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridFilterItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridFilterItem Class
GridFilterItem Overload
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem Methods
GridFilterItem Class See Also Send Feedback

The GridFilterItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FilterMenuPopup | Click to popup the column filter menu.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..AssignElement Method
GridFilterItem Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..CallMethod Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..Capture Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..Click Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..DragTo Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


FilterMenuPopup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..FilterMenuPopup Method
GridFilterItem Class See Also Send Feedback
Click to popup the column filter menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FilterMenuPopup(
    string columnName
)
Visual Basic
Public Sub FilterMenuPopup ( _
    columnName As String _
)
Visual C++
public:
void FilterMenuPopup(
    String^ columnName
)

Parameters

columnName
Type: System..::..String

[Missing <param name="columnName"/> documentation for "M:Telerik.WebAii.Controls.Html.GridFilterItem.FilterMenuPopup(System.String)"]

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..GetValue Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..InvokeEvent Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..MouseClick Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..MouseHover Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..ScrollToVisible Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem..::..SetValue Method
GridFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridFilterItem Class
GridFilterItem Members
Telerik.WebAii.Controls.Html Namespace


GridFilterItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFilterItem Properties
GridFilterItem Class See Also Send Feedback

The GridFilterItem type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridFilterItem Class
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell Members
GridFooterCell Class Constructors Methods Properties See Also Send Feedback

The GridFooterCell type exposes the following members.

Constructors

 | Name | Description
Public method | GridFooterCell()()()() | Initializes a new instance of the GridFooterCell class.
Public method | GridFooterCell(Element) | Initializes a new instance of the GridFooterCell class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this Grid footer cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell Constructor
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridFooterCell()()()() | Initializes a new instance of the GridFooterCell class.
Public method | GridFooterCell(Element) | Initializes a new instance of the GridFooterCell class.

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell Constructor
GridFooterCell Class See Also Send Feedback
Initializes a new instance of the GridFooterCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridFooterCell()
Visual Basic
Public Sub New
Visual C++
public:
GridFooterCell()

See Also

GridFooterCell Class
GridFooterCell Overload
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell Constructor (Element)
GridFooterCell Class See Also Send Feedback
Initializes a new instance of the GridFooterCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridFooterCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridFooterCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridFooterCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridFooterCell Class
GridFooterCell Overload
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell Methods
GridFooterCell Class See Also Send Feedback

The GridFooterCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..AssignElement Method
GridFooterCell Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..CallMethod Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..Capture Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..Click Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..ControlAssert Method
GridFooterCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..DragTo Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..GetValue Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..InvokeEvent Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..MouseClick Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..MouseHover Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..ScrollToVisible Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell..::..SetValue Method
GridFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridFooterCell Class
GridFooterCell Members
Telerik.WebAii.Controls.Html Namespace


GridFooterCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridFooterCell Properties
GridFooterCell Class See Also Send Feedback

The GridFooterCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this Grid footer cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridFooterCell Class
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader Members
GridGroupHeader Class Constructors Methods Properties See Also Send Feedback

The GridGroupHeader type exposes the following members.

Constructors

 | Name | Description
Public method | GridGroupHeader()()()() | Initializes a new instance of the GridGroupHeader class.
Public method | GridGroupHeader(Element) | Initializes a new instance of the GridGroupHeader class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Initiates a 'collapse' action if this group is expanded.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Initiates an 'expand' action if this group is collapsed.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Get whether the group is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupDataItemCount | Get the number of data items for the current group.
Public property | HeaderText | The header text of the group.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the LocatorExpression HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader Constructor
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridGroupHeader()()()() | Initializes a new instance of the GridGroupHeader class.
Public method | GridGroupHeader(Element) | Initializes a new instance of the GridGroupHeader class.

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader Constructor
GridGroupHeader Class See Also Send Feedback
Initializes a new instance of the GridGroupHeader class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridGroupHeader()
Visual Basic
Public Sub New
Visual C++
public:
GridGroupHeader()

See Also

GridGroupHeader Class
GridGroupHeader Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader Constructor (Element)
GridGroupHeader Class See Also Send Feedback
Initializes a new instance of the GridGroupHeader class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridGroupHeader(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridGroupHeader(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridGroupHeader.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridGroupHeader Class
GridGroupHeader Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader Methods
GridGroupHeader Class See Also Send Feedback

The GridGroupHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Initiates a 'collapse' action if this group is expanded.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Initiates an 'expand' action if this group is collapsed.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..AssignElement Method
GridGroupHeader Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..CallMethod Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..Capture Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..Click Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..Collapse Method
GridGroupHeader Class See Also Send Feedback
Initiates a 'collapse' action if this group is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..ControlAssert Method
GridGroupHeader Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..DragTo Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..Expand Method
GridGroupHeader Class See Also Send Feedback
Initiates an 'expand' action if this group is collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..GetValue Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..InvokeEvent Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..MouseClick Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..MouseHover Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..ScrollToVisible Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader..::..SetValue Method
GridGroupHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
GridGroupHeader Members
Telerik.WebAii.Controls.Html Namespace


GridGroupHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupHeader Properties
GridGroupHeader Class See Also Send Feedback

The GridGroupHeader type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Get whether the group is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupDataItemCount | Get the number of data items for the current group.
Public property | HeaderText | The header text of the group.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the LocatorExpression HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupHeader Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel Members
GridGroupPanel Class Constructors Methods Properties See Also Send Feedback

The GridGroupPanel type exposes the following members.

Constructors

 | Name | Description
Public method | GridGroupPanel()()()() | Initializes a new instance of the GridGroupPanel class.
Public method | GridGroupPanel(Element) | Initializes a new instance of the GridGroupPanel class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToUngroup | Performs DragTo action to ungroup the data by the given field if such group field exists in the group panel. Throws ArgumentException otherwise.
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Sort(Int32) | Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such index does not exist in the group panel.
Public method | Sort(String) | Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such name does not exist in the group panel.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupFieldNames | Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.
Public property | GroupItems | Obsolete. Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Get the list of group panel items.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel Constructor
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridGroupPanel()()()() | Initializes a new instance of the GridGroupPanel class.
Public method | GridGroupPanel(Element) | Initializes a new instance of the GridGroupPanel class.

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel Constructor
GridGroupPanel Class See Also Send Feedback
Initializes a new instance of the GridGroupPanel class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridGroupPanel()
Visual Basic
Public Sub New
Visual C++
public:
GridGroupPanel()

See Also

GridGroupPanel Class
GridGroupPanel Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel Constructor (Element)
GridGroupPanel Class See Also Send Feedback
Initializes a new instance of the GridGroupPanel class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridGroupPanel(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridGroupPanel(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridGroupPanel.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridGroupPanel Class
GridGroupPanel Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel Methods
GridGroupPanel Class See Also Send Feedback

The GridGroupPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToUngroup | Performs DragTo action to ungroup the data by the given field if such group field exists in the group panel. Throws ArgumentException otherwise.
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Sort(Int32) | Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such index does not exist in the group panel.
Public method | Sort(String) | Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such name does not exist in the group panel.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..AssignElement Method
GridGroupPanel Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..CallMethod Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..Capture Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..Click Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..ControlAssert Method
GridGroupPanel Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..DragTo Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


DragToUngroup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..DragToUngroup Method
GridGroupPanel Class See Also Send Feedback
Performs DragTo action to ungroup the data by the given field if such group field exists in the group panel. Throws ArgumentException otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragToUngroup(
    string name
)
Visual Basic
Public Sub DragToUngroup ( _
    name As String _
)
Visual C++
public:
void DragToUngroup(
    String^ name
)

Parameters

name
Type: System..::..String
The group name field to ungroup by.

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..GetValue Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..InvokeEvent Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..MouseClick Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..MouseHover Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..ScrollToVisible Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..SetValue Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


Sort Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..Sort Method
GridGroupPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Sort(Int32) | Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such index does not exist in the group panel.
Public method | Sort(String) | Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such name does not exist in the group panel.

See Also

GridGroupPanel Class
GridGroupPanel Members
Telerik.WebAii.Controls.Html Namespace


Sort Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..Sort Method (Int32)
GridGroupPanel Class See Also Send Feedback
Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such index does not exist in the group panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Sort(
    int index
)
Visual Basic
Public Sub Sort ( _
    index As Integer _
)
Visual C++
public:
void Sort(
    int index
)

Parameters

index
Type: System..::..Int32
The group panel item index.

See Also

GridGroupPanel Class
Sort Overload
Telerik.WebAii.Controls.Html Namespace


Sort Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel..::..Sort Method (String)
GridGroupPanel Class See Also Send Feedback
Sorts the data by a group field in the group panel. Throws ArgumentException if an item with such name does not exist in the group panel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Sort(
    string name
)
Visual Basic
Public Sub Sort ( _
    name As String _
)
Visual C++
public:
void Sort(
    String^ name
)

Parameters

name
Type: System..::..String
The group name field to sort by.

See Also

GridGroupPanel Class
Sort Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanel Properties
GridGroupPanel Class See Also Send Feedback

The GridGroupPanel type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupFieldNames | Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.
Public property | GroupItems | Obsolete. Get the group items of the group panel. The names are separated by comma. Returns empty string if there are no items in the group panel.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Get the list of group panel items.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridGroupPanel Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem Members
GridGroupPanelItem Class Constructors Methods Properties See Also Send Feedback

The GridGroupPanelItem type exposes the following members.

Constructors

 | Name | Description
Public method | GridGroupPanelItem()()()() | Initializes a new instance of the GridGroupPanelItem class.
Public method | GridGroupPanelItem(Element) | Initializes a new instance of the GridGroupPanelItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Sort | Clicks on the sort button.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Ungroup | Clicks on the ungroup button.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | The index of the GroupPanelItem.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Get the field name of the group panel item.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem Constructor
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridGroupPanelItem()()()() | Initializes a new instance of the GridGroupPanelItem class.
Public method | GridGroupPanelItem(Element) | Initializes a new instance of the GridGroupPanelItem class.

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem Constructor
GridGroupPanelItem Class See Also Send Feedback
Initializes a new instance of the GridGroupPanelItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridGroupPanelItem()
Visual Basic
Public Sub New
Visual C++
public:
GridGroupPanelItem()

See Also

GridGroupPanelItem Class
GridGroupPanelItem Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem Constructor (Element)
GridGroupPanelItem Class See Also Send Feedback
Initializes a new instance of the GridGroupPanelItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridGroupPanelItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridGroupPanelItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridGroupPanelItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridGroupPanelItem Class
GridGroupPanelItem Overload
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem Methods
GridGroupPanelItem Class See Also Send Feedback

The GridGroupPanelItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Sort | Clicks on the sort button.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Ungroup | Clicks on the ungroup button.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..AssignElement Method
GridGroupPanelItem Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..CallMethod Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..Capture Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..Click Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..DragTo Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..GetValue Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..InvokeEvent Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..MouseClick Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..MouseHover Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..ScrollToVisible Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..SetValue Method
GridGroupPanelItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridGroupPanelItem Class
GridGroupPanelItem Members
Telerik.WebAii.Controls.Html Namespace


Sort Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..Sort Method
GridGroupPanelItem Class See Also Send Feedback
Clicks on the sort button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort
Visual C++
public:
void Sort()

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


Ungroup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem..::..Ungroup Method
GridGroupPanelItem Class See Also Send Feedback
Clicks on the ungroup button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Ungroup()
Visual Basic
Public Sub Ungroup
Visual C++
public:
void Ungroup()

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


GridGroupPanelItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridGroupPanelItem Properties
GridGroupPanelItem Class See Also Send Feedback

The GridGroupPanelItem type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | The index of the GroupPanelItem.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Get the field name of the group panel item.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridGroupPanelItem Class
Telerik.WebAii.Controls.Html Namespace


GridHelper Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridHelper Members
GridHelper Class Methods See Also Send Feedback

The GridHelper type exposes the following members.

Methods

Name | Description
IsExpandCollapseButton | Returns whether the button element is expand/collapse.

See Also

GridHelper Class
Telerik.WebAii.Controls.Html Namespace


GridHelper Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridHelper Methods
GridHelper Class See Also Send Feedback

The GridHelper type exposes the following members.

Methods

Name | Description
IsExpandCollapseButton | Returns whether the button element is expand/collapse.

See Also

GridHelper Class
Telerik.WebAii.Controls.Html Namespace


IsExpandCollapseButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridHelper..::..IsExpandCollapseButton Method
GridHelper Class See Also Send Feedback
Returns whether the button element is expand/collapse.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static bool IsExpandCollapseButton(
    Element element,
    out GridGroupExpandCollapseActionType actionType
)
Visual Basic
Public Shared Function IsExpandCollapseButton ( _
    element As Element, _
    <OutAttribute> ByRef actionType As GridGroupExpandCollapseActionType _
) As Boolean
Visual C++
public:
static bool IsExpandCollapseButton(
    Element^ element,
    [OutAttribute] GridGroupExpandCollapseActionType% actionType
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The current element.
actionType
Type: Telerik.WebAii.Controls.Html..::..GridGroupExpandCollapseActionType %
The Grid expand/collapse action type.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.GridHelper.IsExpandCollapseButton(ArtOfTest.WebAii.ObjectModel.Element,Telerik.WebAii.Controls.Html.GridGroupExpandCollapseActionType@)"]

See Also

GridHelper Class
Telerik.WebAii.Controls.Html Namespace


GridPager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager Members
GridPager Class Constructors Methods Properties See Also Send Feedback

The GridPager type exposes the following members.

Constructors

 | Name | Description
Public method | GridPager()()()() | Initializes a new instance of the GridPager class.
Public method | GridPager(Element) | Initializes a new instance of the GridPager class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangePageSize | The Advanced Pager 'ChangePageSize' action.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GoToPage | The Advanced Pager 'GoToPage' action.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LoadFirstPage | Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.
Public method | LoadLastPage | Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.
Public method | LoadNextPage | Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.
Public method | LoadNextPages | Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.
Public method | LoadPage | Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.
Public method | LoadPreviousPage | Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.
Public method | LoadPreviousPages | Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | The current page index of the loaded page in the table.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InfoText | Get the pager info text when available, returns null otherwise.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Mode | Get the pager mode.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PageCount | The page count of the table.
Public property | PageSize | The page size of the table.
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


GridPager Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager Constructor
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridPager()()()() | Initializes a new instance of the GridPager class.
Public method | GridPager(Element) | Initializes a new instance of the GridPager class.

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


GridPager Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager Constructor
GridPager Class See Also Send Feedback
Initializes a new instance of the GridPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridPager()
Visual Basic
Public Sub New
Visual C++
public:
GridPager()

See Also

GridPager Class
GridPager Overload
Telerik.WebAii.Controls.Html Namespace


GridPager Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager Constructor (Element)
GridPager Class See Also Send Feedback
Initializes a new instance of the GridPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridPager(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridPager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridPager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridPager Class
GridPager Overload
Telerik.WebAii.Controls.Html Namespace


GridPager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager Methods
GridPager Class See Also Send Feedback

The GridPager type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangePageSize | The Advanced Pager 'ChangePageSize' action.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GoToPage | The Advanced Pager 'GoToPage' action.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LoadFirstPage | Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.
Public method | LoadLastPage | Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.
Public method | LoadNextPage | Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.
Public method | LoadNextPages | Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.
Public method | LoadPage | Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.
Public method | LoadPreviousPage | Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.
Public method | LoadPreviousPages | Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..AssignElement Method
GridPager Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..CallMethod Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..Capture Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


ChangePageSize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..ChangePageSize Method
GridPager Class See Also Send Feedback
The Advanced Pager 'ChangePageSize' action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ChangePageSize()
Visual Basic
Public Sub ChangePageSize
Visual C++
public:
void ChangePageSize()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..Click Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..ControlAssert Method
GridPager Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..DragTo Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..GetValue Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


GoToPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..GoToPage Method
GridPager Class See Also Send Feedback
The Advanced Pager 'GoToPage' action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void GoToPage()
Visual Basic
Public Sub GoToPage
Visual C++
public:
void GoToPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..InvokeEvent Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


LoadFirstPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..LoadFirstPage Method
GridPager Class See Also Send Feedback
Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadFirstPage()
Visual Basic
Public Sub LoadFirstPage
Visual C++
public:
void LoadFirstPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadLastPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..LoadLastPage Method
GridPager Class See Also Send Feedback
Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadLastPage()
Visual Basic
Public Sub LoadLastPage
Visual C++
public:
void LoadLastPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadNextPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..LoadNextPage Method
GridPager Class See Also Send Feedback
Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadNextPage()
Visual Basic
Public Sub LoadNextPage
Visual C++
public:
void LoadNextPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadNextPages Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..LoadNextPages Method
GridPager Class See Also Send Feedback
Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadNextPages()
Visual Basic
Public Sub LoadNextPages
Visual C++
public:
void LoadNextPages()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..LoadPage Method
GridPager Class See Also Send Feedback
Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPage(
    int pageNumber
)
Visual Basic
Public Sub LoadPage ( _
    pageNumber As Integer _
)
Visual C++
public:
void LoadPage(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
The number of the page to be loaded.

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPreviousPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..LoadPreviousPage Method
GridPager Class See Also Send Feedback
Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPreviousPage()
Visual Basic
Public Sub LoadPreviousPage
Visual C++
public:
void LoadPreviousPage()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPreviousPages Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..LoadPreviousPages Method
GridPager Class See Also Send Feedback
Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPreviousPages()
Visual Basic
Public Sub LoadPreviousPages
Visual C++
public:
void LoadPreviousPages()

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..MouseClick Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..MouseHover Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..ScrollToVisible Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager..::..SetValue Method
GridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridPager Class
GridPager Members
Telerik.WebAii.Controls.Html Namespace


GridPager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridPager Properties
GridPager Class See Also Send Feedback

The GridPager type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | The current page index of the loaded page in the table.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InfoText | Get the pager info text when available, returns null otherwise.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Mode | Get the pager mode.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PageCount | The page count of the table.
Public property | PageSize | The page size of the table.
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

GridPager Class
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader Members
GridTableHeader Class Constructors Methods Properties See Also Send Feedback

The GridTableHeader type exposes the following members.

Constructors

 | Name | Description
Public method | GridTableHeader()()()() | Initializes a new instance of the GridTableHeader class.
Public method | GridTableHeader(Element) | Initializes a new instance of the GridTableHeader class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClientSelectCheckBoxClick | Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToGroup | Drag the current header cell/column into the RadGrid Grouping Panel to group the data by the corresponging field.
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Reorder(String) | Simulates drag and drop of the current table header to reorder it with the target one.
Public method | Reorder(HtmlControl) | Simulates drag and drop of the current table header to reorder it with the target one.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowContextMenu | Shows the header context menu.
Public method | Sort | Initiates a 'sort' action of the column.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the TableHeader control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | ColumnIndex | The index of the column.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupName | The group name of this column when multi column headers are enabeld.
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MultiHeadersEnabled | Gets whether the multi column headers are enabled
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Reorderable | Get whether the column is reorderable.
Public property | Resizable | Get whether the columns is resizable.
Public property | RowIndex | Gets the row index
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the column is selected.
Public property | SortOrder | The sort order of this column.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TableID | Gets the parent table ID.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UniqueName | The unique name of this column.
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Visible | Get whether the column is visible on the client.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader Constructor
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridTableHeader()()()() | Initializes a new instance of the GridTableHeader class.
Public method | GridTableHeader(Element) | Initializes a new instance of the GridTableHeader class.

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader Constructor
GridTableHeader Class See Also Send Feedback
Initializes a new instance of the GridTableHeader class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridTableHeader()
Visual Basic
Public Sub New
Visual C++
public:
GridTableHeader()

See Also

GridTableHeader Class
GridTableHeader Overload
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader Constructor (Element)
GridTableHeader Class See Also Send Feedback
Initializes a new instance of the GridTableHeader class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridTableHeader(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridTableHeader(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridTableHeader.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridTableHeader Class
GridTableHeader Overload
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader Methods
GridTableHeader Class See Also Send Feedback

The GridTableHeader type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClientSelectCheckBoxClick | Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToGroup | Drag the current header cell/column into the RadGrid Grouping Panel to group the data by the corresponging field.
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Reorder(String) | Simulates drag and drop of the current table header to reorder it with the target one.
Public method | Reorder(HtmlControl) | Simulates drag and drop of the current table header to reorder it with the target one.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowContextMenu | Shows the header context menu.
Public method | Sort | Initiates a 'sort' action of the column.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..AssignElement Method
GridTableHeader Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..CallMethod Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..Capture Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..Click Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


ClientSelectCheckBoxClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..ClientSelectCheckBoxClick Method
GridTableHeader Class See Also Send Feedback
Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClientSelectCheckBoxClick()
Visual Basic
Public Sub ClientSelectCheckBoxClick
Visual C++
public:
void ClientSelectCheckBoxClick()

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..ControlAssert Method
GridTableHeader Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..DragTo Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


DragToGroup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..DragToGroup Method
GridTableHeader Class See Also Send Feedback
Drag the current header cell/column into the RadGrid Grouping Panel to group the data by the corresponging field.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragToGroup()
Visual Basic
Public Sub DragToGroup
Visual C++
public:
void DragToGroup()

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..GetValue Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..InvokeEvent Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..MouseClick Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..MouseHover Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


Reorder Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..Reorder Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reorder(String) | Simulates drag and drop of the current table header to reorder it with the target one.
Public method | Reorder(HtmlControl) | Simulates drag and drop of the current table header to reorder it with the target one.

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


Reorder Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..Reorder Method (String)
GridTableHeader Class See Also Send Feedback
Simulates drag and drop of the current table header to reorder it with the target one.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Reorder(
    string headerName
)
Visual Basic
Public Sub Reorder ( _
    headerName As String _
)
Visual C++
public:
void Reorder(
    String^ headerName
)

Parameters

headerName
Type: System..::..String
The name of the target table header to reorder with.

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown in case of invalid column unique name.

See Also

GridTableHeader Class
Reorder Overload
Telerik.WebAii.Controls.Html Namespace


Reorder Method (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..Reorder Method (HtmlControl)
GridTableHeader Class See Also Send Feedback
Simulates drag and drop of the current table header to reorder it with the target one.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Reorder(
    HtmlControl targetHeader
)
Visual Basic
Public Sub Reorder ( _
    targetHeader As HtmlControl _
)
Visual C++
public:
void Reorder(
    HtmlControl^ targetHeader
)

Parameters

targetHeader
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The target table header to reorder with.

Remarks

The column reordering in RadGrid may interfere with the column resizing feature. This method might not be working if the column resizing is enabled as well.

See Also

GridTableHeader Class
Reorder Overload
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..ScrollToVisible Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..SetValue Method
GridTableHeader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridTableHeader Class
GridTableHeader Members
Telerik.WebAii.Controls.Html Namespace


ShowContextMenu Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..ShowContextMenu Method
GridTableHeader Class See Also Send Feedback
Shows the header context menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowContextMenu()
Visual Basic
Public Sub ShowContextMenu
Visual C++
public:
void ShowContextMenu()

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


Sort Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader..::..Sort Method
GridTableHeader Class See Also Send Feedback
Initiates a 'sort' action of the column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort
Visual C++
public:
void Sort()

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


GridTableHeader Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableHeader Properties
GridTableHeader Class See Also Send Feedback

The GridTableHeader type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the TableHeader control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | ColumnIndex | The index of the column.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupName | The group name of this column when multi column headers are enabeld.
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MultiHeadersEnabled | Gets whether the multi column headers are enabled
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Reorderable | Get whether the column is reorderable.
Public property | Resizable | Get whether the columns is resizable.
Public property | RowIndex | Gets the row index
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the column is selected.
Public property | SortOrder | The sort order of this column.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TableID | Gets the parent table ID.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UniqueName | The unique name of this column.
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Visible | Get whether the column is visible on the client.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

GridTableHeader Class
Telerik.WebAii.Controls.Html Namespace


GridTableView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView Members
GridTableView Class Constructors Methods Properties See Also Send Feedback

The GridTableView type exposes the following members.

Constructors

 | Name | Description
Public method | GridTableView()()()() | Initializes a new instance of the GridTableView class.
Public method | GridTableView(Element) | Initializes a new instance of the GridTableView class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTable..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | CancelAll | Initiates "cancel" action for all the table items in edit mode.
Public method | CancelInsert | Initiates "cancel" action for the table insert item.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ClearSelectedItems | Clears the selection of all items.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CommandItemAction | Initiates a default command item template action -- either 'AddNew' or 'Refresh'.
Public method | ControlAssert | Returns RadControlAssert instance initialize for this control.
Public method | DeleteSelectedItems | Deletes all the selected items on the client.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragDrop | Performs DragDrop of a Grid Item (draggedItemIndex) to another (targetItemIndex).
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToSelect | Performs DragTo from the DataItem with 'start' index to the one with 'end' index selecting the items.
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditAllItems | Initiates "edit" action for all the table items.
Public method | EditSelectedItems | Initiates "edit" action for all the selected items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCells | Get the list of the cells matching the given predicate.
Public method | FindItems | Get the list of the data items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetColumns | Get the columns of the Grid.
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HideFilterItem | Hides the filtering item.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InsertItem | Initiates an "insert item" action client-side.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollDown()()()() | Scroll down in the Grid table using the mouse wheel.
Public method | ScrollDown(Int32) | Scroll down in the Grid table using the mouse wheel.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | ScrollUp()()()() | Scroll up in the Grid table using the mouse wheel.
Public method | ScrollUp(Int32) | Scroll up in the Grid table using the mouse wheel.
Public method | SelectAllItems | Selects all the table items.
Public method | SelectItem | Select an item in the grid.
Public method | SelectItems | Select a set of items in the grid.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowFilterItem | Shows the filter item on the client.
Public method | ShowInsertItem | Shows the insert item client-side.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UpdateEditedItems | Initiates an "update" action for all the table items in edit mode.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertTable()()()() | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)
Public Extension Method | AssertTable(Boolean) | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)

Properties

 | Name | Description
Public property | AllowMultiColumnSorting | Get whether the mult-column sorting is enabled.
Public property | AllowRowSelection | Get whether the row selection is enabled.
Public property | AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows) (Inherited from HtmlTable.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag. (Inherited from HtmlTable.)
Public property | Border | Gets the width of the table border. (Inherited from HtmlTable.)
Public property | CanInsertItem | Get whether the standard table command item is enabled either in the header or the footer.
Public property | Caption | Gets the caption of a table. (Inherited from HtmlTable.)
Public property | CellPadding | Gets the amount of space between the cell border and cell content (Inherited from HtmlTable.)
Public property | CellSpacing | Gets the amount of space between the cells in a table. (Inherited from HtmlTable.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the table HTML control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColumnCount | Gets the number of columns in this table (Inherited from HtmlTable.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | The current page index of the loaded page in this table.
Public property | DataItems | Get the list of the children data items of this table.
Public property | EditedIndexes | Collection containing the indexes of the items in edit mode.
Public property | EditedItems | Get the list of items that are in edit mode.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | ExpandedIndexes | Collection containting the indexes of the expanded items for the current TableView.
Public property | ExpandedItems | The list of expanded items for the current TableView.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag. (Inherited from HtmlTable.)
Public property | Groups | Get the list of the groups for this table.
Public property | HasMultiColumnHeaders | Gets whether multi Column Headers are enabled
Public property | HeadRows | Gets the rows contained in the table header if the table is using the thead tag. (Inherited from HtmlTable.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFilterItemVisible | Get whether the filtering is enabled for the table.
Public property | IsItemInserted | Get whether the insert mode form is opened in this table.
Public property | isMultiHeadersAreImplemented | Gets whether multi Column Headers are implemented
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Gets requested row by index. (Inherited from HtmlTable.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | The name of the TableView.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PageCount | The page count of this table.
Public property | PageSize | The page size of the table.
Public property | Rows | Return List of HtmlTableRows. Only the body rows if TBody is used. (Inherited from HtmlTable.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedCells | Get the list of selected cells.
Public property | SelectedItems | Get the list of selected items.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VirtualItemCount | Get the virtual item count of the table.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table. (Inherited from HtmlTable.)

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


GridTableView Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView Constructor
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GridTableView()()()() | Initializes a new instance of the GridTableView class.
Public method | GridTableView(Element) | Initializes a new instance of the GridTableView class.

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


GridTableView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView Constructor
GridTableView Class See Also Send Feedback
Initializes a new instance of the GridTableView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridTableView()
Visual Basic
Public Sub New
Visual C++
public:
GridTableView()

See Also

GridTableView Class
GridTableView Overload
Telerik.WebAii.Controls.Html Namespace


GridTableView Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView Constructor (Element)
GridTableView Class See Also Send Feedback
Initializes a new instance of the GridTableView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridTableView(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
GridTableView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.GridTableView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

GridTableView Class
GridTableView Overload
Telerik.WebAii.Controls.Html Namespace


GridTableView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView Methods
GridTableView Class See Also Send Feedback

The GridTableView type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTable..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | CancelAll | Initiates "cancel" action for all the table items in edit mode.
Public method | CancelInsert | Initiates "cancel" action for the table insert item.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ClearSelectedItems | Clears the selection of all items.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CommandItemAction | Initiates a default command item template action -- either 'AddNew' or 'Refresh'.
Public method | ControlAssert | Returns RadControlAssert instance initialize for this control.
Public method | DeleteSelectedItems | Deletes all the selected items on the client.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragDrop | Performs DragDrop of a Grid Item (draggedItemIndex) to another (targetItemIndex).
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToSelect | Performs DragTo from the DataItem with 'start' index to the one with 'end' index selecting the items.
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditAllItems | Initiates "edit" action for all the table items.
Public method | EditSelectedItems | Initiates "edit" action for all the selected items.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCells | Get the list of the cells matching the given predicate.
Public method | FindItems | Get the list of the data items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetColumns | Get the columns of the Grid.
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HideFilterItem | Hides the filtering item.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InsertItem | Initiates an "insert item" action client-side.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollDown()()()() | Scroll down in the Grid table using the mouse wheel.
Public method | ScrollDown(Int32) | Scroll down in the Grid table using the mouse wheel.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | ScrollUp()()()() | Scroll up in the Grid table using the mouse wheel.
Public method | ScrollUp(Int32) | Scroll up in the Grid table using the mouse wheel.
Public method | SelectAllItems | Selects all the table items.
Public method | SelectItem | Select an item in the grid.
Public method | SelectItems | Select a set of items in the grid.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowFilterItem | Shows the filter item on the client.
Public method | ShowInsertItem | Shows the insert item client-side.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UpdateEditedItems | Initiates an "update" action for all the table items in edit mode.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertTable()()()() | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)
Public Extension Method | AssertTable(Boolean) | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..AssignElement Method
GridTableView Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..CallMethod Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


CancelAll Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..CancelAll Method
GridTableView Class See Also Send Feedback
Initiates "cancel" action for all the table items in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CancelAll()
Visual Basic
Public Sub CancelAll
Visual C++
public:
void CancelAll()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


CancelInsert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..CancelInsert Method
GridTableView Class See Also Send Feedback
Initiates "cancel" action for the table insert item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CancelInsert()
Visual Basic
Public Sub CancelInsert
Visual C++
public:
void CancelInsert()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..Capture Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ClearSelectedItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ClearSelectedItems Method
GridTableView Class See Also Send Feedback
Clears the selection of all items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClearSelectedItems()
Visual Basic
Public Sub ClearSelectedItems
Visual C++
public:
void ClearSelectedItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..Click Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


CommandItemAction Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..CommandItemAction Method
GridTableView Class See Also Send Feedback
Initiates a default command item template action -- either 'AddNew' or 'Refresh'.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CommandItemAction(
    GridCommandItemType commandItemType,
    GridCommandItemLocation location
)
Visual Basic
Public Sub CommandItemAction ( _
    commandItemType As GridCommandItemType, _
    location As GridCommandItemLocation _
)
Visual C++
public:
void CommandItemAction(
    GridCommandItemType commandItemType,
    GridCommandItemLocation location
)

Parameters

commandItemType
Type: Telerik.WebAii.Controls.Html..::..GridCommandItemType
The command item type.
location
Type: Telerik.WebAii.Controls.Html..::..GridCommandItemLocation
The position of the CommandItem in the Grid.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ControlAssert Method
GridTableView Class See Also Send Feedback
Returns RadControlAssert instance initialize for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialize for this control.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


DeleteSelectedItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..DeleteSelectedItems Method
GridTableView Class See Also Send Feedback
Deletes all the selected items on the client.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DeleteSelectedItems()
Visual Basic
Public Sub DeleteSelectedItems
Visual C++
public:
void DeleteSelectedItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


DragDrop Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..DragDrop Method
GridTableView Class See Also Send Feedback
Performs DragDrop of a Grid Item (draggedItemIndex) to another (targetItemIndex).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragDrop(
    int draggedItemIndex,
    int targetItemIndex
)
Visual Basic
Public Sub DragDrop ( _
    draggedItemIndex As Integer, _
    targetItemIndex As Integer _
)
Visual C++
public:
void DragDrop(
    int draggedItemIndex,
    int targetItemIndex
)

Parameters

draggedItemIndex
Type: System..::..Int32

[Missing <param name="draggedItemIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.GridTableView.DragDrop(System.Int32,System.Int32)"]

targetItemIndex
Type: System..::..Int32

[Missing <param name="targetItemIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.GridTableView.DragDrop(System.Int32,System.Int32)"]

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..DragTo Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


DragToSelect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..DragToSelect Method
GridTableView Class See Also Send Feedback
Performs DragTo from the DataItem with 'start' index to the one with 'end' index selecting the items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragToSelect(
    int startIndex,
    int endIndex
)
Visual Basic
Public Sub DragToSelect ( _
    startIndex As Integer, _
    endIndex As Integer _
)
Visual C++
public:
void DragToSelect(
    int startIndex,
    int endIndex
)

Parameters

startIndex
Type: System..::..Int32
The index of the data item to start dragging from.
endIndex
Type: System..::..Int32
The index of the data item to end drag-to-select.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


EditAllItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..EditAllItems Method
GridTableView Class See Also Send Feedback
Initiates "edit" action for all the table items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void EditAllItems()
Visual Basic
Public Sub EditAllItems
Visual C++
public:
void EditAllItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


EditSelectedItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..EditSelectedItems Method
GridTableView Class See Also Send Feedback
Initiates "edit" action for all the selected items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void EditSelectedItems()
Visual Basic
Public Sub EditSelectedItems
Visual C++
public:
void EditSelectedItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


FindCells Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..FindCells Method
GridTableView Class See Also Send Feedback
Get the list of the cells matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<GridDataCell> FindCells(
    Predicate<GridDataCell> predicate
)
Visual Basic
Public Function FindCells ( _
    predicate As Predicate(Of GridDataCell) _
) As IList(Of GridDataCell)
Visual C++
public:
IList<GridDataCell^>^ FindCells(
    Predicate<GridDataCell^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' GridDataCell >)>)>
The predicate to search for.

Return Value

The list of the cells matching the given predicate.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..FindItems Method
GridTableView Class See Also Send Feedback
Get the list of the data items matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<GridDataItem> FindItems(
    Predicate<GridDataItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of GridDataItem) _
) As IList(Of GridDataItem)
Visual C++
public:
IList<GridDataItem^>^ FindItems(
    Predicate<GridDataItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' GridDataItem >)>)>
The predicate to search for.

Return Value

The list of the data items matching the given predicate.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


GetColumns Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..GetColumns Method
GridTableView Class See Also Send Feedback
Get the columns of the Grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void GetColumns()
Visual Basic
Public Sub GetColumns
Visual C++
public:
void GetColumns()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..GetValue Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


HideFilterItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..HideFilterItem Method
GridTableView Class See Also Send Feedback
Hides the filtering item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void HideFilterItem()
Visual Basic
Public Sub HideFilterItem
Visual C++
public:
void HideFilterItem()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


InsertItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..InsertItem Method
GridTableView Class See Also Send Feedback
Initiates an "insert item" action client-side.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void InsertItem()
Visual Basic
Public Sub InsertItem
Visual C++
public:
void InsertItem()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..InvokeEvent Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..MouseClick Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..MouseHover Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ScrollDown Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ScrollDown Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollDown()()()() | Scroll down in the Grid table using the mouse wheel.
Public method | ScrollDown(Int32) | Scroll down in the Grid table using the mouse wheel.

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ScrollDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ScrollDown Method
GridTableView Class See Also Send Feedback
Scroll down in the Grid table using the mouse wheel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ScrollDown()
Visual Basic
Public Sub ScrollDown
Visual C++
public:
void ScrollDown()

See Also

GridTableView Class
ScrollDown Overload
Telerik.WebAii.Controls.Html Namespace


ScrollDown Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ScrollDown Method (Int32)
GridTableView Class See Also Send Feedback
Scroll down in the Grid table using the mouse wheel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ScrollDown(
    int delta
)
Visual Basic
Public Sub ScrollDown ( _
    delta As Integer _
)
Visual C++
public:
void ScrollDown(
    int delta
)

Parameters

delta
Type: System..::..Int32
The amount to scroll.

See Also

GridTableView Class
ScrollDown Overload
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ScrollToVisible Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ScrollUp Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ScrollUp Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollUp()()()() | Scroll up in the Grid table using the mouse wheel.
Public method | ScrollUp(Int32) | Scroll up in the Grid table using the mouse wheel.

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ScrollUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ScrollUp Method
GridTableView Class See Also Send Feedback
Scroll up in the Grid table using the mouse wheel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ScrollUp()
Visual Basic
Public Sub ScrollUp
Visual C++
public:
void ScrollUp()

See Also

GridTableView Class
ScrollUp Overload
Telerik.WebAii.Controls.Html Namespace


ScrollUp Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ScrollUp Method (Int32)
GridTableView Class See Also Send Feedback
Scroll up in the Grid table using the mouse wheel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ScrollUp(
    int delta
)
Visual Basic
Public Sub ScrollUp ( _
    delta As Integer _
)
Visual C++
public:
void ScrollUp(
    int delta
)

Parameters

delta
Type: System..::..Int32
The amount to scroll.

See Also

GridTableView Class
ScrollUp Overload
Telerik.WebAii.Controls.Html Namespace


SelectAllItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..SelectAllItems Method
GridTableView Class See Also Send Feedback
Selects all the table items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectAllItems()
Visual Basic
Public Sub SelectAllItems
Visual C++
public:
void SelectAllItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


SelectItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..SelectItem Method
GridTableView Class See Also Send Feedback
Select an item in the grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectItem(
    int itemIndex
)
Visual Basic
Public Sub SelectItem ( _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItem(
    int itemIndex
)

Parameters

itemIndex
Type: System..::..Int32
The index of the item to be selected.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


SelectItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..SelectItems Method
GridTableView Class See Also Send Feedback
Select a set of items in the grid.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectItems(
    params int[] itemIndexes
)
Visual Basic
Public Sub SelectItems ( _
    ParamArray itemIndexes As Integer() _
)
Visual C++
public:
void SelectItems(
    ... array<int>^ itemIndexes
)

Parameters

itemIndexes
Type: array< System..::..Int32 >[]()[][]
The array of item indexes.

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..SetValue Method
GridTableView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

GridTableView Class
GridTableView Members
Telerik.WebAii.Controls.Html Namespace


ShowFilterItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ShowFilterItem Method
GridTableView Class See Also Send Feedback
Shows the filter item on the client.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowFilterItem()
Visual Basic
Public Sub ShowFilterItem
Visual C++
public:
void ShowFilterItem()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


ShowInsertItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..ShowInsertItem Method
GridTableView Class See Also Send Feedback
Shows the insert item client-side.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowInsertItem()
Visual Basic
Public Sub ShowInsertItem
Visual C++
public:
void ShowInsertItem()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


UpdateEditedItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView..::..UpdateEditedItems Method
GridTableView Class See Also Send Feedback
Initiates an "update" action for all the table items in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UpdateEditedItems()
Visual Basic
Public Sub UpdateEditedItems
Visual C++
public:
void UpdateEditedItems()

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


GridTableView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
GridTableView Properties
GridTableView Class See Also Send Feedback

The GridTableView type exposes the following members.

Properties

 | Name | Description
Public property | AllowMultiColumnSorting | Get whether the mult-column sorting is enabled.
Public property | AllowRowSelection | Get whether the row selection is enabled.
Public property | AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows) (Inherited from HtmlTable.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag. (Inherited from HtmlTable.)
Public property | Border | Gets the width of the table border. (Inherited from HtmlTable.)
Public property | CanInsertItem | Get whether the standard table command item is enabled either in the header or the footer.
Public property | Caption | Gets the caption of a table. (Inherited from HtmlTable.)
Public property | CellPadding | Gets the amount of space between the cell border and cell content (Inherited from HtmlTable.)
Public property | CellSpacing | Gets the amount of space between the cells in a table. (Inherited from HtmlTable.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the table HTML control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColumnCount | Gets the number of columns in this table (Inherited from HtmlTable.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | The current page index of the loaded page in this table.
Public property | DataItems | Get the list of the children data items of this table.
Public property | EditedIndexes | Collection containing the indexes of the items in edit mode.
Public property | EditedItems | Get the list of items that are in edit mode.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | ExpandedIndexes | Collection containting the indexes of the expanded items for the current TableView.
Public property | ExpandedItems | The list of expanded items for the current TableView.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag. (Inherited from HtmlTable.)
Public property | Groups | Get the list of the groups for this table.
Public property | HasMultiColumnHeaders | Gets whether multi Column Headers are enabled
Public property | HeadRows | Gets the rows contained in the table header if the table is using the thead tag. (Inherited from HtmlTable.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFilterItemVisible | Get whether the filtering is enabled for the table.
Public property | IsItemInserted | Get whether the insert mode form is opened in this table.
Public property | isMultiHeadersAreImplemented | Gets whether multi Column Headers are implemented
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Gets requested row by index. (Inherited from HtmlTable.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | The name of the TableView.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PageCount | The page count of this table.
Public property | PageSize | The page size of the table.
Public property | Rows | Return List of HtmlTableRows. Only the body rows if TBody is used. (Inherited from HtmlTable.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedCells | Get the list of selected cells.
Public property | SelectedItems | Get the list of selected items.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VirtualItemCount | Get the virtual item count of the table.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table. (Inherited from HtmlTable.)

See Also

GridTableView Class
Telerik.WebAii.Controls.Html Namespace


HtmlChartConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartConstants Members
HtmlChartConstants Class Fields See Also Send Feedback

The HtmlChartConstants type exposes the following members.

Fields

Name | Description
CssRadHtmlChart | The base CSS class of the RadHtmlChart wrapper element.
HtmlChartKey | The 'RadHtmlChart' key used across the source classes.
HtmlChartTooltip | The CSS class of the RadHtmlChart tooltip element.

See Also

HtmlChartConstants Class
Telerik.WebAii.Controls.Html Namespace


HtmlChartConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartConstants Fields
HtmlChartConstants Class See Also Send Feedback

The HtmlChartConstants type exposes the following members.

Fields

Name | Description
CssRadHtmlChart | The base CSS class of the RadHtmlChart wrapper element.
HtmlChartKey | The 'RadHtmlChart' key used across the source classes.
HtmlChartTooltip | The CSS class of the RadHtmlChart tooltip element.

See Also

HtmlChartConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadHtmlChart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartConstants..::..CssRadHtmlChart Field
HtmlChartConstants Class See Also Send Feedback
The base CSS class of the RadHtmlChart wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadHtmlChart
Visual Basic
Public Const CssRadHtmlChart As String
Visual C++
public:
literal String^ CssRadHtmlChart

See Also

HtmlChartConstants Class
Telerik.WebAii.Controls.Html Namespace


HtmlChartKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartConstants..::..HtmlChartKey Field
HtmlChartConstants Class See Also Send Feedback
The 'RadHtmlChart' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string HtmlChartKey
Visual Basic
Public Const HtmlChartKey As String
Visual C++
public:
literal String^ HtmlChartKey

See Also

HtmlChartConstants Class
Telerik.WebAii.Controls.Html Namespace


HtmlChartTooltip Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartConstants..::..HtmlChartTooltip Field
HtmlChartConstants Class See Also Send Feedback
The CSS class of the RadHtmlChart tooltip element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string HtmlChartTooltip
Visual Basic
Public Const HtmlChartTooltip As String
Visual C++
public:
literal String^ HtmlChartTooltip

See Also

HtmlChartConstants Class
Telerik.WebAii.Controls.Html Namespace


HtmlChartTooltip Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip Members
HtmlChartTooltip Class Constructors Methods Properties See Also Send Feedback

The HtmlChartTooltip type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlChartTooltip()()()() | Initializes a new instance of the HtmlChart class.
Public method | HtmlChartTooltip(Element) | Initializes a new instance of the HtmlChart class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadHtmlChart. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TooltipText | Gets or sets the HtmlChart tooltip text value.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
Telerik.WebAii.Controls.Html Namespace


HtmlChartTooltip Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip Constructor
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HtmlChartTooltip()()()() | Initializes a new instance of the HtmlChart class.
Public method | HtmlChartTooltip(Element) | Initializes a new instance of the HtmlChart class.

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


HtmlChartTooltip Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip Constructor
HtmlChartTooltip Class See Also Send Feedback
Initializes a new instance of the HtmlChart class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public HtmlChartTooltip()
Visual Basic
Public Sub New
Visual C++
public:
HtmlChartTooltip()

See Also

HtmlChartTooltip Class
HtmlChartTooltip Overload
Telerik.WebAii.Controls.Html Namespace


HtmlChartTooltip Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip Constructor (Element)
HtmlChartTooltip Class See Also Send Feedback
Initializes a new instance of the HtmlChart class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public HtmlChartTooltip(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
HtmlChartTooltip(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.HtmlChartTooltip.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

HtmlChartTooltip Class
HtmlChartTooltip Overload
Telerik.WebAii.Controls.Html Namespace


HtmlChartTooltip Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip Methods
HtmlChartTooltip Class See Also Send Feedback

The HtmlChartTooltip type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

HtmlChartTooltip Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..AssignElement Method
HtmlChartTooltip Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

HtmlChartTooltip Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..CallMethod Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..Capture Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..Click Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..DragTo Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..GetValue Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..InvokeEvent Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..MouseClick Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..MouseHover Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..ScrollToVisible Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip..::..SetValue Method
HtmlChartTooltip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
HtmlChartTooltip Members
Telerik.WebAii.Controls.Html Namespace


HtmlChartTooltip Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
HtmlChartTooltip Properties
HtmlChartTooltip Class See Also Send Feedback

The HtmlChartTooltip type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadHtmlChart. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TooltipText | Gets or sets the HtmlChart tooltip text value.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

HtmlChartTooltip Class
Telerik.WebAii.Controls.Html Namespace


ImageEditorConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageEditorConstants Members
ImageEditorConstants Class Fields See Also Send Feedback

The ImageEditorConstants type exposes the following members.

Fields

Name | Description
CssRadImageEditor | The base CSS class of the RadImageEditor wrapper element.
ImageEditorKey | The 'RadImageEditor' key used across the source classes.

See Also

ImageEditorConstants Class
Telerik.WebAii.Controls.Html Namespace


ImageEditorConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageEditorConstants Fields
ImageEditorConstants Class See Also Send Feedback

The ImageEditorConstants type exposes the following members.

Fields

Name | Description
CssRadImageEditor | The base CSS class of the RadImageEditor wrapper element.
ImageEditorKey | The 'RadImageEditor' key used across the source classes.

See Also

ImageEditorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadImageEditor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageEditorConstants..::..CssRadImageEditor Field
ImageEditorConstants Class See Also Send Feedback
The base CSS class of the RadImageEditor wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadImageEditor
Visual Basic
Public Const CssRadImageEditor As String
Visual C++
public:
literal String^ CssRadImageEditor

See Also

ImageEditorConstants Class
Telerik.WebAii.Controls.Html Namespace


ImageEditorKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ImageEditorConstants..::..ImageEditorKey Field
ImageEditorConstants Class See Also Send Feedback
The 'RadImageEditor' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ImageEditorKey
Visual Basic
Public Const ImageEditorKey As String
Visual C++
public:
literal String^ ImageEditorKey

See Also

ImageEditorConstants Class
Telerik.WebAii.Controls.Html Namespace


IndexesCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Members
IndexesCollection Class Constructors Methods Properties See Also Send Feedback

The IndexesCollection type exposes the following members.

Constructors

 | Name | Description
Public method | IndexesCollection()()()() | Initializes a new instance of the IndexesCollection class.
Public method | IndexesCollection(IList<(Of <<'(Int32>)>>)) | Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified list.
Public method | IndexesCollection(array<Int32>[]()[][]) | Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified int array.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | ConvertToString | Converts the collection to comma separated string.
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | InitializeCodeExpression | Generates initialization code for the indexes collection.
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Matches | Compares the items of the current collection with the passed one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)

See Also

IndexesCollection Class
Telerik.WebAii.Controls.Html Namespace


IndexesCollection Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Constructor
IndexesCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IndexesCollection()()()() | Initializes a new instance of the IndexesCollection class.
Public method | IndexesCollection(IList<(Of <<'(Int32>)>>)) | Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified list.
Public method | IndexesCollection(array<Int32>[]()[][]) | Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified int array.

See Also

IndexesCollection Class
IndexesCollection Members
Telerik.WebAii.Controls.Html Namespace


IndexesCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Constructor
IndexesCollection Class See Also Send Feedback
Initializes a new instance of the IndexesCollection class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IndexesCollection()
Visual Basic
Public Sub New
Visual C++
public:
IndexesCollection()

See Also

IndexesCollection Class
IndexesCollection Overload
Telerik.WebAii.Controls.Html Namespace


IndexesCollection Constructor (IList(Int32))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Constructor (IList<(Of <(<'Int32>)>)>)
IndexesCollection Class See Also Send Feedback
Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified list.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IndexesCollection(
    IList<int> list
)
Visual Basic
Public Sub New ( _
    list As IList(Of Integer) _
)
Visual C++
public:
IndexesCollection(
    IList<int>^ list
)

Parameters

list
Type: System.Collections.Generic..::..IList <(Of <(<' Int32 >)>)>

[Missing <param name="list"/> documentation for "M:Telerik.WebAii.Controls.Html.IndexesCollection.#ctor(System.Collections.Generic.IList{System.Int32})"]

See Also

IndexesCollection Class
IndexesCollection Overload
Telerik.WebAii.Controls.Html Namespace


IndexesCollection Constructor (Int32[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Constructor (array<Int32>[]()[][])
IndexesCollection Class See Also Send Feedback
Initializes a new instance of the IndexesCollection class. Serves as a wrapper for the specified int array.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IndexesCollection(
    int[] intArray
)
Visual Basic
Public Sub New ( _
    intArray As Integer() _
)
Visual C++
public:
IndexesCollection(
    array<int>^ intArray
)

Parameters

intArray
Type: array< System..::..Int32 >[]()[][]

[Missing <param name="intArray"/> documentation for "M:Telerik.WebAii.Controls.Html.IndexesCollection.#ctor(System.Int32[])"]

See Also

IndexesCollection Class
IndexesCollection Overload
Telerik.WebAii.Controls.Html Namespace


IndexesCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Methods
IndexesCollection Class See Also Send Feedback

The IndexesCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | ConvertToString | Converts the collection to comma separated string.
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | InitializeCodeExpression | Generates initialization code for the indexes collection.
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | Matches | Compares the items of the current collection with the passed one.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndexesCollection Class
Telerik.WebAii.Controls.Html Namespace


ConvertToString Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection..::..ConvertToString Method
IndexesCollection Class See Also Send Feedback
Converts the collection to comma separated string.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public string ConvertToString()
Visual Basic
Public Function ConvertToString As String
Visual C++
public:
String^ ConvertToString()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.IndexesCollection.ConvertToString"]

See Also

IndexesCollection Class
Telerik.WebAii.Controls.Html Namespace


InitializeCodeExpression Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection..::..InitializeCodeExpression Method
IndexesCollection Class See Also Send Feedback
Generates initialization code for the indexes collection.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public string InitializeCodeExpression()
Visual Basic
Public Function InitializeCodeExpression As String
Visual C++
public:
String^ InitializeCodeExpression()

Return Value

The initialization code for the indexes collection.

See Also

IndexesCollection Class
Telerik.WebAii.Controls.Html Namespace


Matches Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection..::..Matches Method
IndexesCollection Class See Also Send Feedback
Compares the items of the current collection with the passed one.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool Matches(
    IndexesCollection indexesCollection
)
Visual Basic
Public Function Matches ( _
    indexesCollection As IndexesCollection _
) As Boolean
Visual C++
public:
bool Matches(
    IndexesCollection^ indexesCollection
)

Parameters

indexesCollection
Type: Telerik.WebAii.Controls.Html..::..IndexesCollection
The collextion to compare.

Return Value

Whether the current colleciton items match those from the given collection.

See Also

IndexesCollection Class
Telerik.WebAii.Controls.Html Namespace


IndexesCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
IndexesCollection Properties
IndexesCollection Class See Also Send Feedback

The IndexesCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Int32 >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Int32 >)>)>.)

See Also

IndexesCollection Class
Telerik.WebAii.Controls.Html Namespace


InputConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants Members
InputConstants Class Fields See Also Send Feedback

The InputConstants type exposes the following members.

Fields

Name | Description
CssButtonCell | TextBox table cell button CSS class.
CssError | The input error CSS class.
CssRadInput | The base CSS class of the RadInput wrapper elements.
CssRadInputManager | The Css class of the TextBoxes extended by RadInputManager.
CssSingleInputRendering | The input Single Input Rendering CSS class.
CssSpinButtonCell | NumericTextBox spin buttons table cell CSS class.
CssSpinDown | NumericTextBox spin 'Down' button CSS class.
CssSpinUp | NumericTextBox spin 'Up' button CSS class.
DateInputKey | The DateInput key used across the source classes.
IdTextBoxButton | The TextBox 'Go' button Id.
IdTextBoxLabel | The TextBox built-in label Id.
InputKey | The 'RadInput' key used across the source classes.
NumericTextBoxKey | The NumericTextBox key used across the source classes.
TextBoxKey | The RadTextBox key used across the source classes.

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


InputConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants Fields
InputConstants Class See Also Send Feedback

The InputConstants type exposes the following members.

Fields

Name | Description
CssButtonCell | TextBox table cell button CSS class.
CssError | The input error CSS class.
CssRadInput | The base CSS class of the RadInput wrapper elements.
CssRadInputManager | The Css class of the TextBoxes extended by RadInputManager.
CssSingleInputRendering | The input Single Input Rendering CSS class.
CssSpinButtonCell | NumericTextBox spin buttons table cell CSS class.
CssSpinDown | NumericTextBox spin 'Down' button CSS class.
CssSpinUp | NumericTextBox spin 'Up' button CSS class.
DateInputKey | The DateInput key used across the source classes.
IdTextBoxButton | The TextBox 'Go' button Id.
IdTextBoxLabel | The TextBox built-in label Id.
InputKey | The 'RadInput' key used across the source classes.
NumericTextBoxKey | The NumericTextBox key used across the source classes.
TextBoxKey | The RadTextBox key used across the source classes.

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssButtonCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..CssButtonCell Field
InputConstants Class See Also Send Feedback
TextBox table cell button CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssButtonCell
Visual Basic
Public Const CssButtonCell As String
Visual C++
public:
literal String^ CssButtonCell

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssError Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..CssError Field
InputConstants Class See Also Send Feedback
The input error CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssError
Visual Basic
Public Const CssError As String
Visual C++
public:
literal String^ CssError

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadInput Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..CssRadInput Field
InputConstants Class See Also Send Feedback
The base CSS class of the RadInput wrapper elements.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadInput
Visual Basic
Public Const CssRadInput As String
Visual C++
public:
literal String^ CssRadInput

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadInputManager Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..CssRadInputManager Field
InputConstants Class See Also Send Feedback
The Css class of the TextBoxes extended by RadInputManager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadInputManager
Visual Basic
Public Const CssRadInputManager As String
Visual C++
public:
literal String^ CssRadInputManager

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSingleInputRendering Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..CssSingleInputRendering Field
InputConstants Class See Also Send Feedback
The input Single Input Rendering CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSingleInputRendering
Visual Basic
Public Const CssSingleInputRendering As String
Visual C++
public:
literal String^ CssSingleInputRendering

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSpinButtonCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..CssSpinButtonCell Field
InputConstants Class See Also Send Feedback
NumericTextBox spin buttons table cell CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSpinButtonCell
Visual Basic
Public Const CssSpinButtonCell As String
Visual C++
public:
literal String^ CssSpinButtonCell

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSpinDown Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..CssSpinDown Field
InputConstants Class See Also Send Feedback
NumericTextBox spin 'Down' button CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSpinDown
Visual Basic
Public Const CssSpinDown As String
Visual C++
public:
literal String^ CssSpinDown

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSpinUp Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..CssSpinUp Field
InputConstants Class See Also Send Feedback
NumericTextBox spin 'Up' button CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSpinUp
Visual Basic
Public Const CssSpinUp As String
Visual C++
public:
literal String^ CssSpinUp

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


DateInputKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..DateInputKey Field
InputConstants Class See Also Send Feedback
The DateInput key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DateInputKey
Visual Basic
Public Const DateInputKey As String
Visual C++
public:
literal String^ DateInputKey

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


IdTextBoxButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..IdTextBoxButton Field
InputConstants Class See Also Send Feedback
The TextBox 'Go' button Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdTextBoxButton
Visual Basic
Public Const IdTextBoxButton As String
Visual C++
public:
literal String^ IdTextBoxButton

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


IdTextBoxLabel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..IdTextBoxLabel Field
InputConstants Class See Also Send Feedback
The TextBox built-in label Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdTextBoxLabel
Visual Basic
Public Const IdTextBoxLabel As String
Visual C++
public:
literal String^ IdTextBoxLabel

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


InputKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..InputKey Field
InputConstants Class See Also Send Feedback
The 'RadInput' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string InputKey
Visual Basic
Public Const InputKey As String
Visual C++
public:
literal String^ InputKey

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


NumericTextBoxKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..NumericTextBoxKey Field
InputConstants Class See Also Send Feedback
The NumericTextBox key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string NumericTextBoxKey
Visual Basic
Public Const NumericTextBoxKey As String
Visual C++
public:
literal String^ NumericTextBoxKey

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


TextBoxKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
InputConstants..::..TextBoxKey Field
InputConstants Class See Also Send Feedback
The RadTextBox key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TextBoxKey
Visual Basic
Public Const TextBoxKey As String
Visual C++
public:
literal String^ TextBoxKey

See Also

InputConstants Class
Telerik.WebAii.Controls.Html Namespace


ListBoxConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants Members
ListBoxConstants Class Fields See Also Send Feedback

The ListBoxConstants type exposes the following members.

Fields

Name | Description
CssListBox | The CSS class identifying the ListBox control.
CssListBoxButtonText | The CSS class identifying the ListBox button text.
CssListBoxItem | The CSS class identifying the ListBox item.
CssListBoxItemCheckBox | The CSS class identifying the ListBox item checkbox.
CssListBoxItemImage | The CSS class identifying the ListBox item image element.
CssListBoxItemText | The CSS class identifying the ListBox item span element.
CssListBoxLinkButtonDelete | The CSS class identifying the ListBox link button "Delete".
CssListBoxLinkButtonMoveDown | The CSS class identifying the ListBox link button "MoveDown".
CssListBoxLinkButtonMoveUp | The CSS class identifying the ListBox link button "MoveUp".
CssListBoxLinkButtonTransferAllFrom | The CSS class identifying the ListBox link button "TransferAllFrom".
CssListBoxLinkButtonTransferAllTo | The CSS class identifying the ListBox link button "TransferAllTo".
CssListBoxLinkButtonTransferFrom | The CSS class identifying the ListBox link button "TransferFrom".
CssListBoxLinkButtonTransferTo | The CSS class identifying the ListBox link button "TransferTo".
ListBoxItemKey | The ListBoxItem key used across the source classes.
ListBoxKey | The ListBox key used across the source classes.

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ListBoxConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants Fields
ListBoxConstants Class See Also Send Feedback

The ListBoxConstants type exposes the following members.

Fields

Name | Description
CssListBox | The CSS class identifying the ListBox control.
CssListBoxButtonText | The CSS class identifying the ListBox button text.
CssListBoxItem | The CSS class identifying the ListBox item.
CssListBoxItemCheckBox | The CSS class identifying the ListBox item checkbox.
CssListBoxItemImage | The CSS class identifying the ListBox item image element.
CssListBoxItemText | The CSS class identifying the ListBox item span element.
CssListBoxLinkButtonDelete | The CSS class identifying the ListBox link button "Delete".
CssListBoxLinkButtonMoveDown | The CSS class identifying the ListBox link button "MoveDown".
CssListBoxLinkButtonMoveUp | The CSS class identifying the ListBox link button "MoveUp".
CssListBoxLinkButtonTransferAllFrom | The CSS class identifying the ListBox link button "TransferAllFrom".
CssListBoxLinkButtonTransferAllTo | The CSS class identifying the ListBox link button "TransferAllTo".
CssListBoxLinkButtonTransferFrom | The CSS class identifying the ListBox link button "TransferFrom".
CssListBoxLinkButtonTransferTo | The CSS class identifying the ListBox link button "TransferTo".
ListBoxItemKey | The ListBoxItem key used across the source classes.
ListBoxKey | The ListBox key used across the source classes.

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBox Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBox
Visual Basic
Public Const CssListBox As String
Visual C++
public:
literal String^ CssListBox

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxButtonText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxButtonText Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox button text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxButtonText
Visual Basic
Public Const CssListBoxButtonText As String
Visual C++
public:
literal String^ CssListBoxButtonText

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxItem Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxItem
Visual Basic
Public Const CssListBoxItem As String
Visual C++
public:
literal String^ CssListBoxItem

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxItemCheckBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxItemCheckBox Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox item checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxItemCheckBox
Visual Basic
Public Const CssListBoxItemCheckBox As String
Visual C++
public:
literal String^ CssListBoxItemCheckBox

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxItemImage Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxItemImage Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox item image element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxItemImage
Visual Basic
Public Const CssListBoxItemImage As String
Visual C++
public:
literal String^ CssListBoxItemImage

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxItemText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxItemText Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox item span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxItemText
Visual Basic
Public Const CssListBoxItemText As String
Visual C++
public:
literal String^ CssListBoxItemText

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonDelete Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxLinkButtonDelete Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "Delete".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxLinkButtonDelete
Visual Basic
Public Const CssListBoxLinkButtonDelete As String
Visual C++
public:
literal String^ CssListBoxLinkButtonDelete

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonMoveDown Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxLinkButtonMoveDown Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "MoveDown".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxLinkButtonMoveDown
Visual Basic
Public Const CssListBoxLinkButtonMoveDown As String
Visual C++
public:
literal String^ CssListBoxLinkButtonMoveDown

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonMoveUp Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxLinkButtonMoveUp Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "MoveUp".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxLinkButtonMoveUp
Visual Basic
Public Const CssListBoxLinkButtonMoveUp As String
Visual C++
public:
literal String^ CssListBoxLinkButtonMoveUp

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonTransferAllFrom Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxLinkButtonTransferAllFrom Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "TransferAllFrom".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxLinkButtonTransferAllFrom
Visual Basic
Public Const CssListBoxLinkButtonTransferAllFrom As String
Visual C++
public:
literal String^ CssListBoxLinkButtonTransferAllFrom

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonTransferAllTo Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxLinkButtonTransferAllTo Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "TransferAllTo".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxLinkButtonTransferAllTo
Visual Basic
Public Const CssListBoxLinkButtonTransferAllTo As String
Visual C++
public:
literal String^ CssListBoxLinkButtonTransferAllTo

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonTransferFrom Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxLinkButtonTransferFrom Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "TransferFrom".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxLinkButtonTransferFrom
Visual Basic
Public Const CssListBoxLinkButtonTransferFrom As String
Visual C++
public:
literal String^ CssListBoxLinkButtonTransferFrom

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


CssListBoxLinkButtonTransferTo Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..CssListBoxLinkButtonTransferTo Field
ListBoxConstants Class See Also Send Feedback
The CSS class identifying the ListBox link button "TransferTo".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssListBoxLinkButtonTransferTo
Visual Basic
Public Const CssListBoxLinkButtonTransferTo As String
Visual C++
public:
literal String^ CssListBoxLinkButtonTransferTo

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ListBoxItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..ListBoxItemKey Field
ListBoxConstants Class See Also Send Feedback
The ListBoxItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ListBoxItemKey
Visual Basic
Public Const ListBoxItemKey As String
Visual C++
public:
literal String^ ListBoxItemKey

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ListBoxKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListBoxConstants..::..ListBoxKey Field
ListBoxConstants Class See Also Send Feedback
The ListBox key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ListBoxKey
Visual Basic
Public Const ListBoxKey As String
Visual C++
public:
literal String^ ListBoxKey

See Also

ListBoxConstants Class
Telerik.WebAii.Controls.Html Namespace


ListViewConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewConstants Members
ListViewConstants Class Fields See Also Send Feedback

The ListViewConstants type exposes the following members.

Fields

Name | Description
CssRadListView | The Css class of the ListView div wrapper.
ListViewKey | The ListView key.

See Also

ListViewConstants Class
Telerik.WebAii.Controls.Html Namespace


ListViewConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewConstants Fields
ListViewConstants Class See Also Send Feedback

The ListViewConstants type exposes the following members.

Fields

Name | Description
CssRadListView | The Css class of the ListView div wrapper.
ListViewKey | The ListView key.

See Also

ListViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadListView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewConstants..::..CssRadListView Field
ListViewConstants Class See Also Send Feedback
The Css class of the ListView div wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadListView
Visual Basic
Public Const CssRadListView As String
Visual C++
public:
literal String^ CssRadListView

See Also

ListViewConstants Class
Telerik.WebAii.Controls.Html Namespace


ListViewKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ListViewConstants..::..ListViewKey Field
ListViewConstants Class See Also Send Feedback
The ListView key.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ListViewKey
Visual Basic
Public Const ListViewKey As String
Visual C++
public:
literal String^ ListViewKey

See Also

ListViewConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants Members
MenuConstants Class Fields See Also Send Feedback

The MenuConstants type exposes the following members.

Fields

Name | Description
CssContextMenu | The unique part of RadContextMenu CSS class.
CssMenu | The unique part of RadMenu CSS class.
CssMenuItem | CSS class of the menu item.
CssMenuLink | CSS class of the menu item link.
CssMenuText | CSS class of the menu item span element containing the item text.
MenuItemKey | The MenuItem key used accross the classes.
MenuKey | The Menu key used accross the classes.

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants Fields
MenuConstants Class See Also Send Feedback

The MenuConstants type exposes the following members.

Fields

Name | Description
CssContextMenu | The unique part of RadContextMenu CSS class.
CssMenu | The unique part of RadMenu CSS class.
CssMenuItem | CSS class of the menu item.
CssMenuLink | CSS class of the menu item link.
CssMenuText | CSS class of the menu item span element containing the item text.
MenuItemKey | The MenuItem key used accross the classes.
MenuKey | The Menu key used accross the classes.

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssContextMenu Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants..::..CssContextMenu Field
MenuConstants Class See Also Send Feedback
The unique part of RadContextMenu CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssContextMenu
Visual Basic
Public Const CssContextMenu As String
Visual C++
public:
literal String^ CssContextMenu

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenu Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants..::..CssMenu Field
MenuConstants Class See Also Send Feedback
The unique part of RadMenu CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMenu
Visual Basic
Public Const CssMenu As String
Visual C++
public:
literal String^ CssMenu

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenuItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants..::..CssMenuItem Field
MenuConstants Class See Also Send Feedback
CSS class of the menu item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMenuItem
Visual Basic
Public Const CssMenuItem As String
Visual C++
public:
literal String^ CssMenuItem

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenuLink Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants..::..CssMenuLink Field
MenuConstants Class See Also Send Feedback
CSS class of the menu item link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMenuLink
Visual Basic
Public Const CssMenuLink As String
Visual C++
public:
literal String^ CssMenuLink

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenuText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants..::..CssMenuText Field
MenuConstants Class See Also Send Feedback
CSS class of the menu item span element containing the item text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMenuText
Visual Basic
Public Const CssMenuText As String
Visual C++
public:
literal String^ CssMenuText

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants..::..MenuItemKey Field
MenuConstants Class See Also Send Feedback
The MenuItem key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string MenuItemKey
Visual Basic
Public Const MenuItemKey As String
Visual C++
public:
literal String^ MenuItemKey

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


MenuKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
MenuConstants..::..MenuKey Field
MenuConstants Class See Also Send Feedback
The Menu key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string MenuKey
Visual Basic
Public Const MenuKey As String
Visual C++
public:
literal String^ MenuKey

See Also

MenuConstants Class
Telerik.WebAii.Controls.Html Namespace


NotificationConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NotificationConstants Members
NotificationConstants Class Fields See Also Send Feedback

The NotificationConstants type exposes the following members.

Fields

Name | Description
CssRadNotification | The base CSS class of the RadNotification wrapper element.
IdSuffix | The string that is suffix in notification Id.
NotificationKey | The 'RadNotification' key used across the source classes.

See Also

NotificationConstants Class
Telerik.WebAii.Controls.Html Namespace


NotificationConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NotificationConstants Fields
NotificationConstants Class See Also Send Feedback

The NotificationConstants type exposes the following members.

Fields

Name | Description
CssRadNotification | The base CSS class of the RadNotification wrapper element.
IdSuffix | The string that is suffix in notification Id.
NotificationKey | The 'RadNotification' key used across the source classes.

See Also

NotificationConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadNotification Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NotificationConstants..::..CssRadNotification Field
NotificationConstants Class See Also Send Feedback
The base CSS class of the RadNotification wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadNotification
Visual Basic
Public Const CssRadNotification As String
Visual C++
public:
literal String^ CssRadNotification

See Also

NotificationConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSuffix Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NotificationConstants..::..IdSuffix Field
NotificationConstants Class See Also Send Feedback
The string that is suffix in notification Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSuffix
Visual Basic
Public Const IdSuffix As String
Visual C++
public:
literal String^ IdSuffix

See Also

NotificationConstants Class
Telerik.WebAii.Controls.Html Namespace


NotificationKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
NotificationConstants..::..NotificationKey Field
NotificationConstants Class See Also Send Feedback
The 'RadNotification' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string NotificationKey
Visual Basic
Public Const NotificationKey As String
Visual C++
public:
literal String^ NotificationKey

See Also

NotificationConstants Class
Telerik.WebAii.Controls.Html Namespace


OrgChartConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrgChartConstants Members
OrgChartConstants Class Fields See Also Send Feedback

The OrgChartConstants type exposes the following members.

Fields

Name | Description
CssOrgChart | The CSS class identifying the OrgChart control.
CssOrgChartItem | The CSS class identifying the OrgChart item.
CssOrgChartItemText | The CSS class identifying the OrgChart item span element.
OrgChartItemKey | The OrgChartItem key used across the source classes.
OrgChartKey | The OrgChart key used across the source classes.

See Also

OrgChartConstants Class
Telerik.WebAii.Controls.Html Namespace


OrgChartConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrgChartConstants Fields
OrgChartConstants Class See Also Send Feedback

The OrgChartConstants type exposes the following members.

Fields

Name | Description
CssOrgChart | The CSS class identifying the OrgChart control.
CssOrgChartItem | The CSS class identifying the OrgChart item.
CssOrgChartItemText | The CSS class identifying the OrgChart item span element.
OrgChartItemKey | The OrgChartItem key used across the source classes.
OrgChartKey | The OrgChart key used across the source classes.

See Also

OrgChartConstants Class
Telerik.WebAii.Controls.Html Namespace


CssOrgChart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrgChartConstants..::..CssOrgChart Field
OrgChartConstants Class See Also Send Feedback
The CSS class identifying the OrgChart control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssOrgChart
Visual Basic
Public Const CssOrgChart As String
Visual C++
public:
literal String^ CssOrgChart

See Also

OrgChartConstants Class
Telerik.WebAii.Controls.Html Namespace


CssOrgChartItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrgChartConstants..::..CssOrgChartItem Field
OrgChartConstants Class See Also Send Feedback
The CSS class identifying the OrgChart item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssOrgChartItem
Visual Basic
Public Const CssOrgChartItem As String
Visual C++
public:
literal String^ CssOrgChartItem

See Also

OrgChartConstants Class
Telerik.WebAii.Controls.Html Namespace


CssOrgChartItemText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrgChartConstants..::..CssOrgChartItemText Field
OrgChartConstants Class See Also Send Feedback
The CSS class identifying the OrgChart item span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssOrgChartItemText
Visual Basic
Public Const CssOrgChartItemText As String
Visual C++
public:
literal String^ CssOrgChartItemText

See Also

OrgChartConstants Class
Telerik.WebAii.Controls.Html Namespace


OrgChartItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrgChartConstants..::..OrgChartItemKey Field
OrgChartConstants Class See Also Send Feedback
The OrgChartItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string OrgChartItemKey
Visual Basic
Public Const OrgChartItemKey As String
Visual C++
public:
literal String^ OrgChartItemKey

See Also

OrgChartConstants Class
Telerik.WebAii.Controls.Html Namespace


OrgChartKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
OrgChartConstants..::..OrgChartKey Field
OrgChartConstants Class See Also Send Feedback
The OrgChart key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string OrgChartKey
Visual Basic
Public Const OrgChartKey As String
Visual C++
public:
literal String^ OrgChartKey

See Also

OrgChartConstants Class
Telerik.WebAii.Controls.Html Namespace


PanelBarConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants Members
PanelBarConstants Class Fields See Also Send Feedback

The PanelBarConstants type exposes the following members.

Fields

Name | Description
CssPanelBar | The CSS class identifying the PanelBar control.
CssPanelBarItem | The CSS class identifying the PanelBar item.
CssPanelBarItemExpandableSpan | The CSS class identifying the PanelBar item expandable span.
CssPanelBarItemLink | The CSS class identifying the PanelBar item link.
CssPanelBarItemTemplate | The CSS class identifying the PanelBar item template.
CssPanelBarItemText | The CSS class identifying the PanelBar item text span element.
PanelBarItemKey | The PanelBarItem key used across the source classes.
PanelBarKey | The PanelBar key used across the source classes.

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


PanelBarConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants Fields
PanelBarConstants Class See Also Send Feedback

The PanelBarConstants type exposes the following members.

Fields

Name | Description
CssPanelBar | The CSS class identifying the PanelBar control.
CssPanelBarItem | The CSS class identifying the PanelBar item.
CssPanelBarItemExpandableSpan | The CSS class identifying the PanelBar item expandable span.
CssPanelBarItemLink | The CSS class identifying the PanelBar item link.
CssPanelBarItemTemplate | The CSS class identifying the PanelBar item template.
CssPanelBarItemText | The CSS class identifying the PanelBar item text span element.
PanelBarItemKey | The PanelBarItem key used across the source classes.
PanelBarKey | The PanelBar key used across the source classes.

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants..::..CssPanelBar Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPanelBar
Visual Basic
Public Const CssPanelBar As String
Visual C++
public:
literal String^ CssPanelBar

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBarItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants..::..CssPanelBarItem Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPanelBarItem
Visual Basic
Public Const CssPanelBarItem As String
Visual C++
public:
literal String^ CssPanelBarItem

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBarItemExpandableSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants..::..CssPanelBarItemExpandableSpan Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar item expandable span.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPanelBarItemExpandableSpan
Visual Basic
Public Const CssPanelBarItemExpandableSpan As String
Visual C++
public:
literal String^ CssPanelBarItemExpandableSpan

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBarItemLink Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants..::..CssPanelBarItemLink Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar item link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPanelBarItemLink
Visual Basic
Public Const CssPanelBarItemLink As String
Visual C++
public:
literal String^ CssPanelBarItemLink

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBarItemTemplate Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants..::..CssPanelBarItemTemplate Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar item template.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPanelBarItemTemplate
Visual Basic
Public Const CssPanelBarItemTemplate As String
Visual C++
public:
literal String^ CssPanelBarItemTemplate

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPanelBarItemText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants..::..CssPanelBarItemText Field
PanelBarConstants Class See Also Send Feedback
The CSS class identifying the PanelBar item text span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPanelBarItemText
Visual Basic
Public Const CssPanelBarItemText As String
Visual C++
public:
literal String^ CssPanelBarItemText

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


PanelBarItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants..::..PanelBarItemKey Field
PanelBarConstants Class See Also Send Feedback
The PanelBarItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PanelBarItemKey
Visual Basic
Public Const PanelBarItemKey As String
Visual C++
public:
literal String^ PanelBarItemKey

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


PanelBarKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PanelBarConstants..::..PanelBarKey Field
PanelBarConstants Class See Also Send Feedback
The PanelBar key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PanelBarKey
Visual Basic
Public Const PanelBarKey As String
Visual C++
public:
literal String^ PanelBarKey

See Also

PanelBarConstants Class
Telerik.WebAii.Controls.Html Namespace


PivotGridAggregatesZone Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone Members
PivotGridAggregatesZone Class Constructors Methods Fields Properties See Also Send Feedback

The PivotGridAggregatesZone type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridAggregatesZone | Initializes a new instance of the PivotGridAggregatesZone class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Inherited from PivotGridZone.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from PivotGridZone.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeCellLocator | Initializes the element locator for this control. (Overrides PivotGridZone..::..InitializeCellLocator()()()().)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Fields

 | Name | Description
Public field | cellLocator | Zone locator pattern. (Inherited from PivotGridZone.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Fields | A list containing all the fields in the zone. (Inherited from PivotGridZone.)
Public property | FieldsCount | The count of the fields in the zone. (Inherited from PivotGridZone.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Inherited from PivotGridZone.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridAggregatesZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridAggregatesZone Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone Constructor
PivotGridAggregatesZone Class See Also Send Feedback
Initializes a new instance of the PivotGridAggregatesZone class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridAggregatesZone()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridAggregatesZone()

See Also

PivotGridAggregatesZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridAggregatesZone Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone Fields
PivotGridAggregatesZone Class See Also Send Feedback

The PivotGridAggregatesZone type exposes the following members.

Fields

 | Name | Description
Public field | cellLocator | Zone locator pattern. (Inherited from PivotGridZone.)

See Also

PivotGridAggregatesZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridAggregatesZone Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone Methods
PivotGridAggregatesZone Class See Also Send Feedback

The PivotGridAggregatesZone type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Inherited from PivotGridZone.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from PivotGridZone.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeCellLocator | Initializes the element locator for this control. (Overrides PivotGridZone..::..InitializeCellLocator()()()().)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridAggregatesZone Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..CallMethod Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..Capture Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..Click Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..DragTo Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..GetValue Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


InitializeCellLocator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..InitializeCellLocator Method
PivotGridAggregatesZone Class See Also Send Feedback
Initializes the element locator for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
protected override void InitializeCellLocator()
Visual Basic
Protected Overrides Sub InitializeCellLocator
Visual C++
protected:
virtual void InitializeCellLocator() override

See Also

PivotGridAggregatesZone Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..InvokeEvent Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..MouseClick Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..MouseHover Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..ScrollToVisible Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone..::..SetValue Method
PivotGridAggregatesZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridAggregatesZone Class
PivotGridAggregatesZone Members
Telerik.WebAii.Controls.Html Namespace


PivotGridAggregatesZone Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridAggregatesZone Properties
PivotGridAggregatesZone Class See Also Send Feedback

The PivotGridAggregatesZone type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Fields | A list containing all the fields in the zone. (Inherited from PivotGridZone.)
Public property | FieldsCount | The count of the fields in the zone. (Inherited from PivotGridZone.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Inherited from PivotGridZone.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridAggregatesZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnHeaderCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell Members
PivotGridColumnHeaderCell Class Constructors Methods Properties See Also Send Feedback

The PivotGridColumnHeaderCell type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridColumnHeaderCell()()()() | Initializes a new instance of the PivotGridColumnHeaderCell class.
Public method | PivotGridColumnHeaderCell(Element) | Initializes a new instance of the PivotGridColumnHeaderCell class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Initiates a 'collapse' action of the header.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Initiates a 'expand' action of the header.
Public method | ExpandCollapse | Initiates a 'expand/collapse' action of the header.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanExpandCollapse | Gets whether this header cell can expand/collapse.
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this PivotGrid column header cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Gets whether this header cell is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HeaderCellType | Gets the ColumnHeaderCell type.
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent row item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridColumnHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnHeaderCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell Constructor
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PivotGridColumnHeaderCell()()()() | Initializes a new instance of the PivotGridColumnHeaderCell class.
Public method | PivotGridColumnHeaderCell(Element) | Initializes a new instance of the PivotGridColumnHeaderCell class.

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnHeaderCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell Constructor
PivotGridColumnHeaderCell Class See Also Send Feedback
Initializes a new instance of the PivotGridColumnHeaderCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridColumnHeaderCell()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridColumnHeaderCell()

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnHeaderCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell Constructor (Element)
PivotGridColumnHeaderCell Class See Also Send Feedback
Initializes a new instance of the PivotGridColumnHeaderCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridColumnHeaderCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
PivotGridColumnHeaderCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridColumnHeaderCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnHeaderCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell Methods
PivotGridColumnHeaderCell Class See Also Send Feedback

The PivotGridColumnHeaderCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Initiates a 'collapse' action of the header.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Initiates a 'expand' action of the header.
Public method | ExpandCollapse | Initiates a 'expand/collapse' action of the header.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridColumnHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..AssignElement Method
PivotGridColumnHeaderCell Class See Also Send Feedback
Assigns element and initializes this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

PivotGridColumnHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..CallMethod Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..Capture Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..Click Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..Collapse Method
PivotGridColumnHeaderCell Class See Also Send Feedback
Initiates a 'collapse' action of the header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

PivotGridColumnHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..ControlAssert Method
PivotGridColumnHeaderCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

PivotGridColumnHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..DragTo Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..Expand Method
PivotGridColumnHeaderCell Class See Also Send Feedback
Initiates a 'expand' action of the header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

PivotGridColumnHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


ExpandCollapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..ExpandCollapse Method
PivotGridColumnHeaderCell Class See Also Send Feedback
Initiates a 'expand/collapse' action of the header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ExpandCollapse(
    bool click
)
Visual Basic
Public Sub ExpandCollapse ( _
    click As Boolean _
)
Visual C++
public:
void ExpandCollapse(
    bool click
)

Parameters

click
Type: System..::..Boolean

[Missing <param name="click"/> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridColumnHeaderCell.ExpandCollapse(System.Boolean)"]

See Also

PivotGridColumnHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..GetValue Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..InvokeEvent Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..MouseClick Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..MouseHover Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..ScrollToVisible Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell..::..SetValue Method
PivotGridColumnHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridColumnHeaderCell Class
PivotGridColumnHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnHeaderCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnHeaderCell Properties
PivotGridColumnHeaderCell Class See Also Send Feedback

The PivotGridColumnHeaderCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanExpandCollapse | Gets whether this header cell can expand/collapse.
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this PivotGrid column header cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Gets whether this header cell is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HeaderCellType | Gets the ColumnHeaderCell type.
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent row item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridColumnHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnsZone Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone Members
PivotGridColumnsZone Class Constructors Methods Fields Properties See Also Send Feedback

The PivotGridColumnsZone type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridColumnsZone | Initializes a new instance of the PivotGridColumnsZone class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Inherited from PivotGridZone.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from PivotGridZone.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeCellLocator | Initializes the element locator for this control. (Overrides PivotGridZone..::..InitializeCellLocator()()()().)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Fields

 | Name | Description
Public field | cellLocator | Zone locator pattern. (Inherited from PivotGridZone.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Fields | A list containing all the fields in the zone. (Inherited from PivotGridZone.)
Public property | FieldsCount | The count of the fields in the zone. (Inherited from PivotGridZone.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Inherited from PivotGridZone.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridColumnsZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnsZone Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone Constructor
PivotGridColumnsZone Class See Also Send Feedback
Initializes a new instance of the PivotGridColumnsZone class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridColumnsZone()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridColumnsZone()

See Also

PivotGridColumnsZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnsZone Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone Fields
PivotGridColumnsZone Class See Also Send Feedback

The PivotGridColumnsZone type exposes the following members.

Fields

 | Name | Description
Public field | cellLocator | Zone locator pattern. (Inherited from PivotGridZone.)

See Also

PivotGridColumnsZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnsZone Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone Methods
PivotGridColumnsZone Class See Also Send Feedback

The PivotGridColumnsZone type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Inherited from PivotGridZone.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from PivotGridZone.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeCellLocator | Initializes the element locator for this control. (Overrides PivotGridZone..::..InitializeCellLocator()()()().)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridColumnsZone Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..CallMethod Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..Capture Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..Click Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..DragTo Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..GetValue Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


InitializeCellLocator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..InitializeCellLocator Method
PivotGridColumnsZone Class See Also Send Feedback
Initializes the element locator for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
protected override void InitializeCellLocator()
Visual Basic
Protected Overrides Sub InitializeCellLocator
Visual C++
protected:
virtual void InitializeCellLocator() override

See Also

PivotGridColumnsZone Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..InvokeEvent Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..MouseClick Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..MouseHover Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..ScrollToVisible Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone..::..SetValue Method
PivotGridColumnsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridColumnsZone Class
PivotGridColumnsZone Members
Telerik.WebAii.Controls.Html Namespace


PivotGridColumnsZone Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridColumnsZone Properties
PivotGridColumnsZone Class See Also Send Feedback

The PivotGridColumnsZone type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Fields | A list containing all the fields in the zone. (Inherited from PivotGridZone.)
Public property | FieldsCount | The count of the fields in the zone. (Inherited from PivotGridZone.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Inherited from PivotGridZone.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridColumnsZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants Members
PivotGridConstants Class Fields See Also Send Feedback

The PivotGridConstants type exposes the following members.

Fields

Name | Description
ColumnHeaderKey | The PivotGrid column header key used accross the verifications and action messages.
ColumnHeaderTableId | The Id ending part of the PivotGrid colum header table.
ColumnHeaderZoneId | The Id ending part of the PivotGrid header zone cell.
ColumnHeaderZoneKey | The PivotGrid column header zone key used accross the verifications and action messages.
ContentZoneId | The Id ending part of the PivotGrid content zone div.
CssAdvancedPart | CSS class of the PivotGrid pager advanced part div.
CssAggregatesZone | CSS class of a PivotGrid aggregate zone.
CssArrayPart | CSS class of the PivotGrid pager navigation buttons part div.
CssCollapsedHeaderCell | CSS class of a PivotGrid collapsed header cell.
CssColumnGrandTotal | CSS class of the PivotGrid column grand total cell.
CssColumnHeader | CSS class of a PivotGrid column header.
CssColumnHeaderGrandTotal | CSS class of the PivotGrid column header grand total cell.
CssColumnHeaderTotal | CSS class of the PivotGrid column header total cell.
CssColumnsZone | CSS class of a PivotGrid column zone.
CssColumnTotal | CSS class of the PivotGrid column total cell.
CssContextMenu | CSS class of the PivotGrid context menu.
CssDataCell | CSS class of the PivotGrid data cell.
CssDiv | The unique CSS class of the PivotGrid div element.
CssDragDropPointer | CSS class of the span element that contains the top arrow of the drag-drop pointer.
CssExpandedHeaderCell | CSS class of a PivotGrid expanded header cell.
CssField | CSS class of a PivotGrid field.
CssFieldsContainer | CSS class of the div element that holds the fields inside the fields window.
CssFilterItem | CSS class of a PivotGrid filter item.
CssNumberPart | CSS class of the PivotGrid pager number part div.
CssPageFirst | CSS class of the PivotGrid pager "first page" button.
CssPageLast | CSS class of the PivotGrid pager "last page" button.
CssPageNext | CSS class of the PivotGrid pager "next page" button.
CssPagePrevious | CSS class of the PivotGrid pager "previous page" button.
CssPager | CSS class of the PivotGrid pager item.
CssPagerCell | CSS class of the PivotGrid pager cell.
CssRowGrandTotal | CSS class of the PivotGrid row grand total cell.
CssRowHeader | CSS class of a PivotGrid row header.
CssRowHeaderGrandTotal | CSS class of the PivotGrid row header grand total cell.
CssRowHeaderTotal | CSS class of the PivotGrid row header total cell.
CssRowsZone | CSS class of a PivotGrid rows zone.
CssRowTotal | CSS class of the PivotGrid row total cell.
CssSort | CSS class of the PivotGrid sorting input button.
CssSortAscending | CSS class of the PivotGrid sort button when Ascending sort order is applied.
CssSortDescending | CSS class of the PivotGrid sort button when Descending sort order is applied.
CssTable | CSS class of a PivotGrid table.
CssVerticalScroll | CSS class of the PivotGrid vertical scroll div.
CssWrap | CSS class of the PivotGrid pager wrap div.
DataCellKey | The PivotGrid data cell key used accross the verifications and action messages.
DataTableId | The Id ending part of the PivotGrid Data table.
EmptyRowsZoneId | The Id ending part of the PivotGrid rows zone when it is empty.
FieldKey | The PivotGrid field key used accross the verifications and action messages.
HeaderKey | The PivotGrid header key used accross the verifications and action messages.
HorizontalScrollId | The Id ending part of the PivotGrid horizontal scroll div.
IdChangePageSize | Id of the "change page size" Advanced Pager button.
IdGoToPage | Id of the "go to page" Advanced Pager button.
OuterTableId | The Id ending part of the PivotGrid outer table.
PagerKey | The PivotGrid Pager key used accross the verifications and action messages.
PivotGridKey | The PivotGrid key used accross the verifications and action messages.
RowHeaderKey | The PivotGrid row header key used accross the verifications and action messages.
RowHeaderTableId | The Id ending part of the PivotGrid row header table.
RowHeaderZoneId | The Id ending part of the PivotGrid header zone div.
RowHeaderZoneKey | The PivotGrid row header zone key used accross the verifications and action messages.
SortButtonId | The Id ending part of the PivotGrid sort button.
TableKey | The PivotGrid data table key used accross the verifications and action messages.
VerticalScrollId | The Id ending part of the PivotGrid vertical scroll div.
ZoneKey | The PivotGrid zone key used accross the verifications and action messages.

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


PivotGridConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants Fields
PivotGridConstants Class See Also Send Feedback

The PivotGridConstants type exposes the following members.

Fields

Name | Description
ColumnHeaderKey | The PivotGrid column header key used accross the verifications and action messages.
ColumnHeaderTableId | The Id ending part of the PivotGrid colum header table.
ColumnHeaderZoneId | The Id ending part of the PivotGrid header zone cell.
ColumnHeaderZoneKey | The PivotGrid column header zone key used accross the verifications and action messages.
ContentZoneId | The Id ending part of the PivotGrid content zone div.
CssAdvancedPart | CSS class of the PivotGrid pager advanced part div.
CssAggregatesZone | CSS class of a PivotGrid aggregate zone.
CssArrayPart | CSS class of the PivotGrid pager navigation buttons part div.
CssCollapsedHeaderCell | CSS class of a PivotGrid collapsed header cell.
CssColumnGrandTotal | CSS class of the PivotGrid column grand total cell.
CssColumnHeader | CSS class of a PivotGrid column header.
CssColumnHeaderGrandTotal | CSS class of the PivotGrid column header grand total cell.
CssColumnHeaderTotal | CSS class of the PivotGrid column header total cell.
CssColumnsZone | CSS class of a PivotGrid column zone.
CssColumnTotal | CSS class of the PivotGrid column total cell.
CssContextMenu | CSS class of the PivotGrid context menu.
CssDataCell | CSS class of the PivotGrid data cell.
CssDiv | The unique CSS class of the PivotGrid div element.
CssDragDropPointer | CSS class of the span element that contains the top arrow of the drag-drop pointer.
CssExpandedHeaderCell | CSS class of a PivotGrid expanded header cell.
CssField | CSS class of a PivotGrid field.
CssFieldsContainer | CSS class of the div element that holds the fields inside the fields window.
CssFilterItem | CSS class of a PivotGrid filter item.
CssNumberPart | CSS class of the PivotGrid pager number part div.
CssPageFirst | CSS class of the PivotGrid pager "first page" button.
CssPageLast | CSS class of the PivotGrid pager "last page" button.
CssPageNext | CSS class of the PivotGrid pager "next page" button.
CssPagePrevious | CSS class of the PivotGrid pager "previous page" button.
CssPager | CSS class of the PivotGrid pager item.
CssPagerCell | CSS class of the PivotGrid pager cell.
CssRowGrandTotal | CSS class of the PivotGrid row grand total cell.
CssRowHeader | CSS class of a PivotGrid row header.
CssRowHeaderGrandTotal | CSS class of the PivotGrid row header grand total cell.
CssRowHeaderTotal | CSS class of the PivotGrid row header total cell.
CssRowsZone | CSS class of a PivotGrid rows zone.
CssRowTotal | CSS class of the PivotGrid row total cell.
CssSort | CSS class of the PivotGrid sorting input button.
CssSortAscending | CSS class of the PivotGrid sort button when Ascending sort order is applied.
CssSortDescending | CSS class of the PivotGrid sort button when Descending sort order is applied.
CssTable | CSS class of a PivotGrid table.
CssVerticalScroll | CSS class of the PivotGrid vertical scroll div.
CssWrap | CSS class of the PivotGrid pager wrap div.
DataCellKey | The PivotGrid data cell key used accross the verifications and action messages.
DataTableId | The Id ending part of the PivotGrid Data table.
EmptyRowsZoneId | The Id ending part of the PivotGrid rows zone when it is empty.
FieldKey | The PivotGrid field key used accross the verifications and action messages.
HeaderKey | The PivotGrid header key used accross the verifications and action messages.
HorizontalScrollId | The Id ending part of the PivotGrid horizontal scroll div.
IdChangePageSize | Id of the "change page size" Advanced Pager button.
IdGoToPage | Id of the "go to page" Advanced Pager button.
OuterTableId | The Id ending part of the PivotGrid outer table.
PagerKey | The PivotGrid Pager key used accross the verifications and action messages.
PivotGridKey | The PivotGrid key used accross the verifications and action messages.
RowHeaderKey | The PivotGrid row header key used accross the verifications and action messages.
RowHeaderTableId | The Id ending part of the PivotGrid row header table.
RowHeaderZoneId | The Id ending part of the PivotGrid header zone div.
RowHeaderZoneKey | The PivotGrid row header zone key used accross the verifications and action messages.
SortButtonId | The Id ending part of the PivotGrid sort button.
TableKey | The PivotGrid data table key used accross the verifications and action messages.
VerticalScrollId | The Id ending part of the PivotGrid vertical scroll div.
ZoneKey | The PivotGrid zone key used accross the verifications and action messages.

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnHeaderKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..ColumnHeaderKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid column header key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ColumnHeaderKey
Visual Basic
Public Const ColumnHeaderKey As String
Visual C++
public:
literal String^ ColumnHeaderKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnHeaderTableId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..ColumnHeaderTableId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid colum header table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ColumnHeaderTableId
Visual Basic
Public Const ColumnHeaderTableId As String
Visual C++
public:
literal String^ ColumnHeaderTableId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnHeaderZoneId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..ColumnHeaderZoneId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid header zone cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ColumnHeaderZoneId
Visual Basic
Public Const ColumnHeaderZoneId As String
Visual C++
public:
literal String^ ColumnHeaderZoneId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnHeaderZoneKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..ColumnHeaderZoneKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid column header zone key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ColumnHeaderZoneKey
Visual Basic
Public Const ColumnHeaderZoneKey As String
Visual C++
public:
literal String^ ColumnHeaderZoneKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


ContentZoneId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..ContentZoneId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid content zone div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ContentZoneId
Visual Basic
Public Const ContentZoneId As String
Visual C++
public:
literal String^ ContentZoneId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAdvancedPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssAdvancedPart Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager advanced part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAdvancedPart
Visual Basic
Public Const CssAdvancedPart As String
Visual C++
public:
literal String^ CssAdvancedPart

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAggregatesZone Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssAggregatesZone Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid aggregate zone.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAggregatesZone
Visual Basic
Public Const CssAggregatesZone As String
Visual C++
public:
literal String^ CssAggregatesZone

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssArrayPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssArrayPart Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager navigation buttons part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssArrayPart
Visual Basic
Public Const CssArrayPart As String
Visual C++
public:
literal String^ CssArrayPart

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCollapsedHeaderCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssCollapsedHeaderCell Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid collapsed header cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCollapsedHeaderCell
Visual Basic
Public Const CssCollapsedHeaderCell As String
Visual C++
public:
literal String^ CssCollapsedHeaderCell

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColumnGrandTotal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssColumnGrandTotal Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid column grand total cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColumnGrandTotal
Visual Basic
Public Const CssColumnGrandTotal As String
Visual C++
public:
literal String^ CssColumnGrandTotal

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColumnHeader Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssColumnHeader Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid column header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColumnHeader
Visual Basic
Public Const CssColumnHeader As String
Visual C++
public:
literal String^ CssColumnHeader

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColumnHeaderGrandTotal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssColumnHeaderGrandTotal Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid column header grand total cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColumnHeaderGrandTotal
Visual Basic
Public Const CssColumnHeaderGrandTotal As String
Visual C++
public:
literal String^ CssColumnHeaderGrandTotal

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColumnHeaderTotal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssColumnHeaderTotal Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid column header total cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColumnHeaderTotal
Visual Basic
Public Const CssColumnHeaderTotal As String
Visual C++
public:
literal String^ CssColumnHeaderTotal

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColumnsZone Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssColumnsZone Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid column zone.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColumnsZone
Visual Basic
Public Const CssColumnsZone As String
Visual C++
public:
literal String^ CssColumnsZone

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssColumnTotal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssColumnTotal Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid column total cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssColumnTotal
Visual Basic
Public Const CssColumnTotal As String
Visual C++
public:
literal String^ CssColumnTotal

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssContextMenu Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssContextMenu Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid context menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssContextMenu
Visual Basic
Public Const CssContextMenu As String
Visual C++
public:
literal String^ CssContextMenu

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDataCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssDataCell Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid data cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDataCell
Visual Basic
Public Const CssDataCell As String
Visual C++
public:
literal String^ CssDataCell

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssDiv Field
PivotGridConstants Class See Also Send Feedback
The unique CSS class of the PivotGrid div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDiv
Visual Basic
Public Const CssDiv As String
Visual C++
public:
literal String^ CssDiv

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDragDropPointer Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssDragDropPointer Field
PivotGridConstants Class See Also Send Feedback
CSS class of the span element that contains the top arrow of the drag-drop pointer.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDragDropPointer
Visual Basic
Public Const CssDragDropPointer As String
Visual C++
public:
literal String^ CssDragDropPointer

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpandedHeaderCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssExpandedHeaderCell Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid expanded header cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExpandedHeaderCell
Visual Basic
Public Const CssExpandedHeaderCell As String
Visual C++
public:
literal String^ CssExpandedHeaderCell

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssField Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssField Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid field.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssField
Visual Basic
Public Const CssField As String
Visual C++
public:
literal String^ CssField

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFieldsContainer Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssFieldsContainer Field
PivotGridConstants Class See Also Send Feedback
CSS class of the div element that holds the fields inside the fields window.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFieldsContainer
Visual Basic
Public Const CssFieldsContainer As String
Visual C++
public:
literal String^ CssFieldsContainer

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFilterItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssFilterItem Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid filter item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFilterItem
Visual Basic
Public Const CssFilterItem As String
Visual C++
public:
literal String^ CssFilterItem

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNumberPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssNumberPart Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager number part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNumberPart
Visual Basic
Public Const CssNumberPart As String
Visual C++
public:
literal String^ CssNumberPart

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageFirst Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssPageFirst Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager "first page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageFirst
Visual Basic
Public Const CssPageFirst As String
Visual C++
public:
literal String^ CssPageFirst

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageLast Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssPageLast Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager "last page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageLast
Visual Basic
Public Const CssPageLast As String
Visual C++
public:
literal String^ CssPageLast

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageNext Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssPageNext Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager "next page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageNext
Visual Basic
Public Const CssPageNext As String
Visual C++
public:
literal String^ CssPageNext

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPagePrevious Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssPagePrevious Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager "previous page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPagePrevious
Visual Basic
Public Const CssPagePrevious As String
Visual C++
public:
literal String^ CssPagePrevious

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPager Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssPager Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPager
Visual Basic
Public Const CssPager As String
Visual C++
public:
literal String^ CssPager

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPagerCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssPagerCell Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPagerCell
Visual Basic
Public Const CssPagerCell As String
Visual C++
public:
literal String^ CssPagerCell

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRowGrandTotal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssRowGrandTotal Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid row grand total cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRowGrandTotal
Visual Basic
Public Const CssRowGrandTotal As String
Visual C++
public:
literal String^ CssRowGrandTotal

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRowHeader Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssRowHeader Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid row header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRowHeader
Visual Basic
Public Const CssRowHeader As String
Visual C++
public:
literal String^ CssRowHeader

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRowHeaderGrandTotal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssRowHeaderGrandTotal Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid row header grand total cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRowHeaderGrandTotal
Visual Basic
Public Const CssRowHeaderGrandTotal As String
Visual C++
public:
literal String^ CssRowHeaderGrandTotal

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRowHeaderTotal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssRowHeaderTotal Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid row header total cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRowHeaderTotal
Visual Basic
Public Const CssRowHeaderTotal As String
Visual C++
public:
literal String^ CssRowHeaderTotal

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRowsZone Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssRowsZone Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid rows zone.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRowsZone
Visual Basic
Public Const CssRowsZone As String
Visual C++
public:
literal String^ CssRowsZone

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRowTotal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssRowTotal Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid row total cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRowTotal
Visual Basic
Public Const CssRowTotal As String
Visual C++
public:
literal String^ CssRowTotal

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSort Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssSort Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid sorting input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSort
Visual Basic
Public Const CssSort As String
Visual C++
public:
literal String^ CssSort

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSortAscending Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssSortAscending Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid sort button when Ascending sort order is applied.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSortAscending
Visual Basic
Public Const CssSortAscending As String
Visual C++
public:
literal String^ CssSortAscending

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSortDescending Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssSortDescending Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid sort button when Descending sort order is applied.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSortDescending
Visual Basic
Public Const CssSortDescending As String
Visual C++
public:
literal String^ CssSortDescending

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTable Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssTable Field
PivotGridConstants Class See Also Send Feedback
CSS class of a PivotGrid table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTable
Visual Basic
Public Const CssTable As String
Visual C++
public:
literal String^ CssTable

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssVerticalScroll Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssVerticalScroll Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid vertical scroll div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssVerticalScroll
Visual Basic
Public Const CssVerticalScroll As String
Visual C++
public:
literal String^ CssVerticalScroll

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


CssWrap Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..CssWrap Field
PivotGridConstants Class See Also Send Feedback
CSS class of the PivotGrid pager wrap div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssWrap
Visual Basic
Public Const CssWrap As String
Visual C++
public:
literal String^ CssWrap

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


DataCellKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..DataCellKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid data cell key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DataCellKey
Visual Basic
Public Const DataCellKey As String
Visual C++
public:
literal String^ DataCellKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


DataTableId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..DataTableId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid Data table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DataTableId
Visual Basic
Public Const DataTableId As String
Visual C++
public:
literal String^ DataTableId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


EmptyRowsZoneId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..EmptyRowsZoneId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid rows zone when it is empty.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string EmptyRowsZoneId
Visual Basic
Public Const EmptyRowsZoneId As String
Visual C++
public:
literal String^ EmptyRowsZoneId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


FieldKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..FieldKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid field key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FieldKey
Visual Basic
Public Const FieldKey As String
Visual C++
public:
literal String^ FieldKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


HeaderKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..HeaderKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid header key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string HeaderKey
Visual Basic
Public Const HeaderKey As String
Visual C++
public:
literal String^ HeaderKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


HorizontalScrollId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..HorizontalScrollId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid horizontal scroll div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string HorizontalScrollId
Visual Basic
Public Const HorizontalScrollId As String
Visual C++
public:
literal String^ HorizontalScrollId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdChangePageSize Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..IdChangePageSize Field
PivotGridConstants Class See Also Send Feedback
Id of the "change page size" Advanced Pager button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdChangePageSize
Visual Basic
Public Const IdChangePageSize As String
Visual C++
public:
literal String^ IdChangePageSize

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


IdGoToPage Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..IdGoToPage Field
PivotGridConstants Class See Also Send Feedback
Id of the "go to page" Advanced Pager button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdGoToPage
Visual Basic
Public Const IdGoToPage As String
Visual C++
public:
literal String^ IdGoToPage

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


OuterTableId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..OuterTableId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid outer table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string OuterTableId
Visual Basic
Public Const OuterTableId As String
Visual C++
public:
literal String^ OuterTableId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


PagerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..PagerKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid Pager key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PagerKey
Visual Basic
Public Const PagerKey As String
Visual C++
public:
literal String^ PagerKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


PivotGridKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..PivotGridKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PivotGridKey
Visual Basic
Public Const PivotGridKey As String
Visual C++
public:
literal String^ PivotGridKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


RowHeaderKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..RowHeaderKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid row header key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RowHeaderKey
Visual Basic
Public Const RowHeaderKey As String
Visual C++
public:
literal String^ RowHeaderKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


RowHeaderTableId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..RowHeaderTableId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid row header table.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RowHeaderTableId
Visual Basic
Public Const RowHeaderTableId As String
Visual C++
public:
literal String^ RowHeaderTableId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


RowHeaderZoneId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..RowHeaderZoneId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid header zone div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RowHeaderZoneId
Visual Basic
Public Const RowHeaderZoneId As String
Visual C++
public:
literal String^ RowHeaderZoneId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


RowHeaderZoneKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..RowHeaderZoneKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid row header zone key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RowHeaderZoneKey
Visual Basic
Public Const RowHeaderZoneKey As String
Visual C++
public:
literal String^ RowHeaderZoneKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


SortButtonId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..SortButtonId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid sort button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SortButtonId
Visual Basic
Public Const SortButtonId As String
Visual C++
public:
literal String^ SortButtonId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


TableKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..TableKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid data table key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TableKey
Visual Basic
Public Const TableKey As String
Visual C++
public:
literal String^ TableKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


VerticalScrollId Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..VerticalScrollId Field
PivotGridConstants Class See Also Send Feedback
The Id ending part of the PivotGrid vertical scroll div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string VerticalScrollId
Visual Basic
Public Const VerticalScrollId As String
Visual C++
public:
literal String^ VerticalScrollId

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


ZoneKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridConstants..::..ZoneKey Field
PivotGridConstants Class See Also Send Feedback
The PivotGrid zone key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ZoneKey
Visual Basic
Public Const ZoneKey As String
Visual C++
public:
literal String^ ZoneKey

See Also

PivotGridConstants Class
Telerik.WebAii.Controls.Html Namespace


PivotGridDataCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell Members
PivotGridDataCell Class Constructors Methods Properties See Also Send Feedback

The PivotGridDataCell type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridDataCell()()()() | Initializes a new instance of the PivotGridGridDataCell class.
Public method | PivotGridDataCell(Element) | Initializes a new instance of the PivotGridGridDataCell class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this PivotGrid data cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DataCellType | Gets the Datacell type.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent row item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridDataCell Class
Telerik.WebAii.Controls.Html Namespace


PivotGridDataCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell Constructor
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PivotGridDataCell()()()() | Initializes a new instance of the PivotGridGridDataCell class.
Public method | PivotGridDataCell(Element) | Initializes a new instance of the PivotGridGridDataCell class.

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


PivotGridDataCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell Constructor
PivotGridDataCell Class See Also Send Feedback
Initializes a new instance of the PivotGridGridDataCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridDataCell()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridDataCell()

See Also

PivotGridDataCell Class
PivotGridDataCell Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridDataCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell Constructor (Element)
PivotGridDataCell Class See Also Send Feedback
Initializes a new instance of the PivotGridGridDataCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridDataCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
PivotGridDataCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridDataCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

PivotGridDataCell Class
PivotGridDataCell Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridDataCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell Methods
PivotGridDataCell Class See Also Send Feedback

The PivotGridDataCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridDataCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..AssignElement Method
PivotGridDataCell Class See Also Send Feedback
Assigns element and initializes this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

PivotGridDataCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..CallMethod Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..Capture Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..Click Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..ControlAssert Method
PivotGridDataCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

PivotGridDataCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..DragTo Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..GetValue Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..InvokeEvent Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..MouseClick Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..MouseHover Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..ScrollToVisible Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell..::..SetValue Method
PivotGridDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridDataCell Class
PivotGridDataCell Members
Telerik.WebAii.Controls.Html Namespace


PivotGridDataCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridDataCell Properties
PivotGridDataCell Class See Also Send Feedback

The PivotGridDataCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this PivotGrid data cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DataCellType | Gets the Datacell type.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent row item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridDataCell Class
Telerik.WebAii.Controls.Html Namespace


PivotGridField Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField Members
PivotGridField Class Constructors Methods Properties See Also Send Feedback

The PivotGridField type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridField()()()() | Initializes a new instance of the PivotGridField class.
Public method | PivotGridField(Element) | Initializes a new instance of the PivotGridField class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlSpan..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragDrop | Reorders this PivotGrid field.
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides this PivotGrid field.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Reorder | Reorders this PivotGrid field.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows this PivotGrid field.
Public method | Sort | Initiates a 'sort' action of the field.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanSort | Check whether field can be sorted.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the PivotGrid field. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsHidden | Gets whether the PivotGrid field is hidden.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | OwnerPivotGridId | Gets the id of the owner PivotGrid.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SortOrder | The sort order of this field.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UniqueName | The unique name of this PivotGrid field.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | ZoneIndex | The zone index of this PivotGrid field.
Public property | ZoneType | The zone type of this PivotGrid field.

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


PivotGridField Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField Constructor
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PivotGridField()()()() | Initializes a new instance of the PivotGridField class.
Public method | PivotGridField(Element) | Initializes a new instance of the PivotGridField class.

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


PivotGridField Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField Constructor
PivotGridField Class See Also Send Feedback
Initializes a new instance of the PivotGridField class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridField()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridField()

See Also

PivotGridField Class
PivotGridField Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridField Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField Constructor (Element)
PivotGridField Class See Also Send Feedback
Initializes a new instance of the PivotGridField class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridField(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
PivotGridField(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridField.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

PivotGridField Class
PivotGridField Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridField Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField Methods
PivotGridField Class See Also Send Feedback

The PivotGridField type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlSpan..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragDrop | Reorders this PivotGrid field.
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides this PivotGrid field.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Reorder | Reorders this PivotGrid field.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows this PivotGrid field.
Public method | Sort | Initiates a 'sort' action of the field.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..AssignElement Method
PivotGridField Class See Also Send Feedback
Assigns element and initializes this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..CallMethod Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..Capture Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..Click Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..ControlAssert Method
PivotGridField Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


DragDrop Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..DragDrop Method
PivotGridField Class See Also Send Feedback
Reorders this PivotGrid field.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragDrop(
    HtmlControl dropControl,
    OffsetReference offsetReference,
    Point dropPoint
)
Visual Basic
Public Sub DragDrop ( _
    dropControl As HtmlControl, _
    offsetReference As OffsetReference, _
    dropPoint As Point _
)
Visual C++
public:
void DragDrop(
    HtmlControl^ dropControl,
    OffsetReference offsetReference,
    Point dropPoint
)

Parameters

dropControl
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The control to drop to.
offsetReference
Type: ArtOfTest.Common..::..OffsetReference
The offsetReference from the srop point.
dropPoint
Type: System.Drawing..::..Point
The point to drop to.

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..DragTo Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..GetValue Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..Hide Method
PivotGridField Class See Also Send Feedback
Hides this PivotGrid field.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..InvokeEvent Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..MouseClick Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..MouseHover Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


Reorder Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..Reorder Method
PivotGridField Class See Also Send Feedback
Reorders this PivotGrid field.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool Reorder(
    PivotGridFieldZoneType zoneType,
    int zoneIndex
)
Visual Basic
Public Function Reorder ( _
    zoneType As PivotGridFieldZoneType, _
    zoneIndex As Integer _
) As Boolean
Visual C++
public:
bool Reorder(
    PivotGridFieldZoneType zoneType,
    int zoneIndex
)

Parameters

zoneType
Type: Telerik.WebAii.Controls.Html..::..PivotGridFieldZoneType
The zone type to move to.
zoneIndex
Type: System..::..Int32
The index in the zone to move to.

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridField.Reorder(Telerik.WebAii.Controls.Html.PivotGridFieldZoneType,System.Int32)"]

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..ScrollToVisible Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..SetValue Method
PivotGridField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridField Class
PivotGridField Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..Show Method
PivotGridField Class See Also Send Feedback
Shows this PivotGrid field.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


Sort Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField..::..Sort Method
PivotGridField Class See Also Send Feedback
Initiates a 'sort' action of the field.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort
Visual C++
public:
void Sort()

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


PivotGridField Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridField Properties
PivotGridField Class See Also Send Feedback

The PivotGridField type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanSort | Check whether field can be sorted.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the PivotGrid field. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsHidden | Gets whether the PivotGrid field is hidden.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | OwnerPivotGridId | Gets the id of the owner PivotGrid.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SortOrder | The sort order of this field.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UniqueName | The unique name of this PivotGrid field.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | ZoneIndex | The zone index of this PivotGrid field.
Public property | ZoneType | The zone type of this PivotGrid field.

See Also

PivotGridField Class
Telerik.WebAii.Controls.Html Namespace


PivotGridPager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager Members
PivotGridPager Class Constructors Methods Properties See Also Send Feedback

The PivotGridPager type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridPager()()()() | Initializes a new instance of the PivotGridPager class.
Public method | PivotGridPager(Element) | Initializes a new instance of the PivotGridPager class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangePageSize | The Advanced Pager 'ChangePageSize' action.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GoToPage | The Advanced Pager 'GoToPage' action.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LoadFirstPage | Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.
Public method | LoadLastPage | Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.
Public method | LoadNextPage | Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.
Public method | LoadNextPages | Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.
Public method | LoadPage | Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.
Public method | LoadPreviousPage | Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.
Public method | LoadPreviousPages | Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


PivotGridPager Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager Constructor
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PivotGridPager()()()() | Initializes a new instance of the PivotGridPager class.
Public method | PivotGridPager(Element) | Initializes a new instance of the PivotGridPager class.

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


PivotGridPager Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager Constructor
PivotGridPager Class See Also Send Feedback
Initializes a new instance of the PivotGridPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridPager()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridPager()

See Also

PivotGridPager Class
PivotGridPager Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridPager Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager Constructor (Element)
PivotGridPager Class See Also Send Feedback
Initializes a new instance of the PivotGridPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridPager(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
PivotGridPager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridPager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

PivotGridPager Class
PivotGridPager Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridPager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager Methods
PivotGridPager Class See Also Send Feedback

The PivotGridPager type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangePageSize | The Advanced Pager 'ChangePageSize' action.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GoToPage | The Advanced Pager 'GoToPage' action.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LoadFirstPage | Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.
Public method | LoadLastPage | Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.
Public method | LoadNextPage | Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.
Public method | LoadNextPages | Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.
Public method | LoadPage | Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.
Public method | LoadPreviousPage | Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.
Public method | LoadPreviousPages | Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..AssignElement Method
PivotGridPager Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..CallMethod Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..Capture Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


ChangePageSize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..ChangePageSize Method
PivotGridPager Class See Also Send Feedback
The Advanced Pager 'ChangePageSize' action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ChangePageSize()
Visual Basic
Public Sub ChangePageSize
Visual C++
public:
void ChangePageSize()

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..Click Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..ControlAssert Method
PivotGridPager Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..DragTo Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..GetValue Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


GoToPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..GoToPage Method
PivotGridPager Class See Also Send Feedback
The Advanced Pager 'GoToPage' action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void GoToPage()
Visual Basic
Public Sub GoToPage
Visual C++
public:
void GoToPage()

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..InvokeEvent Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


LoadFirstPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..LoadFirstPage Method
PivotGridPager Class See Also Send Feedback
Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadFirstPage()
Visual Basic
Public Sub LoadFirstPage
Visual C++
public:
void LoadFirstPage()

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadLastPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..LoadLastPage Method
PivotGridPager Class See Also Send Feedback
Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadLastPage()
Visual Basic
Public Sub LoadLastPage
Visual C++
public:
void LoadLastPage()

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadNextPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..LoadNextPage Method
PivotGridPager Class See Also Send Feedback
Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadNextPage()
Visual Basic
Public Sub LoadNextPage
Visual C++
public:
void LoadNextPage()

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadNextPages Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..LoadNextPages Method
PivotGridPager Class See Also Send Feedback
Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadNextPages()
Visual Basic
Public Sub LoadNextPages
Visual C++
public:
void LoadNextPages()

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..LoadPage Method
PivotGridPager Class See Also Send Feedback
Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPage(
    int pageNumber
)
Visual Basic
Public Sub LoadPage ( _
    pageNumber As Integer _
)
Visual C++
public:
void LoadPage(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
The number of the page to be loaded.

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPreviousPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..LoadPreviousPage Method
PivotGridPager Class See Also Send Feedback
Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPreviousPage()
Visual Basic
Public Sub LoadPreviousPage
Visual C++
public:
void LoadPreviousPage()

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPreviousPages Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..LoadPreviousPages Method
PivotGridPager Class See Also Send Feedback
Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPreviousPages()
Visual Basic
Public Sub LoadPreviousPages
Visual C++
public:
void LoadPreviousPages()

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..MouseClick Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..MouseHover Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..ScrollToVisible Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager..::..SetValue Method
PivotGridPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridPager Class
PivotGridPager Members
Telerik.WebAii.Controls.Html Namespace


PivotGridPager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridPager Properties
PivotGridPager Class See Also Send Feedback

The PivotGridPager type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

PivotGridPager Class
Telerik.WebAii.Controls.Html Namespace


PivotGridRowHeaderCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell Members
PivotGridRowHeaderCell Class Constructors Methods Properties See Also Send Feedback

The PivotGridRowHeaderCell type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridRowHeaderCell()()()() | Initializes a new instance of the PivotGridRowHeaderCell class.
Public method | PivotGridRowHeaderCell(Element) | Initializes a new instance of the PivotGridRowHeaderCell class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Initiates a 'collapse' action of the header.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Initiates a 'expand' action of the header.
Public method | ExpandCollapse | Initiates a 'expand/collapse' action of the header.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanExpandCollapse | Gets whether this row cell can expand/collapse.
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this PivotGrid row header cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Gets whether this row cell can expand/collapse.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HeaderCellType | Gets the RowHeaderCell type.
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent row item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridRowHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


PivotGridRowHeaderCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell Constructor
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PivotGridRowHeaderCell()()()() | Initializes a new instance of the PivotGridRowHeaderCell class.
Public method | PivotGridRowHeaderCell(Element) | Initializes a new instance of the PivotGridRowHeaderCell class.

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


PivotGridRowHeaderCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell Constructor
PivotGridRowHeaderCell Class See Also Send Feedback
Initializes a new instance of the PivotGridRowHeaderCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridRowHeaderCell()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridRowHeaderCell()

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridRowHeaderCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell Constructor (Element)
PivotGridRowHeaderCell Class See Also Send Feedback
Initializes a new instance of the PivotGridRowHeaderCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridRowHeaderCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
PivotGridRowHeaderCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridRowHeaderCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridRowHeaderCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell Methods
PivotGridRowHeaderCell Class See Also Send Feedback

The PivotGridRowHeaderCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Initiates a 'collapse' action of the header.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Initiates a 'expand' action of the header.
Public method | ExpandCollapse | Initiates a 'expand/collapse' action of the header.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridRowHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..AssignElement Method
PivotGridRowHeaderCell Class See Also Send Feedback
Assigns element and initializes this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

PivotGridRowHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..CallMethod Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..Capture Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..Click Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..Collapse Method
PivotGridRowHeaderCell Class See Also Send Feedback
Initiates a 'collapse' action of the header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

PivotGridRowHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..ControlAssert Method
PivotGridRowHeaderCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

PivotGridRowHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..DragTo Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..Expand Method
PivotGridRowHeaderCell Class See Also Send Feedback
Initiates a 'expand' action of the header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

PivotGridRowHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


ExpandCollapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..ExpandCollapse Method
PivotGridRowHeaderCell Class See Also Send Feedback
Initiates a 'expand/collapse' action of the header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ExpandCollapse(
    bool click
)
Visual Basic
Public Sub ExpandCollapse ( _
    click As Boolean _
)
Visual C++
public:
void ExpandCollapse(
    bool click
)

Parameters

click
Type: System..::..Boolean

[Missing <param name="click"/> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridRowHeaderCell.ExpandCollapse(System.Boolean)"]

See Also

PivotGridRowHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..GetValue Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..InvokeEvent Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..MouseClick Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..MouseHover Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..ScrollToVisible Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell..::..SetValue Method
PivotGridRowHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridRowHeaderCell Class
PivotGridRowHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


PivotGridRowHeaderCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowHeaderCell Properties
PivotGridRowHeaderCell Class See Also Send Feedback

The PivotGridRowHeaderCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanExpandCollapse | Gets whether this row cell can expand/collapse.
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this PivotGrid row header cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Gets whether this row cell can expand/collapse.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HeaderCellType | Gets the RowHeaderCell type.
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent row item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridRowHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


PivotGridRowsZone Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone Members
PivotGridRowsZone Class Constructors Methods Fields Properties See Also Send Feedback

The PivotGridRowsZone type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridRowsZone | Initializes a new instance of the PivotGridRowsZone class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides PivotGridZone..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from PivotGridZone.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeCellLocator | Initializes the element locator for this control. (Overrides PivotGridZone..::..InitializeCellLocator()()()().)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Fields

 | Name | Description
Public field | cellLocator | Zone locator pattern. (Inherited from PivotGridZone.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Fields | A list containing all the fields in the zone. (Inherited from PivotGridZone.)
Public property | FieldsCount | The count of the fields in the zone. (Inherited from PivotGridZone.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | The index of the cell in the containing row.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Inherited from PivotGridZone.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridRowsZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridRowsZone Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone Constructor
PivotGridRowsZone Class See Also Send Feedback
Initializes a new instance of the PivotGridRowsZone class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridRowsZone()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridRowsZone()

See Also

PivotGridRowsZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridRowsZone Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone Fields
PivotGridRowsZone Class See Also Send Feedback

The PivotGridRowsZone type exposes the following members.

Fields

 | Name | Description
Public field | cellLocator | Zone locator pattern. (Inherited from PivotGridZone.)

See Also

PivotGridRowsZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridRowsZone Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone Methods
PivotGridRowsZone Class See Also Send Feedback

The PivotGridRowsZone type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides PivotGridZone..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from PivotGridZone.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeCellLocator | Initializes the element locator for this control. (Overrides PivotGridZone..::..InitializeCellLocator()()()().)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridRowsZone Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..AssignElement Method
PivotGridRowsZone Class See Also Send Feedback
Assigns element and initializes this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

PivotGridRowsZone Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..CallMethod Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..Capture Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..Click Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..DragTo Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..GetValue Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


InitializeCellLocator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..InitializeCellLocator Method
PivotGridRowsZone Class See Also Send Feedback
Initializes the element locator for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
protected override void InitializeCellLocator()
Visual Basic
Protected Overrides Sub InitializeCellLocator
Visual C++
protected:
virtual void InitializeCellLocator() override

See Also

PivotGridRowsZone Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..InvokeEvent Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..MouseClick Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..MouseHover Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..ScrollToVisible Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone..::..SetValue Method
PivotGridRowsZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridRowsZone Class
PivotGridRowsZone Members
Telerik.WebAii.Controls.Html Namespace


PivotGridRowsZone Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridRowsZone Properties
PivotGridRowsZone Class See Also Send Feedback

The PivotGridRowsZone type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Fields | A list containing all the fields in the zone. (Inherited from PivotGridZone.)
Public property | FieldsCount | The count of the fields in the zone. (Inherited from PivotGridZone.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | The index of the cell in the containing row.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Inherited from PivotGridZone.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridRowsZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridZone Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone Members
PivotGridZone Class Constructors Methods Fields Properties See Also Send Feedback

The PivotGridZone type exposes the following members.

Constructors

 | Name | Description
Public method | PivotGridZone()()()() | Initializes a new instance of the PivotGridZone class.
Public method | PivotGridZone(Element) | Initializes a new instance of the PivotGridZone class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeCellLocator | Initializes the element locator for this control.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Fields

 | Name | Description
Public field | cellLocator | Zone locator pattern.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Fields | A list containing all the fields in the zone.
Public property | FieldsCount | The count of the fields in the zone.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridZone Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone Constructor
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PivotGridZone()()()() | Initializes a new instance of the PivotGridZone class.
Public method | PivotGridZone(Element) | Initializes a new instance of the PivotGridZone class.

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


PivotGridZone Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone Constructor
PivotGridZone Class See Also Send Feedback
Initializes a new instance of the PivotGridZone class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridZone()
Visual Basic
Public Sub New
Visual C++
public:
PivotGridZone()

See Also

PivotGridZone Class
PivotGridZone Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridZone Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone Constructor (Element)
PivotGridZone Class See Also Send Feedback
Initializes a new instance of the PivotGridZone class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public PivotGridZone(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
PivotGridZone(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.PivotGridZone.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

PivotGridZone Class
PivotGridZone Overload
Telerik.WebAii.Controls.Html Namespace


PivotGridZone Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone Fields
PivotGridZone Class See Also Send Feedback

The PivotGridZone type exposes the following members.

Fields

 | Name | Description
Public field | cellLocator | Zone locator pattern.

See Also

PivotGridZone Class
Telerik.WebAii.Controls.Html Namespace


cellLocator Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..cellLocator Field
PivotGridZone Class See Also Send Feedback
Zone locator pattern.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public HtmlFindExpression cellLocator
Visual Basic
Public cellLocator As HtmlFindExpression
Visual C++
public:
HtmlFindExpression^ cellLocator

See Also

PivotGridZone Class
Telerik.WebAii.Controls.Html Namespace


PivotGridZone Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone Methods
PivotGridZone Class See Also Send Feedback

The PivotGridZone type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeCellLocator | Initializes the element locator for this control.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

PivotGridZone Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..AssignElement Method
PivotGridZone Class See Also Send Feedback
Assigns element and initializes this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

PivotGridZone Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..CallMethod Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..Capture Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..Click Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..ControlAssert Method
PivotGridZone Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

PivotGridZone Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..DragTo Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..GetValue Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


InitializeCellLocator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..InitializeCellLocator Method
PivotGridZone Class See Also Send Feedback
Initializes the element locator for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
protected abstract void InitializeCellLocator()
Visual Basic
Protected MustOverride Sub InitializeCellLocator
Visual C++
protected:
virtual void InitializeCellLocator() abstract

See Also

PivotGridZone Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..InvokeEvent Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..MouseClick Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..MouseHover Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..ScrollToVisible Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone..::..SetValue Method
PivotGridZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

PivotGridZone Class
PivotGridZone Members
Telerik.WebAii.Controls.Html Namespace


PivotGridZone Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
PivotGridZone Properties
PivotGridZone Class See Also Send Feedback

The PivotGridZone type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Fields | A list containing all the fields in the zone.
Public property | FieldsCount | The count of the fields in the zone.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

PivotGridZone Class
Telerik.WebAii.Controls.Html Namespace


RadAsyncUpload Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload Members
RadAsyncUpload Class Constructors Methods Properties See Also Send Feedback

The RadAsyncUpload type exposes the following members.

Constructors

 | Name | Description
Public method | RadAsyncUpload()()()() | Initializes a new instance of the RadAsyncUpload class.
Public method | RadAsyncUpload(Element) | Initializes a new instance of the RadAsyncUpload class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadAsyncUpload control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | ButtonClick | Clicks the remove button of file with the specified index.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileSelect | Selects the file by specifid index.
Public method | FileWithIndexUploadedSuccessfully | Returns whether async upload successfuly uploaded a file with specified index.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InlineProgressShownForFile | Returns whether async upload inline progress is shown for file with specified index.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NameOfTheFileWithIndex | Returns the name of the uploaded file with spesific index.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Upload | Upload a file.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FileExtensions | Returns an array containing the allowed file extensions.
Public property | FileExtensionsString | Returns a string containing the allowed file extensions.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HasProgressArea | Returns whether async upload has progress area.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InitialFileInputCount | Returns the initial number of rows when the RadUpload control is first loaded..
Public property | InlineProgressEnabled | Returns whether async upload inline progress is enabled.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsUploading | Returns whether async upload is uploading file.
Public property | ListContainer | Returns async upload input unordered list.
Public property | ListItems | Returns async upload input file controls.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a RadUploadHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | ModuleName | Current async upload module.
Public property | MultipleFileSelection | Returns whether async upload multiple file selection is enabled.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ProgressAreaVisible | Returns whether async upload progress area is visible.
Public property | RemoveButton | Returns upload remove button.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectButton | Returns upload select button.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UploadDialogTitle | Returns the FileUpload dialog title.
Public property | UploadedFilesCount | Returns async upload uploaded files.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


RadAsyncUpload Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload Constructor
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadAsyncUpload()()()() | Initializes a new instance of the RadAsyncUpload class.
Public method | RadAsyncUpload(Element) | Initializes a new instance of the RadAsyncUpload class.

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


RadAsyncUpload Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload Constructor
RadAsyncUpload Class See Also Send Feedback
Initializes a new instance of the RadAsyncUpload class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadAsyncUpload()
Visual Basic
Public Sub New
Visual C++
public:
RadAsyncUpload()

See Also

RadAsyncUpload Class
RadAsyncUpload Overload
Telerik.WebAii.Controls.Html Namespace


RadAsyncUpload Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload Constructor (Element)
RadAsyncUpload Class See Also Send Feedback
Initializes a new instance of the RadAsyncUpload class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadAsyncUpload(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadAsyncUpload(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadAsyncUpload Class
RadAsyncUpload Overload
Telerik.WebAii.Controls.Html Namespace


RadAsyncUpload Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload Methods
RadAsyncUpload Class See Also Send Feedback

The RadAsyncUpload type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadAsyncUpload control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | ButtonClick | Clicks the remove button of file with the specified index.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileSelect | Selects the file by specifid index.
Public method | FileWithIndexUploadedSuccessfully | Returns whether async upload successfuly uploaded a file with specified index.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InlineProgressShownForFile | Returns whether async upload inline progress is shown for file with specified index.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NameOfTheFileWithIndex | Returns the name of the uploaded file with spesific index.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Upload | Upload a file.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..AssignElement Method
RadAsyncUpload Class See Also Send Feedback
Assign the DOM element to be the RadAsyncUpload control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


ButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..ButtonClick Method
RadAsyncUpload Class See Also Send Feedback
Clicks the remove button of file with the specified index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ButtonClick(
    int index
)
Visual Basic
Public Sub ButtonClick ( _
    index As Integer _
)
Visual C++
public:
void ButtonClick(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.ButtonClick(System.Int32)"]

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..CallMethod Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..Capture Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..Click Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..ControlAssert Method
RadAsyncUpload Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..DragTo Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


FileSelect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..FileSelect Method
RadAsyncUpload Class See Also Send Feedback
Selects the file by specifid index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FileSelect(
    int index
)
Visual Basic
Public Sub FileSelect ( _
    index As Integer _
)
Visual C++
public:
void FileSelect(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.FileSelect(System.Int32)"]

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


FileWithIndexUploadedSuccessfully Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..FileWithIndexUploadedSuccessfully Method
RadAsyncUpload Class See Also Send Feedback
Returns whether async upload successfuly uploaded a file with specified index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool FileWithIndexUploadedSuccessfully(
    int index
)
Visual Basic
Public Function FileWithIndexUploadedSuccessfully ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool FileWithIndexUploadedSuccessfully(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.FileWithIndexUploadedSuccessfully(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.FileWithIndexUploadedSuccessfully(System.Int32)"]

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..GetValue Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


InlineProgressShownForFile Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..InlineProgressShownForFile Method
RadAsyncUpload Class See Also Send Feedback
Returns whether async upload inline progress is shown for file with specified index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool InlineProgressShownForFile(
    int index
)
Visual Basic
Public Function InlineProgressShownForFile ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool InlineProgressShownForFile(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.InlineProgressShownForFile(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.InlineProgressShownForFile(System.Int32)"]

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..InvokeEvent Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..MouseClick Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..MouseHover Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


NameOfTheFileWithIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..NameOfTheFileWithIndex Method
RadAsyncUpload Class See Also Send Feedback
Returns the name of the uploaded file with spesific index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public string NameOfTheFileWithIndex(
    int index
)
Visual Basic
Public Function NameOfTheFileWithIndex ( _
    index As Integer _
) As String
Visual C++
public:
String^ NameOfTheFileWithIndex(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.NameOfTheFileWithIndex(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.NameOfTheFileWithIndex(System.Int32)"]

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..ScrollToVisible Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..SetValue Method
RadAsyncUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
RadAsyncUpload Members
Telerik.WebAii.Controls.Html Namespace


Upload Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload..::..Upload Method
RadAsyncUpload Class See Also Send Feedback
Upload a file.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Upload(
    int index,
    string filePath
)
Visual Basic
Public Sub Upload ( _
    index As Integer, _
    filePath As String _
)
Visual C++
public:
void Upload(
    int index,
    String^ filePath
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.Upload(System.Int32,System.String)"]

filePath
Type: System..::..String

[Missing <param name="filePath"/> documentation for "M:Telerik.WebAii.Controls.Html.RadAsyncUpload.Upload(System.Int32,System.String)"]

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


RadAsyncUpload Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadAsyncUpload Properties
RadAsyncUpload Class See Also Send Feedback

The RadAsyncUpload type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FileExtensions | Returns an array containing the allowed file extensions.
Public property | FileExtensionsString | Returns a string containing the allowed file extensions.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HasProgressArea | Returns whether async upload has progress area.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InitialFileInputCount | Returns the initial number of rows when the RadUpload control is first loaded..
Public property | InlineProgressEnabled | Returns whether async upload inline progress is enabled.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsUploading | Returns whether async upload is uploading file.
Public property | ListContainer | Returns async upload input unordered list.
Public property | ListItems | Returns async upload input file controls.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a RadUploadHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | ModuleName | Current async upload module.
Public property | MultipleFileSelection | Returns whether async upload multiple file selection is enabled.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ProgressAreaVisible | Returns whether async upload progress area is visible.
Public property | RemoveButton | Returns upload remove button.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectButton | Returns upload select button.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UploadDialogTitle | Returns the FileUpload dialog title.
Public property | UploadedFilesCount | Returns async upload uploaded files.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadAsyncUpload Class
Telerik.WebAii.Controls.Html Namespace


RadButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton Members
RadButton Class Constructors Methods Properties See Also Send Feedback

The RadButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadButton()()()() | Initializes a new instance of the RadButton class.
Public method | RadButton(Element) | Initializes a new instance of the RadButton class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ClearCheckedState | Clears the checked state of the Radio buttons with the specified GroupName.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Gets or sets the auto postback enabled value of the button.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonGroup | Gets the RadButton Group name.
Public property | ButtonText | Gets or sets the RadButton text value.
Public property | ButtonToggleStateText | Gets or sets the RadButton Toggle State text value.
Public property | ButtonToggleType | Gets the Button control toggle type - None, CheckBox, RadioButton, CustomToggleButton.
Public property | ButtonType | Gets the Button control type - StandardButton, LinkButton, ToggleButton.
Public property | Checked | Gets or sets whether the Button is checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the button control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Gets or sets whether the Button is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Returns whether the button is focused.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsImageButton | Gets a bool value indicating whether the button is an image button.
Public property | IsInputTypeSubmit | Gets a bool value indicating whether the button is a submit button.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsSplitButton | Specifies whether the Split Button functionality is Enabled/Disabled.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Gets or sets the URL to link to when RadButton control is clicked.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PrimaryIconElement | Gets a reference to the HTML element that holds the primary icon.
Public property | ReadOnly | Gets or sets whether the button is in ReadOnly mode.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SecondaryIconElement | Gets a reference to the HTML element that holds the secondary icon.
Public property | SelectedToggleStateIndex | Returns the index of the selected toggle state.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Public property | TextElement | Gets a reference to the HTML element that holds the text of the RadButton control.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadButton Class
Telerik.WebAii.Controls.Html Namespace


RadButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton Constructor
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadButton()()()() | Initializes a new instance of the RadButton class.
Public method | RadButton(Element) | Initializes a new instance of the RadButton class.

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


RadButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton Constructor
RadButton Class See Also Send Feedback
Initializes a new instance of the RadButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadButton()
Visual Basic
Public Sub New
Visual C++
public:
RadButton()

See Also

RadButton Class
RadButton Overload
Telerik.WebAii.Controls.Html Namespace


RadButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton Constructor (Element)
RadButton Class See Also Send Feedback
Initializes a new instance of the RadButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadButton Class
RadButton Overload
Telerik.WebAii.Controls.Html Namespace


RadButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton Methods
RadButton Class See Also Send Feedback

The RadButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ClearCheckedState | Clears the checked state of the Radio buttons with the specified GroupName.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..AssignElement Method
RadButton Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..CallMethod Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..Capture Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


ClearCheckedState Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..ClearCheckedState Method
RadButton Class See Also Send Feedback
Clears the checked state of the Radio buttons with the specified GroupName.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClearCheckedState(
    string groupName
)
Visual Basic
Public Sub ClearCheckedState ( _
    groupName As String _
)
Visual C++
public:
void ClearCheckedState(
    String^ groupName
)

Parameters

groupName
Type: System..::..String
The group name that the buttons belong to.

See Also

RadButton Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..Click Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..ControlAssert Method
RadButton Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadButton Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..DragTo Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..GetValue Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..InvokeEvent Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..MouseClick Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..MouseHover Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..ScrollToVisible Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton..::..SetValue Method
RadButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadButton Class
RadButton Members
Telerik.WebAii.Controls.Html Namespace


RadButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadButton Properties
RadButton Class See Also Send Feedback

The RadButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Gets or sets the auto postback enabled value of the button.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonGroup | Gets the RadButton Group name.
Public property | ButtonText | Gets or sets the RadButton text value.
Public property | ButtonToggleStateText | Gets or sets the RadButton Toggle State text value.
Public property | ButtonToggleType | Gets the Button control toggle type - None, CheckBox, RadioButton, CustomToggleButton.
Public property | ButtonType | Gets the Button control type - StandardButton, LinkButton, ToggleButton.
Public property | Checked | Gets or sets whether the Button is checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the button control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Gets or sets whether the Button is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Returns whether the button is focused.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsImageButton | Gets a bool value indicating whether the button is an image button.
Public property | IsInputTypeSubmit | Gets a bool value indicating whether the button is a submit button.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsSplitButton | Specifies whether the Split Button functionality is Enabled/Disabled.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Gets or sets the URL to link to when RadButton control is clicked.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PrimaryIconElement | Gets a reference to the HTML element that holds the primary icon.
Public property | ReadOnly | Gets or sets whether the button is in ReadOnly mode.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SecondaryIconElement | Gets a reference to the HTML element that holds the secondary icon.
Public property | SelectedToggleStateIndex | Returns the index of the selected toggle state.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Public property | TextElement | Gets a reference to the HTML element that holds the text of the RadButton control.
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadButton Class
Telerik.WebAii.Controls.Html Namespace


RadCalendar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar Members
RadCalendar Class Constructors Methods Properties See Also Send Feedback

The RadCalendar type exposes the following members.

Constructors

 | Name | Description
Public method | RadCalendar()()()() | Initializes a new instance of the RadCalendar class.
Public method | RadCalendar(Element) | Initializes a new instance of the RadCalendar class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ColumnHeaderClick | Clicks on the header of a column.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FastNext | Clicks the FastNextMonth navigation link.
Public method | FastPrevious | Clicks the FastPreviousMonth navigation link.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NavigateToDate(DateTime) | Navigates the Calendar to a specific date.
Public method | NavigateToDate(Int32, Int32, Int32) | Navigates the Calendar to a specific date.
Public method | Next | Clicks the NextMonth navigation link.
Public method | OpenFastNavigation | Opens the FastNavigation Popup.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Previous | Clicks the PreviousMonth navigation link.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | RowHeaderClick | Clicks on the header of a row.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectDate(DateTime) | Select a date in the Calendar.
Public method | SelectDate(String) | Selects a date in the Calendar.
Public method | SelectDate(DateTime, String) | Select a date in the Calendar.
Public method | SelectDate(String, String) | Select a date in the Calendar.
Public method | SelectDate(DateTime, String, Boolean) | Select a date in the Calendar.
Public method | SelectDate(String, String, Boolean) | Selects a date in the Calendar.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Public method | ViewSelectorClick | Clicks on the ViewSelector.

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Check whether autopostback is enabled.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the RadCalendar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Get the culture which is used by the calendar.
Public property | EnableMonthYearFastNavigation | Whether the FastNavigation is enabled.
Public property | EnableMultiSelect | Check whether multi date selection is enabled.
Public property | EnableViewSelector | Returns the value of the EnableViewSelector property.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FastNavigationStep | Get the step for fast navigation.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Get the focused date.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsMultiMonth | Whether the calendar is in multi month display mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MultiMonthCount | The number of the displayed months in multi-month view.
Public property | MultiViewColumns | The number of columns displayed in MutiMonthView mode.
Public property | MultiViewRows | The number of rowsdisplayed in MutiMonthView mode.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PopupVisible | Whether the popup is visible.
Public property | PresentationType | Get the calendar presentation type.
Public property | RangeMaxDate | Get RangeMaxDate.
Public property | RangeMinDate | Get RangeMinDate.
Public property | RangeSelectionMode | Get the calendar range selection mode.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDates | Get Calendar selected dates.
Public property | SingleViewColumnsCount | Get the number of columns in the single month view of the Calendar.
Public property | SingleViewRowsCount | Get the number of rows in the single month view of the Calendar.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TitleText | The title text of the Calendar.
Public property | UseColumnHeadersAsSelectors | Whether the column headers can be used to select the dates in the respective column.
Public property | UseRowHeadersAsSelectors | Whether the row headers can be used to select the dates in the respective row.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RadCalendar Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar Constructor
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadCalendar()()()() | Initializes a new instance of the RadCalendar class.
Public method | RadCalendar(Element) | Initializes a new instance of the RadCalendar class.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


RadCalendar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar Constructor
RadCalendar Class See Also Send Feedback
Initializes a new instance of the RadCalendar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadCalendar()
Visual Basic
Public Sub New
Visual C++
public:
RadCalendar()

See Also

RadCalendar Class
RadCalendar Overload
Telerik.WebAii.Controls.Html Namespace


RadCalendar Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar Constructor (Element)
RadCalendar Class See Also Send Feedback
Initializes a new instance of the RadCalendar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadCalendar(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadCalendar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadCalendar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadCalendar Class
RadCalendar Overload
Telerik.WebAii.Controls.Html Namespace


RadCalendar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar Methods
RadCalendar Class See Also Send Feedback

The RadCalendar type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ColumnHeaderClick | Clicks on the header of a column.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FastNext | Clicks the FastNextMonth navigation link.
Public method | FastPrevious | Clicks the FastPreviousMonth navigation link.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NavigateToDate(DateTime) | Navigates the Calendar to a specific date.
Public method | NavigateToDate(Int32, Int32, Int32) | Navigates the Calendar to a specific date.
Public method | Next | Clicks the NextMonth navigation link.
Public method | OpenFastNavigation | Opens the FastNavigation Popup.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Previous | Clicks the PreviousMonth navigation link.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | RowHeaderClick | Clicks on the header of a row.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectDate(DateTime) | Select a date in the Calendar.
Public method | SelectDate(String) | Selects a date in the Calendar.
Public method | SelectDate(DateTime, String) | Select a date in the Calendar.
Public method | SelectDate(String, String) | Select a date in the Calendar.
Public method | SelectDate(DateTime, String, Boolean) | Select a date in the Calendar.
Public method | SelectDate(String, String, Boolean) | Selects a date in the Calendar.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Public method | ViewSelectorClick | Clicks on the ViewSelector.

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..AssignElement Method
RadCalendar Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..CallMethod Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..Capture Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..Click Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


ColumnHeaderClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..ColumnHeaderClick Method
RadCalendar Class See Also Send Feedback
Clicks on the header of a column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ColumnHeaderClick(
    string dayOfWeek
)
Visual Basic
Public Sub ColumnHeaderClick ( _
    dayOfWeek As String _
)
Visual C++
public:
void ColumnHeaderClick(
    String^ dayOfWeek
)

Parameters

dayOfWeek
Type: System..::..String
The day of week.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..ControlAssert Method
RadCalendar Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..DragTo Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


FastNext Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..FastNext Method
RadCalendar Class See Also Send Feedback
Clicks the FastNextMonth navigation link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FastNext()
Visual Basic
Public Sub FastNext
Visual C++
public:
void FastNext()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


FastPrevious Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..FastPrevious Method
RadCalendar Class See Also Send Feedback
Clicks the FastPreviousMonth navigation link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FastPrevious()
Visual Basic
Public Sub FastPrevious
Visual C++
public:
void FastPrevious()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..GetValue Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..InvokeEvent Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..MouseClick Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..MouseHover Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


NavigateToDate Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..NavigateToDate Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NavigateToDate(DateTime) | Navigates the Calendar to a specific date.
Public method | NavigateToDate(Int32, Int32, Int32) | Navigates the Calendar to a specific date.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


NavigateToDate Method (DateTime)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..NavigateToDate Method (DateTime)
RadCalendar Class See Also Send Feedback
Navigates the Calendar to a specific date.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NavigateToDate(
    DateTime dateToNavigate
)
Visual Basic
Public Sub NavigateToDate ( _
    dateToNavigate As DateTime _
)
Visual C++
public:
void NavigateToDate(
    DateTime dateToNavigate
)

Parameters

dateToNavigate
Type: System..::..DateTime
The date to navigate to.

See Also

RadCalendar Class
NavigateToDate Overload
Telerik.WebAii.Controls.Html Namespace


NavigateToDate Method (Int32, Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..NavigateToDate Method (Int32, Int32, Int32)
RadCalendar Class See Also Send Feedback
Navigates the Calendar to a specific date.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NavigateToDate(
    int year,
    int month,
    int day
)
Visual Basic
Public Sub NavigateToDate ( _
    year As Integer, _
    month As Integer, _
    day As Integer _
)
Visual C++
public:
void NavigateToDate(
    int year,
    int month,
    int day
)

Parameters

year
Type: System..::..Int32
The integer representing the Year part of the date.
month
Type: System..::..Int32
The integer representing the Month part of the date.
day
Type: System..::..Int32
The integer representig the Day part of the date.

See Also

RadCalendar Class
NavigateToDate Overload
Telerik.WebAii.Controls.Html Namespace


Next Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..Next Method
RadCalendar Class See Also Send Feedback
Clicks the NextMonth navigation link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Next()
Visual Basic
Public Sub Next
Visual C++
public:
void Next()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


OpenFastNavigation Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..OpenFastNavigation Method
RadCalendar Class See Also Send Feedback
Opens the FastNavigation Popup.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenFastNavigation()
Visual Basic
Public Sub OpenFastNavigation
Visual C++
public:
void OpenFastNavigation()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


Previous Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..Previous Method
RadCalendar Class See Also Send Feedback
Clicks the PreviousMonth navigation link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Previous()
Visual Basic
Public Sub Previous
Visual C++
public:
void Previous()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RowHeaderClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..RowHeaderClick Method
RadCalendar Class See Also Send Feedback
Clicks on the header of a row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void RowHeaderClick(
    int weekNumber
)
Visual Basic
Public Sub RowHeaderClick ( _
    weekNumber As Integer _
)
Visual C++
public:
void RowHeaderClick(
    int weekNumber
)

Parameters

weekNumber
Type: System..::..Int32

[Missing <param name="weekNumber"/> documentation for "M:Telerik.WebAii.Controls.Html.RadCalendar.RowHeaderClick(System.Int32)"]

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..ScrollToVisible Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


SelectDate Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..SelectDate Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectDate(DateTime) | Select a date in the Calendar.
Public method | SelectDate(String) | Selects a date in the Calendar.
Public method | SelectDate(DateTime, String) | Select a date in the Calendar.
Public method | SelectDate(String, String) | Select a date in the Calendar.
Public method | SelectDate(DateTime, String, Boolean) | Select a date in the Calendar.
Public method | SelectDate(String, String, Boolean) | Selects a date in the Calendar.

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (DateTime)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..SelectDate Method (DateTime)
RadCalendar Class See Also Send Feedback
Select a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectDate(
    DateTime selectedDate
)
Visual Basic
Public Sub SelectDate ( _
    selectedDate As DateTime _
)
Visual C++
public:
void SelectDate(
    DateTime selectedDate
)

Parameters

selectedDate
Type: System..::..DateTime
The date to be selected.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..SelectDate Method (String)
RadCalendar Class See Also Send Feedback
Selects a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectDate(
    string dateTimeValue
)
Visual Basic
Public Sub SelectDate ( _
    dateTimeValue As String _
)
Visual C++
public:
void SelectDate(
    String^ dateTimeValue
)

Parameters

dateTimeValue
Type: System..::..String
The date to be selected.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (DateTime, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..SelectDate Method (DateTime, String)
RadCalendar Class See Also Send Feedback
Select a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectDate(
    DateTime selectedDate,
    string currentCalendarCulture
)
Visual Basic
Public Sub SelectDate ( _
    selectedDate As DateTime, _
    currentCalendarCulture As String _
)
Visual C++
public:
void SelectDate(
    DateTime selectedDate,
    String^ currentCalendarCulture
)

Parameters

selectedDate
Type: System..::..DateTime
The date to be selected.
currentCalendarCulture
Type: System..::..String
The current culture.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..SelectDate Method (String, String)
RadCalendar Class See Also Send Feedback
Select a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectDate(
    string dateTimeValue,
    string currentCalendarCulture
)
Visual Basic
Public Sub SelectDate ( _
    dateTimeValue As String, _
    currentCalendarCulture As String _
)
Visual C++
public:
void SelectDate(
    String^ dateTimeValue,
    String^ currentCalendarCulture
)

Parameters

dateTimeValue
Type: System..::..String
The date to be selected.
currentCalendarCulture
Type: System..::..String
The current culture.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (DateTime, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..SelectDate Method (DateTime, String, Boolean)
RadCalendar Class See Also Send Feedback
Select a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectDate(
    DateTime selectedDate,
    string currentCalendarCulture,
    bool isRangeSelection
)
Visual Basic
Public Sub SelectDate ( _
    selectedDate As DateTime, _
    currentCalendarCulture As String, _
    isRangeSelection As Boolean _
)
Visual C++
public:
void SelectDate(
    DateTime selectedDate,
    String^ currentCalendarCulture,
    bool isRangeSelection
)

Parameters

selectedDate
Type: System..::..DateTime
The date to be selected.
currentCalendarCulture
Type: System..::..String
The current culture.
isRangeSelection
Type: System..::..Boolean
Whether range selection is performed. If set to 'true' the method internally presses the 'shift' key when selecting.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SelectDate Method (String, String, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..SelectDate Method (String, String, Boolean)
RadCalendar Class See Also Send Feedback
Selects a date in the Calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectDate(
    string dateTimeValue,
    string currentCalendarCulture,
    bool isRangeSelection
)
Visual Basic
Public Sub SelectDate ( _
    dateTimeValue As String, _
    currentCalendarCulture As String, _
    isRangeSelection As Boolean _
)
Visual C++
public:
void SelectDate(
    String^ dateTimeValue,
    String^ currentCalendarCulture,
    bool isRangeSelection
)

Parameters

dateTimeValue
Type: System..::..String
The date to be selected.
currentCalendarCulture
Type: System..::..String
The culture that will be used to parse the date.
isRangeSelection
Type: System..::..Boolean
Flag indicating range selection.

See Also

RadCalendar Class
SelectDate Overload
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..SetValue Method
RadCalendar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadCalendar Class
RadCalendar Members
Telerik.WebAii.Controls.Html Namespace


ViewSelectorClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar..::..ViewSelectorClick Method
RadCalendar Class See Also Send Feedback
Clicks on the ViewSelector.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ViewSelectorClick()
Visual Basic
Public Sub ViewSelectorClick
Visual C++
public:
void ViewSelectorClick()

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RadCalendar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCalendar Properties
RadCalendar Class See Also Send Feedback

The RadCalendar type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Check whether autopostback is enabled.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the RadCalendar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Get the culture which is used by the calendar.
Public property | EnableMonthYearFastNavigation | Whether the FastNavigation is enabled.
Public property | EnableMultiSelect | Check whether multi date selection is enabled.
Public property | EnableViewSelector | Returns the value of the EnableViewSelector property.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FastNavigationStep | Get the step for fast navigation.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Get the focused date.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsMultiMonth | Whether the calendar is in multi month display mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MultiMonthCount | The number of the displayed months in multi-month view.
Public property | MultiViewColumns | The number of columns displayed in MutiMonthView mode.
Public property | MultiViewRows | The number of rowsdisplayed in MutiMonthView mode.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PopupVisible | Whether the popup is visible.
Public property | PresentationType | Get the calendar presentation type.
Public property | RangeMaxDate | Get RangeMaxDate.
Public property | RangeMinDate | Get RangeMinDate.
Public property | RangeSelectionMode | Get the calendar range selection mode.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDates | Get Calendar selected dates.
Public property | SingleViewColumnsCount | Get the number of columns in the single month view of the Calendar.
Public property | SingleViewRowsCount | Get the number of rows in the single month view of the Calendar.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TitleText | The title text of the Calendar.
Public property | UseColumnHeadersAsSelectors | Whether the column headers can be used to select the dates in the respective column.
Public property | UseRowHeadersAsSelectors | Whether the row headers can be used to select the dates in the respective row.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadCalendar Class
Telerik.WebAii.Controls.Html Namespace


RadCaptcha Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha Members
RadCaptcha Class Constructors Methods Properties See Also Send Feedback

The RadCaptcha type exposes the following members.

Constructors

 | Name | Description
Public method | RadCaptcha()()()() | Initializes a new instance of the RadCaptcha class.
Public method | RadCaptcha(Element) | Initializes a new instance of the RadCaptcha class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AudioCurrentTime | Get the Captcha audio current time in seconds.
Public property | AudioIsEnabled | Get whether the Captcha audio code is enabled.
Public property | AudioUrl | Get/Sets the Captcha Url.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaptchaInput | Get the Input sub control of this RadCaptcha instance.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the Captcha control.
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | ErrorMessageDisplayed | Get the Captcha Validation.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputAutocomplete | Get the Captcha Input autocomplete state.
Public property | InputMaxLength | Get the Captcha Input max characters length.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ValidationErrorMessage | Get the Captcha Validation Error Message.
Public property | Visible | Get whether the Captcha is enabled.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
Telerik.WebAii.Controls.Html Namespace


RadCaptcha Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha Constructor
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadCaptcha()()()() | Initializes a new instance of the RadCaptcha class.
Public method | RadCaptcha(Element) | Initializes a new instance of the RadCaptcha class.

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


RadCaptcha Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha Constructor
RadCaptcha Class See Also Send Feedback
Initializes a new instance of the RadCaptcha class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadCaptcha()
Visual Basic
Public Sub New
Visual C++
public:
RadCaptcha()

See Also

RadCaptcha Class
RadCaptcha Overload
Telerik.WebAii.Controls.Html Namespace


RadCaptcha Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha Constructor (Element)
RadCaptcha Class See Also Send Feedback
Initializes a new instance of the RadCaptcha class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadCaptcha(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadCaptcha(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadCaptcha.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadCaptcha Class
RadCaptcha Overload
Telerik.WebAii.Controls.Html Namespace


RadCaptcha Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha Methods
RadCaptcha Class See Also Send Feedback

The RadCaptcha type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadCaptcha Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..AssignElement Method
RadCaptcha Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadCaptcha Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..CallMethod Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..Capture Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..Click Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..ControlAssert Method
RadCaptcha Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadCaptcha Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..DragTo Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..GetValue Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..InvokeEvent Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..MouseClick Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..MouseHover Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..ScrollToVisible Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha..::..SetValue Method
RadCaptcha Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadCaptcha Class
RadCaptcha Members
Telerik.WebAii.Controls.Html Namespace


RadCaptcha Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadCaptcha Properties
RadCaptcha Class See Also Send Feedback

The RadCaptcha type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AudioCurrentTime | Get the Captcha audio current time in seconds.
Public property | AudioIsEnabled | Get whether the Captcha audio code is enabled.
Public property | AudioUrl | Get/Sets the Captcha Url.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaptchaInput | Get the Input sub control of this RadCaptcha instance.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the Captcha control.
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | ErrorMessageDisplayed | Get the Captcha Validation.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputAutocomplete | Get the Captcha Input autocomplete state.
Public property | InputMaxLength | Get the Captcha Input max characters length.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ValidationErrorMessage | Get the Captcha Validation Error Message.
Public property | Visible | Get whether the Captcha is enabled.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadCaptcha Class
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker Members
RadColorPicker Class Constructors Methods Properties See Also Send Feedback

The RadColorPicker type exposes the following members.

Constructors

 | Name | Description
Public method | RadColorPicker()()()() | Initializes a new instance of the RadColorPicker class.
Public method | RadColorPicker(Element) | Initializes a new instance of the RadColorPicker class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HidePalette | Hides the ColorPicker palette and updates the ColorPicker instance.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowPalette | Shows the ColorPicker palette and updates the ColorPicker instance.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side script that identifies the control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Columns | Gets ColorPicker columns.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Determines or set whether the ColorPicker is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Icon | Get the icon sub control of this RadColorPicker instance.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Palette | Get the palette sub control of this RadColorPicker instance.
Public property | PaletteDisplayed | Determines whether the palette is displayed.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedColor | Gets/sets currently selected color.
Public property | ShowIcon | Determines whether the ColorPickcer is shown as an icon.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker Constructor
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadColorPicker()()()() | Initializes a new instance of the RadColorPicker class.
Public method | RadColorPicker(Element) | Initializes a new instance of the RadColorPicker class.

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker Constructor
RadColorPicker Class See Also Send Feedback
Initializes a new instance of the RadColorPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadColorPicker()
Visual Basic
Public Sub New
Visual C++
public:
RadColorPicker()

See Also

RadColorPicker Class
RadColorPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker Constructor (Element)
RadColorPicker Class See Also Send Feedback
Initializes a new instance of the RadColorPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadColorPicker(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadColorPicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
RadColorPicker wrapper div.

See Also

RadColorPicker Class
RadColorPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker Methods
RadColorPicker Class See Also Send Feedback

The RadColorPicker type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HidePalette | Hides the ColorPicker palette and updates the ColorPicker instance.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowPalette | Shows the ColorPicker palette and updates the ColorPicker instance.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..AssignElement Method
RadColorPicker Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..CallMethod Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..Capture Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..Click Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..ControlAssert Method
RadColorPicker Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..DragTo Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..GetValue Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


HidePalette Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..HidePalette Method
RadColorPicker Class See Also Send Feedback
Hides the ColorPicker palette and updates the ColorPicker instance.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void HidePalette()
Visual Basic
Public Sub HidePalette
Visual C++
public:
void HidePalette()

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..InvokeEvent Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..MouseClick Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..MouseHover Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..ScrollToVisible Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..SetValue Method
RadColorPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadColorPicker Class
RadColorPicker Members
Telerik.WebAii.Controls.Html Namespace


ShowPalette Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker..::..ShowPalette Method
RadColorPicker Class See Also Send Feedback
Shows the ColorPicker palette and updates the ColorPicker instance.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowPalette()
Visual Basic
Public Sub ShowPalette
Visual C++
public:
void ShowPalette()

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


RadColorPicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadColorPicker Properties
RadColorPicker Class See Also Send Feedback

The RadColorPicker type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side script that identifies the control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Columns | Gets ColorPicker columns.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Determines or set whether the ColorPicker is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Icon | Get the icon sub control of this RadColorPicker instance.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadColorPickerHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Palette | Get the palette sub control of this RadColorPicker instance.
Public property | PaletteDisplayed | Determines whether the palette is displayed.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedColor | Gets/sets currently selected color.
Public property | ShowIcon | Determines whether the ColorPickcer is shown as an icon.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadColorPicker Class
Telerik.WebAii.Controls.Html Namespace


RadComboBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox Members
RadComboBox Class Constructors Methods Properties See Also Send Feedback

The RadComboBox type exposes the following members.

Constructors

 | Name | Description
Public method | RadComboBox()()()() | Initializes a new instance of the RadComboBox class.
Public method | RadComboBox(Element) | Initializes a new instance of the RadComboBox class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadComboBox control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ClearItems | Clears all items of the combobox.
Public method | ClearSelection | Clears the selection.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Disable | Disables the combo box.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the combo box.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByIndex | Finds item by Index.
Public method | FindItemByText | Finds item by Text.
Public method | FindItemByValue | Finds item by Value.
Public method | FindItemIndexByText | Finds item index by text.
Public method | FindItemIndexByValue | Finds item index by value.
Public method | FindItems | Get a list of items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HideDropDown | Hide the drop down of RadComboBox.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectItemByIndex | Selects item by index.
Public method | SelectItemByText | Selects item by Text.
Public method | SelectItemByValue | Selects item by Value.
Public method | SetText(String) | Types the given text to the ComboBox input using default typing speed. Swows the drop down as well.
Public method | SetText(String, Int32) | Types the given text to the ComboBox input using default typing speed. Swows the drop down as well.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowDropDown | Show the drop down of RadComboBox.
Public method | ToggleDropDown | Toggle the drop down of RadComboBox.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CheckBoxesEnabled | Get whether the ComboBox check box support is enabled.
Public property | CheckedItems |
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ComboBoxValue | Gets or set the ComboBox value.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DropDownDiv | Get the drop down div.
Public property | DropDownVisible | Gets whether the drop down is visible.
Public property | ElementOffsetWidth | Get the offset width of the combobox element.
Public property | EmptyMessage | Gets or set the empty message text of the RadComboBox.
Public property | Enabled | Get whether combobox is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FilterEnabled | Get whether combobox filtering is enabled.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Used for verifications when SimpleRendering is enabled.
Public property | Items | Get the list of items.
Public property | LastWord | Gets the word after the last separator in the text of the combobox. If a separator is not set, returns the text itself.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets the selected index of the RadComboBox. Returns '-1' if there is no selected item.
Public property | SimpleRendering | Get whether combobox simple rendering is enabled.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets or set the text of the RadComboBox.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VisibleItems | Get the list of the visible items.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


RadComboBox Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox Constructor
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadComboBox()()()() | Initializes a new instance of the RadComboBox class.
Public method | RadComboBox(Element) | Initializes a new instance of the RadComboBox class.

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


RadComboBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox Constructor
RadComboBox Class See Also Send Feedback
Initializes a new instance of the RadComboBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadComboBox()
Visual Basic
Public Sub New
Visual C++
public:
RadComboBox()

See Also

RadComboBox Class
RadComboBox Overload
Telerik.WebAii.Controls.Html Namespace


RadComboBox Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox Constructor (Element)
RadComboBox Class See Also Send Feedback
Initializes a new instance of the RadComboBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadComboBox(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadComboBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadComboBox Class
RadComboBox Overload
Telerik.WebAii.Controls.Html Namespace


RadComboBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox Methods
RadComboBox Class See Also Send Feedback

The RadComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadComboBox control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ClearItems | Clears all items of the combobox.
Public method | ClearSelection | Clears the selection.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Disable | Disables the combo box.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the combo box.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByIndex | Finds item by Index.
Public method | FindItemByText | Finds item by Text.
Public method | FindItemByValue | Finds item by Value.
Public method | FindItemIndexByText | Finds item index by text.
Public method | FindItemIndexByValue | Finds item index by value.
Public method | FindItems | Get a list of items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HideDropDown | Hide the drop down of RadComboBox.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectItemByIndex | Selects item by index.
Public method | SelectItemByText | Selects item by Text.
Public method | SelectItemByValue | Selects item by Value.
Public method | SetText(String) | Types the given text to the ComboBox input using default typing speed. Swows the drop down as well.
Public method | SetText(String, Int32) | Types the given text to the ComboBox input using default typing speed. Swows the drop down as well.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowDropDown | Show the drop down of RadComboBox.
Public method | ToggleDropDown | Toggle the drop down of RadComboBox.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..AssignElement Method
RadComboBox Class See Also Send Feedback
Assign the DOM element to be the RadComboBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..CallMethod Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..Capture Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


ClearItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..ClearItems Method
RadComboBox Class See Also Send Feedback
Clears all items of the combobox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClearItems()
Visual Basic
Public Sub ClearItems
Visual C++
public:
void ClearItems()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


ClearSelection Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..ClearSelection Method
RadComboBox Class See Also Send Feedback
Clears the selection.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClearSelection()
Visual Basic
Public Sub ClearSelection
Visual C++
public:
void ClearSelection()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..Click Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..ControlAssert Method
RadComboBox Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..Disable Method
RadComboBox Class See Also Send Feedback
Disables the combo box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..DragTo Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..Enable Method
RadComboBox Class See Also Send Feedback
Enables the combo box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..FindItem Method
RadComboBox Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadComboBoxItem FindItem(
    Predicate<RadComboBoxItem> predicate
)
Visual Basic
Public Function FindItem ( _
    predicate As Predicate(Of RadComboBoxItem) _
) As RadComboBoxItem
Visual C++
public:
RadComboBoxItem^ FindItem(
    Predicate<RadComboBoxItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadComboBoxItem >)>)>
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItemByIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..FindItemByIndex Method
RadComboBox Class See Also Send Feedback
Finds item by Index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadComboBoxItem FindItemByIndex(
    int itemIndex
)
Visual Basic
Public Function FindItemByIndex ( _
    itemIndex As Integer _
) As RadComboBoxItem
Visual C++
public:
RadComboBoxItem^ FindItemByIndex(
    int itemIndex
)

Parameters

itemIndex
Type: System..::..Int32

[Missing <param name="itemIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByIndex(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByIndex(System.Int32)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..FindItemByText Method
RadComboBox Class See Also Send Feedback
Finds item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadComboBoxItem FindItemByText(
    string itemText
)
Visual Basic
Public Function FindItemByText ( _
    itemText As String _
) As RadComboBoxItem
Visual C++
public:
RadComboBoxItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::..String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByText(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..FindItemByValue Method
RadComboBox Class See Also Send Feedback
Finds item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadComboBoxItem FindItemByValue(
    string itemValue
)
Visual Basic
Public Function FindItemByValue ( _
    itemValue As String _
) As RadComboBoxItem
Visual C++
public:
RadComboBoxItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::..String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemByValue(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItemIndexByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..FindItemIndexByText Method
RadComboBox Class See Also Send Feedback
Finds item index by text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public int FindItemIndexByText(
    string itemText
)
Visual Basic
Public Function FindItemIndexByText ( _
    itemText As String _
) As Integer
Visual C++
public:
int FindItemIndexByText(
    String^ itemText
)

Parameters

itemText
Type: System..::..String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemIndexByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemIndexByText(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItemIndexByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..FindItemIndexByValue Method
RadComboBox Class See Also Send Feedback
Finds item index by value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public int FindItemIndexByValue(
    string itemValue
)
Visual Basic
Public Function FindItemIndexByValue ( _
    itemValue As String _
) As Integer
Visual C++
public:
int FindItemIndexByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::..String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemIndexByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.FindItemIndexByValue(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..FindItems Method
RadComboBox Class See Also Send Feedback
Get a list of items matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadComboBoxItem> FindItems(
    Predicate<RadComboBoxItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of RadComboBoxItem) _
) As IList(Of RadComboBoxItem)
Visual C++
public:
IList<RadComboBoxItem^>^ FindItems(
    Predicate<RadComboBoxItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadComboBoxItem >)>)>
The predicate, i.e. (item => item.Text == myText).

Return Value

The items matching the given predicate.

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..GetValue Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


HideDropDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..HideDropDown Method
RadComboBox Class See Also Send Feedback
Hide the drop down of RadComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void HideDropDown()
Visual Basic
Public Sub HideDropDown
Visual C++
public:
void HideDropDown()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..InvokeEvent Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..MouseClick Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..MouseHover Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..ScrollToVisible Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


SelectItemByIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..SelectItemByIndex Method
RadComboBox Class See Also Send Feedback
Selects item by index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectItemByIndex(
    int itemIndex
)
Visual Basic
Public Sub SelectItemByIndex ( _
    itemIndex As Integer _
)
Visual C++
public:
void SelectItemByIndex(
    int itemIndex
)

Parameters

itemIndex
Type: System..::..Int32

[Missing <param name="itemIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.SelectItemByIndex(System.Int32)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


SelectItemByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..SelectItemByText Method
RadComboBox Class See Also Send Feedback
Selects item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectItemByText(
    string itemText
)
Visual Basic
Public Sub SelectItemByText ( _
    itemText As String _
)
Visual C++
public:
void SelectItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::..String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.SelectItemByText(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


SelectItemByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..SelectItemByValue Method
RadComboBox Class See Also Send Feedback
Selects item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectItemByValue(
    string itemValue
)
Visual Basic
Public Sub SelectItemByValue ( _
    itemValue As String _
)
Visual C++
public:
void SelectItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::..String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBox.SelectItemByValue(System.String)"]

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


SetText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..SetText Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetText(String) | Types the given text to the ComboBox input using default typing speed. Swows the drop down as well.
Public method | SetText(String, Int32) | Types the given text to the ComboBox input using default typing speed. Swows the drop down as well.

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


SetText Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..SetText Method (String)
RadComboBox Class See Also Send Feedback
Types the given text to the ComboBox input using default typing speed. Swows the drop down as well.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SetText(
    string text
)
Visual Basic
Public Sub SetText ( _
    text As String _
)
Visual C++
public:
void SetText(
    String^ text
)

Parameters

text
Type: System..::..String
The text to set.

See Also

RadComboBox Class
SetText Overload
Telerik.WebAii.Controls.Html Namespace


SetText Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..SetText Method (String, Int32)
RadComboBox Class See Also Send Feedback
Types the given text to the ComboBox input using default typing speed. Swows the drop down as well.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SetText(
    string text,
    int typeSpeed
)
Visual Basic
Public Sub SetText ( _
    text As String, _
    typeSpeed As Integer _
)
Visual C++
public:
void SetText(
    String^ text,
    int typeSpeed
)

Parameters

text
Type: System..::..String
The text to set.
typeSpeed
Type: System..::..Int32
The typing speed (characters typing) in milliseconds.

See Also

RadComboBox Class
SetText Overload
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..SetValue Method
RadComboBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadComboBox Class
RadComboBox Members
Telerik.WebAii.Controls.Html Namespace


ShowDropDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..ShowDropDown Method
RadComboBox Class See Also Send Feedback
Show the drop down of RadComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowDropDown()
Visual Basic
Public Sub ShowDropDown
Visual C++
public:
void ShowDropDown()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


ToggleDropDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox..::..ToggleDropDown Method
RadComboBox Class See Also Send Feedback
Toggle the drop down of RadComboBox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ToggleDropDown()
Visual Basic
Public Sub ToggleDropDown
Visual C++
public:
void ToggleDropDown()

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


RadComboBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBox Properties
RadComboBox Class See Also Send Feedback

The RadComboBox type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CheckBoxesEnabled | Get whether the ComboBox check box support is enabled.
Public property | CheckedItems |
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ComboBoxValue | Gets or set the ComboBox value.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DropDownDiv | Get the drop down div.
Public property | DropDownVisible | Gets whether the drop down is visible.
Public property | ElementOffsetWidth | Get the offset width of the combobox element.
Public property | EmptyMessage | Gets or set the empty message text of the RadComboBox.
Public property | Enabled | Get whether combobox is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FilterEnabled | Get whether combobox filtering is enabled.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Used for verifications when SimpleRendering is enabled.
Public property | Items | Get the list of items.
Public property | LastWord | Gets the word after the last separator in the text of the combobox. If a separator is not set, returns the text itself.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets the selected index of the RadComboBox. Returns '-1' if there is no selected item.
Public property | SimpleRendering | Get whether combobox simple rendering is enabled.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets or set the text of the RadComboBox.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VisibleItems | Get the list of the visible items.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBox Class
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem Members
RadComboBoxItem Class Constructors Methods Properties See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadComboBoxItem()()()() | Initializes a new instance of the RadComboBoxItem class.
Public method | RadComboBoxItem(Element) | Initializes a new instance of the RadComboBoxItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | This method executes when traverse trough page elements. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Checks the item.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disables the item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides the item.
Public method | Highlight | Highlights the item.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Select the item. Hides the combo drop down.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows the item.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Uncheck | UnCheck the node if it is checked.
Public method | UNHighlight | Unhighlights the item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Checkable | Get whether the item contains check box so that it can be checked.
Public property | Checked | Get or set whether the item is checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ComboBox | Returns the parent comboBox.
Public property | ComboBoxElement | Returns the parent comboBox element.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the combo item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Highlighted | Get whether the combo item is highlighted.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the combo item index.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemValue | Get or set the value for this item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a treeview node. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Check if the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the text for this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the combo item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem Constructor
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadComboBoxItem()()()() | Initializes a new instance of the RadComboBoxItem class.
Public method | RadComboBoxItem(Element) | Initializes a new instance of the RadComboBoxItem class.

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem Constructor
RadComboBoxItem Class See Also Send Feedback
Initializes a new instance of the RadComboBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadComboBoxItem()
Visual Basic
Public Sub New
Visual C++
public:
RadComboBoxItem()

See Also

RadComboBoxItem Class
RadComboBoxItem Overload
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem Constructor (Element)
RadComboBoxItem Class See Also Send Feedback
Initializes a new instance of the RadComboBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadComboBoxItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadComboBoxItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBoxItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadComboBoxItem Class
RadComboBoxItem Overload
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem Methods
RadComboBoxItem Class See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | This method executes when traverse trough page elements. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Checks the item.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disables the item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides the item.
Public method | Highlight | Highlights the item.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Select the item. Hides the combo drop down.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows the item.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Uncheck | UnCheck the node if it is checked.
Public method | UNHighlight | Unhighlights the item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..AssignElement Method
RadComboBoxItem Class See Also Send Feedback
This method executes when traverse trough page elements.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadComboBoxItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..CallMethod Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Capture Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Check Method
RadComboBoxItem Class See Also Send Feedback
Checks the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Check()
Visual Basic
Public Sub Check
Visual C++
public:
void Check()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Click Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..ControlAssert Method
RadComboBoxItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Disable Method
RadComboBoxItem Class See Also Send Feedback
Disables the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..DragTo Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Enable Method
RadComboBoxItem Class See Also Send Feedback
Enables the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..GetValue Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Hide Method
RadComboBoxItem Class See Also Send Feedback
Hides the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Highlight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Highlight Method
RadComboBoxItem Class See Also Send Feedback
Highlights the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Highlight()
Visual Basic
Public Sub Highlight
Visual C++
public:
void Highlight()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..InvokeEvent Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..MouseClick Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..MouseHover Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..ScrollToVisible Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Select Method
RadComboBoxItem Class See Also Send Feedback
Select the item. Hides the combo drop down.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..SetValue Method
RadComboBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
RadComboBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Show Method
RadComboBoxItem Class See Also Send Feedback
Shows the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Uncheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..Uncheck Method
RadComboBoxItem Class See Also Send Feedback
UnCheck the node if it is checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Uncheck()
Visual Basic
Public Sub Uncheck
Visual C++
public:
void Uncheck()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


UNHighlight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem..::..UNHighlight Method
RadComboBoxItem Class See Also Send Feedback
Unhighlights the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UNHighlight()
Visual Basic
Public Sub UNHighlight
Visual C++
public:
void UNHighlight()

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadComboBoxItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadComboBoxItem Properties
RadComboBoxItem Class See Also Send Feedback

The RadComboBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Checkable | Get whether the item contains check box so that it can be checked.
Public property | Checked | Get or set whether the item is checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ComboBox | Returns the parent comboBox.
Public property | ComboBoxElement | Returns the parent comboBox element.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the combo item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Highlighted | Get whether the combo item is highlighted.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the combo item index.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemValue | Get or set the value for this item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a treeview node. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Check if the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the text for this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the combo item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadComboBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert Members
RadControlAssert Class Constructors Methods Properties See Also Send Feedback

The RadControlAssert type exposes the following members.

Constructors

 | Name | Description
Public method | RadControlAssert()()()() | Initializes a new instance of the RadControlAssert class.
Public method | RadControlAssert(HtmlControl) | Initializes a new instance of the RadControlAssert class.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | DecimalValue | Assert a decimal.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberValue | Assert a number.
Public method | StringValue | Assert a string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert Constructor
RadControlAssert Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadControlAssert()()()() | Initializes a new instance of the RadControlAssert class.
Public method | RadControlAssert(HtmlControl) | Initializes a new instance of the RadControlAssert class.

See Also

RadControlAssert Class
RadControlAssert Members
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert Constructor
RadControlAssert Class See Also Send Feedback
Initializes a new instance of the RadControlAssert class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert()
Visual Basic
Public Sub New
Visual C++
public:
RadControlAssert()

See Also

RadControlAssert Class
RadControlAssert Overload
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Constructor (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert Constructor (HtmlControl)
RadControlAssert Class See Also Send Feedback
Initializes a new instance of the RadControlAssert class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert(
    HtmlControl control
)
Visual Basic
Public Sub New ( _
    control As HtmlControl _
)
Visual C++
public:
RadControlAssert(
    HtmlControl^ control
)

Parameters

control
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The target control to assert against.

See Also

RadControlAssert Class
RadControlAssert Overload
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert Methods
RadControlAssert Class See Also Send Feedback

The RadControlAssert type exposes the following members.

Methods

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertNumber | Common assert for a number (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Public method | DecimalValue | Assert a decimal.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NumberValue | Assert a number.
Public method | StringValue | Assert a string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


Assert Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert..::..Assert Method
RadControlAssert Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | Assert(Boolean, String, String, String) | Throw AssertException if condition is false. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | Assert(Boolean, String, String, String, Boolean) | Throw an AssertException if conditiion is false and throwAssert is true. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

RadControlAssert Class
RadControlAssert Members
Telerik.WebAii.Controls.Html Namespace


AssertString Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert..::..AssertString Method
RadControlAssert Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | AssertString(String, String, StringCompareType, Boolean) | Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)
Protected method | AssertString(String, String, StringCompareType, Boolean) | Obsolete. Commnon assert for strings. (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

RadControlAssert Class
RadControlAssert Members
Telerik.WebAii.Controls.Html Namespace


DecimalValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert..::..DecimalValue Method
RadControlAssert Class See Also Send Feedback
Assert a decimal.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool DecimalValue(
    string controlPropertyName,
    decimal expected,
    NumberCompareType compareType
)
Visual Basic
Public Function DecimalValue ( _
    controlPropertyName As String, _
    expected As Decimal, _
    compareType As NumberCompareType _
) As Boolean
Visual C++
public:
bool DecimalValue(
    String^ controlPropertyName,
    Decimal expected,
    NumberCompareType compareType
)

Parameters

controlPropertyName
Type: System..::..String
The property name to get value of.
expected
Type: System..::..Decimal
The expected string.
compareType
Type: ArtOfTest.Common..::..NumberCompareType
The compare type.

Return Value

True/false whether the comparison works. Returns false if the property value is not of integer type.

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


NumberValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert..::..NumberValue Method
RadControlAssert Class See Also Send Feedback
Assert a number.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool NumberValue(
    string controlPropertyName,
    int expected,
    NumberCompareType compareType
)
Visual Basic
Public Function NumberValue ( _
    controlPropertyName As String, _
    expected As Integer, _
    compareType As NumberCompareType _
) As Boolean
Visual C++
public:
bool NumberValue(
    String^ controlPropertyName,
    int expected,
    NumberCompareType compareType
)

Parameters

controlPropertyName
Type: System..::..String
The property name to get value of.
expected
Type: System..::..Int32
The expected string.
compareType
Type: ArtOfTest.Common..::..NumberCompareType
The compare type.

Return Value

True/false whether the comparison works. Returns false if the property value is not of integer type.

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


StringValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert..::..StringValue Method
RadControlAssert Class See Also Send Feedback
Assert a string.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool StringValue(
    string controlPropertyName,
    string expected,
    StringCompareType compareType
)
Visual Basic
Public Function StringValue ( _
    controlPropertyName As String, _
    expected As String, _
    compareType As StringCompareType _
) As Boolean
Visual C++
public:
bool StringValue(
    String^ controlPropertyName,
    String^ expected,
    StringCompareType compareType
)

Parameters

controlPropertyName
Type: System..::..String
The property name to get value of.
expected
Type: System..::..String
The expected string.
compareType
Type: ArtOfTest.Common..::..StringCompareType
The compare type.

Return Value

True/false whether the comparison works.

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


RadControlAssert Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadControlAssert Properties
RadControlAssert Class See Also Send Feedback

The RadControlAssert type exposes the following members.

Properties

 | Name | Description
Public property | Target | Gets or sets the assert target (Inherited from BaseControlAssert<(Of <(<'T>)>)>.)

See Also

RadControlAssert Class
Telerik.WebAii.Controls.Html Namespace


RadDataPager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager Members
RadDataPager Class Constructors Methods Properties See Also Send Feedback

The RadDataPager type exposes the following members.

Constructors

 | Name | Description
Public method | RadDataPager()()()() | Initializes a new instance of the RadDataPager class.
Public method | RadDataPager(Element) | Initializes a new instance of the RadDataPager class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FirstPage | Clicks the first page button.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LastPage | Clicks the last page button.
Public method | LoadPage | Clicks a number from the numeric pages.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NextPage | Clicks the next page button.
Public method | NextPages | Clicks on the next pages '...' button.
Public method | Page | Clicks the 'Go' button to perform paging.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | PreviousPage | Clicks the previous page button.
Public method | PreviousPages | Clicks on the previous pages '...' button.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of the DataPager.
Public property | ClientSideLocator | The client-side locator of the RadDataPager. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | Get or set the current page index of the DataPager.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PageCount | Get the page count of the DataPager.
Public property | PagerNumericTextBox | The numeric textbox in the pager.
Public property | PageSize | Get or set the page size of the DataPager.
Public property | PageSizeCombo | The page size ComboBox.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TotalRowCount | The row count.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


RadDataPager Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager Constructor
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadDataPager()()()() | Initializes a new instance of the RadDataPager class.
Public method | RadDataPager(Element) | Initializes a new instance of the RadDataPager class.

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


RadDataPager Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager Constructor
RadDataPager Class See Also Send Feedback
Initializes a new instance of the RadDataPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDataPager()
Visual Basic
Public Sub New
Visual C++
public:
RadDataPager()

See Also

RadDataPager Class
RadDataPager Overload
Telerik.WebAii.Controls.Html Namespace


RadDataPager Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager Constructor (Element)
RadDataPager Class See Also Send Feedback
Initializes a new instance of the RadDataPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDataPager(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDataPager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDataPager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDataPager Class
RadDataPager Overload
Telerik.WebAii.Controls.Html Namespace


RadDataPager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager Methods
RadDataPager Class See Also Send Feedback

The RadDataPager type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FirstPage | Clicks the first page button.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LastPage | Clicks the last page button.
Public method | LoadPage | Clicks a number from the numeric pages.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NextPage | Clicks the next page button.
Public method | NextPages | Clicks on the next pages '...' button.
Public method | Page | Clicks the 'Go' button to perform paging.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | PreviousPage | Clicks the previous page button.
Public method | PreviousPages | Clicks on the previous pages '...' button.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..AssignElement Method
RadDataPager Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..CallMethod Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..Capture Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..Click Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..ControlAssert Method
RadDataPager Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..DragTo Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


FirstPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..FirstPage Method
RadDataPager Class See Also Send Feedback
Clicks the first page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FirstPage()
Visual Basic
Public Sub FirstPage
Visual C++
public:
void FirstPage()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..GetValue Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..InvokeEvent Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


LastPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..LastPage Method
RadDataPager Class See Also Send Feedback
Clicks the last page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LastPage()
Visual Basic
Public Sub LastPage
Visual C++
public:
void LastPage()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..LoadPage Method
RadDataPager Class See Also Send Feedback
Clicks a number from the numeric pages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPage(
    int pageNumber
)
Visual Basic
Public Sub LoadPage ( _
    pageNumber As Integer _
)
Visual C++
public:
void LoadPage(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
The numer to click on.

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..MouseClick Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..MouseHover Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


NextPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..NextPage Method
RadDataPager Class See Also Send Feedback
Clicks the next page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NextPage()
Visual Basic
Public Sub NextPage
Visual C++
public:
void NextPage()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


NextPages Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..NextPages Method
RadDataPager Class See Also Send Feedback
Clicks on the next pages '...' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NextPages()
Visual Basic
Public Sub NextPages
Visual C++
public:
void NextPages()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


Page Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..Page Method
RadDataPager Class See Also Send Feedback
Clicks the 'Go' button to perform paging.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Page()
Visual Basic
Public Sub Page
Visual C++
public:
void Page()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


PreviousPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..PreviousPage Method
RadDataPager Class See Also Send Feedback
Clicks the previous page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void PreviousPage()
Visual Basic
Public Sub PreviousPage
Visual C++
public:
void PreviousPage()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


PreviousPages Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..PreviousPages Method
RadDataPager Class See Also Send Feedback
Clicks on the previous pages '...' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void PreviousPages()
Visual Basic
Public Sub PreviousPages
Visual C++
public:
void PreviousPages()

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..ScrollToVisible Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager..::..SetValue Method
RadDataPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDataPager Class
RadDataPager Members
Telerik.WebAii.Controls.Html Namespace


RadDataPager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDataPager Properties
RadDataPager Class See Also Send Feedback

The RadDataPager type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of the DataPager.
Public property | ClientSideLocator | The client-side locator of the RadDataPager. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | Get or set the current page index of the DataPager.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PageCount | Get the page count of the DataPager.
Public property | PagerNumericTextBox | The numeric textbox in the pager.
Public property | PageSize | Get or set the page size of the DataPager.
Public property | PageSizeCombo | The page size ComboBox.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TotalRowCount | The row count.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDataPager Class
Telerik.WebAii.Controls.Html Namespace


RadDateInput Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput Members
RadDateInput Class Constructors Methods Properties See Also Send Feedback

The RadDateInput type exposes the following members.

Constructors

 | Name | Description
Public method | RadDateInput | Initializes a new instance of the RadDateInput class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from RadInput.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DateFormat | Get the date format of the DateInput control.
Public property | DisplayDateFormat | Get the display date format of the DateInput control.
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Get or set the latest valid date value.
Public property | MinDate | Get or set the earliest valid date value.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Get or set the selected date of the RadDateInput control. If the date input is empty, the property returns the DateTime.MinValue value.
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


RadDateInput Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput Constructor
RadDateInput Class See Also Send Feedback
Initializes a new instance of the RadDateInput class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDateInput()
Visual Basic
Public Sub New
Visual C++
public:
RadDateInput()

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


RadDateInput Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput Methods
RadDateInput Class See Also Send Feedback

The RadDateInput type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from RadInput.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..CallMethod Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..Capture Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..Click Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..DragTo Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..GetValue Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..InvokeEvent Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..MouseClick Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..MouseHover Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..ScrollToVisible Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..SetValue Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput..::..TypeText Method
RadDateInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)

See Also

RadDateInput Class
RadDateInput Members
Telerik.WebAii.Controls.Html Namespace


RadDateInput Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateInput Properties
RadDateInput Class See Also Send Feedback

The RadDateInput type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DateFormat | Get the date format of the DateInput control.
Public property | DisplayDateFormat | Get the display date format of the DateInput control.
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Get or set the latest valid date value.
Public property | MinDate | Get or set the earliest valid date value.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Get or set the selected date of the RadDateInput control. If the date input is empty, the property returns the DateTime.MinValue value.
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateInput Class
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker Members
RadDatePicker Class Constructors Methods Properties See Also Send Feedback

The RadDatePicker type exposes the following members.

Constructors

 | Name | Description
Public method | RadDatePicker()()()() | Initializes a new instance of the RadDatePicker class.
Public method | RadDatePicker(Element) | Initializes a new instance of the RadDatePicker class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
Public method | OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Calendar | Gets the Calendar part of the picker wrapper.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
Public property | DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
Public property | DatePopUpButton | The date popup button of the picker. (Inherited from RadPicker.)
Protected property | DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Public property | Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
Public property | IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
Public property | MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker. (Inherited from RadPicker.)
Public property | PickerType | Gets the Picker control type. (Inherited from RadPicker.)
Public property | PopupDirection | Gets the direction in which the popup opens. (Inherited from RadPicker.)
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker. (Inherited from RadPicker.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker Constructor
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadDatePicker()()()() | Initializes a new instance of the RadDatePicker class.
Public method | RadDatePicker(Element) | Initializes a new instance of the RadDatePicker class.

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker Constructor
RadDatePicker Class See Also Send Feedback
Initializes a new instance of the RadDatePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDatePicker()
Visual Basic
Public Sub New
Visual C++
public:
RadDatePicker()

See Also

RadDatePicker Class
RadDatePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker Constructor (Element)
RadDatePicker Class See Also Send Feedback
Initializes a new instance of the RadDatePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDatePicker(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDatePicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDatePicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDatePicker Class
RadDatePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker Methods
RadDatePicker Class See Also Send Feedback

The RadDatePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
Public method | OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..CallMethod Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..Capture Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..Click Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..DragTo Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..GetValue Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..InvokeEvent Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..MouseClick Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..MouseHover Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..ScrollToVisible Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker..::..SetValue Method
RadDatePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDatePicker Class
RadDatePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDatePicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDatePicker Properties
RadDatePicker Class See Also Send Feedback

The RadDatePicker type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Calendar | Gets the Calendar part of the picker wrapper.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
Public property | DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
Public property | DatePopUpButton | The date popup button of the picker. (Inherited from RadPicker.)
Protected property | DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Public property | Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
Public property | IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
Public property | MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker. (Inherited from RadPicker.)
Public property | PickerType | Gets the Picker control type. (Inherited from RadPicker.)
Public property | PopupDirection | Gets the direction in which the popup opens. (Inherited from RadPicker.)
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker. (Inherited from RadPicker.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDatePicker Class
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker Members
RadDateTimePicker Class Constructors Methods Properties See Also Send Feedback

The RadDateTimePicker type exposes the following members.

Constructors

 | Name | Description
Public method | RadDateTimePicker()()()() | Initializes a new instance of the RadDateTimePicker class.
Public method | RadDateTimePicker(Element) | Initializes a new instance of the RadDateTimePicker class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
Public method | OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Calendar | Gets the Calendar part of the picker wrapper. (Inherited from RadDatePicker.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
Public property | DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
Public property | DatePopUpButton | The date popup button of the picker. (Inherited from RadPicker.)
Protected property | DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Public property | Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
Public property | IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
Public property | MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker. (Inherited from RadPicker.)
Public property | PickerType | Gets the Picker control type. (Inherited from RadPicker.)
Public property | PopupDirection | Gets the direction in which the popup opens. (Inherited from RadPicker.)
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker. (Inherited from RadPicker.)
Public property | TimeView | Gets the TimeView wrapper of the picker.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker Constructor
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadDateTimePicker()()()() | Initializes a new instance of the RadDateTimePicker class.
Public method | RadDateTimePicker(Element) | Initializes a new instance of the RadDateTimePicker class.

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker Constructor
RadDateTimePicker Class See Also Send Feedback
Initializes a new instance of the RadDateTimePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDateTimePicker()
Visual Basic
Public Sub New
Visual C++
public:
RadDateTimePicker()

See Also

RadDateTimePicker Class
RadDateTimePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker Constructor (Element)
RadDateTimePicker Class See Also Send Feedback
Initializes a new instance of the RadDateTimePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDateTimePicker(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDateTimePicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDateTimePicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDateTimePicker Class
RadDateTimePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker Methods
RadDateTimePicker Class See Also Send Feedback

The RadDateTimePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
Public method | OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadDateTimePicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..CallMethod Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..Capture Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..Click Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..DragTo Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..GetValue Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..InvokeEvent Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..MouseClick Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..MouseHover Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..ScrollToVisible Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker..::..SetValue Method
RadDateTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
RadDateTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadDateTimePicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDateTimePicker Properties
RadDateTimePicker Class See Also Send Feedback

The RadDateTimePicker type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Calendar | Gets the Calendar part of the picker wrapper. (Inherited from RadDatePicker.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
Public property | DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
Public property | DatePopUpButton | The date popup button of the picker. (Inherited from RadPicker.)
Protected property | DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Public property | Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
Public property | IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
Public property | MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker. (Inherited from RadPicker.)
Public property | PickerType | Gets the Picker control type. (Inherited from RadPicker.)
Public property | PopupDirection | Gets the direction in which the popup opens. (Inherited from RadPicker.)
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker. (Inherited from RadPicker.)
Public property | TimeView | Gets the TimeView wrapper of the picker.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDateTimePicker Class
Telerik.WebAii.Controls.Html Namespace


RadDock Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock Members
RadDock Class Constructors Methods Properties See Also Send Feedback

The RadDock type exposes the following members.

Constructors

 | Name | Description
Public method | RadDock()()()() | Initializes a new instance of the RadDock class.
Public method | RadDock(Element) | Initializes a new instance of the RadDock class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AnimationDuration | Gets/Sets animation duration of RadDock.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Gets/Sets whether the RadDock will create a Postback or not.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Closed | Gets/Sets whether the RadDock is closed.
Public property | Collapsed | Gets/Sets whether the RadDock is collapsed.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DockMode | Gets/Sets dock mode of the RadDock.
Public property | EnableAnimation | Gets/Sets whether the RadDock animation is enable.
Public property | EnableDrag | Gets/Sets whether the RadDock drag is enable.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Handler | Gets the element that handles the drag of the RadDock.
Public property | Height | Gets/Sets height of the RadDock in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Gets the index of the RadDock in the RadDockZone.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Left | Gets/Sets left of the RadDock.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadDock. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentDockZoneId | Gets the ID of the RadDock zone.
Public property | Pinned | Gets/Sets whether the RadDock is pinned.
Public property | Resizable | Gets/Sets whether the RadDock is resizable.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Skin | Gets the skin of the RadDock.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets the title of the RadDock.
Public property | Top | Gets/Sets top of the RadDock.
Public property | TopBar | Gets the top table Row (TR) element of the RadDock's table.
Public property | UniqueId | Gets/Sets the unique Id of the RadDock.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets width of the RadDock in pixels .

See Also

RadDock Class
Telerik.WebAii.Controls.Html Namespace


RadDock Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock Constructor
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadDock()()()() | Initializes a new instance of the RadDock class.
Public method | RadDock(Element) | Initializes a new instance of the RadDock class.

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


RadDock Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock Constructor
RadDock Class See Also Send Feedback
Initializes a new instance of the RadDock class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDock()
Visual Basic
Public Sub New
Visual C++
public:
RadDock()

See Also

RadDock Class
RadDock Overload
Telerik.WebAii.Controls.Html Namespace


RadDock Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock Constructor (Element)
RadDock Class See Also Send Feedback
Initializes a new instance of the RadDock class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDock(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDock(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDock.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDock Class
RadDock Overload
Telerik.WebAii.Controls.Html Namespace


RadDock Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock Methods
RadDock Class See Also Send Feedback

The RadDock type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadDock Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..AssignElement Method
RadDock Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadDock Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..CallMethod Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..Capture Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..Click Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..ControlAssert Method
RadDock Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadDock Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..DragTo Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..GetValue Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..InvokeEvent Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..MouseClick Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..MouseHover Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..ScrollToVisible Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock..::..SetValue Method
RadDock Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDock Class
RadDock Members
Telerik.WebAii.Controls.Html Namespace


RadDock Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDock Properties
RadDock Class See Also Send Feedback

The RadDock type exposes the following members.

Properties

 | Name | Description
Public property | AnimationDuration | Gets/Sets animation duration of RadDock.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Gets/Sets whether the RadDock will create a Postback or not.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Closed | Gets/Sets whether the RadDock is closed.
Public property | Collapsed | Gets/Sets whether the RadDock is collapsed.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DockMode | Gets/Sets dock mode of the RadDock.
Public property | EnableAnimation | Gets/Sets whether the RadDock animation is enable.
Public property | EnableDrag | Gets/Sets whether the RadDock drag is enable.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Handler | Gets the element that handles the drag of the RadDock.
Public property | Height | Gets/Sets height of the RadDock in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Gets the index of the RadDock in the RadDockZone.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Left | Gets/Sets left of the RadDock.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadDock. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentDockZoneId | Gets the ID of the RadDock zone.
Public property | Pinned | Gets/Sets whether the RadDock is pinned.
Public property | Resizable | Gets/Sets whether the RadDock is resizable.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Skin | Gets the skin of the RadDock.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets the title of the RadDock.
Public property | Top | Gets/Sets top of the RadDock.
Public property | TopBar | Gets the top table Row (TR) element of the RadDock's table.
Public property | UniqueId | Gets/Sets the unique Id of the RadDock.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets width of the RadDock in pixels .

See Also

RadDock Class
Telerik.WebAii.Controls.Html Namespace


RadDockCommand Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand Members
RadDockCommand Class Constructors Methods Properties See Also Send Feedback

The RadDockCommand type exposes the following members.

Constructors

 | Name | Description
Public method | RadDockCommand()()()() | Initializes a new instance of the RadDockCommand class.
Public method | RadDockCommand(Element) | Initializes a new instance of the RadDockCommand class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign this control a base element. Performs any initialization for this control. (Inherited from HtmlAnchor.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Gets/Sets whether the current command will create a Postback or not.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CommandName | Gets the Name of the RadDockCommnad.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadDockCommand. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link. (Inherited from HtmlAnchor.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
Telerik.WebAii.Controls.Html Namespace


RadDockCommand Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand Constructor
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadDockCommand()()()() | Initializes a new instance of the RadDockCommand class.
Public method | RadDockCommand(Element) | Initializes a new instance of the RadDockCommand class.

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


RadDockCommand Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand Constructor
RadDockCommand Class See Also Send Feedback
Initializes a new instance of the RadDockCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDockCommand()
Visual Basic
Public Sub New
Visual C++
public:
RadDockCommand()

See Also

RadDockCommand Class
RadDockCommand Overload
Telerik.WebAii.Controls.Html Namespace


RadDockCommand Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand Constructor (Element)
RadDockCommand Class See Also Send Feedback
Initializes a new instance of the RadDockCommand class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDockCommand(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDockCommand(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDockCommand.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDockCommand Class
RadDockCommand Overload
Telerik.WebAii.Controls.Html Namespace


RadDockCommand Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand Methods
RadDockCommand Class See Also Send Feedback

The RadDockCommand type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign this control a base element. Performs any initialization for this control. (Inherited from HtmlAnchor.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadDockCommand Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..CallMethod Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..Capture Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..Click Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..ControlAssert Method
RadDockCommand Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadDockCommand Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..DragTo Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..GetValue Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..InvokeEvent Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..MouseClick Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..MouseHover Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..ScrollToVisible Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand..::..SetValue Method
RadDockCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDockCommand Class
RadDockCommand Members
Telerik.WebAii.Controls.Html Namespace


RadDockCommand Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockCommand Properties
RadDockCommand Class See Also Send Feedback

The RadDockCommand type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Gets/Sets whether the current command will create a Postback or not.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CommandName | Gets the Name of the RadDockCommnad.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HRef | Gets the URL of the linked resource. (Inherited from HtmlAnchor.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadDockCommand. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Name | Gets the name of a link. (Inherited from HtmlAnchor.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Gets where to open a link. (Inherited from HtmlAnchor.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | The text displayed when the mouse pointer is placed over the System.Web.UI.HtmlControls.HtmlAnchor. (Inherited from HtmlAnchor.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDockCommand Class
Telerik.WebAii.Controls.Html Namespace


RadDockZone Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone Members
RadDockZone Class Constructors Methods Properties See Also Send Feedback

The RadDockZone type exposes the following members.

Constructors

 | Name | Description
Public method | RadDockZone()()()() | Initializes a new instance of the RadDockZone class.
Public method | RadDockZone(Element) | Initializes a new instance of the RadDockZone class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DocksCount | Gets number of RadDocks docked in the RadDockZone.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FitDocks | Gets/Sets whether the RadDockZone will fit RadDocks.
Public property | HighlightedCssClass | Gets/Sets HighlightedCssClass of the RadDockZone.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsHorizontal | Gets RadDockZone's orientation.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadDockZone. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UniqueName | Gets the unique name of the RadDockZone.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDockZone Class
Telerik.WebAii.Controls.Html Namespace


RadDockZone Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone Constructor
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadDockZone()()()() | Initializes a new instance of the RadDockZone class.
Public method | RadDockZone(Element) | Initializes a new instance of the RadDockZone class.

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


RadDockZone Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone Constructor
RadDockZone Class See Also Send Feedback
Initializes a new instance of the RadDockZone class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDockZone()
Visual Basic
Public Sub New
Visual C++
public:
RadDockZone()

See Also

RadDockZone Class
RadDockZone Overload
Telerik.WebAii.Controls.Html Namespace


RadDockZone Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone Constructor (Element)
RadDockZone Class See Also Send Feedback
Initializes a new instance of the RadDockZone class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadDockZone(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadDockZone(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadDockZone.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadDockZone Class
RadDockZone Overload
Telerik.WebAii.Controls.Html Namespace


RadDockZone Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone Methods
RadDockZone Class See Also Send Feedback

The RadDockZone type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadDockZone Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..AssignElement Method
RadDockZone Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadDockZone Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..CallMethod Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..Capture Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..Click Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..ControlAssert Method
RadDockZone Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadDockZone Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..DragTo Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..GetValue Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..InvokeEvent Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..MouseClick Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..MouseHover Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..ScrollToVisible Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone..::..SetValue Method
RadDockZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadDockZone Class
RadDockZone Members
Telerik.WebAii.Controls.Html Namespace


RadDockZone Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadDockZone Properties
RadDockZone Class See Also Send Feedback

The RadDockZone type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DocksCount | Gets number of RadDocks docked in the RadDockZone.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FitDocks | Gets/Sets whether the RadDockZone will fit RadDocks.
Public property | HighlightedCssClass | Gets/Sets HighlightedCssClass of the RadDockZone.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsHorizontal | Gets RadDockZone's orientation.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadDockZone. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UniqueName | Gets the unique name of the RadDockZone.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadDockZone Class
Telerik.WebAii.Controls.Html Namespace


RadEditor Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor Members
RadEditor Class Constructors Methods Properties See Also Send Feedback

The RadEditor type exposes the following members.

Constructors

 | Name | Description
Public method | RadEditor()()()() | Initializes a new instance of the RadEditor class.
Public method | RadEditor(Element) | Initializes a new instance of the RadEditor class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindDropDownByName | Gets the the dropdown by its command name.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindSplitButtonByName | Gets the the splitbutton by its command name.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowToolBar | Shows toolbar, when toolbar mode is OnFocus or PageTop.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CommentsEnabled | Gets or sets whether the RadEditor comments are enabled.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DecodedHtml | Gets/Sets decoded html of RadEditor.
Public property | EditModes | Gets/Sets which editor modes are included in RadEditor.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets RadEditor's height in pixels.
Public property | Html | Gets/Sets html of RadEditor.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFullScreen | Determines whether RadEditor is in FullScreen mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadEditor. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Mode | Gets/Sets current RadEditor Mode.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectionHtml | Gets selected html.
Public property | SelectionText | Gets selected text.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets the text of this RadEditor instance.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolBarMode | Gets/Sets toolbar mode of RadEditor.
Public property | ToolCount | Gets the RadEditor tool count.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets RadEditor's width in pixels.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


RadEditor Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor Constructor
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadEditor()()()() | Initializes a new instance of the RadEditor class.
Public method | RadEditor(Element) | Initializes a new instance of the RadEditor class.

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


RadEditor Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor Constructor
RadEditor Class See Also Send Feedback
Initializes a new instance of the RadEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadEditor()
Visual Basic
Public Sub New
Visual C++
public:
RadEditor()

See Also

RadEditor Class
RadEditor Overload
Telerik.WebAii.Controls.Html Namespace


RadEditor Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor Constructor (Element)
RadEditor Class See Also Send Feedback
Initializes a new instance of the RadEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadEditor(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadEditor(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadEditor.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadEditor Class
RadEditor Overload
Telerik.WebAii.Controls.Html Namespace


RadEditor Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor Methods
RadEditor Class See Also Send Feedback

The RadEditor type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindDropDownByName | Gets the the dropdown by its command name.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindSplitButtonByName | Gets the the splitbutton by its command name.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowToolBar | Shows toolbar, when toolbar mode is OnFocus or PageTop.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..AssignElement Method
RadEditor Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..CallMethod Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..Capture Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..Click Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..ControlAssert Method
RadEditor Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..DragTo Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


FindDropDownByName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..FindDropDownByName Method
RadEditor Class See Also Send Feedback
Gets the the dropdown by its command name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorDropDown FindDropDownByName(
    string commandName
)
Visual Basic
Public Function FindDropDownByName ( _
    commandName As String _
) As EditorDropDown
Visual C++
public:
EditorDropDown^ FindDropDownByName(
    String^ commandName
)

Parameters

commandName
Type: System..::..String
The commnad name of the EditorDropDown.

Return Value

EditorDropDown control.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


FindSplitButtonByName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..FindSplitButtonByName Method
RadEditor Class See Also Send Feedback
Gets the the splitbutton by its command name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public EditorSplitButton FindSplitButtonByName(
    string commandName
)
Visual Basic
Public Function FindSplitButtonByName ( _
    commandName As String _
) As EditorSplitButton
Visual C++
public:
EditorSplitButton^ FindSplitButtonByName(
    String^ commandName
)

Parameters

commandName
Type: System..::..String
The commnad name of the EditorSplitButton.

Return Value

EditorSplitButton control.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..GetValue Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..InvokeEvent Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..MouseClick Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..MouseHover Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..ScrollToVisible Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..SetValue Method
RadEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadEditor Class
RadEditor Members
Telerik.WebAii.Controls.Html Namespace


ShowToolBar Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor..::..ShowToolBar Method
RadEditor Class See Also Send Feedback
Shows toolbar, when toolbar mode is OnFocus or PageTop.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowToolBar()
Visual Basic
Public Sub ShowToolBar
Visual C++
public:
void ShowToolBar()

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


RadEditor Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditor Properties
RadEditor Class See Also Send Feedback

The RadEditor type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CommentsEnabled | Gets or sets whether the RadEditor comments are enabled.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DecodedHtml | Gets/Sets decoded html of RadEditor.
Public property | EditModes | Gets/Sets which editor modes are included in RadEditor.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets RadEditor's height in pixels.
Public property | Html | Gets/Sets html of RadEditor.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFullScreen | Determines whether RadEditor is in FullScreen mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadEditor. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Mode | Gets/Sets current RadEditor Mode.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectionHtml | Gets selected html.
Public property | SelectionText | Gets selected text.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets the text of this RadEditor instance.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolBarMode | Gets/Sets toolbar mode of RadEditor.
Public property | ToolCount | Gets the RadEditor tool count.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets RadEditor's width in pixels.

See Also

RadEditor Class
Telerik.WebAii.Controls.Html Namespace


RadEditorComment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment Members
RadEditorComment Class Constructors Methods Properties See Also Send Feedback

The RadEditorComment type exposes the following members.

Constructors

 | Name | Description
Public method | RadEditorComment()()()() | Initializes a new instance of the RadEditor class.
Public method | RadEditorComment(Element) | Initializes a new instance of the RadEditorComment class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Comment | Gets/Sets the RadEditor comment.
Public property | CommentedText | Gets/Sets the RadEditor commented text.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadEditorComment. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
Telerik.WebAii.Controls.Html Namespace


RadEditorComment Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment Constructor
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadEditorComment()()()() | Initializes a new instance of the RadEditor class.
Public method | RadEditorComment(Element) | Initializes a new instance of the RadEditorComment class.

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


RadEditorComment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment Constructor
RadEditorComment Class See Also Send Feedback
Initializes a new instance of the RadEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadEditorComment()
Visual Basic
Public Sub New
Visual C++
public:
RadEditorComment()

See Also

RadEditorComment Class
RadEditorComment Overload
Telerik.WebAii.Controls.Html Namespace


RadEditorComment Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment Constructor (Element)
RadEditorComment Class See Also Send Feedback
Initializes a new instance of the RadEditorComment class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadEditorComment(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadEditorComment(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadEditorComment.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadEditorComment Class
RadEditorComment Overload
Telerik.WebAii.Controls.Html Namespace


RadEditorComment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment Methods
RadEditorComment Class See Also Send Feedback

The RadEditorComment type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadEditorComment Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..AssignElement Method
RadEditorComment Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadEditorComment Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..CallMethod Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..Capture Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..Click Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..ControlAssert Method
RadEditorComment Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadEditorComment Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..DragTo Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..GetValue Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..InvokeEvent Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..MouseClick Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..MouseHover Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..ScrollToVisible Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment..::..SetValue Method
RadEditorComment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadEditorComment Class
RadEditorComment Members
Telerik.WebAii.Controls.Html Namespace


RadEditorComment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorComment Properties
RadEditorComment Class See Also Send Feedback

The RadEditorComment type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | Comment | Gets/Sets the RadEditor comment.
Public property | CommentedText | Gets/Sets the RadEditor commented text.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadEditorComment. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadEditorComment Class
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox Members
RadEditorCommentsBox Class Constructors Methods Properties See Also Send Feedback

The RadEditorCommentsBox type exposes the following members.

Constructors

 | Name | Description
Public method | RadEditorCommentsBox()()()() | Initializes a new instance of the RadEditor class.
Public method | RadEditorCommentsBox(Element) | Initializes a new instance of the RadEditorCommentsBox class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CommentsBoxText | Gets/Sets the RadEditor comments box text.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadEditorCommentsBox. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsBox Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox Constructor
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadEditorCommentsBox()()()() | Initializes a new instance of the RadEditor class.
Public method | RadEditorCommentsBox(Element) | Initializes a new instance of the RadEditorCommentsBox class.

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox Constructor
RadEditorCommentsBox Class See Also Send Feedback
Initializes a new instance of the RadEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadEditorCommentsBox()
Visual Basic
Public Sub New
Visual C++
public:
RadEditorCommentsBox()

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Overload
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsBox Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox Constructor (Element)
RadEditorCommentsBox Class See Also Send Feedback
Initializes a new instance of the RadEditorCommentsBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadEditorCommentsBox(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadEditorCommentsBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadEditorCommentsBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Overload
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox Methods
RadEditorCommentsBox Class See Also Send Feedback

The RadEditorCommentsBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadEditorCommentsBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..AssignElement Method
RadEditorCommentsBox Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadEditorCommentsBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..CallMethod Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..Capture Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..Click Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..ControlAssert Method
RadEditorCommentsBox Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadEditorCommentsBox Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..DragTo Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..GetValue Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..InvokeEvent Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..MouseClick Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..MouseHover Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..ScrollToVisible Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox..::..SetValue Method
RadEditorCommentsBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
RadEditorCommentsBox Members
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsBox Properties
RadEditorCommentsBox Class See Also Send Feedback

The RadEditorCommentsBox type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CommentsBoxText | Gets/Sets the RadEditor comments box text.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadEditorCommentsBox. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadEditorCommentsBox Class
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox Members
RadEditorCommentsTextBox Class Constructors Methods Properties See Also Send Feedback

The RadEditorCommentsTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | RadEditorCommentsTextBox()()()() | Initializes a new instance of the RadEditor class.
Public method | RadEditorCommentsTextBox(Element) | Initializes a new instance of the RadEditorCommentsTextBox class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadEditorCommentsTextBox. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the Comment text box is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsTextBox Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox Constructor
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadEditorCommentsTextBox()()()() | Initializes a new instance of the RadEditor class.
Public method | RadEditorCommentsTextBox(Element) | Initializes a new instance of the RadEditorCommentsTextBox class.

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox Constructor
RadEditorCommentsTextBox Class See Also Send Feedback
Initializes a new instance of the RadEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadEditorCommentsTextBox()
Visual Basic
Public Sub New
Visual C++
public:
RadEditorCommentsTextBox()

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Overload
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsTextBox Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox Constructor (Element)
RadEditorCommentsTextBox Class See Also Send Feedback
Initializes a new instance of the RadEditorCommentsTextBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadEditorCommentsTextBox(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadEditorCommentsTextBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadEditorCommentsTextBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Overload
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox Methods
RadEditorCommentsTextBox Class See Also Send Feedback

The RadEditorCommentsTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadEditorCommentsTextBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..AssignElement Method
RadEditorCommentsTextBox Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadEditorCommentsTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..CallMethod Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..Capture Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..Click Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..ControlAssert Method
RadEditorCommentsTextBox Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadEditorCommentsTextBox Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..DragTo Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..GetValue Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..InvokeEvent Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..MouseClick Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..MouseHover Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..ScrollToVisible Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox..::..SetValue Method
RadEditorCommentsTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
RadEditorCommentsTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadEditorCommentsTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadEditorCommentsTextBox Properties
RadEditorCommentsTextBox Class See Also Send Feedback

The RadEditorCommentsTextBox type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadEditorCommentsTextBox. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the Comment text box is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadEditorCommentsTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadFileExplorer Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer Members
RadFileExplorer Class Constructors Methods Properties See Also Send Feedback

The RadFileExplorer type exposes the following members.

Constructors

 | Name | Description
Public method | RadFileExplorer()()()() | Initializes a new instance of the RadFileExplorer class.
Public method | RadFileExplorer(Element) | Initializes a new instance of the RadFileExplorer class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickToolbarButton | Click on FileExplorer ToolBar button defined by command
Public method | CloseActiveWindow | Closes the the active window.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | DeleteSelectedGridItem | Deletes the selected item with or without a confirmation window.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LoadFolder | Loads a certain folder in File Explorer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | RightClickGridItemByNumber | Right click on FileExplorer Grid item defined by number
Public method | RightClickTreeNodeByName | Right click on FileExplorer TreeView item defined by number
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectGridItemByNumber | Selects the FileExplorer Grid item defined by number
Public method | SelectTreeNodeByName | Selects the FileExplorer TreeView item defined by number
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AjaxLoadingPanelIsVisible | Gets or sets whether the FileExplorer Ajax Loading panel is visible.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the FileExplorer control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentDirectory | Gets or sets the RadFileExplorer current directory.
Public property | CurrentPermissions | Gets the File explorer current item permissions.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | ExplorerMode | Gets the explorer mode of the RadFileExplorer.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GetActiveWindow | Gets the object of the active window.
Public property | GetActiveWindowID | Gets the the active window ID.
Public property | Grid | Get the Grid sub control of this RadFileExplorer instance.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsActiveWindowVisible | Gets whether an active window is visible.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIsDirectory | Gets whether the currently selected item is directory or not.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NewFolderDefault | Gets or sets File explorer new folder default value.
Public property | OpenFileEnabled | Gets or sets whether the FileExplorer "OpenFile" feature is enabled.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PagingIsAllowed | Gets or sets whether the FileExplorer "Paging" feature is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedGridItemName | Gets the File explorer currently selected item name.
Public property | SelectedGridItemSize | Gets the File explorer currently selected item size.
Public property | SelectedItemExtension | Gets the currently selected item's file extension.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolBar | Get the ToolBar sub control of this RadFileExplorer instance.
Public property | TreeView | Get the Tree sub control of this RadFileExplorer instance.
Public property | Visibility | Gets or sets whether the FileExplorer is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


RadFileExplorer Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer Constructor
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadFileExplorer()()()() | Initializes a new instance of the RadFileExplorer class.
Public method | RadFileExplorer(Element) | Initializes a new instance of the RadFileExplorer class.

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


RadFileExplorer Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer Constructor
RadFileExplorer Class See Also Send Feedback
Initializes a new instance of the RadFileExplorer class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFileExplorer()
Visual Basic
Public Sub New
Visual C++
public:
RadFileExplorer()

See Also

RadFileExplorer Class
RadFileExplorer Overload
Telerik.WebAii.Controls.Html Namespace


RadFileExplorer Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer Constructor (Element)
RadFileExplorer Class See Also Send Feedback
Initializes a new instance of the RadFileExplorer class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFileExplorer(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadFileExplorer(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorer.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadFileExplorer Class
RadFileExplorer Overload
Telerik.WebAii.Controls.Html Namespace


RadFileExplorer Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer Methods
RadFileExplorer Class See Also Send Feedback

The RadFileExplorer type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickToolbarButton | Click on FileExplorer ToolBar button defined by command
Public method | CloseActiveWindow | Closes the the active window.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | DeleteSelectedGridItem | Deletes the selected item with or without a confirmation window.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LoadFolder | Loads a certain folder in File Explorer.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | RightClickGridItemByNumber | Right click on FileExplorer Grid item defined by number
Public method | RightClickTreeNodeByName | Right click on FileExplorer TreeView item defined by number
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectGridItemByNumber | Selects the FileExplorer Grid item defined by number
Public method | SelectTreeNodeByName | Selects the FileExplorer TreeView item defined by number
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..AssignElement Method
RadFileExplorer Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..CallMethod Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..Capture Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..Click Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


ClickToolbarButton Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..ClickToolbarButton Method
RadFileExplorer Class See Also Send Feedback
Click on FileExplorer ToolBar button defined by command

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClickToolbarButton(
    string commandName
)
Visual Basic
Public Sub ClickToolbarButton ( _
    commandName As String _
)
Visual C++
public:
void ClickToolbarButton(
    String^ commandName
)

Parameters

commandName
Type: System..::..String

[Missing <param name="commandName"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorer.ClickToolbarButton(System.String)"]

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


CloseActiveWindow Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..CloseActiveWindow Method
RadFileExplorer Class See Also Send Feedback
Closes the the active window.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CloseActiveWindow()
Visual Basic
Public Sub CloseActiveWindow
Visual C++
public:
void CloseActiveWindow()

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..ControlAssert Method
RadFileExplorer Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


DeleteSelectedGridItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..DeleteSelectedGridItem Method
RadFileExplorer Class See Also Send Feedback
Deletes the selected item with or without a confirmation window.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DeleteSelectedGridItem(
    bool value
)
Visual Basic
Public Sub DeleteSelectedGridItem ( _
    value As Boolean _
)
Visual C++
public:
void DeleteSelectedGridItem(
    bool value
)

Parameters

value
Type: System..::..Boolean

[Missing <param name="value"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorer.DeleteSelectedGridItem(System.Boolean)"]

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..DragTo Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..GetValue Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..InvokeEvent Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


LoadFolder Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..LoadFolder Method
RadFileExplorer Class See Also Send Feedback
Loads a certain folder in File Explorer.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadFolder(
    string value
)
Visual Basic
Public Sub LoadFolder ( _
    value As String _
)
Visual C++
public:
void LoadFolder(
    String^ value
)

Parameters

value
Type: System..::..String

[Missing <param name="value"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorer.LoadFolder(System.String)"]

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..MouseClick Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..MouseHover Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


RightClickGridItemByNumber Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..RightClickGridItemByNumber Method
RadFileExplorer Class See Also Send Feedback
Right click on FileExplorer Grid item defined by number

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void RightClickGridItemByNumber(
    int itemNumber
)
Visual Basic
Public Sub RightClickGridItemByNumber ( _
    itemNumber As Integer _
)
Visual C++
public:
void RightClickGridItemByNumber(
    int itemNumber
)

Parameters

itemNumber
Type: System..::..Int32

[Missing <param name="itemNumber"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorer.RightClickGridItemByNumber(System.Int32)"]

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


RightClickTreeNodeByName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..RightClickTreeNodeByName Method
RadFileExplorer Class See Also Send Feedback
Right click on FileExplorer TreeView item defined by number

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void RightClickTreeNodeByName(
    string treeNodeName
)
Visual Basic
Public Sub RightClickTreeNodeByName ( _
    treeNodeName As String _
)
Visual C++
public:
void RightClickTreeNodeByName(
    String^ treeNodeName
)

Parameters

treeNodeName
Type: System..::..String

[Missing <param name="treeNodeName"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorer.RightClickTreeNodeByName(System.String)"]

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..ScrollToVisible Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


SelectGridItemByNumber Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..SelectGridItemByNumber Method
RadFileExplorer Class See Also Send Feedback
Selects the FileExplorer Grid item defined by number

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectGridItemByNumber(
    int itemNumber
)
Visual Basic
Public Sub SelectGridItemByNumber ( _
    itemNumber As Integer _
)
Visual C++
public:
void SelectGridItemByNumber(
    int itemNumber
)

Parameters

itemNumber
Type: System..::..Int32

[Missing <param name="itemNumber"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorer.SelectGridItemByNumber(System.Int32)"]

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


SelectTreeNodeByName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..SelectTreeNodeByName Method
RadFileExplorer Class See Also Send Feedback
Selects the FileExplorer TreeView item defined by number

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectTreeNodeByName(
    string treeNodeName
)
Visual Basic
Public Sub SelectTreeNodeByName ( _
    treeNodeName As String _
)
Visual C++
public:
void SelectTreeNodeByName(
    String^ treeNodeName
)

Parameters

treeNodeName
Type: System..::..String

[Missing <param name="treeNodeName"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorer.SelectTreeNodeByName(System.String)"]

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer..::..SetValue Method
RadFileExplorer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
RadFileExplorer Members
Telerik.WebAii.Controls.Html Namespace


RadFileExplorer Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorer Properties
RadFileExplorer Class See Also Send Feedback

The RadFileExplorer type exposes the following members.

Properties

 | Name | Description
Public property | AjaxLoadingPanelIsVisible | Gets or sets whether the FileExplorer Ajax Loading panel is visible.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the FileExplorer control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentDirectory | Gets or sets the RadFileExplorer current directory.
Public property | CurrentPermissions | Gets the File explorer current item permissions.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | ExplorerMode | Gets the explorer mode of the RadFileExplorer.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GetActiveWindow | Gets the object of the active window.
Public property | GetActiveWindowID | Gets the the active window ID.
Public property | Grid | Get the Grid sub control of this RadFileExplorer instance.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsActiveWindowVisible | Gets whether an active window is visible.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIsDirectory | Gets whether the currently selected item is directory or not.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NewFolderDefault | Gets or sets File explorer new folder default value.
Public property | OpenFileEnabled | Gets or sets whether the FileExplorer "OpenFile" feature is enabled.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PagingIsAllowed | Gets or sets whether the FileExplorer "Paging" feature is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedGridItemName | Gets the File explorer currently selected item name.
Public property | SelectedGridItemSize | Gets the File explorer currently selected item size.
Public property | SelectedItemExtension | Gets the currently selected item's file extension.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolBar | Get the ToolBar sub control of this RadFileExplorer instance.
Public property | TreeView | Get the Tree sub control of this RadFileExplorer instance.
Public property | Visibility | Gets or sets whether the FileExplorer is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFileExplorer Class
Telerik.WebAii.Controls.Html Namespace


RadFileExplorerListItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem Members
RadFileExplorerListItem Class Constructors Methods Properties See Also Send Feedback

The RadFileExplorerListItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadFileExplorerListItem()()()() | Initializes a new instance of the FileExplorer class.
Public method | RadFileExplorerListItem(Element) | Initializes a new instance of the FileExplorer class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemName | Gets/Sets the FileExplorer ListView item name.
Public property | ItemPath | Gets/Sets the FileExplorer ListView item path.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for FileExplorer. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
Telerik.WebAii.Controls.Html Namespace


RadFileExplorerListItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem Constructor
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadFileExplorerListItem()()()() | Initializes a new instance of the FileExplorer class.
Public method | RadFileExplorerListItem(Element) | Initializes a new instance of the FileExplorer class.

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


RadFileExplorerListItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem Constructor
RadFileExplorerListItem Class See Also Send Feedback
Initializes a new instance of the FileExplorer class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFileExplorerListItem()
Visual Basic
Public Sub New
Visual C++
public:
RadFileExplorerListItem()

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Overload
Telerik.WebAii.Controls.Html Namespace


RadFileExplorerListItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem Constructor (Element)
RadFileExplorerListItem Class See Also Send Feedback
Initializes a new instance of the FileExplorer class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFileExplorerListItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadFileExplorerListItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFileExplorerListItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Overload
Telerik.WebAii.Controls.Html Namespace


RadFileExplorerListItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem Methods
RadFileExplorerListItem Class See Also Send Feedback

The RadFileExplorerListItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadFileExplorerListItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..AssignElement Method
RadFileExplorerListItem Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadFileExplorerListItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..CallMethod Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..Capture Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..Click Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..ControlAssert Method
RadFileExplorerListItem Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadFileExplorerListItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..DragTo Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..GetValue Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..InvokeEvent Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..MouseClick Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..MouseHover Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..ScrollToVisible Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem..::..SetValue Method
RadFileExplorerListItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
RadFileExplorerListItem Members
Telerik.WebAii.Controls.Html Namespace


RadFileExplorerListItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFileExplorerListItem Properties
RadFileExplorerListItem Class See Also Send Feedback

The RadFileExplorerListItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemName | Gets/Sets the FileExplorer ListView item name.
Public property | ItemPath | Gets/Sets the FileExplorer ListView item path.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for FileExplorer. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFileExplorerListItem Class
Telerik.WebAii.Controls.Html Namespace


RadFilter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter Members
RadFilter Class Constructors Methods Properties See Also Send Feedback

The RadFilter type exposes the following members.

Constructors

 | Name | Description
Public method | RadFilter()()()() | Initializes a new instance of the RadFilter class.
Public method | RadFilter(Element) | Initializes a new instance of the RadFilter class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ApplyButtonClick | Clicks the 'Apply' button in the filter control.
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItems | Find items by given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllItems | Get all the filter items.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of the Filter control.
Public property | ClientSideLocator | The client-side locator of the RadFilter. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootItem | Get the root filter item.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFilter Class
Telerik.WebAii.Controls.Html Namespace


RadFilter Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter Constructor
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadFilter()()()() | Initializes a new instance of the RadFilter class.
Public method | RadFilter(Element) | Initializes a new instance of the RadFilter class.

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


RadFilter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter Constructor
RadFilter Class See Also Send Feedback
Initializes a new instance of the RadFilter class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFilter()
Visual Basic
Public Sub New
Visual C++
public:
RadFilter()

See Also

RadFilter Class
RadFilter Overload
Telerik.WebAii.Controls.Html Namespace


RadFilter Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter Constructor (Element)
RadFilter Class See Also Send Feedback
Initializes a new instance of the RadFilter class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFilter(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadFilter(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFilter.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadFilter Class
RadFilter Overload
Telerik.WebAii.Controls.Html Namespace


RadFilter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter Methods
RadFilter Class See Also Send Feedback

The RadFilter type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ApplyButtonClick | Clicks the 'Apply' button in the filter control.
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItems | Find items by given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadFilter Class
Telerik.WebAii.Controls.Html Namespace


ApplyButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..ApplyButtonClick Method
RadFilter Class See Also Send Feedback
Clicks the 'Apply' button in the filter control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ApplyButtonClick()
Visual Basic
Public Sub ApplyButtonClick
Visual C++
public:
void ApplyButtonClick()

See Also

RadFilter Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..AssignElement Method
RadFilter Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

RadFilter Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..CallMethod Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..Capture Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..Click Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..ControlAssert Method
RadFilter Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadFilter Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..DragTo Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..FindItem Method
RadFilter Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFilterItem FindItem(
    Predicate<RadFilterItem> predicate
)
Visual Basic
Public Function FindItem ( _
    predicate As Predicate(Of RadFilterItem) _
) As RadFilterItem
Visual C++
public:
RadFilterItem^ FindItem(
    Predicate<RadFilterItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadFilterItem >)>)>
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadFilter Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..FindItems Method
RadFilter Class See Also Send Feedback
Find items by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadFilterItem> FindItems(
    Predicate<RadFilterItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of RadFilterItem) _
) As IList(Of RadFilterItem)
Visual C++
public:
IList<RadFilterItem^>^ FindItems(
    Predicate<RadFilterItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadFilterItem >)>)>
The predicate used as a search criteria.

Return Value

The list of items matching the search.

See Also

RadFilter Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..GetValue Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..InvokeEvent Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..MouseClick Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..MouseHover Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..ScrollToVisible Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter..::..SetValue Method
RadFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadFilter Class
RadFilter Members
Telerik.WebAii.Controls.Html Namespace


RadFilter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilter Properties
RadFilter Class See Also Send Feedback

The RadFilter type exposes the following members.

Properties

 | Name | Description
Public property | AllItems | Get all the filter items.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of the Filter control.
Public property | ClientSideLocator | The client-side locator of the RadFilter. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootItem | Get the root filter item.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFilter Class
Telerik.WebAii.Controls.Html Namespace


RadFilterExpressionItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem Members
RadFilterExpressionItem Class Constructors Methods Properties See Also Send Feedback

The RadFilterExpressionItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadFilterExpressionItem | Initializes a new instance of the RadFilterExpressionItem class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from RadFilterItem.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadFilterItem.)
Public method | Delete | Clicks the delete button of the item. (Inherited from RadFilterItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenExpressionMenu | Clicks the expression link button.
Public method | OpenExpressionsMenu | Clicks the expression link button.
Public method | OpenFieldMenu | Clicks the Field link button.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteLink | The delete button link of the item. (Inherited from RadFilterItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expression | The expression of the current filtering item.
Public property | ExpressionLink | The link that opens the Expression options menu.
Public property | Field | The field by which the filtering will be performed.
Public property | FieldLink | The link that opens the Filed options menu.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Gets the index of the item relatively to all items in the current level. (Inherited from RadFilterItem.)
Public property | ItemLevel | Gets the hierarchy level of the item. (Inherited from RadFilterItem.)
Public property | Items | Get all the filter items. (Inherited from RadFilterItem.)
Public property | ItemType | The type of the current fiter item. (Inherited from RadFilterItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Inherited from RadFilterItem.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
Telerik.WebAii.Controls.Html Namespace


RadFilterExpressionItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem Constructor
RadFilterExpressionItem Class See Also Send Feedback
Initializes a new instance of the RadFilterExpressionItem class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFilterExpressionItem()
Visual Basic
Public Sub New
Visual C++
public:
RadFilterExpressionItem()

See Also

RadFilterExpressionItem Class
Telerik.WebAii.Controls.Html Namespace


RadFilterExpressionItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem Methods
RadFilterExpressionItem Class See Also Send Feedback

The RadFilterExpressionItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from RadFilterItem.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadFilterItem.)
Public method | Delete | Clicks the delete button of the item. (Inherited from RadFilterItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenExpressionMenu | Clicks the expression link button.
Public method | OpenExpressionsMenu | Clicks the expression link button.
Public method | OpenFieldMenu | Clicks the Field link button.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadFilterExpressionItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..CallMethod Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..Capture Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..Click Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..DragTo Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..GetValue Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..InvokeEvent Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..MouseClick Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..MouseHover Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


OpenExpressionMenu Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..OpenExpressionMenu Method
RadFilterExpressionItem Class See Also Send Feedback
Clicks the expression link button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenExpressionMenu()
Visual Basic
Public Sub OpenExpressionMenu
Visual C++
public:
void OpenExpressionMenu()

See Also

RadFilterExpressionItem Class
Telerik.WebAii.Controls.Html Namespace


OpenExpressionsMenu Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..OpenExpressionsMenu Method
RadFilterExpressionItem Class See Also Send Feedback
Clicks the expression link button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenExpressionsMenu()
Visual Basic
Public Sub OpenExpressionsMenu
Visual C++
public:
void OpenExpressionsMenu()

See Also

RadFilterExpressionItem Class
Telerik.WebAii.Controls.Html Namespace


OpenFieldMenu Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..OpenFieldMenu Method
RadFilterExpressionItem Class See Also Send Feedback
Clicks the Field link button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenFieldMenu()
Visual Basic
Public Sub OpenFieldMenu
Visual C++
public:
void OpenFieldMenu()

See Also

RadFilterExpressionItem Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..ScrollToVisible Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem..::..SetValue Method
RadFilterExpressionItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
RadFilterExpressionItem Members
Telerik.WebAii.Controls.Html Namespace


RadFilterExpressionItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterExpressionItem Properties
RadFilterExpressionItem Class See Also Send Feedback

The RadFilterExpressionItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteLink | The delete button link of the item. (Inherited from RadFilterItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expression | The expression of the current filtering item.
Public property | ExpressionLink | The link that opens the Expression options menu.
Public property | Field | The field by which the filtering will be performed.
Public property | FieldLink | The link that opens the Filed options menu.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Gets the index of the item relatively to all items in the current level. (Inherited from RadFilterItem.)
Public property | ItemLevel | Gets the hierarchy level of the item. (Inherited from RadFilterItem.)
Public property | Items | Get all the filter items. (Inherited from RadFilterItem.)
Public property | ItemType | The type of the current fiter item. (Inherited from RadFilterItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Inherited from RadFilterItem.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFilterExpressionItem Class
Telerik.WebAii.Controls.Html Namespace


RadFilterGroupItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem Members
RadFilterGroupItem Class Constructors Methods Properties See Also Send Feedback

The RadFilterGroupItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadFilterGroupItem | Initializes a new instance of the RadFilterGroupItem class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AddExpression | Clicks the add expression link button.
Public method | AddGroup | Clicks the add group link button.
Public method | AssignElement | Assign element and initialize this control. (Inherited from RadFilterItem.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadFilterItem.)
Public method | Delete | Clicks the delete button of the item. (Inherited from RadFilterItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenFilterOperatorMenu | Clicks the filter operator link button.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AddExpressionLink | The "add expression" link button.
Public property | AddGroupLink | The "add group" link button.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteLink | The delete button link of the item. (Inherited from RadFilterItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Gets the index of the item relatively to all items in the current level. (Inherited from RadFilterItem.)
Public property | ItemLevel | Gets the hierarchy level of the item. (Inherited from RadFilterItem.)
Public property | Items | Get all the filter items. (Inherited from RadFilterItem.)
Public property | ItemType | The type of the current fiter item. (Inherited from RadFilterItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Inherited from RadFilterItem.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Operator | The filter operator used to combine the different expressions.
Public property | OperatorLink | The link that opens the filter opreator menu.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
Telerik.WebAii.Controls.Html Namespace


RadFilterGroupItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem Constructor
RadFilterGroupItem Class See Also Send Feedback
Initializes a new instance of the RadFilterGroupItem class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFilterGroupItem()
Visual Basic
Public Sub New
Visual C++
public:
RadFilterGroupItem()

See Also

RadFilterGroupItem Class
Telerik.WebAii.Controls.Html Namespace


RadFilterGroupItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem Methods
RadFilterGroupItem Class See Also Send Feedback

The RadFilterGroupItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AddExpression | Clicks the add expression link button.
Public method | AddGroup | Clicks the add group link button.
Public method | AssignElement | Assign element and initialize this control. (Inherited from RadFilterItem.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadFilterItem.)
Public method | Delete | Clicks the delete button of the item. (Inherited from RadFilterItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenFilterOperatorMenu | Clicks the filter operator link button.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadFilterGroupItem Class
Telerik.WebAii.Controls.Html Namespace


AddExpression Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..AddExpression Method
RadFilterGroupItem Class See Also Send Feedback
Clicks the add expression link button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void AddExpression()
Visual Basic
Public Sub AddExpression
Visual C++
public:
void AddExpression()

See Also

RadFilterGroupItem Class
Telerik.WebAii.Controls.Html Namespace


AddGroup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..AddGroup Method
RadFilterGroupItem Class See Also Send Feedback
Clicks the add group link button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void AddGroup()
Visual Basic
Public Sub AddGroup
Visual C++
public:
void AddGroup()

See Also

RadFilterGroupItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..CallMethod Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..Capture Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..Click Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..DragTo Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..GetValue Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..InvokeEvent Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..MouseClick Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..MouseHover Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


OpenFilterOperatorMenu Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..OpenFilterOperatorMenu Method
RadFilterGroupItem Class See Also Send Feedback
Clicks the filter operator link button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenFilterOperatorMenu()
Visual Basic
Public Sub OpenFilterOperatorMenu
Visual C++
public:
void OpenFilterOperatorMenu()

See Also

RadFilterGroupItem Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..ScrollToVisible Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem..::..SetValue Method
RadFilterGroupItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
RadFilterGroupItem Members
Telerik.WebAii.Controls.Html Namespace


RadFilterGroupItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterGroupItem Properties
RadFilterGroupItem Class See Also Send Feedback

The RadFilterGroupItem type exposes the following members.

Properties

 | Name | Description
Public property | AddExpressionLink | The "add expression" link button.
Public property | AddGroupLink | The "add group" link button.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteLink | The delete button link of the item. (Inherited from RadFilterItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Gets the index of the item relatively to all items in the current level. (Inherited from RadFilterItem.)
Public property | ItemLevel | Gets the hierarchy level of the item. (Inherited from RadFilterItem.)
Public property | Items | Get all the filter items. (Inherited from RadFilterItem.)
Public property | ItemType | The type of the current fiter item. (Inherited from RadFilterItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Inherited from RadFilterItem.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Operator | The filter operator used to combine the different expressions.
Public property | OperatorLink | The link that opens the filter opreator menu.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFilterGroupItem Class
Telerik.WebAii.Controls.Html Namespace


RadFilterItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem Members
RadFilterItem Class Constructors Methods Properties See Also Send Feedback

The RadFilterItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadFilterItem()()()() | Initializes a new instance of the RadFilterItem class.
Public method | RadFilterItem(Element) | Initializes a new instance of the RadFilterItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlListItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Delete | Clicks the delete button of the item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteLink | The delete button link of the item.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Gets the index of the item relatively to all items in the current level.
Public property | ItemLevel | Gets the hierarchy level of the item.
Public property | Items | Get all the filter items.
Public property | ItemType | The type of the current fiter item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
Telerik.WebAii.Controls.Html Namespace


RadFilterItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem Constructor
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadFilterItem()()()() | Initializes a new instance of the RadFilterItem class.
Public method | RadFilterItem(Element) | Initializes a new instance of the RadFilterItem class.

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


RadFilterItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem Constructor
RadFilterItem Class See Also Send Feedback
Initializes a new instance of the RadFilterItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFilterItem()
Visual Basic
Public Sub New
Visual C++
public:
RadFilterItem()

See Also

RadFilterItem Class
RadFilterItem Overload
Telerik.WebAii.Controls.Html Namespace


RadFilterItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem Constructor (Element)
RadFilterItem Class See Also Send Feedback
Initializes a new instance of the RadFilterItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadFilterItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadFilterItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadFilterItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadFilterItem Class
RadFilterItem Overload
Telerik.WebAii.Controls.Html Namespace


RadFilterItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem Methods
RadFilterItem Class See Also Send Feedback

The RadFilterItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlListItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Delete | Clicks the delete button of the item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItemOrder | Gets this item's order in its parent list. 0 based ordering (Inherited from HtmlListItem.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadFilterItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..AssignElement Method
RadFilterItem Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadFilterItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..CallMethod Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..Capture Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..Click Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..ControlAssert Method
RadFilterItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadFilterItem Class
Telerik.WebAii.Controls.Html Namespace


Delete Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..Delete Method
RadFilterItem Class See Also Send Feedback
Clicks the delete button of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete
Visual C++
public:
void Delete()

See Also

RadFilterItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..DragTo Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..GetValue Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..InvokeEvent Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..MouseClick Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..MouseHover Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..ScrollToVisible Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem..::..SetValue Method
RadFilterItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadFilterItem Class
RadFilterItem Members
Telerik.WebAii.Controls.Html Namespace


RadFilterItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadFilterItem Properties
RadFilterItem Class See Also Send Feedback

The RadFilterItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteLink | The delete button link of the item.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Gets the index of the item relatively to all items in the current level.
Public property | ItemLevel | Gets the hierarchy level of the item.
Public property | Items | Get all the filter items.
Public property | ItemType | The type of the current fiter item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadFilterItem Class
Telerik.WebAii.Controls.Html Namespace


RadGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid Members
RadGrid Class Constructors Methods Properties See Also Send Feedback

The RadGrid type exposes the following members.

Constructors

 | Name | Description
Public method | RadGrid()()()() | Initializes a new instance of the RadGrid class.
Public method | RadGrid(Element) | Initializes a new instance of the RadGrid class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindColumn | Find column by given predicate.
Public method | FindColumnByName | Finds column by name.
Public method | FindColumns | Get a list of columns matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllowCellSelection | Get whether the client-side cell selection is enabled.
Public property | AllowColumnResize | Get whether the column resizing is allowed.
Public property | AllowColumnSelection | Get whether the client-side column selection is enabled.
Public property | AllowColumnsReorder | Get whether columns can be reordered server, client-side or both. To be able to reorder columns client-side, the 'ReorderColumnsOnClient' should be enabled as well.
Public property | AllowMultiCellSelection | Get whether the client-side multi-cell selection is enabled.
Public property | AllowMultiColumnSelection | Get whether the client-side multi-column selection is enabled.
Public property | AllowMultiRowSelection | Get whether the multi-row selection is enabled.
Public property | AllowRowResize | Get whether the row resizing is allowed.
Public property | AllowRowSelection | Get whether the client-side row selection is enabled.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the RadGrid control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ClipCellContentOnResize | Get whether the clip-cell-content-on-resize is enabled.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DetailTableCount | Get the detail table levels of the Grid.
Public property | EditedItemCount | The collection of indexes of the items being edited.
Public property | EnableDragToSelectRows | Get whether the drag-to-select option is enabled.
Public property | EnableHeaderContextMenu | Get whether the header context menu is enabled.
Public property | EnableRealTimeResize | Get whether the real-time resizing is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GridFilterItem | Get the FilterItem HtmlControl if fitering is enabled.
Public property | GroupPanel | Get the GroupPanel HtmlControl if RadGrid's GroupPanel is enabled or null otherwise.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsScrollingEnabled | Get whether the scrolling of the Grid is enabled.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MasterTable | Get the Grid MasterTable.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pager | Get the Grid pager control.
Public property | ReorderColumnsOnClient | Enables the client-side columns reorder if both with the 'AllowColumnsReorder' are on.
Public property | ResizeGridOnColumnResize | Get whether the resize-grid-on-column-resizing is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedCellsCount | Gets the selected cells count.
Public property | StaticHeadersEnabled | Get whether the static headers of the Grid are enabled.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


RadGrid Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid Constructor
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadGrid()()()() | Initializes a new instance of the RadGrid class.
Public method | RadGrid(Element) | Initializes a new instance of the RadGrid class.

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


RadGrid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid Constructor
RadGrid Class See Also Send Feedback
Initializes a new instance of the RadGrid class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadGrid()
Visual Basic
Public Sub New
Visual C++
public:
RadGrid()

See Also

RadGrid Class
RadGrid Overload
Telerik.WebAii.Controls.Html Namespace


RadGrid Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid Constructor (Element)
RadGrid Class See Also Send Feedback
Initializes a new instance of the RadGrid class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadGrid(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadGrid(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadGrid.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadGrid Class
RadGrid Overload
Telerik.WebAii.Controls.Html Namespace


RadGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid Methods
RadGrid Class See Also Send Feedback

The RadGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindColumn | Find column by given predicate.
Public method | FindColumnByName | Finds column by name.
Public method | FindColumns | Get a list of columns matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..AssignElement Method
RadGrid Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..CallMethod Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..Capture Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..Click Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..ControlAssert Method
RadGrid Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..DragTo Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


FindColumn Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..FindColumn Method
RadGrid Class See Also Send Feedback
Find column by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridTableHeader FindColumn(
    Predicate<GridTableHeader> predicate
)
Visual Basic
Public Function FindColumn ( _
    predicate As Predicate(Of GridTableHeader) _
) As GridTableHeader
Visual C++
public:
GridTableHeader^ FindColumn(
    Predicate<GridTableHeader^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' GridTableHeader >)>)>
The predicate used as search criteria.

Return Value

The column matching the given criteria or null if nothing matches the search.

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


FindColumnByName Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..FindColumnByName Method
RadGrid Class See Also Send Feedback
Finds column by name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public GridTableHeader FindColumnByName(
    string columnName
)
Visual Basic
Public Function FindColumnByName ( _
    columnName As String _
) As GridTableHeader
Visual C++
public:
GridTableHeader^ FindColumnByName(
    String^ columnName
)

Parameters

columnName
Type: System..::..String

[Missing <param name="columnName"/> documentation for "M:Telerik.WebAii.Controls.Html.RadGrid.FindColumnByName(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadGrid.FindColumnByName(System.String)"]

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


FindColumns Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..FindColumns Method
RadGrid Class See Also Send Feedback
Get a list of columns matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<GridTableHeader> FindColumns(
    Predicate<GridTableHeader> predicate
)
Visual Basic
Public Function FindColumns ( _
    predicate As Predicate(Of GridTableHeader) _
) As IList(Of GridTableHeader)
Visual C++
public:
IList<GridTableHeader^>^ FindColumns(
    Predicate<GridTableHeader^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' GridTableHeader >)>)>
The predicate.

Return Value

The columns matching the given predicate.

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..GetValue Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..InvokeEvent Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..MouseClick Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..MouseHover Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..ScrollToVisible Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid..::..SetValue Method
RadGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadGrid Class
RadGrid Members
Telerik.WebAii.Controls.Html Namespace


RadGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadGrid Properties
RadGrid Class See Also Send Feedback

The RadGrid type exposes the following members.

Properties

 | Name | Description
Public property | AllowCellSelection | Get whether the client-side cell selection is enabled.
Public property | AllowColumnResize | Get whether the column resizing is allowed.
Public property | AllowColumnSelection | Get whether the client-side column selection is enabled.
Public property | AllowColumnsReorder | Get whether columns can be reordered server, client-side or both. To be able to reorder columns client-side, the 'ReorderColumnsOnClient' should be enabled as well.
Public property | AllowMultiCellSelection | Get whether the client-side multi-cell selection is enabled.
Public property | AllowMultiColumnSelection | Get whether the client-side multi-column selection is enabled.
Public property | AllowMultiRowSelection | Get whether the multi-row selection is enabled.
Public property | AllowRowResize | Get whether the row resizing is allowed.
Public property | AllowRowSelection | Get whether the client-side row selection is enabled.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the RadGrid control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ClipCellContentOnResize | Get whether the clip-cell-content-on-resize is enabled.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DetailTableCount | Get the detail table levels of the Grid.
Public property | EditedItemCount | The collection of indexes of the items being edited.
Public property | EnableDragToSelectRows | Get whether the drag-to-select option is enabled.
Public property | EnableHeaderContextMenu | Get whether the header context menu is enabled.
Public property | EnableRealTimeResize | Get whether the real-time resizing is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GridFilterItem | Get the FilterItem HtmlControl if fitering is enabled.
Public property | GroupPanel | Get the GroupPanel HtmlControl if RadGrid's GroupPanel is enabled or null otherwise.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsScrollingEnabled | Get whether the scrolling of the Grid is enabled.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the Grid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MasterTable | Get the Grid MasterTable.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pager | Get the Grid pager control.
Public property | ReorderColumnsOnClient | Enables the client-side columns reorder if both with the 'AllowColumnsReorder' are on.
Public property | ResizeGridOnColumnResize | Get whether the resize-grid-on-column-resizing is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedCellsCount | Gets the selected cells count.
Public property | StaticHeadersEnabled | Get whether the static headers of the Grid are enabled.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadGrid Class
Telerik.WebAii.Controls.Html Namespace


RadHtmlChart Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart Members
RadHtmlChart Class Constructors Methods Properties See Also Send Feedback

The RadHtmlChart type exposes the following members.

Constructors

 | Name | Description
Public method | RadHtmlChart()()()() | Initializes a new instance of the RadHtmlChart class.
Public method | RadHtmlChart(Element) | Initializes a new instance of the RadHtmlChart class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Animation | Gets or sets whether the HtmlChart animation is enabled.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChartType | Gets the HtmlChart type.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the HtmlChart control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets HtmlChart height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SeriesNumber | Gets HtmlChart series number.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets the HtmlChart title value.
Public property | Visible | Gets or sets whether the HtmlChart is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets HtmlChart width in pixels.
Public property | XAxisTitle | Gets the HtmlChart X axis title value.
Public property | YAxisTitle | Gets the HtmlChart Y axis title value.

See Also

RadHtmlChart Class
Telerik.WebAii.Controls.Html Namespace


RadHtmlChart Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart Constructor
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadHtmlChart()()()() | Initializes a new instance of the RadHtmlChart class.
Public method | RadHtmlChart(Element) | Initializes a new instance of the RadHtmlChart class.

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


RadHtmlChart Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart Constructor
RadHtmlChart Class See Also Send Feedback
Initializes a new instance of the RadHtmlChart class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadHtmlChart()
Visual Basic
Public Sub New
Visual C++
public:
RadHtmlChart()

See Also

RadHtmlChart Class
RadHtmlChart Overload
Telerik.WebAii.Controls.Html Namespace


RadHtmlChart Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart Constructor (Element)
RadHtmlChart Class See Also Send Feedback
Initializes a new instance of the RadHtmlChart class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadHtmlChart(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadHtmlChart(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadHtmlChart.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadHtmlChart Class
RadHtmlChart Overload
Telerik.WebAii.Controls.Html Namespace


RadHtmlChart Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart Methods
RadHtmlChart Class See Also Send Feedback

The RadHtmlChart type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadHtmlChart Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..AssignElement Method
RadHtmlChart Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadHtmlChart Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..CallMethod Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..Capture Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..Click Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..ControlAssert Method
RadHtmlChart Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadHtmlChart.ControlAssert"]

See Also

RadHtmlChart Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..DragTo Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..GetValue Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..InvokeEvent Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..MouseClick Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..MouseHover Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..ScrollToVisible Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart..::..SetValue Method
RadHtmlChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadHtmlChart Class
RadHtmlChart Members
Telerik.WebAii.Controls.Html Namespace


RadHtmlChart Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadHtmlChart Properties
RadHtmlChart Class See Also Send Feedback

The RadHtmlChart type exposes the following members.

Properties

 | Name | Description
Public property | Animation | Gets or sets whether the HtmlChart animation is enabled.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChartType | Gets the HtmlChart type.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the HtmlChart control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets HtmlChart height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SeriesNumber | Gets HtmlChart series number.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets the HtmlChart title value.
Public property | Visible | Gets or sets whether the HtmlChart is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets HtmlChart width in pixels.
Public property | XAxisTitle | Gets the HtmlChart X axis title value.
Public property | YAxisTitle | Gets the HtmlChart Y axis title value.

See Also

RadHtmlChart Class
Telerik.WebAii.Controls.Html Namespace


RadImageEditor Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor Members
RadImageEditor Class Constructors Methods Properties See Also Send Feedback

The RadImageEditor type exposes the following members.

Constructors

 | Name | Description
Public method | RadImageEditor()()()() | Initializes a new instance of the RadImageEditor class.
Public method | RadImageEditor(Element) | Initializes a new instance of the RadImageEditor class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CloseCurrentToolDialog | Closes the current ImageEditor tool.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | CropBoxSet | Sets Crop Box position and size (x, y, width, height).
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FlipHorizontally | ImageEditor Flip horizontally action
Public method | FlipVertically | ImageEditor Flip vertically action
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HideTool | Hides an Image Editor tool.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Redo()()()() | ImageEditor Redo 1 action.
Public method | Redo(Int32) | ImageEditor Redo action. Need to specify steps number.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ResetImage | ImageEditor reset image changes.
Public method | ResizeImage | ImageEditor Resize image action. Need to specify width and height.
Public method | Rotate | ImageEditor Rotate Left action
Public method | RotateLeft | ImageEditor Rotate Left action
Public method | RotateRight | ImageEditor Rotate Right action
Public method | SaveOnClient()()()() | ImageEditor save image on client action.
Public method | SaveOnClient(String) | ImageEditor save image on client action. Need to specify file name.
Public method | SaveOnServer()()()() | ImageEditor save image on server action.
Public method | SaveOnServer(String) | ImageEditor save image on server action. Need to specify file name.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectOptionFromToolbar | Opens ImageEditor tool by name.
Public method | SetText(String) | Sets text to Image.
Public method | SetText(String, Int32, Int32, String, Int32, String) | Sets text to Image.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowTool | Shows an Image Editor tool.
Public method | ToolEnable | Enables/Disables an Image Editor tool.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Undo()()()() | ImageEditor Undo 1 action.
Public method | Undo(Int32) | ImageEditor Undo action. Need to specify steps number.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Public method | ZoomActualSize | ImageEditor zoom to image actual size.
Public method | ZoomBestFit | ImageEditor zoom to fit best.
Public method | ZoomImage | ImageEditor zoom out action.
Public method | ZoomIn | ImageEditor zoom in action.
Public method | ZoomOut | ImageEditor zoom out action.

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the ImageEditor
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CropBoxHeight | Gets Crop Box height. The property is supposed to work only if the Crop dialog is opened.
Public property | CropBoxWidth | Gets Crop Box width. The property is supposed to work only if the Crop dialog is opened.
Public property | CropBoxX | Gets Crop Box X position. The property is supposed to work only if the Crop dialog is opened.
Public property | CropBoxY | Gets Crop Box Y position. The property is supposed to work only if the Crop dialog is opened.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentToolDialogName | Gets the RadImageEditor current tool name.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FlipMode | Gets the Flip mode of the RadImageEditor.
Public property | Height | Gets/Sets ImageEditor height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageHeight | Gets/Sets Image width in pixels.
Public property | ImageWidth | Gets/Sets Image width in pixels.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRedoAvailable | Gets or sets whether the Image editor redo is enabled.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsUndoAvailable | Gets or sets whether the Image editor undo is enabled.
Public property | Left | Gets/Sets the left of the ImageEditor.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Opacity | Gets/Sets Image opacity.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ResizeEnabled | Gets or sets whether the Image editor resizing is enabled.
Public property | RotationAngle | Gets Rotation angle.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ServerUrl | Gets the RadImageEditor image Server URL.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Top | Gets/Sets the top of the ImageEditor.
Public property | Url | Gets the RadImageEditor image URL.
Public property | Visible | Gets or sets whether the Image editor is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets ImageEditor width in pixels.
Public property | ZoomLevel | Gets the image Zoom level.

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


RadImageEditor Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor Constructor
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadImageEditor()()()() | Initializes a new instance of the RadImageEditor class.
Public method | RadImageEditor(Element) | Initializes a new instance of the RadImageEditor class.

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


RadImageEditor Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor Constructor
RadImageEditor Class See Also Send Feedback
Initializes a new instance of the RadImageEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadImageEditor()
Visual Basic
Public Sub New
Visual C++
public:
RadImageEditor()

See Also

RadImageEditor Class
RadImageEditor Overload
Telerik.WebAii.Controls.Html Namespace


RadImageEditor Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor Constructor (Element)
RadImageEditor Class See Also Send Feedback
Initializes a new instance of the RadImageEditor class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadImageEditor(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadImageEditor(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadImageEditor Class
RadImageEditor Overload
Telerik.WebAii.Controls.Html Namespace


RadImageEditor Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor Methods
RadImageEditor Class See Also Send Feedback

The RadImageEditor type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CloseCurrentToolDialog | Closes the current ImageEditor tool.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | CropBoxSet | Sets Crop Box position and size (x, y, width, height).
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FlipHorizontally | ImageEditor Flip horizontally action
Public method | FlipVertically | ImageEditor Flip vertically action
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | HideTool | Hides an Image Editor tool.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Redo()()()() | ImageEditor Redo 1 action.
Public method | Redo(Int32) | ImageEditor Redo action. Need to specify steps number.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ResetImage | ImageEditor reset image changes.
Public method | ResizeImage | ImageEditor Resize image action. Need to specify width and height.
Public method | Rotate | ImageEditor Rotate Left action
Public method | RotateLeft | ImageEditor Rotate Left action
Public method | RotateRight | ImageEditor Rotate Right action
Public method | SaveOnClient()()()() | ImageEditor save image on client action.
Public method | SaveOnClient(String) | ImageEditor save image on client action. Need to specify file name.
Public method | SaveOnServer()()()() | ImageEditor save image on server action.
Public method | SaveOnServer(String) | ImageEditor save image on server action. Need to specify file name.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectOptionFromToolbar | Opens ImageEditor tool by name.
Public method | SetText(String) | Sets text to Image.
Public method | SetText(String, Int32, Int32, String, Int32, String) | Sets text to Image.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowTool | Shows an Image Editor tool.
Public method | ToolEnable | Enables/Disables an Image Editor tool.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Undo()()()() | ImageEditor Undo 1 action.
Public method | Undo(Int32) | ImageEditor Undo action. Need to specify steps number.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Public method | ZoomActualSize | ImageEditor zoom to image actual size.
Public method | ZoomBestFit | ImageEditor zoom to fit best.
Public method | ZoomImage | ImageEditor zoom out action.
Public method | ZoomIn | ImageEditor zoom in action.
Public method | ZoomOut | ImageEditor zoom out action.

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..AssignElement Method
RadImageEditor Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..CallMethod Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Capture Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Click Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


CloseCurrentToolDialog Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..CloseCurrentToolDialog Method
RadImageEditor Class See Also Send Feedback
Closes the current ImageEditor tool.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CloseCurrentToolDialog()
Visual Basic
Public Sub CloseCurrentToolDialog
Visual C++
public:
void CloseCurrentToolDialog()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ControlAssert Method
RadImageEditor Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.ControlAssert"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


CropBoxSet Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..CropBoxSet Method
RadImageEditor Class See Also Send Feedback
Sets Crop Box position and size (x, y, width, height).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CropBoxSet(
    int x,
    int y,
    int width,
    int height
)
Visual Basic
Public Sub CropBoxSet ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
void CropBoxSet(
    int x,
    int y,
    int width,
    int height
)

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.CropBoxSet(System.Int32,System.Int32,System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.CropBoxSet(System.Int32,System.Int32,System.Int32,System.Int32)"]

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.CropBoxSet(System.Int32,System.Int32,System.Int32,System.Int32)"]

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.CropBoxSet(System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..DragTo Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


FlipHorizontally Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..FlipHorizontally Method
RadImageEditor Class See Also Send Feedback
ImageEditor Flip horizontally action

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FlipHorizontally()
Visual Basic
Public Sub FlipHorizontally
Visual C++
public:
void FlipHorizontally()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


FlipVertically Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..FlipVertically Method
RadImageEditor Class See Also Send Feedback
ImageEditor Flip vertically action

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FlipVertically()
Visual Basic
Public Sub FlipVertically
Visual C++
public:
void FlipVertically()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..GetValue Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


HideTool Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..HideTool Method
RadImageEditor Class See Also Send Feedback
Hides an Image Editor tool.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void HideTool(
    ImageEditorTool tool
)
Visual Basic
Public Sub HideTool ( _
    tool As ImageEditorTool _
)
Visual C++
public:
void HideTool(
    ImageEditorTool tool
)

Parameters

tool
Type: Telerik.WebAii.Controls.Html..::..ImageEditorTool

[Missing <param name="tool"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.HideTool(Telerik.WebAii.Controls.Html.ImageEditorTool)"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..InvokeEvent Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..MouseClick Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..MouseHover Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


Redo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Redo Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Redo()()()() | ImageEditor Redo 1 action.
Public method | Redo(Int32) | ImageEditor Redo action. Need to specify steps number.

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


Redo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Redo Method
RadImageEditor Class See Also Send Feedback
ImageEditor Redo 1 action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Redo()
Visual Basic
Public Sub Redo
Visual C++
public:
void Redo()

See Also

RadImageEditor Class
Redo Overload
Telerik.WebAii.Controls.Html Namespace


Redo Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Redo Method (Int32)
RadImageEditor Class See Also Send Feedback
ImageEditor Redo action. Need to specify steps number.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Redo(
    int redoSteps
)
Visual Basic
Public Sub Redo ( _
    redoSteps As Integer _
)
Visual C++
public:
void Redo(
    int redoSteps
)

Parameters

redoSteps
Type: System..::..Int32

[Missing <param name="redoSteps"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.Redo(System.Int32)"]

See Also

RadImageEditor Class
Redo Overload
Telerik.WebAii.Controls.Html Namespace


ResetImage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ResetImage Method
RadImageEditor Class See Also Send Feedback
ImageEditor reset image changes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ResetImage()
Visual Basic
Public Sub ResetImage
Visual C++
public:
void ResetImage()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


ResizeImage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ResizeImage Method
RadImageEditor Class See Also Send Feedback
ImageEditor Resize image action. Need to specify width and height.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ResizeImage(
    int width,
    int height
)
Visual Basic
Public Sub ResizeImage ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
void ResizeImage(
    int width,
    int height
)

Parameters

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.ResizeImage(System.Int32,System.Int32)"]

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.ResizeImage(System.Int32,System.Int32)"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


Rotate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Rotate Method
RadImageEditor Class See Also Send Feedback
ImageEditor Rotate Left action

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Rotate(
    ImageEditorRotation rotation
)
Visual Basic
Public Sub Rotate ( _
    rotation As ImageEditorRotation _
)
Visual C++
public:
void Rotate(
    ImageEditorRotation rotation
)

Parameters

rotation
Type: Telerik.WebAii.Controls.Html..::..ImageEditorRotation

[Missing <param name="rotation"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.Rotate(Telerik.WebAii.Controls.Html.ImageEditorRotation)"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


RotateLeft Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..RotateLeft Method
RadImageEditor Class See Also Send Feedback
ImageEditor Rotate Left action

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void RotateLeft()
Visual Basic
Public Sub RotateLeft
Visual C++
public:
void RotateLeft()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


RotateRight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..RotateRight Method
RadImageEditor Class See Also Send Feedback
ImageEditor Rotate Right action

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void RotateRight()
Visual Basic
Public Sub RotateRight
Visual C++
public:
void RotateRight()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


SaveOnClient Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SaveOnClient Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveOnClient()()()() | ImageEditor save image on client action.
Public method | SaveOnClient(String) | ImageEditor save image on client action. Need to specify file name.

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


SaveOnClient Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SaveOnClient Method
RadImageEditor Class See Also Send Feedback
ImageEditor save image on client action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SaveOnClient()
Visual Basic
Public Sub SaveOnClient
Visual C++
public:
void SaveOnClient()

See Also

RadImageEditor Class
SaveOnClient Overload
Telerik.WebAii.Controls.Html Namespace


SaveOnClient Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SaveOnClient Method (String)
RadImageEditor Class See Also Send Feedback
ImageEditor save image on client action. Need to specify file name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SaveOnClient(
    string name
)
Visual Basic
Public Sub SaveOnClient ( _
    name As String _
)
Visual C++
public:
void SaveOnClient(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SaveOnClient(System.String)"]

See Also

RadImageEditor Class
SaveOnClient Overload
Telerik.WebAii.Controls.Html Namespace


SaveOnServer Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SaveOnServer Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SaveOnServer()()()() | ImageEditor save image on server action.
Public method | SaveOnServer(String) | ImageEditor save image on server action. Need to specify file name.

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


SaveOnServer Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SaveOnServer Method
RadImageEditor Class See Also Send Feedback
ImageEditor save image on server action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SaveOnServer()
Visual Basic
Public Sub SaveOnServer
Visual C++
public:
void SaveOnServer()

See Also

RadImageEditor Class
SaveOnServer Overload
Telerik.WebAii.Controls.Html Namespace


SaveOnServer Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SaveOnServer Method (String)
RadImageEditor Class See Also Send Feedback
ImageEditor save image on server action. Need to specify file name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SaveOnServer(
    string name
)
Visual Basic
Public Sub SaveOnServer ( _
    name As String _
)
Visual C++
public:
void SaveOnServer(
    String^ name
)

Parameters

name
Type: System..::..String

[Missing <param name="name"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SaveOnServer(System.String)"]

See Also

RadImageEditor Class
SaveOnServer Overload
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ScrollToVisible Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


SelectOptionFromToolbar Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SelectOptionFromToolbar Method
RadImageEditor Class See Also Send Feedback
Opens ImageEditor tool by name.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectOptionFromToolbar(
    ImageEditorTool tool
)
Visual Basic
Public Sub SelectOptionFromToolbar ( _
    tool As ImageEditorTool _
)
Visual C++
public:
void SelectOptionFromToolbar(
    ImageEditorTool tool
)

Parameters

tool
Type: Telerik.WebAii.Controls.Html..::..ImageEditorTool

[Missing <param name="tool"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SelectOptionFromToolbar(Telerik.WebAii.Controls.Html.ImageEditorTool)"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


SetText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SetText Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetText(String) | Sets text to Image.
Public method | SetText(String, Int32, Int32, String, Int32, String) | Sets text to Image.

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


SetText Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SetText Method (String)
RadImageEditor Class See Also Send Feedback
Sets text to Image.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SetText(
    string text
)
Visual Basic
Public Sub SetText ( _
    text As String _
)
Visual C++
public:
void SetText(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SetText(System.String)"]

See Also

RadImageEditor Class
SetText Overload
Telerik.WebAii.Controls.Html Namespace


SetText Method (String, Int32, Int32, String, Int32, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SetText Method (String, Int32, Int32, String, Int32, String)
RadImageEditor Class See Also Send Feedback
Sets text to Image.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SetText(
    string text,
    int x,
    int y,
    string fontFamily,
    int fontSize,
    string color
)
Visual Basic
Public Sub SetText ( _
    text As String, _
    x As Integer, _
    y As Integer, _
    fontFamily As String, _
    fontSize As Integer, _
    color As String _
)
Visual C++
public:
void SetText(
    String^ text,
    int x,
    int y,
    String^ fontFamily,
    int fontSize,
    String^ color
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SetText(System.String,System.Int32,System.Int32,System.String,System.Int32,System.String)"]

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SetText(System.String,System.Int32,System.Int32,System.String,System.Int32,System.String)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SetText(System.String,System.Int32,System.Int32,System.String,System.Int32,System.String)"]

fontFamily
Type: System..::..String

[Missing <param name="fontFamily"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SetText(System.String,System.Int32,System.Int32,System.String,System.Int32,System.String)"]

fontSize
Type: System..::..Int32

[Missing <param name="fontSize"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SetText(System.String,System.Int32,System.Int32,System.String,System.Int32,System.String)"]

color
Type: System..::..String

[Missing <param name="color"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.SetText(System.String,System.Int32,System.Int32,System.String,System.Int32,System.String)"]

See Also

RadImageEditor Class
SetText Overload
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..SetValue Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


ShowTool Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ShowTool Method
RadImageEditor Class See Also Send Feedback
Shows an Image Editor tool.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowTool(
    ImageEditorTool tool
)
Visual Basic
Public Sub ShowTool ( _
    tool As ImageEditorTool _
)
Visual C++
public:
void ShowTool(
    ImageEditorTool tool
)

Parameters

tool
Type: Telerik.WebAii.Controls.Html..::..ImageEditorTool

[Missing <param name="tool"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.ShowTool(Telerik.WebAii.Controls.Html.ImageEditorTool)"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


ToolEnable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ToolEnable Method
RadImageEditor Class See Also Send Feedback
Enables/Disables an Image Editor tool.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ToolEnable(
    ImageEditorTool tool,
    bool isEnabled
)
Visual Basic
Public Sub ToolEnable ( _
    tool As ImageEditorTool, _
    isEnabled As Boolean _
)
Visual C++
public:
void ToolEnable(
    ImageEditorTool tool,
    bool isEnabled
)

Parameters

tool
Type: Telerik.WebAii.Controls.Html..::..ImageEditorTool

[Missing <param name="tool"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.ToolEnable(Telerik.WebAii.Controls.Html.ImageEditorTool,System.Boolean)"]

isEnabled
Type: System..::..Boolean

[Missing <param name="isEnabled"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.ToolEnable(Telerik.WebAii.Controls.Html.ImageEditorTool,System.Boolean)"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


Undo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Undo Method
RadImageEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Undo()()()() | ImageEditor Undo 1 action.
Public method | Undo(Int32) | ImageEditor Undo action. Need to specify steps number.

See Also

RadImageEditor Class
RadImageEditor Members
Telerik.WebAii.Controls.Html Namespace


Undo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Undo Method
RadImageEditor Class See Also Send Feedback
ImageEditor Undo 1 action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Undo()
Visual Basic
Public Sub Undo
Visual C++
public:
void Undo()

See Also

RadImageEditor Class
Undo Overload
Telerik.WebAii.Controls.Html Namespace


Undo Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..Undo Method (Int32)
RadImageEditor Class See Also Send Feedback
ImageEditor Undo action. Need to specify steps number.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Undo(
    int undoSteps
)
Visual Basic
Public Sub Undo ( _
    undoSteps As Integer _
)
Visual C++
public:
void Undo(
    int undoSteps
)

Parameters

undoSteps
Type: System..::..Int32

[Missing <param name="undoSteps"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.Undo(System.Int32)"]

See Also

RadImageEditor Class
Undo Overload
Telerik.WebAii.Controls.Html Namespace


ZoomActualSize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ZoomActualSize Method
RadImageEditor Class See Also Send Feedback
ImageEditor zoom to image actual size.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ZoomActualSize()
Visual Basic
Public Sub ZoomActualSize
Visual C++
public:
void ZoomActualSize()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


ZoomBestFit Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ZoomBestFit Method
RadImageEditor Class See Also Send Feedback
ImageEditor zoom to fit best.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ZoomBestFit()
Visual Basic
Public Sub ZoomBestFit
Visual C++
public:
void ZoomBestFit()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


ZoomImage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ZoomImage Method
RadImageEditor Class See Also Send Feedback
ImageEditor zoom out action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ZoomImage(
    int percentage
)
Visual Basic
Public Sub ZoomImage ( _
    percentage As Integer _
)
Visual C++
public:
void ZoomImage(
    int percentage
)

Parameters

percentage
Type: System..::..Int32

[Missing <param name="percentage"/> documentation for "M:Telerik.WebAii.Controls.Html.RadImageEditor.ZoomImage(System.Int32)"]

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


ZoomIn Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ZoomIn Method
RadImageEditor Class See Also Send Feedback
ImageEditor zoom in action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ZoomIn()
Visual Basic
Public Sub ZoomIn
Visual C++
public:
void ZoomIn()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


ZoomOut Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor..::..ZoomOut Method
RadImageEditor Class See Also Send Feedback
ImageEditor zoom out action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ZoomOut()
Visual Basic
Public Sub ZoomOut
Visual C++
public:
void ZoomOut()

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


RadImageEditor Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadImageEditor Properties
RadImageEditor Class See Also Send Feedback

The RadImageEditor type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the ImageEditor
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CropBoxHeight | Gets Crop Box height. The property is supposed to work only if the Crop dialog is opened.
Public property | CropBoxWidth | Gets Crop Box width. The property is supposed to work only if the Crop dialog is opened.
Public property | CropBoxX | Gets Crop Box X position. The property is supposed to work only if the Crop dialog is opened.
Public property | CropBoxY | Gets Crop Box Y position. The property is supposed to work only if the Crop dialog is opened.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentToolDialogName | Gets the RadImageEditor current tool name.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FlipMode | Gets the Flip mode of the RadImageEditor.
Public property | Height | Gets/Sets ImageEditor height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageHeight | Gets/Sets Image width in pixels.
Public property | ImageWidth | Gets/Sets Image width in pixels.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRedoAvailable | Gets or sets whether the Image editor redo is enabled.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsUndoAvailable | Gets or sets whether the Image editor undo is enabled.
Public property | Left | Gets/Sets the left of the ImageEditor.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Opacity | Gets/Sets Image opacity.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ResizeEnabled | Gets or sets whether the Image editor resizing is enabled.
Public property | RotationAngle | Gets Rotation angle.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ServerUrl | Gets the RadImageEditor image Server URL.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Top | Gets/Sets the top of the ImageEditor.
Public property | Url | Gets the RadImageEditor image URL.
Public property | Visible | Gets or sets whether the Image editor is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets ImageEditor width in pixels.
Public property | ZoomLevel | Gets the image Zoom level.

See Also

RadImageEditor Class
Telerik.WebAii.Controls.Html Namespace


RadInput Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput Members
RadInput Class Constructors Methods Properties See Also Send Feedback

The RadInput type exposes the following members.

Constructors

 | Name | Description
Public method | RadInput()()()() | Initializes a new instance of the RadInput class.
Public method | RadInput(Element) | Initializes a new instance of the RadInput class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Disable | Disables the input.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Overrides HtmlControl..::..Focus()()()().)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input.
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input.
Public method | TypeText(String, Int32) | Types text into the input.
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50.
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control.
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus.
Public property | EditValue | Get the value of the control as it is formatted when the control has focus.
Public property | EmptyMessage | Get or set the message that appears when the value is not set.
Public property | Enabled | Get whether the input is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox.
Public property | InputValue | Get or set the client-side input value.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused.
Public property | IsReadOnly | Get whether the input is in read-only mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SingleInputRendering | Gets the control input rendering type.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


RadInput Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput Constructor
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadInput()()()() | Initializes a new instance of the RadInput class.
Public method | RadInput(Element) | Initializes a new instance of the RadInput class.

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


RadInput Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput Constructor
RadInput Class See Also Send Feedback
Initializes a new instance of the RadInput class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadInput()
Visual Basic
Public Sub New
Visual C++
public:
RadInput()

See Also

RadInput Class
RadInput Overload
Telerik.WebAii.Controls.Html Namespace


RadInput Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput Constructor (Element)
RadInput Class See Also Send Feedback
Initializes a new instance of the RadInput class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadInput(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadInput(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadInput.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadInput Class
RadInput Overload
Telerik.WebAii.Controls.Html Namespace


RadInput Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput Methods
RadInput Class See Also Send Feedback

The RadInput type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Disable | Disables the input.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Overrides HtmlControl..::..Focus()()()().)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input.
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input.
Public method | TypeText(String, Int32) | Types text into the input.
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50.
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..AssignElement Method
RadInput Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Blur Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..Blur Method
RadInput Class See Also Send Feedback
Removes focus from the text box, moving it to the next control in the tab order of the page.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Blur()
Visual Basic
Public Sub Blur
Visual C++
public:
void Blur()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..CallMethod Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..Capture Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


Clear Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..Clear Method
RadInput Class See Also Send Feedback
Sets the value of the text box to an empty string.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..Click Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..ControlAssert Method
RadInput Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..Disable Method
RadInput Class See Also Send Feedback
Disables the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..DragTo Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..Enable Method
RadInput Class See Also Send Feedback
Enables the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..Focus Method
RadInput Class See Also Send Feedback
Sets focus to the text box so that the user can edit its value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Focus()
Visual Basic
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..GetValue Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..InvokeEvent Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..MouseClick Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..MouseHover Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..ScrollToVisible Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


SelectAllText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..SelectAllText Method
RadInput Class See Also Send Feedback
Selects all the text of the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectAllText()
Visual Basic
Public Sub SelectAllText
Visual C++
public:
void SelectAllText()

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


SelectText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..SelectText Method
RadInput Class See Also Send Feedback
Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectText(
    int start,
    int end
)
Visual Basic
Public Sub SelectText ( _
    start As Integer, _
    end As Integer _
)
Visual C++
public:
void SelectText(
    int start,
    int end
)

Parameters

start
Type: System..::..Int32
The start index.
end
Type: System..::..Int32
The end index.

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..SetValue Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..TypeText Method
RadInput Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String) | Types text into the input.
Public method | TypeText(String, Int32) | Types text into the input.
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50.
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input.

See Also

RadInput Class
RadInput Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..TypeText Method (String)
RadInput Class See Also Send Feedback
Types text into the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TypeText(
    string valueTyped
)
Visual Basic
Public Sub TypeText ( _
    valueTyped As String _
)
Visual C++
public:
void TypeText(
    String^ valueTyped
)

Parameters

valueTyped
Type: System..::..String
The text to be typed.

See Also

RadInput Class
TypeText Overload
Telerik.WebAii.Controls.Html Namespace


TypeText Method (String, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..TypeText Method (String, Int32)
RadInput Class See Also Send Feedback
Types text into the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TypeText(
    string valueTyped,
    int keyPressTime
)
Visual Basic
Public Sub TypeText ( _
    valueTyped As String, _
    keyPressTime As Integer _
)
Visual C++
public:
void TypeText(
    String^ valueTyped,
    int keyPressTime
)

Parameters

valueTyped
Type: System..::..String
The text to be typed.
keyPressTime
Type: System..::..Int32
The time for each keypress.

See Also

RadInput Class
TypeText Overload
Telerik.WebAii.Controls.Html Namespace


TypeText Method (String, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..TypeText Method (String, Int32, Boolean)
RadInput Class See Also Send Feedback
Types text into the input. KeyHoldTime internally set to 50.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TypeText(
    string valueTyped,
    int keyPressTime,
    bool resetCursorPosition
)
Visual Basic
Public Sub TypeText ( _
    valueTyped As String, _
    keyPressTime As Integer, _
    resetCursorPosition As Boolean _
)
Visual C++
public:
void TypeText(
    String^ valueTyped,
    int keyPressTime,
    bool resetCursorPosition
)

Parameters

valueTyped
Type: System..::..String
The text to be typed.
keyPressTime
Type: System..::..Int32
The time for each keypress.
resetCursorPosition
Type: System..::..Boolean

[Missing <param name="resetCursorPosition"/> documentation for "M:Telerik.WebAii.Controls.Html.RadInput.TypeText(System.String,System.Int32,System.Boolean)"]

See Also

RadInput Class
TypeText Overload
Telerik.WebAii.Controls.Html Namespace


TypeText Method (String, Int32, Int32, Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput..::..TypeText Method (String, Int32, Int32, Boolean)
RadInput Class See Also Send Feedback
Types text into the input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TypeText(
    string valueTyped,
    int keyPressTime,
    int keyHoldTime,
    bool resetCursorPosition
)
Visual Basic
Public Sub TypeText ( _
    valueTyped As String, _
    keyPressTime As Integer, _
    keyHoldTime As Integer, _
    resetCursorPosition As Boolean _
)
Visual C++
public:
void TypeText(
    String^ valueTyped,
    int keyPressTime,
    int keyHoldTime,
    bool resetCursorPosition
)

Parameters

valueTyped
Type: System..::..String
The text to be typed.
keyPressTime
Type: System..::..Int32
The time for each keypress.
keyHoldTime
Type: System..::..Int32
The time to hold the key pressed.
resetCursorPosition
Type: System..::..Boolean
Specifies whether the cursor position should be reset to the beginning of the input before typing.

See Also

RadInput Class
TypeText Overload
Telerik.WebAii.Controls.Html Namespace


RadInput Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInput Properties
RadInput Class See Also Send Feedback

The RadInput type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control.
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus.
Public property | EditValue | Get the value of the control as it is formatted when the control has focus.
Public property | EmptyMessage | Get or set the message that appears when the value is not set.
Public property | Enabled | Get whether the input is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox.
Public property | InputValue | Get or set the client-side input value.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused.
Public property | IsReadOnly | Get whether the input is in read-only mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SingleInputRendering | Gets the control input rendering type.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInput Class
Telerik.WebAii.Controls.Html Namespace


RadInputManager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager Members
RadInputManager Class Constructors Methods Properties See Also Send Feedback

The RadInputManager type exposes the following members.

Constructors

 | Name | Description
Public method | RadInputManager()()()() | Initializes a new instance of the RadInputManager class.
Public method | RadInputManager(Element) | Initializes a new instance of the RadInputManager class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlContainerControl.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManager Class
Telerik.WebAii.Controls.Html Namespace


RadInputManager Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager Constructor
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadInputManager()()()() | Initializes a new instance of the RadInputManager class.
Public method | RadInputManager(Element) | Initializes a new instance of the RadInputManager class.

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


RadInputManager Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager Constructor
RadInputManager Class See Also Send Feedback
Initializes a new instance of the RadInputManager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadInputManager()
Visual Basic
Public Sub New
Visual C++
public:
RadInputManager()

See Also

RadInputManager Class
RadInputManager Overload
Telerik.WebAii.Controls.Html Namespace


RadInputManager Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager Constructor (Element)
RadInputManager Class See Also Send Feedback
Initializes a new instance of the RadInputManager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadInputManager(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadInputManager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadInputManager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadInputManager Class
RadInputManager Overload
Telerik.WebAii.Controls.Html Namespace


RadInputManager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager Methods
RadInputManager Class See Also Send Feedback

The RadInputManager type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlContainerControl.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadInputManager Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..CallMethod Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..Capture Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..Click Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..DragTo Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..GetValue Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..InvokeEvent Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..MouseClick Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..MouseHover Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..ScrollToVisible Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager..::..SetValue Method
RadInputManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadInputManager Class
RadInputManager Members
Telerik.WebAii.Controls.Html Namespace


RadInputManager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManager Properties
RadInputManager Class See Also Send Feedback

The RadInputManager type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManager Class
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox Members
RadInputManagerTextBox Class Constructors Methods Properties See Also Send Feedback

The RadInputManagerTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | RadInputManagerTextBox()()()() | Initializes a new instance of the RadInputManagerTextBox class.
Public method | RadInputManagerTextBox(Element) | Initializes a new instance of the RadInputManagerTextBox class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides RadInput..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Overrides RadInput..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the EmptyMessage of the input.
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides RadInput..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the Text of the Input.
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox Constructor
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadInputManagerTextBox()()()() | Initializes a new instance of the RadInputManagerTextBox class.
Public method | RadInputManagerTextBox(Element) | Initializes a new instance of the RadInputManagerTextBox class.

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox Constructor
RadInputManagerTextBox Class See Also Send Feedback
Initializes a new instance of the RadInputManagerTextBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadInputManagerTextBox()
Visual Basic
Public Sub New
Visual C++
public:
RadInputManagerTextBox()

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Overload
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox Constructor (Element)
RadInputManagerTextBox Class See Also Send Feedback
Initializes a new instance of the RadInputManagerTextBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadInputManagerTextBox(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadInputManagerTextBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadInputManagerTextBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Overload
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox Methods
RadInputManagerTextBox Class See Also Send Feedback

The RadInputManagerTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides RadInput..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..AssignElement Method
RadInputManagerTextBox Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..CallMethod Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..Capture Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..Click Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..DragTo Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..GetValue Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..InvokeEvent Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..MouseClick Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..MouseHover Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..ScrollToVisible Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..SetValue Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox..::..TypeText Method
RadInputManagerTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)

See Also

RadInputManagerTextBox Class
RadInputManagerTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadInputManagerTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadInputManagerTextBox Properties
RadInputManagerTextBox Class See Also Send Feedback

The RadInputManagerTextBox type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Overrides RadInput..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the EmptyMessage of the input.
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides RadInput..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the Text of the Input.
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadInputManagerTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadListBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox Members
RadListBox Class Constructors Methods Properties See Also Send Feedback

The RadListBox type exposes the following members.

Constructors

 | Name | Description
Public method | RadListBox()()()() | Initializes a new instance of the RadListBox class.
Public method | RadListBox(Element) | Initializes a new instance of the RadListBox class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadListBox control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Delete | Click the delete button.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Get a list of items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MoveDown | Click the move down button.
Public method | MoveUp | Click the move up button.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TransferAllFrom | Click the transfer all from button.
Public method | TransferAllTo | Click the transfer all to button.
Public method | TransferFrom | Click the transfer from button.
Public method | TransferTo | Click the transfer to button.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllowTransferOnDoubleClick | Get the value of the AllowTransferOnDoubleClick property.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get whether Listbox AutoPostBack is enabled.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonPosition | ListBox button position.
Public property | CheckBoxesEnabled | Get whether the ListBox check box support is enabled.
Public property | CheckedItems | Gets a list of the checked items.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteButton | The delete button.
Public property | ElementOffsetWidth | Get the offset width of the Listbox element.
Public property | Enabled | Get whether Listbox is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Get the list of items.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MoveDownButton | The move down button.
Public property | MoveUpButton | The move up button.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets the selected index of the RadListBox. Returns '-1' if there is no selected item.
Public property | SelectedItems | Gets a list of the selected items.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TransferAllFromButton | The transfer all from button.
Public property | TransferAllToButton | The transfer all to button.
Public property | TransferFromButton | The transfer from button.
Public property | TransferToButton | The transfer to button.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


RadListBox Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox Constructor
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadListBox()()()() | Initializes a new instance of the RadListBox class.
Public method | RadListBox(Element) | Initializes a new instance of the RadListBox class.

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


RadListBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox Constructor
RadListBox Class See Also Send Feedback
Initializes a new instance of the RadListBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadListBox()
Visual Basic
Public Sub New
Visual C++
public:
RadListBox()

See Also

RadListBox Class
RadListBox Overload
Telerik.WebAii.Controls.Html Namespace


RadListBox Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox Constructor (Element)
RadListBox Class See Also Send Feedback
Initializes a new instance of the RadListBox class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadListBox(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadListBox(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBox.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListBox Class
RadListBox Overload
Telerik.WebAii.Controls.Html Namespace


RadListBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox Methods
RadListBox Class See Also Send Feedback

The RadListBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadListBox control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Delete | Click the delete button.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Get a list of items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MoveDown | Click the move down button.
Public method | MoveUp | Click the move up button.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TransferAllFrom | Click the transfer all from button.
Public method | TransferAllTo | Click the transfer all to button.
Public method | TransferFrom | Click the transfer from button.
Public method | TransferTo | Click the transfer to button.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..AssignElement Method
RadListBox Class See Also Send Feedback
Assign the DOM element to be the RadListBox control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBox.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..CallMethod Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..Capture Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..Click Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..ControlAssert Method
RadListBox Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


Delete Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..Delete Method
RadListBox Class See Also Send Feedback
Click the delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete
Visual C++
public:
void Delete()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..DragTo Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..FindItems Method
RadListBox Class See Also Send Feedback
Get a list of items matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadListBoxItem> FindItems(
    Predicate<RadListBoxItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of RadListBoxItem) _
) As IList(Of RadListBoxItem)
Visual C++
public:
IList<RadListBoxItem^>^ FindItems(
    Predicate<RadListBoxItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadListBoxItem >)>)>
The predicate, i.e. (item => item.Text == myText).

Return Value

The items matching the given predicate.

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..GetValue Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..InvokeEvent Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..MouseClick Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..MouseHover Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


MoveDown Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..MoveDown Method
RadListBox Class See Also Send Feedback
Click the move down button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void MoveDown()
Visual Basic
Public Sub MoveDown
Visual C++
public:
void MoveDown()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


MoveUp Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..MoveUp Method
RadListBox Class See Also Send Feedback
Click the move up button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void MoveUp()
Visual Basic
Public Sub MoveUp
Visual C++
public:
void MoveUp()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..ScrollToVisible Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..SetValue Method
RadListBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadListBox Class
RadListBox Members
Telerik.WebAii.Controls.Html Namespace


TransferAllFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..TransferAllFrom Method
RadListBox Class See Also Send Feedback
Click the transfer all from button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TransferAllFrom()
Visual Basic
Public Sub TransferAllFrom
Visual C++
public:
void TransferAllFrom()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferAllTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..TransferAllTo Method
RadListBox Class See Also Send Feedback
Click the transfer all to button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TransferAllTo()
Visual Basic
Public Sub TransferAllTo
Visual C++
public:
void TransferAllTo()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferFrom Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..TransferFrom Method
RadListBox Class See Also Send Feedback
Click the transfer from button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TransferFrom()
Visual Basic
Public Sub TransferFrom
Visual C++
public:
void TransferFrom()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


TransferTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox..::..TransferTo Method
RadListBox Class See Also Send Feedback
Click the transfer to button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TransferTo()
Visual Basic
Public Sub TransferTo
Visual C++
public:
void TransferTo()

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


RadListBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBox Properties
RadListBox Class See Also Send Feedback

The RadListBox type exposes the following members.

Properties

 | Name | Description
Public property | AllowTransferOnDoubleClick | Get the value of the AllowTransferOnDoubleClick property.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get whether Listbox AutoPostBack is enabled.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonPosition | ListBox button position.
Public property | CheckBoxesEnabled | Get whether the ListBox check box support is enabled.
Public property | CheckedItems | Gets a list of the checked items.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteButton | The delete button.
Public property | ElementOffsetWidth | Get the offset width of the Listbox element.
Public property | Enabled | Get whether Listbox is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Get the list of items.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MoveDownButton | The move down button.
Public property | MoveUpButton | The move up button.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndex | Gets the selected index of the RadListBox. Returns '-1' if there is no selected item.
Public property | SelectedItems | Gets a list of the selected items.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TransferAllFromButton | The transfer all from button.
Public property | TransferAllToButton | The transfer all to button.
Public property | TransferFromButton | The transfer from button.
Public property | TransferToButton | The transfer to button.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBox Class
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem Members
RadListBoxItem Class Constructors Methods Properties See Also Send Feedback

The RadListBoxItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadListBoxItem()()()() | Initializes a new instance of the RadListBoxItem class.
Public method | RadListBoxItem(Element) | Initializes a new instance of the RadListBoxItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadListBoxItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Check the item.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disables the item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragAndDropTo | Drag and drop the item to the specified control. Drops into the center of the element.
Public method | DragAndDropWithOffset | Drag and drop the item with the specified x and y offset.
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Select the item.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UNCheck | UNCheck the item.
Public method | UNSelect | Unselect the item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllowDrag | Returns/sets the AllowDrag property.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Checkable | Get whether the item contains check box so that it can be checked.
Public property | Checked | Check/set whether the item is checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the List item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Gets the value of the ImageUrl property.
Public property | Index | Get the List item index.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemValue | Get or set the value for this item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression that defines the pattern for a listbox item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Check/set whether the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the text for this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Gets the tooltip of the item.
Public property | Visible | Get whether the List item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem Constructor
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadListBoxItem()()()() | Initializes a new instance of the RadListBoxItem class.
Public method | RadListBoxItem(Element) | Initializes a new instance of the RadListBoxItem class.

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem Constructor
RadListBoxItem Class See Also Send Feedback
Initializes a new instance of the RadListBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadListBoxItem()
Visual Basic
Public Sub New
Visual C++
public:
RadListBoxItem()

See Also

RadListBoxItem Class
RadListBoxItem Overload
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem Constructor (Element)
RadListBoxItem Class See Also Send Feedback
Initializes a new instance of the RadListBoxItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadListBoxItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadListBoxItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBoxItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListBoxItem Class
RadListBoxItem Overload
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem Methods
RadListBoxItem Class See Also Send Feedback

The RadListBoxItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadListBoxItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Check the item.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disables the item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragAndDropTo | Drag and drop the item to the specified control. Drops into the center of the element.
Public method | DragAndDropWithOffset | Drag and drop the item with the specified x and y offset.
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Select the item.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UNCheck | UNCheck the item.
Public method | UNSelect | Unselect the item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..AssignElement Method
RadListBoxItem Class See Also Send Feedback
Assign the DOM element to be the RadListBoxItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBoxItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..CallMethod Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..Capture Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..Check Method
RadListBoxItem Class See Also Send Feedback
Check the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Check()
Visual Basic
Public Sub Check
Visual C++
public:
void Check()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..Click Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..ControlAssert Method
RadListBoxItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..Disable Method
RadListBoxItem Class See Also Send Feedback
Disables the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


DragAndDropTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..DragAndDropTo Method
RadListBoxItem Class See Also Send Feedback
Drag and drop the item to the specified control. Drops into the center of the element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragAndDropTo(
    HtmlControl destination
)
Visual Basic
Public Sub DragAndDropTo ( _
    destination As HtmlControl _
)
Visual C++
public:
void DragAndDropTo(
    HtmlControl^ destination
)

Parameters

destination
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The destination control.

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


DragAndDropWithOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..DragAndDropWithOffset Method
RadListBoxItem Class See Also Send Feedback
Drag and drop the item with the specified x and y offset.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragAndDropWithOffset(
    int offsetX,
    int offsetY
)
Visual Basic
Public Sub DragAndDropWithOffset ( _
    offsetX As Integer, _
    offsetY As Integer _
)
Visual C++
public:
void DragAndDropWithOffset(
    int offsetX,
    int offsetY
)

Parameters

offsetX
Type: System..::..Int32

[Missing <param name="offsetX"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBoxItem.DragAndDropWithOffset(System.Int32,System.Int32)"]

offsetY
Type: System..::..Int32

[Missing <param name="offsetY"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListBoxItem.DragAndDropWithOffset(System.Int32,System.Int32)"]

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..DragTo Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..Enable Method
RadListBoxItem Class See Also Send Feedback
Enables the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..GetValue Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..InvokeEvent Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..MouseClick Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..MouseHover Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..ScrollToVisible Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..Select Method
RadListBoxItem Class See Also Send Feedback
Select the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..SetValue Method
RadListBoxItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
RadListBoxItem Members
Telerik.WebAii.Controls.Html Namespace


UNCheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..UNCheck Method
RadListBoxItem Class See Also Send Feedback
UNCheck the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UNCheck()
Visual Basic
Public Sub UNCheck
Visual C++
public:
void UNCheck()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


UNSelect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem..::..UNSelect Method
RadListBoxItem Class See Also Send Feedback
Unselect the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UNSelect()
Visual Basic
Public Sub UNSelect
Visual C++
public:
void UNSelect()

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadListBoxItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListBoxItem Properties
RadListBoxItem Class See Also Send Feedback

The RadListBoxItem type exposes the following members.

Properties

 | Name | Description
Public property | AllowDrag | Returns/sets the AllowDrag property.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Checkable | Get whether the item contains check box so that it can be checked.
Public property | Checked | Check/set whether the item is checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the List item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Gets the value of the ImageUrl property.
Public property | Index | Get the List item index.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemValue | Get or set the value for this item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression that defines the pattern for a listbox item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Check/set whether the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the text for this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Gets the tooltip of the item.
Public property | Visible | Get whether the List item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListBoxItem Class
Telerik.WebAii.Controls.Html Namespace


RadListView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView Members
RadListView Class Constructors Methods Properties See Also Send Feedback

The RadListView type exposes the following members.

Constructors

 | Name | Description
Public method | RadListView()()()() | Initializes a new instance of the RadListView class.
Public method | RadListView(Element) | Initializes a new instance of the RadListView class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of the ListView.
Protected property | ClientObjectElement | Get the span element which holds the client-side object of the ListView.
Public property | ClientSideLocator | The client-side locator of the RadCalendar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentLayout | Get the layout type of the ListView.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PageCount | Get the page count of the ListView.
Public property | PageSize | Get the page size of the ListView.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


RadListView Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView Constructor
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadListView()()()() | Initializes a new instance of the RadListView class.
Public method | RadListView(Element) | Initializes a new instance of the RadListView class.

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


RadListView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView Constructor
RadListView Class See Also Send Feedback
Initializes a new instance of the RadListView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadListView()
Visual Basic
Public Sub New
Visual C++
public:
RadListView()

See Also

RadListView Class
RadListView Overload
Telerik.WebAii.Controls.Html Namespace


RadListView Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView Constructor (Element)
RadListView Class See Also Send Feedback
Initializes a new instance of the RadListView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadListView(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadListView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadListView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadListView Class
RadListView Overload
Telerik.WebAii.Controls.Html Namespace


RadListView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView Methods
RadListView Class See Also Send Feedback

The RadListView type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..AssignElement Method
RadListView Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..CallMethod Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..Capture Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..Click Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..DragTo Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..GetValue Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..InvokeEvent Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..MouseClick Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..MouseHover Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..ScrollToVisible Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView..::..SetValue Method
RadListView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadListView Class
RadListView Members
Telerik.WebAii.Controls.Html Namespace


RadListView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadListView Properties
RadListView Class See Also Send Feedback

The RadListView type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of the ListView.
Protected property | ClientObjectElement | Get the span element which holds the client-side object of the ListView.
Public property | ClientSideLocator | The client-side locator of the RadCalendar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentLayout | Get the layout type of the ListView.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PageCount | Get the page count of the ListView.
Public property | PageSize | Get the page size of the ListView.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadListView Class
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox Members
RadMaskedTextBox Class Constructors Methods Properties See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | RadMaskedTextBox | Initializes a new instance of the RadMaskedTextBox class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from RadInput.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllowEmptyEnumerations | Get or set whether enumerated mask parts can be set to an empty string.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | HideOnBlur | Get or set whether the prompt characters and literals are not displayed when the text box is empty and does not have focus.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsMultiline | Get whether the text mode is MultiLine.
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ValueWithLiterals | Get the value of the text box, including the literal characters from the mask.
Public property | ValueWithPromptAndLiterals | Get the value of the text box, including the prompt characters and literal characters from the mask.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox Constructor
RadMaskedTextBox Class See Also Send Feedback
Initializes a new instance of the RadMaskedTextBox class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMaskedTextBox()
Visual Basic
Public Sub New
Visual C++
public:
RadMaskedTextBox()

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox Methods
RadMaskedTextBox Class See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from RadInput.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..CallMethod Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..Capture Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..Click Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..DragTo Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..GetValue Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..InvokeEvent Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..MouseClick Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..MouseHover Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..ScrollToVisible Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..SetValue Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox..::..TypeText Method
RadMaskedTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)

See Also

RadMaskedTextBox Class
RadMaskedTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadMaskedTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMaskedTextBox Properties
RadMaskedTextBox Class See Also Send Feedback

The RadMaskedTextBox type exposes the following members.

Properties

 | Name | Description
Public property | AllowEmptyEnumerations | Get or set whether enumerated mask parts can be set to an empty string.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | HideOnBlur | Get or set whether the prompt characters and literals are not displayed when the text box is empty and does not have focus.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsMultiline | Get whether the text mode is MultiLine.
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ValueWithLiterals | Get the value of the text box, including the literal characters from the mask.
Public property | ValueWithPromptAndLiterals | Get the value of the text box, including the prompt characters and literal characters from the mask.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMaskedTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadMenu Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu Members
RadMenu Class Constructors Methods Properties See Also Send Feedback

The RadMenu type exposes the following members.

Constructors

 | Name | Description
Public method | RadMenu()()()() | Initializes a new instance of the RadMenu class.
Public method | RadMenu(Element) | Initializes a new instance of the RadMenu class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the Menu control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Closes all opened items from the menu.
Public method | ControlAssert | Get the RadControlInstance initialized for this control.
Public method | Disable | Disables all items in the menu. Clicking on any item has no effect, child items cannot be opened.
Public method | DisableEvents | Disables the control client-side event emitting.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables all items in the menu.
Public method | EnableEvents | Enables the control client-side event emitting. Events are enabled by default.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds item by Text.
Public method | FindItemByValue | Finds item by Value.
Public method | FindItems | Get the list of the items find by given predicate.
Public method | FindItemsByLevel | Get the list of items by given level.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Brings the focus to the menu so that it can be controlled via the keyboard. (Overrides HtmlControl..::..Focus()()()().)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeItems | Initializes all menu items.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllItems | Get all the Menu items.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | Clicked | True if the user has clicked on a root menu item to expand it when ClickToOpen is True.
Public property | ClickToOpen | Get whether the menu ClickToOpen property is set to true.
Public property | ClientId | The client ID of this Menu control.
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the menu is enabled.
Public property | EnableRootItemScroll | True if the menu EnableRootItemScroll property is true.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedItem | Returns the focused root level item. Null if no item has focus.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsGridFilteringMenu | Get whether the menu is a context menu as RadGrid filtering menu.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OpenedItem | Returns the opened root level item. If no item is opened at the root level returns null.
Public property | OrientationType | Menu orientation.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootItems | Get the list of the root items.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


RadMenu Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu Constructor
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadMenu()()()() | Initializes a new instance of the RadMenu class.
Public method | RadMenu(Element) | Initializes a new instance of the RadMenu class.

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


RadMenu Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu Constructor
RadMenu Class See Also Send Feedback
Initializes a new instance of the RadMenu class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenu()
Visual Basic
Public Sub New
Visual C++
public:
RadMenu()

See Also

RadMenu Class
RadMenu Overload
Telerik.WebAii.Controls.Html Namespace


RadMenu Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu Constructor (Element)
RadMenu Class See Also Send Feedback
Initializes a new instance of the RadMenu class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenu(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadMenu(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMenu Class
RadMenu Overload
Telerik.WebAii.Controls.Html Namespace


RadMenu Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu Methods
RadMenu Class See Also Send Feedback

The RadMenu type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the Menu control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Closes all opened items from the menu.
Public method | ControlAssert | Get the RadControlInstance initialized for this control.
Public method | Disable | Disables all items in the menu. Clicking on any item has no effect, child items cannot be opened.
Public method | DisableEvents | Disables the control client-side event emitting.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables all items in the menu.
Public method | EnableEvents | Enables the control client-side event emitting. Events are enabled by default.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds item by Text.
Public method | FindItemByValue | Finds item by Value.
Public method | FindItems | Get the list of the items find by given predicate.
Public method | FindItemsByLevel | Get the list of items by given level.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Brings the focus to the menu so that it can be controlled via the keyboard. (Overrides HtmlControl..::..Focus()()()().)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeItems | Initializes all menu items.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..AssignElement Method
RadMenu Class See Also Send Feedback
Assign the DOM element to be the Menu control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..CallMethod Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..Capture Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..Click Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..Close Method
RadMenu Class See Also Send Feedback
Closes all opened items from the menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..ControlAssert Method
RadMenu Class See Also Send Feedback
Get the RadControlInstance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.ControlAssert"]

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..Disable Method
RadMenu Class See Also Send Feedback
Disables all items in the menu. Clicking on any item has no effect, child items cannot be opened.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


DisableEvents Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..DisableEvents Method
RadMenu Class See Also Send Feedback
Disables the control client-side event emitting.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DisableEvents()
Visual Basic
Public Sub DisableEvents
Visual C++
public:
void DisableEvents()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..DragTo Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..Enable Method
RadMenu Class See Also Send Feedback
Enables all items in the menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


EnableEvents Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..EnableEvents Method
RadMenu Class See Also Send Feedback
Enables the control client-side event emitting. Events are enabled by default.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void EnableEvents()
Visual Basic
Public Sub EnableEvents
Visual C++
public:
void EnableEvents()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..FindItem Method
RadMenu Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenuItem FindItem(
    Predicate<RadMenuItem> predicate
)
Visual Basic
Public Function FindItem ( _
    predicate As Predicate(Of RadMenuItem) _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItem(
    Predicate<RadMenuItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadMenuItem >)>)>
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..FindItemByText Method
RadMenu Class See Also Send Feedback
Finds item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenuItem FindItemByText(
    string itemText
)
Visual Basic
Public Function FindItemByText ( _
    itemText As String _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::..String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.FindItemByText(System.String)"]

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..FindItemByValue Method
RadMenu Class See Also Send Feedback
Finds item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenuItem FindItemByValue(
    string itemValue
)
Visual Basic
Public Function FindItemByValue ( _
    itemValue As String _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::..String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenu.FindItemByValue(System.String)"]

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..FindItems Method
RadMenu Class See Also Send Feedback
Get the list of the items find by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadMenuItem> FindItems(
    Predicate<RadMenuItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of RadMenuItem) _
) As IList(Of RadMenuItem)
Visual C++
public:
IList<RadMenuItem^>^ FindItems(
    Predicate<RadMenuItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadMenuItem >)>)>
The predicate used for search criteria.

Return Value

The list of the root items.

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


FindItemsByLevel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..FindItemsByLevel Method
RadMenu Class See Also Send Feedback
Get the list of items by given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadMenuItem> FindItemsByLevel(
    int level
)
Visual Basic
Public Function FindItemsByLevel ( _
    level As Integer _
) As IList(Of RadMenuItem)
Visual C++
public:
IList<RadMenuItem^>^ FindItemsByLevel(
    int level
)

Parameters

level
Type: System..::..Int32
The level to search for.

Return Value

The list of items by the given level.

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..Focus Method
RadMenu Class See Also Send Feedback
Brings the focus to the menu so that it can be controlled via the keyboard.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Focus()
Visual Basic
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..GetValue Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


InitializeItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..InitializeItems Method
RadMenu Class See Also Send Feedback
Initializes all menu items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void InitializeItems()
Visual Basic
Public Sub InitializeItems
Visual C++
public:
void InitializeItems()

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..InvokeEvent Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..MouseClick Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..MouseHover Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..ScrollToVisible Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu..::..SetValue Method
RadMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadMenu Class
RadMenu Members
Telerik.WebAii.Controls.Html Namespace


RadMenu Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenu Properties
RadMenu Class See Also Send Feedback

The RadMenu type exposes the following members.

Properties

 | Name | Description
Public property | AllItems | Get all the Menu items.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | Clicked | True if the user has clicked on a root menu item to expand it when ClickToOpen is True.
Public property | ClickToOpen | Get whether the menu ClickToOpen property is set to true.
Public property | ClientId | The client ID of this Menu control.
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the menu is enabled.
Public property | EnableRootItemScroll | True if the menu EnableRootItemScroll property is true.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedItem | Returns the focused root level item. Null if no item has focus.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsGridFilteringMenu | Get whether the menu is a context menu as RadGrid filtering menu.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OpenedItem | Returns the opened root level item. If no item is opened at the root level returns null.
Public property | OrientationType | Menu orientation.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootItems | Get the list of the root items.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenu Class
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem Members
RadMenuItem Class Constructors Methods Properties See Also Send Feedback

The RadMenuItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadMenuItem()()()() | Initializes a new instance of the RadMenuItem class.
Public method | RadMenuItem(Element) | Initializes a new instance of the RadMenuItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadMenuItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the item.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the item or navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)
Public method | Close | Closes a item.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds item by Text.
Public method | FindItemByValue | Finds item by Value.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the item. (Overrides HtmlControl..::..Focus()()()().)
Public method | FocusFirstChild | Moves focus to the first child of the item.
Public method | FocusLastChild | Moves focus to the last child of the item.
Public method | FocusNextItem | Moves focus to the next item.
Public method | FocusPreviousItem | Moves focus to the previous item.
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the item.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Navigate | Navigate if NavigateUrl is set.
Public method | Open | Opens the item.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the item.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator used in most of the properties. Returns 'null' for item separators. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get or set whether the menu item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get or set whether this item is focused.
Public property | HasChildren | Check whether the item has children.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the item.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Returns the list of child items of this menu item.
Public property | ItemValue | Get or set the value for this item.
Public property | Level | Get the level of the item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a menu item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Get or set the navigate url of this item.
Public property | Opened | Get whether this item is opened.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the menu item is selected.
Public property | ShouldNavigate | Check whether the item should navigate.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the text of this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem Constructor
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadMenuItem()()()() | Initializes a new instance of the RadMenuItem class.
Public method | RadMenuItem(Element) | Initializes a new instance of the RadMenuItem class.

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem Constructor
RadMenuItem Class See Also Send Feedback
Initializes a new instance of the RadMenuItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenuItem()
Visual Basic
Public Sub New
Visual C++
public:
RadMenuItem()

See Also

RadMenuItem Class
RadMenuItem Overload
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem Constructor (Element)
RadMenuItem Class See Also Send Feedback
Initializes a new instance of the RadMenuItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenuItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadMenuItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMenuItem Class
RadMenuItem Overload
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem Methods
RadMenuItem Class See Also Send Feedback

The RadMenuItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadMenuItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the item.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the item or navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)
Public method | Close | Closes a item.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds item by Text.
Public method | FindItemByValue | Finds item by Value.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the item. (Overrides HtmlControl..::..Focus()()()().)
Public method | FocusFirstChild | Moves focus to the first child of the item.
Public method | FocusLastChild | Moves focus to the last child of the item.
Public method | FocusNextItem | Moves focus to the next item.
Public method | FocusPreviousItem | Moves focus to the previous item.
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the item.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Navigate | Navigate if NavigateUrl is set.
Public method | Open | Opens the item.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the item.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..AssignElement Method
RadMenuItem Class See Also Send Feedback
Assign the DOM element to be the RadMenuItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Blur Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Blur Method
RadMenuItem Class See Also Send Feedback
Blur the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Blur()
Visual Basic
Public Sub Blur
Visual C++
public:
void Blur()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..CallMethod Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Capture Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Click Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the item or navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Click Method
RadMenuItem Class See Also Send Feedback
Click the item or navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadMenuItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Click Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Click Method (Boolean)
RadMenuItem Class See Also Send Feedback
Click the item or navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click(
    bool isClosing
)
Visual Basic
Public Overrides Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
) override

Parameters

isClosing
Type: System..::..Boolean

[Missing <param name="isClosing"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.Click(System.Boolean)"]

See Also

RadMenuItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Close Method
RadMenuItem Class See Also Send Feedback
Closes a item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..ControlAssert Method
RadMenuItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..DragTo Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..FindItem Method
RadMenuItem Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenuItem FindItem(
    Predicate<RadMenuItem> predicate
)
Visual Basic
Public Function FindItem ( _
    predicate As Predicate(Of RadMenuItem) _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItem(
    Predicate<RadMenuItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadMenuItem >)>)>
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..FindItemByText Method
RadMenuItem Class See Also Send Feedback
Finds item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenuItem FindItemByText(
    string itemText
)
Visual Basic
Public Function FindItemByText ( _
    itemText As String _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::..String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.FindItemByText(System.String)"]

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..FindItemByValue Method
RadMenuItem Class See Also Send Feedback
Finds item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMenuItem FindItemByValue(
    string itemValue
)
Visual Basic
Public Function FindItemByValue ( _
    itemValue As String _
) As RadMenuItem
Visual C++
public:
RadMenuItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::..String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadMenuItem.FindItemByValue(System.String)"]

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Focus Method
RadMenuItem Class See Also Send Feedback
Focus the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Focus()
Visual Basic
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FocusFirstChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..FocusFirstChild Method
RadMenuItem Class See Also Send Feedback
Moves focus to the first child of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FocusFirstChild()
Visual Basic
Public Sub FocusFirstChild
Visual C++
public:
void FocusFirstChild()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FocusLastChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..FocusLastChild Method
RadMenuItem Class See Also Send Feedback
Moves focus to the last child of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FocusLastChild()
Visual Basic
Public Sub FocusLastChild
Visual C++
public:
void FocusLastChild()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FocusNextItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..FocusNextItem Method
RadMenuItem Class See Also Send Feedback
Moves focus to the next item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FocusNextItem()
Visual Basic
Public Sub FocusNextItem
Visual C++
public:
void FocusNextItem()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


FocusPreviousItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..FocusPreviousItem Method
RadMenuItem Class See Also Send Feedback
Moves focus to the previous item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FocusPreviousItem()
Visual Basic
Public Sub FocusPreviousItem
Visual C++
public:
void FocusPreviousItem()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..GetValue Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Hide Method
RadMenuItem Class See Also Send Feedback
Hide the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..InvokeEvent Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..MouseClick Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..MouseHover Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Navigate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Navigate Method
RadMenuItem Class See Also Send Feedback
Navigate if NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Navigate()
Visual Basic
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Open Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Open Method
RadMenuItem Class See Also Send Feedback
Opens the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Open()
Visual Basic
Public Sub Open
Visual C++
public:
void Open()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..ScrollToVisible Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..SetValue Method
RadMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadMenuItem Class
RadMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem..::..Show Method
RadMenuItem Class See Also Send Feedback
Show the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


RadMenuItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMenuItem Properties
RadMenuItem Class See Also Send Feedback

The RadMenuItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator used in most of the properties. Returns 'null' for item separators. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get or set whether the menu item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get or set whether this item is focused.
Public property | HasChildren | Check whether the item has children.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the item.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Returns the list of child items of this menu item.
Public property | ItemValue | Get or set the value for this item.
Public property | Level | Get the level of the item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a menu item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Get or set the navigate url of this item.
Public property | Opened | Get whether this item is opened.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the menu item is selected.
Public property | ShouldNavigate | Check whether the item should navigate.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the text of this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMenuItem Class
Telerik.WebAii.Controls.Html Namespace


RadMonthYearPicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker Members
RadMonthYearPicker Class Constructors Methods Properties See Also Send Feedback

The RadMonthYearPicker type exposes the following members.

Constructors

 | Name | Description
Public method | RadMonthYearPicker()()()() | Initializes a new instance of the RadMonthYearPicker class.
Public method | RadMonthYearPicker(Element) | Initializes a new instance of the RadMonthYearPicker class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
Public method | OpenFastNavPopup | Clicks on the button which opens the FastNavigationPopup.
Public method | OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
Public property | DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
Public property | DatePopUpButton | The date popup button of the picker. (Inherited from RadPicker.)
Protected property | DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Public property | Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FastNavigationPopup | Gets the FastNavigationPopup object of the picker
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
Public property | IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFastNavigationPopupOpen | Gets the visibility of FastNavigationPopup
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
Public property | MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker. (Inherited from RadPicker.)
Public property | PickerType | Gets the Picker control type. (Inherited from RadPicker.)
Public property | PopupDirection | Gets the direction in which the popup opens. (Inherited from RadPicker.)
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker. (Inherited from RadPicker.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
Telerik.WebAii.Controls.Html Namespace


RadMonthYearPicker Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker Constructor
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadMonthYearPicker()()()() | Initializes a new instance of the RadMonthYearPicker class.
Public method | RadMonthYearPicker(Element) | Initializes a new instance of the RadMonthYearPicker class.

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


RadMonthYearPicker Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker Constructor
RadMonthYearPicker Class See Also Send Feedback
Initializes a new instance of the RadMonthYearPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMonthYearPicker()
Visual Basic
Public Sub New
Visual C++
public:
RadMonthYearPicker()

See Also

RadMonthYearPicker Class
RadMonthYearPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadMonthYearPicker Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker Constructor (Element)
RadMonthYearPicker Class See Also Send Feedback
Initializes a new instance of the RadMonthYearPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadMonthYearPicker(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadMonthYearPicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadMonthYearPicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadMonthYearPicker Class
RadMonthYearPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadMonthYearPicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker Methods
RadMonthYearPicker Class See Also Send Feedback

The RadMonthYearPicker type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
Public method | OpenFastNavPopup | Clicks on the button which opens the FastNavigationPopup.
Public method | OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadMonthYearPicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..CallMethod Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..Capture Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..Click Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..DragTo Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..GetValue Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..InvokeEvent Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..MouseClick Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..MouseHover Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


OpenFastNavPopup Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..OpenFastNavPopup Method
RadMonthYearPicker Class See Also Send Feedback
Clicks on the button which opens the FastNavigationPopup.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenFastNavPopup()
Visual Basic
Public Sub OpenFastNavPopup
Visual C++
public:
void OpenFastNavPopup()

See Also

RadMonthYearPicker Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..ScrollToVisible Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker..::..SetValue Method
RadMonthYearPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
RadMonthYearPicker Members
Telerik.WebAii.Controls.Html Namespace


RadMonthYearPicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadMonthYearPicker Properties
RadMonthYearPicker Class See Also Send Feedback

The RadMonthYearPicker type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
Public property | DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
Public property | DatePopUpButton | The date popup button of the picker. (Inherited from RadPicker.)
Protected property | DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Public property | Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FastNavigationPopup | Gets the FastNavigationPopup object of the picker
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
Public property | IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFastNavigationPopupOpen | Gets the visibility of FastNavigationPopup
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
Public property | MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker. (Inherited from RadPicker.)
Public property | PickerType | Gets the Picker control type. (Inherited from RadPicker.)
Public property | PopupDirection | Gets the direction in which the popup opens. (Inherited from RadPicker.)
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker. (Inherited from RadPicker.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadMonthYearPicker Class
Telerik.WebAii.Controls.Html Namespace


RadNotification Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification Members
RadNotification Class Constructors Methods Properties See Also Send Feedback

The RadNotification type exposes the following members.

Constructors

 | Name | Description
Public method | RadNotification()()()() | Initializes a new instance of the RadNotification class.
Public method | RadNotification(Element) | Initializes a new instance of the RadNotification class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides the Notification.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Move | Moves the Notification to the specified coordinates (horizontal, vertical).
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectMenuItemByText | Selects an item from the notification Menu.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows the Notification.
Public method | ShowMenu | Shows the notification Menu.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Public method | Visible | Check whether the Notification is visible.

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Animation | Gets/Sets the RadNotification animation type.
Public property | AnimationDuration | Gets/Sets the Notification Animation Duration.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoCloseDelay | Gets/Sets the Notification Animation Duration.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the Notification control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Gets or sets whether the Notification is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Returns whether the notification is focused.
Public property | Height | Gets/Sets Notification height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | KeepOnMouseOver | Gets or sets whether the Notification KeepOnMouseOver functionality is enabled.
Public property | Left | Gets/Sets the left of the Notification.
Public property | LoadType | Gets/Sets the content load type of the RadNotification.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OffsetX | Gets/Sets x-coordinate Notification Offset in pixels.
Public property | OffsetY | Gets/Sets y-coordinate Notification Offset in pixels.
Public property | Opacity | Gets/Sets the Notification opacity.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pinned | Gets or sets whether the Notification pinned functionality is enabled.
Public property | Position | Gets/Sets the Notification position.
Public property | Scrolling | Gets/Sets the RadNotification animation type.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the RadNotification text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets the RadNotification title value.
Public property | Top | Gets/Sets the top of the Notification.
Public property | VisibleTitlebar | Gets or sets whether the Notification Titlebar is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets Notification width in pixels.

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


RadNotification Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification Constructor
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadNotification()()()() | Initializes a new instance of the RadNotification class.
Public method | RadNotification(Element) | Initializes a new instance of the RadNotification class.

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


RadNotification Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification Constructor
RadNotification Class See Also Send Feedback
Initializes a new instance of the RadNotification class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadNotification()
Visual Basic
Public Sub New
Visual C++
public:
RadNotification()

See Also

RadNotification Class
RadNotification Overload
Telerik.WebAii.Controls.Html Namespace


RadNotification Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification Constructor (Element)
RadNotification Class See Also Send Feedback
Initializes a new instance of the RadNotification class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadNotification(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadNotification(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadNotification.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadNotification Class
RadNotification Overload
Telerik.WebAii.Controls.Html Namespace


RadNotification Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification Methods
RadNotification Class See Also Send Feedback

The RadNotification type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides the Notification.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Move | Moves the Notification to the specified coordinates (horizontal, vertical).
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectMenuItemByText | Selects an item from the notification Menu.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows the Notification.
Public method | ShowMenu | Shows the notification Menu.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)
Public method | Visible | Check whether the Notification is visible.

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..AssignElement Method
RadNotification Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..CallMethod Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..Capture Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..Click Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..ControlAssert Method
RadNotification Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadNotification.ControlAssert"]

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..DragTo Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..GetValue Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..Hide Method
RadNotification Class See Also Send Feedback
Hides the Notification.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..InvokeEvent Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..MouseClick Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..MouseHover Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


Move Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..Move Method
RadNotification Class See Also Send Feedback
Moves the Notification to the specified coordinates (horizontal, vertical).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Move(
    int x,
    int y
)
Visual Basic
Public Sub Move ( _
    x As Integer, _
    y As Integer _
)
Visual C++
public:
void Move(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32

[Missing <param name="x"/> documentation for "M:Telerik.WebAii.Controls.Html.RadNotification.Move(System.Int32,System.Int32)"]

y
Type: System..::..Int32

[Missing <param name="y"/> documentation for "M:Telerik.WebAii.Controls.Html.RadNotification.Move(System.Int32,System.Int32)"]

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..ScrollToVisible Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


SelectMenuItemByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..SelectMenuItemByText Method
RadNotification Class See Also Send Feedback
Selects an item from the notification Menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectMenuItemByText(
    string text
)
Visual Basic
Public Sub SelectMenuItemByText ( _
    text As String _
)
Visual C++
public:
void SelectMenuItemByText(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadNotification.SelectMenuItemByText(System.String)"]

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..SetValue Method
RadNotification Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadNotification Class
RadNotification Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..Show Method
RadNotification Class See Also Send Feedback
Shows the Notification.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


ShowMenu Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..ShowMenu Method
RadNotification Class See Also Send Feedback
Shows the notification Menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowMenu()
Visual Basic
Public Sub ShowMenu
Visual C++
public:
void ShowMenu()

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


Visible Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification..::..Visible Method
RadNotification Class See Also Send Feedback
Check whether the Notification is visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool Visible()
Visual Basic
Public Function Visible As Boolean
Visual C++
public:
bool Visible()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadNotification.Visible"]

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


RadNotification Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNotification Properties
RadNotification Class See Also Send Feedback

The RadNotification type exposes the following members.

Properties

 | Name | Description
Public property | Animation | Gets/Sets the RadNotification animation type.
Public property | AnimationDuration | Gets/Sets the Notification Animation Duration.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoCloseDelay | Gets/Sets the Notification Animation Duration.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the Notification control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Gets or sets whether the Notification is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Returns whether the notification is focused.
Public property | Height | Gets/Sets Notification height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | KeepOnMouseOver | Gets or sets whether the Notification KeepOnMouseOver functionality is enabled.
Public property | Left | Gets/Sets the left of the Notification.
Public property | LoadType | Gets/Sets the content load type of the RadNotification.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OffsetX | Gets/Sets x-coordinate Notification Offset in pixels.
Public property | OffsetY | Gets/Sets y-coordinate Notification Offset in pixels.
Public property | Opacity | Gets/Sets the Notification opacity.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pinned | Gets or sets whether the Notification pinned functionality is enabled.
Public property | Position | Gets/Sets the Notification position.
Public property | Scrolling | Gets/Sets the RadNotification animation type.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the RadNotification text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets the RadNotification title value.
Public property | Top | Gets/Sets the top of the Notification.
Public property | VisibleTitlebar | Gets or sets whether the Notification Titlebar is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets Notification width in pixels.

See Also

RadNotification Class
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox Members
RadNumericTextBox Class Constructors Methods Properties See Also Send Feedback

The RadNumericTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | RadNumericTextBox | Initializes a new instance of the RadNumericTextBox class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides RadInput..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | SpinDownClick | NumericTextBox spin down button click.
Public method | SpinUpClick | NumericTextBox spin up button click.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsNegative | Get whether the value of the text box is a negative number.
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxValue | Get or set the maximum value the user can enter.
Public property | MinValue | Get or set the minimum value the user can enter.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ShowSpinButtons | Get whether the numeric text box has an associated pair of spin buttons.
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox Constructor
RadNumericTextBox Class See Also Send Feedback
Initializes a new instance of the RadNumericTextBox class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadNumericTextBox()
Visual Basic
Public Sub New
Visual C++
public:
RadNumericTextBox()

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox Methods
RadNumericTextBox Class See Also Send Feedback

The RadNumericTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides RadInput..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | SpinDownClick | NumericTextBox spin down button click.
Public method | SpinUpClick | NumericTextBox spin up button click.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..AssignElement Method
RadNumericTextBox Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..CallMethod Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..Capture Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..Click Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..DragTo Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..GetValue Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..InvokeEvent Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..MouseClick Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..MouseHover Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..ScrollToVisible Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..SetValue Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


SpinDownClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..SpinDownClick Method
RadNumericTextBox Class See Also Send Feedback
NumericTextBox spin down button click.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SpinDownClick()
Visual Basic
Public Sub SpinDownClick
Visual C++
public:
void SpinDownClick()

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


SpinUpClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..SpinUpClick Method
RadNumericTextBox Class See Also Send Feedback
NumericTextBox spin up button click.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SpinUpClick()
Visual Basic
Public Sub SpinUpClick
Visual C++
public:
void SpinUpClick()

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox..::..TypeText Method
RadNumericTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)

See Also

RadNumericTextBox Class
RadNumericTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadNumericTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadNumericTextBox Properties
RadNumericTextBox Class See Also Send Feedback

The RadNumericTextBox type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsNegative | Get whether the value of the text box is a negative number.
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxValue | Get or set the maximum value the user can enter.
Public property | MinValue | Get or set the minimum value the user can enter.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ShowSpinButtons | Get whether the numeric text box has an associated pair of spin buttons.
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadNumericTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadOrgChart Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart Members
RadOrgChart Class Constructors Methods Properties See Also Send Feedback

The RadOrgChart type exposes the following members.

Constructors

 | Name | Description
Public method | RadOrgChart()()()() | Initializes a new instance of the RadOrgChart class.
Public method | RadOrgChart(Element) | Initializes a new instance of the RadOrgChart class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlContainerControl.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Get the list of items.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
Telerik.WebAii.Controls.Html Namespace


RadOrgChart Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart Constructor
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadOrgChart()()()() | Initializes a new instance of the RadOrgChart class.
Public method | RadOrgChart(Element) | Initializes a new instance of the RadOrgChart class.

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


RadOrgChart Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart Constructor
RadOrgChart Class See Also Send Feedback
Initializes a new instance of the RadOrgChart class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadOrgChart()
Visual Basic
Public Sub New
Visual C++
public:
RadOrgChart()

See Also

RadOrgChart Class
RadOrgChart Overload
Telerik.WebAii.Controls.Html Namespace


RadOrgChart Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart Constructor (Element)
RadOrgChart Class See Also Send Feedback
Initializes a new instance of the RadOrgChart class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadOrgChart(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadOrgChart(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadOrgChart.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadOrgChart Class
RadOrgChart Overload
Telerik.WebAii.Controls.Html Namespace


RadOrgChart Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart Methods
RadOrgChart Class See Also Send Feedback

The RadOrgChart type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlContainerControl.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadOrgChart Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..CallMethod Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..Capture Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..Click Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..ControlAssert Method
RadOrgChart Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadOrgChart Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..DragTo Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..GetValue Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..InvokeEvent Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..MouseClick Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..MouseHover Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..ScrollToVisible Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart..::..SetValue Method
RadOrgChart Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadOrgChart Class
RadOrgChart Members
Telerik.WebAii.Controls.Html Namespace


RadOrgChart Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChart Properties
RadOrgChart Class See Also Send Feedback

The RadOrgChart type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Get the list of items.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadOrgChart Class
Telerik.WebAii.Controls.Html Namespace


RadOrgChartItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem Members
RadOrgChartItem Class Constructors Methods Properties See Also Send Feedback

The RadOrgChartItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadOrgChartItem()()()() | Initializes a new instance of the RadOrgChartItem class.
Public method | RadOrgChartItem(Element) | Initializes a new instance of the RadOrgChartItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadOrgChartItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HierarchicalIndex | Get the HierarchicalIndex for this item.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression that defines the pattern for a OrgChart item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text for this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
Telerik.WebAii.Controls.Html Namespace


RadOrgChartItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem Constructor
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadOrgChartItem()()()() | Initializes a new instance of the RadOrgChartItem class.
Public method | RadOrgChartItem(Element) | Initializes a new instance of the RadOrgChartItem class.

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


RadOrgChartItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem Constructor
RadOrgChartItem Class See Also Send Feedback
Initializes a new instance of the RadOrgChartItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadOrgChartItem()
Visual Basic
Public Sub New
Visual C++
public:
RadOrgChartItem()

See Also

RadOrgChartItem Class
RadOrgChartItem Overload
Telerik.WebAii.Controls.Html Namespace


RadOrgChartItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem Constructor (Element)
RadOrgChartItem Class See Also Send Feedback
Initializes a new instance of the RadOrgChartItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadOrgChartItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadOrgChartItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadOrgChartItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadOrgChartItem Class
RadOrgChartItem Overload
Telerik.WebAii.Controls.Html Namespace


RadOrgChartItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem Methods
RadOrgChartItem Class See Also Send Feedback

The RadOrgChartItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadOrgChartItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadOrgChartItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..AssignElement Method
RadOrgChartItem Class See Also Send Feedback
Assign the DOM element to be the RadOrgChartItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadOrgChartItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadOrgChartItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..CallMethod Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..Capture Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..Click Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..ControlAssert Method
RadOrgChartItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadOrgChartItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..DragTo Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..GetValue Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..InvokeEvent Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..MouseClick Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..MouseHover Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..ScrollToVisible Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem..::..SetValue Method
RadOrgChartItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
RadOrgChartItem Members
Telerik.WebAii.Controls.Html Namespace


RadOrgChartItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadOrgChartItem Properties
RadOrgChartItem Class See Also Send Feedback

The RadOrgChartItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HierarchicalIndex | Get the HierarchicalIndex for this item.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression that defines the pattern for a OrgChart item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text for this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadOrgChartItem Class
Telerik.WebAii.Controls.Html Namespace


RadPane Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane Members
RadPane Class Constructors Methods Properties See Also Send Feedback

The RadPane type exposes the following members.

Constructors

 | Name | Description
Public method | RadPane()()()() | Initializes a new instance of the RadPane class.
Public method | RadPane(Element) | Initializes a new instance of the RadPane class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapses the pane.
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the pane.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadPane. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Collapsed | Determines or set whether the pane is collapsed.
Public property | ContentUrl | Gets/Sets the content url of the pane.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets the height of the pane.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsExternalContent | Determines whether the page is loaded as content in the pane.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadPane. (Overrides Control..::..LocatorExpression.)
Public property | Locked | Determines or set whether the pane is locked.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxHeight | Gets/Sets the maximum of the pane's height.
Public property | MaxWidth | Gets/Sets the maximum of the pane's width.
Public property | MinHeight | Gets/Sets the minimum of the pane's height.
Public property | MinWidth | Gets/Sets the minimum of the pane's width.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollingEnabled | Determines whether the scrolling of pane is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the width of the pane.

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


RadPane Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane Constructor
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadPane()()()() | Initializes a new instance of the RadPane class.
Public method | RadPane(Element) | Initializes a new instance of the RadPane class.

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


RadPane Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane Constructor
RadPane Class See Also Send Feedback
Initializes a new instance of the RadPane class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPane()
Visual Basic
Public Sub New
Visual C++
public:
RadPane()

See Also

RadPane Class
RadPane Overload
Telerik.WebAii.Controls.Html Namespace


RadPane Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane Constructor (Element)
RadPane Class See Also Send Feedback
Initializes a new instance of the RadPane class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPane(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPane(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPane.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPane Class
RadPane Overload
Telerik.WebAii.Controls.Html Namespace


RadPane Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane Methods
RadPane Class See Also Send Feedback

The RadPane type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapses the pane.
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the pane.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..AssignElement Method
RadPane Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..CallMethod Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..Capture Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..Click Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..Collapse Method
RadPane Class See Also Send Feedback
Collapses the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..ControlAssert Method
RadPane Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..DragTo Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..Expand Method
RadPane Class See Also Send Feedback
Expands the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..GetValue Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..InvokeEvent Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..MouseClick Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..MouseHover Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..ScrollToVisible Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane..::..SetValue Method
RadPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPane Class
RadPane Members
Telerik.WebAii.Controls.Html Namespace


RadPane Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPane Properties
RadPane Class See Also Send Feedback

The RadPane type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadPane. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Collapsed | Determines or set whether the pane is collapsed.
Public property | ContentUrl | Gets/Sets the content url of the pane.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets the height of the pane.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsExternalContent | Determines whether the page is loaded as content in the pane.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadPane. (Overrides Control..::..LocatorExpression.)
Public property | Locked | Determines or set whether the pane is locked.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxHeight | Gets/Sets the maximum of the pane's height.
Public property | MaxWidth | Gets/Sets the maximum of the pane's width.
Public property | MinHeight | Gets/Sets the minimum of the pane's height.
Public property | MinWidth | Gets/Sets the minimum of the pane's width.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollingEnabled | Determines whether the scrolling of pane is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the width of the pane.

See Also

RadPane Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar Members
RadPanelBar Class Constructors Methods Properties See Also Send Feedback

The RadPanelBar type exposes the following members.

Constructors

 | Name | Description
Public method | RadPanelBar()()()() | Initializes a new instance of the RadPanelBar class.
Public method | RadPanelBar(Element) | Initializes a new instance of the RadPanelBar class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the PanelBar control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disable the panelbar.
Public method | DisableEvents | Disables the panel bar's client-side event emitting.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enable the panelbar.
Public method | EnableEvents | Enables the panel bar's client-side event emitting. Events are enabled by default.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds item by Text.
Public method | FindItemByValue | Finds item by Value.
Public method | FindItems | Find items by given predicate.
Public method | FindItemsByLevel | Find the panelbar items by given level.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeItems | Initializes all RadPanelBar items.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllItems | Get the list of all PanelBar items.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of this PanelBar control.
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the panelbar is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FullExpandedItem | Get whether the panelbar FullExpandedItem property is true.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootItems | Get root items of the PanelBar.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SingleExpandedItem | Get whether the panelbar SingleExpandedItem property is true.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar Constructor
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadPanelBar()()()() | Initializes a new instance of the RadPanelBar class.
Public method | RadPanelBar(Element) | Initializes a new instance of the RadPanelBar class.

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar Constructor
RadPanelBar Class See Also Send Feedback
Initializes a new instance of the RadPanelBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBar()
Visual Basic
Public Sub New
Visual C++
public:
RadPanelBar()

See Also

RadPanelBar Class
RadPanelBar Overload
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar Constructor (Element)
RadPanelBar Class See Also Send Feedback
Initializes a new instance of the RadPanelBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBar(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPanelBar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPanelBar Class
RadPanelBar Overload
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar Methods
RadPanelBar Class See Also Send Feedback

The RadPanelBar type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the PanelBar control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disable the panelbar.
Public method | DisableEvents | Disables the panel bar's client-side event emitting.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enable the panelbar.
Public method | EnableEvents | Enables the panel bar's client-side event emitting. Events are enabled by default.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds item by Text.
Public method | FindItemByValue | Finds item by Value.
Public method | FindItems | Find items by given predicate.
Public method | FindItemsByLevel | Find the panelbar items by given level.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeItems | Initializes all RadPanelBar items.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..AssignElement Method
RadPanelBar Class See Also Send Feedback
Assign the DOM element to be the PanelBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..CallMethod Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..Capture Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..Click Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..ControlAssert Method
RadPanelBar Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..Disable Method
RadPanelBar Class See Also Send Feedback
Disable the panelbar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


DisableEvents Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..DisableEvents Method
RadPanelBar Class See Also Send Feedback
Disables the panel bar's client-side event emitting.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DisableEvents()
Visual Basic
Public Sub DisableEvents
Visual C++
public:
void DisableEvents()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..DragTo Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..Enable Method
RadPanelBar Class See Also Send Feedback
Enable the panelbar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


EnableEvents Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..EnableEvents Method
RadPanelBar Class See Also Send Feedback
Enables the panel bar's client-side event emitting. Events are enabled by default.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void EnableEvents()
Visual Basic
Public Sub EnableEvents
Visual C++
public:
void EnableEvents()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..FindItem Method
RadPanelBar Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBarItem FindItem(
    Predicate<RadPanelBarItem> predicate
)
Visual Basic
Public Function FindItem ( _
    predicate As Predicate(Of RadPanelBarItem) _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItem(
    Predicate<RadPanelBarItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadPanelBarItem >)>)>
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..FindItemByText Method
RadPanelBar Class See Also Send Feedback
Finds item by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBarItem FindItemByText(
    string itemText
)
Visual Basic
Public Function FindItemByText ( _
    itemText As String _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::..String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.FindItemByText(System.String)"]

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..FindItemByValue Method
RadPanelBar Class See Also Send Feedback
Finds item by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBarItem FindItemByValue(
    string itemValue
)
Visual Basic
Public Function FindItemByValue ( _
    itemValue As String _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::..String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBar.FindItemByValue(System.String)"]

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..FindItems Method
RadPanelBar Class See Also Send Feedback
Find items by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadPanelBarItem> FindItems(
    Predicate<RadPanelBarItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of RadPanelBarItem) _
) As IList(Of RadPanelBarItem)
Visual C++
public:
IList<RadPanelBarItem^>^ FindItems(
    Predicate<RadPanelBarItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadPanelBarItem >)>)>
The predicate used for search criteria.

Return Value

The list of the root items.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemsByLevel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..FindItemsByLevel Method
RadPanelBar Class See Also Send Feedback
Find the panelbar items by given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadPanelBarItem> FindItemsByLevel(
    int level
)
Visual Basic
Public Function FindItemsByLevel ( _
    level As Integer _
) As IList(Of RadPanelBarItem)
Visual C++
public:
IList<RadPanelBarItem^>^ FindItemsByLevel(
    int level
)

Parameters

level
Type: System..::..Int32
The level to search for.

Return Value

The list of the panelbar items matching the given level.

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..GetValue Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


InitializeItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..InitializeItems Method
RadPanelBar Class See Also Send Feedback
Initializes all RadPanelBar items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void InitializeItems()
Visual Basic
Public Sub InitializeItems
Visual C++
public:
void InitializeItems()

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..InvokeEvent Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..MouseClick Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..MouseHover Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..ScrollToVisible Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar..::..SetValue Method
RadPanelBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPanelBar Class
RadPanelBar Members
Telerik.WebAii.Controls.Html Namespace


RadPanelBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBar Properties
RadPanelBar Class See Also Send Feedback

The RadPanelBar type exposes the following members.

Properties

 | Name | Description
Public property | AllItems | Get the list of all PanelBar items.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of this PanelBar control.
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the panelbar is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FullExpandedItem | Get whether the panelbar FullExpandedItem property is true.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootItems | Get root items of the PanelBar.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SingleExpandedItem | Get whether the panelbar SingleExpandedItem property is true.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBar Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem Members
RadPanelBarItem Class Constructors Methods Properties See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadPanelBarItem()()()() | Initializes a new instance of the RadPanelBarItem class.
Public method | RadPanelBarItem(Element) | Initializes a new instance of the RadPanelBarItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadPanelBarItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the item.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)
Public method | ClickHandler | Clicks the expand handler.
Public method | Collapse | Collapse a item if it is not already expanded. The click of the root item also selects it.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the item. The click of the root item also selects it.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds sub item by given text.
Public method | FindItemByValue | Finds sub item by given value.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Moves focus to the item. (Overrides HtmlControl..::..Focus()()()().)
Public method | FocusFirstChild | Moves focus to the first child of the item.
Public method | FocusLastChild | Moves focus to the last child of the item.
Public method | FocusNextItem | Moves focus to the next item.
Public method | FocusPreviousItem | Moves focus to the previous item.
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Makes the item invisible.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Navigate | Navigate if NavigateUrl is set.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects the item.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Makes the item visible.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Unselect | De-selects the item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether this item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expandable | Get whether this item is expandable.
Public property | Expanded | Get whether this item is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether this item is focused.
Public property | HasChildren | Check whether the item has children.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the item.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Get the list of child items of the panelbar item.
Public property | ItemValue | Get or set the value for this item.
Public property | Level | Get the level of the item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a panelbar item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Get or set the navigate url of this item.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Scrollable | Get whether the item is scrollable.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether this item is selected.
Public property | ShouldNavigate | Check whether the item should navigate.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the text of this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether this item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem Constructor
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadPanelBarItem()()()() | Initializes a new instance of the RadPanelBarItem class.
Public method | RadPanelBarItem(Element) | Initializes a new instance of the RadPanelBarItem class.

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem Constructor
RadPanelBarItem Class See Also Send Feedback
Initializes a new instance of the RadPanelBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBarItem()
Visual Basic
Public Sub New
Visual C++
public:
RadPanelBarItem()

See Also

RadPanelBarItem Class
RadPanelBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem Constructor (Element)
RadPanelBarItem Class See Also Send Feedback
Initializes a new instance of the RadPanelBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBarItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPanelBarItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPanelBarItem Class
RadPanelBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem Methods
RadPanelBarItem Class See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadPanelBarItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the item.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)
Public method | ClickHandler | Clicks the expand handler.
Public method | Collapse | Collapse a item if it is not already expanded. The click of the root item also selects it.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands the item. The click of the root item also selects it.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds sub item by given text.
Public method | FindItemByValue | Finds sub item by given value.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Moves focus to the item. (Overrides HtmlControl..::..Focus()()()().)
Public method | FocusFirstChild | Moves focus to the first child of the item.
Public method | FocusLastChild | Moves focus to the last child of the item.
Public method | FocusNextItem | Moves focus to the next item.
Public method | FocusPreviousItem | Moves focus to the previous item.
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Makes the item invisible.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Navigate | Navigate if NavigateUrl is set.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects the item.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Makes the item visible.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Unselect | De-selects the item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..AssignElement Method
RadPanelBarItem Class See Also Send Feedback
Assign the DOM element to be the RadPanelBarItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Blur Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Blur Method
RadPanelBarItem Class See Also Send Feedback
Removes focus from the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Blur()
Visual Basic
Public Sub Blur
Visual C++
public:
void Blur()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..CallMethod Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Capture Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Click Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Click Method
RadPanelBarItem Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadPanelBarItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Click Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Click Method (Boolean)
RadPanelBarItem Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click(
    bool isClosing
)
Visual Basic
Public Overrides Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
) override

Parameters

isClosing
Type: System..::..Boolean

[Missing <param name="isClosing"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.Click(System.Boolean)"]

See Also

RadPanelBarItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


ClickHandler Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..ClickHandler Method
RadPanelBarItem Class See Also Send Feedback
Clicks the expand handler.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClickHandler()
Visual Basic
Public Sub ClickHandler
Visual C++
public:
void ClickHandler()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Collapse Method
RadPanelBarItem Class See Also Send Feedback
Collapse a item if it is not already expanded. The click of the root item also selects it.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..ControlAssert Method
RadPanelBarItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..DragTo Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Expand Method
RadPanelBarItem Class See Also Send Feedback
Expands the item. The click of the root item also selects it.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..FindItem Method
RadPanelBarItem Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBarItem FindItem(
    Predicate<RadPanelBarItem> predicate
)
Visual Basic
Public Function FindItem ( _
    predicate As Predicate(Of RadPanelBarItem) _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItem(
    Predicate<RadPanelBarItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadPanelBarItem >)>)>
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..FindItemByText Method
RadPanelBarItem Class See Also Send Feedback
Finds sub item by given text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBarItem FindItemByText(
    string text
)
Visual Basic
Public Function FindItemByText ( _
    text As String _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItemByText(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.FindItemByText(System.String)"]

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..FindItemByValue Method
RadPanelBarItem Class See Also Send Feedback
Finds sub item by given value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPanelBarItem FindItemByValue(
    string itemValue
)
Visual Basic
Public Function FindItemByValue ( _
    itemValue As String _
) As RadPanelBarItem
Visual C++
public:
RadPanelBarItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::..String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadPanelBarItem.FindItemByValue(System.String)"]

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Focus Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Focus()
Visual Basic
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FocusFirstChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..FocusFirstChild Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the first child of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FocusFirstChild()
Visual Basic
Public Sub FocusFirstChild
Visual C++
public:
void FocusFirstChild()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FocusLastChild Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..FocusLastChild Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the last child of the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FocusLastChild()
Visual Basic
Public Sub FocusLastChild
Visual C++
public:
void FocusLastChild()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FocusNextItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..FocusNextItem Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the next item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FocusNextItem()
Visual Basic
Public Sub FocusNextItem
Visual C++
public:
void FocusNextItem()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


FocusPreviousItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..FocusPreviousItem Method
RadPanelBarItem Class See Also Send Feedback
Moves focus to the previous item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FocusPreviousItem()
Visual Basic
Public Sub FocusPreviousItem
Visual C++
public:
void FocusPreviousItem()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..GetValue Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Hide Method
RadPanelBarItem Class See Also Send Feedback
Makes the item invisible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..InvokeEvent Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..MouseClick Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..MouseHover Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Navigate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Navigate Method
RadPanelBarItem Class See Also Send Feedback
Navigate if NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Navigate()
Visual Basic
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..ScrollToVisible Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Select Method
RadPanelBarItem Class See Also Send Feedback
Selects the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..SetValue Method
RadPanelBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
RadPanelBarItem Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Show Method
RadPanelBarItem Class See Also Send Feedback
Makes the item visible.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


Unselect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem..::..Unselect Method
RadPanelBarItem Class See Also Send Feedback
De-selects the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Unselect()
Visual Basic
Public Sub Unselect
Visual C++
public:
void Unselect()

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadPanelBarItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPanelBarItem Properties
RadPanelBarItem Class See Also Send Feedback

The RadPanelBarItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether this item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expandable | Get whether this item is expandable.
Public property | Expanded | Get whether this item is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether this item is focused.
Public property | HasChildren | Check whether the item has children.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the item.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | Get the list of child items of the panelbar item.
Public property | ItemValue | Get or set the value for this item.
Public property | Level | Get the level of the item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a panelbar item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Get or set the navigate url of this item.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Scrollable | Get whether the item is scrollable.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether this item is selected.
Public property | ShouldNavigate | Check whether the item should navigate.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get or set the text of this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether this item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPanelBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadPicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker Members
RadPicker Class Constructors Methods Properties See Also Send Feedback

The RadPicker type exposes the following members.

Constructors

 | Name | Description
Public method | RadPicker()()()() | Initializes a new instance of the RadPicker class.
Public method | RadPicker(Element) | Initializes a new instance of the RadPicker class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar.
Public method | OpenTimeView | Clicks on the button which opens the TimeView.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using.
Public property | DateInput | Gets the Input part of the picker.
Public property | DatePopUpButton | The date popup button of the picker.
Protected property | DateTimePattern | The DateTime pattern.
Public property | Enabled | Gets or sets whenther the picker is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar.
Public property | IsEmpty | Check whether the picker is empty.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker.
Public property | MinDate | Gets the MinDate of the picker.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker.
Public property | PickerType | Gets the Picker control type.
Public property | PopupDirection | Gets the direction in which the popup opens.
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


RadPicker Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker Constructor
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadPicker()()()() | Initializes a new instance of the RadPicker class.
Public method | RadPicker(Element) | Initializes a new instance of the RadPicker class.

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


RadPicker Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker Constructor
RadPicker Class See Also Send Feedback
Initializes a new instance of the RadPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPicker()
Visual Basic
Public Sub New
Visual C++
public:
RadPicker()

See Also

RadPicker Class
RadPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadPicker Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker Constructor (Element)
RadPicker Class See Also Send Feedback
Initializes a new instance of the RadPicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPicker(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPicker Class
RadPicker Overload
Telerik.WebAii.Controls.Html Namespace


RadPicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker Methods
RadPicker Class See Also Send Feedback

The RadPicker type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar.
Public method | OpenTimeView | Clicks on the button which opens the TimeView.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..AssignElement Method
RadPicker Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..CallMethod Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..Capture Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..Click Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..DragTo Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..GetValue Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..InvokeEvent Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..MouseClick Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..MouseHover Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


OpenCalendar Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..OpenCalendar Method
RadPicker Class See Also Send Feedback
Clicks on the button which opens the calendar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenCalendar()
Visual Basic
Public Sub OpenCalendar
Visual C++
public:
void OpenCalendar()

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


OpenTimeView Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..OpenTimeView Method
RadPicker Class See Also Send Feedback
Clicks on the button which opens the TimeView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenTimeView()
Visual Basic
Public Sub OpenTimeView
Visual C++
public:
void OpenTimeView()

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..ScrollToVisible Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


SetSelectedDate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..SetSelectedDate Method
RadPicker Class See Also Send Feedback
Sets date to the picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SetSelectedDate(
    DateTime selectedDate
)
Visual Basic
Public Sub SetSelectedDate ( _
    selectedDate As DateTime _
)
Visual C++
public:
void SetSelectedDate(
    DateTime selectedDate
)

Parameters

selectedDate
Type: System..::..DateTime
The Date to be set.

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker..::..SetValue Method
RadPicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPicker Class
RadPicker Members
Telerik.WebAii.Controls.Html Namespace


RadPicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPicker Properties
RadPicker Class See Also Send Feedback

The RadPicker type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using.
Public property | DateInput | Gets the Input part of the picker.
Public property | DatePopUpButton | The date popup button of the picker.
Protected property | DateTimePattern | The DateTime pattern.
Public property | Enabled | Gets or sets whenther the picker is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar.
Public property | IsEmpty | Check whether the picker is empty.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker.
Public property | MinDate | Gets the MinDate of the picker.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker.
Public property | PickerType | Gets the Picker control type.
Public property | PopupDirection | Gets the direction in which the popup opens.
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPicker Class
Telerik.WebAii.Controls.Html Namespace


RadPivotGrid Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid Members
RadPivotGrid Class Constructors Methods Properties See Also Send Feedback

The RadPivotGrid type exposes the following members.

Constructors

 | Name | Description
Public method | RadPivotGrid()()()() | Initializes a new instance of the PivotGrid class.
Public method | RadPivotGrid(Element) | Initializes a new instance of the PivotGrid class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AggregateFieldsCount | Gets the Aggregate fields count.
Public property | AllowFieldsReordering | Gets whether fields reordering is enabled.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the PivotGrid control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColumnFieldsCount | Gets the Column fields count.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EnableZoneContextMenu | Gets whether the zone context menu is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FieldsCount | Gets the total field count.
Public property | FilterFieldsCount | Gets the Filter fields count.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HiddenFieldsCount | Gets the count of the hidden fields.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsVerticalScrollingEnabled | Gets whether the vertical scrolling of the PivotGrid is enabled.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam of the PivotGrid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pager | Gets the PviotGrid pager control.
Public property | RowFieldsCount | Gets the Row fields count.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
Telerik.WebAii.Controls.Html Namespace


RadPivotGrid Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid Constructor
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadPivotGrid()()()() | Initializes a new instance of the PivotGrid class.
Public method | RadPivotGrid(Element) | Initializes a new instance of the PivotGrid class.

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


RadPivotGrid Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid Constructor
RadPivotGrid Class See Also Send Feedback
Initializes a new instance of the PivotGrid class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPivotGrid()
Visual Basic
Public Sub New
Visual C++
public:
RadPivotGrid()

See Also

RadPivotGrid Class
RadPivotGrid Overload
Telerik.WebAii.Controls.Html Namespace


RadPivotGrid Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid Constructor (Element)
RadPivotGrid Class See Also Send Feedback
Initializes a new instance of the PivotGrid class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadPivotGrid(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadPivotGrid(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadPivotGrid.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadPivotGrid Class
RadPivotGrid Overload
Telerik.WebAii.Controls.Html Namespace


RadPivotGrid Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid Methods
RadPivotGrid Class See Also Send Feedback

The RadPivotGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assigns element and initializes this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadPivotGrid Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..AssignElement Method
RadPivotGrid Class See Also Send Feedback
Assigns element and initializes this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadPivotGrid Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..CallMethod Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..Capture Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..Click Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..ControlAssert Method
RadPivotGrid Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadPivotGrid Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..DragTo Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..GetValue Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..InvokeEvent Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..MouseClick Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..MouseHover Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..ScrollToVisible Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid..::..SetValue Method
RadPivotGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
RadPivotGrid Members
Telerik.WebAii.Controls.Html Namespace


RadPivotGrid Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadPivotGrid Properties
RadPivotGrid Class See Also Send Feedback

The RadPivotGrid type exposes the following members.

Properties

 | Name | Description
Public property | AggregateFieldsCount | Gets the Aggregate fields count.
Public property | AllowFieldsReordering | Gets whether fields reordering is enabled.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the PivotGrid control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColumnFieldsCount | Gets the Column fields count.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EnableZoneContextMenu | Gets whether the zone context menu is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FieldsCount | Gets the total field count.
Public property | FilterFieldsCount | Gets the Filter fields count.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HiddenFieldsCount | Gets the count of the hidden fields.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsVerticalScrollingEnabled | Gets whether the vertical scrolling of the PivotGrid is enabled.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam of the PivotGrid. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pager | Gets the PviotGrid pager control.
Public property | RowFieldsCount | Gets the Row fields count.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadPivotGrid Class
Telerik.WebAii.Controls.Html Namespace


RadRating Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating Members
RadRating Class Constructors Methods Properties See Also Send Feedback

The RadRating type exposes the following members.

Constructors

 | Name | Description
Public method | RadRating()()()() | Initializes a new instance of the RadRating class.
Public method | RadRating(Element) | Initializes a new instance of the RadRating class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | RatingSelectItemByNumber | Selects RadRating value.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EnableToolTips | Gets/Sets whether the RadRating will show toolTip or not.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsDirectionReversed | Gets/Sets whether the RadRating's direction is reversed or not.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsHorizontal | Gets/Sets the RadRating's orientation.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Gets number of RadRating's items(stars).
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadRating. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Precision | Gets/Sets precision of the RadRating.
Public property | ReadOnly | Gets/Sets whether the RadRating is ReadOnly or not.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedValue | Gets/Sets RadRating's value.
Public property | SelectionMode | Gets/Sets RadRating's SelectionMode.
Public property | Skin | Gets the skin of the RadRating.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRating Class
Telerik.WebAii.Controls.Html Namespace


RadRating Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating Constructor
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRating()()()() | Initializes a new instance of the RadRating class.
Public method | RadRating(Element) | Initializes a new instance of the RadRating class.

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


RadRating Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating Constructor
RadRating Class See Also Send Feedback
Initializes a new instance of the RadRating class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRating()
Visual Basic
Public Sub New
Visual C++
public:
RadRating()

See Also

RadRating Class
RadRating Overload
Telerik.WebAii.Controls.Html Namespace


RadRating Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating Constructor (Element)
RadRating Class See Also Send Feedback
Initializes a new instance of the RadRating class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRating(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRating(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRating.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRating Class
RadRating Overload
Telerik.WebAii.Controls.Html Namespace


RadRating Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating Methods
RadRating Class See Also Send Feedback

The RadRating type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | RatingSelectItemByNumber | Selects RadRating value.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRating Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..AssignElement Method
RadRating Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadRating Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..CallMethod Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..Capture Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..Click Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..ControlAssert Method
RadRating Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRating Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..DragTo Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..GetValue Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..InvokeEvent Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..MouseClick Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..MouseHover Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


RatingSelectItemByNumber Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..RatingSelectItemByNumber Method
RadRating Class See Also Send Feedback
Selects RadRating value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void RatingSelectItemByNumber(
    int index
)
Visual Basic
Public Sub RatingSelectItemByNumber ( _
    index As Integer _
)
Visual C++
public:
void RatingSelectItemByNumber(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRating.RatingSelectItemByNumber(System.Int32)"]

See Also

RadRating Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..ScrollToVisible Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating..::..SetValue Method
RadRating Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRating Class
RadRating Members
Telerik.WebAii.Controls.Html Namespace


RadRating Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRating Properties
RadRating Class See Also Send Feedback

The RadRating type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EnableToolTips | Gets/Sets whether the RadRating will show toolTip or not.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsDirectionReversed | Gets/Sets whether the RadRating's direction is reversed or not.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsHorizontal | Gets/Sets the RadRating's orientation.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Gets number of RadRating's items(stars).
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadRating. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Precision | Gets/Sets precision of the RadRating.
Public property | ReadOnly | Gets/Sets whether the RadRating is ReadOnly or not.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedValue | Gets/Sets RadRating's value.
Public property | SelectionMode | Gets/Sets RadRating's SelectionMode.
Public property | Skin | Gets the skin of the RadRating.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRating Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar Members
RadRibbonBar Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBar type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBar()()()() | Initializes a new instance of the RadRibbonBar class.
Public method | RadRibbonBar(Element) | Initializes a new instance of the RadRibbonBar class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBar control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | QATButtonClick | Clicks the "Customize Quick Access ToolBar button".
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | ActiveContextualTabGroups | Get active Contextual tab groups.
Public property | AllContextualTabGroups | Get all Contextual tab groups.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ContextualTabsEnabled | Get whether the Contextual tabs are enabled.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | QATButtonCount | Get the number of Quick Access TollBar buttons.
Public property | QATEnabled | Get whether the Quick Access ToolBar is enabled.
Public property | QATMenuOpened | Customize Quick Access ToolBar menu visible.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabsCount | Get the number of tabs.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBar Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar Constructor
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBar()()()() | Initializes a new instance of the RadRibbonBar class.
Public method | RadRibbonBar(Element) | Initializes a new instance of the RadRibbonBar class.

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar Constructor
RadRibbonBar Class See Also Send Feedback
Initializes a new instance of the RadRibbonBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBar()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBar()

See Also

RadRibbonBar Class
RadRibbonBar Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBar Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar Constructor (Element)
RadRibbonBar Class See Also Send Feedback
Initializes a new instance of the RadRibbonBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBar(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBar Class
RadRibbonBar Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar Methods
RadRibbonBar Class See Also Send Feedback

The RadRibbonBar type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBar control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | QATButtonClick | Clicks the "Customize Quick Access ToolBar button".
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..AssignElement Method
RadRibbonBar Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBar.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..CallMethod Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..Capture Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..Click Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..ControlAssert Method
RadRibbonBar Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..DragTo Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..GetValue Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..InvokeEvent Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..MouseClick Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..MouseHover Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


QATButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..QATButtonClick Method
RadRibbonBar Class See Also Send Feedback
Clicks the "Customize Quick Access ToolBar button".

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void QATButtonClick()
Visual Basic
Public Sub QATButtonClick
Visual C++
public:
void QATButtonClick()

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..ScrollToVisible Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar..::..SetValue Method
RadRibbonBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
RadRibbonBar Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBar Properties
RadRibbonBar Class See Also Send Feedback

The RadRibbonBar type exposes the following members.

Properties

 | Name | Description
Public property | ActiveContextualTabGroups | Get active Contextual tab groups.
Public property | AllContextualTabGroups | Get all Contextual tab groups.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ContextualTabsEnabled | Get whether the Contextual tabs are enabled.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | QATButtonCount | Get the number of Quick Access TollBar buttons.
Public property | QATEnabled | Get whether the Quick Access ToolBar is enabled.
Public property | QATMenuOpened | Customize Quick Access ToolBar menu visible.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabsCount | Get the number of tabs.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBar Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarApplicationTab Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab Members
RadRibbonBarApplicationTab Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarApplicationTab type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarApplicationTab()()()() | Initializes a new instance of the RadRibbonBarApplicationTab class.
Public method | RadRibbonBarApplicationTab(Element) | Initializes a new instance of the RadRibbonBarApplicationTab class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarApplicationTab control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the application tab. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Opened | Get whether the ApplicationTab is opened.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the application tab.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarApplicationTab Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab Constructor
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarApplicationTab()()()() | Initializes a new instance of the RadRibbonBarApplicationTab class.
Public method | RadRibbonBarApplicationTab(Element) | Initializes a new instance of the RadRibbonBarApplicationTab class.

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarApplicationTab Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab Constructor
RadRibbonBarApplicationTab Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarApplicationTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarApplicationTab()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarApplicationTab()

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarApplicationTab Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab Constructor (Element)
RadRibbonBarApplicationTab Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarApplicationTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarApplicationTab(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarApplicationTab(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarApplicationTab.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarApplicationTab Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab Methods
RadRibbonBarApplicationTab Class See Also Send Feedback

The RadRibbonBarApplicationTab type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarApplicationTab control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the application tab. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarApplicationTab Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..AssignElement Method
RadRibbonBarApplicationTab Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBarApplicationTab control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarApplicationTab.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarApplicationTab Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..CallMethod Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..Capture Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..Click Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the application tab. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..Click Method
RadRibbonBarApplicationTab Class See Also Send Feedback
Click the application tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadRibbonBarApplicationTab Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..ControlAssert Method
RadRibbonBarApplicationTab Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRibbonBarApplicationTab Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..DragTo Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..GetValue Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..InvokeEvent Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..MouseClick Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..MouseHover Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..ScrollToVisible Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab..::..SetValue Method
RadRibbonBarApplicationTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
RadRibbonBarApplicationTab Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarApplicationTab Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarApplicationTab Properties
RadRibbonBarApplicationTab Class See Also Send Feedback

The RadRibbonBarApplicationTab type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Opened | Get whether the ApplicationTab is opened.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the application tab.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarApplicationTab Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton Members
RadRibbonBarButton Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarButton()()()() | Initializes a new instance of the RadRibbonBarButton class.
Public method | RadRibbonBarButton(Element) | Initializes a new instance of the RadRibbonBarButton class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarButton control. (Overrides RadRibbonBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar item. (Inherited from RadRibbonBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadRibbonBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Inherited from RadRibbonBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url. (Inherited from RadRibbonBarItem.)
Public property | DisabledImageUrlLarge | Get the disabled image url large. (Inherited from RadRibbonBarItem.)
Public property | Enabled | Get whether the item is enabled. (Inherited from RadRibbonBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url. (Inherited from RadRibbonBarItem.)
Public property | ImageUrlLarge | Get the image url large. (Inherited from RadRibbonBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Get the index of the item. (Inherited from RadRibbonBarItem.)
Public property | ItemType | Type of the RibbonBar item. (Inherited from RadRibbonBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Inherited from RadRibbonBarItem.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item. (Inherited from RadRibbonBarItem.)
Public property | ParentGroup | Get the parent ribbonBar group. (Inherited from RadRibbonBarItem.)
Public property | ParentTab | Get the parent ribbonBar tab. (Inherited from RadRibbonBarItem.)
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled. (Inherited from RadRibbonBarItem.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item. (Inherited from RadRibbonBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get the value of the item. (Inherited from RadRibbonBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton Constructor
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarButton()()()() | Initializes a new instance of the RadRibbonBarButton class.
Public method | RadRibbonBarButton(Element) | Initializes a new instance of the RadRibbonBarButton class.

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton Constructor
RadRibbonBarButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarButton()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarButton()

See Also

RadRibbonBarButton Class
RadRibbonBarButton Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton Constructor (Element)
RadRibbonBarButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarButton Class
RadRibbonBarButton Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton Methods
RadRibbonBarButton Class See Also Send Feedback

The RadRibbonBarButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarButton control. (Overrides RadRibbonBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar item. (Inherited from RadRibbonBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadRibbonBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..AssignElement Method
RadRibbonBarButton Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBarButton control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..CallMethod Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..Capture Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..Click Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Clicks the ribbonbar item. (Inherited from RadRibbonBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..DragTo Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..GetValue Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..InvokeEvent Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..MouseClick Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..MouseHover Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..ScrollToVisible Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton..::..SetValue Method
RadRibbonBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
RadRibbonBarButton Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarButton Properties
RadRibbonBarButton Class See Also Send Feedback

The RadRibbonBarButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Inherited from RadRibbonBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url. (Inherited from RadRibbonBarItem.)
Public property | DisabledImageUrlLarge | Get the disabled image url large. (Inherited from RadRibbonBarItem.)
Public property | Enabled | Get whether the item is enabled. (Inherited from RadRibbonBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url. (Inherited from RadRibbonBarItem.)
Public property | ImageUrlLarge | Get the image url large. (Inherited from RadRibbonBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Get the index of the item. (Inherited from RadRibbonBarItem.)
Public property | ItemType | Type of the RibbonBar item. (Inherited from RadRibbonBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Inherited from RadRibbonBarItem.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item. (Inherited from RadRibbonBarItem.)
Public property | ParentGroup | Get the parent ribbonBar group. (Inherited from RadRibbonBarItem.)
Public property | ParentTab | Get the parent ribbonBar tab. (Inherited from RadRibbonBarItem.)
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled. (Inherited from RadRibbonBarItem.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item. (Inherited from RadRibbonBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get the value of the item. (Inherited from RadRibbonBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarButton Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarContextualTabGroup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup Members
RadRibbonBarContextualTabGroup Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarContextualTabGroup type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarContextualTabGroup()()()() | Initializes a new instance of the RadRibbonBarContextualTabGroup class.
Public method | RadRibbonBarContextualTabGroup(Element) | Initializes a new instance of the RadRibbonBarTab class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarTab control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the contextual tab group.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActive | Check whether the contextual tab group is active.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabCount | Get the number of associated tabs with this context group.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the tab group.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarContextualTabGroup Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup Constructor
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarContextualTabGroup()()()() | Initializes a new instance of the RadRibbonBarContextualTabGroup class.
Public method | RadRibbonBarContextualTabGroup(Element) | Initializes a new instance of the RadRibbonBarTab class.

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarContextualTabGroup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup Constructor
RadRibbonBarContextualTabGroup Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarContextualTabGroup class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarContextualTabGroup()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarContextualTabGroup()

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarContextualTabGroup Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup Constructor (Element)
RadRibbonBarContextualTabGroup Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarContextualTabGroup(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarContextualTabGroup(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarContextualTabGroup.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarContextualTabGroup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup Methods
RadRibbonBarContextualTabGroup Class See Also Send Feedback

The RadRibbonBarContextualTabGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarTab control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarContextualTabGroup Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..AssignElement Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBarTab control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarContextualTabGroup.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarContextualTabGroup Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..CallMethod Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..Capture Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..Click Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..ControlAssert Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRibbonBarContextualTabGroup Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..DragTo Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..GetValue Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..InvokeEvent Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..MouseClick Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..MouseHover Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..ScrollToVisible Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup..::..SetValue Method
RadRibbonBarContextualTabGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
RadRibbonBarContextualTabGroup Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarContextualTabGroup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarContextualTabGroup Properties
RadRibbonBarContextualTabGroup Class See Also Send Feedback

The RadRibbonBarContextualTabGroup type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the contextual tab group.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActive | Check whether the contextual tab group is active.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabCount | Get the number of associated tabs with this context group.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the tab group.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarContextualTabGroup Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarGroup Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup Members
RadRibbonBarGroup Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarGroup type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarGroup()()()() | Initializes a new instance of the RadRibbonBarGroup class.
Public method | RadRibbonBarGroup(Element) | Initializes a new instance of the RadRibbonBarGroup class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarGroup control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the group is enabled.
Public property | EnabledLauncher | Get whether the launcher is enabled for the group.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupIndex | Get the index of the group.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Get the number of the items in the group.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentTab | Get the parent ribbonBar tab.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the tab.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarGroup Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup Constructor
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarGroup()()()() | Initializes a new instance of the RadRibbonBarGroup class.
Public method | RadRibbonBarGroup(Element) | Initializes a new instance of the RadRibbonBarGroup class.

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarGroup Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup Constructor
RadRibbonBarGroup Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarGroup class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarGroup()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarGroup()

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarGroup Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup Constructor (Element)
RadRibbonBarGroup Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarGroup class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarGroup(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarGroup(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarGroup.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarGroup Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup Methods
RadRibbonBarGroup Class See Also Send Feedback

The RadRibbonBarGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarGroup control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarGroup Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..AssignElement Method
RadRibbonBarGroup Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBarGroup control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarGroup.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarGroup Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..CallMethod Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..Capture Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..Click Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..ControlAssert Method
RadRibbonBarGroup Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRibbonBarGroup Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..DragTo Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..GetValue Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..InvokeEvent Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..MouseClick Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..MouseHover Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..ScrollToVisible Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup..::..SetValue Method
RadRibbonBarGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
RadRibbonBarGroup Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarGroup Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarGroup Properties
RadRibbonBarGroup Class See Also Send Feedback

The RadRibbonBarGroup type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the group is enabled.
Public property | EnabledLauncher | Get whether the launcher is enabled for the group.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupIndex | Get the index of the group.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Get the number of the items in the group.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentTab | Get the parent ribbonBar tab.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the tab.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarGroup Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem Members
RadRibbonBarItem Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarItem()()()() | Initializes a new instance of the RadRibbonBarItem class.
Public method | RadRibbonBarItem(Element) | Initializes a new instance of the RadRibbonBarItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RibbonBarItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar item.
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url.
Public property | DisabledImageUrlLarge | Get the disabled image url large.
Public property | Enabled | Get whether the item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url.
Public property | ImageUrlLarge | Get the image url large.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Get the index of the item.
Public property | ItemType | Type of the RibbonBar item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item.
Public property | ParentGroup | Get the parent ribbonBar group.
Public property | ParentTab | Get the parent ribbonBar tab.
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get the value of the item.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem Constructor
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarItem()()()() | Initializes a new instance of the RadRibbonBarItem class.
Public method | RadRibbonBarItem(Element) | Initializes a new instance of the RadRibbonBarItem class.

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem Constructor
RadRibbonBarItem Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarItem()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarItem()

See Also

RadRibbonBarItem Class
RadRibbonBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem Constructor (Element)
RadRibbonBarItem Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarItem Class
RadRibbonBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem Methods
RadRibbonBarItem Class See Also Send Feedback

The RadRibbonBarItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RibbonBarItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar item.
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..AssignElement Method
RadRibbonBarItem Class See Also Send Feedback
Assign the DOM element to be the RibbonBarItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..CallMethod Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..Capture Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..Click Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Clicks the ribbonbar item.
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..Click Method
RadRibbonBarItem Class See Also Send Feedback
Clicks the ribbonbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public virtual void Click()
Visual Basic
Public Overridable Sub Click
Visual C++
public:
virtual void Click()

See Also

RadRibbonBarItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..ControlAssert Method
RadRibbonBarItem Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRibbonBarItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..DragTo Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..GetValue Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..InvokeEvent Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..MouseClick Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..MouseHover Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..ScrollToVisible Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem..::..SetValue Method
RadRibbonBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
RadRibbonBarItem Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarItem Properties
RadRibbonBarItem Class See Also Send Feedback

The RadRibbonBarItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url.
Public property | DisabledImageUrlLarge | Get the disabled image url large.
Public property | Enabled | Get whether the item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url.
Public property | ImageUrlLarge | Get the image url large.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Get the index of the item.
Public property | ItemType | Type of the RibbonBar item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item.
Public property | ParentGroup | Get the parent ribbonBar group.
Public property | ParentTab | Get the parent ribbonBar tab.
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get the value of the item.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarMenu Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu Members
RadRibbonBarMenu Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarMenu type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarMenu()()()() | Initializes a new instance of the RadRibbonBarMenu class.
Public method | RadRibbonBarMenu(Element) | Initializes a new instance of the RadRibbonBarMenu class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarMenu control. (Overrides RadRibbonBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar menu. (Overrides RadRibbonBarItem..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadRibbonBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Inherited from RadRibbonBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url. (Inherited from RadRibbonBarItem.)
Public property | DisabledImageUrlLarge | Get the disabled image url large. (Inherited from RadRibbonBarItem.)
Public property | Enabled | Get whether the item is enabled. (Inherited from RadRibbonBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url. (Inherited from RadRibbonBarItem.)
Public property | ImageUrlLarge | Get the image url large. (Inherited from RadRibbonBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Get the number of items.
Public property | ItemIndex | Get the index of the item. (Inherited from RadRibbonBarItem.)
Public property | ItemType | Type of the RibbonBar item. (Inherited from RadRibbonBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides RadRibbonBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Opened | Get whether the menu is opened.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item. (Inherited from RadRibbonBarItem.)
Public property | ParentGroup | Get the parent ribbonBar group. (Inherited from RadRibbonBarItem.)
Public property | ParentTab | Get the parent ribbonBar tab. (Inherited from RadRibbonBarItem.)
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled. (Inherited from RadRibbonBarItem.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item. (Inherited from RadRibbonBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get the value of the item. (Inherited from RadRibbonBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarMenu Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu Constructor
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarMenu()()()() | Initializes a new instance of the RadRibbonBarMenu class.
Public method | RadRibbonBarMenu(Element) | Initializes a new instance of the RadRibbonBarMenu class.

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarMenu Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu Constructor
RadRibbonBarMenu Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarMenu class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarMenu()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarMenu()

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarMenu Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu Constructor (Element)
RadRibbonBarMenu Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarMenu class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarMenu(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarMenu(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarMenu.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarMenu Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu Methods
RadRibbonBarMenu Class See Also Send Feedback

The RadRibbonBarMenu type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarMenu control. (Overrides RadRibbonBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar menu. (Overrides RadRibbonBarItem..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadRibbonBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarMenu Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..AssignElement Method
RadRibbonBarMenu Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBarMenu control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarMenu.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarMenu Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..CallMethod Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..Capture Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..Click Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Clicks the ribbonbar menu. (Overrides RadRibbonBarItem..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..Click Method
RadRibbonBarMenu Class See Also Send Feedback
Clicks the ribbonbar menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadRibbonBarMenu Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..DragTo Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..GetValue Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..InvokeEvent Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..MouseClick Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..MouseHover Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..ScrollToVisible Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu..::..SetValue Method
RadRibbonBarMenu Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
RadRibbonBarMenu Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarMenu Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarMenu Properties
RadRibbonBarMenu Class See Also Send Feedback

The RadRibbonBarMenu type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Inherited from RadRibbonBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url. (Inherited from RadRibbonBarItem.)
Public property | DisabledImageUrlLarge | Get the disabled image url large. (Inherited from RadRibbonBarItem.)
Public property | Enabled | Get whether the item is enabled. (Inherited from RadRibbonBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url. (Inherited from RadRibbonBarItem.)
Public property | ImageUrlLarge | Get the image url large. (Inherited from RadRibbonBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Get the number of items.
Public property | ItemIndex | Get the index of the item. (Inherited from RadRibbonBarItem.)
Public property | ItemType | Type of the RibbonBar item. (Inherited from RadRibbonBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides RadRibbonBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Opened | Get whether the menu is opened.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item. (Inherited from RadRibbonBarItem.)
Public property | ParentGroup | Get the parent ribbonBar group. (Inherited from RadRibbonBarItem.)
Public property | ParentTab | Get the parent ribbonBar tab. (Inherited from RadRibbonBarItem.)
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled. (Inherited from RadRibbonBarItem.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item. (Inherited from RadRibbonBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get the value of the item. (Inherited from RadRibbonBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarMenu Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarQATMenuItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem Members
RadRibbonBarQATMenuItem Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarQATMenuItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarQATMenuItem()()()() | Initializes a new instance of the RadRibbonBarQATMenuItem class.
Public method | RadRibbonBarQATMenuItem(Element) | Initializes a new instance of the RadRibbonBarQATMenuItem class.

Methods

 | Name | Description
Public method | Activate | Activates quick access of ribbonbar item.
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarQATMenuItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | DeActivate | Deactivates quick access of ribbonbar item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Active | Get whether the RadRibbonBarQATMenuItem is active.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the RadRibbonBarQATMenuItem.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarQATMenuItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem Constructor
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarQATMenuItem()()()() | Initializes a new instance of the RadRibbonBarQATMenuItem class.
Public method | RadRibbonBarQATMenuItem(Element) | Initializes a new instance of the RadRibbonBarQATMenuItem class.

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarQATMenuItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem Constructor
RadRibbonBarQATMenuItem Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarQATMenuItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarQATMenuItem()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarQATMenuItem()

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarQATMenuItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem Constructor (Element)
RadRibbonBarQATMenuItem Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarQATMenuItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarQATMenuItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarQATMenuItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarQATMenuItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarQATMenuItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem Methods
RadRibbonBarQATMenuItem Class See Also Send Feedback

The RadRibbonBarQATMenuItem type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activates quick access of ribbonbar item.
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarQATMenuItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | DeActivate | Deactivates quick access of ribbonbar item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarQATMenuItem Class
Telerik.WebAii.Controls.Html Namespace


Activate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..Activate Method
RadRibbonBarQATMenuItem Class See Also Send Feedback
Activates quick access of ribbonbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Activate()
Visual Basic
Public Sub Activate
Visual C++
public:
void Activate()

See Also

RadRibbonBarQATMenuItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..AssignElement Method
RadRibbonBarQATMenuItem Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBarQATMenuItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarQATMenuItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarQATMenuItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..CallMethod Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..Capture Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..Click Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


DeActivate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..DeActivate Method
RadRibbonBarQATMenuItem Class See Also Send Feedback
Deactivates quick access of ribbonbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DeActivate()
Visual Basic
Public Sub DeActivate
Visual C++
public:
void DeActivate()

See Also

RadRibbonBarQATMenuItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..DragTo Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..GetValue Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..InvokeEvent Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..MouseClick Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..MouseHover Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..ScrollToVisible Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem..::..SetValue Method
RadRibbonBarQATMenuItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
RadRibbonBarQATMenuItem Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarQATMenuItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarQATMenuItem Properties
RadRibbonBarQATMenuItem Class See Also Send Feedback

The RadRibbonBarQATMenuItem type exposes the following members.

Properties

 | Name | Description
Public property | Active | Get whether the RadRibbonBarQATMenuItem is active.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the RadRibbonBarQATMenuItem.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarQATMenuItem Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarSplitButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton Members
RadRibbonBarSplitButton Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarSplitButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarSplitButton()()()() | Initializes a new instance of the RadRibbonBarSplitButton class.
Public method | RadRibbonBarSplitButton(Element) | Initializes a new instance of the RadRibbonBarSplitButton class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarSplitButton control. (Overrides RadRibbonBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar split button. (Overrides RadRibbonBarItem..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadRibbonBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Inherited from RadRibbonBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url. (Inherited from RadRibbonBarItem.)
Public property | DisabledImageUrlLarge | Get the disabled image url large. (Inherited from RadRibbonBarItem.)
Public property | EnableButtonSelection | Get whether the split EnableButtonSelection property is true.
Public property | Enabled | Get whether the item is enabled. (Inherited from RadRibbonBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url. (Inherited from RadRibbonBarItem.)
Public property | ImageUrlLarge | Get the image url large. (Inherited from RadRibbonBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Get the number of items.
Public property | ItemIndex | Get the index of the item. (Inherited from RadRibbonBarItem.)
Public property | ItemType | Type of the RibbonBar item. (Inherited from RadRibbonBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides RadRibbonBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Opened | Get whether the split button is opened.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item. (Inherited from RadRibbonBarItem.)
Public property | ParentGroup | Get the parent ribbonBar group. (Inherited from RadRibbonBarItem.)
Public property | ParentTab | Get the parent ribbonBar tab. (Inherited from RadRibbonBarItem.)
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled. (Inherited from RadRibbonBarItem.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedButtonIndex | Get whether the selected button index;
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item. (Inherited from RadRibbonBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get the value of the item. (Inherited from RadRibbonBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarSplitButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton Constructor
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarSplitButton()()()() | Initializes a new instance of the RadRibbonBarSplitButton class.
Public method | RadRibbonBarSplitButton(Element) | Initializes a new instance of the RadRibbonBarSplitButton class.

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarSplitButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton Constructor
RadRibbonBarSplitButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarSplitButton()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarSplitButton()

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarSplitButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton Constructor (Element)
RadRibbonBarSplitButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarSplitButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarSplitButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarSplitButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarSplitButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton Methods
RadRibbonBarSplitButton Class See Also Send Feedback

The RadRibbonBarSplitButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarSplitButton control. (Overrides RadRibbonBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar split button. (Overrides RadRibbonBarItem..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadRibbonBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..AssignElement Method
RadRibbonBarSplitButton Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBarSplitButton control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarSplitButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..CallMethod Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..Capture Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..Click Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Clicks the ribbonbar split button. (Overrides RadRibbonBarItem..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..Click Method
RadRibbonBarSplitButton Class See Also Send Feedback
Clicks the ribbonbar split button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadRibbonBarSplitButton Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..DragTo Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..GetValue Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..InvokeEvent Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..MouseClick Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..MouseHover Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..ScrollToVisible Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton..::..SetValue Method
RadRibbonBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
RadRibbonBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarSplitButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarSplitButton Properties
RadRibbonBarSplitButton Class See Also Send Feedback

The RadRibbonBarSplitButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Inherited from RadRibbonBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url. (Inherited from RadRibbonBarItem.)
Public property | DisabledImageUrlLarge | Get the disabled image url large. (Inherited from RadRibbonBarItem.)
Public property | EnableButtonSelection | Get whether the split EnableButtonSelection property is true.
Public property | Enabled | Get whether the item is enabled. (Inherited from RadRibbonBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url. (Inherited from RadRibbonBarItem.)
Public property | ImageUrlLarge | Get the image url large. (Inherited from RadRibbonBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemCount | Get the number of items.
Public property | ItemIndex | Get the index of the item. (Inherited from RadRibbonBarItem.)
Public property | ItemType | Type of the RibbonBar item. (Inherited from RadRibbonBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides RadRibbonBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Opened | Get whether the split button is opened.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item. (Inherited from RadRibbonBarItem.)
Public property | ParentGroup | Get the parent ribbonBar group. (Inherited from RadRibbonBarItem.)
Public property | ParentTab | Get the parent ribbonBar tab. (Inherited from RadRibbonBarItem.)
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled. (Inherited from RadRibbonBarItem.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedButtonIndex | Get whether the selected button index;
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item. (Inherited from RadRibbonBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get the value of the item. (Inherited from RadRibbonBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarTab Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab Members
RadRibbonBarTab Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarTab type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarTab()()()() | Initializes a new instance of the RadRibbonBarTab class.
Public method | RadRibbonBarTab(Element) | Initializes a new instance of the RadRibbonBarTab class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarTab control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the tab. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupCount | Get the number of groups.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsSelected | Check whether the tab is selected.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Get the index of the tab.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the tab.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarTab Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab Constructor
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarTab()()()() | Initializes a new instance of the RadRibbonBarTab class.
Public method | RadRibbonBarTab(Element) | Initializes a new instance of the RadRibbonBarTab class.

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarTab Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab Constructor
RadRibbonBarTab Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarTab()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarTab()

See Also

RadRibbonBarTab Class
RadRibbonBarTab Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarTab Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab Constructor (Element)
RadRibbonBarTab Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarTab(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarTab(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarTab.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarTab Class
RadRibbonBarTab Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarTab Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab Methods
RadRibbonBarTab Class See Also Send Feedback

The RadRibbonBarTab type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadRibbonBarTab control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the tab. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarTab Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..AssignElement Method
RadRibbonBarTab Class See Also Send Feedback
Assign the DOM element to be the RadRibbonBarTab control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarTab.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarTab Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..CallMethod Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..Capture Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..Click Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the tab. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..Click Method
RadRibbonBarTab Class See Also Send Feedback
Click the tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadRibbonBarTab Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..ControlAssert Method
RadRibbonBarTab Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRibbonBarTab Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..DragTo Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..GetValue Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..InvokeEvent Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..MouseClick Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..MouseHover Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..ScrollToVisible Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab..::..SetValue Method
RadRibbonBarTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
RadRibbonBarTab Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarTab Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarTab Properties
RadRibbonBarTab Class See Also Send Feedback

The RadRibbonBarTab type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | GroupCount | Get the number of groups.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsSelected | Check whether the tab is selected.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabIndex | Get the index of the tab.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the tab.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarTab Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarToggleButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton Members
RadRibbonBarToggleButton Class Constructors Methods Properties See Also Send Feedback

The RadRibbonBarToggleButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadRibbonBarToggleButton()()()() | Initializes a new instance of the RadRibbonBarToggleButton class.
Public method | RadRibbonBarToggleButton(Element) | Initializes a new instance of the RadRibbonBarToggleButton class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RibbonBarToggleButton control. (Overrides RadRibbonBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar item. (Inherited from RadRibbonBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadRibbonBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Toggle | Toggles the ribbonbar button.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Inherited from RadRibbonBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url. (Inherited from RadRibbonBarItem.)
Public property | DisabledImageUrlLarge | Get the disabled image url large. (Inherited from RadRibbonBarItem.)
Public property | Enabled | Get whether the item is enabled. (Inherited from RadRibbonBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url. (Inherited from RadRibbonBarItem.)
Public property | ImageUrlLarge | Get the image url large. (Inherited from RadRibbonBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Get the index of the item. (Inherited from RadRibbonBarItem.)
Public property | ItemType | Type of the RibbonBar item. (Inherited from RadRibbonBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides RadRibbonBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item. (Inherited from RadRibbonBarItem.)
Public property | ParentGroup | Get the parent ribbonBar group. (Inherited from RadRibbonBarItem.)
Public property | ParentTab | Get the parent ribbonBar tab. (Inherited from RadRibbonBarItem.)
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled. (Inherited from RadRibbonBarItem.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item. (Inherited from RadRibbonBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Toggled | Get whether the button is toggled.
Public property | Value | Get the value of the item. (Inherited from RadRibbonBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarToggleButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton Constructor
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRibbonBarToggleButton()()()() | Initializes a new instance of the RadRibbonBarToggleButton class.
Public method | RadRibbonBarToggleButton(Element) | Initializes a new instance of the RadRibbonBarToggleButton class.

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarToggleButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton Constructor
RadRibbonBarToggleButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarToggleButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarToggleButton()
Visual Basic
Public Sub New
Visual C++
public:
RadRibbonBarToggleButton()

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarToggleButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton Constructor (Element)
RadRibbonBarToggleButton Class See Also Send Feedback
Initializes a new instance of the RadRibbonBarToggleButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRibbonBarToggleButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRibbonBarToggleButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarToggleButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Overload
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarToggleButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton Methods
RadRibbonBarToggleButton Class See Also Send Feedback

The RadRibbonBarToggleButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RibbonBarToggleButton control. (Overrides RadRibbonBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Clicks the ribbonbar item. (Inherited from RadRibbonBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadRibbonBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Toggle | Toggles the ribbonbar button.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRibbonBarToggleButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..AssignElement Method
RadRibbonBarToggleButton Class See Also Send Feedback
Assign the DOM element to be the RibbonBarToggleButton control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRibbonBarToggleButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRibbonBarToggleButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..CallMethod Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..Capture Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..Click Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Clicks the ribbonbar item. (Inherited from RadRibbonBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..DragTo Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..GetValue Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..InvokeEvent Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..MouseClick Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..MouseHover Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..ScrollToVisible Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..SetValue Method
RadRibbonBarToggleButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
RadRibbonBarToggleButton Members
Telerik.WebAii.Controls.Html Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton..::..Toggle Method
RadRibbonBarToggleButton Class See Also Send Feedback
Toggles the ribbonbar button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Toggle()
Visual Basic
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

RadRibbonBarToggleButton Class
Telerik.WebAii.Controls.Html Namespace


RadRibbonBarToggleButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRibbonBarToggleButton Properties
RadRibbonBarToggleButton Class See Also Send Feedback

The RadRibbonBarToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client-side locator. (Inherited from RadRibbonBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisabledImageUrl | Get the disabled image url. (Inherited from RadRibbonBarItem.)
Public property | DisabledImageUrlLarge | Get the disabled image url large. (Inherited from RadRibbonBarItem.)
Public property | Enabled | Get whether the item is enabled. (Inherited from RadRibbonBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | ImageUrl | Get the image url. (Inherited from RadRibbonBarItem.)
Public property | ImageUrlLarge | Get the image url large. (Inherited from RadRibbonBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | ItemIndex | Get the index of the item. (Inherited from RadRibbonBarItem.)
Public property | ItemType | Type of the RibbonBar item. (Inherited from RadRibbonBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression. (Overrides RadRibbonBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParenItem | Get the direct parent item. (Inherited from RadRibbonBarItem.)
Public property | ParentGroup | Get the parent ribbonBar group. (Inherited from RadRibbonBarItem.)
Public property | ParentTab | Get the parent ribbonBar tab. (Inherited from RadRibbonBarItem.)
Public property | QuickAccessEnabled | Get whether the item has a quick access enabled. (Inherited from RadRibbonBarItem.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of the item. (Inherited from RadRibbonBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Toggled | Get whether the button is toggled.
Public property | Value | Get the value of the item. (Inherited from RadRibbonBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadRibbonBarToggleButton Class
Telerik.WebAii.Controls.Html Namespace


RadRotator Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator Members
RadRotator Class Constructors Methods Properties See Also Send Feedback

The RadRotator type exposes the following members.

Constructors

 | Name | Description
Public method | RadRotator()()()() | Initializes a new instance of the RadRotator class.
Public method | RadRotator(Element) | Initializes a new instance of the RadRotator class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Pause | Pauses the animation.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Resume | Resumes the paused animation.
Public method | Scroll | Scrolls the rotator according to the given direction. Accepts 'Left', 'Right', 'Up' and 'Down' scroll direction arguments.
Public method | ScrollItem | Scrolls the rotator item.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | ScrollViewPort | Scrolls the rotator view port.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Start | Starts the animation.
Public method | StartAutoPlay | Starts auto playing the rotator items.
Public method | Stop | Stops the animation.
Public method | StopViewportAnimation | If an item is partially shown and the rotator is paused, calling this function will force the rotator to fully display the item.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AnimationDirection | Gets/Sets the animation direction.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentItemIndex | Gets the current item index.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FrameDuration | Gets/Sets the time in milliseconds each frame will displays in automatic scrolling scenarios.
Public property | Height | Gets/Sets the Rotator height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InitialItemIndex | Gets/Sets the initial item index.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsAutomaticAdvance | Determines whether the rotator is set in AutomaticAdvance mode.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsPaused | Determines whether the RadRotator is paused or not.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsScrollingForward | Determines whether the rotator is scrolling forward.
Public property | IsScrollingLeft | Determines whether the rotator is scrolling to the left.
Public property | IsScrollingUp | Determines whether the rotator is scrolling upward.
Public property | IsSlideShow | Determines whether the rotator is set in SlideShow mode.
Public property | IsVertical | Determines whether the rotator is vertical.
Public property | IsViewportScrollMode | Determines whether the rotator is scrolling item by item or it is scrolling the whole viewport.
Public property | ItemCount | Gets the item count of the Rotator.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PauseOnMouseOver | Determines or set whether the scrolling pauses on mouse over.
Public property | RotatorType | Gets/Sets the rotator type.
Public property | ScrollDirection | Gets/Sets the rotator scrolling direction.
Public property | ScrollDuration | Gets/Sets the speed in milliseconds for scrolling rotator items.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the Rotator width in pixels.
Public property | WrapFrames | Determines or set whether to start scrolling the frames from the beginning as soon as the rotator shows the last frame.

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


RadRotator Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator Constructor
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadRotator()()()() | Initializes a new instance of the RadRotator class.
Public method | RadRotator(Element) | Initializes a new instance of the RadRotator class.

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


RadRotator Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator Constructor
RadRotator Class See Also Send Feedback
Initializes a new instance of the RadRotator class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRotator()
Visual Basic
Public Sub New
Visual C++
public:
RadRotator()

See Also

RadRotator Class
RadRotator Overload
Telerik.WebAii.Controls.Html Namespace


RadRotator Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator Constructor (Element)
RadRotator Class See Also Send Feedback
Initializes a new instance of the RadRotator class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadRotator(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadRotator(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRotator.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadRotator Class
RadRotator Overload
Telerik.WebAii.Controls.Html Namespace


RadRotator Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator Methods
RadRotator Class See Also Send Feedback

The RadRotator type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Pause | Pauses the animation.
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Resume | Resumes the paused animation.
Public method | Scroll | Scrolls the rotator according to the given direction. Accepts 'Left', 'Right', 'Up' and 'Down' scroll direction arguments.
Public method | ScrollItem | Scrolls the rotator item.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | ScrollViewPort | Scrolls the rotator view port.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Start | Starts the animation.
Public method | StartAutoPlay | Starts auto playing the rotator items.
Public method | Stop | Stops the animation.
Public method | StopViewportAnimation | If an item is partially shown and the rotator is paused, calling this function will force the rotator to fully display the item.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..AssignElement Method
RadRotator Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..CallMethod Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..Capture Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..Click Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..ControlAssert Method
RadRotator Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..DragTo Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..GetValue Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..InvokeEvent Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..MouseClick Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..MouseHover Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


Pause Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..Pause Method
RadRotator Class See Also Send Feedback
Pauses the animation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Pause()
Visual Basic
Public Sub Pause
Visual C++
public:
void Pause()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


Resume Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..Resume Method
RadRotator Class See Also Send Feedback
Resumes the paused animation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Resume()
Visual Basic
Public Sub Resume
Visual C++
public:
void Resume()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


Scroll Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..Scroll Method
RadRotator Class See Also Send Feedback
Scrolls the rotator according to the given direction. Accepts 'Left', 'Right', 'Up' and 'Down' scroll direction arguments.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Scroll(
    RotatorScrollDirection direction
)
Visual Basic
Public Sub Scroll ( _
    direction As RotatorScrollDirection _
)
Visual C++
public:
void Scroll(
    RotatorScrollDirection direction
)

Parameters

direction
Type: Telerik.WebAii.Controls.Html..::..RotatorScrollDirection

[Missing <param name="direction"/> documentation for "M:Telerik.WebAii.Controls.Html.RadRotator.Scroll(Telerik.WebAii.Controls.Html.RotatorScrollDirection)"]

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


ScrollItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..ScrollItem Method
RadRotator Class See Also Send Feedback
Scrolls the rotator item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ScrollItem()
Visual Basic
Public Sub ScrollItem
Visual C++
public:
void ScrollItem()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..ScrollToVisible Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


ScrollViewPort Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..ScrollViewPort Method
RadRotator Class See Also Send Feedback
Scrolls the rotator view port.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ScrollViewPort()
Visual Basic
Public Sub ScrollViewPort
Visual C++
public:
void ScrollViewPort()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..SetValue Method
RadRotator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadRotator Class
RadRotator Members
Telerik.WebAii.Controls.Html Namespace


Start Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..Start Method
RadRotator Class See Also Send Feedback
Starts the animation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Start()
Visual Basic
Public Sub Start
Visual C++
public:
void Start()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


StartAutoPlay Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..StartAutoPlay Method
RadRotator Class See Also Send Feedback
Starts auto playing the rotator items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void StartAutoPlay()
Visual Basic
Public Sub StartAutoPlay
Visual C++
public:
void StartAutoPlay()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


Stop Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..Stop Method
RadRotator Class See Also Send Feedback
Stops the animation.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Stop()
Visual Basic
Public Sub Stop
Visual C++
public:
void Stop()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


StopViewportAnimation Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator..::..StopViewportAnimation Method
RadRotator Class See Also Send Feedback
If an item is partially shown and the rotator is paused, calling this function will force the rotator to fully display the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void StopViewportAnimation()
Visual Basic
Public Sub StopViewportAnimation
Visual C++
public:
void StopViewportAnimation()

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


RadRotator Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadRotator Properties
RadRotator Class See Also Send Feedback

The RadRotator type exposes the following members.

Properties

 | Name | Description
Public property | AnimationDirection | Gets/Sets the animation direction.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentItemIndex | Gets the current item index.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FrameDuration | Gets/Sets the time in milliseconds each frame will displays in automatic scrolling scenarios.
Public property | Height | Gets/Sets the Rotator height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InitialItemIndex | Gets/Sets the initial item index.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsAutomaticAdvance | Determines whether the rotator is set in AutomaticAdvance mode.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsPaused | Determines whether the RadRotator is paused or not.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsScrollingForward | Determines whether the rotator is scrolling forward.
Public property | IsScrollingLeft | Determines whether the rotator is scrolling to the left.
Public property | IsScrollingUp | Determines whether the rotator is scrolling upward.
Public property | IsSlideShow | Determines whether the rotator is set in SlideShow mode.
Public property | IsVertical | Determines whether the rotator is vertical.
Public property | IsViewportScrollMode | Determines whether the rotator is scrolling item by item or it is scrolling the whole viewport.
Public property | ItemCount | Gets the item count of the Rotator.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PauseOnMouseOver | Determines or set whether the scrolling pauses on mouse over.
Public property | RotatorType | Gets/Sets the rotator type.
Public property | ScrollDirection | Gets/Sets the rotator scrolling direction.
Public property | ScrollDuration | Gets/Sets the speed in milliseconds for scrolling rotator items.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the Rotator width in pixels.
Public property | WrapFrames | Determines or set whether to start scrolling the frames from the beginning as soon as the rotator shows the last frame.

See Also

RadRotator Class
Telerik.WebAii.Controls.Html Namespace


RadScheduler Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler Members
RadScheduler Class Constructors Methods Properties See Also Send Feedback

The RadScheduler type exposes the following members.

Constructors

 | Name | Description
Public method | RadScheduler()()()() | Initializes a new instance of the RadScheduler class.
Public method | RadScheduler(Element) | Initializes a new instance of the RadScheduler class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AdvancedFormSetText | Advanced form set text method.
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangeHours | Click the ChangeHours link.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetDayViewTimeSlot(Int32) | Get the TimeSlot form scheduler DayView by index.
Public method | GetDayViewTimeSlot(Int32, Int32) | Get the TimeSlot form scheduler DayView by index and resource index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMonthViewTimeSlot | Get the TimeSlot form scheduler MonthView by timeSlot index and day index.
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetTimeLineTimeSlot | Get the TimeSlot form scheduler TimeLineView.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetWeekViewAllDayTimeSlot | Get the AllDay TimeSlot form scheduler WeekView.
Public method | GetWeekViewTimeSlot | Get the TimeSlot form scheduler WeekView by timeSlot index and day index.
Public method | GoNext | Go to the Next day.
Public method | GoPrevious | Go to the Previous day.
Public method | GoToday | Navigate to today.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InlineFormSetText | Inline form set text method.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NavigateDayView | Navigate to day view.
Public method | NavigateMonthView | Navigate to month view.
Public method | NavigateTimelineView | Navigate to timeline view.
Public method | NavigateWeekView | Navigate to week view.
Public method | OpenCalendar | Activate date picker.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AdvancedFormAllDayCheckBox | Advanced form all day checkbox.
Public property | AdvancedFormAllDayCheckBoxChecked | Advanced form all day checkbox checked state.
Public property | AdvancedFormCancelButton | Get the advanced form Cancel button.
Public property | AdvancedFormDiv | Get the advanced form if visible or null otherwise.
Public property | AdvancedFormMoreControlsPanel | Advanced form more controls panel.
Public property | AdvancedFormMoreControlsPanelVisible | Advanced form more controls visible state.
Public property | AdvancedFormRecurrenceCheckBox | Advanced form recurrence checkbox.
Public property | AdvancedFormRecurrenceCheckBoxChecked | Advanced form recurrence checkbox checked state.
Public property | AdvancedFormRecurrencePanel | Advanced form recurrence panel.
Public property | AdvancedFormRecurrencePanelVisible | Advanced form recurrence panel visible state.
Public property | AdvancedFormSaveButton | Get the advanced form Save button.
Public property | AdvancedFormText | Advanced form text in case the advanced form is visible, null otherwise.
Public property | AdvancedFormVisible | Check whether the advanced form is visible.
Public property | Appointments | Get the Appointments object of the scheduler.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CalendarVisible | Returns whether the calendar is visible.
Public property | CalendarWrapper | Scheduler calendar wrapper.
Public property | ChangeHoursLinkText | Change hours link text.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FirstDayStart | Current day in the day view.
Public property | GetDayViewAllDayTimeSlot | Get the AllDay TimeSlot form scheduler DayView.
Public property | HeaderText | Get the current header text.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InlineFormDiv | Get the inline form div if visible, null otherwise.
Public property | InlineFormText | Get the text of the inline form if visible, or null otherwise.
Public property | InlineFormVisible | Get whether the inline form is visible.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsVisibleModalDialog | Check whether the modal dialog is visible.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for scheduler. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | ModalDialogTitle | Returns modal dialog title.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ResourceTypesString | Returns a string containing the scheduler resource types.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedView | Selected view in the scheduler.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


RadScheduler Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler Constructor
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadScheduler()()()() | Initializes a new instance of the RadScheduler class.
Public method | RadScheduler(Element) | Initializes a new instance of the RadScheduler class.

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


RadScheduler Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler Constructor
RadScheduler Class See Also Send Feedback
Initializes a new instance of the RadScheduler class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadScheduler()
Visual Basic
Public Sub New
Visual C++
public:
RadScheduler()

See Also

RadScheduler Class
RadScheduler Overload
Telerik.WebAii.Controls.Html Namespace


RadScheduler Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler Constructor (Element)
RadScheduler Class See Also Send Feedback
Initializes a new instance of the RadScheduler class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadScheduler(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadScheduler(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadScheduler Class
RadScheduler Overload
Telerik.WebAii.Controls.Html Namespace


RadScheduler Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler Methods
RadScheduler Class See Also Send Feedback

The RadScheduler type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AdvancedFormSetText | Advanced form set text method.
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangeHours | Click the ChangeHours link.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetDayViewTimeSlot(Int32) | Get the TimeSlot form scheduler DayView by index.
Public method | GetDayViewTimeSlot(Int32, Int32) | Get the TimeSlot form scheduler DayView by index and resource index.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMonthViewTimeSlot | Get the TimeSlot form scheduler MonthView by timeSlot index and day index.
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetTimeLineTimeSlot | Get the TimeSlot form scheduler TimeLineView.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetWeekViewAllDayTimeSlot | Get the AllDay TimeSlot form scheduler WeekView.
Public method | GetWeekViewTimeSlot | Get the TimeSlot form scheduler WeekView by timeSlot index and day index.
Public method | GoNext | Go to the Next day.
Public method | GoPrevious | Go to the Previous day.
Public method | GoToday | Navigate to today.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InlineFormSetText | Inline form set text method.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NavigateDayView | Navigate to day view.
Public method | NavigateMonthView | Navigate to month view.
Public method | NavigateTimelineView | Navigate to timeline view.
Public method | NavigateWeekView | Navigate to week view.
Public method | OpenCalendar | Activate date picker.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormSetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..AdvancedFormSetText Method
RadScheduler Class See Also Send Feedback
Advanced form set text method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void AdvancedFormSetText(
    string text
)
Visual Basic
Public Sub AdvancedFormSetText ( _
    text As String _
)
Visual C++
public:
void AdvancedFormSetText(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.AdvancedFormSetText(System.String)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..AssignElement Method
RadScheduler Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..CallMethod Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..Capture Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


ChangeHours Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..ChangeHours Method
RadScheduler Class See Also Send Feedback
Click the ChangeHours link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ChangeHours()
Visual Basic
Public Sub ChangeHours
Visual C++
public:
void ChangeHours()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..Click Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..ControlAssert Method
RadScheduler Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..DragTo Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


GetDayViewTimeSlot Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GetDayViewTimeSlot Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetDayViewTimeSlot(Int32) | Get the TimeSlot form scheduler DayView by index.
Public method | GetDayViewTimeSlot(Int32, Int32) | Get the TimeSlot form scheduler DayView by index and resource index.

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


GetDayViewTimeSlot Method (Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GetDayViewTimeSlot Method (Int32)
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler DayView by index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerTimeSlot GetDayViewTimeSlot(
    int index
)
Visual Basic
Public Function GetDayViewTimeSlot ( _
    index As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetDayViewTimeSlot(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32)"]

See Also

RadScheduler Class
GetDayViewTimeSlot Overload
Telerik.WebAii.Controls.Html Namespace


GetDayViewTimeSlot Method (Int32, Int32)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GetDayViewTimeSlot Method (Int32, Int32)
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler DayView by index and resource index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerTimeSlot GetDayViewTimeSlot(
    int index,
    int resourceIndex
)
Visual Basic
Public Function GetDayViewTimeSlot ( _
    index As Integer, _
    resourceIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetDayViewTimeSlot(
    int index,
    int resourceIndex
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32,System.Int32)"]

resourceIndex
Type: System..::..Int32

[Missing <param name="resourceIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetDayViewTimeSlot(System.Int32,System.Int32)"]

See Also

RadScheduler Class
GetDayViewTimeSlot Overload
Telerik.WebAii.Controls.Html Namespace


GetMonthViewTimeSlot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GetMonthViewTimeSlot Method
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler MonthView by timeSlot index and day index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerTimeSlot GetMonthViewTimeSlot(
    int index,
    int dayIndex
)
Visual Basic
Public Function GetMonthViewTimeSlot ( _
    index As Integer, _
    dayIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetMonthViewTimeSlot(
    int index,
    int dayIndex
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetMonthViewTimeSlot(System.Int32,System.Int32)"]

dayIndex
Type: System..::..Int32

[Missing <param name="dayIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetMonthViewTimeSlot(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetMonthViewTimeSlot(System.Int32,System.Int32)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GetTimeLineTimeSlot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GetTimeLineTimeSlot Method
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler TimeLineView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerTimeSlot GetTimeLineTimeSlot(
    int dayIndex
)
Visual Basic
Public Function GetTimeLineTimeSlot ( _
    dayIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetTimeLineTimeSlot(
    int dayIndex
)

Parameters

dayIndex
Type: System..::..Int32

[Missing <param name="dayIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetTimeLineTimeSlot(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetTimeLineTimeSlot(System.Int32)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GetValue Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


GetWeekViewAllDayTimeSlot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GetWeekViewAllDayTimeSlot Method
RadScheduler Class See Also Send Feedback
Get the AllDay TimeSlot form scheduler WeekView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerTimeSlot GetWeekViewAllDayTimeSlot(
    int dayIndex
)
Visual Basic
Public Function GetWeekViewAllDayTimeSlot ( _
    dayIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetWeekViewAllDayTimeSlot(
    int dayIndex
)

Parameters

dayIndex
Type: System..::..Int32

[Missing <param name="dayIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewAllDayTimeSlot(System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewAllDayTimeSlot(System.Int32)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GetWeekViewTimeSlot Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GetWeekViewTimeSlot Method
RadScheduler Class See Also Send Feedback
Get the TimeSlot form scheduler WeekView by timeSlot index and day index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerTimeSlot GetWeekViewTimeSlot(
    int index,
    int dayIndex
)
Visual Basic
Public Function GetWeekViewTimeSlot ( _
    index As Integer, _
    dayIndex As Integer _
) As SchedulerTimeSlot
Visual C++
public:
SchedulerTimeSlot^ GetWeekViewTimeSlot(
    int index,
    int dayIndex
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewTimeSlot(System.Int32,System.Int32)"]

dayIndex
Type: System..::..Int32

[Missing <param name="dayIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewTimeSlot(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.GetWeekViewTimeSlot(System.Int32,System.Int32)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GoNext Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GoNext Method
RadScheduler Class See Also Send Feedback
Go to the Next day.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void GoNext()
Visual Basic
Public Sub GoNext
Visual C++
public:
void GoNext()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GoPrevious Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GoPrevious Method
RadScheduler Class See Also Send Feedback
Go to the Previous day.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void GoPrevious()
Visual Basic
Public Sub GoPrevious
Visual C++
public:
void GoPrevious()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


GoToday Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..GoToday Method
RadScheduler Class See Also Send Feedback
Navigate to today.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void GoToday()
Visual Basic
Public Sub GoToday
Visual C++
public:
void GoToday()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


InlineFormSetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..InlineFormSetText Method
RadScheduler Class See Also Send Feedback
Inline form set text method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void InlineFormSetText(
    string text
)
Visual Basic
Public Sub InlineFormSetText ( _
    text As String _
)
Visual C++
public:
void InlineFormSetText(
    String^ text
)

Parameters

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadScheduler.InlineFormSetText(System.String)"]

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..InvokeEvent Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..MouseClick Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..MouseHover Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


NavigateDayView Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..NavigateDayView Method
RadScheduler Class See Also Send Feedback
Navigate to day view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NavigateDayView()
Visual Basic
Public Sub NavigateDayView
Visual C++
public:
void NavigateDayView()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


NavigateMonthView Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..NavigateMonthView Method
RadScheduler Class See Also Send Feedback
Navigate to month view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NavigateMonthView()
Visual Basic
Public Sub NavigateMonthView
Visual C++
public:
void NavigateMonthView()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


NavigateTimelineView Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..NavigateTimelineView Method
RadScheduler Class See Also Send Feedback
Navigate to timeline view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NavigateTimelineView()
Visual Basic
Public Sub NavigateTimelineView
Visual C++
public:
void NavigateTimelineView()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


NavigateWeekView Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..NavigateWeekView Method
RadScheduler Class See Also Send Feedback
Navigate to week view.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NavigateWeekView()
Visual Basic
Public Sub NavigateWeekView
Visual C++
public:
void NavigateWeekView()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


OpenCalendar Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..OpenCalendar Method
RadScheduler Class See Also Send Feedback
Activate date picker.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void OpenCalendar()
Visual Basic
Public Sub OpenCalendar
Visual C++
public:
void OpenCalendar()

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..ScrollToVisible Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler..::..SetValue Method
RadScheduler Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadScheduler Class
RadScheduler Members
Telerik.WebAii.Controls.Html Namespace


RadScheduler Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadScheduler Properties
RadScheduler Class See Also Send Feedback

The RadScheduler type exposes the following members.

Properties

 | Name | Description
Public property | AdvancedFormAllDayCheckBox | Advanced form all day checkbox.
Public property | AdvancedFormAllDayCheckBoxChecked | Advanced form all day checkbox checked state.
Public property | AdvancedFormCancelButton | Get the advanced form Cancel button.
Public property | AdvancedFormDiv | Get the advanced form if visible or null otherwise.
Public property | AdvancedFormMoreControlsPanel | Advanced form more controls panel.
Public property | AdvancedFormMoreControlsPanelVisible | Advanced form more controls visible state.
Public property | AdvancedFormRecurrenceCheckBox | Advanced form recurrence checkbox.
Public property | AdvancedFormRecurrenceCheckBoxChecked | Advanced form recurrence checkbox checked state.
Public property | AdvancedFormRecurrencePanel | Advanced form recurrence panel.
Public property | AdvancedFormRecurrencePanelVisible | Advanced form recurrence panel visible state.
Public property | AdvancedFormSaveButton | Get the advanced form Save button.
Public property | AdvancedFormText | Advanced form text in case the advanced form is visible, null otherwise.
Public property | AdvancedFormVisible | Check whether the advanced form is visible.
Public property | Appointments | Get the Appointments object of the scheduler.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CalendarVisible | Returns whether the calendar is visible.
Public property | CalendarWrapper | Scheduler calendar wrapper.
Public property | ChangeHoursLinkText | Change hours link text.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FirstDayStart | Current day in the day view.
Public property | GetDayViewAllDayTimeSlot | Get the AllDay TimeSlot form scheduler DayView.
Public property | HeaderText | Get the current header text.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InlineFormDiv | Get the inline form div if visible, null otherwise.
Public property | InlineFormText | Get the text of the inline form if visible, or null otherwise.
Public property | InlineFormVisible | Get whether the inline form is visible.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsVisibleModalDialog | Check whether the modal dialog is visible.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for scheduler. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | ModalDialogTitle | Returns modal dialog title.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ResourceTypesString | Returns a string containing the scheduler resource types.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedView | Selected view in the scheduler.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadScheduler Class
Telerik.WebAii.Controls.Html Namespace


RadSlider Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider Members
RadSlider Class Constructors Methods Properties See Also Send Feedback

The RadSlider type exposes the following members.

Constructors

 | Name | Description
Public method | RadSlider()()()() | Initializes a new instance of the RadSlider class.
Public method | RadSlider(Element) | Initializes a new instance of the RadSlider class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangeSelectedRegion | Initiates selected region change of the start/end values.
Public method | ChangeValue | Initiates change Slider value action.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadSlider. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentValue | Gets/Sets RadSlider's value.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets the Slider height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsDirectionReversed | Determines or set whether the Slider direction is reversed.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsSelectionRangeEnabled | Determines or set whether the slider range selection is enabled.
Public property | LargeChange | Gets/Sets the large change step of the Slider.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlider. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaximumValue | Gets/Sets the maximum value of the Slider.
Public property | MinimumValue | Gets/Sets the minimum value of the Slider.
Public property | Orientation | Gets/Sets the Slider orientation.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedRegionHeight | Gets RadSlider's Selected Region Height in pixels.
Public property | SelectedRegionWidth | Get RadSlider's Selected Region Width in pixels.
Public property | SelectionEnd | Gets/Sets RadSlider's selection end value.
Public property | SelectionStart | Gets/Sets RadSlider's selection start value.
Public property | SliderId | Gets the ID of the slider.
Public property | SmallChange | Gets/Sets the small change step of the Slider.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the Slider width in pixels.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


RadSlider Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider Constructor
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadSlider()()()() | Initializes a new instance of the RadSlider class.
Public method | RadSlider(Element) | Initializes a new instance of the RadSlider class.

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


RadSlider Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider Constructor
RadSlider Class See Also Send Feedback
Initializes a new instance of the RadSlider class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSlider()
Visual Basic
Public Sub New
Visual C++
public:
RadSlider()

See Also

RadSlider Class
RadSlider Overload
Telerik.WebAii.Controls.Html Namespace


RadSlider Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider Constructor (Element)
RadSlider Class See Also Send Feedback
Initializes a new instance of the RadSlider class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSlider(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSlider(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
RadSlider wrapper div.

See Also

RadSlider Class
RadSlider Overload
Telerik.WebAii.Controls.Html Namespace


RadSlider Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider Methods
RadSlider Class See Also Send Feedback

The RadSlider type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangeSelectedRegion | Initiates selected region change of the start/end values.
Public method | ChangeValue | Initiates change Slider value action.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..AssignElement Method
RadSlider Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..CallMethod Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..Capture Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


ChangeSelectedRegion Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..ChangeSelectedRegion Method
RadSlider Class See Also Send Feedback
Initiates selected region change of the start/end values.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ChangeSelectedRegion(
    decimal start,
    decimal end
)
Visual Basic
Public Sub ChangeSelectedRegion ( _
    start As Decimal, _
    end As Decimal _
)
Visual C++
public:
void ChangeSelectedRegion(
    Decimal start,
    Decimal end
)

Parameters

start
Type: System..::..Decimal
The new start value.
end
Type: System..::..Decimal
The new end value.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


ChangeValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..ChangeValue Method
RadSlider Class See Also Send Feedback
Initiates change Slider value action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ChangeValue(
    decimal value
)
Visual Basic
Public Sub ChangeValue ( _
    value As Decimal _
)
Visual C++
public:
void ChangeValue(
    Decimal value
)

Parameters

value
Type: System..::..Decimal
The new value to be set.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..Click Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..ControlAssert Method
RadSlider Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..DragTo Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..GetValue Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..InvokeEvent Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..MouseClick Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..MouseHover Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..ScrollToVisible Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider..::..SetValue Method
RadSlider Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSlider Class
RadSlider Members
Telerik.WebAii.Controls.Html Namespace


RadSlider Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlider Properties
RadSlider Class See Also Send Feedback

The RadSlider type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadSlider. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentValue | Gets/Sets RadSlider's value.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets the Slider height in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsDirectionReversed | Determines or set whether the Slider direction is reversed.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsSelectionRangeEnabled | Determines or set whether the slider range selection is enabled.
Public property | LargeChange | Gets/Sets the large change step of the Slider.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlider. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaximumValue | Gets/Sets the maximum value of the Slider.
Public property | MinimumValue | Gets/Sets the minimum value of the Slider.
Public property | Orientation | Gets/Sets the Slider orientation.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedRegionHeight | Gets RadSlider's Selected Region Height in pixels.
Public property | SelectedRegionWidth | Get RadSlider's Selected Region Width in pixels.
Public property | SelectionEnd | Gets/Sets RadSlider's selection end value.
Public property | SelectionStart | Gets/Sets RadSlider's selection start value.
Public property | SliderId | Gets the ID of the slider.
Public property | SmallChange | Gets/Sets the small change step of the Slider.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the Slider width in pixels.

See Also

RadSlider Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane Members
RadSlidingPane Class Constructors Methods Properties See Also Send Feedback

The RadSlidingPane type exposes the following members.

Constructors

 | Name | Description
Public method | RadSlidingPane()()()() | Initializes a new instance of the RadSlidingPane class.
Public method | RadSlidingPane(Element) | Initializes a new instance of the RadSlidingPane class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapses the sliding pane.
Public method | Dock | Docks the sliding pane.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Undock | Undocks the sliding pane.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CollapseIconElement | The element, which is used to collapse the sliding pane.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Docked | Determines whether the sliding pane is docked.
Public property | DockIconElement | The element, which is used to dock the sliding pane.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Determines whether the sliding pane is expanded (If the pane is docked, it is not expanded).
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlidingPane. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollingEnabled | Determines whether the sliding pane scrolling is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UnDockIconElement | The element, which is used to undock the sliding pane.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane Constructor
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadSlidingPane()()()() | Initializes a new instance of the RadSlidingPane class.
Public method | RadSlidingPane(Element) | Initializes a new instance of the RadSlidingPane class.

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane Constructor
RadSlidingPane Class See Also Send Feedback
Initializes a new instance of the RadSlidingPane class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSlidingPane()
Visual Basic
Public Sub New
Visual C++
public:
RadSlidingPane()

See Also

RadSlidingPane Class
RadSlidingPane Overload
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane Constructor (Element)
RadSlidingPane Class See Also Send Feedback
Initializes a new instance of the RadSlidingPane class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSlidingPane(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSlidingPane(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSlidingPane.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSlidingPane Class
RadSlidingPane Overload
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane Methods
RadSlidingPane Class See Also Send Feedback

The RadSlidingPane type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapses the sliding pane.
Public method | Dock | Docks the sliding pane.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Undock | Undocks the sliding pane.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..AssignElement Method
RadSlidingPane Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..CallMethod Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..Capture Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..Click Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..Collapse Method
RadSlidingPane Class See Also Send Feedback
Collapses the sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


Dock Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..Dock Method
RadSlidingPane Class See Also Send Feedback
Docks the sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Dock()
Visual Basic
Public Sub Dock
Visual C++
public:
void Dock()

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..DragTo Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..GetValue Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..InvokeEvent Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..MouseClick Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..MouseHover Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..ScrollToVisible Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..SetValue Method
RadSlidingPane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
RadSlidingPane Members
Telerik.WebAii.Controls.Html Namespace


Undock Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane..::..Undock Method
RadSlidingPane Class See Also Send Feedback
Undocks the sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Undock()
Visual Basic
Public Sub Undock
Visual C++
public:
void Undock()

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingPane Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingPane Properties
RadSlidingPane Class See Also Send Feedback

The RadSlidingPane type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CollapseIconElement | The element, which is used to collapse the sliding pane.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Docked | Determines whether the sliding pane is docked.
Public property | DockIconElement | The element, which is used to dock the sliding pane.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Determines whether the sliding pane is expanded (If the pane is docked, it is not expanded).
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlidingPane. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollingEnabled | Determines whether the sliding pane scrolling is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UnDockIconElement | The element, which is used to undock the sliding pane.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSlidingPane Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone Members
RadSlidingZone Class Constructors Methods Properties See Also Send Feedback

The RadSlidingZone type exposes the following members.

Constructors

 | Name | Description
Public method | RadSlidingZone()()()() | Initializes a new instance of the RadSlidingZone class.
Public method | RadSlidingZone(Element) | Initializes a new instance of the RadSlidingZone class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlTable..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands sliding pane.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertTable()()()() | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)
Public Extension Method | AssertTable(Boolean) | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)

Properties

 | Name | Description
Public property | AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows) (Inherited from HtmlTable.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag. (Inherited from HtmlTable.)
Public property | Border | Gets the width of the table border. (Inherited from HtmlTable.)
Public property | Caption | Gets the caption of a table. (Inherited from HtmlTable.)
Public property | CellPadding | Gets the amount of space between the cell border and cell content (Inherited from HtmlTable.)
Public property | CellSpacing | Gets the amount of space between the cells in a table. (Inherited from HtmlTable.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClickToOpen | Determines or set whether click on the tab is needed to open the sliding pane.
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColumnCount | Gets the number of columns in this table (Inherited from HtmlTable.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag. (Inherited from HtmlTable.)
Public property | HeadRows | Gets the rows contained in the table header if the table is using the thead tag. (Inherited from HtmlTable.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Gets requested row by index. (Inherited from HtmlTable.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlidingZone. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PaneCount | Gets the sliding pane count.
Public property | Rows | Return List of HtmlTableRows. Only the body rows if TBody is used. (Inherited from HtmlTable.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SlideDirection | Gets the direction of pane sliding.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table. (Inherited from HtmlTable.)

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone Constructor
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadSlidingZone()()()() | Initializes a new instance of the RadSlidingZone class.
Public method | RadSlidingZone(Element) | Initializes a new instance of the RadSlidingZone class.

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone Constructor
RadSlidingZone Class See Also Send Feedback
Initializes a new instance of the RadSlidingZone class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSlidingZone()
Visual Basic
Public Sub New
Visual C++
public:
RadSlidingZone()

See Also

RadSlidingZone Class
RadSlidingZone Overload
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone Constructor (Element)
RadSlidingZone Class See Also Send Feedback
Initializes a new instance of the RadSlidingZone class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSlidingZone(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSlidingZone(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSlidingZone.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSlidingZone Class
RadSlidingZone Overload
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone Methods
RadSlidingZone Class See Also Send Feedback

The RadSlidingZone type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlTable..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expands sliding pane.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertTable()()()() | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)
Public Extension Method | AssertTable(Boolean) | Overloaded. Assert methods for the HtmlTable content. (Defined by HtmlTableAssertExtensions.)

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..AssignElement Method
RadSlidingZone Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..CallMethod Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..Capture Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..Click Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..ControlAssert Method
RadSlidingZone Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..DragTo Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..Expand Method
RadSlidingZone Class See Also Send Feedback
Expands sliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand(
    string id
)
Visual Basic
Public Sub Expand ( _
    id As String _
)
Visual C++
public:
void Expand(
    String^ id
)

Parameters

id
Type: System..::..String
Sliding pane id.

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..GetValue Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..InvokeEvent Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..MouseClick Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..MouseHover Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..ScrollToVisible Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone..::..SetValue Method
RadSlidingZone Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSlidingZone Class
RadSlidingZone Members
Telerik.WebAii.Controls.Html Namespace


RadSlidingZone Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSlidingZone Properties
RadSlidingZone Class See Also Send Feedback

The RadSlidingZone type exposes the following members.

Properties

 | Name | Description
Public property | AllRows | Gets all rows as one collection. (Head rows, then body rows and then footer rows) (Inherited from HtmlTable.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | BodyRows | Gets the rows contained in the body of the table if the table is using the tbody tag. (Inherited from HtmlTable.)
Public property | Border | Gets the width of the table border. (Inherited from HtmlTable.)
Public property | Caption | Gets the caption of a table. (Inherited from HtmlTable.)
Public property | CellPadding | Gets the amount of space between the cell border and cell content (Inherited from HtmlTable.)
Public property | CellSpacing | Gets the amount of space between the cells in a table. (Inherited from HtmlTable.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClickToOpen | Determines or set whether click on the tab is needed to open the sliding pane.
Public property | ClientSideLocator | Gets the locator FindParam. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColumnCount | Gets the number of columns in this table (Inherited from HtmlTable.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FootRows | Gets the rows contained in the table footer if the table is using the tfoot tag. (Inherited from HtmlTable.)
Public property | HeadRows | Gets the rows contained in the table header if the table is using the thead tag. (Inherited from HtmlTable.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Gets requested row by index. (Inherited from HtmlTable.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSlidingZone. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PaneCount | Gets the sliding pane count.
Public property | Rows | Return List of HtmlTableRows. Only the body rows if TBody is used. (Inherited from HtmlTable.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SlideDirection | Gets the direction of pane sliding.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table. (Inherited from HtmlTable.)

See Also

RadSlidingZone Class
Telerik.WebAii.Controls.Html Namespace


RadSocialShare Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare Members
RadSocialShare Class Constructors Methods Properties See Also Send Feedback

The RadSocialShare type exposes the following members.

Constructors

 | Name | Description
Public method | RadSocialShare()()()() | Initializes a new instance of the RadSocialShare class.
Public method | RadSocialShare(Element) | Initializes a new instance of the RadSocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | ButtonIsAvailable | Verifies whether a certain button is available.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickOption | Gets or sets whether the SocialShareFacebook is enabled.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the SocialShare control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | MainButtonsCount | Gets the count of SocialShare main buttons.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TitleToShare | Gets or Sets the SocialShare Title to share value.
Public property | UrlToShare | Gets or Sets the SocialShare Url to share value.
Public property | Visible | Gets or sets whether the SocialShare is enabled.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
Telerik.WebAii.Controls.Html Namespace


RadSocialShare Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare Constructor
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadSocialShare()()()() | Initializes a new instance of the RadSocialShare class.
Public method | RadSocialShare(Element) | Initializes a new instance of the RadSocialShare class.

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


RadSocialShare Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare Constructor
RadSocialShare Class See Also Send Feedback
Initializes a new instance of the RadSocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSocialShare()
Visual Basic
Public Sub New
Visual C++
public:
RadSocialShare()

See Also

RadSocialShare Class
RadSocialShare Overload
Telerik.WebAii.Controls.Html Namespace


RadSocialShare Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare Constructor (Element)
RadSocialShare Class See Also Send Feedback
Initializes a new instance of the RadSocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSocialShare(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSocialShare(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSocialShare.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSocialShare Class
RadSocialShare Overload
Telerik.WebAii.Controls.Html Namespace


RadSocialShare Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare Methods
RadSocialShare Class See Also Send Feedback

The RadSocialShare type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | ButtonIsAvailable | Verifies whether a certain button is available.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickOption | Gets or sets whether the SocialShareFacebook is enabled.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadSocialShare Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..AssignElement Method
RadSocialShare Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadSocialShare Class
Telerik.WebAii.Controls.Html Namespace


ButtonIsAvailable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..ButtonIsAvailable Method
RadSocialShare Class See Also Send Feedback
Verifies whether a certain button is available.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool ButtonIsAvailable(
    SocialShareButton button
)
Visual Basic
Public Function ButtonIsAvailable ( _
    button As SocialShareButton _
) As Boolean
Visual C++
public:
bool ButtonIsAvailable(
    SocialShareButton button
)

Parameters

button
Type: Telerik.WebAii.Controls.Html..::..SocialShareButton

[Missing <param name="button"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSocialShare.ButtonIsAvailable(Telerik.WebAii.Controls.Html.SocialShareButton)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadSocialShare.ButtonIsAvailable(Telerik.WebAii.Controls.Html.SocialShareButton)"]

See Also

RadSocialShare Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..CallMethod Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..Capture Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..Click Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


ClickOption Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..ClickOption Method
RadSocialShare Class See Also Send Feedback
Gets or sets whether the SocialShareFacebook is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClickOption(
    SocialShareButton option
)
Visual Basic
Public Sub ClickOption ( _
    option As SocialShareButton _
)
Visual C++
public:
void ClickOption(
    SocialShareButton option
)

Parameters

option
Type: Telerik.WebAii.Controls.Html..::..SocialShareButton

[Missing <param name="option"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSocialShare.ClickOption(Telerik.WebAii.Controls.Html.SocialShareButton)"]

See Also

RadSocialShare Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..ControlAssert Method
RadSocialShare Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadSocialShare.ControlAssert"]

See Also

RadSocialShare Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..DragTo Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..GetValue Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..InvokeEvent Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..MouseClick Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..MouseHover Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..ScrollToVisible Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare..::..SetValue Method
RadSocialShare Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSocialShare Class
RadSocialShare Members
Telerik.WebAii.Controls.Html Namespace


RadSocialShare Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSocialShare Properties
RadSocialShare Class See Also Send Feedback

The RadSocialShare type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Gets the client Id of the SocialShare control.
Public property | ClientSideLocator | Gets the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | MainButtonsCount | Gets the count of SocialShare main buttons.
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TitleToShare | Gets or Sets the SocialShare Title to share value.
Public property | UrlToShare | Gets or Sets the SocialShare Url to share value.
Public property | Visible | Gets or sets whether the SocialShare is enabled.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSocialShare Class
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog Members
RadSpellDialog Class Constructors Methods Properties See Also Send Feedback

The RadSpellDialog type exposes the following members.

Constructors

 | Name | Description
Public method | RadSpellDialog()()()() | Initializes a new instance of the RadSpellDialog class.
Public method | RadSpellDialog(Element) | Initializes a new instance of the RadSpellDialog class.

Methods

 | Name | Description
Public method | AddCustomButtonClick | Clicks the add custom button.
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangeAllButtonClick | Clicks the change all button.
Public method | ChangeButtonClick | Clicks the change button.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CloseButtonClick | Clicks the close button.
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | IgnoreAllButtonClick | Clicks the ignore all button.
Public method | IgnoreButtonClick | Clicks the ignore button.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UndoButtonClick | Clicks the undo button.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AddCustomButton | Gets spell add custom button.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChangeAllButton | Gets spell change all button.
Public property | ChangeButton | Gets spell change button.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadSpell. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CloseButton | Gets spell close button.
Public property | ControlToCheck | Gets/Sets the ID of the control to spell check..
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentText | Gets the current text in the TextContainer.
Public property | DialogOpenerSkin | Gets/Sets the skinof the DialogOpener.
Public property | DictionaryLanguage | Gets/Sets the dictionary language culture code.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IgnoreAllButton | Gets spell ignore all button.
Public property | IgnoreButton | Gets spell ignore button.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSpellDialog. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedLanguage | Get the language currently selected in the drop down displayed when the SupportedLanguages language property is set.
Public property | SourceText | Gets/Sets the text of the TextSource object that RadSpell is attached to.
Public property | Spellchecked | Determines whether the spell checking for the target control has been completed. (the OnClientCheckFinished event has been fired).
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UndoButton | Gets spell undo button.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog Constructor
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadSpellDialog()()()() | Initializes a new instance of the RadSpellDialog class.
Public method | RadSpellDialog(Element) | Initializes a new instance of the RadSpellDialog class.

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog Constructor
RadSpellDialog Class See Also Send Feedback
Initializes a new instance of the RadSpellDialog class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSpellDialog()
Visual Basic
Public Sub New
Visual C++
public:
RadSpellDialog()

See Also

RadSpellDialog Class
RadSpellDialog Overload
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog Constructor (Element)
RadSpellDialog Class See Also Send Feedback
Initializes a new instance of the RadSpellDialog class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSpellDialog(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSpellDialog(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSpellDialog.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSpellDialog Class
RadSpellDialog Overload
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog Methods
RadSpellDialog Class See Also Send Feedback

The RadSpellDialog type exposes the following members.

Methods

 | Name | Description
Public method | AddCustomButtonClick | Clicks the add custom button.
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangeAllButtonClick | Clicks the change all button.
Public method | ChangeButtonClick | Clicks the change button.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CloseButtonClick | Clicks the close button.
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | IgnoreAllButtonClick | Clicks the ignore all button.
Public method | IgnoreButtonClick | Clicks the ignore button.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UndoButtonClick | Clicks the undo button.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


AddCustomButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..AddCustomButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the add custom button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void AddCustomButtonClick()
Visual Basic
Public Sub AddCustomButtonClick
Visual C++
public:
void AddCustomButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..AssignElement Method
RadSpellDialog Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..CallMethod Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..Capture Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


ChangeAllButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..ChangeAllButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the change all button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ChangeAllButtonClick()
Visual Basic
Public Sub ChangeAllButtonClick
Visual C++
public:
void ChangeAllButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


ChangeButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..ChangeButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the change button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ChangeButtonClick()
Visual Basic
Public Sub ChangeButtonClick
Visual C++
public:
void ChangeButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..Click Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


CloseButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..CloseButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the close button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CloseButtonClick()
Visual Basic
Public Sub CloseButtonClick
Visual C++
public:
void CloseButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..ControlAssert Method
RadSpellDialog Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..DragTo Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..GetValue Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


IgnoreAllButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..IgnoreAllButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the ignore all button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void IgnoreAllButtonClick()
Visual Basic
Public Sub IgnoreAllButtonClick
Visual C++
public:
void IgnoreAllButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


IgnoreButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..IgnoreButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the ignore button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void IgnoreButtonClick()
Visual Basic
Public Sub IgnoreButtonClick
Visual C++
public:
void IgnoreButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..InvokeEvent Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..MouseClick Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..MouseHover Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..ScrollToVisible Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..SetValue Method
RadSpellDialog Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
RadSpellDialog Members
Telerik.WebAii.Controls.Html Namespace


UndoButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog..::..UndoButtonClick Method
RadSpellDialog Class See Also Send Feedback
Clicks the undo button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UndoButtonClick()
Visual Basic
Public Sub UndoButtonClick
Visual C++
public:
void UndoButtonClick()

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


RadSpellDialog Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSpellDialog Properties
RadSpellDialog Class See Also Send Feedback

The RadSpellDialog type exposes the following members.

Properties

 | Name | Description
Public property | AddCustomButton | Gets spell add custom button.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChangeAllButton | Gets spell change all button.
Public property | ChangeButton | Gets spell change button.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadSpell. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CloseButton | Gets spell close button.
Public property | ControlToCheck | Gets/Sets the ID of the control to spell check..
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentText | Gets the current text in the TextContainer.
Public property | DialogOpenerSkin | Gets/Sets the skinof the DialogOpener.
Public property | DictionaryLanguage | Gets/Sets the dictionary language culture code.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | IgnoreAllButton | Gets spell ignore all button.
Public property | IgnoreButton | Gets spell ignore button.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSpellDialog. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedLanguage | Get the language currently selected in the drop down displayed when the SupportedLanguages language property is set.
Public property | SourceText | Gets/Sets the text of the TextSource object that RadSpell is attached to.
Public property | Spellchecked | Determines whether the spell checking for the target control has been completed. (the OnClientCheckFinished event has been fired).
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UndoButton | Gets spell undo button.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadSpellDialog Class
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar Members
RadSplitBar Class Constructors Methods Properties See Also Send Feedback

The RadSplitBar type exposes the following members.

Constructors

 | Name | Description
Public method | RadSplitBar()()()() | Initializes a new instance of the RadSplitBar class.
Public method | RadSplitBar(Element) | Initializes a new instance of the RadSplitBar class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CollapsePane | Collapses the pane.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandPane | Expands the pane.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Resize | Resizes the previous or the next pane.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BackwardElement | The backward element.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the client-side code that defines the Radsplitter splitbar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Collapsed | Determines whether the previous or next pane is collapsed.
Public property | CollapseMode | Gets/Sets the collapse mode of the splitbar.
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EnabledResize | Determines or set whether the resize is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ForwardElement | The forward element.
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | LeftPaneCollapsed | Determines whether the left pane is collapsed.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSplitter. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NextPaneHeight | Gets/Sets the next pane (right or down) height in pixels.
Public property | NextPaneId | Gets the next pane (right or down) Id.
Public property | NextPaneWidth | Gets/Sets the next pane (right or down) width in pixels.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PreviousPaneHeight | Gets/Sets the previous pane (left or upper) heigh in pixelst.
Public property | PreviousPaneId | Gets the previous pane (left or upper) Id.
Public property | PreviousPaneWidth | Gets/Sets the previous pane (left or upper) width in pixels.
Public property | RightPaneCollapsed | Determines whether the right pane is collapsed.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar Constructor
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadSplitBar()()()() | Initializes a new instance of the RadSplitBar class.
Public method | RadSplitBar(Element) | Initializes a new instance of the RadSplitBar class.

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar Constructor
RadSplitBar Class See Also Send Feedback
Initializes a new instance of the RadSplitBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSplitBar()
Visual Basic
Public Sub New
Visual C++
public:
RadSplitBar()

See Also

RadSplitBar Class
RadSplitBar Overload
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar Constructor (Element)
RadSplitBar Class See Also Send Feedback
Initializes a new instance of the RadSplitBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSplitBar(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSplitBar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSplitBar Class
RadSplitBar Overload
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar Methods
RadSplitBar Class See Also Send Feedback

The RadSplitBar type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | CollapsePane | Collapses the pane.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandPane | Expands the pane.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Resize | Resizes the previous or the next pane.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..AssignElement Method
RadSplitBar Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..CallMethod Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..Capture Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..Click Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


CollapsePane Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..CollapsePane Method
RadSplitBar Class See Also Send Feedback
Collapses the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CollapsePane(
    SplitterPaneType pane
)
Visual Basic
Public Sub CollapsePane ( _
    pane As SplitterPaneType _
)
Visual C++
public:
void CollapsePane(
    SplitterPaneType pane
)

Parameters

pane
Type: Telerik.WebAii.Controls.Html..::..SplitterPaneType

[Missing <param name="pane"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.CollapsePane(Telerik.WebAii.Controls.Html.SplitterPaneType)"]

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..DragTo Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


ExpandPane Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..ExpandPane Method
RadSplitBar Class See Also Send Feedback
Expands the pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ExpandPane(
    SplitterPaneType pane
)
Visual Basic
Public Sub ExpandPane ( _
    pane As SplitterPaneType _
)
Visual C++
public:
void ExpandPane(
    SplitterPaneType pane
)

Parameters

pane
Type: Telerik.WebAii.Controls.Html..::..SplitterPaneType

[Missing <param name="pane"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.ExpandPane(Telerik.WebAii.Controls.Html.SplitterPaneType)"]

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..GetValue Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..InvokeEvent Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..MouseClick Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..MouseHover Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


Resize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..Resize Method
RadSplitBar Class See Also Send Feedback
Resizes the previous or the next pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Resize(
    int previousPaneSize,
    int nextPaneSize,
    SplitterOrientation orientation
)
Visual Basic
Public Sub Resize ( _
    previousPaneSize As Integer, _
    nextPaneSize As Integer, _
    orientation As SplitterOrientation _
)
Visual C++
public:
void Resize(
    int previousPaneSize,
    int nextPaneSize,
    SplitterOrientation orientation
)

Parameters

previousPaneSize
Type: System..::..Int32

[Missing <param name="previousPaneSize"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.Resize(System.Int32,System.Int32,Telerik.WebAii.Controls.Html.SplitterOrientation)"]

nextPaneSize
Type: System..::..Int32

[Missing <param name="nextPaneSize"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.Resize(System.Int32,System.Int32,Telerik.WebAii.Controls.Html.SplitterOrientation)"]

orientation
Type: Telerik.WebAii.Controls.Html..::..SplitterOrientation

[Missing <param name="orientation"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitBar.Resize(System.Int32,System.Int32,Telerik.WebAii.Controls.Html.SplitterOrientation)"]

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..ScrollToVisible Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar..::..SetValue Method
RadSplitBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSplitBar Class
RadSplitBar Members
Telerik.WebAii.Controls.Html Namespace


RadSplitBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitBar Properties
RadSplitBar Class See Also Send Feedback

The RadSplitBar type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BackwardElement | The backward element.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the client-side code that defines the Radsplitter splitbar. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | Collapsed | Determines whether the previous or next pane is collapsed.
Public property | CollapseMode | Gets/Sets the collapse mode of the splitbar.
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EnabledResize | Determines or set whether the resize is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ForwardElement | The forward element.
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | LeftPaneCollapsed | Determines whether the left pane is collapsed.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSplitter. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NextPaneHeight | Gets/Sets the next pane (right or down) height in pixels.
Public property | NextPaneId | Gets the next pane (right or down) Id.
Public property | NextPaneWidth | Gets/Sets the next pane (right or down) width in pixels.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PreviousPaneHeight | Gets/Sets the previous pane (left or upper) heigh in pixelst.
Public property | PreviousPaneId | Gets the previous pane (left or upper) Id.
Public property | PreviousPaneWidth | Gets/Sets the previous pane (left or upper) width in pixels.
Public property | RightPaneCollapsed | Determines whether the right pane is collapsed.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

RadSplitBar Class
Telerik.WebAii.Controls.Html Namespace


RadSplitter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter Members
RadSplitter Class Constructors Methods Properties See Also Send Feedback

The RadSplitter type exposes the following members.

Constructors

 | Name | Description
Public method | RadSplitter()()()() | Initializes a new instance of the RadSplitter class.
Public method | RadSplitter(Element) | Initializes a new instance of the RadSplitter class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadSplitter. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets the height of the splitter.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsNested | Determines whether the splitter is nested in another splitter.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSplitter. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Orientation | The orientation of the splitter.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PaneCount | Gets the number of the splitter panes.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SplitBarCount | Gets the number of the splitter splitbars.
Public property | SplitterId | The splitter's id.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the width of the splitter.

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


RadSplitter Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter Constructor
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadSplitter()()()() | Initializes a new instance of the RadSplitter class.
Public method | RadSplitter(Element) | Initializes a new instance of the RadSplitter class.

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


RadSplitter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter Constructor
RadSplitter Class See Also Send Feedback
Initializes a new instance of the RadSplitter class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSplitter()
Visual Basic
Public Sub New
Visual C++
public:
RadSplitter()

See Also

RadSplitter Class
RadSplitter Overload
Telerik.WebAii.Controls.Html Namespace


RadSplitter Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter Constructor (Element)
RadSplitter Class See Also Send Feedback
Initializes a new instance of the RadSplitter class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadSplitter(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadSplitter(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadSplitter.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadSplitter Class
RadSplitter Overload
Telerik.WebAii.Controls.Html Namespace


RadSplitter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter Methods
RadSplitter Class See Also Send Feedback

The RadSplitter type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..AssignElement Method
RadSplitter Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..CallMethod Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..Capture Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..Click Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..ControlAssert Method
RadSplitter Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..DragTo Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..GetValue Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..InvokeEvent Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..MouseClick Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..MouseHover Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..ScrollToVisible Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter..::..SetValue Method
RadSplitter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadSplitter Class
RadSplitter Members
Telerik.WebAii.Controls.Html Namespace


RadSplitter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadSplitter Properties
RadSplitter Class See Also Send Feedback

The RadSplitter type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadSplitter. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets the height of the splitter.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsNested | Determines whether the splitter is nested in another splitter.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadSplitter. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Orientation | The orientation of the splitter.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PaneCount | Gets the number of the splitter panes.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SplitBarCount | Gets the number of the splitter splitbars.
Public property | SplitterId | The splitter's id.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the width of the splitter.

See Also

RadSplitter Class
Telerik.WebAii.Controls.Html Namespace


RadTab Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab Members
RadTab Class Constructors Methods Properties See Also Send Feedback

The RadTab type exposes the following members.

Constructors

 | Name | Description
Public method | RadTab()()()() | Initializes a new instance of the RadTab class.
Public method | RadTab(Element) | Initializes a new instance of the RadTab class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadTab control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Navigate if NavigateUrl is set, Click otherwise. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindTab | Finds sub-tab by given predicate.
Public method | FindTabByText | Finds sub-tab having given text.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Navigate | Navigate if NavigateUrl is set.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Select the tab.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Unselect | UnSelect the item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get or set whether this tab is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HasChildren | Check whether the item has children.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the tab.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Level | Get the level of the tab.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a menu item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Get or set the navigate url of this tab.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get or set whether this tab is selected.
Public property | ShouldNavigate | Check whether the tab should navigate.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabCount | Returns the tabs collection of the tab.
Public property | Tabs | Returns the tabs collection of the tab.
Public property | TabValue | Get the value set for this tab.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this tab.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the tab is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


RadTab Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab Constructor
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadTab()()()() | Initializes a new instance of the RadTab class.
Public method | RadTab(Element) | Initializes a new instance of the RadTab class.

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


RadTab Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab Constructor
RadTab Class See Also Send Feedback
Initializes a new instance of the RadTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTab()
Visual Basic
Public Sub New
Visual C++
public:
RadTab()

See Also

RadTab Class
RadTab Overload
Telerik.WebAii.Controls.Html Namespace


RadTab Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab Constructor (Element)
RadTab Class See Also Send Feedback
Initializes a new instance of the RadTab class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTab(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTab(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTab.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTab Class
RadTab Overload
Telerik.WebAii.Controls.Html Namespace


RadTab Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab Methods
RadTab Class See Also Send Feedback

The RadTab type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadTab control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Navigate if NavigateUrl is set, Click otherwise. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindTab | Finds sub-tab by given predicate.
Public method | FindTabByText | Finds sub-tab having given text.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Navigate | Navigate if NavigateUrl is set.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Select the tab.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Unselect | UnSelect the item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..AssignElement Method
RadTab Class See Also Send Feedback
Assign the DOM element to be the RadTab control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTab.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..CallMethod Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..Capture Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..Click Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Navigate if NavigateUrl is set, Click otherwise. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..Click Method
RadTab Class See Also Send Feedback
Navigate if NavigateUrl is set, Click otherwise.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadTab Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Click Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..Click Method (Boolean)
RadTab Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click(
    bool isClosing
)
Visual Basic
Public Overrides Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
) override

Parameters

isClosing
Type: System..::..Boolean

[Missing <param name="isClosing"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTab.Click(System.Boolean)"]

See Also

RadTab Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..ControlAssert Method
RadTab Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..DragTo Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


FindTab Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..FindTab Method
RadTab Class See Also Send Feedback
Finds sub-tab by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTab FindTab(
    Predicate<RadTab> predicate
)
Visual Basic
Public Function FindTab ( _
    predicate As Predicate(Of RadTab) _
) As RadTab
Visual C++
public:
RadTab^ FindTab(
    Predicate<RadTab^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadTab >)>)>
The predicate to seacrh for.

Return Value

The sub-tab mathing the search criteria.

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


FindTabByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..FindTabByText Method
RadTab Class See Also Send Feedback
Finds sub-tab having given text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTab FindTabByText(
    string tabText
)
Visual Basic
Public Function FindTabByText ( _
    tabText As String _
) As RadTab
Visual C++
public:
RadTab^ FindTabByText(
    String^ tabText
)

Parameters

tabText
Type: System..::..String
The tab text to search for.

Return Value

Sub-tab having given text.

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..GetValue Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..InvokeEvent Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..MouseClick Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..MouseHover Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Navigate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..Navigate Method
RadTab Class See Also Send Feedback
Navigate if NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Navigate()
Visual Basic
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..ScrollToVisible Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..Select Method
RadTab Class See Also Send Feedback
Select the tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..SetValue Method
RadTab Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTab Class
RadTab Members
Telerik.WebAii.Controls.Html Namespace


Unselect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab..::..Unselect Method
RadTab Class See Also Send Feedback
UnSelect the item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Unselect()
Visual Basic
Public Sub Unselect
Visual C++
public:
void Unselect()

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


RadTab Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTab Properties
RadTab Class See Also Send Feedback

The RadTab type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get or set whether this tab is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HasChildren | Check whether the item has children.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the tab.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Level | Get the level of the tab.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a menu item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Get or set the navigate url of this tab.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get or set whether this tab is selected.
Public property | ShouldNavigate | Check whether the tab should navigate.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TabCount | Returns the tabs collection of the tab.
Public property | Tabs | Returns the tabs collection of the tab.
Public property | TabValue | Get the value set for this tab.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this tab.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Visible | Get whether the tab is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTab Class
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip Members
RadTabStrip Class Constructors Methods Properties See Also Send Feedback

The RadTabStrip type exposes the following members.

Constructors

 | Name | Description
Public method | RadTabStrip()()()() | Initializes a new instance of the RadTabStrip class.
Public method | RadTabStrip(Element) | Initializes a new instance of the RadTabStrip class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the Tabstrip control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disable the TabStrip.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enable the TabStrip.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindTab | Find tab by given predicate.
Public method | FindTabByText | Find tab by given Text.
Public method | FindTabByValue | Find tab by Value.
Public method | FindTabs | Find tabs by given predicate.
Public method | FindTabsByLevel | Get the list of tabs by the given level.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InitializeTabs | Initializes tabs of the RadTabStrip.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllTabs | Get a list of all the tabs.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of this TabStrip control.
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Returns whether the tab strip is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HasMultiPage | Get whether the TabStrip has associated MultiPage.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MultiPageId | The client id of the associated MultiPage control.
Public property | MultiPageSelectedIndex | Get or set the index of the selected MultiPage page view. Returns '-1' if there is no MultiPage associated with the TabStrip.
Public property | MultiPageViewsCount | Get the MultiPage views count or -1 if there is no MultiPage associated with the TabStrip.
Public property | MultiPageVisible | Get or set whether the MultiPage control is visible.
Public property | OrientationType | Tabstrip orientation.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootTabs | Get a list of the TabStrip root tabs.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip Constructor
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadTabStrip()()()() | Initializes a new instance of the RadTabStrip class.
Public method | RadTabStrip(Element) | Initializes a new instance of the RadTabStrip class.

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip Constructor
RadTabStrip Class See Also Send Feedback
Initializes a new instance of the RadTabStrip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTabStrip()
Visual Basic
Public Sub New
Visual C++
public:
RadTabStrip()

See Also

RadTabStrip Class
RadTabStrip Overload
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip Constructor (Element)
RadTabStrip Class See Also Send Feedback
Initializes a new instance of the RadTabStrip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTabStrip(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTabStrip(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTabStrip Class
RadTabStrip Overload
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip Methods
RadTabStrip Class See Also Send Feedback

The RadTabStrip type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the Tabstrip control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disable the TabStrip.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enable the TabStrip.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | FindTab | Find tab by given predicate.
Public method | FindTabByText | Find tab by given Text.
Public method | FindTabByValue | Find tab by Value.
Public method | FindTabs | Find tabs by given predicate.
Public method | FindTabsByLevel | Get the list of tabs by the given level.
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InitializeTabs | Initializes tabs of the RadTabStrip.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..AssignElement Method
RadTabStrip Class See Also Send Feedback
Assign the DOM element to be the Tabstrip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..CallMethod Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..Capture Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..Click Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..ControlAssert Method
RadTabStrip Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..Disable Method
RadTabStrip Class See Also Send Feedback
Disable the TabStrip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..DragTo Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..Enable Method
RadTabStrip Class See Also Send Feedback
Enable the TabStrip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTab Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..FindTab Method
RadTabStrip Class See Also Send Feedback
Find tab by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTab FindTab(
    Predicate<RadTab> predicate
)
Visual Basic
Public Function FindTab ( _
    predicate As Predicate(Of RadTab) _
) As RadTab
Visual C++
public:
RadTab^ FindTab(
    Predicate<RadTab^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadTab >)>)>
The predicate used as a search criteria.

Return Value

The tab found or 'null' if no tab matches the given search criteria.

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTabByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..FindTabByText Method
RadTabStrip Class See Also Send Feedback
Find tab by given Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTab FindTabByText(
    string tabText
)
Visual Basic
Public Function FindTabByText ( _
    tabText As String _
) As RadTab
Visual C++
public:
RadTab^ FindTabByText(
    String^ tabText
)

Parameters

tabText
Type: System..::..String

[Missing <param name="tabText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.FindTabByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.FindTabByText(System.String)"]

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTabByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..FindTabByValue Method
RadTabStrip Class See Also Send Feedback
Find tab by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTab FindTabByValue(
    string tabValue
)
Visual Basic
Public Function FindTabByValue ( _
    tabValue As String _
) As RadTab
Visual C++
public:
RadTab^ FindTabByValue(
    String^ tabValue
)

Parameters

tabValue
Type: System..::..String

[Missing <param name="tabValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.FindTabByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTabStrip.FindTabByValue(System.String)"]

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTabs Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..FindTabs Method
RadTabStrip Class See Also Send Feedback
Find tabs by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadTab> FindTabs(
    Predicate<RadTab> predicate
)
Visual Basic
Public Function FindTabs ( _
    predicate As Predicate(Of RadTab) _
) As IList(Of RadTab)
Visual C++
public:
IList<RadTab^>^ FindTabs(
    Predicate<RadTab^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadTab >)>)>
The predicate used as a search criteria.

Return Value

The list of found tabs or empty list if no tab matches the given search criteria.

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


FindTabsByLevel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..FindTabsByLevel Method
RadTabStrip Class See Also Send Feedback
Get the list of tabs by the given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadTab> FindTabsByLevel(
    int level
)
Visual Basic
Public Function FindTabsByLevel ( _
    level As Integer _
) As IList(Of RadTab)
Visual C++
public:
IList<RadTab^>^ FindTabsByLevel(
    int level
)

Parameters

level
Type: System..::..Int32
The level to search the tabs for.

Return Value

The list of tabs by the given level.

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..GetValue Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


InitializeTabs Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..InitializeTabs Method
RadTabStrip Class See Also Send Feedback
Initializes tabs of the RadTabStrip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void InitializeTabs()
Visual Basic
Public Sub InitializeTabs
Visual C++
public:
void InitializeTabs()

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..InvokeEvent Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..MouseClick Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..MouseHover Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..ScrollToVisible Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip..::..SetValue Method
RadTabStrip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTabStrip Class
RadTabStrip Members
Telerik.WebAii.Controls.Html Namespace


RadTabStrip Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTabStrip Properties
RadTabStrip Class See Also Send Feedback

The RadTabStrip type exposes the following members.

Properties

 | Name | Description
Public property | AllTabs | Get a list of all the tabs.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The client id of this TabStrip control.
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Returns whether the tab strip is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HasMultiPage | Get whether the TabStrip has associated MultiPage.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MultiPageId | The client id of the associated MultiPage control.
Public property | MultiPageSelectedIndex | Get or set the index of the selected MultiPage page view. Returns '-1' if there is no MultiPage associated with the TabStrip.
Public property | MultiPageViewsCount | Get the MultiPage views count or -1 if there is no MultiPage associated with the TabStrip.
Public property | MultiPageVisible | Get or set whether the MultiPage control is visible.
Public property | OrientationType | Tabstrip orientation.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootTabs | Get a list of the TabStrip root tabs.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTabStrip Class
Telerik.WebAii.Controls.Html Namespace


RadTagCloud Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud Members
RadTagCloud Class Constructors Methods Properties See Also Send Feedback

The RadTagCloud type exposes the following members.

Constructors

 | Name | Description
Public method | RadTagCloud()()()() | Initializes a new instance of the RadTagCloud class.
Public method | RadTagCloud(Element) | Initializes a new instance of the RadTagCloud class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the TagCloud control.
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the TagCloud is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets height of the RadTagCloud in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagCloudSort | Get the TagCloud sorting - Not Sorted, Alphabetic Ascending, Alphabetic Descending, Weight Ascending, Weight Descending.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets width of the RadTagCloud in pixels.

See Also

RadTagCloud Class
Telerik.WebAii.Controls.Html Namespace


RadTagCloud Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud Constructor
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadTagCloud()()()() | Initializes a new instance of the RadTagCloud class.
Public method | RadTagCloud(Element) | Initializes a new instance of the RadTagCloud class.

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


RadTagCloud Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud Constructor
RadTagCloud Class See Also Send Feedback
Initializes a new instance of the RadTagCloud class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTagCloud()
Visual Basic
Public Sub New
Visual C++
public:
RadTagCloud()

See Also

RadTagCloud Class
RadTagCloud Overload
Telerik.WebAii.Controls.Html Namespace


RadTagCloud Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud Constructor (Element)
RadTagCloud Class See Also Send Feedback
Initializes a new instance of the RadTagCloud class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTagCloud(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTagCloud(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTagCloud.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTagCloud Class
RadTagCloud Overload
Telerik.WebAii.Controls.Html Namespace


RadTagCloud Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud Methods
RadTagCloud Class See Also Send Feedback

The RadTagCloud type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTagCloud Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..AssignElement Method
RadTagCloud Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadTagCloud Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..CallMethod Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..Capture Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..Click Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..ControlAssert Method
RadTagCloud Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTagCloud Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..DragTo Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..GetValue Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..InvokeEvent Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..MouseClick Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..MouseHover Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..ScrollToVisible Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud..::..SetValue Method
RadTagCloud Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTagCloud Class
RadTagCloud Members
Telerik.WebAii.Controls.Html Namespace


RadTagCloud Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTagCloud Properties
RadTagCloud Class See Also Send Feedback

The RadTagCloud type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the TagCloud control.
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the TagCloud is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets height of the RadTagCloud in pixels.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagCloudSort | Get the TagCloud sorting - Not Sorted, Alphabetic Ascending, Alphabetic Descending, Weight Ascending, Weight Descending.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets width of the RadTagCloud in pixels.

See Also

RadTagCloud Class
Telerik.WebAii.Controls.Html Namespace


RadTextBox Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox Members
RadTextBox Class Constructors Methods Properties See Also Send Feedback

The RadTextBox type exposes the following members.

Constructors

 | Name | Description
Public method | RadTextBox | Initializes a new instance of the RadTextBox class

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides RadInput..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | ButtonClick | TextBox built-in button click. Throws exception if the button is not enabled.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsInPasswordMode | Return whether the TextBox is in password mode.
Public property | IsMultiline | Get whether the text box is in multi-line mode.
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | LabelMessage | Return the TextBox label message.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ShowButton | Return whether the TextBox built-in button is enabled.
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | StrengthIndicator | Get the Span element for the password strength indicator part, when the control is in password mode.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadTextBox Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox Constructor
RadTextBox Class See Also Send Feedback
Initializes a new instance of the RadTextBox class

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTextBox()
Visual Basic
Public Sub New
Visual C++
public:
RadTextBox()

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadTextBox Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox Methods
RadTextBox Class See Also Send Feedback

The RadTextBox type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides RadInput..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Removes focus from the text box, moving it to the next control in the tab order of the page. (Inherited from RadInput.)
Public method | ButtonClick | TextBox built-in button click. Throws exception if the button is not enabled.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Clear | Sets the value of the text box to an empty string. (Inherited from RadInput.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control. (Inherited from RadInput.)
Public method | Disable | Disables the input. (Inherited from RadInput.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the input. (Inherited from RadInput.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Sets focus to the text box so that the user can edit its value. (Inherited from RadInput.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllText | Selects all the text of the input. (Inherited from RadInput.)
Public method | SelectText | Selects the text in the specified range of positions. The first parameter is the start of the range and the second is the end of the range. (Inherited from RadInput.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..AssignElement Method
RadTextBox Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


ButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..ButtonClick Method
RadTextBox Class See Also Send Feedback
TextBox built-in button click. Throws exception if the button is not enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ButtonClick()
Visual Basic
Public Sub ButtonClick
Visual C++
public:
void ButtonClick()

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..CallMethod Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..Capture Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..Click Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..DragTo Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..GetValue Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..InvokeEvent Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..MouseClick Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..MouseHover Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..ScrollToVisible Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..SetValue Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


TypeText Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox..::..TypeText Method
RadTextBox Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeText(String) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32) | Types text into the input. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Boolean) | Types text into the input. KeyHoldTime internally set to 50. (Inherited from RadInput.)
Public method | TypeText(String, Int32, Int32, Boolean) | Types text into the input. (Inherited from RadInput.)

See Also

RadTextBox Class
RadTextBox Members
Telerik.WebAii.Controls.Html Namespace


RadTextBox Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTextBox Properties
RadTextBox Class See Also Send Feedback

The RadTextBox type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoPostBack | Get or set the auto postback enabled value of the input. (Inherited from RadInput.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CaretPosition | Get or set the caret position of the input. (Inherited from RadInput.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the input control. (Inherited from RadInput.)
Public property | ClientSideLocator | Get the Client side locator. (Inherited from RadInput.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DisplayValue | Gets the value of the control as it is formatted when the control does not have focus. (Inherited from RadInput.)
Public property | EditValue | Get the value of the control as it is formatted when the control has focus. (Inherited from RadInput.)
Public property | EmptyMessage | Get or set the message that appears when the value is not set. (Inherited from RadInput.)
Public property | Enabled | Get whether the input is enabled. (Inherited from RadInput.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Protected property | HiddenInput | Gets the hiddent input element of RadInput. (Inherited from RadInput.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputType | Get the Input control type - TextBox, NumericTextBox, DateInput, MaskedTextBox. (Inherited from RadInput.)
Public property | InputValue | Get or set the client-side input value. (Inherited from RadInput.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEmpty | Get whether the input is empty. (Inherited from RadInput.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsFocused | Get whether the input is focused. (Inherited from RadInput.)
Public property | IsInPasswordMode | Return whether the TextBox is in password mode.
Public property | IsMultiline | Get whether the text box is in multi-line mode.
Public property | IsReadOnly | Get whether the input is in read-only mode. (Inherited from RadInput.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsValid | Get whether the input has a valid value. (Inherited from RadInput.)
Public property | LabelMessage | Return the TextBox label message.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Inherited from RadInput.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ShowButton | Return whether the TextBox built-in button is enabled.
Public property | SingleInputRendering | Gets the control input rendering type. (Inherited from RadInput.)
Public property | StrengthIndicator | Get the Span element for the password strength indicator part, when the control is in password mode.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextBoxValue | Gets the string that the user typed into the control. (Inherited from RadInput.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTextBox Class
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker Members
RadTimePicker Class Constructors Methods Properties See Also Send Feedback

The RadTimePicker type exposes the following members.

Constructors

 | Name | Description
Public method | RadTimePicker()()()() | Initializes a new instance of the RadTimePicker class.
Public method | RadTimePicker(Element) | Initializes a new instance of the RadTimePicker class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
Public method | OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
Public property | DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
Public property | DatePopUpButton | The date popup button of the picker. (Inherited from RadPicker.)
Protected property | DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Public property | Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
Public property | IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
Public property | MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker. (Inherited from RadPicker.)
Public property | PickerType | Gets the Picker control type. (Inherited from RadPicker.)
Public property | PopupDirection | Gets the direction in which the popup opens. (Inherited from RadPicker.)
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker. (Inherited from RadPicker.)
Public property | TimeView | Gets the TimeView wrapper of the picker.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker Constructor
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadTimePicker()()()() | Initializes a new instance of the RadTimePicker class.
Public method | RadTimePicker(Element) | Initializes a new instance of the RadTimePicker class.

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker Constructor
RadTimePicker Class See Also Send Feedback
Initializes a new instance of the RadTimePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTimePicker()
Visual Basic
Public Sub New
Visual C++
public:
RadTimePicker()

See Also

RadTimePicker Class
RadTimePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker Constructor (Element)
RadTimePicker Class See Also Send Feedback
Initializes a new instance of the RadTimePicker class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTimePicker(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTimePicker(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTimePicker.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTimePicker Class
RadTimePicker Overload
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker Methods
RadTimePicker Class See Also Send Feedback

The RadTimePicker type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Inherited from RadPicker.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | OpenCalendar | Clicks on the button which opens the calendar. (Inherited from RadPicker.)
Public method | OpenTimeView | Clicks on the button which opens the TimeView. (Inherited from RadPicker.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetSelectedDate | Sets date to the picker. (Inherited from RadPicker.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..CallMethod Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..Capture Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..Click Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..DragTo Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..GetValue Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..InvokeEvent Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..MouseClick Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..MouseHover Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..ScrollToVisible Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker..::..SetValue Method
RadTimePicker Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTimePicker Class
RadTimePicker Members
Telerik.WebAii.Controls.Html Namespace


RadTimePicker Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimePicker Properties
RadTimePicker Class See Also Send Feedback

The RadTimePicker type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the picker. (Inherited from RadPicker.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using. (Inherited from RadPicker.)
Public property | DateInput | Gets the Input part of the picker. (Inherited from RadPicker.)
Public property | DatePopUpButton | The date popup button of the picker. (Inherited from RadPicker.)
Protected property | DateTimePattern | The DateTime pattern. (Inherited from RadPicker.)
Public property | Enabled | Gets or sets whenther the picker is enabled. (Inherited from RadPicker.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FocusedDate | Gets the focused date of the picker. (Inherited from RadPicker.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputTimeFormat | Gets the time format that the input is currently using. (Inherited from RadPicker.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsCalendarPopupVisible | Gets the visibility of the popup calendar. (Inherited from RadPicker.)
Public property | IsEmpty | Check whether the picker is empty. (Inherited from RadPicker.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsTimePopupVisible | Gets the visibility of the TimeView popup. (Inherited from RadPicker.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Inherited from RadPicker.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxDate | Gets the MaxDate of the picker. (Inherited from RadPicker.)
Public property | MinDate | Gets the MinDate of the picker. (Inherited from RadPicker.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | PickerId | The id of the picker. (Inherited from RadPicker.)
Public property | PickerType | Gets the Picker control type. (Inherited from RadPicker.)
Public property | PopupDirection | Gets the direction in which the popup opens. (Inherited from RadPicker.)
Public property | PopupTimeFormat | Gets the TimeFormat that the TimeView is currently using. (Inherited from RadPicker.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedDate | Gets the selected date of the picker. (Inherited from RadPicker.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimePopUpButton | The time popup button of the picker. (Inherited from RadPicker.)
Public property | TimeView | Gets the TimeView wrapper of the picker.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimePicker Class
Telerik.WebAii.Controls.Html Namespace


RadTimeView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView Members
RadTimeView Class Constructors Methods Properties See Also Send Feedback

The RadTimeView type exposes the following members.

Constructors

 | Name | Description
Public method | RadTimeView()()()() | Initializes a new instance of the RadTimeView class.
Public method | RadTimeView(Element) | Initializes a new instance of the RadTimeView class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectTime(DateTime) | Simulates click on a time cell in the TimeView. The cell is identified by the given selected time, the current Culture and TimeFormat.
Public method | SelectTime(String) | Simulates click on a time cell in the TimeView. The cell is identified by the given selected time string that is parsed with the help of the current Culture.
Public method | SelectTime(DateTime, String, String) | Clicks on a time cell in the TimeView.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the TimeView control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimeFormat | Gets the TimeFormat that the TimeView is currently using.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


RadTimeView Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView Constructor
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadTimeView()()()() | Initializes a new instance of the RadTimeView class.
Public method | RadTimeView(Element) | Initializes a new instance of the RadTimeView class.

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


RadTimeView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView Constructor
RadTimeView Class See Also Send Feedback
Initializes a new instance of the RadTimeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTimeView()
Visual Basic
Public Sub New
Visual C++
public:
RadTimeView()

See Also

RadTimeView Class
RadTimeView Overload
Telerik.WebAii.Controls.Html Namespace


RadTimeView Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView Constructor (Element)
RadTimeView Class See Also Send Feedback
Initializes a new instance of the RadTimeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTimeView(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTimeView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTimeView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTimeView Class
RadTimeView Overload
Telerik.WebAii.Controls.Html Namespace


RadTimeView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView Methods
RadTimeView Class See Also Send Feedback

The RadTimeView type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectTime(DateTime) | Simulates click on a time cell in the TimeView. The cell is identified by the given selected time, the current Culture and TimeFormat.
Public method | SelectTime(String) | Simulates click on a time cell in the TimeView. The cell is identified by the given selected time string that is parsed with the help of the current Culture.
Public method | SelectTime(DateTime, String, String) | Clicks on a time cell in the TimeView.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..AssignElement Method
RadTimeView Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..CallMethod Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..Capture Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..Click Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..DragTo Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..GetValue Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..InvokeEvent Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..MouseClick Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..MouseHover Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..ScrollToVisible Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


SelectTime Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..SelectTime Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectTime(DateTime) | Simulates click on a time cell in the TimeView. The cell is identified by the given selected time, the current Culture and TimeFormat.
Public method | SelectTime(String) | Simulates click on a time cell in the TimeView. The cell is identified by the given selected time string that is parsed with the help of the current Culture.
Public method | SelectTime(DateTime, String, String) | Clicks on a time cell in the TimeView.

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


SelectTime Method (DateTime)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..SelectTime Method (DateTime)
RadTimeView Class See Also Send Feedback
Simulates click on a time cell in the TimeView. The cell is identified by the given selected time, the current Culture and TimeFormat.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectTime(
    DateTime selectedTime
)
Visual Basic
Public Sub SelectTime ( _
    selectedTime As DateTime _
)
Visual C++
public:
void SelectTime(
    DateTime selectedTime
)

Parameters

selectedTime
Type: System..::..DateTime
The time to be selected.

See Also

RadTimeView Class
SelectTime Overload
Telerik.WebAii.Controls.Html Namespace


SelectTime Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..SelectTime Method (String)
RadTimeView Class See Also Send Feedback
Simulates click on a time cell in the TimeView. The cell is identified by the given selected time string that is parsed with the help of the current Culture.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectTime(
    string selectedTimeValue
)
Visual Basic
Public Sub SelectTime ( _
    selectedTimeValue As String _
)
Visual C++
public:
void SelectTime(
    String^ selectedTimeValue
)

Parameters

selectedTimeValue
Type: System..::..String
The time to be selected.

See Also

RadTimeView Class
SelectTime Overload
Telerik.WebAii.Controls.Html Namespace


SelectTime Method (DateTime, String, String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..SelectTime Method (DateTime, String, String)
RadTimeView Class See Also Send Feedback
Clicks on a time cell in the TimeView.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectTime(
    DateTime selectedTime,
    string currentCulture,
    string currentTimeFormat
)
Visual Basic
Public Sub SelectTime ( _
    selectedTime As DateTime, _
    currentCulture As String, _
    currentTimeFormat As String _
)
Visual C++
public:
void SelectTime(
    DateTime selectedTime,
    String^ currentCulture,
    String^ currentTimeFormat
)

Parameters

selectedTime
Type: System..::..DateTime
The time to be selected.
currentCulture
Type: System..::..String
The culture whitch the TimeView is currently using.
currentTimeFormat
Type: System..::..String
The time format whitch the TimeView is currently using.

See Also

RadTimeView Class
SelectTime Overload
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView..::..SetValue Method
RadTimeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTimeView Class
RadTimeView Members
Telerik.WebAii.Controls.Html Namespace


RadTimeView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTimeView Properties
RadTimeView Class See Also Send Feedback

The RadTimeView type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the TimeView control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Culture | Gets the culture which the picker is using.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | TimeFormat | Gets the TimeFormat that the TimeView is currently using.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTimeView Class
Telerik.WebAii.Controls.Html Namespace


RadToolBar Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar Members
RadToolBar Class Constructors Methods Properties See Also Send Feedback

The RadToolBar type exposes the following members.

Constructors

 | Name | Description
Public method | RadToolBar()()()() | Initializes a new instance of the RadToolBar class.
Public method | RadToolBar(Element) | Initializes a new instance of the RadToolBar class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBar control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds item by text.
Public method | FindItemByValue | Finds item by value.
Public method | FindItems | Find items by given predicate.
Public method | FindItemsByLevel | Find items by given level.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllItems | Get all the toolbar items.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Orientation | Get or set ToolBar orientation client-side: '0' if the toolbar is horizontal, '1' if it is vertical.
Public property | OrientationType | Get or set the ToolBar Orientation type.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootItems | Get the root items of the toolbar.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


RadToolBar Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar Constructor
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadToolBar()()()() | Initializes a new instance of the RadToolBar class.
Public method | RadToolBar(Element) | Initializes a new instance of the RadToolBar class.

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


RadToolBar Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar Constructor
RadToolBar Class See Also Send Feedback
Initializes a new instance of the RadToolBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBar()
Visual Basic
Public Sub New
Visual C++
public:
RadToolBar()

See Also

RadToolBar Class
RadToolBar Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBar Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar Constructor (Element)
RadToolBar Class See Also Send Feedback
Initializes a new instance of the RadToolBar class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBar(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBar(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBar Class
RadToolBar Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBar Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar Methods
RadToolBar Class See Also Send Feedback

The RadToolBar type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBar control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItem | Find item by given predicate.
Public method | FindItemByText | Finds item by text.
Public method | FindItemByValue | Finds item by value.
Public method | FindItems | Find items by given predicate.
Public method | FindItemsByLevel | Find items by given level.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..AssignElement Method
RadToolBar Class See Also Send Feedback
Assign the DOM element to be the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..CallMethod Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..Capture Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..Click Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..ControlAssert Method
RadToolBar Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..DragTo Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


FindItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..FindItem Method
RadToolBar Class See Also Send Feedback
Find item by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarItem FindItem(
    Predicate<RadToolBarItem> predicate
)
Visual Basic
Public Function FindItem ( _
    predicate As Predicate(Of RadToolBarItem) _
) As RadToolBarItem
Visual C++
public:
RadToolBarItem^ FindItem(
    Predicate<RadToolBarItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadToolBarItem >)>)>
The predicate used as a search criteria.

Return Value

The item found or 'null' if no item matches the given search criteria.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..FindItemByText Method
RadToolBar Class See Also Send Feedback
Finds item by text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarItem FindItemByText(
    string itemText
)
Visual Basic
Public Function FindItemByText ( _
    itemText As String _
) As RadToolBarItem
Visual C++
public:
RadToolBarItem^ FindItemByText(
    String^ itemText
)

Parameters

itemText
Type: System..::..String

[Missing <param name="itemText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.FindItemByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.FindItemByText(System.String)"]

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..FindItemByValue Method
RadToolBar Class See Also Send Feedback
Finds item by value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarItem FindItemByValue(
    string itemValue
)
Visual Basic
Public Function FindItemByValue ( _
    itemValue As String _
) As RadToolBarItem
Visual C++
public:
RadToolBarItem^ FindItemByValue(
    String^ itemValue
)

Parameters

itemValue
Type: System..::..String

[Missing <param name="itemValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.FindItemByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBar.FindItemByValue(System.String)"]

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..FindItems Method
RadToolBar Class See Also Send Feedback
Find items by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadToolBarItem> FindItems(
    Predicate<RadToolBarItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of RadToolBarItem) _
) As IList(Of RadToolBarItem)
Visual C++
public:
IList<RadToolBarItem^>^ FindItems(
    Predicate<RadToolBarItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadToolBarItem >)>)>
The predicate used as a search criteria.

Return Value

The list of items matching the search.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


FindItemsByLevel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..FindItemsByLevel Method
RadToolBar Class See Also Send Feedback
Find items by given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadToolBarItem> FindItemsByLevel(
    int level
)
Visual Basic
Public Function FindItemsByLevel ( _
    level As Integer _
) As IList(Of RadToolBarItem)
Visual C++
public:
IList<RadToolBarItem^>^ FindItemsByLevel(
    int level
)

Parameters

level
Type: System..::..Int32
The level to search for.

Return Value

The list of items matching the search.

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..GetValue Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..InvokeEvent Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..MouseClick Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..MouseHover Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..ScrollToVisible Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar..::..SetValue Method
RadToolBar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBar Class
RadToolBar Members
Telerik.WebAii.Controls.Html Namespace


RadToolBar Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBar Properties
RadToolBar Class See Also Send Feedback

The RadToolBar type exposes the following members.

Properties

 | Name | Description
Public property | AllItems | Get all the toolbar items.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Orientation | Get or set ToolBar orientation client-side: '0' if the toolbar is horizontal, '1' if it is vertical.
Public property | OrientationType | Get or set the ToolBar Orientation type.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootItems | Get the root items of the toolbar.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBar Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton Members
RadToolBarButton Class Constructors Methods Properties See Also Send Feedback

The RadToolBarButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadToolBarButton()()()() | Initializes a new instance of the RadToolBarButton class.
Public method | RadToolBarButton(Element) | Initializes a new instance of the RadToolBarButton class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Check the toolbar item.
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Public method | Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the toolbar item. (Inherited from RadToolBarItem.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UNCheck | UnCheck the toolbar item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllowSelfUNCheck | Gets whether the toolbar item AllowSelfUnCheck property is set.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
Public property | Checked | Get whether the toolbar item is checked.
Public property | CheckOnClick | Get whether the toolbar item CheckOnClick property is set.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Public property | Group | Gets the name of the group to which the item belongs.
Public property | Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
Public property | ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Public property | Level | Get the level of this item. (Inherited from RadToolBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Inherited from RadToolBarItem.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this item. (Inherited from RadToolBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Public property | Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton Constructor
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadToolBarButton()()()() | Initializes a new instance of the RadToolBarButton class.
Public method | RadToolBarButton(Element) | Initializes a new instance of the RadToolBarButton class.

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton Constructor
RadToolBarButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarButton()
Visual Basic
Public Sub New
Visual C++
public:
RadToolBarButton()

See Also

RadToolBarButton Class
RadToolBarButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton Constructor (Element)
RadToolBarButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBarButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarButton Class
RadToolBarButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton Methods
RadToolBarButton Class See Also Send Feedback

The RadToolBarButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Check the toolbar item.
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Public method | Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the toolbar item. (Inherited from RadToolBarItem.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UNCheck | UnCheck the toolbar item.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..AssignElement Method
RadToolBarButton Class See Also Send Feedback
Assign the DOM element to be the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..CallMethod Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..Capture Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..Check Method
RadToolBarButton Class See Also Send Feedback
Check the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Check()
Visual Basic
Public Sub Check
Visual C++
public:
void Check()

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..Click Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..DragTo Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..GetValue Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..InvokeEvent Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..MouseClick Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..MouseHover Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..ScrollToVisible Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..SetValue Method
RadToolBarButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
RadToolBarButton Members
Telerik.WebAii.Controls.Html Namespace


UNCheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton..::..UNCheck Method
RadToolBarButton Class See Also Send Feedback
UnCheck the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UNCheck()
Visual Basic
Public Sub UNCheck
Visual C++
public:
void UNCheck()

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarButton Properties
RadToolBarButton Class See Also Send Feedback

The RadToolBarButton type exposes the following members.

Properties

 | Name | Description
Public property | AllowSelfUNCheck | Gets whether the toolbar item AllowSelfUnCheck property is set.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
Public property | Checked | Get whether the toolbar item is checked.
Public property | CheckOnClick | Get whether the toolbar item CheckOnClick property is set.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Public property | Group | Gets the name of the group to which the item belongs.
Public property | Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
Public property | ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Public property | Level | Get the level of this item. (Inherited from RadToolBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Inherited from RadToolBarItem.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this item. (Inherited from RadToolBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Public property | Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton Members
RadToolBarDropDownButton Class Constructors Methods Properties See Also Send Feedback

The RadToolBarDropDownButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadToolBarDropDownButton()()()() | Initializes a new instance of the RadToolBarDropDownButton class.
Public method | RadToolBarDropDownButton(Element) | Initializes a new instance of the RadToolBarDropDownButton class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Public method | Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the toolbar item. (Inherited from RadToolBarItem.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonCount | Get the button count for the drop down.
Public property | ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DropDownVisible | Get whether the drop down is opened.
Public property | Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Public property | Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
Public property | ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Public property | Level | Get the level of this item. (Inherited from RadToolBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression that defines the pattern for a toolbar drop down button. (Overrides RadToolBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this item. (Inherited from RadToolBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Public property | Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton Constructor
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadToolBarDropDownButton()()()() | Initializes a new instance of the RadToolBarDropDownButton class.
Public method | RadToolBarDropDownButton(Element) | Initializes a new instance of the RadToolBarDropDownButton class.

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton Constructor
RadToolBarDropDownButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarDropDownButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarDropDownButton()
Visual Basic
Public Sub New
Visual C++
public:
RadToolBarDropDownButton()

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton Constructor (Element)
RadToolBarDropDownButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarDropDownButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarDropDownButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBarDropDownButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarDropDownButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton Methods
RadToolBarDropDownButton Class See Also Send Feedback

The RadToolBarDropDownButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Public method | Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the toolbar item. (Inherited from RadToolBarItem.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..AssignElement Method
RadToolBarDropDownButton Class See Also Send Feedback
Assign the DOM element to be the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarDropDownButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..CallMethod Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..Capture Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..Click Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..DragTo Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..GetValue Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..InvokeEvent Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..MouseClick Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..MouseHover Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..ScrollToVisible Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton..::..SetValue Method
RadToolBarDropDownButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
RadToolBarDropDownButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarDropDownButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarDropDownButton Properties
RadToolBarDropDownButton Class See Also Send Feedback

The RadToolBarDropDownButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonCount | Get the button count for the drop down.
Public property | ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DropDownVisible | Get whether the drop down is opened.
Public property | Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Public property | Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
Public property | ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Public property | Level | Get the level of this item. (Inherited from RadToolBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression that defines the pattern for a toolbar drop down button. (Overrides RadToolBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this item. (Inherited from RadToolBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Public property | Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarDropDownButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem Members
RadToolBarItem Class Constructors Methods Properties See Also Send Feedback

The RadToolBarItem type exposes the following members.

Constructors

 | Name | Description
Public method | RadToolBarItem()()()() | Initializes a new instance of the RadToolBarItem class.
Public method | RadToolBarItem(Element) | Initializes a new instance of the RadToolBarItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBarItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the toolbar item.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the toolbar item. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Close the toolbar item(if the item is drop down or split button).
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disables the toolbar item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the toolbar item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the toolbar item. (Overrides HtmlControl..::..Focus()()()().)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the toolbar item.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | Open the toolbar item(if the item is drop down or split button).
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the toolbar item.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonType | Returns the type of the toolbar item(button, split button, drop down button).
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the toolbar item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether the toolbar item is focused.
Public property | Hovered | Get whether the toolbar item is hovered.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the toolbar item.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons.
Public property | ItemValue | Get or set the value set of this item.
Public property | Level | Get the level of this item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the toolbar item.
Public property | Visible | Get whether the toolbar item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem Constructor
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadToolBarItem()()()() | Initializes a new instance of the RadToolBarItem class.
Public method | RadToolBarItem(Element) | Initializes a new instance of the RadToolBarItem class.

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem Constructor
RadToolBarItem Class See Also Send Feedback
Initializes a new instance of the RadToolBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarItem()
Visual Basic
Public Sub New
Visual C++
public:
RadToolBarItem()

See Also

RadToolBarItem Class
RadToolBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem Constructor (Element)
RadToolBarItem Class See Also Send Feedback
Initializes a new instance of the RadToolBarItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBarItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarItem Class
RadToolBarItem Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem Methods
RadToolBarItem Class See Also Send Feedback

The RadToolBarItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBarItem control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the toolbar item.
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the toolbar item. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Close the toolbar item(if the item is drop down or split button).
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disables the toolbar item.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the toolbar item.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the toolbar item. (Overrides HtmlControl..::..Focus()()()().)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the toolbar item.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | Open the toolbar item(if the item is drop down or split button).
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the toolbar item.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..AssignElement Method
RadToolBarItem Class See Also Send Feedback
Assign the DOM element to be the ToolBarItem control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarItem.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Blur Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Blur Method
RadToolBarItem Class See Also Send Feedback
Blur the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Blur()
Visual Basic
Public Sub Blur
Visual C++
public:
void Blur()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..CallMethod Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Capture Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Click Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the toolbar item. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Click Method
RadToolBarItem Class See Also Send Feedback
Click the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadToolBarItem Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Close Method
RadToolBarItem Class See Also Send Feedback
Close the toolbar item(if the item is drop down or split button).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..ControlAssert Method
RadToolBarItem Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Disable Method
RadToolBarItem Class See Also Send Feedback
Disables the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..DragTo Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Enable Method
RadToolBarItem Class See Also Send Feedback
Enables the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


Focus Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Focus Method
RadToolBarItem Class See Also Send Feedback
Focus the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Focus()
Visual Basic
Public Overrides Sub Focus
Visual C++
public:
virtual void Focus() override

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..GetValue Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Hide Method
RadToolBarItem Class See Also Send Feedback
Hide the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..InvokeEvent Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..MouseClick Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..MouseHover Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Open Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Open Method
RadToolBarItem Class See Also Send Feedback
Open the toolbar item(if the item is drop down or split button).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Open()
Visual Basic
Public Sub Open
Visual C++
public:
void Open()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..ScrollToVisible Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..SetValue Method
RadToolBarItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
RadToolBarItem Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem..::..Show Method
RadToolBarItem Class See Also Send Feedback
Show the toolbar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarItem Properties
RadToolBarItem Class See Also Send Feedback

The RadToolBarItem type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonType | Returns the type of the toolbar item(button, split button, drop down button).
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get whether the toolbar item is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether the toolbar item is focused.
Public property | Hovered | Get whether the toolbar item is hovered.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the toolbar item.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons.
Public property | ItemValue | Get or set the value set of this item.
Public property | Level | Get the level of this item.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a toolbar item. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this item.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the toolbar item.
Public property | Visible | Get whether the toolbar item is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarItem Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton Members
RadToolBarSplitButton Class Constructors Methods Properties See Also Send Feedback

The RadToolBarSplitButton type exposes the following members.

Constructors

 | Name | Description
Public method | RadToolBarSplitButton()()()() | Initializes a new instance of the RadToolBarSplitButton class.
Public method | RadToolBarSplitButton(Element) | Initializes a new instance of the RadToolBarSplitButton class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Public method | Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the toolbar item. (Inherited from RadToolBarItem.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonCount | Get the button count of the drop down.
Public property | ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DropDownVisible | Get whether the drop down is opened.
Public property | Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Public property | Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
Public property | ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Public property | Level | Get the level of this item. (Inherited from RadToolBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression that defines the pattern for a toolbar split button. (Overrides RadToolBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this item. (Inherited from RadToolBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Public property | Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton Constructor
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadToolBarSplitButton()()()() | Initializes a new instance of the RadToolBarSplitButton class.
Public method | RadToolBarSplitButton(Element) | Initializes a new instance of the RadToolBarSplitButton class.

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton Constructor
RadToolBarSplitButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarSplitButton()
Visual Basic
Public Sub New
Visual C++
public:
RadToolBarSplitButton()

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton Constructor (Element)
RadToolBarSplitButton Class See Also Send Feedback
Initializes a new instance of the RadToolBarSplitButton class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolBarSplitButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolBarSplitButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarSplitButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Overload
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton Methods
RadToolBarSplitButton Class See Also Send Feedback

The RadToolBarSplitButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the ToolBar control. (Overrides RadToolBarItem..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | Blur | Blur the toolbar item. (Inherited from RadToolBarItem.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Close the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control. (Inherited from RadToolBarItem.)
Public method | Disable | Disables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Enable | Enables the toolbar item. (Inherited from RadToolBarItem.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Focus the toolbar item. (Inherited from RadToolBarItem.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hide the toolbar item. (Inherited from RadToolBarItem.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Open | Open the toolbar item(if the item is drop down or split button). (Inherited from RadToolBarItem.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Show the toolbar item. (Inherited from RadToolBarItem.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..AssignElement Method
RadToolBarSplitButton Class See Also Send Feedback
Assign the DOM element to be the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadToolBarSplitButton.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..CallMethod Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..Capture Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..Click Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the toolbar item. (Inherited from RadToolBarItem.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..DragTo Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..GetValue Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..InvokeEvent Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..MouseClick Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..MouseHover Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..ScrollToVisible Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton..::..SetValue Method
RadToolBarSplitButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
RadToolBarSplitButton Members
Telerik.WebAii.Controls.Html Namespace


RadToolBarSplitButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolBarSplitButton Properties
RadToolBarSplitButton Class See Also Send Feedback

The RadToolBarSplitButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ButtonCount | Get the button count of the drop down.
Public property | ButtonType | Returns the type of the toolbar item(button, split button, drop down button). (Inherited from RadToolBarItem.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Inherited from RadToolBarItem.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DropDownVisible | Get whether the drop down is opened.
Public property | Enabled | Get whether the toolbar item is enabled. (Inherited from RadToolBarItem.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Focused | Get whether the toolbar item is focused. (Inherited from RadToolBarItem.)
Public property | Hovered | Get whether the toolbar item is hovered. (Inherited from RadToolBarItem.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the toolbar item. (Inherited from RadToolBarItem.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Items | The items of the current toolbar item if any. Returns empty list for the toolbar buttons. (Inherited from RadToolBarItem.)
Public property | ItemValue | Get or set the value set of this item. (Inherited from RadToolBarItem.)
Public property | Level | Get the level of this item. (Inherited from RadToolBarItem.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindExpression that defines the pattern for a toolbar split button. (Overrides RadToolBarItem..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Get the text of this item. (Inherited from RadToolBarItem.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the toolbar item. (Inherited from RadToolBarItem.)
Public property | Visible | Get whether the toolbar item is visible. (Inherited from RadToolBarItem.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadToolBarSplitButton Class
Telerik.WebAii.Controls.Html Namespace


RadToolTip Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip Members
RadToolTip Class Constructors Methods Properties See Also Send Feedback

The RadToolTip type exposes the following members.

Constructors

 | Name | Description
Public method | RadToolTip()()()() | Initializes a new instance of the RadToolTip class.
Public method | RadToolTip(Element) | Initializes a new instance of the RadToolTip class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides the ToolTip.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows the ToolTip.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoCloseDelay | Gets/Sets delay in milliseconds for the tooltip when closes automatically.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The RadToolTip client ID.
Public property | ClientSideLocator | Gets the client-side code that defines the RadToolTip. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets ToolTip height in pixels.
Public property | HideDelay | Gets/Sets the delay in milliseconds before the tooltip becomes hidden.
Public property | HideEvent | Gets/Sets ToolTip HideEvent type.
Public property | HideMode | Gets/Sets ToolTip 'Hide' mode.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadToolTipHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Modal | Get\set ToolTip modal mode.
Public property | MouseTrailing | Determines or set whether the tooltip should follow the mouse movement.
Public property | OffsetX | Gets/Sets the horizontal offset relative to its target element.
Public property | OffsetY | Gets/Sets the vertical offset relative to its target element.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RelativeTo | Gets/Sets what element the ToolTip is relative to.
Public property | RelativeToMode | Gets the 'relative to' mode of the ToolTip -- 'Element', 'BrowserWindow', 'Mouse'.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ShowCallout | Determines or set whether the tooltip callout image will be displayed.
Public property | ShowDelay | Gets/Sets delay in milliseconds for the tooltip when appears.
Public property | ShowEvent | Gets/Sets ToolTip ShowEvent type.
Public property | ShowMode | Gets/Sets ToolTip 'Show' mode.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TargetControlId | Gets/Sets the ToolTip target control Id.
Public property | Text | Gets/Sets ToolTip Text.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets ToolTip Title.
Public property | Visible | Determines whether the tooltip is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the ToolTip width in pixels.
Public property | ZIndex | Gets/Sets the ToolTip ZIndex.

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


RadToolTip Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip Constructor
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadToolTip()()()() | Initializes a new instance of the RadToolTip class.
Public method | RadToolTip(Element) | Initializes a new instance of the RadToolTip class.

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


RadToolTip Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip Constructor
RadToolTip Class See Also Send Feedback
Initializes a new instance of the RadToolTip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolTip()
Visual Basic
Public Sub New
Visual C++
public:
RadToolTip()

See Also

RadToolTip Class
RadToolTip Overload
Telerik.WebAii.Controls.Html Namespace


RadToolTip Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip Constructor (Element)
RadToolTip Class See Also Send Feedback
Initializes a new instance of the RadToolTip class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadToolTip(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadToolTip(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The ToolTip table element.

See Also

RadToolTip Class
RadToolTip Overload
Telerik.WebAii.Controls.Html Namespace


RadToolTip Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip Methods
RadToolTip Class See Also Send Feedback

The RadToolTip type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Hide | Hides the ToolTip.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows the ToolTip.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..AssignElement Method
RadToolTip Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..CallMethod Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..Capture Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..Click Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..ControlAssert Method
RadToolTip Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..DragTo Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..GetValue Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


Hide Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..Hide Method
RadToolTip Class See Also Send Feedback
Hides the ToolTip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Hide()
Visual Basic
Public Sub Hide
Visual C++
public:
void Hide()

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..InvokeEvent Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..MouseClick Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..MouseHover Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..ScrollToVisible Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..SetValue Method
RadToolTip Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadToolTip Class
RadToolTip Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip..::..Show Method
RadToolTip Class See Also Send Feedback
Shows the ToolTip.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


RadToolTip Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadToolTip Properties
RadToolTip Class See Also Send Feedback

The RadToolTip type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | AutoCloseDelay | Gets/Sets delay in milliseconds for the tooltip when closes automatically.
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | The RadToolTip client ID.
Public property | ClientSideLocator | Gets the client-side code that defines the RadToolTip. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets ToolTip height in pixels.
Public property | HideDelay | Gets/Sets the delay in milliseconds before the tooltip becomes hidden.
Public property | HideEvent | Gets/Sets ToolTip HideEvent type.
Public property | HideMode | Gets/Sets ToolTip 'Hide' mode.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadToolTipHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Modal | Get\set ToolTip modal mode.
Public property | MouseTrailing | Determines or set whether the tooltip should follow the mouse movement.
Public property | OffsetX | Gets/Sets the horizontal offset relative to its target element.
Public property | OffsetY | Gets/Sets the vertical offset relative to its target element.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RelativeTo | Gets/Sets what element the ToolTip is relative to.
Public property | RelativeToMode | Gets the 'relative to' mode of the ToolTip -- 'Element', 'BrowserWindow', 'Mouse'.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ShowCallout | Determines or set whether the tooltip callout image will be displayed.
Public property | ShowDelay | Gets/Sets delay in milliseconds for the tooltip when appears.
Public property | ShowEvent | Gets/Sets ToolTip ShowEvent type.
Public property | ShowMode | Gets/Sets ToolTip 'Show' mode.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TargetControlId | Gets/Sets the ToolTip target control Id.
Public property | Text | Gets/Sets ToolTip Text.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets ToolTip Title.
Public property | Visible | Determines whether the tooltip is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the ToolTip width in pixels.
Public property | ZIndex | Gets/Sets the ToolTip ZIndex.

See Also

RadToolTip Class
Telerik.WebAii.Controls.Html Namespace


RadTreeList Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList Members
RadTreeList Class Constructors Methods Properties See Also Send Feedback

The RadTreeList type exposes the following members.

Constructors

 | Name | Description
Public method | RadTreeList()()()() | Initializes a new instance of the RadTreeList class.
Public method | RadTreeList(Element) | Initializes a new instance of the RadTreeList class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Gets the list of the data items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllItems | Selects all items.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllowColumnResize | Get whether the column resizing is allowed.
Public property | AllowColumnsReorder | Get whether columns can be reordered server, client-side or both. To be able to reorder columns client-side, the 'ReorderColumnsOnClient' should be enabled as well.
Public property | AllowRowSelection | Gets whether client-side selection is enabled for the TreeList.
Public property | AllowToggleSelection | Gets whether toggle selection is enabled for the TreeList.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the RadTreeList control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | Get or set the current page index of the TreeList.
Public property | DataItems | Get the list of the children data items of the tree.
Public property | EditedItems | Get the list of items that are in edit mode.
Public property | EnableRealTimeResize | Get whether the real-time resizing is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | ExpandedItems | The list of expanded items for the current TableView.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsScrollingEnabled | Get whether the scrolling of the TreeList is enabled.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the TreeList. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pager | Get the TreeList pager control.
Public property | PagerMode | Gets pager mode.
Public property | ReorderColumnsOnClient | Enables the client-side columns reorder if both with the 'AllowColumnsReorder' are on.
Public property | ResizeMode | Gets the resize mode of the TreeList
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndexes | Gets the indexes of the selected items, in the order they were selected.
Public property | SelectedItems | Get the list of selected items.
Public property | Skin | Get the current skin of the TreeList.
Public property | StaticHeadersEnabled | Get whether the static headers of the TreeList are enabled.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeList Class
Telerik.WebAii.Controls.Html Namespace


RadTreeList Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList Constructor
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadTreeList()()()() | Initializes a new instance of the RadTreeList class.
Public method | RadTreeList(Element) | Initializes a new instance of the RadTreeList class.

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


RadTreeList Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList Constructor
RadTreeList Class See Also Send Feedback
Initializes a new instance of the RadTreeList class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeList()
Visual Basic
Public Sub New
Visual C++
public:
RadTreeList()

See Also

RadTreeList Class
RadTreeList Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeList Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList Constructor (Element)
RadTreeList Class See Also Send Feedback
Initializes a new instance of the RadTreeList class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeList(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTreeList(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeList.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeList Class
RadTreeList Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeList Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList Methods
RadTreeList Class See Also Send Feedback

The RadTreeList type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindItems | Gets the list of the data items matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectAllItems | Selects all items.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTreeList Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..AssignElement Method
RadTreeList Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

RadTreeList Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..CallMethod Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..Capture Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..Click Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..ControlAssert Method
RadTreeList Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTreeList Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..DragTo Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


FindItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..FindItems Method
RadTreeList Class See Also Send Feedback
Gets the list of the data items matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<TreeListDataItem> FindItems(
    Predicate<TreeListDataItem> predicate
)
Visual Basic
Public Function FindItems ( _
    predicate As Predicate(Of TreeListDataItem) _
) As IList(Of TreeListDataItem)
Visual C++
public:
IList<TreeListDataItem^>^ FindItems(
    Predicate<TreeListDataItem^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' TreeListDataItem >)>)>
The predicate to search for.

Return Value

The list of the data items matching the given predicate.

See Also

RadTreeList Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..GetValue Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..InvokeEvent Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..MouseClick Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..MouseHover Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..ScrollToVisible Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


SelectAllItems Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..SelectAllItems Method
RadTreeList Class See Also Send Feedback
Selects all items.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectAllItems()
Visual Basic
Public Sub SelectAllItems
Visual C++
public:
void SelectAllItems()

See Also

RadTreeList Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList..::..SetValue Method
RadTreeList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTreeList Class
RadTreeList Members
Telerik.WebAii.Controls.Html Namespace


RadTreeList Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeList Properties
RadTreeList Class See Also Send Feedback

The RadTreeList type exposes the following members.

Properties

 | Name | Description
Public property | AllowColumnResize | Get whether the column resizing is allowed.
Public property | AllowColumnsReorder | Get whether columns can be reordered server, client-side or both. To be able to reorder columns client-side, the 'ReorderColumnsOnClient' should be enabled as well.
Public property | AllowRowSelection | Gets whether client-side selection is enabled for the TreeList.
Public property | AllowToggleSelection | Gets whether toggle selection is enabled for the TreeList.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the RadTreeList control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | Get or set the current page index of the TreeList.
Public property | DataItems | Get the list of the children data items of the tree.
Public property | EditedItems | Get the list of items that are in edit mode.
Public property | EnableRealTimeResize | Get whether the real-time resizing is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | ExpandedItems | The list of expanded items for the current TableView.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | IsScrollingEnabled | Get whether the scrolling of the TreeList is enabled.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam of the TreeList. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Pager | Get the TreeList pager control.
Public property | PagerMode | Gets pager mode.
Public property | ReorderColumnsOnClient | Enables the client-side columns reorder if both with the 'AllowColumnsReorder' are on.
Public property | ResizeMode | Gets the resize mode of the TreeList
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedIndexes | Gets the indexes of the selected items, in the order they were selected.
Public property | SelectedItems | Get the list of selected items.
Public property | Skin | Get the current skin of the TreeList.
Public property | StaticHeadersEnabled | Get whether the static headers of the TreeList are enabled.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeList Class
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode Members
RadTreeNode Class Constructors Methods Properties See Also Send Feedback

The RadTreeNode type exposes the following members.

Constructors

 | Name | Description
Public method | RadTreeNode()()()() | Initializes a new instance of the RadTreeNode class.
Public method | RadTreeNode(Element) | Initializes a new instance of the RadTreeNode class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadTreeNode control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Check the node if it is not already checked.
Public method | Click()()()() | Click the node or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)
Public method | Collapse | Collapse the node if it is not already collapsed.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disables the node.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragAndDropTo(HtmlControl) | Drag and drop the node to the specified control. Drops into the center of the element.
Public method | DragAndDropTo(RadTreeNode) | Drag and drop the node to the specified node.
Public method | DragAndDropWithOffset | Drag and drop the node with the specified x and y offset.
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditNode | Makes node in edit mode.
Public method | Enable | Enables the node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expand the node if it is not already expanded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNode | Find node by given predicate.
Public method | FindNodeByText | Finds node by Text.
Public method | FindNodeByValue | Finds node by Value.
Public method | FindNodes | Get a list of nodes matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Highlight | Highlight the node.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Navigate | Navigate if NavigateUrl is set.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Select the node.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowContextMenu | Show the context menu.
Public method | Toggle | Toggle the expand/collapse of the node.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Uncheck | UnCheck the node if it is checked.
Public method | UNHighlight | Unhighlight the node.
Public method | Unselect | UnSelect the node.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Category | Get or set the category of this node.
Public property | Checkable | Get whether the tree node contains check box so that it can be checked.
Public property | Checked | Get or set whether the node is checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ContextMenuId | Get or set the ID of the context menu.
Public property | ContextMenuShown | Get whether the context menu (if such is set for this node) is shown.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EditInputElement | Get the node edit input element.
Public property | Enabled | Get or set whether the node is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Get or set whether this node is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HasChildren | Check whether the node has children.
Public property | HasContextMenu | True if context menu is available, false otherwise.
Public property | HierarchicalIndex | Get the hierarchical index of the node in the nodes collection of the treeview.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the node in the nodes collection of its parent.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsInEditMode | Get whether the tree node is in edit mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Level | Get the level of the node.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a treeview node. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Get or set the navigate url of this item.
Public property | Nodes | Get the list of child nodes of the treenode.
Public property | NodeValue | Get the value set for this node.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentNode | Get the parent node of this node. Returns 'null' for the root nodes.
Public property | PostBack | Get whether the postback of the node is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get or set whether this node is selected.
Public property | ShouldNavigate | Check whether the item should navigate.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Get or set the target of the node.
Public property | Text | Get or set text of the node.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the node. If a ToolTip is not set, returns 'null'.
Public property | Visible | Get whether this node is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode Constructor
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadTreeNode()()()() | Initializes a new instance of the RadTreeNode class.
Public method | RadTreeNode(Element) | Initializes a new instance of the RadTreeNode class.

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode Constructor
RadTreeNode Class See Also Send Feedback
Initializes a new instance of the RadTreeNode class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode()
Visual Basic
Public Sub New
Visual C++
public:
RadTreeNode()

See Also

RadTreeNode Class
RadTreeNode Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode Constructor (Element)
RadTreeNode Class See Also Send Feedback
Initializes a new instance of the RadTreeNode class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTreeNode(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeNode Class
RadTreeNode Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode Methods
RadTreeNode Class See Also Send Feedback

The RadTreeNode type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the RadTreeNode control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Check | Check the node if it is not already checked.
Public method | Click()()()() | Click the node or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)
Public method | Collapse | Collapse the node if it is not already collapsed.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Disable | Disables the node.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragAndDropTo(HtmlControl) | Drag and drop the node to the specified control. Drops into the center of the element.
Public method | DragAndDropTo(RadTreeNode) | Drag and drop the node to the specified node.
Public method | DragAndDropWithOffset | Drag and drop the node with the specified x and y offset.
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditNode | Makes node in edit mode.
Public method | Enable | Enables the node.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expand the node if it is not already expanded.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNode | Find node by given predicate.
Public method | FindNodeByText | Finds node by Text.
Public method | FindNodeByValue | Finds node by Value.
Public method | FindNodes | Get a list of nodes matching the given predicate.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | Highlight | Highlight the node.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Navigate | Navigate if NavigateUrl is set.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Select the node.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowContextMenu | Show the context menu.
Public method | Toggle | Toggle the expand/collapse of the node.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Uncheck | UnCheck the node if it is checked.
Public method | UNHighlight | Unhighlight the node.
Public method | Unselect | UnSelect the node.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..AssignElement Method
RadTreeNode Class See Also Send Feedback
Assign the DOM element to be the RadTreeNode control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..CallMethod Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Capture Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Check Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Check Method
RadTreeNode Class See Also Send Feedback
Check the node if it is not already checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Check()
Visual Basic
Public Sub Check
Visual C++
public:
void Check()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Click Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Click the node or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click()()()().)
Public method | Click(Boolean) | Click the item or Navigate if the NavigateUrl is set. (Overrides HtmlControl..::..Click(Boolean).)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Click Method
RadTreeNode Class See Also Send Feedback
Click the node or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click()
Visual Basic
Public Overrides Sub Click
Visual C++
public:
virtual void Click() override

See Also

RadTreeNode Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Click Method (Boolean)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Click Method (Boolean)
RadTreeNode Class See Also Send Feedback
Click the item or Navigate if the NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void Click(
    bool isClosing
)
Visual Basic
Public Overrides Sub Click ( _
    isClosing As Boolean _
)
Visual C++
public:
virtual void Click(
    bool isClosing
) override

Parameters

isClosing
Type: System..::..Boolean

[Missing <param name="isClosing"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.Click(System.Boolean)"]

See Also

RadTreeNode Class
Click Overload
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Collapse Method
RadTreeNode Class See Also Send Feedback
Collapse the node if it is not already collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..ControlAssert Method
RadTreeNode Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Disable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Disable Method
RadTreeNode Class See Also Send Feedback
Disables the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Disable()
Visual Basic
Public Sub Disable
Visual C++
public:
void Disable()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


DragAndDropTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..DragAndDropTo Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragAndDropTo(HtmlControl) | Drag and drop the node to the specified control. Drops into the center of the element.
Public method | DragAndDropTo(RadTreeNode) | Drag and drop the node to the specified node.

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


DragAndDropTo Method (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..DragAndDropTo Method (HtmlControl)
RadTreeNode Class See Also Send Feedback
Drag and drop the node to the specified control. Drops into the center of the element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragAndDropTo(
    HtmlControl destination
)
Visual Basic
Public Sub DragAndDropTo ( _
    destination As HtmlControl _
)
Visual C++
public:
void DragAndDropTo(
    HtmlControl^ destination
)

Parameters

destination
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The destination control.

See Also

RadTreeNode Class
DragAndDropTo Overload
Telerik.WebAii.Controls.Html Namespace


DragAndDropTo Method (RadTreeNode)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..DragAndDropTo Method (RadTreeNode)
RadTreeNode Class See Also Send Feedback
Drag and drop the node to the specified node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragAndDropTo(
    RadTreeNode node
)
Visual Basic
Public Sub DragAndDropTo ( _
    node As RadTreeNode _
)
Visual C++
public:
void DragAndDropTo(
    RadTreeNode^ node
)

Parameters

node
Type: Telerik.WebAii.Controls.Html..::..RadTreeNode
The target node to drop to.

See Also

RadTreeNode Class
DragAndDropTo Overload
Telerik.WebAii.Controls.Html Namespace


DragAndDropWithOffset Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..DragAndDropWithOffset Method
RadTreeNode Class See Also Send Feedback
Drag and drop the node with the specified x and y offset.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DragAndDropWithOffset(
    int offsetX,
    int offsetY
)
Visual Basic
Public Sub DragAndDropWithOffset ( _
    offsetX As Integer, _
    offsetY As Integer _
)
Visual C++
public:
void DragAndDropWithOffset(
    int offsetX,
    int offsetY
)

Parameters

offsetX
Type: System..::..Int32

[Missing <param name="offsetX"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.DragAndDropWithOffset(System.Int32,System.Int32)"]

offsetY
Type: System..::..Int32

[Missing <param name="offsetY"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.DragAndDropWithOffset(System.Int32,System.Int32)"]

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..DragTo Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


EditNode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..EditNode Method
RadTreeNode Class See Also Send Feedback
Makes node in edit mode.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void EditNode()
Visual Basic
Public Sub EditNode
Visual C++
public:
void EditNode()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Enable Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Enable Method
RadTreeNode Class See Also Send Feedback
Enables the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Expand Method
RadTreeNode Class See Also Send Feedback
Expand the node if it is not already expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


FindNode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..FindNode Method
RadTreeNode Class See Also Send Feedback
Find node by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode FindNode(
    Predicate<RadTreeNode> predicate
)
Visual Basic
Public Function FindNode ( _
    predicate As Predicate(Of RadTreeNode) _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNode(
    Predicate<RadTreeNode^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadTreeNode >)>)>
The predicate used as search criteria, i.e. "node => node.NodeText == myNodeText".

Return Value

The node matching the given criteria or null if nothing matches the search.

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..FindNodeByText Method
RadTreeNode Class See Also Send Feedback
Finds node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode FindNodeByText(
    string nodeText
)
Visual Basic
Public Function FindNodeByText ( _
    nodeText As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.FindNodeByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.FindNodeByText(System.String)"]

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..FindNodeByValue Method
RadTreeNode Class See Also Send Feedback
Finds node by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode FindNodeByValue(
    string nodeValue
)
Visual Basic
Public Function FindNodeByValue ( _
    nodeValue As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByValue(
    String^ nodeValue
)

Parameters

nodeValue
Type: System..::..String

[Missing <param name="nodeValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.FindNodeByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeNode.FindNodeByValue(System.String)"]

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


FindNodes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..FindNodes Method
RadTreeNode Class See Also Send Feedback
Get a list of nodes matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadTreeNode> FindNodes(
    Predicate<RadTreeNode> predicate
)
Visual Basic
Public Function FindNodes ( _
    predicate As Predicate(Of RadTreeNode) _
) As IList(Of RadTreeNode)
Visual C++
public:
IList<RadTreeNode^>^ FindNodes(
    Predicate<RadTreeNode^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadTreeNode >)>)>
The predicate, i.e. (node => node.NodeText == myText).

Return Value

The nodes matching the given predicate.

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..GetValue Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Highlight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Highlight Method
RadTreeNode Class See Also Send Feedback
Highlight the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Highlight()
Visual Basic
Public Sub Highlight
Visual C++
public:
void Highlight()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..InvokeEvent Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..MouseClick Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..MouseHover Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Navigate Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Navigate Method
RadTreeNode Class See Also Send Feedback
Navigate if NavigateUrl is set.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Navigate()
Visual Basic
Public Sub Navigate
Visual C++
public:
void Navigate()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..ScrollToVisible Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Select Method
RadTreeNode Class See Also Send Feedback
Select the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..SetValue Method
RadTreeNode Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTreeNode Class
RadTreeNode Members
Telerik.WebAii.Controls.Html Namespace


ShowContextMenu Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..ShowContextMenu Method
RadTreeNode Class See Also Send Feedback
Show the context menu.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowContextMenu()
Visual Basic
Public Sub ShowContextMenu
Visual C++
public:
void ShowContextMenu()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Toggle Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Toggle Method
RadTreeNode Class See Also Send Feedback
Toggle the expand/collapse of the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Toggle()
Visual Basic
Public Sub Toggle
Visual C++
public:
void Toggle()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Uncheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Uncheck Method
RadTreeNode Class See Also Send Feedback
UnCheck the node if it is checked.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Uncheck()
Visual Basic
Public Sub Uncheck
Visual C++
public:
void Uncheck()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


UNHighlight Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..UNHighlight Method
RadTreeNode Class See Also Send Feedback
Unhighlight the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UNHighlight()
Visual Basic
Public Sub UNHighlight
Visual C++
public:
void UNHighlight()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


Unselect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode..::..Unselect Method
RadTreeNode Class See Also Send Feedback
UnSelect the node.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Unselect()
Visual Basic
Public Sub Unselect
Visual C++
public:
void Unselect()

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


RadTreeNode Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeNode Properties
RadTreeNode Class See Also Send Feedback

The RadTreeNode type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Category | Get or set the category of this node.
Public property | Checkable | Get whether the tree node contains check box so that it can be checked.
Public property | Checked | Get or set whether the node is checked.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ContextMenuId | Get or set the ID of the context menu.
Public property | ContextMenuShown | Get whether the context menu (if such is set for this node) is shown.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | EditInputElement | Get the node edit input element.
Public property | Enabled | Get or set whether the node is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Get or set whether this node is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | HasChildren | Check whether the node has children.
Public property | HasContextMenu | True if context menu is available, false otherwise.
Public property | HierarchicalIndex | Get the hierarchical index of the node in the nodes collection of the treeview.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Get the index of the node in the nodes collection of its parent.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsInEditMode | Get whether the tree node is in edit mode.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Level | Get the level of the node.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a treeview node. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NavigateUrl | Get or set the navigate url of this item.
Public property | Nodes | Get the list of child nodes of the treenode.
Public property | NodeValue | Get the value set for this node.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentNode | Get the parent node of this node. Returns 'null' for the root nodes.
Public property | PostBack | Get whether the postback of the node is enabled.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get or set whether this node is selected.
Public property | ShouldNavigate | Check whether the item should navigate.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Target | Get or set the target of the node.
Public property | Text | Get or set text of the node.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | ToolTip | Get or set the tooltip of the node. If a ToolTip is not set, returns 'null'.
Public property | Visible | Get whether this node is visible.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeNode Class
Telerik.WebAii.Controls.Html Namespace


RadTreeView Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView Members
RadTreeView Class Constructors Methods Properties See Also Send Feedback

The RadTreeView type exposes the following members.

Constructors

 | Name | Description
Public method | RadTreeView()()()() | Initializes a new instance of the RadTreeView class.
Public method | RadTreeView(Element) | Initializes a new instance of the RadTreeView class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the radTreeView control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | CheckNodeByText | Check node by Text.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickNodeByText | Click node by Text.
Public method | CollapseNodeByText | Collapse node by Text.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditNodeByText | Edit node by Text.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandNodeByText | Expand node by Text.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNode | Find node by given predicate.
Public method | FindNodeByHierarchicalIndex | Finds node by hierarchical index.
Public method | FindNodeByText | Finds node by Text.
Public method | FindNodeByValue | Finds node by Value.
Public method | FindNodeHierarchicalIndexByText | Finds node hierarchical index by Text.
Public method | FindNodeHierarchicalIndexByValue | Finds node hierarchical index by Value.
Public method | FindNodes | Get a list of nodes matching the given predicate.
Public method | FindNodesByLevel | Get a list of nodes matching the given level.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InitializeNodes | Initializes the RadTreeView nodes.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NavigateNodeByText | Navigate node by Text.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectNodeByText | Select node by Text.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowContextMenuForNode | Show context menu for node with Text.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UnCheckNodeByText | UnCheck node by Text.
Public method | UnselectAllNodes | UnSelect all nodes.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AllNodes | Gets a list of all nodes.
Public property | AllowedNodeEditing | Get or set whether the node editing is allowed.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CheckBoxesEnabled | Get whether the TreeView check box support is enabled.
Public property | CheckedNodes | Gets a list of the checked nodes.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get or set whether the node is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootNodes | Gets a list of root nodes of the treeview.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedNodes | Gets a list of the selected nodes.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


RadTreeView Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView Constructor
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadTreeView()()()() | Initializes a new instance of the RadTreeView class.
Public method | RadTreeView(Element) | Initializes a new instance of the RadTreeView class.

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


RadTreeView Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView Constructor
RadTreeView Class See Also Send Feedback
Initializes a new instance of the RadTreeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeView()
Visual Basic
Public Sub New
Visual C++
public:
RadTreeView()

See Also

RadTreeView Class
RadTreeView Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeView Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView Constructor (Element)
RadTreeView Class See Also Send Feedback
Initializes a new instance of the RadTreeView class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeView(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadTreeView(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeView Class
RadTreeView Overload
Telerik.WebAii.Controls.Html Namespace


RadTreeView Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView Methods
RadTreeView Class See Also Send Feedback

The RadTreeView type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the radTreeView control. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | CheckNodeByText | Check node by Text.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClickNodeByText | Click node by Text.
Public method | CollapseNodeByText | Collapse node by Text.
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditNodeByText | Edit node by Text.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandNodeByText | Expand node by Text.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindNode | Find node by given predicate.
Public method | FindNodeByHierarchicalIndex | Finds node by hierarchical index.
Public method | FindNodeByText | Finds node by Text.
Public method | FindNodeByValue | Finds node by Value.
Public method | FindNodeHierarchicalIndexByText | Finds node hierarchical index by Text.
Public method | FindNodeHierarchicalIndexByValue | Finds node hierarchical index by Value.
Public method | FindNodes | Get a list of nodes matching the given predicate.
Public method | FindNodesByLevel | Get a list of nodes matching the given level.
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InitializeNodes | Initializes the RadTreeView nodes.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | NavigateNodeByText | Navigate node by Text.
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SelectNodeByText | Select node by Text.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ShowContextMenuForNode | Show context menu for node with Text.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | UnCheckNodeByText | UnCheck node by Text.
Public method | UnselectAllNodes | UnSelect all nodes.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..AssignElement Method
RadTreeView Class See Also Send Feedback
Assign the DOM element to be the radTreeView control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..CallMethod Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..Capture Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


CheckNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..CheckNodeByText Method
RadTreeView Class See Also Send Feedback
Check node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CheckNodeByText(
    string nodeText
)
Visual Basic
Public Sub CheckNodeByText ( _
    nodeText As String _
)
Visual C++
public:
void CheckNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.CheckNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..Click Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


ClickNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..ClickNodeByText Method
RadTreeView Class See Also Send Feedback
Click node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClickNodeByText(
    string nodeText
)
Visual Basic
Public Sub ClickNodeByText ( _
    nodeText As String _
)
Visual C++
public:
void ClickNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.ClickNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


CollapseNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..CollapseNodeByText Method
RadTreeView Class See Also Send Feedback
Collapse node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CollapseNodeByText(
    string nodeText
)
Visual Basic
Public Sub CollapseNodeByText ( _
    nodeText As String _
)
Visual C++
public:
void CollapseNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.CollapseNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..ControlAssert Method
RadTreeView Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..DragTo Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


EditNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..EditNodeByText Method
RadTreeView Class See Also Send Feedback
Edit node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void EditNodeByText(
    string nodeText
)
Visual Basic
Public Sub EditNodeByText ( _
    nodeText As String _
)
Visual C++
public:
void EditNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.EditNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


ExpandNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..ExpandNodeByText Method
RadTreeView Class See Also Send Feedback
Expand node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ExpandNodeByText(
    string nodeText
)
Visual Basic
Public Sub ExpandNodeByText ( _
    nodeText As String _
)
Visual C++
public:
void ExpandNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.ExpandNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..FindNode Method
RadTreeView Class See Also Send Feedback
Find node by given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode FindNode(
    Predicate<RadTreeNode> predicate
)
Visual Basic
Public Function FindNode ( _
    predicate As Predicate(Of RadTreeNode) _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNode(
    Predicate<RadTreeNode^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadTreeNode >)>)>
The predicate used as search criteria, i.e. "node => node.NodeText == myNodeText".

Return Value

The node matching the given criteria or null if nothing matches the search.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByHierarchicalIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..FindNodeByHierarchicalIndex Method
RadTreeView Class See Also Send Feedback
Finds node by hierarchical index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode FindNodeByHierarchicalIndex(
    string hierarchicalIndex
)
Visual Basic
Public Function FindNodeByHierarchicalIndex ( _
    hierarchicalIndex As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByHierarchicalIndex(
    String^ hierarchicalIndex
)

Parameters

hierarchicalIndex
Type: System..::..String

[Missing <param name="hierarchicalIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByHierarchicalIndex(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByHierarchicalIndex(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..FindNodeByText Method
RadTreeView Class See Also Send Feedback
Finds node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode FindNodeByText(
    string nodeText
)
Visual Basic
Public Function FindNodeByText ( _
    nodeText As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodeByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..FindNodeByValue Method
RadTreeView Class See Also Send Feedback
Finds node by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadTreeNode FindNodeByValue(
    string nodeValue
)
Visual Basic
Public Function FindNodeByValue ( _
    nodeValue As String _
) As RadTreeNode
Visual C++
public:
RadTreeNode^ FindNodeByValue(
    String^ nodeValue
)

Parameters

nodeValue
Type: System..::..String

[Missing <param name="nodeValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeByValue(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodeHierarchicalIndexByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..FindNodeHierarchicalIndexByText Method
RadTreeView Class See Also Send Feedback
Finds node hierarchical index by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public string FindNodeHierarchicalIndexByText(
    string nodeText
)
Visual Basic
Public Function FindNodeHierarchicalIndexByText ( _
    nodeText As String _
) As String
Visual C++
public:
String^ FindNodeHierarchicalIndexByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeHierarchicalIndexByText(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeHierarchicalIndexByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodeHierarchicalIndexByValue Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..FindNodeHierarchicalIndexByValue Method
RadTreeView Class See Also Send Feedback
Finds node hierarchical index by Value.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public string FindNodeHierarchicalIndexByValue(
    string nodeValue
)
Visual Basic
Public Function FindNodeHierarchicalIndexByValue ( _
    nodeValue As String _
) As String
Visual C++
public:
String^ FindNodeHierarchicalIndexByValue(
    String^ nodeValue
)

Parameters

nodeValue
Type: System..::..String

[Missing <param name="nodeValue"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeHierarchicalIndexByValue(System.String)"]

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.FindNodeHierarchicalIndexByValue(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..FindNodes Method
RadTreeView Class See Also Send Feedback
Get a list of nodes matching the given predicate.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadTreeNode> FindNodes(
    Predicate<RadTreeNode> predicate
)
Visual Basic
Public Function FindNodes ( _
    predicate As Predicate(Of RadTreeNode) _
) As IList(Of RadTreeNode)
Visual C++
public:
IList<RadTreeNode^>^ FindNodes(
    Predicate<RadTreeNode^>^ predicate
)

Parameters

predicate
Type: System..::..Predicate <(Of <(<' RadTreeNode >)>)>
The predicate, i.e. (node => node.NodeText == myText).

Return Value

The nodes matching the given predicate.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


FindNodesByLevel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..FindNodesByLevel Method
RadTreeView Class See Also Send Feedback
Get a list of nodes matching the given level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public IList<RadTreeNode> FindNodesByLevel(
    int level
)
Visual Basic
Public Function FindNodesByLevel ( _
    level As Integer _
) As IList(Of RadTreeNode)
Visual C++
public:
IList<RadTreeNode^>^ FindNodesByLevel(
    int level
)

Parameters

level
Type: System..::..Int32
The level to search for.

Return Value

The list of nodes matching the given level.

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..GetValue Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


InitializeNodes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..InitializeNodes Method
RadTreeView Class See Also Send Feedback
Initializes the RadTreeView nodes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void InitializeNodes()
Visual Basic
Public Sub InitializeNodes
Visual C++
public:
void InitializeNodes()

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..InvokeEvent Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..MouseClick Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..MouseHover Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


NavigateNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..NavigateNodeByText Method
RadTreeView Class See Also Send Feedback
Navigate node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void NavigateNodeByText(
    string nodeText
)
Visual Basic
Public Sub NavigateNodeByText ( _
    nodeText As String _
)
Visual C++
public:
void NavigateNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.NavigateNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..ScrollToVisible Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


SelectNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..SelectNodeByText Method
RadTreeView Class See Also Send Feedback
Select node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SelectNodeByText(
    string nodeText
)
Visual Basic
Public Sub SelectNodeByText ( _
    nodeText As String _
)
Visual C++
public:
void SelectNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.SelectNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..SetValue Method
RadTreeView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadTreeView Class
RadTreeView Members
Telerik.WebAii.Controls.Html Namespace


ShowContextMenuForNode Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..ShowContextMenuForNode Method
RadTreeView Class See Also Send Feedback
Show context menu for node with Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ShowContextMenuForNode(
    string nodeText
)
Visual Basic
Public Sub ShowContextMenuForNode ( _
    nodeText As String _
)
Visual C++
public:
void ShowContextMenuForNode(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.ShowContextMenuForNode(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


UnCheckNodeByText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..UnCheckNodeByText Method
RadTreeView Class See Also Send Feedback
UnCheck node by Text.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UnCheckNodeByText(
    string nodeText
)
Visual Basic
Public Sub UnCheckNodeByText ( _
    nodeText As String _
)
Visual C++
public:
void UnCheckNodeByText(
    String^ nodeText
)

Parameters

nodeText
Type: System..::..String

[Missing <param name="nodeText"/> documentation for "M:Telerik.WebAii.Controls.Html.RadTreeView.UnCheckNodeByText(System.String)"]

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


UnselectAllNodes Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView..::..UnselectAllNodes Method
RadTreeView Class See Also Send Feedback
UnSelect all nodes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void UnselectAllNodes()
Visual Basic
Public Sub UnselectAllNodes
Visual C++
public:
void UnselectAllNodes()

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


RadTreeView Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadTreeView Properties
RadTreeView Class See Also Send Feedback

The RadTreeView type exposes the following members.

Properties

 | Name | Description
Public property | AllNodes | Gets a list of all nodes.
Public property | AllowedNodeEditing | Get or set whether the node editing is allowed.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CheckBoxesEnabled | Get whether the TreeView check box support is enabled.
Public property | CheckedNodes | Gets a list of the checked nodes.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Enabled | Get or set whether the node is enabled.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RootNodes | Gets a list of root nodes of the treeview.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectedNodes | Gets a list of the selected nodes.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadTreeView Class
Telerik.WebAii.Controls.Html Namespace


RadUpload Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload Members
RadUpload Class Constructors Methods Properties See Also Send Feedback

The RadUpload type exposes the following members.

Constructors

 | Name | Description
Public method | RadUpload()()()() | Initializes a new instance of the RadUpload class.
Public method | RadUpload(Element) | Initializes a new instance of the RadUpload class.

Methods

 | Name | Description
Public method | AddButtonClick | Clicks the add button.
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | CheckBoxCheck | Checks the checkbox.
Public method | ClearButtonClick | Clicks the clear button.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | DeleteButtonClick | Clicks the delete button.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileSelect | Selects the file by specifid index.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeLocator | Initialize the RadUpload locator.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveButtonClick | Clicks the remove button.
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetText | Sets the text into the specified file index.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | AddButton | Returns upload add button.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClearButton | Returns upload clear button.
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteButton | Returns upload delete button.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FileExtensions | Returns an array containing the allowed file extensions.
Public property | FileExtensionsString | Returns a string containing the allowed file extensions.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InitialFileInputCount | Returns the initial number of rows when the RadUpload control is first loaded..
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputFileCheckBox | Returns file upload checkbox.
Public property | InputFiles | Returns upload input file controls.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a RadUploadHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxFileCount | Get or set the maximum number of rows in the RadUpload control.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RemoveButton | Returns upload remove button.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectButton | Returns upload select button.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


RadUpload Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload Constructor
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadUpload()()()() | Initializes a new instance of the RadUpload class.
Public method | RadUpload(Element) | Initializes a new instance of the RadUpload class.

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


RadUpload Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload Constructor
RadUpload Class See Also Send Feedback
Initializes a new instance of the RadUpload class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadUpload()
Visual Basic
Public Sub New
Visual C++
public:
RadUpload()

See Also

RadUpload Class
RadUpload Overload
Telerik.WebAii.Controls.Html Namespace


RadUpload Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload Constructor (Element)
RadUpload Class See Also Send Feedback
Initializes a new instance of the RadUpload class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadUpload(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadUpload(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadUpload.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadUpload Class
RadUpload Overload
Telerik.WebAii.Controls.Html Namespace


RadUpload Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload Methods
RadUpload Class See Also Send Feedback

The RadUpload type exposes the following members.

Methods

 | Name | Description
Public method | AddButtonClick | Clicks the add button.
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | CheckBoxCheck | Checks the checkbox.
Public method | ClearButtonClick | Clicks the clear button.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Get RadControlAssert instance initialized for this control.
Public method | DeleteButtonClick | Clicks the delete button.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileSelect | Selects the file by specifid index.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Protected method | InitializeLocator | Initialize the RadUpload locator.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveButtonClick | Clicks the remove button.
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetText | Sets the text into the specified file index.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


AddButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..AddButtonClick Method
RadUpload Class See Also Send Feedback
Clicks the add button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void AddButtonClick()
Visual Basic
Public Sub AddButtonClick
Visual C++
public:
void AddButtonClick()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..AssignElement Method
RadUpload Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..CallMethod Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..Capture Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


CheckBoxCheck Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..CheckBoxCheck Method
RadUpload Class See Also Send Feedback
Checks the checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void CheckBoxCheck()
Visual Basic
Public Sub CheckBoxCheck
Visual C++
public:
void CheckBoxCheck()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


ClearButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..ClearButtonClick Method
RadUpload Class See Also Send Feedback
Clicks the clear button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClearButtonClick()
Visual Basic
Public Sub ClearButtonClick
Visual C++
public:
void ClearButtonClick()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..Click Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..ControlAssert Method
RadUpload Class See Also Send Feedback
Get RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


DeleteButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..DeleteButtonClick Method
RadUpload Class See Also Send Feedback
Clicks the delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void DeleteButtonClick()
Visual Basic
Public Sub DeleteButtonClick
Visual C++
public:
void DeleteButtonClick()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..DragTo Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


FileSelect Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..FileSelect Method
RadUpload Class See Also Send Feedback
Selects the file by specifid index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void FileSelect(
    int index
)
Visual Basic
Public Sub FileSelect ( _
    index As Integer _
)
Visual C++
public:
void FileSelect(
    int index
)

Parameters

index
Type: System..::..Int32

[Missing <param name="index"/> documentation for "M:Telerik.WebAii.Controls.Html.RadUpload.FileSelect(System.Int32)"]

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..GetValue Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


InitializeLocator Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..InitializeLocator Method
RadUpload Class See Also Send Feedback
Initialize the RadUpload locator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
protected virtual HtmlFindExpression InitializeLocator()
Visual Basic
Protected Overridable Function InitializeLocator As HtmlFindExpression
Visual C++
protected:
virtual HtmlFindExpression^ InitializeLocator()

Return Value

[Missing <returns> documentation for "M:Telerik.WebAii.Controls.Html.RadUpload.InitializeLocator"]

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..InvokeEvent Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..MouseClick Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..MouseHover Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


RemoveButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..RemoveButtonClick Method
RadUpload Class See Also Send Feedback
Clicks the remove button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void RemoveButtonClick()
Visual Basic
Public Sub RemoveButtonClick
Visual C++
public:
void RemoveButtonClick()

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..ScrollToVisible Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


SetText Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..SetText Method
RadUpload Class See Also Send Feedback
Sets the text into the specified file index.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void SetText(
    int fileIndex,
    string text
)
Visual Basic
Public Sub SetText ( _
    fileIndex As Integer, _
    text As String _
)
Visual C++
public:
void SetText(
    int fileIndex,
    String^ text
)

Parameters

fileIndex
Type: System..::..Int32

[Missing <param name="fileIndex"/> documentation for "M:Telerik.WebAii.Controls.Html.RadUpload.SetText(System.Int32,System.String)"]

text
Type: System..::..String

[Missing <param name="text"/> documentation for "M:Telerik.WebAii.Controls.Html.RadUpload.SetText(System.Int32,System.String)"]

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload..::..SetValue Method
RadUpload Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadUpload Class
RadUpload Members
Telerik.WebAii.Controls.Html Namespace


RadUpload Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadUpload Properties
RadUpload Class See Also Send Feedback

The RadUpload type exposes the following members.

Properties

 | Name | Description
Public property | AddButton | Returns upload add button.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClearButton | Returns upload clear button.
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DeleteButton | Returns upload delete button.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | FileExtensions | Returns an array containing the allowed file extensions.
Public property | FileExtensionsString | Returns a string containing the allowed file extensions.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InitialFileInputCount | Returns the initial number of rows when the RadUpload control is first loaded..
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | InputFileCheckBox | Returns file upload checkbox.
Public property | InputFiles | Returns upload input file controls.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for a RadUploadHtmlControl. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | MaxFileCount | Get or set the maximum number of rows in the RadUpload control.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RemoveButton | Returns upload remove button.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SelectButton | Returns upload select button.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadUpload Class
Telerik.WebAii.Controls.Html Namespace


RadWindow Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow Members
RadWindow Class Constructors Methods Properties See Also Send Feedback

The RadWindow type exposes the following members.

Constructors

 | Name | Description
Public method | RadWindow()()()() | Initializes a new instance of the RadWindow class.
Public method | RadWindow(Element) | Initializes a new instance of the RadWindow class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Closes RadWindow.
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | Maximize | Maximizes RadWindow.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimize | Minimizes/Restores the RadWindow.
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MoveTo | Moves RadWindow to specific coordinates(correct setting of Left and Top is only for Window without restriction zone).
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | Reload | Reloads RadWindow.
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Resize | Resizes RadWindow.
Public method | Restore | Restores RadWindow.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows RadWindow.
Public method | TogglePin | Toggles pin RadWindow.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadWindow. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets the height of the Window.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActive | Determines whether the Window is active.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsClosed | Determines whether the Window is closed.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsMaximized | Determines whether the Window is maximized.
Public property | IsMinimized | Determines whether the Window is minimized.
Public property | IsModal | Determines whether the Window is modal.
Public property | IsPinned | Determines whether the Window is pinned.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Left | Gets/Sets the left of the Window(correct setting of Left is only for Window without restriction zone).
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadWindow. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RestrictionZoneId | Gets/Sets the Id of the Window's restriction zone.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Status | Gets/Sets RadWindow status.
Public property | StatusInputValue | Gets/Sets the value of status input.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets current RadWindow title.
Public property | Top | Gets/Sets the top of the Window(correct setting of Top is only for Window without restriction zone).
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the width of the Window.
Public property | WindowId | The Window's id.

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


RadWindow Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow Constructor
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadWindow()()()() | Initializes a new instance of the RadWindow class.
Public method | RadWindow(Element) | Initializes a new instance of the RadWindow class.

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


RadWindow Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow Constructor
RadWindow Class See Also Send Feedback
Initializes a new instance of the RadWindow class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadWindow()
Visual Basic
Public Sub New
Visual C++
public:
RadWindow()

See Also

RadWindow Class
RadWindow Overload
Telerik.WebAii.Controls.Html Namespace


RadWindow Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow Constructor (Element)
RadWindow Class See Also Send Feedback
Initializes a new instance of the RadWindow class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadWindow(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadWindow(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadWindow Class
RadWindow Overload
Telerik.WebAii.Controls.Html Namespace


RadWindow Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow Methods
RadWindow Class See Also Send Feedback

The RadWindow type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Close | Closes RadWindow.
Public method | ControlAssert | Gets RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | Maximize | Maximizes RadWindow.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Minimize | Minimizes/Restores the RadWindow.
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MoveTo | Moves RadWindow to specific coordinates(correct setting of Left and Top is only for Window without restriction zone).
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | Reload | Reloads RadWindow.
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Resize | Resizes RadWindow.
Public method | Restore | Restores RadWindow.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Show | Shows RadWindow.
Public method | TogglePin | Toggles pin RadWindow.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..AssignElement Method
RadWindow Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..CallMethod Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Capture Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Click Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Close Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Close Method
RadWindow Class See Also Send Feedback
Closes RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..ControlAssert Method
RadWindow Class See Also Send Feedback
Gets RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..DragTo Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..GetValue Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..InvokeEvent Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Maximize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Maximize Method
RadWindow Class See Also Send Feedback
Maximizes RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Maximize()
Visual Basic
Public Sub Maximize
Visual C++
public:
void Maximize()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Minimize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Minimize Method
RadWindow Class See Also Send Feedback
Minimizes/Restores the RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Minimize()
Visual Basic
Public Sub Minimize
Visual C++
public:
void Minimize()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..MouseClick Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..MouseHover Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


MoveTo Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..MoveTo Method
RadWindow Class See Also Send Feedback
Moves RadWindow to specific coordinates(correct setting of Left and Top is only for Window without restriction zone).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void MoveTo(
    int left,
    int top
)
Visual Basic
Public Sub MoveTo ( _
    left As Integer, _
    top As Integer _
)
Visual C++
public:
void MoveTo(
    int left,
    int top
)

Parameters

left
Type: System..::..Int32

[Missing <param name="left"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.MoveTo(System.Int32,System.Int32)"]

top
Type: System..::..Int32

[Missing <param name="top"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.MoveTo(System.Int32,System.Int32)"]

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Reload Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Reload Method
RadWindow Class See Also Send Feedback
Reloads RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Reload()
Visual Basic
Public Sub Reload
Visual C++
public:
void Reload()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Resize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Resize Method
RadWindow Class See Also Send Feedback
Resizes RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Resize(
    int width,
    int height
)
Visual Basic
Public Sub Resize ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
void Resize(
    int width,
    int height
)

Parameters

width
Type: System..::..Int32

[Missing <param name="width"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.Resize(System.Int32,System.Int32)"]

height
Type: System..::..Int32

[Missing <param name="height"/> documentation for "M:Telerik.WebAii.Controls.Html.RadWindow.Resize(System.Int32,System.Int32)"]

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


Restore Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Restore Method
RadWindow Class See Also Send Feedback
Restores RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Restore()
Visual Basic
Public Sub Restore
Visual C++
public:
void Restore()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..ScrollToVisible Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..SetValue Method
RadWindow Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadWindow Class
RadWindow Members
Telerik.WebAii.Controls.Html Namespace


Show Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..Show Method
RadWindow Class See Also Send Feedback
Shows RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Show()
Visual Basic
Public Sub Show
Visual C++
public:
void Show()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


TogglePin Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow..::..TogglePin Method
RadWindow Class See Also Send Feedback
Toggles pin RadWindow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void TogglePin()
Visual Basic
Public Sub TogglePin
Visual C++
public:
void TogglePin()

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


RadWindow Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadWindow Properties
RadWindow Class See Also Send Feedback

The RadWindow type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side code that defines the RadWindow. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets/Sets the height of the Window.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActive | Determines whether the Window is active.
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsClosed | Determines whether the Window is closed.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsMaximized | Determines whether the Window is maximized.
Public property | IsMinimized | Determines whether the Window is minimized.
Public property | IsModal | Determines whether the Window is modal.
Public property | IsPinned | Determines whether the Window is pinned.
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Left | Gets/Sets the left of the Window(correct setting of Left is only for Window without restriction zone).
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for a RadWindow. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RestrictionZoneId | Gets/Sets the Id of the Window's restriction zone.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Status | Gets/Sets RadWindow status.
Public property | StatusInputValue | Gets/Sets the value of status input.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Title | Gets/Sets current RadWindow title.
Public property | Top | Gets/Sets the top of the Window(correct setting of Top is only for Window without restriction zone).
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets/Sets the width of the Window.
Public property | WindowId | The Window's id.

See Also

RadWindow Class
Telerik.WebAii.Controls.Html Namespace


RadXmlHttpPanel Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel Members
RadXmlHttpPanel Class Constructors Methods Properties See Also Send Feedback

The RadXmlHttpPanel type exposes the following members.

Constructors

 | Name | Description
Public method | RadXmlHttpPanel()()()() | Initializes a new instance of the RadXmlHttpPanel class.
Public method | RadXmlHttpPanel(Element) | Initializes a new instance of the RadXmlHttpPanel class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlContainerControl.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the XmlHttpPanel control.
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DomElement | Gets the DOM element of this control.
Public property | DomElementClass | Gets the DOM element class for this control.
Public property | DomElementStyle | Gets the DOM element style for this control.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Html | Get/Sets the XmlHttpPanel Html.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get/Sets the XmlHttpPanel value that is passed to the RadXmlHttpPanel.
Public property | Visible | Get whether the XmlHttpPanel is enabled.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
Telerik.WebAii.Controls.Html Namespace


RadXmlHttpPanel Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel Constructor
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RadXmlHttpPanel()()()() | Initializes a new instance of the RadXmlHttpPanel class.
Public method | RadXmlHttpPanel(Element) | Initializes a new instance of the RadXmlHttpPanel class.

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


RadXmlHttpPanel Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel Constructor
RadXmlHttpPanel Class See Also Send Feedback
Initializes a new instance of the RadXmlHttpPanel class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadXmlHttpPanel()
Visual Basic
Public Sub New
Visual C++
public:
RadXmlHttpPanel()

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Overload
Telerik.WebAii.Controls.Html Namespace


RadXmlHttpPanel Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel Constructor (Element)
RadXmlHttpPanel Class See Also Send Feedback
Initializes a new instance of the RadXmlHttpPanel class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadXmlHttpPanel(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
RadXmlHttpPanel(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.RadXmlHttpPanel.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Overload
Telerik.WebAii.Controls.Html Namespace


RadXmlHttpPanel Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel Methods
RadXmlHttpPanel Class See Also Send Feedback

The RadXmlHttpPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Inherited from HtmlContainerControl.)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

RadXmlHttpPanel Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..CallMethod Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..Capture Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..Click Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..ControlAssert Method
RadXmlHttpPanel Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

RadXmlHttpPanel Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..DragTo Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..GetValue Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..InvokeEvent Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..MouseClick Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..MouseHover Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..ScrollToVisible Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel..::..SetValue Method
RadXmlHttpPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
RadXmlHttpPanel Members
Telerik.WebAii.Controls.Html Namespace


RadXmlHttpPanel Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RadXmlHttpPanel Properties
RadXmlHttpPanel Class See Also Send Feedback

The RadXmlHttpPanel type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientId | Get the client Id of the XmlHttpPanel control.
Public property | ClientSideLocator | Get the Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | DomElement | Gets the DOM element of this control.
Public property | DomElementClass | Gets the DOM element class for this control.
Public property | DomElementStyle | Gets the DOM element style for this control.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Html | Get/Sets the XmlHttpPanel Html.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Value | Get/Sets the XmlHttpPanel value that is passed to the RadXmlHttpPanel.
Public property | Visible | Get whether the XmlHttpPanel is enabled.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

RadXmlHttpPanel Class
Telerik.WebAii.Controls.Html Namespace


RatingConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingConstants Members
RatingConstants Class Fields See Also Send Feedback

The RatingConstants type exposes the following members.

Fields

Name | Description
CssRating | The CSS class identifying the RadRating control.
KeyRating | The Rating key used accross the verifications and action messages.

See Also

RatingConstants Class
Telerik.WebAii.Controls.Html Namespace


RatingConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingConstants Fields
RatingConstants Class See Also Send Feedback

The RatingConstants type exposes the following members.

Fields

Name | Description
CssRating | The CSS class identifying the RadRating control.
KeyRating | The Rating key used accross the verifications and action messages.

See Also

RatingConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRating Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingConstants..::..CssRating Field
RatingConstants Class See Also Send Feedback
The CSS class identifying the RadRating control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRating
Visual Basic
Public Const CssRating As String
Visual C++
public:
literal String^ CssRating

See Also

RatingConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyRating Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RatingConstants..::..KeyRating Field
RatingConstants Class See Also Send Feedback
The Rating key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyRating
Visual Basic
Public Const KeyRating As String
Visual C++
public:
literal String^ KeyRating

See Also

RatingConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants Members
RibbonBarConstants Class Fields See Also Send Feedback

The RibbonBarConstants type exposes the following members.

Fields

Name | Description
CssButtonDiv | The RibbonBarButton div css key used across the source classes.
CssButtonStripAnchor | The RibbonBarButtonStripButton anchor element css key used across the source classes.
CssContextualTab |
CssCustomizeQATButton |
CssCustomizeQATMenuItem | The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu item.
CssCustomizeQATMenuItemChecked | The CSS class identifying checked state of the RibbonBar "Customize Quick Access Toolbar" menu item
CssCustomizeQATMenuSlide | The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu slide element.
CssCustomizeQATMenuULElement | The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu ul element.
CssItemExpanded | The RibbonBarItemExpanded css key used across the source classes.
CssMenuDiv | The RibbonBarMenu div css key used across the source classes.
CssQuickAccessToobar | The CSS class identifying RibbonBar quick access toolbar ul element.
CssQuickAccessToobarItem | The CSS class identifying RibbonBar quick access toolbar item element.
CssRibbobbarApplicationTab | The RibbonBar application tab element css key used across the source classes.
CssRibbobbarApplicationTabText | The RibbonBar application tab text element css key used across the source classes.
CssRibbobbarContentWrapIn | The CSS class identifying RibbonBar content wrap div.
CssRibbobbarElementUniversal | The RibbonBar universal css key used across the source classes.
CssRibbonBarButton | The RibbonBarButton link element css key used across the source classes.
CssRibbonBarButtonIn | The RibbonBarButton inner span element css key used across the source classes.
CssRibbonBarButtonMid | The RibbonBarButton middle span element css key used across the source classes.
CssRibbonBarButtonOut | The RibbonBarButton link element css key used across the source classes.
CssRibbonBarButtonText | The RibbonBarButton text span element css key used across the source classes.
CssRibbonBarGroup | The RibbonBarGroup css key used accross the verifications and action messages.
CssRibbonBarGroupIn | The RibbonBarGroupIn css key used accross the verifications and action messages.
CssRibbonBarMenuMid | The RibbonBarMenu span element key used across the source classes.
CssRibbonBarSplitButtonMid | The RibbonBarSplitButton span element css key used across the source classes.
CssRibbonBarTab | The RibbonBarTab css key used across the source classes.
CssRibbonBarTabStrip | The RibbonBarTabStrip css key used across the source classes.
CssRibbonBarToggleButtonMid | The RibbonBarToggleButton span element css key used across the source classes.
CssTabAnchor | The RibbonBarTabAnchor css key used across the source classes.
CssTabSelected | The RibbonBarTab selected css key used across the source classes.
RibbonBar | The RibbonBar key used across the source classes.
RibbonBarApplicationTabKey | The RibbonBarApplicationTab key used accross the verifications and action messages.
RibbonBarButtonKey | The RibbonBarButton key used accross the verifications and action messages.
RibbonBarContextTabGroup | The RibbonBarContextTabGroup key used accross the verifications and action messages.
RibbonBarDropDownItemKey | The RibbonBarDropDown key used accross the verifications and action messages.
RibbonBarGroupKey | The RibbonBarGroup key used accross the verifications and action messages.
RibbonBarItemKey | The RibbonBarItem key used across the source classes.
RibbonBarMenuKey | The RibbonBarMenu key used accross the verifications and action messages.
RibbonBarQATMenuItem | The RibbonBarQATMenuItem key used accross the verifications and action messages.
RibbonBarSplitButtonKey | The RibbonBarSplitButton key used accross the verifications and action messages.
RibbonBarTabKey | The RibbonBarTab key used accross the verifications and action messages.
RibbonBarToggleButtonKey | The RibbonBarToggleButton key used accross the verifications and action messages.

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants Fields
RibbonBarConstants Class See Also Send Feedback

The RibbonBarConstants type exposes the following members.

Fields

Name | Description
CssButtonDiv | The RibbonBarButton div css key used across the source classes.
CssButtonStripAnchor | The RibbonBarButtonStripButton anchor element css key used across the source classes.
CssContextualTab |
CssCustomizeQATButton |
CssCustomizeQATMenuItem | The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu item.
CssCustomizeQATMenuItemChecked | The CSS class identifying checked state of the RibbonBar "Customize Quick Access Toolbar" menu item
CssCustomizeQATMenuSlide | The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu slide element.
CssCustomizeQATMenuULElement | The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu ul element.
CssItemExpanded | The RibbonBarItemExpanded css key used across the source classes.
CssMenuDiv | The RibbonBarMenu div css key used across the source classes.
CssQuickAccessToobar | The CSS class identifying RibbonBar quick access toolbar ul element.
CssQuickAccessToobarItem | The CSS class identifying RibbonBar quick access toolbar item element.
CssRibbobbarApplicationTab | The RibbonBar application tab element css key used across the source classes.
CssRibbobbarApplicationTabText | The RibbonBar application tab text element css key used across the source classes.
CssRibbobbarContentWrapIn | The CSS class identifying RibbonBar content wrap div.
CssRibbobbarElementUniversal | The RibbonBar universal css key used across the source classes.
CssRibbonBarButton | The RibbonBarButton link element css key used across the source classes.
CssRibbonBarButtonIn | The RibbonBarButton inner span element css key used across the source classes.
CssRibbonBarButtonMid | The RibbonBarButton middle span element css key used across the source classes.
CssRibbonBarButtonOut | The RibbonBarButton link element css key used across the source classes.
CssRibbonBarButtonText | The RibbonBarButton text span element css key used across the source classes.
CssRibbonBarGroup | The RibbonBarGroup css key used accross the verifications and action messages.
CssRibbonBarGroupIn | The RibbonBarGroupIn css key used accross the verifications and action messages.
CssRibbonBarMenuMid | The RibbonBarMenu span element key used across the source classes.
CssRibbonBarSplitButtonMid | The RibbonBarSplitButton span element css key used across the source classes.
CssRibbonBarTab | The RibbonBarTab css key used across the source classes.
CssRibbonBarTabStrip | The RibbonBarTabStrip css key used across the source classes.
CssRibbonBarToggleButtonMid | The RibbonBarToggleButton span element css key used across the source classes.
CssTabAnchor | The RibbonBarTabAnchor css key used across the source classes.
CssTabSelected | The RibbonBarTab selected css key used across the source classes.
RibbonBar | The RibbonBar key used across the source classes.
RibbonBarApplicationTabKey | The RibbonBarApplicationTab key used accross the verifications and action messages.
RibbonBarButtonKey | The RibbonBarButton key used accross the verifications and action messages.
RibbonBarContextTabGroup | The RibbonBarContextTabGroup key used accross the verifications and action messages.
RibbonBarDropDownItemKey | The RibbonBarDropDown key used accross the verifications and action messages.
RibbonBarGroupKey | The RibbonBarGroup key used accross the verifications and action messages.
RibbonBarItemKey | The RibbonBarItem key used across the source classes.
RibbonBarMenuKey | The RibbonBarMenu key used accross the verifications and action messages.
RibbonBarQATMenuItem | The RibbonBarQATMenuItem key used accross the verifications and action messages.
RibbonBarSplitButtonKey | The RibbonBarSplitButton key used accross the verifications and action messages.
RibbonBarTabKey | The RibbonBarTab key used accross the verifications and action messages.
RibbonBarToggleButtonKey | The RibbonBarToggleButton key used accross the verifications and action messages.

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssButtonDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssButtonDiv Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarButton div css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssButtonDiv
Visual Basic
Public Const CssButtonDiv As String
Visual C++
public:
literal String^ CssButtonDiv

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssButtonStripAnchor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssButtonStripAnchor Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarButtonStripButton anchor element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssButtonStripAnchor
Visual Basic
Public Const CssButtonStripAnchor As String
Visual C++
public:
literal String^ CssButtonStripAnchor

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssContextualTab Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssContextualTab Field
RibbonBarConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.WebAii.Controls.Html.RibbonBarConstants.CssContextualTab"]

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssContextualTab
Visual Basic
Public Const CssContextualTab As String
Visual C++
public:
literal String^ CssContextualTab

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCustomizeQATButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssCustomizeQATButton Field
RibbonBarConstants Class See Also Send Feedback

[Missing <summary> documentation for "F:Telerik.WebAii.Controls.Html.RibbonBarConstants.CssCustomizeQATButton"]

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCustomizeQATButton
Visual Basic
Public Const CssCustomizeQATButton As String
Visual C++
public:
literal String^ CssCustomizeQATButton

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCustomizeQATMenuItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssCustomizeQATMenuItem Field
RibbonBarConstants Class See Also Send Feedback
The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCustomizeQATMenuItem
Visual Basic
Public Const CssCustomizeQATMenuItem As String
Visual C++
public:
literal String^ CssCustomizeQATMenuItem

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCustomizeQATMenuItemChecked Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssCustomizeQATMenuItemChecked Field
RibbonBarConstants Class See Also Send Feedback
The CSS class identifying checked state of the RibbonBar "Customize Quick Access Toolbar" menu item

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCustomizeQATMenuItemChecked
Visual Basic
Public Const CssCustomizeQATMenuItemChecked As String
Visual C++
public:
literal String^ CssCustomizeQATMenuItemChecked

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCustomizeQATMenuSlide Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssCustomizeQATMenuSlide Field
RibbonBarConstants Class See Also Send Feedback
The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu slide element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCustomizeQATMenuSlide
Visual Basic
Public Const CssCustomizeQATMenuSlide As String
Visual C++
public:
literal String^ CssCustomizeQATMenuSlide

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCustomizeQATMenuULElement Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssCustomizeQATMenuULElement Field
RibbonBarConstants Class See Also Send Feedback
The CSS class identifying RibbonBar "Customize Quick Access Toolbar" menu ul element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCustomizeQATMenuULElement
Visual Basic
Public Const CssCustomizeQATMenuULElement As String
Visual C++
public:
literal String^ CssCustomizeQATMenuULElement

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssItemExpanded Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssItemExpanded Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarItemExpanded css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssItemExpanded
Visual Basic
Public Const CssItemExpanded As String
Visual C++
public:
literal String^ CssItemExpanded

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMenuDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssMenuDiv Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarMenu div css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMenuDiv
Visual Basic
Public Const CssMenuDiv As String
Visual C++
public:
literal String^ CssMenuDiv

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssQuickAccessToobar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssQuickAccessToobar Field
RibbonBarConstants Class See Also Send Feedback
The CSS class identifying RibbonBar quick access toolbar ul element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssQuickAccessToobar
Visual Basic
Public Const CssQuickAccessToobar As String
Visual C++
public:
literal String^ CssQuickAccessToobar

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssQuickAccessToobarItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssQuickAccessToobarItem Field
RibbonBarConstants Class See Also Send Feedback
The CSS class identifying RibbonBar quick access toolbar item element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssQuickAccessToobarItem
Visual Basic
Public Const CssQuickAccessToobarItem As String
Visual C++
public:
literal String^ CssQuickAccessToobarItem

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbobbarApplicationTab Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbobbarApplicationTab Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBar application tab element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbobbarApplicationTab
Visual Basic
Public Const CssRibbobbarApplicationTab As String
Visual C++
public:
literal String^ CssRibbobbarApplicationTab

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbobbarApplicationTabText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbobbarApplicationTabText Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBar application tab text element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbobbarApplicationTabText
Visual Basic
Public Const CssRibbobbarApplicationTabText As String
Visual C++
public:
literal String^ CssRibbobbarApplicationTabText

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbobbarContentWrapIn Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbobbarContentWrapIn Field
RibbonBarConstants Class See Also Send Feedback
The CSS class identifying RibbonBar content wrap div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbobbarContentWrapIn
Visual Basic
Public Const CssRibbobbarContentWrapIn As String
Visual C++
public:
literal String^ CssRibbobbarContentWrapIn

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbobbarElementUniversal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbobbarElementUniversal Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBar universal css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbobbarElementUniversal
Visual Basic
Public Const CssRibbobbarElementUniversal As String
Visual C++
public:
literal String^ CssRibbobbarElementUniversal

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarButton Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarButton link element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarButton
Visual Basic
Public Const CssRibbonBarButton As String
Visual C++
public:
literal String^ CssRibbonBarButton

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarButtonIn Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarButtonIn Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarButton inner span element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarButtonIn
Visual Basic
Public Const CssRibbonBarButtonIn As String
Visual C++
public:
literal String^ CssRibbonBarButtonIn

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarButtonMid Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarButtonMid Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarButton middle span element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarButtonMid
Visual Basic
Public Const CssRibbonBarButtonMid As String
Visual C++
public:
literal String^ CssRibbonBarButtonMid

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarButtonOut Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarButtonOut Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarButton link element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarButtonOut
Visual Basic
Public Const CssRibbonBarButtonOut As String
Visual C++
public:
literal String^ CssRibbonBarButtonOut

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarButtonText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarButtonText Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarButton text span element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarButtonText
Visual Basic
Public Const CssRibbonBarButtonText As String
Visual C++
public:
literal String^ CssRibbonBarButtonText

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarGroup Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarGroup Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarGroup css key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarGroup
Visual Basic
Public Const CssRibbonBarGroup As String
Visual C++
public:
literal String^ CssRibbonBarGroup

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarGroupIn Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarGroupIn Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarGroupIn css key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarGroupIn
Visual Basic
Public Const CssRibbonBarGroupIn As String
Visual C++
public:
literal String^ CssRibbonBarGroupIn

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarMenuMid Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarMenuMid Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarMenu span element key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarMenuMid
Visual Basic
Public Const CssRibbonBarMenuMid As String
Visual C++
public:
literal String^ CssRibbonBarMenuMid

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarSplitButtonMid Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarSplitButtonMid Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarSplitButton span element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarSplitButtonMid
Visual Basic
Public Const CssRibbonBarSplitButtonMid As String
Visual C++
public:
literal String^ CssRibbonBarSplitButtonMid

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarTab Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarTab Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarTab css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarTab
Visual Basic
Public Const CssRibbonBarTab As String
Visual C++
public:
literal String^ CssRibbonBarTab

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarTabStrip Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarTabStrip Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarTabStrip css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarTabStrip
Visual Basic
Public Const CssRibbonBarTabStrip As String
Visual C++
public:
literal String^ CssRibbonBarTabStrip

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRibbonBarToggleButtonMid Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssRibbonBarToggleButtonMid Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarToggleButton span element css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRibbonBarToggleButtonMid
Visual Basic
Public Const CssRibbonBarToggleButtonMid As String
Visual C++
public:
literal String^ CssRibbonBarToggleButtonMid

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTabAnchor Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssTabAnchor Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarTabAnchor css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTabAnchor
Visual Basic
Public Const CssTabAnchor As String
Visual C++
public:
literal String^ CssTabAnchor

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTabSelected Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..CssTabSelected Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarTab selected css key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTabSelected
Visual Basic
Public Const CssTabSelected As String
Visual C++
public:
literal String^ CssTabSelected

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBar Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBar key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBar
Visual Basic
Public Const RibbonBar As String
Visual C++
public:
literal String^ RibbonBar

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarApplicationTabKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarApplicationTabKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarApplicationTab key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarApplicationTabKey
Visual Basic
Public Const RibbonBarApplicationTabKey As String
Visual C++
public:
literal String^ RibbonBarApplicationTabKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarButtonKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarButtonKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarButton key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarButtonKey
Visual Basic
Public Const RibbonBarButtonKey As String
Visual C++
public:
literal String^ RibbonBarButtonKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarContextTabGroup Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarContextTabGroup Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarContextTabGroup key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarContextTabGroup
Visual Basic
Public Const RibbonBarContextTabGroup As String
Visual C++
public:
literal String^ RibbonBarContextTabGroup

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarDropDownItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarDropDownItemKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarDropDown key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarDropDownItemKey
Visual Basic
Public Const RibbonBarDropDownItemKey As String
Visual C++
public:
literal String^ RibbonBarDropDownItemKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarGroupKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarGroupKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarGroup key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarGroupKey
Visual Basic
Public Const RibbonBarGroupKey As String
Visual C++
public:
literal String^ RibbonBarGroupKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarItemKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarItemKey
Visual Basic
Public Const RibbonBarItemKey As String
Visual C++
public:
literal String^ RibbonBarItemKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarMenuKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarMenuKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarMenu key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarMenuKey
Visual Basic
Public Const RibbonBarMenuKey As String
Visual C++
public:
literal String^ RibbonBarMenuKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarQATMenuItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarQATMenuItem Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarQATMenuItem key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarQATMenuItem
Visual Basic
Public Const RibbonBarQATMenuItem As String
Visual C++
public:
literal String^ RibbonBarQATMenuItem

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarSplitButtonKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarSplitButtonKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarSplitButton key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarSplitButtonKey
Visual Basic
Public Const RibbonBarSplitButtonKey As String
Visual C++
public:
literal String^ RibbonBarSplitButtonKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarTabKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarTabKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarTab key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarTabKey
Visual Basic
Public Const RibbonBarTabKey As String
Visual C++
public:
literal String^ RibbonBarTabKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RibbonBarToggleButtonKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RibbonBarConstants..::..RibbonBarToggleButtonKey Field
RibbonBarConstants Class See Also Send Feedback
The RibbonBarToggleButton key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string RibbonBarToggleButtonKey
Visual Basic
Public Const RibbonBarToggleButtonKey As String
Visual C++
public:
literal String^ RibbonBarToggleButtonKey

See Also

RibbonBarConstants Class
Telerik.WebAii.Controls.Html Namespace


RotatorConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotatorConstants Members
RotatorConstants Class Fields See Also Send Feedback

The RotatorConstants type exposes the following members.

Fields

Name | Description
CssButtons | The CSS class unique part of the Rotator scrolling buttons.
CssRotatorDiv | The CSS class unique part of the Rotator outer div element.
KeyRotator | The constant used as a key for the rotator level.

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


RotatorConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotatorConstants Fields
RotatorConstants Class See Also Send Feedback

The RotatorConstants type exposes the following members.

Fields

Name | Description
CssButtons | The CSS class unique part of the Rotator scrolling buttons.
CssRotatorDiv | The CSS class unique part of the Rotator outer div element.
KeyRotator | The constant used as a key for the rotator level.

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssButtons Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotatorConstants..::..CssButtons Field
RotatorConstants Class See Also Send Feedback
The CSS class unique part of the Rotator scrolling buttons.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssButtons
Visual Basic
Public Const CssButtons As String
Visual C++
public:
literal String^ CssButtons

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRotatorDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotatorConstants..::..CssRotatorDiv Field
RotatorConstants Class See Also Send Feedback
The CSS class unique part of the Rotator outer div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRotatorDiv
Visual Basic
Public Const CssRotatorDiv As String
Visual C++
public:
literal String^ CssRotatorDiv

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyRotator Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
RotatorConstants..::..KeyRotator Field
RotatorConstants Class See Also Send Feedback
The constant used as a key for the rotator level.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyRotator
Visual Basic
Public Const KeyRotator As String
Visual C++
public:
literal String^ KeyRotator

See Also

RotatorConstants Class
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment Members
SchedulerAppointment Class Constructors Methods Properties See Also Send Feedback

The SchedulerAppointment type exposes the following members.

Constructors

 | Name | Description
Public method | SchedulerAppointment()()()() | Initializes a new instance of the SchedulerAppointment class.
Public method | SchedulerAppointment(Element) | Initializes a new instance of the SchedulerAppointment class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the scheduler appointment control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Delete | Delete appointment method.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Edit | Edit appointment method.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Duration | Get the duration of the appointment.
Public property | End | Get the end date of the appointment.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsAllDay | Check whether the appointment is 'all day'.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for appointment. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RecurrenceState | Recurrence state of the appointment.
Public property | ResourceString | Returns a string containing the appointment resource types.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Start | Get the start date of the appointment.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | Subject | Get the subject of this appointment.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Tooltip | Get the tooltip of this appointment.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment Constructor
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SchedulerAppointment()()()() | Initializes a new instance of the SchedulerAppointment class.
Public method | SchedulerAppointment(Element) | Initializes a new instance of the SchedulerAppointment class.

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment Constructor
SchedulerAppointment Class See Also Send Feedback
Initializes a new instance of the SchedulerAppointment class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerAppointment()
Visual Basic
Public Sub New
Visual C++
public:
SchedulerAppointment()

See Also

SchedulerAppointment Class
SchedulerAppointment Overload
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment Constructor (Element)
SchedulerAppointment Class See Also Send Feedback
Initializes a new instance of the SchedulerAppointment class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerAppointment(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SchedulerAppointment(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SchedulerAppointment.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SchedulerAppointment Class
SchedulerAppointment Overload
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment Methods
SchedulerAppointment Class See Also Send Feedback

The SchedulerAppointment type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the scheduler appointment control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Delete | Delete appointment method.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Edit | Edit appointment method.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..AssignElement Method
SchedulerAppointment Class See Also Send Feedback
Assign the DOM element to be the scheduler appointment control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.SchedulerAppointment.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..CallMethod Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..Capture Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..Click Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


Delete Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..Delete Method
SchedulerAppointment Class See Also Send Feedback
Delete appointment method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete
Visual C++
public:
void Delete()

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..DragTo Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


Edit Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..Edit Method
SchedulerAppointment Class See Also Send Feedback
Edit appointment method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Edit()
Visual Basic
Public Sub Edit
Visual C++
public:
void Edit()

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..GetValue Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..InvokeEvent Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..MouseClick Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..MouseHover Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..ScrollToVisible Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment..::..SetValue Method
SchedulerAppointment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
SchedulerAppointment Members
Telerik.WebAii.Controls.Html Namespace


SchedulerAppointment Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerAppointment Properties
SchedulerAppointment Class See Also Send Feedback

The SchedulerAppointment type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the Client side locator - call method. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Duration | Get the duration of the appointment.
Public property | End | Get the end date of the appointment.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsAllDay | Check whether the appointment is 'all day'.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for appointment. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RecurrenceState | Recurrence state of the appointment.
Public property | ResourceString | Returns a string containing the appointment resource types.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Start | Get the start date of the appointment.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | Subject | Get the subject of this appointment.
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Tooltip | Get the tooltip of this appointment.
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SchedulerAppointment Class
Telerik.WebAii.Controls.Html Namespace


SchedulerConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants Members
SchedulerConstants Class Fields See Also Send Feedback

The SchedulerConstants type exposes the following members.

Fields

Name | Description
AdvancedFormKey | The advanced form key used accross the verifications and action messages.
AppointmentKey | The appointment key used accross the verifications and action messages.
CssAdvancedFormCancel | CSS classes constants -- advanced form button cancel.
CssAdvancedFormSave | CSS classes constants -- advanced form button save.
CssAllDayTable | CSS classes constants -- advanced form button cancel.
CssAppointment | CSS classes constants -- appointment.
CssAppointmentAptOut | CSS classes constants -- appointment inner div.
CssAppointmentDelete | CSS classes constants -- appointment delete button.
CssAppointmentWrapper | CSS classes constants -- appointment wrapper.
CssContentTable | CSS classes constants -- advanced form button cancel.
CssInlineFormCancel | CSS classes constants -- inline form cancel button.
CssInlineFormConfirm | CSS classes constants -- inline form save button.
CssInlineFormMore | CSS classes constants -- inline form options button.
CssModalDialogClose | CSS classes constants -- modal dialog button cancel.
CssModalDialogConfirm | CSS classes constants -- modal dialog button save.
CssScheduler | CSS class of the scheduler.
CssSchedulerAdvancedEditWrapper | CSS class of the scheduler advanced edit form wrapper.
CssSchedulerAdvancedForm | CSS class of the scheduler advanced form.
CssSchedulerAdvancedFormHidden | CSS class of the scheduler advanced form hidden.
CssSchedulerAdvancedFormModal | CSS class of the scheduler advanced modal form.
CssSchedulerAdvancedInsertWrapper | CSS class of the scheduler advanced insert form wrapper.
CssSchedulerDatePicker | CSS class of the scheduler picker activator arrow.
CssSchedulerDayView | CSS class of the scheduler day view header.
CssSchedulerHeader | CSS class of the scheduler header.
CssSchedulerHoursLink | CSS class of the scheduler full time link.
CssSchedulerInlineForm | CSS class of the scheduler inline form wrapper.
CssSchedulerModalDialog | CSS class of the scheduler modal dialog.
CssSchedulerModalDialogTitle | CSS class of the scheduler modal dialog title.
CssSchedulerMonthView | CSS class of the scheduler month view header.
CssSchedulerNextDay | CSS class of the scheduler next day arrow.
CssSchedulerPickerWrapper | CSS class of the scheduler date picker wrapper.
CssSchedulerPreviousDay | CSS class of the scheduler previous day arrow.
CssSchedulerTimelineView | CSS class of the scheduler timeline view header.
CssSchedulerToday | CSS class of the scheduler today arrow.
CssSchedulerWeekView | CSS class of the scheduler week view header.
CssTimeslot | CSS classes constants -- timeslot.
IdModalDialogOption1 | The modal dialog option1 key used accross the verifications and action messages.
IdModalDialogOption2 | The modal dialog option2 key used accross the verifications and action messages.
IdSchedulerAdvancedFormAllDayCheckBox | The advanced form all day checkbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormCancelButton | The advanced form save button used accross the verifications and action messages.
IdSchedulerAdvancedFormMoreControlsPanel | The advanced form more controls panel id used accross the verifications and action messages.
IdSchedulerAdvancedFormRecurrenceCheckBox | The advanced form recurrence checkbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormRecurrencePanel | The advanced form recurrence panel id used accross the verifications and action messages.
IdSchedulerAdvancedFormText | The advanced form subject textbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormUpdateButton | The advanced form save button used accross the verifications and action messages.
IdSchedulerInlineFormText | The inline form textbox id used accross the verifications and action messages.
SchedulerKey | The Scheduler key used accross the verifications and action messages.

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


SchedulerConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants Fields
SchedulerConstants Class See Also Send Feedback

The SchedulerConstants type exposes the following members.

Fields

Name | Description
AdvancedFormKey | The advanced form key used accross the verifications and action messages.
AppointmentKey | The appointment key used accross the verifications and action messages.
CssAdvancedFormCancel | CSS classes constants -- advanced form button cancel.
CssAdvancedFormSave | CSS classes constants -- advanced form button save.
CssAllDayTable | CSS classes constants -- advanced form button cancel.
CssAppointment | CSS classes constants -- appointment.
CssAppointmentAptOut | CSS classes constants -- appointment inner div.
CssAppointmentDelete | CSS classes constants -- appointment delete button.
CssAppointmentWrapper | CSS classes constants -- appointment wrapper.
CssContentTable | CSS classes constants -- advanced form button cancel.
CssInlineFormCancel | CSS classes constants -- inline form cancel button.
CssInlineFormConfirm | CSS classes constants -- inline form save button.
CssInlineFormMore | CSS classes constants -- inline form options button.
CssModalDialogClose | CSS classes constants -- modal dialog button cancel.
CssModalDialogConfirm | CSS classes constants -- modal dialog button save.
CssScheduler | CSS class of the scheduler.
CssSchedulerAdvancedEditWrapper | CSS class of the scheduler advanced edit form wrapper.
CssSchedulerAdvancedForm | CSS class of the scheduler advanced form.
CssSchedulerAdvancedFormHidden | CSS class of the scheduler advanced form hidden.
CssSchedulerAdvancedFormModal | CSS class of the scheduler advanced modal form.
CssSchedulerAdvancedInsertWrapper | CSS class of the scheduler advanced insert form wrapper.
CssSchedulerDatePicker | CSS class of the scheduler picker activator arrow.
CssSchedulerDayView | CSS class of the scheduler day view header.
CssSchedulerHeader | CSS class of the scheduler header.
CssSchedulerHoursLink | CSS class of the scheduler full time link.
CssSchedulerInlineForm | CSS class of the scheduler inline form wrapper.
CssSchedulerModalDialog | CSS class of the scheduler modal dialog.
CssSchedulerModalDialogTitle | CSS class of the scheduler modal dialog title.
CssSchedulerMonthView | CSS class of the scheduler month view header.
CssSchedulerNextDay | CSS class of the scheduler next day arrow.
CssSchedulerPickerWrapper | CSS class of the scheduler date picker wrapper.
CssSchedulerPreviousDay | CSS class of the scheduler previous day arrow.
CssSchedulerTimelineView | CSS class of the scheduler timeline view header.
CssSchedulerToday | CSS class of the scheduler today arrow.
CssSchedulerWeekView | CSS class of the scheduler week view header.
CssTimeslot | CSS classes constants -- timeslot.
IdModalDialogOption1 | The modal dialog option1 key used accross the verifications and action messages.
IdModalDialogOption2 | The modal dialog option2 key used accross the verifications and action messages.
IdSchedulerAdvancedFormAllDayCheckBox | The advanced form all day checkbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormCancelButton | The advanced form save button used accross the verifications and action messages.
IdSchedulerAdvancedFormMoreControlsPanel | The advanced form more controls panel id used accross the verifications and action messages.
IdSchedulerAdvancedFormRecurrenceCheckBox | The advanced form recurrence checkbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormRecurrencePanel | The advanced form recurrence panel id used accross the verifications and action messages.
IdSchedulerAdvancedFormText | The advanced form subject textbox id used accross the verifications and action messages.
IdSchedulerAdvancedFormUpdateButton | The advanced form save button used accross the verifications and action messages.
IdSchedulerInlineFormText | The inline form textbox id used accross the verifications and action messages.
SchedulerKey | The Scheduler key used accross the verifications and action messages.

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


AdvancedFormKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..AdvancedFormKey Field
SchedulerConstants Class See Also Send Feedback
The advanced form key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string AdvancedFormKey
Visual Basic
Public Const AdvancedFormKey As String
Visual C++
public:
literal String^ AdvancedFormKey

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


AppointmentKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..AppointmentKey Field
SchedulerConstants Class See Also Send Feedback
The appointment key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string AppointmentKey
Visual Basic
Public Const AppointmentKey As String
Visual C++
public:
literal String^ AppointmentKey

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAdvancedFormCancel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssAdvancedFormCancel Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- advanced form button cancel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAdvancedFormCancel
Visual Basic
Public Const CssAdvancedFormCancel As String
Visual C++
public:
literal String^ CssAdvancedFormCancel

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAdvancedFormSave Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssAdvancedFormSave Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- advanced form button save.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAdvancedFormSave
Visual Basic
Public Const CssAdvancedFormSave As String
Visual C++
public:
literal String^ CssAdvancedFormSave

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAllDayTable Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssAllDayTable Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- advanced form button cancel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAllDayTable
Visual Basic
Public Const CssAllDayTable As String
Visual C++
public:
literal String^ CssAllDayTable

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAppointment Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssAppointment Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- appointment.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAppointment
Visual Basic
Public Const CssAppointment As String
Visual C++
public:
literal String^ CssAppointment

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAppointmentAptOut Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssAppointmentAptOut Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- appointment inner div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAppointmentAptOut
Visual Basic
Public Const CssAppointmentAptOut As String
Visual C++
public:
literal String^ CssAppointmentAptOut

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAppointmentDelete Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssAppointmentDelete Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- appointment delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAppointmentDelete
Visual Basic
Public Const CssAppointmentDelete As String
Visual C++
public:
literal String^ CssAppointmentDelete

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAppointmentWrapper Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssAppointmentWrapper Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- appointment wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAppointmentWrapper
Visual Basic
Public Const CssAppointmentWrapper As String
Visual C++
public:
literal String^ CssAppointmentWrapper

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssContentTable Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssContentTable Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- advanced form button cancel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssContentTable
Visual Basic
Public Const CssContentTable As String
Visual C++
public:
literal String^ CssContentTable

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInlineFormCancel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssInlineFormCancel Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- inline form cancel button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssInlineFormCancel
Visual Basic
Public Const CssInlineFormCancel As String
Visual C++
public:
literal String^ CssInlineFormCancel

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInlineFormConfirm Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssInlineFormConfirm Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- inline form save button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssInlineFormConfirm
Visual Basic
Public Const CssInlineFormConfirm As String
Visual C++
public:
literal String^ CssInlineFormConfirm

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInlineFormMore Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssInlineFormMore Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- inline form options button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssInlineFormMore
Visual Basic
Public Const CssInlineFormMore As String
Visual C++
public:
literal String^ CssInlineFormMore

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssModalDialogClose Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssModalDialogClose Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- modal dialog button cancel.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssModalDialogClose
Visual Basic
Public Const CssModalDialogClose As String
Visual C++
public:
literal String^ CssModalDialogClose

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssModalDialogConfirm Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssModalDialogConfirm Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- modal dialog button save.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssModalDialogConfirm
Visual Basic
Public Const CssModalDialogConfirm As String
Visual C++
public:
literal String^ CssModalDialogConfirm

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssScheduler Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssScheduler Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssScheduler
Visual Basic
Public Const CssScheduler As String
Visual C++
public:
literal String^ CssScheduler

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedEditWrapper Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerAdvancedEditWrapper Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced edit form wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerAdvancedEditWrapper
Visual Basic
Public Const CssSchedulerAdvancedEditWrapper As String
Visual C++
public:
literal String^ CssSchedulerAdvancedEditWrapper

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedForm Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerAdvancedForm Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerAdvancedForm
Visual Basic
Public Const CssSchedulerAdvancedForm As String
Visual C++
public:
literal String^ CssSchedulerAdvancedForm

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedFormHidden Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerAdvancedFormHidden Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced form hidden.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerAdvancedFormHidden
Visual Basic
Public Const CssSchedulerAdvancedFormHidden As String
Visual C++
public:
literal String^ CssSchedulerAdvancedFormHidden

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedFormModal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerAdvancedFormModal Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced modal form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerAdvancedFormModal
Visual Basic
Public Const CssSchedulerAdvancedFormModal As String
Visual C++
public:
literal String^ CssSchedulerAdvancedFormModal

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerAdvancedInsertWrapper Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerAdvancedInsertWrapper Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler advanced insert form wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerAdvancedInsertWrapper
Visual Basic
Public Const CssSchedulerAdvancedInsertWrapper As String
Visual C++
public:
literal String^ CssSchedulerAdvancedInsertWrapper

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerDatePicker Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerDatePicker Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler picker activator arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerDatePicker
Visual Basic
Public Const CssSchedulerDatePicker As String
Visual C++
public:
literal String^ CssSchedulerDatePicker

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerDayView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerDayView Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler day view header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerDayView
Visual Basic
Public Const CssSchedulerDayView As String
Visual C++
public:
literal String^ CssSchedulerDayView

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerHeader Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerHeader Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerHeader
Visual Basic
Public Const CssSchedulerHeader As String
Visual C++
public:
literal String^ CssSchedulerHeader

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerHoursLink Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerHoursLink Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler full time link.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerHoursLink
Visual Basic
Public Const CssSchedulerHoursLink As String
Visual C++
public:
literal String^ CssSchedulerHoursLink

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerInlineForm Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerInlineForm Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler inline form wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerInlineForm
Visual Basic
Public Const CssSchedulerInlineForm As String
Visual C++
public:
literal String^ CssSchedulerInlineForm

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerModalDialog Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerModalDialog Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler modal dialog.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerModalDialog
Visual Basic
Public Const CssSchedulerModalDialog As String
Visual C++
public:
literal String^ CssSchedulerModalDialog

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerModalDialogTitle Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerModalDialogTitle Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler modal dialog title.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerModalDialogTitle
Visual Basic
Public Const CssSchedulerModalDialogTitle As String
Visual C++
public:
literal String^ CssSchedulerModalDialogTitle

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerMonthView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerMonthView Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler month view header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerMonthView
Visual Basic
Public Const CssSchedulerMonthView As String
Visual C++
public:
literal String^ CssSchedulerMonthView

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerNextDay Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerNextDay Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler next day arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerNextDay
Visual Basic
Public Const CssSchedulerNextDay As String
Visual C++
public:
literal String^ CssSchedulerNextDay

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerPickerWrapper Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerPickerWrapper Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler date picker wrapper.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerPickerWrapper
Visual Basic
Public Const CssSchedulerPickerWrapper As String
Visual C++
public:
literal String^ CssSchedulerPickerWrapper

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerPreviousDay Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerPreviousDay Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler previous day arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerPreviousDay
Visual Basic
Public Const CssSchedulerPreviousDay As String
Visual C++
public:
literal String^ CssSchedulerPreviousDay

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerTimelineView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerTimelineView Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler timeline view header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerTimelineView
Visual Basic
Public Const CssSchedulerTimelineView As String
Visual C++
public:
literal String^ CssSchedulerTimelineView

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerToday Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerToday Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler today arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerToday
Visual Basic
Public Const CssSchedulerToday As String
Visual C++
public:
literal String^ CssSchedulerToday

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSchedulerWeekView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssSchedulerWeekView Field
SchedulerConstants Class See Also Send Feedback
CSS class of the scheduler week view header.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSchedulerWeekView
Visual Basic
Public Const CssSchedulerWeekView As String
Visual C++
public:
literal String^ CssSchedulerWeekView

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTimeslot Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..CssTimeslot Field
SchedulerConstants Class See Also Send Feedback
CSS classes constants -- timeslot.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTimeslot
Visual Basic
Public Const CssTimeslot As String
Visual C++
public:
literal String^ CssTimeslot

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdModalDialogOption1 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdModalDialogOption1 Field
SchedulerConstants Class See Also Send Feedback
The modal dialog option1 key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdModalDialogOption1
Visual Basic
Public Const IdModalDialogOption1 As String
Visual C++
public:
literal String^ IdModalDialogOption1

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdModalDialogOption2 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdModalDialogOption2 Field
SchedulerConstants Class See Also Send Feedback
The modal dialog option2 key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdModalDialogOption2
Visual Basic
Public Const IdModalDialogOption2 As String
Visual C++
public:
literal String^ IdModalDialogOption2

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormAllDayCheckBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdSchedulerAdvancedFormAllDayCheckBox Field
SchedulerConstants Class See Also Send Feedback
The advanced form all day checkbox id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSchedulerAdvancedFormAllDayCheckBox
Visual Basic
Public Const IdSchedulerAdvancedFormAllDayCheckBox As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormAllDayCheckBox

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormCancelButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdSchedulerAdvancedFormCancelButton Field
SchedulerConstants Class See Also Send Feedback
The advanced form save button used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSchedulerAdvancedFormCancelButton
Visual Basic
Public Const IdSchedulerAdvancedFormCancelButton As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormCancelButton

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormMoreControlsPanel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdSchedulerAdvancedFormMoreControlsPanel Field
SchedulerConstants Class See Also Send Feedback
The advanced form more controls panel id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSchedulerAdvancedFormMoreControlsPanel
Visual Basic
Public Const IdSchedulerAdvancedFormMoreControlsPanel As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormMoreControlsPanel

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormRecurrenceCheckBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdSchedulerAdvancedFormRecurrenceCheckBox Field
SchedulerConstants Class See Also Send Feedback
The advanced form recurrence checkbox id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSchedulerAdvancedFormRecurrenceCheckBox
Visual Basic
Public Const IdSchedulerAdvancedFormRecurrenceCheckBox As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormRecurrenceCheckBox

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormRecurrencePanel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdSchedulerAdvancedFormRecurrencePanel Field
SchedulerConstants Class See Also Send Feedback
The advanced form recurrence panel id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSchedulerAdvancedFormRecurrencePanel
Visual Basic
Public Const IdSchedulerAdvancedFormRecurrencePanel As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormRecurrencePanel

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdSchedulerAdvancedFormText Field
SchedulerConstants Class See Also Send Feedback
The advanced form subject textbox id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSchedulerAdvancedFormText
Visual Basic
Public Const IdSchedulerAdvancedFormText As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormText

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerAdvancedFormUpdateButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdSchedulerAdvancedFormUpdateButton Field
SchedulerConstants Class See Also Send Feedback
The advanced form save button used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSchedulerAdvancedFormUpdateButton
Visual Basic
Public Const IdSchedulerAdvancedFormUpdateButton As String
Visual C++
public:
literal String^ IdSchedulerAdvancedFormUpdateButton

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSchedulerInlineFormText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..IdSchedulerInlineFormText Field
SchedulerConstants Class See Also Send Feedback
The inline form textbox id used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSchedulerInlineFormText
Visual Basic
Public Const IdSchedulerInlineFormText As String
Visual C++
public:
literal String^ IdSchedulerInlineFormText

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


SchedulerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerConstants..::..SchedulerKey Field
SchedulerConstants Class See Also Send Feedback
The Scheduler key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SchedulerKey
Visual Basic
Public Const SchedulerKey As String
Visual C++
public:
literal String^ SchedulerKey

See Also

SchedulerConstants Class
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot Members
SchedulerTimeSlot Class Constructors Methods Properties See Also Send Feedback

The SchedulerTimeSlot type exposes the following members.

Constructors

 | Name | Description
Public method | SchedulerTimeSlot()()()() | Initializes a new instance of the SchedulerTimeSlot class.
Public method | SchedulerTimeSlot(Element) | Initializes a new instance of the SchedulerTimeSlot class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the TimeSlot control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InsertAppointment | Insert appointment method.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsAllDay | Get whether the time slot is all day type.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for appointment. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ResourceText | Get the resource text if available or null, otherwise.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | Scheduler | Get the parent scheduler.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | StartTime | Get start time of the time slot.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot Constructor
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SchedulerTimeSlot()()()() | Initializes a new instance of the SchedulerTimeSlot class.
Public method | SchedulerTimeSlot(Element) | Initializes a new instance of the SchedulerTimeSlot class.

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot Constructor
SchedulerTimeSlot Class See Also Send Feedback
Initializes a new instance of the SchedulerTimeSlot class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerTimeSlot()
Visual Basic
Public Sub New
Visual C++
public:
SchedulerTimeSlot()

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Overload
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot Constructor (Element)
SchedulerTimeSlot Class See Also Send Feedback
Initializes a new instance of the SchedulerTimeSlot class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SchedulerTimeSlot(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SchedulerTimeSlot(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SchedulerTimeSlot.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Overload
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot Methods
SchedulerTimeSlot Class See Also Send Feedback

The SchedulerTimeSlot type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the DOM element to be the TimeSlot control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InsertAppointment | Insert appointment method.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..AssignElement Method
SchedulerTimeSlot Class See Also Send Feedback
Assign the DOM element to be the TimeSlot control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="e"/> documentation for "M:Telerik.WebAii.Controls.Html.SchedulerTimeSlot.AssignElement(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..CallMethod Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..Capture Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..Click Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..DragTo Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..GetValue Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


InsertAppointment Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..InsertAppointment Method
SchedulerTimeSlot Class See Also Send Feedback
Insert appointment method.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void InsertAppointment()
Visual Basic
Public Sub InsertAppointment
Visual C++
public:
void InsertAppointment()

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..InvokeEvent Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..MouseClick Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..MouseHover Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..ScrollToVisible Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot..::..SetValue Method
SchedulerTimeSlot Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SchedulerTimeSlot Class
SchedulerTimeSlot Members
Telerik.WebAii.Controls.Html Namespace


SchedulerTimeSlot Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SchedulerTimeSlot Properties
SchedulerTimeSlot Class See Also Send Feedback

The SchedulerTimeSlot type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Client side locator. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsAllDay | Get whether the time slot is all day type.
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the FindParam that defines the pattern for appointment. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ResourceText | Get the resource text if available or null, otherwise.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | Scheduler | Get the parent scheduler.
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | StartTime | Get start time of the time slot.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

SchedulerTimeSlot Class
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection Members
SelectedDateCollection Class Constructors Methods Properties See Also Send Feedback

The SelectedDateCollection type exposes the following members.

Constructors

 | Name | Description
Public method | SelectedDateCollection()()()() | Initializes a new instance of the SelectedDateCollection class. The empty constructor.
Public method | SelectedDateCollection(IList<(Of <<'(DateTime>)>>)) | Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified list.
Public method | SelectedDateCollection(array<DateTime>[]()[][]) | Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified DateTime objects array.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | InitializeCodeExpression | Generates initialization code for the selected date collection.
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Matches | Get whether the current colleciton items match those from the given collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection Constructor
SelectedDateCollection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectedDateCollection()()()() | Initializes a new instance of the SelectedDateCollection class. The empty constructor.
Public method | SelectedDateCollection(IList<(Of <<'(DateTime>)>>)) | Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified list.
Public method | SelectedDateCollection(array<DateTime>[]()[][]) | Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified DateTime objects array.

See Also

SelectedDateCollection Class
SelectedDateCollection Members
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection Constructor
SelectedDateCollection Class See Also Send Feedback
Initializes a new instance of the SelectedDateCollection class. The empty constructor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SelectedDateCollection()
Visual Basic
Public Sub New
Visual C++
public:
SelectedDateCollection()

See Also

SelectedDateCollection Class
SelectedDateCollection Overload
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Constructor (IList(DateTime))

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection Constructor (IList<(Of <(<'DateTime>)>)>)
SelectedDateCollection Class See Also Send Feedback
Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified list.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SelectedDateCollection(
    IList<DateTime> list
)
Visual Basic
Public Sub New ( _
    list As IList(Of DateTime) _
)
Visual C++
public:
SelectedDateCollection(
    IList<DateTime>^ list
)

Parameters

list
Type: System.Collections.Generic..::..IList <(Of <(<' DateTime >)>)>

[Missing <param name="list"/> documentation for "M:Telerik.WebAii.Controls.Html.SelectedDateCollection.#ctor(System.Collections.Generic.IList{System.DateTime})"]

See Also

SelectedDateCollection Class
SelectedDateCollection Overload
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Constructor (DateTime[])

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection Constructor (array<DateTime>[]()[][])
SelectedDateCollection Class See Also Send Feedback
Initializes a new instance of the SelectedDateCollection class. Serves as a wrapper for the specified DateTime objects array.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SelectedDateCollection(
    DateTime[] datesArray
)
Visual Basic
Public Sub New ( _
    datesArray As DateTime() _
)
Visual C++
public:
SelectedDateCollection(
    array<DateTime>^ datesArray
)

Parameters

datesArray
Type: array< System..::..DateTime >[]()[][]

[Missing <param name="datesArray"/> documentation for "M:Telerik.WebAii.Controls.Html.SelectedDateCollection.#ctor(System.DateTime[])"]

See Also

SelectedDateCollection Class
SelectedDateCollection Overload
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection Methods
SelectedDateCollection Class See Also Send Feedback

The SelectedDateCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Clear | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | ClearItems | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Contains | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | CopyTo | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | InitializeCodeExpression | Generates initialization code for the selected date collection.
Public method | Insert | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | InsertItem | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | Matches | Get whether the current colleciton items match those from the given collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | RemoveItem | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


InitializeCodeExpression Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection..::..InitializeCodeExpression Method
SelectedDateCollection Class See Also Send Feedback
Generates initialization code for the selected date collection.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public string InitializeCodeExpression()
Visual Basic
Public Function InitializeCodeExpression As String
Visual C++
public:
String^ InitializeCodeExpression()

Return Value

The initialization code for the selected date collection.

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


Matches Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection..::..Matches Method
SelectedDateCollection Class See Also Send Feedback
Get whether the current colleciton items match those from the given collection.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public bool Matches(
    SelectedDateCollection dates
)
Visual Basic
Public Function Matches ( _
    dates As SelectedDateCollection _
) As Boolean
Visual C++
public:
bool Matches(
    SelectedDateCollection^ dates
)

Parameters

dates
Type: Telerik.WebAii.Controls.Html..::..SelectedDateCollection
The date collection to compare.

Return Value

Whether the current colleciton items match those from the given collection.

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


SelectedDateCollection Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SelectedDateCollection Properties
SelectedDateCollection Class See Also Send Feedback

The SelectedDateCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DateTime >)>)>.)
Protected property | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DateTime >)>)>.)

See Also

SelectedDateCollection Class
Telerik.WebAii.Controls.Html Namespace


SliderConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants Members
SliderConstants Class Fields See Also Send Feedback

The SliderConstants type exposes the following members.

Fields

Name | Description
CssDragHandle | The CSS class identifying the Slider thumb anchor.
CssHandleDecrease | The CSS class identifying the Slider's decrease handler element.
CssHandleIncrease | The CSS class identifying the Slider's increase handler element.
CssLargeTick | The CSS class identifying the Slider thumb anchor.
CssSliderItem | The CSS class identifying a Slider item.
CssSliderRegion | The CSS class identifying the Slider's selected region element.
CssSliderTrack | The CSS class identifying the Slider's track element.
CssSmallTick | The CSS class identifying the Slider thumb anchor.
KeySlider | The key identifying the Slider control.
SliderIdPrefix | The ID prefix identifying the Slider control.

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


SliderConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants Fields
SliderConstants Class See Also Send Feedback

The SliderConstants type exposes the following members.

Fields

Name | Description
CssDragHandle | The CSS class identifying the Slider thumb anchor.
CssHandleDecrease | The CSS class identifying the Slider's decrease handler element.
CssHandleIncrease | The CSS class identifying the Slider's increase handler element.
CssLargeTick | The CSS class identifying the Slider thumb anchor.
CssSliderItem | The CSS class identifying a Slider item.
CssSliderRegion | The CSS class identifying the Slider's selected region element.
CssSliderTrack | The CSS class identifying the Slider's track element.
CssSmallTick | The CSS class identifying the Slider thumb anchor.
KeySlider | The key identifying the Slider control.
SliderIdPrefix | The ID prefix identifying the Slider control.

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDragHandle Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..CssDragHandle Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider thumb anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDragHandle
Visual Basic
Public Const CssDragHandle As String
Visual C++
public:
literal String^ CssDragHandle

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHandleDecrease Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..CssHandleDecrease Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider's decrease handler element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssHandleDecrease
Visual Basic
Public Const CssHandleDecrease As String
Visual C++
public:
literal String^ CssHandleDecrease

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHandleIncrease Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..CssHandleIncrease Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider's increase handler element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssHandleIncrease
Visual Basic
Public Const CssHandleIncrease As String
Visual C++
public:
literal String^ CssHandleIncrease

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssLargeTick Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..CssLargeTick Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider thumb anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssLargeTick
Visual Basic
Public Const CssLargeTick As String
Visual C++
public:
literal String^ CssLargeTick

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSliderItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..CssSliderItem Field
SliderConstants Class See Also Send Feedback
The CSS class identifying a Slider item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSliderItem
Visual Basic
Public Const CssSliderItem As String
Visual C++
public:
literal String^ CssSliderItem

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSliderRegion Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..CssSliderRegion Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider's selected region element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSliderRegion
Visual Basic
Public Const CssSliderRegion As String
Visual C++
public:
literal String^ CssSliderRegion

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSliderTrack Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..CssSliderTrack Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider's track element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSliderTrack
Visual Basic
Public Const CssSliderTrack As String
Visual C++
public:
literal String^ CssSliderTrack

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSmallTick Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..CssSmallTick Field
SliderConstants Class See Also Send Feedback
The CSS class identifying the Slider thumb anchor.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSmallTick
Visual Basic
Public Const CssSmallTick As String
Visual C++
public:
literal String^ CssSmallTick

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


KeySlider Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..KeySlider Field
SliderConstants Class See Also Send Feedback
The key identifying the Slider control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeySlider
Visual Basic
Public Const KeySlider As String
Visual C++
public:
literal String^ KeySlider

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


SliderIdPrefix Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SliderConstants..::..SliderIdPrefix Field
SliderConstants Class See Also Send Feedback
The ID prefix identifying the Slider control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SliderIdPrefix
Visual Basic
Public Const SliderIdPrefix As String
Visual C++
public:
literal String^ SliderIdPrefix

See Also

SliderConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareBlogger Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger Members
SocialShareBlogger Class Constructors Methods Properties See Also Send Feedback

The SocialShareBlogger type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareBlogger()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareBlogger(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareBlogger button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
Telerik.WebAii.Controls.Html Namespace


SocialShareBlogger Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger Constructor
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareBlogger()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareBlogger(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


SocialShareBlogger Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger Constructor
SocialShareBlogger Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareBlogger()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareBlogger()

See Also

SocialShareBlogger Class
SocialShareBlogger Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareBlogger Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger Constructor (Element)
SocialShareBlogger Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareBlogger(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareBlogger(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareBlogger.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareBlogger Class
SocialShareBlogger Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareBlogger Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger Methods
SocialShareBlogger Class See Also Send Feedback

The SocialShareBlogger type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareBlogger Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..AssignElement Method
SocialShareBlogger Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareBlogger Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..CallMethod Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..Capture Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..Click Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..DragTo Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..GetValue Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..InvokeEvent Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..MouseClick Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..MouseHover Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..ScrollToVisible Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger..::..SetValue Method
SocialShareBlogger Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
SocialShareBlogger Members
Telerik.WebAii.Controls.Html Namespace


SocialShareBlogger Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareBlogger Properties
SocialShareBlogger Class See Also Send Feedback

The SocialShareBlogger type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareBlogger button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareBlogger Class
Telerik.WebAii.Controls.Html Namespace


SocialShareCompactButton Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton Members
SocialShareCompactButton Class Constructors Methods Properties See Also Send Feedback

The SocialShareCompactButton type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareCompactButton()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareCompactButton(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareCompactButton button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
Telerik.WebAii.Controls.Html Namespace


SocialShareCompactButton Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton Constructor
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareCompactButton()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareCompactButton(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


SocialShareCompactButton Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton Constructor
SocialShareCompactButton Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareCompactButton()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareCompactButton()

See Also

SocialShareCompactButton Class
SocialShareCompactButton Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareCompactButton Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton Constructor (Element)
SocialShareCompactButton Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareCompactButton(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareCompactButton(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareCompactButton.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareCompactButton Class
SocialShareCompactButton Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareCompactButton Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton Methods
SocialShareCompactButton Class See Also Send Feedback

The SocialShareCompactButton type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareCompactButton Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..AssignElement Method
SocialShareCompactButton Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareCompactButton Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..CallMethod Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..Capture Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..Click Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..DragTo Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..GetValue Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..InvokeEvent Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..MouseClick Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..MouseHover Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..ScrollToVisible Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton..::..SetValue Method
SocialShareCompactButton Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
SocialShareCompactButton Members
Telerik.WebAii.Controls.Html Namespace


SocialShareCompactButton Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareCompactButton Properties
SocialShareCompactButton Class See Also Send Feedback

The SocialShareCompactButton type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareCompactButton button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareCompactButton Class
Telerik.WebAii.Controls.Html Namespace


SocialShareConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants Members
SocialShareConstants Class Fields See Also Send Feedback

The SocialShareConstants type exposes the following members.

Fields

Name | Description
CssRadSocialShare | The base CSS class of the RadSocialShare wrapper element.
CssRadSocialShareBlogger | The base CSS class of the RadSocialShare Blogger wrapper element.
CssRadSocialShareCompactButton | The base CSS class of the RadSocialShare CompactButton wrapper element.
CssRadSocialShareDelicious | The base CSS class of the RadSocialShare Delicious wrapper element.
CssRadSocialShareDigg | The base CSS class of the RadSocialShare Digg wrapper element.
CssRadSocialShareFacebook | The base CSS class of the RadSocialShare Facebook wrapper element.
CssRadSocialShareGoogleBookmarks | The base CSS class of the RadSocialShare GoogleBookmarks wrapper element.
CssRadSocialShareLinkedIn | The base CSS class of the RadSocialShare LinkedIn wrapper element.
CssRadSocialShareMailTo | The base CSS class of the RadSocialShare MailTo wrapper element.
CssRadSocialShareMySpace | The base CSS class of the RadSocialShare MySpace wrapper element.
CssRadSocialShareReddit | The base CSS class of the RadSocialShare Reddit wrapper element.
CssRadSocialShareSendEmail | The base CSS class of the RadSocialShare SendEmail wrapper element.
CssRadSocialShareStumbleUpon | The base CSS class of the RadSocialShare StumbleUpon wrapper element.
CssRadSocialShareTumblr | The base CSS class of the RadSocialShare Tumblr wrapper element.
CssRadSocialShareTweeter | The base CSS class of the RadSocialShare Tweeter wrapper element.
SocialShareBloggerKey | The 'RadSocialShare' Blogger key used across the source classes.
SocialShareCompactButtonKey | The 'RadSocialShare' CompactButton key used across the source classes.
SocialShareDeliciousKey | The 'RadSocialShare' DeliciousButton key used across the source classes.
SocialShareDiggKey | The 'RadSocialShare' DiggButton key used across the source classes.
SocialShareFacebookKey | The 'RadSocialShare' Facebook key used across the source classes.
SocialShareGoogleBookmarksKey | The 'RadSocialShare' GoogleBookmarks Button key used across the source classes.
SocialShareKey | The 'RadSocialShare' key used across the source classes.
SocialShareLinkedInKey | The 'RadSocialShare' LinkedIn Button key used across the source classes.
SocialShareMailToKey | The 'RadSocialShare' MailTo Button key used across the source classes.
SocialShareMySpaceKey | The 'RadSocialShare' MySpace Button key used across the source classes.
SocialShareRedditKey | The 'RadSocialShare' Reddit Button key used across the source classes.
SocialShareSendEmailKey | The 'RadSocialShare' SendEmail Button key used across the source classes.
SocialShareStumbleUponKey | The 'RadSocialShare' StumbleUpon Button key used across the source classes.
SocialShareTumblrKey | The 'RadSocialShare' Tumblr Button key used across the source classes.
SocialShareTweeterKey | The 'RadSocialShare' Tweeter Button key used across the source classes.

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants Fields
SocialShareConstants Class See Also Send Feedback

The SocialShareConstants type exposes the following members.

Fields

Name | Description
CssRadSocialShare | The base CSS class of the RadSocialShare wrapper element.
CssRadSocialShareBlogger | The base CSS class of the RadSocialShare Blogger wrapper element.
CssRadSocialShareCompactButton | The base CSS class of the RadSocialShare CompactButton wrapper element.
CssRadSocialShareDelicious | The base CSS class of the RadSocialShare Delicious wrapper element.
CssRadSocialShareDigg | The base CSS class of the RadSocialShare Digg wrapper element.
CssRadSocialShareFacebook | The base CSS class of the RadSocialShare Facebook wrapper element.
CssRadSocialShareGoogleBookmarks | The base CSS class of the RadSocialShare GoogleBookmarks wrapper element.
CssRadSocialShareLinkedIn | The base CSS class of the RadSocialShare LinkedIn wrapper element.
CssRadSocialShareMailTo | The base CSS class of the RadSocialShare MailTo wrapper element.
CssRadSocialShareMySpace | The base CSS class of the RadSocialShare MySpace wrapper element.
CssRadSocialShareReddit | The base CSS class of the RadSocialShare Reddit wrapper element.
CssRadSocialShareSendEmail | The base CSS class of the RadSocialShare SendEmail wrapper element.
CssRadSocialShareStumbleUpon | The base CSS class of the RadSocialShare StumbleUpon wrapper element.
CssRadSocialShareTumblr | The base CSS class of the RadSocialShare Tumblr wrapper element.
CssRadSocialShareTweeter | The base CSS class of the RadSocialShare Tweeter wrapper element.
SocialShareBloggerKey | The 'RadSocialShare' Blogger key used across the source classes.
SocialShareCompactButtonKey | The 'RadSocialShare' CompactButton key used across the source classes.
SocialShareDeliciousKey | The 'RadSocialShare' DeliciousButton key used across the source classes.
SocialShareDiggKey | The 'RadSocialShare' DiggButton key used across the source classes.
SocialShareFacebookKey | The 'RadSocialShare' Facebook key used across the source classes.
SocialShareGoogleBookmarksKey | The 'RadSocialShare' GoogleBookmarks Button key used across the source classes.
SocialShareKey | The 'RadSocialShare' key used across the source classes.
SocialShareLinkedInKey | The 'RadSocialShare' LinkedIn Button key used across the source classes.
SocialShareMailToKey | The 'RadSocialShare' MailTo Button key used across the source classes.
SocialShareMySpaceKey | The 'RadSocialShare' MySpace Button key used across the source classes.
SocialShareRedditKey | The 'RadSocialShare' Reddit Button key used across the source classes.
SocialShareSendEmailKey | The 'RadSocialShare' SendEmail Button key used across the source classes.
SocialShareStumbleUponKey | The 'RadSocialShare' StumbleUpon Button key used across the source classes.
SocialShareTumblrKey | The 'RadSocialShare' Tumblr Button key used across the source classes.
SocialShareTweeterKey | The 'RadSocialShare' Tweeter Button key used across the source classes.

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShare Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShare Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShare
Visual Basic
Public Const CssRadSocialShare As String
Visual C++
public:
literal String^ CssRadSocialShare

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareBlogger Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareBlogger Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare Blogger wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareBlogger
Visual Basic
Public Const CssRadSocialShareBlogger As String
Visual C++
public:
literal String^ CssRadSocialShareBlogger

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareCompactButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareCompactButton Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare CompactButton wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareCompactButton
Visual Basic
Public Const CssRadSocialShareCompactButton As String
Visual C++
public:
literal String^ CssRadSocialShareCompactButton

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareDelicious Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareDelicious Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare Delicious wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareDelicious
Visual Basic
Public Const CssRadSocialShareDelicious As String
Visual C++
public:
literal String^ CssRadSocialShareDelicious

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareDigg Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareDigg Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare Digg wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareDigg
Visual Basic
Public Const CssRadSocialShareDigg As String
Visual C++
public:
literal String^ CssRadSocialShareDigg

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareFacebook Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareFacebook Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare Facebook wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareFacebook
Visual Basic
Public Const CssRadSocialShareFacebook As String
Visual C++
public:
literal String^ CssRadSocialShareFacebook

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareGoogleBookmarks Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareGoogleBookmarks Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare GoogleBookmarks wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareGoogleBookmarks
Visual Basic
Public Const CssRadSocialShareGoogleBookmarks As String
Visual C++
public:
literal String^ CssRadSocialShareGoogleBookmarks

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareLinkedIn Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareLinkedIn Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare LinkedIn wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareLinkedIn
Visual Basic
Public Const CssRadSocialShareLinkedIn As String
Visual C++
public:
literal String^ CssRadSocialShareLinkedIn

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareMailTo Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareMailTo Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare MailTo wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareMailTo
Visual Basic
Public Const CssRadSocialShareMailTo As String
Visual C++
public:
literal String^ CssRadSocialShareMailTo

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareMySpace Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareMySpace Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare MySpace wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareMySpace
Visual Basic
Public Const CssRadSocialShareMySpace As String
Visual C++
public:
literal String^ CssRadSocialShareMySpace

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareReddit Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareReddit Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare Reddit wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareReddit
Visual Basic
Public Const CssRadSocialShareReddit As String
Visual C++
public:
literal String^ CssRadSocialShareReddit

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareSendEmail Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareSendEmail Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare SendEmail wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareSendEmail
Visual Basic
Public Const CssRadSocialShareSendEmail As String
Visual C++
public:
literal String^ CssRadSocialShareSendEmail

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareStumbleUpon Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareStumbleUpon Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare StumbleUpon wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareStumbleUpon
Visual Basic
Public Const CssRadSocialShareStumbleUpon As String
Visual C++
public:
literal String^ CssRadSocialShareStumbleUpon

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareTumblr Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareTumblr Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare Tumblr wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareTumblr
Visual Basic
Public Const CssRadSocialShareTumblr As String
Visual C++
public:
literal String^ CssRadSocialShareTumblr

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSocialShareTweeter Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..CssRadSocialShareTweeter Field
SocialShareConstants Class See Also Send Feedback
The base CSS class of the RadSocialShare Tweeter wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSocialShareTweeter
Visual Basic
Public Const CssRadSocialShareTweeter As String
Visual C++
public:
literal String^ CssRadSocialShareTweeter

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareBloggerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareBloggerKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' Blogger key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareBloggerKey
Visual Basic
Public Const SocialShareBloggerKey As String
Visual C++
public:
literal String^ SocialShareBloggerKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareCompactButtonKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareCompactButtonKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' CompactButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareCompactButtonKey
Visual Basic
Public Const SocialShareCompactButtonKey As String
Visual C++
public:
literal String^ SocialShareCompactButtonKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareDeliciousKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareDeliciousKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' DeliciousButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareDeliciousKey
Visual Basic
Public Const SocialShareDeliciousKey As String
Visual C++
public:
literal String^ SocialShareDeliciousKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareDiggKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareDiggKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' DiggButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareDiggKey
Visual Basic
Public Const SocialShareDiggKey As String
Visual C++
public:
literal String^ SocialShareDiggKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareFacebookKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareFacebookKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' Facebook key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareFacebookKey
Visual Basic
Public Const SocialShareFacebookKey As String
Visual C++
public:
literal String^ SocialShareFacebookKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareGoogleBookmarksKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareGoogleBookmarksKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' GoogleBookmarks Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareGoogleBookmarksKey
Visual Basic
Public Const SocialShareGoogleBookmarksKey As String
Visual C++
public:
literal String^ SocialShareGoogleBookmarksKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareKey
Visual Basic
Public Const SocialShareKey As String
Visual C++
public:
literal String^ SocialShareKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareLinkedInKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareLinkedInKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' LinkedIn Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareLinkedInKey
Visual Basic
Public Const SocialShareLinkedInKey As String
Visual C++
public:
literal String^ SocialShareLinkedInKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareMailToKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareMailToKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' MailTo Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareMailToKey
Visual Basic
Public Const SocialShareMailToKey As String
Visual C++
public:
literal String^ SocialShareMailToKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareMySpaceKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareMySpaceKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' MySpace Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareMySpaceKey
Visual Basic
Public Const SocialShareMySpaceKey As String
Visual C++
public:
literal String^ SocialShareMySpaceKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareRedditKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareRedditKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' Reddit Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareRedditKey
Visual Basic
Public Const SocialShareRedditKey As String
Visual C++
public:
literal String^ SocialShareRedditKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareSendEmailKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareSendEmailKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' SendEmail Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareSendEmailKey
Visual Basic
Public Const SocialShareSendEmailKey As String
Visual C++
public:
literal String^ SocialShareSendEmailKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareStumbleUponKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareStumbleUponKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' StumbleUpon Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareStumbleUponKey
Visual Basic
Public Const SocialShareStumbleUponKey As String
Visual C++
public:
literal String^ SocialShareStumbleUponKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareTumblrKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareTumblrKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' Tumblr Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareTumblrKey
Visual Basic
Public Const SocialShareTumblrKey As String
Visual C++
public:
literal String^ SocialShareTumblrKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareTweeterKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareConstants..::..SocialShareTweeterKey Field
SocialShareConstants Class See Also Send Feedback
The 'RadSocialShare' Tweeter Button key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SocialShareTweeterKey
Visual Basic
Public Const SocialShareTweeterKey As String
Visual C++
public:
literal String^ SocialShareTweeterKey

See Also

SocialShareConstants Class
Telerik.WebAii.Controls.Html Namespace


SocialShareDelicious Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious Members
SocialShareDelicious Class Constructors Methods Properties See Also Send Feedback

The SocialShareDelicious type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareDelicious()()()() | Initializes a new instance of the SocialSharePalette class.
Public method | SocialShareDelicious(Element) | Initializes a new instance of the SocialSharePalette class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareDelicious button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
Telerik.WebAii.Controls.Html Namespace


SocialShareDelicious Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious Constructor
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareDelicious()()()() | Initializes a new instance of the SocialSharePalette class.
Public method | SocialShareDelicious(Element) | Initializes a new instance of the SocialSharePalette class.

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


SocialShareDelicious Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious Constructor
SocialShareDelicious Class See Also Send Feedback
Initializes a new instance of the SocialSharePalette class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareDelicious()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareDelicious()

See Also

SocialShareDelicious Class
SocialShareDelicious Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareDelicious Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious Constructor (Element)
SocialShareDelicious Class See Also Send Feedback
Initializes a new instance of the SocialSharePalette class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareDelicious(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareDelicious(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareDelicious.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareDelicious Class
SocialShareDelicious Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareDelicious Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious Methods
SocialShareDelicious Class See Also Send Feedback

The SocialShareDelicious type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareDelicious Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..AssignElement Method
SocialShareDelicious Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareDelicious Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..CallMethod Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..Capture Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..Click Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..DragTo Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..GetValue Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..InvokeEvent Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..MouseClick Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..MouseHover Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..ScrollToVisible Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious..::..SetValue Method
SocialShareDelicious Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
SocialShareDelicious Members
Telerik.WebAii.Controls.Html Namespace


SocialShareDelicious Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDelicious Properties
SocialShareDelicious Class See Also Send Feedback

The SocialShareDelicious type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareDelicious button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareDelicious Class
Telerik.WebAii.Controls.Html Namespace


SocialShareDigg Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg Members
SocialShareDigg Class Constructors Methods Properties See Also Send Feedback

The SocialShareDigg type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareDigg()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareDigg(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareGigg button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
Telerik.WebAii.Controls.Html Namespace


SocialShareDigg Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg Constructor
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareDigg()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareDigg(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


SocialShareDigg Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg Constructor
SocialShareDigg Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareDigg()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareDigg()

See Also

SocialShareDigg Class
SocialShareDigg Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareDigg Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg Constructor (Element)
SocialShareDigg Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareDigg(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareDigg(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareDigg.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareDigg Class
SocialShareDigg Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareDigg Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg Methods
SocialShareDigg Class See Also Send Feedback

The SocialShareDigg type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareDigg Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..AssignElement Method
SocialShareDigg Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareDigg Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..CallMethod Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..Capture Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..Click Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..DragTo Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..GetValue Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..InvokeEvent Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..MouseClick Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..MouseHover Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..ScrollToVisible Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg..::..SetValue Method
SocialShareDigg Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
SocialShareDigg Members
Telerik.WebAii.Controls.Html Namespace


SocialShareDigg Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareDigg Properties
SocialShareDigg Class See Also Send Feedback

The SocialShareDigg type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareGigg button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareDigg Class
Telerik.WebAii.Controls.Html Namespace


SocialShareFacebook Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook Members
SocialShareFacebook Class Constructors Methods Properties See Also Send Feedback

The SocialShareFacebook type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareFacebook()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareFacebook(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareFacebook button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
Telerik.WebAii.Controls.Html Namespace


SocialShareFacebook Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook Constructor
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareFacebook()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareFacebook(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


SocialShareFacebook Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook Constructor
SocialShareFacebook Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareFacebook()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareFacebook()

See Also

SocialShareFacebook Class
SocialShareFacebook Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareFacebook Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook Constructor (Element)
SocialShareFacebook Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareFacebook(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareFacebook(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareFacebook.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareFacebook Class
SocialShareFacebook Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareFacebook Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook Methods
SocialShareFacebook Class See Also Send Feedback

The SocialShareFacebook type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareFacebook Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..AssignElement Method
SocialShareFacebook Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareFacebook Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..CallMethod Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..Capture Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..Click Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..DragTo Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..GetValue Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..InvokeEvent Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..MouseClick Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..MouseHover Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..ScrollToVisible Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook..::..SetValue Method
SocialShareFacebook Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
SocialShareFacebook Members
Telerik.WebAii.Controls.Html Namespace


SocialShareFacebook Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareFacebook Properties
SocialShareFacebook Class See Also Send Feedback

The SocialShareFacebook type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareFacebook button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareFacebook Class
Telerik.WebAii.Controls.Html Namespace


SocialShareGoogleBookmarks Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks Members
SocialShareGoogleBookmarks Class Constructors Methods Properties See Also Send Feedback

The SocialShareGoogleBookmarks type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareGoogleBookmarks()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareGoogleBookmarks(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare GoogleBookmarks button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
Telerik.WebAii.Controls.Html Namespace


SocialShareGoogleBookmarks Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks Constructor
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareGoogleBookmarks()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareGoogleBookmarks(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


SocialShareGoogleBookmarks Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks Constructor
SocialShareGoogleBookmarks Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareGoogleBookmarks()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareGoogleBookmarks()

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareGoogleBookmarks Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks Constructor (Element)
SocialShareGoogleBookmarks Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareGoogleBookmarks(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareGoogleBookmarks(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareGoogleBookmarks.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareGoogleBookmarks Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks Methods
SocialShareGoogleBookmarks Class See Also Send Feedback

The SocialShareGoogleBookmarks type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareGoogleBookmarks Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..AssignElement Method
SocialShareGoogleBookmarks Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareGoogleBookmarks Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..CallMethod Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..Capture Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..Click Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..DragTo Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..GetValue Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..InvokeEvent Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..MouseClick Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..MouseHover Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..ScrollToVisible Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks..::..SetValue Method
SocialShareGoogleBookmarks Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
SocialShareGoogleBookmarks Members
Telerik.WebAii.Controls.Html Namespace


SocialShareGoogleBookmarks Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareGoogleBookmarks Properties
SocialShareGoogleBookmarks Class See Also Send Feedback

The SocialShareGoogleBookmarks type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare GoogleBookmarks button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareGoogleBookmarks Class
Telerik.WebAii.Controls.Html Namespace


SocialShareLinkedIn Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn Members
SocialShareLinkedIn Class Constructors Methods Properties See Also Send Feedback

The SocialShareLinkedIn type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareLinkedIn()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareLinkedIn(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareLinkedIn button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
Telerik.WebAii.Controls.Html Namespace


SocialShareLinkedIn Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn Constructor
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareLinkedIn()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareLinkedIn(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


SocialShareLinkedIn Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn Constructor
SocialShareLinkedIn Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareLinkedIn()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareLinkedIn()

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareLinkedIn Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn Constructor (Element)
SocialShareLinkedIn Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareLinkedIn(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareLinkedIn(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareLinkedIn.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareLinkedIn Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn Methods
SocialShareLinkedIn Class See Also Send Feedback

The SocialShareLinkedIn type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareLinkedIn Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..AssignElement Method
SocialShareLinkedIn Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareLinkedIn Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..CallMethod Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..Capture Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..Click Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..DragTo Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..GetValue Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..InvokeEvent Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..MouseClick Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..MouseHover Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..ScrollToVisible Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn..::..SetValue Method
SocialShareLinkedIn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
SocialShareLinkedIn Members
Telerik.WebAii.Controls.Html Namespace


SocialShareLinkedIn Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareLinkedIn Properties
SocialShareLinkedIn Class See Also Send Feedback

The SocialShareLinkedIn type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareLinkedIn button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareLinkedIn Class
Telerik.WebAii.Controls.Html Namespace


SocialShareMailTo Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo Members
SocialShareMailTo Class Constructors Methods Properties See Also Send Feedback

The SocialShareMailTo type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareMailTo()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareMailTo(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareMailTo button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
Telerik.WebAii.Controls.Html Namespace


SocialShareMailTo Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo Constructor
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareMailTo()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareMailTo(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


SocialShareMailTo Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo Constructor
SocialShareMailTo Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareMailTo()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareMailTo()

See Also

SocialShareMailTo Class
SocialShareMailTo Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareMailTo Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo Constructor (Element)
SocialShareMailTo Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareMailTo(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareMailTo(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareMailTo.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareMailTo Class
SocialShareMailTo Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareMailTo Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo Methods
SocialShareMailTo Class See Also Send Feedback

The SocialShareMailTo type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareMailTo Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..AssignElement Method
SocialShareMailTo Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareMailTo Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..CallMethod Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..Capture Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..Click Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..DragTo Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..GetValue Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..InvokeEvent Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..MouseClick Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..MouseHover Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..ScrollToVisible Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo..::..SetValue Method
SocialShareMailTo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
SocialShareMailTo Members
Telerik.WebAii.Controls.Html Namespace


SocialShareMailTo Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMailTo Properties
SocialShareMailTo Class See Also Send Feedback

The SocialShareMailTo type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareMailTo button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareMailTo Class
Telerik.WebAii.Controls.Html Namespace


SocialShareMySpace Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace Members
SocialShareMySpace Class Constructors Methods Properties See Also Send Feedback

The SocialShareMySpace type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareMySpace()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareMySpace(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareMySpace button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
Telerik.WebAii.Controls.Html Namespace


SocialShareMySpace Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace Constructor
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareMySpace()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareMySpace(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


SocialShareMySpace Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace Constructor
SocialShareMySpace Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareMySpace()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareMySpace()

See Also

SocialShareMySpace Class
SocialShareMySpace Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareMySpace Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace Constructor (Element)
SocialShareMySpace Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareMySpace(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareMySpace(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareMySpace.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareMySpace Class
SocialShareMySpace Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareMySpace Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace Methods
SocialShareMySpace Class See Also Send Feedback

The SocialShareMySpace type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareMySpace Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..AssignElement Method
SocialShareMySpace Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareMySpace Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..CallMethod Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..Capture Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..Click Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..DragTo Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..GetValue Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..InvokeEvent Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..MouseClick Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..MouseHover Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..ScrollToVisible Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace..::..SetValue Method
SocialShareMySpace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
SocialShareMySpace Members
Telerik.WebAii.Controls.Html Namespace


SocialShareMySpace Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareMySpace Properties
SocialShareMySpace Class See Also Send Feedback

The SocialShareMySpace type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareMySpace button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareMySpace Class
Telerik.WebAii.Controls.Html Namespace


SocialShareReddit Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit Members
SocialShareReddit Class Constructors Methods Properties See Also Send Feedback

The SocialShareReddit type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareReddit()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareReddit(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareReddit button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
Telerik.WebAii.Controls.Html Namespace


SocialShareReddit Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit Constructor
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareReddit()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareReddit(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


SocialShareReddit Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit Constructor
SocialShareReddit Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareReddit()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareReddit()

See Also

SocialShareReddit Class
SocialShareReddit Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareReddit Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit Constructor (Element)
SocialShareReddit Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareReddit(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareReddit(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareReddit.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareReddit Class
SocialShareReddit Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareReddit Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit Methods
SocialShareReddit Class See Also Send Feedback

The SocialShareReddit type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareReddit Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..AssignElement Method
SocialShareReddit Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareReddit Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..CallMethod Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..Capture Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..Click Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..DragTo Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..GetValue Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..InvokeEvent Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..MouseClick Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..MouseHover Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..ScrollToVisible Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit..::..SetValue Method
SocialShareReddit Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
SocialShareReddit Members
Telerik.WebAii.Controls.Html Namespace


SocialShareReddit Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareReddit Properties
SocialShareReddit Class See Also Send Feedback

The SocialShareReddit type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShareReddit button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareReddit Class
Telerik.WebAii.Controls.Html Namespace


SocialShareSendEmail Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail Members
SocialShareSendEmail Class Constructors Methods Properties See Also Send Feedback

The SocialShareSendEmail type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareSendEmail()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareSendEmail(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare SendEmail button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
Telerik.WebAii.Controls.Html Namespace


SocialShareSendEmail Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail Constructor
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareSendEmail()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareSendEmail(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


SocialShareSendEmail Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail Constructor
SocialShareSendEmail Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareSendEmail()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareSendEmail()

See Also

SocialShareSendEmail Class
SocialShareSendEmail Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareSendEmail Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail Constructor (Element)
SocialShareSendEmail Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareSendEmail(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareSendEmail(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareSendEmail.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareSendEmail Class
SocialShareSendEmail Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareSendEmail Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail Methods
SocialShareSendEmail Class See Also Send Feedback

The SocialShareSendEmail type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareSendEmail Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..AssignElement Method
SocialShareSendEmail Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareSendEmail Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..CallMethod Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..Capture Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..Click Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..DragTo Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..GetValue Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..InvokeEvent Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..MouseClick Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..MouseHover Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..ScrollToVisible Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail..::..SetValue Method
SocialShareSendEmail Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
SocialShareSendEmail Members
Telerik.WebAii.Controls.Html Namespace


SocialShareSendEmail Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareSendEmail Properties
SocialShareSendEmail Class See Also Send Feedback

The SocialShareSendEmail type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare SendEmail button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareSendEmail Class
Telerik.WebAii.Controls.Html Namespace


SocialShareStumbleUpon Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon Members
SocialShareStumbleUpon Class Constructors Methods Properties See Also Send Feedback

The SocialShareStumbleUpon type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareStumbleUpon()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareStumbleUpon(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare Stumble Upon button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
Telerik.WebAii.Controls.Html Namespace


SocialShareStumbleUpon Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon Constructor
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareStumbleUpon()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareStumbleUpon(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


SocialShareStumbleUpon Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon Constructor
SocialShareStumbleUpon Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareStumbleUpon()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareStumbleUpon()

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareStumbleUpon Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon Constructor (Element)
SocialShareStumbleUpon Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareStumbleUpon(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareStumbleUpon(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareStumbleUpon.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareStumbleUpon Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon Methods
SocialShareStumbleUpon Class See Also Send Feedback

The SocialShareStumbleUpon type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareStumbleUpon Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..AssignElement Method
SocialShareStumbleUpon Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareStumbleUpon Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..CallMethod Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..Capture Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..Click Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..DragTo Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..GetValue Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..InvokeEvent Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..MouseClick Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..MouseHover Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..ScrollToVisible Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon..::..SetValue Method
SocialShareStumbleUpon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
SocialShareStumbleUpon Members
Telerik.WebAii.Controls.Html Namespace


SocialShareStumbleUpon Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareStumbleUpon Properties
SocialShareStumbleUpon Class See Also Send Feedback

The SocialShareStumbleUpon type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare Stumble Upon button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareStumbleUpon Class
Telerik.WebAii.Controls.Html Namespace


SocialShareTumblr Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr Members
SocialShareTumblr Class Constructors Methods Properties See Also Send Feedback

The SocialShareTumblr type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareTumblr()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareTumblr(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare Tumblr button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
Telerik.WebAii.Controls.Html Namespace


SocialShareTumblr Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr Constructor
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareTumblr()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareTumblr(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


SocialShareTumblr Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr Constructor
SocialShareTumblr Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareTumblr()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareTumblr()

See Also

SocialShareTumblr Class
SocialShareTumblr Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareTumblr Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr Constructor (Element)
SocialShareTumblr Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareTumblr(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareTumblr(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareTumblr.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareTumblr Class
SocialShareTumblr Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareTumblr Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr Methods
SocialShareTumblr Class See Also Send Feedback

The SocialShareTumblr type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareTumblr Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..AssignElement Method
SocialShareTumblr Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareTumblr Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..CallMethod Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..Capture Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..Click Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..DragTo Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..GetValue Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..InvokeEvent Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..MouseClick Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..MouseHover Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..ScrollToVisible Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr..::..SetValue Method
SocialShareTumblr Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
SocialShareTumblr Members
Telerik.WebAii.Controls.Html Namespace


SocialShareTumblr Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTumblr Properties
SocialShareTumblr Class See Also Send Feedback

The SocialShareTumblr type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare Tumblr button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareTumblr Class
Telerik.WebAii.Controls.Html Namespace


SocialShareTweeter Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter Members
SocialShareTweeter Class Constructors Methods Properties See Also Send Feedback

The SocialShareTweeter type exposes the following members.

Constructors

 | Name | Description
Public method | SocialShareTweeter()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareTweeter(Element) | Initializes a new instance of the SocialShare class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare Tweeter button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
Telerik.WebAii.Controls.Html Namespace


SocialShareTweeter Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter Constructor
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SocialShareTweeter()()()() | Initializes a new instance of the SocialShare class.
Public method | SocialShareTweeter(Element) | Initializes a new instance of the SocialShare class.

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


SocialShareTweeter Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter Constructor
SocialShareTweeter Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareTweeter()
Visual Basic
Public Sub New
Visual C++
public:
SocialShareTweeter()

See Also

SocialShareTweeter Class
SocialShareTweeter Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareTweeter Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter Constructor (Element)
SocialShareTweeter Class See Also Send Feedback
Initializes a new instance of the SocialShare class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public SocialShareTweeter(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
SocialShareTweeter(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.SocialShareTweeter.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

SocialShareTweeter Class
SocialShareTweeter Overload
Telerik.WebAii.Controls.Html Namespace


SocialShareTweeter Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter Methods
SocialShareTweeter Class See Also Send Feedback

The SocialShareTweeter type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlContainerControl..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

SocialShareTweeter Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..AssignElement Method
SocialShareTweeter Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

SocialShareTweeter Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..CallMethod Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..Capture Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..Click Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..DragTo Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..GetValue Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..InvokeEvent Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..MouseClick Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..MouseHover Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..ScrollToVisible Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter..::..SetValue Method
SocialShareTweeter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
SocialShareTweeter Members
Telerik.WebAii.Controls.Html Namespace


SocialShareTweeter Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SocialShareTweeter Properties
SocialShareTweeter Class See Also Send Feedback

The SocialShareTweeter type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Gets the HtmlFindExpression that defines the pattern for RadSocialShare. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | Text | Gets/Sets the SocialShare Tweeter button text value.
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

SocialShareTweeter Class
Telerik.WebAii.Controls.Html Namespace


SpellConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants Members
SpellConstants Class Fields See Also Send Feedback

The SpellConstants type exposes the following members.

Fields

Name | Description
CssInner | CSS of the inner spell dialog button span element.
CssLink | CSS of the outer spell dialog button link element.
CssRadSpellDialog | CSS class of the spell dialog div element.
IdButtonAddCustom | Id of the spell dialog "AddCustom" button.
IdButtonCancel | Id of the spell dialog "Close" button.
IdButtonChange | Id of the spell dialog "Change" button.
IdButtonChangeAll | Id of the spell dialog "ChangeAll" button.
IdButtonIgnore | Id of the spell dialog "Ignore" button.
IdButtonIgnoreAll | Id of the spell dialog "IgnoreAlll" button.
IdButtonUndo | Id of the spell dialog "Undo" button.
IdLink | Id of the outer spell dialog button link element.
IdLinkAddCustom | Id of the outer spell dialog "AddCustom" button link element.
IdLinkCancel | Id of the outer spell dialog "Close" button link element.
IdLinkChange | Id of the outer spell dialog "Change" button link element.
IdLinkChangeAll | Id of the outer spell dialog "ChangeAll" button link element.
IdLinkIgnore | Id of the outer spell dialog "Ignore" button link element.
IdLinkIgnoreAll | Id of the outer spell dialog "IgnoreAll" button link element.
IdLinkUndo | Id of the outer spell dialog "Undo" button link element.

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


SpellConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants Fields
SpellConstants Class See Also Send Feedback

The SpellConstants type exposes the following members.

Fields

Name | Description
CssInner | CSS of the inner spell dialog button span element.
CssLink | CSS of the outer spell dialog button link element.
CssRadSpellDialog | CSS class of the spell dialog div element.
IdButtonAddCustom | Id of the spell dialog "AddCustom" button.
IdButtonCancel | Id of the spell dialog "Close" button.
IdButtonChange | Id of the spell dialog "Change" button.
IdButtonChangeAll | Id of the spell dialog "ChangeAll" button.
IdButtonIgnore | Id of the spell dialog "Ignore" button.
IdButtonIgnoreAll | Id of the spell dialog "IgnoreAlll" button.
IdButtonUndo | Id of the spell dialog "Undo" button.
IdLink | Id of the outer spell dialog button link element.
IdLinkAddCustom | Id of the outer spell dialog "AddCustom" button link element.
IdLinkCancel | Id of the outer spell dialog "Close" button link element.
IdLinkChange | Id of the outer spell dialog "Change" button link element.
IdLinkChangeAll | Id of the outer spell dialog "ChangeAll" button link element.
IdLinkIgnore | Id of the outer spell dialog "Ignore" button link element.
IdLinkIgnoreAll | Id of the outer spell dialog "IgnoreAll" button link element.
IdLinkUndo | Id of the outer spell dialog "Undo" button link element.

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInner Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..CssInner Field
SpellConstants Class See Also Send Feedback
CSS of the inner spell dialog button span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssInner
Visual Basic
Public Const CssInner As String
Visual C++
public:
literal String^ CssInner

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


CssLink Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..CssLink Field
SpellConstants Class See Also Send Feedback
CSS of the outer spell dialog button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssLink
Visual Basic
Public Const CssLink As String
Visual C++
public:
literal String^ CssLink

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadSpellDialog Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..CssRadSpellDialog Field
SpellConstants Class See Also Send Feedback
CSS class of the spell dialog div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadSpellDialog
Visual Basic
Public Const CssRadSpellDialog As String
Visual C++
public:
literal String^ CssRadSpellDialog

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonAddCustom Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdButtonAddCustom Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "AddCustom" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdButtonAddCustom
Visual Basic
Public Const IdButtonAddCustom As String
Visual C++
public:
literal String^ IdButtonAddCustom

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonCancel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdButtonCancel Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "Close" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdButtonCancel
Visual Basic
Public Const IdButtonCancel As String
Visual C++
public:
literal String^ IdButtonCancel

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonChange Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdButtonChange Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "Change" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdButtonChange
Visual Basic
Public Const IdButtonChange As String
Visual C++
public:
literal String^ IdButtonChange

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonChangeAll Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdButtonChangeAll Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "ChangeAll" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdButtonChangeAll
Visual Basic
Public Const IdButtonChangeAll As String
Visual C++
public:
literal String^ IdButtonChangeAll

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonIgnore Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdButtonIgnore Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "Ignore" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdButtonIgnore
Visual Basic
Public Const IdButtonIgnore As String
Visual C++
public:
literal String^ IdButtonIgnore

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonIgnoreAll Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdButtonIgnoreAll Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "IgnoreAlll" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdButtonIgnoreAll
Visual Basic
Public Const IdButtonIgnoreAll As String
Visual C++
public:
literal String^ IdButtonIgnoreAll

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdButtonUndo Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdButtonUndo Field
SpellConstants Class See Also Send Feedback
Id of the spell dialog "Undo" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdButtonUndo
Visual Basic
Public Const IdButtonUndo As String
Visual C++
public:
literal String^ IdButtonUndo

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLink Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdLink Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdLink
Visual Basic
Public Const IdLink As String
Visual C++
public:
literal String^ IdLink

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkAddCustom Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdLinkAddCustom Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "AddCustom" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdLinkAddCustom
Visual Basic
Public Const IdLinkAddCustom As String
Visual C++
public:
literal String^ IdLinkAddCustom

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkCancel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdLinkCancel Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "Close" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdLinkCancel
Visual Basic
Public Const IdLinkCancel As String
Visual C++
public:
literal String^ IdLinkCancel

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkChange Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdLinkChange Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "Change" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdLinkChange
Visual Basic
Public Const IdLinkChange As String
Visual C++
public:
literal String^ IdLinkChange

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkChangeAll Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdLinkChangeAll Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "ChangeAll" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdLinkChangeAll
Visual Basic
Public Const IdLinkChangeAll As String
Visual C++
public:
literal String^ IdLinkChangeAll

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkIgnore Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdLinkIgnore Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "Ignore" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdLinkIgnore
Visual Basic
Public Const IdLinkIgnore As String
Visual C++
public:
literal String^ IdLinkIgnore

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkIgnoreAll Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdLinkIgnoreAll Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "IgnoreAll" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdLinkIgnoreAll
Visual Basic
Public Const IdLinkIgnoreAll As String
Visual C++
public:
literal String^ IdLinkIgnoreAll

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


IdLinkUndo Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SpellConstants..::..IdLinkUndo Field
SpellConstants Class See Also Send Feedback
Id of the outer spell dialog "Undo" button link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdLinkUndo
Visual Basic
Public Const IdLinkUndo As String
Visual C++
public:
literal String^ IdLinkUndo

See Also

SpellConstants Class
Telerik.WebAii.Controls.Html Namespace


SplitterConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants Members
SplitterConstants Class Fields See Also Send Feedback

The SplitterConstants type exposes the following members.

Fields

Name | Description
CssCollapseBar | The CSS class identifying the Splitter vertical collapsebar icon.
CssCollapseExpand | The CSS class identifying the Splitter collapse/expand icon.
CssExpandBar | The CSS class identifying the Splitter vertical expandbar icon.
CssHorizontalCollapseBar | The CSS class identifying the Splitter horizontal collapsebar icon.
CssHorizontalExpandBar | The CSS class identifying the Splitter horizontal expandbar icon.
CssPane | The CSS class identifying the Splitter pane control.
CssSlidingPane | The CSS class identifying the spliding pane.
CssSlidingPaneChildElement | The CSS class identifying the SplidingPane child HTML element(table).
CssSlidingPaneCommand1 | The 1st string from CSS class identifying the spliding pane command.
CssSlidingPaneCommand2 | The 2nd string from CSS class identifying the spliding pane command.
CssSlidingZone | The CSS class identifying the spliding zone control.
CssSlidingZoneTab | The CSS class identifying the spliding zone tab.
CssSplitBar | The CSS class identifying the Splitter splitbar control.
CssSplitter | The CSS class identifying the Splitter control.
IdPrefix | The ID prefix identifying the Splitter control.
KeyPane | The key representing the Splitter Pane.
KeySlidingPane | The key representing the Splitter Sliding Pane.
KeySlidingZone | The key representing the Splitter Sliding Zone.
KeySplitBar | The key representing the Splitter SplitBar.
TabPaneIdDifference | The string difference between tab id and pane id.

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


SplitterConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants Fields
SplitterConstants Class See Also Send Feedback

The SplitterConstants type exposes the following members.

Fields

Name | Description
CssCollapseBar | The CSS class identifying the Splitter vertical collapsebar icon.
CssCollapseExpand | The CSS class identifying the Splitter collapse/expand icon.
CssExpandBar | The CSS class identifying the Splitter vertical expandbar icon.
CssHorizontalCollapseBar | The CSS class identifying the Splitter horizontal collapsebar icon.
CssHorizontalExpandBar | The CSS class identifying the Splitter horizontal expandbar icon.
CssPane | The CSS class identifying the Splitter pane control.
CssSlidingPane | The CSS class identifying the spliding pane.
CssSlidingPaneChildElement | The CSS class identifying the SplidingPane child HTML element(table).
CssSlidingPaneCommand1 | The 1st string from CSS class identifying the spliding pane command.
CssSlidingPaneCommand2 | The 2nd string from CSS class identifying the spliding pane command.
CssSlidingZone | The CSS class identifying the spliding zone control.
CssSlidingZoneTab | The CSS class identifying the spliding zone tab.
CssSplitBar | The CSS class identifying the Splitter splitbar control.
CssSplitter | The CSS class identifying the Splitter control.
IdPrefix | The ID prefix identifying the Splitter control.
KeyPane | The key representing the Splitter Pane.
KeySlidingPane | The key representing the Splitter Sliding Pane.
KeySlidingZone | The key representing the Splitter Sliding Zone.
KeySplitBar | The key representing the Splitter SplitBar.
TabPaneIdDifference | The string difference between tab id and pane id.

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCollapseBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssCollapseBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter vertical collapsebar icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCollapseBar
Visual Basic
Public Const CssCollapseBar As String
Visual C++
public:
literal String^ CssCollapseBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCollapseExpand Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssCollapseExpand Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter collapse/expand icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCollapseExpand
Visual Basic
Public Const CssCollapseExpand As String
Visual C++
public:
literal String^ CssCollapseExpand

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpandBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssExpandBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter vertical expandbar icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExpandBar
Visual Basic
Public Const CssExpandBar As String
Visual C++
public:
literal String^ CssExpandBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHorizontalCollapseBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssHorizontalCollapseBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter horizontal collapsebar icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssHorizontalCollapseBar
Visual Basic
Public Const CssHorizontalCollapseBar As String
Visual C++
public:
literal String^ CssHorizontalCollapseBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHorizontalExpandBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssHorizontalExpandBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter horizontal expandbar icon.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssHorizontalExpandBar
Visual Basic
Public Const CssHorizontalExpandBar As String
Visual C++
public:
literal String^ CssHorizontalExpandBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPane Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssPane Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter pane control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPane
Visual Basic
Public Const CssPane As String
Visual C++
public:
literal String^ CssPane

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingPane Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssSlidingPane Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the spliding pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSlidingPane
Visual Basic
Public Const CssSlidingPane As String
Visual C++
public:
literal String^ CssSlidingPane

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingPaneChildElement Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssSlidingPaneChildElement Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the SplidingPane child HTML element(table).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSlidingPaneChildElement
Visual Basic
Public Const CssSlidingPaneChildElement As String
Visual C++
public:
literal String^ CssSlidingPaneChildElement

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingPaneCommand1 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssSlidingPaneCommand1 Field
SplitterConstants Class See Also Send Feedback
The 1st string from CSS class identifying the spliding pane command.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSlidingPaneCommand1
Visual Basic
Public Const CssSlidingPaneCommand1 As String
Visual C++
public:
literal String^ CssSlidingPaneCommand1

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingPaneCommand2 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssSlidingPaneCommand2 Field
SplitterConstants Class See Also Send Feedback
The 2nd string from CSS class identifying the spliding pane command.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSlidingPaneCommand2
Visual Basic
Public Const CssSlidingPaneCommand2 As String
Visual C++
public:
literal String^ CssSlidingPaneCommand2

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingZone Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssSlidingZone Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the spliding zone control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSlidingZone
Visual Basic
Public Const CssSlidingZone As String
Visual C++
public:
literal String^ CssSlidingZone

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSlidingZoneTab Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssSlidingZoneTab Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the spliding zone tab.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSlidingZoneTab
Visual Basic
Public Const CssSlidingZoneTab As String
Visual C++
public:
literal String^ CssSlidingZoneTab

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSplitBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssSplitBar Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter splitbar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSplitBar
Visual Basic
Public Const CssSplitBar As String
Visual C++
public:
literal String^ CssSplitBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSplitter Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..CssSplitter Field
SplitterConstants Class See Also Send Feedback
The CSS class identifying the Splitter control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSplitter
Visual Basic
Public Const CssSplitter As String
Visual C++
public:
literal String^ CssSplitter

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


IdPrefix Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..IdPrefix Field
SplitterConstants Class See Also Send Feedback
The ID prefix identifying the Splitter control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdPrefix
Visual Basic
Public Const IdPrefix As String
Visual C++
public:
literal String^ IdPrefix

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyPane Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..KeyPane Field
SplitterConstants Class See Also Send Feedback
The key representing the Splitter Pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyPane
Visual Basic
Public Const KeyPane As String
Visual C++
public:
literal String^ KeyPane

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


KeySlidingPane Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..KeySlidingPane Field
SplitterConstants Class See Also Send Feedback
The key representing the Splitter Sliding Pane.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeySlidingPane
Visual Basic
Public Const KeySlidingPane As String
Visual C++
public:
literal String^ KeySlidingPane

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


KeySlidingZone Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..KeySlidingZone Field
SplitterConstants Class See Also Send Feedback
The key representing the Splitter Sliding Zone.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeySlidingZone
Visual Basic
Public Const KeySlidingZone As String
Visual C++
public:
literal String^ KeySlidingZone

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


KeySplitBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..KeySplitBar Field
SplitterConstants Class See Also Send Feedback
The key representing the Splitter SplitBar.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeySplitBar
Visual Basic
Public Const KeySplitBar As String
Visual C++
public:
literal String^ KeySplitBar

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


TabPaneIdDifference Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
SplitterConstants..::..TabPaneIdDifference Field
SplitterConstants Class See Also Send Feedback
The string difference between tab id and pane id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TabPaneIdDifference
Visual Basic
Public Const TabPaneIdDifference As String
Visual C++
public:
literal String^ TabPaneIdDifference

See Also

SplitterConstants Class
Telerik.WebAii.Controls.Html Namespace


TabStripConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabStripConstants Members
TabStripConstants Class Fields See Also Send Feedback

The TabStripConstants type exposes the following members.

Fields

Name | Description
CssTab | The CSS class for the tab 'li' element.
CssTabLink | The CSS class for the tab link element.
CssTabStrip | The CSS class identifying the TabStrip 'div' element.
CssTabText | The CSS class for the tab text 'span' element.
TabKey | The Tab key used accross the classes.
TabStripKey | The TabStrip key used accross the classes.

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


TabStripConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabStripConstants Fields
TabStripConstants Class See Also Send Feedback

The TabStripConstants type exposes the following members.

Fields

Name | Description
CssTab | The CSS class for the tab 'li' element.
CssTabLink | The CSS class for the tab link element.
CssTabStrip | The CSS class identifying the TabStrip 'div' element.
CssTabText | The CSS class for the tab text 'span' element.
TabKey | The Tab key used accross the classes.
TabStripKey | The TabStrip key used accross the classes.

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTab Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabStripConstants..::..CssTab Field
TabStripConstants Class See Also Send Feedback
The CSS class for the tab 'li' element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTab
Visual Basic
Public Const CssTab As String
Visual C++
public:
literal String^ CssTab

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTabLink Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabStripConstants..::..CssTabLink Field
TabStripConstants Class See Also Send Feedback
The CSS class for the tab link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTabLink
Visual Basic
Public Const CssTabLink As String
Visual C++
public:
literal String^ CssTabLink

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTabStrip Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabStripConstants..::..CssTabStrip Field
TabStripConstants Class See Also Send Feedback
The CSS class identifying the TabStrip 'div' element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTabStrip
Visual Basic
Public Const CssTabStrip As String
Visual C++
public:
literal String^ CssTabStrip

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTabText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabStripConstants..::..CssTabText Field
TabStripConstants Class See Also Send Feedback
The CSS class for the tab text 'span' element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTabText
Visual Basic
Public Const CssTabText As String
Visual C++
public:
literal String^ CssTabText

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


TabKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabStripConstants..::..TabKey Field
TabStripConstants Class See Also Send Feedback
The Tab key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TabKey
Visual Basic
Public Const TabKey As String
Visual C++
public:
literal String^ TabKey

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


TabStripKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TabStripConstants..::..TabStripKey Field
TabStripConstants Class See Also Send Feedback
The TabStrip key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TabStripKey
Visual Basic
Public Const TabStripKey As String
Visual C++
public:
literal String^ TabStripKey

See Also

TabStripConstants Class
Telerik.WebAii.Controls.Html Namespace


TagCloudConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TagCloudConstants Members
TagCloudConstants Class Fields See Also Send Feedback

The TagCloudConstants type exposes the following members.

Fields

Name | Description
CssRadTagCloud | The base CSS class of the RadTagCloud wrapper element.
TagCloudKey | The 'TagCloud' key used across the source classes.

See Also

TagCloudConstants Class
Telerik.WebAii.Controls.Html Namespace


TagCloudConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TagCloudConstants Fields
TagCloudConstants Class See Also Send Feedback

The TagCloudConstants type exposes the following members.

Fields

Name | Description
CssRadTagCloud | The base CSS class of the RadTagCloud wrapper element.
TagCloudKey | The 'TagCloud' key used across the source classes.

See Also

TagCloudConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadTagCloud Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TagCloudConstants..::..CssRadTagCloud Field
TagCloudConstants Class See Also Send Feedback
The base CSS class of the RadTagCloud wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadTagCloud
Visual Basic
Public Const CssRadTagCloud As String
Visual C++
public:
literal String^ CssRadTagCloud

See Also

TagCloudConstants Class
Telerik.WebAii.Controls.Html Namespace


TagCloudKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TagCloudConstants..::..TagCloudKey Field
TagCloudConstants Class See Also Send Feedback
The 'TagCloud' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TagCloudKey
Visual Basic
Public Const TagCloudKey As String
Visual C++
public:
literal String^ TagCloudKey

See Also

TagCloudConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants Members
ToolBarConstants Class Fields See Also Send Feedback

The ToolBarConstants type exposes the following members.

Fields

Name | Description
CssToolBar | The CSS class identifying the ToolBar control.
CssToolBarButton | The CSS class identifying the ToolBar button.
CssToolBarButtonChoiceArrow | The CSS class identifying the ToolBar drop down and split button arrow.
CssToolBarDropDownButton | The CSS class identifying the ToolBar drop down button.
CssToolBarDropDownExpanded | The CSS class identifying the ToolBar drop down and split button expanded state.
CssToolBarItem | The CSS class identifying the ToolBar item.
CssToolBarItemText | The CSS class identifying the ToolBar item text span element.
CssToolBarItemWrap | The CSS class identifying the ToolBar item wrap link element.
CssToolBarSeparator | The CSS class identifying the ToolBar item separator.
CssToolBarSplitButton | The CSS class identifying the ToolBar split button.
DropDownButtonKey | The ToolBarDropDownButton key used across the source classes.
SplitButtonKey | The ToolBarSplitButton key used across the source classes.
ToolBar | The ToolBar key used across the source classes.
ToolBarButtonKey | The ToolBarButton key used across the source classes.
ToolBarItemKey | The ToolBarItem key used across the source classes.

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants Fields
ToolBarConstants Class See Also Send Feedback

The ToolBarConstants type exposes the following members.

Fields

Name | Description
CssToolBar | The CSS class identifying the ToolBar control.
CssToolBarButton | The CSS class identifying the ToolBar button.
CssToolBarButtonChoiceArrow | The CSS class identifying the ToolBar drop down and split button arrow.
CssToolBarDropDownButton | The CSS class identifying the ToolBar drop down button.
CssToolBarDropDownExpanded | The CSS class identifying the ToolBar drop down and split button expanded state.
CssToolBarItem | The CSS class identifying the ToolBar item.
CssToolBarItemText | The CSS class identifying the ToolBar item text span element.
CssToolBarItemWrap | The CSS class identifying the ToolBar item wrap link element.
CssToolBarSeparator | The CSS class identifying the ToolBar item separator.
CssToolBarSplitButton | The CSS class identifying the ToolBar split button.
DropDownButtonKey | The ToolBarDropDownButton key used across the source classes.
SplitButtonKey | The ToolBarSplitButton key used across the source classes.
ToolBar | The ToolBar key used across the source classes.
ToolBarButtonKey | The ToolBarButton key used across the source classes.
ToolBarItemKey | The ToolBarItem key used across the source classes.

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBar Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBar
Visual Basic
Public Const CssToolBar As String
Visual C++
public:
literal String^ CssToolBar

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarButton Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarButton
Visual Basic
Public Const CssToolBarButton As String
Visual C++
public:
literal String^ CssToolBarButton

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarButtonChoiceArrow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarButtonChoiceArrow Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar drop down and split button arrow.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarButtonChoiceArrow
Visual Basic
Public Const CssToolBarButtonChoiceArrow As String
Visual C++
public:
literal String^ CssToolBarButtonChoiceArrow

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarDropDownButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarDropDownButton Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar drop down button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarDropDownButton
Visual Basic
Public Const CssToolBarDropDownButton As String
Visual C++
public:
literal String^ CssToolBarDropDownButton

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarDropDownExpanded Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarDropDownExpanded Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar drop down and split button expanded state.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarDropDownExpanded
Visual Basic
Public Const CssToolBarDropDownExpanded As String
Visual C++
public:
literal String^ CssToolBarDropDownExpanded

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarItem Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarItem
Visual Basic
Public Const CssToolBarItem As String
Visual C++
public:
literal String^ CssToolBarItem

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarItemText Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarItemText Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar item text span element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarItemText
Visual Basic
Public Const CssToolBarItemText As String
Visual C++
public:
literal String^ CssToolBarItemText

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarItemWrap Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarItemWrap Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar item wrap link element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarItemWrap
Visual Basic
Public Const CssToolBarItemWrap As String
Visual C++
public:
literal String^ CssToolBarItemWrap

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarSeparator Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarSeparator Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar item separator.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarSeparator
Visual Basic
Public Const CssToolBarSeparator As String
Visual C++
public:
literal String^ CssToolBarSeparator

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolBarSplitButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..CssToolBarSplitButton Field
ToolBarConstants Class See Also Send Feedback
The CSS class identifying the ToolBar split button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolBarSplitButton
Visual Basic
Public Const CssToolBarSplitButton As String
Visual C++
public:
literal String^ CssToolBarSplitButton

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


DropDownButtonKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..DropDownButtonKey Field
ToolBarConstants Class See Also Send Feedback
The ToolBarDropDownButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DropDownButtonKey
Visual Basic
Public Const DropDownButtonKey As String
Visual C++
public:
literal String^ DropDownButtonKey

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


SplitButtonKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..SplitButtonKey Field
ToolBarConstants Class See Also Send Feedback
The ToolBarSplitButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string SplitButtonKey
Visual Basic
Public Const SplitButtonKey As String
Visual C++
public:
literal String^ SplitButtonKey

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..ToolBar Field
ToolBarConstants Class See Also Send Feedback
The ToolBar key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ToolBar
Visual Basic
Public Const ToolBar As String
Visual C++
public:
literal String^ ToolBar

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarButtonKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..ToolBarButtonKey Field
ToolBarConstants Class See Also Send Feedback
The ToolBarButton key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ToolBarButtonKey
Visual Basic
Public Const ToolBarButtonKey As String
Visual C++
public:
literal String^ ToolBarButtonKey

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolBarItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolBarConstants..::..ToolBarItemKey Field
ToolBarConstants Class See Also Send Feedback
The ToolBarItem key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ToolBarItemKey
Visual Basic
Public Const ToolBarItemKey As String
Visual C++
public:
literal String^ ToolBarItemKey

See Also

ToolBarConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolTipConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTipConstants Members
ToolTipConstants Class Fields See Also Send Feedback

The ToolTipConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the ToolTip's close button element.
CssToolTip | The CSS class identifying the ToolTip control.
KeyToolTip | The key representing the ToolTip control.
ToolTipIdPrefix | The ID prefix identifying the ToolTip control.

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolTipConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTipConstants Fields
ToolTipConstants Class See Also Send Feedback

The ToolTipConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the ToolTip's close button element.
CssToolTip | The CSS class identifying the ToolTip control.
KeyToolTip | The key representing the ToolTip control.
ToolTipIdPrefix | The ID prefix identifying the ToolTip control.

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCloseButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTipConstants..::..CssCloseButton Field
ToolTipConstants Class See Also Send Feedback
The CSS class identifying the ToolTip's close button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCloseButton
Visual Basic
Public Const CssCloseButton As String
Visual C++
public:
literal String^ CssCloseButton

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


CssToolTip Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTipConstants..::..CssToolTip Field
ToolTipConstants Class See Also Send Feedback
The CSS class identifying the ToolTip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssToolTip
Visual Basic
Public Const CssToolTip As String
Visual C++
public:
literal String^ CssToolTip

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyToolTip Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTipConstants..::..KeyToolTip Field
ToolTipConstants Class See Also Send Feedback
The key representing the ToolTip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyToolTip
Visual Basic
Public Const KeyToolTip As String
Visual C++
public:
literal String^ KeyToolTip

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


ToolTipIdPrefix Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
ToolTipConstants..::..ToolTipIdPrefix Field
ToolTipConstants Class See Also Send Feedback
The ID prefix identifying the ToolTip control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ToolTipIdPrefix
Visual Basic
Public Const ToolTipIdPrefix As String
Visual C++
public:
literal String^ ToolTipIdPrefix

See Also

ToolTipConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeListConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants Members
TreeListConstants Class Fields See Also Send Feedback

The TreeListConstants type exposes the following members.

Fields

Name | Description
ColumnKey | The TreeList column key used accross the verifications and action messages.
CssAdvancedPart | CSS class of the TreeList pager navigation buttons part div.
CssArrPart | The CSS class of the TreeList arrow part div.
CssCollapseButton | The CSS class of the collapse button.
CssCurrentPage | The CSS class of the current page button.
CssEditedItem | The CSS of the edited item.
CssEditForm | The CSS class of the EditForm div.
CssExpandButton | The CSS class of the expand button.
CssFirstCell | The CSS class of the first cell in the item containing data.
CssHeaderRow | The CSS class of the header row.
CssInsertButton | The Css of the insert item button.
CssLastPage | The CSS class of the "last page" button.
CssNumericPartDiv | The CSS class of the 'div' containing the numeric pages.
CssPageFirst | The CSS class of the "first page" button.
CssPageNext | The CSS class of the "next page" button.
CssPagePrevious | The CSS class of the "previous page" button.
CssPager | The CSS class of the TreeList Pager row.
CssPagerCell | The table cell containing the pager elements.
CssScrolling | The Css class of the data items container when scrolling is enabled.
CssSliderPagerLabel | The label of the slider pager.
CssSort | The CSS class of the TreeList sorting input button.
CssSortAscending | The ascending sort CSS class.
CssSortDescending | The descending sort CSS class.
CssStaticHeaderDiv | The Css class of the static header div.
CssTreeList | The TreeList CSS class.
CssTreeListFooter | The Css class of the footer row.
CssTreeListItem | The CSS class of the data item.
CssTreeListResizeToolTip | The TreeList resizing tooltip CSS class.
CssWrap | The CSS class of the TreeList pager wrapping div.
DataCellKey | The TreeList data cell key used accross the verifications and action messages.
DataItemKey | The TreeList Data Item key used accross the verifications and action messages.
FooterKey | The TreeList Footer key used accross the verifications and action messages.
HeaderKey | The TreeList header key used accross the verifications adn action messages.
IdCancelButton | The ID of the cancel button in the edit form.
IdChangePageSize | Id of the "change page size" Advanced Pager button.
IdDeleteButton | The ID of the Delete button.
IdEditButton | The ID of the Edit button.
IdExpandCollapseButton | Id of the expand/collapse button.
IdGoToPage | Id of the "go to page" Advanced Pager button.
IdInsertButton | The ID of the Add button.
IdSelectCheckBox | The id of the checkbox in the select column.
IdUpdateButton | The ID of the update button in the edit form.
PagerKey | The TreeList Pager key used accross the verifications and action messages.
TreeListKey | The TreeList key used accross the verifications and action messages.

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeListConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants Fields
TreeListConstants Class See Also Send Feedback

The TreeListConstants type exposes the following members.

Fields

Name | Description
ColumnKey | The TreeList column key used accross the verifications and action messages.
CssAdvancedPart | CSS class of the TreeList pager navigation buttons part div.
CssArrPart | The CSS class of the TreeList arrow part div.
CssCollapseButton | The CSS class of the collapse button.
CssCurrentPage | The CSS class of the current page button.
CssEditedItem | The CSS of the edited item.
CssEditForm | The CSS class of the EditForm div.
CssExpandButton | The CSS class of the expand button.
CssFirstCell | The CSS class of the first cell in the item containing data.
CssHeaderRow | The CSS class of the header row.
CssInsertButton | The Css of the insert item button.
CssLastPage | The CSS class of the "last page" button.
CssNumericPartDiv | The CSS class of the 'div' containing the numeric pages.
CssPageFirst | The CSS class of the "first page" button.
CssPageNext | The CSS class of the "next page" button.
CssPagePrevious | The CSS class of the "previous page" button.
CssPager | The CSS class of the TreeList Pager row.
CssPagerCell | The table cell containing the pager elements.
CssScrolling | The Css class of the data items container when scrolling is enabled.
CssSliderPagerLabel | The label of the slider pager.
CssSort | The CSS class of the TreeList sorting input button.
CssSortAscending | The ascending sort CSS class.
CssSortDescending | The descending sort CSS class.
CssStaticHeaderDiv | The Css class of the static header div.
CssTreeList | The TreeList CSS class.
CssTreeListFooter | The Css class of the footer row.
CssTreeListItem | The CSS class of the data item.
CssTreeListResizeToolTip | The TreeList resizing tooltip CSS class.
CssWrap | The CSS class of the TreeList pager wrapping div.
DataCellKey | The TreeList data cell key used accross the verifications and action messages.
DataItemKey | The TreeList Data Item key used accross the verifications and action messages.
FooterKey | The TreeList Footer key used accross the verifications and action messages.
HeaderKey | The TreeList header key used accross the verifications adn action messages.
IdCancelButton | The ID of the cancel button in the edit form.
IdChangePageSize | Id of the "change page size" Advanced Pager button.
IdDeleteButton | The ID of the Delete button.
IdEditButton | The ID of the Edit button.
IdExpandCollapseButton | Id of the expand/collapse button.
IdGoToPage | Id of the "go to page" Advanced Pager button.
IdInsertButton | The ID of the Add button.
IdSelectCheckBox | The id of the checkbox in the select column.
IdUpdateButton | The ID of the update button in the edit form.
PagerKey | The TreeList Pager key used accross the verifications and action messages.
TreeListKey | The TreeList key used accross the verifications and action messages.

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


ColumnKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..ColumnKey Field
TreeListConstants Class See Also Send Feedback
The TreeList column key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ColumnKey
Visual Basic
Public Const ColumnKey As String
Visual C++
public:
literal String^ ColumnKey

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAdvancedPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssAdvancedPart Field
TreeListConstants Class See Also Send Feedback
CSS class of the TreeList pager navigation buttons part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAdvancedPart
Visual Basic
Public Const CssAdvancedPart As String
Visual C++
public:
literal String^ CssAdvancedPart

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssArrPart Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssArrPart Field
TreeListConstants Class See Also Send Feedback
The CSS class of the TreeList arrow part div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssArrPart
Visual Basic
Public Const CssArrPart As String
Visual C++
public:
literal String^ CssArrPart

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCollapseButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssCollapseButton Field
TreeListConstants Class See Also Send Feedback
The CSS class of the collapse button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCollapseButton
Visual Basic
Public Const CssCollapseButton As String
Visual C++
public:
literal String^ CssCollapseButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCurrentPage Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssCurrentPage Field
TreeListConstants Class See Also Send Feedback
The CSS class of the current page button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCurrentPage
Visual Basic
Public Const CssCurrentPage As String
Visual C++
public:
literal String^ CssCurrentPage

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditedItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssEditedItem Field
TreeListConstants Class See Also Send Feedback
The CSS of the edited item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditedItem
Visual Basic
Public Const CssEditedItem As String
Visual C++
public:
literal String^ CssEditedItem

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssEditForm Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssEditForm Field
TreeListConstants Class See Also Send Feedback
The CSS class of the EditForm div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssEditForm
Visual Basic
Public Const CssEditForm As String
Visual C++
public:
literal String^ CssEditForm

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssExpandButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssExpandButton Field
TreeListConstants Class See Also Send Feedback
The CSS class of the expand button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssExpandButton
Visual Basic
Public Const CssExpandButton As String
Visual C++
public:
literal String^ CssExpandButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFirstCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssFirstCell Field
TreeListConstants Class See Also Send Feedback
The CSS class of the first cell in the item containing data.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFirstCell
Visual Basic
Public Const CssFirstCell As String
Visual C++
public:
literal String^ CssFirstCell

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssHeaderRow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssHeaderRow Field
TreeListConstants Class See Also Send Feedback
The CSS class of the header row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssHeaderRow
Visual Basic
Public Const CssHeaderRow As String
Visual C++
public:
literal String^ CssHeaderRow

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssInsertButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssInsertButton Field
TreeListConstants Class See Also Send Feedback
The Css of the insert item button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssInsertButton
Visual Basic
Public Const CssInsertButton As String
Visual C++
public:
literal String^ CssInsertButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssLastPage Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssLastPage Field
TreeListConstants Class See Also Send Feedback
The CSS class of the "last page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssLastPage
Visual Basic
Public Const CssLastPage As String
Visual C++
public:
literal String^ CssLastPage

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNumericPartDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssNumericPartDiv Field
TreeListConstants Class See Also Send Feedback
The CSS class of the 'div' containing the numeric pages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNumericPartDiv
Visual Basic
Public Const CssNumericPartDiv As String
Visual C++
public:
literal String^ CssNumericPartDiv

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageFirst Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssPageFirst Field
TreeListConstants Class See Also Send Feedback
The CSS class of the "first page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageFirst
Visual Basic
Public Const CssPageFirst As String
Visual C++
public:
literal String^ CssPageFirst

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPageNext Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssPageNext Field
TreeListConstants Class See Also Send Feedback
The CSS class of the "next page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPageNext
Visual Basic
Public Const CssPageNext As String
Visual C++
public:
literal String^ CssPageNext

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPagePrevious Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssPagePrevious Field
TreeListConstants Class See Also Send Feedback
The CSS class of the "previous page" button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPagePrevious
Visual Basic
Public Const CssPagePrevious As String
Visual C++
public:
literal String^ CssPagePrevious

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPager Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssPager Field
TreeListConstants Class See Also Send Feedback
The CSS class of the TreeList Pager row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPager
Visual Basic
Public Const CssPager As String
Visual C++
public:
literal String^ CssPager

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPagerCell Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssPagerCell Field
TreeListConstants Class See Also Send Feedback
The table cell containing the pager elements.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPagerCell
Visual Basic
Public Const CssPagerCell As String
Visual C++
public:
literal String^ CssPagerCell

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssScrolling Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssScrolling Field
TreeListConstants Class See Also Send Feedback
The Css class of the data items container when scrolling is enabled.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssScrolling
Visual Basic
Public Const CssScrolling As String
Visual C++
public:
literal String^ CssScrolling

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSliderPagerLabel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssSliderPagerLabel Field
TreeListConstants Class See Also Send Feedback
The label of the slider pager.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSliderPagerLabel
Visual Basic
Public Const CssSliderPagerLabel As String
Visual C++
public:
literal String^ CssSliderPagerLabel

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSort Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssSort Field
TreeListConstants Class See Also Send Feedback
The CSS class of the TreeList sorting input button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSort
Visual Basic
Public Const CssSort As String
Visual C++
public:
literal String^ CssSort

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSortAscending Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssSortAscending Field
TreeListConstants Class See Also Send Feedback
The ascending sort CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSortAscending
Visual Basic
Public Const CssSortAscending As String
Visual C++
public:
literal String^ CssSortAscending

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSortDescending Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssSortDescending Field
TreeListConstants Class See Also Send Feedback
The descending sort CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSortDescending
Visual Basic
Public Const CssSortDescending As String
Visual C++
public:
literal String^ CssSortDescending

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssStaticHeaderDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssStaticHeaderDiv Field
TreeListConstants Class See Also Send Feedback
The Css class of the static header div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssStaticHeaderDiv
Visual Basic
Public Const CssStaticHeaderDiv As String
Visual C++
public:
literal String^ CssStaticHeaderDiv

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTreeList Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssTreeList Field
TreeListConstants Class See Also Send Feedback
The TreeList CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTreeList
Visual Basic
Public Const CssTreeList As String
Visual C++
public:
literal String^ CssTreeList

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTreeListFooter Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssTreeListFooter Field
TreeListConstants Class See Also Send Feedback
The Css class of the footer row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTreeListFooter
Visual Basic
Public Const CssTreeListFooter As String
Visual C++
public:
literal String^ CssTreeListFooter

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTreeListItem Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssTreeListItem Field
TreeListConstants Class See Also Send Feedback
The CSS class of the data item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTreeListItem
Visual Basic
Public Const CssTreeListItem As String
Visual C++
public:
literal String^ CssTreeListItem

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTreeListResizeToolTip Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssTreeListResizeToolTip Field
TreeListConstants Class See Also Send Feedback
The TreeList resizing tooltip CSS class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTreeListResizeToolTip
Visual Basic
Public Const CssTreeListResizeToolTip As String
Visual C++
public:
literal String^ CssTreeListResizeToolTip

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


CssWrap Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..CssWrap Field
TreeListConstants Class See Also Send Feedback
The CSS class of the TreeList pager wrapping div.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssWrap
Visual Basic
Public Const CssWrap As String
Visual C++
public:
literal String^ CssWrap

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


DataCellKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..DataCellKey Field
TreeListConstants Class See Also Send Feedback
The TreeList data cell key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DataCellKey
Visual Basic
Public Const DataCellKey As String
Visual C++
public:
literal String^ DataCellKey

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


DataItemKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..DataItemKey Field
TreeListConstants Class See Also Send Feedback
The TreeList Data Item key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string DataItemKey
Visual Basic
Public Const DataItemKey As String
Visual C++
public:
literal String^ DataItemKey

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


FooterKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..FooterKey Field
TreeListConstants Class See Also Send Feedback
The TreeList Footer key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string FooterKey
Visual Basic
Public Const FooterKey As String
Visual C++
public:
literal String^ FooterKey

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


HeaderKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..HeaderKey Field
TreeListConstants Class See Also Send Feedback
The TreeList header key used accross the verifications adn action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string HeaderKey
Visual Basic
Public Const HeaderKey As String
Visual C++
public:
literal String^ HeaderKey

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdCancelButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdCancelButton Field
TreeListConstants Class See Also Send Feedback
The ID of the cancel button in the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdCancelButton
Visual Basic
Public Const IdCancelButton As String
Visual C++
public:
literal String^ IdCancelButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdChangePageSize Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdChangePageSize Field
TreeListConstants Class See Also Send Feedback
Id of the "change page size" Advanced Pager button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdChangePageSize
Visual Basic
Public Const IdChangePageSize As String
Visual C++
public:
literal String^ IdChangePageSize

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdDeleteButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdDeleteButton Field
TreeListConstants Class See Also Send Feedback
The ID of the Delete button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdDeleteButton
Visual Basic
Public Const IdDeleteButton As String
Visual C++
public:
literal String^ IdDeleteButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdEditButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdEditButton Field
TreeListConstants Class See Also Send Feedback
The ID of the Edit button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdEditButton
Visual Basic
Public Const IdEditButton As String
Visual C++
public:
literal String^ IdEditButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdExpandCollapseButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdExpandCollapseButton Field
TreeListConstants Class See Also Send Feedback
Id of the expand/collapse button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdExpandCollapseButton
Visual Basic
Public Const IdExpandCollapseButton As String
Visual C++
public:
literal String^ IdExpandCollapseButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdGoToPage Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdGoToPage Field
TreeListConstants Class See Also Send Feedback
Id of the "go to page" Advanced Pager button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdGoToPage
Visual Basic
Public Const IdGoToPage As String
Visual C++
public:
literal String^ IdGoToPage

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdInsertButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdInsertButton Field
TreeListConstants Class See Also Send Feedback
The ID of the Add button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdInsertButton
Visual Basic
Public Const IdInsertButton As String
Visual C++
public:
literal String^ IdInsertButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdSelectCheckBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdSelectCheckBox Field
TreeListConstants Class See Also Send Feedback
The id of the checkbox in the select column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdSelectCheckBox
Visual Basic
Public Const IdSelectCheckBox As String
Visual C++
public:
literal String^ IdSelectCheckBox

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


IdUpdateButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..IdUpdateButton Field
TreeListConstants Class See Also Send Feedback
The ID of the update button in the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdUpdateButton
Visual Basic
Public Const IdUpdateButton As String
Visual C++
public:
literal String^ IdUpdateButton

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


PagerKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..PagerKey Field
TreeListConstants Class See Also Send Feedback
The TreeList Pager key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string PagerKey
Visual Basic
Public Const PagerKey As String
Visual C++
public:
literal String^ PagerKey

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeListKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListConstants..::..TreeListKey Field
TreeListConstants Class See Also Send Feedback
The TreeList key used accross the verifications and action messages.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TreeListKey
Visual Basic
Public Const TreeListKey As String
Visual C++
public:
literal String^ TreeListKey

See Also

TreeListConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeListDataCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell Members
TreeListDataCell Class Constructors Methods Properties See Also Send Feedback

The TreeListDataCell type exposes the following members.

Constructors

 | Name | Description
Public method | TreeListDataCell()()()() | Initializes a new instance of the TreeListDataCell class.
Public method | TreeListDataCell(Element) | Initializes a new instance of the TreeListDataCell class.

Methods

 | Name | Description
Public method | AddButtonClick | Built-in 'Add' button click to add a child item to the current item. Throws InvalidOperationException if the button cannot be located.
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClientSelectCheckBoxClick | Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditButtonClick | Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandCollapseButtonClick | Expand/collapse button click to expand/collapse the item. Throws InvalidOperationException in case there is no expand/collapse button.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanEditItem | Get whether a built-in 'edit' item button is available in this cell so the item can be edited.
Public property | CanExpandCollapseItem | Get whether a built-in 'expand/collapse' item button is available in this cell so the parent item can be expanded/colapsed.
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this TreeList data cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent data item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


TreeListDataCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell Constructor
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TreeListDataCell()()()() | Initializes a new instance of the TreeListDataCell class.
Public method | TreeListDataCell(Element) | Initializes a new instance of the TreeListDataCell class.

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


TreeListDataCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell Constructor
TreeListDataCell Class See Also Send Feedback
Initializes a new instance of the TreeListDataCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListDataCell()
Visual Basic
Public Sub New
Visual C++
public:
TreeListDataCell()

See Also

TreeListDataCell Class
TreeListDataCell Overload
Telerik.WebAii.Controls.Html Namespace


TreeListDataCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell Constructor (Element)
TreeListDataCell Class See Also Send Feedback
Initializes a new instance of the TreeListDataCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListDataCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
TreeListDataCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.TreeListDataCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

TreeListDataCell Class
TreeListDataCell Overload
Telerik.WebAii.Controls.Html Namespace


TreeListDataCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell Methods
TreeListDataCell Class See Also Send Feedback

The TreeListDataCell type exposes the following members.

Methods

 | Name | Description
Public method | AddButtonClick | Built-in 'Add' button click to add a child item to the current item. Throws InvalidOperationException if the button cannot be located.
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClientSelectCheckBoxClick | Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | EditButtonClick | Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandCollapseButtonClick | Expand/collapse button click to expand/collapse the item. Throws InvalidOperationException in case there is no expand/collapse button.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


AddButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..AddButtonClick Method
TreeListDataCell Class See Also Send Feedback
Built-in 'Add' button click to add a child item to the current item. Throws InvalidOperationException if the button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void AddButtonClick()
Visual Basic
Public Sub AddButtonClick
Visual C++
public:
void AddButtonClick()

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..AssignElement Method
TreeListDataCell Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..CallMethod Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..Capture Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..Click Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


ClientSelectCheckBoxClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..ClientSelectCheckBoxClick Method
TreeListDataCell Class See Also Send Feedback
Client select column check box click to select/unselect the item. Throws InvalidOperationException if the client select column is not available.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClientSelectCheckBoxClick()
Visual Basic
Public Sub ClientSelectCheckBoxClick
Visual C++
public:
void ClientSelectCheckBoxClick()

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..ControlAssert Method
TreeListDataCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..DragTo Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


EditButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..EditButtonClick Method
TreeListDataCell Class See Also Send Feedback
Built-in 'Edit' button click to put the item in edit mode. Throws InvalidOperationException if the edit button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void EditButtonClick()
Visual Basic
Public Sub EditButtonClick
Visual C++
public:
void EditButtonClick()

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


ExpandCollapseButtonClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..ExpandCollapseButtonClick Method
TreeListDataCell Class See Also Send Feedback
Expand/collapse button click to expand/collapse the item. Throws InvalidOperationException in case there is no expand/collapse button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ExpandCollapseButtonClick()
Visual Basic
Public Sub ExpandCollapseButtonClick
Visual C++
public:
void ExpandCollapseButtonClick()

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..GetValue Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..InvokeEvent Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..MouseClick Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..MouseHover Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..ScrollToVisible Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell..::..SetValue Method
TreeListDataCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

TreeListDataCell Class
TreeListDataCell Members
Telerik.WebAii.Controls.Html Namespace


TreeListDataCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataCell Properties
TreeListDataCell Class See Also Send Feedback

The TreeListDataCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanEditItem | Get whether a built-in 'edit' item button is available in this cell so the item can be edited.
Public property | CanExpandCollapseItem | Get whether a built-in 'expand/collapse' item button is available in this cell so the parent item can be expanded/colapsed.
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this TreeList data cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ParentItemIndex | The parent data item index.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

TreeListDataCell Class
Telerik.WebAii.Controls.Html Namespace


TreeListDataItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem Members
TreeListDataItem Class Constructors Methods Properties See Also Send Feedback

The TreeListDataItem type exposes the following members.

Constructors

 | Name | Description
Public method | TreeListDataItem()()()() | Initializes a new instance of the TreeListDataItem class.
Public method | TreeListDataItem(Element) | Initializes a new instance of the TreeListDataItem class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapse the current item.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expand the current item.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
 | GetAbsoluteRowIndex | Gets the absolute (non-hierarchical) index of the row.
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
 | GetRowIndex | Gets the row index of a row.
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects the current item.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | AllCells | Get the list of item's data cells direct children.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanEdit | Get whether the item can be edited, e.g. whether the Grid parent table contains built-in edit column.
Public property | CanExpand | Get whether the item can be expanded.
Public property | CanSelect | Get whether the item can be selected, e.g. whether the TreeList has _clientSettings._selecting._allowItemSelection set to 'true'.
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the control client-side locator, determining which base script initializes the data item object on the client. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Edited | Gets whether the item is in edit mode.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Gets whether the item is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FirstDataCell | The first cell in the row which contains data.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Gets the global index of the row in the TreeList.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | LevelIndex | The index of the item for the level.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NestedLevel | The nested level of the Item. Zero based.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


TreeListDataItem Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem Constructor
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TreeListDataItem()()()() | Initializes a new instance of the TreeListDataItem class.
Public method | TreeListDataItem(Element) | Initializes a new instance of the TreeListDataItem class.

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


TreeListDataItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem Constructor
TreeListDataItem Class See Also Send Feedback
Initializes a new instance of the TreeListDataItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListDataItem()
Visual Basic
Public Sub New
Visual C++
public:
TreeListDataItem()

See Also

TreeListDataItem Class
TreeListDataItem Overload
Telerik.WebAii.Controls.Html Namespace


TreeListDataItem Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem Constructor (Element)
TreeListDataItem Class See Also Send Feedback
Initializes a new instance of the TreeListDataItem class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListDataItem(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
TreeListDataItem(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.TreeListDataItem.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

TreeListDataItem Class
TreeListDataItem Overload
Telerik.WebAii.Controls.Html Namespace


TreeListDataItem Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem Methods
TreeListDataItem Class See Also Send Feedback

The TreeListDataItem type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign a base element for this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Collapse | Collapse the current item.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Expand | Expand the current item.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
 | GetAbsoluteRowIndex | Gets the absolute (non-hierarchical) index of the row.
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
 | GetRowIndex | Gets the row index of a row.
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | Select | Selects the current item.
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..AssignElement Method
TreeListDataItem Class See Also Send Feedback
Assign a base element for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element associated with the control.

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..CallMethod Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..Capture Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..Click Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


Collapse Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..Collapse Method
TreeListDataItem Class See Also Send Feedback
Collapse the current item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Collapse()
Visual Basic
Public Sub Collapse
Visual C++
public:
void Collapse()

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..ControlAssert Method
TreeListDataItem Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..DragTo Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


Expand Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..Expand Method
TreeListDataItem Class See Also Send Feedback
Expand the current item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Expand()
Visual Basic
Public Sub Expand
Visual C++
public:
void Expand()

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


GetAbsoluteRowIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..GetAbsoluteRowIndex Method
TreeListDataItem Class See Also Send Feedback
Gets the absolute (non-hierarchical) index of the row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static int GetAbsoluteRowIndex(
    string id
)
Visual Basic
Public Shared Function GetAbsoluteRowIndex ( _
    id As String _
) As Integer
Visual C++
public:
static int GetAbsoluteRowIndex(
    String^ id
)

Parameters

id
Type: System..::..String
The Id of the row.

Return Value

The index of the row.

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


GetRowIndex Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..GetRowIndex Method
TreeListDataItem Class See Also Send Feedback
Gets the row index of a row.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public static int GetRowIndex(
    string id
)
Visual Basic
Public Shared Function GetRowIndex ( _
    id As String _
) As Integer
Visual C++
public:
static int GetRowIndex(
    String^ id
)

Parameters

id
Type: System..::..String
The Id of the row.

Return Value

The index of the row.

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..GetValue Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..InvokeEvent Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..MouseClick Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..MouseHover Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..ScrollToVisible Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..Select Method
TreeListDataItem Class See Also Send Feedback
Selects the current item.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
void Select()

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem..::..SetValue Method
TreeListDataItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
TreeListDataItem Members
Telerik.WebAii.Controls.Html Namespace


TreeListDataItem Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListDataItem Properties
TreeListDataItem Class See Also Send Feedback

The TreeListDataItem type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | AllCells | Get the list of item's data cells direct children.
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CanEdit | Get whether the item can be edited, e.g. whether the Grid parent table contains built-in edit column.
Public property | CanExpand | Get whether the item can be expanded.
Public property | CanSelect | Get whether the item can be selected, e.g. whether the TreeList has _clientSettings._selecting._allowItemSelection set to 'true'.
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Get the control client-side locator, determining which base script initializes the data item object on the client. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Edited | Gets whether the item is in edit mode.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Expanded | Gets whether the item is expanded.
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | FirstDataCell | The first cell in the row which contains data.
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | Index | Gets the global index of the row in the TreeList.
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | LevelIndex | The index of the item for the level.
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | NestedLevel | The nested level of the Item. Zero based.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Selected | Get whether the item is selected.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

TreeListDataItem Class
Telerik.WebAii.Controls.Html Namespace


TreeListEditForm Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm Members
TreeListEditForm Class Constructors Methods Properties See Also Send Feedback

The TreeListEditForm type exposes the following members.

Constructors

 | Name | Description
Public method | TreeListEditForm()()()() | Initializes a new instance of the TreeListEditForm class.
Public method | TreeListEditForm(Element) | Initializes a new instance of the TreeListEditForm class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Cancel | Performs 'cancel editing/inserting' action for the edit form.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | Insert | Performs 'insert item' action for the edit form.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Update | Performs 'update item' action for the edit form.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
Telerik.WebAii.Controls.Html Namespace


TreeListEditForm Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm Constructor
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TreeListEditForm()()()() | Initializes a new instance of the TreeListEditForm class.
Public method | TreeListEditForm(Element) | Initializes a new instance of the TreeListEditForm class.

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


TreeListEditForm Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm Constructor
TreeListEditForm Class See Also Send Feedback
Initializes a new instance of the TreeListEditForm class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListEditForm()
Visual Basic
Public Sub New
Visual C++
public:
TreeListEditForm()

See Also

TreeListEditForm Class
TreeListEditForm Overload
Telerik.WebAii.Controls.Html Namespace


TreeListEditForm Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm Constructor (Element)
TreeListEditForm Class See Also Send Feedback
Initializes a new instance of the TreeListEditForm class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListEditForm(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
TreeListEditForm(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.TreeListEditForm.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

TreeListEditForm Class
TreeListEditForm Overload
Telerik.WebAii.Controls.Html Namespace


TreeListEditForm Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm Methods
TreeListEditForm Class See Also Send Feedback

The TreeListEditForm type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlDiv..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Cancel | Performs 'cancel editing/inserting' action for the edit form.
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | Insert | Performs 'insert item' action for the edit form.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Public method | Update | Performs 'update item' action for the edit form.
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

TreeListEditForm Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..AssignElement Method
TreeListEditForm Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

TreeListEditForm Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..CallMethod Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


Cancel Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..Cancel Method
TreeListEditForm Class See Also Send Feedback
Performs 'cancel editing/inserting' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

See Also

TreeListEditForm Class
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..Capture Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..Click Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..DragTo Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..GetValue Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


Insert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..Insert Method
TreeListEditForm Class See Also Send Feedback
Performs 'insert item' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Insert()
Visual Basic
Public Sub Insert
Visual C++
public:
void Insert()

See Also

TreeListEditForm Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..InvokeEvent Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..MouseClick Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..MouseHover Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..ScrollToVisible Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..SetValue Method
TreeListEditForm Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
TreeListEditForm Members
Telerik.WebAii.Controls.Html Namespace


Update Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm..::..Update Method
TreeListEditForm Class See Also Send Feedback
Performs 'update item' action for the edit form.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Update()
Visual Basic
Public Sub Update
Visual C++
public:
void Update()

See Also

TreeListEditForm Class
Telerik.WebAii.Controls.Html Namespace


TreeListEditForm Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListEditForm Properties
TreeListEditForm Class See Also Send Feedback

The TreeListEditForm type exposes the following members.

Properties

 | Name | Description
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

TreeListEditForm Class
Telerik.WebAii.Controls.Html Namespace


TreeListFooterCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell Members
TreeListFooterCell Class Constructors Methods Properties See Also Send Feedback

The TreeListFooterCell type exposes the following members.

Constructors

 | Name | Description
Public method | TreeListFooterCell()()()() | Initializes a new instance of the TreeListFooterCell class.
Public method | TreeListFooterCell(Element) | Initializes a new instance of the TreeListFooterCell class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this TreeList footer cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

TreeListFooterCell Class
Telerik.WebAii.Controls.Html Namespace


TreeListFooterCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell Constructor
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TreeListFooterCell()()()() | Initializes a new instance of the TreeListFooterCell class.
Public method | TreeListFooterCell(Element) | Initializes a new instance of the TreeListFooterCell class.

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


TreeListFooterCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell Constructor
TreeListFooterCell Class See Also Send Feedback
Initializes a new instance of the TreeListFooterCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListFooterCell()
Visual Basic
Public Sub New
Visual C++
public:
TreeListFooterCell()

See Also

TreeListFooterCell Class
TreeListFooterCell Overload
Telerik.WebAii.Controls.Html Namespace


TreeListFooterCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell Constructor (Element)
TreeListFooterCell Class See Also Send Feedback
Initializes a new instance of the TreeListFooterCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListFooterCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
TreeListFooterCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.TreeListFooterCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

TreeListFooterCell Class
TreeListFooterCell Overload
Telerik.WebAii.Controls.Html Namespace


TreeListFooterCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell Methods
TreeListFooterCell Class See Also Send Feedback

The TreeListFooterCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign the control element. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

TreeListFooterCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..AssignElement Method
TreeListFooterCell Class See Also Send Feedback
Assign the control element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The underlying element object.

See Also

TreeListFooterCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..CallMethod Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..Capture Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..Click Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..ControlAssert Method
TreeListFooterCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

TreeListFooterCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..DragTo Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..GetValue Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..InvokeEvent Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..MouseClick Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..MouseHover Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..ScrollToVisible Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell..::..SetValue Method
TreeListFooterCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

TreeListFooterCell Class
TreeListFooterCell Members
Telerik.WebAii.Controls.Html Namespace


TreeListFooterCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListFooterCell Properties
TreeListFooterCell Class See Also Send Feedback

The TreeListFooterCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | CellText | The text of this TreeList footer cell.
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator FindParam. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

TreeListFooterCell Class
Telerik.WebAii.Controls.Html Namespace


TreeListHeaderCell Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell Members
TreeListHeaderCell Class Constructors Methods Properties See Also Send Feedback

The TreeListHeaderCell type exposes the following members.

Constructors

 | Name | Description
Public method | TreeListHeaderCell()()()() | Initializes a new instance of the TreeListHeaderCell class.
Public method | TreeListHeaderCell(Element) | Initializes a new instance of the TreeListHeaderCell class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClientSelectCheckBoxClick | Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InsertRootItem | Clicks the add button in the header cell.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Reorder(String) | Simulates drag and drop of the current header to reorder it with the target one.
Public method | Reorder(HtmlControl) | Simulates drag and drop of the current header to reorder it with the target one.
Public method | Resize | Simulates drag and drop of the current header to resize it.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Sort | Initiates a 'sort' action of the column.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the TreeListHeaderCell control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | ColumnIndex | The index of the column provided by the API.
Public property | ColumnWidth | The width of the column.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Reorderable | Get whether the column is reorderable.
Public property | Resizable | Get whether the columns is resizable.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SortOrder | The sort order of this column.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UniqueName | The unique name of this column.
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


TreeListHeaderCell Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell Constructor
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TreeListHeaderCell()()()() | Initializes a new instance of the TreeListHeaderCell class.
Public method | TreeListHeaderCell(Element) | Initializes a new instance of the TreeListHeaderCell class.

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


TreeListHeaderCell Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell Constructor
TreeListHeaderCell Class See Also Send Feedback
Initializes a new instance of the TreeListHeaderCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListHeaderCell()
Visual Basic
Public Sub New
Visual C++
public:
TreeListHeaderCell()

See Also

TreeListHeaderCell Class
TreeListHeaderCell Overload
Telerik.WebAii.Controls.Html Namespace


TreeListHeaderCell Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell Constructor (Element)
TreeListHeaderCell Class See Also Send Feedback
Initializes a new instance of the TreeListHeaderCell class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListHeaderCell(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
TreeListHeaderCell(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.TreeListHeaderCell.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

TreeListHeaderCell Class
TreeListHeaderCell Overload
Telerik.WebAii.Controls.Html Namespace


TreeListHeaderCell Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell Methods
TreeListHeaderCell Class See Also Send Feedback

The TreeListHeaderCell type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableCell..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ClientSelectCheckBoxClick | Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InsertRootItem | Clicks the add button in the header cell.
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | Reorder(String) | Simulates drag and drop of the current header to reorder it with the target one.
Public method | Reorder(HtmlControl) | Simulates drag and drop of the current header to reorder it with the target one.
Public method | Resize | Simulates drag and drop of the current header to resize it.
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | Sort | Initiates a 'sort' action of the column.
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..AssignElement Method
TreeListHeaderCell Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..CallMethod Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..Capture Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..Click Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


ClientSelectCheckBoxClick Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..ClientSelectCheckBoxClick Method
TreeListHeaderCell Class See Also Send Feedback
Click the client select check box in the header to select/unselect all the items. Throws InvalidOperationException if the client select column check box is not available.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ClientSelectCheckBoxClick()
Visual Basic
Public Sub ClientSelectCheckBoxClick
Visual C++
public:
void ClientSelectCheckBoxClick()

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..ControlAssert Method
TreeListHeaderCell Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..DragTo Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..GetValue Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


InsertRootItem Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..InsertRootItem Method
TreeListHeaderCell Class See Also Send Feedback
Clicks the add button in the header cell.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void InsertRootItem()
Visual Basic
Public Sub InsertRootItem
Visual C++
public:
void InsertRootItem()

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..InvokeEvent Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..MouseClick Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..MouseHover Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Reorder Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..Reorder Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Reorder(String) | Simulates drag and drop of the current header to reorder it with the target one.
Public method | Reorder(HtmlControl) | Simulates drag and drop of the current header to reorder it with the target one.

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Reorder Method (String)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..Reorder Method (String)
TreeListHeaderCell Class See Also Send Feedback
Simulates drag and drop of the current header to reorder it with the target one.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Reorder(
    string headerName
)
Visual Basic
Public Sub Reorder ( _
    headerName As String _
)
Visual C++
public:
void Reorder(
    String^ headerName
)

Parameters

headerName
Type: System..::..String
The name of the target header to reorder with.

Exceptions

Exception | Condition
System..::..ArgumentException | Thrown in case of invalid column unique name.

See Also

TreeListHeaderCell Class
Reorder Overload
Telerik.WebAii.Controls.Html Namespace


Reorder Method (HtmlControl)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..Reorder Method (HtmlControl)
TreeListHeaderCell Class See Also Send Feedback
Simulates drag and drop of the current header to reorder it with the target one.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Reorder(
    HtmlControl targetHeader
)
Visual Basic
Public Sub Reorder ( _
    targetHeader As HtmlControl _
)
Visual C++
public:
void Reorder(
    HtmlControl^ targetHeader
)

Parameters

targetHeader
Type: ArtOfTest.WebAii.Controls.HtmlControls..::..HtmlControl
The target header to reorder with.

Remarks

The column reordering in RadTreeList may interfere with the column resizing feature. This method might not be working if the column resizing is enabled as well.

See Also

TreeListHeaderCell Class
Reorder Overload
Telerik.WebAii.Controls.Html Namespace


Resize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..Resize Method
TreeListHeaderCell Class See Also Send Feedback
Simulates drag and drop of the current header to resize it.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Resize(
    int colWidth
)
Visual Basic
Public Sub Resize ( _
    colWidth As Integer _
)
Visual C++
public:
void Resize(
    int colWidth
)

Parameters

colWidth
Type: System..::..Int32
The width the column have to be resized to.

Remarks

The column resizing in RadTreeList may interfere with the column reordering feature. This method might not be working if the column reordering is enabled as well.

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..ScrollToVisible Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..SetValue Method
TreeListHeaderCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

TreeListHeaderCell Class
TreeListHeaderCell Members
Telerik.WebAii.Controls.Html Namespace


Sort Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell..::..Sort Method
TreeListHeaderCell Class See Also Send Feedback
Initiates a 'sort' action of the column.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void Sort()
Visual Basic
Public Sub Sort
Visual C++
public:
void Sort()

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


TreeListHeaderCell Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListHeaderCell Properties
TreeListHeaderCell Class See Also Send Feedback

The TreeListHeaderCell type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | CellIndex | Gets the position of a cell in the cells collection of a row (Inherited from HtmlTableCell.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | The client-side locator of the TreeListHeaderCell control. (Overrides HtmlControl..::..ClientSideLocator.)
Public property | ColSpan | Gets the number of columns a table cell should span (Inherited from HtmlTableCell.)
Public property | ColumnIndex | The index of the column provided by the API.
Public property | ColumnWidth | The width of the column.
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | Height | Gets the height of a table cell. (Inherited from HtmlTableCell.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the locator IFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | Reorderable | Get whether the column is reorderable.
Public property | Resizable | Get whether the columns is resizable.
Public property | RowSpan | Gets the number of rows a table cell should span. (Inherited from HtmlTableCell.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | SortOrder | The sort order of this column.
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | UniqueName | The unique name of this column.
Public property | VAlign | Gets the vertical alignment of data within a table cell. (Inherited from HtmlTableCell.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)
Public property | Width | Gets the width of a table cell. (Inherited from HtmlTableCell.)

See Also

TreeListHeaderCell Class
Telerik.WebAii.Controls.Html Namespace


TreeListPager Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager Members
TreeListPager Class Constructors Methods Properties See Also Send Feedback

The TreeListPager type exposes the following members.

Constructors

 | Name | Description
Public method | TreeListPager()()()() | Initializes a new instance of the TreeListPager class.
Public method | TreeListPager(Element) | Initializes a new instance of the TreeListPager class.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangePageSize | The Advanced Pager 'ChangePageSize' action.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GoToPage | The Advanced Pager 'GoToPage' action.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LoadFirstPage | Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.
Public method | LoadLastPage | Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.
Public method | LoadNextPage | Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.
Public method | LoadNextPages | Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.
Public method | LoadPage | Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.
Public method | LoadPreviousPage | Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.
Public method | LoadPreviousPages | Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | Get or set the current page index of the TreeList.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Mode | Get the pager mode.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


TreeListPager Constructor

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager Constructor
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TreeListPager()()()() | Initializes a new instance of the TreeListPager class.
Public method | TreeListPager(Element) | Initializes a new instance of the TreeListPager class.

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


TreeListPager Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager Constructor
TreeListPager Class See Also Send Feedback
Initializes a new instance of the TreeListPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListPager()
Visual Basic
Public Sub New
Visual C++
public:
TreeListPager()

See Also

TreeListPager Class
TreeListPager Overload
Telerik.WebAii.Controls.Html Namespace


TreeListPager Constructor (Element)

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager Constructor (Element)
TreeListPager Class See Also Send Feedback
Initializes a new instance of the TreeListPager class.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public TreeListPager(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
TreeListPager(
    Element^ element
)

Parameters

element
Type: ArtOfTest.WebAii.ObjectModel..::..Element

[Missing <param name="element"/> documentation for "M:Telerik.WebAii.Controls.Html.TreeListPager.#ctor(ArtOfTest.WebAii.ObjectModel.Element)"]

See Also

TreeListPager Class
TreeListPager Overload
Telerik.WebAii.Controls.Html Namespace


TreeListPager Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager Methods
TreeListPager Class See Also Send Feedback

The TreeListPager type exposes the following members.

Methods

 | Name | Description
Public method | AddEventListener | Add an event handler to a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | AssignElement | Assign element and initialize this control. (Overrides HtmlTableRow..::..AssignElement(Element).)
Protected method | AssignFailed | Mark the assignment to failed. Throw if the framework is set for throwing. (Inherited from Control.)
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)
Public method | ChangePageSize | The Advanced Pager 'ChangePageSize' action.
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)
Public method | ControlAssert | Returns RadControlAssert instance initialized for this control.
Public method | Download | Clicks a control using the MouseClick or Click and handles the download dialogs sequence that is produced. (Inherited from HtmlControl.)
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragToWindowLocation | Drag this HtmlControl, using the browser window as the drop target (Inherited from HtmlControl.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | FindParentContainer<(Of <<'(TContainerControl>)>>) | Traverses the DOM tree upwards until it finds the container element desired. (Inherited from HtmlControl.)
Public method | Focus | Give this Html element focus. (Inherited from HtmlControl.)
Protected method | GetAttributeAsString | Get an attribute of this element as a string (Inherited from HtmlControl.)
Public method | GetComputedStyle | Returns an HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetComputedStyleValue | Returns the computed value of the specified style. The computed style value represents the final computed value taking into account the CSS properties for this HtmlElement. (Inherited from HtmlControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRectangle | The absolute screen position and size of this HtmlControl. (Inherited from HtmlControl.)
Public method | GetStyle | Returns a HtmlStyle object that can be used to easily probe the style value. (i.e. convert unit styles to Int32 or color value to System.Drawing.Color) (Inherited from HtmlControl.)
Public method | GetStyleValue | Returns any style as if you are accessing the element.style object from JavaScript. (Inherited from HtmlControl.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GoToPage | The Advanced Pager 'GoToPage' action.
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)
Public method | IsVisible | Returns whether the html element is visible or not. Returns true only when computedStyle.display != 'none' && computedStyle.visibility != 'hidden' (Inherited from HtmlControl.)
Public method | LoadFirstPage | Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.
Public method | LoadLastPage | Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.
Public method | LoadNextPage | Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.
Public method | LoadNextPages | Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.
Public method | LoadPage | Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.
Public method | LoadPreviousPage | Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.
Public method | LoadPreviousPages | Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | Parent<(Of <<'(TContainerControl>)>>) | Return the parent HtmlContainerControl of the desired type that this HtmlControl is contained inside of. If a parent HtmlControl of the desired type is not found, will return null. (Inherited from HtmlControl.)
Public method | Refresh | Refresh this control within the current DOM and update this control property values. (Inherited from Control.)
Public method | RemoveEventListener | Removes an event handler from a Javascript event handler list on this HtmlControl. (Inherited from HtmlControl.)
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)
Public method | ToString | Builds and returns a string representation of this element. (Inherited from HtmlControl.)
Protected method | ValidateControl | Validate a HtmlControl using its LocatorExpression. (Inherited from HtmlControl.)
Protected method | ValidateTag | Validate a tag name (Inherited from HtmlControl.)

Extension Methods

 | Name | Description
Public Extension Method | AssertAttribute()()()() | Overloaded. Assert methods based on the HtmlControl's attributes. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertAttribute(Boolean) | Overloaded. Assert methods based on the HtmlControl's attributes (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertContent | Assert methods based on the HtmlControl's content. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle()()()() | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)
Public Extension Method | AssertStyle(Boolean) | Overloaded. Assert methods based on the HtmlControl's style. (Defined by HtmlControlsAssertExtensions.)

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


AssignElement Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..AssignElement Method
TreeListPager Class See Also Send Feedback
Assign element and initialize this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public override void AssignElement(
    Element e
)
Visual Basic
Public Overrides Sub AssignElement ( _
    e As Element _
)
Visual C++
public:
virtual void AssignElement(
    Element^ e
) override

Parameters

e
Type: ArtOfTest.WebAii.ObjectModel..::..Element
The element.

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


CallMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..CallMethod Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallMethod(String) | Call a client side Javascript method on this HtmlControl. (Inherited from HtmlControl.)
Public method | CallMethod<(Of <<'(T>)>>)(String, T) | Call a client side Javascript method on this HtmlControl with return type of T and a default return value. (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


Capture Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..Capture Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Capture()()()() | Captures and returns a bitmap image of this HtmlControl. (Inherited from HtmlControl.)
Public method | Capture(String) | Captures and saves this HtmlControl's image to the WebAii log location as a file. (Inherited from HtmlControl.)
Public method | Capture(String, String) | Captures and saves this HtmlControl's image to the specified save path as the specified file name as a BMP file. (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


ChangePageSize Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..ChangePageSize Method
TreeListPager Class See Also Send Feedback
The Advanced Pager 'ChangePageSize' action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void ChangePageSize()
Visual Basic
Public Sub ChangePageSize
Visual C++
public:
void ChangePageSize()

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


Click Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..Click Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Click()()()() | Invoke a click on this HtmlControl. (Inherited from HtmlControl.)
Public method | Click(Boolean) | Invoke a click on this HtmlControl that will cause its browser window to close (this is common for html pop-ups). (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


ControlAssert Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..ControlAssert Method
TreeListPager Class See Also Send Feedback
Returns RadControlAssert instance initialized for this control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public RadControlAssert ControlAssert()
Visual Basic
Public Function ControlAssert As RadControlAssert
Visual C++
public:
RadControlAssert^ ControlAssert()

Return Value

RadControlAssert instance initialized for this control.

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


DragTo Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..DragTo Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DragTo(Point) | Drag this HtmlControl to an absolute screen coordinate point. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl) | Drag this HtmlControl to the center on the destination HtmlControl. (Inherited from HtmlControl.)
Public method | DragTo(Int32, Int32) | Drag this HtmlControl to a relative X/Y offset. (Inherited from HtmlControl.)
Public method | DragTo(HtmlControl, OffsetReference, Point) | Drag to a destination HtmlControl with an offset of where within the destination HtmlControl to drag to. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from with an offset and drop on the destination HtmlControl center. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Point, HtmlControl, OffsetReference, Point) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Rectangle, OffsetReference, Int32, Int32) | Drag this HtmlControl from a source offset to an X/Y offset from the source. (Inherited from HtmlControl.)
Public method | DragTo(OffsetReference, Int32, Int32, Boolean, HtmlControl, OffsetReference, Int32, Int32, Boolean) | Drag this HtmlControl by specifying a reference point on the HtmlControl rectangle to start the drag from and a reference point on the destination HtmlControl to specify the drop location. (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


GetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..GetValue Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue<(Of <<'(T>)>>)(String) | Get a property value (e.g. control.border or control.style.backgroundColor). (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, T) | Get a property value (e.g. control.border or control.style.backgroundColor) and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)
Public method | GetValue<(Of <<'(T>)>>)(String, Boolean, T) | Get a property value (e.g. control.border or control.style.backgroundColor) with ability to specify wrappedJSObject's in Firefox and return the specified default value if the get fails for any reason. (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


GoToPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..GoToPage Method
TreeListPager Class See Also Send Feedback
The Advanced Pager 'GoToPage' action.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void GoToPage()
Visual Basic
Public Sub GoToPage
Visual C++
public:
void GoToPage()

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


InvokeEvent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..InvokeEvent Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeEvent(ScriptEvent) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEvent, Boolean) | Invokes an event on this HtmlControl. (Inherited from HtmlControl.)
Public method | InvokeEvent(ScriptEventType, Boolean) | (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


LoadFirstPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..LoadFirstPage Method
TreeListPager Class See Also Send Feedback
Initiates a load 'first' paging action to load the first page. Throws InvalidOperationException if the 'first page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadFirstPage()
Visual Basic
Public Sub LoadFirstPage
Visual C++
public:
void LoadFirstPage()

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


LoadLastPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..LoadLastPage Method
TreeListPager Class See Also Send Feedback
Initiates a load 'last' paging action to load the next page. Throws InvalidOperationException if the 'last page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadLastPage()
Visual Basic
Public Sub LoadLastPage
Visual C++
public:
void LoadLastPage()

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


LoadNextPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..LoadNextPage Method
TreeListPager Class See Also Send Feedback
Initiates a load 'next' paging action to load the next page. Throws InvalidOperationException if the 'next page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadNextPage()
Visual Basic
Public Sub LoadNextPage
Visual C++
public:
void LoadNextPage()

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


LoadNextPages Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..LoadNextPages Method
TreeListPager Class See Also Send Feedback
Initiates a load 'next pages' action to load the next pages. Throws InvalidOperationException if the 'next pages' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadNextPages()
Visual Basic
Public Sub LoadNextPages
Visual C++
public:
void LoadNextPages()

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..LoadPage Method
TreeListPager Class See Also Send Feedback
Initiates load page action for the given page number. Throws InvalidOperationException if the button with the given number cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPage(
    int pageNumber
)
Visual Basic
Public Sub LoadPage ( _
    pageNumber As Integer _
)
Visual C++
public:
void LoadPage(
    int pageNumber
)

Parameters

pageNumber
Type: System..::..Int32
The number of the page to be loaded.

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPreviousPage Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..LoadPreviousPage Method
TreeListPager Class See Also Send Feedback
Initiates a load 'previous' paging action to load the previous page. Throws InvalidOperationException if the 'previous page' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPreviousPage()
Visual Basic
Public Sub LoadPreviousPage
Visual C++
public:
void LoadPreviousPage()

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


LoadPreviousPages Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..LoadPreviousPages Method
TreeListPager Class See Also Send Feedback
Initiates a load 'previous pages' action to load the previous pages. Throws InvalidOperationException if the 'previous pages' button cannot be located.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public void LoadPreviousPages()
Visual Basic
Public Sub LoadPreviousPages
Visual C++
public:
void LoadPreviousPages()

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


MouseClick Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..MouseClick Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseClick()()()() | Uses the Desktop.Mouse object to move the mouse to this HtmlControl and click it. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType) | Uses the Desktop.Mouse object to move the mouse to the absolute center of this HtmlControl and simulate a left mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Point, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseClick(MouseClickType, Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to move the mouse to a point relative to this HtmlControl and simulate the specified mouse click. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


MouseHover Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..MouseHover Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MouseHover()()()() | Uses the Desktop.Mouse object to Hover over this absolute center of this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Point) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)
Public method | MouseHover(Int32, Int32, OffsetReference) | Uses the Desktop.Mouse object to Hover over a point relative to this HtmlControl. Be sure this HtmlControl is visible in the browser window first. Call ScrollToVisible(ScrollToVisibleType) or ScrollToVisible(ScrollToVisibleType, Rectangle)first if the element could be currently outside of the browsers window. (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..ScrollToVisible Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scroll the browsers window to make this HtmlControl visible on the page. This will method uses the ScrollToVisibleType.ElementTopAtWindowTop (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scroll the browsers window to make this HtmlControl visible on the page. (Inherited from HtmlControl.)
Public method | ScrollToVisible(ScrollToVisibleType, Rectangle) | Scroll the browsers window so that the specified rectangle within this HtmlControl is visible on the page. (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


SetValue Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager..::..SetValue Method
TreeListPager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue<(Of <<'(T>)>>)(String, T) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") (Inherited from HtmlControl.)
Public method | SetValue<(Of <<'(T>)>>)(String, T, Boolean) | Set a property value. (e.g. control.border = 2 or control.style.backgroundColor = "red") myControl.SetValue<string>("style.backgroundColor","red") (Inherited from HtmlControl.)

See Also

TreeListPager Class
TreeListPager Members
Telerik.WebAii.Controls.Html Namespace


TreeListPager Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeListPager Properties
TreeListPager Class See Also Send Feedback

The TreeListPager type exposes the following members.

Properties

 | Name | Description
Public property | Align | Gets the horizontal alignment of data within a table row. (Inherited from HtmlTableRow.)
Public property | Attributes | All attributes defined for this HtmlControl. (Inherited from HtmlControl.)
Public property | BaseElement | Gets the DOM element representing this test control (Inherited from Control.)
Public property | Cells | Return list of HtmlTableCells. (Inherited from HtmlTableRow.)
Public property | ChildNodes | Get all the child element nodes of this HtmlControl. (Inherited from HtmlControl.)
Public property | ClientSideLocator | Gets the client-side locator for this HtmlControl. This property can be used to define a custom client side object that this HtmlControl maps to. GetValue/SetValue properties use that object to make their calls instead of the default one. (Inherited from HtmlControl.)
Public property | CssClass | This HtmlControl's CSS class name. (Inherited from HtmlControl.)
Public property | CurrentPageIndex | Get or set the current page index of the TreeList.
Public property | Events | The list of events defined on this HtmlControl (Inherited from HtmlControl.)
Public property | Find | Find property (Inherited from HtmlControl.)
Public property | ID | This HtmlControl's ID. (Inherited from HtmlControl.)
Public property | InnerText | Gets the innerText of this container control. (Inherited from HtmlContainerControl.)
Public property | IsActiveElement | Gets whether this element has the keyboard focus (Inherited from HtmlControl.)
Public property | IsEnabled | Gets / sets whether this control is enabled (not disabled) (Inherited from HtmlControl.)
Public property | IsRefresh | Gets whether the control is executing a Refresh call. (Inherited from Control.)
Public property | Item | Return cell by its index in this row. (Inherited from HtmlTableRow.)
Public property | Locator | Gets the FindParam that describes this control. The base Control returns null. (Inherited from Control.)
Public property | LocatorExpression | Get the item locator HtmlFindExpression. (Overrides Control..::..LocatorExpression.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from HtmlControl.)
Public property | Mode | Get the pager mode.
Public property | OwnerBrowser | Gets the owner browser that owns this control. (Inherited from Control.)
Public property | RowIndex | Gets the position of a row in the table's rows collection. (Inherited from HtmlTableRow.)
Public property | ScrollLeft | Gets / Sets the scrollLeft value of this HtmlControl. (Inherited from HtmlControl.)
Public property | ScrollTop | Gets / Sets the scrollTop value of this HtmlControl. (Inherited from HtmlControl.)
Public property | Styles | Styles collection set on this HtmlControl and persisted in the Html stream. This collection does not contain computed styles. (Inherited from HtmlControl.)
Public property | TagName | The tag name of this HtmlControl. (Inherited from HtmlControl.)
Public property | TextContent | Gets the TextContent of this container control. (Inherited from HtmlContainerControl.)
Protected property | ThrowOnInvalidAssignment | Gets whether the control should throw on invalid assignments (Inherited from Control.)
Public property | Wait | Gets the HtmlWait object attached to this HtmlControl. (Inherited from HtmlControl.)

See Also

TreeListPager Class
Telerik.WebAii.Controls.Html Namespace


TreeViewConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants Members
TreeViewConstants Class Fields See Also Send Feedback

The TreeViewConstants type exposes the following members.

Fields

Name | Description
CssNodeCheckBox | The CSS class of the tree node check box.
CssNodeCollapse | The CSS class identifying the tree node is collapsed.
CssNodeDiv | The CSS class of the tree node inner div element.
CssNodeEdit | The CSS class of the tree node edit element.
CssNodeExpand | The CSS class identifying the tree node is expanded.
CssNodeImage | The CSS class of the tree node image element.
CssNodeLI | The CSS class of the tree node 'li' element.
CssNodeSelected | The CSS class identifying the tree node is selected.
CssNodeSpan | The CSS class of the tree node span element, could be HtmlAnchor in older versions though (2010).
CssNodeSpanTriStateCheckBoxChecked | The CSS class of the tree node span element checked tristate check box.
CssNodeSpanTriStateCheckBoxUnChecked | The CSS class of the tree node span element unchecked tristate check box.
CssNodeTriStateCheckBoxSpanUniversal | The CSS class of the tree node span element tristate checkbox.
CssTreeView | The CSS class of the tree.
TreeNodeKey | The TreeNode key used accross the classes.
TreeViewKey | The TreeView key used accross the classes.

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeViewConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants Fields
TreeViewConstants Class See Also Send Feedback

The TreeViewConstants type exposes the following members.

Fields

Name | Description
CssNodeCheckBox | The CSS class of the tree node check box.
CssNodeCollapse | The CSS class identifying the tree node is collapsed.
CssNodeDiv | The CSS class of the tree node inner div element.
CssNodeEdit | The CSS class of the tree node edit element.
CssNodeExpand | The CSS class identifying the tree node is expanded.
CssNodeImage | The CSS class of the tree node image element.
CssNodeLI | The CSS class of the tree node 'li' element.
CssNodeSelected | The CSS class identifying the tree node is selected.
CssNodeSpan | The CSS class of the tree node span element, could be HtmlAnchor in older versions though (2010).
CssNodeSpanTriStateCheckBoxChecked | The CSS class of the tree node span element checked tristate check box.
CssNodeSpanTriStateCheckBoxUnChecked | The CSS class of the tree node span element unchecked tristate check box.
CssNodeTriStateCheckBoxSpanUniversal | The CSS class of the tree node span element tristate checkbox.
CssTreeView | The CSS class of the tree.
TreeNodeKey | The TreeNode key used accross the classes.
TreeViewKey | The TreeView key used accross the classes.

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeCheckBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeCheckBox Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node check box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeCheckBox
Visual Basic
Public Const CssNodeCheckBox As String
Visual C++
public:
literal String^ CssNodeCheckBox

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeCollapse Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeCollapse Field
TreeViewConstants Class See Also Send Feedback
The CSS class identifying the tree node is collapsed.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeCollapse
Visual Basic
Public Const CssNodeCollapse As String
Visual C++
public:
literal String^ CssNodeCollapse

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeDiv Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeDiv Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node inner div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeDiv
Visual Basic
Public Const CssNodeDiv As String
Visual C++
public:
literal String^ CssNodeDiv

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeEdit Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeEdit Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node edit element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeEdit
Visual Basic
Public Const CssNodeEdit As String
Visual C++
public:
literal String^ CssNodeEdit

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeExpand Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeExpand Field
TreeViewConstants Class See Also Send Feedback
The CSS class identifying the tree node is expanded.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeExpand
Visual Basic
Public Const CssNodeExpand As String
Visual C++
public:
literal String^ CssNodeExpand

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeImage Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeImage Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node image element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeImage
Visual Basic
Public Const CssNodeImage As String
Visual C++
public:
literal String^ CssNodeImage

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeLI Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeLI Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node 'li' element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeLI
Visual Basic
Public Const CssNodeLI As String
Visual C++
public:
literal String^ CssNodeLI

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeSelected Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeSelected Field
TreeViewConstants Class See Also Send Feedback
The CSS class identifying the tree node is selected.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeSelected
Visual Basic
Public Const CssNodeSelected As String
Visual C++
public:
literal String^ CssNodeSelected

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeSpan Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeSpan Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node span element, could be HtmlAnchor in older versions though (2010).

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeSpan
Visual Basic
Public Const CssNodeSpan As String
Visual C++
public:
literal String^ CssNodeSpan

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeSpanTriStateCheckBoxChecked Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeSpanTriStateCheckBoxChecked Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node span element checked tristate check box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeSpanTriStateCheckBoxChecked
Visual Basic
Public Const CssNodeSpanTriStateCheckBoxChecked As String
Visual C++
public:
literal String^ CssNodeSpanTriStateCheckBoxChecked

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeSpanTriStateCheckBoxUnChecked Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeSpanTriStateCheckBoxUnChecked Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node span element unchecked tristate check box.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeSpanTriStateCheckBoxUnChecked
Visual Basic
Public Const CssNodeSpanTriStateCheckBoxUnChecked As String
Visual C++
public:
literal String^ CssNodeSpanTriStateCheckBoxUnChecked

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssNodeTriStateCheckBoxSpanUniversal Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssNodeTriStateCheckBoxSpanUniversal Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree node span element tristate checkbox.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssNodeTriStateCheckBoxSpanUniversal
Visual Basic
Public Const CssNodeTriStateCheckBoxSpanUniversal As String
Visual C++
public:
literal String^ CssNodeTriStateCheckBoxSpanUniversal

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


CssTreeView Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..CssTreeView Field
TreeViewConstants Class See Also Send Feedback
The CSS class of the tree.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssTreeView
Visual Basic
Public Const CssTreeView As String
Visual C++
public:
literal String^ CssTreeView

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeNodeKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..TreeNodeKey Field
TreeViewConstants Class See Also Send Feedback
The TreeNode key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TreeNodeKey
Visual Basic
Public Const TreeNodeKey As String
Visual C++
public:
literal String^ TreeNodeKey

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


TreeViewKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
TreeViewConstants..::..TreeViewKey Field
TreeViewConstants Class See Also Send Feedback
The TreeView key used accross the classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string TreeViewKey
Visual Basic
Public Const TreeViewKey As String
Visual C++
public:
literal String^ TreeViewKey

See Also

TreeViewConstants Class
Telerik.WebAii.Controls.Html Namespace


UploadConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants Members
UploadConstants Class Fields See Also Send Feedback

The UploadConstants type exposes the following members.

Fields

Name | Description
CssAddButton | CSS class of the 'Add' button.
CssCheckBox | CSS class of the 'Check' button.
CssClearButton | CSS class of the 'Clear' button.
CssDeleteButton | CSS class of the 'Delete' button.
CssFakeInput | CSS class of the 'fake' input
CssFileInput | CSS class of the file input.
CssRadUpload | CSS class of the upload main div element.
CssRemoveButton | CSS class of the 'Remove' button.
CssSelectButton | CSS class of the 'Select' button.
KeyUpload | The key identifying the Upload control.

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


UploadConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants Fields
UploadConstants Class See Also Send Feedback

The UploadConstants type exposes the following members.

Fields

Name | Description
CssAddButton | CSS class of the 'Add' button.
CssCheckBox | CSS class of the 'Check' button.
CssClearButton | CSS class of the 'Clear' button.
CssDeleteButton | CSS class of the 'Delete' button.
CssFakeInput | CSS class of the 'fake' input
CssFileInput | CSS class of the file input.
CssRadUpload | CSS class of the upload main div element.
CssRemoveButton | CSS class of the 'Remove' button.
CssSelectButton | CSS class of the 'Select' button.
KeyUpload | The key identifying the Upload control.

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssAddButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssAddButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Add' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssAddButton
Visual Basic
Public Const CssAddButton As String
Visual C++
public:
literal String^ CssAddButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCheckBox Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssCheckBox Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Check' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCheckBox
Visual Basic
Public Const CssCheckBox As String
Visual C++
public:
literal String^ CssCheckBox

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssClearButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssClearButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Clear' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssClearButton
Visual Basic
Public Const CssClearButton As String
Visual C++
public:
literal String^ CssClearButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssDeleteButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssDeleteButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Delete' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssDeleteButton
Visual Basic
Public Const CssDeleteButton As String
Visual C++
public:
literal String^ CssDeleteButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFakeInput Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssFakeInput Field
UploadConstants Class See Also Send Feedback
CSS class of the 'fake' input

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFakeInput
Visual Basic
Public Const CssFakeInput As String
Visual C++
public:
literal String^ CssFakeInput

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssFileInput Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssFileInput Field
UploadConstants Class See Also Send Feedback
CSS class of the file input.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssFileInput
Visual Basic
Public Const CssFileInput As String
Visual C++
public:
literal String^ CssFileInput

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRadUpload Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssRadUpload Field
UploadConstants Class See Also Send Feedback
CSS class of the upload main div element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRadUpload
Visual Basic
Public Const CssRadUpload As String
Visual C++
public:
literal String^ CssRadUpload

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssRemoveButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssRemoveButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Remove' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssRemoveButton
Visual Basic
Public Const CssRemoveButton As String
Visual C++
public:
literal String^ CssRemoveButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


CssSelectButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..CssSelectButton Field
UploadConstants Class See Also Send Feedback
CSS class of the 'Select' button.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssSelectButton
Visual Basic
Public Const CssSelectButton As String
Visual C++
public:
literal String^ CssSelectButton

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyUpload Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
UploadConstants..::..KeyUpload Field
UploadConstants Class See Also Send Feedback
The key identifying the Upload control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyUpload
Visual Basic
Public Const KeyUpload As String
Visual C++
public:
literal String^ KeyUpload

See Also

UploadConstants Class
Telerik.WebAii.Controls.Html Namespace


WindowConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants Members
WindowConstants Class Fields See Also Send Feedback

The WindowConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the Window's close button element.
CssMaximizeButton | The CSS class identifying the Window's maximize button element.
CssMinimizeButton | The CSS class identifying the Window's minimize button element.
CssPinButton | The CSS class identifying the Window's pin button element.
CssReloadButton | The CSS class identifying the Window's reload button element.
CssResizeBorder1 | The CSS class identifying the Window's div element, which handles top resize.
CssResizeBorder2 | The CSS class identifying the Window's table cell element, which handles bottom resize.
CssResizeBorder3 | The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.
CssStatusBar | The CSS class identifying the Window's statusbar element.
CssWindow | The CSS class identifying the Window control.
IdPrefix | The string that is prefix in window Id.
KeyWindow | The name identifying the Window control.

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


WindowConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants Fields
WindowConstants Class See Also Send Feedback

The WindowConstants type exposes the following members.

Fields

Name | Description
CssCloseButton | The CSS class identifying the Window's close button element.
CssMaximizeButton | The CSS class identifying the Window's maximize button element.
CssMinimizeButton | The CSS class identifying the Window's minimize button element.
CssPinButton | The CSS class identifying the Window's pin button element.
CssReloadButton | The CSS class identifying the Window's reload button element.
CssResizeBorder1 | The CSS class identifying the Window's div element, which handles top resize.
CssResizeBorder2 | The CSS class identifying the Window's table cell element, which handles bottom resize.
CssResizeBorder3 | The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.
CssStatusBar | The CSS class identifying the Window's statusbar element.
CssWindow | The CSS class identifying the Window control.
IdPrefix | The string that is prefix in window Id.
KeyWindow | The name identifying the Window control.

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssCloseButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssCloseButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's close button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssCloseButton
Visual Basic
Public Const CssCloseButton As String
Visual C++
public:
literal String^ CssCloseButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMaximizeButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssMaximizeButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's maximize button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMaximizeButton
Visual Basic
Public Const CssMaximizeButton As String
Visual C++
public:
literal String^ CssMaximizeButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssMinimizeButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssMinimizeButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's minimize button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssMinimizeButton
Visual Basic
Public Const CssMinimizeButton As String
Visual C++
public:
literal String^ CssMinimizeButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssPinButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssPinButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's pin button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssPinButton
Visual Basic
Public Const CssPinButton As String
Visual C++
public:
literal String^ CssPinButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssReloadButton Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssReloadButton Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's reload button element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssReloadButton
Visual Basic
Public Const CssReloadButton As String
Visual C++
public:
literal String^ CssReloadButton

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssResizeBorder1 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssResizeBorder1 Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's div element, which handles top resize.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssResizeBorder1
Visual Basic
Public Const CssResizeBorder1 As String
Visual C++
public:
literal String^ CssResizeBorder1

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssResizeBorder2 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssResizeBorder2 Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's table cell element, which handles bottom resize.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssResizeBorder2
Visual Basic
Public Const CssResizeBorder2 As String
Visual C++
public:
literal String^ CssResizeBorder2

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssResizeBorder3 Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssResizeBorder3 Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's table cell element, which handles resize actions: to left, to right and to diagonals.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssResizeBorder3
Visual Basic
Public Const CssResizeBorder3 As String
Visual C++
public:
literal String^ CssResizeBorder3

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssStatusBar Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssStatusBar Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window's statusbar element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssStatusBar
Visual Basic
Public Const CssStatusBar As String
Visual C++
public:
literal String^ CssStatusBar

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


CssWindow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..CssWindow Field
WindowConstants Class See Also Send Feedback
The CSS class identifying the Window control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string CssWindow
Visual Basic
Public Const CssWindow As String
Visual C++
public:
literal String^ CssWindow

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


IdPrefix Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..IdPrefix Field
WindowConstants Class See Also Send Feedback
The string that is prefix in window Id.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string IdPrefix
Visual Basic
Public Const IdPrefix As String
Visual C++
public:
literal String^ IdPrefix

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


KeyWindow Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
WindowConstants..::..KeyWindow Field
WindowConstants Class See Also Send Feedback
The name identifying the Window control.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string KeyWindow
Visual Basic
Public Const KeyWindow As String
Visual C++
public:
literal String^ KeyWindow

See Also

WindowConstants Class
Telerik.WebAii.Controls.Html Namespace


XmlHttpPanelConstants Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XmlHttpPanelConstants Members
XmlHttpPanelConstants Class Fields See Also Send Feedback

The XmlHttpPanelConstants type exposes the following members.

Fields

Name | Description
ClassRadXmlHttpPanel | The virtual base id of the RadXmlHttpPanel wrapper element.
XmlHttpPanelKey | The 'XmlHttpPanel' key used across the source classes.

See Also

XmlHttpPanelConstants Class
Telerik.WebAii.Controls.Html Namespace


XmlHttpPanelConstants Fields

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XmlHttpPanelConstants Fields
XmlHttpPanelConstants Class See Also Send Feedback

The XmlHttpPanelConstants type exposes the following members.

Fields

Name | Description
ClassRadXmlHttpPanel | The virtual base id of the RadXmlHttpPanel wrapper element.
XmlHttpPanelKey | The 'XmlHttpPanel' key used across the source classes.

See Also

XmlHttpPanelConstants Class
Telerik.WebAii.Controls.Html Namespace


ClassRadXmlHttpPanel Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XmlHttpPanelConstants..::..ClassRadXmlHttpPanel Field
XmlHttpPanelConstants Class See Also Send Feedback
The virtual base id of the RadXmlHttpPanel wrapper element.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string ClassRadXmlHttpPanel
Visual Basic
Public Const ClassRadXmlHttpPanel As String
Visual C++
public:
literal String^ ClassRadXmlHttpPanel

See Also

XmlHttpPanelConstants Class
Telerik.WebAii.Controls.Html Namespace


XmlHttpPanelKey Field

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
XmlHttpPanelConstants..::..XmlHttpPanelKey Field
XmlHttpPanelConstants Class See Also Send Feedback
The 'XmlHttpPanel' key used across the source classes.

Namespace: Telerik.WebAii.Controls.Html
Assembly: Telerik.WebAii.Controls.Html (in Telerik.WebAii.Controls.Html.dll) Version: 2012.1.411.0 (2012.1.411.0)

Syntax

C#
public const string XmlHttpPanelKey
Visual Basic
Public Const XmlHttpPanelKey As String
Visual C++
public:
literal String^ XmlHttpPanelKey

See Also

XmlHttpPanelConstants Class
Telerik.WebAii.Controls.Html Namespace


Telerik.WebAii.Controls.Xaml Namespace

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
Telerik.WebAii.Controls.Xaml Namespace
Send Feedback
Namespace for all the XAML control wrapper classes.

Classes

 | Class | Description
Public class | AdaptiveMovingAverageKaufmanIndicator | Represents the AdaptiveMovingAverageKaufmanIndicator for ChartView control wrapper.
Public class | AggregateResultsList | Represents the RadGridView for Silverlight/WPF AggregateResultsList control wrapper.
Public class | AppointmentElement | The ScheduleView AppointmentItem wrapper.
Public class | AppointmentItem | The Scheduler AppointmentItem wrapper.
Public class | AppointmentItemDialog | Represents the Scheduler appointment item dialog window wrapper.
Public class | AppointmentsControl | The AppointmentsControl serves as a holder for the TimeSlot and Appointment lists.
Public class | AreaSeries | Represents the AreaSeries for RadCartesianChart Silverlight control wrapper.
Public class | AutoHideArea | Represents the RadDocking for Silverlight AutoHideArea control wrapper.
Public class | AverageTrueRangeIndicator | Represents the AverageTrueRangeIndicator for ChartView control wrapper.
Public class | BarItem | Represents the BulletGraph for Silverlight BarItem control wrapper.
Public class | BarSeries | Represents the BarSeries for RadCartesianChart Silverlight control wrapper.
Public class | BarStackPanel | Represents the BulletGraph for Silverlight BarStackPanel control wrapper.
Public class | BollingerBandsIndicator | Represents the BollingerBandsIndicator for ChartView control wrapper.
Public class | CalendarButton | Represents the RadCalendarButton custom control wrapper.
Public class | CalendarElementNames | Holds the list of the important Calendar element names.
Public class | CalendarPanel | The Calendar panel holding the CalendarButtons.
Public class | CalendarView | Represents the RadCalendar for Silverlight CalendarView control.
Public class | Candlestick | Represents the Candlestick for RadCartesianChart Silverlight control wrapper.
Public class | CandlestickSeries | Represents the CandlestickSeries for RadCartesianChart Silverlight control wrapper.
Public class | CartesianChartGrid | Represents the CartesianChartGrid for RadCartesianChart Silverlight control wrapper.
Public class | CategoricalAxis | Represents the CategoricalAxis for RadCartesianChart Silverlight control wrapper.
Public class | CategoricalRadialAxis | Represents the CategoricalRadialAxis for RadPolarChart Silverlight control wrapper.
Public class | Chart3DLabels | Represents the RadChart for Silverlight Chart3DLabels control wrapper.
Public class | Chart3DLabelsText | Represents the RadChart for Silverlight Chart3DLabelsText control wrapper.
Public class | Chart3DLayoutTransformControl | Represents the RadChart for Silverlight Chart3DLayoutTransformControl control wrapper.
Public class | Chart3DTitleLabels | Represents the RadChart for Silverlight Chart3DTitleLabels control wrapper.
Public class | ChartArea | Represents the RadChart for Silverlight ChartArea control wrapper.
Public class | ChartAxisTitle | Represents the RadChart for Silverlight ChartAxisTitle control wrapper.
Public class | ChartAxisX | Represents the RadChart for Silverlight RadChartAxisX control wrapper.
Public class | ChartAxisY | Represents the RadChart for Silverlight RadChartAxisY control wrapper.
Public class | ChartHorizontalGridLines | Represents the RadChart for Silverlight ChartHorizontalGridLines control wrapper.
Public class | ChartHorizontalGridLines2D | Represents the RadChart for Silverlight ChartHorizontalGridLines2D control wrapper.
Public class | ChartHorizontalMinorTicks2D | Represents the RadChart for Silverlight ChartHorizontalMinorTicks2D control wrapper.
Public class | ChartHorizontalStripLines | Represents the RadChart for Silverlight ChartHorizontalStripLines control wrapper.
Public class | ChartHorizontalStripLines2D | Represents the RadChart for Silverlight ChartHorizontalStripLines2D control wrapper.
Public class | ChartLegend | Represents the RadChart for Silverlight ChartLegend control wrapper.
Public class | ChartLegendItem | Represents the RadChart for Silverlight ChartLegendItem control wrapper.
Public class | ChartNoDataControl | Represents the RadChart for Silverlight ChartNoData control wrapper.
Public class | ChartPanel | The Chart series panel holder.
Public class | ChartPlotAreaAxisX2D | Represents the RadChart for Silverlight ChartPlotAreaAxisX2D control wrapper.
Public class | ChartPlotAreaAxisY2D | Represents the RadChart for Silverlight ChartPlotAreaAxisY2D control wrapper.
Public class | ChartPointMark | Represents the RadChart for Silverlight ChartPointMark control wrapper.
Public class | ChartSeriesItemLabel | Represents the RadChart for Silverlight ChartSeriesItemLabel control wrapper.
Public class | ChartTitle | Represents the RadChart for Silverlight ChartTitle control wrapper.
Public class | ChartVerticalGridLines | Represents the RadChart for Silverlight ChartVerticalGridLines control wrapper.
Public class | ChartVerticalGridLines2D | Represents the RadChart for Silverlight ChartVerticalGridLines2D control wrapper.
Public class | ChartVerticalMinorTicks2D | Represents the RadChart for Silverlight ChartVerticalMinorTicks2D control wrapper.
Public class | ChartVerticalStripLines | Represents the RadChart for Silverlight ChartVerticalStripLines control wrapper.
Public class | ChartVerticalStripLines2D | Represents the RadChart for Silverlight ChartVerticalStripLines2D control wrapper.
Public class | ChartViewAxisLabel | Represents the ChartViewAxisLabel class
Public class | ChartViewAxisTick | Represents the ChartViewAxisTick class
Public class | ChartViewBarItem | Represents the ChartViewBarItem class
Public class | ChartViewConcentricCurves | Represents the ChartViewConcentricCurves class
Public class | ChartViewContentPresenter | Represents the ChartViewContentPresenter class
Public class | ChartViewEllipsePointMark | Represents the ChartViewEllipsePointMark class
Public class | ChartViewGridlines | Represents the ChartViewGridlines class
Public class | ChartViewPieSlice | Represents the ChartViewPieSlice class
Public class | ChartViewRectanglePointMark | Represents the ChartViewRectanglePointMark class
Public class | ChartViewSeriesItemLabel | Represents the ChartViewSeriesItemLabel class
Public class | ChartViewStriplines | Represents the ChartViewStriplines class
Public class | ChartViewTrackBallLabel | Represents the ChartViewTrackBallLabel class
Public class | ChartXAxisItem | Represents the RadChart for Silverlight RadChartXAxisItem control wrapper.
Public class | ChartXAxisLabel | Represents the RadChart for Silverlight RadChartXAxisLabel control wrapper.
Public class | ChartXAxisMinorTicks | Represents the RadChart for Silverlight ChartXAxisMinorTicks control wrapper.
Public class | ChartYAxisItem | Represents the RadChart for Silverlight RadChartYAxisItem control wrapper.
Public class | ChartYAxisLabel | Represents the RadChart for Silverlight RadChartYAxisLabel control wrapper.
Public class | ChartYAxisMinorTicks | Represents the RadChart for Silverlight ChartYAxisMinorTicks control wrapper.
Public class | ColorPickerElementNames | Holds the list of the important ColorPicker element names.
Public class | ComboBoxElementNames | A list of names specific to RadComboBox component elements.
Public class | CommodityChannelIndexIndicator | Represents the CommodityChannelIndexIndicator for ChartView control wrapper.
Public class | ComparativeMeasure | Represents the BulletGraph for Silverlight ComparativeMeasure class.
Public class | ComparativeMeasuresContainer | Represents the BulletGraph for Silverlight ComparativeMeasuresContainer control wrapper.
Public class | ContinuousSeriesBase |
Public class | CustomTimeLineControl | Represents the RadTimeLine for Silverlight TimeLineInstantItemContainer control wrapper.
Public class | DataAxisLabel | Represents the DataAxisLabel for RadDataBar Silverlight control wrapper.
Public class | DataBarLabel | Represents the DataBarLabel for RadDataBar Silverlight control wrapper.
Public class | DataBarShape | Represents the DataBarShape for Silverlight RadDataBar control wrapper.
Public class | DateTimeCategoricalAxis | Represents the DateTimeCategoricalAxis for RadCartesianChart Silverlight control wrapper.
Public class | DateTimeContinuousAxis | Represents the DateTimeContinuousAxis for RadCartesianChart Silverlight control wrapper.
Public class | DateTimePickerClock | Represents the RadClock for Silverlight control wrapper.
Public class | DateTimePickerElementNames | Holds the list of the important DateTimePicker element names.
Public class | DockingElementNames | Holds the list of the important RadDocking element names.
Public class | DocumentHost | Represents the RadDocking for Silverlight DocumentHost control wrapper.
Public class | DocumentPagePresenter | Represents the DocumentPagePresenter control wrapper.
Public class | DocumentPresenterWrapperBase |
Public class | DocumentStatisticsInfo |
Public class | DocumentWebLayoutPresenter | Represents the DocumentPagePresenter control wrapper.
Public class | ExpanderElementNames | Represents a list of control element names.
Public class | ExponentialMovingAverageIndicator | Represents the ExponentialMovingAverageIndicator for ChartView control wrapper.
Public class | ExtendedTextBox | Represents the Silverlight MaskedTextBox's ExtendedTextBox control wrapper.
Public class | FeaturedMeasurePresenter | Represents the BulletGraph for Silverlight FeaturedMeasurePresenter control wrapper.
Public class | FieldFilterControl |
Public class | FilteringControl |
Public class | FluidContentControlElementNames | Represents the FluidContentControl important sub element names.
Public class | GaugeCustomTickMark | Represents the RadGauge for Silverlight GaugeCustomTickMark control wrapper.
Public class | GaugeLabel | Represents the RadGauge for Silverlight GaugeLabel control wrapper.
Public class | GaugeLinearBar | Represents the RadGauge for Silverlight GaugeLinearBar control wrapper.
Public class | GaugeLinearRange | Represents the RadGauge for Silverlight GaugeLinearRange control wrapper.
Public class | GaugeMarker | Represents the RadGauge for Silverlight GaugeMarker control wrapper.
Public class | GaugeNeedle | Represents the RadGauge for Silverlight GaugeNeedle control wrapper.
Public class | GaugeNumericIndicator | Represents the RadGauge for Silverlight GaugeNumericIndicator control wrapper.
Public class | GaugeRadialBar | Represents the RadGauge for Silverlight GaugeRadialBar control wrapper.
Public class | GaugeRadialRange | Represents the RadGauge for Silverlight GaugeRadialRange control wrapper.
Public class | GaugeStateIndicator | Represents the RadGauge for Silverlight GaugeStateIndicator control wrapper.
Public class | GaugeTick | Represents the RadGauge for Silverlight GaugeTick control wrapper.
Public class | GridViewAggregateResultCell | Represents the RadGridView for Silverlight AggregateResultCell control wrapper.
Public class | GridViewCell | Represents the RadGridView for Silverlight GridViewCell control wrapper.
Public class | GridViewFooterCell | Represents the RadGridView for Silverlight GridViewFooterCell control wrapper.
Public class | GridViewFooterRow | Represents the RadGridView for Silverlight GridViewFooterRow control wrapper.
Public class | GridViewGroupPanel | Represents the RadGridView for Silverlight GridViewGroupPanel control wrapper.
Public class | GridViewGroupPanelCell | Represents the RadGridView for Silverlight GridViewGroupPanelCell control wrapper.
Public class | GridViewGroupPanelItem | Represents the RadGridView for Silverlight GridViewGroupPanelItem control wrapper.
Public class | GridViewGroupRow | Represents the RadGridView for Silverlight GridViewGroupRow control wrapper.
Public class | GridViewHeaderCell | Represents the RadGridView for Silverlight/WPF GridViewHeaderCell control wrapper.
Public class | GridViewHeaderRow | Represents the RadGridView for Silverlight GridViewHeaderRow control wrapper.
Public class | GridViewNewRow | Represents the RadGridView for Silverlight GridViewNewRow control wrapper.
Public class | GridViewRow | Represents the RadGridView for Silverlight/WPF GridViewRow control wrapper.
Public class | GroupContainer | Represents the RadTimeBar for Silverlight GroupContainer control wrapper.
Public class | GroupControl | Represents the RadTimeBar for Silverlight GroupControl control wrapper.
Public class | HeatMapColorGrid | Represents the HeatMapColorGrid for Silverlight control wrapper.
Public class | HeatMapColumnLabelsControl | Represents the HeatMapColumnLabelsControl for Silverlight control wrapper.
Public class | HeatMapLabel | Represents the HeatMapLabel for RadHeatMap Silverlight control wrapper.
Public class | HeatMapRowLabelsControl | Represents the HeatMapRowLabelsControl for Silverlight control wrapper.
Public class | HorizontalDataAxisTick | Represents the HorizontalDataAxisTick for RadCartesianChart Silverlight control wrapper.
Public class | HorizontalLabelTick | Represents the BulletGraph for Silverlight HorizontalLabelTick control wrapper.
Public class | ItemContainer | Represents the RadTimeBar for Silverlight ItemContainer control wrapper.
Public class | ItemControl | Represents the RadTimeBar for Silverlight ItemControl control wrapper.
Public class | LinearAxis | Represents the LinearAxis for RadCartesianChart Silverlight control wrapper.
Public class | LinearGauge | The Linear Gauge holder.
Public class | LineSeries | Represents the LineSeries for RadCartesianChart Silverlight control wrapper.
Public class | ListBoxElementNames | A list of names specific to RadListBox component elements.
Public class | LogarithmicAxis | Represents the LogarithmicAxis for RadCartesianChart Silverlight control wrapper.
Public class | MacdhIndicator | Represents the MacdhIndicator for ChartView control wrapper.
Public class | MacdIndicator | Represents the MacdIndicator for ChartView control wrapper.
Public class | MinimizedOutlookBarArea | Represents the Silverlight MinimizedOutlookBarArea control wrapper.
Public class | MinimizedOutlookBarItem | Represents the Silverlight MinimizedOutlookBarItem control wrapper.
Public class | ModifiedExponentialMovingAverageIndicator | Represents the ModifiedExponentialMovingAverageIndicator for ChartView control wrapper.
Public class | ModifiedMovingAverageIndicator | Represents the ModifiedMovingAverageIndicator for ChartView control wrapper.
Public class | MomentumIndicator | Represents the MomentumIndicator for ChartView control wrapper.
Public class | MovingAverageIndicator | Represents the MovingAverageIndicator for ChartView control wrapper.
Public class | NumericRadialAxis | Represents the NumericRadialAxis for RadPolarChart Silverlight control wrapper.
Public class | NumericUpDownElementNames | Represents a list of control sub elements names.
Public class | OhlcSeries | Represents the OhlcSeries for RadCartesianChart Silverlight control wrapper.
Public class | OhlcStick | Represents the OhlcStick for RadCartesianChart Silverlight control wrapper.
Public class | OscillatorIndicator | Represents the OscillatorIndicator for ChartView control wrapper.
Public class | OutlookBarElementNames | Represents the OutlookBar important sub element names.
Public class | PaneHeader | Represents the RadDocking for Silverlight PaneHeader control wrapper.
Public class | PanelBarElementNames | Represents the PanelBar/PanelBarItem important sub element names.
Public class | PanZoomBar | Represents the PanZoomBar for RadCartesianChart Silverlight control wrapper.
Public class | PickerTextBox | Represents the PickerTextBox control wrapper.
Public class | PickerToggleButton | Represents the Silverlight PickerToggleButton control wrapper.
Public class | PieSeries | Represents the PieSeries for RadPieChart Silverlight control wrapper.
Public class | PolarAreaSeries | Represents the PolarAreaSeries for RadPolarChart Silverlight control wrapper.
Public class | PolarAxis | Represents the PolarAxis for RadPolarChart Silverlight control wrapper.
Public class | PolarChartGrid | Represents the PolarChartGrid for RadPolarChart Silverlight control wrapper.
Public class | PolarLineSeries | Represents the PolarLineSeries for RadPolarChart Silverlight control wrapper.
Public class | PolarPointSeries | Represents the PolarPointSeries for RadPolarChart Silverlight control wrapper.
Public class | PositioningIndicatorPanel | Represents the BulletGraph for Silverlight PositioningIndicatorPanel control wrapper.
Public class | QualitativeRangeContainer | Represents the BulletGraph for Silverlight QualitativeRangeContainer control wrapper.
Public class | QuantitativeScaleContainer | Represents the BulletGraph for Silverlight QuantitativeScaleContainer control wrapper.
Public class | QuickAccessToolBar | Represents the Silverlight RadRibbonBar's QuickAccessToolBar control wrapper.
Public class | RadarAreaSeries | Represents the RadarAreaSeries for RadPolarChart Silverlight control wrapper.
Public class | RadAreaSparkline | Represents the RadSparklines for Silverlight RadAreaSparkline control wrapper.
Public class | RadarLineSeries | Represents the RadarLineSeries for RadPolarChart Silverlight control wrapper.
Public class | RadarPointSeries | Represents the RadarPointSeries for RadPolarChart Silverlight control wrapper.
Public class | RadBarcode11 | Represents the RadBarcode11 for Silverlight control wrapper.
Public class | RadBarcode128 | Represents the RadBarcode128 for Silverlight control wrapper.
Public class | RadBarcode128A | Represents the RadBarcode128A for Silverlight control wrapper.
Public class | RadBarcode128B | Represents the RadBarcode128B for Silverlight control wrapper.
Public class | RadBarcode128C | Represents the RadBarcode128C for Silverlight control wrapper.
Public class | RadBarcode25Interleaved | Represents the RadBarcode25Interleaved for Silverlight control wrapper.
Public class | RadBarcode25Standard | Represents the RadBarcode25Standard for Silverlight control wrapper.
Public class | RadBarcode39 | Represents the RadBarcode39 for Silverlight control wrapper.
Public class | RadBarcode93 | Represents the RadBarcode93 for Silverlight control wrapper.
Public class | RadBarcode93Extended | Represents the RadBarcode93Extended for Silverlight control wrapper.
Public class | RadBarcodeCodebar | Represents the RadBarcodeCodebar for Silverlight control wrapper.
Public class | RadBarcodeEAN13 | Represents the RadBarcodeEAN13 for Silverlight control wrapper.
Public class | RadBarcodeEAN8 | Represents the RadBarcodeEAN8 for Silverlight control wrapper.
Public class | RadBarcodeMSI | Represents the RadBarcodeMSI for Silverlight control wrapper.
Public class | RadBarcodePostnet | Represents the RadBarcodePostnet for Silverlight control wrapper.
Public class | RadBarcodeUPCA | Represents the RadBarcodeUPCA for Silverlight control wrapper.
Public class | RadBarcodeUPCE | Represents the RadBarcodeUPCE for Silverlight control wrapper.
Public class | RadBarcodeUPCSupplement2 | Represents the RadBarcodeUPCSupplement2 for Silverlight control wrapper.
Public class | RadBarcodeUPCSupplement5 | Represents the RadBarcodeUPCSupplement5 for Silverlight control wrapper.
Public class | RadBook | Represents the Silverlight RadBook wrapper.
Public class | RadBookItem | Represents the Silverlight RadBookItem control wrapper.
Public class | RadBusyIndicator | Represents the Silverlight RadBusyIndicator control wrapper.
Public class | RadButton | Represents the RadButton for Silverlight control wrapper.
Public class | RadCalculator |
Public class | RadCalculatorElementNames | Represents a list of RadCalculator element names.
Public class | RadCalendar | The class represents the RadCalendar Silverlight control wrapper.
Public class | RadCartesianChart | Represents the RadCartesianChart for Silverlight control wrapper.
Public class | RadCell | Represents the Silverlight TreeListView RadColumn control wrapper.
Public class | RadChart | Represents the RadChart for Silverlight RadChart control wrapper.
Public class | RadClock | Represents the RadClock for Silverlight control wrapper.
Public class | RadClockItem | Represents the RadClockItem for Silverlight control wrapper.
Public class | RadColorPaletteView | Represents the Silverlight RadColorPaletteView control wrapper.
Public class | RadColorPaletteViewItem | Represents the Silverlight RadColorPaletteViewItem control wrapper.
Public class | RadColorPicker | Represents the Silverlight RadColorPicker control wrapper.
Public class | RadColorSelector | Represents the Silverlight RadColorSelector control wrapper.
Public class | RadColumn | Represents the Silverlight TreeListView RadColumn control wrapper.
Public class | RadColumnSparkline | Represents the RadSparklines for Silverlight RadColumnSparkline control wrapper.
Public class | RadComboBox | Represents the Silverlight RadComboBox control wrapper.
Public class | RadComboBoxItem | Represents the Silverlight RadComboBoxItem control wrapper.
Public class | RadContextMenu | Represents the Silverlight RadContextMenu wrapper.
Public class | RadControlMappingKeys | Represents a collection of keys identifying RadControls in the framework.
Public class | RadCoverFlow | Represents the Silverlight RadCoverFlow wrapper.
Public class | RadCoverFlowItem | Represents the Silverlight RadCoverFlowItem control wrapper.
Public class | RadDataAxis | Represents the RadDataAxis for Silverlight RadDataBar control wrapper.
Public class | RadDataBar | Represents the RadDataBar for Silverlight RadDataBar control wrapper.
Public class | RadDatePicker | Represents the DatePicker control wrapper.
Public class | RadDateTimePicker | Represents the DateTimePicker control wrapper.
Public class | RadDiagram | Represents the Silverlight RadDiagram control wrapper.
Public class | RadDiagramConnection | Represents the Silverlight RadDiagram's RadDiagramConnection control wrapper.
Public class | RadDiagramShape | Represents the Silverlight RadDiagram's RadDiagramShape control wrapper.
Public class | RadDiagramThumbnail | Represents the Silverlight RadDiagram's RadDiagramThumbnail control wrapper.
Public class | RadDocking | Represents the RadDocking for Silverlight control wrapper. Serves as a holder for the child split containers and tool windows.
Public class | RadDocumentPane | Represents the RadDocking for Silverlight RadDocumentPane control wrapper.
Public class | RadDropDownButton | Represents the RadDropDownButton for Silverlight control wrapper.
Public class | RadExpander | Represents the RadExpander for Silverlight control wrapper.
Public class | RadFluidContentControl | Represents the Silverlight RadFluidContentControl wrapper.
Public class | RadGauge | Represents the RadGauge for Silverlight RadGauge control wrapper.
Public class | RadGridResizer | Represents the RadDocking for Silverlight RadGridResizer control wrapper.
Public class | RadGridView | Represents the RadGridView for Silverlight control wrapper.
Public class | RadHeatMap | Represents the RadHeatMap for Silverlight control wrapper.
Public class | RadHorizontalBulletGraph | Represents the BulletGraph for Silverlight RadHorizontalBulletGraph control wrapper.
Public class | RadHtmlPlaceholder | Represents the RadHtmlPlaceholder for Silverlight control wrapper.
Public class | RadialGauge | The Radial Gauge holder.
Public class | RadLinearSparkline | Represents the RadSparklines for Silverlight RadLinearSparkline control wrapper.
Public class | RadListBox | Represents the Silverlight RadListBox control wrapper.
Public class | RadListBoxItem | Represents the Silverlight RadComboBoxItem control wrapper.
Public class | RadMaskedCurrencyInput | Represents the XAML RadMaskedCurrencyInput control wrapper.
Public class | RadMaskedDateTimeInput | Represents the XAML RadMaskedDateTimeInput control wrapper.
Public class | RadMaskedInput | Represents the Silverlight MaskedInput control wrapper.
Public class | RadMaskedNumericInput | Represents the XAML RadMaskedNumericInput control wrapper.
Public class | RadMaskedTextBox | Represents the Silverlight MaskedTextBox control wrapper.
Public class | RadMaskedTextInput | Represents the XAML RadMaskedTextInput control wrapper.
Public class | RadMenu | Represents the Silverlight RadMenu wrapper.
Public class | RadMenuBase | Serves as the base for the Silverlight RadMenu and RadContextMenu wrappers.
Public class | RadMenuItem | Represents the Silverlight RadMenuItem wrapper.
Public class | RadNumericUpDown | Represents the RadNumericUpDown for Silverlight control wrapper.
Public class | RadOutlookBar | Represents the Silverlight RadOutlookBar control wrapper.
Public class | RadOutlookBarItem | Represents the Silverlight RadOutlookBarItem control wrapper.
Public class | RadPane | Represents the RadDocking for Silverlight RadPane control wrapper.
Public class | RadPaneGroup | Represents the RadDocking for Silverlight RadPaneGroup control wrapper.
Public class | RadPanelBar | Represents the Silverlight RadPanelBar control wrapper.
Public class | RadPanelBarItem | Represents the Silverlight RadPanelBarItem control wrapper.
Public class | RadPieChart | Represents the RadPieChart for Silverlight control wrapper.
Public class | RadPivotCell | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotCellPanel | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotFieldArea | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotFieldAreaItem | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotFieldBox | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotFieldBoxItem | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotFieldList | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotGrid | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotGridPanel | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotGroupHeader | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotHeader | The base FrameworkElement that represents any visual element in the Silverlight application.
Public class | RadPivotMap | Represents the PivotMap for Silverlight RadPivotMap control wrapper.
Public class | RadPolarChart | Represents the RadPolarChart for Silverlight control wrapper.
Public class | RadProgressBar | Represents the RadProgressBar for Silverlight control wrapper.
Public class | RadRadioButton | Represents the RadRadioButton for Silverlight control wrapper.
Public class | RadRibbonBar | Represents the Silverlight RadRibbonBar control wrapper.
Public class | RadRibbonButton | Represents the Silverlight RadRibbonBar's Button control wrapper.
Public class | RadRibbonDropDownButton | Represents the Silverlight RadRibbonBar's DropDownButton control wrapper.
Public class | RadRibbonGroup | Represents the Silverlight RadRibbonGroup control wrapper.
Public class | RadRibbonRadioButton | Represents the Silverlight RadRibbonRadioButton control wrapper.
Public class | RadRibbonSplitButton | Represents the RadRibbonSplitButton for Silverlight control wrapper.
Public class | RadRibbonView | Represents the RadRibbonView control wrapper.
Public class | RadRichTextBox | Represents the RadRichTextBox control wrapper.
Public class | RadScatterSparkline | Represents the RadSparklines for Silverlight RadScatterSparkline control wrapper.
Public class | RadScheduler | Represents the RadScheduler control wrapper. Serves as a main entry point for the entire Scheduler API.
Public class | RadScheduleView | Represents the RadScheduleView control wrapper. Serves as a main entry point for the entire RadScheduleView API.
Public class | RadSlider | Represents the Silverlight RadSlider control wrapper.
Public class | RadSparklineColumn | Represents the RadSparklines for Silverlight RadSparklineColumn control wrapper.
Public class | RadSparklineDiamond | Represents the RadSparklines for Silverlight RadSparklineDiamond control wrapper.
Public class | RadSparklineIndicatorItem | Represents the RadSparklines for Silverlight RadSparklineIndicatorItem control wrapper.
Public class | RadSplitButton | Represents the RadSplitButton for Silverlight control wrapper.
Public class | RadSplitContainer | Represents the RadDocking for Silverlight RadSplitContainer control wrapper. The instance may contain child split containers as well as pane group controls.
Public class | RadStacked100DataBar | Represents the RadStacked100DataBar for Silverlight RadDataBar control wrapper.
Public class | RadStackedDataBar | Represents the RadStackedDataBar for Silverlight RadDataBar control wrapper.
Public class | RadTabControl | Represents the Silverlight RadTabControl wrapper.
Public class | RadTabItem | Represents the Silverlight RadTabItem wrapper.
Public class | RadTickBar | Represents the Silverlight RadTickBar control wrapper. Holds the Slider ticks.
Public class | RadTileView | Represents the Silverlight RadTileView wrapper.
Public class | RadTileViewItem | Represents the Silverlight RadTileViewItem wrapper.
Public class | RadTimeBar | Represents the RadTimeBar for Silverlight TimeBar control wrapper.
Public class | RadTimeLine | Represents the RadTimeLine for Silverlight TimeLine control wrapper.
Public class | RadTimePicker | Represents the RadTimePicker for Silverlight control wrapper.
Public class | RadToggleButton | Represents the RadToggleButton for Silverlight control wrapper.
Public class | RadToolBar | Represents the Silverlight RadToolBar control wrapper.
Public class | RadToolBarTray | Represents the Silverlight RadToolBar control wrapper.
Public class | RadTreeListView | Represents the Silverlight RadTreeListView control wrapper.
Public class | RadTreeListViewItem | Represents the Silverlight RadTreeViewItem control wrapper.
Public class | RadTreeMap | Represents the PivotMap for Silverlight RadPivotMap control wrapper.
Public class | RadTreeMapItem | Represents the Treemap and PivotMap for Silverlight RadTreeMapItem control wrapper.
Public class | RadTreeMapPanel | Represents the Treemap and PivotMap for Silverlight RadTreeMapPanel control wrapper.
Public class | RadTreeView | Represents the Silverlight RadTreeView control wrapper.
Public class | RadTreeViewItem | Represents the Silverlight RadTreeViewItem control wrapper.
Public class | RadUniformGrid | Represents the RadUniformGrid for Silverlight control wrapper.
Public class | RadUpload | Represents the RadUpload for Silverlight control wrapper.
Public class | RadUploadItem | Represents the RadUploadItem for Silverlight control wrapper.
Public class | RadVerticalBulletGraph | Represents the BulletGraph for Silverlight RadVerticalBulletGraph control wrapper.
Public class | RadWatermarkTextBox | Represents the WatermarkTextBox control wrapper.
Public class | RadWindow | Represents the Silverlight RadWindow control wrapper.
Public class | RadWinLossSparkline | Represents the RadSparklines for Silverlight RadWinLossSparkline control wrapper.
Public class | RateOfChangeIndicator | Represents the RateOfChangeIndicator for ChartView control wrapper.
Public class | RaviIndicator | Represents the RaviIndicator for ChartView control wrapper.
Public class | RelativeMomentumIndexIndicator | Represents the RelativeMomentumIndexIndicator for ChartView control wrapper.
Public class | RelativeStrengthIndexIndicator | Represents the RelativeStrengthIndexIndicator for ChartView control wrapper.
Public class | RibbonBarElementNames | Represents the RadRibbonBar important sub element names.
Public class | ScatterAreaSeries | Represents the ScatterAreaSeries for RadCartesianChart Silverlight control wrapper.
Public class | ScatterLineSeries | Represents the ScatterLineSeries for RadCartesianChart Silverlight control wrapper.
Public class | ScatterPointSeries | Represents the ScatterPointSeries for RadCartesianChart Silverlight control wrapper.
Public class | SchedulerDayPresenter | The Scheduler DayView presenter.
Public class | SchedulerElementNames | Represents the Scheduler important sub element names.
Public class | SchedulerMonthPresenter | The Scheduler MonthView presenter.
Public class | SchedulerPresenter | The Scheduler View presenter base control.
Public class | SchedulerTimelinePresenter | Represents the RadScheduler Timeline presenter control wrapper.
Public class | SchedulerWeekPresenter | Represents the Scheduler WeekView wrapper.
Public class | ScheduleViewElementNames | Represents the ScheduleView important sub element names.
Public class | SelectionIndicator | Represents the RadTimeBar for Silverlight SelectionIndicator control wrapper.
Public class | SelectionThumb | Represents the RadTimeBar for Silverlight SelectionThumb control wrapper.
Public class | SelectionVisibilityIndicator | Represents the RadTimeBar for Silverlight SelectionVisibilityIndicator control wrapper.
Public class | ShadeControl | Represents the RadTimeBar for Silverlight ShadeControl control wrapper.
Public class | ShapePoint<(Of <(<'T>)>)> | Represents the ShapePoint class
Public class | SliderElementNames | Represents a list of RadSlider element names used accross the wrapper controls.
Public class | SplineAreaSeries | Represents the SplineAreaSeries for RadCartesianChart Silverlight control wrapper.
Public class | SplineSeries | Represents the SplineSeries for RadCartesianChart Silverlight control wrapper.
Public class | SplitButtonElementNames | Represents the RadSplitButton important sub element names.
Public class | StochasticFastIndicator | Represents the StochasticFastIndicator for ChartView control wrapper.
Public class | StochasticSlowIndicator | Represents the StochasticSlowIndicator for ChartView control wrapper.
Public class | StringFilterEditor |
Public class | TabControlElementNames | Represents the TabControl/TabItem important sub element names.
Public class | TileViewElementNames | Represents the TileView important sub element names.
Public class | TimeBarContentPanel | Represents the RadTimeBar for Silverlight TimeBarContentPanel control wrapper.
Public class | TimeBarPanel | Represents the RadTimeBar for Silverlight TimeBarPanel control wrapper.
Public class | TimeBarStackPanel | Represents the RadTimeBar for Silverlight TimeBarStackPanel control wrapper.
Public class | TimelineGroupPeriodContainer | Represents the RadTimeLine for Silverlight TlGroupContainer control wrapper.
Public class | TimelineGroupPeriodControl | Represents the RadTimeLine for Silverlight GroupControl control wrapper.
Public class | TimeLineInstantItemControl | Represents the RadTimeLine for Silverlight TimeLineInstantItemContainer control wrapper.
Public class | TimeLineItemContainer | Represents the RadTimeLine for Silverlight TimeLineItemContainer control wrapper.
Public class | TimeLineItemControl | Represents the RadTimeLine for Silverlight TimeLineItemControl control wrapper.
Public class | TimelineItemGroupControl | Represents the RadTimeLine for Silverlight TimelineItemGroupControl control wrapper.
Public class | TimelinePeriodContainer | Represents the RadTimeBar for Silverlight TimelinePeriodContainer control wrapper.
Public class | TimelinePeriodControl | Represents the RadTimeLine for Silverlight TimelinePeriodControl control wrapper.
Public class | TimePickerElementNames | Holds the list of the important TimePicker element names.
Public class | TimeSlotItem | Represents the TimeSlotItem control.
Public class | ToolBarElementNames | Represents the ToolBar/ToolBarTray important sub element names.
Public class | ToolWindow | Represents the RadDocking for Silverlight ToolWindow control wrapper. The tool window always contains a single SplitContainer instance that may hold other containers or pane groups.
Public class | TrackBallInfoControl | Represents the TrackBallInfoControl for Silverlight control wrapper.
Public class | TreeListViewElementNames | Represents the TreeListView important element names.
Public class | TreeViewElementNames | Represents the TreeView and TreeViewItem important sub element names.
Public class | TriangleScatterPoint | Represents the TriangleScatterPoint class
Public class | TrixIndicator | Represents the TrixIndicator for ChartView control wrapper.
Public class | TrueRangeIndicator | Represents the TrueRangeIndicator for ChartView control wrapper.
Public class | UltimateOscillatorIndicator | Represents the UltimateOscillatorIndicator for ChartView control wrapper.
Public class | UploadElementNames | Holds the list of important RadUpload element names.
Public class | VerticalDataAxisTick | Represents the VerticalDataAxisTick for RadCartesianChart Silverlight control wrapper.
Public class | VerticalLabelTick | Represents the BulletGraph for Silverlight VerticalLabelTick control wrapper.
Public class | VirtualizingTimelinePanel | Represents the RadTimeLine for Silverlight VirtualizingTimelinePanel control wrapper.
Public class | WeightedMovingAverageIndicator | Represents the WeightedMovingAverageIndicator for ChartView control wrapper.
Public class | WindowElementNames | Represents a list of RadWindow element names used accross the wrappers.
Public class | WindowTitle | Represents the Silverlight WindowTitle control wrapper.

Interfaces

 | Interface | Description
Public interface | IAppointmentElement |
Public interface | IAutoHideArea | Represents the IAutoHideArea control wrapper for SL/Wpf interface.
Public interface | ICalendarButton | Represents the CalendarButton control wrapper for SL/Wpf interface.
Public interface | ICalendarView | Represents the CalendarView control wrapper for SL/Wpf interface.
Public interface | IDateTimePickerClock | Represents the RadDateTimePickerClock control wrapper for SL/Wpf interface.
Public interface | IDocumentHost | Represents the IDocumentHost control wrapper for SL/Wpf interface.
Public interface | IFieldFilterControl |
Public interface | IFilteringControl |
Public interface | IGridViewCell |
Public interface | IGridViewFooterCell |
Public interface | IGridViewFooterRow |
Public interface | IGridViewGroupRow |
Public interface | IGridViewHeaderCell |
Public interface | IGridViewHeaderRow |
Public interface | IGridViewNewRow |
Public interface | IGridViewRow |
Public interface | IMinimizedOutlookBarArea |
Public interface | IMinimizedOutlookBarItem |
Public interface | IPaneHeader | Represents the IPaneHeader control wrapper for SL/Wpf interface.
Public interface | IQuickAccessToolBar |
Public interface | IRadBook |
Public interface | IRadBookItem |
Public interface | IRadBusyIndicator | Represents the Rad control wrapper for SL/Wpf interface.
Public interface | IRadButton | The common RadButton SL/Wpf interface.
Public interface | IRadCalculator |
Public interface | IRadCalendar | Represents the RadCalendar control wrapper for SL/Wpf interface.
Public interface | IRadClock | Represents the RadClock control wrapper for SL/Wpf interface.
Public interface | IRadClockItem | Represents the RadClockitem control wrapper for SL/Wpf interface.
Public interface | IRadColorPaletteView |
Public interface | IRadColorPaletteViewItem |
Public interface | IRadColorPicker |
Public interface | IRadColorSelector |
Public interface | IRadComboBox | Represents the RadComboBox control wrapper for SL/Wpf interface.
Public interface | IRadComboBoxItem | Represents the RadComboBoxItem control wrapper for SL/Wpf interface.
Public interface | IRadContextMenu |
Public interface | IRadDatePicker | Represents the RadDatePicker control wrapper for SL/Wpf interface.
Public interface | IRadDateTimePicker | Represents the RadDateTimePicker control wrapper for SL/Wpf interface.
Public interface | IRadDiagram | The common RadDiagram SL/Wpf interface.
Public interface | IRadDiagramConnection | The common RadDiagramConnection SL/Wpf interface.
Public interface | IRadDiagramShape | The common RadDiagramShape SL/Wpf interface.
Public interface | IRadDiagramThumbnail |
Public interface | IRadDocking | Represents the RadDocking control wrapper for SL/Wpf interface.
Public interface | IRadDocumentPane | Represents the IRadDocumentPane control wrapper for SL/Wpf interface.
Public interface | IRadDropDownButton | The common RadDropDownButton SL/Wpf interface.
Public interface | IRadExpander |
Public interface | IRadGridResizer | Represents the IRadGridResizer control wrapper for SL/Wpf interface.
Public interface | IRadGridView |
Public interface | IRadListBox | Represents the RadListBox control wrapper for SL/Wpf interface.
Public interface | IRadListBoxItem | Represents the RadListBoxItem control wrapper for SL/Wpf interface.
Public interface | IRadMaskedInput |
Public interface | IRadMaskedTextBox |
Public interface | IRadMenu |
Public interface | IRadMenuBase |
Public interface | IRadMenuItem |
Public interface | IRadNumericUpDown |
Public interface | IRadOutlookBar |
Public interface | IRadOutlookBarItem |
Public interface | IRadPane | Represents the IRadPane control wrapper for SL/Wpf interface.
Public interface | IRadPaneGroup | Represents the IRadPaneGroup control wrapper for SL/Wpf interface.
Public interface | IRadPanelBar |
Public interface | IRadPanelBarItem |
Public interface | IRadPivotCell | Represents the Silverlight RadPivot's IRadPivotCell control wrapper.
Public interface | IRadPivotCellPanel | Represents the Silverlight RadPivotGrid's IRadPivotCellPanel control wrapper.
Public interface | IRadPivotFieldArea | Represents the Silverlight RadFieldList's IRadPivotFieldArea control wrapper.
Public interface | IRadPivotFieldAreaItem | Represents the Silverlight RadFieldList's IRadPivotFieldAreaItem control wrapper.
Public interface | IRadPivotFieldBox | Represents the Silverlight RadFieldList's IRadPivotFieldBox control wrapper.
Public interface | IRadPivotFieldBoxItem | Represents the Silverlight RadFieldList's IRadPivotFieldBoxItem control wrapper.
Public interface | IRadPivotFieldList | Represents the Silverlight RadFieldList's IRadPivotFieldList control wrapper.
Public interface | IRadPivotGrid | Represents the Silverlight RadPivot's IRadPivotGrid control wrapper.
Public interface | IRadPivotGridPanel | Represents the Silverlight RadPivot's IRadPivotGridPanel control wrapper.
Public interface | IRadPivotGroupHeader | Represents the Silverlight RadPivot's IRadPivotGroupHeader control wrapper.
Public interface | IRadPivotHeader | Represents the Silverlight RadPivot's IRadPivotHeader control wrapper.
Public interface | IRadProgressBar |
Public interface | IRadRadioButton | The common RadRadioButton SL/Wpf interface.
Public interface | IRadRibbonBar |
Public interface | IRadRibbonButton |
Public interface | IRadRibbonDropDownButton |
Public interface | IRadRibbonGroup |
Public interface | IRadRibbonRadioButton |
Public interface | IRadRibbonSplitButton |
Public interface | IRadRibbonView |
Public interface | IRadRichTextBox |
Public interface | IRadScheduleView | Represents the RadScheduleView control wrapper for SL/Wpf interface.
Public interface | IRadSlider |
Public interface | IRadSplitButton | The common RadSplitButton SL/Wpf interface.
Public interface | IRadSplitContainer | Represents the IRadSplitContainer control wrapper for SL/Wpf interface.
Public interface | IRadTabControl |
Public interface | IRadTabItem |
Public interface | IRadTickBar |
Public interface | IRadTileView |
Public interface | IRadTileViewItem |
Public interface | IRadTimePicker | Represents the RadTimePicker control wrapper for SL/Wpf interface.
Public interface | IRadToggleButton | The common RadToggleButton SL/Wpf interface.
Public interface | IRadToolBar |
Public interface | IRadToolBarTray |
Public interface | IRadTreeView |
Public interface | IRadTreeViewItem |
Public interface | IRadWatermarkTextBox | Represents the RadComboBox control wrapper for SL/Wpf interface.
Public interface | IRadWindow |
Public interface | IStringFilterEditor |
Public interface | IToolWindow | Represents the IToolWindow control wrapper for SL/Wpf interface.
Public interface | IWindowTitle |

Enumerations

 | Enumeration | Description
Public enumeration | BarcodeTypes | The types of barcodes.
Public enumeration | BulletGraphTypes | The types of bulletgraphs.
Public enumeration | CalculatorOperation |
Public enumeration | CalendarDisplayMode | Represents the Calendar display mode.
Public enumeration | ChartTypes | The types of chart series.
Public enumeration | DataBarTypes | The types of DataBars.
Public enumeration | DockingDragDirection | The RadDocking drag direction enumeration - left, right, up and down.
Public enumeration | DockPosition | The dock position enumeration. Used as an argument for RadDocking.DockToX like methods.
Public enumeration | ExpandDirection |
Public enumeration | FluidContentControlState | Represents the FluidContentControl state values.
Public enumeration | HeaderCellThumbName | Enumerates the HeaderCell thumbs user interacts with.
Public enumeration | ListBoxSelectionModifierKey |
Public enumeration | Position | Represents an enumeration of possible positions specific to the control layout.
Public enumeration | RadTreeMapAndPivotMapTypes | The types of bulletgraphs.
Public enumeration | SchedulerViewType | The enumeration holding the supported Scheduler view types.
Public enumeration | SparklineTypes | The types of sparklines.
Public enumeration | ThumbName | Enumerates the Slider control thumbs user interacts with.
Public enumeration | TurnPagePosition | Represents the RadBook enumeration for the possible corner positions to turn a page from.
Public enumeration | ViewDefinitionType | The enumeration holding the supported ScheduleView view types.


AdaptiveMovingAverageKaufmanIndicator Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator Members
AdaptiveMovingAverageKaufmanIndicator Class Constructors Methods Properties See Also Send Feedback

The AdaptiveMovingAverageKaufmanIndicator type exposes the following members.

Constructors

 | Name | Description
Public method | AdaptiveMovingAverageKaufmanIndicator | Initializes a new instance of the AdaptiveMovingAverageKaufmanIndicator class.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Protected method | GetPoints | (Inherited from ContinuousSeriesBase.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Inherited from Control.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Figures | Gets a list of Figures (Inherited from ContinuousSeriesBase.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Paths | Get the list of paths. (Inherited from ContinuousSeriesBase.)
Public property | PointsCollection | Get the Points collection. (Inherited from ContinuousSeriesBase.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SecondFigurePointsCollection | Get the Points collection of the second figure. (Inherited from ContinuousSeriesBase.)
Public property | StrokeColor | Get the indicator color. (Inherited from ContinuousSeriesBase.)
Public property | StrokeColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ContinuousSeriesBase.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag of AdaptiveMovingAverageKaufmanIndicator. (Overrides FrameworkElement..::..XamlTag.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
Telerik.WebAii.Controls.Xaml Namespace


AdaptiveMovingAverageKaufmanIndicator Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator Constructor
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback
Initializes a new instance of the AdaptiveMovingAverageKaufmanIndicator class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2012.1.719.0 (2012.1.719.0)

Syntax

C#
public AdaptiveMovingAverageKaufmanIndicator()
Visual Basic
Public Sub New
Visual C++
public:
AdaptiveMovingAverageKaufmanIndicator()

See Also

AdaptiveMovingAverageKaufmanIndicator Class
Telerik.WebAii.Controls.Xaml Namespace


AdaptiveMovingAverageKaufmanIndicator Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator Methods
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

The AdaptiveMovingAverageKaufmanIndicator type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the reference and perform your custom class initialization. (Overrides FrameworkElement..::..AssignReference(AutomationReference).)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Protected method | GetPoints | (Inherited from ContinuousSeriesBase.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Inherited from Control.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..AnySibling Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


AssignReference Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..AssignReference Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback
Assign the reference and perform your custom class initialization.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2012.1.719.0 (2012.1.719.0)

Syntax

C#
public override void AssignReference(
    AutomationReference reference
)
Visual Basic
Public Overrides Sub AssignReference ( _
    reference As AutomationReference _
)
Visual C++
public:
virtual void AssignReference(
    AutomationReference^ reference
) override

Parameters

reference
Type: ArtOfTest.WebAii.Silverlight..::..AutomationReference

[Missing <param name="reference"/> documentation for "M:Telerik.WebAii.Controls.Xaml.AdaptiveMovingAverageKaufmanIndicator.AssignReference(ArtOfTest.WebAii.Silverlight.AutomationReference)"]

Implements

IFrameworkElement..::..AssignReference(AutomationReference)
IAutomationPeer..::..AssignReference(AutomationReference)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..GetProperty Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..GetRectangle Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..Highlight Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..InvokeMethod Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..IsHitTest Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..NextSibling Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..Parent Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..PreviousSibling Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..ScrollToVisible Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator..::..SetProperty Method
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
AdaptiveMovingAverageKaufmanIndicator Members
Telerik.WebAii.Controls.Xaml Namespace


AdaptiveMovingAverageKaufmanIndicator Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AdaptiveMovingAverageKaufmanIndicator Properties
AdaptiveMovingAverageKaufmanIndicator Class See Also Send Feedback

The AdaptiveMovingAverageKaufmanIndicator type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Figures | Gets a list of Figures (Inherited from ContinuousSeriesBase.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | Paths | Get the list of paths. (Inherited from ContinuousSeriesBase.)
Public property | PointsCollection | Get the Points collection. (Inherited from ContinuousSeriesBase.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | SecondFigurePointsCollection | Get the Points collection of the second figure. (Inherited from ContinuousSeriesBase.)
Public property | StrokeColor | Get the indicator color. (Inherited from ContinuousSeriesBase.)
Public property | StrokeColorValue | Get the selected color RGB representation. Example: '255:0:0'. (Inherited from ContinuousSeriesBase.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag of AdaptiveMovingAverageKaufmanIndicator. (Overrides FrameworkElement..::..XamlTag.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AdaptiveMovingAverageKaufmanIndicator Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsList Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList Members
AggregateResultsList Class Constructors Methods Properties See Also Send Feedback

The AggregateResultsList type exposes the following members.

Constructors

 | Name | Description
Public method | AggregateResultsList | Initializes a new instance of the AggregateResultsList class

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Inherited from ItemsControl.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AggregateResultCells | Gets the aggregate result cells.
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsList Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList Constructor
AggregateResultsList Class See Also Send Feedback
Initializes a new instance of the AggregateResultsList class

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2012.1.719.0 (2012.1.719.0)

Syntax

C#
public AggregateResultsList()
Visual Basic
Public Sub New
Visual C++
public:
AggregateResultsList()

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsList Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList Methods
AggregateResultsList Class See Also Send Feedback

The AggregateResultsList type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Inherited from ItemsControl.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..AnySibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..GetProperty Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..GetRectangle Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..Highlight Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..InvokeMethod Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..IsHitTest Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..NextSibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..Parent Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..PreviousSibling Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..ScrollToVisible Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList..::..SetProperty Method
AggregateResultsList Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AggregateResultsList Class
AggregateResultsList Members
Telerik.WebAii.Controls.Xaml Namespace


AggregateResultsList Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AggregateResultsList Properties
AggregateResultsList Class See Also Send Feedback

The AggregateResultsList type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | AggregateResultCells | Gets the aggregate result cells.
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | DisplayMemberPath | (Inherited from ItemsControl.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AggregateResultsList Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentElement Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement Members
AppointmentElement Class Constructors Methods Properties See Also Send Feedback

The AppointmentElement type exposes the following members.

Constructors

 | Name | Description
Public method | AppointmentElement | Initializes a new instance of the AppointmentItem class.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Delete | Simulate user clicking on the appointment delete button.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Inherited from Control.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select | Selects the appointment.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | DeleteButton | Get the delete button of this appointment item.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | EndResizeGrip | Get the bottom resizer of this appointment item.
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected | Gets if the Appointment is Selected
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | StartResizeGrip | Get the top resizer of this appointment item.
Public property | Subject | Get the appointment subject.
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentElement Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement Constructor
AppointmentElement Class See Also Send Feedback
Initializes a new instance of the AppointmentItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2012.1.719.0 (2012.1.719.0)

Syntax

C#
public AppointmentElement()
Visual Basic
Public Sub New
Visual C++
public:
AppointmentElement()

See Also

AppointmentElement Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentElement Methods

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement Methods
AppointmentElement Class See Also Send Feedback

The AppointmentElement type exposes the following members.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Delete | Simulate user clicking on the appointment delete button.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Inherited from Control.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select | Selects the appointment.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
Telerik.WebAii.Controls.Xaml Namespace


AnySibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..AnySibling Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


Delete Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..Delete Method
AppointmentElement Class See Also Send Feedback
Simulate user clicking on the appointment delete button.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2012.1.719.0 (2012.1.719.0)

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete
Visual C++
public:
virtual void Delete() sealed

Implements

IAppointmentElement..::..Delete()()()()

See Also

AppointmentElement Class
Telerik.WebAii.Controls.Xaml Namespace


GetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..GetProperty Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


GetRectangle Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..GetRectangle Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


Highlight Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..Highlight Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


InvokeMethod Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..InvokeMethod Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


IsHitTest Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..IsHitTest Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


NextSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..NextSibling Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


Parent Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..Parent Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


PreviousSibling Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..PreviousSibling Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


ScrollToVisible Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..ScrollToVisible Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


Select Method

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..Select Method
AppointmentElement Class See Also Send Feedback
Selects the appointment.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2012.1.719.0 (2012.1.719.0)

Syntax

C#
public void Select()
Visual Basic
Public Sub Select
Visual C++
public:
virtual void Select() sealed

Implements

IAppointmentElement..::..Select()()()()

See Also

AppointmentElement Class
Telerik.WebAii.Controls.Xaml Namespace


SetProperty Method

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement..::..SetProperty Method
AppointmentElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)

See Also

AppointmentElement Class
AppointmentElement Members
Telerik.WebAii.Controls.Xaml Namespace


AppointmentElement Properties

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentElement Properties
AppointmentElement Class See Also Send Feedback

The AppointmentElement type exposes the following members.

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | DeleteButton | Get the delete button of this appointment item.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | EndResizeGrip | Get the bottom resizer of this appointment item.
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected | Gets if the Appointment is Selected
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | StartResizeGrip | Get the top resizer of this appointment item.
Public property | Subject | Get the appointment subject.
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentElement Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItem Members

[image] [image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentItem Members
AppointmentItem Class Constructors Methods Properties See Also Send Feedback

The AppointmentItem type exposes the following members.

Constructors

 | Name | Description
Public method | AppointmentItem | Initializes a new instance of the AppointmentItem class.

Methods

 | Name | Description
Public method | AddChildNode | Add a child node to this framework element. (Inherited from FrameworkElement.)
Public method | AnySibling(String) | Return any sibling of this control of the specified type. This method searches the previous siblings first, then the next sibilings. (Inherited from FrameworkElement.)
Public method | AnySibling<(Of <<'(T>)>>)()()()() | Return any sibling of this control of the specified type. (Inherited from FrameworkElement.)
Public method | As<(Of <<'(T>)>>) | Return this framework element as a strongly-typed control. (Inherited from FrameworkElement.)
Public method | AssignReference | Assign the automation reference to this element. (Inherited from FrameworkElement.)
Public method | Capture | Capture the image of this element. (Inherited from FrameworkElement.)
Public method | CastAs<(Of <<'(T>)>>) | Returns this framework element as a strongly-typed control without enforcing tag name to match the type. This functions gives you free casting abilities between types. (Inherited from FrameworkElement.)
Public method | Delete | Simulate user clicking on the appointment delete button.
Public method | Deserialize | Deserialize this AutomationObject to a jsonString TODO: Should this be a static method? (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | DragToTimeSlot(Int32) | Drag the appointment item to the time slot with the given index.
Public method | DragToTimeSlot(FrameworkElement) | Drag the appointment item to the given time slot element.
Public method | DragToTimeSlotDay | Drag the appointment item to the MonthView time slot with the given index and occurrence.
Public method | EndsWithDaySlot(Int32) | Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.
Public method | EndsWithDaySlot(Int32, Int32) | Get whether the appointment ends with the time slot and starts with a previous slot. Supposed to be used in MonthView only.
Public method | EndsWithSlotIndex | Get whether the appointment item ends in the time slot with given index.
Public method | EndsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
Public method | EnsureClickable | Performs best-effort operations to ensure that this element is user-visible and avialable for simulated user actions. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether this FrameworkElement is equal to another, by comparing their AutomationReferences (Inherited from FrameworkElement.)
Public method | FallsInDaySlot(Int32) | Get whether the appointment rectangle completely resides within the time slot with given day.
Public method | FallsInDaySlot(Int32, Int32) | Get whether the appointment rectangle completely resides within the given time slot. Supposed to be used in MonthView only.
Public method | FallsInSlotIndex | Get whether the appointment rectangle completely resides within the time slot with given index.
Public method | FallsInSlotRectangle | Checks whether the appointment item falls within the given time slot's rectangle.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FromRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | GetAttachedProperty<(Of <<'(T>)>>) | Get value of attached property. (Inherited from FrameworkElement.)
Public method | GetAutomationProperty | (Inherited from FrameworkElement.)
Public method | GetChildren | Get the children of this framework element. (Inherited from FrameworkElement.)
Public method | GetChildTagIndex | Given a child FrameworkElement of this element, return this child's tag index relative to this element. If the child has the same tag name as this element, it will not be counted. (Inherited from FrameworkElement.)
Public method | GetHashCode | Calculates and returns the hashcode for this element. (Inherited from FrameworkElement.)
Public method | GetHostParent | Not implemented for Silverlight elements. Returns null. (Inherited from FrameworkElement.)
Public method | GetIdentifier | Gets whether this framework element has an automationid set on it or name. If it does, it will return which one was found and its value. If both are found, AutomationId will be returned first. (Inherited from FrameworkElement.)
Public method | GetIntRectangle | Gets the bounding rectangle of this element within the Silverlight app with integral coordinates (Inherited from FrameworkElement.)
Public method | GetNextSibling | Get the next sibling of this FrameworkElement. (Inherited from FrameworkElement.)
Public method | GetParent | Get the Parent of this element. (Inherited from FrameworkElement.)
Public method | GetPrevSibling | Get the previous sibling. (Inherited from FrameworkElement.)
Public method | GetProperties | Reads and returns the specified property from this element. (Inherited from FrameworkElement.)
Public method | GetProperty(AutomationProperty) | Get a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty(AutomationProperty, Object) | Gets a property on this automation object, or returns a default value if the property cannot be retrieved (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | GetProperty<(Of <<'(T>)>>)(String) | Gets the property value by given name. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | GetPropertyTypeSafe | (Inherited from FrameworkElement.)
Public method | GetRealType | (Inherited from ListBoxItem.)
Public method | GetRectangle()()()() | Get the bounding rectangle of this element within this Silverlight App. (Inherited from FrameworkElement.)
Public method | GetRectangle(FrameworkElement) | Get the bounding rectangle of this element relative to another element (Inherited from FrameworkElement.)
Public method | GetScreenRectangle | Return the actual coordinates of this element in absolute screen coordinates taking into account the location of the overall plug-in on the page. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUniqueHashCode | Calculates and returns the hash code for this element. (Inherited from FrameworkElement.)
Public method | Highlight()()()() | Highlight this element. (Inherited from FrameworkElement.)
Public method | Highlight(Boolean) | Highlight this element (Inherited from FrameworkElement.)
Public method | InitializeMappings | Initialize the Mappings collection. This method is called when the Mappings collection is accessed for the first time. It is then cached (Inherited from FrameworkElement.)
Public method | Invoke | Obsolete. Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(String, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | InvokeMethod(AutomationMethod, array<Object>[]()[][]) | Invokes a method on the AutomationObject's client-side peer (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | IsChild | Checks if element passed in is a child of this framework element. (Inherited from FrameworkElement.)
Public method | IsHitTest()()()() | Determines whether the element can be clicked/selected (Inherited from FrameworkElement.)
Public method | IsHitTest(Boolean) | Determines whether [is hit test] [the specified allow partial visibiltiy]. (Inherited from FrameworkElement.)
Public method | IsHitTest(FrameworkElement, Boolean) | Determines whether [is hit test] [the specified relative parent]. (Inherited from FrameworkElement.)
Public method | KeyPress | Simulate user key press specific to this element. (Inherited from FrameworkElement.)
Public method | Match | Match this FrameworkElement against a specific find expression. (Inherited from FrameworkElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextSibling(String) | Return the next sibling of this control of type. (Inherited from FrameworkElement.)
Public method | NextSibling<(Of <<'(T>)>>)()()()() | The next sibling control of desired type. (Inherited from FrameworkElement.)
Public method | Parent()()()() | Get the parent framework element (Inherited from FrameworkElement.)
Public method | Parent(String) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | Parent(String, Boolean) | Get the parent control that matched the control type. (Inherited from FrameworkElement.)
Public method | PreviousSibling(String) | The previous sibling control of desired type. (Inherited from FrameworkElement.)
Public method | PreviousSibling<(Of <<'(T>)>>)()()()() | The previous sibling control of specified type. (Inherited from FrameworkElement.)
Public method | Refresh | Refresh this FrameworkElement within the VisualTree. (Inherited from FrameworkElement.)
Public method | ResizeFromEnd | Resizes the appointment item from the end with the slots/steps as given in the argument.
Public method | ResizeFromStart | Resizes the appointment item from the start with the slots/steps as given in the argument.
Public method | ScrollToVisible()()()() | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | ScrollToVisible(ScrollToVisibleType) | Scrolls the web page so that this element is visible in the browser window (Inherited from FrameworkElement.)
Public method | Select | Selects the appointment.
Public method | Serialize | Serialize this automation object to a Json String (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetAttachedProperty<(Of <<'(T>)>>) | Set value of attached property. (Inherited from FrameworkElement.)
Public method | SetClosingTag | Ignore for the base FrameworkElement. May be overriden in a derived class to provide additional functionality. (Inherited from FrameworkElement.)
Public method | SetDepth | Set the depth of this framework element. (Inherited from FrameworkElement.)
Public method | SetFindInfo | (Inherited from FrameworkElement.)
Public method | SetFocus | Sets keyboard focus to this element (Inherited from FrameworkElement.)
Public method | SetParent | Set the parent object of this framework element. (Inherited from FrameworkElement.)
Public method | SetProperty(String, Object) | Sets the property value. Will be useful for common translators supporting different technologies (SL/Wpf). (Inherited from FrameworkElement.)
Public method | SetProperty(AutomationProperty, Object) | Set a property on this automation object. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public method | SetProxy | (Inherited from FrameworkElement.)
Public method | SetUid | (Inherited from FrameworkElement.)
Public method | SetXamlTag | Set the Xaml tag name. (Inherited from FrameworkElement.)
Public method | StartsWithDaySlot(Int32) | Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.
Public method | StartsWithDaySlot(Int32, Int32) | Get whether the appointment starts with the time slot and continues on the next slot. Supposed to be used in MonthView only.
Public method | StartsWithSlotIndex | Get whether the appointment item starts in the time slot with given index.
Public method | StartsWithSlotRectangle | Get whether the appointment item starts within the rectangle of the given time slot.
Public method | ToRealObject | Used internally to translate object across application boundaries (Inherited from FrameworkElement.)
Public method | ToString | Gets the string representation of this FrameworkElement object. (Inherited from FrameworkElement.)
Public method | ToXml | Gets an Xml formatted string that represents this element and all its children This Xml represents the VisualTree. (Inherited from FrameworkElement.)
Public method | ValidateMouseLocationIfNeeded | Validate that the current location of the mouse is inside the browser window. (Inherited from FrameworkElement.)
Protected method | ValidateType | Validate a control type with the control tag name. (Inherited from FrameworkElement.)

Properties

 | Name | Description
Public property | AbsoluteSiblingTagIndex | Get the sibling tag index of this FrameworkElement. (Inherited from FrameworkElement.)
Public property | AbsoluteTagIndex | Get the absolute index of this Xaml tag in the Visual Tree. (Inherited from FrameworkElement.)
Public property | ActualHeight | Gets the value of the ActualHeight of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the value of the ActualWidth of this element. (Inherited from FrameworkElement.)
Public property | Application | Get the Application object that owns this element. (Inherited from FrameworkElement.)
Public property | AutomationId | Gets the AutomationId set on this element if any. (Inherited from FrameworkElement.)
Public property | Background | (Inherited from Control.)
Public property | BorderBrush | (Inherited from Control.)
Public property | BorderThickness | (Inherited from Control.)
Public property | Children | Gets the visual children of this element. (Inherited from FrameworkElement.)
Public property | Clip | Gets / Sets the value of the Clip of this element. (Inherited from FrameworkElement.)
Public property | ComputedVisibility | (Inherited from FrameworkElement.)
Public property | Content | (Inherited from ContentControl.)
Public property | DeleteButton | Get the delete button of this appointment item.
Public property | Depth | Get the depth of this element in the Visual Tree. (Inherited from FrameworkElement.)
Public property | DesiredSize | Gets the value of the DesiredSize of this element. (Inherited from FrameworkElement.)
Public property | EnableValidateMouseLocation | Enables or disables the validation of mouse click locations before performing mouse actions (Inherited from FrameworkElement.)
Public property | EndTimeSlot | Get the TimeSlotItem this AppointmentItem ends (and doesn't start) with. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns 'null' for the appointments falling in only one time slot, see the TimeSlotOwner property.
Public property | Find | Get the Find object used to search the visual children of this element. (Inherited from FrameworkElement.)
Public property | FontFamily | (Inherited from Control.)
Public property | FontSize | (Inherited from Control.)
Public property | FontStretch | (Inherited from Control.)
Public property | FontStyle | (Inherited from Control.)
Public property | FontWeight | (Inherited from Control.)
Public property | Foreground | (Inherited from Control.)
Public property | Height | Gets / Sets the value of the Height of this element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets / Sets the value of the HorizontalAlignment of this element. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | (Inherited from Control.)
Public property | Host | Returns the AutomationHost for this object. (Inherited from FrameworkElement.)
Public property | IsEnabled | (Inherited from Control.)
Public property | IsHitTestVisible | Gets / Sets the value of the IsHitTestVisible of this element. (Inherited from FrameworkElement.)
Public property | IsSelected | (Inherited from ListBoxItem.)
Public property | IsTabStop | (Inherited from Control.)
Public property | IsTestRegion | Gets whether or not this element is contained in a test region. (Inherited from FrameworkElement.)
Public property | IsVisible | (Inherited from FrameworkElement.)
Public property | Mappings | Gets a mappings collection that stores customizable control specific mapping knowledge that can be later customized. (Inherited from FrameworkElement.)
Public property | Margin | Gets / Sets the value of the Margin of this element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets / Sets the value of the MaxHeight of this element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets / Sets the value of the MaxWidth of this element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets / Sets the value of the MinHeight of this element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets /Sets the value of the MinWidth of this element. (Inherited from FrameworkElement.)
Public property | Name | Gets the value of the Name of this element. (Inherited from FrameworkElement.)
Public property | Opacity | Gets / Sets the value of the Opacity of this element. (Inherited from FrameworkElement.)
Public property | OpacityMask | Gets / Sets the value of the OpacityMask of this element. (Inherited from FrameworkElement.)
Public property | Padding | (Inherited from Control.)
Public property | ParsedElement | Get the parsed element under this object. (Inherited from FrameworkElement.)
Public property | PropertyBag | The automation object property bag. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RecurrentMaskVisibility | Get the recurrent mask visibility value.
Public property | Reference | Get or set the object reference. (Inherited from AutomationObject<(Of <(<'T>)>)>.)
Public property | RenderSize | Gets the value of the RenderSize of this element. (Inherited from FrameworkElement.)
Public property | RenderTransform | Gets / Sets the value of the RenderTransform of this element. (Inherited from FrameworkElement.)
Public property | RenderTransformOrigin | Gets / Sets the value of the RenderTransformOrigin of this element. (Inherited from FrameworkElement.)
Public property | StartTimeSlot | Get the TimeSlotItem this AppointmentItem starts (and doesn't end) with. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns 'null' for the appointments falling in only one time slot, see the TimeSlotOwner property.
Public property | Subject | Get the appointment subject.
Public property | TabIndex | (Inherited from Control.)
Public property | TabNavigation | (Inherited from Control.)
Public property | TagNameIndex | Gets the tag name index of the xaml tag name in the visual tree. (Inherited from FrameworkElement.)
Public property | TechnologyType | Get the technology type of this element. (Inherited from FrameworkElement.)
Public property | Text | Gets the element text, the first text block text by default. (Inherited from FrameworkElement.)
Public property | TextBlockContent | Gets the text from all the inner TextBlock elements. (Inherited from FrameworkElement.)
Public property | TextLiteralContent | Gets the literal text content of this framework element if any. (Inherited from FrameworkElement.)
Public property | TimeSlotLength | Get the length of the appointment item in time slots.
Public property | TimeSlotOwner | Get the TimeSlotItem this AppointmentItem falls (comepletely) in. Note, this property iterates through all the TimeSlots in the AppointmentsControl so it's a bit slow. Returns null for the appointments falling in two or more time slots, see the StartTimeSlot and EndTimeSlot properties.
Public property | ToolTipText | The text of the tooltip specified for this element (Inherited from FrameworkElement.)
Public property | Uid | (Inherited from FrameworkElement.)
Public property | UseLayoutRounding | Gets / Sets the value of the UseLayoutRounding of this element. (Inherited from SilverlightTestElement.)
Public property | User | Gets the UI interaction object that allows you to interact with this framework element directly using real mouse and keyboard interactions (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets / Sets the value of the VerticalAlignment of this element. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | (Inherited from Control.)
Public property | Visibility | Gets / Sets the value of the Visibility of this element. (Inherited from FrameworkElement.)
Public property | Wait | Gets a VisualWait object to be used on waiting for Visual elemnets in the VisualTree. (Inherited from FrameworkElement.)
Public property | Width | Gets / Sets the value of the Width of this element. (Inherited from FrameworkElement.)
Public property | XamlTag | Get the xaml tag name of this FrameworkElement. This is used for hierarchy matching and traversal. (Inherited from FrameworkElement.)
Public property | XamlTagBase | Gets the lowest control type that the framework recognizes (Inherited from FrameworkElement.)

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace


AppointmentItem Constructor

[image]

Telerik Corp. - Testing Framework 2012.2 Automation Infrastructure
AppointmentItem Constructor
AppointmentItem Class See Also Send Feedback
Initializes a new instance of the AppointmentItem class.

Namespace: Telerik.WebAii.Controls.Xaml
Assembly: Telerik.WebAii.Controls.Xaml (in Telerik.WebAii.Controls.Xaml.dll) Version: 2012.1.719.0 (2012.1.719.0)

Syntax

C#
public AppointmentItem()
Visual Basic
Public Sub New
Visual C++
public:
AppointmentItem()

See Also

AppointmentItem Class
Telerik.WebAii.Controls.Xaml Namespace